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Chapter 1
 

Program Overview

Home Designer Pro is specifically designed for the residential and light commercial design professional. It allows you to 
easily and  efficiently produce 3D models and construction documents for your projects. We thank you for choosing Home 
Designer and wish you the best in your design work.

TOPICS
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Menus, Toolbars, and Hotkeys 17
Dialogs 19
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Home Designer Trial Software 31

9



Home Designer Pro 2025 Reference Manual - Dashboard

 

Dashboard
When Home Designer is launched, the Dashboard window displays, allowing you to choose how you want to begin 
working in the program or access useful resources. The Dashboard can also be opened at any time by selecting File> 

Dashboard.

You can control whether the Dashboard automatically opens and closes in the Preferences dialog. See General Panel on 
page 69.   

 
New/Open File

Select a File command to open a .plan or .layout file.

 l Click New Plan  or New Layout  to open a new, blank file. See Creating a New Plan or Layout on page 36.         

 l Choose Open Plan  or Open Layout  to work on an existing or layout file.               See Opening and Importing Files 

on page 42.

 
Recent Files

The full pathnames of the most recently opened files are listed here. Click on a name to open the file. You set the number of 
files in this list in the Preferences dialog. See General Panel on page 69.
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Move your mouse pointer over a name to see the file’s full 
pathname. 

 
Getting Started & Resources

A selection of useful online Getting Started options and Resources are available here. Click on an option to launch your 
default internet browser to HomeDesignerSoftware.com.   

 l Click Getting Started to visit the Getting Started page on our website with links to a variety of resources to help 
you begin using the program.

 l Click Training Videos to access a searchable collection of videos focused on specific topics.   

 l Click Download Catalogs to visit our 3D Library of downloadable bonus and manufacturer library catalogs. See 
Library Content on page 705.         

 
Announcements

When an internet connection is available, the Announcements section displays updated messages and news from Chief 
Architect. 

 
My Account

Click My Account to launch your default internet browser to the My Account page on our website. If you are not currently 
logged in, you will instead go to the Login page.

 
Build & Product Key

Your software version’s Build number and the first five characters of your Product Key display here for reference.

 

The Home Designer Pro Environment
Home Designer is designed to be intuitive and efficient.
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3D DRAFTING

In Home Designer, the drawing area is laid out on a Cartesian grid: a three dimensional coordinate system described using 
the X, Y, and Z axes. A Coordinate System Indicator displays at the bottom left corner of most views, and the current 
position of your mouse pointer displays in the Status Bar at the bottom of the program window. See Coordinate System 
Indicators on page 104.

Architectural objects take up space in all three dimensions and their height, width and depth can be specified in U.S. or 
metric units. In addition, the location of objects can be precisely defined using coordinates, again specified in U.S. or metric 
units. See Moving Objects Using Dimensions on page 341.

CAD objects such as lines and arcs take up space in two dimensions in the current view. Their dimensions can also be 
specified in U.S. or metric units and their locations precisely defined using coordinates.         

Objects can be rotated relative to the Cartesian grid system, as well. When the program presents the option to rotate to an 
Absolute Angle, this angle will be measured relative to an imaginary horizontal line drawn in floor plan view from the 
origin in the positive X direction.

EASY ACCESS TO TOOLS

You can access Home Designer’s features in various ways using the mouse and keyboard. 

 l Convenient toolbar buttons allow fast access to frequently-used tools and let you customize the interface.             
 l Menus provide access to most tools and settings.             
 l Keyboard shortcuts are available for most tools.             
 l Contextual menus display with a right-click of the mouse.             
 l The Status Bar on page 24 at the bottom of the screen provides tool descriptions and other information about the 

current task.             

OBJECT-BASED DESIGN

Home Designer’s parametric, object-based design technology means you place and edit objects, rather than work with the 
many individual lines or surfaces used to represent them.          

You can quickly select and edit the location, size, shape, style and other properties of objects as well as change the materials 
applied to their surfaces.          

Use Home Designer’s editing capabilities to make the objects you place in a plan match the objects they represent in real 
life. For example, you can set up your windows and doors to match those available from your supplier.          

INTERFACE TOGGLES

A number of useful drawing and editing behaviors, as well as the display of important elements in the interface, can be 
easily enabled and disabled using the menus and toolbars.

 l Object Snaps, Angle Snaps, and Grid Snaps can be toggled on or off as needed. Individual Object Snaps and Extension 
Snaps can be toggled as well. See Snap Behaviors on page 113.             

 l Display Elements like Print Preview, Show Line Weights, and the Reference Display can be turned on when needed 
and then toggled off.             

 l Special Edit Behaviors can be enabled for particular tasks, then replaced by the Default Behavior. See Defaults, 
Preferences, and Edit Behaviors on page 138.             
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When a setting is turned on, or a tool is selected, its  toolbar icon will be shaded and a small check is displayed at its lower 
right corner. In Windows its menu icon will appear the same, but in MacOS™ only a large check will be displayed to the 
left of the icon.

Menu in Windows

Menu in MacOS™

Many of these interface elements are global Preferences while others are file-specific default settings. See Default Settings 
vs Preferences on page 57.   

 

Using Input Devices
You can interact with Home Designer using a variety of input devices. 

KEYBOARD

A keyboard is necessary for entering text and size values. See Dialogs on page 19.

Your keyboard can also be used to navigate the dialog panels, as well as navigate the program menus. Many commands can 
also be invoked using keyboard hotkeys. See Menus, Toolbars, and Hotkeys on page 17.

In addition to the keyboard, a mouse or other device that can move a pointer is necessary in order to draw, select, and edit 
objects in your drawings. 

THREE BUTTON MICE

Left Button

The left button is the primary button used in Home Designer. Unless specified otherwise, Home Designer 
documentation refers to the left mouse button.

Many objects, such as doors and cabinets, are created by clicking the left mouse button. Others, such as walls, stairs and 
dimension lines, are created by dragging the pointer from one end of the object to the other.   

Note: If you are left-handed and have re-programmed your mouse, 
reverse the instructions for left and right buttons in this manual. 

Right Button

The right button has several uses:
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 l Right-click to select any object. If, for example, the Straight Exterior Wall  tool is active, the left mouse button 

only allows you to select walls. You can, however, select other types of objects such as cabinets with the right mouse 
button.             

 l Use the right mouse button to temporarily switch to the Alternate edit behavior. See Defaults, Preferences, and Edit 
Behaviors on page 138.              

 l You can also use the right mouse button to open a context sensitive menu with additional editing commands. See 
Contextual Menus on page 18.             

Middle Button

The middle button can be used to pan in most view types or to temporarily use the Move edit behavior. To close a 
tabbed view window, click on its tab using the middle mouse button. You can also program it to work as a double-
click.

If your mouse does not have a middle mouse button, in the Mac version of Home Designer you can use the left button and 
the Command key to achieve the same results.

Mouse Wheel

The mouse wheel can be used to zoom in and out in most view types. See Zoom Tools on page 108.

The Back, or X1, button on a 5-button mouse can be used to temporarily enable the Concentric edit behavior. See the 
documentation for your mouse.    

The Forward, or X2, button on a 5-button mouse can be used to temporarily enable the Resize edit behavior. See the 
documentation for your mouse.    

             3D MICE

3Dconnexion®'s 3D mice can be used to navigate in Home Designer. For information about navigating in camera views and 
overviews, see 3Dconnexion® 3D Mice on page 786.

TRACKPADS

In addition to the standard trackpad gestures on your system, in Home Designer you can pinch to zoom.

In macOS™, you can Option + click to pan. Panning with a trackpad is not supported in the Windows version of the 
software, however. 

TOUCH SCREENS

Standard one-finger touch screen gestures are supported in both the Windows and Mac versions of the software with one 
exception: double-tapping is not supported. In the Windows version, touching with a second finger to cancel an action is 
also supported, as are two-finger pan and two-finger pinch to zoom. 

You can set the Pinch Zoom Sensitivity for both trackpads and 
touch screens in the Preferences dialog. See General Panel on 

page 69.
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GAMEPADS

In the Windows version of Home Designer, gamepads can be used to navigate in camera views, overviews, as well as 
elevation views. See Gamepads on page 787.

CROSSHAIRS

Crosshairs help you position the pointer relative to objects in a view while drawing and editing. They can be set to 
display in Plan and Cross Section/Elevation views, and in Perspective and Orthographic camera views. Select View> 

Crosshairs to toggle crosshairs on or off in the current view type.

You can customize the Crosshairs’ appearance    and control their display in different view types in the Preferences dialog. 
See Edit Panel on page 79.

POINTER ICONS

The appearance of the pointer or cursor in Home Designer will vary, depending on which tool is active. For example, when 
the Select Objects  tool is active, it will look like a white arrow, and when a Cabinet Tool  is active, it will look like 

a base cabinet with a small cross.

In addition, one or more additional icons may follow the pointer if a recommended setting is not in use or if a problematic 
condition exists in the file:     

Icon Reason

Angle Snaps has been disabled.
See Angle Snaps on page 115.

The Alternate Edit Behavior has been selected.
See Alternate on page 139.

The Resize Edit Behavior has been selected.
See Resize on page 139.

The Concentric Edit Behavior has been selected.
See Concentric on page 140.

The Fillet Edit Behavior has been selected.
See Fillet on page 141.

Connect CAD Segments has been disabled.
See Connect CAD Segments on page 142.

The Rotate/Resize About Current Point Edit Behavior has been selected.
See Rotate/Resize About Current Point on page 142

Auto Rebuild Terrain has been disabled.
See Auto Rebuild Terrain on page 893

Rebuild Walls, Floor and Ceilings has been disabled.
See Rebuilding Walls, Floors and Ceilings on page 522

A bad wall connection has been detected.
See Fix Wall Connections on page 245
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Icon Reason

An irregular wall angle has been detected.
See Wall Angles on page 242

A reversed wall has been detected.
See Reverse Layers on page 252

You can turn off the display of these informative pointer icons in the Preferences dialog if you wish. See Behaviors Panel 
on page 81.

 

View and Side Windows
Home Designer Pro’s main program window has a number of important features that let you interact with the program, such 
as toolbars and menus. It also features two different kinds of windows: view windows and side windows.         

VIEW WINDOWS

View windows are sometimes referred to as “the drawing area” because most of them are windows in which you can draw 
or place architectural and/or CAD objects. There are a number of different types of view windows in Home Designer:

 l Plan views
 l Camera views and overviews
 l Cross section/elevation views
 l Materials Lists         
 l Layout         

View windows can be navigated by panning and zooming. You can also enable scrollbars on their right side and bottom. 
Select View> Scrollbars  to toggle their display. See View Tools on page 107. 

Although only one view window can be active at any given time, there is no limit to the number of view windows that can 
be open. View windows can be tiled or tabbed, and you can navigate between them in a number of different ways. See 
Window and View Tools on page 102.

You can also tear a view window out of the main program window. This creates a second, separate program window 
complete with toolbars and menus.  Individual view windows can be torn out and transferred between program windows. 

SIDE WINDOWS

Side windows provide access to a variety of tools and content that helps you add detail your drawings.   

Side windows are so-named because they are typically docked to either the left or right side of the program window - 
although, they can also be docked to the top or bottom, or undocked entirely.  There are several different  side windows in 
Home Designer:         

 l Child Tool Palette on page 91
 l The Library Browser on page 692
 l Walkthrough Previews on page 869
 l Action History on page 195
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Each of these side windows can be opened via the View menu or by clicking the toolbar button associated with it. Similarly, 
each can be closed by clicking the Close button in its title bar or tab, via the View menu, or by clicking its toolbar button. 
See View Tools on page 107.         

Side windows can be resized by clicking and dragging an undocked edge. To undock a side window, either drag its title bar 
out into the drawing area or click the Undock button on its title bar. To dock a side window, drag its title bar to any side of 
the program window. You can also double-click on its title bar to return it to its last docked location.         

Two or more side windows can be docked together to form a shared side window, and can be tiled and/or tabbed within that 
shared window. To create a shared side window, begin by docking a side window to a side of the main program window, 
then:         

 l To create tabbed side windows, drag a second side window over the first. When the docked window becomes 
highlighted, release the mouse button.         

 l To create tiled side windows, drag a second side window over the first. When the docked window becomes 
highlighted, slowly drag the mouse towards one of its sides. When a highlighted space is created along that side, 
release the mouse button.         

To prevent a side window from docking while you are moving it, hold down the Ctrl/⌘  key while dragging it. You can also 
choose to disable Side Window Drag Docking in the Preferences dialog, and you can enable or disable Top/Bottom 
Docking for each side window, as well. See Appearance Panel on page 63.         

Side windows can also be set to their initial states in the Preferences dialog. See Reset Options Panel on page 87.         

 

Menus, Toolbars, and Hotkeys
Home Designer's drawing, editing, and view tools can be accessed via menus, toolbar buttons, and keyboard hotkeys.

PROGRAM MENUS

Home Designer's program menus are located below the title bar in the program window and can be used to access nearly all 
tools in the program. Click on a menu name to expand it, then click on a menu item to either activate that tool or access the 
item’s submenu. Items with a submenu have an arrow to the right of the name.

In the Home Designer documentation, menu paths are written in this format: Tools> Floor/Reference Display> Up One 
Floor .

The menus can be accessed using the keyboard:

 l Press the Alt key once to enable this functionality - one letter in each menu will become underlined.
 l Press the key associated with one of these underlined letters to expand its menu - one letter in each menu item’s name 

will be underlined. Press the key associated with one of these letters to activate that tool or access the item’s submenu.
 l Press the Esc key to undo your last selection, or click with the mouse to exit out of this functionality. 

Menu items with an icon to their left have a toolbar button associated with them. In addition, many tools can also be 
activated using keyboard hotkeys. If a menu item has a hotkey, it will display to the right of the item’s name. 

Edit menu items with button icons to the left 
and hotkeys to the right
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TOOLBARS AND HOTKEYS

Home Designer installs with a set of toolbars docked to the margins of the program window. Using these toolbar buttons is 
a fast and easy way to access many program features. If a tool is active, a small check mark will display at the lower right of 
its button icon. See Toolbars and Hotkeys on page 90.

The Edit Toolbar is a special toolbar with buttons that can be used to modify a selected object or objects. The buttons on 
this toolbar vary, depending on the type(s) of object selected, the current view, and how you selected the object; when no 
object is selected, the Edit Toolbar is blank. See The Edit Toolbar on page 92.

You can move the toolbars, customize them by adding or removing buttons, or create your own toolbars from scratch. See 
Toolbar Customization Dialog on page 96.

Many tools also have a keyboard hotkey associated with them. See Hotkeys on page 99.

CONTEXTUAL MENUS

Contextual menus are context-sensitive menus that display tools relevant to a selected object or view. To open a contextual 
menu, right-click on an object, in an empty space in a view window, on a line item in the Library Browser, or in a text field 
in a dialog box.

Contextual Menu for Plan Views

The options in an object’s contextual menu are usually the same as those on an object’s Edit Toolbar. See The Edit Toolbar 
on page 92.

Contextual Menu for a selected room

Contextual menus can be enabled or disabled in the Preferences dialog. When contextual menus are disabled, right-clicks 
perform generic object selection, much like when the Select Objects  tool is active. See Appearance Panel on page 63.         

TOOL SEARCH

Tool Search is a Search text field that you can add to your toolbars and use to access any tool or command in the 
program without having to find it in the menus or toolbars. See To add a button to a toolbar on page 93. 

As you type in the Tool Search field, a list will drop down below the text field, showing search results that update as you 
type. Tool Search results are based on tool names and also tool descriptions, making it easier to find a tool when you aren't 
sure of the name. Click on an item in the results to activate that tool or command.

When Child Tool Palette is selected in the Preferences dialog, Tool Search results will include the names of parent tools, 
and if you click on a parent tool its child tools will display in the Tool Palette. When Drop Down toolbars are selected 
instead, parent tools are excluded from the results. See Toolbar Arrangement on page 91.

18



Home Designer Pro 2025 Reference Manual - Dialogs

 

Dialogs
Default and preference settings, object specifications, display settings, and many other functions are accessed through dialog 
boxes. 

Note: Some of the dialog box images in the software documentation have 
been resized smaller than their actual minimum size. 

DIALOG PANELS

Many dialogs have multiple panels, which are listed in a tree list on the left side of the dialog. Click on a panel name in the 
list to make it active. In Windows, panels can also be navigated using the keyboard. Press:         

 l Ctrl/⌘  + Tab or Ctrl/⌘  + F6 to navigate forward;           
 l Ctrl/⌘  + Shift + Tab or Ctrl/⌘  + Shift + F6 to navigate backward.           

When a panel name is actively selected in the list, you can also navigate the tree list using the Up and Down arrow keys.          

By default, dialogs always open to the first panel in the list; if you prefer, you can choose to Open Dialogs to the Last 
Panel Visited. See General Panel on page 69.         

UNITS AND MATH OPERATIONS IN DIALOGS

The units of measurement used in dialogs are determined by your choice of template files. See Creating a New Plan or 
Layout on page 36.    

The number format used in dialogs are set based on your operating system’s defaults. See Region and Language Settings on 
page 58. You can change the number format as well as the angle format in the Dialog Number Style/Angle Style dialog. See 
Dialog Number/Angle Style Dialog on page 88.

Basic addition, subtraction, multiplication, and division can be performed in the text boxes where numeric values are 
entered.         

Note that settings for angle, pitch, or bearing do not support math, nor do those with spin controls or slider bars.         

 l To add, type the + character followed by the amount that you wish to add. Spaces are ignored and including a unit of 
measurement is optional.             

 l To subtract, type the - character followed by the amount you wish to subtract. As with adding, spaces are ignored and 
a unit of measurement is optional.             

 l To multiply, type the * character followed by the amount you wish to multiply by. Spaces are ignored, and only one of 
the values being multiplied can have a unit of measurement.             

 l To divide, type the / character followed by the amount you wish to divide by. To divide, there must be a space before 
the / - if there is not, the input may be treated as a fraction. The denominator, or value typed after the /, cannot have a 
unit of measurement.             

Math expressions support a single operation only: more than one operation character (+, -, *, /) at a time is not allowed.         

Basic math operations can also be used to move objects using dimensions. See Moving Objects Using Dimensions on page 
341. 
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ELEVATION REFERENCES

A variety of different architectural objects can be placed at a particular elevation in the 3D drawing space. That elevation 
can be set relative to a number of different references; the options available may vary depending on the object type:

 l Absolute is measured from Z = 0. See 3D Drafting on page 12.
 l From Floor is measured relative to top of the Floor Structure at the object's location. See Floor and Ceiling Heights 

on page 301.                 
 o If the object is not in a room, it is measured relative to the default Floor Height for its Floor Level. See Multiple 

Floors on page 517.
 o If the object is not in a room and is on the same Floor Level as the Terrain, it is instead measured relative to the 

Terrain.
 l From Finished Floor is measured relative to the object to  the surface of the Floor Finish at the object's location.     

 o If the object is not in a room, it is measured in the same manner as From Floor.
 l From Terrain is measured relative to the object to the surface of the terrain at the object's location. See Terrain on 

page 890.                 
 o If no terrain is present, it is measured relative to the default Floor Height for its Floor Level. 

 l From Ceiling is measured relative to the object to the Ceiling surface at the object's location.                 
 o If the object is not in a room, it is measured relative to the default ceiling height for its Floor Level.

 l From Roof  is measured relative to the object to the Roof surface at the object's location. See Roofs on page 573.                 
 o If the object is not in a room, it is measured relative to the default ceiling height for its Floor Level.

DIALOG SIZE AND POSITION

Dialog boxes can be both moved and resized to suit your needs. By default, the program will remember both the position 
and size that you specify for a dialog and use it the next time you open it. The size of dialog preview panes can also be 
changed, and are remembered as well. You can specify whether the program does this always, per session, or never in the 
Preferences dialog. See General Panel on page 69.         

 l To move a dialog, position your mouse pointer within its title bar and then simply click and drag.             
 l To resize a dialog, position your mouse pointer on any edge or corner and then click and drag outward or inward. If 

you drag an edge, only that edge will move; if you drag a corner, the two adjacent edges will move.             
 l To resize a preview pane, click and drag the vertical grab handle to its left. See Dialog Panel Splitters on page 22, 

below.             

When a dialog is resized, some elements such as list boxes and text fields within it may resize in response.         

All dialogs have a minimum size limitation but no maximum size. If a dialog opens on a monitor with resolution too low to 
display its full extents, it will have vertical and/or horizontal scrollbars.         

You can reset the default sizes and positions of all dialogs in the Preferences dialog. See Reset Options Panel on page 87.         

SPECIFICATION DIALOGS

Each object in Home Designer has a unique specification dialog where you can enter size, style and other information 
specific to the selected object. To access it, select the object and click the Open Object edit button.

You can also double-click on an object with the Select Objects  tool active to open its specification dialog. See Selecting 

Objects on page 142.
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In addition, you can access an active camera view's specification dialog by selecting 3D> Edit Active Camera . The 3D 

View tools also have defaults dialogs where you can specify the initial attributes of camera views. See 3D Views on page 
770.

Most objects also have a defaults dialog that lets you specify the initial values in the specification dialog.  See Default 
Settings on page 57.      

You can open the specification dialog for group-selected objects if they are of the same type, such as base cabinets.           

 l If a particular setting varies among the different objects, its check box will have a solid fill instead of a check mark. 
Click once to clear the box for all selected objects, or click a second time to place a check mark for all selected 
objects.           

 l In some dialogs, if a particular setting varies among the different objects, it will have a “No Change” radio button. 
Leave this button selected, or choose a different option to apply it to all objects in the selection set.           

 l If the setting has a text field or drop-down list, it will say “No Change”. Changes made to such a setting can be 
undone by replacing the value in the text field with the letter N before you click OK. 

 l In a few cases, such as schedule Columns to Include, the “No Change” attribute cannot be modified.        

If you select multiple objects of different types, the Open Object  edit button is usually not available. This button may 

be available if the objects have data in common, but you can only edit the common data.           

DIALOG PREVIEW PANES

Many specification dialogs have a preview pane that shows how changes to settings affect the selected object. This preview 
updates when you click in a different field or press the Tab key.         

If you switch to a panel with settings that affect the selected object’s appearance in a certain view, that view will be shown 
in the preview. For example, if you select the GENERAL panel, a 3D view will be shown; but if you select the FILL STYLE 
panel, floor plan view will be shown. When floor plan view is shown, the primary and all secondary layers associated with 
the object will display. See Primary and Secondary Layers on page 125.           

When you click in the preview pane, your mouse pointer changes to a four-headed arrow and you can rotate around the 
object as well as zoom in and out using the mouse scroll wheel. Some objects, notably walls, doors, and windows, have 
Interior and Exterior labels to indicate which side is visible in the preview. Click the Fill Window  button above the 

preview pane to zoom in or out so that the object fills the extents of the pane, maintaining the current rotation.         

In most dialogs, the Standard, Vector View, and Glass House Rendering Techniques can be applied to the preview. See 
Rendering Techniques on page 832. You can specify whether Standard or Vector View is used by default in the Preferences 
dialog. See Appearance Panel on page 63.

In the Define Material and Select Material dialogs, materials are previewed on a Cube, Sphere, Teapot, or Face shape and 
the Physically Based, Standard, and Vector View Rendering Techniques can be applied to the preview. In addition, either a 
room or a backdrop image can display behind the shape and this background can be blurred if you wish. See Materials on 
page 745.           

Click the Color  button to turn color in the preview off or on. Some objects have additional tools that affect object 

previews. For example, the Cabinet Specification dialogs have a Select Cabinet Face Item  button. Object specific tools 

like this are discussed in the documentation for that object type's specification dialog.         

Note: When multiple objects are selected, their shared specification 
dialog preview will typically only show one of the objects. 
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DIALOG PANEL SPLITTERS

Many dialog panels are divided into up to three sections: a list of panels on the left, an object preview on the right, and a 
central area where settings are located. The vertical splitters separating these sections each have a pale grey, vertical grab 
handle.         

To resize the panel list or preview, as well as the area in the middle, move your mouse pointer over the vertical grab handle: 
when the splitter cursor   can be seen, click and drag to the left or right. In order to move a splitter, the dialog box 
typically needs to be wider than its minimum width. 

The Library Browser side window also has a number of splitters, mostly vertical. See The Library Browser on page 692.

NAVIGATING DIALOGS

Dialog panels and settings can be accessed using the mouse. You can also navigate the settings on a given dialog panel 
using the keyboard. For example:

 l Line items in tree lists can be browsed using the arrow keys. Up and Down navigate the list, while Left and Right 
expand and contract categories.

 l Press the Tab key to shift focus from the tree list to the first setting on the selected panel. 
 l Press the Tab key to shift focus from one setting to the next, or Shift + Tab to go in the reverse direction. 
 l A check box can be checked or cleared by pressing the Spacebar or the + or - keys, respectively, while it is in focus. 
 l Columns of radio buttons can be navigated using the Up and Down arrow keys; rows can be navigated using the Left 

and Right arrows. Select a radio button by pressing the Spacebar while it is in focus.
 l Settings in list boxes can be navigated using the Up and Down arrow keys. When a check box is in focus, it can be 

checked or cleared by pressing the Spacebar. 
 l Drop-down lists can be browsed using the Up and Down arrow keys. When the mouse pointer is directly over the 

drop-down, the mouse scroll wheel can also be used; on a Mac, the list must also be expanded. In Windows only, you 
can press Tab to select the highlighted item in the list and proceed to the next setting. 

 l Settings with spin control arrows   can be adjusted by typing in the text field or using the Up and Down arrow keys. 
When the mouse pointer is directly over the setting, the mouse scroll wheel can also be used.

 l Slider bars   can be adjusted by typing in the text field or using the Left and Right arrow keys. When the 
mouse pointer is directly over the slider bar, the mouse scroll wheel can also be used.

 l Line items in tables can be navigated using the Up, Down, Left, and Right arrow keys.
 l To expand a drop-down list in a table, navigate to it and press the Spacebar.  Then, browse the list using the Up and 

Down arrow keys. Using the mouse, a drop-down list in a table must be clicked twice: first to select, then to expand 
the list.

 l Line items in tables can be group selected using the Ctrl or Shift keys, or by pressing Ctrl/⌘  + A.
 l Press the Enter key to close most dialogs and apply your changes.
 l In the Mac version, Command + . closes dialogs.

Note: Keyboard navigation in dialogs may vary somewhat depending on 
your computer platform. 

In the Mac version of the software, Dictation is supported in dialogs. Select Edit> Start Dictation, then open a dialog. Say 
the word “Numeral” before a number to enter it as a numeric value or immediately follow a number with a unit such as 
“foot” to enter it as a measurement. 
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Edit Handles
A selected object has edit handles that can be used to modify its size, position, and orientation. When you move the pointer 
over an edit handle, information about what it does displays in the Status Bar and the pointer changes to suggest how you 
can use it. 

The edit handles that display depend on the type of object selected, the current view, and how far you are zoomed out. Edit 
handles do not resize as you zoom in or out. If you are zoomed out far enough, some edit handles may be hidden so that 
they do not stack over one another. As you zoom in, these handles become visible again.

How each handle behaves when it is clicked and dragged may depend on which Edit Behavior  is currently active. See 

Defaults, Preferences, and Edit Behaviors on page 138.     

You can cancel any edit handle operation before it is completed 
by pressing the Esc key or by pressing any two mouse buttons at 

the same time. 

MOVE EDIT HANDLE

The square Move handle located at the center of a selected box or polyline-based object, or at the center of a group of 
selected objects, lets you move the selection orthogonal, or at right angles to, its edges. When you position the mouse 

pointer over the Move handle, it displays a four-headed arrow. See Moving Objects on page 167.

Depending on the type of object(s) selected and how far you are zoomed in or out, the position of the Move handle may 
shift so that it remains on-screen. See Zoom Tools on page 108.

RESHAPE/RESIZE EDIT HANDLES

Square edit handles on the edges and corners of a selected object allow you to resize the object by moving its edges. 
A two-headed arrow indicates that the object's edge or corner can be moved in the direction of the arrows. When 

multiple objects are selected, the Resize handle is not available. See Resizing Objects on page 173.

Depending on the type of object selected and how far you are zoomed in or out, the Resize handles may not display on-
screen.

In the case of a selected line-based object, clicking and dragging the Resize edit handle will move the object perpendicular 
to itself. See Editing Line-Based Objects on page 146.

ROTATE EDIT HANDLE

The triangular Rotate handle lets you rotate the selected object or group of objects. The Rotate handle is located 
adjacent to either the object's selected edge or its front if it has one, and when you move your mouse pointer over this 

handle, it displays a circular arrow. See Rotating Objects on page 178.
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A selection's Rotate handle will display regardless of how far you are zoomed out; however, it is possible to zoom in far 
enough that it no longer can be seen.

OTHER EDIT HANDLES

In addition to the Move, Reshape/Resize, and Rotate edit handles, a variety of objects in Home Designer Pro have additional 
edit handles for special purposes. Examples include:

 l Same Wall Type edit handles. See Edit Handles for Walls on page 253.
 l Change Swing/Hinge Side edit handle for doors. See Changing Door Swings on page 387.
 l Add Extension and Extension Line End edit handles for dimension lines. See Editing Dimension Lines on page 336.
 l Resize edit handles for Schedule columns. See Plant Schedules on page 943.

 

The Status Bar
The Status Bar at the bottom of the main program window displays information about the current state of the program. 

This information depends on a variety of conditions such as settings in the Preferences dialog, the type of object selected, 
and the current position of the pointer. Examples of information that may be reported include:

 l The type of object currently selected or the total number of group-selected objects. 
 l Plan file name and view information when a layout box is selected.
 l A description of the edit handle that the pointer is over.
 l A brief description of the toolbar button or menu item that the mouse pointer is positioned over.
 l The name of the active tool, a brief description of that tool, and its hotkey, if it has one.
 l The length and/or angle of an object as it is being drawn.
 l Basic information about a selected library object, folder, or catalog.
 l The current floor level.
 l The layer that the selected object is on and its Drawing Group.
 l The size of the active window in pixels.
 l Whether a camera view is rendering or has finished rendering.
 l The current CAD coordinates of the mouse pointer.

The number format used in the Status Bar is set in the Dimension Defaults dialog, while the angle style can be specified in 
the Number Style/Angle Style dialog. See Format Panel on page 328 and Dialog Number/Angle Style Dialog on page 88.          

 

Message Boxes
As you work in Home Designer, the program will occasionally prompt you to examine your settings, alert you if you 
command it to do something that could potentially cause a problem, or notify you if it encounters a problem that needs your 
attention.
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Situations where such message boxes may display include: 

 l Closing a file or view without saving;
 l Modifying an object that is set to rebuild automatically;
 l A file referenced outside the program, such as an image or texture, is missing;
 l Creating an object in a space too small to contain it.

As with dialog boxes, you can access the options in a message box using the mouse or navigate them using the keyboard.

A few messages have a Send Report button. Click this button to send details regarding the issue that prompted the message 
to Chief Architect via the internet. 

Some message boxes include a “Remember my choice” or a “Do not show this again” check box. Check this box to prevent 
messages of this specific type from displaying in the future. When this box is checked, some options in the message box 
may become inactive.

To allow all message boxes to display again, click the Reset Message Boxes button in the Preferences dialog. See Reset 
Options Panel on page 87. 

NAME PROMPT

The Name Prompt dialog allows you to Rename an entity such as a column in a Plant Schedule. See Plant Schedule 
Specification Dialog on page 945.

For best results, type a short, descriptive, and unique name and then click OK.          

 

Preferences and Default Settings
Preferences and default settings control many aspects of the user interface and tool behavior in Home Designer. You can use 
these settings to customize the program to suit your personal work style.

For more information about defaults and preferences, see Preferences and Default Settings on page 56.

PREFERENCES

Preference settings let you change program behavior to suit your workflow. For example, you can: 

 l Turn certain display elements on or off.
 l Choose background and editing feedback colors.
 l Set the frequency of autosaves, the maximum number of “undos,” and file locking.          
 l Set the default folders for various files.          
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 l Control the editing behaviors of objects.          
 l Specify the active materials Master List file.          
 l Set rendering specifications to maximize efficiency and quality. 

Preference settings are global, affecting all plan and layout files.

DEFAULTS

Most objects in Home Designer derive their initial properties from their respective default dialogs. 

For example, a newly placed Window  gets its initial values from the Window Defaults dialog and a newly placed 

Hinged Door  gets its initial values from the Door Defaults dialog. 

Once an object is placed in a plan, its initial properties can be overridden, but setting up your defaults before you begin 
drawing can save you considerable time as you build a model in the program.

Default settings, unlike Preferences, are file specific.

DYNAMIC DEFAULTS

Most default settings are static: if you change one, any objects of that type in the current file will not be affected. A few 
defaults, however, are dynamic: they are tied to existing objects in the drawing and if you change the default, those objects 
may be affected. See Dynamic Defaults on page 58. 

 

Drawing a Plan
When you draw a plan in Home Designer, you are placing 3D objects that represent building components. Home Designer 
comes with predefined default settings so you can start drawing plans immediately. You should review these default settings 
to be sure they match your drawing and building methods. See Preferences and Default Settings on page 56.         

SET THE DEFAULTS

 1.  Open a new plan using the template of your choice. See Template Plans on page 36.           

 2.  Set the structural defaults:          

 l Floor Defaults. Set the default ceiling height for Floor 1. See Floor Level Defaults Dialogs on page 518.          

 l Foundation Defaults. Set the foundation specifics such as type, footing size, and stem wall height. See 
Foundation Defaults on page 497.          

 l Framing Defaults. Set the floor framing specifications, including type and dimensions. See Framing Defaults 
on page 627.          

 l Default Wall Types. Specify the defaults for walls and railings. See Wall, Railing, and Fencing Defaults on 
page 229.           

 3.  Set material defaults for roof, walls, and rooms (optional). See Material Defaults on page 746.          

 4.  Set style defaults for doors, windows, molding, cabinets and other objects.           
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DRAW THE FLOORS

 1.  While the size of the drawing area in Home Designer is limited only by the resources on your computer, it is best to 
begin your drawing near the origin, 0,0. See 3D Drafting on page 12.         

 2.  Draw the exterior walls on Floor 1. See Creating Walls on page 241.         

 3.  Adjust the perimeter shape and size as required. See Using the Edit Handles on page 251.         

 4.  Place any first floor bearing walls.          

 5.  Define types for special rooms such as garages and decks in the plan. See Room Types on page 289.          

 6.  Place perimeter doors and windows. See Doors on page 378 and Windows on page 408.         

 7.  Build additional floors. See Adding Floors on page 519.         

 8.  Specify the default ceiling height for each floor as soon as it is created. See Floor Level Defaults Dialogs on page 
518.         

 9.  Adjust the perimeter shape of additional floors as needed. See Editing Walls on page 251.         

 10.  Align edited or moved walls with those above or below where appropriate. See Aligning Walls on page 255.         

ENTERING DIMENSIONS

When using U.S. Units, enter distances as inches or feet and inches, in fractional or decimal form. Millimeters are the 
default unit for all metric distances. See Dimensions on page 320.         

 l To enter feet, include the ( ' ) marker or the program assumes inches.         
 l In most cases, the program allows precision to 1/16th of an inch. Fractions with denominators 2, 4, 8 and 16 are 

allowed.
 l The program usually converts decimals to fractions.         
 l You can enter angles as decimal degrees, degrees, minutes, and seconds, quadrant bearings, or azimuth bearings. See 

Dialog Number/Angle Style Dialog on page 88.          

BUILD THE FOUNDATION

 1.  Derive the foundation plan from the first floor. See Building a Foundation on page 501.         

 2.  Adjust the foundation perimeter shape as needed.         

 3.  Place interior foundation walls as needed for the first floor bearing walls.         

 4.  Place any other foundation walls required.         

 5.  Align with Above as needed. See Aligning Walls on page 255.         

ADD STRUCTURE AND DETAILS

 1.  Build non-structural interior walls. Begin on floor one and work up in multiple story structures.          

 2.  Add walls where needed to create features such as chimney chases, plumbing walls, or Open Below areas.         

 3.  Finish the relevant interior structure including interior doors, doorways, cabinets, fixtures, and fireplaces.         
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 4.  Build the roof planes. If you generate the roof automatically, remember to carry the roof directives in the walls from 
the first floor up to the top floor for multiple story structures. See Roofs on page 573.           

 5.  Build the framing. See Framing on page 626.           

 6.  Build the terrain and landscaping. See Terrain on page 890.         

 7.  Create the plot plan. See Plot Plans on page 892.   

CREATE THE LAYOUT

 1.  If one does not exist, create a Layout file with a title block, placing the border, title block, and other text on page 0. 
See Layout on page 970.          

 2.  Send views to the layout. See Sending Views to Layout on page 973.

 3.  Print the layout. See Printing and Plotting on page 984.          

 

Viewing Your Plan
You can see your model in a variety of different 2D and 3D views. You can display more than one view at a time; and in 
any view, you can pan or zoom in or out. See Window and View Tools on page 102. 

Plan view is a 2D view of the model most commonly used for drawing and editing. Each floor displays separately; however, 
you  have extensive control over which objects display at any given time, can easily switch between floors, and can also 
display items on a second floor for reference. See Multiple Floors on page 517.

You can create interior and exterior 3D views of your model from any perspective. As in plan view, you can select and edit 
many objects in 3D views and control which objects are visible. See 3D Views on page 770. 

You can also create Doll House Views that show only the current floor plus any floors beneath it. Ceilings on the current 
floor are omitted so you can see the interior, visualize the relationships between spaces, and plan traffic flow.
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Framing Overviews display framing in 3D, provided that framing has been built. You can customize 3D views to serve 
special purposes such as this.         

The Cross Section and Elevation camera tools create scaled 2D views of a model’s exterior and interior that can be 
dimensioned and annotated. Just as in other views, you can select and edit objects in a Cross Section/Elevation view as well 
as control which objects display.           

LAYOUT FILES

All plan views can be sent to a layout where they can be arranged to produce construction documentation. See 
Sending Views to Layout on page 973.         

All views can also be exported as a graphic image. See To export a picture on page 852.   

 

Getting Help
There are many forms of help available in Home Designer Pro including: Tool Tips, the Status Bar, and the online 
Help menu. See Resources and Support on page 1006.
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All these forms of help assume you have a basic working knowledge of your operating system, including how to use a 
mouse, open, close and save files, copy, paste, and right-click to access contextual menus. Help also assumes you are 
familiar with basic computer terminology.

The vocabulary used in the design and construction trades vary widely by region. Our online Glossary provides definitions 
for the terms we use in our information resources. Visit HomeDesignerSoftware.com.

More information is available on Home Designer’s website, HomeDesignerSoftware.com. 

TOOL TIPS

When you move the pointer over a toolbar button or menu item, a Tool Tip displays, offering a brief description of the tool. 
More information displays in the Status Bar at the bottom of the window. The Status Bar also reports information about the 
currently active tool or the currently selected object. See The Status Bar on page 24.

CONTEXTUAL HELP

Home Designer Pro's Help is a searchable menu that provides information about all of the tools in the program. 
Select Help> Launch Help or press the F1 key to open the program’s Help and explore the table of Contents, 

browse the Index, or Search for keywords.

The Help can be used to provide instant information about toolbar buttons, menu items, and objects in your plan.

 l Position the mouse pointer over a toolbar button or menu item, then press the F1 key to open the Help to a page with 
more information about the tool.

 l When an object is selected, press the F1 key to open the Help to a page with information about that object. If you 
position the mouse pointer over one of the selected object's edit handles and press the F1 key, a page with information 
about that handle will display instead. 

 l Press the Help button in any dialog box to open online Help to a page describing the options in that dialog. 

When the Help is open, it will update automatically to show information about the currently selected object, active tool or 
dialog, or highlighted item. If you would like to turn off this dynamic behavior, click the Prevent Help from Updating 
Dynamically  button at the top of the Help window.

Additional buttons at the top of the Help window allow you to zoom as well as search the current page.

Chief Architect strives to make our documentation as helpful as possible. 
Please send any suggestions to: documentation@chiefarchitect.com.

 

About Home Designer
Select Help> About Home Designer in Windows® or Home Designer> About Home Designer in macOS™ to view 
information about your software license, the program’s version number, and its release date.

Contact information for Chief Architect, Inc. is available on the MORE INFORMATION panel.

 

Product Upgrade Options
Ready to expand your design capabilities in the software? Select Help> Product Upgrade Options to launch your default 
web browser and learn about options for upgrading your software license at www.homedesignersoftware.com.         
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Home Designer Trial Software
All Home Designer program titles have Trial versions available for free download at HomeDesignerSoftware.com.         

The Trial software offers the same functionality as a purchased license with a few limitations:         

 l File Saving         
 l Printing         
 l File Exporting         
 l Recording of Walkthroughs         
 l Printing or Exporting of Materials Lists         
 l Library Browser restrictions         

CONVERTING THE TRIAL VERSION

An installation of any of our Trial programs can be converted into a full working version of the program at any time by 
purchasing a software license. There are several ways to begin this process in the Trial:          

 l Click the Purchase Full Version Now button in any Trial Restriction message box.         
 l Select Help> Purchase Home Designer Pro . 

 l Select File> Dashboard  and then click the Purchase Full Version Now button.

Once you have purchased a license, you can activate it while the Trial software is running.         

To activate the full version

 1.  Select Help> Activate Full Version.         

 2.  In the Product Activation dialog, type or paste the Product Key associated with your software license.         

 3.  Click the Activate Full Version button.         

♥
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Chapter 2
 

File Management

Home Designer Pro reads and edits two main document types: .plan files and .layout files. The complete 3D model of a 
structure, surrounding terrain and any CAD data associated with it are stored in the plan file. Data used to create working 
drawings and the links to various views are stored in the layout file.

All commands related to opening, saving and closing plans are located in the File menu. You can also open plans from the 
Dashboard window. See Dashboard on page 10.

Just as with files created in other software applications, you should back up your plan and layout files externally on a 
regular basis to avoid accidental loss of work.

TOPICS

Compatibility with Other Programs 33
Organizing Your Files 34
Home Designer Pro Data 35
Creating a New Plan or Layout 36
Saving, Exporting, and Backing Up Files 37
Auto Archive 40
Opening and Importing Files 42
Referenced Files 44
Backup Entire Plan or Layout 46
Exiting Home Designer 47
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Compatibility with Other Programs
Plans and layout files produced in the following programs can all be read by Home Designer Pro 2025. 

 l Chief Architect® X1 through X16 (limited editability if enabled)             
 l Chief Architect® 10.0 through 11.3 (read only)             
 l All Better Homes and Gardens Home Designer® products, Interior Designer, and Landscaping and Deck Designer, 

Versions 7 and 8.
 l All Chief Architect Home Designer® products, Interior Designer, and Landscaping and Deck Designer, Versions 9 

through 2024.

Only the .plan and .layout files from prior versions can be opened in Home Designer Pro 2025.               A number of steps are 
recommended when migrating plans created in an earlier program version into Home Designer Pro 2025. Before doing so, 
see Getting Started Checklist on page 1011.

Files that have been opened and saved in Home Designer Pro 2025 cannot be read by any of the program versions listed 
above. To continue to read files in the program in which they were created, be sure to create copies of your files before 
opening them in version 2025. 

Plans and layout files produced in the Windows® version of Home Designer Pro 2025 can be read in the Mac® version, and 
vice versa. 

FILE ASSOCIATION

Although multiple versions of Home Designer can be installed on a computer, the operating system will only associate
 .plan, .layout, .calib, and .calibz files with one of them. If they are not associated with Home Designer Pro 2025, click the 
Associate Files with this Program button in the Preferences dialog. See File Management Panel on page 70. 

OPENING CHIEF ARCHITECT PLANS IN HOME DESIGNER PROGRAMS

Plans created in Chief Architect Versions 10 through X16 and Home Designer Pro Versions 7 through 2025 can be opened 
in the latest Home Designer programs for viewing and annotating, but not for general editing or drawing of architectural 
objects.         

Plans created in build 11.4 or later of Chief Architect X1 or Home Designer Pro 8, or in later program versions, can be set 
to allow limited editability in other Home Designer programs. When this permission is enabled, a Home Designer user can 
use all of their program’s drawing tools and can edit objects in the plan that those tools can create. If an object cannot be 
created in the Home Designer program, however, it will not be editable.         

Please note, too, that if a plan has more floors than the Home Designer program supports, the entire plan can be viewed and 
annotated only.         

To protect some objects from being edited when a file with editing permission is opened in another Home Designer 
program, consider locking their layers. See Locking Layers on page 126.   

Allow Editing in Select Home Designer Products can be enabled or disabled only when the file is opened in Home 
Designer Pro. See General Plan Defaults Dialog on page 60.           
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Organizing Your Files
You should keep your plan              and layout files separate from the support files needed to run Home Designer. To keep files 
organized, you may find it helpful to create a new folder for each project.         

Home Designer files may use imported images, textures and other custom content saved in their own external data files. 
Consider storing copies of all external files in the same folder as the plan              and layout files that use them so that they are 
easily found.              

Here is one way to organize your files:         

 l Create a folder in your Documents directory called “Home Designer Plans” or another name you prefer. See your 
operating system’s Help to learn how to create folders.         

 l Inside this folder, make a new folder for each client or project. Save all the files for that client or project inside this 
folder, including plan and layout files and referenced external files. See Saving, Exporting, and Backing Up Files on 
page 37.         

Bear in mind, though, that path names exceeding 260 characters cannot be opened by Home Designer. As a result, it is a 
good idea to limit the number of embedded folders you use in your file organization method.         

Once you understand the file management of Home Designer, you              should decide on a naming convention that suits your 
needs.          

It is recommended that each layout file be saved in the same 
folder as the plan file(s) associated with it. See Managing Layout 

Links on page 981. 

To specify a default Save As location

 1.  Select Edit> Preferences , then select New Plans from Category list. See New Plans Panel on page 74.           

 2.  Under Open and Save As, click Use this Folder. The Browse button becomes available.          

 3.  Browse to the folder you plan to save your projects in. Click OK.          

THUMBNAIL IMAGES

A thumbnail is a miniature image that helps identify a file in the Open Plan File dialog in the Windows version of the 
software.

If thumbnails are enabled in the Preferences dialog, the program automatically creates one when you first save a new plan or 
layout. You can, however, create a custom thumbnail using any view as well as choose to generate small or large 
thumbnails. See File Management Panel on page 70.

To create a custom thumbnail image

 1.  You must save the file and give it a name before you can save a thumbnail.

 2.  Create the 2D or 3D view that you want to use as a thumbnail for the current file.

 3.  With the desired view active, select File> Save Thumbnail Image .

Thumbnail images are saved in the plan or layout file that they are associated with. 

34



Home Designer Pro 2025 Reference Manual - Home Designer Pro Data

 

Home Designer Pro Data
When Home Designer Pro 2025 is installed, the program automatically creates a folder in the user Documents directory 
called  Home Designer Pro 2025 Data. This folder contains important user-specific information saved in the following 
folders and files and should not be moved, renamed or deleted: 

 l Archives - A folder of automatically archived plan and layout files. See Auto Archive on page 40.
 l Backdrops - A folder of custom backdrop images. See 3D Backdrops on page 785.         
 l Images - A folder of custom images. See Using the Contextual Menu on page 709.         
 l Database Libraries - A folder of user library data. See Library Content on page 705.             
 l Scripts - A folder for custom Ruby scripts associated with Chief Architect plans.
 l Templates - A folder of plan                  and layout template files. See                  Creating a New Plan or Layout on page 36.             
 l Textures - A folder where you can save image files used to create custom material textures. See Creating Materials 

on page 755.             
 l Toolbars - A folder of                  customized toolbar files. See                  Toolbar Customization Dialog on page 96.             
 l mmaster.mat - The Master Materials List file. See The Master List on page 964.             
 l sheetSizes.sheet - A list of user-created Drawing Sheets. See Customize Sheet Sizes Dialog on page 991.             
 l _MigrateBackup - If you migrated legacy settings into Version 2025, additional folders with names appended with _

MigrateBackup may also be present. 

If the Home Designer Pro 2025 Data folder is renamed, moved 
or deleted, the program will automatically replace it using 

default information from the program's installation folder. When this 
occurs, customized user settings and custom user library content will not 
be available.

DATA FOLDER NAME AND LOCATION

The name of the Home Designer Pro 2025 Data folder cannot be changed, but you can specify its location on your system in 
the Preferences dialog. See Folders Panel on page 72.

If you specify a new location for this folder, the program will not migrate any custom user settings that you might have. 
Instead, it will automatically create a new folder at that location containing default information from the Home Designer Pro 
2025 installation folder. If you would like to copy custom settings to the new location, you can do this yourself in an 
operating system window.         

When specifying a location for the Data folder, bear these considerations in mind:         

 l If you move the Home Designer Pro 2025 Data folder on your computer without specifying its location in Preferences, 
the program will automatically replace the folder in its default location using default information from the software's 
installation folder.             

 l The same will result if you specify a location on a network or removable device and that location becomes 
inaccessible. For this reason, it is best to use a location on your local hard drive.              

 l The User Database Libraries in particular may contain a large amount of data. Whatever location you choose to use 
must be located on a hard drive with sufficient space to hold these files.             

Just as with your plan and layout files, it is a good idea to back up your Home Designer Pro 2025 Data folder.           

Because the Home Designer Pro 2025 Data contains custom user data, it is not deleted when the program is uninstalled. See 
Uninstalling Pro.
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Creating a New Plan or Layout
To open the Create New Plan dialog, select File> New Plan.

You can also choose New Plan in the Dashboard window. See Dashboard on page 10.

Create a new layout file by selecting File> New Layout or by sending a view to layout when no layout file is yet 
open or associated with the current plan file. See Creating a Layout File on page 972.             

By default, a new layout file will be assigned the same name of the first plan file sent to it, associating the layout files with 
the plan files used.           

Note: Only one layout file can be open at any given time.

New, blank plans are called Untitled.plan and new, blank layout files, Untitled.layout. Unless these files are named and 
saved, they will be lost when closed. See Saving, Exporting, and Backing Up Files on page 37.          

UNITS OF MEASUREMENT

All plan and layout files save measurements in either U.S. or metric units. New files are created using one or the other, 
depending on the current setting in the Preferences dialog. When the program is first installed, the Windows OS setting for 
units determines what system is used. See New Plans Panel on page 74.          

A plan or layout file’s unit of measurement must be specified before it is created and cannot be changed later.              

While it is recommended that you create new plans using the type of unit that you plan to use, you can display dimensions 
using any type of unit. See Dimension Preferences and Defaults on page 321.          

TEMPLATE PLANS

When you select File> New Plan  in Home Designer, the Create New Plan dialog opens, letting you select a template for 

your new plan. The resulting new plan uses either metric or U.S. units of measurement and predefined default settings for 
objects like walls, doors, windows, and cabinets. See Default Settings on page 57. 

 l Select either U.S. Units or Metric Units of measurement. Once a new plan has been created, its Measurement Units 
cannot be changed. 
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 l Select a style template from the list. If you are uncertain as to the right style for your plan, choose Default, as you 
cannot change the plan style template once a plan has been created.

When you click OK, a new floor plan view window opens, ready for you to begin drawing.

When Home Designer Pro opens a new, blank plan or layout file, the new file is actually a copy of a template using either 
metric or U.S. units of measurement and predefined default settings, wall definitions, and page setup information.

SELECT TEMPLATE DIALOG

When a new, blank plan or layout file is opened in Home Designer Pro, the new file is actually a copy of a template using 
either metric or U.S. units of measurement and predefined default settings, wall definitions, and page setup information. 

Creating a new plan without referencing a template file is not recommended. If you try to create a new plan              or layout using 
a template file that is not available, the Select Template dialog will prompt you to specify a template for the new file you 
are creating. 

 l Select Load Installed Template (Recommended), then select a template file from the drop-down list. 
 l Select Load Custom Template, then click the Browse button and browse to a plan or layout file saved on your 

computer.
 l You can also type or paste the full path name of a file in the text field.

If you encounter this dialog, make sure that the program Data folder is at a location that can be accessed by the program. 
You may also want to reset your template files to the defaults installed with the program. See Home Designer Pro Data on 
page 35 and Reset Options Panel on page 87.         

 

Saving, Exporting, and Backing Up Files
Saving, exporting, and backing up your files are three separate tasks that accomplish different things: 

 l Saving a plan or layout file retains your work so that it can be later opened in Home Designer Pro.         
 l Exporting a file allows you to save certain kinds of data in a format that can be used by a program other than Home 

Designer.
 l Backing up your files involves taking steps to make sure that your valuable data is protected and available when 

needed. 

Whether you are saving, exporting, or backing up your data, it is important that you select a location on your computer for 
the files you create, and also specify a short, meaningful name that you will be able to identify in the future. 
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To save an untitled plan or layout file

 1.  Select File> Save As  to open the Save File dialog.

 2.  Specify a location on your local computer where you would like to save the file. See Organizing Your Files on page 
34.

 3.  In the File name text field, type a name for the file. 

 4.  Home Designer automatically assigns the File of type and file extension .plan to plan files and .layout to layout 
files.

 5.  When both the Save in location and File name are correct, click Save.

Although the program warns you if you try to exit without 
saving, you should get in the habit of saving plan files before 

exiting the program.

SAVING PLAN AND LAYOUT FILES

When you first save a new, untitled file, you must select a location for it on your computer and give it a name. There are 
two options for saving plan and layout files: File> Save  and File> Save As .        

Both Save and Save As can be used to save your plan and layout files; however, they accomplish this in two different ways:

  Save saves the current state of your plan or layout file without changing its name and should normally be used 
for saving your work.

  Save As opens the Save File dialog, allowing you to save the plan or layout file using a different name or 
location on your computer. 

Initially, all Open  and Save As  operations go to your Documents directory. After that, the location last visited is 

remembered and subsequent Open or Save As commands default to the directory last used for that operation. This path is 
saved when the program exits. The next time Home Designer is launched, these defaults are used.

If you prefer, you can instead specify a directory to be used for all Open or Save As operations in the Preferences  

dialog. See New Plans Panel on page 74.          

SAVED VIEWS

All saved camera views are saved with their plan file. See View Windows on page 103.

When saving a layout, the program saves all the links to the various views saved in the layout, and all the CAD objects 
added to the .layout file.

By default, a new layout file is assigned the same name as the first plan file from which a view is sent to it. It is also saved 
in the same directory as the plan file. If no view has been sent to a layout, it remains untitled until you save it.          

SAVE FILE DIALOG

The Save File dialog uses the operating system’s file save dialog format, and is also used when exporting files. The dialog 
name may vary, depending on the type of file being saved or exported.

A similar Select Folder dialog allows you to select a folder to which files can be exported. 
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 Location

Choose a location on your local computer for the file you are saving.

 
 Files

Any existing folders and/or files in the current location display here.

 
 File Name

In the File Name field, type a name for the file. If you select an existing file from the space above, its name will display 
here automatically.

 
 Save as Type

When saving a file, the program will choose the appropriate file type from the Save as type drop-down list. When 
exporting, you may need to choose a specific file type.

SAVING REVISION FILES

Revisions are a common aspect of any design project. There are a number of possible strategies for organizing revision files:

 l Prepending the file name;
 l Appending the file name;
 l Saving revisions in separate folders.

To avoid confusion and potential mistakes, it is recommended that you always give files unique names - including revision 
files. If you choose to organize your revisions by saving them in separate folders, you should also give each file a unique 
name that makes it impossible to confuse it with another file saved in a different folder.

EXPORTING FILES

Home Designer has a number of options for exporting information out of  and importing information into your drawings. 
See Importing and Exporting on page 875. 

Often, file export dialogs are simply versions of the Save File dialog. See Save File Dialog on page 38, above.
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Similarly, file import dialogs are often similar to the Open File dialog. See Importing Files on page 43. 

BACKUP ENTIRE PLAN

File> Save As  is a simple way to transfer a plan or layout to a different location on your computer. Bear in mind, 

though, that plan and layout files often reference external data files such as imported textures, images, and backdrops. These 
external files are not affected when Save As is used.          

If you transfer a plan file from one computer to another, the program will warn you of missing files if the external data files 
used by the plan cannot be found when you open it. 

Layouts are also dynamically linked to plan files. When transferring layout files to another computer, be aware that the plan 
files are also external file references and are not actually contained in the layout.         

When transferring plans              or layouts to another computer that does not have these external files, use the Backup Entire Plan 
 tool. See Backup Entire Plan or Layout on page 46.         

BACKING UP YOUR FILES

It is always a good idea to create backup copies of all your important files on your computer. 

It is strongly recommended, however, that you never save directly:

 l Across a network, such as onto a server;
 l Onto removable media such as a USB thumb drive.
 l Across the Internet.

Instead, copy your files to such locations only after you have saved them on your computer’s hard drive and exited the 
program.

Similarly, you should never open files saved in these locations. Copy the files to the local hard drive, and then open them. 
See Opening and Importing Files on page 42.         

Archive folders are used by Home Designer to manage prior versions of your files. You should not view these files as a 
substitute for your own backup routine, and should never save a file in an archive folder. See Auto Archive on page 40.   

When backing up your Home Designer files, consider backing up not only your .plan and .layout files, but your custom 
user data, as well - including library content, toolbar configurations, and textures. This custom data is all located in the 
Home Designer Pro Data folder, so it can be easily backed up. See Home Designer Pro Data on page 35.

You can, if you wish, create a folder inside the Data folder for your .plan and .layout files, as well. See Organizing Your 
Files on page 34.         

 

Auto Archive
The first time a plan or layout is saved, an Archive folder is automatically created in the Home Designer Pro 2025 Data 
folder. The Archive folder contains Auto Save and Archive files. 

The program will also create Auto Save files for unsaved plans and layouts provided that they have been open for longer 
than the Auto Save frequency setting in the Preferences dialog. See Auto Save Files on page 41, below. 
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Auto Save and Archive files should not be viewed as a substitute 
for regularly saving your work by selecting File> Save or 

pressing Ctrl/⌘  + S, nor should they be considered an alternative to your 
own file backup routine.

ARCHIVE FILES

Every time a drawing is saved, Archive files that keep a historical archive of your plan are automatically created or updated. 

JonesResidence.plan

JonesResidence_2024_1_15.plan

JonesResidence_2024_1_15_13.plan

If you do not save your work regularly, your archive files will 
not be updated.         

Plan, layout and related files from previous versions of the program are automatically moved to the archive folder when the 
plan is opened and saved in Home Designer Pro 2025.         

Archive files are meant to be for emergency use only. If you must access an archive file, open it as you would any other 
file. As soon as the file is open, use Save As  to save this file to another location.

LEGACY ARCHIVE FILES

Plan              and layout files saved in the current program version are not backwards-compatible: that is, they cannot be opened in 
older versions of the software.         

If you open a Home Designer plan or layout file from a previous program version and immediately Save it (not Save As), 
the Auto Archive utility will create an additional archive file using the original program version format. This archive file is 
a copy of the original and can still be opened in the original program version.         

MANAGE ARCHIVES

Home Designer offers two convenient ways to access Archive folders.           

 l Select File> Manage Auto Archives  to open the current plan’s Archive folder.          

 l Click Yes in the Archived Files dialog when the program warns you that the number of archive files exceeds the Auto 
Archive Files value.          

You can also move or delete archived files using your operating system. See your operating system’s Help for more 
information.        

AUTO SAVE FILES

As you work, Home Designer automatically creates Auto Save files at regular intervals when changes are made to a file but 
not saved by selecting File> Save . 

These Auto Save files are appended _auto_save.plan or _auto_save.layout and are saved in the Archive folder. 
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When you close a file normally, its Auto Save file is retained until the next time the file is opened - at which time the Auto 
Save file is overwritten.

JonesResidence_auto_save.plan

Auto Save file after normal shutdown

You can enable Auto Save and set its frequency in the Preferences dialog. See File Management Panel on page 70.           

Auto save files created as a result of an improper program shutdown are appended _auto_save_bak.plan or _auto_save_
bak.layout.

    JonesResidence_auto_save_bak.plan

Auto Save file after abnormal shutdown

If your computer shuts down accidentally, you can recover some of your work by opening the _auto_save_bak file.

When you reopen a file after a computer shut down or system crash, the program will notify you if an Auto Save file newer 
than the original file is found and give you the option to open that file. 

Even with Auto Save, you should save your work manually on a regular basis using any of the following methods: 

 l Click the Save  button.

 l Select File> Save .

 l Press Ctrl/⌘  + S.

 

Opening and Importing Files
Opening and importing files are often similar tasks, but accomplish two very different things:

 l Opening a file refers to opening it in the program in which it was created. Only plan or layout files can be opened in 
Home Designer Pro. See Compatibility with Other Programs on page 33.         

 l Importing a file brings data that was created in a different program into Home Designer. A number of different file 
types can be imported into Home Designer.

Select File> Open Plan to open an existing .plan file or File> Open Layout to open an existing .layout file              located on 
your computer. Home Designer Pro automatically browses to either the directory last used or to a specific directory, 
depending on your current Preferences settings. See New Plans Panel on page 74.         

Before opening a file located on a removable storage device, 
server, or other computer on a network, copy it to your local 

machine’s hard drive first.

OPEN FILE DIALOG

The Open File dialog uses the operating system’s file open dialog format, and is also used when importing files. The dialog 
name may vary, depending on your operating system and the type of file being opened or imported.         

A similar Select Folder dialog allows you to select an entire folder of files to import.         
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File Path

Choose the location on your local computer for the file you are opening.

 
Folder Contents

Any existing folders and/or files in the current location display here.         

 
File Name

When selecting a file, its name will automatically display in the File Name field. You can also type the file’s name to locate 
a specific file. When importing  some types of files, multiple files may be selected.

 
File Type

When opening or importing a file, the program will usually choose the appropriate file type from the File type drop-down 
list. When importing, you may need to choose a specific file type. 

Plan files open to the floor that was active when the file was last saved and closed; layout files open to the page that was 
active.         

IMPORTING FILES

Home Designer has a number of options for exporting and importing information out of and into your drawings. Often, file 
import dialogs are simply versions of the Open File dialog. See              Importing and Exporting on page 875.          

Similarly, file export dialogs are often similar to the Save File dialog. See Exporting Files on page 39.          

RECENTLY OPENED FILES

A list of recently opened and saved plan and layout files can be accessed by selecting File> Open Recent Files. Select one 
of these files to open it without using the Open File dialog.          

The maximum number of recent files listed in the File menu can be changed in the Preferences  dialog. You can also 

specify that the recent files list display at the bottom of the File menu rather than in a submenu. See File Management Panel 
on page 70.         
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The names of recent files also display in the Dashboard window. Click on the name of a file to open it. See Dashboard on 
page 10.

To clear the Recent Files List, select File> Open Recent Files> Clear Recent Files.

 

Referenced Files
A Home Designer plan or layout file typically includes information from a variety of external files.

MISSING FILES DIALOG

Home Designer plan and layout files can reference a variety of external file types for added detail, including: 

 l Material Textures
 l Images
 l Plant Images
 l 3D Backdrops
 l Picture Files
 l PDF Files

Whenever any view in a plan or any page in a layout is opened, the program checks for referenced files used in that view 
and will notify you if any of those files cannot be found by opening the Missing Files dialog.

If a layout file is missing referenced files on pages that you do not view during the current session, this dialog may also 
open when you print the layout. See Layout on page 970.           

You can also open this dialog at any time by selecting Tools> Checks> Missing Files. When accessed this way, all missing 
files associated with the current file are listed: not just those used in the current view.         

 
File Information

The table lists any Missing Files as well as useful information about each: 

 l Missing File reports the name and file extension of the missing file.    

 l File Usage indicates how the missing file is used in the program.    

 l Object Name states the name of the object in Home Designer that references the file.    
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 l Object Location indicates where in the file the object can be found.    

 l The next column indicates whether a missing texture is In Use in the plan.    

 l File Path states the last known location of the missing file on your computer system.
Click on a line item in the table to select it and resolve it using the options on the right. Multiple line items can be 
selected; however, the selections on the right may be limited. See Shift and Ctrl/⌘  Select on page 146.

 
Options

The buttons on the right offer options for resolving a selected missing file. The names of these buttons will vary somewhat, 
depending on the type of file(s) selected in the list on the left.                 

 l Click the top Replace Object button to replace any instances of an object or material referencing the selected 
missing file with a different object or material from the library. Not available for textures, PDF files or picture files.     

 l Click the Replace File button to open the Browse for Missing File dialog and select a file saved on your system to 
replace the missing one. See Opening and Importing Files on page 42.

 l Click the Delete Object button to remove the object or material referencing the missing file from the plan. Not 
available for backdrops or material textures that are In Use.

 l Click the Clear File Reference button to remove a selected backdrop from the camera or Camera Defaults that it is 
assigned to, or to remove a selected texture from the material it is applied to.        

 l Click the Add Search Directory button to direct the program to a particular folder to search for missing files in. The 
list of Search folders can be reset in the Preferences dialog. See Reset Options Panel on page 87.

You can prevent this dialog from opening automatically by checking Do not display missing files again during this 
session at the bottom of the dialog. This option is not available when the dialog is opened manually.

REFERENCED PLAN FILES DIALOG

In addition to the file types described above, layout files also reference plan files. The Referenced Plan Files dialog 
lists all plan files that the current layout file references and allows you to relink these files. To open this dialog in a 

layout file, select Layout> Referenced Plan Files.

 
Plan Files Present

The names of all plan files with intact links to the current plan or layout are listed here.                 
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If you want, you can select a file and click the Browse button just above the Plan Files Present field and replace the 
selected plan with a different plan saved on your system.

 
Plan Files Not Found

The names of all plan files with disrupted links to the current plan or layout are listed here. Any files listed here have been 
moved, renamed, or deleted and cannot be found by the program. Intervention is required to find these files and reestablish 
their links to the current file. 
Select a missing file and click the Browse button just above the Plan Files Not Found field to open the Browse For 
Missing File dialog, which is a typical Open dialog. See Opening and Importing Files on page 42.

 l Locate the missing file in your system’s directory structure. When the missing file is selected, click Open to link it 
to the layout. 

 l You can also redirect an intact link to from a File Present in Layout to a different file in the same manner.
If all missing files are successfully relinked, the layout opens when you click OK in the Referenced Plan Files dialog.
Be sure to choose File>Save  in the layout file when the missing files have been located to save their links to the 

layout file.

RESULTS OF MISSING REFERENCED PLAN FILES OR LINKED VIEWS

All dynamic and semi-dynamic layout views are linked to a specific view in the plan file that they reference. If the 
referenced plan file is found but the linked view is not, the layout box is not successfully linked. See Managing Layout 
Links on page 981.

If an error message displays, one or more of the missing files could not be replaced by the specified file. Click OK to 
continue. The layout opens, but with the following characteristics:

 l Any plan views associated with the missing file(s) are blank. Only the border displays if the “Layout Box Borders” 
layer is set to display. See Layout Page Display Options on page 971.

 l Any elevations or cross sections associated with the missing file(s) show the automatically generated lines, but any 
CAD objects added to the view are absent.

 

Backup Entire Plan or Layout
Because Home Designer plans contain many references to external files such as material textures and images, it is a 
good idea to make copies all the associated files when a plan is moved to a new location. You can easily do this by 

selecting File> Backup Entire Plan.         

Layout files also rely on references to plan files, images, and other files. Select File> Backup Entire Layout to copy these 
files when you want to move a layout file to a new location.          

Backing up an entire plan or layout is important when:         

 l Migrating legacy files created in older program versions.
 l Transferring files to another computer or sending them to another user.
 l Archiving or backing up your work.

Note: Always use File> Backup Entire Plan or Layout when sending files 
to a user of the Chief Architect Viewer. See Sharing Your Files with 
Clients. 
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To back up a plan or layout

 1.  To copy all associated plan or layout files to a new directory, select File> Backup Entire Plan or Layout 

 2.  The Backup Entire Plan or Layout dialog opens.

 l Choose Backup Plan Files and All Referenced Files to copy the plan or layout file and all externally referenced 
files such as linked plan files, inserted picture files, metafiles, and texture, image,  and backdrop graphics files.

 l Choose Backup Plan Files Only to copy all associated plan files and any externally linked files and inserted 
picture files, but no graphics or texture files. This is best used only when transferring a file to a computer that 
already has the graphics files installed.

 l When Send Backup Files to Zip Archive is checked, the files are saved in a zipped folder. Uncheck this if you 
prefer to save them in a regular folder instead.

 l Click OK.

 3.  The Select the Plan or Project Backup Folder or Choose Zip Archive to Backup dialog opens next. This is a typical 
Save File dialog. See Saving, Exporting, and Backing Up Files on page 37.

 l Navigate to a folder on your system and select it.

 l With the destination folder for the backup selected, click OK.

 4.  If the destination folder already contains files, the program will confirm whether you want to overwrite them.
The resulting folder contains a copy of the plan or layout file and all referenced files, and can be moved to a new 
computer.         

 

Exiting Home Designer
Select File> Exit in Windows® or Home Designer>Quit in macOS™ to exit the program. It is best to save your work 
before exiting/quitting; however, if you have not saved any open files, you will be reminded to do so. See Closing Views 
and Files on page 110.

When you exit from the program using File> Exit or Home Designer>Quit, all Autosave files and Undo files are 
automatically deleted. See Auto Save Files on page 41 and Undo and Redo on page 195.

In macOS™, if you click the program window’s red Close button, the program window will close and you will be prompted 
to save your work; however,  the program itself will continue to run. If you do not plan to use the program in the near future, 
it is good practice to Quit instead of letting the program run in the background.
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Chapter 3
 

Project Planning

The tools described in this chapter allow you to conduct preliminary budget and space planning, and to and run checks on 
plans so you can be more confident that they are free of common drawing errors. 

TOPICS

Space Planning 49
Room Box Specification Dialog 52
Finding Objects 52
Plan Check 53
Loan Calculator 54
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Space Planning
The Space Planning Tools are a time-saving way to create a preliminary room-by-room design without getting 
caught up in the details. When Room Boxes are arranged to meet your needs, you can convert them into a working 

plan that can be edited and detailed to completion. Select Tools>Space Planning  to access these tools in plan view 

only.

 Use the Space Planning Toolbar Configuration to efficiently design using the Space Planning Tools along with 
Text, Dimensions, and CAD tools. See Toolbar Configurations on page 92.

PLACING AND ARRANGING ROOM BOXES

The Space Planning tools consist primarily of tools that place various types of Room Boxes, each associated with a 
particular Room Type such as Bedroom  or Kitchen . See Room Types on page 289.

Select a Room Box tool, then move the pointer into the drawing area. A preview of the box will follow the pointer: click 
once to place a 2D Room Box at that location. You can also click and drag to draw a Room Box of any size. You can 
continue to create more of the same type of Room Box until another tool is selected. A Room Box can be placed so that it 
does not touch other boxes, or so its edge(s) align with or overlap those of other, previously placed boxes.

DISPLAYING ROOM BOXES

Room Boxes and their labels are located on the “Space Planning Boxes” layer. Space Planning Box labels use the Text Style 
assigned to that layer, as well. See Displaying Objects on page 124.

You can change a Room Box's Room Name and Function as well as its line and fill style in its specification dialog. See 
Room Box Specification Dialog on page 52.

Each Room Box is surrounded by lines that indicate the extents of the walls that will define it once the Build House tool 
converts boxes into rooms.

EDITING ROOM BOXES

Room Boxes are a type of 2D CAD polyline and once placed, they can be moved, resized, and reshaped much like other 
closed-polyline based objects. Curved edges are not supported on Room Boxes, however. See Editing Closed Polyline-
Based Objects on page 157.

As with Room Boxes in the process of being placed, a selected box can be moved so that it does not touch other boxes, or 
so its edge(s) align with or overlap those of other boxes. Boxes overlap in the order they were created, with newer boxes 
overlapping boxes placed earlier.

When one Room Box overlaps another, its edge lines are drawn in the area of the overlap, while the overlapped box's lines 
are suppressed. If you select the overlapped box, however, its selection fill and edit handles indicate its full area. Overlap 
does not affect a room's actual shape until Build House is used.

Two edit tools are unique to Room Boxes and allow you to manage overlap situations:
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  Remove Overlapped Areas removes all areas from the selected Room Box(es) that are overlapped by adjacent 
boxes. The box edges are not drawn differently as a result, but any overlap conditions are removed, additional 

edit handles may become available, and the selected box typically gains new edges as its shape is modified.
  The Overlap Adjacent Room Box allows you to reverse an instance where the selected Room Box is 
overlapped by an adjacent box, making it overlap the other box instead. To use this tool, click the button and 

then click on the adjacent Room Box that currently overlaps the selected box. The box edges are redrawn to reflect this 
change, but neither box's shape actually changes and no additional edit handles become available. 

BUILD HOUSE

When Room Boxes are in place, select Tools> Space Planning> Build House to convert them into a structure in 
which walls and railings define rooms. When Build House is used, walls are generated based on the locations of the 

Room Box edges as they are drawn: any overlaps are ignored. See Rooms on page 286.

Room Box edges are converted into walls using the Wall Types set in the Exterior Wall, Interior Wall, Railing, and Deck 
Railing Defaults dialogs. See Wall, Railing, and Fencing Defaults on page 229.

Room Box edges are converted into walls using the Wall Types set in the Exterior/Interior Wall Defaults dialog. Railings 
and Deck Railings are used to define some exterior Room Types, as well. See Wall, Railing, and Fencing Defaults on page 
229.

Room Boxes and rooms defined by walls and 
railings created by the Build House tool

MULTIPLE FLOORS

Space Planning is supported on Floor 1 and all floor levels above it but not on Floor 0. See Multiple Floors on page 517.

If you would like to use Room Boxes to design room layout on upper floor levels, it is important that you make sure the 
Room Boxes, or more to the point, the walls they will eventually create, are properly aligned between floors. To do this:

 l Turn on the Reference Display. See The Reference Display on page 525.
 l Make sure that the "Space Planning Boxes" layer is turned on in the Reference Display. See Change Floor / Reference 

Dialog on page 525.
 l Make sure that Object Snaps are enabled - particularly, Endpoint and On Object snaps. See Object Snaps on page 114.
 l Use a Room Box's edit handles to snap its edges to edges drawn in the Reference Display.
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SPACE PLANNING ASSISTANT

In plan view, select Tools> Space Planning> Space Planning. The Space Planning Assistant gathers information about the 
rooms you want to include in your house. When you click Finish, the selected room boxes display.

Room boxes can now be arranged into a floor plan. 

MULTIPLE FLOORS

If you specified a two-story house in the Space Planning Assistant:

 1.  Edit and arrange the room boxes on Floor 1 as desired.                     

 2.  Select Tools> Space Planning> Build House  tool to create the walls on the first floor.                     

 3.  Go Up One Floor  and notice that the positions of the walls on Floor 1 display in red as a reference.

 4.  Arrange the rooms on Floor 2 as desired using the red polylines as a guide.

 5.  On the second floor, select Tools> Space Planning> Build House  to complete the second floor.
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Room Box Specification Dialog
Select one or more room boxes and click the Open Object edit button to open the Room Box Specification dialog. 
See Space Planning on page 49.

GENERAL PANEL

Most of the settings on the GENERAL panel are used when the selected room box is converted to a room using the Build 
House  tool. 

 l Specify a Room Name for the selected Room Box. When the default is specified, the Function selected below is used 
as the name. 

 l Select a Function from the drop-down list. See Room Types on page 289. 

LINE STYLE PANEL

The LINE STYLE panel is available for a variety of other objects in the program. For more information, see Line Style Panel 
on page 209.

FILL STYLE PANEL

The FILL STYLE panel is available for a variety of other objects in the program. See Fill Style Panel and Dialogs on page 
132.

 

Finding Objects
There are a variety of tools in the program designed to help you locate specific objects. These tools often open a new view 
window in which the object in question is either highlighted or selected.           

 l To find out where a line item in               the Materials List is located in the model, select its row or any cell in its row and click 
the Find Object in Plan  edit button. See Find Object in Plan on page 962. 

 l To locate a string of text, select Edit> Find/Replace Text. See Find/Replace Text on page 361.          
 l In a               Framing Overview or other 3D view in which wall framing can be seen, select a wall framing member and click 

the Find Wall  edit button to locate its owner wall in plan view. See Selecting Walls on page 251.

Additional tools are available to help you find files referenced by your plans and layout files.           

 l Select Tools> Checks> Missing Files Check to identify and locate any missing referenced files. See Referenced Files 
on page 44.          

 l Select Tools> Layout> Referenced Plan Files to identify and locate any plans linked to the current layout file. See 
Managing Layout Links on page 981.          
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Plan Check
Plan Check examines the current floor of a plan, checking for anything that appears to violate common building 
practices. Plan Check may not find all the problems in a plan, but does it point out areas that may need improvement. 

Disclaimer: The Plan Check feature in Home Designer does not 
claim to detect all building code and design requirements. It 

merely compares your plan with common building practices. 

To run Plan Check, select Tools> Checks> Plan Check .

Potential plan errors found are usually highlighted in plan view. To ensure the highlighted item is on-screen, make sure the 
entire plan is shown in the window before you run Plan Check.

PLAN CHECK DIALOG

The current error number, along with the total number of errors found, is stated at the top of the dialog.

A description of the current error displays in the field on the left.

Options for navigating Plan Check are found on the right side.

 l Click Next to ignore the current error and proceed to the next.
 l Click Previous to return to the previous error.
 l Click Hold to suspend Plan Check so you can fix the current error. Select Tools> Checks> Plan Check again and the 

check starts where it left off.
 l Click Done to terminate Plan Check.

If this dialog obscures the plan view, drag its title bar to move it. It remembers its new position and displays there the next 
time Plan Check is run.

ROOM TYPES

Plan Check can do a much better job of checking for problems if it knows what the rooms in your plan are to be used for, 
so you should assign a Room Type to each room in your plan. See Room Types on page 289.

The first time Plan Check runs in a plan, it automatically assigns a room type to as many undesignated rooms as it can. 
Some rooms are determined by their size and shape, and others by their contents. For example, a shelf in a small room 
indicates a closet; a stove or refrigerator indicates a kitchen; or a bed, a bedroom. If the program cannot assign a room type, 
Plan Check highlights it and suggests that you do so manually. 
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Loan Calculator
Select Tools> Loan Calculator to open the Loan Calculator dialog. This dialog lets you calculate different aspects of 
a loan for the current plan based on a variety of parameters. 

 
Calculate

Specify what aspect of the loan you would like to calculate from the Calculate drop-down list:

 l Monthly Payment 

 l Loan Amount 

 l Term 

 l Interest Rate 

 
Result

The calculation Result, based on the information you provide, displays here.

 l If you make changes to any of the fields in the dialog, click the = button to refresh the Result.

 
Required Fields

The Required Fields are the same as the options in the Calculate drop-down list. The option selected under Calculate will 
be inactive under Required Fields.

 l Specify the desired Loan Amount.

 l Specify the desired Term, in years.

 l Specify the desired Interest Rate.

 l Specify the desired Monthly Payment.

 
Optional Fields

The Optional Fields allow you to include additional information in your loan calculation. 
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 l Specify the expected Property Taxes per year. 

 l Specify the expected Homeowner’s Insurance cost per year. 

 l Specify the expected Private Mortgage Insurance (PMI) cost per year.

 l Specify the cost of any expected Other Fees.

When Monthly Payment is calculated, each Optional value is divided by twelve (months) and then added to the total 
payment.

When a Calculate option other than Monthly Payment is selected, these values are divided by twelve (months) and then 
subtracted from the specified Monthly Payment value. The result, which does not display, is then used to determine the 
Loan Amount, Term or Interest Rate.
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Chapter 4
 

Preferences and Default Settings

Preferences are global settings that affect the functionality and appearance of the Home Designer environment, while default 
settings control what objects look like when they are initially created. You can save time and increase your productivity by 
becoming familiar with these settings and customizing them before you begin a new project or as needed thereafter.

TOPICS

Default Settings vs Preferences 57
Dynamic Defaults 58
Reset to Defaults 59
General Plan Defaults Dialog 60
Preferences Dialog 62
Dialog Number/Angle Style Dialog 88
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Default Settings vs Preferences
Default and preference settings have important effects on how the tools in Home Designer function. Default settings are file 
specific, while Preferences are global, taking effect regardless of what file is open. 

Defaults and Preferences can be customized to suit your needs and improve your efficiency, so it is recommended that you 
become familiar with them and learn how you can use them to your advantage.

DEFAULT SETTINGS

Default settings determine the initial characteristics of objects when they are first drawn. For example, when you 
place a base cabinet in a plan, its size, materials, front items, and hardware are determined by settings in the Base 

Cabinet Defaults dialog.

Some defaults affect the structure of your model: for example, Floor, Foundation, Framing, and Wall defaults.           

Defaults are file-specific, which means that any changes that you make to the default settings in one plan or layout file will 
have no effect on other plans or layout files.

You can access a complete list of the various default settings in the current plan or layout file by selecting Edit> Default 
Settings  from the menu.

 l Click the arrow beside a category to expand it and access the defaults for items related to that category.         
 l To open the defaults dialog associated with an item in the list, double-click on the line item, or click on the item and 

then click the Edit button.
 l General CAD defaults are view-specific and are only available in views where CAD objects can be drawn. See CAD 

Defaults Dialog on page 198.           

Many defaults dialogs can also be opened by double-clicking on a parent and/or child toolbar button of a tool affected by 
the settings in that dialog. For example, you can:          
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 l Double-click the Cabinet Tools  parent button to open the Defaults Settings dialog for Cabinet tools only;          

 l Double-click the Base Cabinet  child button to open the Base Cabinet Defaults dialog.          

Some objects have similar defaults dialogs which can be selected and edited as a group. Camera Defaults, Wall Defaults, 
Door Defaults, the Base, Wall, and Full Height Cabinet Defaults, and the Floor Defaults are examples. See Shift and Ctrl/⌘  
Select on page 146.          

PREFERENCES

Preference settings influence the overall environment of the program, such as what the interface looks like, how the 
tools are accessed, and the basic rules governing how objects are drawn and edited. See Preferences Dialog on page 

62. 

Unlike default settings, Preferences are global, which means that any changes that you make to them will take effect in all 
plan and layout files. 

To access the Preferences dialog, select Edit> Preferences  from the menu.

REGION AND LANGUAGE SETTINGS

There are a few formatting considerations in Home Designer that are set based on your  operating system’s Region settings:           

 l Units of measurement - When you first install and launch the program, your template plan and layout files will be set 
to use either U.S. or metric units, depending on your operating system settings. See New Plans Panel on page 74.           

 l Currency - The currency associated with your Region settings will be used in the Materials List, Components dialogs, 
and Loan Calculator. See Materials Lists on page 950 and Loan Calculator on page 54.           

 l Decimal mark format - Depending on your operating system settings, either a dot or a comma will be used in 
dimension lines, dialogs, and anywhere the program can display a numeric value using decimals.          

 l Date format - The format of                  Sun Angle date labels vary depending on your operating system settings. See                  Sun Angles 
on page 826.

 

Dynamic Defaults
Dynamic defaults are values that can be changed globally throughout the current plan or layout file. 

 l If you change a dynamic default value in a defaults dialog, all objects of that type that are set to use the default will 
update automatically to use the new value.

 l Any objects of that type that are not using the default value because of editing will not be affected if you change the 
default. 

Dynamic defaults are presented in several different ways in specification dialogs:

 l Some settings have a Use Default radio button, or a “Use Default” option in a drop-down list.
 l Some settings have a Default check box. Uncheck this box to make the setting not dynamic, or check it again to 

restore the dynamic behavior.
 l Some dynamic default text fields have an Active Defaults   icon in the value field.                     

58



Home Designer Pro 2025 Reference Manual - Reset to Defaults

Not all default settings are dynamic; however, most objects that have defaults dialogs do have some settings that are 
dynamic defaults. They are available for a variety of objects, including dimension lines, walls, doors, cabinets and rooms. 
Materials are another example of an attribute that uses Dynamic Defaults: including for objects that do not have defaults 
dialogs such as library symbols. See Material Defaults on page 746.

 

Reset to Defaults
Select Edit> Reset to Defaults to open the Reset to Defaults dialog. 

This dialog allows you to reset critical structural settings in the current plan to the default values. 

 
Reset Scope

The settings can be cleared for the current floor or for All Floors.

 
Default

Specify which settings you want to reset to Default.    

 l Check Floor and/or Ceiling Heights to reset the default values as specified in the Floor Defaults dialog. Floor and 
ceiling heights for any room can be changed in the Room Specification dialog. See Floor Level Defaults Dialogs on 
page 518.    

 l Roof Groups - You can specify a room’s Roof Group in the Room Specification dialog. This builds the roof over 
this room and others in the same Roof Group independent of the roof built over other parts of the plan. Check to 
reset to the default Roof Group, zero. See Roof Groups on page 577.    

 l When Roof Directives in Walls are reset, all items on the ROOF panel of the Wall Specification dialog are reset to 
the default. See Roof Directives in Walls on page 577.    

 l Check Roof Gable Lines (Delete) to delete any Roof Gable Lines in the plan. See Gable/Roof Lines on page 609.    

 l Wall Top Heights and Wall Bottom Heights - Wall shape and height can be edited in 3D views. Check to reset 
wall shapes and heights. See Editing Walls on page 251.    
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General Plan Defaults Dialog
The settings in the General Plan Defaults dialog control basic features of the Home Designer environment in plan 
files. Just as with other default settings, they are file specific, which means that they can be set differently in 

individual plan files. To open this dialog, select Edit> Default Settings, select "Plan", and click the Edit button.

You can also open this dialog by double-clicking the Select Objects  button.

The General Layout Defaults dialog is similar to the General Plan Defaults dialog, but has fewer settings and is available in 
layout files only. Its settings, too, are file specific.         

  General Settings

 l Check Warn Before Delete Selected Item if you want the program to require confirmation before an item is 
deleted.         

 l Check Ignore Casing for Opening Resize to allow wall openings such as doors to be positioned against an 
intersecting interior wall. Clear this box retain sufficient space for the opening’s specified interior trim width. Not 
available in layout files.
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 l Check Allow Editing in Select Home Designer Products to allow limited editing of the current file in other 
compatible Home Designer programs. See Compatibility with Other Programs on page 33.            

 l Check Warn Before Delete Selected Item if you want the program to require confirmation before an item is 
deleted.

 l Check Pitch in Degrees to display the pitch value in degrees in all dialogs as well as in roof plane labels. Values 
between -89° and 89° can be entered. When Pitch in Degrees in unchecked, Pitch is described in terms of rise and 
run: x inches in 12 or x mm in 1000.

 l The Arrow Key Scroll Distance setting determines how far to scroll in plan view when you press an arrow key. The 
initial default is 12 inches (300 mm). Not available in layout files. See Using the Arrow Keys on page 109.

 
Allowed Angles

See Angle Snaps on page 115.         

 l Select 15 Degrees to enable Angle Snaps in 15° increments.             

 l Select 7 1/2 Degrees to enable Angle Snaps in 7 ½° increments.              

 l Check Additional Angles and enter up to eight custom Allowed Angle values. Click the Number Style button to 
specify the format used to enter angles in dialogs. See Dialog Number/Angle Style Dialog on page 88.             

 
Snap Grid

See Grid Snaps on page 116.    

 l Check Use Snap Grid/Units to enable Grid Snaps.

 l Specify the Snap Unit you wish to use. The initial default is 1 inch (10 mm).

It may be helpful to temporarily change the Snap Unit when 
working with large objects such as terrain.      

 l Uncheck Show Snap Grid to turn off the display of the Snap Grid, a visual indicator of the location of the snap 
points.           

 l Click the Color bar to specify the Snap Grid Color. See Select Color Dialog on page 135.           

 l Check Display as Dots to display the Snap Grid using dots rather than lines.     

 l You can also click the Grid Snaps  toggle button to turn on/off grid snapping.     

  Reference Grid

 l Check Show Reference Grid to display the Reference Grid, the virtual graph paper used to create a sense of scale in 
plan view.             

 l Specify the Reference Grid Size.    

 l Click the Color bar to specify the Reference Grid Color. See Select Color Dialog on page 135.      

 l Check Display as Dots to display the Reference Grid using dots rather than lines.           

 l You can also click the Display Reference Grid  toggle button to turn on/off the grid display.           

 
Living Area

 Not available in layout files. See Living Area on page 296. 
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 l Select Main Layer to have the Living Area calculation measure from the walls’ Main Layer.

 l Select Surface to have the Living Area calculation measure from the walls’ exterior surface.

 l Uncheck Show “Living Area” to turn off the display of the Living Area label. 

 
Opening Indicators

 Not available in layout files. Opening Indicators display on doors, windows, and cabinet doors in camera views when the 
"Opening Indicators" layer is turned on. See Opening Indicators on page 384.                 

 l Check Hinge Indicators Point to Handle for opening indicators to point towards the handle side of openings. When 
unchecked, opening indicators point towards the hinge side.

 

Preferences Dialog
The settings in the Preferences dialog are global: they apply to all plan and layout files and are preserved between 
sessions. To access this dialog, select Edit> Preferences in Windows® or Home Designer> Preferences in 

macOS™. Unlike most dialogs in the program, it is not necessary to have a plan or layout file open to access the Preferences 
dialog.

The Preferences dialog has the following panels:
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APPEARANCE PANEL

 

Contextual Menus

 l Check Contextual Menus to activate contextual menus that display when you right-click. See Contextual Menus on 
page 18.

 l Check Click Twice to Display to require two right-clicks on an object before the contextual menu displays. This 
allows the first right-click to be used for object selection. See Selecting Objects on page 142.

 

Note: In 3D views, the two clicks must be on the same object surface 
in order for the contextual menu to display: Clicking on two different 
surfaces of the same object is treated like two single-clicks. 
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Status Bar

 l Check Status Bar to activate the Status Bar at the bottom of the main program window. See The Status Bar on page 
24.

 l Check Show Screen Redraw Time to display the number of seconds it takes to redraw the current view. In camera 
views, multiple redraw times are reported for individual processes rather than one cumulative time.

 l Check Show Coordinates to display the coordinates of your cursor at all times on the right side of the Status Bar.

 l The coordinates’ number style is controlled in the Number Style/Angle Style dialog.  See Dialog Number/Angle Style 
Dialog on page 88.

 
Show Line Weights

Specify the on-screen display of Line Weights. See Line Weights on page 995.     

 l Check Show Line Weights to represent line weights on-screen. Depending on your zoom factor and your monitor’s 
resolution, lines may appear to be wider on screen than when they are printed. Zooming closer may reflect a more 
accurate idea of the actual line width.

 l Specify the Minimum Display Weight, in Pixels. This is the lowest line weight possible on screen, regardless of 
how far you zoom out. A Minimum Display Weight of 0 is the same as 1. This setting is ignored when printing or 
when Print Preview  is enabled.

  Display

 l Images and Pictures - Check Display in Color when Possible to display pictures and images in color even when 
Color   is toggled off. Does not affect the display of images in any 3D views aside from Vector Views. See Color 

On/Off on page 130.

 l Menus - Check Show Icons to display tool icons next to items in the menus.

 l Color Off is - Specify whether views appear in Black and White or Grayscale when color is toggled off. Does not 
apply to any 3D views aside from Vector Views. See Vector View on page 832.

 
Dialog Previews

Specify whether Dialog Previews use the Standard or Vector View Rendering Technique by default. See Dialog Preview 
Panes on page 21.

 
Material Previews

Specify whether or not a Blurred Backdrop Effect is applied behind the preview in the Define Material dialog, Plan 
Materials dialog, Select Material dialog, and Library Browser when a Backdrop image is in use. See Materials on page 
745 and The Library on page 691.

 
Toolbars

Specify how the program's toolbars present child tools when a parent button is clicked.     

 l Choose Parent-Child to display child tools as buttons at the end of the toolbar where the parent button resides.

 l Choose Drop Down to display child tools when the drop-down arrow to the right of the parent button is clicked.
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 l Uncheck Scale Toolbar Icons for High DPI to prevent toolbar icons from becoming larger on systems running 
Windows and using Custom Scaling to increase DPI resolution. When checked, toolbar buttons will increase in size 
when high DPI is used. Not available in the Mac version of the software.

 l Specify the desired toolbar Button Size, in pixels. Increasing this value will proportionally resize the text in the 
drop-down toolbars, as well. See Toolbar Button Size on page 92.

 
Side Window Drag Docking

Specify whether side windows dock to the edges of the program window. See View and Side Windows on page 16.      

 l Uncheck Side Window Drag Docking to prevent undocked side windows from docking when moved using the 
mouse. A side window can still be docked to its last docked location by double-clicking its title bar.

 l Top/Bottom Docking - Check the box beside a side window’s name to allow it to dock on the top and bottom edges 
of the program window. Does not affect docking to the left and right sides.

 
Minimum Display Size

Specify the minimum display size of Temporary Dimensions and Labels, in pixels. For labels, this is the on-screen size 
and does not affect printed or exported output. To use the printed scale, turn on Print Preview .     

 l Dimension sizes are set in the Dimension Defaults dialog. See Dimension Defaults Dialog on page 322.

COLORS PANEL
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View Colors

Specify view background colors and colors associated with selected objects by clicking a color bar to open the Select Color 
dialog. The Selection Line and all Fill colors can also be assigned a level of opacity. See Select Color Dialog on page 135.      

 l Specify the Plan Background color for plan view. The background colors for 3D views can be set in their defaults 
and specification dialogs. See Backdrop Panel on page 806.

 l Specify the Layout Background color, which is the background color in layout files. See Layout on page 970.

 l Specify the Selection Line color and its level of opacity. This is the line color of the bounding box that draws 
around a selected object or objects and overlays the lines that represent the selected object(s). This color also 
outlines temporary CAD points and is the fill color for temporary points aside from the Current CAD Point. See 
Selecting Objects on page 142.

 l Specify the Selection Fill and its level of opacity. This is the fill for the bounding box that draws around a selected 
object or objects. If a selected object has a fill style assigned to it, the appearance of its Selection Fill color may be 
affected. See Fill Style Panel and Dialogs on page 132.

 l Specify the Handle Fill, which is the fill color for selected objects' edit handles and its level of opacity. This fill is 
also assigned to the Current CAD Point. See Edit Handles on page 23 and The Current Point on page 202.

 l Specify the Secondary Handle Fill, which is used to identify special edit handles such as the Key Frame handles on 
Walkthrough Paths. Both color and opacity level can be set. See Key Frames on page 865.

 l Specify the Selected Edge Handle Fill color and its level of opacity. This is the fill color of the edit handle on a 
selected object’s Selected Edge. See Selected Edge on page 143.

 l Click the Reset button to reset all View Colors to the installed defaults.

Note: If the Selection Line and Handle Fill Colors are similar, it may 
be difficult to distinguish between active and inactive CAD Points.

 
Interface Colors

Specify the colors for a variety of different elements in the software’s interface by selecting an option from the drop-down 
list:     

 l Select “System” to use your operating system’s color settings.

 l In the Mac version of the software, select “Force Light” to use Light Mode in Home Designer regardless of the 
system settings, or “Force Dark” to use Dark Mode in Home Designer regardless of the system settings.

 l Select “Custom Color Theme” to apply a color theme to the program interface and select its characteristics below.
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 l The table and settings that follow are only available when “Custom Color Theme” is selected, above:     

 o The table lists all available Color Themes. Click on a line item to select and activate that color theme.     

 o Locked themes are installed with the program and cannot be modified or deleted.     

 o To create an unlocked theme, select any theme in the list and click the Copy button.     

 o Select an unlocked theme and click the Rename button to specify a new name.     

 o Select an unlocked theme and click the Delete button to remove the theme from the list.     

 o When an unlocked theme is selected, the settings below the table are enabled, allowing you to specify the colors for 
a variety of elements in the program interface.

 o When Toolbar Button/Image Backgrounds is unchecked, toolbar buttons and images in dialogs use the 
Dialog/Toolbar Background color.

The program interface will update as you select different color themes or edit the selected unlocked theme’s color settings.

LIBRARY BROWSER PANEL

The LIBRARY BROWSER panel controls the appearance of the Library Browser window. See The Library Browser on page 
692.

 
Search

When Include Web Results  is checked, content that is available for download will be included in the Filter Results. 
Uncheck this to only include content already present in the library in the Filter Results. Include Web Results  is also a 

toggle button in the Library Browser. See The Library Browser on page 692.

 
Folders Panel

When Enable Filtering is checked, the tree list in the Folders panel will be filtered according to the active search 
parameters. Uncheck this to show all content in the tree list, regardless of the active filter. 
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Folders Panel Rename Behavior

Specify which actions allow you to edit the name of an item in the User Catalog. See Renaming Library Items on page 711.                 

 l Select Double-Click Selected Item to open an inline text editor when you double-click on the name of a library 
item.

 l Select Single-Click Selected Item to open an inline text editor when you single-click on the name of a library item 
that is already selected.

 l Select Do Not Rename With Clicks to never open an inline text editor in the Folders Panel and instead use the 
contextual menu when you wish to rename an item.

  Filter Results Panel

 l When Show Names in Tile Mode is checked, the names of items in the Filter Results panel list are reported under 
each thumbnail when Tile Mode is in use. When unchecked, only the thumbnails display.

 l Check Double-Click Closes Browser to close the Library Browser side window when you double-click on an item 
in the Filter Results list. Doing this will also close any other side windows that the Library Browser is docked with.

 
Preview Panel Default Render Technique

Specify whether selected library items are displayed in the Preview panel using the Standard or Vector View Rendering 
Technique. See Rendering Techniques on page 832.

  Panel Layout

 l When Lock Panels is unchecked, library panels can be rearranged by clicking and dragging their title bars. Check 
this box to prevent library panels from being moved.

 l Click the Reset Panel Layout button to return all library panels to their system default locations.

To restore the original size and position of the Library Browser and other 
side windows, click the Restore Side Windows button on the Reset 
Options Panel on page 87.

TEXT PANEL

  Text Specification Enter Key
 l Uncheck Create New Line to close the Text and Rich Text Specification dialogs when the Enter key is pressed. 

When this is checked, a new line of text is created when Enter is pressed and the dialog remains open.
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GENERAL PANEL

  Undo

 l When Undo is checked, the Undo and Redo commands can be used. See Undo and Redo on page 195.

 l Maximum Undos - Specify how many levels of Undo and Redo you want available, from 1 to 100. Undo files are 
saved in the Undo Directory.

  Check For Program Updates

 l When Check For Program Updates is checked, Home Designer will check for updates when the program is 
launched.

 l By default, Home Designer checks for program updates once a day when the program is launched. You can specify a 
different frequency, in days, if you prefer.

  Startup

 l When Show Dashboard is selected, the Dashboard window opens when Home Designer is launched. See 
Dashboard on page 10.

 l When Open New Plan is selected, a new plan file is instead created. See Creating a New Plan or Layout on page 
36.

  Dashboard

 l When Show When No Other Tabs are Open is checked, the Dashboard will open when all other view tabs are 
closed. See View Windows on page 103.
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 l Check Close When a New Tab is Created to close the Dashboard tab whenever a new view is opened. When this is 
unchecked, the Dashboard remains open when a new tab is created.

  Troubleshooting

 l Check Automatically Send Error Reports to automatically send a report to Chief Architect in the event of a 
program error. This box becomes checked automatically if you click the Send Report button in an error message box. 
If an unsent error report generated during the current program session exists, it will be sent automatically if this box 
is checked by the user. See Error Messages on page 1008.

 l Check Record Timing Log to have the program create an event timing log in the Hidden User Settings Folder for 
troubleshooting purposes. Unless you are actively troubleshooting program performance, this box should be 
unchecked.

 l Specify the desired Pinch Zoom Sensitivity, which affects the zoom rate for touch screens, trackpads, as well as 
Ctrl/⌘  + scroll wheel actions in Home Designer. The default value is 1. See Using Input Devices on page 13.

Additional options are available in the Mac version of the software only:

   l When Mouse Movement Optimizations is checked, zooming using the mouse scroll wheel is optimized for Mac 
systems. This box is checked by default and should only be unchecked when troubleshooting issues with the mouse 
scroll wheel in the Mac version of the software.

 l Use the Mouse Scroll Sensitivity scrollbar or text field to control how sensitive the mouse scroll wheel is when 
zooming using the mouse scroll wheel in the Mac version of the software.

  Save Dialog Size and Position

 l Specify when to Save Dialog Size and Save Dialog Position: Always, Per Session, or Never. See Dialog Size and 
Position on page 20.

 l Check Open Dialogs to the Last Panel Visited to open paneled dialogs to the last panel that you accessed during 
the current program session. When unchecked, dialogs always open to the first panel. See Dialogs on page 19.

FILE MANAGEMENT PANEL

The settings on the FILE MANAGEMENT panel let you modify functions related to the program’s plan and layout file 
management.
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Auto Save

 l Check Auto Save, then enter a value greater than zero in the text field to specify the frequency in minutes that Auto 
Save files are created. Auto Save files are stored in the Archive folder. See Auto Save Files on page 41.

Even with Auto Save active, you should frequently save your 
work to the hard drive by selecting File> Save.

 
File Locking

Choose whether or not to lock .plan and .layout files when they are open. File Locking prevents another program or copy 
of Chief Architect software from opening and modifying the same file at the same time and is recommended in nearly all 
circumstances.      

 l Select Use File Locking to lock files.

 l Select Disable File Locking to disable this feature.

 
Recent File List

Specify the maximum size and location of the Recent File List.     

 l Specify the maximum number of recently opened files to list in the Dashboard window and at File> Open Recent 
Files. You can open any of the files in this list by selecting it, making it a quick way to access your most recent 
work.

 l Uncheck Show in Submenu to display the Recent File List at the bottom of the File menu rather than in a submenu.
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Thumbnail Images

Thumbnail images are file previews that display when opening or searching for saved plan and layout files. Thumbnail 
Images on page 34.     

 l Check  Thumbnail Images to automatically create thumbnail images when a plan or layout is first saved. If this 
option is disabled, you can still create thumbnails manually.

 l Select either Small or Large thumbnails. Large thumbnails provide a higher quality image but result in larger file 
sizes.

 
Auto Archive Files

Select an Auto Archive Files option. Every time a file is saved, the current archive file is overwritten. See Auto Archive on 
page 40.     

 l Select Hourly to save and append archive files based on an hourly format.

 l Select Daily to save and append archive files based on a daily format.

 l Select Previous Save to archive only the most recently saved file, unappended.

  Auto Archive Warning

 l Uncheck Auto Archive Warning to prevent the program from prompting you to manage archive files. When 
checked, you will be reminded to manage the current file’s archives when they reach the number specified below.

 l Enter the Maximum Files, which is the number of files that must be in a file’s Archive directory before the Manage 
Archives warning will display. See Manage Archives on page 41.

  Auto Copy Files

 l When Copy Externally Referenced Material Files to My Data Folder is checked, the program automatically 
makes a copy of the material texture files associated with any custom materials that you create in your Home 
Designer Pro 2025 Data folder. This can help prevent these files from becoming lost if the originals are deleted. See 
About Materials on page 746 and Home Designer Pro Data on page 35.

  File Association

 l Click the Associate Files With This Program button to direct your computer’s operating system to associate all
 .plan, .layout, .calib, and .calibz files with Home Designer Pro 2025. This button will not be active if plan, layout, 
and library files are already associated with this program and version. See File Association on page 33.

FOLDERS PANEL

Home Designer stores many support files in various folders on your computer. The default locations of these directories are 
listed and can be redefined on the FOLDERS panel if necessary.

You do not need to change default locations under normal circumstances, but sometimes it may be preferable to locate 
certain files in another location. To specify a new default folder for a particular purpose, click the Browse button to the right 
of that item.

Changing settings on the Folders panel can result in unexpected 
program functionality.
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 l Important user-specific information is stored in the Home Designer Pro 2025 Data folder, which is located in your 
Documents directory by default. See Home Designer Pro Data on page 35.
If you specify a new location, any custom toolbars or other settings that you may have will not be copied to the new 
location: you can do this yourself if you wish.

Make sure that the location you specify is accessible and has 
adequate space for the files in this folder. See Data Folder 

Name and Location on page 35.

 l The User Library Folders contain custom content, including the User Catalog and Trash in the Library Browser. See 
The User Catalog on page 706 and Deleting Library Items on page 712.
 o When Keep User Library and Referenced Files in Data Folder is checked, the location of these folders will 

update if you specify a new location for the Data folder, above. 
 o When this is unchecked, these folders will remain in the location specified below. 
 o If you specify a new location, you will be presented with the option of automatically copying your existing User 

Catalog and Trash, as well as your Backdrops, Images, and Textures folders to the new location. 
 l By default, Temporary files and Undo files are stored in the same folder. See Undo and Redo on page 195.

 o If you wish to use a different folder, you must specify a directory on a hard drive with sufficient space to hold 
these files.

 o Home Designer will not let you save your work in the Temporary or Undo folder, or open files saved in either 
location.

 l All library content aside from your User Catalog is stored in the System Library Database Folder. See Library 
Content on page 705.
 o By default, this folder is created in the directory intended for shared application data in your operating system 

(C:\ProgramData in Windows;/Library/Application Support in macOS).
 o If you specify a new location, the program will automatically copy your library content to that location.

If you choose to use a different folder, you must specify a 
directory on a hard drive with sufficient space to hold these 

files. 

 l All Program Paths - Click the Show button to open the Program Paths dialog, where you can find the location of files 
that may be needed for troubleshooting purposes. See Program Paths Dialog on page 1009.
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NEW PLANS PANEL

 
Open and Save As
Control how the program behaves when a new plan is opened or an existing plan is saved.      

 l Use Last Folder refers the program to the directory last used to save or open a plan file.

 l Use This Folder refers the program to a particular location specified by you.

 l Click the Browse button to define a particular directory when Use This Directory is selected.

UNIT CONVERSIONS PANEL

In many places throughout Home Designer, you can specify the size of an object with any Length unit listed on the UNIT 
CONVERSIONS panel. Using the data on this panel, the program will convert your entry into the unit set in the Dialog 
Number/Angle Style dialog. See Dialog Number/Angle Style Dialog on page 88.

These conversions are also useful when you import drawings. When an object is drawn in a Home Designer plan file, it is 
always at its true, unscaled size and the drawing is only scaled when you print it. This means that if you import a scaled 
drawing, you must compensate for its scaling by creating a custom unit of measurement. See Import Drawing Assistant on 
page 880.

The default unit conversions are locked and cannot be changed, but custom conversions can be added to the list and later 
modified.
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Units

A list of available units of measurement displays here. Click on the name of a unit to select it.      

 l Add, Edit, Delete, or Copy the unit conversions. Certain unit conversions are locked and cannot be edited or 
deleted.

 l If you click Add, Edit or Copy, the Add Unit Conversion dialog displays.

 
Sample

An example of how the unit selected above converts to a selection of similar units. You can use this to verify that any unit 
conversion you create is correct.
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ADD UNIT CONVERSION DIALOG

  Unit Name

 l Type a short, descriptive name of the new unit. Names must be unique: the names of units installed with the program 
cannot be used.

 l Names can include any characters, as well as spaces. Bear in mind, though, that names of units for measuring length 
that have numbers in them may be unusable if entered in some dialogs in the program.

 l Check Default Unit to display this new unit in places that present lists of available units. For example, if you have 
inches as units and make inches a default, inches appear on the list when you are given a choice of units, such as in 
the Import Drawing Assistant. In other places, such as the Materials List, all units are listed.

 
Measurement Type

Specify what the new unit measures.      

 l Select the appropriate radio button: Length, Area, or Volume.

  Conversion

 l Specify how much to Multiply by your custom unit to convert to the unit you select from the drop-down list. A 
measurement type must be selected before the list is populated.

 
Sample

An example of the Unit Conversion defined above displays here.

When importing a drawing with a 1” = 20’ scale, for example, create a unit to convert this scaling to 1” = 1”.

To create a new unit of measurement

 1.  Click the Add button to open the Add Unit Conversion dialog.

 2.  Type a short, descriptive name like “convert 1:20” in the Unit Name field.

 l Because this unit will be used only for scaling conversion, including numbers in its name will not cause any issues.

 3.  Select Length as the Measurement Type.
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 4.  Type 20 in the Multiply by field.

 5.  Select “ft” from the drop-down list.

Note: You can achieve the same results if you Multiply by 240 to 
convert to inches.

 6.  Click OK to close the dialog.

ARCHITECTURAL PANEL

 
Walls

Select the desired default behaviors for selected walls.     

 l Check Show Same Wall Type Handles to display edit handles on selected walls that draw new walls of the same 
type when dragged. See Same Wall Type Edit Handles on page 254.

 l Check Select Room Before Wall in 3D to select the room defined by a wall when you click on the wall in 3D 
views. See Selecting Rooms on page 291.

 

Stairs

 l Check Stair Sections Move Independently to allow stair sections connected by landings to move separately, 
without moving the entire staircase. See Editing Stairs and Ramps on page 534.

  Rooms

 l Uncheck Enable ‘Show Room Label’ Automatic Behavior When Changing Room Types to prevent a room’s 
label from displaying when an “Unspecified” room is assigned a different Room Type in its Room Specification 
dialog. When this box is checked, the room label’s display will be enabled when the Room Type is changed from 
“Unspecified”. See General Panel on page 308.

 
Legacy File Configuration

Specify how obsolete settings are handled when legacy files are opened in the current program version. See Considerations 
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for Legacy Files on page 1013.                 

 l When Opening Indicators Point to Hinge Side is checked, the opening indicators for hinged openings point to the 
hinge side of the opening in legacy files opened in Home Designer Pro 2025. When unchecked, opening indicators in 
these files point to the handle side. See Opening Indicators on page 384.

CAD PANEL

The CAD panel controls whether or not objects snap together to form polylines and objects that behave like polylines. See 
Polylines on page 218.   

  Options 

 l Uncheck Connect CAD Segments  to prevent CAD objects from snapping together to form polylines as they are 

drawn or edited. See Connect CAD Segments on page 142.

Note: Unlike other Preferences, the program always resets Connect 
CAD Segments to be on whenever you close the program.

 
Line Properties

These settings affect open CAD shapes, including lines, arcs, and splines.     

 l Endcap Printed Length - The beginning and end of CAD lines that use a dashed line style are sometimes difficult 
to distinguish. Endcaps can be placed to eliminate this problem. Specify the printed endcap length in inches (mm).

 l Uncheck Show Same Line Type Handles to turn off the display of these edit handles on selected CAD objects. See 
Same Line Type Edit Handles on page 207.

 
Sun Angle

See Sun Angles and Shadows on page 825.     

 l Define the default Latitude, Longitude and Time Zone used when creating Sun Angles.
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EDIT PANEL

The settings on the EDIT panel of the Preferences dialog control the appearance of the cursor and selection behavior of edit 
handles. See Using the Crosshairs on page 170.   

 
Crosshairs

You can use a cursor with Crosshairs in different view types and control its appearance. See Crosshairs on page 15.     

 l Check Enable in Plan and Cross Section/Elevation Views to use a cursor with crosshairs in plan and cross 
section/elevation views. This option is checked by default.

 l Check Enable in Perspective Views to use a cursor with crosshairs in perspective camera views and overviews.

 l When Synchronize with Cursor is checked, the mouse pointer and crosshairs always move together on screen. If 
you feel that they do not keep up with your mouse movements, try unchecking this option.

 l Click the Color bar to open the Select Color dialog and specify the color of the crosshairs.

 l Specify the Width of the crosshairs lines, in Scaled Pixels.

 l Crosshairs Size is specified as a percentage of the view Window Width. Specify the Size as 100% to extend the 
crosshairs across the entire screen.

 l Set the Aperture Size, measured in Scaled Pixels. The aperture is the space where the crosshairs meet. A value of 0 
makes the crosshairs meet at a point. Larger numbers leave a gap in the center.

 
Selection

Customize the appearance of some types of selected objects, and edit handle sensitivity.      

 l Enter an Edit Handle Size in Scaled Pixels. The edit handles are twice this number of pixels plus one. For example, 
the default value is 4, which results in a handle that is 9 x 9 pixels (4 x 2 = 8, and 8 + 1 = 9). The minimum value is 
1, which results in a handle that is 3 x 3 pixels.
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 l Enter a value, in Scaled Pixels, for Edit Handle Tolerance to specify how close to an edit handle you must click in 
order to select it. The default value is 0.

 l When Show Start and End Indicators is checked, an S and an E display at the start and end points of a selected 
wall or the selected edge of a CAD-based object. This can make it easier to edit the selected edge in the object’s 
specification dialog. Uncheck this box if you prefer not to see these indicators. See Selected Edge on page 143.

 l Specify the Size of the Start and End Indicators, in Scaled Pixels.

 
Marquee Selection

Specify program behavior when selecting objects using a marquee. See Marquee Select on page 145.

  Select Intersected Objects selects any objects whose bounding boxes are intersected by or located within 
the marquee. 

  Select Contained Objects selects only objects located entirely within the marquee. This option provides the 
best results in most situations.

  Select Objects by Center selects only objects whose center points are located within the marquee.

 You can add the Selection Modes tools to your toolbars. See To 
add a button to a toolbar on page 93. 

COORDINATE SYSTEM PANEL

Indicators for the X, Y, and Z drawing space axes and/or the drawing space origin can be set to display in a variety of views 
for reference purposes. See Coordinate System Indicators on page 104.
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Plan View and Layouts

Check the box beside each indicator type that you want to display in these view types. In these 2D views, the X and Y axes 
are always shown.

 
Cross Section/Elevation Views

Check the box beside each indicator type that you want to display in these view types. In these views, the Z axis is always 
shown, and the other axis is dependent on the camera's direction. If the camera's line of sight is at an angle that is not 
parallel to either the X or Y axis in plan view, all three axes will be represented.

 
Orthographic and Perspective Views

Check the box beside each indicator type that you want to display in these 3D view types. In these views, the X, Y, and Z 
axes are always shown.

  Axes Indicator

 l The X Axis, Y Axis, and Z Axis Colors display in the Color bars. Click a Color bar to choose a new color if you 
wish. See Select Color Dialog on page 135.

 l Specify the Line Length, which controls the size of the Floating Axis Indicator in all view types.

 l Specify the Label Height, which controls the size of the X, Y, and Z axis labels in all view types.

  Origin Indicator

 l Specify the Color of the Origin Indicator crosshairs. See Select Color Dialog on page 135.

 l Specify the Origin Indicator's Draw Order: select Front to draw the Origin Indicator in front of objects in the 
view, or select Back to draw it behind all objects in the view. See Drawing Groups on page 129.

BEHAVIORS PANEL

The settings on the BEHAVIORS panel of the Preferences dialog define basic editing behaviors of CAD and architectural 
objects.
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Rotate/Resize About
Define the point about which an object or a group of objects rotates or resizes. See Rotate/Resize About on page 113.     

 l Select Object Center to rotate or resize the selection about its center point. Object Center is the default setting.     

 l Select Current Point to rotate the object about the current CAD point instead.

 l To resize a CAD object about a current point, select the Resize Edit Type.     

 l This function can also be accessed by selecting Edit> Edit Behaviors> Resize . See Defaults, Preferences, and 

Edit Behaviors on page 138.

 l Rotate Jump defines the angles an object or group of objects jumps to as it is rotated. When this value is set to 0°, 
the Allowed Angles set in the Plan Defaults dialog are used; otherwise, Allowed Angles are ignored.

 
Primary Movement Methods

Control the directions that you can move objects using their edit handles.     

 l Select Orthogonal to move an object perpendicular to any of its edges.     

 l Select Polar to move an object at Allowed Angles.

 
Edit Type

See Defaults, Preferences, and Edit Behaviors on page 138.     

 l Specify the active Edit Behavior.

 l Specify the desired Jump increment for Concentric resizing. This setting is also found in the Set Concentric Jump 
dialog. See Concentric Resize on page 174.    

 l Uncheck Behavior Indicators to turn off the display of the mouse pointer icons associated with these Edit 
Behaviors. This box is checked by default.

Note: Unlike other Preferences, the program always restores the Default 
Edit Behavior whenever you close the program.

SNAP PROPERTIES PANEL

The settings on the SNAP PROPERTIES panel of the Preferences dialog control the behavior of Object Snaps as well as the 
appearance of snap indicators. See Object Snaps on page 114.
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  Options

 l Specify the Snap Distance, which is how far the cursor can be from a snap point for the snap to occur. This value is 
measured in Scaled Pixels; the default value is 12. 
When working with very small objects, you may find it helpful to reduce this value; when working with very large 
objects, it may be helpful to increase it. 
This setting also controls the minimum length of camera and cross section/elevation lines of sight. See Creating 
Camera Views on page 776.

 l Specify the Maximum Bump Distance, which is the distance in Scaled Pixels that a selected object must be 
dragged to override bumping and move past an obstructing object.

  Snap Indicators

 l Specify a snap Indicator Size in pixels. This setting also controls the size of temporary CAD Points. See Place 
Point on page 201.

 l Click the color bar to select a snap Indicator Color from the Select Color dialog. See Select Color Dialog on page 
135.

 
Object Snaps

These options can also be turned on and off using the toggle buttons on the toolbar and/or keyboard hotkeys.     

Check Object Snaps to enable the object snap  options, below.

  Endpoint enables snapping to the ends of lines, arcs, splines and other objects.
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Endpoint snaps

  Midpoint enables snapping to the midpoint of an object such as a line or arc. For objects such as boxes, you 
can snap to the midpoint of any side of the box.

Midpoint snaps

  Center enables snapping to the center of cabinets, fixtures, furniture, as well as circles and arcs.

Center snap

  Quadrant enables snapping to the left, right, top, or bottom of an object. Only used for arcs and circles.

Quadrant snaps

  On Object enables snapping to any point on the selected object, including CAD objects and cabinets.

On Object snap

  Points/Markers allows you to snap to temporary CAD points. Note that this only affects CAD Points, not 
Text Markers. See Point Tools on page 200.

Points/Markers snap

84



Home Designer Pro 2025 Reference Manual - Preferences Dialog

  Intersection enables snapping to the intersection of two objects, such as the intersection of a line with another 
line. Intersection snapping also snaps extension lines to objects, and allows you to snap two extension lines to 

each other.

Intersection snap

When Intersection snapping is enabled, wall extension line snapping will also occur. See Creating Walls on page 241.

  Other Snaps

  Check Bumping/Pushing to allow objects to bump into and move other objects. See Bumping/Pushing on 
page 168.       

 o Check Bumping/Pushing for Type-in Movement to cause objects moved using dimensions to bump 
into objects in their path of movement and stop. When unchecked, objects moved using type-in methods 
move to their specified destination locations. See Moving Objects on page 167.

  Check Angle Snaps  to enable snapping to Allowed Angles. See Angle Snaps on page 115.

MASTER LIST PANEL

The MASTER LIST panel specifies how the Master List(s) for materials appears. You can maintain Multiple Master Lists, but 
only one may be used at any given time. See Materials Lists on page 950.

 
Master List File
The name and pathname of the currently referenced Master List is shown. It is referenced for all subsequently opened plans 
when a materials list is generated.     

 l Click the Browse button to select a different Master List. Navigate the directory structure until you find the new 
Master List to be used, select it, and click OK.
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Note: If the Master List file is saved in the program Data folder, and 
the location of My Data Folder is changed, this pathname will 
automatically update. See Folders Panel on page 72.

 l Click the New button to create a new Master List. Name and save it in the location of your choice. When you create 
a new Master List, it is blank until you build a materials list and enter prices, supplier or manufacturer information. 
The Master List is saved automatically when you close.

RENDER PANEL

The settings on the RENDER panel control how 3D views are generated and navigated.

   General Options

 l Horizon Lines are lines that generate along the curved edges of symbol objects in Vector Views. Uncheck this box 
to increase the speed of Vector View generation but also suppress these lines. See Vector View on page 832.

 

3Dconnexion® 3D Mouse and Gamepad

See 3Dconnexion® 3D Mice on page 786.     

 l Select Navigate about Camera to center mouse movement about the location of the camera.

 l Select Navigate about Camera Focal Point to center mouse movement about the location of the camera’s focal 
point. See To create a camera view on page 776.

  Troubleshooting

 l In the Windows version of the program, uncheck Enable GPU Ray Tracing to disable enhanced shadow and 
ambient occlusion quality in 3D views that support these effects. This box is checked by default and should only be 
unchecked for troubleshooting purposes. If this option is disabled, it is not supported on the system. 

 l In the Windows version of the software, the Enable Diagnostics (Requires Restart) option makes it possible for 
information about certain errors to be collected. Restarting with Diagnostics enabled will degrade program 
performance and should only be done when requested Chief Architect Technical Support. See Contacting Technical 
Support on page 1008.
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 l Manage GPU Residency helps improve performance when printing very large files. This option is checked by 
default and should only be unchecked for troubleshooting of printing issues in the Windows version of the software 
only. See Printing and Plotting on page 984.

 l In the Mac version of the software, checking Disable Render Target Aliasing may address pixelation in camera 
views. This option is unchecked by default on most systems.

 l In the Mac version of the software, the Enable Retina Render Targets option is checked by default but should be 
unchecked on systems that do not have Retina displays.

VIDEO CARD STATUS PANEL

The VIDEO CARD STATUS panel displays information about your video card, including the vendor and whether it supports 
the software's minimum requirements.

This information may be important if you are having problems generating 3D views.

RESET OPTIONS PANEL

In order for some of the Reset Options to take effect, you will need to restart Home Designer. 

 l If message boxes have been suppressed, you can make them display again by clicking Reset Message Boxes. See 
Message Boxes on page 24.

 l Click the Reset Dialog Sizes button to restore all dialog boxes to their original sizes and positions. See Dialogs on 
page 19.

 l Click the Reset Toolbars button to reset all toolbars to their original states. If you are encountering warning messages 
regarding toolbars, this option may resolve the issue. Note that any custom toolbar configurations that you may have 
created will be discarded if you click this button. See Creating Custom Toolbar Configurations on page 95.

 l Click the Reset Templates button to restore the templates used for creating new plan and layout files. See Template 
Plans on page 36.

 l Click the Reset Side Windows button to restore all side windows to their original sizes and positions. Tool Palette 
Settings   are also reset, as are the panes in the Library Browser. See Side Windows on page 16.

 l Home Designer retains a list of locations where you have located missing files in the past. If you find that the program 
takes a long time searching before informing you that files are missing, you can click the Reset Search Folders button 
to clear this list. See Referenced Files on page 44.
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 l Click the Reset Migration button to be prompted to migrate your content and settings from an older program version 
the next time you launch the software. 

 l Click the Reset Preferences button to restore all preferences to those originally installed with the program.

Resetting all preferences to default can be a drastic step and 
should be done with caution.

 

Dialog Number/Angle Style Dialog
At the bottom of many dialogs, you can click the Number Style button to open the Dialog Number/Angle Style dialog.

The settings in this dialog are global and control the format of distances, coordinates and angles of angles in dialog boxes 
and inline text fields, as well as in the Status Bar. They are also persistent for the current program session only: when you 
restart the program, they are reset. See The Status Bar on page 24.

These settings control the format of values used in dialogs but do not limit how you must enter these values. For example, if 
you set your Number Style to use Inches, values will display using fractional inches. You can, however, enter values using 
decimal inches, inches and feet, or even decimal feet by including the appropriate unit indicators. When the dialog you’re 
typing in updates, the value will be converted to fractional inches.    

When U.S. Units are used, the Fractional Inches and Feet, Fractional Inches options use fractional inches with 
denominators of 2, 4, 8 and 16. A few objects, notably text, dimensions, and floor, ceiling and wall structure layers can be 
sized using smaller fractions with  larger denominators. 

Angles can be displayed using one of the following methods: 

 l Degrees/Minutes/Seconds - Measured counterclockwise from a line drawn horizontally to the right of the angle’s 
vertex. Useful for most drawing tasks. Select the level of accuracy that you require.             

 l Quadrant Bearings - Measured from a vertical line representing North/ South, Quadrant Bearings use directional 
bearings in their measurements. Useful for site drawings.             

 l Azimuth Bearings - Measured from a line drawn straight up from the angle’s vertex (ie, North on a site plan). Useful 
for site drawings, Azimuth Bearings use degrees, minutes, and seconds in their measurements.             

 l Pitch - Defined as a ratio of vertical rise to horizontal run. In U.S. Unit plans, the run is always 12”; in metric plans, it 
is 1000 mm. Useful for roofs.             
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Quadrant and Azimuth Bearings are affected by the orientation of the North Pointer , if one is present in the current 

plan. See North Pointer on page 825.
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Chapter 5
 

Toolbars and Hotkeys

Two of the most efficient ways to access Home Designer’s tools and settings are the toolbars and keyboard shortcuts, also 
referred to as hotkeys.

TOPICS

Toolbar Arrangement 91
Customizing Toolbars 93
Creating Custom Toolbar Configurations 95
Toolbar Customization Dialog 96
Hotkeys 99
Gamepad Settings Dialog 100
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Toolbar Arrangement
Home Designer’s toolbars provide fast access to the program’s most commonly used tools and settings, and are organized so 
that related tools are grouped together and easy to find. 

If a tool or setting is active, a small check mark will display at 
the lower right corner of its button icon.

The toolbars that display in a given view depend on the view type. For example, the toolbars that are available in floor plan 
and 3D views are not available in Materials Lists. Some toolbars are available in more than one type of view. If a tool 
cannot be used in that view, its icon will appear pale grey in color.

You can turn off the display of toolbars entirely or turn them on again by selecting View> Toolbars .    

Many of Home Designer’s tools are organized into families of related tools which can be accessed using either of two styles 
of toolbar interface: the Child Tool Palette or Drop Down tools. You can select the interface that you prefer in the 
Preferences dialog. See Appearance Panel on page 63. 

DROP-DOWN TOOLS

Click on the arrow to the right of a button to display a drop-down list of related tools. For example, click the arrow to the 
right of the Window  button to display a drop-down list of the other Window Tools. 

The most recently selected tool displays in the toolbar.   

CHILD TOOL PALETTE

An alternative to Drop-Down toolbars is the Parent button and Child Tool Palette interface. Parent toolbar buttons 
have a blue triangle in the lower right corner. When you select a Parent button, its Child tools display in the Child 

Tool Palette. If the Child Tool Palette has been closed, it will open. You can open the Tool Palette at any time, even when 
Drop Down tools are enabled, by selecting View>Tool Palette . See View Tools on page 107.

By default, the Child Tool Palette is docked on the left side of the program window; but it can be undocked and moved, as 
well as resized and closed, just like other side windows. See Side Windows on page 16.

As long as it is open, the Child Tool Palette will also display the members of a selected tool’s family when the Drop Down 
interface is active. If you select a tool that does not belong to a family, the previously selected tool’s family will continue to 
display in the Tool Palette.

When you click the Window Tools  Parent button, for example, its Child buttons display in the Child Tool Palette.
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Click the Settings  button at the bottom of the palette to select how the tools within it are presented: 

   Fit Palette: resize the palette so that it is one row wide. 

   Grid View: display only the button icons of the child tools in a grid that may have multiple rows, depending on 
the width of the palette side window.

   List View: display child tools in a vertical list with each tool’s button icon and name in a row.

THE EDIT TOOLBAR

The Edit Toolbar is a special toolbar that only features buttons when one or more objects in the drawing window is selected. 
By default, it is located at the bottom of the program window, just above the Status Bar. The buttons on this toolbar vary, 
depending on the type of object selected, the current view, and how you selected the object; when no object is selected, it is 
blank.

TOOLBAR CONFIGURATIONS

Home Designer Pro installs a set of Toolbar Configurations, which control what tools are initially included in the toolbars, 
as well as where these toolbars are located.         

   The Default Configuration displays architectural tools used for house design, including walls, windows, doors, 
stairs, cabinets, etc. 

   The Terrain Configuration displays buttons associated with the terrain and road tools, including the plant and 
sprinkler tools. See Terrain Toolbar Configuration on page 891.

   The Space Planning Configuration displays buttons associated with the Space Planning Assistant. See Space 
Planning on page 49.             

To switch toolbar configurations

There are several ways to switch from one Toolbar Configuration to another.          

 l Click a Toolbar Configuration button.          
 l Choose a configuration in the Toolbar Customization dialog. See Configurations Panel on page 98.          
 l Right-click in an empty space on any toolbar and select a Toolbar Configuration from the contextual menu.           

TOOLBAR BUTTON SIZE

By default, toolbar buttons are sized at 20 pixels, which works well on most computer monitors running default system 
settings. If you wish, you can increase or decrease this size in the Preferences dialog. See Appearance Panel on page 63.
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Customizing Toolbars
The Toolbar Configurations installed with the program are designed to help make tools quickly and easily accessible; 
however, for greatest efficiency, you may want to customize them to meet your own particular needs. A number of options 
are available:          

Any changes made to an existing Toolbar Configuration will be saved whenever you:

 l Switch to a different configuration;
 l Close the Toolbar Configuration dialog;
 l Exit out of Home Designer.

Bear in mind that the size of the Home Designer program window and the space available for toolbar button depends on 
your monitor’s size and screen resolution settings.          

TOGGLING TOOLBARS

You can turn off the display of all toolbars entirely or turn them on again by selecting View> Toolbars.   

There are also several ways to toggle individual toolbars on or off:         

 l Right-click in an empty space on any toolbar and mouse over Toolbars in the contextual menu. In the submenu, 
toolbars with a check mark next to their name are on in the current view. Click on a toolbar name to turn it off if it is 
on, or vice versa.             

 l Toolbars can be turned on or off in the Toolbar Customization dialog. See Toolbar Panel on page 97.
 l If a toolbar is undocked, click the Close button at its top right corner.             

MOVING TOOLBARS

You can move any toolbar to a different location by clicking and dragging its dotted grab bar. Toolbars can be docked to 
any side of the program window, or they can be undocked and left floating. 

Undocked toolbars can be moved outside the program window, and they can be closed completely. They can also be 
reshaped; however, they cannot be resized in such a manner that any buttons become hidden.

Changes to toolbars are saved between program sessions.          

ADDING AND REMOVING BUTTONS

Toolbar buttons can be added to or removed from toolbars using the Toolbar Customization dialog.         

To add a button to a toolbar

 1.  Select Tools> Toolbar and Hotkeys> Customize Toolbars  and go to the TOOLS panel of the Toolbar 

Customization dialog. See Tools Panel on page 96.             

 2.  Select the View Type that you want to add a toolbar button in.             

 l You can add any buttons you like to any View Type; however, not all buttons will necessarily be available for 
use in all views.
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 3.  Search or browse to find the desired button or its parent in the Available Toolbar Buttons list.

 4.  Click and drag the button you wish to add to a toolbar out of the dialog box.             

 l Drop it onto an existing toolbar to add the button to that toolbar.                 

 l Drop it away from an existing toolbar to create a new toolbar. See To create a new toolbar on page 94.

To remove a button from a toolbar, open the Toolbar Customization dialog, then click and drag the button out of the toolbar 
area.

Buttons cannot be added to or removed from the Edit Toolbar. See The Edit Toolbar on page 92.         

ADDING AND REMOVING TOOLBARS

Toolbars can be added to or removed from each View Type using either the toolbar contextual menu or the Toolbar 
Customization dialog.         

To add or remove an existing toolbar

 1.  Right-click on an empty space in a toolbar.

 2.  In the contextual menu, click on the name of a toolbar.             

 l If the toolbar has a check mark next to it, clicking on it will clear the check mark and remove the toolbar from 
the current View Type.

 l If the toolbar does not have a check mark next to it, clicking on it will add the toolbar to the current View 
Type.

You can also specify which toolbars are used in each View Type in the Toolbar Customization dialog. See Toolbar Panel 
on page 97.           

CREATING NEW TOOLBARS

New toolbars can be created using the Toolbar Customization dialog.         

To create a new toolbar

 1.  Select Tools> Toolbar and Hotkeys> Customize Toolbars  and go to the TOOLS panel of the Toolbar 

Customization dialog.             

 2.  Select the View type to which you want to add a new toolbar.             

 3.  Select the first button that you want on the toolbar from the Available Toolbar Buttons list.             

 4.  Click and drag the button out of the dialog box and drop it:

 l In an empty section of the program window border to create a new toolbar docked at that location.

 l In the drawing area to create a new, undocked toolbar.

 5.  Additional buttons can be added by dragging them onto to this new toolbar.

Use the Empty Space button in your toolbars as a spacer.
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 6.  A new toolbar will inherit the name of the first tool that was added to it, preceded by the word Custom. You can 
assign a new name on the TOOLBAR panel of the Toolbar Customization dialog.

 7.  Also on the TOOLBAR panel, specify the View Types that the new toolbar should be used in.

LOCKING TOOLBARS

When your toolbars are organized the way you want them, you can select Tools> Toolbars> Lock Toolbars to 
prevent them from being moved. Select the same tool to unlock toolbars. Lock Toolbars is also available in the 

contextual menu for toolbars: right-click in an empty space on any toolbar to access it. See Contextual Menus on page 18.         

RESTORING TOOLBARS

To discard your changes and restore all installed Toolbar Configurations to their original condition, click the Reset 
Toolbars button in the Toolbar Customization dialog. See Toolbar Panel on page 97.         

Because resetting toolbars affects all installed Toolbar Configurations, you may find it worthwhile to create your own 
custom Toolbar Configurations. See Creating Custom Toolbar Configurations on page 95.         

You can also restore toolbars to their original state in the Preferences dialog; however, please note that if toolbars are 
restored using this option, any custom configurations that you have created will be discarded. See Reset Options Panel on 
page 87.         

 

Creating Custom Toolbar Configurations
If you extensively edit your toolbars, consider creating one or more custom Toolbar Configurations so that your changes can 
be backed up as well as transferred to a different computer if you wish. 

To create a custom configuration

 1.  Go to the CONFIGURATIONS panel of the Toolbar Customization dialog. See Configurations Panel on page 98.

 2.  Select a configuration similar to the one you want to create and click Copy.             

 3.  Give the new configuration a short, unique name. It will be saved in the Home Designer Pro 2025 Toolbars folder. 
See Home Designer Pro Data on page 35.             

 4.  When you click OK, the new configuration will appear in the list, and it will be active.             

 5.  On the TOOLBARS panel, select each of the different View Types to see the toolbars active in each and confirm that 
they suit your needs.             

 6.  You can now move toolbars, add or remove buttons, and add or remove toolbars to meet your requirements.             

 7.  When you are satisfied with your new Toolbar Configuration, click Close.             

It is a good idea to back up your custom Toolbar Configurations 
files. See Home Designer Pro Data on page 35.

CUSTOM CONFIGURATION BUTTONS

By default, new Toolbar Configurations display a default configuration   button; however, if you want you can make your 

own button icon for your custom Toolbar Configuration.          
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Create a .png file with the same name as the configuration and save it in the Toolbars folder. To see an example, look at the 
Default .png file in the Home Designer Pro Toolbars folder, which corresponds to the Default Toolbar configuration. See 
Home Designer Pro Data on page 35.          

 l Toolbar button images must be 20 x 20 pixels in size.             
 l The color (R:192, G:192, B:192) maps to the system 3D face color.             
 l The color (R:128, G:128, B:128) maps to the system 3D Shadow color.             
 l The color (R:223, G:223, B:223) maps to the system 3D light color.             

IMPORTING CUSTOM CONFIGURATIONS

Toolbar Configurations can be imported into the program, allowing you to transfer custom configurations between 
computers as well as add backed up configurations to new installations.          

To import a custom configuration

 1.  Go to the Configurations tab of the Toolbar Customization dialog.             

 2.  Click Add.             

 3.  Browse to the location of the toolbar you want to import.             

 4.  Click Open. If the .toolbar file is not in the Home Designer Pro 2025 Toolbars folder, a copy of the file will be 
created there.             

 

Toolbar Customization Dialog
Select Tools> Toolbars and Hotkeys> Customize Toolbars to open the Toolbar Customization dialog. You can 
also right-click in an empty space in any toolbar and select Customize Toolbars from the contextual menu.

In the Toolbar Customization dialog, you can:

 l Add and remove buttons from toolbars.
 l Specify which toolbars display in different view types. 
 l Select the active Toolbar Configuration.

The Toolbar Customization Specification dialog has the following panels:

TOOLS PANEL

From the TOOLS panel, you can add or remove buttons from your toolbars, as well as create new toolbars.
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View Type

Select the View Type that you would like to add toolbar buttons to. When the dialog is first opened, the selected View Type 
is that of the current view. If you select a different View Type, the toolbars associated with it will display behind the dialog 
for reference until you click the Done button.         

 
Available Toolbar Buttons

The Available Toolbar Buttons display in a list that can be searched or browsed.         

 l Type a keyword or the name of a tool in the Search field. As you type, only buttons that match your search will 
display. 
When nothing is typed in this field, all buttons will display in the list. 
If a child tool matches your search, its parent will display in the search results. Click the arrow next to the parent’s 
name to see the child tools.         

 l The Available Toolbar Buttons list can be browsed using the scrollbar to the right.          

 l Click on a button in the list to display a description of that tool, below.          

 l Parent tools have an arrow to the right of their button icon in the list. Click on this arrow to display the child tools 
below the parent. See Toolbar Arrangement on page 91.          

If you do not see a particular button in the list, it may be the child of a parent tool.

 
Tool Description

When a button is selected in the list above, a description of it displays here.         

TOOLBAR PANEL

The TOOLBAR panel allows you to manage the use of individual toolbars.         
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View Type

When this dialog is first opened, the selected View Type is that of the current view. If you select a different View Type, the 
toolbars associated with it will display behind the dialog for reference until you click the Done button.         

 
Toolbars

The Toolbars table displays the names of all available toolbars, along with the View Types in which they are in use.         

 l Select a toolbar by clicking on its name.          

 l Click to place a check mark in a column to add the selected toolbar to that View Type; click on check mark to 
remove it.         

 l Double-click on a toolbar in the Toolbar Name column to rename it. Toolbar names must be unique.         

 l Click Delete to remove the selected toolbar from the list. A deleted toolbar is no longer available in any View Type.         

 l Click Reset Toolbars to restore all the toolbars to their original configuration. See Restoring Toolbars on page 95.          

Clicking the Reset Toolbars button removes all changes that you 
may have made to all installed Toolbar Configurations.

CONFIGURATIONS PANEL

The CONFIGURATIONS panel allows you to add, remove, and switch between Toolbar Configurations. See Toolbar 
Configurations on page 92.
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A list of Toolbar Configurations displays here. Select a configuration before clicking the Remove, Copy, or Switch To 
buttons.         

 l Click Switch To to switch to the selected Toolbar Configuration, making it active. See To switch toolbar 
configurations on page 92.

 l Click Copy to create a copy of the selected Toolbar Configuration.          
 l Click Remove to remove the selected Toolbar Configuration. This removes the configuration from the list but does not 

delete the configuration file permanently. If only one configuration is listed, it cannot be deleted.          
 l The location of the Current Toolbars Folder displays below. See Home Designer Pro Data on page 35.         

 

Hotkeys
Many Home Designer tools have a keyboard shortcut, or hotkey, associated with them. If such a hotkey exists, it will 
display to the right of the tool’s name in the menu.

Tools in the Edit menu with tool icons to the 
left of their names and hotkeys to the right.

To use a hotkey, simply press the appropriate key or combination of keys instead of selecting the menu item or clicking the 
toolbar button. For example, press the Ctrl/⌘  and Z keys at the same time to perform an Undo .

Note: If a key or key combination is in use as a system hotkey, it cannot 
be used as a program hotkey.   

CREATE HOTKEY LIST

A list of the hotkeys available to the current program user can be saved in .html or .xhtml format.    

Select Tools> Toolbars and Hotkeys> Create Hotkey List to open the Save Hotkey List File dialog, a standard Save 
dialog, and create a hotkey list that can then be opened in a web browser window and printed, if you wish.    
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Gamepad Settings Dialog
The Gamepad Settings dialog allows you to specify thumbstick behavior in Home Designer. Select Tools> 
Customize Gamepad to open this dialog. See Gamepads on page 787.

You can also open this dialog by clicking the Gamepad Settings button, which you can add to your toolbars. See To add a 
button to a toolbar on page 93.

You can also specify whether navigation is centered about the location of the camera or its focal point in the Preferences 
dialog. See Render Panel on page 86. 

 
Enable Gamepad

Check this box to allow Home Designer to recognize a gamepad on your system and enable the other settings in this dialog.         

 
Speed

When Linear Acceleration is checked, camera acceleration is always directly proportional to the amount the thumbstick is 
pushed. When unchecked, acceleration is increased on a curve, allowing more precision on the low end, and more speed on 
the high end.

  Left Thumbstick

 l When Change Camera Height When Moving in 3D, the left thumbstick can be used to change the camera height 
in 3D. Uncheck this to maintain a consistent camera height instead.    

 l Use the slider bar or text field to specify the 2D Sensitivity, which controls how quickly the view pans in plan and 
elevation views.    
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 l Use the slider bar or text field to specify the 3D Sensitivity, which controls how quickly the camera moves in 3D 
views.

 l Use the slider bar or text field to specify the 2D Smooth Acceleration, which controls how the speed at which 
acceleration and deceleration occur in 2D views.

 l Use the slider bar or text field to specify the 3D Smooth Acceleration, which controls the speed at which 
acceleration and deceleration occur in 3D views.

  Right Thumbstick

 l When Invert X-Axis in 3D is unchecked, pushing the right thumbstick to the left rotates the camera to the left. 
When checked, pushing this thumbstick to the left rotates the camera to the right.    

 l When Invert Y-Axis in 3D is unchecked, pushing the right thumbstick to the up rotates the camera upward. When 
checked, pushing the thumbstick up rotates the camera downward.    

 l Use the slider bar or text field to specify the 2D Sensitivity, which controls how quickly the view zooms in plan and 
elevation views.    

 l Use the slider bar or text field to specify the 3D Sensitivity, which controls how quickly the camera rotates in 3D 
views. 

 
Reset Thumbsticks

Click this button to restore the default Left and Right Thumbsticks settings. 
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Chapter 6
 

Window and View Tools

The View and Window Tools let you control how views of your drawing are shown on screen, as well as toggle useful 
drawing aides on and off.

By default, Pro uses a tabbed document interface. The name of the file and the type of view displays at the top of each view 
window in its title bar. If the view is saved, its name also displays. 

TOPICS

View Windows 103
Plan Views 104
Working in Multiple Views 105
View Tools 107
Zoom Tools 108
Fill Window 109
Panning the Display 109
Closing Views and Files 110
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View Windows
In Home Designer Pro, there are several different types of views:

 l Plan Views, see page 104
 l 3D Views, see page 770
 l Cross Section/Elevation Views, see page 776
 l Materials Lists, see page 950
 l Layout, see page 970

Each view displays in a view window. While multiple views can be open and display on screen, only one view window can 
be active at any given time. See Working in Multiple Views on page 105. 

 l Plan, 3D, and cross section/elevation views are found in plan files only. Each view window can show the model from 
a different perspective and display a unique set of information about it, making them useful for a variety of drawing 
tasks and print requirements.             

 l Materials Lists are found in plan files only and contain a list of objects found in the model along with their 
components and information like floor level and counts.           

 l Layout files are composed of five pages. A given layout view window can only display a single page at a time.             

COORDINATE SYSTEM INDICATORS

In Home Designer, the drawing area is laid out on a Cartesian grid, a three dimensional coordinate system described using 
the X, Y, and Z axes. As a reference, you can display one or more Coordinate and Origin Indicators in your views to help 
locate your model within this system. This can be particularly helpful in camera views or if you have rotated your drawing.

There are three types of Coordinate System Indicator:

  The Floating Axes Indicator is always present at the lower left corner of a view window, regardless of the 
drawing space coordinates currently showing in the view. The length of the floating axes can be specified.

  The Fixed Axes Indicator is always present at the drawing space Origin: 0,0,0 (0,0 in plan views, CAD Details, 
and layout) and may or may not be visible in the current view, depending on its extents. When visible, the fixed 

axes extend to the edges of the view window.
  The Origin Indicator crosshairs are always present at the drawing space Origin. They are of a fixed size and 
may or may not be visible in the current view.

These Coordinate System Indicators can be turned on or off for different view types in the Preferences dialog. They can also 
be toggled on or off using the View menu, as well as using the toggle buttons that can be added to the toolbars. See 
Coordinate System Panel on page 80.

The Coordinate System Indicators are an on-screen reference only: they are not included when a view is printed, exported, 
or sent to layout.

You can specify that any camera, cross section/elevation view, or Materials List be saved. See Saving 3D Views on page 
800.         

When a view is saved, all of its attributes are retained, including the:          

 l Floor level         
 l Extents of the view         
 l Color toggle         
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COORDINATE SYSTEM INDICATORS

In Home Designer, the drawing area is laid out on a Cartesian grid: a three dimensional coordinate system described using 
the X, Y, and Z axes. Indicators for these axes as well as the drawing space origin at (0,0,0) can be set to display in a 
variety of view types to help you visualize your drawing's position and orientation in the coordinate system.          

There are three types of Coordinate System Indicator:

 l The Floating Axes Indicator is always present at the lower left corner of a view window, regardless of the 
drawing space coordinates currently showing in the view. The length of the floating axes can be specified.

 l The Fixed Axes Indicator is always present at the drawing space Origin: 0,0,0 (0,0 in plan views, 
CAD Details, and layout) and may or may not be visible in the current view, depending on its extents. When 

visible, the fixed axes extend to the edges of the view window.
 l The Origin Indicator crosshairs are always present at the drawing space Origin. They are of a fixed size and 

may or may not be visible in the current view.

You can specify which indicator(s) display in several different view types as well as control aspects of the indicators' 
appearance in the Preferences dialog. See Coordinate System Panel on page 80.

VIEW SPECIFICATION DIALOGS

These view types have a specification dialog that allows you to various aspects of its content:         

 l Camera Specification Dialogs, see page 801
 l Cross Section/Elevation Specification Dialogs, see page 809
 l Materials List Specification Dialog, see page 954

 

Plan Views
Plan view is where most drawing and editing is done, and when you open a new plan file, a plan view is active. When an 
existing plan file is opened, the floor level, view extents, and Color toggle setting that were in use in the active plan view 
the last time the plan was saved will all be used.

You can create additional plan views for use during the current program session: select Tools> New Plan View . Each 

plan view that you create can show a different floor and have different view extents and Color setting.   

NEW PLAN VIEW

To create a new plan view, select Tools> New Plan View. An identical copy of the current plan view is created and 
will become the active view. 

ROTATE PLAN VIEW

To rotate everything in a plan view, including all objects on all floors, the Snap and Reference Grids, the plan’s 
Cartesian coordinates, and the drawing sheet, select Tools> Rotate Plan View to open the Rotate Plan View dialog. 

See 3D Drafting on page 12.       
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Enter the degrees to rotate the plan view to using decimal units with either positive or negative values. The degrees rotated 
displays in ±180º format. For example, if you enter 270º, it displays as -90º when the dialog is reopened.          

Rotate Plan View  rotates a plan relative to its original orientation. For example, entering 90º twice results in a rotation 

of 90º, not 180º.          

Text objects rotate with the plan unless you uncheck Rotate with Plan in the Text Specification dialog for each object. See 
Rich Text Specification Dialog on page 352.          

The Rotate Plan View tool does not rotate objects; it literally 
rotates only your view of those objects. As a result, it does not 

alter the orientation of the plan in layout views or on the printed page. 

REVERSE PLAN

The Reverse Plan tool is a quick way to mirror a plan so that everything on all floors of the entire plan is swapped 
left to right.   

Select Tools> Reverse Plan to reflect an entire plan right to left, as though it were flipped about a vertical line.   

Reversing a plan rebuilds the entire model and affects views sent to layout.   

 

Working in Multiple Views
Although only one layout file can be open at a time, there is no limit to the number of plan files that can be open, nor is 
there a limit to the number of view windows that can be open. The name of the file and the type of view is stated at the top 
of each view window in its title bar as well as in its tab. If the view is saved, its name displays instead of the view type. 

By default, Home Designer uses a tabbed document interface, which means that when more than one view window is open 
in the program window, each open window will have a tab that displays in a row above the currently active view.

 l Each tab states the name of the file, the view type, and the view’s name.
 l Each tab features an icon indicating its type of view. 
 l Click on a tab to make it the active view.
 l If there is not enough room in the program window to display all tabs, left and right arrow buttons allow you to scroll 

through the tabs.
 l Tabs can be reordered by clicking and dragging.

There is no limit to the number of 3D view windows that you can have open at a given time; bear in mind, though, that each 
window demands use of your computer’s resources and that you may see poor performance if too many views are open. See 
3D Views on page 770.

There are several ways to close a view window. See Closing Views and Files on page 110.

TILING VIEWS

As an alternative to tabbed views, windows can instead be tiled. Tiling allows you to display multiple views in 
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a single Pro window so you can see the results of changes in plan view in 3D or vice versa. It can also be useful for copying 
objects from one plan to another. 

There are several ways to create tiled views:

 l Click and drag a view window’s title bar or tab into the part of the drawing area that you would like it to be. When a 
highlighted space is created, release the mouse button. 

 l Select Window> Tile Horizontally  to display views in a horizontal orientation, one above the other. 

 l Select Window> Tile Vertically  or press Shift + F6 to display views in a vertical, side by side, orientation. 

Views are tiled left to right or top to bottom in the order in which they were last active: the most recent view is on the left or 
at the top, while least recent is on the right or on the bottom. 

 l To activate a view, click on its title bar or anywhere in the view window. Note that any changes you make in the 
active window are reflected in other views as well.

 l To end window tiling, select Window> Tab Windows. You can also end tiling by double-clicking on the title bar of 
the program window.

MULTIPLE PROGRAM WINDOWS

To create a second program window, click and drag the title bar or tab of a view window completely out of the current 
program window: for example, onto a second monitor.  A second Pro program window will be created with its own menu 
and toolbars. 

SWAPPING VIEWS

There are a number of ways to switch between open view windows:

 l Click on a view window’s tab.
 l Select Window> Swap Views  or press the F7 key to switch between the two most recent views.          

 l The Swap Views  button toggles between the current view and the view that was current before it.           

 l Select Window> Select Next Tab  or Window> Select Previous Tab  to cycle through all open views in the 

order you prefer. 
 l In Windows®, press the Ctrl + Tab (Next Window) or Ctrl + Shift + Tab (Previous Window) keys to cycle through all 

open views. 
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 l In macOS™, press the ⌘  + } (Next Window) or ⌘  + Shift + { (Previous Window) keys to cycle through all open 
views. 

 l A list of all the views currently open is located at the bottom of the Window menu. Each view is identified by its name 
and what type of view it is. A check mark is beside the view that is currently active. Select one to go directly to that 
view. 

If more than eight view windows are open, More Windows will be the last item in the Window menu. Select this option to 
open the Select Window dialog:

Select the name of a view in the list and click OK to make it the active view.

Note: The Window Menu Tools parent button can be added to the 
toolbars. See Toolbar Customization Dialog on page 96. 

 

View Tools
The View Tools allow you to open and close the program’s side windows, as well as toggle a variety of references and 
drawing aides. Select the View menu to access these tools. You can also add the View Tools parent button or any of its 
child tools to your toolbars. See Adding and Removing Buttons on page 93.

  Refresh Display redraws the current window to clean up extra lines, show missing items, and correct random 
on-screen effects caused by changes to the model. See Refresh Display on page 130.

  Library Browser opens and closes the Library Browser side window. See The Library on page 691.

  Tool Palette opens and closes the Tool Palette, which will display related tools. See Child Tool Palette on page 
91.

  Status Bar displays or suppresses the Status Bar at the bottom of the program window. See The Status Bar on 
page 24.         

  Scrollbars displays and suppresses scrollbars on view windows. See View Windows on page 16. 

  Toolbars displays and hides the program’s toolbars. See Toolbars and Hotkeys on page 90.         

  Color toggles the display of color in the current view. See Color On/Off on page 130.

  Crosshairs toggles the use of the blue crosshairs centered on the mouse pointer in most views. 

  Coordinate System Indicator - Floating toggles the Floating Axes Indicator in views of the current type in all 
files. See Coordinate System Indicators on page 104. 

  Coordinate System Indicator - Fixed toggles the Fixed Axes Indicator in views of the current type in all files 
and can be added to the toolbars. 

  Coordinate System Indicator - Origin toggles the Origin Indicator in views of the current type in all files and 
can be added to the toolbars. 

  Reference Grid toggles the display of the Reference Grid in all views in the current plan or layout file. See Grid 
Snaps on page 116.

  Temporary Dimensions toggles the use of Temporary Dimensions when objects are selected. See Temporary 
Dimensions on page 333. 

  Arc Centers and Ends toggles the display of Arc Centers and Ends in the current view. See Arc Centers and 
Ends on page 153.
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  Line Weights toggles the display of Line Weights in all views in which lines are drawn. See Line Weights on 
page 992.

  Drawing Sheet toggles the display of the drawing sheet. See Print Preview on page 991. 

  Watermarks toggles the display of the current plan or layout file's watermark. See Watermarks on page 998.             

 

Zoom Tools
Zoom is used to magnify any given area on the plan or 3D view. Select Window> Zoom, then click and drag a 
marquee around an area on screen. When you release the mouse, the selected area expands to fill the screen. 

Note that in 3D views, using Zoom does not reposition the camera. This can lead to inconsistencies between a camera’s 
position and what is actually shown in the view if other methods of zooming are used later. See Navigating in Camera 
Views on page 785.

When the zoom is complete, whatever tool was active prior to selecting the  Zoom tool automatically becomes active again. 
If another zoom is needed, click the  Zoom tool again.

These additional commands are also found in the Window menu:

  Zoom In - Click to zoom in towards the screen center by a factor of two.

  Zoom Out - Click to zoom out from the screen center by a factor of two.

  Undo Zoom - Reverse the last zoom or fill window operation. This option is also found in the contextual menu, 
as is the Zoom tool. See Menus, Toolbars, and Hotkeys on page 17.

  Fill Window Selected Objects - Fits all selected items on screen.

  Fill Window Building Only - Fits all walls and railings on the current floor on screen. 

  Fill Window - Fits all visible items on screen. See Fill Window on page 109.

Note: Undo and Redo do not affect zoom.

ZOOMING WITH THE MOUSE WHEEL

Use the mouse wheel to zoom in and out in all view windows. Scrolling the mouse wheel one click up or down 
zooms in or out, centering on the location of your pointer and changing the zoom by about 10%.

By default, zooming in 3D views changes the camera’s position. See Mouse Scroll Wheel and Trackpad on page 786.

Note: Depending on the configuration of your mouse, it may be 
necessary to hold down the Ctrl/⌘  key while turning the mouse wheel. 
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Fill Window
In plan view or a cross section/elevation view, select Window> Fill Window or press the F6 key to view nearly 
everything on screen that is visible, including the Reference Display. CAD Points are the only objects that are not 

included when Fill Window is used. 

If you are zoomed in so that only a portion of the drawing displays on screen, selecting Fill Window zooms out so that the 
entire view fits on the screen. If you are zoomed out so that the entire drawing is smaller than the screen, selecting  Fill 
Window zooms in until the drawing fills the screen.

When the drawing sheet is shown, Fill Window zooms to the sheet borders.

FILL WINDOW SELECTED OBJECTS

Window> Fill Window Selected Objects is similar to Fill Window, but zooms in or out so that the current selected 
object or objects fill the current window. See Selecting Multiple Objects on page 145.

FILL WINDOW BUILDING ONLY

Window> Fill Window Building Only is similar to Fill Window, but zooms in or out to so that all walls, railings, 
and roof planes in the view fill the current window. These objects are included in the extents of the view even if their 

layers are turned off. Other objects are ignored.

IN 3D VIEWS

The Fill Window tools behave slightly differently in perspective and orthographic 3D views. In perspective views, the 
original zoom factor is restored, while in orthographic views the camera’s Field of View is adjusted so that all surfaces in 
the 3D view are included. 

 

Panning the Display
There are a number of ways to pan the display without changing the zoom factor.

USING THE ARROW KEYS

In plan view, the Arrow keys work exactly like clicking the Arrow buttons on the scrollbar. They shift the display according 
to the number of inches defined in the Plan Defaults dialog.

USING THE MOUSE

If you have a wheel mouse, you can pan the display by pressing the middle mouse button, or wheel, and moving the mouse 
in the direction you would like to pan. When the middle mouse button is held down, the pointer changes to a hand   icon. 

In the Mac version of Home Designer, you can pan using the left mouse button and Option key. 

Mouse drivers sometimes have other functions assigned to the wheel and buttons. These override the Home Designer 
setting.

USING A MAC TRACKPAD

In the Mac version of Home Designer, you can two finger drag to pan the display. See Trackpads on page 14. 
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USING THE PAN WINDOW TOOL

The Pan Window tool works much like the mouse wheel method.

 l Select Window> Pan Window. The pointer changes to a hand   icon. Click and drag to pan the window. The 
program reverts to the previously active tool when you release the mouse button.

 l Double-click the Pan Window tool and the command remains active.     

USING THE SCROLLBARS

One method is to use the scrollbars on the right and bottom edges of the window. See View Windows on page 16.

 l Click the end arrow keys on the scrollbars to shift the display in 12" increments. 
 l The 12" increment is defined in the Plan Defaults dialog under Inches Scrolled by Arrow Key. See General Plan 

Defaults Dialog on page 60.         

 

Closing Views and Files
If a view is still needed, you can swap to a different view without closing it. If, however, a view is no longer needed, it can 
be closed. There are several ways to close a view window:

 l Select File> Close View to close the active window. 
 l Press Ctrl/⌘  + W or Ctrl/⌘  + F4 to close the active window.
 l Click the Close button in the active view’s title bar or in any view’s tab.
 l A tabbed view can be closed by clicking on its tab using the middle mouse button.
 l Select File> Close All 3D Views  to close all currently open camera view windows instead of just the active 

window. 
 l Select File> Close All Views to close all currently open view windows instead of just the active window. 

If a plan has only one view window open and you try to close it, the program will prompt you to save before closing if there 
are any unsaved changes. Edited cross section/elevation and saved plan views also prompt you to save before closing. See 
Saving Plan and Layout Files on page 38.

Although the program warns you if you try to exit without 
saving, you should get in the habit of saving plan files before 

exiting. 

Even if all view windows are closed, the program can still be open. See Exiting Home Designer on page 47. 
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Chapter 7
 

Creating Objects

There are a wide variety of objects in Home Designer that you can use to create complete 3D models and working drawings. 
Although these objects are sometimes very different from one another, the methods used to create them are similar. 

Once an object is created, it can be selected and edited to meet the requirements of your project. The editing characteristics 
common to most objects are described elsewhere. See Editing Objects on page 137.
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Architectural vs CAD Objects
There are two broad categories of objects in Home Designer: architectural objects and CAD objects.          

CAD objects such as  lines, arcs, text, and dimensions are 2D objects that can be created and edited in plan view, cross 
section/elevation views, and on layout pages but do not display in 3D camera views and overviews. See The CAD Drawing 
Tools on page 199.

In contrast, architectural objects such as walls, cabinets, doors, windows, and stairs display in 2D and 3D views.              
Architectural objects can be created and edited in 2D and 3D views but not on layout pages.

Some architectural objects, such as custom countertops and slabs, have some behaviors in common with CAD objects and 
are referred to as CAD-based.         

 

Defaults and Preferences
The ways that objects in the program behave as they are created and edited are affected by a number of default and 
preference settings. See Preferences and Default Settings on page 56.          

It is a good idea to be familiar with these options and how they 
affect both drawing and editing in the program.             

SNAP SETTINGS

Select Edit> Snap Settings to access the three categories of Snap Settings that determine how objects snap to one 
another and whether they snap to allowed angles or to points on a grid, as well as object bumping and pushing 

behaviors.         

The available Snap Settings are:

  Object Snaps - enables snapping to objects. See Object Snaps on page 114.         

  Angle Snaps - enables snapping at Allowed Angles. See Angle Snaps on page 115.         

  Grid Snaps - enables snapping to the Snap Grid.  See Grid Snaps on page 116.          

  Bumping/Pushing - enables bumping and pushing behaviors. See Bumping/Pushing on page 168.         

EDIT BEHAVIORS

Select Edit> Edit Behaviors to access the six global edit behavior modes that determine how dragging the edit 
handles with the left mouse button affects a selected object and may also affect how objects are drawn.          

The available Edit Behaviors are:

  Default - provides the most commonly used editing options. See Default on page 138.         

  Alternate - provides an alternative to the Default behaviors that may be more useful in some situations. See 
Alternate on page 139.         
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  Resize - scales an object as you drag a corner handle. See Resize on page 139.         

  Concentric - allows you to resize objects so that the distance moved by each edge is the same as all other edges. 
See Concentric on page 140.         

  Fillet - allows you to add a fillet at any corner of an object. See Fillet on page 141.         

CONNECT CAD SEGMENTS

Select Edit> Edit Behaviors> Connect CAD Segments to toggle the ability to edit the individual segments of 
polyline-based objects and connected walls. See Disconnect Edges on page 144.

Unlike Object Snaps, Connect CAD Segments also affects the ability to snap line- and arc-based objects together as they are 
drawn to form a polyline. See Object Snaps on page 114.

ROTATE/RESIZE ABOUT

Objects can be rotated or resized about either their own centers or the Current CAD point. See Rotate/Resize About 
on page 179.          

Specify which behavior is used by selecting Edit> Edit Behaviors> Rotate/Resize About Current Point  or in the 

Preferences dialog. See Behaviors Panel on page 81.           

ARC CREATION MODES

Select Edit> Arc Creation Modes to access the five Arc Creation Modes that control how arcs and curved walls are 
drawn.         

The available Arc Creation Modes are:

  Free Form Arc - mode allows you to define an arc by clicking and dragging along the desired path. See Free 
Form Arc on page 211.         

  Arc About Center - mode allows you to draw an arc by defining the center and then the start and end points. 
See Arc About Center on page 211.         

 

Snap Behaviors
There are three categories of snap behavior in Home Designer that affect how objects are created and how they can be 
edited: 

  Object Snaps, which snap CAD and architectural objects to other objects. See Object Snaps on page 114.

  Angle Snaps, which snap objects at specific angles. See Angle Snaps on page 115.

  Grid Snaps, which snap objects to points on a grid. See Grid Snaps on page 116.

Snap behaviors can be controlled in the Preferences dialog and in the Plan or Layout Defaults dialogs.
See Snap Properties Panel on page 82 and General Plan Defaults Dialog on page 60.          

You can select Edit> Snap Settings  to quickly turn Object, Angle and Grid Snaps on or off. 

To temporarily disable Snap Behaviors and other move restrictions, press the Ctrl/⌘  key while dragging an edit handle.
See Moving Objects on page 167.   
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HOTKEYS

You can also temporarily enable individual Snap Behaviors during a mouse editing operation using hotkeys. This can be 
helpful if you wish to use one particular type of snap behavior when you begin an operation, but a different behavior when 
you end it.           

The Snap Behavior hotkeys are listed on the right side of the Edit> Snap Settings  submenu.

See Hotkeys on page 99.          

To use snap behavior hotkeys

 1.  Select Edit> Snap Settings  and toggle off the snap behavior category that you wish to control using hotkeys.          

 2.  Select a tool that you wish to draw with or an object you wish to edit.          

 3.  Begin drawing or editing and hold down the left mouse button without releasing.          

 4.  Press and hold the appropriate key on your keyboard to enable the snap behavior associated with it.           

 5.  When you are finished using the snap behavior, release the hotkey but continue holding down your left mouse 
button.          

 6.  If you wish, you can press and hold a different hotkey on your keyboard and continue the drawing or editing 
operation.          

 7.  When you are finished, release the left mouse button.          

 

Object Snaps
Object Snaps allow you to position objects precisely relative to each other; for example, to position lines so that 
their endpoints meet or roof plane edges so that they are collinear.

Object Snaps can be turned on or off by selecting Edit> Snap Settings> Object Snaps , by clicking the toggle button, 

or in the Preferences dialog. See Snap Properties Panel on page 82.

Object Snaps are indicated visually as you create or edit objects. To remove any object snap indicators that are visible on 
screen, press the 1 (one) key. As you continue drawing or editing, new indicators may appear.          

With the exception of On Object  snaps, Object Snaps have priority over all other types of snapping in Home Designer. 

Bumping/Pushing  overrides Object Snaps, however. See Bumping/Pushing on page 168.          

OBJECT SNAP LOCATIONS

There are many locations on an object that other objects can snap to. Each type of object snap can be toggled by selecting 
Edit> Snap Settings  or in the Preferences dialog. See Snap Properties Panel on page 82.

Regardless of which Object Snaps are active, when multiple objects are selected the selection set’s only snap point is its 
midpoint.

EXTENSION SNAPS

Extension snaps allow you to snap to a point that is not actually on an object. Instead, these snaps locate points that are 
either collinear to the end of a wall or orthogonal (at a 90° angle) to it.         
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Extension snaps function when you are drawing or editing walls and create a “sticky point” and blue extension line where 
the wall being drawn reaches a point that is either collinear or orthogonal to another wall’s end point. See Creating Walls on 
page 241.         

OBJECT SNAPS HOTKEYS

 l Hold down the “S” key to temporarily disable Object Snaps.              

 

Angle Snaps
It is often important that objects be drawn at exact angles. This can be accomplished using Angle Snaps. Angle 
Snaps allow you to draw walls, lines, and other objects at specified Allowed Angles. Angle Snaps also affect the way 

objects rotate, the radius of arcs, and a variety of other operations.

You can specify whether Angle Snaps use 15° increments or 7.5° increments plus any additional Allowed Angles that you 
may specify. See General Plan Defaults Dialog on page 60.           

Angle Snaps can be turned on or off by selecting Edit> Snap Settings> Angle Snaps , by clicking the toggle button, or 

in the Preferences dialog. See Snap Properties Panel on page 82. 

Because drawing at regular angles is extremely important, when Angle Snaps are disabled, the Angle Snaps   icon will 
display near and follow the pointer. See Pointer Icons on page 15.

ANGLE SNAP SETTINGS

You can change Allowed Angle settings for Angle Snaps in the Plan Defaults or Layout Defaults dialog. See General Plan 
Defaults Dialog on page 60.         

Specify 15 Degree or 7 ½ Degree angle snaps. You can also specify Additional Angles.           

ANGLE SNAPS AND OBJECT SNAPS

Angle Snaps have a higher priority than Grid Snaps and On Object Snaps , but a lower priority to all other Object 

Snaps. If a valid Object Snap exists, the program uses that instead of an Angle Snap.           

Walls are an exception to this snapping prioritization. When 
walls are drawn or edited, Angle Snaps take higher priority than 

Object Snaps. See Creating Walls on page 241. 

Sometimes both Angle Snaps and Object Snaps apply. For example, suppose a CAD line is drawn at 15°  using Angle Snaps 
and another line is approached. You can draw the new line at 15° using Intersection Snaps  to snap to a point on the 

existing line.           

Use Object Snapping and Angle Snapping to 
draw a line at a 15° angle that intersects and 

existing line
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Now suppose that we don't want the new line to end on the existing line. Hold down the “S” key to temporarily disable 
Object Snaps, allowing only Angle Snaps. 

 

Grid Snaps
Grid Snaps allow you to snap objects to points on an on-screen grid as they are created, moved, and resized. See 
Moving Objects on page 167 and Resizing Objects on page 173.

It is recommended that you draw and position the exterior walls of your plan with Grid Snaps enabled. Once these walls 
are in place, you may choose to turn Grid Snaps off to finish the rest of the drawing.          

Grid Snaps are turned on and off by selecting Edit> Snap Settings> Grid Snaps, by clicking the toggle button, or in the 
Plan or Layout Defaults dialog. 

REFERENCE GRID

In addition to the Snap Grid, the Reference Grid is provided to give you a visual sense of scale. It is useful for 
zooming in and out, or for general layout guidelines, but is not used for snapping. The Reference Grid can be toggled 

on and off by selecting View> Reference Grid. See View Tools on page 107.         

The appearance and size of the Snap and Reference Grids can be controlled in the Plan Defaults and Layout Defaults 
dialogs. See General Plan Defaults Dialog on page 60. 

GRID SNAPS AND ANGLE SNAPS

Of the three snap behaviors, Grid Snaps have the lowest priority and are overridden by Angle Snaps and Object Snaps. 

When Grid snaps and Angle Snaps are both enabled, objects are drawn and edited using Polar Coordinates. For example, if 
the grid Snap Unit is set to 12" (1 foot), drawing a new wall at an Allowed Angle snaps the wall length to 0", 12", 24", and 
so on.

To draw a line or wall at an Allowed Angle but with unrestricted 
length, disable Grid Snaps and leave Angle Snaps on.

 

Creating Objects
In Home Designer Pro, there are four ways to add new objects to your drawing: by clicking to place an object, by clicking 
and dragging to draw an object, by entering coordinates, or by importing custom symbols, CAD drawings, pictures or 
metafiles.

If you create an object using any of these methods and the layer it will go on is either locked or turned off, the program will 
ask you if you want to unlock or display the layer. Objects can be created on layers that are not set to display, but they 
cannot be created on locked layers. See Object Creation and Layers on page 118.

While the size of the drawing area in Home Designer is limited only by the resources on your computer, it is best to begin 
your drawing near the origin, 0,0. The current position of your mouse pointer displays in the Status Bar at the bottom of the 
program window. See 3D Drafting on page 12.          
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CLICK-TO-CREATE

Many objects, including doors and windows, cabinets, library symbols, text, pictures, and images are created by clicking. 
Select a library object or one of the drawing tools mentioned above, then click in the drawing area to place the object at that 
location. 

Continue clicking to place the selected object until another tool is selected.         

If you click at a location where there is not enough room for the object to be placed, one of two things may happen:         

 l Some objects, notably cabinets, doors, and windows, will resize smaller to fit into the space.          
 l Most objects cannot resize in this manner, so the program will present a warning message indicating that there is not 

sufficient space at the current location.         

When most drawing tools are active or library symbols selected for placement, a preview outline follows your mouse 
pointer, indicating the size and shape of the object to be created. If your pointer is positioned at a location where the object 
cannot be placed, this preview outline will not display.         

As you move the mouse pointer, the center point of the object’s back edge will snap to active snap points when Grid Snaps 
 or Object Snaps  are enabled. See Snap Behaviors on page 113.

Many architectural objects can be created in plan view or any 3D view. In order to place a stand-alone, click-to-create object 
in 3D, it is necessary to click near a wall or within the Terrain Perimeter as these objects help orient the new object within 
the 3D space.          

CLICKING AND DRAGGING

Other objects, including walls and railings, straight stairs, and CAD and CAD-based objects are created by clicking and 
dragging to define either a path or an enclosed area. Select a tool, then click and drag in the drawing area to draw an object 
between your start and end points.

Continue drawing the selected object until another tool is selected.

You can temporarily slow the movement of the mouse as you drag by holding down the Shift key.

You can cancel any click-and-drag drawing operation before it is completed by pressing the Esc key, or by pressing any two 
mouse buttons at the same time. 

Polyline- and Spline-based objects can be created by snapping multiple Line-, Arc-, and/or Spline-based objects together. 
These objects will only snap together to form a polyline or spline if they are on the same layer and share identical attributes 
such as color, line style, and arrow specifications. See Editing Objects on page 137.           

ENTERING COORDINATES

CAD lines, arcs and points can be created using the Input Line, Input Arc and Input Point dialogs. See Input Point on page 
201, Input Line on page 205, or Input Arc on page 211.

AUTO REBUILD

A number of objects, notably foundations, roofs, Attic walls, and framing, can be automatically generated and rebuilt as 
changes are made to the model. Objects created in this manner can be edited just like other objects; however, the Auto 
Rebuild functionality will be disabled.           
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IMPORTING OBJECTS

Custom symbols, CAD drawings, pictures and metafiles can be imported into the program and placed in the drawing area 
with a click. See Importing and Exporting on page 875 and Pictures, Images, and Walkthroughs on page 845.   

CONVERTING OBJECTS

A variety of objects can be created by converting existing CAD objects and many CAD-based objects into another type of 
object. See Converting Objects on page 182.           

OBJECT CREATION AND LAYERS

When it is created, every object is placed on a layer which controls whether and how it displays. See Layers on page 124. 

If you try to create an object on a layer that is not set to display in the current view, the program will ask if you want to turn 
that layer on. See Message Boxes on page 24. 

 l Click Yes to create the object and turn on its layer in the current view.
 l Click No to create the object but leave its layer turned off in the current view. 
 l Click Cancel to not create the object and leave the layer turned off.

If you try to create an object on a layer that is locked, the program will prompt you to unlock the layer. If you choose to 
leave the layer locked, the object will not be created.  See Locking Layers on page 126.          

Similarly, if you try to insert an object into another object that is on a locked layer, nothing will be created. See Inserted 
Objects on page 715.          

 

Copying and Pasting Objects
New objects can also be created by cutting, copying, and pasting existing objects, either individually or in groups. Objects 
can be copied from one floor to another, one view window to another, and one file to another. Because copying uses your 
system’s clipboard, some objects can be pasted into other applications, as well.

Objects created in a plan or layout using U.S. Units should not 
be pasted into a metric file, or vice versa. See Units of 

Measurement on page 36.

Objects cannot be pasted into any views that they cannot be created in normally. For example, CAD objects cannot be 
pasted into a 3D camera view or overview, while Architectural objects cannot be pasted onto a layout page.

Note: Terrain Perimeters can be copied and pasted, but the pasted copy 
will be a Standard Polyline which can then be converted into a Terrain 
Perimeter or other type of polyline. See Convert Polyline on page 182.

There are a number of ways that objects can be cut, copied, and pasted:   

CUT, COPY, AND PASTE

The Cut, Copy, and Paste tools allow you to copy a selection to the system clipboard and then paste it into a different view 
window, onto a different floor level, or even into a different application.
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Select Edit> Cut or press Ctrl/⌘  + X to remove the selected object(s) from the file and save them in the system 
clipboard so that the selection can be pasted in a different location in Home Designer or in another application, 

depending on the type of selection.   

Select Edit> Copy or press Ctrl/⌘  + C to save a copy of the selected object(s) to the system clipboard while 
maintaining the original(s). The selection can then be pasted in a different location in Home Designer or in another 

application, depending on the type of selection.

Select Edit> Paste or press Ctrl/⌘  + V to enable Paste mode, then left- or right-click in the current view to paste the 
selected object(s) previously copied to the system clipboard at that location. If pasting from another application, click 

in the destination view in Home Designer first to make sure it is active. 

To Cut, Copy, and Paste

 1.  Select an object or objects to copy, then:

 l Select Edit> Cut or press Ctrl/⌘  + X to remove the original selection from the file and copy it to the system 
clipboard.

 l Select Edit> Copy or press Ctrl/⌘  + C to copy the selection to the clipboard while retaining the original.

 2.  If you wish to paste the copy in a different view or program window, open that window and click in it to make it 
active.

 3.  Select Edit> Paste from the menu or press Ctrl/⌘  + V. 

 4.  When pasting in Home Designer, the mouse pointer will display the Copy/Paste   icon. Left- or right-click once 
to paste a copy of the object at that location.

If the new object(s) are pasted into Home Designer, they will be selected. Objects pasted in 3D views are selected on their 
top surfaces.

If the selection being pasted consists of text, it is placed in a Text object.

If the selection being pasted is an image, the Paste Image dialog opens.

Specify how you would like to paste the selected image:         

 l Select Backdrop to add the image to a new 3D backdrop in the User Catalog in the library, where it will be selected. 
See 3D Backdrops on page 841.         

 l Select Image to add the image to an Image object in the User Catalog in the library, where it will be selected. See 
Images on page 846.         

 l Select Material to add the image to a new material in the User Catalog in the library, where it will be selected. See 
Creating Materials on page 755.         

 l Select Picture to display the picture in the current plan view. See Pictures on page 852.         
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COPY/PASTE

The Copy/Paste edit tool allows you to copy the selected object(s) to the system clipboard and immediately enable 
the Paste function so that a copy can be made in the current view. Edit handles and a variety of edit tools let you 

control the location, orientation, and size/shape of the pasted object(s).    

To Copy/Paste by clicking

 1.  Select an object or objects to copy.

 2.  Click the Copy/Paste  edit button. The cursor displays the Copy/Paste   icon.

 3.  Left- or right-click once to paste a copy of the selection at that point where you clicked.

The Copy/Paste edit tool can be used in combination with the original selection's edit handles to move, rotate, or reshape the 
copy relative to the original. The available edit handles will vary depending on the type and number of objects selected. See 
Edit Handles on page 23.

To Copy/Paste by dragging

 1.  Select an object or objects to copy.

 2.  Click the Copy/Paste  edit button. The cursor displays the Copy/Paste   icon.

 3.  Click and drag an edit handle:

 l Drag the Move edit handle to position the copy at a new location. As you drag, a preview of the selection follows 
the mouse pointer.

 l CAD lines and some line-based objects have a round Orthogonal Move edit handle. When dragged, movement is 
restricted to directions that are perpendicular to the selected line.

 l Other types of CAD and CAD-based objects have a round Concentric Resize edit handle. Click and drag this 
handle to create a concentric copy that is either larger or smaller than the original.

 l Drag a corner handle to create a copy in the same location as the original but with a different shape or size. The 
result depends on which Edit Behavior  you use. See Defaults, Preferences, and Edit Behaviors on page 138. 

 l Drag the Rotate handle to create a copy in the same location as the original, but rotated to a different angle.

 4.  You can resize or position the copy accurately with respect to the original by watching the moved distance in the 
Status Bar at the bottom of the screen.

The Copy/Paste  edit button activates Paste mode in which each available edit tool and handle makes a copy in addition 

to its primary function and seven new edit buttons display on the Edit Toolbar.

  Click the Sticky Mode edit button to remain in the current mode and place multiple copies of the selected object
(s). See Sticky Mode on page 121, below.

  Click the Paste Hold Position edit button create a copy of the selection at the same location as the original. See 
Paste Hold Position on page 121, below. 

  Click the Point to Point Move edit button to make a copy of the selection at a specific location. See Point to 
Point Move on page 169.         

  Click the Center Object edit button to make a copy of the selection and center it relative to another object. See 
Center Object on page 172.
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  Click the Reflect About Object edit button to make a copy of the selection reflected about another object. See 
Reflect About Object on page 180.         

  Click the Main Edit Mode edit button or press the Esc key to return to the selection's main Edit Toolbar.

To use Copy/Paste with other edit tools

 1.  Select the object(s) to be copied and click the Copy/Paste  edit button.

 2.  Notice that the options in the Edit Toolbar change and include several tools for moving and centering:

 l Click the Point to Point Move  edit button, then click at the start and end points to position the copy at a 

particular point. After your click on the start point, an extension line, selection preview outline, and Point B   
icon follow the mouse pointer.

 l Click the Center Object  edit button, then mouse over the object you want to center the copy relative to and 

click once when the desired centering axis and selection preview outline displays. 

 l Click the Reflect About Object  edit button, then mouse over the object you want to reflect the copy about and 

click once when the desired reflection axis and selection preview outline displays.    

 3.  An exact copy of the selected object(s) is created and is positioned and oriented based on the actions performed 
using the second edit tool.      

STICKY MODE

Normally, after an action is performed using the edit tools or handles while in Paste mode, you  return to the Main 
Edit Mode. Click the Sticky Mode edit button to remain in Paste mode and continue pasting copies of the selected 

object(s). 

To exit Paste mode and return to the main Edit Toolbar for the selected object, click the Main Edit Mode  edit button, 

or press the Esc key. You can also click the Sticky Mode button once more.

PASTE HOLD POSITION

Click the Paste Hold Position edit button to create a copy of the selected object(s) at the same location as the 
original. The copy remains selected so you can perform additional operations.

Because multiple walls, railing and fencing cannot share the same space, the Paste Hold Position  edit button is not 

available for these objects.

When copying between different floors or view windows, you can paste a copy at the same absolute position as the original 
selection using the Paste Hold Position command.

To use Paste Hold Position

 1.  Select the object(s) to be copied.

 2.  Click the Copy/Paste  edit button.

 3.  Switch to the desired floor or plan file and select Edit> Paste> Paste Hold Position .

 4.  A copy is placed at the same X, Y coordinates on the new floor or in the new plan as the original’s position.
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When a CAD-based object is moved to a new floor, only its 
display in plan view is moved - its physical location in the 

model remains unchanged. See Architectural vs CAD Objects on page 
112.

COPY AND PASTE IN PLACE

Select Edit> Copy and Paste in Place to create a copy of the selected object(s) at the same location as the original. 
The copy remains selected so you can perform additional operations.

Because multiple walls, railings, and fencing cannot share the same space, the Copy and Paste in Place command is not 
available for these objects.

PASTE SPECIAL

The Paste Special tool allows you to choose a representation for the selection to be pasted. 

Selections can be pasted as:

 l Enhanced Windows Metafiles (EMF). See Metafiles on page 856. 
 l Device Independent Bitmaps (BMP). See Importing Pictures on page 853.
 l Unformatted non-unicode text (TXT).
 l File Name (a path to a file). Depending on the file type, it will be either opened or imported (if supported). 
 l Unformatted text (HTML). Pastes as text.
 l Model Objects - Home Designer format, not compatible with other programs.

To use Paste Special

 1.  Select an object, image, text or file on your computer and copy it.

 2.  Switch to the desired Home Designer view window and select Edit> Paste> Paste Special .

 3.  In the Paste Special dialog, select the desired representation for the selection and click OK.

 4.  Click in the drawing area to place the copy at that location. 

TRANSFORM/REPLICATE OBJECT

Objects and groups of objects can be copied and pasted using the Transform Replicate Object dialog. See 
Transform/Replicate Object Dialog on page 183.
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Chapter 8
 

Displaying Objects

The way that objects display is an important in all stages of the design process. There are two primary ways that  the display 
of objects is controlled: Drawing Groups and Layers.         

TOPICS

Displaying Objects 124
Layers 124
Layer Attributes 125
Layer Display Options Dialog 127
Layer Sets 128
Drawing Groups 129
Display Toggles 130
Fill Styles 131
Fill Style Panel and Dialogs 132
Select Color Dialog 135
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Displaying Objects
There are two broad categories of objects in Home Designer: architectural objects and CAD objects. See Architectural vs 
CAD Objects on page 112.         

CAD objects are two-dimensional and display only in the view in which they were drawn. Architectural objects, on the 
other hand, are 3D and are represented in 2D and 3D views in different ways.

LAYER SETTINGS

By default, CAD and CAD-based objects use the settings assigned to their layer: including line style, color, and weight. 
They can be assigned custom line attributes in their specification dialogs. See Line and Text Styles on page 126.          

In plan view, architectural objects are represented much like CAD objects, using the attributes assigned to their layer. In 
addition, the edge lines of architectural objects in Vector Views also use these layer settings. See Vector View on page 832.

In addition, layers can be used to turn the display of objects on and off in different views. See Layer Attributes on page 125.
         

FILL STYLES

Closed CAD objects and can also be assigned a fill style for their interior areas. Fill styles may be a solid color or a pattern, 
and can be specified as transparent. See Fill Styles on page 131. 

Many architectural objects              can also be assigned a fill style; however, it is only used in plan view. In 3D views, architectural 
objects are represented using surfaces that have materials assigned to them.         

PATTERNS AND TEXTURES

The appearance of architectural objects in 3D views is determined by the materials applied to the objects’ surfaces. See 
Materials on page 745.         

Material patterns display in Technical Illustration and Vector Views, while textures display in other types of rendered views. 
See Rendering Techniques on page 832.

You can turn the display of patterns on or off in 3D views that use them by selecting 3D> Toggle Patterns .         

 

Layers
Layers are used to organize and manage the display of all objects in all views. A layer can be thought of as a transparent 
sheet with objects placed on it for viewing. Nearly all views use multiple layers, like a stack of transparencies put together 
to show different types of objects. 

You can find out which layer an object is on by selecting the object and looking at the Status Bar. And, you can customize 
how each layer displays in a particular view in the Layer Display Options dialog. See The Status Bar on page 24 and Layer 
Display Options Dialog on page 127.

Multiple layers are organized into Layer Sets, which allow you to control which objects display in different views. See 
Layer Sets on page 128.
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Layer Attributes
The display of objects in different views is controlled by layer sets and layers in the Layer Display Options dialog. See 
Layer Display Options Dialog on page 127.

IN-USE LAYERS

A layer is considered to be in use in the current plan or layout file if one or more objects are assigned to it; if it is selected in 
one or more defaults dialogs; or, if it is a system default layer for one or more drawing tools.           

In the Layer Display Options dialog, the Used column identifies in use layers:          

 Indicates that one or more objects are assigned to the layer.             

 Indicates that there are no objects on the layer, but that it is specified in a defaults dialog.             

 Indicates that the layer is not used elsewhere, but is a system default layer for certain object types.             

Move your mouse pointer over an icon to display a tool tip summarizing where the layer is in use.           

PRIMARY AND SECONDARY LAYERS

Every object is placed on a layer which controls whether it displays in a given view. This layer is referred to as the object’s 
primary layer, and you can see its name in the Status Bar when the object is selected. See The Status Bar on page 24.          

In addition, some objects have secondary layers which may alter the appearance of objects on the primary layer, but do not 
control whether the objects display or not.          

For example, the primary layer for base cabinets is “Cabinets, Base”. In addition, base cabinets have a number of secondary 
layers that control the display of the countertop, face indicators, door opening indicators, module lines and labels.         

Note: If an object’s primary layer is turned off, information on its 
secondary layers will not display - even if those layers are turned on.

All layers with a check in the Disp column display when the current layer set is active. Objects that are not displayed cannot 
be seen or selected. If you try to place or draw an object on a layer that is hidden, the program asks if you want to turn the 
layer on.         

Some objects are designed to be inserted into another object rather than standing alone. If the display of an object that 
contains an inserted object is turned off, the inserted object’s display will be turned off, as well  For example, if the display 
of a wall is turned off, any doors and windows in that wall will not display either. See Inserted Objects on page 715.         

Only displayed objects are included when DXF/DWG and EMF files are exported, and only displayed objects print.         
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LINE AND TEXT STYLES

A layer’s Color, Weight, and Line Style attributes determine how an object on that layer appears in plan view.  See Line 
Weights on page 995.

These attributes also affect Surface Edge Lines in 3D views using the Vector View Rendering Technique. The Color 
attribute is also used for Surface Edge Lines in Technical Illustration renderings. See 3D View Defaults Dialog on page 774.

The Text Style attribute affects the appearance of dimensions, object labels, and objects that can display text such as Room 
Labels, Callouts, and Markers. See Text Styles on page 373.

Many objects, including all CAD and text objects, allow you to override these settings for an individual instance without 
changing its layer. See Line Style Panel on page 209.          

EDGE AND PATTERN LINES

In 3D Vector Views, objects are represented using lines to define their surface edges. By default, Edge Lines use the 
attributes set for the object’s layer, as described above.           

Some CAD-based architectural objects, such as Slabs, have line style settings in their specification dialogs; however, these 
specifications are not used unless Use Object Settings is checked in the 3D View Defaults dialog. See 3D View Defaults 
Dialog on page 774.           

In addition, a material applied to an object surface may have a pattern associated with it. Pattern line color, weight, and 
spacing is set in the Define Material dialog. See Pattern Panel on page 761.           

LOCKING LAYERS

Objects on layers with a lock icon in the Lock column cannot be selected by the user.           

New objects cannot be drawn on a locked layer, either. If you lock a layer and then attempt to draw a new object on that 
layer, a message box will ask you to unlock the layer.           

Layers with objects that you need to see as a reference while working, but not select, are good candidates for locking. For 
example:           

 l Locking the “Rooms” layer can make it easier to select objects located inside rooms.
 l Locking the “Roof Planes” layer can make it easier to select objects located under the eaves.

Another use for locking layers is to protect them from editing in plans opened by clients or others in select Home Designer 
programs. See Opening Chief Architect Plans in Home Designer Programs on page 33.          
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Locking a layer does not prevent objects on that layer from 
being modified. In addition, most objects can be deleted using 

the Delete Objects dialog. Objects are also deleted if the floor they are 
placed on is deleted. See Deleting Objects on page 191. 

 

Layer Display Options Dialog
The Layer Display Options dialog controls the display of layers in the active layer set. From any view except the 
Materials List, select Tools> Display Options to open this dialog. 

The Layer Display Options dialog consists of a table that lists all layers and their attributes.
  Select Tools> Display Options in a layout to open the similar Layout Page Display Options dialog. See Layout Page 

Display Options on page 971. 

To edit the attributes of the Reference Floor Layer Set, click the Define button in the Change Floor/Reference dialog. See 
The Reference Display on page 525.

 
Properties for Current Layer Set

The Properties for Current Layer Set the layer set that is active in the current view are presented in a table of layers and 
their attributes. Click a column header to sort all layers in the table by that column. An arrow above a column indicates that 
it is being used to sort the table, and in which direction it is being sorted. 
The Name column is sorted alphabetically. Layers are named so that similar object types are listed near one another, and 
sorting is case sensitive to allow greater control over organization.               

 l An icon in the Used column indicates that the layer is in use. The information in this column can be sorted, but not 
edited here. See In-Use Layers on page 125.           

 l A check in the Disp column indicates which layers are set to be visible. If a layer is turned off, this column is 
blank.          
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 l A lock icon   in the Lock column indicates which layers are locked, preventing objects on that layer from being 
selected. See Locking Layers on page 126.          

 l The Color column shows the line color for each layer and can be sorted so that like colors are listed together.          

 l The Line Style column shows the line style for each layer and can be sorted so that like line styles are listed 
together.          

 l The Line Weight column displays the line weight used by each layer and can be sorted so that like line weights 
are listed together. See Line Weights on page 995.           

 l The Text Style column shows the text style assigned to each layer and can be sorted so that layers using the same 
style are listed together. See Text Styles on page 373.          

Layers are selected by clicking on them in the table. Hold down the Shift key or the Ctrl/⌘  key to select multiple layers at 
once. Press Ctrl/⌘  + A or click the Select All button to select all layers in the table. When selected, a layer’s attributes 
display and can be edited below.           

The program remembers what layer(s) are selected when you 
click OK and selects them again when you return to this 

dialog.

 
Properties for “Selected Layer”

The Properties for “Selected Layer” options let you modify the attributes of one or more selected layers. Line Color, 
Style, and Size affect lines in plan view and surface edge lines in Vector Views. When multiple layers are selected, “No 
Change” may display for attributes that are not shared by the selected layers.

 l To turn off a selected layer, uncheck Display. See Layer Attributes on page 125.                 

 l To protect the objects on a selected layer from accidental changes, check Lock. Items on locked layers can display 
but cannot be selected. See Locking Layers on page 126.          

 l To change the color of lines on a selected layer, click the Color bar to open the Select Color dialog. See  Select 
Color Dialog on page 135. 

 l Specify the default Line Weight, or thickness, for objects on the selected layer. See Line Weights on page 995.          

 l To change the Line Style of a selected layer, click the drop-down arrow.

 l To change the Text Style of a selected layer, click the drop-down arrow. See Text Styles on page 373.

Note: Not all objects display in all views. For instance, invisible walls do 
not appear in camera views or materials lists.

 

Layer Sets
Layer Sets are used to control the layer settings for different views in a plan or layout file. All views associated with a plan 
file - including views sent to layout - make use of layer sets stored in that .plan file. 

A layer set consists of a complete list of the layers in the current plan or layout along with the display settings for each layer 
as set for a particular type of view. These display settings can be modified, and can be different for each type of view. See 
Layer Display Options Dialog on page 127.

Layer sets are file specific, which means that changes made in one plan or layout file have no effect on the settings in other 
files. 

Home Designer uses a different layer set for each type of view of your plan:
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 l Plan views. See Plan Views on page 104. 
 l Camera views and Overviews. See 3D View Tools on page 775.
 l Cross Section/Elevation views.
 l Wall Elevation Views.
 l Framing Overviews. See Framing Overview on page 778.
 l Reference Floor. See The Reference Display on page 525.

While any view is active, select Tools> Display Options  to make changes to the layer set used for that view type. 

Any changes made to settings in the  Layer Display Options dialog for one particular view will affect all views using that 
same layer set. For example, if you make changes for a camera view, all camera views and overviews in the current plan 
will be affected. See Layer Display Options Dialog on page 127.

 

Drawing Groups
Each object in a plan              or layout file belongs to a Drawing Group, which influences whether it displays in front of or behind 
other objects. Drawing Groups control the display of objects in plan view and on the layout page. They also control the 
display of CAD objects drawn in cross section/elevation views. They do not affect the display of objects in camera views 
and overviews.         

Most categories of objects have their own Drawing Group; however, a few objects are instead placed in the Front or Back 
Group. Imported pictures, which are placed in the Back Group, are a notable example. A selected object’s Drawing Group is 
reported in the Status Bar. See The Status Bar on page 24.          

Within a given Drawing Group, drawing order is determined by the order in which objects are placed. By default, an object 
will display in front of any objects that were created before it was. For example, if you place a chair and then a table, the 
table will display in front of the chair; if you instead place a table and then the chair, the chair will display in front.          

Drawing order also affects how objects are selected. If two objects are positioned so that they overlap one another, and you 
click at a point that they both share, the frontmost object will become selected first. See Select Next Object on page 143.          

DRAWING GROUP EDIT TOOLS

Once an object has been placed, its position in the drawing order can be modified. To do this, select one or more 
objects and click the View Drawing Group Edit Tools edit button.         

There are two options for moving a selection towards the back of the drawing order:          

  Click the Send to Back edit button to move the selected object(s) to the back of the Back Group so it displays 
behind all other objects.         
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  Click the Send Backward edit button to move the selected object(s) to the back of its current Drawing Group. If 
it is already at the back of its current group, it will be moved to the next group down in the drawing order.

There are two options for moving a selection towards the front of the drawing order:          

  Click the Bring to Front edit button to move the selected object(s) to the front of the Front Group so that it 
displays in front of all other objects.          

  Click the Bring Forward edit button to move the selected object(s) to the front of its current Drawing Group. If 
it is already at the front of its current group, it will be moved to the next group up in the drawing order.

SELECT DRAWING GROUP DIALOG

The Select Drawing Group edit button reports the Drawing Group number that the selected object(s) is in. When multiple 
objects are selected, a horizontal line may display instead. Click this button to open the Select Drawing Group dialog.          

 l Select a Drawing Group from the drop-down list to place the selected object(s) into that group. The default group for 
the selected object is noted as such.           

 l When multiple objects in different groups are selected, “No Choice” will initially display. You can select “Default: 
Multiple Values” to return each object to its respective default group.          

 

Display Toggles
There are a number of toggles and tools that can be used to affect the appearance of the on-screen display. 

PRINT PREVIEW

Print Preview and its related display toggles allow you to get a sense of what the current view will look like when it 
is printed. See Print Preview on page 991.

REFRESH DISPLAY

Refresh Display redraws the current window to clean up extra lines, show missing items, and correct random on-
screen effects caused by changes to a model. Select View> Refresh Display or press the F5 key to refresh the on-

screen display. 

COLOR ON/OFF

The display of color on-screen can be toggled on and off in any view by selecting View> Color or by clicking the 
toggle button. 

 l If Color is toggled off in any 3D view other than a Vector View, the view will be displayed in grayscale.
 l If Color is toggled off in any line based view, including plan view, Vector Views,  and layout, the view will be 

displayed  either in black and white or grayscale, depending on the Color Off Is setting in the Preferences dialog. See 
Appearance Panel on page 63.             
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The Color toggle can be set on a view by view basis and can be saved in the Camera Specification and Cross 
Section/Elevation Specification dialogs. See Camera Panel on page 801 and Camera Panel on page 810.

To display views in grayscale

 1.  Select View> Color  to toggle color off.             

 2.  Select Edit> Preferences  to open the Preferences dialog.             

 3.  On the APPEARANCE panel, select Grayscale as the Color Off Is setting. See Appearance Panel on page 63.             

To display views in black and white

 1.  Select View> Color  to toggle color off.    

 2.  Select Edit> Preferences  to open the Preferences dialog.    

 3.  On the APPEARANCE panel, select Black and White as the Color Off Is setting.    

When Color  is toggled off and Black and White is specified, all lines appear as black, regardless of their color. Solid 

fill colors appear as either white or black, depending on which is closer to the actual fill color when Color is turned on. The 
background remains as defined in the Preferences dialog. See Colors Panel on page 65.          

You can specify whether cross section/elevations, camera views, and overviews using the Vector View Rendering 
Technique are generated with colors turned on in the 3D View Defaults dialog. See 3D View Defaults Dialog on page 774.          

You can also print in color, black and white, or grayscale. See Print View Dialog on page 1001.         

ARC CENTERS AND ENDS

The display of arc center- and endpoints, and the display of circle center points can be toggled by selecting View> 
Arc Centers and Ends, by clicking the toggle button, or in the CAD Defaults dialog. See Arc Centers and Ends on 

page 153.         

DELETE SURFACE

In any 3D view, select 3D> Delete Surface, then click a surface in the view to temporarily remove the surface from 
the current view. See Delete 3D Surface on page 785.

 

Fill Styles
Fill styles are CAD-based patterns that can be used to fill the interiors of closed CAD shapes. In plan view, fill styles can 
also be applied to a variety of architectural objects. See Fill Style Panel and Dialogs on page 132.

The Fill Styles library contains fill styles that can be applied to objects individually in their specification dialogs, by default 
in their defaults dialogs, as well as using the Fill Style Painter tools.           

FILL STYLE EYEDROPPER AND PAINTER TOOLS

The Fill Style Eyedropper tool allows you to load a fill style assigned to an existing object into the Fill Style Painter 
and apply that fill style to other eligible objects.         

Select Tools> Fill Style Painter to access the Fill Style Painter tools, which are used to apply fill styles to closed CAD 
objects. In plan view, the Fill Style Painter tools can be used to apply fill styles to a variety of architectural objects, as well.         
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These tools are similar to other Painter Tools in the program. See Eyedropper and Painter Tools on page 189. 

Patterns, which are similar to fill styles, can be used to represent 
materials in Vector Views. See Patterns and Textures on page 

746.

IMPORT PATTERNS

Select File> Import> Import Patterns to open the Import Custom Patterns file and import a .pat file. See Importing 
Files on page 43.

Patterns are imported directly to the User Catalog in the Library Browser. See The User Catalog on page 706.

 

Fill Style Panel and Dialogs
Fill styles are CAD-based patterns that can be used to fill the interiors of closed CAD shapes. In plan view, fill styles can 
also be applied to a variety of architectural objects, symbol objects, and Wall Hatching. See Wall Hatching on page 240.

The FILL STYLE panel is found in the specification dialogs for a variety of objects in the program. This panel is not 
available Electrical Connection splines, Sprinkler Lines, or any object that does not form a closed shape. 

Sprinklers can have more than one fill style. As such, the FILL STYLE panel in their specification dialog does not have 
settings for a single fill style: instead, it lets you access the Fill Style Specification dialog for each of the selected object's 
possible fill styles. See Sprinkler Specification Dialog on page 943.

The settings on this panel are also found in a number of dialogs:

 l To open the Fill Style Specification dialog, right-click on a fill style in the library and select Open Object or right-
click on an unlocked library folder and select New> Fill Style. See Using the Contextual Menu on page 697.

 l You can also create a new fill style by clicking the Add New Fill Style  button in the Select Library Object dialog. 

See Select Library Object Dialog on page 716.
 l To open the Layer Fill Style dialog, click in the Fill column in the Wall Type Definitions or any Material Layers 

Definition dialog. See Wall Type Definitions Dialog on page 264 and Material Layers Definition Dialogs on page 743. 
 l The Spray Area and Sprinkler Symbol Fill Style dialogs can be accessed by clicking the Fill Style button on the FILL 

STYLE panel of the Sprinkler Specification dialog. See Framing Defaults Dialog on page 636.          
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Fill Style Name
 In the Fill Style Specification dialog only, specify the Fill Style Name.

 
Pattern

Select a Pattern Type from the drop-down list and specify its characteristics.         

 l Select “Library” from the list or click the Library button to choose a pattern from the library. When a Library fill 
style is selected, its name will display in the list instead of a system default Type. See Assigned Items on page 716.              

 
Scale

These options vary, depending on whether a system pattern Type or a pattern from the Library is selected, above.    

When a system pattern Type is selected:
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 l Specify the Row Offset of the selected fill pattern. Only available for Grid, Offset and Grid, Step patterns.     

Grid, Offset and Grid, Step patterns: both 
with 1/4 Row Offset

 o For Grid, Offset patterns, the offset alternates back and forth from row to row.

 o For Grid, Step patterns, the offset progresses upward and to the right. 

 l Specify the Width of the selected fill pattern.              For Concrete and Sand fills, instead adjust the overall Spacing. Not 
available for Solid fill.

 l Specify the Height of the selected fill pattern.              Only available for the Grid fill Types, as well as Herringbone and 
U’s.

When a pattern from the Library is selected:

 l Specify an X Scale and Y Scale for the selected fill pattern. Only available when the name of a fill style from the 
library is listed as the fill Type, above.

 
Offsets and Angle

Specify the fill’s Offsets and Angle.         

 l Specify the Horizontal and Vertical Offsets. See Mapping Patterns and Textures on page 756.              

 l Specify the Angle of the selected fill pattern. Not available for Solid fill.         

  Pattern Appearance

 l Set the Line Weight for the selected fill pattern. Not available for “Solid” fill.          

 l Specify a custom Pattern Color for the lines that make up the fill pattern or Solid fill by clicking the color bar. 
The Layer Color is used by default. See Select Color Dialog on page 135.

 l Custom Color is selected automatically if you click the color bar above.         

 l Select Use Layer Color to have the fill pattern use the layer color for the pattern lines or solid fill.              

 l Select Use Background Color to use the view’s background color for the pattern lines or solid fill.             

 l Use the Transparency slider bar or text field to control how transparent the fill pattern lines are. This setting also 
affects the transparency of Solid fill colors.         

 
Background

Check Background to add a solid background color to the fill pattern and enable the settings below. When unchecked, the 
fill pattern has a transparent background. Not available when “Solid” is the selected Pattern Type.          

 l Specify a custom Background Color by clicking the color bar. The Background Color set in the Preferences 
dialog is used by default. See Colors Panel on page 65.

 l Custom Color is selected automatically if you click the color bar above.         
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 l Select Use Layer Color to have the fill pattern use the layer color for the pattern lines or solid fill.              

 l Select Use Background Color to use the view’s background color for the pattern lines or solid fill.             

 l Use the Transparency slider bar or text field to control how transparent the background color is.          

 
Add to Library

On the FILL STYLE panel only, click the Add to Library button to add the fill pattern as it is currently defined to the User 
Catalog. See Add to Library on page 709.             

 
Preview

A preview of the selected pattern displays to the right. As changes are made to the settings on this panel, the preview will 
update.             

 l Choose a Preview Width from the drop-down list. This value controls how large an area the preview represents. The 
selected value indicates the horizontal width of the preview pane in actual plan inches (mm).         

 

Select Color Dialog
The Select Color dialog can be opened by clicking on the Color bar that can be found in many dialogs throughout the 
Windows version of the program. 

Mouse over a Color bar to display a tool tip reporting the 
selected color’s RGB values. 

In the Mac version, the standard Colors dialog, or Color Picker, is used instead.

 
Current Color

The currently selected color displays in the rectangle at the lower center of the dialog. There are a number of ways to select 
a color in this dialog.

 
Basic Colors

Click in any one of the color boxes to select it.
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  Color Spectrum

 l Click anywhere in the color spectrum area to select a color. The location of the selected color is identified by 
crosshairs.     

 l Click anywhere in the vertical bar or drag the arrow to adjust the selected color’s Luminosity and RGB values.    

  Color Definition

 l Define a color by specifying its Hue, Saturation, and Luminosity (HSL) or its Red, Green, and Blue (RGB) 
values.     

 l Specify the color's Opacity. 0% is totally transparent. Only available when Selection and Edit Handle colors are 
being set via the COLORS panel of the Preferences dialog. See Colors Panel on page 65.    

  Custom Colors

 l Click in one of the Custom colors boxes to either select it or to specify it as the box for a new custom color to be 
defined.    

 l Click the Add to Custom Colors button to add the selected color to the Custom Colors group.    

 
Color Chooser Eyedropper

Click this button, then click anywhere on your monitor to select the color displaying at that location.

Click OK to apply the currently selected color to the object’s line or fill style, or to the material’s pattern color. 
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Chapter 9
 

Editing Objects

Just as the methods used to create different objects in Home Designer are similar, the options for moving, rotating, resizing, 
and otherwise editing them are also alike. 

Edit handles allow objects to be resized, relocated, or rotated using the mouse. Edit toolbar buttons and the contextual 
menus access edit tools relevant to the selected object(s). Most objects have a specification dialog that allows you to edit it 
in ways that are specific to that type of object. 

The editing characteristics common to most objects are described in this chapter. Unique, object-specific editing behaviors 
and the specification dialogs are covered in their respective chapters. 
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Defaults, Preferences, and Edit Behaviors
The same defaults and preference settings that affect how objects are drawn also influence how they can be edited. See 
Defaults and Preferences on page 112.          

In addition, the Edit Behavior modes that determine how edit handles affect an object, and may also affect how 
objects are drawn. The currently active Edit Behavior is a global preference setting, affecting all plan and layout files.

         

Two of these modes, Default and Alternate, are useful for most drawing and editing needs and can be considered primary 
editing modes. Default mode, in particular, accesses the most commonly used behaviors and is the best choice in most 
circumstances.

When an Edit Behavior other than Default is active, its icon displays near the mouse pointer. For example, when Connect 
CAD Segments is disabled, CAD objects cannot connect to form polylines and the Connect CAD Segments   icon follows 
the mouse pointer to remind you that this behavior is active. See Pointer Icons on page 15.         

Regardless of which Edit Behavior is active, the Default behavior is restored when you close the program. 

The other modes, Resize, Concentric, and Fillet, offer special editing behaviors that may be useful only in certain situations 
and can be considered secondary. 

Each edit behavior can be temporarily enabled using the different buttons on your mouse or by pressing the keyboard keys 
associated with each. See Using Input Devices on page 13 and Hotkeys on page 99.           

You can also specify which edit behavior mode is active when the left mouse button is used in the Preferences dialog, by 
selecting Edit> Edit Behaviors , or by clicking the corresponding toggle button, which can be added to your toolbar. 

See Behaviors Panel on page 81.          

DEFAULT

The Default mode is one of the primary edit behavior modes. It offers access to the most commonly used edit 
behaviors and should be selected as your preference in most situations.         

When the use of a tool is described in this manual, it is assumed 
that the Default edit behavior mode is active.

 l Drawing - Standard click and drag drawing behavior is enabled. See Creating Objects on page 116.           
 l Resize/Reshape - Default allows you to adjust the angle of any corner of a polyline without affecting adjacent corners, 

changing the object’s shape.           

 l For box-based objects, the Default mode functions the same as the Alternate mode.           

138



Home Designer Pro 2025 Reference Manual - Defaults, Preferences, and Edit Behaviors

 l Movement - Default allows you to move objects orthogonal, or at a right angle, to any of their edges.          
 l Rotation - In Default mode, objects snap at Allowed Angles as they are rotated.          

You can temporarily enable the Default  edit mode when another mode is active by pressing Alt + Z or Alt + / while 

performing an edit or drawing operation.          

ALTERNATE

The Alternate mode is the second primary edit behavior mode. When this mode is active, the Alternate   icon 
displays near the mouse pointer.         

Note: Not all commands have an Alternate edit behavior. If a selected 
tool does not, it will not work when this edit mode is active. 

 l Alternate allows you to drag an end handle on an open polyline to change it from a line to an arc or vice versa.           
 l Alternate overrides the Lock Center  setting of arc-based objects.

 l Movement - Alternate allows you to move objects at Allowed Angles when Angle Snaps  are enabled, or 

orthogonal to any of its edges when they are not. See Angle Snaps on page 115.           
 l Rotation - Alternate snaps objects at Allowed Angles as they are rotated. 
 l Alternate allows you to create a camera view using the Alternate Rendering Technique. See Alternate Rendering 

Technique on page 777.         

You can temporarily enable the Alternate edit mode when another mode is active by pressing Alt or using the right mouse 
button while performing an edit               operation.    

 l Drawing - Standard click and drag drawing behavior is enabled.           
 l Resize/Reshape - Move allows you to move the selected object when any edit handle is used.           
 l Movement - Move mode allows you to move objects at Allowed Angles.          
 l Rotation - In Move mode, objects snap at Allowed Angles as they are rotated.          

RESIZE

The Resize edit behavior allows you to rescale an object. As you drag a corner edit handle of an object, you get an 
exactly scaled version of the original. For example, you can resize an object to 50% of its original size while 

maintaining the same proportions. When this mode is active, the Resize   icon displays near the mouse pointer.         

 l Drawing - Standard click and drag drawing behavior is enabled.            
 l Resize/Reshape - Resize allows you to keep the angle between adjacent edges fixed when a corner handle is moved.           
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To proportionally resize an object, always drag a corner edit 
handle and not an edge handle.

 l Movement - Resize allows you to move an object orthogonal, or at a right angle, to any of its edges.          
 l Rotation - In Resize Mode, objects snap at Allowed Angles as they are rotated.           

You can temporarily enable the Resize edit mode when another mode is active by pressing X or the period key, or using the 
X2 button on a five-button mouse while performing an edit or drawing operation. See Using Input Devices on page 13.          

CONCENTRIC

The Concentric mode allows you to resize objects so that the distance moved by each edge is the same. For example, 
you can resize an irregularly shaped polyline so that each edge is exactly ten feet in from the original position, which 

is useful for creating site plans with setbacks. When this mode is active, the Concentric   icon displays near the mouse 
pointer.         

 l Drawing - Standard click and drag drawing behavior is enabled.            
 l Resize/Reshape - Concentric allows you to resize an irregularly-shaped polyline so that each edge is moved the same 

distance from its original location.           

 l Concentric mode also allows you to move opposite edges of a four-sided object or opposite ends of a line-based object 
so that each edge or end is moved the same distance from its original location.           

 l Movement - Concentric mode allows you to move an object orthogonal, or at a right angle, to any of its edges.          
 l Rotation - In Concentric mode, objects snap at Allowed Angles as they are rotated.          

In some cases, the Concentric and Resize edit behaviors have the same result, such as when a circle is resized. Usually, 
though, the two behaviors are different because concentric resizing does not maintain the original ratio between an irregular 
polyline’s edges.           

140



Home Designer Pro 2025 Reference Manual - Defaults, Preferences, and Edit Behaviors

Resize (left) and Concentric (right) produce 
different results when a shape is complex           

In Concentric mode, objects resize in Concentric Jump increments specified in the Preferences and Set Concentric 
Distance dialogs. See Behaviors Panel on page 81.           

When the Concentric Jump distance is set at 0", objects resize according to the Snap Unit specified in the Plan Defaults 
dialog. See Grid Snaps on page 116.           

To concentrically resize an object with no restrictions, set the 
Concentric Jump value on the Behaviors panel of the Preferences 

dialog to zero and turn off Grid Snaps.

You can temporarily enable the Concentric edit mode when another mode is active by pressing C or the command key, or 
using the X1 button on a five-button mouse while performing an edit or drawing operation. See Using Input Devices on 
page 13. 

You can also concentrically resize a single selected object regardless of the currently active Edit Behavior by clicking 
the Concentric Resize edit button. See Resizing Objects on page 173.

FILLET

The Fillet mode allows you to add a fillet, or curve, at any corner of an object. Dragging a corner edit handle adjusts 
the fillet radius at that corner. When this mode is active, the Fillet   icon displays near the mouse pointer.         

 l Drawing - Standard click and drag drawing behavior is enabled.           
 l Resize/Reshape - Fillet allows you to create a fillet at by dragging a corner edit handle inward.           

 l Movement - Move mode allows you to move objects at Allowed Angles.          
 l Rotation - In Move mode, objects snap at Allowed Angles as they are rotated.          

The Fillet edit behavior adjusts all the corners of a box at once. The radius of each corner is the same.          

Fillet does not have an effect on circles, ovals, ellipses or arc segments.          

You can temporarily enable the Fillet edit mode when another mode is active by pressing F while performing an edit or 
drawing operation.          

To produce fillets or chamfers of an exact radius, use the Fillet 
Lines or Chamfer Lines edit button. See Fillet Lines on page 177 

and Chamfer Lines on page 178.
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CONNECT CAD SEGMENTS

Typically, when two CAD objects share the same properties and Endpoint Snaps are enabled, they can be snapped 
end-to-end to form a polyline. Connect CAD Segments controls whether CAD objects with the same properties can 

be snapped together to form polylines. It also controls whether spline segments can be snapped together. See Polylines on 
page 218 and Splines on page 223.         

Select Edit> Edit Behaviors> Connect CAD Segments to toggle this behavior on or off. You can also turn Connect CAD 
Segments on or off in the Preferences dialog. See CAD Panel on page 78.     

In addition to CAD objects, Connect CAD Segments also affects stairs, ramps, and road objects. See Stairs, Ramps, and 
Landings on page 527 and Roads, Driveways, and Sidewalks on page 928.           

When Connect CAD Segments is disabled, CAD objects cannot connect to form polylines and the Connect CAD Segments 
 icon displays near the mouse pointer. See Pointer Icons on page 15.          

ROTATE/RESIZE ABOUT CURRENT POINT

Objects can be rotated or resized about either their own centers or the current CAD point. See The Current Point on 
page 202.         When this mode is active, the Rotate/Resize About Current Point   icon displays near the mouse 

pointer. See Rotate/Resize About on page 179.

 

Selecting Objects
“Select” refers to selecting an object for editing. An object must be selected before it can be edited. There are a number of 
ways that objects can be selected:

In order for an object to be selected, it must be both unlocked and visible in the current view. See Layers on page 124. 

When an object is selected, it displays edit handles and is highlighted using the Selection Line and Selection Fill colors set 
in the Preferences dialog. See Colors Panel on page 65.

In 3D views, a selected object will also display lines representing the selected edge or surface. The size of the edit handles 
does not change as you zoom in or out and is set in the Preferences dialog.  To prevent them from stacking on one another, 
some edit handles may not display as you zoom away from the selected object. See Edit Panel on page 79.

When an object is selected, its edit toolbar also displays: by default, it is located at the bottom of the Home Designer 
program window just above the Status Bar.  See The Edit Toolbar on page 92.

Groups of objects can also be selected simultaneously. See Selecting Multiple Objects on page 145.

Information about the selected object or objects will also display in the Status Bar. See The Status Bar on page 24.

A selected object remains selected until another object is selected, a different tool is activated, the Esc key is pressed, or any 
two mouse buttons are pressed at the same time. 

FINDING OBJECTS

In order to select an object for editing, you may first need to find it. There are a variety of tools in the program designed to 
help you locate specific objects. These tools often open a new view window in which the object in question is either 
highlighted or selected.     
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 l To find out where a line item in      the Materials List is located in the model, select its row or any cell in its row and click 
the Find Object in Plan  edit button. See Find Object in Plan on page 962. 

 l To locate a string of text, select Edit> Find/Replace Text. See Find/Replace Text on page 361.     
 l In a      Framing Overview or other 3D view in which wall framing can be seen, select a wall framing member and click 

the Find Wall  edit button to locate its owner wall in plan view. See Selecting Walls on page 251.

 l Select Tools> Checks> Missing Files Check to identify and locate any missing referenced files. See Referenced Files 
on page 44.     

SELECT OBJECTS

With the exception of temporary CAD points, any object created using Home Designer Pro's drawing tools can be 
selected using the Select Objects tool. Select Edit> Select Objects, click the toolbar button or press the Spacebar to 

activate this tool, then click on an object to select it.

You can also select objects or open context sensitive menus using the right mouse button when any tool is active.

By default, you can select an object by clicking within 12 pixels of it. You can adjust this distance by changing the Snap 
Distance in the Preferences dialog. A lower value, for example, can be helpful for working with small objects but can also 
make it very difficult to select larger objects. See Snap Properties Panel on page 82.           

SELECT NEXT OBJECT

If there is more than one object in a particular space, it may be difficult to select the desired object. When a nearby 
object is selected, click the Select Next Object edit button or press the Tab key until the desired object becomes 

selected. This function cannot be applied to groups of selected objects.

SELECTING SIMILAR OBJECTS

If a tool other than Select Objects  is active, you can only select objects of that type using the left mouse button. For 

example, if the Straight Exterior Wall  tool is active, you can only select walls using the left mouse button. 

This can be useful for selecting an object when many objects of a different type occupy the same space in plan view. 

Objects can be selected using the right mouse button, regardless of which tool is active. 

RIGHT-CLICKING

Regardless of which tool is active, you can select an object by right-clicking on it once. When you right-click to select an 
object a contextual menu also appears, displaying the object’s edit tools. You can turn contextual menus on or off in the 
Preferences dialog. See Contextual Menus on page 18.

If a drawing tool is active and you right-click to select an object, you can unselect it by left-clicking in an empty space in 
the drawing area. Although a drawing tool is active, it is not used. If you then left-click a second time, the active tool will be 
used.   

SELECTED EDGE

When you click on a polyline- or box-based object, the edge that you click nearest becomes the selected edge and displays 
an edit handle larger and of a different color than those on other edges. The handle on this edge may also display at the 
point where you clicked to select it. You can specify the Selected Edge Handle Fill color in the Preferences dialog. See 
Colors Panel on page 65. 
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This edge can be edited on the SELECTED LINE or SELECTED ARC panel of the object’s specification dialog, as well as using 
a variety of edit toolbar buttons. It can also be moved using dimensions. See Moving Objects Using Dimensions on page 
341, Line Panel on page 208 and Arc Panel on page 214.

The Start and End points of a CAD-based object’s selected edge or of a wall can be indicated by an S and an E when the 
object is selected. These Start and End indicators can be helpful when editing the selected edge in the object’s specification 
dialog, and their display can be turned on and off in the Preferences dialog. See Edit Panel on page 79.           

SELECTED SIDE

Most architectural objects can be selected in 3D views. When selected, the outline of their bounding box displays, and edit 
handles are located on the side where you clicked to select the object. The edit handles can be used to move, resize, or rotate 
the object in different directions, depending on which side is selected.

If the currently selected side of an object is not the one you need, click the Select Next Side edit button to select a 
different side of the object. You can cycle through all sides of the object until the one you need is selected.

DISCONNECT EDGES

Polyline-based objects are composed of lines and arcs that are connected end to end. The individual edges of open 
and closed polylines can be selected and edited independently of the object’s other edges when Disconnect Edges is 

in use. Select CAD> Lines> Disconnect Edges to enable this ability.         

Disconnect Edges also affects terrain paths, but does not affect Walkthrough Paths, Electrical Connection or Sprinkler 
splines, or closed polyline-based objects such as slabs and roof planes.         

To use Disconnect Edges

 1.  Select CAD> Lines> Disconnect Edges .         

 2.  Click on an individual edge of an eligible polyline-based object to select it.         

 3.  Notice that it is no longer connected to the rest of the polyline.         

 4.  The individual segment can now be edited entirely independent of its neighbors.         

 5.  Continue clicking on polyline edges to disconnect them from their polyline.        
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 6.  When you are finished, click the Select Objects  button or activate another tool.         

 7.  To connect the segment to the polyline again, move the end handles so that they snap to the ends of adjacent 
segments.         

 8.  When Disconnect Edges  is used, only edges that you click on are actually affected by it. Any polylines that you 

do not click on will remain intact.          

You can also separate the selected edge of an open or closed polyline from the rest of the polyline by clicking the 
Disconnect Selected Edge  edit button. See Selected Edge on page 143.         

 

Selecting Multiple Objects
Multiple objects can be selected and edited in groups. The options available for editing them will vary depending on the 
type or types of objects selected. See Editing Multiple Objects on page 167.

MARQUEE SELECT

Groups of objects can be selected by holding down either the Shift or Ctrl/⌘  key when the Select Objects  tool is active 

and then dragging a marquee around the objects to be selected. 

When using the marquee-select method, both CAD and architectural objects included in the marquee are selected. To 
remove an object from the selection set, hold down the Ctrl/⌘  key and click on it.

If an object is selected and a selection marquee is drawn around it using the Ctrl/⌘  key, that object becomes deselected.  If 
the Shift key is used instead, the original object  remains selected and the other objects are added to the selection set.

The Shift key can be used to marquee-select objects of a similar type when the drawing tool used to create those objects is 
active. 

To marquee-select objects by type

 1.  Select a drawing tool used to create the type of object you wish to select: for example, the Hinged Door  tool. 

 2.  Hold down the Shift key, then click and drag a rectangular selection marquee in the drawing area.

 3.  When you release the mouse button, objects of the selected drawing tool’s type - here, door objects - located in the 
marquee will be selected.

You can specify whether objects must be totally contained in or intersected by the marquee, or whether an object’s center 
point must be contained in the marquee, in the Preferences dialog or using the Selection Mode  buttons, which can be 

added to your toolbars. See Edit Panel on page 79.         

To make marquee selection easier, you can turn off the display 
of objects you do not want to include in your selection set. See 

Layers on page 124.

MARQUEE SELECT SIMILAR

The Marquee Select Similar edit tool lets you group-select objects in the current plan view that are similar to the 
selected object(s). 
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To use Marquee Select Similar

 1.  In plan view, select one or more objects, then click the Marquee Select Similar  edit button.

 2.  The Restrictive Selection  toggle controls whether objects are selected by similar type(s) only, or if additional 

attributes are taken into account. 

 l Restrictive Selection  is disabled by default, so objects of the same type will be selected.

 l Click the Restrictive Selection  edit button to toggle it on and select only objects with additional attributes like 

materials in common. 

 3.  Click and drag a rectangular selection marquee in the drawing area to select similar objects within its area.

 4.  Alternatively, click the Select All Similar  edit button to select all similar objects in the current view.

 5.  The Marquee Select Similar  tool is not available for all object types. For example, it is not available for wall 

framing.         

SHIFT AND CTRL/⌘  SELECT

You can select a group of objects by adding them to the selection set one by one. Select an object, hold down either the 
Shift or Ctrl/⌘  key, and click additional objects to select them. 

More than one type of object can be selected using this method, but the ability to edit the group-selected items is limited to 
attributes that all selected objects have in common.

To remove an object from a selection set, click on it once more with the Ctrl/⌘  key pressed.

The Shift and Ctrl/⌘  keys can be used to select multiple items in a variety of contexts, such as: the Library Browser, lists in 
dialog boxes, and files to be imported. They can also be used to marquee-select objects in plan view. See Marquee Select on 
page 145, above.   

EDIT AREA

The Edit Area Tools allow you to define an area of your plan and select the objects within that area for editing. See 
Edit Area Tools on page 186.   

 

Editing Line-Based Objects
Objects are considered line-based when they can be edited similar to CAD lines using their edit handles.         

CAD lines, framing members, straight walls and railings, straight stairs, and straight roads are examples of line-based 
objects. 

Most line-based objects can be connected to the ends of other like objects to form polylines or polyline-based objects 
provided that they have identical attributes such as line color and arrow specifications.  See Editing Open Polyline-Based 
Objects on page 153 and Editing Closed Polyline-Based Objects on page 157.

Some objects, notably walls, have line-based editing behavior only when selected on certain surfaces. See Editing Walls on 
page 251.

Wall openings such as doors and windows have line-based editing behavior in  plan view only but cannot be rotated, 
reversed or converted to an arc. See Editing Doors on page 385 and Editing Windows on page 418.
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Other objects, such as stairs and roads, have additional edit handles that allow you to concentrically adjust the object’s 
width. 

USING THE EDIT HANDLES

When selected, a typical line-based object displays six edit handles: a Move handle, two Extend/Change Angle handles, two 
Same Line Type handles, and a Rotate handle.

Any action performed using the edit handles can be canceled by pressing the Esc key or any two mouse buttons at the same 
time.

The behavior of the edit handles may depend on the currently 
active Edit Behavior. See Defaults, Preferences, and Edit 

Behaviors on page 138.

A. Move

 l Click and drag the Move handle to move the object according to the currently active Edit Behavior . See Defaults, 

Preferences, and Edit Behaviors on page 138.              
 l Movement may be limited or stopped by other objects or Snap Behaviors. Move restrictions can be overridden by 

holding down the Ctrl/⌘  key while dragging. See Unrestricted Movement on page 168.

B. Rotate
 l The Rotate handle is used to rotate the object, either about its center or about the current CAD point. See Rotating 

Objects on page 178.

C. Extend/Change Angle
 l Drag a square end handle parallel to the selected line to change its length. 
 l Drag a square end handle at an angle to the selected line to change its angle. When Angle Snaps  are on, the line 

snaps to Allowed Angles. See Angle Snaps on page 115.
 l Right-click and drag it to change the adjacent line into an arc, or vice versa. See Alternate on page 139.              
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D. Same Line Type
 l Drag a diamond-shaped end handle in any direction to draw a new line that shares the original’s color, weight, line 

style, and layer. See Same Line Type Edit Handles on page 207.             

Adjust Width

Some line-based objects, such as stairs and roads, have additional handles that allow the width of the object to be adjusted.

Adjust width

 l Click and drag a small, round Expand handle to increase or decrease the object’s width. By default, objects are resized 
in 1" increments. This Snap Unit is defined in the Plan Defaults dialog. See General Plan Defaults Dialog on page 60.

USING DIMENSIONS

Dimensions can be used to position line-based objects relative to other objects. See Moving Objects Using 
Dimensions on page 341.         

Dimensions cannot, however, be used to adjust the length of line-based objects, or the width of line-based objects such as 
stairs.         

USING THE SPECIFICATION DIALOG

Line-based objects can be edited using their specification dialogs. See Line Specification Dialog on page 208.

USING THE EDIT TOOLBAR

A selected line-based object can be edited in a variety of ways using the buttons on the Edit Toolbar. 

The following toolbar buttons may display on the Edit Toolbar for a selected line-based object: 

  Select Next Object selects nearby objects instead of the selected object. See Selecting Objects on page 142.

  Open Object opens the specification dialog for the selected object(s). See Specification Dialogs on page 20.

  Copy/Paste copies the selected object(s) to the system clipboard so they can be pasted elsewhere. See Copying 
and Pasting Objects on page 118.

  Delete deletes the selected object(s). See Deleting Objects on page 191.

  Transform/Replicate Object copies, moves, rotates, resizes, or reflects the selected object(s). See 
Transform/Replicate Object Dialog on page 183.             

  Make Parallel/Perpendicular makes the selected object(s) parallel or perpendicular to a straight edge. See Make 
Parallel/Perpendicular on page 171.             

  Point to Point Move accurately moves the selected object(s). See Point to Point Move on page 169.              

  Center Object centers an object along a wall within a room or relative to a cabinet fixture. See Center Object on 
page 172.             
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  Reflect About Object reflects the selected object(s) about another object. See Reflecting Objects on page 180.              

  View Drawing Group Edit Tools modifies the selected object’s place in the drawing order. See Drawing Group 
Edit Tools on page 129.             

  Add Break adds a new corner or pivot point to the selected object. See Add Break on page 175.             

  Complete Break breaks the selected object into two separate objects. See Add Break on page 175.             

  Reverse Direction reverses the direction of the selected object(s). See Reverse Direction on page 181.             

  Convert Polyline converts the object into a special polyline-based object. See Convert Polyline on page 182.             

  Change Line/Arc changes a line-based object to an arc, or vice versa. See Change Line/Arc on page 176.             

  Intersect/Join Two Lines joins two non-parallel lines or arcs. See Intersect/Join Two Lines on page 177.             

  Fillet Lines create an additional arc connecting two non-parallel lines or arcs. See Fillet Lines on page 177.             

  Chamfer Lines chamfers the corner between adjacent edges. See Chamfer Lines on page 178.             

 

Editing Arc-Based Objects
Objects are considered arc-based when they can be edited similar to CAD arcs using their edit handles.           

CAD arcs, curved walls and railings, curved stairs, and curved roads are examples of arc-based objects.

Most arc-based objects can be connected to other like objects to form polylines or polyline-based objects provided that they 
have identical attributes such as line color and arrow specifications. See Editing Open Polyline-Based Objects on page 153 
and Editing Closed Polyline-Based Objects on page 157.

Some objects, notably curved walls, have arc-based editing behavior only when selected on certain surfaces. See Editing 
Walls on page 251.

Other objects, such as curved stairs and roads, have additional edit handles that allow you to concentrically adjust the 
object’s width. 

The currently active Arc Creation Mode  determines how an arc-based object is drawn. Once an arc is drawn, the active 

Arc Creation Mode does not affect it. See Drawing Arcs - Arc Creation Modes on page 210.          

USING THE EDIT HANDLES

When selected, a typical arc-based object displays seven edit handles. 
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Any action performed using the edit handles can be canceled by pressing the Esc key or any two mouse buttons at the same 
time.

The behavior of the edit handles may depend on the currently 
active Edit Behavior. See Defaults, Preferences, and Edit 

Behaviors on page 138.

A. Resize (changes radius)
B. Reshape (moves center)
C. Move Chord
D. Extend (along arc or chord)
E. Same Line Type
F. Move Arc Center
G. Rotate

Move
 l Two Move edit handles allow the arc to be relocated without changing its shape. One is located at the center of the 

chord and the other, at the arc center. 
 l If you would like to snap one of these center points to another point, use that handle when moving the arc. See 

Aligning Arc Centers on page 173.          
 l Click and drag the Move handle to move the object according to the currently active Edit Behavior . See Defaults, 

Preferences, and Edit Behaviors on page 138.           
 l Movement may be limited or stopped by other objects or Snap Behaviors. Move restrictions can be overridden by 

holding down the Ctrl/⌘  key while dragging. See Unrestricted Movement on page 168.

Dragging the Move edit handle downward

Rotate
 l The Rotate handle is used to rotate the arc, either about its center or about the current CAD point. See Rotating 

Objects on page 178.

Extend
 l The end edit handles expand or contract the arc when moved along the arc radius or chord. 
 l If you follow the path of the arc, the end edit handles allow you to adjust the arc length.
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 l The angle formed by the center point of the arc and its two endpoints is referred to as the Included Angle. If Angle 
Snaps are on, the Included Angle of the arc, as measured in degrees, can be rotated at Allowed Angles. See Angle 
Snaps on page 115.

 l Right-click and drag it to change the adjacent arc into a line, or vice versa. See Alternate on page 139.           

Dragging an End edit handle to lengthen an 
arc

Resize
 l Drag the small, round Resize edit handle to change the radius and included angle of the arc while maintaining its 

center. 

Dragging the Resize edit handle toward the 
center

Reshape
 l Drag the small triangular Reshape handle to change the length and location of the center without moving the 

endpoints.             

Dragging the Reshape edit handle away 
from the center

Same Line Type
 l Drag a diamond-shaped end handle in any direction to draw a new line that shares the arc’s color, weight, line style, 

and layer. See Same Line Type Edit Handles on page 207.          

Adjust Width

Some arc-based objects, such as stairs, have additional handles that allow the width of the object to be adjusted. 
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Adjust Width edit handles

 l Click and drag a small, round edit handle to increase or decrease the object’s width. By default, objects are resized 
according to the Snap Unit defined in the Plan Defaults dialog. See General Plan Defaults Dialog on page 60.

USING DIMENSIONS

Dimensions can be used to position arc-based objects. Dimension lines typically locate tangent extension lines and 
any extension lines that may be parallel to those lines rather than the arc itself. See Moving Objects Using 

Dimensions on page 341.         

USING THE SPECIFICATION DIALOG

Arc-based objects can be edited using their specification dialogs. See Arc Specification Dialog on page 214.

USING THE EDIT TOOLBAR

A selected arc-based object can be edited in a variety of ways using the buttons on the Edit Toolbar. 

The following toolbar buttons may display on the Edit Toolbar for a selected arc-based object:

  Select Next Object selects nearby objects instead of the selected object. See Selecting Objects on page 142.

  Open Object opens the specification dialog for the selected object(s). See Specification Dialogs on page 20.

  Copy/Paste copies the selected object(s) to the system clipboard so they can be pasted elsewhere. See Copying 
and Pasting Objects on page 118.

  Delete deletes the selected object(s). See Deleting Objects on page 191.

  Transform/Replicate Object copies, moves, rotates, resizes, or reflects the selected object(s). See 
Transform/Replicate Object Dialog on page 183.          

  Point to Point Move accurately moves the selected object(s). See Point to Point Move on page 169.           

  Center Object centers an object along a wall within a room or relative to a cabinet fixture. See Center Object on 
page 172.         

  Reflect About Object reflects the selected object(s) about another object. See Reflecting Objects on page 180.           

  View Drawing Group Edit Tools modifies the selected object’s place in the drawing order. See Drawing Group 
Edit Tools on page 129.         

  Add Break adds a new corner or pivot point to the selected object. See Add Break on page 175.         

  Complete Break breaks the selected object into two separate objects. See Add Break on page 175.         
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  Reverse Direction reverses the direction of the selected object(s). See Reverse Direction on page 181.          

  Convert Polyline converts the object into a special polyline-based object. See Convert Polyline on page 182.          

  Change Line/Arc changes an arc-based object to a line, or vice versa. See Change Line/Arc on page 176.         

  Intersect/Join Two Lines joins two non-parallel  lines or arcs. See Intersect/Join Two Lines on page 177.          

  Fillet Lines creates an additional arc connecting two lines. See Fillet Lines on page 177.          

  Chamfer Lines creates an additional edge connecting two lines. See Chamfer Lines on page 178.          

ARC CENTERS AND ENDS

When working with arc-based objects or circles, it can be helpful to see their center points. Similarly, when snapping 
arcs together to form a polyline, seeing their endpoints can be helpful. Select View> Arc Centers and Ends to toggle 

the display of both on the current floor. You can also turn on their display in the CAD Defaults dialog. See CAD Defaults 
Dialog on page 198.         

Arc-based objects can be aligned using their center points. See Aligning Arc Centers on page 173.           

 

Editing Open Polyline-Based Objects
Open polyline-based objects are composed of individual line- and arc-based objects that are connected at their end points 
but do not form an enclosed area. See Polylines on page 218. 

Objects are considered open polyline-based when they can be edited similar to open CAD polylines using their edit handles.          

Open CAD polylines, connected walls, stairs, and connected roads are examples of open polyline-based objects. 

For information about editing closed polyline-based objects, see Editing Closed Polyline-Based Objects on page 157.

Other objects, such as connected stair and road segments, have additional edit handles that allow you to concentrically 
adjust the width of all segments of the object. 
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If Connect CAD Segments is disabled, clicking on a CAD 
polyline edge selects the individual edge rather than the entire 

polyline. See Disconnect Edges on page 144.    

USING THE EDIT HANDLES

A polyline can be composed of many segments. See Polylines on page 218. 

When selected, an open polyline-based object displays a Move handle, a Rotate handle, a Reshape handle at the intersection 
of each segment, and an Extend handle at each end.

Each straight, line-based segment also has a Move edit handle along its length. 

Each curved, arc-based segment has its own Move handle at the center of its chord, a Resize handle and, if it has an 
unlocked center, a Reshape handle. See Editing Arc-Based Objects on page 149.

When a polyline is selected, the edge that you click nearest is called the selected edge, and certain operations affect only this 
edge. The Move handle of the selected edge is larger than that of other edges. It displays along the length of a line segment, 
or at the center of the chord on an arc segment. See Selected Edge on page 143.

Any action performed using the edit handles can be canceled by pressing the Esc key or any two mouse buttons at the same 
time.

The behavior of the edit handles  depends on the currently active 
Edit Behavior. See Defaults, Preferences, and Edit Behaviors on 

page 138.    

A. Move

 l Click and drag the Move handle to move the object according to the currently active Edit Behavior . 

 l Movement may be limited or stopped by other objects or Snap Behaviors. Move restrictions can be overridden by 
holding down the Ctrl/⌘  key while dragging. See Unrestricted Movement on page 168.

B. Rotate
 l The Rotate handle is used to rotate the object, either about its center or about the current CAD point. Its position 

varies depending on which edge is currently selected. See Rotating Objects on page 178.

C. Extend
 l Click and drag an Extend handle to lengthen or shorten the unconnected end of the selected line or arc segment, or to 

change the radius of the selected arc. See Editing Arc-Based Objects on page 149.
 l Right-click and drag it to change the adjacent line into an arc, or vice versa. See Alternate on page 139.           
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D. Reshape
 l Click and drag a Reshape edit handle to change the angle and/or length of the segments on either side of it, or the size 

of the object, depending on the currently active Edit Behavior . 

E. Move Line Segment
 l The Move Line Segment edit handle is found on straight segments of open polylines and moves the straight section 

according to the currently active Edit Behavior . Adjacent segments may extend or contract in their original 

directions to maintain their connections. 

F. Move Arc
 l Click and drag the Move Arc edit handle to change the radius and/or chord length or position, depending on the 

currently active Edit Behavior  and whether the arc has a locked center. Adjacent segments may extend, contract, 

or change angle to maintain their connections. 

G. Resize Arc
 l Click and drag the Resize Arc edit handle to change the radius, chord length and chord position of the arc segment, 

depending on the currently active Edit Behavior  and whether the arc has a locked center. Adjacent segments may 

extend, contract, or change angle to maintain their connections. 

H. Reshape Arc
 l Click and drag the Reshape Arc edit handle to change the radius of the arc without moving its end points. Only 

available if the arc has an unlocked center.

I. Same Line Type
 l Drag a diamond-shaped end handle in any direction to draw a new line that shares the original polyline’s color, 

weight, line style, and layer. See Same Line Type Edit Handles on page 207.          

J. Adjust Width

Some open polyline-based objects, such as stairs and roads, have additional handles that allow the width of the object to be 
adjusted. 

 l Click and drag a small, round edit handle to increase or decrease the object’s width. By default, objects are resized in 
1" increments. This Snap Unit is defined in the Plan Defaults dialog. See General Plan Defaults Dialog on page 60.

USING DIMENSIONS

Dimensions can be used to move or reshape polyline-based objects. See Moving Objects Using Dimensions on page 
341.         

USING THE SPECIFICATION DIALOG

Open polyline-based objects can be edited using their specification dialogs. See Polyline Specification Dialog on 
page 219.
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USING THE EDIT TOOLBAR

A selected open polyline-based object can be edited in a variety of ways using the buttons on the Edit Toolbar. 

The following toolbar buttons may display on the Edit Toolbar for a selected open polyline-based object:

  Select Next Object selects nearby objects instead of the selected object. See Selecting Objects on page 142.

  Open Object opens the specification dialog for the selected object(s). See Specification Dialogs on page 20.

  Copy/Paste copies the selected object(s) to the system clipboard so they can be pasted elsewhere. See Copying 
and Pasting Objects on page 118.

  Delete deletes the selected object(s). See Deleting Objects on page 191.

  Disconnect Selected Edge disconnects the selected edge of the polyline, turning it into a separate object. See 
Disconnect Edges on page 144.           

  Transform/Replicate Object copies, moves, rotates, resizes, or reflects the selected object(s). See 
Transform/Replicate Object Dialog on page 183.          

  Make Parallel/Perpendicular makes the selected straight edge parallel or perpendicular to another straight edge. 
See Make Parallel/Perpendicular on page 171. Not available when the selected edge is an arc.         

  Point to Point Move accurately moves the selected object(s). See Point to Point Move on page 169.           

  Center Object centers an object along a wall within a room or relative to a cabinet fixture. See Center Object on 
page 172.         

  Reflect About Object reflects the selected object(s) about another object. See Reflecting Objects on page 180.           

  View Drawing Group Edit Tools modifies the selected object’s place in the drawing order. See Drawing Group 
Edit Tools on page 129.         

  Add Break adds a new corner or pivot point to the selected object. See Add Break on page 175.         

  Complete Break breaks the selected object into two separate objects. See Add Break on page 175.          

  Reverse Direction reverses the direction of the selected object(s). See Reverse Direction on page 181.          

  Close Polyline converts the selected open polyline into a closed polyline. See Close Polyline on page 157.           

  Convert Polyline converts the object into a special polyline-based object. See Convert Polyline on page 182.          

  Change Line/Arc changes a line-based polyline edge to an arc, or vice versa. See Change Line/Arc on page 176.
         

  Intersect/Join Two Lines joins two a non-parallel lines or arcs. See Intersect/Join Two Lines on page 177.          

  Fillet Lines creates an arc connecting two non-parallel lines. See Fillet Lines on page 177. Cannot be used if the 
adjacent edge is an arc.           

  Chamfer Lines creates a line connecting two non-parallel lines. See Chamfer Lines on page 178.          

156



Home Designer Pro 2025 Reference Manual - Editing Closed Polyline-Based Objects

CLOSE POLYLINE

An open polyline-based object can be converted into a closed polyline using the Close Polyline edit tool. This tool 
adds an edge to the open polyline, connecting its two ends and closing the gap between them.

Close Polyline is not available when Connect CAD Segments  is enabled. See Disconnect Edges on page 144.         

 

Editing Closed Polyline-Based Objects
Closed polyline-based objects are composed of individual line- and arc-based objects joined end-to-end and forming an 
enclosed area. See Polylines on page 218. 

Objects are considered closed polyline-based when they can be edited similar to closed CAD polylines using their edit 
handles.          

Closed CAD polylines, slabs and roof planes are examples of closed polyline-based objects.          

Some objects, notably walls, have closed polyline-based editing behavior only when they are selected on certain surfaces in 
3D views. See Editing Walls on page 251.          

For information about editing open polyline-based objects, see Editing Open Polyline-Based Objects on page 153.

If Connect CAD Segments is disabled, clicking on a polyline 
edge selects the individual edge rather than the entire polyline. 

See Disconnect Edges on page 144.    

USING THE EDIT HANDLES

A polyline can be composed of many segments. See Polylines on page 218. 

When selected, a closed polyline-based object displays a Move handle, a Rotate handle, and a Reshape handle at the 
intersection of each segment. 

Each straight, line-based segment has a Move edit handle along its length. 

Each curved, arc-based segment has its own Move handle at the center of its chord, a Resize handle and, if it has an 
unlocked center, a Reshape handle. See Editing Arc-Based Objects on page 149.

When a polyline is selected, the edge that you click nearest is called the selected edge, and certain operations affect only this 
edge. The Move handle of the selected edge is larger than that of other edges. It displays along the length of a line segment, 
or at the center of the chord on an arc segment. See Selected Edge on page 143.
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Any action performed using the edit handles can be canceled by pressing the Esc key or any two mouse buttons at the same 
time.

The behavior of the edit handles may depend on the currently 
active Edit Behavior. See Defaults, Preferences, and Edit 

Behaviors on page 138.

A. Move

 l Click and drag the Move handle to move the object according to the currently active Edit Behavior . 

 l Movement may be limited or stopped by other objects or Snap Behaviors. Move restrictions can be overridden by 
holding down the Ctrl/⌘  key while dragging. See Unrestricted Movement on page 168.

B. Rotate
 l The Rotate handle is used to rotate the object, either about its center or about the current CAD point. Its position 

varies depending on which edge is currently selected. See Rotating Objects on page 178.

C. Reshape
 l Click and drag a Reshape edit handle to change the angle and/or length of the segments on either side of it, or the size 

of the object, depending on the currently active Edit Behavior . 

D. Move Line Segment
 l The Move Line Segment edit handle is found on straight segments of closed polylines and moves the straight section 

according to the currently active Edit Behavior . Adjacent segments may extend or contract in their original 

directions to maintain their connections. 

E. Move Arc
 l Click and drag the Move Arc edit handle to change the radius and/or chord length or position, depending on the 

currently active Edit Behavior  and whether the arc has a locked center. Adjacent segments may extend, contract, 

or change angle to maintain their connections. 

F. Resize Arc
 l Click and drag the Resize Arc edit handle to change the radius, chord length and chord position of the arc segment, 

depending on the currently active Edit Behavior  and whether the arc has a locked center. Adjacent segments may 

extend, contract, or change angle to maintain their connections. 
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G. Reshape Arc
 l Click and drag the Reshape Arc edit handle to change the radius of the arc without moving its end points. Only 

available if the arc has an unlocked center.

Other    objects, such as connected road segments, have additional edit handles that allow you to concentrically adjust the 
width of all segments of the object.    

USING DIMENSIONS

             Dimensions can be used to move or reshape closed polyline-based objects. See Moving Objects Using Dimensions 
on page 341.         

USING THE SPECIFICATION DIALOG

 Closed polyline-based objects can be edited using their specification dialogs. See Polyline Specification Dialog on 
page 219.

USING THE EDIT TOOLBAR

A selected closed polyline-based object can be edited in a variety of ways using the buttons on the Edit Toolbar. The 
options available will vary by object type.

The following toolbar buttons may display on the Edit Toolbar for a selected closed polyline-based object:

  Select Next Object                 selects nearby objects instead of the selected object. See Selecting Objects on page 142.

  Open Object opens the specification dialog for the selected object(s). See Specification Dialogs on page 20.

  Copy/Paste copies the selected object(s) to the system clipboard so they can be pasted elsewhere. See Copying 
and Pasting Objects on page 118.

  Delete                 deletes the selected object(s). See Deleting Objects on page 191.

  Disconnect Selected Edge disconnects the selected edge of the polyline, turning it into a separate object. See 
Disconnect Edges on page 144.           

  Transform/Replicate Object                  copies, moves, rotates, resizes, or reflects the selected object(s). See 
Transform/Replicate Object Dialog on page 183.          

  Make Parallel/Perpendicular                 makes the selected straight edge parallel or perpendicular to another straight edge 
by either rotating the selected edge or the entire polyline. See Make Parallel/Perpendicular on page 171. Not 

available when the selected edge is an arc.         
  Point to Point Move                 accurately moves the selected object(s). See Point to Point Move on page 169.           

  Center Object centers an object along a wall within a room or relative to a cabinet fixture. See Center Object on 
page 172.         

  Reflect About Object  reflect the selected object(s) about another object. See Reflecting Objects on page 180.           

  View Drawing Group Edit Tools                 modifies the selected object’s place in the drawing order. See Drawing Group 
Edit Tools on page 129.         

  Add Break                 adds a new corner or pivot point to the selected object. See Add Break on page 175.         
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  Complete Break                 breaks an edge of the selected object into two separate objects. See Add Break on page 175.         

  Reverse Direction                 reverses the direction of the selected object(s). See Reverse Direction on page 181.          

  Convert Polyline converts the object into a special polyline-based object. See Convert Polyline on page 182.          

  Change Line/Arc changes a line-based polyline edge to an arc, or vice versa. See Change Line/Arc on page 176.
         

  Intersect/Join Two Lines joins two non-parallel lines or arcs. See Intersect/Join Two Lines on page 177.          

  Fillet Lines creates an arc connecting two non-parallel lines. See Fillet Lines on page 177. Cannot be used if the 
adjacent edge is an arc.           

  Chamfer Lines creates a straight line between two non-parallel lines. See Chamfer Lines on page 178.          

 

Editing Box-Based Objects
Objects are considered box-based when they can be edited similar to CAD boxes using their edit handles.          

Box-based objects are similar to closed polyline-based objects, but must always have four sides with right-angled corners. 

In addition to the CAD Box tools, Text objects, many library symbols,              pictures and images are examples of box-based 
objects.

USING THE EDIT HANDLES

When selected, a box-based object displays ten edit handles. Unlike polylines, boxes must always have four sides with right-
angled corners.

Any action performed using the edit handles can be canceled by pressing the Esc key or any two mouse buttons at the same 
time.

The behavior of the edit handles may depend on the currently 
active Edit Behavior. See Defaults, Preferences, and Edit 

Behaviors on page 138.
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 l Click and drag the Move handle to move the object according to the currently active Edit Behavior . See Defaults, 

Preferences, and Edit Behaviors on page 138. 

Movement may be limited or stopped by other objects or Snap Behaviors. Move restrictions can be overridden by 
holding down the Ctrl/⌘  key while dragging. See Unrestricted Movement on page 168.

 l The four Resize handles located at each corner are used to increase or decrease the size of the object. 

 l The four Extend handles display along each edge. If you select an object on an edge, the Extend handle displays at the 
point where you clicked; otherwise, it displays at the center of the edge.

 l The triangular Rotate handle located near the selected edge of the object is used to rotate it either about its center or 
the current CAD point. The pointer changes to a circular arrow   when moved over this handle. See Rotating Objects 
on page 178.

USING DIMENSIONS

             Dimensions can be used to move or reshape box-based objects. See Moving Objects Using Dimensions on page 341.         

USING THE SPECIFICATION DIALOG

Box-based objects can be edited using their specification dialogs. See Box Specification Dialog on page 222.

USING THE EDIT TOOLBAR

A selected box-based object can be edited in a variety of ways using the buttons on the Edit Toolbar.  
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The following toolbar buttons may display on the Edit Toolbar for a selected box-based object:

  Select Next Object selects nearby objects instead of the selected object. See Selecting Objects on page 142.

  Open Object opens the specification dialog for the selected object(s). See Specification Dialogs on page 20. 

  Copy/Paste copies the selected object(s) to the system clipboard so they can be pasted elsewhere. See Copying 
and Pasting Objects on page 118.

  Delete deletes the selected object(s). See Deleting Objects on page 191.

  Transform/Replicate Object copies, moves, rotates, resizes, or reflects the selected object(s). See 
Transform/Replicate Object Dialog on page 183.          

  Make Parallel/Perpendicular makes the selected straight edge parallel or perpendicular to another straight edge. 
Not available when the selected edge is an arc. See Make Parallel/Perpendicular on page 171.

  Point to Point Move accurately moves the selected object(s). See Point to Point Move on page 169.

  Center Object              centers an object along a wall within a room or relative to a cabinet fixture. See Center Object on 
page 172.

  Reflect About Object reflects the selected object(s) about another object. See Reflecting Objects on page 180.           

  View Drawing Group Edit Tools              modifies the selected object’s place in the drawing order. See Drawing Group 
Edit Tools on page 129.         

  Convert Polyline converts the object into a special polyline-based object. See Convert Polyline on page 182.          

 

Editing Spline-Based Objects
A Spline is a curve that passes smoothly through a set of points, or vertices. Splines are typically used in situations where an 
irregular, free-flowing curve is needed.

Objects are considered spline-based when they can be edited similar to CAD splines using their edit handles. See Splines on 
page 223.

Sprinkler lines, spline terrain curbs, spline terrain walls, and both round and kidney-shaped terrain features are spline-based 
objects. See Terrain on page 890.         

USING THE EDIT HANDLES

When a spline is selected, several different types of handles display.  

Any action performed using the edit handles can be canceled by pressing the Esc key or any two mouse buttons at the same 
time.
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The behavior of the edit handles may depend on the currently 
active Edit Behavior. See Defaults, Preferences, and Edit 

Behaviors on page 138.

A. Move

 l Click and drag the Move handle to move the object according to the currently active Edit Behavior . See Defaults, 

Preferences, and Edit Behaviors on page 138. 
 l Movement may be limited or stopped by other objects or Snap Behaviors. Move restrictions can be overridden by 

holding down the Ctrl/⌘  key while dragging. See Unrestricted Movement on page 168.

B. Rotate
 l Click and drag the Rotate edit handle to rotate the entire spline. 

C. Vertex
 l The Vertex edit handles display along the spline at each vertex. Click and drag a Vertex edit handle to change the 

length, angle and curve of adjacent segments without affecting other vertices. 

Same Line Type
 l Drag a diamond-shaped end handle in any direction to draw a new spline segment that shares the original spline’s 

color, weight, line style, and layer. See Same Line Type Edit Handles on page 207.          

USING THE SPECIFICATION DIALOG

Spline-based objects can be edited using their specification dialogs. See Polyline Specification Dialog on page 219.

USING THE EDIT TOOLBAR

A selected spline-based object can be edited in a variety of ways using the buttons on the Edit Toolbar.  

The following toolbar buttons may display on the Edit Toolbar for a selected spline-based object: 
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  Select Next Object selects nearby objects instead of the selected object. See Selecting Objects on page 142.

  Open Object opens the specification dialog for the selected object(s). See Specification Dialogs on page 20. 

  Copy/Paste copies the selected object(s) to the system clipboard so they can be pasted elsewhere. See Copying 
and Pasting Objects on page 118.

  Delete deletes the selected object(s). See Deleting Objects on page 191.

  Transform/Replicate Object copies, moves, rotates, resizes, or reflects the selected object(s). See 
Transform/Replicate Object Dialog on page 183.          

  Make Parallel/Perpendicular makes the selected spline edge parallel or perpendicular to another straight edge. 
See Make Parallel/Perpendicular on page 171.         

  Point to Point Move accurately moves the selected object(s). See Point to Point Move on page 169.           

  Center Object centers an object along a wall within a room or relative to a cabinet fixture. See Center Object on 
page 172.         

  Reflect About Object reflects the selected object(s) about another object. See Reflecting Objects on page 180.           

  View Drawing Group Edit Tools modifies the selected object’s place in the drawing order. See Drawing Group 
Edit Tools on page 129.         

  Add Break adds a new corner or pivot point to the selected object. See Add Break on page 175.         

  Complete Break breaks an edge of the selected object into two separate objects. See Add Break on page 175.         

  Reverse Direction reverses the direction of the selected object(s). See Reverse Direction on page 181.     

  Convert Polyline converts the object into a special polyline-based object. See Convert Polyline on page 182.          

 

Editing Circles, Ovals and Ellipses
Objects created using the Circle Tools are unusual in that no architectural objects share their functionalities.

USING THE EDIT HANDLES

When selected, circles, ovals and ellipses display eleven edit handles. 

Unlike Ovals  and Ellipses , a Circle  cannot be edited into any other shapes; it can only be a circle.

Any action performed using the edit handles can be canceled by pressing the Esc key or any two mouse buttons at the same 
time.

The behavior of the edit handles may depend on the currently 
active Edit Behavior. See Defaults, Preferences, and Edit 

Behaviors on page 138.
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A. Move
B. Rotate
C. Reshape
D. Concentric Resize

Move

 l Click and drag the Move handle to move the object according to the currently active Edit Behavior . See Defaults, 

Preferences, and Edit Behaviors on page 138.
 l Movement may be limited or stopped by other objects or Snap Behaviors. Move restrictions can be overridden by 

holding down the Ctrl/⌘  key while dragging. See Unrestricted Movement on page 168.

Rotate
 l Click and drag the Rotate handle of an oval or ellipse to change its orientation.

Reshape
 l The eight edit handles beyond the perimeter are Reshape edit handles. Move them in or out to resize and reshape an 

oval or ellipse.

 l Unlike ovals and ellipses, circles cannot be reshaped. When a Reshape handle is dragged on a circle, it is only resized.
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Concentric Resize
 l The Concentric Resize edit handle displays on the perimeter of a circle between a corner Reshape handle and the 

center. Click and drag this handle to resize the circle without moving its center point. 

USING DIMENSIONS

             Dimensions can be used to move or resize circle-based objects. See Moving Objects Using Dimensions on page 341.

USING THE SPECIFICATION DIALOG

             Circles, ovals and ellipses can be edited using their specification dialogs. See Circle/Oval/Ellipse Specification 
Dialog on page 217. 

USING THE EDIT TOOLBAR

A selected circle, oval or ellipse can be edited in a variety of ways using the buttons on the Edit Toolbar.  

The following toolbar buttons may display on the Edit Toolbar for a selected circle, oval or ellipse:

  Select Next Object selects nearby objects instead of the selected object. See Selecting Objects on page 142.

  Open Object opens the specification dialog for the selected object(s). See Specification Dialogs on page 20.

  Copy/Paste copies the selected object(s) to the system clipboard so they can be pasted elsewhere. See Copying 
and Pasting Objects on page 118.

  Delete deletes the selected object(s). See Deleting Objects on page 191.

  Transform/Replicate Object copies, moves, rotates, resizes, or reflects the selected object(s). See 
Transform/Replicate Object Dialog on page 183.          

  Make Parallel/Perpendicular makes the selected edge parallel or perpendicular to another straight edge. See 
Make Parallel/Perpendicular on page 171.         

  Point to Point Move accurately moves the selected object(s). See Point to Point Move on page 169.           

  Center Object centers an object along a wall within a room or relative to a cabinet fixture. See Center Object on 
page 172.         

  Reflect About Object reflects the selected object(s) about another object. See Reflecting Objects on page 180.           

  View Drawing Group Edit Tools modifies the selected object’s place in the drawing order. See Drawing Group 
Edit Tools on page 129.         
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  Convert Polyline converts the object into a special polyline-based object. See Convert Polyline on page 182.          

 

Editing Multiple Objects
There are a               couple of options for accurately and efficiently editing multiple objects at once. See Selecting Multiple Objects 
on page 145. 

DYNAMIC DEFAULTS

Dynamic defaults are a useful way to apply certain attributes to multiple objects of the same type throughout a plan. They 
are found in the defaults dialogs for a variety of different architectural objects, and when these default values are changed, 
all objects that are set to use them throughout the current plan will update automatically. Dynamic defaults are particularly 
valuable for applying critical defaults like ceiling heights and floor structure. See Dynamic Defaults on page 58.          

IN THE SPECIFICATION DIALOG

When multiple objects are selected, the Open Object edit button is often available. The settings available in a shared 
specification dialog will vary, depending on the types of objects that are selected. If the objects are of the same type, 

their shared specification dialog will have many of the settings that their individual specification dialogs have; if they are 
not similar, the dialog may have only a few settings. When multiple objects are selected, their shared specification dialog 
may also have settings in a “No Change” state. See Specification Dialogs on page 20.         

USING THE EDIT TOOLBAR

Group-selected objects can also be edited using the buttons on edit toolbar. The available tools will vary, depending on 
which types of objects are selected. See The Edit Toolbar on page 92.         

 

Moving Objects
Objects can be moved using the edit handles as well as a variety of edit tools. Multiple selected objects can also be moved 
as a group. See Selecting Objects on page 142.

USING THE EDIT HANDLES

Select an object, then click the Move edit handle and drag it to a new location. When your pointer is over the Move handle, 
it displays a four-headed arrow  . 

As an object is moved, it jumps at set increments when Grid Snaps  are enabled. See Grid Snaps on page 116.

When Object Snaps  are enabled, a selected object snaps to its original location if it passes over that location while 

being moved.          
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The behavior of the Move edit handle varies depending on the currently active Edit Behavior . See Defaults, 

Preferences, and Edit Behaviors on page 138.            

 l If the Default , Resize , Concentric  or Fillet  edit behavior is active, the object moves orthogonal, or at 

a right angle to, any of its edges.          
 l If the Alternate  edit behavior is active, the selected object(s) can be moved at Allowed Angles if Angle Snaps 

 are enabled, or orthogonal to any of its edges if they are not. See Alternate on page 139.          

You can temporarily slow the movement of your mouse as you drag an edit handle by  holding down the Shift key.

BUMPING/PUSHING

When Edit> Snap Settings> Bumping/Pushing is enabled, architectural objects will bump into and can push one 
another as they are moved. This setting also affects CAD and CAD-based objects with CAD Stops Move and/or 

Wall Stops Move enabled. See Line Style Panel on page 209.         

When an object bumps into another object while it is being moved, it stops. If you do not release the mouse button and 
continue to drag, however, the selected object resumes movement and continues past the obstructing object. 

Instead of dragging through and past obstructing objects, you can instead push them. To do this, bump an object into an 
obstructing object and release the mouse button. Then, click and drag the Move edit handle a second time in the same 
direction. 

Walls, wall openings, cabinets, furnishings and fixtures, and CAD and CAD-based objects are examples of objects that can 
bump into as well as push other objects. Electrical Connections and Custom Backsplashes are examples of objects that are 
not affected by Bumping/Pushing.

By default, Bumping/Pushing  does not affect objects moved using dimensions. See Moving Objects Using Dimensions 

on page 341. 

The Maximum Bump Distance, which is the distance you must drag to override bumping, is set in the Preferences dialog. 
Bumping/Pushing for Type-in Movement can also be enabled there. See Snap Properties Panel on page 82.           

Certain types of objects, notably roof planes, and objects on locked layers can be bumped but cannot be pushed. See Layer 
Display Options Dialog on page 127.           

CAD STOPS MOVE/WALL STOPS MOVE

CAD and CAD-based objects can be set to stop at other CAD objects and/or at walls as they are being moved. See Line 
Style Panel on page 209.          

Some objects, such as cross boxes, framing members and insulation, are automatically set to stop when moved against other 
CAD objects.           

CAD Stops Move and Wall Stops Move do not function if Bumping/Pushing  is turned off.          

UNRESTRICTED MOVEMENT

Many objects have restrictions placed on their movement by their own properties or specification settings. Architectural 
objects, for example, bump into other 3D objects as they are being moved when Bumping/Pushing  is enabled.

CAD-based objects can be set to stop at other CAD objects or at walls. See Line Style Panel on page 209. 

Other move restrictions are activated by the Snap Settings . See Snap Behaviors on page 113.
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These restrictions can be overridden when necessary by holding down the Ctrl/⌘  key while dragging to move an object.

To move an object freely

 1.  Select the object. 

 2.  Hold down the Ctrl/⌘  key.

 3.  Click the Move edit handle and drag it to the new location.

You can also press the Ctrl/⌘  key while dragging an object’s Move handle to override move restrictions. 

NUDGING

You can use the arrow keys on your keyboard to move a selected object or objects by single Snap Grid increments in 2D 
and 3D views. This is referred to as nudging. See Grid Snaps on page 116.

In Plan View

To nudge an object in plan view, select it and press any of the four arrow keys: Up, Down, Left, or Right. These directions 
are relative to the Snap Grid: if Rotate Plan View  is used to rotate plan view, the definitions of up, down, left, and right 

are affected. See Rotate Plan View on page 104.

In 3D Views

In 3D views, nudging is relative to the selected surface. If, for example, you select the front of a cabinet in 3D and nudge it 
to the left, it will move to the left in plan view. If you instead select the back of a cabinet in 3D and nudge it to the left, it 
will move to the right in plan view. 

When multiple objects are selected, the surface that was clicked on last is considered the selected surface. When nudged, all 
selected objects will move relative to that surface. See Shift and Ctrl/⌘  Select on page 146. 

If an object is rotated, the directions that it can be nudged in 2D are not affected; however, in 3D, they are. If, for example, 
a cabinet is rotated 45º, it will nudge to the left as defined by the Snap Grid in plan view. When nudged in 3D, however, it 
will move at a 45º angle to the Snap Grid: or parallel to the selected surface.

POINT TO POINT MOVE

The Point to Point Move edit button allows a selected object or group of objects to be accurately moved.          

The Point to Point Move tool is often most effective when used in combination with Object Snaps. Bear in mind that it is 
also affected by Grid Snaps, and that in some situations you may want to toggle snaps off. See Snap Behaviors on page 113. 

To use Point to Point Move

 1.  Select one or more objects that you would like to move, then click the Point to Point Move  edit button.          

 2.  A temporary CAD point   preview follows the mouse pointer, which displays the Point A   icon. Click on a point 
that you want to accurately reposition: a temporary point is placed at that location. 

 3.  Move the mouse pointer:              

 l An extension line extends from Point A to the pointer, which now displays the Point B   icon and is followed 
by a preview outline of the selection and another temporary point preview. 
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 l You can move the mouse at any angle, making it easier to use Object Snaps.

 l Hold down the Shift key to moved at Allowed Angles only. See Angle Snaps on page 115.       

 4.  Click on the point on an object or in the plan where you would like the selected point to be relocated when it is 
moved.         

 5.  The selected object(s) are moved so that they maintain their position relative to the point and both temporary points 
are deleted.         

To retain a copy of the selected object(s) in the original location, the Copy/Paste  edit button before clicking the Point 

to Point Move button. See To use Copy/Paste with other edit tools on page 121.

Point to Point Move can also be used with the Edit Area  tools. See Edit Area Tools on page 186.         

USING CENTER OBJECT

The Center Object edit button allows you to move walls, cabinets and other objects so that they are centered along a 
wall within a room or relative to a window or cabinet.              See Center Object on page 172.          

MOVE TO FRAMING REFERENCE

Framing members can be positioned relative to a Framing Reference using the Move to Framing Reference edit 
tool. See Framing Reference Markers on page 651.         

USING DIMENSIONS

Objects or the selected edges of some objects can be moved using dimensions. See Moving Objects Using 
Dimensions on page 341.         

When Bumping/Pushing for Type-in Movement is checked in the Preferences dialog, adjacent objects can be pushed 
when an object is moved using dimensions.         

Note: By default, objects moved using dimensions are not subject to 
Bumping/Pushing. See Bumping/Pushing on page 168.

USING THE TRANSFORM/REPLICATE OBJECT DIALOG

Objects and groups of objects can be moved relative to themselves or an absolute location using the Transform 
Replicate Object dialog. See Transform/Replicate Object Dialog on page 183.         

 

Aligning Objects
It is often important to align objects such as text boxes, roof plane edges, or walls, or to align objects on different floors. 
There are several methods to choose from.   

USING THE CROSSHAIRS

Objects can be aligned by eye using the mouse pointer crosshairs as a reference. This method can help you draw, place and 
edit objects quickly, easily, and with reasonable accuracy, but is not necessarily as accurate as some of the other approaches 
described here. See Crosshairs on page 15.
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The mouse pointer crosshairs can be turned on and off and their size and aperture set in the Preferences dialog. See Edit 
Panel on page 79.

USING SNAP SETTINGS

With Object Snaps  on, you can snap the edge of a selected object to that of another. Select an edge of an object. 
Drag it to the edge of another object to reveal an Object Snap point, then release the mouse.

With Grid Snaps on and Angle Snaps off, select the left side of the object, and drag from the center move 
handle. This snaps the selected side to the grid.

When both Grid Snaps     and Angle Snaps    on, objects snap at increments equal to the Snap unit specified in the Plan 
Defaults dialog rather than onto the grid itself. This does not align objects to the grid unless they were already snapped to 
the grid. See Snap Behaviors on page 113. 

USING DIMENSIONS

Create a temporary or manual dimension relative to an object such as a wall or line, and relocate the objects to the 
same dimension. See Moving Objects Using Dimensions on page 341.    

Text objects can be aligned using settings in the Text 
Specification dialog. See Aligning Text on page 359.

CAD STOPS MOVE/WALL STOPS MOVE

CAD and CAD-based objects can be aligned using another CAD object or a wall as a guide. Check the CAD Stops Move 
and/or Wall Stops Move boxes in the objects’ specification dialogs, then move them until they bump into the CAD object 
or wall that you wish to use as a guide for alignment. See Line Style Panel on page 209.    

MAKE PARALLEL/PERPENDICULAR

The Make Parallel/Perpendicular edit button allows you to make an object's Selected Edge parallel or perpendicular 
to any straight line or edge.   

If you select an edge of a polyline-based object, adjacent edges extend or contract to maintain contact, but other edges 
remain unchanged. The selected edge rotates about its endpoint if selected near the end, or about its center if you click 
within its middle third.

A few objects, such as camera symbols, are not eligible to be used as an axis for the Make Parallel/Perpendicular tool.   

To use Make Parallel/Perpendicular

 1.  Select an object such as a roof plane on the edge that you would like to make parallel or perpendicular to another 
object or feature.     

 l Click near the center of the selected edge to lock the midpoint when the edge's angle is changed.      

 l Click near one end of the selected edge to lock that end when the edge's angle is changed.    

 2.  Click the Make Parallel/Perpendicular  edit button.

 3.  If you want to rotate the entire polyline instead of changing the angle of the selected edge, double-click on the Make 
Parallel/Perpendicular  button and select the option to Rotate entire polyline in the Make 
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Parallel/Perpendicular dialog. This setting is global for the duration of the current program session. See Make 
Parallel/Perpendicular with Polyline-Based Objects on page 180.

 4.  As the pointer passes over an eligible object, it becomes highlighted and a dashed make parallel/perpendicular axis 
line displays.     

 l An axis collinear with an object edge can be used.

 l An axis through the midpoint of and perpendicular to an object edge can be used.

 l An axis that splits the angle at a corner between two connected object edges or walls can be used.

 5.  When an axis displays, a preview of the selection to be made parallel/perpendicular will also display, indicating its 
new shape if edited using that axis.          

 6.  When the axis and preview meet your needs, click once. If the first object is within 45° of parallel to the axis, it is 
made parallel. Otherwise, it is made perpendicular to the axis.     

CENTER OBJECT

The Center Object edit button can be used to center a variety of objects either relative to another object. Center 
Object can be used to center architectural objects in plan view, cross section/elevation, and 3D views. It can also be 

used to center CAD objects in plan view, cross section/elevation views, and layout. 

A few objects, such as camera symbols, are not eligible to be used as a centering axis.    

To use the Center Object edit tool

 1.  Select one or more objects that you would like to center relative to another object or feature.    

 2.  Click the Center Object      edit button.    

 3.  Move the mouse pointer over the object you would like to center the selected object relative to.    

 4.  As the pointer passes over an eligible object, it becomes highlighted and a dashed centering axis line displays.     

 l A centering axis collinear with an edge can be used.

 l A centering axis through the midpoint of and perpendicular to an edge can be used.

 l A centering axis that splits the angle at a corner between two connected object edges or walls can be used.

 5.  When the centering axis displays, a preview of the selection to be pasted will also display, indicating where it will be 
located if centered along that axis.          

 6.  When the centering axis and preview meet your needs, click once to center the selected object along that axis line.    
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To center an object in a room

 1.  Select one or more objects that you would like to center relative to a room.    

 2.  Click the Center Object      edit button.    

 3.  Move the mouse pointer in the room that you would like to center the selected object relative to.

 l When a room is being used for centering, its area will be highlighted.

 l As you move the pointer, a centering axis will display along the wall it is closest to. 

 l If you move the pointer near a wall corner, the centering axis will split the angle of that corner.    

 l The selected object does not have to be inside a room in order to be centered relative to that room.     

 4.  When a centering axis displays, a preview of the selection to be pasted will also display, indicating where it will be 
located if centered along that axis.          

 5.  When the centering axis and preview meet your needs, click once to center the selection relative to the room.     

Objects can also be centered relative to the Exterior Room. See The Exterior Room on page 292.    

To retain a copy of the selected object(s) in the original location, the Copy/Paste  edit button before clicking the Center 

Object button. See To use Copy/Paste with other edit tools on page 121.

ALIGNING ARC CENTERS

The center points of circles and arc-based objects can be aligned, even if the objects are on different floors, when the 
Reference Display is turned on and Arc Centers and Ends  is toggled on. Note that Arc Centers and Ends is a floor-

specific toggle. See The Reference Display on page 525 and Arc Centers and Ends on page 153.    

To align center points easily, it is helpful to turn on Object Snaps  and turn off Angle Snaps . See Object Snaps on 

page 114 and Angle Snaps on page 115.    

ALIGNING OBJECTS ON DIFFERENT FLOORS

Objects on different floors can be aligned with one another using Object Snaps  and the Reference Display . See 

Object Snaps on page 114 and The Reference Display on page 525.

 

Resizing Objects
Objects can be resized using the edit handles, specification dialogs, and the Transform/Replicate Object dialog. 

USING THE EDIT HANDLES

Depending on the currently active Edit Behavior , the end, corner and/or side edit handles can be used to resize a 

selected object. See Defaults, Preferences, and Edit Behaviors on page 138.

When the Concentric  edit behavior is active, dragging an object’s corner or end handle  resizes it according to the 

Concentric Jump value set in the Preferences dialog. See Concentric on page 140.          
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Objects can be resized about either their center points or the current CAD point. See Rotate/Resize About on page 179.          

To override any movement restrictions caused by snap settings or the presence of other objects, press the Ctrl/⌘  key while 
dragging an edit handle.

As an object is resized, any dimensions indicating its size will update to reflect your changes. You can use dimensions as 
references to help you achieve the correct size for most objects. 

You can temporarily slow the movement of your mouse as you drag an edit handle by  holding down the Shift key.

USING THE SPECIFICATION DIALOG

Most objects can be accurately resized in their specification dialogs. See Specification Dialogs on page 20. 

USING DIMENSIONS

Many objects can be resized by selecting an edge and then moving that edge using dimensions. See Moving Objects 
Using Dimensions on page 341.         

Walls can also be resized using dimensions; however, it is important to understand that the selected edges of other objects 
cannot be resized using dimensions - they can only be moved. To resize an edge, select an adjacent edge and move that edge 
instead.         

CONCENTRIC RESIZE

The Concentric Resize edit tool allows you to resize a selected object using its edit handles so that the distance 
moved by each edge is the same. For example, you can resize an irregularly shaped polyline so that each edge is 

exactly ten feet in from the original position, which is useful for creating site plans with setbacks. The behavior will vary 
depending on the shape of the object and the edit handle used to resize it. See Concentric on page 140.

When the Concentric Resize edit button is clicked, three new edit buttons display on the Edit Toolbar:

  Click the Sticky Mode edit button to remain in the current mode and resize the selected object repeatedly. See 
Sticky Mode on page 121.

  Click the Set Concentric Jump edit button to specify how much each of the object's edges moves when 
concentrically resized. The Jump Distance set in the Set Concentric Jump Distance dialog is a global value and 

is the same as the Jump Distance set in the Preferences dialog. See Behaviors Panel on page 81. 
  Click the Main Edit Mode edit button or press the Esc key to return to the selection's main Edit Toolbar.

USING THE TRANSFORM/REPLICATE OBJECT DIALOG

Most objects can be resized about either their centers or an absolute point using the Transform Replicate Object 
dialog. See Transform/Replicate Object Dialog on page 183.         

 

Reshaping Objects
There is a variety of ways to reshape objects using the edit handles, specification dialogs and edit toolbar buttons.

Some objects, notably circles and box-based objects, cannot be reshaped - only resized. See Resizing Objects on page 173.
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USING THE EDIT HANDLES

Depending on the Edit Behavior  in use, the end, corner and/or side edit handles can be used to reshape a selected 

object. See Defaults, Preferences, and Edit Behaviors on page 138.

When a line-based, arc-based, or open polyline-based object is selected, you can right-click and drag an end handle to 
change a line into an arc or vice versa. This behavior does not apply to closed polylines.         

To override any movement restrictions caused by snap settings or the presence of other objects, press the Ctrl/⌘  key while 
dragging an edit handle.

You can temporarily slow the movement of your mouse as you drag an edit handle by  holding down the Shift key.

USING THE SPECIFICATION DIALOG

A variety of CAD and CAD-based objects can be reshaped by editing values on either the SELECTED LINE or 
SELECTED ARC panel of their specification dialogs. See Polyline Specification Dialog on page 219.

USING DIMENSIONS

Both temporary and manually drawn dimensions can be used to increase or decrease the distance between the edge a 
line- or polyline-based object and another, parallel edge or line. See Moving Objects Using Dimensions on page 341.         

Angular Dimensions  can be used to adjust the angle where two polyline segments meet. See Using Angular 

Dimensions on page 179.         

ADD BREAK

The Add Break edit tool can be used to break an individual line-, arc-, or spline-based object into two segments. The 
edges of a polyline-based object can also be broken.         

Note: The Add Break edit button is not available for box-based objects, 
objects created with the Circle Tools, North Pointers, Sun Angles, Joist 
Direction Lines, or some architectural objects such as stairs and trusses.

There are two types of breaks: partial and complete. A partial break creates a new corner or pivot point between two 
connected segments, while a complete break actually severs an edge into two disconnected segments.         

To create a partial break

 1.  Select the object, object edge, or the centerline of the object that you want to add a pivot point or corner to.         

 2.  Click the Add Break  edit button once or press the 3 key. 

 3.  If you would like to create more than one break, click the Sticky Mode  edit button. 

 4.  If you want, you can click the Corner Edit Handles  edit button to toggle off their display.         

 5.  Click the edge to create a new corner edit handle at that location and two separate edges on either side of that 
handle.         
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 6.  If you enabled Sticky Mode , continue clicking to place additional breaks.         

 7.  Click the Main Edit Mode  edit button or press the Esc key to return to the selected object’s main edit toolbar.         

If you click and drag one of the edit handles on either side of the partial break, the edge moves at a right angle to itself and 
another edge forms, connecting the moved edge with the one on the other side that does not move.         

You can remove an edge from a polyline-based object by clicking and dragging a corner handle until it snaps to an adjacent 
corner handle.         

When a complete break is created, the object or edge is totally severed at that point.          

With the exception of framing members, complete breaks cannot be created on CAD-based architectural objects. In the case 
of framing members, only complete breaks can be created.         

To create a complete break

 1.  Click the object, object edge, or object centerline that you want to break into two segments.         

 2.  Click the Add Break  edit button. 

 3.  Click the Complete Break  edit button. 

 4.  If you would like to create more than one complete break, click the Sticky Mode  edit button. 

 5.  If you want, you can click the Corner Edit Handles  edit button to toggle off their display.         

 6.  Click on an edge to create a complete break at that location.         

 7.  If you enabled Sticky Mode , continue clicking to place additional breaks.         

 8.  Click the Main Edit Mode  edit button or press the Esc key to return to the selected object’s main edit toolbar.         

The edge that you clicked on will be divided into two separate sections, one of which will be selected. You can now move 
or edit the selected edge completely independent of the object or edge on the other side of the break. Click on the other edge 
to select it instead.         

When Object Snaps  are enabled, breaks can be placed at snap locations such as midpoints. See Object Snaps on page 

114.          

To remove a break from an edge

 1.  Make sure that Object Snaps  are enabled. See Object Snaps on page 114.

 2.  Select the object that has a break that you want to remove.         

 3.  Click on the corner edit handle associated with the break that you want to remove and drag it to an adjacent corner 
handle.         

 4.  When you see an Endpoint  snap indicator, release the mouse button. The handle that you selected will be 

removed.         

CHANGE LINE/ARC

Select an individual line-based or arc-based object or a segment of a polyline-based object and click the Change 
Line/Arc edit button to convert the selected segment from a line to an arc or vice versa.
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USING MAKE PARALLEL/PERPENDICULAR

The Make Parallel edit button can be used to reshape a polyline by making a selected edge parallel or perpendicular 
to another straight edge. See Make Parallel/Perpendicular on page 171.         

INTERSECT/JOIN TWO LINES

The Intersect/Join Two Lines edit tool allows you to connect two non-parallel line- and/or arc-based objects or to 
join two edges of an open or closed polyline-based object. The lines or edges will shorten or lengthen as need to 

intersect at a point and join. If one or more edges exists between the two polyline edges, they will be removed.         

To use Intersect/Join Two Lines

 1.  Click on a line, arc, or polyline segment that you would like to connect to another line or segment.         

 2.  Click the Intersect/Join Two Lines  edit button.         

 3.  Click on the other line or polyline edge.         

 4.  If there are intervening polyline edges, a message will confirm that you would like them to be removed. Click Yes.         

FILLET LINES

The Fillet Lines edit tool allows you to replace the angled corner where two polyline edges meet with an arc.          

Fillet Lines can also be used to join two non-parallel line-based objects with an arc. If one or both of the two objects is an 
arc, both will extend or contract as needed to become connected. No additional arc is created.         

To use Fillet Lines

 1.  Click on a line or polyline segment that you would like to connect to another line or segment with a fillet, or arc.         

 2.  Click the Fillet Lines  edit button, then click the Fillet Radius  edit button.         

 3.  In the Set Fillet Radius dialog, specify the desired Fillet Radius and click OK. If this value is 0, no fillet will be 
created.         
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 4.  To apply a fillet to more than one corner of the selected polyline, click the Sticky Mode  edit button.         

 5.  Click on the line or polyline segment that you want the selected line or edge to connect to with a fillet.         

 6.  If you enabled Sticky Mode , continue clicking on edges to create additional fillets.         

 7.  Click the Main Edit Mode  edit button or press the Esc key to return to the selected object’s main edit toolbar.         

Once two lines are filleted, the arc between them can be edited. See Editing Arc-Based Objects on page 149.         

CHAMFER LINES

The Chamfer Lines edit tool allows you to create a straight corner bevel of a specified size connecting any two non-
parallel lines or polyline edges. The Chamfer Distance set in the Chamfer Distance dialog describes the distance both 

lines that form the corner are shortened to produce the bevel: not the length of the bevel itself.

The Chamfer Lines tool can also be used to extend an arc so that it joins to another arc or line. If one or both of the two 
objects is an arc, both will extend or contract as needed to become connected. No additional chamfer is created.          

The Chamfer Lines edit tool is used much the way the Fillet Lines edit tool is. See To use Fillet Lines on page 177, above.           

The Fillet Lines and Chamfer Lines edit tools can also be used 
the same way as the Intersect/Join Two Lines tool to join lines 

and polyline edges and remove any intervening polyline edges. 

USING CLOSE POLYLINE

An open polyline-based object can be converted into a closed polyline using the Close Polyline edit tool. See Close 
Polyline on page 157.          

SIMPLIFY POLYLINE

The Simplify Polyline edit button is available for an open or closed polyline or polyline-based object with a segment 
that is unusually short and can cause problems when editing the polyline’s shape. Click this edit button to remove the 

segment.         

 

Rotating Objects
Objects can be rotated using the edit handles as well as a variety of edit tools. Multiple selected objects can also be rotated 
as a group. See Selecting Objects on page 142. 

By default, an object or group of objects  rotate about the center point of the selection set. You can instead specify that 
objects rotate about the current CAD point.  See The Current Point on page 202.
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USING THE EDIT HANDLES

Select an object, then click the triangular Rotate edit handle and drag it in any direction. When your pointer is over the 
Rotate handle, it displays a curved arrow  .

The angles of line-based objects can also be changed by dragging an end handle in a direction other than parallel to the 
object. The object rotates about the opposite end point. See Editing Line-Based Objects on page 146.

When Angle Snaps  are enabled, objects snap to Allowed Angles as specified in the Plan Defaults dialog as they are 

rotated. See Angle Snaps on page 115. 

To override any movement restrictions caused by snap settings or the presence of other objects, press the Ctrl/⌘  key while 
dragging an edit handle.

You can temporarily slow the movement of your mouse as you drag an edit handle by  holding down the Shift key.

USING THE SPECIFICATION DIALOG

The exact angle of some objects such as lines, arcs, walls and the selected edges of polylines can be specified on 
either the GENERAL panel, SELECTED LINE panel, or SELECTED ARC panel of that object’s specification dialog. See 

Polyline Specification Dialog on page 219.

ROTATE/RESIZE ABOUT

Objects can be rotated about either their own centers or the current CAD point. See The Current Point on page 202.          

Rotate About Object Center Rotate About Current Point

You can specify which behavior is used by selecting Edit> Edit Behaviors> Rotate/Resize About Current Point . 

When this option is selected, objects rotate about the current CAD point; when it is not selected, object rotate about their 
centers.           

The Rotate/Resize About behavior can also be specified in the Preferences dialog. See Behaviors Panel on page 81.           

USING ANGULAR DIMENSIONS

Angular Dimensions are useful for adjusting the angles of a variety of objects with straight edges. See Angular 
Dimensions on page 332.         

To change an angular dimension

 1.  Draw an Angular Dimension  between the objects you want to move.          

 l Begin and end as close as possible to the two objects you wish to locate.          

 2.  Select the edge that you want to move.          

 3.  Click the dimension value to open the Set Angular Dimension dialog.          

 l The Previous Value is indicated degrees, minutes and seconds.           
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 4.  Enter a value in the New Value field.          

 5.  Select Rotate Edge to move the selected edge when OK is clicked or select Rotate entire polyline to rotate the 
entire object the selected edge is a part of, maintaining the Previous Value of the angle.          

 6.  Click OK to apply the change.          

When an entire polyline is rotated using the Set Angular Dimension dialog, it rotates around the vertex of the angle.           

MAKE PARALLEL/PERPENDICULAR WITH POLYLINE-BASED OBJECTS

The Make Parallel/Perpendicular edit button usually adjusts the angle of a selected polyline edge. See Make 
Parallel/Perpendicular on page 171.          

To rotate the entire polyline instead, double-click the Make Parallel  edit button to open the Make Parallel dialog.           

Choose to either Rotate Selected Edge Only, or Rotate Entire Polyline. This setting is global, affecting all files, and is 
retained during the current program session.           

Polylines rotate according to the current Rotate/Resize About setting. See Behaviors Panel on page 81.          

USING THE TRANSFORM/REPLICATE OBJECT DIALOG

Objects and groups of objects can be rotated to a relative or absolute angle using the Transform Replicate Object 
dialog. See Transform/Replicate Object Dialog on page 183.         

 

Reflecting Objects
There are several ways to reflect an object, group of objects, or an entire plan about an axis or another object. Either the 
original object(s) or copies of the original(s) can be reflected.         

REFLECT ABOUT OBJECT

A selected object or objects can be reflected about another object, regardless of its angle, using the Reflect About 
Object edit tool.         

Most objects have one or more axes that can be used.         
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 l When line-based object is used as the reflective object, the reflection axis can be either collinear with the object's 
centerline or perpendicular to it and running through its midpoint.

 l When an open or closed polyline-based object is used as the reflective object:
 o A reflection axis collinear with an object edge or line-based object's midpoint can be used.
 o A reflection axis through the midpoint of and perpendicular to an object edge can be used.
 o A reflection axis that splits the angle at a corner between two connected object edges can be used.

 l Rooms and the walls that define them can also be used as reflective objects: much like closed polyline-based objects.
 l When a circle or box-based object such as a CAD box or cabinet is used as the reflective object, the axis runs down 

the center of the object from back to front.         
 l In 3D views, architectural objects can only be reflected about a vertical axis - not a horizontal axis.         
 l A few objects, such as camera symbols, are not eligible to be used as a reflective object.         

To use Reflect About Object

 1.  Draw a CAD line to act as the reflection line.         

 2.  Select the object(s) to be reflected.         

 3.  Click the Reflect About Object  edit button.         

 4.  Move your mouse pointer over a CAD line, object edge, or other object that you would like to reflect the selection 
about.

 5.  When the mouse pointer is over a valid reflection axis, a preview of the selection to be pasted will display on the 
opposite side of the axis as the original.          

 6.  Click once when the preview meets your needs. The selection is reflected around the CAD line, and the original is 
no longer there.         

To retain a copy of the selected object(s) in the original location, click the Copy/Paste  edit button before clicking the 

Reflect About Object button. See To use Copy/Paste with other edit tools on page 121.         

USING TRANSFORM/REPLICATE OBJECT

Objects and groups of objects can also be reflected horizontally or vertically using the Transform Replicate Object 
dialog. See Transform/Replicate Object Dialog on page 183.         

REVERSE DIRECTION

Select a line-based, arc-based, open spline-based, or open polyline-based object and click the Reverse Direction edit 
button to reverse its direction. Not available for Terrain Path objects.         

Reversing an object's direction switches its Start and End points and can be useful with certain line styles or if the selected 
object has an arrow at one end. The Reverse Direction tool also reverses the direction in which a selected Walkthrough 
Path is recorded. See Walkthrough Paths on page 864.

REVERSE PLAN

The Reverse Plan tool reflects architectural and CAD objects on all floors of an entire plan, as though they were 
flipped about a vertical line. See Reverse Plan on page 105.
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Note: Reverse Plan does not affect the Terrain objects. See Terrain on 
page 890.

 

Converting Objects
CAD objects and many CAD-based objects can be converted into a variety of other types of objects.

CONVERT POLYLINE

The Convert Polyline edit tool lets you turn CAD-based objects into a different type of CAD-based object. Examples 
include countertop, stair landings, special polylines such as Materials List Polylines, and a variety of slab, hole and 

terrain objects.         

To convert a CAD-based object into a different object type, select the object               in plan view and click the Convert Polyline 
 edit button to open the Convert Polyline dialog.         

 
Polyline Types
The various polyline types that the selected object can be converted into are listed here. Click the radio button beside one 
line item in this list to select it.

  CAD
 l Plain Polyline - See Polylines on page 218.         

 
Architectural
These settings are only available if the selected polyline is closed. See Polylines on page 218.         
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 l Backsplash - Only available in cross section/elevation views. See Custom Backsplashes on page 452.         

 l Countertop - See Countertops on page 451.         

 l Landing - Not available if the polyline is a spline. See Landings on page 539.          

 l Skylight - Only available when the selected polyline is contained inside a single roof plane. See Skylights and Roof 
Holes on page 612.          

 l Slab and Slab with Footing - See The Slab Tools on page 508.          

 
Terrain
Most of these options are only available when a Terrain Perimeter is present.         

 l Elevation Line/Region - See Elevation Data Tools on page 893.           

 l Terrain Break - See Elevation Data Tools on page 893.           

 l Garden Bed - Only available when the selected object is a closed polyline. See Terrain Features on page 899. 

 l Grass Region - Only available when the selected object is a closed polyline. See Terrain Features on page 899.         

 l Flat Region - Only available when the selected object is a closed polyline. See Terrain Modifier Tools on page 898.   

 l Hill/Valley - Only available when the selected object is a closed polyline. See Terrain Modifier Tools on page 898.

 l Raised/Lowered Region - Only available when the selected object is a closed polyline. See Terrain Modifier Tools 
on page 898. 

 l Terrain Wall - See Terrain Walls on page 901.

 l Terrain Curb - See Terrain Curbs on page 902.  

 l Sprinkler Line - See Sprinkler Tools on page 942. 

 l Terrain Feature - Only available when the selected object is a closed polyline. See Terrain Features on page 899.           

 l Terrain Perimeter - See Terrain Perimeter on page 891. This option is only available when: the polyline is closed, 
a Terrain Perimeter does not yet exist, and only one polyline is currently selected.

   Other
 l Walkthrough Path - See Walkthrough Paths on page 864.          

 
Retain Original Polyline

When this box is unchecked, the originally selected polyline is replaced by a polyline of the type selected above. Check this 
box to instead keep both the original and converted polylines.                  

Click OK to convert the selected object or objects.          

 

Transform/Replicate Object Dialog
Select any object or group of objects and click the Transform/Replicate Object edit button to open the 
Transform/Replicate Object dialog.         

If multiple options are selected in the Transform/Replicate Object dialog, they are performed in the order they appear in the 
dialog, from top to bottom.         
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Always double-check values entered in the Transform/Replicate 
Object dialog. Large offset values, resize factors, or numbers of 

copies can result in objects that are time-consuming to create or may be 
off the screen. 

 
Copy

Check Copy, then specify the Number of Copies to make. Not available when certain object types are selected: for 
example, Roof Baselines.  

 
Move

Check Move, then specify how far and in what direction to move the selected object(s).    

There are three ways to define where you want to move the selection in the horizontal XY plane:

 l Specify the desired X Delta and Y Delta values, which are the object’s changes in position along the X and Y axes.
Only available when the Relative to Itself or Relative to Current Point radio button is selected as the movement 
reference. See The Current Point on page 202.     

 l Specify the desired X Position and Y Position values, which define a point along the X and Y axes.
Only available when Absolute Location is selected as the movement reference. See 3D Drafting on page 12.     
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 l Specify the Angle of movement and the Distance that you want the selection to move.     

 o Select Relative Angle to Itself to move the selection relative to its current orientation. When this option is selected, 
the selection's current absolute orientation is reported in the Angle field and can be changed.    

 o Select Absolute Angle to move the selection relative to an imaginary horizontal line drawn in the positive X 
direction from the origin.

When the X/Y Delta or X/Y Position settings are changed, 
the information in the Angle and Distance fields will update 

automatically, and vice versa.

You can also specify the Z Delta, which is the selection's elevation on the vertical Z axis. This setting is always relative 
to the selection's original elevation.

 
Rotate

Select this option, then specify the Angle to rotate the object(s).         

 l Select Absolute Angle to rotate the object relative to an imaginary horizontal line drawn in the positive X direction 
from the origin. 

 l Select Relative Angle to rotate the object the specified angle relative to its current orientation.
You can also specify the point the selected object(s) rotate about, below.          

 
Resize

Specify the Resize Factor in decimals. A resize factor of 2 doubles the size of the object, while a resize factor of 0.5 halves 
the object’s size. Not available for all objects, including line- and arc-based objects.          
You can also specify the point the selected object(s) is resized about, below.          

 
Reflect

Select this option, then specify which axis to reflect about.         

 l Horizontally - Select this option to reflect the object horizontally.

 l Vertically - Select this option to reflect the object vertically.

You can also specify the point the selected object(s) is reflected about, below.          

 
Rotate/Resize/Reflect About

This section is enabled when the Rotate, Resize and/or Reflect functions are selected.         

 l X Position - Specify the X coordinate of the point to perform the selected edit function(s) about when About 
Absolute Point is selected.

 l Y Position - Specify the Y coordinate of the point to perform the selected edit function(s) about when About 
Absolute Point is selected.

 l About Object Center - Select this option to perform the selected edit function(s) about the object’s center.

 l About Absolute Point - Select this option to perform the selected edit function(s) about the specified point.

 l About Current Point - Select this option to perform the selected edit function(s) about the current CAD point.
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Edit Area Tools
The Edit Area Tools allow you to quickly define an area of your plan and select the objects in that area. Once 
selected, they can then be repositioned, copied or deleted. Select Edit> Edit Area to access the Edit Area Tools.

Unlike other selection methods, the Edit Area Tools cut walls, railing and fencing where the selection marquee intersects 
them, allowing you to edit only the selected portion of these objects. 

Some objects, such as cabinets, are included in the selection only if more than half of the object is contained within the 
marquee.  

Camera and cross-section/elevation symbols are included in the selection and can be moved with it. While cameras can also 
be rotated as well as copied, cross section/elevations cannot. See Editing 3D Views on page 791. 

A few objects, notably CAD points, are not affected by the Edit Area Tools.

The Edit Area tools can cause wide-spread changes across an 
entire plan and should always be used with caution.

EDIT AREA

Select Edit> Edit Area> Edit Area and draw a rectangular marquee around the area of the plan to be edited. 

Edit Area affects all objects included in the selection marquee that are located on the current floor, regardless of whether 
they are displaying in plan view or not.

EDIT AREA VISIBLE

Select Edit> Edit Area> Edit Area Visible and draw a marquee around the area of the plan to be edited. 

Edit Area Visible only affects visible objects included in the selection marquee: objects not currently displayed in plan 
view are unaffected.

EDIT AREA (ALL FLOORS)

Select Edit> Edit Area> Edit Area (All Floors) and draw a marquee around the area of the plan to be edited. 

Edit Area (All Floors) affects all objects on all floors of the plan that are included in the selection marquee, regardless of 
whether they display in plan view. 

EDIT AREA (ALL FLOORS) VISIBLE

Select Edit> Edit Area> Edit Area (All Floors) Visible and draw a marquee around the area of the plan to be 
edited. 

Edit Area (All Floors) Visible affects all visible objects on all floors of the plan that are included in the selection marquee. 
Objects not currently displaying in plan view are not affected.

EDIT AREA POLYLINE

If a rectangular marquee’s shape does not allow you to define an area precisely, use a closed polyline instead. 

186



Home Designer Pro 2025 Reference Manual - Edit Area Tools

Select a polyline that defines the desired area in plan view and then select one of the Edit Area Tools . The polyline 

becomes temporarily highlighted and acts as an Edit Area marquee. 

USING THE EDIT HANDLES

An Edit Area marquee displays edit handles that are similar to those of a closed polyline. See Using the Edit Handles on 
page 157.

 l Click the Move edit handle to move the entire selection set. See Moving Objects on page 167.
 l Click the Rotate edit handle to rotate the entire selection set. See Rotating Objects on page 178.
 l Click and drag the Reshape and Resize edit handles at each corner and along each edge to adjust the size and shape of 

the marquee. See Using the Edit Handles on page 157.

Adjusting the size or shape of an Edit Area marquee may change which objects are included in the selection set but does not 
otherwise affect those objects.

USING THE EDIT TOOLBAR

A selected Edit Area marquee and/or the objects within it can be edited in a variety of ways using the buttons on the Edit 
Toolbar.  See Using the Edit Toolbar on page 159. 

The following toolbar buttons may display on the Edit Toolbar for an Edit Area marquee:

  Copy/Paste copies the selection set to the system clipboard so it can be pasted elsewhere. See Copying and 
Pasting Objects on page 118.

  Delete deletes the selection set. See Deleting Objects on page 191.

  Transform/Replicate Object copies, moves, rotates, resizes, or reflects the selection set. See 
Transform/Replicate Object Dialog on page 183.

  Make Parallel/Perpendicular rotates the Edit Area marquee and the selection set so that the selected marquee 
edge is parallel or perpendicular to another straight edge. See Make Parallel/Perpendicular on page 171.           

  Point to Point Move accurately moves the selection between two points. See Point to Point Move on page 169.           

  Center Object centers the selection relative to another object. See Center Object on page 172.          

  Reflect About Object reflects the selection set about another object. See Reflecting Objects on page 180.           

  Allowed Angles opens the Place at Allowed Angles dialog.           

PLACE AT ALLOWED ANGLES DIALOG

If more than one percent of the straight walls included in an Edit Area marquee are not at an Allowed Angle, the 
Allowed Angles edit button displays. 

Click the Allowed Angles edit button to display the Place at Allowed Angles dialog.          
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Select the first option and click OK to rotate the plan so that the largest group of off-angle walls move to an Allowed 
Angle. This may place this largest group at Allowed Angles, but has two disadvantages.           

 l First, other groups of off angle walls remain off angle.           
 l Second, any walls that were at an allowed angle before this action will move to an off angle. The dialog shows how 

much (weighted by length) of the selected walls are in each category.           

Select the second option and click OK to add new entries to the Allowed Angles list and allow new walls to be placed at 
these angles. Walls already at Allowed Angles remain so. See Angle Snaps on page 115.          

Select the third option and click OK to do nothing, which is the same as clicking Cancel.          

You may want to rotate the majority of the walls to one of the normal allowed angles. Then, use an Edit Area  tool to 

select everything again and select the second option to provide new angle entries to cover the remaining walls.              

 

Stretch CAD
The Stretch CAD tool allows you to reshape or move a variety of CAD-based objects using a temporary closed 
polyline.          

To use the Stretch CAD tool

 1.  Select Edit> Stretch CAD .          

 2.  Click and drag to draw a rectangular polyline through the CAD objects that you would like to stretch.          

 3.  You can edit the shape of the Stretch CAD polyline so that it intersects the objects you want to stretch along the 
desired planes. See Editing Closed Polyline-Based Objects on page 157.          

 l An edge of the polyline must extend through each of the objects that you would like to stretch.          

 l The opposite polyline edge should be located outside those objects.          

 4.  When the Stretch CAD polyline’s shape and position meet your needs, click and drag its Move edit handle.          

 5.  As you drag, intersected objects will either stretch, contract, or move.          

 l An edge of the polyline must extend through each of the objects that you would like to stretch.          
 l The opposite polyline edge should be located outside those objects.          

 1.  When the Stretch CAD polyline’s shape and position meet your needs, click and drag its Move edit handle.          

 2.  As you drag, intersected objects will either stretch, contract, or move.          

Not all CAD-based objects can be reshaped using the Stretch CAD  tool:          
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 l Road and Text objects are examples of objects that can be moved but not reshaped by this tool.          
 l Stairs, Ramps, and Sun Shadows are examples of objects that are not affected by this tool at all.           

 

Eyedropper and Painter Tools
There are a number of tools in Home Designer that allow you to apply attributes to objects by clicking on them.    

 l The Eyedropper tools allow you to load attributes from one object and apply them to other objects.     
 l The Painter tools allow you to apply attributes to one or more objects. Depending on the tool, attributes may be loaded 

from another object using an Eyedropper tool or selected from a dialog.     
 l Some object attributes can also be replaced directly from the library. See To replace an inserted object on page 717.     

Attributes cannot be either loaded from or painted onto objects on locked layers or on layers that are not set to display. They 
can be used to modify automatically generated objects such as roof planes and framing; however, the associated Auto 
Rebuild function will be turned off. See Auto Rebuild on page 117.     

EYEDROPPER TOOLS

The Eyedropper tools allow you to select attributes from one object and apply them to other objects. There are     three    
Eyedropper tools in the program:   

  Material Eyedropper, see Material Eyedropper on page 748

  Object Eyedropper, see Object Eyedropper on page 191

  Fill Style Eyedropper, see Fill Style Eyedropper and Painter Tools on page 131

To use an eyedropper tool

 1.  Select the Eyedropper tool that you want to use and notice that the mouse pointer displays an eyedropper   icon.    

 2.  Move the mouse pointer over an object in the current view. If the object is eligible for use with the selected 
Eyedropper:     

 l It will become highlighted in the view.      

 l The left side of the Status bar will report information about that object or the attribute that the Eyedropper can load 
from it.      

 3.  Click once to load the object’s attributes so they can be applied to other, similar objects.    

 4.  Notice that your mouse pointer now displays a spray can   icon. This means that the Painter tool associated with the 
selected Eyedropper is now active.    

 5.  Depending on the tool in use, additional buttons may now display on the Edit Toolbar. Select the option or options 
that you need:    

 l The Painter Scoping Mode buttons. See Painter Scoping Modes on page 190, below.     

 l Blend Colors with Materials. See Material Painter Tools on page 747.     

 l Toggle Library Replacement Mode . See    Replace From Library on page 717.
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 6.  Move your mouse pointer over an object that is similar to the one selected in step 2. If it is eligible to receive the 
loaded attribute(s):     

 l It will become highlighted in the view.      

 l The left side of the Status bar will report information about the attribute to be painted or loaded.      

 7.  Click on an eligible object to apply     attributes to it as well as to any other identical objects, depending on which 
Painter Scoping Mode is active.    

 8.  Continue clicking to apply attributes until the Esc key is pressed or another tool is activated.    

PAINTER TOOLS

The Painter Tools let you apply attributes to a wide variety of objects by clicking on them. When a Painter tool is active, the 
mouse pointer will display a spray can   icon. There are a number of ways to load attributes into a Painter tool.   

 l Click on an object using any Eyedropper tool to load its attribute(s). The associated Painter tool will become active, 
ready to paint the loaded attributes.     

 l Select a material      or fill style     in the Library Browser and move the mouse pointer into the current view window. If that 
item can be applied in the current view type, the associated Painter will be active and you can apply the selection to 
eligible objects in that view.    

 l When you select the Material Painter                   tool, the Select Material dialog will open, allowing you to choose a 

material from the library. See Select Material/Library Object Dialog on page 751.     
 l When you select the Fill Style Painter  tool, the Select Library Object dialog will open, allowing you to choose a 

fill style from the library. See Select Library Object Dialog on page 716.

Once a Painter tool is loaded, simply click on an object to apply the selected attributes. See To use the Material Painter tool 
on page 748.   

PAINTER SCOPING MODES

There are five Painter Scoping Modes that control how broadly or narrowly a selected Painter tool will apply an attribute or 
attributes to objects in the current plan. These modes are listed in the same submenu as the associated Eyedropper and/or 
Painter tool. When a Painter tool is active, they are also found on the Edit Toolbar. In both locations, a small check mark 
will display at the lower left of the active Mode’s button icon. 

Depending on the type of object attributes have been loaded from, not all Object Painter Scoping Modes may be available.    

Rather than modify instances of an object type, the Material Painter Scoping Modes replace instances of a material based on 
the selected scope.    

  Object Mode applies attributes to or replaces a material on individual target objects, one at a time. All instances 
of the original material on a target object are replaced by the one being painted.    

  Marquee Mode is available in plan view for the Fill Style and Object Painter tools. To use this mode, click and 
drag a marquee around the objects you would like to paint instead of clicking on them.    

  Room Mode applies attributes to a target object as well to as all instances of that object type in the same room 
with a single click. All instances of the original material throughout the room are replaced by the one being 

painted.    
  Floor Mode applies attributes to a target object as well as all instances of that object type on the same floor with 
a single click. All instances of the original material on the current floor are replaced by the one being painted.    
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  Plan Mode applies attributes to a target object as well as all instances of that object type in the entire plan with a 
single click. All instances of the original material throughout the plan are replaced by the one being painted.    

  An additional mode, the Component Mode, is only available for the Material Painter and Adjust Material 
Definition tools. It is also available when replacing an inserted object with another from the library. See Material 

Painter Scoping Modes on page 749, Adjust Material Definition on page 753, and    Replace From Library on page 717.
   

Home Designer will remember your Painter Scoping Mode selection until you quit the program. The next time you launch 
the program, Object Mode will be active.    

 

Object Painter
A variety of attributes can be copied from one object to another using the Object Painter tools.

OBJECT EYEDROPPER

Select Tools> Object Painter> Object Eyedropper to apply the attributes of one object to other objects. The Object 
Eyedropper functions like other Eyedropper tools. See To use an eyedropper tool on page 189.   

When the Object Painter is active, you can choose a Painter Scoping Mode to control how broadly or narrowly the selected 
attributes are applied to other objects. See Painter Scoping Modes on page 190.    

 

Deleting Objects
Objects can be deleted in a variety of ways:

 l Select an object or group of objects, then: click the Delete  edit button; select Edit> Delete  from the menu; or 

press either the Delete or Backspace key.          
 l Entire categories of objects can be deleted using the Delete Objects dialog.         
 l Objects are deleted if the floor they are placed on is deleted. See Deleting Floors on page 522.         

If an object has a line with arrow attached to it, the line with arrow is deleted if the object is deleted. To prevent the arrow 
from being deleted, drag the attached end away from the object before deleting it. 

A variety of objects in the program can be generated automatically, including roofs, the foundation, and framing. 
Automatically generated objects cannot be deleted unless the automatic creation option is disabled.           

Objects such as roofs, framing, and Auto Exterior Dimensions that are set to automatically rebuild or refresh cannot be 
deleted while that behavior is enabled. Automatically generated objects cannot be deleted unless the automatic creation 
option is disabled.          

Although objects on locked layers cannot be selected, most can 
nevertheless be deleted using the Delete Objects dialog. 

DELETING POLYLINE EDGES

There are a number of different ways to delete individual edges of polyline-based objects:          
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 l Select Connect CAD Segments . Select the edge and delete. See Disconnect Edges on page 144.          

 l Drag a corner handle until it overlaps an adjacent corner handle to remove the edge between them and merge them 
into a single handle.          

 l Create a complete break at both ends. Select the edge and delete. See To create a complete break on page 176.          
 l The Fillet Lines  and Chamfer Lines  tools can be used to delete polyline edges. See Reshaping Objects on 

page 174.          

DELETE SURFACE

In any 3D view, select 3D> Delete Surface, then click a surface in the view to temporarily remove the surface from 
the current view without permanently affecting the object. See Delete 3D Surface on page 785.

 

Delete Objects Dialog
The Delete Objects dialog lets you delete categories of objects in a plan or layout file. Select Edit> Delete Objects to 
access this dialog. The settings in the dialog vary depending on whether a plan or a layout file is active:

IN PLAN VIEWS

The Delete Objects dialog only deletes objects in plan view - it does not delete CAD objects or plant schedules drawn in 
cross section/elevation views. If this dialog is opened while a camera view is active, CAD objects and plant schedules 
cannot be deleted.
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  Delete Scope

 l Choose All Floors to delete objects on all floors in the current plan.          

 l Choose All Rooms on This Floor to delete objects in all rooms on the current floor.         

 l Choose Single Room to delete objects in rooms on the current floor that you then select. See To use the Delete 
Objects dialog on page 194, below.         

 l Click the Select All button to check all boxes below.

 l Click the Clear All button to uncheck all boxes blow.

 
Objects

Specify which types of architectural Objects you want to delete.         

 
CAD

Specify which types of CAD objects you want to delete. See CAD Objects on page 197.         
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Framing

Specify which types of Framing objects you want to delete. See Framing on page 626.

 
Plant Schedules

Specify whether or not to delete Plant Schedules. See Plant Schedules on page 943.    

 
Walls

Specify which kinds of Walls you want to delete. See Walls, Railings, and Fencing on page 228.         

To use the Delete Objects dialog

 1.  Specify the Delete Scope as Single Room, All Rooms On This Floor, or All Floors.          

 2.  Click Select All to check all the boxes or Clear All to uncheck all boxes.         

 3.  Check the box for each category of objects you want to delete.          

 l Check the box beside any heading to select all of the categories within it; clear the box beside a heading to 
deselect all of its categories.         

 4.  Check the box for each subcategory of objects that you want to delete.         

 l If “Roof Planes” cannot be selected, they may be locked. See Editing Roof and Ceiling Planes on page 589.          

 5.  When the scope is set to Single Room:         

 l Move your cursor into the drawing area and click in a room of the plan to delete objects of the selected type 
within that room without closing the dialog.          

 l Only objects with their center point located in the room are deleted.          

 l Continue clicking on rooms or choose a different Delete Scope.         

 l Click Done when all selections have been deleted.          

Note: If you click in or try to switch to a view window other than the 
active view, the Delete Objects dialog will close. 

 6.  If you select All Rooms On This Floor or All Floors, you do not need to click in plan view. The Delete button 
becomes available, and clicking it closes the dialog and deletes the specified objects.          

IN LAYOUT
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  Delete Options

 l Click the Select All button to check all boxes below.

 l Click the Clear All button to uncheck all boxes.

 
Layout Objects

Specify which types of objects that you want to delete. See On the Layout Page on page 972.   

 

Undo and Redo
The Undo and Redo commands allow you to both undo the last action performed, as well as redo actions that 
were recently Undone. 

Undo files are stored in the Undo Directory, which can be specified in the Preferences dialog. See Folders Panel on page 
72.    

The 50 most recent actions can be Undone or Redone, depending on your settings in the Preferences dialog. See General 
Panel on page 69. Actions that can be Undone and Redone include creating, editing, and deleting objects.

The maximum number of Undo files is specified in the Maximum Undos value in the Preference settings. If you have 
Undo enabled, be sure to define a directory on a hard drive with enough space for these files.

To Undo an action, select Edit> Undo, click the Undo  button, or press Ctrl/⌘  + Z.

The Redo command is only available after Undo has been used. To Redo an Undone action, select Edit> Redo, click the 
Redo  button or press Ctrl/⌘  + Y.

It is important to note that Undo and Redo do not affect all actions in the program, including:

 l Save and Save As. See Saving Plan and Layout Files on page 38. 
 l Changes made in the Library Browser. See The Library Browser on page 692. 
 l Changes made in a dialog while the dialog box is open. See Dialogs on page 19.
 l Changes made to lights using the Adjust Lights dialog. See Adjust Lights Dialog on page 822.          
 l Changes made to the display by panning the display or zooming in or out. See Zoom Tools on page 108.
 l Changes made to the position of a camera, or its Rendering Technique. See Editing 3D Views on page 791. 

ACTION HISTORY

The Action History side window allows you to access recent Undoable actions in the current plan or layout file.  
Select View>Action History to open or close this side window. 
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Each line item in the Action History side window represents an action that changes one or more objects or settings in a 
dialog, and includes a tool icon indicating the name of the drawing tool, edit tool, or dialog used. If an object was edited, its 
object type and information about how it was edited is also stated. 

Actions are listed in chronological order with the most recent at the top of the list. Up to 50 of the most recent actions can 
be listed by default. The maximum list length is tied to the Maximum Undos value set in the Preferences dialog. See 
General Panel on page 69.

The selected line item is highlighted and reflects the current state of the file:

 l Items below it are past actions that can be Undone.
 l Any items above it have effectively already been Undone but can be Redone.

Click on a line item to make that action the most recent and effectively Undo all line items above it in the list and Redo all 
line items below it.

By default, when the Action History side window is opened, it will be docked on the right side of the program window. 
Like other side windows, though, it can be moved. See Side Windows on page 16.          
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Chapter 10
 

CAD Objects

The CAD tools allow you to add details to 2D views of your design to create complete working drawings.

CAD objects do not affect 3D objects or display in camera views or overviews, but they can be used to add details to layout 
pages, plan views and cross section/elevation views. 

CAD polylines can be converted to 3D objects such as countertops and terrain data, and shown in 3D views.  See Convert 
Polyline on page 182.          

CAD objects are edited much like other objects in Home Designer. See Editing Objects on page 137.
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CAD Defaults and Preferences
CAD Defaults can be accessed by selecting Edit> Default Settings from the menu and expanding the CAD category.  

The behavior and appearance of CAD objects are also affected by settings on the CAD, LINE PROPERTIES, SUN 
ANGLE, BEHAVIORS, and SNAP PROPERTIES panels of the Preferences dialog. Unlike default settings, preference 

settings are global, affecting all plan and layout files. See Preferences Dialog on page 62.

CAD DEFAULTS DIALOG
The settings in the CAD Defaults dialog control the basic appearance of CAD objects. This dialog can also be opened 
by clicking the CAD Defaults button, which can be added to the toolbars. See To add a button to a toolbar on page 

93. 

Each plan file has multiple CAD Defaults dialogs: one affecting plan view and one for every cross section/elevation view. 
Each layout file has its own CAD Defaults, as well. The CAD Defaults associated with a given view can be accessed by 
opening the CAD Defaults dialog while that view is active.

The CAD Defaults dialog cannot be opened when a camera view or overview is active.          

 
Display Line Angles as

Specify the format to use when Show Angle is checked in an object’s specification dialog. See Line Style Panel on page 
209.

Line angles can be displayed using three basic methods: 
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 l Degrees/Minutes/Bearings - Measured counterclockwise from a line drawn horizontally to the right of the angle’s 
vertex. Useful for most drawing tasks. Select the level of accuracy that you require.

 l Quadrant Bearings - Measured from a vertical line representing North/ South, Quadrant Bearings use directional 
bearings in their measurements. Useful for site drawings.

 l Azimuth Bearings - Measured from a line drawn straight up from the angle’s vertex (i.e., North on a site plan). 
Useful for site drawings, Azimuth Bearings use degrees, minutes, and seconds in their measurements.

Line length and angle indicators use the Text Style of the layer 
that their object is on. See Text Styles on page 373.

 
Options

Select any combination of the available Options.

 l Check Show Arc Centers and Ends  to show arc centers and ends on the current floor. Ends display as small 

lines where arcs connect to one another. Centers also acts as snap points. See Arc Centers and Ends on page 153.         

 
Display Line Length As

In plan and layout files using US Units, specify whether to Display Line Length as either Fractional or Decimal Feet. 
This controls the appearance of line length indicators, which only display when Show Length is checked in an object’s 
specification dialog. Not available in metric files. See Line Style Panel on page 209.

 

The CAD Drawing Tools
The following CAD Tools are available in the CAD menu and the toolbars.

POINT TOOLS

Select CAD> Points to access the Point Tools.         

The Place Point , Input Point , Point Marker , and Delete Temporary Points  tools can be used to create or 

remove snap points for a variety of purposes. See Point Tools on page 200.          

LINE TOOLS

Select CAD> Line to access the Line Tools.         

The Draw Line , Input Line , Line With Arrow , Sun Angle , and the North Pointer  allow you to 

create various types of lines. See Line Tools on page 204.          
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ARC TOOLS

Select CAD > Arcs to access the Arc Tools.         

The Draw Arc , Input Arc , and the Arc With Arrow  tools allow you to create arcs. See Arc Tools on page 

211.          

BOX TOOLS

Choose CAD > Boxes to access the Box Tools.         

The Rectangular Polyline ,               Box , Cross Box , and Insulation  tools allow you to create a variety of polyline 

and box objects. See Box Tools on page 221.

CIRCLE TOOLS

Select CAD> Circles to access the Circle Tools.

The Circle , Circle About Center , Oval , and the Ellipse  tools are discussed in detail later in this chapter. 

See Circle Tools on page 216.

SPLINE

A Spline is a curve that passes smoothly through a set of points. Select CAD> Spline to draw connected line 
segments that form a spline. See Splines on page 223.

Once created, a spline can be selected and edited. See Editing Spline-Based Objects on page 162 and Polyline Specification 
Dialog on page 219.

DIMENSION TOOLS

Select CAD> Dimensions to access the Dimension Tools. The Dimension Tools can be used with CAD and 
architectural objects and are discussed in their own chapter. See Dimensions on page 320.

TEXT TOOLS

Select CAD> Text to access the Text Tools. The Text Tools are discussed in their own chapter. See Text, Callouts, 
and Markers on page 347.

 

Point Tools
Select CAD> Points  to access the Point Tools.         

Temporary points created using the Place Point  and Input Point  tools and permanent Point Markers  can be 

used with Object Snaps  to accurately position a variety of objects. See Object Snaps on page 114.           
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POINT MARKERS

Use a permanent Point Marker as a snap point for dimension lines and other CAD objects. Select CAD> Points> 
Point Marker and click in the view to place a permanent point marker. Point markers display as a simple cross by 

default, but you can specify a different style of marker as well as add a label in the Marker Specification dialog. See Marker 
Panel on page 370.         

Once created, Point Markers can be edited like other Markers. You can also place Point Markers using the Marker  tool. 

See Markers on page 368. 

Point Markers are also created when the Point to Point Dimension  tool is used or when a dimension line is copied and 

pasted independent of the objects it locates. See Point to Point Dimensions on page 333. 

PLACE POINT

Select CAD> Points> Place Point, then and click in the drawing area to place a temporary CAD point at that 
location. Temporary CAD points can be used for a variety of purposes: for example, as an anchor for snapping 

objects to a precise location.  The Current CAD Point can be used for additional tasks. See The Current Point on page 202, 
below. 

Once a temporary CAD point is created, it cannot be selected and does not have an edit handle or edit tools. The only way 
to modify it is to move it using the Move Point dialog. See Move Point Dialog on page 203, below.

The size and color of temporary points is specified in the Preferences dialog. See Snap Properties Panel on page 82 and 
Colors Panel on page 65.

INPUT POINT

Temporary CAD points can be placed with precision by entering coordinates. See 3D Drafting on page 12.         

To use the Input Point tool

 1.  Select CAD> Points> Input Point  to open the New CAD Point dialog.              

 2.  Select a Location option, and enter the desired location of the point.              

 3.  Click OK to close the dialog and create the new point. The new point becomes the Current Point and is highlighted. 
See The Current Point on page 202.              

 4.  Alternatively, click Next to create the new point but remain in the New CAD Point dialog and create additional 
points. As each is created, it becomes the Current Point.              
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NEW CAD POINT DIALOG

 
Current Point

The location of the Current Point displays here. If no CAD points are present, the origin (0, 0) displays. See The Current 
Point on page 202.         

 
New Point

Specify the location of the New Point.

 l Absolute Location - Define the point in X Position (horizontal) and Y Position (vertical) coordinates, relative to 
the origin at (0,0).              

 l Relative to Current Point - Define the new point in X and Y coordinates that are relative to the Current Point, as 
though that point was at (0,0). Only available when a Current Point exists.               

 o Check Polar to define the new point by its Distance and Angle from the Current Point rather than in X and Y 
coordinates. This is helpful when creating a plot plan. See Plot Plans on page 892.              

The position of the New Point is defined here. The options available depend on the method chosen to define it, above.          

 l X Position and Y Position coordinates relative to (0,0) are entered if the Absolute Location method is specified.              

 l X Position and Y Position coordinates relative to the Current Point are entered if the Relative to Current Point 
method is specified.              

 l Distance and Angle from the Current Point are entered if the Relative to Current Point: Polar method is specified.             

 l Click Next to create the new point without exiting the dialog so you can input data for the next point. The newly 
created point becomes the Current Point.              

Click the Number Style button to change the units used in 
dialogs. See Dialog Number/Angle Style Dialog on page 88.

THE CURRENT POINT

In any view and on any floor, there may be multiple temporary CAD points. The Current Point is either the most recently 
created or most recently selected temporary CAD point. The Current Point has a variety of uses:          

 l As the starting point for objects as they are drawn by entering data. See Entering Coordinates on page 117.               
 l As the point about which objects are rotated. See Rotating Objects on page 178.               
 l To indicate the points at which roof planes can join. See To find roof plane intersection points on page 596.              
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The Current CAD Point displays using the Selection Line and Handle Fill colors set in the Preferences dialog. When 
multiple temporary points are on-screen, the other points use only the Selection Line color as both outline and fill so the 
Current CAD Point can be easily identified. See Colors Panel on page 65.          

The Current CAD Point on the right has a 
unique fill color.

To specify a different temporary point as the Current CAD Point, double-click on it. See Move Point Dialog on page 203, 
below.          

To delete the Current Point

 1.  Make sure no other objects are selected by clicking the Select Objects  button. You can also press the Esc key to 

deselect any selected objects.

 2.  Press the Delete key to delete the Current Point. The temporary point created prior to this one becomes the new 
Current Point.           

 3.  If you continue pressing the Delete key, temporary points will be deleted in the reverse order that they were created.          

MOVE POINT DIALOG

A CAD Point can be repositioned relative to itself, another point, or a CAD object such as a line using the Move Point 
dialog. When a Point is moved, it becomes the Current Point.          

For example, you can locate the point exactly one-quarter the distance along a given line, or exactly 6 inches from one end. 
This new location can then be used for the start point of a new line or other purpose.          

To reposition a CAD Point, double-click on it using the Select Objects  tool. That point becomes the Current Point, and 

the Move Point dialog opens.          

 
Current Location

The Current Location of the selected point displays at the top of the dialog for reference.         

 
New Location

Specify the New Location of the point.
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 l Absolute Location - Define the new location in X (horizontal) and Y (vertical) Position coordinates, relative to 
the origin at (0,0).          

 l Relative to Itself - Define the new location in X and Y Position coordinates relative to the current location, as 
though that point were the origin.            

 l Relative to Previous Point - Define the new location relative to the point that was the Current Point prior to this 
one, as though that point was the origin. Only available if the selected point is located on a CAD object.          

 o Check Polar to define the new location’s Distance and Angle from the previous point instead of using X and Y 
coordinates. Only available if Relative to Itself or to Previous Point is selected above.          

 l Along Line - Define the new location relative to the edge of a nearby CAD object. This option is enabled only 
when the point is located near a CAD object and refers to the end nearest to the point’s original location.           

 o Check Percentage (%) to specify the Along Line value as a percentage of the total line or arc length rather than as 
a distance. 0% moves the point to the closest end of the nearest edge, 50% to the midpoint, and 100% to the other 
end. Negative numbers and percentages greater than 100 are allowed.           

 l Specify the new position of the point here. The options that are available depend on the method chosen above to 
define the New Location.          

 o X Position and Y Position coordinates are entered if the Absolute Location method is specified or if either 
Relative method is used with Polar unchecked.          

 o Distance and Angle are entered if either Relative method is specified when Polar is checked.          

 o From Edge - When the Along Line method is used, specify the distance of the point’s New Location to the end of 
the CAD object’s edge that it was originally closest to. When Percentage (%) is checked, enter this value as a 
percentage instead. 

Click the Number Style button to change the units used in 
dialogs. See Dialog Number/Angle Style Dialog on page 88.

DELETE TEMPORARY POINTS

All temporary CAD points in the current view can be deleted at once using CAD>Points>Delete Temporary Points. 
In plan view, Delete Temporary Points will delete all temporary points on all floors.

You can also press the Delete key when the Select Objects tool is active and nothing is selected to delete the points one by 
one; however, Delete Temporary Points  can save time when there are many points.

 

Line Tools
Select CAD> Draw Lines to access the Line Tools.

If Object Snaps  and Connect CAD Segments  are enabled, you can connect the ends of multiple lines and/or arcs 

to form a single entity called a polyline. See Polylines on page 218.   

DRAW LINE

 Select CAD> Lines> Draw Line, then click and drag from beginning to end.          
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INPUT LINE

CAD lines can also be created using absolute values entered with the keyboard by selecting CAD> Lines> Input 
Line. This method is slower but more precise than using the mouse and is ideal when the desired length and angle of 

each line is known, such as with property lines.         

Before any line is drawn using this method, a starting point must be defined. If a starting point has not been defined, Home 
Designer Pro assumes a starting point of 0,0.         

To use the Input Line tool

 1.  Select CAD> Points> Place Point , then click the screen to place a CAD point. This is the Current Point, and is 

the start point for the new line. See The Current Point on page 202.         

 2.  Select CAD> Lines> Input Line  to open the New CAD Line dialog. This dialog can also be opened by double-

clicking the Line Tools  parent button.         

 3.  If necessary, specify the start point.         

 4.  Specify the method used to define the location of the End Point, then define the End Point.          

 5.  Click OK to close the dialog and draw the line, or click Next to draw the line but remain in the New CAD Line 
dialog and draw additional lines.         

Note: If you accidentally click OK instead of Next and need to continue 
drawing a polyline using the New CAD Line dialog, select the Input Line 
tool again and continue.

NEW CAD LINE DIALOG

 
Start Point

The X Position (horizontal) and Y Position (vertical) coordinates of the start point for the new line display here. They can 
also be changed, if you wish.         

 
End Point

The new line’s End Point is defined here. Begin by specifying how you want to define the line End Point Location.         
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 l Absolute Location - Define the end point of the new line in X Position (horizontal) and Y Position (vertical) 
coordinates, relative to (0,0).         

 l Relative to Start Point - Define the end point of the new line in X and Y coordinates that are relative to the line’s 
Start Point, as though it were at (0,0).         

 l Check Polar to define the End Point of the new line by its Distance and Angle from the Start Point rather than in 
X and Y coordinates. This is helpful when creating a plot plan. See Plot Plans on page 892.         

 l Relative to Previous Line - Define the End Point of the new line by its Distance and Angle relative to the end of 
the last line drawn, as though that line’s angle were at 0° and its End Point, at  (0,0).          

 l X Position (horizontal) and Y Position (vertical) coordinates relative to (0,0) are entered if the Absolute Location 
method is specified.         

 l X Position (horizontal) and Y Position (vertical) coordinates relative to the start point are entered if the Relative to 
Start Point method is specified.         

 l Distance and Angle from the start point are entered if the Relative to Start Point: Polar method is specified.         

 l Distance and Angle from the start point are entered if the Relative to Previous Line method is specified.         

 l Click Next to create the line without exiting the dialog so you can input data for the next line. The start point of 
the next line is the end point of this line.         

Click the Number Style button to change the units used in 
dialogs. See Dialog Number/Angle Style Dialog on page 88.

To enter an angle in bearings

 1.  While not required, you may want to select Quadrant or Azimuth Bearings in the Dialog Number/Angle Style 
dialog.          

 2.  For Quadrant Bearings, begin by typing  N or S (for North or South).         

 3.  Next, type the number of degrees followed by either a  letter d or a space.          

 4.  Type the number of minutes followed by either a ‘ or a space.          

 5.  Type the number of seconds followed by either a “ or a space.          

 6.  Finally, for Quadrant Bearings, type either E or W (for East or West).           

Following are some examples of Quadrant Bearings. It is not necessary to capitalize the letters. Spaces after each value are 
optional.          

 l N 20d 30' E         
 l S 45' W         
 l N 89d 48' 30" W         
 l N 90' E         

ENTER COORDINATES

Similar to Input Line, lines can also be specified by pressing the Tab key when a line is in the process of being drawn. This 
opens the Enter Coordinates dialog. See Entering Coordinates on page 117.         
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LINE WITH ARROW

Create a line or polyline with an arrow on one or both ends by selecting CAD> Lines> Line With Arrow, then 
clicking and dragging in the drawing area. The initial attributes of the line’s arrow are set in the Arrow Defaults 

dialog. See Arrow Defaults on page 348.          

As with other lines, lines with arrows can be edited after they are created and connected to form polylines provided that they 
share the same  style attributes. See Editing Line-Based Objects on page 146 and Line Specification Dialog on page 208.         

You can also create arcs with arrowheads. See Arc with Arrow on page 213.         

If either end of a Line with Arrow is snapped to an object, it 
maintains its connection if that object is moved. See Text Arrows 

on page 362. 

SUN ANGLE

Sun Angles let you specify the date, time, latitude, and longitude that the program uses when calculating the angle of 
the Generic Sun as well as the direction and length of sun shadows. See Sun Angles and Shadows on page 825.         

NORTH POINTER

The North Pointer tool is used to define the direction of true north in a plan. The direction of north does not affect 
the orientation of the Snap and Reference grids, but it does determine the direction of bearing information as well as 

how shadows and conditioned area totals are calculated. See North Pointer on page 825.    

If a North Pointer is not used, north is assumed to be straight up on screen in plan view.     

DISCONNECT EDGES

Select CAD> Lines> Disconnect Edges, then click on the edge of a polyline-based object to disconnect that edge 
from the rest of the polyline. See Disconnect Edges on page 144.         

When Connect CAD Segments  is toggled off, CAD objects will not join to form a single polyline, either as they are 

drawn or when edited. See Polylines on page 218.          

SAME LINE TYPE EDIT HANDLES

A new CAD line can also be drawn using the Same Line Type edit handles on an existing CAD object. The start point of 
the new line is located at one end of the existing object and shares its line color, weight, style, and its layer. If the object has 
an arrow, its attributes are also inherited. See Line Style Panel on page 209 and Arrow Panel on page 226.   

The Same Line Type edit handles are available for CAD lines, arcs, open polylines, and splines, but not for closed CAD 
shapes or CAD-based architectural objects. They can be turned off in the Preferences dialog if you wish. See CAD Panel on 
page 78.    
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When Connect CAD Segments  is disabled, the new CAD line will snap to the existing object, forming an open 

polyline or spline. When Connect CAD Segments is enabled, on the other hand, the two will remain separate objects.   

 

Line Specification Dialog
Select a CAD Line, Line With Arrow, or Text Line With Arrow and click the Open Object edit button to open the 
Line Specification dialog. 

The settings on the panels in this dialog are found in the specification and defaults dialogs for a variety of different objects 
in the program.

The Line Specification dialog has the following panels:

LINE PANEL

The information on the LINE panel of the Line Specification dialog is similar to that found on the SELECTED LINE panels of 
various specification dialogs in the program.

 
Lock

These lock options control how changing properties on this dialog affect the line.

 l Select Start to keep the start of the line fixed when changing the length, angle, and end.          

 l Select End to keep the end of the line fixed when changing the length, angle, and start.          

 l Select Center to keep the center of the line fixed. Changing the length of the line moves the start and end of the line 
equally. Changing the angle rotates the line around the center.          

 l Select Length/Angle to keep the length and angle of the line segment fixed. Moving the start or end moves the other 
end so the length and angle of the line do not change.          

When editing a polyline, moving the Start of a line segment moves the end of the previous connected line, if there is one. 
Similarly, moving the End of a line segment moves the start of the next connected line, if there is one.           
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Length/Angle

Specify the length and angle of the selected line. Not available when Length/Angle is locked, above.

 
Start Point

Specify the X and Y coordinates of the line’s Start Point. Not available when the Start or Center Point is locked, above.

 
End Point

Specify the X and Y coordinates of the line’s End Point. Not available when the Center or End Point is locked.

The format used here can be changed by clicking the Number Style button. See Dialog Number/Angle Style Dialog on page 
88.          

LINE STYLE PANEL

The LINE STYLE panel is found in the specification dialogs for many different objects. The settings here control the 
appearance of the lines and/or arcs that make up an object. Depending on the type of object selected, some settings may not 
be available. The available settings vary slightly depending on whether the object was drawn in a plan or a layout file.

  Line Options

 l Specify the line Color used to represent the selected object. Check By Layer to use the color assigned to the 
object’s layer or click the Color bar to select a different color. See Select Color Dialog on page 135.          

Mouse over the Color bar to display a tool tip reporting the 
selected color’s RGB values. 

 l Specify the line Style used to represent the selected object. Check By Layer to use the line style assigned to the 
object’s layer or click the drop-down list               to select a different style.

 l Define the Line Weight or check By Layer to use the Line Weight assigned to the object’s layer. See Line 
Weights on page 995.          

Setting the line weight to zero makes the line weight print as 
thin as possible.

209



Home Designer Pro 2025 Reference Manual - Drawing Arcs - Arc Creation Modes

 
Bumping

These options are not available for Electrical Connections or Custom Backsplashes and only function when 
Bumping/Pushing is enabled. See Bumping/Pushing on page 168. 

 l Check CAD Stops Move to bump the selected object into other CAD or CAD-based objects as it is moved, and/or to 
push the other object(s).           

 l Check Wall Stops Move to stop the selected object when it bumps into a wall. Walls cannot be pushed by other 
objects. Not available in layout files.          

 
Display Options

These options not available for CAD Box- or CAD Circle-based objects, or for Custom Backsplashes, Electrical 
Connections, North Pointers, or Sun Angles.

 l Check Show Length to show the length of each line centered above the line.           

 l Check Show Angle to show the angle of each line centered below the line. If the object is an arc, its radius will also 
display. 

The Length and Angle formats are specified in the CAD Defaults dialog. See CAD Defaults Dialog on page 198.          

 l Uncheck All Angles to show only those angles that are neither horizontal nor vertical. This is automatically checked 
when Show Angle is checked.           

 l Check Reverse Angle to reverse the angle by 180°. This may be helpful when showing a line’s bearing, since the 
direction a line is drawn from start point to end point defines its bearing.          

An additional Display Options setting is available In the Picture File, Metafile, and PDF File Box Specification dialogs. 
See Pictures, Images, and Walkthroughs on page 845.          

 l Check Show Border to display the selected object’s border polyline.           

ARROW PANEL

The settings on ARROW panel allow you to customize the style of arrowhead the selected object displays. See Arrow Panel 
on page 226.

 

Drawing Arcs - Arc Creation Modes
There are two Arc Creation Modes that control how arcs and arc-based objects are drawn. Select Edit> Arc Creation 
Modes to select a mode.         

The program remembers the last creation mode used between sessions. Once drawn, all arcs are edited similarly. See 
Editing Arc-Based Objects on page 149.          

Before deciding which Arc Tool or Arc Creation Mode is best for the project at hand, it is helpful to be familiar with the 
different components that make up an arc.          

A. Center - the point the arc is drawn about.          
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B. Radius - the distance from the center to 
the arc.          
C. Start / End - where the arc begins and 
ends.          
D. Chord - the straight line between the start 
and end point.          
E. Tangent - a straight line that intersects an 
arc and is perpendicular to the radius of the 
arc at that point.

FREE FORM ARC

Free Form Arc mode allows you to define an arc by clicking and dragging along the desired path.

To draw a Free Form arc

 1.  Select CAD> Arcs> Draw Arc , then click at the arc’s start point.           

 2.  Move the pointer along the desired curve while dragging to curve the arc.          

 3.  Release the mouse button at the end point to complete the arc.           

ARC ABOUT CENTER

Arc About Center mode allows you to draw an arc by defining the center and then the start and end points.          

To draw an Arc About Center

 1.  Select CAD> Arcs> Draw Arc , then click once to define the center point.

 2.  Click and drag from the start point of the arc to its end point.          

 3.  Or, click and drag an arc. The Current Point is used as the center. See The Current Point on page 202.          

 

Arc Tools
Select CAD> Arcs to display the submenu of Arc Tools.

DRAW ARC

The method used to draw an arc using Draw Arc depends on which Arc Creation Mode is currently active. Once 
drawn, an arc can be edited. See Editing Arc-Based Objects on page 149.

INPUT ARC

An arc can be drawn to exact specifications using the New CAD Arc dialog. 
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To use the Input Arc tool

 1.  Select CAD> Points> Place Point , then click the screen to place a CAD point. This is the Current Point, and 

will be the start point for the new arc. See The Current Point on page 202.

 2.  Select CAD> Lines> Input Arc  to open the New CAD Arc dialog.

  The New CAD Arc dialog can also be opened by double-clicking the Arc Tools  parent button. 

 3.  If necessary, specify the Start Point.

 4.  Specify the method used to define the arc’s Direction, then define its angle. 

 5.  Define the arc’s Radius. In order to create an arc, a value greater than 0 must be specified.

 6.  Define the arc’s Extension, or length, using one of the three methods. In order to create an arc, one of these values 
must be greater than 0, and only one method should be used. 

 7.  Click OK to close the dialog and draw the arc.

NEW CAD ARC DIALOG

 
Start Point

The X Position (horizontal) and Y Position (vertical) coordinates of the Start Point for the new arc display here. They can 
also be changed, if you wish.

 
Direction

Specify how you want to define the arc’s Direction, then specify its angle.

 l The Start Direction defines the angle of the tangent from the arc’s start point. 

 l The Chord Direction defines the angle of the arc’s chord from the start point.
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Start Direction at 0° vs Chord Direction at 
0°

  Curve

 l Define the arc's Radius.

 l Select the direction that the arc curves: either to the Right/Clockwise or to the Left/Counterclockwise.

 
Length

Control the length of the arc by defining one of these:

 l A. Arc Angle - the arc's central angle as measured between the radii of both start and end points. 

 l B. Arc Length - the length of the arc along its curve from one endpoint to the other.

 l C. Chord Length - the linear distance between start and end point.

Click the Number Style button to change the units used in 
dialogs. See Dialog Number/Angle Style Dialog on page 88.

ARC WITH ARROW

You can create an arc with an arrow on one or both ends, using the Arc With Arrow tool. Draw an Arc With 
Arrow like a regular arc. When you release the mouse button,  the arc has an arrowhead at the end. The default 

attributes of the arrow are determined by the settings in the  Arrow Defaults dialog. See Arrow Defaults on page 348. 

As with regular arcs, arcs with arrows can be edited after they are created. See Editing Arc-Based Objects on page 149 and 
Arc Specification Dialog on page 214.

Continue to draw connected lines and arcs to form a polyline with an arrowhead at the end. The arrowheads display only at 
the free ends, not where the lines connect. See Polylines on page 218.

Lines with arrowheads can also be created. See Line With Arrow on page 207.

A line can be converted to an arc or vice versa by selecting the 
line, pressing and holding down the Alt key, then using the edit 

handle at either end to bend the line.

213



Home Designer Pro 2025 Reference Manual - Arc Specification Dialog

 

Arc Specification Dialog
Select an arc and click the Open Object edit button to open the Arc Specification dialog.

The settings on the ARC panel are also found on the SELECTED ARC panels for many objects.

ARC PANEL

 
Lock

These options control how changing properties in this dialog affects the arc. 

 l Start - Select this option to keep the start fixed when changing the arc, chord, or end.          

 l End - Select this option to keep the end fixed when changing the arc, chord, or start.          

 l Center - Select this option to keep the center of the arc fixed when changing the arc.          

 l Arc - Select this option to keep the arc fixed when changing the arc location.          

 l Chord - Select this option to keep the arc chord fixed when changing the arc radius.          

 
Arc

These parameters define the arc. Various controls are disabled depending on what lock option is used.
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 l Center X Point - Specify the X coordinate for the center of the arc.          

 l Center Y Point - Specify the Y coordinate for the center of the arc.          

 l Radius - The distance between the center of the arc and the arc surface.          

 l Start Angle - Specify the angle that a line drawn from the arc center to the arc start measured from a horizontal 
line to the right.

 l End Angle - Specify the angle that a line drawn from the arc center to the arc end measured from a horizontal line 
to the right.

 l Arc Angle - The angle between the center of the arc and each end.

 l Arc Length - The length of the arc along the curve.

 l Uncheck Automatic Facet Angle to specify the Facet Angle, which is the angle at which the surfaces of a curved 
3D object are broken in 3D views. The default value is 7.5°; a smaller value produces a smoother curve while a 
larger value may generate more quickly in 3D views. These settings are only available on the SELECTED ARC panel 
for some CAD-based architectural objects such as Slabs. See Architectural vs CAD Objects on page 112.           

 
Start Point

 These values define the start point of the arc. The Position settings are disabled when the Start is locked.

 l Start X Position - Specify the X coordinate for the beginning of the arc.          

 l Start Y Position - Specify the Y coordinate for the beginning of the arc.          

 l Start Direction - Specify the angle of a tangent line at the start of the arc.          

 
End

These values define the end point of the arc. The Position settings are disabled when the End is locked.
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 l End X Position - Specify the X coordinate for the end of the arc.          

 l End Y Position - Specify the Y coordinate for the end of the arc.          

 l End Direction - Specify the angle of a tangent line at the end of the arc.          

 
Chord

These values define the chord of the arc.

 l Chord Length - The straight line distance between the two ends of the arc.          

 l Chord Angle - Specify the angle of the chord (the imaginary straight line going from the start of the arc to the end 
of the arc).          

LINE STYLE PANEL

For information about the LINE STYLE panel, see Line Style Panel on page 209.

ARROW PANEL

For information about the ARROW panel, see Arrow Panel on page 226.

 

Circle Tools
Select CAD> Circles to access the Circle Tools.         

CIRCLE

To draw a circle, select CAD> Circles> Circle, then click and drag across the diameter, in any direction.    

Once a circle is created, it can be edited. See Editing Circles, Ovals and Ellipses on page 164 and Circle/Oval/Ellipse 
Specification Dialog on page 217.    

DRAW CIRCLE ABOUT CENTER

Select CAD> Circles > Circle About Center to create a circle by dragging the radius out from the center point.       

To draw a Circle About Center

 1.  Click the Circle About Center  tool.          

 2.  Click the screen to define the center.          
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 3.  Drag the radial distance and release the mouse button. If you are using Object Snaps , both the center point and 

the radius snap to any appropriate nearby CAD object, intersection or point.          

OVAL

An Oval is a four-arc approximation of an ellipse. To draw an oval, select CAD> Circles> Oval, then click and drag 
at an angle to define the oval's maximum height and width.          

Once an oval is created, it can be edited. See Editing Circles, Ovals and Ellipses on page 164 and Circle/Oval/Ellipse 
Specification Dialog on page 217.    

ELLIPSE

An Ellipse is a set of points with a constant combined distance from two points called foci. An ellipse looks like a 
stretched circle, or a circular surface viewed at an angle. To draw an ellipse, select CAD> Circles> Ellipse and drag 

at an angle to define its maximum height and width.          

Once an ellipse is created, it can be edited. See Editing Circles, Ovals and Ellipses on page 164 and Circle/Oval/Ellipse 
Specification Dialog on page 217.    

 

Circle/Oval/Ellipse Specification Dialog
Select a circle, oval or ellipse and click the Open Object  edit button to open the CAD Circle, Oval or  Ellipse 

Specification dialog.

The CAD Circle, Oval, and Ellipse Specification dialogs are almost exactly the same. The Oval and Ellipse Specification 
dialogs have an additional setting for Angle on the GENERAL panel.           

GENERAL PANEL

 
Center Point

Specify the position of the circle, oval or ellipse’s Center Point. 

 l Specify the X Position and Y Position of the center of the circle, oval or ellipse.          

 l Specify an oval or ellipse’s Angle. Not available for circles.           
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  Size

 l Specify the Length and Width of an oval or ellipse, or the Diameter and Radius of a circle.

 l Specify the Circumference of a selected circle. Not available for ovals or ellipses.

LINE STYLE PANEL

For information about the LINE STYLE panel, see Line Style Panel on page 209.

FILL STYLE PANEL

For information about settings on this panel, see Fill Style Panel and Dialogs on page 132.

 

Polylines
A polyline consists of two or more line and/or arc segments that are attached at their endpoints. Select CAD> Boxes> 
Rectangular Polyline, then click and drag from corner to corner to create a rectangular-shaped, closed polyline. A 

closed polyline measuring 2’x 2’ (600 mm x 600 mm) can also be created by clicking once while the Rectangular Polyline 
tool is active.

When Object Snaps  and Connect CAD Segments  are enabled, you can also create a polyline by drawing lines 

and/or arcs end-to-end, allowing the end of each new object to snap to the end of the previous one. See Defaults, 
Preferences, and Edit Behaviors on page 138.

Line- and arc-based objects will only snap together to form a polyline if they are on the same layer and share identical 
attributes such as color, line style, and arrow specifications.

If one end of the polyline is connected to the other, it becomes a closed polyline. Closed polylines can be adjusted in a 
variety of ways that open polylines cannot. For example, closed polylines can be assigned a fill pattern and/or turned into 
special 3D objects such as slabs or countertops that display in 3D views. 

Lines and polylines can be distinguished by the edit handles that display when you select each. A line displays an edit 
handle at each end and one in the middle. If more than three edit handles display, the object is a polyline.         

Selected line

Selected polyline with two collinear edges

Lines that appear connected to a polyline may prove to be unconnected when selected.         
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For example, the two polylines in the following image appear identical until their left edges are selected. The entire polyline 
on the left is highlighted, showing it is a closed polyline. The polyline on the right, however reveals that its left edge is not 
fully attached. In contrast, the left edge of the polyline on the left is part of the larger polyline unit.         

The Close Polyline  edit tool can be used to connect the edges of an open polyline. This tool adds a segment between the 

two open ends, closing the gap between them. See Close Polyline on page 157.         

Polylines can be copied, moved, reshaped, or resized as a single unit. Additionally, the individual segments can be edited. 
See Disconnect Edges on page 144.

Once created, polylines can be edited in a variety of ways. See Editing Open Polyline-Based Objects on page 153 and 
Editing Closed Polyline-Based Objects on page 157.

 

Polyline Specification Dialog
Select an open polyline, closed polyline, spline, Sprinkler Line polyline, or Electrical connection and click the Open 
Object edit button to open the Polyline Specification dialog. 

The panels that are available in the Polyline Specification dialog will vary, depending on the attributes of the selected 
polyline as well as those of its selected edge.

POLYLINE PANEL

The POLYLINE panel is found in the specification dialogs for a variety of objects throughout the program. It states: 

 l The total number of Polylines or Holes Selected;          
 l The Length of an open polyline; 
 l The Perimeter of a closed polyline; 
 l The Area of a closed polyline;
 l The Volume of a closed polyline;
 l The Number of Lines that form an open polyline or the perimeter of a closed polyline or polyline hole;
 l The Number of Holes located inside a closed polyline;
 l The Hole Perimeter is the total length of the perimeter(s) of any holes inside a closed polyline;
 l The Hole Area is the total area of the holes located inside a closed polyline.

If the polyline is not closed, the Area and Volume are described as “Not closed”. The Volume of a 2D polyline will always 
be 0, even if it is closed. 

When one or more roof planes or ceiling planes is selected, the Area is reported in a variety of ways. See Polyline Panel on 
page 600.

If multiple objects of the same type are selected, the combined totals of these values are stated.           

SPLINE PANEL

The SPLINE panel is only available when the selected object is a spline or spline-based object.  See Splines on page 223.           
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 l New Segment Angle - Specify the angle between the selected spline's segments. A smaller angle makes the spline's 
curves smoother while a larger value produces segment intersections that are more angular. Values between 0° and 45° 
are allowed.

 l In the Electrical Connection Defaults dialog only, specify the Curvature Ratio of newly drawn Electrical Connection 
splines. A lower value produces new Electrical Connection splines with gentle curves while a higher value produces 
splines with tight curves. See Electrical Connection on page 489.

SELECTED LINE PANEL

The SELECTED LINE panel is available when the selected edge of the polyline is a line as opposed to an arc and is not 
available if the selected object is a spline. See Editing Line-Based Objects on page 146.

Moving the Start of a line segment moves the end of the previous connected line, if there is one. Similarly, moving the End 
of a line segment moves the start of the next connected line, if there is one. 

This panel is similar to the LINE panel of the Line Specification dialog. See Line Panel on page 208. 

SELECTED ARC PANEL

The SELECTED ARC panel is available when the selected segment of the polyline is an arc as opposed to a line. It is not 
available if the selected object is a spline. 

This panel is similar to the ARC panel of the Arc Specification dialog. See Arc Panel on page 214.

LINE STYLE PANEL

This panel is similar to the LINE STYLE panel in the Line Specification dialog. See Line Style Panel on page 209.

FILL STYLE PANEL

The FILL STYLE panel is found in the specification dialogs for a variety of objects in the program. Only available for closed 
polylines. See Fill Style Panel and Dialogs on page 132.

ARROW PANEL

The ARROW panel is available for most open polylines and splines and is similar to the ARROW panel of the Line 
Specification dialog. See Arrow Panel on page 226. 

The ARROW panel is not available for closed polylines, Sprinkler Lines, or Electrical Connections. 

COMPONENTS PANEL

The COMPONENTS panel is available for a selected Sprinkler Line or Sprinkler Spline. See Sprinkler Tools on page 942.          

The information on this panel can be used in the materials list. See Components Panel on page 967.          
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COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 967.

 

Box Tools
Select CAD> Boxes to access the Box Tools.         

RECTANGULAR POLYLINE

A Rectangular Polyline can be created in either of two ways:         

 l Click in the drawing area to place a 24” x 24” square polyline at that location.          
 l Click and drag from corner to corner to draw a rectangle of any size.           

CAD polylines can also be created by connecting CAD lines and/or arcs. See Polylines on page 218.

Once created, a rectangular polyline can be edited into any shape or converted to a 3D object. See Editing Closed Polyline-
Based Objects on page 157.

BOX

Select CAD> Boxes> Box to draw a 2D rectangular polygon shape. CAD Boxes are drawn from corner to corner, 
forming a rectangle.

The sides of a Box can be resized, but unlike a polyline, a Box always has four 90° corners. See Editing Box-Based Objects 
on page 160 and Box Specification Dialog on page 222.         

CROSS BOX

Use the Cross Box tool to create a 2D box with an X-shaped cross in the interior to represent framing in a cross 
section detail.         

In cross section/elevation views, Cross Boxes are used to represent joists and rafters members that are perpendicular to and 
cut by the camera’s clip plane. See Cross Section/Elevation Views on page 779.           

BLOCKING BOX

Use the Blocking Box tool to create a 2D box with a diagonal line in the interior to represent blocking or bridging in 
a cross section detail.         
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INSULATION

Use the Insulation tool to draw insulation in cross section details. Insulation Boxes are like 2D boxes and Cross 
Boxes; however, unlike these other types of boxes, Insulation Boxes do not have perimeter lines: only the curves of 

the insulation pattern.          

 

Box Specification Dialog
Select a CAD box, a framing box, a Cross box, a Blocking box, or an Insulation box and click the Open Object edit 
button to open the Box Specification dialog. See Box Tools on page 221.

GENERAL PANEL

 
Box Style

Specify a Box Style. Select Normal to specify a normal box, Cross to specify a cross box, or Insulation to specify an 
insulation box. If multiple CAD boxes are selected, “No Change” may display. 

 
Position

Define the Position of the box. 
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 l Specify the X Position and Y Position of the center of the box.          

 l Specify the Angle of the box.          

 
Size

Define the Size of the box by specifying its Height and Width.

LINE STYLE PANEL

For information about the LINE STYLE panel, see Line Panel on page 208.

FILL STYLE PANEL

For information about the FILL STYLE panel, see Fill Style Panel and Dialogs on page 132.

 

Splines
A Spline is a curve that passes smoothly through a set of points. Splines are typically used in situations where there is 
an irregular curve. A contour line is a typical example. Splines are useful wherever a free-flowing curve is needed.

Once created, splines can be selected and edited. See Editing Spline-Based Objects on page 162 and Polyline Specification 
Dialog on page 219.

To use the Spline tool

 1.  Select CAD>  Spline .

 2.  Make sure that Connect CAD Segments  are enabled so multiple spline segments can snap together. See 

Connect CAD Segments on page 113.

 3.  Click and drag to draw the first spline segment just as you would a line. A single spline segment looks identical to a 
line, in fact. You may need to turn off Angle Snaps  to draw freely.

Spline line drawn between two points

 4.  Draw the second segment from the end of the first at a different angle. Object Snaps  should be on to assure that 

new segments attach correctly to the ends of previous segments.

Spline polyline drawn between three 
points
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 5.  As soon as two straight spline segments connect end-to-end, the straight segments become a curve that passes 
through the endpoints defined by the original segments. Each point is called a vertex. 

 6.  Draw a few more segments, connecting each to the free end of a previously drawn segment.

Spline polyline drawn between four 
points

 7.  Notice as additional segments are drawn that the spline changes the curvature of the previous segment to create a 
continuous curve between the last three points.

Spline polyline drawn between five 
points

 8.  Form a closed spline by drawing a segment between its two free ends.

Draw additional segment to close 
polyline

 9.  The result is an irregular curve that flows smoothly through each vertex.

Spline-based objects will only snap together to form a single spline if they share identical attributes such as color, line style, 
and arrow specifications.

Note: Spline-based objects with the same properties will only snap 
together when Connect CAD Segments is enabled. See Connect CAD 
Segments on page 142.
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Displaying CAD Objects
As with architectural objects, the display of CAD objects is controlled in the Layer Display Options dialog. See Layer 
Display Options Dialog on page 127.

CAD objects can be drawn in plan views, layout, and cross section/elevation views. They are 2D objects only, though, so 
they cannot be seen in any view other than the one they are drawn in and are never visible in camera views or overviews. 
See Architectural vs CAD Objects on page 112.

DRAWING GROUPS

Each object in a plan or layout file is included in a Drawing Group, which influences whether it displays in front of or 
behind other objects. By default, all CAD objects are placed in the same Drawing Group. Their drawing order relative to 
one another is based on the order in which they were placed: an object will display in front of any objects that were created 
before it was. 

Once created, however, the drawing order of CAD objects can be customized. See Drawing Groups on page 129.

SHOW LENGTH AND ANGLE

You can specify that line segment length and angle display along a CAD line, CAD arc, or along each segment of a CAD 
polyline. If the segment is an arc, its radius also displays. See Line Style Panel on page 209.          

The format of the length and angle can be specified in the CAD Defaults dialog. See CAD Defaults Dialog on page 198.          

Line length and angle indicators use the Text Style assigned to the layer that their CAD object is on. See Text Styles on page 
373.           

ENDCAPS

Dashed lines often display endcaps, which are dashes of a particular length. You can specify the Printed Length of endcaps 
in the Preferences dialog. See CAD Panel on page 78.          

LINE STYLES

A selection of line styles is available for you to apply to CAD              and some architectural and terrain objects. See Line Style 
Panel on page 209.         

HIDE/SHOW SELECTED EDGE

The Hide Selected Edge and Show Selected Edge edit tools allow you to toggle the display of the selected 
edge of a CAD polyline. See Selected Edge on page 143.

FILL STYLES

A selection of fill styles can be applied to closed CAD and CAD-based architectural objects. See Fill Styles on page 131.
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Arrow Panel
The ARROW panel is available for in the specification dialog for CAD lines, arcs, splines, open polylines, and 
dimension lines. Select one of these objects and click the Open Object edit button. See CAD Objects on page 197 

and Dimension Line Specification Dialog on page 343.

The defaults for arrows assigned to CAD objects are set in the Arrow Defaults dialog. See CAD Defaults and Preferences 
on page 198. 

Some objects, notably Joist Direction Lines, do not have the Attach or Auto Position settings. Other objects, including 
closed polylines, Sprinkler Lines, and Electrical connections cannot have arrows at all.

 l Check Include Arrow to apply an arrow to the tail end of the selected object and enable the settings that follow.
 l Select an arrowhead Style from the drop-down list.

 o Check Default to use the default arrowhead.
 o Arrowheads with a white center have a transparent fill.

 l The arrowhead's Fill Color displays in the Color bar. Click the bar to specify a custom color. See Select Color Dialog 
on page 135.                 
 o Select Default Fill Color to use the fill color specified in the Arrow Defaults dialog.
 o Select Match Line Color to use the color specified on the LINE STYLE panel. See Arrow Panel on page 226.
 o Custom Color is selected automatically if you click the Color bar above.     

 l Specify the arrowhead's Size, measured from its front to its back.               
 l Check Arrow on Both Ends to place an arrowhead on both ends of the selected object.          
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 l When Attach Tail to Other Objects is checked, the tail end of the arrow will attach to another object when snapped 
to it, and will maintain its attachment if the object is moved. When this is checked and the arrow is selected, its tail 
end edit handle will display the Selected Edge Handle Fill color.          

 l Check Auto Position Tail to have the tail end update its position on the object it is attached to if either object is 
moved. See Auto Position Arrows on page 363.          

 l When Attach Head to Other Objects is checked, the head of the arrow will attach to another object when snapped to 
it, and will maintain its attachment if the object is moved. When this is checked and the arrow is selected, its arrow 
end edit handle will display the Selected Edge Handle Fill color.          

 l Check Auto Position Head to have the arrow end update its position on the object it is attached to if either object is 
moved.           
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Chapter 11
 

Walls, Railings, and Fencing

To draw a wall, select one of the Wall Tools on page 232, then click and drag in a line to the approximate length that you 
want. When you enclose an area with walls, a room is created, complete with floor and ceiling. The Door Tools on page 380 
and Window Tools on page 409 can be used to add openings, while Dimensions on page 320 are used to position walls and 
openings with accuracy.

Walls are the single most important structural component in Home Designer. They define Rooms on page 286, are used to 
create Foundations on page 496, and even influence how Roofs on page 573 are built. It is helpful to understand how Wall 
Type Definitions, wall connections, and wall alignment all affect your design.

TOPICS

Wall, Railing, and Fencing Defaults 229
Wall Tools 232
Railing and Deck Tools 233
Fencing Tools 236
Exterior and Interior Walls 236
Foundation Walls 236
Pony Walls 238
Room Dividers and Invisible Walls 239
Polygon Shaped Decks 240
Wall Hatching 240
Creating Walls 241
Connecting Walls 244
Displaying Walls 246
Measuring Walls 248
Editing Walls 251
Edit Handles for Walls 253
Aligning Walls 255
Roof Directives in Walls 257
Attic Walls 259
Stepped and Raked Walls 260
Wall Type Definitions 262
Wall Type Definitions Dialog 264
Wall Specification Dialog 268
Railing and Fencing Specification Dialogs 281
Wall Hatching Specification Dialog 285
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Wall, Railing, and Fencing Defaults
Default Settings can be accessed by selecting Edit> Default Settings. Click the arrow next to “Walls” to display the 
walls sub-headings. Select a subheading and click the Edit button to open the Wall Defaults dialog associated with 

your selection.

There is a defaults dialog associated with each of the Wall Tools in the list of subheadings. These can be multiple-selected 
by holding down the Shift or Ctrl/⌘  keys. See Shift and Ctrl/⌘  Select on page 146.          

The defaults dialog for each wall tool can also be accessed by double-clicking the tool’s toolbar button.          

The settings in the various wall defaults dialogs determine what wall types are drawn when the different wall tools are used. 
It is a good idea to be familiar with these settings and how they relate to your style of building. See Wall Type Definitions 
on page 262.

GENERAL WALL DEFAULTS

The General Wall Defaults dialog controls the general behavior and display attributes of all walls, railings and 
fencing.         

For quick access, the General Wall Defaults  button can be added to the toolbar or you can press Alt + Q.          

 
Resize About

These radio buttons determine what part of a wall retains its position when its wall type or wall type definition is changed. 
See Resize About on page 255.          

The Resize About location is also where any snap points will be located along a wall as it is drawn or connected to other 
walls, and is where a wall’s length is measured.

 l Outer Surface - Snap to and resize about the exterior surface. When a wall is resized, its exterior surface does not 
move.          

 l Main Layer Outside - Snap to and resize about the outer line of the Main Layer. When a wall is resized, the outer 
line of its Main Layer does not move. 

 l Wall Center - Snap to and resize about the center line. When a wall is resized, its center line does not move, but 
wall layers on either side may.          
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 l Main Layer Inside - Snap to and resize about the inner line of the Main Layer. When a wall is resized, the inner 
line of its Main Layer does not move. 

 l Inside Surface - Snap to and resize about the interior surface. When a wall is resized, its interior surface does not 
move.         

Note: In most circumstances, it is recommended that you Resize About the Main Layer Outside to avoid unexpected 
results.

  Automatic Walls

 l Uncheck Auto Rebuild Attic Walls to prevent Attic walls from automatically generating when the model changes. 
When checked, Attic Walls are automatically generated. See Attic Walls on page 259.

EXTERIOR AND INTERIOR WALL DEFAULTS DIALOGS

Specify the initial attributes of walls drawn using the Exterior  and Interior Wall  tools in the Exterior and Interior 

Wall Defaults dialogs. See Wall Tools on page 232. 

The panels in this dialog are the same as their respective panels in the Wall Specification dialog. See Wall Specification 
Dialog on page 268.          

FOUNDATION WALL DEFAULTS

Specify the initial attributes of walls created by the Foundation Wall  tool when it is either used manually or when a 

stem wall or pier foundation is generated in the Foundation Wall Defaults dialog. See Foundation Walls on page 236.         

The Foundation Wall Defaults dialog also controls the wall type drawn by the Retaining Wall  tool. Unlike other walls, 

Retaining Walls  are used to modify your terrain rather than build a structure. See Terrain Wall and Curb Tools on page 

901.         

Footing size and other information used when building stem wall or pier foundations is also specified here. For more 
information, see Foundation Defaults Dialog on page 498.         

The panels in this dialog are the same as their respective panels in the Wall Specification dialog. See Wall Specification 
Dialog on page 268. 

All Foundation Wall and Monolithic Slab footings use the "Foundation/Slab" material set in the Material Defaults dialog. 
See Material Defaults on page 746.  

PONY WALL DEFAULTS

Specify the initial attributes of walls drawn using the Pony Wall  tool. See Pony Walls on page 238.         

The Display in Plan and Display of Openings in Non-Displayed Parts of Walls settings on the WALL TYPES panel of the 
Pony Wall Defaults dialog are     static in views sent to layout. See Keeping Layout Views Current on page 975.         

The panels in this dialog are the same as those in the Wall Specification dialog. See Wall Specification Dialog on page 268.         

RAILING AND DECK RAILING DEFAULTS

Specify the types of railings created when the Railing and Deck Railing tools are used. See Railing and Deck Tools on page 
233.         
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Note: By default, Railings and Deck Railings are drawn using two 
separate wall types: “Interior Railing” and “Deck Railing/Fence”. See 
Wall Type Definitions on page 262.

The panels in these dialogs are the same as their respective panels in the Wall Specification dialog. See Wall Specification 
Dialog on page 268.         

GLASS WALL DEFAULTS

Specify the initial attributes of walls drawn using the Straight Glass Wall  tool. See Glass Walls and Half-Walls on 

page 232.         

The panels in this dialog are the same as their respective panels in the Wall Specification dialog. See Wall Specification 
Dialog on page 268.         

GLASS PONY WALL DEFAULTS

Specify the initial attributes of walls drawn using the Straight Glass Pony Wall  tool. See Glass Walls and Half-Walls 

on page 232.         

The panels in this dialog are the same as their respective panels in the Wall Specification dialog. See Wall Specification 
Dialog on page 268.         

HALF-WALL DEFAULTS

Specify the attributes of a solid railing drawn using either the Straight Half Wall  or Curved Half Wall  tool. See 

Glass Walls and Half-Walls on page 232.         

The panels in this dialog are the same as their respective panels in the Wall Specification dialog. See Wall Specification 
Dialog on page 268.         

FENCING DEFAULTS

Specify the initial attributes of walls drawn using either of the Fencing Tools . See Fencing Tools on page 236.         

The panels in this dialog are the same as their respective panels in the Wall Specification dialog. See Wall Specification 
Dialog on page 268.         

ROOM DIVIDER DEFAULTS

Specify the initial attributes of walls drawn using the Room Divider  tool. See Room Dividers and Invisible Walls on 

page 239.         

The panels in this dialog are the same as their respective panels in the Wall Specification dialog. See Wall Specification 
Dialog on page 268.         

WALL HATCHING DEFAULTS

Specify the initial attributes of Wall Hatching  tool. See Wall Hatching on page 240.   

The panels in this dialog are the same as their respective panels in the Wall Hatching Specification dialog. See Wall 
Hatching Specification Dialog on page 285.  
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Wall Tools
Select Build> Wall  to access the Wall Tools. The type of wall drawn by each wall tool is specified in its 
corresponding defaults dialog. 

The Curved Wall tools are similar to their corresponding Straight Wall Tools. Select Build> Wall to access these 
tools as well. 

EXTERIOR WALLS

The Exterior Wall and Curved Exterior Wall tools draw walls using the default wall type specified for 
exterior walls in the Exterior/Interior Wall Defaults dialog. See Exterior and Interior Walls on page 236.

INTERIOR WALLS

The Interior Wall and Curved Interior Wall tools draw walls using the wall type specified for interior walls. 
The interior wall type is defined in the Exterior/Interior Wall Defaults dialog.          

Note: Whether a wall is recognized as an exterior or interior wall by the 
program is determined by its position in the model, not by the tool used 
to draw it. See Exterior and Interior Walls on page 236.

FOUNDATION WALLS

The Foundation Wall and Curved Foundation Wall tools draw foundation walls according to the 
information specified in the Foundation Defaults dialog. Foundation walls normally have a footing and can be 

drawn on any floor of the model, not just the foundation floor. See Foundation Walls on page 236.         

PONY WALLS

A Pony Wall, also called a split wall, is defined as a wall with two separate wall types, one for the upper 
portion and another for the lower portion.         

The Pony Wall and Curved Pony Wall tools draw pony walls using the information specified in the Pony Wall Defaults 
dialog.  You can also convert a normal wall into a pony wall and vice versa in the Wall Specification dialog. See Pony 
Walls on page 238.         

GLASS WALLS AND HALF-WALLS

The Straight Glass Wall tool creates single-layer glass walls that do not cut the surfaces of the floor, ceiling, or 
adjacent walls.              The wall type and other attributes of glass walls drawn with this tool are defined in the Straight Glass 

Wall Defaults dialog. See Glass Wall Defaults on page 231 and Partition Walls on page 245.

The Straight Glass Pony Wall tool creates a pony wall with a glass upper partition.              The height and other attributes 
of walls drawn with this tool are defined in the Straight Glass Pony Wall Defaults dialogs. See Glass Pony Wall 

Defaults on page 231.

The Half-Wall and Curved Half-Wall tools create solid railings: walls that are 36” (900 mm) high topped 
with a handrail. See Railing and Deck Tools on page 233.               The height and other attributes of solid railings 

drawn with this tool are defined in the Half-Wall Defaults dialog. See Half-Wall Defaults on page 231. 
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ROOM DIVIDERS

Room Dividers are Invisible walls with a thickness of 0” (mm) that are used to define separate room areas in a plan. 
They can display in plan view but not in 3D views. See Room Dividers and Invisible Walls on page 239.

WALL HATCHING

The Wall Hatching tool applies a hatch pattern to a wall that displays in plan views. You must click the wall that 
you want to apply the hatch pattern to. You can then select the hatch and resize it if you want to only hatch a portion 

of a wall. See Wall Hatching on page 240.

FIX WALL CONNECTIONS

The Fix Wall Connections tool connects walls whose ends are within a few inches of each other but are not 
connected. See Fix Wall Connections on page 245.

WALL BREAK

The legacy Wall Break tool divides walls into separate segments. It is similar to the Add Break edit tool, but can be 
used to modify multiple walls without having to select them first. The Wall Break tool has been deprecated but can 

be activated using the hotkey Ctrl/⌘  + B. In addition, it may be available if legacy toolbars have been migrated into 
Version 2025. See Add Break on page 175.

The Break Wall tool can also be added to the toolbars. See Toolbars and Hotkeys on page 90.         

DEFINE WALL TYPES

The Define Wall Types tool opens the Wall Type Definitions dialog, where wall types can be created, copied and 
edited. See Wall Type Definitions Dialog on page 264.

 

Railing and Deck Tools
Railings are a special type of wall that have a specified height rather than building all the way to a room’s ceiling 
height. Select Build> Railing and Deck to access the Railing and Deck Tools. Railings are typically used to define 

interior spaces, while the various Deck tools are used to define exterior Deck rooms. 

With the exception of the Polygon Shaped Deck tool, each of the tools in this family have both Straight and Curved 
versions, and are created and edited just like walls. See Creating Walls on page 241.

To create a break in a railing for a stairway or other access, use a Doorway  or create a gate using a Hinged Door  or 

other door type. This keeps the railing continuous and maintains room definition. See Room Definition on page 287. 

When first drawn, railings are specified as No Locate, which prevents Auto Exterior Dimensions  from locating them. 

See General Panel on page 268.

The attributes for railings when they are first drawn are defined in the Railing Defaults dialog. See Railing and Deck Railing 
Defaults on page 230.          

233



Home Designer Pro 2025 Reference Manual - Railing and Deck Tools

RAILINGS

The Railing and Curved Railing tools create railings that are primarily used to define interior spaces. The 
style and height of railings drawn with this tool are defined in Railing Defaults dialog. See Railing and Deck 

Railing Defaults on page 230.

Half Walls  are also a type of Railing. See Glass Walls and Half-Walls on page 232.

Railings are ideal for a number of tasks:

 l Creating changes in floor and/or ceiling height. See Floor and Ceiling Heights on page 301.
 l Creating stairwells. See Creating a Stairwell on page 553.

DECK RAILING

The Straight Deck Railing and Curved Deck Railing tools draw decks, complete with framing and bounded 
by a railing. If a foundation level exists, supports for the deck are also created. See Decks on page 299.         

When a room is defined using deck railing, its Room Type is automatically set to “Deck”. See Decks on page 299.         

DECK EDGES

The Straight Deck Edge and Curved Deck Edge draw decks complete with framing, but without a railing. No 
deck supports are created.          

POLYGON SHAPED DECK

The Polygon Shaped Deck tool opens the New Polygon Shaped Deck dialog, where you can specify the exact size 
and number of sides of a new polygonal deck room and then click in plan view to create that deck room. See              

Polygon Shaped Decks on page 240.         
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RAILING TYPES

A variety of railing types can be specified in the Railing and Deck Railing Specification dialogs. See Rail Style Panel on 
page 281. Available types include:

 l Baluster creates railings composed of newel posts, balusters, a railing, and an optional bottom rail. 
 l Solid produces a framed railing wall, or Half Wall. See Glass Walls and Half-Walls on page 232. 
 l If Panels is selected, you can choose a panel style such as cable, glass, or ironwork from the library. See 

Newels/Balusters Panel on page 283.

By default, newels and balusters do not display in plan view, but their display can be turned on. See Newels/Balusters Panel 
on page 283.

WALL TYPES AND RAILINGS

Just like regular walls, railings are assigned a wall type: “Interior Railing”. This wall type has three layers: a framing layer 
in the middle and a layer of drywall on each side. See Wall Type Definitions on page 262.           

You can use a different wall type definition for railings if you wish, but bear in mind that this wall type definition 
determines several important things:           

 l The railing’s appearance in plan view. See Displaying Walls on page 246.           
 l The actual thickness of Solid railings in 3D views.           
 l The extent of the floor platform, if a platform edge is defined by the railing is defined by the outer surface of the wall 

type. See Floor and Ceiling Platforms on page 303.           
 l If the railing is used to create a change in floor height, this wall type controls the structure and position of the partial 

wall built beneath the railing, if one is required. See Floor and Ceiling Heights on page 301.           

If the railing is a type other than Solid, its sizing is specified on the NEWELS/BALUSTERS panel of the Railing Specification 
dialog, and the railing is centered along the width of the wall type. This will not be evident in plan view unless newels and 
balusters are set to display.           

Deck Railing is also assigned a wall type: “Deck Railing/Fencing”. This wall type has a single framing layer and is 
recommended for use only with deck railing and fencing.           

RAILINGS OVER WALLS

To produce a railing over a solid wall, specify it as both a Railing and a Pony Wall. See Pony Walls on page 238.          

To create a solid glass partition over a partial-height wall, specify the “Glass Shower” wall type as the Upper Wall.           

To create a glass panel above a half wall

 1.  Draw a Half Wall  and open its specification dialog.           

 2.  On the WALL TYPES panel of the Railing Specification dialog, check the box beside Pony Wall.          

 3.  On the RAIL STYLE panel, select Panel and uncheck Include Top Rail, Include Bottom Rail, and Raise Bottom.           

 4.  On the NEWELS/BALUSTERS panel, select “Solid” and adjust the Newels/Posts Width and Spacing values to meet 
your needs.           

 5.  On the MATERIALS panel, specify a glass material for the Panel component.          
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Fencing Tools
Fencing is a special type of wall that is designed to follow the terrain rather than define a room with a flat floor platform.         

Select Build> Fencing or click the Fencing Tools to access the fencing tools. Fencing automatically follows the 
shape of the terrain.  You can choose to have the fencing follow the terrain smoothly or to have each segment step as 

it follows the terrain. See Rail Style Panel on page 281.

The Fencing and Curved Fencing tools are used to draw fences, which are similar to railings but by default 
do not define room areas. Fencing is created and edited much like walls and railings, and normally used 

outside a building and follows the shape of the terrain. See Terrain on page 890.         

Define the default fence style in the Fencing Defaults dialog. See Fencing Defaults on page 231.          

 

Exterior and Interior Walls
Most walls are drawn using either the Straight Exterior Wall and Straight Interior Wall tools.          

Exterior and interior walls can also be drawn using the Curved Exterior Wall and Curved Interior Wall 
tools.          

The only difference between the Exterior and Interior Wall Tools is the wall type used: Exterior Walls use a wall type set up 
to model a wall with siding, while Interior Walls model interior walls with sheetrock. See Wall Type Definitions on page 
262.         

To draw a wall using a different wall type, you can change the default wall type for either tool in the Exterior and Interior 
Wall Defaults dialogs. You can also draw a wall using the default type and then change the wall type in the Wall 
Specification dialog. See              Wall Types Panel on page 277.         

Whether a wall is recognized by the program as an actual exterior or interior wall is based on its position in the model, not 
by which tool you used to draw the wall. 

 l Any wall or wall segment that is entirely surrounded by interior room areas is considered to be an interior wall. 
 l Any wall or wall segment that defines an exterior room or is exposed to the outside of the building is considered to be 

an exterior wall. See Room Types on page 289. 

If a Framed wall separates an interior room area from an exterior room, hybrid room, or the outside of the building, it will 
have insulation counted for it in the Materials List. See In the Materials List on page 248.

 

Foundation Walls
Foundation walls are similar to the interior and exterior walls but also have a footing. Foundation walls can 
either be created automatically when a foundation floor is created or manually by drawing them using the 
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Straight or Curved Foundation Wall tool. See Building a Foundation on page 501. 

The initial foundation wall type and footing size              are specified in the Foundation Wall Defaults dialog. These values can be 
changed for individual walls in the Wall Specification dialog. See Wall Specification Dialog on page 268.         

You can draw a foundation wall on any floor of a plan, not just on the foundation level. Any wall can be specified as a 
foundation wall, regardless of the tool used to draw it. See Foundation Panel on page 275.           

Foundation walls are placed on the “Walls, Foundation” layer. In plan view, foundation wall footings are placed on the 
“Footings” layer; in 3D views, they are on the “Walls, Foundation” layer. See Displaying Walls on page 246.

SLAB FOOTINGS

When a Monolithic Slab foundation is created, the slabs are defined by specially defined foundation walls that have footing 
widths equal to that of the wall type - by default, 16” (350 mm). For Garage curbs, the footings should be wider than the 
wall type. See Foundation Panel on page 275.

Rooms defined by Slab Footings will have a Ceiling Height of 0 and a Monolithic Slab Foundation. See Structure Panel on 
page 310.         

BRICK LEDGES

Brick ledges can be produced in monolithic slab, stem wall, and grade beam foundations. They do not extend under door 
openings in monolithic slab foundations.          

Brick ledges are represented in plan view by lines on the “Brick Ledge Lines” layer. See In Plan View on page 246.         

In order for a brick ledge to be produced, the foundation wall material directly under the brick ledge must be             the “Concrete” 
Structure Type and the wall material that drops into the brick ledge must be  the "Masonry" Type. See Material Structure 
Types on page 758.

Additional settings that control whether a brick ledge is produced as well as its size are found in the Wall Type Definition of 
the wall that is located above the brick ledge. See Wall Type Definitions on page 262.

 l The width of the ledge is equal to that of the Exterior Layers of the wall type.          
 l The Build Platform to Exterior of Layer setting cannot be the wall type’s exterior layer.          
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If the floor platform inside a brick ledge is hung on the foundation wall, Subflooring to Wall Interior must be checked in 
the Wall Specification dialog in order for a brick ledge to generate. See Structure Panel on page 270.          

 

Pony Walls
A Pony Wall, sometimes called a split wall, is a wall with two separate wall types, one above the other.         

Walls drawn using the Pony Wall  tool are created using the wall types and other information specified in the Pony Wall 

Defaults dialog. See Pony Wall Defaults on page 230.         

Most pony walls combine two exterior or two interior wall types; however, a pony wall can also produce an individual wall 
to be an exterior wall near its top and an interior wall near its bottom. See Exterior/Interior Pony Walls on page 259.         

When a pony wall is also specified as a Railing, its upper wall is replaced by a railing. See Wall Types and Railings on page 
235.          

You can also convert a normal wall into a pony wall and vice versa in the Wall Specification dialog. See Wall Types Panel 
on page 277.          

The height where the upper portion meets the lower can be adjusted in 3D views using the wall’s edit handles as well as in 
the Wall Specification dialog. The upper and lower sections of a pony wall are linked, so if either portion is modified along 
the division between the two, the other portion of the pony wall adjusts to match.              See Stepped and Raked Walls on page 
260.

DISPLAYING PONY WALLS

You can specify whether the upper and lower portion of pony walls displays in plan view in the Pony Wall Defaults dialog. 
See Wall Types Panel on page 277.

The default Display in Plan View setting is plan view specific and is static in views sent to layout. See Plan Views on page 
104 and Keeping Layout Views Current on page 975.         

The Display in Plan View option can also be set for individual walls in the Wall Specification dialog.

 l If a wall is set to use the Default, the active option and its appearance may change in different plan views.
 l If the wall is set to use an option other than the Default, it will use that option in all views regardless of the default 

setting. 

Just as with other walls, the appearance of the portion of a pony wall that displays in plan view can be controlled. See 
Displaying Walls on page 246.          
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Only the portion of a pony wall that displays can be snapped to; however, regardless of what part is displaying, the upper 
wall will be used to Align with Wall Above , and the lower part will be used to Align with Wall Below . See 

Editing Walls on page 251 and Aligning Walls on page 255.   

By default, when a door or window is located entirely in one part of a pony wall, and that part is not displayed in plan view, 
the opening’s outline is shown but the wall’s layer lines and fill drawn through it. You can instead display openings in the 
non-displayed parts of pony walls the same as in the displayed parts, or not at all. See Pony Wall Defaults on page 230.          

If a window or door is completely contained by one part of a pony wall, it will display in plan view if the other part of the 
pony wall is shown; but the wall’s layer fill pattern or Wall Hatching fill pattern will display over it.          

CHANGING WALL TYPES

The default upper and lower parts of a Pony Wall can be specified in the Pony Wall Defaults dialog. See Pony Wall 
Defaults on page 230.         

The upper and lower parts of a Pony Wall can be redefined as different wall types in the Wall Specification dialog. See Wall 
Types Panel on page 277.         

 

Room Dividers and Invisible Walls
The Room Divider tool is used to define separate room areas in a plan; typically, by dividing a large room area into 
two or more smaller areas. See Room Definition on page 287.

Common uses for Room Dividers                                           include dividing areas of an open floor plan into areas with different purposes.          

Room Dividers can also be used to define areas with different floor or ceiling materials or heights. 

Room Dividers  are drawn using the attributes specified in the Room Divider Defaults dialog; which means they are 

simply walls that are specified as Invisible and have a single layer of an “Air Gap” material with a thickness of 0” (mm). 

If a zero-thickness Room Divider  separates two rooms with different floor and/or ceiling heights, its wall type will be 

changed to the current plan’s default Interior Wall so that the platform step created by the height difference can be enclosed. 
See Floor and Ceiling Platforms on page 303.

INVISIBLE WALLS

Any wall, regardless of its wall type or thickness, can also be specified as Invisible - or vie versa - in the Wall Specification 
dialog or by clicking the Make Wall(s) Invisible  or Make Wall(s) Visible  edit button. See General Panel on page 

268.

Room Dividers are placed on the “Walls, Invisible” layer, as are walls that are specified as Invisible. See Room Divider 
Defaults on page 231. 
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Walls specified as Invisible can display in plan view but not in 3D views or the Materials List. See Displaying Walls on 
page 246.

It is not possible to place doors or windows  into an Invisible wall; however, if a wall with openings in it is specified as 
Invisible, any openings in it will remain. 

IMPORTANT NOTES ON INVISIBLE WALLS

 l Floor, wall and ceiling areas are calculated separately for rooms divided by Invisible walls.
 l Invisible walls are ignored by the Auto Place Outlets  tool; it functions as though they were not present. 

 l Cabinets, fixtures and furniture can be moved freely through Invisible walls. 
 l Invisible walls can be drawn through a cabinet to attach to the wall behind.         

 

             Polygon Shaped Decks
Select Build> Railing and Deck> Polygon Shaped Deck to open the New Polygon Shaped Deck dialog and create a 
polygon shaped deck with regular sides.         

The settings in this dialog are saved between program sessions. 

To create a polygon shaped deck

 1.  Click the radio button beside an option to specify whether you want to Define Polygon by Side Length, Radius to 
Corner or Radius to Side.         

 2.  Specify the desired Number of Sides.         

 3.  Specify the desired Side Length or,         

 4.  Specify the desired Radius.         

 5.  Uncheck Include Railing to produce a deck platform defined by Deck Edges. This option is not available in the 
New Polygon Shaped Room dialog.         

 6.  Click OK, then click once in plan view to create the specified polygon shaped deck.         

 

Wall Hatching
The Wall Hatching tool can be used to fill wall segments with a single hatch pattern in plan view. To apply wall 
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hatching, select Build> Wall> Wall Hatching, then click on a wall. The hatch pattern covers the entire length and width of 
the wall segment.

Note: The Wall Hatching tool cannot be used to apply a hatch pattern to 
Invisible Walls or to walls on a locked layer. See Room Dividers and 
Invisible Walls on page 239 and Locking Layers on page 126.

Wall Hatching places a hatch pattern across all layers of the selected wall layers displaying in the current view, covering 
any fill styles specified for that wall type. When wall hatching is applied to a railing, or when the “Walls, Main Layer Only” 
layer is turned on, wall hatching only displays in the Main Layer(s). See The Main Layer on page 262.

In many cases, it is preferable to create a wall type definition rather than use the Wall Hatching tool because multiple fill 
styles can be used. See Wall Type Definitions Dialog on page 264.         

Wall hatching can be selected, edited and deleted much like other line-based objects. See Editing Line-Based Objects on 
page 146.

The initial appearance of wall hatching can be specified in the Wall Hatching Defaults dialog. Once created, the wall hatch 
pattern and its line weight can be customized in the Wall Hatching Specification dialog. See Wall Hatching Specification 
Dialog on page 285. 

If you use the Wall Hatching tool to apply a hatch pattern to a wall that has been divided into multiple segments using the 
Add Break  edit tool, the pattern is only applied to the segment that you clicked on. See Add Break on page 175.

Like doors and windows, wall hatching must be placed within a single wall segment but can be edited to extend across 
multiple collinear wall segments after it is created. Unlike doors and windows, only the midpoint of Wall Hatching can be 
located by dimension lines.

If three or more wall hatching objects occupy the same space in a wall, a Caution   symbol will display at the problem 
location in plan view. Click on the Caution   symbol that displays over the wall to open a contextual menu, then select 
Delete to delete a duplicate wall hatching. When no more Caution symbols remain, you should then confirm that the 
remaining two wall hatching objects meet your needs and delete any that are unnecessary.

When editing or deleting wall hatching, make sure that it is selected rather than the wall by noting that “Wall Hatching” 
displays in the Status Bar. See The Status Bar on page 24. 

 

Creating Walls
Walls, railings, and fencing are drawn similar to the way CAD lines are drawn: select a Wall Tool and then click and drag 
from end to end in the drawing area by clicking and dragging from end to end. Walls can be drawn in plan view, camera 
views, and overviews. See Line Tools on page 204.

There are several other ways that walls can be created in Home Designer:

 l Exterior walls can be generated automatically when a new floor is built by using another floor as a model. See Adding 
Floors on page 519.

 l Foundation walls are created when a foundation is automatically generated on Floor 0. See Foundations on page 496. 
 l Attic walls are generated automatically when the program perceives a gap between a wall that defines a room and the 

roof above. See Attic Walls on page 259.
 l The Space Planning Assistant creates room boxes which can be arranged and then converted into walls. See Space 

Planning on page 49.
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DRAWING WALLS

Drawing walls to create a floor plan is simple if you keep a few things in mind: 

 l Draw exterior walls first to define the building’s footprint, then draw the interior walls after the perimeter is in place. 
 l It is easiest to draw walls at the approximate location and length needed and then move or resize them precisely using 

dimensions later. See Moving Objects Using Dimensions on page 341. 
 l When drawing and positioning exterior walls, make sure Grid Snaps  are enabled. Once these walls are in place, 

you may prefer to turn Grid Snaps off to draw and position interior walls and other objects. See Grid Snaps on page 
116. 

 l If you wish to input wall lengths as you draw, make sure your General Wall Defaults are set to Resize About Outer 
Surface. See Entering Wall Lengths and Angles on page 243.           

 l As walls are drawn, “sticky” points and extension lines identify points that are either collinear or orthogonal to the end 
points of other walls, making alignment easier. See Extension Snaps on page 114. 

 l When walls enclose an area to form a room, the program will orient all exterior walls so that the siding material faces 
outward. See Wall Type Definitions on page 262. 

 l To flip the layers of a wall after it is drawn, select it and click the Reverse Layers  edit button. See Editing Walls 

on page 251.
 l Initial wall heights are determined by the default floor and ceiling heights of the current floor. See Floor Level 

Defaults Dialogs on page 518.

WALL ANGLES

With very few exceptions, walls should be drawn and edited with Angle Snaps  enabled. Walls that are drawn at 

irregular angles can result in wall connection,  alignment, and room definition problems. See Angle Snaps on page 115.

Fencing, Terrain Walls, and Retaining Walls, which should never be used as part of a building's structure, are reasonable 
candidates for being drawn at off angles. See Fencing Tools on page 236 and Terrain Wall and Curb Tools on page 901.

If a wall is drawn at an off angle on the current floor level, the Off Angle Wall   icon will follow the mouse pointer and a 
Caution   symbol will display over the problem wall in plan view. See Pointer Icons on page 15.

Click on the Caution   symbol that displays over the wall to open a contextual menu: 

  Select Fix Off Angle Wall  to correct the wall's angle in the Fix Off Angle Wall dialog.

  Select Ignore Off Angle Wall to leave the wall unchanged and suppress the Caution symbol.

  Select Ignore All Off Angle Walls to leave the wall unchanged and suppress the Caution symbol on all off angle 
walls on all floor levels.

You can also suppress the Caution symbol by specifying the needed angle in the wall’s specification dialog or adding that 
angle to the list of Allowed Angles. See General Plan Defaults Dialog on page 60. 

When you select Fix Off Angle Wall  in the contextual menu, the Fix Off Angle Wall dialog opens:
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 l The Old Angle is stated for reference.
 l Enter a New Angle in the text field.
 l Specify whether to Lock the Start, Center, or End point of the wall when its angle is changed.

There are several other ways to fix a selected wall if it has been drawn at an off angle: 

 l Click the Open Object  edit button and specify the correct angle. See General Panel on page 268.

 l Click and drag an end edit handle until the wall snaps to an Allowed Angle. See Angle Snaps on page 115.
 l If the wall in question should be aligned with a wall directly above or below it, click the Align with Wall Above  

or Align with Wall Below  edit button. See Aligning Walls on page 255.

WALL POSITIONING

The recommended method of drawing walls is to draw them at their approximate location and length, then move them into 
position with accuracy using dimensions. To make this task quick and efficient: 

 l Notice the temporary wall that displays as you draw. Its length and angle display in the Status Bar at the bottom of the 
window and adjust as you move the mouse. Release the mouse button to draw the wall at the displayed length and 
angle. See The Status Bar on page 24. 

 l Use Snaps to help ensure proper wall alignment and orientation. See Snap Behaviors on page 113. 

Once walls are drawn, they can be accurately dimensioned and moved as needed. See Measuring Walls on page 248. 

ENTERING WALL LENGTHS AND ANGLES

The fastest way to draw walls is to draw them at their approximate position and length, and then move or resize them 
accurately using dimensions. See Moving Walls Using Dimensions on page 250.          

For those that wish to enter walls’ lengths and angles as they are drawn, first select Resize About Outer Surface in the 
General Wall Defaults dialog. See Resize About on page 255.          

Then draw a wall, select it, and specify its Length and Angle in the Wall Specification dialog.  Draw a second wall and 
specify its length and angle, and so on. See General Panel on page 268.          

WALL OPENINGS

To create a door or doorway, do not draw wall sections with a gap between them. Walls should be drawn to completely 
enclose rooms, and then door and window objects should be placed in the walls to create openings later. See Doors on page 
378 and Windows on page 408. 

TEMPORARY DIMENSIONS

Temporary dimensions will display along the length of a wall as it is drawn when Temporary Dimensions are 
toggled on. See Temporary Dimensions on page 333. 
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DRAWING CURVED WALLS

Drawing a curved wall, curved railing, or curved fence is similar to drawing a CAD arc. See Arc Tools on page 211.         

As with CAD arcs, the method used to draw a curved wall depends on which Arc Creation Mode  is currently active.  

See Drawing Arcs - Arc Creation Modes on page 210.          

A straight wall can also be converted into a curved wall and vice versa using the Change Line/Arc  edit button. See 

Change Line/Arc on page 176.

To create a room in the shape of a circle, you must draw two 
curved walls.

A curved wall always has a center point. The center displays as a small cross when Show Arc Centers and Ends  is 

enabled. See Arc Centers and Ends on page 153.         

The radius of a curved wall is measured from the center to a surface or layer of the wall. The radius can be defined in the 
Wall Specification dialog. You may elect to define the radius to the exterior or interior wall layers. See  General Panel on 
page 268.         

SPACE PLANNING ASSISTANT

The Space Planning Assistant Tools allow you to place and arrange room  boxes that can then be converted into a 
fully editable house plan, including walls. See Space Planning on page 49.         

WALL FRAMING

Once walls have been drawn, they can be framed. For best results, avoid generating framing until your model is in its final 
form. See Wall Framing on page 627.           

Once created, wall framing can be viewed and edited in floor plan and 3D views.          

 

Connecting Walls
When walls are drawn sufficiently close to one another, they will snap together to form an intersection. This snapping 
occurs when the walls’ center lines are within a distance defined by the larger of the two walls’ widths and will occur even 
when Object Snaps  are turned off. See Object Snaps on page 114.

If the two walls in question have identical specifications and are collinear, they will merge to become a single wall. See 
Aligning Collinear Walls on page 255.  

When three or more walls connect to form a completely enclosed area, that area defines a room. See Rooms on page 286.

244



Home Designer Pro 2025 Reference Manual - Connecting Walls

When walls snap together to form an intersection and Object Snaps  are enabled, the program joins them at their Resize 

About line, which is specified in the General Wall Defaults dialog. See Aligning Walls on page 255. 

 l The wall that is being drawn or edited will move, lengthen, or shorten slightly to meet the other wall. 
 l The other wall will not move; however, its length may be affected. 

WALL INTERSECTIONS

Any time two walls intersect, one wall will build through the other. You can turn on the display of the “Walls, Through 
Wall Lines” layer in plan view to see which walls build through and which do not. See Layer Attributes on page 125.           

When a wall builds through another wall, it will extend into the intersected wall until it meets the interior surface of that 
wall’s Main Layer. See The Main Layer on page 262.          

PARTITION WALLS

By default, walls not only build to an intersecting wall’s Main Layer, they also build through the finish layers of the floor 
below and the ceiling above to reach the structural layers.          

In some situations, though, this is not desirable: for example, glass shower walls are typically installed against the surfaces 
of walls, floors and ceilings rather than building into them. To achieve this, use               the “Glass Shower” wall type. See Glass 
Walls and Half-Walls on page 232.

FIX WALL CONNECTIONS

Occasionally, intersecting walls  may not properly connect. When this is the case and the connection in question is on 
the current floor level, a Caution   symbol will display at the problem location in plan view and the Connect Walls 

 icon will follow your mouse pointer.

Click on the Caution   symbol that displays over the wall to open a contextual menu: 

  Select Delete to delete the wall.

  Select Ignore Unconnected Wall to leave the wall unchanged and suppress the Caution symbol.

To correct wall connections throughout the current plan, select Build> Walls> Fix Wall Connections .           

Alternatively, you can fix an individual wall connection using the Connect Walls  edit tool.          

To use the Connect Walls edit tool

 1.  Select a wall.          

 2.  Click the Connect Walls  edit button.          

 3.  Click on a wall that you want to connect to the selected wall.           

 l If the unconnected wall ends are sufficiently close to one another, the tool connects them.           

 l If the separation is too great, extend one towards the other and try again.           
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REMOVING WALL BREAKS

The Add Break  edit tool allows you to break a wall into two or more separate wall segments. See Add Break on page 

175.

To merge two collinear walls separated by a break, select one of the segments, then click the end edit handle located at the 
break and drag it a few plan inches (mm) away from the break. 

If the two walls do not merge, either the walls are not collinear or their specifications are not identical. You can open the 
Wall Specification dialog for each wall and determine how they differ. See Wall Specification Dialog on page 268.

 

Displaying Walls
 While the structure and appearance of each wall type is controlled in the Wall Type Definitions dialog, the display of 
walls in all views is controlled in the Layer Display Options dialog. See Layer Attributes on page 125.

If a “Walls” layer is turned off in plan view, any doors and windows placed in walls on that layer will not display, either. 
See Displaying Doors on page 382 and Displaying Windows on page 416.

IN PLAN VIEW

The appearance of each wall type, including line weights and colors and wall layer fill styles, is specified in the Wall Type 
Definitions dialog. See Wall Type Definitions Dialog on page 264.

There are also several options for controlling how walls are displayed in plan view. In the Layer Display Options dialog, 
you can specify whether or not various types of walls display.

 l Walls are placed on layers with “Walls” at the beginning of the layer name, such as “Walls, Normal”. 
 l The display of the wall layers specified in the Wall Type Definitions dialog can be controlled. If you turn off the 

display of the layer called “Walls, Layers”, wall types display with two lines representing the inside and outside 
surfaces.           

 l In addition, you can turn off the display of non-structural layers and show only the walls’ Main Layers by turning on 
the display of the “Walls, Main Layer Only” layer. This allows you to create both fully configured walls and framing 
layouts. The “Walls, Main Layer Only” layer affects the display of walls in plan view only. See The Main Layer on 
page 262. 

 l The “Walls, Through Wall Lines” layer controls the display of lines indicating which walls build through at wall 
intersections.          

 l Foundation Walls have footings that display in all view when the “Footings” layer is turned on. See Displaying 
Foundations on page 502. 

 l Foundation Walls may also have brick ledge lines that display in plan view when the "Brick Ledge Lines" layer is 
turned on. See Brick Ledges on page 237.

Note: In plan view, railings not specified as Solid display their Main 
Layer regardless of whether “Walls, Layers” or “Walls, Main Layer 
Only” is turned on. See Wall Types and Railings on page 235. 

Either the upper or lower portion of a Pony Wall can display in plan view. Only the portion that displays can be snapped to 
or aligned with walls above or below. See Pony Walls on page 238.         
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It is sometimes helpful to display the walls from a floor other than the current floor. To do this, select and display a 
reference floor. See The Reference Display on page 525. You can also specify which layers are included in the Reference 
Display Layer Set in the Layer Display Options dialog. 

NOTIFICATION ICONS

Occasionally, the program may detect a problem with one or more walls in a plan. When this is the case, notification icons 
will display on the floor where the problem has occurred:

 l If a wall is drawn at an off angle, the Off Angle Wall   icon will follow the mouse pointer and a Caution   symbol 
will display over the problem wall in plan view. 

 l If there is a problem with a wall connection, the Connect Walls   icon will follow the mouse pointer and a Caution 
 symbol will display at the problem location.

The recommended response to either situation is to fix the problem, although you can choose to ignore it if you prefer. See 
Wall Angles on page 242 and Fix Wall Connections on page 245. 

If an issue has been ignored, notification icons for it will not display. Select Tools> Checks> Reset Notification 
Icons to display any suppressed notifications so that any wall angle or connection problems can be corrected.

IN 3D VIEWS

As in plan view, the display of walls can be controlled by layer in the Layer Display Options dialog. 

Each layer of a wall is generated when you create a 3D view. You can see the different layers in 3D using the Delete 
Surface  tool. See Delete 3D Surface on page 785.         

A wall’s framing layer displays as a solid layer rather than studs and plates until wall framing is built. See Framing on page 
626. Wall framing is placed on the “Framing, Wall” layer.

When a camera is located on the exterior of a structure, you can select 3D> Camera View Options> Hide Camera-Facing 
Exterior Walls , allowing the interior to be seen as you rotate around the model. Interior walls set as Attic walls are also 

hidden when this setting is active.  

While most architectural objects in the program can display in both floor plan and 3D views, a few cannot. Invisible walls 
and Wall Hatching are examples of objects that do not display in 3D.

Unlike in plan view, doors and windows placed in a wall can display in 3D views even if the wall’s layer is turned off. See 
3D View Defaults Dialog on page 774.

WALL LABELS

Wall labels are located on the “Walls, Layers” layer and can be set to display in plan views. See Label Panel on page 376. 

Walls do not have Automatic Labels by default; however, custom labels can be assigned to any wall in the Wall 
Specification and Defaults dialogs.

WALL MATERIALS

There are several ways that materials can be assigned to walls, depending on how the walls and the rooms they define have 
been defined. See Rooms on page 286. 

When you draw a wall, it uses the materials specified in its wall type definition. See Wall Type Definitions on page 262. 
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You can change the surface material of an individual wall in the Wall Specification dialog. If you select “Use Default” as 
the material and the wall is used to define a room, the program refers to the material specified in the Room Specification 
dialog. See Wall Specification Dialog on page 268.

You can also change a room’s wall material in the Room Specification dialog. See Materials Panel on page 750. To restore 
the default Wall Type material, select Use Default in the Select Material dialog. See Select Material/Library Object Dialog 
on page 751. 

Wall materials can also be changed using the Material Painter  tool, but bear in mind that depending on which Material 

Painter Scoping Mode is in use, only a portion of the wall may be painted and that the entire room may be affected rather 
than the individual wall. See Material Painter and Walls on page 749.

When neither the wall nor the room has a material assigned to it, the program refers to the general material for walls in the 
Material Defaults dialog. See Material Defaults on page 746.          

Note: Wall materials that are specified on the Materials panel of either 
the Wall or Room Specification dialog are not calculated in the Materials 
List.

IN THE MATERIALS LIST

The materials that make up wall assemblies are listed under different Categories in the Materials List: 

 l Siding - Lists the materials assigned to each wall’s Exterior Layers, such as siding, sheathing, and housewrap. 
 l Framing - Lists the framing material(s) for all walls as well as railings specified as Solid. Non-framed walls’ Main 

Layer materials are also listed here when those walls are not specified as Foundation. Wall framing, including studs, 
plates, and headers, is only counted when a framing material has been assigned to a wall type and wall framing has 
been built. See Framing on page 626.

 l Insulation - Insulation is calculated for all exterior walls are not defined as Railings, and have one or more Framing 
layers. Insulation thickness is equal to that of the framing layer. See Exterior and Interior Walls on page 236.

 l Wallboard - Lists the materials assigned to each wall's Interior Layers, such as drywall. This does not include Wall 
Coverings or materials specified in either the Room or Wall Specification dialog. See Materials Panel on page 280.

 l Interior Trim - Lists base, crown and chair rail moldings, and Wall Covering materials specified in the Wall and 
Room Specification dialogs. See Wall Covering Panel on page 279.

 l Foundation - Lists the concrete, block, and rebar for all walls specified as Foundation as well as their footings. See 
Foundation Walls on page 236.

 l General - Reports the thickness of glass wall materials and their total lengths. 

With the exception of wallboard, windows and doors are taken into account in the calculation of these totals.

Wall framing members can be reported in a Materials List using one of four methods: Linear Length, Buy List, Cut List, or 
Mixed Reporting. See Framing and the Materials List on page 659.

 

Measuring Walls
Accurate wall measurements are an essential aspect of any drawing, and can be achieved by following two basic rules:

 l Be aware of what part of a wall assembly dimensions are locating;
 l Position walls using dimensions rather than edit handles or edit tools.

These rules can easily be met when you keep the following recommendations in mind.
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DIMENSION DEFAULTS

Before drawing dimensions - and particularly, before using them to move your walls into position - make sure that all 
Dimension Defaults settings meet your needs. See Dimension Preferences and Defaults on page 321.

Depending on your Dimension Defaults settings, manual and/or automatic dimension lines may locate wall surfaces or wall 
dimension lines. See Locate Manual Panel on page 325.

Be aware that the wall length dimension that displays when a wall is selected as well as the Length specification in the Wall 
Specification dialog do not inherit their settings from the Dimension Defaults. Instead, they follow the Resize About line. 
See Resize About on page 255. 

Dimensions can be set to locate Wall Steps in elevation views. Steps in foundation walls in plan views can also be located. 
Wall steps cannot be moved using dimensions, however. See Stepped Walls and Footings on page 260.

If a wall is specified as Invisible, dimensions will locate it at its centerline regardless of its Wall Type Definition or your 
Dimension Defaults settings. If the Invisible wall divides rooms with different floor heights, dimensions will locate the edge 
of the wall facing the room where the floor is lower. See Room Dividers and Invisible Walls on page 239.

Only the portions of pony walls that display are located by dimensions. The upper and lower parts of pony walls typically 
have different thicknesses, so which  part you choose to display may affect your plan’s dimensions. See Pony Wall Defaults 
on page 230.         

OBJECT, ANGLE AND GRID SNAPS

Object Snaps, Angle Snaps, and Grid Snaps make it easier to align walls when they are being drawn as well as when they 
are edited. See Snap Behaviors on page 113. 

Object Snaps  help to ensure consistent wall connections and are particularly helpful when aligning collinear walls. 

When Grid Snaps  are enabled, walls are drawn on a regularly spaced grid, which helps avoid inaccurate wall 

placement. This can become particularly important if you forego positioning walls using dimensions in favor of using edit 
handles to move them. 

Using Grid Snaps is recommended when you are laying out 
exterior shell walls, but may be inconvenient when positioning 

interior walls or other objects. 

Angle Snaps  make it easy to accurately draw walls at regular angles, ensuring walls that are truly parallel or 

perpendicular to one another and separated by consistent distances.

PRIMARY AND SECONDARY SIDES

When dimensions that locate walls are drawn or generated in plan view, a Primary and a Secondary Side for each wall is 
identified. For exterior walls, the Primary Side is always the exterior side of the Wall Type Definition and the Secondary 
side is always the interior. See Wall Type Definitions on page 262.

For interior walls, the functionality is more complex:

 l For vertical interior walls with perfectly symmetrical wall layers, the Primary Side is always on the left side of the 
wall as it is drawn in the plan, regardless of the orientation of its layers.

 l For horizontal interior walls with perfectly symmetrical wall layers, the Primary side is always on the bottom side of 
the wall as it is drawn in the plan.
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 l For both vertical and horizontal interior walls with wall layer that are not symmetrical, the functionality is the same as 
that for exterior walls: the Primary Side is always the exterior side of the Wall Type Definition and the Secondary side 
is always the interior.

With the exception of Interior and Auto Room Dimensions, you can specify whether the various dimension tools locate the 
Primary Side, Secondary Side, or both in the Dimension Defaults dialog. See Locate Manual Panel on page 325.

Dimension lines that are drawn through a wall can also be set to measure and report the widths of walls, or to suppress that 
information. See Dimension Panel on page 344.

EDITING EXTENSION LINES

Once a dimension line has been drawn, its extension lines can be edited to locate a number of locations on a wall assembly:

 l The exterior surface
 l The Wall Dimension Layer’s exterior          
 l The center line of the wall assembly
 l The Main Layer’s center line
 l The Main Layer’s interior
 l The interior surface

See Editing Extension Lines on page 338.

MOVING WALLS USING DIMENSIONS

Automatic, manually-drawn, and temporary dimension lines can be used to both resize and move walls with accuracy. 
Select a wall, then click on a dimension line that reports its distance from another wall and type in the value that you 

need. See Moving Objects Using Dimensions on page 341.

When a wall is resized using dimensions, the inline text field used to edit the dimension will have three unique buttons:

 l Horizontal walls have Move Left End , Move Both Ends , and Move Right End . 

 l Vertical walls have Move Top End , Move Both Ends , and Move Bottom End . 

Choose the option that you want to use before pressing the Enter key.

Note: If only one of these buttons is available, the wall end that the 
button references is the only part of the selected wall that the dimension 
line actually locates, and only that end can be moved using the selected 
dimension.

If both ends of the selected wall intersect walls that are not parallel to one another, a fourth option will be available: Move 
Along Rails . When this option is used, the selected wall both resizes and changes position so that it remains connected 

to the other walls when you press the Enter key.
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NO LOCATE

If a wall is specified as No Locate in the Wall Specification dialog, it will be ignored by Auto Exterior Dimensions  in 

plan view, as will any doors or windows placed in it. See Dimensions on page 320.

By default, Railings, Deck Railings, and Room Dividers are specified as No Locate. See General Panel on page 268.

If a wall is specified as No Locate, it will be moved to the “Walls, No Locate” layer. If this box is later unchecked, the wall 
will return to its default layer. If a wall is on a non-default layer, it will remain there. See Displaying Walls on page 246.           

Once a dimension line has been created, it can be edited so that it locates a No Locate wall or railing that is perpendicular to 
it.

 

Editing Walls
Walls can be selected in all views. When a wall is selected, it displays edit handles and an edit toolbar that can be used to 
modify it in various ways. When a wall is selected, temporary dimensions may also display. See Temporary Dimensions on 
page 333.

The ways in which a wall can be edited depend on the current view and which edge is selected. See Selecting Objects on 
page 142.

SELECTING WALLS

Like other objects, walls can be selected in a variety of ways. See Selecting Objects on page 142.

 l When Select Room Before Wall in 3D is checked in the Preferences dialog and you click on a wall in a cross 
section/elevation or camera view, the room defined by that side of the wall will become selected instead of the wall. 
See Appearance Panel on page 63 and Selecting Rooms on page 291.

When this is the case, you can select the wall by clicking the Select Next Object  edit button or pressing the Tab 

key.          
 l In plan views, the Edit Area  tools allow you to select only part of a wall or walls. See Edit Area Tools on page 

186.          
 l In a Framing Overview or other 3D view in which wall framing can be seen, select a wall framing member and click 

the Find Wall  edit button to switch to a plan view in which the wall associated with the selected framing is 

selected. A wall selected in this manner can then be edited even when its layer is turned off and/or locked. See 
Locking Layers on page 126. 

In plan view, if wall hatching has been applied to a wall using the Wall Hatching  tool, it is possible that the hatching 

may be selected first. If it is, click Select Next Object  to select the wall itself. See Wall Hatching on page 240.

USING THE EDIT HANDLES

A selected wall can be modified in a variety of ways using its edit handles in any view. The handles that are available will 
depend on the current view type. See Edit Handles for Walls on page 253.
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IN THE SPECIFICATION DIALOG

The appearance and structure of walls can be customized in the Wall Specification dialog. See Wall Specification 
Dialog on page 268.

The characteristics of the roof directly above a selected wall can also be specified in the Wall Specification dialog. See Roof 
Panel on page 272.

USING THE EDIT TOOLS

A selected wall or walls can be edited in a variety of ways using the buttons on the Edit Toolbar. See The Edit Toolbar on 
page 92.

REVERSE LAYERS

When walls enclose an area to form a room, the program will orient all exterior walls so that the siding material faces 
outward. When needed, you can click the Reverse Layers edit button to flip the orientation of the interior and 

exterior layers of a selected wall. Its wall type definition is not affected by this change. See Interior and Exterior Surfaces 
on page 263.

When a wall has Lower Wall Type if Split By Butting Roof checked in its specification dialog and its interior wall layers 
are oriented to face adjacent roof planes, a Caution   symbol will display at the problem location in plan view and the 
Reverse Layers   icon will follow your mouse pointer. See Roof Panel on page 272.

Click on the Caution   symbol that displays over the wall to open a contextual menu: 

 l Select Reverse Layers to flip the wall's interior and exterior layers.
 l Select Ignore Reversed Wall to leave the wall unchanged and suppress the Caution symbol.

WALL THICKNESS

The initial thickness of a wall is determined by its wall type definition. You can change a wall’s thickness by modifying its 
wall type. If you do this, all instances of the wall type used in the plan will be affected - not just an individual object. See 
Wall Type Definitions on page 262. 

You can also specify a selected wall’s thickness in its Wall Specification dialog. See General Panel on page 268. 

If a selected wall’s thickness is changed: 

 l A copy of the wall’s wall type is created with the same name but appended with a number equal to the thickness of the 
Main Layers, and that new type is assigned to the wall. See The Main Layer on page 262.

 l The change in thickness will be applied to new wall type’s innermost Main Layer. 
 l The Main Layer must be at least 1/16” thick, and the wall’s thickness cannot be less than the original wall type’s total 

thickness minus the thickness of its Main Layer.  

If a wall type’s thickness is modified, the wall will resize about the Resize About line specified in the General Wall 
Defaults dialog. In some instances, the wall may appear to move as a result of changes made to the thicknesses of its layers. 
See General Wall Defaults on page 229. 

WALL HEIGHTS

The height of a wall is controlled by the ceiling height of the room(s) it defines. If the ceiling or floor height of a room is 
changed, the height of the walls that define it also change. 
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 l The initial ceiling height for all rooms on a floor is set in the Floor Defaults dialog for that floor. See Floor Level 
Defaults on page 287. Whenever possible, it is best to set all ceiling heights using the default.         

 l The ceiling height of a single room can be set in its Room Specification dialog. See General Panel on page 308.
 l The default Floor and Ceiling Heights for a given floor can be adjusted by editing the top and/or bottom edges of the 

Exterior Room in a 3D view. See The Exterior Room on page 292.           
 l The top or bottom edge of any wall can be adjusted independent of floor or ceiling heights using the mouse in Cross 

Section/Elevation and 3D views. Top and bottom edges can also be stepped and raked. See Stepped and Raked Walls 
on page 260.          

 l The top height of a selected Railing can also be edited in Cross Section/Elevation and 3D views. The bottom height, 
however, cannot. See Railing and Deck Tools on page 233.          

 l The                  edge dividing an upper and lower pony wall can be edited in Cross Section/Elevation and 3D views. In addition, 
its height can be defined in the Wall Specification dialog. See Wall Types Panel on page 277. 

WALL LENGTH

By far, the most accurate way to position walls and specify wall length is using dimensions. For more information, see 
Measuring Walls on page 248.

To produce accurate measurements, remember to: 

 l Be aware of what part of your walls is being located by each type of dimension.
 l Avoid specifying dimension values with greater accuracy than your dimensions are set to display. See Format Panel 

on page 328. 

Wall length can be modified in several other ways, as well: 

 l In the Wall Specification dialog. See General Panel on page 268.
 l Using the Add Break  edit tool to divide a selected wall into two segments. See Add Break on page 175.

 l By dragging the end edit handles. See Editing Line-Based Objects on page 146 and Editing Arc-Based Objects on 
page 149. 

Be aware that the wall length dimension that displays when a wall is selected as well as the Length specification in the Wall 
Specification dialog do not locate the wall the same way dimension lines do, using settings from the Dimension Defaults. 
Instead, they follow the Resize About line and may not report the same values as dimension lines. See Resize About on 
page 255.           

If you try to resize a wall by a small amount using one of its edit handles and that wall is connected to another wall at that 
end, its length will not change because its end will snap back to the existing intersection. See Connecting Walls on page 
244. 

Dimension Defaults can have a significant effect on wall 
position. It is recommended that you review these settings and 

make sure that they meet your needs.

 

Edit Handles for Walls
Walls can be edited extensively using their edit handles. Depending on the type of view, a wall displays a different set of 
edit handles when selected. 

Moving a wall in any view will move any cabinets attached to that wall, as well.    
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IN PLAN VIEW

In plan view, straight and curved walls can be edited like other line- and arc-based objects. See Editing Line-Based Objects 
on page 146 and Editing Arc-Based Objects on page 149.

In addition:

 l A wall’s edit handles display along its Resize About line. See Resize About on page 255.          
 l A wall can only be moved perpendicular to itself or, in the case of curved walls, perpendicular to its chord using the 

Move edit handle. To move a wall at Allowed Angles, use the Alternate  Edit Behavior. See Alternate on page 

139. 
 l When wall labels are set to display and a wall has a label, it will have a small, square Move edit handle.         

IN CAMERA VIEWS

The edit handles that are available for a selected wall in a camera view depends whether the wall is selected on its interior 
or exterior surface or on its top or bottom edge.

 l In a cross section/elevation view, the top and bottom edges of straight and curved walls can be edited like closed 
polylines. See Editing Closed Polyline-Based Objects on page 157. Only the top and bottom edges of walls can be 
broken, angled, or curved: the side edges cannot.    

 l In a camera view or overview, click on an interior or exterior surface to display the same edit handles as in an 
elevation view: one at each corner and one on the top and bottom edges.    

 l In a camera view or overview, click on the top surface of a wall to display the same edit handles as in plan view, 
allowing you to rotate, move, and extend or shorten the length of the wall.      

 l The footings of Foundation Walls and Slab Footings can be selected in 3D views and edited using the edit handles. 
See Footing Width and Height on page 505.     

SAME WALL TYPE EDIT HANDLES

The Same Wall Type edit handles allow you to draw a new wall extending out from either end of a selected wall and 
with identical properties as that wall. These edit handles are enabled globally in the Preferences dialog. If you prefer, 

you can disable them globally and enable them only as needed by selecting a wall and clicking the Same Wall Type edit 
button. See Architectural Panel on page 77.         

When the Same Wall Type edit handles are enabled, two edit handles display just beyond a selected wall’s Extend edit 
handles in plan view or when the top edge of the wall is selected in a 3D view.          

Click and drag a Same Wall Type edit handle at any angle to draw a new wall segment of the same type as the selected 
wall.           
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Aligning Walls
Wall alignment refers to the way wall segments line up with one another, either on the same floor or on the floor above or 
below.  Walls may need to be aligned in a variety of situations.

To make alignment easier when drawing or resizing walls, “sticky” points and extension lines identify points that are either 
collinear or orthogonal to the end points of other walls. See Extension Snaps on page 114. 

RESIZE ABOUT

The Resize About line specified in the General Wall Defaults dialog controls two important aspects of wall alignment:          

 l What part of a wall retains its position when its wall type or wall type definition is changed. See Wall Type Definitions 
on page 262.          

 l Where walls snap together to form an intersection. See Connecting Walls on page 244.          

See General Wall Defaults on page 229.          

The Resize About line is the line along which a selected wall’s length is measured in the Wall Specification dialog. See 
Wall Length on page 253.           

The Resize About line is also the line along which a selected wall’s edit handles display, and is the line along which any 
snap points will be located. See Editing Walls on page 251.           

ALIGNING COLLINEAR WALLS

Collinear walls are parallel walls connected end to end and drawn on the same floor. When collinear walls join end-to-end, 
the walls snap together. If these walls have the same wall type and identical specifications, and if Object Snaps  are 

enabled, they will merge to become a single wall segment.

CREATING A NOOK

Walls can be aligned across an opening such as a nook, so that they are collinear, using the Add Break  edit tool.          

To align walls across a gap

 1.  Select a wall to build a nook into and click the Add Break  edit button.          

 2.  Click at a point on the wall close to one side of the nook area. Do not worry about exact placement right now.          

 3.  Click again near the other side of the nook. Two short lines at each location where you clicked indicate Breaks in the 
walls.          
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 4.  Right-click the middle section of the wall to select the wall section.          

 5.  Click the middle Move handle and drag the wall outward.          

 6.  Draw side walls to connect the wall back to the rest of the house.          

 7.  Move these short walls using dimensions to accurately size the nook.          

ALIGNING WALLS BETWEEN FLOORS

Walls can be aligned between floors by clicking the Align With Wall Above and Align With Wall Below edit 
buttons.

By default, walls on different floors are aligned by the outer edges of their Main Layers. See The Main Layer on page 262.         

In order for these edit tools to be available, the areas of the walls 
in question must be partially aligned, or overlapping.

To align walls between floors

 1.  Select a wall that you want to align with another wall either above or below it.

 2.  If the wall is above or below the other wall along only part of its length, you must click on it along that part. Select 
Tools> Floor/Reference Display> Reference Display On  to help make sure you click on the correct part of the 

wall.

 3.  When you have selected the wall at the desired location, click either the Align With Wall Above  or Align With 

Wall Below  edit button.

ALIGNING CURVED WALLS BETWEEN FLOORS

Curved walls are aligned between floors using the same technique to align straight walls. If the centers and radii of the walls 
are within a few inches of each other, the Align With Wall Above  and Align With Wall Below  edit buttons are 

enabled for the selected wall. The selected curved wall will take on the radius and center of the referenced wall when the 
walls are aligned.

ALIGNING PONY WALLS BETWEEN FLOORS

When aligning a pony wall with either the wall above or below:         

  Align With Wall Below will always align the lower pony wall with the wall below, as specified in the lower 
pony wall’s Wall Type Definition. See Wall Type Definitions on page 262.

  Align With Wall Above will always align the upper pony wall with the wall above, as specified in the upper 
pony wall’s Wall Type Definition.              
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ALIGNING FOUNDATION WALLS

By default, foundation walls and slab footings will align with walls on the floor above along the outside surface of the Main 
Layer of both wall types. See Wall Type Definitions on page 262.   

If there is only one layer for both the stem wall and the first floor wall above it, the exterior surfaces of the walls align. The 
footing is centered on the stem wall.   

ALIGNING RAILINGS ON DIFFERENT PLATFORMS

Two collinear Railings or Deck Railings on the same floor can be aligned one above the other when they define rooms with 
different floor heights.

To align railing on different platforms

 1.  Click and drag to draw a Railing or Deck Railing that divides a room such as a deck in two.

 2.  Click the Select Objects  button, then click in one of the room areas.

 3.  Click the Open Object  edit button, and on the GENERAL panel of the Room Specification dialog:             

 l Specify a Floor Height that differs from that of the other by at least the height of the railing, then click OK.

 l The default railing height is 36”, so for best results the Floor Height should be changed by at least this amount.

 4.  Click on the railing drawn in step 1, then click the Open Object  edit button. On the RAIL STYLE panel of the 

Railing or  Deck Railing Specification dialog, check Generate on Low Platform. See Rail Style Panel on page 281.

 5.  Click and drag a second railing parallel to the one drawn in step 1.

 6.  Select this second railing and click the Open Object  edit button. On the GENERAL panel of the Railing or Deck 

Railing Specification dialog, check the box beside No Room Def and click OK.

 7.  With the railing still selected, Ctrl/⌘  + + drag it into the same position as the first railing. See To move an object 
freely on page 169.

 

Roof Directives in Walls
To automatically generate a roof plane using values other than the defaults or to not generate a roof plane bearing on a 
particular wall (as for a gable or the sides of a shed roof), you can change the settings in the Wall Specification dialog. See 
Roof Panel on page 272. 

HIP, GABLE, AND SHED ROOFS

By default, the program will produce a roof plane over each exterior wall to create a hip roof. You can specify a different 
condition over a selected wall, however. For example:
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 l Check Full Gable Wall to create a gable with a ridge centered above the selected wall(s).
 l Check High Shed/Gable Wall for the side walls or the wall under the high side of a shed roof. 
 l You can also select a wall and click the Change to Gable Wall(s)  edit button, or change it back by clicking the 

Change to Hip Wall(s)  edit button. 

PITCH

The default pitch for roof planes is set in the Build Roof dialog. However, any exterior wall can define the pitch of the roof 
plane built above it.

You can also specify a second, upper pitch above a given wall. Mansard, gambrel, gull wing and half-hip are examples of 
roof styles that use two pitches. 

OVERHANGS AND ROOF RETURNS

You can specify the overhang of the roof plane to be generated above the selected wall. This setting only takes effect when 
Same Height at Exterior Walls is unchecked in the Build Roof dialog, which is also where the default Overhang value is set.           

Check Auto Roof Return to generate roof returns on the selected wall. In most cases, roof returns only generate on Full 
Gable Walls. See Roof Returns on page 623.         

EXTEND SLOPE DOWNWARD

Check Extend Slope Downward to extend the roof plane downward over a bump-out, instead of creating additional roof 
planes. The two connecting walls that create the bump-out must be Full Gable walls.

In the following image, the bearing wall of the bump-out has Extend Slope Downward checked. The two short side walls 
are Full Gable Walls. 

CLERESTORY AND DORMER WALLS

Occasionally, walls are built between two roof planes rather than between a roof plane and a floor platform. Common 
examples include clerestory walls and the side, or the cheek, walls of floating dormers.          
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Check Roof Cuts Wall at Bottom to have the bottom of the selected wall clipped by the roof plane below, as where a 
floating dormer wall meets the main roof plane.          

EXTERIOR/INTERIOR PONY WALLS

It’s not uncommon for an individual wall to be an exterior wall near its top, and an interior wall near its bottom.           

Check Lower Wall Type If Split By Butting Roof to achieve this. When this option is checked, the selected wall is 
specified as a pony wall and a second, lower wall type can be specified. Unlike with other pony walls, the change in wall 
type occurs wherever a roof plane builds to the exterior of the wall. See Pony Walls on page 238.           

 

Attic Walls
In Home Designer, walls are built between the floor and ceiling platforms of the current floor.  See Floor and Ceiling 
Heights on page 301. When the program detects an open space between a wall and the roof plane above it, it automatically 
creates an Attic Wall on the floor above that wall to fill in the gap. 

Attic Walls are typically found above Full Gable Walls, forming a gable or closing the top portion of a side wall of a shed 
roof. They are also generated above all exterior walls when the Raise Off Plate value in the Build Roof dialog is 3” (175 
mm) or greater. See Build Roof Dialog on page 579. 

Attic Walls are often found on the Attic floor, but can be generated on other floors, as well. See The Attic Floor on page 
525.

Attic Walls are specified as such in the Wall Specification dialog; if automatically generated, that will be noted as well. If 
needed, you can specify a regular wall as an Attic Wall. If you specify a wall as an Attic Wall, it will be moved to the 
“Walls, Attic” layer, See General Panel on page 268.

When you Rebuild Walls/Floors/Ceilings , all automatically generated Attic Walls in the plan are deleted and rebuilt.

REMOVING ATTIC WALLS

Occasionally, the program will generate an Attic Wall where one is not wanted. There are several ways to address this:

 l Turn off the display of the “Walls, Attic” layer.
 l Specify the Attic Wall as Invisible. See Room Dividers and Invisible Walls on page 239.
 l Some interior Attic Walls can be suppressed by specifying space they enclose as a Shelf Ceiling. See Shelf Ceilings on 

page 302.
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 l Select the Attic Wall and Delete  it. The program will specify the wall as Invisible automatically. If you delete this 

Invisible wall, a new Attic Wall will be created.
 l Combine the Attic Wall with the wall below. To do this, select Combine with Above Wall in the Wall Specification 

dialog for the wall below. See Roof Panel on page 272.          

KNEE WALLS

Knee Walls are a bit like Attic Walls in that they are not meant to generate to full ceiling height. Instead, they build upward 
until they encounter a roof plane. Unlike Attic Walls, however, Knee Walls are used in the interior of a structure, typically 
to separate unused areas from rooms on the upper floor of a story-and-a-half structure. See Room Types on page 289.

Home Designer does not specify walls as Knee Walls automatically. If an interior wall is drawn in a location where the roof 
is lower than the ceiling height, you should specify it as a Knee Wall in the Wall Specification dialog. See Roof Panel on 
page 272.

For best results, Knee Walls should be drawn perpendicular to the pitch of the roof and should intersect with Full Gable 
Walls on each end. 

 

Stepped and Raked Walls
Stepped and raked walls can be created using the Add Break  edit tool and the wall’s edit handles in any 3D or cross 

section/elevation view. In many cases, working in a Back Clipped Cross Section  is easiest and allows the greatest 

accuracy.          

When you try to select a wall in a 3D view, the interior or 
exterior room that it defines may be selected first. Click the 

Select Next Object edit button to select the wall itself. See Selecting 
Walls on page 251. 

STEPPED WALLS AND FOOTINGS

A typical example of stepped walls is a stepped foundation with pony walls. In the illustration below, the lower part of the 
pony wall is the concrete wall with footing, and the upper part of the pony wall is a framed wall with brick siding built to 
the first floor platform. See Pony Walls on page 238.           

To add a step to a wall

 1.  Select the wall in a Back Clipped Cross Section  view.           

 2.  Click the Add Break  tool, then click the top or bottom edge of the wall to place the break.           
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 3.  In addition to the corner handles, two handles display along the broken edge.           

 4.  Select one of these two handles, and drag up or down.          

 5.  A square step is created.          

The vertical edges of a wall cannot be broken, although they can be raked as well as moved side to side.          

By default, a stepped foundation wall  displays an “S” symbol at the location of each step in plan view. The display of this 
“S” is controlled in the Foundation Defaults dialog. See Foundation Defaults on page 497. 

Steps in walls can be located by dimensions in elevation views when Wall Steps is checked in the Dimension Defaults 
dialog. In addition, steps in foundation walls can be located in plan view. Wall steps cannot be moved using dimensions, 
however. See Locate Manual Panel on page 325.

RAKED WALLS

A raked wall has an angled top or bottom edge.           

To create a simple raked wall

 1.  Select the wall in Cross Section/Elevation or 3D view.           

 2.  Click one of the corner edit handles and drag that handle either up or down.           

 3.  To rake a wall at a specific angle, you can:           

 l Use Angle Snaps  and Allowed Angles. See Angle Snaps on page 115.          

 l Draw a CAD Line  at the desired angle and use the Make Parallel/Perpendicular  edit tool. See Make 

Parallel/Perpendicular on page 171.           

COMPOUND RAKED WALLS

A compound raked wall is a wall that has a top or bottom edge with multiple angles.           
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To create a compound raked wall

 1.  Select the wall in Cross Section/Elevation or 3D view.           

 2.  Use the Add Break  tool to add breaks to the wall edge, as for a stepped wall.           

 3.  Select a segment of the edge and adjust its angle, as for a raked wall.           

 

Wall Type Definitions
Every wall drawn in a plan is assigned a wall type, and its Wall Type Definition determines its structure, its appearance in 
plan view, and its default materials. Wall types can be viewed, edited, and created in the Wall Type Definitions dialog. See 
Wall Type Definitions Dialog on page 264.

Wall types typically have multiple assembly layers, each representing a different material. All of these layers can be 
calculated in the Materials List. The materials assigned to the surface layers of the Wall Type Definition also determine the 
wall’s appearance in 3D views. See Materials Lists on page 950.         

You can specify the default wall type that is drawn by each Wall Tool and can specify the wall type of any wall after it is 
drawn in the Wall Specification dialog. See Wall, Railing, and Fencing Defaults on page 229 and Wall Types Panel on page 
277.   

THE MAIN LAYER

In most circumstances, each wall type’s Main Layer should be specified as the structural layer. A wall type is considered to 
be:

 l “Framed” if it has a Main Layer specified as Framing;             
 l “Concrete” if it has a Main Layer with the “Concrete” Material Structure Type;             
 l “Masonry” if it has a Main Layer with a “Masonry” Material Structure Type.             

See Materials and the Materials List on page 757.         

 l The Main Layer determines many things in addition, including:             
 l Floor and ceiling platforms and automatically built foundation walls normally build to the outer edge of the Main 

Layer.             
 l The Main Layers of exterior walls build through slab floors while interior wall layers stop at the slab surface.              
 l At intersections, walls join at the interior surfaces of their Main Layers. See Connecting Walls on page 244. 
 l Windows are placed relative to the outer surface of the outermost Main Layer.
 l Exterior walls on different floors are aligned by the exterior edges of their outermost Main Layer. 
 l Roof baselines are placed at the outer edge of the outermost Main Layer when roofs are automatically generated. See 

The Baseline on page 586.
 l Roof baselines and gable/roof lines that are manually drawn snap to the outermost edge of the Main Layer.              
 l By default, walls resize about the exterior surface of their Main Layers when their thickness, wall type, or Wall Type 

Definition is changed. See Resize About on page 255. 
 l Object Snaps                  locate the interior and exterior edges of a wall’s Main Layers. See Object Snaps on page 114. 

 l The Sheathing Layer that windows and doors may be recessed to is the layer located just outside the outer Main Layer.               
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All of this information is reliant on the Main Layer, so creating your wall type definitions accurately beforehand and 
specifying the Main Layer correctly is very important.         

MULTIPLE MAIN LAYERS

In standard light frame construction, walls build to one another’s framing layers, and floor and ceiling platforms are built to 
bear over the wall framing; however, some building techniques configure these components in other ways. You can control 
how walls of a given type are intersected, and also where platforms build to, by specifying multiple Main Layers.         

 l By default, when multiple Main Layers are specified:         
 l Intersecting walls build to the interior surface of the innermost Main Layer.          
 l Floor platforms build to the exterior surface of the outermost Main Layer.         
 l A selected wall’s edit handles display along the exterior of the outermost Main Layer.         
 l The exterior surface of the outermost Main Layer is the Dimension Layer.          

See Wall Type Definitions Dialog on page 264.         

THE DIMENSION LAYER

Dimension Defaults can be set to locate walls at their surfaces or at the exterior line of their Wall Dimension Layer. See 
Locate Manual Panel on page 325.         

For installed wall types, the default Wall Dimension layer is the Main Layer; however, this can be changed in the Wall Type 
Definitions dialog. In addition to the Wall Dimension Layer, dimensions can locate the inside surface of the Main Layer, as 
well.         

Whether Surface or Wall Dimension Layer is selected on the LOCATE OBJECTS panel of the Dimension Defaults dialog 
determines a number of aspects related to how dimensions locate walls:         

 l How Auto Exterior and Manual Dimensions measure the lengths of walls.                 
 l Where both Manual and Automatic Reach are measured from.                 
 l Where Extension line lengths and their Gap From Marked Object are measured from.                 
 l Where First Line Offset for Auto Exterior Dimensions  is measured from.                 

 l How the minimum enclosed area required by Auto Exterior Dimensions  is measured.                 

The settings on the LOCATE OBJECTS panel control how dimensions initially locate walls. Once a dimension line has been 
created, you can move its extension lines or add new extensions to locate other points along a wall’s assembly. See 
Measuring Walls on page 248.             

INTERIOR AND EXTERIOR SURFACES

Every wall has an interior and exterior surface - including walls in a plan that are recognized by the program as being 
interior walls. See Exterior and Interior Walls on page 236.

Having separate designations for a wall’s two sides serves a couple of purposes:

 l It allows the program to orient each wall’s exterior side toward the outside of a structure. See Creating Walls on page 
241.

 l It allows you to specify different materials for each side’s surface in the Wall Specification dialog. See Materials 
Panel on page 280.
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In the Wall Type Definitions dialog, the exterior surface is shown at the top of the Wall Layers table. In plan view, you can 
identify a selected wall’s exterior surface by the location of its edit handles, which display on the exterior of the Main Layer 
by default. See Resize About on page 255.

LEGACY WALL TYPES

In Home Designer Pro version 9 and prior, generic, single-layer wall types were used as the default for railings, deck 
railings and fencing. 

 l In Home Designer  Pro 8 and prior, there were two such wall types: “Default (wood frame 16” OC)” and “Default 
(concrete)”.             

 l In Home Designer  Pro 9, these two wall types were replaced by one named “Adjustable Thickness Wall”.             

When plans that include either of these wall types - in the drawing itself or set as a default - are opened in Home Designer 
Pro 2025, the legacy wall type is replaced by a new wall type named “Wall-X”, where X is the thickness of the wall’s Main 
Layer, rounded up. There are a few exceptions:

 l If legacy wall types with the same thickness but different materials are found, they use the same naming convention 
appended with an additional _X.          

 l If a wall using a legacy wall type is specified as a Foundation wall, the resulting wall type will be named “Foundation 
Wall-X”.          

 l If a legacy wall type has the same attributes as a wall type installed with Home Designer Pro 2025, such as 8” 
Concrete Stem Wall, it will be replaced by that wall type.          

Unless a wall is specified as a Foundation wall, Deck Railing, or Fencing, it will be treated as a framed wall and its new 
wall type will acquire two additional 1/2” (13 mm) thick wall layers: an interior and an exterior layer. These new layers will 
use the interior and exterior materials of the original wall. The wall’s original layer will maintain its original thickness, 
acquire a framing material, and will become the new wall type’s Main Layer.         

Foundation, Deck Railing, and Fencing wall types converted in this manner will continue to have only one layer.         

 

Wall Type Definitions Dialog
The Wall Type Definitions dialog is used to define new wall types and redefine existing wall types in the current plan 
file. Select Build> Wall> Define Wall Types to open this dialog.          

You can also click the Define button on the WALL TYPES panel of the Wall Specification dialog or in most Wall Defaults 
dialogs. See Wall Types Panel on page 277.          

Changes made to an existing wall type definition affect all walls in the current plan using that wall type. Walls in other plan 
files are unaffected.         

If changes to a wall type affect its thickness, the position of any walls in the plan using that wall type may be affected. See 
General Wall Defaults on page 229.         
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Wall Types

Manage the list of wall types available in the current plan. See Wall Type Definitions on page 262.             

 l Click the drop-down list to display all wall types in the current plan. Select a wall type from the list to display its 
definition. You can rename a wall type by typing in a new name. Note that wall type names in a plan must be 
unique.             

 l To create a new wall type, click New to define a new wall type from scratch or click Copy to copy the current wall 
type. A copied wall type can then be renamed and redefined.             

 l Click Rename to rename an existing wall type, or simply click on its name and type a new name.             

 l To remove a wall type from the current plan, select it and click Delete. Wall types that are in use or set as plan 
defaults cannot be deleted.             

 l To remove all wall types that are not in use or set as a default from the current plan, click Delete All Unused.             

 
Wall Layers

The selected wall type's layers are listed here, from the exterior at the top to the interior at the bottom. The last item listed is 
the interior surface line rather than a true layer.             

 l The list is divided into three sections: Exterior, Main, and Interior Layers. To move a layer from one section to 
another, use the Move Up and Move Down buttons to the right.             

 l A wall type’s thickest structural layer is typically set as the Main Layer; however, multiple Main Layers can be 
specified. See The Main Layer on page 262.             
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 l Click in either the Pattern or Texture column to open the Select Material dialog and choose a material for the 
selected wall layer. See Select Material/Library Object Dialog on page 751.             

 l Click in the Fill column to open the Layer Fill Style dialog and specify a fill style for the selected wall layer. See 
Fill Styles on page 131.              

Wall layer fill styles are overridden if you use the Wall 
Hatching tool on a wall in plan view. See Wall Hatching on 

page 240.      

 l Click in the Thickness column to type the selected layer’s thickness, or depth. Very thin layers can be created, but 
for best results, avoid using a thickness of 0. For very small values, it can be helpful to temporarily change the 
dialog number format: click the Number Style button.

 l Click in the Extension column to type how far the selected layer extends past its default bottom elevation, either 
at the bottom of the wall's bottom plate or that of the floor platform it builds on. Only available for Exterior wall 
layers, the highest Extension value is also applied to the wall type's Brick Ledge Depth, set on the Wall 
Properties Tab.

The buttons to the right of the table allow you to reorganize the wall type definition’s layers.         

 l Click the Insert Above button to create a new layer directly above, or outside, the selected layer in the wall type 
definition. The new layer is a copy of the original.              

 l Click the Insert Below button to create a new layer directly below, or inside, the selected layer in the wall type 
definition. The new layer is a copy of the original.             

 l Click the Move Up button to swap the selected layer’s position with that of the layer immediately outside it or to 
move it into the layer section directly outside it. Not available for the outer-most layer or for a single Main Layer.              

 l Click the Move Down button to swap the selected layer’s position with that of the layer immediately inside it or to 
move it into the layer section directly inside it. Not available for the inner-most layer or for a single Main Layer.              

 l Click Delete to remove the selected layer from the wall type definition.              

 l The Total Thickness of the wall assembly displays here. If you change this value, the thickness of the Main Layer 
automatically updates to account for the difference.             

 
Properties Tabs

Click on a tab to access various settings related to the functionality and appearance of the selected wall layer. See below. 

 
Preview

A preview of the selected wall type definition displays here. See Dialog Preview Panes on page 21.     

 l When the selected preview type is a 3D view, a gap is shown between each of the wall layers in the preview. Click 
the Explode Layers  button remove or restore these gaps.     

 l When Plan View is the selected preview type, click the Line Weights  button to toggle the display of the wall 

layer and pattern line weights, or thicknesses. See Line Weights on page 995.    

MATERIAL PROPERTIES TAB

Specify whether the selected wall layer has special attributes. Defaults for the Spacing, Width, Count, and Length settings 
can be set in the Framing Defaults dialog. See Wall Panel on page 638.

266



Home Designer Pro 2025 Reference Manual - Wall Type Definitions Dialog

 l Check Framing to produce framing in the selected layer when wall framing is generated. See Framing Defaults on 
page 627.
 o Check Use Default Framing Material to apply the default framing material set in the Build Framing dialog to 

the selected wall layer. See Materials Panel on page 649. 
 o Select the framing Type from the drop-down list. See Framing Types on page 629.    
 o Specify the on-center Stud Spacing of the selected wall layer. The default value is set in the Framing Defaults 

dialog. See Wall Panel on page 638.
 o Specify the Stud Width of the framing in the selected layer. The default value is set in the Framing Defaults 

dialog.
 o Specify the Top Plate Count, which is the number of plates stacked one above the other on top of the wall studs. 

When multiple plates are specified, their ends are staggered 48" (1200 mm).    
 o Specify the Top Plate Width, which is the vertical thickness of the top plate(s).    
 o Specify the Bottom Plate Count, which is the number of plates stacked under the wall studs.    
 o Specify the Bottom Plate Width, which is the vertical thickness of the bottom plate(s).    
 o Check Max Plate Length, then specify the maximum allowed length for the boards that make up the top and 

bottom plates. When unchecked, top and bottom plates run the entire length of each wall, regardless of its length.
 l Check Air Gap to prevent the selected layer from displaying in 3D views or being calculated in the Materials List.
 l Check Horizontal Framing to produce framing that runs horizontally instead of vertically, sometimes referred to as 

girts.     
 o When Horizontal Framing is checked, specify the Bottom Run Elevation. This value is absolute, measured from 

the center of the lowest horizontal framing member relative to zero, the default top height of the subflooring on 
Floor 1. For horizontal framing on Floor 0, enter the absolute elevation of the bottom run on that floor. See Floor 
1 Default Height on page 288.    

 o When Horizontal Framing is checked, check Max Girt Length and then specify the maximum allowed length 
for the girt boards. When unchecked, girt boards run the entire length of the wall, regardless of its length.    

LAYER PROPERTIES TAB

 
Selected Wall Layer Line
These settings control the appearance of the selected wall layer's edge line. The exterior-most Main Layer has two edge 
lines, while all layers inside it have one line on their interior side and all Exterior layers have one line on their exterior side.   

 l Define the Color, Style, and Weight for the selected Wall Line.      

 l Check By Layer if you want the line to assume the attributes of the wall’s layer as defined in the Layer Display 
Options dialog. See Layer Attributes on page 125.       

WALL PROPERTIES TAB

  Wall Settings
 l Build Platform to Exterior of Layer - Select a wall layer from the drop-down list to build floor and ceiling 

platforms to. By default, the exterior side of the outermost Main Layer is selected.             

Note: If Build Platform to Exterior of Layer is set to the exterior wall 
layer, no siding material will generate to cover the floor platform. 
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 l Dimension to Exterior of Layer  - Select the wall type’s Dimension Layer from the drop-down list. By default, the 
outermost Main Layer is selected. This setting does not affect Interior Dimensions. See The Dimension Layer on 
page 263.             

 

Wall Specification Dialog
To open the Wall Specification dialog, select a wall or group of walls and click the Open Object edit button. 

The panels of the Wall Specification dialog are also found in the Railing, Deck Railing, and Fencing Specification dialogs. 
See Railing and Fencing Specification Dialogs on page 281.   

The settings in this dialog are also similar to those in the various Wall Defaults dialogs. The settings in these defaults 
dialogs determine the initial characteristics of railings, deck railings and fencing when they are first drawn. See Wall, 
Railing, and Fencing Defaults on page 229.         

The Wall Specification dialog has the following panels:

GENERAL PANEL

The settings on the GENERAL panel determine the basic use of the selected wall, as well as its length, angle, and other 
attributes.         

 
General

Specify General properties of the selected wall(s) or railing(s).             

 l Check Foundation Wall to specify the selected wall as a foundation wall. More foundation wall settings are 
available on the FOUNDATION panel. See Foundation Walls on page 236.         
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 l Check Railing to specify the selected wall as a railing. More railing settings are found on the RAILING, 
NEWELS/BALUSTERS, and RAILS panels. See Railing and Fencing Specification Dialogs on page 281.   

 l Check Terrain Retaining Wall to treat the selected wall as a terrain retaining wall. See Retaining Walls on page 
902.         

 l Check Attic Wall to prevent the selected wall from extending through the roof above. See Attic Walls on page 259.          

 l The Thickness of the selected wall displays and can be changed here. If the wall is a Post to Overhead Beam railing, 
this setting also affects the width of the beam. See Wall Thickness on page 252.   

 l Wall Angle - The current absolute angle of the wall in plan view is shown. If you type in a new angle, the wall 
rotates about its locked point and any walls attached to it will not move. If the selected wall is curved, this value 
describes the angle of the chord and cannot be modified. See 3D Drafting on page 12.   

 l Wall Length - The current length, as measured along the Resize About line, is shown. If you type a new length, the 
wall will extend or contract according to how it is locked. Any walls attached to the selected wall will not move. If 
the selected wall is curved, this value cannot be modified. See Resize About on page 255. 

 l Select a radio button to Lock the selected straight wall at its Start, End or Center. When the Wall Angle or Wall 
Length of the selected wall is changed, this point along the wall does not move. Not available for curved walls.         

  Options

 l Check Invisible to specify the wall as invisible. Invisible walls can display in plan view but not in 3D views or the 
Materials List. Room Dividers  are invisible by default. See Room Dividers and Invisible Walls on page 239. 

 l Check No Room Definition to display the wall in floor plan and/or 3D views but not create room definition. This 
box is checked and inactive when the selected wall is set to be a Furred Wall on the STRUCTURE panel. See Room 
Definition on page 287. 

 l Check No Locate to prevent Auto Exterior Dimensions  from locating the wall in plan view. See No Locate on 

page 251.

 l Check No Room Moldings Exterior to prevent any room moldings from generating along the Exterior side of the 
selected wall. See Room Moldings on page 308. 

 l Check No Room Moldings Interior to prevent any room moldings from generating along the Interior side of the 
selected wall. 

 l Automatically Generated Wall displays for reference and is checked whenever the selected wall was generated by 
the program. Typically, automatic walls are also Attic walls.

 l Check Ignored by Hide Exterior Walls to prevent the selected wall from being hidden in 3D views when the Hide 
Camera-Facing Exterior Walls option is in use. See Hide Camera-Facing Exterior Walls on page 817.

 
Curved Wall

The Curved Wall settings control the definition of a selected curved wall’s radius and are only available when the selected 
wall is curved.             

 l Select Outer Surface to measure the selected wall’s radius from its center point to its outer surface.             

 l Select Main Layer Outside to measure the radius from the wall’s center point to the outside of its Main Layer. See 
The Main Layer on page 262.             
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 l Select Main Layer Inside to measure the radius from the wall’s center point to the inside of its Main Layer.             

 l Select Inner Surface to measure the radius from the wall’s center point to its inner surface.             

 l Specify the selected wall’s Radius, as defined by the radio button selected above.         

 
Preview

A preview of the selected wall, including any doors or windows inserted into it, displays on the right. If the selected wall is 
specified as Invisible, its plan view will display here by default. See Dialog Preview Panes on page 21.     

STRUCTURE PANEL

The settings on the STRUCTURE panel control the height and other structural attributes of the selected wall(s).         

 
Default Wall Heights

The Default Wall Heights settings allow you to reset a wall’s default top and bottom heights if they have been manually 
edited. See Wall Heights on page 252.         

 l Default Wall Top Height and Default Wall Bottom Height are only enabled if the selected wall’s top and/or 
bottom height has been edited. Check these boxes to restore the default heights.         

 
Platform Intersections

These settings control the relationship between the selected wall and the Ceiling Platform above and the Floor Platform 
below it. They only take effect when the selected wall is positioned at a platform edge, such as at the exterior of a building 
or Open Below room. See Floor and Ceiling Platforms on page 303.     
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 l Check Generate Between Platforms to fill in the gap between floor and/or ceiling platforms when the selected 
railing or invisible wall separates rooms with different floor and/or ceiling heights. When unchecked, this gap is not 
closed. Only available for railings, Invisible railings, and Invisible walls, this setting has no effect when the selected 
wall type has only one layer.      

The Ceiling Platform settings control how the selected wall's top plates are generated.     

 l Select Automatic to set the wall's top plates under the ceiling above if there is a floor/ceiling platform above, or to 
balloon frame the wall if there is not a platform above.     

 l Select Stop at Ceiling Above to have the top of the wall top at the bottom of the ceiling platform above, as is 
typical in light frame construction.     

 l Select Balloon Through Ceiling Above to have the top of the wall go past the ceiling platform. If there is a framed 
wall directly above, the framing will continue upward to that wall's top plate. The two walls remain separate objects 
on different floors, however, unless the wall above is an Attic Wall. This setting does not affect interior walls.             

 l Select Hang Floor Platform Above on Wall to produce a platform that hangs on the inside of the selected wall 
rather than bearing on top of it. When checked, the two options that follow are available.             

 l Select Subflooring to Interior Wall to produce subflooring that builds to the inside surface of the wall. When 
unchecked, the subflooring builds over the top of the wall to the outside of its Main Layer. The wall's top height may be 
lowered to accommodate a sill plate. See Floor and Ceiling Platform Definitions on page 303 and The Main Layer on 
page 262.              

 l Select Include Ledger to hang the platform from a ledger board attached to the wall. When unchecked, no ledger is 
created when platform framing is generated. See Floor and Ceiling Platform Framing on page 627.              

The Floor Platform settings control how the selected wall's bottom plate is generated.       

 l Select Automatic to set the wall's bottom plate on top of the floor platform below, or to balloon frame the wall if 
there is not a platform below. If the wall is a Concrete type, the floor platform instead hangs on the inside the 
selected wall. See The Main Layer on page 262.

 l Select Stop at Floor Below to have the bottom of the wall stop at the top surface of the floor platform, as is typical 
in light frame construction.     

 l Select Balloon Through Floor Below to have the bottom of the wall go through the floor platform below. If the 
selected wall is framed and there is a framed wall directly below, the studs of the wall below will extend up produce 
balloon framing. If the wall below is set to Stop at Ceiling Above, the selected wall's bottom plates will rest on that 
wall's top plates. This setting does not affect interior walls.              

Note: Whether a wall is a framed or concrete type is determined by 
the material assigned to its Main Layer. See Wall Type Definitions 
Dialog on page 264.

 
Wall Intersection

The Wall Intersection settings control whether the selected wall builds through wall corners at its Start and End points. 
The display of Start and End Indicators can be turned on or off in the Preferences dialog. See Edit Panel on page 79.         

 l Select Through Wall at Start to build the wall through the wall corner located at its start point.         

 l Select Through Wall at End to build the wall through the wall corner located at its end point.         

 l When neither box is checked, the program will determine whether the wall builds through the corners at each of its 
endpoints.         
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Rim Joists

Specify the number of Rim Joists for the floor platform below the selected wall(s). See Framing on page 626.         

 l Select Single or Double to generate one or two rim joists, respectively.         

 l Select Automatic to generate two rim joists if there is no wall below the selected wall, and one rim joist when there 
is a wall below. Automatic produces a single rim joist for Deck Railing.              

  Stud Layout

 l Check Use Framing Reference to use a Framing Reference Marker as the starting point for the selected wall's 
stud layout. When unchecked, stud rollout begins at the wall's Start. See Framing Reference Markers on page 
651.    

 l Check Reverse Stud Rollout Direction to begin stud rollout at the selected wall's End instead of its Start. Only 
available when Use Framing Reference is unchecked. The display of Start and End Indicators can be turned on 
or off in the Preferences dialog. See Edit Panel on page 79

 l Specify the Stud Rollout Offset, which is the distance from the selected wall's Start or End that you want stud 
rollout to begin. Only available when Use Framing Reference is unchecked.    

  Framing

 l Check Retain Wall Framing to preserve the framing of the selected wall when the wall framing is globally 
rebuilt. See Keeping Framing Current on page 658.    

 l Check Stagger Multiple Framing Layers to produce wall studs that are offset from one another when wall 
framing is created. This setting only has an effect if a wall type with multiple Framing layers is specified. See 
Wall Type Definitions Dialog on page 264.    

 l When Insert Floor Framing Below is checked, extra floor joists will be generated under the selected wall for 
support if the wall in question is parallel with the joists below. Uncheck this box for joists generated at regular 
layout. Extra joists can be added manually if desired. See Floor and Ceiling Platform Framing on page 627.

 
Preview

A preview of the selected wall, including any doors or windows inserted into it, displays on the right. See Dialog 
Preview Panes on page 21.    

ROOF PANEL

Any automatically generated roof style other than a hip requires roof information to be defined in the exterior walls. On the 
ROOF panel, you can specify how the selected wall interacts with the roof plan, defining the portion of the roof plan that 
bears on it. See Automatic vs. Manual Roofs on page 574.
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Roof Options

Specify the shape of the wall relative to the roof.             

 l Select Hip Roof to create a roof plane that bears on top of the selected wall.

 l Select Full Gable Wall to create a gable end over the selected wall. 

 l Select Dutch Gable Wall to create a small gable part way up a hip roof. Use the Pitch Options below to specify the 
location of the gable.             

 l Select High Shed/Gable Wall to specify the selected wall as the high end of a shed roof.    

 l Select Knee Wall to define the selected interior wall as a knee wall. Only an interior wall can be defined as a knee 
wall. A knee wall’s height is defined by the roof above, not the ceiling height. See Knee Walls on page 260.    

 l Select Extend Slope Downward to continue a roof down over a bump-out in an exterior wall. See Extend Slope 
Downward on page 258.    

 l Check Roof Cuts Wall at Bottom to prevent the portion of a selected wall located below an intersecting roof plane 
from building.    

 l When Include Automatic End Truss Above is checked and there is an Attic wall above the selected wall, that Attic 
wall will receive a Reduced Gable End Truss when roof trusses are automatically generated. This box is checked 
automatically whenever a wall is specified as a Full Gable Wall. See Roof Trusses on page 664.
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 l Combine with Above Wall is only available when a selected wall has an Attic wall above it. Check this box to 
balloon frame the two walls when automatic framing is built. The two walls remain separate objects. See Attic Walls 
on page 259.         

 
Pitch Options

Specify the pitch or pitches of the roof plane(s) above the selected wall.             

 l Enter a value to define the Pitch of the roof plane bearing on the selected wall. 

 l Check Upper Pitch to create a roof with two pitches or, if the selected wall is a Full Gable Wall, a half hip 
condition.

 l Enter the Pitch of the second, upper roof.

 l Specify the Height that the Upper Pitch Starts at, or define the distance In from Baseline that the second pitch 
begins. The two values are dynamic. Press the Tab key to update the relative numbers. These settings are also used 
to position a Dutch Gable Wall.

 
Overhang Length

Specify the Overhang Length, which is the horizontal distance from the baseline to the eave. See The Baseline on page 
586.    

 
Auto Roof Return

    Check Auto Roof Return to generate roof returns on the selected wall. In most cases, roof returns only work for Full 
Gable Walls. See Roof Returns on page 623.             

 l Specify the horizontal Length of the roof return in inches (mm).             

 l Enter a value in inches (mm) to Extend the roof returns past the overhang.             

 l Specify a Gable, Hip, or Full roof return.             

 l Specify a Sloping or Flat roof return.                 

 l Check the box to Include Gutters on the roof returns.             

 
Lower Wall Type if Split by Butting Roof

Check Lower Wall Type if Split by Butting Roof to specify the wall type for any portion of the selected wall located 
beneath an adjacent, abutting roof plane, should one be present. A wall affected by this setting is specified as a Pony Wall 
and the upper wall is defined on the WALL TYPES panel. See Exterior/Interior Pony Walls on page 259.         

 
Treat As Part Of Bay/Bow/Bow Window

These options correspond to the Roof options in the Bay/Bow/Bow Window Specification dialog and should only be used 
by groups of three or more walls that form a bay or bow shaped bump-out. See Bay, Box, Bow Windows and Roofs on page 
437.    

 l Check Treat As Part Of Bay/Box/Bow Window to create a hip roof with California ridge over the bump-out 
formed by the selected walls when the roof is rebuilt.

 l Check Use Existing Roof to ignore the bump-out formed by the selected walls when the roof is rebuilt.     

 l Check Extend Existing Roof Over to extend the eave of the main roof plane to cover the bump-out created by the 
selected walls and follow its footprint.    
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 l Check Rectangular Roof Over to create a rectangular hip roof over the bump-out formed by the selected walls 
instead of one that follows its footprint. 

 
Preview

             A preview of the selected wall, including any doors or windows inserted into it, displays on the right. See Dialog Preview 
Panes on page 21.   

FOUNDATION PANEL

 
Foundation

Specify the Foundation properties of the selected wall(s).         

 l Check Foundation Wall to specify the selected wall as a foundation wall and enable additional settings on this 
panel. This box is checked by default for automatically generated foundation walls as well as walls drawn with the 
Foundation Wall tool .         

Note: Rooms defined by walls drawn using the Slab Footing tool 
will have a Ceiling Height of 0 and a Monolithic Slab Foundation. 
Rooms defined by walls that are later specified as Slab Footings 
will not unless the room is on Floor 0 and the plan has a 
Monolithic Slab foundation specified.

 l The Wall Thickness of the selected wall displays and can be changed here.         

 
Footing

Check Footing to assign a concrete footing to the selected wall(s) and enable the settings below. Only available when 
Foundation Wall is checked, above.         
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 l Specify the Width and Height of the footing below the selected foundation wall(s). The Height value will be 
unavailable if the bottom height of the footing has been edited. See Stepped Foundations on page 508.         

 l Check Automatic Footing Bottom Height to restore the default height of the selected wall’s footing. Only 
available when the footing bottom height has been edited.         

 l Check Vertical Footing to generate footings that run up and down along any steps in the foundation wall’s bottom 
height.         

 
Slab

Specify how  footings generate in the presence of Monolithic and regular slabs. See Foundations on page 496.             

 l Check Add Chamfer on Monolithic Slab to add a chamfer to the selected wall's footing when the wall defines a 
Monolithic slab. See Automatic Foundation Types on page 497.

 l Check Add Chamfer on Regular Slab to add a chamfer to the selected wall's footing when the wall defines a slab 
floor that is not Monolithic.

 l Specify the Chamfer Width and Height, which define the angled corners where the footing meets the underside of 
the slab.         

 
Sill Plate

Check Sill Plate to reserve space for one or more sill plates, or mud sills between the selected foundation stem wall or grade 
beam and the floor platform or framed wall that bears on it. Sill plates are generated when the floor framing is generated. 
See Framing Defaults on page 627.             

 l Specify the Width and Height of the treated sill plates. If the Height is set to zero, no sill plates are produced. Not 
available if Monolithic Slab is the selected Foundation Type.    

 l Specify the Max Length, then specify the maximum allowable length for sill plate boards generated over the 
selected wall. When unchecked, sill plates run the full length of the wall, regardless of length.    

 l Specify the Count, which is the number of sill plates stacked vertically on each stem wall or grade beam.             

 
Preview

     A preview of the selected wall, including any doors or windows                           inserted into it, displays on the right. See Dialog Preview 
Panes on page 21.         
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WALL TYPES PANEL

 
General

Specify the selected wall's primary wall type.             

 l Choose the selected wall’s Wall Type from the drop-down list of all currently available types.

 l Click the Define button to open the Wall Type Definitions dialog to create or modify existing wall types. See Wall 
Type Definitions Dialog on page 264.

 l A preview of the selected wall type as seen in plan view displays below the drop-down list.         

  Pony Wall

 l Check Pony Wall to specify the selected wall as a pony wall having different wall types on its upper and lower 
portions. If the selected wall is a Foundation Wall, its initial wall type will become the Lower Wall Type. For all 
other walls, the initial wall type will be the upper Wall Type. See Pony Walls on page 238. 

 l Select the Lower Wall Type, the wall type of the lower portion of the pony wall, from the drop-down list. A 
preview of the selected wall type displays directly below.

 l Click the Define button to open the Wall Type Definitions dialog.
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 l Specify the height of the division between the upper and lower walls. These two settings are dynamic: if one is 
changed, the other will update accordingly.

 o Specify the Elevation of Lower Wall Top, which is the division between the upper and lower walls. If the top of 
the lower pony wall is stepped or raked, this value will be “No Change”. This is an absolute value: regardless of the 
wall’s location, it is always measured from 0” (mm) - the default floor height for Floor 1. See Floor Level Defaults 
Dialogs on page 518 and Stepped and Raked Walls on page 260.

 o Specify the Height Off Floor of the division between the upper and lower walls. This value is measured from the 
floor height of the room(s) defined by the selected wall. If the wall defines rooms with different floor heights, “No 
change” will display.

 l Align Pony Walls at - Specify how the layers of the selected wall’s Upper and Lower portions align.                 

 o Select Outer Surface to align wall types at their outer surfaces.

 o Select Main Layer Outside to align wall types at the exterior edge of their main layers.

 o Select Wall Center to align the centers of the main layers of both wall types.

 o Select Main Layer Inside to align the wall types at the interior side of their main layers.

 o Select Inner Surface to align wall types at their interior surfaces.

 o No Change is used by default when multiple pony walls with different alignment settings are selected. Choose this 
to leave the alignment as it was when the dialog was opened.

 
Display in Plan View

Specify which part of the pony wall you would like to display. In the Pony Wall Defaults dialog, this option can be set 
differently in each plan view but are disabled if the current view is not a plan view or if multiple defaults are being edited. 
See Displaying Pony Walls on page 238.                 

 l Select Use Default to display the portion of the pony wall specified in the Pony Wall Defaults dialog in the current 
plan view. The portion set as the Default is stated in parentheses for reference. Not available in the Pony Wall 
Defaults dialog.

Note: The default Display in Plan View settings can be set differently 
for each plan view and become permanent parts of views sent to 
layout. See Plan Views on page 104 and Keeping Layout Views 
Current on page 975.

 l Select Upper Wall to display the upper portion of the selected pony wall.     

 l Select Lower Wall to display the lower portion of the selected pony wall.     

 l Select Upper Wall and Lower Wall Outline to display the selected pony wall's upper wall along with the edge 
lines of the lower wall.     

 l Select Upper Wall Outline and Lower Wall to display the selected pony wall's lower wall along with the edge 
lines of the upper wall.     

 l Select Upper Wall and Lower Wall to display both the upper and lower portions of the selected pony wall.     

 l When walls are group-selected, choose No Change to allow each wall in the selection set to maintain its own 
setting.     

 
Display of Openings in Non-Displayed Parts of Walls

In the Pony Wall Defaults dialog only, specify how doors and windows display in plan view when they are located entirely 
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in the part of a pony wall that is not visible.                 

 l Select Outline to display the lines associated with openings but draw the wall layers’ lines and fill through them.     

 l Select Always to display doors and windows the same regardless of where they are located: drawing their outlines 
and preventing wall layers from drawing through them.     

 l Select Hide to not draw door and window outlines at all, so they cannot be seen.

 
Preview

A preview of the selected wall, including any doors or windows              inserted into it, displays on the right. See Dialog Preview 
Panes on page 21.

WALL COVERING PANEL

The WALL COVERING panel is also available in the Room Specification dialog. See Room Specification Dialog on page 308.
         

 
Materials

All wall covering materials applied to the selected wall are listed here. Select one from the drop-down list to edit its position 
or remove it from the wall.         

 l Click Add New to apply a new wall covering to the selected wall. See Select Library Object Dialog on page 716.         

 l Click Replace to replace the current wall covering with a new one from the library.         

 l Click Delete to remove the current wall covering from the selected wall.         
Preview panes showing the current wall covering display the row of buttons.         

 
Position

Specify the Position of the selected wall covering.         
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 l Enter the heights of the current wall covering’s Top To Ceiling and Floor To Bottom. The wall covering’s 
Height from its top edge to its bottom edge can also be specified.         

 l Check Interior and/or Exterior to apply the wall covering to the inside and/or outside of the selected wall. Interior 
is checked by default. Not available for rooms. See Wall Type Definitions on page 262.         

 
Options

Check No Room Wall Coverings to prevent any wall coverings assigned to rooms from generating on the selected wall.         

 
Preview

Most wall coverings are best previewed  using the Standard Rendering Technique. See Dialog Preview Panes on page 21.          

RAIL STYLE PANEL

The settings on the RAIL STYLE panel are  only available for Railings, Half Walls, Deck Railings, and Fencing. See Rail 
Style Panel on page 281.   

NEWELS/BALUSTERS PANEL

The settings on the NEWELS/BALUSTERS panel are only available for Railings, Half Walls, Deck Railings, and Fencing. See 
Newels/Balusters Panel on page 283.

RAILS PANEL

The settings on the RAILS panel are used to specify the style and size of the horizontal components of a selected Railing, 
Deck Railing, or Fence. See Railing and Deck Tools on page 233.

A similar panel is also found in the Staircase and Ramp Specification dialogs and has additional settings for handrails at 
walls. See Rails Panel on page 566.

The settings on this panel are like those on the MOLDINGS panel found in a variety of dialogs in the program. See Moldings /  
Rails Panels on page 688. 

MATERIALS PANEL

All walls - including interior walls, railings and fencing - have an “Exterior Wall Surface” and an “Interior Wall Surface”. 
See Interior and Exterior Surfaces on page 263. 

The materials specified on the MATERIALS panel affect the appearance of walls and Solid Railings in 3D views but are not 
calculated in the Materials List. See Materials Lists on page 950. 

For most railing types, the “Exterior Wall Surface” component only affects the appearance of the floor platform under the 
railing and the “Interior Wall Surface” component is not used. For fencing, neither material component is used. 

LABEL PANEL

Wall labels display in plan view              when the “Walls, Labels” layer is turned on and use the Text Style assigned to that layer. 
See Wall Labels on page 247.

For information about the settings on this panel, see              Label Panel on page 376.
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COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 967.         

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in the materials list. For more information, see 
Object Information Panel on page 968.   

 

Railing and Fencing Specification Dialogs
To open the Railing or Fencing Specification dialog, select a railing or fencing, or a group of railings or fencing, and 
click the Open Object edit button. 

The Railing and Fencing Specification dialogs are the same as the Wall Specification dialog, but have three panels that 
apply only to Railings, Half Walls, Deck Railings, and Fencing. See Wall Specification Dialog on page 268. 

The RAILS panel is similar to the HANDRAIL panel found in the Staircase and Ramp Specification dialogs. See Stairs, 
Ramps, and Landings on page 527.          

RAIL STYLE PANEL

 
Specify Railing

Check Specify Railing to specify the selected wall as a railing and enable the other options on this panel. Railings drawn 
using the Railing  or Deck Railing  tools have this checked by default.
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 l Select the radio button for the desired Railing Type:

 o Select Balusters to create regularly spaced balusters between larger newel posts. 

 o Select Solid to create a solid railing or Half Wall. Not available if the selected railing is also a Pony Wall. See Pony 
Walls on page 238. 

 o Select Open to create a railing with only newel posts and top and bottom rails.

 o Select Open with Middle Rail to create a railing with newel posts and top, bottom, and middle rails.

 o Select Panels to create a railing composed of panels, then click the Library button to select a panel style from the 
Library Browser. See Select Library Object Dialog on page 716. You can specify the panel style on the 
NEWELS/BALUSTERS panel. See Newels/Balusters Panel on page 283.

 l Specify a Horizontal Offset, which allows you to place the railings either inside or outside their default location. A 
positive value offsets the railings in the direction of their interior surface, while a negative value offsets them 
outward. Room definition is not affected by this offset so you can offset a railing relative to the floor platform edge 
it defines.

 
Newels/Posts

 

 l Check Newels/Posts to assign these to the selected railing, then specify their properties:

 o Select Post to Rail to create newel posts from the floor to the top rail. This option is selected by default.

 o Select Post to Beam to create newel posts from floor to a beam placed just under the ceiling height. The beam’s 
width is based on the Thickness of the selected railing wall.

 o Select Post to Ceiling to extend the newel posts to the ceiling.

 o Select Rail to Post to produce newel posts of the Height specified on the NEWELS/BALUSTERS panel, with rails 
that build to the sides of the newels. 

 
Start/End Posts

If either the Start or End of the selected railing is connected to another railing, the settings associated with that end will not 
be available. These options are not available at all when Newels/Posts is unchecked above.    

 l Select the Type of post at the railing’s Start and End points: “Full Post”, “Half Post”, or “None.” The “Auto Post” 
options place either a Half post or None if the railing intersects a wall and a Full post otherwise: the currently 
applicable Type is indicated in parentheses. A Full Post is always placed where railings meet at a corner. 

 l Specify the Start and End Wall Offsets, which are the distances between the railing’s half posts and the intersecting 
wall.             

 l Check Uniform Offsets to apply the same offset to both ends of the railing.             

 l Check Square Half Post to use a square half post where the railing intersects a wall instead of the post Type 
specified on the NEWELS/BALUSTERS panel. This only applies when a railing end is set to have a Half Post.             

 
Top/Bottom Rail

These options control the placement of the top and bottom rail, or shoe. 
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 l Uncheck Include Top Rail to eliminate the top rail.

 l Uncheck Include Bottom Rail to eliminate the bottom rail and extend the balusters to the floor. Not available for 
Solid railings.

 l Check Raise/Lower Bottom, then specify the Floor to Bottom distance, measured up from the floor platform to 
the bottom rail or panel. A negative value positions the bottom rail or panel below the floor.

 
Build From

Specify where the selected railing or fencing should Build From. With the exception of Follow Stairs, these settings are not 
available for Solid railings.             

 l Check Step Terrain to have the railing or fencing follow the terrain in horizontal steps between each newel post. 
Not available if the selected railing is a Pony Wall.          

 l Check Follow Terrain to have the railing or fencing follow the terrain smoothly. Not available if the selected railing 
is a Solid or a Pony Wall.          

 l Check Generate on Low Platform to build the selected railing on the lower floor platform when the railing defines 
two room areas with different floor heights. See Aligning Railings on Different Platforms on page 257.          

 l Check Follow Stairs to have the railing or fencing follow the rise of stairs drawn in the same location. See Inset or 
Middle Railing on page 551 for more information.         

 
Preview

A preview of the selected railing or fence, including any doorways or gates inserted into it, displays on the right. See Dialog 
Preview Panes on page 21. 

NEWELS/BALUSTERS PANEL

 
Railing

Specify the height of the railing.              
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 l For interior railings, the Railing Height is measured from the height of the floor finish.              See Floor and Ceiling 
Platform Definitions on page 303. 

 
Newels/Posts

Specify the characteristics of the selected railing’s newel posts.    

 l Specify the Width of each newel at its widest point.           

 l Check Use Wall Width to assign the width of the wall type assigned to the selected railing to its newels.          

 l Specify the Height, which is the height from the floor or ground to the top of the newel. Not available if Post to 
Rail, Post to Overhead Beam or Post to Ceiling is selected on the RAIL STYLE panel. See Rail Style Panel on page 
281.    

 l Specify the Horizontal Offset, which is the amount each newel is offset from the center of the railing. You can, for 
example, use this setting to create a fence with the posts on one side of the fence boards.

 o A positive value offsets the newels towards the interior; a negative value, towards the exterior.

 o When this value is negative and Full Post is selected Start and/or End Type, a newel is created on each side of an 
exterior corner rather than one centered on the corner. See Rail Style Panel on page 281, above.

 l Specify the Bottom Offset, which is the amount each newel is raised or lowered. When this value is 0, the newels' 
bottom edges are positioned on the surface of the floor finish.         

 l Specify the Spacing method that determines the distance between the selected railing's newel posts.

 o Select "Automatic" from the drop-down list to evenly space all newels as close to the interval specified below as 
possible, depending on the length of the selected railing.

 o Select "From Start" to place newels at the interval specified below beginning at the railing's Start end. The interval 
between the End newel and the one adjacent to it will vary, depending on the length of the selected railing. See 
Selected Edge on page 143.

 o Select "From End" to place newels at the interval specified below beginning at the railing's End. The interval 
between the newel at the Start end and the one adjacent to it will vary, depending on the length of the selected 
railing.

 o Select "Centered" to place two newels at the interval specified below, then center them on the midpoint. Additional 
newels are laid out from there; however, the interval between the newels at the Start and End points and adjacent 
newels will vary, depending on the length of the railing. It is also possible that layout may originate from a single 
newel at the railing's midpoint: again, depending on railing length and spacing. 

 l Specify the on-center Max. Spacing interval. The actual spacing of newels may vary from this value, depending on 
the spacing method selected above and the length of the selected railing.

 l Type - Select Square, Round, or Library newels. Selecting Library from the drop-down list is the same as clicking 
the Library button to the immediate right and allows you to select a symbol from the library. See Select Library 
Object Dialog on page 716.        

 
Balusters

These settings are only available when the railing type is “Balusters” on the RAIL STYLE panel.         

 l Specify the Width or diameter of each baluster at its widest point.          

 l Specify the on-center Spacing of the balusters.         
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 l Type - Select Square, Round, or Library balusters.          

 
Panels

These settings are only available when the railing type is specified as Panels on the RAIL STYLE panel. 

 l Specify the panel’s Thickness.         

 l Select “Solid” or “Library” from the Panel Type drop-down list.          

You can also apply newels, balusters, and panels onto a railing 
directly from the Library Browser. See Inserted Objects on 

page 715. 

 
Preview

 A preview of the selected railing or fence, including any doorways or gates inserted into it, displays on the right. See 
Dialog Preview Panes on page 21.          

RAILS PANEL

The settings on the RAILS panel are used to specify the style and size of the horizontal components of a selected Railing, 
Deck Railing, or Fence. See Railing and Deck Tools on page 233.         

A similar panel is also found in the Staircase and Ramp Specification dialogs and has additional settings for handrails at 
walls. See Rails Panel on page 566.         

The settings on this panel are like those on the MOLDINGS panel found in a variety of dialogs in the program. See Moldings /  
Rails Panels on page 688.         

 

Wall Hatching Specification Dialog
To open the Wall Hatching Specification dialog, select a Wall Hatching and click the Open Object edit button. The 
settings in this dialog are also found in the Wall Hatching Defaults dialog. See Wall Hatching on page 240.

FILL STYLE PANEL

The FILL STYLE panel is found in the specification dialogs for many different objects. See Fill Style Panel and Dialogs on 
page 132.   

LABEL PANEL

Wall Hatching labels display in plan view when the "Walls, Labels" layer is turned on and use the Text Style assigned to 
that layer. The Automatic Label for wall hatching is blank, but you can specify a custom label. For information about the 
settings on this panel, see Label Panel on page 376.   
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Chapter 12
 

Rooms

Rooms are created when walls are drawn to enclose an area. When a room is defined in this way, it automatically receives 
both a floor and ceiling as well as features like moldings and finish materials that can be seen in 3D Views.  

Rooms can be selected and edited. Each room can be assigned a Room Type with predefined characteristics. For example, a 
room defined as a Deck is assigned certain attributes that are different from a Kitchen. 

TOPICS

Room Definition 287
Floor and Room Defaults 287
Room Types 289
Displaying Rooms 291
Selecting Rooms 291
Editing Rooms 293
Room Labels 295
Room Label Specification Dialog 297
Decks 299
Floor and Ceiling Heights 301
Floor and Ceiling Platforms 303
Special Ceilings 305
Room Moldings 308
Room Specification Dialog 308
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Room Definition
A room is a totally enclosed area defined by any combination of joined walls or railings, visible or invisible. To be 
recognized as a room by Home Designer, a room must have an unbroken perimeter.

Unless otherwise specified, rooms generate floor and ceiling platforms automatically. Most rooms are also automatically 
covered by the roof when one is built. There are exceptions to this, such as rooms defined as Decks. See Room Types on 
page 289. 

Room definition disappears if part or all of a surrounding wall is deleted. It is a good idea to finalize the position of walls 
before specifying Room Types or defining room attributes such as floor or ceiling height.

SUBDIVIDING ROOMS

When a room area is first defined, it inherits its characteristics from the Floor Defaults dialog for that floor. If the room is 
then specified as a particular type, it may inherit properties from the Room Defaults dialog associated with its type. See 
Floor and Room Defaults on page 287.         

If a new room is created by subdividing a larger room, it inherits its characteristics from that larger room - including any 
non-default settings.          

If two rooms are separated by an Invisible wall, their interior areas will be measured from the wall’s centerline and 
characteristics like the floor finish materials and moldings will break along that line.          

 l If the two rooms have different floor heights, the break will occur at the wall edge that faces the room where the floor 
is lower.          

 l If the two rooms have different ceiling heights, the break will occur at the wall edge that faces the room where the 
ceiling is higher.          

COPYING AND PASTING ROOMS

A room can be copied into the same or a different plan by copying and pasting the walls that define it. Rooms copied in this 
manner retain their size and shape, as well as any finish materials assigned to the walls. See Copying and Pasting Objects 
on page 118. 

If you want to retain the room’s Type and other specifications, copy and paste it and the walls that define it using the Edit 
Area  tools. See Edit Area Tools on page 186.

 

Floor and Room Defaults
Select Edit> Default Settings to open the Default Settings dialog, then click the arrow to the left of “Floors and 
Rooms” to expand the category.  Here, you can access several defaults dialogs which directly affect rooms. Select a 

line item and click the Edit button to open the defaults dialog associated with it.

FLOOR LEVEL DEFAULTS

Many important default values that affect rooms are specified in the Floor Level Defaults dialog for each floor level in a 
plan. This dialog controls important information that the program uses to create a 3D model - particularly floor and ceiling 
heights and materials. Moldings can also be specified in the Floor Level Defaults dialogs.          
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Only the defaults for Floor 1 can be set ahead of time. The program uses the settings from Floor 1 to create subsequent 
floors. Once a new floor is created, its floor defaults can be changed. See Floor Level Defaults Dialogs on page 518.         

The Floor Level Defaults dialog for the current floor can also be opened by clicking the Floor Defaults button, which 
can be added to the toolbars. See Adding and Removing Buttons on page 93.         

FLOOR 1 DEFAULT HEIGHT

Home Designer always defines the default height of Floor 1 at 0’-0”. This height value is measured from the top of the 
subfloor and is the constant by which the heights of structural elements in the program like walls, floors, and ceilings are 
measured. The heights of architectural objects can be measured relative to this absolute height, as well. As such, this default 
cannot be changed. 

FLOOR AND CEILING PLATFORMS

Floor and Ceiling Structure and Finish definitions assigned to rooms affect structural heights as well as the appearance of 
rooms and have a hierarchy of dynamic defaults. See Floor and Ceiling Platforms on page 303.          

ROOM TYPE DEFAULTS

The Room Types dialog can also be opened by clicking the Room Types button, which can be added to the toolbars.          

Select an Available Room Type from the list, then:         

 l Click the Edit button to modify the selected Room Type in the Room Type Defaults dialog.         
 l Click the Rename button to specify a new Name for the selected Room Type.         

The settings in the Room Type Defaults dialogs allow you to specify the following for each Room Type:          

 l The Name, as used in its default Room Label              
 l Inclusion in the Living Area. See Living Area on page 296.          
 l Ceiling Structure and Finish. See Floor and Ceiling Platforms on page 303.         
 l Floor Structure and Finish.           
 l Framing and Supports for Deck rooms. See Decks on page 299.          
 l Moldings. See Room Moldings on page 308.          
 l Components information for use in the Materials List. See Components Panel on page 967.          

These settings are also found in the Room Specification dialog. See General Panel on page 308, Structure Panel on page 
310, Deck Panel on page 315, and Deck Support Panel on page 316.          
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ROOM LABEL DEFAULTS

The Room Label Defaults dialog allows you to specify the initial appearance of room labels. This dialog is also accessed by 
expanding the “Rooms” category in the Default Settings dialog. See Room Labels on page 295.           

The options on most panels of the Room Label Defaults dialog are similar to those in the Text Specification dialog.              

Any text added to the Room Label Defaults dialog displays in all subsequently created room labels, after the Room Name. 
Changes made to default settings do not alter existing room labels. To update existing labels so that they reflect changes 
made to the defaults, delete and replace them. See Editing Room Labels on page 296.          

 

Room Types
Room Types are used to quickly apply useful structural, functional, and appearance properties to different kinds of rooms. 
For example, a room assigned the “Garage” Room Type will receive concrete curbs under its walls when the Foundation is 
built, while a “Kitchen” will get GFCI Outlets when the Auto Place Outlet tool is used. 

When a room is first created by enclosing an area with walls, it is assigned a generic room type of “Unspecified.” Once a 
room is created, though, it can be assigned a Room Type in the Room Specification dialog. See General Panel on page 
308. 

A selection of pre-defined Room Types is available for use. See Room Type Defaults on page 288.         

ROOM TYPE DEFAULTS

Each Room Type is composed of two sets of characteristics: those set by the program, and those that are directly editable.         

Characteristics set by the program are grouped together based on typical requirements for different types of rooms. These 
non-editable sets of properties is referred to as Room Functions.         

Characteristics of a Room Type that can be modified include the default room Name, whether it is included in the Living 
Area, and the floor structure, finish, and deck supports. See Room Type Defaults on page 288. 

When you specify that a room be a certain Room Type, all of the characteristics associated with that Room Type are 
assigned to the room, overriding existing settings. After you specify a Room Type, though, various settings can be 
customized.           

ROOM TYPES

There are three broad categories of room Types: Interior, Exterior and Hybrid.

 l Interior - Most room Types are Interior.
 l Exterior - Balcony, Court, Deck.
 l Hybrid - Attic, Garage, Open Below, Porch, Slab.

EFFECTS OF ROOM TYPES

Home Designer applies specific properties to rooms depending on the assigned Room Type.    
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Living and Conditioned Areas
 l All interior type rooms are included in Living Area calculations by default; exterior and hybrid type rooms are not.         
 l All interior type rooms are included in Conditioned Area calculations by default. Open Below rooms are also included; 

however, exterior and other hybrid type rooms are not.

Ceilings and Roofs
 l Interior rooms have a flat ceiling and are set to generate a roof above them.
 l Exterior rooms are assumed to be open to the outside and do not have a flat ceiling or generate a roof above them.
 l Attic rooms do not receive a ceiling and are ignored by the program’s automatic roof generator.
 l Garage, Slabs, and Porches are treated like exterior rooms in all cases except that they generate a ceiling and a roof 

above them by default.

Floors and Foundations
 l A room’s default floor structure and finish definitions are determined by its Room Type. See Room Type Defaults on 

page 288.
 l Open Below rooms have no floor platform and influence how adjacent walls are framed. Stairwells and Crawl Spaces 

are created using the Open Below Room Type. 
 l Garages have a foundation under them as defined by the Foundation Defaults dialog with a concrete slab at the top of 

stem wall or grade beam.
 l The floor in Garage and Slab rooms display in 3D on Floor 0, not the first floor. See Garages on page 506.
 l Defining a room as Slab causes the floor platform thickness to equal the slab thickness value in the Foundation 

Defaults dialog.         
 l Deck rooms do not generate foundations. See Decks on page 299.

Doors and Windows
 l A window placed in a wall between an exterior room and an interior room always faces out toward the exterior. 
 l Doors placed between interior and exterior type rooms inherit their settings from the Exterior Defaults for the door 

tool, if hinged or sliding; they display threshold lines and are considered Exterior. See Interior vs Exterior Doors on 
page 379.

 l Doors placed between interior type rooms do not display thresholds and are considered Interior. 
 l Open Below rooms are treated as interior rooms for window and door placement. All other hybrid type rooms are 

treated as interior.     

Electrical

 l An electrical object placed on the wall of an exterior room using the Light , Switch , 110V Outlet  or 220V 

Outlet  tool will automatically be a waterproof or outdoor type fixture, as specified in the Electrical Defaults 

dialog. See Electrical Defaults on page 485. 
 l The Auto Place Outlets  tool adds outlets automatically to all interior rooms. See Auto Place Outlets on page 489.             

 l Auto Place Outlets  places GFCI outlets over base cabinets in Kitchens and Baths. Kitchens also receive standard 

height outlets while Baths do not.
 l Auto Place Outlets  places fewer outlets in hybrid type rooms.             

 l Auto Place Outlets  does not place outlets in exterior type rooms, Porches or Open Below rooms.             
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Plan Check

 l Plan Check  uses Room Types and their characteristics for basic plan checking. For example, a closet does not 

need a smoke detector but a bedroom does. See Plan Check on page 53.             

 

Displaying Rooms
Unlike most things in Home Designer, a room is not an individual object. Rather, a room is a space defined by the walls that 
enclose it.

IN PLAN VIEWS

Rooms typically display a transparent fill in plan view. You can, however, specify a solid color or fill pattern for all the 
rooms on an entire floor in the Floor Defaults dialog, or for individual rooms in the Room Specification dialog. See Fill 
Style Panel on page 319.

In order for room fill styles to display, the “Rooms” layer must be turned on. See Layer Attributes on page 125. 

Room labels that include the room’s name as well as its size and other information can be set to display in plan view. See 
Room Labels on page 295. 

IN 3D VIEWS

Rooms can be viewed in views created by any of the 3D view tools. The              Dollhouse View tool             s can be used to see all 
rooms on the current floor without their ceilings. See Creating Overviews on page 777.         

IN THE MATERIALS LIST

The contents of a room, including furnishings and floor and ceiling materials can be calculated using the Calculate in 
Room tool. See Calculate Materials in Room on page 951.         

The Calculate Materials From Selection edit tool creates a Materials List that calculates the finish materials in a selected 
room or rooms. Room moldings and wall, floor, and ceiling finish materials are counted, as is subflooring; but doors, 
windows, and structural materials like framing and other structural materials are not.           

 

Selecting Rooms
Room definition is established when a room is completely enclosed by walls. You can confirm that a room has room 
definition by using the Select Objects  tool to select it. When a fully-enclosed room is selected, its interior space 

becomes highlighted. See Selecting Objects on page 142. 

Rooms can be group-selected using the Shift or Ctrl/⌘  key. They can also be marquee-selected using the Marquee Select 
Similar  edit tool. To select rooms of a particular type, us the Restrictive Selection  option. See Selecting Multiple 

Objects on page 145.

Although rooms may be visible, if the “Rooms” layer is locked in the               current view, it will not be possible to select a room. 
See Locking Layers on page 126. 
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Note: The selection color can be specified in the Preferences dialog. See 
Colors Panel on page 65.

THE EXTERIOR ROOM

Each floor level of a plan has an Exterior Room, which allows you to control its exterior wall coverings and materials in the 
Exterior Room Specification dialog. See Room Specification Dialog on page 308.

To select the Exterior Room in plan view, click just outside an exterior wall using the Select Objects  tool. If a wall or 

other object becomes selected instead, click the Select Next Object  edit button or press the Tab key until the Exterior 

Room becomes selected. The Status Bar indicates which object is currently selected. See The Status Bar on page 24. 

When it is selected, a highlighted band around the plan’s exterior displays. 

IN 3D VIEWS

A room can be selected in a 3D view by clicking on an empty space on its floor or a wall surface while the Select Objects 
 tool is active. 

If you select a wall or other object instead of the room, click Select Next Object  edit button or press the Tab key until 

the room becomes selected. 

In exterior camera views and overviews, the Exterior Room for each floor can be selected by clicking on the exterior surface 
of an exterior wall using the Select Objects  tool and then clicking the Select Next Object  edit button. 

SELECT ROOM BEFORE WALL IN 3D

By default, when you click on a wall surface in a 3D view, the individual wall will become selected. If you prefer to always 
select the room first instead of the wall, check  Select Room Before Wall in 3D in the Preferences dialog. See Architectural 
Panel on page 77.          
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Editing Rooms
A room’s structure and appearance can be modified using its edit tools and specification dialog. Rooms can be selected in 
all views, and the ways in which they can be edited depend somewhat on the current view. See Selecting Rooms on page 
291. 

IN 3D VIEWS

The top and bottom heights of individual walls, the floor and ceiling heights of individual rooms, and the floor and ceiling 
heights for and entire floor levels can be edited using edit handles in 3D views. Lowered ceilings cannot be edited in 3D. 
See 3D Views on page 770. See The Exterior Room on page 292.

The default floor and ceiling heights for an entire floor level can be edited by selecting the Exterior Room. See The Exterior 
Room on page 292 and Floor and Room Defaults on page 287.

To change default ceiling heights in 3D

 1.  Create a 3D or cross section/elevation view of the exterior of your plan. 

 2.  Click on the exterior surface of a wall, then click the Select Next Object  edit button.

 3.  When the Exterior Room is selected in 3D:

 l The wall that you clicked on remains highlighted and an edit handle displays along its top edge.

 l When the wall is on any floor other than Floor 1, an edit handle also displays along its bottom edge.

 l A bounding box displays around each wall of the selected floor level. 

 l The Status Bar says “Exterior Room”. See The Status Bar on page 24.

 l A temporary dimension will display, measuring from the floor’s default rough floor to default rough ceiling. See 
Temporary Dimensions on page 333.

 4.  Click and drag the edit handle on the top wall edge to adjust the default ceiling height, or the edit handle on the 
bottom edge to adjust the default floor height. 

 5.  As you drag a handle, notice that the entire floor level is affected.         

 l The wall that you clicked on remains highlighted and an edit handle displays along its top edge.

 l When the wall is on any floor other than Floor 1, an edit handle also displays along its bottom edge.

 l A bounding box displays around each wall of the selected floor level. 

 l The Status Bar says “Exterior Room”. See The Status Bar on page 24.

 l A temporary dimension will display, measuring from the floor’s default rough floor to default rough ceiling. 
See Temporary Dimensions on page 333.

 6.  Click and drag the edit handle on the top wall edge to adjust the default ceiling height, or the edit handle on the 
bottom edge to adjust the default floor height. 
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Note: Any rooms that do not update when the default floor or ceiling 
height is changed are not using the default values. To use the default 
values for a specific room, check Default for any of the room height 
values in its specification dialog. See General Panel on page 308.

To adjust room heights in 3D

 1.  Create a 3D or Cross Section/Elevation view of your plan.

 2.  Click on the surface of a wall that faces a room to select it, then click the Select Next Object  edit button. 

 3.  When a room is selected in 3D:

 l The wall that you clicked on remains highlighted and an edit handle displays along its top and bottom edges.

 l The Status Bar says “Room”. 

 l A temporary dimension will display in cross section/elevation views, and measure from the room’s rough floor to 
rough ceiling. 

 4.  Click and drag the edit handle on the top wall edge to adjust the room ceiling height, or the handle on the bottom 
edge to adjust its floor height. Temporary dimensions display.

 5.  As you drag a handle, notice that all walls defining that room are affected.

To adjust the height of a wall in 3D

 1.  Create a 3D or cross section/elevation view of your plan.           

 2.  Click on a surface of the wall to select it.          

 3.  Click and drag the edit handles along its top and bottom surfaces. See Wall Heights on page 252.          

Room materials such as floor, ceiling, and wall materials can be changed in 3D views using the Material Painter . See 

Material Painter Tools on page 747.

Room moldings can be replaced directly from the library in 3D views, as well. See    Replace From Library on page 717.

IN THE SPECIFICATION DIALOG

Floor and ceiling heights, moldings, wall coverings, and materials can all be specified in the Room Specification 
dialog. See Room Specification Dialog on page 308.

USING THE EDIT TOOLS

A variety of options are available on the Edit Toolbar for a selected room. See The Edit Toolbar on page 92.         

  Calculate Materials for Room creates a materials list of the contents of the selected room, not including walls. 
See Calculate Materials in Room on page 951.          

  Turn Ceiling Off removes the flat ceiling from the selected room while Turn Ceiling On restores it. See     
Vaulted and Cathedral Ceilings on page 306.     

  Auto Room Dimensions edit button to generate interior dimensions that measure each wall defining the selected 
room(s). See Auto Room Dimensions on page 334.          
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Room Labels
A label can display in plan view for any area defined as a room. There are two parts to each room label: 

 l The Room Name, which is set in the Room Specification dialog.
 l The room size, which can be reported as dimensions and/or an area and is determined by the configuration of the walls 

that define the room. 

Room labels can move or even disappear when room entries are 
revalidated.

CUSTOM ROOM NAMES

The Room Names that display in room labels are based on the Room Types assigned in the Room Specification dialog. See 
Room Types on page 289.

You can, however create a custom name for a selected room, also in the Room Specification dialog. See General Panel on 
page 308.

Before creating a custom Room Name, assign the Room Type most similar to the room’s actual use.  For example, if you 
wish to name a room “Guest Room”, begin by specifying it as a “Bedroom” since these rooms have similar uses. 

You can assign a custom Room Name, move a room label or even delete it without affecting the Room Type. 

ROOM LABEL DEFAULTS

The initial settings that control the size, font, color and other aspects of room label appearance are controlled in the 
Room Label Defaults dialog. See Room Label Defaults on page 289.          

You can also add additional text to the default room label if you wish. This text will appear in the labels for all rooms.          

DISPLAYING ROOM LABELS

The display of room labels is controlled in the Layer Display Options dialog.             Room labels are placed on the “Rooms, 
Labels” layer and use the Text Style assigned to that layer. See Layer Display Options Dialog on page 127.         

You can specify how the area of rooms is reported by the program by turning on the display of one or more of these layers:         

 l Rooms, Standard Area is measured from the center of interior walls that define the room and from either the outside 
surface or the outside of the Main Layer of exterior walls, depending on the Living Area to setting in the General Plan 
Defaults dialog. It is rounded to the nearest square foot or mm and does not include the area within bay, box and bow 
windows. See Exterior and Interior Walls on page 236 and General Plan Defaults Dialog on page 60.         

 l Rooms, Interior Area is measured from the inner surfaces of all the room's walls.         
 l Rooms, Interior Dimensions is also measured from the inner surfaces of the room walls.

The display of room labels can also be controlled on a room by room basis in the Room Specification dialog. See General 
Panel on page 308.         
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EDITING ROOM LABELS

Room labels are similar to simple Text  objects and can be moved and resized much like any other text object. You can 

also modify a room label’s Text Style and other attributes in the Room Label Specification dialog. See Room Label 
Specification Dialog on page 297. 

The text of a room label cannot be modified in its specification dialog, however. The Room Name can only be specified in 
the Room Specification dialog and additional text can only be added in the Room Label Defaults dialog. 

If you delete a room label, the Room Type and Room Name remain unchanged in the Room Specification dialog. To restore 
the label, check the Show Room Label check box on the GENERAL panel of that dialog.

If you wish to further customize an individual room’s label by adding text, uncheck Show Room Label in the Room 
Specification dialog and create your own label using a Text object. See The Text Tools on page 350.

ROOM AREA

Unlike the rest of a room label, the room area and dimensions are not standard text entries and cannot be edited or changed. 
The room area moves, resizes and rotates with the rest of the room label, but you can turn the area and dimensions on or off 
separately in the Layer Display Options dialog. See Displaying Rooms on page 291.

All three area formats measure the room's size at floor level. The Interior Area room area calculation includes the areas 
within bay, box or bow windows, while the Standard Area and Interior Dimensions calculations do not. 

LIVING AREA

The Living Area label is an automatically generated Text object that reports the area of the current floor specified as living 
space. By default, interior type rooms are defined as part of the Living Area, while exterior and hybrid type rooms are not. 
In addition, rooms with a Rough Ceiling height that is less than 48" (1200 mm) are excluded from the Living Area by 
default. See Room Types on page 289.

Regardless of its Room Type, you can specify whether any room is included in the Living Area Calculation in the Room 
Specification dialog. See General Panel on page 308.

A Living Area label is created as soon as a room area is defined by walls and/or railings and is recalculated every time you 
add, remove, resize, or redefine a room or when you Rebuild Walls/Floors/Ceilings . If multiple buildings are created, 

each will have its own Living Area label. If none of a structure’s rooms are included in the Living Area Calculation, 
however, no Living Area label will display for it. 

Each Living Area label can be edited in its specification dialog. Bear in mind, though, that if a new floor is added, any 
existing Living Area labels will be deleted and replaced. See Room Label Specification Dialog on page 297.

Living Area labels are placed on the "Room Labels" layer. To turn off the display of all Living Area labels in a plan without 
affecting individual room labels, you can uncheck Show Living Area Label in the General Plan Defaults dialog. See 
General Plan Defaults Dialog on page 60.

Living Area labels cannot be deleted: if you select one and click the Delete  edit button, Show Living Area Label in the 

General Plan Defaults dialog will become unchecked.          

LIVING AREA VS. FOOTPRINT

The Living Area should not be mistaken for the footprint of a house. Only true livable areas are included in the Living Area 
calculation. By default, exterior and hybrid room types such as Garage, Deck, and Porch are not included. Neither is any 
room labeled Open Below or Attic. See Room Types on page 289. 
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Regardless of its room type, you can specify whether a room is included in the Living Area calculation in the Room 
Specification dialog. See General Panel on page 308. 

Living Area is measured from either the outside surface or the outer surface of the Main Layer of exterior walls. See Wall 
Type Definitions on page 262. 

 

Room Label Specification Dialog
The Room Label Specification dialog opens if you select a Room Label or Living Area Label and click the Open 
Object edit button. See Room Labels on page 295.   

A similar Text Specification dialog is available for simple Text objects in legacy plan     or layout files created in Version 8 or 
prior. See Compatibility with Other Programs on page 33.   

Note: Rich Text objects have a different specification dialog. See Rich 
Text Specification Dialog on page 352.

TEXT PANEL

The settings on the TEXT panel allow you to type the selected Living Area Label's content. Text cannot be added to a 
selected room's label, however.          

  Text Entry
 l Enter text in the Text Entry field. This field is available for the Living Area but not for a selected room's label. See 

Room Labels on page 295. 

 l Depending on the current Preferences  settings, pressing the Enter key either forces a new line in the text box or 

closes the dialog. A carriage return can also be added by typing Shift + Enter or Ctrl/⌘  + Enter. See Text Panel on 
page 68.          

 l Text automatically wraps to a new line without requiring a hard return.          

 l Tabs can be added to the text by pressing the Tab key.          

Two spelling suggestions, Ignore Spelling, and Learn Spelling 
are available in the contextual menu if you right-click on a 

selected misspelled word. See Find/Replace Text on page 361.

 
Preview
In the legacy Text Specification dialog only, a preview of the selected text object displays on the right. Not available for 
Room Labels. See Dialog Preview Panes on page 21.

297



Home Designer Pro 2025 Reference Manual - Room Label Specification Dialog

ATTRIBUTES PANEL

  Box/Grid

 l Specify the positions of the selected text object's Tab Stops.

 l In the text field, specify the number of spaces from the left edge of the text box where each new column begins. The 
first column always starts at 0 and is not listed.

 l Check Display Border to turn on the display of a border polyline around the selected object.

 l Check Display Grid Lines to turn on the display of the grid formed by the specified rows and columns.          

  Alignment

 l Specify the Horizontal alignment of the text characters within its left and right edges of its columns by choosing an 
option from the drop-down list. 

 l Specify the Vertical alignment of the text characters within its top and bottom edges by choosing an option from the 
drop-down list.          

  Origin/Angle

 l Specify the X Position and Y Position of the selected object relative to the origin. See 3D Drafting on page 12.           

 l Specify the Angle of the selected text object. The default value is 0°.          
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  Size

 l Specify the Height of the selected text object(s) or check Auto Height to automatically adjust its height to match its 
contents.          

 l Specify the Width to of the selected text object(s) or check Auto Width to automatically adjust its width to match 
its contents. When Auto Width is used, text extends in a single line rather than wrap.          

 l Specifying a Height and/or Width of 0 sizes the text box as small as the text within it allows without turning on the 
Automatic behavior.           

  Margins

 l A default Left and Right margin is applied. Top and Bottom margins are measured relative to the line height and 
may not extend to the text box completely when given a value of 0.

 l Check Apply Top/Bottom Margins to Each Row to apply the Top and Bottom Margins specified above to each 
line of text within the selected Text object. When unchecked, the Top and Bottom margins are applied to the Text 
object as a whole.

 
Preview
In the legacy Text Specification dialog only, a preview of the selected text object displays on the right. Not available for 
Room Labels.         

LINE STYLE PANEL

The LINE STYLE panel is found in the specification dialogs for many different objects. For more information, see Line Style 
Panel on page 209.          

FILL STYLE PANEL

For information about the settings on this panel, see Fill Style Panel and Dialogs on page 132.          

TEXT STYLE PANEL

The TEXT STYLE panel is available for a number of objects in the program and control the appearance of the selected 
object’s text. See Text Style Panel on page 373.           

 

Decks
A Deck room is an exterior-type room that uses deck planking and framing to create a floor platform rather than using a 
floor finish that spans the entire room area. See Floor and Ceiling Platform Definitions on page 303. 

The default settings for deck planking and framing are set in the Deck Room Defaults dialog. See Room Type Defaults on 
page 288.         

To draw a deck, select Build> Railing and Deck> Straight Deck Railing , then click and drag to draw a railing. Once 

room definition is established, the area defined by the railing can be assigned the “Deck” room type. 

 l To create a deck without a railing, use one of the Deck Edge tools. See Fencing Tools on page 236.         
 l You can also create a regular, polygon-shaped deck using the Polygon Shaped Deck  tool. See Polygon Shaped 

Deck on page 234.         
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A room does not have to be defined by Deck Railing to be specified as a “Deck.” See Room Types on page 289. You can 
also define a room as a “Deck” in the Room Specification dialog. See General Panel on page 308. 

By default, decks do not have roofs. If you want a roof over a deck, check Roof Over This Room in the Room 
Specification dialog. See Structure Panel on page 310.

To give the roof a visible means of support, you can select the Post to Beam option in the Wall Specification dialog. See 
Rail Style Panel on page 281.

Openings in deck railings can be created using Doorways . See Openings in Railings on page 390. 

DECK FRAMING AND PLANKING

When a Deck room is created, the floor platform is modeled using joists, beams, posts, and planking as specified in the 
Deck Room Defaults dialog. See Structure Panel on page 310, Deck Panel on page 315, and Deck Support Panel on page 
316. 

 l If a floor level is present below the one that the Deck room is created on, the framing will be created there. If needed, 
beams may be generated with posts beneath them, if specified. When terrain is present, the posts will have footings, 
again, if specified.           

 l If a floor level is not present below the Deck, framing will be generated on the same floor as the room. Beams may be 
created but posts will not.          

 l Deck framing, planking, posts, and beams are placed on their own layers with names that begin with “Framing, Deck”: 
for example, “Framing, Deck Posts”. These layers are often turned off in plan view but are typically turned on in 3D 
views. See Displaying Framing on page 655.

If standard floor framing is present when a room is specified as a Deck, that framing is deleted and replaced with 
automatically-generated deck framing. In addition, a Deck's framing will automatically rebuild any time the walls or railings 
that define it are moved or changes are made to its Structure, Deck, or Deck Support settings.

Once created, the individual planking and framing objects generated for a Deck room can be selected and edited like other 
framing objects, provided that Automatically regenerate deck framing is unchecked  on the DECK panel of the Room 
Specification dialog. See Editing Framing on page 656.           

If changes are later made to the settings on the DECK and/or DECK SUPPORT panel of the Room Specification dialog and 
Automatically regenerate deck framing is unchecked, however, the deck framing and planking will not rebuild in 
response.          

To rebuild a deck’s framing and remove any changes you may have made to automatically-generated deck framing or 
planks, select the Deck room and click the Build Deck Framing  edit button. The Build Deck Framing edit tool does not 

affect any manually-drawn floor joists or trusses in the Deck room's area.         

If you delete a Deck room, its deck framing and planking will be automatically deleted, as well. To prevent this from 
happening, check Keep deck framing after the deck room is deleted. See Deck Panel on page 315.          

The structural materials for a selected deck can be calculated in a Materials List by clicking the Calculate Structural 
Materials for Deck  edit button. Any planks that are cut to a smaller width (ripped) to fit the size of the Deck will be 

described using their full width. See The Materials List Tools on page 951.
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Floor and Ceiling Heights
Default floor and ceiling heights are defined in the Floor Defaults dialog for each floor, including the foundation. Use the 
Floor Defaults dialog to change these values on a floor-by-floor basis. See Floor and Room Defaults on page 287.

Use the Room Specification dialog to set floor heights on a room-by-room basis. See Room Specification Dialog on page 
308. 

Different rooms on the same floor can have unique floor and ceiling heights, allowing you to create: 

 l Split levels and bi-levels
 l Sunken living rooms and garages
 l Cathedral, vaulted, and coffered ceilings.

In 3D views, you can adjust the default floor and ceiling height for the entire floor, the floor and ceiling height for an 
individual room, or the top and bottom heights of an individual wall. See In 3D Views on page 293.

In order to raise or lower an area’s floor or ceiling height, you must give it a room definition. To create room definition 
without enclosing an area with solid walls, use Railings . 

Invisible walls and railings will fill in the vertical space between floor platforms of different heights as long as Generate 
Between Platforms is checked in their specification dialog. See General Panel on page 268.           

Ceiling and floor heights are interrelated. Changing the floor height in one room can affect ceiling heights of the rooms 
below. 

 l If a room’s floor is lowered, its ceiling height is increased while the ceiling below that room drops. 
 l If the floor is raised, the ceiling height decreases while the ceiling below that room is raised. 

If the rooms above a particular room have more than one floor height, the room’s ceiling is stepped.

In a situation like this, a Lowered Ceiling can be used to cover “steps” made by different floor heights on the floor above. 
See General Panel on page 308.
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DROPPED CEILINGS AND RAISED FLOORS

The structure of a dropped, or suspended, ceiling can be specified in the Ceiling Finish dialog either for a room or the 
defaults for a floor. See Floor and Ceiling Platform Definitions on page 303.         

To create a framed dropped ceiling

 1.  Select a room and click the Open Object  edit button.           

 2.  On the STRUCTURE panel of the Room Specification dialog, click the Ceiling Finish button. See Structure Panel on 
page 310.          

 3.  In the Ceiling Finish dialog:         

 l Check Frame Lowered Ceiling.         

 l Specify the depth of the Air Gap, or the distance between the bottom of the ceiling platform and the top of the 
lowered ceiling framing.         

 l Specify the Framing Thickness, which is the depth of the framing layer.         

A dropped ceiling composed of a metal grid requires only two layers: one for the plenum and one for the tiles.               To achieve 
this, set the Framing Thickness to 0” (mm).

SHELF CEILINGS

In rooms with high or vaulted ceilings, it is possible to have a smaller room such as a closet that has a flat, lower ceiling. By 
default, the area above the flat ceiling will be enclosed by automatically-generated Attic walls. See Attic Walls on page 259. 

If you prefer, you can specify that these Attic walls be suppressed and an open space be created instead. This condition is 
referred to as a Shelf Ceiling, or plant shelf, and can be specified in the Room Specification dialog of the room with the 
lower flat ceiling. See Structure Panel on page 310. 

SPLIT LEVELS

A split level can be created by raising or lowering the floor and ceiling heights of various areas of the plan.

In the following example, the lowest floor height is 0, the next is 24, and the next is 48 inches. The ceiling height in each 
room is set at 109 inches. See Split Levels on page 523.
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Floor and Ceiling Platforms
In many ways, rooms in Home Designer are defined by the floor platforms below them and the floor and/or ceiling 
platforms above.          

All floor and ceiling platform and finish materials are used for the calculation of the materials list. See Materials Lists on 
page 950.         

FLOOR VS CEILING PLATFORMS

Floor and ceiling platforms are not the same thing in Home Designer. Floor platforms have living space above them and are 
designed to be weight-bearing. Ceiling platforms, on the other hand, have living space below them but not above them. 
They are not designed to bear weight and are typically less strong - and less thick - than floor platforms.         

FLOOR AND CEILING PLATFORM DEFINITIONS

Floor and ceiling platforms are made up of layers of different materials such as framing, subflooring or drywall, and finish 
materials. They are defined in the Floor and Ceiling Structure Definition dialogs. See Material Layers Definition Dialogs on 
page 743.              

Note: Subflooring refers to the topmost layer(s) of a floor structure not 
specified as Framing.

Floor and Ceiling Platform Definitions play a role in determining floor and ceiling heights. Ceiling Finish Definitions can be 
used to create              dropped ceilings. See Floor and Ceiling Heights on page 301. 

In addition to the structural layers of a platform, floors and ceilings also have a finish layer. You can specify floor and 
ceiling finish materials for an entire floor or individual room on the MATERIALS panel of either the Floor Level Defaults or 
Room Specification dialog. See Materials Panel on page 750.         

FLOOR/CEILING PLATFORM DEFAULTS DIALOG

The plan-wide defaults for all floor and ceiling platforms are set via the Floor/Ceiling Platform Defaults dialog. Floor and 
ceiling platform depths contribute to the overall height of a structure, so their default values should be set as early as 
possible. See Floor and Ceiling Platform Framing on page 627.
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Structure Panel

 l The total depth of each assembly is reported for reference.
 l Click the Edit button beside each assembly type to define its composition in the Material Layers Definition dialogs. 

See Material Layers Definition Dialogs on page 743.
 l Floor Finish is composed of a single layer. Type the desired default depth in the text field.

Materials Panel

The settings on this panel affect the appearance of floor and ceiling surfaces in 3D views. See Materials Panel on page 750. 

Dynamic Platform Defaults

Floor and Ceiling Structure and Finish definitions assigned to rooms have a hierarchy of dynamic defaults. These defaults 
help you maintain consistency throughout each model. See Dynamic Defaults on page 58.          

 l The plan-wide defaults for platforms are set in the Floor/Ceiling Platform Defaults dialog. See Floor and Ceiling 
Platform Framing on page 627.          

 l The plan-wide defaults can be overridden for each floor level in the Floor Level Defaults and Framing Defaults 
dialogs.         

 l Floor-wide platform defaults can be overridden in the Room Type Defaults dialogs. See Room Types on page 289.         
 l The platform defaults for Room Types can be overridden for individual rooms in the Room Specification dialog. See 

Structure Panel on page 310. 
 l The settings for individual rooms can be overridden by Joist Direction Lines. See Joist Direction Lines on page 653.         
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FLOOR AND CEILING FINISHES AND THE MATERIAL PAINTER

If you use the Material Painter to change a room’s floor or ceiling finish material, it will add that material to the 
room’s Floor or Ceiling Finish Definition. Changes to a Deck room’s planking or framing will affect its Floor 

Structure Definition. See Material Painter Tools on page 747.         

When the Material Painter is used to add a floor or ceiling finish material in a room where one does not currently exist, a 
new finish layer is created and the material Depth is used as its Thickness. See Materials List Panel on page 768.         

STEPPED FLOOR AND CEILING PLATFORMS

Each floor has default floor and ceiling heights. You can, however, use the Room Specification dialog to specify floor and 
ceiling heights on a room by room basis to create stepped floors and ceilings. See Structure Panel on page 310.    

If you require a single floor platform with a uniform height and thickness but different ceiling heights for the rooms below, 
specify a lowered ceiling using the Ceiling Finish Specification dialog. See Lowered Ceilings on page 305.   

Either way, by default, any gap between floor and ceiling platforms that step at a railing or invisible wall is closed off by a 
short section of solid wall. If you require a gap between the platforms, either select a single-layer wall type or uncheck 
Generate Between Platforms in the Wall or Railing Specification dialog. See General Panel on page 268.    

PLATFORM EDGES

Typically, floor and ceiling platforms are built so that they bear on top of walls. The edges of the platform structures extend 
through exterior walls to the layer of the wall type definition with the Build Platform to This Line setting. See Wall Type 
Definitions on page 262.    

 l For framed walls, the Build Platform to This Line layer is set as the outside of the wall’s Main Layer,     
 l For concrete walls, it’s the inside of the wall’s Main Layer.     
 l The platforms of rooms with raised floors and/or lowered ceilings build in the same manner: to the Build Platform to 

This Line layer of the wall type assigned to the railing or invisible wall defining the room. See Floor and Ceiling 
Heights on page 301.     

For a given wall type, you can specify a different Build Platform to This Line wall layer surface provided that it  is on the 
exterior side of the Main Layer.    

In addition, you can specify that individual walls build through floor and ceiling platforms in the Wall Specification dialog.  
See General Panel on page 268.   

 

Special Ceilings
By default, the program builds a flat ceiling platform on top the wall plates of a room. More varied and complex ceilings are 
made using settings in the Room Specification dialog and the Ceiling Plane  tool. Ceiling planes are drawn and can be 

edited much like roof planes. See Ceiling Planes on page 605.

LOWERED CEILINGS

If you require uniform top plate heights and a single floor platform with a uniform height and thickness but different ceiling 
heights for the rooms below, specify a lowered ceiling. You can define a lowered or dropped ceiling in a room without 
affecting the top height of the walls by specifying the lowered ceiling framing as a layer in the Ceiling Finish Definition. 
See Floor and Ceiling Platforms on page 303.
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In the following illustration, the default ceiling height for the entire first floor is 120", and the room on the right has a 
ceiling finish lowered to 96".  

When a Soffit is positioned against the ceiling in a room, the Ceiling Finish layers located directly above it - including any 
lowered ceiling framing - will not generate. See Placing Soffits on page 739.          

To create a lowered ceiling

 1.  Select the room in which you would like to specify a lowered ceiling.

 2.  Click the Open Object  edit button to open the Room Specification dialog.

 3.  On the STRUCTURE panel, click the Ceiling Finish button to open the Ceiling Finish  dialog. See Material Layers 
Definition Dialogs on page 743.             

 l Check Frame Lowered Ceiling.             

 l Specify the Air Gap, which is the distance between the bottom of the platform above and the top of the lowered 
ceiling framing.             

 l Specify the Framing Thickness, which is the depth of the lowered ceiling joists.             

 4.  When you are finished, click OK to close the Ceiling Finish Definition dialog.             

 5.  On the Structure panel, notice that the preview diagram represents the Finished Ceiling height (F).

    VAULTED AND CATHEDRAL CEILINGS

A cathedral ceiling has the same pitch as the roof and is created using the underside of the roof above the room. A vaulted 
ceiling typically has a different pitch from that of the roof and is often framed using scissor trusses. See Scissors Trusses on 
page 674.
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To create a cathedral ceiling

 1.  Build a roof for your plan. See Roofs on page 573. 

 2.  Select the room and open the Room Specification dialog. See Room Specification Dialog on page 308.

 3.  On the STRUCTURE panel, uncheck Flat Ceiling Over This Room.

You can also remove or restore a selected room's flat ceiling by clicking the Turn Off Ceiling  or Turn On Ceiling  

edit button.

By default, cathedrals ceiling use the ceiling material set in the Room Specification dialog. If you require a different 
material on a given roof plane, uncheck Use Room Ceiling Finish in the Roof Plane Specification dialog. See Options 
Panel on page 600.          

To create a vaulted ceiling

 1.  To create a ceiling pitch different from the roof’s, select Build> Roof> Ceiling Plane  and draw ceiling planes. 

See Ceiling Planes on page 605.              

 2.  Select each ceiling plane and specify its pitch. See Ceiling Plane Specification Dialog on page 606.              

TRAY CEILINGS

A tray ceiling is an area within a ceiling that is raised and has either vertical or sloping sides.  A standard tray ceiling can be 
easily created by placing Soffits around the perimeter of the room. An angled tray ceiling can be created using the underside 
of roof planes above.         

To create an automatic angled tray ceiling

 1.  In the Room Specification dialog, make sure that Flat Ceiling Over this Room is checked, then specify the desired 
height of the walls as the Ceiling Height. See Structure Panel on page 310.             

 2.  Make sure that Auto Rebuild Roofs is unchecked, then build the roof. See Build Roof Dialog on page 579.             

 3.  Change the Ceiling Height of the room to the desired height of the flat ceiling surface in its center.              

In plan view, dashed lines indicate where the ceiling changes from sloped to flat. These lines are located on the “Ceiling 
Break Lines” layer in the Display Options dialog. See Layer Display Options Dialog on page 127.         

If the roof is rebuilt after the ceiling height is adjusted upward, the new roof will be raised to match the new ceiling height 
and a tray ceiling will not be created.         

In the following example, a hip roof is built on 8’ (2400 mm) ceilings. After the roof is built, the Ceiling Height is raised to 
10’ (3000 mm). The resulting ceiling follows the roof pitch for 2’ (600 mm), then becomes a flat ceiling.          
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CANTILEVER UNDERSIDES

Occasionally, a room will cantilever out past an exterior wall. You can specify the surface material of the underside of a 
cantilever on the MATERIALS panel of the Room Specification dialog. For no material, select “No Material” from the Plan 
Materials dialog. See Room Specification Dialog on page 308.

 

Room Moldings
Base molding, chair rail, and crown moldings can be applied to rooms on a floor by floor basis in the Floor Defaults 
dialogs, to different room types in the Room Type Defaults dialogs, and to individual rooms in the Room Specification 
dialog. See Floor and Room Defaults on page 287 and Room Specification Dialog on page 308.

By default, Home Designer does not automatically add room moldings to exterior or hybrid room types. Baseboards and 
chair rails are not automatically added to Open Below rooms, either; however, crown molding is if it is specified in the 
defaults for the room’s floor. See Room Types on page 289.

Base molding and chair rail heights are both offset from the floor, while crown molding is offset from the ceiling. For 
additional information, see Moldings /  Rails Panels on page 688.

By default, room moldings are suppressed behind cabinets placed against a wall. You can prevent this from occurring by 
checking Suppress Adjacent Room Moldings in the Cabinet Specification dialog. See General Panel on page 465.

Suppress Adjacent Room Moldings is also an option in the Architectural Block Specification dialog as well as in the 
Symbol Object Specification dialog for fixtures and furniture. See General Panel on page 735 and Symbol Object 
Specification Dialogs on page 723.

Room Moldings can be suppressed along an individual wall by checking No Room Molding Exterior and/or Interior in 
the Wall Specification dialog. See General Panel on page 268.          

 

Room Specification Dialog
The Room Specification dialog controls the structural characteristics and appearance of a selected room. To open the 
Room Specification dialog, select one or more rooms and click the Open Object edit button. See Selecting Rooms on 

page 291. 

Some of the panels in this dialog are also found in the Exterior Room Specification dialog as well as in the Floor, 
Floor/Ceiling Platform, and Room Type Defaults dialogs. See Floor and Room Defaults on page 287. 

The Room Specification dialog has the following panels:          

Some values in this dialog are dynamic. A value with Default specified references the Floor Defaults dialog. To return a 
value to the default, replace the check mark. See Dynamic Defaults on page 58.         

The settings in this dialog are similar to those in the Floor Defaults dialog, but affect only the selected room See Floor Level 
Defaults Dialogs on page 518.         

If multiple rooms are selected, not all of the settings in this dialog will be available. See Selecting Objects on page 142.          

GENERAL PANEL

The GENERAL panel is also available in the Room Type Defaults dialogs. See Floor and Room Defaults on page 287.           

308



Home Designer Pro 2025 Reference Manual - Room Specification Dialog

 
General

Specify the Room Type and the appearance of the Room Label

 l Select the Room Type from the drop-down list. Changing the Room Type can affect settings throughout the dialog. 
See Room Types on page 289.    

 l Click the Define button to open the Room Types dialog where you can customize the settings of the selected Room 
Type.    

 l In the Room Type Defaults dialog only, the Function of the selected room type displays for reference. See Room 
Types on page 289.             

 l If you wish to use a custom name in the room’s label, type the desired Room Name in the text field. 

 l Check Show Room Label to display the room label in plan view. See Room Labels on page 295.
Show Room Label is unchecked automatically if you select “Unspecified” as the Room Type, and checked 
automatically if you select any other Room Type; however, you can turn this behavior off if you wish in the 
Preferences dialog. See Architectural Panel on page 77.

 
Living Area

See Living Area on page 296.         

 l Select Include in Total Living Area Calculation to include the room in the Living Area regardless of its Room 
Type.              

 l Select Exclude from Total Living Area Calculation exclude the room from the Living Area regardless of its Room 
Type.              

 l Select Use Default for Room Type (Included/Excluded) to base the selected room’s inclusion in the Living Area 
on its Room Type. The default for the selected Room Type is stated in parentheses.             
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  Options

 l Specify the Roof Group of the selected room. Change this value to control how the program combines the selected 
room’s roof system with that of the rest of the building when automatic roofs are built. This value is nearly always 
left at zero. Not available in the Room Type Defaults dialogs. See Roof Groups on page 577.         

 
Room Information

Size information about the selected room or rooms is reported here for reference. Some of this information can also be 
displayed in room labels. See Displaying Room Labels on page 295.

 
Preview

The preview on the right side of this dialog features a cross section diagram showing the relationships between the room’s 
heights and platform thicknesses. 

 l If present, the floors above and below the selected room are also shown. The left side of the floor above is offset for 
clarity.

 l The height and thickness values shown in this diagram are set on the Structure Panel on page 310. 

STRUCTURE PANEL

Some settings on the STRUCTURE panel are also found in the Floor, Floor/Ceiling Platform, and Room Type Defaults 
dialogs. 

In the Floor/Ceiling Platform and Room Type Defaults dialogs, only the Floor and Ceiling settings are available. See Floor 
and Room Defaults on page 287.    
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Active Defaults   icons in the Elevation and Height fields, as well as Default check boxes next to the Structure and Finish 
fields indicate that these settings are Dynamic Defaults. See Dynamic Defaults on page 58. 

Note: Many of the settings on this panel are interdependent. For example, 
if the Ceiling Structure thickness is modified, the Absolute Ceiling and 
Rough Ceiling heights will change in response. 

 
Absolute Elevations

These height values are measured from zero, which is the default top height of the subflooring on Floor 1. See Floor and 
Ceiling Heights on page 301.     

 l The Floor Above height displays here for reference. If multiple rooms with differing floor heights exist directly 
above, “No Change” will display.     

 l Specify the Ceiling height of the selected room, as measured from zero to the bottom of the ceiling framing. Not 
available in the Room or Floor Defaults dialog or if multiple floor heights are specified above the selected room.     

 l Specify the Floor height, as measured from zero to the top of the subfloor.

Note: The default floor height for Floor 1 is 0. It can be modified in the Room Specification dialog, but not in the Floor 
1 Defaults dialog. See Floor and Room Defaults on page 287.    

 l If a room is defined directly beneath the selected room on the floor below, additional settings may be available.    
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 l Specify the Floor Below height, which is the subfloor height of the room directly below where you clicked to select 
the currently selected room. If there are multiple rooms with differing floor heights located below, this value may 
change depending on where you click.    

 l If the selected room is directly above a Garage and there is a foundation present, you can specify the SWT Below 
height, which is the top height of the concrete stem walls around the perimeter of the garage. 

 
Relative Heights

These height values are measured from surfaces within the selected room or the room below.    

 l Specify the Rough Ceiling height, as measured from the subfloor surface to the bottom of the ceiling framing. Not 
available if multiple floor heights are specified directly above the selected room.    

 l Specify the Finished Ceiling height, as measured from the finished floor surface to the finished ceiling surface. Not 
available if multiple floor heights are specified directly above the selected room.    

 l Specify the distance from the Stem Wall Top to Ceiling. Only available when Floor for this Room is Supplied by 
the Foundation ‘Room’ from the Floor Below is checked, below.    

 l Specify the Floor to Stem Wall Top for rooms with Floor for this Room is Supplied by the Foundation ‘Room’ 
from the Floor Below specified.    

 l Specify the Ceiling Below height, which is the height of the ceiling of the room below, as measured from that 
room’s subfloor to rough ceiling surfaces. Not available when Auto Rebuild Foundation is enabled or if there is no 
room below the selected room. See Rebuilding Foundations on page 503.    

 l Specify the Stem Wall height, which is measured from the top of the foundation wall footing to the top of the 
treated sill plate, if one is specified. Only available if the selected room or the room below it is defined by 
foundation walls.

 
Ceiling

Only the Ceiling Finish and Structure settings are available in the Room Type Defaults dialogs.

 l If Roof Over This Room is checked, a roof automatically generates over the room. If unchecked, no automatic roof 
generates.

If this option is unchecked and a roof plane is manually drawn over this room, its structure will be that of an eave 
rather than a regular roof. In most cases, if a roof is present over a room, this box should be checked. See Roof Panel 
on page 644.

 l If Flat Ceiling Over This Room is checked, the room has a flat ceiling. If unchecked, the ceiling follows the 
underside of the roof or manually drawn ceiling planes.

 l Check Shelf Ceiling to prevent Attic Walls from generating over the interior walls that define the selected room. 
When unchecked, interior Attic Walls will generate if surrounding rooms have higher ceilings than the selected 
room. See Shelf Ceilings on page 302.

 l Check Use Soffit Surface for Ceiling to frame the roof over the selected room using the framing defaults for fascia 
rather than for rafters.             
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 l The Ceiling Structure depth displays here for reference. 

 o Click the Edit button to open the Ceiling Structure Definition dialog and define the layers of materials that form the 
ceiling platform. 

 o Check Default to use the Ceiling Structure Definition set in the current floor’s Floor Defaults dialog. Not available 
for rooms on Floor 0. See Floor and Ceiling Platform Framing on page 627.             

 l The Ceiling Finish depth displays here for reference.

 o Click the Edit button to open the Ceiling Finish dialog and define the layers of materials that form the finished 
ceiling surface.

 o Check Default to use the Ceiling Finish              set in the current floor’s Floor Defaults dialog. See Ceiling Finish Dialog on 
page 314.             

 o Check the Default box to the right of either of the above buttons to restore the default structure and/or finish set in 
the Room Type Defaults dialog. See Floor and Room Defaults on page 287.             

 
Floor

In the Room Type Defaults dialogs, the most of the options here are not available.         

 l When Floor Under This Room is checked, the room has a floor platform as specified below.             

 l If Floor Supplied by the Foundation Room Below is checked, the floor platform for this room is a slab located on 
the floor below and cannot be edited here. This option cannot be edited while Automatically Rebuild Foundation is 
enabled. See Foundation Defaults Dialog on page 498.

 l If Monolithic Slab Foundation is checked, the current Floor Structure will be replaced by a single 4” (100 mm) 
layer of concrete with footings that can be seen in camera views only. When a stem wall or grade beam foundation is 
generated, a slab will be created beneath the selected room.

If the selected room has a living space located anywhere 
beneath it, avoid checking Monolithic Slab Foundation.

 l When Build Foundation Below is checked, the selected room receives a foundation under it when the foundation is 
automatically built. Uncheck this box to prevent a foundation from being created below the selected room. See 
Building a Foundation on page 501.    

 l Specify the thickness of the Floor Finish layer. Check Default to use the default Floor Finish thickness set in the 
current floor’s Floor Defaults dialog.             

 l Specify which part of the floor platform moves On Structure Resize. Select Lock Floor Top to keep the top of the 
floor structure at the same height and raise or lower its bottom when the platform depth is changed. Select Lock 
Floor Bottom to keep the bottom of the floor structure at the same height and raise or lower the top when the depth 
is changed.             
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 l The Floor Structure depth displays here for reference.

 o If the selected room is a Deck, this label will be Planks, Joists instead. See Decks on page 299

 o Click the Edit button to open the Floor Structure Definition dialog and define the layers of materials that form the 
floor platform.

 o Check Default to use the Floor Structure Definition set in the current floor level’s Floor Defaults dialog. See 
Material Layers Definition Dialogs on page 743.             

 o Check the Default box to the right of either button to restore the default structure and/or finish. See Floor and 
Ceiling Platforms on page 288.             

Note: The default floor and ceiling platform and finish definitions for 
rooms are set in the current floor’s Floor Defaults dialog. In the Floor 
Defaults dialog, the defaults are drawn from the Floor/Ceiling Platform 
Defaults dialog. See Floor and Room Defaults on page 287.

 
Preview

The preview on the right side of this dialog features a cross section diagram showing the relationships between the room’s 
heights and platform thicknesses. 

 l If present, the floors above and below the selected room are also shown. The left side of the floor above is offset for 
clarity.

 l The callout or dimension line associated with selected height or thickness value will be highlighted in the preview, 
as will any height or thickness value that you move your mouse point over. 

 l The font used by the callouts and dimensions is set in the               Dimension Defaults dialog, while the unit of measurement 
is specified in the Dialog Number/Angle Style dialog. See Dimension Defaults Dialog on page 322 and Dialog 
Number/Angle Style Dialog on page 88.             

 l What appears in both the diagram and in the settings on the STRUCTURE panel may be affected by the location where 
you clicked to select the room. For example:

 l If the selected room is located above two rooms with different structural settings, the position of the pointer relative 
to these two lower rooms determines which of them displays as the floor below.

 l If the selected room is located below two rooms with different floor heights, its absolute and relative ceiling height 
settings will be disabled. 

CEILING FINISH DIALOG

 l Check Frame Lowered Ceiling to enable the two settings that follow.             
 l Specify the Air Gap, which is the vertical distance between the lowered ceiling framing and the framing of the 

platform above it.             
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 l Specify the Framing Thickness, which is the vertical depth of the framing of the lowered ceiling.             
 l Specify the Finish Thickness, which is the vertical depth of the ceiling finish material.             
 l The Total thickness of the Ceiling Finish Definition displays for reference.             

DECK PANEL

The options on the DECK panel are only available for rooms designated as Decks, and control how deck planking and joists 
are generated. See Deck Framing and Planking on page 300.

The settings on this panel are also found in the Deck Room Defaults dialog, but affect the selected Deck room(s) only rather 
than Decks as they are initially created. See Room Type Defaults on page 288.          

  Automatic Deck Framing

 l Check Automatic Deck Framing to generate planking and support framing for the deck that updates as changes are 
made to the deck. See Decks on page 299.

 l Check Keep Deck Framing After Deck Room is Deleted to retain the automatically generated framing and 
planking when the selected deck room is deleted. When this box is unchecked, the framing is automatically removed 
if the room is deleted.           

 
Deck Planking

Deck planking should be specified in the top layer of the room's Floor Structure Definition.                     

 l Specify how far the deck planking Overhangs the rim joists.         

 l Specify the Plank Width of the deck planking. 

 l Check Max Plank Length, then specify the maximum allowable length for the selected Deck's planks. When 
unchecked, planks run the full length of the Deck room.
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 l Specify the Plank Gap Width, which is the distance between individual planks.         

 l If you want to enter a Plank Direction, remove the check mark from Automatic. Enter the direction as degrees.         

 l Specify the Number of Border Planks. These are planks that follow the outside edge of the deck and may not be 
parallel with the rest of the planking. Border planks generate as long as the length of an inside edge is greater than 
0”. They do not generate on curved deck edges.         

Note: Planking thickness and joist depth are specified in the Floor 
Structure Definition dialog. See Floor and Ceiling Platform 
Definitions on page 303.      

 l Check No Border Against Walls to prevent border planking from being generated along any walls defining the 
deck.             

 l Check Herringbone to produce a herringbone pattern where the border planks meet.             

 l Check Treated to specify that the deck planking is counted as treated in               the Materials List.             

  Deck Joists

 l Enter the Width of the joists that support the deck.             

 l Specify the Spacing between joists, as measured from joist center to joist center.             

 l If you want to specify joist Direction, uncheck Automatic and enter the direction in degrees. When checked, joists 
are run in the direction that results in the shortest spans.             

 l Check Treated to specify that the deck joists are counted as treated in the Materials List.             

 
Preview

The preview on the right side of this dialog features a cross section diagram showing the relationships between the room’s 
heights and platform thicknesses.         

 l If present, the floors above and below the selected room are also shown. The left side of the floor above is offset for 
clarity.         

 l The height and thickness values shown in this diagram are set on the Structure Panel on page 310.         

DECK SUPPORT PANEL

The options on the DECK SUPPORT panel are only available for Deck rooms and control how deck beams and posts are 
generated. See Deck Framing and Planking on page 300.          

The settings on this panel are also found in the Deck Room Defaults dialog, but affect the selected Deck room(s) only rather 
than Decks as they are initially created. See Room Type Defaults on page 288.          
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Deck Beams

Specify the configuration of the beams under the selected Deck room.                     

 l Uncheck Deck Beams to prevent the automatic generation of support beams under the selected Deck room.             

 l Specify the vertical beam Depth.    

 l Specify the horizontal beam Width.    

 l Specify the Member Count, which is the number of framing members sistered together to form the selected Deck's 
beams.

 l Specify the Position of the beams:

 o With Joists positions the top edge of each beams at the same height as the tops of the joists.

 o Under Joists positions the beams directly under the bottom edges of the joists.

 l Specify the Max Spacing of beams, measured from center to center. Beams may be positioned closer than this 
value, but not further apart.

 l Specify the Offset from Deck Edge, which is the distance from each deck edge and the nearest beam that is parallel 
to that edge.

 o This value is measured from the center line of the beam.

 o Check Flush With Edge to align the interior edge of the beam with the deck edge.             

 
Deck Posts

Specify the configuration of the posts under the selected Deck room.    
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 l Uncheck Deck Posts to prevent the automatic generation of support posts under the selected Deck room.    

 l Select a Type from the drop-down list. See Framing Types on page 629.             

 l Specify the Dimension, which is both the width and depth of the posts.    

 l Specify the Max Spacing of posts, measured from center to center. Posts may be positioned closer together than this 
value, but not further apart.    

 l Specify the Offset from End, which is the distance from the end of each beam to the center of the nearest post. 
Deck posts cannot be generated past the end of a deck beam, so any value less than half the posts' Width 2 value will 
align end posts with the end of the beam.

 l Specify the posts' Alignment to Beams: Exterior, Centered, or Interior. This setting only has an effect when the 
default Deck Beam or sistered beams' Width is greater than the posts' default Dimension.

 
Deck Post Footings

These settings are not available if Deck Posts is unchecked, above.         

 l Uncheck Deck Post Footings to prevent the automatic generation of footings under the selected Deck room’s posts.             

 l Specify the footings’ Height Above Terrain. See Foundations and the Terrain on page 507.             

 l Specify the footings’ Thickness and Width.             

 l Specify whether the footings are Square or Round in shape.             

 
Preview

The preview on the right side of this dialog features a cross section diagram showing the relationships between the room’s 
heights and platform thicknesses.         

 l If present, the floors above and below the selected room are also shown. The left side of the floor above is offset for 
clarity.          

 l The height and thickness values shown in this diagram are set on the Structure Panel on page 310.         

MOLDINGS PANEL

Chair rail, crown and base moldings can be assigned to one or more selected rooms on the MOLDINGS panel. Moldings are 
placed on a room’s wall surfaces and continue around the surface of any soffit that is attached to the wall at the molding 
height.         

The settings on this panel are also similar to those found in the Floor Defaults dialog, but affect only the selected room 
instead of all rooms on the current floor.          

The settings on this panel are similar to those found in other specification dialogs throughout the program. See Moldings /  
Rails Panels on page 688.         

WALL COVERING PANEL

The settings on the WALL COVERING panel of the Room Specification dialog are the same as those on the same panel of the 
Wall Specification dialog. When a wall covering is assigned in the Room Specification dialog, it is applied to all walls in 
the selected room only. See Wall Covering Panel on page 279.
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FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the room in plan view.  This panel is also found in the Floor 
Defaults dialog. For more information, see Fill Style Panel and Dialogs on page 132.

MATERIALS PANEL

The settings on this panel affect the appearance of a selected room’s walls, floor, ceiling, and moldings in 3D views. See 
Materials Panel on page 750. 

Default molding and ceiling and floor covering materials can be set on this panel in the Floor Defaults and Room Defaults 
dialogs.         

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 967.          
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Chapter 13
 

Dimensions

Home Designer provides a variety of dimensioning tools for measuring walls, doors, windows, and many other objects in 
various 2D and 3D views. 

Dimensions can be used to accurately position objects relative to other objects. In addition, dimension lines and extensions 
can be selected and customized. 

TOPICS

Dimension Preferences and Defaults 321
Dimension Defaults Dialog 322
The Manually Drawn Dimension Tools 331
Automatic Dimensions 333
Displaying Dimension Lines 334
Selecting Dimension Lines 335
Editing Dimension Lines 336
Editing Extension Lines 338
Moving Objects Using Dimensions 341
Dimension Line Specification Dialog 343
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Dimension Preferences and Defaults
There are a number of defaults settings as well as options in the Preferences dialog that affect dimensions.           

PREFERENCES

All plan and layout files save measurements in either U.S. or metric units. The type of unit used is determined when 
the file is first created and cannot be changed later. See Creating a New Plan or Layout on page 36.

You can specify either metric files or those using U.S. Units to be used as the templates whenever you open a new, blank 
plan or layout file in the Preferences dialog. See New Plans Panel on page 74.           

You can also specify the minimum on-screen display size for dimension numbers in the Preferences dialog. See Appearance 
Panel on page 63.         

DEFAULT SETTINGS

Select Edit> Default Settings to open the Default Settings dialog, then select "Dimension" and click the Edit button.

The Dimension Defaults dialog can also be accessed by double-clicking the Dimension Tools  parent button. See 

Dimension Defaults Dialog on page 322.

When Angle Snaps  are enabled, dimensions can be drawn at the Allowed Angles set in the General Plan Defaults 

dialog. Regardless of their angles, however, dimensions will only locate objects that are parallel to one another. See General 
Plan Defaults Dialog on page 60.

When a Marker is created in association with a manually drawn dimension, the Marker will inherit its initial settings from 
the Marker Defaults dialog. See Markers on page 368.

DIMENSIONS AND ACCURACY

When a model is drawn with greater accuracy than dimensions are set to report, rounding may be required. The Rounding 
Method in the Dimension Defaults dialog controls how Home Designer Pro handles dimensions that require rounding. See 
General Panel on page 322.          

The two Rounding Methods are:

 l Grid Rounding, which always add up dimension runs correctly, but individual distances may be inaccurate in order to 
achieve this.          

 l Distance Rounding, which shows the distance between equally spaced objects correctly, but dimension runs are not 
always accurate when added.          

Dimensioning the same object using these two rounding methods will obtain the same results as long as  objects are placed 
with the same accuracy as the precision of the dimension lines. If an object is placed using more precision than the 
dimensions, results may vary between methods.          
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A good approach to accurate dimensioning is to turn on the 
accuracy indicators and position objects so that the inaccuracy 

indicators do not display. 

 

Dimension Defaults Dialog
Select Edit> Default Settings, expand the “Dimension” category, select “Dimensions”, and click the Edit button to 
open the Dimension Defaults dialog. 

You can also open this dialog by double-clicking the Dimension Tools  parent button. If you double-click any of the 

Dimension Tools child buttons, the LOCATE panel associated with that tool will be active.

The settings in this dialog are dynamic defaults, which means that any changes made here may affect existing dimension 
lines in the drawing that are using default values. See Dynamic Defaults on page 58.

GENERAL PANEL
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  General

 l Specify the Line Separation, which is the distance between Baseline Dimension lines in plan inches (mm). This 
value should always be greater than the Character Height. See Text Style Panel on page 331.

 l Specify how far manually drawn dimension lines Reach to locate walls and/or objects specified on the LOCATE 
panels. The default is 24” (450 mm) in plan files and 1” (10 mm) in layout. See Locate Manual Panel on page 
325.          

 
Rounded Value Indicators

Rounded Value Indicators can display when the degree of accuracy in use is not sufficient to describe a dimension’s true 
value.         

 l Check + or - After Number to indicate that the actual dimension value is higher or lower than the value shown.         

 l Check ~ Before Number to indicate dimension values that are not accurate with the ~ symbol.         

  Rounding Method

 l Grid Rounding ensures that the sum of the parts of a dimension line add up to the whole distance. To produce this 
result, some sections may not be rounded accurately. This is the recommended rounding method and is selected by 
default.         

 l Distance Rounding addresses each section of a dimension line individually, which could result in the sum of these 
sections not being equal to the whole. This option is available for legacy purposes only and is not recommended. 
See Dimensions and Accuracy on page 321.         

To avoid the appearance of inaccuracy that rounding may 
cause, draw with Grid Snaps enabled and place objects in 

your plan using the same accuracy as your dimensions. See Grid 
Snaps on page 116. 

 
Dimension Text Position

Specify the location of dimension numbers relative to the dimension line.    

 l Centered on Dimension Line centers the primary dimension numbers on the dimension line. If two formats are 
used, the primary format is placed above the line and the secondary format, beneath it.    

 l Position dimension numbers Above Dimension Line.    

 l Position dimension numbers Below Dimension Line.    

SETUP AUTOMATIC PANEL

The settings on the SETUP AUTOMATIC panel affect how Auto Exterior and Auto Room Dimensions are created. 
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  General

 l Specify the Line Separation, which is the distance between Auto Exterior Dimension lines in plan inches (mm). 
This value should always be greater than the Character Height used by the label. If two formats are used, it should be 
at least twice the Character Height. See Dimension Labels on page 335.   

 l Specify the 1st Line Offset, which is the distance between each wall and the nearest Automatic Dimension line that 
measures its length in plan inches (mm).   

 
Exterior

These settings control how Auto Exterior Dimensions generate.    

 l Specify how far Auto Exterior Dimensions Reach to locate objects set back from exterior walls. If exterior walls are 
set back further than this distance, additional dimension lines are produced to locate the set-back walls.    

 l Specify the Minimum Area, which is the minimum area defined as a room needed for Auto Exterior Dimensions to 
generate.    

 l When Overall Dimension is checked, a dimension line reporting the overall length of each side of the structure is 
created.

 l When Inner Dimension is checked, up to three rows of Auto Exterior Dimensions per exterior wall are generated. 
Uncheck this box to suppress these inner dimension strings.     

 l Check Auto Refresh to delete and replace Auto Exterior Dimensions whenever a change is made to the model that 
affects them.    

 
Room

These settings control how Auto Room Dimensions generate.    

 l Specify the Minimum Area, which is the minimum area defined as a room needed for Auto Room Dimensions to 
generate. 

 l When Overall Dimension is checked and a room's Auto Room Dimensions locate objects in addition to its walls, an 
overall dimension for each wall is also generated.    
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 l Check Auto Refresh to delete and replace Room Dimensions whenever a change is made to the model that affects 
them.    

LOCATE MANUAL PANEL

The settings on the MANUAL panel specify how and whether or not Manual Dimensions  locate specific types of 

objects.    

Changes made on this panel only affect new dimension lines as they are drawn, not those already drawn. Once created, a 
dimension line's extensions can be edited so that they locate objects in ways not specified here. See Editing Extension Lines 
on page 338.

In the Dimension Defaults dialog for a layout file, only the CAD Objects settings on this panel is available.   

 
Walls

Specify the marked location in wall assemblies referred to by Extension Lines as well as the Reach and 1st Line Offset 
settings. See The Dimension Layer on page 263.             

 l Select Surfaces to locate exterior and interior walls at their surfaces.   

 l Select Wall Dimension Layer to locate walls at their Dimension Layer. A wall’s Dimension Layer is specified in its 
wall type. See Wall Type Definitions Dialog on page 264.   

 l Select None to prevent Manual End to End Dimensions from locating walls.

 
Wall Options

These settings control how or whether exterior and interior walls are located by Manual  Dimensions. See Exterior and 
Interior Walls on page 236 and Primary and Secondary Sides on page 249.           
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 l Specify how Exterior walls are located:     

 o Check Primary Side to have dimensions locate the exterior side of exterior walls.

 o Check Secondary Side to have dimensions locate the interior side of exterior walls.     

 o When neither box is checked, exterior walls are not located by Manual  Dimensions.

 l Specify how Interior walls are located:     

 o Check Primary Side to have dimensions locate the interior side of interior walls. For Auto Exterior Dimensions, this 
option locates the bottom of horizontal interior walls and the left side of vertical interior walls

 o Check Secondary Side to have dimensions locate the exterior side of interior walls. For Auto Exterior Dimensions, 
this option locates the top of horizontal walls and the right side of vertical walls.    

 o Check Centers to have dimensions locate the centers of interior walls.     

 o When neither box is checked, interior walls are not located by Manual  Dimensions.

 l Check Wall Steps to have dimensions locate steps in walls in elevation views. Steps in foundation walls in plan 
views are also located. See Stepped Walls and Footings on page 260.    

 l When Display Wall Widths is checked, the thicknesses of any walls that a dimension line crosses will be measured. 
Uncheck this box to suppress the segments dimension line segments that report these measurements.

Note: Walls specified as No Locate will not be located by some 
dimension tools. See No Locate on page 251.     

  Locate Objects

 l Each category corresponds to a type of object in Home Designer. Under each category are locations, or marks, on 
these objects that dimensions can locate.

 l Check the box beside an option to have dimension lines locate that mark on objects of that type as they are drawn or 
generated.   

 l Uncheck the box beside a category to not locate objects in that category: any checked boxes in that category remain 
checked, but disabled. Check the box beside a category to locate the selected marks on objects of that type.

 Cabinets

 Cabinets can be moved and resized in plan and cross section/elevation views. See Using 
Dimensions on page 459.

Sides The sides do not have to be perpendicular to the dimension line

Corners Angled cabinets are dimensioned to their corners at a right angle to the dimension line. A 
cabinet’s front or sides do not need to be perpendicular or parallel to the dimension line for its 
corners to be located.

Centers A cabinet’s front or sides do not need to be perpendicular or parallel to the dimension line for its 
center to be located.

Moldings In elevation views only, locate the tops and bottoms of cabinet moldings.

Countertop In plan view, a cabinet’s front or sides must be perpendicular or parallel to the dimension line for 
its countertop to be located. In elevation views, only the top and bottom edges can be located 
when the dimension is being drawn.
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Backsplash In elevation views only, locate the tops and bottoms of backsplash edges.

Toe Kick In elevation views only, locate the tops and bottoms of toe kicks.

 Fixtures/Appliances

 These options affect how dimension lines locate appliances and other fixtures such as hardware, 
millwork, sprinklers, and Geometric Shapes. In cross section/elevation views, dimensions can 
only locate furniture at points where a surface is present.

Sides/Corners For sides to be located, they must be perpendicular to the dimension line

Centers An object’s front or sides do not need to be perpendicular or parallel to the dimension line for its 
center to be located.

 Furniture

 These options affect how dimension lines locate furniture and furnishing accessories. See Stand-
Alone Objects on page 715.

Sides/Corners For sides to be located, they must be perpendicular to the dimension line.

Centers An object’s front or sides do not need to be perpendicular or parallel to the dimension line for its 
center to be located.

 Openings

 Specify how dimensions locate doors and windows. Openings in walls specified as No Locate 
will not be located by Auto Exterior Dimensions. See Doors on page 378, Windows on page 408, 
and No Locate on page 251.

Casing Locate the outer edges of both sides of wall openings’ casing. Because interior and exterior 
casing often have different widths, an opening may have different interior and exterior 
dimensions when this option is selected.

Centers Locate the centers of wall openings.

Rough Opening Locate both sides of the rough opening of doors and windows.

Sides Locate the both sides of wall openings. This option locates the nominal width - not the rough 
opening.

 CAD Objects

 These options control how dimension lines locate 2D CAD objects as well as CAD-based objects 
such as slabs and stairs. See CAD Objects on page 197.

Line/Sides For a line/side to be located, it must be perpendicular to the dimension line.

Ends/Corners Locate all ends/corners of polylines, no matter what angle they are in relation to the dimension 
line.

Callouts/Markers See Callouts on page 364 and Markers on page 368.

Clip Lines See Side Clipping on page 781.

Text See The Text Tools on page 350.

 Framing

 See Using Dimensions on page 657.

Sides Locate both sides of framing objects.

Centers Locate the centers of framing objects.

 Other Objects

327



Home Designer Pro 2025 Reference Manual - Dimension Defaults Dialog

 Electrical and image objects can be moved using dimensions, but not resized.

Electrical See Using Dimensions on page 492.

Plants and Images See Using Dimensions on page 849.

LOCATE END TO END PANEL

The settings on the LOCATE END TO END panel are the same as those on the LOCATE MANUAL panel, but control how 
objects are located when an End to End Dimension  or Point to Point Dimension  is drawn. See End-to-End 

Dimensions on page 332 and Locate Manual Panel on page 325.   

LOCATE INTERIOR PANEL

The settings on the LOCATE INTERIOR panel are also found on the LOCATE MANUAL panel, but control how objects are 
located when an Interior Dimension  is drawn. See Interior Dimensions on page 332 and Locate Manual Panel on page 

325. 

LOCATE AUTO EXTERIOR PANEL

The settings on the LOCATE AUTO EXTERIOR panel are also found on the LOCATE MANUAL panel, but control how objects 
are located when Auto Exterior Dimensions  are generated. See Auto Exterior Dimensions on page 334 and Locate 

Manual Panel on page 325.   

LOCATE AUTO ROOM PANEL

The settings on the LOCATE AUTO ROOM panel are also found on the LOCATE MANUAL panel, but control how objects are 
located when Auto Room Dimensions  are generated. See Auto Room Dimensions on page 334 and Locate Manual 

Panel on page 325.   

FORMAT PANEL

The settings on the  FORMAT panel allow you to specify the units, position, and degree of accuracy of dimension numbers. 
The settings on this panel also control the format of object length numbers in the Status Bar. See The Status Bar on page 24. 

These settings are the same as those on the  FORMAT  panel of the Dimension Line Specification dialog and the DIMENSION 
FORMAT panel of the Room Label Defaults dialog. See Dimension Line Specification Dialog on page 343 and Room Label 
Defaults on page 289. 

328



Home Designer Pro 2025 Reference Manual - Dimension Defaults Dialog

 
Format

Specify the numbering Format for dimension numbers.             

 l Select the Units of measurement to be used by dimensions from the drop-down list. The choices in this list 
correspond to all units measuring length specified in the Preferences dialog. See Unit Conversions Panel on page 74.

Note: Although you can select U.S. or metric units in any plan or 
layout, it is best to use the same unit type that the file uses to save 
measurements. See Units of Measurement on page 36.

 l Check Unit Indicators to display the unit of measurement along with the dimension number.

 l Check Leading Zeros to include the zero before a decimal less than 1 or to display  0’ or 0” when the ft-in or ’-” unit 
formats is used. 

 l Check Trailing Zeros to display trailing zeros at the end of decimal values. When the ft-in or ’-” unit format is used 
and fractional inches are specified, 0” will be included. 

 l Check Display as Inches to display the dimension number of sufficiently short segments in inches rather than the 
Unit selected above. This option is only available when the specified Unit is a form of either feet or yards, or a 
format that includes feet.   

 l The Less than or equal to value specifies how short a segment must be before its number uses inches rather than 
the specified Unit.   

 l Select a Fraction Style from the drop-down list. This option affects the angle of the fraction's vinculum line.   

 l Specify the desired Fraction Text Size as a percentage of a selected dimension line's Number Height. Only available 
when either "Diagonal" or "Vertical" are selected as the Fraction Style.

 
Accuracy

Specify the degree of accuracy used by dimension numbers.             
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 l Select the Decimal Places radio button for dimension numbers in decimal format. In the text field, specify the 
number of decimal places to use, from 0 to 20. If 0 is used, no decimal places are used.    

 l Select the Smallest Fraction radio button for dimension numbers using whole numbers and fractions. In the text 
field, specify the largest denominator to use, from 1 to 16. If 1 is entered, whole numbers are used.    

 
Angular Format

Specify format used by Angular Dimensions. See Angular Dimensions on page 332.     

 l Select an Angle Style. For a description of each, see Dialog Number/Angle Style Dialog on page 88.   

 l When Degrees is selected, you can specify the number of Decimal Places to report.

EXTENSIONS PANEL

The settings on the EXTENSIONS panel control the length of extension lines.   

 
Extension Length

Specify the Extension Length relative to the marked location on an object.     

 l Specify the Length Away From Marked Object, which is the length of the portion of an extension line that 
extends from the dimension line in the opposite direction of the object it locates.      

 l Select Length Towards Marked Object to specify a fixed length for the portion of an extension line that extends 
from the dimension line toward the object it locates. If the dimension line is moved, this length remains the same but 
the size of the gap updates.     

 l Select Gap From Marked Object to specify the distance between the end of extension lines and their marked 
location in plan inches or mm. If a dimension line is moved, extension lines update, and the size of this gap is 
maintained.    

Gap From Marked Object  +  Length Toward Marked Object =  
Distance to Marked Object

 
Fixed Proximity

Specify a fixed length for one extension line that will not change if the object the extension line locates is moved. See Using 
Fixed Proximity on page 341.             
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 l Check Fixed Proximity to specify a fixed distance between the marked object and the dimension line. You can only 
fix the proximity for a single extension line.    

 l Specify the Distance to Marked Object, which is the distance from the dimension line to the marked object, using a 
positive value.         

Extension Line and Gap lengths are measured from the marked 
location on a wall. See The Dimension Layer on page 263. 

Fixed Proximity only affects dimension lines that locate an object using an extension line. When a dimension line 
arrowhead points directly to the object without using an extension line, this option has no effect.         

Auto Exterior Dimensions ignore Distance to Marked Object and use the default 1st Line Offset and Line Separation values. 
See Setup Automatic Panel on page 323.

 
Legacy Support

These settings are only recommended for files originally created in Chief Architect              Home Edition 5 and prior.          

 l Check Legacy Compatible Extensions to assign a program-defined length to extension lines that cannot be edited.         

 l Check Short Extensions to have short, uniform-length extension lines that do not reach all the way to the objects 
they locate.         

Note: If you select an extension line, Legacy Compatible Extensions 
will be turned off automatically.

ARROW PANEL

The settings on the ARROW panel control the size and style of dimension line arrows. See Arrow Panel on page 226.   

TEXT STYLE PANEL

The settings on the TEXT STYLE panel control the size, font and other attributes of automatic, manually drawn, and 
temporary dimension line labels. Individual dimension lines inherit their text style from a Saved Dimension Default: they 
cannot have a non-default text style assigned to them. See Dimension Labels on page 335. 

For information about the settings on this panel, see Text Style Panel on page 373.

Temporary dimensions and their labels always use the Selection Line color set in the Preferences dialog. See Colors Panel 
on page 65.

 

The Manually Drawn Dimension Tools
Select CAD> Dimensions to access the manually-drawn Dimension Tools.

Manually drawn dimensions are created by clicking and dragging like other line-based objects and can be drawn in plan 
view, cross section/elevation views, and on layout pages.

The Automatic Dimension tools can also be used to create 
interior and exterior dimensions. See Automatic Dimensions on 

page 333.
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There are six manually drawn Dimension Tools:         

With the exception of Angular Dimensions , dimension lines only locate objects that are parallel or nearly parallel to 

one another and should be drawn orthogonal, or at right angles, to the objects being located.         

Dimension lines locate objects using Object Snaps , although they do not need to be enabled in order to draw 

dimensions. See Object Snaps on page 114. Bear in mind, though, that Object Snaps must be enabled in order to:         

 l Locate parallel objects drawn at angles other than Allowed Angles.         
 l Locate more than one object drawn in the same space, such as a CAD line drawn over a wall.         

The zoom factor of the current view affects whether objects drawn close together are dimensioned or not. If you try to 
dimension an array of objects but the dimension line locates only the first and last objects along its path, Zoom  in on the 

objects and try again. Similarly, if you want to dimension between two objects but the dimension locates unwanted objects 
between them, Zoom  out. See Zoom Tools on page 108.   

Once created, both manually drawn and automatically generated dimension lines can be selected and edited.  See Editing 
Dimension Lines on page 336.   

If the object or objects located by a dimension are resized or moved, the dimension will update to reflect the change. 
Objects located by a dimension can also be accurately relocated or resized by specifying a new dimension value. See 
Moving Objects Using Dimensions on page 341. 

MANUAL DIMENSIONS

The Manual Dimension tool creates dimension lines that locate all eligible objects positioned between their start and 
end points and within the default Reach distance.   

Manual Dimensions locate walls and a variety of other object types as specified in the  Dimension Defaults dialog. See 
Locate Manual Panel on page 325.   

END-TO-END DIMENSIONS

The End-to-End Dimension tool creates dimension lines that locate an eligible object at its start and end points but 
ignores any objects in between.    

End to End Dimensions locate walls and a variety of other object types as specified in the  Dimension Defaults dialog. See 
Locate End to End Panel on page 328.         

ANGULAR DIMENSIONS

The Angular Dimension tool measures the angle between any two straight edges, including walls, cabinets, and the 
straight sides of polyline-based objects. To create an angular dimension, click on the first edge to be dimensioned, 

then drag an arc and release on the second edge.         

By default, Angular Dimensions use the Angle Style specified in the  Dimension Defaults dialog. See Format Panel on 
page 328.   

INTERIOR DIMENSIONS

The Interior Dimension tool creates dimension lines that measure the interiors of rooms. Interior Dimensions do not 
locate the exterior sides of exterior walls by default, although they can be edited to do so, and they have Display 

Wall Widths unchecked by default in their specification dialog so they do not report the thicknesses of walls or wall layers. 
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See Dimension Panel on page 344.          

Interior Dimensions locate either wall surfaces or the Main Layer, as well as a variety of other objects, depending on the 
settings in the Dimension Defaults dialog. See Locate Interior Panel on page 328.         

POINT TO POINT DIMENSIONS

The Point to Point Dimension tool creates dimension lines that locate an eligible object at their start and end points 
if possible. If no object is present at either location, a Point Marker is created and the dimension line locates it 

instead. See Markers on page 368.         

Point to Point Dimensions can be drawn in either of two ways:         

 l When the Default  edit behavior is active, a Point to Point Dimension places Point Markers at its start and end 

points, which it locates. Any objects along the dimension line’s length are ignored. See Point Markers on page 201.         
 l When the Alternate  edit behavior is active, a Point to Point Dimension locates objects along its length as well as 

objects or Point Markers at its start and end. See Defaults, Preferences, and Edit Behaviors on page 138.         

The Point Markers created by the Point to Point Dimension tool can be selected and edited. See Editing Markers on page 
368.         

Point to Point Dimensions locate walls and a variety of other objects depending on the settings in the Dimension Defaults 
dialog. See Locate End to End Panel on page 328.   

TAPE MEASURE

Use the Tape Measure tool to draw a temporary dimension line between any two points in the drawing area. The 
tool will place temporary markers at the start and end points of the dimension line. The Tape Measure line and its 

start and end points all disappear when you release the mouse button. If Object Snaps  are enabled and an object is 

located by the temporary line, you can snap to it.

DELETE DIMENSIONS

The Delete Dimensions  tool deletes all dimension lines displaying in the current view in a plan file. In a layout file, 

dimensions that currently display on all pages are deleted. See Deleting Dimension Lines on page 337.

 

Automatic Dimensions
These tools automatically create dimension lines in plan view for different purposes:

The manually drawn Dimension tools can also be used to draw 
dimensions in plan and cross section/elevation views. See The 

Manually Drawn Dimension Tools on page 331.

TEMPORARY DIMENSIONS

Temporary Dimensions display automatically when an object is selected and report the distance between that 
object’s selected edge and other objects. Select View> Temporary Dimensions to turn on or off the display of 

Temporary Dimensions. This toggle affects all views and is saved between launches of Home Designer.
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A Temporary Dimension will only display when an object is selected, and as with other dimension lines, it will only locate 
objects that are parallel or nearly parallel to one another. Temporary Dimensions will also locate the endpoints of CAD lines 
and the corners of objects located past the end of the selected edge, within 4 feet (1200 mm) of the point where you click to 
select the object.

AUTO EXTERIOR DIMENSIONS

The Auto Exterior Dimensions tool generates dimensions around a plan’s exterior in plan view, locating walls and 
openings as specified in the Dimension Defaults dialog.

Up to three rows of automatically generated dimensions may be created per exterior wall:

 l The innermost dimension line locates exterior walls, interior walls, and all openings in exterior walls.
 l The second dimension line locates exterior and interior walls.
 l The outermost dimension line is the overall exterior dimension.

Auto Exterior Dimensions do not generate properly if there is a 
gap in the exterior walls or if they do not connect properly. If 

automatic dimensions do not generate, try Build> Wall> Fix Wall 
Connections.

If you edit an Auto Exterior Dimension  line, it will be converted to a manual dimension, so if Auto Exterior 

Dimensions are later regenerated, your changes will not be lost.

AUTO ROOM DIMENSIONS

Select one or more rooms in plan view and click the Auto Room Dimensions edit button to generate interior 
dimensions that measure each wall defining the selected room(s).

Auto Room Dimensions lines are generated inside the rooms they measure and locate walls and wall openings, as well as 
other objects, as specified in the Dimension Defaults dialog. See Locate Auto Room Panel on page 328. 

Auto Room Dimensions do not recognize the No Locate setting for walls. If a wall is specified as No Locate, Auto Room 
Dimensions will locate it anyway. See No Locate on page 251.

 

Displaying Dimension Lines
The display of dimension lines is controlled in the Layer Display Options dialog. See Displaying Objects on page 
123. 

Dimension lines created by any of the dimension tools share the same components:

 l Dimension Lines run parallel with the distance being measured.
 l Extension Lines are perpendicular to dimension lines, indicating what they locate. If a dimension line locates more 

than two objects, extension lines divide the dimension line into segments. 
 l Arrowheads display at the intersections of dimension and extension lines.
 l Dimension Labels display at the midpoint of dimension line segments and indicate the distance that each segment 

measures.
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EXTENSION LINES

If a dimension line is offset from the objects it locates, extension lines help clarify exactly what is being located. Extension 
lines are numbered: when a dimension line is selected, an Extension Line Number displays at the end of each extension line.
         

You can specify the default length of extension lines in the Dimension Defaults dialog. See Extensions Panel on page 330.         

Once drawn, the appearance of extension lines can be edited. See Editing Extension Lines on page 338.         

DIMENSION LABELS

Manually drawn, automatic, and temporary dimension labels use the Text Style specified in the Dimension Defaults dialog. 
Unlike many objects that use Text Styles, by default dimensions use a Text Style specified in the defaults dialog rather than 
the Text Style assigned to their layer. See Text Style Panel on page 373. 

Like other text, dimension labels are subject to scaling. For 
example, A Character Height of 6” prints a 1/8” tall number at 

1/4” = 1’ scale. A Character Height of 125 mm prints a 3 mm tall number 
at 1 m = 50 m scale. See Printing Text, Dimensions, and Line Styles on 
page 994.

By default, dimension labels have a solid fill that is the same as the Background Color set in the Preferences dialog. You 
can instead specify that labels use a Text Style with a transparent fill.   

You can also specify the minimum size of Temporary Dimension numbers displaying on screen in the Preferences dialog. 
See Appearance Panel on page 63.         

Labels can be centered on dimension lines or located either above or below them. See Format Panel on page 328.

Dimension labels have their own edit handle and can be moved when a dimension line is selected. See Editing Dimension 
Lines on page 336.

DIMENSION ARROWHEADS

You can specify the style, color and size of  dimension arrows in the Dimension Defaults and Dimension Line Specification 
dialogs. See Arrow Panel on page 226. 

The arrow at the end of a dimension line will not display if it is close enough to another dimension arrow that the two will 
overlap. A typical example of this is where two sections of an Interior Dimension locate two sides of an interior wall.   

DIMENSIONS IN CAMERA VIEWS

In plans created in Chief Architect Premier, saved cameras may include one or more dimension lines. These dimension lines 
cannot be selected, edited, or deleted in Home Designer Pro; however, you can turn off the display of the 
"Dimensions" layer in camera views. See Opening Chief Architect Plans in Home Designer Programs on page 33.

 

Selecting Dimension Lines
Before a manually-drawn or automatic dimension line can be edited, it must be selected. A dimension line can be selected in 
one of three ways, each of which affects the ways that the dimension line can then be edited.         
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The standard way to select an individual dimension line is to click anywhere along its length when the Select Objects  

or any of the Manual Dimension  tools is active. When selected in this manner, the dimension line’s full range of 

editing options are available.          

You can instead click on one of the dimension line’s extension lines. When selected in this way, the selected extension 
line’s length can be edited; however, fewer edit handles are available overall. See Editing Extension Lines on page 338.          

If you select an extension line by mistake, press the Esc key to 
display the full set of dimension line edit handles. 

Dimension lines can also be group-selected, with limited editing options. See Selecting Multiple Objects on page 145.          

 

Editing Dimension Lines
Before a dimension line can be edited, it must be selected. See Selecting Dimension Lines on page 335.         

With the exception of Temporary Dimensions , dimension lines can be selected and edited using the mouse, the Edit 

Toolbar buttons, and the Dimension Line Specification dialog. See Dimension Line Specification Dialog on page 343.

If an Auto Dimension line is edited, it will no longer be considered an automatic dimension line and will not be deleted and 
replaced the next time the tool used to create it is used.

For information about changing the value reported in a dimension line label, see Moving Objects Using Dimensions on page 
341.   

USING THE EDIT HANDLES

When a dimension line is selected, its edit handles can be seen. There are five types of dimension line edit handles. The 
total number of edit handles a dimension line has depends on how many extension lines it has.  

 A.  The Extension Line End handles are positioned at the point that each extension line locates and are used to move or 
delete extension lines. See Moving an Extension Line on page 339.

 B.  The Add Extension Line handle displays to the side of the Move handle and is used to add extension lines to the 
dimension line. Extension lines added in this manner are able to locate marks that the dimension line might not 
locate as it was being drawn. See Adding an Extension Line on page 338.

 C.  The Move handle is located where you clicked to select the dimension line and displays the Selected Edge Handle 
Fill color. It is used to move the entire dimension line, including any subsections, perpendicular to itself. Extension 
lines are resized as appropriate. The pointer changes to a two-headed arrow   when moved over this handle.

 D.  The small, square Move Dimension Label handle is located at the center of the selected label. Use this handle to 
move the dimension number for each dimension line section. The pointer changes to a  four-headed arrow   when 
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moved over this handle. When Object Snaps are enabled, dimension label centers will snap to their associated 
dimension line.         

 E.  The Rotate handle is located past the end of the dimension line and can be used to rotate the dimension line.

A selected Angular Dimension has only one edit handle. When you click and drag this handle, the selected Angular 
Dimension will move. Its length will increase or decrease concentrically depending on which direction it is moved, and the 
location of its arc center will be maintained.

As a selected dimension line is resized, it's drawing behavior and the objects it locates may vary, depending on the 
Dimension Tool that was used to create it. When selected, Interior Dimensions are described as such in the Status Bar. See 
The Status Bar on page 24.

USING THE EDIT TOOLS

Dimension lines can be repositioned, copied, and deleted using the Edit Toolbar buttons just like other objects in the 
program can. See The Edit Toolbar on page 92. 

Click the Edit Extensions  edit button to edit the lengths of the selected dimension’s extension lines. See Editing 

Extension Lines on page 338.         

DIMENSION NUMBER SIZE

The initial size of dimension numbers is specified in the Dimension Defaults dialog. See Dimension Defaults Dialog on 
page 322. 

You can specify number height for individual dimension lines in the Dimension Line Specification dialog. See Dimension 
Panel on page 344.

As with text and other objects, dimension number size is subject to scaling when sent to layout or printed. See Printing Text, 
Dimensions, and Line Styles on page 994.

COPYING AND PASTING DIMENSION LINES

Dimension lines can be copied and pasted into any view type that supports dimensions. If a dimension line is copied 
independent of the objects it originally locates, the pasted dimension line will locate Point Markers. See Point Markers and 
Dimensions on page 369.

DELETING DIMENSION LINES

There are several ways to delete dimension lines: 

 l Select any manual or automatic dimension line or group of dimension lines, then press the Delete key or click the 
Delete  edit button. See Deleting Objects on page 191.

 l Select CAD> Dimensions> Delete Dimensions  to delete all dimension lines displaying in the current view in a 

plan file. In a layout file, dimensions that currently display on all pages are deleted.
 l The Delete Objects dialog allows you to delete all manually drawn and/or automatic dimension lines in all plan views 

using one of three scopes. In a layout file, dimensions can be deleted on the current page or on all pages. See Delete 
Objects Dialog on page 192.

Automatically generated dimension lines may be set to Auto Refresh in the Dimension Defaults dialog. When deleted in 
plan view, you will be prompted to turn off the Auto Refresh functionality. See Automatic Dimensions on page 333.
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Individual dimension line segments located between extension lines can also be deleted. If a segment is located between two 
other segments along the same dimension line, that dimension will be broken in two.

To delete a portion of a dimension line

 1.  Select any Dimension Tool aside from Angular or Auto Exterior Dimensions.

 2.  Manually draw a dimension line over the segment that you wish to remove, dragging from extension line to 
extension line.

 

Editing Extension Lines
Before extension lines can be edited, either they or their dimension line must be selected. See Selecting Dimension Lines on 
page 335.         

Extension lines can be added, edited, and deleted using the edit handles when their dimension line is selected. In addition, 
extension lines can be individually selected and edited.

Extension lines are also affected by settings in the Dimension Line Specification dialog. See Extensions Panel on page 345.         

ADDING AN EXTENSION LINE

The Add Extension Line edit handle allows you to locate marks that the dimension line might not have been able to locate 
as it was being drawn. Interior Dimensions, for example, do not locate cabinets as they are drawn; however, you can add an 
extension line that locates a cabinet.

To add an extension line

 1.  Select the dimension line anywhere along its length.

 2.  Click the diamond-shaped Add Extension Line edit handle which displays near the Move edit handle. The pointer 
changes to a two-headed arrow  .

 3.  Drag the handle to the object that you want to locate with a new extension handle. This example adds an extension 
line to the left side of the window. 

 4.  Release the mouse button to add an extension line.

338



Home Designer Pro 2025 Reference Manual - Editing Extension Lines

MOVING AN EXTENSION LINE

Extension lines can be moved to locate the centers, sides, or surfaces of most objects. Here, an extension line is moved from 
the windows edge to the center.

To move an extension line

 1.  Select the dimension line anywhere along its length: do not click on the extension line itself.

 2.  Click the Extension Line edit handle. The pointer changes to a two-headed arrow  .

 3.  Drag the handle to a new location. The extension line snaps to possible marks as the handle is moved.

 4.  Release the mouse button at the new location.
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Not all library symbols can be located by a dimension line as it 
is drawn. Once a dimension is drawn, however, you can move or 

add an extension line to locate the library object.

DELETING AN EXTENSION LINE

When an extension line is deleted, the remaining dimensions update. If a dimension line has only two extension lines, they 
cannot be deleted.

To remove an extension line

 1.  Select the dimension line anywhere along its length: do not click on the extension line itself.

 2.  Click the Extension Line edit handle. 

 3.  Drag it perpendicular to the direction of the arrows, away from any dimensionable object, and release the button 
when the extension line disappears.

In addition, individual extension lines can be selected, allowing you to resize them.         

RESIZING EXTENSION LINES

You can resize extension lines in the Dimension Line Specification dialog or using their edit handles. See Extensions Panel 
on page 330.         
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To resize an extension line

 1.  Click on the extension line or select the dimension line and click the Edit Extensions  edit button to display two 

handles along the extension line.         

 2.  Click either handle, turning the pointer into a two-headed arrow  .         

 3.  Extend or contract the extension line and release the mouse.         

USING FIXED PROXIMITY

The Fixed Proximity option allows you to specify a fixed length for one extension line that will not change if the object the 
extension line locates is moved.         

To use Fixed Proximity

 1.  Select a dimension line that locates multiple independent objects and note the Extension Number of the extension 
line that you would like to have a fixed length.         

 2.  Open the Dimension Line Specification dialog and go to the EXTENSIONS panel. See Extensions Panel on page 345.         

 l Select the Extension Number that you  noted in step 1 from the Selected Extension drop-down list.          

 l Check Fixed Proximity.          

 l Specify the desired Distance to Marked Object, which is the distance from the selected dimension line to the 
object that the Selected Extension locates. This distance includes the Gap From Marked Object.          

 l Click OK.          

To see how Fixed Proximity works, select the object that the extension line with Fixed Proximity specified and move it.  
Notice that the dimension line moves in response and that all extension lines’ lengths adjust except for the one with Fixed 
Proximity specified.         

 

Moving Objects Using Dimensions
Most objects can be moved by changing an automatic, manual, or temporary dimension value that locates it. This technique 
can be applied in nearly any situation where dimensions are present, including angular dimensions. See Moving Objects on 
page 167.

In addition, some objects can be resized using dimensions. See Resizing Objects on page 173.

Your pointer indicates which dimensions can be used to relocate the selected object by changing to a pointing hand   icon. 

Another way to tell is to select an object and drag it in the desired direction. As you drag, note which dimensions update. 
These dimensions are the dimensions that can be used to move that object. 

Note: A selected object can be moved and resized using a dimension line 
even when that dimension’s layer is locked. See Locking Layers on page 
126.

341



Home Designer Pro 2025 Reference Manual - Moving Objects Using Dimensions

To move an object using dimensions

 1.  Select the object and click on a dimension line that locates it. An inline text field opens at the location where you 
clicked. 

 l The actual distance displays in the text field. 

 l If the dimension is locating two different objects and the selected object is polyline-based, the Move Edge and 
Move Entire Object buttons display to the right of the text field. 

 l If the dimension describes a selected wall’s length, additional buttons display to the right. See Moving Walls Using 
Dimensions on page 250.

 2.  Click the Move button of your choice. 

 3.  Enter a new value in the text field. 

 l To use a different unit, include its indicator after the value.    

 l To move the selected object past a second object, to its opposite side, enter a negative value. 

 l Basic math operations can also be performed in the inline text box, just as they can in dialogs. See Units and Math 
Operations in Dialogs on page 19.

 4.  The selected object moves or resizes when you press the Enter key or click outside the text field. 

 5.  If Bumping/Pushing  is enabled, the object being moved will bump into any objects in its move path and not 

move the entire distance. Hold down the Ctrl/⌘  key when you press the Enter key to override this move restriction. 
See Bumping/Pushing on page 168.         

A variety of polyline- and box-based objects can also be resized using dimensions.

To resize an object using dimensions

 1.  Select the object along the edge that you would like to move. See Selected Edge on page 143.

 2.  Click on a dimension line that indicates its distance from the object’s opposite side. 

 3.  In the inline text field, enter a value. 

 4.  Click Move edge to move the selected edge only. 

 5.  The selected edge moves, resizing the object, when you press the Enter key. 

You can cancel a move or resize operation using dimensions at 
any time by pressing the Esc key.

RESIZING WALLS USING EXTERIOR DIMENSIONS

When resizing a structure using dimensions, it is important to work your way around it in one direction. Relocate one wall 
at a time in succession so that you do not redefine the same dimension more than once. 

For more information, see Measuring Walls on page 248. 
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USING ANGULAR DIMENSIONS

Angular Dimensions are useful for adjusting the angles of polyline-based objects and walls.         

To change an angular dimension

 1.  Draw an CAD> Dimensions> Angular Dimension , then click and drag to draw an arc within the angle you 

wish to measure.         

 2.  Select the edge that you want to move.         

 3.  Click the dimension value to open the Set Angular Dimension dialog.         
The Set Angular Dimension dialog reports the Previous Value in degrees, minutes and seconds.

 4.  Enter a value in the New Value field.         

 5.  Specify what you want to rotate:         

 l Select Rotate edge to move the selected edge when you click OK, or          

 l Select Rotate entire polyline to rotate the entire object about the corner formed by the edges that the Angular 
Dimension locates, maintaining the previous value of that angle.          

 6.  Click OK to apply the change.         

 

Dimension Line Specification Dialog
To open the Dimension Line Specification dialog, select one or more dimension lines and click the Open Object edit 
button.   

The settings in this dialog are dynamic defaults. See Dimension Defaults Dialog on page 322. 

The Dimension Line Specification dialog has the following panels:
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DIMENSION PANEL

 
Options

Specify the text size and display of wall widths attributes for the selected dimension line. The minimum on-screen size can 
be set in the Preferences dialog. See Appearance Panel on page 63.             

 l Specify the Number Height of the selected dimension's labels. See Dynamic Defaults on page 58.

Dimension Number Height is subject to scaling. See Scaling 
Text on page 359.

 l Uncheck Display Wall Widths to suppress those portions of the dimension line that measure between two surfaces 
of the same wall. Both sides of a wall may still be located, but its width will not display. This option is checked by 
default for most manually drawn dimensions, but is unchecked for Interior Dimensions .    

 
Rounded Value Indicators

Specify the use and appearance of Rounded Value Indicators, which can display when the degree of accuracy in use is not 
sufficient to describe a dimension’s true value.         

 l Check Use Default to use the default indicator(s). Uncheck this box to make the options that follow active.         

 l Check + or - After Number to indicate that the actual dimension value is higher or lower than the value shown.         

 l Check ~ Before Number to indicate dimension values that are not accurate with the ~ symbol.         

DIMENSION PANEL FOR ANGULAR DIMENSIONS
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 l Specify a Number Height for the selected dimension. See Dynamic Defaults on page 58.

 
Use Default Angle Style

When this box is checked, the selected dimension uses the angle style set in the Dimension Defaults dialog. Uncheck this 
box to select a different Angle Style and number of Decimal Places. See Format Panel on page 328.

EXTENSIONS PANEL

The settings on the EXTENSIONS panel allow you to edit the selected dimension line's extensions. See Editing Extension 
Lines on page 338.

This panel is not available for multiple dimensions selected as a group or for Angular Dimensions .         

Opening this panel will turn off Legacy Compatible Extensions 
if it is enabled in the Dimension Defaults dialog. See Extensions 

Panel on page 330.

 
Extension Lines

An editable table lists the selected dimension line's extensions here. Initially, the extension closest to the point where you 
clicked to select the dimension line will be highlighted. The highlighted extension line is selected and can be edited.    

Each extension line’s number displays beside it when a 
dimension line is selected. See Displaying Dimension Lines on 

page 334.     

 l Click on a line item to select and edit it. The Properties for Selected Extension are listed and can be edited using 
the settings below.     

 l The available Extension Length and Marker Style settings can also be edited in the table. The available options 
depend on which Extension Length option is selected below.
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 l Only available in the table, click in the Fixed Proximity column to specify a fixed distance between the marked 
object and the dimension line. You can only fix the proximity for a single extension line. See Using Fixed Proximity 
on page 341.     

 l When Fixed Proximity is checked, specify the Distance to Marked Object, which is the distance from the 
dimension line to the marked object, using a positive value.

  The Properties for Selected Extension options allow you to edit the Extension Line selected in the table above.

 
Extension Length

These settings are the same as those in the Dimension Defaults dialog, but apply to the extension lines associated with the 
selected dimension line only.  See Extensions Panel on page 330.         

 l Uncheck Use Default to enable the three settings that follow as well as the equivalent fields for the selected line 
item in the table above. 

 l Check Use Default to restore the default settings to the Selected Extension line.

 l Specify the Length Away From Marked Object, which is the length of the portion of an extension line that 
extends from the dimension line in the opposite direction of the object it locates.      

 l Select Length Towards Marked Object to specify a fixed length for the portion of an extension line that extends 
from the dimension line toward the object it locates. If the dimension line is moved, this length remains the same 
but the size of the gap updates.     

 l Select Gap From Marked Object to specify the distance between the end of extension lines and their marked 
location in plan inches or mm. If a dimension line is moved, extension lines update, and the size of this gap is 
maintained.    

ARROW PANEL

For information about the settings on this panel, see Arrow Panel on page 226.
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Chapter 14
 

Text, Callouts, and Markers

The Text Tools help you draw attention to special details of your drawings. Text objects can be added in plan view, in cross 
section/elevation views, and to layout pages.

TOPICS

Text Defaults and Preferences 348
Fonts and Alphabets 349
The Text Tools 350
Creating Text Objects 351
Displaying Text Objects 352
Rich Text Specification Dialog 352
Editing Text 357
Copying and Pasting Text 360
Find/Replace Text 361
Text Arrows 362
Callouts 364
Callout Specification Dialog 366
Markers 368
Marker Specification Dialog 369
Callout Panel 372
Text Styles 373
Object Labels 375
Label Panel 376
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Text Defaults and Preferences
Text Defaults can be accessed by selecting Edit> Default Settings in any view in which text can be created. Click 
the "+" next to Text, Callouts and Markers to display the sub-headings. See Default Settings vs Preferences on 

page 57.          

The default settings for Rich Text, Callouts, Markers, and Arrows determine what these objects look like when they are first 
created. Text Style Defaults determine the appearance of text associated with things like dimensions and object labels.          

Changes made to default settings do not alter existing text objects, so it is a good idea to go over these settings before 
placing text.           

TEXT STYLE DEFAULTS

Select “Text Style” from the list in the Default Settings dialog and click the Edit button to open the Saved Text Style 
Defaults dialog.             

The Text Style Defaults dialog allows you to specify the attributes of the various Text Styles in use in the current file. See 
Text Styles on page 373.         

RICH TEXT DEFAULTS

Double-click the Rich Text  to open the Rich Text Defaults dialog and specify the default appearance of Rich Text 

objects.          

The Rich Text Defaults dialog is similar to the Rich Text Specification dialog. See Rich Text Specification Dialog on page 
352.         

Text Lines with Arrows use the same default layer as Rich Text, so by default they have the same color, line weight and 
line style. See Layers on page 124.         

CALLOUT DEFAULTS

Double-click the Callout  tool to open the Callout Defaults dialog and specify the default appearance of callouts.          

The Callout Defaults dialog looks almost the same as the Callout Specification dialog. See Callout Specification Dialog on 
page 366.

MARKER DEFAULTS

Double-click the Marker  tool to open the Marker Defaults dialog and specify the default appearance of markers.         

The Marker Defaults dialog looks almost the same as the Marker Specification dialog. See Marker Specification Dialog on 
page 369.

ARROW DEFAULTS

Double-click the Text Line with Arrow  tool to open the Arrow Defaults dialog.         

The settings in the Arrow Defaults dialog determine the initial settings for arrows drawn using the              Text Line with Arrow 
 and Line With Arrow tools. These settings also determine the initial appearance of arrows when they are added to 

CAD lines, arcs, and polylines.
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The Arrow Defaults dialog looks almost the same as the ARROW panel of the Line Specification dialog. See Arrow Panel on 
page 226.          

Avoid typing any text in any text Defaults dialog unless you 
want it to be present in all text objects you create.

PREFERENCES

Specify whether pressing the Enter key creates a new line of text or closes the Rich Text and Text Specification 
dialogs in the Preferences dialog. See Text Panel on page 68.

 

Fonts and Alphabets
Home Designer allows you to use any font found in your computer’s Fonts directory.         

For best printed results, using true-type or open-type fonts is recommended.         

CHIEF BLUEPRINT FONT

The Chief Blueprint font is installed in the Windows Fonts directory when Home Designer is installed.         

On Mac systems, this font is embedded with the Home Designer Pro 2025 installation but not installed on the system. As 
such, it is available for use in Home Designer Pro 2025 but not in other programs.         

INTERNATIONAL ALPHABETS

The Rich Text  tool supports unicode alphabets and characters. In order to use a unicode alphabet or characters, the 

appropriate language support must be installed on your computer. See The Text Tools on page 350.         

Special characters can be added to any Rich Text  object by:         

 l Copying and pasting the character from another application;         
 l Copying and pasting the character from the Windows Character Map;         
 l Using the Mac Character Viewer;         
 l Typing the keystroke associated with the character.         

See Copying and Pasting Text on page 360. 

CHARACTER SIZE

Rich Text , Text , Callouts , Markers , Plant Schedules , and dimension numbers can be sized to 1/128” 

accuracy (0.078125 mm). See Text Style Panel on page 373.          

These objects use CAD Style Font Sizing, which specifies text size as the measurement from the baseline to the topmost 
part of the capital letter A, as in most CAD programs.         

In legacy files migrated into Version 2025, an additional Legacy Compatible Size option will be available for some objects 
if it was specified in the original program version. When this method is used, text size is based on information stored in the 
font that is then modified to approximate the specified Character Height.         

Rich Text  objects have two font sizing methods to choose from: CAD Style Font Sizing and a method similar to most 

word processing applications, where size is based on information stored in the font. See Options Panel on page 356.         
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REPLACE FONTS

Select Edit> Replace Fonts to replace one or more fonts in the current file with a different font using the Replace 
Fonts dialog.

The Replace Fonts dialog will also open if you open a plan or layout file that uses a font that is not installed on the current 
computer, giving you an opportunity to replace that font. 

The table lists all fonts in the current file and how they will be replaced. 

 l Click on a font name in the list to select it. Use the Shift or Ctrl/⌘  key to select multiple fonts. See Shift and Ctrl/⌘  
Select on page 146. 

 l Select a replacement font from the Replace With drop-down list, or leave “No Change” as the selection to maintain 
the file’s association with the missing fonts. 

 l A preview of the selected font displays below the Replace With list.

If this dialog opens in response to missing fonts and you do not plan to return the file to the computer where it was created, 
you may want to replace missing fonts with the fonts you normally use. On the other hand, if you do intend to return the 
file, you may prefer to not replace any missing fonts. 

 

The Text Tools
Select CAD> Text to access the Text Tools. These tools are available in plan view, in cross section/elevation views, 
and in layout files.         

  The Rich Text tool is used to create text objects. See Creating Text Objects on page 351.             

  The Text Line with Arrow tool is used to connect text and another object with an arrow. See Text Arrows on 
page 362.             

  The Text with Arrow tool places a Rich Text object with an arrow attached.             

  The Callout tool is used to place callouts. See Callouts on page 364.             

  The Marker tool is used to place markers for Level Lines, Test Borings and Point Markers. See Markers on 
page 368.             
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Creating Text Objects
Text, callouts and markers can be created in plan view, in cross section/elevation views, and on layout pages. See View 
Windows on page 103. 

Once created, text, callouts and markers can be selected and edited in a variety of ways. See Editing Text on page 357. 

To create Rich Text

 1.  Select CAD> Text> Rich Text . 

 2.  Click in the drawing area, and the Rich Text Specification dialog will open. See Rich Text Specification Dialog on 
page 352.             

 3.  Type or paste the desired text into the Text Field.

 4.  Use the options in the dialog to change the font, style and size of any portion of the text. See Editing Text on page 
357.

 5.  When you are finished, click OK. The Text  tool remains active, so you can create additional text objects if you 

wish.             

Note: If you do not type anything in the Text Field, a text object will not 
be created when you click outside it.

Rich Text , Callouts ,              and Markers  can also be created              by clicking where you want the upper left corner of the 

object to be created. The object’s specification dialog will open: enter text and click OK.         

You can also create lines with arrows connecting the text that you create to items in the drawing. See Text Arrows on page 
362. 

PLACING TEXT FROM THE LIBRARY

Rich Text, Callouts, and Markers can be added to the User Catalog in the Library and then placed into plans and 
layout files as needed. See Add to Library on page 709 and    Replace From Library on page 717.         

TEXT AND CAD OBJECTS

Text can be used in combination with CAD objects to create legends, title blocks, and a wide variety of other details. See 
CAD Objects on page 197 and Layout on page 970.          

HYPERLINKS

Hyperlinks that link to web pages both in the views they are created in as well as when printed to PDF can be added 
to Rich Text objects in their specification dialogs. See Text Panel on page 352.

To open a link in Home Designer, select a Rich Text object, then mouse over the text in the selected object. If the mouse 
pointer displays a pointing hand   icon, the Status Bar will report the address that it links to, and you can click once to 
open the link in your default web browser.
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Displaying Text Objects
As with other types of objects, the display of Text objects is controlled in the Layer Display Options dialog.  Text objects are 
located on layers with “Text” at the beginning of the layer name, such as “Text, Callouts”. See Layer Display Options 
Dialog on page 127. 

Text objects can only be displayed in views where text can be created. 

The display attributes of each individual text object can be controlled independent of the layer it is placed on. See Rich Text 
Specification Dialog on page 352. 

 

Rich Text Specification Dialog
The Rich Text Specification dialog opens if you select one or more Rich Text objects, then click the Open Object 
edit button.

This dialog also opens when you select the Rich Text  tool and then click once in the drawing area. 

When Rich Text objects are group-selected, the text content, zoom factor, and Paragraph Options cannot be changed, but 
everything else can be. 

The Rich Text Specification dialog is similar to the Rich Text Defaults dialog but affects the selected text rather than all 
subsequently created text objects. See Text Defaults and Preferences on page 348.         

TEXT PANEL

The settings on the TEXT panel allow you to type the selected Rich Text object’s content and control many aspects of its 
appearance, including its font, size, color and style.

You can specify the appearance of the text before typing, and can also select and change the attributes of all or portions of 
the text content after it is typed. To change text that already exists, simply highlight it using the mouse and/or the Shift + 
arrow keys and then make any needed changes to its attributes. 

Note: If you do not type anything in the text field on this panel when 
creating a new object, no object will be created when you click OK. On 
the other hand, if you remove the text from an existing object and click 
OK, an empty text box will result.

 
Edit Bar

Use the options on the Edit Bar, which displays above the Text Entry field, to change the font, size, and style of the text.             
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Select the desired options before typing to affect the text as it is typed, or select some or all of the text and then specify 
which options to apply to it.

 l Select a Font from the drop-down list.    

 l Specify the Text Size in drawing units.    

 l Click the Print Size  button to open the Printed Size Input dialog. See Scaling Text on page 359.           

 l Click the Color  button to specify the color of the selected or subsequently typed text. See Select Color Dialog 

on page 135. If Layer Color Text is checked on the APPEARANCE panel, any custom colors specified here are lost. 
See Appearance Panel on page 355.

 l Click the Insert Hyperlink  button to insert text that links to a web address or edit an existing selected hyperlink. 

See Hyperlinks on page 351 and Insert Hyperlink Dialog on page 354, below.

Note: Hyperlink text is automatically underlined and assigned a non-
default blue color. Once created, though, it is editable. To remove a 
hyperlink, select the linked text, right-click, and select Remove 
Hyperlink from the contextual menu.    

 l Click the Bold  button to specify the selected text as bold. The Ctrl/⌘  + B hotkey can also be used.    

 l Click the Italic  button to specify the selected text as italic. The Ctrl/⌘  + I hotkey can also be used.    

 l Click the Underline  button to specify the selected text as underlined. The Ctrl/⌘  + U hotkey can also be used.    

 l Click the Strikethrough  button to specify the selected text as stricken-through.    

 l Click the Uppercase  button to display the selected text in all capital letters.    

 l Click the Align Left , Align Center , or Align Right  button to specify how the selected text is aligned.    

 l Click the Paragraph Options  button to specify the selected paragraph’s alignment, spacing and bullets or 

numbering in the Paragraph Options dialog.    

 l Specify the Zoom factor of the selected text by typing a percentage value in the text field or clicking the up/down 
arrows. This setting only affects the text as it appears in this dialog.

Note: Some fonts cannot be drawn at certain zoom factors. When this 
is the case, the appearance of the text will not change.

 
Text Entry Field

Type or paste text in the Text Entry field. See Copy, Cut and Paste on page 360.   

 l Depending on the current Preferences  settings, pressing the Enter key either forces a new line in the text box or 

closes the dialog. A carriage return can also be added by typing Shift + Enter or Ctrl/⌘  + Enter. See Text Panel on 
page 68.          

 l Right-click in the Text Entry field to access a contextual menu from which you can select Undo, Redo, Cut, Copy, 
Paste and Select All. See Contextual Menus on page 18.   
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 l To edit text in the entry field, click and drag to highlight any portion of it and then use the tools on the Edit Bar as 
needed.   

INSERT HYPERLINK DIALOG

 
Text

Specify the text of the hyperlink that the reader will see.

 l If any text in the Rich Text Specification dialog is selected or if the cursor is located within an existing hyperlink 
when you click the Insert Hyperlink  button, it will populate the Text field. If you change this initial text, the 

selected text in the Rich Text Specification dialog will update when you click OK and return to that dialog.

 l If no text is selected but the cursor is located within an existing hyperlink when you click the Insert Hyperlink 
 button, that hyperlink will essentially be selected: its text will populate the Text field and its address will 

populate the Address field.

 
Address

Specify the address, or URL, of the page that the link will access.    

 l If the Address field is empty when you click OK, the hyperlink will be removed.

PARAGRAPH OPTIONS DIALOG
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Alignment

Specify the Alignment of the selected paragraph(s). See Aligning Text on page 359.

 
Line Spacing

Specify the Line Spacing of the selected paragraph(s). 

 l Click the radio button beside Single, 1.5 Lines, Double or User Specified.

 l If you select User Specified Line Height, type the desired height in the text field. For best results, this value should 
be at least as much as the largest text size used in the selection. 

 
Margins

Specify the appearance of the selection’s side Margins, as measured in from edges of the text box. Only positive Margin 
values can be used. 

 l Specify the Indent, which is measured from the left side margin. A negative value can be used if a left Margin has 
been specified.

 
Bullets

Specify the appearance of Bullets and numbering in the selection. 

 l Select the desired bullet, numbered, or lettered Type from the drop-down list.

 l Specify the Number Prefix, which are any characters that you would like to display before the number or letter. 
Does not affect paragraphs using circle or square bullets.

 l Specify the Number Suffix, which are any characters that you would like to display after the number or letter and 
before its actual text. Does not affect paragraphs using circle or square bullets.

APPEARANCE PANEL

Text Lines with Arrows  use the same default layer as Rich Text, so they share the same default color, line weight and 

line style. See Layers on page 124.         
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Border

 Check Border to display a border around the selected text object and enable the settings that follow.         

 
Fill

Check Fill to display a fill color within selected text object(s) and enable the settings that follow.         

 l Select Custom Color then click the Color bar to use a fill color of your choosing.             

 l Check Use Layer Color to use the color assigned to the text object’s layer as its fill color.             

 l Check Use Background Color to use program’s Background color as the text object’s fill color. See Colors Panel 
on page 65.             

 l Use the Transparency slider bar or text field to control how transparent the fill color is.             

 
Margins

Specify the Top, Bottom, Left, and Right Margins, which are the distance between the text and the border of the selected 
text object(s).         

OPTIONS PANEL

  Options

 l Check Add an Arrow to add a Text Arrow to the selected text object. It will be attached to the left side of the 
selected object if the text is set to Align Left, or to the right side if it is set to Align Right or Align Center. See Text 
Arrows on page 362.          

 l Check Rotate with Plan to rotate the selected text when Rotate Plan View  is used. If unchecked, the selected 

text is unaffected when Rotate Plan View is used. See Rotate Plan View on page 104. 

Rotate with Plan also affects text in views sent to layout if the layout box is rotated. See CAD and Text in Layout 
on page 972.           
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  Origin/Angle

 l Specify the X Position and Y Position of the selected object relative to the origin. See 3D Drafting on page 12.           

 l Specify the Angle of the selected text object. The default value is 0°.          

 
Size

Specify the Size of the selected text object.         

 l Specify the Height of the selected text object(s) or check Auto Height to automatically adjust the text object’s 
height to match its contents.          

 l Specify the Width to of the selected text object(s) or check Auto Width to automatically adjust the text objects 
width to match its contents. When Auto Width is used, text extends in a single line rather than wrap.          

 l CAD Style Font Sizing measures text size based on the total height of the capital letter A, as most CAD programs 
do. Uncheck this to instead size text according to information stored with the font, as most word processing 
programs do. See Character Size on page 349.           

 
Bumping

See Bumping/Pushing on page 168.         

 l Check CAD Stops Move to bump the selected object into other CAD or CAD-based objects as it is moved.          

 l Check Wall Stops Move to stop the selected object when it bumps into a wall.           

 

Editing Text
Once created, Rich Text  objects can be selected individually or as a group and edited using the edit handles, the Edit 

Toolbar buttons, and their specification dialogs. See Rich Text Specification Dialog on page 352.

A customized text object can be added to the Library for future 
use. See Add to Library on page 709.

Text objects can be edited using a variety of methods:         

Callout and Marker editing are described separately. See Editing Callouts on page 365 and Editing Markers on page 368.         

EDITING TEXT ATTRIBUTES

Most text attributes, including the font, size, style, and the content itself, are edited in the Rich Text Specification dialog.

In order to edit the attributes of an existing Rich Text object, you must select some or all of the text before making changes. 
See Text Panel on page 352. 

To edit Rich Text attributes

 1.  Select a Rich Text object and click the Open Object  edit button.

 2.  On the TEXT panel of the Rich Text Specification dialog, click and drag to select some or all of the text typed into 
the Text field. 
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 3.  With some or all of the text selected, change any of the attributes available along the top of the panel, including the 
font, size, color, and style.

 4.  As changes are made, the selected text updates. Only the selected text is modified.

USING THE EDIT HANDLES

A selected Text object has the same edit handles as other box-based objects. See Editing Box-Based Objects on page 160.         

As a text box’s width is made narrower or wider using an edit handle, its height may increase or decrease so that none of the 
text becomes hidden. The opposite is not true, however: a text box’s height cannot be resized smaller than the height of the 
rows of text it currently contains, plus its margins.

Depending on the active Edit Behavior , the text box and the characters within it may or may not resize together when a 

corner edit handle is dragged. See Defaults, Preferences, and Edit Behaviors on page 138.         

 l If Resize  editing is enabled, both the text object and the font resize when a corner edit handle is dragged.         

 l If Default  or Concentric  editing is enabled, the text box resizes, but not the font size.         

 l If Fillet  editing is selecting, the corners become rounded and the font size does not change. See Behaviors Panel 

on page 81.         

When text is resized using the edit handles, there is a “sticky 
point” at the natural size of the text box. Hold down the Ctrl/⌘  

key while resizing to override this behavior. 

USING THE EDIT TOOLS

A selected Rich Text object can be edited in a variety of ways using the buttons on the Edit Toolbar See The Edit Toolbar 
on page 92.

RESIZING TEXT

Both the border of a text object and the characters it contains can be resized.         
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The border of a text object can be resized using its edit handles or by specifying the Height and Width in its specification 
dialog.         

The default character height of Rich Text  objects can be specified as can the character height for individual objects, in their 
specification dialogs. See Text Defaults and Preferences on page 348.

Character height can be measured in either of two ways. See Character Size on page 349.          

SCALING TEXT

As with the size of other objects, text size is subject to the current drawing scale specified in the Page Setup dialog. See 
Drawing Sheet Setup Dialog on page 988.         

To determine the Height in drawing units that is needed to produce text of a specific size when printed, use the Print Size 
Calculator dialog.         

To use the Print Size Calculator dialog

 1.  Select the text object or Text Style that you wish to scale and click:         

 l The Print Size  button on the TEXT panel of the Rich Text Specification dialog. See Text Panel on page 352.         

 l The Scale button on the TEXT panel of a variety of specification dialogs. See Text Style Panel on page 373.         

 l The Scale button in the Text Style Defaults dialog.         

 2.  In the Print Size Calculator dialog:         

 l Confirm the desired Printed Scale.         

 l Enter the Desired Print Size of the text.         

 l The Text Height in View required to produce the Desired Print Size displays here for reference.         

 3.  Click OK to return to the previous dialog. The Character Height value now equals that of the Text Height in View.         

Generally, the Printed Scale does not need to be changed in the Print Size Calculator dialog unless you intend to send the 
current view to layout at a different drawing scale. See Sending Views to Layout on page 973.         

ALIGNING TEXT

Text can be aligned in a number of ways.         

 l The text content of a text object can be aligned to the left, right, center or justified in the Rich Text Specification 
dialog. See Text Panel on page 352.

 l The text content of a text object can be also be aligned by clicking the Align Left , Align Right , Center , 

or Justify  edit button.             

 l The center points of text objects can be aligned with one another by assigning them the same X and/or Y Position. See 
Attributes Panel on page 367.           
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 l Text objects can be aligned by bumped them against a CAD line or CAD based object such as a roof plane. See 
Bumping/Pushing on page 168.           

A variety of other alignment methods are also available. See Aligning Objects on page 170. 

The text in the columns of a plant schedule can also be aligned. See Plant Schedules on page 943.

COPY, CUT AND PASTE

Copy, Cut and Paste of text into and out of the text specification dialogs can be accomplished using keyboard hotkeys:

 l Press Ctrl/⌘  + X to Cut the selected text and save it to the system clipboard.
 l Press Ctrl/⌘  + C to Copy the selected text and copy it to the system clipboard.
 l Press Ctrl/⌘  + V to Paste your last cut or copied selection in a new text object.

For more, See Copying and Pasting Text on page 360.         

Copy, Cut and Paste use the system clipboard, making it possible to transfer text between text objects, between Home 
Designer files, from a plan or layout into another application, or vice versa.  See Copying and Pasting Objects on page 118. 

 

Copying and Pasting Text
The Copy, Cut and Paste commands use the system clipboard, making it possible to transfer text between text objects, 
between Home Designer files, from a plan or layout into another application such as a text editor or spreadsheet program, or 
vice versa. See Copying and Pasting Objects on page 118.

All or selected portions of the Materials List can also be copied and pasted into a text object, as well as into a word 
processing or spreadsheet program. See Materials Lists on page 950.         

Cut, Copy, and Paste can also be accessed from the Edit menu of many applications, including Home Designer. These menu 
commands are not available when the text specification dialogs are open, but you can use the associated hotkeys. 

To Copy, Cut and Paste text

 1.  On the TEXT panel of either text specification dialog or in another program altogether, highlight the text you wish to 
cut, copy or paste.

 2.  Press Ctrl/⌘  + X to Cut the selected text out of its original location and save it to the system clipboard.

 3.  Press Ctrl/⌘  + C to Copy the selected text to the system clipboard without removing it from its original location.

 4.  Open the text object or a file in another application and click to place your cursor in the Text field, writing area, or 
spreadsheet cell.

 5.  Press Ctrl/⌘  + V to Paste the copied text at the location of your cursor.

Bear in mind that when text is copied and pasted, its formatting is not always retained. The results depend on the program or 
type of text object in which the content was created as well as the type of text object into which it is pasted. 

PASTING INTO RICH TEXT

Text pasted into a Rich Text object from another source will retain most - but not necessarily all - of its custom 
formatting. If a line of text is sufficiently long, however, it may be wrapped automatically when pasted into Rich 

Text. 

To retain the same character size when text is pasted from a word processing program into the Rich Text Specification 
dialog, uncheck CAD Style Font Sizing. See Options Panel on page 356.           
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If you want to retain the original color(s) of the text being pasted into a Rich Text object, be sure to uncheck Layer Color 
Text in the Rich Text Specification dialog. See Appearance Panel on page 355.          

Text pasted into a RichText object from a spreadsheet program retains basic column and row information. Column width 
cannot be adjusted as it can in simple Text ; however, as you add or remove text from a cell, row height will increase or 
decrease to accommodate your changes.

PASTING INTO A VIEW

Text can also be pasted directly into a plan view or cross section/elevation view. When you use the Paste command, a new 
Rich Text object is created, the text is pasted into that object, and it is selected. In order to see the new object, you may need 
to Fill Window. 

 

Find/Replace Text
Find/Replace Text locates text in Rich Text, Callouts, Markers, Plant Schedule titles and headings, and custom labels for 
objects and rooms. It does not locate text in automatic object labels, default room labels, suppressed labels, the Materials 
List, or in the bodies of Plant Schedules, however.    

Find/Replace Text locates text even when an object’s layer is turned off and/or locked.              It can also find text in objects on 
locked layers. See Locking Layers on page 126.         

FIND/REPLACE TEXT

Select Edit> Find/Replace Text to find a particular word or string of text in your plan or layout file and replace it if 
you wish.          

  Find and Replace

 l Type the string of text that you want to Find in the text field.         

 l Type the string of text that you want the text you find to be Replaced With.          

361



Home Designer Pro 2025 Reference Manual - Text Arrows

 l Select the scope of your search from the Searching In drop-down list. Choose “Current View”, “Current File”, “All 
Open Files” or “Selected Objects”.          

 
Search Options

These settings allow you to refine your search.         

 l Check Case Sensitive to distinguish between capitalized and lowercase letters when searching. When unchecked, 
capitalization is ignored while searching. Regardless of whether this is checked, the capitalization used in the 
Replaced With field will be applied when text is replaced.         

 l When Expand Percent Signs is checked, the program will ignore strings of one or two % signs in a row, which may 
be used to mark up imported text with style commands. Uncheck this to find individual % signs in the search results.
         

 l Check Show in File to open a new view window and highlight the object associated with the current search Result. 
When unchecked, the current search Result will only be highlighted if it is located in the current view window. See 
Working in Multiple Views on page 105.          

 l Click the Highlight Color button to specify the color used to highlight the object associated with the current search 
Result.              See Select Color Dialog on page 135.

 
Results

The current search Results are shown for reference in the field on the left. The location of the associated object, including 
file name, view name, and its object type is stated above the Results field as well. Click a button to the right of the Results 
field to perform the associated action:         

 l Click Find Previous to find the previous search Results.          

 l Click Find Next to search for additional Results.          

 l Click to Replace the current search Results with the replacement specified above.         

 l Click to Replace All instances of the current search Results found throughout the Searching In scope, selected 
above.          

Although the Find options do not locate text in suppressed 
labels, Replace All will replace that text. See Displaying Labels 

on page 376. 

Two spelling suggestions, Ignore Spelling, and Learn Spelling 
are available in the contextual menu if you right-click on a 

selected misspelled word in the Rich Text and Text Specification dialogs. 
See Rich Text Specification Dialog on page 352.

 

Text Arrows
Text arrows, which are simply CAD lines with arrows drawn on the “Text” layer, can be used to connect text objects to 
details of interest in your drawing. See Line Tools on page 204. 

There are several ways to create text arrows, and special attachment behaviors to take advantage of.
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TEXT WITH ARROW

The Text with Arrow tool places a text object with an arrow already attached. This line with arrow can be selected 
and edited like any other CAD line. See Line Tools on page 204.

TEXT LINE WITH ARROW

Text Lines with Arrow can be attached to text, CAD, and architectural objects by selecting CAD> Text> Text Line 
with Arrow and then clicking and dragging to draw a line. There is no limit to the number of text lines with arrows 

that can be attached to an object.   

The endpoints of Text Lines with Arrow can be joined to form polylines with corners that can be adjusted using the edit 
handles. See Polylines on page 218. 

A Text Line with Arrow behaves like a Line With Arrow  with one exception: Text Lines with Arrow are initially 

placed on the “Text” layer, not the “CAD, Default”. See Layers on page 124.

ATTACHING TEXT ARROWS TO OBJECTS

A CAD line, arc, spline, or open polyline with an arrow can be attached to other objects. It can attach to an architectural 
object anywhere within its 2D symbol in plan view, but attaches to a closed polyline-based object along its edges. A text 
line with arrow will automatically be deleted if one of the objects it is attached to is deleted. 

Text Lines with Arrow that have the same Line Style and Arrow attributes can be snapped together to form open or closed 
polylines. If two lines with arrows meet within the bounding box of a text object, however, they will not join. This allows 
you to attach multiple, separate text arrows to a single text object. See Editing Line-Based Objects on page 146.

Text Lines with arrow can be independent or attached to other objects at both their tail and head ends. Arrows attach to 
closed polyline-based objects along their edges, but can attach to Text or an architectural object anywhere within its 
bounding box in plan view.  

 l When a selected Text Line with Arrow is attached to an object on either end, its end edit handle will display the 
Selected Edge Handle Fill color. See Colors Panel on page 65.

 l If an attached object is moved, the end of the Text Line with Arrow will move, as well.
 l If a text arrow is attached to text or another object, deleting either the text or the object will also delete the text arrow.

AUTO POSITION ARROWS

If either or both ends of a line with arrow are attached to an object, Auto Position Tail and Auto Position Head will be 
available in the Line Specification dialog. See Arrow Panel on page 226.           

The Auto Position options are designed to prevent lines with arrows from crossing over the text or other objects that they 
are attached to. These options snap the ends of a line with arrow to predefined points on the object(s) it is attached to. If an 
attached object is moved, the end of the line with arrow will update so that it is snapped to the closest Auto Position 
location. Similarly, if the line with arrow is moved, rotated, or resized, its end may snap to a new Auto Position location on 
an attached object.          

There are four Auto Position locations on a text object: one at the midpoint of each side. The Auto Position locations on 
other objects varies by object type.           

The following image illustrates the behavior of Auto Positioning. The arrow has the Auto Position Tail option checked, and 
the tail end of the line is attached to the text object. When the head of the line with arrow is moved, the tail of the arrow 
snaps to different Auto Position locations on the text object, maintaining its connection.
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In addition:          

 l If a selected Text Line with Arrow is moved away from an Auto Position location and you check Auto Position Tail, 
the tail will snap to the nearest Auto Position location.           

 l The first segment of a polyline arrow attached to text maintains its angle when Auto Position is off and text is moved.          
 l Auto Position is disabled automatically when an arrow is not attached to one of the auto position locations.          
 l Arcs and splines with arrows can also be attached to text and other objects.          

 

Callouts
To create a callout, select CAD> Text> Callout, then click at the location where you want a callout to be placed in 
plan view, a cross section/elevation view, or on a layout page. The Callout Specification dialog displays. Make any 

needed changes and click OK to place a callout. See Callout Specification Dialog on page 366.

CROSS SECTION LINES

Check the Cross Section Line box in the Callout Specification dialog to add a cross section line with the length, angle, and 
other attributes that you specify. See Attributes Panel on page 367.          

Cross section lines can be added to any callout shape. You can specify the cross section line's length and angle in the 
Callout Specification dialog, as well as add text above and/or below the line. A cross section line can also be resized as well 
as rotated using the square edit handle located at the end of the cross section line. See Editing Callouts on page 365, below.         

CALLOUT ARROWS

To add an arrow or “hat” to a callout, select the callout and drag the diamond-shaped handle away from the center of the 
callout. An arrow is created, pointing in the direction you dragged. See Editing Callouts on page 365, below.
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Arrows can also be specified in the Callout Specification dialog. See Attributes Panel on page 367.     

You can also add as many CAD Lines with Arrows as you like to callouts. To add a line with arrow to a callout:

 l Select the callout, then click and drag the diamond-shaped Add Text Line with Arrow edit handle located below the 
callout.

 l Select CAD> Text> Text Line with Arrow , then click and drag to create a line with arrow, which can be moved 

or resized as needed.          

See Text Arrows on page 362.

DOUBLE CALLOUTS

Any callout can be specified as a Double Callout in the Callout Specification dialog. See Attributes Panel on page 367.          

To resize the line between the two callout shapes, select the callout and then click and drag the edit handle at the center of 
either callout shape. The arrows on a double callout are always the same on both callouts.           

EDITING CALLOUTS

Callouts can be edited using the edit handles, the Edit Toolbar buttons and the Callout Specification dialog. See Callout 
Specification Dialog on page 366.

When a callout is selected, it has a selection of edit handles. The number varies depending on whether it has a cross section 
line and/or arrow.

A. Move
 l The Move handle is located at the center of the callout shape. Click and drag this handle to move the callout according 

to the currently active Edit Behavior . 

B. Concentric Resize
 l The small circular Concentric Resize handle displays on the perimeter of the callout shape. If the callout has a cross 

section line, it will be found where that line meets the perimeter. Click and drag this handle to resize the callout 
without moving its center point.

 l If the callout's Size is set to Automatic in its specification dialog, any text displaying inside its shape will also resize 
when this edit handle is used. See Callout Panel on page 372.  
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C. Rotate
 l The large triangular Rotate handle displays outside the callout shape perimeter, just past the end of the cross section 

line if one is present. It is used to rotate the callout shape. The callout's text does not rotate along with the shape unless 
the Text Angle is set to Automatic.

D. Extend Cross Section Line
 l The  square Extend handle is at the end of the cross section line, if there is one. Click and drag this handle to change 

the cross section line's length and/or angle.

E. Add Callout Arrow
 l The diamond-shaped Add Callout Arrow handle is located just outside the callout shape. Click and drag this handle 

away from the callout shape in any direction to draw a callout arrow, or hat, to the perimeter. See Callout Arrows on 
page 364.

F. Rotate Callout Arrow
 l The small triangular Add Callout Arrow handle is located at the end of each callout arrow, or hat. Click and drag this 

handle to rotate that arrow around the callout shape.
 l Remove an arrow by clicking and dragging this handle towards the center of the callout.

 

Callout Specification Dialog
To open the Callout Specification dialog, select a Callout and click the Open Object edit button. This dialog also 
displays when a new Callout is created using the Callout  tool. See Callouts on page 364.

The Callout Specification dialog is similar to Callout Label Specification dialog, which allows you to create callout labels 
for layout views. See Layout Box Borders and Labels on page 978.

This dialog is also similar to the Callout Defaults dialog but affects the selected callouts rather than all subsequently created 
callouts. See Text Defaults and Preferences on page 348.

CALLOUT PANEL

For information about the settings on this panel, see Callout Panel on page 372.

366



Home Designer Pro 2025 Reference Manual - Callout Specification Dialog

ATTRIBUTES PANEL

 
Cross Section Line

Check Cross Section Line to apply a cross section line to the selected callout and enable the settings that follow.                 

 l Check Double Callout to specify two identical callouts connected by the cross section line. Only available when 
Display is checked.            

 l Select the cross section line’s line Style from the drop-down list. When By Layer is checked, the line style specified 
in the Layer Display Options dialog is used.

 l Specify the Weight of the cross section line or check By Layer to use the line weight specified in the Layer Display 
Options dialog.     

 l Specify the Minimum Length of the cross section line. The actual length may be greater, depending on the text 
either above or below the cross section line.   

 l Specify the Relative Angle of the cross section line. This setting is not absolute: rather, it is measured relative to the 
Shape Angle of the callout object.     

  Callout Arrows

 l Specify whether the arrows are Small or Large.           

 l Check Filled to specify arrows with a solid fill. When unchecked, arrows are unfilled.          
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 l Specify the Color of the callout's arrow(s): check By Layer to use the color specified in the Layer Display Options 
dialog or click the Color bar to choose an arrow color. See Select Color Dialog on page 135. 

 l Use the Transparency slider or text field to control how transparent the callout arrow(s) are.        

 l Specify the Number of Arrows. 

 l The angle of each arrow can be set using the callout's edit handles. See Editing Callouts on page 365.

 
Preview

A preview of the selected callout displays on the right. See Dialog Preview Panes on page 21.         

LINE STYLE PANEL

The LINE STYLE panel is found in the specification dialogs for many different objects. For more information, see Line Style 
Panel on page 209.          

Additional attributes for the cross section line and arrows can be specified on the Attributes Panel on page 367.

 

Markers
To create a marker, select CAD> Text> Marker and click at the location where you want it to be placed. The 
Marker Specification dialog opens.               

Markers for Level Lines, Test Borings and Point Markers can be placed in plan view, and cross section/elevation views.

You can also place a framing reference marker using Build> Framing> Framing Reference . Framing Reference 

Markers should only be placed in plan views. See Framing Reference Markers on page 651.          

EDITING MARKERS

Markers can be edited using the edit handles, edit toolbar and Marker Specification dialog. See Marker Specification Dialog 
on page 369.

When a marker is selected, it has four edit handles.

A. Move
 l The Move handle is located at the center of the callout shape. Click and drag this handle to move the callout according 

to the currently active Edit Behavior . 
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B. Concentric Resize
 l The small circular Concentric Resize handle displays on the perimeter of the callout shape. If the callout has a cross 

section line, it will be found where that line meets the perimeter. Click and drag this handle to resize the callout 
without moving its center point.

 l If the callout's Size is set to Automatic in its specification dialog, any text displaying inside its shape will also resize 
when this edit handle is used. See Callout Panel on page 372.

C. Extend Cross Section Line
 l The  square Extend handle is at the end of the cross section line, if there is one. Click and drag this handle to change 

the cross section line's length and/or angle.

D. Rotate
 l The large triangular Rotate handle displays outside the callout shape perimeter, just past the end of the cross 

section line if one is present. It is used to rotate the callout shape. The callout's text does not rotate along with the 
shape unless the Text Angle is set to Automatic.

A customized marker can be added to the Library for future use. 
See Add to Library on page 709.

POINT MARKERS AND DIMENSIONS

There are a number of scenarios in which Markers may be created in conjunction with dimension lines. These Point Markers 
derive their initial attributes from the               Marker Defaults dialog and can be selected and edited:         

 l When the Point to Point Dimension  tool is used to draw a dimension line and an object is not available to snap to 

at either the start or end point, a Point Marker will be automatically created and the dimension line will locate it. See 
Point to Point Dimensions on page 333.           

 l Dimensions drawn in a cross section/elevation view may locate Cross Section Lines that represent objects rather than 
the objects themselves. When this occurs, Point Markers will also be placed and the dimension lines will locate them. 
See Cross Section Lines on page 795.           

 l If a dimension line is copied independent of the objects it locates, the pasted dimension line will locate Point Markers. 
See Copying and Pasting Dimension Lines on page 337.          

 

Marker Specification Dialog
To open the Marker Specification dialog, select a marker and click the Open Object edit button.         

This dialog also displays when a new marker is created by clicking in plan view using the Marker  tool.           

The Marker Specification dialog is similar to the Marker Defaults dialog but affects the selected markers rather than all 
subsequently created markers.               See Text Defaults and Preferences on page 348.         
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MARKER PANEL

 
Type

Choose a marker Type. Note that Framing Reference Markers  affect the model, while the other marker types are for 

annotation only. See Framing Reference Markers on page 651.

Examples of Level Line, Test Boring, Point 
and Framing Reference markers.

 
Line

Specify the Minimum Length and Angle of the marker's line and text. 

 l For Level Line and Framing Reference Markers, the actual length of the level line may be greater, depending on the 
text either above or below the line.   

 l For Test Boring and Point Markers, the Minimum Length controls the gap between marker and text. 

 
Label

Specify the text and alignment of the selected marker’s Label. The label’s text style can be specified on the TEXT STYLE 
panel. See Text Styles on page 373.         
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 l When Auto Adjust Text Direction is checked, label text is oriented relative to the bottom or the right side of the 
view window, depending on the cross section line's angle. When unchecked, label text is oriented relative to the 
cross section line, regardless of its angle.   

 l Type the Text which displays above the marker’s line. 

 l Select a text Alignment option from the drop-down list. Only available for Level Line and Framing Reference 
markers.   

 o Toward Marker positions the text next to the marker shape.   

 o Centered centers the text along the length of the marker's line.   

 o Away From Marker positions the text at the end of the marker's line.   

Text Below Line and the related settings below it are only available for Level Line markers.

 l Type the Text Below Line that displays below the Level Line marker’s line, if desired.   

 l Specify the Text Style used by the Text Below Line:   

 o When Match Text Above is checked, the Text Below Line uses the same Text Style as the text above the line.   

 o Uncheck this box, then select a different Text Style from the drop-down list.   

 l Select a text Alignment option for the Text Below Line from the drop-down list. "Match Text Above" is selected by 
default.         

 
Size

Specify the Size of the selected marker.         

 l Specify the Marker Radius, which is the distance from the marker’s center to the edge of its filled shape.          

 l In a cross section/elevation view, specify the Height of the marker, relative to 0. This setting is also available in plan 
view but does not affect the marker’s position.                See Detailing Cross Section/Elevation Views on page 782.         

 
Preview

A preview of the selected marker displays on the right. See Dialog Preview Panes on page 21.          

LINE STYLE PANEL

The LINE STYLE panel is found in the specification dialogs for many different objects. For more information, see Line Style 
Panel on page 209.          

Additional attributes for the cross section line and arrows can be specified on the ATTRIBUTES panel. See Attributes Panel 
on page 367.         

TEXT STYLE PANEL

The settings on the TEXT STYLE panel control the appearance of the selected object’s text. For more information, see Text 
Style Panel on page 373.           
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Callout Panel
The CALLOUT panel is found in the Callout Specification dialog. See Callout Specification Dialog on page 366.

  Label

 l Type the Callout Label, which displays inside the callout shape. This text is centered in the callout shape when no 
Text Below Line is specified.         

 l Type the Text Below Line for the bottom row, if desired. If Text Below Line is added, a line centered in the callout 
shape will separate this text from the Text Above Line.      

 
Shape

Select a callout shape by clicking the radio button beside one of the options.

  Size/Orientation

 l Uncheck Automatic to enable the Size field and specify a new value. When checked, the callout is sized so that it 
encompasses its Label.

 l Specify the Shape Angle of the callout shape. Does not affect the Ellipse, Capsule, or Rectangle shapes.

 l Specify the Text Angle of the text inside the callout shape. Check Automatic for the Text Angle to match the Shape 
Angle. 

 
Preview

As in many specification dialogs, a preview of the selected object displays on the right. See Dialog Preview Panes on page 
21.         
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Text Styles
In Home Designer, a Text Style is a set of attributes assigned to objects that displays text, such as Dimensions, Callouts, 
Markers, Plant Schedules, and object labels.

Note: Because of its ability to use multiple attributes in the same object, 
Rich Text does not use Text Styles. See Rich Text Specification Dialog 
on page 352. 

You can create your own or edit existing Text Styles to suit your needs in the Text Style Defaults dialog.

TEXT STYLE DEFAULTS

Select Edit> Default Settings,              click on “Text Styles” and click the Edit button. The Saved Text Styles dialog will 
open, allowing you to select which Saved Text Style Defaults you would like to edit.

SAVED TEXT STYLES DIALOG

 l Select the Name of a Text Style from the list.         
 l Click the Copy button to create a new Text Style by copying the one currently selected in the Name field.         
 l Click the Edit button to open the defaults dialog for the selected Text Style so that you can edit it.         
 l Click the Rename button to change the name of the selected Text Style.         
 l Click the Delete button to remove the selected Text Style from the current plan or layout file.         
 l Click OK to close the Saved Text Style Defaults dialog and save any changes you made in the defaults dialog(s). Any 

changes made to a given Text Style will be applied to all objects in the current plan that are set to use that Text Style.         
 l Click Cancel to close the Saved Text Style Defaults dialog without saving any changes that you may have made in the 

defaults dialog.         

TEXT STYLE PANEL

The TEXT STYLE panel is found in various specification and defaults dialogs in the program.          

The settings on this panel are also found in the Text Style Defaults dialog, where they affect all objects using that style 
rather than a single selected object.          
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Source of Text Style

Specify where the selected object should draw its Text Style from. These options are not available in the Text Style Defaults 
dialog.                 

 l Select Use Layer for Text Style to use the Text Style assigned to the layer that the selected text is located on.                     

 l Select Use Text Style, then choose a style from the drop-down list to apply that style to the selected object, 
regardless of what layer it is on. When this is not selected, the name of the selected object’s Text Style displays here 
for reference.                      

 l Select Use Custom Text Style to enable the settings below and customize the selected objects Text Style attributes.                     

 l Check Use Default Text Style to use the default style for the selected object type, or uncheck this box to enable the 
settings below and define a custom style.         

 l The settings that follow are only editable when Use Custom Text Style is selected. When it is not selected, 
information about the Text Style that is assigned to the selected object displays for reference.

  Font

 l Select a font from the drop-down list.         

 l The text styles Bold, Underline, Italic, Strikeout, and Uppercase are available. Check any of the boxes to apply 
that style.         

  Character Height

 l Enter the Character Height in drawing units. This height is subject to the current drawing scale.          

 l Click the Scale button to open the Printed Size Input dialog. See Scaling Text on page 359.          
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 l If the selected object was originally created in an older program version and had Legacy Compatible Size checked 
in that version, this check box will be available. If you uncheck the box and click OK, however, the option will be 
removed. See Character Size on page 349.          

  Options

 l Check Rotate with Plan to rotate text using the selected Text Style when Rotate Plan View  is used. If 

unchecked, the text is unaffected when Rotate View is used. See Rotate Plan View on page 104. 

Rotate with Plan also affects text in a view sent to layout if the layout box is rotated. See CAD and Text in Layout 
on page 972.          

 l Check Transparent to make text boxes using the selected Text Style transparent. When unchecked, text boxes have 
a solid fill the same color as your background color. Not available for objects that have FILL STYLE panels in their 
specification dialogs. See Colors Panel on page 65.           

  Text Color

 l When By Layer is checked, text uses the line color assigned to the layer that the object it is assigned to is located 
on. See Layer Attributes on page 125.          

 l Uncheck By Layer, then click the Color bar to select a different color. See Select Color Dialog on page 135.         

 
Preview of Text Style

A preview of the Text Style currently assigned to the selected object displays here.          

 
Object Preview

In some specification dialogs, a preview of the selected object displays on the right. See Dialog Preview Panes on page 21.          

 

Object Labels
Object labels can display in plan views for a variety of different object types: 

 l Automatic Labels provide basic information about the object, such as its type, size, or name.
 l You can create a custom label for an object in its specification dialog using text. See Label Panel on page 376.

Object labels have their own Move edit handle that displays when their object is selected. Schedule callout labels can be 
moved in the same manner. When an object has both label types displaying, they share a single Move handle and can only 
be rotated using settings in the object specification dialog and Schedule Specification dialog. See Labels Panel on page 948 
and Edit Handles on page 23.

AUTOMATIC LABELS

Most objects that can display labels have an Automatic Label created by the program that states basic information about it. 

When Automatic Label is selected in the object’s specification dialog, this is usually the label that will be used; however:

 l If a user-defined label is specified in the object’s defaults dialog, that label will be used instead of the Automatic 
Label.

 l If the  plant is included in a plant schedule and callout labels are specified in that schedule, a callout label will be used. 
 l Fixtures and appliances inserted into cabinets do not have labels of their own.
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DISPLAYING LABELS

The display of object labels in plan views can be controlled by layer in the Layer Display Options dialog. Label layer 
names begin with the object type, followed by the word Label: for example, cabinet labels are located on the 

“Cabinets, Labels” layer. See Layer Display Options Dialog on page 127.

You can choose to suppress the label for an individual object on the LABEL panel of its specification dialog. This setting 
does not affect schedule callouts. See Label Panel on page 376.

Object labels use the “Default Label Style” Text Style. See Text Styles on page 373.   

With the exception of those for rooms, roofs, and cameras, labels can also be included in the Materials List and Master List. 
Items in the Labels column of the Materials List are editable; however, any changes will not be applied to the actual objects’ 
labels. See Materials List Columns on page 959. 

The minimum on-screen display size of labels can be specified in the Preferences dialog. See Appearance Panel on page 63.

 

Label Panel
The LABEL panel is found in the specification and defaults dialogs for a variety of different objects. The settings that 
are available will vary depending on the type of object that is selected.

Note: If you choose a callout shape in the Plant Schedule Specification 
dialog, the settings here are overridden and the schedule label is used 
instead. See Labels Panel on page 948.

 
Suppress Label

Check this box to prevent the selected object’s label from displaying in plan views. This option does not affect the display 
of schedule callouts. See Object Labels on page 375.

Most objects have this option; however, Bay, Box, and Bow Windows and Mulled Units instead have several settings for 
controlling Multiple Component labels. These settings also affect how Bay, Box and Bow Windows and Mulled Window 
units are counted the Materials List. See Window Labels on page 417.     

For Bay, Box and Bow Windows and Mulled Window units:

 l Select Suppress All Labels to display no label in plan view. Individual components are counted in the Materials 
List.     
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 l Select Show Component Labels to produce labels for each component in plan view. Individual components are 
counted in the Materials List.     

 l Select Show Single Label for Entire Unit to produce one label for the unit and suppress component labels. When 
this option is selected, the settings that follow on the LABEL panel become enabled.     

 
Label Options

Specify the information reported in the label. Not available for cameras. See Displaying 3D Views on page 783.

 l Select Automatic Labels to use the default label for the selected object. See Automatic Labels on page 375.

 l Select Specify Label to replace the selected object’s Automatic Label with whatever you type in the text field 
below. Press the Enter key while the cursor is in the text field to begin a new line. When Specify Label is chosen, 
the text of the selected object’s Automatic Label initially populates the text field.    

 
Preview

In most specification dialogs, a preview of the selected object displays here. In the preview pane, labels can be seen in Plan 
View only. Only the regular object label is shown: even when a selected plant has a schedule callout label. See Dialog 
Preview Panes on page 21. 
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Chapter 15
 

Doors

Home Designer comes with tools for creating a wide variety of interior and exterior doors. In addition, the library offers a 
large selection of specialty doors and doorways including hinged, sliding, pocket, bifold, and garage doors. Additional 
name-brand door catalogs are also available for download from our website, HomeDesignerSoftware.com.

TOPICS

Door Defaults 379
Door Tools 380
Displaying Doors 382
Editing Doors 385
Changing Door Swings 387
Special Doors 390
Door Specification Dialog 392
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Door Defaults
There are several defaults dialogs for doors. Default Settings are accessed by selecting Edit> Default Settings. Click 
the arrow next to “Doors” to expand the category. Select one or more subheadings and click the Edit button to open 

the defaults dialog associated with your selection: 

The various Door Defaults in the list can be multiple-selected by holding down the Shift or Ctrl/⌘  keys. See Shift and 
Ctrl/⌘  Select on page 146.          

Door Defaults can also be accessed by double-clicking the Door Tools  parent button or the Hinged Door  or Sliding 

Door  child button. Double-clicking the other Door Tools child buttons will open the defaults dialog for that particular 

door type.           

Because Hinged and Sliding Doors are often used in both interior and exterior applications, they have both Interior and 
Exterior Door Defaults. 

The Door Defaults dialogs look nearly the same as the Door Specification dialog. See Door Specification Dialog on page 
392. There are only a couple of differences: 

 l Since default settings are specified here, “Use Default” is not an option for some settings as it is in the Door 
Specification dialog. 

 l The Door Type cannot be changed in the Defaults dialogs.

INTERIOR VS EXTERIOR DOORS

Regardless of its Door Type or the tool used to create it, a door will be: 

 l An Interior Door if it is created in a wall that separates two interior rooms;
 l An Exterior Door if it is created in a wall that separates an interior room from either an exterior room or the building’s 

exterior. See Room Types on page 289. 

This rule does not apply to doors placed from the Library or copied and pasted from one location to another, however. If, 
for example, you place a hinged door in an interior wall between two rooms and then paste a copy of that door in an exterior 
wall, the copy will remain an interior door. See Exterior and Interior Walls on page 236.
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DYNAMIC DOOR DEFAULTS

A variety of door default values are dynamic, including the Door Style, Casing, Lintel, Jamb, Hardware, Framing, and 
Rough Opening. When a dynamic default is changed, existing door using the default value are affected. See Dynamic 
Defaults on page 58. 

All Materials listed under “Doorway” on the MATERIALS panel are also dynamic. Materials assigned to doors and hardware 
items from the library, however, are listed separately and are dynamically linked to the “Interior Door”, “Exterior Door” and 
“Fixture Trim” and “Hardware” materials set in the Material Defaults dialog rather than the Door Defaults dialogs. See 
Material Defaults Dialog on page 747.           

DOOR FRAMING

The default headers, trimmers, rough opening, and sill for doors can be defined in the Door Defaults dialogs. You can also 
specify an additional amount to cutout for door openings in concrete garage curbs and foundation walls. See Rough Opening 
Panel on page 405 and Framing Panel on page 406.

The default header depths for different spans can be set in the Framing Defaults dialog. See Openings Panel on page 641.

 

Door Tools
To place a door, select the type you want from the Build> Door submenu. Move your mouse pointer over a wall, 
railing, or fencing section. When a preview outline can be seen, click to place a door at that location.

The minimum initial size for doors varies by Door Type. For example, If there is room enough along the wall to fit a 12” 
(300 mm) wide Hinged Door, a preview outline will display and a door can be placed. Garage doors, in contrast, must 
initially be at least 6’ (1800 mm) wide.

Doors can be placed in both straight and curved walls, as well as span across straight, collinear wall segments.         

A newly created door inherits the settings in the Door Defaults dialog for its door type. Once created, doors can be edited in 
a variety of ways. See Door Defaults on page 379. 

Doors cannot be placed in a wall specified as Invisible or if the wall in question is on a locked layer. See Locking Layers on 
page 126. See Room Dividers and Invisible Walls on page 239.

Once placed, any door may be changed into any other type of door in the Door Specification dialog. See General Panel on 
page 393.

HINGED DOORS

Select Build> Door> Hinged Door and click on a wall to place a hinged door at that location. Hinged doors have 
separate defaults for interior and exterior doors. By default, a hinged door becomes a double door when its width is 

four feet (1200 mm) or greater. 

The initial swing direction of a hinged door depends on the location of the mouse pointer relative to the wall when you 
click. The door will swing towards the side of the wall that you click nearest. 

The initial hinge side of a hinged door can be set by clicking to place the door and then holding the mouse button down 
rather than releasing it. Move the mouse toward the end of the door that you would like the hinges to be on: as the mouse 
pointer nears either end, the door preview’s hinge side will move to that end. You can also adjust the door’s swing direction 
in this manner. When the swing direction and hinge side are correct, release the mouse button.
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DOORWAYS

Select Build> Door>  Doorway and click on a wall to place a doorway. Doorways are simply openings without a 
door and can be placed in interior and exterior walls, railings, and fences. You can assign a door from the library to a 

doorway if you wish.

SLIDING DOORS

Select Build> Door> Sliding Door and click on a wall to place a sliding door. Sliding doors have separate defaults 
for interior and exterior doors: interior sliding doors are typically solid while exterior sliding doors are Glass Panel 

doors. 

The initial opening side of a sliding door can be specified by moving the mouse pointer along the wall while the mouse 
button is still pressed.  

POCKET DOORS

Select Build> Door> Pocket Door and click on a wall where you want to place a pocket door.

As with sliding doors, the initial opening side of a pocket door can be specified by moving the mouse pointer along the wall 
while the mouse button is still pressed.  

By default, a pocket door becomes a double pocket door if its width is four feet  (1200 mm) or greater. 

BIFOLD DOORS

Select Build> Door> Bifold Door and click on a wall where you want to place a bifold door.

Like a hinged door, the initial opening side of a bifold door depends on the location of the mouse pointer relative to the wall 
when you click. The door will open towards the side of the wall that you click nearest. 

Similarly, the initial hinge side of a bifold door can be specified by moving the mouse pointer along the wall while the 
mouse button is still pressed.  

By default, a bifold door becomes a double bifold if its width is greater than three feet (900 mm).

GARAGE DOORS

Select Build> Door> Garage Door and click on a wall to place a garage door.

In plan view, dashed lines show the size and location of the garage door when open.

Garage doors will build into a garage stem wall provided the room is designated as a garage before the door is inserted. See 
Room Types on page 289.

FIXED DOOR

Select Build> Door> Fixed Door and click on a wall to place a fixed door.
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BARN DOOR

Select Build> Door> Barn Door and click on a wall to place a surface mounted sliding door, sometimes referred to 
as a barn style door.

SHOWER DOOR

Select Build> Door> Shower Door and click on a wall to place a hinged glass slab shower door.

Place a Shower Door in a Straight Glass Wall. See Wall Tools on 
page 232.

 

THE DOORS & DOORWAYS LIBRARY CATALOG

The Doors & Doorways library catalog can be accessed by selecting View> Library Browser and browsing to Home 
Designer Core Catalogs> Architectural> Doors and Doorways. This catalog contains a variety of interior and exterior 

doors, as well as special entryways and wrapped openings. 

Entryways and wrapped openings are examples of Doorways, which are wall openings that do not have doors within them.

To add a door to the Doorway, select a Door Type other than “Doorway” from the drop-down list in the Door Specification 
dialog. See General Panel on page 393. 

You can also select a door from the library and place it into a doorway in plan view or any 3D view.

To place a library door in a doorway

 1.  Open the Library Browser in plan view or any 3D view. 

 2.  Browse or search to find a door style that suits your needs. 

 3.  Select the door in the Library Browser, then click on the doorway to place the selected door within it. If a door 
already exists, it is replaced. 

 4.  Continue clicking other doorways as needed.

 

Displaying Doors
The display of doors, door labels, opening indicators, header lines, and casing is controlled in the Layer Display 
Options dialog. See Layer Display Options Dialog on page 127. 

If the “Doors” layer is turned off, doors and their casing do not display but openings in the walls where they are located are 
visible.
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Along with the doors themselves, the display of a number of door components can also be controlled by layer:

 l Interior and exterior door casings are located on the “Casings, Exterior” and “Casings, Interior” layers and can display 
in all views. In plan view, the vertical side casings will be shown, but the horizontal top casing or lintel will not. If a 
door is recessed, the affected wall layers will adjust to accommodate the casing. 

 l Window and door shutters are located on the "Shutters" layer and can display in all views. Shutters can also be set to 
Show Closed or open. See Shutters Panel on page 432.

 l When the “Opening Header Lines” layer is turned on in plan view, headers are represented by dashed lines within each 
door. These lines do not correspond to actual framing objects and cannot be selected. In addition, header framing 
members can be set to display. See Wall Framing on page 627.      

 l If a door is placed in a Garage room at a height where it extends into the stem wall or curb, a cutout in the concrete 
will display on the floor below. You can specify the cutout’s size and whether it displays in plan view in the Door 
Specification dialog. See Rough Opening Panel on page 405.

Doors can only be placed in walls, so if a wall’s layer is turned off in plan view, any door placed in that wall will not 
display, either. In 3D views, however, doors can display independent of their containing walls:

 l When Hide Camera-Facing Exterior Walls is in use in the current view. See Displaying Walls on page 246. 
 l When Display Openings Independent of Walls and Roofs is checked in the 3D View Defaults dialog. See 3D View 

Defaults Dialog on page 774.

IN PLAN VIEWS

A door’s jamb, casing, and swing are all represented in plan view. If a door is recessed, the affected wall layers will adjust 
to accommodate the casing.

A threshold line will display across a door opening in plan view when the door:

 l Is located in an exterior wall. See Exterior and Interior Walls on page 236.
 l Opens to an exterior room such as a Garage or Deck. See Room Types on page 289.
 l Is located between rooms with different floor heights. See Floor and Ceiling Platforms on page 303.

Doorways display dashed lines that represent the wall surface between the doorway and the ceiling. Other types of doors do 
not display these wall surface lines, however, you can specify that any door display them or not in its specification dialog. 
See Options Panel on page 395.          

If an exterior door to a Garage room on Floor 1 extends into a Garage stem wall or curb on Floor 0, its location will be 
indicated on Floor 0. You can control the display of this concrete cutout in the Door Specification dialog. See Garages on 
page 506. 
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When the “Opening Header Lines” layer is turned on in plan view, headers are represented by dashed lines within each 
door’s opening. These lines do not correspond to actual framing objects and cannot be selected. In addition, header framing 
members can be set to display. See Wall Framing on page 627.           

The vertical casing on the sides of doors will display in plan view when the “Casings, Exterior” and “Casings, Interior” 
layers are turned on. See Casing Panel on page 397.           

IN 3D VIEWS

In addition to the components drawn in plan views, door hardware and millwork display in camera views.

You can specify whether a selected door is shown open or closed in 3D views by clicking the Show Door Open in 3D  

and Show Door Closed in 3D  edit buttons as well as in the Door Specification dialog. See Options Panel on page 395.

If a door is set to display open in 3D, the angle of the open door can be changed using the edit handles in plan view. See 
Using the Edit Handles on page 385.

You can specify whether an exterior door has a threshold in the Door Specification dialog. See Casing Panel on page 397.

You can also specify whether window and door glass is opaque or transparent in the Rendering Technique Options dialog. 
When Opaque Window Glass is used, window and door glass uses the color specified for the active Rendering Technique. 
See Rendering Technique Options on page 834.          

Doors as well as windows can display in 3D Framing Overviews when Display Openings Independent of Walls and 
Roofs is checked in the 3D View Defaults dialog. See 3D View Defaults Dialog on page 774.

OPENING INDICATORS

Doors, windows and cabinet doors can all display opening indicator arrows in Vector Views. See Vector View on page 832.

To display an object's opening indicator arrows in a Vector View:

 l Turn on the “Opening Indicators” layer in the Layer Display Options dialog.
 l Make sure the object is set to Show its opening indicators in its specification dialog. See Opening Indicators Panel on 

page 403.

Opening indicators on a cabinet, window, and 
doors in a Vector View

You can specify whether opening indicators point to the opening hinge side or the opening side in the General Plan Defaults 
dialog. See General Plan Defaults Dialog on page 60.
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DOOR LABELS

Door labels display in floor plan view, centered on the doors they represent, when the “Doors, Labels” layer is turned on 
and use the Text Style assigned to their layer. See Label Panel on page 376. 

Door labels indicate Width and Height. For example: 

 l In U.S. Unit plans, the automatic label for a 3’-0” wide, 6’-8” high double hung window will read 3068. 
 l In metric plans, the automatic label for a 900 mm wide, 2100 mm high double hung window will read 900x2100.

Customized labels               can also be specified in the Door Specification dialog.

IN THE MATERIALS LIST

The materials associated with doors are listed under different Categories in the Materials List:

 l Doors - Lists door panels, handles, and hinges.                 
 l Interior Trim - Lists interior casing and lintels as well as interior door jambs.                 
 l Exterior Trim - Lists exterior casing, lintels, shutters. Exterior jambs and thresholds are also listed here.                 

As with other objects, there are a number of ways to control how, or whether, doors are included in the Materials List. See 
Organizing Materials Lists on page 953.     

You can add and edit information about a door’s accessories in the Door Specification dialog. See Components Panel on 
page 967.     

 

Editing Doors
Before a door can be edited, it must be selected. To select a door, click it when the Select Objects  tool or any of the 

Door Tools  are active. Doors and/or windows can also be group selected and edited. See Selecting Objects on page 142.

Blocked units are made up of individual doors and windows that have been grouped together to act as one object. You can 
create what is essentially a blocked door unit by assigning a library door to a doorway from the library. 

Select a blocked unit by clicking on it in any view. To select a door that is a component of a blocked unit, click at the 
location of the component in question, then click the Select Next Object  edit button. See Selecting Objects on page 

142.

USING THE EDIT HANDLES

In plan view, click either of the two end handles and drag along the wall to change the width. The label showing the size 
updates as the handles are dragged. Click and drag the Move handle at the center to move the door along the wall it is 
placed in. Use the triangular Rotate handle to adjust the door’s swing. If door labels are set to display, they will each have a 
small square Move edit handle. See Displaying Doors on page 382.

In 3D views, a selected door has five edit handles: the Move handle at the center and a Resize handle on each edge.  Click 
and drag an edge handle to resize the door. 

Using the edit handles, doors resize according to the currently active Edit Behavior . See Defaults, Preferences, and 

Edit Behaviors on page 138.   
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A door or window moved against an intersecting wall temporarily stops when the casing meets the intersecting wall. You 
can continue to drag and it resumes movement past the intersecting wall. 

IN THE SPECIFICATION DIALOG

The most precise method of editing a door or group of doors is to use the Door Specification dialog. Door type, size, casing, 
materials, shape, and more can all be specified in this dialog. See Door Specification Dialog on page 392. 

USING THE EDIT TOOLS

A selected door or doors can be edited in a variety of ways using the buttons on the Edit Toolbar. See The Edit Toolbar on 
page 92.

  Change Opening/Hinge Side changes the side of the door that its hinges are on. See Changing Door Swings on 
page 387.

  Change Swing Side changes which direction the selected door swings.

  Show Door Open in 3D or Show Door Closed in 3D controls the selected door’s appearance in 3D 
views. See In 3D Views on page 384.

  Gable Over Door/Window creates a gable over the selected door(s) the next time the roof is rebuilt. See 
Gable/Roof Lines on page 609. 

USING DIMENSIONS

Like various other objects, doors can be moved using dimensions. See Moving Objects Using Dimensions on page 
341. 

You can specify how doors and windows are located by dimensions in the Dimension Defaults dialog. Dimensions can be 
set to locate the centers, sides, casing, and/or rough openings of doors and windows, or you can choose to not locate them at 
all. See Locate Manual Panel on page 325.           

Once a dimension line has been drawn, you  can move or add its extension lines to locate non-default locations on a door. 
See Editing Extension Lines on page 338. 

CENTERING DOORS

The Center Object edit button allows you to center a selected door along a wall within a room or relative to a 
cabinet or window. See Center Object on page 172.

To center a door along a wall

 1.  Select a door or combination of windows and doors in plan view. 

 2.  Click the Center Object  edit button then choose from one of the following options: 

 l Click near a wall inside a room to center the door along that wall in that room.

 l Click outside the house (on the exterior room) near an exterior wall to center the door along an exterior wall.

DOOR STYLE AND PANELS

There are a number of Door Styles available for use, including Slab, basic Panel, and Louvered. In addition, a selection of 
door panel symbols is available in the Library. See Placing Library Objects on page 714.
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By default, most door types are either single or double, depending on their width. You can specify how many panels a 
selected door has in the Door Specification dialog. See Options Panel on page 395.          

DOOR SIDES

Like walls, all doors have two sides: an interior side and an exterior side. This is the case even for doors placed in interior 
walls. See Exterior and Interior Walls on page 236.          

By default, the interior side of the door will face the direction that the door swings to open. If you prefer, you can specify 
that the interior side face the opposite direction in the Door Specification dialog. See General Panel on page 393.           

You can specify the materials for the two sides separately in the Door Specification dialog. See Materials Panel on page 
407.          

You can also specify different casing for the interior and exterior sides of exterior doors - that is, doors placed in exterior 
walls or walls defining a Garage or other exterior room type. See Room Types on page 289.           

DOOR CASING

Doors typically feature casing, or trim, on both sides of the wall opening. See Moldings /  Rails Panels on page 688.         

 l By default, interior doors use the same casing profile on both sides. You can specify that both sides be edited 
separately in the Door Specification dialog. See General Panel on page 393.         

 l Exterior doors can have different casing profiles on their interior and exterior sides.         

The default casing for interior and exterior doors is a basic rectangular stock profile. You can specify a door’s casing 
profiles  in the Door Specification dialog, or you can choose to suppress casing altogether. See Casing Panel on page 397.         

A separate molding profile can be specified for the lintel, or top horizontal molding. See Lintel Panel on page 398.          

Exterior and interior door casing will display in all views when the “Casings, Exterior” and “Casings, Interior” layers are 
turned on. In plan view, only the vertical side casing is shown.           

DOOR HARDWARE

Handles, locks, and hinges can be assigned to a door in the Door Specification dialog. See Hardware Panel on page 402.

In 3D views, handles and locks can also be applied directly from the Library Browser. Select a hardware item in the library, 
then click on the door to apply it to that side of the door. See Inserted Objects on page 715.          

 

Changing Door Swings
Door swing direction and hinge side can be changed using the edit handles and the Change Opening/Hinge 
Side and Change Swing Side edit buttons.

Note: If the door is set to draw closed, the swing as it appears in plan 
view has no effect on the 3D view. See Options Panel on page 395.

The Change Opening/Hinge Side  edit button is available for all doors except doors with multiple panels and garage 

doors.

The Change Swing Side  edit button is available for all doors except pocket doors. 
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HINGED DOORS

In addition to using the edit buttons, Hinged Doors and Shower Doors’ hinge side and swing direction can be changed using 
the triangular Rotate edit handle.

To adjust the angle of swing:

 1.  In plan view, select the door and grab the triangular handle.

 2.  Drag to change the amount of swing. 

 3.  Release the mouse. 

If you drag near the closed position, the door snaps to a closed position.

To change the swing using edit handles:

 1.  In plan view, select the door and grab the triangular edit handle.

 2.  Drag the pointer along the path of the new arc to change the hinge side and/or swing direction.

 3.  Release the mouse.

You can specify a Double Hinged Door to swing from its center 
in the Door Specification dialog. See Options Panel on page 

395.
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To change the swing using edit buttons:

 1.  In plan view, select the door.

 2.  To change the hinge side, click the Change Opening/Hinge Side  edit button.

 3.  To change the swing direction, click the Change Swing Side  edit button.

You can also specify a Hinged Door to swing in both directions 
in the Door Specification dialog. See Options Panel on page 

395.

SLIDING TYPE DOORS

Sliding, Pocket, Bifold, and Barn Doors are types of sliding door. 

Similar to hinged doors, the Opening/Hinge and Swing sides of a Sliding, Pocket, Bifold, or Barn Door can be changed by 
clicking and dragging its diamond-shaped edit handle. 

To change the side of a Sliding, Pocket, Bifold or Barn door that opens, select the door and click the Change 
Opening/Hinge Side  edit button.

Note: For a Pocket Door to change Opening Side, there must be enough 
room for the entire door to fit in the wall on that side.

To flip the fixed and moving sides of the door, click the Change Swing Side  edit button.

GARAGE DOORS

To change the side of a garage door that it faces, select it and click the Change Swing Side  edit button.
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Unlike other door types, the Swing side of a garage door cannot be modified using the edit handles. 

 

Special Doors
A variety of special doors and doorways can be created in Home Designer.

TRANSOMS ABOVE DOORS

Transom windows above doors are created the same as other stacked windows. See Grouped Windows on page 413.

WRAPPED OPENINGS

Wrapped openings of various shapes are available in the Doors & Doorways Library.          

You can also create a wrapped opening by unchecking Use Interior Casing and/or Use Exterior Casing in a Doorway’s 
Door Specification dialog. See Casing Panel on page 397. If base molding is present, it will wrap around the opening. 

RECESSED DOORS

A door placed in a brick or stone wall is often recessed into the wall’s exterior. In the illustration below, the door to the 
right is recessed, so the brick wraps the opening. The door on the left is not recessed, so the casing is outside the brick.           

You can specify a door as recessed in the Door Specification dialog. See Options Panel on page 395.          

OPENINGS IN RAILINGS

Use the Doorway  tool to open a railing for a stairway or other access. 
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To open a railing across an entire section, resize the doorway’s Width so that it is greater than the length of the railing in 
the Door Specification dialog. The opening resizes to the maximum width possible for that space. See General Panel on 
page 393.

To add a gate, specify the doorway’s Door Type as a Door, then choose an appropriate gate as the Door Style. A selection 
of gates is available in the Fences & Railings library folder. See Placing Library Objects on page 714.          

CREATING A DOORWAY WITH A RAILING

When a railing is specified as No Room Def, it can be positioned within a Doorway .

To create a doorway with railing

 1.  Place a Doorway  at the desired location in your plan.

 2.  Select Build> Railing and Deck> Straight Railing , then click and drag to draw a railing parallel to the wall 

with the doorway. 

 3.  Select the railing, then use the Resize edit handles to adjust the length of the railing as needed. See Using the Edit 
Handles on page 147.

 4.  With the railing selected, click the Open Object  edit button.

 5.  On the GENERAL panel of the Railing Specification dialog, check No Room Def and click OK. See General Panel 
on page 268.

 6.  With the railing still selected, Ctrl/⌘  + drag it into position within the doorway. See To move an object freely on 
page 169.
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PLACING A GABLE OVER A DOOR

Click the Gable Over Door/Window edit button to produce a gable roof over the selected door(s) the next time 
automatic roofs are built. See Gable/Roof Lines on page 609.

You can manually edit or delete this gable line at any time. Your changes take effect when the automatic roofs are rebuilt. 
This can also be used with group selected doors.

 

Door Specification Dialog
To open the Interior or Exterior Door Specification dialog, select a door or group of doors and click the Open Object 
edit button or double-click on a door using the Select Objects  or any Door  tool.

Whether a selected door is Interior or Exterior depends on where it is placed. See Interior vs Exterior Doors on page 379.

The Lintel panel is also found in the Window Specification 
dialog. See Window Specification Dialog on page 420. 

The Door Specification dialog has the following panels:
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GENERAL PANEL

  General

 l Door Style - Select Slab, Glass Slab, Panel, Glass Panel, Louvered, or Glass Louver from the drop-down list; select 
a style from the Library; or choose “Use Default” to use the default door style set in the Door Defaults dialog. See 
Door Defaults on page 379.

 l Select “Library” from the drop-down list or click the Library button to choose a door symbol from the library. Once 
a library door is selected, its name is added to the Door Style list. See Select Library Object Dialog on page 716.

 l Specify the Door Type as Doorway, Hinged, Sliding, Pocket, Bifold, Garage, Fixed, Barn, or Shower. In the Door 
Defaults dialogs, the Door Type cannot be changed. 

 l Specify the Swing Angle of the selected door in plan view, between 0° and 180°.

 o An angle of 0° displays the door as closed and an angle of 180° displays it as wide open.

 o The Swing Angle for Bifold doors and double doors that swing from the center can be no more than 90°. 

 o The Swing Angle also affects the door’s appearance in 3D views if Draw Closed is unchecked on the OPTIONS 
panel. See Options Panel on page 395.

 l Specify the Panel Offset, which is how far the selected door is offset from its default location. Most door types are 
centered in the wall’s Main Layer by default, while Barn Doors are positioned against the wall surface.

 
Size and Position

                 Specify the Size and Position of the selected door. 
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 l Specify the Width and Height of the door. These values do not include the jamb unless Door Size Includes Jamb is 
selected on the JAMB panel.

 l Specify the Thickness of the door. This option does not affect door symbols from the Library. See Door Style and 
Panels on page 386.

 l  Select the Elevation Reference from the drop-down list. This determines where the next two settings are measured 
from and also affects their labels. See Elevation References on page 20.

 o Specify the height to Top, measured from the selected Elevation Reference to the top of the door frame. 

 o Specify the height to Bottom, measured from the selected Elevation Reference to the bottom of the door frame. 

  Barn Doors

 l Specify the Side and Top Overhang values, which control how much the selected door extends past its wall 
opening.

 
Panel Frame Widths

Specify the dimensions of the selected door’s rails and stiles. Only available for Glass, Panel, and Louvered doors.          

 l Specify the Width of the stiles and top rail. Uncheck Uniform to specify separate values for the Left, Right, and 
Top of the frame, or leave it checked to use the same value for all three.

 l Specify the height of the Bottom rail.

  Louvers

 l Specify the Size, or vertical height, of the selected door’s louvers. Only available for Louvered and Glass Louvered 
doors.

 l By default, louvers face the direction that the door swings. Check Reverse Direction to reverse the direction that 
they face.

  Options

 l Check Reverse Interior/Exterior to reverse the two sides of the selected door so that they face the opposite 
direction. Only available when a door symbol from the Library is specified as the Door Style. See Door Sides on 
page 387.

 l Check Separate Trim and Materials for Each Side to specify the casing, lintels, and all materials for each side of 
the selected interior door independently. When unchecked, the two sides of the door use the same trim and materials. 
Only available when the selected door is placed in an interior wall. See Exterior and Interior Walls on page 236.

 
Preview

A preview of the door displays on the right side of the dialog box. A label indicates which side of the door is its Interior and 
which is its Exterior. See Dialog Preview Panes on page 21.
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OPTIONS PANEL

 
Door Panels

                 Specify the number of Door Panels or sections that the selected door has.  See Door Style and Panels on page 386.

 l Select Single Door Only to force the selected hinged, pocket or bifold door to be a single door, regardless of its 
width.

 l Select Double Door Only to force the selected hinged, pocket or bifold door to be a double door, regardless of its 
width.

 l Select Calculate From Width to use the program defaults. Hinged and pocket doors default to Single Door when 
less than four feet (1200 mm) wide; bifold doors do so when less than three feet (900 mm) wide. If the width is 
greater than this, Double Door is the default. 

Note: The Calculate From Width defaults are not editable.

 l For a selected Garage Door, specify the number of Vertical Panels.

 l When All Glass is unchecked, only the third panel from the bottom the door is a glass panel: the rest are solid 
panels. Check this box to make all of the panels glass. The number and style of the lites and the Muntin Width can 
be specified on the LITES panel.

 
Plan Display

The Plan Display settings control the display of dashed wall surface lines above the door in plan view. See In Plan Views 
on page 383.                 

 l Select Automatic to display wall surface lines only when the selected door is a Doorway.

 l Select Show Top Edge to display wall surface lines regardless of the door type.
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 l Select Hide Top Edge to not show wall surface lines regardless of door type.

 
3D Display

Specify whether the selected door is shown open or closed in 3D and cross section/elevation views. 

 l If Show Open is selected, the Swing Angle set on the General Panel on page 393 is used. 

 
Door Swing

Specify how the selected door swings. Most options here are only available when the selected Hinged or Pocket door is a 
Double Door. Not available for Bifold, Slider or Garage doors. See Changing Door Swings on page 387.         

 l Check Both Doors Swing to allow both sides of a Double Door to swing. 

 l Check Left Swing Only or Right Swing Only to allow only the left or right side of a Double Door to swing. 

 l Check Swings from Center to create a Double Door with hinges at the center rather than at the outside edges. 

 l Check Swings Both Directions to allow a door or both sides of a Double Door to swing both directions. 

 
Recessed Into Wall

The Recessed into Wall options allow you to recess the selected door’s jamb into a wall, away from the exterior surface. 
This setting also affects the exterior casing and lintel, if used. Only available if the door is placed in a multi-layered wall. 
See Wall Type Definitions on page 262.     

 l Check Recessed to activate the settings that follow.                 

Not Recessed

 l Select To Main Layer to recess the door to the wall’s Main Layer.

Recessed to Main Layer

 l Select To Sheathing Layer to recess the door to the wall’s sheathing layer. 

Recessed to Sheathing Layer

 
In Curved Wall

Specify whether a door placed in a curved wall is Straight or Curved. This setting affects both the frame and the door 
panel. Slider, Pocket, and Barn Doors are specified as Curved automatically and cannot be changed. See Drawing Curved 
Walls on page 244.
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Plinth Blocks

Add an Interior Plinth Block and/or Exterior Plinth Block to the selected door. Plinth blocks do not display in 3D views, 
but are counted in the Materials List. 

 
Preview

A preview of the door displays on the right side of the dialog box. See Dialog Preview Panes on page 21.   

CASING PANEL

The CASING panel is also found in the Window and Mulled Unit Specification dialogs. See Window Specification Dialog on 
page 420.

By default, interior and exterior casing is suppressed for doorways placed into railings: including solid railings and railing 
pony walls.         

 
Use Interior Casing

When this box is unchecked, no casing is used and the settings that follow are disabled.    

 l Casing Profile - Click the Library button to select a molding profile for the casing. A preview of the casing profile 
displays to the right. See Select Library Object Dialog on page 716.    

 l Click the Clear button to remove a selected casing profile from the door. When no profile from the library is 
selected, a basic rectangular stock profile is used.    

 l Specify the Width of the selected casing.    
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 l Define the Reveal, which is the distance between the inside edge of the door or window frame and the inside edge of 
the casing. 

 
Use Exterior Casing

Check this box to enable the settings that follow, then specify the exterior casing for the selected door(s) These settings are 
the same as those for the Interior Casing, and are not available for doors in interior walls unless Separate Trim and 
Materials on Each Side is checked on the GENERAL panel. See General Panel on page 393. 

 
Curved Wall Casing

These settings are enabled if the selected door or window is located in a curved wall. See Drawing Curved Walls on page 
244.                  

 l Door and window casing and jamb can be constructed three ways in curved walls:            

 l Straight - Both the door and casing are straight. This can be used where the wall’s curvature is not too sharp and the 
opening is not too wide. Not available for Sliding, Pocket, or Barn Doors. 

 l Radial - A vertical surface that would be perpendicular to a straight wall has its plane pass through the wall's center 
of curvature. 

 l Parallel - A vertical surface that would be perpendicular to a straight wall remains parallel to the line from the wall 
center through the opening center. 

 
Preview

A preview of the door displays on the right side of the dialog box. If casing is not specified for a Doorway or Passthrough, 
the Show Wall option will be toggled on automatically. See Dialog Preview Panes on page 21.

LINTEL PANEL

The settings on the LINTEL panel allow you to assign a lintel: a top molding that meets the side casing using a butt joint 
instead of a mitered joint.

The LINTEL panel is also found in the Window and Mulled Unit Specification dialogs. See Window Specification Dialog on 
page 420.
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Use Interior Lintel

Check Use Interior Lintel to enable the settings that follow, then specify the lintel applied to the interior side of the 
selected door(s) using these settings. When this box is unchecked, no lintel is used.         

 l Lintel Profile - Click the Library button to select a molding profile for the lintel. A preview of the selected profile 
displays to the right. See Select Library Object Dialog on page 716.

 l Click the Clear button to remove a selected lintel profile from the door. 

 l Specify the Width of the lintel. This value is independent of the casing’s width; however, the lintel does inherit its 
depth from the casing.

 l Specify how far to Extend the lintel past the outside edges of the casing on each side. 

 l Check Wrap to wrap the lintel profile back toward the wall. 

 
Use Exterior Lintel

Check Use Exterior Lintel to enable the settings that follow, then specify the exterior lintel for the selected door(s) using 
these settings. These settings are the same as those for the Interior Lintel, and are not available for doors in interior walls 
unless Use Exterior Trim and Materials is checked on the GENERAL panel. See General Panel on page 393.          

 
Preview

A preview of the door displays on the right side of the dialog box. See Dialog Preview Panes on page 21.         

SILL/THRESHOLD PANEL

The settings on the SILL/THRESHOLD panel of the Door Specification dialogs allow you to specify whether the door has a 
threshold or sills. These settings are also found on the SILL/THRESHOLD panel of the Window Specification dialog. See 
Sill/Threshold Panel on page 424.   

LITES PANEL

The settings on the LITES panel of the Door Specification dialogs are only available when the selected door is specified as a 
Glass door on the General Panel on page 393. These settings are also found on the LITES panel of the Window 
Specification dialog. See Lites Panel on page 428.   
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JAMB PANEL

The settings on the JAMB panel are similar to those on the FRAME panel of the Window Specification dialog. See Frame 
Panel on page 427.         

By default, Has Jamb is unchecked for doorways placed into railings: including solid railings and railing pony walls.          

 
Has Jamb

Check Has Jamb to enable the settings that follow, then specify the attributes of the selected door’s jamb using those 
settings. The jamb is not included in the door’s size, which is set on the General Panel on page 393.         

 l Specify the Positioning of the door. These settings affect what the door's Size settings on the GENERAL panel are 
describing; however, switching these settings does not affect the Size values:

 o Select Door Size Includes Jamb to specify size as a total of the door panel plus jamb width.

 o Select Door Size Excludes Jamb to specify the size of the door panel only.

 l These values only affect the door's specified size when Door Size Includes Jamb is selected, above: 

 o Specify the Sides Width, which is the thickness of the pieces of the door jamb that display in plan view. This value 
is subtracted from the "pocket" side rough opening for Pocket Doors when wall framing is generated. See Pocket 
Doors on page 381.

 o Specify the Top Width, which is the thickness of the top vertical piece of the door jamb.

 l Uncheck Fit Jamb to Wall to specify the Depth and Inset of the selected door’s jamb. When this box is checked, the 
jamb Depth automatically extends from the Recessed Into Wall layer to the wall’s inside surface with an Inset of 0”. 
The Recessed Into Wall layer is specified on the OPTIONS panel of this dialog.

 o Specify the Depth of the door jamb from front to back.

 o Specify the jamb’s Inset, which is measured from the Recessed Into Wall layer and moves the door jamb towards its 
interior side. If used, the casing and lintel are not affected by this setting.

 
Preview

A preview of the door displays on the right side of the dialog box. See Dialog Preview Panes on page 21.         
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ARCH PANEL

The settings on the ARCH panel are also found in the Window Specification dialog; however, it is not available for window 
symbols from the library, and its settings are not available if a selected window has been modified using the SHAPE panel. 
See Shape Panel on page 429.         

 
Arch

Define the style and size of the Arch.          

 l Select a Type of arch from the drop-down list.         

 l Specify the Height of the arch, as measured from the base of the arch to the top of the door. Not available for Round 
Top and Octagonal Arches.         

 l The Radius can also be defined for Tudor and Double Arches.

 
Options

Define the orientation of the arch. 

 l Check Reflect Vertically to reflect the arch, top to bottom. This option cannot be used if a Sill is specified, and is 
typically used with windows rather than doors. See Window Specification Dialog on page 420.         

 l Select Full Arch to produce an arch with the apex at the door’s center.         
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 l Select Left Arch to produce an arch with the apex on the door’s right side.         

 l Select Right Arch to produce an arch with the apex on the door’s left side.         

Note: The Left and Right settings here on this panel refer to the door 
or window as viewed from its exterior.

 
Preview

A preview of the door displays on the right side of the dialog box. See Dialog Preview Panes on page 21.         

HARDWARE PANEL

Many of the settings on the HARDWARE panel are Dynamic Defaults: if “Use Default” is selected, the setting in the Door 
Defaults dialog for the selected door’s Type is used. See Dynamic Defaults on page 58. 

 
Handles

. 

 l Select an Interior Handle and/or Exterior Handle from the drop-down lists. Select “Library” or click the Library 
button to select a handle from the library. See Select Library Object Dialog on page 716.

 l When a handle from the Library is selected, you can click the Edit button to customize its size and angle. See 
Hardware Size/Orientation Dialog on page 476.

 l Specify the location of the door handles In From Door Edge.

 l Specify the location of the door handles Up From Bottom.

 
Locks
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 l Select an Interior Lock and/or Exterior Lock from the drop-down lists. Select “Library” or click the Library 
button to select a lock from the library. 

 l Specify the location of the door locks Up From Bottom. The locks use the same In From Door Edge value as the 
handles.

To use the same handle and lock on both sides of a door, select 
“Match Interior” as the Exterior option. 

 
Hinges

Only Hinged and Bifold doors receive hinges.

 l Select a style of Hinges from the drop-down list. Select “Library” or click the Library button to select a hinge style 
from the library. 

 l Specify the distance In From Top/Bottom of the door to the center of the top and bottom hinges. 

Note: For hinges to look right, it is best to have at least a 1/4" (6 
mm) reveal for the interior, or hinge side, door casing. 

 l Specify the Number of Hinges on the selected door. Interior hinged doors and bifold doors typically have two 
hinges while exterior hinged doors have three.

 
Sliding Tracks

Only available when a Barn Door is selected.

 l Select a Sliding Track from the drop-down list. Select “Library” or click the Library button to select a track from 
the library. See Select Library Object Dialog on page 716.

 l Specify the track’s Height Above Door.

 l Select a style of Hangers from the drop-down list. Select “Library” or click the Library button to select a hanger 
from the library. 

 l Specify the distance In From Sides of the door to the center of the outermost hangers. 

 l Specify the number of Hangers to be evenly spaced along the door.

 
Options

Check Hardware on Fixed Section to include handles, locks, and hinges on the fixed side of a double Hinged door. Only 
available for Double Doors with Left or Right Swing Only selected. See Options Panel on page 395.         

 
Preview

A preview of the door displays on the right side of the dialog box. See Dialog Preview Panes on page 21.

SHUTTERS PANEL

The settings on the SHUTTERS panel of the Door Specification dialogs are also found on the Shutters panel of the Window 
Specification dialog. See Shutters Panel on page 403.         

OPENING INDICATORS PANEL

The settings on the OPENING INDICATORS panel control the appearance of the selected hinged or sliding door's opening 
indicator in camera views using the Vector View Rendering Technique. These settings are also available for windows and 
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cabinets. See Opening Indicators on page 384.

 
Opening Indicators

Specify whether the selected door's opening indicators display.

 
Sliding Indicator Style

Available for Sliding, Pocket, Barn, and Garage doors, as well as Single Hung, Double Hung, and Sliding windows. Sliding 
indicator arrows display centered over all movable door panel(s) or window component(s).    

 l Select Fixed Length, then specify the desired Length of the indicator arrow in the text field.

 l Select Relative Length for an indicator arrow sized relative to the movable component it is drawn over.

 l Specify the Inset from Edge, which is the distance of each end of the indicator arrow line from the adjacent edge of 
the associated door panel or window component. If a panel or component is not wide or tall enough to accommodate 
the Inset distance on both ends of the arrow line, this value will be ignored and an arrow 10" (250 mm) long will be 
used.    

 l Specify the Horizontal Offset, which allows you to offset the arrow line to the right or left using a positive or 
negative value.    

 l Specify the Vertical Offset, which allows you to offset the arrow line upwards or downwards using a positive or 
negative value.

 
Preview

A preview of the door displays on the right side of the dialog box. Opening indicators only display in Vector Views. See 
Dialog Preview Panes on page 21.
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ROUGH OPENING PANEL

  Rough Opening

 l The Total Width, Total Height and the Header Bottom Height are reported here for reference.

 l  Specify the Behavior used to define the rough opening:      

 o When Additional Space is selected, the rough opening is equal to the specified size of the door or window plus 
additional space, specified below.      

 o When Clearance Gap is selected, the rough opening for doors is equal to the specified size of the door plus the 
thickness of its jamb plus the values specified below. For windows, the rough opening is equal to the specified size 
plus the values set below.      

 l When Additional Space is the selected Behavior:

 o Specify the total Additional Width added to the width of the window frame or that of the door, not including jamb.

 o Specify the total Additional Height added to the height of the window frame or that of the door, not including jamb. 
If the selected opening at floor level, the bottom of the rough opening will be at the height of the subfloor.

 l When Clearance Gap is the selected Behavior:

 l Specify the Side Clearance, which is the space on each side of the window frame or door jamb, between it and the 
adjacent trimmers.

 l Specify the Top Clearance, which is the space above the window frame or door jamb, between it and the header or wall 
top plate.

 l Specify the Bottom Clearance, which is the space below the window frame or door jamb, between it and the sill, 
bottom plate, or subfloor.
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  Add for Concrete Cutout

 l Specify the amount to add to Each Side of the door opening when the upper part of the door is in a framed wall and 
the lower part is located in a concrete or masonry wall, stem wall, or garage curb. See Wall Type Definitions on page 
262.

 l Uncheck Show in Plan to suppress the display of the concrete cutout in plan views. A concrete cutout will only 
display in plan views if it is located in a garage curb. See In Plan Views on page 383.

FRAMING PANEL

The settings on the FRAMING panel control how the selected door or doors is framed. A similar panel is also found in the 
Window Specification dialog. See Window Specification Dialog on page 420.         

Home Designer is dependent upon user input and does not 
calculate loads or perform structural analysis. Always consult 

your local building authorities and contact a licensed engineer for 
structural calculations.

 
Header

Specify the characteristics of the selected door’s header. See Headers on page 628.         

 l Uncheck Include Header to prevent a structural header from generating when wall framing is created. When this 
box is checked, a header as defined below is generated; when it is unchecked, a single, non-structural, horizontal 
framing member of the same type as the wall studs is created above the door opening.    

 l Select the header’s framing member Type from the drop-down list. See Framing Types on page 629.    

 l Specify the Thickness of each header framing member.    

 l Specify the Count, which is the number of the framing members used to create the header. Up to 10 header boards 
can be specified, but only those that fit within the wall’s framing layer will be generated when wall framing is 
created.    

 l Specify the vertical Depth of the header. This value does not include the top and bottom chords of a Box Header.    
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 l In the Door and Window Defaults dialogs, an additional Calculate from Width check box is available. When 
checked, the header Depth is automatically calculated based on settings in the Framing Defaults dialog and the 
door’s current width. See Openings Panel on page 641.    

 l Select a Framing Method from the drop-down list. See Headers on page 628.    

 o Standard headers are composed of vertically-oriented framing members.

 o Flat headers are composed of horizontally-oriented framing members.

 o Boxed headers have vertical framing members with horizontally-oriented top and bottom rails. The horizontal boards 
are not included in the header Depth. 

 
Supports

Specify the number of Trimmers and King Studs to be generated on each side of the selected door.          

 
Sill

When the bottom of a door is raised sufficiently off the floor, it will require a sill as part of its framing.          

 l Specify the Thickness, which is the vertical thickness of the sill board.   

 l Check Double Bottom Sill to generate two bottom sill members of the specified thickness instead of one.   

MATERIALS PANEL

The MATERIALS panel is available for a variety of objects throughout the program. For more information, see Materials 
Panel on page 750.

LABEL PANEL

Door labels display in plan view when the “Doors, Labels” is turned on and use the Text Style assigned to that layer. See 
Door Labels on page 385. 

For information about the settings on this panel, see Label Panel on page 376.

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 967.         

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used the materials list. For more information, see Object 
Information Panel on page 968.         

MANUFACTURER PANEL

The MANUFACTURER panel provides contact information for the selected door’s manufacturer. Only available for doors from 
Manufacturer library catalogs. See Manufacturer Catalogs on page 705.         
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Chapter 16
 

Windows

Home Designer can model a wide variety of windows. Fixed glass, hung, casement, sliding, awning, hopper, and louver 
window styles can all be created with the standard Window tool. The shape of a window can be angled or made into a round 
top or other arch styles. Home Designer can create bay, box, and bow windows with a single click. In addition, the library 
contains many mulled window combinations.

TOPICS

Window Defaults 409
Window Tools 409
Special Windows 411
Grouped Windows 413
Mulled Units 414
Window Levels 415
Displaying Windows 416
Editing Windows 418
Window Specification Dialog 420
Bay, Box, and Bow Windows 435
Bay, Box, Bow Windows and Roofs 437
Bay/Box and Bow Window Specification Dialogs 440
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Window Defaults
Default Settings can be accessed by selecting Edit> Default Settings. Select Window from the Default Settings 
dialog and click the Edit button.

You can also double-click the Window Tools  parent button to open the Window Defaults dialog.           

The settings in the Window Defaults dialog control the attributes of a window when it is initially placed in a plan, so you 
should define the type of window that will be placed most often in your model. See Default Settings on page 57.

The panels in the Window Defaults dialog are similar to those found in the Window Specification dialog, with one 
exception: 

On the GENERAL panel of the Window Defaults dialog, you can specify the Minimum Separation between window and/or 
door units in the plan.

The Minimum Separation value in the Window Defaults dialog specifies how close window and/or door units can be to 
each other. This setting also determines the width of the shared casing between windows. 

For more information, see Window Specification Dialog on page 420.

DYNAMIC WINDOW DEFAULTS

A variety of window default values are dynamic, including the Window Type, Casing, Lintel, Sash, Frame, Treatments, 
Framing, and Rough Opening. All Materials are also dynamic. When a dynamic default is changed, existing windows using 
the default value are affected. See Dynamic Defaults on page 58. 

WINDOW FRAMING

The defaults for window framing can be defined in the Window Defaults dialogs. You can also specify an additional amount 
to cutout for window openings in concrete walls when the upper part of the window is located in a framed wall. See Rough 
Opening Panel on page 434 and Framing Panel on page 434.

The default header depths for different spans can be set in the Framing Defaults dialog. See Openings Panel on page 641.

 

Window Tools
To place a window, select Build> Window and choose the desired Window Tool. Move your mouse pointer over a 
wall section, then click to place a window in the wall at that location.

 l If there is room enough along the wall to fit a 6” (150 mm) wide Standard Window, a preview of the window will 
display and a window can be placed. 

 l The Bay, Box, and Bow Window tools do not have preview outlines. If a minimum width of 30” (725 mm) cannot be 
accommodated at the location where you click, a warning message will display and a window unit will not be created.

Standard Windows, Passthroughs, and Wall Niches can be placed in both straight and curved walls, as well as span across 
straight, collinear wall segments. In contrast, a Bay, Box, or Bow Window can only be placed in a single, straight wall.

Windows can also be placed in the Pony Walls; however, if the upper wall is a Railing, only Windows, Passthroughs, and 
Wall Niches can be placed provided that they are located entirely within the lower wall. See Pony Walls on page 238.
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Windows cannot be placed in a wall specified as Invisible or if the wall in question is on a locked layer. See Locking Layers 
on page 126. See Room Dividers and Invisible Walls on page 239.

STANDARD WINDOWS

Select Build> Window> Window, then click on a straight or curved wall to place a Standard Window at that 
location.

A Standard Window is a single window that is not a bay, box, bow window, a corner window or a blocked unit. These 
special types are made up of multiple Standard Windows. 

A Standard Window that is part of a special window is called a Component Window.

Standard Windows can be specified as any of a variety of window types, such as double hung, casement and awning. See 
Window Specification Dialog on page 420.

BAY WINDOWS

The roof is affected by Bay, Box and Bow Windows. These 
windows should therefore be placed before the roof is built.

A Bay Window is composed of three wall sections, each with a single component window. The two side walls are at 
an angle to the main wall. Select Build> Window> Bay Window and click on a straight wall to produce a bay 

window. 

When initially placed, bay windows measure  2’-2” across at the front, 4’-2” across at the back, and are 1’-0” deep. The 
component windows are specified in the Window Defaults dialog and their sizes adjust to fit the available space. 

BOX WINDOWS

A Box Window is a bay window with side angles set at 90°. Select Build> Window> Box Window and click on a 
straight wall to produce a box window. 

Box windows initially measure 4’-2” wide with a depth of 1’-6”. The component windows are specified in the Window 
Defaults dialog and their sizes adjust to fit the available space. 

BOW WINDOWS

A Bow Window is a group of identical wall segments that form a segmented curve. Select Build> Window> Bow 
Window and click on a straight wall to produce a 5-section bow window. 

Bow windows can be composed of between two and twenty sections. The number of bow window components can be 
changed in the Bow Window Specification dialog. See Bay/Box and Bow Window Specification Dialogs on page 440.          

The component windows are specified in the Window Defaults dialog. Their sizes adjust to fit the available space.
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The 5-section bow below has a 4’-10” radius centered 3’-9” inside the wall, giving an opening 5’-10” across and a depth of 
11½”.

Note that for a bow with an odd number of sections, the radial dimension is from the center of the arc to an outside corner 
where two window sections join. The depth (11 ½”) is measured to the flat area of the center section, not to a corner. As a 
result, the radius is a bit greater than the sum of the depth and the distance from the center of the bow’s curve to the exterior 
of the wall.          

Note: Bay, box, and bow window areas are not included in the living area 
or in room standard area calculations. They are included in room interior 
area calculations.

PASS-THROUGHS

Select Build> Window> Pass-Through, then click on a straight or curved wall to place a Pass Through at that 
location.         

A Pass-Through is simply a wall opening without a window unit placed inside. Like a window, it can have casing and a sill. 
It does not, however, have a sash, frame, or glass. It is one of the window Types available in the Window Specification 
dialog. See General Panel on page 420.         

WALL NICHES

Select Build> Window> Wall Niche, then click on a straight or curved wall to place a Wall Niche at that location.

A Wall Niche is a wall opening that does not extend through the entire depth of the wall. You can specify the niche’s depth 
in the Window Specification dialog. See General Panel on page 420.

WINDOWS LIBRARY

Select View> Library Browser, then browse to Home Designer Core Catalogs> Architectural> Windows to access a 
selection of special window units. Select the desired window, then click on a wall to place the window at that 

location. 

 

Special Windows
A variety of special windows can be created using multiple standard windows, the edit tools or custom symbols.

CREATING MANUAL BAY, BOX AND BOW WINDOWS

Sometimes it is easier to draw bay, box and bow windows manually than to use the automatic tools. Bays created using 
walls can have more than one window per section, which is not possible using a bay window unit.

Bear in mind that moving a manually created bay, box or bow window is generally more difficult than moving a unit 
created with one of the Window Tools  since it is composed of individual walls.
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CORNER WINDOWS

To create a corner window, first create the desired window on each side of the corner. For best results, the heights, casing, 
and sills of both windows should be the same. For glass that meets at the corner: 

 l Specify both windows as Fixed Glass.          
 l Use each window’s Move edit handle to position it all the way in the corner. To do this, drag the Move handle past the 

corner and parallel to the wall that the window is placed in. When the preview outline moves into the middle of the 
wall corner, release the mouse button.          

 l You can also position a window in a corner using its end Resize handle.          
 l Select Mitered in the Window Specification dialog. See Frame Panel on page 427.          

Angled top, or shaped windows can be components of corner windows as long as their heights are equal at the corners. 
Windows with single or two segment tops can be used, but windows with three cannot. If a two segment window is used, 
the segment nearest the corner must be flat.          

When a corner post is required, select Post instead of Mitered. There are a number of ways to control its size.          

 l Use dimensions to position the windows relative to the corner. By default, windows will stop when their interior 
casing bumps into the adjacent wall. See Editing Windows on page 418. 

 l To move a window all the way into a corner, check Ignore Casing for Opening Resize. See General Plan Defaults 
Dialog on page 60. 

 l To produce a minimal corner post and no siding or casing between the windows, use their Move edit handles. Click 
and drag each window past the exterior corner until its preview outline moves into the middle of the wall corner. 

SPECIAL WINDOW SHAPES

A selection of special shaped windows is available in the Windows Library, including arched windows and mulled units. 

In addition, you can create a wide variety of window shapes in the Window Specification dialog, including:         

 l Arched windows. See Arch Panel on page 431.         
 l Trapezoidal windows. See Shape Panel on page 429.         
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RECESSED WINDOWS

A window or mulled unit placed in a brick or stone wall is often recessed into the wall’s exterior, so the brick wraps the 
opening.         

You can specify a window as recessed in the Window Specification dialog. See Options Panel on page 422.          

PLACING A GABLE OVER A WINDOW

Click the Gable Over Door/Window edit button to produce a gable roof over the selected window(s) the next time 
automatic roofs are built. See Gable/Roof Lines on page 609.         

You can manually edit or delete this gable line at any time. Your changes take effect when the automatic roofs are rebuilt. 
This tool can also be used with group selected windows.         

STAINED GLASS

A selection of solid stained glass materials is available in the Home Designer Core Catalogs> Materials> Glass library. See 
Materials on page 745.         

VENTS

A selection of attic, foundation and gable vents are available in the Library Browser. See The Library on page 691.

Vents are placed in the same manner as regular windows and can be edited in much the same way, as well. 

 

Grouped Windows
Windows can be grouped together to create a wide variety of custom configurations. Stacked windows are easy to create in 
3D views, particularly cross section/elevation views, using their edit handles. See Editing Windows on page 418.
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Notice how the windows and door in this example are separate, with spaces between them. Doors and/or windows can also 
be positioned so that there are no spaces between the windows and door units, and the casing between them appears to be 
shared. To help organize their display in plan view, you can place stacked windows of varying heights on different Window 
Levels. See Window Levels on page 415.

AUTOMATICALLY MULLED OPENINGS

To form a mulled group of windows and/or doors, move them close enough together so that their casings touch. Once the 
casings touch, the windows are mulled together with one casing between the two of them. 

The sill of each window in the group must be at the same level for them to share the middle casing; however, the casing 
tops do not. The casings are modeled as if they are one unit but the windows remain separate objects for dimensioning and 
the Materials List.

Windows can be automatically mulled to doors if the bottom of the window is at the elevation of the floor, equal to the 
bottom of the door. 

The Minimum Separation value in the Window Defaults dialog specifies how close window and door units can be to each 
other. This setting also controls the width of the shared casing between adjacent windows. See Window Defaults on page 
409.          

MULLED UNITS IN THE LIBRARY

A selection of mulled window units is available in the Windows library. To place one in your plan, select it and click 
on a wall in any view. See Placing Library Objects on page 714.

MULTIPLE STACKED OPENINGS

If four or more multiple windows or doors occupy the same space in a wall, a Caution   symbol will display at the 
problem location in plan view.

Click on the Caution   symbol that displays over the wall to open a contextual menu, then select Delete Duplicate to 
delete a duplicate opening. When no more Caution symbols remain, you should then confirm that the remaining three 
openings meet your needs and delete any that are unnecessary.

 

Mulled Units
A mulled unit is a group of two or more windows and/or doors blocked together to form a single unit. A selection of mulled 
units is available in the Library Browser.
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SELECTING COMPONENTS OF MULLED UNITS

To select a component of a mulled unit from the library, click at the location of the component in question, then click the 
Select Next Object  edit button or press the Tab key until that individual component is selected. Only the component 

clicked on is selectable using this method. If you need to select a different component, click on it and repeat the process.

The selected component may be on any window level in the mulled unit. If there are multiple levels, it is easiest to select the 
components in a 3D view. When you have selected an individual component, you can change its parameters in the Window 
Specification dialog. See Window Specification Dialog on page 420.

If the selected component is not itself a mulled unit and has no components above it, its Height and Arch parameters can be 
changed. Changing the Height causes the component top to move. The bottom remains stationary.

DISPLAYING MULLED UNITS

As with other windows, the display of mulled window units is controlled in the Layer Display Options dialog. See 
Layer Attributes on page 125.

Mulled units are placed on the “Windows” layer by default and have a single label, which is on the “Windows, Labels” 
layer. Mulled units from the library are also included in the windows category of the Materials List. If the component 
objects of a mulled unit have unique moldings or materials, they will not be noted in the Materials List.

If a mulled unit includes a door, Treat as Door will be checked in the Mulled Unit Specification dialog. When this box is 
checked, the unit’s default layer is “Doors” and its label is placed on the “Doors, Labels” layer. Units set to Treat as Door 
are also included in the “Doors” category of the Materials List. See Options Panel on page 422. 

You can, if you wish, display a mulled unit’s individual component labels instead of a single label for the unit. Labels are 
placed on the layers they would be on were the unit not mulled. A mulled unit’s label setting also affects how it is listed               in 
the Materials List. See Label Panel on page 376.         

 l When Suppress All Labels is selected, individual components are counted               in the Materials List.         
 l When Show Component Labels is selected, components are counted               in the Materials List.
 l When Show Single Label for Entire Unit is selected, the unit is treated as a single object the materials list.

\\

 

Window Levels
It is often necessary to position more than one window, mulled unit, and/or door at the same location along a wall in plan 
view: for example, to create an entry with side lites and transom. 
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To help control and organize the appearance of stacked wall openings in plan view, you can assign windows at various 
heights to different Window Levels.           

Window Levels do not define the height of a window, just the appearance and behavior of windows and doors in plan view.          

WINDOW LEVEL ZERO

Window Level 0 (zero) is the Window Level that all windows and doors are always placed on by default.            

 l In plan view, windows and doors on the Window Level 0 display the line color and style of the layer they are on. 
Windows on any other level appear light gray.          

 l When you click on stacked doors and windows in plan view, those on Window Level 0 are selected first. To select an 
opening on another level, use the Select Next Object  edit button. See Select Next Object on page 143. 

 l Only windows and doors on the Window Level 0 can be located by dimension lines as they are drawn. You can, 
however, add an extension line to locate an opening on a non-default Level. See Adding an Extension Line on page 
338.         

Once the window is created, its parameters, including Window Level, can be changed. See Editing Windows on page 418.            

 

Displaying Windows
The display of windows and window labels in floor plan and 3D views can be controlled in the Layer Display 
Options dialog. See Layer Display Options Dialog on page 127.

Along with the windows themselves, the display of a number of window components can also be controlled by layer:

 l Interior and exterior window casings are located on the “Casings, Exterior” and “Casings, Interior” layers and can 
display in all views. In plan view, the sills and vertical side casings will be shown, but the horizontal top casing or 
lintel will not. If a window is recessed, the affected wall layers will adjust to accommodate the casing. 

 l Window and door shutters are located on the "Shutters" layer and can display in all views. Shutters can also be set to 
Show Closed or open. See Shutters Panel on page 432.

 l Window curtains and blinds are located on the "Windows, Curtains & Blinds" layer, which controls their display in 
camera views only. See Treatments Panel on page 432.

 l When the “Opening Header Lines” layer is turned on in plan view, headers are represented by dashed lines within each 
window. These lines do not correspond to actual framing objects and cannot be selected. In addition, header framing 
members can be set to display. See Wall Framing on page 627.      

 l If a window is placed in a Garage room at a height where it extends into the stem wall or curb, a cutout in the concrete 
will display on the floor below. You can specify the cutout’s size and whether it displays in plan view in the Window 
Specification dialog. See Rough Opening Panel on page 405.      

If the “Windows” layer is not set to display, window casing and other components are not visible, but the openings in the 
walls where they are located can still be seen.

Windows can only be placed in walls, so if a wall’s layer is turned off in plan view, any windows placed in that wall will 
not display, either. In 3D views, however, windows can display independent of their containing walls: 

 l When Hide Camera-Facing Exterior Walls is in use in the current view. See Displaying Walls on page 246. 
 l When Display Openings Independent of Walls and Roofs is checked in the 3D View Defaults dialog. See 3D View 

Defaults Dialog on page 774.
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IN PLAN VIEW

A window’s frame, glass, and sill are all represented in plan view. This makes some window types, notably Sliding and 
Double and Triple Casement windows, distinguishable. 

Window Types in plan view

By default, when a window is located entirely in one part of a pony wall, and that part is not displayed in plan view, the 
window’s outline is shown but the wall’s layer lines and fill drawn through it. You can instead display windows in the non-
displayed parts of pony walls the same as in the displayed parts, or not at all. See Pony Wall Defaults on page 230.          

Bay, box, and bow windows have dimensions lines associated with them. 

 l You can suppress their display by turning off the “Manual Dimensions” layer or on a unit by unit basis in the unit’s 
specification dialog. See Bay/Box and Bow Window Specification Dialogs on page 440. 

 l The arrow style and fill are set in the Dimension Defaults dialog. See Dimension Defaults Dialog on page 322.             

IN 3D VIEWS

In addition to the components that are drawn in plan views, in camera views, interior and exterior window treatments 
display when the "Windows, Curtains & Blinds" layer is on. In 3D Vector Views, windows can also display opening 
indicator arrows. See Opening Indicators on page 384.           

You can also specify whether window and door glass is opaque or transparent in the Rendering Technique Options dialog. 
When Opaque Window Glass is used, window and door glass uses the color specified for the active Rendering Technique. 
See Rendering Technique Options on page 834.          

Windows as well as doors can display in 3D Framing Overviews when Display Openings Independent of Walls and 
Roofs is checked in the 3D View Defaults dialog. See 3D View Defaults Dialog on page 774.

WINDOW LABELS

Window labels display in floor plan view, centered on the windows they represent, when the “Windows, Labels” layer is 
turned on and use the Text Style assigned to their layer. Similarly, Wall Niche labels display in the same manner when the 
"Wall Niches, Labels" layer is turned on. See Label Panel on page 376.

Automatic window and niche labels indicate Width and Height, followed by Type. For example: 

 l In U.S. Unit plans, the automatic label for a 3’-0” wide, 4’-0” high double hung window will read 3040 DH.
 l In metric plans, the automatic label for a 900 mm wide, 1200 mm high double hung window will read 900x1200 DH.
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You can specify whether a Bay, Box or Bow Window displays a single label or displays the labels of its component 
windows. See Bay, Box, and Bow Windows on page 435.

 l When Suppress All Labels is selected, individual components of Bay, Box and Bow Windows are counted in the 
Materials List.              

 l When Show Component Labels is selected, components of Bay, Box and Bow Windows are counted                  in the Materials 
List.             

 l When Show Single Label for Entire Unit is selected, the Bay, Box or Bow Windows has one label in plan view but 
each component is counted separately in the materials list.             

These options are also available for mulled units but affect their display the materials list somewhat differently. See 
Displaying Mulled Units on page 415.          

Customized labels can also be specified in the Window Specification dialog.

IN THE MATERIALS LIST

The materials associated with windows are listed under different Categories in the Materials List:

 l Windows - Lists windows units, including Passthroughs.     
 l Interior Trim - Lists interior casing, lintels, aprons, and sills.     
 l Exterior Trim - Lists exterior casing, lintels, aprons, sills, and shutters.     
 l Wall Board - Lists the backerboard associated with Wall Niches.     

As with other objects, there are a number of ways to control how, or whether, windows are included in the Materials List. 
See Organizing Materials Lists on page 953.      

You can add and edit information about a window’s accessories in the Window Specification dialog. See Components Panel 
on page 967.      

 

Editing Windows
Before a window can be edited, it must be selected. Click on a window when the Select Objects  tool or any of the 

Window Tools  are active. Doors and/or windows can also be group-selected and edited. See Selecting Objects on page 

142.

To select a window that is part of a blocked unit, click the component window, then click the Select Next Object  edit 

button. See Selecting Components of Mulled Units on page 415.

Once selected, windows can be edited using their edit handles, the Edit Toolbar buttons, and their specification dialogs.

USING THE EDIT HANDLES

In plan view, click either of the two end handles and drag along the wall to change the width. The label showing the size 
updates as the window is resized. 

In 3D views, a selected window has five edit handles: the Move handle at the center and a Resize handle on each edge. 
Click and drag an edge handle to resize the window. If window labels are set to display, they will each have a small square 
Move edit handle. See Displaying Windows on page 416.

418



Home Designer Pro 2025 Reference Manual - Editing Windows

Using the edit handles, a window resizes according to the currently active Edit Behavior . See Defaults, Preferences, 

and Edit Behaviors on page 138.    

In 3D views, a selected window has five edit handles: the Move handle at the center and a Resize handle on each edge.  
Click and drag an edge handle to resize the window. 

A single window or a group of windows can be moved with the center edit handle.

A door or window moved against an intersecting wall temporarily stops when it is the casing distance from the intersecting 
wall. Enable Ignore Casing for Opening Resize in the Plan Defaults dialog to turn off this behavior. See General Plan 
Defaults Dialog on page 60.

You can continue to drag the selected window and  it will resume movement past or onto the intersecting wall. 

To create a corner window, drag the Move handle straight out past the wall corner, parallel to the selected window’s wall. 
See Corner Windows on page 412.

IN THE SPECIFICATION DIALOG

The most precise method of editing an individual window or group of windows is to use the Window Specification 
dialog. The window type, size, casing, materials, shape, and more can all be specified in this dialog. See Window 

Specification Dialog on page 420.

USING THE EDIT TOOLS

A selected window or windows can be edited in a variety of ways using the buttons on the Edit Toolbar. See The Edit 
Toolbar on page 92.

  Gable Over Door/Window  creates a gable over the selected window(s) the next time the roof is rebuilt. See 
Gable/Roof Lines on page 609.     

  Change Wall Side moves a selected Wall Niche to the opposite side of the wall. See Wall Niches on page 411.

USING DIMENSIONS

Like various other objects, windows can be moved using dimensions. See Moving Objects Using Dimensions on page 
341. 

You can specify how windows and doors are located by dimensions in the Dimension Defaults dialog. Dimensions can be 
set to locate the centers, sides, casing, and/or rough openings of windows and doors, or you can choose to not locate them at 
all. See Locate Manual Panel on page 325.

When they are generated or being drawn, dimension lines can only locate windows and doors on the Default Level. You 
can, however, add an extension line to an existing dimension line to locate an opening on a non-default Level. See Window 
Levels on page 415.          

Once a dimension line has been drawn, you  can move or add its extension lines to locate non-default locations on a window. 
See Editing Extension Lines on page 338. 

WINDOW CASING, SILLS, AND MILLWORK

Windows often feature casing, or trim, on both sides of the wall opening as well as a sill on one or both sides. See Moldings 
/  Rails Panels on page 688.          

The default casing for windows and doors is a basic rectangular stock profile. You can specify a window’s casing profiles in 
the Window Specification dialog, or you can choose to suppress casing altogether. See Casing Panel on page 397.          
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A separate molding profile can be specified for the lintel, or top horizontal molding. A sill profile can be specified, as well. 
See Lintel Panel on page 424.          

Additional millwork items can be applied above and below the window’s casing on its exterior side. See Treatments Panel 
on page 432.           

Each of these objects can be replaced with a different profile or object directly from the library in 3D views. Select a 
molding profile or millwork item, then click on the window component you want it to replace. See    Replace From Library 
on page 717.           

WINDOW TREATMENTS AND SHUTTERS

Curtains and blinds can be assigned to the interior side of windows in the Window Specification dialog. See Treatments 
Panel on page 432.

Shutters can be assigned to the exterior of windows in a similar manner. See Shutters Panel on page 432.

Each of these objects can be replaced with a different object directly from the library in 3D views. Select a window 
treatment or shutter item, then click on the window component you want it to replace. See    Replace From Library on page 
717.      

 

Window Specification Dialog
To open the Window Specification dialog, select a window or a group of windows and click the Open Object edit 
button; or double-click the window using the Select Objects  or a Window  tool. 

This dialog is also available for the components of Bay, Box, and Bow Windows. See Bay, Box, and Bow Windows on page 
435.

The settings in this dialog are similar to those in the Window Defaults dialog. See Window Defaults on page 409.

The settings in this dialog are also similar to those in the Wall Niche, Mulled Unit and Window Symbol Specification 
dialogs. Although similar, a number of the options cannot be edited when either a window symbol or a mulled unit is 
selected, and some panels are not available. See Grouped Windows on page 413.

The panels that are available in the Window Specification dialog will vary depending on whether the selected window is a 
regular window or a mulled unit or symbol object from the library.

GENERAL PANEL

In the Wall Niche Specification dialog, only the Size and Position settings on this panel are available. See Wall Niches on 
page 411.
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Window Type

Select the type of window from the list. The first entry in the list is the “Use Default”, which is set in the Window Defaults 
dialog. 

  Size and Position

 l Specify the window’s Width and Height. These values do not include the window frame unless Window Size 
Includes Frame is selected on the FRAME panel. 

 l Select the Elevation Reference from the drop-down list. This determines where the next two settings are measured 
from and also affects their setting labels. See Elevation References on page 20.

 o Specify the height to Top, measured from the selected Elevation Reference to the top of the window frame. 

 o Specify the height to Bottom, measured from the selected Elevation Reference to the bottom of the window frame.

 l Specify the Depth of the selected Wall Niche, measured from the wall surface to the back of the niche. Only 
available for Wall Niches.

Note: When either the Floor to Top or Floor to Bottom setting is 
modified, the other will adjust in response to prevent the window’s 
Height from changing.

 
Component Options

These settings affect windows with movable sections and are not available for Pass-Throughs, Fixed glass windows, mulled 
units, or window symbols.  

 l Specify the Bottom Component Size for Single Hung, Double Hung, Double Awning, Double Hopper, and Triple 
Hopper windows; specify the Top/Bottom Component Size for Triple Awning windows; or, 

 l Specify the Side Component Size for Triple Casement and Triple Sliding windows, the Right Component Size for 
Left Sliding windows, or the Left Component Size for Right Sliding and Double Casement windows. A 
Component Size value of 0 creates  a window with identically sized components. 
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 l Specify how each Component Opens from the available options. Only available for Casement, Double and Triple 
Awning, and Double and Triple Hopper windows.           

 
Interior Windows

These settings are only present when the selected window is a Pass-Through placed in an interior wall. See Exterior and 
Interior Walls on page 236. 

 l Check Separate Trim and Materials for Each Side to specify the casing, lintels, sills, and all materials for each 
side of the selected Pass-Through independently. When unchecked, the two sides use the same trim and materials. 

  Options

 l Louver Size - Specify the vertical height of the selected window’s louvers. Only available for Louvered and Glass 
Louver windows.           

 
Preview

A preview of the selected window displays here. A label indicates which side of the window is its Interior and which is its 
Exterior. See Dialog Preview Panes on page 21. 

Window opening directions can best be seen using the Vector View Rendering Technique.          

OPTIONS PANEL

The OPTIONS panel is not available in the Wall Niche Specification dialog.

The Mulled Units and Mullion Depth settings on the OPTIONS panel are only available in the Mulled Unit Specification 
dialog. See Grouped Windows on page 413.

 
Options

These settings affect how the selected window is listed in the Materials List. See Displaying Windows on page 416.                 

 l Check Interior Corner Block to count interior corner blocks in the Materials List. These do not display in 3D 
views.
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 l Check Exterior Corner Block to count exterior corner blocks in the Materials List. These do not display in 3D 
views.

 l Check Egress to specify the window as an egress window in the Materials List. Not available for Pass-Throughs.

Consult your local building and fire code authorities for your 
local egress window requirements.

 l Check Reverse Symbol to reverse a window symbol as though it were reflected about a vertical line through its 
center. Only available in the Window Symbol Specification dialog. 

 
Mulled Units

Only available when a Mulled Unit is selected.See Mulled Units in the Library on page 414.

 l Check Treat as Door to include the unit in the “Doors” category of the Materials List. Only available when the 
selected unit contains a door.

 l Uncheck Single Wall Hole to produce individually framed wall openings for each unit in a mulled unit. When this 
box is checked, a single wall opening with one header for the entire unit is produced.           

 
Mullion Depth

Only available when a Mulled Unit is selected. Specify the depth of the casing between the Mulled Unit's components, 
measured from the wall surface. Positive values move the mullion surface towards the wall center; negative values, away 
from it.   

 l Specify the Inside depth of the mullion on the interior surface of the wall.

 l Specify the Outside depth of the mullion on the exterior surface of the wall.           

 
Recessed into Wall

These settings allow you to recess the selected window or mulled unit into a wall, away from the exterior surface. Only 
available if the window or mulled unit is in a multi-layered wall.         

 l Check Recessed to enable the options below.

 l Select To Main Layer to recess the window to the wall’s Main Layer.

 l Select To Sheathing Layer to recess the window to the wall’s sheathing layer, which is the layer located just 
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outside the wall type’s Main Layer(s). See Wall Type Definitions on page 262.           

  Vertical Stacking

 l Specify the window Level that the selected window is placed on. Not available for mulled units or window symbols. 
See Window Levels on page 415.

 
Preview

A preview of the selected window displays here. See Dialog Preview Panes on page 21.         

CASING PANEL

The settings on the CASING panel of the Window and Mulled Unit Specification dialogs are also found on the panel of the 
same name in the Door Specification dialog. See Casing Panel on page 397.

The CASING panel is not available in the Window Symbol Specification dialog.

LINTEL PANEL

The settings on the LINTEL panel of the Window and Mulled Unit Specification dialogs are also found on the panel of the 
same name in the Door Specification dialog. See Lintel Panel on page 398.          

The LINTEL panel is not available in the Window Symbol Specification dialog.          

SILL/THRESHOLD PANEL

The settings on the SILL/THRESHOLD panel of the Window and Mulled Unit Specification dialogs are not available if the 
window has a vertically reflected arch. See Arch Panel on page 431.          

The SILL/THRESHOLD panel is not available in the Window Symbol Specification dialog.          

424



Home Designer Pro 2025 Reference Manual - Window Specification Dialog

 
Use Threshold

Check Use Threshold then specify its Interior and Exterior Depth, below. When this box is unchecked, no threshold is 
added. Typically, exterior doors and full-height side lites receive a threshold while other openings do not. Thresholds extend 
under an opening's exterior casing, if present.          

 
Use Interior Sill

Check Use Interior Sill to enable the settings that follow, then specify the sill applied to the interior side of the selected 
window(s) using these settings. When this box is unchecked, no interior sill is used.         

 l Sill Profile - Click the Library button to select a molding profile for the sill. A preview of the selected profile 
displays to the right. See Select Library Object Dialog on page 716.          

 l Click the Clear button to remove the selected sill profile from the window. When no library profile is selected, a 
basic rectangular profile is used.          

 l Specify how far to Extend the sill past the outside edges of the casing on each side. If an Apron is specified, it will 
also be affected by this setting.          

 l Specify how far to Inset the sill into the window. A value of 0 positions the sill profile against the surface of the 
wall. Only available when a sill profile from the library is selected.          

 l Check Wrap to wrap the sill profile back toward the wall.           

 l Check Apron to include an apron under the sill. When Wrap is checked, the apron will be 1/2” (12 mm) shorter than 
the sill on each side; when it is unchecked, it will be the same length as the sill.           

 
Use Exterior Sill

Check Use Exterior Sill to enable the settings that follow, then specify the exterior sill for the selected window(s) using 
these settings. These settings are the same as those for the Interior Sill, above.         

 
Preview

A preview of the selected window displays here. See Dialog Preview Panes on page 21.         

SASH PANEL

The settings on the SASH panel control the size and position of the selected window’s sash. Note that increasing the Side, 
Middle, Top or Bottom Width decreases the area of the glass and vice versa. 

The SASH panel is not available in the Wall Niche, Mulled Unit, and Window Symbol Specification dialogs, and the settings 
on this panel are not available for Pass-Throughs.
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Sash

Specify the width and depth of the selected window’s sash, which are the pieces of the window that hold the glass; or, 
uncheck this box to prevent it from having a sash.

 l Specify the Side Width of all vertical sash members: those at the window sides as well as the central members of 
Casement and Sliding windows. This is also the width of the top portion of the window when an arch is specified.    

 l Specify the Middle width of horizontal components between the top and bottom sash in Double Hung, Double and 
Triple Awning, and Double and Triple Hopper windows. It does not affect Casement and Sliding windows.    

 l Specify the Top and Bottom Widths. The Top value is not used if the window has an arch.    

 l Specify the Depth, or thickness, of the sash stock measured from the exterior to the interior.    

 l Specify the Inset, the distance between the frame and the outermost sash. If there is no frame, the inset is measured 
from the outer surface of the wall’s Main Layer.          

 l Curved Options - When the selected window is placed in a curved wall, specify whether it has a curved or straight 
sash. A curved sash is typically used with Radial casing. See Casing Panel on page 397.          

 
Preview

A preview of the selected window displays here. See Dialog Preview Panes on page 21. 
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FRAME PANEL

The FRAME panel is not available for mulled units or window symbols from the library. The settings on the FRAME panel are 
similar to those on the JAMB panel of the Door Specification dialog. See Jamb Panel on page 400.          

 
Has Frame

Check Has Frame to include a frame and enable the settings below. When this is unchecked, the selected window has no 
frame around it.     

 l Specify the Positioning of the window frame. These settings affect what the window's Size settings on the GENERAL 
panel are describing; however, switching these settings does not affect the Size values:

 o Select Window Size Includes Frame to specify size as a total of the window glass plus sash plus jamb width.

 o Select Window Size Excludes Frame to specify the size of the window glass plus sash only. 

 l Specify the Side, Top, and Bottom Widths of the window’s frame. Changing these values only affects a window's 
total size when Window Size Includes Frame is selected, above.          

 l Uncheck Fit Frame to Wall to specify the Depth and Inset of the selected window’s frame. When this box is 
checked, the frame Depth automatically extends from the Recessed Into Wall layer to the wall’s inside surface with 
an Inset of 0”. The Recessed Into Wall layer is specified on the Options Panel on page 422 of this dialog.          

 o Specify the Depth of the window frame from front to back.          

 o Specify the frame’s Inset, which is measured from the Recessed Into Wall layer and moves the window frame 
towards its interior side. If used, the casing and lintel are not affected by this setting.          

 
Options

Specify how corner windows join. Only available when the selected window is one of two Fixed glass windows that meet at 
a wall corner, or when both windows are selected. See Corner Windows on page 412.         

 l Select Post to produce a vertical support between the two windows that separates their sash and glass.

 l Select Mitered for sash and glass that meet and miter at the corner where the two windows meet.

 
Preview

A preview of the selected window displays here. See Dialog Preview Panes on page 21.
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LITES PANEL

The LITES panel allows you to add muntins to windows, and is also available for Glass doors. See Doors on page 378. 

There are four possible styles of muntin bars for regular windows, plus two additional options for arched windows.

A window that has been modified using the SHAPE panel cannot have divided lites or shutters added.

The LITES panel is not available in the Wall Niche, Mulled Unit, and Window Symbol Specification dialogs, and the 
settings on this panel are not available for Pass-Throughs.

 
Lites

Specify the number, position and style of lites for the selected window.    

 l Select a Type, or style, of window lite from the drop-down list. 

 l Normal style is the most common, with muntins going horizontally and vertically. Colonial windows are an example 
of the normal style.     

 l Diamond style uses angled muntin bars to divide up the lites. French windows are an example of the diamond style.     

 l Prairie style is based on the normal style, but with all the central muntin bars removed, leaving only the two outside 
muntin bars both horizontally and vertically. Typically, both Lites Across and Lites Vertical should be set between 6 
and 8. Federal or Federation windows are an example of the Prairie style.     

 l Craftsman style is based on the normal style, but only the topmost horizontal muntin bar is kept with all the 
portions of the vertical muntin bars above it. Typically, both Lites Across and Lites Vertical should be set between 4 
and 8.     

 l Enter the number of horizontal Lites Across in each sash.      

 l Enter the number of vertical Lites Vertical in each sash.     
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 l Specify the Muntin Width, which is the width of the bars dividing the panes of glass.     

 l Check or uncheck Lites in Top and/or Lites in Bottom - or Lites in Left and/or Lights in Right - to specify either 
one or both of the sashes to have divided lites.     

 l Check Muntin in Corner to add a vertical muntin bar where two corner windows meet. Only available when 
Mitered is selected as the Corner Join option on the FRAME panel. See Corner Windows on page 412.           

 l Check Auto Adjust Lites for Component Size to have the program produce lites that are consistent in size across 
all components. When this is checked, the window’s lites and its specification settings may not agree; when 
unchecked, lites in the components may not be consistent in size. 

 l Note: Because the fixed window in a Triple Sliding window is twice the size of the movable windows, the fixed 
section has a vertical muntin bar. To eliminate this, uncheck Auto Adjust Lites for Component Size.

 
Round Top Arch

These options are only available if the window has an Arch specified.

 l Specify a Ray Count of up to 10 radial muntin bars in the portion of the window within the arch. There is one more 
pane of glass than the number of rays specified. See Arch Panel on page 431.          

 l Check Concentric to produce muntins radiating from a curved inner muntin that is concentric with the window’s 
arch. You must have at least three Lites Across for this to be used.          

 
Preview

A preview of the selected window displays here. See Dialog Preview Panes on page 21. 

SHAPE PANEL

The settings on the SHAPE panel control the position of the selected window’s corners, allowing you to create angled edges 
and mitered top corners.          

If any of these settings are used to create a custom shape, the selected window will be automatically specified as “Fixed 
Glass” on the GENERAL panel. If the selected window has an arch specified on the ARCH panel, it will be removed.         

The SHAPE panel is not available for mulled units or window symbols from the library.         

Note: The Left and Right settings on this panel refer to the window’s 
exterior.
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Window Width

The Window Width displays for reference here. It can be changed on the General Panel on page 420.         

 l Click Match Roof to match the angle of the top of the window to the pitch of the roof above by changing its Sides 
heights, below. If either Top Inside Corner box is checked, it will become unchecked. 

Match Roof does not work for curved roofs, has no effect if the window is not in a gable end wall, and is not 
available in the Window Defaults dialog.         

 l Click Revert All to restore the window to its original shape, type and arch settings.          

 
Sides

Specify the height of the window’s Left and Right sides, as measured from the bottom of the window. By default, these 
settings match the window’s Height.             

 
Top Inside Corners

These settings allow you to create a second set of top corners with angled edges between them and the outside top corners.                 

 l Check Left to add an additional corner along the top edge.          

 l Specify the Height of the left inner corner, as seen from the exterior, measured from the bottom of the window.         

 l Specify the Offset of the left inner corner, as measured from the left side of the window.          

 l An additional Right Inside Corner can be specified in a similar manner.          

 
Bottom Corners

These settings allow you to raise the heights of the bottom corners, as measured from the bottom of the window specified on 
the General Panel on page 420.                 

 l Check Left to raise the height of the bottom left corner.          

 l Specify the Height of the bottom left corner. This value cannot exceed the Height of the Left Side.           
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 l The height of the Bottom Right corner can be raised in a similar manner.          

 l The height of the Bottom Right corner can be raised in a similar manner.

 
Preview

A preview of the selected window displays here. You may want to rotate the view so the window’s exterior can be seen. See 
Dialog Preview Panes on page 21.              

Note: The Left and Right settings on this panel refer to the window’s 
exterior.

The following diagram represents added Inner corners using open circles and the left and right corners using solid black 
circles:          

 l A has different left and right Side Heights with no Top Inside Corner added.           
 l B has matching left and right heights with an added Top Inside Corner.           
 l C is the same as B, except that the left and right Side Heights have been shortened to 1/4”.           
 l D is the same as B except it has two added Top Inside Corners.          
 l E is the same as A except that the Bottom Right Corner has been raised.          

ARCH PANEL

The settings on the ARCH panel of the Window and Mulled Unit Specification dialogs are also found on the panel of the 
same name in the Door Specification dialog. See Arch Panel on page 401.         

The settings on this panel of the Mulled Unit Specification dialog define the overall shape of the blocked unit’s top. If the 
mulled unit already includes a component window with an arch, these settings cannot be modified.              

The ARCH panel is not available for window symbols from the library, and its settings are not available if the selected 
window has been modified using the SHAPE panel.         
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TREATMENTS PANEL

The settings on the TREATMENTS panel allow you to add embellishments to the interior and exterior of the selected window 
or mulled unit.         

The TREATMENTS panel is not available in the Wall Niche and Window Symbol Specification dialogs.           

 
Curtains

Curtains are applied to the selected window or mulled unit’s interior side.             

 l Specify a style of Curtains by selecting “Use Default”, “None” or “Library” from the drop-down list.  If a non-
default library item has been selected, its name will display in the list, as well.          

 l Click the Library button or select “Library” from the drop-down list to choose a style of curtain from the library. 
See Select Library Object Dialog on page 716.          

 l Specify the Height Off Floor of the bottom edge of the curtains.          

 l Specify the Height Above Casing of the top of curtains.          

 
Blinds

Blinds are specified in the same manner that Curtains are chosen, above.             

 
Preview

A preview of the selected window displays on the right. You may want to rotate the view so the window’s interior can be 
seen. See Dialog Preview Panes on page 21.             

SHUTTERS PANEL

The settings on the SHUTTERS panel allow you to specify exterior shutters for the selected window or mulled unit from the 
library.          

The SHUTTERS panel is not available in the Wall Niche and Window Symbol Specification dialogs.         
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Shutters

Select a Type of shutters from the drop-down list or click the Library button to select a style of shutters from the Library 
Browser. See Select Library Object Dialog on page 716.          

  Size

 l When Match Opening Width is checked, each shutter’s width is exactly half that of the window, excluding casing.         

 l Uncheck Match Opening Width to specify a Width in the text field. If the window is later resized, the shutters will 
not adjust in response.         

 l When Match Opening Height is checked, each shutter’s height equals that of the window, excluding casing.         

 l Uncheck Match Opening Height to specify a Height in the text field. If the window is later resized, the shutters 
will not adjust in response.         

 
Position

Specify the position of the shutters relative to the window.          

 l Select On Casing to position the shutters just outside the window frame, like functional shutters.          

 l Select Outside Casing to position shutters outside the window casing, as decorative shutters often are.         

 l Select Custom to create a custom position for the shutters by specifying the Offset from Side and Offset from 
Bottom in the fields below.          

 
Options

Additional shutter Options can be specified here.         
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 l Specify the Louver Size. Only available when "Louvered" is selected as the Type, above.

 l Check Reverse Direction to orient the shutters so their exterior sides face outward and their interior sides face the 
wall. For functional shutters, this should remain unchecked.          

 l When Match Arch is checked, shutters are shaped to match the selected window's arch shape. Uncheck this box for 
shutters with flat tops that reach the bottom of the curved portion of an arched window. Only available the selected 
window has an Arch specified. See Arch Panel on page 431. 

 l Check Show Closed  to draw the shutters so they cover the exterior of the selected window. When this is unchecked, 
the shutters are positioned against the wall on either side of the window.     

 
Sides

Specify which sides of the selected window receive shutters.         

 l Select Automatic to assign shutters to both sides of the window as long as there is sufficient room on the wall. If the 
window is next to a wall intersection or corner, the shutter closest to the intersection will not generate.           

 l Select Left Side Only to assign a shutter to the left side of the window and none on the right.           

 l Select Both Sides to assign shutters to both sides of the window under all circumstances, even if there isn’t enough 
room on the wall for one or both of them.          

 l Select Right Side Only to assign a shutter to the right side of the window and none on the left.          

 
Preview

A preview of the selected window displays on the right. Shutters will only generate if there is sufficient room for them 
along the window's containing wall. In order to see the shutters, you may need to rotate the preview to show the Exterior. 
See Dialog Preview Panes on page 21.          

OPENING INDICATORS PANEL

The settings on the OPENING INDICATORS panel are also found on the panel of the same name in the Door Specification 
dialog. See Opening Indicators Panel on page 403.    

ROUGH OPENING PANEL

The settings on the ROUGH OPENING panel are also found on the panel of the same name in the Door Specification dialog. 
See Rough Opening Panel on page 405.    

FRAMING PANEL

The settings on the FRAMING panel are also found on the panel of the same name in the Door Specification dialog. See 
Framing Panel on page 406.          

MATERIALS PANEL

The settings on the MATERIALS panel are the same as those found on the same panel in dialogs throughout the program. See 
Materials Panel on page 750.

The settings on the MATERIALS panel of the Mulled Unit Specification dialog apply to all components of the blocked unit. 
Any settings made for individual components of the blocked unit are overridden here.          
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LABEL PANEL

Window labels display in plan view when the “Windows, Labels” layer is turned on and use the Text Style assigned to that 
layer. See Window Labels on page 417.          

Similarly, Wall Niche labels display in plan view                           when the “Wall Niches, Labels” layer is turned on and use the Text Style 
assigned to that layer. See Window Labels on page 417.          

For more information about the settings on this panel. See Label Panel on page 376.         

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 967.          

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in the materials list. For more information, see 
Object Information Panel on page 968.   

MANUFACTURER PANEL

The MANUFACTURER panel provides contact information for the selected window’s manufacturer. Only available for 
windows from Manufacturer library catalogs. See Manufacturer Catalogs on page 705.         

 

 

Bay, Box, and Bow Windows
Bay, Box and Bow Windows are created much the way regular windows are: select a tool, then click a 
wall to place that window type. 

Home Designer automatically builds a foundation under bay/box/bow windows placed on Floor 1 unless they are raised 
from their original position. That section of the foundation wall is also a bay/box/bow, but without windows. If the 
foundation was generated before the window is placed, the foundation must be rebuilt or edited manually.

DISPLAYING BAY, BOX, AND BOW WINDOWS

The display of bay, box, and bow windows is controlled in the Layer  Display Options dialog. See Layer Display Options 
Dialog on page 127. 

Like other windows, bay, box, and bow windows can display labels. Either a single label for the unit can be used, or a 
separate label for each component. See Window Labels on page 417. 

Bay, box, and bow window width and radius dimensions, which display in plan view when specified to do so in the 
window’s specification dialog, are placed on the “Dimensions” layer. See Options Panel on page 442.   

EDITING BAY, BOX, AND BOW WINDOWS

Bay, box, and bow windows are edited similar to regular windows with one exception: in plan view, a diamond-shaped 
Depth edit handle displays on the section. Drag this Depth handle outward to increase the depth, or inward to decrease the 
depth of the unit. See Editing Windows on page 418.
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Bay, box, and bow windows can also be edited in their respective specification dialogs. See Bay/Box and Bow Window 
Specification Dialogs on page 440.

COMPONENT WINDOWS

A component window within a bay, box, or bow window can be edited like others standard window, with a few restrictions. 
To select a component window, click at the location of the component in question, then click the Select Next Object  

edit button or press the Tab key. 

 l Only the bay or box window component that was clicked on is selected using this method. If you need to select a 
different component, click on it and repeat the process.

 l In a bow window, all components are identical, so only one component can be selected. Changing this component 
changes them all.

An individual component window can be resized using the edit handles or by changing settings in the component’s Window 
Specification dialog. Component windows can also be resized using the Transform/Replicate Object dialog. See 
Transform/Replicate Object Dialog on page 183.

When a bay/box/bow window is first created, there is room for one standard trimmer on each side of each component 
window. When the bay as a whole is moved and resized, its components automatically resize so that a standard trimmer is 
still accommodated. 

If you increase a component window’s width to the point where there is not enough room for standard trimmers, a thinner 
trimmer can be used. The size of this thinner trimmer is specified in the Build Framing dialog. See Openings Panel on page 
641.           

If a component window is resized, it retains its size if at all possible when the containing bay/box/bow window is moved or 
resized. If the bay is resized in such a way that the component is too large to fit even with a thinner trimmer, the component 
resumes its default behavior, resizing as the containing bay window is resized.

FLOORS AND CEILINGS

When originally created, the floor and ceiling within a bay, box, or bow window are the same heights as the floor and 
ceiling of the room in which it is placed. 

Both the top and bottom heights of these window units can be adjusted in its specification dialog or a 3D view using its edit 
handles to create a lowered ceiling and/or a bench seat or garden window.
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When the ceiling is lowered, the top heights of the walls that define the window unit are also lowered. When a roof is built 
over the unit, its height will be affected, as well.

When the bottom of the window is raised to create a bench seat, the unit’s walls will not reach the ground. As a result, 
window units with bench seats will have no foundation beneath them when the foundation is built.

 

Bay, Box, Bow Windows and Roofs
Several different roof styles can be specified for Bay, Box and Bow window units in the Bay/Box and Bow Specification 
dialogs. See General Panel on page 440. 

If you change a Bay, Box, or Bow Window’s roof specification, you will need to rebuild the roofs to see the changes. See 
Rebuilding Roofs on page 578. 

HIP ROOFS

By default, a hip roof is built above the unit when roofs are automatically generated. Bay and Bow Windows with angled 
side walls also receive two additional roof planes that produce a ridge at the back of the bump-out's roof, sometimes referred 
to as a California ridge. No roof directives need to be selected in the Bay/Box/Bow Specification dialog to produce this roof.

Hip roofs over Bay, Box, and Bow Windows

USE THE EXISTING ROOF

To generate a standard roof that ignores a Bay, Box, or Bow Window, check Use Existing Roof. 
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Existing roof extending over and following 
the shape of Bay, Box, and Bow Windows

With this option the Bay, Box, or Bow Windows is tucked under the roof eave. You may find it necessary to increase the 
width of the eave. See Roof Panel on page 580.

EXTEND THE EXISTING ROOF

To have the main roof extend down over the window unit and follow the shape of the unit, select Extend Existing Roof 
Over. 

Existing roof extending over and following 
the shape of Bay, Box, and Bow Windows

To extend the main roof down over a window unit to create a rectangular roof over it rather than one that follows its shape, 
select both Extend Existing Roof over and Rectangular Roof Over. 

Existing roof extending rectangular bump-
outs over Bay, Box, and Bow Windows

For this roof style, the ceiling heights of the window unit and the adjacent room must be the same. If you lower the ceiling 
of the window unit and then build the roof, a lower hip roof over the window is created. See Floors and Ceilings on page 
436.

If a header is desired over the window unit, first build the roof, then lower the ceiling of the window unit. Once the ceiling 
is lowered, select Rebuild Walls/Floors/Ceilings . Do not rebuild roof planes.
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RECTANGULAR HIP ROOFS

To create a rectangular-shaped hip roof above a Bay, Box, or Bow window, select Rectangular Roof Over.

Rectangular-shaped hip roofs over Bay, Box, 
and Bow Windows

GABLE ROOF

A gable roof is not one of the automatic options for the roof above a Bay, Box, or Bow Window. A gable can be created by 
manually editing the rectangular hip roofs that are automatically created. See Roof Planes on page 585.

To create a gable over a bay window

 1.  Select a Bay, Box, or Bow window, open its specification dialog, and choose the Rectangular Roof Over option.

 2.  Rebuild the roof.

 3.  Select one of the side roof planes and drag the corner edit handle located at front end of the ridge forward until the 
fascia snaps to the edge of the front hip section. 

 4.  Edit the other side roof plane in the same manner.         

 5.  Delete the front hip section.           

 6.  Adjust the roof’s overhang as needed.           

To create a gable roof over a normal window, use the Gable 
Over Door/Window edit button. See Gable/Roof Lines on page 

609.
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Bay/Box and Bow Window Specification Dialogs
To open the Bay/Box Window Specification or the Bow Window Specification dialog, select one or more Bay, Box, 
or Bow Windows and click the Open Object edit button. See Bay, Box, and Bow Windows on page 435.

The options in this dialog can only be set for objects placed in a plan: Bay, Box, and Bow Windows do not have defaults 
dialogs. 

The settings that are available in these dialogs depend on whether the selected object is a Bay, Box, or Bow Window.         

The Bay/Box and Bow Window Specification dialogs have the following panels:         

GENERAL PANEL

 
Sections

The setting that displays here depends on whether the selected window is a Bay, Box, or Bow Window.   

 l Specify the Bay Angle, which is the angle of the side components of a Bay or Box Window. Bay Windows have an 
angle of 45° by default; Box Windows have an angle of 90°.

 l Specify the Quantity, which is the number of component windows in a Bow Window.    

 
Size

Specify the Width and Depth of the Bay, Box, or Bow Window. 

 
Wall Type

Specify the Wall Type used by the walls embedded in the selected Bay, Box, or Bow Window. See Wall Type Definitions 
on page 262. 
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 l Select “Use Main Wall Type” from the drop-down list to use the same wall type as that of the wall that the window 
unit is placed in. If the main wall is a Pony Wall, both wall types are used.           

 l Select a specific wall type from the drop-down list to use it instead of the Main Wall Type.           

 l When a specific wall type is selected, click the Define button to modify its definition. See Wall Type Definitions 
Dialog on page 264.           

 
Ceiling

Specify the height and structure of the Ceiling within the selected window. 

 l Check Has Lowered Ceiling to enable the settings that follow. When this is unchecked, the ceiling height and finish 
material within the window is the same as that for the adjacent room.

 l Specify the Height Lowered, which is measured from the ceiling height of the adjacent room. 

Note: If the Height Lowered is 0”, Has Lowered Ceiling will become 
unchecked when you click OK.

 l Specify the Finish Thickness, which is the thickness of the ceiling’s finish material.           

 l Specify the Structure Thickness, which is the thickness of the ceiling’s structural layer.          

 
Floor

Specify the height and structure of the Floor within the selected window. 

 l Check Has Raised Floor to enable the settings that follow. When this is unchecked, the floor height and material 
within the window is the same as that for the adjacent room. 

 l Specify the Height Raised, which is the measured from the floor height of the adjacent room. 

Note: If the Height Raised is 0”, Has Raised Floor will become 
unchecked when you click OK.

 l Specify the Finish Thickness, which is the thickness of the floor’s finish material.          

 l Specify the Structure Thickness, which is the thickness of the floor’s structural layer.          
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OPTIONS PANEL

 
Roof

Specify the structure of the automatic roof over the selected window unit. See Bay, Box, Bow Windows and Roofs on page 
437. 

 l Check Use Existing Roof if the existing roof needs no changes to accommodate the bay window.

 l Check Extend Existing Roof Over to extend the existing roof plane to cover the bay window below.

 l Check Rectangular Roof Over to create a roof over the bay window that is square across the end instead of 
following the profile of the roof. 

 
Dimensions

Specify the appearance of the selected window unit’s dimensions in plan view. These dimensions are drawn on the 
"Dimensions" layer but cannot be selected. See Dimensions on page 320.

 l Check Display Standard Dimension to display the automatically-produced dimensions that show the window’s 
width and depth.

 l Check Display Dimensions to Center to display a Bow Window’s radial dimension.

 
Components

Specify the structure of the selected window unit’s components and the wall sections containing them.

 l Uncheck Has Component Windows to remove the component windows of the selected Bay, Box, or Bow 
Window and disable the settings that follow.          

 l Check No Trimmers for Components to eliminate the trimmer studs for Bay and Box Window components, 
allowing the width of each component window to increase. See Wall Framing on page 627.          

 l Check No Framing Between Components to remove both studs between the component windows.          
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Note: If the selected unit is moved or resized, its components 
automatically resize to use a standard trimmer, regardless of whether 
either of the two options above are selected.

 l Check Connect Outer Casing to have exterior casing surround the component windows of a Bow Window as a 
group rather than individually. Mullions are provided between components. This is how interior casing is always 
created.           

 l Check Components Recessed to recess the component windows into the wall and enable the settings that follow. 
Typically used if the window is placed in a brick wall and you want to produce a brick molding.           

 l Select To Main Layer to recess the components to the wall’s Main Layer instead of the exterior wall surface. See 
The Main Layer on page 262.           

 l Select To Sheathing Layer to recess the components to the sheathing layer instead of the exterior wall surface.          

MATERIALS PANEL

The settings on the MATERIALS panel are the same as those found on the same panel in dialogs throughout the program. See 
Materials Panel on page 750.

LABEL PANEL

Bay, Box, and Bow Window labels display in plan view                           when the “Windows, Labels” layer is turned on and use the Text 
Style assigned to that layer. See Window Labels on page 417.          

For more information about the settings on this panel. See              Label Panel on page 376.         

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. See Components Panel on page 967.          

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in the materials list. For more information, see 
Object Information Panel on page 968.   
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Chapter 17
 

Cabinets

With Home Designer’s cabinet tools you can create base, wall, and full height cabinets as well as soffits, shelves, partitions, 
and custom countertops. These objects are very versatile, allowing for a wide range of customization. 

A selection of cabinet door and drawer styles are available in the Library Browser.

Home Designer also has many customized cabinets and cabinet groups available in the library.

TOPICS

Cabinet Defaults 445
The Cabinet Tools 447
Cabinet Fillers 449
Placing Cabinets 449
Countertops 451
Custom Backsplashes 452
Displaying Cabinets 453
Cabinet Labels 455
Cabinet Construction 457
Editing Cabinets 457
Editing Cabinet Styles 459
Special Cabinets 461
Cabinet Specification Dialog 464
Cabinet Shelf Specification Dialog 475
Hardware Size/Orientation Dialog 476
Shelf/Partition Specification Dialog 477
Custom Countertop Specification Dialog 479
Custom Backsplash Specification Dialog 482
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Cabinet Defaults
There are several defaults dialogs for cabinets. Access Default Settings by selecting Edit> Default Settings, then clicking 
the arrow beside “Cabinets”. Select a subheading and click the Edit button to open the defaults dialog associated with your 
selection.

The Cabinet Defaults dialogs can also be accessed by double-clicking the Cabinet Tools  parent button.          

Double-clicking a Cabinet Tools child button also opens its corresponding defaults dialog, if that object has a defaults 
dialog.          

Each type of cabinet object has default definitions for size, style, materials and much more. In fact, the default dialog for 
each cabinet type is similar to its corresponding specification dialog. For descriptions of these settings, see Cabinet 
Specification Dialog on page 464, Shelf/Partition Specification Dialog on page 477 and Soffit Specification Dialog on page 
740.

Custom Countertops do not have defaults dialogs. Instead, their initial settings are based on the those of other objects.         

 l Custom Countertops’ initial settings are based on Base Cabinet Default settings but are also influenced by the settings 
of cabinets beneath them. See Countertops on page 451.             

DYNAMIC CABINET DEFAULTS

When a dynamic default is changed, existing cabinet objects using the default value are affected. See Dynamic Defaults on 
page 58.           

The following cabinet default values are dynamic: Separation, Backsplash Height and Thickness, Countertop Overhang 
and Thickness, Toe Kick Height and Depth, Side and Vertical Overlap, Stiles, and  Hardware spacing.           

All Materials are also dynamic. In addition, the Cabinet Defaults can be set up to refer dynamically to information in the 
Material Defaults dialog. This makes it easy to have all cabinet objects in a plan use the same default materials. See 
Material Defaults Dialog on page 747.           

To use dynamic cabinet Material Defaults

 1.  Specify the desired materials for the cabinet categories in the Material Defaults dialog:              

 l “Cabinets” can be linked to the default cabinet box, cabinet interior, shelves, and toe kicks as well as to Shelves 
and Partitions.              

 l “Cabinet Door/Drawer” can be linked to the default frames and panels of cabinet doors and drawers.              
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 l “Countertop” can be linked to the default countertop.               

 l “Hardware” can be linked to the default door and drawer pulls and hinges.              

 2.  On the MATERIALS panel of the Base Cabinet Defaults dialog, select the first object component and click the Select 
Material button.              

 3.  The Select Material dialog opens:              

 l On the LIBRARY MATERIAL panel, check Use default material, or              

 l On the PLAN MATERIAL panel, select “Use Default” at the top of the list.              

 4.  Click OK, then repeat this step for each of the components in the list.              

 5.  Repeat steps 2-4 in each of the Cabinet Defaults dialogs.              

GENERAL CABINET DEFAULTS

The General Cabinet Defaults dialog can be accessed only from the Default Settings dialog.

  Automatic Behaviors

 l Specify the Minimum Cabinet Width. The smallest allowable value is 1/16 of an inch (10 mm).

 l Specify the Minimum Shelf Spacing inside Door and Opening face items.

 
Cabinet Resizing

Specify how Cabinet Resizing takes place when the edit handles are used.

 l Select Use Grid Snaps to resize cabinets using Snap Grid increments. See Grid Snaps on page 116.    

 l Select Use Resize Increment to resize cabinets using the increment specified here.    

 l Set the Resize Increment at which cabinets resize. The minimum allowable increment is 1/16 of an inch (10 mm).

  Plan Display Options

 l Check Show Partial Module Lines to represent module lines as grey lines that do not extend across the cabinets. 
When this is unchecked, lines between merged cabinet modules display as specified by the “Cabinets, Module 
Lines” layer. See Displaying Cabinets on page 453.          
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 l Check Show Closed Doors/Drawers and Panels to display closed cabinet doors, drawers, and panels in plan view. 
When unchecked, these items are not shown. See Displaying Cabinets on page 453. 

 

The Cabinet Tools
Select Build> Cabinet to access the Cabinet Tools.

Cabinets are easily created with a single click in plan view or any camera view. See Click-to-Create on page 117.

Typically, groups of cabinet objects are positioned closely together and arranged to form work spaces, and there are some 
special behaviors and techniques to be aware of. See Placing Cabinets on page 449.

Once created, cabinets, soffits, shelves, partitions and fillers can be selected and edited much like other box-based objects. 
See Editing Cabinets on page 457.

BASE CABINETS

Base cabinets can be placed directly under wall cabinets and generate a countertop and toe kick by default.

WALL CABINETS

Wall cabinets can be placed directly over base cabinets. 

FULL HEIGHT CABINETS

Full height cabinets generate a toe kick by default and cannot be placed on top of other cabinets.

SOFFITS

Soffits typically fill the space between cabinet tops and the ceiling, but can also be used to create any object that can 
be modeled as a 3D box. To place a soffit, select Build> Cabinet> Soffit and click in any view.

By default, soffits use the material assigned to interior walls in the Material Defaults dialog. Like cabinets, soffits can have 
molding profiles applied to them.

For more information about using soffits for a variety of purposes, see Other Objects on page 738.

SHELVES

Select Build> Cabinet>  Shelf and click in any view to create a shelf. 

Create corner shelves by placing one shelf on each wall, then moving or stretching them until they touch.

Once created, shelves can be selected and edited. See Shelf/Partition Specification Dialog on page 477.

You can also specify shelves inside base, wall, and full height cabinet boxes. See Cabinet Shelf Specification Dialog on 
page 475.          
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PARTITIONS

Select Build> Cabinet> Partition button and click in any view to create a vertical partition. 

Like shelves, partitions can be selected and edited after they are placed.

Partitions can be used with shelves to create complex storage systems.

CUSTOM COUNTERTOPS

Custom Countertops are drawn and edited just like other closed-polyline based objects. Select Build> Cabinet> 
Custom Countertop, then either click and drag a rectangle or single-click to place a 2’x2’ countertop. See 

Countertops on page 451.         

You can also generate a custom countertop over one or more base cabinets using the Generate Custom Countertop  

edit tool. See Using the Edit Tools on page 458.         

CUSTOM BACKSPLASHES

Select Build> Cabinet> Custom Backsplash while an elevation or camera view is active, then either click and drag 
a rectangle or single-click on a wall surface to place a Custom Backsplash Layered Material Polyline on that wall. 

See Custom Backsplashes on page 452.

A custom backsplash can also be created using the Convert Polyline  edit tool. See Convert Polyline on page 182.         

CABINET LIBRARY CATALOG

In the Library Browser, browse to Home Designer Core Catalogs> Architectural> Cabinets to access a selection of 
specialty cabinets. Select the library object you want, then click in any view to place it in the plan. Once placed, 

library cabinets can be edited. See Placing Library Objects on page 714.

CABINET DOORS, DRAWERS, AND PANELS CATALOG

A selection of cabinet door panels, drawer fronts, and specialty cabinet storage options can be found in the Library 
Browser in Home Designer Core Catalogs> Architectural> Cabinet Doors, Drawers, and Panels. 

 l Doors and drawers can be assigned to a cabinet in its specification dialog. See Door/Drawer Panel on page 471.
 l Select a door or drawer in the library, then click on a cabinet in your plan to place the door or drawer onto that 

cabinet. Side and back panels cannot be applied to cabinets using this approach. See Inserted Objects on page 715.
 l Cabinet doors and drawers can also be placed as stand-alone fixtures. Once placed, they can be edited like other stand-

alone library objects. See Editing Library Objects on page 713.

BUILT-IN SINKS AND APPLIANCES

A variety of fixtures and appliances such as sinks, cooktops, and dishwashers can be placed into cabinets. See Inserted 
Objects on page 715. 

Place fixtures and appliances into cabinets early, so that any 
resizing can be done while there is adequate free space.
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To insert a fixture into a cabinet, select the fixture in the Library Browser, then click on a cabinet. There must be enough 
space in the cabinet or adjoining cabinets to contain the selected fixture. Only one front mounted appliance can be inserted 
in this manner.           

If a sink or cooktop is inserted into a cabinet with a top Drawer or Double Drawer, its Item Type will automatically change 
to a False Drawer or False Double Drawer.

Once placed, an inserted fixture can be selected and edited:

 l To select a fixture in a cabinet top, click on it and then click the Select Next Object  edit button. See Select Next 

Object on page 143.
 l Front fixtures can only be modified or deleted in the Cabinet Specification dialog. See  Front Panel on page 468. 

Fixtures can be added to both the top and front of the same 
cabinet. It is up to you to determine which can be effectively and 

safely combined in the real world. 

ELECTRICAL SWITCHES AND OUTLETS

Electrical switches and outlets placed within the backsplash area of a base cabinet will display in front of the 
backsplash in 3D views when the “Electrical” layer is turned. See The Electrical Tools on page 486.

 

Cabinet Fillers
Home Designer automatically generates fillers when cabinets of the same height are either touching or placed with 3” (75 
mm) of one another. Automatic fillers receive the same toe kick, moldings, and backsplash as adjacent cabinets, and model 
a continuous countertop.

If two cabinets meeting at a corner are separated from each other by 3” (75 mm) or less, the program will automatically 
generate a filler in the angle between them. A filler is used to separate the front of one of these cabinets from the one it 
meets so that drawers and doors have room to operate.

 

Placing Cabinets
Cabinets are easily created with a single click in any view. See Click-to-Create on page 117. 

When used near a wall corner, the Cabinet Tools will produce corner cabinets and soffits. See Corner Cabinets on page 
462.

When created, cabinets are positioned relative to the floor of the room in which they are placed. Base and full height 
cabinets typically rest on the floor while wall cabinets are placed a set distance above the floor. See Cabinet Defaults on 
page 445.
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If the ceiling height of the room does not accommodate the height of a cabinet, its Floor to Bottom value will be retained 
and its Height will be reduced so that it fits under the ceiling. When this happens, some front items may be removed from 
the cabinet if there is not enough room for them. See  Front Panel on page 468.

Because cabinets are typically organized into groups with shared attributes, they have some special behaviors. 

CABINET SNAPPING AND ALIGNING

Cabinets have several special snapping and aligning behaviors which help you create precisely aligned cabinets quickly and 
easily.

 l When Base and/or Full Height cabinets are within 3” of one another’s sides, they will snap together. Wall cabinets 
snap in a similar manner, but only with other Wall cabinets.

 l When Base and/or Full Height cabinets are within 3” of one another’s sides and their front or back surfaces are within 
3” of aligning, they will become aligned. Wall cabinets snap in a similar manner with other Wall cabinets as well as 
Full Height cabinets.

 l When a Base and/or Full Height cabinet is placed against the back of another Base or Full Height cabinet, its back 
surface will automatically face the other cabinet’s back. Wall cabinets snap in a similar manner with other Wall as 
well as Full Height cabinets.

 l When a cabinet or cabinet filler is placed against a wall, its back and/or side will snap to the wall and, if the wall is 
moved, the cabinet will move with it.

When cabinets are snapped to a wall or to other cabinets, only exposed end cabinets have side counter overhangs.

Cabinet snapping and aligning occurs even when Object Snaps  are turned off; however, you can override this behavior 

by moving a cabinet into the desired position using dimensions. See Moving Objects Using Dimensions on page 341.

CABINET MERGING

When cabinets of the same height and type are placed side-by-side within 3” (30 mm) of one another they will automatically 
merge, making any shared components such as the toe kick, countertop, backsplash, and moldings continuous. Any gap 
between merged cabinets will be automatically filled.

The exposed ends of merged cabinets have side counter overhangs.

Cabinets placed at different angles will also merge if they face toward one another and meet at a front corner. Cabinets that 
meet at a back corner will also merge provided that they face away from one another at an angle no greater than 87°. In 
either case, a filler is created in the angle between the two. 

If the side of a cabinet is placed within 3” (30 mm) of a wall, the countertop will extend to the wall and a filler will be 
created. 

Cabinet merging occurs even when Object Snaps  are turned off.

BASE AND WALL CABINETS

Base and wall cabinets have different default heights, so they can be placed directly above or below one another without 
interference. You can use Object Snaps  to center a wall cabinet’s back center point above that of a base cabinet, or vice 

versa. See Click-to-Create on page 117.
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MINIMUM CABINET SIZE

If you try to place a cabinet into a space that is too narrow for its default size, the program will place a smaller cabinet with 
a width that is a multiple of the default Resize Increment. For example, if you try to place a 24” wide cabinet in a 20” wide 
space and your Resize Increment is 3”, the program places an 18” cabinet. See General Cabinet Defaults on page 446.

If you try to place a cabinet into a space narrower than the default Minimum Cabinet Width, a cabinet will not be placed. 
If, for example, you have a space that is 8” and your Minimum Cabinet Width is 9”, no cabinet is placed. 

 

Countertops
Countertops are automatically generated on top of base cabinets, but can also be drawn manually. 

AUTOMATIC COUNTERTOPS

Base cabinets automatically receive countertops as specified in the Base Cabinet Defaults dialog. These default countertops 
are components of the cabinets and can be edited in the Cabinet Specification dialog, but cannot be selected and modified 
separately.

The overhangs on automatic countertops are clipped on any side where the cabinet is positioned against or within 3" (75 
mm) of a wall, a Full Height Cabinet, a Partition, or free-standing appliance from the Library. Edge profiles on those sides 
are also suppressed, as are toe kicks.

CUSTOM COUNTERTOPS

When an automatic countertop does not meet your needs, you can instead use a Custom Countertop. In any view 
except a cross section/elevation, select Build> Cabinet> Custom Countertop, then either click and drag a rectangle 

or single-click to place a 2’x2’ countertop polyline. This countertop can be selected independent of any cabinets beneath it 
and is edited just like other closed-polyline based objects. See Editing Closed Polyline-Based Objects on page 157.

When a Custom Countertop covers any portion of a base cabinet, it overrides that cabinet's automatic countertop and bases 
its thickness and height on the base cabinet below.          

 l If there are multiple cabinets below, it uses the specifications for the cabinet with the greatest overall height.         
 l If there is no base cabinet below, its height and thickness are based on the base cabinet defaults. See Cabinet Defaults 

on page 445. 

If a sink or built-in appliance is added to the cabinet, a hole for the fixture is automatically cut in the Custom Countertop. 

By default, if a side of a Custom Countertop is positioned against a wall, the edge profile on that side will not generate.

You can also generate a Custom Countertop over one or more selected base cabinets by clicking the Generate 
Custom Countertop edit button. See Using the Edit Tools on page 458.

When created in this manner, the Custom Countertop inherits the cabinet's countertop material. If the cabinet has a To Top 
molding profile at counter height, the Custom Countertop will inherit it, as well. See Editing Cabinet Styles on page 459.   

EDITING CUSTOM COUNTERTOPS

Once created, a custom countertop can be selected in 2D and 3D views and edited like other closed-polyline based objects. 
See Editing Closed Polyline-Based Objects on page 157.         
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Custom countertops initially use the default countertop material set in the Base Cabinet Defaults dialog. You can specify a 
different material as well as the height and position in the Custom Countertop Specification dialog. See Custom Countertop 
Specification Dialog on page 479.         

You can also specify the edge profile of a custom countertop in the Custom Countertop Specification dialog. See Moldings 
Panel on page 479.         

WATERFALL COUNTERTOPS

To add a vertical waterfall to the edge of a Custom Countertop, select that edge and click the Add Waterfall to 
Selected Edge edit button. See Selected Edge on page 143.         

You can also specify a waterfall edge as well as edit its attributes in the Custom Countertop Specification dialog. See 
General Panel on page 480.         

To remove a waterfall from a countertop edge, select that edge and click the Remove Waterfall from Selected Edge 
edit tool.         

 

Custom Backsplashes
The Custom Backsplash tool allows you to create areas on a wall that use a different surface material than the parent 
wall. To create a Custom Backsplash, select Build> Cabinet> Custom Backsplash, then either click and drag to 

draw a rectangular shape on a wall, or click once to create a shape that covers the wall surface. 

If you click to create a Custom Backsplash, it will:

 l Seek to fill the area between any base cabinets or floor appliances against that wall surface and any wall cabinets 
and/or windows above them. 

 l If nothing is above any base cabinets, it will fill the area between the cabinets and the ceiling; if nothing is below any 
wall cabinets, it will fill the area between the cabinets and the floor. 

 l Replace the backsplash associated with any base or wall cabinets. 

Custom Backsplashes are closed polyline-based objects that are drawn on the vertical surface of a wall. They can only be 
drawn, and their shapes edited, in camera and elevation views. See Polylines on page 218 and Editing Closed Polyline-
Based Objects on page 157.

Custom Backsplashes are composed of a layer of backsplash material. The layer material and its thickness can be set in the 
Custom Backsplash Specification dialog. See  Custom Backsplash Specification Dialog on page 482.

By default, a Custom Backsplash will cut into the wall layers between it and its parent wall’s Main Layer and replace those 
layers with its own within its perimeter; it can, however, can be affixed to the wall’s surface instead if you prefer.
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Displaying Cabinets
The display of the various cabinet object types, labels, module lines, door opening indicators, and more is controlled 
in the Layer Display Options dialog. See Layer Attributes on page 125.

IN PLAN VIEW

Fill Styles and colors that display in plan view can be assigned to cabinet objects. See Fill Styles on page 131.           

Like other objects, cabinets are placed in Drawing Groups that affect whether they display in front of or behind other 
objects in plan view. By default, wall cabinets, soffits and shelves are drawn in front of base and full height cabinets, 
countertops and partitions. You can modify a selected  cabinet’s place in the drawing order by clicking the View Drawing 
Group Edit Tools  edit button. See Drawing Group Edit Tools on page 129. 

Objects assigned to cabinets, including hardware and moldings, are located on the same layer as their parent object. They 
display in 3D views, but are not shown in plan view. There are a few exceptions:

 l Both automatic and Custom Countertops are drawn on the “Cabinets, Countertops” layer in all views. In plan view, 
countertops use the line style, color, and weight assigned to this layer; in 3D views, the line attributes of the parent 
object’s layer is used instead.

 l Cabinet doors, drawers, and panels are drawn on the “Cabinets, Doors & Drawers” layer in all views. When closed, 
however, they only display in 3D views by default. See Cabinet Doors and Drawers on page 453, below.

 l Closed Doors, Drawers and Panels can be set to display in plan view in the General Cabinet Defaults dialog. See 
General Cabinet Defaults on page 446.

 l You can also display cabinet front indicator arrows in plan view by turning on the “Cabinets, Front Indicators” layer.

Both automatic and Custom Countertops can be assigned an edge profile, and can display the width of this profile when 
Display Molding Edges in Plan Views is selected in the Base Cabinet or Custom Countertop Specification dialog.

By default, cabinet module lines display in plan view when cabinet objects of the same type are placed side by side. If you 
prefer that these lines not display, turn off the “Cabinets, Module Lines” layer. You can also specify whether module lines 
are full or partial. See General Cabinet Defaults on page 446.

Cabinet labels display in plan view when the “Cabinets, Labels” layer is turned on and use the Text Style assigned to their 
layer. See Cabinet Labels on page 455.

IN 3D VIEWS

In 3D views, cabinet doors and drawers are drawn on the “Cabinets, Doors & Drawers” layer, and their display can be 
turned on and off.         

In 3D Vector Views, cabinet doors can display opening indicator arrows. See Opening Indicators on page 384.           

CABINET DOORS AND DRAWERS

There are several options for controlling the display of cabinet doors and drawers in plan and 3D views.           

Cabinet doors and drawers are drawn on the “Cabinets, Doors & Drawers” layer. In plan view, they use the line style, color, 
and weight assigned to that layer when they are set to display. In 3D Vector Views, they use the line style, color, and weight 
assigned to their parent cabinet’s layer.          

453



Home Designer Pro 2025 Reference Manual - Displaying Cabinets

 l Cabinet doors and drawers can be drawn open or closed in both plan and 3D views.           
 l To draw a selected cabinet’s doors open in all views, click the Open Cabinet Doors  edit button. Any shelves set 

as Rollout will display in 3D views as well.             
 l To draw its drawers open in all views, click the Open Cabinet Drawers  edit button.             

 l To close the doors and/or drawers, click the Close Cabinet Doors  or Close Cabinet Drawers  edit button.             

Cabinet doors and drawers also can be set to Show Open in the Cabinet Specification dialog. In addition, you can specify 
how far open each is drawn. See  Front Panel on page 468.          

By default, doors and drawers do not display in plan view when they are closed: even when the “Cabinets, Doors & 
Drawers” layer is set to display. You can, however, check Show Closed Doors/Drawers in Plan Views in the General 
Cabinet Defaults dialog. See General Cabinet Defaults on page 446.           

ROLLOUT SHELVES AND STORAGE

Shelves can be specified for Door and Opening cabinet front items and are visible in 3D views. Those inside Doors will 
only display in 3D views when Doors and Rollout Shelves are set to Show Open. See  Front Panel on page 468.           

Shelves can be specified as Rollout, each with its own rollout percentage, and will display in 3D views when Doors and 
Rollout Shelves are set to Show Open. If a Rollout shelf is in a Door item, the door must be set to 100% Percent Open in 
order for the shelf to draw open. See Cabinet Shelf Specification Dialog on page 475.           

Cabinet shelves and added storage items do not display in plan view.          

IN THE MATERIALS LIST

The materials associated with cabinet objects are listed under different Categories in the Materials List:          

 l Cabinets - Lists Cabinets, Shelves, Partitions, Custom Countertops, Custom Backsplashes, storage and organization 
inserts, as well as cabinet doors and drawers placed from the library as free-standing objects.             

 l Interior Trim - Lists Soffits and any moldings assigned to cabinet objects located in Interior rooms. Note that Soffits 
are not listed in the Materials List unless a non-default material is applied to them.             

 l Exterior Trim - Lists any Soffits and moldings assigned to cabinet objects located in Exterior rooms. See Room Types 
on page 289.             

 l Fixtures - Lists any sinks inserted into base cabinets. See Inserted Objects on page 715.             
 l Appliance - Lists any appliance fixtures inserted into cabinets. If a base cabinet has an under-counter appliance 

inserted into it, that cabinet will not be counted in the Materials List - only the countertop and backsplash materials 
associated with it will be listed. The cabinet will also display the appliance’s label information instead of its own. See 
Cabinet Labels on page 455.             

As with other objects, there are a number of ways to control how, or whether, cabinets are included in the Materials List. 
See Organizing Materials Lists on page 953.           

You can add and edit information about a cabinet’s accessories in the Cabinet Specification dialog. See Components Panel 
on page 967.           

Note that cabinet door and drawer height is described in two different ways:           

 l In the Cabinet Specification dialog, the Item Height for cabinet doors and drawers describes the height of the opening 
in the cabinet box rather than that of the door or drawer front. See  Front Panel on page 468.             

 l In the Materials List, the full height of cabinet door and drawer front is listed in the Size column.             
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Cabinet Labels
Labels for cabinets display in plan view when the “Cabinets, Labels” layer is turned on. See Label Panel on page 376.

Shelves and Partitions can also display labels when the “Cabinets, Labels” layer is turned on. Unlike cabinets, the 
Automatic Label for these objects is blank; however, you can specify a custom label in their specification dialogs.

Cabinet labels  use the Text Style specified for the “Cabinets, Labels” layer. See Text Styles on page 373.         

If a base cabinet’s only front item aside from Separations and Blank Areas is an Appliance, the appliance’s label will 
display instead of the cabinet’s, and will be placed on the “Cabinets, Labels” layer.           

The minimum on-screen display size of object labels can be specified in the Preferences dialog. See Appearance Panel on 
page 63.          

AUTOMATIC LABELS

The format for automatic cabinet labels has four parts: Key, Code, Size, and Door Swing.           

The Key provides basic information about the cabinet box and its use. B refers to base cabinets, W refers to wall cabinets 
and U refers to full height cabinets.           

Together with the key, the Code provides additional information about the shape of the cabinet box:          

Code  

 All Cabinets

LS + Key Lazy Susan

LSD + Key Lazy Susan Diagonal Door

DC + Key Diagonal Door 

LC + Key Left Corner

BC + Key Blind Corner

E + Key Right or Left End

A + Key Angled Front

PR + Key Peninsula Radius

R + Key Radius End

Key + XL Extend Left Face Frame

Key + XR Extend Right Face Frame

Key + XLR Extend Left and Right Face Frame

B Base

OB Oven Base

SB Sink Base

RB Range Base

#DB Drawer Bank (# is the number of drawers

FHB Full Height Base (1 full height door)

W Wall
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Code  

Code above + #D Drawer (# is the number of drawers

U Full Height (Utility)

OTC Tall Oven

RTC Tall Refrigerator

Blind corner cabinets are dependent on the cabinet’s position in the plan. A cabinet can only be a blind corner cabinet when 
its front is partially hidden by another cabinet. See Blind Cabinets on page 464. If a cabinet is moved, therefore, its Code 
information may change.           

The Size follows the Code in a cabinet label. Cabinet width is always included in the label; depth and height, on the other 
hand, may be included depending on the cabinet type and whether they are standard or non-standard.          

Base and full height cabinet labels present Size information in this order: width, depth, height. Wall cabinet labels present it 
in a slightly different order: width, height, depth.          

 Sizes

Base W(D)(H)

Width (W) Always included

Depth (D) 24” (60 cm)

Height (H) 34 1/2” (90 cm)

Corner Depth (D) Depth = Width

Wall WH(D)

Width (W) Always included

Depth (D) Always included

Height (H) 12” (30 cm)

Corner Depth (D) Depth = Width

Full Height WDH

Width (W) Always included

Depth (D) Always included

Height (H) Always included

Corner Depth (D) Always included

Door Swing is included at the end of the label as either L or R, but only if all the doors on a cabinet have the same swing.          

Here are a few examples of automatic cabinet labels and their meanings:           

 l 3DB24: Base cabinet with 3 drawers, 24” wide. Depth and height are standard.          
 l SB24R: Sink base, 24” wide, with a right door. Depth and height are standard.          
 l BCW2436R: Blind wall cabinet, 24” wide, 36” high, with a right door. Depth is standard.          
 l DCW2436L: Diagonal corner wall cabinet, 24” wide, 36” high, with a left door. Depth is standard (equal to width).          
 l OTC362490: Full height cabinet with oven, 36” wide, 24” deep, 90” high.          
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The Automatic Labels for Shelves and Partitions are blank, but 
you can specify custom labels for both. See Shelf/Partition 

Specification Dialog on page 477.

 

Cabinet Construction
Both framed and frameless, or European-style, cabinet construction can be specified in Home Designer Pro. You can also 
specify either the overlay or reveal of cabinet doors, drawers, and panels. 

If you know what cabinet construction style you want, you can save time by specifying that style in the Cabinet Defaults 
dialogs before you start placing cabinets. See Cabinet Defaults on page 445.

FRAMED AND FRAMELESS

A cabinet can be specified as Framed or Frameless on the BOX CONSTRUCTION panel of the Cabinet Specification dialog. 
See Box Construction Panel on page 467.

The sides of both Framed and Frameless cabinet boxes are 3/4" (18 mm) thick. This value is also the system default Item 
Height for Separation face items in Frameless cabinets. See Cabinet Defaults on page 445.

Framed cabinets have left and right stiles with widths that can be specified. The Separation value set on the BOX 
CONSTRUCTION panel of the Cabinet Specification dialog serves as the default Height value for separation face items as well 
as the default width for left and right stiles. These can be set individually on the FRONT/SIDES/BACK panel. See  Front Panel 
on page 468.

TRADITIONAL OVERLAY

To specify how far doors, drawers and panels overlap vertical stiles and horizontal separations, select Traditional Overlay 
on the BOX CONSTRUCTION panel of the Cabinet Specification dialog and then specify the Overlap of all doors, drawers, 
and panels on the selected cabinet. 

When Traditional Overlay is selected, the widths of stiles can be specified on the FRONT/SIDES/BACK panel, as can the 
heights of selected Separation items; however, the overlap of individual items cannot.

FULL OVERLAY AND REVEAL

To specify the reveal on horizontal separations and vertical stiles, select Full Overlay on the BOX CONSTRUCTION panel and 
then specify the desired Reveal. Both the sizes and the reveals on the Left and Right Stiles and on individual Separation 
items can be customized on the FRONT/SIDES/BACK panel.

INSET DOORS AND DRAWERS

Cabinet doors and drawers can be specified as Inset instead of overlaid on the BOX CONSTRUCTION panel of the Cabinet 
Specification dialog.

 

Editing Cabinets
Cabinets can be selected in 2D and 3D views both individually and in groups and edited using the edit handles, the Edit 
Toolbar and their specification dialog.
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You can marquee-select cabinets of multiple types when the Full 
Height Cabinet tool is active. See Marquee Select on page 145.

USING THE EDIT HANDLES

Cabinets can be edited like other box-based objects. See Editing Box-Based Objects on page 160. The edit handles that a 
cabinet displays when selected will vary depending on the view. 

When a cabinet is selected in plan view or on its top surface in a 3D view, ten edit handles display: the Move handle at the 
center, the Rotate handle, and a Resize handle on each edge and at each corner. In plan view, cabinet labels also have a 
small square Move edit handle when they are set to display. See Displaying Cabinets on page 453.

In 3D views, cabinets can be selected on any surface: front, side, back or top. When the side of a cabinet is selected, five 
edit handles are available: the Move handle and a Resize handle on each edge. 

Cabinets cannot be concentrically resized, even when the Concentric edit behavior is enabled. See Defaults, Preferences, 
and Edit Behaviors on page 138.          

IN THE SPECIFICATION DIALOG

A selected cabinet can be customized in a variety of ways in its specification dialog. See Cabinet Specification 
Dialog on page 464. 

When you group select cabinets of different types, some options are not available in the Cabinet Specification dialog. For 
example, you cannot modify the crown molding on a full height cabinet if it is selected with a base cabinet that does not 
have crown molding. Any specifications that they share in common, however, can be edited.         

Soffits, shelves, and partitions can also be group-selected and edited using a shared specification dialog. It is, however, 
necessary that only soffits, or only shelves, or only partitions be a part of the selection set in order to access a shared 
specification dialog.           

USING THE EDIT TOOLS

A cabinet or cabinets can be edited in a variety of ways using the buttons on the Edit Toolbar. See The Edit Toolbar on 
page 92.

  The Open Cabinet Doors/Drawers and Close Cabinet Doors/Drawers tools affect the cabinet's doors 
and drawers in 2D and 3D views. See Cabinet Doors and Drawers on page 453.

  Generate Custom Countertop replaces a base cabinet's countertop with a separate Custom Countertop object. 
See Custom Countertops on page 451.

  Select Next Object allows you to select a fixture inserted into a cabinet. See Select Next Object on page 143.
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ADD TO LIBRARY

Cabinets can be saved in the Library Browser. Select a base, wall or full height cabinet or cabinet filler and click the 
Add to Library edit button. See Add to Library on page 709. 

USING DIMENSIONS

Like various other objects, cabinets can be moved and resized using dimensions. See Moving Objects Using 
Dimensions on page 341.

In order to be edited using dimensions, cabinets must be located by them. In the Dimension Defaults dialog, you specify 
what components of a cabinet are located by dimensions as they are drawn:          

 l Cabinet sides, corners, and centers can be located in both plan and elevation views.          
 l Backsplashes, countertops, toe kicks, and moldings can be located in elevation views. The heights of cabinet 

components cannot, however, be edited using dimensions. 
 l Automatic and Custom Countertops can be located as well as edited in both plan and elevation views provided that 

Countertops are set to be located.
 l If Display Molding Edges in Plan View is checked in the Base Cabinet Specification dialog, a cabinet's counter edge 

profile will display and can be located by dimensions provided that Cabinet Moldings are set to be located.
 l Automatic Backsplashes can also be located and edited in both types of views provided that CAD Objects are set to be 

located.         

See Locate Manual Panel on page 325.           

If you wish, you can add or move a dimension’s extension lines to locate countertop edges in plan view after the dimension 
line is drawn. In elevation views, the heights of cabinet face items, openings, the toe kick, backsplash, and/or moldings can 
also be located in this manner. 

Depending on whether a cabinet box or Custom Countertop is selected, Temporary Dimensions will locate objects near the 
Selected Edge somewhat differently: See Temporary Dimensions on page 333.

 l If a cabinet box is selected, Temporary Dimensions will locate the nearest wall surface or another cabinet box, but not 
automatically generated or Custom Countertops.

 l If a Custom Countertop is selected, Temporary Dimensions will locate the nearest wall surface, Custom Countertop, or 
automatically generated countertop edge.

MOVING WALLS WITH CABINETS ATTACHED

When a cabinet is placed or moved against a wall, it will snap to the wall and become attached to it. When a wall is moved, 
all attached cabinets move with it. 

When wall layers are resized or the wall layer definition redefined, the cabinets may become unattached. To reattach, select 
the cabinets, drag them away from the wall, and then drag them back again.          

 

Editing Cabinet Styles
A variety of settings allow you to customize the appearance of your cabinets to create styles ranging from traditional to 
contemporary.

If the desired style is known before cabinets are placed, you can save time by specifying that style in the Cabinet Defaults 
dialogs before you start drawing. See Cabinet Defaults on page 445.
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A variety of cabinet style attributes, including doors and drawers, 
moldings, and millwork accessories can be replaced with 

different items selected in the library. See    Replace From Library on 
page 717.

CABINET FACE ITEMS

A variety of different face items can be added to the front of any cabinet, including doors, drawers, cutting boards, and 
horizontal separations. Face items can be moved, resized, as well as removed and can also be split vertically or horizontally 
to produce a variety of custom configurations. See  Front Panel on page 468.

When adding, removing, or resizing face items, it is helpful to keep a few rules in mind:

 l Door and drawer Item Height settings reflect the height of the opening rather than that of the front item. When 
Traditional Overlay is specified, an item’s front height will be equal to its Item Height plus its top and bottom 
Vertical Overlap.           

 l When the overall height of a cabinet or the height of a face item is changed, the height of the lowest face item that is 
not a Separation is adjusted to accommodate the change. 

 l If you increase the height of the lowest face item, the non-Separation item directly above is adjusted; if you decrease 
its height, a Blank Area and Separation are created below it. 

 l If the bottom-most face item on a cabinet is a Separation and you increase its height to be greater than the default 
value, it will extend down past the bottom of the cabinet, creating a recessed bottom.

 l By default, if the bottom-most face item on a cabinet is anything other than a Separation or Blank Area, the cabinet 
box will be treated as an appliance garage and will not have a bottom. 

Note: To ensure that Face Item heights always equal the total cabinet 
front height, the program automatically adjusts the bottom Face Item as 
changes are made elsewhere. This means you should start editing Face 
Items at the top and work down. 

DOORS, DRAWERS AND PANELS

 l Cabinet doors, drawers, and panels can be applied in either of two ways:  
 l In the Cabinet Specification dialog. See Door/Drawer Panel on page 471.
 l Directly from the Library Browser.

A secondary door or drawer style can also be specified - for example, to create glass doors above solid doors in wall 
cabinets. See  Front Panel on page 468.          

Select a style in the Library, then click on a cabinet to apply the selected style to that cabinet. Additional cabinets may also 
be affected, depending on the active Scoping Mode. See    Replace From Library on page 717.

When replacing cabinet door or drawer style, the Replace from Library behavior will vary depending on the view type:

 l In plan view, the main style will be updated and any secondary styles will be unaffected.
 l In camera views, the main style will be updated only if all of a cabinet's doors or drawers are affected by the change.

FRAMED AND FRAMELESS CABINETS

Both framed and European-style frameless cabinets can be specified in Home Designer Pro.     
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For both types of cabinet, you can define the door and drawer overlay or specify inset doors. On a traditional framed 
cabinet, you can also control the size of the rails and stiles. See  Front Panel on page 468.     

CABINET HARDWARE AND MOLDINGS

Cabinet handles, pulls, and hinges can be assigned in the Cabinet Specification dialog. See Door/Drawer Panel on page 
471.

The hardware on individual doors and drawers can also be customized. See  Front Panel on page 468.    

In 3D views, cabinet hardware can also be applied directly from the Library Browser. Select a cabinet hardware item in the 
Library, then click on a cabinet door or drawer to assign it to all face items of that type, including custom hardware on 
individual face items. See Inserted Objects on page 715.          

Base cabinet with pilasters and feet

Wall cabinet with crown molding and light 
rail

COUNTERTOPS AND BACKSPLASHES

The countertop thickness, overhang, edge profile, and material for a selected base cabinet can be specified in the Cabinet 
Specification dialog. See General Panel on page 465 and Moldings /  Rails Panels on page 688.

Backsplashes can be specified for base cabinets on the GENERAL panel of their specification dialogs, as well. If a Custom 
Countertop is created using the Generate Custom Countertop  edit tool, it will inherit the backsplash attributes of the 

base cabinet. Manually drawn Custom Countertops, however, do not have backsplashes. See Using the Edit Tools on page 
458.

In addition, Custom Countertops and Backsplashes can be created independent of base cabinets. See The Cabinet Tools on 
page 447.

CABINET SHELVES

You can customize the shelves inside base, wall, and full height cabinet boxes. See Cabinet Shelf Specification Dialog on 
page 475.            

 

Special Cabinets
There are a number of special cabinet shapes that can be specified. Certain requirements must be met before some special 
cabinet shapes can be specified. If the requirements are not met, a warning message will explain what is needed. See 
Cabinet Specification Dialog on page 464.

Note: Only Standard cabinets can be the default cabinet Type. See 
Cabinet Defaults on page 445. 
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STANDARD CABINETS

Select Build> Cabinet> Base Cabinet  and click in plan view to place a standard, rectangular base cabinet.

CORNER CABINETS

To create a corner cabinet, click as close to an inside wall corner as possible using either the Base Cabinet , Wall 

Cabinet , or Full Height  cabinet tool. A corner cabinet remains a corner cabinet when it is moved, edited or copied.

You can turn an existing cabinet into a corner cabinet by selecting “Corner” from the Special drop-down list in its 
specification dialog. See General Panel on page 465.

 l Before a corner cabinet can be specified in the Cabinet Specification dialog, the cabinet’s Width must be greater than 
its Depth.

 l The Left and the Right Side Widths can be set independently for corner cabinets. 

 l You can specify a Diagonal Door on corner cabinets to create an angled corner cabinet. See  Front Panel on page 468.

END CABINETS

To turn a cabinet into an end cabinet, specify its Type as “Left End” or “Right End”.
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 l End Cabinets have an angled front and side.
 l The cabinet width must be no greater than its depth for an end cabinet to be specified.

RADIUS END CABINETS

To turn a cabinet into a radius end cabinet, specify its Type as “Left Radius End” or “Right Radius End”.

As you face the cabinet, a right radius end curves to the right, and a left radius end curves to the left.

PENINSULA RADIUS CABINETS

To turn a cabinet into an end cabinet, specify its Type as “Peninsula Radius”.

The radius can be adjusted by changing the Depth/Bow Depth value. See General Panel on page 465.          

ANGLED FRONT CABINETS

To assign an angled front to a cabinet, specify its Type as “Angled Front”.         

 l The length of the left and right side of an Angled Front cabinet can be defined by changing the Depth/Bow Depth 
value. See General Panel on page 465.             

KITCHEN ISLANDS

To create a kitchen island, simply place several cabinets back-to-back and/or side-to-side. Match the widths so that each 
cabinet back or side meets the back or side of only one other cabinet. If this is not done, the lines separating the cabinets 
cannot be suppressed. 
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A given side of a single cabinet cannot merge with the edges of two different cabinets. The example below shows two 
instances of cabinets placed back-to-back. Cabinet fronts and joining surfaces are shown.

BLIND CABINETS

Often, when two cabinets meet in a corner, one is partially hidden by the other. This partially hidden cabinet is called a 
“blind” cabinet. Home Designer will resize and offset the front items of the partially hidden cabinet so that they are not 
located in the hidden portion of the cabinet face.

You can also create a blind cabinet manually by controlling the widths of a cabinet’s left or right stile in its Cabinet 
Specification dialog. See  Front Panel on page 468.          

 

Cabinet Specification Dialog
Select one or more cabinets and click the Open Object edit button to open the Cabinet Specification dialog.

The options in the Cabinet Specification dialogs are similar to the corresponding Cabinet Defaults dialog. See Cabinet 
Defaults on page 445.   

The Cabinet Specification dialogs have the following panels:

464



Home Designer Pro 2025 Reference Manual - Cabinet Specification Dialog

GENERAL PANEL

 
Cabinet Style

A number of Cabinet Types are available in the drop-down list. Certain requirements must be met before some types can 
be specified. Not available in the Cabinet Defaults dialogs. See Special Cabinets on page 461. 

 
Size/Position

The selected cabinet’s dimensions and position relative to the floor can be specified here. Fractional values are supported to 
1/16th of an inch (1 mm).

 l Specify the Width of the cabinet box, as measured across the front of the cabinet box from left to right. This does 
not include the countertop overhang.

 l Specify the Height (Including Counter) of the cabinet box, as measured from bottom to top. For base cabinets, this 
value includes the countertop thickness, but not the height of the backsplash. 

Note: Height refers to the height of the entire cabinet, including 
countertop and toe kick. If you change the Countertop Thickness or 
Toe Kick Height, the cabinet’s total height is not altered. Instead, the 
cabinet face height and the heights of face items change in response. 

 l Specify the Depth of the cabinet box, as measured from front to back. It does not include the thickness of overlay 
doors or the countertop overhang. 

 l For Corner cabinets, the Width and Depth fields are instead named Right Side Width and Left Side Width.
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 l For Corner cabinets, specify the Bow Depth. A positive number creates a bow and a negative number, an inside 
bow. Not available for Corner cabinets if Diagonal is unchecked on the Front panel. See  Front Panel on page 468.

 l For Angled Front cabinets, specify the Left Depth and Right Depth rather than the Depth and Bow Depth.

 l Select the Elevation Reference from the drop-down list. This determines where the next two settings are measured 
from and also affects their setting labels. See Elevation References on page 20.

 o Specify the to Top distance, measured from the Elevation Reference to the top of the cabinet’s countertop. 

 o Specify the to Bottom distance, measured from the Elevation Reference to the bottom of the cabinet, including the 
toe kick.

 
Countertop

Specify the dimensions and style of the selected cabinet’s Countertop, or uncheck this box to prevent it from having a 
countertop. Only available for base cabinets.              

 l Specify the countertop Thickness. Changing this value does not alter the cabinet height, but it does affect the height 
of face items. See  Front Panel on page 468.         

 l Specify the countertop Overhang. Uncheck Uniform to specify separate values for each side in the fields below, or 
leave it checked to use the same value for all sides. Overhangs do not generate on sides that are against a wall, free-
standing appliance, Partition, or another Base or Full Height Cabinet. See Cabinet Snapping and Aligning on page 
450.         

 l Corner Treatment - Specify Clipped or Rounded countertop corners. 

 l When Clipped or Rounded is selected, specify the Corner Width, which is measured from the original location of 
the corner to the point where the straight front edge ends.   

 l Check Display Molding Edges in Plan Views to draw the molding profile applied to the countertop in plan views, 
if there is one. When unchecked, only the countertop's Overhang is represented. See Editing Cabinet Styles on page 
459.             

 
Backsplash

Check the box beside Backsplash, then specify its dimensions and when it should generate, or leave this box unchecked to 
prevent the selected base or wall cabinet from having a backsplash.              

 l Specify the backsplash Height and Thickness.              Height is only available for base cabinets - not wall cabinets in 
legacy files.

 l Check Side to add the backsplash to the side of the cabinet if it is against a wall or a taller cabinet. Not available for 
Corner cabinets.         

 l Check Always Present to display the backsplash at all times. If unchecked, a backsplash is present only when the 
cabinet is against a wall.         

 l The Backsplash to Base Below check box is only available in legacy plan files if it was checked in the original 
program version. When checked, a backsplash extends from the selected wall cabinet down to the backsplash or 
countertop of the base cabinet below. If this box is unchecked and you click OK, the setting will be removed from 
the dialog.   

 
Toe Kick

Specify the dimensions and style of the selected cabinet’s  Toe Kick, or uncheck this box to prevent it from having a toe 
kick. Only available for base and full height cabinets. Regardless of the settings here, toe kicks do not generate  on sides that 
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are against a wall, free-standing appliance, Partition, or another Base or Full Height Cabinet.            

 l Specify the toe kick’s Height and Depth. Changing the Height does not alter the cabinet height but does affect the 
heights of the cabinet face and face items.             

 l Flat Sides can be added to base and full height cabinets. Checking Flat Sides eliminates the toe kick area on the 
exposed end(s) of the cabinet.             

 l Check Flat Back to eliminate the toe kick on a cabinet with an exposed back. This does not eliminate the toe kick 
on the cabinet front.             

 l Check Closed Toe to extend the cabinet sides to cover the sides of the toe kick. If pilasters that do not extend to the 
floor are specified, checking this places a support block under them at Exposed Ends. See Accessories Panel on page 
474.    

  Options

 l Uncheck Diagonal Door to create double doors at right angles instead of a single diagonal door. This option is 
checked by default in the Cabinet Defaults dialog and is only available for Corner Cabinets. See Corner Cabinets on 
page 462.

 l Check Lazy Susan to indicate a lazy Susan in the cabinet’s label and its appearance in plan view. This option does 
not display in 3D views.

 l When Suppress Adjacent Room Moldings is checked, room moldings do not generate on walls where the selected 
cabinet touches them. Uncheck this box to allow room moldings to generate through the cabinet. See Room Moldings 
on page 308.

 
Preview

A preview of the selected cabinet displays on the right side of the panel. See Dialog Preview Panes on page 21. 

BOX CONSTRUCTION PANEL

 
Box Construction

Define the Box Construction of the selected cabinet. Select Framed to create a traditional framed cabinet and enable the 
settings below, or choose Frameless for a European style cabinet.           

 l Specify the Separation value, which is the width of the horizontal face frame piece between doors, drawers, and 
other face items.     
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Door/Drawer Overlay

See Cabinet Construction on page 457.    

 l Select Traditional Overlay, then specify the default Overlap value for the selected cabinet's face items. You can 
customize the Left, Right, Top, and Bottom Overlays of individual door and drawer face items, as well. See Cabinet 
Specification Dialog on page 464, below.   

 l Select Full Overlay, then specify the Reveal, which is the distance between door and drawer front items. This 
serves as the default for the Left and Right Reveal settings on THE FRONT/SIDES/BACK panel.    

 l Select Inset to produce doors and drawers that are flush with the rails and stiles rather than overlaying it.             

 
Preview

A preview of the selected cabinet displays on the right side of the panel. See Dialog Preview Panes on page 21. 

 FRONT PANEL

If you click on a cabinet face item in the preview on the right side of the dialog, the FRONT panel will become active and 
that face item will be selected and can be edited. 

 
Face Items

Most of these settings are only active when a door, drawer, or other face item is selected. To select a face item, click on its 
name in the list or click on it in the preview on the right.             

When a face item is selected, it is highlighted in the list as well as in the preview; its attributes can be edited and the list can 
be navigated using the arrow and number keys. The vertical frame pieces on the sides of the cabinet front are referred to as 
stiles and cannot be selected in the preview. See Cabinet Face Items on page 460.
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 l A numbered tree list of face items displays here. Item numbers start at the top of the cabinet and go down the face to 
the bottom of the cabinet. Item 1 is usually the top face frame Separation, or rail. The selected face item is 
highlighted; if no item is selected, the “Vertical Layout Parent” heading will be highlighted.      

 l The name of inserted library objects associated with doors, drawers, and appliance items is stated in the list. If a door 
or drawer is using the default style, it s name will be preceded by "Default".      

 l Click Add New to add a new face item directly below the currently selected item. When a face item is added, the 
height of the lowest item on the cabinet front is reduced to make room for the new item. If you click Add New with 
no face item selected, the new item is added to the bottom of the cabinet face.

 l In the New Cabinet Face Item dialog, define the Item Type, Item Height, and click OK. If the Item Type is 
“Separation”, you can check Default to use the default Separation Height. 

 l Click Delete to remove the selected face item. When an Auto Left, Auto Right, Left, Right, or Double Door is 
deleted, it is replaced by an Opening; when other face item types are deleted, the height of the lowest item is 
increased to make up the difference. You can also press the Delete key to remove a selected face item. 

The program tries to maintain a single separation between all 
face items. When you add or delete a face item, separations 

are usually added or deleted with them.

 l Click Move Up to move the currently selected item up one position, switching places with the item directly above.    

 l Click Move Down to move the currently selected item down one position, switching places with the item directly 
below.    

 l When the selected face item is part of a “Layout - Horizontal”, the Move Left and/or Move Right buttons will be 
available instead. Click either to have the selected item switch places with its neighbor.              

 l Click Split Vertical to divide the selected face item into two separate side-by-side items of the same Item Type and 
Height. A vertical separation is added between them and together the three new items have the same Width as the 
original item. Not available for Horizontal or Vertical Layouts, Appliances, Separations, or for items 1 1/2” (50 mm) 
wide or less.              

 l Click Split Horizontal to divide the selected face item into two separate items of the same Item Type and Width, 
stacked one above the other. A horizontal separation is added between them and together the three new items have 
the same Height as the original item. Not available for Horizontal or Vertical Layouts, Appliances, Separations, or 
for items 1 1/2” (51 mm) tall or less.              

 l Click Equalize to make the sizes of a face item’s sub-items equal in size. Only available if the selected item is a 
Vertical or Horizontal Layout with sub-items.              

  Selected Item Properties

 l Choose the selected face item’s Item Type from the drop-down list:    
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Item Type Special Behaviors

Blank Area Creates a solid, flat surface.

Horizontal 
Layout

Creates a group of identical, side-by-side items separated by vertical 
separations.

Vertical 
Layout

Creates a group of identical, stacked items separated by horizontal 
separations.

False 
Drawer and

False 
Double 
Drawer

Assumes the appearance of specified the drawer style, including 
hardware.

Drawer and 
Double 
Drawer

Creates a single or double drawer of the specified drawer style, 
including hardware.

Cutting 
Board

Creates a cutting board. 

Auto Right 
and Auto 
Left Door

Become double doors when the width of the opening is greater than 24" 
(600 mm). 

Left, Right, 
and Double 

Door

As specified, regardless of opening width.

Door Panel Assumes the appearance of the specified door style but with no 
hardware.

Opening Creates an opening with shelves.

Separation Creates a horizontal rail, or frame piece. 

Appliance Creates an opening with no shelves, for which an appliance can be 
specified.

 l Specify the selected face item’s Item Height. Fractional values are supported to 1/16th of an inch (1 mm). For 
doors and drawers, this is the height of the opening: the selected door or drawer's Front Height is reported to the 
right for reference. A door or drawer’s front height is equal to its Height plus its top and bottom Vertical 
Overlap. For best results, edit face item heights starting at the top of the cabinet and work down. See Cabinet 
Face Items on page 460.    

 l Specify the selected face item’s Item Width. Fractional values are supported to 1/16th of an inch (1 mm). For 
doors and drawers, this is the width of the opening: the selected door or drawer's Front Width is reported to the 
right for reference. Only available for components of a Horizontal Layout.              

 l Check Lock from Auto Resize to prevent the selected face item from resizing when the cabinet is resized, new 
face items are added, or when the Equalize button is clicked.

 l Shelves - Click the Specify button to open the Cabinet Shelves Specification dialog and specify the shelf 
configuration for a selected Door or Opening Face Item. See Cabinet Shelf Specification Dialog on page 475.             
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 l When an Appliance/Door/Drawer is selected:

 o Click the Specify button to choose an appliance from the Library or to customize the selected door, drawer, or 
panel’s front style and hardware. The options available depend on the type of face item currently selected. See 
Select Library Object Dialog on page 716 and Door/Drawer Panel on page 471.               

 o Click the Clear button to remove the selected appliance from the cabinet or to reset the selected door or drawer 
so it uses hardware and front style assigned to the cabinet.               

 o Check Reverse Appliance to reverse the selected face item from left to right: for example, to move a 
dishwasher’s controls from the left side to the right. Only available when an “Appliance” item is selected. See 
Inserted Objects on page 715.    

 l Specify the Percent Open of a selected drawer, which controls how far it is shown open in plan and 3D views. 
See Cabinet Doors and Drawers on page 453.    

 l Specify the Swing Angle of a selected door in plan and 3D views. An angle of 0° displays the door completely 
closed and an angle of 180° displays it as wide open.    

  Side Properties

 l Specify the widths of the Left Stile and Right Stile. Only available when the selected cabinet has Framed Box 
Construction specified. See Framed and Frameless Cabinets on page 460.             

  Options

 l Specify which types of front items you would like to Show Open in plan, 3D, and cross section/elevation views. See 
Cabinet Doors and Drawers on page 453.      

 
Preview

A preview of the selected cabinet displays on the right side of the panel. See Dialog Preview Panes on page 21.             

 l Select Cabinet Face Item  mode is active by default and allows you to click on a face item like a door, drawer, 

or separation in the preview to select it for editing. The selected face item is highlighted in grey. 

 l Mouse-Orbit Camera  mode allows you to orbit around the preview of the cabinet. When this is active, you can 

right-click on a front item to select it. 

DOOR/DRAWER PANEL

The settings on the DOOR/DRAWER panel allow you to control the appearance of the selected cabinet’s doors, drawers and 
hardware. 

Similar settings are also found in the Door and Drawer Face Item Specification dialogs, which allow you to customize the 
door and drawer style as well as the hardware for individual cabinet face items. See  Front Panel on page 468.
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  Door

 l Select a door Main Style from the drop-down list. See Doors, Drawers and Panels on page 460.    

 o Select “Use Default” to apply the door style specified in the defaults dialog for the selected cabinet’s type. See 
Cabinet Defaults on page 445.    

 o Select “Slab Doors” to apply a flat door front or “Framed Doors” to apply a door with a frame and flat panel front.    

 o Select “Library” or click the Library button to select a cabinet door from the library. If a library door has been 
previously selected, its name will display in the list. See Select Library Object Dialog on page 716.    

 l Specify the selected door's Thickness. If you assign a door symbol from the library to the cabinet, this value will 
update to match the symbol's Depth.

 l Check Glass Doors to use a glass material for the panel of Framed doors or for the entire door for Slab doors. Not 
available when “Library” is the selected door Style. 

 l Check Stile Between Doors to separate double doors and double drawers with a stile. Other face items types are not 
affected by this setting.               
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  Door Handle

 l Select a door handle Main Style from the drop-down list or choose one from the Library. 

 l When a handle from the Library is selected, you can click the Edit button to customize the handle's size and angle. 
See Hardware Size/Orientation Dialog on page 476.

 l Specify the Vertical Position of the door handle: Choose Use Default to use the default position; Centered for a 
handle centered on the door face; or specify a Distance From Top. 

 l Specify the Horizontal Position of the door handle: Choose Use Default to use the default position, Centered for a 
handle centered on the door face, or specify the handle’s Distance From Edge.

  Door Hinges

 l Select a door hinge Main Style from the drop-down list or choose one from the Library. 

 l When a handle from the Library is selected, you can click the Edit button to customize the handle's size and angle. 
See Hardware Size/Orientation Dialog on page 476.

 l Specify the location of the hinges Up/Down From Edge, as measured from the door edge. If the cabinet door is 
more than 35 1/4” (880 mm) high, three hinges will be created instead of two. 

  Drawer

 l Select a drawer Main Style from the drop-down list or choose one from the Library. For best results, “Framed” 
drawers should be at least  6” (150 mm) high.

 l Specify the selected drawer's Thickness.

  Drawer Handle

 l Select a drawer handle Main Style from the drop-down list or choose one from the Library. 

 l When a handle from the Library is selected, you can click the Edit button to customize the handle's size and angle. 
See Hardware Size/Orientation Dialog on page 476.

 l Specify the Horizontal Position of the drawer handle(s): Choose Use Default to use the default position; One 
Handle Centered for a single handle centered on the drawer face; or Two Handles In From Edge for two handles 
set in from the drawer sides by the value specified in the text field. 

 l Specify the Vertical Position of the drawer handle(s): Choose Use Default to use the default position, Centered for 
handle(s) centered on the drawer face, or specify the handle’s Distance From Top. 

  Options

 l Enter a Slab Bevel width to create beveled edges on Slab drawers and doors. The bevel width, as viewed from the 
front, has a maximum value of 3” (75 mm). Framed and Library doors are not affected by this setting.               

 
Preview

A preview of the selected cabinet displays on the right side of the panel. See Dialog Preview Panes on page 21.
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ACCESSORIES PANEL

The ACCESSORIES panel is only available in the Base Cabinet Specification dialog. It is not available for wall or full height 
cabinets, nor is it found in the Base Cabinet Defaults dialog.         

 
Top Appliance/Fixture

The Top Appliance/Fixture settings apply to a fixture inserted into a base cabinet’s countertop. These settings are not 
available in the Base Cabinet Defaults dialog. See Built-In Sinks and Appliances on page 448.    

 l Select a fixture Symbol from the drop-down list, or choose “None”. If a fixture is inserted into the countertop, its 
name will be listed. If no top fixture is present, you can select “Library” to select a fixture symbol from the Library.    

 l Specify the Front Offset, which is the distance from the front of the fixture to the front of the cabinet box. A 
positive value offsets the fixture towards the back of the cabinet while a negative value moves it forward. 

 l Specify the Center Side Offset, which is the distance between the fixture’s center and that of the cabinet. A positive 
value offsets the fixture to the right while a negative value offsets it to the left.    

 l Check Reverse to reverse the selected fixture from left to right: for example, to move a cooktop’s controls from the 
left side to the right. See Inserted Objects on page 715.

 
Preview

A preview of the selected cabinet displays on the right side of the panel. See Dialog Preview Panes on page 21. 

OPENING INDICATORS PANEL

The settings on the OPENING INDICATORS panel allow you to control whether an opening indicator displays on the selected 
cabinet's door(s) in camera views. See Opening Indicators Panel on page 403.

MOLDINGS PANEL

The settings on the MOLDINGS panel allow you to assign one or more horizontal moldings around the selected cabinet. See 
Editing Cabinet Styles on page 459.

For information about the settings here, see Moldings /  Rails Panels on page 688.

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected cabinet in plan view. For more information, see 
Fill Style Panel and Dialogs on page 132.
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MATERIALS PANEL

The settings on the MATERIALS panel affect the appearance of the selected cabinet in 3D views. For information about these 
settings, see Materials Panel on page 750.

Some material options may be disabled if the selected cabinet is a manufacturer symbol. 

LABEL PANEL

Cabinet labels display in plan view when the “Cabinets, Labels” layer is turned on and use the Text Style assigned to that 
layer. See Cabinet Labels on page 455. 

For more information about the settings on this panel, see Label Panel on page 376.

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 967.

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in the materials list. For more information, see 
Object Information Panel on page 968.   

 

Cabinet Shelf Specification Dialog
In the Base Cabinet, Wall Cabinet, or Full Height Cabinet Specification dialog, select a door or opening face item and click 
the Specify Shelves button to open the Cabinet Shelf Specification dialog.  See  Front Panel on page 468.          
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Shelf Management

Specify how shelves in the selected face item are created.

 l By default, cabinet doors and openings receive Automatic cabinet shelves. The number of shelves, shelf type, 
thickness, spacing, and depth display below.          

 l Select the Manual radio button to specify the shelving for the selected door or opening. If the cabinet is resized after 
shelving has been manually edited, the specifications are maintained, but all shelves may not display in all situations.          

 
Automatic Settings

Displayed for reference only. 

 
Manual Shelf Specification

 The following settings are available when Manual is selected, above:             

 l Specify the total Number of Shelves in the selected door or opening front item.           

 l Select a Shelf from the drop-down list to customize its settings. To edit all shelves at once, choose “All Shelves”.           

Note: If “All Shelves” is selected after changes are made to an individual 
shelf, “No Change” may display in the settings that follow.

 l Click the Library button to select a shelf, storage, or organization object from the Library Browser. See Inserted 
Objects on page 715.           

 l Click the Clear button to restore the default shelf style.          

 l Check Rollout, then specify the amount that the shelf rolls out when set to Show Open. Only available for Standard 
cabinets. See Rollout Shelves and Storage on page 454.           

 l Specify the Thickness/Height of the shelves or storage item.           

 l Specify the Spacing From Previous, which is the distance from the bottom of the selected shelf to the top of the 
shelf below it.          

 l If the Spacing From Previous value is changed, Equal Spacing will become unchecked. Check this box to produce 
evenly space the shelves within the selected cabinet front item.          

 l Specify the selected shelf’s Depth: choose Full, Half, or Specify a custom value in inches (mm).          

 
Preview

The preview shows shelf numbers and spacing. Shelf thickness and depth are also represented. Press the Tab key to update 
the preview as changes are made.

 

Hardware Size/Orientation Dialog
In the Base Cabinet, Wall Cabinet, or Full Height Cabinet Specification dialog, click the Edit button associated with either 
door/drawer handles or drawer hinges to open the Cabinet Shelf Specification dialog.  See Door/Drawer Panel on page 471.          
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Name

The Name of the selected hardware symbol is reported here for reference.

  Rotation

 l Specify an exact Angle by typing it in the text field.           

 l Click the Rotate +90° or Rotate -90° button to add or subtract 90° from the Angle value.           

 
Preview

The preview shows the hardware's containing cabinet with the specified hardware. See Dialog Preview Panes on page 21.

 

Shelf/Partition Specification Dialog
Select a shelf or partition and click the Open Object edit button to open the Shelf Specification or Partition 
Specification dialog.

The options in these specification dialogs are similar to the corresponding defaults dialogs. See Cabinet Defaults on page 
445.
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GENERAL PANEL

 
Size/Position

Specify the Height, Width, and Depth of the shelf or partition.    

 l Left Side Width and Right Side Width replace Width and Depth when a Diagonal or L-Shaped Corner Type are 
selected below.

 l  Select the Elevation Reference from the drop-down list. This determines where the next two settings are measured 
from and also affects their setting labels. See Elevation References on page 20.

 o Specify the to Top distance, measured from the Elevation Reference to the top of the shelf or partition. 

 o Specify the to Bottom distance, measured from the Elevation Reference to the bottom of the shelf or partition.

 
Toe Kick

Specify the dimensions of a selected Partition's Toe Kick, or uncheck this box to prevent it from having a toe kick. Only 
available for Partitions.    

 l Specify the toe kick's Height and Depth. Changing the Height does not alter the Partition's height.

 l Check Flat Back to eliminate the toe kick on a Partition with an exposed back. This does not eliminate the toe kick 
on the Partition's front.

  Options

 l Specify the Corner Type: "Diagonal", "L-Shaped", or "None". "None" produces a rectangular shelf or partition. In 
the Shelf Defaults dialog, "Diagonal" and "L-Shaped" are the available Auto Corner Types. See Corner Cabinets 
on page 462.

 l When Suppress Adjacent Room Moldings is checked, room moldings do not generate on walls where the selected 
object touches them. Uncheck this box to allow room moldings to generate through the object.

 
Preview

A preview of the selected object displays on the right side of the panel. See Dialog Preview Panes on page 21.  
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FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected object in plan view.               See Fill Style Panel and 
Dialogs on page 132.

MOLDINGS PANEL

The settings on the MOLDINGS panel allow you to apply molding to the selected object. For information about these settings, 
see Moldings /  Rails Panels on page 688.         

MATERIALS PANEL

The settings on the MATERIALS panel affect the appearance of the selected object in 3D views. For information about these 
settings, see Materials Panel on page 750.

LABEL PANEL

Shelf and Partition labels display in plan view when the “Cabinets, Labels” layer is turned on and use the Text Style 
assigned to that layer. The Automatic Labels for Shelves and Partitions are blank, but you can specify custom labels if you 
wish.  See Cabinet Labels on page 455.

For more information about the settings on this panel, see              Label Panel on page 376.         

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. See Components Panel on page 967.          

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in the materials list. See Object Information Panel 
on page 968.   

 

Custom Countertop Specification Dialog
Select a custom countertop and click the Open Object edit button to open the Custom Countertop Specification 
dialog.         
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GENERAL PANEL

  Options

 l Check No Molding On Selected Edge to turn off the display of molding on the selected edge. Only has an effect 
when a molding is specified for the countertop on the MOLDINGS panel of this dialog.             

 l Check Display Molding Edges in Plan Views to display two edge lines instead of one, indicating the width of any 
molding applied to the countertop. Only has an effect when a molding profile is specified for the countertop.              

  Countertop Thickness

 l Uncheck Set Thickness From Cabinet, then specify the Thickness of the selected Custom Countertop below. When 
this is checked, the thickness is inherited from the cabinet below or from the Base Cabinet Defaults dialog if no 
cabinet is present below.             

  Countertop Height

 l Uncheck Set Height from Cabinet, then specify the height of the selected Custom Countertop using the settings 
below. When this is checked, Countertop height is determined by the cabinet below or by the default base cabinet 
counter thickness if no cabinet is present below.             
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 l Select the Elevation Reference from the drop-down list. This determines where the next two settings are measured 
from and also affects their setting labels. See Elevation References on page 20.             

 o Specify the height to Top, which is measured from the selected Elevation Reference to the top of the countertop.             

 o Specify the height to Bottom, which is measured from the selected Elevation Reference to the bottom of the 
countertop.             

 
Waterfall Edge

Control whether the selected countertop edge has a waterfall and specify its attributes. See Waterfall Countertops on page 
452.          

 l Check Add Waterfall to Selected Edge to add a vertical extension to the selected edge of the countertop.              

 l Uncheck Mitre All Waterfall Edges to create butt joints with seams that may be visible in some views where the 
waterfall meets the horizontal countertop and any adjacent waterfall edges. When checked, these joints are mitered 
so the only visible seams are located at the corners.             

 l When Automatic Height is checked, the waterfall builds down to the floor height countertop’s room, or the default 
floor height for the current floor if it is not in a room. Uncheck this to specify the waterfall’s vertical height, below.              

 l Specify the Height from Counter Bottom, measured from the bottom of the horizontal countertop to the bottom of 
the waterfall.          

 
Molding on Selected Edge

An edge profile for the selected counter can be specified on the Moldings panel. See Selected Edge on page 143.     

 l Select Automatic to remove the edge profile from the selected edge when it is positioned against a wall and generate 
it otherwise.      

 l Select No Molding to remove the edge profile from the selected edge regardless of where it is positioned.       

 l Select Has Molding to generate the edge profile on the selected edge regardless of where it is positioned.       

 l Check Apply to All Edges to apply the option specified for the currently selected edge to all edges of the 
countertop. This is an action rather than a state: the next time this dialog is opened, this box will be unchecked.

 
Preview

A preview of the selected countertop displays on the right side of the panel. See Dialog Preview Panes on page 21.          

POLYLINE PANEL

The POLYLINE panel states the length of the countertop’s Perimeter, its Area, and its Volume. See Polyline Panel on page 
219.          

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. For more information, see  Line 
Panel on page 208.         

The SELECTED ARC panel is available when the selected edge has been converted to an arc. For more information, see Arc 
Panel on page 214.         

See, too, Selected Edge on page 143 and Change Line/Arc on page 176.          
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MOLDINGS PANEL

The settings on the MOLDINGS panel allow you to apply an edge profile to the selected countertop. For information about 
these settings, see Moldings /  Rails Panels on page 688.

LINE STYLE PANEL

For information about the settings on this panel, see Line Style Panel on page 209.         

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected countertop in plan view. For information about 
these settings, see Fill Style Panel and Dialogs on page 132.         

MATERIALS PANEL

The settings on the MATERIALS panel affect the appearance of the selected countertop in 3D views. For information about 
these settings, see Materials Panel on page 750.         

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 967.          

 

 Custom Backsplash Specification Dialog
Select a Custom Backsplash and click the Open Object edit button to open the Custom Backsplash Specification 
dialog.

STRUCTURE PANEL

 l The total thickness of the Material Layers displays here for reference.
 l Click the Edit button to open the Material Layers Definition dialog. See Material Layers Definition Dialogs on page 

743. 
 l Uncheck Cut Finish Layers of Parent Object to fix the selected Material Region to the surface of its parent floor 

platform or wall. When checked, it cuts into the finish layers of the polyline’s parent object and replaces those layers 
with its own within its perimeter. 

POLYLINE PANEL

The POLYLINE panel indicates the length of the region’s Perimeter and its enclosed Area. See Polyline Panel on page 219.
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SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. See Line Panel on page 208.

The SELECTED ARC panel is available when the selected edge has been converted into an arc. See Arc Panel on page 214.

See, too, Selected Edge on page 143 and Change Line/Arc on page 176.

LINE STYLE PANEL

For information about the settings on this panel, see Line Style Panel on page 209.

FILL STYLE PANEL

The FILL STYLE panel is only available for Floor Material Regions. For information about the settings on this panel, see Fill 
Style Panel and Dialogs on page 132.

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 967.
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Chapter 18
 

Electrical

The electrical plan shows the location of all electrical objects such as lights, switches, outlets, smoke detectors and vent 
fans. Basic wiring diagrams show which objects share circuits and the locations of the controlling switches.

Electrical objects can be displayed in 2D and 3D views. Some electrical light fixtures also add light sources to 3D views. 
See Lighting on page 817.

Usually, the electrical plan is one of the last additions to a plan since the position of most electrical objects is determined by 
the location of walls, cabinets and other objects.

Building requirements vary throughout the country and around 
the world. It is your responsibility to comply with local codes.

TOPICS

Electrical Defaults 485
The Electrical Tools 486
Placing Electrical Objects 488
Auto Place Outlets 489
Creating Wiring Schematics 489
Electrical Library Content 490
Displaying Electrical Objects 491
Editing Electrical Objects 492
Light Data Panel 493
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Electrical Defaults
There are two defaults dialogs for electrical objects, which you can access by selecting Edit> Default Settings, then 
clicking the arrow beside “Electrical”. Select a subheading and click the Edit button to open the defaults dialog 

associated with your selection. See Default Settings on page 57.

Default heights and other attributes of individual objects can be overridden in the Electrical Service Specification dialog. 
See Light Data Panel on page 493.

ELECTRICAL DEFAULTS DIALOG

The Electrical Defaults dialog lets you specify which electrical symbols are placed by the Electrical Tools and can be 
opened by double-clicking any of the Electrical Tools' toolbar buttons, except Electrical Connection.

 
Default Library Objects

The Default Library Objects are the objects created using the Electrical Tools. Select an item in the scrollable list to see 
and edit its settings.                 

 l The name of the object shown in the preview image displays here.          

 l Select an item in the Default Library Objects list and click the Library button to select a new default object from the 
library. See Select Library Object Dialog on page 716.          

 l Click the Edit button to open the specification dialog for the selected object. Any changes you make in the 
specification dialog are saved with the plan as long as the selected object is not replaced. See Light Data Panel on 
page 493.          

 
Default Heights

Specify the heights at which electrical outlets and switches are initially placed when the Switch or any of the Outlet tools 
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are used.                 

 l Check Use Default Heights to apply the default heights specified here to electrical objects placed in plan view using 
the Electrical Tools. When this is unchecked, electrical objects use the height saved with their symbol. See Placing 
Library Objects on page 714.           

 l Outlet - Specify the default height for outlets, as well as phone, cable and TV jacks.          

 l Switch - Specify the default height for switches, doorbells and thermostats.          

 l Above Base Cabinet - Specify the default height for switches and outlets placed above base cabinets in plan view, 
as measured from the countertop. See Adjusting Electrical Object Heights on page 493.          

 l On Cabinet Side - Specify the default height for switches and outlets placed on the sides of cabinet boxes, measured 
relative to the side of the cabinet in question. See Placing Electrical Objects on page 488.          

 
Preview

A preview of the selected object displays here. See Dialog Preview Panes on page 21.             

ELECTRICAL CONNECTION DEFAULTS

The Electrical Connection Defaults control the appearance of Electrical Connection splines when they are first drawn 
and can be opened by double-clicking the Electrical Connection tool. See Creating Wiring Schematics on page 489.

This dialog is similar to the Electrical Connection Specification and Polyline Specification dialogs but has only two panels:

 l The SPLINE panel allows you to control the curvature of Electrical Connection splines. See Spline Panel on page 219.           
 l The LINE STYLE panel lets you control the line style assigned to Electrical Connection splines. See Line Style Panel on 

page 209.

 

The Electrical Tools
Select Build> Electrical to access the Electrical Tools. Some electrical objects are designed to be inserted into walls, 
floors, ceilings or cabinets, although some can also be free-standing. With the exception of Electrical Connection 

splines, they can be created with a single click in plan and camera views. See Placing Electrical Objects on page 488.

The Electrical Tools place objects or draw according to the settings in the Electrical Defaults dialogs. See Electrical 
Defaults on page 485.

Different outlet, switch, and light fixture symbols can be placed in different room types. To take advantage of the program’s 
capabilities, define room types properly before placing electrical objects. See Room Types on page 289.

Once created, outlets, switches, and lights can be selected and edited. See Editing Electrical Objects on page 492.

OUTLETS

The outlet tools can place receptacles on walls, the floor, and on the sides of cabinets and soffits.

Select Build> Electrical, then choose:

  110V Outlet to place 110 volt duplex outlets. 

  GFCI Outlet to place ground fault circuit interrupter outlets.

486



Home Designer Pro 2025 Reference Manual - The Electrical Tools

  220V Outlet to place 220 volt outlets. 

The type and height of an outlet will vary depending on  where it is placed. For example:

 l An outlet placed on a wall at the back of a base cabinet in plan view is positioned above the counter.    
 l An outlet placed on a wall at the back of a base cabinet containing a kitchen sink is placed at the standard 11 1/2" (300 

mm) above the floor.    
 l An outlet placed on the side of a cabinet or soffit will be positioned 32” (800 mm) up from that object’s bottom.    
 l An outlet placed outside the building or in an exterior area such as a deck or porch will be weatherproof.
 l An outlet placed in the central area of a room in plan view will be positioned on the floor, with one exception: 110V 

Outlets placed in Garage or Slab rooms will be positioned on the ceiling.

In camera views, 110V Outlets can be placed on ceilings in any 
room type.

LIGHT FIXTURES

Select Build> Electrical> Light to place light fixtures on walls, the ceiling, or on soffits. All light fixtures placed in 
a plan can also serve as light sources in most 3D views. To place a light fixture using the Light tool:

 l Click near a wall or the side of a soffit to place a wall-mounted fixture at that location. 
 l Click away from a wall to place a ceiling mounted light. 
 l Click inside a soffit in plan view or on its bottom surface in a camera view to place a ceiling mounted light on the 

soffit’s bottom surface.
 l Click outside a room and away from a wall to place a path light.
 l Some light symbols from the library can be mounted under wall cabinets, as well. 

The rendering characteristics of individual lights that control how they appear in    rendered  views can be specified on the 
LIGHT DATA panel of the Electrical Service Specification dialog. See Light Data Panel on page 493.

SWITCHES

Select Build> Electrical> Switch to place electrical switches on walls or on the sides of cabinets or soffits. Like 
outlets, the height of switches is measured from the floor to the center of the object.

 l A switch placed on the side of a cabinet or soffit will be positioned 32” (800 mm) up from that object’s bottom.    
 l Switches placed outside the building or in an exterior area such as a deck or porch will be weatherproof.

If you connect two or more switches in a circuit, they update to 
3-way or 4-way switches automatically.

Switches placed from the Electrical Library do not automatically update by default, but can be specified to do so. See Light 
Data Panel on page 493.    

AUTO PLACE OUTLETS

Select Build> Electrical> Auto Place Outlets and click in a room tool to place outlets at regular intervals around the 
entire room. See Auto Place Outlets on page 489.
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ELECTRICAL CONNECTION

Select Build> Electrical> Electrical Connection, then click and drag to draw splines that snap to electrical switches, 
outlets, and lights to illustrate wiring circuits. See Creating Wiring Schematics on page 489.

LIGHTING AND ELECTRICAL LIBRARY CATALOGS

A selection of free-standing and ceiling-, wall- and cabinet-mounted light fixtures is available in the Library Browser 
at Home Designer Core Catalogs> Architectural> Lighting. 

Special use outlets, switches, jacks and numerous other electrical items can be found at Home Designer Core Catalogs> 
Mechanical, Electrical, Plumbing> Electrical. See Placing Library Objects on page 714. 

 

Placing Electrical Objects
Electrical switches, outlets, lights, and other symbols can be created with a single click in any view. They can also be placed 
from the Library. See Click-to-Create on page 117. 

When the Switch, Light, or an outlet tool is used, the type and height of the object that is created will vary depending on 
where it is placed. As you move your mouse pointer around the view, an object preview will display near the pointer 
whenever it is over a location where an object can be placed. Specific details for each tool are noted in The Electrical Tools 
on page 486.

The electrical objects in the Library are typically designed for a specific use and can only be placed on a wall, on the floor, 
or on the ceiling. Some are instead free-standing and are designed to be placed on a table or the floor. See Placing Library 
Objects on page 714. 

Wall mounted outlets, switches, and Library symbols can also be placed on the sides of cabinets and soffits. They will snap 
to the outside of the cabinet box or to the outside of Side or Back Panels, but will ignore doors and drawers.

When a light fixture is created using any method, including copying and pasting, it will always be turned On. This is the 
case even if the default symbol is turned Off. See Light Data Panel on page 493.

ELECTRICAL OBJECT HEIGHTS

When a wall-mounted electrical object is placed in plan view using one of the Electrical Tools, its initial height off the floor 
is based on settings in the Electrical Defaults dialog. See Electrical Defaults on page 485. 

Wall mounted electrical symbols placed directly from the Library derive their initial heights from specification settings 
saved with each object. See Light Data Panel on page 493.

Similarly, cabinet-mounted electrical objects are placed using height information set in either the Electrical Defaults dialog 
or the symbol’s specification dialog. If the default height is higher or lower than the cabinet it’s being placed on, the 
electrical object will be placed along the top or bottom edge of the cabinet box. 

In 3D views, an electrical object placed on a wall in a 3D view will snap to its default height provided that the mouse 
pointer is near that height when you click. If you move the mouse pointer away from the default height, the object will be 
positioned wherever you click on the wall, regardless of the height at that point. 
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Auto Place Outlets
Select Build> Electrical> Auto Place Outlets and click in a room to place 110 volt outlets on the walls around the 
entire room, spaced so that no wall position is farther than six feet (1800 mm) from the nearest outlet. 110 or 220 volt 

outlets are also placed behind large appliances. In addition, a light is placed above each sink. 

Outlets and sink lights are placed based on settings in the Electrical Defaults dialog. See Electrical Defaults on page 485.          

It is important that a room’s Type be defined before Auto Place Outlets is used so that outlets are placed appropriately. For 
example, it places GFCI Outlets  over base cabinets if they are located in rooms specified as Kitchen or Bath. See Room 

Types on page 289.

Auto Place Outlets               does not work in rooms assigned an exterior room type such as Deck. To place outlets in an exterior 
room, place them from the Electrical Library or use the 110V Outlet  tool.

Railings and invisible walls are ignored by Auto Place Outlets. If it is used in a room defined by railings or invisible walls, 
outlets are automatically placed in any adjacent rooms on the other side of these wall types. See Room Definition on page 
287. 

Once placed, any outlet can be moved, edited, or deleted. See Editing Electrical Objects on page 492. 

 

Creating Wiring Schematics
Electrical schematics can be created in two ways. Using the Electrical Connection  tool is quick and easy, but if you 

need detailed schematics, you can create your own wiring diagrams using the CAD tools. See CAD Objects on page 197.         

ELECTRICAL CONNECTION

In plan view, select Build> Electrical> Electrical Connection, then click and drag to draw splines that attach to 
electrical Switches, Outlets, and Lights to illustrate wiring circuits. Electrical Connection Splines can also attach to 

cabinets and non-Electrical symbol objects. In addition, they can snap to points on other types of objects when Objects 
Snaps are in use; however, they are not attached to those objects and are not actually required to snap to or be attached to 
anything. See Object Snaps on page 114. 

You can also draw an Electrical Connection spline using a selected Switch, Outlet, or Light fixture's Electrical Connection 
edit handle. When you move your mouse pointer over this diamond-shaped edit handle, the Electrical Connection   icon 
will replace the default arrow and you can click and drag to draw a connection between the selected object and another 
electrical object.

To create a new circuit or add to an existing circuit, click on a switch, outlet, or light while the Electrical Connection tool 
is active, drag to the next object and release.

When an Electrical Connection spline is first drawn, it looks like an arc but actually consists of two segments that are 
defined by vertex points. When selected, its edit handles display at each of these vertices. If you click and drag one of these 
edit handles, the length, angle, and curvature of the spline will change but the other vertices will not move.  See Splines on 
page 223.
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Unattached ends of Electrical Connection splines can be connected to one another and once drawn, additional vertices can 
be added and used to form complex curves. See Editing Spline-Based Objects on page 162. 

To remove a connection from a circuit, simply select it and us its end edit handle to disconnected it from the object it is 
connected to. If you remove an electrical object from a circuit, any Electrical Connection splines connected to it will also be 
deleted. See Deleting Objects on page 191.

RESET CURVATURE

An edited Electrical Connection spline can be reset to its original shape using the Reset Curvature edit tool. This 
tool removes any breaks from the selected spline, restores its original curvature direction, and applies the Curvature 

Ratio set in the Electrical Connection Defaults dialog. See Spline Panel on page 219.

THREE- AND FOUR-WAY SWITCHES

Multiple switches can control an object or group of Electrical objects. 

 l Two switches controlling the same objects are referred to as three-way switches. 
 l Three switches controlling the same objects are called four-way switches. 

In plan view, a three- or four-way switch’s “way” number will automatically display in its 2D symbol. You can prevent a 
switch's symbol from changing by unchecking Automatically Change Switch Type When Wiring in its specification 
dialog. See Symbol Object Specification Dialogs on page 723. 

While more than one Switch can be connected to a cabinet or non-Electrical symbol object using an Electrical Connection 
spline, the Switches will not become three- or four-way. 

 

Electrical Library Content
Select View> Library Browser  to accesses a variety of electrical symbols. See The Library Browser on page 692.

Browse for electrical objects such as bath vent fans, an electrical panel, fluorescent lights, chandeliers, a smoke detector, 
thermostat, and more. Select a symbol, then click in your plan to place it on a wall, floor, or ceiling.

You can specify which electrical object in the library is used by each of the Electrical Tools. See Electrical Defaults on 
page 485.           

490



Home Designer Pro 2025 Reference Manual - Displaying Electrical Objects

You can also assign electrical objects from the library to toolbar buttons for easy access and placement to frequently-used 
library objects. See Place Library Object Button on page 716.          

ADDING ELECTRICAL CONTENT

Any electrical symbol placed into a plan can be customized and added to the User Catalog in the Library Browser. See Add 
to Library on page 709.

 

Displaying Electrical Objects
The display of electrical objects and connections is controlled in the Layer Display Options dialog. See Layer 
Attributes on page 125.

When displayed in 3D views, light fixtures act as sources of light that help illuminate the 3D model. See Lighting on page 
817.

IN PLAN VIEW

In plan view, electrical objects are represented by commonly used CAD symbols that represent the type of object rather than 
its appearance in 3D.

Like other objects, electrical objects are placed in Drawing Groups that affect whether they display in front of or behind 
other objects in plan view. You can modify a selected  object’s place in the drawing order by clicking the View Drawing 
Group Edit Tools  edit button. See Drawing Group Edit Tools on page 129. 

Electrical symbols are placed on the “Electrical” layer, while Electrical Connection splines are drawn on the “Electrical, 
Connections” layer.   

ELECTRICAL LABELS

Electrical labels display in plan view when the “Electrical, Labels” layer is turned on and use the Text Style assigned to 
their layer. See Label Panel on page 376.

Customized labels                           can be specified in the Electrical Service Specification dialog.             

Electrical labels have their own edit handles and can be moved when the electrical object is selected.

Note: Some electrical objects are represented in plan view by a symbol 
that includes text. This text is not part of the object’s label and does not 
use the Text Style assigned to the “Electrical, Labels” layer. 

IN THE MATERIALS LIST

Electrical objects, including outlets, switches, lights, and symbols from the library such as jacks and fans, are listed under 
the Electrical Category in the Materials List. Electrical Connection splines are 2D objects only, however, and are not 
calculated. See Materials Lists on page 950. 

As with other objects, there are a number of ways to control how, or whether, electrical objects are included in the Materials 
List. See Organizing Materials Lists on page 953.           

You can add and edit information about an electrical object’s accessories and sub-accessories in specification dialog. See 
Components Panel on page 967.           
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Editing Electrical Objects
Electrical objects can be selected individually as well as in a group in 2D and 3D views and edited using the edit handles, 
the Edit Toolbar and their specification dialog. See Symbol Object Specification Dialogs on page 723.

Electrical objects can be marquee-selected by type when the drawing tool used to create them is active. The Marquee Select 
Similar edit tool can also be used to group-select electrical objects. See Selecting Multiple Objects on page 145.

Light fixtures and Added Lights can be group-selected, but their light data cannot be edited unless each has the same 
number of light sources. See Lighting on page 817.         

Lights can also be edited using the Adjust Lights dialog. See Adjust Lights Dialog on page 822.         

USING THE EDIT HANDLES

The edit handles for electrical objects vary depending on the location of the object. 

 l In plan view, Switches, Outlets, and Lights have a special diamond-shaped Electrical Connection edit handle located 
below the object's symbol. Click and drag this handle to draw an Electrical Connection spline between the selected 
object and another electrical object. See Creating Wiring Schematics on page 489.

 l Wall mounted electrical objects cannot be rotated in plan view, so only the Move edit handle displays.
 l Electrical objects placed on floors and ceilings can be rotated in plan view.
 l In 3D views, some ceiling mounted and free-standing light fixtures can be resized.
 l  Electrical connections  are edited like splines. See Editing Spline-Based Objects on page 162.

 l When set to display in plan view, each electrical label has a small square Move edit handle.

IN THE SPECIFICATION DIALOGS

Electrical objects can be edited in the Electrical Service Specification dialog. See Symbol Object Specification 
Dialogs on page 723.

USING THE EDIT TOOLS

A selected electrical symbol can be edited in a variety of ways using the buttons on the Edit Toolbar. See The Edit Toolbar 
on page 92.

  Change to GFCI Outlet changes a selected 110V Outlet to a GFCI Outlet, as specified in the Electrical Defaults 
dialog.

  Change to 110V Outlet changes a selected GFCI Outlet to a 110V Outlet.

  Turn Light(s) On in 3D toggles a selected light on so that it emits light in 3D views while Turn Light(s) 
Off in 3D toggles it off. See Displaying Lights on page 820.

USING DIMENSIONS

Electrical objects can be moved precisely using dimensions. See Moving Objects Using Dimensions on page 341.

By default, electrical objects are not located by dimension lines as the lines are drawn. Once created, though, you can edit a 
dimension line’s extensions to locate the center of any electrical object. See Editing Extension Lines on page 338.
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In order to locate electrical objects by a dimension line as it is being drawn, first check the box beside Electrical on the 
LOCATE OBJECTS panel of the Dimension Defaults dialog. See Locate Manual Panel on page 325.    

ADJUSTING ELECTRICAL OBJECT HEIGHTS

When a wall- or cabinet-mounted electrical object is placed, its initial height is based on settings in the Electrical Defaults 
dialog. See Placing Electrical Objects on page 488.

Once placed, a wall-mounted electrical object’s height can be edited in  three ways: 

 l Specify the height in the Electrical Service Specification dialog. See Symbol Object Specification Dialogs on page 
723.

 l In 3D views, the position of an electrical object can be adjusted using its edit handles.
 l In any view, use the Transform/Replicate Object  tool. See Transform/Replicate Object Dialog on page 183.           

DELETING ELECTRICAL OBJECTS

An electrical object can be deleted by selecting it and clicking the Delete  edit button or by pressing the Delete key.

All electrical objects in a room, on a floor, or in the entire plan can also be deleted as a group using the Delete Objects 
dialog. See Deleting Objects on page 191.

 

Light Data Panel
The LIGHT DATA panel is available in the specification dialogs for              Light fixture symbols as well as Added Lights. 
Select one or more electrical objects and/or Added Lights and click the Open Object edit button to open the 

Electrical Service Specification, Added Light, or Light Data dialog. See Added Lights on page 818 and Symbol Object 
Specification Dialogs on page 723.

The settings on this panel allow you to control the attributes of the light source(s) associated with the selected object. A 
number of the settings on this panel can also be edited in the Adjust Lights dialog. See Adjust Lights Dialog on page 822.
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Light Sources

Each fixture can have multiple Light Sources, listed here. See Lighting on page 817.         

 l Click on a line item in the table to select it for editing using either the settings in the table or those below. Multiple 
line items can also be selected and edited. See Shift and Ctrl/⌘  Select on page 146.

 l The selected light source's Position Indicator displays in the preview on the right.  

 l Click Add Light, Copy Light, or Delete Light to add or delete light sources from the list. If the selected fixture has 
only one light source, Delete Light will not be available. These options are not available for Added Lights.         

  Light Characteristics

 l Select either Point Light or Spot Light as the light Source Type. The Type determines which options are enabled 
below. See Light Types on page 819.          

 l Select an Intensity from the drop-down list. The available options are described using lumens and correspond to 
commonly used light bulb wattages. You can also use the text box or spin controls to make fine adjustments to the 
Intensity value. When a non-standard value is specified, the Intensity is described as “Custom Lumens”.          

 l Click the Color bar to define the color of the selected light source. Colored lights alter the appearance of textures 
and can be used to achieve special effects. See Select Color Dialog on page 135.          

The default color of light is pure white, which has the least 
effect on the appearance of material colors and textures.

The Angle and Drop Off Rate settings below are only available for Spot Lights.          

 l The Tilt Angle controls the angle of the illumination with respect to the horizon. A value of -90° points the light 
straight down and a value of 90° points it straight up. 0° is parallel to the horizon.         
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 l The Direction Angle defines the direction of the illumination relative to the ground. 0° is measured horizontally 
pointing to the right. Positive values rotate in a counter-clockwise direction from there. Enter a value up to 360°. If 
you enter a negative value, the program adds 360° to it when you click OK or press the Tab key.         

 l The Cut Off Angle controls the angle of the cone of illumination for Spot Lights only. A cone angle of 180° 
creates a spot light that shines in a half sphere on one side of the light source. A small cone angle, for example 
10°, creates a very narrow cone of light.          

 l The Drop Off Rate affects how fast a Spot Light’s intensity drops off from the center of the cone to the outside 
edge. 

A value of 0 produces a cone of light with the same intensity from the center to the outside edge and a sharp 
distinction between lit areas within the cone and unlit areas outside it. As this value is increased, the light intensity 
decreases closer to the edge of the cone and the distinction between lit and unlit areas becomes softer. Only 
available for Spot Lights.

 
Offset

The Offset settings control the location of the selected Light Source relative to the fixture.         

 l From Base controls how far the light source is from the fixture base. The fixture base is determined by the surface 
that it is attached to (i.e. wall, floor, or ceiling).             

 l X Position and Y Position allow you to position the light source relative to the center of the fixture, along the 
floor/ceiling.             

 
Options

Additional Options that affect how the selected light source behaves are available.         

 l Check On to use the light source in camera views, or uncheck it if you prefer that the light source not be used. See 
Lighting on page 817.             

 l Casts Shadows controls whether or not the selected light source casts shadows in camera views. See Shadows on 
page 815.

 l Check Show Position in Camera View to indicate the position of a selected Point or Spot Light source in the 
preview pane and in              3D views              when it is turned On. This tool can be used to determine if your light source is 
positioned correctly. See In 3D Views on page 821.         

 
Preview

A preview of the selected object displays here. The selected light source’s Position in Camera View displays in all views 
except Plan View. See Dialog Preview Panes on page 21.         
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Chapter 19
 

Foundations

There are three foundation types in Home Designer Pro: stem walls with footings, grade beams on piers, and monolithic 
slab. All three can be generated automatically or manually. The foundation type can be specified in the Foundation Defaults 
dialog when the foundation is built on Floor 0. 

There can be only one foundation level in a plan, Floor 0; however, foundation structures can be drawn on any floor using 
the Foundation and Slab Tools.          

Always consult registered geotechnical and civil engineers for 
information regarding the proper foundation for your site. 

TOPICS

Foundation Defaults 497
Foundation Defaults Dialog 498
Building a Foundation 501
Displaying Foundations 502
Editing Foundations 503
Deleting Foundations 505
Foundations and Rooms 506
Foundations and the Terrain 507
The Slab Tools 508
Editing Slabs 509
Slab Specification Dialog 509
Editing Piers and Pads 511
Fireplaces 512
Fireplace Specification Dialog 513
Library Fireplaces 516
Chimneys 516

496



Home Designer Pro 2025 Reference Manual - Foundation Defaults

 

Foundation Defaults
There are several defaults dialogs that affect the foundation. They can be accessed by selecting Edit> Default 
Settings.

 l In the Default Settings dialog, select “Foundation” and click the Edit button to open the Foundation Defaults dialog.
 l Once a foundation has been built, it will have a Floor 0 Defaults dialog. The structural settings in this dialog are 

initially drawn from those in the Foundation Defaults dialog.  See Floor Level Defaults Dialogs on page 518.         
 l The Foundation Wall Defaults dialogs control the default setup of Foundation Walls. See Wall, Railing, and Fencing 

Defaults on page 229.    
 l The default attributes for Slabs and Slabs with Footings can be set in the Slab Defaults dialogs. See The Slab Tools on 

page 508.
 l The default attributes for Post footings can be set in the Framing Defaults dialog. See Framing Defaults Dialog on 

page 636.

AUTOMATIC FOUNDATION TYPES

Home Designer can automatically generate three types of foundation on Floor 0. See Building a Foundation on page 501.

Walls with Footings

The Walls with Footings option can be used to create stem wall and frost wall foundations, crawl spaces, and full 
basements.

A Walls with Footings foundation is defined by walls as specified in the Foundation Wall Defaults dialog and can support 
both framed and concrete floor platforms on the floor above. If Slab at Top of Stem Wall is checked, a concrete slab floor 
will be generated to serve as the floor platform for rooms on Floor 1 and a slab with frost walls is produced. Otherwise, if 
the Basement Ceiling Height of 72" (1800 mm) or greater is specified, a slab floor for the basement is generated 
automatically.

By default, floor platforms bear on top of foundation stem walls. You can instead select Hang Floor Above on Wall in a 
foundation wall's specification dialog. See Structure Panel on page 270.

Monolithic Slab

As the name implies, the Monolithic Slab option produces a single slab defined by Slab Footings on Floor 0 for each 
structure on Floor 1. See Foundation Walls on page 236.

Monolithic Slab room areas are defined by Slab Footing walls and supply the concrete floor platform for all of Floor 1. No 
other floor structure type is supported. 

When a Monolithic Slab foundation is generated, both Monolithic Slab Foundation and Floor Supplied by the 
Foundation Room Below become checked in the Floor 1 Defaults dialog, as well as in the Room Specification dialog for 
all rooms on Floor 1. These boxes will become unchecked automatically if you later generate a different foundation type.

Regardless of what foundation type is generated, you can specify that an individual room on Floor 1 receives a Monolithic 
Slab Foundation in its specification dialog. See Structure Panel on page 310.

Grade Beams on Piers

The Grade Beams on Piers option produces foundation walls as specified in the Foundation Wall Defaults dialog, only 
without footings. These walls also receive regularly spaced Round Piers or Square Pads, again, as specified in the 
Foundation Wall Defaults dialog. See Editing Piers and Pads on page 511.
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Grade Beams on Pier foundations can support crawl spaces and basements, as well as framed and concrete floor platforms 
on the floor above.

 

Foundation Defaults Dialog
The Foundation Defaults dialog allows you to specify stem wall height, slab thickness, sill plates, and other  
characteristics of an automatically-generated foundation. These values determine how a new foundation is generated 

as well as the sizes for manually drawn foundation walls added to an existing foundation. Select Edit> Default Settings, 
and in the Default Settings dialog, select "Foundation" and click the Edit button.

The settings in the Foundation Defaults dialog are similar to those in the Build Foundation dialog, which opens when 
Build> Floor> Build Foundation  is selected. The primary difference is that when you click OK in the Foundation 

Defaults dialog, no changes are made to the model. See Building a Foundation on page 501.

FOUNDATION PANEL

 
Automatically Rebuild Foundation

Check Auto Rebuild Foundation to automatically rebuild the foundation whenever changes are made to Floor 1 that affect 
the structure of the foundation. See Rebuilding Foundations on page 503.

 
Foundation Type

Three different Foundation Types can be created in Home Designer Pro. Each type of foundation has different default 
settings, options, and behaviors. Select the radio button next to the desired type.         
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 l Select Walls with Footings to produce a foundation composed of stem walls with footings that run continuously 
under the base of the walls.         

 l Select Grade Beams on Piers to generate a pier and grade beam foundation. The floor framing rests directly on top 
of the grade beams.         

 l Select Monolithic Slab to build a slab foundation defined by slab footings. The foundation forms the floor platform 
for Floor 1. It is visible on Floor 0 and can be selected and edited.

 l Check Hang 1st Floor Platform Inside Foundation Walls to produce stem walls that build up to the top of the 
floor platform of Floor 1. When unchecked, the stem walls build to the bottom of the floor platform, which bears on 
top of them. Only available when Walls with Footings is selected, above.         

 l Check Show “S” Markers on Step Foundation to include an “S” symbol in plan view anywhere there is a step in 
foundation wall height. Not available when Grade Beams on Piers is selected, above. See Displaying Foundations on 
page 502.

  Slab

 l Specify the Slab Thickness, which is the thickness of the slab produced above the footing or at the top of the stem 
wall.         

 l Check Slab at top of Stem Wall to raise the slab so its top is flush with the top of the stem walls. Only available 
when Walls with Footings is the selected Foundation Type.
If Slab at top of Stem Wall is selected, all rooms on the first floor are automatically set to Floor Supplied by the 
Foundation Room Below in the Room Specification dialog. See Structure Panel on page 310.

  Stem Walls

 l The name of the Default Foundation Wall Type displays here for reference.         

 l Click the Edit Default Foundation Wall button to open the Foundation Wall Defaults dialog and change the default 
settings for foundation walls. See Foundation Walls on page 236.

 l If Monolithic Slab is the selected Foundation Type, the Edit Garage Curb button will be available. Click it to open 
the Foundation Wall Defaults dialog and define the walls that form curbs around Garage and Slab rooms.         

 l Specify the Minimum Height, which is the minimum height for foundation stem walls and grade beams and 
includes the sill plates.         

 l The Basement Ceiling Height displays here as a reference. This is the distance from the top of the slab floor to the 
basement ceiling and is equal to the Minimum Wall Height minus the Slab Thickness. 

If the Minimum Wall Height is at least 76” (1900 mm), a Ceiling Finish is added to the foundation room 
automatically. A slab floor is also generated above the footing. The ceiling height and finish can be changed later. 
To remove this slab, specify the room areas in the basement as “Open Below”. See Room Specification Dialog on 
page 308.

 
Piers

These settings are only available when Grade Beams on Piers is the selected Foundation Type.         

 l Specify the Width, Depth, and Maximum Separation of the piers.         

 l Choose either Round or Square piers.         

 
Garage Options

These settings only apply to rooms defined as Garages. See Garages on page 506.                 
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 l Specify the Garage Floor to Stem Wall Top, which is the distance between the slab and the tops of the stem walls 
in both Garage and Slab rooms. Available for Walls with Footings and Grade Beams on Piers foundation types. See 
Foundation Defaults on page 497.

Note: The Garage Floor to Stem Wall Top setting only affects 
Garage rooms that have a Floor Height of 0. See Structure Panel on 
page 310. 

 l Specify the Lower Garage Floor height, which is the distance that Garage and Slab room floors are lowered when a 
Monolithic Slab foundation is  built. This value is also the height of the curbs around these rooms. 

 l Specify the Minimum Garage Height, which is the minimum height that stem walls defining a Garage foundation 
will be, regardless of the Minimum Stem Wall Height for the rest of the foundation.         

OPTIONS PANEL

The OPTIONS panel allows you to include rebar and other materials related to the foundation in the Materials List. See 
Materials Lists on page 950.

Some options on this panel may be unavailable depending on the foundation type selected on the FOUNDATION panel.         

 
Rebar

Specify the Rebar used in the major foundation components: Footing, Wall Horizontal courses, Wall Vertical courses, 
Pier, and Slab. Rebar and mesh are calculated in the Materials List provided that the wall or footing they are associated 
with is the “Concrete” Structure Type; but, they do not display in any 2D or 3D views of the model. See The Materials List 
Tools on page 951.

 l Bars per Course - Specify the number of bars of rebar to be used per course for each foundation component.         

 l Course Spacing - Define the spacing for Vertical and Horizontal Wall courses, and for Slabs. If slabs are to have 
rebar instead of mesh, this spacing value applies to both directions.         

 l Rebar size - Define the rebar size in 1/8th inches. 4 represents 4/8, or 1/2 inch.         

 l Specify the Overlap where sticks of rebar meet, in terms of the rebar’s Diameter. A value of 40.0, for example, 
equals 40 times the Rebar Size.         

 l Check Use Mesh to reinforce the slab floor with mesh instead of rebar, or uncheck it to use rebar.         
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Foundation Options

Select either Foam Seal, Termite Flashing, or both. These options are added to the Materials List, but do not display in the 
model.         

 

Building a Foundation
Foundations can be generated automatically or drawn manually. A combination of the two methods can also be used.         

Three foundation types are available: stem walls with footings, grade beams on piers, and monolithic slabs. See Automatic 
Foundation Types on page 497.

Automatically built foundations are placed on Floor 0 and are based on wall positions and floor heights on Floor 1. 
Foundation walls or slab footings are generated under:

 l All exterior walls on Floor 1 that define a room that has Build Foundation Below specified. In order to automatically 
receive a foundation wall below, Exterior walls cannot be Railings or Invisible. See Room Definition on page 287.

 l Any interior walls on Floor 1 defining rooms with different floor heights. See Floor and Ceiling Heights on page 301. 

At least one room that has Build Foundation Below specified must be defined by visible, non-railing walls on Floor 1 for a 
foundation to be automatically generated. If no rooms are defined on Floor 1, a blank Floor 0 is created. 

There can be only one Floor 0 per plan. If your plan requires a foundation on more than one floor, you will need to draw the 
required foundation walls or slabs yourself.         

To build an automatic foundation

 1.  Specify the desired floor heights for the rooms on Floor 1: particularly Porch and Garage rooms.

 2.  Select Build> Floor> Build Foundation . 

 3.  Specify the desired foundation type and other information in the Build Foundation dialog and click OK. The settings 
in this dialog are similar to those in the Foundation Defaults dialog. See Foundation Defaults Dialog on page 498.

 l To rebuild the foundation using these settings any time changes are made to the structure on Floor 1, check the 
box beside Automatically Rebuild Foundation.

 4.  In the New Floor dialog, select Derive new Foundation plan from the 1st floor plan and click OK to build a 
foundation based on Floor 1.

If you prefer, you can instead select Make new (blank) plan for the Foundation to create an empty foundation level where 
you can manually draw foundation walls or slabs.

In most cases, it is preferable to base Floor 0 off the first floor plan and then manually edit the foundation as needed. See 
Editing Foundations on page 503.

FOUNDATION WALL ALIGNMENT

By default, foundation walls and slab footings will align with walls on the floor above along the outside surface of the Main 
Layer of both wall types.     See Aligning Walls on page 255.

MIXING FOUNDATION TYPES

You can also create a foundation that combines stem walls, grade beams and piers, and/or monolithic slabs.
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To create a foundation of multiple types

 1.  Begin by specifying any rooms on Floor 1 that require a slab floor as either a Garage or Slab Room Type. See 
Foundations and Rooms on page 506.

 2.  Alternatively, or in addition, you can specify any rooms on Floor 1 as having a Monolithic Slab Foundation. See 
Structure Panel on page 310.          

 3.  Build Foundation , as described above.   

 l If the foundation will include any grade beams and piers, specify Grade Beams on Piers as the Foundation 
Type and build the foundation.          

 l If the foundation will include a combination of stem walls and slabs, specify Walls with Footings as the 
Foundation Type.          

 4.  Once the foundation walls have been generated, they can be moved or deleted, and new Foundation Walls  

and/or Slabs  can be drawn. See Foundation Walls on page 236 and The Slab Tools on page 508.         

OPENINGS IN FOUNDATION WALLS

Any doors placed in walls around a Garage will receive cutouts in the garage stem wall or curb. The width of that cutout 
can be specified in the Door Specification dialog. See General Panel on page 393.          

 

Displaying Foundations
The objects associated with foundations can be displayed in a variety of ways in Home Designer.

FOUNDATION LAYERS

The display of foundation walls, slabs, curbs, piers and footings is controlled in the  Layer Display Options dialog. 
See Layer Display Options Dialog on page 127. 

 l Foundation Walls, including grade beams, slab footings and Garage curbs, are placed on the “Walls, Foundation” 
layer.

 l Footings under slab footings and Foundation Walls are placed on the “Footings” layer, as are foundation piers. 
 l Post footings and deck post footings are placed on the “Footings, Post” and “Footings, Deck Post” layers.
 l Slabs created using the Slab Tools  are placed on the “Slabs, Custom” layer.         

 l Wall labels and slab labels are placed on the “Walls, Labels” and “Polylines 3D, Labels” layers, respectively.          
 l In stem wall and grade beam foundations, brick ledge lines in plan view are on the “Slabs” layer; in monolithic slab 

foundations, they are on the “Walls, Foundation” layer. See Brick Ledges on page 237.
 l The “Foundations” layer controls the display of all objects on Floor 0 in 3D views but does not affect plan view. 

IN PLAN VIEW

The appearance of foundation wall types, including line weights, colors and fill styles, is specified in the Wall Type 
Definitions dialog. See Wall Type Definitions Dialog on page 264.         
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Changes in stem wall and monolithic slab foundation heights are represented in plan view with S markers. These markers 
are located on the “Footings, Step Markers” layer and use the Text Style assigned to that layer. See Stepped Foundations on 
page 508.          

If a door on Floor 1 extends into a stem wall or curb defining a Garage room, its location will be indicated on Floor 0. See 
Displaying Doors on page 382.

IN 3D VIEWS

In 3D views, all objects on Floor 0 will only display when the “Foundation” layer is turned on. 

While the display of foundation walls and their footings can be controlled independent of one another in plan view, in 3D 
views this is not the case. If a foundation wall is set to display, its footing will as well - even if the “Footings” layer is 
turned off. The reverse is also true - if a foundation wall’s display is turned off, so will its footing’s.

The display of monolithic slab foundations in 3D views is controlled by the “Foundation” layer. Slab footings are located on 
the “Walls, Foundation” layer; but if this layer is turned off, any slab footings that define a foundation room will continue to 
display as long as the “Foundation” layer is on. 

IN THE MATERIALS LIST

The materials that make up foundation walls, footings, and slab floors are listed under the Foundation category in the 
Materials List, including:          

 l Concrete for walls, slabs, and footings
 l Rebar for walls and footings
 l Rebar or mesh for slabs

Other objects relevant to foundations can be found in these categories:          

 l Exterior Trim - Lists slabs drawn with the Slab  tools that are located outside a structure.          

 l Interior Trim - Lists slabs drawn with the Slab  tools that are located inside a structure.          

See Materials Lists on page 950.           

 

Editing Foundations
Stem wall with footings, wall with piers and monolithic slab foundations are all created using walls which enclose room 
areas.

 l Foundation walls can be selected and edited much like other walls. See Editing Walls on page 251.
 l Footing size can be changed on a wall by wall basis. See Editing Foundations on page 503.           
 l Foundation rooms can also be selected and edited like other rooms. See Foundations and Rooms on page 506.

REBUILDING FOUNDATIONS

By default, foundations update automatically when changes are made to the structure on Floor 1. For example, if exterior 
walls are moved or floor platforms are raised or lowered, the foundation will be rebuilt.
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You can direct the program to rebuild an automatically generated foundation whenever changes are made on Floor 1 that 
affect the foundation by checking Auto Rebuild Foundation in the Foundation Defaults dialog. See Foundation Defaults 
on page 497.          

You can also rebuild an automatically generated foundation by selecting Build> Floor> Build Foundation  from the 

menu. 

When Auto Rebuild Foundation is enabled, walls cannot be edited, manually drawn or deleted on Floor 0. When the 
foundation is rebuilt, any manually drawn or edited walls are deleted. Similarly, rooms on Floor 0 cannot be edited while 
this option is enabled. If you try to draw a wall or edit a room or a wall while Auto Rebuild Foundation is turned on, a 
warning message will display.         

CHANGING FOUNDATION TYPES

When a foundation is generated, the program creates Floor Defaults settings for Floor 0 based on the information in the 
Build Foundation dialog. If you specify a Monolithic Slab foundation, the default Floor Structure on Floor 1 will also be 
changed to a slab rather than a framed platform. See Floor Level Defaults Dialogs on page 518.   

 

To avoid unexpected results, it is recommended that you not 
change the Foundation Type once the foundation is built.

STEM WALL HEIGHT

When a foundation is created, all of Floor 0 uses the stem wall height specified in the Foundation Defaults dialog, 

This height is measured from the bottom of floor platform of Floor 1 to top of the stem walls’ footings. If Floor 1 has 
multiple floor platform heights, the foundation stem walls will be stepped.

Once a foundation is created, stem wall heights can be adjusted either on a room-by-room basis or for individual walls.

To change a room’s stem wall height

 1.  Select a room on Floor 0 and click the Open Object  edit button. 

 2.  Specify the desired Stem Wall Height in the Room Specification dialog. See General Panel on page 308.

 3.  If you wish to reduce the Stem Wall Height, you will first need to reduce the Ceiling Height value by the same 
amount. 

If adjacent rooms have stem wall heights that differ by at least 1/16 of an inch, the stem wall separating them uses the larger 
of these two values.

In 3D views, individual stem walls can be selected and edited. In most cases, this method should only be used for stepping 
the bottom of the foundation wall. See Stepped Walls and Footings on page 260.           
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FOOTING WIDTH AND HEIGHT

Foundation Wall footings derive their Width and Height from in the Foundation Wall Defaults dialog, Once a Foundation 
Wall is created, its footing can be adjusted in its specification dialog. See Foundation Panel on page 275.

Stem wall footing heights can also be edited in 3D views just as the rest of the stem wall can. Slab               footing heights, on the 
other hand, cannot be adjusted in 3D. See Stepped and Raked Walls on page 260.

You can specify whether stepped stem walls have vertical footings on the FOUNDATION panel of the Foundation Wall 
Defaults and Specification dialogs.               

INTERIOR FOOTINGS

Slab foundations often have interior footings: to support posts, for example. Home Designer does not generate interior 
footings automatically, but you can easily draw them using the Slab   tool. See The Slab Tools on page 508.

To create an interior footing

 1.  Select Build> Slab> Slab , then click and drag to draw a slab on Floor 0. This slab will serve as a footing.

 2.  Select the slab and click the Open Object  edit button.

 3.  In the Slab Specification dialog, specify the desired Height and Thickness. See General Panel on page 510.

 l The Height should be set so that it meets the bottom surface of the monolithic slab above.

 4.  Use the edit handles, dimensions and/or the Reference Display to position the slab at the desired location. 

 

Deleting Foundations
Select Build> Floor> Delete Foundation to delete the entire foundation floor. 

You can also select and delete individual foundation walls and slabs by clicking the Delete  edit button or pressing the 

Delete key. See Deleting Objects on page 191.

Deleting and rebuilding the foundation is often the quickest way to update the model when substantial changes are made to 
Floor 1 after the foundation is built.
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Foundations and Rooms
When a foundation plan is created, rooms included in the Living Area calculation generate a stem wall, grade beam, or slab 
foundation below them. Garage rooms generate slab foundations, but exterior rooms such as Decks, Courts and Balconies 
do not generate any foundation. See Room Types on page 289. 

Interior foundation walls are not generated unless:

 l They separate the area under a Slab or Garage room from the rest of the plan;
 l They separate the area under a room specified as having a slab foundation from the rest of the plan;         
 l They define areas under rooms with different floor heights.

Note: To remove all or part of the concrete slab in the basement area, 
select a basement room and define it as Open Below in the Room 
Specification dialog.

GARAGES

When a foundation is generated based on the floor plan of Floor 1, a room on the first floor specified as either a Garage or 
Slab type will receive a stem wall or pier foundation with a slab floor and stem walls. If a monolithic slab foundation is 
generated, the room will receive a slab floor with curbs.

An opening placed in a wall defining a Garage will receive a cutout in the stem wall or curb that displays in plan view on 
the floor below provided that the stem wall or curb’s Main Layer has a Concrete or Brick material type.           

The width of the concrete cutout can be defined and you can specify whether the cutout displays in the Door or Window 
Specification dialog. See Rough Opening Panel on page 405.           

By default, a room on Floor 1 specified as a Garage or a Slab will be assigned a lower floor height when the foundation is 
built. The amount that it is lowered depends on the foundation type:

 l The floor height will drop the default thickness of the floor platform for Floor 1 plus 12” (300 mm) in a Walls with 
Footings or Grade Beams on Piers foundation.

 l The floor height will drop 3 1/2” (88 mm) in a Monolithic Slab foundation. 

These values are set in the Foundation Defaults dialog. See Foundation Defaults on page 497.           

To build a Garage slab with stem walls

 1.  Before the foundation is generated, specify the room as a Garage or Slab. 

 2.  Build an automatic Wall with Footings or Grade Beam on Piers foundation.

In the Floor 1 Garage’s Room Specification dialog, Floor Supplied by the Foundation Room Below will now be checked. 
See Structure Panel on page 310.          

By default, the program produces a  4" (100 mm) slab and 24” (600 mm) high stem walls around the garage. These stem 
walls are drawn on Floor 0 and will indicate the locations of any doors that extend into them.           

To build a Garage slab with curbs

 1.  Before the foundation is generated, specify the room as a Garage or Slab. 

 2.  Build an automatic Monolithic Slab foundation, specifying the required Lower Garage Floor value.
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By default, the program produces a  4" (100 mm) slab and 3 1/2” (88 mm) high curb around the garage. The curbs are drawn 
on Floor 0, use the Default Foundation Wall type, and will indicate the locations of any doors that extend into them.         

The floor height of the garage and the stem wall or curb height can then be adjusted, if necessary, in the Garage room’s 
Room Specification dialog. See Structure Panel on page 310.         

BASEMENT ROOMS

When a foundation’s type is Walls with Footings or Grade Beams on Piers, and it is assigned a Basement Ceiling Height of 
48" (1200 mm) or greater, the resulting basement is automatically included in the Living Area calculation. It does not, 
however, have a floor or ceiling finish.

When a foundation is assigned a Basement Ceiling Height of 72" (1800 mm) or greater, the resulting basement is 
automatically created with a 4” (100 mm) concrete slab floor and a default Floor Finish like that on Floor 1. Similarly, it is 
automatically given a painted drywall Ceiling Finish. See  Foundation Defaults on page 497.   

Regardless of its ceiling height, however, you can specify a floor or ceiling finish for any room in the Room Specification 
dialog. See Structure Panel on page 310.

The resulting basement can be divided into separate rooms using Interior Walls  or any wall type you wish. If the rooms 

in a basement have different floor heights, it is best to separate them using walls specified as Foundation Walls .

 

Foundations and the Terrain
Home Designer automatically raises the structure in a plan a set distance above the terrain. See Terrain Height vs Floor 
Height on page 892.         

In a plan with a foundation present, the terrain will be:          

 l 6” (187 mm) below the top of the stem walls or grade beams in a Walls with Footings or Grade Beams on Piers 
foundation.    

 l 8” (200 mm) below the top of the slab in a Monolithic Slab foundation.             

By default, the program will also create a flattened pad under the building footprint.         

Not all foundations have these requirements, of course, so you can customize your foundation and terrain to suit your needs.
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DAYLIGHT BASEMENTS

Daylight basements, also referred to as look-out basements, have walls that are tall enough for basement windows to be 
positioned above the terrain. They are often found in split level or split entry structures.         

To create a daylight basement condition,  build a stem wall foundation and modify these settings in the Terrain Specification 
dialog:          

 l Uncheck Auto Calculate Elevation.             
 l Increase the Building Pad Elevation, which is the distance between the default floor height of Floor 1 and the terrain.              

WALKOUT BASEMENTS

Walkout basements are a type of daylight basement typically located on sloped terrain. They feature walls that are above 
ground at the lower end of the slope so that a door can be positioned above the terrain at that end.          

To create a walkout basement, build a stem wall foundation and modify these settings in the Terrain Specification dialog:          

 l Uncheck Flatten Pad.             
 l Uncheck Auto Calculate Elevation.             

You will also need to create sloped terrain and adjust the Building Pad Elevation and/or terrain data so that the terrain is at 
the appropriate height relative to the structure at both the high and low ends of the slope.         

STEPPED FOUNDATIONS

Stepped foundations are usually built on sloping terrain. A stepped foundation will be produced automatically if more than 
one floor height is present on Floor 1 when the foundation is built. 

In plan view, steps in stem wall and monolithic slab foundations are represented using S markers. See Displaying 
Foundations on page 502.          

As with a walkout basement, you will need to build a stem wall foundation and modify these settings in the Terrain 
Specification dialog:          

 l Uncheck Flatten Pad.             
 l Uncheck Auto Calculate Elevation.             

You will also need to create sloped terrain and adjust the Building Pad Elevation and/or terrain data so that the terrain is at 
the appropriate height relative to the structure at both the high and low ends of the slope.         

You can also create a stepped foundation by editing foundation rooms and walls. See Stem Wall Height on page 504.

 

The Slab Tools
Select Build> Slab to access the Slab Tools.         

SLABS

Select Build> Slab> Slab or Slab With Footing, then either click or click and drag a rectangle to draw a slab. 
The Slab Tools are intended for generic purposes than foundations and should not be substituted for a 

foundation plan. See Rectangular Polyline on page 221.         
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A newly drawn Slab or Slab With Footing inherits the settings in the Slab Defaults or Slab with Footing Defaults dialog. 
Once created, slabs can be edited like other closed polylines. See Editing Slabs on page 509.         

A slab is also created when the Post with Footing  tool is used. See Post with Footing on page 634.         

PIERS AND PADS

Piers and pads can be manually placed under walls, railings, or beams on any floor. Select Build> Slab> 
Round Pier or Build> Slab> Square Pad and click in plan view to place a pier or pad.         

For information about editing Round Piers and Square Pads, see Editing Piers and Pads on page 511.         

EDITING SLABS AND PIERS/PADS

Once created, slabs can be selected in 2D and 3D views both individually and as a group and can be edited using the edit 
handles, the Edit Toolbar, and the Slab Specification dialog. See Slab Specification Dialog on page 509.   

Slabs can be edited like other closed-polyline base objects in both 2D and 3D views. See Editing Closed Polyline-Based 
Objects on page 157.   

USING THE EDIT TOOLS

One or more selected Slabs can be edited in a variety of ways using the buttons on the Edit Toolbar. As with most objects, 
Slabs can be copied, replicated, moved, deleted, etc. See The Edit Toolbar on page 92.   

SLABS AND THE MATERIALS LIST

If a slab's material type is specified as Concrete or Volume, the materials list  calculates the total volume of the slab and all 
footings. See Define Material Dialog on page 760.         

 

Editing Slabs
Slabs can be selected in 2D and 3D views both individually and as a group and can be edited using the edit handles, the Edit 
Toolbar, and the Slab Specification dialog. See Slab Specification Dialog on page 509.         

USING THE EDIT HANDLES

Slabs can be edited like other closed-polyline base objects in both 2D and 3D views. See Editing Closed Polyline-Based 
Objects on page 157.         

USING THE EDIT TOOLS

One or more selected Slabs can be edited in a variety of ways using the buttons on the Edit Toolbar. As with most objects, 
Slabs can be copied, replicated, moved, deleted, etc. See The Edit Toolbar on page 92. 

 

Slab Specification Dialog
Select one or more Slabs and click the Open Object edit button to open the Slab Specification dialog.
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The options in this dialog are similar to those in the Slab Defaults and Slab with Footing Defaults dialogs, but affect the 
selected slab(s) only.

GENERAL PANEL

 
Slab

Specify the characteristics of the selected Slab.         

 l Specify the Thickness, which is the measurement from the slab’s top to bottom surfaces.             

 l Select the Elevation Reference, from the drop-down list. This determines where the next two settings are measured 
from and also affects their setting labels. See Elevation References on page 20.    

 o Specify the slab’s height to Top, which is of its top surface measured from the selected Elevation Reference. 

 o Specify the slab’s height to Bottom, which is the height of its bottom surface, measured from the Elevation 
Reference. 

 l When the selected slab is a Post Footing or Deck Post Footing, specify whether it is Square or Round. Not 
available for manually drawn slabs or if the slab’s shape has been modified using the Change Line/Arc  edit 

tool. See Post with Footing on page 634.             

 
Footing

Specify the characteristics of the selected slab’s Footing. Not available in the Slab Defaults dialog.

 l Check Has Footing if you would like the slab to have a footing around the inside of its perimeter.    

 l Specify the Height and Width for the footing.    

 l Specify the Footing Offset, which is the distance that the footing extends out past the edges of the slab. A value of 0 
aligns the outside of the footing with the outside of the slab. 

 
Preview

A preview of the selected slab displays on the right side of the panel. See Dialog Preview Panes on page 21.         

POLYLINE PANEL

The POLYLINE panel states the length of the selected slab’s Perimeter, its enclosed Area, and its Volume See Polyline 
Panel on page 219.         
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SELECTED LINE PANEL

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. For information about the 
settings on this panel, see Polyline Specification Dialog on page 219.         

SELECTED ARC PANEL

The SELECTED ARC panel is available when the selected edge is an arc as opposed to a line. See Change Line/Arc on page 
176.         

LINE STYLE PANEL

For information about the settings on this panel, see Line Style Panel on page 209.         

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the selected slab’s appearance in plan view. For information about these 
settings, see Fill Style Panel and Dialogs on page 132.         

MATERIALS PANEL

For information about the settings on this panel, see Materials Panel on page 750.         

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 967.         

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in the materials list. For more information, see 
Object Information Panel on page 968.   

 

Editing Piers and Pads
Round Piers and Square Pads can be selected individually and in groups in 2D and 3D views  and edited using their edit 
handles and edit toolbars. 

There are several ways to move piers and pads; however, they must always be positioned under a wall. A pier or pad can 
only be moved away from the wall it is placed beneath if it is moved to another wall.

USING THE MOUSE

In plan view, piers and pads can be edited like CAD lines. Three edit handles allow the pier or pad to be resized and moved 
along the wall it is placed beneath. See Editing Line-Based Objects on page 146. 

In 3D views, piers and pads can be edited like CAD boxes. See Editing Box-Based Objects on page 160. 

USING DIMENSIONS

In plan view, piers and pads can also be moved using dimensions. See Moving Objects Using Dimensions on page 341.
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If you move a foundation wall or beam, any piers or pads it 
contains will move with it.

USING THE EDIT TOOLS

A selected pier or pad can be edited in a variety of ways using the buttons on the Edit Toolbar. As with most objects, piers 
and pads can be replicated, moved, and deleted. See The Edit Toolbar on page 92. 

 

Fireplaces
A selection of freestanding fireplace symbols is available in the Architectural Core Catalog. See The Library on page 
691.    

A masonry fireplace can be placed in or away from a wall by selecting the legacy Fireplace tool and then clicking in 
the drawing area.         

 l If created in a wall, it is considered a wall opening and can be moved or resized like a window or door.           
 l If created away from a wall, it moves and resizes similar to a cabinet.         

The legacy Fireplace  tool can be added to the toolbars. See Adding and Removing Buttons on page 93.          

The display of fireplaces is controlled in the Layer Display Options dialog. See Layer Display Options Dialog on page 127.          

Fireplaces can be edited, moved, resized, and deleted similar other objects. See Editing Objects on page 137.          

BUILT INTO A WALL

Flush and Mantle fireplace symbols are available in different styles in the Library Browser and can be positioned against a 
wall to create the front face of a built-in fireplace. For information about adding a chimney, see Chimneys on page 516.

To place a masonry fireplace in a wall, click the Fireplace  button, then click on a wall. A fireplace is created with the 

outside of the fireplace flush with the outside of the wall.          

Fireplaces cannot be placed in a wall specified as Invisible or if the wall in question is on a locked layer. See Locking 
Layers on page 126. 

A selected masonry fireplace inserted into a wall has four edit handles, all located along the wall.          

Click the diamond-shaped Depth handle and drag toward the outside of the wall. The fireplace will stop when the firebox 
front is flush with the inside edge of the wall.          
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In 3D views, fireplaces placed in walls have five edit handles: a Resize handle along each edge and a Move handle at the 
center.           

Fireplaces always face the interior when placed on an exterior wall. When placing a fireplace in an interior wall, click on the 
edge of the wall that you want the fireplace to face. The fireplace is created with the firebox on the same side as the wall 
edge you clicked on to create it.           

FREESTANDING FIREPLACES

A selection of freestanding metal and adobe fireplace unit symbols is available in the Library Browser.

To place a free-standing masonry fireplace, click the Fireplace  button, then click in an open area away from a wall.    

Both fireplace symbols and freestanding legacy masonry fireplace objects have ten edit handles when selected and may be 
rotated, resized, or moved in any direction, similar to the way CAD boxes can. See Editing Box-Based Objects on page 160.    

Free-standing fireplaces can be selected and replaced with a symbol from the library by clicking the Replace From Library 
 edit button. See    Replace From Library on page 717.     

MASONRY FIREPLACE FOUNDATIONS

When a Walls with Footings or Grade Beams on Piers foundation is built, a fireplace foundation will be generated under 
any Fireplaces  present on Floor 1. See Building a Foundation on page 501.           

Fireplace foundations are the same material type as the original fireplace, but do not have a firebox or a hearth. Fireplace 
foundations can be edited or deleted as needed. A firebox and hearth can be added in the Fireplace Specification dialog. See 
Fireplace Specification Dialog on page 513.          

 

Fireplace Specification Dialog
Select a legacy Fireplace and click the Open Object edit button to display the Fireplace Specification dialog. 
Multiple fireplaces can be group-selected, but all objects in selection group must be either placed in a wall or free-

standing. 
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GENERAL PANEL

  Size and Position

 l Specify the Height, Width, and Depth of the fireplace.          

 l Specify the Hearth Depth. This is measured from the front of the fireplace out into the room. To eliminate the 
hearth altogether, enter a zero for this value.          

 l Specify the Hearth Height, relative to the floor in the room that the fireplace faces.          

 l Select the Elevation Reference from the drop-down list. This determines where the next two settings are measured 
from and also affects their setting labels. See Elevation References on page 20.         

 o Specify the height to Top, measured from the selected Elevation Reference.           

 o Specify the height to Bottom, measured from the selected Elevation Reference.          

 
Plan Display

Check Suppress Dimensions to turn off the display of the selected fireplace’s width and firebox width dimensions in plan 
view.         

 
Preview

The preview of the fireplace updates as changes are made.
See Dialog Preview Panes on page 21.         
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FIREBOX PANEL

 
No Firebox

Check No Firebox to eliminate the firebox from the fireplace. This is checked by default for a fireplace object generated on 
Floor 0 to serve as a solid matching base for a fireplace on Floor 1.         

  Size

 l Specify the firebox’s Height and Width.          

 l Specify the Depth of the firebox.          

  Offset

 l Enter the offset Distance, which is how far the firebox is offset from the fireplace center. A value of 0 centers the 
firebox in the fireplace.           

 l Offset to Left/Right - Choose to offset the firebox to the left or to the right.           

 
Preview

The preview of the fireplace updates as changes are made. See Dialog Preview Panes on page 21.         

ROUGH OPENING PANEL

The settings on the ROUGH OPENING panel are also found on the panel of the same name in the Door Specification dialog. 
See Rough Opening Panel on page 405.    

MATERIALS PANEL

For information about the settings on this panel, see Materials Panel on page 750.          

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 967.          
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Library Fireplaces
A variety of fireplace symbols are available in the library. Flush fireplaces are designed to snap to wall surfaces. Some 
fireplace symbols can be enclosed by walls or positioned to project through a wall. See Placing Library Objects on page 
714.         

Always check the manufacturer’s product information for the 
framing and clearance requirements of the fireplace unit you 

plan to use, and design your plan accordingly

 

Chimneys
Chimneys can be created using a variety of methods. 

MASONRY FIREPLACE CHIMNEYS

To create a chimney on a masonry fireplace

 1.  Select the fireplace in a 3D view. 

 2.  Ctrl/⌘  + drag the top edge of the chimney upward through all the floors and the roof until it is to the desired height. 
See Unrestricted Movement on page 168.

 3.  When the chimney is approximately the correct height, select the fireplace, click the Open Object  edit button, 

and type in the exact height.

CHIMNEY CHASES AND CAPS

There are two ways to draw a chimney chase: 

 l Place a closed box Geometric Shape or Soffit over the chimney chase, resize it to match, then increase its height either 
in its specification dialog or in a 3D view using the same method as extending a masonry fireplace. 

 l Use walls to define the chimney chase as a room area, making sure these walls are aligned between floors. The 
chimney chase “room” on the uppermost floor should have a much higher ceiling than the other rooms on that floor 
and should also have no ceiling or roof. See Room Specification Dialog on page 308.

A selection of chimney tops is available in the library. In addition, custom chimney caps can be made using  Geometric 
Shapes and/or Soffits. See Other Objects on page 738.
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Chapter 20
 

Multiple Floors

When a new plan file is opened in Home Designer Pro, two floor levels are present: Floor 1 and the Attic Floor. You can 
add more floors whenever you like: up to 5  total. Once created, floors can also be copied and deleted.         

Home Designer also supports special floors for foundations and attics. Only one foundation level and one attic can exist in a 
plan. Foundations are discussed in their own chapter. See Foundations on page 496.         

TOPICS

Floor Level Defaults Dialogs 518
Floor Tools 518
Adding Floors 519
Displaying Floor Levels 520
Exchanging Floors 521
Copying Floors 522
Deleting Floors 522
Rebuilding Walls, Floors and Ceilings 522
Split Levels 523
The Current Floor 524
The Attic Floor 525
The Reference Display 525
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Floor Level Defaults Dialogs
There is a Floor Defaults dialog for each floor level in a plan file aside from the Attic floor. To access these dialogs, 
select Edit> Default Settings. Click the arrow to the left of “Floors and Rooms” to expand the category, then expand 

the “Floor Levels” subcategory. Select              one or more floor levels and click the Edit button to open the Floor Defaults dialog 
for that floor or floors. See Default Settings vs Preferences on page 57.         

 l Floor Defaults can also be accessed by double-clicking the Floor Tools  parent button.             

 l In addition, the Floor Defaults  button can be added to the toolbars. See Toolbar Customization Dialog on page 

96.             

The Floor Level Defaults dialog also opens whenever you add a new floor to the plan. See Adding Floors on page 519.          

The Floor Level Defaults dialog does not open when you build a foundation; however, the Floor 0 Default settings are 
created based on the current Foundation Defaults. See              Foundation Defaults on page 497.          

The settings in each Floor Level Defaults dialog are also found in the Room Specification dialog, but control the default 
settings for all rooms on the floor level in question. The settings here also control the default height of individual walls as 
they are drawn on that floor. See Room Specification Dialog on page 308.          

Note: The default floor height for Floor 1 is 0. It can be modified in the 
Room Specification dialog, but not in the Floor 1 Defaults dialog. See 
Floor and Room Defaults on page 287.

STRUCTURE PANEL

The settings on the STRUCTURE panel are similar to those in the Room Specification dialog. See Structure Panel on page 
310.          

MOLDINGS PANEL

The settings on the MOLDINGS panel are similar to those in the Room Specification dialog. See              Moldings /  Rails Panels on 
page 688.          

FILL STYLE PANEL

The settings on the FILL STYLE panel are similar to those in the specification dialogs for many objects throughout the 
program. See Fill Style Panel and Dialogs on page 132.          

MATERIALS PANEL

The settings on the MATERIALS panel are similar to those in the specification dialogs for many objects throughout the 
program. See Materials Panel on page 750.          

 

Floor Tools
Select Build> Floor to access the following floor tools:        
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  Build New Floor builds a new floor; a new floor can be generated based upon the perimeter of the floor below 
or a blank floor can be created and drawn from scratch. See Adding Floors on page 519.             

  Insert New Floor inserts a new floor below the Current Floor. See Adding Floors on page 519.             

  Delete Current Floor removes the Current Floor from the plan. For more information, see Deleting Floors on 
page 522.             

  Build Foundation opens the Foundation Defaults dialog and build a foundation floor. See Building a 
Foundation on page 501.             

  Delete Foundation removes the foundation from the plan. See Deleting Foundations on page 505.             

  Rebuild Walls/Floors/Ceilings forces Home Designer Pro to recalculate the relationship between the walls, 
floors, and ceilings in your model. See Rebuilding Walls, Floors and Ceilings on page 522.             

 

Adding Floors
When a new plan file is opened in Home Designer Pro, two floor levels are present: Floor 1 and the Attic Floor. You can 
add up to 5 total living floors, as well as create a foundation below Floor 1.         

Floors can be added whenever you like; and once created, they can also be copied and deleted.          

Note: Home Designer allows only one floor, the foundation/basement, 
below Floor 1. See Foundations on page 496. 

BUILD NEW FLOOR

New floors can be created in plan view as well as in 3D views, and are always added above the top living floor. To 
create a new floor, select Build> Floor> Build New Floor.          

 l Derive new 2nd floor plan from the 1st floor plan creates a new top floor with exterior walls generated directly over 
the exterior walls of the floor below. Wall types and roof directives associated with the walls on the floor below are 
duplicated; however, interior walls are not. See Roof Panel on page 272.         

 l Check Move Highest Floor’s Roof Up to move any roof planes displaying on the highest floor in the plan up one 
floor when the new floor is created. Roof planes displaying on floors other than the top floor are unaffected. This 
option is only available if there are roof planes built on the top floor and is not available when Auto Rebuild Roofs is 
enabled. See Build Roof Dialog on page 579.         

When Move highest floor roof up is checked, roof planes on 
the top floor will move even if the “Roof Planes” layer is 

locked and manually edited roof planes are set to be retained. See 
Roof Panel on page 580.
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 l Check Step floor/ceiling elevations to match existing floor to maintain all ceiling heights on the existing floor by 
stepping floor heights on the new floor to match. Ceiling heights on the new floor also become stepped accordingly. 
See Floor and Ceiling Platforms on page 303.          

 l Make new (blank) plan for the # floor creates a new top floor that is blank. This option is typically useful only if 
none of the exterior walls on the new floor will be directly above the exterior walls on the floor below. If you choose 
this method, it may be helpful to turn on the Reference Floor when drawing walls on the new floor. See The Reference 
Display on page 525.         

When you click OK, the Floor Defaults dialog for the newly created floor opens. Make any necessary changes to the floor 
structure, moldings, or materials and click OK. See Floor Level Defaults Dialogs on page 518.         

The new floor becomes the Current Floor in plan view. If, however, the new floor is created in a 3D view, the camera 
remains on its original floor and does not move.          

INSERT NEW FLOOR

A floor level can also be inserted beneath the Current Floor in both plan and 3D views. Begin by going to the floor 
level you would like to insert a floor under to make it the Current Floor, then select Build> Floor> Insert New 

Floor.  See The Current Floor on page 524.         

 l Select Derive new # Floor plan from the # Floor plan to insert a new floor below the Current Floor, with exterior 
walls based on those of the Current Floor.           

 l Check Move Highest Floor’s Roof Up to move any roof planes displaying on the highest floor in the plan up one 
floor when the new floor is created. Roof planes displaying on floors other than the top floor are unaffected. This 
option is only available if there are roof planes built on the top floor and is not available when Auto Rebuild Roofs is 
enabled. See Build Roof Dialog on page 579.          

When Move highest floor roof up is checked, roof planes on 
the top floor will move even if the “Roof Planes” layer is 

locked and manually edited roof planes are set to be retained. See 
Roof Panel on page 580.

 l Check Step floor/ceiling elevations to match existing floor to maintain the floor and ceiling heights on the existing 
floors by stepping floor and ceiling heights on the new floor to match. See Floor and Ceiling Platforms on page 303.           

 l Select Make new (blank) plan to insert a blank floor below the Current Floor.           

ADDING A FOUNDATION

To add a foundation, select Build> Floor> Build Foundation . See Building a Foundation on page 501.         

 

Displaying Floor Levels
Home Designer allows you to view the floor levels in a plan in a variety of ways.
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IN PLAN VIEW

In plan view, only one floor level can be active for editing at a time. This is referred to as the Current Floor. See The 
Current Floor on page 524. 

In addition to the Current Floor, one other floor can be displayed for reference purposes: the Reference Floor. Objects on the 
Current Floor can snap to those on the Reference Floor, helping you align objects. See The Reference Display on page 525.

Floor and ceiling platforms do not display in plan view. When floor and/or ceiling framing is present, its display can be 
turned on; however, other components of floor and ceiling platforms like sheathing, drywall, and finish materials, cannot.          

IN 3D VIEWS

In 3D views, all floor levels in a plan are visible, from the foundation up to the attic. There are two exceptions:

  Orthographic and Perspective Doll House Views, which show the Current Floor, not including its 
ceiling, plus any floors beneath it.

  Wall Elevation views, which show a wall on a single floor, in a single room.             

See 3D View Tools on page 775. 

IN THE MATERIALS LIST

The materials that make up floor and ceiling platform assemblies are listed under different Categories in the Materials List:           

 l Subfloor - Lists floor framing and structural subflooring materials specified in all Floor Structure Definitions in the 
current plan. See Floor and Ceiling Platform Definitions on page 303.          

 l Flooring - Lists flooring and subflooring materials specified in all Floor Finish Definitions in the current plan.          
 l Framing - Lists ceiling framing and any other materials specified in all Ceiling Structure Definitions in the current 

plan.          
 l Wall Board - Lists ceiling finish materials specified in all Ceiling Finish Definitions in the current plan.          
 l Insulation - Floor insulation is calculated for all rooms that have a floor, and ceiling insulation is calculated for all 

rooms that have a ceiling - regardless of the Floor or Ceiling Structure Definition. When a ceiling is not present, 
insulation is calculated for the roof. See Structure Panel on page 310.           

 l Foundation - Lists the concrete and mesh for all Floor Structure Definitions in the current plan with a layer of 
concrete material. See Materials and the Materials List on page 757.          

See Materials Lists on page 950.           

 

Exchanging Floors
Select Build> Floor> Exchange With Floor Above or Exchange With Floor Below to swap the Current 
Floor with the floor above or below.         

The floor that was moved becomes the Current Floor at its new location. You can easily move a floor up or down several 
floors by using either one of these buttons repeatedly.         

521



Home Designer Pro 2025 Reference Manual - Copying Floors

 

Copying Floors
The Edit Area  tools can be used to make copies of entire floors in a plan. See Edit Area Tools on page 186.  You can 

use these tools to:          

 l Make a copy of an existing floor to be pasted onto a new floor.          
 l Make a copy of all existing floors in a plan to be pasted into a different plan.          

You can also copy the information on a floor by pressing Ctrl/⌘  + A (Select All), then using Copy  and Paste Hold 

Position . See Paste Hold Position on page 121.          

COPYING BETWEEN PLANS

While you can copy and paste floors from one plan file to another, this is not always the best approach.           

 l To make a copy of the plan for backup or your records, use Save As  to save the file using a new name. See Saving 

Plan and Layout Files on page 38.          
 l To copy the model into another plan with multiple structures, consider exporting it as a symbol and importing it into 

the new plan. See Symbol Objects on page 720.          

 

Deleting Floors
Select Build> Floor> Delete Current Floor to remove the Current Floor from the plan. If there is a floor above, it 
becomes the Current Floor; if there is no floor below, the floor beneath becomes the Current Floor.

To delete Floor 0, select Build> Floor> Delete Foundation. You can delete the foundation without actually being on 
Floor 0. Floor 0 cannot be deleted while Auto Rebuild Foundation is turned on. See Deleting Foundations on page 

505.         

When a floor is deleted, all objects on that floor are deleted with 
it, including locked roof planes and any other objects on locked 

layers. See Locking Layers on page 126.

 

Rebuilding Walls, Floors and Ceilings
When you make a change to the walls or to the floor or ceiling platforms in your plan, they may not immediately 
resize or move in the 3D model. The program does detect such changes, though, and the next time you generate a 3D 

or section/elevation view, walls,  floors and ceilings are rebuilt.         

By default, walls, floors and ceilings are also rebuilt when an automatic roof is generated. See Build Roof Dialog on page 
579.          

You can direct the program to rebuild walls, floors, and ceilings at any time by selecting Build> Floor> Rebuild 
Walls/Floors/Ceilings .          

If you do not want the program to rebuild walls, floors and ceilings when a 3D view is created, uncheck Auto Rebuild 
Floors and Ceilings in the 3D View Defaults dialog. This may speed up plan view editing for very large plans. When this is 
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unchecked and the structure is not up-to-date, the Rebuild Walls, Floors, Ceilings   icon displays near your mouse 
pointer. See 3D View Defaults Dialog on page 774.           

 

Split Levels
Both split level floor plans and split level entries can be created by controlling the floor and ceiling heights of individual 
rooms in a multiple story structure.         

For more detailed information about both types of structure, visit HomeDesignerSoftware.com.

SPLIT LEVEL FLOOR PLANS

A split level, or tri-level, structure is a building where the floor level in one part of the plan is located approximately 
halfway between the floor and ceiling levels of another part of the plan.         

To create a simple split level plan

 1.  Draw a simple rectangular structure divided into two separate halves by an interior wall.         

 2.  Select one of the rooms and click the Open Object  edit button. See Room Specification Dialog on page 308.         

 3.  Raise the Floor Height then press the Tab key.         

 4.  Restore the Relative Rough Ceiling to the default value, then click OK.         

 5.  Build a stem wall foundation. See Foundations on page 496.         

 l The foundation under the room with the lower floor height will have the specified Min Stem Wall Height.         

 l The foundation under the room with the raised floor will have taller stem walls.         

 l Both can be edited in the Room Specification dialog.         

 6.  If you add a Floor 2, note that the Ceiling Height in the room on Floor 1 will be reset to the default value.         

 l To maintain a stepped condition on multiple floors, return to this room and set the Relative Rough Ceiling back to 
using the default.         

SPLIT LEVEL ENTRIES

A split level entry, or divided entry, is characterized by an entry door that opens onto a landing positioned halfway between 
the basement floor and first floor levels.         
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To create a simple split level entry

 1.  Create a plan file with a full basement at the location of the entry door. See Basement Rooms on page 507.         

 2.  Go to Floor 0 and draw a stair Landing  at the location of the entry. See Landings on page 539.         

 3.  Specify the desired height of the landing. See Stair Landing Specification Dialog on page 569.          

 4.  Draw stairs upward from the basement floor to the landing.         

 5.  Draw a second stair section from the landing upward.         

 6.  Select the stairs and click the Auto Stairwell  edit button. See Creating a Stairwell on page 553.         

Split level entries are often associated with daylight basements. See Daylight Basements on page 508.         

 

The Current Floor
In a given plan view window, only one floor level can be active at any given time. The active floor is referred to as the 
Current Floor, and it is the only floor on which objects can be edited.

If you would like to view two different floor levels side by side, open a second plan view, navigate to the desired floor, and 
then tile the two views. Although both are visible, only one of these view windows is active. See Working in Multiple Views 
on page 105.   

FLOOR UP / FLOOR DOWN

If you are working with more than one floor, you can select Tools> Floor/Reference Display> Up One Floor or Down 
One Floor to switch from one floor to another. 

You can change the Current Floor in floor plan, cross section/elevation and 3D views. The Current Floor displays on the 
Change Floor/Reference  button, which can be found between the Down One Floor and the Up One Floor buttons. 

Floors become available once they have been built. The Attic and foundation levels are also accessible using these tools. 

CHANGE FLOOR / REFERENCE

If there are multiple floors, select Tools> Floor/Reference Display> Change Floor/Reference to open the Change 
Floor/Reference dialog, where you can select both the Current Floor and which floor is used in the Reference Floor, 

as well as control the appearance of the Reference Floor. See The Reference Display on page 525.
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The Attic Floor
Home Designer automatically creates a floor above the top numbered floor level of each plan. This floor is called the 
Attic floor and has only one purpose: to provide a space for automatically generated Attic walls. See Attic Walls on 

page 259.         

In some situations, you may find it necessary to draw one or more walls on the Attic floor; however, even if you enclose an 
area with walls, rooms cannot be created on this floor level. If you wish to create an attic loft or bonus room in your plan, 
you must do so on a numbered floor level.         

Because the Attic floor is not meant to be a living area, a warning message will display if you try to draw walls or other 
objects on this floor level.         

 

The Reference Display
When a model has more than one floor level, it is often helpful to see how they relate to each other in plan view. 
Select Tools> Floor/Reference Display> Reference Display to turn on the display of an additional reference floor 

along with the Current Floor.

Objects     on the Reference Floor cannot be selected or edited.   

If the Reference Floor Display is turned on when a view is printed, it will be included in the printed output. See Displaying 
Objects on page 987.   

If the Reference Floor is on when a plan view is sent to layout, it is always on in that layout view and is not affected if it is 
turned off in the plan. See Keeping Layout Views Current on page 975.   

CHANGE FLOOR / REFERENCE DIALOG

Select Tools> Floor/Reference Display> Change Floor/Reference or click the toolbar button that reports the 
current floor level. See The Current Floor on page 524.

In the Change Floor/Reference dialog, you can specify which floor level is the Current Floor. You can also specify a 
Reference Floor from one or more different plan files, multiple Reference Floors, and Reference Floor layer sets and 
drawing order here, as well.          

When this dialog is accessed from a camera view, only the Current Floor options will be active.   
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Current Floor

The Current Floor is highlighted here. Select another floor from the list to make it the Current Floor instead. 

 
Reference Display

These settings are only available when a plan view is active.            

 l Check Show Reference Floor to turn on the display of the Reference Floor.          

 l Choose the current Reference Floor from the drop-down list. When “Automatic” is selected, the floor level below 
the Current Floor is always used; if there is no floor below, the floor above is used instead.          

 l Click the Define button to open the Layer Display Options dialog and change the settings for the Reference Floor 
Layer Set. See Layer Sets on page 128.
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Chapter 21
 

Stairs, Ramps, and Landings

Staircases can be composed of one or more straight or curved stair sections, ramps, and landings. Stairs and ramps can be 
drawn, selected and edited in 2D and 3D views.

Starter treads can be defined, stair sections can be flared, treads can be wrapped, and curved sections can be turned into 
winders.           

Landings can be created automatically or manually and their shape customized. You can edit an existing landing, or create a 
landing from a closed CAD polyline. Landing heights can be defined or you can let them automatically adjust as needed.          

Stairwells can be created automatically or manually and can be seen in 3D views. 

Local building and fire authorities must be consulted for specific 
stair construction codes and access requirements.

TOPICS

Stair and Ramp Defaults 528
The Stair Tools 528
Anatomy of a Staircase 529
Drawing Stairs and Ramps 530
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Winders 546
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Rooms Below Staircases 554
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Stair Landing Specification Dialog 569
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Stair and Ramp Defaults
The purpose of interior stairs is to provide passage from one floor platform to another, so the attributes that influence floor 
heights - including ceiling heights, floor platform thicknesses, and floor finish materials - also influence the structure of 
stairs. When considering a staircase’s structure, bear in mind that riser height is directly dependent on the distance from one 
floor platform to another. 

When Automatic Heights are used, stairs are built so that they rest on the top of the floor structure of the floor where they 
are drawn, and build up to the top of the floor structure on the floor above. Risers are measured to the floor finish surfaces 
on both floors. See Floor and Ceiling Platform Definitions on page 303.           

Ramps are built in a similar manner: interior ramps bear on the floor structure, and when Automatic Heights are used, the 
top surface of both interior and exterior ramps locates floor finish surfaces.           

 

The Stair Tools
Select Build> Stairs to access the Stair Tools.

DRAW STAIRS

To draw a straight staircase select Build> Stairs> Draw Stairs, then click and drag in floor plan or a 3D view. You 
can also click once to place a staircase that extends from the current floor up to the next floor. See Drawing Stairs 

and Ramps on page 530.

STRAIGHT STAIRS

Select Build> Stairs> Straight Stairs, then click to create stairs between the current floor and the floor above. To 
create stairs between two floor platforms on the current floor, click on the low side, within a few feet of where the 

floor changes height. 

 l If you click on the low side of a floor platform defined by a railing, a doorway will be created in the railing, adjacent 
to the stairs. 

 l If you click on the low side of a floor platform defined by a wall, stairs will be created but a doorway will not.
 l If you click at a location that is not near the edge of a floor platform, a full height staircase will be created.

CURVED STAIRS

Select Build> Stairs> Curve to Left or Curve to Right and click once in plan view to place a curved 
staircase. See Curved Stairs and Ramps on page 531.

L-SHAPED STAIRS

Select Build> Stairs> L-Shaped Stairs, then click to create two equal stair sections that form a 90° corner and are 
connected by a landing. See L- and U-Shaped Stairs on page 532.

U-SHAPED STAIRS

Select Build> Stairs> U-Shaped Stairs, then click to create two stair sections that form a 180° turn and are 
connected by a landing. 
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LANDING

Select Build> Stairs> Landing to draw a landing, which is a platform connecting two or more stair sections. See 
Landings on page 539.

There are two ways to create a landing using this tool:

 l Click once to place a landing measuring 39” (975 mm) on each side.
 l Click and drag to draw a rectangular landing sized as needed. See Polylines on page 218. 

You can also create a landing by converting a CAD polyline. See Convert Polyline on page 182.          

RAMP

Select Build> Stairs> Ramp to draw a sloped ramp. By default, ramps are drawn at a 1:12 slope to a maximum 
height of 30” (760 mm). See Drawing Stairs and Ramps on page 530.

SPIRAL STAIRS

In the Library Browser, browse to Home Designer Core Catalogs> Architectural> Spiral Stairs to access a selection 
of spiral staircase fixtures. Select the object that you want, then click in any view to place it in the plan. See The 

Library on page 691. 

Because spiral staircase symbols are fixture symbols, they do not have an Auto Stairwell edit tool. An opening in the floor 
above a spiral staircase must be created manually. See Creating a Stairwell on page 553. 

 

Anatomy of a Staircase
Stairs as well as ramps are often described in terms of rise and run. Rise is typically between 6" and 8", and the run 
between 10" and 12". In metric plans,  rise is 177 to 190 mm, and the run is about 250 mm. Whenever possible, Home 
Designer will automatically apply reasonable rise and run values that meet most building codes to stairs and ramps as they 
are drawn.

In Home Designer, staircases automatically have a consistent rise and run along their length because this is also a typical 
requirement of most building codes. When this is not desired, however, stairs and ramps can be divided into multiple 
sections subsections. See Stair and Ramp Sections and Subsections on page 536.

STAIRCASE TERMINOLOGY

Balusters - The vertical members that run between the handrail and the treads or bottom rail. 

Bracket - Decorative L-shaped supports on the exposed side of stairs below each tread.

Landing - A platform connecting two or more stair sections.

Newels - The end post of a stair railing located at landings and the beginnings and endings of new stair sections.

Rise - The height of a riser, measured from tread surface to tread surface, Also referred to as Unit Rise. 

Rise Angle - The angle of the staircase or stair section, defined by a line drawn through the back surfaces of its treads.

Riser - The vertical stair member located between the treads. Risers may be solid or open. When open, the front surfaces of 
the stringers are considered the risers. 
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Run - The depth of a tread, measured from riser surface to riser surface. Run does not include the Tread Overhang. Also 
referred to as Unit Run. 

Runner - The carpet that runs down the center of the staircase.

Shoe - The bottom railing, placed on the landing floor, that anchors the balusters at landings. 

Stringer - The inclined support member of a staircase that supports the treads and risers.

Tread - The horizontal member of a stair that the foot is placed on. 

Tread Overhang - The portion of a tread extending past the front surface of the riser and over the tread below. Also 
referred to as Nosing or Nosing Extension, it is not included in the Run or Tread Depth measurements.

Tread Thickness - The vertical depth of the tread material.

Winder - A wedge-shaped stair tread used where curved or angled stairways change direction.

STAIR STRUCTURE AND THE MODEL

By default, stairs locate the height of the floor platform that they are drawn on and seek the next level, which may be the 
floor platform of the floor above or a landing. The stringers locate the subfloor of the floor platforms and maintain 
consistent riser height. If the stairs are long enough to reach the next level at a reasonable rise angle, their tread depth and 
number of treads are automatically calculated to create a staircase with consistent tread and riser dimensions along its entire 
length. 

You can modify this behavior or turn off it off altogether in the Staircase Specification dialog and specify your own rise and 
run values. Bear in mind, though, that if you turn it off, you will need to specify the correct Top and Bottom Heights to 
make sure that the stairs actually meet both floor platforms correctly. See General Panel on page 556.           

 

Drawing Stairs and Ramps
Stairs and ramps can be drawn in floor plan and 3D views but not in cross section/elevation views. There are a few things to 
keep in mind when drawing stairs:

 l Before stairs are created, make sure that the heights for both the lower and upper floors are correctly defined. 
 l Stairs are drawn going UP, so they should be drawn from the lower of the two floors they connect. 
 l By default, stairs adjust their riser and tread dimensions to connect two floor heights if possible. The rise and run are 

calculated so that the steps are consistent in size. 
 l Stairs drawn within 1” (25 mm) of a wall will snap to the outer surface of the wall. 
 l Stairs will snap to the Reference Display , if you have it turned on. See The Reference Display on page 525.

 l Hold down the Ctrl/⌘  key to suppress these snapping behaviors. See Snap Behaviors on page 113.
 l If a stairwell room has been defined on the floor above, the top of the stairs can be dragged until it stops at the railing 

or wall defining the stairwell.
 l When drawing stairs or a ramp up from the terrain, it is a good idea to make sure the terrain is up-to-date. See 

Building the Terrain on page 903.

STRAIGHT STAIRS AND RAMPS

The Draw Stairs  tool can be used in two different ways:
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 l Click and drag in a straight line to draw stairs that are the length that you drag.
 l Click once to place stairs that go from the current floor up to the height of the next floor level.

You can also click once using the Straight Stairs  tool to create stairs between rooms on the same floor with different 

floor heights or between exterior rooms and the terrain. When the Straight Stairs tool is active, a preview outline of the 
stairs will follow the mouse pointer. Hold down the Alt key while dragging to reverse the direction of the Up arrow in the 
preview.

Similarly, Ramps  can be created by either clicking and dragging or by clicking. A ramp created with a single click will 

be 30” (760 mm) high, have a slope of 1:12, and be 360” (9120 mm) long. 

An individual stair or ramp section must be between 6” (150 mm) and 100’ (30 m) in length. If a greater length is needed, 
connect two sections using a landing.

CURVED STAIRS AND RAMPS

You can make a straight stair or ramp section curved, or vice versa: 

 l Select the stairs or ramp and click the Change Line/Arc  edit button. See Change Line/Arc on page 176.

 l Select the stairs or ramp, hold down the Alt key (or right-click), and drag an end edit handle. See Alternate on page 
139.          

You can also curve straight stairs and ramps by drawing them against a curved wall.

Curved Stairs can also be created in plan view by selecting Build> Stairs> Curve to Left or Curve to Right. 
Click to place a 90º curved stair section that can then be edited. You can continue clicking to place additional 

curved staircases until another tool is selected.

Once drawn, the radius of a curved stair section can be specified in the Staircase Specification dialog. See General Panel on 
page 556.
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DRAWING STAIRS AND RAMPS DOWNWARD

Stairs              and ramps can be drawn from the current floor level downward; however, drawing stairs or ramps between floors in 
this manner is not recommended. Drawing downward should only be used to create a staircase or ramp between a porch or 
deck and the terrain when you require the direction arrow to say “DN” instead of “UP”. See Displaying Stairs, Ramps, and 
Landings on page 534.             

To draw stairs going downward

 1.  Select Build> Stairs> Draw Stairs .

 2.  Hold down the Alt key or the right mouse button.         

 3.  Click and drag to create straight stairs.         

When drawing stairs or ramps from a floor platform to the terrain, or vice versa, they will locate the height of the terrain as 
long as it is lower than the floor height. You can also create a landing or “room” outside the structure and use it to establish 
the bottom height of the stairs or ramp. Then, draw in an upward direction from the lower platform to the upper platform. 

 

L- and U-Shaped Stairs
The L-Shaped Stairs and U-Shaped Stairs tools allow you to place staircases composed of two stair sections 
connected by one or more landings with a single click. 

The staircases created with these tools build from the current floor to the floor above. If you need a staircase that builds 
between platforms on the same floor level, or in a downward direction, you will need to draw it manually. See Landings on 
page 539.

When you select either tool, the New Shaped Staircase dialog opens. 

NEW SHAPED STAIRCASE DIALOG

The settings in this dialog retained between sessions in the software and are global, affecting all plans. 

 

 l Check Only Show This Dialog on Double Click to suppress this dialog unless the L-Shaped Stairs or U-Shaped 
Stairs is double-clicked. 

 l Specify the Default Direction of the stairs as they build upward: Clockwise, or Counterclockwise. These settings 
only apply to staircases when they are not placed next to a wall.
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 l Check Make Winders to create multiple landings with angled edges between the two stair sections When 
unchecked, a single rectangular landing is produced.

  U-Shaped Stairs

 l Specify the width of the Gap between the two stair sections. 

 l Check Split Landing to create two rectangular landings instead of one. When Make Winders is also checked, each 
of these two landings is further divided into triangular shaped winders.

When you click OK, a preview outline will follow the mouse pointer.

PLACING L- AND U-SHAPED STAIRS

You can control the staircase’s orientation and direction prior to placing it by moving the mouse pointer towards a wall.

In the case of a L-Shaped  staircase with Clockwise set as the Default Direction:

 l As you move the mouse pointer close to a wall, the upper stair section in the preview outline will snap to the wall first.
 l As you move the mouse pointer closer to the wall, the preview outline will rotate so that the bottom stair section snaps 

to the wall instead.    
 l If you move the mouse pointer into a wall corner, the preview outline will rotate so the landing is in the corner and the 

Default Direction is used.

In the case of a U-Shaped  staircase with Clockwise set as the Default Direction:

 l As you move the mouse pointer close to a wall, the back of the landing in the preview outline will snap to the wall 
first.

 l As you move the mouse pointer closer to the wall, the preview outline will rotate so that the upper stair section snaps 
to the wall.    

 l If you continue to move the mouse closer, the lower stair section will snap to the wall instead.    
 l If you move the mouse pointer into a wall corner, the preview outline will rotate so that the bottom stair section snaps 

to the wall that is nearest to the mouse pointer.

When an L- or U-Shaped Staircase preview outline is in a wall corner, you can use the mouse to further control position and 
direction:

 l When an L-Shaped  staircase preview is in a wall corner, move the mouse pointer over the stair sections to control 

which is the bottom section.
 l When a U-Shaped  staircase preview is in a wall corner, move the mouse pointer within the landing area to control 

which wall the back of the landing snaps to. 
 l With the landing in place, move the mouse pointer over the two stair sections to control which is the bottom section. 

You can use keyboard hotkeys to override these behaviors:

 l Press the Alt key to reverse these snapping behaviors and the stairs’ direction.    
 l Hold down the Ctrl/⌘  key to prevent the stairs from rotating or snapping to walls.
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Displaying Stairs, Ramps, and Landings
The display of stairs, ramps, and landings in all views is controlled in the Layer Display Options dialog. Stairs, 
ramps, and landings are placed on the “Stairs & Ramps” layer. See Layer Attributes on page 125.

IN PLAN VIEW

In plan view, stairs, ramps and landings display on the floor they were drawn on and are only visible from the floor above if 
there is a stairwell. See Creating a Stairwell on page 553.

Stairs and ramps have an arrow indicating the direction they run. Interior stairs and ramps have an UP arrow on the floor 
they were created on and a DN arrow when viewed from the floor above. See Drawing Stairs and Ramps on page 530.

The style and size of the direction arrow can be specified in the Staircase or Ramp Specification dialog. The Text Style, 
color, and display are controlled by the “Stairs & Ramps, Up/Down Arrows” layer. See Arrow Panel on page 226. 

In addition, staircases can use and display a Walkline in plan views. The Walkline is drawn on the "Stairs & Ramps" layer 
and can be specified in the Staircase Specification dialog. See Style Panel on page 559.         

When a staircase is selected in plan view, the numbers associated with each of its sections and subsections display. Stair 
sections are assigned a single number, while subsection numbers have two parts: a section number and subsection number 
separated by a hyphen.

To see the center of a stair section curve in plan view, click Show Arc Centers and Ends . See Arc Centers and Ends 

on page 153. 

ON MULTIPLE FLOORS

Stairs and ramps display on the floor level on which they are drawn.  If they are located beneath an Open Below room, they 
will be visible within the area of that room on the floor level above, as well.

IN 3D VIEWS

Although stairs span between two floors, they can only belong to one floor. As a result, only multi-floor views show the 
upper floor with the platform opening and the lower floor with the staircase simultaneously. In Doll House Views, stairwells 
may appear as an empty spaces. See 3D View Tools on page 775.

 

Editing Stairs and Ramps
Staircases and ramps can be selected and edited in plan view and 3D views. See Selecting Objects on page 142. 

To select a single section of a staircase, hold down the Shift key before clicking on it. When selected in this manner, a stair 
section can be edited independent of any other connected stair sections.          
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USING THE EDIT HANDLES

When a staircase or ramp is selected, its edit handles display. These edit handles can be used to customize the selected 
object in many ways. See Editing Objects on page 137.

 l Straight stair sections and ramps are edited along their centerlines like CAD lines. They have additional edit handles 
for resizing the width of the section. See Editing Line-Based Objects on page 146.

 l Curved stair sections and ramps are edited along their centerlines like CAD arcs and also include edit handles for 
resizing the stair’s width. See Editing Arc-Based Objects on page 149.

 l Ramps can be resized to a maximum top height of  30” (760 mm). If you extend a ramp’s length to greater than 360” 
(9120 mm), its slope will decrease. For a taller ramp and control over the slope, uncheck Automatic Heights in the 
Ramp Specification dialog and specify the values you need. See General Panel on page 567.         

 l When stair sections are merged, the edit handles display differently depending on what subsection is currently 
selected. See Merging Stair and Ramp Sections on page 537.

 l When moving merged stair or ramp sections, all merged sections and landings move as one unless Stair Sections 
Move Independently is checked in the Preferences dialog. To temporarily enable this behavior, hold down the Alt 
key. See Architectural Panel on page 77 and Alternate on page 139.

 l Additional edit handles display on the first two treads of a staircase if the Starter Tread  edit button is clicked. See 

Starter Treads on page 545. 
 l Several additional edit handles display on a staircase if the Flare/Curve Stairs  edit button has been clicked. See 

Flared Stairs and Curved Treads on page 541.         

IN THE SPECIFICATION DIALOG

Stairs and ramps can be customized and their structure precisely defined in the Staircase and Ramp Specification 
dialogs. See Staircase Specification Dialog on page 555, Ramp Specification Dialog on page 567, and Stair Landing 

Specification Dialog on page 569.

Stair, ramp, and landing railings can also be customized. See Railing Panel on page 562, and Newels/Balusters Panel on 
page 564.

If one or more staircase and ramp is selected, their shared specification dialog will be limited to settings that both object 
types share, including those that affect railings, line styles, and fill styles.

USING THE EDIT TOOLS

A selected staircase or ramp can be edited in a variety of ways using the buttons on the Edit Toolbar. See The Edit Toolbar 
on page 92.

  Starter Tread allows you to create one or two rounded starter treads at the base of a selected staircase. See 
Starter Treads on page 545.

  Flare/Curve Stairs allow you to flare or curve the sides of the selected staircase's base. See Flared Stairs and 
Curved Treads on page 541.

  Auto Stairwell creates a Stairwell room on the floor above the selected staircase. See Creating a Stairwell on 
page 553.

ADJUSTING THE RADIUS OF CURVED STAIRS

The easiest way to match the radius of a stair  section to the radius of a curved wall is to draw a staircase near one side of the 
curved wall using the Draw Stairs  tool. The stairs snap to the wall, and the radius of the new staircase is defined. See 
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Curved Stairs and Ramps on page 531.           

Existing curved stairs can be aligned with an existing curved wall by aligning their centers, much the same way that curved 
stairs on different floors can be aligned. See Aligning Objects on page 170.          

If there is no curved wall, the radius of a stair section can be aligned to a CAD arc or circle.          

To align curved stairs to an object

 1.  Align the centers of the CAD object and the staircase.           

 2.  Select the curved stairs and move the side nearest to the arc or circle edge using the Resize edit handle.           

Finally, restore the stair width by dragging from the other side handle or using the Stair Specification dialog.          

 

Stair and Ramp Sections and Subsections
In Home Designer, staircases and ramps can be composed of multiple sections. In addition, each section can be broken into 
multiple subsections. 

 l Both sections and subsections can be curved while their neighbors are straight and can have different tread depths.
 l Stair sections can also have different tread widths, can be disconnected from adjacent sections using the edit handles, 

and are usually separated from other sections by landings.
 l Subsections both move and rotate as a single object, while sections move with other sections but rotate separately.

You can identify sections and subsections by clicking on a stair or ramp to select it: sections are identified with labels using 
whole numbers (1, 2, etc), while subsections are identified using hyphens (1-1, 1-2, etc). In addition, when a stair or ramp is 
selected, only the selected section will have edit handles. 

The selected section or subsection can be identified by the Move edit handle, which is red by default. See Selected Edge on 
page 143. 

CREATING STAIR AND RAMP SUBSECTIONS

There are several ways to create a stair section with multiple subsections:

 l Draw one section, then draw a second section that begins at the first one’s endpoint.
 l Draw two separate segments, then snap the start point of one segment to the endpoint of the other using the edit 

handles. 
 l Draw one segment and use the Add Break  edit tool to divide it into two subsections. See Add Break on page 175.

CREATING STAIR AND RAMP SECTIONS

There are also three ways to create multiple stair sections:
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 l Draw two separate stair sections and join them using a landing.
 l Use the Complete Break  edit tool to divide a section into two sections. See To create a complete break on page 

176.
 l Use the Disconnect Selected Subsection  edit tool to change a subsection into a section. 

MERGING STAIR AND RAMP SECTIONS

Any combination of straight and curved stair sections or straight and curved ramps using Automatic Heights can be 
merged. The resulting staircase or ramp section is made up of subsections and, if there are no landings, functions as a single 
unit. 

Stair and ramp subsections must be drawn in the same direction if they are to be merged: 

 l The top edge of a stair section or ramp cannot merge with the bottom edge of another section or ramp.
 l Combinations of stairs drawn in the UP and DOWN directions cannot be merged. 

Stair subsections merge at the center points of their upper and lower edges. 

Stair sections and ramps cannot be merged directly. If a combination of stairs and a ramp is required, connect them with a 
landing. See Landings on page 539.

To merge stair or ramp sections

 1.  Confirm that the stairs or ramps that you wish to merge are using Automatic Heights. See General Panel on page 
556.

 2.  Position the sections so they are in the desired relationship to each other. 

 l In order to merge stair sections correctly, they must be parallel to one another. 

 l To create merged subsections that change direction, make one of the merged sections curved and then specify 
Winders. See Winders on page 546.

 3.  Select either stair or ramp section so that its edit handles display.

 4.  Click the Extend handle on the end to be merged and drag it to the point where the two stairs or ramps are to meet. 

A staircase consisting of merged subsections resembles a single stair section in plan view. The UP (or DN) arrows join, 
becoming a single direction arrow. 

When a subsection is selected, the entire staircase is selected. Additional edit handles, indicating the presence of multiple 
subsections and allowing you to reposition the line along which they join.  See Using the Edit Handles on page 535.
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LOCK TREAD DEPTH

If a staircase with Lock Tread Depth selected in the Staircase Specification dialog is resized, its length increases or 
decreases one full tread at a time. See General Panel on page 556.           

When Lock Tread Depth is checked, it can be difficult to merge the section with another section or landing. If this is a 
problem, you can temporarily uncheck Lock Tread Depth. After the stairs are merged, the tread depth can be locked again.           

CURVED SUBSECTIONS

Stair subsections attached at both ends by other sections do not have a free end that can be dragged into a curve. In this 
situation, change the middle sub-section to a curve using the Change Line/Arc  edit button. See Change Line/Arc on 

page 176.

To curve an enclosed stair subsection

 1.  Draw three straight stair sections and connect them end to end.

 2.  Select the middle subsection.

 3.  Click the Change Line/Arc  edit button. The center section turns into a curved stair section. 

 4.  Use the triangular Change Curve edit handle to adjust the curvature of the middle section as needed.

Stairs joined in this manner can be turned into winders, which are steps located where a staircase turns and are narrower on 
the inside of the turn than they are on the outside. See Winders on page 546.
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Landings
Stair landings are platforms between stair sections and/or ramps, and can be created in either of five ways: 

 l Click and drag using the Landing  tool. 

 l Single-click using the Landing  tool to create a 3’-3” (975 mm) square landing. 

 l Click between two stair sections using the Draw Stairs  tool.

 l Convert a closed CAD polyline into a landing. See Convert Polyline on page 182.          
 l One or more landings are also created when the L-Shaped Stairs  or U-Shaped Stairs  tool is used.

To create a landing between stair sections

 1.  Draw two stair sections going UP. They can be at any angle.

 2.  Click between the two sections using the Draw Stairs  tool to create a landing. Notice that only one direction 

arrow displays after the sections are joined by a landing.

Similarly, a landing can be created between two ramps by clicking between them with the Ramp  tool active. 

Multiple stair sections and/or ramps can be connected to one landing. For example, two or three stair sections might meet at 
a landing with a single stair section continuing to the next level.

To be linked by a landing, all sections must be drawn in the same UP direction and the top of one section should be near the 
bottom of the next.

Stair sections connected with a landing will move together as a single unit unless Stair Sections Move Independently is 
checked in the Preferences dialog. See Architectural Panel on page 77.

A landing formed between two stair sections having less than a 90º angle between them are created with a short edge not 
less than 6” (150 mm). This is because most building codes require the shortest tread to be at least 6” wide. This edge can 
be manually edited to less than 6” if needed.

ADJACENT LANDINGS

Some staircases have more than one landing adjacent to one another. When Auto Adjust Height is used, landings in Home 
Designer recognize other nearby landings and will automatically adjust their heights and railings when their edges are 
sufficiently close to one another.

To create adjacent landings, draw two landings and then position them so that their edges are within 1” (25 mm) of one 
another. The landing that was drawn first will maintain its position while the height of the one drawn later will be the 
equivalent of one riser higher than the first. The railings on adjacent edges are suppressed, as well. 

Adjacent landings can be used to represent winders. See Winders on page 546.          
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EDITING LANDINGS

Once created, landings can be selected in 2D and 3D views and edited like other closed-polyline based objects. See Editing 
Closed Polyline-Based Objects on page 157.

Landings derive their initial materials, height, thickness, and railings  from the stairs and/or ramps attached to them. You can 
assign a unique railing or material to a landing in the Stair Landing Specification dialog. See Stair Landing Specification 
Dialog on page 569.

When moving a landing, all stair or ramp sections connected to it move as one unless Stair Sections Move Independently 
is checked in the Preferences dialog. To temporarily enable this behavior, hold down the Alt key. See Architectural Panel 
on page 77 and Alternate on page 139.

LANDING HEIGHT AND THICKNESS

A landing’s height and thickness can either be dynamically controlled by the program or user-defined and static.

By default, landing top height and thickness are both set to Auto Adjust. This means that if the structure of the attached 
stairs is edited so that their length or riser height is affected, the landing’s height and thickness will adjust automatically to 
maintain consistent riser height in all connected stair sections.

If you uncheck either Auto Adjust box in the Stair Landing Specification dialog, the landing will maintain the specified 
height and/or thickness no matter how the attached stairs or ramps are modified. This can result in stairs that have 
inconsistent risers. See General Panel on page 570.

LANDING RAILINGS

By default, landings have railings on all edges, but will automatically suppress the railing along any portion of an edge that 
connects to a stair or ramp section or has an adjacent landing. You can specify whether this automatic behavior is used, the 
railing is suppressed, or the railing is always applied in the Stair Landing Specification dialog. See General Panel on page 
570. 

You can  also suppress the railing on a selected edge by clicking the Remove Railing from Selected Edge  edit button. 

To always generate the railing on a selected edge, click the Add Railing to Selected Edge  edit button. See Selected 

Edge on page 143. 

Landings can be edited into a wide variety of shapes. So that the railings of stair sections connect properly to the landing 
railings, you may find it helpful to use the Add Break  edit tool to create a break in a landing edge if it is longer than the 

connecting stairs are wide. See Add Break on page 175.

 

Maintaining Tread Depth
Most building codes require staircases to maintain a consistent tread depth. 

WALKLINE

By default, Home Designer measures a stair section’s length and tread depth along a Walkline located 12" (30 cm) from the 
right edge of the stair section. On curved stairs, it is located 12” (30 cm) from the inside edge of the curve. 

The distance of the Walkline from the staircase edge can be specified in the Staircase Specification dialog. See Style Panel 
on page 559.          
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Alternatively, you can turn the Walkline feature off and tread depth will be measured at the tread center.           

When a curved stair section has Automatic Treads specified in the Staircase Specification dialog and the Walkline is used, 
the number and/or width of treads in a section or subsection changes when the inner edge is moved. For this reason, it is 
best to finalize stair section width as early as possible.

There are two ways to keep tread depth even throughout a stair section made of multiple subsections.          

LOCK TREAD DEPTH

The first way to maintain tread depth is to Lock Tread Depth to a specified value in the Staircase Specification dialog. See 
General Panel on page 556.           

Once locked, any changes to the length of the stair section are achieved by keeping the specified tread depth and changing 
the number of treads.           

IGNORE SUBSECTION BOUNDARIES

Curved stair sections typically have treads that are wider on one side than on the other. When they are connected to other 
stair sections, as with winders, it is possible to have treads that are too narrow at the Walkline. See Winders on page 546.           

Uniform tread depth in a stair section with subsections can be maintained by checking Ignore Subsection Boundaries in 
the Staircase Specification dialog. See General Panel on page 556.           

When Ignore Subsection Boundaries is checked, the Tread Depth value may change when the stair section is edited, but 
will remain consistent throughout all subsections.            

Because the boundaries between stair sections are being ignored, the treads where a straight section joins a curved section 
may shift position or change angle to accommodate the adjustment.          

 

Flared Stairs and Curved Treads
Any stair section can be flared and/or its treads curved using the Flare/Curve Stairs edit button. 

Only exposed sides of a stair section can be flared. If one side of a stair section is against a wall or wrapped (see Wrapped 
Stairs on page 547), only the exposed end can be flared. 
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Flaring, curved treads, and special treads should be the last 
changes that you make to any stairs.

CREATING A FLARED STAIR

Flared stairs grow wider near one end, typically sweeping outward at the bottom. Stairs can also be flared at the top or on 
both ends.

To create flared stairs

 1.  Create the stairs and connect them to a landing, floor platform edge, or another stair section. 

 2.  Specify the section width, tread depth, and any other needed information.

 3.  Select the stairs and click the Flare/Curve Stairs  edit button. New Flare edit handles display on all four corners 

of the stairs.

 4.  Drag one of the corner handles to flare that corner. As you drag the flare, the Status Bar shows the distance the side 
handle moves. This allows you to move the opposite handle the same amount.

 5.  When you are finished editing the flare, click the Main Edit Mode  to restore the stairs’ regular edit handles and 

toolbar buttons. 

SYMMETRICALLY FLARED STAIRS

Use the dimension information that displays in the Status Bar as a reference to create symmetric flares on both sides.
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ADJUSTING THE FLARE RADIUS

After a flared staircase has been created, you may want to soften the radius of the flare.

The four handles at the sides and the four handles at the corners flare the stair section when dragged outward. The two 
handles in the center of the section move the starting point for flaring along the stair section.

To adjust the flare radius

First, adjust the curvature of the flared section.

 1.  Select the flared stair and click the Flare/Curve Stairs  edit button to access the flare handles again. 

 2.  Select the handle along the flared edge of the stair. Drag this handle outward very slightly. This forms a more 
gradual flare. 

Then, adjust the starting point of the flare:

 1.  Select the flared stair and click the Flare/Curve Stairs  edit button to access the flare handles again. 

 2.  This time, drag the lower of the two central handles upward. The handle above it moves with it. This moves the start 
point for the bottom flare from the middle of the section toward its top, making the flare even more gradual.

TREADS PERPENDICULAR TO FLARE

Flared stairs often look best when the treads curve to meet the flared side perpendicular to the radius.
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To curve the edges of flared treads

 1.  Select the flared stair and click the Flare/Curve Stairs  edit button to access the flare handles again. 

 2.  Drag a corner edit handle upward one tread depth or less.

 3.  When you are finished editing the curve, click the Main Edit Mode  to restore the stairs’ regular edit handles and 

toolbar buttons. 

This type of tread curving works only on flared edges and concentrates the curvature at that edge.

Flared treads can also be curved using the Curve edit handle, which curves the treads more uniformly.

CURVING THE TREADS

When treads are curved, all treads in the section show some degree of curvature. Treads close to the curved end have a 
greater curve than those at the opposite end, but both ends can be curved. 

To curve stair treads

 1.  Select the staircase, then click the Flare/Curve Stairs  edit button. 

 2.  Drag the edit handle at the center of the bottom edge a small distance to curve the treads.
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 3.  When you are finished editing the curve, click the Main Edit Mode  to restore the stairs’ regular edit handles and 

toolbar buttons. 

 

Starter Treads
The first and second treads of a staircase can be turned into starter treads by clicking the Starter Tread edit button. 
Starter treads extend to the side of the staircase, have rounded edges and are common on traditional staircases. 

A starter tread can be added only to open sides of a stair section. If one side of a stair section is against a wall or wrapped 
(see Wrapped Stairs on page 547), only the exposed tread end can become a starter tread. 

To create starter treads

 1.  Click on a staircase to select it.

 2.  Click the Starter Tread  edit button. An edit handle displays on each end of both the first and second treads.

 3.  Drag either of the handles on the first tread outward from the stair section. If the stair section is against a wall, only 
one handle displays on the side opposite the wall.

 4.  As you drag, the ends of the tread become rounded.
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 5.  Two additional edit handles display on each side of the tread, along the back edge. 

 6.  Drag either of the two square handles upward to increase the width of the rounded ends of the tread. 

 7.  Drag the edit handle on the second tread outward from the stair section to create a second starter tread. 

 8.  To make changes to existing starter treads, select the stairs, click the Starter Tread  edit button and repeat the 

above steps as needed. 

 9.  When you are finished editing the starter treads, click the Main Edit Mode  to restore the stairs’ regular edit 

handles and toolbar buttons. 

 

Winders
Winders are steps located where a staircase turns and are narrower on the inside of the turn than they are on the outside. A 
staircase defined as a winder expands to fill in any gaps between the side of the stairs and nearby walls.           

Curved stair sections are typically used to create winders, although straight stairs can also be used. See Curved Stairs and 
Ramps on page 531.          

To create winders

 1.  In an enclosed room area, place and connect the stair sections that you want to be winders. For best results:          

 l The stairs should be two straight sections connected by a curved section between them;          

 l The curved section should be adjacent to a 90° corner, as illustrated.          

It is often easiest to create the staircase configuration in an 
open space, away from walls, then move it into position in a 

wall corner before specifying it as Winders. 

 2.  Select the staircase and click the Open Object  edit button to open the Staircase Specification dialog.           

 3.  On the GENERAL panel, place a check in the Winders check box and click OK.           

 l The stairs should be two straight sections connected by a curved section between them;          

 l The curved section should be adjacent to a 90° corner, as illustrated.          
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It is often easiest to create the staircase configuration in an 
open space, away from walls, then move it into position in a 

wall corner before specifying it as Winders. 

 4.  Select the staircase and click the Open Object  edit button to open the Staircase Specification dialog.           

 5.  On the GENERAL panel, place a check in the Winders check box and click OK.           

 6.  The steps nearest the wall corner adjust their shapes and extend into the corner after the stair is changed to a winder.           

Winders must be in a room with valid room definition. You 
cannot create winders in an area composed of only 2 corner 

walls. If this configuration is needed, enclose the area in with Invisible 
walls so that a room area is defined.

The Winders attribute directs the stair section to expand or contract to meet  nearby walls, and can also be used to create a 
partial railing. See Partial Railings on page 550.          

Winders sometimes have treads that are too narrow at the inside curve. The Ignore Subsection Boundaries option can 
address this issue. See Ignore Subsection Boundaries on page 541.          

In situations where the conditions for stair winders cannot be met, you can use adjacent landings. See Landings on page 
539.          

 

Wrapped Stairs
Check Allow Wrap on the STYLE panel of the Staircase Specification dialog and the selected stairs can be wrapped around 
the corner of a deck or landing. Curved stairs and stairs with multiple subsections cannot be wrapped. See Style Panel on 
page 559.

Stair sections that wrap around a corner to meet one another must have identical attributes. As a result, edits made to one 
wrapped stair section apply to all adjacent, wrapped sections.           

To wrap stairs around a deck

 1.  Begin by drawing a deck. See Decks on page 299. 

 2.  Use the Straight Stairs  tool to place a stair section on each side of the corner around which you want them to 

wrap.

 3.  Move the stair sections toward the corner of the deck. When the two sections are sufficiently close to the corner, 
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they will merge to form wrapped steps.

You can also draw stairs down from a deck by right-clicking to 
draw them or by pressing the Alt key while you drag. See To 

draw stairs going downward on page 532.

To wrap stairs around a landing

 1.  Use the Draw Stairs  tool to create two perpendicular stair sections with top ends that share a corner. 

 2.  Click between them to create a landing.

 3.  Rotate one stair section 180°. 

 4.  The stairs wrap around the corner. Notice that the Up arrow displays on the most recently edited stair section.
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Other Special Railings and Stairs
Stairs can be customized to meet a variety of needs.

SOLID RAILINGS

To create a solid rail along a staircase, position a solid Railing against, but not underneath, the stairs. Specify it as 
Solid and that it Follow Stairs. See Rail Style Panel on page 281.

The solid railing recognizes the adjacent stairs and climbs alongside them. 

If any balusters extend beyond the railing, eliminate them by unchecking Left Railing or Right Railing in the Staircase 
Specification dialog. See Style Panel on page 559.

FULLY HOUSED STRINGERS WITH BALUSTERS

Fully housed stringers with balusters can also be created by positioning a pony wall next to the stairs.          

To create fully housed stringers

 1.  Create a staircase, then select the stairs and click the Open Object  edit button.             

 2.  On the STYLE panel of the Staircase Specification dialog, uncheck Stringer at Wall and click OK.             

549



Home Designer Pro 2025 Reference Manual - Other Special Railings and Stairs

 3.  Draw an Interior Wall  or Half Wall  against, but not underneath, the stairs.             

 4.  Select the wall and click the Open Object  edit button.             

 5.  On the GENERAL panel of the Wall or Railing Specification dialog, make sure Railing is checked.             

 6.  On the WALL TYPES panel:             

 l Check Pony Wall.                 

 l Specify the Lower Wall Type as the same interior wall as the upper wall.                 

 l Specify the Elevation of Lower Wall Top. This value should equal the stairs’ riser height plus the height above 
the treads.                 

 7.  On the RAIL STYLE panel:             

 l Check Follow Stairs.             

 l Specify desired Railing Height.             

 l Click OK.             

Note: To create housed stringers, check Trim Against Wall in the 
Staircase Specification dialog. See Stringers Panel on page 560.

PARTIAL RAILINGS

A staircase can be enclosed on one side by a combination of wall and railing.          

Partial railings can be created by creating a staircase composed of two sections, each with a different tread width. See Stair 
and Ramp Sections and Subsections on page 536.       

To create a partial stair railing

 1.  Create a staircase and draw an Interior Wall  against, but not underneath, the stairs.         

 2.  In plan view, select the stairs and click the Add Break  edit button. See Add Break on page 175.      

 3.  Next, click the Complete Break  edit button.

 4.  With Object Snaps  enabled, click once on the stairs where they meet the end of the interior wall to add a 

complete break to the stairs at that location. The staircase is broken into two separate sections. See Object Snaps on 
page 114.       
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 5.  Select the stair section that is not adjacent to the interior wall and, using either its edit handles or its specification 
dialog, increase its tread width.    

 6.  You may need to Zoom  in on the stairs and wall to move the stair edge.             

RAILING PANELS

You can specify panels, including glass panels or cables, as a stair or ramp’s railing in the Staircase and Ramp Specification 
dialogs. See Railing Panel on page 562.         

INSET OR MIDDLE RAILING

You can use a Railing  to create inset stair railings or a middle railing.         

To use railing panels with stairs

 1.  Create a staircase and draw a Railing  under the stairs.         

 l Make sure that the railing is located entirely within a single stair section.         

 l Position it so that it is aligned with the left edge.         

 2.  Select the railing and click the Open Object  edit button. See Wall Specification Dialog on page 268.         

 3.  On the RAIL STYLE panel of the Railing Specification dialog:         

 l Select the Panels radio button.         

 l Check Follow Stairs.         

 4.  On the NEWELS/BALUSTERS panel, click the Browse button to the right of Panel Type and select the railing panel 
you want to use on the stairs, then click OK.         

 5.  Select the staircase and click the Open Object  edit button.         

 6.  On the NEWELS/BALUSTERS panel of the Railing Specification dialog, uncheck Left Railing to prevent the default 
stair railing from generating in addition to the railing panel.         

 7.  Repeat these steps if you want railing panels under the right side of the stairs, as well.         
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CONCRETE STAIRS

To make a solid concrete staircase

 1.  Select the stairs and click the Open Object  edit button.    

 2.  On the STYLE panel of the Staircase Specification dialog:         

 l Set the Tread Overhang to zero.         

 l Set the Tread Thickness to zero.         

 l Uncheck Open Risers. 

 l Uncheck Open Underneath.

 3.  On the STRINGERS panel, you can also check Large Stringer Base.         

 4.  On the MATERIALS panel, specify the “Riser/Trim”, “Support Wall”, and “Tread” materials as concrete.         

MASONRY STAIRS

To make a set of masonry stairs

 1.  On the STYLE panel of the Staircase Specification dialog:         

 l Set the Tread Overhang to zero.         

 l Set the Tread Thickness to the thickness of the masonry material.         

 2.  On the MATERIALS panel, assign the desired masonry material to the “Tread” component and specify the 
“Riser/Trim” material as concrete.         

STEEL STRINGER
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To make a steel stringer with concrete treads

 1.  On the STYLE panel of the Staircase Specification dialog:         

 l Check Open Underneath.         

 l Set the Tread Thickness to 2 inches or more.         

 2.  On the STRINGERS panel, select 1 Center Stringer.         

 3.  On the MATERIALS panel, specify the “Tread” material as concrete and the “Riser/Trim” material as steel.         

 

Creating a Stairwell
An interior staircase must be located in a stairwell, an opening to the floor above. A stairwell is an Open Below room type 
on the floor above. See Room Types on page 289.

If you create a stairwell away from other walls so the Open Below is created in the center of another room, connect a wall 
of the Open Below room to another wall using an invisible wall. 

CREATING A STAIRWELL AUTOMATICALLY

To create a stairwell that matches the perimeter of a selected staircase, click the Auto Stairwell edit button. This 
button is only available when a living space exists above the staircase. It will not be available if the space above is 

Open Below or on the Attic Floor.

Auto Stairwell automatically creates a room on the floor above enclosed by railings, defined as Open Below in the Room 
Specification dialog, and given a Stairwell room label. This room can be selected and edited like any other room.

CREATING A STAIRWELL MANUALLY

Stairwells can also be created manually. 

To create a manual stairwell

 1.  Draw a two-story building. Create the staircase on the first floor.

 2.  Make the second floor the Current Floor and the first floor the Reference Floor. See The Reference Display on 
page 525.

 3.  Select Tools> Floor/Reference Display> Reference Display  to show the Reference Floor, including the stairs. 

 4.  On the upper floor, use the Railing  tool to create a room around the stairs. Use the edit handles to position the 

railings as needed. 

 5.  Select the railings one at a time and move them into position. 
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 l When a railing is selected, its bounding box shows the location of the outer surface of the railing’s drywall layer. 
For best results, this outer surface (which does not display when the railing is not selected) should meet the top 
edge of the stairs. See Wall Types and Railings on page 235.

 l If you prefer, you can also go Down One Floor  and adjust the top edge of the staircase to snap it to the 

surface of the railing on the floor above.

 6.  When the railings are positioned properly, select Tools> Floor/Reference Display> Reference Display  to turn 

off the display of the Reference Floor.

 7.  Click inside the room using the Select Objects  tool to select it, then click the Open Object  edit button.

 8.  On the GENERAL panel of the Room Specification dialog, select “Open Below” from the Room Type list. Click OK 
to close the dialog.

 9.  Place a Doorway  in the railing at the top step for an opening. 

 10.  Select the doorway and define a large width in the Door Specification dialog. If the doorway is specified wider than 
the railing, its width adjusts to fit the available space.

 

Rooms Below Staircases
Rooms such as closets or storage areas are commonly located beneath staircases.         

To create a room below a staircase

 1.  Draw a staircase, select it, and click the Open Object  edit button to open the Staircase Specification dialog. See 

Staircase Specification Dialog on page 555.         

 l If Winders are specified for this staircase, set Max Tread Contraction to 2" on the STYLE panel to allow walls to 
be built entirely under the staircase.          

 l On the FILL STYLE panel, select “No Pattern” so the walls and other objects under the stairs can be seen.         

 2.  On the same floor as the staircase, draw the Interior Walls  under them, following their shape.

 3.  Reposition the walls as needed, making sure that each is entirely under the stairs.         
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 4.  The wall at the foot of the stairs should be placed no closer to the bottom than the second step.         

 5.  Add a door and specify the Room Type.         

 

Staircase Specification Dialog
Staircases can be defined with the greatest accuracy in the Staircase Specification dialog. To open this dialog, select 
one or more staircases and click the Open Object edit button, or double-click a stair section using the Draw Stairs 

, Straight Stairs , or Select Objects  tool. 

If a staircase is composed of multiple stair sections, or if multiple separate staircases are selected, the section that you 
clicked on to select the staircase is the Selected Section. You can select a different Selected Section on the General panel; 
however, regardless of which section is selected, information about all the sections is available and can be edited in the 
dialog.

The Staircase Specification dialog has the following panels:         

It is recommended that all floor heights, ceiling heights and 
platform thicknesses be established before using the Staircase 

Specification dialog.
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GENERAL PANEL

 
Staircase Information

Structural information about the selected staircase displays here for reference and updates as changes are made on the 
GENERAL panel.     

 l The first comment tells whether or not the staircase reaches the next level, which may be a floor platform or locked 
landing. It also indicates whether its rise angle is either steeper or more shallow than the Best Fit, described below. If 
Automatic Heights is unchecked, this comment instead says “Start and end heights are set manually”.     

 l The second comment, Best fit riser height of ___ requires ___ total risers to reach ___ to next level, describes 
the ideal rise and run for the selected staircase. The program defines the Best Fit Riser Height as the riser height 
closest to 6 3/4” (168.75 mm) that allows the selected staircase to meet the next level precisely.  This comment is 
only active if Automatic Heights is checked, below.

  If the staircase includes a landing with a user-specified height, that height is used to calculate this information. See Landing 
Height and Thickness on page 540.           

 l The total number of stair Sections, Landings, and Risers associated with the selected staircase also display here.    

 l The Rise Angle of the currently active stair section also displays here.

 l Click the Make Best Fit button to add or remove risers to the Selected Section. You can specify which section is 
Selected below. Only available when Automatic Heights is checked and the staircase does not currently use the 
Best Fit Riser Height. 

  Make Best Fit will also extend stairs drawn in a downward direction until they reach the terrain. See Terrain Perimeter on 
page 891.     

A diagram of a sample staircase’s structure displays here for reference, as well. 

 
Advanced Options

The Advanced Options apply to all sections and subsections.
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 l Specify how Tread Depth is determined:    

 o Select Automatic Treads to have the program define the depth and number of stair treads. If the staircase has 
multiple sections, each may have different tread depths.    

 o Select Lock Tread Depth to specify the Tread Depth for each stair section, below, and prevent them from changing. 
When Lock Tread Depth is selected and the length of the stairs is changed, the number of treads will change.

 o Select Lock Number of Treads to specify the number of treads in each stair section and prevent it from changing. 
When Lock Number of Treads is selected and the length of the stairs is changed, the tread depths will change.    

 o If multiple staircases or a staircase with multiple sections is selected, No Change may be an option as well. Select 
this to maintain the multiple sections’ individual settings.     

 o Check Ignore Subsection Boundaries to maintain tread depth throughout a stair section composed of merged 
subsections, regardless of whether the subsections have different tread depths assigned to them. See Ignore 
Subsection Boundaries on page 541.      

 l The Section Heights settings control how the top and bottom heights of each stair section is determined:     

 o Uncheck Automatic Heights if you would like to specify the bottom and top heights of each stair section, as 
measured from the default floor height of Floor 1, 0” (mm). When checked, the program automatically defines the 
top and bottom heights by precisely locating floor platforms and landings.              

 o The Top Height Reference values control what point on the staircase the Top Height value, below, describes.     

 o Select Floor/Landing for the Top Height value to describe the height of the top tread plus the stated Riser Height.            

 o Select Top Riser for the Top Height value to describe the height of the top riser.             

 l If you make changes in this dialog that will affect the Selected Section's length, first use the Lock End settings to 
control which end moves. The height of the Selected Section’s locked end is not affected by these settings: only its 
position in plan view. These settings are actions rather than settings:     

 o Select Lock Top to prevent the selected stair section’s top end from moving. Sections and landings above the 
selected section do not move when you click OK, while those below do move.      

 o Select Lock Bottom to prevent the selected stair section’s bottom end from moving. Sections and landings below the 
selected section do not move when you click OK, while those above do move.             

If you select a staircase by clicking near its bottom end, 
Lock Top will be selected; if you select it near its top end, 

Lock Bottom will be selected. 

 l The Radius Reference options control where the radius of curved stair sections, specified below, is measured from.    

 o Outer Arc measures the radius from the outer surface of the curved stair section's structure.    

 o Centerline measures the radius from the curved stair section's centerline.    

 o Walkline measures the radius from the curved stair section's walkline. See Walkline on page 540.    

 o Inner Arc measures the radius from the inner surface of the curved stair section's structure.

 
Specifications

The specifications for each stair section and subsection are listed as line items and can be edited here. Up to ten line items 
total can display. A change in one value usually affects other values. You may need to reposition the staircase after making 
changes.    
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 l The Section Number column identifies the Selected Section and the number of each section of the selected 
staircase. The radio button to the left indicates which section or subsection is selected.  If Ignore Subsection 
Boundaries is unchecked, subsection numbers are also identified. See Displaying Stairs, Ramps, and Landings on 
page 534.

 l Define the Length, or run, of each section or subsection measured along the Walkline. The length is equal to the 
number of treads multiplied by the tread depth. See Walkline on page 540.

When the length of a section changes, other sections and landings in the staircase unit move in response. You can specify 
whether the bottom or top edge of the Selected Section moves when you resize it by selecting either the Lock Bottom or 
Lock Top radio button, above.

 l Define the Width of each section. Only one width can be defined for a section, so all subsections in the same section 
have the same width. If a section is connected to a landing, its width should equal the length of the landing edge that 
it connects to. See Landings on page 539.     

 l Specify the Tread Depth, or run, of each stair tread in the selected section. To lock this value, check Lock Tread 
Depth, above.

If a landing is created between two stair sections and one of them has locked tread depth, the resulting staircase also has 
locked tread depth. Any landings or sections connected to this new staircase adjust to meet it and then have locked tread 
depth as well.

 l Define the number of Treads in a stair section or subsection. To lock this value, select Lock Number of Treads, 
above.

 l Define the Bottom Height, the height of the stair section’s bottom edge. To lock this value, click the radio button to 
the left of the section’s number, then click the Lock Bottom radio button, above, and click OK.         

 l Define the Top Height, the height of the stair section’s top edge. To lock this value, click the radio button to the left 
of the section’s number, then click the Lock Top radio button, above, and click OK. 

 l Define the Riser Height, the height of the risers in each stair section.

 l Define the Radius of a curved stair section. The location on the stairs where the radius is measured from can be 
specified above. Not available if the selected staircase does not have a curved section.

 l Check Winders to specify the Selected Section, including subsections, as winders. See Winders on page 546.           

 
Preview

A preview of the selected staircase displays on the right side of the panel. If the staircase includes any landings, only the 
section that was selected when the dialog was opened will display. See Dialog Preview Panes on page 21. 
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STYLE PANEL

 
Tread

See Anatomy of a Staircase on page 529.

 l Specify the Tread Overhang, which is the distance that each tread overhangs the riser.

 l Specify the Tread Thickness.

 
Open Options

The Open Options control whether the selected stairs have open risers or an open underside. 

 l Check Open Risers to eliminate the riser face under each tread and expose the stringers.

 l Uncheck Open Underneath to add a skirt below the staircase along the two sides. It looks like a wall in 3D, but 
only has a single face. Base molding does not generate along the bottom of the skirt, and doors cannot be placed in 
it. In most cases, the recommended way to enclose the area beneath stairs is to use walls. See Rooms Below 
Staircases on page 554.

 l Specify the Side Inset of the skirt below the staircase. The default value of 0 aligns the skirt with the outside of the 
surface of the stringers. Only available when Open Underneath is unchecked.          

 
Runner

Specify the attributes of the staircase’s carpet Runner. Only available when Open Risers is unchecked, above.

 l Specify the Runner Width. The default value of 0 does not create a runner. 

 l Uncheck Runner Tucked to have the runner drop straight down from the tread front to the riser below. This is 
checked by default. 
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Winder

Define the Max Tread Contraction, which is the amount a tread’s width may be reduced when it meets a wall. See Partial 
Railings on page 550.
This option only takes effect when the stairs are specified as Winders on the GENERAL panel. See General Panel on page 
556.

 
Use Walkline

See Walkline on page 540.    

 l Check Use Walkline to have the program calculate the tread depth based on a Walkline. Uncheck the box to disable 
this function.    

 l Specify the distance of the Walkline from Edge. The default value is 12” (300 mm).          

 l Check Show Walkline to show the Walkline in plan view.          

 
Top Landing

Specify the appearance of the staircase where it meets the next floor platform. These options do not affect the edges of 
landings.                 

 l Check Nosing at Top Landing to produce tread nosing attached to platform edge at the top of stairs.         

 l Check Riser Surface at Top Landing to produce a riser surface against the platform edge at the top of the stairs. 
This allows stair risers to match all the way to the top of the platform.         

  Options

 l Check Automatic Railing Openings to automatically create a doorway opening when the selected stairs are snapped 
to a railing drawn on the same floor as the stairs. This is checked by default.           

 l Check Allow Wrap to wrap the selected stairs around the corner of a deck or landing where another, identical stair 
section is present. See Wrapped Stairs on page 547.           

 
Preview

A preview of the selected staircase displays on the right side of the panel. If the staircase includes any landings, only the 
section that was selected when the dialog was opened will display. See Dialog Preview Panes on page 21. 

STRINGERS PANEL

The settings on the STRINGERS panel affect all sections of a selected staircase.         
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  Stringer Style

 l Click a radio button to specify the number of stringers assigned to the staircase.              Select Custom Stringers to enable 
the Left, Middle, and Right settings below.

 l Specify the Height Above Tread, measured straight down from the top outer edge of the tread nosing to the top of 
the stringer. Only available when 2 Closed Side Stringers is selected, above.          

 l Specify the Height Below Tread, measured straight down from the back bottom edge of the tread to the bottom of 
the stringer. Not available when Custom Stringers is selected, above.         

The Left, Middle, and Right settings are enabled when Custom Stringers is selected. For each of these:          

 l Specify the Count for each stringer location. Multiple Left and Right stringers are butted side to side while multiple 
Middle stringers are evenly spaced between them.          

 l Specify the Thickness, measured horizontally.           

 l Specify the Offset of each stringer from its default location. A positive value offsets the stringer(s) to the right; a 
negative value offsets them to the left.           

 l Specify the Height Below the treads, measured straight down from the back bottom edge of the tread to the bottom 
of the stringer.           

 l Check Ext to specify the stringer(s) as Exterior and allow them to extend up past the top of the stair treads.           

 l Specify the Height Above the stair treads, measured straight down from the top outer edge of the tread nosing to the 
top of the stringer.          

 l The vertical Depth of the stringers is reported here for reference. This value is affected by the Heights above and 
below the treads, as well as the stairs Rise Angle.          

 
Trim Against Wall

Specify the attributes of the Trim Against Wall that generates when the staircase is positioned against a wall.  
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 l Specify the Height Above Tread, measured straight down from the top outer edge of the tread nosing to the top of 
the tread.           

 l Specify the Height Below Tread, measured straight down from the back bottom edge of the tread to the bottom of 
the trim.           

 l Specify the Thickness of the trim, measured horizontally.           

 l Clip Top - Specify whether to clip the top of the trim where it meets the upper floor level. Trim can be clipped on 
the Left and/or Right sides of the staircase.          

  Options

 l Extend Stringer Top is checked by default and extends a triangular portion of the stringer under the landing or 
platform at the top of the stairs.          

 l Check Large Stringer Base to widen the stringers at the foot of the staircase. This is helpful when walls are created 
below the stairs.         

 
Preview

A preview of the selected staircase displays on the right side of the panel. To see the stringers, click in the preview and drag 
upward to rotate. See Dialog Preview Panes on page 21. 

RAILING PANEL

By default, the settings on the RAILING panel also affect the railings on any landings attached to the selected staircase or 
ramp. See Landings on page 539.           

This panel is also found in the Ramp and Landing Specification dialogs.
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  Railing

 l Stair Rail Height defines the height from tread surface directly over the riser to railing top.

 l Landing Rail Height defines the height of the landing rail top from the landing surface.

 l Horizontal Offset allows you to place the railings either inside or outside their default location aligned with the 
edge of the stairs. A positive value offsets the railings inward while a negative value offsets them outward.

 l Railing On - Select Left and/or Right to specify placement of railings on stair sections.

 l Railing at Wall - Select Left and/or Right to specify the placement of wall railings. Not available for ramps.

 l Check Railing Transitions on Left and/or Right to create “gooseneck” connections between stair and landing 
railings. This option only has an effect when Rail Passes Over Newel is checked. Not available for ramps.          

 l Check Smooth Transitions on Left and/or Right to specify the placement of smooth connections between stair and 
landing railings. Not available for ramps.           

 l Check both Railing Transitions and Smooth Transitions to produce a handrail like this:          
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  Style

 l Select Balusters to create regularly spaced balusters between larger newel posts.         

 l Select Open to create with only newels posts.          

 l Select Open with Middle Rail to create railings with newel posts and a middle rail.          

 l Select Panels to create railings composed of panels. The panel style is specified on the NEWELS/BALUSTERS panel. 
See Newels/Balusters Panel on page 564.         

  Top/Bottom Rail

 l Check Include Handrail/Top Rail to produce a top rail on the stair railings that receives the top baluster ends and 
typically acts as a handrail.          

 l Check Include Bottom Rail to place a low rail on the landing surface that receives the balusters ends.          

 l Check Raise Bottom, then specify the distance to raise the bottom rail or panel from the stair tread.         

 
Preview

A preview of the selected staircase displays on the right side of the panel. If the staircase includes any landings, only the 
section that was selected when the dialog was opened will display. See Dialog Preview Panes on page 21.          

NEWELS/BALUSTERS PANEL

The settings on the NEWELS/BALUSTERS panel will also affect the appearance of railings on any landings attached to the 
selected staircase. See Landings on page 539.         

These settings are similar to those found on the same panel of the Ramp and Landing Specification dialogs. See Ramp 
Specification Dialog on page 567.         
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Newels

 l Uncheck Has Newel Posts to prevent newels from generating in the selected staircase’s railings. When this box is 
checked, newels are generated and can be edited using the settings that follow.

 l Type - Select Square, Round, or newels from the Library. Selecting Library from the drop-down list is the same 
as clicking the Library button to the right and allows selection of a newel from the library.

 l Specify the Width, which is the width or diameter of each newel. For Library newels, this is the width at its widest 
point.

 l Specify the Height, which is the height from the landing surface to the top of the newel. Only available when Rail 
Passes Over Newel is unchecked; when this box is checked, newels build to the bottom of the handrail.

 l Specify the Horizontal Offset, which is the amount each newel is offset from the center of the railing.

 l Specify the Bottom Offset, which is the amount each newel's bottom is offset from the tread or floor surface beneath 
it.

 l Check Clipped to clip any newels that extend down to or past the floor level at the floor surface.

 l Specify the on-center Spacing of the newel posts.

 
Balusters

The first three Balusters settings are similar to the Newels options of the same names, above.         

 l Cut Baluster Top - Each tread normally has two to three balusters, growing longer toward its back. The default is to 
use the same baluster and cut it off at the bottom to shorten it toward the tread front. Check this box to cut the 
balusters at the top instead.         

 
Panels

These settings are only available when the railing Style specified as “Panels” on the Railing Panel on page 562.
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 l Specify the panel’s Thickness.         

 l Select “Solid” or “Library” from the Type drop-down list.         

You can also apply newels, balusters, and panels onto stair 
or ramp railing directly from the Library Browser. See 

Inserted Objects on page 715.    

 
Preview

             A preview of the selected staircase displays on the right side of the panel. If the staircase includes any landings, only the 
section that was selected when the dialog was opened will display. See Dialog Preview Panes on page 21.          

RAILS PANEL

The settings on the RAILS panel are similar to those on the RAILS panel of the Wall Specification dialog as well as the 
MOLDINGS panel of a variety of other dialogs. See Moldings /  Rails Panels on page 688.

By default, the settings on the RAILS panel will also affect the appearance of railings on any landings attached to the 
selected staircase. See Landings on page 539. 

LINE STYLE PANEL

The settings on the LINE STYLE panel are available for a variety of other objects in the program. For information about these 
settings, see Line Style Panel on page 209.

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected staircase in plan view. For information about 
these settings, see Fill Style Panel and Dialogs on page 132.

MATERIALS PANEL

The settings on the MATERIALS panel affect the appearance of the selected staircase in 3D views and are available for a 
variety of objects throughout the program. For information about these settings, see Materials Panel on page 750.

The settings on this panel will also affect the materials applied to any landings attached to the selected staircase. See 
Landings on page 539.

ARROW PANEL

The settings on the ARROW panel control the appearance of the selected staircase’s direction arrow in plan view. See In Plan 
View on page 534.          

For information about these settings, see Arrow Panel on page 226.          

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. See Components Panel on page 967.          
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Ramp Specification Dialog
Ramps can be defined with the greatest accuracy using the Ramp Specification dialog. To open this dialog, select one 
or more ramps and click the Open Object edit button or double-click a ramp section using the Ramp  or Select 

Objects  tool. 

The Ramp Specification dialog has the following panels:         

GENERAL PANEL

 
Diagram

A diagram of a sample ramp’s structure displays here for reference. 

 
Size

Specify the Ramp Length and Width.

 
Heights

Specify the Heights of various key locations on the selected ramp.                  
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 l Uncheck Automatic Heights/Slope to activate the settings below, then specify the height and slope of the ramp. 

 l Specify the Top Height, which is the height of the ramp at its high end.

 l Specify the Bottom Height, which is the height of the ramp at its low end.

 l Specify the Base Height, which is the height of the bottom surface of the ramp.

 
Slope

Specify the ramp’s Slope by typing its Rise value in the first field, and the Run value in the second field. See Anatomy of a 
Staircase on page 529. 

  Options

 l Check Automatic Railing Openings to automatically create a doorway opening when the selected ramp is snapped 
to a railing drawn on the same floor as the ramp. This is checked by default.

 l Check Open Underneath to remove the skirt around the bottom of the ramp so that it has a uniform, sloped 
thickness that may not reach the floor or terrain at the high end. This is unchecked by default.

 l Specify the Max Thickness, which is the ramp’s maximum thickness. At the low end of the ramp where it meets the 
floor or terrain, its thickness may be less than this value. 

 
Tread

Specify the structure of the ramp’s Tread, which an optional surface layer placed over the top of the ramp.

 l Check Has Tread Surface to apply a top tread surface to the ramp and enable the settings below. 

 l Specify the Tread Overhang, which is the distance the tread surface extends past the ramp’s edges. 

 l Specify the Tread Thickness, which is the tread surface’s vertical depth. 

 
Preview

             A preview of the selected ramp displays on the right side of the panel. If the ramp is composed of multiple sections 
separated by landings, only the section that was selected when the dialog was opened will display. See Dialog Preview 
Panes on page 21.          

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected ramp segment is a line as opposed to an arc. For more information, 
see  Line Panel on page 208.         

The SELECTED ARC panel is available when the selected ramp segment has been converted to an arc. For more information, 
see Arc Panel on page 214.         

See, too, Selected Edge on page 143 and Change Line/Arc on page 176.          

RAILING PANEL

The settings on the RAILING panel are similar to those on the same panel in the Staircase Specification dialog. For 
information about these settings, see Railing Panel on page 562.         

By default, the settings on this panel will also affect the appearance of railings on any landings attached to the selected 
ramp. See Landings on page 539.         
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NEWELS/BALUSTERS PANEL

The settings on the NEWELS/BALUSTERS panel are similar to those on the same panel in the Staircase Specification dialog. 
For more information, see Newels/Balusters Panel on page 564.         

By default, the settings on this panel will also affect the appearance of railings on any landings attached to the selected 
ramp. See Landings on page 539.         

RAILS PANEL

The settings on the RAILS panel are similar to those on the RAILS panel of the Staircase Specification dialog as well as the 
MOLDINGS panel of a variety of other dialogs. See Moldings /  Rails Panels on page 688.         

By default, the settings on this panel will also affect the appearance of railings on any landings attached to the selected 
ramp. See Landings on page 539.         

LINE STYLE PANEL

The settings on the LINE STYLE panel are available for a variety of other objects in the program. For information about these 
settings, see Line Style Panel on page 209.         

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected ramp in plan view. For information about these 
settings, see Fill Style Panel and Dialogs on page 132.         

MATERIALS PANEL

The settings on the MATERIALS panel affect the appearance of the selected ramp in 3D views and are available for a variety 
of objects throughout the program. For information about these settings, see Materials Panel on page 750.         

The settings on this panel will also affect the materials applied to any landings attached to the selected ramp. See Landings 
on page 539.         

ARROW PANEL

The settings on the ARROW panel control the appearance of the selected ramp’s direction arrow in plan view. See In Plan 
View on page 534.          

For information about these settings, see Arrow Panel on page 226.          

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 967.          

 

Stair Landing Specification Dialog
Select a landing and click the Open Object edit button to open the Stair Landing Specification dialog. See Landings 
on page 539.

The Stair Landing Specification dialog has the following panels:
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GENERAL PANEL

 
Landing

Uncheck Auto Adjust Height to specify the selected landing’s Top Height. 

 l A free-standing interior landing will have a default Top Height equal to one riser plus the thickness of the default 
floor finish. A free-standing exterior landing will have a default top height equal to its thickness. When this box is 
checked, the landing height may adjust as needed to maintain consistent riser height in all connected stair sections, 
ramp sections, or adjacent landings. 

 l The Top Height field is only active when Auto Adjust Height is unchecked. See Landing Height and Thickness on 
page 540. 

Note: A network of adjacent landings can only be created when Auto 
Adjust Height is checked. See Adjacent Landings on page 539.

  Uncheck Auto Adjust Thickness to specify the selected landing’s Thickness. 

 l A free-standing landing will have a default thickness of 6 3/4” (169 mm). When checked, the thickness is based on 
the riser height of the stair sections it is attached to, or the thickness of the ramps it is attached to.

 l The Thickness field is only active when Auto Adjust Thickness is unchecked. 

 
Selected Edge

Specify how railings are applied to the landing’s Selected Edge. See Selected Edge on page 143.      

 l Select Automatic to suppress the railing on any portion of the selected edge that either connects to a stair or ramp 
section or has an adjacent landing, but to produce a railing where that is not the case. See Landing Railings on page 
540.     

 l Select No Railing to suppress the railing on the selected edge of this landing.     

 l Select Has Railing to produce a railing along the selected edge, even where it connects to a stair or ramp section or 
has an adjacent landing.     

 l Check Apply to All Edges to apply your selection to all edges of the landing. This is an action rather than a state - 
the next time this dialog is opened, this box will be unchecked.

 
Preview

A preview of the selected landing displays on the right side of the panel. See Dialog Preview Panes on page 21.
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POLYLINE PANEL

The POLYLINE panel states the length of the landing’s Perimeter, its enclosed Area, and its Volume. 

The settings on this panel are available for a variety of other objects in the program. See Polyline Panel on page 219.

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. For more information, see  Line 
Panel on page 208.

The SELECTED ARC panel is available when the selected edge has been converted to an arc. For more information, see Arc 
Panel on page 214.

See, too, Selected Edge on page 143 and Change Line/Arc on page 176. 

RAILING PANEL

The settings on the RAILING panel are similar to those on the same panel in the Staircase Specification dialog. For 
information about these settings, see Railing Panel on page 562.         

There is one setting that is unique to the Landing Specification dialog:         

Uncheck Use Connected Stair or Ramp Railing to enable the settings on this panel, the NEWELS/BALUSTERS panel, and 
the RAILS panel. When checked, the selected landing derives all railing settings from the connected stairs or ramp.

If the selected landing is not connected to a stair or ramp, this check box will be named Use Default Interior or Exterior 
Stair Railing, depending on where the landing is located.         

NEWELS/BALUSTERS PANEL

The settings on the NEWELS/BALUSTERS panel are similar to those on the same panel in the Staircase Specification dialog. 
For more information, see Newels/Balusters Panel on page 564.         

By default, the settings on this panel will also affect the appearance of railings on any landings attached to the selected 
ramp. See Landings on page 539.         

RAILS PANEL

The settings on the RAILS panel are similar to those on the RAILS panel of the Staircase Specification dialog as well as the 
MOLDINGS panel of a variety of other dialogs. See Moldings /  Rails Panels on page 688.          

LINE STYLE PANEL

The settings on the LINE STYLE panel are available for a variety of objects throughout the program. See Line Style Panel on 
page 209.
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FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected landing in plan view. See Fill Style Panel and 
Dialogs on page 132.   

MATERIALS PANEL

When a landing is attached to stairs or a ramp, its initial materials are derived from the stairs or ramp. When the landing is 
attached to a ramp, its top surface material is defined by the Landing Sides component unless the ramp is using a Tread 
material.

The settings on this are available for a variety of objects throughout the program. For information about these settings, see 
Materials Panel on page 750.

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 967.          
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Chapter 22
 

Roofs

Home Designer Pro’s manual and automatic Roof Tools allow you to draw almost any roof style. 

Verify that all roof planes join as intended. The program does 
not confirm correct geometry between manually designed or 

edited roof planes. It is possible to design and edit roof planes with hips 
and valleys that do not meet properly. 

TOPICS

Automatic vs. Manual Roofs 574
Roof Defaults 574
The Roof Tools 575
Automatic Roofs 577
Build Roof Dialog 579
Roof Planes 585
Displaying Roofs 587
Editing Roof and Ceiling Planes 589
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Automatic vs. Manual Roofs
Home Designer Pro can create just about any roof style. Most common roof styles such as hips and gables can easily be 
generated automatically. 

More complex roof styles, including curved roof planes, can be created manually. The manual roof tools allow you to create 
any roof system that can be represented using roof planes.          

AUTOMATICALLY GENERATED ROOFS

The quickest and easiest way to create a roof over a structure is automatically. By default, a roof plane is generated over 
each exterior wall, creating a hip roof. The program automatically joins the roof planes at ridges, hips, and valleys and tries 
to create roof planes that join together to form a single, integrated system. See Automatic Roofs on page 577.         

Any deviations from the default hip roof can be specified on the ROOF panel of the Wall Specification dialog for any 
exterior wall. Here, you can specify a Full Gable Wall, High/Shed Gable Wall, or other options instead of a default hip roof. 
You can also specify a different overhang, pitch, an upper pitch, and the elevation where the upper pitch begins for the roof 
plane that rests on the selected wall. See Roof Directives in Walls on page 257.          

When you need the roof planes over an area of a plan to be entirely separate from those over the rest of the structure, you 
can assign those areas to a non-default Roof Group. See Roof Groups on page 577.          

Roofs can also be automatically generated based on a Roof Baseline Polyline. When a Roof Baseline Polyline is used, 
information that determines where and how roof planes are generated is contained in the Roof Baseline Specification dialog. 
See Roof Baseline Polylines on page 601.          

Bay, bow, and box windows also produce roof planes automatically. For information about these windows and the roof 
styles that can be used with them, see Bay, Box, Bow Windows and Roofs on page 437.          

MANUALLY DRAWN ROOFS

Any roof system that can be created automatically can also be created manually. Each roof plane is drawn and edited 
individually, offering full control over the process and limiting the possibilities only to your imagination.           

Note: You cannot manually draw or edit roof planes when Auto Rebuild 
Roofs is enabled in the Build Roof dialog. See Roof Panel on page 580.

USING BOTH TECHNIQUES

Another useful option is to start with an automatically generated roof and use manual design techniques to finish it. Using 
both automatic roof generation and the manual roof drawing and editing techniques, you can quickly design highly 
customized roof systems.           

 

Roof Defaults
Select Edit> Default Settings, to open the Default Settings dialog for a variety of drawing tools, several of which 
directly affect roof generation. 
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ROOF DEFAULTS DIALOG

The Build Roof and Roof Defaults dialogs are nearly identical in appearance and function. The only difference is that the 
Build Roof dialog has a number of check boxes that allow you to automatically generate roof planes and related objects. See 
Build Roof Dialog on page 579.

If changes are made to the settings in this dialog after the roof has been built, you will need to rebuild the roof in order for 
your changes to take effect.           

ROOF FRAMING DEFAULTS

Default settings for framing can be specified in either the Build Roof, Framing Defaults, or the Framing Defaults dialog. 
Framing defaults control the depth of roof planes as well as the depth of floor and ceiling platforms, which influence roof 
plane heights. See Framing Defaults on page 627.          

To create roof planes with a particular assembly of layers, begin by setting up the desired roof framing defaults, then build 
the roof. If you later need to change the structure of the roof planes, make the needed change to the Framing Defaults, and 
then rebuild the roof. You can also edit the structure of individual roof planes.          

FLOOR AND CEILING HEIGHTS

The initial heights of floors and ceilings, which influence roof heights, are specified in the Floor Defaults dialog for each 
floor. See Floor Level Defaults Dialogs on page 518.         

The floor and ceiling heights in individual rooms also influence roof heights and are specified in the Room Specification 
dialog. See Structure Panel on page 310.

If Auto Rebuild Roofs is checked in the Build Roof dialog and 
you change floor or ceiling heights, floor or ceiling platform 

depths, wall positions or roof directives in walls, the roof rebuilds to 
reflect your changes. See Rebuilding Roofs on page 578.

WALL SPECIFICATION DIALOG

By default, when an automatic roof is built, a roof plane is generated over each exterior wall, creating a hip roof. 

Any deviations from this default hip roof, such as a gable or a different pitch, can be specified in the Wall Specification 
dialog for any exterior wall. See Roof Panel on page 272. 

DORMER DEFAULTS

The settings in the Dormer Defaults dialog determine the initial settings for automatic dormers and are much like those in 
the Dormer Specification dialog. See Dormer Specification Dialog on page 619.         

The Dormer Defaults dialog can be opened from the Default Settings dialog or by double-clicking either of the Auto 
Dormer  tools.           

 

The Roof Tools
Select Build> Roof to access the Roof Tools. 
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BUILD ROOF

Select Build> Roof> Build Roof to open the Build Roof dialog, specify the settings for automatically generated and 
manually drawn roof planes as well as manually drawn ceiling planes, and build or rebuild a roof. See Build Roof 

Dialog on page 579.

When roofs are automatically generated, a roof plane is created over each exterior wall by default, resulting in a hip roof, 
and the program tries to join them together to form a single, integrated system.

To automatically generate a roof plane using values other than the defaults or to not generate a roof plane bearing on a 
particular wall (as with a gable or the sides of a shed roof), you can change the settings in the Wall Specification dialog. See 
Roof Panel on page 272.

ROOF PLANE

Select Build> Roof> Roof Plane to draw a roof plane manually. See Roof Planes on page 585. You can also double-
click the Roof Plane button to open the Build Roof dialog.         

Note: You cannot use the Roof Plane tool when Auto Rebuild Roofs is 
enabled in the Build Roof dialog. See Manually Drawn Roofs on page 
574.

CEILING PLANE

Select Build> Roof> Ceiling Plane to draw a ceiling plane manually. Ceiling planes are drawn and behave much like 
roof planes. See Ceiling Planes on page 605.         

GABLE/ROOF LINE

Select Build> Roof> Gable/Roof Line to draw a gable line that generates a gable along a baseline edge when roofs 
are automatically generated. See Gable/Roof Lines on page 609.         

SKYLIGHT

Select Build> Roof> Skylight, then draw a rectangle over an existing roof plane to create a skylight. The skylight, 
skylight shaft, and ceiling hole (if a ceiling exists) are drawn at the same time. See Skylights and Roof Holes on page 

612.    

ROOF HOLE

Select Build> Roof> Roof Hole, then draw a rectangle over an existing roof plane to create a hole. See Skylights and 
Roof Holes on page 612.   

AUTO FLOATING DORMER

Select Build> Roof>  Auto Floating Dormer and click within an existing roof plane to place an auto floating 
dormer. See Dormers and Crickets on page 616.

AUTO DORMER

Select Build> Roof> Auto Dormer and click within a roof plane to place a dormer. See Dormers and Crickets on 
page 616.         
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DELETE ROOF PLANES

Select Build> Roof> Delete Roof Planes to delete all roof planes in the plan. See Deleting Roof Planes on page 594.

DELETE CEILING PLANES

Select Build> Roof> Delete Ceiling Planes to delete all manually drawn ceiling planes in the plan. See Ceiling 
Planes on page 605.         

FIX ROOFS

Select Build> Roof> Fix Roofs to remove breaks where a single edge of one roof plane meets the broken edge of 
another along a ridge, hip or valley. Fix Roofs does not affect eave edges. See Roof Edges and Walls on page 591.         

 

Automatic Roofs
When roofs are automatically generated, a roof plane is created over each exterior wall by default, resulting in a hip roof, 
and the program tries to join them together to form a single, integrated system.

There are a number of options available to produce variations in this default roof style. 

ROOF DIRECTIVES IN WALLS

To automatically generate a roof plane using values other than the defaults or to not generate a roof plane bearing on a 
particular wall (as with a gable or the sides of a shed roof), you can change the settings in the Wall Specification dialog for 
that wall. See Roof Panel on page 272.

ROOF GROUPS

When an automatic roof is generated, the program tries to create roof planes that join together to form a single, integrated 
system. Different parts of the structure influence how the roof is generated over the whole.           

When you need the roof planes over an area of a plan to be entirely separate from those over the rest of the structure, you 
can assign those areas to a non-default Roof Group. The program treats different Roof Groups as separate buildings for the 
purpose of automatic roof generation, preventing their roofs from influencing one another.           

Bear in mind that the use of Roof Groups typically involves using a combination of both automatic roof generation and 
manual roof editing, and that changes to Attic walls may also be necessary. See Using Both Techniques on page 574.           

Roof Groups are assigned using numbers. The Default Roof Group is always 0, and you can assign rooms to other roof 
groups in the Room Specification dialog. See General Panel on page 308.          

CURVED WALLS AND ROOFS

Automatically generated roof planes are placed over curved walls at specified increments. In the Build Roof dialog, you can 
specify the degree increments for the roof over curved walls, from 6° to 90°. The lower the number, the more roof sections 
are created over the curved wall.           

The following  illustrations show a roof created at two different curved increments: 30° and 15°.          
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CONCAVE CURVED WALLS AND ROOFS

Regular roof plane sections can also generate over concave curved walls. For roof sections to generate over a concave 
curved wall, the sections’ baselines must be longer than the Minimum Alcove Size value on the BUILD panel of the Build 
Roof dialog.          

If the baselines are shorter, the automatically generated roofs are simplified by either:           

 l Ignoring the curved wall, as if the walls on either side extended to their meeting point.          

 l Spanning the concave curved wall with a straight Baseline and produce a roof plane for it from that.          

REBUILDING ROOFS

By default, whenever changes are made to wall placement, floor/ceiling heights, or roof directives in walls, the roof will 
update in response. If you do not want the roof to rebuild automatically, uncheck Auto Rebuild Roofs in the Build Roof 
dialog. See Roof Panel on page 580.         

Changes made to  floor or ceiling platform thicknesses will also cause the roof to be automatically rebuilt. See Editing 
Rooms on page 293.   

You can also rebuild the roof at any time to reflect the current state of the model by opening the Build Roof dialog, 
checking Build Roof Planes, and clicking OK.

Manually dawn roof planes are specified as such in the Roof Plane Specification dialog. If a roof plane was automatically 
generated, it will instead have a Mark as Edited check box. See Roof Plane Specification Dialog on page 597.          
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When the roof is rebuilt using Auto Rebuild Roof or Build Roof Planes in the Build Roof dialog, all roof planes in the 
plan, both automatically generated and manually drawn, are deleted and replaced.          

 l To preserve any manually drawn roof planes, check Retain Manually Drawn Roof Planes on the BUILD panel of the 
Build Roof dialog before the roof is rebuilt.           

 l To preserve any automatically generated roof planes that you have edited, check Retain Edited Roof Planes on the 
BUILD panel of the Build Roof dialog before the roof is rebuilt.          

Note: Under some conditions, when the roof is rebuilt new roof planes 
may be generated in the same location as retained manually drawn or 
automatic roof planes. 

Roof planes cannot be edited or manually drawn when Auto Rebuild Roofs is turned on. If you try to either edit or draw a 
roof plane using the Roof Plane  tool, a question message will display.          

 

Build Roof Dialog
The Build Roof dialog is used to automatically build or rebuild roof planes and generate Roof Baseline Polylines. 
The settings in this dialog act as defaults for both manually drawn and automatic roofs. See Roof Defaults on page 

574.    

To open the Build Roof dialog, select Build> Roof> Build Roof . You can also double-click the Roof Tools  button 

or the Roof Plane  button to open this dialog.

Roof planes and Roof Baseline Polylines are generated based on the positions and roof directive settings for each exterior 
wall in the plan. If you make changes to any of these walls or to any of the settings in this dialog, you will need to build the 
roof again for them to take effect. See Roof Panel on page 272. 

Aside from a number of check boxes on the ROOF panel that allow you to automatically generate roof planes and related 
objects, the settings in this dialog are also found in the Roof Defaults dialog. See Roof Defaults on page 574. 

The settings in this dialog are similar to those found in the Roof Plane Specification dialog, but affect all subsequently 
created roof planes rather than one or more selected  roof planes. See Roof Plane Specification Dialog on page 597.         

The Build Roof dialog has the following panels:
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ROOF PANEL

  Build

 l Check Build Roof Planes to build a new roof structure over the entire model. Unless you specify otherwise, the 
program discards the existing roof planes  and produces new ones.                      

 l If you check Auto Rebuild Roofs, the program automatically rebuilds the roof  whenever you make a change that 
affects the generation of roofs, such as changes to exterior walls or ceiling heights.   

 l Check Make Roof Baseline Polylines to delete the existing roof and to create Roof Baseline Polyline(s) based on 
the exterior wall layout and roof information defined in those walls. Not available when Build Roof Planes is 
checked. See Roof Baseline Polylines on page 601.   

 l You can also specify how manually drawn or edited roof planes are handled when the roof is rebuilt automatically. 
These options are only available when Build Roof Planes is checked. See Rebuilding Roofs on page 578.     

 l Check Retain Manually Drawn Roof Planes to prevent manually drawn roof planes from being deleted when roof 
planes are rebuilt. Automatic roof planes may be generated in the same location. Also available if Make Roof 
Baseline Polylines is checked.   
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 l Check Retain Edited Automatic Roof Planes to prevent automatic roof planes that have been manually edited - 
including roof planes over exploded dormers - from being deleted when roof planes are rebuilt. Also available if 
Make Roof Baseline Polylines is checked.
If a newly generated roof plane is coplanar with a retained plane, and the area where they overlap is at least half the 
area of either of them, the new roof plane is deleted and only the retained plane is kept.   

Note: Under some conditions, new roof planes may be generated in 
the same location as manually drawn or automatic roof planes that 
have been retained. 

 l Check Use Existing Roof Baselines to produce a roof plan based on your Roof Baseline Polyline(s) instead of the 
exterior wall layout.   

  Specifications

 l Specify the roof Framing Method: either Trusses or Rafters. When Trusses is selected, roof plane Structure 
Thickness is derived from the default Top Chord Depth for roof trusses set in the Framing Defaults dialog; when 
Rafters is selected, the Structure Thickness is derived from the default Structure Definition. If you plan to use both 
trusses with rafters, select Framing so that the rafters’ depth can be accommodated. See Trusses Panel on page 647 
and Roof Panel on page 644.

 l Enter a value to describe the Pitch. In plans using U.S. units of measurement, pitch is described as a ratio over 12 by 
default; in metric plans, it is measured in degrees. For a conversion to degrees, see Roof Pitches in Degrees on page 
625.         

 l Check Pitch in Degrees to display the pitch value in degrees in all dialogs as well as in roof plane labels. Values 
between -89° and 89° can be entered. When Pitch in Degrees is unchecked, Pitch is described in terms of rise and 
run: x inches in 12 or x mm in 1000.

  Roof Height

 l Specify the Heel Height, which the height that the roof is raised off the wall top plates to accommodate an Energy 
Heel. Only available when Trusses is the selected Framing Method. See Energy Heels on page 672.

 l Uncheck Automatic Birdsmouth Cut to enable the settings below. When checked, the birdsmouth is calculated 
based on the pitch and rafter depth and its values are listed here for reference. Only available when Rafters is the 
selected Framing Method. See Birdsmouth Cut on page 591.             

 l The Raise Off Plate and Birdsmouth settings do not affect the bearing wall heights.             

 o Enter a positive Raise Off Plate value in this field to build the roof to bear on Attic knee walls. A value of 6" builds 
the roof 6" above the wall top plates, bearing on short Attic walls.   

 o Enter a negative Birdsmouth Cut value to control the birdsmouth depth. For a birdsmouth depth of 3”, enter -3”. 
The location of the Baseline may change if you use the Raise Off Plate setting to specify the birdsmouth depth. See 
Birdsmouth Cut on page 591.            

 l Specify the Birdsmouth Seat, which is the horizontal depth of the birdsmouth cut. If you change this value, the 
Raise Off Plate/Birdsmouth Cut value will automatically adjust.            

 l To control the Birdsmouth Cut, you should also check Same Roof Height at Exterior Walls, above.             

 l The Vertical Structure Depth is reported here for reference. It can be changed on the STRUCTURE panel. See 
Structure Panel on page 585.            
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 l Specify the amount to Raise/Lower All Roof Planes, which controls the height of roof planes relative to the ceiling 
height specified for the rooms below. See Floor and Ceiling Heights on page 301.      

 o The default value is 0, which creates roof planes that bear on the wall top plates at the Ceiling Height of the room 
below.            

 o Increase this value to raise roof planes so they do not bear directly on the wall top plates. If roofs are raised 
sufficiently, Attic walls will automatically generate to support them. The exact height depends on the roof pitch.            

 o Decrease this value to drop roof planes downward and decrease the height of the bearing walls. If roofs are lowered 
sufficiently, they may extend into rooms, producing areas with angled ceilings.            

 l Check Ignore Top Floor to ignore the top living floor when roof planes are generated. Roof planes are built on the 
top plates of the walls below the top floor.            

 l Specify how you would like the eaves of roof planes with different pitches to meet. See Aligning Eaves on page 596.             

 l Check Same Roof Height at Exterior Walls to keep bearing walls the same height and change horizontal roof 
overhang distances as needed so that eaves meet correctly. 

 o When checked, this option ignores any overhang values you may have entered in the Wall Specification dialog. See 
Aligning Eaves on page 596.

 o Uncheck this option to raise or lower some roof planes relative to the wall’s top plate, allowing all horizontal 
overhangs to be the same unless a non-default value has been entered in the Wall Specification dialog. See Roof 
Directives in Walls on page 257.            

 l Check Same Height Eaves to keep the eave height for all roof planes the same. Roof planes are raised and lowered 
as needed so that eaves meet correctly. 

 o The eave height used when this box is checked is that of a roof plane using the default Pitch and Overhang values. 
When this box is checked, all roof planes are affected, including those that do not need adjustment in order to align 
with adjacent planes.

 o When Same Height Eaves is checked, any non-default overhang values specified in the Wall Specification dialog 
are used. Roof planes are raised or lowered so that the eave height is the same, regardless of the horizontal overhang.
            

 l Uncheck Allow Low Roof Planes only when an upper floor overhangs roof planes below.            

 
Roof Overhang

An overhang is measured horizontally from the outside Main Layer of exterior walls to the top outside edge of the fascia or, 
if no fascia is present, the end of the top of the rafter. The overhang does not include gutters. See The Main Layer on page 
262.     

 l Eave is the overhang distance outside bearing walls for roof planes using the default Pitch. If a particular roof plane 
has a different Pitch, its overhang will adjust to keep its fascia at the same height. Overhang may be greater for a 
shallower pitch, lesser for a greater pitch.      

 l Gable is the overhang distance at gable ends or rake walls.    

If the roof overhang values are not sufficient to extend past the 
outer surface of exterior walls, the walls may not generate 

correctly in 3D views. 
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  Options

 l Enter the Segment Angle at Curved Wall, which is the angle for roof segments automatically generated to cover a 
curved wall. A smaller angle produces more roof planes. Note that in some instances, slightly smaller or larger 
values will be used instead of the specified angle.         

 l Specify the Minimum Alcove Size, which is the minimum depth and width of an alcove in an otherwise straight 
exterior wall. Alcoves with both a depth and width less than this value are roofed over, while alcoves that are either 
wider or deeper than this value do not receive a roof.         

OPTIONS PANEL

  Eaves

 l Specify how the rafter and truss ends are Cut by selecting either Square Cut or Plumb Cut.         

 l Check Boxed Eave to produce horizontal boxed eaves or uncheck it for sloping eaves. You can also change this for 
individual roof planes in the Roof Plane Specification dialog. See Boxed Eaves on page 624.                     

 l Check Flush Eave to produce box eaves that build flush with the adjacent exterior wall. When unchecked, boxed 
eaves build to the gable fascia.                     

583



Home Designer Pro 2025 Reference Manual - Build Roof Dialog

 l Higher Eaves Boxed - If the selected roof plane contains more than one eave, check this box to box the higher 
eaves as well as the lower ones.                      

 l By default, Boxed Eaves extend from the inside edge of the roof fascia to the exterior Main Layer of the wall, 
enclosing the overhang area. If an exterior room with Use Soffit Surface for Ceiling checked is located between the 
roof’s baseline and an interior room, the Boxed Eave will extend across that room, as well. You can instead uncheck 
Default to Overhang and specify the Length of the boxed eaves. Not available if Flush Eave is checked.                     

 
Ceiling Break Lines

See Special Ceilings on page 305.                 

 l Specify how the Ceiling surface on the underside of roof planes is built. See     Vaulted and Cathedral Ceilings on 
page 306.                     

 l When Use Room Ceiling Finish is checked, the ceiling finish thickness and material on the undersides of roof 
planes are defined by the room below. Uncheck this box to enable the two settings that follow and define the ceiling 
finish as part of the roof planes instead. When this is unchecked, you can specify the Ceiling Surface material on the 
Materials Panel on page 585.                      

 l Check Has Ceiling to enable the Ceiling Thickness option. When this box is unchecked, the selected roof plane will 
have no ceiling surface at all and the “Ceiling Surface” component will not be available on the MATERIALS panel.                     

 l Specify the Ceiling Thickness, which is the thickness of the bottom surface of the ceiling plane.                      

 
Supply

Specify which material components to calculate in the Materials List. See Materials Lists on page 950. Only Gutter is 
available in the Roof Plane Specification dialog.

 l Uncheck Gutter to not include gutters on subsequently-built roof planes. This option affects both the Materials List 
and 3D views.                     

 l Check Edge Flashing to calculate edge flashing in the Materials List when one or more roof planes is against a wall.
                     

 l Check Ridge Vent to calculate ridge venting in the Materials List.                     

584



Home Designer Pro 2025 Reference Manual - Roof Planes

 l Check Metal Drip Edge at Eave to calculate metal drip edge along the eaves in the Materials List.                     

 l Check Metal Drip Edge at Gable to calculate metal drip edge along any gable eaves in the Materials List.                     

 l Check Valley Flashing to calculate valley flashing in the Materials List when two or more roof planes form a valley.
                     

  3D Display

 l When Show All Ridges is checked, a line along each hip between roof planes forming the conical roof above a 
curved wall displays in Vector Views. Uncheck this box to suppress these lines. See Rendered and Vector Views on 
page 771.    

STRUCTURE PANEL

The settings on the STRUCTURE panel of the Build Roof dialog are the same as those on the ROOF panel of the Build 
Framing dialog. Changes made in one dialog are also applied in the other. See Roof Panel on page 644.          

Note: Changes made on the Structure panel will not affect the structure 
of existing roof planes. To make changes take effect, rebuild the roof.

ARROW PANEL

The settings on this panel allow you to control the appearance of roof plane slope direction arrows. See Displaying Roofs on 
page 587.          

For information about these settings, see Arrow Panel on page 226.          

MATERIALS PANEL

The settings on this panel allow you to specify the default materials for the roof’s various components. See Materials Panel 
on page 750.

ROOF STYLES PANEL

The ROOF STYLES panel provides links to tutorial information about creating different roof styles automatically. Click on a 
roof style to launch the online Help to a page with information about the roof style you selected.  

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 967.          

 

Roof Planes
When creating a roof, it is helpful to know how to draw a roof plane manually and be familiar with its parts.           

DRAWING ROOF PLANES

Roof planes are CAD-based objects that are created and edited like much closed polylines, and also have pitch, 
elevation and structural properties.         
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Before drawing roof planes, you should set your roof defaults so that the 3D attributes of your roof planes are correct. See 
Roof Defaults on page 574.          

To draw a roof plane

 1.  Select Build> Roof> Roof Plane .           

 2.  Click and drag a Baseline from point 1 to point 2, as in the following example:          

Most roof planes are drawn over a wall, and the Baseline 
should be located directly above the outer edge of the wall’s 

Main Layer. See The Main Layer on page 262.

 3.  Release the mouse button at point 2 and move your cursor in the upslope direction. As you move the cursor, a 
preview outline of the roof plane displays.          

 4.  Click at point 3 to build the roof plane. Point 3 is located on the ridge edge of the roof plane.           

Note: You cannot manually draw roof planes when Auto Rebuild 
Roofs is enabled in the Build Roof dialog. See Roof Panel on page 
580.

THE BASELINE

The pitch direction and initial height of any roof plane - manual or automatic - is determined by its Baseline.          

A roof plane's Baseline is normally located over the outer main layer of the wall and is used as the pivot point for the roof 
plane when the pitch is changed. See The Main Layer on page 262.          

Baseline height is determined by the following formula:           

Elevation of the wall top plate + (Vertical Structure Depth - Vertical Birdsmouth Depth) = Baseline Height          

In a cross section, the Baseline is located directly above the outer surface of the main wall layer, at the top surface of the 
roof framing.           
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A roof Baseline displays as a separate line within its roof plane when the “Roofs, Baselines” layer is turned on. In 3D 
views, it can only be seen if the roof plane is selected.           

A Baseline has a tick mark at its center point which indicates the direction that the roof plane slopes upward. If the upslope 
tick is pointing the wrong direction, either rotate the entire roof plane or delete it and draw a new one.           

When drawing the Baseline of a roof plane, here are some things to consider:          

 l A Baseline does not have to be drawn over a wall, although it often is.
 l A Baseline drawn along a wall should be drawn over the outer edge of the wall’s Main Layer. It will, in fact, snap to 

that layer if possible.
 l The elevation of the top plate is defined by the ceiling height in the room. If the roof plane is not drawn over a wall, 

its height is based on the default ceiling height value for the current floor.
 l If a Baseline is drawn over the top of any other roof plane, the Baseline height equals the height of the existing roof 

plane at the point where you started drawing.

Once drawn, a Baseline can be selected in plan view and edited independent of the roof plane. See Editing Roof Baselines 
on page 591.

EAVE AND GABLE OVERHANGS

Roof overhangs are measured horizontally from the outside Main Layer of exterior walls to the top outside edge of the 
fascia or, if no fascia is present, the end of the top of the rafter. The overhang does not include  gutters. See The Main Layer 
on page 262. 

The location of a roof plane’s fascia and shadow boards also determines its area and the size of its polyline in plan view. 
See Polyline Panel on page 600.          

 

Displaying Roofs
The display of roof planes, their labels, and attributes such as gutters and ridge caps is controlled in the Layer Display 
Options dialog. See Layer Display Options Dialog on page 127.

Roof planes are drawn on the "Roof Planes" layer. If this layer is turned off and Auto Rebuild Roofs feature is turned on, 
changes made to the plan that cause the roof to rebuild will not automatically turn on its display. See Rebuilding Roofs on 
page 578. 
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IN PLAN VIEW

A number of layers associated with roof planes only display information in plan view, including "Roofs, Baselines" and 
"Roofs, Gable Lines".    

If the bottom surface of the roof extends below the ceiling height of a room, Ceiling Break lines will display, indicating 
where the flat ceiling ends and sloped ceiling begins. Ceiling Break lines are drawn on the “Ceiling Break Lines” layer in 
plan view only.   

In plan view, roof planes can display on any floor without affecting their height in 3D. To move the display of 
a roof plane to a new floor, select it in plan view and click either the Display on Floor Above or Display on 

Floor Below edit button. The display of group-selected roof planes can also be controlled in this manner.   

Any skylights or roof holes placed in a roof plane moved in this manner will move, as well. Other associated objects like 
Auto Dormers or gutters will not move, however.

PROJECTED VS ACTUAL SIZE

Like other closed-polyline based objects, roof planes, ceiling planes, and roof holes have a perimeter and an area. Roof 
objects are unique, however, in that they typically have a pitch. This means that their size is represented in two ways: 

 l Actual size, which is useful for calculating materials
 l Projected size, which is used in plan view and is useful for representing setbacks, overhangs, and other attributes.

When a roof object has a non-zero pitch, its projected size will be smaller than its actual size. The steeper the pitch, the 
larger the difference between the two. Any edges that are perpendicular to the pitch direction are not affected by the 
steepness of the pitch; however, all other edges are. In its specification dialog, you can specify the length of a roof object's 
selected edge's using either the Projected Length or the Length at Pitch. See Line Panel on page 208. 

Information about a roof object's projected and actual size is reported in its specification dialog. See Polyline Panel on page 
600.

Skylights are special type of roof object that also have projected size in plan view. See Skylights and Roof Holes on page 
612.

ROOF PLANE LABELS

Roof plane labels indicating the pitch and slope direction are located on the “Roofs, Labels” layer and can be set to display 
in floor plan              view. When a roof plane or a ceiling plane with a label specified is selected, its label will have a small square 
Move handle.

You can specify whether roof plane labels display the pitch in terms of rise and run or in decimal degrees by checking or 
unchecking Pitch in Degrees in the Build Roof dialog. See Roof Panel on page 580.         

A roof plane’s label can be customized in its specification dialog. See Label Panel on page 376.

Manually drawn Ceiling Planes  and Skylights  can also display labels when the “Roofs, Labels” layer is on. Unlike 

roof planes, these objects’ labels do not include a slope indicator and their Automatic Labels are blank; however, you can 
specify a custom label using text in their specification dialogs. See Ceiling Planes on page 605 and Skylights and Roof 
Holes on page 612.         

When a roof plane, ceiling plane or roof hole/skylight is selected in a 3D view, its label will display on a temporary basis if 
the “Roofs, Labels” layer is turned on.          
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IN CROSS SECTION VIEWS

When a roof or ceiling plane is viewed in a cross section, the layers that compose it can be seen, including the roof surface, 
sheathing, and the ceiling surface:         

 l If roof framing has been built, its display can be turned on, as well. See Displaying Framing on page 655.          
 l If a roof or ceiling plane is located over a room with Flat Ceiling Over this Room checked, the ceiling surface will 

not generate. See     Vaulted and Cathedral Ceilings on page 306.         

IN THE MATERIALS LIST

The materials that make up roof and ceiling plane assemblies are listed under different Categories in the Materials List:          

 l Roofing - Lists most materials associated with roofs, including roofing, sheathing, rafters and trusses, gutters, and 
skylights.         

 l Insulation - Insulation is calculated for roof and ceiling planes above rooms that do not have Flat Ceiling Over This 
Room checked. See Structure Panel on page 310.         

 l Wallboard - Lists ceiling materials for all rooms, including those that use the underside of the roof as their ceiling.         
 l Framing - Lists ceiling framing for manually drawn ceiling planes.          

See Materials Lists on page 950.          

 

Editing Roof and Ceiling Planes
A selected roof or ceiling plane can be edited in 2D and 3D using edit handles, edit toolbar buttons, and its specification 
dialog. In 3D views, you can also use the Material Painter .  See Material Painter Tools on page 747.          

The appearance and display of roof and ceiling planes can also be customized. See Displaying Roofs on page 587 and Roof 
Plane Specification Dialog on page 597.

By default, all roof planes are deleted and replaced whenever the roof is rebuilt using the Build Roof dialog. If you have 
manually edited roof planes and do not want them to be replaced, be sure to check Retain Edited Roof Planes in the Build 
Roof dialog. See Roof Panel on page 580.          

SELECTING ROOF PLANES

To select a roof or ceiling plane in plan view, click on one of its edges. When a roof or ceiling plane is selected, it is 
highlighted using the Selection Line and Fill Colors set in the Preferences dialog, and a full complement of edit handles 
displays, including one on each edge and each corner. See Selecting Objects on page 142.

A roof or ceiling plane’s Baseline can also be selected and edited in plan view. To select it, first select the roof plane and 
then click the Select Next Object  edit button. When the Baseline is selected, the roof plane is highlighted but edit 

handles only display at the midpoint and on each end of the Baseline. See The Baseline on page 586. 

Roof and ceiling planes can also be group-selected, although their editing options will be limited. See Selecting Multiple 
Objects on page 145.

Roof and ceiling planes can be selected and edited in 3D views; however, their Baselines cannot. 
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ROOFS AND AUTO REBUILD

Roof planes cannot be edited while Auto Rebuild Roofs is checked in the Build Roof dialog. If you try to do so, the 
program will prompt you to turn Auto Rebuild off.

An exception to this rule is the Material Painter  tool, which you can use to change the materials used by  individual 

roof planes without rebuilding the roof. Bear in mind, though, that any changes made using the Material Painter will not 
be retained if the roof is later rebuilt. See Material Painter Tools on page 747.   

2D SHAPE AND 3D ORIENTATION

There are two basic aspects to editing roof planes: 2D shape and 3D orientation.           

 l The 2D shape of a roof or ceiling plane can be edited much like a closed CAD polyline. As a plane's perimeter is 
reshaped in 2D, the program maintains its height and pitch in 3D. See Editing Closed Polyline-Based Objects on page 
157.          

 l The 3D orientation of a roof or ceiling plane is defined by its height, pitch, and its structure: all of which can be edited 
in its specification dialog.          

An understanding of these two concepts may require some practice, but allows you to design almost any kind of roof 
system.          

RAISING/LOWERING ROOF AND CEILING PLANES

The default height of a roof or ceiling plane is based on the ceiling height of the room below. See Floor and Ceiling Heights 
on page 575.

Roof planes can be raised or lowered in the Roof Plane Specification dialog. Begin by locking the Pitch, then change 
one of the Height values. See General Panel on page 598. 

Ceiling planes can be edited in a similar manner in their specification dialog. See General Panel on page 607.    

You can also raise or lower roof and ceiling planes using the Transform/Replicate Object edit tool. See 
Transform/Replicate Object Dialog on page 183.     

In addition, when a new floor is added to a plan, you can choose to move any roof planes displaying on the top floor up to 
the newly added floor level. Ceiling planes are not affected when a new floor is added. See Adding Floors on page 519.     

CHANGING A ROOF OR CEILING PLANE'S PITCH

The default pitch for a roof system as well as for manually-drawn ceiling planes is set in the Build Roof dialog. Non-default 
pitches can be set in the specification dialog of each exterior bearing wall defining a room on the top floor level of the plan. 
See Roof Directives in Walls on page 257.

Just as with its height, the pitch of a roof or ceiling plane can be modified on the GENERAL panel of its specification 
dialog. Begin by locking one of the Height values and then change the Pitch. 

If you choose to lock the Top of Plate height of a roof plane, the point about which the plane will pivot depends on whether 
Automatic Birdsmouth Cut is checked in the Build Roof dialog.

 l When it is checked, the roof plane will pivot about the top inside edge of the bearing wall's top plate.
 l When it is unchecked, it will pivot about the top outside edge of the top plate.

Changing a roof plane's pitch can affect how it connects to adjacent roof planes. See Connecting Roof and Ceiling Planes on 
page 595. 
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EDITING ROOF PLANE STRUCTURE

To create roof planes of a particular depth, begin by setting up the desired roof framing defaults, then build the roof. See 
Framing Defaults on page 627.      

If you later need to change the structure of the roof planes, make the needed change to the Framing Defaults, and then 
rebuild the roof. You can also edit roof structure on an individual roof plane basis. See Roof Plane Specification Dialog on 
page 597.      

BIRDSMOUTH CUT

The birdsmouth is the notch cut into a rafter where it rests on the wall top plate. You can control its vertical depth and the 
width of the birdsmouth seat in the Build Roof dialog. See Roof Panel on page 580.      

There are two ways to create a roof plane with no birdsmouth:      

 l Select Trusses as the Framing Method in the Build Roof dialog before drawing the roof plane.      
 l Specify a Raise/Lower All Roof Planes value of at least 1/16” in the Build Roof dialog.       

To change the birdsmouth depth after the roof is built, you can move the roof planes up or down, or change the pitch. For 
example, if you lock the pitch and raise the roof plane by one inch, you decrease the birdsmouth depth by one inch.      

EDITING ROOF BASELINES

The pitch direction and initial height of any roof plane - manual or automatic - is determined by its Baseline. See The 
Baseline on page 586.           

In plan view, a Baseline can be selected and edited independent of the roof plane. To select it, click on the roof plane at the 
location of the Baseline and then click the Select Next Object  edit button. The Status Bar tells you when the roof plane 

Baseline is selected. See Select Next Object on page 143.            

If a roof plane Baseline is moved, its height will not change. Instead, the height of the roof plane will be affected. In most 
cases, therefore, moving a roof plane’s Baseline independent of the roof plane itself is not recommended.           

If the angle of a roof plane’s Baseline is changed, the direction of the roof plane’s pitch will be modified. The Baseline 
Angle can be modified in either of two ways:           

 l In the Roof Plane Specification dialog. This will change its angle relative to the floor, and will tilt the roof plane along 
an axis perpendicular to its Baseline. This method is helpful when a specific eave angle is needed. See General Panel 
on page 598.          

 l Using its Rotate edit handle in plan view. This will change its angle relative to the roof plane’s eave or ridge and will 
modify the direction of the pitch. This method is best when the pitch direction matters more than the angle of the eave.          

 l Both of these methods can be used to modify the same roof plane, although the second approach makes it difficult to 
control both the pitch direction and eave angle, and is not recommended.           

The length of a roof plane Baseline can be lengthened or shortened using its edit handles without changing any of the roof 
plane’s attributes.           

ROOF EDGES AND WALLS

By default, the edges of a roof plane will automatically snap to the outer surface of a nearby parallel wall. You can disable 
this Special Snapping behavior for a selected roof plane in its specification dialog. See General Panel on page 598.      

After moving a corner edit handle, it may be difficult to make an edge parallel to an eave or a wall. Use the Make 
Parallel/Perpendicular 
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 edit button to align a roof or ceiling plane edge with a wall, another roof plane edge, or another object with a straight 

edge. See Make Parallel/Perpendicular on page 171.      

If opposite sides of a roof plane are parallel, Temporary 
Dimensions will display between them when one side is selected.

Sometimes, what appears to be a single, straight roof plane edge may actually be broken into two or more edges, which can 
affect your ability to align the edge properly.      

A single edge will have three edit handles; if more than three display, more than one edge is present. An extra handle can be 
removed manually by dragging it into an adjacent handle. You can also use Build> Roof> Fix Roofs . See Fix Roofs on 

page 577.     

When Bumping/Pushing  is enabled and CAD Stops Move is checked in the Roof Plane Specification dialog, a roof 

plane will bump against another roof plane, CAD or CAD based object as it is moved. Roof planes cannot push these 
objects, however. See Bumping/Pushing on page 168.      

LOCKING ROOF PLANES

When the roof plan is correct, roof planes can be locked to prevent them from being accidentally selected and changed. To 
do this, lock the “Roof Planes” layer. See Layer Display Options Dialog on page 127.

Locking roof planes will not prevent roof planes from being deleted if the floor they are on is deleted. See Locking Layers 
on page 126.         

ROOFS AND AUTO REBUILD

Roof planes cannot be edited while Auto Rebuild Roofs is checked in the Build Roof dialog. If you try to do so, the 
program will prompt you to turn Auto Rebuild off.

An exception to this rule is the Material Painter  tool, which you can use to change the materials used by  individual 

roof planes without rebuilding the roof. Bear in mind, though, that any changes made using the Material Painter will not 
be retained if the roof is later rebuilt. See Material Painter Tools on page 747.   

2D SHAPE AND 3D ORIENTATION

There are two basic aspects to editing roof planes: 2D shape and 3D orientation.           

 l The 2D shape of a roof or ceiling plane can be edited much like a closed CAD polyline. As a plane's perimeter is 
reshaped in 2D, the program maintains its height and pitch in 3D. See Editing Closed Polyline-Based Objects on page 
157.          

 l The 3D orientation of a roof or ceiling plane is defined by its height, pitch, and its structure: all of which can be edited 
in its specification dialog.          

An understanding of these two concepts allows you to design almost any kind of roof system.          

RAISING/LOWERING ROOF AND CEILING PLANES

The default height of a roof or ceiling plane is based on the ceiling height of the room below. See Floor and Ceiling Heights 
on page 575.

Roof planes can be raised or lowered in the Roof Plane Specification dialog. Begin by locking the Pitch, then change 
one of the Height values. See General Panel on page 598. 
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Ceiling planes can be edited in a similar manner in their specification dialog. See General Panel on page 607.    

You can also raise or lower roof and ceiling planes using the Transform/Replicate Object edit tool. See 
Transform/Replicate Object Dialog on page 183.     

In addition, when a new floor is added to a plan, you can choose to move any roof planes displaying on the top floor up to 
the newly added floor level. Ceiling planes are not affected when a new floor is added. See Adding Floors on page 519.     

CHANGING A ROOF OR CEILING PLANE'S PITCH

The default pitch for a roof system as well as for manually-drawn ceiling planes is set in the Build Roof dialog. Non-default 
pitches can be set in the specification dialog of each exterior bearing wall defining a room on the top floor level of the plan. 
See Roof Directives in Walls on page 257.

Just as with its height, the pitch of a roof or ceiling plane can be modified on the GENERAL panel of its specification 
dialog. Begin by locking one of the Height values and then change the Pitch. 

If you choose to lock the Top of Plate height of a roof plane, the point about which the plane will pivot depends on whether 
Automatic Birdsmouth Cut is checked in the Build Roof dialog.

 l When it is checked, the roof plane will pivot about the top inside edge of the bearing wall's top plate.
 l When it is unchecked, it will pivot about the top outside edge of the top plate.

Changing a roof plane's pitch can affect how it connects to adjacent roof planes. See Connecting Roof and Ceiling Planes on 
page 595. 

EDITING ROOF PLANE STRUCTURE

To create roof planes of a particular depth, begin by setting up the desired roof framing defaults, then build the roof. See 
Framing Defaults on page 627.      

If you later need to change the structure of the roof planes, make the needed change to the Framing Defaults, and then 
rebuild the roof. You can also edit roof structure on an individual roof plane basis. See Roof Plane Specification Dialog on 
page 597.      

BIRDSMOUTH CUT

The birdsmouth is the notch cut into a rafter where it rests on the wall top plate. You can control its vertical depth and the 
width of the birdsmouth seat in the Build Roof dialog. See Roof Panel on page 580.      

There are two ways to create a roof plane with no birdsmouth:      

 l Select Trusses as the Framing Method in the Build Roof dialog before drawing the roof plane.      
 l Specify a Raise/Lower All Roof Planes value of at least 1/16” in the Build Roof dialog.       

To change the birdsmouth depth after the roof is built, you can move the roof planes up or down, or change the pitch. For 
example, if you lock the pitch and raise the roof plane by one inch, you decrease the birdsmouth depth by one inch.      

EDITING ROOF BASELINES

The pitch direction and initial height of any roof plane - manual or automatic - is determined by its Baseline. See The 
Baseline on page 586.           

In plan view, a Baseline can be selected and edited independent of the roof plane. To select it, click on the roof plane at the 
location of the Baseline and then click the Select Next Object  edit button. The Status Bar tells you when the roof plane 

Baseline is selected. See Select Next Object on page 143.            
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If a roof plane Baseline is moved, its height will not change. Instead, the height of the roof plane will be affected. In most 
cases, therefore, moving a roof plane’s Baseline independent of the roof plane itself is not recommended.           

If the angle of a roof plane’s Baseline is changed, the direction of the roof plane’s pitch will be modified. The Baseline 
Angle can be modified in either of two ways:           

 l In the Roof Plane Specification dialog. This will change its angle relative to the floor, and will tilt the roof plane along 
an axis perpendicular to its Baseline. This method is helpful when a specific eave angle is needed. See General Panel 
on page 598.          

 l Using its Rotate edit handle in plan view. This will change its angle relative to the roof plane’s eave or ridge and will 
modify the direction of the pitch. This method is best when the pitch direction matters more than the angle of the eave.          

 l Both of these methods can be used to modify the same roof plane, although the second approach makes it difficult to 
control both the pitch direction and eave angle, and is not recommended.           

The length of a roof plane Baseline can be lengthened or shortened using its edit handles without changing any of the roof 
plane’s attributes.           

ROOF EDGES AND WALLS

By default, the edges of a roof plane will automatically snap to the outer surface of a nearby parallel wall. You can disable 
this Special Snapping behavior for a selected roof plane in its specification dialog. See General Panel on page 598.      

After moving a corner edit handle, it may be difficult to make an edge parallel to an eave or a wall. Use the Make 
Parallel/Perpendicular  edit button to align a roof or ceiling plane edge with a wall, another roof plane edge, or another 

object with a straight edge. See Make Parallel/Perpendicular on page 171.      

If opposite sides of a roof plane are parallel, Temporary 
Dimensions will display between them when one side is selected.

Sometimes, what appears to be a single, straight roof plane edge may actually be broken into two or more edges, which can 
affect your ability to align the edge properly.      

A single edge will have three edit handles; if more than three display, more than one edge is present. An extra handle can be 
removed manually by dragging it into an adjacent handle. You can also use Build> Roof> Fix Roofs . See Fix Roofs on 

page 577.     

When Bumping/Pushing  is enabled and CAD Stops Move is checked in the Roof Plane Specification dialog, a roof 

plane will bump against another roof plane, CAD or CAD based object as it is moved. Roof planes cannot push these 
objects, however. See Bumping/Pushing on page 168.      

LOCKING ROOF PLANES

When the roof plan is correct, roof planes can be locked to prevent them from being accidentally selected and changed. To 
do this, lock the “Roof Planes” layer. See Layer Display Options Dialog on page 127.

Locking roof planes will not prevent roof planes from being deleted if the floor they are on is deleted. See Locking Layers 
on page 126.         

DELETING ROOF PLANES

There are several ways to delete roof planes.

  Delete the entire roof quickly by selecting Build> Roof> Delete Roof Planes. 
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  You can also delete all roof planes at once in the Delete Objects dialog. See Delete Objects Dialog on page 192.

  In addition, you can select one or more roof planes or roof plane baselines, then press the Delete key or click the 
Delete edit button to delete it from the plan. See Deleting Objects on page 191.          

Generally speaking, roof planes cannot be deleted if they are locked. An exception to this rule occurs when an entire floor of 
a plan is deleted. Any roof planes present on a floor will be deleted when the floor is deleted, locked or not. See Deleting 
Floors on page 522.          

When a roof plane is deleted, any roof framing associated with it is automatically deleted, as well.          

 

Connecting Roof and Ceiling Planes
When a roof system is drawn correctly, roof planes will meet along geometrically correct lines to form ridges, hips, and 
valleys. There are a number of tools to help you achieve this when manually drawing or editing roofs.         

To generate roof planes that do not form a single, integrated system, consider using Roof Groups. See Roof Groups on page 
577.     

By default, all roof planes are deleted and replaced whenever the roof is rebuilt using the Build Roof dialog. If you have 
manually edited roof planes and do not want them to be replaced, be sure to check Retain Edited Roof Planes in the Roof 
Plane Specification dialog. See Roof Panel on page 580.          

Roof planes cannot be edited while Auto Rebuild Roofs is turned 
on. If you try to do so, the program will prompt you to turn it 

off.

JOIN ROOF PLANES

Two roof or ceiling planes can be joined at adjacent edges in both 2D and 3D using the Join Roof Planes edit button. 
To use this tool, first identify which edges of the roof planes can extend to meet at a ridge, hip, or valley. The 

program will join the two planes along the line where they intersect whenever possible.         

To use Join Roof Planes

 1.  Select a roof or ceiling plane on the edge to be joined to another plane.          

 2.  Click the Join Roof Planes  edit button or press the 2 key.          

 3.  Move your pointer to the edge of the second roof or ceiling plane that the first one needs to join to. When your 
pointer is over the second plane, this plane will highlight.          

 4.  Click on the edge of the second roof or ceiling plane to join it to the first plane.          

Note: Join Roof Planes cannot be used to join a roof plane and ceiling 
plane. Only planes of the same type can be joined using this tool.

If the planes are not close enough, or their shape is not correct, you may need to align their edges, remove extra edges, or 
move them closer.           

When roof or ceiling planes adjust, the program joins them at the proper location and the adjacent edges extend or contract 
to remain connected. If the joining of the two will completely eliminate or reverse an adjacent edge, the connection cannot 
be made.           
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LOCATING INTERSECTIONS

When roof planes of differing slopes meet, they create a ridge, hip, or valley. The Join Roof Planes  edit tool is the 

easiest way to move roof plane edges so that they meet correctly; but you can also locate roof plane intersection points 
where the ridge, hip or valley should be. Once you know where the planes will meet, you can drag edges or corners to those 
points.          

To find roof plane intersection points

 1.  Select the roof plane you would like to place intersection points on.

 2.  Click the Place Roof Plane Intersection Point  edit button.

 3.  Click the edge of another roof plane to place a temporary CAD Point at the geometrically accurate location where 
that edge would meet the selected roof plane.

 4.  Repeat these steps for additional edges as needed.

 5.  Once these intersection points are identified, you can snap the corners of the second roof plane to them.

ALIGNING EAVES

It is not uncommon for roof plans to feature more than one pitch. In order for the eaves of roof planes with different pitches 
to meet correctly at ridges and hips, you must control the roof planes’ heights and their horizontal overhang distances. Two 
options in the Build Roof dialog allow you to control how the eaves of automatically generated roof planes align. See Roof 
Panel on page 580.          

 l Same Roof Height at Exterior Walls maintains the default height of roof planes where they bear on exterior walls. 
The horizontal overhang distances of any non-default roof planes are adjusted so that they continue to join correctly 
with default roof planes.          

 l Same Eave Heights maintains the default roof plane height at the eaves as well as any non-default horizontal 
overhang distances. All roof planes are raised or lowered so that they all have the same height at the eaves as default 
roof planes.           

Roof planes that do not join other roof planes with different pitches at ridges or hips are referred to as Independent.           

 l When Same Roof Height at Exterior Walls is checked, Independent roof planes are not affected and will maintain 
any non-default overhang values.           

 l When both Same Roof Height at Exterior Walls and Same Eave Heights are checked, the overhangs of Independent 
roof planes will be adjusted to preserve their heights at both the exterior walls and the eaves.           
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MOVE TO BE COPLANAR

The Move to be Coplanar edit button allows you to move the selected roof plane to be coplanar (in the same plane) 
with the next selected roof plane. You can use this tool in both 2D and 3D views. The results can be easily seen in a 

cross section view. The two roof planes must have parallel Baselines for this to work.         

SET BASELINE HEIGHT DIALOG

If you manually draw a roof plane so that it bears on a wall at its Baseline, and is placed in the same location as an existing 
roof plane, the Set Baseline Height dialog will display. See The Baseline on page 586.          

 l Select Over Wall Top to create a roof plane that bears on the wall it is drawn over and has an overhang as specified 
in the Build Roof dialog. This option would be appropriate to produce a full height dormer. See Manually Drawn 
Dormers on page 618.          

 l Select Over the Existing Roof Plane to produce a roof plane with a height based on that of the roof plane below it 
rather than the wall. The Baseline height equals the top height of the existing roof at the point where you began 
drawing the new roof plane Baseline, and has no overhang. This option would be appropriate to create a dormer vent 
or cricket. See Crickets on page 618.          

 

Roof Plane Specification Dialog
Select one or more roof planes and click the Open Object edit button to open the Roof Plane Specification dialog. 

The Roof Plane Specification dialog has the following panels:
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GENERAL PANEL

There are four values that define the 3D orientation of a roof plane: Ridge Top Height, Baseline Height, Fascia Top 
Height, and Pitch.

Locking any of the Height values defines that value as the pivot point for the selected roof plane. Each of these dimensions 
is measured from the first floor default elevation of 0' - 0".

If you lock the Pitch and change a Height value, the roof plane moves vertically, keeping the same slope. It will not pivot.               

Changing these values does not affect the 2D representation of the roof plane.

  General

 l Specify the selected roof plane's Framing Method: either Trusses or Rafters. When Trusses is selected, the roof 
plane's Structure Thickness is derived from the default Top Chord Depth for roof trusses set in the Framing Defaults 
dialog; when Rafters is selected, the Structure Thickness is derived from the dialog. See Roof Panel on page 644 and 
Trusses Panel on page 647.

 
Height/Pitch

Specify the Height and Pitch of the selected roof plane(s). Heights are measured from the top surface of the roof plane(s) 
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rafters or trusses. See Roof Planes on page 585.     

 l The Top of Plate is defined by the ceiling height of the room below and is reported here for reference. N/A displays 
if no room is below the roof plane.     

 l Define the Ridge Top Height, or lock this value to make it the roof plane’s pivot point. If the roof plane's has 
multiple ridge lines, this setting is associated with the highest ridge.

 l Define the Baseline Height, or lock this value to make it the pivot point.     

 l Define the Fascia Top Height, or lock this value to make it the pivot point.     

Note: The Fascia Top height will decrease slightly if the fascia edge is 
aligned with the ridge top of another roof plane.

   l Specify the Pitch for the selected roof plane, or lock this value to move the roof plane vertically when a Height 
value is changed.

 l Check Pitch in Degrees to display the pitch value in degrees in all dialogs as well as in roof plane labels. Values 
between -89° and 89° can be entered. When Pitch in Degrees in unchecked, Pitch is described in terms of rise and 
run: x inches in 12 or x mm in 1000.

The diagram to the right of the Height/Pitch settings shows the location of the Lock point. If a Height/Pitch setting is 
currently selected for editing, its location will also be indicated using an arrow.

   l Select a radio button to choose whether to Show Diagram for Rafters or Trusses. The structure of the roof and 
location of the Top of Plate Lock point vary between these two options.

 
Measurements

Information about the structure of the selected roof plane(s) displays here for reference.     

 l Specify the Structure Thickness of the selected roof plane(s). The default Structure Thickness is set in the Framing 
Defaults dialog. See Framing Defaults Dialog on page 636.    

 l The Birdsmouth Depth is the plumb or vertical depth of the birdsmouth cut. To change it, move the roof plane 
some way. For example, if you lock the pitch and raise the roof plane by one inch, you will decrease the birdsmouth 
depth by one inch. See Birdsmouth Cut on page 591.    

 l The Birdsmouth Seat is the horizontal width of the birdsmouth cut. This value is dynamically linked to the 
birdsmouth depth - if one changes, so does the other.    

 l The Vertical Structure Depth is defined by measuring a plumb line across the roof plane structure. The degree of 
pitch affects the Vertical rafter width. The greater the pitch, the greater the vertical structure depth.    

 l Overhang from Baseline is the horizontal overhang measured from the Baseline to the eave.    

 l Mark as Edited - When an automatically generated roof plane is modified, the program marks it as "edited", giving 
you the option of retaining it when the roof is rebuilt. Uncheck this box to remove this status from the selected roof 
plane. See Rebuilding Roofs on page 578.    

 l Mark as Edited is only available for automatically generated roof planes. If a manually drawn roof plane is 
selected, the words Manual Roof Plane will display here instead.

 l When Use Special Snapping is checked, the selected roof plane's edges will automatically snap to the outside 
surface of walls that it may butt against. Uncheck this to prevent the roof plane from snapping to any nearby walls.

 
Baseline

Specify the angle of the selected roof plane’s Baseline, relative to the XY axis. See Editing Roof Baselines on page 591.     
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 l A positive Baseline Angle value causes the Baseline to tilt upward from its default height. A negative value causes it 
to tilt downward. The top heights of any walls under the selected roof plane will become angled, as well.     

 l The Baseline Height defined above can be maintained at either the Start or End point. In plan view, the Baseline 
direction is clockwise around the house.

OPTIONS PANEL

The settings on the OPTIONS panel are the same as those on the panel of the same name in the Build Roof dialog, but affect 
the selected roof plane only. See Options Panel on page 583.         

STRUCTURE PANEL

The settings on the STRUCTURE panel are similar to those on the ROOF panel of the Build Framing dialog, but apply to the 
selected roof plane only. See Roof Panel on page 644.         

One check box is unique to the STRUCTURE panel of the Roof Plane Specification dialog: check Retain Roof Framing to 
keep the selected roof plane’s framing from being deleted and replaced when roof framing is rebuilt.         

POLYLINE PANEL

The POLYLINE panel states the length of the roof plane's Perimeter and its enclosed Area, calculated using several different 
methods.

 l The Perimeter is the total length of the roof plane’s sides, not including fascia, with its pitch taken into account. It 
does not equal the perimeter as measured in plan view unless the roof plane has no fascia and the pitch is 0.              

 l The Framing Area is the area of the roof plane’s framing, not including the fascia, with the pitch taken into account. 
It is slightly smaller than the Roof Surface Area as roofing typically overhangs the framing by a small amount.             

 l The Projected Area is the area of the roof plane polyline, including fascia, as seen in plan view. It does not equal the 
Roof Surface Area unless the pitch is 0.             

 l The Roof Surface Area is the area of the roof plane’s top surface, which covers the fascia, with the pitch taken into 
account.             

 l The Overhang Area is the area of the roof plane’s overhang, including fascia, with its pitch taken into account.              
 l The Projected Overhang Area is the area of the roof plane’s overhang, including fascia, as seen in plan view. Not 

available for Ceiling Planes or Roof Holes.
 l The Overhang Area is the area of the roof plane’s overhang, including fascia, with its pitch taken into account. Not 

available for Ceiling Planes or Roof Holes.
 l The Projected Overhang Area is the area of the roof plane’s overhang, including fascia, as seen in plan view. Not 

available for Ceiling Planes or Roof Holes.

SELECTED LINE PANEL

The SELECTED LINE panel is similar to the Line panel of the Line Specification dialog. See Line Panel on page 208.          
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LINE STYLE PANEL

For information about the settings on this panel, see Line Style Panel on page 209.          

FILL STYLE PANEL

The settings on the FILL STYLE panel control the appearance of the selected roof plane in plan view. For information about 
these settings, see Fill Style Panel and Dialogs on page 132.           

ARROW PANEL

The settings on the ARROW panel allow you to control the appearance of the selected roof plane’s slope direction arrow. See 
Displaying Roofs on page 587.          

For information about these settings, see Arrow Panel on page 226.          

MATERIALS PANEL

The settings on the MATERIALS panel allow you to specify materials for the selected roof plane’s various components. For 
more information, see Materials Panel on page 750.          

The “Ceiling Surface” component is only available when Use Room Ceiling Finish is unchecked               and Has Ceiling, 
checked, on the OPTIONS panel. See Options Panel on page 583.

LABEL PANEL

Roof plane labels display when the “Roofs, Labels” layer is turned on and use the Text Style assigned to that layer. See 
Roof Plane Labels on page 588.          

For information about the settings on this panel, see               Label Panel on page 376.         

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. See Components Panel on page 967.          

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in the materials list. For more information, see 
Object Information Panel on page 968.   

 

Roof Baseline Polylines
Typically, the program builds an automatic roof based on the settings in the Build Roof dialog and on the ROOF panel of the 
Wall Specification dialog, along with the layout of the exterior walls and floor and ceiling heights.           

If you want to build a roof that diverges from the footprint of your building as well as the roof directives in the exterior 
walls, you can use Roof Baseline Polylines.          
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To create roof baseline polylines

 1.  Select Build> Roof> Build Roof .          

 2.  On the BUILD panel of the Build Roof dialog, check Make Roof Baseline Polylines.           

 3.  Click OK. A set of roof Baselines is created along the outside edge of the Main Layer of the exterior walls, forming 
one or more closed polylines.          

As with roof planes, the heights of Roof Baseline Polylines are determined by ceiling heights in the plan. If roof planes will 
be built at more than one height, a separate baseline polyline is created for each height.          

Once created, a Roof Baseline Polyline can be edited in a variety of ways, then used as the basis for the roof then next time 
it is built automatically.           

To create a new roof using the directives in your Roof Baseline Polyline(s), check Use Existing Roof Baselines in the Build 
Roof dialog and click OK. See Roof Panel on page 580.          

DISPLAYING ROOF BASELINE POLYLINES

Roof Baseline Polylines are placed on the “Roofs, Baseline Polylines” layer               and use the Text Style assigned to that layer. 
See Layer Attributes on page 125.

Roof directive information displays along each edge of the polyline, including:          

 l V - vertical (against wall);          
 l G -gable/shed;          
 l K - knee wall;          
 l L - lower (extend slope downward).          

If the directive information includes the pitch, the roof plane slopes toward that edge; if it includes the word (vert), it does 
not.          

EDITING ROOF BASELINE POLYLINES

A Roof Baseline Polyline’s shape can be edited much like a CAD polyline using its edit handles and edit toolbar buttons. 
See Editing Closed Polyline-Based Objects on page 157.            

Roof Baseline Polylines always form a closed area with straight sides only. They cannot be severed or curved, but additional 
joints or corners can be added.          

In addition to length and direction, each Roof Baseline Polyline edge has roof directives associated with it, much like the 
roof directives in individual walls. See Roof Directives in Walls on page 257.          

AN EXAMPLE

In order for it to reflect any changes that you make to a Roof Baseline Polyline, the roof must be rebuilt. For a simple 
example of Roof Baseline Polyline editing, consider an L-shaped house, with a rectangular roof. The inner part of the ’L’ is 
a patio that is covered under the same roof.          
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On the left is the baseline polyline as it was originally produced and the roof plan it creates.          

To model the roof plan shown on the right

 1.  Select the Roof Baseline Polyline along its bottom-most edge.          

 2.  Click the Intersect/Join Two Lines  edit button. See Reshaping Objects on page 174.          

 3.  Click the left-most edge to remove the two intervening edges.           

 4.  A message box informs you that “The system must delete intervening lines (those on the inside of the L) to join the 
two selected lines.” Click OK.          

 5.  Open the Build Roof dialog and select the Build Roof Planes and Use Existing Roof Baseline check boxes to 
model the roof plan shown on the right side of the image above.          

 

Roof Baseline Specification Dialog
Like walls, each line of a Roof Baseline Polyline contains roof directives that affect automatic roof generation. Select 
any edge of a Roof Baseline Polyline click the Open Object edit button open the Roof Baseline Specification dialog.

ROOF BASELINE PANEL

The settings on the ROOF BASELINE panel control the roof directives associated with the selected edge of the Roof Baseline 
Polyline. See Selected Edge on page 143.
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Baseline Height

See The Baseline on page 586. 

  Roof Options

 l The first six options: Hip Wall, Full Gable Wall, Dutch Gable Wall, High Shed/Gable Wall, Knee Wall, and 
Extend Slope Downward are the same as those in the Wall Specification dialog. See Roof Panel on page 272.          

 l Select Against Wall if the roof plane rising from this baseline butts against an exterior wall. This is similar to 
checking High Shed/Gable Wall.          

 
Pitch Options

These settings are also found in the Wall Specification dialog. See Roof Panel on page 272.         

 l Unlike the Pitch value elsewhere, this value is not a Dynamic Default here; however, you can click on the Default 
icon to load the current default Pitch. See Build Roof Dialog on page 579.          

POLYLINE PANEL

The POLYLINE panel reports general information about the size and shape of the selected Roof Baseline Polyline. See 
Polyline Panel on page 600.           

SELECTED LINE PANEL

This panel is similar to the LINE panel of the Line Specification dialog. See Line Panel on page 208.          

LINE STYLE PANEL

For information about the settings on this panel, see Line Style Panel on page 209.          

FILL STYLE PANEL

The settings on the FILL STYLE panel control the appearance of the selected Roof Baseline Polyline in plan view. See Fill 
Style Panel and Dialogs on page 132.          
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Roof and Ceiling Framing
Roof framing can be both drawn manually and generated automatically. You can also combine the two techniques. As with 
other kinds of framing, it is often easiest to begin by generating roof framing automatically and then editing it as needed. 
See Manual vs. Automatic Framing on page 630.

Roof Trusses  cannot be generated automatically - they must be drawn manually and then replicated. If you intend to 

use Roof Trusses, make sure the settings in the Build Roof dialog are properly defined before you build the roof. See Roof 
Trusses on page 664.

When using a combination of Roof Trusses and stick framing, begin by drawing the roof planes and ceiling planes. When 
they are in place, draw and replicate the Roof Trusses.  Finally, automatically generate or manually draw the stick framing 
and edit it as needed. See Mixing Rafters and Trusses on page 632.

Framing for manually drawn Ceiling Planes  cannot be drawn manually - it must be automatically generated. The 

framing for manually drawn Ceiling Planes is generated when roof framing is built and uses the settings in the Build Roof 
dialog as defaults. Once it has been created, it can be edited. See Ceiling Planes on page 605.

REBUILDING ROOF FRAMING

If roof framing defaults are modified after the roof and roof framing are built, neither will update automatically. In order to 
update the model you need to rebuild the roof, then rebuild the roof framing. 

You can also modify the roof framing settings for individual roof planes, and then either build roof framing or click the 
Build Framing for Selected Object  edit button. See Keeping Framing Current on page 658.

 

Ceiling Planes
Ceiling planes are drawn the same way as roof planes and are edited using the same tools. They are useful for 
creating custom vaulted ceilings. See     Vaulted and Cathedral Ceilings on page 306.         

Ceiling planes are drawn using the same default pitch as roof planes, specified in the Build Roof dialog. See Build Roof 
Dialog on page 579.          
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If you wish, you can specify the desired pitch in the Build Roof dialog before drawing a ceiling plane, or you can change 
the pitch after it is drawn in the Ceiling Plane Specification dialog. See Ceiling Plane Specification Dialog on page 606.          

There are a few things to remember when drawing ceiling planes.          

 l Ceiling planes should be created over rooms that have Flat Ceiling Over this Room unchecked in the Room 
Specification dialog. See Structure Panel on page 310.          

 l The Baseline of a ceiling plane should be drawn along the outer surface of the bearing wall’s Main Layer. This allows 
the ceiling plane to extend over and be supported by the wall. See The Main Layer on page 262.           

 l The sloping edge at the side of a ceiling plane should butt to the inside of the wall.          
 l Ceiling planes act independent of the roof planes above.          
 l Usually, the pitch of a ceiling plane is lower than the pitch of the corresponding roof plane.           
 l Ceiling planes can be joined together using the Join Roof Planes  edit button. See Join Roof Planes on page 595.          

 l Select a ceiling plane and click the Open Object  edit button to open the Ceiling Plane Specification dialog. See 

Ceiling Plane Specification Dialog on page 606.          

DISPLAYING CEILING PLANES

Ceiling planes are drawn on the “Ceiling Planes” layer.         

Manually drawn Ceiling Planes  can also display labels when the “Roofs, Labels” layer is on. See Roof Plane Labels on 

page 588.          

EDITING CEILING PLANES

Ceiling planes can be edited much like roof planes using their edit handles and edit toolbar buttons. See Editing Roof and 
Ceiling Planes on page 589.           

Ceiling planes can also be edited in their specification dialog. See Roof Plane Specification Dialog on page 597.           

As with roof planes, the ceiling planes layer can be locked to prevent them from being selected.           

DELETING CEILING PLANES

There are several ways to delete ceiling planes. See Deleting Objects on page 191.          

  Select Build> Roof> Delete Ceiling Planes to delete all ceiling planes in the current plan.          

  Ceiling planes can also be deleted at once in the Delete Objects dialog. See Delete Objects Dialog on page 192.         

  Select a ceiling plane or group of ceiling planes, then click the Delete edit button or press the Delete key.          

 

Ceiling Plane Specification Dialog
Select a ceiling plane and click the Open Object edit button to open the Ceiling Plane Specification dialog.

The Ceiling Plane Specification dialog is similar to the Roof Plane Specification dialog. See Roof Plane Specification 
Dialog on page 597.
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The Ceiling Plane Specification dialog has the following panels:

GENERAL PANEL

There are four values that define the 3D orientation of a ceiling plane: Ridge Height, Height Inside Wall, Height Outside 
Wall, and Pitch.          

Locking any of the Height values defines that value as the pivot point for the selected ceiling plane. Each of these 
dimensions is measured from the first floor default elevation of 0' - 0".           

If you lock the Pitch and change a Height value, the ceiling plane moves vertically, keeping the same slope. It will not 
pivot.           

Changing these values does not affect the 2D representation of the ceiling plane.          

 
Height/Pitch

Specify the Height and Pitch of the selected ceiling plane. Heights are measured to the bottom surface of the ceiling plane’s 
rafters or trusses, at the center point of the ceiling plane’s baseline. See The Baseline on page 586.                 

 l Select the Elevation Reference, which is where the Height values below are measured from.           

 l Define the Ridge Height, or lock this value to make it the ceiling plane’s pivot point.          

 l Define the Height Inside Wall, or lock this value to make it the ceiling plane’s pivot point. If the plane is drawn 
over a wall, this is located at the inside surface of the wall’s Main Layer.          

 l Define the Height Outside Wall, or lock this value to make it the ceiling plane’s pivot point. Only available when a 
ceiling plane is drawn over a wall, this is the height of the lower edge of the ceiling rafters, were they not clipped by 
the wall below.           

 l Specify the selected ceiling plane’s Pitch, or lock this value to move the plane vertically when a Height value is 
changed.           
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 l Check Pitch in Degrees to display the Pitch value in degrees               in all dialogs as well as in roof plane labels.  Values 
between -89° and 89° can be entered. When Pitch in Degrees in unchecked, Pitch is described in terms of rise and 
run: x inches in 12 or x mm in 1000. See Roof Pitches in Degrees on page 625.

 
Measurements

Information about the structure of the selected ceiling plane(s) displays here for reference.

 l Specify the Structure Thickness. The default Structure Thickness is the same as that for roof planes and is set in the 
Framing Defaults dialog. See Framing Defaults Dialog on page 636.         

 l The Vertical Rafter Depth is defined by measuring a plumb line through the ceiling structure. The greater the pitch, 
the greater the vertical structure depth.         

 l The Top of Plate value is the top plate height of the bearing wall, and is also the ceiling height of the room.         

 l Overhang From Wall Inside - Only appearing when a ceiling plane is drawn over a bearing wall, this is the 
horizontal distance from the Baseline to the inside Main Layer surface of the wall. The Baseline is typically drawn 
over the outside Main Layer surface, so this value is equal to the wall’s Main Layer thickness.         

 l Clip End - This is the amount a ceiling rafter’s underside must be clipped at its lower end to rest on the wall top 
plate, and is zero if the ceiling plane was not drawn over a bearing wall. This value is equal to the ceiling plane’s 
rise in slope over the distance of the Overhang from Inside Bottom.

The Outside Bottom value plus the Clip end value equals the Top of Plate value.         

 
Ceiling Finish

Specify how the Ceiling Finish surface on the underside of the selected ceiling plane is built.              

 l When Use Room Ceiling Finish is checked, the selected ceiling plane’s ceiling finish thickness and material are 
defined by the room below and the “Ceiling Surface” component will not be available on the MATERIALS panel. 
Uncheck this box to define the ceiling finish as part of the ceiling plane and enable the Ceiling Thickness option.         

 l Specify the Ceiling Thickness, which is the thickness of the bottom surface of the ceiling plane.          

POLYLINE PANEL

The POLYLINE panel states the length of the ceiling plane’s Perimeter, its Framing Area, and its Projected Area. See 
Polyline Panel on page 600.           

SELECTED LINE PANEL

This panel is similar to the LINE panel of the Line Specification dialog. See Line Panel on page 208.          

LINE STYLE PANEL

For information about the settings on this panel, see Line Style Panel on page 209.          

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected ceiling plane in plan view. For information about 
these settings, see Fill Style Panel and Dialogs on page 132.          
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MATERIALS PANEL

The “Ceiling Surface” material can be specified here. It is only available, however, when Use Room Ceiling Finish is 
unchecked on the GENERAL panel.         

For more information about the settings on this panel, see Materials Panel on page 750.         

LABEL PANEL

Ceiling plane labels display when the “Roofs, Labels” layer is turned on and use the Text Style assigned to that layer. The 
Automatic Label for ceiling planes is blank, but you can specify a custom label. See Roof Plane Labels on page 588.         

For information about the settings on this panel, see Label Panel on page 376.         

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. See Components Panel on page 967.         

 

Gable/Roof Lines
The Gable/Roof Line tool can be used to automatically generate a gable above the bearing wall of a hip roof plane. It 
is best used in situations where roof directives in walls are not possible. For example:         

 l Where a wall is not present, such as across the front of an alcove;         
 l Over a Bay, Box, or Bow Window.             

See Roof Directives in Walls on page 257.         

In addition, the Gable Over Door/Window edit button allows you to add a small Gable/Roof Line over one or more 
selected doors or windows the next time automatic roof planes are built.

Gable/Roof Lines display in plan view when the “Roofs, Gable Lines” layer is set to display and can be selected and edited 
much like regular CAD lines. See Editing Line-Based Objects on page 146.          

CREATING A GABLE

To create a gable using a Gable/Roof Line

 1.  Select Build> Roof> Gable/Roof Line , then click and drag to draw a line outside the exterior wall that you 

want to create a gable over.         

 2.  Position the Gable/Roof Line within 10 feet (2260 mm) of the wall’s Main Layer but not touching it. See The Main 
Layer on page 262.         

 l Make sure that the Gable/Roof Line is exactly parallel to the exterior wall.          

 3.  Resize the Gable/Roof Line so that it is the length of the desired gable.         

 l The length of the Gable/Roof Line determines the gable width at the wall Main Layer, not at the overhang.          

 l At the larger roof eave, a gable roof is wider than the gable line by twice the overhang distance.         

 4.  You can specify the pitch of the gable roof planes and their overhang in the Gable Line Specification dialog. See 

609



Home Designer Pro 2025 Reference Manual - Gable/Roof Lines

Gable Line Specification Dialog on page 612.         

 5.  Select Build> Roof> Build Roof  and regenerate the roof. See Build Roof Dialog on page 579.         

To use the Gable Over Door/Window tool

 1.  Select one or more doors or windows.          

 2.  Click the Gable Over Door/Window  edit button.         

 l Gable Over Door/Window is not available for openings placed in Full Gable Walls or for Bay, Box or Bow 
Windows. See Bay, Box, Bow Windows and Roofs on page 437.         

 3.  In the Gable Line Specification dialog, specify the desired Pitch and Overhang for the gable roof. See Gable Line 
Specification Dialog on page 612.         

 4.  The next time automatic roof planes are built, gables will be created over each of these doors and windows.         

 l Each gable will extend 12” (300 mm) on either side of its door or window.         

 l If two of these openings are within 30” (750 mm) of each other on the same wall, a single gable will be created.          

 l If you move or resize the door or window(s), the associated Gable/Roof Line will not update until the roof is built 
again.          

 5.  There are several ways to remove a Gable Over Door/Window:

 l Select the door(s) or window(s) and click the Delete Gable Over Opening  edit button.

 l Select the gable line and click the Delete  edit button. 

 l All Gable/Roof Lines can be deleted using the Reset to Defaults dialog. See Reset to Defaults on page 59.

 l The next time the roof is built, the gable or gables will be removed.          

610



Home Designer Pro 2025 Reference Manual - Gable/Roof Lines

COVERING AN ALCOVE

A Gable/Roof Line  can also be used to maintain a roof plane baseline where there is no wall below. For example, you 

can use it to extend a roof plane across an alcove, rather than wrap into it.          

In order for a Gable/Roof Line to direct the roof to extend over an alcove or other area where no wall is present, it must be 
aligned with the exterior walls’ Main Layer.          

COVERING A BAY

A Gable/Roof Line  drawn across a bay causes a gable to be built above the bay when roofs are automatically 

generated.         

In order for the gable to be built, at least one end of the Gable/Roof Line must extend past the side walls of the bay.          

If the Gable/Roof Line is drawn along the outer edge of the bay’s outer wall’s Main Layer, the resulting gable will extend 
only to the eave of the larger roof. Draw the Gable/Roof Line beyond the bay’s outer wall to extend out past the larger 
roof’s eave.           
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Gable Line Specification Dialog
Select a gable line and click the Open Object edit button to open the Gable Line Specification dialog. This dialog 
also opens whenever the Gable Over Door/Window  edit button is clicked. See Gable/Roof Lines on page 609.         

GABLE LINE PANEL

The settings on this panel affect the structure of the two roof planes associated with the selected Gable/Roof Line.         

The defaults for these settings are set in the Build Roof dialog. See Roof Panel on page 580.         

 l Specify the Pitch of the roof planes that form the gable.         
 l Specify the Overhang of the roof planes that form the gable.          

LINE PANEL

The settings on the LINE panel are available for a variety of other objects in the program. See Line Panel on page 208.         

LINE STYLE PANEL

The settings on the LINE STYLE panel are available for a variety of other objects in the program. See Line Style Panel on 
page 209.         

ARROW PANEL

The settings on the ARROW panel are available for a variety of other objects in the program. See Arrow Panel on page 226.         

 

Skylights and Roof Holes
Select Build> Roof> Skylight to insert a flat panel skylight with a frame into a single roof plane, create a hole in the 
roof and the ceiling below, and also a shaft between the roof and ceiling holes.

Select Build> Roof> Roof Hole to create a hole in the roof and the ceiling below as well as a shaft between the two 
holes.
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A skylight and roof hole in plan view and 
Glass House rendering.   

CREATING SKYLIGHTS AND ROOF HOLES

To create a Skylight or a Roof Hole, select either tool and then click and drag to draw a rectangular polyline within a single 
roof plane. With either tool active, you can also click once within a roof plane to place an object measuring 2' x 2', as 
measured in plan view with the roof pitch not taken into account.

To place a skylight in a vaulted ceiling, uncheck Flat Ceiling Over This Room in the Room Specification dialog, draw the 
Ceiling Planes to produce the vault and edit them as needed, and then draw the skylight. See Structure Panel on page 310.

Note: If a sloped ceiling plane is present under the skylight, a hole in this 
ceiling plane is automatically produced. This hole is visible, and may be 
located directly under the roof hole. It can be moved and edited 
separately.

DISPLAYING SKYLIGHTS AND ROOF HOLES

Skylights and roof holes are placed on the "Roofs, Openings" layer. Although they are inserted into roof planes, skylights 
and roof holes are able to display in plan view when their containing roofs do not. Skylights are also able to display 
independent of their containing roofs in 3D views. See Displaying Objects on page 124.

In plan view, skylights and roof holes are represented using their projected size: the steeper the pitch of the roof, the more 
affected a skylight or roof hole's shape in plan view will differ from its actual shape. The true size and shape of skylights 
and roof holes is only represented in plan view when they are inserted into a roof plane with a pitch of 0.  To create a 
skylight of a particular size, therefore, its size must be set in its specification dialog rather than using edit handles or using 
the Edit Skylight Shape  tool. See Edit Skylight Shape on page 614, below.

Both skylights and roof holes can display labels in plan views when the "Roofs, Labels" layer is turned on. Automatic 
skylight and roof hole labels report the object's size using the same format that window labels use. See Window Labels on 
page 417.

Skylights are counted in the Roofing category of the Materials List, while the shaft material of Roof Holes is calculated 
under Wall Board. See Materials Lists on page 950.
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EDITING SKYLIGHTS AND ROOF HOLES

A roof hole is essentially a feature of its containing roof plane's shape and can be edited much the same way roof planes and 
other closed-polyline based objects are using the edit handles and edit toolbar buttons. See Editing Roof and Ceiling Planes 
on page 589.

Skylights, on the other hand, are a special type of inserted object with editing options that are restricted because of the 
difference between their actual size and their projected size. Because the actual size of a skylight is not usually represented a 
plan or camera view, the only way to resize one is in its specification dialog or using the Edit Skylight Shape  edit tool. 

See              Skylight/Roof Hole Specification Dialog on page 614.

Skylights and roof holes should always be contained by a single roof plane. If either object type extends past a roof plane 
edge, the results may be unexpected. If the roof plane is deleted, any skylights or holes it contains are also deleted. 

EDIT SKYLIGHT SHAPE

The Edit Skylight Shape edit tool lets you make changes to a selected skylight's actual shape. Not available when 
skylights are group-selected.

When you click this edit button, a Skylight Detail Window opens, showing the shape of the skylight's hole represented by a 
closed CAD polyline. This polyline can be edited to produce the desired shape, or it can be deleted and replaced with a new 
closed polyline created using a selection of CAD drawing tools. Only one CAD object can be present in a Skylight Detail 
Window, and only a closed polyline shape can be saved as a Skylight Detail. When you close this view window, the 
program will give you an opportunity to save your changes and apply them to the selected skylight. See Editing Closed 
Polyline-Based Objects on page 157.

 

             Skylight/Roof Hole Specification Dialog
Select a skylight or a roof hole and click the Open Object edit button to open the Skylight/Roof Hole Specification 
dialogs. See Skylights and Roof Holes on page 612.    

GENERAL PANEL

 
Skylight

Not available when a roof hole is selected.
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 l Select a Shape from the drop-down list: "Circle", "Ellipse", "Oval", or "Rectangle". If the Skylight's shape has been 
edited using the Edit Skylight Shape edit tool, "Custom" will be the selected Shape. See Edit Skylight Shape on 
page 614.

 l Specify the Width and Height of the selected Ellipse, Oval, or Rectangle-shaped skylight. The Height value 
describes the skylight's actual size: not its projected size as measured in plan view.

 l When the selected skylight is a Circle, specify its Diameter.

 l Select which part of the skylight to Lock when it is resized: its Top, Center, or Bottom.

 
Frame

Not available when a roof hole is selected.

 l Check Display in Plan View to draw the selected skylight's frame in plan view.

 l Specify the Width and Height of the skylight's Frame.

 
Inside Hole Rim

Specify how the hole for the skylight is framed as well as the shape of the skylight well where it passes through the roof 
plane.     

 l Select Square Sides to cut the framing for the skylight square to the pitch of the roof.

 l Select Plumb Sides to produce framing for the skylight that is plumb-cut.

 l Select Plumb/Square to produce framing with the bottom edge plumb-cut and the top edge, square-cut.

 
Preview

A preview of the selected skylight displays here. Not available when a roof hole is selected. See Dialog Preview Panes on 
page 21.   

POLYLINE PANEL

The POLYLINE panel states the roof hole/skylight’s Perimeter, its Framing Area, and its Projected Area. See Polyline 
Panel on page 600.

SELECTED LINE PANEL

This panel is similar to the LINE panel of the Line Specification dialog. See Line Panel on page 208.          

LINE STYLE PANEL

For information about the settings on this panel, see Line Style Panel on page 209.

FILL STYLE PANEL

The settings on the FILL STYLE panel control the appearance of the selected roof hole or skylight in plan view. See Fill Style 
Panel and Dialogs on page 132.

MATERIALS PANEL

For information about the MATERIALS panel, see Materials Panel on page 750.
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LABEL PANEL

Roof hole and skylight labels display when the “Roofs, Labels” layer is turned on and use the Text Style assigned to that 
layer. The Automatic Label for these objects is blank, but you can specify a custom label. See Roof Plane Labels on page 
588.

For information about the settings on this panel, see Label Panel on page 376.         

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. See Components Panel on page 967.    

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in schedules and the materials list. See Object 
Information Panel on page 968.          

 

Dormers and Crickets
Dormers can be drawn manually or placed automatically using the Auto Dormer tools. Automatic Dormers 
can be placed only under certain conditions:          

 l Automatic Dormers can only be placed entirely within a single roof plane. They cannot extend past the eaves or ridge 
of this roof plane.         

 l Automatic Dormer side walls cannot be positioned above other walls in the plan.         

If you click within a roof plane to place an automatic dormer, but click too close to an eave or the ridge, a dormer will not 
be created; however, its outline will. Move this outline box to a location that meets the dormer’s requirements and it will be 
created.         

Automatic dormers reside by default on their own layer, “Roofs, Dormers”. The display of automatic dormer components is 
not controlled by this layer; however, you can lock this layer to prevent unintended editing. See Layer Display Options 
Dialog on page 127.          

The initial width, height, roof style and other settings of Auto Dormers are set in the Dormer Defaults dialog. See Dormer 
Defaults on page 575.         

AUTO FLOATING DORMER

Select Build> Roof> Auto Floating Dormer and click the roof plane where you would like to place the center of the 
dormer's front wall. 

The bottom edges of all floating dormer walls are cut off by the underlying roof plane.                           To produce such a dormer manually, 
check Roof Cuts Wall at Bottom for the dormer walls on the ROOF panel of the Wall Specification dialog.

Usually, no room is defined by the walls of this type of dormer.           

The images below show both the outside and inside of a typical              floating dormer.         

616



Home Designer Pro 2025 Reference Manual - Dormers and Crickets

A floating              dormer can be placed in plan view on the same floor that its underlying roof plane displays on, or it can be 
placed on the floor above. Normally, it does not matter what floor the dormer is on; but in some cases, it may need to be on 
the floor above so that the dormer walls do not interfere with walls or railings in the room below.          

Regardless of which floor it is placed on, a dormer must always fit within a single roof plane. When placing a dormer on the 
floor above, you may find it helpful to turn on the Reference Display . See The Reference Display on page 525.          

You may also find it helpful to display the underlying roof plane on the floor above using the Roof Plane Specification 
dialog. See Roof Plane Specification Dialog on page 597.         

If the dormer is placed on the same floor as the underlying roof plane and the room below, and if the room has a flat ceiling, 
then a hole will be produced in the ceiling under the dormer.          

AUTO DORMER

Select Build> Roof> Auto Dormer and click on a roof plane where you want the center of the dormer's front wall to 
be.         

The walls of an auto dormer go to the floor and meet a knee wall on either side on the back of the dormer. This knee wall 
must run parallel to the underlying roof plane’s Baseline.          

 l If you are creating a (non-floating) auto dormer, a knee wall must already exist. The dormer side walls run back to the 
knee wall and the knee wall is broken where the dormer walls meet it.           

 l The knee wall does not have to be designated as such in the Wall Specification dialog unless you are generating an 
automatic roof. See Knee Walls on page 260.          

 l A non-floating dormer must always be created on the same floor as the knee walls.           
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MANUALLY DRAWN DORMERS

Once you are familiar with Home Designer Pro’s roof tools, drawing dormers manually can be quite simple. There are 
several different ways to draw dormers; some methods work better in certain applications.         

A variety of resources with information about drawing dormers manually is available at HomeDesignerSoftware.com.         

There are a few things to keep in mind.          

 l Walls extend upward until they meet an overlying roof plane.           
 l A wall can also be cut by underlying roof planes if Roof Cuts Wall at Bottom is checked in the Wall Specification 

dialog. For this to work properly, the edge of the roof plane must extend completely through the width of the wall. See 
Clerestory and Dormer Walls on page 258.          

 l Polylines can be converted into a Hole in Roof/Ceiling that allows walls to extend above or below the roof line. See 
Convert Polyline on page 182.          

CRICKETS

When a room's ceiling height is such that it extends above the roof of surrounding rooms, the automatic roof generator will 
create a cricket against any walls that face up-slope of an adjacent roof. You can also manually draw a cricket using the 
Roof Plane  tool and the Place Roof Plane Intersection Point  edit tool. See Connecting Roof and Ceiling Planes 

on page 595.

 

Editing Auto Dormers
Auto Dormers are a collection of objects that behave as one. When a dormer is selected, it can be edited using its edit 
handles, edit tools, and specification dialog. See Dormer Specification Dialog on page 619.         

If you click the Explode Dormer  edit button, the dormer’s individual components can be edited.          
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USING THE EDIT HANDLES

When selected, an auto dormer displays three edit handles. The Move handle displays over the front wall and allows you to 
relocate the dormer. Two resize handles display on the side walls and allow you to change the width of the dormer.         

There are some things to keep in mind when editing auto dormers and auto floating dormers using the mouse.         

 l Dormers move at 90° angles unless the Ctrl/⌘  key is pressed before moving them.         
 l The dormer must be contained within one underlying roof plane.         
 l Auto dormers cannot be moved beyond the required knee wall.         

EDITING THE WINDOW

Dormer windows can be selected, edited, deleted and replaced just like other windows. See Editing Windows on page 418. 
You can place several windows in the front wall.         

Unless the dormer's window has been edited or changed in the Window Specification dialog, when the dormer width is 
changed, its width changes automatically to fill the front dormer wall. If the window has been edited, its width stays fixed. 
If a change to the dormer makes its front wall too short to hold the window, the window reverts to auto width.         

EXPLODE AUTO DORMER

Click the Explode Auto Dormer edit button to explode a selected auto dormer into its component parts. The dormer 
walls, roof planes, window, and hole in the roof/ceiling can be edited individually. 

The program treats roof planes over an exploded auto dormer as though they were manually drawn, allowing you to protect 
them from being rebuilt in the Build Roof dialog. See Roof Panel on page 580.          

Once exploded, it is not possible to block the components into a Dormer object again.          

 

Dormer Specification Dialog
Select a dormer or dormers and click the Open Object edit button to open the Dormer Specification dialog.         

The settings in this dialog are also found in the Dormer Defaults dialog, where they apply to all dormers as they are created 
rather than to a selected dormer.         
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ROOF PANEL

  Roof Style

 l Choose a roof Type from the drop-down list.  You can choose from Hip, Gable, Shed, Gambrel, Mansard, Barrel, 
Curved Eave, Hip Curved Eave or Eyebrow.          
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  Pitch

 l Specify the Pitch of the dormer roof planes. The default dormer pitch applies to all dormer roof types except Shed, 
which has a default 3 in 12 pitch. For Gambrel and Mansard types, this applies to the lowest, or eave, roof planes.

 l Check Pitch in Degrees to display the Pitch value in degrees in all dialogs as well as in roof plane labels; uncheck it 
to display the pitch in terms of rise and run. See Roof Pitches in Degrees on page 625.

 l The Second Pitch specifies the upper roof of a Gambrel, Mansard, curved eave, and hip curved eave.

 l When a Second Pitch is used, specify the In from Eave distance, measured from the lower roof plane eave to where 
the upper roof plane starts.

 
Roof Overhang

Specify the depth of the selected dormer’s Eave and Gable Overhangs.         

  Framing

See Roof Framing on page 629.

 l Select the dormer roof's Framing Method: either Trusses or Rafters.

 l When Include Ridges is checked, ridge and hip rafters are created for the dormer's roof when roof framing is 
generated. Uncheck this if you do not want to generate ridge or hip rafters for the selected dormer.

 l Specify the Ridge Depth, which is the depth of the dormer's ridge and hip rafters.         

 l Specify the Fascia Depth for gable fascia and the Eave Fascia Depth.         

 l Specify the Rafter Depth.         

 l The Vertical Rafter Depth is reported here for reference.         

 l Specify whether to Include Boxed Eaves and/or Gutters

 l Select either Plumb or Square Rafter Cut.         

 
Auto Roof Return

See Roof Returns on page 623.              

 l Check Auto Roof Returns to generate roof returns on the selected dormer. Roof Returns can be only specified for 
Gable dormers. 

 l Specify the horizontal Length of the roof return in inches (mm).         

 l Enter a value in inches (mm) to Extend the roof returns past the dormer overhang.           

 l Specify a Gable, Hip, or Full roof return.          

 l Specify a Sloping or Flat roof return.         
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WALLS PANEL

  Walls

 l Select a Wall Type for the dormer walls from the drop-down list.

 l Click the Define button to open the Wall Type Definitions dialog to create or modify existing wall types. See Wall 
Type Definitions Dialog on page 264.

 l Specify the Height of the dormer, as measured from where the top of the underlying roof plane meets the dormer 
front wall exterior to the top plate of the dormer roof’s bearing walls. This top height is called the dormer ceiling 
height, even if the ceiling in the dormer is not flat. The top dormer window casing is usually close to this height.

 o Check Set to Existing Ceiling to assign the ceiling height of the room behind the dormer to the dormer. Not 
available in the Dormer Defaults dialog.          

 l Height to Reach Existing shows the difference between the dormer height where the inside of the wall meets the 
underside of the roof and the ceiling of the room behind it.         

 l Specify the dormer’s Width, measured from the outside surfaces of the dormer side walls.

 l The Dormer Room options are only available for Floating Dormers and are intended for use with dormers on an 
upper floor level:

 o Select Create Shaft to Room Below to create an opening in the floor platform to the floor below, and enclose the 
inside of the dormer with walls that form a room. 

 o Select Form Room Inside Dormer to create an opening in the floor platform below that is defined as a room using 
the dormer walls plus an invisible Room Divider.         

 o Select Neither Room nor Shaft to make no changes to the structure below the dormer.      

 l Dormer windows can appear too narrow on the outside due to the space required for interior casing to clear the 
inside surfaces of the side walls. Two additional settings are available in the Dormer Defaults dialog to help address 
this.          

 o When Set Inside Window Trim Width is checked, you can set the Inside Window Trim value, which is the 
default interior casing width for dormer windows. When unchecked, dormer windows use the default interior casing 
width set in the Window Defaults dialog.          
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Windows

 

 l When Auto Resize Windows is checked, the selected dormer's window will resize when the dormer's height or 
width are adjusted. Uncheck this box to keep the window the same when the dormer is resized.

LINE STYLE PANEL

For information about the settings on this panel, see Line Style Panel on page 209.         

 

Roof Returns and Other Details
Home Designer Pro offers a selection of tools to add architectural details to your roof design.

ROOF RETURNS

A roof return is a small decorative roof plane that connects to the low side of a gable roof overhang and extends below the 
upper triangular portion of the gable wall. Three styles of roof returns that can be produced automatically.         

The first two styles are called Gable and Hip returns since the return ends in a gable or hip.          

Hip and Gable Roof Returns

The third is called a Full return because it extends under the entire gable to connect both sides and is sometimes referred to 
as a water table. In order for a Full return to be created, the roof planes on each side must have the same              Fascia Top Height.
         

Full Roof Return

It is not difficult to manually draw roof returns using small roof planes, but it is quicker to produce them automatically. 
Roof returns are generated automatically on a wall by wall basis using settings in the Wall Specification dialog. See Roof 
Panel on page 272.         

623



Home Designer Pro 2025 Reference Manual - Roof Returns and Other Details

These roof return settings are also found in the Dormer Specification dialog for gable roof dormers and function similarly. 
See Roof Panel on page 620.         

The pitch of an automatically generated roof return is the same as that of the roof plane above it. Its structure is the same as 
that of the subfascia and eaves of the roof plane above. See Structure Panel on page 600. 

BOXED EAVES

Boxed eaves have a flat, horizontal soffit surface instead of one that follows the underside of the rafter ends. Boxed eaves 
can either extend out to the gable fascia or build flush with the adjacent exterior wall.           

Boxed Eave at a gable end

You can specify Boxed Eaves for all roof planes in the Build Roof dialog and for individual roof planes in the Roof Plane 
Specification dialog. See Options Panel on page 583.          

Flush eaves cannot be deeper than the default Eave Overhang Depth. If you have eaves of varying depths, specify the 
deepest value as the default and set walls with smaller eaves accordingly.  The flush eave end uses the wall’s surface 
material by default; however, you can specify a different material if you wish. See Materials Panel on page 585.          

FASCIA

Fascia               can be added to both automatic and manually drawn roof planes. They can be specified in the Build Roof dialog and 
added to roof planes as they are created, and they can be added to or removed from individual roof planes in the Roof Plane 
Specification dialog.

 l Fascia and eave fascia can be specified in the Build Framing and Build Roof dialogs. See Roof Panel on page 644.          
 l Fascia is generated whenever the roof is built or rebuilt.

Fascia display in 3D views and are included in the materials list. 

Fascia

The material specified for fascia in the Build Roof dialog displays as part of the roof plane rather than as a separate object. 
It displays in 3D views but not plan view.          

In addition, sub fascia boards are created when roof framing is generated and are placed on the “Framing, Roof Rafters” 
layer. The fascia material is not applied to these framing members, however.           

The width and depth of fascia and eave fascia can be specified in the Build Framing dialog. See Roof Panel on page 644.          

SOFFITS

Soffits are the layer of material that covers the rafter ends on the underside of roof eaves and can be constructed in               either of 
two ways:
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 l By default, soffits follow the underside of the rafter ends and butt against the inside edge of the fascia. The rafter end 
depth and thus the soffit height is controlled by the Gable Sub Fascia Depth. See Roof Panel on page 644.          

 l Boxed eaves can be specified in the Build Roof and Roof Plane Specification dialogs. Boxed eave height is controlled 
by the Eave Sub Fascia Depth. See Options Panel on page 583.          

GUTTERS

Gutters are added to non-sloping eaves on both automatic and manually drawn roof planes when Gutters is checked in the 
Build Roof dialog. They can also be added to or removed from individual roof planes in the Roof Plane Specification 
dialog. See Options Panel on page 583.          

Gutters are placed on the “Roofs, Gutters” layer. By default, this layer is turned on in 3D views but not in plan view, is 
included in the materials list, and is locked. See Layer Display Options Dialog on page 127.          

 

Roof Pitches in Degrees
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Chapter 23
 

Framing

In Home Designer Pro, framing can be produced both manually and automatically, and can be calculated in the Materials 
List. 

Manual framing members are drawn by clicking and dragging, like drawing a CAD line. Automatic framing for the major 
components of a 3D model (floors, ceilings, walls and roofs) can be generated using the Build Framing dialog. 

Both manually drawn and automatically generated framing members can be selected and edited in 2D and 3D views.  

Trusses are covered in their own chapter, Trusses on page 663.

TOPICS
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Framing Defaults
Select Edit> Default Settings to open the Default Settings dialog. Select Framing from the list, then click the Edit 
button to open the Framing Defaults dialog.

Both automatic and manually-drawn framing are generated according to the settings in the Framing Defaults dialog. This 
dialog is nearly identical to the Build Framing dialog in both appearance and function. The only difference is that the Build 
Framing dialog has check boxes that allow you to generate different types of framing automatically. See Framing Defaults 
Dialog on page 636.

Any changes made in the Framing Defaults or Build Framing dialog will affect subsequently drawn or generated framing, 
but not framing already present in the plan. 

The settings in the Framing Defaults dialog directly affect a 
variety of important structural elements in each plan which 

determine floor, ceiling and roof heights; so it is best to set your Framing 
Defaults before building your model. See Drawing a Plan on page 26. 

FLOOR AND CEILING PLATFORM FRAMING

Floor and ceiling platform depths contribute to the overall height of a structure, so their default values should be set as early 
as possible. 

The plan-wide defaults for all floor and ceiling platforms are set via the Floor/Ceiling Platform Defaults dialog. These 
settings serve as the defaults for the Floor Level Defaults dialogs and the Floor Level panels of the Framing Defaults dialog. 
See Floor Level Defaults on page 287 and Dynamic Platform Defaults on page 304.

Floors and ceilings can be framed using either framing or trusses. See Floor and Ceiling Trusses on page 664. 

By default, automatically-generated floor and ceiling joists run in the direction that results in the shortest span between 
exterior walls and/or beams. Joist Direction  lines also allow you to define the direction that joists in a particular floor 

or ceiling platform. See Joist Direction Lines on page 653.

Ceiling joists do not automatically generate in areas where the bottom chords of roof trusses are already present. See Roof 
Trusses on page 664.

In standard light frame construction, floor and ceiling platforms are built to pass over or bear on the wall framing; however, 
this is not always desired. You can specify that joists bear on a selected wall, that platforms hang on it, or that a wall build 
through platforms in the Wall Specification dialog. See Structure Panel on page 270.

WALL FRAMING

Like other types of framing, wall framing is generated based on settings in the Framing Defaults dialog. See Wall Panel on 
page 638 and Openings Panel on page 641.

In addition, wall framing is dependent on settings from other sources:

 l Framing Type, Spacing, Width, Plate Count and size, and more can be specified for each Wall Type in the Wall Type 
Definitions dialog. See Wall Type Definitions Dialog on page 264.

 l Horizontal wall framing, or Girts, can be specified for each Wall Type, as well.
 l The structural specifications for individual walls can be set in the Wall Specification dialog. See Structure Panel on 

page 270.
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 l Stud layout can be pulled from a Framing Reference Marker or from the Start or End of each wall. See Framing 
Reference Markers on page 651.

DOOR AND WINDOW FRAMING

The rough openings, trimmers, and sills for doors and windows are set in their respective defaults and specification dialogs. 
The rough opening for legacy fireplace objects can also be specified. See:

 l Door Specification Dialog on page 392
 l Window Specification Dialog on page 420
 l Fireplace Specification Dialog on page 513

Note: Door and window bucks do not automatically generate in concrete 
or block walls. 

HEADERS

The size, position, and composition of door and window headers can also be set in their respective defaults and specification 
dialogs. 

In addition, a range of header depths for openings of different widths can be specified in the Framing Defaults dialog. Check 
Calculate from Width in the Door and Window Defaults dialogs to assign header depths to openings based on their width. 
See Openings Panel on page 641.

Like other framing members, headers are assigned a Structure Type such as “Lumber” or “LVL”. By default, the program 
will try to ensure that an opening’s Header Type agrees with the framing material used by the wall it is inserted into. To do 
this, it compares the Header Type to the wall’s framing material: 

 l Wood framing types: Lumber, I-Joist, Glulam, Engineered Lumber, LVL, PSL, and VSL.
 l Steel framing types: Steel I, Steel Box, C Channel, and U Channel. 

If the Header Type agrees with the wall framing material, it will be unchanged; however, if it does not agree it will change 
to either “Lumber” in a wood-framed wall or “C-Channel” in a steel-framed wall. To prevent this from occurring and use 
the specified Header Type regardless of wall material, uncheck Automatic. See Framing Types on page 629. 

There are three Framing Methods for headers: Standard, Flat, and Boxed. See Framing Panel on page 406.

 l Standard headers are composed of vertically-oriented framing members.
 l Flat headers are composed of horizontally-oriented framing members.
 l Boxed headers have vertical framing members with horizontally-oriented top and bottom rails. 

SILL PLATES

Sill plates are created when floor framing is generated. They are created over all exterior walls that have either Concrete or 
Brick material type as their Main Layer material and support a framed floor platform directly above. See The Main Layer on 
page 262 and Materials and the Materials List on page 757. 

Sill plate size and number can be specified in the Wall Specification dialog of the supporting masonry wall. Only the 
bottommost plate that comes into contact with masonry is specified as Treated. See Foundation Panel on page 275. 

These sill plates are placed on the “Framing, Sill Plates” layer. See Displaying Framing on page 655.

When a monolithic slab foundation is created, the bottom plates of framed walls built on the slab are specified as Treated 
and are placed on the “Framing, Wall” layer. 
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As with sill plates, multiple bottom plates can be specified in the Framing Defaults dialog, but only the bottommost plate is 
specified as Treated. See Wall Panel on page 638. 

POSTS AND BEAMS

The Post, Floor Beam, and Roof Beam Defaults dialogs can be accessed via the BEAMS and POSTS panels of the Framing 
Defaults dialog. 

These defaults can also be accessed by double-clicking the respective drawing tools. In addition, the Deck Post and Deck 
Beam Defaults dialogs are similar, and can be accessed from the Deck Room Defaults dialog. See Room Type Defaults on 
page 288.

ROOF FRAMING

Roofs can be framed using either rafters or trusses. You can select the Framing Method that you want in the Build Roof 
dialog. See Build Roof Dialog on page 579.

Settings on the ROOF and TRUSSES panels of the Framing Defaults dialog determine the structure of roof planes and 
manually drawn ceiling planes as well as how they rest on bearing walls, so it is important that their default values be set 
before building the roof. See Roof Panel on page 644 and Trusses Panel on page 647.

You can add non-structural purlins to the Roof Surface Definition and/or Roof Ceiling Finish Definition. See Material 
Layers Definition Dialogs on page 743.

If changes are made to these defaults that you need to apply to the entire roof plan, you will need to either manually edit or 
rebuild the entire roof - not just the roof framing. See Roofs on page 573. 

DECK FRAMING

Deck rooms have special automatically generated framing and are not affected by the settings in the Framing Defaults or 
Build Framing dialogs. Deck framing defaults are set in the Deck Room Defaults dialog. See Decks on page 299. 

FRAMING TYPES AND ROLES

By default, most framing is set to use “Lumber” as the material type. You can select from a number of other types, however, 
such as I-Joist and Glulam. See Framing Types on page 629.

Each framing member also has a Role, which refers to its purpose and position in the structure. Examples include Floor 
Joist, Header, Plate, and Rafter. A framing member's initial Role is determined when it is created: either automatically 
generated or drawn manually. Once created, you can specify a different Role for any framing member in its specification 
dialog. Roles are reported in the Materials List. See General Panel on page 659.

 

Framing Types
The appearance of a framing member in 3D and cross section/elevation views, and Materials Lists is affected by its Type as 
well as the material assigned to it. See Displaying Framing on page 655.
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Concrete, fir, and steel framing members of 
different Framing Types

Framing Type affects a member's shape, or profile, and thus its appearance in 3D and cross section/elevation views. Type is 
only mentioned in the Materials List Description for headers, posts, beams, purlins, deck planks, joists, rafters. Steel studs 
are identified as well, but the profile shape is not stated. 

The material specified for a framing member determines what it looks like in camera views by applying a texture, pattern, or 
color to its surface. Framing materials are usually mentioned in the Description column of the Materials List but have no 
effect on how the framing is calculated. 

The default framing materials and Type are set:

 l In the Floor and Ceiling Structure Definition dialogs for floor and ceiling framing. See Floor and Ceiling Platform 
Definitions on page 303.

 l In the Wall Type Definitions dialog for wall framing. See Wall Type Definitions Dialog on page 264.
 l In the Framing Defaults dialog for General Framing, Posts, and Rafters. See Materials Panel on page 649. 

In the Floor and Ceiling Structure Definition dialogs for floor and ceiling framing, the Framing Type provides an additional 
option: Truss, which allows you to automatically generated floor and ceiling trusses. See Floor and Ceiling Trusses on page 
664.

FRAMING COMPOSITION

A variety of structural member shapes is available for use in Home Designer Pro. They fall into four categories: 

 l Wood Composition 
 o Lumber, I-Joist, Glulam, Engineered Lumber, LVL, PSL, and VSL.

 l Steel framing types: Steel I and Steel Box. 
 l Concrete Composition

 o Rectangular and Circular/Rounded. 
 o Concrete posts and beams support rebar.

 l Other.

The Composition of a framing type influences a variety of characteristics: particularly shape. A Steel I-beam, for example, 
is shaped slightly different than a wood I-joist.  There are also a variety of subtleties with regard to how automatic framing 
gets generated based on the composition. For example, Steel studs are longer than wood studs because they are supported by 
Steel U Channel plates rather than plates that are rectangular lumber.

 

Manual vs. Automatic Framing
Platform, roof, and wall framing can be produced manually or automatically. In most cases, automatically-generated framing 
is preferable because it is faster than manually placing, replicating and editing numerous individual framing members. 

In many plans, though, framing is drawn using both approaches. For example, a combination of automatically generated 
rafters and manually drawn trusses can be used to model a roof framing plan. See Mixing Trusses with Stick Framing on 
page 670. 

Regardless of how it is created, individual framing members can be selected and edited. See Editing Framing on page 656. 

 l Automatic Framing on page 631
 l Manual Framing on page 631
 l Framing with Beams on page 632

630



Home Designer Pro 2025 Reference Manual - Manual vs. Automatic Framing

 l Mixing Manual and Automatic Framing on page 632
 l Mixing Rafters and Trusses on page 632

AUTOMATIC FRAMING

Automatic framing of floor and ceiling platforms, walls and roofs can be generated using the Build Framing dialog. The 
settings in this dialog control the size, spacing, and type of framing drawn in a plan, and related structural information for 
the major components of the 3D model. See Framing Defaults Dialog on page 636.

Automatic framing of a particular structural component is not generated until the Build Framing dialog is opened to the 
appropriate panel and one of two check boxes selected:  

 l Select the Build check box to build automatic framing once. For example, check Build Wall Framing on the WALL 
panel, then click OK to build wall framing once based on the current state of the model. 

 l Select the Automatic check box, then click OK to build automatic framing every time a change is made to that 
structural component in the plan. For example, check Automatic Wall Framing on the WALL panel to rebuild all wall 
framing any time a wall is affected by changes to the model. 

Note: When Automatic framing of a particular type is enabled, framing 
of that type cannot be manually edited or deleted. 

In order for framing to generate in a particular layer of a structural component such as a wall assembly or floor platform, 
that layer must have the Framing specification. See Wall Type Definitions Dialog on page 264 and Material Layers 
Definition Dialogs on page 743.   

By default, joists automatically generate in the direction that results in the shortest span; however, you can produce different 
results using Bearing Lines , Floor/Ceiling Beams , and/or Joist Direction  lines. See Bearing Lines on page 

654 and Joist Direction Lines on page 653.

MANUAL FRAMING

Framing objects can also be drawn manually. With the exception of Posts, framing objects are drawn by clicking and 
dragging in a straight line, the way other line-based objects are. See Line Tools on page 204.

The manual framing tools are organized into families: general framing, floor and ceiling framing and roof framing. The 
family that a drawing tool belongs to determines where it can be used: 

 l Roof framing objects can only be drawn within the area of one or more roof planes.
 l Floor and ceiling framing objects can only be drawn within one or more floor or ceiling platforms.
 l General Framing  objects and Posts  can be drawn anywhere in a model.

REBUILDING AND RETAINING FRAMING

It is important to remember that framing does not update automatically when changes are made to the model unless it is set 
to do so. You can direct the program to rebuild the automatic framing of floors/ceilings, walls and/or roofs every time a 
change to the model affects one of these components in the Framing Defaults dialog. See Build Framing Dialog on page 
650.

To learn more, see Keeping Framing Current on page 658.

When automatic framing associated with a particular panel in the Build Framing dialog is generated, any existing 
automatically produced framing of that type is deleted and replaced. You can prevent this from happening to a selected wall 
or roof or ceiling plane by checking Retain Wall Framing or Retain Roof Framing in the object’s specification dialog.
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MIXING MANUAL AND AUTOMATIC FRAMING

Floor and ceiling platforms can be framed with a combination of manually-drawn and automatically generated joists. 
Similarly, roof planes can be framed with a combination of manually drawn and automatic rafters.

If you plan to use this approach, bear in mind that automatically generated joists and rafters will not be created in the same 
location as an existing, manually drawn joist or rafter; but, they will not necessarily use the same layout. For consistent 
layout, consider using a Framing Reference Marker . See Framing Reference Markers on page 651. 

Manually drawn floor, ceiling, and roof framing is unaffected when automatic framing is rebuilt and remains along with the 
newly produced automatic framing. In contrast, manually drawn wall framing is deleted when automatic framing is rebuilt. 
You can, however, prevent this from happening by checking Retain Wall Framing in the Wall Specification dialog.

MIXING RAFTERS AND TRUSSES

 l Roofs can be framed with rafters, trusses, or a combination of the two. If you plan to combine roof trusses with rafters 
and/or ceiling joists, you can save time by:

 l Select Rafters as the Framing Method in the Build Roof dialog before automatically building or manually drawing a 
roof. This will produce roof planes set up to accommodate rafters. See Build Roof Dialog on page 579.

 l Draw and position all roof trusses before automatically generating framing to produce rafters and ceiling joists. See 
Roof Trusses on page 664.

For more information, see Mixing Trusses with Stick Framing on page 670. 

FRAMING WITH BEAMS

Floor/Ceiling Beams  can be drawn in a plan either before or after automatic framing has been generated. Default 

settings for beams can be set in the Framing Defaults dialog. See Beams Panel on page 642.

If a Floor/Ceiling Beam is present and wall framing is generated, posts will be placed under the beam in any walls that pass 
under it and studs and top plates will build around the beam as necessary. 

If a Floor/Ceiling Beam is created before automatic floor or ceiling framing, you can specify whether joists bear on the 
beam or hang on its sides.

To build joists that bear on a beam

 1.  Draw a Floor/Ceiling Beam  at the desired location in your plan.

 2.  Select the beam and click the Open Object  edit button. On the GENERAL panel of the Beam Specification 

dialog, confirm that: 

 l The Top Height value is equal to the Ceiling Height of the room(s) over which the beam is placed.

 l  Bearing Beam is checked. 

 3.  Click OK, then select Build> Framing> Build Framing  and build the appropriate floor or ceiling framing. See 

Floor Level Panels on page 636.
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To build joists that butt against a beam

 1.  Draw a Floor/Ceiling Beam  at the desired location in your plan.

 2.  Select the beam and click the Open Object  edit button. On the GENERAL panel of the Beam Specification 

dialog: 

 l Specify the desired Depth value and then lock it.

 l Specify the Bottom Height value so that it is equal to the Ceiling Height of the room(s) over which the beam is 
placed.

 3.  Uncheck Bearing Beam. 

 4.  If necessary, select Build> Framing> Joist Direction  and draw a line perpendicular to the beam and within the 

floor or ceiling platform. 

 5.  Click OK, then select Build> Framing> Build Framing  and build the appropriate floor or ceiling framing. See 

Floor Level Panels on page 636.

 

Framing Tools
Select Build> Framing to access the automatic and manual Framing Tools.

The Framing Tools family has three separate parent buttons: General Framing Tools , Floor/Ceiling Framing Tools 

, and Roof Framing Tools .

The default settings for framing members are derived from their respective panels in the Framing Defaults dialog. See 
Framing Defaults on page 627.

Most types of framing can be created both manually and automatically. Once created, both automatically generated and 
manually drawn framing members can be selected and edited. See Editing Framing on page 656.

Horizontal floor/ceiling platform framing members are referred 
to as "joists"; vertical wall framing members are referred to as 

"studs"; and sloped roof framing members are referred to as “rafters”.

BUILD FRAMING

There are several ways to build framing. See Building Framing on page 650.

Select Build> Framing> Build Framing to open the Build Framing dialog. Here, you can define settings that control 
how framing is drawn and generate automatic framing. 

Select Build> Framing> Build All Framing to build or rebuild all floor, ceiling, wall, and roof framing throughout 
the current plan.

GENERAL FRAMING

General Framing objects are generic, framing members that can be drawn outside a floor or ceiling platform or roof 
plane. Select Build> Framing> General Framing, then click and drag in a straight line to create one of these 

objects. In plan view, a horizontal framing member is created.    
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POST

Posts can only be placed manually. To do so, select Build> Framing> Post and click in plan view. 

POST WITH FOOTING

Posts can also be created with footings  beneath them. Select Build> Framing> Post and click in plan view to place a 
post centered over a footing. Post footings are Slab  objects and can be selected independent of their posts. See 

The Slab Tools on page 508.

RAFTER

Rafters can be drawn both manually and automatically. To draw a rafter manually, select Build> Framing> Rafter 
in plan view, then click and drag in a straight line within a roof plane. 

Rafters are edited like other framing members, except that you cannot set the height. If a rafter is moved, its height and 
slope are automatically reset to fit under the roof plane at its new position.

ROOF BLOCKING

Roof Blocking is automatically generated in the eaves if a soffit is not present; otherwise, blocking is drawn 
manually. In plan view, select Build> Framing> Roof Blocking and click and drag in a straight line within a roof 

plane. Blocking is typically drawn perpendicular to the rafters, but at the same pitch. 

Each run of blocking behaves as a single object but has gaps where it crosses rafters, trusses or other blocking. 

Before drawing Roof Blocking:

 l Specify whether you want In Line, Stagger blocking, or Cross bridging in the Framing Defaults dialog. 
 l Build the roof framing. See Roof Panel on page 644.

In 3D, roof blocking is tilted to follow the pitch of the roof plane in which it is drawn. 

ROOF TRUSS

Roof trusses can be drawn both drawn manually and generated automatically. To do so, select Build> Framing> 
Roof Truss in plan view and click and drag  in a straight line within one or more roof planes. Roof planes and either 

a default or manually drawn ceiling must be present before a roof truss can be drawn. See Roof Trusses on page 664.

ROOF BEAM

Roof beams can only be drawn manually. To do so, select Build> Framing> Roof Beam in plan view and click and 
drag in a straight line. Roof beams are normally drawn across rafters and placed directly under them. 

JOIST

Floor and ceiling joists can be both drawn manually and generated automatically. To draw a joist, select Build> 
Framing> Joist in plan view, then click and drag in a straight line within a floor or ceiling platform. 

Joists are always drawn as the ceiling framing for the current floor. See The Current Floor on page 524. Whether a floor or 
ceiling joist is drawn is determined by the presence of a floor platform above. 
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 l If there is no floor platform above, a ceiling joist is drawn. 
 l If there is a floor platform above, a floor joist is drawn. 

If you want to draw floor joists for Floor 1, for example, you must do so on Floor 0. See Foundations on page 496.

Joists can be automatically generated for multiple floors in the Build Framing dialog. See Floor Level Panels on page 636. 

Ceiling joists, floor joists and rafters have their own layers. 
Proper layer assignment maximizes display and materials 

flexibility.

JOIST BLOCKING

Joist blocking can only be drawn manually in plan view. To do so, select Build> Framing> Joist Blocking, then  
click and drag in a straight line within a floor or ceiling platform. 

Before drawing Joist Blocking:

 l Specify whether you want In Line, Stagger blocking, or Cross bridging in the Framing Defaults dialog. 
 l Build the floor and/or ceiling platform. See Floor Level Panels on page 636.

Regardless of how many joists or other objects it crosses, each run of blocking behaves as a single object. 

FLOOR/CEILING TRUSS

Floor and ceiling trusses can only be drawn manually in plan view. Select Build> Framing> Floor/Ceiling Truss, 
then click and drag in a straight line within a floor or ceiling platform. See Floor and Ceiling Trusses on page 664.    

FLOOR/CEILING BEAM

Floor and ceiling beams can only be drawn manually in plan view. Select Build> Framing> Floor/Ceiling Beam, 
then click and drag in a straight line within a floor or ceiling platform.

Beams can be drawn in two different ways:

 l Under Joists places the beam underneath the joists so the joists can bear on it. 
 l With Joists places the top of the beam even with the tops of the joists it supports. The joist then butts against it. See 

Beams Panel on page 642.

FRAMING REFERENCE MARKER

Framing Reference Markers are manually-placed reference points that specify how automatically-generated 
framing is laid out. To place one, select Build> Framing> Framing Reference Marker in plan view and click to 

place a Framing Reference Marker. 

A Framing Reference Marker can also be created by placing a Marker  and then specifying its type. See Markers on 

page 368 and Framing Reference Markers on page 651. 

BEARING LINE

Bearing Lines direct the program to lap or butt joists and/or rafters where they cross the line instead of spanning 
from wall to wall, and can only be drawn in plan view. To draw one, select Build> Framing> Bearing Line and 

click and drag in a straight line. See Bearing Lines on page 654.
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JOIST DIRECTION

Joist Direction lines define the direction in which joists run in a floor or ceiling platform and can only be drawn in 
plan view. To draw one, select Build> Framing> Joist Direction and click and drag within a floor or ceiling 

platform. See Joist Direction Lines on page 653.

 

Framing Defaults Dialog
Select Edit> Default Settings to open the Default Settings dialog. Select "Framing" from the list, then click the Edit 
button to open the Framing Defaults dialog. This dialog can also be accessed by double-clicking the General 

Framing  button or any of the Floor/Ceiling Framing Tools , or Roof Framing Tools  buttons.

Each major structural component of the model has its own panel or panels in the Framing Defaults dialog. The number of 
panels in the dialog varies depending on how many floors are in your model. There will be a panel called  “1st” for the first 
floor, “2nd” for the second floor, and so on.

 l Floor and ceiling framing settings are found on the Floor Level panels. See Floor Level Panels on page 636. 
 l Wall framing settings are located on the WALL, OPENINGS, and FIREPLACES panels. See Wall Panel on page 638, 

Openings Panel on page 641, and Fireplaces Panel on page 642.
 l Floor/Ceiling Beam and Roof Beam settings are found on the BEAMS panel. See Framing Defaults Dialog on page 

636.
 l Post, floor/ceiling beam and roof beam settings are found on the POSTS panel. See Posts Panel on page 643.
 l Roof framing settings are located on the ROOF and TRUSSES panels. See Roof Panel on page 644 and Trusses Panel on 

page 647.
 l The settings on the ROOF panel are the same as those on the STRUCTURE panel of the Build Roof dialog. See Roof 

Panel on page 644.
 l You can specify how framing looks in plan view on the PLAN VIEW panel. See Plan Display Panel on page 649.
 l You can set the default materials used for framing on the MATERIALS panel. See Materials Panel on page 649.

FLOOR LEVEL PANELS

The default floor and ceiling framing for individual floor levels are set here. The defaults for all floor levels, however, is set 
in the Floor/Ceiling Platform Defaults dialog. See Floor and Room Defaults on page 287. 

The floor framing for a given floor level is always generated or manually drawn on the floor below. As such, the floor 
framing settings for a given floor level are found on the FLOOR panel for the floor below it. For example, the floor framing 
settings for Floor 2 are found on the 1ST panel, while the floor framing settings for Floor 1 are found on the FOUNDATION 
panel. See Floor and Ceiling Platforms on page 303.

In order to create the floor framing for Floor 1, a Floor 0 must be present. If a Floor 0 has not been built, the Build Floor 
Framing check box on the FOUNDATION panel will not be available. See Foundations on page 496. 
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Automatic Floor/Ceiling Framing

Check Automatic Floor/Ceiling Framing to regenerate floor and ceiling framing whenever changes are made to the model. 
See Automatic Framing on page 631. 

 l Check Use Framing Reference to use a Framing Reference Marker as the starting point for joist layout. If a 
Framing Reference Marker is present, the center of the first joist is placed at this point and spacing goes from there. 
If joists are lapped, the surface is placed at this point. When this is unchecked, the program tries to position ceiling 
joists so that they coincide with rafters. See Framing Reference Markers on page 651. 

 
Ceiling Above Floor X

Ceiling platforms are only present above rooms that do not have living space above them. Ceiling platforms that already 
have the bottom chords of roof trusses present in them do not receive automatically generated joists. See Roof Trusses on 
page 664.   

 l Check Build Ceiling Framing to generate or regenerate ceiling framing when the OK button is clicked. Only 
available when there is no living space above at least part of the current floor. Not available in the Framing Defaults 
dialog.    

 l The Ceiling Structure depth displays here for reference. Click the Edit button to open the Ceiling Structure 
Definition dialog and define the layers of materials that form the ceiling platform. See Material Layers Definition 
Dialogs on page 743.    
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 l Check Default to use the Ceiling Structure Definition set in the Floor/Ceiling Platform Defaults dialog. See Floor 
and Room Defaults on page 287.    

 l Enter a value for the On Center Spacing of joists generated in ceiling platforms on Floor X.    

 l Specify the Width, which is the horizontal thickness of the ceiling's joists or trusses.    

 l Specify how the ceiling framing members Bear on Beams: they can either Lap side by side or Butt end to end. The 
lap is 8” (200 mm) and centered over the support.    

 l Specify what style of Blocking or bridging is produced for the ceiling when Joist Blocking  is manually drawn 

after joists are in place. See Joist Blocking on page 635.    

 o In Line produces blocking pieces that align with each other.

 o Stagger produces blocking that alternates on either side of the line you draw.    

 o Cross produces cross bridging that looks like in line blocking in plan view, but shows as cross bridging in 3D views 
and the materials list.

 
Subfloor of Floor Y

If a room has a living space above it, its ceiling will be supplied by the floor platform of the room(s) above instead of a 
ceiling platform.    

 l Check Build Floor Framing to generate or regenerate floor framing when the OK button is clicked. Not available in 
the Framing Defaults dialog or if there is no floor level located below Floor Y.    

 l The Floor Structure depth displays here for reference. Click the Edit button to open the Floor Structure Definition 
dialog and define the layers of materials that form the floor platform. Only available if there is living space above at 
least part of the current floor.    

 l Check Default to use the Floor Structure Definition set in the Floor/Ceiling Platform Defaults dialog.    

 l Enter a value for the on center Spacing of floor joists above the current floor.    

 l Specify the Width, which is the horizontal thickness of the floor's joists or trusses.    

 l Check Rim Joist to create rim joists across the ends of the floor joists when floor framing is generated. If this is 
unchecked, line blocking across the ends of the floor joists is usually drawn in manually later.    

 l Check Max Rim Joist Length, then specify the maximum allowable length for rim joist boards. When unchecked, 
rim joists run the full length of each platform edge where joist ends are found.    

 l Specify the Rim Joist Width, which is the horizontal thickness.    

 l Select the Rim Joist Type from the drop-down list. See Framing Types on page 629.    

 l Specify how the floor framing members Bear on Beams: they can either Lap side to side or Butt end to end. The 
lap is 8” (200 mm) and centered over the support.    

 l Specify what style of Blocking or bridging is produced for the floor when Joist Blocking  is manually drawn 

after joists are in place. See #2, above. 

WALL PANEL

The Thickness, Spacing, Count, and Length settings on this panel serve as the defaults for framed wall types. See Wall Type 
Definitions Dialog on page 264.
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Automatically Build Wall Framing

Check this box to regenerate wall framing whenever changes are made to the model. See Automatic Framing on page 631.

 
Wall

Specify how wall studs are created.   

 l Check Build Wall Framing to build wall framing for the entire model. Framing is built in walls with one or more 
layers specified as Framing. Not available in the Framing Defaults dialog. See Wall Type Definitions on page 262.     

 l Specify the Stud Thickness for all wall Framing layers in the plan. Stud depth is equal to the thickness of each wall 
layer that has a Framing material.     

Note: If the Stud Thickness is equal to the stud depth, only one stud will 
be created at wall corners.     

 l Specify the Stud Spacing for all wall Framing layers in the plan, starting from the Framing Reference Marker, if one 
is present. See Framing Reference Markers on page 651.     

 l Stud Depth - The depth of each wall stud is determined by the thickness of its wall layer, which is set in the Wall 
Type Definitions dialog. See Wall Type Definitions Dialog on page 264.     
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 l When Allow Automatic Balloon Framing is checked, walls adjacent to Open Below rooms are balloon-framed. 
Uncheck this box to instead produce wall plates separated by rim joists instead. See Effects of Room Types on page 
289.

 
Wall Connections

Specify how the framing at Wall Corners and Wall Intersections is generated.    

 l Select "Standard" to produce corners or intersections composed of three studs.    

 l Select "Reduced Stud" to produce corners or intersections composed of two studs.    

 l Select "Laddered" to add horizontal ladder blocking at corners or intersections.

 l Select "U Shaped" to produce corners composed of three studs in a U-shaped configuration. Only available for Wall 
Corners.    

 
Plates

Define how top and bottom plates are generated.

 l Specify the Top Plate Count, as well as their vertical Thickness.    

 l Specify the Bottom Plate Count, as well as their vertical Thickness.    

 l Specify the Max Plate Length, which is the maximum allowed length for the boards that make up the top and 
bottom plates. This value is only applicable for wall types that are set to use a maximum plate length. 

 
Blocking

Specify where and how horizontal blocking is created. Each run of blocking behaves as a single object but has gaps where it 
crosses studs.

 l Check Exterior to automatically produce blocking on exterior walls when wall framing is built.    

 l Check Interior to automatically produce blocking on internal walls when wall framing is built.    

 l In Line produces blocking pieces that align with each other.    

 l Stagger produces blocking that alternates on either side of a center line along the wall.    

 l Wall blocking is generated exactly half-way up each wall’s total height. Once created, it can be selected in a 
Framing Overview.    

  Girts
Specify the Max Girt Length, which is the maximum allowed length for horizontal girt boards. This value is only 
applicable for wall types that are set to use a maximum girt length.             

 
Mitre Ends of Angle Walls

Specify how wall corners that are not right angles are framed. 90° corners are not affected by these settings.    

 l Select Mitre Plate Ends to mitre the ends of the top and bottom plates. If unchecked, top and bottom plates will be 
butted together.    

 l Select Rotate End Studs to rotate the studs closest to mitre ends to the angle of the mitre. If unchecked, studs will 
remain perpendicular to the angle of the walls.    

 l Select Horizontal Frame Through to frame through the horizontal walls in plan view, butting vertical walls against 
them. If unchecked, walls that are vertical in plan view will frame through.    
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OPENINGS PANEL

Various defaults for door and window headers as well as the trimmers for bay/box/bow windows can be set here. 

The rough openings for doors and windows can be specified in the Door and Window Defaults and Specification dialogs. 
See Door and Window Framing on page 628.

 
Header Sizes

Specify default Header Sizes, dependent on width of the door or window, including its Rough Opening. These values 
should be set so that the wider the opening, the deeper the header. 

 l If the top of an opening’s Rough Opening is closer to the top plate than the Maximum Depth, a solid header is 
produced to fill the entire space. Short cripple studs between the header and top plate are not produced. 

 
Bay/Box/Bow Trimmers

Specify how Bay/Box/Bow Trimmers, are generated. 

 l Specify the Maximum Number of trimmers that a Bay, Box, or Bow Window with a lowered top height can have 
on each side of the opening. 

 l Specify the Component Thickness, which is the thickness of a thinner trimmer for manually resized Bay/Box/Bow 
Window components if a standard trimmer does not fit. See Component Windows on page 436. 

 
Materials List

Check List Cut Header Lengths in Mixed Reporting to show precut headers in the Materials List. Precut headers are 
shown only if the walls have been framed and Mixed Reported is selected as the reporting method.
If this is unchecked, the Materials List produces a total footage for all headers. When checked, each different length of 
precut header is listed separately. Note that the total number of headers is affected by the Count value of each door and 
window.
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Plan Views

Specify the default Header Fill Style for door and window headers by clicking the Fill Style button to open the Wall 
Header Fill Style dialog. See Displaying Framing on page 655. 

FIREPLACES PANEL

The rough openings for legacy Fireplaces placed in walls can be set on the FIREPLACES panel. See Fireplaces on page 512.

 
Headers

Specify the characteristics of fireplace Headers. 

 l Specify the Type of material used for fireplace headers. See Framing Types on page 629.

 l Specify the Thickness of fireplace headers. 

 l Specify the Count of boards used to form a fireplace header. 

 
Trimmers

Specify when to generate multiple Trimmers on each side of a fireplace. These values include the fireplace’s Rough 
Opening. See Door and Window Framing on page 628.

 l Double Trimmer At - Fireplace openings of this width or greater receive two trimmers on each side when framed. 

 l Triple Trimmer At - Fireplace openings of this width or greater receive three trimmers on each side when framed. 

 
Sills

Specify the characteristics of fireplace Sills. A sill is only generated if a fireplace is raised sufficiently off the floor.

 l Specify the Thickness of fireplace sills. 

 l Check Double Sills to specify a double sill for all fireplaces. 

BEAMS PANEL

Floor/Ceiling Beams and Roof Beams are not automatically generated: they can only be drawn manually. See 
Manual Framing on page 631.
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Posts and beams may be created under a Deck room 
automatically, depending on its size, location, and other 

variables. Deck Framing defaults are set in the Deck Room Defaults 
dialog. See Deck Framing and Planking on page 300.

 
Floor/Ceiling Beams

Click the Edit Floor Beam Defaults to open the Floor/Ceiling Beam Defaults dialog. This dialog is similar to the Framing 
Specification dialog. See Framing Specification Dialog on page 659.

 
Roof Beams

Click the Edit Roof Beam Defaults to open the Roof Beam Defaults dialog. This dialog is also similar to the Framing 
Specification dialog. 

 
Options

The Options settings affect the positioning of Floor/Ceiling Beams. 

 l Specify the Placement of Floor/Ceiling Beams relative to the joists. With Joists places beams at the same height as 
the joists so they hang on the beams; Under Joists places beams below joists so they bear on the beams. See 
Bearing Lines on page 654. 

 l Align Exterior with Outer Layer/Main Layer - When a Floor/Ceiling Beam is drawn along and over an exterior 
wall, its exterior surface can snap to either the wall’s outer layer or outer Main Layer, as specified here. See The 
Main Layer on page 262.

POSTS PANEL

Posts are not automatically generated: they can only be drawn manually. See Manual Framing on page 631. 

Posts and beams may be created under a Deck room 
automatically, depending on its size, location, and other 

variables. Deck Framing defaults are set in the Deck Room Defaults 
dialog. See Deck Framing and Planking on page 300.
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Posts

Click the Edit Post Defaults to open the Post Defaults dialog. This dialog is similar to the Framing Specification dialog for 
posts. See Framing Specification Dialog on page 659.

 
Post Footings

The Post Footings settings control the initial attributes of footings created with the Post with Footing  tool. 

 l Specify the Height Above Floor value, measured from the top of the subfloor of the room in which the post is 
placed.

 l Specify the top to bottom Thickness of the footing.

 l Specify the Width of the footing. This is the length of each side of a square footing and the diameter of a round 
footing.

 l Select the Square or Round radio button to specify the initial shape of post footings. Once created, a post footing 
can be edited like other closed polylines. See Editing Closed Polyline-Based Objects on page 157.

ROOF PANEL

The settings on the ROOF panel of the Build Framing dialog are exactly the same as those on the STRUCTURE panel of the 
Build Roof dialog. See Build Roof Dialog on page 579.

These settings are also found on the STRUCTURE panel of the Roof Plane Specification dialog. Those settings that apply to 
ceiling planes are available in the Ceiling Plane Specification dialog. See Roof Plane Specification Dialog on page 597.

Note: Changes made on the Roof panel will not affect the structure of 
existing roof planes. To make changes take effect, rebuild the roof.
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Automatic Roof Framing

Check Automatic Roof Framing to automatically rebuild roof framing if changes are made to the roof plan. See Automatic 
Framing on page 631.

 l Check Use Framing Reference to use a Framing Reference Marker as the starting point for rafter layout. See 
Framing Reference Markers on page 651.

Note: Use Framing Reference is useful when framing a gable roof, but 
not necessarily a hip roof. See Framing References and Roof Framing 
on page 652.

  Roof

 l Check Build Roof Framing to build roof framing for the entire model. Not available in the Framing Defaults dialog. 
See Roofs on page 573.
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 l Uncheck Angled Dormer Hole to frame dormers using rafters under the dormer valleys and a double header where 
the peak of the dormer roof meets the main roof plane. When checked, a five-sided hole is framed with two angled 
double rafters located under the dormer valleys. 
If a double header does not fit within the main roof plane, an angled dormer hole is produced regardless of this 
setting. 

 l Uncheck Trim Framing To Soffits to generate full-depth rafters all the way to the subfascia. If checked, rafter 
depths are trimmed to the top surface of the soffits in the eave area.

 l Specify the Spacing of automatically generated rafters.

 l Specify the Maximum Lookout Spacing. Depending on a roof plane’s length, its lookouts may be spaced closer 
than this value, but not further.

 l Uncheck Trim Framing To Soffits to generate full-depth rafters all the way to the subfascia. If checked, rafter 
depths are trimmed to the top surface of the soffits in the eave area.

 l Specify the Spacing of automatically generated rafters.

 l Specify the Maximum Lookout Spacing. Depending on a roof plane’s length, its lookouts may be spaced closer 
than this value, but not further.

Specify the Blocking Style. See Roof Blocking on page 634. 

 l Check Vertical to generate blocking that is oriented vertically, or plumb. When unchecked, blocking is 
perpendicular to the roof framing. 

 l In Line produces blocking pieces that align with each other.

 l Stagger produces blocking that alternates on either side of the line you draw. 

 l Cross/Bridging produces cross bridging that looks like in line blocking in plan view, but shows as cross bridging 
in 3D views and the materials list. 

 
Roof Size

Specify the desired Width and Depth for Rafters, the Ridge, Lookouts, Gable Sub Fascia  Eave Sub Fascia, Gable 
Fascia, Eave Fascia, Blocking, and the Shoe Plate.         
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 l The Gable Sub Fascia setting controls the height of both gable and eave soffits, and thus the depth of rafter tails 
when Trim Framing to Soffits is checked, above.

 l Uncheck the boxes beside Ridge, Lookout, Eave Sub Fascia, Gable Fascia and/or Eave Fascia to prevent these 
framing members from generating when roof framing is built. When these boxes are checked, these items will 
generate as specified here. 

 l In the Ceiling Plane Specification dialog only, check Include Ridges to create ridge boards for the selected ceiling 
plane(s) when roof framing is generated.

 
Hip Girder Truss

Specify how hip-end girder trusses are generated.

 l Specify the Count, which is how many trusses are generated side by side to produce a girder truss.

 l Specify the Distance from Wall Main Layer, which is the distance from the outermost girder truss to the outside of 
the Main Layer of the wall that support the sub-girder trusses. When Automatic is checked, hip-end girder trusses 
are generated on layout, and approximately 4' (1200 mm) from the outside of the exterior of the wall's Main Layer.

 
Roof Overframing

These settings affect how roof framing is generated at locations where roof planes are drawn to represent an overbuild 
situation.    

 l Check Roof Overframing to generate shoe plates for the upper roof's rafters to join to in overbuild situations. When 
unchecked, no shoe plates are created.    

 l Specify the Overframe Layer, which is the layer of the lower roof assembly that the shoe plate snaps to when roof 
framing is generated.    

 o Select Roof Finish to generate overbuild framing on top of the topmost layer of the roof's Surface Definition.    

 o Select Sheathing to generate overbuild framing on top of the lowermost layer of the roof's Surface Definition.    

 o Select Structural to generate overbuild framing on top of the roof's Structure Definition.

TRUSSES PANEL

Changes to the settings on this panel do not affect any trusses that are already present in the current plan. See Trusses on 
page 663.

The spacing of automatically generated trusses is specified on the ROOF and Floor panels of this dialog.

Home Designer Pro does not engineer trusses. Always consult an 
engineer or truss company to have your trusses professionally 

designed.
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Roof Truss Member Depth

Roof trusses use the default Width setting for Rafters. See Roof Panel on page 644.                 

 l Specify the depth of the Top Chord. This value is the default roof plane Structure Thickness when the Framing 
Method is Trusses.

 l Specify the depth of the Bottom Chord.

 l Specify the depth of the Webbing.

 
Roof Truss Maximum Horizontal Span

These settings control the maximum distance between the junctions where webbing meets the Top Chord and Bottom 
Chord. Changing these values can create different truss configurations such as kingpost, queenpost, fink, double fink, fan, 
howe, or double howe. 
These distances are measured horizontally for both roof and floor and ceiling trusses. In some instances, especially in 
more complex trusses, making these spans equal may result in the webbing appearing more normal or standard. See 
Trusses on page 663.

  Roof Truss Options

 l Check Require Kingpost to include a central vertical webbing member. If this is unchecked, a vertical member may 
still be created, depending on the Maximum Horizontal Span settings and the length of the truss.

648



Home Designer Pro 2025 Reference Manual - Framing Defaults Dialog

 l Check Energy Heel to remove the bottom chord from the overhang area. For an energy heel to be modeled, the roof 
should also be raised off the top plates by at least 7”, depending on the roof pitch. See Energy Heels on page 672.

  Floor/Ceiling Truss Member Depth

 l Specify the depth of the Top Chord.

 l Specify the depth of the Bottom Chord.

 l Specify the depth of the Webbing.

 
Floor/Ceiling Truss Options

The Maximum Horizontal Span setting controls the maximum distance between the junctions where webbing meets the 
Top Chord and Bottom Chord.

PLAN DISPLAY PANEL

The settings on the PLAN DISPLAY panel affect the appearance of Joists, Rafters, Trusses, and General Framing members in 
plan view. See Displaying Framing on page 655.

 l Specify the Default Fill Style for joists, rafters, and General Framing members by clicking the Fill Style button to 
open the Default Framing Fill Style dialog. See Displaying Framing on page 655. 

 l The Default Fill Style is not a dynamic default setting. Any framing already present in the plan will not be affected if 
you change it.

 l Check Use Line for Framing to show joists, rafters, and General Framing members as single lines rather than as 
closed polylines. See Displaying Framing on page 655. 

Note: The Use Line for Framing setting is dynamic but affects the current 
floor only. The Default Fill Style setting affects all framing as it is 
created but is not dynamic.

MATERIALS PANEL

The default materials that display on General Framing objects and Rafters are specified on the MATERIALS panel. These 
materials are used in 3D views only and are not used in the Materials List. Materials List information is derived from the 
structure Type of each framing object. See Framing and the Materials List on page 659.

Changes made on the MATERIALS panel of the Build Framing dialog only affect subsequently created framing: both 
manually drawn and automatically generated.
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The settings on this panel of the Build Framing dialog are the same as in many other specification dialogs. See Materials 
Panel on page 750.

 

Building Framing
There are several ways to generate framing. If any layers associated with framing that can display in the current view are 
not turned on, you will be given an opportunity to turn them on if you wish. See Displaying Framing on page 655.

BUILD ALL FRAMING

Select Build>Framing>Build All Framing to generate framing in all structural components that have framing as 
part of their definition: walls, floors, ceilings, and roofs. Framing is generated throughout the model based on current 

settings and structural conditions. See Framing Defaults on page 627.

BUILD FRAMING DIALOG

Select Build>Framing>Build Framing to specify which structural components to generate framing in.

 
Framing Defaults

Click this button to open the Framing Defaults dialog. See Framing Defaults Dialog on page 636.             

 
Automatically Rebuild Framing

Specify which structural components are automatically regenerated whenever changes are made to the structure. See 
Automatic Framing on page 631.

 
Build Framing Once

Specify which structural components you would like to generate framing for one time when you click OK in this dialog. See 
Manual Framing on page 631.                 
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BUILD FRAMING FOR SELECTED OBJECT(S)

The Build Framing for Selected Object(s) edit tool allows you to build or rebuild the framing for a selected wall, 
floor platform, Roof Plane or Ceiling Plane. It also allows you to ensure that a truss's envelope and webbing are up-

to-date.

Note: The Build Framing for Selected Object(s) edit tool is not 
available if the selected object has Retain Framing specified. See 
Rebuilding and Retaining Framing on page 631.           

Framing for Walls

The Build Framing for Selected Object(s) edit tool is available for walls using a framed wall type and for railings 
specified as Solid, but not for other types of walls and railings. See Wall Type Definitions on page 262. 

Framing for Rooms

The Build Framing for Selected Object(s) edit tool is only available for rooms that have Floor Under This Room 
checked, Monolithic Slab Foundation unchecked, and a framing material specified in its Floor Structure Definition. See 
Structure Panel on page 310.           

Rebuilding Trusses

If you make changes to a selected truss that affect its envelope or webbing, click the Rebuild Framing for Selected Object
(s) edit button to ensure that its configuration is up-to-date. This performs the same action as checking Force Truss 
Rebuild in the Truss Specification dialog. See Editing Truss Envelopes on page 669.

 

Framing Reference Markers
Framing Reference Markers are markers that specify the starting point for the layout of automatically-produced 
framing. See Markers on page 368.

In order for framing to be laid out relative to a Framing Reference Marker, it must be set to do so:

 l Floor and ceiling framing as well as deck joists can be set to Use Framing Reference on a floor-by-floor basis in the 
Build Framing dialog. See Floor Level Panels on page 636.

 l Roof framing can be set to Use Framing Reference plan-wide in the Build Framing dialog. See Roof Panel on page 
644.

 l Wall framing for individual walls can be set to Use Framing Reference in the Wall Specification dialog. See 
Structure Panel on page 270.

Each floor level can have its own Framing Reference Marker, which affects the layout of all framing members generated on 
that floor. If multiple markers are present on a given floor, the one that was created first is used and those created later are 
ignored. See In Plan View on page 655.

In many cases, a single Framing Reference Marker can be used for the entire model. When this is the case, it must be placed 
on Floor 1.

Note: If no Framing Reference Markers exist in your plan, the point at 
0,0 is used as the Framing Reference location for joists, while the 
framing for roof planes and walls generate relative to their parent object.
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USING FRAMING REFERENCE MARKERS

To place a Framing Reference Marker, select Build> Framing> Framing Reference Marker . Click in plan view to 

place the Framing Reference Marker and then build or rebuild some or all framing in the plan. Although Framing Reference 
Markers can be placed anywhere, a typical location is the corner of two exterior walls, at the exterior of their framing layer. 
See Wall Type Definitions on page 262.

When Object Snaps  are enabled, Framing Reference Markers snap to framing members and other CAD-based objects 

first, and then to a wall Main Layer surface or corner if possible. See Object Snaps on page 114.

Once placed, Framing Reference Markers can be modified just like other markers. See Markers on page 368.

When framing is generated using a Framing Reference Marker, the first framing member of a given type snaps to this point 
and all other framing members are laid out from there. 

 l Wall and roof framing snap to the Framing Reference Marker at their centers.
 l Floor and ceiling framing snaps to the Framing Reference Marker at their centers when it is set to Butt Over Support 

in the Build Framing dialog. See Floor Level Panels on page 636.
 l Floor and ceiling framing snaps to the Framing Reference Marker along an edge when it is set to Lap over a 

supporting beam or wall. If Lap is selected, the surfaces where the joists lap are placed at reference spacing, so that 
joists are placed on either side of the framing reference locations. 

MOVE TO FRAMING REFERENCE

Manually drawn or edited framing as well as automatic framing that was not generated using a Framing Reference 
Marker can be moved relative to a Framing Reference Marker using the Move to Framing Ref edit button. 

A group of selected framing objects that are all parallel to each other can be moved using the Move to Framing Ref edit 
button. Only one of the objects in the group is compared to the Framing Reference Marker and moved; the remaining 
objects are simply moved the same amount as the first object. Ideally, therefore, the group should have proper spacing 
relative to each other before the move. 

To move framing objects to a framing reference marker

 1.  Group select the framing objects.

 2.  Click the Move to Framing Ref  edit button.

 3.  The framing members are moved to the nearest Framing Reference Marker.

To determine placement, the Move to Framing Ref edit tool uses:

 l For wall studs, the default On Center Spacing for wall framing, which is set in the Build Framing/Framing Defaults 
dialog. See Wall Panel on page 638. 

 l For roof rafters, the On Center Spacing of the selected object's parent roof plane. See Structure Panel on page 600.
 l For floor and ceiling joists, the default On Center Spacing for the current floor set in the Build Framing/Framing 

Defaults dialog. They may instead reference spacing specific to a particular floor or ceiling platform. See Joist 
Direction Lines on page 653.

FRAMING REFERENCES AND ROOF FRAMING

Framing Reference Markers are useful when framing a gable roof, but not necessarily a hip roof. When a Framing 
Reference is used, common rafters on either side of a hip rafter will not meet in the same place.
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If a Framing Reference Marker is not used, the automatic framing utility starts common rafter spacing from each end of the 
horizontal ridges, which results in common rafters on either side of hip jacks meeting each other.

 

Joist Direction Lines
By default, automatically-generated floor and ceiling joists will run in the direction that results in the shortest span 
between beams. A Joist Direction line allows you to define the direction that joists in a particular floor or ceiling 

platform run, regardless of span.

To draw a Joist Direction line, select Build> Framing> Joist Direction , then click and drag as you would draw a CAD 

line. In order to have any effect, a Joist Direction line must be drawn within the area of a single floor or ceiling platform 
with a framing layer. If a Joist Direction Line is positioned outside of such an area, a non-suppressible Caution   symbol 
will display over it.

To avoid unexpected results, only one Joist Direction line should be present in a given floor or ceiling platform, and it 
should not extend outside the extents of that platform.

Joist Direction lines are located on the “Framing, Bearing Lines” layer and use the Text Style assigned to that layer. See 
Text Styles on page 373. 

MULTIPLE JOIST DIRECTIONS

By default, all of the rooms on each living floor share a single floor platform and a single ceiling platform. If you require 
joists that run in two directions in either of these platforms, begin by dividing the platform in question in two. There are a 
number of ways to do this:

 l Divide the living area into separate rooms with different platform thicknesses and/or heights. See Floor and Ceiling 
Platforms on page 303.

 l Draw a Floor/Ceiling Beam  specified as a Bearing Beam. See Floor/Ceiling Beam on page 635.

 l Draw a Bearing Line . See Bearing Lines on page 654.

Floor/Ceiling Beams and Bearing Lines should be drawn on the same living floor as the joists they will interact with. Floor 
framing for a living floor is created on the floor below, while ceiling framing for a living floor is created on that floor. See 
Floor and Ceiling Platform Framing on page 627.  

JOIST SIZE AND SPACING

The text of a Joist Direction line states the platform framing’s Structure Type and size, and the spacing. By default, these 
values reflect the settings in the Framing Defaults dialog. See Floor Level Panels on page 636. 

In plans using US Units, when the Structure Type is “Lumber”, the nominal size will be reported for the joists. For all other 
Structure Types, fractional inches are used. 

It is important to note that if a Joist Direction line is set to use non-default Spacing and Depth values, they will override the 
settings in both the Framing Defaults and Room Specification dialogs. It will not, however, change the settings in either 
dialog.
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Joist Direction Specification Dialog
Joist Direction Lines allow you to control joist spacing and attributes in the floor/ceiling platform in which it is 
drawn. To change these attributes, select a Joist Direction Line and click the Open Object edit button. See Joist 

Direction Lines on page 653.

Any changes made in this dialog will not affect any joists already present. In order for that to occur, framing must be 
rebuilt.

FLOOR JOIST PANEL

The FLOOR JOIST panel is available when the selected object is a Joist Direction  Line.

 l Define the Spacing of the joists in the platform associated with the selected Joist Direction line.
 l Define the Depth of these joists. 

Note: This is not the recommended method for specifying joist depth and 
spacing in most cases. You should instead use the settings in the Room 
Specification dialog. See Room Specification Dialog on page 308.

LINE STYLE PANEL

For information about the settings on this panel, see Line Style Panel on page 209.

ARROW PANEL

Joist Direction Lines do not use the Attach or Auto Position options for arrows. For information about the settings on this 
panel, see Arrow Panel on page 226.

 

Bearing Lines
It is not unusual for joists to lap or butt in the middle of a span rather than build across a platform. When they do, 
they typically bear on a beam at that point. To produce joists that break over a support, specify the beam in question 

as Bearing in the Framing Specification dialog. See General Panel on page 659. 

Joists lap or butt over the support depending on the option selected in the Build Framing dialog. See Floor Level Panels on 
page 636.

In either case, the joists’ overlap or butted ends are centered over the support. When an offset from the center is required, do 
not specify the wall or beam as Bearing and instead draw a Bearing Line. 

A Bearing Line directs the program to lap or butt joists where they cross the line instead of framing across to a wall. 

Select Build> Framing> Bearing Line , then click and drag to draw a Bearing Line as you would draw a CAD line. A 

Bearing Line should start outside the floor or ceiling platform and end outside it, passing completely through the building. 
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Bearing Lines are edited just like CAD lines, and can be connected to form polylines. See Editing Line-Based Objects on 
page 146 or Editing Open Polyline-Based Objects on page 153.

Bearing Lines are one of the ways that a floor or ceiling platform can be divided into separate smaller platforms with 
different Joist Directions . See Joist Direction Lines on page 653.

 

Displaying Framing
The display of framing members is controlled in the Layer Display Options dialog. Framing objects are created on 
one of over twenty layers with names that begin with “Framing,”: Ceiling Beams, for example, are placed on the 

“Framing, Ceiling Beams” layer. See Layer Attributes on page 125.

IN PLAN VIEW

In plan view, wall studs and posts are represented by box-based CAD objects that look like Cross Boxes. See Cross Box on 
page 221 and Editing Box-Based Objects on page 160. 

Joists, rafters, trusses,  General Framing, and headers are represented in plan view by line-based CAD objects that are look 
like long, thin rectangles. See Editing Line-Based Objects on page 146.

Note: The framing for the floor platform of a given floor level is drawn 
on the floor level below. See Floor Level Panels on page 636.

You can specify a default fill style for line-based framing members in the Build Framing dialog. See Plan Display Panel on 
page 649, Openings Panel on page 641, and Fill Styles on page 131.

By default, newly drawn line-based framing members of a given type display in front of older ones. Posts, meanwhile, 
display in front of beams, but behind joists. You can specify the drawing order of framing members in their specification 
dialogs. See Line Style Panel on page 662.

If you prefer, joists, rafters, trusses, and General Framing can instead be represented by a single line. The Use Line for 
Framing setting can be set differently for each floor in a plan. See Plan Display Panel on page 649.

IN 3D VIEWS

The easiest way to view framing in 3D is to use either the Orthographic Framing Overview  or Perspective Framing 

Overview  tool, which display the model using the "3D Framing Layer Set". See Framing Overview on page 778. 

Framing objects can display in other 3D and most cross section/elevation views, although by default they are not set to do 
so. If you wish to see framing in these views, turn on the framing layers when the view is active. Regardless of whether 
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their layers are on, framing objects will not display in Wall Elevation views or any cross section/elevation view that has 
Clip to Room checked. See Cross Section/Elevation Views on page 779.

To reveal framing covered by other objects or wall layers, use the Delete Surface  tool. See Delete 3D Surface on page 

785. 

IN CROSS SECTION/ELEVATION VIEWS

To display framing in a cross section/elevation view, make sure the framing layers are turned on in that view. See Layer 
Display Options Dialog on page 127. 

You can also use the Delete Surface  tool to temporarily delete the surfaces of wall layers or other objects that block the 

view. 

In cross section/elevation views, horizontal framing objects that are cut by the cross section plane display as boxes 
containing an ’X’. , Joist Blocking  and Roof Blocking  cut by the cross section plane displays as a box 

containing a single diagonal line. See  Cross Section/Elevation Views on page 779.

 

Editing Framing
Framing can be edited much like other line-based objects can using the edit handles, edit toolbar buttons, or the Framing 
Specification dialog. See Framing Specification Dialog on page 659.

Framing is organized into families which determine where it is generated and where it can be manually drawn. See Manual 
vs. Automatic Framing on page 630. Once framing has been created, however, it can be moved out of its structural 
component. In order to move roof framing above or below a roof plane, you must first check Manual Rafter Height in the 
Framing Specification dialog. See Framing Specification Dialog on page 659. 

When Start and End Indicators are enabled in the Preferences dialog, a selected framing member will display an S and an 
E at its start and end points. This makes it easier to choose which end to lock when specifying its Length or Angle. See Edit 
Panel on page 79.

Roof and floor/ceiling trusses cannot be edited like regular framing members can and are discussed in their own chapter. 
See Editing Truss Envelopes on page 669.

SELECTING FRAMING

Before a framing member can be edited, it must be selected. Framing can be individually selected in all views, and some 
types can be group-selected. To group-select framing in plan view, first select any of the Framing Tools. See Marquee 
Select on page 145.

To select framing objects of a particular type, use the Marquee Select Similar  tool’s Restrictive Selection  option. 

See Marquee Select Similar on page 145.
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USING THE EDIT HANDLES

In plan view, framing members can be drawn, edited, and moved much the way CAD lines can. See Editing Line-Based 
Objects on page 146. 

In cross section/elevation views, joists and rafters cut by the cross section and displaying a cross box can also be edited. See 
Editing Box-Based Objects on page 160. Also, in cross section/elevation views headers can be edited like closed polylines. 
See Editing Closed Polyline-Based Objects on page 157. 

In a camera view or overview, the handles that display on a framing member depend on where it is clicked for selection and 
your current zoom factor.

 l Click the top surface to display the same edit handles as in plan view, allowing you to rotate, move, and extend or 
shorten the length of the member.

 l Click a side surface to display the same edit handles as in an elevation view, one at each end and one at the center.
 l Zoom in and click on the appropriate edge to display edit handles that control the width and depth of framing 

members.

USING THE EDIT TOOLS

A selected framing member can be edited in a variety of ways using the buttons on the Edit Toolbar. See The Edit Toolbar 
on page 92.

  Move to Framing Reference moves the selection into alignment with a Framing Reference Marker. See 
Framing Reference Markers on page 651.

  Join and Lap Ends and Join and Mitre Ends join horizontal framing members at either a lapped or 
mitered joint. See Lapped and Mitered Joints on page 657, below.

USING DIMENSIONS

Framing members can be both moved and resized using dimensions in plan view and elevation views. See Moving 
Objects Using Dimensions on page 341. 

In order for a manually drawn Dimension Tool to locate framing objects as a dimension line is drawn, it must be set to do 
so in the Dimension Defaults dialog. See Locate Manual Panel on page 325.

LAPPED AND MITERED JOINTS

You can make two horizontal framing members meet at a lapped intersection using the Join and Lap Ends edit 
button.

To join and lap framing members

 1.  Select a horizontal framing member such as a joist, rafter, beam, or General Framing object.

 2.  Click the Join and Lap Ends  edit button.

 3.  Click on a second horizontal framing member that is not parallel to the initially selected member.

 4.  The two members now meet at a lapped joint. The initially selected framing member butts against the second one, 
which laps the end of the first.

Alternatively, mitered joints can be created using the Join and Mitre Ends edit button. This edit tool is used in the 
same way as the Join and Lap Ends tool.
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The Join and Mitre Ends and Join and Lap Ends tools not available for wall studs, Posts, Floor/Ceiling Trusses, or Roof 
Trusses.

STEEL AND CONCRETE

You can set framing defaults to generate steel framing and concrete structural members as well as lumber and other framing 
types. Individual framing members can also be specified as concrete or steel, as well.  

When setting up defaults or modifying an individual object, make sure you specify both the desired framing Type and the 
material. See Framing Types on page 629. 

DELETING FRAMING

Individual and group-selected framing members can be deleted the way other objects in the program are. See Deleting 
Objects on page 191. 

Categories of framing, such as wall framing or floor and ceiling framing, can also be deleted in the Delete Objects 
dialog. See Delete Objects Dialog on page 192.

 

Keeping Framing Current
When you modify your plan, move walls, raise or lower platforms or redesign the roof, any framing present in the plan will 
not update to reflect your changes. In order for the framing to be updated, you must regenerate automatically produced 
framing and either edit or delete and replace manual framing. 

For this reason, it is recommended that you wait until your model is finished, or nearly finished, before creating framing. 
See Drawing a Plan on page 26.

AUTOMATIC FRAMING

Automatically-generated framing can be rebuilt using either of two check boxes in the Build Framing dialog:

 l Select a Build check box to build automatic framing once. For example, check Build Wall Framing on the WALL 
panel to build wall framing once based on the current state of the model. If the model is changed later, you may need 
to do this again. 

 l Select an Automatic check box to build automatic framing every time a change is made to that structural component 
in the plan. For example, check Automatic Wall Framing on the WALL panel to rebuild all wall framing any time a 
wall is affected by changes to the model. 

When floor, ceiling or roof framing is regenerated, all automatically produced framing objects and any copies of them are 
deleted and new framing is calculated. See Rebuilding and Retaining Framing on page 631.

MANUAL FRAMING

It is vital to remember that manually drawn framing objects and copies of them are not retained when automatic framing is 
rebuilt. 

If a plan is not final, therefore, do not spend a lot of time altering or copying automatically produced framing objects. It is 
best to wait until your design is final before doing manual framing work. 
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Framing and the Materials List
Each framing member created in a plan is counted in the Materials List. See Materials Lists on page 950.

Framing can be calculated using one of several reporting methods.

 l Buy List calculates the framing materials of the different structural components of the plan by counting individual 
pieces and matching them to a list of board sizes that you specify.    

 l Cut List calculates the framing materials of the different structural components of the plan by counting the individual 
pieces present in the model.         

 l Linear Length calculates the framing materials of the different structural components of the plan in linear lengths.     
 l Mixed Reporting calculates framing materials using a combination of linear lengths and piece counts and is 

recommended for saved Materials Lists in legacy plans.    

Depending on what a framing member is used for, it may be listed in the Framing (F), Subfloor (SF), Roofing (R), or 
Decks-Walks (DW) category. See Categories on page 953.

 l Framing includes all wall framing, posts, and General Framing objects.
 l Subfloor lists floor and ceiling framing joists as well as sheathing.
 l Roofing includes trusses, rafters, and sheathing.
 l Decks lists posts, beams, joists, and planking associated with Deck rooms.

It is important to note that the floor, ceiling, and roof framing counted in the Materials List may vary considerably 
depending on whether framing of those types is actually present in the plan: 

 l If no framing is present in the model, then the required floor, ceiling, and roof framing is estimated. Total linear 
footage for various depths of rafters and joists is estimated, rather than a quantity of specific lumber lengths and sizes. 
Wall framing is not estimated. 

 l If even one floor, ceiling, or roof framing object exists in the plan, then objects in that category are counted instead of 
estimated for the Materials List. 

FRAMING MATERIALS AND THE MATERIALS PANEL

The materials applied to framing objects in 3D views are not used in the Materials List. Materials List information is 
derived from the structural use of each framing object and its Type - not the material seen on its surfaces in 3D views. See 
Materials Panel on page 649.

 

Framing Specification Dialog
Select a framing member and click the Open Object edit button to open the Framing Specification dialog for the type 
of framing member selected. 

The settings in this dialog are similar to those in the Post and Beam Specification and Defaults dialogs. See Framing with 
Beams on page 632.

The panels available in the Framing Specification dialog will vary, depending on the type of framing object that is selected.

GENERAL PANEL

The options available in on the GENERAL panel will vary depending on the type of framing member selected.
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  Automatic Height

 l When Automatic Height is checked, the selected Roof Rafter, Roof Beam, or Roof Blocking object generates 
within the structural layer of the roof plane(s) it is drawn in. Uncheck this box to enable the Manual Height settings 
that follow. 

 l If the selected object’s height is edited outside this dialog, Automatic Height will become unchecked automatically. 

  Depth and Height

 l Check the box beside Raise/Lower, then enter a positive value to raise or negative value to lower the framing object 
from its current position. The amount is added to both the Top and Bottom Heights when you click either Apply or 
OK, and does not affect the Depth. When Raise/Lower is checked, the other Depth and Height settings are disabled. 

 l Select the radio button beside one of the height values to Lock it, then change a value that remains available. 

 l Specify the Top Height of the post, as measured from the first floor subfloor at 0”. For a rafter, this is the top height 
at its low end.

 l Specify the Bottom Height of the post, as measured from the first floor subfloor at 0”. For a rafter, this is the 
bottom height its low end.

 l Specify the Depth of the framing object. For a rafter, this is the depth measured perpendicular to the roof plane.

 l Manual Rafter Height - Normally, the height of each Rafter or Roof Beam end is reset after any move or edit so 
that it is located just under the roof surface. Check this box to allow the height of the object to be changed. Only 
available for Rafters and Roof Beams. 
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  Options

 l Set the framing member’s Width, as seen in plan view. For Posts:

 o Instead specify Width 1 and Width 2.

 o Check Match Width 1 to ensure that the post is always square in shape when it is resized.

 l Specify a selected wall framing member’s Thickness, as seen in plan view. Only available for wall framing.

 l Select the selected framing member's structural Role from the drop-down list. See Framing Types on page 629.

 l Select a structural member Type from the drop-down list. The Round Type is unique to Posts. See Framing 
Composition on page 630.

 l Check Show Cross to display the selected Post as a cross box in plan view. Only available for Posts. See Displaying 
Framing on page 655.

Note: Instead of counting individual concrete posts and beams in the 
Materials List, the total volume of their concrete is calculated. The 
square footage for beam and post forms is also listed.

 l Check Bearing Beam to specify the selected Floor/Ceiling Beam as a load-bearing beam. When checked, 
automatically generated joists run perpendicular to the selected beam and either lap or butt over it, as specified in the 
Build Framing dialog. If the beam’s Top Height is at least 1” higher than the joists’ bottom height, the joists will 
instead butt against the sides of the beam. See Framing with Beams on page 632. Only available for Floor/Ceiling 
Beams. 

 l Check Treated to specify that the selected framing member be counted as treated in the Materials List.

 l The Rotate options let you rotate and align a selected wall stud, blocking, or header within the wall’s framing layer. 
Select None for the framing member’s Thickness to span the depth of the framing layer; select Flat to Outside to 
rotate the member 90° and align it with the outside of the framing layer; select Flat to Inside to rotate the member 
90° and align it with the inside of the framing layer. 

 
Length and Angle

Lock the point about which you want like the selected object to resize and/or rotate, then specify its exact length and angle. 
See Editing Framing on page 656. 

 l Specify the Length of the framing object. Rafter length is measured along the top of the rafter, and so is greater than 
the length measured in plan view. Not available for Posts.

 l Width 1 and 2 - Specify the Post width in each dimension. When a Round Post is specified, Width 1 refers to its 
diameter and Width 2 is not available.

 l Specify the Angle of the framing object in plan view. Changing this rotates the object about the location specified by 
the radio buttons described below.

 l Select Lock Center to resize or rotate the object about its center point. 
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 l Select Lock Start to resize or rotate the object about the location from which you started drawing the framing 
object.

 l Select Lock End to resize or rotate the object about the location where you stopped drawing it.

LINE STYLE PANEL

The settings on the LINE STYLE panel affect the selected object’s line style, its bumping behaviors, and its drawing order. 
See Line Style Panel on page 209.

FILL STYLE PANEL

For headers, floor, ceiling, and roof framing, and General Framing, the settings on the FILL STYLE panel affect the selected 
object’s appearance in plan view. See Fill Style Panel and Dialogs on page 132.

The settings on this panel are not available for wall framing members that display as a cross box in plan view.         

MATERIALS PANEL

The default materials on this panel are set in the Build Framing dialog. If you change the selected object’s framing Type, the 
material here may update - unless you have previously specified a non-default material. See Materials Panel on page 750.

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 967.          

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in the materials list. For more information, see 
Object Information Panel on page 968.   
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Chapter 24
 

Trusses

There are two basic ways to frame a roof. The first is commonly called “stick framing,” or sometimes “handstacking” or 
“cut-and-stack.” This type of roof incorporates framing such as rafters, ridges, and ceiling joists. See Framing on page 626.

The other method is to use prefabricated, engineered roof trusses. Home Designer Pro allows you to design and display a 
wide variety of trusses.

DISCLAIMER

Home Designer Pro does not engineer trusses. The trusses displayed by Home Designer are for illustrative purposes only. 
They can show how trusses are used in your plan, and help you communicate to the licensed engineer who produces your 
final truss design where you want your trusses and how you would like them to work.

Always have your truss designs approved by a licensed engineer.
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Truss Defaults
The default settings for floor, ceiling and roof trusses are set in the Framing Defaults dialog. Select Edit> Default 
Settings and in the Default Settings dialog, select Framing and click the Edit button.

 l The default settings for truss chord and webbing depth, maximum span, and kingpost are set in the Framing Defaults 
dialog. See Trusses Panel on page 647. 

 l The overall depth of individual Floor/Ceiling Trusses  are based on the thicknesses of the platforms in which they 

are drawn. See Floor Level Panels on page 636. 
 l The structure of Roof Trusses  is determined by the position of the roof plane(s) above and the ceiling plane(s) 

below. See Roof Planes on page 585 and Ceiling Planes on page 605.

You can also set the Heel Height for Roof Trusses in the Build Roof dialog. See Roof Panel on page 580.

 

Floor and Ceiling Trusses
Floor and ceiling trusses can be used instead of joists to frame platforms. As with floor and ceiling joists, the 
presence of a room above determines whether a platform is a floor or a ceiling and thus, whether a floor or ceiling 

truss is drawn. For example, a truss drawn on the first floor of a single story home will be a ceiling truss, while a truss 
drawn on the first floor of a two-story building will be a floor truss for the 2nd floor.

 l A floor or ceiling truss can only exist in a floor or ceiling platform. The vertical depth of the truss is defined by the 
Thickness of the platform's framing layer, so if you intend to use floor/ceiling trusses you should set your platform 
depths accordingly. See Floor and Ceiling Platforms on page 303. 

 l To generate floor and/or ceiling trusses automatically in a platform, select "Truss" as the Structure Type for the 
platform structure's Framing layer and then use the Build Framing dialog to generate floor/ceiling framing. See Floor 
Level Panels on page 636.

To draw a floor or ceiling truss manually, select Build> Framing> Floor/Ceiling Truss , then click and drag within a 

floor or ceiling platform in plan view. A Framing layer in the platform structure is required; however, its Structure Type 
does not have to be "Truss". See Drawing Trusses on page 665.

To create a sloped ceiling truss, draw a Roof Truss and specify it 
as a Sloping Flat Truss. See General Panel on page 675.

The TRUSSES panel of the Build Framing dialog contains default settings for floor and ceiling trusses. See Trusses Panel on 
page 647. These default settings can be overridden by the settings in the Floor/Ceiling Truss Specification dialog. See 
Floor/Ceiling Truss Specification Dialog on page 679.

 

Roof Trusses
Roof trusses can be used instead of or in combination with rafters to frame roofs and ceilings. Roof trusses can be 
automatically generated or drawn manually, and can only be created where a roof and ceiling are already present. To 

draw a roof truss, select Build> Framing> Roof Truss, then click and drag in plan view within one or more roof planes. 
See Drawing Trusses on page 665. 

If you intend to use roof trusses, you should build your roof planes with this in mind: 
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 l Before building the roof, select Trusses as the roof Framing Method in the Build Roof dialog. When this is selected, 
roof plane Structure Thickness is based on the default Top Chord Depth set in the Framing Defaults dialog. See 
Trusses Panel on page 647.

 l If Rafters is selected as the Framing Method, roof Structure Thickness is determined by the rafter Depth setting on 
the ROOF panel of the Framing Defaults dialog.

 l If you plan to use both trusses and rafters, build the roof using Rafters as the Framing Method and then manually edit 
the roof planes that will receive trusses. You can specify a roof plane's Framing Method in its specification dialog. See 
General Panel on page 598.

ROOF TRUSS PLACEMENT

The shape of a roof truss is defined by the space between the roof above and flat ceiling platform or manually drawn 
Ceiling Plane  below. 

 l If the bottom chords of trusses form the framing for a flat ceiling platform, ceiling joists in that platform will not 
automatically generate. See Floor and Ceiling Platform Framing on page 627.

 l If the bottom chords of trusses are defined by a sloped ceiling plane, a Scissor Truss will be created. See Scissors 
Trusses on page 674.

If the program either does not find both roof planes and a ceiling, or if there is not enough room between them to model a 
truss, a warning message will report that this is the case if you position one at that location. The problem truss may still 
display in plan view with a label of the form “TR-*”. If it does, it should be either moved or deleted. See Editing Trusses on 
page 667.

One or both ends of a truss may be truncated if they are drawn across another truss. If this happens, it will end exactly on 
the surface of the existing truss, producing a girder truss. See Girder Trusses on page 674.

Trusses can end on interior walls. You can draw a truss that partially crosses the building by starting and/or ending it within 
24” (600mm) of an interior wall. The truss end will snap to the Main Layer surface on the far side of the wall.

ROOF TRUSS WEBBING

The webbing in a newly drawn truss is controlled by the Top Chord and Bottom Chord settings in the Framing Defaults 
dialog. See Trusses Panel on page 647.

Making adjustments to these default values can result in different truss configurations such as kingpost, queenpost, fink, 
double fink, fan, howe, or double howe to be represented.

End Trusses have vertical webbing that can replace wall framing when the truss in question is positioned within an Attic 
wall. Automatically-generated End Trusses can also receive horizontal blocking.

 

Drawing Trusses
Trusses can be generated automatically or drawn manually and replicated. Trusses are drawn similar to the way CAD lines 
are and can be drawn in plan view only. See Draw Line on page 204. 

To draw and replicate trusses

 1.  Select either the Floor/Ceiling Truss  or Roof Truss  tool, then click and drag within either a floor/ceiling 

platform or one or more roof planes.
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 l As they are drawn, roof trusses will snap to any walls that they cross. 

 l When a roof truss ends over an exterior wall, it will extend into the roof eave, stopping at the inside edge of the 
Eave Sub Fascia.

 l When a roof truss is drawn over a Full Gable Wall, it will have End Truss and Reduced Gable checked 
automatically. 

 l Floor/Ceiling trusses will snap to the wall surfaces, the exterior surface of a wall’s Main Layer, as well as to a 
variety of CAD-based objects, and can be drawn to any length.

 2.  Reposition the truss:

 l Floor/ceiling trusses are often positioned relative to an exterior wall or Framing Reference Marker . See 

Framing Reference Markers on page 651.

 l Roof trusses are can be positioned over a gable end wall or at the ridge end of a hip. 

 3.  Open the truss’s specification dialog and edit its settings to meet your needs. See Roof Truss Specification Dialog on 
page 675 or Floor/Ceiling Truss Specification Dialog on page 679. 

 4.  Make multiple copies of the truss at specified intervals using the Transform/Replicate Object  edit tool. See 

Transform/Replicate Object Dialog on page 183.

The copies of Roof Trusses automatically conform to the structural conditions in their new locations. As a result, replicated 
Roof Trusses and their labels may be different from the original. See Truss Labels on page 669. 

Unlike Roof Trusses, Floor/Ceiling Trusses do not conform to new structural conditions when they are either moved or 
copied. See Moving Trusses on page 668.

 

Displaying Trusses
The display of trusses and their labels is controlled in the Layer Display Options dialog. The various truss types are 
placed on the "Framing, Ceiling Trusses", "Framing, Floor Trusses", and "Framing Roof Trusses" layers by default, 

while their labels are placed on the "Framing, Floor/Ceiling Truss Labels" and "Framing, Roof Truss Labels" layers. See 
Layer Display Options Dialog on page 127.

IN PLAN VIEWS

In  plan view trusses use the line style assigned to their layer by default, but can be assigned a different line style if you 
wish. See Line Style Panel on page 209.

By default, trusses use the fill style set in the Build Framing dialog in plan view, but can be assigned a custom fill. See Plan 
Display Panel on page 649.

Like other objects, trusses are placed in Drawing Groups that affect whether they display in front of or behind other objects 
in plan view. You can modify a selected truss’s place in the drawing order by clicking the View Drawing Group Edit 
Tools   edit button. See Drawing Groups on page 129.

Truss labels display in plan view when the “Trusses, Labels” layer is turned on and use the Text Style assigned to their 
layer. They are also used in the Materials List. See Truss Labels on page 669.
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IN 3D VIEWS

The easiest way to view trusses in 3D is to use either the Orthographic Framing Overview  or Perspective Framing 

Overview  tool, which display the model using the 3D Framing Set layer set. See Framing Overview on page 778. 

Trusses can display in other 3D and cross section/elevation views, although by default they are not set to do so. If you wish 
to see trusses in these views, turn on the “Framing, Trusses” layer when the view is active.

You can create exposed trusses by placing roof and ceiling planes to produce the desired truss structure, drawing the trusses, 
and then removing the ceiling. See     Vaulted and Cathedral Ceilings on page 306.

To reveal trusses covered by other objects, you can use the Delete Surface  tool. See Delete 3D Surface on page 785.

IN THE MATERIALS LIST

All trusses are listed under the Roofing category in the Materials List. Their labels appear in the Size column, along with 
their length. See The Materials List Tools on page 951. 

 

Editing Trusses
Trusses can be edited much like other objects can using the edit handles, edit toolbar buttons, or the Truss Specification 
dialogs. See Roof Truss Specification Dialog on page 675 and Floor/Ceiling Truss Specification Dialog on page 679.

SELECTING TRUSSES

Before a truss can be edited, it must be selected. Like other architectural objects, Trusses can be individually and group-
selected selected in all views. See Selecting Objects on page 142.

To group-select trusses of a particular type, use the Marquee Select Similar  tool. See Marquee Select Similar on page 

145.

When Start and End Indicators are enabled in the Preferences dialog, a truss selected in plan view will display an S and 
an E at its start and end points.  See Edit Panel on page 79.

Trusses can be deleted individually, or all at once in the Delete Objects dialog. See Delete Objects Dialog on page 192.   

USING THE EDIT HANDLES

In plan view, trusses can be drawn, edited, and moved much the way CAD lines can. See Editing Line-Based Objects on 
page 146.

When editing a roof truss’s length, bear in mind that if you position either of its ends at a location that doesn’t correspond to 
a roof plane edge, interior wall, or another truss, Use Special Snapping will automatically become unchecked in its 
specification dialog. 

When selected in a camera view, a truss can be edited like a closed polyline. This is not always recommended, though, 
because the truss may no longer match the space in the structure that it is meant to occupy. See Editing Truss Envelopes on 
page 669.

The depth of truss chords can be changed in the truss’s specification dialog, but not using the edit handles.   
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USING THE EDIT TOOLS

A selected truss can be edited in a variety of ways using the buttons on the Edit Toolbar. See The Edit Toolbar on page 92.

  Build Framing for Selected Object(s) rebuilds the envelope and webbing of the selected truss. See Editing 
Truss Envelopes on page 669.

  Move to Framing Reference moves the selection into alignment with a Framing Reference Marker. See 
Framing Reference Markers on page 651.

USING DIMENSIONS

Trusses can be repositioned precisely as well as resized using dimensions. See Moving Objects Using Dimensions on 
page 341.

In order for a dimension tool to locate trusses as dimensions are drawn, that tool needs to be set to do so in the Dimension 
Defaults dialog. See Locate Manual Panel on page 325. 

MOVING TRUSSES

Trusses can be moved using either their Move edit handle or the Transform/Replicate Object  edit tool. It’s important 

to note that Roof and Floor/Ceiling Trusses may behave differently when they are moved: 

 l When a Roof Truss  is moved, its shape updates to conform to the structural conditions defined by the roof and 

ceiling in its new location. To prevent this from occurring, check Lock Truss Envelope and Webbing in the Roof 
Truss Specification dialog before moving the truss. See Lock Truss Envelope and Webbing on page 669.

 l This is not the case with Floor/Ceiling Trusses : when moved to a location with a different platform structure, a 

Floor/Ceiling Truss will not update to conform to its new surroundings. It is important to draw, position, and copy 
them within the same floor or ceiling platform structure. If a different Floor/Ceiling Truss depth is needed, a new truss 
should be drawn. 

SPECIAL TRUSS SNAPPING

By default, Roof Trusses  have a number of special snapping behaviors that are used even when Object Snaps  are 

toggled off. See Object Snaps on page 114. 

These special behaviors include:

 l As they are drawn, Roof Trusses will snap to any walls that they cross. 
 l When drawn along an exterior wall, a Roof Truss will snap so that its outer surface is flush with the outer surface of 

the wall's Main Layer. 
 l When drawn along a roof plane edge, a Roof Truss will snap to the roof plane’s edge or corner. 
 l The center line Roof Trusses will snap to the line along which two roof planes meet. 
 l When a Roof Truss ends over an exterior wall, it will extend into the roof eave, stopping at the inside edge of the Eave 

Sub Fascia.

Floor/Ceiling Trusses  can be drawn to any length but also have special snapping:

 l Floor/Ceiling trusses will snap to the wall surfaces, the exterior surface of a wall’s Main Layer, as well as to a variety 
of CAD-based objects.
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If you edit a truss in such a way that its ends do not correspond to a special snapping location, Use Special Snapping will 
automatically become unchecked in its specification dialog. This allows you to easily customize a truss but may make it 
difficult to snap to commonly used locations. 

You can check or uncheck Use Special Snapping in the Roof Truss Specification dialog. See General Panel on page 675.

DELETING TRUSSES

Individual and group-selected trusses can be deleted the way other objects in the program can. See Deleting Objects 
on page 191.

Trusses can also be deleted by category as well as floor in the Delete Objects dialog. See Delete Objects Dialog on 
page 192.

 

Editing Truss Envelopes
A truss envelope is the shape defined by a truss’s top and bottom chords.  When a truss is drawn, the envelope is derived 
from the floor platform, ceiling platform, or roof that the truss is drawn in. 

When a truss is viewed in a 3D view, its envelope can be edited like a closed polyline. See Editing Closed Polyline-Based 
Objects on page 157.

This function can be used to change a roof truss end or overhang as well as the overall truss shape. Changing the truss 
envelope does not change the structure that it is drawn in, however. 

In addition, when a Roof Truss  is moved, its shape updates to conform to the structural conditions defined by the roof 

and ceiling in its new location. As a result, a Roof Truss’s label can change when the truss is moved to a new location. 

Floor/Ceiling Trusses  do not update when moved to a location with different structural conditions.

FORCE TRUSS REBUILD

If you make changes to a selected truss that affect its envelope or webbing, you can ensure that its configuration is up-to-
date by checking Force Truss Rebuild in the truss's specification dialog. See General Panel on page 675.

LOCK TRUSS ENVELOPE AND WEBBING

The Lock Truss Envelope and Webbing attribute can be used to prevent a Roof Truss  envelope from updating when 

it is moved or replicated. See Roof Truss Specification Dialog on page 675. 

 

Truss Labels
Labels for roof  trusses display when the “Framing, Roof Truss Labels” layer is turned on in the current view. Similarly, 
floor and ceiling trusses display when the “Framing, Floor/Ceiling Truss Labels” is turned on. See Layer Display Options 
Dialog on page 127.

Truss labels are available in two formats: automatic and user-specified. See Label Panel on page 376.

Truss labels can display in plan view and are used in the Label column of the Materials List. See Displaying Trusses on 
page 666. 

Truss labels use the Text Style specified for their layer in the current view. See Text Styles on page 373.
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By default, truss labels are centered on the truss that they identify. If the truss is moved or deleted, the label is moved or 
deleted as well. When a truss is selected, its label has a small square Move edit handle. See Editing Trusses on page 667.

Truss labels obey the Minimum Display Size for labels set in the Preferences dialog. See Appearance Panel on page 63. 

If two or more trusses share the same configuration with identical chords and webbing, they will also share the same truss 
label.

AUTOMATIC TRUSS LABELS

Automatic roof truss labels use the format TR-X, where X is a number indicating the order in which each distinct truss 
configuration was created. For example, the first truss type created in a plan is labeled TR-1; the second, TR-2; and so on. 

Floor and ceiling trusses are labeled FTR-X and use the same numbering convention. 

 

Mixing Trusses with Stick Framing
After the trusses for your roof are in place, additional roof framing can be added. See Roof Framing on page 629. 

FRAMING DEFAULTS

Roof planes created using defaults set up for trusses will continue to use those defaults when stick framing is added. If you 
intend to add rafters, the roof planes should be created while Rafters is selected as the Framing Method in the Build Roof 
dialog. See Roof Panel on page 580.

Selecting Rafters as the Framing Method has a similar effect on roof trusses to that of Raise Off Plate: roof truss bottom 
chords may be longer than expected and their top chords, higher. This is necessary to create the space needed to 
accommodate the rafter’s depth.

AUTOMATIC FRAMING

The Build Framing dialog can be used to generate roof framing in areas not framed by the trusses, including gable eaves and 
the ends of hips. Note that rafters will not generate closer than 14” (350mm) to an existing, parallel truss. 

Automatically generated roof framing will not extend through an existing roof truss. Instead: 

 l Automatically produced rafters generate inward from the eave until they butt into a truss. 
 l Blocking for standard and hip ridges generates as individual rafter objects between trusses. 
 l Lookouts will pass over Reduced Gable trusses and will end at the next truss in. See Roof Truss Specification Dialog 

on page 675.
 l Hip ridges and common rafters at the end of a hip roof will pass over a Drop Hip Truss. See Drop Hip or California 

Hip on page 671.
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MANUALLY DRAWN FRAMING

Unlike automatically generated roof framing, manually drawn rafters will extend through trusses. Rafters can also snap to 
truss edges as they are being drawn or when they are being edited. See Manual Framing on page 631. 

 

Hip Trusses
A variety of different hip truss configurations can be created, including: 

STEP DOWN HIP

Step Down hip roofs are the quickest style of hip truss framing to produce. 

To create a step down hip truss system

 1.  First, draw a Roof Truss  at the apex of the triangular hip roof plane. When Object Snaps  are enabled, it 

will snap into position. See Object Snaps on page 114.

 2.  Select the truss; click the Transform/Replicate Object  edit button; and create enough copies of the truss in the 

direction of the hip to reach a reasonable minimum height. See Transform/Replicate Object Dialog on page 183. 

 3.  Using the Roof Truss  tool, draw hip jacks along the hip ridge from the last truss out into the overhang.

 4.  Using the Roof Truss  tool, draw a jack truss from the intersection of the last hip truss and the hip jack to the 

eave. 

 5.  Select the jack truss; click the Transform/Replicate Object   edit button; and lay out jack trusses up to the other 

hip jack.

DROP HIP OR CALIFORNIA HIP

A Drop Hip, or California Hip, system uses trusses with lowered top chords to support stick frame hip ridges and common 
rafters. 

To create a drop hip truss system

 1.  Start a drop hip truss system as you would a step down hip system. See Step Down Hip on page 671.

 2.  When the hip trusses are drawn, group select them, open the Truss Specification dialog, and select the Drop Hip 
Truss check box. See General Panel on page 675.

 3.  Use the Build Framing dialog to produce the common rafters, and the short joists at the hip end. See Build Framing 
Dialog on page 650.

The amount that the top chord is lowered is derived from the rafter Depth on the ROOF panel of the Framing Defaults 
dialog. Because both common rafters and hip ridges must pass over this truss, the ridge depth should be set equal to that of 
the rafter depth. 
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SUBGIRDER HIP

Sub-girders are the partial trusses that butt into a reinforced girder truss at the end of the main run. Girder trusses and sub-
girders can be generated automatically, and you can specify the girder count as well as its distance from the end wall. See 
Roof Panel on page 644.

Girder trusses and subgirders can also be drawn manually.

To create a subgirder truss system manually

 1.  Draw a Roof Truss  and position it as needed: for example, where the hip apex meets the ridge.

 2.  Double it by drawing a second truss on the far side from the hip section. 

 3.  Using the Roof Truss  tool, draw the first subgirder from the hip apex out to the eaves. 

 4.  Select it and use the Transform/Replicate Object  edit button to make copies in both directions. Stop when the 

height of the subgirders reach a reasonable minimum.

 5.  Finish off with hip jacks and jack trusses as in a step down hip system.

 

Special Roof Trusses
A number of special purpose roof trusses can be created in Home Designer Pro. 

ENERGY HEELS

An energy heel or raised heel truss is created when the roof is raised off of the wall top plates, creating space for additional 
insulation. When this is the case, a vertical member positioned over the supporting exterior wall is added to the truss. 

Energy Heel Truss

To create an energy heel

 1.  In the Build Roof dialog:

 l Specify the Framing Type as Trusses;

 l Specify the desired Heel Height;

 2.  Automatically generate or manually draw the roof planes.

 3.  Automatically generate roof framing or manually draw Roof Trusses. See To draw and replicate trusses on page 
665.
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 4.  By default, the bottom chord extends out to the subfascia. If a truss is moved or replicated into a position where an 
Energy Heel is required, open the truss’s specification dialog, check Energy Heel and Force Truss Rebuild, then 
click OK. See General Panel on page 675. 

Energy Heel Truss with shortened bottom 
chord

 5.  Use the Transform/Replicate Object  edit tool to make additional copies of that truss as needed. 

ATTIC TRUSSES

Attic trusses, a variation of roof trusses, can be drawn if a plan contains an Attic area on both sides and above an upstairs 
room, such as in a Cape Cod style home. The following is a typical cross section view of a building with attic trusses: 

Structure that meets requirements for Attic 
Trusses

Certain conditions must be met before an attic truss can be built: 

 l The structure should be sufficiently wide to allow for a loft and attic spaces.
 l The loft area must be on a living floor. It cannot be on the Attic floor. See The Attic Floor on page 525.
 l The loft area must have Attic rooms on both sides. See Room Types on page 289.
 l The loft area must be separated from the Attic rooms on both sides by Knee Walls. See Knee Walls on page 260.
 l A flat ceiling in the loft area and a floor below must be present. 
 l The roof pitch must be steep enough to provide appropriate ceiling height for the loft area. Typical pitches for such a 

condition are 8 in 12 or greater.
 l The roof should bear on the walls of the floor below the loft area and form continuous planes from ridge to baselines.

Once these conditions are met, a roof truss is ready to be designated as an attic truss. 

 1.  Select the roof truss in plan view and click the Open Object  edit button to display the GENERAL panel of the 

Roof Truss Specification dialog.

 2.  Check the box beside Attic Truss and click OK. See Roof Truss Specification Dialog on page 675.
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Attic Truss

SCISSORS TRUSSES

Trusses drawn between roof planes and sloping ceiling planes of a different pitch than the roof are called  Scissor trusses. 
See Ceiling Planes on page 605.

The following is an example of a scissors truss drawn beneath an 8 in 12 pitch gable roof and above 4 in 12 pitch ceiling 
planes. 

Scissor Truss

GIRDER TRUSSES

Girder trusses provide extra support for various purposes. Hip end girder trusses consisting of two or more trusses side by 
side can be generated automatically. See Hip Trusses on page 671.

 

Other types of girder trusses can be drawn manually. For example, you can draw a new truss from an existing truss to the 
roof edge, as you would to draw a hip or end jack truss; or draw a truss between two trusses, forming a girder.

Girder Trusses reinforcing a skylight hole

Trusses cannot be drawn through each other. If a truss is drawn through an existing truss, the program automatically 
shortens it so that it butts into the existing truss.
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SLOPING FLAT TRUSSES

A sloping flat truss is a roof truss that builds within the rafter area of the roof plane(s) it is drawn in. In order to create one, 
the roof plane(s) must have a rafter depth deep enough to accommodate its chords and webbing.

Sloping Flat Truss

To create a sloping flat truss

 1.  Select the roof plane in which you would like to draw sloping flat trusses and click the Open Object  edit button. 

 2.  On the STRUCTURE panel of the Roof Plane Specification dialog, specify the  Rafter depth as the desired depth of 
the sloping flat truss. See Structure Panel on page 600.

 3.  Select the roof truss and click the Open Object  edit button. 

 4.  On the GENERAL panel of the Roof Truss Specification dialog, check the boxes beside Sloping Flat Truss and 
Force Truss Rebuild, then click OK. See General Panel on page 675.

 5.  Use the Transform/Replicate Object  edit tool to replicate the truss within the area of the roof plane(s) edited in 

step 2. 

 

Roof Truss Specification Dialog
Select one or more roof trusses and click the Open Object edit button to open the Roof Truss Specification dialog. 
See Roof Trusses on page 664.

The Roof Truss Specification dialog allows you to redefine attributes of an existing truss or group of trusses. Some settings 
affect only individual trusses, such as gable trusses, while others affect the whole group.

The shape or volume of a roof truss is controlled by the roof planes above it and the ceiling planes below it. It cannot be 
changed from this dialog.

Truss webbing is drawn for representational purposes only and 
as with trusses in Home Designer Pro in general, is not 

engineered.

The Roof Truss Specification dialog has the following panels:   

GENERAL PANEL

The defaults for many of the settings on the GENERAL panel are set in the Build Framing dialog. See Trusses Panel on page 
647. 
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Member Sizing

Specify the sizes of the different members that form the selected truss.    

 l Specify the depths of the Top Chord and Bottom Chord.

 l Specify the depth of the Webbing.

 l Specify the Thickness, which is the width of the truss in plan view. 

A. Top Chord
B. Bottom Chord
C. Webbing

 
Maximum Span

Specify the Maximum Span, which is the maximum horizontal distance between supports along the Top and Bottom 
Chords. When these values are equal, the truss webbing often appears more regular.

 
Options

Additional Options allow you to create special truss types.
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 l Check Require Kingpost to require a vertical webbing member from the roof peak to the bottom chord.     

Roof Truss with Kingpost

 o If Require Kingpost is unchecked, a kingpost may still be supplied, depending on the truss length and the specified 
maximum spans.    

 l Check End Truss to replace the webbing with vertical members positioned and spaced the same as the wall studs 
below.     

End Truss

 o If an End Truss is in the same position as an Attic wall, it replaces the framing that would otherwise be produced for 
that wall when Include Automatic End Truss Above is checked in the specification dialog for the wall below. See 
Roof Panel on page 272. 

 o Automatically-generated End Trusses can also receive horizontal blocking, when specified in the Framing Defaults 
dialog. See Trusses Panel on page 647.    

 l Check Energy Heel to remove the bottom chord from the overhang area. For an energy heel to be modeled and for 
this setting to have an effect, the roof should also be raised off the top plates by at least 7”, depending on the roof 
pitch. See Energy Heels on page 672.    

Energy Heel Truss with shortened bottom 
chord

 l Check Drop Hip Truss to lower the flat top of a truss in the hip area of a roof so that common rafters and hip ridges 
can pass over and be supported by it. See Drop Hip or California Hip on page 671.    

 l Check Reduced Gable to lower the top chord of an End Truss so that lookouts can pass over the truss. Reduced 
trusses do not have overhangs, but you can draw short rafters drawn at the ends of the truss.
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The Insert End Truss in Attic Wall option in the Wall 
Specification dialog automatically produces a Reduced 

Gable End Truss above a selected wall. See Structure Panel on page 
270.

 l Check Attic Truss to specify an attic truss. See Attic Trusses on page 673.    

 l Check Sloping Flat Truss to create a truss with a bottom chord that follows the underside of the roof plane(s) it is 
drawn in. When this is unchecked, the bottom chord follows the ceiling of the room or manually drawn ceiling plane 
below. See Sloping Flat Trusses on page 675.    

 l Check Force Truss Rebuild to rebuild the truss envelope based on the current state of the ceiling and roof when you 
click OK. See Force Truss Rebuild on page 669.    

 l Check Lock Truss Envelope and Webbing to lock the size and configuration of the selected truss. If a locked truss 
is moved, it will maintain its original settings and will not fit properly if the new roof and ceiling conditions are 
different from the original. See Lock Truss Envelope and Webbing on page 669.    

 l Uncheck Use Special Snapping to prevent the selected truss from using special truss snapping behavior. This box 
may become unchecked automatically if you edit a truss using its edit handles. When unchecked, Object Snaps  

may still occur. See Special Truss Snapping on page 668.

 
Preview

A preview of the selected truss displays on the right side of the panel. See Dialog Preview Panes on page 21. 

LINE STYLE PANEL

The settings on this panel affect the appearance of the selected truss in plan view only. See Line Style Panel on page 209.

FILL STYLE PANEL

The settings on this panel affect the appearance of the selected truss in plan view. See Fill Style Panel and Dialogs on page 
132.

MATERIALS PANEL

The settings on the MATERIALS panel affect the appearance of the selected truss in 3D views. See Materials Panel on page 
750.
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LABEL PANEL

Roof truss labels can display in plan view when the “Framing, Roof Truss Labels” layer is turned on and use the Text Style 
assigned to that layer. See Text Styles on page 373.

For more information about the settings on this panel, see               Label Panel on page 376.         

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 967.          

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in the materials list. For more information, see 
Object Information Panel on page 968.   

 

Floor/Ceiling Truss Specification Dialog
To open the Floor or Ceiling Truss Specification dialog, select one or more floor or ceiling trusses and click the 
Open Object edit button. See Floor and Ceiling Trusses on page 664. 

Default values for trusses are set in the Build Framing dialog. See Framing Defaults Dialog on page 636. 

The Floor/Ceiling Truss Specification dialogs have the following panels:

GENERAL PANEL

 
Member Depth

Specify the Member Depth of the different components of the selected truss.

 l Specify the depth of the Top Chord.

 l Specify the depth of the Bottom Chord.
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 l Specify the depth of the Webbing.

 
Thickness

Specify the Thickness of the truss’s chords and webbing.

 l Specify the Overall Thickness of the selected truss.

 l Specify the thickness of the Webbing. 

 
Maximum Span

Specify the Maximum Span, which is the maximum horizontal distance between supports along the Top and Bottom 
Chord.                      

  Options

 l Check Vertical Supports to use vertical supports in the selected truss. 

 l Check Force Truss Rebuild to rebuild the truss envelope based on the existing floor or ceiling platform when you 
click OK. Not available if Lock Truss Envelope and Webbing is checked, below. See Force Truss Rebuild on page 
669.

 l Check Lock Truss Envelope and Webbing to lock the size and configuration of the truss. A locked truss which has 
been relocated will maintain its original settings. See Lock Truss Envelope and Webbing on page 669.

 l Uncheck Use Special Snapping to prevent the selected truss from snapping along its long edge to a wall’s Main 
Layer or to the corner of a roof plane. If disabled, Object Snaps  may still occur. See Special Truss Snapping on 

page 668.

 
Preview

A preview of the selected truss displays on the right side of the panel. See Dialog Preview Panes on page 21. 

LINE STYLE PANEL

The settings on this panel affect the appearance of the selected truss in plan view only. See Line Style Panel on page 209.   

FILL STYLE PANEL

The settings on this panel affect the appearance of the selected truss in plan view only. See Fill Style Panel and Dialogs on 
page 132.   

MATERIALS PANEL

The settings on the MATERIALS panel affect the appearance of the selected truss in 3D views. See Materials Panel on page 
750.   
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LABEL PANEL

Floor and ceiling truss labels can display in plan view when the “Framing, Floor/Ceiling Truss Labels” layer is turned on 
and use the Text Style assigned to that layer. See Text Styles on page 373.   

For more information about the settings on this panel, see               Label Panel on page 376.         

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 967.          

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in the materials list. For more information, see 
Object Information Panel on page 968.   
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Chapter 25
 

Trim and Moldings

The Trim Tools allow you to place corner boards and quoins at wall intersections that form corners. 

You can also assign moldings to a variety of objects, such as rooms and cabinets, in those objects’ specification dialogs. See 
Specification Dialogs on page 20.

TOPICS

Trim and Molding Defaults 683
Corner Boards 683
Corner Board Specification Dialog 684
Quoins 685
Quoin Specification Dialog 685
Editing Corner Boards and Quoins 687
Moldings and Millwork 688
Moldings /  Rails Panels 688
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Trim and Molding Defaults
Select Edit> Default Settings to open the Default Settings dialog where you can access the defaults for a variety of 
drawing tools, including a number that affect trim and moldings. 

 l Click the + beside “Corner Trim” to access the defaults for Corner Boards and Quoins. See Corner Boards on page 
683 and Quoins on page 685.           

 l Click the + beside “Floors and Rooms”, then beside “Floor Levels”. Select a floor level and click the Edit button to 
specify the default moldings for rooms on that floor. See Floor Level Defaults on page 287.          

 l Click the + beside “Door” to access the defaults for Interior and Exterior Doors. See Door Defaults on page 379. 
 l Select “Window” and click the Edit button to specify the default casing for windows. See Window Defaults on page 

409.
 l Click the + beside “Cabinet” to access the defaults for the Cabinet Tools, where you can specify default crown and 

other moldings. See Cabinet Defaults on page 445.         

 

Corner Boards
Corner boards are added to a building exterior in any view by selecting Build> Trim> Corner Boards.

Click at a wall corner where you want to add trim. Be sure to click where the outside wall surfaces meet. If you click where 
the inside surfaces meet, corner trim will be created inside the room.

You can also add Corner Boards to all exterior corners at once by selecting Build> Trim> Auto Place Corner Boards .

         

By default, Auto Place Corner Boards  adds Corner Boards to outside corners only. If you prefer, you can specify that 

inside corners receive corner boards in the Corner Board Defaults dialog. See General Panel on page 684.

Note: The Auto Place Corner Boards tool does not place corner boards 
on manually drawn dormers or at intersections with Attic Walls. See Attic 
Walls on page 259.

Corner boards extend from the top plate down to the bottom of the floor platform of the floor on which it is placed, but do 
not extend to other floors. You must add corner boards to all floors of the building that you want to have corner boards. 

A selected corner board or boards can be moved, but only to another wall corner or corners.  In 3D views, corner boards can 
be lengthened or shortened using the edit handles. Corner boards can be copied, deleted and resized similar to other objects 
using the Edit Toolbar or the Corner Board Specification dialog. See Corner Board Specification Dialog on page 684.

The default material for corner boards is defined by the Exterior Trim entry in the Material Defaults dialog. See Material 
Defaults on page 746. 
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Corner Board Specification Dialog
Select one or more corner boards and click the Open Object edit button to open the Corner Board Specification 
dialog.

The settings in this dialog are similar to those in the Corner Board Defaults dialog, but affect the selected corner boards 
rather than all subsequently created corner boards.           

GENERAL PANEL

Specify the Width and Thickness of the selected corner board(s).         

Check Set Top/Set Bottom to specify the top and bottom heights of the corner board(s).           

 l If Set Top is unchecked, the top of the corner board automatically extends to the top plate.          
 l If Set Bottom is unchecked, the bottom of the corner board automatically extends to the bottom of the floor platform.          

In the Corner Board Defaults dialog, an additional Auto Place Option is available.          

 l Check Include Inside Corners to place Corner Boards on inside corners when the Auto Place Corner Boards  

tool is used. When unchecked, only outside corners receive corner boards.           

MATERIALS PANEL

The settings on the MATERIALS panel are available for a wide variety of objects in the program. For information about these 
settings, see Materials Panel on page 750.

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 967.          
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Quoins
Select Build> Trim> Quoins in any view and click at a wall corner where you want to place quoins. 

You can also add Quoins to all exterior corners at once by selecting Build> Trim> Auto Place Quoins .         

By default, Auto Place Quoins  adds Quoins to outside corners only. If you prefer, you can specify that inside corners 

receive quoins in the Quoin Defaults dialog. See General Panel on page 684.

Note: The Auto Place Quoins tool does not place quoins on manually 
drawn dormers or at intersections with Attic Walls. See Attic Walls on 
page 259.

A selected quoin or quoins can be moved, but only to another wall corner or corners. In 3D views, quoins can be lengthened 
or shortened using the edit handles. Quoins can be copied, deleted and resized similar to other objects using the Edit Toolbar 
or  the Quoin Specification dialog. See Quoin Specification Dialog on page 685.

The size of quoins in plan view is relative on their size in 3D.

Initially, quoins use the same material as the default material of the wall surface they are placed against. This material is 
specified in the Wall Type Definitions dialog. See Wall Specification Dialog on page 268.

 

Quoin Specification Dialog
Select one or more quoins and click the Open Object edit button to open the Quoin Specification dialog.

The settings in this dialog are the same as those in the Quoin Defaults dialog, but affect the selected quoins rather than all 
subsequently created quoins.          
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GENERAL PANEL

  Size and Position

 l Specify the Width, which is the horizontal dimension of each quoin in the selected Quoin object. The dimension 
along the other wall is half this value when they are staggered or mirrored.

 l Specify the Thickness, which is the amount that the quoin protrudes from the exterior surface of the wall.          

 l Specify the Quoin Height for individual quoins in the selected Quoin object.

 l Specify the Quoin Gap, which is the distance between successive quoins.          

 l Check Set Top/Set Bottom to specify the top and bottom heights of the quoin(s) in the text fields.           

 l If Set Top is unchecked, the top of the corner board automatically extends to the top plate.          

 l If Set Bottom is unchecked, the bottom of the quoin automatically extends to the bottom of the floor platform.          

  Style

 l Uniform - Produce quoins that are of equal length on both sides of the corner.

 l Staggered - Produce quoins that have one long side and one short side staggered on opposite sides of the corner.

 l Mirrored - Produce quoins that alternate having either two long sides or two short sides.

 l When Staggered or Mirrored is selected, check Swap Start Block to switch the starting order for the quoins.           

In the Quoin Defaults dialog, an additional Auto Place Option is available.          
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 l Check Include Inside Corners to place Quoins on inside corners when the Auto Place Quoins  tool is used. When 

unchecked, only outside corners receive quoins.          

MATERIALS PANEL

The settings on the MATERIALS panel are available for a wide variety of objects in the program. For information about these 
settings, see Materials Panel on page 750.

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 967.          

 

Editing Corner Boards and Quoins
Before a corner board or quoin can be edited, it must be selected. Click on a trim object when the Select Objects  tool is 

active. Corner boards and quoins can also be group selected and edited. See Selecting Objects on page 142.

Corner boards and quoins can be edited using their edit handles, the Edit Toolbar buttons, and their specification dialogs. 
See Corner Board Specification Dialog on page 684 and Quoin Specification Dialog on page 685.

USING THE EDIT HANDLES

Depending on the type of view, a corner board or quoin displays a different set of edit handles when selected. 

 l In plan view, corner boards and quoins display one edit handle and can be moved from one eligible location at a wall 
corner to another.

 l In 3D views, corner boards and quoins can be moved, lengthened, and shorted much the other line-based objects are. 
See Editing Line-Based Objects on page 146. 

USING THE EDIT BUTTONS

A selected corner board or quoin can be edited in a variety of ways using the buttons on the Edit Toolbar. See The Edit 
Toolbar on page 92.

DELETING CORNER TRIM

Corner boards and quoins can be selected individually or in groups and deleted using the Delete  edit button or the 

Delete key. They can also be removed using the Delete Objects dialog. See Deleting Objects on page 191. 
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Moldings and Millwork
Moldings and millwork are often used to enhance both the interior and exterior of designs.

MILLWORK

A selection of various types of millwork objects including columns, corbels and finials is available in the Library Browser. 
See The Library Browser on page 692. 

Most millwork objects are designed to be placed in a plan as free-standing objects. Some -  notably, newels and balusters - 
can be assigned to objects such as railings and stairs.              See Placing Library Objects on page 714.          

Both free-standing millwork and that assigned to an object can be replaced from the library in 3D views. See    Replace From 
Library on page 717.         

MOLDINGS AND RAILS

Moldings can be applied to rooms, doors, windows, and cabinets in their specification dialogs. The sizes of the rails on 
railing, fencing, stairs, and ramps can also be specified in a similar manner. See Moldings /  Rails Panels on page 688.

A selection of molding profiles including crown moldings and chair rails, can be found in the Library Browser. See 
Assigned Items on page 716.

REPLACING AN EXISTING MOLDING

If a molding profile has already been applied to an object, it can be replaced by another directly from the library in a 
3D view. Select Build> Trim> Replace Moldings, select a molding profile from the Select Library Object dialog, 

then move the mouse pointer into the view window and click on a molding in the view. See Select Library Object Dialog on 
page 716 and    Replace From Library on page 717.    

You can also select a molding profile directly from the Library Browser while a 3D view is active and move your mouse 
pointer into the view window. When a molding is selected, the pointer displays the Moldings   icon. When the mouse 
pointer is moved over a molding in the view, the Replace From Library   icon displays instead. Click on the molding's 
surface to change its molding profile.   

 

Moldings /  Rails Panels
The specification dialogs for a variety of objects in the program include a MOLDINGS panel. Select an object or group 
of similar objects and click the Open Object edit button to open the specification dialog for that selection. The 

settings available on this panel will vary depending on the type of object selected.   

The RAILS panel of the Railing, Fencing, Staircase, Ramp, and Stair Landing Specification dialogs is similar to the 
MOLDINGS panel. See Railing and Fencing Specification Dialogs on page 281 and Staircase Specification Dialog on page 
555.     
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  At the top of the dialog, one or more check boxes may be present.     

 l Only available for rooms, uncheck Use Floor Default to make the settings that follow active. Check this box to use 
the defaults set in the Floor Defaults dialog for the current floor. In the Room Type Defaults dialogs, the settings for 
Floor 1 are shown in the preview when this is checked. See Floor Level Defaults on page 287.      

 l If multiple objects with different moldings assigned to them are selected, a No Change check box will be available. 
Uncheck this box to make the settings that follow active but note that only moldings that all selected objects have in 
common will be retained.

Note: If multiple rooms are selected and only some of them have Use 
Default checked, these settings on this panel will not be editable.       

 
Molding/Rail Profiles

The selected object’s molding profiles or rail profiles are listed in a table and can be edited here.    

  On the RAILS panel of the Staircase, Ramp, and Stair Landing Specification dialogs, the table is divided into three sections: 
Top Rail, Middle Rail, and Bottom Rail. In the Wall Specification dialog, there is a fourth section: Beam.                 

 l Select the name of a molding to edit it or remove it from the object.       

 l Click in the Width and/or Height column and type to specify the selected molding’s size.      

 l Specify the Vertical Offset of the selected molding, measured relative to the default molding location on the object 
it is assigned to.       

 l A check mark in the To Top column means that the Vertical Offset value is measured from the top of the molding. 
When unchecked, this value is measured from the bottom of the molding. Click to place or remove a check mark.       
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 l When Retain Aspect Ratio is checked, if you change either the Height or Width, the other value changes to 
maintain their original ratio. When this is unchecked, the two values can be edited independently.       

 l On the RAILS panel of the Railing Specification dialog, check Full Wall Width to make the rail Width equal to the 
Thickness of the selected railing wall. Not available for stairs or ramps.      

The buttons on the right allow you to manage the moldings listed in the table. These are not available on the RAILS panel.     

 l Add New opens the Select Library Object dialog and add a new molding profile to the selected object. See Select 
Library Object Dialog on page 716.

 l Click the Make Copy button to add a copy of the selected molding profile at the bottom of the list.      

 l Replace removes the selected profile and replace it with a new profile from the Library.      

 l Move Up and Move Down change the order of the line items in the table. This does not change a selected item’s 
Height, Offset, To Top setting, or Type: only its position in the table.       

 
Selected Profile Options

The Selected Profile Options only apply to the molding profile selected above.

 l A preview of the molding profile(s) displays here. When multiple moldings of the same Type, To Top setting, or 
similar Height are specified, they will display together here, even when only one is selected. The selected profile is 
identified by thicker edge lines than the others. When multiple moldings of different Types, To Top, or Height 
settings are selected, no preview will display.      

 l When a room or cabinet is selected, choose a molding Type from the drop-down list. For rooms, the choices are 
"Base Molding", "Chair Rail", and "Crown Molding"; for base cabinets, "Edge Profile" and "Base Molding"; for wall 
cabinets, "Crown Molding" and "Light Rail"; and for full height cabinets, "Crown Molding" and "Base Molding". 
When a molding profile's Type is changed, its To Top setting may also change, above. See Room Moldings on page 
308 and Cabinet Hardware and Moldings on page 461.       

 l Click the Rotate Profile button to rotate a selected profile 90° counterclockwise, or to the left.      

Note: The Default Base Molding is a basic rectangular stock profile 
rather than a profile from the library. 

 
Preview

Many specification and defaults dialogs have previews of the selected object in which the moldings assigned to it can be 
seen. See Dialog Preview Panes on page 21.    

When Use Floor Default is checked in the Room Type Defaults dialog, this preview always shows the default moldings for 
Floor 1.
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Chapter 26
 

The Library

Home Designer Pro’s library offers thousands of symbols, materials, and images that can enhance any plan. 

New library catalogs and enhancements are  made available by Chief Architect Software on a continuing basis and are 
available for download for the current program version. 

You can also customize items from the library or import new items from outside the program and then save them in the 
library for future use.

TOPICS

The Library Browser 692
Searching and Filtering  the Library 698
Find in Library 704
Library Content 705
Downloading Library Content 707
Importing Library Catalogs 708
Adding Library Content 709
Organizing the Library 710
Editing Library Objects 713
Exporting Library Catalogs 714
Placing Library Objects 714
Select Library Object Dialog 716
Place Library Object Button 716
Replace From Library 717
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The Library Browser
The Home Designer Library Browser side window allows you to manage the contents of the library as well as add 
library content to your drawings. 

To open or close the Library Browser:
 l Select View> Library Browser.
 l Click the Library Browser  button.

 l Press Ctrl/⌘  + L.

When Double-Click Closes Browser is checked in the Preferences dialog, you can also close the Library Browser by 
double-clicking on an item in the Filter Results. Doing this will also close any other side windows that the Library Browser 
is docked with. See Library Browser Panel on page 67.

By default, the Library Browser is docked to the right side of the program window, but it can be undocked or docked to 
another side if you wish. See Side Windows on page 16.

The Library Browser has six panels: 

 l Filters and search options 
 l Folders tree list 
 l Filter Results 
 l Details
 l Preview 
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Filters

Search or filter the library to find the content you need. Filter Results are reported below. See Searching and Filtering  the 
Library on page 698.     

 l Type in the text field. A drop-down list of search results will appear below the field that updates as you type.

 o Click on a line item to use that item as a search parameter.     

 o You can also type and press the Enter key to use your text as a search parameter.

 l Click the Advanced Search  button to refine the current search parameters as well as create custom filters. See 

Advanced Search Dialog on page 702.

 l When Include Web Results  is toggled on, content that is available for download will be included in the Filter 

Results. Turn this option off to only include content already present in the library in the Filter Results. This option is 
also found in the Preferences dialog. See Library Browser Panel on page 67.
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 l All currently active search parameters are listed immediately below, each in a rectangle border.

 o You can also add search parameters to the current filter by selecting Folders and/or Tags.

 o Click on an item here to stop using it.

 l Click the Go Back in History  and Go Forward in History  buttons to cycle between filters that have been 

active during the current program session.      

 l The tree list in the Folders panel is filtered to only show content that matches your search criteria, and the Filter 
Results panel below is populated with all items that match the active search parameters.     

 l Click the arrow to the right of the Advanced Search button to select a filter from the drop-down list. “Not Filtered” 
will be the only available option until you either specify a search parameter, select a folder in the Folders panel, or 
create a custom filter.

 
Folders

The contents of the Library are listed in a directory tree and can be browsed here. When you select a folder, it will be listed 
as a search parameter under Filters, above, and its contents will be listed under Filter Results, below.             

 l The Folders tree list has five categories: Home Designer Core Catalogs, Home Designer Bonus Catalogs, 
Manufacturer Catalogs, User Catalog and Trash. See Library Content on page 705 and Deleting Library Items on 
page 712.    

If the Home Designer Core Catalogs, Bonus Catalogs, or 
Manufacturer Catalogs are empty, they will not be listed 

in the Folders tree list. See Downloading Library Content on 
page 707.

 l The basic structure of the directory tree is:      

 l Library items are always placed in alphabetical order within their hierarchy.    

 l Navigate the Folders panel tree list using the mouse and/or keyboard:    

 o Click the gray Expand arrow pointing to a catalog or folder to display its contents. Once expanded, you can click the 
black Collapse arrow pointing downward to close it again. Scroll through the list using either the scroll bar on the 
right or the mouse scroll wheel.    

 o You can also browse the list using the Arrow keys. The up and down arrow keys navigate up and down in the list, 
while the left and right arrow keys expand and contract a selected catalog or folder.    

 l Click on an item to select it. When you select an individual item, information about it will be shown in the Details 
and Preview panels below and you can place or apply it in your drawing. 

 
Filter Results

All library items that match the currently active search parameters listed in the Filters panel are listed here. Their total 
number is reported in the panel's heading in parentheses.     

694



Home Designer Pro 2025 Reference Manual - The Library Browser

 l Like the Folders list, the Filter Results can be navigated using the mouse and/or keyboard.

 l Click on an item to select it: information about it will be shown in the Details and Preview panels below, and you 
can place or apply it in your drawing. Basic information about it also displays in the program’s Status Bar. See The 
Status Bar on page 24. 

 l Multiple items can be selected for organization and limited editing purposes but cannot be placed in a drawing. 

 l You can choose to display the Filter Results in either List Mode or Grid Mode in the Toolbar panel, below.    

You can increase or decrease the size of the Filter 
Results tiles by pressing the Ctrl/⌘  key while scrolling 

the mouse wheel. See Three Button Mice on page 13.

 
Tags

Tags allow you to create custom categories which you can then assign library items to. Tags can be used as filters 
themselves, or as search attributes in more complex filters. The Tags panel does not display by default: click the Settings 
button in the Toolbar panel below to control which panels display.    

 l All available Tags are listed in this panel. Click on one to use it as a search parameter listed in the Filters panel, 
above. The currently selected Tag has a dashed outline.

 l Favorites is the installed system Tag.

 l Click the Create New  button to open the New Library Tag dialog and type a short, descriptive name for a new 

Tag. 

 l Right-click on a custom Tag to select Rename, Change Color, or Delete from the contextual menu.

 
Details

Information about the selected library item is reported here, including:

 l Type 

 l Catalog - See Library Content on page 705.

 l Folders - See Organizing the Library on page 710.

 l Tags - See Creating and Using Tags on page 700.

 l Notes - You can add a Note to any unlocked library item by clicking the Edit Notes  button in this panel. A text 

field becomes available and you can choose to Save Notes  as well as Insert Hyperlink .

 
Preview

When an item is selected either the Folders or Filter Results panel, a representation of the item displays in the Preview 
panel. If the selected object is a 3D symbol, you can  rotate and zoom in or out on the Preview using the mouse.
Options above the preview pane affect its appearance and vary depending on the type of object selected. These options are 
also found in most objects' specification dialogs:             

  The Standard, Vector View, and Glass House Rendering Techniques can be applied to the 
preview for architectural objects, as can Plan View. See Rendering Techniques on page 

832. You can specify whether Standard or Vector View is used by default in the Preferences dialog. See 
Appearance Panel on page 63.
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  Fill Window sizes and positions the selected object so that it fills the preview pane as much as possible.

  The display of Color can be toggled on and off in the preview for all item types.

  The display of Line Weights can be toggled on and off for Fill Patterns.

The options above the preview pane are different when a material is selected. These options are also found in the Define 
Material dialog:

  The Physically Based, Standard, and Vector View Rendering Techniques can be applied to the 
preview for materials.

  The display of Color can be toggled on and off in the preview for materials just as it can for most other item 
types.

  Click the Restore Original View button to reset the material preview to its original perspective. 

  A selected material will display on a shape in the Preview panel. The initial shape is a 
Teapot, but you can select a Cube, Sphere, or 2D Plane instead. The object shape 

selection is also shared with the Define Material dialog. See Define Material Dialog on page 760.

  A selected material's preview shape displays in front of a backdrop. You can either Use Default 
Room or a Backdrop from Library. The current as well as recently used backdrop images are also 

listed in the drop-down list. See 3D Backdrops on page 841.

  You can specify that the backdrop for materials be 
blurred in the Preferences dialog. See Appearance 

Panel on page 63.

 
Toolbar

The toolbar at the bottom of the browser aids in searching, displaying panels, and managing library content. The settings 
here are saved between program sessions.    

  The Settings menu lets you select which Library Browser panes are presented and which are hidden.     

  List Mode displays items in the Filter Results pane in a scrollable horizontal list with item name and preview 
thumbnail.

  Grid Mode displays items in the Filter Results pane as a grid of thumbnail images.     

  Open the Plant Chooser dialog. See Plant Chooser Dialog on page 936.     

  Update Library Catalogs downloads and installs updates to your installed catalogs to include the latest 
content. See Updating Library Catalogs on page 706.     

  Open the Preferences dialog, where display properties for the Library Browser can be controlled. See Library 
Browser Panel on page 67.

  Search Subfolders includes the contents of subfolders when a folder is an active search parameter. Turn this 
off to only include items saved in the folder itself, at the folder level: not in subfolders.     
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  When Include Folders in Text Search is toggled on, any folders that match a Text search will be listed in the 
Filter Results. Turn this off to include objects in the Filter Results but not folders.

CUSTOMIZING THE BROWSER

The Library Browser can be resized, moved, as well as docked with other Side Windows in the configuration of your 
choice. To return the Library Browser to its original position and size, click the Reset Side Windows button in the 
Preferences dialog. See Side Windows on page 16.

The panels in the Library Browser are customizable:

 l You can control which Library Browser panels display by clicking the Settings  button.

 l To adjust the height or width of a panel, place the pointer over the split bar you want to move. When the splitter cursor 
 displays, click and drag. See Dialog Panel Splitters on page 22.

 l Panels can be rearranged within the Library Browser side window. Click and drag a panel's title bar: When a 
highlighted space is created at the location you want, release the mouse button.

 l When your panel arrangement meets your needs, you can lock it: click the Settings  button, then select Lock 

Panels . When panels are locked, they can be resized but cannot be moved except via the Settings menu.

 l To return the Library Browser's panels to their original configuration, click the Reset Panel Layout button in the 
Preferences dialog. See Library Browser Panel on page 67.

USING THE CONTEXTUAL MENU

A number of important library functions can be accessed using the contextual menu. Right-click on an item in the Folders 
panel to open a contextual menu displaying options related to that item. A limited contextual menu is also available when 
you right-click on an item in the Filter Results panel. See Contextual Menus on page 18.

The options in the contextual menu vary depending on the item selected, but may include: 
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 l Update
 l Cut/Copy/Paste
 l Copy to User Catalog
 l Search in Folder(s)
 l New
 l Delete
 l Duplicate
 l Rename
 l Add Link
 l Tags
 l Export Library
 l Adjust Lights
 l Open Object
 l Expand All/Collapse All
 l Show in Folder
 l Vacuum
 l Restore from Trash

KEYBOARD COMMANDS

The Library Browser can be navigated using the Arrow keys on your keyboard. 

 l The right and left arrow keys expand and collapse folders.
 l The up and down keys change which library object is currently selected.
 l Select an item and press the F2 key to rename it.
 l Select an item and press the Delete key to delete it. 

EXPAND/COLLAPSE ALL

When a library category or folder is selected in the Folders pane, Expand All and Collapse All are available in the 
contextual menu, allowing you to expand or contract its contents in the tree list. All folders located within the selected 
folder are expanded or contracted, as well.

 

Searching and Filtering  the Library
Depending on how much library content you have imported or customized, the tree list in the Folders panel can be 
extensive. The Library Browser filtering options let you focus your searches using parameters that you define. There are 
several approaches to finding content.

SEARCHING THE LIBRARY

The most straight-forward way to find content in the Library Browser is to search for it. You can search for item names, 
folder names, object types, tags, and other search attributes.

When Include Web Results is enabled, content available for download from the Chief Architect 3D Library is also included 
in the Search results. Be sure to scroll down the Search drop-down list as well as the Filter Results.
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To search the Library Browser

 1.  Specify how you would like library folders treated for search purposes:

 l When Search Subfolders  is toggled on, the contents of subfolders are included when a folder is an active 

search parameter. Turn this off to only include items saved in the folder itself, at the folder level: not in 
subfolders.

 l When Include Folders in Text Search  is toggled on, any folders that match a Text search will be listed in 

the Filter Results. Turn this off to include objects in the Filter Results but not folders.

 2.  If you would like to search to one or more particular folders, select them in the Folders panel, then right-click on the 
selection and select Search in Folder(s). The selected folder(s) will act as filters until they are actively removed or 
another filter is selected.

 3.  Click in the Search text field at the top of the Filters panel and begin typing a keyword to search for. As you type, a 
list will drop down below the text field, showing search results that update as you type.             

The Library Filter drop-down list 
with search results.

 l Use the keyboard Arrow keys or scroll bar to scroll through the drop-down list.    

 l Click on a line item to use that item as a search parameter that influences how the Folders and Filter Results 
panels are populated, below.    

When Include Web Results is enabled, the search results 
include downloadable content available in the Chief 

Architect 3D Library. See Library Content on page 705.

 4.  You can use Boolean keywords and quotation marks to refine your search:

 l Boolean keywords (NOT, AND, OR), capitalized and with spaces, can be used. Shortcuts (!, +, |) can be used, as 
well.

 l Boolean keywords' are prioritized from highest to lowest in this order: not, and, or. Parentheses can also be used.

 l Use quotation marks “” to search for an exact word or phrase. Quotation marks around a Boolean keyword will 
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treat the keyword as a normal search term.

 l Press the Enter key to populate the Filter Results panel with items that match your search text. 

 5.  You can also search for Object Attributes, which are listed in the Advanced Search dialog:

 l Type

 l Style

 l Manufacturer

 l Symbol Type

 l Symbol Options

 l Symbol Placement

 l Hardware Options

 l Has Texture

 l Plant is 3D

 6.  To combine an attribute with a keyword, use this format: Attribute: keyword. 

 7.  Repeat steps 2 - 5 to add additional parameters to the current filter if you wish.

 8.  Click the Advanced Search  button to further refine your search as well as create a Custom Filter. See below.

 9.  You can click the Clear  button on the right side of the Search text field to remove anything typed in this field. 

 10.  Right-click on an item in the Filter Results list and select Show in Folder to view the item’s location in the Folders 
list.

 l Click the List Mode  button to display the Filter Results in a single column with each object's name to the 

right of its preview thumbnail.

 l Click the Tile Mode  button to display the Filter Results in a grid layout with each object's name beneath its 

preview thumbnail.

You can use the Go Back and Go Forward in History buttons in 
the Filter panel of the Library Browser to cycle between filters 

that have been active during the current program session.

CREATING AND USING TAGS

Tags let you group library items into categories that make library filtering more efficient for you. There are numerous uses 
for Tags, for example: to group items that you use often by drawing task, design style, or a particular project. Home 
Designer has a single system tag, Favorites , but you can create your own by clicking the Create New  button in the 

Tags panel of the Library Browser. See The Library Browser on page 692.

To add a tag to an item, right-click on it and select Tags> from the contextual menu. In the submenu, check the box beside 
each Tag that you would like to add to the selected item and then select Apply. See Using the Contextual Menu on page 
697.

You can also select Tags> Manage Tags from the contextual menu for one or more selected objects to open the Manage 
Library Tags dialog.
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Search

If you have created a large number of Tags, you can type in this field to search for a particular Tag name.                 

 l A drop-down list of search results will appear below the field that updates as you type: click on an item in that list to 
select and apply it to the selected objects.

 l You can also create a new Tag using what you have typed as its name.

  Tags for Item/Common Tags for Items

The names of Tags assigned to the selected object(s) are reported here.

 l When multiple objects are selected, only the Tags assigned to all objects will be named here.      

 l Click on a name to remove that Tag from the selected object(s).

  Tags

The names of all available Tags are listed here. 

 l Click on the name of a Tag to assign it to the selected object(s).

 l As in the Tags panel of the Library Browser, you can Create New  Tags as well as right-click on a Tag's name 

here and Rename, Change Color, or Delete.

To use a tag to find items in the Library Browser, simply click on its name in the Tags panel. All library items that have 
been assigned that tag will be listed in the Filter Results, where you can select them for use in your drawing. You can also 
include Tags in custom saved Filters.

FILTERING THE LIBRARY

A Library Filter is a set of one or more search parameters that allows you to search for specific content by restricting what is 
listed in the Folders and Filter Results panels. Library Filters can include plain text, a Symbol Type, an object Type, a 
Folder, and/or one or more Tags. You can add items to a filter by typing in the Search field, selecting a folder in the Folders 
panel, or selecting a Tag. Depending on which parameters are already in use, it is possible that a parameter may be removed 
when a new one is added.

To fine-tune a set of search parameters, or to save a set of parameters for future use, click the Advanced Search  button. 

Any filters that you create will be in the Active Filter drop-down list at the top of the Library Browser. Select a filter from 
the list to display content in the library tree list according to its settings. See The Library Browser on page 692. 

701



Home Designer Pro 2025 Reference Manual - Searching and Filtering the Library

ADVANCED SEARCH DIALOG

Click the Advanced Search button in the Library Browser to refine your search results using a Temporary Filter as 
well as create custom filters that can be saved for future use. This dialog cannot be accessed while catalogs are being 

updated. See Updating Library Catalogs on page 706.

 
Saved Filters

A list of all filters, temporary as well as saved, is found here. See Creating Custom Filters, below.     

 l Click on a filter to select it and edit its search parameters using the options on the right.

 l Click the New button to create a new filter using the currently selected parameters. In the New Library Filter dialog, 
type a short, descriptive, unique name for the new filter.

 l Click the Save As button to create a new filter with search parameters that are identical to the selected filter.

 l Click the Rename button to rename the currently selected saved filter.

 l Click the Delete button to delete the currently selected saved filter.

 l Click the Save button to save any changes made to the selected filter. Filters with unsaved changes are can be 
identified by an asterisk after their names.

 l Click the Save All button to save any changes made to all library filters.
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  Names/Keywords

 l Text Contains - Type the text you would like to use as a search parameter. When you press the Enter key, it will be 
added to the Selected Parameters list.

 o Check Match Whole Word to match the entire keyword or words with the complete name of an item.

 o Check Exclude Keywords to ignore search attribute keywords when searching.

 l Tags - When you begin typing in the text field, a drop-down list of available Tags will appear below the field and 
will update as you type. Click on a line item to add it to the Selected Parameters list. 

 l In Folder - When you begin typing in the text field, a drop-down list of folder names that match what you typed 
will appear below the field and will update as you type. Click on a line item to add to the Selected Parameters list.

 
Exclude Catalogs

Click this button to open the Exclude Catalogs dialog, where you can select catalog-level library items to exclude from your 
search.

 
Attribute Parameters

Select various object attributes to include in your search.    

 l Check the box beside an option to use it as a search parameter. For material Textures and Plants, a "no change" state 
allows you to include items in your search regardless of whether they have a particular attribute.

 l Click the arrow beside an attribute category to expand it:

 o Type - A variety of library item types is listed here.    

 o Style - A selection of architectural and design styles is listed here.

 o Manufacturer - A list of brands with Chief Architect Manufacturer Catalogs is listed here. If Include Web Results 
 is toggled on, all available manufacturers are listed; if not, only those actually installed in the Library Browser 

are listed. See Manufacturer Catalogs on page 705.    

 l Has Texture - Lets you search for materials based on whether they have a texture or are simply solid colors. A "no 
change" state searches for materials regardless of whether it has a texture. See About Materials on page 746.   

 l Plant is 3D - This option lets you search for either 3D plant symbols or 2D plant images. A "no change" state 
searches for both. See Plant Tools on page 935.

 
Selected Search Parameters

The currently selected parameters are listed here.     

 l Parameters have icons that indicate which type of data they restrict.

 l Click on a parameter from the list.

EXCLUDE CATALOGS DIALOG

Click the Edit button beside Exclude Catalogs in the Advanced Search dialog to open this dialog and select library catalogs 
to exclude from the current Filter, regardless of the active search parameters.
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The contents of the tree list in the Folders panel of the Library Browser are listed here. Check the box beside any catalog's 
name to exclude it from the currently active filter.

 

Find in Library
You can find out whether a selected object is saved in the library and if so, where, using the Find Original in 
Library edit tool. 

The Find Original in Library edit tool also allows you to locate any objects inserted  into the selected object as well as any 
materials or moldings assigned to it. See Inserted Objects on page 715.

FIND IN LIBRARY DIALOG

The Find in Library dialog opens when you select one or more objects and click the Find Original in Library  edit 

button This dialog lists all of the selected objects as well as all objects assigned to and inserted into them. 

Highlighted line items are categories that may have multiple components beneath them. 

 l Check the box beside a line item to find that object in the library.
 l Check the box beside a category heading to select all items in that category.

When you click OK, the dialog will close and one of three things will happen:

 l If a single line item was selected in the Find in Library dialog was clicked, that item will be selected in the tree list of 
the Library Browser. 

 l If the single line item is not found in the library, a message box will inform you of this and give you the option of 
adding it to the library.

 l If multiple line items were selected, the Show in Library Results dialog will open, summarizing the status of each.

SHOW IN LIBRARY RESULTS

If multiple line items are selected in the Find in Library dialog, the Show in Library Results dialog will report where, or if, 
they are found in the library.

Each line item selected in the Find in Library dialog is listed here.

 l Click on a line item to select it. Multiple lines can also be selected. See Shift and Ctrl/⌘  Select on page 146.
 l Click the Show in Library button to locate and select the selected line item in the tree list of the Library Browser. Not 

available if the selected item is “Not Found in Library Browser”, or if multiple line items are selected.
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 l Click the Add to Library button to add the selected line item(s) to the User Catalog in the library. 
 l Click the Done button to close the dialog.

 

Library Content
The Home Designer Pro library has five categories: Home Designer Core Catalogs, Home Designer Bonus Catalogs, 
Manufacturer Catalogs, User Catalog and Trash. 

HOME DESIGNER CORE CATALOGS

The Home Designer Core Catalogs category contains a wide selection of 3D symbols, images, and materials. If you install 
the program from USB drive, this library content will also be installed; if you download the software, you will be able to 
download the Core Catalogs separately, after the program is installed. 

When you launch the program for the first time, it will ask if you want to download the Core Catalogs. Click Yes to begin 
the download. If you click No, you can download at any time by selecting Library> Install Core Content from the menu. 

HOME DESIGNER BONUS CATALOGS

Chief Architect regularly posts new library catalogs available for download. Select  Library> Get Additional Content 
Online  from the menu to access the bonus catalogs and content. 

Most Bonus Catalogs can be purchased for a nominal fee, while others are available free of charge. In addition, some Bonus 
Catalogs are only available to Chief Architect Support and Software Assurance program members. 

MANUFACTURER CATALOGS

A variety of name brand library catalogs is available for download on the Home Designer website with content ranging from 
materials to fixtures.         

Select Library> Get Additional Content Online  to access these Manufacturer Catalogs.          

As with the Bonus Catalogs, some Manufacturer Catalogs are available free of charge while others can be purchased, and 
some are available for Support and Software Assurance members only.          

Note: Support and Software Assurance is an optional program for holders 
of Chief Architect Premier software licenses and is not available for 
Home Designer licenses.

VIEW ONLINE CONTENT

You can view a list of the Bonus and Manufacturer Catalogs available for download in the Folders panel of the Library 
Browser by clicking on   View Online Catalogs, which is located under these two categories below the installed catalogs.

 l Click on a catalog to see its contents in the Folders, Filter Results, and Preview panels.
 l To download an online catalog, right-click on it and select Download Catalog from the contextual menu. See 

Downloading Library Content on page 707.
 l To hide the catalogs available for download, click on   Hide Online Catalogs.
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THE USER CATALOG

The User Catalog is the location for items that you add to the library either from a drawing or by importing. See Adding 
Library Content on page 709. 

You can create and organize custom library folders and imported items such as symbols, images, backdrops, and materials. 
See Organizing the Library on page 710.

UPDATING LIBRARY CATALOGS

The Home Designer Core Catalogs, Bonus Catalogs, and Manufacturer Catalogs are updated periodically to include new and 
improved content. The program automatically checks for updates when it is launched and will indicate that updated content 
is available by displaying the Update   icon to the right of the Core, Bonus and/or Manufacturer Catalog categories. This 
icon is also stamped onto the folder for individual Bonus and Manufacturer catalogs with updated content available:  . 

To update an individual catalog or all catalogs in a category, right-click on its name in the Folders list and select 
Update from the contextual menu. See Using the Contextual Menu on page 697.

You can update all of your installed catalogs at once by selecting Library> Update Library Catalogs at any time. 
The program will gather information about the content in each of these three categories, and then download and 

replace any content that is not up-to-date. 

As catalogs are updated, you may see a progress indicator at the bottom of the Library Browser. When the process is 
finished, the Catalog Update Summary dialog will report which catalogs were updated and the status of each update. See 
Download Progress on page 707.

LIBRARY CONTENT LOCATION

All library content aside from your User Catalog is stored in the System Library Database Folder. By default, this folder 
is created in the directory intended for shared application data in your operating system (C:\ProgramData in Windows; 
/Library/Application Support in macOS). 

The Home Designer User Catalog File, User_Library.calib, is saved in the User Library Folder, which is located in the 
Home Designer Pro 2025 Data folder by default. See Home Designer Pro Data on page 35.

You can specify a different location for both if you wish in the Preferences dialog. If you choose a removable drive or 
network location, library slowness may result. See Folders Panel on page 72.

If you choose to use a different location for your User Catalog, your existing User Library content as well as your 
Backdrops, Images, Patterns, and Textures folders will be moved there, as well. It is important that you specify a directory 
on a hard drive with sufficient space to hold these files.

Library catalogs are not designed to be shared between program 
titles or versions. Items designed for use in Home Designer Pro 

2025 are not compatible with earlier program versions.

BACKING UP CUSTOM CONTENT

The best way to back up your custom library content is to export the items in your User Catalog, as this will ensure that the 
textures used by custom materials or imported symbols are not lost. See Backing Up Your Files on page 40. 

Exported libraries use the .calibz file format: a zipped file type that can include textures and images along with other library 
data.
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To back up your custom library content

 1.  Launch Home Designer and open a plan file.

 2.  If the Library Browser is not open, select View> Library Browser  from the menu.

 3.  Right-click on a folder or item in the User Catalog. 

 4.  Select Export Library from the contextual menu.

 5.  The Export Library Data dialog is a typical Save dialog. See Exporting Files on page 39.

 l Notice that the file type in the Save as type field is “Library File with Textures/Images (*.calibz)”.

 

Downloading Library Content
The Home Designer Core Catalogs, Home Designer Bonus Catalogs, Manufacturer Catalogs are all available for internet 
download.         

CORE CATALOGS

When you launch Home Designer for the first time, you will be asked if you want to download the Core Catalogs. Click Yes 
to begin the download. 

If you click No, you can download at any time by selecting Library> Install Core Content from the menu. 

BONUS AND MANUFACTURER CATALOGS

Bonus  and Manufacturer Catalogs can be downloaded from our website,  www.HomeDesignerSoftware.com. Select 
Library> Get Additional Content Online to launch your default internet browser to our Content Resources page. 

When Include Web Results  is toggled on, content that is available for download will be included in the Filter Results. 

Items in the Filter Results that are not downloaded will have the Available Online   watermark. Right-click on one these 
items and select Download Catalog from the contextual menu to download it. If you are not logged in to your online Chief 
Architect account, you will be prompted to do so. See Chief Architect Account Login on page 876.

You can also view a list of the Bonus and Manufacturer Catalogs available for download in the Folders panel of the Library 
Browser by clicking on   View Online Catalogs, which is located under these two categories below the installed catalogs. 

DOWNLOAD PROGRESS

If a Bonus or Manufacturer catalog required a purchase, you may be prompted to wait while the purchase is processed.

When library content is downloading, a green progress bar will display at the bottom of the Library Browser. If you choose 
to download the Core Catalogs while the library is not open, the Browser will open so the progress indicator can display. 

Click on the progress bar to display the name of the current file being downloaded, the total amount of data to be 
downloaded in KB, and the amount downloaded so far.
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PAUSING AND RESUMING

Library downloads can only take place while Home Designer is running. If you close the program while a download is in 
progress, a dialog will confirm whether you wish to stop the download.

 l Click Stop Download and Close Program to stop the download and close the program. 
 l Click Cancel to leave the program open and continue downloading. 

Most catalogs are composed of a single file. If you stop the download midway, none of the downloaded data will be 
retained.

The Core Catalogs, on the other hand, contain a large volume of data saved in multiple files. If you close the program and 
stop the Core Catalogs download midway, only data associated with the file currently being downloaded will be lost. You 
can resume the download beginning with that file at a later time by selecting Library> Install Core Content.

DOWNLOAD ERRORS

If any problems occur during the library download process, a dialog box will notify you at the end of the download. Click 
Retry Download to repeat the download and correct any errors or click Cancel to discard the downloaded catalog. 

 

Importing Library Catalogs
Home Designer library files have two different file extensions: .calib and .calibz. Both files can include any combination of 
Home Designer library items; in addition, .calibz files are able to save data associated with textures and images. Both file 
types can be imported into the Home Designer library.

There are several ways to import a .calib or .calibz file into the program library:

 l Double-click on the file in an operating system window while a plan or layout file is open.
 l Drag the file from an operating system window and drop it into the Home Designer program window. 
 l Select Library> Import Library from the program menu.

Although multiple versions of Home Designer can be installed on a computer, the operating system will only associate
 .calib and .calibz library files with one version. If they are not associated with Home Designer Pro 2025, click the 
Associate Files with this Program button in the Preferences dialog. See File Management Panel on page 70.          

Note: Library files cannot be imported if no plan or layout file is open, or 
when a Materials List window is active. 

To import library files into the library

 1.  Select Library> Import Library to display the Import Library Data dialog.

 2.  Browse to the .calib or .calibz file(s) that you want to import and either single or group-select the files so that their 
names display in the File Name field.

 l To select a group of files, click on the first one, hold down the Shift key, then click on another file. The two files 
plus all files in between are selected.

 l To select multiple files individually, click on one, hold down the Ctrl/⌘  key, then click on additional files. Only 
the files you click on are selected.
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 l To select all files in the directory, click on one and press Ctrl/⌘  + A. Only do this if you wish to import all files in 
the folder.

 3.  Click the Open button. 

 4.  A progress bar will display, telling you the progress of each library data file as it is imported. 

 5.  Once imported, each file will be listed in and selected in the Library Browser tree list. See Library Content on page 
705.

 l If the catalog is a Bonus or Manufacturer catalog, it will be added to the corresponding library catalog.

 l Otherwise, the catalog's contents will be added to the User Catalog. The catalog's folder structure will be 
preserved, and if any duplicate objects are found, you will be notified.

When a .calibz file is imported into the program, any images or textures saved in it will be copied into the Home Designer 
Pro 2025 Data\ Images and Textures folders for backup purposes. The program will only reference these copies if it cannot 
locate the files in their original locations. See Home Designer Pro Data on page 35.

 

Adding Library Content
In addition to downloading Home Designer Content and importing entire catalogs into the library, you can also add a variety 
of individual objects to the library. 

ADD TO LIBRARY

Nearly any object imported into a plan or placed from the Library Browser can be added to the User Catalog in the library. 

 l Select one or more objects in your plan and click the Add to Library  edit button.

 l Check Add to Library in the Import 3D Symbol dialog. See Importing 3D Symbols on page 727.         

A few objects cannot be added to the library: notably terrain objects, CAD objects, imported pictures, metafiles, and PDF 
files.  

Any object created using a drawing tool in Home Designer will automatically be added to the User Catalog using the name 
of that tool, whereas a symbol will automatically use the Symbol Name. See Native Objects vs Symbols on page 713. 

If multiple identical objects are selected when the Add to Library button is clicked, only one instance will be added to the 
User Catalog.

Once added to the library, objects in the User Catalog can be renamed and edited. See Renaming Library Items on page 711. 

USING THE CONTEXTUAL MENU

A variety of new content can be added to the User Catalog by right-clicking on it or on a folder within it and selecting 
New> from the contextual menu: 

 l Backdrops - See 3D Backdrops on page 841.         
 l Fill Styles - See Fill Styles on page 131.         
 l Images - See Images on page 846.         
 l Materials - See Creating Materials on page 755.
 l Plant Image - See Plant Image Specification Dialog on page 938.
 l 3D Symbols - See Importing 3D Symbols on page 727.
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See also Using the Contextual Menu on page 697 and Adding New Folders on page 710.         

CREATING A CUSTOMIZED LIBRARY ITEM

You can customize an existing library item and save your changes for future use by first copying the item into the User 
Catalog.         

To customize a library object

 1.  Right-click on a library item and select Copy to User Catalog from the contextual menu.

 2.  If the library item is already located in the User Catalog, instead select Duplicate from the contextual menu. A copy 
will be created in the same location as the original.

 3.  Right-click on the copied item and select Open Object  from the menu.             

 4.  The item’s specification dialog opens, and you can make any changes that you wish to the item.             

 5.  Make any needed changes to the item, then click OK. Your changes will be saved with this item for use in any plan.             

 

Organizing the Library
Library folders and objects can be copied, pasted, moved, and deleted: allowing you to organize your User Catalog to best 
suit your work style and needs. See The User Catalog on page 706.

ADDING NEW FOLDERS

New folders can be added to the User Catalog or to any folder located within it. To add a new folder, right-click on User 
Catalog or one of its sub-folders and select New> Folder from the contextual menu. See Using the Contextual Menu on 
page 697.

The new folder is created inside the library item you right-clicked on and is initially named “Untitled”. Right-click on it and 
select Rename from the contextual menu, then type a short, descriptive name and press the Enter key. 

SELECTING LIBRARY ITEMS

To select a library object, folder, or category, simply click on it in the Folders tree list. You can also multiple-select library 
items. See Shift and Ctrl/⌘  Select on page 146.
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 l To select a group of items, click on the first one, hold down the Shift key, then click on another item. The two items 
plus all items in between are selected.              

 l To select multiple items individually, click on one, hold down the Ctrl/⌘  key, then click on additional items. Only the 
items you click on are selected.              

When an object is selected, a thumbnail displays in the Filter Results and Preview panels and basic information about it also 
displays in the program’s Status Bar. See The Status Bar on page 24. 

A selected library item can be modified in a number of ways to help meet your organizational needs. When multiple items 
are selected, these options may be limited depending on the specific selection set.

RENAMING LIBRARY ITEMS

Only folders and objects in the User Catalog can be renamed. There are several ways to do this in the tree list: 

 l Right-click on the item, select Rename from the contextual menu, and type a new name. 
 l Click once on the item, press the F2 key and type a new name.
 l Click once on the item, pause for a moment, then click a second time and type a new name. You can change this 

behavior in the Preferences dialog. See Library Browser Panel on page 67.

Library names are case-sensitive and cannot be blank. While you can have more than one library item that uses the same 
name, it is best to use short, descriptive and unique names.

When an object's name is changed in the User Catalog, its name is also changed in its specification dialog.

MOVING LIBRARY ITEMS

Folders and objects in the User Catalog can be moved to new locations within the User Catalog. There are several ways to 
do this:

 l Select one or more items in the Folders tree list, then click and drag it to the new location in the list. An icon that 
follows the mouse pointer indicates when it is over supported and unsupported locations, and any folder able to accept 
the new content highlights as your mouse pointer moves over it. Release the mouse button to relocate the selection in 
the highlighted location.

 l Cut one or more selected items from their current location, right-click on the folder where you want to move them, 
and Paste them there. Cut is found in the selected items' contextual menu while Paste is found in the contextual menu 
for the destination folder. See Cut, Copy, and Paste on page 118. 

 l Using Move to Folder, which is available in the contextual menu for library objects, but not for folders. See Using the 
Contextual Menu on page 697.

Folders and library objects are always organized alphabetically within each hierarchy.

COPYING AND LINKING LIBRARY ITEMS

All library folders and objects can be copied and pasted to new locations in the User Catalog using options in their 
contextual menus. There are two types of copies in the library:

 l Independent copies of objects that can then be customized without affecting the original. Both folders and objects can 
be copied to the User Catalog.

 l Linked copies, which are actually representations of the same object shown in different locations in the User Catalog. 
If one copy is edited, all linked copies are affected. Only library objects can have linked copies: folders cannot.

There are two ways to create independent copies of folders and/or objects:
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 l Copy one or more selected folders and/or objects in their current location, right-click on the User Catalog or the 
subfolder where you want to copy them, and Paste them there. Copy is found in the selected items' contextual menu 
while Paste is found in the contextual menu for the destination folder. See Cut, Copy, and Paste on page 118. 

 l Copy to User Catalog pastes copies of the selected folder(s) and/or object(s) in the User Catalog automatically, 
without requiring you to choose the location or the Paste command.

There are also two ways to create linked copies of objects in the User Catalog:

 l Copy copies a selected object or objects to the system Clipboard. Right-click on the User Catalog or the subfolder 
where you want to want a linked copy and select Paste Link from the contextual menu.

 l Move to Folder allows you to select multiple folders to list a selected object or objects in.

ADD LINK DIALOG

The Add Link dialog allows you to specify which User Catalog folder(s) linked copies of a selected object or group of 
objects is listed in.

  Search

If your User Catalog contains many folder or subfolders, you can type in this field to search for a particular folder name. A 
drop-down list of search results will appear below the field that updates as you type: click on an item in that list to select it.

  User Catalog Folders

The names of all folders and subfolders in the User Catalog are listed here. Click on a folder name to select it, then click 
OK.

DELETING LIBRARY ITEMS

The five installed library categories: Home Designer Core Catalogs, Home Designer Bonus Catalogs, Manufacturer 
Catalogs, User Catalog, and Trash cannot be deleted. 

Catalog level folders in all categories can be deleted; however, individual subfolders and objects can only be deleted out of 
the User Catalog.

Items in the library that are eligible for deletion can be deleted in either of two ways: 

 l Right-click on it and choose Delete from the contextual menu.
 l Select it and press the Delete key.
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When items from the User Catalog are deleted, they are moved to the Library Browser Trash  . Items in the Trash can be 
retrieved by right-clicking on them and selecting Restore from the contextual menu. To return an item to a particular folder 
in the User Catalog, instead select Cut. Then, right-click on the destination folder and select Paste.

To empty the Trash, right-click on it and select Empty Trash from the contextual menu. 

Depending on how much content is in the Trash, emptying it can be time consuming. You can click the Cancel button to 
end the process if you wish. 

The Empty Trash command is both immediate and permanent. It 
cannot be undone, so use care when using it. You should back 

up all your library files regularly. See Backing up Custom Content on 
page 706. 

When content is deleted from the Library Browser, data associated with that content may remain in the library database. If 
you delete library content for the purpose of increasing available disk space, you can right-click on the User Catalog as well 
as the Trash and select Vacuum from the contextual menu. See The Library Browser on page 692.

 

Editing Library Objects
The Core, Manufacturer, and Bonus Catalogs and the objects within them cannot be edited. Library objects can, however, be 
customized to suit your design needs. There are three approaches to doing so:         

 l Select an object in the User Catalog, edit it using any of the options in its contextual menu, and your changes will be 
reflected when you next place this library object in a drawing. See Using the Contextual Menu on page 697. 

 l Place an object in a drawing and then edit it using the various edit tools available for it. This will not affect the 
original object still saved in the library.         

 l Place an object in a drawing, edit it using the available edit tools, and then add it back to the library for future use. 
This will not replace the original object still saved in the library. See Add to Library on page 709.         

To customize an object in the Core, Manufacturer, or Bonus 
Catalog, right-click on it and select Copy to User Catalog from 

the contextual menu. See Creating a Customized Library Item on page 
710.

NATIVE OBJECTS VS SYMBOLS

In Home Designer, objects created using the program’s standard tools, such as the Door Tools  and Cabinet Tools , 

are referred to as native objects. 

On the other hand, objects placed from the library, such as fixtures and furnishings, are symbols. Symbols are typically 
more limited than native objects in how they can be edited.

In addition to the symbols available in the library, you can import additional symbols into the program from 3D .dxf, .dwg,
 .obj, .3ds, .skp, or .dae files. See Importing 3D Symbols on page 727.

Any changes made to objects like fixtures and furniture will not be reflected in their Materials List Description, although 
they may be seen in other columns, such as Size. See Materials Lists on page 950. 

USING THE EDIT TOOLS

The specification dialog for an individual symbol, Rich Text object, Callout, Marker, Elevation Point, image, or plant image 
in the User Catalog can be edited from the Library Browser Directory Pane. Right-click on the item and select Open Object 

713



Home Designer Pro 2025 Reference Manual - Exporting Library Catalogs

from the contextual menu. See Specification Dialogs on page 20. 

Individual or multiple group-selected materials can be edited by right-clicking and selecting Open Object as well. See 
Define Material Dialog on page 760.          

EDITING BUILT-IN FIXTURES AND APPLIANCES

A fixture installed into the front of a cabinet becomes a cabinet face item, like a door or drawer. It can be resized or deleted 
like other face items in the Cabinet Specification dialog. See  Front Panel on page 468. 

 

Exporting Library Catalogs
Exporting library files allows you to: 

 l Back up your custom library content.
 l Transfer library content between computers.
 l Share custom library content with colleagues.          

Exporting is often preferable to simply copying library files because it allows you to include images and textures in the 
exported library. 

To export content from the library

 1.  Locate an object, folder, or catalog that you want to export, right click on it, and select Export Library.

 2.  In the Export Library Data dialog:

 l Choose the appropriate Save in: location for your exported library file.

 l Type a short, descriptive name for your library file in the File Name field.

 l Click the Save as type: drop-down list and select whether or not you want the library to include Textures/Images.

If any of the items being exported are images or use textures, 
be sure to select the .calibz file type.

 l Click Save.

 3.  Your exported library file can now be copied to a network location or storage device in an operating system window. 

 

Placing Library Objects
Library objects are subject to placement restrictions based upon typical real-life placement. Most library objects require 
sufficient free space at the location where they are placed, for example, and some library objects have additional 
requirements. Library windows and doors, for example, must be placed in a wall just like standard windows and doors, and 
some fixtures are designed to be placed in cabinets.

There are three main categories of items available in the Library Browser:

 l Stand-alone objects that can be placed directly into a plan. Examples include cabinet modules, furnishings and images.
 l 3D objects designed to be inserted into another 3D object. Examples include cabinet fixtures, windows and doors. 

Some items, such as cabinet doors, railing balusters, and fence panels, can be inserted into another object or placed as 
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stand-alone objects. 
 l Materials fill styles, and molding profiles, which cannot stand alone and must be assigned or applied to another object.

If the Replace from Library   icon appears by your pointer, you can click on the object your pointer is over and replace it 
with the one currently selected in the Library Browser. See    Replace From Library on page 717.

If a warning message displays when placing a library object, it means that the object cannot be placed at the point where 
you clicked and will indicate where the object can be placed.

STAND-ALONE OBJECTS

Most library categories contain objects that can be selected in the Library Browser and placed directly in a 2D or 3D view. 

 l Most stand-alone objects are designed to rest on the floor or terrain.
 l Some objects will rest on top of a cabinet or countertop, shelf, furniture, or roof plane object if one is located at the 

point where they are first placed.
 l A few objects, notably some light fixtures, will mount on the bottom of a wall cabinet or on the ceiling.
 l In addition, some objects will attach to a wall if one is nearby. 

To place a stand-alone library object

 1.  Click on an object in the Folders tree list or Filter Results list in the Library Browser to select it for placement. See 
The Library Browser on page 692. 

 2.  Move your mouse pointer into the view area and notice that it displays an icon indicating the type of object selected 
instead of an arrow.

 3.  Click to place the selected object at that location. 

 4.  Continue clicking to place as many instances of the selected object as needed. When you are finished, click the 
Select Objects  button. 

Once a stand-alone object has been placed, it can be edited in a variety of ways. See Editing Library Objects on page 713.

INSERTED OBJECTS

Some objects cannot stand alone and must be placed into other objects in a plan. For example, doors and windows must be 
inserted into a wall, while some appliances and plumbing fixtures are designed be placed inside a base cabinet. See Doors 
on page 378, Windows on page 408 and Cabinets on page 444.

With the exceptions of doors, windows, and skylights, an inserted library object can only display in a 2D or 3D view if the 
object that contains it is set to display. This is the case even if the inserted object’s layer is turned on. See Displaying 
Symbol Objects on page 721. 

To insert a library object

 1.  Click on an item in the Folders tree list or Filter Results list of the Library Browser to select it for placement. See 
The Library Browser on page 692. 

 2.  Move your pointer into the drawing area.

 3.  Click on the object into which you wish to insert the selected library item. If the selected library item is designed to 
be inserted into that type of object, it will be placed into it.

 4.  Continue clicking on other objects to place as many instances of the selected item as needed. When you are finished, 
click the Select Objects  button.
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When an object has been inserted into another object, it can be replaced directly from the library. See    Replace From 
Library on page 717.

If you try to insert an object into another object that is on a locked layer, nothing will be created. See Object Creation and 
Layers on page 118.          

ASSIGNED ITEMS

Some library items, such as fill styles, materials and moldings, are not objects in themselves but can be applied to objects in 
a variety of ways.

 l Using the specification dialog of the containing object. See Select Library Object Dialog on page 716.
 l By selecting the item in the library and then clicking on the containing object.             
 l Fill styles, materials and moldings can be assigned to objects directly from the library in 3D views by selecting the 

library item and then clicking on an object.  See Eyedropper and Painter Tools on page 189 and    Replace From 
Library on page 717.

 

Select Library Object Dialog
The Select Library Object dialog is a modal version of the Library Browser that is accessible from many object specification 
dialogs. See Specification Dialogs on page 20. 

This dialog also opens when you select the Fill Style Painter  tool. See Painter Tools on page 190.         

The Select Library Object dialog only displays categories of items that are related to the object component being edited. For 
example, if this dialog is accessed from the DOOR/DRAWER panel of the Cabinet Specification dialog, only cabinet door and 
drawer symbols will be listed. If it is accessed from the Moldings panel, only moldings will be listed.

The Select Library Object dialog is similar to the LIBRARY MATERIALS panel of the Select Material dialog. See Select 
Material/Library Object Dialog on page 751.

 

Place Library Object Button
The Place Library Object button can be added to your toolbar and used for quick access and placement of 
frequently used library items.         
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If the Place Library Object button has not yet been assigned a library object, click it once to open the Library Object 
Button Specification dialog.          

Double-click a Place Library Object button that has been assigned a library object to open the Library Object Button 
Specification dialog.         

 
Library Object

Click the Library button to open the Select Library Object dialog and assign a library object to the button. If a library 
object has already been assigned, click this button to assign a new library object. See Select Library Object Dialog on page 
716.          

 
Button Name

When a library object has been selected, type a Button Name in the text field.         

 
Button Icon Choices

When a library object has been selected, assign a Button Icon. Choose from two automatically generated button icons or 
click Browse to browse your computer for a different icon.         

Up to 398 Place Library Object buttons can be added to the same toolbar, each assigned a different object.         

The library object assigned to the Place Library Object button is actually saved with that particular button. If you move or 
delete the library item from the library, the button will continue to function.         

○

 

   Replace From Library
There are two different ways to replace an object in a plan with another object from the library.          

An inserted object or a molding profile can be replaced by a different item from the library with a single click. This 
approach is particularly effective in 3D views, where the results can immediately be seen. See Inserted Objects on page 715.

To replace an inserted object

 1.  Open the Library Browser, browse to an object of a type similar to the one you wish to replace, and click on it to 
select it. 

 2.  Select a Replace from Library Scoping Mode from the Edit Toolbar:
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 l Component Mode  is the default mode and replaces a single instance of a molding or an inserted object on the 

target object. Most object types have a list of components in their specification dialog, on the MATERIALS and 
COMPONENTS panels. See Materials Panel on page 750 and Object Components on page 967.

 l Object Mode  replaces all instances of an item inserted into the target object. 

 l Room Mode  replaces all instances of an item inserted into objects in the room where the target object is 

located. 

 l Floor Mode  replaces all instances of an item inserted into objects on the floor where the target object is 

located. 

 l Plan Mode  replaces all instances of an item inserted into objects in the entire plan. 

 l Toggle Library Replacement Mode  allows you to place a free-standing object instead of replacing anything.

 3.  Move the mouse pointer into the view window. The Replace from Library   icon will display near the mouse 
pointer when it passes over an object that can be replaced by the selection from the library.

 4.  Click once to replace the object in the plan as well as to any other identical objects, depending on which Painter 
Scoping Mode is active, with the selected object from the library. 

Some types of inserted objects - notably, plants assigned to Garden Beds, cabinet doors and drawers, and doors - can also be 
replaced in this manner in plan view provided that the Alternate Edit Behavior is not active.

In the Windows version of the program, you can temporarily 
override this replacement behavior in plan view by holding down 

the Alt key. A free-standing object will be created if there is space for it 
instead of an inserted object being replaced.

The Replace From Library edit button is available for nearly any stand-alone object that can be added to the library 
and can be used in 2D and 3D views. Click this button to open the Replace From Library dialog and replace the 

selected object, and others like it if you choose, with an object of the same type from the library.         

  Replacement Options

 l Replace Selected Object replaces only the currently selected object.    

 l Replace Identical Objects in Room replaces all objects that are in the same room as, and are identical to, the 
currently selected object. Not available for doors or windows.    

 l Replace Identical Objects on Floor replaces all objects that are on the same floor as, and are identical to, the 
currently selected object.     
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Replace With

Click the Library button to open the Select Library Object dialog and select an object to use as a replacement. The name of 
the object that is currently selected as a replacement displays above.             

Replace From Library               cannot be used to replace a selected cabinet with a cabinet of a larger size. In addition, it is not 

available for backdrops and items assigned to other objects, such as materials. 
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Chapter 27
 

Symbol Objects

Symbol objects play a variety of important roles in Home Designer.

Home Designer provides a complete set of architectural tools for creating highly customized designs, as well as a large 
selection of objects in the Library Browser that can be used to add more detail to a plan. 

In addition, if you don’t find precisely what you need, you can either import symbols from third party sources or create your 
own symbols in Home Designer. See Importing 3D Symbols on page 727.

Custom symbols can also be edited and added to the library. See The Library on page 691.

TOPICS

Displaying Symbol Objects 721
Editing Symbol Objects 721
Symbol Object Specification Dialogs 723
Importing 3D Symbols 727
3D Data Import Requirements 728
3D Symbols and Materials 729
Exporting a 3D Model 730
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Displaying Symbol Objects
The display options available for symbol objects depend on the type of object in question, as well as the view.

If the display of an object is turned off in a 2D or 3D view, any objects inserted into it will not display in that view, either - 
even if the inserted object’s layer is turned on. See Inserted Objects on page 715. 

IN PLAN VIEW

All symbol objects except hardware applied to doors or cabinets can display in plan view. Symbol objects are represented in 
plan view by 2D symbols that resemble the size and shape of the object when viewed from above.

As with other architectural objects, the display of symbol objects is controlled by layer in the Layer Display Options dialog. 
Each category of objects has its own layer.  See Layer Display Options Dialog on page 127.

Like other objects, each symbol object is  placed in a Drawing Group that affects whether it displays in front of or behind 
other objects. You can modify a selected symbol’s place in the drawing order by clicking the View Drawing Group Edit 
Tools  edit button. See Drawing Group Edit Tools on page 129. 

OBJECT LABELS

Free-standing symbol objects, including those in Architectural Blocks, can display labels in plan views when the appropriate 
layer is set to display in the Layer Display Options dialog. Fixture labels, for example, are located on the “Fixtures, Labels” 
layer. See Label Panel on page 376.

Library object labels use the Text Style assigned to their layer. See Text Styles on page 373.         

You can specify a custom label for symbol objects in their specification dialog. See Symbol Object Specification Dialogs on 
page 723.         

IN 3D VIEWS

All symbol objects can display in 3D views when their layers are turned on. 

IN THE MATERIALS LIST

Most objects placed from the library are counted in the Materials List. These architectural objects have a COMPONENTS 
panel in their specification dialog that lets you control how that object displays in the Materials List. See Components Panel 
on page 967.          

Note: Although the size and materials of many library objects can be 
edited, these changes are not reflected in the Materials List. See 
Materials Lists on page 950.

 

Editing Symbol Objects
Symbol objects can be selected and edited much like other objects in the program. A symbol’s category determines exactly 
what editing options are available; however, most symbols can be edited using the edit handles, edit toolbar, and 
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specification dialog. See Editing Objects on page 137.

Symbols have some additional options that allow you to control how the symbol behaves when it is placed, selected, moved 
and resized.

Stand-alone library symbols placed in a plan can be selected individually or as a group, like other objects in Home Designer. 
To select a symbol object inserted into the top of a cabinet, select that cabinet and click the Select Next Object  edit 

button. See Selecting Objects on page 142. 

Once selected, a library object can be edited in a variety of ways using dimensions, the edit handles, the Edit Toolbar 
buttons and its specification dialog. See Symbol Object Specification Dialogs on page 723. 

A selected library object placed in a plan will have a variety of edit tools available. See The Edit Toolbar on page 92.

NATIVE OBJECTS VS SYMBOLS

In Home Designer, objects created using the program’s standard tools, such as the Door Tools  and Cabinet Tools , 

are referred to as native objects. 

On the other hand, objects placed from the library, such as fixtures and furnishings, are symbols. Symbols are typically 
more limited than native objects in how they can be edited.

In addition to the symbols available in the library, you can import additional symbols into the program from 3D .dxf, .dwg,
 .obj, .3ds, .skp, or .dae files. See Importing 3D Symbols on page 727.

Any changes made to objects like fixtures and furniture will not be reflected in their Materials List Description, although 
they may be seen in other columns, such as Size. See Materials Lists on page 950. 

USING EDIT HANDLES

Most free-standing library symbols are box-based objects and can be edited as such once placed in a drawing. See Editing 
Box-Based Objects on page 160. Depending on the type of view and the surface selected, the edit handles a symbol displays 
will vary. 

When a typical symbol is selected in plan view or on the top surface in a 3D view, up to ten edit handles display. They are 
the Move handle at the center, the Rotate handle just outside the front indicator (a V) and a Resize handle on each edge and 
at each corner. In plan view, symbol object labels also have a small square Move edit handle when they are set to display. 

When a symbol is selected on a side in a cross section/elevation or 3D view, it displays six edit handles: the Move handle, a 
Rotate handle, and a Resize handle on each edge. See Selected Side on page 144.

When a free-standing symbol is selected on its side and rotated, you will be prompted to choose whether to update its plan 
view symbol to reflect its new orientation, as viewed from above. See In Plan View on page 721. 

Symbols cannot be concentrically resized, even when the Concentric  edit behavior is enabled. See Defaults, 

Preferences, and Edit Behaviors on page 138.   

Fixtures and furniture placed in a plan are subject to bumping/pushing behavior when moved. See Bumping/Pushing on 
page 168.

EDITING BUILT-IN FIXTURES AND APPLIANCES

A fixture symbol inserted into the top of a cabinet can be selected by clicking on it, then clicking the Select Next Object 
 edit tool. Once selected, the fixture can be moved, rotated, and resized using its edit handles. See Inserted Objects on 
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page 715 and Select Next Object on page 143. 

A fixture installed into the front of a cabinet becomes a cabinet face item, like a door or drawer. It can be resized or deleted 
like other face items in the Cabinet Specification dialog. See  Front Panel on page 468. 

 

Symbol Object Specification Dialogs
Select an object and click the Open Object edit button to open that object's Specification dialog. This dialog can also 
be opened when multiple symbol objects are selected as long as the objects are of the same type.

This dialog can also be accessed by right-clicking on an object in the library User Catalog and select Open Object . 

Editing an object in the library changes does not affect any instances of it already placed in a plan. See Editing Library 
Objects on page 713.

The settings in the Hardware Orientation dialog for cabinet hardware are also found  on the GENERAL panel of this dialog. 
See Cabinet Hardware and Moldings on page 461.

The names and settings in these dialogs vary and are determined by the type of object being edited:

 l Electrical Service Specification
 l Fixture Specification
 l Furniture Specification
 l Geometric Shape Specification
 l Hardware Specification
 l Millwork Specification
 l 3D Plant Specification
 l Sprinkler Specification

The Cabinet Specification dialogs have the following panels:

GENERAL PANEL
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Object Dimensions

These values describe the total size of the selected object's bounding box. For some objects, such as those that insert into 
cabinets or have special clearance requirements, the bounding box will not match the symbol's geometry.    

 l Specify the total Width, Depth, and Height of the object's bounding box.    

 l Click the Reset Object Size button to reset the original Width, Depth, and Height values.    

 l When Retain Aspect Ratio is unchecked, the Width, Depth, and Height can be edited independent of one another, 
potentially changing the object's shape. Check this box to maintain the ratio between these settings when the object 
is resized in this dialog. This box does not affect editing performed outside this dialog and is an action rather than a 
state: the next time you open this dialog, it will be unchecked.    

  Position

 l Select the Elevation Reference from the drop-down list. This determines where the next two settings are measured 
from and also affects their setting labels. Not available in the Electrical Service Specification or Hardware 
Orientation dialog. See Elevation References on page 20.

 o Specify the height to Top, measured from the selected Elevation Reference to the top of the object.

 o Specify the height to Bottom, measured from the selected Elevation Reference to the bottom of the object.

 l The options available for electrical objects differ from other symbol objects, and vary depending on where the 
selected object is set to be mounted:                     

 o For Ceiling Mounted objects and those set to Mount Under Wall Cabinet, specify the Offset from Ceiling. A 
negative value recesses the selected object into the surface it is mounted on.      

 o For Floor Mounted objects, specify the Offset from Floor.      

 o For Wall Mounted and Cabinet Mounted objects, specify the Height to Center, measured from the object's center to 
the floor or terrain.      

 o For Wall Mounted and Cabinet Mounted objects, you can also specify the symbol's horizontal Distance from Wall 
or Distance from Cabinet. A negative value recesses the object into the surface it is mounted on.

  Options

 l When Suppress Adjacent Room Moldings is checked, room moldings do not generate on walls where the selected 
object touches them. When it is unchecked, room moldings generate through the object. Not available for Sprinklers.

 l Check Reflect Geometry to reverse the object’s appearance, so that features on its left are positioned on its right, 
and vice versa. This turns a right-hand refrigerator, for example, into a left-hand refrigerator. This option has no 
effect on objects that are symmetrical.

 l The Sprinkler Settings are only available if the selected object is a sprinkler. See Sprinkler Tools on page 942.

 o Specify the Spray Angle, which is the angle within which the sprinkler sprays. An angle of 360° forms a complete 
circle.

 o Specify the Spray Radius, which is the distance from the sprinkler head that the spray reaches. 

 
Copyright

If the selected object has a copyright, information about it displays here.
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Preview

A preview of the selected library object displays here and updates with changes. If the selected symbol is inserted into 
another object, such as an appliance in a cabinet, the parent object will also display. See Dialog Preview Panes on page 21.

LIGHT DATA PANEL

The LIGHT DATA panel is only available for Electrical symbol objects and Added Lights. The settings on this panel allow 
you to control the attributes of the light source(s) associated with the selected object. See Light Data Panel on page 493.

3D PANEL

The options on the 3D panel primarily affect the symbol’s appearance in 3D views. This panel is only available when a 
symbol is in the process of being imported. See Importing 3D Symbols on page 727.

  3D Geometry

 l Select the Drawing Unit that was used to create the symbol. If any units other than inches or mm are selected, the 
program will convert the data into units appropriate for Home Designer. Only available when a symbol is being 
imported. To apply a change to this setting, you must also click the Browse button and reload the symbol data from 
the original file. 

Note: SKP files are always imported using inches, regardless of the 
default units used in the plan file.

 l Check Reflect Geometry to reverse the object’s appearance, so that features on its left are positioned on its right, 
and vice versa. This turns a right-hand refrigerator, for example, into a left-hand refrigerator. This option has no 
effect on objects that are symmetrical.

 
Rotation

These settings allow you to rotate the selected symbol(s) about the X, Y, and Z axes. Note that rotating a symbol will affect 
the location of its top, bottom, front, and /or back - and thus the location of its default origin. It may affect the size of the 
bounding box, as well; however, it does not affect the bounding box’s orientation. See Editing Symbol Objects on page 721.     

 l Select the X, Y, or Z Axis that you wish to rotate the symbol about.      

 l Specify the Angle to rotate the symbol in the text field. An angle of 90° is set by default.      
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 l Click the Rotate + button to rotate the symbol around the selected axis in a clockwise direction.      

 l Click the Rotate - button to rotate the symbol around the selected axis in a counterclockwise direction.    

 
Faces

Specify how the selected symbol’s 3D Faces are generated.

 l The Number Of Faces that a selected symbol has displays here for reference. When multiple symbols are being 
imported, nothing displays. Although there is no limit to the number of faces, large numbers can increase rendering 
time significantly. 

 
Preview

A preview of the symbol’s appearance displays here and updates as changes are made to the settings in this dialog. When 
multiple symbols are selected, the most recently selected symbol displays. See Dialog Preview Panes on page 21.

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected symbol object in plan view, and are found in a 
variety of dialogs throughout the program. See Fill Style Panel and Dialogs on page 132.    

This panel is available for most types of symbol objects. One exception, however, is Window Symbols from the Library.

Sprinklers can have more than one fill style. As such, the FILL STYLE panel in the Sprinkler Specification dialog does not 
have settings for a single fill style: instead, it lets you access the Fill Style Specification dialog for each of the selected 
object's possible fill styles. See Displaying Sprinklers on page 942.

MATERIALS PANEL

The MATERIALS panel allows you to assign materials to the symbol's components and is similar to the MATERIALS panel in 
many specification dialogs. See Materials Panel on page 750.

If the selected symbol is in the process of being imported, bear in mind that .dxf/.dwg files do not include material 
information, so the symbol's components will not initially have materials assigned to them. See 3D Symbols and Materials 
on page 729.

In the Symbol Object Specification dialogs only, the names of the Components listed here can be customized: simply click 
on the Name of a selected component and type a short, descriptive name that better meets your needs. These names are not 
used elsewhere in the program.

LABEL PANEL

A variety of library objects can display labels in plan view. Labels use the Text Style assigned to the layer they are on.   

For information about the settings on this tab, see Label Panel on page 376.   
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COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 967.    

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in the materials list. For more information, see 
Object Information Panel on page 968.   

MANUFACTURER PANEL

The MANUFACTURER panel provides contact information for the selected object’s manufacturer. Only available for symbols 
from Manufacturer library catalogs. See Manufacturer Catalogs on page 705.   

 

Importing 3D Symbols
Home Designer Pro supports the import of 3D surface and 3D solid objects saved in .dwg, .dxf, .3ds, .obj, .stl, .dae, 
and .skp formats. See 3D Data Import Requirements on page 728.

To import a symbol object, select File> Import> Import 3D Symbol . 

Home Designer Pro supports the import of 3D surface and 3D solid objects saved in .dxf, .dwg, .obj, .3ds, .stl, .skp and
 .dae file formats. When imported, these symbols are treated as stand-alone fixtures.    

The Import 3D Symbol File dialog, which opens first, is a typical Open File dialog in which multiple files can be group-
selected for import. See Importing Files on page 43.

For most file types, there are three ways to import a 3D symbol into Home Designer Pro:

 l By selecting File> Import> Import 3D Symbol to import into the current plan.
 l By dragging and dropping the file from an operating system window into plan view to import into the current plan. 
 l By selecting New>3D Symbol from the contextual menu in the Library Browser to import it into the User Catalog. 

See Using the Contextual Menu on page 697.

3D .dxf/.dwg files can only be imported by selecting File> Import> Import 3D Symbol.

To drag and drop a 3D symbol file

 1.  Open the plan in which you would like to import a 3D symbol and remain in plan view.

 2.  Open an operating system window in front of the Home Designer program window.

 3.  Resize and position the window so that the Home Designer program window can be seen behind it.

 4.  Click on the desired  .3ds, .obj .stl, .dae, or .skp file and drag it into the Home Designer program window.

 5.  When your cursor changes to a +, click in the drawing area to place as many copies of the symbol as desired. When 
you are finished, select a different tool. 

If the symbol you are importing has a high surface count, it may 
impact program performance. When this is a possibility, the 

program will warn you and present you with an option to cancel the 
import operation. 
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3D Data Import Requirements
Importing a symbol that can be used by Home Designer is a relatively simple process that begins with previously created 3D 
data. This 3D data often comes from a program other than Home Designer. If you use another 3D modeling program to 
create the 3D data, be aware of the following requirements before attempting to create symbols.

Chief Architect does not provide support for any third party 
software.

There are a number of requirements that must be met before any 3D data can be used to create a symbol in Home Designer 
Pro:

 l The 3D data must be stored in a standard Drawing Exchange File (.dxf), AutoCAD® Drawing (.dwg), object (.obj), 
3D Studio® Mesh (.3ds), stereolithography (.stl), COLLADA (.dae), or SketchUp version 2021 and prior (.skp) file 
format. If you have 3D data in another format, you must convert it into one these formats first.

 l Geometry and material information stored in .3ds files are imported; cameras and lights are not.
 l The 3D model must be composed of 3D DWG or 3DSOLID solid entities, or face data. Faces are typically referred to 

as 3D faces, polygonal faces, or poly meshes. Other types of entities such as lines, curves, circles, polylines, and free 
form surfaces can exist in the file but are not imported when the symbol is created. This is true for all 
(.dxf/.dwg/.obj/.3ds/.skp) file types.

 l The face data should be assigned to different layers so that you can map them to the correct materials when viewing 
them in 3D. It is helpful to name your layers using a convention that identifies that materials should be assigned to 
each sub-component.

 l Pay attention to the origin and orientation of the 3D data when designing symbols. Home Designer allows some 
adjustment when creating the symbol, but it is easier to build the 3D data correctly before importing it into Home 
Designer. For more information about defining the origin, see Editing Symbol Objects on page 721.

 l If a symbol with faces that have more than four vertices is imported, the faces are truncated, resulting in an object that 
appears to have holes. The best remedy is to re-export the model from the original application using only triangular or 
quadrilateral faces.

 l Home Designer does not support grouped objects in symbols imported from .3ds files. 

SURFACE NORMALS

If you use third party software to create a .dxf/.dwg/.obj/.3ds./skp file that will be imported as a symbol, you should be 
familiar with the concept of surface normals.

A surface normal is a vector that is perpendicular to the plane of a surface. This vector points in one direction, determined 
by the way the face is drawn.

If a face is drawn clockwise, the surface normals are directed outward; if a face is drawn counter-clockwise, the surface 
normals point inward. Home Designer assumes that the face on the positive side of the normal vector is the outside face.
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Many objects can be drawn using only one side of each face. A cube is a good example: the inside of a cube is not visible, 
so it is not necessary to create its inside faces. When inside faces are not calculated, 3D views in Home Designer can 
generate more quickly. 

 

3D Symbols and Materials
When a symbol is imported into Home Designer, material definitions may be included with it. Whether and how material 
information is included depends on the symbol’s file format. See About Materials on page 746. 

DXF/DWG and STL Files

.dxf/.dwg and .stl files do not include information about material definitions. When imported, default materials for interior 
fixtures will be assigned.

OBJ Files

Material definitions for most .obj files are saved in a separate file with the .mtl file extension. If such a file exists, the 
materials associated with the .obj file display in the list on the left side of the MATERIALS panel of its specification dialog. 

If Home Designer does not receive material definition information in an accompanying .mtl file, default material properties 
are assigned. 

Material definitions for .obj files can also include texture information in the form of image files (.jpg, .png, etc). 

In order to properly import an .obj file, Home Designer needs the .obj file, the .mtl file, and any referenced texture files. If 
a texture file is not available, the material it is associated with is created without a texture.

The material definitions associated with an imported .obj symbol are not available for use by other objects in Home 
Designer until that symbol has been placed into a plan. The associated texture files are then copied to the user’s Textures 
folder. See Home Designer Pro Data on page 35. 

3DS and DAE Files

Material definitions for .3ds and .dae files refer to texture information in separate image files. 

In order to properly import a .3ds and .dae file, Home Designer needs these referenced image files. If a texture file is not 
available, the material it is associated with will be created without it. The associated texture files are copied to the user’s 
Textures folder. 

SKP Files

The textures associated with a .skp file are saved in the file. After you import a symbol and either place it in a plan or add it 
to the Library, these textures are saved in the user's Textures folder. 

Home Designer does not support deformed textures. If a texture associated with a .skp file is deformed, it will be imported 
without the deformations. 

TEXTURE FILENAME CONFLICT

If a texture of the same name already exists in the plan when an .obj, .3ds, or .skp file is imported, the Texture Filename 
Conflict dialog displays. 
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 l Select Rename the imported texture, then click the Browse button to create a copy of the texture’s image file with a 
new name that you specify. 

 l Select Use the existing texture instead of the imported texture to keep the existing texture.
 l Select Replace the existing texture with the imported texture to replace the texture already present in the plan with 

the new, imported one.
 l Check Do this for all remaining textures in this object to use the same selection for all textures with filename 

conflicts associated with this symbol. 

 

Exporting a 3D Model
The entire 3D model, or any part that you choose, can be exported from Home Designer into              either of two formats:

 l DAE Format on page 730
 l STL Format on page 731

To export a 3D model

 1.  A camera view or overview must be active. See Types of 3D Views on page 771.          

 2.  Make sure that everything that you want to export is set to display in the current view, and everything you do not 
want to export is not set to display. See Layers on page 124.          

 l Any surfaces removed using the Delete Surfaces  tool will not be exported. See Displaying 3D Views on page 

783.         

 3.  When the model is ready, select File> Export> and choose the file format that you want to use.          

 4.  Give the file a name, making sure to save it in the desired location. See Exporting Files on page 39. 

Note: Some proprietary 3D data provided in Manufacturer catalogs 
cannot be exported. The program will notify you if this protected data is 
included in the model you are trying to export. See Manufacturer 
Catalogs on page 705.

DAE FORMAT

A .dae file can be opened by any program that uses COLLADA™’s .dae format. When the model is ready, select 
File> Export> 3D COLLADA Model to export to this format.         

The Export COLLADA Model dialog is a typical File Save dialog.         
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Any light sources that are On in the current view, as well as ambient light, will be exported to a .dae file along with the 
model. See Lighting on page 817.         

Any material textures used in the model are saved as image files in a folder in the same location as the saved .dae file. The 
folder has the same name as the .dae file, appended with “_textures”.         

STL FORMAT

An .stl file can be opened by any program that uses Stereolithography format, and can be printed using a 
stereolithography machine, or 3D printer. When the model is ready, select File> Export> 3D Model (STL).         

The Export STL Model dialog is a typical File Save dialog.         

A 3D model exported to an .stl file does not include any material or texture information.         
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Chapter 28
 

Architectural Blocks

An architectural block is a collection of individual 3D objects that are grouped together so that they can be placed and 
moved as a single object. Although blocked together, these objects retain many of their own attributes, such as materials.

Architectural blocks can also be exploded so that the individual sub-objects become independent of one another.

TOPICS

Creating Architectural Blocks 733
Displaying Architectural Blocks 733
Editing Architectural Blocks 734
Architectural Block Specification Dialog 735
Architectural Blocks, Sub-Objects, and Components 736
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Creating Architectural Blocks
To create an architectural block, group-select multiple architectural objects, then click the Make Architectural Block 
edit button. Architectural blocks can be created in any view. See Architectural vs CAD Objects on page 112.         

The following is a list of objects that can be included in architectural blocks:         

 l Cabinets (Base, Wall, Full Height)             
 l Custom Countertops
 l Soffits, Shelves, Partitions             
 l Fixture and Furniture symbols              
 l Hardware symbols             
 l Millwork symbols             
 l Geometric Shapes             
 l Electrical objects             
 l Images             
 l Slabs and Foundation Slabs             
 l Roads, Driveways, Sidewalks             
 l Terrain Features and Terrain Modifiers             

Once blocked, the set of blocked objects is contained in a bounding box, indicating that they are now an architectural block.          

 

Displaying Architectural Blocks
As with individual objects, the display of architectural blocks is controlled in the Layer Display Options dialog. See 
Layer Attributes on page 125.   

 l If an architectural block is composed of objects that are on the same layer, the block will be placed on that layer, as 
well. 

 l If an architectural block is composed of objects on different layers, the block will be placed on the “Architectural 
Blocks” layer.

IN PLAN VIEW

You can control the appearance of the bounding box by changing the display properties of the architectural block’s layer or 
you can turn off its display in the Architectural Block Specification dialog. See General Panel on page 735.          

Like other objects, an architectural block is placed in a Drawing Group that affects whether it displays in front of or behind 
other objects. You can modify a selected  architectural block’s place in the drawing order by clicking the View Drawing 
Group Edit Tools  edit button. See Drawing Group Edit Tools on page 129.         

ARCHITECTURAL BLOCK LABELS

Architectural blocks can display labels for both the block and any component objects that have labels in plan              view. As with 
the objects they are associated with, you can turn off the display of component labels by layer. Labels  for architectural 
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blocks are placed on the “Architectural Blocks, Labels” layer and use the Text Style assigned to that layer. See             Label Panel 
on page 376.         

The label for an architectural block can be generated automatically, user-specified, or suppressed. See Architectural Block 
Specification Dialog on page 735.          

 

Editing Architectural Blocks
Architectural blocks can be selected and edited in 2D and 3D views. See Selecting Objects on page 142.

Note: Moving an architectural block in 3D view regenerates the view. If 
the architectural block contains terrain objects, the terrain is rebuilt.

Once selected, an architectural block can be edited using its edit handles, edit toolbar buttons, and specification dialog. See 
Architectural Block Specification Dialog on page 735.

USING THE EDIT HANDLES

A selected architectural block displays a Move handle and a Rotate handle.

Architectural blocks cannot be resized, but the individual objects in a block can be. 

IN THE SPECIFICATION DIALOG

Architectural blocks can be edited in their specification dialog. See Architectural Block Specification Dialog on page 
735.         

USING THE EDIT TOOLS

A selected architectural block or blocks can be edited in a variety of ways using the buttons on the Edit Toolbar. See The 
Edit Toolbar on page 92.   

EDITING SUB-OBJECTS

The individual objects included in an architectural block can also be selected and edited. See To select a sub-object on page 
736.

EXPLODE ARCHITECTURAL BLOCK

You can break an architectural block to make its objects independent. Select the architectural block and click the 
Explode Architectural Block edit button.  

Note: If you open a plan created in another version of Home Designer 
and an architectural block includes an object that you cannot create in 
your version of the software, you cannot unblock it or edit its 
components. 

ADDING ARCHITECTURAL BLOCKS TO THE LIBRARY

You can create your own architectural blocks and save them in the library. See Add to Library on page 709.         
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Architectural Block Specification Dialog
The Architectural Block Specification dialog controls the way architectural blocks display in plan view and in 
materials lists. Select one or more architectural blocks and click the Open Object edit button to open this dialog.         

GENERAL PANEL

 
Display Options

These settings control the appearance of the selected architectural block in plan view. See Displaying Architectural Blocks 
on page 733.         

 l Check Display Bounding Box to show the bounding box of the objects in the architectural block.             

 l Uncheck Display Sub-Objects to suppress the display of the sub-objects and display only the bounding box. If 
Display Bounding Box is unchecked, it will become checked.             

 l Check Display Sub-Objects Using Block Draw Order to display all component objects of the selected block using 
the block’s drawing order. When unchecked, each component displays according to its individual drawing order. See 
Drawing Groups on page 129.          

 
Size/Position

These settings are not available if the selected block includes any objects such as electrical objects that do not have these 
settings in their individual specification dialogs.         

 l Select the Elevation Reference from the drop-down list. This determines where the next two settings are measured 
from and also affects their setting labels. See Elevation References on page 20.    

 o Specify the height to Top, measured from the selected Elevation Reference to the top of the architectural block.             

 o Specify the height to Bottom, measured from the selected Elevation Reference to the bottom of the architectural 
block.             

 

Options

 l When Suppress Adjacent Room Moldings is checked, a room's base, chair, and/or crown moldings will not 
generate where the selected block's bounding box crosses them when positioned against a wall. When unchecked, 
room moldings are not affected by the block and generate normally. See Room Moldings on page 308.
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Preview

A preview of the selected cabinet displays on the right side of the panel. See Dialog Preview Panes on page 21. 

LABEL PANEL

Labels for Architectural Blocks display in plan view when the “Architectural Blocks, Labels” layer is turned on and use the 
Text Style assigned to that layer. See Architectural Block Labels on page 733.         

The LABEL panel is available for a variety of different objects. For more information, see              Label Panel on page 376.    

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 967.          

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in the materials list. For more information, see 
Object Information Panel on page 968.         

 

Architectural Blocks, Sub-Objects, and Components
An architectural block is composed of a group of sub-objects that have been blocked together. For example, a kitchen island 
architectural block may consist of cabinets, appliances, a custom countertop, and other accessories.

Each of the sub-objects in an architectural block may contain additional parts called  components. The cabinets in a kitchen 
island, for example, may contain handles, hinges, and drawer glide.         

SUB-OBJECTS

Certain attributes of an architectural block can be edited at the sub-object level. A sub-object can be edited by accessing its 
specification dialog in either of two ways:

 l Explode the architectural block, select the sub-object, and click the Open Object  edit button.

 l Select the sub-object while it is part of the architectural block and click the Open Object  edit button. Some 

attributes may not be editable while the object is part of a block. See Editing Architectural Blocks on page 734.

To select a sub-object

 1.  Click the Select Objects  button, then click on the sub-object that you would like to edit.

 2.  With the architectural block selected, click the Select Next Object  edit button or press the Tab key. 

  The selection switches to the individual object and it can be edited using its edit handles, edit toolbar and 
specification dialog.

The options for editing a sub-object may be more restricted than if the object were independent. If more extensive editing is 
required, the architectural block must be exploded. See Explode Architectural Block on page 734.
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COMPONENTS

You can view and modify the components of an architectural block or group of blocks in the Architectural Block 
Specification dialog. The COMPONENTS panel lists all the sub-objects that comprise an architectural block, as well as the 
components that make up each sub-object. See Components Panel on page 967.          
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Chapter 29
 

Other Objects

Home Designer has additional objects that can be used to customize your design. 

TOPICS

General Shapes 739
Soffits 739
Soffit Specification Dialog 740
Material Layers Definition Dialogs 743
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General Shapes
Items in the Home Designer Core Catalogs> Shapes library catalog allow you to create a variety of custom objects 
using basic geometric shapes. These shapes can be used individually or combined to create a wide variety of custom 

objects. 

General Shape objects are placed and edited much like other library objects. See Editing Box-Based Objects on page 160.

 

Soffits
Soffits typically fill the space between the tops of wall cabinets and the ceiling, but they are very versatile and can be 
used to create almost any other object that can be modeled as a 3D box. Select Build> Cabinet> Soffit to activate 

this tool.         

SOFFIT DEFAULTS

The default settings for soffits are set in the Soffit Defaults dialog. The settings in this dialog are similar to those in 
the Soffit Specification dialog. See Soffit Specification Dialog on page 740.         

When a soffit is created, it is placed on the “Cabinets, Soffits” layer. See Layer Attributes on page 125.          

For best results when placing soffits above wall cabinets:         

 l The default soffit should be the same width as and 1" (20mm) deeper than the default wall cabinet. See Cabinet 
Defaults on page 445.          

 l The default soffit Floor to Bottom value should equal the sum of the default wall cabinet’s Floor to Bottom value plus 
its Height. See General Panel on page 740.         

 l The default soffit Height should be equal to or greater than the space between the ceiling and the top of the wall 
cabinets.          

If the sum of the default soffit’s Floor to Bottom value and Height is larger than the ceiling height of the room in which a 
soffit is placed, the Floor to Bottom value will be retained and its Height will be adjusted so that it fits under the ceiling.          

The maximum soffit width is 250 feet (48m), and the minimum width is 1/16" (1 mm).         

Once a soffit is placed in a plan, you can change its size and position to meet a variety of needs. See Editing Box-Based 
Objects on page 160.    

PLACING SOFFITS

Soffits can be created in both 2D and 3D views by simply clicking with the Soffit  tool active. See Click-to-Create on 

page 117.          

To create a corner soffit, click as close to an inside wall corner as possible. A corner soffit retains its shape when it is 
moved, edited, or copied.          

When positioned against a wall in a room, soffits will automatically display any moldings present in that room that are at 
the same height as the soffit. Soffits can also have custom molding profiles assigned to them. See Moldings Panel on page 
318.         

When positioned against the ceiling in a room, a soffit will prevent the Ceiling Finish layers directly above it from 
generating in 3D. See Lowered Ceilings on page 305.          
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CALCULATING MATERIALS ON SOFFITS

The number of bricks, tiles, shingles, shakes or other materials applied to a soffit is calculated using the following rules:   

 l If the soffit depth is less than the larger of 4 inches (10 mm) or 1 ½ times the material thickness, then only the front 
area of the soffit is used. Thus if a soffit is 48"x48"x4" thick, and the Dark Red brick material is used (3"x 8" with 
3/8" mortar joint), the front of the soffit is 48"x48"=2304 square inches. Including the mortar joint, each brick requires 
3 3/8" x 8 3/8" = 28.26 square inches. 2304 sq. in. divided by 28.26 sq. in. per brick gives 81.5 bricks.    

 l If the soffit depth is greater than both 4 inches (10 mm) and 1 ½ times the material thickness, then the surface areas of 
the soffit back, sides and top are used in addition to the front, if these surfaces are not attached to a wall or other soffit. 
However, only those portions of the sides, top and bottom remaining after subtracting twice the material thickness are 
used. So, for Dark Red brick, which has a depth of 4", the sides, top and bottom surface areas cannot contribute to the 
brick count unless the soffit depth is greater than 8 inches.    

 l If surface materials such as brick are applied to a large soffit, the soffit center is assumed to be hollow, with only a 
single layer of the material applied to each applicable face.    

 l For shingles and shakes, the overlap amount should be subtracted from the height, as opposed to brick or tile, where 
the joint width is added to the size.    

 l For materials in the area category, the soffit area calculation above is used, with the material thickness treated as zero.    
 l For materials in the volume, concrete or earth categories, the true volume of the soffit is used.    

 

Soffit Specification Dialog
To open the Soffit Specification dialog, select the soffit and click the Open Object edit button or double-click on a 
soffit using the Soffit               tool.         

The settings in this dialog are similar to those in the Soffit Defaults dialog, but affect only the selected object(s).          

GENERAL PANEL

 
Size/Position

Define the Size and Position of the selected soffit relative to the floor              or terrain.          
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 l Specify the Width of the soffit.          

 l Define the vertical Height of the soffit.          

 l Define the Depth, which is the distance between the front and the back of the soffit. When selected in plan view, the 
front of a soffit has a “V,” and the back of the soffit has a triangular rotation handle.         

 l If the selected soffit is a corner soffit, the Width controls its left side width, and Depth controls its right side width.          

 l Specify the distance from Floor to Top of the soffit.         

 l Specify the distance from Floor to Bottom of the soffit.          

 l When the selected soffit is outside a room, its Floor to Bottom height is measured relative to the terrain. Check Auto 
Adjust Height to maintain the same distance above the terrain if the soffit is moved to a location with different 
terrain height. Uncheck this to maintain the same absolute height regardless of the terrain below. When Auto Adjust 
Height is checked, the Floor to Bottom value may automatically adjust if the soffit is moved.         

 l Check Sloped Soffit to slope the soffit vertically from the back up towards the front. This may become checked 
automatically if you check Place Under Ceiling or Place Under Roof, below. When you specify a soffit as sloped, 
the available options on this panel change. See  General Panel - Sloped Soffits on page 741, below.

 l The Height at Back Face and Front Face settings become enabled when Sloped Soffit is checked. See  General 
Panel - Sloped Soffits on page 741, below.         

 
Options

Only the Ignore Room Moldings setting is available in the Soffit Defaults dialog.

 l Specify the Corner Type: "Diagonal", "L-Shaped", or "None" which produces a rectangular soffit. In the Soffit 
Defaults dialog, "Diagonal" and "L-Shaped" are the available Auto Corner Types. Not available when Sloped Soffit 
is checked, above. See Corner Cabinets on page 462.

 l Check Place Under Ceiling to adjust the soffit’s height so its top contacts the ceiling above. If the soffit is below a 
sloped ceiling plane, Sloped Soffit will become checked and the Height at Back and Front Face will adjust to match 
the pitch. Not available in the Soffit Defaults dialog, or if the soffit is not below a ceiling.             

 l Check Place Under Roof to adjust the soffit’s height so its top contacts the bottom of the roof above.                  Provided that 
the roof above does not have a pitch of 0, Sloped Soffit will become checked and the Height at Back and Front Face 
will adjust to match the pitch. Not available in the Soffit Defaults dialog, or if there is no roof above the soffit.             

 l Check Ignore Room Moldings to prevent the selected soffit from displaying moldings assigned to the room that it is 
placed in. See Room Moldings on page 308.          

 
Preview

A preview of the soffit displays on the right side of the dialog box. See Dialog Preview Panes on page 21.         

 GENERAL PANEL - SLOPED SOFFITS

When a soffit is specified as sloped, the available options on the GENERAL panel of the Soffit Specification dialog change.
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 l Width is measured left to right across the soffit, parallel to the front of the soffit.             
 l Thickness is the top-to-bottom height of the front and back faces of the soffit.         
 l Horizontal Length is measured from back to front in plan view. When a soffit is sloped, this measurement is not the 

actual length of the soffit’s bottom or top edge. It cannot, for example, be used to determine the length of a sloped 
beam.         

Both the front and back heights of a sloped soffit must be defined. Checking Place Under Ceiling or Place Under Roof will 
automatically adjust these values to match the slope of the ceiling or roof plane above.

 l Height at Back Face is measured from the finished floor to the lowest point at the back of the soffit.         
 l Height at Front Face is measured from the finished floor to the underside of the soffit at the upper end.         

MOLDINGS PANEL

The settings on the MOLDINGS panel allow you to assign one or more horizontal moldings around the selected soffit.    

For information about the settings on this panel, see Moldings /  Rails Panels on page 688.   

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the selected soffit’s appearance in plan view. For information about the settings 
on this panel, see Fill Style Panel and Dialogs on page 132.    

MATERIALS PANEL

For information about the settings on this panel, see Materials Panel on page 750.   

LABEL PANEL

Soffit labels display in plan view when the “Cabinets, Labels” layer is turned on and use the Text Style assigned to that 
layer. The Automatic Label for Soffits is blank, but you can specify a custom label.    See Cabinet Labels on page 455.

For more information about the settings on this panel, see     Label Panel on page 376.   
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COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 967.    

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in the materials list. For more information, see 
Object Information Panel on page 968.   

 

Material Layers Definition Dialogs
The Material Layers Definition dialogs allow you to define the layers that make up wall, floor, ceiling, slab, and roof 
assemblies. The names of these dialogs vary and are determined by the type of object or component being edited. They 
include:

 l Backsplash Layers Definition
 l Ceiling Structure Definition
 l Floor Structure Definition

See Custom Backsplashes on page 452 and Floor and Ceiling Platforms on page 303.   

 
Layers

The selected  assembly’s layers are numbered and listed from the top of the structure to its bottom. To select a layer for 
editing, click in its row.

 l Click in the Material, Pattern, or Texture column to open the Select Material dialog and choose a material for the 
selected layer. See Select Material/Library Object Dialog on page 751.     

 l Click in the Thickness column to type the selected layer’s thickness or depth. Very thin layers can be created, but 
for best results avoid using a thickness of 0. For very small values, it can be helpful to temporarily change the dialog 
number format: click the Number Style button.          

 l The Total Thickness of the assembly displays to the right as a reference.          
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 l Select a Structure Type from the drop-down list. Only available when the selected material is a Framing type. See 
Displaying Framing on page 655.           

 
Structure

Specify whether the selected layer has special structural attributes.    

 l Check Framing to produce framing in the selected layer when framing is generated for the selected structural 
assembly's type. See Automatic Framing on page 631.    

 l Select the framing Type from the drop-down list. See Displaying Framing on page 655.     

 l Check Air Gap to prevent the selected layer from displaying in 3D views or being calculated in the Materials List. 
See Creating an Accurate Materials List on page 952.    

 
Preview

A preview of the selected assembly displays here. See Dialog Preview Panes on page 21.         

 l By default, a gap is shown between each of the assembly layers. Click the Explode Layers  button to remove or 

restore these gaps.          
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Chapter 30
 

Materials

The objects used in Home Designer have a variety of 3D properties. These objects - walls, windows, doors, cabinets, roof 
planes, lot perimeters, etc. - can have materials assigned to them so that they look realistic in 3D views. These materials can 
also be used to generate materials lists that can help with cost estimations. 

Designing with objects that look correct in 3D and calculate properly in the Materials List requires that you use realistic 
material definitions and apply them appropriately to objects in your plan.

Home Designer comes with many materials that are ready for use. From siding, roofing, flooring, masonry, tile, and 
paneling, to road surfaces, grass, water, and wood materials, Home Designer has materials for every application, inside and 
out. If you cannot find a material that suits your needs, you can customize the materials provided or create your own.

Learning how to create, manage, apply, and edit materials saves time and adds that professional touch to your designs.          

Redefining only the visual properties of a material may create 
unexpected results. For example, changing the image of a brick 

material to represent siding does not cause the material to be considered 
as siding during material calculations.

TOPICS

About Materials 746
Material Defaults 746
Material Painter Tools 747
Materials Panel 750
Select Material/Library Object Dialog 751
Editing Materials 753
Creating Materials 755
Mapping Patterns and Textures 756
Materials and the Materials List 757
Managing Plan Materials 759
Define Material Dialog 760
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About Materials
The materials that are assigned to objects in Home Designer perform these important roles:

 l They determine what the surfaces of objects look like in 3D views. 
 l They influence how objects are calculated in the Materials List. See Materials Lists on page 950.

Materials are stored in the Library Browser and can be applied to objects in either of two ways:

 l Using the Material Painter . See Material Painter Tools on page 747.

 l In an object’s specification dialog. See Materials Panel on page 750.

PATTERNS AND TEXTURES

In Home Designer Pro, materials have two attributes that determine what they look like in 3D views: Textures and Patterns.          

 l Textures are created using special image files that tile seamlessly when applied to surfaces and are visible in most 
Rendering Techniques. See In Rendered Views on page 784.         

 l Patterns are composed of CAD lines and are seen in Technical Illustration and Vector Views. Select 3D> Toggle 
Patterns  to toggle the display of patterns on or off in these views in the current plan. See Rendering Techniques 

on page 832.
 l Materials also have a solid Material Color, which is the pattern field color and is also used if a material has no texture. 

Often, the texture and pattern for a given material are both set up to represent the characteristics of the material in the real 
world and have similar sizing and angles. When customizing such a material, check Keep Pattern/Texture in Sync before 
making changes to maintain this consistency. See Define Material Dialog on page 760.         

MATERIALS LIST CALCULATION METHODS

Every material can be assigned a Calculation method which defines how the material is calculated in the Materials List: for 
example, by piece, area, or volume. See Materials and the Materials List on page 757.         

 

Material Defaults
Most objects in the program have defaults dialogs which allow you to set up a variety of attributes, including 
materials, before the objects are created. These defaults dialogs are accessed by selecting Edit> Default Settings. See 

Preferences and Default Settings on page 56.

The Material Defaults dialog serves two purposes. It allows you to:

 l Set the default materials for objects that do not have a defaults dialog: for example, fireplaces and furnishings from the 
library. 

 l Set the initial materials that can then populate a variety of defaults dialogs. Door, Window, and Cabinet Defaults are 
examples of defaults dialogs that can draw their material assignments from the Material Defaults dialog. 

Material defaults are dynamic, which means that if you change a particular default material, all objects that are set to use 
that default will automatically update to use the new material. See Dynamic Defaults on page 58. 
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Because material defaults are dynamic, you can use the Material Defaults dialog to apply a material to multiple objects that 
share similar components. For example:

 l The “Room Moldings” Material Default applies to the base, crown, and chair rail moldings that can be assigned to 
rooms, as well as to interior door and window casing. If you change this Material Default, all of these objects in the 
plan can be affected.

 l The “Cabinet”, “Cabinet Door/Drawer”, “Countertop”, and “Hardware” Material Defaults can be used in your Cabinet 
Defaults dialogs to ensure that all cabinets use the same materials. See Dynamic Cabinet Defaults on page 445. 

MATERIAL DEFAULTS DIALOG

Select Edit> Default Settings  from the menu, select “Materials”, and click the Edit button to open the Material 

Defaults dialog. 

 l Select a material category from the scrollable list. Select multiple line items using the Shift or Ctrl/⌘  key. See Shift 
and Ctrl/⌘  Select on page 146. 

 l Click the Select Material button or either material preview box to open the Select Material dialog. See Select 
Material/Library Object Dialog on page 751.

 

Material Painter Tools
In a 3D view, select 3D> Material Painter to access the Material Painter Tools, which are used to apply materials 
to object surfaces. The Material Painter tools are available in all Rendering Techniques except Glass House views. 

See Glass House on page 833.

If you use the Material Painter to change a Deck room’s 
planking or framing will affect its floor structure definition. See 

Floor and Ceiling Platform Definitions on page 303. 

MATERIAL PAINTER

The Material Painter tool allows you to apply a selected material to other objects in 3D views. It can be activated in 
several ways: 
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 l Select 3D> Material Painter> Material Painter . 

 l Select a material in the Library Browser while a 3D view is active. 
 l The Material Painter also becomes active when the Material Eyedropper is used.

The Material Painter  is similar to the other Painter tools but has some additional considerations. See Painter Tools on 

page 190.

To use the Material Painter tool

 1.  In a 3D view, select 3D> Material Painter> Material Painter . 

 2.  Choose a material from the Select Material dialog. See Select Material/Library Object Dialog on page 751.         

 l Check Use Default Material at the bottom left of the LIBRARY MATERIALS panel or select “Use Default” from the 
top of the list on the PLAN MATERIALS panel to apply the default material to any object that has a defaults dialog. 
See Material Defaults on page 746.

 3.  If you click the Copy Selected Material  button, a copy of the selected material is created and the Define 

Material dialog will open, allowing you to customize that copy. See Copy Selected Material on page 749.    

 4.  Select one of the Material Painter Scoping Modes from the Edit Toolbar. See Material Painter Scoping Modes on 
page 749, below.

 5.  If you selected a solid color material, choose whether to use the Blend Colors with Materials  option and click 

the edit button to turn this feature on or off. See Blend Colors With Materials on page 749, below.

 l The mouse pointer displays a paint roller icon    when Blend Colors With Textures is active.

 l The mouse pointer displays a spray can icon    when the Material Painter is active and Blend Colors With 
Textures is not. 

 6.  Note that the name of the material being painted displays on the left side of the Status Bar at the bottom of the 
program window. See The Status Bar on page 24. 

 l Move your pointer over a surface in the 3D view. The Status Bar now states both the material being painted and 
the current material on the target surface.

 7.  Click on a surface to apply the selected material to that surface. The material is applied to surfaces in the model 
based on the active Material Painter Scoping Mode.          

 8.  If either the Component  or Object Mode  is active, you can continue to click on surfaces to apply the 

selected material. When you are finished, select a different tool. 

MATERIAL EYEDROPPER

The Material Eyedropper tool allows you to load the material assigned to an existing object into the Material 
Painter and apply that material to other objects and is similar to other Eyedropper tools. See Eyedropper Tools on 

page 189.
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MATERIAL PAINTER SCOPING MODES

There are five Material Painter Scoping Modes, each specifying how broadly or narrowly the selected material will be 
applied to surfaces in your plan. They are similar to other Painter Scoping Modes in the program, but rather than modify 
instances of an object type, the Material Painter Scoping Modes replace instances of a material based on the selected scope. 
See Painter Scoping Modes on page 190.

These Painter Scoping Modes are also available when the Adjust Material Definition  tool is used, allowing you to 

control how extensively a change to a material is applied throughout the current plan. See Adjust Material Definition on 
page 753.

  Material Painter Component Mode is the default mode and applies the selected material to a single component 
on the target object. For most object types, using this tool is the same as opening an object’s specification dialog 

and changing the material of one of its components on the MATERIALS panel. See Materials Panel on page 750.
  Material Painter Object Mode replaces all instances of a material on the target object. 

  Material Painter Room Mode replaces all instances of a material in the room where the target object is located. 

  Material Painter Floor Mode replaces all instances of a material on the floor where the target object is located. 

  Material Painter Plan Mode replaces all instances of a material in the entire plan. 

BLEND COLORS WITH MATERIALS

The Blend Colors With Materials option allows you to apply a solid color to a surface displaying a texture or 
pattern and blend the two. 

Blend Colors With Materials  works in all five Material Painter Scoping Modes. See Blending Materials on page 756.

COPY SELECTED MATERIAL

The Copy Selected Material tool creates a copy of the selected material, gives you an opportunity to customize it as 
needed, and then lets you apply the new material to surfaces in the model. This option is helpful if you need slightly 

different versions of the same material - for example, to orient wood planks or tile in different directions.   

When you click the Copy Selected Material  button, the Define Material dialog will open, allowing you to customize 

the new material. When you click OK, the customized material is loaded into the Material Painter. See Define Material 
Dialog on page 760.

Once you apply the material to one or more surfaces in the model, it will be listed in the Plan Materials dialog. See 
Managing Plan Materials on page 759.   

MATERIAL PAINTER AND WALLS

Painting walls is an obvious use for the Material Painter ; however, it is important to note that the Material Painter 

Scoping Modes affect walls and rooms somewhat differently than they do other objects: particularly if a wall defines 
multiple rooms on the side that is being painted.

Component  and Object Modes  only paint the section of the wall that defines the room located where you click to 

apply a new material. Sections of the same wall that define other rooms are unaffected. 
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Room Mode  applies the material to all walls and solid railings that define the room where you click provided that they 

have the same original surface material as the one being painted. Any other objects in the room with that original material 
are also affected, but railings are not unless they are specified as Solid. 

Floor  and Plan Modes  apply the material to all walls, all railings, and any other objects with the same original 

surface material as the one being painted: either on the current floor, or throughout the plan.

Note: Wall materials applied using the Material Painter tool are not 
calculated in the Materials List. See In the Materials List on page 248.

 

Materials Panel
The specification dialogs for most objects include a MATERIALS panel. Select an object or a group of similar objects 
and click the Open Object edit button to open the specification dialog for that selection. 

On the MATERIALS panel, you can specify material assignments for the components that make up that object. When a new 
material is assigned, the appearance of the preview image on the right side of the dialog updates. 

If the selected object is using a material that is missing its texture, a Caution   symbol will display next to the Materials 
panel name in the list on the left side of the object’s specification dialog. See Referenced Files on page 44. 

 
Object Components

The table on the left side of the panel lists the components of the selected object that can be assigned unique materials, 
along with the names of those materials and whether or not the default materials are used. Some objects may have only one 
component while more complex objects may have many. As changes are made to the selected object, components may be 
added to or removed from this table.    

 l Click on a Component in the table to select it. Multiple line items can be added to the selection set by holding down 
the Shift or Ctrl/⌘  key. See Shift and Ctrl/⌘  Select on page 146.    

 l The selected component’s Material is stated in the list, to the right of the component name. If the component is using 
the default material, the name will be preceded by the word “Default:”. If it is using a Material Default, it will be 
preceded by the word “Default” followed by the name of an object type. See Material Defaults on page 746.    

750



Home Designer Pro 2025 Reference Manual - Select Material/Library Object Dialog

Note: If the selected object is a wall or a room modified using the 
Material Painter, a component’s Material may be described as “No 
Change”. See Material Painter and Walls on page 749.

 
Material Preview

The two boxes to the right of the table display previews of the color, pattern, and texture of the material assigned to the 
selected component. If “No Texture” displays in the preview window, the material has no texture assigned to it; if a Caution 
 symbol and the words,“Texture Missing” display, the texture file could not be found on the system. 

  There are several ways to open the Select Material dialog and choose a different material for one or more selected line 
items:    

 l Double-click on a line item in the table.    

 l Select one or more line items and click the Select Material button.    

 l Select one or more line items and click on either of the preview boxes. 
See Select Material/Library Object Dialog on page 751. 

 
Preview

A preview of the selected object displays on the right side of the panel. To view material textures, select Standard as the 
View Type; to view material patterns, select Vector View. See Dialog Preview Panes on page 21.   

 

Select Material/Library Object Dialog
The Select Material dialog allows you to select a material to apply to one or more objects and is opened by clicking the 
Select Material button on the MATERIALS panel of most specification dialogs or by using the Material Painter . See 

Materials Panel on page 750 and Material Painter Tools on page 747.

The similar Select Library Object dialog allows you to select an item from the library to either apply or insert into a 
currently selected object. See Placing Library Objects on page 714.

The Select Library Object dialog has a single panel; however, depending on how it is accessed, the Select Material dialog 
will have either two or three panels:          

 l The Library Materials Panel on page 751 allows you to select materials from the Library Browser.          
 l The Plan Materials Panel on page 753 lets you select materials from the Plan Materials dialog.          
 l The Material Defaults Panel on page 753 lets you associate an object component with a Material Defaults category 

rather than a specific material and is only available when the component of a library symbol is selected on the 
MATERIALS panel of the object’s specification dialog.          

The Rendering Technique, object shape, and backdrop selections in this dialog are shared with the Plan Materials and 
Define Material dialogs. The object shape and backdrop are also shared with the Library Browser. You also can specify a 
Blurred Backdrop Effect in the Preferences dialog that is used in all of these dialogs and in the Library Browser. See Define 
Material Dialog on page 760 and Appearance Panel on page 63.         

LIBRARY MATERIALS PANEL

The LIBRARY MATERIALS panel is a modal version of the Library Browser that lists only materials. See The Library 
Browser on page 692.
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Most of the settings on this panel are also found in the Select Library Object dialog. See Select Library Object Dialog on 
page 716.

The LIBRARY MATERIALS panel has most of the functionality that the Library Browser has, including the search, search 
filtering options, and preview options. 

 l To locate a material, you can search, apply a Library Filter or Tag, or browse the Folders tree list. See Searching and 
Filtering  the Library on page 698.

 l Located below the tree list, check Use default material to apply the default material to the selected object component
(s), if one exists. See Material Defaults on page 746. 

 l A preview of the selected material displays on the right. See Dialog Preview Panes on page 21.
 l To apply a material to an object, select it in the Filter Results panel and click OK. 

A selection of buttons below the tree list allows you to control the appearance of the panes in this dialog. The Selection and 
Preview panes are always present when the dialog is first opened. See The Library Browser on page 692.

 l For materials, select an object shape to display the material on in the preview on the far right: Cube, Sphere, Teapot, 
or Plane.

 l For materials, specify the background for the object shape: Use Default Room or Backdrop from Library.  See 3D 
Backdrops on page 841.

An additional button allows you to add new content to the User Catalog. The available option varies depending on the type 
of library item being assigned or inserted into another object.

 l Click the Add New Fill Style  button to open the Fill Style Specification dialog. See Fill Style Panel and Dialogs 

on page 132. 
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 l Click the Add New Backdrop  button to open the Import Backdrop File dialog. See 3D Backdrops on page 841.

 l Click the Add New Material  button to open the Define Material dialog and create a new material saved in the 

User Catalog. See Define Material Dialog on page 760.

The OK button is only active when a library item is selected. If a library folder or catalog is selected, the OK button cannot 
be clicked. 

The Rendering Technique and object shape selections in this dialog are shared with the Define Material and Select Material 
dialogs. The object shape is also shared with the Library Browser. See Dialog Preview Panes on page 21.         

PLAN MATERIALS PANEL

The PLAN MATERIALS panel is similar to the Plan Materials dialog and lets you select from a list of materials already 
present in the plan as well as manage that list. See Managing Plan Materials on page 759.           

Select “Use Default” from the top of the list to apply the default material to the selected object, if applicable.          

MATERIAL DEFAULTS PANEL

The MATERIAL DEFAULTS panel will only be present if the Select Material dialog was accessed via an object specification 
dialog where a component of an inserted library symbol was selected.

Rather than apply a specific material to the selected component, you can dynamically associate it with a Material Default 
category. See Material Defaults on page 746.

 

Editing Materials
Much like objects, materials in Home Designer can be edited so that they better suit your design needs. There are several 
ways to customize a material:

 l Edit the original material and replace all instances of it in the current plan;
 l Create and edit a copy of the original material and replace only some instances of the original in the current plan;
 l Edit a material in the Library Browser and apply it in any plan as needed.

Editing the material applied to an object is not the same as 
applying a different material to that object. See Material Painter 

Tools on page 747.

ADJUST MATERIAL DEFINITION

The Adjust Material Definition tool lets you make changes to the materials seen in camera views.

Adjust Material Definition has five Painter Scoping Modes that allow you to control how extensively your changes to a 
given material are applied:

  Material Painter Component Mode allows you to edit the material applied to a single component on a target 
object. If any other instances of the original material are present in the current plan, including on other 

components of the same object, you will be presented with the option of editing a copy of the original material on that 
component so those other instances can remain unchanged.
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  Material Painter Object Mode allows you to edit all instances of the material on a target object. If any other 
instances of the original material are present on other objects in the current plan, you will be presented with the 

option of editing a copy of the original material on the target object so those other instances can remain unchanged.
  Material Painter Room Mode allows you to edit all instances of the material located in the same room as the 
target object. If any other instances of the original material are present in other rooms in the current plan, you 

will be presented with the option of editing a copy of the original material so those other instances can remain 
unchanged.

  Material Painter Floor Mode allows you to edit all instances of the material located on the same floor level as 
the target object. If any other instances of the original material are present on other floors in the current plan, you 

will be presented with the option of editing a copy of the original material so those other instances can remain 
unchanged.

  Material Painter Plan Mode allows you to edit all instances of the material in the current plan. When Plan 
Mode is selected, the original material is modified and creating a copy of it is not an option.

To use the Adjust Material Definition tool

 1.  Create a camera view in which a material that you would like to modify can be seen.

 2.  While the camera view is active, select 3D> Adjust Materials> Adjust Material Definition .

 3.  Notice that the  Adjust Materials Painter Scoping Mode buttons become available on the Edit Toolbar, and click 
on the Mode that suits your needs.

 4.  Select the material that you want to edit:

 l Move your mouse pointer over a surface and notice the Status Bar reports that material's name.

 l Click on a surface displaying the material you want to edit.

 5.  If the material is assigned to any objects outside the scope set by the selected Mode, the Create Copy of Material 
dialog will open. 

 l Select Create a Copy of the Material to make a copy of the material and leave the original unchanged, then type 
a name for the new material in the Copy Name text field.

 l Select Edit the Source Material to modify the original material and apply your changes plan-wide.

 6.  The Define Material dialog opens next, allowing you to edit either the original material or a copy of it. See Define 
Material Dialog on page 760.

 7.  When you click OK, your customized material will be applied in the current plan according to the selected Mode. 

Changing a material definition using the Adjust Material Definition tool only affects objects in the current plan that are 
using that material. It does not affect any materials saved in the library or materials used in other plans. See Adding Library 
Content on page 709.
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PLAN MATERIALS

You can also edit, copy, and create new materials in the Plan Materials dialog. Select 3D> Plan Materials to open 
this dialog for the current plan.

IN THE LIBRARY BROWSER

Materials saved in the User Catalog of the Library Browser are editable: right-click on one and select Open Object  

from the contextual menu to open the Define Material dialog for that material. See Editing Library Objects on page 713.

 

Creating Materials
Home Designer provides a wide variety of materials - including numerous name brand material catalogs - that are ready to 
download and use. If you cannot find a suitable material, you can edit an existing material or create a new one. See Editing 
Materials on page 753.

TEXTURE FILE MANAGEMENT

Materials often have a texture which is an image file that add realism to the material's appearance. In order to display a 
material’s texture, Home Designer needs to be able to locate the image file associated with it on your computer. See 
Referenced Files on page 44.

If a texture referenced by a newly created material is not located in either the Home Designer Pro 2025 Data folder or the 
installation folder for the program’s library textures, a copy of the file will be made in Home Designer Pro 2025 
Data\Textures\Material Data and the material will reference that copy. See Home Designer Pro Data on page 35.

IN THE PLAN MATERIALS DIALOG

There are two ways to create a new material in the Plan Materials dialog. See Managing Plan Materials on page 759.          

 l Click the New button to create a new material for use in the current plan file.          
 l Select a material and click the Copy button to make a new material based on the original, which can then be edited 

and used in the current plan.         

IN THE LIBRARY BROWSER

Materials can be created in the Library Browser, making them available for use in any plan. See Adding Library Content on 
page 709. 

In the directory pane of the Library Browser, right-click on an unlocked folder and select New> Material  from the 

contextual menu. See Using the Contextual Menu on page 697.

The Define Material dialog opens, allowing you to specify the new material’s attributes. See Define Material Dialog on 
page 760. 

USING PASTE IMAGE

A new material can be created by copying an image that will serve as its texture to the system clipboard, then navigating to 
a Home Designer Pro window and selecting Edit> Paste> Paste  from the menu. See Cut, Copy, and Paste on page 118.           
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COPYING MATERIALS

When the Adjust Material Definition tool is used with any scoping mode other than Plan Mode, the program will 
prompt you to choose whether to edit the original material or create a copy of it. See Adjust Material Definition on 

page 753.

BLENDING MATERIALS

In 3D views, you can create a new material by blending a solid color such as a paint color with a textured and/or 
patterned material. Select 3D> Material Painter> Blend Colors With Materials to toggle this feature on or off. See 

Blend Colors With Materials on page 749.

The result is a new material that is saved in the current plan. It can be found in the Plan Materials dialog, edited as needed, 
and added to the library if desired. See Managing Plan Materials on page 759.

Materials created using the Blend Colors With Materials  tool are given the name of the patterned/textured material 

with the extension “--PAINTED:” followed by the name of the solid color material. 

 

Mapping Patterns and Textures
Materials have two attributes that determine what they look like in 3D views: patterns and textures. See About Materials on 
page 746.          

Both patterns and textures have points of origin, which determine where the pattern or texture begins on an X/Y axis. By 
default, this origin is 0,0; however, you can specify a different origin for each in the Define Material dialog. See Define 
Material Dialog on page 760.         

You can also specify whether a material’s pattern and texture origins are set globally or independently for each object. By 
default, this mapping is per object; check Global Symbol Mapping on either the TEXTURE or PATTERN panel of the Define 
Material dialog to map all instances of the material throughout the plan from the same origins.         

If a material is set to map globally, it may not look right on some surfaces in 3D views. If this is the case and you do not 
wish to map the material independently on each object, you can create a copy of the material for each surface that requires 
modification and specify its texture’s origin.         

The fill styles of CAD objects are similar to material patterns 
and can also be mapped on an individual object basis. See Fill 

Style Panel and Dialogs on page 132.

DETERMINING THE ORIGIN

Before a new origin can be specified, the display of coordinates in the Status Bar should be enabled. See The Status Bar on 
page 24.         
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To determine origin coordinates on the horizontal plane, place your cursor over the origin location in floor plan view. When 
the pointer is in the position you want to establish as the material origin, take note of the coordinates that display in the 
Status Bar.          

To determine origin coordinates on the vertical plane, place your cursor over the origin location in a cross section/elevation 
view.         

Once you have taken note of the new origin coordinates, enter them as Horizontal and Vertical Offsets on either the 
PATTERN or TEXTURE panel of the Define Material dialog. See Define Material Dialog on page 760.         

A texture or pattern origin is a property of the material rather than of the object that the material is assigned to. When an 
object is moved, the pattern or texture maintains its absolute position and may not look right. It is a good idea to assign 
pattern or texture origins only after the position of the object has been finalized.         

STRETCH TO FIT

Some special textures, often used for artwork, do not tile. Instead, these textures resize to stretch across any surfaces that 
they are applied to. Materials that behave this way are specified as Stretch to Fit in the Define Material dialog. See Define 
Material Dialog on page 760.   

To display an artwork texture, first place a wall or desk frame in your plan. A selection of both are available in the library. 
See Placing Library Objects on page 714.         

Next, simply apply a material specified as Stretch to Fit to the center portion of the frame. See Material Painter Tools on 
page 747.         

 

Materials and the Materials List
When applied to structural components like slabs or wall, floor and ceiling, or roof layers, materials determine how or 
whether those components are calculated in the Materials List. Each material’s Structure Type and its Calculation Method 
are specified in the Define Material dialog. See Materials List Panel on page 768.         
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MATERIAL STRUCTURE TYPES

The Material Structure Type controls how or whether certain structural features generate in the model.          

 l The Concrete type must be assigned to a wall type in order for a brick ledge to be cut into it.       This type is also required 
to produce rebar and steel mesh in the Materials List. It is recommended for concrete walls, footings and monolithic 
slabs See Foundations on page 496 and Brick Ledges on page 237.    

 l The Masonry type must be assigned to the exterior layer of a wall type in order to generate a brick ledge in the wall 
below.

 l The Other type is useful for other structural applications such as framing, sheathing, and siding.          

CALCULATION METHODS

A material’s Calculation method controls how it is counted in the Materials List when it is applied to structural components 
like wall, ceiling, floor, layers, or slabs.          

For walls, structural assembly layers, and slabs,  "Area", "Count" and "Linear" calculations are based on the area of the 
assembly or the top of the slab. If a material is calculated by "Count", its Depth is not used; however, the thickness of the 
layer or slab is noted in the Size column of the Materials List.          

For Soffits, "Area", "Count" and "Linear" calculations are made for all sides of the object. The Depth of materials calculated 
by "Count" is used, but thickness is otherwise not noted.         

 l "Area" calculates the total area of a material in               structural     layers and slabs              in square feet (m).          
 l "Count" calculates a piece count based the material’s Width, Height, and Depth.          
 l "Linear" calculates the total length of strips required to cover the area in feet (m).          
 l "Volume" calculates the total volume of a material in      structural     layers and slabs              in cubic yards (m)         
 l "None" prevents the material from being calculated in the materials list at all.           

To prevent a structural layer from being counted in the materials 
list as well as from displaying in the 3D model, specify it as an 

Air Gap. See Wall Type Definitions Dialog on page 264 and Material 
Layers Definition Dialogs on page 743.

Once a Materials List has been created, the unit of measurement can be changed. See Changing Count Units on page 961.

REPRESENTING OVERLAP

Any material using the Count or Linear Calculation method can be set up to account for material overlap in the Define 
Material dialog. To do this:          

 l On the PATTERN panel, set up the material’s pattern so that it accurately represents the size and shape of the exposed 
portion of an individual piece or strip.          

 l On the TEXTURE panel, set the Scale to represent the appearance of the exposed material in rendered 3D views.         
 l On the MATERIALS LIST panel, specify the full size of the actual material, including the overlapped portion.          

If a material is set up to represent overlapping pieces, it is important that you not click the Update from Pattern button. 
See Materials List Panel on page 768.         
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Managing Plan Materials
The Plan Materials dialog allows you to manage the materials used in the current plan. Select 3D> Materials> Plan 
Materials to open this dialog. You can also access its settings in the Select Material dialog. See Select 

Material/Library Object Dialog on page 751.          

When a material is applied to an object in a plan, a copy of that material is created and saved with the plan. If you use the 
Define Materials dialog to modify that material, your changes affect it wherever it is found throughout that plan. All objects 
in that plan that use that material are affected, but objects placed in other plans are not.           

All materials that come with Home Designer are stored in the 
Library Browser. You can create your own materials and save 

them there, as well. See Creating Materials on page 755.

PLAN MATERIALS DIALOG

 
Search

Begin typing in the text field. As you type, the list below will be filtered to show only materials with names that contain 
your text.

 
Plan Materials

A sortable, scrollable list of the materials referenced by the current plan displays here. Click on the name of a material to 
select it. Select multiple materials by holding down the Shift or Ctrl/⌘  key.         

 l If there is a check mark in the In Use column, the material is used by one or more objects in your plan or is defined 
as a default material for one or more objects in your plan.          

 l If the In Use column is empty, the material was used at one time but is no longer assigned to any objects or used as 
a default.          

 
Management Options

The buttons on the right allow you to modify the selected material and manage the items in the list.         
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 l Click Edit to open the Define Material dialog for the selected material. See Define Material Dialog on page 760.          

 l Click New to open the Define Material dialog to create a new material.          

 l Click Copy to create a copy of the selected material and open the Define Material dialog where you can make 
changes to the copied material.          

 l Click Purge to remove all unused materials from the plan.          

 l Click Delete to remove the selected material from the plan. If the material is used in the model, you cannot delete it.          

 l Click Add to Library to add the selected material to the Library Browser, making it available for use in other plans. 
See Adding Library Content on page 709.              

Note: Although there is no limit to the number of materials you can have 
in one plan, it is recommended that you keep the total number below 
1024.

 
Preview

A preview of the material applied to an object displays here. If multiple materials are selected at once, the first one in the 
list will display. Various options allow you to view different aspects of the material’s attributes:         

 l Display the material in Physically Based, Standard rendering, or Vector View.   

 l Zoom and orbit the object in the view.          

 l Toggle Color on or off.          

 l Click the Restore Original View  button to reset the material preview to its original perspective.           

 l Select an object shape: Cube, Sphere, Teapot, or Plane.          

The Rendering Technique and object shape selections in this dialog’s preview are shared with the Define Material dialog. 
Unlike other dialog previews, these are retained when you close the dialog. The object shape selection is also shared with 
the Library Browser. See Dialog Preview Panes on page 21 and The Library Browser on page 692.          

 

Define Material Dialog
The Define Material dialog allows you to adjust how materials look in 3D views as well as how they are calculated in the 
Materials List. It can be accessed in a number of ways:

 l Use the Adjust Material Definition  tool. See Adjust Material Definition on page 753.

 l Select a material from the Plan Materials dialog and click Edit, New, or Copy. See Managing Plan Materials on page 
759.

 l Right-click on a material in the User Catalog in the Library Browser and select Open Object  from the contextual 

menu. When multiple materials are selected, some settings will not be available. See Using the Contextual Menu on 
page 697.

 l You can also right-click on the User Catalog and select New> Material.

If you select a material from a Manufacturer Catalog, some options in the Define Material dialog may not be available and 
the panels may vary. See Manufacturer Catalogs on page 705.       

If you access the Define Material dialog through a menu or specification dialog, any changes you make will affect that 
material wherever it is found in the current plan. Other objects in that plan using that material will also be affected, but 
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objects outside the current plan will not. You can click the Add to Library button at the bottom of the dialog to add the 
material to the User Catalog for future use in any plan. See Adding Library Content on page 709.

The Rendering Technique, object shape, and backdrop selections in this dialog are shared with the Plan Materials and Select 
Material dialogs. The object shape and backdrop are also shared with the Library Browser. You can specify a Blurred 
Backdrop Effect in the Preferences dialog  that is used in all of these dialogs and in the Library Browser. See Dialog 
Preview Panes on page 21 and Appearance Panel on page 63.         

The Define Material dialog has the following panels:

PATTERN PANEL

Patterns are used to represent materials in Technical Illustration and Vector Views. See Patterns and Textures on page 746.

 
Material Name

The Material Name displays here. You can type a different name if you wish. Renaming the material does not create a new 
material: it redefines the existing material. See Creating Materials on page 755.         

 l Check Keep Pattern/Texture in Sync to maintain consistent Scale and Offset and Angle settings for both the 
selected material’s pattern and its texture if any of these settings are modified.

 
Colors

Specify the Colors used to represent the material’s pattern in Vector Views. Click either color box to open the Select Color 
dialog and select a color. See Select Color Dialog on page 135.         
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 l The Material Color displays in Vector Views and is used in rendered views if a material has no texture specified. 
See In Vector Views on page 784.

 l The pattern Line Color displays in Vector Views only.

 l Specify the Line Weight, which is the thickness of the pattern lines.

 l Specify the Shading Contrast, which is the amount of contrast between surfaces at different angles to each other in 
Vector Views. You can specify whether Shading Contrast is used in the Rendering Technique Options dialog. See 
Vector View Panel on page 836.

The following shows a curved wall with three different Shading Contrasts (created in a separate graphics program). Notice 
how the lowest contrast at the top appears almost flat.         

 
Pattern

When “No Pattern” is selected as the Pattern Type, the Scale, Offset and Angle settings are disabled.         

 l Select a Pattern Type from the drop-down list. Select “Library” or click the Library button to select a pattern from 
the library. When a pattern is selected from the library, its name will display in the list. See Select Library Object 
Dialog on page 716.

  Scale

 l Specify the Width of the selected pattern. For Concrete and Sand materials, instead adjust the overall pattern 
Spacing.             

 l Specify the selected pattern’s Height. Only available for Brick, Tile, Shingles, and U’s patterns.

 l For some imported patterns and patterns from the library, instead specify the pattern’s X Scale and Y Scale. If the 
pattern appears black in the square preview pane, these values should be increased.

 l Uncheck Retain Aspect Ratio if you would like to modify the Height or Width without affecting the other value. 
This check box is an action rather than a state: the next time you open this dialog, it will be checked.
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  Offset and Angle

 l Specify the Row Offset for Grid, Offset and Grid, Step patterns.

 l Specify the Horizontal and Vertical Offsets, if needed, so the pattern displays correctly on surfaces. See Mapping 
Patterns and Textures on page 756.

 l Specify the pattern's Angle, measured counterclockwise, in degrees.

 l Check Global Symbol Mapping to map the pattern and texture using the same origin on all objects. When 
unchecked, the origin is defined individually for each object.

 
Copyright

If the selected pattern has a Copyright, information about it displays here.

 
Pattern Preview

A preview of the material’s pattern displays in the square pane. It updates as you change the pattern’s specifications.

 
Preview

A preview of the material applied to an object displays here and updates as changes are made to the material definition. 
Various options allow you to view different aspects of the material’s attributes:         

 l Scroll in the preview pane to zoom or click and drag to orbit the object shape in the view.

 l Display the material in              Standard rendering or Vector View.

 l There are two options for clicking and dragging within the Preview pane:

 o When a Spherical Backdrop is specified for the material preview, click the Rotate Spherical Backdrop  button, 

then click and drag in the preview pane to adjust the backdrop horizontally. Not available if the Default Room or a 
regular backdrop is in use. See Spherical Panoramic Backdrops on page 842.

 o When Mouse Orbit Camera  is toggled on, you can click and drag in the preview pane to orbit around the object 

displaying the selected material.

 l Toggle Color  on or off.

 l Click the Restore Original View  button to reset the material preview to its original perspective.

 l Select an object shape: Cube, Sphere, Teapot, or Plane.

 l Select the background for the object shape: Use Default Room  or Backdrop from Library .  Recently used 

backdrop images can also be selected. See 3D Backdrops on page 841.

The Rendering Technique and object shape selections in this dialog’s preview are shared with the Plan Materials dialog. 
Unlike other dialog previews, these are retained when you close the dialog. The object shape selection is also shared with 
the Library Browser. See Managing Plan Materials on page 759.

TEXTURE PANEL

In most Rendering Techniques, materials are represented using textures. See Rendering Techniques on page 832. 

Transparency information may be contained on the alpha channel of a texture; if so, it is used in rendered views. 
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Material Name

The Material Name displays here and can be changed if you wish. Renaming the material does not create a new material: it 
redefines the existing material.         

 l Check Keep Pattern/Texture in Sync to maintain consistent Scale and Offset and Angle settings for both the 
selected material’s pattern and its texture if any of these settings are modified.

 
Texture Source

Displays the path and file name of the selected texture.             

 l Click the Browse button to browse to a texture file saved on your computer. Supported file formats are .jpg, .bmp,
 .png, .gif, and .tif. See Creating Materials on page 755.

 l You can also type or paste the full path name of a texture in the text field. To remove the file, click the Remove   
button.

 l Textures saved in .zip files can also be used. See To use an image saved in a .zip file on page 766, below.

 l If the texture is not located in either the Home Designer Pro 2025 Data folder or the installation folder for the 
program’s library textures, a copy of the file will be made in Home Designer Pro 2025 Data\Textures/Material Data. 
See Home Designer Pro Data on page 35.
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  Scale

 l Adjust the X Scale and Y Scale, or height and width, of the selected texture.

 o If a surface is larger than the area described by the X and Y Scale, the surface will receive “tiles” of the texture 
image. If it is smaller, only a portion of the texture is shown.

 o Check Stretch to Fit to stretch the texture image to cover each surface's height and/or width. For artwork or 
photography in a frame, check Stretch to Fit for both X Scale and Y Scale.        

 l Check Retain Aspect Ratio to maintain the ratio between the texture image’s height and width and prevent 
distortion when either its X or Y Scale value is adjusted.

 l Click the Reset Original Aspect Ratio button to restore the texture image's actual aspect ratio.

Note: Changing the scale or selecting Stretch to Fit can cause textures 
to appear distorted if applied to a surface with a different aspect ratio 
than the original texture image. 

 
Offset and Angle

 See Mapping Patterns and Textures on page 756.   

 l Specify the X and Y Positions of the texture’s origin, if needed, to adjust its layout on surfaces.

 l Specify the Angle of the texture on the surfaces of objects, in degrees.

 l Check Global Symbol Mapping to map the texture and pattern using the same origin on all objects. When 
unchecked, the origin is defined individually for each object.

 
Material Color

Material Color can also be set on the PATTERN panel. See Pattern Panel on page 761.         

 l Check Blend with Texture to apply the Material Color over the material’s texture. 

When a new material is created using the Blend Colors With Materials  tool, the resulting material has this box 

checked. See Blend Colors With Materials on page 749.

 l Click the Color button to specify the Material Color.

 l Click the Set Material Color Using Texture button to use the predominant color of the material’s texture. See 
Patterns and Textures on page 746.

 
Texture Preview

A preview of the material’s texture displays in the square pane. It updates as you change the material definition.

 
Preview

A preview of the material applied to an object displays here and updates as changes are made to the material definition. 
Various options allow you to view different aspects of the material’s attributes:         

 l Scroll in the preview pane to zoom or click and drag to orbit the object shape in the view.

 l Display the material in              Standard rendering or Vector View.

765



Home Designer Pro 2025 Reference Manual - Define Material Dialog

 l There are two options for clicking and dragging within the Preview pane:

 o When a Spherical Backdrop is specified for the material preview, click the Rotate Spherical Backdrop  button, 

then click and drag in the preview pane to adjust the backdrop horizontally. Not available if the Default Room or a 
regular backdrop is in use. See Spherical Panoramic Backdrops on page 842.

 o When Mouse Orbit Camera  is toggled on, you can click and drag in the preview pane to orbit around the object 

displaying the selected material.

 l Toggle Color  on or off.

 l Click the Restore Original View  button to reset the material preview to its original perspective.

 l Select an object shape: Cube, Sphere, Teapot, or Plane.

 l Select the background for the object shape: Use Default Room  or Backdrop from Library .  Recently used 

backdrop images can also be selected. See 3D Backdrops on page 841.

The Rendering Technique and object shape selections in this dialog’s preview are shared with the Plan Materials dialog. 
Unlike other dialog previews, these are retained when you close the dialog. The object shape selection is also shared with 
the Library Browser. See Managing Plan Materials on page 759.

To use an image saved in a .zip file

 1.  Type or copy the full path name of the .zip file in the text field.

 2.  Directly after the path name, type #zip:, followed immediately by the name of the bump map file including its file 
extension.

PROPERTIES PANEL

The PROPERTIES panel controls how the material appears in most rendered 3D views.         

A material’s rendered appearance is also affected by the Render settings in the Preferences dialog and the lights that have 
been placed in the model. See Light Types on page 819.         

For special lighting effects on an object, use at least one point or spot light.         

766



Home Designer Pro 2025 Reference Manual - Define Material Dialog

 
Material Name

The selected materials' name displays here. You can type a different name if you wish. Renaming the material does not 
create a new material: it redefines the existing material.

  Options

 l Brightness controls how bright the material appears. It can be used to get the desired appearance relative to other 
materials being used.

 l Shininess controls the sheen of the material when it is rendered with a point or spot light source on it. Shiny 
materials appear to have a bright white spot on them which simulates reflection of light.

 l Transparency - Use the slider bar or text field to control the materials transparency. A value of 0 is completely 
opaque and a value of 100 is completely transparent. Specifying materials with transparency can slow down 
rendering speed in some situations.

 l Emissive - Use the slider bar or text field to control how bright a material appears independent of the lighting in the 
scene. It can be used to simulate surfaces that are glowing with their own light, such as the glass on a light fixture.

 
Preview

A preview of the material applied to an object displays here and updates as changes are made to the material definition. 
Various options allow you to view different aspects of the material’s attributes:             

 l Scroll in the preview pane to zoom or click and drag to orbit the object shape in the view.

 l Display the material in              Standard rendering or Vector View.

 l There are two options for clicking and dragging within the Preview pane:

 o When a Spherical Backdrop is specified for the material preview, click the Rotate Spherical Backdrop  button, 

then click and drag in the preview pane to adjust the backdrop horizontally. Not available if the Default Room or a 
regular backdrop is in use. See Spherical Panoramic Backdrops on page 842.

 o When Mouse Orbit Camera  is toggled on, you can click and drag in the preview pane to orbit around the object 

displaying the selected material.

 l Toggle Color  on or off.
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 l Click the Restore Original View  button to reset the material preview to its original perspective.

 l Select an object shape: Cube, Sphere, Teapot, or Plane.

 l Select the background for the object shape: Use Default Room  or Backdrop from Library .  Recently used 

backdrop images can also be selected. See 3D Backdrops on page 841.

The Rendering Technique and object shape selections in this dialog’s preview are shared with the Plan Materials dialog. 
Unlike other dialog previews, these are retained when you close the dialog. The object shape selection is also shared with 
the Library Browser. See Managing Plan Materials on page 759.

MATERIALS LIST PANEL

The settings on the MATERIALS LIST panel control how the selected material is counted in the Materials List. See Materials 
and the Materials List on page 757.          

 
Material Name

The Material Name displays here. You can type a different name if you wish. Renaming the material does not create a new 
material: it redefines the existing material.

  Specifications

 l Select a Material Structure Type from the drop-down list. The selected Type defines how - or whether - the 
material is calculated in the Materials List. See Material Structure Types on page 758.

 l Select a Materials List Calculation method. When “Framing” is the selected Structure Type, the only available 
Calculation Method will be “Framing". See Calculation Methods on page 758.

 l The settings that are available below depend on which Calculation method is selected.

 l Specify the material’s Width. This value is available for Count and Linear Calculation methods.

 l Specify the material’s Height. Only available for the Count Calculation method.

 l Click the Update from Pattern button to make the Width and Height values here match those set on the PATTERN 
panel. Only available when Count or Linear is selected as the Calculation method.
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 l Specify the material’s Depth. Only available for the Count Calculation method, this value is only used for Materials 
List calculations when the material is applied to a Soffit. This value may also be used if the Material Painter is used 
to create a floor or ceiling finish. See Floor and Ceiling Finishes and the Material Painter on page 305.

 
Preview

The settings on the MATERIALS LIST panel affect how the material is calculated in Materials Lists, but not its appearance in 
camera views.

MANUFACTURER PANEL

If the selected material is from a Manufacturer library catalog, the Define Material dialog will have a              fifth              panel: the 
MANUFACTURER panel, which lists contact information. See Manufacturer Catalogs on page 705.          
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Chapter 31
 

3D Views

Little preparation is needed to create a 3D view of a model: simply click a button to create an overview or click and drag to 
create a camera or cross section/elevation view. 

To improve the quality of the rendering and create a custom look, you can adjust lighting and edit the materials used in the 
plan. See 3D Rendering on page 814.

Many objects can be placed and edited in 3D views, and any camera view or overview can be saved or even used to record 
a walkthrough. See Pictures, Images, and Walkthroughs on page 845.
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Types of 3D Views
There are three categories of 3D views in Home Designer: camera views, overviews and cross section/elevation views. Each 
of these view types can be generated using a variety of Rendering Techniques. See Rendering Techniques on page 832.         

Every 3D view is also either orthographic or perspective in nature. Cross section/elevation views are always orthographic 
while camera views are always perspective. You can choose to generate overviews as either orthographic or perspective.           

PERSPECTIVE AND ORTHOGRAPHIC VIEWS

Perspective views have a focal, or vanishing, point. Surface edges and lines that would be parallel in real life appear to 
converge towards that focal point, and objects closer to the camera appear larger while objects farther from the camera 
appear smaller.          

Orthographic views do not have a focal or vanishing point. Parallel surface edges and pattern lines appear parallel in these 
views and objects appear to be the same size regardless of their distance from the camera.          

Perspective views display 3D objects much the way that they appear to the eye in real life, so they are ideal for presentation 
views. By default, perspective views are created using the Standard Rendering Technique.          

Orthographic views, on the other hand, are useful for technical drawings. By default, orthographic views are created using 
the Vector View technique.          

RENDERED AND VECTOR VIEWS

3D views can be generated using a variety of different Rendering Techniques. See Rendering Techniques on page 832.          

Most rendered views represent materials using textures. Surface edge lines are generally not drawn and lighting is often 
modeled, creating results that range from a photorealistic appearance to artistic painting styles.

Vector Views are non-photorealistic views in which objects are drawn using surface edge lines, or vectors. Limited lighting 
and shadows can be calculated and materials are represented using pattern lines and solid colors. Vector Views are ideal for 
layout drawings and high resolution printing. See Vector View on page 832.         

 

3D View Defaults and Preferences
There are a number of defaults and preference settings that allow you to control the initial characteristics of 3D views.           

  Camera positioning, field of view and related initial settings for camera views are specified in the Camera 
Defaults dialogs. See Camera Defaults Dialogs on page 772.             

  The settings in the 3D View Defaults dialog control a variety of functions that affect views created by all 3D 
View tools. See 3D View Defaults Dialog on page 774.             

  The default characteristics of the Generic Sun light source can be specified in the Generic Sun Defaults dialog. 
See Adjust Sunlight Dialog on page 830.             
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  As in plan view, the display of objects in 3D views can be controlled by layer. See Layer Attributes on page 125.

  3D views can be generated using any of the Rendering Techniques. See Rendering Techniques on page 832.             

  The initial settings for each Rendering Technique can be set in the Rendering Techniques Defaults dialog. See 
Rendering Technique Options on page 834.             

  The RENDER panel of the Preferences dialog has settings that affect 3D views. See Render Panel on page 86.             

 

Camera Defaults Dialogs
There are several defaults dialogs for cameras, which can be accessed by selecting Edit> Default Settings or by 
double-clicking either the Orthographic or Perspective View Tools parent button. In the Default Settings dialog, 

click the arrow next to “Camera Tools”, then select a subheading and click the Edit button to open the defaults dialog 
associated with your selection.

The various Camera Defaults in the list can be multiple-selected and then edited as a group by holding down the Shift or 
Ctrl/⌘  keys. Depending on the selection, not all settings may be available. See Shift and Ctrl/⌘  Select on page 146.          

The defaults dialog for Camera Tools other than Overviews can be accessed by double-clicking the associated toolbar 
button.          

The settings in the Camera Defaults dialogs affect how each type of camera captures, clips, and renders views; how they 
display in  plan view; how they are positioned; and how they move.          

Once a camera is created, its attributes can be customized. See Editing 3D Views on page 791.

FULL CAMERA DEFAULTS

Specify the initial attributes of cameras created using the Full Camera  tool. See Camera Views on page 775.

The settings in this dialog are the same as those the Full Camera Specification dialog. See Camera Specification Dialogs on 
page 801. 

Note: The Reflections setting in the Full Camera Defaults is used by 
walkthroughs created using the Walkthrough Path tool. See Recording a 
Walkthrough on page 871. 
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FLOOR CAMERA DEFAULTS

Specify the initial attributes of cameras created using the legacy Floor Camera  tool. This tool is not in the menus or 

default toolbars but can be added to the toolbars               if you wish. See Toolbars and Hotkeys on page 90. 

The settings in this dialog are the same as those in the Floor Camera Specification dialog.           

PERSPECTIVE FULL OVERVIEW DEFAULTS

Specify the initial attributes of cameras created using the Perspective Full Overview  tool. See Full Overview on page 

778.         

The settings in this dialog are the same as those in the Perspective Full Overview Specification dialog.

DOLL HOUSE VIEW DEFAULTS

Specify the initial attributes of cameras created using the Doll House View  tool. See Doll House View on page 778.         

The settings in this dialog are the same as those in the  Doll House View Specification dialog.

PERSPECTIVE FRAMING OVERVIEW DEFAULTS

Specify the initial attributes of cameras created using the Perspective Framing Overview  tool. See Overviews on page 

776.   

The panels in this dialog are the same as their respective panels in the Orthographic Framing Overview Specification dialog. 

CROSS SECTION/ELEVATION DEFAULTS

Specify the initial attributes of cameras created using the Cross Section/Elevation  tool. See Cross Section/Elevation 

Views on page 776.         

The settings in this dialog are also found in the Cross Section/Elevation Specification dialog. See Cross Section/Elevation 
Specification Dialogs on page 809.         

BACK CLIPPED CROSS SECTION DEFAULTS

Specify the initial attributes of cameras created using the Back Clipped Cross Section  tool. See Cross 

Section/Elevation Views on page 776.          

The panels in this dialog are the same as their respective panels in the Cross Section/Elevation Specification dialog. See 
Cross Section/Elevation Specification Dialogs on page 809.          

WALL ELEVATION DEFAULTS

Specify the initial attributes of cameras created using the Wall Elevation  tool. See Cross Section/Elevation Views on 

page 776.         

The panels in this dialog are the same as their respective panels in the Wall Elevation Specification dialog. See Cross 
Section/Elevation Specification Dialogs on page 809.          
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ORTHOGRAPHIC FULL OVERVIEW DEFAULTS

Specify the initial attributes of cameras created using the Orthographic Floor Overview  tool. See Full Overview on 

page 778.          

The panels in this dialog are the same as their respective panels in the Orthographic Full Overview Specification dialog.           

ORTHOGRAPHIC DOLLHOUSE VIEW DEFAULTS

Specify the initial attributes of cameras created using the Orthographic Dollhouse View  tool. See Overviews on page 

776.         

The panels in this dialog are the same as their respective panels in the Orthographic Dollhouse View Specification dialog. 

ORTHOGRAPHIC FRAMING OVERVIEW DEFAULTS

Specify the initial attributes of cameras created using the Orthographic Framing Overview  tool. See Overviews on 

page 776.   

The panels in this dialog are the same as their respective panels in the Orthographic Framing Overview Specification dialog.

 

3D View Defaults Dialog
Select 3D> 3D View Defaults or Edit> Default Settings  to open the 3D View Defaults dialog.         

The settings in this dialog control a variety of functions that affect views created by all 3D View tools.           

 
General Options

These settings affect all 3D views. 

 l Check Camera Bumps Off Walls to prevent cameras from moving freely through walls. When this setting is on, 
you can "walk" up a staircase by moving the camera using the Move Camera Tools.
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 l When Turn Automatically is checked, cameras automatically change direction when they approach a wall, door 
opening, or staircase. This should be unchecked when using a 3D mouse or gamepad. See 3Dconnexion® 3D Mice 
on page 786 and Move Camera Tools on page 788.

 l Check Auto Rebuild Walls/Floors/Ceilings to automatically rebuild floors and ceilings before a 3D view or 
elevation is displayed. When this is unchecked and the structure is not up-to-date, the Rebuild Walls, Floors, 
Ceilings   icon displays near your mouse pointer. See Rebuilding Walls, Floors and Ceilings on page 522.

 l Check Legacy Compatible Texture Mapping to use global texture mapping settings rather than texture mapping 
fixed to individual objects. 

Legacy Compatible Texture Mapping should remain 
unchecked except in legacy plans with custom rotated textures.

 l When Auto Adjust Electrical Default Glass Properties is checked, the program automatically adjusts the 
behavior of electrical fixture glass in Standard rendered views in response to interior and exterior lighting 
conditions. When this box is unchecked, these adjustments are not made. 

 l Check Always Display Active Cameras to turn on the display of active camera symbols, even when the 
“Cameras” layer is turned off. When unchecked, active camera symbols obey the layer setting.

 l When Display Openings Independent of Walls and Roofs is checked, doors, windows, and skylights display in 
3D views when their containing wall or roof plane does not. Uncheck this to prevent these objects from displaying 
in 3D when their parent objects do not. This setting affects the display of openings in both Invisible walls and 
those on layers that are not set to display.

 
Surface Edge Lines

Specify how Surface Edge Lines display for all objects in Vector View renderings. Surface edge line color in Technical 
Illustration renderings are also affected by these settings. See Rendering Techniques on page 832.

 l Check Use Layer Settings to display surface edge lines for objects using the display settings specified by layer in 
the Layer Display Options dialog. If this option is not checked, all edge lines are drawn black and solid with a line 
weight of 0. See Layer Attributes on page 125.

 l When Use Object Settings is checked, all objects that have non-default settings specified on the LINE STYLE panel 
of their specification dialog display using those settings, overriding the layer settings in the Layer Display Options 
dialog. Only available when Use Layer Settings is checked. See Line Style Panel on page 209.

 

3D View Tools
Select 3D> Create Orthographic View to display the Orthographic View Tools or 3D> Create Perspective 
View to display the Perspective View Tools. 

There are three  types of 3D Views:

CAMERA VIEWS

Camera views are Perspective views. They are not scaled and cannot be annotated but are ideal for creating presentation 
views.          
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  The Full Camera tool creates multi-floor views of the 3D model. It can be used to create interior and exterior 
perspectives, and is good for displaying cathedral ceilings, roofs, lofts, stairwell openings, and other variation in 

floor and ceiling levels.
  The Floor Camera tool creates perspective views of the current floor only. Nothing above the ceiling surface is 
generated, and neither is anything below the floor. This legacy tool is not in the menus or default toolbars but can 

be added to the toolbars              if you wish. See Toolbars and Hotkeys on page 90. 

OVERVIEWS

An overview can be either orthographic in nature or perspective, depending on the tool used to create it. See Creating 
Overviews on page 777.

  The Orthographic and Perspective Full Overview tools create views of the entire model including all 
floors, ceilings, and the roof.    

                   The  Orthographic and Perspective Doll House View tools create views of the current floor with the 
ceiling removed and all floors beneath it visible.         

                   The Orthographic and Perspective Framing Overview tools create views of the framing in the model. 
Framing must be built in order for it to display in a framing overview. See Framing Overview on page 

778.    

CROSS SECTION/ELEVATION VIEWS

Cross Section/Elevation views are similar to the traditional, scaled orthographic views often used in drafting. They are 
scaled and can be fully annotated. See Cross Section/Elevation Views on page 779.         

  A Cross Section/Elevation view displays all floors of the model. If the view is created outside the structure 
looking toward it, the result is an exterior elevation. If the view is created inside the structure, or passes through 

any of the structure, a cross section is created.         
  The Back Clipped Cross Section tool includes only the objects between the starting point and stopping point of 
the cross section line.         

  The Wall Elevation tool creates an elevation of a wall on a single floor and in a single room. The Wall 
Elevation tool cannot be used to create exterior views.         

 

Creating Camera Views
All Camera views are created using the same method.

To create a camera view

 1.  In plan view, select the desired camera tool. The mouse pointer displays the camera   icon. 

 2.  Click and drag a line to define the view direction.

A. Camera Position (click)
B. Line of Sight (drag)
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C. Focal Point (release)
D. Field of View

 l The camera's position is where you click to begin the line. 

 l The line that you drag defines the direction the camera is pointed. 

 l The end of the line is the focal point of the view, the point the camera rotates around.

 l The Field of View is 55° by default.

 3.  To create a camera using the Alternate Rendering Technique, right-click and drag to create the camera. See 
Alternate on page 139.

 4.  When you release the mouse button, a view generates in a new window.

 5.  Return to the plan view. A camera symbol now displays in plan view. See Working in Multiple Views on page 105.

In order to create a camera view, you must click and drag at least as far as your current Snap Distance. See Snap Properties 
Panel on page 82. 

A new camera can also be created by copying and pasting an existing camera symbol selected in plan view. See Copying 
and Pasting Objects on page 118.

CAMERA HEIGHT

By default, Cameras are created at a height of 60” (1500 mm). Where this height is measured from depends on the location 
of the camera:

 l If the camera is inside a room, it is measured from that room’s subfloor.
 l If the camera is outside a room but inside the Terrain Perimeter, it is measured from the terrain at the location of the 

camera.         
 l If the camera is located in neither a room nor within the Terrain Perimeter, it is measured from the default height of 

the subfloor for the current floor. 

Once created, a camera’s height can be modified in its Camera Specification dialog, and the default height value can be set 
in the Camera Defaults dialog. See Camera Panel on page 801.

ALTERNATE RENDERING TECHNIQUE

With the exception of overviews, all camera views can be created by either left-click + dragging or right-click + dragging. 
See Alternate on page 139.

These two actions provide an efficient way to create a camera view using either the primary Rendering Technique or the 
Alternate Rendering Technique, respectively. See Rendering Techniques on page 832.

Both primary and Alternate Rendering Technique are set in the defaults dialog for the camera tool. See Camera Defaults 
Dialogs on page 772.

 

Creating Overviews
In Home Designer, there are three different overview types: Full, Doll House, and Framing Overviews.         

Each type of overview can be generated as either an orthographic or perspective view. An overview window’s title bar 
indicates whether it is perspective or orthographic. See Perspective and Orthographic Views on page 771.         
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Overviews generate as soon as you select the tool and are always created at the same 120° angle. The initial focal point is 
located at the center of the architectural model: the terrain is not taken into consideration determining its position. The 
distance of the camera from the model will vary depending on its size: the larger the architectural model, the further away 
the camera will be from the focal point so that the entire model can be seen in the view. 

A new overview camera can also be created by selecting an existing overview camera in plan view and then copying and 
pasting it. See Copying and Pasting Objects on page 118.

Once generated, an overview window’s title bar indicates its view type and a camera symbol in plan view represents its 
location. An overview camera can be edited much like regular camera views can. See Editing 3D Views on page 791.

FULL OVERVIEW

Select 3D> Create Orthographic View> Orthographic Full Overview or 3D> Create Perspective View> 
Perspective Full Overview to generate an exterior view of the entire model. 

DOLL HOUSE VIEW

Select 3D> Create Orthographic View> Orthographic Doll House View  or 3D> Create Perspective 
View> Perspective Doll House View to create a view of the current floor with the ceiling removed and all 

floors beneath it visible.

Doll House Views are an effective tool for illustrating traffic flow and the relationships between spaces.  

To see a different floor, select Tools> Floor/Reference Display> Up One Floor  or Down One Floor . You can also 

return to plan view and make another floor current before generating the Doll House View.

If you prefer, you can specify in the Camera Defaults dialog that only the current floor be included in Floor Overviews. See 
Camera Defaults Dialogs on page 772.           

FRAMING OVERVIEW

Select 3D> Create Orthographic View> Orthographic Framing Overview or 3D> Create Perspective  
View>  Perspective Framing Overview to create a view of the entire model, displaying only framing and the 

foundation. 
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Framing overviews include all floor, wall, and roof framing as well as foundations. Unlike other overviews, which use the 
Camera View layer set, Framing Overviews use the 3D Framing Set. See Layer Sets on page 128.

Framing must be built before generating this view or the view will be empty.           

 

Cross Section/Elevation Views
The cross section/elevation tools produce the traditional, orthogonal views often used in drafting. Regardless of their 
distance from the camera, all lines and dimensions in these views are their true lengths, making it easy to accurately see the 
spatial relationships of the 3D objects in the model.

Cross section/elevation views are the only 3D views that can be enhanced with the 2D CAD tools. They can be fully 
annotated and dimensioned, sent to layout, and printed to scale. See Detailing Cross Section/Elevation Views on page 782.

CREATING CROSS SECTION/ELEVATION VIEWS

Each of these tools has a specific function:

  A Cross Section/Elevation view displays all floors of the model. The cross section begins at the point where the 
camera arrow is drawn and continues through the entire model.    

  The Back Clipped Cross Section tool includes only the objects or portions of objects between the starting point 
and stopping point of the camera’s Line of Sight.    

  The Wall Elevation tool creates an interior elevation of a single wall defining the room that the camera is drawn 
in. It creates a 2D projection of that wall and the objects located between that wall and its Cross Section Line; 

does not cut through walls or show the ceiling, floor, or roof; and is used primarily for kitchen and bath elevations. 
Wall Elevations do not show framing objects, regardless of what layer they are on. This tool cannot be used to create 
exterior views.    

Cross Section/Elevation, Back Clipped Cross Section, and Wall Elevation views are created in the same way.   

To create a cross section/elevation view

 1.  Select the Cross Section/Elevation , Back Clipped Cross Section , or Wall Elevation tool. The pointer 

changes to a   with crosshairs marking the position of the pointer.

 2.  Click and drag a line in plan view.             

 l If you selected the Wall Elevation tool, you must click inside a room area.

 l A Camera symbol displays where you click, along with a Cross Section Line indicating the plane of the camera’s 
cross section cut line.                 
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A. Camera location (click)
B. Line of Sight (drag)
C. Focal Point (release)
D. Cross Section Line

 3.  Drag in the direction of the Line of Sight to draw a camera arrow.             

 l Always drag the camera arrow perpendicular to the wall to be viewed.                  

 l If the view is a Back Clipped Cross Section, a second Cross Section Line at the end of the Line of Sight indicates 
the furthest extent of the back clip.     

 4.  When you release the mouse button, the view generates in a new window.             

 5.  Once created, a cross section/elevation view's extents can be edited. See Camera Panel on page 810.

As with camera views, you must click and drag at least as far as your current Snap Distance in order to create a Cross 
Section/Elevation view. See Snap Properties Panel on page 82.          

A new cross section/elevation view can also be created by copying and pasting an existing cross section/elevation camera 
symbol selected in plan view. See Copying and Pasting Objects on page 118.

Once created, the clipping in all cross section/elevation views can be customized to control how much of the model is 
included in the view. See Camera Panel on page 810.    

If the Line of Sight does not cut through a 3D object and the object is within the back clipped distance, such as a window 
shown in elevation, the object retains its 3D definition and can be selected, moved, stretched, or otherwise modified in the 
view. The 3D model is updated in all views.         

 

Clipped Section Views
The Cross Section/Elevation Specification dialog has Scene Clipping options that allow you to control the extents of the 
view and thus how much of the model it shows. See Camera Panel on page 810.

In plan view, information about its front, back, and side clipping are indicated when a camera symbol is selected. In a 
clipped view, side and elevation clipping are indicated using Clip Lines on the "CAD, Clip Lines" layer. See Displaying 3D 
Views on page 783.

FRONT AND BACK CLIPPING

All cross section/elevation views have a clipping plane positioned at the same location as the camera and running 
perpendicular to its Line of Sight. This front clipping plane is also referred to as the Cross Section Line, and is shown in 
plan view when the camera's symbol is selected. If an object is positioned so that it is cut by this plane, its edges will be 
drawn but the object will not be selectable in the view. 

There are two ways to adjust the position of the front clipping plane:

 l Specify the camera's X and Y Position value in the Cross Section/Elevation Specification dialog.
 l Use the camera's edit handles in plan view to reposition the start point of its Line of Sight. 
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By default, Back Clipped Cross Section views also have a second clipping plane: the Back Clip plane, which controls how 
far into the model from the camera the view extends: objects located further from the camera than the Back Clip plane are 
not included in the view while those located between the front and back planes are. A Back Clip can be specified for any 
cross section/elevation view once it has been created. 

There are two ways to specify the distance between the front and back clipping planes:

 l Set a specific Back Clip After value in the Cross Section/Elevation Specification dialog.
 l Use the camera's edit handles in plan view to move the end of its Line of Sight, changing its length. 

SIDE CLIPPING

By default, cross section/elevation views include the entire width of the 3D model. You can instead choose to Clip Sides in 
the Cross Section/Elevation Specification dialog. There are three ways to specify a view's Clip Width:

 l Set a specific value in the Cross Section/Elevation Specification dialog.
 l Use the edit handles in plan view to change the length of the Cross Section Line, or front cutting plane. 
 l In the view itself, turn on the "CAD, Clip Lines" layer and adjust the position of the vertical Side Clip lines using the 

edit handles.

You can toggle side clipping in an active view by selecting 3D> Camera View Options> Clip Sides. This option is 
not available for views set to Clip to Room.

TOP AND BOTTOM CLIPPING

By default, cross section/elevation views include the entire height of the 3D model. You can instead choose to Clip 
Elevation in the Cross Section/Elevation Specification dialog. There are two ways to specify the top and bottom extents of a 
clipped view:

 l Set a specific Bottom and Top Clip Elevation values in the Cross Section/Elevation Specification dialog.
 l In the view itself, turn on the "CAD, Clip Lines" layer and adjust the position of the horizontal Elevation Clip lines 

using the edit handles.

When both Side and Top/Bottom Elevation clipping are in use, 
the Make Parallel/Perpendicular edit tools can be used to 

customize the horizontal top and bottom clipping planes. These tools do 
not affect the vertical side clipping planes, however. See Make 
Parallel/Perpendicular on page 171.

You can toggle elevation clipping in an active view by selecting 3D> Camera View Options> Clip Sides. Not 
available for views set to Clip to Room.

CLIP TO ROOM

The Clip to Room option in the Cross Section/Elevation Specification dialog is only available when a selected view camera 
is located inside a room. This option is the default for Wall Elevation views, and produces a view showing a single wall 
defining the camera's room along with any objects between the camera and that wall. When this setting is in use, the other 
clipping options are disabled.
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Detailing Cross Section/Elevation Views
CAD objects, including Text and Dimensions, can be created in cross section/elevation views. These objects are 
superimposed on the view and have no effect on the 3D model itself. If CAD objects have been added to a cross 

section/elevation view, the program will prompt you to save the view before closing the window. This information is then 
stored in the view. See View Windows on page 103.   

In cross section views, some objects, such as walls, may be represented using Cross Section lines. If a dimension line finds 
an object surface edge represented by a Cross Section line, a Point Marker will be placed at that location, and the dimension 
will locate it instead of the Cross Section line. See Markers on page 368.    

CAD objects will snap to the Snap Grid when Grid Snaps  are enabled. Note that the 3D model may obscure the display 

of the Snap Grid. See Grid Snaps on page 116.     

Annotated cross section/elevation views can      be sent to layout. See CAD and Text in Layout on page 972.   

DEPTH CUE

The Depth Cue tool allows you to add a partially transparent mask over part of a cross section/elevation view based 
on surfaces' distance from the camera. Surfaces nearer the camera are more prominent while those further are 

partially obscured.

Depth Cue creates the appearance of fog over 
surfaces in the distance.

To add Depth Cue to an active cross section/elevation view, select 3D> Camera View Options> Depth Cue .
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 l Check Use Depth Cue to apply this effect to the current view and enable the settings below.
 l When Keep Start/End in Sync is checked, the Start and End values are always the same, producing a sharp border 

where the fog begins. Uncheck this to produce variation in the level of fog transparency.
 l Specify the Start and End distances from the camera between which the Depth Cue opacity is applied.
 l Specify the Fog Opacity, which controls how opaque or transparent the cue is. 0% is totally transparent while 100% 

cannot be seen through at all.
 l The Fog Color displays in the Color button. Click this button to choose a different color if you wish. See Select Color 

Dialog on page 135.

Depth Cue does not affect appearance of text, dimensions, or CAD objects drawn in the view.

 

Displaying 3D Views
A variety of tools and settings allow you to control the appearance of 3D views. There are also numerous ways to adjust a 
3D view’s position, focal point and field of view. See Editing 3D Views on page 791.

The name of the current plan file and the type of view displays at the top of each view window in its title bar. If a 3D view 
is saved, its name also displays. 

There is no limit to the number of 3D view windows that you can have open at a given time; bear in mind, though, that each 
window demands use of your computer’s resources and that you may see poor performance if too many views are open. See 
Working in Multiple Views on page 105.

The 3D model will rebuild automatically as you draw; however, if you notice any anomalies in the model in 3D, 
select 3D> Rebuild 3D to regenerate all 3D data associated with the current plan. All open views will remain open.

LAYER DISPLAY OPTIONS

As in plan view, the display of objects in 3D views can be controlled by layer. See Layer Display Options Dialog on page 
127.

Different view types use different layer sets when they are created. See Layer Sets on page 128.

To show framing in a cross section/elevation view, framing must first be built using the Build Framing dialog and the 
appropriate framing layers must be turned on in the Section View layer set. See Framing on page 626. 

To show a view's Clip Lines, turn on the "CAD, Clip Lines" layer in that view. See Clipped Section Views on page 780.         

IN PLAN VIEW

Cameras are represented in plan view by symbols that indicate the camera’s position, field of view and focal point.
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2D camera symbols are located on the “Cameras” layer               See Layers on page 124.

By default, active camera symbols display regardless of whether the “Cameras” layer is on or off. If you prefer that their 
display be turned on or off with this layer, uncheck Always Display Active Cameras in the 3D View Defaults dialog. See 
3D View Defaults Dialog on page 774.           

Active camera symbols and callouts use the Selection Line color set in the Preferences dialog. All other display attributes 
are derived from the “Cameras” layer. See Colors Panel on page 65.          

You can also display camera symbols for saved cameras when the “Cameras” layer is turned on. See Layers on page 124.         

The symbols for Full Overviews, Cross Section/Elevation, and Back Clipped Cross Section views display on all floors, 
while those for Full Cameras, Floor Overviews, and Wall Elevations display only on the floor where they were created.

You can also move a camera to a different floor by clicking the Up One Floor  or Down One Floor  button while 

the camera view is active. Note that this may affect what is seen in the view as well as its display in plan view. See Floor 
Up / Floor Down on page 524. 

Both saved and unsaved active cameras can have labels indicating the camera number or its name. Camera labels are located 
on the “Cameras, Labels” layer. See Label Panel on page 376. 

Camera labels are numbered sequentially in each plan in the order they were created unless you rename them. 

 l Camera labels always use the Camera Name. Saved cameras’ names can be specified in the Camera Specification 
dialogs. See Camera Panel on page 801.             

Camera symbols are an on-screen reference: they do not print unless Print Image is used and cannot be sent to layout 
except as an image. They are, however, included in views exported to .dxf

IN RENDERED VIEWS

There are a number of factors that contribute to the appearance of rendered 3D views:

 l Select View> Color  to toggle between color and grayscale in 3D views. See Color On/Off on page 130. 

 l Select 3D> Rendering Technique to select a technique to apply to the current view. See Rendering Techniques on 
page 832.

 l Select 3D> Lighting> Adjust Lights  to open the Adjust Lights dialog and edit the light sources in the current 

plan. See Adjust Lights Dialog on page 822.             

Several other factors can contribute to the overall quality of a rendered 3D view. See Rendering Tips on page 815.         

IN VECTOR VIEWS

There are also a number of factors that affect the appearance of 3D Vector Views:         
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 l Select 3D> Toggle Patterns  in a Technical Illustration or Vector View to turn on or off the display of the 

“Patterns, 3D Views” layer, which controls the display of material pattern lines. See Layers on page 124.         
 l Select View> Color  to toggle between color and black and white to control the display line and fill colors.         

 l The line style, color, and weight of objects in Vector Views can be specified by layer or, for some objects, individually 
in their specification dialogs. See Line Style Panel on page 209.         

 l The line weight, color, and style of material patterns are set in the Define Material dialog. See Define Material Dialog 
on page 760.             

 l Line weights display on screen when Show Line Weights  is enabled. See Line Weights on page 992.         

3D BACKDROPS

A backdrop is an image, usually of an exterior view, that displays in the background of 3D views to help place the model 
into a realistic setting and add a sense of perspective. If a backdrop is not specified, Home Designer applies a background 
color. See 3D Backdrops on page 841.         

RENDERING TECHNIQUES

Any 3D view can be assigned a Rendering Technique for a range of different purposes: from detail drawings to 
artistic presentation views. Select 3D> Rendering Techniques to access these tools. See Rendering Techniques on 

page 832.          

DELETE 3D SURFACE

The individual surfaces that make up objects can be temporarily removed from any 3D view by selecting 3D> Delete 
Surface and then clicking on a surface. When the pointer is over a surface, that surface will become highlighted.

Surfaces removed in one view are removed in all 3D views, but are not permanently removed from the model. Continue 
clicking surfaces to remove them, then select another tool when you are finished.

Surfaces in 3D views are composed of multiple triangles. Hold the Alt key while clicking to delete one triangular face at a 
time rather than all triangles forming a  surface. 

To restore the most recently deleted surface, select 3D> Delete Surface  or click the toolbar button. 

There are several ways to restore all deleted surfaces:

 l Select Build> Floor> Rebuild Walls/Floors/Ceilings .

 l Exit the 3D view and reopen it.
 l Create a new 3D view. 

 

Navigating in Camera Views
Once a 3D view is created, there are many ways to manipulate the camera location and the direction of its line of site using 
the mouse, the keyboard, and the menus. 

The Move Camera with Mouse buttons are included on the toolbars  in 3D views by default; but, you can add the other tools 
your toolbars as well as customize their hotkeys. See Toolbars and Hotkeys on page 90.          
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When the keyboard, toolbar buttons, or menu commands are used to move or rotate a camera, the adjustments occur in 
regular increments. The size of these increments is specified in the Camera Specification dialog: 

 l The Incremental Move Distance controls Panning movement and forward and backward Dolly movement. 
 l The Incremental Rotate Angle controls Orbit movement, Tilt movement, and side to side Dolly movement.

See              Camera Panel on page 801.

Each time you move the camera, the view is updated. If you are using either the toolbar or keyboard to move the camera,  
you can hold down the Shift  key, suppressing the redraw of the view until the Shift  key is released and allowing you to 
move multiple increments more quickly. 

Press the Ctrl/⌘  + Alt + S keys while in a camera view or 
overview to spin the view. To stop the spinning, press the Esc 

key.

You can also move a camera to a different floor by clicking the Up One Floor  or Down One Floor  button while 

the camera view is active. Note that this may affect what is seen in the view as well as its display in plan view. See Floor 
Up / Floor Down on page 524. 

MOUSE SCROLL WHEEL AND TRACKPAD

3D views can be panned and zoomed when any tool is active using the mouse scroll wheel or trackpad gestures. See 
Trackpads on page 14.

The program adjusts the speed of these actions depending on characteristics of the camera: 

 l Zoom speed depends on how close the camera is to the object located behind the mouse pointer. When the target 
object is far from the camera, zooming is faster; as the camera gets closer to the target, zooming slows. 

 l Panning speed depends on the length of the camera’s Line of Sight. In general, it is likely to be faster in an exterior 
view of a large model, slower in an interior view of a small room. See Creating Camera Views on page 776.

By default, panning and zooming adjusts the position and direction of the camera. It does not, however, adjust the distances 
at which surfaces are clipped. This means that if you zoom in closely on an object, some of its surfaces may be removed 
from the view. One way to avoid this is to lower the camera’s Clip Surfaces Within value in the Camera Specification 
dialog. See Camera Panel on page 801.   

3DCONNEXION® 3D MICE

3Dconnexion®'s 3D mice can be used to navigate in all views - including camera views and overviews.

In the Windows version of Home Designer, preprogrammed view direction hotkeys are supported on devices with buttons 
for that purpose. MacOS™ does not provide mapping support to the view direction commands.

In Orthographic views, navigation is centered around the camera’s focal point; for Perspective views, you can specify 
whether navigation is centered about the camera or its focal point in the Preferences dialog. See Render Panel on page 86.

For best results when using a 3D mouse, uncheck Turn Automatically when Camera Bumps Off Walls is enabled. See 
3D View Defaults Dialog on page 774.          

Rolling is not supported in Home Designer, In addition, 3D mice cannot be used to move the mouse pointer. For details 
about using your 3D Connexion® mouse, refer to its documentation.
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GAMEPADS

In the Windows version of Home Designer, gamepads can be used to navigate in camera views, overviews, and 
elevation views. To use a gamepad in Home Designer, Select Tools> Toolbars and Hotkeys> Gamepad Settings, 

then check Enable Gamepad in the Gamepad Settings dialog. You can also adjust the sensitivity and other aspects of 
thumbstick functionality when used in Home Designer. See Gamepad Settings Dialog on page 100.

You can also specify whether navigation is centered about the location of the camera or its focal point in the Preferences 
dialog. See Render Panel on page 86.         

You can add the Gamepad Settings and Toggle 3D Mouse and 
Gamepad Navigation buttons to your toolbars if you wish. See 

To add a button to a toolbar on page 93.

MOVE CAMERA WITH MOUSE

An active camera’s position can be edited using the mouse. Select 3D> Move Camera With Mouse to access the 
Move Camera with Mouse modes, select a mode, and use the left mouse button for the primary behavior or the right 

mouse button for the secondary behavior. With the exception of Mouse Orbit Camera, which is available in Orthographic 
Overviews, these tools are not available in Orthographic views.

Tool
Primary Behavior

(Left-Click)

Alternate 
Behavior

(Right-Click)

Mouse-Orbit 
Camera

Left-click and drag to rotate the camera around its 
focal point. The camera’s position and direction both 
change.

You can temporarily activate Mouse-Tilt Camera by 
using the right mouse button while the Mouse-Pan 
Camera or Mouse-Tilt Camera mode is active.

To continuously rotate the camera around its focal 
point, left-click in the 3D view, drag the mouse, and 
release the mouse button to “throw” the view. Click 
again in the view to stop it from rotating. 

Right-click and 
drag to tilt the 
camera instead 
of orbiting.

In the Mac version of the software, you can 
temporarily activate Mouse-Orbit Camera while 
another tool is active: hold down the Option + Shift 
keys, then left-click and drag. When the mouse button 
and keys are released, the previously active tool will 
again be active. 

Mouse-Pan 
Camera

Left-click and drag to move the camera in any 
direction. The camera’s position changes, but its 
direction does not.

Right-click and 
drag to orbit 
instead of 
panning.
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Tool
Primary Behavior

(Left-Click)

Alternate 
Behavior

(Right-Click)

Mouse-Dolly 
Camera

Left-click and drag up and down to move  the camera 
forward and backward or drag left or right to rotate 
the camera side to side.

Right-click and 
drag to tilt the 
camera instead 
of dollying.

Mouse-Tilt 
Camera

Left-click and drag in any direction to tilt the camera, 
changing its view direction but not its position.

You can temporarily activate Mouse-Tilt Camera by 
using the right mouse button while the Mouse-Orbit 
Camera or Mouse-Dolly Camera mode is active.

Right-click to 
orbit instead of 
tilting.

3D Center 
Camera on 

Point

Lets you focus the camera at a particular point in the 
scene. This changes the camera’s direction and focal 
point, but not its position.

To use this tool, activate it and then click on any 
object in the scene.

N/A

3D Focus on 
Object

Lets you focus on a specific object by changing the 
camera’s position, direction, focal point, and the 
length of its line of sight.

To use this tool, activate it and then click on an object 
in the scene. Alternatively, select an object in the view 
and click the Focus on Selected edit button.

N/A

MOVE CAMERA WITH KEYBOARD

An active camera’s position can be changed using the Arrow keys on your keyboard. Select 3D> Move Camera with 
Keyboard to access the Move Camera with Keyboard modes. With the exception of Mouse Orbit Camera, which is 
available in Orthographic Overviews, these modes are not available in Orthographic views.

These modes use the Incremental Move Distance and Incremental Rotate Angle set in the active 3D view’s Camera 
Specification dialog. 

 l Keyboard-Orbit Camera lets you use the keyboard to rotate the camera around the focal point. The camera’s position 
and direction both change.

 l Keyboard-Pan Camera lets you move the camera up, down, right, and left using the keyboard. The camera’s position 
changes, but its direction does not.

 l Keyboard-Dolly Camera lets you move the camera forward and back using the Up and Down Arrow keys, and rotate 
side to side using the Left and Right keys. 

 l Keyboard-Tilt Camera lets you use the Arrow keys to tilt the camera up, down, or side to side to change the focal 
point. The camera’s direction changes, but its position does not. 

MOVE CAMERA TOOLS

Select 3D> Move Camera in a 3D view to access these tools. These tools change the active camera’s position but 
not its direction, and are not available in  Orthographic views. 
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The Move Camera Forward and Move Camera Back tools allow 
you to "walk" up and down stairs when Camera Bumps Off 

Walls is checked. See 3D View Defaults Dialog on page 774.

These tools use the Incremental Move Distance set in the active 3D view’s Camera Specification dialog. 

 Description

Move Camera Forward moves the camera and its focal point 
forward. 

Move Camera Back moves the camera and the focal point 
back. 

Move Camera Left moves the camera and the focal point to 
the left in a line perpendicular to the line of sight. 

Move Camera Right moves the camera and the focal point to 
the right in a line perpendicular to the line of sight. 

Move Camera Up moves the camera and the focal point up. 

Move Camera Down moves the camera and the focal point 
down. 

ORBIT CAMERA TOOLS

Select 3D> Orbit Camera in a 3D view to access these tools. Orbiting the camera rotates it about the focal point 
using the Incremental Rotate Angle set in the active view’s Camera Specification dialog. 

These tools are not available in Cross Section/Elevation, Back Clipped Cross Section, or Wall Elevation Defaults views.

 Description

Move Camera In moves the camera closer to the focal point 
along the line of sight. The camera cannot move past the focal 
point using this tool.

Move Camera Out moves the camera away from the focal 
point along the line of sight. 

Orbit Camera Upward rotates the camera up about the focal 
point. The camera cannot rotate past a vertical line looking 
straight down on the focal point.

Orbit Camera Downward rotates the camera down about the 
focal point. The camera cannot rotate past a vertical line 
looking straight up at the focal point.

Orbit Camera Left rotates the camera to the left about the 
focal point.

Orbit Camera Right rotates the camera to the right about the 
focal point. 
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TILT CAMERA TOOLS

Select 3D> Tilt Camera to access these tools. Tilting keeps the camera in one place and pivots the camera about its 
vertical or horizontal axis. This movement uses the Incremental Rotate Angle set in the active view’s Camera 

Specification dialog and is similar to tilting your head up and down or turning it side-to-side. 

These tools are not available in              Orthographic views.         

 Description

Tilt Camera Upward tilts the camera up while keeping it in 
the same location. The camera cannot tilt beyond the vertical 
position.

Tilt Camera Downward tilts the camera down while keeping 
it in the same location. The camera cannot tilt beyond the 
vertical position.

Turn Camera Left turns the camera to the left while staying 
in the same location.

Turn Camera Right turns the camera to the right while 
staying in the same location.

VIEW DIRECTION TOOLS

The View Direction Tools allow you to view the model from a specific direction in a camera view or overview. 
While one of these views is active, select 3D> View Direction to access these tools.         

 Description

Front View creates a front view of the model.

Back View creates a back view of the model.

Top View creates a top view of the model.

Bottom View creates a bottom view of the model.

Left Side View create a left side view of the model.

Right Side View create a right side view of the model.

Restore Original View restores the original view position. 
This option is also available for material previews in the 
Library Browser and Define Material dialogs.
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Editing 3D Views
In addition to its position and direction, there are other ways to modify a 3D view.

If you make changes to an open camera view that was saved previously, you will be prompted to resave the view when you 
close it.

IN THE SPECIFICATION DIALOG

You can  make adjustments to a camera in its specification dialog. This dialog is particularly helpful for making fine 
adjustments to the camera’s position, appearance, and other attributes. See Camera Specification Dialogs on page 

801 and Cross Section/Elevation Specification Dialogs on page 809.

Tile a 3D view and plan view and use the camera movement 
tools to see how they affect the camera. See Tiling Views on 

page 105.

USING THE EDIT TOOLS

A camera symbol or symbols selected in plan view can be edited in a variety of ways using the buttons on the Edit Toolbar. 
See The Edit Toolbar on page 92.

USING THE EDIT HANDLES

Return to plan view without closing the 3D view. See Working in Multiple Views on page 105.   

Using the Select Objects  tool, select the camera object. When a camera symbol is selected, it displays four edit handles. 

 l Drag the Line of Sight handle to change the camera angle without moving the focal point.
 l Drag the Move handle to relocate the camera while maintaining its relative angle.
 l Drag the Focal Point handle to reposition the focal point and change the line of sight without moving the camera.
 l Drag the Rotate handle to rotate the camera’s line of sight about its center.

The 3D view corresponding to the camera symbol reflects changes made to the symbol in plan view. 

Multiple camera symbols can be selected; however, their editing options are limited to being moved, rotated, and deleted. 

USING THE CONTEXTUAL MENU

In a 3D view, right-click in an empty space in which the backdrop or background color displays to access the contextual 
menu. See Contextual Menus on page 18. 
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 l In Vector Views, the options are a selection of commonly used commands from the File, Edit, Tools and Window 
menus.         

 l In the other Rendering Techniques, the options are a selection of tools and toggles specific to the current view.

UP ONE FLOOR/DOWN ONE FLOOR

You can move a camera to a different floor. While the camera view is active, select Tools> Floor/Reference 
Display> Up One Floor  or Down One Floor. Note that this may affect what is seen in the view as well as its 

display in plan view. See In Plan View on page 783.

The position and movement of a camera is affected by its location within the model. When the camera is outside a building, 
its height is relative to the terrain and follows the terrain as it is moved. When inside a building, the camera height is 
relative to the floor of the room it is drawn in.

If the camera is on an upper floor and you move the camera outside the building, the camera remains at the same height 
relative to the floor it was created on.

ZOOMING

The Zoom Tools are available in all 3D views. See Zoom Tools on page 108.   

Selecting Window> Zoom In , Zoom Out  or Fill Window  does not change the camera’s location or field of 

view. Instead, the extents of the view are expanded or cropped. 

If you wish, you can instead set the Zoom  tools to change the  Field of View when used in a 3D view. See Render 

Panel on page 86.         

FIELD OF VIEW

The Field of View refers to a camera’s field of vision. A wider field of view makes the focal point appear further away, as 
more of the image is included in the same view window.

In plan view, the angled lines of a camera symbol indicate its field of view.

A camera’s field of view can be adjusted in the Camera Specification dialog. See Camera Panel on page 801.
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RESET SAVED CAMERA

If you open a saved camera, overview, or cross section/elevation view and then change the position, direction, or any other 
attribute of the view, you will be prompted to either restore the original attributes or save the current settings when you 
close the view. See Saving 3D Views on page 800.

You can also restore its original attributes at any time prior to closing the view using the Reset Saved Camera tools. Select 
3D> Camera View Options to access these tools.

  Reset Saved Camera (All) resets all changes made to the attributes of the current view.

  Reset Saved Camera (Position) resets changes to the camera's position and orientation but leaves other 
attributes as they are.

 

Cross Section Slider
Select 3D> Camera View Options> Cross Section Slider when a camera view or overview is active to open the 
Cross Section Slider dialog. 

To use the Cross Section Slider

 1.  Check the box beside a cross section cutting plane to select it and make its Position slider and text box active.

 2.  Move the Position slider to adjust the position of the cutting plane. 

 l The cutting plane Position is measured from the edge of the model that is cut first by the selected cutting plane.

 l Position the Cutting Plane with accuracy using the text field to the right of the slider. 

 3.  Repeat steps 1-3 to use additional cutting planes if you wish. 

 4.  Click OK to close the dialog. If the active camera is saved, its Cross Section Slider settings will also be retained. See 
Saving 3D Views on page 800. 

Note: Effects created by the Cross Section Slider are not included in 
Vector Views sent to layout using Plot Lines. See Plot Line Views on 
page 977. 
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Working in 3D
A variety of tools are available in 3D views that allow you to edit your 3D model as well as annotate it.

ANNOTATING CROSS SECTION/ELEVATION VIEWS

The Text, CAD, and a selection of Dimension tools are available in cross section/elevation views, allowing you to add 
technical information, call attention to details, and other tasks in these views. See Detailing Cross Section/Elevation Views 
on page 782. 

CREATING OBJECTS IN 3D VIEWS

You can place windows, doors, cabinets, electrical objects, corner trim, and most library objects directly into 3D views. To 
do this, select the appropriate tool and click in the 3D view. You can then edit the object’s size and placement.          

When created in 3D, most objects must be placed against a wall, on a floor platform, or within the Terrain Perimeter.         

You can also click and drag to draw some CAD-based objects such as              custom countertops, roof planes,              terrain features and 
roads in camera views and overviews.          

The Build Framing and Build Roof dialogs are also accessible in 3D views, although the manual Framing Tools  and 

Roof Tools  are not.           

SELECTING AND EDITING OBJECTS IN 3D VIEWS

Most objects can be selected and edited in 3D views. Select Edit> Select Objects  and click on the surface of an object 

to select it. Once selected, objects can be edited using their edit handles, buttons on the Edit Toolbar, and the object’s 
specification dialog. See Editing Objects on page 137.         

When you select an object, edit handles and a handle surface display. The handle surface is a rectangle around the perimeter 
of the object that indicates the overall height and width of the selected surface. The edit handles that display depend on the 
type of object selected. Walls, for example, display two resize edit handles when selected while the top of a cabinet displays 
ten handles, allowing you to move, resize and reshape it.         

Note: If the wall height of the Exterior Room is adjusted in a 3D view, 
the default Floor or Ceiling Height of the entire floor is changed. See 
Floor and Room Defaults on page 287.

All moving or resizing is in the plane of the handle surface. You cannot  move an object directly towards or away from the 
camera, for example, because that surface plane cannot be seen in the view.          

By default, object movement is restricted to 1 inch (10 mm) increments, but this restriction can be set to custom increments 
in the Plan Defaults dialog and toggled off and on by selecting Edit> Snap Settings> Grid Snaps . See Grid Snaps on 

page 116.         

Unrestricted positioning can also be enabled by holding down the Ctrl/⌘  key while moving or resizing an object. See 
Unrestricted Movement on page 168.          

Temporary dimension lines display when many objects are selected to help you resize the object and determine its height. 
These are sometimes easier to see when the color is toggled off. See Temporary Dimensions on page 333.
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Because cross section/elevation views are orthogonal and display objects at their actual dimensions, they are sometimes 
more suitable for editing objects than camera views or overviews. See Cross Section/Elevation Views on page 779.         

When several 3D views are open, changes made in the plan automatically rebuild the model in all views.  Because of this, it 
is typically faster to make changes to your plan with as few windows open as possible.         

EDITING MATERIALS IN 3D VIEWS

  Select 3D> Materials> Adjust Material Definition, then click on a surface in the 3D view to open the Define 
Material dialog for that material. See Adjust Material Definition on page 753.         

  Select 3D> Material Painter to apply materials to surfaces in the view using the Material Painter Tools. See 
Material Painter Tools on page 747.         

  Select 3D> Material Painter> Material Eyedropper to apply the material on a surface in the view to other 
surfaces in the view. See Material Eyedropper on page 748.          

CROSS SECTION LINES

Cross Section Lines are created in cross section views to represent any objects split by the cross section line of the camera. 
They are placed on the “Cross Section Lines” layer, which is locked by default, and they get deleted and replaced whenever 
the view is redrawn.          

When a dimension is drawn to locate an object split by a camera’s section line, it actually locates Cross Section Lines. So 
that dimensions can be retained when Cross Section Lines are regenerated, a Point Marker  is automatically created 

where a dimension meets a Cross Section Line and the dimension locates it instead of the Cross Section Line. See Point 
Markers and Dimensions on page 369.           

Cross Section Lines will print when their layer is turned on; however, they are not included when the view is sent to layout. 
The Point Markers created when dimensions locate Cross Section Lines, however, will both print and display in views sent 
to layout. See Layout on page 970.          

The “Cross Section Lines” layer can be unlocked, allowing Cross Section Lines to be selected and edited. Additional CAD 
objects can also be placed on this layer when it is unlocked, as well; however, when the view is redrawn, all CAD objects 
on this layer will be deleted and replaced with a fresh set of Cross Section Lines.           

REBUILD 3D

As changes are made to your plan, a 3D view automatically updates to reflect any changes visible in the view. If you 
find that a view is not updating as expected, select 3D> Rebuild 3D to rebuild the entire 3D model.  

 

Virtual Reality
The Virtual Reality option  is available in the Windows version of Home Designer and allows you to view a plan in 
3D using a VR headset. To view a model in VR, select 3D> Virtual Reality while a Perspective camera view or 

overview is active. 

SYSTEM REQUIREMENTS

The following virtual reality headset models are supported for use in Home Designer:          
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 l Oculus: Rift, Rift S, Quest (using Link Cable), Quest 2 (using Link Cable)     
 l HTC: Vive, Vive Pro, Vive Pro 2, Vive Cosmos, Vive Cosmos Elite, Vive XR Elite with a Vive Streaming Cable
 l Valve Index         
 l Microsoft Mixed Reality          

In order to run Virtual Reality in Home Designer, your computer should meet not only the program’s system requirements 
but also the system recommendations provided by your VR headset manufacturer.         

In addition, you must first install Steam, a game and software distribution program available at store.steampowered.com.           

Once it has been installed, you must also run the SteamVR Setup so that your headset runs through the Steam software. The 
setup will walk you through setting up the VR sensors in a clear area, free from obstructions, where you can walk and move 
around.          

Virtual Reality can only be activated while viewing an active Perspective View using either the Standard or Physically 
Based Rendering Technique. If Hand Drawn Lines on Top or GPU Ray Tracing is in use in the current view, it will be 
ignored in VR. See Rendering Techniques on page 832.           

SAFETY CONSIDERATIONS

Virtual Reality should only be run in a space free of obstructions that could cause injury.           

To avoid slow performance that could result in motion sickness, turn off any other CPU and GPU intensive applications on 
your system before launching Virtual Reality. Particularly if your system has a high resolution display, use FSR in the 
current camera view to improve performance prior to launching Virtual Reality. You can also use FSR on systems with a 
regular monitor; however, you may notice decreased rendering quality. See AMD FidelityFX on page 815.       

In addition, these settings are recommended in the current camera view prior to launching Virtual Reality:          

 l Turn Reflections off.          
 l Turn on a minimal number of lights and shadows. 

See Lighting on page 817 and Camera Specification Dialogs on page 801.          

Just like in a Home Designer camera view, it is possible to navigate through objects in the model when in Virtual Reality, 
like walls and furniture. To avoid disorientation or motion sickness, you should avoid doing so.          

To avoid motion sickness while using virtual reality, gamepad style controllers are not supported. You can, however, walk 
within the area designated during your Steam VR Setup. To navigate to different  locations in the model, you can also 
teleport as well as switch between Room View and Overview modes.          

ROOM VIEW AND OVERVIEW MODES

Home Designer has two Virtual Reality modes:          

 l In a Room View, you can navigate a model by looking around, walking, and teleporting. Room View is active when 
you enter VR from a Perspective Camera view.          

 l In an Overview you can move and rotate the model in order to examine its exterior. Overview mode is active when 
you enter VR from a Perspective Overview.          

Note: For best results, use the Full Camera tool for Room Views rather 
than Floor Camera. See 3D View Tools on page 775.

In both modes, your initial position and orientation in Virtual Reality are based on the position and angle of the camera. As 
you turn your head or walk, the view seen in the VR headset will update to reflect your movements. The original camera in 
Home Designer will be unaffected, however.          
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Once you enter Virtual Reality, you can switch between the two modes:          

 l To transition from Room View to Overview, point either VR controller straight up until the Teleport Line changes to a 
short gray line. Press and hold the Transition button on your VR controller until the line changes entirely to the Mode 
Transition Color and the controller vibrates, then release the button. See Virtual Reality Dialog on page 798, below.          

 l To transition from Overview to Room View, point either VR controller toward a valid surface on the model. Press and 
hold the Transition button until the line changes entirely to the Mode Transition Color and the controller vibrates, then 
release the button.          

NAVIGATING ROOM VIEWS

In a Room View, you can explore a model by looking around, walking in your predefined VR space, and teleporting.           

To teleport to other locations within the model, press and hold the Trigger on your VR controller while aiming at a suitably 
flat surface. A Teleport Marker will appear at the location that you point at, and releasing the Trigger will teleport you to 
that location.           

In Room View, the VR controller projects a Teleport Line that indicates whether a targeted surface is a valid location to 
teleport to. A valid surface is defined as any surface that has less than 45° pitch, however if a valid surface exists less than 
12” below an invalid target location, it will show as valid and the teleport marker will be placed next to the targeted surface. 
This allows you to easily teleport next to an otherwise invalid surface, such as a wall or cabinet.          

To cancel a teleport action, aim the Teleport Line at an invalid location. When the line changes color and the Teleport 
Marker disappears, release the Trigger.           

In Room View, a number of navigation actions can be completed using your VR controller. These controls are the same on 
both right and left controllers, but specific functions differ slightly depending on the VR controller used.          

Command HTC Vive/Microsoft Oculus Rift

Teleport Trigger

Undo Trackpad Left Thumbstick Left + Click

Redo Trackpad Right Thumbstick Right + Click

Reset Menu Button Thumbstick Up + Click

Transition Trackpad Down X or A Button

Update Lighting Trackpad Upper Click Y or B Button

NAVIGATING OVERVIEWS

In Overview mode, you can examine and model by moving and rotating it in front of you as if holding a scaled version of 
the model.          

In this mode, the Grip buttons on your VR controller allow you to “grab” and rotate the model. Using the Grip buttons on 
both VR controllers simultaneously gives a more natural rotation, as if grabbing and rotating the entire model.          

Pressing and holding the Trigger allows you to drag the model in any direction: up, down, left, right, towards you, and away 
from you.           

Pressing the Triggers while holding the Grips on both controllers simultaneously allows you to zoom in and out. Moving 
your hands apart will zoom in to the model, moving them closer together will zoom out.          

In Overview mode, a number of actions can be completed using your VR controller. These controls are the same on both 
right and left controllers, but specific functions differ slightly depending on the VR controller used.          
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Command HTC Vive/Microsoft Oculus Rift

Rotate Grip

Drag Trigger

Zoom Grip + Trigger

Undo Trackpad Left Thumbstick Left + Click

Redo Trackpad Right Thumbstick Right + Click

Reset Menu Button Thumbstick Click

Transition Trackpad Down X or A Button

Update Lighting Trackpad Upper Click  

VIRTUAL REALITY DIALOG

To view a model in VR, select 3D> Virtual Reality  while a Perspective Camera view or Overview is active. The 

Virtual Reality dialog will open. 

Note: Neither Hand Drawn Lines on Top nor GPU Ray Tracing are 
supported in VR.

 
VR Status

The current Virtual Reality Status is stated at the top of the dialog, along with information about graphics card or chipset 
being used on the computer.                 

 l Click the Toggle Virtual Reality button to turn Virtual Reality on or off.          
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OpenGL Information

Information about your graphics card is displayed here for reference. Visit HomeDesignerSoftware.com for information 
about system requirements.              

  Options

 l Validity of a surface is indicated by the color of the teleport line. The Valid Teleport Line and Invalid Teleport 
Line Colors can be set here.          

 l The teleport line will display the Mode Transition Color when switching between Room View and Overview 
Modes. This color can also be set here.          

 l When Virtual Reality is active, the program window shows what the user sees in the VR headset. By default, both 
eyes’ views are shown in a split screen. If you would prefer to see only the left eye’s view, uncheck Display Both 
Eyes On Screen in the Virtual Reality dialog.           

 l When Update Lighting on Teleport is checked, the lighting in the model will update when you teleport more than 
10 feet (3 m) to ensure that your destination has lighting. Uncheck this is you prefer to only update lighting manually 
using the controller.          

 
Room View

Specify how the teleport feature works in Room View Mode.                 

 l Use Curved Teleport Line changes the teleport line from a straight line to a curved arc. This is checked by default 
for Room Views.           

 l The Teleport Reference Height setting determines how the camera height is calculated when the teleport feature is 
used.          

 l When Floor Under Marker is selected, the new camera position will calculate its height based on the floor surface, 
or the floor directly beneath where the teleport marker lands if locating a raised surface such as a countertop or table. 
This may result in being teleported inside furniture or other objects.          

 l When Surface at Marker is selected, the new camera location will determine its height from the surface where the 
marker landed. This will place the camera on top of objects such as furniture and may result in the view being in or 
above the ceiling.          

 
Overview

Specify how the teleport feature works in Overview Mode.                 

 l Use Curved Teleport Line changes the teleport line from a straight line to a curved arc. This is unchecked by 
default for Overviews.          

 l Lock X-Axis Rotation prevents the model from being tilted vertically.          

 l Lock Y-Axis Rotation prevents the model from being rolled left to right.           

 l Lock Z-Axis Rotation prevents the model from being spun horizontally.           

When Virtual Reality is active, neither the camera nor the model can be edited in any way. If you wish to make 
modifications, you must Toggle Virtual Reality off in the Virtual Reality dialog, make the necessary adjustments, and then 
enter Virtual Reality again.           
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Saving and Printing 3D Views
3D camera views, overviews, and cross section/elevation views can be saved with the plan in which they are created, 
exported and saved as image files, as well as sent to layout and printed. 

SAVING 3D VIEWS

Select 3D> Save Active Camera to save the current camera in the plan. You can also save a camera view by 
checking the Saved box in the Camera Specification dialog. See Camera Specification Dialogs on page 801.          

Saved cameras can be closed and re-opened for later use, and retain their attributes including Cross Section Slider, Sunlight, 
Shadows, and Rendering Technique settings. If you make any changes to these attributes while a saved camera view is 
active and then close the view, you will be prompted to save your changes. See Cross Section Slider on page 793, Adjust 
Sunlight Dialog on page 830, Shadows on page 815, and Rendering Techniques on page 832.

In addition, if Dimensions, CAD, and/or Text objects are drawn in a cross section/elevation view, you will be prompted to 
save the view when you close it. Any  Dimensions, CAD, and/or Text objects added to a cross section/elevation view are 
saved with the view as part of the plan file.

ACTIVATING SAVED VIEWS

There are several ways to open a saved 3D view:          

 l Select the camera symbol in plan view and click the Open View  edit button.

 l Right-click on the camera symbol in plan view and select Open View  from the contextual menu.         

 l Double-click the camera symbol using the Select Objects  tool.

Unsaved cameras that are open in another view window can also be activated using the Open View  edit button.         

If you open a saved camera view and then modify its location or direction using any of the tools available in that view, the 
program will confirm whether you want to re-save the camera using these new settings when you close it. See Navigating in 
Camera Views on page 785.         

EXPORTING 3D VIEWS

All 3D views can be exported and saved as .bmp, .jpg, .png, or .tif files. Physically Based renderings can also be 
exported as .hdr files. Select File> Export> Picture to save the current screen image as an image file. See To export 

a picture on page 852.

In addition, Vector Views can be exported and saved as .emf files. See Metafiles on page 856.         

Once saved, a picture can be opened and converted into many other formats using a graphics program. Picture files can be 
sent to layout or used in word processing, desktop publishing, and web development programs to create advertisements, 
brochures, etc.

PLAN BACKUP

When transferring a plan to another computer or to another user, it is helpful to include all the Images, Textures, and 
Backdrops used in the plan so that rendered views are complete. The Backup Entire Plan tool allows you to do so. 

See Backup Entire Plan or Layout on page 46.         
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PRINTING 3D VIEWS

Since all 3D views other than Vector Views are created using pixels instead of lines, File> Print> Print Image must 
be used when printing. Print Image is a special Home Designer function that prints the screen in picture format. The 

entire view prints, including images such as plants and textures. 

3D views can also be sent to layout and then printed as part of your construction documents.          

  Select File> Send to Layout to send the current view to layout. See Sending Views to Layout on page 973.

  Select a saved, inactive camera symbol in plan view and click the Send Camera’s View to Layout edit button to 
send the view to layout.         

CLOSING 3D VIEWS

Although you can have any number of 3D views open at a time, to conserve resources on your computer it is a good idea to 
close views when you no longer need them. There are a number of different ways to do this. See Closing Views and Files on 
page 110. 

 

Camera Specification Dialogs
The Camera Specification dialog can be accessed in plan view by selecting one or more camera symbols and clicking 
the Open Object edit button. See In Plan View on page 783.

This dialog can also be accessed while a camera view or overview is active by selecting 3D> Edit Active Camera. 

The settings in this dialog may vary somewhat depending on the tool used to create the selected view. This tool name is 
indicated in the dialog’s title bar: the specification dialog for a Full Camera , for example, is named Full Camera 

Specification. See 3D View Tools on page 775.

The Camera Specification dialog has the following panels:

The settings in this dialog are also found in the Camera Defaults dialogs for each of the various camera tools. See Camera 
Defaults Dialogs on page 772.

CAMERA PANEL

The CAMERA  panel is also found in the Walkthrough Path Specification and Defaults dialogs. See Walkthrough Path 
Specification Dialog on page 866.
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Some settings only affect some types of views. Depending on the type of camera view selected, not all the settings may be 
available.         

 
General

Not available in the Walkthrough Path Specification and Defaults dialogs.

 l Specify a Name for the camera that displays in its label in plan view. Names must be unique. 

 l Check Saved to save this view with the plan. As soon as you type anything in the text field, this box becomes 
checked. If you click OK while this box is checked, it will become checked permanently.

 l Uncheck Show Color to toggle the display off in the current view. See Color On/Off on page 130. 

 l Check Show Watermark to turn on the display of the default watermark. See Watermarks on page 998.
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  Rendering

 l Choose the selected camera or walkthrough path’s Rendering Technique from the drop-down list.

 o Click the Define button to open the Rendering Technique Options dialog. Any changes made in that dialog only 
affect the selected view or path. Not available in the Camera Defaults dialogs. See Rendering Techniques on page 
832. 

 o In the Camera Defaults dialogs for all tools except Overviews, you can also specify an Alternate Rendering 
Technique to be used when a view is created using the Alternate  Edit Behavior. See Alternate on page 139.    

 l Check Show Shadows to turn on shadows in the selected camera view. When unchecked, shadows are not 
generated. See Shadows on page 815.

 o Check Ray Casted Sun Shadows for higher quality shadows cast by sunlight. Ray Casted Sun Shadows take longer 
to generate than regular shadows and only refresh when the camera is not moving.     

 l Check Reflections to turn on reflections in the selected camera view. When unchecked, reflections are not generated. 
See Reflections on page 816.             

 l Light Bloom occurs around areas of intense illumination and looks as though the light is ‘bleeding’ beyond the edges 
of the light source. It adds realism to the view but can take longer to render. Only affects Standard and Watercolor 
renderings. See Rendering Techniques on page 832.             

 l Select the amount of Ambient Occlusion in the view using the slider bar or text field. Ambient Occlusion allows 
variation in the strength of the ambient light. It is more realistic than uniform ambient light, but can take longer to 
render. Only affects Standard, Watercolor, and Physically Based renderings. See Ambient Lighting and Occlusion on 
page 819. 

 
AMD FidelityFX

These settings allow you to improve rendering performance on systems with high resolution monitors. These options are not 
used in line-based Rendering Techniques. See AMD FidelityFX on page 815.    

 l Specify the level of Sharpening, which affects how sharp or soft textures appear in the current view.

 l Super Resolution refers to a technique that renders at a lower-than-native resolution and then upscales the result. On 
high resolution displays, these options improve performance without noticeably affecting quality. 

 o The scaling factor used by each option is listed after its name: the higher the factor, the greater potential for both 
performance improvement and reduced quality.

 o Only "Native Resolution" is recommended on regular resolution monitors, as noticeable quality loss may occur 
otherwise. 

 
Depth of Field

These settings allow you to add blur to objects that are not in focus in the current Standard, Vector View, Physically Based, 
Glass House, or Technical Illustration rendering. Not available in the Walkthrough Path Specification and Defaults dialogs.    

 l Check Depth of Field Enabled to enable the settings below and add blur to out-of-focus objects.

 l Set the F-Stop using the scroll bar or text field. A low value increases blur while a high value reduces blur.

 l Specify the Focus Distance, which is the distance from the camera at which objects are in focus and no blur occurs. 
Objects closer to the camera than this distance are subject to blur, as are those further away from the camera.

 
Lighting

These settings control which and how many light sources are used in the current view. See Lighting Modes on page 821.             

803



Home Designer Pro 2025 Reference Manual - Camera Specification Dialogs

 l When Use Sunlight is checked, the sun light source is on in the current view. Uncheck this box to toggle sunlight 
off. 

 l Click the Adjust Sunlight button to open the Adjust Sunlight dialog. Not available in the Camera Defaults or 
Walkthrough Path Defaults dialogs. See Sunlight and Moonlight on page 818.

 l Select Automatic, then specify the Maximum Number of lights that can be used in the current camera view. 

 l Select Use Light Settings to use all light sources in the entire plan provided that they are turned On .         

 l Click the Adjust Lights button to view a list of the light sources in the plan and modify their settings. See Adjust 
Lights Dialog on page 822.         

 

 
Options

Most of these settings are not available in the Walkthrough Path Specification and Defaults dialogs.

 l The Field of View defines the camera’s field of vision in angular degrees. See Field of View on page 792.

 l Clip Surfaces Within - Objects located within this distance from the camera do not display in the view. Decrease 
this value to display objects located close to the camera; increase it to improve the appearance of some surfaces in 
Overview cameras with very large extents. 

 l Uncheck Show Lower Floors to show only the current floor in the selected Floor Overview. When checked, the 
current floor plus any floors beneath it are included in the view. Only available for Floor Overviews. See Doll 
House View on page 778.                  

 l Check Hide Camera-Facing Exterior Walls to suppress the display of any exterior walls that face the camera. 
Interior walls set as Attic walls are also suppressed. This setting only has an effect when the selected camera’s 
position is on the exterior of a structure and also has an associated toggle. See Hide Camera-Facing Exterior Walls 
on page 817.

 l Check Extend Terrain to Horizon to create a virtual extension of the Terrain Perimeter in camera views that 
appears to extend to the horizon. This setting only has an effect if a Terrain Perimeter is present. See Terrain 
Perimeter on page 891.

POSITIONING PANEL

Only the X and Y Position settings are available in the Cross Section/Elevation Specification dialog. See Cross 
Section/Elevation Specification Dialogs on page 809.
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Position

These settings determine the position and orientation of the camera. Only the Height Above Floor and Tilt Angle are 
available in the Camera Defaults dialogs. See Navigating in Camera Views on page 785.  

 l The Height Above Floor defines the height that the camera is above the floor level for the current floor. See 
Camera Height on page 777.    

 l The Tilt Angle determines the vertical angle that the camera is tilted. The camera maintains its focal point and 
position in plan view, but if the camera is tilted, the focal point is above or below the current camera height. 

 l Specify the selected camera’s Camera Angle. This is an absolute value: an angle of 0° points the camera toward the 
left in plan view.    

 l Specify the X Position and Y Position for the selected camera. These are absolute coordinates. Specifying zero for 
both places the camera at the plan’s origin point (0,0).    

 
Navigation

These settings control how the camera is affected when you navigate using the mouse. See Move Camera with Mouse on 
page 787.    

 l The Incremental Move Distance controls how far the camera moves each time you Pan in any direction or Dolly 
forwards or backward using the keyboard, toolbar buttons, or menu. For interior views a small number is good, but 
for exterior you may want a larger increment.    

 l The Incremental Rotate Angle defines how many degrees the camera rotates each time you Tilt, Orbit, or Dolly 
side to side using the keyboard, toolbar buttons, or menu. A setting of 90° would make one full rotation in four 
moves.    

PLAN DISPLAY PANEL

The settings on the PLAN DISPLAY panel control the appearance of the selected camera's symbol in plan view. See In Plan 
View on page 783.           
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 l The Camera Symbol Size is measured in plan inches (mm).    
 o Check Show Camera Focal Point to display the camera’s focal point in plan view. When unchecked, the 

camera’s line of sight and focal point are hidden until the camera is selected.    
 o Check Show Field of View Indicators to display the camera’s field of view indicators in plan view.    

 l You can also change the FOV Indicator Length, which is measured in plan inches (mm).    

BACKDROP PANEL

The settings on the Backdrop panel allow you to specify a backdrop image or color to display behind your model in the 
selected 3D view. See 3D Backdrops on page 841.         

The BACKDROP panel is also found in the Walkthrough Path Specification and Defaults dialogs. See Walkthrough Path 
Specification Dialog on page 866.
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Specify Backdrop

A preview of the selected backdrop image is shown here. A backdrop cannot be selected or removed when Use Generated 
Sky is checked, below.             

 l Backdrop Name - The selected backdrop image’s name displays for reference.          

 l Click Select Backdrop to choose a backdrop image from the library. See Select Library Object Dialog on page 716.          

 l Click Remove Backdrop to use a solid color instead of a backdrop image in all 3D views, then specify the color 
below.          

 
Use Generated Sky

Not available for Orthographic Overviews or Cross Section/Elevation views.                 
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 l Check Use Generated Sky to use a sky backdrop that simulates different times of day based on the position of the 
Generic Sun. 

 o When checked, Spherical Panoramic Backdrop will also be checked and a preview of the Generated Sky will display 
in the current view behind the dialog, and will update as changes are made to the settings below. 

 o If the view's Rendering Technique is not set to Use Backdrop Image, it will be set to do so automatically. See 
Rendering Technique Options on page 834.  

 l Specify the Starlight Intensity, which is how bright the stars appear in the sky.    

 l Specify the Star Density, which controls how close stars are to one another.    

 l Specify the Moon Luminance, which is how much light the moon contributes to the scene.    

 l Specify the Moon Intensity, which is how bright the moon appears in the sky.    

 l Specify the Moon Tilt, which is the direction that the moon's light shines.    

 l Specify the Moon Direction, which describes the position of the moon in the sky.    

 l Specify the Moon Angular Radius, which controls the size of the moon.    

 l Specify the Sun Angular Radius, which controls the size of the sun.    

 l Click the Reset button to reset all Generated Sky settings to the system defaults.

 
Spherical Panoramic Backdrop

These settings are only available when a Backdrop image is selected, and are not available for Orthographic Overviews or 
Cross Section/Elevation views. When User Generated Sky is checked, above, these settings cannot be edited.                 

 l Check Spherical Panoramic Backdrop to place the selected backdrop onto a sphere that surrounds the model in the 
current view. This box is checked automatically when Use Generated Sky is checked, above.    

 l Horizontal Tile - Specify how many times to tile the selected backdrop image side by side.     

 l Vertical Tile -  Specify how many times to stack the selected backdrop image one above the other.     

 l Specify the Horizontal Span, which is how much of the sphere the backdrop is applied to. A Span of 360° wraps 
the entire sphere.     

 l Specify the Horizontal Offset, in degrees, to shift the backdrop image or tiled images in a clockwise direction.     

 l Specify the Vertical Max, which is the height of the bottom of the backdrop, measured relative to the top of the 
sphere.     

 l Specify the Vertical Min, which is the height of the bottom of the backdrop, measured relative to the bottom of the 
sphere.     

 l The Eye Level setting controls the vertical position of the camera within the sphere. A value of 0 positions the 
camera at the bottom of the sphere while a value of 1 positions it at the top. The default value is 0.5., which centers 
the camera inside the sphere.    

  Background Color

 l Click the Color bar to select the Background Color that displays when a backdrop image is not being used. See 
Select Color Dialog on page 135.      

The Background Color for plan views is set in the Preferences dialog. See Colors Panel on page 65.     

808



Home Designer Pro 2025 Reference Manual - Cross Section/Elevation Specification Dialogs

LABEL PANEL

In the Camera Specification dialogs, the settings on the LABEL panel are limited to the Suppress Label check box and 
Position and Orientation settings.         

Camera labels always use the Camera Name specified on the CAMERA panel. When callouts are used, the Callout Label 
and Text Below Line are specified on the PLAN DISPLAY panel.         

For information about this panel, see Label Panel on page 376.         

 

Cross Section/Elevation Specification Dialogs
The Cross Section/Elevation Specification dialogs can be accessed in plan view by selecting one or more cross 
section/elevation camera symbols and clicking the Open Object edit button. See In Plan View on page 783.

This dialog can also be accessed while a cross section/elevation camera view is active by selecting 3D> Edit Active 
Camera. 

The Cross Section/Elevation dialog has the following panels:

Most of the settings in this dialog are also found in the Cross Section/Elevation, Back Clipped Cross Section, and   Wall 
Elevation Defaults dialogs. See Camera Defaults Dialogs on page 772.    
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CAMERA PANEL

  General

 l Specify a Name for the camera that displays in its label in plan view. Names must be unique.      

 l Check Saved to save this view with the plan. As soon as you type anything in the text field, this box becomes 
checked. If you click OK while this box is checked, it will become checked permanently. 

 l Uncheck Show Color to toggle the display off in the current view. See Color On/Off on page 130. 

 l Check Show Watermark to turn on the display of the default watermark. See Watermarks on page 998.

  Rendering

 l Choose the selected camera’s Rendering Technique from the drop-down list. Click the Define button to open the 
Rendering Technique Options dialog. See Rendering Techniques on page 832. 

 l Check Show Shadows to turn on shadows in the selected camera view. When unchecked, shadows are not 
generated. See Shadows on page 815. 
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 l Check Ray Casted Sun Shadows for higher quality shadows cast by sun light. Ray Casted Sun Shadows take longer 
to generate than regular shadows and only refresh when the camera is not moving.

 
AMD FidelityFX

See AMD FidelityFX on page 815.      

 l Specify the level of Sharpening, which affects how sharp or soft textures appear in the current view. In cross 
section/elevation views, this option only affects views using the Standard and Watercolor Rendering Techniques. See 
Rendering Techniques on page 832.

  Lighting

 l When Use Sunlight is checked, the sun light source is on in the current view. Uncheck this box to toggle sunlight 
off. 

 l Click the Adjust Sunlight button to open the Adjust Sunlight dialog. Not available in the Camera Defaults dialogs. 
See Sunlight and Moonlight on page 818.

 
Scene Clipping

These settings control the extents of the camera view. Not all settings are available in the various cross section/elevation 
defaults dialogs. See Clipped Section Views on page 780.

 l Check Framing Back Clip to include only the framing objects or portions of framing objects located between the 
start and end points of the camera's Line of Sight in the view.

 o Specify the Back Clip Framing After distance, which is the distance from the camera's position beyond which 
framing objects are clipped.

 l Check Back Clip to include only the objects or portions of objects located between the start and end points of the 
camera's Line of Sight in the view. This box is checked by default for Back Clipped Cross Section views and is not 
available in any of the Defaults dialog.      

 o Specify the Back Clip After distance, which is the distance from the camera's position beyond which objects other 
than framing are clipped. It is also the length of the camera's Line of Sight from the Cross Section Line at its start to 
the Back Clip Line at its end. This text field reports the length of the camera's Line of Sight even when Back Clip is 
unchecked above, and is not available in any of the Defaults dialogs.     

 l Check Clip Sides to limit the selected view’s side-to-side extents to the Clip Width specified below. When 
unchecked, the full width of the model is included in the view.     

 l Specify the Clip Width, which is the width of the camera's side-to-side extents. This value controls the length of the 
camera's Cross Section Line when its symbol is selected in plan view. When Clip Sides is checked, it also affects 
how much of the model is shown in the view, and the Cross Section Line has end edit handles that adjust this value 
when they are dragged. See Editing 3D Views on page 791.     

 l Check Clip Elevation to limit the selected view's vertical extents to the elevation values below. When unchecked, 
the full height of the model is included in the view.     

 o Specify the Bottom Clip Elevation, which is the bottommost extent of the view. Objects or parts of objects located 
below this elevation are not included in the view. When Clip Sides is checked and the bottom clipping plane has 
been edited, this value refers to the end point with the higher elevation.     

 o Specify the Top Clip Elevation, which is the topmost extent of the view. Objects or parts of objects located above 
this elevation are not included in the view. When Clip Sides is checked and the top clipping plane has been edited, 
this value refers to the end point with the lower elevation.     
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 l Check Clip to Room to confine the extents of the current view to the room that the camera is located in. The view's 
clip values are reported above for reference. This box is checked by default for Wall Elevation views, is only 
available when the selected camera is located inside a room, and is not available in any of the Defaults dialogs. 
When this box is checked, framing objects will not be visible in the view.          

 o Check Ignore Railings and Invisible Walls to ignore the room definition created by these types of walls in a 
selected view. When this is unchecked, only room definition created by regular walls is recognized.    

 o Check Ignore Walls Above to prevent any walls located above the selected camera's room from displaying in the 
view. This option typically has an effect only when the camera's room has Flat Ceiling Over This Room unchecked, 
or the room above has Floor Under This Room unchecked, in the Room Specification dialog. See Structure Panel on 
page 310. 

POSITIONING PANEL

The settings on the POSITIONING panel let you specify the location of the camera symbol in plan view. See Positioning 
Panel on page 804.

PLAN DISPLAY PANEL

The settings on the PLAN DISPLAY panel control the appearance of the selected camera in plan view. See In Plan View on 
page 783.           

 
Plan Display
These settings allow you to specify the appearance of the selected camera’s symbol.  See Dynamic Defaults on page 
58. 

 l Uncheck Default beside any of these options to modify it.

 l The Camera Symbol Size is measured in plan inches (mm). 

 l Check Show Camera Focal Point to display the camera’s focal point in plan view. When unchecked, the camera’s 
line of sight, focal point, and clip plane indicators are hidden until the camera is selected.

 l Specify the Clip Plane Indicator Length in plan inches (mm). See To create a cross section/elevation view on 
page 779. 

BACKDROP PANEL

The settings on the BACKDROP panel allow you to specify a backdrop image or color to display behind your model in the 
selected 3D view. See Backdrop Panel on page 806.          
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LABEL PANEL

In the Cross Section/Elevation Camera Specification dialog, the settings on the LABEL panel are limited to the Suppress 
Label check box and Position and Orientation settings.           

Camera labels always use the Camera Name specified on the CAMERA panel. When callouts are used, the Callout Label 
and Text Below Line are specified on the Plan Display panel.          

For information about this panel, see               Label Panel on page 376.
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Chapter 32
 

3D Rendering

There are a variety of tools available to create 3D views of a model: simply click a button to create an overview, or click 
and drag to create a camera or cross section/elevation view. See 3D Views on page 770.         

To improve the quality of the rendering and create a custom look, you can adjust lighting, edit the materials used in the 
plan, choose from several rendering techniques, and fine-tune 3D view quality settings.   

TOPICS

Rendering Tips 815
Lighting 817
Light Types 819
Displaying Lights 820
Lighting Modes 821
Light Specification Dialog 824
Sun Angles and Shadows 825
Sun Angle Specification Dialog 827
Adjust Sunlight Dialog 830
Rendering Techniques 832
Rendering Technique Options 834
3D Backdrops 841
Backdrop Specification Dialog 843
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Rendering Tips
There are a variety of factors which affect the appearance and quality of rendered 3D views. You can use these tools and 
settings to achieve renderings that meet your needs. 

TONE MAPPING

In 3D renderings, the appearance of materials is affected by the light that bounces off them. Because radiance can vary 
widely in a given scene, it is possible for colors in the scene to fall outside of the range of colors that monitors are capable 
of displaying, which can result in the perception of less than ideal lighting quality. Tone mapping addresses this issue by 
mapping colors in the rendering to colors that can display on-screen. 

Tone Mapping Operators (TMOs) are different formulas for performing this color mapping. There is no one "best" TMO, 
since the desired lighting and coloring can vary from scene to scene and also from viewer to viewer. In Home Designer, one 
of two TMOs can be used in Physically Based renderings:

 l Hable Tone Mapping produces moderate color saturation and is often more suitable for interior scenes.
 l ACES produces somewhat greater color saturation, particularly of bright colors, which may be preferable in exterior 

daytime scenes.   

You can specify the Tone Mapping Operator you wish to use in the Rendering Technique Options dialog. See Physically 
Based Panel on page 836.

AMD FIDELITYFX

In some cases, rendering large and complex scenes can be time-consuming: particularly when the Physically Based 
Rendering Technique is used. On systems with high resolution monitors (ex. 4k or Retina), you can reduce rendering time 
without noticeably impacting quality using the AMD FidelityFX settings. FidelityFX Super Resolution, also referred to as 
FSR, is a technique that renders scenes at a lower-than-native resolution to shorten rendering time and then scales the result 
up again. On regular, lower resolution monitors this typically results in decreased quality; however, on high resolution 
displays the change in quality is considerably less pronounced.

FSR can be specified in camera views and overviews, but not cross section/elevation views. See Camera Panel on page 
801.

FSR is only used in the Standard, Physically Based, and Watercolor Rendering Techniques. See Rendering Techniques on 
page 832.

FSR is particularly useful when recording walkthroughs; but it is also available in camera and cross section/elevation views. 
See Camera Panel on page 801.

LIGHTING

Lighting is extremely important in most 3D renderings. Lighting controls the visibility of objects in a view, affects the 
appearance of surfaces, and influences the appearances of colors and textures on those surfaces. Even small changes to light 
intensity, direction and color can have a large impact on image quality. See Lighting on page 817. 

SHADOWS

 Like lighting, shadows have an important effect on image quality. Shadows can be generated in any type of camera 
view using any Rendering Technique aside from Glass House. See Rendering Techniques on page 832.
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When shadows are enabled and the sun is shining directly at a window, its light can shine through the window and into an 
interior room. These shadows use Ray Casted Sun Shadows by default, but this option can be unchecked if it slows 
performance in 3D views. See Sunlight and Moonlight on page 818.

Shadows are enabled in Full Camera views by default. You can, however, check or uncheck Show Shadows and Ray 
Casted Sun Shadows in the defaults dialog for any camera tool or in the specification dialog for any camera view. In 
addition, you can select 3D> Camera View Options> Toggle Shadows  in any camera view. See Camera Panel on 

page 801.

Shadows are affected by the number of light sources in a plan, as well as what Rendering Technique is in use. In order for a 
light source to cast shadows, it must be On in the current view and have Cast Shadows checked in its specification dialog. 
See Light Data Panel on page 493.

In addition to their appearance in camera views, sun shadows can also display in plan view to represent the shadows created 
by the sun at a particular date, time, and location. See Sun Shadows on page 826.

REFLECTIONS

 Reflections are another aspect of lighting that can increase a 3D view’s realism. When a flat surface is assigned a 
Mirror material, it can display the reflections of other objects in the scene. Bear in mind that a Mirror surface cannot 

display the reflection of another mirror: when one mirror can be seen in another, its material is shown rather than a 
reflection.

Reflections in Mirrors only generate in Perspective 3D views using Rendering Techniques that show material textures. In 
some situations, they can slow down 3D view generation and responsiveness. See Rendering Techniques on page 832.

When the Physically Based  Rendering Technique is in use, reflections on non-mirror surfaces are modeled, as well. See 

Physically Based on page 833.

Reflections in Mirrors can be toggled on or off in a camera view by selecting 3D> Camera View Options> Toggle 
Reflections  as well as in the Camera Specification dialog.

MATERIAL DEFINITIONS

Textures are graphic files that represent contoured surfaces of objects such as carpet, bricks, tile, and wood in rendered 
views. Textures are assigned to materials which in turn are assigned to objects. See Patterns and Textures on page 746. 

The display of materials in rendered views is controlled by settings on the TEXTURE and PROPERTIES panels of the Define 
Material dialog. See Define Material Dialog on page 760.

For realistic rendered views, it is sometimes helpful to make adjustments to texture properties so that they map to surfaces 
correctly. See Mapping Patterns and Textures on page 756. 

Brightness, shininess and transparency control how light sources affect the display of surfaces in rendered views. See 
Lighting on page 817.

If no texture is selected for a material or if the display of textures is turned off, affected surfaces are a solid color instead.

MATERIAL TRANSPARENCY

Most materials are opaque while some materials, such as glass, are partially transparent. Transparency can be set in the 
Define Material dialog. See Properties Panel on page 766.

Transparency is supported in all Rendering Techniques. Most Rendering Techniques, however, have an Opaque Window 
Glass setting that, when checked, overrides the transparency of the Glass components of exterior doors, exterior windows, 
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and interior windows. Interior doors with Glass components are unaffected. When this box is checked, Glass components 
display the Material Color assigned to their material. See Rendering Technique Options on page 834.

IMAGES

Image objects use picture files to represent individual objects such as trees, flowers, and vehicles in 3D views. Images are 
useful because they have only one 3D surface, allowing them to represent complicated 3D objects with a high degree of 
realism but with minimal cost in terms of performance. See Placing Images on page 846.   

BACKDROPS AND GENERATED SKY

A backdrop is an image, usually of an exterior view, that displays in the background of 3D views to help place the model 
into a realistic setting and add a sense of perspective. Backdrops also contribute to the Global Illumination in Physically 
Based renderings. If a backdrop is not specified, Home Designer applies a background color. See 3D Backdrops on page 
841.

The Generated Sky is a spherical backdrop option that simulates the sky at different times of day based on the position of 
the Generic Sun. A horizon line is modeled when the Generated Sky is in use and as the sun is moved closer to the horizon, 
its intensity decreases and its color becomes an increasingly deep amber color. When the sun is either below the horizon or 
toggled off, representations of the moon and stars become visible. See Sunlight and Moonlight on page 818.

Backdrops and the Generated Sky are view specific and can be set in the Camera Specification dialog. See Backdrop Panel 
on page 806.

HIDE CAMERA-FACING EXTERIOR WALLS

Occasionally, it can be very helpful to view the interior of a structure from an exterior view. To achieve this, create 
an exterior camera view or overview and select 3D> Camera View Options> Hide Camera-Facing Exterior Walls. 

This option is view-specific and can also be set in the Camera Specification dialog. See Camera Panel on page 801. 

Hide Camera-Facing Exterior Walls is also an option for Walkthrough Paths. See Record Walkthrough Options Dialog on 
page 872.

 

Lighting
Lighting controls the visibility of objects in 3D views, affects the appearance of surfaces, and influences the appearances of 
colors and textures on those surfaces.              

Each individual light source has a set of properties, such as intensity and color, that can be defined. See Light Data Panel on 
page 493.          

Lighting is supported in the Standard, Physically Based, and Watercolor Rendering Techniques in Perspective camera 
views. 

By default, a maximum of 20 lights can display in a given camera view or overview. If more than 20 are present, those with 
the highest intensity located in the same room as the camera are rendered. Lights in adjacent rooms may also be rendered, 
with the highest intensity lights rendered first. 

 l You can specify a different Maximum Lights number in the Camera Specification dialog. See Camera Panel on page 
801.

 l You can also manually turn on and off individual lights in order to get the desired lighting effects. See Displaying 
Lights on page 820.              
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When the camera is outside a building, the program normally uses sunlight for lighting calculations and turns off all other 
light sources. You can turn the sunlight off and use all the other exterior lights to simulate nighttime views.

There are five types of light sources in Standard rendered views:

DEFAULT INTERIOR LIGHT

If you create a Standard interior camera in a room where no lights have been placed, the program creates a Default Light 
source within that room. The Default interior light acts like a central point light source but cannot be selected or edited. 

Because the Default Light cannot be adjusted, if you want to control the light in an interior rendered view, you must add 
lights to the rooms in your plan by placing light fixtures and Added Lights. 

LIGHT FIXTURES

An electrical symbol that represents a Light Fixture can have one or more light sources associated with it. Properties for 
each light source such as light type, color, and intensity can be modified in the fixture’s Electrical Service Specification 
dialog. See Symbol Object Specification Dialogs on page 723.

You can also adjust a light source's Offset, or position relative to the fixture. If you choose to Show Position in Camera 
View, you can see where the light source is located.          

Light sources look most realistic when they are offset from a surface.          

ADDED LIGHTS

In plan view, select 3D> Lighting> Add Lights to quickly add a light source to a plan. Added Lights and their labels 
are placed on the “Light Sources” and “Light Sources, Labels” layers.         

Added lights only act as light sources in plan files that have at least one room defined. They display 2D symbols in plan 
view but do not display as objects in 3D views. 

While Added Lights do not display as objects in 3D, you can specify that an Added Light’s position be represented by red 
crosshairs in rendered views that use lighting. Spot Lights also display a blue arrow indicating the light's direction. See 
Light Data Panel on page 493.

Added lights can be placed into objects that normally do not generate light, such as a TV.

There are two types of added light sources: Point Lights and Spot Lights. See Light Types on page 819.

SUNLIGHT AND MOONLIGHT

Sunlight is the only source of light in exterior daytime camera views. When standard shadows are enabled, sunlight can also 
shine through windows into interior rooms. See Shadows on page 815.

Select 3D> Lighting> Toggle Sunlight  while in a camera view to simulate either daytime or nighttime exterior lighting.

To  prevent the Sunlight from lighting a scene without switching to nighttime lighting, check Use Only Backdrop for 
Lighting in the Rendering Technique Options dialog. This option is useful for overcast daytime scenes in Physically Based 
renderings. See Physically Based Panel on page 836.

There are two types of sunlight:
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 l The Generic Sun’s default intensity, color, and angle can be set in the Generic Sun Defaults dialog, and can be 
modified in the Adjust Sunlight dialog. In addition, you can specify that it follow the camera in 3D views so surfaces 
are always illuminated. The Generic Sun’s settings are view specific: each 3D view can have its own, unique settings. 
See Adjust Sunlight Dialog on page 830. 

 l You can instead place a Sun Angle  in plan view to produce sunlight based on specific date, time, latitude, and 

longitude information. See Sun Angles and Shadows on page 825.

You can specify that a particular Sun Angle or the Generic Sun be used in any active camera view in the Adjust Sunlight 
dialog. See Adjust Sunlight Dialog on page 830.

Select 3D> Lighting> Move Sun, then click and drag in any direction in a camera view to adjust the position of the 
Generic Sun. You can also Ctrl/⌘  + click to place the Generic Sun at the location where you click. This tool is only 

available in Rendering Techniques that support lighting, or any camera view using the Generic Sky backdrop. This option is 
most effectively used when Use Generated Sky is in use and cannot be used while Sun Follows Camera is checked in the 
Camera Specification dialog.

When the Generated Sky is in use and the Generic Sun is either toggled off or has been moved below the horizon, 
representations of the moon and stars can be seen in the sky. Select 3D> Lighting> Move Moon, then click and drag 

in any direction or Ctrl/⌘  + click to adjust the position of the moon. This tool is only available in Perspective Views. The 
intensity and other attributes of the moon and stars can be set in the Camera Specification dialog when Use Generated Sky 
is checked. See Backdrop Panel on page 806.

AMBIENT LIGHTING AND OCCLUSION

Ambient lighting simulates the way light bounces around a scene, producing a basic level of uniform illumination on all 
surfaces. It is used in camera views and overviews using the Standard, and Watercolor Rendering Techniques.

There are three types of ambient light in Home Designer:

 l Interior Ambient controls the ambient light in interior views.
 l Daytime Ambient controls the ambient light in exterior views when Toggle Sunlight  is on. See Sun Angles and 

Shadows on page 825.
 l Nighttime Ambient controls the ambient light in exterior rendered views when Toggle Sunlight  is off.

You can control the brightness of each in the Rendering Technique Options dialog. See Standard Panel on page 835. 

Ambient occlusion adds shading to surfaces near corners which, because of their location, reflect less light compared to 
other surfaces. Too little ambient occlusion can result in a view having a flat appearance. You can specify the amount of 
Ambient Occlusion to use in Standard, Watercolor, and Physically Based renderings in the Camera Specification dialogs. 
See Camera Panel on page 801.

BACKDROP INTENSITY

In Physically Based renderings, the scene's backdrop contributes to its Global Illumination. You can control Daytime and 
Nighttime Backdrop Intensity in the Rendering Technique Options dialog. See Physically Based Panel on page 836.       

 

Light Types
There are  two types of light source, each of which generates light in a different way and allows you to create a variety of 
lighting effects:           

819



Home Designer Pro 2025 Reference Manual - Displaying Lights

 l Point Light sources
 l Spot Light sources

Any punctual light source              except a Sun Angle can be specified as a Point or Spot Light in its specification dialog. See Light 
Data Panel on page 493.         

In addition to being assigned to light fixtures, punctual light sources can be placed in a plan as Added Lights, which 
are light sources that are not associated with a fixture. As with light fixtures, the lighting properties of Added Lights 

can be set in their specification dialog. See Light Specification Dialog on page 824.         

POINT LIGHTS

Point Lights are punctual, which means that they originate from a single, infinitely small point. Like a bare light bulb, a 
Point Light radiates light equally in all directions from its origin and is a realistic representation of non-directional electric 
lighting.         

If no user defined light exists, Home Designer creates a Point Light source to represent a light within a room.         

To create a Point Light source

 1.  In plan view, select 3D> Lighting> Add Lights .

 2.  Click in plan view. Do not drag the pointer when you click the screen, or you will create a Spot Light.

SPOT LIGHTS

A Spot Light is also punctual, but focuses the light in a specified direction. The Tilt and Direction Angles can be specified 
in a Spot Light’s specification dialog.         

To create a Spot Light source

 1.  In plan view, select 3D> Lighting> Add Lights .

 2.  Click and drag in plan view no more than two plan feet (600 mm) in any direction.

 3.  As you drag, the light preview will look like a Spot Light icon.

 4.  When you release the mouse, a Spot Light pointing in the direction that you dragged is created.

 5.  You can edit the Spot Light's 

You can also use a Spot Light’s edit handles in plan view to move it, as well as change its direction and Cut Off Angle.         

 

Displaying Lights
The display of light fixtures and Added Lights in floor plan and 3D views is controlled in the Layer Display Options 
dialog. Light fixtures are placed on the “Electrical” layer, and Added Lights, on the “Light Sources” layer. See Layer 

Display Options Dialog on page 127.
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In addition, they can serve as sources of light in rendered 3D views. They can be turned on and off, as well as set to cast 
shadows.

IN PLAN VIEW

In plan view, both light fixtures and Added Lights can display labels when the “Electrical, Labels” and/or “Light Sources, 
Labels” layers are turned on. See Label Panel on page 376.

IN 3D VIEWS

Light fixtures and Added Lights can serve as sources of light in rendered views.       

To turn a light on or off

There are several ways to turn a light fixture or Added Light on or off:         

 l Select one or more fixtures or Added Lights and click the Turn Light(s) Off in 3D  or Turn Light(s) On in 3D 

 edit button.

 l Uncheck On in the object’s specification dialog. See Light Data Panel on page 493.
 l Clear the On/Off check box in the Adjust Lights dialog. See Adjust Lights Dialog on page 822.

Added Lights are not associated with a 3D fixture, but you can specify that any punctual light source’s location be 
represented in 3D views using crosshairs. See Light Data Panel on page 493.         

Punctual light source position indicators will only display when the light is in use in the current 3D view. That is, it must 
be:          

 l Turned on.
 l In-use in the current view.
 l Either located in a room or in an exterior view with Sunlight toggled off.

Sunlight will shine through windows into interior rooms when shadows are enabled. See Shadows on page 815.         

 

Lighting Modes
By default, cameras use an Automatic Lighting Mode that allows a set number of lights to illuminate the view. This number 
can be specified in the Camera Specification and Adjust Lights dialogs. See Camera Panel on page 801.

If more than the set number of lights are present, lights are prioritized in this order:

 l Lights in the same room as the camera before those in different rooms.
 l Higher intensity lights before lower intensity lights.
 l Lights closer to the camera before those further away.

Regardless of their intensity or proximity to the camera:

 l Interior lights are not used in exterior camera views.
 l Exterior lights are not used in exterior camera views when the Sunlight is toggled on. See Sunlight and Moonlight on 

page 818.
 l Lights on floors above the camera are not used in Floor Overviews. See 3D View Tools on page 775.

The Automatic Lighting Mode is useful because it is an easy way to produce reasonable lighting without taxing your video 
memory.
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An alternative to the Automatic Lighting Mode is the Use Light Settings option. When Use Light Settings is selected, all 
lights in the current plan that are turned On are used in 3D views. This gives you control over which lights are used as light 
sources but may require more resources on your system.         

ADJUST LIGHTS DIALOG

Light fixtures and Added Lights in the current plan are listed and can be edited in the Adjust Lights dialog, making it 
an efficient way to control which lights are turned on in 3D views. Select 3D> Lighting> Adjust Lights to open this 

dialog in floor plan or any 3D view. You can also open it by clicking the Adjust Lights button in the Camera Specification 
dialog. See Camera Panel on page 801.         

You can also access a version of this dialog via the contextual menu when one or more light fixtures in the User Catalog of 
the Library is selected. See Using the Contextual Menu on page 697. 

The Generic Sun, Moon,              and Sun Angles are not listed in this dialog. See Sunlight and Moonlight on page 818.        

 
Light Settings

 When the dialog is opened while a camera view is active, these settings are available:         

 l The name of the Current Camera is stated here for reference.

 l Specify the desired Lighting Mode:

 o Automatic uses the Maximum Lights specified here and the On/Off settings specified below.

 o Use Light Settings uses the lights that are turned On, as specified below. 
If the current view is a camera in which lighting is used, the view will update automatically as changes are made in  the 
Adjust Lights dialog. In some circumstances, this can result in slow performance in this dialog.          
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 l To avoid this slowness, you can uncheck Update Lighting Automatically. 

 l When Update Lighting Automatically is checked, you can click the Update button to update the lights in the 
camera view.

 
Light Source Properties

All lights in the current plan are listed here, and a variety of their attributes can be edited.                

 l Total Light Objects, punctual Light Sources, and In Use lights are reported for reference above the Properties table.

 l The organization of the columns in the Properties table is customizable:

 o Right-click on a column heading to control which columns display and which do not.

 o Click and drag a column heading to the left or right to move that column to a different position.

 l All lights in the current plan are listed in the table using the same Names as their labels. Click on a line item to 
select it.             

 o When the selected line item is a light fixture, you can change the color and On/Off state of all of its lights as a 
group. 

 o If a line item is a light fixture, it will have an arrow to the left of its name. Click this arrow to show the fixture’s  
lights as individual line items.

 o When multiple line items are selected, only their color and On/Off state can be edited. Multiple line items can be 
selected by holding down the Shift  key. See Shift and Ctrl/⌘  Select on page 146.

 l Check the box in the On column to turn the selection's light on or uncheck the box to turn it off. See In 3D Views on 
page 821.

 o If a fixture has multiple lights associated with it and only some are on, a solid square will display in its check box. 

 l The Count column lists the number of light sources assigned to each light fixture. This column is empty for Added 
Lights and Area Lights.             

 l The Room column states the location of each light. If a light is not in a room, “Outside” will be reported. See Rooms 
on page 286.          

 l The Floor column states the floor level that each light is on. See Multiple Floors on page 517.           

 l The Type column states the type of light source used by each light. See Light Types on page 819.             

 l The Intensity column states the strength of each light.             

 l The Color column displays the light’s color. Click the button to choose a different color if you wish.             

 l The In Use column states whether each light is emitting light in the Current Camera view. If a fixture has multiple 
light sources and only some are in use, a blue box will display in its row.

 l The Show Position column indicates whether each punctual light source's position is set to show in camera views. 
Area Lights do not have this option. See In 3D Views on page 821.

 
Adjust

The properties of light fixtures and Added sources Lights can be edited.     

 l To adjust the properties of an individual light fixture, select it and click the Adjust Light button to open its 
specification dialog. See Light Data Panel on page 493.
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 l To adjust the properties of an Added Light, double-click on its name or select it and click the Adjust Light button to 
open its specification dialog. Multiple Added Lights can be edited using this button.  See Light Specification Dialog 
on page 824. 

 

Light Specification Dialog
Select one or more Point or Spot Lights and click the Open Object edit button to open the Light Specification dialog.
         

You can also select 3D> Lighting> Adjust Lights  to access a list of the light sources present in the current plan and 

open the specification dialog for any of them. See Adjust Lights Dialog on page 822. 

LOCATION PANEL

 
Light Display
Specify where the selected Added Light displays in plan and 3D views.         

 l Select All Floors to display the selected light on all floors in plan view. See Multiple Floors on page 517.

 l Select Specify Floor Number to display the light on one floor only, then choose a floor number from the drop-down 
list.

Note: The floor or floors that an Added Light displays on in plan 
view is totally independent of where it displays in 3D.

 l Specify the selected light’s Absolute Elevation, measured relative to 0, which is the default height of Floor 1.

 l Specify the Display Size, which is the diameter of the circle representing the Added Light in plan view.

LIGHT DATA PANEL

The settings on this panel are also found on the same panel of the Electrical Service Specification dialog. See Light Data 
Panel on page 493.         

Depending on the type of light selected, the options available here may vary. 

LABEL PANEL

Labels for Added Lights display in plan view when the “Light Sources, Labels” layer is turned on and use the Text Style 
assigned to that layer. See Text Styles on page 373.          

For information about the settings on this panel, see               Label Panel on page 376.
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Sun Angles and Shadows
In addition to the functional and aesthetic properties of ambient light and light sources in rendered views, the direction and 
angle of the sun’s light and shadows are an important consideration. Two tools allow you to generate sunlight and sun 
shadows with accuracy:

  North Pointers allow you to specify the direction of true north in a plan.

  Sun Angles let you specify an exact location, date, and time for sunlight and sun shadow generation.

NORTH POINTER

The North Pointer tool is used to define the direction of true north in a plan. The direction of north does not affect the 
orientation of the Snap and Reference grids, but it does affect the direction of sunlight and sun shadows, how conditioned 
area totals are calculated, and how bearing information is interpreted by the program. 

Every bearing is defined relative to North, so it is best to 
establish this direction before entering survey information for a 

site plan. 

If a North Pointer is not used, north is assumed to be straight up on screen in plan view. 

Select CAD> North Pointer , then click and drag to draw the pointer, starting at the tail and dragging toward the point. 

Once it is drawn, you can define its exact length and angle in its specification dialog. See Line Specification Dialog on page 
208.

Multiple North Pointers can be drawn in a given plan file, and will always point in the same direction automatically. If you 
rotate one of them, the others will automatically rotate to match. Similarly, if you draw a new North Pointer at a different 
angle, existing North Pointers will rotate to that angle automatically. 

If you choose to display line angles when a North Pointer exists, be sure to select the appropriate format in the CAD 
Defaults dialog. See CAD Defaults and Preferences on page 198.

 l If angles are set to Bearings, they are relative to the North Pointer.

 l If angles are set to show as Degrees, the angle relates to 0° (horizontal to the right) even if a North Pointer is present.
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A North Pointer can be selected and edited using its edit handles and Edit Toolbar buttons. All attributes of the N aside from 
its size are drawn from the Text Style assigned to the “CAD, Default” layer. For more information, see Editing Line-Based 
Objects on page 146. 

SUN ANGLES

Sun Angles let you establish exactly where your plan’s building site is located, and a precise date and time. This information 
allows the program to determine the sun’s location in the sky and generate sunlight and sun shadows with accuracy.           

Note: Sun Angle calculations do not adjust for elevation. They are based 
on formulas published by the United States Naval Observatory and have 
limited accuracy as documented by the USNO. 

When an exterior 3D view is rendered, the program looks for an active Sun Angle. If it finds none, the Generic Sun is used. 
See Sunlight and Moonlight on page 818.          

To create a Sun Angle

 1.  In plan view, go to Floor 1 or Floor 0. Sun Angles can only be created on these floor levels. See Multiple Floors on 
page 517.              

 2.  Select CAD> Sun Angle  and click in the drawing area to place a Sun Angle arrow at that location.              

 3.  In the Sun Angle Specification dialog, specify the Sun Angle’s Earth Data and other information. See Sun Angle 
Specification Dialog on page 827.             

 4.  After it is created, a Sun Angle cannot be rotated; but it can be moved as well as resized using its edit handles. 
Shadows are not affected.             

Multiple Sun Angles can be created, each with different specifications; however, only one can be used as a light source in a 
given 3D view. If more than one Sun Angle is present, specify the one to use in the current view in the Adjust Sunlight 
dialog. See Adjust Sunlight Dialog on page 830.          

Sun Angles can display their date and time in plan view and can also produce sun shadow polylines in plan view. Both Sun 
Angles and their shadows are on the “Sun Angles & Shadows” layer.   

SUN SHADOWS

Sun Angles  allow the program to produce shadows cast by a building that reflect the exact position of the sun in the sky in a 
particular location and at a specific date and time. This position and time information is specified in the Sun Angle 
Specification dialog; the date format is derived from your operating system settings. See Earth Data Panel on page 828 and 
Region and Language Settings on page 58.          

In plan view, sun shadows are represented by polylines filled with a hatch pattern. If a Terrain Perimeter is present, the 
shape of a sun shadow polyline is affected by changes in terrain height. If no Terrain Perimeter exists, sun shadows fall on 
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an imaginary plane at a height of zero, the default height for Floor 1. Sun shadows rebuild whenever the terrain is rebuilt. 
See Build Terrain on page 892.          

No sun shadow generates if the sun is below the horizon or if it is so low on the horizon that the shadow would be 
extremely long.          

Multiple Sun Angles can be placed in the same plan to allow the simultaneous display of shadows cast at different times in 
plan view. Only one should be turned on in 3D views at any given time, however.          

Specify different line colors and/or styles for shadows cast by 
multiple Sun Angles on the Line Style and Fill Style panels of 

the Sun Angle Specification dialog.

To generate the sun shadows associated with a particular Sun Angle, select it and click the Make Shadow  edit button or 

click the Make Shadow button in the Sun Angle Specification dialog. See Lighting Data Panel on page 829.           

There are several ways to delete a sun shadow polyline:          

 l In plan view, select and delete the defining polyline.             
 l In plan view, select and delete the Sun Angle arrow.             
 l In plan view, select the Sun Angle arrow and click the Delete Shadow  edit button.             

 l In the Sun Angle Specification dialog, click the Delete Shadow button. See Earth Data Panel on page 828.             
 l In the Sun Angle Specification dialog, click the Make Shadow button to delete existing shadows and create new ones.

             

 

Sun Angle Specification Dialog
Select CAD> Sun Angle, then click in plan view to open the Sun Angle Specification dialog and create a new Sun 
Angle. See Sun Angles and Shadows on page 825.

To open the Sun Angle Specification dialog for an existing Sun Angle, select it and click the Open Object  edit button. 

This dialog can also be accessed by clicking the Edit button in Adjust Sunlight dialog. See Adjust Sunlight Dialog on page 
830.   
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EARTH DATA PANEL

The settings on the EARTH DATA panel let you establish exactly where your plan’s building site is located, and exactly when 
the sun’s light should be calculated. This information allows the program to generate sunlight and sun shadows with 
accuracy. 

 
Solar Angles

The Solar Angles display for reference and may update as changes are made to the settings on this panel. 

 l The Solar Altitude is the angle of the sun above the horizontal plane, in degrees. 

 l The Solar Direction is the angle between true North and the sun's direction. This is the angle the Sun Angle arrow 
points in plan view relative to the direction of North. See North Pointer on page 825. 

 
Location

                  Specify the Location of the selected Sun Angle. The initial location can be set in the Preferences dialog. See CAD Panel on 
page 78.

 l Specify the Latitude, which is measured either North or South of the equator, depending on which radio button 
you select. 

 l Specify the Longitude, which is measured either East or West of the Greenwich meridian, depending on which 
radio button you select. 

 
Date and Time

Specify the Date and Time of the selected Sun Angle. The initial time zone can be set in the Preferences dialog.

 l Specify a Date for the selected Sun Angle. Select a month from the first drop-down list, a day from the second, 
and a year from the third. 
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 l Specify a Time for the selected Sun Angle. Select an hour from the first drop-down list; minutes in 15 minute 
increments can be selected from the second list.

 l If you want the Sun Angle to observe Daylight Savings Time, check this box.

 l Specify the Time Zone that the building site is located in. 

  Plan View Display

 l Specify the Length of Plan Symbol, which is the length of the Sun Angle arrow in plan view.

 l Check Show Date on Sun Angle to have the date and time display on the Sun Angle arrow in plan view. This 
label uses the Text Style assigned to the “Sun Angle & Shadows” layer. See Text Styles on page 373. 

 l Check Auto Rebuild Terrain to rebuild the terrain automatically whenever you create a sun shadow. If this is 
unchecked and you regenerate sun shadows, the program will prompt you to rebuild the terrain. >See Building the 
Terrain on page 903.

When you use the Build Terrain command in plan view, all sun shadows in the plan are automatically updated.

 l Click the Make Shadow button to create or regenerate the sun shadow in plan view. See Sun Shadows on page 
826.

 l Click the Delete Shadow button to remove the sun shadow from plan view. 

 l Check Always Update to have the program update the selected Sun Angle’s shadow whenever any of the defining 
information is changed. When this is checked, the program may be slower when changes are made in this dialog. 

 l If Always Update is unchecked and you make changes in this dialog, click the Make Shadow button to generate a 
new shadow.

Note: The Make Shadow option does not toggle Shadows, but may 
cause 3D views to update if they are using the selected Sun Angle. See 
Shadows on page 815.

LIGHTING DATA PANEL

A Sun Angle can be used as a light source in 3D views. The settings on the LIGHTING DATA panel control attributes of the 
sunlight associated with the selected Sun Angle. 

The settings defined on the LIGHTING DATA panel do not affect the sun shadow in plan view: they only affect 3D views in 
which lighting and shadows can display.

 l When Casts Shadows is checked, the light source associated with the selected Sun Angle casts shadows. These 
shadows are similar to the shadow shown in plan view, but may render differently based on the presence of other light 
sources. See Shadows on page 815.
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 l Select an Intensity from the drop-down list or specify a value using the text field to define the relative strength of the 
light source. The time of day as set on the EARTH DATA panel does not affect how the Sun Angle renders as a light 
source, but this does.

 l Click the Color bar to select a color for the sunlight associated with the selected Sun Angle. See Select Color Dialog 
on page 135. 

LINE STYLE PANEL

For information about the LINE STYLE panel, see Line Style Panel on page 209.

FILL STYLE PANEL

The settings on the FILL STYLE panel control the appearance of the selected Sun Angle’s shadow in plan view. For 
information about these settings, see Fill Style Panel and Dialogs on page 132.

ARROW PANEL

For information about the settings on the ARROW panel, see Arrow Panel on page 226.

 

Adjust Sunlight Dialog
The Adjust Sunlight dialog allows you to control the intensity, direction and color of the Generic Sun light source in 
the currently active 3D view or to select a Sun Angle to serve as the source of sunlight in the currently active view. 

See Sunlight and Moonlight on page 818.  

The settings in this dialog are view specific. Any changes made to them affect the sun in the currently active 3D view only. 
Other 3D views can have their own unique settings.     

The initial sunlight attributes used in a newly created camera are set in the Sunlight Defaults dialog. See 3D View Defaults 
and Preferences on page 771.    

There are four ways to open the Adjust Sunlight dialog:   

 l Click the Adjust Sunlight button in the Camera and Cross Section/Elevation Specification dialogs. See Camera Panel 
on page 801.

 l From the menu, select 3D> Lighting> Adjust Sunlight.
 l From the toolbar, click Camera View Lighting Tools , then click the Adjust Sunlight  button.

 l Right-click in an empty space in the background area, then select Adjust Sunlight from the contextual menu.
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Use Generic Sun

Select Use Generic Sun to represent the sun in the currently active 3D view using the settings that follow.

 l Use the Intensity slider bar or text field to control the brightness of the Generic Sun's light. This setting is not 
applied in views using the Generated Sky. See Backdrops and Generated Sky on page 817.

 l Click the Color bar to define the color of the light being modeled. Colored sunlight may be used to achieve special 
lighting effects, but may alter the appearance of your material colors and textures. The color selected here is not 
used in views using the Generated Sky.

 l Check Sun Follows Camera to adjust the position of the Generic Sun so that it is always behind the camera, 
illuminating surfaces in the view. When this is checked, the Tilt and Direction Angle settings that follow are 
disabled. This option must be unchecked in order to use the Move Sun and Move Moon tools. See Sunlight and 
Moonlight on page 818.

Note: If the Generated Sky is used in the current view and Sun 
Follows Camera is checked, the Generated Sky will not update if 
the camera is moved.

 l Specify the Tilt Angle, which is the angle of the sunlight with respect to the horizon. A value of 90° means that 
the light points straight up, while a value of -90° means that the light points straight down. 0° is parallel to the 
horizon.

 l Specify the Direction Angle, which is the direction that the sunlight points toward. 0° is measured horizontally on 
screen, pointing to the right. Positive values rotate in a counter-clockwise direction from there, while negative 
values rotate clockwise.

 l Click the Reset to Defaults button to restore the settings set in the Sunlight Defaults dialog in the current view. 

 l In the Sunlight Defaults dialog, the Restore Initial Settings button is available instead. Click this to reset the 
options in that dialog to the originally installed settings.

 
Use Sun Angle

Select Use Sun Angle to represent the sun using a light source defined by a Sun Angle . See Sun Angles and Shadows on 

page 825.    

 l Select a Sun Angle from the drop-down list to serve as the source of sunlight in the currently active 3D view. If no 
Sun Angle is present, the Generic Sun is used.
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 l Click the Edit button to open the Sun Angle Specification dialog for the selected Sun Angle. 
By default, the Generic Sun light color is pure white, which has the least effect on the appearance of material colors and 
textures. See Materials on page 745.

 

Rendering Techniques
Any camera view, cross section/elevation view, or overview can be generated using one of several Rendering 
Techniques to produce views for a range of different purposes: from detail drawings to artistic presentation views. To 

access these tools, while a 3D view is active, select 3D> Rendering Techniques, then select one of the following 
techniques: 

There are three ways to create a view using a particular Rendering Technique:         

 l Specify the default Rendering Technique as well as an Alternate Rendering Technique for most camera tools in the 
Camera Defaults dialogs. See Alternate Rendering Technique on page 777.

 l Create a 3D view, then select the desired Rendering Technique from the menu.              
 l Select the desired Rendering Technique in the Camera Defaults dialog, then create a 3D view. See Camera Defaults 

Dialogs on page 772.             

Once a view is created, the effects of the selected Rendering Technique can be adjusted in the Rendering Technique Options 
dialog. See Rendering Technique Options on page 834.          

If a camera view is saved, its Rendering Technique settings are saved, as well. See Saving and Printing 3D Views on page 
800.          

The Watercolor technique requires more time to generate than 
other Rendering Techniques. To save time, adjust the camera’s 

perspective before using one of these techniques. See Editing 3D Views 
on page 791.

STANDARD RENDERING

Standard rendering is a photo-realistic technique that represents materials using textures, models lighting and 
shadows, and can also display reflections. Surface edge lines are not drawn and no special colors or effects are 

applied.

In plan view, the camera symbol for a view using the Standard technique displays an S in its center. See Displaying 3D 
Views on page 783.

VECTOR VIEW

In Vector Views, surface edge lines are drawn and pattern lines and colors are used to represent materials while 
textures are not. Shadows are supported, and when in use a single light source is used to produce them. Shading 

832



Home Designer Pro 2025 Reference Manual - Rendering Techniques

Contrast can be applied to surfaces, but other special colors or effects are not.             

In plan view, the camera symbol for a view using the Vector View technique displays a V in its center.         

PHYSICALLY BASED

Physically Based rendering is similar to the photo-realistic Standard technique: it represents materials using textures, 
does not draw surface edge lines, models lighting, and can display shadows. Not available in Orthographic Cross 

Section/Elevation views.

Physically Based rendering models material properties and light propagation more accurately than other rendering 
techniques and is best used when a focus on lighting and finish materials is the goal.

In plan view, the camera symbol for a view using the Physically Based technique displays a Ph in its center.

GLASS HOUSE

Glass House rendering uses different shades of a single color to display the model with surface edge lines and semi-
transparent surfaces. Lighting and shadows are not modeled, and materials are not represented, so neither pattern lines 

nor textures are used. 

In plan view, the camera symbol for a view using the Glass House technique displays a G in its center.

TECHNICAL ILLUSTRATION

Technical Illustration rendering draws surface edge and pattern lines, and uses shades of two colors, Warm and Cool. 
The warm shade is applied to surfaces that face the light source in the view, and the cool shade, to surfaces that face 

away from it.
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Only one light source is used: the light with the highest Intensity found in the room containing the camera. In exterior 
views, this light is always the Generic Sun. If no lights are on, a fallback light is used. Lighting is modeled as non-
photorealistic, stylized highlights and shadows are supported. See Lighting on page 817.         

In plan view, the camera symbol for a view using the Technical Illustration technique displays a T in its center.         

WATERCOLOR

Watercolor rendering approximates the effects of watercolor painting such as pigment pooling and flow. It uses 
textures to represent materials and models lighting, shadows, and reflections.

In plan view, the camera symbol for a view using the Watercolor technique displays a W in its center.         

Note: In some plans, the Watercolor techniques may take a considerable 
amount of time. You can press the Esc key to cancel the rendering.

 

Rendering Technique Options
The settings in the Rendering Technique Options dialog allow you to control the specific effects of each rendering 
technique on an active 3D view. To access this dialog, create a camera view, cross section/elevation view, or 

overview and select 3D> Rendering Techniques> Technique Options.

The Rendering Technique Options dialog can also be accessed by clicking the Define button in the active view's 
specification dialog. See Camera Panel on page 801.

This dialog can also be accessed by double-clicking the Rendering Techniques  parent button. 

The settings in the Rendering Technique Defaults dialog are the same as those in this dialog, but control the initial settings 
of each technique when it is first applied.     

In the Rendering Technique Options dialog, select a technique from the list on the left to make its options active on the 
right. When this dialog is first opened, the technique currently used by the view is selected. 

As changes are made in the Rendering Technique Options dialog, the 3D view automatically updates to reflect those 
changes for all techniques except Watercolor. To update views using these techniques, which take more time to draw than 
the others, click the Update button in the dialog. 

834



Home Designer Pro 2025 Reference Manual - Rendering Technique Options

When a 3D view is saved, its Rendering Technique Options settings are saved, as well. See Saving 3D Views on page 800.   

The Rendering Technique Options dialog has the following panels:

STANDARD PANEL

The active 3D view immediately updates to reflect any changes made to the Rendering Technique Options for 
Standard renderings. 

There are a variety of other tools that affect the appearance of Standard rendered views, as well. See Displaying 3D Views 
on page 783. 

  General

 l When Use Backdrop Image When Available is checked, the backdrop image specified for this view is used. When 
unchecked or if no backdrop image is specified for the current view, the specified Backdrop Color is used instead. 
See 3D Backdrops on page 841.

 l Check Opaque Window Glass to make the glass in windows and exterior doors opaque. When unchecked, door and 
window glass is transparent. See Material Transparency on page 816.     

 l When Opaque Window Glass is checked, specify the color of door and window glass:

 l Select Use Material Color to use the glass material's color. See Patterns and Textures on page 746.

 l Select Use Custom Color to click the Color button and select a glass color. See Select Color Dialog on page 135.     

 
Ambient Light

Specify the amount of Ambient light to use in different situations in Standard and Watercolor renderings. See Ambient 
Lighting and Occlusion on page 819.

 l Interior Ambient affects interior views.    

 l Daytime Ambient affects exterior views.

 l Nighttime Ambient affects nighttime exterior views.
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  Reset

 l Click Reset to Defaults to apply the Standard settings defined in the Rendering Technique Defaults dialog.     

 l In the Rendering Technique Defaults dialog, the Restore Initial Settings button is available instead. Click this to 
reset the options on this panel to the system defaults.

VECTOR VIEW PANEL

The active 3D view immediately updates to reflect any changes made to the Rendering Technique Options for Vector 
Views.   

Additional settings that affect the appearance of Vector Views can be found in the 3D View Defaults dialog. See 3D View 
Defaults Dialog on page 774.    

There are a variety of other tools that affect the appearance of Vector Views. See Displaying 3D Views on page 783.    

 l Check Use Backdrop Image When Available to use the backdrop image specified for this view. When unchecked or 
if no backdrop image is specified for the current view, the specified Backdrop Color is used instead.

 l Check Opaque Window Glass to make the glass in windows and exterior doors opaque. When unchecked, door and 
window glass is transparent. See Material Transparency on page 816.      

 l When Opaque Window Glass is checked, specify the color of door and window glass:
 l Select Use Material Color to use the glass material's color. See Patterns and Textures on page 746.
 l Select Use Custom Color to click the Color button and select a glass color. See Select Color Dialog on page 135.      

 l Specify the Shadow Intensity, which is how dark or light shadows appear. A value of 100% creates shadows that hide 
any objects located within them; a value of 0% effectively produces no shadows.    

 l When Apply Shading Contrast is checked, different levels of shading is used on surfaces oriented at different angles 
in the model. Uncheck this box to use unmodified material Colors on all surfaces, regardless of the angle. Each 
material’s Shading Contrast can be set individually. See Pattern Panel on page 761.

 l Click Reset to Defaults to apply the Vector View settings defined in the Rendering Technique Defaults dialog.     
 l In the Rendering Technique Defaults dialog, the Restore Initial Settings button is available instead. Click this to 

reset the options on this panel to the system defaults.

PHYSICALLY BASED PANEL

This panel is only available in Perspective camera views and overviews. The active 3D view immediately updates to 
reflect any changes made to the Rendering Technique Options for Physically Based renderings.    
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There are a variety of other tools that affect the appearance of Physically Based rendered views, as well. See Rendering Tips 
on page 815.    

  General

 l When Use Backdrop Image When Available is checked, the backdrop image specified for this view is used. When 
unchecked or if no backdrop image is specified for the current view, the specified Backdrop Color is used instead.

 
Exposure

Exposure is the amount of light in the scene that is captured by the camera. A low value produces a darker view; too high a 
value can make the scene look washed out.

 l When Automatic Exposure is selected, the program automatically adjusts luminance in the scene based on the light 
sources in use.

 l Select Manual Exposure to manually adjust the level of luminance. This can sometimes be helpful in some dimly lit 
scenes.

 l Specify the view's Tone Mapping Operator, which is a method of color processing that enhances the quality of 
highlights and shadows in the scene. 

 o Select Hable for somewhat lower color saturation. This option is often more suitable for interior scenes.

 o Select ACES for somewhat greater color saturation, particularly of bright colors, which may be preferable in exterior 
scenes.   

  Global Illumination

 l Specify the Daytime Background Intensity, which is the brightness of the view's background color or backdrop 
image when the Sunlight is toggled on. See Backdrop Panel on page 806.

 l Specify the Nighttime Background Intensity, which is the background brightness when the Sunlight is toggled off. 
See Sunlight and Moonlight on page 818.
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 l Check Use Only Backdrop for Lighting to prevent the Sunlight from lighting the scene without toggling it off. This 
option is useful for overcast daytime scenes.

 
Color Adjustment

You can adjust the Hue, Saturation, and Brightness of the view, if needed.     

  Reset

 l Click Reset to Defaults to apply the Physically Based settings defined in the Rendering Technique Defaults dialog.     

 l In the Rendering Technique Defaults dialog, the Restore Initial Settings button is available instead. Click this to 
reset the options on this panel to the system defaults.     

GLASS HOUSE PANEL

The active 3D view immediately updates to reflect any changes made to the Rendering Technique Options settings 
for Glass House renderings. 

 l When Use Backdrop Image When Available is checked, the backdrop image specified for this view is used. When 
unchecked or if no backdrop image is specified for the current view, the specified Backdrop Color is used instead. See 
3D Backdrops on page 841.

 l Click the Color bar to select a color for the semi-transparent surfaces and lines in a Glass House view. See Select 
Color Dialog on page 135.    

 l Specify the Transparency of the surfaces in Glass House view. For example, to create a wireframe line drawing of 
your structure, turn transparency to full and minimize line thickness.    

 l Specify the Line Thickness of surface lines in Glass House view.    
 l Click Reset to Defaults to apply the Glass House settings defined in the Rendering Technique Defaults dialog.             

 o In the Rendering Technique Defaults dialog, the Restore Initial Settings button is available instead. Click this to 
reset the options on this panel to the system defaults.

TECHNICAL ILLUSTRATION PANEL

The active 3D view immediately updates to reflect any changes made to the Rendering Technique Options settings 
for Technical Illustration renderings.    
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  General

 l When Use Backdrop Image When Available is checked, the backdrop image specified for this view is used. When 
unchecked or if no backdrop image is specified for the current view, the specified Backdrop Color is used instead. 
See 3D Backdrops on page 841.

 l Check Opaque Window Glass to make the glass in windows and exterior doors opaque. When unchecked, door and 
window glass is transparent. See Material Transparency on page 816.       

 l When Opaque Window Glass is checked, specify the color of door and window glass:

 l Select Use Material Color to use the glass material's color. See Patterns and Textures on page 746.

 l Select Use Custom Color to click the Color button and select a glass color. See Select Color Dialog on page 135.        

  Effects

 l Click the Color bar to select a Warm Color for surfaces that face the light source and a Cool Color for surfaces 
that face away from the light. See Select Color Dialog on page 135.     

 l Specify the Warm Blend, which is the degree to which the selected Warm Color is blended with original colors on 
well-lit surfaces in the view.      

 l Specify the Cool Blend, which is the degree to which the selected Cool Color is blended with original colors on 
shaded surfaces in the view.      

 l Specify the Line Thickness of all surface edge and pattern lines in the view. Surface Edge Line color in Technical 
Illustrations can be set by layer in the Layer Display Options dialog when Use Layer Settings is selected in the 3D 
View Defaults dialog. Some objects' Surface Edge Line color can also be set per object. See 3D View Defaults 
Dialog on page 774.     

  Reset

 l Click Reset to Defaults to apply the Technical Illustration settings defined in the Rendering Technique Defaults 
dialog.     
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 l In the Rendering Technique Defaults dialog, the Restore Initial Settings button is available instead. Click this to 
reset the options on this panel to the system defaults.

WATERCOLOR PANEL

In order for the active 3D view to reflect changes made to the Rendering Technique Options settings for Watercolor 
renderings, you must click either the OK button or the Update View button in the dialog. This may take several 

moments.    

  General

 l When Use Backdrop Image When Available is checked, the backdrop image specified for this view is used. When 
unchecked or if no backdrop image is specified for the current view, the specified Backdrop Color is used instead.

 l Check Opaque Window Glass to make the glass in windows and exterior doors opaque. When unchecked, door and 
window glass is transparent. Opaque Window Glass is not available when the Base Technique is Physically Based. 
See Material Transparency on page 816.       

 l When Opaque Window Glass is checked, specify the color of door and window glass:                         

 o Select Use Material Color to use the glass material's color. See Patterns and Textures on page 746.

 o Select Use Custom Color to click the Color button and select a glass color. See Select Color Dialog on page 135.        

 l Specify the Base Technique, which is the Rendering Technique used to render the scene prior to applying 
Watercolor Effects. Not available in Orthographic views.

  Effects

 l Specify the Smooth Amount, which is the degree to which details are removed from the original view.     

 l Specify the Paint Contrast, which determines the extent to which variations in pigment color are used.      

 l Specify the Turbulence Strength, which produces “pooling”, or variations in the strength of pigment colors.     

840



Home Designer Pro 2025 Reference Manual - 3D Backdrops

 l Specify the Turbulence Scale, which controls the size of the areas of pooling.     

 l Specify the Pigment Settling Strength, which is creates the appearance of pigment settling into low areas in paper.     

 l Specify the Edge Strength, which is how well-defined surface edge lines are.     

  Reset

 l Click Reset to Defaults to apply the Watercolor settings defined in the Rendering Technique Defaults dialog.     

 l In the Rendering Technique Defaults dialog, the Restore Initial Settings button is available instead. Click this to 
reset the options on this panel to the system defaults.     

 l Views using the Watercolor technique do not update as changes are made to the settings here as they do with most 
Rendering Techniques. Click Update View to apply any changes to these settings to the current view.

 

3D Backdrops
A backdrop is an image, typically of an exterior view, that displays in the background of 3D views to help place the model 
into a realistic setting and add a sense of perspective.          

In Physically Based renderings, backdrop images can also contribute to the Global Illumination of the scene. See Physically 
Based Panel on page 836.

Backdrops automatically adjust to fit each view window, so they look best when they are created with a height to width 
ratio that is similar to the window you are working in.         

SPECIFYING A BACKDROP IMAGE

Backdrop images are view specific. You can select a backdrop image for a camera view from the library in either of two 
ways:          

 l In a 3D view, open the Library Browser. Select a Backdrop image, then move your mouse pointer   into the view 
window. Click anywhere in the view to apply the selected backdrop.          

 l Open the Camera Specification dialog, and on the BACKDROP panel, click the Select Backdrop button. See Backdrop 
Panel on page 806.

 l You can also specify a backdrop image for the material preview panes in the Library Browser and Select Material, 
Define Material, Plan Materials dialogs. See Dialog Preview Panes on page 21.       

In Physically Based renderings, High Dynamic Range images in .hdr file format can be used to create high-quality 
backdrops that also provide more realistic scene lighting. This file format is often used for Spherical Panoramic Backdrops. 

When a backdrop image is not applied, Home Designer applies a background color instead. This color can be specified on 
the BACKDROP panel of the Camera Specification dialog, as well.          
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You can create digital photos of a building site for use as 
3D backdrops.

SPHERICAL PANORAMIC BACKDROPS

Spherical Panoramic Backdrops are a special type of backdrop that wraps around the model in Perspective 3D views as 
though it were applied to a sphere surrounding it. Although any backdrop image can be specified as a Spherical Panoramic 
Backdrop, it takes an image processing program or special camera to generate an image that will function properly as such. 
If you have such a file, you can assign it to a custom Backdrop, then check Spherical Panoramic Backdrop in its 
Backdrop Specification dialog. See Backdrop Specification Dialog on page 843. 

You can create a Spherical Panoramic Backdrop by exporting a camera view or overview as a 360 Panorama. See Export 
360 Panorama on page 887.  

When in use, Spherical Panoramic Backdrop images can be rotated horizontally by selecting 3D> Camera View 
Options> Rotate Spherical Backdrop, and offset both vertically and horizontally in the Camera Specification 

dialog. See Backdrop Panel on page 806.

The Use Generated Sky option produces a special Spherical Panoramic Backdrop that simulates a daytime sky using the 
Generic Sun or active Sun Angle  data. See Sun Angles and Shadows on page 825. 

When the Generated Sky is in use, a horizon line is modeled: in a camera with a Tilt Angle of 0°, it runs across the center of 
the view window. As the sun is moved closer to the horizon, its intensity decreases and its color becomes an increasingly 
deep amber color. When the sun is moved below the horizon it may continue to contribute to light to the sky, but it will not 
cast light on the model. When the sun is either below the horizon or toggled off, representations of the moon and stars 
become visible. See Sunlight and Moonlight on page 818.

Note: Spherical Panoramic Backdrops, including the Generated Sky, 
cannot be used in Orthographic Overviews.

BACKDROP DEFAULTS

By default, Home Designer uses backdrop images in Perspective Full Cameras only. You can, however, specify 
which types of views use backdrops by default, and also select the default backdrop images for each, in the Camera 

Tools Defaults dialogs. See Camera Defaults Dialogs on page 772.

Similarly, backdrop images are only used by default in              a few Rendering Techniques: Standard, Watercolor, and 
Physically Based. You can choose whether a backdrop is used in any technique in the Rendering Technique Options 

dialog. See Rendering Technique Options on page 834.         

ADDING NEW BACKDROPS

A new backdrop image can be created using a variety of graphic file formats - including High Dynamic Range .hdr - and 
can be imported into Home Designer in several ways:         

 l Select File> Import> Backdrop  to open the Import Backdrop File dialog, which is similar to the Import Picture 

File dialog. See Importing Pictures on page 853.         
 l Right-click on the User Catalog and select New> Backdrop from the contextual menu.         
 l Copy and paste an image into Home Designer. See Copying and Pasting Objects on page 118.          
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Backdrop Specification Dialog
To open the Backdrop Specification dialog, select File> Import> Import Backdrop or right-click on the User 
Catalog in the Library Browser and select New> Backdrop from the contextual menu. See Adding New Backdrops 

on page 842.         

You can also open this dialog by right-clicking on a backdrop image in the User Catalog in the Library Browser and 
selecting  Open  from the contextual menu.           

 
Preview

A preview of the selected image displays here.          

 
Backdrop

Specify backdrop’s Name and the image file associated with it.         
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 l Type a Name for the selected backdrop, to be used in the Library Browser and 3D View Defaults dialog.          

 l In the Location field, type the full pathname of the image file or click the Browse button and browse to the file on 
your computer. If the file is not located in the Home Designer Pro 2025 Data folder, a copy of the file will be 
created at Home Designer Pro 2025 Data\Backdrops\-My Backdrops and the program will reference that copy. See 
Home Designer Pro Data on page 35.          

 
Spherical Backdrop Options

A backdrop should only be specified as a Spherical Panoramic Backdrop if its image file was specially created for this 
purpose. See Spherical Panoramic Backdrops on page 842.     

 l Check Spherical Panoramic Backdrop to place the selected backdrop onto a sphere that surrounds the model in the 
current view.      

 o When an .hdr backdrop image is imported, it is automatically set to be a Spherical Panoramic Backdrop.

 l Horizontal Tile - Specify how many times to tile the selected backdrop image side by side.      

 l Vertical Tile -  Specify how many times to stack the selected backdrop image one above the other.      

 l Specify the Horizontal Span, which is how much of the sphere the backdrop is applied to. A Span of 360° wraps 
the entire sphere.      

 l Specify the Horizontal Offset, in degrees, to shift the backdrop image or tiled images in a clockwise direction. The 
Horizontal Offset can also be adjusted using the Rotate Spherical Backdrop  tool. See Backdrops and 

Generated Sky on page 817.     

 l Specify the Vertical Max, which is the height of the bottom of the backdrop, measured relative to the top of the 
sphere.      

 l Specify the Vertical Min, which is the height of the bottom of the backdrop, measured relative to the bottom of the 
sphere.     

 l The Eye Level setting controls the vertical position of the camera within the sphere. A value of 0 positions the 
camera at the bottom of the sphere while a value of 1 positions it at the top. The default value is 0.5., which centers 
the camera inside the sphere.    

Some experimenting with the Angle values may be necessary to achieve the desired results. You may prefer to do this after 
adding the backdrop to a plan. See Backdrop Panel on page 806.         

 
Copyright

If the selected image has a Copyright, information about it will display here.          
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Chapter 33
 

Pictures, Images, and Walkthroughs

Home Designer uses picture files in a variety of ways to enhance your drawings. 

The Library Browser contains images of real world objects like plants and vehicles that can display in 3D views.

Picture files can also be imported into Home Designer and shown in most views. 

You can save any view using a variety of picture file formats. In addition, Home Designer allows you to create virtual tour 
videos that can be played back later and shared with others.
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Editing Images 848
Image Specification Dialog 849
Pictures 852
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Picture Files vs Pictures and Image Objects
In common computer language, picture files, pictures and images are more or less synonymous. In the Home Designer 
environment, however, there are some notable differences between these terms.         

In Home Designer, a two dimensional image file such as a .bmp, .jpg, .gif, or .png is referred to as a picture file or an image 
file. Examples of these files are saved on most computers and can be opened in a variety of applications.          

A Picture, on the other hand, is a file that has been imported into the program. Pictures can be imported into plan view, 
cross section/elevation views, and layout pages. They are two-dimensional only and do not display in camera views or 
overviews.          

An Image object is also based on a picture file, but it does display in both 2D and 3D views. Images have 3D width and 
height data associated with them, as well as a 2D symbol which displays in plan view.          

Picture files have additional uses in Home Designer, as well:         

 l Backdrops are picture files that display behind 3D views. See 3D Backdrops on page 841.         
 l Textures are picture files that realistically represent materials in 3D views. See About Materials on page 746.          

 

Images
Images add realistic detail to 3D views without adding many surfaces to the model. For example, a tree image with a single 
surface can be used instead of a tree symbol with thousands, dramatically improving realism without compromising drawing 
time.         

There are two types of Images in Home Designer:          

  Images rotate so that they always face the camera in 3D views.         

  Billboard Images do not rotate to face the camera. An example of when this may be useful is an image of a 
trellis, which might look awkward when facing a camera from a side view.          

PLACING IMAGES

A selection of Images are available in the Library Browser. Select one and click in a plan view, camera view or 
overview to place it. See Placing Library Objects on page 714.

Once created, Images can be edited using their edit handles, edit tools, and their specification dialog. See Editing Images on 
page 848.

CREATING IMAGES

Custom Images can be added to the User Catalog in the library, as well as created in plan files. Home Designer can use any 
image with a *.bmp, *.jpg, *.png, *.gif, or  *.tif extension.         

Generally, .png files work best as Images because this format has good compression and allows for the Image to contain 
transparency information.         
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To create an Image in plan view

 1.  In plan view, select Build> Image> Create Image  or Billboard Image  to open the Image Specification 

dialog. See Image Specification Dialog on page 849.         

 2.  On the IMAGE panel:         

 l Click the Browse button to select a picture file on your computer or enter the path to a valid picture file in the 
Image File field. If the file is not located in the Home Designer Pro 2025 Data folder, a copy of the file will be 
created at Home Designer Pro 2025 Data\Images\-My Images and the Image object will reference that copy. See 
Home Designer Pro Data on page 35.          

 l Select a 2D Plan Symbol from the drop-down list or click the Library button and select a symbol from the 
library. The selected symbol represents the image in plan view. See Image Panel on page 849.         

 l Specify the Size and Position of the image.          

 3.  Specify transparency information on the TRANSPARENCY panel.          

 4.  Click OK to close the Image Specification dialog.         

 5.  Click to place the new Image in plan view.          

To create an image in the Library Browser

 1.  In the Library Browser, right-click on an unlocked folder.         

 2.  Select New> Image from the contextual menu to open the Image Specification dialog.          

 3.  Browse to the image file you want to add and select your other options. See Image Specification Dialog on page 
849.           

 4.  Once created, the image is listed in the library folder that you right-clicked on. Size and other data is saved.          

USING PASTE IMAGE

You can also import an image by first copying it to the system clipboard, then navigating to a Home Designer 
window and selecting Edit> Paste> Paste. See Paste Special on page 122.          

 

Displaying Images
The display of images in floor plan and 3D views is controlled in the Layer Display Options dialog. See Layer 
Attributes on page 125.

Images are placed on the “Images” layer.         

IN PLAN VIEW

In plan view, images display in front of most other objects, will print, and can be included in views sent to layout or 
exported to .dxf/.dwg.

In plan view, most images are represented by an Image   symbol. You can specify a different symbol to represent an 
image if you wish. See Image Specification Dialog on page 849.          
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IN 3D VIEWS

The actual picture associated with an Image object can be seen in most 3D views, as can any transparency data associated it. 
See Image Specification Dialog on page 849.         

Images can be set to either rotate so that they always face the camera or remain stationary, like billboards. See Images on 
page 846. 

Images can display in all Rendering Techniques except  Glass House. See Rendering Techniques on page 832.

IN LAYOUT VIEWS

Images can be included in all views sent to layout with the exception of those using Plot Lines. See Plot Line Views on page 
977.         

IN MATERIALS LISTS

Plant Images are included in the Materials List by default while regular Image objects are not. If you wish to include one, 
you need to create a custom Component in its specification dialog, then generate a new Materials List.  See Object 
Components on page 967.      

IN SCHEDULES

Plant Images can be listed in Plant Schedules while regular Image objects cannot. See Plant Schedules on page 943.     

 

Editing Images
Images can be selected in 2D and 3D views and edited using the edit handles, edit tools and the Image Specification dialog. 
See Image Specification Dialog on page 849.         

USING THE EDIT HANDLES

In plan view, a selected image can be rotated, moved, and resized. In 3D views, a selected image only has two edit handles: 
the circular Resize handle and square Move handle.          

When an image is resized using the edit handle, its aspect ratio is retained and 2D symbol resizes proportionally.         
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USING THE EDIT TOOLBAR

A selected image or images can be edited in a variety of ways using the buttons on the Edit Toolbar. See The Edit Toolbar 
on page 92.         

USING DIMENSIONS

Dimension lines can locate the centers of Image objects and can be used to move these objects \in plan view, but not 
in cross section/elevation views. See Moving Objects Using Dimensions on page 341. 

In order for a manually drawn Dimension Tool to locate image objects as a dimension line is drawn, it must be set to do so 
in the Dimension Defaults dialog. See Locate Manual Panel on page 325.

 

Image Specification Dialog
Select an image and click the Open Object edit button to open the Image Specification dialog. 

IMAGE PANEL

 
General

General information about the selected Image can be specified here.         

 l The Image File associated with the Image can be specified. Click Browse to choose a file saved on your computer 
or type the file’s full pathname in the text field.              

 l Select a 2D Plan Symbol from the drop-down list to represent the Image in plan view. See Displaying Images on 
page 847.             
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Size/Elevation

Specify the Size/Elevation of the image as it displays in 3D views.         

 l Enter a Height for the selected image.              

 l Enter a Width for the selected image.              

 l Uncheck Retain Aspect Ratio of X if you would like to modify the Height or Width without affecting the other 
value. If you do this, the image may appear distorted. 
This check box does not affect editing performed outside this dialog and is an action rather than a state: the next time 
you open this dialog, it will be checked.             

 l Click Reset Original Aspect Ratio of to reset the image’s original aspect ratio and remove any distortion caused by 
resizing.             

 l Select the Elevation Reference from the drop-down list. This determines where the next two settings are measured 
from and also affects their setting labels. See Elevation References on page 20.             

 o Specify the height to Top, measured from the selected Elevation Reference to the top edge of the image.         

 o Specify the height to Bottom, measured from the selected Elevation Reference to the bottom edge of the image.         

 
Center Point

Specify the location of the X and Y Coordinates of the selected image’s Center Point.         

  Options

 l Check Reverse Image to reflect the appearance of the image about an imaginary vertical line through its center.              

 l Check Image Always Faces Camera to prevent the image from rotating to face the camera in 3D views. This box is 
unchecked by default for Billboard Images. See Images on page 846.             

 
Copyright

Any Copyright information associated with the selected Image will be stated here.          

 
Preview

A preview of the selected Image displays here. The Glass House Rendering Techniques is not available for images. See 
Dialog Preview Panes on page 21.          

TRANSPARENCY PANEL

The settings on the TRANSPARENCY panel let you specify portions of the selected image as transparent.         
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 l Click the Use Transparency From The Image File radio button to use any transparency data included in the image 
file.             

 l Click the Use Custom Transparency Color radio button to specify a color in the image to represent the transparency 
and enable the settings below.              

 l Click the Color bar to select a color in the Select Color dialog. See Select Color Dialog on page 135.             
 l Use the slide bar or enter a value to specify a level of Tolerance to be applied to colors that are almost the same as the 

specified transparency color.             
 l Move your pointer over the small preview image below. The pointer changes to an eyedropper and a magnified 

preview displays to its right. Click to select the color of the pixel your pointer is over as the Transparency color. The 
selected color displays in the Color bar, below.             

 l A magnified preview of the area in the preview image above displays here, allowing for accurate pixel selection.             

Note: The image preview will display its original orientation, even if 
Reverse Image is checked on the Image panel.

The Transparency Color

If the portion of the image file that you wish to use contains the transparency color, that part of the image also becomes 
transparent. If this happens, the image may appear partially disintegrated.         

You may need to experiment to find the best transparency color and tolerance for the image.         

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected image’s 2D Plan Symbol in plan view, provided 
that the selected symbol is a closed shape. For information about these settings, see Fill Style Panel and Dialogs on page 
132.         

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 967.          
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Pictures
A variety of picture file types can be imported into and exported out of Home Designer.

Metafiles are also types of picture files that can be imported and exported. See Metafiles on page 856.

EXPORTING PICTURES

There are several ways to save a picture of a view in Home Designer:

Using the Export Picture tool is similar to creating a screen capture of everything  in the current view window. 
Pictures can be saved in various file formats and used in other applications. Export Picture is best suited for 

rendered views. When exporting a line-based view, best results can be achieved by saving it as a metafile. See To export a 
metafile on page 857.

The Export 360 Panorama tool creates a spherical panoramic image file. See Export 360 Panorama on page 887.         

Use the Print Image tool to either print or save the current view as a PDF file. See Print Image Dialog on page 
1004.

To export a picture

 1.  Open the view that you would like to export as a picture file. 

 2.  Zoom, pan or otherwise adjust the view so that what you see on screen suits your needs. See Displaying 3D Views 
on page 783.

 3.  Select File> Export> Export Picture (BMP, JPG, PNG)  to open the Export Picture dialog, below, and specify 

the desired image size and other properties.         

Physically Based renderings can be exported as High 
Dynamic Range .hdr files. See Rendering Techniques on page 

832.

 4.  In the Export Picture File dialog, which opens next, give the new picture file a name, file type, and save location. 
See Exporting Files on page 39.          

EXPORT PICTURE DIALOG

The settings in this dialog are retained between program sessions.
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Image Size

Specify the exported file’s Image Size in pixels or inches (mm).         

 l Check Use Active Window Size to export the picture at the same size as the active view window. The window’s 
Width and Height are described below. In camera views only, these values can be changed, in which case this box 
becomes unchecked automatically.         

 l Select either Pixels or Units as the method by which the picture’s dimensions are measured.             

 l Specify the Width and Height of the image. The initial values correspond to the view window’s size. In plan view, 
they display for reference only.             

 l Specify the Resolution of the image. Select Dots/Inch or Dots/mm from the drop-down list.             

 l Uncheck Retain Aspect Ratio if you would like to modify the Height or Width without affecting the other value. 
Leave this box checked to prevent the image from becoming distorted.             

 
Image Properties

Check Transparent Background to produce alpha transparency in the spaces between all objects that can be seen in the 
current view. Transparency associated with Fill and Text Styles is retained, as well. Note that the .png and .png file types 
support transparency, while the .jpg and .bmp file types do not. 

 
Options

When Open in Default Image Viewer is checked, the exported image will open in your system's default image viewer 
program when the export is complete. Uncheck this box if you prefer that the exported image not be opened. 

When you click OK, the Export Picture File dialog will open, allowing you to specify a name, file type, and save location 
for the picture file. If the exported picture is larger than the view window, a progress dialog may display as it is created. See 
Save File Dialog on page 38.

IMPORTING PICTURES

Pictures can be imported into and displayed in plan view, cross section/elevation views, and layout pages. Pictures do 
not display in camera views or overviews. See Displaying Pictures, Metafiles, and PDF Boxes on page 861.         

There are several ways to import a Picture into Home Designer:         
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 l Select File> Import> Import Picture (BMP, JPG, PNG) to open the Import Picture File dialog, which is a typical 
open file dialog. See Importing Files on page 43.          

 l Click and drag an image file from an operating system window into the Home Designer window.             
 l In any application, copy an image to the system clipboard, then select Edit> Paste> Paste Special  from the 

program menu in an eligible view window. See Paste Special on page 122.         

Note: Importing large, or multiple, Pictures into a plan or layout file can 
result in program slowness. 

An imported picture is placed in the center of the current view. Once imported, pictures can be selected and edited. See 
Editing Pictures, Metafiles, and PDF Boxes on page 862.

If the file referenced by a picture object is modified outside Home Designer, its appearance will not update in Home 
Designer until you close and reopen the plan or layout file it was imported into.

 

Picture File Box Specification Dialog
Select an imported picture file and click the Open Object edit button to open the Picture File Box Specification 
dialog.         

GENERAL PANEL

 
Picture File

Information about the selected Picture File can be specified here.         
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 l The Filename of the picture file displays here. You can type a new pathname in the text field to change the picture 
assigned to this box if you wish. If the selected picture box is not linked to a file saved on the system, a Caution   
symbol will display in the text field.         

 l Click the Browse button to choose a new picture file or to relink to a missing file.          

 l Check Save in Plan to embed the picture in the plan or layout file. If a picture file is embedded, it does not need to 
be linked to a file on the system and you do not need to include it when sending the plan or layout to a different 
computer.          

 l Click the radio button beside either PNG or JPEG to specify how to save the embedded picture data.   

 l Specify the picture’s Quality % when JPEG is selected. A lower value results in better compression, while a higher 
value reduces data loss.           

Note: PNG is the better option for pictures of line drawings, text, or large 
areas of a single color. In addition, PNG files support alpha channel 
transparency. JPEG is the better option for photos. 

 
Center/Orientation

Specify the position of the selected Picture’s center point and its angle. See 3D Drafting on page 12.         

 l Specify the X and Y Positions of the picture box’s center point relative to the absolute origin.           

 l Specify the Angle of the picture box relative to a horizontal line pointing towards the right-hand side of the screen.          

 
Size

Specify the Size of the picture in plan inches (mm).             

 l Specify the Width of the picture box. The original width in pixels displays to the right.          

 l Specify the Height of the picture box. The original height in pixels displays to the right.          

 l Uncheck Retain Aspect Ratio of X if you would like to modify the Height or Width without affecting the other 
value. If you do this, the picture may appear distorted. This check box does not affect editing performed outside this 
dialog and is an action rather than a state: the next time you open this dialog, it will be checked.          

 l Reset Original Aspect Ratio - If the aspect ratio is changed, you can click this button to return the picture to its 
original aspect ratio.           

 l Check Reset Cropping to fill the extents of the selected Picture box with the image associated with it. If the box has 
been resized, the image may appear distorted. See Editing Pictures, Metafiles, and PDF Boxes on page 862.          

 
Display Options

A variety of Display Options are available.             

 l Check Grayscale to replace the color in the selected picture with shades of gray.          

 l Check Reflect to reverse the image.          

 l Enter a degree of Brightness from 1 - 100%.          

 l Enter a degree of Contrast from 1 - 100%.          

 
Preview

A preview of the selected Picture displays here. See Dialog Preview Panes on page 21.   
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LINE STYLE PANEL

The settings on this panel are similar to those on the LINE STYLE panel in numerous other dialogs, with one exception: 
check Show Outline to turn on the display of the picture’s border polyline. For more information, see Line Style Panel on 
page 209.         

 

Metafiles
A metafile (.emf, .wmf) is a special picture file format made up of vectors (lines) that allow the image to be rescaled 
without loss of quality. High resolution pictures of line-based views can be exported as a metafile.

Note: Metafiles are not supported in Mac operating systems and cannot 
be imported or exported in Mac versions of the software. 

EXPORTING METAFILES

An enhanced metafile (.emf) can be exported from any line-based view: that is, from plan view and 3D Vector 
Views. 

Only objects that display on screen are included in an exported metafile. 
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To export a metafile

 1.  Accurately position the view on screen.

 2.  Select File> Export> Export Metafile (EMF) .

 3.  Drag a marquee   from corner to corner, defining the area to be included in the metafile.

 4.  Release the mouse button to open the Export Metafile dialog, which is a typical Save File dialog. See Exporting 
Files on page 39.

 5.  When you click the Save button, the Metafile Size dialog opens.

 6.  Specify the desired Width or Height of the metafile. When one value is edited, the other changes to maintain its 
aspect ratio. 

Specify, too, the desired Dots Per Inch (DPI) for the metafile. A larger value results in a higher quality metafile, but 
also a larger file size.

 7.  When a metafile is exported from a 3D Vector View, you can also specify the printed thickness of lines in the view. 
To increase the printing line weight, type a larger number in the Use Line Weight field. See Vector View on page 
832. 

Metafiles exported from plan view use the line weights defined in the Layer Display Options dialog. See Layer 
Display Options Dialog on page 127. 

IMPORTING METAFILES

Metafiles can be imported into and displayed in plan view, cross section/elevation views, and layout pages. Metafiles 
do not display in camera views or overviews. See Displaying Pictures, Metafiles, and PDF Boxes on page 861.         

There are two ways to import a metafile into Home Designer:         

 l Select File> Import> Import Metafile (EMF, WMF)  to open the Import Metafile dialog, which is a typical open 

file dialog. See Importing Files on page 43.             
 l You can also click and drag a metafile file from an operating system window into the Home Designer window to 

import it.             

An imported metafile is placed in the center of the current view. Once imported, metafiles can be selected and edited. See 
Editing Pictures, Metafiles, and PDF Boxes on page 862.         
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Metafile Box Specification Dialog
Select an imported metafile and click the Open Object edit button to open the Metafile Box Specification dialog.          

GENERAL PANEL

 
Center/Orientation

Specify the position of the selected metafile’s center point and its angle. See The Home Designer Pro Environment on page 
11.         

 l Specify the X and Y Position relative to the absolute origin.           

 l Specify the Angle of the metafile box relative to a horizontal line pointing towards the right-hand side of the screen.          

 
Size

Specify the Size of the metafile in plan inches (mm).         

 l Specify the Width of the metafile box.           

 l Specify the Height of the metafile box.           

 l Uncheck Retain Aspect Ratio of X if you would like to modify the Height or Width without affecting the other 
value. If you do this, the metafile may appear distorted. 
This check box does not affect editing performed outside this dialog and is an action rather than a state: the next time 
you open this dialog, it will be checked.          

 l Reset Original Aspect Ratio - If the aspect ratio is changed, you can click this button to return the picture to its 
original aspect ratio.           

 l Check Reset Cropping to fill the extents of the selected metafile box with the image associated with it. If the box 
has been resized, the image may appear distorted. See Editing Pictures, Metafiles, and PDF Boxes on page 862.          

LINE STYLE PANEL

The settings              on this panel             are similar to those on the LINE STYLE panel in numerous other dialogs, with one exception. 
Check Show Outline to turn on the display of the picture’s border polyline. For more information, see Line Style Panel on 
page 209.         
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PDF Files
Portable Document Format (.pdf) files are a special type of file that can be viewed on nearly any computer and can include 
a wide variety of visual information.           

PRINTING AND EXPORTING PDF FILES

You can save any view as a 2D .pdf file by selecting File> Export> Export PDF. This will open either the Print 
View or Print Image dialog, depending on the view type.          

You can also save any view as a 2D .pdf file by selecting “Chief Architect Save as PDF” as the Destination printer Name in 
either of these dialogs. See Printing to a PDF File on page 995.          

IMPORTING PDF FILES

To import a .pdf file, select File> Import> Import PDF. You can also import a .pdf file by dragging it from an 
operating system window into the Home Designer window.         

You can import .pdf files into Home Designer Pro in plan view, cross section/elevation views., and in layout. Once 
imported, PDF boxes behave and can be edited similar to imported pictures and metafiles. See Editing Pictures, Metafiles, 
and PDF Boxes on page 862.         

Some .pdf files can contain both 2D and 3D information; however, Home Designer can only support 2D data in an imported
 .pdf file. When a 3D .pdf file is imported, it may display text, a static image of the 3D model, or it may not import at all.          

Note: Importing large, or multiple, .pdf files into a plan or layout file can 
result in program slowness. 

 
 

The full pathname of the .pdf file displays here. If the pathname is not that of a valid .pdf file, this text will display in red.          

 l Click the Browse button to choose a new .pdf file or to relink to a missing file.         

 l Specify the Page of the .pdf file that displays in the preview on the right. Type a page number in the text field or use 
the spin control arrows to browse the pages sequentially.         

 
Preview

A preview of the page selected above displays on the right.          
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Import

Specify how much of the .pdf file you wish to Import. When multiple pages are imported, a separate PDF box is created 
for each one.         

 l Select Current Page to import only the page specified above and shown in the preview to the right.          

 l Select Pages, then specify the starting page in the From field and the ending page in the To field.          

 l Select All to import the entire .pdf file.          

 

PDF Box Specification Dialog
Select an imported PDF box and click the Open Object edit button to open the PDF Box Specification dialog.

GENERAL PANEL

 
PDF File

The full Filename of the .pdf file displays here. Type a new name to associate the selected PDF box with a different .pdf 
file.         

 l Click the Browse button to choose a new .pdf file or to relink to a missing file.          

 l Specify the Page of the .pdf file that displays in the selected PDF box.          

 l Check Save in Plan to embed the .pdf in the plan or layout file. If a .pdf is embedded in a file, you do not need to 
include it when sending the file to a different computer. If the .pdf file is modified, however, the PDF box in Home 
Designer Pro will only update automatically if this is unchecked.          

 
Center/Orientation

Specify the position of the selected PDF box’s center point and its angle. See 3D Drafting on page 12.         
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 l Specify the X and Y Positions of the PDF box’s center point relative to the absolute origin.          

 l Specify the Angle of the PDF box relative to an imaginary horizontal line pointing towards the right-hand side of the 
view window.          

 
Size

Specify the Size of the PDF box in plan inches (mm).         

 l Specify the Width of the PDF box.           

 l Specify the Height of the PDF box.           

 l Uncheck Retain Aspect Ratio of X if you would like to modify the Height or Width without affecting the other 
value. If you do this, the PDF box may appear distorted. 
This check box does not affect editing performed outside this dialog and is an action rather than a state: the next time 
you open this dialog, it will be checked.          

 l Reset Original Aspect Ratio - If the aspect ratio is changed, you can click this button to return the picture to its 
original aspect ratio.           

 l Check Reset Cropping to fill the extents of the selected PDF box with the image associated with it. If the box has 
been resized, the image may appear distorted. See Editing Pictures, Metafiles, and PDF Boxes on page 862.          

LINE STYLE PANEL

The settings     on this panel are similar to those on the LINE STYLE panel in numerous other dialogs, with one exception: 
Check the Show Outline box to turn on the display of the PDF box’s border polyline.         

See Line Style Panel on page 209.         

 

Displaying Pictures, Metafiles, and PDF Boxes
The display of Pictures, Metafiles, and PDF Boxes is controlled in the  Layer Display Options dialog. See Layer 
Attributes on page 125.

Pictures, Metafiles, and PDF Boxes are placed on the "Picture/PDF Boxes" layer.         

Pictures, Metafiles, and PDF Boxes can be imported into and displayed in plan view, cross section/elevation views, and 
layout pages. A Picture, Metafile, or PDF Box can only be seen in the view where it was imported and cannot be imported 
into a camera view or overview.         

DRAWING GROUPS

Each object in a plan or layout file is included in a Drawing Group, which influences whether it displays in front of or 
behind other objects. By default, imported pictures and PDF Boxes are placed in             the Back Group, and imported metafiles 
are placed in             the same Drawing Group as CAD objects.         

Once imported, the drawing order of pictures, metafiles, and PDF Boxes can be customized. See Drawing Groups on page 
129.          

IN LAYOUT

Pictures, metafiles, and PDF boxes are included when a view is sent to layout, and can also be imported directly onto a 
layout page. See Pictures, Metafiles, and PDFs in Layout on page 973.          
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Editing Pictures, Metafiles, and PDF Boxes
Pictures, Metafiles, and PDF Boxes can be selected and edited using the edit handles, the Edit Toolbar, and their 
specification dialogs.          

IN THE SPECIFICATION DIALOG

Pictures, Metafiles, and PDF Boxes can be customized in their specification dialog. See:          

USING THE EDIT HANDLES

Pictures, Metafiles, and PDF Boxes have edit handles similar to other box-based objects. See Editing Box-Based Objects on 
page 160.          

 l The corner Resize handles do not behave the same for Pictures, Metafiles, and PDF Boxes as they do for CAD boxes, 
however. If you drag a corner handle of one of these objects while the Default Edit Behavior is active, its contents will 
resize and height to width ratio will be retained.          

 l If you drag an Extend handle along a Picture, Metafile, or PDF Box’s edge, the contents of the box will not be resized. 
If you resize it larger, an empty space will be created between that edge and the contents; if you resize it smaller, the 
contents will be cropped.         

USING DIMENSIONS

Pictures, Metafiles, and PDF Boxes can be relocated relative to other objects with precision using dimensions.          

To avoid changing the selected object’s aspect ratio, make sure you choose to move the entire object rather than the selected 
edge. See Moving Objects Using Dimensions on page 341.         

USING THE EDIT TOOLS

A selected Picture, Metafile, or PDF Box can be edited in a variety of ways using the buttons on the Edit Toolbar. See The 
Edit Toolbar on page 92.         

POINT TO POINT RESIZE

A selected picture, metafile, or PDF box can be resized in either the X or Y direction with the Point to Point Resize 
edit tool.         

To use the Point to Point Resize tool

 1.  Select a picture box, metafile box, or PDF box.          

 2.  Click the Point to Point Resize  edit button. When you move the mouse pointer into the drawing area, it displays 

the Point A   icon.           

 3.  Click on the first of two points in the selected object’s area that have a known distance between them.          

 4.  Notice:          
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 l A temporary CAD point is created at the point where you clicked.          

 l The mouse pointer now displays the Point B   icon.   

 l As you move the mouse pointer, an extension line extends either horizontally or vertically from Point A.           

 5.  Click on the second of the two points with a known distance between them.           

 l Regardless of where the mouse pointer is positioned, Point B will be at the end of the extension line so for best 
results Points A and B should be on the same X or Y plane.          

 6.  After you click on the second point, the Point to Point Resize dialog opens.          

 7.  The current distance between the two points populates the text field. Enter a new dimension that matches the desired 
distance between the points.          

 8.  When Retain Aspect Ratio is checked, the ratio between the selected object’s height and width is maintained when 
you click OK and the object is resized. When this is unchecked, the object may become distorted-looking. If the 
selected object has been rotated, this box will be disabled and its aspect ratio will be retained.          

 9.  Click OK to resize the picture, metafile, or pdf.          

RESIZE FACTOR

With a bit of calculation, an imported picture, metafile, or PDF box can be resized to scale using the Transform/Replicate 
Object dialog. Once resized, the information in the object box can be traced using Home Designer Pro’s drawing tools and 
then deleted.           

It is a good idea to delete a resized picture after it is traced to 
help avoid program slowness and limit your plan or layout file’s 

size.

To calculate the Resize Factor

 1.  Find two items in the imported object that are separated by a known horizontal or vertical distance, such as two 
walls or plot lines.           

 2.  Draw parallel CAD lines on top of these two items. See The CAD Drawing Tools on page 199.          

 3.  Find the distance between the CAD lines. See The Manually Drawn Dimension Tools on page 331.          

 4.  The Resize Factor for the image is the distance described in the picture divided by the distance between the CAD 
lines.          

For example, if the items are supposed to be 10 feet apart on the picture, but the distance between the two CAD lines 
drawn on them is only 2 feet, you need to set the Resize Factor for the picture to 5. (10’ divided by 2’ equals 5). When 
the picture is 5 times the original size, the items on the picture are at the actual scale shown on the picture.          

 5.  Select the picture and click the Transform/Replicate Object  edit button.           

 6.  In the Transform/Replicate Object dialog, select the Resize Factor check box.          

 7.  Enter the Resize Factor calculated above, then click OK.          
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Walkthrough Paths
A 3D Walkthrough is a series of pictures saved as an .mp4, .wmv, or .avi file that can be played as a video by media 
player applications. Although you can record a walkthrough video directly from a camera view, Walkthrough Paths 

offer more options and flexibility and are the preferred way to create a walkthrough video in Home Designer.

CREATING WALKTHROUGH PATHS

There are two ways to create a Walkthrough Path:

The Create Walkthrough Path tool allows you to define the route that a walkthrough video travels through a plan as 
well as specify details like camera height, angle, and speed before actually recording. 

Available in plan view, the Create Orbital Walkthrough Path edit tool creates a circular walkthrough path around a 
selected full overview or  camera's focal point. The path's radius is equal to the length of the camera's line of sight, 

and all frames are pointed at the camera's focal point. 3D> Walkthroughs> Create Orbital Walkthrough Path is also an 
option when a camera view or overview is active.

To use the Create Walkthrough Path tool

 1.  Begin by choosing a codec for recording walkthroughs. See Selecting a Codec on page 874.          

 2.  Make sure that Connect CAD Segments  is enabled so multiple spline segments can snap together. See Connect 

CAD Segments on page 113.

 3.  In plan view, select 3D> Walkthroughs> Create Walkthrough Path , then click and drag to draw a 

Walkthrough Path. See To use the Spline tool on page 223.         

 4.  Edit the direction and curvature of the spline’s segments, as needed. See Editing Spline-Based Objects on page 162.          

 5.  Add Key Frames  to the path and modify their specifications. See Key Frames on page 865.         

 6.  Select the path and click the Record Walkthrough Along Path  edit button. See Record Walkthrough Along 

Path on page 871.          

Walkthrough Paths can follow stairs and ramps to span multiple 
floors. See Walkthrough Paths and Stairs on page 865.

In plan view, you can convert a CAD polyline or spline into a Walkthrough Path. See Convert Polyline on page 182.   

DISPLAYING AND EDITING WALKTHROUGH PATHS

Walkthrough Paths display in plan view only and are located on the “Walkthrough Paths” layer. Walkthrough Paths display 
in front of most other objects, will print, and are included in views sent to layout or exported to .dxf/.dwg. See Layers on 
page 124.

Before a Walkthrough Path can be edited, it must be selected. The Key Frame closest to the point where you clicked will be 
the Selected Key Frame. See Selecting Objects on page 142.

Walkthrough Paths can be edited like other spline-based objects using the edit handles, edit toolbar, and specification dialog. 
See Editing Spline-Based Objects on page 162.
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In addition to the standard edit handles for splines, Walkthrough Paths also have an edit handle for each Key Frame. The 
Key Frame closest to the point where you click displays the Selected Edge Handle Fill color, while the other Key Frame 
handles use the Secondary Handle Fill color. Both are set in the Preferences dialog. See Colors Panel on page 65.

To reverse the direction of the entire walkthrough, select it and click the Reverse Direction  edit button. See Reverse 

Direction on page 181. 

KEY FRAMES

Key Frames are points along a Walkthrough Path that allow you to change:          

 l Camera direction, tilt angle, and height;          
 l Changes in walkthrough speed;         
 l The floor that the walkthrough is on.          

These changes are applied as the camera moves along the Walkthrough Path from one Key Frame to another.         

To add a Key Frame to a Walkthrough Path

 1.  Select the path and click the Add Key Frame  edit button. 

 2.  If you wish to add multiple Key Frames, click the Sticky Mode  edit button. See Sticky Mode on page 121.

 3.  Click on the selected path to add a Key Frame at that location. The new Key Frame receives height and angle 
attributes based on its position on the path and the attributes of the Key Frames before and after it.

 4.  If you clicked the Sticky Mode  button, continue clicking to create additional Key Frames. When you are 

finished, click the Main Edit Mode  edit button or select a different drawing tool.

In plan view, each Key Frame is represented by a camera symbol centered along the walkthrough path. It displays its Key 
Frame number, is pointed in the direction of its Camera Angle, and its position along the path corresponds to its Time 
setting.          

Key Frame Time, Angle, and other properties can be edited in the Walkthrough Path Specification dialog. See General 
Panel on page 867.          

You can also select a Walkthrough Path and move and rotate each Key Frame using its edit handles.          

To remove a Key Frame from a Walkthrough Path, click on its symbol to select it and click the Delete Key Frame  edit 

button. The selected Key Frame can be identified by the color of its Move edit handle. This edit tool can be used to delete 
the Start and End Key Frames; however, if only two Key Frames are present it will not be available. Key Frames can also 
be deleted in the Walkthrough Path Specification dialog. See Selected Edge on page 143 and General Panel on page 867.

WALKTHROUGH PATHS AND STAIRS

If you draw a Walkthrough Path up or down a staircase or ramp, it will follow the height of the stairs or ramp and continue 
on the next floor.          

865



Home Designer Pro 2025 Reference Manual - Walkthrough Path Specification Dialog

To create a multiple floor walkthrough

 1.  Draw a Walkthrough Path so that it extends into a staircase or ramp in the same direction as its Direction Arrow. See 
Displaying Stairs, Ramps, and Landings on page 534.         

 l Do not drag the Walkthrough Path across the entire length of the stairs or ramp. If you do, its height will remain 
relative to the current floor.         

 2.  When you release the mouse button, the program will automatically display a dashed line with an arrow extending 
past the last Key Frame on the current floor.         

 l If it follows stairs or a ramp going upward, the path will also extend to the top end of the staircase or ramp.         

 3.  Go up or down one floor, select the Walkthrough Path, and resize and reshape it as needed. You can use the Create 
Walkthrough Path  tool to draw more segments and use the Add Key Frame  edit tool, as well.          

PREVIEWING A WALKTHROUGH

Depending on the quality settings and length of a Walkthrough Path, it may take a considerable amount of time to 
record a walkthrough video. The Walkthrough Preview side window allows you to preview part or all of an existing 

walkthrough path to confirm that it meets your needs prior to actually recording it. Select View> Walkthrough Preview to 
open or close this side window. See Walkthrough Previews on page 869.

PLAYING A WALKTHROUGH

Once a walkthrough has been recorded, it can be played using a media player on your system.         

To play a walkthrough

 1.  Select 3D> Walkthroughs> Play Walkthrough  to open the Select Video File dialog.          

 2.  Browse to the .mp4, .wmv, or .avi file on saved on your computer. Your system's default video player plays the 
walkthrough video.         

 

Walkthrough Path Specification Dialog
Select a Walkthrough Path and click the Open Object edit button to open the Walkthrough Path Specification dialog. 
See Walkthrough Paths on page 864.          

Most of the settings in this dialog are also found in the Walkthrough Path Defaults dialog.

The Walkthrough Path Specification dialog has the following panels:
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GENERAL PANEL

 
Key Frames

A list of the selected path’s Key Frames displays on the left.  Click on a Frame in the list to select and edit it using the 
settings on the right. When the dialog is opened, the Key Frame selected in plan view will be selected in the list 
automatically. See Key Frames on page 865.    

 l Specify the Floor that the selected Key Frame is located on. See Multiple Floors on page 517.    

 l Specify the Time in seconds at which the selected Key Frame is found in the duration of the walkthrough. The 
Times of the walkthrough path's first and final frames cannot be moved.    

 l Specify the Speed After (ft/s), which is how fast the camera moves along the walkthrough path from the current 
Key Frame to the next. Not available if the last Key Frame is selected.    

 l Specify the Camera Angle at the selected Key Frame.    

 l Specify the Tilt Angle of the camera at the selected Key Frame.    

 l Specify the Height of the camera at the selected Key Frame.    

 l Click the Delete button to remove the selected Key Frame from the path. Key Frames can also be deleted in plan 
view using the Delete Key Frame  edit tool. This option can be used to delete the Start and End Key Frames; 

however, if only two Key Frames are present it will not be available.    

 l Specify the Key Frame Symbol Size, which is the size of the symbols representing the selected walkthrough path’s 
Key Frames in plan view. See Key Frames on page 865.

Specify how the Camera Angles associated with each key frame are measured:     

 l Select Absolute to measure the Camera Angles relative to the plan’s X and Y axes.    
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 l Select Relative to Path to measure the Camera Angles frame relative to the direction of the path at that location.

Note: When Relative Angles are used, a Camera Angle of 0° points 
in the direction of the Walkthrough Path. When Absolute Angles are 
used, 0° always points in the positive direction along the X axis.    

Specify how the Camera Heights associated with each key frame are measured:    

 l Select Absolute to measure camera height relative to the plan’s Z axis.    

 l Select Relative to Floor/Terrain to measure camera height relative to the floor or terrain at each Key Frame 
location.

 
Resolution

Control the size of the selected walkthrough's frames.    

 l Select a size from the drop-down list. If the Width or Height is modified below, the selected Resolution will be 
"Custom".

 l The current Width, based on the selected Resolution, is stated here. If you change this value, the selected Resolution 
will be "Custom".

 l The current Height, based on the selected Resolution, is stated here. If you change this value, the selected Resolution 
will be "Custom".

  Walkthrough Options

 l Specify the Duration, or total length of the walkthrough video in seconds.

 l Specify the desired number of Frames per Second, between 1 and 100. A higher number results in a higher quality 
recording but also a larger file size.

 l In the Walkthrough Path Defaults dialog only, specify the Video Codec to use when recording walkthroughs. See 
Selecting a Codec on page 874.

CAMERA PANEL

The settings on the CAMERA panel let you specify lighting, a Rendering Technique, and more. These settings are also found 
in the Camera Specification dialog. See Camera Panel on page 801.

BACKDROP PANEL

The settings on the BACKDROP panel are also found in the Camera Specification dialog. See Backdrop Panel on page 806. 

POLYLINE PANEL

The POLYLINE panel states the length of the path’s Perimeter. The Area and Volume of a walkthrough path will always be 
described as “Not closed”. See Polyline Panel on page 219.          

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected path is a spline or the selected edge is a line as opposed to an arc. 
See Line Panel on page 208.   

The SELECTED ARC panel is available when the selected path edge is an arc as opposed to a spline or line. See Arc Panel on 
page 214.   
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See, too, Selected Edge on page 143 and Change Line/Arc on page 176.  

LINE STYLE PANEL

This panel is similar to the LINE STYLE panel in the Line Specification dialog. See Line Style Panel on page 209.         

 

Walkthrough Previews
Depending on the quality settings and length of a Walkthrough Path, it may take a considerable amount of time to 
record a walkthrough video. The Walkthrough Preview side window allows you to preview part or all of an existing 

Walkthrough Path to confirm that it meets your needs prior to actually recording it. Select View> Walkthrough Preview to 
open or close this side window. See Side Windows on page 16.

You can also open or close this side window by selecting a Walkthrough Path and clicking the Walkthrough Preview  

edit button.

 
Active Walkthrough

Select the Walkthrough Path that you would like to see in the preview from the drop-down list. All paths present in the 
current plan are listed, and are described using their Label. See Walkthrough Path Specification Dialog on page 866.    
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 l Click the Define button to open the selected path's Walkthrough Path Specification dialog. See Walkthrough Path 
Specification Dialog on page 866.    

 
Preview

A preview of the selected walkthrough displays here. When a preview is not playing, the Current Frame displays.    

 l Click and drag in the preview window to adjust the Camera Angle and Tilt Angle of the Current Frame.

 l Click and drag the green slider bar to control which frame of the walkthrough displays in the preview pane. You can 
also click anywhere along the slider to move the bar to that location or use the Current Frame setting, below.    

 l The yellow bar at the top of the slider indicates the duration of the walkthrough and the location of the Start and End 
Frames selected below. Click and drag the handles at each end to move the Start and End Frames.    

 l Blue diamonds along the slider show the location of the selected walkthrough's Key Frames, defined below.    

 l Specify the Start Frame of the walkthrough video. This will be the first frame of the walkthrough video when it is 
recorded using Custom Frames to Record, and is Frame 1 by default. See Record Walkthrough Along Path on page 
871.    

 l Specify the End Frame of the walkthrough video. This will be the final frame of the walkthrough video when it is 
recorded using Custom Frames to Record, and is the last frame of the walkthrough by default.    

 l Specify the Current Frame, which displays in the preview pane above and can also be specified using the slider 
bar. The Current Frame cannot be located before the Start Frame. 

  Preview Controls

  Use Recording Quality shows the preview using the same level of quality as set on the CAMERA panel of the 
Walkthrough Path Specification dialog. This option is selected by default but may cause slow performance in 

the preview pane. See Camera Panel on page 868.

  Use Standard Quality may improve performance if you encounter slowness in the preview pane. This option 
shows the preview using without shadows, bloom or reflections. In addition, Watercolor and Physically Based 

Renderings are shown using the Standard Rendering Technique. This setting is retained during the current program 
session but is reset when the program is relaunched.

  Create Camera View creates a camera view window using the location and angle of the current frame. 

  Jump to Previous Key Frame moves the preview back one Key Frame. Not available if the Current Frame is 
located before the Start Frame.

  Go to Previous Frame moves the preview back one frame.  Not available if the Current Frame is located 
before the Start Frame.

  Go to Next Frame advances the preview ahead one frame. Not available if the Current Frame is located after 
the End Frame.

  Jump to Next Key Frame advances the preview ahead one Key Frame. Not available if the Current Frame is 
located after the End Frame.

  Play Walkthrough Preview from Beginning plays a preview of the walkthrough from the Start Frame 
through the End Frame.
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  Play Walkthrough Preview from Current Frame plays a preview of the walkthrough from the Current 
Frame through the End Frame.

  Record Walkthrough records a preview of the walkthrough from the Start Frame through the End Frame.

 
Key Frames

Make adjustments to the selected walkthrough's Key Frames. These settings are also found in the Walkthrough Path 
Specification dialog. See General Panel on page 867.    

 l Click on a Key Frame in the list on the left to select and edit it.    

 l Specify the Floor that the selected Key Frame is located on.    

 l Specify the Time in seconds at which the selected Key Frame is found in the duration of the walkthrough. The 
Times of the walkthrough paths' first and final frames cannot be moved.    

 l Specify the Speed After, which is how fast the camera moves along the walkthrough path from the current Key 
Frame to the next, in feet per second. Not available if the last Key Frame is selected.    

 l Specify the Camera Angle at the selected Key Frame.    

 l Specify the Tilt Angle of the camera at the selected Key Frame.

The Camera Angle and Tilt Angle can also be adjusted by 
clicking and dragging in the preview pane, above.

 l Specify the Height of the camera at the selected Key Frame. You can specify where the Heights are measured from 
in the Walkthrough Path Specification dialog, which is accessible by clicking the Define button, above.    

 l Click the Delete button to remove the selected Key Frame from the path.

 
Walkthrough Preview Control Options

Click the Options   button at the bottom of the side window to specify what settings are presented as well as their layout.

 l Select Preview Pane to toggle the display of the Preview panel that plays the walkthrough preview or shows the 
Current Frame

 l Select Key Frame Settings toggle the display of the Key Frames settings.

 l Select Horizontal Layout to position the Key Frames settings to the right of the other settings, or select or Vertical 
Layout to position the Key Frame settings below the other settings. The side window's shape does not adjust when 
you switch between layout options, so you may need to resize it by clicking and dragging its edges.

 

Recording a Walkthrough
There are two approaches to recording a walkthrough of a plan: using a Walkthrough Path, and recording frame by frame, 
directly from a camera view.   

RECORD WALKTHROUGH ALONG PATH

Once a Walkthrough Path has been drawn, you can use it to record a walkthrough video. See Creating Walkthrough Paths 
on page 864. 
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Depending on the quality settings and length of a Walkthrough 
Path, it may take a considerable amount of time to record a 

walkthrough video. You can preview a walkthrough before recording it. 
See Walkthrough Previews on page 869.

To record a walkthrough along a path

 1.  In plan view, select a Walkthrough Path.

 2.  Open its specification dialog and make sure the settings on the GENERAL, CAMERA, and BACKDROP panels meet your 
needs. See Walkthrough Path Specification Dialog on page 866. 

 3.  On the CAMERA panel:

 l Make sure the Rendering Technique Options meet your needs. See Rendering Technique Options on page 834.

 l Particularly if your monitor is high resolution and you wish you use the Physically Based rendering technique, 
use FidelityFX Super Resolution to shorten the recording time. See AMD FidelityFX on page 815.         

 4.  Click the Record Walkthrough Along Path  edit button.         

 5.  In the Record Walkthrough Options dialog, specify the desired Quality, Resolution, Rendering Options, Video 
Codec, and the name and save location of your walkthrough file, then click OK.         

Note: You can specify your preferred settings, including Key Frame 
Symbol Size, Compression, and Video Codec in the Walkthrough 
Path Defaults dialog. See Default Settings on page 57.

 6.  When you click OK, a camera view will open, showing the progress as the walkthrough is recorded.         

To cancel the recording as it is being created, press the Esc key.         

RECORD WALKTHROUGH OPTIONS DIALOG

Most of the settings in this dialog are also found in the Walkthrough Path Defaults dialog.         
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Camera and Backdrop

Click the Define button to open the Record Walkthrough Camera Options dialog, where Rendering Technique, lighting, 
backdrop, and more for the current walkthrough can be specified. The settings in this dialog are also found in the Camera 
Specification dialog. See Camera Specification Dialogs on page 801.              

 
Resolution

Specify the size of the walkthrough’s frames.              

 l Select a resolution from the drop-down list. If you modify the Width or Height below, “Custom” will become 
selected.         

 l The current Width, based on the selected Resolution, is stated here. If you change this value, the selected Resolution 
will become “Custom”.          

 l The current Height, based on the selected Resolution, is stated here. If you change this value, the selected Resolution 
will become “Custom”.          

 l Check Retain Aspect Ratio to retain the original ratio between the frame Width and Height. If you modify either 
value while this is unchecked, the walkthrough may appear distorted.          

  Walkthrough Options

 l Specify a Compression percentage between 0 and 100. A value of 0 gives the highest quality images and largest file 
sizes.      

 l Specify a Duration Along Path, in seconds.       

 l Specify the desired number of Frames Per Second, between 1 and 100. A higher number results in a higher quality 
recording but also a larger video file.       

 l Select a Video Codec from the drop-down list. See Selecting a Codec on page 874.

 
Frames

This setting is retained between sessions and is also global, affecting all walkthroughs in all plan files.      

 l Specify the Frames to Record by choosing either All or a Custom range, which is set in the Walkthrough Preview 
side window. See Walkthrough Previews on page 869.

 l The Total Frames Along Path, Total Frames to Record, and Total Recording Duration display for reference.

When you click OK, the program will begin recording the walkthrough video. If you selected Save to Chief Architect 
Cloud, you may first be prompted to log in to your Chief Architect Cloud Account. See Chief Architect Account Login on 
page 876.         

FRAME BY FRAME WALKTHROUGHS

You can also create a walkthrough by recording it frame by frame. Although time-consuming and lacking many of the 
options that a Walkthrough Path provides, creating a walkthrough in this manner lets you see exactly what is being recorded 
as you record it.          

To record a walkthrough frame by frame

 1.  Create a camera view. This view is the first frame of the walkthrough.         

 2.  While the camera view is active, select 3D> Walkthroughs> Record Walkthrough .          
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 3.  In the Walkthrough Options dialog:          

 l Select a Frame Rate between 1 and 100. The value entered is the number of frames per second.          

 l Select a Compression Percent between 0 and 100. A value of 0 gives the highest quality images and the largest 
file size.         

 l Select a Codec from the drop-down list. See Selecting a Codec on page 874, below. 

 l Click OK.         

 4.  In the Save Video As dialog, specify the name, location, and file format for the walkthrough file, then click Save. 
The available file formats will vary, depending on the codec you selected.         

 5.  Use the camera movement tools to navigate the view. Each time the screen redraws, it is recorded as the next frame 
in sequence. See Editing 3D Views on page 791.         

 6.  To move the camera without saving a view, select 3D> Walkthroughs> Pause Recording  to temporarily stop 

recording.          

 l You can then select 3D> Walkthroughs> Save Frame               button to control what views are saved.         

 l You can start recording again by selecting Pause Recording               once more.         

 7.  When the walkthrough sequence is complete, select 3D> Walkthroughs> Stop Recording  or close the view.         

Note: Zooming in and out and using the scrollbars does not change the 
viewpoint and does not produce a frame for the walkthrough.

If you resize the current view window while recording a walkthrough, the program will stop recording.          

SELECTING A CODEC

A codec is a utility that compresses and decompresses media files, and is used when both recording and viewing videos 
such as walkthroughs. When you record a walkthrough in Home Designer, you can choose which of the codecs installed on 
your system you want to use. This selection is universal and is retained between program sessions: when you choose a 
codec in the Walkthrough Path Defaults or either Walkthrough Options dialog, it will become selected the next time you 
open either dialog, even if you do so in another plan.          

“Windows Media Video 9” is the default codec in the Windows version and “H.264”, in the Mac version; but any codecs 
installed on your system will be available to use.          

To choose the codec that best suits your needs, it is a good idea to create a test walkthrough using each of the codecs 
installed on your system to see how well their walkthrough quality and file compression meet your requirements. Note that 
your choice of codec may affect the file formats in the Save Video As dialog.         

For more information about codecs, visit  HomeDesignerSoftware.com.
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Chapter 34
 

Importing and Exporting

Importing is the process of opening a file that was produced in a different program in Home Designer. Exporting, on the 
other hand, is the process of saving information in a Home Designer file to a format that can be read by another program. 

Home Designer allows you to import and export a variety of information from and to other applications. This chapter 
focuses on importing and exporting 2D .dwg/.dxf files and a variety of 3D file formats. Other importing and exporting 
options are described in the chapters in which those objects or settings are discussed. See Pictures, Images, and 
Walkthroughs on page 845.
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Chief Architect Account Login
Your online Chief Architect Account allows you to take advantage of a variety of valuable resources including catalog 
downloads, license management, and technical support.

There are a number of tasks in the software that require you to be logged into your Chief Architect cloud account:

 l Downloading library catalogs. See Downloading Library Content on page 707.
 l Uploading Chief Architect 3D Viewer models. See Export Chief Architect 3D Viewer File on page 876.
 l Uploading 360 Panorama images. See Export 360 Panorama on page 887.
 l Importing a drawing from the Room Planner mobile app. See Import Room Planner File on page 878.         

If you try to do this while you are logged out of your cloud account, the Chief Architect Account Login dialog will open, 
giving you an opportunity to log in.         

You can also log into or out of your online account at any time by selecting Help> Log in to Chief Architect Account or 
Help> Log out of Chief Architect Account.         

CHIEF ARCHITECT ACCOUNT LOGIN DIALOG

 l To upload Chief Architect 3D Viewer models, 360° Panoramas, and Walkthrough videos or to download library 
content, enter the E-mail Address and Password associated with your online Digital Locker and software license. 

 l In order to import Room Planner files, you should enter the same E-mail Address and Password that you used to 
save the drawing to the cloud in Room Planner.

 l Check Remember Login to retain your E-mail Address and Password information in this dialog between sessions.

When this dialog is accessed via the Library Browser contextual menu, you can click the Switch to Offline Mode button to 
close the dialog and exclude online content from being included in library searches. You can switch to Online Mode at any 
time by clicking the Include Web Results  button in the Library Browser. See The Library Browser on page 692.

 

Export Chief Architect 3D Viewer File
The Chief Architect 3D Viewer allows a model created in Chief Architect to be viewed in either:         
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 l A web browser on a computer.
 l The 3D Viewer app on a mobile device.

In order to export a Chief Architect 3D Viewer file, you must be logged in to your Chief Architect cloud account.         

For more information about the Chief Architect 3D Viewer, visit HomeDesignerSoftware.com.         

To export a file to the cloud for viewing with either option, select File> Export> Export Chief Architect 3D Viewer File 
 while a 3D view is active. Up to 99 3D Viewer models can be stored in your online account at a time. 

Any light sources that are On in the current view, as well as ambient light, will be exported along with the model. See 
Lighting on page 817. 

3D VIEWER EXPORT OPTIONS

 l Select Create New Model to export a new model without affecting any previously exported files.         
 l Select Replace Existing Model to select a previously exported model in the list and replace it with the model being 

exported now.          
 l To select an existing model to replace, click on its line item in the table.          

The information in the table is sortable: click a column header to sort all line items in the table by that column. An arrow 
above the column indicates that it is being used to sort the table, and in which direction it is being sorted.

When you click OK, the Export 3D Viewer File dialog opens, where you can specify the exported model’s name, 
description, and other details.         

EXPORT 3D VIEWER FILE DIALOG

 l The Name of the current plan file populates this field by default. Specify a different name for the exported 3D Viewer 
file if you would like. Names must be unique.         
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 l Type a brief Description of the model.         
 l Click the Cameras button to open the Select Cameras to Export dialog and specify which saved cameras to export 

with the model. See 3D Views on page 770.         
 l The Surface Count and Texture Size display here for reference. Large Surface Count and/or Texture Size values can 

impact performance in the app.         

To reduce Surface Count and Texture Size, consider turning off 
unnecessary layers in the current 3D view before exporting. See 

Layers on page 124. 

When you click OK, the 3D model is exported using the layer settings in the camera view that  was active when the model 
was exported.          

On the 3D Viewer page, you can also choose to share an exported model with someone so that it can be opened in a 3D 
Viewer page or in the 3D Viewer mobile app.          

SELECT CAMERAS TO EXPORT DIALOG

 l The Camera Name of each saved Perspective Camera and Overview in the plan is listed in a table. The camera that is 
active when you export the model, if listed, is followed by “(source)”.              Doll House Views can be exported; however, 
they behave like Full Overviews in the 3D Viewer.          

 l In the Include column, click to add or remove a check mark for each camera that you would like to export. By default, 
only cameras of the same type, on the same floor, and using the same layer set are Included.          

 l In the Initial View column, add a check mark for the camera that you would like to be active when the model is 
opened in 3D Viewer.         

 l Click the Include All button to export all saved cameras with the model. A large number of saved cameras may slow 
down the interface of the 3D Viewer app.         

 l Click the Include None button to export no saved cameras with the model. When the model is opened, an unsaved 3D 
Overview will be the initial view.         

The columns in the table are sortable: click a column header to sort all line items in the table by that column. An arrow 
above the column indicates that it is being used to sort the table, and in which direction it is being sorted.

The columns in the table are sortable: click a column header to sort all line items in the table by that column. An arrow 
above the column indicates that it is being used to sort the table, and in which direction it is being sorted.

 

Import Room Planner File
Select File> Import> Import Room Planner File, then select and download a Room Planner file from the cloud. 
When prompted to log in, use the same credentials you used to save a plan to the cloud in Room Planner. See Chief 

878



Home Designer Pro 2025 Reference Manual - DXF vs DWG File Formats

Architect Account Login on page 876.

Files created in Room Planner version 2 and newer can be imported into Home Designer 2025.

Note that the exterior walls in an imported Room Planner drawing will inherit their thickness and other properties from the 
Exterior Wall Defaults dialog in the current plan, while interior walls will retain the thickness that was set in Room Planner. 
See Exterior and Interior Wall Defaults Dialogs on page 230.

Unless a custom ceiling height has been specified in Room Planner, rooms in an imported file use the Default ceiling height 
set in the Floor Defaults dialog. See Floor Level Defaults on page 287.

Visit roomplanner.chiefarchitect.com for more information about the Room Planner mobile app.

 

DXF vs DWG File Formats
.dwg is the native AutoCAD® file format. Originally a proprietary format, it is now widely used with many different 
products.         

.dxf (Drawing eXchange Format) is a standard file format created by Autodesk for the transfer of data between other 
programs.         

Many design programs can read and write .dxf and .dwg files. Both formats interpret data as CAD objects such as lines, 
polylines, and circles. Both formats can also contain 3D data which can be imported into Home Designer Pro, as well.

Binary .dxf format is another related file format. It is easier for computers to read, is more accurate, and occupies less disk 
space and regular .dxf files. When exporting, however, bear in mind that not all applications support binary .dxf.          

 

Importing 2D Drawings
2D drawings are imported by reading entities from a .dxf or .dwg file and creating the equivalent CAD objects in Home 
Designer Pro.          

Home Designer Pro 2025 can import 2D .dxf or .dwg files compatible with AutoCAD® through version 2023. See Import 
Drawing Assistant on page 880.       

A .dxf or .dwg file can be imported into plan view or a cross section/elevation view.          

Only drawings created in AutoCAD®’s Model Space can be imported into Home Designer. Entities drawn in Paper Space 
are not recognized.          

External references (xrefs) are not recognized by Home Designer, either.         

In general, all Z coordinates are mapped to zero. If an entity in an imported drawing has thickness, Home Designer ignores 
it.         

SUPPORTED ENTITIES

The following is a list of the entities that are imported and how they are converted. All other entities are ignored:          

 l Lines - Both 2D and 3D lines.         
 l Circles - Fully supported in 2D.         
 l Arcs - Fully supported in 2D.         
 l Ellipses - Fully supported in 2D.          
 l Spline entities - Fully supported as 2D polylines.         
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 l Polylines and Lightweight Polylines - Polylines are imported as polylines. Bumps are converted to arcs. Line widths 
are ignored.         

 l Lightweight Polylines - Fully supported in 2D.         
 l Points - Points are not supported unless the layer they are on is converted to Elevation Data. See Importing Elevation 

Data on page 921.         
 l Text and Multi-line Text - Both are imported as Rich Text and mapped to the Text layer. Multi-line text objects 

retain their original width. The first font in a multi-line text object is applied to the entire object. If that font is 
unavailable, Arial is used.         

 l Multileaders - Fully supported in 2D.         
 l Unicode - Fully supported in text objects only.         
 l Blocks and Block Inserts - A block is a named group of CAD entities that have been joined together to behave as a 

single object. A block insert is a reference to such a block. Blocks are loaded by name. If a duplicate name is found, 
you can specify whether a block is imported under a new name, replaces an existing block or simply uses the existing 
block of the same name.          

Note: Blocks imported into Home Designer Pro cannot be exploded 
into their individual component objects. See CAD Blocks on page 
880, below.

 l Hatch entities - If Import Hatch entities is selected on the SELECT FILE page of the Import Drawing Assistant for a
 .dwg file, Hatch patterns are imported as a CAD block consisting of solid black filled polylines.          

 l 2D Solids (Not ACIS Solids) - Fully supported in 2D.          
 l Solids - A solid is a 3 or 4-sided filled area. These are imported as 2D faces.         
 l 3D Faces/Polyface Meshes - A 3D face has its Z coordinate mapped to zero, and imports as a polyline.         
 l Dimensions - Rotated, aligned and 3-point angular dimensions are supported. All other dimension types are imported 

as lines and text rather than functioning dimensions.             

 l Attributes - Attributes are text objects associated with other items, like blocks. These are imported as text objects at 
the appropriate location but the association with the original object is broken.         

 l Line Styles - Line styles are not imported. Instead, if a style of the same name displays in the Home Designer line 
styles, that line style is used. Otherwise, a solid line style is used.          

 l Layers- You can specify which layers in the imported drawing to import into your Home Designer file. See Layers on 
page 124.         

CAD BLOCKS

A block is a group of CAD objects that has been joined together to behave as a single object. Although blocks can be 
imported into Home Designer Pro, they cannot be exploded and have no specification dialog. They can, however, be 
selected, moved, and deleted. See CAD Objects on page 197.         

 

Import Drawing Assistant
A 2D .dxf or .dwg file can be imported into any orthographic view: plan view, cross section/elevation views, and 
layout. For information about supported entities, model and paper space, and other considerations, see Importing 2D 

Drawings on page 879.       

To import a 2D drawing file, open the view in which you would like to place the drawing and select File> Import> Import 
Drawing (DWG/DXF) to open the welcome page of the Import Drawing Assistant. Click Next to continue.         
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You can also launch the Import Drawing Assistant by dragging a .dxf/.dwg file from an operating system window into the 
Home Designer Pro window.         

SELECT FILE

 
 

Click the Browse button to select the file that you wish to import. When a file is selected, its full pathname displays to its 
left. The directory containing the last file selected using the Import Drawing Assistant displays here otherwise. If the 
pathname is not a valid dxf/.dwg file, this text will display in red. 

Note: If the file you are importing is password protected, you will be 
prompted to enter the password before continuing.

 
 

If you want to convert lines with shared end points to polylines and/or boxes, check the appropriate options. Polylines are 
not affected by these settings, nor are lines that do not share end points.             

 l Check Polylines to import lines with shared end points as polylines.          

 l Check Boxes to import lines with shared end points that form a closed rectangular shape as boxes.          

 
 

Specify how to treat CAD blocks associated with the selected drawing.         

 l Select Import all CAD blocks to include all CAD blocks associated with the file being imported whether or not 
they are in use.             

 l Select Only import CAD blocks if they are referenced in the drawing to reduce the volume of transferred data.          

 
 

Check Import Hatch entities to import areas of hatching as solid-filled polylines.         

Click Next to load the file into memory so that Home Designer Pro can present information about the contents of the file. 
This can take a while for larger files.         
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SELECT LAYERS

In Home Designer Pro, all drawing file layers are mapped to the “CAD, Default” layer. Original layer attributes are lost, but 
line color, styles, and weight are preserved on a per-object basis.         

 
 

A list of the layers found in the imported file and information about each layer displays in this table. See Layers on page 
124.         

 l In the Layer column, check the box to the left of each layer name to specify which layers you want to import. 
Layers with checked boxes are imported; those with unchecked boxes are not.          

 l Layers that were Visible in the original program are checked by default. You can include a layer that is not visible 
by checking the box to the left of its name.          

 l Layers that were Frozen in the original program are not checked by default. You can include a frozen layer by 
checking the box to its left.         

 l If a layer is set to Convert To a Terrain Perimeter or Elevation Data, it will be indicated in this column provided 
that you are importing into plan view.         

 
 

Click Select All to check the box to the left of all layer names in the table. Click Clear All to clear the check box to the left 
of all layer names in the table.

 
 

The Convert To drop-down list allows you convert the data on any layer into a Terrain Perimeter or Elevation Data. See 
Terrain Perimeter on page 891 and Importing DWG/DXF Elevation Data on page 926. Only available when importing into 
plan view.         

To convert a layer to a Terrain Perimeter or Terrain Data, click on its name in the table and then select an option from the 
Convert To drop-down list. The option you choose will then display in the Convert To column in the table.          

882



Home Designer Pro 2025 Reference Manual - Import Drawing Assistant

Note: If an open polyline is converted into a Terrain Perimeter, the 
program will draw an additional edge to close the gap. 

DRAWING UNIT

 
 

Select a unit of measurement from the drop-down list. Selecting the correct unit helps ensure that your imported drawing is 
accurately sized.         

Note: During the import process, Home Designer Pro defaults to inches 
or millimeters. If you are importing a site plan or topo prepared by a 
surveyor, or importing a metric drawing into an U.S. Unit plan (or vice 
versa), you may need to change units. 

If the file being imported was drawn at a scale other than 1:1, you can compensate for this scaling by creating a custom 
unit of measurement and specifying it here. See Unit Conversions Panel on page 74.         

 
 

Specify how dimensions are imported.

 l Select Import as dimensions where possible to import dimensions as Home Designer-supported dimension lines.         

 l Select Import as CAD blocks to import dimensions as CAD entities that are not recognized by Home Designer as 
dimensions.         

 
 

Check Move drawing to the origin to place the drawing at 0,0. When this is unchecked, it is imported to the same location 
as it was drawn in the original application. See 3D Drafting on page 12. 

IMPORT COMPLETE

When a .dxf/.dwg file is imported into Home Designer Pro, all of its components are selected as a group. The selection set 
has Move and Rotate edit handles available for relocating the entire drawing, as well as a variety of edit tools. Once another 
object or tool is selected, the drawing components are no longer group-selected.          

If you do not see your imported drawing, select Window> Fill Window , as it may have been placed at a location not 

currently visible on screen. When the drawing can be seen, move your mouse pointer over it and note its coordinates in the 
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Status Bar. If any coordinate value has more than six digits,              use the Transform/Replicate Object  edit button to move 

it closer to the origin. See Transform/Replicate Object Dialog on page 183.         

Imported CAD objects can be selected and edited just like objects that were drawn in the program. See Editing Objects on 
page 137.         

 

Exporting 2D DXF/DWG Files
Line-based 2D files can be exported from Home Designer in both .dxf and .dwg file formats. You can specify the version of 
AutoCAD® to export to. Compatibility with other software may vary.         

There are two ways to export a 2D drawing file in Home Designer: Export Current View and Export All Floors.         

EXPORT CURRENT VIEW

To export the currently active plan view or 3D view, select File> Export> Current View (DWG/DXF).          

Bear in mind that Orthographic views are drawn to scale and will produce a 2D drawing that can be accurately dimensioned. 
Perspective views, on the other hand, are not scaled and do not produce drawings that can be dimensioned accurately. See 
Perspective and Orthographic Views on page 771.

EXPORT ALL FLOORS

To export the plan view for all floor plans simultaneously, select File> Export> All Floors  (DWG/DXF) from any 
floor of the plan. The floor plans are exported to a single .dxf or .dwg file.         

If you choose to export all floors, the file will contain all floors superimposed on each other. Upon export, each layer in 
your Home Designer drawing is divided into separate layers: one for each floor. For example: “Electrical-2” contains 
objects on Floor 2 that were originally on the “Electrical” layer.         

EXPORT DRAWING DIALOG

 
AutoCAD® File Format Options

.dxf and .dwg files created by Chief Architect can be compatible with a variety of AutoCAD® versions. Specify which 
version from the drop-down list.         
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Layer Options

The Layer Options settings allow you to control the layers associated with the file being exported. See Layers on page 124.
         

 l Split Wall Assemblies Into Layers - The lines that represent wall layers can be exported onto different layers, 
allowing them to be displayed separately. See Wall Type Definitions on page 262.             

 l Select Export Only Displayed Layers to export only those layers that are displayed on screen. This is what always 
occurs when exporting from layout, but is not an available option in layout files.          

 l Select Export all used and named layers to export all layers that either have something on them or have a layer 
name specified. Not available in layout files.          

  Other Options

 l Scaling Unit - Select the unit of measurement to be used. For best results, choose inches or feet for U.S. Unit plan or 
layout files, or metric units for metric files. See Dimension Preferences and Defaults on page 321.          

 l Uncheck Create Associative Dimensions to export dimensions as simple CAD entities that are not recognized 
dimensions by other programs. Associative dimensions are recognized by AutoCAD® and many other CAD 
programs. 

When exporting a layout page, it is often best to uncheck this box.    

 l Check Export Pattern Lines to export pattern lines. Pattern lines are exported as normal CAD lines.          

 l Check Export Filled Areas to export filled areas as AutoCAD® 2D solid entities.

Dimension lines using non-default               formatting will lose their changes and will use the default format upon export.    

When you are satisfied with your selections, click the Export button to save the exported file as either a .dwg, .dxf, or 
binary .dxf file.           

Note: Binary .dxf is easier for computers to read, is more accurate, and 
occupies less disk space, but some applications do not support binary 
.dxf. 

 

Additional 2D Export Information
The export process converts high level Home Designer objects (doors, windows, etc) into simple, CAD-based objects (lines, 
arcs, etc). Home Designer exports all data to AutoCAD®’s Model Space.          

SUPPORTED ENTITIES

The following entity types are currently supported for 2D export:         

 l Line - The simplest entity. In AutoCAD®, lines are 3 dimensional with the Z coordinate set to zero.         
 l Arc - Arcs have a start angle, end angle and radius.          
 l Circle - Fully Supported.         
 l Multi Line Text - If exporting to an AutoCAD® release that supports multi-line text, Home Designer writes the file as 

multi-line text. If exporting to a version that does not support multi-line text, the file is written as simple text.          
 l Unicode Text - Fully supported.         
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 l Polylines - Polylines are a collection of points with lines or arcs connecting them. Home Designer supports both lines 
and arcs. Arcs are referred to as bulges in AutoCAD®.         

 l Block Insert - A block insert is a reference to a block, which is a named collection of entities. A block can also 
contain block inserts.          

DIMENSIONS

Aligned, rotated, and angular dimensions can all be exported.

Each dimension has an associated block containing a representation of the dimension as it is drawn in Home Designer. It 
also contains all the data to recreate that information.         

 l When an exported dimension is modified in AutoCAD® or other CAD program, its appearance changes.          
 l Home Designer does not support arrowhead styles or fonts.         
 l Three kinds of dimensions are generated: Aligned, Rotated and 3 Point Angular.         
 l Please refer to AutoCAD® documentation for more information.         

Note: Uncheck “Use Associative Dimensions” in the Export Drawing 
File dialog if the CAD program you are using does not support 
AutoCAD® Associative dimensions. See Export Drawing Dialog on page 
884.

LAYERS

Layers in other systems are similar to Home Designer layers, but there are some subtle differences. Layer information is 
mapped as follows:         

Home Designer Other Systems

Name Name

Color Nearest AutoCAD® Color. Home Designer uses the 
default AutoCAD® color table to determine this 
mapping.

Display On

Size Line Weight. In AutoCAD®, line weights are 
determined by a table of mm line widths. Home 
Designer maps to the closest match in this table 
based the current view’s Line Weight Scale. See 
Drawing Sheet Setup Dialog on page 988.

Style Line type

Lock Lock

LINE TYPES

A line type, or line style, is used by layers and entities to determine how lines are drawn. Home Designer line types installed 
with the program are supported on export.         
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Export 360 Panorama
The Export 360 Panorama tool creates a spherical panoramic image that can be opened in various panorama 
viewers. Select File> Export> Export 360 Panorama while a 3D view is active to access this tool.          

For best results, position the camera as near as you can to the center of the scene before exporting.         

EXPORT 360 PANORAMA FILE

All of the settings in this dialog are retained during the current program session.         

 
 

Specify the size of the exported image, in pixels.          

 l Specify the Height and Width of the exported image file, in pixels.         

 l Check Limit Dimensions to Powers of Two to restrict the Width and Height to values that are powers of two. 
When this is checked and an ineligible value is entered, it will adjust up or down to the nearest power of two. 
Although not required, this option is recommended for best results in some panoramic image viewers.          

 l The Retain Aspect Ratio check box displays for reference and cannot be changed. The ratio between Width and 
Height is 2 to 1 when Limit Dimensions to Powers of Two is unchecked, above.         

 
Save to Disk

Check Save to Disk to save the exported panoramic image file on the local computer system.          

 l Click the Browse button to open the Export 360 Panorama File dialog and give the new picture file a name, file 
type, and save location. See Exporting Files on page 39.          
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 l Specify the full pathname of the File you wish to export, or click the Browse button to open the Export 360 
Panorama File dialog, which is a typical File Save dialog. See Exporting Files on page 39.          

 
Save as Backdrop

Check Save as Backdrop to save an exported panoramic image file in the Home Designer Data folder and use it to create a 
new Backdrop in the Library Browser. See Home Designer Pro Data on page 35

 l Specify the Name of the image file, not including its file extension. This will also serve as the Backdrop's name in 
the Library Browser. See The User Catalog on page 706.

 l If the camera view is using either the Physically Based or Clay Rendering Technique, the backdrop image will be an 
.hdr image file; otherwise, it will be a .jpg file. 

 
Save to Chief Architect Cloud

Check Save to Chief Architect Cloud to save the exported panoramic image file to your Chief Architect Cloud Account. 
Up to 99 uploaded panoramic images can be stored in your online account at a time. See Chief Architect Account Login on 
page 876.         

 l Select Create New to upload a new image or select Replace Existing to replace a panoramic image already in your 
Chief Architect Cloud Account with a new one.

 l Type a short, descriptive Name for the exported panoramic image file.          

 l Type a brief Description of the file.         

When you click OK, a panoramic image is created and a progress dialog may display. Because spherical panoramas are 
composed of multiple images stitched together, they may take longer to create than a standard exported picture. See 
Exporting Pictures on page 852.       

Note: You can also upload a previously saved panoramic image file to 
the cloud on the 360 Panoramas page of your online account. 

REPLACE EXISTING 360 PANORAMA DIALOG

The Replace Existing 360 Panorama File dialog opens when you click the Browse button in the Export 360 Panorama to 
replace an existing file previously uploaded to your Chief Architect Cloud Account.

The information in the table is sortable: click a column header to sort all line items in the table by that column. An arrow 
above the column indicates that it is being used to sort the table, and in which direction it is being sorted.

Click on a line item to select it, then click OK to replace it with a new 360 Panorama.
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Export Thermal Envelope Data
A thermal envelope is a three dimensional boundary built around a structure's conditioned space that separates it from the 
unconditioned space around it. Thermal Envelopes are composed of floor platforms, ceiling platforms, walls, doors, and 
windows. 

You can export information about the thermal envelope of the current plan by selecting File> Export> Thermal 
Envelope Data. This data is organized by floor level; notes the direction of walls, doors, and windows; and reports 

the area of each envelope component.

Thermal Envelope Data is exported to a comma delimited .csv text file which can be opened in a text editor or spreadsheet 
application. Once exported, it will automatically open in the application associated with .csv files on your system.
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Chapter 35
 

Terrain

Home Designer Pro allows you to model the terrain around a house. Begin by specifying elevation data that creates the 
surface contours, and then add surface features such as planting areas and water features in level terrain around your house 
plan.

You can import terrain data from a variety of sources and use this data to produce your 3D model. 

Once the terrain is modeled, shadows that follow the terrain can be created using the Sun Angle tool. See Sun Angles and 
Shadows on page 825.           

Driveways, parking lots, and sidewalks as well as plants and sprinklers are among the objects that can be placed in your 
terrain and are discussed in Plants and Sprinklers on page 934 and  Roads, Driveways, and Sidewalks on page 928.

TOPICS

Terrain Toolbar Configuration 891
Terrain Perimeter 891
Elevation Data Tools 893
Terrain Modifier Tools 898
Terrain Features 899
Terrain Wall and Curb Tools 901
Terrain Objects in the Library 902
Displaying Terrain 902
Editing Terrain Objects 904
Terrain Specification Dialog 904
Elevation Point Specification Dialog 908
Elevation Line/Region Specification Dialog 909
Flat Region Specification Dialog 911
Hill / Valley Specification Dialog 911
Raised / Lowered Region Specification Dialog 912
Terrain Feature Specification Dialogs 912
Grass Region Specification Dialog 914
Garden Bed Specification Dialog 916
Terrain Break Specification Dialog 919
Terrain Path Specification Dialog 919
Importing Elevation Data 921
Import Terrain Assistant 922
Import GPS Data Assistant 924
Importing DWG/DXF Elevation Data 926
Converting CAD Objects to Terrain Data 927

890



Home Designer Pro 2025 Reference Manual - Terrain Toolbar Configuration

 

Terrain Toolbar Configuration
The Terrain and Road Tools can be accessed through the Terrain menu. You can also display these tools on your 
toolbar using the Terrain Configuration. See Toolbar Configurations on page 92.          

The Terrain Configuration and Terrain menu both display the following Terrain, Road, Plant, and Sprinkler parent tools:          

  Elevation Tools allow you to create and edit the Terrain Perimeter and generate or remove contour lines.         

  Elevation Data Tools allow you to add elevation data to your terrain.         

  Terrain Modifier Tools model changes in elevation within a defined area.          

  Terrain Feature Tools let you add materials over the top of the terrain.           

  Garden Bed Tools create Terrain Features with a mulch material.         

  Water Feature Tools create Terrain Features with a water material.         

  Stepping Stone Tools are used to create paths composed of multiple Terrain Features.         

  Terrain Wall and Curb Tools let you draw walls and curbs that follow the terrain.         

  Road, Driveway and Sidewalk Tools allow you to create paved areas that can form intersections.          

  Plant Tools allow you to place plant images and 3D plant symbols.          

  Sprinkler Tools are used to lay out sprinkler symbols and irrigation lines.          

 

Terrain Perimeter
The Terrain Perimeter is a closed polyline defining the boundary of the terrain that generates in 3D views and of the 
contour lines that generate in plan view. Select Terrain> Create Terrain Perimeter to create a Terrain Perimeter.

A CAD polyline can also be converted into a Terrain Perimeter. See Editing Terrain Objects on page 904.          

If you create a Terrain Perimeter in plan view but do not see it, select Window> Fill Window . See Zoom Tools on page 

108. 
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When created in a new, blank plan, a new Terrain Perimeter will be 50’ x 100’. If you create a Terrain Perimeter after you 
have drawn all or part of a 3D model, it may increase in size as needed to encompass the structure(s) in plan view.           

Once created, the Terrain Perimeter can be resized and edited like other polyline-based objects. See Editing Closed Polyline-
Based Objects on page 157. 

When a Terrain Perimeter is first created, it is completely flat and is placed at a height of 0’-0”, or sea level.         

The Terrain Perimeter by itself does not have elevation data associated with it. You can use the Elevation Data   and 

Terrain Modifier  tools to create terrain that slopes in a wide variety of ways. If you do not create elevation data within 

the Terrain Perimeter, the terrain remains flat at an elevation of 0' - 0". See Elevation Data Tools on page 893 and Terrain 
Modifier Tools on page 898.         

The Terrain Perimeter has a variety of editable properties, including many that affect the appearance of the terrain in 2D and 
3D views. See Terrain Specification Dialog on page 904.

PLOT PLANS

Using the CAD drawing and editing tools, you can create an accurate plot plan of any building site. 

TERRAIN HEIGHT VS FLOOR HEIGHT

Home Designer always defines the default height of Floor 1 at 0’-0”. This height value is the constant by which the heights 
of structural elements in the program like walls, floors, and ceilings are measured. The heights of architectural object can be 
measured relative this absolute height, as well. See Floor 1 Default Height on page 288.

The default height of Floor 1 is not, however, the absolute by which terrain elevation is measured. Instead, elevation data is  
measured relative to sea level. This means that if you want to, you can use real-world elevation data to generate a 3D terrain 
model without also having to measure floor and ceiling heights from sea level. See Importing Elevation Data on page 921. 

The program automatically positions Floor 1 a set distance above the terrain. To do this, it first calculates the average 
elevation of the building footprint's perimeter and then assigns that average elevation to the center point of the building 
footprint. Finally, it adds the thickness of the floor platform and any sill plates to this value plus either 6” (150 mm) or 8”  
(200 mm) depending on the foundation type. The resulting value, referred to as the automatic Subfloor Height Above 
Terrain, is how far the default height of Floor 1 is above sea level in the current plan. See Foundations and the Terrain on 
page 507.

The Subfloor Height Above Terrain distance is stated and can be modified in the Terrain Specification dialog. You can 
specify a custom value to produce a daylight or walkout basement. See General Panel on page 905. 

BUILD TERRAIN

Select Terrain> Build Terrain to generate the terrain surface based on the elevation data you have provided. Build 
Terrain also updates the Building Pad Elevation value in the Terrain Specification dialog. See Building the Terrain on 

page 903.    
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AUTO REBUILD TERRAIN

By default, terrain will automatically build any time a 3D view is created, ensuring that the terrain in the view is up-to-date. 
If your terrain is very large and/or highly detailed and has not been modified, and you find that this unnecessarily slows 
down the generation of 3D views, consider turning this behavior off in the Terrain Specification dialog. See General Panel 
on page 905. 

When Auto Rebuild Terrain is turned off, the Auto Rebuild Terrain   icon will follow your mouse pointer. See Pointer 
Icons on page 15.         

CLEAR TERRAIN

To remove the generated terrain contours, select Terrain> Clear Terrain. When the terrain is cleared, contours do 
not display in 3D and contour lines do not display in plan view.         

Clear Terrain does not remove the Terrain Perimeter, elevation data, or terrain features from the model. Rather, it deletes 
all program-generated 2D contour lines and 3D contours.         

TERRAIN SURFACE TRIANGLES

Home Designer generates 3D terrain surfaces by dividing them into triangles. The size of the triangles determines how 
detailed contour lines and terrain surfaces in the 3D model can be. You can specify triangle size in the Terrain Perimeter 
Specification dialog. See General Panel on page 905.          

Increasing the triangle count decreases triangle size, yielding more detailed contour lines and a better 3D approximation of 
the terrain. Smaller triangles demand longer terrain generation time and increased memory requirements. If you select a 
large number of small triangles for a large site, you may wait a long time for the calculation.           

Decreasing the triangle count increases triangle size. Elevation lines are sampled less frequently, speeding up terrain 
generation. If you specify a small number of triangles for a plan with detailed elevation data, contour lines and 3D surfaces 
may not generate correctly.           

When a large Terrain Perimeter is used, consider increasing the 
Triangle Count to help make sure all Elevation Data and Terrain 

Modifiers generate contours. 

 

Elevation Data Tools
Select Terrain> Elevation Data to add elevation information to your terrain.          

When terrain is generated, this data is used to calculate the surface of your site and is represented by contour lines in plan 
view and a curved surface in 3D. See Displaying Terrain on page 902.         

Elevation data can be specified using the Elevation Point , Elevation Line , Elevation Spline , Elevation 

Region , and Terrain Break  tools.    

Elevation data can also be imported. See Importing Elevation Data on page 921.         

The elevation of each Elevation Line, Spline, and Region is specified relative to sea level.          

In order to create rising and/or falling terrain, multiple terrain data objects with different elevation values must be used. If 
only one terrain data object is placed, the terrain will be flat regardless of the object’s specified elevation.         
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To avoid unexpected results, do not draw Elevation Data objects 
with different elevation information at the same location. 

ELEVATION POINTS

An Elevation Point contains the absolute elevation data for one point in the terrain model. Typically, Elevation 
Points are imported rather than placed manually.          

Home Designer requires many points to make an accurate approximation of your site. Even small sites may require over a 
hundred points to generate an accurate model of the terrain if it is sloped. For the sake of illustration, the following example 
shows only a few elevation points.         

To place an elevation point

 1.  Select Terrain> Elevation Data> Elevation Point  and click in plan view at the point where you would like to 

place elevation data.              See Place Point on page 201.

 2.  The Elevation Point Specification dialog opens. Enter an elevation value and click OK. See Elevation Point 
Specification Dialog on page 908.         

 3.  Click somewhere else in plan view and the Elevation Point Specification dialog opens again with the last elevation 
value entered.          

 4.  Repeat steps 1, 2 and 3 to place additional elevation points with varied elevation values as needed.         

 5.  Select Terrain> Build Terrain . See Building the Terrain on page 903.         

Elevation Points are most effective when they are imported. 
When adding elevation data manually, use Elevation Lines and 

Splines instead. See Importing Elevation Data on page 921.
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ELEVATION LINES

An Elevation Line contains absolute elevation data for many points along a line at a constant elevation. Elevation 
lines can be connected to create a polyline with many straight sections. For the sake of illustration, the images in the 

following example show single-section elevation lines.         

To draw an elevation line

 1.  Select Terrain> Elevation Data> Elevation Line , then click and drag a line inside the Terrain Perimeter in plan 

view.          

 2.  Click on the elevation line to select it, then click the Open Object  edit button.         

 3.  At first, an elevation line is at elevation 0' - 0". In the Elevation Line Specification dialog, specify the desired 
elevation and click OK. See Elevation Line/Region Specification Dialog on page 909.         

 4.  Repeat steps 2 and 3 to draw additional elevation lines as needed.          

 5.  Select Terrain> Build Terrain . See Building the Terrain on page 903.         

After it is drawn, an Elevation Line can be edited much the way other line-based objects can. See Editing Line-Based 
Objects on page 146.          
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ELEVATION SPLINES

Elevation Splines can be used to form complex curves and shapes. Like elevation lines, elevation splines contain 
absolute elevation data for many points along a constant elevation.

To place an elevation spline, select Terrain> Elevation Data> Elevation Spline  and click and drag multiple sections in 

plan view.  See Splines on page 223.

Elevation splines are initially placed at elevation 0' - 0"and must be opened and assigned an elevation. See Elevation 
Line/Region Specification Dialog on page 909.          

After it is drawn, an Elevation Spline can be edited much the way other spline-based objects can. See Editing Spline-Based 
Objects on page 162.          

ELEVATION REGIONS

An Elevation Region contains absolute elevation data for an enclosed region and is ideal for creating a flat surface in 
your terrain.          

Elevation Regions are similar to Flat Regions in that they produce an area with a flat surface; however, they differ in that an 
Elevation Region affects the contours of the terrain outside its perimeter and may also have some sloping within its 
perimeter. See Flat Regions on page 899.          

To create an elevation region

 1.  Select Terrain> Elevation Data> Elevation Region . 

 2.  There are two ways to add a Terrain Modifier to your plan:          

 l Click once to place an 8’ (0.6 m) square feature at that location.         

 l Click and drag from end-to-end to draw a feature sized as needed. See Rectangular Polyline on page 221.
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 3.  Click on the region to select it, then click the Open Object  edit button.

 4.  At first, an elevation line is at elevation 0' - 0". In the Elevation Region Specification dialog, specify the desired 
elevation and click OK. See              Elevation Line/Region Specification Dialog on page 909.

 l Click once to place an 8’ (0.6 m) square feature at that location.         
 l Click and drag from end-to-end to draw a feature sized as needed. See Rectangular Polyline on page 221.

 1.  Click on the region to select it, then click the Open Object  edit button.

 2.  At first, an elevation line is at elevation 0' - 0". In the Elevation Region Specification dialog, specify the desired 
elevation and click OK. See              Elevation Line/Region Specification Dialog on page 909.

After it is drawn, and Elevation Region can be reshaped much the way other closed polyline-based objects can. See Editing 
Closed Polyline-Based Objects on page 157.         

An Elevation Region  can also be created by drawing a closed polyline using Elevation Lines . 

TERRAIN BREAKS

A Terrain Break creates a division along the terrain surface that affects terrain generation. Elevation data on one 
side of the terrain break does not affect the terrain generation on the other side, allowing you to create immediate 

drops in terrain.         

To place a Terrain Break, select Terrain> Elevation Data> Terrain Break  and click and drag a line in plan view.

 l If the Terrain Break divides the Terrain Perimeter into two separate pieces, the terrain data on either side is calculated 
independently and smoothed separately, resulting in sharp terrain contours.           

 l If the Terrain Break does not extend completely from one side of the Terrain Perimeter to the other, the areas near 
each end of the Terrain Break are blended.           
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The Retaining Wall  tool creates a similar effect by drawing a Terrain Break as well as a retaining wall that rests against 

the break. By default, the top height of the retaining wall matches the terrain on  the high side of the break and the bottom 
matches the low side. See Terrain Wall and Curb Tools on page 901.

 

Terrain Modifier Tools
Select Terrain> Modifier to access tools that allow you to modify the existing elevation data by drawing a closed 
polyline. Their height is relative to the terrain surface generated from the Elevation Data provided in your plan.          

The elevation data associated with a Terrain Modifier only affects the terrain within its perimeter. The rest of the terrain is 
unaffected.          

RAISED AND LOWERED REGIONS

The Raised Region tool creates a raised area with a top surface that is flattened like a plateau but follows the 
surface of the terrain. The Lowered Region tool creates a depression with a bottom that follows the terrain and 

is flattened.          
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HILLS AND VALLEYS

The Hill and Valley tools create raised and lowered areas in the terrain that come to a point rather than  
flattening at their highest or lowest elevations.         

FLAT REGIONS

The Flat Region tool creates an area with a surface that is flattened like a plateau but is level rather than following 
the contours of the terrain.         

There are two ways to add a Terrain Modifier to your plan:          

 l Click once to place a modifier with endpoints that form a 10’ (4 m) square at that location.          
 l Click and drag from end-to-end to draw a feature sized as needed. See Rectangular Polyline on page 221.         

Terrain Modifiers can only be drawn when a Terrain Perimeter is present, and will only display in 3D when they are drawn 
within the perimeter. See Displaying Terrain on page 902.         

Once created, Terrain Modifiers can be selected and edited in a variety of ways. See Editing Spline-Based Objects on page 
162.          

 

Terrain Features
Terrain Features are useful for creating landscaping features that follow the contours of the terrain and have a specified 
height, thickness, and material. Terrain Features can, for example, be used to create paths and planting beds with gravel or 
mulch materials that stand out in a grassy Terrain Perimeter.  

Terrain Features can be drawn in both plan and camera views, but only when a Terrain Perimeter is present. Although they 
can be drawn beyond the extents of the terrain, in 3D views they only display within it. See Displaying Terrain on page 
902.

Terrain Features can be drawn in either of two ways: click-to-create and clicking and dragging. See Creating Objects on 
page 116.

Terrain Features can also be converted from closed 2D CAD polylines or splines using the Convert Polyline  edit tool. 

See Convert Polyline on page 182.

Once created, Terrain Features can be edited into nearly any shape you need. See Editing Closed Polyline-Based Objects on 
page 157 and Editing Spline-Based Objects on page 162.
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You can specify a Terrain Feature's material and height in its specification dialog. See Terrain Feature Specification 
Dialogs on page 912. 

TERRAIN FEATURE TYPES

There are different types of Terrain Feature tool, all accessible in the Terrain menu. Each is designed to efficiently draw 
specific types of features:

  The Terrain Feature Tools create general-purpose features with a concrete material. Terrain Holes are a special 
Terrain Feature that create a hole in the terrain rather than apply a material over it.

  The Garden Bed Tools place features with a surface material and height typical of planting beds. In addition, 
you can choose to distribute copies of a plant image within a Garden Bed. See Distributed Plant Panel on page 

913.
  The Grass Region Tools create  regions of realistic generated 3D grass. See Grass Region Specification Dialog 

on page 914.
  The Water Feature Tools create ponds and streams with material and height attributes typical of bodies of 
water. While Ponds are Terrain Features, Streams are a special type of Terrain Curb with a water material. See 

Terrain Wall and Curb Tools on page 901. 
  The Stepping Stone Tools can be used to create a walkway made of individual stepping stones with material and 
height attributes typical of walking paths.

POLYLINE FEATURES

Most Terrain Feature parent tools have a Polyline Feature child tool that creates rectangular-shaped polyline features that 
can then be edited into a wide variety of shapes. Polyline Features created with a single click initially measure 10' (4 m) per 
side. See Editing Closed Polyline-Based Objects on page 157.

 
Rectangular Feature

 
Terrain Hole

 
Polyline Garden Bed

 
Polyline Grass Region

 
Polyline Stepping Stone

ROUND FEATURES

All Terrain Feature parent tools have a Round Feature child tool that creates spline-based features that are roughly circular 
in shape with smoothly curved corners. Round Features created with a single click are initially about 150 square feet (13.6 
square meters). See Editing Spline-Based Objects on page 162.

 
Round Feature

 
Round Garden Bed

 
Round Grass Region

 
Round Pond
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Round Stepping Stone

KIDNEY SHAPED FEATURES

Most Terrain Feature parent tools have a Kidney Shaped Feature child tool that creates spline-shaped features with smoothly 
curved corners and a right angle bend in their shape. Kidney Shaped Features created with a single click are initially about 
67 square feet (6 square meters). See Editing Spline-Based Objects on page 162.

 
Kidney Shaped Feature

 
Kidney Shaped Garden Bed

 
Kidney Shaped Grass Region

 
Kidney Shaped Pond

TERRAIN HOLES

By default, the program automatically cuts a hole in the terrain around any structures located within and on the same floor 
as the Terrain Perimeter. The shape of these holes follow the exterior surfaces of the walls and will automatically update if 
any of those walls are moved.         

  A Terrain Hole is a Terrain Feature that cuts a hole in the terrain and is useful for manually clipping the terrain 
around a foundation that does not match the footprint of the first floor. Using this tool is the same as creating a 

Terrain Feature and checking Make Hole in the Terrain Feature Specification dialog. See Terrain Feature Specification 
Dialogs on page 912.

 

Terrain Wall and Curb Tools
Select Terrain> Terrain Wall and Curb to draw landscaping walls and curbs that follow the contours of the terrain.          

Straight and curved Terrain Walls and Curbs are drawn just as other walls are. See Creating Walls on page 241.         

Terrain Walls and Curbs are examples of Terrain Paths. Other examples include Sidewalks and Streams. See Terrain Path 
Specification Dialog on page 919.         

TERRAIN WALLS

Use the Straight Terrain Wall tool to draw a wall that sits on top of and follows the terrain.          

Use the Spline Terrain Wall to draw a curved terrain wall. This wall is drawn the same way as a CAD Spline. See 
Splines on page 223.         

Once drawn, a Terrain Wall can be like other line-based objects. See Editing Line-Based Objects on page 146 and Editing 
Spline-Based Objects on page 162.         

Terrain walls are 5’ (1500 mm) high and concrete by default, but you can specify the material, height and more in the 
Terrain Path Specification. See Terrain Path Specification Dialog on page 919.          
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RETAINING WALLS

The Retaining Wall tools function similarly to Terrain Breaks, but include a wall. See Terrain Breaks on page 897.          

Use the Straight Retaining Wall tool draws a straight wall that holds back sloped terrain.         

Use the Curved Retaining Wall tool to draw a curved retaining wall.          

A Retaining Wall’s height is determined by the elevation of the terrain on each side. By default, the height of the wall 
matches the terrain on the high side of the break and the bottom matches the low side. If you insert a Retaining Wall into 
flat terrain, it looks like a concrete strip in 3D views.         

Once drawn, a Retaining Wall can be edited much like other walls. See Editing Walls on page 251.         

TERRAIN CURBS

Terrain Curbs are useful for creating curbs around planting beds and along paths.         

Use the Straight Terrain Curb tool to draw a straight landscaping curb.         

Use the Spline Terrain Curb tool to draw a curved landscaping curb. This curb is drawn the same way as a CAD 
Spline. See Splines on page 223.          

Once drawn, a Terrain Curb can be like other line- and spline-based objects. See Editing Line-Based Objects on page 146 
and Editing Spline-Based Objects on page 162.         

You can specify the height of straight and spline terrain curbs on the GENERAL panel of the Terrain Path Specification. See 
Terrain Path Specification Dialog on page 919.         

You can also add Fencing to your terrain, complete with gates 
from the Doors Library. See Fencing Tools on page 236.

STREAMS

Streams are a special type of spline-based Terrain Curb with a water material. Select Terrain> Water Feature> to 
access the Stream tool. See Terrain Features on page 899.

Streams follow the contours of the terrain, so for best results try to draw them so they follow a downhill course for their 
entire length.

 

Terrain Objects in the Library
The Library Browser contains a variety of objects that can be placed in a plan’s terrain, including plants, exterior 
fixtures, accessories and roadway objects. See The Library Browser on page 692. 

 

Displaying Terrain
The display of terrain objects in 2D and 3D views is controlled in the Layer Display Options dialog. See Layer 
Display Options Dialog on page 127.
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IN PLAN VIEW

Like other objects, terrain objects are placed in Drawing Groups that affect whether they display in front of or behind other 
objects. You can modify a selected object’s place in the drawing order by clicking the View Drawing Group Edit Tools 

 edit button. See Drawing Group Edit Tools on page 129. 

You can customize appearance of Terrain Features, Roads, and other terrain objects in plan view by changing their line and 
fill styles. See Line Style Panel on page 209 and Fill Styles on page 131.

Plant images are represented in plan view by 2D CAD symbols. You can select a plant’s symbol in the Plant Image 
Specification dialog. See Image Panel on page 939.

Sun Shadows are generated by the program and represent shadows cast at a particular location on the Earth and at a specific 
date and time. These shadows are computed based on the contour of the terrain and can be represented by an automatically-
generated CAD polyline in plan view. See Sun Angles and Shadows on page 825.

BUILDING THE TERRAIN

When terrain is generated, Home Designer gathers all elevation data that has been added to the model and creates a 
terrain surface. The program interpolates the data to produce smooth contours.   

A Terrain Perimeter with no additional elevation data drawn within it generates terrain that is flat at the elevation 0' - 0", or 
sea level.   

By default, the terrain is automatically built before a 3D view is generated and when a Sun Shadow is created. This process 
takes a variable amount of time, depending on the amount of elevation data and number of terrain features in the plan. The 
Building Terrain progress dialog displays as terrain is generated, sometimes only briefly, indicating the progress.

You can turn off Auto Rebuild Terrain in the Terrain Specification dialog as well as in the Sun Angle Specification dialog, 
and rebuild the terrain manually only when needed by selecting Terrain> Build Terrain . When Auto Rebuild Terrain 

is turned off and the terrain is not up-to-date, the Build Terrain   icon displays near your mouse pointer. See Terrain 
Specification Dialog on page 904 and Earth Data Panel on page 828.    

CONTOUR LINES

When elevation data has been drawn or imported into a plan, contour lines will display in plan views. See Elevation Data 
Tools on page 893.          

Home Designer Pro can produce both primary and secondary contours. They are on two different layers so you can control 
their display separately. Contour line labels use the Text Styles assigned to the “Terrain, Primary Contours” and “Terrain, 
Secondary Contours” layers.           

By default, all contour lines are set to be primary, but you can specify secondary contours, frequency and other attributes of 
contour lines in the Terrain Specification dialog.  See Contours Panel on page 906.           

IN 3D VIEWS

In order for objects such as Terrain Features and Roads to be visible in 3D views, they must be drawn within the Terrain 
Perimeter. Any portions of these objects drawn outside the Terrain Perimeter will not be seen in 3D views. See Terrain 
Features on page 899.

A variety of tools are available to help you adjust the perspective of your 3D views. See Editing 3D Views on page 791. 
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TERRAIN AND 3D DRAWING TIME

Terrain is typically large with many surface triangles, which often increases the drawing time of 3D views. The time 
required is affected by the quality of the terrain, the amount of elevation data and number of terrain features present. For 
information about surface triangles and how they influence terrain quality, see General Panel on page 905. 

Lights and symbols can be placed outdoors and included in 3D views when the terrain is generated. These objects can also 
contribute to the time needed to generate 3D views. See Rendering Tips on page 815.

 

Editing Terrain Objects
Before a terrain object can be edited, it must be selected. All terrain objects can be selected in plan view. In addition, the 
Terrain Perimeter and Terrain Features can be selected in 3D views. See Selecting Objects on page 142. 

A selected terrain object can be edited using its edit handles, edit tools and specification dialog. See Specification Dialogs 
on page 20.

Any time elevation data is changed, the terrain must be rebuilt. This can be done by selecting Terrain> Build Terrain , 

and occurs automatically when a 3D view is created.         

USING THE EDIT HANDLES

Terrain objects can be moved, resized, and reshaped using their edit handles. How a selected object can be edited depends 
on what type of object it is. See Editing Objects on page 137.

 l The Terrain Perimeter can be moved, resized, and reshaped like a polyline-based objects. 
 l Elevation Points can be moved in plan view using the Move edit handle.         
 l Elevation Lines, Elevation Splines and Terrain Breaks are edited like other line- and spline-based objects.    
 l The shape of a Raised Region, Lowered Region, Hill,              Valley, and Flat Region can be edited like a spline.          
 l Terrain Features are edited like other spline- and polyline-based objects. 

USING THE EDIT TOOLS

A selected terrain object can be edited in a variety of ways using the buttons on the Edit Toolbar. The edit tools available 
for a terrain object depends on the type of object selected. See The Edit Toolbar on page 92.

Note: If you copy terrain objects from one plan to another, you cannot 
view the pasted objects in 3D unless a Terrain Perimeter exists. 

USING DIMENSIONS

Like many other types of objects, terrain objects can be resized and moved using dimensions. For more information 
see Moving Objects Using Dimensions on page 341.

 

Terrain Specification Dialog
The Terrain Specification dialog controls how your terrain is modeled, as well as its appearance. It can be accessed in any of 
three ways:

904



Home Designer Pro 2025 Reference Manual - Terrain Specification Dialog

  Select Terrain> Terrain Specification;          

  Select the Terrain Perimeter and click the Open Object edit button;

  Double-click the Terrain Perimeter using the Select Objects tool. 

GENERAL PANEL

 
Auto Rebuild Terrain

Check Auto Rebuild Terrain to automatically rebuild terrain to reflect recent changes before generating a 3D view or a 
Sun Shadow. If this option is unchecked and the terrain is not up-to-date, the Rebuild Terrain   icon displays near your 
mouse pointer. See Building the Terrain on page 903.

 
Building Pad

Specify how the Building Pad is generated beneath the structure. See Foundations and the Terrain on page 507. 

 l To specify the distance between Floor 1 and the terrain at the building footprint center, uncheck Automatic and enter 
a value in the Subfloor Height Above Terrain field.

 l Check Automatic to have Home Designer automatically lower the terrain relative to the first floor. See Terrain 
Height vs Floor Height on page 892.

 l Check Flatten Pad to flatten the area beneath the building. To create a walkout basement, uncheck this box.         
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Skirt

Define the thickness of the Skirt added to the terrain. The skirt is only visible in 3D views and gives the viewer a sense of 
depth when viewing the terrain.          

 l Flat specifies that the skirt be flat at its base. Home Designer determines the lowest point in the terrain and then 
offsets this value by the user specified thickness value. The resulting value is used as a uniform elevation for the 
base of the skirt.           

 l Follow Terrain specifies that the skirt base maintains a consistent distance below the terrain. The distance is 
equivalent to the specified Thickness value.          

 
Terrain Surface Smoothing

The Terrain Surface Smoothing settings control the amount of curvature applied to terrain edges.           

 l Low produces terrain that has sharp peaks and abrupt changes in slope, while High results in terrain that flows 
continuously from point to point but may take longer to generate.           

 l Select Linear to apply no smoothing to the Terrain. Instead, flat triangular surfaces are created between elevation 
points. This option is only recommended when large amounts of closely spaced elevation data is present.           

 
Triangle Count

Specify the number of surface triangles used to generate the terrain in 3D views. A lower count value will generate more 
quickly but have reduced quality.          

 l Specify a Custom triangle count value.           

 l Specify the maximum Triangle Size in the terrain surface. Smaller triangles produce better quality results in 3D but 
take longer to generate.          

Home Designer builds 3D terrain surfaces by splitting them into triangles. See Terrain Surface Triangles on page 893.

Triangles are computed roughly as follows:

Size of Triangle = Area of Terrain Perimeter / Number of Triangles

The Low (1000), Medium (2000), and High (4000) values work well for a Terrain Perimeter of approximately 20,000 sq ft 
(1858 m²). If your Terrain Perimeter varies greatly from this, consider defining the number of triangles using the Custom 
setting or the Triangle Size setting.

 
Clipping

Check Hide Terrain Intersected by Building to cut out the portion of the terrain that is intersected by the first floor 
footprint. Checking this box prevents the generation of contour lines inside the house. 

If your foundation footprint differs from your first floor footprint, you may need to use the Terrain Hole  tool for 

custom clipping instead. See Terrain Features on page 899.

CONTOURS PANEL

Home Designer Pro identifies two types of contour lines: Primary and Secondary. They are drawn on different layers, so 
you can control how they display in plan view. See Contour Lines on page 903.          
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Frequency

Specify the Frequency at which contour lines are generated.         

 l Define the Interval between contour lines, which is the change in elevation between contours. If the interval is set to 
12”, a contour line is computed for each elevation change of 12”.          

 l Specify the Offset value. When the Offset is 0, a contour line will be drawn at zero elevation and additional contours 
will generate based on the Interval value. If the Offset is changed to 5, a contour line will be drawn 5 units from zero 
elevation rather than at 0, and additional contours will generate from there.          

 l Primary contour every__contours - Specify the interval for primary contours. A value of 1 produces only primary 
contours, while a value of 5 defines every fifth contour line as a primary contour.          

 
Smoothing

If contour Smoothing is turned on, Home Designer attempts to remove sharp bends and jagged sections from the 2D 
contour lines.         

 l Specify the number of Passes to perform when smoothing. The more passes, the smoother the contour lines become, 
but contours become less accurate.          

 
Label Options

Control the display of Contour Labels in plan view.          

 l Check Label Primary Contours to label primary contour lines with their elevation data using the Units specified 
below.           

 l Check Label Secondary Contours to label secondary contour lines with their elevation data.           

 l Check Highlight Negative Elevations to display labels of contour lines with elevations below 0 in red. When 
unchecked, they use the color set in the Text Style assigned to their layer.           
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Primary and secondary contour line labels use the Text Style 
assigned to their respective layers. See Text Styles on page 

373.

 
Label Units

Specify the Label Units used by contour labels. Select either Inches or Decimal Feet (Millimeters or Meters for metric).         

POLYLINE PANEL

The POLYLINE panel states the length of the Terrain Perimeter’s Perimeter, its enclosed Area, and its Volume. 

The settings on this panel are available for a variety of other objects in the program. For information about these settings, 
see Polyline Panel on page 219.

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. See Line Panel on page 208.

The SELECTED ARC panel is available when the selected edge has been converted into an arc. See Arc Panel on page 214.

See, too, Selected Edge on page 143 and Change Line/Arc on page 176.

LINE STYLE PANEL

The settings on the LINE STYLE panel are available for a variety of other objects in the program. See Line Style Panel on 
page 209.

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the Terrain Perimeter in plan view. See Fill Style Panel and 
Dialogs on page 132.

MATERIALS PANEL

The settings on the MATERIALS panel let you specify the terrain surface and terrain skirt materials used in 3D views. These 
materials are not calculated in the Materials List. See Materials Panel on page 750.

 

Elevation Point Specification Dialog
To open the Elevation Point Specification dialog, select an elevation point and click the Open Object edit button, or 
double-click on an Elevation Point using the Select Objects  tool.

Use the Elevation Point Specification dialog to define the selected elevation point and control its appearance in plan view.          
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GENERAL PANEL

 
Location

Specify the exact location of the elevation point.         

 l Specify the Elevation of the selected Elevation Point.          

Click the Number Style button to specify the units of 
measurement used in this and other dialogs. See Dialog 

Number/Angle Style Dialog on page 88. 

 l X Position - Enter the x coordinate of the elevation point.         

 l Y Position - Enter the y coordinate of the elevation point.         

  Display

 l In the Text field, type any notes that you would like to display beside the selected Elevation Point in plan view.          

 l Enter the Marker Radius, which is the size of the point marker, measured from the center to an edge.          

LINE STYLE PANEL

The settings on the LINE STYLE panel are available for a variety of other objects in the program. For information about these 
settings, see Line Style Panel on page 209.         

TEXT STYLE PANEL

The settings on the TEXT STYLE panel control the appearance of the selected Elevation Point’s text. For more information, 
see Text Style Panel on page 373.          

 

Elevation Line/Region Specification Dialog
To open the Elevation Line or Elevation Region Specification dialog, select an Elevation Line, Spline, a polyline 
composed of Elevation Lines or Splines, or an Elevation Region and click the Open Object edit button. You can also 

double-click an Elevation Line/Spline using the Select Objects  tool.

The Elevation Line Specification dialog is used to define the selected Elevation Line             /Spline and controls its appearance in 
plan view.          
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The settings in this dialog are the same as those in the Elevation Region Specification dialog. See Elevation Regions on 
page 896.          

ELEVATION PANEL

 l Specify the Elevation of the selected Elevation Line, Spline, or Polyline.         

Click the Number Style button to specify the units of 
measurement used in this and other dialogs. See Dialog 

Number/Angle Style Dialog on page 88. 

 l Check Interior is Flat to maintain a flat surface at the specified Elevation. When unchecked, the perimeter of the 
region maintains the specified Elevation, but the interior elevation may vary depending on other elevation data in the 
drawing. Only available for closed Elevation Regions.          

 l Check Interpolate Tangent to Edge to flatten the terrain surface as it approaches the edges of the Elevation Region. 
This option is only available for closed Elevation Regions, and only when Interior is Flat is unchecked.           

POLYLINE PANEL

The POLYLINE panel states the Length of an open polyline or the Perimeter of a closed polyline. If multiple Elevation Line             
/Spline segments form a closed Elevation Region, its Area will be calculated. Elevation Lines             /Splines do not have a 
thickness, so they have no Volume.         

SPLINE PANEL

The SPLINE panel has a single option and is only available when the selected object is an Elevation Spline. See Splines on 
page 223.          

New Segment Angle - Specify the angle between line segments that are used to draw the spline. Specifying a smaller angle 
makes the spline smoother. Specify a larger angle to draw the spline faster.          

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. See Line Panel on page 208.         

The SELECTED ARC panel is available when the selected edge has been converted into an arc. See Arc Panel on page 214.         

See, too, Selected Edge on page 143 and Change Line/Arc on page 176.         

LINE STYLE PANEL

The settings on the LINE STYLE panel are available for a variety of other objects in the program. See Line Style Panel on 
page 209.         
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Flat Region Specification Dialog
To open the Flat Region Specification dialog, select a Flat Region and click the Open Object edit button, or double-
click a Flat Region using the Select Objects  tool. See Flat Regions on page 899.          

The options in the Flat Region Specification dialog are similar to those a number of other dialogs in the program.          

POLYLINE PANEL

The POLYLINE panel states the length of the region’s Perimeter and its enclosed Area. Flat Regions do not have a Volume 
measurement. See Polyline Panel on page 219.           

SPLINE PANEL

The SPLINE panel has a single option and is only available when the selected object is a spline.  See Splines on page 223.         

New Segment Angle - Specify the angle between line segments that are used to draw the spline. Specifying a smaller angle 
makes the spline smoother. Specify a larger angle to draw the spline faster.          

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. See Line Panel on page 208.          

The SELECTED ARC panel is available when the selected edge has been converted into an arc. See Arc Panel on page 214.          

See, too, Selected Edge on page 143 and Change Line/Arc on page 176.          

LINE STYLE PANEL

The settings on the LINE STYLE panel are available for a variety of objects in the program. See Line Style Panel on page 
209.          

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected object in plan view. See Fill Style Panel and 
Dialogs on page 132.          

 

Hill / Valley Specification Dialog
The Hill/Valley Specification defines the selected Hill or Valley and controls its appearance in plan view.          

To open the Hill/Valley Specification dialog, select one or more Hills or Valleys and click the Open Object edit button, or 
double-click the region(s) using the Select Objects  tool.
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HILL / VALLEY PANEL

 l Enter a Height for the selected Hill or Valley. This height is relative to the terrain surface that is generated from the 
Elevation Data in your plan. See Terrain Modifier Tools on page 898.         

POLYLINE PANEL

The POLYLINE panel states the length of the hill or valley’s Perimeter and its enclosed Area. Hills and Valleys do not have 
a volume measurement.          

SPLINE PANEL

The SPLINE panel has a single option. See Splines on page 223.

New Segment Angle - Specify the angle between line segments that are used to draw the spline. Specifying a smaller angle 
makes the spline smoother. Specify a larger angle to draw the spline faster.          

LINE STYLE PANEL

The settings on the LINE STYLE panel are available for a variety of other objects in the program. See Line Style Panel on 
page 209.         

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected object in plan view. See Fill Style Panel and 
Dialogs on page 132.         

 

Raised / Lowered Region Specification Dialog
To open the Raised/Lowered Region Specification dialog, select one or more raised or lowered regions and click the 
Open Object edit button, or double-click the region(s) using the Select Objects  tool.

The Raised / Lowered Region Specification dialog is similar to the Hill / Valley Specification dialog. See Hill / Valley 
Specification Dialog on page 911.         

 

Terrain Feature Specification Dialogs
To open the Terrain Feature Specification dialog, select one or more Terrain Features and click the Open Object edit 
button, or double-click on a Terrain Feature using the Select Objects  tool. A number of related objects including 

Ponds, Stepping Stones, Driveways, and Parking Lots use this same specification dialog. See Terrain Features on page 899.
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Garden Beds are also a type of Terrain Feature and have an additional DISTRIBUTED PLANT panel in their Garden Bed 
Specification dialog. 

The panels that are available in the Terrain Feature Specification dialogs will vary, depending on the type of Terrain Feature 
that is selected.

GENERAL PANEL

 l Specify the Terrain to Top value, which is the distance from the top surface of the terrain to that of the terrain 
feature. If this value is a negative number, the feature sinks into the terrain.    

 l Specify the feature’s Thickness.
 l Check Make Hole to specify the selected Terrain Feature as a Terrain Hole. See Terrain Holes on page 901.          
 l Check Clip Overlapping Terrain Features to suppress the 3D display of any part of the selected Terrain Feature 

intersected by other Terrain Features with a lower Terrain to Top value. Clipping is useful for creating features that 
contain other features such as planters or swimming pools.

DISTRIBUTED PLANT PANEL

This panel is only available when the selected Terrain Feature is a Garden Bed. See              Distributed Plant Panel on page 917.

POLYLINE PANEL

The POLYLINE panel states the length of the garden bed’s Perimeter, its enclosed Area, and its Volume. See Polyline Panel 
on page 219.

SPLINE PANEL

The SPLINE panel has a single option and is only available when the selected object is a spline.  See Splines on page 223.         

New Segment Angle - Specify the angle between line segments that are used to draw the spline. Specifying a smaller angle 
makes the spline smoother. Specify a larger angle to draw the spline faster.         

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. See Line Panel on page 208.

The SELECTED ARC panel is available when the selected edge has been converted into an arc. See Arc Panel on page 214.

See, too, Selected Edge on page 143 and Change Line/Arc on page 176.
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LINE STYLE PANEL

The settings on the LINE STYLE panel are available for a variety of other objects in the program. See Line Style Panel on 
page 209.

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected object in plan view. See Fill Style Panel and 
Dialogs on page 132.

MATERIALS PANEL

The settings on the MATERIALS panel affect the appearance of the selected object in 3D views. See Materials Panel on page 
750.

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 967.          

 

Grass Region Specification Dialog
To open the Grass Region Specification dialog, select one or more Grass Regions and click the Open Object edit 
button, or double-click a Grass Region using the Select Objects  tool. See Terrain Features on page 899.

The settings in this dialog are similar to those in the Grass Region Defaults dialog.

Most of the panels in this dialog are similar to those for a variety of other objects in the program.

The Grass Region Specification dialog has the following panels:

GENERAL PANEL

 
Blades

Specify the physical attributes of the selected region's blades of grass.    
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 l Specify the Density value, which controls how closely the blades of grass are to one another.    

 l Specify the grass blades' Minimum and Maximum Height.

 l Specify the grass blades' Minimum and Maximum Width.

 l Specify the grass blades' Minimum and Maximum Curve. A value of 0° produces grass blades that are completely 
straight.

  Appearance

 l Specify the Color values, which are the colors assigned to the grass blades. 

 l Specify the Noise Frequency, which is the amount of speckled light reflected off the grass blades.

 l Specify the Roughness of the grass blades. Adjusting this value can also affect the appearance of lighting noise in 
some scenes.     

 o Check Mow to clip the pointed ends of the tallest grass blades so they have a straight top edge and enable the 
settings that follow: 

 o Specify the grass blades' Cut Height, which is the height at which the tallest blades are clipped.

 o Specify the Mow Line Intensity, which is the degree to which all grass blades are cut to the Cut Height.

 o Specify the Mow Line Width, which defines the variance in height that grass blades may have.

 o Specify the Mow Line Angle, which is the cut angle on the blades of grass.

 
Preview

A preview of the selected Grass Region displays on the right side of the panel. The Vector View Rendering Techniques is 
not available for Grass Regions. See Dialog Preview Panes on page 21.    

POLYLINE PANEL

The POLYLINE panel states the length of the region’s Perimeter, its enclosed Area, and more. See Polyline Panel on page 
219.

SPLINE PANEL

The SPLINE panel has a single option and is only available when the selected region is a spline.  See Splines on page 223.         

New Segment Angle - Specify the angle between line segments that are used to draw the spline. Specifying a smaller angle 
makes the spline smoother. Specify a larger angle to draw the spline faster.         

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. See Line Panel on page 208.

The SELECTED ARC panel is available when the selected edge has been converted into an arc. See Arc Panel on page 214.

See, too, Selected Edge on page 143 and Change Line/Arc on page 176.
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LINE STYLE PANEL

The settings on the LINE STYLE panel are available for a variety of other objects in the program. See Line Style Panel on 
page 209.

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected object in plan view. See Fill Style Panel and 
Dialogs on page 132.

MATERIALS PANEL

The settings on the MATERIALS panel affect the appearance of the soil surface located under the blades of grass in 3D views. 
See Materials Panel on page 750.

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 967.          

 

Garden Bed Specification Dialog
Select a Garden Bed and click the Open Object edit button to open the Garden Bed Specification dialog. This dialog 
is similar to the Terrain Feature Specification dialog; however, the DISTRIBUTED PLANT panel is unique to Garden 

Beds. See Terrain Feature Specification Dialogs on page 912.
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             DISTRIBUTED PLANT PANEL

 
Selected Object

Specify object assigned to the selected region. When an object is assigned, its name and a preview of a single instance of it 
display here.    

 l Click the Library button to choose an object from the library. See Select Library Object Dialog on page 716.    

 l Click the Delete button to unassign the currently selected object from the selected region.    

 l Click the Edit button to open the Selected Object’s specification dialog. Changes made here affect all objects 
generated within the region. See Specification Dialogs on page 20.    

You can replace the plant assigned to a Garden Bed by applying 
a new one directly from the library. See    Replace From Library 

on page 717.

  Display Options

 l Check Show Objects to display the distributed objects in plan view.

 l Check Show Region to display the distribution region outline in plan view.

 
Spacing

Specify how the objects distributed in the region are spaced. 
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 l Specify the Distance between the objects in the region, as measured from their center points. When Auto Spacing is 
checked, this setting is automatically populated by a value that is 10% greater than the larger of either the object's 
Height or Width.

 l Objects in the region can be randomly offset from their default positions if you wish. Specify their Maximum 
Offset, measured from their center points. Not available when Evenly Scattered is selected, below.

 l Specify the style of Distribution:     

 o Select Standard Grid to position the objects in rows and columns based on the standard X/Y grid in the program. 
This grid is affected by Rotate Plan View. See Rotate Plan View on page 104.

 o Select Alternate Grid to position the objects in rows and columns based on the shape of the region.

 o Select Evenly Scattered to distribute the objects evenly but not on a grid layout.

 
Orientation

Specify how or if the objects in the region are rotated. These settings do not affect the region itself or its edges.    

 l Specify the Angle that the distributed objects should be placed at.

 l Angle Options:    

 o Select Absolute Angle to rotate the objects relative to an imaginary horizontal line drawn in the positive X direction 
from the origin. See 3D Drafting on page 12. 

 o Select Relative Angle to rotate the objects relative to the angle of the region’s first edge or, if that edge is curved, to 
the angle of its chord. The first edge is typically located at the top of the region when it is first created; however, this 
can change as the region is edited.

 o Select Random Angle to rotate the objects in the region at a variety of random angles. 

 
Positioning

Specify the positioning of the distributed objects relative to a point of origin within the region. 

 l Specify the X Offset, the horizontal distance in plan view from the region’s specified point of origin. 

 l Specify the Y Offset, the vertical distance in plan view from the region’s specified point of origin. 

 l Select Offset From Polyline Start to measure the offset from the region’s start point. This start point is typically 
located at the top left of the region when it is first created; however, this can change as the region is edited. 

 l Select Offset From Polyline Center to measure the offset from the region’s center point. 

  Scaling

 l Check Scaling to specify a range of size variation of the objects in the region.

 o Specify the Minimum Scale, which is the smallest resize of the objects allowed. 

 o Specify the Maximum Scale, which is the largest resize of the objects allowed.

 
Preview

A preview of the region displays on the right side of the dialog box. If no object has been assigned to the selected region, 
Plan View will be the default preview type. See Dialog Preview Panes on page 21. 

For more information, see Label Panel on page 376.
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COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 967.    

 

Terrain Break Specification Dialog
To open the Terrain Break Specification dialog, select a Terrain Break or group of Terrain Breaks and click the Open 
Object edit button or double-click the Terrain Break(s) using the Select Objects  tool. See Terrain Breaks on 

page 897. 

GENERAL PANEL

 l Define the Transition Distance, which is the distance from the edge of the terrain break to where the break stops 
affecting the terrain.           

POLYLINE PANEL

The POLYLINE panel states the Length of an open polyline or the Perimeter of a closed polyline. If multiple Terrain Break 
segments form a closed polyline, its Area will be calculated. Terrain Breaks do not have a thickness, so they have no 
Volume. See Polyline Panel on page 219.           

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. See Line Panel on page 208.          

The SELECTED ARC panel is available when the selected edge has been converted into an arc. See Arc Panel on page 214.          

See, too, Selected Edge on page 143 and Change Line/Arc on page 176.          

LINE STYLE PANEL

For information about the LINE STYLE panel, see Line Style Panel on page 209.          

FILL STYLE PANEL

The FILL STYLE panel is only available when multiple Terrain Break segments enclose an area. The settings on this panel 
affect the appearance of the closed shape in plan view. See Fill Style Panel and Dialogs on page 132.          

 

Terrain Path Specification Dialog
To open the Terrain Path Specification dialog, select one or more Sidewalks, Streams, Terrain Walls, or Terrain 
Curbs and click the Open Object edit button, or double-click the terrain path(s) using the Select Objects 
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 tool. See Terrain Wall and Curb Tools on page 901.

Most of the panels in this dialog are similar to those for a variety of other objects in the program.

GENERAL PANEL

The Flare settings on the GENERAL panel are only found in the Road Specification and Driveway Specification dialogs.

  Size

 l Specify the path's Width.     

 l Specify the Terrain to Top value, which is the distance from the top surface of the terrain to that of the path. If this 
value is a negative number, the object sinks into the terrain.     

 l Specify the path's Thickness.    

 
Flare

When one terrain path joins another, you can flare the intersection.          

 l Check Start to create a flare at the starting end of the selected terrain path, then specify the Radius of that flare.          

 l Check End to create a flare at that end of the terrain path, then specify the Radius of that flare.          

 
Preview

A preview of the selected cabinet displays on the right side of the panel. See Dialog Preview Panes on page 21. 
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POLYLINE PANEL

The POLYLINE panel states the length of the Terrain Path’s Perimeter, its enclosed Area, and its Volume. See Polyline 
Panel on page 219. 

SPLINE PANEL

The SPLINE panel has a single option and is only available when the selected object is a spline path. See Splines on page 
223.          

 l New Segment Angle - Specify the angle between line segments that are used to draw the spline. Specifying a smaller 
angle makes the spline smoother. Specify a larger angle to draw the spline faster.          

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. See Line Panel on page 208.

The SELECTED ARC panel is available when the selected edge has been converted into an arc. See Arc Panel on page 214.

See, too, Selected Edge on page 143 and Change Line/Arc on page 176.

LINE STYLE PANEL

The settings on the LINE STYLE panel are available for a variety of other objects in the program. See Line Style Panel on 
page 209.

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected object in plan view. See Fill Style Panel and 
Dialogs on page 132.

MATERIALS PANEL

The settings on the MATERIALS panel affect the appearance of the selected object in 3D views. See Materials Panel on page 
750.

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 967.   

 

Importing Elevation Data
Elevation data can be added to a plan using the tools and techniques described in this chapter or it can be imported from a 
file. See Elevation Data Tools on page 893.         

Home Designer Pro can import elevation data saved in              DXF/DWG, GPS Exchange (.gpx) and a variety of text file formats 
(.txt, .csv, .prn, .xyz, .auf and .nez). If your terrain data is not saved in one of these file formats, there are third party 
programs available that can convert to these formats.          
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DXF/DWG FILES

If you have a model of your terrain created on another program that contains contour lines and elevation data, that 
information can be imported directly as elevation data into Home Designer Pro as a .dxf or a .dwg file. See Importing 
DWG/DXF Elevation Data on page 926.          

TEXT FILES

Elevation data can be saved in text files as x, y, and z coordinates where x and y define the location of a point on a 
Cartesian grid, and z defines the elevation for that point. Each data point must be on a separate line in the text file.          

Importable text files can come from surveyors, other software programs, or you can create your own using a GPS system.          

Elevation data saved in text files can be imported using the Import Terrain Assistant.              See Import Terrain Assistant on page 
922.         

GPS EXCHANGE FILES

Elevation data in standard format .gpx files created using a GPS system can also be imported using the Import GPS Data 
Assistant. See Import GPS Data Assistant on page 924.          

GPS data may include three types of points - Way, Track, and Route. Home Designer Pro can only import a .gpx file if it 
includes one or more Way Points, and cannot use Route Points at all. If a .gpx file does not include any Way Points, it will 
not be imported, and if it includes any Route Points, they will be ignored.           

Home Designer supports the import of data in standard .gpx files that adhere to the GPX 1.1 Schema. Files that do not 
follow this standard cannot be imported.         

 

Import Terrain Assistant
The Import Terrain Assistant allows you to import elevation data saved in text (.txt) file format into a plan.         

Each data point in this format has information about its X-axis (East to West location), Y-axis (North to South location), and 
Z-axis (elevation). It might also have a brief description. In order to import elevation data from a text file, you need to know 
how the data in the file is organized.          

To launch the Import Terrain Assistant, select File> Import> Terrain Data . Click Next.         

SELECT FILE
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  Select a file to import

 l Click the Browse button to locate a file on your computer. See Importing Files on page 43.          

 l If a file has been selected, its full pathname displays here for reference; if a file has not been selected, the directory 
of the last file imported displays. If the pathname is not that of a valid .txt file, this text will display in red.          

  Select the organization of the data

 l Elevation information can be organized in one of six different ways, and can be separated by either a comma 
(comma delimited) or a space (space delimited).          

 l XYZ - Information in this format begins with the X coordinate, followed by the Y coordinate and the Z coordinate.         

 l #XYZ - Information in this format begins with a number that belongs to each data point followed by the X 
coordinate, the Y coordinate, and the Z coordinate.         

 l #XYZ Description - Information in this format begins with a number that belongs to each data point followed by the 
X coordinate, the Y coordinate, the Z coordinate, and a description.         

 l YXZ - Information in this format begins with the Y coordinate followed by the X coordinate and the Z coordinate.         

 l #YXZ - Information in this format begins with a number that belongs to each data point followed by the Y 
coordinate, the X coordinate, and the Z coordinate.         

 l #YXZ Description - Information in this format begins with a number that belongs to each data point followed by the 
Y coordinate, the X coordinate, the Z coordinate, and a description.         

Click Next to continue.         

SCALE DATA

  Imported Data

 l The total number of data points to be imported and the ranges of their coordinates are described here.
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  Units

 l Select the Units of measurement used for each axis.

  Map

 l Map a data point in the file to the origin in Home Designer to position the terrain data relative to your plan. See 3D 
Drafting on page 12.

  Scale 

 l To change the scale of the terrain, multiply the coordinates of each axis by a specific number to decrease or increase 
the relative size or relief of your terrain.

  Rotate North Counterclockwise

 l Specify an amount to rotate the terrain data counterclockwise, or to the left.
Click Next to finish.

 

Import GPS Data Assistant
The Import GPS Data Assistant allows you to import terrain data from the standard .gpx file format. See GPS 
Exchange Files on page 922.         

Select File> Import> GPS Data to open the Import GPS Data Assistant, then click Next to continue.         

 Due to the lack of accuracy in some GPS systems, exact 
distances using the Import GPS Data Assistant are not 

guaranteed.

SELECT FILE

  Select a file to import

 l Click the Browse button to locate a .gpx file on your computer. See Importing Files on page 43.          

 l If a file has been selected, its full pathname is reported here for reference; if a file has not been selected, the 
directory of the last file imported displays. If the pathname is not that of a valid .gpx file, this text will display in 
red.          
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Note: Not all GPS programs use the standard .gpx file format; 
however, only files using the standard format can be imported.

Click Next to continue.

IMPORT DATA AS

 
Name

Specify which items you want to import by checking the box to the left of the Name. Items with unchecked boxes are not 
imported.         

 
Import As

Specify what you would like the selected item to Import As from the drop-down list.         

 l Only Way Points have elevation data associated with them. To import this data, import them as “Elevation Points”.          

 l Select “Marker” to import either Way Points or Track Points as location markers. Markers have no elevation data 
associated with them.         

 l Select “Polyline” to create an open CAD polyline based on the position of Way Points or Track Points. The points 
themselves are not imported. Polylines have no elevation data associated with them.         

 l Select “Terrain Perimeter” to create a closed Terrain Perimeter polyline based on the position of either Way Points 
or Track Points. The points themselves are not imported. A Terrain Perimeter has no elevation data associated with 
it. See Terrain Perimeter on page 891.          

Way Points are typically imported as “Elevation Data”, 
while Track Points are imported as “Markers”, “Polylines’, 

or “Terrain Perimeter”. 

Click Next to continue.
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TRANSFORM COORDINATES

  Lower Elevation Data by

 l Specify the amount that you would like to lower all imported elevation data.          

  Rotate North Counterclockwise

 l Specify an amount to rotate the terrain data counterclockwise, or to the left.           

  Map this point to the origin

 l Specify a point in the imported terrain data, defined by degrees Latitude and Longitude, that you would like to 
locate at the origin in the Home Designer plan.          

Click Next to finish.

If you do not see the imported terrain, select Window> Fill Window .

 

Importing DWG/DXF Elevation Data
Select File> Import> Drawing (DWG/DXF)  to open the Import Drawing Assistant, which you can use to import 
elevation data in .dwg/.dxf format. See Import Drawing Assistant on page 880. 

By default, the Import Drawing Assistant imports entities as regular CAD objects; however, you can specify that any layer 
in the drawing be converted to either a Terrain Perimeter or Elevation Data. If a layer is converted to Elevation Data, any 
points and lines on that layer are converted to Elevation Points and Lines, and any elevation data associated with them is 
preserved. Elevation data associated with objects in CAD blocks is not recognized, however.

 l If an imported line has vertices with the same Z values, an Elevation Line is created.
 l If the vertices have differing Z values, an Elevation Point is created for each vertex.
 l Imported points are converted to Elevation Points.
 l Other imported entities (solids, faces, etc.) are imported normally.

To avoid unexpected results when importing a drawing, only 
convert layers with elevation information to Elevation Data. 
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If a Terrain Perimeter does not exist in the plan or if a layer in the .dwg/.dxf file is not converted to a Terrain Perimeter, a 
Terrain Perimeter is created around the extents of the Elevation Data when it is imported.  

 

Converting CAD Objects to Terrain Data
CAD lines, splines, and polylines - either imported or drawn using Home Designer Pro’s CAD Tools - can be 
selected and converted to terrain data using the Convert Polyline edit tool.

In plan view, select a CAD line, spline, or polyline and click the Convert Polyline  edit button to open the Convert 

Polyline dialog. See Convert Polyline on page 182.

A Terrain Perimeter must exist before any other types of terrain object can be created. If no Terrain Perimeter is present in 
the current plan, this will be the only terrain item available in the Convert Polyline dialog.            

When you click OK, the terrain object’s specification dialog opens, allowing you to specify elevation data or other 
attributes.
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Chapter 36
 

Roads, Driveways, and Sidewalks

Roads, sidewalks, driveways and parking lots are modeled in 3D like other terrain objects in Home Designer. Because they 
have much in common with terrain objects and rely upon terrain data to be viewed in 3D, it is helpful to be familiar with 
terrain modeling before using these tools. See Terrain on page 890.

TOPICS

Road, Driveway, and Sidewalk Tools 929
Displaying Road Objects 930
Editing Road Objects 931
Road Specification Dialog 931
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Road, Driveway, and Sidewalk Tools
Roads objects can be drawn in plan view, camera views and overviews, but only when a Terrain Perimeter exists in 
the plan. See Terrain Perimeter on page 891. 

Straight and Spline road objects:

 l Are typical line- and spline-based objects, and can be edited as such. 
 l Are flat along their widths, which makes it easy to create roads on sloping terrain.
 l Can be joined end-to-end to form intersections and networks.
 l Have a consistent width that can be defined in their specification dialogs. See Road Specification Dialog on page 931 

and Terrain Path Specification Dialog on page 919. 

Driveways and Parking Lots, on the other hand, are actually Terrain Features which follow the contours of the terrain rather 
than cut into them. They are drawn as rectangles but can be edited to any shape. See Terrain Features on page 899 and 
Editing Closed Polyline-Based Objects on page 157.

Once road objects have been placed, they can be edited individually or as a group. See Editing Road Objects on page 931.

ROAD TOOLS

Select Terrain> Road and Sidewalk> Straight Road, then click and drag to draw a line within the Terrain 
Perimeter to draw a Straight Road. 

The ends of multiple road sections can be connected together. Roads are edited along their center line and can be edited 
much like other line-based objects. See Editing Line-Based Objects on page 146.

Select Terrain> Road and Sidewalk> Spline Road, then click and drag to draw a curved road composed of spline 
segments. 

Spline roads are drawn and edited like other spline-based objects. See Editing Spline-Based Objects on page 162. 

SIDEWALK TOOLS

To create a sidewalk with no curves, select Terrain>  Road and Sidewalk> Straight Sidewalk, then click and drag 
a line within the Terrain Perimeter.

Sidewalks are edited along their center line like line-based objects. See Editing Line-Based Objects on page 146. 
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Select Terrain> Sidewalk> Spline Sidewalk, then click and drag to draw a curved sidewalk composed of spline 
segments. 

DRIVEWAY AREA

A Driveway Area is a terrain feature with a concrete material assignment. To create a driveway, select Terrain> 
Road and Sidewalk> Driveway Area, then click and drag from corner to corner to draw a rectangle. See 

Rectangular Polyline on page 221.         

Height, thickness and material information can be specified in a driveway’s specification dialog. See Terrain Feature 
Specification Dialogs on page 912.         

Driveways can be edited like other closed polylines. See Editing Closed Polyline-Based Objects on page 157.         

PARKING LOT

A Parking Lot is a terrain feature with an asphalt material assignment. To place a parking lot, select Terrain> Road 
and Sidewalk> Parking Lot, then click and drag from corner to corner to draw a rectangle. See Rectangular 

Polyline on page 221.         

Height, thickness and material information can be specified in a parking lot’s specification dialog. See Terrain Feature 
Specification Dialogs on page 912.         

 

Displaying Road Objects
Roads and sidewalks display in floor plan and 3D views based on the settings for their layers in the Layer Display 
Options dialog. See Layers on page 124.

IN 3D VIEWS

In order for Road objects to be visible in 3D views, they must be drawn within the Terrain Perimeter. Any portions of these 
objects drawn outside the Terrain Perimeter will not be seen in 3D views. 

By default, the terrain rebuilds automatically when road objects are added, removed or edited. If it does not, you can select 
Terrain> Build Terrain . See Terrain Perimeter on page 891.
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Editing Road Objects
Road objects can be selected in 2D and 3D views and edited using the edit handles, the Edit Toolbar, and their specification 
dialogs. 

Terrain Walls  and Terrain Curbs are also Road objects. See Terrain Wall and Curb Tools on page 901.

USING THE EDIT HANDLES

The edit handles available for a selected road object depend on the type of object selected. 

 l Straight Roads , straight Terrain Walls , and straight Terrain Curbs  are edited along their centerline like 

a line or open polyline. See Editing Line-Based Objects on page 146. 
 l Spline Roads , Spline Sidewalks, Spline Terrain Walls  are edited along their centerline like CAD splines. 

See Editing Spline-Based Objects on page 162.
 l Driveway Areas  and Parking Lots  are edited like other closed polyline based objects. See Editing Closed 

Polyline-Based Objects on page 157.             

IN THE SPECIFICATION DIALOG

Road objects can be customized in their specification dialogs. See Road Specification Dialog on page 931, Terrain 
Feature Specification Dialogs on page 912, and Terrain Path Specification Dialog on page 919.

USING THE EDIT TOOLS

A selected road object can be edited in a variety of ways using the buttons on the Edit Toolbar. See The Edit Toolbar on 
page 92.

 

Road Specification Dialog
To open the Road Specification dialog, select a Straight Road or Spline Road and click the Open Object edit button.    

Many of the settings in this dialog are similar to those in the Terrain Path Specification dialog. See Terrain Path 
Specification Dialog on page 919.         
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GENERAL PANEL

  Size

 l Specify the road's Width.

 l Specify the Terrain to Top value, which is the distance from the top surface of the terrain to that of the road. If this 
value is a negative number, the road sinks into the terrain.      

 l Specify the road's Thickness.       

 
Flare

When one road intersects another, flares can be specified.                 

 l Check Start to create a flare at the starting end of the selected road, then specify the Radius of that flare.          

 l Check End to create a flare at the end of the selected road, then specify the Radius of that flare.          

 
Preview

A preview of the selected road displays on the right side of the panel. See Dialog Preview Panes on page 21. 

POLYLINE PANEL

The POLYLINE panel states the length of the road’s Perimeter, its Area and its Volume.              For more information, see Polyline 
Panel on page 219.          

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when a Straight Road is selected. For more information, see Line Panel on page 208.           
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The SELECTED ARC panel is available when the curved segment of a  Straight Road is selected. See Arc Panel on page 214.           

See, too, Selected Edge on page 143 and Change Line/Arc on page 176. 

SPLINE PANEL

The SPLINE panel is available when a Spline Road is selected. Specify the angle between the line segments used to draw the 
spline. For more information, see Spline Panel on page 219.           

LINE STYLE PANEL

This panel is the same as the LINE STYLE panel in many other specification dialogs. See Line Style Panel on page 209.          

FILL STYLE PANEL

The settings on the FILL STYLE panel affect the appearance of the selected object in plan view. For information about these 
settings, see Fill Style Panel and Dialogs on page 132.         

MATERIALS PANEL

The settings on the MATERIALS panel affect the appearance of the selected object in 3D views. For information about these 
settings, see Materials Panel on page 750.         

COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 967.  
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Chapter 37
 

Plants and Sprinklers

The Plant Tools and sprinklers from the Library Browser allow you to create planting designs and irrigation systems in your 
terrain. 

The Terrain Tools are discussed in their own chapter. See Terrain on page 890.

TOPICS

Plant Tools 935
Plant Chooser Dialog 936
Hardiness Zones 938
Plant Image Specification Dialog 938
Sprinkler Tools 942
Sprinkler Specification Dialog 943
Plant Schedules 943
Schedule Numbering and Columns 944
Plant Schedule Specification Dialog 945
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Plant Tools
Select Terrain> Plant to add plants to your landscaping plan. Plants can also be placed in a plan directly from the 
library. See Placing Library Objects on page 714.

Plant objects are actually images, which provide realism while avoiding high 3D surface count. Once created, plant images 
can be selected and edited much like other image objects. See Editing Images on page 848.         

Select Terrain> Plant> Plant Chooser to open the Plant Chooser dialog and find plants based on their 
characteristics and requirements. See Plant Chooser Dialog on page 936.

Select Terrain> Plant> Create Plant Image to create a plant image. See Plant Image Specification Dialog on page 
938. Once a plant image is created, it can be added to the library for future use. See Creating Images on page 846. 

Select Terrain> Plant> Grow All Plants to open the Grow Plants dialog. 

Click and drag the slider bar and select a growth period from zero to twenty years. This only works for plants that have a 
mature height and mature age specified in the Plant Image Specification dialog. See Plant Information Panel on page 940.         

Select Terrain> Plant> Show Hardiness Zones  to access regional climate zone maps. See Hardiness Zones on 
page 938.         

Select Terrain> Plant> Plant Schedule, then click to create a plant schedule. See Plant Schedules on page 943.         

Home Designer’s Library Browser features a Plants category with a selection of plant, shrub and tree images which you can 
place in your plan. See The Library on page 691.         

Once placed in your plan, these plant images can be selected, moved, copied and resized to produce a wide variety of 
unique landscaping designs. See Editing Images on page 848.         

GARDEN BEDS

Garden Beds are a special type of Terrain Feature with material and height attributes typical of planting beds.  In 
addition, you can choose to distribute copies of a plant image within a Garden Bed. See Terrain Feature Types on 

page 900.

PLANTS LIBRARY CATALOGS

In the Library Browser, browse to Home Designer Core Catalogs> Plants to access a selection of plant images. Select 
the library object you want, then click in any view to place it in the plan. See The Library on page 691.   

A selection of Bonus Catalogs of plants is also available for download. See Home Designer Bonus Catalogs on page 705.    

In addition, you can add single plants and blocked groups of plants to the library. See Adding Library Content on page 709 
and Architectural Blocks on page 732. 

935



Home Designer Pro 2025 Reference Manual - Plant Chooser Dialog

PLANT SCHEDULES

The Plant Schedule tool allows you to create customizable plant schedules and plant labels that display schedule 
numbers.  See Plant Schedules on page 943.         

 

Plant Chooser Dialog
Select Terrain> Plant> Plant Chooser or click the Plant Chooser button at the bottom of the Library Browser 
window to open the Plant Chooser.         

Use this dialog to search the library for plant images that match your search parameters. You can search using any or all of 
the options in the Plant Chooser.         

The search parameters in this dialog correspond to the settings on the PLANT INFORMATION panel of the Plant Image 
Specification dialog. See Plant Information Panel on page 940.          

 
Name

Type the Name of a plant that you would like to find.         
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 l Specify the plant’s Common Name, Scientific Name, or its Variety Name.          

 l A Pronunciation field is also provided. In the Plant Image Specification dialog, it is populated with a phonetic 
pronunciation guide for the plant’s scientific name.          

 
Type

Check one or more boxes to indicate selected plant Type to search for.         

 
Sub-Type

Check one or more boxes to specify the selected Sub-Type to search for.         

 
Needs

Specify the plant Needs to search for. These include the Sun, Water, Soil pH, and Hardiness Zone range. See Hardiness 
Zones on page 938.         

 
Flowers and Foliage

 -         

 l Specify the Flower Color to search for. Multiple colors can be selected.         

 l Specify the Leaf Color to search for. Multiple colors can be selected.         

 l Specify the Bloom Time to search for, which is the season when the plant produces flowers.          

 
Height

Specify the plant Height at maturity to search for.              This is used with the Grow Plants feature. See Plant Tools on page 935.

 l An average mature height range can be entered using the From and To drop-down lists.         

 l A specific Height at Maturity to search for can be entered in the text field.         

 l A specific Starting Age, in months, can be entered in the text field.         

 l A specific Age at Maturity, in months, can be entered in the text field.         

 
Special Characteristics

Check one or more boxes to search for plants with Special Characteristics.         

 
Object Type

Select which types of plant Object Type to search for. 3D Plants are symbol objects, while Plant Images are two 
dimensional images.         

 
Search

Click the Search button at the bottom of the dialog to search for plants that meet your search criteria. The search results 
display to the right.         

 
Search Results

Your search results display here.         
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 l Information about the search status as well as the Number of Items that match your search criteria are stated.         

 l Specify whether you want the search results to use the Common Name or Scientific Name.          

 l Click on the name of a plant in the list to see its location in the Library Browser.         

 
View Item

Click the View Item button to see more information about the selected plant in the Plant Information dialog. See Plant 
Image Specification Dialog on page 938.         

 

Hardiness Zones
Select Terrain> Plant> Show Hardiness Zones to view a selection of regional Hardiness Zone Maps. Click the 
drop-down list at the top left to select various regions.

 

Plant Image Specification Dialog
Select one or more plant images in a plan view or 3D view and click the Open Object edit button to open the Plant 
Image Specification dialog. 

This dialog can also be accessed by selecting Terrain> Plant> Create Plant Image  or by selecting New> Plant Image 

from the Library Browser contextual menu.         

The PLANT INFORMATION and PLANT DESCRIPTION panels are also found in the Plant Information dialog, which can be 
accessed from the Plant Chooser dialog. See Plant Chooser Dialog on page 936.         
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IMAGE PANEL

  General

 l The path and name of the selected plant’s Image File displays here.

 l Click Browse to specify the saved location on your computer of the image that represents the plant in 3D views.

 l A number of 2D Plant Symbols are available to represent the image in plan view. Choose one from the drop-down 
list.

 
Size/Elevation

Specify the Size/Elevation of the plant image, as seen in 3D views.    

 l Specify the Height and Width of the image.    

 l When Retain Aspect Ratio of is checked, if you change either the Height or Width, the other value changes to 
maintain this ratio. If this is unchecked and you resize the plant image, it may become distorted.    

 l Click Reset Original Aspect Ratio of to reset the image’s original aspect ratio and remove any distortion caused by 
resizing.    

 l Select the Elevation Reference from the drop-down list. This determines where the next two settings are measured 
from and also affects their setting labels. See Elevation References on page 20.    

 o Specify the to Top distance, measured from the Elevation Reference to the top edge of the image.    

 o Specify the to Bottom distance, measured from the Elevation Reference to the bottom edge of the image.

 
Center Point

Specify the location of the selected plant image’s Center Point.    
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 l Position the selected plant image in reference to the plan coordinates by specifying its X Coordinate and Y 
Coordinate.

  Options

 l Check Reverse Image to reflect the appearance of the image about an imaginary vertical line through its center.     

 l Check Image Always Faces Camera to prevent the plant image from rotating with the camera.     

 
Copyright

If the selected plant image has been copyrighted, its Copyright Information displays here.          

 
Preview

A preview of the selected plant image displays here. The Glass House Rendering Technique is not available for plant 
images. See Dialog Preview Panes on page 21.

TRANSPARENCY PANEL

The settings on the Transparency panel of this dialog are similar to those on the same panel of the Image Specification 
dialog. For more information, see Transparency Panel on page 850.         

PLANT INFORMATION PANEL

The settings on the Plant Information panel correspond to the search parameters in the Plant Chooser. See Plant Chooser 
Dialog on page 936.         

When multiple plants with differing attributes are selected, some 
button icons may be replaced by an X symbol signifying “No 

Change”.
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PLANT DESCRIPTION PANEL

 
Description

A detailed Description of the plant displays in this text field.         

 
Lighting Comments

Information in the Lighting Comments fields describes the plant’s light requirements.         

 
Hardiness Zone Comments

Hardiness Zone Comments are given here. See Hardiness Zones on page 938.         

FILL STYLE PANEL

The settings on the FILL STYLE panel control the appearance of the selected plant’s 2D Plant Symbol in plan view.  By 
default, plant images’ fill style is None (Transparent). For information about the settings on this panel, see Fill Style Panel 
and Dialogs on page 132.

If the plant’s 2D Plan Symbol does not form a closed shape, the settings on the Fill Style panel will have no effect on the 
appearance of the plant in plan view. 

LABEL PANEL

Plant labels display in plan view when the “Plants, Labels” layer is turned on and use the Text Style assigned to that layer. 
See Label Panel on page 376.         
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COMPONENTS PANEL

The information on the COMPONENTS panel can be used in the materials list. For more information, see Components Panel 
on page 967.          

OBJECT INFORMATION PANEL

The information entered on the OBJECT INFORMATION panel can be used in the materials list. For more information, see 
Object Information Panel on page 968.   

 

Sprinkler Tools
  Use the Sprinkler Tools to design a sprinkler system in your plan.          

  Select Terrain> Sprinkler> Sprinkler Head to open the Select Library Object dialog. Browse to a sprinkler 
type in the library, click OK, then click in the drawing area to place as many as you need. Once drawn, sprinkler 

heads can be selected and edited. See Sprinkler Specification Dialog on page 943.   
  Select Terrain> Sprinkler> Sprinkler Line to draw sprinkler lines in your plan. Sprinkler lines are 2D objects 
and are drawn and edited much like CAD Lines. See Line Tools on page 204.         

DISPLAYING SPRINKLERS

The display of Sprinkler Heads, Lines and Splines can be controlled in the Layer Display Options dialog. See Layer 
Attributes on page 125.

In plan view, Sprinkler Head symbols indicate the spray angle. You can specify a fill style for both Spray Area and 
Sprinkler Symbol in the Sprinkler Specification dialog. See Symbol Object Specification Dialogs on page 723.       

Sprinkler Heads display in 3D views; however, Sprinkler Lines and Splines do not.         

Sprinkler Heads are counted in the Materials List, as is the total length of Sprinkler Lines and Splines. See Materials Lists 
on page 950.         

EDITING SPRINKLERS

Sprinklers can be edited much the way other objects from the library can: using their edit handles, edit tools, and in their 
specification dialog. See Editing Library Objects on page 713. 

If you use the Fill Style Painter to modify a sprinkler's appearance in plan view, its Spray Area fill will be painted: not the 
Sprinkler Symbol fill. See Fill Style Eyedropper and Painter Tools on page 131.
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Sprinkler Specification Dialog
To open the Sprinkler Specification dialog, select a sprinkler or group of sprinklers and click the Open Object edit 
button. You can also double-click the sprinkler(s) using the Select Objects  tool.

The Sprinkler Specification dialog an example of a Symbol Object Specification dialog. See Symbol Object Specification 
Dialogs on page 723. 

Sprinkler Lines and Sprinkler Splines also have a specification dialog which is very similar to the Polyline Specification 
dialog. See Polyline Specification Dialog on page 219.

 

Plant Schedules
A Plant Schedule is a table that lists  all of the plants in your plan and can include a variety of information about 
them, including quantities, common and scientific names, and growing needs. Schedules are dynamically linked to 

the plants in your plan and update as they are created, deleted, moved, or modified.   

In plan view, select Terrain> Plant> Plant Schedule , then click anywhere in the view to place a schedule at that 

location. You can continue clicking to place additional copies of the schedule. See Click-to-Create on page 117.   

Schedules can be edited using the edit handles, the Edit Toolbar buttons, and the Plant Schedule Specification dialog. 

USING THE EDIT HANDLES

A selected schedule has edit handles similar to those of a CAD box. See Editing Box-Based Objects on page 160. 

In addition, schedules have edit handles that let you control column width: 

A. Move
 l The Move handle is located at the center of the schedule. Click and drag this handle to change the schedule's position. 

B. Resize
 l The small circular Resize handles are located on the schedule's two vertical edges. Click and drag one of these handle 

to make the schedule wider or more narrow. The right-most column's width is affected by this change. 

C. Rotate
 l The triangular Rotate handle is located below the schedule. Click and drag this handle to rotate the schedule around its 

center point. 
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D. Resize Column
 l The small circular Resize Column edit handles are located in the Title row, centered on the grid lines that divide the 

columns, and can be dragged left or right. If a column is resized sufficiently small, the text within will wrap to 
multiple rows. The Reset Column Widths edit tool lets you resize all columns so there is no wrapping or extra empty 
space. See Plant Schedules on page 943, below.

The behavior of edit handles may depend on the currently active 
Edit Behavior. See Defaults, Preferences, and Edit Behaviors on 

page 138.

By default, the objects listed in the selected schedule are arranged in rows and information about them is presented in 
columns. You can Swap Rows/Columns to instead list objects in columns and information about those objects, in rows. See 
Plant Schedule Specification Dialog on page 945.

IN THE SPECIFICATION DIALOG

The contents, Text Style, and other attributes of schedules can be modified in the Plant Schedule Specification dialog. 
See Plant Schedule Specification Dialog on page 945.

You can control how objects are listed in a  plant schedule by specifying which Columns to Include. For example, if you 
were to include "Flower Color" but exclude “Common Names” and “Scientific Names” in the Schedule Specification 
dialog, the resulting plant schedule would list all red flowers in one line item, regardless of their species.

You can also control the appearance of the callout labels associated with plants listed in a schedule. See Object Labels on 
page 375.

USING THE EDIT TOOLS

A schedule can be edited in a variety of ways using the buttons on the Edit Toolbar. See The Edit Toolbar on page 92.

  The Align Left, Align Right, Center, and Justify edit tools allow you to specify how the 
contents of schedule columns are aligned. See Aligning Text on page 359.

 

Schedule Numbering and Columns
How plants are listed in a schedule is influenced by the order in which they are placed into the plan, as well as by which 
columns are in use in the schedule.   

SCHEDULE NUMBERING

The numbering of plants in schedules is dependent on the order in which they are placed in the plan, as well as the floor 
they are on.   

 l Any plants present in your plan before a schedule is created will be listed first in ascending alphanumeric order, 
according to their Label information.    

 l A new, unique plant placed in the plan after the schedule is created will be added to the bottom of the schedule in the 
order that they are placed, regardless of its Label information.    

When an object is edited, its schedule number may or may not change:   
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 l If an object with a Quantity of 1 in the schedule is edited, its position in the schedule will not change.    
 l If a group of objects listed on the same row in a schedule are edited simultaneously, their position will not change.    
 l If an object listed on the same row in a schedule with other similar objects is edited so that it is no longer similar 

enough to share the same row, it will move to the bottom of the schedule.

COLUMNS TO INCLUDE

Every schedule has a selection of Columns to Include in its specification dialog. See Plant Schedule Specification Dialog 
on page 945.

Information in the Code, Comment, Description, Manufacturer, and Supplier columns is drawn from an object’s 
specification dialog. See Object Information Panel on page 968.

It is important to remember that the columns you choose to include in a schedule can influence the number of separate line 
items that will be listed in the schedule. 

For example, if you were to include "Flower Color" but exclude “Common Names” and “Scientific Names” in the Plant 
Schedule Specification dialog, the resulting schedule would list all red flowers in one line item, regardless of their species.

 

Plant Schedule Specification Dialog
Plant Schedules and the object labels associated with them can be edited in the Schedule Specification dialog. To 
open this dialog, either select a schedule and click the Open Object edit button or double-click the schedule using 

the Select Objects  tool.    

The Schedule Specification dialog has the following panels:          

 GENERAL PANEL
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Columns

Specify which columns are included in the selected schedule.  See Schedule Numbering and Columns on page 944.         

 l An alphabetical list of Available Columns displays on the left.    

 o Select one or more names in the list of Available Columns, then click the Add button to add them to the Columns 
to Include list on the right. See Shift and Ctrl/⌘  Select on page 146.    

 o You can also double-click on an item in the list to add it to the Columns to Include list on the right.

 l A list of the Columns to Include in the selected schedule displays on the right. The top-to bottom order in this list 
corresponds to the columns’ left-to-right order in the schedule. At least one column must be included to create a 
schedule.

 o Select or double-click on an item in the list and click the Rename button to specify a new name.    

 o Click the Reset button to restore the default names for all Columns to Include in the current schedule.

 o Select one or more items in the list, then click the Remove button to remove those items from the list.    

 o Select one item in the list and click the Move Up button to adjust its position upward in the list.    

 o Select one item in the list and click the Move Down button to adjust its position downward in the list.

 l Select a column that reports a quantity, component count, length, area, or volume to enable these check boxes:

 o Check Calculate Total to report a total for all objects in a row at the bottom of the column.

 o Check Sum Similar Rows to group similar objects in a single row and report the total for all objects associated with 
that row. When this is unchecked, the individual objects are reported in separate rows unless their values in the 
selected column are identical.

 
Object Preview Options

These options affect the appearance of previews in the 2D Symbol, 3D Elevation, and 3D Perspective Columns, when 
included in the schedule. Not available for layout tables. See Schedule Numbering and Columns on page 944.         

 l Check Show Color to draw Callout Symbol, 2D Symbol, 3D Elevation, and 3D Perspective object previews using 
colored lines. When this is unchecked, lines are black and 3D previews are shown in grayscale. 

 o Select From Plan to draw Callout Symbols and 2D Symbols using the color assigned to each object's layer, and 3D 
Elevations and 3D Perspectives using black.

 o Select From Schedule to draw Callout Symbol, 2D Symbol, 3D Elevation, and 3D Perspective object previews 
using the color assigned to the schedule's layer.    

 l Check Scale Images to display object previews at the same relative scale. When unchecked, each preview fills its 
cell to the extent possible.    

 l Check Use Plan View Scale to apply the same scale used in plan view to the 2D Symbol column.    
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ATTRIBUTES PANEL

 
Box/Grid

Specify the appearance of the selected schedule’s border and grid.          

 l Check Display Border to display lines around the outside of the schedule.

 l Check Display Grid Lines to display lines around the rows and columns of schedule, forming boxes around each 
item, or cell.

  Alignment

 l Specify the selected schedule’s Horizontal text alignment within the left and right edges of its columns by choosing 
an option from the drop-down list. 

 l Specify the selected schedule’s Vertical text alignment within the top and bottom edges of its rows by choosing an 
option from the drop-down list.          

 
Position

Define the position of the selected schedule. Not available in the Schedule Defaults dialogs.          

 l Specify the X and Y Positions of the schedule’s center point.

 l Specify the schedule’s Angle.

 
Margins

Specify the Left, Right, Top,  and Bottom Margins, which define the distance between the text and border of each schedule 
cell.          
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LINE STYLE PANEL

The LINE STYLE panel is found in the specification dialogs for many different objects. For information about the settings on 
this panel, see Line Style Panel on page 209.         

FILL STYLE PANEL

The FILL STYLE panel is found in the specification dialogs for many different objects. For information about the settings on 
this panel, see Fill Style Panel and Dialogs on page 132.          

TEXT STYLE PANEL

For information about the settings on this panel, see Text Style Panel on page 373.

LABELS PANEL

The LABELS panel of the Schedule Specification dialog controls the type, size and appearance of the labels that display in 
plan view.          

  Specify which type(s) of label plants in the selected schedule use.      

 l Select Use Both Callout and Label for plants listed in the schedule to display both regular labels and schedule 
callouts.      

 l Select Use Callout for plants to display schedule callouts but not their regular labels.      

 l Select Use Label for plants to display only their regular labels and no callouts. See Label Panel on page 376.
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  Label Text

 l Schedule Number Prefix - Specify the leading characters used in callout labels or when Include Schedule Number 
is checked in the object’s specification dialog. See Label Panel on page 376.    

 l When Include Leading Zeroes is checked, single-digit callout labels include a zero in front of the callout number. 
Uncheck this box to remove these leading zeroes from the labels.

 
Callout Shape

When either Use Both Callout and Label or Use Callout is selected above, the callout shape can be selected here. There 
are ten shapes to choose from.    

  Size/Orientation

 l Uncheck Automatic to enable the Size field and specify a new value. When checked, the callout is sized so that it 
encompasses the Label Text that displays inside its shape.

 l Specify the Shape Angle.

 l Specify the Text Angle relative to the orientation of the callout shape. Not available when Ellipse, Capsule, or 
Rectangle is selected as the Callout Shape.

 l When Automatic is checked, the Text Angle automatically matches the Shape Angle.
Like other object labels, callout labels use the Text Style assigned to the layer they are on. See Text Styles on page 373.
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Chapter 38
 

Materials Lists

Home Designer can calculate a Materials List in three ways: for All Floors, From Area, or for Room.

Materials Lists can be created, edited, and printed directly from the program. They can also be exported as text, .xml, or
 .html files for use in other programs.

The Materials List’s calculations are based on assumptions that 
may not match your building style. Chief Architect Software 

makes no representation as to the accuracy or reliability of the Materials 
List generated by Home Designer Pro. Always compare the Materials 
List with a manual take-off before providing a quote or ordering 
materials for a job. 

TOPICS

The Materials List Tools 951
Creating an Accurate Materials List 952
Organizing Materials Lists 953
Materials List Specification Dialog 954
Materials List Columns 959
Editing Materials Lists 961
Find Object in Plan 962
Saving and Managing Materials Lists 962
Printing and Exporting the Materials List 963
The Master List 964
Object Components 967
Object Information Panel 968
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The Materials List Tools
A Materials List is like a snapshot of the current plan at the time that the list is made. Any changes made to the 
model after a Materials List is generated are not included in that list. Create a new Materials List if you would like it 

to include these changes. Select Tools> Materials List to access the Materials List tools.         

It is not necessary to wait until the plan is complete to generate a Materials List. In fact, you can create a series of Materials 
Lists reflecting costs at various stages of a project.

When you close a Materials List window, the program will ask if you want to save the Materials List. Type a name and 
click Yes to save the list or click No to close the list without saving it. See Saving and Managing Materials Lists on page 
962.         

CALCULATE FROM ALL FLOORS

Select Tools> Materials List> Calculate Materials for All Floors to generate a Materials List for the entire model.

Materials lists calculated for all floors can be lengthy, and only a portion of the list may display on your screen at one time. 
Use the scrollbars to scroll through the complete list. Move the pointer to cells in the list and click to make changes. Once 
created, you can also specify which categories are included in the Materials List Specification dialog. See Categories Panel 
on page 955.

CALCULATE FROM AREA

In plan view only, select Tools> Materials List> Calculate From Area to produce a Materials List for the portion 
of a plan  on a single floor that is included within a temporary rectangular Materials List Polyline.          

To use Calculate from Area

 1.  In plan view, select Tools> Materials List> Calculate from Area.             

 2.  Click and drag to draw a rectangular marquee around the area of the current floor that you would like to produce a 
Materials List for.             

 3.  When the mouse button is released, a Materials List for the area within the rectangle will display.             

Calculate From Area rectangles are temporary and do not display in plan view after the list is created.         

CALCULATE MATERIALS FROM SELECTION

Select one or more objects and click the Calculate Materials From Selection edit button to create a Materials List that 
calculates only the selected object(s) and their components.           

When the selected object is a room, its moldings and wall, floor, and ceiling finish materials are counted, as is its 
subflooring; but doors, windows, and structural materials like framing and other structural materials are not.           

CALCULATE MATERIALS IN ROOM

To create the Materials List for a room, select the room and then select Tools> Materials List> Calculate Materials 
for Room. 

Calculate Materials in Room  is also available on a selected room’s edit toolbar. See Editing Rooms on page 293.          
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A Materials List calculated from a room is created for only the contents of that room: wall materials are not included. An 
object will be counted in the Materials List if its center point is located inside the room.         

CALCULATE STRUCTURAL MATERIALS FOR DECK

The structural materials for a selected deck can be calculated in a Materials List by clicking the Calculate Structural 
Materials for Deck edit button. Any accessories added on the COMPONENTS panel of a deck's Room Specification 

dialog will be included in a Materials List created using this tool. See Decks on page 299 and Components Panel on page 
967.

MASTER LIST

Select Tools> Materials List> Master List to open the Master List, a list of previously used materials and any added 
information such as price or manufacturer. See The Master List on page 964.         

MATERIALS LIST MANAGEMENT

Select Tools> Materials List> Materials List Management to open a list of saved Materials Lists associated with 
the current plan. See Saving and Managing Materials Lists on page 962.         

MATERIALS LIST PREFERENCES

The MASTER LIST panel of the Preferences dialog lets you specify the current Master List file and the columns used 
in it. See Master List Panel on page 85.         

 

Creating an Accurate Materials List
In order to take full advantage of Home Designer’s Materials List capabilities, there are several things to keep in mind. 

 l The accuracy of your Materials List is directly related to the accuracy of your model. Floor and ceiling heights, wall 
lengths, and structural settings all directly affect Materials List calculations.         

 l It takes more than just making your drawing look right to generate an accurate Materials List. If, for example, you use 
CAD lines to draw an item on a floor plan, that item will not be included in the Materials List. A better way would be 
to use a symbol or structural element. See Architectural vs CAD Objects on page 112.         

 l If you use custom materials, make sure their material definitions are set up correctly. See Creating Materials on page 
755 and Materials and the Materials List on page 757.         

 l Bear in mind that using generic objects like Geometric Shapes from the library can result in items being calculated in 
the Materials List in a manner that you might not expect. See Other Objects on page 738.

OBJECT INFORMATION AND COMPONENTS

Code, Comment, Manufacturer, and Supplier information can be specified for many objects. See Object Information Panel 
on page 968.   

Price, Extra, Markup, Labor, and Equipment information can also be specified in an object’s specification dialog. See 
Components Panel on page 967.          

You can add this information to some objects before they are created in their defaults dialogs. See Default Settings on page 
57.          

You can also add this information to objects placed from the library. See Editing Library Objects on page 713.           
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MATERIAL DEFINITIONS

The material assigned to structural components like walls, floors and ceilings, roofs, and slabs determines how each 
component is calculated in the Materials List. See Calculation Methods on page 758.          

FRAMING IN THE MATERIALS LIST

You can specify whether framing materials are calculated by linear foot, as a cut list, or as a buy list.

For more information about how framing appears in the Materials List, see Framing and the Materials List on page 659.          

 

Organizing Materials Lists
You can control which items are calculated in the Materials List by specifying which categories are used.

In addition, you can control how much information about each item is included by specifying which columns to display.           

You can also use the Structural Member Reporting Control drop-down list in the toolbars to choose which method the 
Materials List uses for calculating framing members. See Framing and the Materials List on page 659.

There are some parts of a model that cannot be excluded from the Materials List. Floor and ceiling platforms are prime 
examples. If you need to generate a Materials List for only part of a plan, such as an addition, consider making a copy of the 
plan file. In the copy, delete the as-built portion of the plan and then generate a Materials List.

CATEGORIES

The line items in the Materials List and Master List are organized into a set of predefined categories, such as Electrical and 
Framing, which display in the ID column. 

You can specify which category each item belongs to in the Materials List and Master List. In addition, many objects can be 
assigned to a category prior to generating a Materials List in their specification dialog. See Components Panel on page 967. 
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To specify a line item’s category

 1.  Create a Materials List, open the Master List, or open an object’s specification dialog and go to the COMPONENTS 
panel.

 2.  Click in the cell in the ID column for a line item.

 3.  Select the desired category from the drop-down list that becomes available.

The categories that are available cannot be altered; however, you can specify which categories are included in the Materials 
List in either of two ways:

 l In the Materials List Defaults dialog.
 l For individual lists in the Materials List Specification dialog. See Materials List Specification Dialog on page 954.

SUBCATEGORIES

By default, the Subcategory column of the Materials List is empty for all line items. You can add text to any Subcategory 
cell by clicking in the cell and typing.          

Items can be assigned to a subcategory in the Materials List and, for many items, in their object’s specification dialog in the 
same manner that they can be assigned to a category. See Components Panel on page 967.           

MATERIALS LIST COLUMNS

Each column in the Materials List reports a different category of information about objects in the list. You can specify most 
of this information for a variety of objects prior to generating a Materials List. See Object Components on page 967.          

You can also specify which columns are included in the Materials List as well as their order in the Materials List 
Specification dialog. See Materials List Specification Dialog on page 954.          

DETAILS DIALOG

For information about one or more selected line items in a Materials List, click the Details edit button. The Details 
dialog displays all Materials List columns for reference, which can be helpful when not all columns are in use in the 

Materials List. It also lists the Source Object of the selected line item or items.

This dialog will also open when multiple objects located on more than one floor are selected in a Materials List and you 
click the Find Object in Plan  edit button. See Find Object in Plan on page 962.           

When one or more line items located on the same floor are selected, click the Find button at the bottom of the dialog to 
view their location in a plan view window. 

CHANGING THE APPEARANCE

The grid lines, colors, and font used for Materials Lists and the Master List can be specified in Materials List and Master 
List Specification dialogs. See Appearance Panel on page 957.   

 

Materials List Specification Dialog
             When a Materials List or the Master List is open, select Tools>  Materials List> Materials List Specification to 
open the Materials List Specification dialog for the current list.
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The Master List Specification dialog is similar to this dialog, but only the COLUMNS panel is available. See The Master List 
on page 964.          

CATEGORIES PANEL

The Categories  listed here appear in the ID column of the Materials List in the order they are presented here. 

 l Check the box beside the name of each category that you want to display in the currently active Materials List. 
 l Click the Select All button to display all categories in the active Materials List.          
 l Click the Clear All button to suppress the display of all categories in the active Materials List.          
 l Multiple rows can also be selected together using Shift and Ctrl/⌘  keys. See Shift and Ctrl/⌘  Select on page 146. 

Note: The information in a suppressed category is still part of the 
Materials List. If the Materials List is exported, suppressed categories are 
exported, as well.
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COLUMNS PANEL

 l Check the box beside each column you want to include in the Materials List. To suppress a column’s display, remove 
the check mark next to its name. Columns appear in the Materials List in the order that they display in this list.           

 l Move Up - Click on a column name, then click this button to move that item up one place in the list.           
 l Move Down - Click this button to move the selected column down in the list.          

OPTIONS PANEL

 l Select a Structural Member Reporting method from the drop-down list to specify how framing members are counted 
and reported. There are four methods to choose from:
 o Buy List calculates the framing materials of the different structural components of the plan by counting 

individual pieces and matching them to common board lengths.    
 o Cut List calculates the framing materials of the different structural components of the plan by counting the 

individual pieces present in the model.          
 o Linear Length calculates the framing materials of the different structural components of the plan in linear 

lengths.     
 o Mixed Reporting calculates framing materials using a combination of linear lengths and piece counts and is 

recommended for saved Materials Lists in legacy plans.    
 l Select the Length Units you want to use to report framing lengths. Only available when Buy List or Cut List is 

selected, above.
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 l Select a floor level from the Restrict to Floor drop-down list to limit the current Materials List to objects on that 
floor. When "All Floors" is selected, the Materials List includes objects from all floors.

 l If you plan to buy materials from multiple suppliers, you can create a Materials List for each. Select an option from 
the Restrict to Supplier drop-down list to only list items associated with the selected supplier; select "Show All 
Suppliers" to list all items, including those with no supplier; or select "Show Only No Supplier" to only list items that 
do not have a supplier. Suppliers can be added to this list in the specification dialog for various objects.  See Object 
Information Panel on page 968. 

When a Materials List is active, you can use the Structural Member Reporting Control drop-down list in the toolbar to 
choose which method the Materials List uses. This control is not available in the Master List.         

APPEARANCE PANEL

  Grid

 l Specify whether you want the cells of the Materials List to be separated by Horizontal Lines and/or Vertical Lines.

 l When Solid Lines is unchecked, the Materials List grid uses a dashed line style. Uncheck this to instead have 
unbroken lines.

  Custom Colors

 l When Custom Colors is checked, the Materials List uses the colors defined below. When this is unchecked, either 
the colors associated with the active Color Theme or your operating system's default colors are used.
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 l Each Color box displays the color assigned for various uses in the Materials List. Click a Color box to choose a 
different color. See Select Color Dialog on page 135.

  Font

 l Select a Font from the drop-down list.

 l Select a Font Size from the drop-down list.

 l Select one or more font styles: Bold, Italic, Underline, and/or Strikeout.

 
Reset to Defaults

Click this button to reset all settings on this panel to the installed system defaults.     

 
Preview

A sample of the selected font and style displays here.                 

958



Home Designer Pro 2025 Reference Manual - Materials List Columns

 

Materials List Columns
The columns in the Materials List and the Master List are very similar, but not all columns appear in all places. 

The following table lists the capabilities of each column:          

Column Available In Editable In Description

ID Materials List, 
Master List,
Components 
Panel

Materials List, 
Components 
Panel 

Displays an automatically generated 
identifier for each line item. Select the 
cell in this column to change an item’s 
category.

Use Master List Master List A check box beside for line item 
indicates if it is included in the Materials 
List. 

Sub 
Category

Materials List, 
Components 
Panel

Materials List, 
Components 
Panel

Select a cell in this column to change a 
line item’s subcategory. 

Floor Materials List N/A States the floor that the line item is 
located on. See Multiple Floors on page 
517. 

Label Materials List, 
Master List,
Components 
Panel

Materials List  Lists the label that displays in plan view 
for most items that have labels associated 
with them. See Label Panel on page 376. 

Supplier Materials List, 
Master List,
Components 
Panel

Materials List, 
Master List,
Components 
Panel

Specify a supplier for the item. A 
Supplier in the Master List is not used if 
one has been entered in the object’s 
specification dialog.

Manufacturer Materials List, 
Master List,
Components 
Panel

Materials List, 
Master List,
Components 
Panel

Specify a manufacturer for the item. A 
Manufacturer in the Master List is not 
used if one has been entered in the 
object’s specification dialog.

Code Materials List, 
Master List,
Components 
Panel

Materials List, 
Master List,
Components 
Panel

Specify a Code, such as an SKU, for the 
item. A Code in the Master List is not 
used if one has been entered in the 
object’s specification dialog.  

Size Materials List, 
Master List,
Components 
Panel

Materials List, 
Components 
Panel

Click in a cell to edit the size description 
of the line item. To restore the original 
size, delete the text you typed in. For a 
blank cell, type a single blank space.

Description Materials List, 
Master List,
Components 
Panel

Materials List, 
Components 
Panel

Click in a cell to edit the description of 
the line item in the same way that the 
Size can be edited. 
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Column Available In Editable In Description

Quantity Master List Master List Specify how many of an item must be 
found before information from the 
Master List is applied to it in a Materials 
List. If at least this many items are 
found, price, supplier, and other 
information is used. 

Count Materials List, 
Components 
Panel

Components 
Panel

This is the actual number of an item, 
either associated with the selected object 
or in the Materials List. Count can be 
increased for accessories added to a 
selected object.

Extra Materials List, 
Components 
Panel

Materials List, 
Components 
Panel

Specify an additional amount of the line 
item. Changes made in the object’s 
specification are reflected in the Count 
column in the Materials List.

Price Materials List, 
Master List,
Components 
Panel

Materials List, 
Master List,
Components 
Panel

This is the per-unit price of an item. A 
Price in the Master List is not used if one 
has been entered in the object’s 
specification dialog.

% Markup Materials List, 
Master List,
Components 
Panel

Materials List, 
Master List,
Components 
Panel

Specify a markup percentage for the 
item. A markup in the Master List is not 
used if one has been entered in the 
object’s specification dialog.

Labor Materials List, 
Master List,
Components 
Panel

Materials List, 
Master List,
Components 
Panel

Specify a labor cost for the item. A 
Labor value in the Master List is not 
used if one has been entered in the 
object’s specification dialog.

Equipment Materials List, 
Master List,
Components 
Panel

Materials List, 
Master List,
Components 
Panel

Specify an equipment cost related to the 
item. An Equipment value in the Master 
List is not used if one has been entered in 
the object’s specification dialog.

Total Cost Materials List, 
Components 
Panel

Materials List, 
Components 
Panel

This is the total cost based on Count, 
Price, % Markup, Labor and Equip 
values.

Default Master List Master List Click in this column to specify the line 
item as the default when more than one 
item is available.

Comment Materials List, 
Master List,
Components 
Panel

Materials List, 
Master List,
Components 
Panel

Additional information related to the 
item can be entered here. A Comment in 
the Master List is not used if one has 
been entered in the object’s specification 
dialog.
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Column Available In Editable In Description

Accounting 
Code

Materials List, 
Master List,
Components 
Panel

Materials List, 
Master List,
Components 
Panel

The Accounting Code information is 
used if a plan file is opened in Chief 
Architect X16 and a materials list is 
exported for use in BuilderTREND 
software. 

 

Editing Materials Lists
Materials Lists can be edited in a variety of ways. You can adjust the width of a column by clicking and dragging the bar on 
the right side of the column name. 

EXPAND AND COLLAPSE ROWS

If a line item has an arrow to the left of its name in the ID column, it represents multiple individual objects. 
Click the Expand edit button to display these individual objects as separate line items; click the Collapse edit 

button to hide them. You can also click the arrow to the left of the name to expand or collapse the line items. This option is 
not available in Materials List Reports.

ADDING INFORMATION

You can enter information in the Price, Supplier, Code, Comment and Manufacturer columns for each line item. 

Adding price or other information for any item is straightforward. Simply click in the cell and type the desired information. 
When the information is correct, you can add it to the Master List. See Adding to the Master List on page 965. 

When a Materials List is calculated, you can have the program search the Master List for Price, Supplier, and Code 
information for each item by selecting Tools> Update From Master List . The information used is marked as “Default” 

in the Master List.               See Materials List Columns on page 959.

CHANGING INFORMATION

Although the information in some columns cannot be saved to the Master List, you can change the information in any 
column in an individual Materials List. As with added information, click in a cell to select the existing text, then type in the 
desired text. 

To move a line item to a new category, select the cell in the ID column and choose a new category from the drop-down list 
that becomes available. You can also select a subcategory by clicking in the cell in the Sub Category column. See 
Categories on page 953.

CHANGING COUNT UNITS

The material for a given object component will be counted either by piece; linear feet or meters; square feet or meters; or 
cubic yards or meters. The same method and unit used in the Count column will be used in the Extra column. 

When the Count is linear, area, or volume, you can choose a different unit of measurement: 

 l Double-click in a cell in the Count column to select and edit it, then choose a unit of measurement from the drop-down 
list to the right of the selected cell.
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 l You can also click the Number Formatting  button when a Count cell is selected to specify the units and accuracy 

of the value in the selected field. The specified unit is also used in the Extra field for that row. See Number Formatting 
Dialog.

The currency used in the Cost and Total Cost columns is determined by your operating system's Region settings. See Region 
and Language Settings on page 58. 

TOOL TIPS

Whenever you mouse over a cell in the Count column, a Tool Tip will display, providing information about the cell’s 
contents. When the Count is a total length, area, or volume, it may be rounded. The Tool Tip will show the value with 
greater accuracy.

TOTAL COST

Total Cost for a line item is calculated using the Count, Price, % Markup, Labor and Equipment columns to calculate the 
cost. The formula used is: 

(Count + Extra) * Price * (1 + (%    Markup/100)) + ((Count + Extra) * Labor) + ((Count + Extra) * Equipment)

If a column does not appear, 0 is used for the value of that column with the exception of Count and Price, which are always 
used in the calculation even if they are not shown.

COPYING INFORMATION

Portions of a Materials List can be copied and then pasted into a Text  object or into a word processing program or 

spreadsheet program using the standard Windows Copy (Ctrl/⌘  + C), Cut (Ctrl/⌘  + X), and Paste (Ctrl/⌘  + V) commands. 
See Copying and Pasting Text on page 360.

 

Find Object in Plan
To find out where a line item in the Materials List is located in the model, select its row or any cell in its row and 
click the Find Object in Plan edit button. This tool selects the object or objects associated with that line item and 

will open a new view window to do so if necessary. 

If a plan view showing the floor that the object is on is open, that view will become active and the object will be selected. If 
no such view is open, a new view showing the object’s floor will be created. See View Windows on page 103. 

If the selected item is a component of a complex object like an Auto Dormer, Mulled Unit, Bay Window, or Architectural 
Block, the parent object will be selected in the plan instead of the individual component. 

If the selected row or rows in a Materials List refer to objects on different floors, the Details dialog will open when you 
click the Find Object in Plan  edit button. See Details Dialog on page 954.

 

Saving and Managing Materials Lists
To save an open Materials List, click the Save Active Materials List button in the top toolbars. If the Materials List 
has not been previously saved, the Save Materials List dialog will open, allowing you to type a short, descriptive 

name for the list. You will also be prompted to save a Materials List when you close its window.          

Once a Materials List has been saved, it is  listed in the Materials List Management dialog.
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MATERIALS LIST MANAGEMENT DIALOG

Select Tools> Materials List>  Materials List Management to open the Materials List Management dialog.         

All saved Materials Lists are listed here. Click on an item in the list on the left to select it.          

 l Edit - Open the selected Materials List. You can also double-click an item in the list.          
 l Rename - Open the Rename Materials List dialog and type a new name for the list.         
 l Delete - Remove the selected Materials List from the current plan.         

 

Printing and Exporting the Materials List
There are several options for printing and exporting the information in a Materials List.

To print a Materials List, select File> Print while the Materials List window is active. See Print View Dialog on 
page 1001.

A Materials List can also be exported into a one of several different file formats that can be opened by various 
programs. In a Materials List window, or in the Master List, select File> Export Materials List to open the Export 

Materials List dialog.

EXPORT MATERIALS LIST DIALOG

 
File Type

Specify the File Type that you would like to export to.         
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 l Select Tab Delimited (TXT) to create a text file with a tab between each field entry in the Materials List, and a 
carriage return between each row.         

 l Select Comma Delimited (CSV) to create a text file with a comma between each field entry in the Materials List 
and a carriage return between each row.         

 l Select Spreadsheet (XML) to create a file that can be opened by Microsoft Excel.         

 l Select Web Page (HTML) to create an html file that you can view with a web browser.         

 
Options

Additional export options are available here.         

 l Uncheck Include Column Headers to prevent column headings from appearing in the first row of the exported file. 
Column headers are always included in HTML files.         

 l Uncheck Include Hidden Columns to only export columns currently displayed in the active Materials List. When 
this is checked, all columns are exported, regardless of whether they are currently displayed.         

 l Check Open in Default Spreadsheet Editor to open the exported file with the program specified on your computer 
when you finish exporting.   

 l When XML or HTML is selected above and Export with Colors is checked, the Color Theme or Custom Colors 
used in the Materials List are exported. When unchecked, the white and pale gray fill and black text are used.    

 
Units

Specify how Units of measurement are exported. Currency information is always exported, regardless of the option chosen 
here.         

 l Select Include Units with Amounts to include units in the same column as the associated value.         

 l Select Include Units in a New Column to report units as text in a new column.         

 l Select Do Not Include Units to not export units at all.         

When you click OK, the Write Materials Export File dialog will open. This is a typical File Save dialog. See Exporting 
Files on page 39. 

ESTIMATING SOFTWARE

You can export a Materials List to a word processor or spreadsheet program to arrange it in your estimating format. You can 
also export the Materials List to a number of commercial estimating programs in whose databases you can keep your current 
pricing, labor costs, and  markups and generate reports based on this data. 

Before purchasing an estimating software program, be sure that the program supports the direct import of Chief Architect 
Materials Lists. 

Any questions regarding estimating software packages and how they interact with Home Designer should be directed toward 
the company providing the estimating software. Chief Architect Software is unable to provide any technical support for third 
party programs.

 

The Master List
The Master List saves price, supplier, manufacturer, and other information about items in your Materials Lists and 
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allows you to apply that information to items in future Materials Lists. Select Tools> Materials List> Master List to open 
the Master List.         

Home Designer Pro allows you to have more than one Master List. Only one can be active, however, and only the active list 
is updated with new information. You can specify which Master List is active in the Preferences dialog. See Preferences 
Dialog on page 62.           

 
Category

The Category drop-down list at the top left corner of the window lets you select one particular category of items to display, 
or all categories. See Categories on page 953.

 
Columns

As with individual Materials Lists, you can specify which columns display in the list. See Materials List Specification 
Dialog on page 954.         

 
Find

Use the Find field near the bottom of the window to search for text in the Master List.         

The search starts from the currently selected cell and moves to the right, then moves down to the next row starting at the left 
column, and so on, until it finds an instance of the text you entered.           

ADDING TO THE MASTER LIST

You can edit line items in a Materials List and then add them to the Master List for future use.          

To use Update to Master List

 1.  Create a Materials List and change or add information in any editable column of a line item.          

 2.  Select the line item by clicking on its line number on the left side of the list. When selected, then entire line becomes 
highlighted.           
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 3.  Select multiple adjacent rows by holding down the Shift key while clicking. See Shift and Ctrl/⌘  Select on page 
146.         

 4.  Select Tools> Update to Master List . The information in the selected line is saved in the Master List.

 l If an item in the Master List is listed in the same Category and has the same Size, Description, and Label 
information as the selected line item, it will be updated.

 l If no item in the Master List matches the selection, a new line item in the Master List will be created.

Once Master List information exists for a particular item, you do not need to enter it again until you want to update it.           

UPDATE FROM MASTER LIST

Similarly, items in a Materials List can be updated to include information in the Master List.          

To use Update from Master List

 1.  When a Materials List is active, click on a row number to select the row.           

 2.  Select Tools> Update from Master List  to have the program search the Master List for a record for the selected 

line item. If an identical record is available, its information is included in the Materials List.           

 l Multiple rows can be selected by clicking on one row number, then holding down the Shift key and clicking on 
additional row numbers.          

 l Select all rows by clicking the cell at the top left corner of the Materials List, above the row numbers.          

If the Master List contains more than one record for an item, the program references the last one entered. You can override 
this by defining one specific entry as the default. This is achieved by clicking on the check box in the Def column.           

The Master List is almost identical to a Materials List, but has a few additional controls to help with viewing.           

EDITING THE MASTER LIST

In the Master List, existing line items can be modified or deleted.               

Often, the Master List will include items that you may not want to include in all Materials Lists.          

 l Check boxes in the Use column indicate whether each item is included in the Materials List. If Use is unchecked, the 
item is not included. This is useful in cases where several line items will be purchased as a single unit.          

 l This Quantity column is used to specify how many of an item must be found before information from the Master List 
is applied to it in a Materials List. If at least this many of the item are found, price, supplier, and other information is 
used. Quantity is useful for applying a quantity discount.          

 l When more than one line item is available for a specific component or accessory, the Default column indicates which 
item is to be used. Click this column to specify this item as the default. This is useful when a line item has been 
updated to the Master List more than once with different price, supplier or other information.          

To delete a row from the Master List, click on the row number at the far left. The entire row highlights. Select Edit> 
Delete, click the Delete  button, or press the Delete key.          

You should regularly back up your Master List (mmaster.mat) or 
lists. See Backing Up Your Files on page 40. 
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Object Components
Many architectural objects in the program, from walls to cabinets to images, have components associated with them that are 
calculated in the Materials List. For example, base cabinets have cabinet box and countertop components.

In addition to their components, some objects also have subcomponents. Cabinet boxes, for example, have doors, drawers 
and hardware.           

 Component information for Plant images can be listed in Plant 
Schedules. See Plant Schedules on page 943.

Components and subcomponents are specified on the COMPONENTS panel of many object specification dialogs.          

You can also add and edit information for objects and their accessories in the Materials and Master Lists. See Editing 
Materials Lists on page 961.          

COMPONENTS PANEL

Select one or more objects of the same type and click the Open Object edit button to open their specification dialog. 
The information on the COMPONENTS panel is the same as the Materials List line item(s) for the selected object.

The information on the COMPONENTS panel can also be edited for objects in the User Catalog of the Library Browser. See 
Editing Library Objects on page 713. 

The selected object’s components and their attributes are listed in two tables.           

 
Components

The selected object’s components and subcomponents are listed here.         

 l Subcomponent names are indented to help distinguish them from main components.           

 l Click on a line item to select it and display its Materials List information to the right.          

The buttons above the table allow you to manage this list.           

 l When a component is selected, click the Add Line Item  button to add a new component to the list. When a 

subcomponent is selected, a new subcomponent is created instead.           
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 l Click the Remove Line Item  button to remove the selected line item from the list.          

 l Click the Restore  button to return to the list any previously removed components or subcomponents. Only 

available when line items have been removed. User-created line items that have been removed are not affected by 
this option.

 l Click the Revert  button to reset any Values customized below. In the Cabinet Specification dialogs, they are 

reset to the values set in the corresponding Cabinet Defaults dialog; in the Cabinet Defaults dialogs, they are reset to 
the system defaults.     

   Materials List Data

 l The left column is a list of column headings found in the Materials List. See Materials List Columns on page 954.         

 l The Value for each Materials List column can be specified              in the right column.         

Additional information about how values are calculated may display below the table for some objects: notably, rooms and 
terrain features.

Note: The Label can be edited on the Label panel of the object’s 
specification dialog. See Label Panel on page 376.

 

Object Information Panel
The OBJECT INFORMATION panel is found in the specification and defaults dialogs for a variety of different objects. 
The settings on this panel let you specify information that can then be included in the Materials List and in Plant 

Schedules. See Materials List Columns on page 959 and Schedule Numbering and Columns on page 944.    
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Code

Specify a Code, such as an SKU, for the selected object. 

 
Comment

Specify a Comment for the selected object.

 
Description

Specify a Description for the selected object.

 
Manufacturer

Specify the selected object’s Manufacturer. 

 
Supplier

Specify the selected object’s Supplier.
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Chapter 39
 

Layout

The Home Designer Pro layout facility provides a set of easy to use tools for creating printed construction documents. You 
can create your own title block and border, then arrange multiple views of a plan, notes, and more on a page for printing.

Each layout file has up to five pages, each of which can contain multiple views, details, images, CAD objects, or text.

For detailed information about printing in Home Designer Pro, see Printing and Plotting on page 984. 
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Layout Preferences and Defaults
There are a number of defaults and preference settings that affect layout files.

You can specify the background color of the drawing area in layout files on the COLORS panel of the Preferences 
dialog. See Colors Panel on page 65. 

To access the layout defaults for the current layout file, select Edit> Default Settings. The options in the Default 
Settings dialog are similar to those found in this same dialog in a plan file, although there are fewer choices in the list 

because only CAD objects, dimensions, and text can be drawn on layout pages. See Default Settings on page 57. 

GENERAL LAYOUT DEFAULTS

The settings in the General Layout Defaults dialog control basic features of the Chief Architect environment in the current 
layout file. As with other default settings, they are file specific, which means that they can be set differently in individual 
layout files. To open this dialog, select Edit> Default Settings , select "Layout", and click the Edit button. The settings 

in this dialog are also found in the General Plan Defaults dialog. See General Plan Defaults Dialog on page 60.

DRAWING SHEET SETUP

The settings in the Drawing Sheet Setup dialog are file-specific and are particularly important considerations in layout files. 
See Drawing Sheet Setup Dialog on page 988.

LAYOUT PAGE DISPLAY OPTIONS

Select Tools> Layer Settings> Display Options to open the Layout Page Display Options dialog. 

This dialog is  similar to the Layers Display Options dialog, but controls only the display of objects drawn on the layout 
page, such as CAD objects, text, dimensions, and imported objects. The display of layout view boxes is also controlled by 
the Layout Page Display Options - but not the objects within those views. 

For information about how to use this dialog, see Layer Display Options Dialog on page 127.

For information about controlling the display of objects in views sent to layout, see Displaying Layout Views on page 977. 

LAYOUT BOX DEFAULTS

The default line style, fill style, and label format for layout boxes can be set in the Layout Box Defaults dialog. See Layout 
Box Specification Dialog on page 979.

 

   The Layout Tools
There are a variety of tools available to send views to layout and edit them, as well as manage links. 

Many of the tools available in layout are described in the Printing chapter. See The Printing Tools on page 987. 

Select File> Send to Layout to open the Send to Layout dialog and send the current view to layout. See Sending 
Views to Layout on page 973. 
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In plan view, select a saved cross section/elevation view symbol and click the Send Camera’s View to Layout edit 
button. See Saving and Printing 3D Views on page 800.

  Select a layout view and click the Open View edit button to open the view that was originally sent to layout. 
This tool is only available for dynamic views. See Editing Dynamic Views on page 979. 

Select Edit> Delete Objects to delete categories of objects from the current layout file. See Delete Objects Dialog on 
page 192.

Select Window> Swap Views to switch between the current view and the view that was current before it. See 
Working in Multiple Views on page 105.

 

Creating a Layout File
To open an existing layout file, select File> Open Layout. Browse to a directory and select the layout file to open. 
See Opening and Importing Files on page 42.    

As with plan view windows, when a layout file is open, it is listed at the bottom of the Window menu as an open view. See 
Working in Multiple Views on page 105. 

In order to create a layout file, you must open a new file and then save it.

Choose File> New Layout to create a blank layout file. A layout file is created with the name Untitled.layout. 

Select File> Save to save the layout file. It is important that you save the layout in the same directory as the plan file 
from which views will be or have been sent to the layout pages. See Organizing Your Files on page 34.

Although it is possible to use multiple plan files with a layout, it is generally best to associate only one plan file with a 
layout and to use the same file name for both. If more than one plan file is used, all should be saved in the same directory as 
the layout file. 

When you save your layout, take a moment to also save the plan file associated with it. 

When a view is sent to layout, the plan and layout files become 
linked. If you rename or move either file, this link will be 

broken and the view will not display. See Managing Layout Links on 
page 981.

 

CAD and Text in Layout
CAD objects, text objects, as well as dimensions can be incorporated into your layout by both including them in your 
views sent to layout and by drawing them on the layout page. 

ON THE LAYOUT PAGE

CAD and text can be drawn directly on the layout page, allowing you to create a title block, border, as well as notes and 
other annotations.

You can draw dimension lines on the layout page to help position CAD and text objects, as well. Dimensions that locate 
objects in a view sent to layout, however, should be drawn in the original view. See Dimensions on page 320.

CAD, text, and dimensions created in layout can be selected, edited, and deleted just as they can in other views. See Editing 
Text on page 357 and CAD Objects on page 197.
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Pictures and PDFs can also be imported into layout. See Pictures, Images, and Walkthroughs on page 845.

IN VIEWS SENT TO LAYOUT

CAD, text, and dimensions in views sent to layout are scaled just like other objects in scaled views. If you want text in a 
layout view to print at a particular size, specify its size based on the scaling you will use when you send the view to layout. 
See Character Size on page 349.

If you rotate a view on the layout page, any text in that view will rotate as well, provided that its Text Style is using the 
Rotate with Plan setting. See Text Styles on page 373. 

 

Pictures, Metafiles, and PDFs in Layout
Picture files, metafiles, and PDF files can be included in views sent to layout or imported directly onto a layout page. See 
Displaying Pictures, Metafiles, and PDF Boxes on page 861.

Views can also be sent to layout as pictures embedded in the layout file. See Static Views on page 976. 

A picture or metafile imported onto the layout page can be selected and edited using its edit handles, edit tools and 
specification dialog. See Editing Pictures, Metafiles, and PDF Boxes on page 862. 

Embedded pictures and pdf files increase layout file size. Limit 
the number of large and/or multiple pictures.

 

Sending Views to Layout
Layout files can contain  multiple views sent from one or more plan files. To send the active view from a plan file to 
layout, select File> Send to Layout.

You can also send one or more saved, closed cross section/elevation views to layout by selecting the camera symbol 
and clicking the Send Camera’s View to Layout edit button. This edit tool is only available when the selected view 

has been saved, has not previously been sent to layout, and is not open. See Saving and Printing 3D Views on page 800.

To send a view to layout

 1.  Prepare the view so that the desired layer, default, and other settings are in use. See Dynamic Views on page 975 for 
more details.

 2.  Select File> Send to Layout .

 3.  In the Send to Layout dialog, select the layout page and other options that you need for the selected view.

 4.  Click OK to send the view to the specified layout page. Depending on the type of view and size of the model, you 
may see a progress indicator in the Status Bar. See The Status Bar on page 24. 

SEND TO LAYOUT DIALOG

The options available in the Send to Layout dialog vary depending on the type of view being sent to layout.
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Send Position

These options are available for all types of views.      

 l Check Snap to Active CAD Point to snap the view you are sending to layout to the active CAD Point. See Point 
Tools on page 200.    

 l Check Show Layout Page to go to the layout page when you click OK. When this is unchecked, the current view 
remains active.

 
Send Options

The options available here depend on the type of view being sent to layout. The last settings used for cross section/elevation 
views are retained during the current program session, as are the last settings used for camera views and overviews, and 
those used for plan views.    

 l Select Entire Plan/View to send to layout the extent of the plan that is visible when you click Fill Window . 

This option is not available for Perspective 3D views. See Types of 3D Views on page 771.    

 l Select Current Screen to send only what is shown on screen to layout. This option is available for all view types.    

 l Select Current Screen As Image to send only what is shown on screen to layout as an embedded image. See 
Picture File Box Specification Dialog on page 854. This option is available for all views, and is the only option 
available for rendered views.    

 
Camera View Options

These options are available for cross section/elevation, camera views, and overviews sent to layout - provided that Current 
Screen as Image is not selected, above. The last settings used for cross section/elevation views are retained during the 
current program session, as are the last settings used for camera views and overviews.    
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 l Select Live View to make the view dynamically linked to the plan file.     

 o Select Update on Demand to update the view only when prompted. See Keeping Layout Views Current on page 
975.     

 o Select Always Update to update the view any time a change is made to the model. This option ensures that the view 
is always current but may cause program slowness.     

 l Select Plot Lines to send a Vector View to layout that uses automatically generated Plot Lines to represent surface 
edges and material pattern lines in the model. See Plot Line Views on page 977.     

 o Check Color Fill to include colors that correspond to the materials used in the model.     

 o Check Use Edge Line Defaults to use a line weight of 18 and black color for all object edge lines.
When unchecked, the view uses layer- and/or object-specific settings, per the Surface Edge Lines settings in the 3D 
View Defaults dialog. See 3D View Defaults Dialog on page 774.     

 o Check Use Pattern Line Defaults to use a line weight of 10 and black color for all material pattern lines.
When unchecked, the pattern line weight and color settings set in the Define Material dialog are used. See Pattern 
Panel on page 761.

 
Scaling

Select a radio button to specify how the view sent to layout is subjected to scaling.    

 l Select Fit to Sheet (No Scale) to send the view to layout at approximately half the size of the layout drawing sheet. 
Once on the layout page, the view can be resized. 

 l Specify the exact scale for the view in layout. Both U.S. and metric units of measurement are available and can be 
selected independently. 

 l When views are sent to layout at different scales, line weights and line styles are subject to the same scaling. In most 
cases this is not desirable. When Use Layout Line Scaling is checked, the lines in views sent to layout appear the 
same as lines drawn directly on layout. This option is not available for rendered views. See Line Weights and Scaling 
on page 996.

 

Keeping Layout Views Current
It is not uncommon for changes to be made to a plan after views have been sent to layout. In order to make sure that your 
layout file is up-to-date, it is important to recognize that there are four types of layout views: 

 l Dynamic Views on page 975, which update automatically every time changes are made to the original view in the plan.
 l Semi-Dynamic Views on page 976, which fully update when printed or prompted by you.
 l Static Views on page 976, which do not reference the plan and cannot be updated: only replaced.
 l Plot Line Views on page 977 have elements that are Dynamic or Semi-Dynamic and others that are Static. 

Semi-Dynamic and Plot Line Views can be updated using the Update Layout View tools. Select Tools> Update 
Layout Views. In addition, a selected view can be updated using the Update View  edit tool. 

DYNAMIC VIEWS

Dynamic views reference the original view in the plan and update automatically whenever changes are made to that view, 
including:
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 l Changes to the model.
 l Changes to annotations in the view.
 l Changes to the layer settings used by the layout view. See Layout View Layers on page 977.

In order for a view to be Dynamic, it must be sent to layout using either the Entire Plan/View or Current View Send 
Option. In addition, camera views must have Update Always specified. See Send To Layout Dialog on page 973.

While convenient, Dynamic views require use of your computer’s resources and may slow program performance. Consider 
sending cameras, overviews, and cross section/elevations to layout as Semi-Dynamic views.

For the most part, plan views sent to layout are Dynamic; however, a number of elements are Static

In order to modify these elements in a view, you need to delete the view and resend it.         

 l The default Display in Plan View setting for pony walls is a permanent part of the layout view. See Pony Wall 
Defaults on page 230.

 l The floor level shown in a view sent to layout does not change if you move to a different floor in the plan. See 
Multiple Floors on page 517.

 l The Reference Display  setting in a view sent to layout is unaffected if the Reference Display is turned on or off in 

the plan. See The Reference Display on page 525.
 l The Color  setting in a view sent to layout is unaffected if Color is toggled on or off in the original view. See 

Color On/Off on page 130. 
 l The Rotate Plan View  angle is a permanent part of the layout view. See Rotate Plan View on page 104.

For information about controlling the display of dynamic views in layout, see Displaying Layout Views on page 977.   

SEMI-DYNAMIC VIEWS

Camera views, overviews, and cross section/elevation views can all be sent to layout as Semi-Dynamic views. Semi-
Dynamic views reference the original view in the plan but no information about the model or the view’s layer settings 
update unless you prompt the layout view to update. 

When a cross section/elevation view has been sent to layout, CAD objects, text, and dimensions in that view are fully 
Dynamic - even if the view is set to Update on Demand. See Detailing Cross Section/Elevation Views on page 782.

In order for a view to be Semi-Dynamic, it must be sent using either the Entire Plan/View or Current View Send Option 
and have Update on Demand specified. See Send To Layout Dialog on page 973.

There are several ways to update a Semi-Dynamic view:

 l Select it and click the Update View  edit button;

 l Select Tools> Update Layout Views> Update All Views ; or

 l Select Tools> Update Layout Views> Update All Live Views .

 l Update on Demand views also update automatically when you print the layout page that they are on. 

Views set to Update on Demand may experience a loss in quality as you zoom and pan on the layout page. To restore a 
view’s resolution, simply update it. 

STATIC VIEWS

Static views are like a snapshot of the model taken at a specific time: they do not update when the plan changes. If changes 
to the plan need to be shown in a Static view, that view must be deleted and resent to layout. 

976



Home Designer Pro 2025 Reference Manual - Displaying Layout Views

All views sent to layout using the Current Screen as Image option are Static. They are treated as imported images 
embedded in the layout file. See Picture File Box Specification Dialog on page 854.

PLOT LINE VIEWS

Camera views, overviews, and cross section/elevation views using the Vector View Rendering Technique can be sent to 
layout as Plot Lines. See Rendered and Vector Views on page 771.

In Plot Line views, the lines in the layout view that represent the 3D model are automatically generated copies of those in 
the original view, allowing them to maintain the line weights that were specified in the plan. See Line Weights on page 995.

 l Plot Line views are Semi-Dynamic in that they are linked to the original view and can be updated.
 l Plot Line views are Static in that they will not update automatically when printed: they can only be updated manually 

by you.
 l Any CAD objects, text, or dimensions drawn in a cross section/elevation view sent to layout will not be copied and 

represented by Plot Lines. These objects are fully Dynamic and will update immediately in the layout view if changes 
are made to them. See Detailing Cross Section/Elevation Views on page 782.

 l The Color  setting in a Plot Line view is unaffected if Color is toggled on or off in the original view in the plan. 

See Color On/Off on page 130.
 l Image objects and effects created using the Cross Section Slider are not included in Plot Line views. See Images on 

page 846 and Cross Section Slider on page 793.

Plot Line views do not automatically update when printed, nor can they be set to update automatically. In order to update a 
Plot Line view, you must do one of the following:

 l If you close a saved view that was previously sent to layout as Plot Lines and the model has been modified since then, 
an Update View to Layout message box lets you choose whether you want to update the view on the layout page. 
Click Yes if you want to update it or No to leave it unchanged. This message can be suppressed if you wish.

 l Select the Plot Lines layout box and click the Update View  edit button;

 l Click the Update All Plot Line Views  button.

 l Click the Update All Views  button; or

 

Displaying Layout Views
Just as some elements in a view window do not print, they are not included when a view is sent to layout: for example, the 
Reference Grid and camera symbols in plan view. See Print Preview on page 991.         

LAYOUT VIEW LAYERS

When a view is sent to layout, the current layer display settings are used. See Layer Attributes on page 125.

The layer settings of a selected Dynamic or Semi-Dynamic layout view can be edited if you click the Open View  edit 

button to open the original view in the plan. Please be aware that if you open the original view in this manner and then Save 
the plan, the layout view and the original view will share the same layer settings going forward. You should only do this if 
you want a layout view with layer settings that update whenever changes are made in the plan.         

If you would like to change the layer settings of a layout view, consider deleting it and sending a new view to layout with 
the desired layer settings.         
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LAYOUT BOX BORDERS AND LABELS

A border will display around each layout box when the “Layout Box Borders” layer is set to display in the Layout Page 
Display Options dialog. See Layout Page Display Options on page 971. 

Layout boxes can also display labels when the “Layout Box Labels” layer is set to display. See Label Panel on page 376.   

Automatic layout box labels display basic information about the original view in the plan. For example, plan view sent to 
layout from Floor 1 will have an automatic label that says, “1st Floor”. A camera view sent to layout will have a label that 
states the camera’s name. Layout box labels can be customized in the Layout Box Specification dialog. See Label Panel on 
page 980.

MISSING LAYOUT VIEWS

If a view on the layout page can be selected but cannot be seen, its link to the plan from which it was sent may have been 
broken. See Managing Layout Links on page 981. 

 

Editing Layout Views
To edit a layout view, first select its layout box using the Select Objects  tool. Once selected, the view box can be edited 

using its edit handles, edit toolbar or specification dialog.

USING THE EDIT HANDLES

Layout view boxes can be edited using their edit handles like closed polyline-based objects. See Editing Closed Polyline-
Based Objects on page 157. 

Only layout boxes linked to plan views can be rotated, however: cross section/elevation and 3D views cannot. Both the 
layout box and the view inside it rotate.

IN THE SPECIFICATION DIALOG

Layout view boxes can be customized in their specification dialog. See Layout Box Specification Dialog on page 979.

USING THE EDIT TOOLS

A selected layout view or views can be edited in a variety of ways using the buttons on the Edit Toolbar. See The Edit 
Toolbar on page 92.

USING DIMENSIONS

Like other CAD based objects, layout views can be moved and resized using dimensions. See Moving Objects Using 
Dimensions on page 341.

COPYING VIEWS

Just like many objects, views sent to layout can be copied and pasted into different layout files. 

As a general rule, though, if multiple copies of a view are needed, it is best to send the view to layout as many times as 
necessary because each view can then be controlled independently.

978



Home Designer Pro 2025 Reference Manual - Layout Box Specification Dialog

Bear in mind, too, that if a layout has views copied from a different layout file and is later moved to a different location on 
your computer, the link to the original plan file may be broken. See Keeping Layout Views Current on page 975. 

EDITING DYNAMIC VIEWS

Select a Dynamic or Semi-Dynamic view and click the Open View  edit button to open the original view that was sent 

to layout. You can also double-click a view of either type in layout to open the original view. See Opening Layout Views on 
page 981.

RESIZING SCALED VIEW BOXES

Scaled views retain their scale regardless of how you resize the border. If the border is increased in size, blank spaces may 
be created; if the border is made smaller, the view may become cropped. 

RESIZING NON-SCALED VIEW BOXES

If the view was sent to layout using the Fit to Sheet setting, or if a view is set to No Scale in the Change Scale dialog, 
resizing may have one of two results:

 l Drag a corner edit handle using the Alternate  Edit Behavior to resize both the border and the image 

proportionally. See Alternate on page 139.
 l If you use any other Edit Behavior or if you drag a side edit handle, the perimeter of the layout box changes but the 

view inside it stays the same size. If you make the border smaller, the view may become cropped. 

 

Layout Box Specification Dialog
Select one or more layout view boxes and click the Open Object edit button to open the Layout Box Specification 
dialog. The settings that are available will depend on the types of views selected.

The settings on the LINE STYLE, FILL STYLE, and LABEL panels of this dialog are similar to those in the LAYOUT BOX 
DEFAULTS dialog. See Layout Preferences and Defaults on page 971.

PLAN VIEW PANEL

The PLAN VIEW panel is only available in legacy layout files when the selected view is using a non-default Number Height 
for Dimensions. This legacy setting affects the size of dimension numbers in the selected layout view but not in the original 
plan file. See Dimension Defaults Dialog on page 322.   

CAMERA VIEW PANEL

The CAMERA VIEW panel is only available when the selected view is a 3D or cross section/elevation view. See 3D Views on 
page 770.         
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 l Select Live View to make the view dynamically linked to the plan file.    
 o Select Update on Demand to update the view only when prompted. See Keeping Layout Views Current on page 

975.     
 o Select Always Update to update the view any time a change is made to the model. This option ensures that the 

view is always current but may cause program slowness.   
 l Select Plot Lines to make the view a semi-dynamic Vector View with automatically generated plot lines that represent 

surface edges and material pattern lines. See Plot Line Views on page 977.    
 o Check Color Fill to include colors that correspond to the materials used in the model.   

POLYLINE PANEL

The POLYLINE panel states the length of the layout box’s Perimeter, its Area, and its Volume. See Polyline Panel on page 
219. 

SELECTED LINE/ARC PANEL

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. For more information, see  Line 
Panel on page 208.

The SELECTED ARC panel is available when the selected edge has been converted to an arc. For more information, see Arc 
Panel on page 214.

See, too, Selected Edge on page 143 and Change Line/Arc on page 176. 

LINE STYLE PANEL

The settings on the LINE STYLE panel let you set the properties of the selected layout box’s border and to specify what 
layout page it is located on. 

For more information, see Line Style Panel on page 209. 

FILL STYLE PANEL

For information about the FILL STYLE panel, see Fill Style Panel and Dialogs on page 132.

LABEL PANEL

Layout box labels display in layout when the “Layout Box Labels” layer is turned on and use the Text Style assigned to that 
layer. See Layout Box Borders and Labels on page 978. 

For more information about the settings on this panel, see Label Panel on page 376.
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Opening Layout Views
Dynamic and Semi-Dynamic views sent to layout refer to an original view in a plan. From the layout page, you can 
access that original view by selecting a layout box, then clicking the Open View edit button. The original view can 

also be opened by double-clicking the layout view using the Select Objects  tool.

Changes made in this view update in the original layout view when the plan file is saved. Be aware that depending on the 
changes you make, other views may also be affected. 

LAYER SETS

Always remember that when you open a view to edit it, any changes that you make to your layer settings will be reflected 
on the layout page. When you are finished making changes to your layout view and wish to resume work on the plan, save 
your work, close the plan, and then open it again. This will help avoid unintended changes to your layout view.         

 

Managing Layout Links
Careful file management is needed to avoid missing files and disrupted layout links. See Organizing Your Files on page 34.

The following guidelines can help prevent layout links from being broken:

 l Save plan files in the same folder as the layout, or in a sub-folder in that folder.
 l Custom graphics included in a plan or layout should be embedded in the file or saved in the same folder as the layout.
 l Plan files should never be renamed. If a new name is desired, make a copy of the file and rename the copy. Changes 

made in the copy do not affect views sent to layout from the original plan.
 l Avoid sending cross section/elevations to layout more than once. Changes made to the view can affect layout views in 

unintended ways.
 l Layout files should never be moved. If a layout file must be moved, the entire folder it is saved in should be moved or 

copied and then moved.
 l Use File> Backup Entire Layout  to create an independent copy of the original layout. Avoid use of “Save As.”  

See Backup Entire Plan or Layout on page 46.

When a layout box is selected, the name of the plan file and 
basic information about view it is linked to are reported in the 

Status Bar. See The Status Bar on page 24.

FINDING MISSING FILES

When a layout file is opened, the program performs a breadth-first search for dynamically linked views. This means that it:

 l Looks first in the same folder as the layout. 
 l Looks next in the folders located closest to the layout’s folder. 
 l If a missing file is not found, it expands its search further from the location of the layout file until the files with the 

linked views are located.
 l If a missing file is not found, a second breadth-first search will be performed, searching all zipped files found in the 

first search. 

If a file remains missing after the program performs a search of your system, a Warning message will indicate that the 
program could not successfully open all of the layout’s associated plan files. When you click OK, the Referenced Plan Files 
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dialog will open, allowing you to relink the layout to its missing associated files. You can also open this dialog at any time 
by selecting Tools> Layout> Referenced Plan Files  while a layout file is open. See Referenced Plan Files Dialog on 

page 45.

 

Layout Page Management
Layout files are organized into separate pages numbered 0 through 5.

THE CURRENT PAGE

The current layout page is indicated at the center of the Layout Page Up/Down buttons.

To navigate between layout pages

 1.  Click the arrow buttons on either side of the Layout Page button.

 2.  Click the Current Page number between the arrows to open the Go To Layout Page dialog. Enter a page number 
and click OK.

 3.  Select Page Up or Page Down from the Tools> Layout> menu.

 4.  Press Shift + N (Page Up) or Shift + M (Page Down).

LAYOUT PAGE ZERO

Layout Page Zero serves as a template for the other pages, allowing you to create a single title block and border in one 
place. Add anything to a Page Template that you want on some or all of your printed layout pages, such as:     

 l Title Block. See Text, Callouts, and Markers on page 347.     
 l Borders. See CAD Objects on page 197.     
 l Imported images. See Images on page 846.      

Note: The printable area varies from printer to printer. For best results, 
inset layout borders 1/2" to 3/4" from the paper edge. 

Because of its special purpose, Layout Page Zero cannot be deleted.           

 

Printing Layout Files
Printing layout files is similar to printing a view in a plan file. Select File> Print> Print to open the Print dialog. See 
Print View Dialog on page 1001. 

As in plan views, printing options for layouts are set in the Drawing Sheet Setup dialog for that layout file. See Drawing 
Sheet Setup Dialog on page 988.
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PRINTING TO SCALE

A layout file’s drawing scale is specified in the Drawing Sheet Setup dialog. While you can specify any drawing scale that 
you wish, in nearly all circumstances, you will want the scale to be 1 in = 1 in or 1 mm = 1 mm for all layout files. 

The views sent to your layout pages have already been assigned a scale, and if you select a scale other than one-to-one for 
the layout, these views will be scaled a second time when printed. 

Layout views will print at their specified scales only when the 
drawing scale for the layout file is 1 in = 1 in or 1 mm = 1 mm.

When a view is sent to layout at a scale other than that used by the original view, line weights may be affected. See Line 
Weights and Scaling on page 996.

PRINTING SERVICES

If you plan to use a printing service, you may want to install a PDF writer. See Printing to a PDF File on page 995. 

You can also print to file using the driver for the printer that the service will use. See Printing to File on page 986.

Find out what paper size the print service uses and select it in the Drawing Sheet Setup dialog. See Drawing Sheet Setup 
Dialog on page 988.

CHECK PLOTS

When a large drawing sheet size has been specified, you can print a check plot at a reduced scale so that it can be printed on 
a smaller printer. This allows you to make final checks before printing to the larger size. See Check Plots on page 994.

 

Exporting Layout Files
A layout  can be exported to a .dxf file much like any other vector-based view. 

The main difference is in the scale of the output, which is in scaled paper units rather than model units. If a 50” line in a 
plan would be scaled to 1” inch when printed, it is exported as a 1” line instead of its length before prior to scaling. See 
Exporting 2D DXF/DWG Files on page 884.
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Chapter 40
 

Printing and Plotting

Home Designer provides a variety of options for printing scaled plan views, cross section/elevation views, and 3D 
perspectives.

To create working drawings, you can use the program’s Layout facility. Multiple views of the model can be arranged on 
pages along with a border and title block. For more information, see Layout on page 970.          

Home Designer also allows you to save your drawings in .pdf file format that can then be sent to a printing service.

Note: Screen captures are provided for illustrative purposes only and are 
not an endorsement of any products.

TOPICS

Introduction to Printing 985
Printers and Plotters 985
Printing Defaults 986
The Printing Tools 987
Drawing Sheet Setup Dialog 988
Print Preview 991
Printing to Scale 993
Printing Across Multiple Pages 995
Printing to a PDF File 995
Line Weights 995
Watermarks 998
Print View Dialog 1001
Print Image Dialog 1004
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Introduction to Printing
Home Designer Pro offers printing options to suit a variety of needs. It is helpful to be familiar with these options and 
choose the one that makes the most sense for the project at hand.         

OUTPUT OPTIONS

Printing From Layout - For professional quality documents with a title block, border, and multiple views of the model, 
printing from layout provides the best results. For more information, see Layout on page 970.         

Printing Directly From a View - You may prefer to print individual drawings directly from a view. See Print Tools on 
page 987.          

Printing to PDF - Plans can be printed to a .pdf file and printed remotely. See Printing to a PDF File on page 995.         

Export to STL - Exports an .stl file that can be printed on a stereolithography machine, or 3D printer. See STL Format on 
page 731.         

TERMINOLOGY

Drawing Sheet Size - The dimensions of the final printed output. This may or may not be the same as the printer paper size. 
If the sheet and paper sizes are the same, only one page is required per sheet. See Drawing Sheet Setup Dialog on page 988.
         

Paper Size - The dimensions of the paper to be printed on. Specifying a paper size that is smaller than the              Sheet Size allows 
large drawings to be printed across multiple pages.         

Check Plot - A test printing, typically at a smaller scale, made before final output to large paper format. For more 
information, see Check Plots on page 994.         

Line Weight - The thickness of a line. A thicker line weight is easier to see, but may not show as much detail. See Line 
Weights on page 995.          

Drawing Scale - Drawings are often printed to scale for accuracy. ¼" = 1' and 1 m = 50 m are examples of common scales. 
You can specify this scale in the Drawing Sheet Setup dialog. See Drawing Sheet Setup Dialog on page 988.          

When a particular scale is not important, drawings can also be sized to fill a particular area. See Printing to Scale on page 
993.         

Always familiarize yourself with your printer or plotter before a 
deadline is near, and bear in mind that it can take a little time to 

configure a new printer.

 

Printers and Plotters
There are many different types of printers and plotters. In general, a printer is smaller, normally outputting 8½ x 11" (Letter 
or ANSI A size), 8½ x 14" (Legal Size) or sometimes as large as 11 x 17" (Tabloid or ANSI B size).

Plotters are typically used to output larger sheets of paper such as 17 x 22" (ANSI C), or 18” x 24” (ARCH C).
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PRINTER DRIVERS

A printer driver is a program that allows a printer to communicate with the rest of the computer system. Drivers are usually 
created by the printer manufacturer, are typically updated regularly, and can usually be downloaded free of charge from the 
manufacturer’s website.          

In addition to interpreting between the printer and the rest of the system, printer drivers save default page size, orientation, 
margin size, and other information that Home Designer refers to unless you specify otherwise. See Print View Settings on 
page 986.         

If you experience printing problems, consider installing updated drivers for your printer. Visit your printer manufacturer’s 
website for more information.         

Options available with one driver may not be available with 
another. Printers and plotters supported in one operating system 

may not be supported by the manufacturer in another.

PRINTING TO FILE

If your print service requires you to print to a file that can be read by their plotter, you can install that printer’s drivers on 
your system and then use the Windows System Print dialog to Print to File. See Print View Dialog on page 1001.           

Printing to a file is not an option in the Mac System Print dialog.           

CLEARING PRINTER INFORMATION

Some information specific to individual printers, such as available paper sizes, is saved with each plan file. You can select 
File> Print> Clear Printer Info to clear the printer-specific information stored with the plan file.

 

Printing Defaults
You can print to any printer or plotter that is supported on your operating system and can specify the current printer at any 
time in either the Drawing Sheet Setup or Print View dialog.            

DRAWING SHEET SETUP

When any orthographic view is active, you can specify its Drawing Sheet size, margins, orientation, printed Drawing 
Scale, and more in the Drawing Sheet Setup dialog. Select File> Print> Drawing Sheet Setup to open this dialog. 

See Drawing Sheet Setup Dialog on page 988.         

The settings in the Drawing Sheet Setup dialog are view-specific. This means that in a plan file, they can be set up one way 
for plan views and a different way for each cross section/elevation view. When a new view is created, its initial settings are 
derived from the current plan view settings.

The Drawing Scale set in the Drawing Sheet Setup dialog acts as the default scale for the active view’s Print, Printed Size 
Input, and Send to Layout dialogs. See Send To Layout Dialog on page 973.           

PRINT VIEW SETTINGS

When you are ready to print an orthographic view, select File> Print> Print. The initial settings in the Print View 
dialog are drawn from the Drawing Sheet Setup for the view. The system’s default printer is selected and if possible, 

the paper size and orientation are set to match those of the Drawing Sheet.          
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Once a view has been printed, most of the settings in the Print View dialog are saved and will be applied to all views of the 
same type, in all Home Designer Pro files. View types with separate Print View settings are:           

 l Plan view          
 l Cross Section/Elevation views          
 l Layout          
 l Materials Lists          

If you prefer that the Print View settings not be retained in this manner, uncheck Remember Print Settings after Printing 
in the Drawing Sheet Setup dialog.          

DISPLAYING OBJECTS

You can control the display of objects when printing directly from a view in the Layer Display Options dialog. See 
Layer Display Options Dialog on page 127.

Objects must be visible in order for them to print; however, not all items that are visible will print. See Print Preview on 
page 992.         

To control the display of objects in a camera view sent to layout, turn layers on/off  in the view before it is sent to layout.

PRINT PREVIEW

To get a sense of whether your current settings will meet your needs when printed, you can use the Print Preview 
toggle to view the printed output on screen before any paper is used. See Print Preview on page 991.         

 

The Printing Tools
Select File> Print to view the Print Tools submenu. These tools fall into four categories. 

PRINT SETUP TOOLS

Drawing Sheet Setup - Opens the Drawing Sheet Setup dialog. See Drawing Sheet Setup Dialog on page 988.

Scale to Fit - Automatically selects a scale that fits your plan to the drawing sheet. See Printing to Scale on page 
993.

Center Sheet - Automatically centers the drawing sheet on your drawing. See Center Sheet on page 993.

Print Preview - Shows on screen how the current view will appear printed, based on the current scale and other 
settings. See Print Preview on page 991.

PRINT TOOLS

Print - Prints the current plan view, Vector View, or layout sheet to a specified scale. See Print View Dialog on page 
1001.

Print Image - Prints the current view including images, textures, and backdrop. Views printed with Print Image are 
not scaled. See Print Image Dialog on page 1004.
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You can also select File> Export> Export PDF to open the Export PDF dialog. See Print View Dialog on page 
1001.

DISPLAY TOGGLES

A number of toggles allow you to turn various aspects of the display on or off. See Interface Toggles on page 12.           

Color  - Turn the on-screen display of color on or off in all views except perspective views. See Color on page 992.         

Line Weights - When this is on, line weights appear on screen as they will print. See Line Weights on page 992.         

Drawing Sheet - Turn this on for a preview of your plan relative to the current Drawing Sheet. See Drawing Sheet 
on page 992.         

Reference Grid - The Reference Grid does not print, so you can turn this off to get a better sense of what the view 
will look like printed. See Reference Grid on page 992.         

ADDITIONAL PRINT TOOLS

Customize Sheet Sizes - Allows you to create custom sheet sizes. See Customize Sheet Sizes Dialog on page 991.          

Clear Printer Info - Some information specific to individual printers, such as available paper sizes, is saved with 
each file. This clears the printer-specific information associated with the current page setup. 

 

Drawing Sheet Setup Dialog
The settings in the Drawing Sheet Setup dialog control the sheet size and scaling for the current view. Select File> 
Print> Drawing Sheet Setup to open this dialog.         

The Drawing Sheet Setup dialog is only available when a plan view, cross section/elevation view,               or layout is active. When 
a perspective view is active, Drawing Sheet Setup is not available.

The settings in this dialog are specific to the current view and are saved with the .plan              or .layout file.              See Printing Defaults 
on page 986.
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Drawing Sheet

Specify the Orientation and Size of the Drawing Sheet, which is the final printed output.         

 l Click the Customize button to open the Customize Sheet Sizes dialog. See Customize Sheet Sizes Dialog on page 
991.          

Paper can often be inserted into plotters in either of two 
orientations. Refer to your plotter’s documentation to find 

out which way to insert the paper for correct results.

 l Check Show Drawing Sheet in View to turn on the display of the Drawing Sheet in orthographic views. See 
Drawing Sheet on page 992.

 
Drawing Scale

Specify the Drawing Scale for the active view. This scale is applied only when the view is printed.         
The scale is specified in two parts, which by default are              1 ft = 1 ft or 1 m = 1 m for layout views, and ¼ inch = 1 ft or 1 
m = 50 m for all other views. Both U.S. and metric units of measurement are available and can be selected independently.
The Drawing Scale acts as the default scale for the active view’s Print, Print Size Calculator, and Send to Layout dialogs.           

 
Printer for View

                 Specify the Printer for View which is the printer for the active view in the current file. These settings are global, affecting 
all plan and layout files.                 
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 l Uncheck Remember Print Settings after Printing to enable the Choose button, below. When this is checked, the 
printer is selected in the Print View dialog. See Printing Defaults on page 986.         

 l Click the Choose button to select a printer and edit its paper settings in the Default Printer for View dialog.         

The name of a Printer displays to the left of the Choose button for reference.

 l If the Remember box is checked, the last printer used in the current view type is shown; if no printer has been used 
in the current view, “None” will display.         

 l If the Remember box is unchecked, the system’s default printer will be shown.         

If you have questions about your printer’s settings, consult its documentation.

 
Drawing Margins

Specify the Drawing Margins which define the extents of the printable area of the active view’s Drawing Sheet.         

 l Click the Populate from Printer button to set the margins based on the selected printer’s default settings. See 
Printers and Plotters on page 985.          

 l Specify the width of the Top, Bottom, Left, and Right margins.         

 
Advanced Line Weights

The Advanced Line Weight Options allow you to specify the active view’s line weight scale. A layout file’s line weight 
scale should always be the same as that of any plan views associated with it. See Line Weights and Scaling on page 996.         

 l Check Use 1 for all line weights (Home Designer compatibility) to have the program maintain a consistent line 
thickness and dash size when the drawing scale is changed. When checked, the Line Weight Scale is based on a 1/4 
inch = 1 foot drawing scale and 1= 1/300 inch line weight scale.               This option is not available for layouts and is not 
normally recommended. See Line Weights on page 995. 

 l Select the Line Weight Scale. See Line Weights and Scaling on page 996. This setting should always be the same 
for both a given layout file and any plan views associated with it.          

 
Preview of Line Weight

A line weight Preview illustrates how changes to the line weight scale affect the printed size of various line weights at the 
current Drawing Scale.         

DEFAULT PRINTER FOR VIEW DIALOG

To open the Default Printer for View dialog, click the Choose button in the Drawing Sheet Setup dialog.          

 l Select a Printer from the drop-down list.          
 l Choose the Orientation of the paper used by the selected printer.          
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 l Select a Paper Size from the drop-down list. The options available will depend on the selected printer.          
 l Select a Paper Source from the drop-down list. The options available will depend on the selected printer.          

CUSTOMIZE SHEET SIZES DIALOG

To open the Customize Sheet Sizes dialog, select File> Print> Customize Sheet Sizes, or click the Customize 
button in the Drawing Sheet Setup dialog.           

Several options are available:          

 l Click New to create a new sheet size.          
 l Select a sheet size and click Copy to create a duplicate sheet size.          
 l Click Delete to remove the selected sheet size.          
 l Select a sheet size and click Edit to open the Edit Paper Size dialog and change its description, dimensions, and units 

of measurement.         

 l Click OK to close the dialog. Any new sheet sizes created are now available in the Drawing Sheet Setup dialog.          
 l The data for this dialog is stored in the “sheetSizes.sheet” file in the program’s Data folder.           

CLEARING PRINTER INFORMATION

Select File> Print> Clear Printer Info to clear the printer-specific information stored in the Drawing Sheet Setup 
dialog. See Printers and Plotters on page 985.

 

Print Preview
Print Preview and its related display toggles allow you to get a sense of what the current view will look like when it is 
printed.
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PRINT PREVIEW

Select File> Print> Print Preview for an on-screen representation of how the current view will appear when printed. 
Print Preview is only available in views that can be scaled. See Printing to Scale on page 993.

When Print Preview is on, the Drawing Sheet and line weights are displayed, and the Drawing Sheet  and Line 

Weights  toggles are overridden.         

Objects such as camera symbols, CAD points, text and dimension objects appear on-screen as they will on the printed page.

When Print Preview  is enabled, color will display depending on whether Print in Color is selected in the Print View 

dialog. See Print View Dialog on page 1001. 

The Reference Display does print if it is visible. See The Reference Display on page 525.         

COLOR

The Color toggle turns the on-screen display of color on or off in all views. When Color is toggled off, views print in 
either black and white or grayscale depending on your Preferences setting. See Colors Panel on page 65.

REFERENCE GRID

The Reference Grid is an on-screen grid composed of regular squares that can be used to convey a sense of scale 
while drawing.  It does not print, and its size can be specified in the General Plan Defaults dialog. See General Plan 

Defaults Dialog on page 60.         

LINE WEIGHTS

Select View> Line Weights for an on-screen representation of line weights and line styles.  Turning Line Weights on 
or off does not affect the final printed output.         

 l When Line Weights is turned on, you can Zoom In  to see the location of lines and dashed lines as they will 

appear on the printed page.
 l When Line Weights is off, dashed lines look the same, regardless of the zoom factor.

Line Weights can also be turned on or off in the Preferences dialog. See Appearance Panel on page 63.

DRAWING SHEET

The Drawing Sheet is a representation of the size and orientation of the final printed output. It is different from the 
printed page size, which means that you can print a large Sheet to multiple smaller pages. Select View> Drawing 

Sheet to show the Drawing Sheet on screen.

The Drawing Sheet size and orientation are specified in the Drawing Sheet Setup dialog. See Drawing Sheet Setup Dialog 
on page 988.

When the Drawing Sheet is set to display, a blue border representing the margins of the printable area will also display for 
reference. If the margins have been set to populate from the selected printer, this border may not display on all edges of the 
drawing sheet. See Printer Drivers on page 986.

When Drawing Sheet  is on, the drawing sheet behaves as an object.
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 l When selected at its border the sheet has edit handles, allowing it to be moved. See Editing Objects on page 137.
 l You can also resize the sheet using its edit handles; however, for best results, it is recommended that you instead select 

an available sheet size in the Drawing Sheet Setup dialog. See Drawing Sheet Setup Dialog on page 988.
 l Dimension lines can locate the edges of the sheet and can be used to position other objects relative to it. See Moving 

Objects Using Dimensions on page 341.

Note: Specifying a sheet size in the Drawing Sheet Setup dialog 
is preferable to editing the sheet size on-screen.

The drawing sheet cannot be rotated or copied.

CENTER SHEET

Select File> Print> Center Sheet to center the Drawing Sheet on the drawing. This moves the              Sheet relative to the 
drawing but does not affect the coordinates of objects in the drawing. The location of the Drawing Sheet is 

independent for each floor of the model.         

 

Printing to Scale
Several different print scaling options are available. The type of view that you are printing determines which options you 
may choose from.

ORTHOGONAL VIEWS

Plan views, Orthographic 3D  views, and layout pages are orthogonal views, which means:         

 l Your line of sight is at a right angle to all objects in the view.             
 l Objects do not appear to decrease in size as their distances from the viewer increase.             

Orthogonal views can be printed to scale; however, Orthographic 3D views can only be printed to scale when the Vector 
View Rendering Technique is used.         

The scale set in the Page Setup dialog is inherited by the Print and Send to Layout dialogs. This scale can be overridden on 
an individual basis in either of these dialogs. See Print View Dialog on page 1001 and Sending Views to Layout on page 
973.         

Select File> Print> Scale to Fit  in an orthogonal view to select a suitable scale and re-center the drawing sheet so that 

everything fits on the sheet.         

U.S. Unit drawing scales are typically noted in inches per foot. Larger scales, such as 1 inch = 50 feet or 1:200m, are often 
used for property layouts.         

PERSPECTIVE VIEWS

Camera views and Perspective overviews display the model much the way the eye would see it and cannot be scaled.         

 l Objects in the view may be at any angle relative to your line of sight.              
 l Objects seem to decrease in size as their distances from the viewer increase.             

Perspective views can only be printed using the Print Image  tool. See Print Image Dialog on page 1004.         

While perspective views cannot be scaled, you can control the printed size of the view. If Fit to Paper is selected in the 
Print View dialog, a percent value can be set that defines how much of the printed page to fill. See Print View Dialog on 
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page 1001. 50% causes the print to be 50% of both the height and width of the paper, including the non-printable border.           

For example, if printing to an 8½ x 11 page with a 1" non-printable border in each direction:           

 l 100% would print an area 8½ x 11. This is not recommended, as part of the output could fall outside the printable 
area.          

 l 50% would print an area 4¼ x 5½.           
 l Each printer may vary slightly.          

CHECK PLOTS

A check plot is a test print that allows you to print at a reduced scale on smaller, less expensive paper so you can check that 
the drawing will print as expected. The drawing scale is temporarily adjusted to a specified fraction of its true value. Both 
drawing scale and line weights are subject to this scale adjustment.           

For example, if a layout has a border designed to fit on a Drawing Sheet of 24” x 36”, a check plot at 1/2 scale would allow 
it to fit on a 12” x 18’ page. A view sent to that layout at a Drawing Scale of 1/4” = 1’ would be scaled at 1/8” = 1’ when 
printed at 1/2 scale.           

To create a check plot

 1.  Select File> Print> Print View . In the Print View dialog:           

 l Click the Check Plot at radio button, then choose the desired scale fraction from the drop-down list.           

 l The Paper Size will automatically adjust to fit the selected Check Plot Scale.           

 l Confirm that the Paper Size is the size you wish to use, then click Print.          

 2.  The next time you print a view, remember to choose To Scale or Fit to Paper again in the Print View dialog.           

PRINTING TEXT, DIMENSIONS, AND LINE STYLES

As with other objects your drawings, text and dimension numbers are subject to scaling when views are sent to layout or 
printed. See Scaling Text on page 359.          

Printed text size is also influenced by the selected font and the method used to specify its size. See Character Size on page 
349.          

Text may not print exactly as it appears on-screen. To get a better idea of how text and dimension characters will print, you 
may find it helpful to Zoom In  on them.           

For best printed results, using true-type or open-type fonts is recommended.           

Text may not appear accurately on screen when the font used by 
the printer is different from the font used on screen. Consult 

your printer documentation for more information on font substitution.

The line styles assigned to CAD and a variety of other objects are subject to scaling when printed as well. They are only 
subject to scaling when sent to layout, however, under specific circumstances. See Line Weights and Scaling on page 996.           
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Printing Across Multiple Pages
When printing directly from a plan view, cross section/elevation view, or layout it is possible to print at a scale that does not 
fit the drawing on one page.

When printing to a paper size that is smaller than the sheet size, a 2% overlap is used. Crop marks print where the paper 
needs to be cut between pages. A solid line is drawn at the drawing sheet boundary on the sides that need to be cut.          

To see on-screen what the drawing will look like when printed, select View> Drawing Sheet   and then Window> Fill 

Window . Grey lines across the drawing sheet  indicate where the page breaks will occur. See Drawing Sheet on page 

992.

 

Printing to a PDF File
Portable Document Format, or .pdf files, are  one of the most universally compatible and efficient file formats and can be 
viewed and printed on most computer platforms. 

You can save any view as a .pdf file by selecting “Chief Architect Save as PDF” or any other PDF writer installed on your 
system as the Destination printer Name in either the Print View or Print Image dialog. See Print View Dialog on page 1001 
and Print Image Dialog on page 1004. 

You can also print to .pdf from any view by selecting File> Export> Export PDF . See PDF Files on page 859.

When you print to .pdf, you will be asked to create a file name and choose a destination to save it in the Save as PDF File 
dialog. See Exporting Files on page 39.

You can also import .pdf file into Home Designer. See Importing PDF Files on page 859.         

 

Line Weights
The weight of a line refers to its thickness on the printed page and is described in absolute terms as a fraction of a unit, 
often 1/100th of a millimeter or 1/1000 of an inch. In Home Designer Pro, line weights are assigned to objects, patterns, and 
layers using whole numbers that correspond to the numerator of this fraction. 

Line Weights are specifically a tool for controlling printed output; however, you can toggle the on-screen display of 
Line Weights to get a sense of how they will print by selecting View> Line Weights. See Line Weights on page 992.

         

You can specify the Line Weight Scale by defining the denominator and the unit used in this fraction in the Drawing Sheet 
Setup dialog. See Drawing Sheet Setup Dialog on page 988.           

The method for specifying an object’s line weight depends on the object and the type of view.          

 l Most objects’ line weights can be set by layer. See Layer Display Options Dialog on page 127.          
 l Some objects’ line weights can be set in their specification dialogs. See Line Style Panel on page 209.          
 l The line weights for walls in plan view are defined by wall type in the Wall Type Definitions dialog. See Wall Type 

Definitions Dialog on page 264.          
 l The line weights of material pattern lines, which are visible in Vector Views, can be set in the Define Material dialog. 

See Define Material Dialog on page 760.           
 l The line weight for fill patterns is set for individual objects in their specification dialogs. See Fill Styles on page 131.          
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 l The line weight applied to surface edges in Vector Views can be set in the Print dialog. See Print View Dialog on page 
1001.         

 l The end cap length of dashed lines in plan view is set in the Preferences dialog.  See CAD Panel on page 78.          
 l An assigned line weight of 0 draws a line weight of 1 pixel, the thinnest line weight a printer allows. How thick this is 

varies from printer to printer. See Printers and Plotters on page 985.           

LINE WEIGHTS AND SCALING

Line weights and line styles are subject to scaling when printed. You can see an on-screen approximation of what lines will 
look like when a view is printed by toggling on either Line Weights  or Print Preview . See Print Preview on page 

991.          

When a view is sent to layout, line weights and styles may be further affected by the drawing scale selected for the layout 
view. This occurs when the layout view’s scale is different from the Drawing Scale of the original view.           

For example, assume that you have an object in a view with a line weight of 20, and that the view’s Drawing Scale is 1 mm 
= 50 mm.           

 l If you send the view to layout at 1 mm = 25 mm scale, twice the original scale, the resulting printed line weight for 
this object will increase to 40 instead of 20.           

 l If you send the view to layout at 1 mm = 100 mm scale, half the original scale, the resulting printed line weight for 
this object will decrease to 10 instead of 20.           

Line weight scaling affects both line weights and line styles and can be particularly noticeable with dashed line styles.              

You can specify the drawing scale for any orthogonal view by opening the Drawing Sheet Setup dialog while in that view. 
See Printing to Scale on page 993.           

For any layout view, you can specify whether the original line weight is maintained or not in the Send to Layout dialog. See 
Send To Layout Dialog on page 973.   

Note that in order to produce exact line weights, a Vector View must be sent to layout using the Plot Lines option. See Plot 
Line Views on page 977.          

Note: Under most circumstances, you should select Use Layout Line 
Scaling when sending views to layout.

In the following image, the same plan view has been sent to layout twice, at two different scales. The view on the left was 
sent at the same scale as the original view, 
1/8” = 1’.  The view on the right was sent at 1” = 1’, or magnified eight times, to show an area of the plan in greater detail.           

Because the view on the right was sent to layout at a scale other than that of the original, it is subject to layout line scaling.           

The solid lines representing walls, cabinets and doors are rescaled to be eight times thicker than in the original view.          
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Similarly, the dashed lines representing the door jambs are rescaled so that the dashes and the spaces between them are eight 
times larger than in the original view.           

If Use Layout Line Scaling is enabled, line weights are no longer scaled and the dashed lines display at the same size as in 
the original view.           

Because the view in this example is scaled eight times larger in this case, the dashes and line weights look relatively small 
and fine when Use Layout Line Scaling is enabled. Were the view rescaled to be smaller instead, the line weights would 
look relatively large and thick.          

PRINTERS AND LINE WEIGHT

Line weight and print scaling are subject to the limitations of the printer being used. For example, you will not be able to 
see the difference between a line that is 1/150th of an inch wide and one that is 1/300th of an inch wide when they are 
printed using a printer that prints 150 dots per inch (DPI).           

That is, a CAD line with a line weight of 1 will look the same as a CAD line with a line weight of 4 when the Line Weight 
Scale is set at 1 = 1/600th of an inch and you print to a printer capable of 150 DPI.           

Setting an object’s or group of objects’ line weight to zero causes the lines to print as thinly as possible.          

The default Line Weight Scale of 1 = 1/100 mm makes it easy to 
meet many professional drawing standards and in most cases 

should not be changed.
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Watermarks
A customizable watermark containing text or the image of your choice can be added to any plan view or layout. To 
toggle the watermark on or off in the current view, select View> Watermark.         

In layout files, the watermark will display on all pages when it is toggled on. In plan files, on the other hand, the Watermark 
toggle can be set on a view by view basis and can be saved in the Camera Specification and Cross Section/Elevation 
Specification dialogs. See View Specification Dialogs on page 104.

Watermarks also are file specific, so you can have a different watermark in each plan and layout file if you wish.              

The method for printing a view with a watermark varies depending on the view type:          

 l For most types of views, check Show Watermark in the Print View dialog. See Print View Dialog on page 1001.           
 l For perspective cameras and overviews, toggle the watermark on before printing. See Saving and Printing 3D Views 

on page 800.           

WATERMARK DEFAULTS DIALOG

A watermark can be customized in the Watermark Defaults dialog. To open this dialog, select Edit> Default Settings and 
in the Default Settings dialog, click on “Watermark” and click the Edit button.          

You can also open this dialog by clicking the Define button in the Print View dialog. See Print View Dialog on page 1001.          

When the Watermark Defaults dialog is open, the watermark will display in the view window behind the dialog and will 
update as changes are made to its settings.          
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Watermark Type

Select a Watermark Type from the drop-down list.          

 
Text

These settings are available when “Text” is the Watermark Type selected above.         

 l Type the desired watermark Text in the text field.          

 l Click the Color bar to select a color for the watermark text. See Select Color Dialog on page 135.          

 l Specify the Print Size of the watermark text, as measured from the baseline to top of the capital letter A in the 
selected Font.           

 l Select a Font from the drop-down list.          

 
Image

These settings are available when “Image” is the Watermark Type selected above.   

 l To select an image to use as the watermark, click the Browse button to open the Watermark Image File dialog, 
which is a typical Open dialog. See Importing Files on page 43.     

 l When an image File is specified, its pathname displays in the text field. You can type a different pathname if you 
wish. When you click OK, however, the image reported here becomes embedded in the current plan or layout and 
will no longer be listed in this field if you return to this dialog.          

 l Specify the Ratio to Sheet, which is how far the image extends across the sheet. Not available when “Fit to Sheet” 
Layout is selected, below.          

  General

 l Specify the Layout of the watermark from the drop-down list.          

 l Specify the watermark’s Angle, measured relative to a horizontal line pointing towards the right-hand side of the 
screen.           

 l Use the Transparency slider bar or text field to control how transparent the watermark is.           

 l The Marks Per settings are only available when “Tile” or “Border” is selected as the Layout, above.          

 l Specify the Marks Per Row, which is the number of instances of the watermark across the width of the Drawing 
Sheet.          

 l Specify the Marks Per Column, which is the number of instances of the watermark from top to bottom of the 
Drawing Sheet.          

 
Margins

Specify the watermark Margins, measured in from the edges of the Drawing Sheet.         

 l Check Use Drawing Sheet Margin to use the same margins for the watermark that are specified for the Drawing 
Sheet or uncheck this box to enable the settings that follow. See Drawing Sheet Setup Dialog on page 988.           

 l Specify the width of the Top, Bottom, Left, and Right watermark margins.          

 l Check Update Automatically to have the watermark update in the current view as changes are made in the dialog.           
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 l Click the Update button to update the watermark in the view behind the dialog. Not available if Update 
Automatically is checked above. 

  Preview

 l Check Update Automatically to have the watermark update in the current view as changes are made in the dialog.

 l Click the Update button to update the watermark in the view behind the dialog. Not available if Update 
Automatically is checked above.             

 

Print View Dialog
To print from plan view, 3D Vector Views,  layout, or the Materials  List, select File> Print> Print. The Print View 
Print Layout, or Print Materials List dialog opens. The settings that are available will vary depending on which 

version of the dialog is open. 

Select File> Export> Export PDF to open the similar Export PDF dialog.

Note: 3D views that are not Vector Views can be printed using Print 
Image. See Print Image Dialog on page 1004.

If Remember Print Settings after Printing is checked in the Drawing Sheet Setup dialog, most settings in this dialog will 
be saved and applied globally to all views of the same type in all Home Designer files. There are three exceptions: Sheets 
and Copies are always reset, and the Print Source is determined by whether or not the Drawing Sheet  is toggled on 

See Print View Settings on page 986.           
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  Destination

 l Select the Name of the printer you would like to use from the drop-down list. To print to .pdf, select “Chief 
Architect Save as PDF” from the list, or choose a .pdf writer installed on your system. See Printing to a PDF File 
on page 995.

 l Select the DPI, or Dots Per Inch to use when printing, from the drop-down list. The available options may vary 
depending on the selected printer.

 
Paper

Select the Paper Orientation, Size, and Source. The available Size and Source options are controlled by the selected 
printer’s driver. See Printer Drivers on page 986.

 l When possible, the program will automatically set the Size and Orientation to match those of the Drawing Sheet. See 
Drawing Sheet Setup Dialog on page 988.

 l The Paper Size may be automatically adjusted if the Drawing Scale option is changed, below.

 
Print Range

In layout files only, specify the range of pages to print. Only pages that have views or objects drawn directly on them                 
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Print Source

Not available in the Print Materials List dialog.

 l Select Drawing Sheet to print the entire sheet even though you may be zoomed in on a portion of the view. This is 
selected by default when the Drawing Sheet is set to display in the current view.

 l Select Current View to print only that portion of the active view that is currently visible on screen. If you are 
zoomed out, any blank space outside the printable objects in the view is ignored. This is selected by default when the 
Drawing Sheet is not displaying in the current view.

 
Drawing Scale

 Changes to these options may cause the Paper Size to change, above. Not available in the Print Materials List dialog or in 
camera views or overviews. See Printing to Scale on page 993.

 l Fit to Paper prints the view on one page. The program uses whatever scale is necessary to fit the plan on one page. 

 l When Fit to Paper is selected, specify the percentage of the paper to be used. The default value is 95%.

Note: The Fit to Paper percentage value is global - affecting all views 
in all files, and is retained between sessions.     

 l Select To Scale to print at the scale specified in the Drawing Sheet Setup dialog. See Drawing Sheet Setup Dialog 
on page 988.     

 l To print a check plot, select Check Plot at and choose a scale adjustment from the drop-down list. See Check Plots 
on page 994.          

  Options

 l Specify the number of Copies you would like to print. 

 l Check Include Watermark to include a watermark in the printed output. Click the Define button to open the 
Watermark Defaults dialog. See Watermark Defaults Dialog on page 998.          

 l Check Print in Color to print in color or clear the check box to print in either grayscale or black and white. In the 
Print Materials List dialog, system default colors are used when this box is unchecked.

 l To print in grayscale, check Obey Color On/Off Setting in the Preferences dialog before printing, then uncheck 
Print in Color. See Appearance Panel on page 63.          

 l To print in black and white, uncheck Obey Color On/Off Setting in the Preferences dialog before printing, then 
uncheck Print in Color. Lines and fill colors print as either black or white, depending on which is closer to the line 
or fill’s actual color.           

 l Most black and white printers print a grayscale approximation of the colors if Print in Color is selected.           

 
Advanced Options

Click the Open System Print Dialog button to close the Print View dialog and print using your operating system’s Print 
dialog instead. Not available when No Printer is selected.             

 
Preview

Control the appearance of the print job preview on the right side of the dialog.    
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 l Specify the Page that displays in the Preview area.

 l Click the buttons to Zoom In, Zoom Out, or Fit the selected Page to the extents of the Preview area. 

 l Uncheck Update Automatically to turn off the print job Preview and prevent it from updating as changes are made 
to the settings in this dialog. 

 l Click the Update button to update the print job Preview to reflect the current settings in this dialog. If Update 
Automatically is unchecked, clicking Update may force the Preview to be blank.

  Preview Pane

 l When Update Automatically is checked, a preview of the current print job displays here. The drawing sheet 
displays as a white rectangle, and if multiple sheets are required, you can scroll through them. If the print job is 
large, a progress dialog may display briefly as the preview draws or updates.

 
 Information

To help prevent unwanted printed output, information messages regarding page size, resolution, and scale may display 
below the preview pane, depending on the settings in this dialog. 

 

Print Image Dialog
Any view can be printed by selecting File> Print Image. This is the only way to print most 3D views. See 3D 
Rendering on page 814.

The Print Image dialog is similar to the Print View dialog; however, the printing process is different. Print Image prints 
individual pixels as opposed to vectors (lines).

 
Destination

Select the Name of the Printer you wish to use from the drop-down list. To print to .pdf, select “Chief Architect Save as 
PDF” from the list, or choose a .pdf writer installed on your system. See Printing to a PDF File on page 995.
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 l Select the DPI, or Dots Per Inch to use when printing, from the drop-down list. The available options may vary 
depending on the selected printer.          

 
Paper

Select the Paper Orientation, Size, and Source. The available Size and Source options are controlled by the selected 
printer’s driver. See Printer Drivers on page 986.

 
Options

Specify the number of Copies you would like to print. 

 
Advanced Options

Click the Open System Print Dialog button to close the Print View dialog and print using your operating system’s Print 
dialog instead. Not available when No Printer is selected.

 
Preview

Control the appearance of the print job Preview on the right side of the dialog.

 l Specify which Page displays in the Preview area.

 l Click the buttons to Zoom In, Zoom Out, or Fit the selected Page to the extents of the Preview. 

 l Uncheck Update Automatically to turn off the print job Preview and prevent it from updating as changes are made 
to the settings in this dialog. 

 l Click the Update button to update the print job Preview to reflect the current settings in this dialog. If Update 
Automatically is unchecked, clicking Update may force the Preview to be blank.

 
Preview Pane

When Update Automatically is checked, a preview of the current print job is displayed to the right. If the print job is large, 
a progress dialog may display briefly as the preview draws or updates.

 
Information

To help prevent unwanted printed output, information messages regarding page size and resolution may display here, 
depending on the settings in this dialog. 
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Chapter 41
 

Resources and Support

Chief Architect technical support and training resources to help you be successful using our software. 

TOPICS

Learning and Inspiration 1007
Contacting Technical Support 1008
Error Messages 1008
Program Paths Dialog 1009
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Learning and Inspiration
Chief Architect offers a variety of resources that help you learn how to use the software, discover new drawing techniques, 
and connect with other Home Designer users.

HOME DESIGNER WEBSITE

The Home Designer website has an array of resources, including downloadable library content, program updates and 
more. Select Help> Visit Home Designer Web Site from the program menu to launch your default internet browser 

to HomeDesignerSoftware.com.

The vocabulary used in the design and construction trades vary widely by region. Our online Glossary provides definitions 
for the terms we use in our information resources. Visit HomeDesignerSoftware.com.

REFERENCE MANUAL

The Home Designer Pro 2025 Reference Manual is a comprehensive source of information about the entire program 
interface. This manual is available online in .pdf format by selecting Help> View Reference Manual.

USER'S GUIDE

Written for new Home Designer users, but a helpful reference for users of all experience levels as well, the User's Guide 
walks you through the process of creating a complete model, from the first wall to the interior design and landscaping.   

This guide is available online by selecting Help> View User's Guide.

ONLINE HELP VIDEOS

Another resource that illustrates Home Designer’s tools is the collection of tutorial videos available on our website. To view 
the online videos, select Help> View Online Help Videos from the program menu or visit 
www.homedesignersoftware.com/videos.

ONLINE KNOWLEDGE BASE

The Home Designer Knowledge Base is a collection of online articles that address common technical issues as well as a 
range of how-to questions with illustrations and step-by-step instructions. To access these resources, visit  
HomeDesignerSoftware.com.

HOMETALK ONLINE FORUM

The HomeTalk User Forum hosts ongoing discussion on a variety of topics related to the use of Home Designer. It is rich 
with useful tips and available free of charge to all registered Home Designer users. 

 l Discussions are initiated and carried out by users.
 l Experienced users share knowledge with each other and beginners.
 l Chief Architect Software team members post announcements, advice and technical information.

To visit HomeTalk, select Help> HomeTalk or go to   hometalk.chiefarchitect.com.
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ONLINE SAMPLES GALLERY

A collection of plans and renderings is available for viewing and download on our website. Select File> Download 
Sample Plans to launch your internet browser to HomeDesignerSoftware.com.

 

Contacting Technical Support
Chief Architect’s world class technical support services can be accessed both online and by telephone. Select Help> 
Technical Support from the program menu to visit  HomeDesignerSoftware.com.

Before contacting Technical Support, take a moment to see if the answer to your question is found in the program’s Help, 
Training Videos, or other online resources. When you contact us, you will be referred to these resources if the answer can 
be found there.

There are a number of things you can do to ensure a speedy answer to your question when you contact Technical Support.

 l Select Help> About Home Designer (PC) or Home Designer> About Home Designer (Mac) and make a note of the 
first characters of your Product Key and the program’s Build number.

 l We periodically release updates to the current program version. Before contacting Technical Support, select Help> 
Download Program Updates and make sure you are running the most current update for your program version. 

 l When you encounter an error message, click the Send Report button if possible and copy the message’s exact 
wording. See Error Messages on page 1008.

 l When calling Technical Support, have Home Designer running on the computer where the problem occurs. This is 
necessary in order to troubleshoot the issue and verify that a solution is found. 

 l Be prepared to reproduce and describe the problem in detail. If we cannot reproduce the problem, there is a reduced 
chance that we will be able to resolve it.

TELEPHONE SUPPORT

Our Technical Support team is committed to answering your questions as quickly as possible and in the order received. We 
can resolve most issues in just a few minutes and are happy to help you find the best resource to answer your questions. So 
that we can quickly answer all calls, though, we may ask that you limit your inquiry to one question. 

ONLINE SUPPORT

If a Support technician needs to see a copy of a plan, layout, or other file, they will ask you submit it to us using the Chief 
Architect Online Support Center. 

Questions can also be submitted directly to the Technical Support department using the Online Support Center as well. Be 
sure to provide a detailed description of the problem you are encountering in your ticket.

 

Error Messages
Most common error messages have a known cause and simple resolution. When you encounter an error or warning message 
in Home Designer, you can click the Check Knowledge Base button in the message box to launch your default internet 
browser to the Home Designer Knowledge Base on our website,  HomeDesignerSoftware.com.

If the message is discussed in an article it will display, providing information about the message and how best to avoid it. 

It is important that abnormal errors be reported to Chief Architect Technical Support so that we can identify and resolve any 
problems. 
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The content of an error message is useful in diagnosing its cause. If you encounter an error message, make a note of the 
error number and the full text of the message. You can also click the Details button and copy the text into a text document 
or Online Support on page 1008 Center ticket.

If you encounter the error more than once, make a note of your steps prior to receiving the message.

Finally, check to see if there are program updates available. Program updates contain enhancements and other changes that 
allow the software to perform at an optimum level. Select Help> Download Program Updates from the Home Designer 
menu and follow the instructions on our website,  HomeDesignerSoftware.com.

ERROR REPORTING

When an error occurs, you may have the option in the message box to send the report to Chief Architect by clicking the 
Send Report button in the error message box. A report containing technical details about the error, but no personal 
information, is sent to our Testing team for evaluation. 

When you click the Send Report button, the Automatically Send Error Reports option will be enabled so that a report will 
be sent automatically should you encounter additional errors in the future. When Automatically Send Error Reports is 
enabled, error message boxes will not have a Send Report button. You can enable or disable Automatically Send Error 
Reports in the Preferences dialog. See General Panel on page 69.  

After clicking the Send Report button, please contact  Technical Support with any additional information that you may 
have about the circumstances of the error: for example, the type of view that was open and the tool that was active.

 

Program Paths Dialog
Some technical issues can be caused by problems with support files used by Home Designer Pro. In the event of such an 
issue, Chief Architect Technical Support may direct you to the Program Paths dialog. This dialog displays a list of files 
utilized by the software along with the pathname of each.  

To avoid unintended problems that could prevent you from using the software, it is strongly recommended that you make no 
changes to any of the files in this list except with the direct assistance of Technical Support.
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Chapter 42
 

What’s New in Home Designer 2025

Welcome to Home Designer 2025. This topic has been written to help our upgrading customers make a smooth transition 
from earlier versions of Home Designer to Home Designer 2025. 

TOPICS

Getting Started Checklist 1011
Migrating Legacy Content 1012
Migrating Legacy Settings 1012
Migrating Legacy Templates 1013
Considerations for Legacy Files 1013
New and Improved Features by Chapter 1019
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Getting Started Checklist
There are many new features in Home Designer 2025, and many existing features have changed. The following checklist 
suggests steps you should take before migrating your files to Home Designer 2025. More information about each of these 
steps can be found after the checklist.

 1. □   Review the List of New and Improved Features by Chapter

There are a number of important reasons why you should familiarize yourself with the new and improved features in 
Home Designer 2025:

 l New and improved features allow you to produce drawings more efficiently, so it is to your advantage to use 
them. 

 l Some changes to existing functionality may affect your accustomed drawing style and thus your productivity 
if you are not aware of them. 

 l New features may affect your choice of settings in your template files, as well as your preferred Preferences 
settings. 

See  New and Improved Features by Chapter on page 1019. 

 2. □   Review Migrating Legacy Content

Legacy users of Home Designer often have library catalogs and other custom content that they want to continue 
using. See Migrating Legacy Content on page 1012.

 3. □   Review Migrating Legacy Settings

Before migrating Preferences or Toolbars, bear in mind that legacy settings may not be best suited for using the new 
program version. See Migrating Legacy Settings on page 1012.

 4. □   Review Migrating Legacy Templates

Before migrating Templates, bear in mind that they may not be set up to take advantage of new tools in the new 
program version. See Migrating Legacy Templates on page 1013.

 5. □   Review the Considerations for Legacy Files

Before opening a plan or layout file created in a previous version of Home Designer, be aware of potential changes to 
the file that could occur in the new program version. See Considerations for Legacy Files on page 1013.     

 6. □   Launch Home Designer 2025

Once you have learned about the new features in Version 2025 and decided whether to migrate any custom settings from a 
legacy program version, launch Home Designer 2025. The first time you launch, the Migrate Settings dialog will give you 
the opportunity to bring legacy settings and content forward into Version 2025.
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Migrating Legacy Content
Legacy users of Home Designer Pro often have a wealth of library catalogs and other custom content that they have built 
over time and want to continue using. 

LEGACY LIBRARY CONTENT

There are several ways that legacy library catalogs can be brought into Home Designer 2025. 

If you have Home Designer version 2014 through 2024 installed on your computer, the Migrate Settings dialog will display 
after you activate the license, allowing you to migrate library content as well as a selection of other settings for use in Home 
Designer 2025. If multiple legacy versions are present on the system, only the data associated with the most recent will be 
migrated.

You can import library files from Versions               8 through 2014 at any time by selecting Library> Import Library (.calib, 
.calibz) from the program menu.

CUSTOM GRAPHICS FILES

Home Designer can use graphics files regardless of where they are stored on your system; however, it is a good idea to keep 
your data organized in one location. If you have custom graphics files, including textures, images or backdrops that you 
used in a previous program version, you can copy them manually using your operating system for use in Home Designer 
2025.  

 l Copy custom texture files to the Home Designer 2025 Textures folder located in the Home Designer 2025 Data folder. 
 l Copy custom image files to your Home Designer 2025 Images folder located in the Home Designer 2025 Data folder. 
 l Copy custom backdrop files to your Home Designer 2025 Backdrops folder located in the Home Designer 2025 Data 

folder. 

In Home Designer 8 through 2024, custom graphics were saved in the Home Designer Data folder, as they are in version 
2025. In version 7, they were located in the program’s installation directory, in folders that began with “My”. Custom 
backdrops, for example, were saved in “My Backdrops”. 

Texture and image files are not listed in the Library Browser. These files can be assigned to material and image objects, 
however, which are stored in the library so it is important to retain them. There are several tools available for adding 
materials and images to the library. 

 

Migrating Legacy Settings
The Migrate Settings dialog lets you migrate settings from the most recent legacy installation of your Home Designer title 
into Version 2025. If you have extensively customized your Preferences or Toolbars, you may want to continue using those 
settings. Before doing so, though, it is important to consider that you may make it harder to take advantage of new tools and 
functionality in Version 2025.

PREFERENCES SETTINGS

Although you can migrate your Preferences settings from Versions 2014 through 2024 into Version 2025, the settings that 
are available in Version 2025 may differ from previous program versions. You should review all the settings in the 
Preferences dialog to make sure that they are set to suit your drawing needs. 
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CUSTOM TOOLBARS

It is possible to migrate toolbars from previous program versions into Version 2025; however, it is also possible that your 
migrated toolbars will be missing new tools available in Version 2025. 

Additionally, obsolete toolbar buttons are occasionally removed from the program and will also be removed from migrated 
legacy toolbars. See  New and Improved Features by Chapter on page 1019 for information about new features as well as 
removed or deprecated tools.

We recommend that you set up your custom toolbars the way you would like them in Version 2025. You may find it most 
effective to customize your toolbars as you get used to working in the new program version, rather than beforehand.  

 

Migrating Legacy Templates
Home Designer 2025 installs a selection of template plan and layout files that have been set up to take advantage of the 
program’s updated tools and features. See Creating a New Plan or Layout on page 36. Although you can migrate your 
template files for use in Version 2025, for best results it is recommended that you use the templates installed with Home 
Designer 2025.

If you choose to continue using template files that you used in a previous program version, it is very important that you take 
the time to review all the default settings in the file, making sure that they will continue to suit your needs in Version 2025. 
See  New and Improved Features by Chapter on page 1019.

Next, make sure that you are aware of changes in Version 2025 that may affect legacy files: including templates. See 
Considerations for Legacy Files on page 1013.

 

Considerations for Legacy Files
As in all software, every new program version introduces changes to its functionality as well as to the user interface. If you 
choose to bring a project forward, be sure to take a few moments to look it over in the new version and confirm that the new 
functionality does not require you to make any modifications. Particularly if you have an approaching deadline, you may 
find it best to finish the current project in the version of the software in which you began it.

Be sure to read this section before opening any plans created in 
earlier versions of Home Designer.

Home Designer 2025 can open the .plan and .layout files from prior versions. Files with the older .pl and .la file extensions 
are no longer supported, however, and cannot be opened by Home Designer 2025. Before opening any files created in 
earlier versions of Home Designer, it is important to be aware of changes made in the newest version and the effect they 
may have on your legacy plan and layout files. 

Please note that files saved in the latest program version cannot be read by older versions of the software. When a legacy 
file is saved in the version 2025, an unaltered copy of the original file is created in the Home Designer 2025 Data folder, 
under Archives, which can still be opened in the original version. 

FOR FILES CREATED IN VERSION 2024 AND PRIOR

In addition to the above recommendations, if you wish to open files created in Home Designer Version       2024 or prior, bear 
in mind the following:    
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 1.  Door Thickness
In Home Designer 2024 and prior, the Thickness value set in the Door Specification dialog affected parametric door 
panels in 3D views but not door symbols. In Version 2025, this setting affects both types of door panel in 3D. When a 
legacy file is opened in Version 2025, any symbol door panels will have the depth specified in the Door Specification 
dialog when viewed in a camera view rather than the depth of the symbol object. 

 2.  Material Emissivity
In Home Designer 2024 and prior, the Emissive property for materials could be set using decimal values. In Version 
2025, this setting supports whole numbers only. When a legacy file is opened in Version 2025, any decimal Emissive 
values will be rounded to the nearest whole number. If this setting is rounded to zero, the change may be noticeable in 
Standard, and Watercolor renderings. 

FOR FILES CREATED IN VERSION 2023 AND PRIOR

In addition to the above recommendations, if you wish to open files created in Home Designer Version       2023 or prior, bear 
in mind the following:    

 1.  Window Casing Reveal
In Home Designer 2023 and prior, window casing had an Overlap Frame setting that controlled where casing was placed 
relative to the window frame, and windows with different frame Width values for their top, bottom, and sides would also 
have different reveals. In Version 2024, this setting was replaced with a Reveal setting. When a legacy file is opened in 
Version 2025, any windows with different Width values will no longer have different reveals. 

 2.  Text Indent and Margins
In Home Designer 2023 and prior, the indent and margins of text could vary depending on the font used. In Version 
2024, indent and margins are not affected by settings in the font. When a legacy file is opened in Version 2025, text 
with varying indent and/or margins may be affected. 

FOR FILES CREATED IN VERSION 2022 AND PRIOR

In addition to the above recommendations, if you wish to open files created in Home Designer Version      2022 or prior, bear 
in mind the following:   

 1.  Stair Walklines
In Home Designer 2022 and prior, Walklines were drawn on the "Dimensions" layer. In Version 2023, they are drawn 
on the "Stairs & Ramps" layer. When a legacy file is opened in Version 2025, any Walklines displaying in the file may 
have different line color, weight, and style attributes. 

 2.  Door Rough Openings
In Home Designer 2022 and prior, if a door's Floor to Bottom height was not sufficient to accommodate its Bottom 
Rough Opening, the door's Top Rough Opening space would be increased in the model but not in the Door Specification 
dialog. In Version 2023, this no longer occurs: if the Floor to Bottom height is less than the Bottom Rough Opening, the 
full Bottom Rough Opening is simply not modeled when framing is generated. When a legacy file is opened in Version 
2025, its rough opening is modeled exactly as it was in the previous program version but its Top and Bottom Rough 
Opening values now reflect how the rough opening is modeled. 

FOR FILES CREATED IN VERSION 2021 AND PRIOR

In addition to the above recommendations, if you wish to open files created in Home Designer Version      2021 or prior, bear 
in mind the following:
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 1.  Default 110V Ceiling Outlet
In Home Designer 2021 and prior, the 110V Outlet tool did not have the ability to place outlets in ceilings. In Version 
2022, this ability was added, as was the new GFCI Outlet tool. When a legacy file is opened in Version 2025, the new 
Electrical Defaults settings for these items will automatically refer to objects in the Version 2025 Core Catalogs. You 
should confirm that these defaults meet your needs. If these default objects are not present in your library, a warning 
message will inform you of the issue. 

 2.  Automatic and Manual Dimension Layers
In Home Designer 2021 and prior, the system default layer for automatically generated dimension lines was 
"Dimensions, Automatic", and the system default for manually drawn dimensions was "Dimensions, Manual". In 
Version 2025, the system default layer for all dimensions is simply "Dimensions". When a legacy file is opened in 
Version 2025, automatic dimensions that were on the "Dimensions, Automatic" layer in the earlier version will be 
placed on the "Dimensions, Legacy" layer while any dimensions that were on the "Dimensions, Manual" layer in the 
previous version will be placed on the "Dimensions" layer. 

 3.  Gable Lines
In Home Designer 2021 and prior, Gable Lines with a Pitch value of 90° were allowed but did not affect automatic roof 
generation. In Version 2025, they are not supported. When a legacy file is opened in Version 2025, any Gable Lines 
with a Pitch of 90° will be removed automatically. This will not affect the current roof or automatic roof generation. 

FOR FILES CREATED IN VERSION 2020 AND PRIOR

In addition to the above recommendations, if you wish to open files created in Home Designer Version               2020 or prior, bear 
in mind the following: 

 1.  Perspective Crop Mode
In Home Designer 2017 through 2020, Perspective Crop Mode allowed older functionality governing zooming in 
cameras from Version 2016 and prior to be preserved in saved cameras in legacy plans migrated forward. This 
deprecated tool has been removed from the program’s menu and toolbars in Version 2021, although it can be migrated 
with legacy toolbars and hotkeys. Saved cameras in legacy plans with this behavior enabled may become distorted if you 
pan or zoom in the view. To permanently disable this behavior in a camera view and resolve the resulting distortion, 
select Window> Fill Window or press the F6 key. 

 2.  Units of Measurement
In Home Designer 2020 and prior, units of measurement used by the program, including user-defined units,  were stored 
in a file called Units.dat located in the Home Designer Data folder. Beginning in version 2021, this information is saved 
with other Preferences settings. 

FOR FILES CREATED IN VERSION              2019 AND PRIOR

In addition to the above recommendations, if you wish to open files created in Home Designer Version               2019 or prior, bear 
in mind the following:

 1.  Marker and Elevation Point Heights          
In Home Designer 2019 and prior, the # sign could be added to the label of a Marker or Elevation Point and the label 
would report the height of the Marker or the Elevation Point’s elevation. In Version 2025, text macros are used to report 
this information instead. In legacy plans, any # signs in Marker or Elevation Point labels will be replaced by the 
%heightf% or %elevationf% macro.  

 2.  Glass Shower Walls          
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In Home Designer 2019 and prior, the “Glass Shower” wall type was included in installed template files and like other 
wall types, built to the structural layer of floors and ceilings and to the Main Layer of adjacent walls. In Version 2025, 
this wall type has the new Partition Wall attribute and instead builds to floor, ceiling, and wall surfaces. When a legacy 
file is opened in Version 2025, this wall type will be modified to have Partition Wall checked automatically and existing 
walls will be affected by this change.  

FOR FILES CREATED IN VERSION 2018 AND PRIOR

In addition to the above recommendations, if you wish to open files created in Home Designer Version               2018 or prior, bear 
in mind the following:

 1.  Parallel Lights          
In Home Designer 2018 and prior, Parallel Light sources could be specified for electrical light fixtures and Added 
Lights. In Version 2025, Parallel Lights are no longer supported. In legacy plans opened in Version 2025, any Parallel 
Light sources will be converted to Spot Lights.  

 2.  Joist Direction Lines          
In Home Designer 2018 and prior, Joist Direction Lines described all platform framing as “joists” and used nominal 
lumber sizes in whole inches in US Unit plans. In Version 2025, the platform’s framing Structure Type is reported and 
in US Unit plans, the size is described in fractional inches. When a legacy file is opened in Version 2025, Joist Direction 
Lines will use the new, more accurate labeling.  

FOR FILES CREATED IN VERSION 2016 AND PRIOR

In addition to the above recommendations, if you wish to open files created in Home Designer Version               2016 or prior, bear 
in mind the following:

 1.  Boxed Eaves          
In Home Designer 2017, improvements to the generation of Boxed Eaves ensure that they extend into exterior rooms 
with “Use Soffit Surface for Ceiling” specified when located between the roof baseline and an interior room. In some 
legacy plans opened in Version 2025, the Length value for Boxed Eaves may need to be modified in the Roof Plane 
Specification dialog.  

 2.  Uppercase Text          
The Uppercase option was added to Text Styles in Version               2017, whereas in Version 2016 and prior, it was an option 
for Room Labels only. In legacy plans opened in Version 2017, Room Label Defaults will be assigned a Custom Text 
Style if any Room Labels are present in the drawing. The Room Labels will be assigned a Custom Text Style, as well. If 
a given Room Label has been sent to layout more than once and was set to use different Text Styles in each layout view, 
it is possible that its appearance may be affected in some views.  

FOR FILES CREATED IN VERSION               2015 AND PRIOR

In addition to the above recommendations, if you wish to open files created in Home Designer Version               2015 or prior, bear 
in mind the following:

 1.  Built-in Appliances          
In Home Designer 2015 and prior, some appliance symbols designed to be inserted into base cabinets had incorrect 
sizing data. In legacy plans opened in Version 2025, these appliances will not fit into the cabinet correctly and will need 
to be replaced. Built-in dishwashers are particularly affected. 

 2.  Formatting of Bulleted and Numbered Lists          
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In Version X7, various improvements were made to the way lines of Rich Text are spaced. In legacy plans opened in 
Version X7, Rich Text objects with bulleted and numbered lists may require adjustments. 

 3.  Chief Blueprint Font
The Chief Blueprint font was improved for Version X6, with decreased top and bottom spacing. The change in spacing 
may increase the overall height of text objects using this font in X6 files opened in Version 2025. X5 and prior legacy 
files will not be affected by this change. 

FOR FILES CREATED IN VERSION 2012 AND PRIOR

In addition to the above recommendations, if you wish to open files created in Home Designer Version 2012 or prior, bear 
in mind the following:

 1.  Roof Overhangs and Framing          
In Home Designer 2012 and prior, roof overhangs were measured to the outside of the subfascia, whereas in Version 
2014 and later, they are measured to the outside of the fascia. In legacy plans opened in Version 2025, this will not 
affect the appearance of roof planes in floor plan view because in 2012 and prior, roof plane polylines represented the 
projected framing area whereas in Version 2025 they represent the total projected area. But, the position of the fascia 
and subfascia will shift, as will the length of the rafters. 

 2.  Door Swing Direction and Materials          
In Home Designer X4 and prior, exterior doors that swing outward displayed the interior material on the exterior side of 
the door. This was corrected in Version 2025. Doors modified to work around the old behavior could be affected in 
legacy plans opened in Version 2025. 

 3.  Door Swing Direction and Louvers          
Improvements to door louver direction may affect louvers in all doors with the exception of bifold doors. 

 4.  Wrapped Door/Window Lintels and Window Sills         
In Home Designer 2012 and prior, wrapped lintels and sills extended out further than those that were not wrapped. In 
legacy plans opened in Version 2025, the extents of wrapped lintels and sills will be adjusted so that they equal their 
Extend setting. 

 5.  Invisible Beams          
The legacy Invisible Beam check box was removed from the Wall Specification dialog. When legacy plans are opened 
in Version 2025, any Invisible Beam walls will be converted to Invisible Walls. 

FOR FILES CREATED IN VERSION 10 AND PRIOR

In addition to the above recommendations, if you wish to open files created in Home Designer Version               10 or prior, bear in 
mind the following:

 1.  Text Styles          
The appearance of a number of objects that include text - including object labels, the North Pointer, Sun Angles, Joist 
Direction Lines, the Up/Down arrows for stairs and ramps - can now be controlled using Text Style. Their appearance 
may be altered somewhat in legacy plans opened in Home Designer 2025. 

 2.  Light Sources          
The illumination created by light fixtures and Added Lights was improved in Home Designer 2025. Lighting in legacy 
plans may appear noticeably brighter when viewed in version 2025. 
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FOR FILES CREATED IN VERSION 9 AND PRIOR

If you wish to open files created in Home Designer Version               9 or prior, bear in mind the following file management changes 
and structural enhancements:

 1.  Legacy file formats          
Home Designer7              files were saved in  .pl and .la the file formats. These file formats files are no longer supported and 
cannot be opened in version 2025. 

 2.  Material textures, images, and backdrops          
Home Designer9              and prior installed with a catalog of library content, including a selection of material textures, images, 
and backdrops. This library catalog is no longer installed with the program because it is now available for download on-
demand, so it will be possible to open a legacy plan in version 2025 and encounter numerous missing file warnings. To 
avoid this, we recommend using the Export Entire Plan feature in the original program version to create a folder that 
includes the plan and all associated textures, images, and backdrops before opening this file in 2025. This tool is 
renamed Backup Entire Plan in version 2025. 

 3.  Floor and ceiling finish thicknesses          
In Home Designer 9 and prior, floor and ceiling finish layers were not modeled in 3D, and objects such as railings, 
stairs, landings, cabinets, fixtures, and furnishings measured their Floor to Bottom height from the subfloor. These 
objects now measure their Floor to Bottom height from the floor finish surface, so it is possible that you may notice 
height changes for these objects - particularly in saved, annotated cross section/elevation views. 

 4.  Riser heights and landing thicknesses          
The default Best Fit Riser Height for stairs that do not reach the next level has been updated from 9” (225 mm) in 
version               9 and prior to 6 3/4” (169 mm) in Home Designer 2025. This may affect the riser heights of stairs, as well as the 
thicknesses of landings attached to those stairs. 

 5.  Auto Adjust Height          
The Follow Terrain option in some specification dialogs was replaced by the Auto Adjust Height check box. If a cabinet, 
fireplace, fixture, furniture, or other library symbol had Follow Terrain unchecked in version               9 or prior and was located 
in a room with a floor height other than the default for the current floor, then the object’s Floor to Bottom Height will 
change to equal that room’s floor height. The object’s position in the model will not change, however. 

 6.  Adjustable Thickness Walls          
In Home Designer 9 and prior, generic, single-layer wall types were available for use. When a legacy plan file is opened 
in version 2025 and these wall types are detected, they are replaced by an updated, non-generic wall type. Framed walls 
and Railings will also acquire 1/2” (13 mm) thick layers of sheetrock on each side. Railings that define a Deck room 
with Advanced Deck Framing Built will not acquire sheetrock layers. 

 7.  Stairwells defined by railings          
Interior railings that used a generic, single-layer wall type drawn in older program versions will acquire layers of 
sheetrock when the plan is opened in version 2025. This can affect the appearance of staircases where they join to a 
floor platform. To address this issue, select the railing and move it 1/2” (13 mm) away from the top edge of the 
staircase. 

 8.  Deck rooms          
In legacy plans opened in Home Designer 2025, Deck rooms with Advanced Deck Framing built retain the framing but 
have Automatic Deck Framing turned off by default. Decks with no Advanced Deck Framing built are converted to 
Balcony rooms. 

 9.  Structural Member Reporting          
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When a plan created in Home Designer9 or prior is opened in Home Designer2025, Materials Lists are set to calculate 
Total Linear Length. For a combination of linear length and piece count, select Mixed Reporting in the Structural 
Member Reporting dialog. 

 10.  Fill New Framing Members          
In Home Designer 9 and prior, Fill New Framing Members was view-specific; in Home Designer 2025 it applies to the 
entire plan. As a result, it is turned off by default in legacy plans opened in version 2025. 

 

 New and Improved Features by Chapter
The following is a list of new and improved features in Pro Version 2025. Where possible, cross-references to additional 
information are provided. 

PROGRAM OVERVIEW

 l New Tool Search  can be added to the toolbars and used to access any tool.

FILE MANAGEMENT

 l New Clear File Reference option for materials in the Missing Files dialog.
 l New Manage Auto Archives options in the Preferences dialog.

PROJECT PLANNING

 l Space Planning Room Boxes can now be drawn by clicking and dragging and can be edited to any shape.
 l New Remove Overlapped Areas  and Overlap Adjacent Room Box  edit tools for Space Planning Room 

Boxes.
 l Space Planning Room Boxes now display lines representing wall width.

PREFERENCES AND DEFAULT SETTINGS

 l New Blurred Backdrop Effect Preferences option for material previews.
 l The Minimum Display Size for Dimensions now only affects Temporary Dimensions.
 l The obsolete Optimize for Multi-Core CPUs troubleshooting setting has been removed from the Preferences dialog.
 l The obsolete Hardware Edge Smoothing setting has been removed from the Preferences dialog. High quality anti-

aliasing is always used. 

TOOLBARS AND HOTKEYS

 l Toolbars can now be added for when No View is open.

CREATING OBJECTS

 l The frame, casing, and sill of doors and windows can now be snapped to.
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DISPLAYING OBJECTS

 l A variety of edit tools including Make Parallel/Perpendicular and Reflect About Object can now use angled editing 
axes defined the corners where object edges meet.

 l Fill styles from the Library now have separate X and Y Scale settings. 

EDITING OBJECTS

 l New Action History side window lets you access all recent Undo actions. 
 l The Convert Polyline dialog now features a scrollable list. 
 l New Retain Original Polyline option in the Convert Polyline dialog. 
 l Plain Polyline is now an option in the Convert Polyline dialog. 
 l The obsolete Convert to Plain Polyline edit tool has been removed.
 l Terrain Walls and Terrain Curbs are now options in the Convert Polyline dialog. 
 l New Concentric Resize  and Set Concentric Jump  edit buttons.

 l Exterior Sprinklers are now deleted with Terrain Objects using the Delete Objects dialog.

CAD OBJECTS

 l New Hide Selected Edge  and Hide Selected Edge edit tools for CAD polylines. 

WALLS, RAILINGS, AND FENCING

 l New Spacing options for railing newels: "Automatic", "From Start", "From End", "Centered".
 l Offset double newel posts at exterior railing corners can now be created.
 l Chamfered footings for foundation stem walls can now be specified.
 l The defaults for multiple wall tools can now be edited as a group via the Default Settings dialog.

ROOMS

 l New Deck Beam Count, Position, and Offset from Deck Edge settings.
 l New Deck Post Alignment with Deck Beams settings.
 l New Room Information in the Room Specification dialog reports size information about the selected room(s).

DIMENSIONS

 l New Delete Dimensions  tool lets you delete all dimensions in the current view.

 l If you double-click any of the Dimension Tools child buttons to open the Dimension Defaults dialog, the LOCATE 
panel associated with that tool will be active.

 l The maximum Line Separation value in the Dimension Defaults dialog has been increased to 500" (12500 mm).
 l Auto Story Pole Dimensions now allow multiple marks at the same location in the model.

TEXT, CALLOUTS, AND MARKERS

 l New Pointed capsule Callout and Note shape.
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DOORS AND WINDOWS

 l All Door Types can now be placed in railings and fencing.
 l A Sill or Threshold for both doors and windows can now be specified.
 l Doors can now have separate materials assigned to the threshold and interior/exterior jamb.
 l Windows can now have separate materials assigned to the threshold and interior/exterior frame.
 l The Panel Offset for all Door Types can now be set in the Door Specification dialog.
 l The default Window Level is now 0 and can no longer be modified.

CABINETS

 l The Thickness of cabinet door and drawer fronts can now be specified.
 l New Diagonal and L-Shaped Corner Type options for Shelves and Partitions.
 l The Panel Thickness setting now affects panel symbols from the Library as well as parametric panels.

ELECTRICAL

 l New Electrical Connection Defaults dialog.
 l Electrical Connection Splines can now attach to cabinets and non-Electrical symbol objects.
 l Electrical Connection Splines are no longer required to attach to objects and can snap to points on objects that they are 

not attached to.
 l New Reset Curvature  edit tool for Electrical Connection splines.

SCHEDULES AND OBJECT LABELS

 l New Columns/Rows panel in the Schedule Specification dialog.
 l Schedules can now be added to the library.
 l New Pointed capsule schedule callout shape.
 l New Calculate Total option produces a calculation in the Totals row for selected columns.
 l New Sum Similar Rows option groups similar objects in a single row and reports the total count, length, area, or 

volume for all objects associated with that row.
 l The new Calculate Total option for columns in the Schedule Specification dialog.
 l The obsolete Total Length column in schedules has been removed.
 l Schedule text now can be aligned Vertically within rows as well as horizontally within columns.
 l The Move Up in Schedule and Move Down in Schedule edit tools are now available when Use Label is the selected 

schedule label option.

STAIRS, RAMPS, AND LANDINGS

 l New Multiple Stairs and Ramps shared specification and defaults dialogs.

ROOFS

 l New Include Ridge framing option in the Dormer Specification dialog.
 l The Ridge Depth of dormer ridge and hip rafters can now be specified in the Dormer Specification dialog.
 l When a roof plane's Baseline is selected in plan view, the entire roof plane is now highlighted.
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FRAMING AND TRUSSES

 l New Build All Framing  tool.

 l All build framing commands are organized in a new, streamlined Build Framing dialog.
 l Floor and Ceiling Framing can now be generated separately.
 l Automatically-generated End Trusses can now include horizontal blocking.
 l New Flat Header Framing Method in the Door and Window Specification dialogs.
 l New Build Framing for Parent Object(s)  edit tool allows  you to build or rebuild the framing for the parent 

object of a selected framing member.
 l Blocking can now be added to trusses.

THE LIBRARY

 l The Convert Legacy (.alb) Library Files tool has been retired.
 l The Adjust Lights dialog is now accessible for a selected light fixture in the User Catalog using the contextual menu.
 l The Move to Folder(s) dialog has been renamed Add Link. 

SYMBOL OBJECTS

 l The FILL STYLE panel is now available for nearly all types of symbol objects.
 l Under-cabinet fixtures can now be placed above a free-standing fixture without selecting it.

OTHER OBJECTS

 l New Diagonal and L-Shaped Corner Type options for Soffits.

MATERIALS

 l The Preview pane in the Library Browser and the Define Material, Select Material and Plan Material dialogs can now 
show a backdrop image instead of the default room.

 l Stretch to Fit can now be applied to material texture height and width independently.

3D VIEWS

 l New Reset Saved Camera (All)  and Reset Saved Camera (Position)  tools.

 l The Cross Section Slider tool is now available in Vector Views.
 l Changes to the settings in the Camera and Cross Section/Elevation Specification dialogs made while the camera view 

is active are not permanent unless you explicitly save the view.
 l The obsolete Edge Smoothing When Idle setting for 3D views has been removed from the program.

3D RENDERING

 l New AMD FidelityFX options in the Camera Specification dialogs.
 l The Base Rendering Technique used to render a scene prior to applying Watercolor Effects can now be specified.
 l New Rotate Spherical Backdrop  option in camera views with Spherical Panoramic Backdrops.
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 l New Tone Mapping Operator setting for Physically Based renderings.
 l The columns in the Adjust Lights dialog are now customizable.

PICTURES, IMAGES, AND WALKTHROUGHS

 l Physically Based renderings can now be exported as High Dynamic Range .hdr files.
 l Perspective High Dynamic Range images can now be used as backdrops, and the .hdr file type is now available in the 

Import Backdrop File dialog.
 l New Open in Default Image Viewer option for exported pictures.

IMPORTING AND EXPORTING

 l New Remember Login option in the Chief Architect Account Login dialog.
 l The Export 360 Panorama dialog now has an option to Save as Backdrop.

PLANTS AND SPRINKLERS

 l Separate fill styles can be assigned to a sprinkler's Spray Area and Sprinkler Symbol in plan view.

LAYOUT

 l Improved feedback helps identify and fix broken layout links.
 l The Referenced Plan Files  tool is now present in the layout toolbars.

 l The Update View to Layout message, which lets you choose whether you want to update the Plot Lines view on the 
layout page or not when you close the camera view, has been restored to the program.
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