Reference Manual

A description of the software interface, including drawing tools and settings.
Contents

Chapter 1: Program Overview

Startup Options .................................................................................................................. 23
The Home Designer Pro Environment ............................................................................. 25
Using Input Devices............................................................................................................ 26
View and Side Windows..................................................................................................... 28
Toolbars and Hotkeys ........................................................................................................ 29
Menus................................................................................................................................... 29
Dialogs .................................................................................................................................. 30
The Status Bar .................................................................................................................... 33
Message Boxes..................................................................................................................... 33
Preferences and Default Settings ...................................................................................... 34
Drawing a Plan .................................................................................................................... 34
Viewing Your Plan ............................................................................................................. 35
Getting Help........................................................................................................................ 36
About Home Designer ........................................................................................................ 37
Product Upgrade Options.................................................................................................. 37
Home Designer Trial Software .......................................................................................... 37

Chapter 2: File Management

Compatibility with Other Programs................................................................................. 39
Organizing Your Files........................................................................................................ 40
Home Designer Pro Data ................................................................................................... 40
Creating a New Plan or Layout.......................................................................................... 41
Saving, Exporting, and Backing Up Files ......................................................................... 43
Thumbnail Images .............................................................................................................. 45
Auto Archive ...................................................................................................................... 45
Undo Files............................................................................................................................ 46
Opening and Importing Files ............................................................................................ 47
Referenced Files.................................................................................................................. 48
Backup Entire Plan or Project ............................................................................................ 49
Exiting Home Designer Pro ............................................................................................... 49
Chapter 3: Project Management

Space Planning

Room Box Specification Dialog

Finding Objects

Plan Check

Loan Calculator

Chapter 4: Preferences and Default Settings

Default Settings vs Preferences

Dynamic Defaults

Reset to Defaults

General Plan Defaults Dialog

Preferences Dialog

Dialog Number/Angle Style Dialog

Chapter 5: Toolbars and Hotkeys

Toolbar Arrangement

Customizing Toolbars

Creating Custom Toolbar Configurations

Toolbar Customization Dialog

Hotkeys

Gamepad Settings Dialog

Chapter 6: Window and View Tools

View Windows

Working in Multiple Views

View Tools

Zoom Tools

Undo Zoom

Fill Window

Panning the Display

Closing Views and Files

Chapter 7: Creating Objects

Architectural vs CAD Objects

Defaults and Preferences
Chapter 10: CAD Objects

<table>
<thead>
<tr>
<th>CAD Defaults and Preferences</th>
<th>161</th>
</tr>
</thead>
<tbody>
<tr>
<td>The CAD Drawing Tools</td>
<td>162</td>
</tr>
<tr>
<td>Point Tools</td>
<td>163</td>
</tr>
<tr>
<td>Line Tools</td>
<td>166</td>
</tr>
<tr>
<td>Line Specification Dialog</td>
<td>168</td>
</tr>
<tr>
<td>Drawing Arcs - Arc Creation Modes</td>
<td>171</td>
</tr>
<tr>
<td>Arc Tools</td>
<td>172</td>
</tr>
<tr>
<td>Arc Specification Dialog</td>
<td>174</td>
</tr>
<tr>
<td>Circle Tools</td>
<td>175</td>
</tr>
<tr>
<td>Circle/Oval/Ellipse Specification Dialog</td>
<td>176</td>
</tr>
<tr>
<td>Polylines</td>
<td>176</td>
</tr>
<tr>
<td>Polyline Specification Dialog</td>
<td>177</td>
</tr>
<tr>
<td>Box Tools</td>
<td>178</td>
</tr>
<tr>
<td>Box Specification Dialog</td>
<td>179</td>
</tr>
<tr>
<td>Splines</td>
<td>180</td>
</tr>
<tr>
<td>Displaying CAD Objects</td>
<td>181</td>
</tr>
</tbody>
</table>

Chapter 11: Walls, Railings, and Fencing

<table>
<thead>
<tr>
<th>Wall, Railing, and Fencing Defaults</th>
<th>184</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wall Tools</td>
<td>186</td>
</tr>
<tr>
<td>Railing and Deck Tools</td>
<td>187</td>
</tr>
<tr>
<td>Fencing Tools</td>
<td>189</td>
</tr>
<tr>
<td>Exterior and Interior Walls</td>
<td>189</td>
</tr>
<tr>
<td>Foundation Walls</td>
<td>189</td>
</tr>
<tr>
<td>Pony Walls</td>
<td>190</td>
</tr>
<tr>
<td>Room Dividers and Invisible Walls</td>
<td>191</td>
</tr>
<tr>
<td>Polygon Shaped Decks</td>
<td>192</td>
</tr>
<tr>
<td>Hatch Wall</td>
<td>193</td>
</tr>
<tr>
<td>Creating Walls</td>
<td>193</td>
</tr>
<tr>
<td>Connecting Walls</td>
<td>195</td>
</tr>
<tr>
<td>Displaying Walls</td>
<td>196</td>
</tr>
</tbody>
</table>
# Measuring Walls

- Measuring Walls

# Editing Walls

- Editing Walls

# Edit Handles for Walls

- Edit Handles for Walls

# Editing Straight/Curved Wall Combinations

- Editing Straight/Curved Wall Combinations

# Aligning Walls

- Aligning Walls

# Roof Directives in Walls

- Roof Directives in Walls

# Attic Walls

- Attic Walls

# Stepped and Raked Walls

- Stepped and Raked Walls

# Wall Type Definitions

- Wall Type Definitions

# Wall Type Definitions Dialog

- Wall Type Definitions Dialog

# Wall Specification Dialog

- Wall Specification Dialog

# Railing and Fencing Specification Dialogs

- Railing and Fencing Specification Dialogs

# Wall Hatch Specification Dialog

- Wall Hatch Specification Dialog

---

## Chapter 12: Rooms

- Room Definition
- Floor and Room Defaults
- Room Types
- Displaying Rooms
- Selecting Rooms
- Editing Rooms
- Room Labels
- Room Label Specification Dialog
- Decks
- Floor and Ceiling Heights
- Floor and Ceiling Platforms
- Special Ceilings
- Room Moldings
- Room Specification Dialog

## Chapter 13: Dimensions

- Compatibility With Previous Versions
- Dimension Preferences and Defaults
- Dimension Defaults Dialog
- Auto Dimension Defaults Dialogs
- The Dimension Tools
- Displaying Dimension Lines
- Selecting Dimension Lines
- Editing Dimension Lines
Chapter 14: Text, Callouts, and Markers

Text Defaults and Preferences ................................................................. 267
Fonts and Alphabets ................................................................................ 268
The Text Tools ........................................................................................ 269
Creating Text, Callouts and Markers ..................................................... 269
Displaying Text, Arrows, Callouts and Markers .................................... 270
Rich Text Specification Dialog ............................................................. 270
Editing Text ............................................................................................. 274
Copying and Pasting Text ...................................................................... 276
Find/Replace Text ................................................................................... 277
Text Arrows ............................................................................................. 278
Callouts ................................................................................................... 279
Callout Specification Dialog ................................................................. 279
Editing Callouts ...................................................................................... 281
Markers .................................................................................................. 282
Marker Specification Dialog ................................................................. 282
Editing Markers ...................................................................................... 283
Text Styles ............................................................................................... 283
Object Labels .......................................................................................... 285

Chapter 15: Doors

Door Defaults .......................................................................................... 287
Door Tools ............................................................................................... 288
Displaying Doors ..................................................................................... 290
Editing Doors .......................................................................................... 291
Changing Door Swings ........................................................................... 293
Special Doors ......................................................................................... 294
Door Specification Dialog ....................................................................... 296

Chapter 16: Windows

Window Defaults .................................................................................... 307
Window Tools ........................................................................................ 308
Special Windows .................................................................................... 309
Grouped Windows .................................................................................. 310
Chapter 19: Foundations

Foundation Defaults ......................................................................................................... 373
Building a Foundation .................................................................................................... 376
Displaying Foundations ................................................................................................. 377
Editing Foundations ........................................................................................................ 378
Aligning Foundation Walls ............................................................................................ 379
Deleting Foundations ..................................................................................................... 380
Foundations and Rooms ................................................................................................. 380
Foundations and the Terrain ......................................................................................... 381
The Slab Tools ................................................................................................................... 382
Editing Slabs ..................................................................................................................... 382
Slab Specification Dialog ............................................................................................... 383
Editing Piers and Pads .................................................................................................... 384
Library Fireplaces ............................................................................................................ 384
Chimneys .......................................................................................................................... 385

Chapter 20: Multiple Floors

Floor Defaults Dialog .................................................................................................... 387
Floor Tools ......................................................................................................................... 388
Adding Floors ................................................................................................................... 388
Displaying Floors ............................................................................................................. 389
Exchanging Floors .......................................................................................................... 390
Copying Floors ................................................................................................................ 390
Deleting Floors ................................................................................................................ 391
Rebuilding Walls, Floors and Ceilings ........................................................................... 391
Split Levels ....................................................................................................................... 391
The Current Floor ............................................................................................................ 392
The Attic Floor ................................................................................................................ 393
The Reference Floor ....................................................................................................... 393

Chapter 21: Stairs, Ramps, and Landings

Stair and Ramp Defaults ................................................................................................ 395
The Stair Tools ................................................................................................................ 396
Anatomy of a Staircase ..................................................................................................... 396
Drawing Stairs and Ramps .............................................................................................. 397
L- and U-Shaped Stairs ................................................................................................. 399
Displaying Stairs, Ramps, and Landings ....................................................................... 399
Editing Stairs and Ramps .............................................................................................. 400
Chapter 22: Roofs

Automatic vs. Manual Roofs ................................................................. 427
Roof Defaults ..................................................................................... 428
The Roof Tools .................................................................................. 429
Automatic Roofs .............................................................................. 430
Build Roof Dialog ........................................................................... 431
Roof Planes ....................................................................................... 436
Displaying Roofs ............................................................................. 438
Editing Roof and Ceiling Planes ...................................................... 439
Roof Plane Specification Dialog ...................................................... 443
Roof Baseline Polylines ................................................................. 445
Roof Baseline Specification Dialog ................................................. 446
Roof and Ceiling Framing ............................................................. 447
Ceiling Planes ............................................................................... 448
Ceiling Plane Specification Dialog ................................................. 449
Gable/Roof Lines ................................................................. 451
Gable Line Specification Dialog .................................................. 453
Skylights and Roof Holes .......................................................... 453
Roof Hole/Skylight Specification Dialog ..................................... 454
Dormers and Crickets ................................................................. 455
Editing Auto Dormers ................................................................. 457
Dormer Specification Dialog ..................................................... 458
Roof Returns and Other Details ................................................ 460
Chapter 23: Framing

Framing Defaults.............................................................................................................. 463
Manual vs. Automatic Framing ...................................................................................... 465
The Framing Tools ........................................................................................................... 467
Build Framing Dialog....................................................................................................... 469
Framing Reference Markers ........................................................................................... 479
Joist Direction Lines......................................................................................................... 481
Joist Direction Specification Dialog................................................................................ 481
Bearing Lines .................................................................................................................... 482
Displaying Framing.......................................................................................................... 482
Editing Framing................................................................................................................ 484
Keeping Framing Current............................................................................................... 485
Framing and the Materials List...................................................................................... 485
Framing Specification Dialog.......................................................................................... 486

Chapter 24: Trusses

Truss Defaults ................................................................................................................... 489
Floor and Ceiling Trusses ............................................................................................ 490
Roof Trusses.................................................................................................................... 490
Drawing Trusses............................................................................................................... 491
Displaying Trusses............................................................................................................ 491
Editing Trusses ................................................................................................................. 491
Editing Truss Envelopes ................................................................................................. 493
Truss Labels...................................................................................................................... 493
Mixing Trusses with Stick Framing ................................................................................ 493
Hip Trusses........................................................................................................................ 494
Special Roof Trusses....................................................................................................... 495
Roof Truss Specification Dialog...................................................................................... 497
Floor/Ceiling Truss Specification Dialog........................................................................ 499

Chapter 25: Trim and Moldings

Trim and Molding Defaults............................................................................................ 501
Corner Boards .................................................................................................................. 501
Corner Board Specification Dialog................................................................................ 502
Quoins............................................................................................................................... 503
Quoin Specification Dialog ............................................................................................ 503
Editing Corner Boards and Quoins ................................................................................. 505
Millwork ............................................................................................................................ 505
Chapter 30: 3D Views

OpenGL and Hardware ................................................................. 557
Types of 3D Views ........................................................................ 557
Defaults and 3D Preferences ......................................................... 558
Camera Defaults Dialogs .............................................................. 558
3D View Defaults Dialog .............................................................. 560
3D View Tools .............................................................................. 561
Creating Camera Views ................................................................. 562
Creating Overviews ...................................................................... 563
Cross Section/Elevation Views ...................................................... 564
Displaying 3D Views .................................................................... 565
Repositioning Cameras ................................................................. 567
Editing 3D Views ......................................................................... 571
Cross Section Slider ..................................................................... 572
Working in 3D ............................................................................. 573
Saving and Printing 3D Views ...................................................... 574
Camera Specification Dialog ....................................................... 575
Cross Section/Elevation Camera Specification Dialog .................. 579

Chapter 31: 3D Rendering

Rendering Tips ........................................................................... 583
Lighting ..................................................................................... 585
Light Types ............................................................................... 586
Displaying Lights ....................................................................... 587
Lighting Modes .......................................................................... 587
Light Specification Dialog ......................................................... 589
Sun Angles and Shadows ............................................................. 590
### Chapter 32: Pictures, Images, and Walkthroughs

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Picture Files vs Pictures and Image Objects</td>
<td>602</td>
</tr>
<tr>
<td>Images</td>
<td>602</td>
</tr>
<tr>
<td>Displaying Images</td>
<td>603</td>
</tr>
<tr>
<td>Editing Images</td>
<td>603</td>
</tr>
<tr>
<td>Image Specification Dialog</td>
<td>604</td>
</tr>
<tr>
<td>Pictures</td>
<td>606</td>
</tr>
<tr>
<td>Picture File Box Specification Dialog</td>
<td>607</td>
</tr>
<tr>
<td>Metafiles</td>
<td>608</td>
</tr>
<tr>
<td>Metafile Box Specification Dialog</td>
<td>609</td>
</tr>
<tr>
<td>PDF Files</td>
<td>610</td>
</tr>
<tr>
<td>PDF Box Specification Dialog</td>
<td>611</td>
</tr>
<tr>
<td>Displaying Pictures, Metafiles, and PDF Boxes</td>
<td>612</td>
</tr>
<tr>
<td>Editing Pictures, Metafiles, and PDF Boxes</td>
<td>613</td>
</tr>
<tr>
<td>3D Backdrops</td>
<td>614</td>
</tr>
<tr>
<td>Backdrop Specification Dialog</td>
<td>615</td>
</tr>
<tr>
<td>Walkthrough Paths</td>
<td>616</td>
</tr>
<tr>
<td>Recording a Walkthrough</td>
<td>618</td>
</tr>
<tr>
<td>Walkthrough Path Specification Dialog</td>
<td>620</td>
</tr>
</tbody>
</table>

### Chapter 33: Importing and Exporting

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chief Architect Account Login</td>
<td>623</td>
</tr>
<tr>
<td>Export Chief Architect 3D Viewer File</td>
<td>624</td>
</tr>
<tr>
<td>Import Room Planner File</td>
<td>625</td>
</tr>
<tr>
<td>DXF vs DWG File Formats</td>
<td>625</td>
</tr>
<tr>
<td>Importing 2D Drawings</td>
<td>625</td>
</tr>
<tr>
<td>Import Drawing Assistant</td>
<td>626</td>
</tr>
<tr>
<td>Exporting 2D DXF/DWG Files</td>
<td>629</td>
</tr>
<tr>
<td>Additional 2D Export Information</td>
<td>631</td>
</tr>
<tr>
<td>3D Data Import Requirements</td>
<td>632</td>
</tr>
<tr>
<td>Importing 3D Symbols</td>
<td>632</td>
</tr>
<tr>
<td>Symbol Specification Dialog</td>
<td>633</td>
</tr>
<tr>
<td>3D Symbols and Materials</td>
<td>634</td>
</tr>
<tr>
<td>Exporting a 3D Model</td>
<td>635</td>
</tr>
</tbody>
</table>
Chapter 34: Terrain

Terrain Toolbar Configuration ............................................................... 637
Terrain Perimeter .................................................................................. 638
Elevation Data Tools .............................................................................. 639
Terrain Modifier Tools ........................................................................... 643
Terrain Feature Tools ............................................................................ 643
Garden Bed Tools .................................................................................. 644
Water Feature Tools ............................................................................ 645
Stepping Stone Tools ............................................................................ 645
Terrain Wall and Curb Tools ................................................................. 645
Sun Shadows ......................................................................................... 646
Terrain Objects in the Library ............................................................... 646
Displaying Terrain ................................................................................. 646
Editing Terrain Objects ......................................................................... 647
Terrain Specification Dialog ................................................................. 648
Elevation Point Specification Dialog .................................................... 651
Elevation Line/Region Specification Dialog ......................................... 652
Flat Region Specification Dialog .......................................................... 653
Hill / Valley Specification Dialog .......................................................... 653
Raised / Lowered Region Specification Dialog ..................................... 654
Terrain Feature Specification Dialog .................................................... 654
Garden Bed Specification Dialog .......................................................... 657
Terrain Break Specification Dialog ....................................................... 657
Terrain Path Specification Dialog ........................................................ 658
Importing Elevation Data ...................................................................... 659
Import Terrain Assistant ........................................................................ 660
Import GPS Data Assistant .................................................................... 661
Importing DWG/DXF Elevation Data ..................................................... 663
Converting CAD Objects to Terrain Data ............................................. 663

Chapter 35: Roads, Driveways and Sidewalks

Road, Driveway and Sidewalk Tools ....................................................... 665
Displaying Road Objects ....................................................................... 666
Editing Road Objects ............................................................................ 666
Road Specification Dialog .................................................................... 667
Chapter 36: Plants and Sprinklers

Plant Tools ......................................................................................................................... 669
Plant Chooser Dialog ........................................................................................................ 670
Hardiness Zones ................................................................................................................ 672
Plant Image Specification Dialog .................................................................................... 672
Sprinkler Tools ................................................................................................................. 675
Sprinkler Specification Dialogs ....................................................................................... 675
Plant Schedules ................................................................................................................. 675
Schedule Columns and Numbering ................................................................................ 676
Plant Schedule Specification Dialog ................................................................................ 677

Chapter 37: Materials Lists

The Materials List Tools ................................................................................................. 681
Creating an Accurate Materials List .............................................................................. 682
Structural Member Reporting ........................................................................................ 683
Organizing Materials Lists .............................................................................................. 684
Materials List Specification Dialog ................................................................................. 685
Editing Materials Lists ..................................................................................................... 687
Saving and Managing Materials Lists ............................................................................ 688
Printing and Exporting the Materials List ...................................................................... 688
Conditioned Area Totals .................................................................................................. 689
The Master List ................................................................................................................. 690
Object Components .......................................................................................................... 692
Object Information Panel ................................................................................................. 693

Chapter 38: Layout

Layout Preferences and Defaults .................................................................................... 695
The Layout Tools .............................................................................................................. 696
Creating a Layout File ...................................................................................................... 696
CAD and Text in Layout ................................................................................................. 696
Pictures and Metafiles in Layout .................................................................................... 697
Sending Views to Layout ................................................................................................. 697
Keeping Layout Views Current ....................................................................................... 699
Displaying Layout Views ............................................................................................... 701
Editing Layout Views ....................................................................................................... 701
Layout Box Specification Dialog ................................................................................... 702
Opening Layout Views ..................................................................................................... 703
Managing Layout Links ................................................................................................. 704
Chapter 39: Printing and Plotting

Introduction to Printing ........................................... 707
Printers and Plotters ................................................. 708
Printing Defaults ...................................................... 708
The Printing Tools ..................................................... 709
Drawing Sheet Setup Dialog ........................................ 710
Print Preview ........................................................... 713
Printing to Scale ....................................................... 714
Printing Across Multiple Pages ................................... 715
Printing to a PDF File ................................................. 715
Line Weights ............................................................ 716
Watermarks .............................................................. 717
Print View Dialog .................................................... 719
Print Image Dialog .................................................... 721

Appendix AN: What’s New in Home Designer Pro 2021

Getting Started Checklist ........................................... 723
Considerations for Migrating Legacy Content ..................... 724
Considerations for Migrating Legacy Settings ....................... 725
Considerations for Legacy Files ..................................... 725
New and Improved Features by Chapter .............................. 729

Appendix A: Resources and Support

Learning and Inspiration ............................................. 733
Contacting Technical Support ....................................... 734
Error Messages ......................................................... 735
Program Paths Dialog ............................................... 736
Home Designer Pro is specifically designed for the residential and light commercial design professional. It allows you to easily and efficiently produce 3D models and construction documents for your projects. We thank you for choosing Home Designer Pro and wish you the best in your design work.

Chapter Contents

- Startup Options
- The Home Designer Pro Environment
- Using Input Devices
- View and Side Windows
- Toolbars and Hotkeys
- Menus
- Dialogs
- The Status Bar
- Message Boxes
- Preferences and Default Settings
- Drawing a Plan
- Viewing Your Plan
- Getting Help
- About Home Designer
- Home Designer Trial Software

Startup Options

When Home Designer Pro opens, the **Startup Options** dialog displays, allowing you to choose how you want to begin working in the program or access useful resources.

The **Startup Options** dialog can be opened at any time by selecting **File> Startup Options**.
Select a **File** command to open a .plan or .layout file.

- Click **New Plan** or **New Layout** to open a new, blank file. See “Creating a New Plan or Layout” on page 41.

- Choose **Open Plan** or **Open Layout** to work on an existing plan or layout file. See “Opening and Importing Files” on page 47.

**Recent Files** lists the full pathnames of the most recently opened files. Click on a name to open the file.

A selection of useful online **Getting Started** options and **Resources** are available here. Click on an option to launch your default internet browser to HomeDesignerSoftware.com.

- Click **Getting Started** to visit the Getting Started page on our web site with links to a variety of resources to help you begin using the program.

- Click **Training Videos** to access a searchable collection of videos focused on specific topics.

- Click **Download Catalogs** to visit our 3D Library of downloadable bonus and manufacturer library catalogs. See “Library Content” on page 514.

When an internet connection is available, the **Announcements** section displays updated messages and news from Chief Architect.

**My Account** to launch your default internet browser to the Log In page on our web site.

Your software version’s **Build** number and the first five characters of your **Product Key** display here for reference.

To prevent the **Startup Options** dialog from displaying when you launch Home Designer Pro, uncheck **Show Options on Startup** in the **Preferences** dialog. See “General Panel” on page 67.
The Home Designer Pro Environment

Home Designer Pro is designed to be intuitive and efficient.

3D Drafting

In Home Designer Pro, the drawing area is laid out on a Cartesian grid, a three dimensional coordinate system described using the X, Y, and Z axes. The current position of your mouse pointer displays in the Status Bar at the bottom of the program window.

Architectural objects take up space in all three dimensions and their height, width and depth can be specified in Imperial or metric units. In addition, the location of objects can be precisely defined using coordinates, again specified in Imperial or metric units.

CAD objects such as lines and arcs take up space in two dimensions in the current view. Their dimensions can also be specified in Imperial or metric units and their locations precisely defined using coordinates.

Objects can be rotated relative to the Cartesian grid system, as well. When the program presents the option to rotate to an Absolute Angle, this angle will be measured relative to an imaginary horizontal line drawn in floor plan view from the origin in the positive X direction.

Easy Access to Tools

You can access Home Designer Pro’s features in various ways using the mouse and keyboard.

- Convenient toolbar buttons allow fast access to frequently-used tools and let you customize the interface.
- Menus provide access to most tools and settings.
- Keyboard shortcuts are available for most tools.
- Contextual menus display with a right-click of the mouse.
- The Status Bar at the bottom of the screen provides tool descriptions and other information about the current task.

Object-Based Design

Home Designer Pro’s parametric, object-based design technology means you place and edit objects, rather than work with the many individual lines or surfaces used to represent them.

You can quickly select and edit the location, size, shape, style and other properties of objects as well as change the materials applied to their surfaces.

Use Home Designer Pro’s editing capabilities to make the objects you place in a plan match the objects they represent in real life. For example, you can set up your windows and doors to match those available from your supplier.
Interface Toggles

A number of useful drawing and editing behaviors, as well as the display of important elements in the interface, can be easily enabled and disabled using the menus and toolbars. For example:

- Object Snaps, Angle Snaps, and Grid Snaps can be toggled on or off as needed. Individual Object Snaps and Extension Snaps can be toggled as well. See “Snap Behaviors” on page 100.
- Display Elements like Print Preview, Show Line Weights, and the Reference Display can be turned on when needed and then toggled off.
- Special Edit Behaviors can be enabled for particular tasks, then replaced by the Default Behavior.

Many of these interface elements are global Preferences while others are file-specific default settings. See “Default Settings vs Preferences” on page 57.

Using Input Devices

You can interact with Home Designer Pro using a variety of input devices.

Keyboard

A keyboard is necessary for entering text and size values. See “Dialogs” on page 30.

Your keyboard can also be used to navigate the dialog panels, as well as navigate the program menus. Many commands can also be invoked using keyboard hotkeys. See “Menus” on page 29 and “Hotkeys” on page 29.

In addition to the keyboard, a mouse or other device that can move a pointer is necessary in order to draw, select, and edit objects in your drawings.

Three Button Mice

The left button is the primary button used in Home Designer Pro. Unless specified otherwise, Home Designer Pro documentation refers to the left mouse button.

Many objects, such as doors and cabinets, are created by clicking the left mouse button. Others, such as walls, stairs and dimension lines, are created by dragging the pointer from one end of the object to the other.

Note: If you are left-handed and have re-programmed your mouse, reverse the instructions for left and right buttons in this manual.

See “Defaults, Preferences, and Edit Behaviors” on page 119.

When a setting is turned on, its icon will display a small checkmark at its lower right corner and have a border around it in both the toolbars and the menu.

The Right button has several uses.

Right-click to select any object. If, for example, the Straight Exterior Wall tool is active, the left mouse button only allows you to select walls. You can, however, select other types of objects such as cabinets with the right mouse button.

Use the right mouse button to temporarily switch to the Alternate edit behavior. See “Defaults, Preferences, and Edit Behaviors” on page 119.

You can also use the right mouse button to open a context sensitive menu with additional editing commands. See “Contextual Menus” on page 30.

The Middle button can be used to pan in most view types or to temporarily use the Move edit behavior. To close a tabbed view window, click on its tab using the middle mouse button. You can also program it to work as a double-click.

If your mouse does not have a middle mouse button, in the Mac version of Home Designer Pro you can use the left button and the Command key to achieve the same results.

The Mouse Wheel can be used to zoom in and out in most view types. See “Zoom Tools” on page 96.
The Back, or X1, button on a 5-button mouse can be used to temporarily enable the Concentric edit behavior. See the documentation for your mouse.

The Forward, or X2, button on a 5-button mouse can be used to temporarily enable the Resize edit behavior. See the documentation for your mouse.

3D Mice

3Dconnexion®’s 3D mice can be used to navigate in Home Designer Pro. For information about navigating in camera views and overviews, see “3Dconnexion® 3D Mice” on page 567.

Trackpads

In addition to the standard trackpad gestures on your system, in Home Designer Pro you can pinch to zoom.

In macOS™, you can Command + click to pan. Panning with a trackpad is not supported in the Windows version of the software, however.

Touch Screens

Standard one-finger touch screen gestures are supported in both the Windows and Mac versions of the software. In the Windows version, touching with a second finger to cancel an action is also supported, as are two-finger pan and two-finger pinch to zoom.

Gamepads

In the Windows version of Home Designer Pro, gamepads can be used to navigate in camera views, overviews, as well as elevation views. See “Gamepads” on page 568.

Crosshairs

Crosshairs help you position the pointer relative to objects in a view while drawing and editing. They can be set to display in Plan and Cross Section/Elevation views, and in Perspective and Orthographic camera views. Select View> Crosshairs to toggle crosshairs on or off in the current view type.

You can customize the Crosshairs’ appearance and control their display in different view types in the Preferences dialog. See “Edit Panel” on page 73.

Edit Handles

A selected object has edit handles that can be used to modify its size, position, and orientation. When you move the pointer over an edit handle, information about what it does displays in the Status Bar and the pointer changes to suggest how you can use it.

- A two-headed arrow indicates that the object, corner or edge can be moved in the direction of the arrows.

- A four-headed arrow indicates that the selected object or edge may be moved in multiple directions.

- A circular arrow indicates that the selected object can be rotated.

Resize handles display along the edges of the object are used to change the size. See “Resizing Objects” on page 145.

The Move handle at the object’s center lets you move the object. Depending on the type of object(s) selected and how far you are zoomed in or out, the position of the Move handle may shift so that it remains on-screen. See “Moving Objects” on page 141.

The triangular Rotate handle lets you rotate the object. See “Rotating Objects” on page 148.

How each handle behaves when it is clicked and dragged may depend on which Edit Behavior is currently active. See “Defaults, Preferences, and Edit Behaviors” on page 119.

You can cancel any edit handle operation before it is completed by pressing the Esc key on your keyboard or by pressing any two mouse buttons at the same time.

The edit handles that display depend on the type of object selected, the current view, and how far you are zoomed out. Edit handles do not resize as you zoom.
If you are zoomed out far enough, some edit handles may be hidden so that they do not stack over one another. As you zoom in, these handles become visible again.

**Pointer Icons**

The appearance of the pointer in Home Designer Pro will vary, depending on which tool is active. For example, when the Select Objects tool is active, it will look like a white arrow, and when a Cabinet Tool is active, it will look like a base cabinet with a small cross.

In addition, one or more additional icons may follow the pointer if a recommended setting is not in use or if a problematic condition exists in the file:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>📡</td>
<td>Angle Snaps</td>
</tr>
<tr>
<td>🎬</td>
<td>Alternate Edit Behavior</td>
</tr>
<tr>
<td>⬇️</td>
<td>Resize Edit Behavior</td>
</tr>
<tr>
<td>🔈</td>
<td>Concentric Edit Behavior</td>
</tr>
<tr>
<td>🔎</td>
<td>Fillet Edit Behavior</td>
</tr>
<tr>
<td>Ⓜ️</td>
<td>Disconnect Edges</td>
</tr>
<tr>
<td>🔂</td>
<td>Rotate/Resize About Current Point</td>
</tr>
<tr>
<td>⏰</td>
<td>Auto Rebuild Terrain</td>
</tr>
<tr>
<td>🔍</td>
<td>Rebuilding Walls, Floors and Ceilings</td>
</tr>
<tr>
<td>🔍</td>
<td>Fix Wall Connections</td>
</tr>
<tr>
<td>🟠</td>
<td>Irregular Wall Angles</td>
</tr>
</tbody>
</table>

**View and Side Windows**

Home Designer Pro’s main program window has a number of important features that let you interact with the program, such as toolbars and menus. It also features two different kinds of windows: view windows and side windows.

**View Windows**

View windows are sometimes referred to as “the drawing area” because most of them are windows in which you can draw or place architectural and/or CAD objects. There are a number of different types of view windows in Home Designer Pro:

- Plan views
- Camera views and overviews
- Cross section/elevation
- Materials Lists
- Layout

View windows can be navigated by panning and zooming. You can also enable scroll bars on their right side and bottom. Select View> Scrollbars to toggle their display. See “View Tools” on page 96.

Although only one view window can be active at any given time, there is no limit to the number of view windows that can be open. View windows can be tiled or tabbed, and you can navigate between them in a number of different ways. See “Window and View Tools” on page 93.

View and Side Windows

You can also tear a view window out of the main program window. This creates a second, separate program window complete with toolbars and menus. Individual view windows can be torn out and transferred between program windows.

**Side Windows**

Side windows provide access to a variety of tools and content that helps you add detail your drawings.

Side windows are so-named because they are typically docked to either the left or right side of the program window - although, they can also be docked to the top or bottom, or undocked entirely. There are several different types of side window:

- Child Tool Palette
- The Library Browser

Each of these side windows can be opened via the View menu or by clicking the toolbar button associated with it. Similarly, each can be closed by clicking the Close button in its title bar or tab, via the View menu, or by clicking its toolbar button. See “View Tools” on page 96.

To undock a side window, either drag its title bar out into the drawing area or click the Undock button on its title bar. To dock a side window, drag its title bar to any side of the program window. You can also double-click on its title bar to return it to its last docked location.
Two or more side windows can be docked together to form a shared side window, and can be tiled and/or tabbed within that shared window. To create a shared side window, begin by docking a side window to a side of the main program window, then:

• To create tabbed side windows, drag a second side window over the first. When the docked window becomes highlighted, release the mouse button.
• To create tiled side windows, drag a second side window over the first. When the docked window becomes highlighted, slowly drag the mouse towards one of its sides. When a highlighted space is created along that side, release the mouse button.

You can choose to disable Side Window Drag Docking in the Preferences dialog, and you can also enable Top/Bottom Docking. See “Appearance Panel” on page 62.

Side windows can also be set to their initial states in the Preferences dialog. See “Reset Options Panel” on page 81.

Toolbars and Hotkeys

Using the toolbar buttons is the fastest, easiest way to access many program features. If a tool is active, a small checkmark will display at the lower left of its button icon. You can move the toolbars, customize them by adding or removing buttons, or create your own toolbars from scratch. See “Toolbar Customization Dialog” on page 89.

You can also turn off the display of toolbars entirely or turn them on again by selecting View > Toolbars.

When you pass the pointer over a toolbar button, a “tool tip” displays the name of the tool and a more detailed description displays in the Status Bar at the bottom of the program window. When you see one of these tool tips, press the F1 key to get more information about that item. See “Getting Help” on page 36.

Home Designer Pro’s tools are organized into families of related tools which can be accessed using either of two styles of toolbar interface: the Child Tool Palette or Drop Down tools. You can select the interface that you prefer in the Preferences dialog. See “Appearance Panel” on page 62.

The Edit Toolbar

When you select an object, the edit toolbar appears. By default, it is located at the bottom of the program window, just above the Status Bar. The buttons on the edit toolbar can be used to edit the selected object(s). Which buttons display depends on the type of object selected, the current view, and how you selected the object.

The edit toolbar buttons are the same as the options in the contextual menu when you right-click on an object. See “Contextual Menus” on page 30.

Toolbars and Hotkeys

You can customize these configurations to suit your needs, or you can create your own custom configurations.

The Edit Toolbar

When you select an object, the edit toolbar appears. By default, it is located at the bottom of the program window, just above the Status Bar. The buttons on the edit toolbar can be used to edit the selected object(s). Which buttons display depends on the type of object selected, the current view, and how you selected the object.

The edit toolbar buttons are the same as the options in the contextual menu when you right-click on an object. See “Contextual Menus” on page 30.

Hotkeys

Many commands can be invoked from the keyboard. Press Alt on your keyboard and press the underlined letter in a menu name to access that menu, as well as items in the menus and submenus.

Other keys or key combinations will invoke a variety of program commands. If a Home Designer Pro menu item has a keyboard shortcut, or hotkey, associated with it, that hotkey will display to the right of its name in the menu.

Menus

Home Designer Pro uses a standard Windows menu format. The menus are located below the title bar in the program window and can be used to access nearly all tools in the program. Click on a menu
name to expand it, then click on a menu item to either activate that tool or access the item’s submenu. Items with a submenu have an arrow to the right of the name.

Menu items with an icon to their left have a toolbar button associated with them. Some buttons are not included on the toolbars but can easily be added. See “Toolbar Customization Dialog” on page 89.

The menus can be accessed using the keyboard. Press the Alt key once to enable this functionality - one letter in each menu will become underlined. Press the key associated with one of these underlined letters to expand its menu - one letter in each menu item’s name will be underlined. Press the key associated with one of these letters to activate that tool or access the item’s submenu. Press the Esc key to undo your last selection, or click with the mouse to exit out of this functionality.

Many tools in Home Designer Pro also have hotkeys associated with them. If a menu item has a hotkey, it will display to the right of the item’s name. See “Hotkeys” on page 91.

In the Home Designer Pro documentation, menu paths are written in this format: `Build> Window> Box Window`. An icon image after the menu path indicates that a toolbar button is also available.

### Contextual Menus

Contextual menus are context-sensitive menus that display tools relevant to a selected object or view. To open a contextual menu, right-click on an object, in an empty space in a view window, or in a text field in a dialog box.

The options in an object’s contextual menu are usually the same as those on an object’s Edit toolbar. See “The Edit Toolbar” on page 29.

### Dialogs

Default and preference settings, object specifications, display settings, and many other functions are accessed through dialog boxes.

Many dialogs have multiple panels, which are listed in a tree list on the left side of the dialog. Click on a panel name in the list to make it active. In Windows, panels can also be navigated using the keyboard. Press:

- Ctrl + Tab or Ctrl + F6 to navigate forward;
- Ctrl + Shift + Tab or Ctrl + Shift + F6 to navigate backward.

When a panel name is active, you can also navigate the tree list using the Up and Down arrow keys.

By default, dialogs always open to the first panel in the list; if you prefer, you can choose to Open Dialogs to the Last Panel Visited. See “General Panel” on page 67.

### Keyboard Navigation

Dialog panels and settings can be accessed using the mouse. You can also navigate the settings on a given dialog panel using the keyboard. For example:

- Line items in tree lists can be browsed using the arrow keys. Up and Down navigate the list, while Left and Right expand and contract categories.
- Press the Tab key to shift focus from the tree list to the first setting on the selected panel.
• Press the Tab key to shift focus from one setting to the next, or Shift + Tab to go in the reverse direction.

• A check box can be checked or cleared by pressing the Spacebar or the + or - keys, respectively, while it is in focus.

• Columns of radio buttons can be navigated using the Up and Down arrow keys; rows can be navigated using the Left and Right arrows. Select a radio button by pressing the Spacebar while it is in focus.

• Settings in list boxes can be navigated using the Up and Down arrow keys. When a check box is in focus, it can be checked or cleared by pressing the Spacebar.

• Drop-down lists can be browsed using the Up and Down arrow keys. When the mouse pointer is directly over the drop-down, the mouse scroll wheel can also be used; on a Mac, the list must also be expanded. In Windows only, you can press Tab to select the highlighted item in the list and proceed to the next setting.

• Settings with spin control arrows can be adjusted by typing in the text field or using the Up and Down arrow keys. When the mouse pointer is directly over the setting, the mouse scroll wheel can also be used.

• Slider bars can be adjusted by typing in the text field or using the Left and Right arrow keys. When the mouse pointer is directly over the slider bar, the mouse scroll wheel can also be used.

• Line items in tables can be group selected using the Ctrl or Shift keys, or by pressing Ctrl+A.

• Press Enter on your keyboard to close most dialogs and apply your changes.

• In the Mac version, Command + . closes dialogs.

The number format used in dialogs are set based on your operating system’s defaults. See “Region and Language Settings” on page 58. You can change the number format as well as the angle format in the Dialog Number Style/Angle Style dialog. See “Dialog Number/Angle Style Dialog” on page 82.

Math Operations in Dialogs

Basic addition, subtraction, multiplication, and division can be performed in the text boxes where numeric values are entered.

Note that settings for angle, pitch, or bearing do not support math, nor do those with spin controls or slider bars.

• To add, type the + character followed by the amount that you wish to add. Spaces are ignored and including a unit of measurement is optional.

• To subtract, type the - character followed by the amount you wish to subtract. As with adding, spaces are ignored and a unit of measurement is optional.

• To multiply, type the * character followed by the amount you wish to multiply by. Spaces are ignored, and only one of the values being multiplied can have a unit of measurement.

• To divide, type the / character followed by the amount you wish to divide by. To divide, there must be a space before the / - if there is not, the input may be treated as a fraction. The denominator, or value typed after the /, cannot have a unit of measurement.

Math expressions support a single operation only: more than one operation character (+, -, *, /) at a time is not allowed.

Basic math operations can also be used to move objects using dimensions. See “Moving Objects Using Dimensions” on page 263.

Dialog Size and Position

Dialog boxes can be both moved and resized to suit your needs. By default, the program will remember both the position and size that you specify for a dialog and use it the next time you open it. The size of dialog preview panes can also be changed, and are remembered as well. You can specify whether the program does this always, per session, or never in the Preferences dialog. See “General Panel” on page 67.
• To move a dialog, position your mouse pointer within its title bar and then simply click and drag.

• To resize a dialog, position your mouse pointer on any edge or corner and then click and drag outward or inward. If you drag an edge, only that edge will move; if you drag a corner, the two adjacent edges will move.

• To resize a preview pane, click and drag the vertical grab handle to its left. See “Dialog Panel Splitters” on page 33.

When a dialog is resized, some elements such as list boxes and text fields within it may resize in response.

All dialogs have a minimum size limitation but no maximum size. If a dialog opens on a monitor with resolution too low to display its full extents, it will have vertical and/or horizontal scroll bars.

You can reset the default sizes and positions of all dialogs in the Preferences dialog. See “Reset Options Panel” on page 81.

Note: Some of the dialog box images in the software documentation have been resized smaller than their actual minimum size.

Specification Dialogs

Each object in Home Designer Pro has a unique specification dialog where you can enter size, style and other information specific to the selected object. To access it, select the object and click the Open Object edit button. You can also double-click on an object with the Select Objects tool active to open its specification dialog. See “Selecting Objects” on page 123.

Most objects also have a defaults dialog that lets you specify the initial values in the specification dialog.

You can open the specification dialog for group-selected objects if they are of the same type, such as base cabinets.

• If a particular setting varies among the different objects, its check box will have a solid fill instead of a check mark. Click once to clear the box for all selected objects, or click a second time to place a check mark for all selected objects.

• In some dialogs, if a particular setting varies among the different objects, it will have a “No Change” radio button. Leave this button selected, or choose a different option to apply it to all objects in the selection set.

• If the setting has a text field or drop-down list, it will say “No Change”. Changes made to such a setting can be undone by replacing the value in the text field with the letter N before you click OK.

If you select multiple objects of different types, the Open Object edit button is usually not available. This button may be available if the objects have data in common, but you can only edit the common data.

Dialog Preview Panes

Many specification dialogs have a preview pane that shows how changes to settings affect the selected object. This preview updates when you click in a different field or press the Tab key on your keyboard.

If you switch to a panel with settings that affect the selected object’s appearance in a certain view, that view will be shown in the preview. For example, if you select the GENERAL panel, a 3D view will be shown; but if you select the FILL STYLE panel, floor plan view will be shown. When floor plan view is shown, the primary and all secondary layers associated with the object will display. See “Primary and Secondary Layers” on page 110.

When you click in the preview pane, your mouse pointer changes to a four-headed arrow and you can rotate around the object as well as zoom in and out using the mouse scroll wheel. Some objects, notably walls, doors, and windows, have Interior and Exterior labels to indicate which side is visible in the preview. Click the Fill Window button above the preview pane to zoom in or out so that the object fills the extents of the pane, maintaining the current rotation.

In most dialogs, the Standard, Vector View, and Glass House Rendering Techniques can be applied to the preview. See “Rendering Techniques” on page 595. You can specify whether Standard or Vector View is used by default in the Preferences dialog. See “Appearance Panel” on page 62.

Click the Color button to turn color in the preview on or off. Some objects have additional tools that affect object previews. For example, the Cabinet Specification dialogs have a Select Cabinet Face Item button. Object specific tools like this are discussed in the documentation for that object type.
The Status Bar

Dialog Panel Splitters
Many dialog panels are divided into up to three sections: a list of panels on the left, an object preview on the right, and a central area where settings are located. The vertical splitters separating these sections each have a pale grey, vertical grab handle.

To resize the panel list or preview, as well as the area in the middle, move your mouse pointer over the vertical grab handle: when the splitter cursor can be seen, click and drag to the left or right.

The Status Bar
The Status Bar at the bottom of the main program window displays information about the current state of the program.

This information depends on a variety of conditions such as settings in the Preferences dialog, the type of object selected, and the current position of the pointer. The information may include the following:

• The type of object currently selected or the total number of group-selected objects.
• A description of the edit handle that the pointer is over.
• A brief description of the toolbar button or menu item highlighted by the mouse.
• The name of the active tool, a brief description of that tool, and its hotkey, if it has one.

• The length and/or angle of an object as it is being drawn.
• Basic information about a selected library object, folder, or catalog.
• The current floor.
• The layer that the selected object is on.
• The selected object’s Drawing Group.
• The size of the active window in pixels.
• The current CAD coordinates of the mouse pointer.

The number format used in the Status Bar is set in the Dimension Defaults dialog, while the angle style can be specified in the Number Style/Angle Style dialog. See “Format Panel” on page 251 and “Dialog Number/Angle Style Dialog” on page 82.

Message Boxes
As you work in Home Designer Pro, the program will occasionally prompt you to examine your settings, alert you if you command it to do something that could potentially cause a problem, or notify you if it encounters a problem that needs your attention.

Situation where such message boxes may display include:
• Closing a file or view without saving;
• Modifying an object that is set to rebuild automatically;
• A file referenced outside the program, such as an image or texture, is missing;
• Creating an object in a space too small to contain it.

As with dialog boxes, you can access the options in a message box using the mouse or navigate them using the keyboard.

A few messages have a Send Report button. Click this button to send details regarding the issue that prompted the message to Chief Architect via the internet.

Some message boxes include a “Remember my choice” or a “Do not show this again” checkbox. Check this box to prevent messages of this specific type from displaying in the future. When this box is checked, some options in the message box may become inactive.

To allow all message boxes to display again, click the Reset Message Boxes button in the Preferences dialog. See “Reset Options Panel” on page 81.
Preferences and Default Settings

Preferences and default settings control many aspects of the user interface and tool behavior in Home Designer Pro. You can use these settings to customize the program to suit your personal work style.

For more information about defaults and preferences, see “Preferences and Default Settings” on page 57.

Preferences

Preference settings let you change program behavior to suit your workflow. For example, you can:

• Turn certain display elements on or off.
• Choose background and editing feedback colors.
• Set frequency of autosaves, maximum number of “undos,” and file locking.
• Set default folders for various files.
• Control the editing behaviors of objects.
• Setup the materials list categories, sub-categories, and report style, as well as manufacturer and supplier information.
• Set rendering specifications to maximize efficiency and quality.

Preference settings are global, affecting all plan and layout files.

Defaults

Most objects in Home Designer Pro derive their initial properties from their respective default dialogs.

For example, a newly placed Window gets its initial values from the Window Defaults dialog and a newly placed Hinged Door gets its initial values from the Door Defaults dialog.

Once an object is placed in a plan, its initial properties can be overridden, but setting up your defaults before you begin drawing can save you considerable time as you build a model in the program.

Default settings, unlike Preferences, are file specific.

Dynamic Defaults

Most default settings are static: if you change one, any objects of that type in the current file will not be affected. A few defaults, however, are dynamic: they are tied to existing objects in the drawing and if you change the default, those objects may be affected. See “Dynamic Defaults” on page 58.

Drawing a Plan

When you draw a plan in Home Designer Pro, you are placing 3D objects that represent building components. Home Designer Pro comes with predefined default settings so you can start drawing plans immediately. You should review these default settings to be sure they match your drawing and building methods. See “Preferences and Default Settings” on page 57.

Set the Defaults

1. Open a new plan using the template of your choice. See “Template Plans” on page 42.
2. Set the structural defaults:
   • Floor Defaults. Set the default ceiling height for Floor 1. See “Floor Defaults Dialog” on page 387.
   • Foundation Defaults. Set the foundation specifics such as type, footing size, and stem wall height. See “Foundation Defaults” on page 373.

4. Set style defaults for doors, windows, molding, cabinets and other objects.

Draw the Floors

1. While the size of the drawing area in Home Designer Pro is limited only by the resources on your computer, it is best to begin your drawing near the origin, 0,0,0. See “3D Drafting” on page 25.
2. Draw the exterior walls on Floor 1. See “Creating Walls” on page 193.
3. Adjust the perimeter shape and size as required. See “Using the Edit Handles” on page 200.

4. Place any first floor bearing walls.

5. Define types for special rooms such as garages and decks in the plan. See “Room Types” on page 227.


7. Build additional floors. See “Adding Floors” on page 388.

8. Specify the default ceiling height for each floor as soon as it is created. See “Floor Defaults Dialog” on page 387.

9. Adjust the perimeter shape of additional floors as needed. See “Editing Walls” on page 200.

10. Align edited or moved walls with those above or below where appropriate. See “Aligning Walls” on page 204.

**Entering Dimensions**

When using Imperial units, enter distances as inches or feet and inches, in fractional or decimal form. Millimeters are the default unit for all metric distances. See “Dimensions” on page 249.

- To enter feet, include the (’) marker or the program assumes inches.

- In most cases, the program allows precision to 1/16th of an inch. Fractions with denominators 2, 4, 8 and 16 are allowed.

- The program usually converts decimals to fractions.

- You can enter angles as decimal degrees, degrees, minutes, and seconds, quadrant bearings, or azimuth bearings. See “Dialog Number/Angle Style Dialog” on page 82.

**Build the Foundation**

1. Derive the foundation plan from the first floor. See “Building a Foundation” on page 376.

2. Adjust the foundation perimeter shape as needed.

3. Place interior foundation walls as needed for the first floor bearing walls.

4. Place any other foundation walls required.

5. **Align with Above** as needed. See “Aligning Walls” on page 204.

**Add Structure and Details**

1. Build non-structural interior walls. Begin on floor one and work up in multiple story structures.

2. Add walls where needed to create features such as chimney chases, plumbing walls, or Open Below areas.

3. Finish the relevant interior structure including interior doors, doorways, cabinets, fixtures, and fireplaces.

4. Build the roof planes. If you generate the roof automatically, remember to carry the roof directives in the walls from the first floor up to the top floor for multiple story structures. See “Roofs” on page 427.

5. Build the framing. See “Framing” on page 463.


7. Create the plot plan. See “Plot Plans” on page 638.

**Create the Layout**

1. If one does not exist, create a Layout file with a title block, placing the border, title block, and other text on page 0. See “Layout” on page 695.

2. Send views to the layout. See “Sending Views to Layout” on page 697.

3. Print the plan. See “Printing and Plotting” on page 707.

**Viewing Your Plan**

You can see your model in a variety of different 2D and 3D views. You can display more than one view at a time; and in any view, you can pan or zoom in or out. See “Window and View Tools” on page 93.

Floor plan view is a 2D view of the model most commonly used for drawing and editing. Each floor displays separately; however, you have extensive control over which objects display at any given time, can easily switch between floors, and can also display
items on a second floor for reference. See “Multiple Floors” on page 387.

You can create interior and exterior 3D views of your model from any perspective. As in floor plan view, you can select and edit many objects in 3D views and control which objects are visible. See “3D Views” on page 557.

You can also create **Doll House Views** that show only the current floor plus any floors beneath it. Ceilings on the current floor are omitted so you can see the interior, visualize the relationships between spaces, and plan traffic flow.

**Framing Overviews** display framing in 3D, provided that framing has been built. You can customize 3D views to serve special purposes such as this.

The Cross Section and Elevation camera tools create scaled 2D views of a model’s exterior and interior that can be dimensioned and annotated. Just as in other views, you can select and edit objects in a Cross Section/Elevation view as well as control which objects display.

**Layout**

All plan views can be sent to a layout where they can be arranged to produce construction documentation. See “Sending Views to Layout” on page 697.

All views can also be exported as a graphic image. See “To export a picture” on page 606.

**Getting Help**

There are many forms of help available in Home Designer Pro including: Tool Tips, the Status Bar, and the online Help menu.

All these forms of help assume you have a basic working knowledge of your operating system, including how to use a mouse, open, close and save files, copy, paste, and right-click to access contextual menus. Help also assumes you are familiar with basic computer terminology.

More information is available in the product documentation in both printed and electronic format and on Home Designer’s official web site, HomeDesignerSoftware.com.

See “Resources and Support” on page 733.

**Tool Tips**

When you move the pointer over a toolbar button or menu item, a **Tool Tip** displays, offering a brief
description of the tool. More information displays in the Status Bar at the bottom of the window.

**Contextual Help**

Online **Help** is a searchable menu that provides information about all of the tools in Home Designer Pro. Select **Help> Launch Help** to open the program’s Help and explore the table of contents, browse the Index, or Search for keywords.

The Help can also be used to provide instant information about toolbar buttons, menu items, and objects in your plan.

- When you move the cursor over a toolbar button or menu item, a brief summary of that tool displays in the Status Bar. Press the F1 key to open online Help to a page with more information about the tool.
- When an object is selected, edit handles display. Place the cursor over an edit handle and press F1 to open online Help to a page with information about that handle.
- Press the **Help** button in any dialog box to open online Help to a page describing the options in that dialog.

**About Home Designer**

Select **Help> About Home Designer Pro** in Windows® or **Home Designer> About Home Designer** in macOS™ to view information about your software license, the program’s version number, and its release date.

Contact information for Chief Architect, Inc. is available on the MORE INFORMATION panel.

**Product Upgrade Options**

Select **Help> Product Upgrade Options** to launch your default web browser and learn about options for upgrading your software license at www.homedesignersoftware.com.

**Home Designer Trial Software**

Free Trial versions of some Home Designer programs are available for download at HomeDesignerSoftware.com.

The Trial software offers the same functionality as a purchased license with a few limitations:

- **File Saving**
- Printing
- **File Exporting**
- Recording of Walkthroughs
- Printing or Exporting of Materials Lists
- Library Browser restrictions

**Converting the Trial Version**

An installation of the Home Designer Pro Trial software can be converted into a full working version of the program at any time by purchasing a software license. There are several ways to begin this process in the Trial:

1. **Select Help> Activate Full Version.**
2. In the **Product Activation** dialog, type or paste the **Product Key** associated with your software license.
3. Click the **Activate Full Version** button.
Chapter 2:

File Management

Home Designer Pro reads and edits two main document types: .plan files and .layout files. The complete 3D model of a structure, surrounding terrain and any CAD data associated with it are stored in the plan file. Data used to create working drawings and the links to various views are stored in the layout file.

All commands related to opening, saving and closing plans are located in the File menu. You can also open plans from the Startup Options dialog. See “Startup Options” on page 23.

Just as with files created in other software applications, you should back up your plan and layout files externally on a regular basis to avoid accidental loss of work.

Chapter Contents

• Compatibility with Other Programs
• Organizing Your Files
• Home Designer Pro Data
• Creating a New Plan or Layout
• Saving, Exporting, and Backing Up Files
• Thumbnail Images
• Auto Archive
• Undo Files
• Opening and Importing Files
• Referenced Files

Compatibility with Other Programs

Plans and layout files produced in the following programs can all be read by Home Designer Pro 2021.

• Chief Architect® X1 through X12 (limited edit- ability if enabled)
• Chief Architect® 10.0 through 11.3 (read only)
• All Better Homes and Gardens Home Designer® products, Interior Designer, and Landscaping and Deck Designer, Versions 7 and 8.

Only the .plan and .layout files from prior versions can be opened in Home Designer Pro 2021. A number of steps are recommended when migrating plans created in an earlier program version into Home Designer Pro 2021. Before doing so, see “Getting Started Checklist” on page 723.

Files that have been opened and saved in Home Designer Pro 2021 cannot be read by any of the program versions listed above. To continue to read files in the program in which they were created, be sure to create copies of your files before opening them in Home Designer Pro 2021.

Plans and layout files produced in the Windows® version of Home Designer Pro 2021 can be read in the Mac® version, and vice versa.

File Association

Although multiple versions of Home Designer can be installed on a computer, the operating system will only associate .plan, .layout, .calib, and .calibz files
with one of them. If they are not associated with Home Designer Pro 2021, click the **Associate Files with this Program** button in the **Preferences** dialog. See “File Management Panel” on page 68.

**Opening Chief Architect Plans in Home Designer Programs**

Plans created in Chief Architect Versions 10 through X12 and Home Designer Pro Versions 7 through 2021 can be opened in the latest Home Designer programs for viewing and annotating, but not for general editing or drawing of architectural objects.

Plans created in build 11.4 or later of Chief Architect X1 or Home Designer Pro 8, or in later program versions, can be set to allow limited editability in other Home Designer programs. When this permission is enabled, a Home Designer user can use all of their program’s drawing tools and can edit objects in the plan that those tools can create. If an object cannot be created in the Home Designer program, however, it will not be editable.

Please note, too, that if a plan has more floors than the Home Designer program supports, the entire plan can be viewed and annotated only.

To protect some objects from being edited when a file with editing permission is opened in another Home Designer program, consider locking their layers. See “Locking Layers” on page 111.

**Allow Editing in Select Home Designer Products** can be enabled or disabled only when the file is opened in Home Designer Pro. See “General Plan Defaults Dialog” on page 59.

**Organizing Your Files**

You should keep your plan and layout files separate from the support files needed to run Home Designer Pro. To keep files organized, you may find it helpful to create a new folder for each project.

Home Designer Pro files may use imported images, textures and other custom content saved in their own external data files. Consider storing copies of all external files in the same folder as the plan and layout files that use them so that they are easily found.

Here is one way to organize your files:

- Create a folder in your Documents directory called “Home Designer Pro Plans” or another name you prefer. See your operating system’s Help to learn how to create folders.
- Inside this folder, make a new folder for each client or project. Save all the files for that client or project inside this folder, including plan and layout files and referenced external files. See “Saving, Exporting, and Backing Up Files” on page 43.

**Home Designer Pro Data**

When Home Designer Pro 2021 is installed, the program automatically creates a folder in the user Documents directory called **Home Designer Pro 2021 Data**. This folder contains important user-specific information saved in the following folders and files and should not be moved, renamed or deleted:

- **Archives** - A folder of automatically archived plan and layout files. See “Auto Archive” on page 45.
Creating a New Plan or Layout

To open the Create New Plan dialog, select File→New Plan.

You can also choose New Plan in the Startup Options dialog. See “Startup Options” on page 23.

Create a new layout file by selecting File→New Layout or by sending a view to layout when no layout file is yet open or associated with the current plan file. See “Creating a Layout File” on page 696.

Data Folder Name and Location

The name of the Home Designer Pro 2021 Data folder cannot be changed, but you can specify its location on your system in the Preferences dialog. See “Folders Panel” on page 69.

If you specify a new location for this folder, the program will not migrate any custom user settings that you might have. Instead, it will automatically create a new folder at that location containing default information from the Home Designer Pro installation folder. If you would like to copy custom settings to the new location, you can do this yourself in an operating system window.

When specifying a location for the Data folder, bear these considerations in mind:

• If you move the Home Designer Pro 2021 Data folder on your computer without specifying its location in Preferences, the program will automatically replace the folder in its default location using default information from the Home Designer Pro installation folder.

• The same will result if you specify a location on a network or removable device and that location becomes inaccessible. For this reason, it is best to use a location on your local hard drive.

• The User Database Libraries in particular may contain a large amount of data. Whatever location you choose to use must be located on a hard drive with sufficient space to hold these files.

Just as with your plan and layout files, it is a good idea to back up your Home Designer Pro 2021 Data folder.

Because the Home Designer Pro 2021 Data contains custom user data, it is not deleted when the program is uninstalled. See “Uninstalling Home Designer Pro” on page 16 of the User’s Guide.

By default, a new layout file will be assigned the same name of the first plan file sent to it, associating the layout files with the plan files used.

Note: Only one layout file can be open at any given time.

New, blank plans are called Untitled.plan and new, blank layout files, Untitled.layout. Unless these files are named and saved, they will be lost when closed.

Creating a New Plan or Layout

• Backdrops - A folder of custom backdrop images. See “3D Backdrops” on page 566.

• Images - A folder of custom images. See “Using the Contextual Menu” on page 518.

• Database Libraries - A folder of user library data. See “Library Content” on page 514.

• Scripts - A folder for custom Ruby scripts associated with Chief Architect plans.

• Templates - A folder of plan and layout template files. See “Creating a New Plan or Layout” on page 41.

• Textures - A folder where you can save image files used to create custom material textures. See “Creating Materials” on page 545.

• Toolbars - A folder of customized toolbar files. See “Toolbar Customization Dialog” on page 89.

• mmaster.mat - The Master Materials List file. See “The Master List” on page 690.

• sheetSizes.sheet - A list of user-created Drawing Sheets. See “Customize Sheet Sizes Dialog” on page 712.

• units.dat - A list of user-created units of measurement. See “Unit Conversions Panel” on page 70.

• _MigrateBackup - If you migrated legacy settings into version 2021, additional folders with names appended with _MigrateBackup may also be present. See “Migrating Content and Settings” on page 14.

If the Home Designer Pro 2021 Data folder is renamed, moved or deleted, the program will automatically replace it using default information from the Home Designer Pro installation folder. When this occurs, customized user settings and custom user library content will not be available.
See “Saving, Exporting, and Backing Up Files” on page 43.

**Units of Measurement**

All plan and layout files save measurements in either Imperial or metric units. New files are created using one or the other, depending on the current setting in the Preferences dialog. When the program is first installed, the Windows OS setting for units determines what system is used. See “New Plans Panel” on page 70.

A plan or layout file’s unit of measurement must be specified before it is created and cannot be changed later.

While it is recommended that you create new plans using the type of unit that you plan to use, you can display dimensions using any type of unit. See “Dimension Preferences and Defaults” on page 250.

**Template Plans**

When you select File > New Plan in Home Designer Pro, the Create New Plan dialog opens, letting you select a template for your new plan. The resulting new plan uses either metric or U.S. units of measurement and predefined default settings for objects like walls, doors, windows, and cabinets. See “Default Settings” on page 57.

- Select either U.S. Units or Metric Units of measurement. Once a new plan has been created, its Measurement Units cannot be changed.
- Select a style template from the list. If you are uncertain as to the right style for your plan, choose Default, as you cannot change the plan style template once a plan has been created.

When you click OK, a new floor plan view window opens, ready for you to begin drawing.

When Home Designer Pro opens a new, blank plan or layout file, the new file is actually a copy of a template using either metric or U.S. units of measurement and predefined default settings, wall definitions, and page setup information. See “Creating a New Plan or Layout” on page 41.

**Select Template Dialog**

When a new, blank plan or layout file is opened in Home Designer Pro, the new file is actually a copy of
• Select **Load Installed Template (Recommended)**, then select a template file from the drop-down list.
• Select **Load Custom Template**, then click the **Browse** button and browse to a plan or layout file saved on your computer.

Saving, Exporting, and Backing Up Files

Saving, exporting, and backing up your files are three separate tasks that accomplish different things:
• Saving a plan or layout file retains your work so that it can be later opened in Home Designer Pro.
• Exporting a file allows you to save certain kinds of data in a format that can be used by a program other than Home Designer Pro.
• Backing up your files involves taking steps to make sure that your valuable data is protected and available when needed.

Whether you are saving, exporting, or backing up your data, it is important that you select a location on your computer for the files you create, and also specify a short, meaningful name that you will be able to identify in the future.

**To save an untitled plan or layout file**

1. Select **File> Save** to open the **Save File** dialog.
2. Specify a location on your computer where you would like to save the file. See “Organizing Your Files” on page 40.
3. In the **File name** text field, type a name for the file.
4. Home Designer Pro automatically assigns the **File of type** and file extension .plan to plan files and .layout to layout files.
5. When both the Save in location and File name are correct, click **Save**.

Although the program warns you if you try to exit without saving, you should get in the habit of saving plan files before exiting the program.

Saving Plan and Layout Files

When you first save a new, untitled file, you must select a location for it on your computer and give it a name. There are two options for saving plan and layout files: File> Save and File> Save As.

Both **Save** and **Save As** can be used to save your plan and layout files; however, they accomplish this in two different ways.
• **File> Save** saves the current state of your plan or layout file without changing its name and should normally be used for saving your work.
• **File> Save As** opens the **Save File** dialog, allowing you to save the plan or layout file using a different name or location on your computer.

Initially, all **Open** and **Save As** operations go to your Documents directory. After that, the location last visited is remembered and subsequent **Open** or **Save As** commands default to the directory last used for that operation. This path is saved when the program exits. The next time Home Designer Pro is launched, these defaults are used.

If you prefer, you can instead specify a directory to be used for all **Open** or **Save As** operations in the **Preferences** dialog. See “New Plans Panel” on page 70.

Saved Views

All saved camera views are saved with their plan file. See “View Windows” on page 93.

When saving a layout, the program saves all the links to the various views saved in the layout, and all the CAD objects added to the .layout file.

By default, a new layout file is assigned the same name as the first plan file from which a view is sent to it. It is also saved in the same directory as the plan file. If no view has been sent to a layout, it remains untitled until you save it.
Save File Dialog

The **Save File** dialog uses the operating system’s file save dialog format, and is also used when exporting files. The dialog name may vary, depending on the type of file being saved or exported.

A similar **Select Folder** dialog allows you to select a folder to which files can be exported.

1. Choose a location on your local computer for the file you are saving.
2. Any existing folders and/or files in the current location display here.
3. In the **File Name** field, type a name for the file. If you select an existing file from the space above, its name will display here automatically.
4. When saving a file, the program will choose the appropriate file type from the **Save as type** drop-down list. When exporting, you may need to choose a specific file type.

Saving Revision Files

Revisions are a common aspect of any design project. There are a number of possible strategies for organizing revision files:

- Prepending the file name;
- Appending the file name;
- Saving revisions in separate folders.

To avoid confusion and potential mistakes, it is recommended that you always give files unique names - including revision files. If you choose to organize your revisions by saving them in separate folders, you should also give each file a unique name that makes it impossible to confuse it with another file saved in a different folder.

Exporting Files

Home Designer Pro has a number of options for exporting and importing information out of and your drawings. See “Importing and Exporting” on page 623.

Often, file export dialogs are simply versions of the **Save File** dialog.

Similarly, file import dialogs are often similar to the **Open File** dialog. See “Importing Files” on page 47.

Backup Entire Plan

**File> Save As** is a simple way to transfer a plan or layout to a different location on your computer. Bear in mind, though, that plan and layout files often reference external data files such as imported textures, images, and backdrops. These external files are not affected when **Save As** is used.

If you transfer a plan file from one computer to another, the program will warn you of missing files if the external data files used by the plan cannot be found when you open it.
Layouts are also dynamically linked to plan files. When transferring layout files to another computer, be aware that the plan files are also external file references and are not actually contained in the layout.

When transferring plans or layouts to another computer that does not have these external files, use the **Backup Entire Plan** tool. See “Backup Entire Plan or Project” on page 49.

**Backing Up Your Files**

It is always a good idea to create backup copies of all your important files on your computer.

It is strongly recommended, however, that you never save directly:

- Across a network, such as onto a server;
- Onto removable media such as a USB thumb drive;
- Across the Internet.

**Thumbnail Images**

A thumbnail is a miniature image that helps identify a file in the **Open Plan File** dialog in Windows. Any view of a plan or any layout page can be saved as the thumbnail.

If thumbnails are enabled in the **Preferences** dialog, the program automatically creates one when you first save a new plan or layout. You can choose to generate small or large thumbnails. See “File Management Panel” on page 68.

**Auto Archive**

The first time a plan or layout is saved, Home Designer Pro creates an Archive folder in the Home Designer Pro Data folder. The Archive folder contains Auto Save and Archive files.

The program does not create Auto Save and Archive files for untitled plans and layouts. In order for these to be created, a file must have been previously saved and given a name and save location on your computer. Further, Archive files are only updated when you save your work.

Instead, copy your files to such locations only after you have saved them on your computer’s hard drive and exited the program.

Similarly, you should never open files saved in these locations. Copy the files to the local hard drive, and then open them. See “Opening and Importing Files” on page 47.

Archive folders are used by Home Designer Pro to manage prior versions of your files. You should not view these files as a substitute for your own backup routine, and should never save a file in an archive folder. See “Auto Archive” on page 45.

When backing up your Home Designer Pro files, consider backing up not only your `.plan` and `.layout` files, but your custom user data, as well - including library content, toolbar configurations, and textures. This custom data is all located in the Home Designer Pro Data folder, so it can be easily backed up. See “Home Designer Pro Data” on page 40.

You can, if you wish, create a folder inside the Data folder for your `.plan` and `.layout` files, as well. See “Organizing Your Files” on page 40.

**Auto Save and Archive files should not be viewed as a substitute for regularly saving your work by selecting **File** > **Save** or pressing Ctrl + S on the keyboard, nor should they be considered an alternative to your own file backup routine.**

**Archive Files**

Every time a drawing is saved, Archive files that keep a historical archive of your plan are automatically created or updated.
Plan, layout and related files from previous versions of the program are automatically moved to the archive folder when the plan is opened and saved in Home Designer Pro.

Archive files are meant to be for emergency use only. If you must access an archive file, open it as you would any other file. See “Creating a New Plan or Layout” on page 41. As soon as the file is open, use **Save As** to save this file to another location.

### Legacy Archive Files

Plan and layout files saved in the current program version are not backwards-compatible: that is, they cannot be opened in older versions of the software.

If you open a Home Designer plan or layout file from a previous program version and immediately **Save** it (not **Save As**), the Auto Archive utility will create an additional archive file using the original program version format. This archive file is a copy of the original and can still be opened in the original program version.

### Auto Save Files

As you work, Home Designer Pro automatically creates Auto Save files at regular intervals when changes are made to a file but not saved by selecting **File > Save**.

These Auto Save files are appended _auto_save.plan or _auto_save.layout and are saved in the Archive folder.

### Undo Files

Home Designer Pro stores a set number of copies of all open plan file changes, known as undo files. Undo files are referenced whenever you select **Edit > Undo** or **Edit > Redo**. See “Undo and Redo” on page 159.

Undo files are stored in the Undo Directory, which can be specified in the **Preferences** dialog. See “Folders Panel” on page 69.

When you close a file normally, its Auto Save file is retained until the next time the file is opened - at which time the Auto Save file is overwritten.

You can enable Auto Save and set its frequency in the **Preferences** dialog. See “General Panel” on page 67.

Auto save files created as a result of an improper program shutdown are appended _auto_save_bak.plan or _auto_save_bak.layout.

If your computer shuts down accidentally, you can recover some of your work by opening the _auto_save_bak file.

When you reopen a file after a computer shut down or system crash, the program will notify you if an Auto Save file newer than the original file is found and give you the option to one that file.

Even with Auto Save, you should save your work manually on a regular basis using any of the following methods:

- Click the **Save** button.
- Select **File > Save**.
- Press Ctrl + S on the keyboard.

The maximum number of Undo files is specified in the **Maximum Undos** value in the Preference settings. If you have **Undo** enabled, be sure to define a directory on a hard drive with enough space for these files.

When Home Designer Pro is closed normally, any current Undo files are deleted.
Opening and Importing Files

Opening and importing files are often similar tasks, but accomplish two very different things:

- Opening a file refers to opening it in the program in which it was created. Only plan or layout files can be opened in Home Designer Pro. See “Compatibility with Other Programs” on page 39.
- Importing a file brings data that was created in a different program into Home Designer Pro. A number of different file types can be imported into Home Designer Pro.

Select File> Open Plan to open an existing .plan file or File> Open Layout to open an existing .layout file located on your computer. Home Designer Pro automatically browses to either the directory last used or to a specific directory, depending on your current Preferences settings. See “New Plans Panel” on page 70.

Open File Dialog

The Open File dialog uses the operating system’s file open dialog format, and is also used when importing files. The dialog name may vary, depending on your operating system and the type of file being opened or imported.

A similar Select Folder dialog allows you to select an entire folder of files to import.

1. Choose the location on your local computer for the file you are opening.
2. Any existing folders and/or files in the current location display here.
3. In the File Name field, type the file’s name. If you select the file in the space above, its name will automatically display here. When importing some types of files, multiple files may be selected.
4. When opening or importing a file, the program will usually choose the appropriate file type from the Save as type drop-down list. When importing, you may need to choose a specific file type.

Plan files open to the floor that was active when the file was last saved and closed; layout files open to the page that was active.

Importing Files

Home Designer Pro has a number of options for exporting and importing information out of and into your drawings. Often, file import dialogs are simply
versions of the Open File dialog. See “Importing and Exporting” on page 623.
Similarly, file export dialogs are often similar to the Save File dialog. See “Exporting Files” on page 44.

Recently Opened Files
A list of recently opened and saved plan and layout files can be accessed by selecting File> Open Recent Files. Select one of these files to open it without using the Open File dialog.

The maximum number of recent files listed in the File menu can be changed in the Preferences dialog. You can also specify that the recent files list display at the bottom of the File menu rather than in a submenu. See “File Management Panel” on page 68.

The names of recent files also display in the Startup Options dialog. Click on the name of a file to open it. See “Startup Options” on page 23.

Referenced Files
Home Designer Pro plan and layout files often reference a variety of external files for added detail, including:

- Material Textures
- Images
- Plant Images
- 3D Backdrops
- Picture Files
- PDF Files

Whenever any view in a plan or any page in a layout is opened, the program checks for referenced files used in that view and will notify you if any of those files cannot be found by opening the Missing Files dialog.

You can also open this dialog at any time by selecting Tools> Checks> Missing Files. When accessed this way, all missing files associated with the current file are listed: not just those used in the current view.

Missing Files Dialog

1. The table lists any Missing Files as well as useful information about each:

   - **Missing File** reports the name and file extension of the missing file.
   - **File Usage** indicates how the missing file is used in the program.
   - **Object Name** states the name of the object in Home Designer Pro that references the file.
   - **Object Location** indicates where in the file the object can be found.
   - The next column indicates whether a missing texture is in use in the plan.

   - **File Path** states the last known location of the missing file on your computer system.

   Click on a line item in the table to select it and resolve it using the options on the right. Multiple line items can be selected; however, the selections on the right may be limited. See “Shift and Ctrl Select” on page 125.

2. The buttons on the right offer options for resolving a selected missing file. The names of these buttons will vary somewhat, depending on the type of file(s) selected in the list on the left.
• Click the top Replace Object button to replace any instances of an object or material referencing the selected missing file with a different object or material from the library. Not available for PDF files or picture files.
• Click the Replace File button to open the Browse for Missing File dialog and select a file saved on your system to replace the missing one. See “Opening and Importing Files” on page 47.
• Click the Delete Object button to remove the object or material referencing the missing file from the plan. Not available for material textures that are In Use.
• Click the Add Search Directory button to direct the program to a particular folder to search for missing files in. The list of Search folders can be reset in the Preferences dialog. See “Reset Options Panel” on page 81.

You can prevent this dialog from opening automatically by checking Do not display missing files again during this session at the bottom of the dialog. This option is not available when the dialog is opened manually.

Backup Entire Plan or Project

Because Home Designer Pro plans contain many references to external files such as material textures and images, it is a good idea to make copies all the associated files when a plan is moved to a new location. You can easily do this by selecting File> Backup Entire Plan.

Layout files also rely on references to plan files, images, and other files. Select File> Backup Entire Project to copy these files when you want to move a layout file to a new location.

Backing up an entire plan or layout is important when:
• Migrating legacy files created in older program versions.
• Transferring files to another computer or sending them to another user.
• Archiving or backing up your work.

To back up a plan or layout

1. To copy all associated plan or layout files to a new directory, select File> Backup Entire Plan or Project.
2. The Backup Entire Plan or Project dialog opens.

Choose Backup Plan Files and All Referenced Files to copy the plan or layout file and all externally referenced files such as linked plan files, inserted picture files, metafiles, and texture, image, and backdrop graphics files.
• Choose Backup Plan Files Only to copy all associated plan files and any externally linked files and inserted picture files, but no graphics or texture files. This is best used only when transferring a file to a computer that already has the graphics files installed.
• Check Send Backup Files to Zip Archive to save the files in a zipped folder instead of a regular folder.
• Click OK.

3. The Select the Plan or Project Backup Folder or Choose Zip Archive to Backup dialog opens next. This is a typical Save File dialog. See “Saving, Exporting, and Backing Up Files” on page 43.
• Navigate to a folder on your system and select it.
• With the destination folder for the backup selected, click OK.

4. If the destination folder already contains files, the program will confirm whether you want to overwrite them.

The resulting folder contains a copy of the plan or layout file and all referenced files, and can be moved to a new computer.
Exiting Home Designer Pro

Select **File > Exit** to exit the program. If you have not saved any open files, you will be reminded to do so. It is better to save your work before exiting than to save on exit. See “Closing Views and Files” on page 98.

When you exit from the program using **File > Exit**, all Autosave files and Undo files are automatically deleted.

On a Mac, if you click the program window’s red **Close** button, the window will close but the program itself will continue to run. To close it down completely, right-click on its icon on the Dock and select **Quit** from the contextual menu.
Project Management

The tools described in this chapter allow you to conduct preliminary budget and space planning, and to run checks on plans so you can be more confident that they are free of common drawing errors.

**Chapter Contents**

- Space Planning
- Room Box Specification Dialog
- Finding Objects
- Plan Check
- Loan Calculator

**Space Planning**

The **Space Planning Tools** are a time-saving way to create a preliminary room-by-room design of a home without getting caught up in the details. When the room boxes are laid out, the **Build House** tool converts them into a working plan that can be edited and detailed to completion.

**Space Planning Assistant**

In plan view, select **Tools> Space Planning> Space Planning**. The **Space Planning Assistant** gathers information about the rooms you want to include in your house. When you click **Finish**, the selected room boxes display.

Room boxes can now be arranged into a floor plan.

**Placing Room Boxes**

In addition to or as an alternative to the room boxes created for you by the **Space Planning Assistant**, you can create your own room boxes. In plan view, select **Tools> Space Planning**. In the submenu, choose the desired room type, then click to place a room box of that type.

**Displaying Room Boxes**

Room boxes and their labels are located on the “Space Planning Boxes” layer. Space Planning Box labels use the Text Style assigned to that layer, as well. See “Displaying Objects” on page 109.

**Editing Room Boxes**

Once created, room boxes can be edited in a variety of ways.
• Select room boxes using the Select Objects tool just like other objects in Home Designer Pro. See “Selecting Objects” on page 123.

• Room boxes can be resized, rotated, and rearranged. See “Editing Box-Based Objects” on page 136.

• Try to line up the rooms so that they are just touching. Excessive overlaps may cause your rooms to form incorrectly. Closets are the exception. You can overlap a room with a closet, or place in inside another room box.

• Rooms can be copied and pasted using the Copy/Paste edit button and deleted using the Delete edit button.

• Select Tools> Space Planning or click the Space Planning Configuration button to access the room box tools and place additional room boxes in your plan. Select a tool and click in the plan to place a room box of that type.

• Select Tools> Space Planning> Toggle Room Boxes or click the toggle button to hide or show the room boxes.

Build House

When the room boxes are in place, select Tools> Space Planning> Build House to convert them into a building composed of walls and railings. Doors are inserted between the rooms, as well.

When you Build House, the “Space Planning Boxes” layer is automatically turned off. The room boxes that you created are not deleted, however.

Multiple Floors

If you specified a two-story house in the Space Planning Assistant:
1. Edit and arrange the room boxes on Floor 1 as desired.
2. Select Tools> Space Planning> Build House tool to create the walls on the first floor.
3. Go Up One Floor and notice that the positions of the walls on Floor 1 display in red as a reference.
4. Arrange the rooms on Floor 2 as desired using the red polylines as a guide.
5. On the second floor, select Tools> Space Planning> Build House to complete the second floor.

**Room Box Specification Dialog**

Select one or more room boxes and click the Open Object edit button to open the Room Box Specification dialog.

**General Panel**

Most of the settings on the General panel are used when the selected room box is converted to a room using the Build House tool.

1. Specify the selected room box’s Room Type and Name.
   - Specify a Room Name for the selected room box. When the default is specified, the Function selected below is used as the name.
   - Select a Function from the drop-down list. See “Room Types” on page 227.
2. Specify the Size of the selected room box.
   - Specify the room box’s Width and Height.
   - Specify the Fillet Radius, which is the radius of the curve on each of the room box’s corners. Unlike the other settings on this panel, this value does not affect the shape of the room created using Build House.

**Line Style Panel**

The Line Style panel is available for a variety of other objects in the program. For more information, see “Line Style Panel” on page 169.

**Fill Style Panel**

The Fill Style panel is available for a variety of other objects in the program. See “Fill Style Specification Dialog” on page 115.

**Finding Objects**

There are a variety of tools in the program designed to help you locate specific objects. These tools often open a new view window in which the object in question is either highlighted or selected.

- To find out where a line item in the Materials List is located in the model, select its row or any cell in its row and click the Find Object in Plan.
edit button. See “Find Object in Plan” on page 685.

- To locate a string of text, select Edit> Find/Replace Text. See “Find/Replace Text” on page 277.

- In a Framing Overview or other 3D view in which wall framing can be seen, select a wall framing member and click the Find Wall edit button to locate its owner wall in plan view. See “Selecting Walls” on page 200.

Additional tools are available to help you find files referenced by your plans and layout files.

- Select Tools> Checks> Missing Files Check to identify and locate any missing referenced files. See “Referenced Files” on page 48.

- Select Tools> Layout> Referenced Plan Files to identify and locate any plans linked to the current layout file. See “Managing Layout Links” on page 704.

**Plan Check**

**Plan Check** examines the current floor of a plan, checking for anything that appears to violate common building practices. Plan Check may not find all the problems in a plan, but does it point out areas that may need improvement.

To run Plan Check, select Tools> Checks> Plan Check.

Potential plan errors found are usually highlighted in plan view. To ensure the highlighted item is on-screen, make sure the entire plan is shown in the window before you run Plan Check.

### Plan Check Dialog

The current error number, along with the total number of errors found, is stated at the top of the dialog.

A description of the current error displays in the field on the left.

Options for navigating Plan Check are found on the right side.

- Click Next to ignore the current error and proceed to the next.
- Click Previous to return to the previous error.
- Click Hold to suspend Plan Check so you can fix the current error. Select Tools> Checks> Plan Check again and the check starts where it left off.
- Click Done to terminate Plan Check.

If this dialog obscures the plan view, drag its title bar to move it. It remembers its new position and displays there the next time Plan Check is run.

**Room Types**

**Plan Check** can do a much better job of checking for problems if it knows what the rooms in your plan are to be used for, so you should assign a Room Type to each room in your plan. See “Room Types” on page 227.

The first time **Plan Check** runs in a plan, it automatically assigns a room type to as many undesignated rooms as it can. Some rooms are determined by their size and shape, and others by their contents. For example, a shelf in a small room indicates a closet; a stove or refrigerator indicates a kitchen; or a bed, a bedroom. If the program cannot assign a room type, **Plan Check** highlights it and suggests that you do so manually.

**Loan Calculator**

Select Tools> Loan Calculator to open the Loan Calculator dialog. This dialog lets you calculate different aspects of a loan for the current plan based on a variety of parameters.
Specify what aspect of the loan you would like to calculate from the Calculate drop-down list:

- Monthly Payment
- Loan Amount
- Term
- Interest Rate

The calculation Result, based on the information you provide, displays here. If you make changes to any of the fields in the dialog, click the = button to refresh the Result.

3. The Required Fields are the same as the options in the Calculate drop-down list. The option selected under Calculate will be inactive under Required Fields.
   - Specify the desired Loan Amount.
   - Specify the desired Term, in years.
   - Specify the desired Interest Rate.
   - Specify the desired Monthly Payment.

4. The Optional Fields allow you to include additional information in your loan calculation.
   - Specify the expected Property Taxes per year.
   - Specify the expected Homeowner’s Insurance cost per year.
   - Specify the expected Private Mortgage Insurance (PMI) cost per year.
   - Specify the cost of any expected Other Fees.

When Monthly Payment is calculated, each Optional value is divided by twelve (months) and then added to the total payment.

When a Calculate option other than Monthly Payment is selected, these values are divided by twelve (months) and then subtracted from the specified Monthly Payment value. The result, which does not display, is then used to determine the Loan Amount, Term or Interest Rate.
Preferences are global settings that affect the functionality and appearance of the Home Designer Pro environment, while default settings control what objects look like when they are initially created. You can save time and increase your productivity by becoming familiar with these settings and customizing them before you begin a new project or as needed thereafter.

**Default Settings vs Preferences**

Default and preference settings have important effects on how the tools in Home Designer Pro function. Default settings are file specific, while Preferences are global, taking effect regardless of what file is open.

Defaults and Preferences can be customized to suit your needs and improve your efficiency, so it is recommended that you become familiar with them and learn how you can use them to your advantage.

**Default Settings**

Default settings determine the initial characteristics of objects when they are first drawn. For example, when you place a base cabinet in a plan, its size, materials, front items, hardware are determined by settings in the Base Cabinet Defaults dialog.

Some defaults affect the structure of your model: for example, Floor, Foundation, Framing, and Wall defaults.

Defaults are file-specific, which means that any changes that you make to the default settings in one plan or layout file will have no effect on other plans or layout files.

You can access a complete list of the various default settings in the current plan or layout file by selecting Edit> Default Settings from the menu.

**Chapter Contents**

- Default Settings vs Preferences
- Dynamic Defaults
- Reset to Defaults
- General Plan Defaults Dialog
- Preferences Dialog
- Dialog Number/Angle Style Dialog
• Click the + beside a category to expand it and access the defaults for items related to that category.

• To open the defaults dialog associated with an item in the list, double-click on the line item, or click on the item and then click the Edit button.

• General CAD defaults are view-specific and are only available in views where CAD objects can be drawn. See “CAD Defaults Dialog” on page 161.

Many defaults dialogs can also be opened by double-clicking on a parent and/or child toolbar button of a tool affected by the settings in that dialog. For example, you can:

• Double-click the Cabinet Tools parent button to open the Defaults Settings dialog for Cabinet tools only;

• Double-click the Base Cabinet child button to open the Base Cabinet Defaults dialog.

Preferences

Preference settings influence the overall environment of the program, such as what the interface looks like, how the tools are accessed, and the basic rules governing how objects are drawn and edited. See “Preferences Dialog” on page 61.

Unlike default settings, Preferences are global, which means that any changes that you make to them will take effect in all plan and layout files.

To access the Preferences dialog, select Edit>Preferences from the menu.

Region and Language Settings

There are a few formatting considerations in Home Designer Pro that are set based on your operating system’s Region settings:

• Units of measurement - When you first install and launch the program, your template plan and layout files will be set to use either Imperial or metric units, depending on your operating system settings. See “New Plans Panel” on page 70.

• Currency - The currency associated with your Region settings will be used in the Materials List, Components dialogs, and Loan Calculator. See “Materials Lists” on page 681 and “Loan Calculator” on page 54.

• Decimal mark format - Depending on your operating system settings, either a dot or a comma will be used in dimension lines, dialogs, and anywhere the program can display a numeric value using decimals.

• Date format - The format of Sun Angle date labels vary depending on your operating system settings. See “Sun Angles” on page 591.

Dynamic Defaults

Dynamic defaults are values that can be changed globally throughout the current plan or layout file. They are available for a variety of objects, including dimension lines, walls, doors, cabinets and rooms.

• If you change a dynamic default value in a defaults dialog, all objects of that type that are set to use the default will update automatically to use the new value.

• Any objects of that type that are not using the default value because of editing will not be affected if you change the default.

Dynamic defaults are presented in several different ways in specification dialogs. Some settings have a Use Default radio button, or a “Use Default” option in a drop-down list.
Dynamic default check boxes have a **Default** checkbox. Uncheck this box to make the setting not dynamic, or check it again to restore the dynamic behavior.

Dynamic default text fields have an Active Defaults ⚫️ icon in the value field.

- Click on the Active Defaults ⚫️ icon to remove the red check mark and prevent the value from being dynamic.
- Type a value into the text field. The red check mark is removed from the Active Defaults icon and the setting is no longer dynamic.
- Click on the Defaults ⚫️ icon to restore the red check mark and make the setting dynamic again.

Materials are another example of an attribute that uses Dynamic Defaults. See “Material Defaults” on page 540.

**Reset to Defaults**

Select **Edit > Reset to Defaults** to open the **Reset to Defaults** dialog.

This dialog allows you to reset critical structural settings in the current plan to the default values.

1. The settings can be cleared for the current floor or for All Floors.
2. Specify which settings you want to reset to Default.

**General Plan Defaults Dialog**

The settings in the **General Plan Defaults** dialog control basic features of the Home Designer Pro environment in plan files. Just as with other default settings, they are file specific, which means that they can be set differently in individual plan files. To open this dialog, select **Edit > Default Settings ⚫️**, select Plan, and click the **Edit** button, or double-click the Select Objects 📦 button.

The **General Layout Defaults** dialog is similar to the **General Plan Defaults** dialog, but has fewer settings and is available in layout files only. Its settings, too, are file specific.
General Settings - Specify the default functionality for a variety of general behaviors in the program.

- Check Warn Before Delete Selected Item if you want the program to require confirmation before an item is deleted.
- Check Ignore Casing for Opening Resize to allow wall openings such as doors to be positioned against an intersecting interior wall. Clear this box retain sufficient space for the opening’s specified interior trim width. Not available in layout files.
- Check Allow Editing in Select Home Designer Products to allow limited editing of the current file in other compatible Home Designer programs. See “Compatibility with Other Programs” on page 39.
- Check Show Pitch as Degrees to display the roof pitch in degrees. Not available in layout files.

The Arrow Key Scroll Distance setting determines how far to scroll in plan view when you press an arrow key. The initial default is 12 inches (300 mm). Not available in layout files. See “Using the Arrow Keys” on page 97.

Specify the Allowed Angles used when Angle Snaps are enabled. See “Angle Snaps” on page 101.

- Select 15 Degrees to enable Angle Snaps in 15° increments.
- Select 7 1/2 Degrees to enable Angle Snaps in 7 1/2° increments.
- Check Additional Angles and enter up to eight custom Allowed Angle values. Click the Number Style button to specify the format used to enter angles in dialogs. See “Dialog Number/Angle Style Dialog” on page 82.

The Snap Grid allows you to snap objects to specific points on-screen as they are moved or resized. See “Grid Snaps” on page 102.
Preferences Dialog

The settings in the Preferences dialog are global: they apply to all plan and layout files and are preserved between sessions. To access this dialog, select Edit> Preferences in Windows® or Chief Architect> Preferences in macOS™. Unlike most dialogs in the program, it is not necessary to have a plan or layout file open to access the Preferences dialog.

The Preferences dialog’s list of panels is organized in a tree structure with categories and subcategories. A white arrow next to a category indicates that it has subcategories. Click the arrow to make the subcategories visible or to hide them.

Preferences dialog panels:
- Appearance Panel
- Colors Panel
- Font Panel
- Library Browser Panel
- Text Panel
- General Panel
- File Management Panel
- Folders Panel
- New Plans Panel
- Unit Conversions Panel
- Architectural Panel
- CAD Panel
- Edit Panel
- Behaviors Panel
- Snap Properties Panel
- Materials List Panel
- Report Style Panel
- Master List Panel
- Render Panel
- Video Card Status Panel
- Reset Options Panel

Preferences Dialog

- Check Use Snap Grid/Units to enable Grid Snaps.
- Specify the Snap Unit you wish to use. The initial default is 1 inch (10 mm).

It may be helpful to temporarily change the Snap Unit when working with large objects such as terrain.

- Uncheck Show Snap Grid to turn off the display of the Snap Grid, a visual indicator of the location of the snap points.
- Click the Color bar to specify the Snap Grid Color. See “Select Color Dialog” on page 117.
- Check Display as Dots to display the Snap Grid using dots rather than lines.

4 Specify the display of the Reference Grid.
- Check Show Reference Grid to display the Reference Grid, the virtual graph paper used to create a sense of scale in plan view.
- Specify the Reference Grid Size.
- Check Display as Dots to display the Reference Grid using dots rather than lines.

You can also click Grid Snaps toggle button to turn on/off grid snapping or click the Display Reference Grid toggle button to turn on/off the grid display.

5 Specify how the Living Area label is calculated and whether it displays in plan view. Not available in layout files. See “Living Area” on page 232.
- Select Main Layer to have the Living Area calculation measure from the walls’ Main Layer.
- Select Surface to have the Living Area calculation measure from the walls’ exterior surface.
- Uncheck Show “Living Area” to disable the display of the Living Area label.
Check **Contextual Menus** to activate contextual menus that display when you right-click. See “Contextual Menus” on page 30.

- **Check Click Twice to Display** to require two right-clicks on an object before the contextual menu displays. This allows the first right-click to be used for object selection. See “Selecting Objects” on page 123.

In 3D views, the two clicks must be on the same object surface in order for the contextual menu to display: Clicking on two different surfaces of the same object is treated like two single-clicks.

Check **Status Bar** to activate the Status Bar at the bottom of the main program window. See “The Status Bar” on page 33.

- **Check Show Screen Redraw Time** to display the number of seconds it takes to redraw the current view.

- Check **Show Coordinates** to display the coordinates of your cursor at all times on the right side of the Status Bar.

The coordinates’ number style is controlled in the **Number Style/Angle Style** dialog. See “Dialog Number/Angle Style Dialog” on page 82.

Specify the on-screen display of **Line Weights**. See “Line Weights” on page 716.

- **Check Show Line Weights** to represent line weights on-screen. Depending on your zoom factor and your monitor’s resolution, lines may appear to be wider on screen than when they are printed. Zooming closer may reflect a more accurate idea of the actual line width.

- Specify the **Minimum Display Weight**, in Pixels. This is the lowest line weight possible on screen, regardless of how far you zoom out. A Minimum Display Weight of 0 is the same as 1. This setting
is ignored when printing or when Print Preview is enabled.

4 Display -

- **Images and Pictures** - Check Display in Color when Possible to display pictures and images in color even when Color on is toggled off. Does not affect the display of images in any 3D views aside from Vector Views. See “Color On/Off” on page 114.

- **Menus** - Check Show Icons to display tool icons next to items in the menus.

- **Color Off is** - Specify whether views appear in Black and White or Grayscale when color is toggled off. Does not apply to any 3D views aside from Vector Views. See “Vector View” on page 595.

Specify whether Dialog Previews use the Standard or Vector View Rendering Technique by default. See “Dialog Preview Panes” on page 32.

Specify how Toolbars present child tools when a parent button is clicked.

- Choose **Parent-Child** to display child tools as buttons at the end of the toolbar where the parent button resides.
- Choose **Drop Down** to display child tools when the drop-down arrow to the right of the parent button is clicked.

5

6

7 Uncheck **Side Window Drag Docking** to prevent undocked side windows from docking when moved using the mouse. A side window can still be docked to its last docked location by double-clicking its title bar. See “View and Side Windows” on page 28.

- **Top/Bottom Docking** - Check the box beside a side window’s name to allow it to dock on the top and bottom edges of the program window. Does not affect docking to the left and right sides.

Specify the **Minimum Display Size** of Dimensions and Labels, in pixels. This is the on-screen size and does not affect printed or exported output. To use the printed scale, set these values to 0 or turn on Print Preview.

- Dimension sizes are set in the Dimension Defaults dialog. See “Dimension Defaults Dialog” on page 250.

8
Specify the **View Colors** for a variety of different elements in the software’s interface by clicking a color bar to open the **Select Color** dialog. See “Select Color Dialog” on page 117.

- **Background Color** for plan view. The background colors for 3D views can be set in their defaults and specification dialogs. See “Backdrop Panel” on page 578.

- **Layout Background** color, which is the background color in layout files. See “Layout” on page 695.

- **Selection Line** color, which is the color of the lines that represent object(s) and their edit handles when they are selected.

- **Handle Fill** color, which is the fill color of the edit handles for selected objects.

- **Selected Edge Handle Fill** color, which is the fill color of the edit handle on a selected object’s Selected Edge. See “Selected Edge” on page 123.

- **Selection Fill** color, which is the fill color for selected objects. Note that depending on the fill assigned to a selected object, its Selection Fill color may vary.

**Note:** If the Selection Line and Handle Fill Colors are similar, it may be difficult to distinguish between active and inactive CAD Points.

- **Editing Transparency**, which is the degree to which the selection fill and edit handles are transparent. The default value is 20%.
Specify the **Interface Colors** that you want to use in Home Designer Pro by selecting an option from the drop-down list:

- Select “System” to use your operating system’s color settings.
- In the Mac version of the software, select “Force Light” to use Light Mode in Home Designer Pro regardless of the system settings, or “Force Dark” to use Dark Mode in Home Designer Pro regardless of the system settings.
- Select “Custom Color Theme” to apply a color theme to the program interface and select its characteristics below.

The table and settings that follow are only available when “Custom Color Theme” is selected, above:

- The table lists all available Color Themes. Click on a line item to select and activate that color theme.
- Locked themes are installed with the program and cannot be modified or deleted.
- To create an unlocked theme, select any theme in the list and click the **Copy** button.
- Select an unlocked theme and click the **Rename** button to specify a new name.
- Select an unlocked theme and click the **Delete** button to remove the theme from the list.
- When an unlocked theme is selected, the settings below the table are enabled, allowing you to specify the colors for a variety of elements in the program interface.
- When **Toolbar Button/Image Backgrounds** is unchecked, toolbar buttons and images in dialogs use the Dialog/Toolbar Background color.

The program interface will update as you select different color themes or edit the selected unlocked theme’s color settings.

### Font Panel

The **FONT panel** controls the font used by dimensions in legacy plans when they are opened in Home Designer Pro 2021, as well as the font used in the **Materials List**.

1. **Specify the Fonts** for use in Legacy Dimension Conversion and Materials Lists.
   - Select **Legacy Dimension Conversion** from the list to specify the font used by dimensions in legacy files from Versions 7 to 10. See “Dimensions” on page 249.
   - Select **Materials Lists** from the list to specify the font used by Materials Lists and the Master List. See “Materials Lists” on page 681.

2. Sample text displays the selected font and font style.

For information about text in Home Designer Pro 2021 files, see “Text, Callouts, and Markers” on page 267.
Library Browser Panel

The LIBRARY BROWSER panel controls the appearance of the Library Browser window. See “The Library Browser” on page 509.

1. The View options control the display of the main sections of the Library Browser.
   - Check **Hide Selection Pane** to hide the pane that displays objects in a selected catalog or folder.
   - Check **Hide Preview Pane** to hide the pane that shows a preview of a selected object.

2. Selection Pane View options control how objects in the Selection Pane are presented.
   - Select **Tiled to Fit Window** to display all items in a catalog or folder. If there are many items, their previews may be very small to fit in the pane.
   - Select **Scrollable List** to display all items in the selected catalog or folder in a scrollable list. If there are many objects, the list may be long but each object preview will be sized to fit the pane.
   - Check **Show Names in Selection Pane** to display the names of the objects in the Selection Pane.

3. Preview Pane/Selection Pane Layout - Select a radio button to change the appearance of the Library Browser.
   - **Vertical** - Displayed sections of the Library Browser are divided vertically.
   - **Horizontal** - Displayed sections are divided horizontally.
   - **Stacked** - Displayed sections are divided both horizontally and vertically.

4. Specify whether selected library items in the **Preview Pane** are displayed using the **Standard** or **Vector View** Rendering Technique. See “Rendering Techniques” on page 595.

To restore the original size and position of the Library Browser and other side windows, click the **Restore Side Windows** button on the Reset Options Panel.

Text Panel

Text Specification Enter Key -

- Uncheck **Create New Line** to close the **Text** and **Rich Text Specification** dialogs when the Enter key is pressed. When this is checked, a new line of text is created when Enter is pressed and the dialog remains open.
Preferences Dialog

General Panel

1. When **Undo** is checked, the Undo and Redo commands can be used. See “Undo and Redo” on page 159.

- **Maximum Undos** - Specify how many levels of Undo and Redo you want available, from 1 to 100. Undo files are saved in the Undo Directory.

2. When **Check For Program Updates** is checked, Home Designer Pro will check for updates when the program is launched.

- By default, Home Designer Pro checks for program updates once a day when the program is launched. You can specify a different frequency, in days, if you prefer.

3. When **Show Options at Startup** is checked, the **Startup Options** dialog opens when Home Designer Pro is launched. See “Startup Options” on page 23.

4. **Troubleshooting** -

- Uncheck **Optimize for Multi-Core CPUs** to turn off program optimizations for multi core processors. This box is checked by default and should only be unchecked for technical troubleshooting purposes.

- Uncheck **2D Zoom and Panning Optimizations** to turn off program speed optimizations for zooming and panning in 2D views.

- Check **Record Timing Log** to have the program create an event timing log in the Hidden User Settings Folder for troubleshooting purposes. Unless you are actively troubleshooting program performance, this box should be unchecked.

Additional options are available in the Mac version of the software only:

- When **Mouse Movement Optimizations** is checked, zooming using the mouse scroll wheel is optimized for Mac systems. This box is checked by default and should only be unchecked when troubleshooting issues with the mouse scroll wheel in the Mac version of the software.

- Use the **Mouse Scroll Sensitivity** scroll bar or text field to control how sensitive the mouse scroll wheel is when zooming using the mouse scroll wheel in the Mac version of the software.

5. Specify when the program should **Save Dialog Size and Position**: **Always**, **Per Session**, or **Never**. See “Dialog Size and Position” on page 31.

- Check **Open Dialogs to the Last Panel Visited** to open paneled dialogs to the last panel that you accessed during the current program session. When unchecked, dialogs always open to the first panel. See “Dialogs” on page 30.

6. Specify how window sizes in **Room Planner Imports** are measured. See “Import Room Planner File” on page 625.
• Check **Measure Windows from Inside of Frame** to measure window heights and widths from the inside of the frame. When unchecked, window sizes are measured from the outside of the window frame, as they are in the **Window Specification** dialog in Home Designer Pro. See “General Panel” on page 316.

**File Management Panel**

The settings on the **FILE MANAGEMENT** panel let you modify functions related to the program’s plan and layout file management.

1. Check **Auto Save**, then enter a value greater than zero in the text field to specify the frequency in minutes that Auto Save files are created. Auto Save files are stored in the Archive folder. See “Auto Save Files” on page 46.

   - Even with Auto Save active, you should frequently save your work to the hard drive by selecting File> Save.

2. **File Locking** - Choose whether or not to lock .plan and .layout files when they are open. File Locking prevents another program or copy of Chief Architect software from opening and modifying the same file at the same time and is recommended in nearly all circumstances.

   - Select **Use File Locking** to lock files.
   - Select **Disable File Locking** to disable this feature.

3. Specify the maximum size and location of the **Recent File List**.

4. Check **Thumbnail Images** to automatically create thumbnail images of files that display when opening or searching for saved files. If this option is disabled, you can still create thumbnails manually. See “Thumbnail Images” on page 45.

   - Select either **Small** or **Large** thumbnails. Large thumbnails provide a higher quality image but result in larger file sizes.

5. When **Copy Externally Referenced Material Files to My Data Folder** is checked, the program automatically makes a copy of the material texture files associated with any custom materials that you create in your Home Designer Pro 2021...
Data folder. This can help prevent these files from becoming lost if the originals are deleted. See “About Materials” on page 540 and “Home Designer Pro Data” on page 40.

6 Click the **Associate Files With This Program** button to direct your computer’s operating system to associate all .plan, .layout, .calib, and .calibz files with Home Designer Pro 2021. This button will not be active if plan, layout, and library files are already associated with this program and version. See “File Association” on page 39.

### Folders Panel

Home Designer Pro stores many support files in various folders on your computer. The default locations of these directories are listed and can be redefined on the FOLDERS panel if necessary.

You do not need to change default locations under normal circumstances, but sometimes it may be preferable to locate certain files in another location.

- Important user-specific information is stored in the **Home Designer Pro 2021 Data** folder, which is located in your Documents directory by default. See “Home Designer Pro Data” on page 40. If you specify a new location, any custom toolbars or other settings that you may have will not be copied to the new location: you can do this yourself if you wish.

- The **User Library Folder** contains custom library objects saved in the User Catalog in the Library Browser. When **Keep User Library and Referenced Files in Data Folder** is checked, this folder’s location will update if you specify a new location for the Data folder, above. When this is unchecked, this folder will remain in the location specified below. If you specify a new location, the program will automatically copy your existing User Library content as well as your Backdrops, Images, Patterns, and Textures folders to the new location. See “The User Catalog” on page 515.

- By default, **Temporary** files and **Undo** files are stored in the same folder. If you wish to use a different folder, you must specify a directory on a hard drive with sufficient space to hold these files. See “Undo and Redo” on page 159.

---

![Preferences Dialog](image)

Make sure that the location you specify is accessible and has adequate space for the files in this folder. See “Data Folder Name and Location” on page 41.
• Home Designer Pro will not let you save your work in the Temporary or Undo folder, or open files saved in either location.

• All library content aside from your User Catalog is stored in the System Library Database Folder. By default, this folder is created in the directory intended for shared application data in your operating system (C:\ProgramData in Windows;/Library/Application Support in macOS). If you specify a new location, the program will automatically copy your library content to that location. See “Library Content” on page 514.

If you choose to use a different folder, you must specify a directory on a hard drive with sufficient space to hold these files.

• All Program Paths - Click the Show button to open the Program Paths dialog, where you can find the location of files that may be needed for troubleshooting purposes. See “Program Paths Dialog” on page 736.

New Plans Panel

Open/Save As Directory - Control how the program behaves when a new plan is opened or an existing plan is saved.

• Use Last Directory refers the program to the directory last used to save or open a plan file.

• Use This Directory refers the program to a particular location specified by you.

• Click the Browse button to define a particular directory when Use This Directory is selected.

Unit Conversions Panel

In many places throughout Home Designer Pro, you can specify the size of an object with any Length unit listed on the UNIT CONVERSIONS panel. Using the data on this panel, the program will convert your entry into the unit set in the Dialog Number/Angle Style dialog. See “Dialog Number/Angle Style Dialog” on page 82.

These conversions are also useful when you import drawings. When an object is drawn in a Home Designer Pro plan file, it is always at its true, unscaled size and the drawing is only scaled when you print it. This means that if you import a scaled drawing, you must compensate for its scaling by creating a custom unit of measurement. See “Import Drawing Assistant” on page 626.

The default unit conversions are locked and cannot be changed, but custom conversions can be added to the list and later modified.
A list of available units of measurement displays here. Click on the name of a unit to select it.

- **Add**, **Edit**, **Delete**, or **Copy** the unit conversions. Certain unit conversions are locked and cannot be edited or deleted.

If you click **Add**, **Edit** or **Copy**, the **Add Unit Conversion** dialog displays.

The **Sample** area shows how the unit selected above converts to a selection of similar units. You can use this to verify that any unit conversion you add is correct.

### Add Unit Conversion Dialog

1. **Unit Name** - Type a short, descriptive name of the new unit. Names must be unique: the names of units installed with the program cannot be used.

   Names can include any characters, as well as spaces. Bear in mind, though, that names of units for measuring length that have numbers in them may be unusable if entered in some dialogs in the program.

   Check **Default Unit** to display this new unit in places that present lists of available units. For example, if you have inches as units and make inches a default, inches appear on the list when you are given a choice of units, such as in the **Import Drawing Assistant**. In other places, such as the Materials List, all units are listed.

2. **Measurement Type** specifies what the new unit measures. Select the appropriate radio button: **Length**, **Area**, or **Volume**.

3. **Conversion** -

   - Specify how much to **Multiply by** your custom unit to **convert to** the unit you select from the drop-down list. A measurement type must be selected before the list is populated.

4. A **Sample** of the Unit Conversion defined above displays here.
To create a new unit of measurement

When importing a drawing with a 1” = 20’ scale, for example, create a unit to convert this scaling to 1” = 1”.

1. Click the Add button to open the Add Unit Conversion dialog.
2. Type a short, descriptive name like “convert 1:20” in the Unit Name field.
3. Because this unit will be used only for scaling conversion, including numbers in its name will not cause any issues.
4. Select Length as the Measurement Type.
5. Type 20 in the Multiply by field.
6. Select “ft” from the drop-down list.

6. Click OK to close the dialog.

Architectural Panel

[Image of architectural panel]

1. Select the desired default behaviors for selected Walls.
   - Check Show Same Wall Type Handles to display edit handles on selected walls that draw new walls of the same type when dragged. See “Same Wall Type Edit Handles” on page 202.
   - Check Select Room Before Wall in 3D to select the room defined by a wall when you click on the wall in 3D views. See “Selecting Rooms” on page 229.
   - Check Turn on Connect Island Rooms When Opening Legacy Plans to automatically connect “island” rooms an Invisible wall in legacy plans opened in Version 2021. See “Room Definition” on page 225.

2. Opening Appearance - Specify the appearance of opening indicators on cabinets, doors, and windows. See “Displaying Cabinets” on page 341, “Displaying Doors” on page 290, or “Displaying Windows” on page 313.
   - Select Opening Indicators Point to Hinge Side for opening indicators that point to the hinge side of the opening.
   - Select Opening Indicators Point to Handle Side for opening indicators that point to the handle side of the opening.

3. Check Stair Sections Move Independently to allow stair sections connected by landings to move separately, without moving the entire staircase. See “Editing Stairs and Ramps” on page 400.

4. Uncheck Enable ‘Show Room Label’ Automatic Behavior When Changing Room Types to prevent a room’s label from displaying when an “Unspecified” room is assigned a different...
Room Type in its Room Specification dialog. When this box is checked, the room label’s display will be enabled when the Room Type is changed from “Unspecified”. See “General Panel” on page 240.

Check **Automatically Place Roof Intersection Points** to automatically generate temporary CAD points that correspond to roof plane intersection points. When unchecked, these temporary points are not created. See “Locating Intersections” on page 440.

**CAD Panel**

The CAD panel controls whether or not objects snap together to form polylines and objects that behave like polylines. See “Polylines” on page 176.

**Options -**

- Uncheck **Connect CAD Segments** to prevent CAD objects from snapping together to form polylines as they are drawn or edited. See “Connect CAD Segments” on page 122.

**Note:** Unlike other Preferences, the program always resets Connect CAD Segments to be on whenever you close the program.

- **Endcap Printed Length** - The beginning and end of CAD lines that use a dashed line style are sometimes difficult to distinguish. Endcaps can be placed to eliminate this problem. Specify the printed endcap length in inches (mm).

- Uncheck **Show Same Line Type Handles** to turn off the display of these edit handles on selected CAD objects. See “Same Line Type Edit Handles” on page 168.

**Sun Angle** - Define the default **Latitude**, **Longitude** and **Time Zone** used when creating Sun Angles. See “Sun Angles and Shadows” on page 590.

**Edit Panel**

The settings on the Edit panel of the Preferences dialog control the appearance of the cursor and selection behavior of edit handles. See “Using the Mouse Pointer Crosshairs” on page 143.
You can use a cursor with Crosshairs in different view types and control its appearance. See “Crosshairs” on page 27.

- Check Enable in Plan and Cross Section/Elevation Views to use a cursor with crosshairs in plan and cross section/elevation views. This option is checked by default.

- Check Enable in Perspective Views to use a cursor with crosshairs in perspective camera views and overviews.

- When Synchronize with Cursor is checked, the mouse pointer and crosshairs always move together on screen. If you feel that they do not keep up with your mouse movements, try unchecked this option.

- Click the Color bar to open the Select Color dialog and specify the color of the crosshairs.

- Crosshair Size is specified as a percentage of the view Window Width. Specify the Size as 100% to extend the crosshairs across the entire screen.

- Set the Aperture Size, measured in pixels. The aperture is the space where the crosshairs meet. A value of 0 makes the crosshairs meet at a point. Larger numbers leave a gap in the center.

Specify the desired Selection settings, which affect how objects are selected and their appearance.

- Enter an Edit Handle Size in pixels. The edit handles are twice this number of pixels plus one. For example, the default value is 4, which results in a handle that is 9 x 9 pixels (4 x 2 = 8, and 8 + 1 = 9). The minimum value is 1, which results in a handle that is 3 x 3 pixels.

- Enter a value, in pixels, for Edit Handle Tolerance to specify how close to an edit handle you must click in order to select it. The default value is 0.

- Check Show Start and End Indicators to display an S and an E at the start and end points of a selected wall or the selected edge of a CAD-based object. This can make it easier to edit the selected edge in the object’s specification dialog. See “Selected Edge” on page 123.

Specify program behavior when using Marquee Selection to select objects. See “Marquee Select” on page 125.

- Choose Select Intersected Objects to select any objects whose bounding boxes are intersected by or located within the marquee.

- Choose Select Contained Objects to select only objects located entirely within the marquee. This option provides the best results in most situations.

- Choose Select Objects by Center to select only objects whose center points are located within the marquee.
Behaviors Panel

The settings on the BEHAVIORS panel of the Preferences dialog define basic editing behaviors of CAD and architectural objects.

1. **Rotate/Resize About** defines the point about which an object or a group of objects rotates or resizes. See “Rotate/Resize About” on page 100.
   - Select **Object Center** to rotate or resize the selection about its center point. Object Center is the default setting.
   - Select **Current Point** to rotate the object about the current CAD point instead.

To resize a CAD object about a current point, select the **Resize** Edit Type.

This function can also be accessed by selecting **Edit > Edit Behaviors > Resize**. See “Defaults, Preferences, and Edit Behaviors” on page 119.

- **Rotate Jump** defines the angles an object or group of objects jumps to as it is rotated. When this value is set to 0°, the Allowed Angles set in the Plan Defaults dialog are used; otherwise, Allowed Angles are ignored.

Box rotating about Current Point with Jump set to 45°
The **Primary Movement Methods** control the directions that you can move objects using their edit handles.

- Select **Orthogonal** to move an object perpendicular to any of its edges.
- Select **Polar** to move an object at Allowed Angles.

Select one of the five **Edit Type** radio buttons. For detailed information about the different edit types and how they affect different objects, see “Defaults, Preferences, and Edit Behaviors” on page 119.

- If **Concentric** is selected, specify the desired **Jump** increment.
- Uncheck **Behavior Indicators** to turn off the display of the mouse pointer icons associated with these Edit Behaviors. This box is checked by default.

### Note: Unlike other Preferences, the program always restores the Default Edit Behavior whenever you close the program.

---

**Snap Properties Panel**

The settings on the Snap Properties panel of the Preferences dialog control the behavior of Object Snaps as well as the appearance of snap indicators. See “Object Snaps” on page 101.

![Preferences Panel](image)

**Options** -

- **Snap Distance**, which is how far the cursor can be from a snap point for the snap to occur. This value is measured in screen pixels; the default value is 12.

  When working with very small objects, you may find it helpful to reduce this value; when working with very large objects, it may be helpful to increase it.

  This setting also controls the minimum length of camera and cross section/elevation lines of sight. See “Creating Camera Views” on page 562.

- Specify the **Maximum Bump Distance**, which is the distance that a selected object must be dragged to override bumping and move past an obstructing object.

**Control the appearance of Snap Indicators.**

- Specify a snap **Indicator Size** in pixels. This setting also controls the size of temporary CAD Points. See “Place Point” on page 163.
Click the color bar to select a snap **Indicator Color** from the **Select Color** dialog. See “Select Color Dialog” on page 117.

Enable any combination of **Object Snaps**. You can also turn these options on or off with the toggle buttons on the toolbar or using keyboard hotkeys.

- **Check Object Snaps** to enable the object snap options, below.

  - **Endpoint** enables snapping to the ends of lines, arcs, splines and other objects.
  
  ![Endpoint and Midpoint snaps](endpoint.png)

  - **Midpoint** enables snapping to the midpoint of an object such as a line or arc. For objects such as boxes, you can snap to the midpoint of any side of the box.

  ![Quadrant snaps](quadrant.png)

  - **Center** enables snapping to the center of cabinets, fixtures, furniture, as well as circles and arcs.
  
  ![Quadrant snaps](center.png)

  - **Quadrant** enables snapping to the left, right, top, or bottom of an object. Only used for arcs and circles.
  
  ![Quadrant snaps](quadrant.png)

  - **On Object** enables snapping to any point on the selected object, including CAD objects and cabinets.
  
  ![On Object snaps](onobject.png)

- **Points/Markers** allows you to snap to any temporary points you may have placed, as well as callouts and markers.

![Points/Markers snaps](pointsmarkers.png)

- **Intersection** enables snapping to the intersection of two objects, such as the intersection of a line with another line. Intersection snapping also snaps extension lines to objects, and allows you to snap two extension lines to each other.

![Intersection snaps](intersection.png)

When Intersection snapping is enabled, wall extension line snapping will also occur. See “Creating Walls” on page 193.

- **Control the behavior of Other Snaps**.

  - **Check Bumping/Pushing** to allow objects to bump into and move other objects. See “Bumping/Pushing” on page 142.
  
  ![Bumping/Pushing for Type-in Movement](bump.png)

  - **Check Bumping/Pushing for Type-in Movement** to cause objects moved using dimensions to bump into objects in their path of movement and stop. When unchecked, objects moved using type-in methods move to their specified destination locations. See “Moving Objects” on page 141.

  - **Check Angle Snaps** to enable snapping to Allowed Angles. See “Angle Snaps” on page 101.

### Materials List Panel

The settings on the **Materials List** panel control which categories are included in Materials Lists. The names of all categories and their ID prefixes are listed here. They are defined by the program and cannot be changed. See “Materials Lists” on page 681.
When a material is entered in the Materials List, the program decides what category it goes in and assigns it an ID, which is the prefix followed by a number. EX1 would be the first exterior trim piece entered in the Materials List for a particular plan.

- **Include These Categories** - Check the categories you want to include in every new materials list generated. Before you hide a category, make sure you know what items are listed within it.

- Click **Select All** to check the boxes beside all categories, or click **Clear All** to clear the check boxes beside all categories.

  It is usually better to remove categories from individual plan lists in the Layer Display Options dialog, rather than globally. See “Layer Display Options Dialog” on page 111.

**Report Style Panel**

The REPORT STYLE panel controls the appearance of Materials Lists and the Master List.
Include These Columns - Check the box beside each column to include it in newly created Materials Lists. Columns can also be specified for an individual Materials List by choosing Tools> Edit Active View while that Materials List is active. See “Materials List Specification Dialog” on page 685.

- Use the Move Up and Move Down buttons to change the order that columns appear. To change the order, select one or more items in the list and click the button. The selected columns move up or down by one in the list.

When Querying Suppliers and Manufacturers - Select an option to narrow or broaden your query when searching the Master List.

Choose whether or not Grid lines display in the Materials and Master Lists, both on-screen and printed.

- Check Horizontal Lines for lines between Materials List rows.
- Check Vertical Lines for lines between Materials List columns.
- Check Solid Lines for a solid line style. When unchecked, dotted lines are used.

When Custom Colors is checked, Materials Lists use the colors defined below. When this is unchecked, either the colors associated with the active Color Theme or your operating system’s default colors are used. See “Colors Panel” on page 64.

Background Colors can be specified for Odd and Even numbered rows.

Specify the Text Font Size, which is the height of the font used in the Materials List and Master List. See “Editing Materials Lists” on page 687.
Master List Panel

The MASTER LIST panel specifies how the Master List(s) for materials appears. You can maintain Multiple Master Lists, but only one may be used at any given time. See “Materials Lists” on page 681.

1 Include These Columns - Check each column to include it in the Master materials list.

Use the Move Up and Move Down buttons to change the order of columns. To change the order, select one or more items in the list and click the button. The selected columns move up or down by one in the list.

2 Master List File - The name and pathname of the currently referenced Master List is shown. It is referenced for all subsequently opened plans when a materials list is generated.

- Click the Browse button to select a different Master List. Navigate the directory structure until you find the new Master List to be used, select it, and click OK.

Note: If the Master List file is saved in the program Data folder, and the location of My Data Folder is changed, this pathname will automatically update. See “Folders Panel” on page 69.

- Click the New button to create a new Master List. Name and save it in the location of your choice. When you create a new Master List, it is blank until you build a materials list and enter prices, supplier or manufacturer information. The Master List is saved automatically when you close.

Render Panel

The settings on the RENDER panel control how 3D views are generated and navigated.
General Options -

- **Horizon Lines** are lines that generate along the curved edges of symbol objects in Vector Views. Uncheck this box to increase the speed of Vector View generation but also suppress these lines. See “Vector View” on page 595.

- **Hardware Edge Smoothing** uses the video card to reduce the jagged appearance of angled surface edges and pattern lines, producing cleaner lines. The higher the smoothing effect, the longer the rendering time. See “Edge Smoothing” on page 584.

The **3Dconnexion® 3D Mouse and Gamepad** settings affect how 3D mice and gamepads function in Perspective 3D views. See “3Dconnexion® 3D Mice” on page 567.

- Select **Navigate about Camera** to center mouse movement about the location of the camera.

- Select **Navigate about Camera Focal Point** to center mouse movement about the location of the camera’s focal point. See “To create a camera view” on page 562.

The **Troubleshooting** settings can be used to troubleshoot performance in 3D views.

- Uncheck **Use Enhanced Lighting** to disable most lighting effects in Rendering Techniques that support lighting. This box is checked by default and should only be unchecked for troubleshooting purposes. It may become unchecked automatically if the program detects a problem with your video card. See “OpenGL and Hardware” on page 557.

- Uncheck **Use Global Illumination** to disable lighting effects in the Physically Based Rendering Technique. This box is checked by default and should only be unchecked for troubleshooting purposes. See “Physically Based” on page 596.

- When **Texture Compression** is checked, material textures are compressed so that less video memory is required when a 3D view is generated. Texture Compression takes time, however, so view generation will typically be slower.

Video Card Status Panel

The **VIDEO CARD STATUS** panel displays information about your video card, including the vendor and whether the minimum required OpenGL version is supported. See “OpenGL and Hardware” on page 557.

This information may be important if you are having problems generating 3D views.

Reset Options Panel

In order for some of the Reset Options to take effect, you will need to restart Home Designer Pro.
• If message boxes have been suppressed, you can make them display again by clicking Reset Message Boxes. See “Message Boxes” on page 33.

• Click the Reset Dialog Sizes button to restore all dialog boxes to their original sizes and positions. See “Dialogs” on page 30.

• Click the Reset Toolbars button to reset all toolbars to their original states. If you are encountering warning messages regarding toolbars, this option may resolve the issue. Note that any custom toolbar configurations that you may have created will be discarded if you click this button. See “Creating Custom Toolbar Configurations” on page 88.

• Click the Reset Side Windows button to restore all side windows to their original sizes and positions. Tool Palette Settings are also reset, as are the panes in the Library Browser. See “Side Windows” on page 28.

• Home Designer Pro retains a list of locations where you have located missing files in the past. If you find that the program takes a long time searching before informing you that files are missing, you can click the Reset Search Folders button to clear this list. See “Referenced Files” on page 48.

• Click the Reset Migration button to be prompted to migrate your content and settings from an older program version the next time you launch the software. See “Migrating Content and Settings” on page 14.

• Click the Reset Preferences button to restore all preferences to those originally installed with the program.

Dialog Number/Angle Style Dialog

At the bottom of many dialogs, you can click the Number Style button to open the Dialog Number/Angle Style dialog.

The settings in this dialog are global and control the format of distances, coordinates and angles of angles in dialog boxes and inline text fields, as well as in the Status Bar. See “The Status Bar” on page 33.

These settings control the format of values used in dialogs but do not limit how you must enter these values. For example, if you set your Number Style to use Inches, values will display using fractional inches. You can, however, enter values using decimal inches, inches and feet, or even decimal feet by including the appropriate unit indicators. When the dialog you’re typing in updates, the value will be converted to fractional inches.
When Imperial units are used, the **Fractional Inches** and **Feet, Fractional Inches** options use fractional inches with denominators of 2, 4, 8 and 16. A few objects, notably text, dimensions, and floor, ceiling and wall structure layers can be sized using smaller fractions with larger denominators.

Angles can be displayed using one of four basic methods:

- **Degrees/Minutes/Seconds** - Measured counterclockwise from a line drawn horizontally to the right of the angle’s vertex. Useful for most drawing tasks. Select the level of accuracy that you require.

- **Quadrant Bearings** - Measured from a line drawn straight up from the angle’s vertex (i.e., North on a site plan). Useful for site drawings, Azimuth Bearings use degrees, minutes, and seconds in their measurements.

- **Pitch** - Defined as a ratio of vertical rise to horizontal run. In Imperial units, the run is always 12”; in metric units it is 1000 mm. Useful for roofs.

Quadrant and Azimuth Bearings are affected by the orientation of the North Pointer, if one is present in the current plan. See “North Pointer” on page 590.
Two of the most efficient ways to access Home Designer Pro’s tools and settings are the toolbars and keyboard shortcuts, also referred to as hotkeys.

Chapter Contents

- Toolbar Arrangement
- Customizing Toolbars
- Creating Custom Toolbar Configurations
- Toolbar Customization Dialog
- Hotkeys
- Gamepad Settings Dialog

Toolbar Arrangement

Home Designer Pro’s toolbars provide fast access to the program’s most commonly used tools and settings, and are organized so that related tools are grouped together and easy to find.

The toolbars that display in a given view depend on the view type. For example, the toolbars that are available in floor plan and 3D views are not available in Materials Lists.

Some toolbars are available in more than one type of view. If a tool cannot be used in that view, its icon will appear pale grey in color.

Many of Home Designer Pro’s tools are organized into families of related tools which can be accessed using either of two styles of toolbar interface: the Child Tool Palette or Drop Down tools. You can select the interface that you prefer in the Preferences dialog. See “Appearance Panel” on page 62.

You can turn off the display of toolbars entirely or turn them on again by selecting View > Toolbars.

Drop-Down Tools

Click on the arrow to the right of a button to display a drop-down list of related tools. For example, click the arrow to the right of the Window button to display a drop-down list of the other Window Tools.

The most recently selected tool displays in the toolbar.
Child Tool Palette

An alternative to Drop-Down toolbars is the Parent button and Child Tool Palette interface. Parent toolbar buttons have a blue triangle in the lower right corner. When you select a Parent button, its Child tools display in the Child Tool Palette. If the Child Tool Palette has been closed, it will open.

By default, the Child Tool Palette is docked on the left side of the program window; but it can be undocked and moved, as well as resized and closed, just like other side windows. See “Side Windows” on page 28.

As long as it is open, the Child Tool Palette will also display the members of a selected tool’s family when the Drop Down interface is active. If you select a tool that does not belong to a family, the previously selected tool’s family will continue to display in the Tool Palette.

When you click the Window Tools Parent button, for example, its Child buttons display in the Child Tool Palette.

Click the Settings button at the bottom of the palette to select how the tools within it are presented:

• Select Fit Palette to resize the palette so that it is one row wide.

• Select Grid View to display only the button icons of the child tools in a grid that may have multiple rows, depending on the width of the palette side window.

• Select List View to display child tools in a vertical list with each tool’s button icon and name in a row.

You can open the Tool Palette at any time, even when Drop Down tools are enabled, by selecting View>Tool Palette. See “View Tools” on page 96.

The Edit Toolbar

When you select an object, its edit toolbar opens. By default, it is located at the bottom of the program window, just above the Status Bar. The buttons on the edit toolbar can be used to edit the selected object(s). Which buttons display depends on the type of object selected, the current view, and how you selected the object.

Toolbar Configurations

Home Designer Pro installs a set of Toolbar Configurations, which control what tools are initially included in the toolbars, as well as where these toolbars are located.

• The Default Configuration displays architectural tools used for house design, including walls, windows, doors, stairs, cabinets, etc.

• The Terrain Configuration displays buttons associated with the terrain and road tools, including the plant and sprinkler tools. See “Terrain Toolbar Configuration” on page 637.

• The Space Planning Configuration displays buttons associated with the Space Planning Assistant. See “Space Planning” on page 51.

To switch toolbar configurations

There are several ways to switch from one Toolbar Configuration to another.

• Click a Toolbar Configuration button.

• Choose a configuration in the Toolbar Customization dialog. See “Configurations Panel” on page 91.

• Right-click in an empty space on any toolbar and select a Toolbar Configuration from the contextual menu.

Toolbar Button Size

By default, toolbar buttons are sized at 20 pixels, which works well on most computer monitors running default system settings. If you wish, you can increase or decrease this size in the Preferences dialog. See “Appearance Panel” on page 62.
Customizing Toolbars

The Toolbar Configurations installed with the program are designed to help make tools quickly and easily accessible; however, for greatest efficiency, you may want to customize them to meet your own particular needs. A number of options are available:

- Toggling toolbars
- Moving toolbars
- Adding buttons to existing toolbars
- Adding new toolbars

Any changes made to an existing Toolbar Configuration will be saved whenever you:
- Switch to a different configuration;
- Close the Toolbar Configuration dialog;
- Exit out of Home Designer Pro.

Bear in mind that the size of the Home Designer Pro program window and the space available for toolbar button depends on your monitor’s size and screen resolution settings.

### Toggling Toolbars

There are several ways to toggle individual toolbars on or off:

- Right-click in an empty space on any toolbar and mouse over Toolbars in the contextual menu. In the submenu, toolbars with a check mark next to their name are on in the current view. Click on a toolbar name to turn it off if it is on, or vice versa.

- Toolbars can be turned on or off in the Toolbar Customization dialog. See “Toolbars Panel” on page 90.

- If a toolbar is undocked, click the Close button at its top right corner.

You can turn off the display of toolbars entirely or turn them on again by selecting View> Toolbars.

Changes to toolbars are saved between program sessions.

### Adding and Removing Buttons

Toolbar buttons can be added to or removed from toolbars using the Toolbar Customization dialog.

**To add a button to a toolbar**

1. Select Tools> Toolbar and Hotkeys> Customize Toolbars and go to the TOOLS panel of the Toolbar Customization dialog. See “Tools Panel” on page 89.

2. Select the View Type that you want to add a toolbar button in.
   - You can add any buttons you like to any View Type; however, not all buttons will necessarily be available for use in all views.

3. Search or browse to find the desired button or its parent in the Available Toolbar Buttons list.

4. Click and drag the button you wish to add to a toolbar out of the dialog box.
   - Drop it onto an existing toolbar to add the button to that toolbar.
   - Drop it away from an existing toolbar to create a new toolbar. See “To create a new toolbar” on page 88.

To remove a button from a toolbar, open the Toolbar Customization dialog, then click and drag the button out of the toolbar area.

Buttons cannot be added to or removed from the Edit toolbar. See “The Edit Toolbar” on page 29.

### Adding and Removing Toolbars

Toolbars can be added to or removed from each View Type using either the toolbar contextual menu or the Toolbar Customization dialog.

**To add or remove an existing toolbar**

1. Right-click on an empty space in a toolbar.

2. In the contextual menu, click on the name of a toolbar.
   - If the toolbar has a check mark next to it, clicking on it will clear the check mark and remove the toolbar from the current View Type.
• If the toolbar does not have a check mark next to it, clicking on it will add the toolbar to the current View Type.

You can also specify which toolbars are used in each View Type in the Toolbar Customization dialog.
See “Toolbar Panel” on page 90.

Creating New Toolbars

New toolbars can be created using the Toolbar Customization dialog.

To create a new toolbar

1. Select Tools> Toolbar and Hotkeys> Customize Toolbars and go to the TOOLS panel of the Toolbar Customization dialog.
2. Select the View type to which you want to add a new toolbar.
3. Select the first button that you want on the toolbar from the Available Toolbar Buttons list.
4. Click and drag the button out of the dialog box and drop it:
   • In an empty section of the program window border to create a new toolbar docked at that location.
   • In the drawing area to create a new, undocked toolbar.
5. Additional buttons can be added by dragging them onto to this new toolbar.

6. A new toolbar will inherit the name of the first tool that was added to it, preceded by the word Custom. You can assign a new name on the TOOLBAR panel of the Toolbar Customization dialog.
7. Also on the TOOLBAR panel, specify the View Types that the new toolbar should be used in.

Locking Toolbars

When your toolbars are organized the way you want them, you can select Tools> Toolbars> Lock Toolbars to prevent them from being moved. Select the same tool to unlock toolbars. Lock Toolbars is also available in the contextual menu for toolbars: right-click in an empty space on any toolbar to access it. See “Contextual Menus” on page 30.

Restoring Toolbars

To discard your changes and restore all installed Toolbar Configurations to their original condition, click the Reset Toolbars button in the Toolbar Customization dialog. See “Toolbar Panel” on page 90.

Because resetting toolbars affects all installed Toolbar Configurations, you may find it worthwhile to create your own custom Toolbar Configurations.

You can also restore toolbars to their original state in the Preferences dialog; however, please note that if toolbars are restored using this option, any custom configurations that you have created will be discarded. See “Reset Options Panel” on page 81.

Creating Custom Toolbar Configurations

If you extensively edit your toolbars, consider creating one or more custom Toolbar Configurations so that your changes can be backed up as well as transferred to a different computer if you wish.

To create a custom configuration

1. Go to the CONFIGURATIONS panel of the Toolbar Customization dialog.
2. Select a configuration similar to the one you want to create and click Copy.
3. Give the new configuration a short, unique name. It will be saved in the Home Designer Pro Toolbars folder. See “Home Designer Pro Data” on page 40.
4. When you click OK, the new configuration will appear in the list, and it will be active.
5. On the TOOLBARS panel, select each of the different View Types to see the toolbars active in each and confirm that they suit your needs.
6. You can now move toolbars, add or remove buttons, and add or remove toolbars to meet your requirements.
7. When you are satisfied with your new Toolbar Configuration, click Close.

It is a good idea to back up your custom Toolbar Configurations files. See “Home Designer Pro Data” on page 40.
**Custom Configuration Buttons**

By default, new Toolbar Configurations display a default configuration button; however, if you want you can make your own button icon for your custom Toolbar Configuration.

Create a .bmp file with the same name as the configuration and save it in the Toolbars folder. To see an example, look at the Default.bmp file in the Home Designer Pro Toolbars folder, which corresponds to the Default Toolbar configuration. See “Home Designer Pro Data” on page 40.

- Toolbar button bitmaps must be 20 x 20 pixels in size.
- The color (R:192, G:192, B:192) maps to the system 3D face color.
- The color (R:128, G:128, B:128) maps to the system 3D Shadow color.
- The color (R:223, G:223, B:223) maps to the system 3D light color.

**Importing Custom Configurations**

Toolbar Configurations can be imported into the program, allowing you to transfer custom configurations between computers as well as add backed up configurations to new installations.

To import a custom configuration

1. Go to the Configurations tab of the Toolbar Customization dialog.
2. Click Add.
3. Browse to the location of the toolbar you want to import.
4. Click Open. If the .toolbar file is not in the Home Designer Pro Toolbars folder, a copy of the file will be created there.

**Toolbar Customization Dialog**

Select Tools> Toolbars and Hotkeys> Customize Toolbars to open the Toolbar Customization dialog. You can also right-click in an empty space in any toolbar and select Customize Toolbars from the contextual menu.

In the Toolbar Customization dialog, you can:

- Add and remove buttons from toolbars.
- Specify which toolbars display in different view types.
- Select the active Toolbar Configuration.

**Tools Panel**

From the TOOLS panel, you can add or remove buttons from your toolbars, as well as create new toolbars.
Select the View Type that you would like to add toolbar buttons to. When the dialog is first opened, the selected View Type is that of the current view. If you select a different View Type, the toolbars associated with it will display behind the dialog for reference until you click the Done button.

The Available Toolbar Buttons display in a list that can be searched or browsed.

- Type a keyword or the name of a tool in the Search field. As you type, only buttons that match your search will display. When nothing is typed in this field, all buttons will display in the list.
- If a child tool matches your search, its parent will display in the search results. Click the arrow next to the parent’s name to see the child tools.
- The Available Toolbar Buttons list can be browsed using the scroll bar to the right.
- Click on a button in the list to display a description of that tool, below.
- Parent tools have an arrow to the right of their button icon in the list. Click on this arrow to display the child tools below the parent. See “Toolbar Arrangement” on page 85.

If you do not see a particular button in the list, it may be the child of a parent tool.

Tool Description - When a button is selected in the list above, a description of it displays here.

The TOOLBAR panel allows you to manage the use of individual toolbars.

When this dialog is first opened, the selected View Type is that of the current view. If you select a different View Type, the toolbars associated with it will display behind the dialog for reference until you click the Done button.

The Toolbars table displays the names of all available toolbars, along with the View Types in which they are in use.

- Select a toolbar by clicking on its name.
- Click to place a check mark in a column to add the selected toolbar to that View Type; click on check mark to remove it.
- Double-click on a toolbar in the Toolbar Name column to rename it. Toolbar names must be unique.
- Click Delete to remove the selected toolbar from the list. A deleted toolbar is no longer available in any View Type.
- Click Reset Toolbars to restore all the toolbars to their original configuration. See “Restoring Toolbars” on page 88.

Clicking the Reset Toolbars button removes all changes that you may have made to all installed Toolbar Configurations.
Hotkeys

The CONFIGURATIONS panel allows you to add, remove, and switch between Toolbar Configurations. See “Toolbar Configurations” on page 86.

A list of Toolbar Configurations displays here. Select a configuration before clicking the Remove, Copy, or Switch To buttons.

- Click Switch To to switch to the selected Toolbar Configuration, making it active. See “To switch toolbar configurations” on page 86.
- Click Copy to create a copy of the selected Toolbar Configuration.
- Click Remove to remove the selected Toolbar Configuration. This removes the configuration from the list but does not delete the configuration file permanently. If only one configuration is listed, it cannot be deleted.

The location of the Current Toolbars Folder displays below. See “Home Designer Pro Data” on page 40.

Hotkeys

Many Home Designer Pro tools have a keyboard shortcut, or hotkey, associated with them. If such a hotkey exists, it will display to the right of the tool’s name in the menu.

To use a hotkey, simply press the appropriate key or combination of keys on your keyboard instead of selecting the menu item or clicking the toolbar button. For example, press the Ctrl and Z keys at the same time to perform an Undo.

Note: If a key or key combination is in use as a system hotkey, it cannot be used as a program hotkey.

Create Hotkey List

A list of the hotkeys available to the current program user can be saved in .html or .xhtml format.

Select Tools> Create Hotkey List to open the Save Hotkey List File dialog, a standard Save dialog, and create a hotkey list that can then be opened in a web browser window and printed, if you wish.

Gamepad Settings Dialog

The Gamepad Settings dialog allows you to specify thumbstick behavior in Home Designer Pro. Select Tools> Customize Gamepad to open this dialog.

You can also specify whether navigation is centered about the location of the camera or its focal point in the Preferences dialog. See “Render Panel” on page 80.
Check Enable Gamepad to allow Home Designer Pro to recognize a gamepad on your system and enable the other settings in this dialog.

**Speed** - When Linear Acceleration is checked, camera acceleration is always directly proportional to the amount the thumbstick is pushed. When unchecked, acceleration is increased on a curve, allowing more precision on the low end, and more speed on the high end.

Specify the behavior of the **Left Thumbstick** in 2D and 3D views.
- When Change Camera Height When Moving in 3D, the left thumbstick can be used to change the camera height in 3D. Uncheck this to maintain a consistent camera height instead.
- Use the slider bar or text field to specify the **2D Sensitivity**, which controls how quickly the view pans in plan and elevation views.
- Use the slider bar or text field to specify the **3D Sensitivity**, which controls how quickly the camera moves in 3D views.

Specify the behavior of the **Right Thumbstick** in 2D and 3D views.
- When Invert X-Axis in 3D is unchecked, pushing the right thumbstick to the left rotates the camera to the left. When checked, pushing this thumbstick to the left rotates the camera to the right.
- When Invert Y-Axis in 3D is unchecked, pushing the right thumbstick to the up rotates the camera upward. When checked, pushing the thumbstick up rotates the camera downward.
- Use the slider bar or text field to specify the **2D Sensitivity**, which controls how quickly the view zooms in plan and elevation views.
- Use the slider bar or text field to specify the **3D Sensitivity**, which controls how quickly the camera rotates in 3D views.

Click the **Reset Thumbs** knob to restore the default Left and Right Thumbsticks settings on this panel.
The View and Window Tools let you control how views of your drawing are shown on screen, as well as toggle useful drawing aides on and off.

By default, Home Designer Pro uses a tabbed document interface. The name of the file and the type of view displays at the top of each view window in its title bar. If the view is saved, its name also displays.

### View Windows

In Home Designer Pro, there are several different types of views:

- **Plan Views**
- **3D Views**
- **Cross Section/Elevation Views**
- **Materials Lists**
- **Layout**

Each view displays in a view window. While multiple views can be open and display on screen, only one view window can be active at any given time. See “Working in Multiple Views” on page 94.

- **Plan, 3D, and Cross Section/Elevation Views** are found in plan files only. Each view window can show the model from a different perspective and display a unique set of information about it, making them useful for a variety of drawing tasks and print requirements.
- **Materials Lists** are found in plan views only and contain a list of objects found in the model along with their components and information like amounts and pricing.
- **Each layout file is composed of a single sheet in one view window.**

You can specify that any Camera, Cross Section/Elevation View, or Materials List be saved. See “Saving 3D Views” on page 575.

When a view is saved, all of its attributes are retained, including the:

- **Floor level**
- **Extents of the view**
- **Color toggle**

### Plan Views

Plan view is where most drawing and editing is done, and when you open a new plan file, a plan view is active. When an existing plan file is opened, the floor level, view extents, and Color toggle setting that were in use in the active plan view the last time the plan was saved will all be used.
You can create additional plan views for use during the current program session: select **Tools > New Plan View**. Each plan view that you create can show a different floor and have different view extents and Color setting.

### Rotate Plan View

To rotate everything in a plan view, including all objects on all floors, the Snap and Reference Grids, the plan’s Cartesian coordinates, and the drawing sheet, select **Tools > Rotate Plan View** to open the **Rotate Plan View** dialog.

Enter the degrees to rotate the plan view to using decimal units with either positive or negative values. The degrees rotated displays in ±180° format. For example, if you enter 270°, it displays as -90° when the dialog is reopened.

**Rotate Plan View** rotates a plan relative to its original orientation. For example, entering 90° twice results in a rotation of 90°, not 180°.

Text objects rotate with the plan unless you uncheck **Rotate with Plan** in the **Text Specification** dialog for each object. See “Rich Text Specification Dialog” on page 270.

The Rotate Plan View tool does not rotate objects; it literally rotates only your view of those objects. As a result, it does not alter the orientation of the plan in layout views or on the printed page.

### Closing View Windows

There are a number of ways to close view windows. See “Closing Views and Files” on page 98.

### Working in Multiple Views

Although only one layout file can be open at a time, there is no limit to the number of plan files that can be open, nor is there a limit to the number of view windows that can be open. The name of the file and the type of view is stated at the top of each view window in its title bar as well as in its tab. If the view is saved, its name displays instead of the view type.

By default, Home Designer Pro uses a tabbed document interface, which means that when more than one view window is open in the program window, each open window will have a tab that displays in a row above the currently active view.

- Each tab states the name of the file, the view type, and the view’s name.

- Each tab features an icon indicating its type of view.

- Click on a tab to make it the active view.

- If there is not enough room in the program window to display all tabs, left and right arrow buttons allow you to scroll through the tabs.

- Tabs can be reordered by clicking and dragging.

There is no limit to the number of 3D view windows that you can have open at a given time; bear in mind, though, that each window demands use of your computer’s resources and that you may see poor performance if too many views are open. See “3D Views” on page 557.

There are several ways to close a view window. See “Closing Views and Files” on page 98.

### Tiling Views

As an alternative to tabbed views, windows can instead be tiled. Tiling allows you to display multiple views in a single Home Designer Pro window so you can see the results of changes in plan view in 3D or vice versa. It can also be useful for copying objects from one plan to another.
There are several ways to create tiled views:

- Click and drag a view window’s title bar or tab into the part of the drawing area that you would like it to be. When a highlighted space is created, release the mouse button.

- Select Window> Tile Horizontally to display views in a horizontal orientation, one above the other.

- Select Window> Tile Vertically or press Shift + F6 on the keyboard to display views in a vertical, side by side, orientation.

Views are tiled left to right or top to bottom in the order in which they were last active: the most recent view is on the left or at the top, while least recent is on the right or on the bottom.

- To activate a view, click on its title bar or anywhere in the view window. Note that any changes you make in the active window are reflected in other views as well.

- To end window tiling, select Window> Tab Windows. You can also end tiling by double-clicking on the title bar of the program window.

Multiple Program Windows

To create a second program window, click and drag the title bar or tab of a view window completely out of the current program window: for example, onto a second monitor. A second Home Designer Pro program window will be created with its own menu and toolbars.

• Click on a view window’s tab.

• Select Window> Swap Views or press F7 to switch between the two most recent views.

• The Swap Views button toggles between the current view and the view that was current before it.

• Select Window> Select Next Tab or Window> Select Previous Tab to cycle through all open views in the order you prefer.

• In Windows, press the Ctrl + Tab (Next Window) or Ctrl + Shift + Tab (Previous Window) keys to cycle through all open views.

• On a Mac, press the Ctrl + } (Next Window) or Ctrl + Shift + { (Previous Window) keys to cycle through all open views.

• A list of all the views currently open is located at the bottom of the Window menu. Each view is identified by its name and what type of view it is. A check mark is beside the view that is currently active. Select one to go directly to that view.

If more than eight view windows are open, More Windows will be the last item in the Window menu. Select this option to open the Select Window dialog:

Select the name of a view in the list and click OK to make it the active view.

Note: The Window Menu Tools parent button can be added to the toolbars. See “Toolbar Customization Dialog” on page 89.
View Tools

The View Tools allow you to open and close the program’s side windows, as well as toggle a variety of references and drawing aids. Select the View menu to access these tools. You can also add the View Tools parent button to your toolbars. See “Adding and Removing Buttons” on page 87.

Refresh Display redraws the current window to clean up extra lines, show missing items, and correct random on-screen effects caused by changes to the model. See “Refresh Display” on page 114.

Library Browser opens and closes the Library Browser side window. See “The Library” on page 509.

Tool Palette opens and closes the Tool Palette, which will display related tools. See “Child Tool Palette” on page 86.

Status Bar displays or suppresses the Status Bar at the bottom of the program window. See “The Status Bar” on page 33.

Scrollbars displays and suppresses scrollbars on view windows. See “View Windows” on page 28.

Toolbars displays and hides the program’s toolbars. See “Toolbars and Hotkeys” on page 85.

Color toggles the display of color in the current view. See “Color On/Off” on page 114.

Reference Grid toggles the display of the Reference Grid in all views in the current plan or layout file. See “Grid Snaps” on page 102.

Temporary Dimensions toggles the use of Temporary Dimensions when objects are selected. See “Temporary Dimensions” on page 258.

Arc Centers and Ends toggles the display of Arc Centers and Ends in the current view. See “Arc Centers and Ends” on page 130.

Line Weights toggles the display of Line Weights in all views in which lines are drawn. See “Line Weights” on page 713.

Drawing Sheet toggles the display of the drawing sheet. See “Print Preview” on page 713.

Zoom Tools

Zoom is used to magnify any given area on the plan or 3D view. Select Window>Zoom, then click and drag a marquee around an area on screen. When you release the mouse, the selected area expands to fill the screen.

Note that in 3D views, using Zoom does not reposition the camera. This can lead to inconsistencies between a camera’s position and what is actually shown in the view if other methods of zooming are used later. See “Repositioning Cameras” on page 567.

When the zoom is complete, whatever tool was active prior to selecting the Zoom tool automatically becomes active again. If another zoom is needed, click the Zoom tool again.

Zoom In - Click to zoom in towards the screen center by a factor of two.

Zoom Out - Click to zoom out from the screen center by a factor of two.

Undo Zoom - Reverse the last zoom operation.

Fill Window - Fits all visible items on screen.

Fill Window Building Only - Fits all walls and railings on the current floor on screen.

Zooming With The Mouse Wheel

Use the mouse wheel to zoom in and out in all view windows. Scrolling the mouse wheel one click up or down zooms in or out, centering on the location of your pointer and changing the zoom by about 10%.

By default, zooming in 3D views changes the camera’s position. See “Mouse Scroll Wheel and Trackpad” on page 567.

Note: Depending on the configuration of your mouse, it may be necessary to hold down the Ctrl key while turning the mouse wheel.
Undo Zoom

Select Window > Undo Zoom to reverse the last zoom operation.

Note: Undo and Redo do not affect zoom.

Fill Window

In plan view or a cross section/elevation view, select Window > Fill Window or press the F6 key to view nearly everything on screen that is visible, including the Reference Display. CAD Points are the only objects that are not included when Fill Window is used.

If you are zoomed in so that only a portion of the drawing displays on screen, selecting Fill Window zooms out so that the entire view fits on the screen. If you are zoomed out so that the entire drawing is smaller than the screen, selecting Fill Window zooms in until the drawing fills the screen.

When the drawing sheet is shown, Fill Window zooms to the sheet borders.

Fill Window Building Only

Window > Fill Window Building Only is similar to Fill Window, but zooms in or out to so that all walls, railings, and roof planes in the view fill the current window. These objects are included in the extents of the view even if their layers are turned off. Other objects are ignored.

In 3D Views

Fill Window and Fill Window Building Only behave slightly differently in perspective and orthographic 3D views. In perspective views, the original zoom factor is restored, while in orthographic views the camera’s Field of View is adjusted so that all surfaces in the 3D view are included.

Panning the Display

There are four ways to pan the display without changing the zoom factor.

Using the Scroll Bars

One method is to use the scroll bars on the right and bottom edges of the window.

- Drag the square button in the bar itself in order to pan a larger distance.
- Click the end arrow keys on the scroll bars to shift the display in 12” increments.
- The 12” increment is defined in the Plan Defaults dialog under Inches Scrolled by Arrow Key. See “General Plan Defaults Dialog” on page 59.

Using the Arrow Keys

In plan view, the arrow keys on the keyboard work exactly like clicking the arrow buttons on the scroll bar. They shift the display according to the number of inches defined in the Plan Defaults dialog.

Using the Mouse

If you have a wheel mouse, you can pan the display by pressing the middle mouse button, or wheel, and moving the mouse in the direction you would like to pan. When the middle mouse button is held down, the pointer changes to a hand icon.

In the Mac version of Home Designer Pro, you can pan using the left mouse button and Option key. Mouse drivers sometimes have other functions assigned to the wheel and buttons. These override the Home Designer Pro setting.
Using a Mac Trackpad

In the Mac version of Home Designer Pro, you can two finger drag to pan the display. See “Trackpads” on page 27.

Using the Pan Window Tool

The Pan Window tool works much like the mouse wheel method. Choose Window> Pan Window. The pointer changes to a hand icon. Click and drag to pan the window. The program reverts to the previously active tool when you release the mouse button.

• Select Window> Pan Window. The pointer changes to a hand icon. Click and drag to pan the window. The program reverts to the previously active tool when you release the mouse button.

• Double-click the Pan Window tool and the command remains active.

Closing Views and Files

If a view is still needed, you can swap to a different view without closing it. If, however, a view is no longer needed, it can be closed. There are several ways to close a view window:

• Select File> Close View to close the active window.

• Press Ctrl + W or Ctrl + F4 on the keyboard to close the active window.

• Click the Close button in the active view’s title bar or in any view’s tab.

• A tabbed view can be closed by clicking on its tab using the middle mouse button.

• Select File> Close All 3D Views to close all currently open camera view windows instead of just the active window.

• Select File> Close All Views to close all currently open view windows instead of just the active window.

If a plan has only one view window open and you try to close it, the program will prompt you to save before closing if there are any unsaved changes. Edited cross section/elevation and saved plan views also prompt you to save before closing. See “Saving, Exporting, and Backing Up Files” on page 43.

Although the program warns you if you try to exit without saving, you should get in the habit of saving plan files before exiting.

Even if all view windows are closed, the program can still be open. See “Exiting Home Designer Pro” on page 49.
Chapter 7: Creating Objects

There are a wide variety of objects in Home Designer Pro that you can use to create complete 3D models and working drawings. Although these objects are sometimes very different from one another, the methods used to create them are similar.

Once an object is created, it can be selected and edited to meet the requirements of your project. The editing characteristics common to most objects are described elsewhere. See “Editing Objects” on page 119.

Architectural vs CAD Objects

There are two broad categories of objects in Home Designer Pro: architectural objects and CAD objects. CAD objects such as lines, arcs, text, and dimensions are 2D objects that can be created and edited in plan view and cross section/elevation views, and on layout pages but do not display in 3D camera views and overviews. See “The CAD Drawing Tools” on page 162.

In contrast, architectural objects such as walls, cabinets, doors, windows, and stairs display in 2D and 3D views. Architectural objects can be created and edited in 2D and 3D views but not on layout pages.

Some architectural objects, such as custom countertops and slabs, have some behaviors in common with CAD objects and are referred to as CAD-based.

Defaults and Preferences

The ways that objects in the program behave as they are created and edited are affected by a number of default and preference settings. See “Preferences and Default Settings” on page 57.

Snap Settings

Select Edit > Snap Settings to access the three categories of Snap Settings that determine how objects snap to one another and whether they snap to allowed angles or to points on a grid, as well as object bumping and pushing behaviors.

Object Snaps enable snapping to objects. See “Object Snaps” on page 101.

**Grid Snaps** enable snapping to the Snap Grid. See “Grid Snaps” on page 102.

**Bumping/Pushing** enables bumping and pushing behaviors. See “Bumping/Pushing” on page 142.

### Edit Behaviors

Select **Edit> Edit Behaviors** to access the six global edit behavior modes that determine how dragging the edit handles with the left mouse button affects a selected object and may also affect how objects are drawn.

The **Default** edit behavior provides the most commonly used editing options. See “Default” on page 120.

The **Alternate** edit behavior provides an alternative to the Default behaviors that may be more useful in some situations. See “Alternate” on page 120.

The **Resize** edit behavior scales an object as you drag a corner handle. See “Resize” on page 121.

The **Concentric** edit behavior allows you to resize objects so that the distance moved by each edge is the same as all other edges. See “Concentric” on page 121.

### Snap Behaviors

There are three categories of snap behavior in Home Designer Pro that affect how objects are created and how they can be edited:

- **Object Snaps**, which snap CAD and architectural objects to other objects.

- **Angle Snaps**, which snap objects at specific angles.

- **Grid Snaps**, which snap objects to points on a grid.

Snap behaviors can be controlled in the **Preferences** dialog and in the **Plan** or **Layout Defaults** dialogs. See “Snap Properties Panel” on page 76 and “General Plan Defaults Dialog” on page 59.

The **Fillet** edit behavior allows you to add a fillet at any corner of an object. See “Fillet” on page 122.

### Connect CAD Segments

Select **Edit> Edit Behaviors> Connect CAD Segments** to toggle the ability to edit the individual segments of polyline-based objects and connected walls. It also affects the ability to snap line- and arc-based objects together as they are drawn to form a polyline. See “Disconnect Edges” on page 124.

### Rotate/Resize About

Objects can be rotated or resized about either their own centers or the Current CAD point. See “Point Tools” on page 163.

Specify which behavior is used by selecting **Edit> Edit Behaviors> Rotate/Resize About Current Point** or in the **Preferences** dialog. See “Behaviors Panel” on page 75.

### Arc Creation Modes

Select **Edit> Arc Creation Modes** to access the five Arc Creation Modes that control how arcs and curved walls are drawn.

**Free Form Arc** mode allows you to define an arc by clicking and dragging along the desired path. See “Free Form Arc” on page 172.

You can select **Edit> Snap Settings** to quickly turn Object, Angle and Grid Snaps on or off.

To temporarily disable Snap Behaviors and other move restrictions, press the Ctrl key while dragging an edit handle. See “Moving Objects” on page 141.

### Hotkeys

You can also temporarily enable individual Snap Behaviors during a mouse editing operation using hotkeys. This can be helpful if you wish to use one particular type of snap behavior when you begin an operation, but a different behavior when you end it.

The Snap Behavior hotkeys are listed on the right side of the **Edit> Snap Settings** submenu. See “Hotkeys” on page 91.
To use snap behavior hotkeys

1. Select **Edit > Snap Settings** and toggle off the snap behavior category that you wish to control using hotkeys.
2. Select a tool that you wish to draw with or an object you wish to edit.
3. Begin drawing or editing and hold down the left mouse button without releasing.
4. Press and hold the appropriate key on your keyboard to enable the snap behavior associated with it.
5. When you are finished using the snap behavior, release the hotkey but continue holding down your left mouse button.
6. If you wish, you can press and hold a different hotkey on your keyboard and continue the drawing or editing operation.
7. When you are finished, release the left mouse button.

Object Snaps

Object Snaps allow you to position objects precisely relative to each other; for example, to position lines so that their endpoints meet or roof plane edges so that they are collinear.

Object Snaps can be turned on or off by selecting **Edit > Snap Settings > Object Snaps**, by clicking the toggle button, or in the **Preferences** dialog. See “Snap Properties Panel” on page 76.

Object Snaps are indicated visually as you create or edit objects. To remove any object snap indicators that are visible on screen, press the 1 (one) key. As you continue drawing or editing, new indicators may appear.

With the exception of On Object snaps, Object Snaps have priority over all other types of snapping in Home Designer Pro. **Bumping/Pushing** overrides Object Snaps, however. See “Bumping/Pushing” on page 142.

Object Snap Locations

There are many locations on an object that other objects can snap to. Each type of object snap can be toggled by selecting **Edit > Snap Settings**, or in the **Preferences** dialog. See “Snap Properties Panel” on page 76. Regardless of which Object Snaps are active, when multiple objects are selected the selection set’s only snap point is its midpoint.

Extension Snaps

Extension snaps allow you to snap to a point that is not actually on an object. Instead, these snaps locate points that are either collinear to the end of a wall or orthogonal (at a 90° angle) to it.

Extension snaps function when you are drawing or editing walls and create a “sticky point” and blue extension line where the wall being drawn reaches a point that is either collinear or orthogonal to another wall’s end point. See “Creating Walls” on page 193.

Object Snaps Hotkeys

- Hold down the “S” key to temporarily disable Object Snaps.

Angle Snaps

It is often important that objects be drawn at exact angles. This can be accomplished using **Angle Snaps**. Angle Snaps allow you to draw walls, lines, and other objects at specified Allowed Angles. Angle Snaps also affect the way objects rotate, the radius of arcs, and a variety of other operations.

You can specify whether Angle Snaps use 15° increments or 7.5° increments plus any additional Allowed Angles that you may specify. See “General Plan Defaults Dialog” on page 59.

Angle Snaps can be turned on or off by selecting **Edit > Snap Settings > Angle Snaps**, by clicking the toggle button, or in the **Preferences** dialog. See “Snap Properties Panel” on page 76. When Angle Snaps are disabled, the Angle Snaps icon will display near the mouse pointer.
**Angle Snap Settings**

You can change Allowed Angle settings for Angle Snaps in the **Plan Defaults** or **Layout Defaults** dialog. See “General Plan Defaults Dialog” on page 59.

Specify **15 Degree** or **7 ½ Degree** angle snaps. When **7 ½ Degree** Angle Snaps are selected, you can also specify **Additional Angles**.

**Angle Snaps and Object Snaps**

Angle Snaps have a higher priority than Grid Snaps and **On Object Snaps**. However, they have a lower priority to all other Object Snaps. If a valid Object Snap exists, the program uses that instead of an Angle Snap.

Sometimes both Angle Snaps and Object Snaps apply. For example, suppose a CAD line is drawn at **15°** using Angle Snaps and another line is approached. You can draw the new line at **15°** using **Intersection Snaps** to snap to a point on the existing line.

**Grid Snaps**

**Grid Snaps** allow you to snap objects to points on an on-screen grid as they are created, moved, and resized. See “Moving Objects” on page 141 and “Resizing Objects” on page 145.

It is recommended that you draw and position the exterior walls of your plan with **Grid Snaps** enabled. Once these walls are in place, you may choose to turn Grid Snaps off to finish the rest of the drawing.

Grid Snaps are turned on and off by selecting **Edit> Snap Settings>Grid Snaps** by clicking the toggle button, or in the **Plan** or **Layout Defaults** dialog.

**Reference Grid**

In addition to the Snap Grid, the **Reference Grid** is provided to give you a visual sense of scale. The Reference Grid is useful for zooming in and out, or for general layout guidelines, but is not used for snapping.

The Reference Grid can be toggled on and off by selecting **View> Reference Grid**. See “View Tools” on page 96.

The appearance and size of the Snap and Reference Grids can be controlled in the **Plan** and **Layout Defaults** dialogs. See “General Plan Defaults Dialog” on page 59.

**Grid Snaps and Angle Snaps**

Of the three snap behaviors, Grid Snaps have the lowest priority and are overridden by Angle Snaps and Object Snaps.

When Grid snaps and Angle Snaps are both enabled, objects are drawn and edited using Polar Coordinates. For example, if the grid **Snap Unit** is set to **12”** (1 foot), drawing a new wall at an Allowed Angle snaps the wall length to **0”, 12”, 24”, and so on**.

**Creating Objects**

In Home Designer Pro, there are four ways to add new objects to your drawing: by clicking to place an
Creating Objects

103

object, by clicking and dragging to draw an object, by entering coordinates, or by importing custom symbols, drawings, pictures, or metafiles.

If you create an object using any of these methods and the layer it will go on is either locked or turned off, the program will ask you if you want to unlock or display the layer. Objects can be created on layers that are not set to display, but they cannot be created on locked layers. See “Object Creation and Layers” on page 104.

While the size of the drawing area in Home Designer Pro is limited only by the resources on your computer, it is best to begin your drawing near the origin, 0,0,0. The current position of your mouse pointer displays in the Status Bar at the bottom of the program window. See “3D Drafting” on page 25.

Click-to-Create

Many objects, including doors and windows, cabinets, library symbols, text, pictures, and images are created by clicking. Select a library object or one of the drawing tools mentioned above, then click in the drawing area to place the object at that location.

Continue clicking to place the selected object until another tool is selected.

If you click at a location where there is not enough room for the object to be placed, one of two things may happen:

• Some objects, notably cabinets, doors, and windows, will resize smaller to fit into the space.

• Most objects cannot resize in this manner, so the program will present a warning message indicating that there is not sufficient space at the current location.

When most drawing tools are active or library symbols selected for placement, a preview outline follows your mouse pointer, indicating the size and shape of the object to be created. If your pointer is positioned at a location where the object cannot be placed, this preview outline will not display.

As you move the mouse pointer, the center point of the object’s back edge will snap to active snap points when Grid Snaps [ ] or Object Snaps [ ] are enabled. See “Snap Behaviors” on page 100.

Many architectural objects can be created in plan view or any 3D view. In order to place a stand-alone, click-to-create object in 3D, it is necessary to click near a wall or within the Terrain Perimeter as these objects help orient the new object within the 3D space.

Clicking and Dragging

Other objects, including walls and railings, straight stairs, and CAD and CAD-based objects are created by clicking and dragging to define either a path or an enclosed area. Select a tool, then click and drag in the drawing area to draw an object between your start and end points.

Continue drawing the selected object until another tool is selected.

You can temporarily slow the movement of the mouse as you drag by holding down the Shift key on your keyboard.

You can cancel any click-and-drag drawing operation before it is completed by pressing the Esc key on your keyboard, or by pressing any two mouse buttons at the same time.

Polyline- and Spline-based objects can be created by snapping multiple Line-, Arc-, and/or Spline-based objects together. These objects will only snap together to form a polyline or spline if they are on the same layer and share identical attributes such as color, line style, and arrow specifications. See “Editing Objects” on page 119.

Entering Coordinates

CAD lines, arcs and points can be created using the Input Line, Input Arc and Input Point dialogs. See “Input Point” on page 163, “Input Line” on page 166, or “Input Arc” on page 172.

Auto Rebuild

A number of objects, notably foundations, roofs, and framing, can be automatically generated and rebuilt as changes are made to the model. Objects created in this manner can be edited just like other objects; however, the Auto Rebuild functionality will be disabled.

Importing Objects

Custom symbols, drawings, pictures and metafiles can be imported into the program and placed in the drawing area with a click. See “Importing and Exporting” on page 623 and “Pictures, Images, and Walkthroughs” on page 601.
Converting Objects

A variety of objects can be created by converting existing CAD objects and many CAD-based objects into another type of object. See “Converting Objects” on page 150.

Object Creation and Layers

When it is created, every object is placed on a layer which controls whether and how it displays. See “Layers” on page 110.

If you try to create an object on a layer that is not set to display in the current view, the program will ask if you want to turn that layer on. See “Message Boxes” on page 33.

Copying and Pasting Objects

New objects can also be created by cutting, copying, and pasting existing objects, either individually or in groups. Objects can be copied from one floor to another, one view window to another, and one file to another. Because copying uses your system’s clipboard, some objects can be pasted into other applications, as well.

Objects cannot be pasted into any views that they cannot be created in normally. For example, CAD objects cannot be pasted into a 3D camera view or overview, while Architectural objects cannot be pasted onto a layout page.

A few objects, such as Terrain Perimeters and camera symbols, cannot be copied.

Cut

Select Edit> Cut or press Ctrl + X to remove the selected object(s) from the file and save them in the system clipboard. To paste the selection in Home Designer Pro or another application, select Edit> Paste or press Ctrl + V while in that application to enable the Paste function.

Copy

Select Edit> Copy or press Ctrl + C to copy the selected object(s) to the system clipboard. To paste the selection in Home Designer Pro or another application, select Edit> Paste or press Ctrl + V while in that application to enable the Paste function.

Paste

Select Edit> Paste or press Ctrl + V to enable Paste mode, then left- or right-click in the current view to paste the selected object(s) previously copied to the system clipboard at that location. If pasting from another application, click in the destination view in Home Designer Pro first to make sure it is active.

Once pasted, these object(s) are selected. Objects pasted in 3D views are selected on their top surfaces. If the selection being pasted consists of text, it is placed in a Text object.

If the selection being pasted is an image, the Paste Image dialog opens.

Specify how you would like to paste the selected image:

- Select Backdrop to add the image to a new 3D backdrop in the User Catalog in the library, where it will be selected. See “3D Backdrops” on page 614.
• Select **Image** to add the image to an Image object in the User Catalog in the library, where it will be selected. See “Images” on page 602.

• Select **Material** to add the image to a new material in the User Catalog in the library, where it will be selected. See “Creating Materials” on page 545.

• Select **Picture** to display the picture in the current plan view. See “Pictures” on page 606.

**Copy/Paste**

Click the **Copy/Paste** edit button to copy the selected object(s) to the system clipboard and immediately enable the **Paste** function in Home Designer Pro.

The **Copy/Paste** edit button activates Paste mode in which each available edit tool and handle makes a copy in addition to its primary function and four new edit buttons display on the edit toolbar.

• Click the **Sticky Mode** edit button to remain in the current mode and place multiple copies of the selected object(s).

• Click the **Paste Hold Position** edit button to create a copy of the selection at the same location as the original. See “Paste Hold Position” on page 106.

• Click the **Point to Point Move** edit button to make a copy of the selection at a specific location. See “Using Point to Point Move” on page 143.

• Click the **Reflect About Object** edit button to make a copy of the selection reflected about another object. See “Reflect About Object” on page 150.

• Click the **Main Edit Mode** edit button or press the Esc key to return to the selected object’s main edit toolbar.

If you paste a selection in a file other than its original source file, when you return to the original, Paste mode is still enabled.

The **Copy/Paste** edit button can be used with the edit handles in either of two ways: by clicking or by dragging an edit handle.

**To Copy/Paste by clicking**

1. Select an object or objects to copy.
2. Click the **Copy/Paste** edit button, select **Edit> Copy** from the menu or press Ctrl + C to copy and then Ctrl + V to activate the Paste functionality. The cursor displays the Copy/Paste icon.
3. If you wish to paste the copy in a different view or program window, open that window.
4. If your cursor does not display the Copy/Paste icon, select **Edit> Paste** from the menu or press Ctrl + V.
5. Left- or right-click once to paste a copy of the object at that location.

**To Copy/Paste by dragging**

1. Select an object or objects to copy.
2. Click the **Copy/Paste** edit button, select **Edit> Copy** from the menu or press Ctrl + C. The cursor displays the Copy/Paste icon.
3. Drag an edit handle:
   • Drag the Move edit handle to position the copy at a new location.
   • Drag a corner handle to create a copy in the same location but with a different size or shape. The result depends on which **Edit Behavior** you use. See “Defaults, Preferences, and Edit Behaviors” on page 119.
4. You can resize or position the copy accurately with respect to the original by watching the moved distance in the Status Bar at the bottom of the screen.

**Sticky Mode**

Normally, after an action is performed using the edit tools or handles while in an edit mode such as Paste mode, you return to the Main Edit Mode. Click the **Sticky Mode** edit button to remain in Paste mode and continue pasting copies of the selected object(s).

To exit Paste mode and return to the main edit toolbar for the selected object, click the **Main Edit Mode** edit button or press the Esc key on your keyboard. If you have not pasted a copy of the selected object and immediately click **Copy/Paste**...
after returning to the Main Edit Mode, **Sticky Mode** is still enabled.

**Sticky Mode** is available when the Copy/Paste edit button is clicked.

### Paste Hold Position

Click the **Paste Hold Position** edit button to create a copy of the selected object(s) at the same location as the original. The copy remains selected so you can perform additional operations.

Because multiple walls, railing and fencing cannot share the same space, the **Paste Hold Position** edit button is not available for these objects.

When copying between different floors or view windows, you can paste a copy at the same absolute position as the original selection using the **Paste Hold Position** command.

**To use Paste Hold Position**

1. Select the object(s) to be copied.
2. Click the **Copy/Paste** edit button.
3. Switch to the desired floor or plan file and select **Edit > Paste > Paste Hold Position**.
4. A copy is placed at the same X, Y coordinates on the new floor or in the new plan as the original’s position.

### Copy and Paste in Place

Select **Edit > Copy and Paste in Place** to create a copy of the selected object(s) at the same location as the original. The copy remains selected so you can perform additional operations.

Because multiple walls, railings, and fencing cannot share the same space, the **Copy and Paste in Place** command is not available for these objects.

### Paste Special

The **Paste Special** tool allows you to choose a representation for the selection to be pasted.

Selections can be pasted as:
- Device Independent Bitmaps (BMP). See “Importing Pictures” on page 607.
- Unformatted non-unicode text (TXT).
- File Name (a path to a file). Depending on the file type, it will be either opened or imported (if supported).
- Unformatted text (HTML). Pastes as text.
- Model Objects - Home Designer Pro format, not compatible with other programs.

**To use Paste Special**

1. Select an object, image, text or file on your computer and copy it.
2. Switch to the desired Home Designer Pro view window and select **Edit > Paste > Paste Special**.
3. In the **Paste Special** dialog, select the desired representation for the selection and click OK.
4. Click in the drawing area to place the copy at that location.

### Using the Transform/Replicate Object Dialog

Objects and groups of objects can be copied and pasted using the **Transform Replicate Object** dialog. See “Transform/Replicate Object Dialog” on page 151.

### Using Point to Point Move

The **Point to Point Move** edit button can be used in combination with **Copy/Paste** to make a copy of the selected object(s) at a specified location. See “Using Point to Point Move” on page 143.

**To use point to point copy**

1. Select the object(s) to be copied, click the **Copy/Paste** edit button, then the **Point to Point Move** edit button.
2. Click at the start point and then at the end point.
3. An exact copy of the selected object(s) is created at the end point while the original remains unchanged.

### Using Reflect About Object

The **Reflect About Object** edit button can be used in combination with **Copy/Paste** to
make a reflected copy of the selected object(s), much the way \textbf{Point to Point Move} \ë can. See “Reflect About Object” on page 150.
Displaying Objects

The way that objects display is an important in all stages of the design process. There are two primary ways that the display of objects is controlled: Drawing Groups and Layers.

Displaying Objects

There are two broad categories of objects in Home Designer Pro: architectural objects and CAD objects. See “Architectural vs CAD Objects” on page 99.

CAD objects are two-dimensional and display only in the view in which they were drawn. Architectural objects, on the other hand, are 3D and are represented in 2D and 3D views in different ways.

Layer Settings

By default, CAD and CAD-based objects use the settings assigned to their layer: including line style, color, and weight. They can also be assigned custom line attributes in their specification dialogs. See .

In plan view, architectural objects are represented much like CAD objects, using the attributes assigned to their layer. In addition, the edge lines of architectural objects in Vector Views also use these layer settings. See “Vector View” on page 595.

In addition, layers can be used to turn the display of objects on and off in different views.

Chapter Contents

• Displaying Objects
• Layers
• Layer Attributes
• Layer Display Options Dialog
• Layer Sets
• Drawing Groups
• Display Toggles
• Fill Styles
• Select Color Dialog

Fill Styles

Closed CAD objects and can also be assigned a fill style for their interior areas. Fill styles may be a solid color or a pattern, and can be specified as transparent. See “Fill Styles” on page 115.

Many architectural objects can also be assigned a fill style; however, it is only used in plan view. In 3D views, architectural objects are represented using surfaces that have materials assigned to them.

Patterns and Textures

The appearance of architectural objects in 3D views is determined by the materials applied to the objects’ surfaces. See “Materials” on page 539.

Material patterns display in Technical Illustration and Vector Views, while textures display in other types of rendered views. See “Rendering Techniques” on page 595.
In 3D views that use textures, you can turn on or off the display of textures by selecting 3D> Camera View Options> Toggle Textures.

Layers

Layers are used to organize and manage the display of all objects in all views. A layer can be thought of as a transparency sheet with objects placed on it for viewing. Nearly all views use multiple layers, like a stack of transparencies put together to show different types of objects.

Layer Attributes

The display of objects in different views is controlled by layer sets and layers in the Layer Display Options dialog. See “Layer Display Options Dialog” on page 111.

In Use Layers

A layer is considered to be in use in the current plan or layout file if one or more objects are assigned to it; if it is selected in one or more defaults dialogs; or, if it a system default layer for one or more drawing tools.

In the Layer Display Options dialog, the Used column identifies in use layers:

- A red plus sign (+) indicates that one or more objects are assigned to the layer.
- A white wrench (-) indicates that there are no objects on the layer, but that it is specified in a defaults dialog.
- A grey S ($) indicates that the layer is not used elsewhere, but is a system default layer.

Move your mouse pointer over an icon to display a tool tip summarizing where the layer is in use.

Primary and Secondary Layers

Every object is placed on a layer which controls whether it displays in a given view. This layer is referred to as the object’s primary layer, and you can see its name in the Status Bar when the object is selected. See “The Status Bar” on page 33.

In addition, some objects have secondary layers which may alter the appearance of objects on the primary layer, but do not control whether the objects display or not.

For example, the primary layer for base cabinets is “Cabinets, Base”. In addition, base cabinets have a number of secondary layers that control the display of the countertop, face indicators, door opening indicators, module lines and labels.

Note: If an object’s primary layer is turned off, information on its secondary layers will not display - even if those layers are turned on.

All layers with a check in the “Disp.” column display when the current layer set is active. Objects that are not displayed cannot be seen or selected. If you try to place or draw an object on a layer that is hidden, the program asks if you want to turn the layer on.

Some objects are designed to be inserted into another object rather than standing alone. If the display of an object that contains an inserted object is turned off, the inserted object’s display will be turned off, as well. For example, if the display of a wall is turned off, any doors and windows in that wall will not display either. See “Inserted Objects” on page 522.

Only displayed objects are included when DXF/DWG and EMF files are exported, and only displayed objects print.
Line and Text Styles

A layer’s **Color**, **Weight**, **Line Style** and **Text Style** attributes determine how an object on that layer appears in plan view and in 3D views using the Vector View rendering technique.

Many objects, including all CAD and text objects, allow you to override these settings for an individual instance without changing its layer. See “Line Style Panel” on page 169.

Edge and Pattern Lines

In 3D Vector Views, objects are represented using lines to define their surface edges. By default, Edge Lines use the attributes set for the object’s layer, as described above.

Some CAD-based architectural objects, such as Slabs, have line style settings in their specification dialogs; however, these specifications are not used unless **Use Object Settings** is checked in the **3D View Defaults** dialog. See “3D View Defaults Dialog” on page 560.

In addition, a material applied to an object surface may have a pattern associated with it. Pattern line color, weight, and spacing is set in the **Define Material** dialog. See “Pattern Panel” on page 550.

Layer Display Options Dialog

The **Layer Display Options** dialog controls the display of layers in the active layer set. From any view except the Materials List, select **Tools> Display Options** to open this dialog.

The **Layer Display Options** dialog consists of a table that lists all layers and their attributes.

There are a number of dialogs similar to **Layer Display Options** in the program:

- Select **Tools> Display Options** in a layout to open the **Layout Page Display Options** dialog. See “Layout Page Display Options” on page 695.

To edit the attributes of the Reference Floor Layer Set, click the **Define** button in the **Change Floor/Reference** dialog. See “The Reference Floor” on page 393.

Locking Layers

Objects on layers with a lock icon in the **Lock** column cannot be selected by the user.

New objects cannot be drawn on a locked layer, either. If you lock a layer and then attempt to draw a new object on that layer, a message box will ask you to unlock the layer.

Layers with objects that you need to see as a reference while working, but not select, are good candidates for locking. For example:

- Locking the “Rooms” layer can make it easier to select objects located inside of rooms.
- Locking the “Roof Planes” layer can make it easier to select objects located under the eaves.

Another use for locking layers is to protect them from editing in plans opened by clients or others in select Home Designer programs. See “Opening Chief Architect Plans in Home Designer Programs” on page 40.

**⚠️** Locking a layer does not prevent objects on that layer from being modified. In addition, most objects can be deleted using the Delete Objects dialog. Objects are also deleted if the floor they are placed on is deleted. See “Deleting Objects” on page 157.
The Properties for the layer set that is active in the current view are presented in a table of layers and their attributes. Click a column header to sort all layers in the table by that column. An arrow above a column indicates that it is being used to sort the table, and in which direction it is being sorted.

The Name column is sorted alphabetically. Layers are named so that similar object types are listed near one another, and sorting is case sensitive to allow greater control over organization.

- An icon in the Used column indicates that the layer is in use. The information in this column can be sorted, but not edited here. See “In Use Layers” on page 110.
- A check in the Disp column indicates which layers are set to be visible. If a layer is turned off, this column is blank.
- A lock icon in the Lock column indicates which layers are locked, preventing objects on that layer from being selected. See “Locking Layers” on page 111.
- The Color column shows the line color for each layer and can be sorted so that like colors are listed together.
- The Line Style column shows the line style for each layer and can be sorted so that like line styles are listed together.
- The Line Weight column displays the line weight used by each layer and can be sorted so that like line weights are listed together. See “Line Weights” on page 716.
- The Text Style column shows the text style assigned to each layer and can be sorted so that layers using the same style are listed together. See “Text Styles” on page 283.

Layers are selected by clicking on them in the table. Hold down the Shift key or the Ctrl key to select multiple layers at once. Press Ctrl + A or click the Select All button to select all layers in the table. When selected, a layer’s attributes display and can be edited below.

The program remembers what layer(s) are selected when you click OK and selects them again when you return to this dialog.

The Properties for “Selected Layer” options let you modify the attributes of one or more selected layers. Line Color, Style, and Size affect lines in plan view and surface edge lines in Vector Views. When multiple layers are selected, “No Change” may display for attributes that are not shared by the selected layers.

- To turn off a selected layer, uncheck Display. See “Layer Attributes” on page 110.
- To protect the objects on a selected layer from accidental changes, check Lock. Items on locked layers can display but cannot be selected. See “Locking Layers” on page 111.
Layer Sets

Layer Sets are used to control the layer settings for different views in a plan or layout file. All views associated with a plan file - including views sent to layout - make use of layer sets stored in that .plan file.

A layer set consists of a complete list of the layers in the current plan or layout along with the display settings for each layer as set for a particular type of view. These display settings can be modified, and can be different for each type of view. See “Layer Display Options Dialog” on page 111.

Layer sets are file specific, which means that changes made in one plan or layout file have no effect on the settings in other files.

Home Designer Pro uses a different layer set for each type of view of your plan:

- Plan views. See “Plan Views” on page 93.
- Camera views and Overviews. See “3D View Tools” on page 561.
- Elevation views. See “Cross Section/Elevation Views” on page 564.
- Framing Overviews. See “Framing Overview” on page 563.
- Reference Floor. See “The Reference Floor” on page 393.

While any view is active, select Tools> Display Options to make changes to the layer set used for that view type.

Any changes made to settings in the Layer Display Options dialog for one particular view will affect all views using that same layer set. For example, if you make changes for a camera view, all camera views and overviews in the current plan will be affected. See “Layer Display Options Dialog” on page 111.

Drawing Groups

Each object in a plan or layout file belongs to a Drawing Group, which influences whether it displays in front of or behind other objects. Drawing Groups control the display of objects in plan view and on the layout page. They also control the display of CAD objects drawn in cross section/elevation views. They do not affect the display of objects in camera views and overviews.

Most categories of objects have their own Drawing Group; however, a few objects are instead placed in the Front or Back Group. Imported pictures, which are placed in the Back Group, are a notable example. A selected object’s Drawing Group is reported in the Status Bar. See “The Status Bar” on page 33.

Within a given Drawing Group, drawing order is determined by the order in which objects are placed. By default, an object will display in front of any objects that were created before it was. For example, if you place a chair and then a table, the table will display in front of the chair; if you instead place a table and then the chair, the chair will display in front.

Drawing order also affects how objects are selected. If two objects are positioned so that they overlap one another, and you click at a point that they both share,
the frontmost object will become selected first. See “Select Next Object” on page 124.

Drawing Group Edit Tools

Once an object has been placed, its position in the drawing order can be modified. To do this, select one or more objects and click the View Drawing Group Edit Tools edit button.

There are two options for moving a selection towards the back of the drawing order:

- Click the Send to Back edit button to move the selected object(s) to the back of the Back Group so it displays behind all other objects.
- Click the Send Backward edit button to move the selected object(s) to the back of its current Drawing Group. If it is already at the back of its current group, it will be moved to the next group down in the drawing order.

There are two options for moving a selection towards the front of the drawing order:

- Click the Bring to Front edit button to move the selected object(s) to the front of the Front Group so that it displays in front of all other objects.
- Click the Bring Forward edit button to move the selected object(s) to the front of its current Drawing Group. If it is already at the front of its current group, it will be moved to the next group up in the drawing order.

Select Drawing Group Dialog

The Select Drawing Group edit button reports the Drawing Group number that the selected object(s) is in. When multiple objects are selected, a horizontal line may display instead. Click this button to open the Select Drawing Group dialog.

- Select a Drawing Group from the drop-down list to place the selected object(s) into that group. The default group for the selected object is noted as such.
- When multiple objects in different groups are selected, “No Choice” will initially display. You can select “Default: Multiple Values” to return each object to its respective default group.

Display Toggles

There are a number of toggles and tools that can be used to affect the appearance of the on-screen display.

Print Preview

Print Preview and its related display toggles allow you to get a sense of what the current view will look like when it is printed. See “Print Preview” on page 713.

Refresh Display

Refresh Display redraws the current window to clean up extra lines, show missing items, and correct random on-screen effects caused by changes to a model. Select View> Refresh Display or press the F5 key to refresh the on-screen display.

Color On/Off

The display of color on-screen can be toggled on and off in any view by selecting View> Color or by clicking the toggle button.

Click the Bring to Front edit button to move the selected object(s) to the front of the Front Group so that it displays in front of all other objects.

Click the Bring Forward edit button to move the selected object(s) to the front of its current Drawing Group. If it is already at the front of its current group, it will be moved to the next group up in the drawing order.

To display views in gray scale

1. Select View> Color to toggle color off.
2. Select Edit> Preferences to open the Preferences dialog.
3. On the APPEARANCE panel, select Grayscale as the Color Off Is setting. See “Appearance Panel” on page 62.

To display views in black and white

1. Select View> Color to toggle color off.
2. Select Edit> Preferences to open the Preferences dialog.
3. On the Appearance panel, select Black and White as the Color Off Is setting.

When Color is toggled off and Black and White is specified, all lines appear as black, regardless of their color. Solid fill colors appear as either white or black, depending on which is closer to the actual fill color when Color is turned on. The background remains as defined in the Preferences dialog. See “Colors Panel” on page 64.

You can specify whether cross section/elevations, camera views, and overviews using the Vector View Rendering Technique are generated with colors turned on in the 3D View Defaults dialog. See “3D View Defaults Dialog” on page 560.

You can also print in color, black and white, or gray scale. See “Print View Dialog” on page 719.

**Arc Centers and Ends**

The display of arc center- and endpoints, and the display of circle center points can be toggled by selecting View> Arc Centers and Ends, by clicking the toggle button, or in the CAD Defaults dialog. See “CAD Defaults Dialog” on page 161.

**Delete Surface**

In any 3D view, select 3D> Delete Surface, then click a surface in the view to temporarily remove the surface from the current view. See “Delete 3D Surface” on page 566.

---

### Fill Styles

Filled styles are CAD-based patterns that can be used to fill the interiors of closed CAD shapes. In plan view, filled styles can also be applied to a variety of architectural objects.

The Fill Styles library contains filled styles that can be applied to objects individually in their specification dialogs, by default in their defaults dialogs, as well as using the Fill Style Painter tools.

**Fill Style Eyedropper**

The Fill Style Eyedropper allows you to load a filled style assigned to an existing object into the Fill Style Painter and apply that filled style to other eligible objects. It is similar to other Eyedropper tools. See “Eyedropper Tools” on page 155.

**Fill Style Painter Tools**

Select Tools> Fill Style Painter to access the Fill Style Painter tools, which are used to apply filled styles to closed CAD objects. In plan view, the Fill Style Painter tools can be used to apply filled styles to a variety of architectural objects, as well. These tools are similar to other Painter Tools in the program. See “Eyedropper and Painter Tools” on page 155.

Patterns, which are similar to filled styles, can be used to represent materials in Vector Views. See “Patterns and Textures” on page 540.

**Import Patterns**

Select File> Import> Import Patterns to open the Import Custom Patterns file and import a .pat file. See “Importing Files” on page 47. Patterns are imported directly to the User Catalog in the Library Browser. See “The User Catalog” on page 515.

To open the Fill Style Specification dialog, right-click on a filled style in the library and select Open Object or right-click on an unlocked library folder and select New> Fill Style. See “Using the Contextual Menus” on page 511.

To open the similar Layer Fill Style dialog, click in the Fill column in the Wall Type Definitions or any Material Layers Definition dialog. See “Wall Type Definitions Dialog” on page 210 and “Material Layers Definition Dialogs” on page 538.
The **Default Framing** and **Default Header Fill Style** dialogs are also similar to this dialog and can be accessed by clicking the Fill Style button on the PLAN DISPLAY and OPENINGS panels of the Build Framing dialog. See “Build Framing Dialog” on page 469.

The settings in this dialog are also found on the Fill Style panel of specification dialogs for a variety of objects in the program. This panel is not available for Sprinkler Lines or Electrical Connections as these tools cannot be used to form closed shapes.

![Fill StyleSpecification](image)

1. In the Fill Style dialog only, specify the Fill Style Name.
2. Select a Pattern Type from the drop-down list and specify its characteristics.
   - Select “Library” from the list or click the Library button to choose a pattern from the library. When a Library fill style is selected, a custom name may display in the list instead of a system default Type. See “Assigned Items” on page 522.
   - When “No Pattern” is selected as the Type, the settings that follow are disabled.

When a fill style from the library is selected, it is possible for some or all of the settings in this dialog to change.

3. Specify the fill style’s Scale.
   - Specify the Width of the selected fill pattern. For Concrete and Sand fills, instead adjust the overall Spacing. Not available for Solid fill.
   - Specify the Height of the selected fill pattern. Only available for Grid, Grid 1/2 Offset, and U’s fill Types.
   - Specify a Scale for the selected fill pattern. Only available when the name of a library fill style from the library is listed as the fill Type, above.
4. Specify the fill’s Offsets and Angle.
   - Specify the Horizontal and Vertical Offsets. See “Mapping Patterns and Textures” on page 546.
   - Specify the Angle of the selected fill pattern. Not available for Solid fill.
Additional **Pattern Appearance** settings control the fill’s line weight and color.

- Set the **Line Weight** for the selected fill pattern. Not available for “Solid” fill.
- Specify a custom **Color** for the lines that make up the fill pattern or Solid fill by clicking the color bar. The Layer Color is used by default.
- **Custom Color** is selected automatically if you click the color bar above.
- Select **Use Layer Color** to have the fill pattern use the layer color for the pattern lines or solid fill.
- Select **Use Background Color** to use the view’s background color for the pattern lines or solid fill.
- Use the **Transparency** slider bar or text field to control how transparent the fill pattern lines are. This setting also affects the transparency of Solid fill colors.

Check **Background** to add a solid background color to the fill pattern and enable the settings below. When unchecked, the fill pattern has a transparent background. Not available when “Solid” is the selected Pattern Type.

- Specify a custom background **Color** by clicking the color bar. The Background Color set in the **Preferences** dialog is used by default. See “Colors Panel” on page 64.
- **Custom Color** is selected automatically if you click the color bar above.
- Select **Use Layer Color** to have the fill pattern use the layer color for the pattern lines or solid fill.
- Select **Use Background Color** to use the view’s background color for the pattern lines or solid fill.
- Use the **Transparency** slider bar or text field to control how transparent the background color is.
- On the Fill Style panel only, click the **Add to Library** button to add the fill pattern as it is currently defined to the User Catalog. See “Add to Library” on page 517.

A preview of the selected pattern displays to the right. As changes are made to the settings on this panel, the preview will update.

- Choose a **Preview Width** from the drop-down list. This value controls how large an area the preview represents. The selected value indicates the horizontal width of the preview pane in actual plan inches (mm).

---

**Select Color Dialog**

The **Select Color** dialog can be opened by clicking on the Color bar that can be found in many dialogs throughout the Windows version of the program.

In the Mac version, the standard **Colors** dialog, or Color Picker, is used instead.
The currently selected color displays in the rectangle at the lower center of the dialog. There are a number of ways to select a color in this dialog:

1. Click in any one of the Basic colors boxes to select it.
2. Click anywhere in the color spectrum area to select a color.
3. The location of the selected color is identified by crosshairs.
4. Click anywhere in the vertical bar or drag the arrow to adjust the selected color’s Luminosity and RGB values.
5. Define the color by specifying its Hue, Saturation, and Luminosity (HSL) or its Red, Green, and Blue (RGB) values.
6. Click one of the Custom colors boxes to either select it or to specify it as the box for a new custom color to be defined.
7. Click the Add to Custom Colors button to add the selected color to the Custom Colors group.
8. Click the Color Chooser Eyedropper, then click anywhere on your monitor to select the color displaying at that location.
9. You can select a color from any program window. Before opening the Color Chooser dialog, make sure the desired color can be seen on screen.
10. Click OK to apply the currently selected color to the object’s line or fill style, or to the material’s pattern color.
Chapter 9:
Editing Objects

Just as the methods used to create different objects in Home Designer Pro are similar, the options for moving, rotating, resizing, and otherwise editing them are also alike.

Edit handles allow objects to be resized, relocated, or rotated using the mouse. Edit toolbar buttons and the contextual menus access edit tools relevant to the selected object(s). Most objects have a specification dialog that allows you to edit it in ways that are specific to that type of object.

The editing characteristics common to most objects are described in this chapter. Unique, object-specific editing behaviors and the specification dialogs are covered in their respective chapters.

Chapter Contents
• Defaults, Preferences, and Edit Behaviors
• Selecting Objects
• Selecting Multiple Objects
• Editing Line-Based Objects
• Editing Arc-Based Objects
• Editing Open Polyline-Based Objects
• Editing Closed Polyline-Based Objects
• Editing Box-Based Objects
• Editing Spline-Based Objects
• Editing Circles, Ovals and Ellipses
• Editing Multiple Objects
• Moving Objects
• Aligning Objects
• Resizing Objects
• Reshaping Objects
• Rotating Objects
• Reflecting Objects
• Converting Objects
• Transform/Replicate Object Dialog
• Edit Area Tools
• Stretch CAD
• Eyedropper and Painter Tools
• Object Eyedropper
• Deleting Objects
• Delete Objects Dialog
• Undo and Redo

Defaults, Preferences, and Edit Behaviors

The same defaults and preference settings that affect how objects are drawn also influence how they can be edited. See “Defaults and Preferences” on page 99.

In addition, there are five Edit Behavior modes that determine how edit handles affect an object, and may also affect how objects are drawn. The currently active edit behavior is a global preference setting, affecting all plan and layout files.
Two of these modes, **Default** and **Alternate**, are useful for most drawing and editing needs and can be considered primary editing modes. Default mode, in particular, accesses the most commonly used behaviors and is the best choice in most circumstances. When an Edit Behavior other than Default is active, its icon displays near the mouse pointer.

The other three modes, **Resize**, **Concentric** and **Fillet**, offer special editing behaviors that may be useful only in certain situations and can be considered secondary.

Each edit behavior can be temporarily enabled using the different buttons on your mouse or by pressing the keyboard keys associated with each. See “Using Input Devices” on page 26 and “Hotkeys” on page 91.

You can also specify which edit behavior mode is active when the left mouse button is used in the **Preferences** dialog, by selecting **Edit> Edit Behaviors**, or by clicking the corresponding toggle button, which can be added to your toolbar. See “Behaviors Panel” on page 75.

---

### Default

The **Default** mode is one of the primary edit behavior modes. It offers access to the most commonly used edit behaviors and should be selected as your preference in most situations.

- **Drawing** - Standard click and drag drawing behavior is enabled. See “Creating Objects” on page 102.
- **Resize/Reshape** - Default allows you to adjust the angle of any corner of a polyline without affecting adjacent corners, changing the object’s shape.

---

### Alternate

The **Alternate** mode is the second primary edit behavior mode. When this mode is active, the Alternate Alt icon displays near the mouse pointer.

Note: Not all commands have an Alternate edit behavior. If a selected tool does not, it will not work when this edit mode is active.

- Alternate allows you to drag an end handle on an open polyline to change it from a line to an arc or vice versa.
- Alternate overrides the **Lock Center** setting of arc-based objects.
- **Movement** - Alternate allows you to move objects at Allowed Angles when **Angle Snaps** are enabled, or orthogonal to any of its edges when they are not. See “Angle Snaps” on page 101.
- **Rotation** - Alternate snaps objects at Allowed Angles as they are rotated.

You can temporarily enable the **Alternate** edit mode when another mode is active by pressing Alt + Z or Alt + / while performing an edit or drawing operation.

---

Note: Regardless of which Edit Behavior is active, the Default behavior is restored when you close the program.
using the right mouse button while performing an edit operation.

**Resize**

The **Resize** edit behavior allows you to rescale an object. As you drag a corner edit handle of an object, you get an exactly scaled version of the original. For example, you can resize an object to 50% of its original size while maintaining the same proportions. When this mode is active, the Resize icon displays near the mouse pointer.

- **Drawing** - Standard click and drag drawing behavior is enabled.
- **Resize/Reshape** - Reshape allows you to keep the angle between adjacent edges fixed when a corner handle is moved.
- **Movement** - Reshape allows you to move an object orthogonal, or at a right angle, to any of its edges.
- **Rotation** - In Resize Mode, objects snap at Allowed Angles as they are rotated.

You can temporarily enable the **Resize** edit mode when another mode is active by pressing X or the period key, or using the X2 button on a five-button mouse while performing an edit or drawing operation. See “Using Input Devices” on page 26.

**Concentric**

The **Concentric** mode allows you to resize objects so that the distance moved by each edge is the same. For example, you can resize an irregularly shaped polyline so that each edge is exactly ten feet in from the original position, which is useful for creating site plans with setbacks. When this mode is active, the Concentric icon displays near the mouse pointer.

- **Drawing** - Standard click and drag drawing behavior is enabled.
- **Resize/Reshape** - Concentric allows you to resize an irregularly-shaped polyline so that each edge is moved the same distance from its original location.

- **Movement** - Concentric mode also allows you to move opposite edges of an object so that each edge is moved the same distance from its original location.

- **Rotation** - In Concentric mode, objects snap at Allowed Angles as they are rotated.

In some cases, the Concentric and Resize edit behaviors have the same result, such as when a circle is resized. Usually, though, the two behaviors are different because concentric resizing does not maintain the original ratio between an irregular polyline’s edges.
In Concentric mode, objects resize in Concentric Jump increments specified in the Preferences dialog. See “Behaviors Panel” on page 75.

When the Concentric Jump distance is set at 0", objects resize according to the Snap Unit specified in the Plan Defaults dialog. See “Grid Snaps” on page 102.

You can temporarily enable the Concentric edit mode when another mode is active by pressing C or the command key, or using the X1 button on a five-button mouse while performing an edit or drawing operation. See “Using Input Devices” on page 26.

**Fillet**

The Fillet mode allows you to add a fillet, or curve, at any corner of an object. Dragging a corner edit handle adjusts the fillet radius at that corner. When this mode is active, the Fillet icon displays near the mouse pointer.

- **Drawing** - Standard click and drag drawing behavior is enabled.
- **Resize/Reshape** - Fillet allows you to create a fillet at by dragging a corner edit handle inward.

**Connect CAD Segments**

Typically, when two CAD objects share the same properties and Endpoint Snaps are enabled, they can be snapped end-to-end to form a polyline. Connect CAD Segments controls whether CAD objects with the same properties can be snapped together to form polylines. It also controls whether spline segments can be snapped together. See “Polylines” on page 176 and “Splines” on page 180.

Connect CAD Segments also affects stairs, ramps, and road objects. See “Stairs, Ramps, and Landings” on page 395 and “Roads, Driveways and Sidewalks” on page 665.

When Connect CAD Segments is disabled, the Connect CAD Segments icon displays near the mouse pointer and CAD objects cannot form polylines. See “Pointer Icons” on page 28.

Select Edit> Edit Behaviors> Connect CAD Segments to toggle this behavior on or off. You can also turn Connect CAD Segments on or off in the Preferences dialog. See “CAD Panel” on page 73.

**Rotate/Resize About Current Point**

Objects can be rotated or resized about either their own centers or the current CAD point. See “The Current Point” on page 164.
Selecting Objects

“Select” refers to selecting an object for editing. An object must be selected before it can be edited.

In order for an object to be selected, it must be both unlocked and visible in the current view. See “Layers” on page 110.

When an object is selected, it displays edit handles and a selection fill color. See “Colors Panel” on page 64.

In 3D views, a selected object will also display lines representing the selected edge or surface. The size of the edit handles does not change as you zoom in or out and is set in the Preferences dialog. See “Edit Panel” on page 73. To prevent them from stacking on one another, some edit handles may not display as you zoom away from the selected object.

When an object is selected, its edit toolbar also displays, typically at the bottom of the Home Designer Pro program window just above the Status Bar. See “The Edit Toolbar” on page 29.

Information about the selected object or objects may also display in the Status Bar. See “The Status Bar” on page 33.

A selected object remains selected until another object is selected, a different tool is activated, the Esc key on the keyboard is pressed, or any two mouse buttons are pressed at the same time.

Select Objects

With the exception of temporary CAD points, any object created using Home Designer Pro can be selected using the Select Objects tool. Select Edit> Select Objects, click the toolbar button or press the Space bar on your keyboard to activate this tool, then click on an object to select it.

You can also select objects or open context sensitive menus using the right mouse button when any tool is active.

By default, you can select an object by clicking within 12 pixels of it. You can adjust this distance by changing the Snap Distance in the Preferences dialog. A lower value, for example, can be helpful for working with small objects but can also make it very difficult to select larger objects. See “Snap Properties Panel” on page 76.

Selecting Similar Objects

If a tool other than Select Objects is active, you can only select objects of that type using the left mouse button. For example, if the Straight Exterior Wall tool is active, you can only select walls using the left mouse button.

This can be useful for selecting an object when many objects of a different type occupy the same space in plan view.

Objects can be selected using the right mouse button, regardless of which tool is active.

Right-Clicking

Regardless of which tool is active, you can select an eligible object by right-clicking on it once. When you right-click to select an object a contextual menu also appears, displaying the object’s edit tools. You can turn contextual menus on or off in the Preferences dialog. See “Contextual Menus” on page 30.

If a drawing tool is active and you right-click to select an object, you can unselect it by left-clicking in an empty space in the drawing area. Although a drawing tool is active, it is not used. If you then left-click a second time, the active tool will be used.

Selected Edge

When you click on a polyline- or box-based object, the edge that you click nearest becomes the selected edge and displays an edit handle larger and of a different color than those on other edges. The handle on this edge may also display at the point where you clicked to select it. You can specify the Selected
**Edge Handle Fill** color in the Preferences dialog. See “Colors Panel” on page 64.

This edge can be edited on the SELECTED LINE or SELECTED ARC panel of the object’s specification dialog, as well as using a variety of edit toolbar buttons. It can also be moved using dimensions. See “Moving Objects Using Dimensions” on page 263, “Line Panel” on page 168 and “Arc Panel” on page 174.

The Start and End points of a CAD-based object’s selected edge or of a wall can be indicated by an S and an E when the object is selected. These Start and End indicators can be helpful when editing the selected edge in the object’s specification dialog, and their display can be turned on and off in the Preferences dialog. See “Edit Panel” on page 73.

**Disconnect Edges**

Polyline-based objects are composed of lines and arcs that are connected end to end. The individual edges of open and closed polylines can be selected and edited independently of the object’s other edges when Disconnect Edges is in use. Select CAD> Lines> Disconnect Edges to enable this ability.

Disconnect Edges also affects terrain paths, but does not affect Walkthrough Paths, Connect Electrical or Sprinkler splines, or closed polyline-based objects such as slabs and roof planes.

**To use Disconnect Edges**

1. Select CAD> Lines> Disconnect Edges.
2. Click on an individual edge of an eligible polyline-based object to select it.

3. Notice that it is no longer connected to the rest of the polyline.
4. The individual segment can now be edited entirely independent of its neighbors.
5. Continue clicking on polyline edges to disconnect them from their polyline.
6. When you are finished, click the Select Objects button or activate another tool.
7. To connect the segment to the polyline again, move the end handles so that they snap to the ends of adjacent segments.

When Disconnect Edges is used, only edges that you click on are actually affected by it. Any polylines that you do not click on will remain intact.

You can also separate the selected edge of an open or closed polyline from the rest of the polyline by clicking the Disconnect Selected Edge edit button. See “Selected Edge” on page 123.

**Selected Side**

Most architectural objects can be selected in 3D views. When selected, the outline of their bounding box displays, and edit handles are located on the side where you clicked to select the object. The edit handles can be used to move, resize, or rotate the object in different directions, depending on which side is selected.

**Select Next Object**

If there is more than one object in a particular space, it may be difficult to select the desired object. When a nearby object is selected, click the Select Next Object edit button or press the Tab key until the desired object becomes selected. This function cannot be applied to groups of selected objects.
Selecting Multiple Objects

Multiple objects can be selected and edited in groups. The options available for editing them will vary depending on the type or types of objects selected. See “Editing Multiple Objects” on page 141.

Marquee Select

Groups of objects can be selected by holding down either the Shift or Ctrl key when the Select Objects tool is active and then dragging a marquee around the objects to be selected.

When using the marquee-select method, both CAD and architectural objects included in the marquee are selected. To remove an object from the selection set, hold down the Ctrl key and click on it.

If an object is selected and a selection marquee is drawn around it using the Ctrl key, that object becomes deselected. If the Shift key is used instead, the original object remains selected and the other objects are added to the selection set.

The Shift key can be used to marquee-select objects of a similar type when the drawing tool used to create those objects is active.

To marquee-select objects by type

1. Select a drawing tool used to create the type of object you wish to select: for example, the Hinged Door tool.
2. Hold down the Shift key, then click and drag a rectangular selection marquee in the drawing area.
3. When you release the mouse button, objects of the selected drawing tool’s type - here, door objects - located in the marquee will be selected.

You can specify whether objects must be totally contained in or intersected by the marquee, or whether an object’s center point must be contained in the marquee, in the Preferences dialog or using the Selection Mode buttons, which can be added to your toolbars. See “Edit Panel” on page 73.

Marquee Select Similar

The Marquee Select Similar edit tool lets you group-select objects in the current plan view that are similar to the selected object(s).

To use Marquee Select Similar

1. In plan view, select one or more objects, then click the Marquee Select Similar edit button.
2. The Restrictive Selection button controls whether objects are selected by similar type(s) only, or if additional attributes are taken into account.
   • Restrictive Selection is disabled by default, so objects of the same type will be selected.
   • Click the Restrictive Selection edit button to toggle it on and select only objects with additional attributes like materials in common.
3. Click and drag a rectangular selection marquee in the drawing area to select similar objects within its area.
4. Alternatively, click the Select All Similar edit button to select all similar objects in the current view.

The Marquee Select Similar tool is not available for all object types. For example, it is not available for wall framing.

Shift and Ctrl Select

You can select a group of objects by adding them to the selection set one by one. Select an object, hold down either the Shift or Ctrl key, and click additional objects to select them.

More than one type of object can be selected using this method, but the ability to edit the group-selected items is limited to attributes that all selected objects have in common.

To remove an object from a selection set, click on it once more with the Ctrl key pressed.

The Shift and Ctrl keys can be used to select multiple items in a variety of contexts, such as: the Library and Project Browsers, lists in dialog boxes, and files to be imported. They can also be used to marquee-
select objects in plan view. See Marquee Select, above.

**Editing Line-Based Objects**

Objects are considered line-based when they can be edited similar to CAD lines using their edit handles.

CAD lines, framing members, straight walls and railings, straight stairs, and straight roads are examples of line-based objects.

Most line-based objects can be connected to other like objects to form polylines or polyline-based objects. See “Editing Open Polylines” on page 130 and “Editing Closed Polylines” on page 133.

Some objects, notably walls, have line-based editing behavior only when selected on certain surfaces. See “Editing Walls” on page 200.

Wall openings such as doors and windows have line-based editing behavior in plan view only but cannot be rotated, reversed or converted to an arc. See “Editing Doors” on page 291 and “Editing Windows” on page 314.

The behavior of the edit handles may depend on the currently active Edit Behavior. See “Defaults, Preferences, and Edit Behaviors” on page 119.

**Move**

- Click and drag the Move handle to move the object according to the currently active Edit Behavior. See “Defaults, Preferences, and Edit Behaviors” on page 119.
- Movement may be limited or stopped by other objects or Snap Behaviors. Move restrictions can be overridden by holding down the Ctrl key while dragging. See “Unrestricted Movement” on page 142.

**Rotate**

- The Rotate handle is used to rotate the object, either about its center or about the current CAD point. See “Rotating Objects” on page 148.

**Extend/Change Angle**

- Drag a square end handle parallel to the selected line to change its length.
- Drag a square end handle at an angle to the selected line to change its angle. When Angle Snaps are on, the line snaps to Allowed Angles. See “Angle Snaps” on page 101.
- Right-click and drag it to change the adjacent line into an arc, or vice versa. See “Alternate” on page 120.

**Using the Edit Handles**

When selected, a typical line-based object displays six edit handles: a Move handle, two Extend/Change Angle handles, two Same Line Type handles, and a Rotate handle.

Any action performed using the edit handles can be cancelled by pressing the Esc key or any two mouse buttons at the same time.
Editing Line-Based Objects

Same Line Type
- Drag a diamond-shaped end handle in any direction to draw a new line that shares the original’s color, weight, line style, and layer. See “Same Line Type Edit Handles” on page 168.

Adjust Width
Some line-based objects, such as stairs and roads, have additional handles that allow the width of the object to be adjusted.

- Click and drag a small, round Expand handle to increase or decrease the object’s width. By default, objects are resized in 1” increments. This Snap Unit is defined in the Plan Defaults dialog. See “General Plan Defaults Dialog” on page 59.

Using Dimensions
Dimensions can be used to position line-based objects relative to other objects. See “Moving Objects Using Dimensions” on page 263.

Dimensions cannot, however, be used to adjust the length of line-based objects, or the width of line-based objects such as stairs.

Using the Specification Dialog
Line-based objects can be edited using their specification dialogs. See “Line Specification Dialog” on page 168.

Using the Edit Toolbar
A selected line-based object can be edited in a variety of ways using the buttons on the edit toolbar.

The following toolbar buttons may display on the edit toolbar for a selected line-based object:

- Click the Select Next Object edit button to select nearby objects instead of the selected object. See “Selecting Objects” on page 123.

- Click the Open Object edit button to open the specification dialog for the selected object(s). See “Specification Dialogs” on page 32.

- Click the Copy/Paste edit button to copy the selected object(s) to the system clipboard so they can be pasted elsewhere. See “Copying and Pasting Objects” on page 104.

- Click the Delete edit button to delete the selected object(s). See “Deleting Objects” on page 157.

- Click the Transform/Replicate Object edit button to copy, move, rotate, resize, or reflect the selected object(s). See “Transform/Replicate Object Dialog” on page 151.

- Click the Make Parallel/Perpendicular edit button to make the selected object(s) parallel or perpendicular to a straight edge. See “Using Make Parallel/Perpendicular” on page 144.

- Click the Point to Point Move edit button to accurately move the selected object(s). See “Using Point to Point Move” on page 143.

- Click the Center Object edit button to center an object along a wall within a room or relative to a cabinet fixture. See “Using Center Object” on page 144.

- Click the Reflect About Object edit button to reflect the selected object(s) about another object. See “Reflecting Objects” on page 150.

- Click the View Drawing Group Edit Tools edit button to modify the selected object’s place in the drawing order. See “Drawing Group Edit Tools” on page 114.

- Click the Break edit button to add a new corner or pivot point to the selected object. See “Break” on page 146.

- Click the Complete Break edit button to break the selected object into two separate objects. See “Break” on page 146.

- Click the Reverse Direction edit button to reverse the direction of the selected object(s). See “Reverse Direction” on page 150.

- Click the Convert Polyline edit button to convert the object into a special polyline-based object. See “Convert Polyline” on page 151.

- Click the Change Line/Arc edit button to change a line-based object to an arc, or vice versa. See “Change Line/Arc” on page 147.
- Click the **Intersect/Join Two Lines** edit button, then click on a non-parallel line or arc to join the two objects. See “Intersect/Join Two Lines” on page 147.
- Click the **Fillet Lines** edit button, then click on a non-parallel line or arc to create an additional arc connecting the two. See “Fillet Lines” on page 148.
- Click the **Chamfer Lines** edit button, then click an edge adjacent to the selected edge to chamfer the corner between them. See “Chamfer Lines” on page 148.

## Editing Arc-Based Objects

Objects are considered arc-based when they can be edited similar to CAD arcs using their edit handles. CAD arcs, curved walls and railings, curved stairs, and curved roads are examples of arc-based objects. Most arc-based objects can be connected to other like objects to form polylines or polyline-based objects. See “Editing Open Polyline-Based Objects” on page 130 and “Editing Closed Polyline-Based Objects” on page 133.

Some objects, notably curved walls, have arc-based editing behavior only when selected on certain surfaces. See “Editing Walls” on page 200.

Other objects, such as curved stairs and roads, have additional edit handles that allow you to concentrically adjust the object’s width.

The currently active **Arc Creation Mode** determines how an arc-based object is drawn. Once an arc is drawn, the active Arc Creation Mode does not affect it. See “Drawing Arcs - Arc Creation Modes” on page 171.

### Using the Edit Handles

When selected, a typical arc-based object displays seven edit handles.

Any action performed using the edit handles can be cancelled by pressing the Esc key or any two mouse buttons at the same time.

The behavior of the edit handles may depend on the currently active Edit Behavior. See “Defaults, Preferences, and Edit Behaviors” on page 119.

### Move
- Two Move edit handles allow the arc to be relocated without changing its shape. One is located at the center of the chord and the other, at the arc center.
- If you would like to snap one of these center points to another point, use that handle when moving the arc. See “Aligning Arc Centers” on page 145.
- Click and drag the Move handle to move the object according to the currently active **Edit Behavior**. See “Defaults, Preferences, and Edit Behaviors” on page 119.
- Movement may be limited or stopped by other objects or Snap Behaviors. Move restrictions can be overridden by holding down the Ctrl key while dragging. See “Unrestricted Movement” on page 142.
Editing Arc-Based Objects

Rotate
- The **Rotate** handle is used to rotate the arc, either about its center or about the current CAD point. See “Rotating Objects” on page 148.

Extend
- The end edit handles expand or contract the arc when moved along the arc radius or chord.
- If you follow the path of the arc, the end edit handles allow you to adjust the arc length.
- The angle formed by the center point of the arc and its two endpoints is referred to as the Included Angle. If **Angle Snaps** are on, the Included Angle of the arc, as measured in degrees, can be rotated at Allowed Angles. See “Angle Snaps” on page 101.
- Right-click and drag it to change the adjacent arc into a line, or vice versa. See “Alternate” on page 120.

Resize
- Drag the small, round **Resize** edit handle to change the radius and included angle of the arc while maintaining its center.

Reshape
- Drag the small triangular **Reshape** handle to change the length and location of the center without moving the endpoints.

Same Line Type
- Drag a diamond-shaped end handle in any direction to draw a new line that shares the arc’s color, weight, line style, and layer. See “Same Line Type Edit Handles” on page 168.

Adjust Width
Some arc-based objects, such as stairs, have additional handles that allow the width of the object to be adjusted.

Using Dimensions
- Dimensions can be used to position arc-based objects. Dimension lines typically locate tangent extension lines and any extension lines that may be parallel to those lines rather than the arc itself. See “Moving Objects Using Dimensions” on page 263.

Using the Specification Dialog
Arc-based objects can be edited using their specification dialogs. See “Arc Specification Dialog” on page 174.

Using the Edit Toolbar
A selected arc-based object can be edited in a variety of ways using the buttons on the edit toolbar.

The following toolbar buttons may display on the edit toolbar for a selected arc-based object:
• Click the Select Next Object edit button to select nearby objects instead of the selected object. See “Selecting Objects” on page 123.

• Click the Open Object edit button to open the specification dialog for the selected object(s). See “Specification Dialogs” on page 32.

• Click the Copy/Paste edit button to copy the selected object(s) to the system clipboard so they can be pasted elsewhere. See “Copying and Pasting Objects” on page 104.

• Click the Delete edit button to delete the selected object(s). See “Deleting Objects” on page 157.

• Click the Transform/Replicate Object edit button to copy, move, rotate, resize, or reflect the selected object(s). See “Transform/Replicate Object Dialog” on page 151.

• Click the Point to Point Move edit button to accurately move the selected object(s). See “Using Point to Point Move” on page 143.

• Click the Center Object edit button to center an object along a wall within a room or relative to a cabinet fixture. See “Using Center Object” on page 144.

• Click the Reflect About Object edit button to reflect the selected object(s) about another object. See “Reflecting Objects” on page 150.

• Click the View Drawing Group Edit Tools edit button to modify the selected object’s place in the drawing order. See “Drawing Group Edit Tools” on page 114.

• Click the Break edit button to add a new corner or pivot point to the selected object. See “Break” on page 146.

• Click the Complete Break edit button to break the selected object into two separate objects. See “Break” on page 146.

• Click the Reverse Direction edit button to reverse the direction of the selected object(s). See “Reverse Direction” on page 150.

• Click the Convert Polyline edit button to convert the object into a special polyline-based object. See “Convert Polyline” on page 151.

• Click the Change Line/Arc edit button to change an arc-based object to a line, or vice versa. See “Change Line/Arc” on page 147.

• Click the Intersect/Join Two Lines edit button, then click on a non-parallel line or arc to join the two objects. See “Intersect/Join Two Lines” on page 147.

• Click the Fillet Lines edit button, then click on a non-parallel line or arc to create an additional arc connecting the two. See “Fillet Lines” on page 148.

• Click the Chamfer Lines edit button, then click an edge adjacent to the selected edge to chamfer the corner between them. See “Chamfer Lines” on page 148.

Arc Centers and Ends

When working with arc-based objects or circles, it can be helpful to see their center points. Similarly, when snapping arcs together to form a polyline, seeing their endpoints can be helpful. Select View> Arc Centers and Ends to toggle the display of both on the current floor. You can also turn on their display in the CAD Defaults dialog. See “CAD Defaults Dialog” on page 161.

Arc-based objects can be aligned using their center points. See “Aligning Arc Centers” on page 145.

Editing Open Polyline-Based Objects

Open polyline-based objects are composed of individual line- and arc-based objects that are connected at their end points but do not form an enclosed area. See “Polylines” on page 176.

Objects are considered open polyline-based when they can be edited similar to open CAD polylines using their edit handles.

Open CAD polylines, connected walls, stairs, and connected roads are examples of open polyline-based objects.

For information about editing closed polyline-based objects, see “Editing Closed Polyline-Based Objects” on page 133.
Other objects, such as connected stair and road segments, have additional edit handles that allow you to concentrically adjust the width of all segments of the object. If Connect CAD Segments is disabled, clicking on a CAD polyline edge selects the individual edge rather than the entire polyline. See “Disconnect Edges” on page 124.

Using the Edit Handles

A polyline can be composed of many segments. See “Polylines” on page 176.

When selected, an open polyline-based object displays a Move handle, a Rotate handle, a Reshape handle at the intersection of each segment, and an Extend handle at each end.

Each straight, line-based segment also has a Move edit handle along its length.

Each curved, arc-based segment has its own Move handle at the center of its chord, a Resize handle and, if it has an unlocked center, a Reshape handle. See “Editing Arc-Based Objects” on page 128.

When a polyline is selected, the edge that you click nearest is called the selected edge, and certain operations affect only this edge. The Move handle of the selected edge is larger than that of other edges. It displays along the length of a line segment, or at the center of the chord on an arc segment. See “Selected Edge” on page 123.

Any action performed using the edit handles can be cancelled by pressing the Esc key or any two mouse buttons at the same time.

Move

- Click and drag the Move handle to move the object according to the currently active Edit Behavior.

- Movement may be limited or stopped by other objects or Snap Behaviors. Move restrictions can be overridden by holding down the Ctrl key while dragging. See “Unrestricted Movement” on page 142.

Rotate

- The Rotate handle is used to rotate the object, either about its center or about the current CAD point. Its position varies depending on which edge is currently selected. See “Rotating Objects” on page 148.

Extend

- Click and drag an Extend handle to lengthen or shorten the unconnected end of the selected line or arc segment, or to change the radius of the selected arc. See “Editing Arc-Based Objects” on page 128.

- Right-click and drag it to change the adjacent line into an arc, or vice versa. See “Alternate” on page 120.

Reshape

- Click and drag a Reshape edit handle to change the angle and/or length of the segments on either side of it, or the size of the object, depending on the currently active Edit Behavior.

The behavior of the edit handles depends on the currently active Edit Behavior. See “Defaults, Preferences, and Edit Behaviors” on page 119.
Move Line Segment
- The Move Line Segment edit handle is found on straight segments of open polylines and moves the straight section according to the currently active Edit Behavior. Adjacent segments may extend or contract in their original directions to maintain their connections.

Move Arc
- Click and drag the Move Arc edit handle to change the radius and/or chord length or position, depending on the currently active Edit Behavior, and whether the arc has a locked center. Adjacent segments may extend, contract, or change angle to maintain their connections.

Resize Arc
- Click and drag the Resize Arc edit handle to change the radius, chord length and chord position of the arc segment, depending on the currently active Edit Behavior, and whether the arc has a locked center. Adjacent segments may extend, contract, or change angle to maintain their connections.

Reshape Arc
- Click and drag the Reshape Arc edit handle to change the radius of the arc without moving its end points. Only available if the arc has an unlocked center.

Same Line Type
- Drag a diamond-shaped end handle in any direction to draw a new line that shares the original polyline’s color, weight, line style, and layer. See “Same Line Type Edit Handles” on page 168.

Adjust Width
Some open polyline-based objects, such as stairs and roads, have additional handles that allow the width of the object to be adjusted.

Snap Unit is defined in the Plan Defaults dialog. See “General Plan Defaults Dialog” on page 59.

Using Dimensions
- Dimensions can be used to move or reshape polyline-based objects. See “Moving Objects Using Dimensions” on page 263.

Using the Specification Dialog
- Open polyline-based objects can be edited using their specification dialogs. See “Polyline Specification Dialog” on page 177.

Using the Edit Toolbar
A selected open polyline-based object can be edited in a variety of ways using the buttons on the edit toolbar.

The following toolbar buttons may display on the edit toolbar for a selected open polyline-based object:
- Click the Select Next Object edit button to select nearby objects instead of the selected object. See “Selecting Objects” on page 123.
- Click the Open Object edit button to open the specification dialog for the selected object(s). See “Specification Dialogs” on page 32.
- Click the Copy/Paste edit button to copy the selected object(s) to the system clipboard so they can be pasted elsewhere. See “Copying and Pasting Objects” on page 104.
- Click the Delete edit button to delete the selected object(s). See “Deleting Objects” on page 157.
- Click the Disconnect Selected Edge edit button to disconnect the selected edge of the polyline, turning it into a separate object. See “Disconnect Edges” on page 124.
- Click the Transform/Replicate Object edit button to copy, move, rotate, resize, or reflect the selected object(s). See “Transform/Replicate Object Dialog” on page 151.
- Click the Make Parallel/Perpendicular edit button to make the selected straight edge parallel or perpendicular to another straight edge. See “Using Make Parallel/Perpendicular” on page
• Click the **Point to Point Move** edit button to accurately move the selected object(s). See “Using Point to Point Move” on page 143.

• Click the **Center Object** edit button to center an object along a wall within a room or relative to a cabinet fixture. See “Using Center Object” on page 144.

• Click the **Reflect About Object** edit button to reflect the selected object(s) about another object. See “Reflecting Objects” on page 150.

• Click the **View Drawing Group Edit Tools** edit button to modify the selected object’s place in the drawing order. See “Drawing Group Edit Tools” on page 114.

• Click the **Break** edit button to add a new corner or pivot point to the selected object. See “Break” on page 146.

• Click the **Complete Break** edit button to break the selected object into two separate objects. See “Break” on page 146.

• Click the **Reverse Direction** edit button to reverse the direction of the selected object(s). See “Reverse Direction” on page 150.

• Click the **Close Polyline** edit button to convert the selected open polyline into a closed polyline. See “Using Close Polyline” on page 133.

• Click the **Convert Polyline** edit button to convert the object into a special polyline-based object. See “Convert Polyline” on page 151.

• Click the **Change Line/Arc** edit button to change a line-based polyline edge to an arc, or vice versa. See “Change Line/Arc” on page 147.

• Click the **Record Walkthrough Along Path** edit button to record a walkthrough video of your model along the path defined by the selected polyline. See “Walkthrough Paths” on page 616.

• Click the **Intersect/Join Two Lines** edit button, then click on a non-parallel line or arc to join the two objects. See “Intersect/Join Two Lines” on page 147.

• Click the **Fillet Lines** edit button, then click on an adjacent edge to create an arc connecting the two. See “Fillet Lines” on page 148. Cannot be used if the adjacent edge is an arc.

• Click the **Chamfer Lines** edit button, then click on an edge adjacent to the selected edge to chamfer the corner between them. See “Chamfer Lines” on page 148.

---

**Using Close Polyline**

An open polyline-based object can be converted into a closed polyline using the **Close Polyline** edit tool. This tool adds an edge to the open polyline, connecting its two ends and closing the gap between them. **Close Polyline** is not available when **Connect CAD Segments** is enabled. See “Disconnect Edges” on page 124.

---

**Editing Closed Polyline-Based Objects**

Closed polyline-based objects are composed of individual line- and arc-based objects joined end-to-end and forming an enclosed area. See “Polylines” on page 176.

Objects are considered closed polyline-based when they can be edited similar to closed CAD polylines using their edit handles.

Closed CAD polylines, slabs and roof planes are examples of closed polyline-based objects.

Some objects, notably walls, have closed polyline-based editing behavior only when they are selected on certain surfaces in 3D views. See “Editing Walls” on page 200.

For information about editing open polyline-based objects, see “Editing Open Polyline-Based Objects” on page 130.
Other objects, such as connected road segments, have additional edit handles that allow you to concentrically adjust the width of all segments of the object.

Any action performed using the edit handles can be cancelled by pressing the Esc key or any two mouse buttons at the same time.

The behavior of the edit handles may depend on the currently active Edit Behavior. See “Defaults, Preferences, and Edit Behaviors” on page 119.

Using the Edit Handles

A polyline can be composed of many segments. See “Polylines” on page 176.

When selected, a closed polyline-based object displays a Move handle, a Rotate handle, and a Reshape handle at the intersection of each segment.

Each straight, line-based segment has a Move edit handle along its length.

Each curved, arc-based segment has its own Move handle at the center of its chord, a Resize handle and, if it has an unlocked center, a Reshape handle. See “Editing Arc-Based Objects” on page 128.

When a polyline is selected, the edge that you click nearest is called the selected edge, and certain operations affect only this edge. The Move handle of the selected edge is larger than that of other edges. It displays along the length of a line segment, or at the center of the chord on an arc segment. See “Selected Edge” on page 123.

Move
- Click and drag the Move handle to move the object according to the currently active Edit Behavior.
- Movement may be limited or stopped by other objects or Snap Behaviors. Move restrictions can be overridden by holding down the Ctrl key while dragging. See “Unrestricted Movement” on page 142.

Rotate
- The Rotate handle is used to rotate the object, either about its center or about the current CAD point. Its position varies depending on which edge is currently selected. See “Rotating Objects” on page 148.

Reshape
- Click and drag a Reshape edit handle to change the angle and/or length of the segments on either side of it, or the size of the object, depending on the currently active Edit Behavior.

Move Line Segment
- The Move Line Segment edit handle is found on straight segments of closed polylines and moves the straight section according to the currently active Edit Behavior. Adjacent segments may extend or contract in their original directions to maintain their connections.
Move Arc
- Click and drag the Move Arc edit handle to change the radius and/or chord length or position, depending on the currently active Edit Behavior and whether the arc has a locked center. Adjacent segments may extend, contract, or change angle to maintain their connections.

Resize Arc
- Click and drag the Resize Arc edit handle to change the radius, chord length and chord position of the arc segment, depending on the currently active Edit Behavior and whether the arc has a locked center. Adjacent segments may extend, contract, or change angle to maintain their connections.

Reshape Arc
- Click and drag the Reshape Arc edit handle to change the radius of the arc without moving its end points. Only available if the arc has an unlocked center.

Using Dimensions
Dimensions can be used to move or reshape closed polyline-based objects. See “Moving Objects Using Dimensions” on page 263.

Using the Specification Dialog
Closed polyline-based objects can be edited using their specification dialogs. See “Polyline Specification Dialog” on page 177.

Using the Edit Toolbar
A selected closed polyline-based object can be edited in a variety of ways using the buttons on the edit toolbar.

The following toolbar buttons may display on the edit toolbar for a selected closed polyline-based object:

- Click the Select Next Object edit button to select nearby objects instead of the selected object. See “Selecting Objects” on page 123.

- Click the Open Object edit button to open the specification dialog for the selected object(s). See “Specification Dialogs” on page 32.

- Click the Copy/Paste edit button to copy the selected object(s) to the system clipboard so they can be pasted elsewhere. See “Copying and Pasting Objects” on page 104.

- Click the Delete edit button to delete the selected object(s). See “Deleting Objects” on page 157.

- Click the Disconnect Selected Edge edit button to disconnect the selected edge of the polyline, turning it into a separate object. See “Disconnect Edges” on page 124.

- Click the Transform/Replicate Object edit button to copy, move, rotate, resize, or reflect the selected object(s). See “Transform/Replicate Object Dialog” on page 151.

- Click the Make Parallel/Perpendicular edit button to make the selected straight edge parallel or perpendicular to another straight edge by either rotating the selected edge or the entire polyline. See “Using Make Parallel/Perpendicular” on page 144. Not available when the selected edge is an arc.

- Click the Point to Point Move edit button to accurately move the selected object(s). See “Using Point to Point Move” on page 143.

- Click the Center Object edit button to center an object along a wall within a room or relative to a cabinet fixture. See “Using Center Object” on page 144.

- Click the Reflect About Object edit button to reflect the selected object(s) about another object. See “Reflecting Objects” on page 150.

- Click the View Drawing Group Edit Tools edit button to modify the selected object’s place in the drawing order. See “Drawing Group Edit Tools” on page 114.

- Click the Break edit button to add a new corner or pivot point to the selected object. See “Break” on page 146.

- Click the Complete Break edit button to break an edge of the selected object into two separate objects. See “Break” on page 146.

- Click the Reverse Direction edit button to reverse the direction of the selected object(s). See “Reverse Direction” on page 150.
• Click the Convert Polyline edit button to convert the object into a special polyline-based object. See “Convert Polyline” on page 151.

• Click the Change Line/Arc edit button to change a line-based polyline edge to an arc, or vice versa. See “Change Line/Arc” on page 147.

• Click the Record Walkthrough Along Path edit button to record a walkthrough video of your model along the path defined by the selected polyline. See “Walkthrough Paths” on page 616.

• Click the Intersect/Join Two Lines edit button, then click on a non-parallel line or arc to join the two objects. See “Intersect/Join Two Lines” on page 147.

• Click the Fillet Lines edit button, then click on an adjacent edge to create an arc connecting the two. See “Fillet Lines” on page 148. Cannot be used if the adjacent edge is an arc.

• Click the Chamfer Lines edit button, then click an edge adjacent to the selected edge to chamfer the corner between them. See “Chamfer Lines” on page 148.

Editing Box-Based Objects

Objects are considered box-based when they can be edited similar to CAD boxes using their edit handles.

Box-based objects are similar to closed polyline-based objects, but must always have four sides with right-angled corners.

In addition to the CAD Box tools, Text objects, many library symbols, pictures and images are examples of box-based objects.

Using the Edit Handles

When selected, a box-based object displays ten edit handles. Unlike polylines, boxes must always have four sides with right-angled corners.

Any action performed using the edit handles can be cancelled by pressing the Esc key or any two mouse buttons at the same time.

• Click and drag the Move handle to move the object according to the currently active Edit Behavior. See “Defaults, Preferences, and Edit Behaviors” on page 119.

• Movement may be limited or stopped by other objects or Snap Behaviors. Move restrictions can be overridden by holding down the Ctrl key while dragging. See “Unrestricted Movement” on page 142.

• The four Resize handles located at each corner are used to increase or decrease the size of the object.
• The four Extend handles display along each edge. If you select an object on an edge, the Extend handle displays at the point where you clicked; otherwise, it displays at the center of the edge.

• The triangular Rotate handle located near the selected edge of the object is used to rotate it either about its center or the current CAD point. The pointer changes to a circular arrow when moved over this handle. See “Rotating Objects” on page 148.

Using Dimensions

Dimensions can be used to move or reshape box-based objects. See “Moving Objects Using Dimensions” on page 263.

Using the Specification Dialog

Box-based objects can be edited using their specification dialogs. See “Box Specification Dialog” on page 179.

Using the Edit Toolbar

A selected box-based object can be edited in a variety of ways using the buttons on the edit toolbar.

The following toolbar buttons may display on the edit toolbar for a selected box-based object:

• Click the Select Next Object edit button to select nearby objects instead of the selected object. See “Selecting Objects” on page 123.

• Click the Open Object edit button to open the specification dialog for the selected object(s). See “Specification Dialogs” on page 32.

• Click the Copy/Paste edit button to copy the selected object(s) to the system clipboard so they can be pasted elsewhere. See “Copying and Pasting Objects” on page 104.

• Click the Delete edit button to delete the selected object(s). See “Deleting Objects” on page 157.

• Click the Transform/Replicate Object edit button to copy, move, rotate, resize, or reflect the selected object(s). See “Transform/Replicate Object Dialog” on page 151.

• Click the Make Parallel/Perpendicular edit button to make the selected straight edge parallel or perpendicular to another straight edge. See “Using Make Parallel/Perpendicular” on page 144. Not available when the selected edge is an arc.

• Click the Point to Point Move edit button to accurately move the selected object(s). See “Using Point to Point Move” on page 143.

• Click the Center Object edit button to center an object along a wall within a room or relative to a cabinet fixture. See “Using Center Object” on page 144.

• Click the Reflect About Object edit button to reflect the selected object(s) about another object. See “Reflecting Objects” on page 150.

• Click the View Drawing Group Edit Tools edit button to modify the selected object’s place in the drawing order. See “Drawing Group Edit Tools” on page 114.

• Click the Convert Polyline edit button to convert the object into a special polyline-based object. See “Convert Polyline” on page 151.
Editing Spline-Based Objects

A Spline is a curve that passes smoothly through a set of points, or vertices. Splines are typically used in situations where an irregular, free-flowing curve is needed.

Objects are considered spline-based when they can be edited similar to CAD splines using their edit handles. See “Splines” on page 180.

Sprinkler lines, spline terrain curbs, spline terrain walls and both round and kidney-shaped terrain features are spline-based objects. See “Terrain” on page 637.

Using the Edit Handles

When a spline is selected, several different types of handles display.

Any action performed using the edit handles can be cancelled by pressing the Esc key or any two mouse buttons at the same time.

Move

• Click and drag the Move handle to move the object according to the currently active Edit Behavior. See “Defaults, Preferences, and Edit Behaviors” on page 119.

• Movement may be limited or stopped by other objects or Snap Behaviors. Move restrictions can be overridden by holding down the Ctrl key while dragging. See “Unrestricted Movement” on page 142.

Rotate

• Click and drag the Rotate edit handle to rotate the entire spline.

Vertex

• The Vertex edit handles display along the spline at each vertex. Click and drag a Vertex edit handle to change the length, angle and curve of adjacent segments without affecting other vertices.

Same Line Type

• Drag a diamond-shaped end handle in any direction to draw a new spline segment that shares the original spline’s color, weight, line style, and layer. See “Same Line Type Edit Handles” on page 168.

Using the Specification Dialog

Spline-based objects can be edited using their specification dialogs. See “Polyline Specification Dialog” on page 177.

Using the Edit Toolbar

A selected spline-based object can be edited in a variety of ways using the buttons on the edit toolbar.

The following toolbar buttons may display on the edit toolbar for a selected spline-based object:

• Click the Select Next Object edit button to select nearby objects instead of the selected object. See “Selecting Objects” on page 123.

• Click the Open Object edit button to open the specification dialog for the selected object(s). See “Specification Dialogs” on page 32.

• Click the Copy/Paste edit button to copy the selected object(s) to the system clipboard so they
can be pasted elsewhere. See “Copying and Pasting Objects” on page 104.

- Click the **Delete** edit button to delete the selected object(s). See “Deleting Objects” on page 157.

- Click the **Transform/Replicate Object** edit button to copy, move, rotate, resize, or reflect the selected object(s). See “Transform/Replicate Object Dialog” on page 151.

- Click the **Make Parallel/Perpendicular** edit button to make the selected spline edge parallel or perpendicular to another straight edge. See “Using Make Parallel/Perpendicular” on page 144.

- Click the **Point to Point Move** edit button to accurately move the selected object(s). See “Using Point to Point Move” on page 143.

- Click the **Center Object** edit button to center an object along a wall within a room or relative to a cabinet fixture. See “Using Center Object” on page 144.

- Click the **Reflect About Object** edit button to reflect the selected object(s) about another object. See “Reflecting Objects” on page 150.

- Click the **View Drawing Group Edit Tools** edit button to modify the selected object’s place in the drawing order. See “Drawing Group Edit Tools” on page 114.

- Click the **Break** edit button to add a new corner or pivot point to the selected object. See “Break” on page 146.

- Click the **Complete Break** edit button to break an edge of the selected object into two separate objects. See “Break” on page 146.

- Click the **Convert Polyline** edit button to convert the object into a special polyline-based object. See “Convert Polyline” on page 151.

- Click the **Record Walkthrough Along Path** edit button to record a walkthrough video of your model along the path defined by the selected polyline. See “Walkthrough Paths” on page 616.

---

**Editing Circles, Ovals and Ellipses**

Objects created using the **Circle Tools** are unusual in that no architectural objects share their functionalities.

---

**Using the Edit Handles**

When selected, circles, ovals and ellipses display eleven edit handles.

Unlike **Ovals** and **Ellipses**, a **Circle** cannot be edited into any other shapes; it can only be a circle.

Any action performed using the edit handles can be cancelled by pressing the Esc key or any two mouse buttons at the same time.

---

<table>
<thead>
<tr>
<th>Move</th>
<th>Rotate</th>
<th>Reshape</th>
<th>Concentric Resize</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Move" /></td>
<td><img src="image" alt="Rotate" /></td>
<td><img src="image" alt="Reshape" /></td>
<td><img src="image" alt="Concentric Resize" /></td>
</tr>
</tbody>
</table>

**Move**

- Click and drag the Move handle to move the object according to the currently active **Edit Behavior**. See “Defaults, Preferences, and Edit Behaviors” on page 119.

- Movement may be limited or stopped by other objects or Snap Behaviors. Move restrictions can be overridden by holding down the Ctrl key while dragging. See “Unrestricted Movement” on page 142.

**Rotate**

- Click and drag the Rotate handle of an oval or ellipse to change its orientation.
Reshape

• The eight edit handles beyond the perimeter are Reshape edit handles. Move them in or out to resize and reshape an oval or ellipse.

• Unlike ovals and ellipses, circles cannot be reshaped. When a Reshape handle is dragged on a circle, it is only resized.

Concentric Resize

• The Concentric Resize edit handle displays on the perimeter of a circle between a corner Reshape handle and the center. Click and drag this handle to resize the circle without moving its center point.

Using Dimensions

Dimensions can be used to move or resize circle-based objects. See “Moving Objects Using Dimensions” on page 263.

Using the Specification Dialog

Circles, ovals and ellipses can be edited using their specification dialogs. See “Circle/Oval/Ellipse Specification Dialog” on page 176.

Using the Edit Toolbar

A selected circle, oval or ellipse can be edited in a variety of ways using the buttons on the edit toolbar.

The following toolbar buttons may display on the edit toolbar for a selected circle, oval or ellipse:

• Click the Select Next Object edit button to select nearby objects instead of the selected object. See “Selecting Objects” on page 123.

• Click the Open Object edit button to open the specification dialog for the selected object(s). See “Specification Dialogs” on page 32.

• Click the Copy/Paste edit button to copy the selected object(s) to the system clipboard so they can be pasted elsewhere. See “Copying and Pasting Objects” on page 104.

• Click the Delete edit button to delete the selected object(s). See “Deleting Objects” on page 157.

• Click the Transform/Replicate Object edit button to copy, move, rotate, resize, or reflect the selected object(s). See “Transform/Replicate Object Dialog” on page 151.

• Click the Make Parallel/Perpendicular edit button to make the selected edge parallel or perpendicular to another straight edge. See “Using Make Parallel/Perpendicular” on page 144.

• Click the Point to Point Move edit button to accurately move the selected object(s). See “Using Point to Point Move” on page 143.

• Click the Center Object edit button to center an object along a wall within a room or relative to a cabinet fixture. See “Using Center Object” on page 144.
• Click the **Reflect About Object** ❮ button to reflect the selected object(s) about another object. See “Reflecting Objects” on page 150.

• Click the **View Drawing Group Edit Tools** ❮ button to modify the selected object’s place in the drawing order. See “Drawing Group Edit Tools” on page 114.

• Click the **Convert Polyline** ❮ button to convert the object into a special polyline-based object. See “Convert Polyline” on page 151.

### Editing Multiple Objects

There are a couple of options for accurately and efficiently editing multiple objects at once. See “Selecting Multiple Objects” on page 125.

### Dynamic Defaults

Dynamic defaults are one useful way to apply certain attributes to multiple objects of the same type throughout a plan. Dynamic defaults are found in the defaults dialogs for a variety of different architectural objects, and when these default values are changed, all objects that are set to use them throughout the current plan will update automatically. Dynamic defaults are particularly valuable for applying critical defaults like ceiling heights and floor structure. See “Dynamic Defaults” on page 58.

### Moving Objects

Objects can be moved using the edit handles as well as a variety of edit tools. Multiple selected objects can also be moved as a group. See “Selecting Objects” on page 123.

#### Using the Edit Handles

Select an object, then click the **Move** edit handle and drag it to a new location. When your pointer is over the Move handle, it displays a four-headed arrow.

As an object is moved, it jumps at set increments when **Grid Snaps** ❮ are enabled. See “Grid Snaps” on page 102.

### In the Specification Dialog

When multiple objects are selected, the **Open Object** edit button is often available. The settings available in a shared specification dialog will vary, depending on the types of objects that are selected. If the objects are of the same type, their shared specification dialog will have many of the settings that their individual specification dialogs have; if they are not similar, the dialog may have only a few settings. When multiple objects are selected, their shared specification dialog may also have settings in a “No Change” state. See “Specification Dialogs” on page 32.

#### Using the Edit Toolbar

Group-selected objects can also be edited using the buttons on edit toolbar. The available tools will vary, depending on which types of objects are selected.

When **Object Snaps** ❮ are enabled, a selected object snaps to its original location if it passes over that location while being moved.

The behavior of the Move edit handle varies depending on the currently active **Edit Behavior** ❮. See “Defaults, Preferences, and Edit Behaviors” on page 119.

• If the **Default**, **Resize**, **Concentric**, or **Fillet** edit behavior is active, the object moves orthogonal, or at a right angle to, any of its edges.

• If the **Alternate** edit behavior is active, the selected object(s) can be moved at Allowed Angles if **Angle Snaps** ❮ are enabled, or orthogonal to any of its edges if they are not. See “Alternate” on page 120.
You can temporarily slow the movement of your mouse as you drag an edit handle by holding down the Shift key on your keyboard.

**Bumping/Pushing**

When Edit> Snap Settings> Bumping/Pushing is enabled, architectural objects will bump into and can push one another as they are moved. This setting also affects CAD and CAD-based objects with CAD Stops Move and/or Wall Stops Move enabled. See “Line Style Panel” on page 169.

When an object bumps into another object while it is being moved, it stops. If you do not release the mouse button and continue to drag, however, the selected object resumes movement and continues past the obstructing object.

Instead of dragging through and past obstructing objects, you can instead push them. To do this, bump an object into an obstructing object and release the mouse button. Then, click and drag the Move edit handle a second time in the same direction.

Walls, wall openings, cabinets, furnishings and fixtures, and CAD and CAD-based objects are examples of objects that can bump into as well as push other objects.

By default, Bumping/Pushing does not affect objects moved using dimensions. See “Moving Objects Using Dimensions” on page 263.

The Maximum Bump Distance, which is the distance you must drag to override bumping, is set in the Preferences dialog. Bumping/Pushing for Type-in Movement can also be enabled there. See “Snap Properties Panel” on page 76.

Certain types of objects, notably roof planes, and objects on locked layers can be bumped but cannot be pushed. See “Layer Display Options Dialog” on page 111.

**CAD Stops Move/Wall Stops Move**

CAD and CAD-based objects can be set to stop at other CAD objects and/or at walls as they are being moved. See “Line Style Panel” on page 169.

Some objects, such as cross boxes, framing members and insulation, are automatically set to stop when moved against other CAD objects.

CAD Stops Move and Wall Stops Move do not function if Bumping/Pushing is turned off.

**Unrestricted Movement**

Many objects have restrictions placed on their movement by their own properties or specification settings. Architectural objects, for example, bump into other 3D objects as they are being moved when Bumping/Pushing is enabled.

CAD-based objects can be set to stop at other CAD objects or at walls. See “Line Style Panel” on page 169.

Other move restrictions are activated by the Snap Settings. See “Snap Behaviors” on page 100.

These restrictions can be overridden when necessary by holding down the Ctrl key while dragging to move an object.

**To move an object freely**

1. Select the object.
2. Hold down the Ctrl key.
3. Click the Move edit handle and drag it to the new location.

You can also press the Ctrl key while dragging an object’s Move handle to override move restrictions.

**Nudging**

You can use the arrow keys on your keyboard to move a selected object or objects by single Snap Grid increments in 2D and 3D views. This is referred to as nudging. See “Grid Snaps” on page 102.

**In Plan View**

To nudge an object in plan view, select it and press any of the four arrow keys: Up, Down, Left, or Right. These directions are relative to the Snap Grid: if Rotate Plan View is used to rotate plan view, the definitions of up, down, left, and right are affected. See “Rotate Plan View” on page 94.

**In 3D Views**

In 3D views, nudging is relative to the selected surface. If, for example, you select the front of a cabinet in 3D and nudge it to the left, it will move to the left in plan view. If you instead select the back of a cabinet in 3D and nudge it to the left, it will move to the right in plan view.

When multiple objects are selected, the surface that was clicked on last is considered the selected surface. When nudged, all selected objects will move relative
to that surface. See “Shift and Ctrl Select” on page 125.

If an object is rotated, the directions that it can be nudged in 2D are not affected; however, in 3D, they are. If, for example, a cabinet is rotated 45°, it will nudge to the left as defined by the Snap Grid in plan view. When nudged in 3D, however, it will move at a 45° angle to the Snap Grid: or parallel to the selected surface.

**Using Point to Point Move**

The **Point to Point Move** edit button allows a selected object or group of objects to be accurately moved.

**To use Point to Point Move**

1. Select one or more objects that you would like to move, then click the **Point to Point Move** edit button.
2. The mouse pointer displays the Point A icon. Click on a point that you want to accurately reposition.
3. An extension line extends from Point A to the mouse pointer, which now displays the Point B icon.
4. Click on the point in the plan where you would like the selected point to be relocated when it is moved.
5. The selected object(s) are moved so that they maintain their position relative to the point.

**Point to Point Move** can also be used with the **Copy/Paste** edit button. See “To use point to point copy” on page 106.

**Center Object**

The **Center Object** edit button allows you to move walls, cabinets and other objects so that they are centered along a wall within a room or relative to a window or cabinet.

**Move to Framing Reference**

Framing members can be positioned relative to a Framing Reference using the **Move to Framing Reference** edit tool. See “Framing Reference Marker” on page 469.

**Using Dimensions**

Objects or the selected edges of some objects can be moved using dimensions. See “Moving Objects Using Dimensions” on page 263.

When **Bumping/Pushing for Type-in Movement** is checked in the **Preferences** dialog, adjacent objects can be pushed when an object is moved using dimensions.

**Using the Transform/Replicate Object Dialog**

Objects and groups of objects can be moved relative to themselves or an absolute location using the **Transform Replicate Object** dialog. See “Transform/Replicate Object Dialog” on page 151.

**Aligning Objects**

It is often important to align objects such as text boxes, roof plane edges, or walls, or to align objects on different floors. There are several methods to choose from.

**Using the Mouse Pointer Crosshairs**

Objects can be aligned by eye using the mouse pointer crosshairs as a reference. This method can help you draw, place and edit objects quickly, easily, and with reasonable accuracy, but is not necessarily as accurate as some of the other approaches described here. See “Crosshairs” on page 27.

The mouse pointer crosshairs can be turned on and off and their size and aperture set in the **Preferences** dialog. See “Edit Panel” on page 73.

**Using Snap Settings**

With **Object Snaps** on, you can snap the edge of a selected object to that of another. Select an edge of
an object. Drag it to the edge of another object to reveal an Object Snap point, then release the mouse.

With **Grid Snaps** and **Angle Snaps** off, select the left side of the object, and drag from the center move handle. This snaps the selected side to the grid.

When both **Grid Snaps** and **Angle Snaps** on, objects snap at increments equal to the **Snap unit** specified in the **Plan Defaults** dialog rather than onto the grid itself. This does not align objects to the grid unless they were already snapped to the grid. See “Snap Behaviors” on page 100.

**Using Dimensions**

Create a temporary or manual dimension relative to an object such as a wall or line, and relocate the objects to the same dimension. See “Moving Objects Using Dimensions” on page 263.

**CAD Stops Move/Wall Stops Move**

CAD and CAD-based objects can be aligned using another CAD object or a wall as a guide. Check the **CAD Stops Move** and/or **Wall Stops Move** boxes in the objects’ specification dialogs, then move them until they bump into the CAD object or wall that you wish to use as a guide for alignment. See “Line Style Panel” on page 169.

**Using Make Parallel/Perpendicular**

The **Make Parallel/Perpendicular** edit button allows you to make a selected object parallel or perpendicular to any straight line or edge.

If you select an edge of a polyline-based object, adjacent edges extend or contract to maintain contact, but other edges remain unchanged. The selected edge rotates about its endpoint if selected near the end, or about its center if you click within its middle third.

A few objects, such as camera symbols, are not eligible to be used as an axis for the **Make Parallel/Perpendicular** tool.

**To use Make Parallel/Perpendicular**

1. Select an object such as a roof plane on the edge that you would like to make parallel or perpendicular to another object.
   - Click near the center of the edge to rotate it about the center.
   - Click near an end to rotate the edge about that end.
2. Click the **Make Parallel/Perpendicular** edit button
3. Click on a straight edge of an eligible object such as a wall.
4. If the first object is within 45° of parallel to the second object, it is made parallel. Otherwise, it is made perpendicular to the second object.

You can also make the selected edge parallel by rotating the entire object. See “Make Parallel/Perpendicular with Polyline-Based Objects” on page 149.

**Using Center Object**

The **Center Object** edit button can be used to center a variety of objects either relative to another object. Center Object can be used to center architectural objects in floor plan, cross section/elevation, and 3D views. It can also be used to center CAD objects in plan view and layout.

A few objects, such as camera symbols, are not eligible to be used as a centering axis.

**To center an object**

1. Select an object.
2. Click the **Center Object** edit button.
3. Move the mouse pointer over the object you would like to center the selected object relative to.
• As the pointer passes over an eligible object, it becomes highlighted and a dashed centering axis line displays.

4. When the desired centering axis displays, click once to center the selected object along that axis line.

To center an object in a room

1. Select an object such as a cabinet.
2. Click the Center Object edit button.
3. Move the mouse pointer in the room that you would like to center the selected object relative to.
   • As you move the pointer, a centering axis will display along the wall it is closest to.
   • The selected object does not have to be inside a room in order to be centered relative to that room.
4. When a centering axis displays along the correct wall, click once.
5. The object is moved perpendicular to the centering axis.

If you click outside an exterior wall instead of clicking inside, the selected object is centered along the edge of the Exterior Room. See “The Exterior Room” on page 229.

Aligning Arc Centers

The center points of circles and arc-based objects can be aligned, even if the objects are on different floors, when the Reference Display is turned on and Arc Centers and Ends is toggled on. Note that Arc Centers and Ends is a floor-specific toggle. See “The Reference Floor” on page 393 and “Arc Centers and Ends” on page 130.

To align center points easily, it is helpful to turn on Object Snaps and turn off Angle Snaps. See “Object Snaps” on page 101 and “Angle Snaps” on page 101.

Aligning Objects on Different Floors

Objects on different floors can be aligned with one another using Object Snaps and the Reference Display. See “Object Snaps” on page 101 and “The Reference Floor” on page 393.

Resizing Objects

Objects can be resized using the edit handles, specification dialogs, and the Transform/Replicate Object dialog.

Using the Edit Handles

Depending on the currently active Edit Behavior, the end, corner and/or side edit handles can be used to resize a selected object. See “Defaults, Preferences, and Edit Behaviors” on page 119.

When the Concentric edit behavior is active, dragging an object’s corner or end handle resizes it according to the Concentric Jump value set in the Preferences dialog. See “Concentric” on page 121.

Objects can be resized about either their center points or the current CAD point. See “Behaviors Panel” on page 75.

To override any movement restrictions caused by snap settings or the presence of other objects, press the Ctrl key while dragging an edit handle.

As an object is resized, any dimensions indicating its size will update to reflect your changes. You can use dimensions as references to help you achieve the correct size for most objects.

You can temporarily slow the movement of your mouse as you drag an edit handle by holding down the Shift key on your keyboard.

Using the Specification Dialog

Most objects can be accurately resized in their specification dialogs. See “Specification Dialogs” on page 32.

Using Dimensions

Many objects can be resized by selecting an edge and then moving that edge using dimensions. See “Moving Objects Using Dimensions” on page 263.

Walls can also be resized using dimensions; however, it is important to understand that the selected edges of other objects cannot be resized using dimensions - they can only be moved. To resize an edge, select an adjacent edge and move that edge instead.
Using the Transform/Replicate Object Dialog

Most objects can be resized about either their centers or an absolute point using the Transform Replicate Object dialog. See “Transform/Replicate Object Dialog” on page 151.

Reshaping Objects

There is a variety of ways to reshape objects using the edit handles, specification dialogs and edit toolbar buttons.

Some objects, notably circles and box-based objects, cannot be reshaped - only resized. See “Resizing Objects” on page 145.

Using the Edit Handles

Depending on the Edit Behavior, in use, the end, corner and/or side edit handles can be used to reshape a selected object. See “Defaults, Preferences, and Edit Behaviors” on page 119.

When a line-based, arc-based, or open polyline-based object is selected, you can right-click and drag an end handle to change a line into an arc or vice versa. This behavior does not apply to closed polylines.

To override any movement restrictions caused by snap settings or the presence of other objects, press the Ctrl key while dragging an edit handle.

You can temporarily slow the movement of your mouse as you drag an edit handle by holding down the Shift key on your keyboard.

Using the Specification Dialog

A variety of CAD and CAD-based objects can be reshaped by editing values on either the SELECTED LINE or SELECTED ARC panel of their specification dialogs. See “Polyline Specification Dialog” on page 177.

Using Dimensions

Both temporary and manually drawn dimensions can be used to increase or decrease the distance between the edge a line- or polyline-based object and another, parallel edge or line.

Angular Dimensions can be used to adjust the angle where two polyline segments meet. See “Using Angular Dimensions” on page 149.

Break

The Break edit tool can be used to break an individual line-, arc-, or spline-based object into two segments. The edges of a polyline-based object can also be broken.

There are two types of breaks: partial and complete. Partial breaks create a new corner, or pivot point, while complete breaks actually sever an edge into two segments.

To create a partial break

1. Click the object, object edge, or object center-line that you want to break into two segments.
2. Click the Break edit button once or press the 3 key.
3. If you would like to create more than one break, click the Sticky Mode edit button.
4. If you would like to move the edges of the object as you add breaks, click the Edge Edit Handles edit button to toggle on their display.
5. If you want, you can click the Corner Edit Handles edit button to toggle off their display.
6. Click the edge to create a new corner edit handle at that location and two separate edges on either side of that handle.
7. If you enabled Sticky Mode, continue clicking to place additional breaks.
8. Click the Main Edit Mode edit button or press the Esc key to return to the selected object’s main edit toolbar.

Note: The Break edit button is not available for box-based objects, objects created with the Circle Tools, North Pointers, Sun Angles, Joist Direction Lines, or some architectural objects such as stairs and trusses.
If you click and drag one of the edit handles on either side of the partial break, the edge moves at a right angle to itself and another edge forms, connecting the moved edge with the one on the other side that does not move.

You can remove an edge from a polyline-based object by clicking and dragging a corner handle until it snaps to an adjacent corner handle.

When a complete break is created, the object or edge is totally severed at that point.

With the exception of framing members, complete breaks cannot be created on CAD-based architectural objects. In the case of framing members, only complete breaks can be created.

**To create a complete break**

1. Click the object, object edge, or object center-line that you want to break into two segments.
2. Click the Break edit button.
3. Click the Complete Break edit button.
4. If you would like to create more than one complete break, click the Sticky Mode edit button.
5. If you would like to move the edges of the object as you add breaks, click the Edge Edit Handles edit button to toggle on their display.
6. If you want, you can click the Corner Edit Handles edit button to toggle off their display.
7. Click on an edge to create a complete break at that location.
8. If you enabled Sticky Mode, continue clicking to place additional breaks.
9. Click the Main Edit Mode edit button or press the Esc key to return to the selected object’s main edit toolbar.

The edge that you clicked on will be divided into two separate sections, one of which will be selected. You can now move or edit the selected edge completely independent of the object or edge on the other side of the break. Click on the other edge to select it instead.

When Object Snaps are enabled, breaks can be placed at snap locations such as midpoints. See “Object Snaps” on page 101.

**To remove a break from an edge**

1. Make sure that Object Snaps are enabled.
2. Select the object that has a break that you want to remove.
3. Click on the corner edit handle associated with the break that you want to remove and drag it to an adjacent corner handle.
4. When you see an Endpoint snap indicator, release the mouse button. The handle that you selected will be removed.

**Change Line/Arc**

Select an individual line-based or arc-based object or a segment of a polyline-based object and click the Change Line/Arc edit button to convert the selected segment from a line to an arc or vice versa.

**Make Parallel/Perpendicular**

The Make Parallel edit button can be used to reshape a polyline by making a selected edge parallel or perpendicular to another straight edge. See “Using Make Parallel/Perpendicular” on page 144.

**Intersect/Join Two Lines**

The Intersect/Join Two Lines edit tool allows you to connect two non-parallel line-and/or arc-based objects or to join two edges of an open or closed polyline-based object. The lines or edges will shorten or lengthen as need to intersect at a point and join. If one or more edges exists between the two polyline edges, they will be removed.

**To use Intersect/Join Two Lines**

1. Click on a line, arc, or polyline segment that you would like to connect to another line or segment.
2. Click the Intersect/Join Two Lines edit button.
3. Click on the other line or polyline edge.
4. If there are intervening polyline edges, a message will confirm that you would like them to be removed. Click Yes.

**Fillet Lines**

The Fillet Lines edit tool allows you to replace the angled corner where two polyline edges meet with an arc or to join two non-parallel line-based objects with an arc.

If one or both of the two objects is an arc, both will extend or contract as needed to become connected. No additional arc is created.

**To use Fillet Lines**

1. Click on a line or polyline segment that you would like to connect to another line or segment with a fillet, or arc.
2. Click the Fillet Lines edit button, then click the Fillet Radius edit button.
3. In the Set Fillet Radius dialog, specify the desired Fillet Radius and click OK. If this value is 0, no fillet will be created.
4. To apply a fillet to more than one corner of the selected polyline, click the Sticky Mode edit button.
5. Click on the line or polyline segment that you want the selected line or edge to connect to with a fillet.

6. If you enabled Sticky Mode, continue clicking on edges to create additional fillets.
7. Click the Main Edit Mode edit button or press the Esc key to return to the selected object’s main edit toolbar.

Once two lines are filleted, the arc between them can be edited. See “Editing Arc-Based Objects” on page 128.

**Chamfer Lines**

The Chamfer Lines edit tool allows you to create a straight corner bevel of a specified size connecting any two non-parallel lines or polyline edges. It can also be used to extend an arc so that it joins to another arc or line.

If one or both of the two objects is an arc, both will extend or contract as needed to become connected. No additional chamfer is created.

The Chamfer Lines edit tool is used much the way the Fillet Lines edit tool is. See “To use Fillet Lines” on page 148.

**Close Polyline**

An open polyline-based object can be converted into a closed polyline using the Close Polyline edit tool. See “Using Close Polyline” on page 133.

**Simplify Polyline**

The Simplify Polyline edit button is available for an open or closed polyline or polyline-based object with a segment that is unusually short and can cause problems when editing the polyline’s shape. Click this edit button to remove the segment.

By default, an object or group of objects rotate about the center point of the selection set. You can instead specify that objects rotate about the current CAD point. See “The Current Point” on page 164.
Using the Edit Handles

Select an object, then click the triangular Rotate edit handle and drag it in any direction. When your pointer is over the Rotate handle, it displays a curved arrow.

The angles of line-based objects can also be changed by dragging an end handle in a direction other than parallel to the object. The object rotates about the opposite end point. See “Editing Line-Based Objects” on page 126.

When Angle Snaps are enabled, objects snap to Allowed Angles as specified in the Plan Defaults dialog as they are rotated. See “Angle Snaps” on page 101.

To override any movement restrictions caused by snap settings or the presence of other objects, press the Ctrl key while dragging an edit handle.

You can temporarily slow the movement of your mouse as you drag an edit handle by holding down the Shift key on your keyboard.

Using the Specification Dialog

The exact angle of some objects such as lines, arcs, walls and the selected edges of polylines can be specified on either the GENERAL panel, SELECTED LINE panel, or SELECTED ARC panel of that object’s specification dialog. See “Polyline Specification Dialog” on page 177.

Rotate/Resize About

Objects can be rotated or resized about either their own centers or the current CAD point. See “The Current Point” on page 164.

Using Angular Dimensions

Angular Dimensions are useful for adjusting the angles of a variety of objects with straight edges. See “Angular Dimensions” on page 257.

To change an angular dimension

1. Draw an Angular Dimension between the objects you want to move.
   • Begin and end as close as possible to the two objects you wish to locate.
2. Select the edge that you want to move.
3. Click the dimension value to open the Set Angular Dimension dialog.
   • The Previous Value is indicated degrees, minutes and seconds.
4. Enter a value in the New Value field.
5. Select Rotate Edge to move the selected edge when OK is clicked or select Rotate entire polyline to rotate the entire object the selected edge is a part of, maintaining the Previous Value of the angle.
6. Click OK to apply the change.

When an entire polyline is rotated using the Set Angular Dimension dialog, it rotates around the vertex of the angle.

Make Parallel/Perpendicular with Polyline-Based Objects

The Make Parallel/Perpendicular edit button usually adjusts the angle of a selected polyline edge. See “Using Make Parallel/Perpendicular” on page 144.

To rotate the entire polyline instead, double-click the Make Parallel edit button to open the Make Parallel dialog.
Choose to either **Rotate Selected Edge Only**, or **Rotate Entire Polyline**. This setting is global, affecting all files, and is retained during the current program session.

### Reflecting Objects

There are several ways to reflect an object, group of objects, or an entire plan about an axis or another object. Either the original object(s) or copies of the original(s) can be reflected.

**Reflect About Object**

A selected object or objects can be reflected about another object, regardless of its angle, using the **Reflect About Object** edit tool.

- Line-based objects are often used for reflecting a selection, but most objects have an axis that can be used.
  - When an open or closed polyline-based object is used as the reflective object, the edge that is clicked on acts as the axis.
  - When a circle or box-based object such as a CAD box or cabinet is used as the reflective object, the axis runs down the center of the object from back to front.
  - In 3D views, architectural objects can only be reflected about a vertical axis - not a horizontal axis.
  - A few objects, such as camera symbols, are not eligible to be used as a reflective object.

**To use Reflect About Object**

1. Draw a CAD line to act as the reflection line.
2. Select the object(s) to be reflected.
3. Click the **Reflect About Object** edit button.
4. Click the CAD line to reflect the selection about the line.

### Converting Objects

CAD objects and many CAD-based objects can be converted into a variety of other types of objects.

Polylines rotate according to the current **Rotate/Resize About** setting. See “Behaviors Panel” on page 75.

**Using the Transform/Replicate Object Dialog**

Objects and groups of objects can be rotated to a relative or absolute angle using the **Transform Replicate Object** dialog. See “Transform/Replicate Object Dialog” on page 151.

5. The selection is reflected around the CAD line, and the original is no longer there.

To retain a copy of the selected object(s) in the original location, click the **Copy/Paste** edit button before clicking the **Reflect About Object** button.

**Using Transform/Replicate Object**

Objects and groups of objects can also be reflected horizontally or vertically using the **Transform Replicate Object** dialog. See “Transform/Replicate Object Dialog” on page 151.

**Reverse Plan**

The **Reverse Plan** tool is a quick way to mirror a plan so that everything on all floors of the entire plan is swapped left to right.

Select **Tools > Reverse Plan** to reflect an entire plan right to left, as though it were reflected about a vertical line.

Reversing a plan rebuilds the entire model and affects views sent to layout.

**Reverse Direction**

Select a line-based, arc-based or polyline-based object and click the **Reverse Direction** edit button to reverse its direction. Not available for Terrain Path objects.

Reversing a line or polyline is useful with certain line styles or with an arrow at one end.
The **Convert Polyline** edit tool lets you to turn CAD objects into CAD-based architectural objects such as counter tops and stair landings, special polylines such as Materials List Polylines, and a variety of slab, hole and terrain objects.

To convert a CAD object into one of these 3D objects, select the object in plan view and click the **Convert Polyline** edit button to open the **Convert Polyline** dialog.

1. The **Architectural** settings are only available if the selected polyline is closed. See “Polylines” on page 176.
2. **Slab** and **Slab with Footing** - See “The Slab Tools” on page 382.
3. **Countertop** - See “Custom Countertops” on page 337.
4. **Landing** - Not available if the polyline is a spline. See “Landings” on page 403.

Most of the **Terrain** options are only available when a Terrain Perimeter is present.

Click the radio button beside one of the objects in this dialog, then click OK.

**Elevation Line** - See “Elevation Lines” on page 640.

**Garden Bed** - Only available when the selected object is a closed polyline. See “Terrain Feature Tools” on page 643.

**Sprinkler Line** - See “Sprinkler Tools” on page 675.

**Terrain Break** - See “Terrain Breaks” on page 642.

**Terrain Feature** - Only available when the selected object is a closed polyline. See “Terrain Feature Tools” on page 643.

**Terrain Perimeter** - See “Terrain Perimeter” on page 638. This option is only available when:
- The polyline is closed
- A terrain perimeter does not yet exist
- Only one polyline is currently selected

**Other** -

**Walkthrough Path** - See “Walkthrough Paths” on page 616.

Click OK to convert the object or objects.

The specification dialog appropriate to the newly converted object opens, allowing you to specify its height, material and other information.

### Convert to Plain Polyline

Click the **Convert to Plain Polyline** edit button to convert a special polyline to a plain 2D CAD polyline. See “Polylines” on page 176.

After a special polyline is converted into a plain polyline, it can be converted into a special polyline of the same or different type.

Bear in mind that some special polylines can only be converted to a plain polyline in the view type that they were created in. If a special polyline is selected and converted in a 3D view, the resulting plain polyline will be created in plan view.

**Always double-check values entered in the Transform/Replicate Object dialog. Large offset values, resize factors, or numbers of copies can result in objects that are time-consuming to create or may be off the screen.**
Check **Copy**, then specify the **Number of Copies** to make.

Check **Move**, then specify how far or where to move the object(s).

- Select **Relative to Itself** to move the object relative to its current position, then specify the **X Delta**, **Y Delta** and **Z Delta** values, which are the object's changes in position along each axis.
- Select **Absolute Location** to move the object to an absolute location. You can either specify its **X and Y Position**, or **Angle and Distance**, if **Polar** is checked.
- Select **Relative to Current Point** to move the object relative to the current CAD point. See “Point Tools” on page 163. You can either specify its **X Delta** and **Y Delta**, or **Angle and Distance**, if **Polar** is checked.

![Transform/Replicate Object dialog box](image)

- Select **Absolute Angle** to rotate the object relative to an imaginary horizontal line drawn in the positive X direction from the origin. See “3D Drafting” on page 25.
- Select **Relative Angle** to rotate the object the specified angle relative to its current orientation. You can also specify the point the selected object(s) rotate about, below.

4 Select **Resize**, then specify the **Resize Factor** in decimals. A resize factor of 2 doubles the size of the object, while a resize factor of 0.5 halves the object's size. Not available for all objects, including line- and arc-based objects and Primitives. You can also specify the point the selected object(s) is resized about, below.

5 **Reflect** - Select this option, then specify which axis to reflect about.

- **Horizontally** - Select this option to reflect the object horizontally.
- **Vertically** - Select this option to reflect the object vertically.

You can also specify the point the selected object(s) is reflected about, below.

---

When a CAD-based object is moved to a new floor, only its display in plan view is moved - its physical location in the model remains unchanged. See “Architectural vs CAD Objects” on page 99.

3 **Rotate** - Select this option, then specify the **Angle** to rotate the object(s).
The Edit Area Tools allow you to quickly define an area of your plan and select the objects in that area. Once selected, they can then be repositioned, copied or deleted. Select Edit > Edit Area to access the Edit Area Tools.

Unlike other selection methods, the Edit Area Tools cut walls, railing and fencing where the selection marquee intersects them, allowing you to edit only the selected portion of these objects. Some objects, such as cabinets, are included in the selection only if more than half of the object is contained within the marquee. Camera and cross-section/elevation symbols are included in the selection and can be moved with it. While cameras can also be rotated as well as copied, cross section/elevations cannot. See “Editing 3D Views” on page 571.

A few objects, notably CAD points, are not affected by the Edit Area Tools.

The Edit Area tools can cause wide-spread changes across an entire plan and should always be used with caution.

**Edit Area**

Select Edit > Edit Area > Edit Area and draw a rectangular marquee around the area of the plan to be edited.

**Edit Area** affects all objects included in the selection marquee that are located on the current floor, regardless of whether they are displaying in plan view or not.

**Edit Area Visible**

Select Edit > Edit Area > Edit Area Visible and draw a marquee around the area of the plan to be edited. Edit Area Visible only affects visible objects included in the selection marquee: objects not currently displayed in plan view are unaffected.

**Edit Area (All Floors)**

Select Edit > Edit Area > Edit Area (All Floors) and draw a marquee around the area of the plan to be edited. Edit Area (All Floors) affects all objects on all floors of the plan that are included in the selection marquee, regardless of whether they display in plan view.

**Edit Area (All Floors) Visible**

Select Edit > Edit Area > Edit Area (All Floors) Visible and draw a marquee around the area of the plan to be edited. Edit Area (All Floors) Visible affects all visible objects on all floors of the plan that are included in the selection marquee. Objects not currently displaying in plan view are not affected.

**Edit Area Polyline**

If a rectangular marquee’s shape does not allow you to define an area precisely, use a closed polyline instead.

Select a polyline that defines the desired area in plan view and then select one of the Edit Area Tools. The polyline becomes temporarily highlighted and acts as an Edit Area marquee.
Using the Edit Handles

An Edit Area marquee displays edit handles that are similar to those of a closed polyline. See “Using the Edit Handles” on page 134.

- Click the **Move** edit handle to move the entire selection set. See “Moving Objects” on page 141.
- Click the **Rotate** edit handle to rotate the entire selection set. See “Rotating Objects” on page 148.
- Click and drag the **Reshape** and **Resize** edit handles at each corner and along each edge to adjust the size and shape of the marquee. See “Using the Edit Handles” on page 134.

Adjusting the size or shape of an Edit Area marquee may change which objects are included in the selection set but does not otherwise affect those objects.

Using the Edit Toolbar

A selected Edit Area marquee and/or the objects within it can be edited in a variety of ways using the buttons on the edit toolbar. See “Using the Edit Toolbar” on page 135.

The following toolbar buttons may display on the edit toolbar for an Edit Area marquee:

- Click the **Copy/Paste** edit button to copy the selection set to the system clipboard so it can be pasted elsewhere. See “Copying and Pasting Objects” on page 104.
- Click the **Delete** edit button to delete the selection set. See “Deleting Objects” on page 157.
- Click the **Transform/Replicate Object** edit button to copy, move, rotate, resize, or reflect the selection set. See “Transform/Replicate Object Dialog” on page 151.
- Click the **Make Parallel/Perpendicular** edit button to rotate the Edit Area marquee and the selection set so that the selected marquee edge is parallel or perpendicular to another straight edge. See “Using Make Parallel/Perpendicular” on page 144.
- Click the **Point to Point Move** edit button to accurately move the selection set. See “Using Point to Point Move” on page 143.
- Click the **Center Object** edit button to center the selection along a wall within a room or relative to a cabinet fixture. See “Using Center Object” on page 144.
- Click the **Reflect About Object** edit button to reflect the selection set about another object. See “Reflecting Objects” on page 150.
- Click the **Allowed Angles** edit button to open the **Place at Allowed Angles** dialog.

Place at Allowed Angles Dialog

If more than one percent of the straight walls included in an Edit Area marquee are not at an Allowed Angle, the Allowed Angles edit button displays.

Click the **Allowed Angles** edit button to display the **Place at Allowed Angles** dialog.

Select the first option and click **OK** to rotate the plan so that the largest group of off-angle walls move to an Allowed Angle. This may place this largest group at Allowed Angles, but has two disadvantages.

- First, other groups of off angle walls remain off angle.
- Second, any walls that were at an allowed angle before this action will move to an off angle. The dialog shows how much (weighted by length) of the selected walls are in each category.

Select the second option and click **OK** to add new entries to the Allowed Angles list and allow new walls to be placed at these angles. Walls already at Allowed Angles remain so. See “Angle Snaps” on page 101.

Select the third option and click **OK** to do nothing, which is the same as clicking **Cancel**.

You may want to rotate the majority of the walls to one of the normal allowed angles. Then, use an **Edit Area** tool to select everything again and select...
the second option to provide new angle entries to cover the remaining walls.

**Stretch CAD**

The **Stretch CAD** tool allows you to reshape or move a variety of CAD-based objects using a temporary closed polyline.

**To use the Stretch CAD tool**

1. Select **Edit > Stretch CAD**.
2. Click and drag to draw a rectangular polyline through the CAD objects that you would like to stretch.
3. You can edit the shape of the Stretch CAD polyline so that it intersects the objects you want to stretch along the desired planes. See “Editing Closed Polyline-Based Objects” on page 133.
   - An edge of the polyline must extend through each of the objects that you would like to stretch.
4. When the Stretch CAD polyline’s shape and position meet your needs, click and drag its Move edit handle.
5. As you drag, intersected objects will either stretch, contract, or move.

Not all CAD-based objects can be reshaped using the **Stretch CAD** tool:

- Road and Text objects are examples of objects that can be moved but not reshaped by this tool.
- Stairs, Ramps, and Sun Shadows are examples of objects that are not affected by this tool at all.

**Eyedropper and Painter Tools**

There are a number of tools in Home Designer Pro that allow you to apply attributes to objects by clicking on them.

- The Eyedropper tools allow you to load attributes from one object and apply them to other objects.
- The Painter tools allow you to apply attributes to one or more objects. Depending on the tool, attributes may be loaded from another object using an Eyedropper tool or selected from a dialog.
- Some object attributes can also be replaced directly from the library. See “To replace an inserted object” on page 523.

Attributes cannot be either loaded from or painted onto objects on locked layers or on layers that are not set to display. They can be used to modify automatically generated objects such as roof planes and framing; however, the associated Auto Rebuild function will be turned off. See “Auto Rebuild” on page 103.

**Eyedropper Tools**

The Eyedropper tools allow you to select attributes from one object and apply them to other objects. There are three Eyedropper tools in the program:

- **Material Eyedropper**.

- **Object Eyedropper**.

- **Fill Style Eyedropper**.

**To use an eyedropper tool**

1. Select the Eyedropper tool that you want to use and notice that the mouse pointer displays an eyedropper icon.
2. Move the mouse pointer over an object in the current view. If the object is eligible for use with the selected Eyedropper:
   - It will become highlighted in the view.
   - The left side of the Status bar will report information about that object or the attribute that the Eyedropper can load from it.
3. Click once to load the object’s attributes so they can be applied to other, similar objects.
4. Notice that your mouse pointer now displays a spray can icon. This means that the Painter tool associated with the selected Eyedropper is now active.
5. Depending on the tool in use, additional buttons may now display on the edit toolbar. Select the option or options that you need:
• The **Painter Mode** buttons. See “Painter Modes” on page 156, below.
• **Blend Colors with Materials.** See “Material Painter Tools” on page 541.

6. Move your mouse pointer over an object that is similar to the one selected in step 2. If it is eligible to receive the loaded attribute(s):
   • It will become highlighted in the view.
   • The left side of the Status bar will report information about the attribute to be painted or loaded.

7. Click on an eligible object to apply attributes to it as well as to any other identical objects, depending on which Painter Mode is active.

8. Continue clicking to apply attributes until the Esc key is pressed or another tool is activated.

### Painter Tools

The Painter Tools let you apply attributes to a wide variety of objects by clicking on them. When a Painter tool is active, the mouse pointer will display a spray can icon. There are a number of ways to load attributes into a Painter tool:

• Click on an object using any Eyedropper tool to load its attribute(s). The associated Painter tool will become active, ready to paint the loaded attributes.

• Select a material or fill style in the Library Browser and move the mouse pointer into the current view window. If that item can be applied in the current view type, the associated Painter will be active and you can apply the selection to eligible objects in that view.

• When you select the **Material Painter** tool, the **Select Material** dialog will open, allowing you to choose a material from the library. See “Select Material Dialog” on page 543.

• When you select the **Fill Style Painter** tool, the **Select Library Object** dialog will open, allowing you to choose a fill style from the library. See “Select Library Object Dialog” on page 522.

Once a Painter tool is loaded, simply click on an object to apply the selected attributes. See “To use the Material Painter tool” on page 541.

### Painter Modes

There are five Painter Modes that control how broadly or narrowly a selected Painter tool will apply an attribute or attributes to objects in the current plan. These modes are listed in the same submenu as the associated Eyedropper and/or Painter tool. When a Painter tool is active, they are also found on the edit toolbar. In both locations, a small check mark will display at the lower left of the active Mode’s button icon.

<table>
<thead>
<tr>
<th>Painter Mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Object Mode</strong></td>
<td>Applies attributes to or replaces a material on individual target objects, one at a time. All instances of the original material on a target object are replaced by the one being painted.</td>
</tr>
<tr>
<td><strong>Marquee Mode</strong></td>
<td>Available in plan view for the Fill Style Painter and Object Painter tools. To use this mode, click and drag a marquee around the objects you would like to paint instead of clicking on them.</td>
</tr>
<tr>
<td><strong>Room Mode</strong></td>
<td>Applies attributes to a target object as well as all instances of that object type in the same room with a single click. All instances of the original material throughout the room are replaced by the one being painted.</td>
</tr>
<tr>
<td><strong>Floor Mode</strong></td>
<td>Applies attributes to a target object as well as all instances of that object type on the same floor with a single click. All instances of the original material on the current floor are replaced by the one being painted.</td>
</tr>
<tr>
<td><strong>Plan Mode</strong></td>
<td>Applies attributes to a target object as well as all instances of that object type in the entire plan with a single click. All instances of the original material throughout the plan are replaced by the one being painted.</td>
</tr>
</tbody>
</table>

An additional mode, the **Material Painter Component Mode**, is available for the Material Painter only. See “Material Painter Modes” on page 542.
Home Designer Pro will remember your Painter Mode selection until you quit the program. The next time you launch the program, Object Mode will be active.

**Object Eyedropper**

Select **Tools > Object Painter > Object Eyedropper** to apply the attributes of one object to other, similar objects. The Object Eyedropper functions like other Eyedropper tools. See “To use an eyedropper tool” on page 155.

**Deleting Objects**

Objects can be deleted in a variety of ways:
- Select an object or group of objects, then click the **Delete** edit button, select **Edit > Delete** from the menu, or press the either the Delete or Backspace key on your keyboard.
- Entire categories of objects can be deleted using the **Delete Objects** dialog.
- Objects are deleted if the floor they are placed on is deleted. See “Deleting Floors” on page 391.

If an object has a line with arrow attached to it, the line with arrow is deleted if the object is deleted. To prevent the arrow from being deleted, drag the attached end away from the object before deleting it.

A variety of objects in the program can be generated automatically, including roofs, the foundation, and framing. Automatically generated objects cannot be deleted unless the automatic creation option is disabled.

Objects such as roofs, framing, and Auto Exterior Dimensions that are set to automatically rebuild or refresh cannot be deleted while that behavior is enabled. Automatically generated objects cannot be deleted unless the automatic creation option is disabled.

**Delete Objects Dialog**

Select **Edit > Delete Objects** to use the **Delete Objects** dialog to delete all objects of one or more specified types in one room, on the current floor, or on all floors in the plan.

The **Delete Objects** dialog only deletes objects in plan view - it does not delete CAD objects or plant schedules drawn in cross section/elevation views. If this dialog is opened while a camera view is active, CAD objects and plant schedules cannot be deleted.
Select a **Delete Scope**:

- Choose **All Floors** to delete objects on all floors in the current plan.
- Choose **All Rooms on This Floor** to delete objects in all rooms on the current floor.
- Choose **Single Room** to delete objects only in rooms on the current floor that you specify.
- Click the **Select All** button to check the boxes beside all of the categories.
- Click the **Clear All** button to uncheck the boxes beside all of the categories.

Specify which types of architectural **Objects** you want to delete.

Specify which types of **CAD** objects you want to delete. See “CAD Objects” on page 161.

Specify which types of **Framing** objects you want to delete. See “Framing” on page 463.

Specify whether or not to delete **Plant Schedules**. See “Plant Schedules” on page 675.

**Specify which kinds of Walls** you want to delete. See “Walls, Railings, and Fencing” on page 183.

**To use the Delete Objects dialog**

1. Specify the **Delete Scope** as **Single Room**, **All Rooms On This Floor**, or **All Floors**.
2. Click **Select All** to check all the boxes or **Clear All** to uncheck all boxes.
3. Check the box for each category of objects you want to delete.
   - Check the box beside any heading to select all of the categories within it; clear the box beside a heading to deselect all of its categories.
4. Check the box for each subcategory of objects that you want to delete.
   - If “Roof Planes” cannot be selected, they may be locked. See “Editing Roof and Ceiling Planes” on page 439.
5. When the scope is set to **Single Room**:
   - Move your cursor into the drawing area and click in a room of the plan to delete objects of
Undo and Redo

The Undo and Redo commands allow you to both undo the last action performed, as well as redo actions that were recently Undone.

The 50 most recent actions can be Undone or Redone, depending on your settings in the Preferences dialog. See “General Panel” on page 67. Actions that can be Undone and Redone include creating, editing, and deleting objects.

To Undo an action, select Edit > Undo, click the Undo button, or press Ctrl + Z on your keyboard.

The Redo command is only available after Undo has been used. To Redo an Undone action, select Edit > Redo, click the Redo button or press Ctrl + Y on your keyboard.

It is important to note that Undo and Redo do not affect all actions in the program, including:

• Save and Save As. See “Saving, Exporting, and Backing Up Files” on page 43.
• Changes made in the Library Browser. See “The Library Browser” on page 509.
• Changes made in a dialog while the dialog box is open. See “Dialogs” on page 30.
• Changes made to lights using the Adjust Lights dialog. See “Adjust Lights Dialog” on page 588.
• Changes made to the display by panning the display or zooming in or out. See “Undo Zoom” on page 97.
• Changes made to the position of a camera, or its Rendering Technique. See “Editing 3D Views” on page 571.
Chapter 10: CAD Objects

With the 2D Computer Aided Design (CAD) tools included in Home Designer Pro, you can add details to views of your 3D model to create complete working drawings.

The CAD Tools are used to add information to 2D views of your model. CAD objects do not affect 3D objects or display in camera views or overviews, but they can be used to add details to layout pages, plan views and cross section/elevation views.

CAD polylines can be converted to 3D objects such as countertops and terrain data, and shown in 3D views. See “Convert Polyline” on page 151.

CAD objects are edited much like other objects in Home Designer Pro. See “Editing Objects” on page 119.

Chapter Contents
- CAD Defaults and Preferences
- The CAD Drawing Tools
- Point Tools
- Line Tools
- Line Specification Dialog
- Arc Tools
- Drawing Arcs - Arc Creation Modes
- Arc Specification Dialog
- Circle Tools
- Circle/Oval/Ellipse Specification Dialog
- Polylines
- Polyline Specification Dialog
- Box Tools
- Box Specification Dialog
- Splines
- Displaying CAD Objects

CAD Defaults and Preferences

CAD Defaults can be accessed by selecting Edit> Default Settings from the menu and expanding the CAD category.

The behavior and appearance of CAD objects are also affected by settings on the CAD, LINE PROPERTIES, SUN ANGLE, BEHAVIORS, and SNAP PROPERTIES panels of the Preferences dialog. Unlike default settings, preference settings are global, affecting all plan and layout files. See “Preferences Dialog” on page 61.

CAD Defaults Dialog

The settings in the CAD Defaults dialog control the basic appearance of CAD objects. This dialog can also be opened by clicking the CAD Defaults button, which can be added to the toolbars. See “To add a button to a toolbar” on page 87.

Each plan file has multiple CAD Defaults dialogs: one affecting plan view and one for every cross section/elevation view. Each layout file has its own CAD Defaults, as well. Each set of CAD Defaults can be accessed by opening the CAD Defaults dialog from within that view.

The CAD Defaults dialog cannot be opened when a camera view or overview is active.

161
Specify whether to **Display Line Length as** either Fractional or Decimal Feet. This controls the appearance of line length indicators, which only display when Show Length is checked in an object’s specification dialog. See “Line Style Panel” on page 169.

**Display Line Angles as** - Specify the format to use when Show Angle is checked in an object’s specification dialog. See “Line Style Panel” on page 169.

### Line Angles

- **Degrees/Minutes/Bearings** - Measured counterclockwise from a line drawn horizontally to the right of the angle’s vertex. Useful for most drawing tasks. Select the level of accuracy that you require.
- **Quadrant Bearings** - Measured from a vertical line representing North/South. Quadrant Bearings use directional bearings in their measurements. Useful for site drawings.
- **Azimuth Bearings** - Measured from a line drawn straight up from the angle’s vertex (i.e., North on a site plan). Useful for site drawings, Azimuth Bearings use degrees, minutes, and seconds in their measurements.

Select any combination of the available Options.

- Check **Show Arc Centers and Ends** to show arc centers and ends on the current floor. Ends display as small lines where arcs connect to one another. Centers also act as snap points. See “Arc Centers and Ends” on page 130.

**Line length and angle indicators use the Text Style of the layer that their object is on.** See “Text Styles” on page 283.

The CAD Drawing Tools

- **The CAD Tools are available in the CAD menu and on the toolbars.**

**Point Tools**

- **Select CAD> Points** to access the Point Tools.

The **Place Point**, **Input Point**, **Point Marker**, and **Delete Temporary Points** tools can be used to create or remove snap points for a variety of purposes. See “Point Tools” on page 163.

**Line Tools**

- **Select CAD> Line** to access the Line Tools.

The **Draw Line**, **Input Line**, **Line With Arrow**, **Sun Angle**, and the **North Pointer** allow you to create various types of lines. See “Line Tools” on page 166.
Arc Tools

Select CAD > Arcs to access the Arc Tools.

The Draw Arc, Input Arc, and the Arc With Arrow tools allow you to create arcs. See “Arc Tools” on page 172.

Box Tools

Choose CAD > Boxes to access the Box Tools.

The Rectangular Polyline, Box, Cross Box, and Insulation tools allow you to create a variety of polyline and box objects. See “Box Tools” on page 178.

Circle Tools

Select CAD > Circles to access the Circle Tools.

The Circle, Circle About Center, Oval, and the Ellipse tools are discussed in detail later in this chapter. See “Circle Tools” on page 175.

Point Tools

Select CAD > Points to access the Point Tools.

Temporary points created using the Place Point and Input Point tools and permanent Point Markers can be used with Object Snaps to accurately position a variety of objects. See “Object Snaps” on page 101.

The size of temporary points is specified in the Preferences dialog. See “Snap Properties Panel” on page 76.

Place Point

Select CAD > Points > Place Point, then and click in the drawing area to place a temporary CAD point at that location. Temporary CAD points can be used for a variety of purposes: for example, as an anchor for snapping objects to a precise location. The Current CAD Point can be used for additional tasks. See “The Current Point” on page 164.

Spline

A Spline is a curve that passes smoothly through a set of points. Select CAD > Spline to draw connected line segments that form a spline. See “Splines” on page 180.

Once created, a spline can be selected and edited. See “Editing Spline-Based Objects” on page 138 and “Polyline Specification Dialog” on page 177.

Dimension Tools

Select CAD > Dimensions to access the Dimension Tools. The Dimension Tools can be used with CAD and architectural objects and are discussed in their own chapter. See “Dimensions” on page 249.

Text Tools

Select CAD > Text to access the Text Tools. The Text Tools are discussed in their own chapter. See “Text, Callouts, and Markers” on page 267.

Input Point

Temporary CAD points can be placed with precision by entering coordinates. See “3D Drafting” on page 25.

To use the Input Point tool

1. Select CAD > Points > Input Point to open the New CAD Point dialog.
2. Select a Location option, and enter the desired location of the point.
3. Click OK to close the dialog and create the new point. The new point becomes the Current Point and is highlighted. See “The Current Point” on page 164.
4. Alternatively, click Next to create the new point but remain in the New CAD Point dialog and create additional points. As each is created, it becomes the Current Point.
New CAD Point Dialog

The location of the **Current Point** displays here. If no CAD points are present, the origin (0, 0) displays. See “The Current Point” on page 164.

Specify the location of the **New Point**.

- **Absolute Location** - Define the point in **X Position** (horizontal) and **Y Position** (vertical) coordinates, relative to the origin at (0,0).
- **Relative to Current Point** - Define the new point in **X** and **Y** coordinates that are relative to the Current Point, as though that point was at (0,0). Only available when a Current Point exists.
- Check **Polar** to define the new point by its **Distance** and **Angle** from the Current Point rather than in X and Y coordinates. This is helpful when creating a plot plan. See “Plot Plans” on page 638.

The position of the New Point is defined here. The options available depend on the method chosen to define it, above.

- **X Position** and **Y Position** coordinates relative to (0,0) are entered if the Absolute Location method is specified.
- **X Position** and **Y Position** coordinates relative to the Current Point are entered if the Relative to Current Point method is specified.
- **Distance** and **Angle** from the Current Point are entered if the Relative to Current Point: Polar method is specified.
- Click **Next** to create the new point without exiting the dialog so you can input data for the next point. The newly created point becomes the Current Point.

**Point Markers**

Use a permanent **Point Marker** as a snap point for dimension lines and other CAD objects. Select **CAD> Points> Point Marker** and click in the view to place a permanent point marker. Point markers display as a simple cross, with or without a text label. They can be opened for specification and modified to include a label or alter their attributes.

You can also place Point Markers using the **Marker** tool, which lets you specify the marker label and type. See “Markers” on page 282.

Point Markers are also created when the **Point to Point Dimension** tool is used or when a dimension line is copied and pasted independent of the objects it locates. See “Point to Point Dimensions” on page 258.

**Delete Temporary Points**

All temporary points in the current view can be deleted at once using **CAD> Points> Delete Temporary Points**. In plan view, Delete Temporary Points will delete all temporary points on all floors.

You can also press the **Delete** key when nothing is selected to delete the points one by one; however, **Delete Temporary Points** can save time when there are many points.

**The Current Point**

In any view and on any floor, there may be multiple temporary CAD points. The Current Point is either the most recently created or most recently selected temporary CAD point. The Current Point has a variety of uses:

- As the starting point for objects as they are drawn by entering data. See “Entering Coordinates” on page 103.
- As the point about which objects are rotated. See “Rotating Objects” on page 148.
- To indicate the points at which roof planes can join. See “To find roof plane intersection points” on page 440.
When multiple temporary points are on-screen, the Current CAD Point is highlighted so it can be easily identified.

To delete the Current Point

1. Make sure no other objects are selected by clicking the Select Objects button. You can also press the Esc key to deselect any selected objects.
2. Press the Delete key on the keyboard to delete the Current Point. The temporary point created prior to this one becomes the new Current Point.
3. If you continue pressing the Delete key, temporary points will be deleted in the reverse order that they were created.

Move Point Dialog

A CAD Point can be repositioned relative to itself, another point, or a CAD object such as a line using the Move Point dialog. When a Point is moved, it becomes the Current Point.

For example, you can locate the point exactly one-quarter the distance along a given line, or exactly 6 inches from one end. This new location can then be used for the start point of a new line or other purpose.

To reposition a CAD Point, double-click on it using the Select Objects tool. That point becomes the Current Point, and the Move Point dialog opens.

The Current Location of the selected point displays at the top of the dialog for reference.

Specify the New Location of the point.

- **Absolute Location** - Define the new location in X (horizontal) and Y (vertical) Position coordinates, relative to the origin at (0,0).
- **Relative to Itself** - Define the new location in X and Y Position coordinates relative to the current location, as though that point were the origin.
- **Relative to Previous Point** - Define the new location relative to the point that was the Current Point prior to this one, as though that point was the origin. Only available if the selected point is located on a CAD object.
- Check **Polar** to define the new location’s Distance and Angle from the previous point instead of using X and Y coordinates. Only available if Relative to Itself or to Previous Point is selected above.
- **Along Line** - Define the new location relative to the edge of a nearby CAD object. This option is enabled only when the point is located near a CAD object and refers to the end nearest to the point’s original location.
- Check **Percentage (%)** to specify the Along Line value as a percentage of the total line or arc length rather than as a distance. 0% moves the point to the closest end of the nearest edge, 50% to the midpoint, and 100% to the other end. Negative numbers and percentages greater than 100 are allowed.
• Specify the new position of the point here. The options here depend on the method chosen to define the New Location.

• **X Position** and **Y Position** coordinates are entered if the Absolute Location method is specified or if either Relative method is used with Polar unchecked.

• **Distance** and **Angle** are entered if either Relative method is specified when Polar is checked.

• **From Edge** - When the Along Line method is used, specify the distance of the point’s New Location to the end of the CAD object’s edge that it was originally closest to. When **Percentage (%)** is checked, enter this value as a percentage instead.

If the point is near an arc, **Along Line** is measured along the curve.

If the point is near a box or polyline, **Along Line** is measured along the nearest side just as it does with an individual line or arc.

If the point is near an oval or circle, **Along Line** is measured along an (invisible) axis line that the item was originally drawn along.

### Line Tools

Select **CAD> Draw Lines** to display the Line Tools.

If **Object Snaps** and **Connect CAD Segments** are enabled, you can connect the ends of two lines and/or arcs to form a single entity called a polyline. See “Polylines” on page 176.

#### Draw Line

Select **CAD> Lines> Draw Line**, then click and drag from beginning to end.

If you double-click the Draw Line tool, the **Input Line** dialog will open.

#### Input Line

CAD lines can also be created using absolute values entered with the keyboard by selecting **CAD> Lines> Input Line**. This method is slower but more precise than using the mouse and is ideal when the desired length and angle of each line is known, such as with property lines.

Before any line is drawn using this method, a starting point must be defined. If a starting point has not been defined, Home Designer Pro assumes a starting point of 0,0.

**To use the Input Line tool**

1. Select **CAD> Points> Place Point**, then click the screen to place a CAD point. This is the Current Point, and is the start point for the new line. See “The Current Point” on page 164.

2. Select **CAD> Lines> Input Line** to open the **New CAD Line** dialog. The **New CAD Line** dialog can also be opened by double-clicking the **Line Tools** parent button.

3. If necessary, specify the start point.

4. Specify the method used to define the location of the End Point, then define the End Point.

5. Click **OK** to close the dialog and draw the line, or click **Next** to draw the line but remain in the **New CAD Line** dialog and draw additional lines.

**Note:** If you accidentally click **OK** instead of **Next** and need to continue drawing a polyline using the **New CAD Line** dialog, select the Input Line tool again and continue.
New CAD Line Dialog

1. The X Position (horizontal) and Y Position (vertical) coordinates of the start point for the new line display here. They can also be changed, if you wish.

2. The new line’s End Point is defined here. Begin by specifying how you want to define the line End Point Location.

- **Absolute Location** - Define the end point of the new line in X Position (horizontal) and Y Position (vertical) coordinates, relative to (0,0).
- **Relative to Start Point** - Define the end point of the new line in X and Y coordinates that are relative to the line’s Start Point, as though it were at (0,0).
- **Relative to Previous Line** - Define the End Point of the new line by its Distance and Angle from the Start Point rather than in X and Y coordinates. This is helpful when creating a plot plan. See “Plot Plans” on page 638.
- **Polar** - Check Polar to define the End Point of the new line by its Distance and Angle from the Start Point rather than in X and Y coordinates. This is helpful when creating a plot plan. See “Plot Plans” on page 638.
- **Distance and Angle** from the start point are entered if the Relative to Previous Line method is specified.
- **Click Next** to create the line without exiting the dialog so you can input data for the next line. The start point of the next line is the end point of this line.

To enter an angle in bearings

1. While not required, you may want to select **Quadrant** or **Azimuth Bearings** in the Dialog Number/Angle Style dialog.
2. For Quadrant Bearings, begin by typing N or S (for North or South).
3. Next, type the number of degrees followed by either a letter d or a space.
4. Type the number of minutes followed by either a ‘ or a space.
5. Type the number of seconds followed by either a “ or a space.
6. Finally, for Quadrant Bearings, type either E or W (for East or West).

Following are some examples of Quadrant Bearings. It is not necessary to capitalize the letters. Spaces after each value are optional.

- N 20d 30' E
- S 45' W
- N 89d 48' 30” W
- N 90' E

Enter Coordinates

Similar to **Input Line**, lines can also be specified by pressing the Tab key on the keyboard when a line is in the process of being drawn. This opens the Enter Coordinates dialog. See “Entering Coordinates” on page 103.

Line With Arrow

Create a line or polyline with an arrow on one or both ends by selecting CAD> Lines> Line With Arrow, then clicking and dragging in the drawing area. The initial attributes of the line’s arrow are set in the **Arrow Defaults** dialog. See “Arrow Defaults” on page 268.
As with other lines, lines with arrows can be edited after they are created and connected to form polylines. See “Editing Line-Based Objects” on page 126 and “Line Specification Dialog” on page 168.

You can also create arcs with arrowheads. See “Arc with Arrow” on page 173.

If either end of a Line with Arrow is snapped to an object, it maintains its connection if that object is moved. See “Text Arrows” on page 278.

**North Pointer**

The North Pointer tool is used to define the direction of true north in a plan. The direction of north does not affect the orientation of the Snap and Reference grids, but it does determine the direction of bearing information as well as how shadows and conditioned area totals are calculated. See “North Pointer” on page 590.

If a North Pointer is not used, north is assumed to be straight up on screen in plan view.

**Sun Angle**

Sun Angles let you specify the date, time, latitude, and longitude that the program uses when calculating the angle of the Generic Sun as well as the direction and length of sun shadows. See “Sun Angles and Shadows” on page 590.

**Same Line Type Edit Handles**

A new CAD line can also be drawn using the Same Line Type edit handles on an existing CAD object.

The start point of the new line is located at one end of the existing object and shares its line color, weight, style, and its layer. If the object has an arrow, its attributes are also inherited. See “Line Style Panel” on page 169 and “Arrow Panel” on page 171.

The Same Line Type edit handles are available for CAD lines, arcs, open polylines, and splines, but not for closed CAD shapes or CAD-based architectural objects. They can be turned off in the Preferences dialog if you wish. See “CAD Panel” on page 73.

When Connect CAD Segments is disabled, the new CAD line will snap to the existing object, forming an open polyline or spline. When Connect CAD Segments is enabled, on the other hand, the two will remain separate objects.

**Disconnect Edges**

Select CAD> Lines> Disconnect Edges, then click on the edge of a polyline-based object to disconnect that edge from the rest of the polyline. See “Disconnect Edges” on page 124.

When Connect CAD Segments is toggled off, CAD objects will not join to form a single polyline, either as they are drawn or when edited. See “Polylines” on page 176.

**Line Specification Dialog**

Select a CAD Line, Line With Arrow, or Text Line With Arrow and click the Open Object edit button to open the Line Specification dialog.

The settings on the panels in this dialog are found in the specification and defaults dialogs for a variety of different objects in the program.

**Line Panel**

The information on the LINE panel of the Line Specification dialog is similar to that found on the SELECTED LINE panels of various specification dialogs in the program.
1 Lock - These lock options control how changing properties on this dialog affect the line.

- Select Start to keep the start of the line fixed when changing the length, angle, and end.
- Select End to keep the end of the line fixed when changing the length, angle, and start.
- Select Center to keep the center of the line fixed. Changing the length of the line moves the start and end of the line equally. Changing the angle rotates the line around the center.
- Select Length/Angle to keep the length and angle of the line segment fixed. Moving the start or end moves the other end so the length and angle of the line do not change.

When editing a polyline, moving the Start of a line segment moves the end of the previous connected line, if there is one. Similarly, moving the End of a line segment moves move the start of the next connected line, if there is one.

2 Specify the Length and Angle of the selected line.

3 Specify the X and Y coordinates of the line’s Start Point. Not available when the Start or Center Point is locked.

4 Specify the X and Y coordinates of the line’s End Point. Not available when the Center or End Point is locked.

The format used here can be changed by clicking the Num Style button. See “Dialog Number/Angle Style Dialog” on page 82.

Line Style Panel

The LINE STYLE panel is found in the specification dialogs for many different objects. The settings here control the appearance of the lines and/or arcs that make up an object. Depending on the type of object selected, some settings may not be available.
Line Options -

- Check **Show Border** to display a border around the selected Picture file. Not available for other object types. See “Pictures” on page 606.
- Specify the line **Color** used to represent the selected object. Check **By Layer** to use the color assigned to the object’s layer or click the Color bar to select a different color. See “Select Color Dialog” on page 117.
- Specify the line **Style** used to represent the selected object. Check **By Layer** to use the line style assigned to the object’s layer or click the drop-down list to select a different style.
- Define the **Line Weight** or check **By Layer** to use the line weight assigned to the object’s layer. See “Line Weights” on page 716.
- Check **Wall Stops Move** to stop the selected object when it bumps into a wall. Walls cannot be pushed by other objects. Not available in layout files.
- Select the desired **Display Options**. These options not available for CAD Box- or CAD Circle-based objects, or for North Pointers, or Sun Angles.
  - Check **Show Length** to show the length of each line centered above the line.
  - Check **Show Angle** to show the angle of each line centered below the line. If the object is an arc, its radius will also display.
  - The **Length** and **Angle** formats are specified in the **CAD Defaults** dialog. See “CAD Defaults Dialog” on page 161.
  - Uncheck **All Angles** to show only those angles that are neither horizontal nor vertical. This is automatically checked when **Show Angle** is checked.
  - Check **Reverse Angle** to reverse the angle by 180°. This may be helpful when showing a line’s bearing, since the direction a line is drawn from start point to end point defines its bearing.
- Specify the desired **Bumping** behaviors for the selected object(s). These options only function when **Bumping/Pushing** is enabled. See “Bumping/Pushing” on page 142.
- Check **CAD Stops Move** to bump the selected object into other CAD or CAD-based objects as it is moved, and/or to push the other object(s).
- Check **Show Outline** to display the selected object’s border polyline.

An additional **Display Options** setting is available In the **Picture File**, **Metafile**, and **PDF File Box Specification** dialogs. See “Pictures, Images, and Walkthroughs” on page 601.
The ARROW panel is available for any line, arc, open polyline, or spline that can have an arrow: including dimension lines. The defaults for arrows are set in the **Arrow Defaults** dialog. See “CAD Defaults and Preferences” on page 161 and “Dimension Defaults Dialog” on page 250.

A line, polyline, or spline with an arrow can be attached to other objects. It attaches to a closed polyline-based object along its edges, but can attach to an architectural object anywhere within its 2D symbol in plan view. If an arrow is attached to another object, deleting that object will also delete the arrow.

Some objects, notably Joist Direction Lines, do not have the Attach or Auto Position settings. Other objects, including closed polylines, Sprinkler Lines and Electrical connections are examples of objects that cannot have arrows at all.

- Check **Include Arrow** to apply an arrow to the tail end of the selected object and enable the settings that follow.
- Select an arrowhead **Style** from the drop-down list or check **Default** to use the default arrowhead. Note that arrows with a white center have a transparent fill.
- Select the **Fill Color** used to fill the arrowhead or check **Default** to use the default fill color.
- Specify a **Size** for the arrow.
- Check **Arrow on Both Ends** to place an arrowhead on both ends of the selected object.
- When **Attach Tail to Other Objects** is checked, the tail end of the arrow will attach to another object when snapped to it, and will maintain its attachment if the object is moved. When this is checked and the arrow is selected, its tail end edit handle will display the Selected Edge Handle Fill color.
- Check **Auto Position Tail** to have the tail end update its position on the object it is attached to if either object is moved. See “Auto Position Arrows” on page 278.
- When **Attach Head to Other Objects** is checked, the head of the arrow will attach to another object when snapped to it, and will maintain its attachment if the object is moved. When this is checked and the arrow is selected, its arrow end edit handle will display the Selected Edge Handle Fill color.
- Check **Auto Position Head** to have the arrow end update its position on the object it is snapped to if either object is moved.

**Drawing Arcs - Arc Creation Modes**

There are two Arc Creation Modes that control how arcs and arc-based objects are drawn. Select **Edit > Arc Creation Modes** to select a mode.

The program remembers the last creation mode used between sessions. Once drawn, all arcs are edited similarly. See “Editing Arc-Based Objects” on page 128.

Before deciding which Arc Tool or Arc Creation Mode is best for the project at hand, it is helpful to be familiar with the different components that make up an arc.
• The **center** of an arc is the point the arc is drawn about.
• The **radius** is the distance from the center to the arc.
• The **start** is where the arc begins.
• The **end** is where the arc stops.
• The **chord** is the straight line between the start and end point.
• A straight line that intersects an arc and is perpendicular to the radius of the arc at that point is **tangent** to the arc.

**Free Form Arc**

**Free Form Arc** mode allows you to define an arc by clicking and dragging along the desired path. There are two methods for using this mode.

**Arc Tools**

Select **CAD> Arcs** to display the submenu of Arc Tools.

**Draw Arc**

The method used to draw an arc using **Draw Arc** depends on which Arc Creation Mode is currently active. Once drawn, an arc can be edited. See “Editing Arc-Based Objects” on page 128.

**Input Arc**

An arc can be drawn to exact specifications using the **New CAD Arc** dialog.

**To use the Input Arc tool**

1. Select **CAD> Points> Place Point**, then click the screen to place a CAD point. This is the Current Point, and will be the start point for the new arc. See “The Current Point” on page 164.

**Arc About Center**

**Arc About Center** mode allows you to draw an arc by defining the center and then the start and end points.

**To draw an Arc About Center**

1. Select **CAD> Arcs> Draw Arc**, then click once to define the center point.
2. Click and drag from the start point of the arc to its end point.
3. Or, click and drag an arc. The Current Point is used as the center. See “The Current Point” on page 164.

**To draw a Free Form arc**

1. Select **CAD> Arcs> Draw Arc**, then click at the arc’s start point.
2. Move the pointer along the desired curve while dragging to curve the arc.
3. Release the mouse button at the end point to complete the arc.

To use the Input Arc tool

1. Select **CAD> Points> Place Point**, then click the screen to place a CAD point. This is the Current Point, and will be the start point for the new arc. See “The Current Point” on page 164.

2. Select **CAD> Lines> Input Arc** to open the New CAD Arc dialog. The New CAD Arc dialog can also be opened by double-clicking the Arc Tools parent button.
3. If necessary, specify the Start Point.
4. Specify the method used to define the arc’s Direction, then define its angle.
5. Define the arc’s Radius. In order to create an arc, a value greater than 0 must be specified.
6. Define the arc’s Extension, or length, using one of the three methods. In order to create an arc, one of these values must be greater than 0, and only one method should be used.
7. Click **OK** to close the dialog and draw the arc.
New CAD Arc Dialog

1. The X Position (horizontal) and Y Position (vertical) coordinates of the Start Point for the new arc display here. They can also be changed, if you wish.

2. Specify how you want to define the arc’s Direction, then specify its angle.
   - The Start Direction defines the angle of the tangent from the arc’s start point.
   - The Chord Direction defines the angle of the arc’s chord from the start point.

3. Define the Radius of the arc.

4. The Extension settings control the length of the arc. Define only one:
   - The Arc Angle is defined by imaginary lines drawn from the arc center point to its two endpoints.
   - The Arc Length is the length of the arc along its curve from one endpoint to the other.

- The Chord Length is the length of an imaginary straight line drawn from one arc endpoint to the other.

Select the direction that the arc curves: either to the Right/Clockwise or to the Left/Counterclockwise.

Click the Number Style button to change the units used in dialogs. See “Dialog Number/ Angle Style Dialog” on page 82.

Arc with Arrow

You can create an arc with an arrow on one or both ends, using the Arc With Arrow tool.

Draw an Arc With Arrow like a regular arc. When you release the mouse button, the arc has an arrowhead at the end. The default attributes of the arrow are determined by the settings in the Arrow Defaults dialog. See “Arrow Defaults” on page 268.

As with regular arcs, arcs with arrows can be edited after they are created. See “Editing Arc-Based Objects” on page 128 and “Arc Specification Dialog” on page 174.

Continue to draw connected lines and arcs to form a polyline with an arrowhead at the end. The arrowheads display only at the free ends, not where the lines connect. See “Polylines” on page 176.

Lines with arrowheads can also be created. See “Line With Arrow” on page 167.

A line can be converted to an arc or vice versa by selecting the line, pressing and holding down the Alt key, then using the edit handle at either end to bend the line.
Arc Specification Dialog

Select an arc and click the Open Object edit button to open the Arc Specification dialog. The settings on the ARC panel are also found on the SELECTED ARC panels for many objects.

Arc Panel

The Lock options control how changing properties in this dialog affects the arc.

- **Start** - Select this option to keep the start fixed when changing the arc, chord, or end.
- **End** - Select this option to keep the end fixed when changing the arc, chord, or start.
- **Center** - Select this option to keep the center of the arc fixed when changing the arc.
- **Arc** - Select this option to keep the arc fixed when changing the arc location.
- **Chord** - Select this option to keep the arc chord fixed when changing the arc radius.

Arc - These parameters define the arc. Various controls are disabled depending on what lock option is used.

- **Center X Point** - Specify the X coordinate for the center of the arc.
- **Center Y Point** - Specify the Y coordinate for the center of the arc.
- **Radius** - The distance between the center of the arc and the arc surface.
- **Start Angle** - Specify the angle that a line drawn from the arc center to the arc start makes with a horizontal line to the right.
- **End Angle** - Specify the angle that a line drawn from the arc center to the arc end makes with a horizontal line to the right.
- **Arc Angle** - The angle between the center of the arc and each end.
• **Arc Length** - The length of the arc along the curve.

• Uncheck **Automatic Facet Angle** to specify the **Facet Angle**, which is the angle at which the surfaces of a curved 3D object are broken in 3D views. The default value is 7.5°; a smaller value produces a smoother curve while a larger value may generate more quickly in 3D views. These settings are only available on the SELECTED ARC panel for some CAD-based architectural objects such as Slabs. See “Architectural vs CAD Objects” on page 99.

3 **Start Point** - These values define the start point of the arc. The Position settings are disabled when the Start is locked.

• **Start X Position** - Specify the X coordinate for the beginning of the arc.

• **Start Y Position** - Specify the Y coordinate for the beginning of the arc.

4 **End** - These values define the end point of the arc. The Position settings are disabled when the End is locked.

• **End X Position** - Specify the X coordinate for the end of the arc.

• **End Y Position** - Specify the Y coordinate for the end of the arc.

• **End Direction** - Specify the angle of a tangent line at the end of the arc.

5 **Chord** - These values define the chord of the arc.

• **Chord Length** - The straight line distance between the two ends of the arc.

• **Chord Angle** - Specify the angle of the chord (the imaginary straight line going from the start of the arc to the end of the arc).

**Line Style Panel**

For information about the LINE STYLE panel, see “Line Style Panel” on page 169.

**Arrow Panel**

For information about the ARROW panel, see “Arrow Panel” on page 171.

**Draw Circle About Center**

Select **CAD> Circles> Circle About Center** to create a circle by dragging the radius out from the center point.

**To draw a Circle About Center**

1. Click the **Circle About Center** tool.
2. Click the screen to define the center.
3. Drag the radial distance and release the mouse button. If you are using **Object Snaps**, both...
the center point and the radius snap to any appropriate nearby CAD object, intersection or point.

Ovals

An Oval is a four-arc approximation of an ellipse. To draw an oval, select CAD> Circles> Oval, then click and drag. Use the CAD Oval Specification dialog to accurately set the length and width of the oval and other attributes.

Ellipses

An Ellipse is a set of points with a constant combined distance from two points called foci. An ellipse looks like a stretched circle, or a circular surface viewed at an angle. To draw an ellipse, select CAD> Circles> Ellipse and drag at an angle to define its maximum height and width. Use the CAD Ellipse Specification dialog to accurately set the length and width of the ellipse and other attributes.

Circle/Oval/Ellipse Specification Dialog

Select a circle, oval or ellipse and click the Open Object edit button to open the CAD Circle, Oval or Ellipse Specification dialog. The CAD Circle, Oval, and Ellipse Specification dialogs are almost exactly the same. The Oval and Ellipse Specification dialogs have an additional setting for Angle on the GENERAL panel.

General Panel

Specify the position of the circle, oval or ellipse’s Center Point.
- Specify the X Position and Y Position of the center of the circle, oval or ellipse.
- Specify an oval or ellipse’s Angle. Not available for circles.

Size - Specify the Length and Width of an oval or ellipse, or the Diameter and Radius of a circle.

Line Style Panel

For information about the LINE STYLE panel, see “Line Style Panel” on page 169.

Fill Style Panel

For information about settings on this panel, see “Fill Style Specification Dialog” on page 115.

Polylines

A polyline consists of two or more line and/or arc segments that are attached at their endpoints. Select CAD> Boxes> Rectangular Polyline, then click and drag from corner to corner to create a rectangular-shaped, closed polyline. A closed polyline measuring 2’x 2’ (600 mm x 600 mm) can also be created by clicking once while the Rectangular Polyline tool is active.
When **Object Snaps** and **Connect CAD Segments** are enabled, you can also create a polyline by drawing lines and/or arcs end-to-end, allowing the end of each new object to snap to the end of the previous one. See “Defaults, Preferences, and Edit Behaviors” on page 119.

Line- and arc-based objects will only snap together to form a polyline if they are on the same layer and share identical attributes such as color, line style, and arrow specifications.

If one end of the polyline is connected to the other, it becomes a closed polyline. Closed polylines can be assigned a fill pattern and/or turned into special 3D objects such as slabs or countertops that display in 3D views.

Lines and polylines can be distinguished by the edit handles that display when you select each. A line displays an edit handle at each end and one in the middle. If more than three edit handles display, the object is a polyline.

Lines that appear connected to a polyline may prove to be unconnected when selected.

For example, the two polylines in the following image appear identical until their left edges are selected. The polyline on the left reveals that its left edge is not attached. In contrast, the left edge of the polyline on the right is part of the larger polyline unit.

The **Close Polyline** edit tool can be used to connect the edges of an open polyline. This tool adds a segment between the two open ends, closing the gap between them. See “Using Close Polyline” on page 133.

Polylines can be copied, moved, reshaped, or resized as a single unit. Additionally, the individual segments can be edited. See “Disconnect Edges” on page 124.

Once created, polylines can be edited in a variety of ways. See “Editing Open Polyline-Based Objects” on page 130 and “Editing Closed Polyline-Based Objects” on page 133.

---

**Polyline Specification Dialog**

Select an open polyline, closed polyline, spline, Sprinkler Line polyline, or Electrical connection and click the **Open Object** edit button to open the **Polyline Specification** dialog.

**Polyline Panel**

The **POLYLINE** panel is found in the specification dialogs for a variety of objects throughout the program. It states:

- The total number of **Polylines** or **Holes Selected**;
- The **Length** of an open polyline;
• The **Perimeter** of a closed polyline;
• The **Area** of a closed polyline;
• The **Volume** of a closed polyline;
• The **Number of Lines** that form an open polyline or the perimeter of a closed polyline or polyline hole;
• The **Number of Holes** located inside of a closed polyline;
• The **Hole Perimeter** is the total length of the perimeter(s) of any holes inside of a closed polyline;
• The **Hole Area** is the total area of the holes inside of a closed polyline.

If the polyline is not closed, the Area and Volume are described as “Not closed”. The Volume of a 2D polyline will always be 0, even if it is closed.

If multiple objects of the same type are selected, the combined totals of these values are stated.

### Spline Panel

The SPLINE panel has a single option and is only available when the selected object is a spline. See “Splines” on page 180.

**New Segment Angle** - Specify the angle between line segments that are used to draw the spline. Specifying a smaller angle makes the spline smoother. Specify a larger angle to draw the spline faster.

### Selected Line Panel

The SELECTED LINE panel is available when the selected edge of the polyline is a line as opposed to an arc and is not available if the selected object is a spline. See “Editing Line-Based Objects” on page 126.

### Box Tools

Select **CAD> Boxes** to access the Box Tools.

**Rectangular Polyline**

A **Rectangular Polyline** can be drawn in either of two ways:

- Click in the drawing area to place a 24” x 24” square polyline at that location.
- Click and drag from corner to corner to draw a rectangle of any size.

Once created, a rectangular polyline can be edited into any shape or converted to a 3D object. See
“Editing Closed Polyline-Based Objects” on page 133.

**Box**

Draw a 2D box from the midpoint of one side to the midpoint of the opposite side. The sides of a box can be resized, but a box always has four 90° corners.

Boxes have some unique editing behaviors. See “Editing Box-Based Objects” on page 136.

**Cross Box**

Use the Cross Box tool to create a 2D box with an X-shaped cross in the interior to represent framing in a cross section detail.

In cross section/elevation views, Cross Boxes are used to represent joists and rafters members that are perpendicular to and cut by the camera’s clip plane. See “Cross Section/Elevation Views” on page 564.

**Blocking Box**

Use the Blocking Box tool to create a 2D box with a diagonal line in the interior to represent blocking or bridging in a cross section detail.

**Insulation**

Use the Insulation tool to draw insulation in cross section details. Insulation Boxes are like 2D boxes and Cross Boxes; however, unlike these other types of boxes, Insulation Boxes do not have perimeter lines: only the curves of the insulation pattern.

**Box Specification Dialog**

Select a CAD box, a framing box, a cross box, a blocking box, or an insulation box and click the Open Object edit button to open the Box Specification dialog. See “Box Tools” on page 178.

**General Panel**

Specify a Box Style. Select Normal to specify a normal box, Cross to specify a cross box, or Insulation to specify an insulation box. If multiple CAD boxes are selected, “No Change” may display.
Define the **Position** of the box.

- Specify the **X Position** and **Y Position** of the center of the box.
- Specify the **Angle** of the box.

Define the **Size** of the box by specifying its **Height** and **Width**.

### Splines

A Spline is a curve that passes smoothly through a set of points. Splines are typically used in situations where there is an irregular curve. A contour line is a typical example. Splines are useful wherever a free-flowing curve is needed.

Once created, splines can be selected and edited. See “Editing Spline-Based Objects” on page 138 and “Polyline Specification Dialog” on page 177.

**To use the Spline tool**

1. Select **CAD > Spline**.
2. Click and drag to draw the first spline segment just as you would a line. A single spline segment looks identical to a line, in fact. You may need to turn off **Angle Snaps** to draw freely.

3. Draw the second segment from the end of the first at a different angle. **Object Snaps** should be on to assure that new segments attach correctly to the ends of previous segments.

4. As soon as two straight spline segments connect end-to-end, the straight segments become a curve that passes through the endpoints defined by the original segments. Each point is called a vertex.

5. Draw a few more segments, connecting each to the free end of a previously drawn segment.

6. Notice as additional segments are drawn that the spline changes the curvature of the previous segment to create a continuous curve between the last three points.

7. Form a closed spline by drawing a segment between its two free ends.

8. The result is an irregular curve that flows smoothly through each vertex.

Spline-based objects will only snap together to form a single spline if they share identical attributes such as color, line style, and arrow specifications.

---

**Line Style Panel**

For information about the LINE STYLE panel, see “Line Panel” on page 168.

**Fill Style Panel**

For information about the FILL STYLE panel, see “Fill Style Specification Dialog” on page 115.
Displaying CAD Objects

As with architectural objects, the display of CAD objects is controlled in the Layer Display Options dialog. See “Layer Display Options Dialog” on page 111.

CAD objects can be drawn in plan views, layout, and cross section/elevation views. They are 2D objects only, though, so they cannot be seen in any view other than the one they are drawn in and are never visible in camera views or overviews. See “Architectural vs CAD Objects” on page 99.

Drawing Groups

Each object in a plan or layout file is included in a Drawing Group, which influences whether it displays in front of or behind other objects. By default, all CAD objects are placed in the same Drawing Group. Their drawing order relative to one another is based on the order in which they were placed: an object will display in front of any objects that were created before it was.

Once created, however, the drawing order of CAD objects can be customized. See “Drawing Groups” on page 113.

Show Length and Angle

You can specify that line segment length and angle display along a CAD line, CAD arc, or along each segment of a CAD polyline. If the segment is an arc, its radius also displays. See “Line Style Panel” on page 169.

The format of the length and angle can be specified in the CAD Defaults dialog. See “CAD Defaults Dialog” on page 161.

Line length and angle indicators use the Text Style assigned to the layer that their CAD object is on. See “Text Styles” on page 283.

Endcaps

Dashed lines often display endcaps, which are dashes of a particular length. You can specify the Printed Length of endcaps in the Preferences dialog. See “CAD Panel” on page 73.

Line Styles

A selection of line styles is available for you to apply to CAD and some architectural and terrain objects. See “Line Style Panel” on page 169.

Fill Styles

A selection of fill styles can be applied to closed CAD and CAD-based architectural objects.
To draw a wall, select one of the Wall Tools, then click and drag in a line to the approximate length that you want. When you enclose an area with walls, a room is created, complete with floor and ceiling. The Door Tools and Window Tools can be used to add openings, while Dimensions are used to position walls and openings with accuracy.

Walls are the single most important structural component in Home Designer Pro. They define Rooms, are used to create Foundations, and even influence how Roofs are built. It is helpful to understand how Wall Type Definitions, wall connections, and wall alignment all affect your design.

Chapter Contents

- Wall, Railing, and Fencing Defaults
- Wall Tools
- Railing and Deck Tools
- Fencing Tools
- Exterior and Interior Walls
- Foundation Walls
- Pony Walls
- Railing and Deck Tools
- Room Dividers and Invisible Walls
- Polygon Shaped Decks
- Hatch Wall
- Creating Walls
- Connecting Walls
- Displaying Walls
- Measuring Walls
- Editing Walls
- Edit Handles for Walls
- Editing Straight/Curved Wall Combinations
- Aligning Walls
- Roof Directives in Walls
- Attic Walls
- Stepped and Raked Walls
- Wall Type Definitions
- Wall Type Definitions Dialog
- Wall Specification Dialog
- Railing and Fencing Specification Dialogs
- Wall Hatch Specification Dialog
There are several default dialogs for walls. Default Settings can be accessed by selecting Edit > Default Settings. Click the arrow next to “Walls” to display the walls sub-headings. Select a subheading and click the Edit button to open the Wall Defaults dialog associated with your selection:

The defaults dialog for each wall tool can also be accessed by double-clicking the tool’s toolbar button.

The settings in the various wall defaults dialogs determine what wall types are drawn when the different wall tools are used. It is a good idea to be familiar with these settings and how they relate to your style of building. See “Wall Type Definitions” on page 208.

The General Wall Defaults dialog controls the general behavior and display attributes of all walls, railings and fencing.

For quick access, the General Wall Defaults button can be added to the toolbar or you can press Alt+Q on your keyboard.

1. **Resize About** - These radio buttons determine what part of a wall retains its position when its wall type or wall type definition is changed. See “Resize About” on page 204.

   The Resize About location is also where any snap points will be located along a wall as it is drawn or connected to other walls, and is where a wall’s length is measured.

   - **Outer Surface** - Snap to and resize about the exterior surface. When a wall is resized, its exterior surface does not move.
   - **Main Layer Outside** - Snap to and resize about the outer line of the Main Layer. When a wall is resized, the outer line of its Main Layer does not move.
   - **Wall Center** - Snap to and resize about the center line. When a wall is resized, its center line does not move, but wall layers on either side may.
   - **Main Layer Inside** - Snap to and resize about the inner line of the Main Layer. When a wall is resized, the inner line of its Main Layer does not move.
   - **Inside Surface** - Snap to and resize about the interior surface. When a wall is resized, its interior surface does not move.

   **Note:** In most circumstances, it is recommended that you Resize About the Main Layer Outside to avoid unexpected results.

2. Check **Show Wall Length When Editing** to display a temporary length dimension when a wall is drawn or edited. Wall length only displays when Temporary Dimensions are on. See “Temporary Dimensions” on page 258.

3. Uncheck **Auto Rebuild Attic Walls** to prevent Attic walls from automatically generating when the model changes. When checked, Attic Walls are automatically generated. See “Attic Walls” on page 207.

### Exterior and Interior Wall Defaults Dialogs

Specify the initial attributes of walls drawn using the Exterior and Interior Wall tools in the Exterior and Interior Wall Defaults dialogs. See “Wall Tools” on page 186.

The panels in this dialog are the same as their respective panels in the Wall Specification dialog. See “Wall Specification Dialog” on page 212.
Wall, Railing, and Fencing Defaults

Foundation Wall Defaults

Specify the initial attributes of walls created by the Foundation Wall tool when it is either used manually or when a stem wall or pier foundation is generated in the Foundation Wall Defaults dialog. See “Foundation Walls” on page 189.

Unlike other walls, Retaining Walls are used to modify your terrain rather than build a structure. See “Terrain Wall and Curb Tools” on page 645.

Footing size and other information used when building stem wall or pier foundations is also specified here. For more information, see “Foundation Defaults” on page 373.

The Foundation Wall Defaults dialog also controls the wall type drawn by the Retaining Wall tool. See “Foundation Walls” on page 189.

The panels in this dialog are the same as their respective panels in the Wall Specification dialog. See “Wall Specification Dialog” on page 212.

Pony Wall Defaults

Specify the initial attributes of walls drawn using the Pony Wall tool. See “Pony Walls” on page 190.

The Display in Plan and Display of Openings in Non-Displayed Parts of Walls settings on the WALL TYPES panel of the Pony Wall Defaults dialog are static in views sent to layout. See “Keeping Layout Views Current” on page 699.

The panels in this dialog are the same as those in the Wall Specification dialog. See “Wall Specification Dialog” on page 212.

Railing and Deck Railing Defaults

Specify the types of railings created when the Railing and Deck Railing tools are used. See “Railing and Deck Tools” on page 187.

The panels in these dialogs are the same as their respective panels in the Wall Specification dialog. See “Wall Specification Dialog” on page 212.

Glass Wall Defaults

Specify the initial attributes of walls drawn using the Straight Glass Wall tool. See “Glass Walls and Half-Walls” on page 186.

The panels in this dialog are the same as their respective panels in the Wall Specification dialog. See “Wall Specification Dialog” on page 212.

Glass Pony Wall Defaults

Specify the initial attributes of walls drawn using the Straight Glass Pony Wall tool. See “Glass Walls and Half-Walls” on page 186.

The panels in this dialog are the same as their respective panels in the Wall Specification dialog. See “Wall Specification Dialog” on page 212.

Half-Wall Defaults

Specify the attributes of a solid railing drawn using either the Straight Half Wall or Curved Half Wall tool. See “Glass Walls and Half-Walls” on page 186.

The panels in this dialog are the same as their respective panels in the Wall Specification dialog. See “Wall Specification Dialog” on page 212.
Fencing Defaults

Specify the initial attributes of walls drawn using either of the Fencing Tools. See “Fencing Tools” on page 189.

The panels in this dialog are the same as their respective panels in the Wall Specification dialog. See “Wall Specification Dialog” on page 212.

Room Divider Defaults

Specify the initial attributes of walls drawn using the Room Divider tool. See “Room Dividers and Invisible Walls” on page 191.

The panels in this dialog are the same as their respective panels in the Wall Specification dialog. See “Wall Specification Dialog” on page 212.

Wall Tools

Select Build> Wall to access the Wall Tools. The type of wall drawn by each wall tool is specified in its corresponding defaults dialog.

The Curved Wall tools are similar to their corresponding Straight Wall Tools. Select Build> Wall to access these tools as well.

Exterior Walls

The Exterior Wall and Curved Exterior Wall tools draw walls using the default wall type specified for exterior walls in the Exterior/Interior Wall Defaults dialog. See “Exterior and Interior Walls” on page 189.

Interior Walls

The Interior Wall and Curved Interior Wall tools draw walls using the wall type specified for interior walls. The interior wall type is defined in the Exterior/Interior Wall Defaults dialog.

Note: Whether a wall is recognized as an exterior or interior wall by the program is determined by its position in the model, not by the tool used to draw it. See “Exterior and Interior Walls” on page 189.

Foundation Walls

The Foundation Wall and Curved Foundation Wall tools draw foundation walls. Foundation walls normally have a footing and can be drawn on any floor of the model, not just the foundation floor. See “Foundation Walls” on page 189.

Pony Walls

A Pony Wall, also called a split wall, is defined as a wall with two separate wall types, one for the upper portion and another for the lower portion.

The Pony Wall and Curved Pony Wall tools draw pony walls using the information specified in the Pony Wall Defaults dialog. You can also convert a normal wall into a pony wall and vice versa in the Wall Specification dialog. See “Pony Walls” on page 190.

Glass Walls and Half-Walls

The Straight Glass Wall tool creates single-layer glass walls that do not cut the surfaces of the floor, ceiling, or adjacent walls. The wall type and other attributes of glass walls drawn with this tool are defined in the Straight Glass Wall Defaults dialog. See “Glass Wall Defaults” on page 185 and “Partition Walls” on page 196.

The Straight Glass Pony Wall tool creates a pony wall with a glass upper partition. The height and other attributes of walls drawn with this tool are defined in the Straight Glass Pony Wall Defaults dialogs. See “Glass Pony Wall Defaults” on page 185.

The Half-Wall and Curved Half-Wall tools create solid railings: walls that are 36” (900 mm) high topped with a handrail. The height and other attributes of solid railings drawn with this tool are defined in the Half-Wall Defaults dialog. See “Half-Wall Defaults” on page 185.

Room Dividers

Room Dividers are Invisible walls with a thickness of 0” (mm) that are used to define
Railing and Deck Tools

Railings are a special type of wall that have a specified height rather than building all the way to a room’s ceiling height.

Select Build> Railing and Deck to access the Railing and Deck Tools. Railings are typically used to define interior spaces, while the various Deck tools are used to define exterior Deck rooms.

With the exception of the Polygon Shaped Deck tool, each of the tools in this family have both Straight and Curved versions, and are created and edited just like walls. See “Creating Walls” on page 193.

To create a break in a railing for a stairway or other access, use a Doorway. This keeps the railing continuous and maintains room definition. See “Room Definition” on page 225.

When first drawn, railings are specified as No Locate, which prevents Auto Exterior Dimensions from locating them. This attribute may also be helpful if you do not want a railing to divide an area into two separate rooms. See “General Panel” on page 212.

The attributes for railings when they are first drawn are defined in the Railing Defaults dialog. See “Railing and Deck Railing Defaults” on page 185.

Railings

The Railing and Curved Railing tools create railings that are primarily used to define interior spaces. The style and height of railings drawn with this tool are defined in Railing Defaults dialog. See “Railing and Deck Railing Defaults” on page 185.

Railings are ideal for a number of tasks:

- Creating changes in floor and/or ceiling height. See “Floor and Ceiling Heights” on page 235.
- Creating stairwells. See “Creating a Stairwell” on page 412.

Deck Railing

The Straight Deck Railing and Curved Deck Railing tools draw decks, complete with framing and bounded by a railing. If a foundation level exists, supports for the deck are also created. See “Decks” on page 234.

When a room is defined using deck railing, its Room Type is automatically set to “Deck”. See “Decks” on page 234.

Deck Edges

The Straight Deck Edge and Curved Deck Edge draw decks complete with framing, but without a railing. No deck supports are created.
Polygon Shaped Deck

The Polygon Shaped Deck tool opens the New Polygon Shaped Deck dialog, where you can specify the exact size and number of sides of a new polygonal deck room and then click in plan view to create that deck room. See “Polygon Shaped Decks” on page 192.

Railing Types

A variety of railing types can be specified in the Railing and Deck Railing Specification dialogs. See “Rail Style Panel” on page 222. Available types include:

- **Baluster** creates railings composed of newel posts, balusters, a railing, and an optional bottom rail.
- **Solid** produces a framed railing wall, or Half Wall. See “Glass Walls and Half-Walls” on page 186.
- If **Panels** is selected, you can choose a panel style such as cable, glass, or ironwork from the library. See “Newels/Balusters Panel” on page 223.

By default, newels and balusters do not display in plan view, but their display can be turned on. See “Newels/Balusters Panel” on page 223.

Wall Types and Railings

Just like regular walls, railings are assigned a wall type: “Interior Railing”. This wall type has three layers: a framing layer in the middle and a layer of drywall on each side. See “Wall Type Definitions” on page 208.

You can use a different wall type definition for railings if you wish, but bear in mind that this wall type definition determines several important things:

- The railing’s appearance in plan view. See “Displaying Walls” on page 196.
- The actual thickness of Solid railings in 3D views.
- The extent of the floor platform, if a platform edge is defined by the railing is defined by the outer surface of the wall type. See “Floor and Ceiling Platforms” on page 236.
- If the railing is used to create a change in floor height, this wall type controls the structure and position of the partial wall built beneath the railing, if one is required. See “Floor and Ceiling Heights” on page 235.

If the railing is a type other than Solid, its sizing is specified on the NEWELS/BALUSTERS panel of the Railing Specification dialog, and the railing is centered along the width of the wall type. This will not be evident in plan view unless newels and balusters are set to display.

Deck Railing is also assigned a wall type: “Deck Railing/Fencing”. This wall type has a single framing layer and is recommended for use only with deck railing and fencing.

Railings Over Walls

To produce a railing over a solid wall, specify it as both a Railing and a Pony Wall. See “Pony Walls” on page 190.

To create a solid glass partition over a partial-height wall, specify the “Glass Shower” wall type as the Upper Wall.

To create a glass panel above a half wall

1. Draw a Half Wall and open its specification dialog.
2. On the WALL TYPES panel of the Railing Specification dialog, check the box beside Pony Wall.
3. On the RAIL STYLE panel, select Panel and uncheck Include Top Rail, Include Bottom Rail, and Raise Bottom.
4. On the NEWELS/BALUSTERS panel, select “Solid” and adjust the Newels/Posts Width and Spacing values to meet your needs.
5. On the MATERIALS panel, specify a glass material for the Panel component.
Fencing Tools

Fencing is a special type of wall that is designed to follow the terrain rather than define a room with a flat floor platform.

Select Build> Fencing or click the Fencing Tools to access the fencing tools. Fencing automatically follows the shape of the terrain. You can choose to have the fencing follow the terrain smoothly or to have each segment step as it follows the terrain. See “Rail Style Panel” on page 222.

The Fencing and Curved Fencing tools are used to draw fences, which are similar to railings but by default do not define room areas. Fencing is created and edited much like walls and railings, and normally used outside of a building and follows the shape of the terrain. See “Terrain” on page 637.

Define the default fence style in the Fencing Defaults dialog. See “Fencing Defaults” on page 186.

Exterior and Interior Walls

Most walls are drawn using either the Straight Exterior Wall and Straight Interior Wall tools.

Exterior and interior walls can also be drawn using the Curved Exterior Wall and Curved Interior Wall tools.

The only difference between the Exterior and Interior Wall Tools is the wall type used: Exterior Walls use a wall type set up to model a wall with siding, while Interior Walls model interior walls with sheetrock. See “Wall Type Definitions” on page 208.

You can specify the default wall type for each tool in the Exterior/Interior Wall Defaults dialog. See “Exterior and Interior Wall Defaults Dialogs” on page 184.

Foundation Walls

Foundation walls are similar to the interior and exterior walls but also have a footing. Foundation walls can either be created automatically when a foundation floor is created or manually by drawing them using the Straight or Curved Foundation Wall tool. See “Building a Foundation” on page 376.

To draw a wall using a different wall type, you can change the default wall type for either tool in the Exterior and Interior Wall Defaults dialogs. You can also draw a wall using the default type and then change the wall type in the Wall Specification dialog. See “Wall Types Panel” on page 218.

Whether a wall is recognized by the program as an actual exterior or interior wall is based on its position in the model, not by which tool you used to draw the wall.

• Any wall or wall segment that is entirely surrounded by interior room areas is considered to be an interior wall.
• Any wall or wall segment that defines an exterior room or is exposed to the outside of the building is considered to be an exterior wall. See “Room Types” on page 227.
the **Wall Specification** dialog. See “Wall Specification Dialog” on page 212.

You can draw a foundation wall on any floor of a plan, not just on the foundation level. Any wall can be specified as a foundation wall, regardless of the tool used to draw it. See “Foundation Panel” on page 217.

Foundation walls are placed on the “Walls, Foundation” layer. In plan view, foundation wall footings are placed on the “Footings” layer; in 3D views, they are on the “Walls, Foundation” layer. See “Displaying Walls” on page 196.

### Slab Footings

When a monolithic slab foundation is created, the slabs are defined by specially defined foundation walls that have footing widths equal to that of the wall type - by default, 16” (350 mm). For Garage curbs, the footings should be wider than the wall type. See “Foundation Panel” on page 217.

Rooms defined by these Slab Footing walls will have a Ceiling Height of 0 and a Monolithic Slab Foundation. See “Structure Panel” on page 242.

### Brick Ledges

Brick ledges can be produced in monolithic slab, stem wall, and grade beam foundations. They do not extend under door openings in monolithic slab foundations.

Brick ledges are represented in plan view:

- In stem wall and grade beam foundations, brick ledge lines are on the “Slabs” layer.
- In monolithic slab foundations, they are on the “Walls, Foundation” layer.

See “In Plan View” on page 196.

In order for a brick ledge to be produced, the foundation wall material directly under the brick ledge must be the “Concrete” Structure Type and the wall material that drops into the brick ledge must be the “Masonry” Type. See “Material Structure Types” on page 548.

Additional settings that control whether a brick ledge is produced as well as its size are found in the Wall Type Definition of the wall that is located above the brick ledge. See “Wall Type Definitions” on page 208.

- The width of the ledge is equal to that of the Exterior Layers of the wall type.
- The **Build Platform to Exterior of Layer** setting cannot be the wall type’s exterior layer.

If the floor platform inside of a brick ledge is hung on the foundation wall, **Subflooring to Wall Interior** must be checked in the **Wall Specification** dialog in order for a brick ledge to generate. See “Structure Panel” on page 214.

### Pony Walls

A **Pony Wall**, sometimes called a split wall, is a wall with two separate wall types, one above the other.
Walls drawn using the **Pony Wall** tool are created using the wall types and other information specified in the **Pony Wall Defaults** dialog. See “Pony Wall Defaults” on page 185.

Most pony walls combine two exterior or two interior wall types; however, a pony wall can also produce an individual wall to be an exterior wall near its top and an interior wall near its bottom. See “Exterior/Interior Pony Walls” on page 206.

When a pony wall is also specified as a Railing, its upper wall is replaced by a railing. See “Wall Types and Railings” on page 188.

You can also convert a normal wall into a pony wall and vice versa in the **Wall Specification** dialog. See “Wall Types Panel” on page 218.

The height where the upper portion meets the lower can be adjusted in 3D views using the wall’s edit handles as well as in the **Wall Specification** dialog. The upper and lower sections of a pony wall are linked, so if either portion is modified along the division between the two, such as raking or the stepping of a footing, the other portion of the pony wall adjusts to match. See “Stepped and Raked Walls” on page 207.

### Displaying Pony Walls

You can specify whether the upper and lower portion of pony walls displays in plan view in the **Pony Wall Defaults** dialog. This **Display in Plan** option can also be set for individual walls in the **Wall Specification** dialog. See “Wall Types Panel” on page 218.

Just as with other walls, the appearance of the portion of a pony wall that displays in plan view can be controlled. See “Displaying Walls” on page 196.

Only the portion of a pony wall that displays can be snapped to; however, regardless of what part is displaying, the upper wall will be used to **Align with Wall Above** ⬆️, and the lower part will be used to **Align with Wall Below** ⬇️. See “Editing Walls” on page 200 and “Aligning Walls” on page 204.

By default, when a door or window is located entirely in one part of a pony wall, and that part is not displayed in plan view, the opening’s outline is shown but the wall’s layer lines and fill drawn through it. You can instead display openings in the non-displayed parts of pony walls the same as in the displayed parts, or not at all. See “Pony Wall Defaults” on page 185.

If a window or door is completely contained by one part of a pony wall, it will display in plan view if the other part of the pony wall is shown; but the wall’s layer fill pattern or Hatch Wall fill pattern will display over it.

The **Display in Plan** and **Display of Openings in Non-Displayed Parts of Walls** settings on the WALL TYPES panel of the **Pony Wall Defaults** are static in views sent to layout. See “Keeping Layout Views Current” on page 699.

### Changing Wall Types

The default upper and lower parts of a Pony Wall can be specified in the **Pony Wall Defaults** dialog. See “Pony Wall Defaults” on page 185.

The upper and lower parts of a Pony Wall can be redefined as different wall types in the **Wall Specification** dialog. See “Wall Types Panel” on page 218.

### Room Dividers and Invisible Walls

The **Room Divider** tool is used to define separate room areas in a plan; typically, by dividing a large room area into two or more smaller areas. See “Room Definition” on page 225.

Common uses for Room Dividers include dividing areas of an open floor plan into areas with different purposes.
Room Dividers can also be used to define areas with different floor or ceiling materials or heights.

**Room Dividers** are drawn using the attributes specified in the **Room Divider Defaults** dialog; which means they are simply walls that are specified as Invisible and have a single layer of an “Air Gap” material with a thickness of 0” (mm).

If a zero-thickness Room Divider separates two rooms with different floor and/or ceiling heights, its wall type will be changed to the current plan’s default Interior Wall so that the platform step created by the height difference can be enclosed. See “Floor and Ceiling Platforms” on page 236.

**Invisible Walls**

Any wall, regardless of its wall type or thickness, can also be specified as Invisible - or vice versa - in the **Wall Specification** dialog or by clicking the **Make Wall(s) Invisible** or **Make Wall(s) Visible** edit button. See “General Panel” on page 212.

Room Dividers are placed on the “Walls, Invisible” layer by default, as are walls that are specified as Invisible. See “Room Divider Defaults” on page 186.

Walls specified as Invisible can display in plan view but not in 3D views or the Materials List. See “Displaying Walls” on page 196.

It is not possible to place doors or windows into an Invisible wall; however, if a wall with openings in it is specified as Invisible, any openings in it will remain.

**Important Notes on Invisible Walls**

- Floor, wall and ceiling areas are calculated separately for rooms divided by Invisible walls.
- Invisible walls are ignored by the **Auto Place Outlets** tool; it functions as though they were not present.
- Cabinets, fixtures and furniture can be moved freely through Invisible walls.
- Invisible walls can be drawn through a cabinet to attach to the wall behind.
- Room Dividers are automatically generated to connect “island” rooms to the larger structure around them. See “Room Definition” on page 225.

**Polygon Shaped Decks**

Select **Build> Railing and Deck> Polygon Shaped Deck** to open the **New Polygon Shaped Deck** dialog and create a polygon shaped deck with regular sides.

The settings in this dialog are saved between program sessions.

**To create a polygon shaped deck**

1. Click the radio button beside an option to specify whether you want to **Define Polygon by Side Length**, **Radius to Corner** or **Radius to Side**.
2. Specify the desired **Number of Sides**.
3. Specify the desired **Side Length** or,
4. Specify the desired **Radius**.
5. Uncheck **Include Railing** to produce a deck platform defined by Deck Edges. This option is not available in the **New Polygon Shaped Room** dialog.
6. Click **OK**, then click once in plan view to create the specified polygon shaped deck.
The **Hatch Wall** tool can be used to fill wall segments with a single hatch pattern in plan view.

To apply wall hatching, select **Build > Wall > Hatch Wall**, then click on a wall. The hatch pattern covers the entire length and width of the wall segment.

**Note:** The Hatch Wall tool cannot be used to apply a hatch pattern to Invisible Walls or to walls on a locked layer. See “Room Dividers and Invisible Walls” on page 191 and “Locking Layers” on page 111.

**Hatch Wall** places a hatch pattern across all layers of the selected wall layers displaying in the current view, covering any fill styles specified for that wall type. When wall hatching is applied to a railing, or when the “Walls, Main Layer Only” layer is turned on, wall hatching only displays in the Main Layer(s). See “The Main Layer” on page 209.

In many cases, it is preferable to create a wall type definition rather than use the **Hatch Wall** tool because multiple fill styles can be used. See “Wall Type Definitions Dialog” on page 210.

Once created, wall hatching can be selected, edited and deleted much like other line-based objects. See “Editing Line-Based Objects” on page 126.

If you use the **Hatch Wall** tool to apply a hatch pattern to a wall that has been divided into multiple segments using the **Break** edit tool, the pattern is only applied to the segment that you clicked on. See “Break” on page 146.

Like doors and windows, wall hatching cannot extend across multiple wall segments. Unlike these objects, hatching cannot be located by dimension lines.

The wall hatch pattern and its line weight can be specified in the **Wall Hatch Specification** dialog. See “Wall Hatch Specification Dialog” on page 224.

When editing or deleting wall hatching, make sure that it is selected rather than the wall by noting that “Wall Hatching” displays in the Status Bar. See “The Status Bar” on page 33.

### Creating Walls

Walls, railings, and fencing are drawn similar to the way CAD lines are drawn: select a Wall Tool and then click and drag from end to end in the drawing area. Walls can be drawn in plan view, camera views, and overviews. See “Draw Line” on page 166.

There are several other ways that walls can be created in Home Designer Pro:

- Exterior walls can be generated automatically when a new floor is built by using another floor as a model. See “Adding Floors” on page 388.
- Foundation walls are created when a foundation is automatically generated on Floor 0. See “Foundations” on page 373.
- Attic walls are generated automatically when the program perceives a gap between a wall that defines a room and the roof above. See “Attic Walls” on page 207.
- The **Space Planning Assistant** creates room boxes which can be arranged and then converted into walls. See “Space Planning” on page 51.

### Drawing Walls

Drawing walls to create a floor plan is simple if you keep a few things in mind:

- **Draw exterior walls first to define the building’s footprint, then draw the interior walls after the perimeter is in place.**
- **It is easiest to draw walls at the approximate location and length needed and then move or resize them precisely using dimensions later.** See “Moving Objects Using Dimensions” on page 263.
- **When drawing and positioning exterior walls, make sure **Grid Snaps** are enabled. Once these walls are in place, you may prefer to turn Grid Snaps off to draw and position interior walls and other objects.** See “Grid Snaps” on page 102.
- **If you wish to input wall lengths as you draw, make sure your General Wall Defaults are set to **Resize About Outer Surface**.** See “Entering Wall Lengths and Angles” on page 194.
• As walls are drawn, “sticky” points and extension lines identify points that are either collinear or orthogonal to the end points of other walls, making alignment easier. See “Extension Snaps” on page 101.

• When walls enclose an area to form a room, the program will orient all exterior walls so that the siding material faces outward. See “Wall Type Definitions” on page 208.

• To flip the layers of a wall after it is drawn, select it and click the Reverse Layers edit button. See “Editing Walls” on page 200.

• Initial wall heights are determined by the default floor and ceiling heights of the current floor. See “Floor Defaults Dialog” on page 387.

Wall Angles

With very few exceptions, walls should be drawn and edited with Angle Snaps enabled. Walls that are drawn at irregular angles can result in wall connection, alignment, and room definition problems.

If a wall is drawn at an off angle, the Off Angle Wall icon will follow the mouse pointer and a Caution symbol will display over the problem wall in plan view.

To correct the wall’s angle, click on the Caution symbol that displays over the wall and select Fix Off Angle Wall from the contextual menu. In the Fix Off Angle Wall dialog:

- The Old Angle is stated for reference.
- Enter a New Angle in the text field.
- Specify whether to Lock the Start, Center, or End point of the wall when its angle is changed.

There are several other ways to fix a selected wall if it has been drawn at an off angle:

- Click the Open Object edit button and specify the correct angle. See “General Panel” on page 212.
- Click and drag an end edit handle until the wall snaps to an Allowed Angle. See “Angle Snaps” on page 101.
- If the wall in question should be aligned with a wall directly above or below it, click the Align with Wall Above or Align with Wall Below edit button. See “Aligning Walls” on page 204.

You can also suppress the Caution symbol by specifying the needed angle in the wall’s specification dialog or adding that angle to the list of Allowed Angles. See “General Plan Defaults Dialog” on page 59.

Although not recommended unless the walls in question are Fencing, Terrain Walls, and/or Retaining Walls, you can choose to Ignore Off Angle Wall or Ignore All Off Angle Walls by clicking on the Caution symbol that displays over an off angle wall. See “Fencing Tools” on page 189 and “Terrain Wall and Curb Tools” on page 645.

Wall Positioning

The recommended method of drawing walls is to draw them at their approximate location and length, then move them into position with accuracy using dimensions. To make this task quick and efficient:

- Notice the temporary wall that displays as you draw. Its length and angle display in the Status Bar at the bottom of the window and adjust as you move the mouse. Release the mouse button to draw the wall at the displayed length and angle. See “The Status Bar” on page 33.
- Use Snaps to help ensure proper wall alignment and orientation. See “Snap Behaviors” on page 100.

Once walls are drawn, they can be accurately dimensioned and moved as needed. See “Measuring Walls” on page 199.

Entering Wall Lengths and Angles

The fastest way to draw walls is to draw them at their approximate position and length, and then move or resize them accurately using dimensions. See “Using Dimensions” on page 200.

For those that wish to enter walls’ lengths and angles as they are drawn, first select Resize About Outer Surface in the General Wall Defaults dialog. See “Resize About” on page 204.
Then draw a wall, select it, and specify its **Length** and **Angle** in the **Wall Specification** dialog. Draw a second wall and specify its length and angle, and so on. See “General Panel” on page 212.

### Wall Openings

To create a door or doorway, do not draw wall sections with a gap between them. Walls should be drawn to completely enclose rooms, and then door and window objects should be placed in the walls to create openings later. See “Doors” on page 287 and “Windows” on page 307.

### Temporary Dimensions

Temporary dimensions will display along the length of a wall as it is drawn when **Temporary Dimensions** are toggled on and **Show Wall Length When Editing** is checked in the **General Wall Defaults** dialog. See “Temporary Dimensions” on page 258 and “General Wall Defaults” on page 184.

### Drawing Curved Walls

Drawing a curved wall, curved railing, or curved fence is similar to drawing a CAD arc. See “Arc Tools” on page 172.

As with CAD arcs, the method used to draw a curved wall depends on which **Arc Creation Mode** is currently active. See “Drawing Arcs - Arc Creation Modes” on page 171.

A straight wall can also be converted into a curved wall and vice versa using the **Change Line/Arc** edit button. See “Change Line/Arc” on page 147.

### Connecting Walls

When walls are drawn sufficiently close to one another, they will snap together to form an intersection. This snapping occurs when the walls’ center lines are within a distance defined by the larger of the two walls’ widths and will occur even when **Object Snaps** are turned off. See “Object Snaps” on page 101.

If the two walls in question have identical specifications and are collinear, they will merge to become a single wall. See “Aligning Collinear Walls” on page 204.

A curved wall always has a center point. The center displays as a small cross when **Show Arc Centers and Ends** is enabled. See “Arc Centers and Ends” on page 130.

The radius of a curved wall is measured from the center to a surface or layer of the wall. The radius can be defined in the **Wall Specification** dialog. You may elect to define the radius to the exterior or interior wall layers. See “General Panel” on page 212.

### Space Planning Assistant

The **Space Planning Assistant Tools** allow you to place and arrange room boxes that can then be converted into a fully editable house plan, including walls. See “Space Planning” on page 51.

### Wall Framing

Once walls have been drawn, they can be framed. For best results, avoid generating framing until your model is in its final form. See “Wall Framing” on page 464.

When three or more walls connect to form a completely enclosed area, that area defines a room. See “Rooms” on page 225.

When walls snap together to form an intersection and **Object Snaps** are enabled, the program joins them at their **Resize About** line, which is specified in the **General Wall Defaults** dialog. See “Aligning Walls” on page 204.

- The wall that is being drawn or edited will move, lengthen, or shorten slightly to meet the other wall.
• The other wall will not move; however, its length may be affected.

**Wall Intersections**

Any time two walls intersect, one wall will build through the other. You can turn on the display of the “Walls, Thru Wall Lines” layer in plan view to see which walls build through and which do not. See “Layer Attributes” on page 110.

When a wall builds through another wall, it will extend into the intersected wall until it meets the interior surface of that wall’s Main Layer. See “The Main Layer” on page 209.

**Partition Walls**

By default, walls not only build to an intersecting wall’s Main Layer, they also build through the finish layers of the floor below and the ceiling above to reach the structural layers.

In some situations, though, this is not desirable: for example, glass shower walls are typically installed against the surfaces of walls, floors and ceilings rather than building into them. To achieve this, use the “Glass Shower” wall type. See “Glass Walls and Half-Walls” on page 186.

**Fix Wall Connections**

Occasionally, intersecting walls may not properly connect. When this is the case and the connection in question is on the current floor, a Caution symbol will display at the problem location in plan view and the Connect Walls icon will follow your mouse pointer.

Click on the Caution symbol that displays over the wall to open a contextual menu:

- Select Delete to delete the wall.
- Select Ignore Unconnected Wall to leave the wall unchanged and suppress the Caution symbol.

To correct wall connections throughout the current plan, select Build> Walls> Fix Wall Connections.

Alternatively, you can fix an individual wall connection using the Connect Walls edit tool.

**To use the Connect Walls edit tool**

1. Select a wall.
2. Click the Connect Walls edit button.
3. Click on a wall that you want to connect to the selected wall.
   - If the unconnected wall ends are sufficiently close to one another, the tool connects them.
   - If the separation is too great, extend one towards the other and try again.

**Removing Wall Breaks**

The Break edit tool allows you to break a wall into two or more separate wall segments. See “Break” on page 146.

To merge two collinear walls separated by a break, select one of the segments, then click on the end edit handle located at the break and drag it a few plan inches (mm) away from the break.

If the two walls do not merge, either one or both walls have been moved and they are no longer collinear, or one or both has been edited in some way and they are no longer identical. Open the Wall Specification dialog for each wall and determine how they differ. See “Wall Hatch Specification Dialog” on page 224.

**Displaying Walls**

While the structure and appearance of each wall type is controlled in the Wall Type Definitions dialog, the display of walls in all views is controlled in the Layer Display Options dialog. See “Layer Attributes” on page 110.

If a “Walls” layer is turned off in plan view, any doors and windows placed in walls on that layer will not display, either. See “Displaying Doors” on page 290 and “Displaying Windows” on page 313.

**In Plan View**

The appearance of each wall type, including line weights and colors and wall layer fill styles, is specified in the Wall Type Definitions dialog. See “Wall Type Definitions Dialog” on page 210.

There are also several options for controlling how walls are displayed in plan view. In the Layer Display Options dialog, you can specify whether or not various types of walls display. Walls are placed
on layers with “Walls” at the beginning of the layer name, such as “Walls, Normal”.

The display of the wall layers specified in the **Wall Type Definitions** dialog can be controlled. If you turn off the display of the layer called “Walls, Layers”, wall types display with two lines representing the inside and outside surfaces.

In addition, you can turn off the display of non-structural layers and show only the walls’ Main Layers by turning on the display of the “Walls, Main Layer Only” layer. This allows you to create both fully configured walls and framing layouts. The “Walls, Main Layer Only” layer affects the display of walls in plan view only. See “The Main Layer” on page 209.

The “Walls, Thru Wall Lines” layer controls the display of lines indicating which walls build through at wall intersections.

- **Note:** In plan view, railings not specified as Solid display their Main Layer regardless of whether “Walls, Layers” or “Walls, Main Layer Only” is turned on. See “Wall Types and Railings” on page 188.

Either the upper or lower portion of a Pony Wall can display in plan view. Only the portion that displays can be snapped to or aligned with walls above or below. See “Pony Walls” on page 190.

Foundation Walls have footings that display in plan view as long as the “Footings” layer is turned on. Brick ledge lines can also display. See “Displaying Foundations” on page 377.

It is sometimes helpful to display the walls from a floor other than the current floor. To do this, select and display a reference floor. See “The Reference Floor” on page 393. You can also specify which layers are included in the Reference Display Layer Set in the **Layer Display Options** dialog.

**Notification Icons**

Occasionally, the program may detect a problem with one or more walls in a plan. When this is the case, notification icons will display on the floor where the problem has occurred:

- If a wall is drawn at an off angle, the **Off Angle Wall** icon will follow the mouse pointer and a **Caution** symbol will display over the problem wall in plan view.

- If there is a problem with a wall connection, the **Connect Walls** icon will follow the mouse pointer and a **Caution** symbol will display at the problem location.

The recommended response to either situation is to fix the problem, although you can choose to ignore it if you prefer. See “Wall Angles” on page 194 and “Fix Wall Connections” on page 196.

If an issue has been ignored, notification icons for it will not display. Select **Tools> Checks> Reset Notification Icons** to display any suppressed notifications so that any wall angle or connection problems can be corrected.

**In 3D Views**

As in plan view, the display of walls can be controlled by layer in the **Layer Display Options** dialog.

Each layer of a wall is generated when you create a 3D view. You can see the different layers in 3D using the **Delete Surface** tool. See “Delete 3D Surface” on page 566.

A wall’s framing layer displays as a solid layer rather than studs and plates until wall framing is built. See “Framing” on page 463. Wall framing is placed on the “Framing, Wall” layer.

When a camera is located on the exterior of a structure, you can select **3D> Camera View Options> Hide Camera-Facing Exterior Walls**, allowing the interior to be seen as you rotate around the model. Interior walls set as Attic walls are also hidden when this setting is active.

While most architectural objects in the program can display in both floor plan and 3D views, a few cannot. Invisible walls and Wall Hatching are examples of objects that do not display in 3D.

Unlike in plan view, doors and windows placed in a wall can display in 3D views even if the wall’s layer is turned off. See “3D View Defaults Dialog” on page 560.

**Wall Labels**

Wall labels are located on the “Walls, Layers” layer and can be set to display in plan views. See “Object Labels” on page 285.
Walls do not have Automatic Labels by default; however, custom labels can be assigned to any wall in the Wall Specification and Defaults dialogs.

Wall Materials

There are several ways that materials can be assigned to walls, depending on how the walls and the rooms they define have been defined. See “Rooms” on page 225.

When you draw a wall, it uses the materials specified in its wall type definition. See “Wall Type Definitions” on page 208.

You can change the surface material of an individual wall in the Wall Specification dialog. If you select “Use Default” as the material and the wall is used to define a room, the program refers to the material specified in the Room Specification dialog. See “Wall Specification Dialog” on page 212.

You can also change a room’s wall material in the Room Specification dialog. See “Materials Panel” on page 542. To restore the default Wall Type material, select Use Default in the Select Material dialog. See “Select Material Dialog” on page 543.

Wall materials can also be changed using the Material Painter tool, but bear in mind that depending on which Material Painter Mode is in use, only a portion of the wall may be painted and that the entire room may be affected rather than the individual wall. See “Material Painter and Walls” on page 542.

When neither the wall nor the room has a material assigned to it, the program refers to the general material for walls in the Material Defaults dialog. See “Material Defaults” on page 540.

Note: Wall materials that are specified on the Materials panel of either the Wall or Room Specification dialog are not calculated in the Materials List.

In the Materials List

The materials that make up wall assemblies are listed under different Categories in the Materials List:

- **Siding** - Lists all materials located outside of each wall’s Main Layer, such as siding, sheathing, and housewrap.

- **Framing** - Lists the Main Layer material(s) for all walls as well as railings specified as Solid. Non-framed walls’ Main Layer materials are also listed here when those walls are not specified as Foundation.

Wall framing, including studs, plates, and headers, is only counted when a framing material has been assigned to a wall type and wall framing has been built. See “Framing” on page 463.

- **Insulation** - Insulation is calculated for all exterior walls that are not defined as Railings, and have one or more Framing layers. Insulation thickness is equal to that of the framing layer. See “Exterior and Interior Walls” on page 189.

- **Wallboard** - Lists all materials located inside of each wall’s Main Layer, such as drywall. Includes all materials aside from framing, concrete, and rebar in walls that do not define rooms.

Does not include Wall Coverings or materials specified in either the Room or Wall Specification dialog. See “Materials Panel” on page 221.


- **Foundation** - Lists the concrete and rebar for all walls specified as Foundation as well as their footings. See “Foundation Walls” on page 189.

With the exception of wallboard, windows and doors are taken into account in the calculation of these totals.

Additional wall-related information is listed in the General category, including the total linear feet of each wall type per floor and the thermal envelope wall area per floor. See “Conditioned Area” on page 690.

A wall type’s Main Layer plays a central role in determining how wall materials are calculated. For this and other reasons, correct Main Layer assignment is very important. See “The Main Layer” on page 209.
Measuring Walls

Accurate wall measurements are an essential aspect of any drawing, and can be achieved by following two basic rules:

• Be aware of what part of a wall assembly dimensions are locating;
• Position walls using dimensions rather than edit handles or edit tools.

These rules can easily be met when you keep the following recommendations in mind.

For information about changing the value reported in a dimension line label, see “Using Dimensions” on page 200.

Use Dimension Defaults

Manually-drawn and automatic dimensions can be set to locate walls at their Dimension Layers or at their surfaces. Before drawing dimensions - and particularly, before using them to move your walls into position - make sure that your Dimension Defaults are set up to meet your needs. See “Dimension Preferences and Defaults” on page 250.

If a wall is specified as Invisible, dimensions will locate it at its centerline regardless of its Wall Type Definition or your Dimension Defaults settings. If the Invisible wall divides rooms with different floor heights, dimensions will locate the edge of the wall facing the room where the floor is lower.

Be aware, too, that the wall length dimension that displays when a wall is selected as well as the Length specification in the Wall Specification dialog do not inherit their settings from the Dimension Defaults. Instead, they follow the Resize About line. See “Resize About” on page 204.

Edit Dimension Lines

Once a dimension line has been drawn, its extension lines can be edited to locate a number of locations on a wall assembly:

• The exterior surface
• The Wall Dimension Layer’s exterior
• The center line of the wall assembly
• The Main Layer’s center line
• The Main Layer’s interior
• The interior surface

See “Editing Extension Lines” on page 261.

Moving Walls Using Dimensions

By far, the most precise method of positioning walls is using dimension lines. To produce accurate measurements, remember to:

• Be aware of what part of your walls is being located by each type of dimension.
• Avoid specifying dimension values with greater accuracy than your dimensions are set to display.

See “Format Panel” on page 251.

See “Using Dimensions” on page 200.

Remember that the temporary wall length dimension that displays when a wall is selected may be set to locate a different part of the wall assembly than other dimension lines. See “Wall Length” on page 201.

Use Object, Angle and Grid Snaps

Object Snaps, Angle Snaps, and Grid Snaps make it easier to align walls when they are being drawn as well as when they are edited. See “Snap Behaviors” on page 100.

Object Snaps help to ensure consistent wall connections and are particularly helpful when aligning collinear walls.

When Grid Snaps are enabled, walls are drawn on a regularly spaced grid, which helps avoid inaccurate wall placement. This can become particularly important if you forego positioning walls using dimensions in favor of using edit handles to move them.

Angle Snaps make it easy to accurately draw walls at regular angles, ensuring walls that are truly parallel or perpendicular to one another and separated by consistent distances.

No Locate

If a wall is specified as No Locate in the Wall Specification dialog, it will be ignored by Auto Exterior Dimensions in plan view, as will any doors or windows placed in it. See “Dimensions” on page 249.
By default, Railings, Deck Railings, and Room Dividers are specified as No Locate. See “General Panel” on page 212.

If a wall is on its default layer and is specified as No Locate, it will be moved to the “Walls, No Locate” layer. If this box is later unchecked, the wall will return to its default layer. If a wall is on a non-default layer, it will remain there. See “Displaying Walls” on page 196.

Once a dimension line has been created, it can be edited so that it locates a No Locate wall or railing that is perpendicular to it. See Editing Dimension Lines.

Editing Walls

Walls can be selected in all views. When a wall is selected, it displays edit handles and an edit toolbar that can be used to modify it in various ways. When a wall is selected, temporary dimensions may also display. See “Temporary Dimensions” on page 258.

The ways in which a wall can be edited depend on the current view and which edge is selected. See “Selecting Objects” on page 123.

Selecting Walls

Like other objects, walls can be selected in a variety of ways. See “Selecting Objects” on page 123.

• In plan view, if wall hatching has been applied to a wall using the Hatch Wall tool, the hatching may be selected first. Click Select Next Object to select the wall itself. See “Hatch Wall” on page 193.

• When Select Room Before Wall in 3D is checked in the Preferences dialog and you click on a wall in a cross section/elevation or camera view, the room defined by that side of the wall will become selected instead of the wall. See “Appearance Panel” on page 62 and “Selecting Rooms” on page 229.

When this is the case, you can select the wall by clicking the Select Next Object edit button or pressing the Tab key.

• In plan views, the Edit Area tools allow you to select only part of a wall or walls. See “Edit Area Tools” on page 153.

• In a Framing Overview or other 3D view in which wall framing can be seen, select a wall framing member and click the Find Wall edit button to switch to a plan view in which the wall associated with the selected framing is selected. A wall selected in this manner can then be edited even when its layer is turned off and/or locked. See “Locking Layers” on page 111.

Using the Edit Handles

A selected wall can be modified in a variety of ways using its edit handles in any view. The handles that are available will depend on the current view type. See “Edit Handles for Walls” on page 202.

In the Specification Dialog

The appearance and structure of walls can be customized in the Wall Specification dialog. See “Wall Specification Dialog” on page 212.

The characteristics of the roof directly above a selected wall can also be specified in the Wall Specification dialog. See “Roof Panel” on page 215.

Using the Edit Tools

A selected wall or walls can be edited in a variety of ways using the buttons on the edit toolbar. See “The Edit Toolbar” on page 29.

Using Dimensions

Automatic, manually-drawn, and temporary dimension lines can be used to both resize and move walls with accuracy. Select a wall, then click on a dimension line that locates it and type in the value that you need. See “Moving Objects Using Dimensions” on page 263.

When a wall is resized using dimensions, the inline text field used to edit the dimension will have three unique buttons:

• Horizontal walls have Move Left End, Move Both Ends, and Move Right End.

• Vertical walls have Move Top End, Move Both Ends, and Move Bottom End.

Choose the option that you want to use before pressing the Enter key.
If both ends of the selected wall intersect walls that are not parallel to one another, a fourth option will be available: **Move Along Rails**. When this option is used, the selected wall both resizes and changes position so that it remains connected to the other walls when you press the Enter key.

Depending on your Dimension Defaults settings, manual and/or automatic dimension lines may locate wall surfaces or wall dimension lines. See “Locate Objects Panel” on page 252.

### Wall Thickness

The initial thickness of a wall is determined by its wall type definition. You can change a wall’s thickness by modifying the definition of its wall type. If you do this, all instances of the wall type used in the plan will be affected - not just an individual object. See “Wall Type Definitions” on page 208.

You can also specify a selected wall’s thickness in its **Wall Specification** dialog. See “General Panel” on page 212.

If a selected wall’s thickness is changed:

- A copy of the wall’s wall type is created with the same name but appended with a number equal to the thickness of the Main Layers, and that new type is assigned to the wall. See “The Main Layer” on page 209.

- The change in thickness will be applied to new wall type’s innermost Main Layer.

- The Main Layer must be at least 1/16” thick, and the wall’s thickness cannot be less than the original wall type’s total thickness minus the thickness of its Main Layer.

If a wall type’s thickness is modified, the wall will resize about the **Resize About** line specified in the **General Wall Defaults** dialog. In some instances, the wall may appear to move as a result of changes made to the thicknesses of its layers. See “General Wall Defaults” on page 184.

### Wall Heights

The height of a wall is controlled by the ceiling height of the room(s) it defines. If the ceiling or floor height of a room is changed, the height of the walls that define it also change.

- The initial ceiling height for all rooms on a floor is set in the **Floor Defaults** dialog for that floor. See “Floor Level Defaults” on page 226. Whenever possible, it is best to set all ceiling heights using the default.

- The ceiling height of a single room can be set in its **Room Specification** dialog. See “General Panel” on page 240.

- The default Floor and Ceiling Heights for a given floor can be adjusted by editing the top and/or bottom edges of the Exterior Room in a 3D view. See “The Exterior Room” on page 229.

- The top or bottom edge of any wall can be adjusted independent of floor or ceiling heights using the mouse in Cross Section/Elevation and 3D views. Top and bottom edges can also be stepped and raked. See “Stepped and Raked Walls” on page 207.

- The top height of a selected Railing can also be edited in Cross Section/Elevation and 3D views. The bottom height, however, cannot. See “Railing and Deck Tools” on page 187.

- The edge dividing an upper and lower pony wall can be edited in Cross Section/Elevation and 3D views. In addition, its height can be defined in the **Wall Specification** dialog. See “Wall Types Panel” on page 218.

### Wall Length

Wall length can be modified in several different ways:
• Using dimensions. See “Measuring Walls” on page 199.
• In the **Wall Specification** dialog. See “General Panel” on page 212.
• Using the **Break** edit tool to divide a selected wall into two segments. See “Break” on page 146.
• By dragging the end edit handles. See “Editing Line-Based Objects” on page 126 and “Editing Arc-Based Objects” on page 128.

Bear in mind that if you try to resize a wall by a small amount using one of its edit handles and that wall is connected to another wall at that end, its length will not change because its end will snap back to the existing intersection. See “Connecting Walls” on page 195.

The most accurate way to specify wall length is using dimensions. By default, wall length is measured at the outside edge of the Main Layer. You can instead specify that manual and/or automatic dimension lines locate surfaces in the **Dimension Defaults** dialogs. See “Dimension Preferences and Defaults” on page 250.

Be aware that the wall length dimension that displays when a wall is selected as well as the **Length** specification in the **Wall Specification** dialog do not inherit their settings from the Dimension Defaults. Instead, they follow the **Resize About** line. See “Resize About” on page 204.

---

**Note:** By default, dimensions and the **Resize About** line all use the exterior edge of the Main Layer. When **Resize About** is set to use a different location, dimension lines may not agree with a wall’s length specification. See “Measuring Walls” on page 199.

---

**Edit Handles for Walls**

Walls can be edited extensively using their edit handles. Depending on the type of view, a wall displays a different set of edit handles when selected.

• In plan view, straight and curved walls can be edited like other line- and arc-based objects. See “Editing Line-Based Objects” on page 126 and “Editing Arc-Based Objects” on page 128.
• In plan view, a wall’s edit handles display along its **Resize About** line. See “Resize About” on page 204.
• In a camera view or overview, click on the top surface of a wall to display the same edit handles as in plan view, allowing you to rotate, move, and extend or shorten the length of the wall.
• Moving a wall in any view will move any cabinets attached to that wall, as well.
• In a cross section/elevation view, the top and bottom edges of straight and curved walls can be edited like closed polylines. See “Editing Closed Polyline-Based Objects” on page 133. Only the top and bottom edges of walls can be broken, angled or curved: the side edges cannot.
• In a camera view or overview, click on an interior or exterior surface to display the same edit handles as in an elevation view: one at each corner and one on the top and bottom edges.

• A wall can only be moved perpendicular to itself or, in the case of curved walls, perpendicular to its chord using the **Move** edit handle. To move a wall at Allowed Angles, use the **Alternate** Edit Behavior. See “Alternate” on page 120.
• The footings of Foundation Walls and Slab Footings can be selected in 3D views and edited using the edit handles. See “Footing Width and Height” on page 379.
• The **Same Wall Type** edit handles can be enabled, allowing you to draw a new wall segment of the same type as the selected wall.

**Same Wall Type Edit Handles**

The **Same Wall Type** edit handles allow you to draw a new wall extending out from either end of a selected wall and with identical properties as that wall.

To temporarily enable the Same Wall Type edit handles, select a wall and click the **Same Wall Type** edit button. You can also enable these handles globally in the **Preferences** dialog. See “Architectural Panel” on page 72.

When the Same Wall Type edit handles are enabled, two edit handles display just beyond a selected wall’s **Extend** edit handles in plan view or when the top edge of the wall is selected in a 3D view.
Editing Straight/Curved Wall Combinations

If you move a straight wall connected to a curved wall with a locked center and the connection cannot be maintained without changing the center of the arc, the walls lose their connection.

Click and drag a Same Wall Type edit handle at any angle to draw a new wall segment of the same type as the selected wall.

If you move a straight wall connected to a curved wall with a locked center, the curved wall extends along its curve and the straight wall will either lengthen or shorten as needed to stay connected to the curved wall.

If the connection between the straight and curved wall cannot be maintained because of the curved wall’s radius, it will be broken.

When an Extend edit handle of a curved wall with a locked center is dragged with the Alternate Edit Behavior active, the locked center setting will be overridden. See “Defaults, Preferences, and Edit Behaviors” on page 119.
Aligning Walls

Wall alignment refers to the way wall segments line up with one another, either on the same floor or on the floor above or below. Walls may need to be aligned in a variety of situations.

To make alignment easier when drawing or resizing walls, “sticky” points and extension lines identify points that are either collinear or orthogonal to the end points of other walls. See “Extension Snaps” on page 101.

Resize About

The Resize About line specified in the General Wall Defaults dialog controls two important aspects of wall alignment:

- What part of a wall retains its position when its wall type or wall type definition is changed. See “Wall Type Definitions” on page 208.
- Where walls snap together to form an intersection. See “Connecting Walls” on page 195.

See “General Wall Defaults” on page 184.

The Resize About line is the line along which a selected wall’s length is measured in the Wall Specification dialog. See “Wall Length” on page 201.

The Resize About line is also the line along which a selected wall’s edit handles display, and is the line along which any snap points will be located. See “Editing Walls” on page 200.

Aligning Collinear Walls

Collinear walls are parallel walls connected end to end and drawn on the same floor. When collinear walls join end-to-end, the walls snap together. If these walls have the same wall type and identical specifications, and if Object Snaps are enabled, they will merge to become a single wall segment.

Creating a Nook

Walls can be aligned across an opening such as a nook, so that they are collinear, using the Break edit tool.

To align walls across a gap

1. Select a wall to build a nook into and click the Break edit button.
2. Click at a point on the wall close to one side of the nook area. Do not worry about exact placement right now.
3. Click again near the other side of the nook. Two short lines at each location where you clicked indicate Breaks in the walls.
4. Right-click the middle section of the wall to select the wall section.
5. Click the middle Move handle and drag the wall outward.
6. Draw side walls to connect the wall back to the rest of the house.
7. Move these short walls using dimensions to accurately size the nook.

Aligning Walls Between Floors

Walls can be aligned between floors by clicking the Align With Wall Above and Align With Wall Below edit buttons.

By default, walls on different floors are aligned by the outer edges of their Main Layers. See “The Main Layer” on page 209.

In order for these edit tools to be available, the areas of the walls in question must be partially aligned, or overlapping.

To align walls between floors

1. Select a wall that you want to align with another wall either above or below it.
2. If the wall is above or below the other wall along only part of its length, you must click on it along that part. Select Tools> Floor/Reference Display> Reference Display On to help make sure you click on the correct part of the wall.
3. When you have selected the wall at the desired location, click either the Align With Wall Above or Align With Wall Below edit button.

**Aligning Curved Walls Between Floors**

Curved walls are aligned between floors using the same technique to align straight walls. If the centers and radii of the walls are within a few inches of each other, the Align With Wall Above and Align With Wall Below edit buttons are enabled for the selected wall. The selected curved wall will take on the radius and center of the referenced wall when the walls are aligned.

**Aligning Pony Walls Between Floors**

When aligning a pony wall with either the wall above or below:

- Align With Wall Below will always align the lower pony wall with the wall below, as specified in the lower pony wall’s Wall Type Definition. See “Wall Type Definitions” on page 208.

- Align With Wall Above will always align the upper pony wall with the wall above, as specified in the upper pony wall’s Wall Type Definition.

**Aligning Railings on Different Platforms**

Two collinear Railings or Deck Railings on the same floor can be aligned one above the other when they define rooms with different floor heights.

---

**Roof Directives in Walls**

To automatically generate a roof plane using values other than the defaults or to not generate a roof plane bearing on a particular wall (as for a gable or the sides of a shed roof), you can change the settings in the Wall Specification dialog. See “Roof Panel” on page 215.

**Hip, Gable, and Shed Roofs**

By default, the program will produce a roof plane over each exterior wall to create a hip roof. You can instead specify a gable or shed roof above the selected wall.

- Check Full Gable Wall to create a gable with a ridge centered above the selected wall(s).
• Check **High Shed/Gable Wall** for the side walls or the wall under the high side of a shed roof.

• You can also select a wall and click the **Change to Gable Wall(s)** edit button, or change it back by clicking the **Change to Hip Wall(s)** edit button.

**Pitch**

The default pitch for roof planes is set in the **Build Roof** dialog. However, any exterior wall can define the pitch of the roof plane built above it.

You can also specify a second, upper pitch above a given wall. Mansard, gambrel, gull wing and half-hip are examples of roof styles that use two pitches. See “Roof Tutorial” on page 48 of the User’s Guide.

**Overhangs and Roof Returns**

You can specify the overhang of the roof plane to be generated above the selected wall. This setting only takes effect when Same Height at Exterior Walls is unchecked in the **Build Roof** dialog, which is also where the default Overhang value is set.

Check **Auto Roof Return** to generate roof returns on the selected wall. In most cases, roof returns only generate on Full Gable Walls. See “Roof Returns” on page 460.

**Extend Slope Downward**

Check **Extend Slope Downward** to extend the roof plane downward over a bump out, instead of creating additional roof planes. The two connecting walls that create the bump out must be Full Gable walls.

In the following image, the bearing wall of the bump out has **Extend Slope Downward** checked. The two short side walls are **Full Gable Walls**.

**Clerestory and Dormer Walls**

Occasionally, walls are built between two roof planes rather than between a roof plane and a floor platform. Common examples include clerestory walls and the side, or the cheek, walls of floating dormers.

Check **Roof Cuts Wall at Bottom** to have the bottom of the selected wall clipped by the roof plane below, as where a floating dormer wall meets the main roof plane.

**Exterior/Interior Pony Walls**

It’s not uncommon for an individual wall to be an exterior wall near its top, and an interior wall near its bottom.

Check **Lower Wall Type If Split By Butting Roof** to achieve this. When this option is checked, the
selected wall is specified as a pony wall and a second, lower wall type can be specified. Unlike with other pony walls, the change in wall type occurs wherever a roof plane builds to the exterior of the wall. See “Pony Walls” on page 190.

Attic Walls

In Home Designer Pro, walls are built between the floor and ceiling platforms of the current floor. See “Floor and Ceiling Heights” on page 235. When the program detects an open space between a wall and the roof plane above it, it automatically creates an Attic Wall on the floor above that wall to fill in the gap.

Attic Walls are typically found above Full Gable Walls, forming a gable or closing the top portion of a side wall of a shed roof. They are also generated above all exterior walls when the Raise Off Plate value in the Build Roof dialog is 3” (175 mm) or greater. See “Build Roof Dialog” on page 431.

Attic Walls are often found on the Attic floor, but can be generated on other floors, as well. See “The Attic Floor” on page 393.

Attic Walls are specified as such in the Wall Specification dialog; if automatically generated, that will be noted as well. If needed, you can specify a regular wall as an Attic Wall. If you specify a wall as an Attic Wall, it will be moved to the “Walls, Attic” layer, See “General Panel” on page 212.

When you Rebuild Walls/Floors/Ceilings, all automatically generated Attic Walls in the plan are deleted and rebuilt.

Removing Attic Walls

Occasionally, the program will generate an Attic Wall where one is not wanted. There are several ways to address this:

• Turn off the display of the “Walls, Attic” layer.

Stepped and Raked Walls

Stepped and raked walls can be created using the Break Line tool and the wall’s edit handles in any 3D or Cross Section/Elevation view. In many cases, working in a Backclipped Cross Section is easiest and allows the greatest accuracy.

Knee Walls

Knee Walls are a bit like Attic Walls in that they are not meant to generate to full ceiling height. Instead, they build upward until they encounter a roof plane. Unlike Attic Walls, however, Knee Walls are used in the interior of a structure, typically to separate unused areas from rooms on the upper floor of a story-and-a-half structure. See “Room Types” on page 227.

Home Designer Pro does not specify walls as Knee Walls automatically. If an interior wall is drawn in a location where the roof is lower than the ceiling height, you should specify it as a Knee Wall in the Wall Specification dialog. See “Roof Panel” on page 215.

For best results, Knee Walls should be drawn perpendicular to the pitch of the roof and should intersect with Full Gable Walls on each end.

Steppe Walls and Footings

A typical example of stepped walls is a stepped foundation with pony walls. In the illustration below,
the lower part of the pony wall is the concrete wall with footing, and the upper part of the pony wall is a framed wall with brick siding built to the first floor platform. See “Pony Walls” on page 190.

To add a step to a wall

1. Select the wall in a Backclipped Cross Section view.
2. Click the Break Line tool, then click the top or bottom edge of the wall to place the break.
3. In addition to the corner handles, two handles display along the broken edge.
4. Select one of these two handles, and drag up or down.
5. A square step is created.

The vertical edges of a wall cannot be broken, although they can be raked as well as moved side to side.

By default, a stepped foundation wall displays an “S” symbol at the location of each step in plan view. The display of this “S” is controlled in the Foundation Defaults dialog. See “Foundation Panel” on page 374.

Raked Walls

A raked wall has an angled top or bottom edge.

To create a simple raked wall

1. Select the wall in Cross Section/Elevation or 3D view.
2. Click one of the corner edit handles and drag that handle either up or down.
3. To rake a wall at a specific angle, you can:
   - Draw a CAD Line at the desired angle and use the Make Parallel/Perpendicular edit tool. See “Using Make Parallel/Perpendicular” on page 144.

Compound Raked Walls

A compound raked wall is a wall that has a top or bottom edge with multiple angles.

To create a compound raked wall

1. Select the wall in Cross Section/Elevation or 3D view.
2. Use the Break Line tool to add breaks to the wall edge, as for a stepped wall.
3. Select a segment of the edge and adjust its angle, as for a raked wall.

Wall Type Definitions

Every wall drawn in a plan is assigned a wall type, and its Wall Type Definition determines its structure, its appearance in plan view, and its default materials. Wall types can be viewed, edited, and created in the Wall Type Definitions dialog. See “Wall Type Definitions Dialog” on page 210.
Walls can have up to ten layers defined, each representing a different material. All of these layers can be calculated in the Materials List. The materials assigned to the surface layers of the wall type definition also determine the wall’s appearance in 3D views. See “Materials Lists” on page 681.

You can specify the default wall type that is drawn by each Wall Tool and can specify the wall type of any wall after it is drawn in the **Wall Specification** dialog. See “Wall, Railing, and Fencing Defaults” on page 184 and “Wall Types Panel” on page 218.

### The Main Layer

In most circumstances, each wall type’s Main Layer should be specified as the structural layer. A wall type is considered to be:

- “Framed” if it has a Main Layer with the “Framing” or “Steel Framing” Material Structure Type;
- “Concrete” if it has a Main Layer with the “Concrete” Material Structure Type;
- “Masonry” if it has a Main Layer with a “Masonry” Material Structure Type.

See “Materials and the Materials List” on page 547.

The Main Layer determines many things in addition, including:

- Floor and ceiling platforms and automatically built foundation walls normally build to the outer edge of the Main Layer.
- The Main Layers of exterior walls build through slab floors while interior wall layers stop at the slab surface.
- At intersections, walls join at the interior surfaces of their Main Layers. See “Connecting Walls” on page 195.
- Windows are placed relative to the outer surface of the outermost Main Layer.
- Exterior walls on different floors are aligned by the exterior edges of their outermost Main Layer.
- Roof baselines are placed at the outer edge of the outermost Main Layer when roofs are automatically generated. See “The Baseline” on page 437.
- Roof baselines and gable/roof lines that are manually drawn snap to the outermost edge of the Main Layer.
- By default, walls resize about the exterior surface of their Main Layers when their thickness, wall type, or Wall Type Definition is changed. See “Resize About” on page 204.
- Object Snaps locate the interior and exterior edges of a wall’s Main Layers. See “Object Snaps” on page 101.
- The Sheathing Layer that windows and doors may be recessed to is the layer located just outside the outer Main Layer.

All of this information is reliant on the Main Layer, so creating your wall type definitions accurately beforehand and specifying the Main Layer correctly is very important.

### Multiple Main Layers

In standard light frame construction, walls build to one another’s framing layers, and floor and ceiling platforms are built to bear over the wall framing; however, some building techniques configure these components in other ways. You can control how walls of a given type are intersected, and also where platforms build to, by specifying multiple Main Layers.

By default, when multiple Main Layers are specified:

- Intersecting walls build to the interior surface of the innermost Main Layer.
- Floor platforms build to the exterior surface of the outermost Main Layer.
- A selected wall’s edit handles display along the exterior of the outermost Main Layer.
- The exterior surface of the outermost Main Layer is the Dimension Layer

See “Wall Type Definitions Dialog” on page 210.

### The Dimension Layer

Dimension Defaults can be set to locate walls at their surfaces or at the exterior line of their Wall Dimension Layer. See “Locate Objects Panel” on page 252.

For installed wall types, the default Wall Dimension layer is the Main Layer; however, this can be changed in the **Wall Type Definitions** dialog. In addition to the Wall Dimension Layer, dimensions...
can locate the inside surface of the Main Layer, as well.

Whether Surface or Wall Dimension Layer is selected on the LOCATE OBJECTS panel of the Dimension Defaults dialog determines a number of aspects related to how dimensions locate walls:

- Where both Manual and Automatic Reach are measured from.
- Where Extension line lengths and their Gap From Marked Object are measured from.
- Where First Line Offset for Auto Exterior Dimensions is measured from.
- How the minimum enclosed area required by Auto Exterior Dimensions is measured.

The settings on the LOCATE OBJECTS panel control how dimensions initially locate walls. Once a dimension line has been created, you can move its extension lines or add new extensions to locate other points along a wall’s assembly. See “Measuring Walls” on page 199.

**Legacy Wall Types**

In Home Designer Pro version 9 and prior, generic, single-layer wall types were used as the default for railings, deck railings and fencing. In the earliest program versions, they were the defaults for walls, as well.

- In Home Designer Pro 8 and prior, there were two such wall types: “Default (wood frame 16"OC)” and “Default (concrete)”.
- In Home Designer Pro 9, these two wall types were replaced by one named “Adjustable Thickness Wall”.

When plans that include either of these wall types - in the drawing itself or set as a default - are opened in Home Designer Pro 2021, the legacy wall type is replaced by a new wall type named “Wall-X”, where X is the thickness of the wall’s Main Layer, rounded up. There are a few exceptions:

- If legacy wall types with the same thickness but different materials are found, they use the same naming convention appended with an additional _X.
- If a wall using a legacy wall type is specified as a Foundation wall, the resulting wall type will be named “Foundation Wall-X”.
- If a legacy wall type has the same attributes as a wall type installed with Home Designer Pro 2021, such as 8” Concrete Stem Wall, it will be replaced by that wall type.

Unless a wall is specified as a Foundation wall, Deck Railing, or Fencing, it will be treated as a framed wall and its new wall type will acquire two additional 1/2” (13 mm) thick wall layers: an interior and an exterior layer. These new layers will use the interior and exterior materials of the original wall. The wall’s original layer will maintain its original thickness, acquire a framing material, and will become the new wall type’s Main Layer.

Foundation, Deck Railing, and Fencing wall types converted in this manner will continue to have only one layer.

**Interior and Exterior Surfaces**

Every wall has an interior and exterior surface - including walls in a plan that are recognized by the program as being interior walls. See “Exterior and Interior Walls” on page 189.

Having separate designations for a wall’s two sides serves a couple of purposes:

- It allows the program to orient each wall’s exterior side toward the outside of a structure. See “Creating Walls” on page 193.
- It allows you to specify different materials for each side’s surface in the Wall Specification dialog. See “Materials Panel” on page 221.

In the Wall Type Definitions dialog, the exterior surface is shown at the top of the Wall Layers table. In plan view, you can identify a selected wall’s exterior surface by the location of its edit handles, which display on the exterior of the Main Layer by default. See “Resize About” on page 204.

**Wall Type Definitions Dialog**

The Wall Type Definitions dialog is used to define new wall types and redefine existing wall types in the current plan file. Select Build> Wall> Define Wall Types to open this dialog.
You can also click the Define button on the WALL TYPES panel of the Wall Specification dialog or in most Wall Defaults dialogs. See “Wall Types Panel” on page 218.

Changes made to an existing wall type definition affect all walls in the current plan using that wall type. Walls in other plan files are unaffected.

If changes to a wall type affect its thickness, the position of any walls in the plan using that wall type may be affected. See “General Wall Defaults” on page 184.

1 Manage the list of wall types available in the current plan.
   - Click the drop-down list to display all wall types in the current plan. Select a wall type from the list to display its definition. You can rename a wall type by typing in a new name. Note that wall type names in a plan must be unique.
   - To create a new wall type, click New to define a new wall type from scratch or click Copy to copy the current wall type. A copied wall type can then be renamed and redefined.
   - Click Rename to rename an existing wall type, or simply click on its name and type a new name.
   - To remove a wall type from the current plan, select it and click Delete. Wall types that are in use or set as plan defaults cannot be deleted.
   - To remove all wall types that are not in use or set as a default from the current plan, click Delete All Unused.

2 The selected wall type’s Wall Layers are listed here. Wall layers are listed from exterior at the top to interior at the bottom. The last item listed is the interior surface line rather than a true layer.
   - Click in either the Pattern or Texture column to open the Select Material dialog and choose a material for the selected wall layer. See “Select Material Dialog” on page 543.
   - Click in the Fill column to open the Layer Fill Style dialog and specify a fill style for the selected wall layer. See “Fill Styles” on page 115.
   - Click in the Thickness column to type the selected layer’s thickness, or depth. Very thin layers can be created, but for best results, avoid using a thickness of 0. For very small values, it can be helpful to temporarily change the dialog number format: click the Number Style button.
The buttons to the right of the table allow you to reorganize the wall type definition’s layers.

- Click the **Insert Above** button to create a new layer directly above, or outside, the selected layer in the wall type definition. The new layer is a copy of the original.
- Click the **Insert Below** button to create a new layer directly below, or inside, the selected layer in the wall type definition. The new layer is a copy of the original.
- Click the **Move Up** button to swap the selected layer’s position with that of the layer immediately outside of it or to move it into the layer section directly outside of it. Not available for the outermost layer or for a single Main Layer.
- Click the **Move Down** button to swap the selected layer’s position with that of the layer immediately inside of it or to move it into the layer section directly inside of it. Not available for the innermost layer or for a single Main Layer.
- Click **Delete** to remove the selected layer from the wall type definition.

The **Total Thickness** of the wall assembly displays here. If you change this value, the thickness of the Main Layer automatically updates to account for the difference.

Specify the attributes of the **Selected Wall Layer Line**, which is the line defining the selected layer’s exterior.

- Define the **Color**, **Style**, and **Weight** for the selected Wall Line.
- Check **By Layer** if you want the line to assume the attributes of the wall’s layer as defined in the **Layer Display Options** dialog. See “Layer Attributes” on page 110.

Wall layer fill styles are overridden if you use the **Hatch Wall** tool on a wall in plan view. See “Hatch Wall” on page 193.

### Wall Settings -

#### Build Platform to Exterior of Layer -
Select a wall layer from the drop-down list to build floor and ceiling platforms to. By default, the exterior side of the Main Layer is selected.

**Note:** If Build Platform to Exterior of Layer is set to the exterior wall layer, no siding material will generate to cover the floor platform.

#### Dimension to Exterior of Layer -
Select the wall type’s Dimension Layer from the drop-down list. By default, the Main Layer is selected. This setting does not affect Interior Dimensions. See “The Dimension Layer” on page 209.

A preview of the selected wall type definition displays here. See “Dialog Preview Panes” on page 32.

- When the selected preview type is a 3D view, a gap is shown between each of the wall layers in the preview. Click the **Explode Layers** button remove or restore these gaps.
- When Plan View is the selected preview type, click the **Line Weights** button to toggle the display of the wall layer and pattern line weights, or thicknesses. See “Line Weights” on page 716.

### Wall Specification Dialog

To open the **Wall Specification** dialog, select a wall or group of walls and click the **Open Object** edit button.

The panels of the **Wall Specification** dialog are also found in the **Railing, Deck Railing, and Fencing Specification** dialogs. See “Railing and Fencing Specification Dialogs” on page 221.

The settings in this dialog are also similar to those in the various **Wall Defaults** dialogs. The settings in these defaults dialogs determine the initial characteristics of railings, deck railings and fencing when they are first drawn. See “Wall, Railing, and Fencing Defaults” on page 184.

### General Panel

The settings on the **GENERAL** panel determine the basic use of the selected wall, as well as its length, angle, and other attributes.
Specify General properties of the selected wall(s) or railing(s).

- Check **Foundation Wall** to specify the selected wall as a foundation wall. More foundation wall settings are available on the FOUNDATION panel. See “Foundation Walls” on page 186.
- Check **Railing** to specify the selected wall as a railing. More railing settings are found on the RAILING and NEWELS/BALUSTERS panels.
- Check **Terrain Retaining Wall** to treat the selected wall as a terrain retaining wall. See “Retaining Walls” on page 646.
- Check **Attic Wall** to prevent the selected wall from extending through the roof above. See “Attic Walls” on page 207.
- The **Thickness** of the selected wall displays and can be changed here. If the wall is a Post to Overhead Beam railing, this setting also affects the width of the beam. See “Wall Thickness” on page 201.
- **Wall Angle** - The current absolute angle of the wall in plan view is shown. If you type in a new angle, the wall rotates about its locked point and any walls attached to it will not move. If the selected wall is curved, this value describes the angle of the chord and cannot be modified. See “3D Drafting” on page 25.
- **Wall Length** - The current length, as measured along the Resize About line, is shown. If you type a new length, the wall will extend or contract according to how it is locked. Any walls attached to the selected wall will not move. If the selected wall is curved, this value cannot be modified. See “Resize About” on page 204.
- Select a radio button to **Lock** the selected straight wall at its Start, End or Center. When the Wall Angle or Wall Length of the selected wall is changed, this point along the wall does not move. Not available for curved walls.

Check any of the Options to modify the selected wall accordingly. In most cases, multiple options can be selected.

- Check **Invisible** to specify the wall as invisible. Invisible walls can display in plan view but not in 3D views or the Materials List. Room Dividers are invisible by default. See “Room Dividers and Invisible Walls” on page 191.
- Check **No Room Definition** to display the wall in floor plan and/or 3D views but not create room definition. See “Room Definition” on page 225.
• Check **No Locate** to prevent **Auto Exterior Dimensions** from locating the wall in plan view. See “No Locate” on page 199.

• Check **No Room Moldings Exterior** to prevent any room moldings from generating along the Exterior side of the selected wall. See “Room Moldings” on page 240.

• Check **No Room Moldings Interior** to prevent any room moldings from generating along the Interior side of the selected wall.

• **Automatically Generated Wall** displays for reference and is checked whenever the selected wall was generated by the program. Typically, automatic walls are also Attic walls.

The **Curved Wall** settings control the definition of a selected curved wall’s radius and are only available when the selected wall is curved.

- **Select Outer Surface** to measure the selected wall’s radius from its center point to its outer surface.
- **Select Main Layer Outside** to measure the radius from the wall’s center point to the outside of its Main Layer. See “The Main Layer” on page 209.
- **Select Main Layer Inside** to measure the radius from the wall’s center point to the inside of its Main Layer.
- **Select Inner Surface** to measure the radius from the wall’s center point to its inner surface.
- Specify the selected wall’s **Radius**, as defined by the radio button selected above.

A preview of the selected wall, including any doors or windows inserted into it, displays on the right. If the selected wall is specified as Invisible, its plan view will display here by default. See “Dialog Preview Panes” on page 32.

**Structure Panel**

The settings on the **STRUCTURE** panel control the height and other structural attributes of the selected wall(s).

1. **Default Wall Heights** settings allow you to reset a wall’s default top and bottom heights if they have been manually edited. See “Wall Heights” on page 201.

2. **Default Wall Top Height** and **Default Wall Bottom Height** are only enabled if the selected wall’s top and/or bottom height has been edited. Check these boxes to restore the default heights.
The Platform Intersection settings control the relationship between the selected wall and the floor and ceiling platforms above and below it. These settings only take effect when the selected wall is positioned at a platform edge, such as at the exterior of a building or Open Below room.

- Select Stop at Ceiling Above to have the top of the wall stop at the bottom of the ceiling platform above.
- Select Balloon Through Ceiling Above to have the top of the wall go past the ceiling platform. If there is a wall directly above, the framing will continue upward to its bottom plate. The two walls remain separate objects on different floors, however, unless the wall above is an Attic Wall. Does not affect interior walls.
- Select Hang Floor Platform Above on Wall to produce a platform that hangs on the inside of the selected wall rather than bearing on top of it. When checked, the two options that follow are available.
- Select Subflooring to Interior Wall to hang the platform on the inside surface of the wall. When unchecked, the platform builds to the inside surface of the wall’s Main Layer. See “The Main Layer” on page 209.
- Select Include Ledger to hang the platform from a ledger board attached to the wall. When unchecked, no ledger is created when platform framing is generated. See “Floor and Ceiling Framing” on page 463.
- Select Stop at Floor Below to have the bottom of the wall stop at the top surface of a floor platform. This is the default for framed wall types.
- Select Go Through Floor Below to have the bottom of the wall go through the floor platform below. This is the default for concrete wall types. If the wall is framed and there is a framed wall directly below, the studs of the wall below will extend up produce balloon framing. Does not affect interior walls.

Note: Whether a wall is a framed or concrete type is determined by the material assigned to its Main Layer. See “Wall Type Definitions Dialog” on page 210.

- Select Generate Between Platforms to fill in the gap between floor and/or ceiling platforms when the selected railing or invisible wall separates rooms with different floor and/or ceiling heights. When unchecked, this gap is not closed. Only available for railings, Invisible railings, and Invisible walls, this setting has no effect when the selected wall type has only one layer. See “Floor and Ceiling Platforms” on page 236.

The Wall Intersection settings control whether the selected wall builds through wall corners at its Start and End points. The display of Start and End Indicators can be turned on or off in the Preferences dialog. See “Edit Panel” on page 73.

- Select Through Wall at Start to build the wall through the wall corner located at its start point.
- Select Through Wall at End to build the wall through the wall corner located at its end point.
- When neither box is checked, the program will determine whether the wall builds through the corners at each of its endpoints.

Specify the number of Rim Joists for the floor platform below the selected wall(s). See “Framing” on page 463.

- Select Single or Double to generate one or two rim joists, respectively.
- Select Automatic to generate two rim joists if there is no wall below the selected wall, and one rim joist when there is a wall below. Automatic produces a single rim joist for Deck Railing.

Check Retain Wall Framing to preserve the framing of the selected wall when the wall framing is globally rebuilt. See “Keeping Framing Current” on page 485.

A preview of the selected wall, including any doors or windows inserted into it, displays on the right. See “Dialog Preview Panes” on page 32.

Roof Panel

Any automatically generated roof style other than a hip requires roof information to be defined in the exterior walls. On the ROOF panel, you can specify how the selected wall interacts with the roof plan, defining the portion of the roof plan that bears on it. See “Automatic vs. Manual Roofs” on page 427.
**Roof Options** - Specify the shape of the wall relative to the roof.

- Check **Full Gable Wall** to create a gable end over the selected wall.
- Check **Dutch Gable Wall** to create a small gable part way up a hip roof. Use the Pitch Options below to specify the location of the gable.
- Check **High Shed/Gable Wall** to specify the selected wall as the high end of a shed roof.
- Check **Knee Wall** to define the selected interior wall as a knee wall. Only an interior wall can be defined as a knee wall. A knee wall’s height is defined by the roof above, not the ceiling height. See “Knee Walls” on page 207.
- Check **Extend Slope Downward** to continue a roof down over a bump out in an exterior wall. See “Extend Slope Downward” on page 206.
- Check **Roof Cuts Wall at Bottom** to prevent the portion of a selected wall located below an intersecting roof plane from building.
- **Combine with Above Wall** is only available when a selected wall has an Attic wall above it. Check this box to balloon frame the two walls when automatic framing is built. The two walls remain separate objects. See “Attic Walls” on page 207.

**Pitch Options** - Specify the pitch or pitches of the roof plane(s) above the selected wall.

- Enter a value to define the **Pitch** of the roof plane bearing on the selected wall.
- Check **Upper Pitch** to create a roof with two pitches or, if the selected wall is a Full Gable Wall, a half hip condition.
- Enter the **Pitch** of the second, upper roof.
- Specify the **Height** that the Upper Pitch Starts at, or define the distance **In from Baseline** that the second pitch begins. The two values are dynamic. Press the Tab key to update the relative numbers. These settings are also used to position a Dutch Gable Wall.

**Specify the Overhang Length**, which is the horizontal distance from the baseline to the eave. See “The Baseline” on page 437.
Check **Auto Roof Return** to generate roof returns on the selected wall. In most cases, roof returns only work for Full Gable Walls. See “Roof Returns” on page 460.

- Specify the horizontal **Length** of the roof return in inches (mm).
- Enter a value in inches (mm) to **Extend** the roof returns past the overhang.
- Specify a **Gable**, **Hip**, or **Full** roof return.
- Specify a **Sloping** or **Flat** roof return. See “Roof Tutorial” on page 48 of the User’s Guide.
- Check the box to **Include Gutters** on the roof returns.

Check **Lower Wall Type if Split by Butting Roof** to specify the wall type for any portion of the selected wall located beneath an adjacent, abutting roof plane, should one be present. A wall affected by this setting is specified as a Pony Wall and the upper wall is defined on the WALL TYPES panel. See “Exterior/Interior Pony Walls” on page 206.

A preview of the selected wall, including any doors or windows inserted into it, displays on the right. See “Dialog Preview Panes” on page 32.

### Foundation Panel

1. Specify the **Foundation** properties of the selected wall(s).
   - Check **Foundation Wall** to specify the selected wall as a foundation wall and enable additional settings on this panel. This box is checked by default for automatically generated foundation walls as well as walls drawn with the **Foundation Wall** tool.
   - The **Thickness** of the selected wall displays and can be changed here.

2. Check **Footing** to assign a concrete footing to the selected wall(s) and enable the settings below. Only available when Foundation Wall is checked, above.
   - Specify the **Width** and **Height** of the footing below the selected foundation wall(s). The **Height** value will be unavailable if the bottom height of the footing has been edited. See “Stepped Foundations” on page 382.
   - Check **Automatic Footing Bottom Height** to restore the default height of the selected wall’s footing. Only available when the footing bottom height has been edited.
• Check **Vertical Footing** to generate footings that run up and down along any steps in the foundation wall’s bottom height.

Specify how **Monolithic Slab** footings generate. These settings apply only when the selected wall defines the side of a Monolithic Slab. See “Foundations” on page 373.

• Specify the **Chamfer Width** and **Height**, which define the angled corners where the footing meets the underside of the slab.

Check **Sill Plate** to reserve space for one or more sill plates, or mud sills between the selected foundation stem wall or grade beam and the floor platform or framed wall that bears on it. Sill plates are generated when the floor framing is generated. See “Sill Plates” on page 464.

• Specify the **Width** and **Height** of the treated sill plates. If the Height is set to zero, no sill plates are produced. Not available if **Monolithic Slab** is the selected **Foundation Type**.

• Specify the **Count**, which is the number of sill plates stacked vertically on each stem wall or grade beam.

A preview of the selected wall, including any doors or windows inserted into it, displays on the right. See “Dialog Preview Panes” on page 32.

---

**Wall Types Panel**

1. Choose the selected wall’s **Wall Type** from the drop-down list of all currently available types. A preview of the selected wall type displays below the drop-down list.

2. Click the **Define** button to open the **Wall Type Definitions** dialog to create or modify existing wall types. See “Wall Type Definitions Dialog” on page 210.

3. Check **Pony Wall** to specify the selected wall as a pony wall having different wall types on its upper and lower portions. See “Pony Walls” on page 190.

If the selected wall is a Foundation Wall, its initial wall type will become the Lower Wall Type. For all other walls, the initial wall type will be the upper Wall Type.

4. Select the **Lower Wall Type**, the wall type of the lower portion of the pony wall, from the drop-down list. A preview of the selected wall type displays directly below.
• Click the Define button to open the Wall Type Definitions dialog.

Specify the height of the division between the upper and lower walls. These two settings are dynamic: if one is changed, the other will update accordingly.

• Specify the Elevation of Lower Wall Top, which is the division between the upper and lower walls. If the top of the lower pony wall is stepped or raked, this value will be “No Change”. This is an absolute value: regardless of the wall’s location, it is always measured from 0” (mm) - the default floor height for Floor 1. See “Floor Defaults Dialog” on page 387.

• Specify the Height Off Floor of the division between the upper and lower walls. This value is measured from the floor height of the room(s) defined by the selected wall. If the wall defines rooms with different floor heights, “No change” will display.

Align Pony Walls - Specify how the layers of the selected wall’s Upper and Lower portions align.

• Select Outer Surface to align wall types at their outer surfaces.

• Select Main Layer Outside to align wall types at the exterior edge of their main layers.

• Select Wall Center to align the centers of the main layers of both wall types.

• Select Main Layer Inside to align the wall types at the interior side of their main layers.

• Select Inner Surface to align wall types at their interior surfaces.

• No Change is used by default when multiple pony walls with different alignment settings are selected. Choose this to leave the alignment as it was when the dialog was opened.

Specify which part of the pony wall you would like to Display in Plan View. See “Displaying Pony Walls” on page 191.

• Select Default to display the portion of the pony wall specified in the Pony Wall Defaults dialog.

• Select Upper Wall to display the upper portion of this pony wall in plan view regardless of the default setting.

• Select Lower Wall to display the lower portion of this pony wall in plan view regardless of the default setting.

• When walls are group-selected, choose No Change to allow each wall in the selection set to maintain its own setting.

In the Pony Wall Defaults dialog only, specify the Display of Openings in Non-Displayed Parts of Walls. This controls how doors and windows display in plan view when they are located entirely in the part of a pony wall that is not visible.

• Select Outline to display the lines associated with openings but draw the wall layers’ lines and fill through them.

• Select Always to display doors and windows the same regardless of where they are located: drawing their outlines and preventing wall layers from drawing through them.

• Select Hide to not draw door and window outlines at all, so they cannot be seen.

A preview of the selected wall, including any doors or windows inserted into it, displays on the right. See “Dialog Preview Panes” on page 32.

Wall Covering Panel

The Wall Covering panel is also available in the Room Specification dialog. See “Room Specification Dialog” on page 240.
All wall covering materials applied to the selected wall are listed here. Select one from the drop-down list to edit its position or remove it from the wall.

- Click **Add New** to apply a new wall covering to the selected wall. See “Select Library Object Dialog” on page 522.
- Click **Replace** to replace the current wall covering with a new one from the library.
- Click **Delete** to remove the current wall covering from the selected wall.

Preview panes showing the current wall covering display the row of buttons.

Specify the **Position** of the selected wall covering.

- Enter the heights of the current wall covering’s **Top To Ceiling** and **Floor To Bottom**. The wall covering’s **Height** from its top edge to its bottom edge can also be specified.
- Check **Interior** and/or **Exterior** to apply the wall covering to the inside and/or outside of the selected wall. Interior is checked by default. Not available for rooms. See “Wall Type Definitions” on page 208.
- Check **No Room Wall Coverings** to prevent any wall coverings assigned to rooms from generating on the selected wall.

Most wall coverings are best previewed using the Standard Rendering Technique. See “Dialog Preview Panes” on page 32.

**Rail Style Panel**

The settings on the RAIL STYLE panel are only available for Railings, Half Walls. See “Rail Style Panel” on page 222.

**Newels/Balusters Panel**

The settings on the NEWELS/BALUSTERS panel are only available for Railings, Half Walls. See “Newels/Balusters Panel” on page 223.

**Rails Panel**

The settings on the RAILS panel are used to specify the style and size of the horizontal components of a selected Railing, Deck Railing, or Fence. See “Railing and Deck Tools” on page 187.

A similar panel is also found in the Staircase and Ramp Specification dialogs and has additional settings for handrails at walls. See “Rails Panel” on page 422.

The settings on this panel are like those on the MOLDINGS panel found in a variety of dialogs in the program. See “Moldings Panel” on page 506.
Materials Panel
All walls - including interior walls, railings and fencing - have an “Exterior Wall Surface” and an “Interior Wall Surface”. See “Interior and Exterior Surfaces” on page 210.

The materials specified on the MATERIALS panel affect the appearance of walls and Solid Railings in 3D views but are not calculated in the Materials List. See “Materials Lists” on page 681.

For most railing types, the “Exterior Wall Surface” component only affects the appearance of the floor platform under the railing, and “Interior Wall Surface” component is not used. For fencing, neither material component is used.

Label Panel
Wall labels display in plan view when the “Walls, Labels” layer is turned on and use the Text Style assigned to that layer. See “Wall Labels” on page 197.

For information about the settings on this panel, see “Label Panel” on page 286.

Components Panel
The information on the COMPONENTS panel can be used in the materials list. For more information, see “Components Panel” on page 692.

Object Information Panel
The information entered on the OBJECT INFORMATION panel can be used in the materials list. For more information, see “Object Information Panel” on page 693.

Railing and Fencing Specification Dialogs
To open the Railing or Fencing Specification dialog, select a railing or fencing, or a group of railings or fencing, and click the Open Object edit button.

The Railing and Fencing Specification dialogs are the same as the Wall Specification dialog, but have three panels that apply only to Railings, Half Walls, Deck Railings, and Fencing. See “Wall Specification Dialog” on page 212.

The RAILS panel is similar to the HANDRAIL panel found in the Staircase and Ramp Specification dialogs. See “Stairs, Ramps, and Landings” on page 395.
Check Specify Railing to specify the selected wall as a railing and enable the other options on this panel. Railings drawn using the Railing or Deck Railing tools have this checked by default.

Select the radio button for the desired Railing Type:

- Select Balusters to create regularly spaced balusters between larger newel posts.
- Select Solid to create a solid railing or Half Wall. Not available if the selected railing is also a Pony Wall. See “Pony Walls” on page 190.
- Select Open to create a railing with only newel posts and top and bottom rails.
- Select Open with Middle Rail to create a railing with newel posts and top, bottom, and middle rails.
- Select Panels to create a railing composed of panels. You can specify the panel style on the Newels/Balusters panel.

Check Newels/Posts to assign these to the selected railing, then specify their properties.

- Select Post to Rail to create newel posts from the floor to the top rail. This option is selected by default.
- Select Post to Beam to create newel posts from floor to a beam placed just under the ceiling height. The beam’s width is based on the Thickness of the selected railing wall.
- Select Post to Ceiling to extend the newel posts to the ceiling.
- Select Rail to Post to produce newel posts of the Height specified on the Newels/Balusters panel, with rails that build to the sides of the newels.

Specify the type and offset of the railing’s Start/End Posts.

- Select the Type of post at the railing’s Start and End points: “Full Post”, “Half Post”, or “None.” The “Auto Post” options place a Full post if the railing intersects a wall and either a Half post or None otherwise.
- Specify the Start and End Wall Offsets, which are the distances between the railing’s half posts and the intersecting wall.
- Check Uniform Offsets to apply the same offset to both ends of the railing.
- Check Square Half Post to use a square half post where the railing intersects a wall instead of the post Type specified on the Newels/Balusters
panel. This only applies when a railing end is set to have a Half Post.

4 The Top/Bottom Rail options control the placement of the top and bottom rail, or shoe.
- Uncheck Include Top Rail to eliminate the top rail.
- Uncheck Include Bottom Rail to eliminate the bottom rail and extend the balusters to the floor. Not available for Solid railings.
- Check Raise Bottom, then specify the Floor to Bottom distance, measured up from the floor platform to the bottom rail or panel.

5 Specify where the selected railing or fencing should Build From. With the exception of Follow Stairs, these settings are not available for Solid railings.
- Check Step Terrain to have the railing or fencing follow the terrain in horizontal steps between each newel post. Not available if the selected railing is a Pony Wall.
- Check Follow Terrain to have the railing or fencing follow the terrain smoothly. Not available if the selected railing is a Pony Wall.
- Check Generate on Low Platform to build the selected railing on the lower floor platform when the railing defines two room areas with different floor heights. See “Aligning Railings on Different Platforms” on page 205.
- Check Follow Stairs to have the railing or fencing follow the rise of stairs drawn in the same location. See “Inset or Middle Railing” on page 411 for more information.

6 A preview of the selected railing or fence, including any doorways or gates inserted into it, displays on the right. See “Dialog Preview Panes” on page 32.

### Newels/Balusters Panel

1 Specify the height of the Railing.
- Specify the Railing Height. For interior railings, this is measured from the height of the floor finish. See “Floor and Ceiling Platform Definitions” on page 237.

2 Specify the characteristics of the selected railing’s Newels/Posts.
- Specify the Width of each newel at its widest point.
- Check Use Wall Width to assign the width of the wall type assigned to the selected railing to its newels.
- Specify the Height, which is the height from the floor or ground to the top of the newel. Not available if Post to Rail, Post to Overhead Beam or Post to Ceiling is selected on the RAIL STYLE panel.
• Specify the **Offset**, which is the amount each newel is offset from the center of the railing. Use this to create a fence with the newels on one side of the fence boards.

• Specify the on-center **Spacing** of the newel posts.

• **Type** - Select Square, Round, or Library newels.

Note: Selecting Library from the drop-down list is the same as clicking the Library button to the immediate right and allows you to select a symbol from the library. See “Select Library Object Dialog” on page 522.

3 Specify the characteristics of the selected railing’s **Balusters**. These settings are only available when the railing type is “Balusters”.

• Specify the **Width** or diameter of each baluster at its widest point.

• Specify the on-center **Spacing** of the balusters.

• **Type** - Select Square, Round, or Library balusters.

4 Specify the characteristics of the selected railing’s **Panels**. These settings are only available when the railing type is specified as Panels on the RAIL STYLE panel.

• Specify the panel’s **Thickness**.

• Select “Solid” or “Library” from the **Panel Type** drop-down list.

5 A preview of the selected railing or fence, including any doorways or gates inserted into it, displays on the right. See “Dialog Preview Panes” on page 32.

### Rails Panel

The settings on the RAILS panel are used to specify the style and size of the horizontal components of a selected Railing, Deck Railing, or Fence. See “Railing and Deck Tools” on page 187.

A similar panel is also found in the **Staircase** and **Ramp Specification** dialogs and has additional settings for handrails at walls. See “Rails Panel” on page 422.

The settings on this panel are like those on the MOLDINGS panel found in a variety of dialogs in the program. See “Moldings Panel” on page 506.

### Wall Hatch Specification Dialog

To open the **Wall Hatch Specification** dialog, select a Wall Hatch and click the **Open Object** edit button. See “Hatch Wall” on page 193.

The settings in the **Wall Hatch Specification** dialog are found on the **FILL STYLE** panel of the specification dialogs for many different objects. See “Fill Style Specification Dialog” on page 115.
Rooms are created when walls are drawn to enclose an area. When a room is defined in this way, it automatically receives both a floor and ceiling as well as features like moldings and finish materials that can be seen in 3D Views.

Rooms can be selected and edited. Each room can be assigned a Room Type with predefined characteristics. For example, a room defined as a Deck is assigned certain attributes that are different than a Kitchen.

Chapter Contents

- Room Definition
- Floor and Room Defaults
- Room Types
- Displaying Rooms
- Selecting Rooms
- Editing Rooms
- Room Types
- Room Labels
- Room Label Specification Dialog
- Decks
- Floor and Ceiling Heights
- Floor and Ceiling Platforms
- Special Ceilings
- Room Moldings
- Room Specification Dialog

Room Definition

A room is a totally enclosed area defined by any combination of joined walls or railings, visible or invisible. To be recognized as a room by Home Designer Pro, a room must have an unbroken perimeter.

Unless otherwise specified, rooms generate floor and ceiling platforms automatically. Most rooms are also automatically covered by the roof when one is built. There are exceptions to this, such as rooms defined as Decks. See “Room Types” on page 227.

If a room is drawn within a larger structure and none of its walls connect to the exterior walls, either directly or indirectly by connecting to walls that do, it is referred to as an “island” room. The program will connect such a room to the larger structure with an Invisible Wall. See “Room Dividers and Invisible Walls” on page 191.

Room definition disappears if part or all of a surrounding wall is deleted. It is a good idea to finalize the position of walls before specifying Room Types or defining room attributes such as floor or ceiling height.

Subdividing Rooms

When a room area is first defined, it inherits its characteristics from the Floor Defaults dialog for that floor. If the room is then specified as a particular type, it may inherit properties from the Room Defaults dialog associated with its type.
If a new room is created by subdividing a larger room, it inherits its characteristics from that larger room - including any non-default settings.

If two rooms are separated by an Invisible wall, their interior areas will be measured from the wall’s centerline and characteristics like the floor finish materials and moldings will break along that line.

- If the two rooms have different floor heights, the break will occur at the wall edge that faces the room where the floor is lower.
- If the two rooms have different ceiling heights, the break will occur at the wall edge that faces the room where the ceiling is higher.

**Copying and Pasting Rooms**

A room can be copied into the same or a different plan by copying and pasting the walls that define it. Rooms copied in this manner retain their size and shape, as well as any finish materials assigned to the walls. See “Copying and Pasting Objects” on page 104.

If you want to retain the room’s Type and other specifications, copy and paste it and the walls that define it using the **Edit Area** tools. See “Edit Area Tools” on page 153.

**Floor and Room Defaults**

Select **Edit > Default Settings** to open the **Default Settings** dialog, then click the arrow to the left of “Floors and Rooms” to expand the category. Here, you can access several defaults dialogs which directly affect rooms. Select a line item and click the **Edit** button to open the defaults dialog associated with it.

**Floor Level Defaults**

Many important default values that affect rooms are specified in the **Floor Defaults** dialog for each floor in a plan. This dialog controls important information that the program uses to create a 3D model - particularly floor and ceiling heights and materials. Moldings can also be specified in the **Floor Defaults** dialog.

Only the defaults for Floor 1 can be set ahead of time. The program uses the settings from Floor 1 to create subsequent floors. Once a new floor is created, its floor defaults can be changed. See “Floor Defaults Dialog” on page 387.

The **Floor Defaults** dialog for the current floor can also be opened by clicking the **Floor Defaults** button, which can be added to the toolbars. See “Adding and Removing Buttons” on page 87.

**Floor 1 Default Height**

Home Designer Pro always defines the default height of Floor 1 at 0'-0". This height value is measured from the top of the subfloor and is the constant by which the heights of structural elements in the program like walls, floors, and ceilings are measured. The heights of architectural objects can be measured relative to this absolute height, as well. As such, this default cannot be changed.

**Floor/Ceiling Platform Defaults**

Floor and Ceiling Structure and Finish definitions assigned to rooms have a hierarchy of dynamic defaults. See “Dynamic Defaults” on page 58.

- The plan-wide defaults for platforms are set in the **Floor/Ceiling Platform Defaults** dialog.
- The plan-wide defaults can be overridden for each floor level in the **Floor Defaults** dialogs.
- Floor-wide platform defaults can be overridden in the **Room Type Defaults** dialogs.
- The platform defaults for Room Types can be overridden for individual rooms in the **Room Specifications** dialog. See “Structure Panel” on page 242.

See “Floor and Ceiling Platforms” on page 236.

**Room Type Defaults**

The **Room Types** dialog can also be opened by clicking the **Room Types** button, which can be added to the toolbars.
Select an Available Room Type from the list, then:

- Click the **Edit** button to modify the selected Room Type in the Room Type Defaults dialog.
- Click the **Rename** button to specify a new Name for the selected Room Type.

The settings in the Room Type Defaults dialogs allow you to specify the following for each Room Type:

- The **Name**, as used in its default Room Label.
- Inclusion in the **Living Area**. See “Living Area” on page 232.
- **Ceiling Structure** and **Finish**. See “Floor and Ceiling Platforms” on page 236.
- **Floor Structure** and Finish.

**Room Types**

Room Types are used to quickly apply useful structural, functional, and appearance properties to different kinds of rooms. For example, a room assigned the “Garage” Room Type will receive concrete curbs under its walls when the Foundation is built, while a “Kitchen” will get GFCI Outlets when the Auto Place Outlet tool is used.

When a room is first created by enclosing an area with walls, it is assigned a generic room type of “Unspecified.” Once a room is created, though, it can be assigned a Room Type in the Room Specification dialog. See “General Panel” on page 240.

A selection of pre-defined Room Types is available for use. See “Room Type Defaults” on page 226. When you specify that a room be a certain Room Type, all of the characteristics associated with that Room Type are assigned to the room, overriding existing settings. After you specify a Room Type, though, various settings can be customized.

**Available Room Types**

There are three broad categories of room Types: Interior, Exterior and Hybrid.


**Exterior** - Court, Deck, Balcony.

**Hybrid** - Open Below, Garage, Slab, Porch, Attic.
Effects of Room Types

Home Designer Pro applies specific properties to rooms depending on the assigned Room Type.

Living and Conditioned Areas

- All interior type rooms are included in Living Area calculations by default; exterior and hybrid type rooms are not.
- With the exception of Unspecified rooms, all interior type rooms are included in Conditioned Area calculations by default. Open Below rooms are also included; however, exterior and other hybrid type rooms are not. See “Conditioned Area Totals” on page 689.

Ceilings and Roofs

- Interior rooms have a ceiling and roof above them.
- Exterior rooms are assumed to be open to the outside and do not generate a roof above them.
- Attic rooms do not receive a ceiling and are ignored by the program’s automatic roof generator.
- Garage, Slabs, and Porches are treated like exterior rooms in all cases except that they generate a ceiling and a roof above them by default.

Floors and Foundations

- A room's default floor structure and finish definitions are determined by its Room Type. See “Room Type Defaults” on page 226.
- Open Below is a unique type of interior room that has no floor platform. Open Below rooms can be used for defining stairwell openings.
- Garages have a foundation under them as defined by the Foundation Defaults dialog with a concrete slab at the top of stem wall or grade beam.
- The floor in Garage and Slab rooms display in 3D on Floor 0, not the first floor. See “Garages” on page 380.
- Defining a room as Slab causes the floor platform thickness to equal the slab thickness value in the Foundation Defaults dialog.

Displaying Rooms

Unlike most things in Home Designer Pro, a room is not an individual object. Rather, a room is a space defined by the walls that enclose it.

Doors and Windows

- A window placed in a wall between an exterior room and an interior room always faces out toward the exterior.
- Doors placed between interior and exterior type rooms inherit their settings from the Exterior Defaults for the door tool, if available; they display threshold lines and are considered Exterior. See “Interior vs Exterior Doors” on page 288.
- Doors placed between interior type rooms do not display thresholds and are considered Interior.
- Open Below rooms are treated as interior rooms for window and door placement.

Electrical

- An electrical object placed on the wall of an exterior room using the Light, Switch, 110V Outlet or 220V Outlet tool will automatically be a waterproof or outdoor type fixture, as specified in the Electrical Defaults dialog. See “Electrical Defaults Dialog” on page 363.
- The Auto Place Outlets tool adds outlets automatically to all interior rooms. In Bath rooms, only one outlet over each sink is added. See “Auto Place Outlets” on page 366.
- Auto Place Outlets places GFCI outlets in Kitchens and Baths.
- Auto Place Outlets places fewer outlets in hybrid type rooms.
- Auto Place Outlets does not place outlets in exterior type rooms, Porches or Open Below rooms.

Plan Check

- Plan Check uses Room Types and their characteristics for basic plan checking. For example, a closet does not need a smoke detector but a bedroom does. See “Plan Check” on page 54.

In Plan Views

Rooms typically display a transparent fill in plan view. You can, however, specify a solid color or fill pattern for all the rooms on an entire floor in the
Floor Defaults dialog, or for individual rooms in the Room Specification dialog. See “Fill Style Panel” on page 247.

In order for room fill styles to display, the “Rooms” layer must be turned on. See “Layer Attributes” on page 110.

Room labels that include the room’s name as well as its size and other information can be set to display in plan view. See “Room Labels” on page 231.

In 3D Views

Rooms can be viewed in views created by any of the 3D view tools. The Dollhouse View tools can be used to see all rooms on the current floor without their ceilings. See “Creating Overviews” on page 563.

In the Materials List

The contents of a room, including furnishings and floor and ceiling materials can be calculated using the Calculate in Room tool. See “Calculate Materials in Room” on page 682.

The Calculate Materials From Selection edit tool creates a Materials List that calculates the finish materials in a selected room or rooms. Room moldings and wall, floor, and ceiling finish materials are counted, as is subflooring; but doors, windows, and structural materials like framing and other structural materials are not.

Selecting Rooms

Room definition is established when a room is completely enclosed by walls. You can confirm that a room has room definition by using the Select Objects tool to select it. When a fully-enclosed room is selected, its interior space becomes highlighted. See “Selecting Objects” on page 123.

Rooms can be group-selected using the Shift or Ctrl key. They can also be marquee-selected using the Marquee Select Similar edit tool. To select rooms of a particular type, use the Restrictive Selection option. See “Selecting Multiple Objects” on page 125.

Although rooms may be visible, if the “Rooms” layer is locked in the current view, it will not be possible to select a room. See “Locking Layers” on page 111.

The Exterior Room

Each floor level of a plan has an Exterior Room, which allows you to control its exterior wall coverings and materials in the Exterior Room Specification dialog. See “Room Specification Dialog” on page 240.

To select the Exterior Room in plan view, click just outside an exterior wall using the Select Objects tool. If a wall or other object becomes selected instead, click the Select Next Object edit button or press the Tab key until the Exterior Room becomes selected. The Status Bar indicates which object is currently selected. See “The Status Bar” on page 33.

When it is selected, a highlighted band around the plan’s exterior displays.

Note: The selection color can be specified in the Preferences dialog. See “Colors Panel” on page 64.
In 3D Views

A room can be selected in a 3D view by clicking on an empty space on its floor or a wall surface while the Select Objects tool is active.

If you select a wall or other object instead of the room, click Select Next Object edit button or press the Tab key until the room becomes selected.

In exterior camera views and overviews, the Exterior Room for each floor can be selected by clicking on the exterior surface of an exterior wall using the

Select Objects tool and then clicking the Select Next Object edit button.

Select Room Before Wall in 3D

By default, when you click on a wall surface in a 3D view, the individual wall will become selected. If you prefer to always select the room first instead of the wall, check Select Room Before Wall in 3D in the Preferences dialog. See “Architectural Panel” on page 72.

Editing Rooms

A room’s structure and appearance can be modified using its edit tools and specification dialog. Rooms can be selected in all views, and the ways in which they can be edited depend somewhat on the current view. See “Selecting Rooms” on page 229.

In 3D Views

The top and bottom heights of individual walls, the floor and ceiling heights of individual rooms, and the floor and ceiling heights for and entire floor levels can be edited using edit handles in 3D views. Lowered ceilings cannot be edited in 3D. See “3D Views” on page 557.

The default floor and ceiling heights for an entire floor level can be edited by selecting the Exterior Room. See “Floor and Room Defaults” on page 226.

To change default ceiling heights in 3D

1. Create a 3D or Cross Section/Elevation view of the exterior of your plan.
2. Click on the exterior surface of a wall, then click the Select Next Object edit button.
3. When the Exterior Room is selected in 3D:
   • The wall that you clicked on remains highlighted and an edit handle displays along its top edge.
   • When the wall is on any floor other than Floor 1, an edit handle also displays along its bottom edge.
   • A bounding box displays around each wall of the selected floor level.
   • The Status Bar says “Exterior Room”. See “The Status Bar” on page 33.
   • A temporary dimension will display, measuring from the floor’s default rough floor to default rough ceiling. See “Temporary Dimensions” on page 258.
4. Click and drag the edit handle on the top wall edge to adjust the default ceiling height, or the edit handle on the bottom edge to adjust the default floor height.
5. As you drag a handle, notice that the entire floor level is affected.

To adjust room heights in 3D

1. Create a 3D or Cross Section/Elevation view of your plan.
2. Click on the surface of a wall that faces a room to select it, then click the Select Next Object edit button.
3. When a room is selected in 3D:
   • The wall that you clicked on remains highlighted and an edit handle displays along its top and bottom edges.
   • The Status Bar says “Room”.
   • A temporary dimension will display in cross section/elevation views, and measure from the room’s rough floor to rough ceiling.
4. Click and drag the edit handle on the top wall edge to adjust the room ceiling height, or the

Note: Any rooms that do not update when the default floor or ceiling height is changed are not using the default values. To use the default values for a specific room, check Default for any of the room height values in its specification dialog. See “General Panel” on page 240.
handle on the bottom edge to adjust its floor height. Temporary dimensions display.

5. As you drag a handle, notice that all walls defining that room are affected.

To adjust the height of a wall in 3D

1. Create a 3D or cross section/elevation view of your plan.
2. Click on a surface of the wall to select it.
3. Click and drag the edit handles along its top and bottom surfaces. See “Wall Heights” on page 201.

Room materials such as floor, ceiling, and wall materials can be changed in 3D views using the

Material Painter. See “Material Painter Tools” on page 541.

Room moldings can be replaced directly from the library in 3D views, as well. See “Replace From Library” on page 523.

Room Labels

A label can display in plan view for any area defined as a room. There are two parts to each room label:

- The Room Name, which is similar to a Text object and can be selected and edited. See “The Text Tools” on page 269.
- The room area, which is not a standard text entry and cannot be directly edited.

Room labels can move or even disappear when room entries are revalidated.

Custom Room Names

The Room Names that display in room labels are based on the Room Types assigned in the Room Specification dialog. See “Room Types” on page 227.

You can, however create a custom name for a selected room, also in the Room Specification dialog. See “General Panel” on page 240.

Before creating a custom Room Name, assign the Room Type most similar to the room’s actual use. For example, if you wish to name a room “Guest Room”, begin by specifying it as a “Bedroom” since these rooms have similar uses.

You can assign a custom Room Name, move a room label or even delete it without affecting the Room Type.

Room Label Defaults

The initial settings that control the size, font, color and other aspects of room label appearance are controlled in the Room Label Defaults dialog. See “Room Label Defaults” on page 227.

You can also add additional text to the default room label if you wish. This text will appear in the labels for all rooms.

Displaying Room Labels

The display of room labels is controlled in the Layer Display Options dialog. Room labels are placed on the “Rooms, Labels” layer and use the Text Style assigned to that layer. See “Layer Display Options Dialog” on page 111.

You can specify how the area of rooms is reported by the program by turning on the display of one or more of these layers:

- Rooms, Standard Area is measured from the center of interior walls that define the room and from either the outside surface or outside of the
Main Layer of exterior walls, depending on the Living Area to setting in the General Plan Defaults dialog. It is rounded to the nearest square foot or mm and does not include the area within bay, box and bow windows. See “Exterior and Interior Walls” on page 189 and “General Plan Defaults Dialog” on page 59.

- **Rooms, Interior Area** is measured from the inner surfaces of all the room's walls.
- **Rooms, Interior Dimensions** is also measured from the inner surfaces of the room walls.

The display of room labels can also be controlled on a room by room basis in the Room Specification dialog. See “General Panel” on page 240.

### Editing Room Labels

Room labels are similar to simple Text objects and can be moved and resized much like any other text object. You can also modify a room label’s Text Style and other attributes in the Room Label Specification dialog. See “Room Label Specification Dialog” on page 233.

The text of a room label cannot be modified in its specification dialog, however. The Room Name can only be specified in the Room Specification dialog and additional text can only be added in the Room Label Defaults dialog.

If you delete a room label, the Room Type and Room Name remain unchanged in the Room Specification dialog. To restore the label, check the Show Room Label checkbox on the GENERAL panel of that dialog.

If you wish to further customize an individual room's label by adding text, uncheck Show Room Label in the Room Specification dialog and create your own label using a Text object.

### Room Area

Unlike the rest of a room label, the room area and dimensions are not standard text entries and cannot be edited or changed. The room area moves, resizes and rotates with the rest of the room label, but you can turn the area and dimensions on or off separately in the Layer Display Options dialog. See “Displaying Rooms” on page 228.

The **Interior Area** room area calculation includes the areas within bay, box or bow windows, while the Standard Area and Interior Dimensions calculations do not.

### Living Area

The Living Area label is an automatically generated Text object that reports the area of the current floor specified as living space. By default, Interior Rooms are defined as part of the Living Area, while Exterior and Hybrid Rooms are not. See “Available Room Types” on page 227.

Regardless of its Room Type, you can specify whether any room is included in the Living Area Calculation in the Room Specification dialog. See “General Panel” on page 240.

A Living Area label is created as soon as a room area is defined by walls and/or railings and is recalculated every time you add, remove, resize, or redefine a room or when you Rebuild Walls/Floors/Ceilings. If multiple buildings are created, each will have its own Living Area label. If none of a structure’s rooms are included in the Living Area Calculation, however, no Living Area label will display for it.

Each Living Area label can be edited in its specification dialog. If a new floor is added, however, any existing Living Area labels will be deleted and replaced. See “Room Label Specification Dialog” on page 233.

To turn off the display of all Living Area labels in a plan, uncheck **Show Living Area Label** in the General Plan Defaults dialog or turn off the “Room Labels” layer in the Layer Display Options dialog. See “General Plan Defaults Dialog” on page 59.

The Living Area label can be moved or deleted. To restore a deleted Living Area label, select Tools> Plan Check. You can click the Done button immediately, without actually completing Plan Check. See “Plan Check” on page 54.

### Living Area vs. Footprint

The Living Area should not be mistaken for the footprint of a house. Only true livable areas are included in the Living Area calculation. By default, exterior and hybrid room types such as Garage, Deck, and Porch are not included. Neither is any room labeled Open Below or Attic. See “Available Room Types” on page 227.

Regardless of its room type, you can specify whether a room is included in the Living Area calculation in the Room Specification dialog. See “General Panel” on page 240.
Living Area is measured from either the outside surface or the outer surface of the Main Layer of exterior walls. See “Wall Type Definitions” on page 208.

Room Label Specification Dialog

The Room Label Specification dialog opens if you select a Room Label or Living Area Label and click the Open Object edit button. See “Room Labels” on page 231.

A similar Text Specification dialog is available for simple Text objects in legacy plan or layout files created in Version 8 or prior. See “Compatibility with Other Programs” on page 39.

Text Panel

The settings on the Text panel allow you to add information to the Living Area Label. The text of a selected Room Label cannot be edited, however. See “Room Labels” on page 231.

In the text field, type any information that you would like added to the Living Area Label. The text of a selected Room Label displays here but cannot be edited.

Attributes Panel

1. Tabs - Check Box/Grid to have gridlines separate the rows and columns of tabbed text.

When no tabs are present, a simple box is drawn around the text.
• In the text field, specify the number of spaces from the left edge of the text box where each new column begins. The first column always starts at 0 and is not listed.
• Check Display Border to turn on the display of a border polyline around the selected object.
• Check Display Grid Lines to turn on the display of the grid formed by the specified rows and columns.

2 Select an Alignment option from the drop-down list to apply to the text.
3 Specify the Origin/Angle of the selected text object.
• Specify the X Position and Y Position of the selected object relative to the origin. See “3D Drafting” on page 25.
• Specify the Angle of the selected text object. The default value is 0°.
4 Specify the Size of the selected text object(s).
  • Specify the Height of the selected text object(s) or check Auto Height to automatically adjust its height to match its contents.
  • Specify the Width to of the selected text object(s) or check Auto Width to automatically adjust its width to match its contents. When Auto Width is used, text extends in a single line rather than wrap.

Decks

A Deck room is an exterior-type room that uses deck planking and framing to create a floor platform rather than using a floor finish that spans the entire room area. See “Floor and Ceiling Platform Definitions” on page 237.

The default settings for deck planking and framing are set in the Deck Room Defaults dialog. See “Room Type Defaults” on page 226.

To draw a deck, select Build> Railing and Deck> Straight Deck Railing, then click and drag to draw a railing.
• To create a deck without a railing, use one of the Deck Edge tools. See “Fencing Tools” on page 189.
• You can also create a regular, polygon-shaped deck using the Polygon Shaped Deck tool. See “Polygon Shaped Deck” on page 188.

Specifying a Height and/or Width of 0 sizes the text box as small as the text within it allows without turning on the Automatic behavior.

5 Specify the Margins to be used with the text. This is the distance between the text and the edge of the text box.

A default Left and Right margin is applied. Top and Bottom margins are measured relative to the line height and may not extend to the text box completely when given a value of 0.

Line Style Panel

The LINE STYLE panel is found in the specification dialogs for many different objects. For more information, see “Line Style Panel” on page 169.

Fill Style Panel

For information about the FILL STYLE panel, see “Fill Style Specification Dialog” on page 115.

Text Style Panel

The TEXT STYLE panel is available for a variety of objects in the program and control the appearance of the selected object’s text. See “Text Style Panel” on page 284.

A room does not have to be defined by Deck Railing to be specified as a “Deck.” See “Room Types” on page 227. You can also define a room as a “Deck” in the Room Specification dialog. See “General Panel” on page 240.

By default, decks do not have roofs. If you want a roof over a deck, check Roof Over This Room in the Room Specification dialog. See “Structure Panel” on page 242.

To give the roof a visible means of support, you can select the Post to Beam option in the Wall Specification dialog. See “Rail Style Panel” on page 222.

Openings in deck railings can be created using Doorways. See “Openings in Railings” on page 295.
**Deck Framing and Planking**

When a Deck room is created, the floor platform is modeled using joists, beams, posts, and planking as specified in the Deck Room Defaults dialog. See “Structure Panel” on page 242, “Deck Panel” on page 245, and “Deck Support Panel” on page 246.

- If a floor level is present below the one that the Deck room is created on, the framing will be created there. If needed, beams may be generated with posts beneath them, if specified. When terrain is present, the posts will have footings, again, if specified.
- If a floor level is not present below the Deck, framing will be generated on the same floor as the room. Beams may be created but posts will not.
- Deck framing, planking, posts, and beams are placed on their own layers with names that begin with “Framing, Deck”: for example, “Framing, Deck Posts”. These layers are often turned off in plan view but are typically turned on in 3D views. See “Displaying Framing” on page 482.

If standard floor framing is present when a room is specified as a Deck, that framing is deleted and replaced with deck framing.

If changes are later made to the settings on the Deck panel of the Room Specification dialog, the deck framing and planking will be automatically rebuilt in response. To prevent this from happening, uncheck Automatic Deck Framing.

Once created, the individual planking and framing objects generated for a Deck room can be selected and edited like other framing objects, provided that Automatic Deck Framing is turned off. See “Editing Framing” on page 484.

To rebuild a deck’s framing and remove any changes you may have made to individual deck framing or planks, select the Deck room and click the Build Deck Framing edit button.

If you delete a Deck room, its deck framing and planking will be automatically deleted, as well. To prevent this from happening, check Keep Deck Framing After Deck Room is Deleted. See “Deck Panel” on page 245.

The structural materials for a selected deck can be calculated in a Materials List by clicking the Calculate Structural Materials for Deck edit button. See “Materials Lists” on page 681.

**Floor and Ceiling Heights**

Default floor and ceiling heights are defined in the Floor Defaults dialog for each floor, including the foundation. Use the Floor Defaults dialog to change these values on a floor-by-floor basis. See “Floor and Room Defaults” on page 226.

Use the Room Specification dialog to set floor heights on a room-by-room basis. See “Room Specification Dialog” on page 240.

Different rooms on the same floor can have unique floor and ceiling heights, allowing you to create:

- Split levels and bi-levels
- Sunken living rooms and garages
- Cathedral, vaulted, and coffered ceilings.

In 3D views, you can adjust the default floor and ceiling height for the entire floor, the floor and ceiling height for an individual room, or the top and bottom heights of an individual wall. See “In 3D Views” on page 230.

In order to raise or lower an area’s floor or ceiling height, you must give it a room definition. To create room definition without enclosing an area with solid walls, use Railings.

Invisible walls and railings will fill in the vertical space between floor platforms of different heights as long as Generate Between Platforms is checked in
their specification dialog. See “General Panel” on page 212.

Ceiling and floor heights are interrelated. Changing the floor height in one room can affect ceiling heights of the rooms below.

- If a room’s floor is lowered, its ceiling height is increased while the ceiling below that room drops.
- If the floor is raised, the ceiling height decreases while the ceiling below that room is raised.

If the rooms above a particular room have more than one floor height, the room’s ceiling is stepped.

In a situation like this, a Lowered Ceiling can be used to cover “steps” made by different floor heights on the floor above. See “General Panel” on page 240.

**Dropped Ceilings**

The structure of a dropped, or suspended, ceiling can be specified in the Ceiling Finish dialog either for a room or the defaults for a floor. See “Floor and Ceiling Platform Definitions” on page 237.

*To create a framed dropped ceiling*

1. Select a room and click the **Open Object** edit button.
2. On the Structure panel of the **Room Specification** dialog, click the **Ceiling Finish** button. See “Structure Panel” on page 242.
3. In the Ceiling Finish dialog:
   - Check **Frame Lowered Ceiling**.
   - Specify the depth of the **Air Gap**, or the distance between the bottom of the ceiling plat-

**Floor and Ceiling Platforms**

In many ways, rooms in Home Designer Pro are defined by the floor platforms below them and the floor and/or ceiling platforms above.

All floor and ceiling platform and finish materials are used for the calculation of the materials list. See “Materials Lists” on page 681.
Floor and Ceiling Platforms

Floor and ceiling platforms are not the same thing in Home Designer Pro. Floor platforms have living space above them and are designed to be weight-bearing. Ceiling platforms, on the other hand, have living space below them but not above them. They are not designed to bear weight and are typically less strong - and less thick - than floor platforms.

Floor and Ceiling Platform Definitions

Floor and ceiling platforms are made up of layers of different materials such as framing, subflooring, drywall, and finish materials.

Floor and ceiling platform definitions play a role in determining floor and ceiling heights. Floor and ceiling finishes can be used to create dropped ceilings. See “Floor and Ceiling Heights” on page 235.

• You can specify the composition of the default floor and ceiling platforms for an entire plan in the Floor/Ceiling Platform Defaults dialog. The settings in this dialog are also found in the Room Specification dialog. See “Structure Panel” on page 242.

• Floor and ceiling platforms can be customized on a floor-by-floor basis in the Floor Defaults dialog. See “Floor Level Defaults” on page 226.

• Floor and ceiling platforms can also be customized for individual rooms in the Room Specification dialog. See “Structure Panel” on page 242.

Regardless of how they are accessed, floor and ceiling structure are defined in the Floor and Ceiling Structure Definition dialogs. See “Material Layers Definition Dialogs” on page 538.

In addition to the structural layers of a platform, floors and ceilings also have a finish layer. You can specify floor and ceiling finish materials for an entire floor or individual room on the MATERIALS panel of the Room Specification dialog. For no material, select “No Material” from the Plan Materials dialog. See “Room Specification Dialog” on page 240.

Platform Edges

Typically, floor and ceiling platforms are built so that they bear on top of walls. The edges of the platform structures extend through exterior walls to the layer of the wall type definition with the Build Platform to This Line setting. See “Wall Type Definitions” on page 208.

• For framed walls, the Build Platform to This Line layer is set as the outside of the wall’s Main Layer,

• For concrete walls, it’s the inside of the wall’s Main Layer.
• The platforms of rooms with raised floors and/or lowered ceilings build in the same manner: to the **Build Platform to This Line** layer of the wall type assigned to the railing or invisible wall defining the room. See “Floor and Ceiling Heights” on page 235.

For a given wall type, you can specify a different **Build Platform to This Line** wall layer surface provided that it is on the exterior side of the Main Layer.

In addition, you can specify that individual walls build through floor and ceiling platforms in the **Wall Specification** dialog. See “General Panel” on page 212.

### Special Ceilings

By default, the program builds a flat ceiling platform on top the wall plates of a room. More varied and complex ceilings are made using settings in the **Room Specification** dialog and the **Ceiling Plane** tool. Ceiling planes are drawn and can be edited much like roof planes. See “Ceiling Planes” on page 448.

### Lowered Ceilings

You can define a lowered or dropped ceiling in a room without affecting the top height of the walls by specifying the lowered ceiling framing as a layer in the Ceiling Finish Definition. See “Floor and Ceiling Platforms” on page 236.

In the following illustration, the default ceiling height for the entire first floor is 120", and the room on the right has a ceiling finish lowered to 96".

![Illustration of normal and lowered ceilings](image)

When a Soffit is positioned against the ceiling in a room, the Ceiling Finish layers located directly above it - including any lowered ceiling framing - will not generate. See “Placing Soffits” on page 534.

**To create a lowered ceiling**

1. Select the room in which you would like to specify a lowered ceiling.

2. Click the **Open Object** edit button to open the **Room Specification** dialog.

3. On the **STRUCTURE** panel, click the **Ceiling Finish** button to open the **Ceiling Finish** dialog. See “Material Layers Definition Dialogs” on page 538.
   - Check **Frame Lowered Ceiling**.
   - Specify the **Air Gap**, which is the distance between the bottom of the platform above and the top of the lowered ceiling framing.
   - Specify the **Framing Thickness**, which is the depth of the lowered ceiling joists.

4. When you are finished, click OK to close the **Ceiling Finish Definition** dialog.

5. On the **STRUCTURE** panel, notice that the preview diagram represents the Finished Ceiling height (F).

### Vaulted and Cathedral Ceilings

A cathedral ceiling has the same pitch as the roof and is created using the underside of the roof above the room. A vaulted ceiling typically has a different pitch from that of the roof and is often framed using scissor trusses. See “Scissors Trusses” on page 496.
To create a cathedral ceiling

1. Build a roof for your plan. See “Roofs” on page 427.
2. Select the room and open the Room Specification dialog. See “Room Specification Dialog” on page 240.
3. On the STRUCTURE panel, uncheck Flat Ceiling Over This Room.

By default, cathedrals ceiling use the ceiling material set in the Room Specification dialog. If you require a different material on a given roof plane, uncheck Use Room Ceiling Finish in the Roof Plane Specification dialog. See “Options Panel” on page 444.

To create a vaulted ceiling

1. To create a ceiling pitch different from the roof’s, select Build > Roof > Ceiling Plane and draw ceiling planes. See “Ceiling Planes” on page 448.
2. Select each ceiling plane and specify its pitch. See “Ceiling Plane Specification Dialog” on page 449.

Trey Ceilings

A trey ceiling is an area within a ceiling that is raised and has either vertical or sloping sides. A standard trey ceiling can be easily created by placing Soffits around the perimeter of the room. An angled trey ceiling can be created using the underside of roof planes above.

To create an automatic angled trey ceiling

1. In the Room Specification dialog, make sure that Flat Ceiling Over this Room is checked, then specify the desired height of the walls as the Ceiling Height. See “Structure Panel” on page 242.
2. Make sure that Auto Rebuild Roofs is unchecked, then build the roof. See “Build Roof Dialog” on page 431.
3. Change the Ceiling Height of the room to the desired height of the flat ceiling surface in its center.

In plan view, dashed lines indicate where the ceiling changes from sloped to flat. These lines are located on the “Ceiling Break Lines” layer in the Display Options dialog. See “Layer Display Options Dialog” on page 111.

If the roof is rebuilt after the ceiling height is adjusted upward, the new roof will be raised to match the new ceiling height and a trey ceiling will not be created.

In the following example, a hip roof is built on 8’ (2400 mm) ceilings. After the roof is built, the Ceiling Height is raised to 10’ (3000 mm). The resulting ceiling follows the roof pitch for 2’ (600 mm), then becomes a flat ceiling.

Cantilever Undersides

Occasionally, a room will cantilever out past an exterior wall. You can specify the surface material of the underside of a cantilever on the MATERIALS panel of the Room Specification dialog. For no material, select “No Material” from the Plan Materials dialog. See “Room Specification Dialog” on page 240.
Other Special Ceilings

Soffits can be used in various ways to enhance the 3D model. Soffits’ ability to follow the slope of the roof offers unlimited possibilities, such as exposed beams or trusses and coffered ceilings. See “Special Applications for Soffits” on page 534.

Framing members and locked roof trusses can also be used for similar purposes.

Room Moldings

Base molding, chair rail, and crown moldings can be applied to rooms on a floor by floor basis in the Floor Defaults dialogs, to different room types in the Room Type Defaults dialogs, and to individual rooms in the Room Specification dialog. See “Floor and Room Defaults” on page 226 and “Room Specification Dialog” on page 240.

By default, Home Designer Pro does not automatically add room moldings to exterior or hybrid room types. Baseboards and chair rails are not automatically added to Open Below rooms, either; however, crown molding is if it is specified in the defaults for the room’s floor. See “Room Types” on page 227.

Base molding and chair rail heights are both offset from the floor, while crown molding is offset from the ceiling. For additional information, see “Applying Moldings” on page 505.

Room Specification Dialog

The Room Specification dialog controls the structural characteristics and appearance of a selected room. To open the Room Specification dialog, select one or more rooms and click the Open Object edit button. See “Selecting Rooms” on page 229.

Some of the panels in this dialog are also found in the Exterior Room Specification dialog as well as in the Floor, Floor/Ceiling Platform, and Room Type Defaults dialogs. See “Floor and Room Defaults” on page 226.

Some values in this dialog are dynamic. A value with Default specified references the Floor Defaults dialog. To return a value to the default, replace the check mark. See “Dynamic Defaults” on page 58.

The settings in this dialog are similar to those in the Floor Defaults dialog, but affect only the selected room. See “Floor Defaults Dialog” on page 387.

If multiple rooms are selected, not all of the settings in this dialog will be available. See “Selecting Objects” on page 123.

General Panel

The General panel is also available in the Room Type Defaults dialogs. See “Floor and Room Defaults” on page 226.
The settings here control the Room Type and the appearance of the Room Label.

- Select the **Room Type** from the drop-down list. Changing the Room Type can affect settings throughout the dialog. Not available when multiple rooms are selected. See “Room Types” on page 227.

- Click the **Define** button to open the **Room Types** dialog where you can customize the settings of the selected Room Type. Not available when multiple rooms are selected.

- In the **Room Type Defaults** dialog only, the **Function** of the selected room type displays for reference. See “Available Room Types” on page 227.

- If you wish to use a custom name in the room’s label, type the desired **Room Name** in the text field.

- Check **Show Room Label** to display the room label in plan view. See “Room Labels” on page 231. This option is unchecked automatically if you select “Unspecified” as the Room Type, and checked automatically if you select any other Room Type; however, you can turn this behavior off if you wish in the **Preferences** dialog. See “Architectural Panel” on page 72.

Specify whether the selected room is included in the **Living Area** calculation. See “Living Area” on page 232.

- Select **Include in Total Living Area Calculation** to include the room in the Living Area regardless of its Room Type.

- Select **Exclude from Total Living Area Calculation** to exclude the room from the Living Area regardless of its Room Type.

- Select **Use Default for Room Type (Included/Excluded)** to base the selected room’s inclusion in the Living Area on its Room Type. The default for the selected Room Type is stated in parentheses.

Specify the **Roof Group** of the selected room. Change this value to control how the program combines the selected room’s roof system with that of the rest of the building when automatic roofs are built. This value is nearly always left at zero. Not available in the **Room Type Defaults** dialogs. See “Roof Groups” on page 430.

The preview on the right side of this dialog features a cross section diagram showing the relationships between the room’s heights and platform thicknesses.

If present, the floors above and below the selected room are also shown. The left side of the floor above is offset for clarity.

The height and thickness values shown in this diagram are set on the Structure Panel.
Structure Panel

Some settings on the STRUCTURE panel are also found in the Floor, Floor/Ceiling Platform, and Room Type Defaults dialogs.

In the Floor/Ceiling Platform and Room Type Defaults dialogs, only the Floor and Ceiling settings are available. When multiple rooms are selected, only these settings can be modified. See “Floor and Room Defaults” on page 226.

Active Defaults icons in the Elevation and Height fields, as well as Default check boxes next to the Structure and Finish fields indicate that these settings are Dynamic Defaults. See “Dynamic Defaults” on page 58.

Absolute Elevation - These height values are measured from zero, which is the default top height of the subflooring on Floor 1. See “Floor and Ceiling Heights” on page 235.

- The Floor Above height displays here for reference. If multiple rooms with differing floor heights exist directly above, “No Change” will display.
- Specify the Ceiling height of the selected room, as measured from zero to the bottom of the ceiling framing. Not available in the Room or Floor Defaults dialog or if multiple floor heights are specified above the selected room.
- Specify the Floor height, as measured from zero to the top of the subfloor.
If a room is defined directly beneath the selected room on the floor below, additional settings may be available.

- Specify the **Floor Below** height, which is the subfloor height of the room directly below where you clicked to select the currently selected room. If there are multiple rooms with differing floor heights located below, this value may change depending on where you click.
- If the selected room is directly above a Garage and there is a foundation present, you can specify the **SWT Below** height, which is the top height of the concrete stem walls around the perimeter of the garage.

**Relative Heights** - These height values are measured from surfaces within the selected room or the room below.

- Specify the **Rough Ceiling** height, as measured from the subfloor surface to the bottom of the ceiling framing. Not available if multiple floor heights are specified directly above the selected room.
- Specify the **Finished Ceiling** height, as measured from the finished floor surface to the finished ceiling surface. Not available if multiple floor heights are specified directly above the selected room.
- Specify the distance from the **Stem Wall Top to Ceiling**. Only available when **Floor for this Room is Supplied by the Foundation ‘Room’ from the Floor Below** has been checked.
- Specify the **Ceiling Below** height, which is the height of the ceiling of the room below, as measured from that room’s subfloor to rough ceiling surfaces. Not available when Auto Rebuild Foundation is enabled or if there is no room below the selected room. See “Rebuilding Foundations” on page 378.
- Specify the **Stem Wall** height, which is measured from the top of the foundation wall footing to the top of the treated sill plate, if one is specified. Only available if the selected room or the room below it is defined by foundation walls.

3 Specify the characteristics of the room’s **Ceiling**. Only the Ceiling Finish and Structure settings are available in the Room Type Defaults dialogs.

- If **Roof Over This Room** is checked, a roof automatically generates over the room. If unchecked, no roof generates.

If this option is unchecked and a roof plane is manually drawn over this room, its structure will be that of an eave rather than a regular roof. See “Roof Panel” on page 476.

- If **Flat Ceiling Over This Room** is checked, the room has a flat ceiling. If unchecked, the ceiling follows the underside of the roof or manually drawn ceiling planes.

- Check **Shelf Ceiling** to prevent Attic Walls from generating over the interior walls that define the selected room. When unchecked, interior Attic Walls will generate if surrounding rooms have higher ceilings than the selected room. See “Shelf Ceilings” on page 236.

- Check **Use Soffit Surface for Ceiling** to frame the roof over the selected room using the framing defaults for fascia rather than for rafters.

- The **Ceiling Structure** depth displays here for reference. Click the **Edit** button to open the Ceiling Structure Definition dialog and define the layers of materials that form the ceiling platform. Check **Default** to use the Ceiling Structure Definition set in the current floor’s Floor Defaults dialog. Not available for rooms on Floor 0. See “Material Layers Definition Dialogs” on page 538.

- The **Ceiling Finish** depth displays here for reference. Click the **Edit** button to open the Ceiling Finish dialog and define the layers of materials that form the finished ceiling surface. Check Default to use the Ceiling Finish set in the current floor’s Floor Defaults dialog. See “Ceiling Finish Dialog” on page 244.

- Check the **Default** box to the right of either button to restore the default structure and/or finish. See “Floor/Ceiling Platform Defaults” on page 226.

4 Specify the characteristics of the room’s **Floor**. Only the Floor Finish, Structure, and On Structure Resize settings are available in the Room Type Defaults dialogs.

- When **Floor Under This Room** is checked, the room has a floor platform as specified below.
• If **Floor Supplied by the Foundation Room Below** is checked, the floor platform for this room is a slab located on the floor below and cannot be edited here.

• If **Monolithic Slab Foundation** is checked, the current Floor Structure will be replaced by a single 4” (100 mm) layer of concrete with footings that can be seen in camera views only. When a stem wall or grade beam foundation is generated, a slab will be created beneath the selected room.

**Warning:** If the selected room has a living space located anywhere beneath it, avoid checking Monolithic Slab Foundation.

• Specify the thickness of the **Floor Finish** layer. Check **Default** to use the default Floor Finish thickness set in the current floor’s Floor Defaults dialog.

• Specify which part of the floor platform moves **On Structure Resize**. Select **Lock Floor Top** to keep the top of the floor structure at the same height and raise or lower its bottom when the platform depth is changed. Select **Lock Floor Bottom** to keep the bottom of the floor structure at the same height and raise or lower the top when the depth is changed.

• The **Floor Structure** depth displays here for reference. Click the **Edit** button to open the **Floor Structure Definition** dialog and define the layers of materials that form the floor platform. Check **Default** to use the Floor Structure Definition set in the current floor level’s Floor Defaults dialog. See “Material Layers Definition Dialogs” on page 538.

• If the selected room is a Deck, the Floor Structure button will be labeled **Planks, Joists** instead. See “Decks” on page 234.

• Check the **Default** box to the right of either button to restore the default structure and/or finish. See “Floor/Ceiling Platform Defaults” on page 226.

**Note:** The default floor and ceiling platform and finish definitions for rooms are set in the current floor’s Floor Defaults dialog. In the Floor Defaults dialog, the defaults are drawn from the Normal Room Defaults dialog. See “Floor and Room Defaults” on page 226.

The preview on the right side of this dialog features a cross section diagram showing the relationships between the room’s heights and platform thicknesses.

• If present, the floors above and below the selected room are also shown. The left side of the floor above is offset for clarity.

• The callout or dimension line associated with selected height or thickness value will be highlighted in the preview, as will any height or thickness value that you move your mouse point over.

• The font used by the callouts and dimensions is set in the Dimension Defaults dialog, while the unit of measurement is specified in the Dialog Number/Angle Style dialog. See “Dimension Defaults Dialog” on page 250 and “Dialog Number/Angle Style Dialog” on page 82.

What appears in both the diagram and in the settings on the STRUCTURE panel may be affected by the location where you clicked to select the room. For example:

• If the selected room is located above two rooms with different structural settings, the position of the pointer relative to these two lower rooms determines which of them displays as the floor below.

• If the selected room is located below two rooms with different floor heights, its absolute and relative ceiling height settings will be disabled.

### Ceiling Finish Dialog

![Ceiling Finish Dialog](image)

• Check **Frame Lowered Ceiling** to enable the two settings that follow.

• Specify the **Air Gap**, which is the vertical distance between the lowered ceiling framing and the framing of the platform above it.

• Specify the **Framing Thickness**, which is the vertical depth of the framing of the lowered ceiling.

• Specify the **Finish Thickness**, which is the vertical depth of the ceiling finish material.
• The **Total** thickness of the Ceiling Finish Definition displays for reference.

**Deck Panel**

The options on the Deck panel are only available for rooms designated as Decks, and control how deck planking and joists are generated. See “Deck Framing and Planking” on page 234.

The settings on this panel are also found in the **Deck Room Defaults** dialog, but affect the selected Deck room(s) only rather than Decks as they are initially created. See “Room Type Defaults” on page 226.

1. Check **Automatic Deck Framing** to generate planking and support framing for the deck that updates as changes are made to the deck. See “Decks” on page 234.

2. Check **Keep Deck Framing After Deck Room is Deleted** to retain the automatically generated framing and planking when the selected deck room is deleted. When this box is unchecked, the framing is automatically removed if the room is deleted.

3. Specify the appearance of the **Deck Planking**.
   - Specify how far the deck planking **Overhangs** the rim joists.
   - Specify the **Plank Width** of the deck planking.
   - Specify the **Plank Gap Width**, which is the distance between individual planks.
   - If you want to enter a **Plank Direction**, remove the check mark from **Automatic**. Enter the direction as degrees.

4. Specify the **Number of Border Planks**. These are planks that follow the outside edge of the deck and may not be parallel with the rest of the planking. Border planks generate as long as the length of an inside edge is greater than 0". They do not generate on curved deck edges.

Note: Planking thickness and joist depth are specified in the Floor Structure Definition dialog. See “Floor and Ceiling Platform Definitions” on page 237.

1. Check **No Border Against Walls** to prevent border plinking from being generated along any walls defining the deck.

2. Check **Herringbone** to produce a herringbone pattern where the border planks meet.

3. Check **Treated** to specify that the deck planking is counted as treated in the Materials List.

### Diagram

- **Automatic Deck Framing**
- **Keep Deck Framing After Deck Room is Deleted**
- **Deck Planking**
- **Number of Border Planks**
- **No Border Against Walls**
- **Herringbone Border Pattern**
- **Treated**

Specify the configuration of the **Deck Joists**.
• Enter the **Width** of the joists that support the deck.

• Specify the **Spacing** between joists, as measured from joist center to joist center.

• If you want to specify joist **Direction**, uncheck **Automatic** and enter the direction in degrees. When checked, joists are run in the direction that results in the shortest spans.

• Check **Treated** to specify that the deck joists are counted as treated in the Materials List.

4 The preview on the right side of this dialog features a cross section diagram showing the relationships between the room’s heights and platform thicknesses.

If present, the floors above and below the selected room are also shown. The left side of the floor above is offset for clarity.

The height and thickness values shown in this diagram are set on the Structure Panel.

### Deck Support Panel

The options on the **Deck Support panel** are only available for Deck rooms and control how deck beams and posts are generated. See “Deck Framing and Planking” on page 234.

The settings on this panel are also found in the **Deck Room Defaults** dialog, but affect the selected Deck room(s) only rather than Decks as they are initially created. See “Room Type Defaults” on page 226.

1 Specify the configuration of the **Deck Beams** under the selected Deck room.

• Uncheck **Deck Beams** to prevent the automatic generation of support beams under the selected Deck room.

• Click the **Edit Beam** button to open the **Deck Beam Defaults** dialog and define the beam size and other characteristics. See “Framing Specification Dialog” on page 486.

• Specify the maximum **Beam Spacing**. Beams may be positioned closer than this value, but not further apart.

2 Specify the configuration of the **Deck Posts** under the selected Deck room.

• Uncheck **Deck Posts** to prevent the automatic generation of support posts under the selected Deck room.

• Click the **Edit Post** button to open the **Deck Post Defaults** dialog and define the size and other characteristics of the posts associated with the selected Deck. See “Framing Specification Dialog” on page 486.

• Specify the maximum **Post Spacing**. Posts may be positioned closer together than this value, but not further apart.
Specify whether **Deck Post Footings** are generated under the selected Deck room’s deck posts. Not available if Deck Posts is unchecked, above.

- Uncheck **Deck Post Footings** to prevent the automatic generation of footings under the selected Deck room’s posts.
- Specify the footings’ **Height Above Terrain**. See “Foundations and the Terrain” on page 381.
- Specify the footings’ **Thickness** and **Width**.
- Specify whether the footings are **Square** or **Round** in shape.
- Specify the **Rebar Size Number**.
- Specify the **Rebar Count**, or number of bars in each footing.

The preview on the right side of this dialog features a cross section diagram showing the relationships between the room’s heights and platform thicknesses.

If present, the floors above and below the selected room are also shown. The left side of the floor above is offset for clarity.

The height and thickness values shown in this diagram are set on the Structure Panel.

### Moldings Panel

Chair rail, crown and base moldings can be assigned to one or more selected rooms on the MOLDINGS panel. Moldings are placed on a room’s wall surfaces and continue around the surface of any soffit that is attached to the wall at the molding height.

The settings on this panel are also similar to those found in the **Floor Defaults** dialog, but affect only the selected room instead of all rooms on the current floor.

The settings on this panel are similar to those found in other specification dialogs throughout the program. See “Moldings Panel” on page 506.

### Wall Covering Panel

The settings on the WALL COVERING panel of the Room Specification dialog are the same as those on the same panel of the Wall Specification dialog. When a wall covering is assigned in the Room Specification dialog, it is applied to all walls in the selected room only. See “Wall Covering Panel” on page 219.

### Fill Style Panel

The settings on the FILL STYLE panel affect the appearance of the room in plan view. This panel is also found in the **Floor Defaults** dialog. For more information, see “Fill Style Specification Dialog” on page 115.

### Materials Panel

The settings on this panel affect the appearance of a selected room’s walls, floor, ceiling, and moldings in 3D views. See “Materials Panel” on page 542.

Default molding and ceiling and floor covering materials can be set on this panel in the **Floor Defaults** and Room Defaults dialogs.

### Components Panel

The information on the COMPONENTS panel can be used in the materials list. For more information, see “Components Panel” on page 692.
Chapter 13: Dimensions

Home Designer Pro provides a variety of dimensioning tools for measuring walls, doors, windows, and many other objects in various 2D and 3D views.

Dimensions can be used to accurately position objects relative to other objects. In addition, dimension lines and extensions can be selected and customized.

Compatibility With Previous Versions

Dimensions function differently in Versions 6 and later of Home Designer Pro than they did in their predecessor, Chief Architect Home Edition 5. Being familiar with these changes is helpful if you have plans that were originally created in these legacy program versions.

Extension Lines

In Chief Architect Home Edition 5, extension lines had two modes: normal and short. Version 6 and later offer full control over extension lines. If Legacy Compatible Extensions is checked, you do not have this control. See “Extensions Panel” on page 255.

Accuracy

When the model is drawn with greater accuracy than dimensions are set to display, rounding may be required. The Rounding Method in the Dimension Defaults dialog controls how Home Designer Pro handles dimensions that require rounding. See “Setup Panel” on page 251.

In Home Designer Pro Home Edition 5 and prior, dimensions used Distance Rounding, which shows the distance between equally spaced objects correctly, but dimension runs are not always accurate when added.

In Versions 6 and later, dimensions use Grid Rounding, which always add up dimension runs correctly, but individual distances may be inaccurate in order to achieve this.

Dimensioning the same object using these two rounding methods will obtain the same results as long as objects are placed with the same accuracy as the precision of the dimension lines. If an object is placed using more precision than the dimensions, results may vary between methods.
Dimension Preferences and Defaults

There are a number of settings in the Preferences dialog that affect dimensions, as well as several dimension defaults dialogs.

Preferences

All plan and layout files save measurements in either Imperial or metric units. The type of unit used is determined when the file is first created and cannot be changed later. See “Creating a New Plan or Layout” on page 41.

You can specify either metric or Imperial files to be used as the templates whenever you open a new, blank plan or layout file in the Preferences dialog. See “New Plans Panel” on page 70.

You can also specify the minimum on-screen display size for dimension numbers in the Preferences dialog. See “Appearance Panel” on page 62.

Default Settings

Select Edit> Default Settings or double-click the Dimension Tools parent button or any of its child buttons (with the exception of the Auto Exterior tool), or the Automatic Dimension Tools parent button. There are three dimension defaults dialogs:

• Dimension Defaults Dialog
• Two Auto Dimension Defaults Dialogs

When Angle Snaps are enabled, dimensions can be drawn at the Allowed Angles set in the General Plan Defaults dialog. Regardless of their angles, however, dimensions will only locate objects that are parallel to one another. See “General Plan Defaults Dialog” on page 59.

When Marker is created in association with a manually drawn dimension, the Marker will inherit its initial settings from the Marker Defaults dialog. See “Markers” on page 282.

Dimension Defaults Dialog

Select Edit> Default Settings, expand the “Dimension” category, select “Dimensions”, and click the Edit button to open the Dimension Defaults dialog.

You can also double-click the Dimension Tools parent button to open this dialog.

The settings in this dialog are dynamic defaults, which means that any changes made here may affect existing dimension lines in the drawing that are using default values. See “Dynamic Defaults” on page 58.
Dimension Defaults Dialog

Setup Panel

1. General -
   - Specify the Line Separation, which is the distance between Baseline Dimension lines in plan inches (mm). This value should always be greater than the font size. If two formats are used, it should be at least twice the font size.
   - Specify how far manually drawn dimension lines Reach to locate walls and/or objects specified on the LOCATE OBJECTS panel. The default is 24” (450 mm) in plan files and 1” (10 mm) in layout.
   - Specify the initial spacing of Automatic Dimensions: specifically, Auto Exterior and Auto Interior Dimensions.
   - Specify the Line Separation, which is the distance between Auto Exterior Dimension lines in plan inches (mm). This value should always be greater than the font size. If two formats are used, it should be at least twice the font size.
   - Specify the 1st Line Offset, which is the distance between each wall and the nearest Automatic Dimension line that measures its length in plan inches (mm).
   - Specify the use and appearance of Rounded Value Indicators, which can display when the degree of accuracy in use is not sufficient to describe a dimension’s true value.
   - Check + or - After Number to indicate that the actual dimension value is higher or lower than the value shown.
   - Check ~ Before Number to indicate dimension values that are not accurate with the ~ symbol.

2. Specify the Rounding Method used for dimension values.
   - Grid Rounding ensures that the sum of the parts of a dimension line add up to the whole distance. To produce this result, some sections may not be rounded accurately. This is the recommended rounding method and is selected by default.
   - Distance Rounding addresses each section of a dimension line individually, which could result in the sum of these sections not being equal to the whole.

Format Panel

The settings on the FORMAT panel allow you to specify the units, position, and degree of accuracy of dimension numbers. The settings on this panel also control the format of object length numbers in the Status Bar. See “The Status Bar” on page 33.

These settings are the same as those on the FORMAT panel of the Dimension Line Specification dialog and the DIMENSION FORMAT panel of the Room Label Defaults dialog. See “Dimension Line
Specify the numbering **Format** for dimension numbers.

- Select the **Units** of measurement to be used by dimensions from the drop-down list. The choices in this list correspond to all units measuring length specified in the Preferences dialog. See “Unit Conversions Panel” on page 70.

- Check **Unit Indicators** to display the unit of measurement along with the dimension number.

- Check **Leading Zeros** to include the zero before a decimal less than 1 or to display 0’ or 0” when the ft-in or '-” unit formats is used.

- Check **Trailing Zeros** to display trailing zeros at the end of decimal values. When the ft-in or '-” unit format is used and fractional inches are specified, 0” will be included.

Specify the degree of **Accuracy** used by dimension numbers.

- Select the **Decimal Places** radio button for dimension numbers in decimal format. In the text field, specify the number of decimal places to use, from 0 to 20. If 0 is used, no decimal places are used.

- Select the **Smallest Fraction** radio button for dimension numbers using whole numbers and fractions. In the text field, specify the largest denominator to use, from 1 to 16. If 1 is entered, whole numbers are used.

Specify the **Dimension Text Position**, which is the location of dimension numbers relative to the dimension line.

- **Center** primary dimension numbers on the dimension line. If two formats are used, the primary format is placed above the line and the secondary format, beneath it.

- Position dimension numbers **Above Line**.

- Position dimension numbers **Below Line**.

**Locate Objects Panel**

The settings on the LOCATE OBJECTS panel specify how and whether or not dimension lines locate specific types of objects. Changes made on this panel only affect new dimension lines, not those already drawn.

These settings affect dimension lines as they are drawn. Once created, their extension lines can be edited so that they locate objects in ways not specified here. See “Editing Extension Lines” on page 261.

The LOCATE OBJECTS panel is also found in the Auto Exterior Dimension Defaults dialog. See “Auto Dimension Defaults Dialogs” on page 256.
In the **Dimension Defaults** dialogs for a layout file, only the **CAD Objects** settings on this panel will be available.

The **Walls** settings affect Manual and Interior Dimensions and are also available in the **Auto Exterior Dimension Defaults** dialog. See “The Dimension Tools” on page 257 and “Auto Dimension Defaults Dialogs” on page 256.

The first two settings also determine the marked location in wall assemblies referred to by Extension Lines as well as the Reach and 1st Line Offset settings. See “The Dimension Layer” on page 209.

- Select **Surfaces** to locate exterior walls by outer surface and interior walls by one of their surfaces.
- Select **Wall Dimension Layer** to locate walls at the Dimension Layer. A wall’s Dimension Layer is specified in its wall type. See “Wall Type Definitions Dialog” on page 210.
- Select **None** to prevent Manual and End to End Dimensions from locating walls.

The **Wall Options** settings control how dimensions locate interior walls where they intersect exterior walls, and only apply to interior walls drawn perpendicular to the exterior walls they intersect.

- Select **Interior Wall Centers** to have dimension lines locate the centers of interior walls. If Wall Dimension Layer is selected above, dimensions locate interior walls at the center of their Main Layers. See “The Main Layer” on page 209.
- Select **Primary Wall Side** to have dimension lines locate one side of interior walls.
- Select **Both Wall Sides** to have dimension lines locate both surfaces of interior and exterior walls. Wall thicknesses are also dimensioned.
- Check **Interior Walls Only** for dimensions to ignore the interior surface of exterior walls and the thicknesses of interior walls. Only available when Both Wall Surfaces is selected.

**Note:** Walls specified as No Locate will not be located by some dimension tools. See “No Locate” on page 199.
The remaining Locate Object options are organized into categories.

- Check the box beside an option to have dimension lines locate that location on the object type in question as they are drawn or generated.
- Check the box beside a category heading to check all of the boxes in that category. Uncheck the box to clear all of those options.

The **Cabinets** options affect how dimension lines locate objects cabinets and cabinet fillers within the Reach area. See “Using Dimensions” on page 344.

- Locate the **Sides** of cabinet objects. The sides do not need to be perpendicular to the dimension line.
- Locate the **Corners** of cabinet objects. Angled cabinets are dimensioned to their corners at a right angle to the dimension line. A cabinet’s front or sides do not need to be perpendicular or parallel to the dimension line for its corners to be located.
- Locate the **Centers** of cabinet objects. A cabinet’s front or sides do not need to be perpendicular or parallel to the dimension line for its center to be located.
- Locate cabinet **Countertop** edges. A cabinet’s front or sides must be perpendicular or parallel to the dimension line for its countertop to be located. In elevation views, only the height can be located when the dimension is being drawn.

Note: In cross section/elevation views, dimensions can only locate furniture at points where a surface is present.

Does not affect Custom Countertops 🛋.
- Locate top and bottom **Backsplash** edges in elevation views.
- Locate top and bottom **Toe Kick** edges in elevation views.
- Locate tops and bottoms of **Moldings** in elevation views.

The **Fixtures/Appliances** options affect how dimension lines locate appliances and other fixtures including hardware, millwork, sprinklers, and Geometric Shapes.

- Locate the **Sides/Corners** of appliances and other fixtures. For sides to be located, they must be perpendicular to the dimension line.
- Locate the **Centers** of all fixtures within the Reach area. An object’s front or sides do not need to be perpendicular or parallel to the dimension line for its center to be located.

The **Furniture** options affect how dimensions locate interior and exterior furnishings within the Reach area.

- Locate the **Sides/Corners** of furnishings. For sides to be located, they must be perpendicular to the dimension line.
- Locate the **Centers** of all furnishings. An object’s front or sides do not need to be perpendicular or parallel to the dimension line for its center to be located.

Note: Openings in walls specified as No Locate will not be located by Auto Exterior Dimensions. See "No Locate" on page 199.

The **Openings** options control how wall openings are located by dimension lines.

- Locate the **Centers** of wall openings.
- Locate the both **Sides** of wall openings. This option locates the nominal width - not the rough opening.
- Locate the outer edges of both sides of wall openings’ **Casing**. Because interior and exterior casing often have different widths, an opening may have different interior and exterior dimensions when this option is selected.
- Locate both sides of the **Rough Opening** of doors and windows.

The **CAD Objects** options control how dimension lines locate 2D CAD objects as well as CAD-based objects such as slabs and polyline solids, and stairs.

- Locate **Line/Sides** that are perpendicular to the dimension line. If the lines or edges are not perpendicular to the dimension line, they are not dimensioned.
- Locate all **Ends/Corners** of polylines, no matter what angle they are in relation to the dimension line.
- Check **Callouts/Markers** to locate these objects.
- Check **Text** to locate text objects.

The **Framing** options affect how dimensions locate framing objects within the Reach area. See “Using Dimensions” on page 484.

- Locate the **Centers** of framing objects.
• Locate both **Sides** of framing objects.

  The **Other Objects** options affect whether dimension lines locate additional object types at their centers.

• Locate **Electrical** objects. Use this option when you want to precisely position electrical objects. See “Moving Electrical Objects Using Dimensions” on page 369.

• Locate **Plants and Images**.

### Extensions Panel

1. Specify the **Extension Length** relative to the marked location on an object.

   - Select **Gap From Marked Object** to specify the distance between the end of extension lines and their marked location in plan inches or mm. If a dimension line is moved, extension lines update, and the size of this gap is maintained.

   - Select **Length Towards Marked Object** to specify a fixed length for the portion of an extension line that extends from the dimension line toward the object it locates. If the dimension line is moved, this length remains the same but the size of the gap updates.

   - Specify the **Length Away From Marked Object**, which is the length of the portion of an extension line that extends from the dimension line in the opposite direction of the object it locates.

2. Check **Proximity Fixed** to specify a fixed distance between the marked object and the dimension line. You can only fix the proximity for a single extension line. See “Using Proximity Fixed” on page 263.

   • **Distance to Marked Object** - When Proximity Fixed is checked, you can specify the distance from the dimension line to the marked object using a positive value.

3. The **Legacy Support** settings are only recommended for files originally created in Chief Architect Home Edition 5 and prior. See “Compatibility With Previous Versions” on page 249.

   - Check **Legacy Compatible Extensions** to assign a program-defined length to extension lines that cannot be edited.

   - Check **Short Extensions** to have short, uniform-length extension lines that do not reach all the way to the objects they locate.
Arrow Panel

For information about the ARROW panel, see “Arrow Panel” on page 171.

Auto Dimension Defaults Dialogs

The settings in the Auto Dimension Defaults dialogs allow you to control the initial appearance and behavior of dimensions created using either of the Auto Dimension tools.

Select Edit> Default Settings or double-click either the Automatic Dimension Tools or Dimension Tools parent button. Expand the Dimension category, select either of the “Auto” subcategories, and click the Edit button.

You can also add buttons to your toolbars that you can click to quickly open either of these dialogs. See “To add a button to a toolbar” on page 87.

• Auto Exterior Dimensions Defaults
• Auto Interior Dimensions Defaults

The default Line Separation and First Line Offset values for automatic dimensions are set in the Dimension Defaults dialog. See “Setup Panel” on page 251.

General Panel

• Specify how far Auto Exterior Dimension lines Reach to locate objects set back from exterior walls. The default is 192 inches (4800 mm). If exterior walls are set back further than this distance, additional dimension lines are produced to dimension the set-back walls. Only available in the Auto Exterior Dimension Defaults dialog.

• Specify the Minimum Area: the minimum enclosed area needed for Auto Dimensions to generate.

• Check Overall Dimension to generate the overall dimensions of a plan when Auto Dimensions are created.

• Check Auto Refresh Dimensions to delete and replace Auto Exterior Dimensions whenever a change is made to the model that affects them. Not available for Auto Interior Dimensions.

• Check Ignore Interior Walls to prevent interior walls that intersect exterior walls from being located by Auto Exterior Dimensions. Not available for other Auto Dimensions.

Locate Objects Panel

The settings on the LOCATE OBJECTS panel are also found on the same panel of the Dimension Defaults dialog. The available options will vary in each defaults dialog, depending on the functionality of the tool. See “Locate Objects Panel” on page 252.

The next two settings control how temporary dimensions locate interior walls.
The Dimension Tools

Select CAD > Dimensions to access the Dimension Tools. Manually drawn dimensions are created by clicking and dragging like other line-based objects and can be drawn in plan view, cross section/elevation views, and on layout pages.

With the exception of Angular Dimensions, dimension lines only locate objects that are parallel or nearly parallel to one another and should be drawn orthogonal, or at right angles, to the objects being located.

Dimension lines locate objects using Object Snaps, although they do not need to be enabled in order to draw dimensions. See “Object Snaps” on page 101. Bear in mind, though, that Object Snaps must be enabled in order to:

- Locate parallel objects drawn at angles other than Allowed Angles.
- Locate more than one object drawn in the same space, such as a CAD line drawn over a wall.

The zoom factor of the current view affects whether objects drawn close together are dimensioned or not. If you try to dimension an array of objects but the dimension line locates only the first and last objects along its path, Zoom in on the objects and try again. Similarly, if you want to dimension between two objects but the dimension locates unwanted objects between them, Zoom out. See “Zoom Tools” on page 96.

Once created, both manually drawn and automatically generated dimension lines can be selected and edited. See “Editing Dimension Lines” on page 260.

Manual Dimensions

To display the distance between two objects, select CAD > Dimensions > Manual Dimension and drag a dimension line near or through the objects.

Manual Dimensions locate objects as specified on the LOCATE OBJECTS panel and lying within the Reach distance specified in the Dimension Defaults dialog. See “Dimension Defaults Dialog” on page 250.

End-to-End Dimensions

Use the End-to-End Dimension tool to dimension between any two defined objects in plan view, cross section/elevation views and on layout pages.

Select CAD > Dimensions > End-to-End Dimension, then click and drag the dimension from the first object to the second object. The dimension line snaps to each object, ignoring any other objects located between either end.

End-to-End Dimensions locate objects as specified on the LOCATE OBJECTS panel and lying within the Reach distance specified in the Dimension Defaults dialog.

Angular Dimensions

The Angular Dimension tool measures the angle between any two straight edges, including lines, walls, the sides of boxes, the straight sides of polylines, cabinets, and soffits.

To create an angular dimension, click on the first edge to be dimensioned, then drag an arc and release on the second edge.

As with other dimension lines, Angular Dimensions adjust if one of the dimensioned objects is moved. Angular Dimensions can also be selected and moved using its edit handle. As it is moved, an Angular Dimension maintains the location of its arc center.

Interior Dimensions

Draw Interior Dimension lines parallel to walls in plan view to create interior dimensions.

The Interior Dimension tool locates interior wall surfaces only. It does not dimension between layer surfaces in the same wall, and it does not locate walls unless it actually intersects them.
**Interior Dimensions** locate either wall surfaces or the Main Layer, depending on the settings in the LOCATE OBJECTS panel of the **Dimension Defaults** dialog. See “Locate Objects Panel” on page 252.

**Point to Point Dimensions**

The **Point to Point Dimension** tool places Point Markers at the start and end points of a dimension line as it is drawn and dimensions between them. See “Markers” on page 282.

Point to Point Dimensions can be drawn in either of two ways:

- When the Default edit behavior is active, a Point to Point Dimension places Point Markers at its start and end points, which it locates. Any objects along the dimension line’s length are ignored. See “Point Markers” on page 164.

- When the Alternate edit behavior is active, a Point to Point Dimension locates objects along its length as well as objects or Point Markers at its start and end. See “Defaults, Preferences, and Edit Behaviors” on page 119.

Point Markers can be selected and edited. See “Editing Markers” on page 283.

If the objects or Point Markers located by a **Point to Point Dimension** line are moved, the dimension updates to reflect the change.

Objects and Point Markers located by a **Point to Point Dimension** line can be accurately relocated by specifying new dimension values. See “Moving Objects Using Dimensions” on page 263.

**Auto Exterior Dimensions**

The **Auto Exterior Dimension** tool generates dimensions around a plan’s exterior in plan view. These dimension lines locate walls and openings as specified in the **Auto Exterior Dimension Defaults** dialog. See “Auto Dimension Defaults Dialogs” on page 256.

If you edit an **Auto Exterior Dimension** line, it will be converted to a manual dimension, so if Auto Exterior Dimensions are later regenerated, your changes will not be lost.

Up to three rows of automatically generated dimensions may be created per exterior wall. The innermost dimension line locates exterior walls, interior walls, and all openings in exterior walls. The second dimension line locates exterior and interior walls. The outermost dimension line is the overall exterior dimension.

**Auto Interior Dimensions**

Select one or more rooms and click the **Auto Interior Dimensions** edit button to generate interior dimensions that measure each wall defining the selected room(s).

**Auto Interior Dimensions** lines are generated inside of the rooms they measure and locate walls, openings, and other objects as specified in the **Auto Interior Dimension Defaults** dialog. See “Locate Objects Panel” on page 252.

**Auto Interior Dimensions** do not recognize the No Locate setting for walls. If a wall is specified as No Locate, Auto Interior Dimensions will locate it anyway. See “No Locate” on page 199.

**Temporary Dimensions**

Temporary Dimensions display when an object is selected and show the distance between the object’s selected edge and other objects. Select View> Temporary Dimensions to turn on or off the display of temporary dimensions. This toggle affects all views and is saved between launches of Home Designer Pro.

As with other dimension lines, Temporary Dimensions only locate objects that are parallel or nearly parallel to one another. They will also locate the endpoints of CAD lines and the corners of objects located past the end of the selected edge, within 4 feet (1200 mm) of the point where you click to select the object.

A temporary dimension will not display when an object is selected if a dimension line is already present that shows the same information.
Displaying Dimension Lines

The display of dimension lines is controlled in the Layer Display Options dialog. See “Displaying Objects” on page 109.

Dimension lines created by any of the dimension tools share the same components.

- **Dimension Lines** run parallel with the distance being measured.
- **Extension Lines** are perpendicular to dimension lines, indicating what they locate. If a dimension line locates more than two objects, extension lines divide the dimension line into segments.
- **Arrowheads** display at the intersections of dimension and extension lines.
- **Dimension Labels** display at the midpoint of dimension line segments and indicate the distance that each segment measures.

Dimension labels have their own edit handle and can be moved when a dimension line is selected.

By default, dimension labels have a solid fill that is the same as the Background Color set in the Preferences dialog. You can instead specify that labels use a Text Style that has a transparent or other fill.

You can also specify the minimum size of dimension numbers displaying on screen in the Preferences dialog. See “Appearance Panel” on page 62.

Labels can be centered on dimension lines or located either above or below them. See “Format Panel” on page 251.

Dimension labels have their own edit handle and can be moved when a dimension line is selected.

**Dimension Arrowheads**

You can specify the style, color and size of dimension arrows in the Dimension Defaults and Dimension Line Specification dialogs. See “Arrow Panel” on page 171.

---

**Tape Measure**

Use the Tape Measure tool to draw a temporary dimension line between any two points in the drawing area. The tool will place temporary markers at the start and end points of the dimension line. These points and the line both disappear when you release the mouse button. If Object Snaps are enabled and an object is located by the temporary line, you can snap to it.
The arrow at the end of a dimension line will not display if it is close enough to another dimension arrow that the two will overlap. A typical example of this is where two sections of an Interior Dimension locate two sides of an interior wall.

Selecting Dimension Lines

Before a manually-drawn or automatic dimension line can be edited, it must be selected. A dimension line can be selected in one of three ways, each of which affects the ways that the dimension line can then be edited.

The standard way to select an individual dimension line is to click anywhere along its length when the Select Objects or any of the Manual Dimension tools is active. When selected in this manner, the dimension line’s full range of editing options are available.

You can instead click on one of the dimension line’s extension lines. When selected in this way, the selected extension line’s length can be edited; however, fewer edit handles are available overall. See “Editing Extension Lines” on page 261.

Dimension lines can also be group-selected, with limited editing options. See “Selecting Multiple Objects” on page 125.

Editing Dimension Lines

For information about changing the value reported in a dimension line label, see “Moving Objects Using Dimensions” on page 263.

With the exception of Temporary Dimensions, dimension lines can be selected and edited using the mouse, the edit toolbar buttons, and the Dimension Line Specification dialog. See “Dimension Line Specification Dialog” on page 264.

If an Auto Exterior Dimension line is edited, it will no longer be considered an automatic dimension line and will not be deleted and replaced the next time the Auto Exterior Dimensions tool is used.

Using the Mouse

When a dimension line is selected, its edit handles can be seen. There are five types of dimension line edit handles. The total number of edit handles a dimension line has depends on how many extension lines it has.

- The **Extension Line** handles are positioned at the point that each extension line locates and are used to move or delete extension lines. See “Moving an Extension Line” on page 262.
- The **Add Extension Line** handle displays to the side of the Move handle and is used to add extension lines to the dimension line. Extension lines added in this manner are able to locate marks that the dimension line might not locate as it was being drawn. See “Adding an Extension Line” on page 261.
- The **Move** handle is located where you clicked to select the dimension line and is used to move the entire dimension line, including any subsections,
Editing Extension Lines

Extension lines are perpendicular to itself. Extension lines are resized as appropriate. The pointer changes to a two-headed arrow ←→ when moved over this handle.

- The small, square **Move Dimension Label** handle is located at the center of the selected label. Use this handle to move the dimension number for each dimension line section. The pointer changes to a four-headed arrow ☐ when moved over this handle.
- The **Rotate** handle is located past the end of the dimension line and can be used to rotate the dimension line.

Using the Edit Tools

Dimension lines can be repositioned, copied, and deleted using the edit toolbar buttons just like other objects in the program can. See “The Edit Toolbar” on page 29.

Click the **Edit Extensions** edit button to edit the lengths of the selected dimension’s extension lines. See “Editing Extension Lines” on page 261.

Dimension Number Size

The initial size of dimension numbers is specified in the **Dimension Defaults** dialog. See “Dimension Defaults Dialog” on page 250.

You can specify number height for individual dimension lines in the **Dimension Line Specification** dialog. See “Dimension Panel” on page 265.

As with text and other objects, dimension number size is subject to scaling when sent to layout or printed. See “Printing Text, Dimensions, and Line Styles” on page 715.

Copying and Pasting Dimension Lines

Dimension lines can be copied and pasted into any view type that supports dimensions. If a dimension line is copied independent of the objects it originally locates, the pasted dimension line will locate Point Markers. See “Point Markers and Dimensions” on page 282.

Deleting Dimension Lines

There are several ways to delete dimension lines.

You can select any manual or automatic dimension line or group of dimension lines, then press the Delete key or click the **Delete** edit button. See “Deleting Objects” on page 157.

The **Delete Objects** dialog allows you to delete all manually drawn and/or automatic dimension lines at once. See “Delete Objects Dialog” on page 157.

Individual dimension line segments located between extension lines can also be deleted. If a segment is located between two other segments along the same dimension line, that dimension will be broken in two.

To delete a portion of a dimension line

1. Select any **Dimension Tool** aside from Angular or Auto Exterior Dimensions.
2. Manually draw a dimension line over the segment that you wish to remove, dragging from extension line to extension line.

Adding an Extension Line

The Add Extension Line edit handle allows you to locate marks that the dimension line might not have been able to locate as it was being drawn. Interior Dimensions, for example, do not locate cabinets as they are drawn; however, you can add an extension line that locates a cabinet.

To add an extension line

1. Select the dimension line anywhere along its length.
2. Click the diamond-shaped Add Extension Line edit handle which displays near the Move edit handle. The pointer changes to a two-headed arrow ↔.

3. Drag the handle to the object that you want to locate with a new extension handle. This example adds an extension line to the window edge.

4. Release the mouse button to add an extension line.

Moving an Extension Line

Extension lines can be moved to locate the centers, sides, or surfaces of most objects. Here, an extension line is moved from the window’s edge to the center.

To move an extension line

1. Select the dimension line anywhere along its length: do not click on the extension line itself.
2. Click the Extension Line edit handle. The pointer changes to a two-headed arrow ↔.
3. Drag the handle to a new location. The extension line snaps to possible marks as the handle is moved.
4. Release the mouse button at the new location.

Deleting an Extension Line

When an extension line is deleted, the remaining dimensions update. If a dimension line has only two extension lines, they cannot be deleted.

To remove an extension line

1. Select the dimension line anywhere along its length: do not click on the extension line itself.
2. Click the Extension Line edit handle.
3. Drag it perpendicular to the direction of the arrows, away from any dimensionable object, and release the button when the extension line disappears.

In addition, individual extension lines can be selected, allowing you to resize them.

Resizing Extension Lines

You can resize extension lines in the Dimension Line Specification dialog or using their edit handles. See “Extensions Panel” on page 255.

To resize an extension line

1. Click on the extension line or select the dimension line and click the Edit Extensions edit
Moving Objects Using Dimensions

button to display two handles along the extension line.

2. Click either handle, turning the pointer into a two-headed arrow ↔.
3. Extend or contract the extension line and release the mouse.

Using Proximity Fixed

The Proximity Fixed option allows you to specify a fixed length for one extension line that will not change if the object the extension line locates is moved.

To use Proximity Fixed

1. Select a dimension line that locates multiple independent objects and note the Extension Number of the extension line that you would like to have a fixed length.

2. Open the Dimension Line Specification dialog and go to the EXTENSIONS panel. See “Extensions Panel” on page 266.
   • Select the Extension Number that you noted in step 1 from the Selected Extension drop-down list.
   • Check Proximity Fixed.
   • Specify the desired Distance to Marked Object, which is the distance from the selected dimension line to the object that the Selected Extension locates. This distance includes the Gap From Marked Object.
   • Click OK.

To see how Proximity Fixed works, select the object that the extension line with Proximity Fixed specified and move it. Notice that the dimension line moves in response and that all extension lines’ lengths adjust except for the one with Proximity Fixed.

Moving Objects Using Dimensions

Most objects can be moved by changing an automatic, manual, or temporary dimension value that locates it. This technique can be applied in nearly any situation where dimensions are present, including angular dimensions. See “Moving Objects” on page 141.

In addition, some objects can be resized using dimensions. See “Resizing Objects” on page 145.

Your pointer indicates which dimensions can be used to relocate the selected object by changing to a pointing hand icon.

Another way to tell is to select an object and drag it in the desired direction. As you drag, note which dimensions update. These dimensions are the dimensions that can be used to move that object.

Note: A selected object can be moved and resized using a dimension line even when that dimension’s layer is locked. See “Locking Layers” on page 111.

To move an object using dimensions

1. Select the object and click on a dimension line that locates it. An inline text field opens at the location where you clicked.
   • The actual distance displays in the text field.
   • If the dimension is locating two different objects and the selected object is polyline-based, the Move Edge and Move Entire Object buttons display to the right of the text field.

   Move Edge (selected)

   16’ 1"

   Move Entire Object

   • If the dimension describes a selected wall’s length, additional buttons display to the right. See “Using Dimensions” on page 200.
2. Click the **Move** button of your choice.
3. Enter a new value in text field.
   • To use a different unit, include its indicator after the value.
   • To move the selected object past a second object, to its opposite side, enter a negative value.
   • Basic math operations can also be performed in the inline text box, just as they can in dialogs. See “Math Operations in Dialogs” on page 31.
4. The selected object moves or resizes when you press the Enter key or click outside of the text field.
5. If **Bumping/Pushing** is enabled, the object being moved will bump into any objects in its move path and not move the entire distance. Hold down the Ctrl key when you press Enter to override this move restriction. See “Bumping/Pushing” on page 142.

A variety of polyline- and box-based objects can also be resized using dimensions.

**To resize an object using dimensions**

1. Select the object along the edge that you would like to move. See “Selected Edge” on page 123.
2. Click on a dimension line that indicates its distance from the object’s opposite side.
3. In the inline text field, enter a value.
4. Click **Move edge** to move the selected edge only.
5. The selected edge moves, resizing the object, when you press the Enter key.

You can cancel a move or resize operation using dimensions at any time by pressing the Esc key.

**Resizing Walls Using Exterior Dimensions**

When resizing a structure using dimensions, it is important to work your way around it in one direction. Relocate one wall at a time in succession so that you do not redefine the same dimension more than once.

For more information, see “Measuring Walls” on page 199.

**Using Angular Dimensions**

Angular Dimensions are useful for adjusting the angles of polyline-based objects and walls.

**To change an angular dimension**

1. Draw an **CAD> Dimensions> Angular Dimension** arc, then click and drag to draw an arc within the angle you wish to measure.
2. Select the edge that you want to move.
3. Click the dimension value to open the **Set Angular Dimension** dialog.

   The **Set Angular Dimension** dialog indicates the Previous Value in degrees, minutes and seconds.

4. Enter a value in the **New Value** field.
5. Specify what you want to rotate:
   • Select **Rotate edge** to move the selected edge when you click OK, or
   • Select **Rotate entire polyline** to rotate the entire object about the corner formed by the edges that the Angular Dimension locates, maintaining the previous value of that angle.
6. Click **OK** to apply the change.

**Dimension Line Specification Dialog**

To open the Dimension Line Specification dialog, double-click a dimension line using
the Select Objects or Manual Dimension tool, or select a dimension line or group of dimension lines and click the Open Object edit button.

The settings in this dialog are dynamic defaults. See “Dimension Defaults Dialog” on page 250.

Dimension Panel

1. Options - Specify the size and display of wall widths attributes for the selected dimension line. The minimum on-screen size can be set in the Preferences dialog. See “Appearance Panel” on page 62.
   - Specify the Number Height for the selected dimension. See “Dynamic Defaults” on page 58.
   - Check Suppress Wall Widths to suppress those portions of the dimension line that measure between two surfaces of the same wall. Both sides of a wall may still be located, but its width will not display.

   *Dimension Number Height is subject to scaling. See “Scaling Text” on page 275.*

   • Check + or - After Number to indicate that the actual dimension value is higher or lower than the value shown.
   • Check ~ Before Number to indicate dimension values that are not accurate with the ~ symbol.

2. Specify the use and appearance of Rounded Value Indicators, which can display when the degree of accuracy in use is not sufficient to describe a dimension’s true value.
   - Check Use Default to use the default indicator(s). Uncheck this box to make the options that follow active.
   - Check + or - After Number to indicate that the actual dimension value is higher or lower than the value shown.
   - Check ~ Before Number to indicate dimension values that are not accurate with the ~ symbol.

Dimension Panel for Angular Dimensions

- Specify a Number Height for the selected dimension. See “Dynamic Defaults” on page 58.
- Select an Angle Style radio button to specify the selected dimension’s angle format. See “Dialog Number/Angle Style Dialog” on page 82.
The EXTENSIONS panel is not available for dimensions selected as a group or for Angular Dimensions.

**Selected Extension** - Choose an extension line associated with the currently selected dimension from the drop-down list. The Selected Extension can then be edited here.

- Uncheck Use Plan Default to enable the three settings that follow. Check this box to restore the default settings to the Selected Extension line. See “Dimension Defaults Dialog” on page 250.

- The Extension Length settings are the same as those in the Dimension Defaults dialog, but apply to the extension lines associated with the selected dimension line only. See “Extensions Panel” on page 255.

- Click Apply to All to apply the settings for the Selected Extension line to all extension lines associated with the selected dimension.

- Check Proximity Fixed to specify a fixed distance between the marked object and the dimension line. You can only fix the proximity for a single extension line.

- Distance to Marked Object - When Proximity Fixed is checked, you can specify the distance from the dimension line to the marked object using a positive value. See “Extensions Panel” on page 255.

**Arrow Panel**

For information about the settings on this panel, see “Arrow Panel” on page 171.
Chapter 14: Text, Callouts, and Markers

The Text Tools help you draw attention to special details of your drawings. Text objects can be added in plan view, in cross section/elevation views, and to layout pages.

Chapter Contents

- Text Defaults and Preferences
- Fonts and Alphabets
- The Text Tools
- Creating Text, Callouts and Markers
- Displaying Text, Arrows, Callouts and Markers
- Rich Text Specification Dialog
- Editing Text
- Copying and Pasting Text
- Find/Replace Text
- Text Arrows
- Callouts
- Callout Specification Dialog
- Editing Callouts
- Markers
- Marker Specification Dialog
- Editing Markers
- Text Styles
- Object Labels

Text Defaults and Preferences

Text Defaults can be accessed by selecting Edit> Default Settings in any view in which text can be created. Click the “+” next to Text, Callouts and Markers to display the sub-headings. See “Default Settings vs Preferences” on page 57.

The default settings for Rich Text, Callouts, Markers, and Arrows determine what these objects look like when they are first created. Text Style Defaults determine the appearance of text associated with things like dimensions and object labels.

Changes made to default settings do not alter existing text objects, so it is a good idea to go over these settings before placing text.

Text Style Defaults

Select “Text Style” from the list in the Default Settings dialog and click the Edit button to open the Saved Text Style Defaults dialog.
The **Text Style Defaults** dialog allows you to specify the attributes of the various Text Styles in use in the current file. See “Text Styles” on page 283.

### Rich Text Defaults

Double-click the **Rich Text** tool to open the **Rich Text Defaults** dialog and specify the default appearance of Rich Text objects.


**Text Lines with Arrows** use the same default layer as Rich Text, so by default they have the same color, line weight and line style. See “Layers” on page 110.

### Callout Defaults

Double-click the **Callout** tool to open the **Callout Defaults** dialog and specify the default appearance of callouts.

The **Callout Defaults** dialog looks almost the same as the **Callout Specification** dialog. See “Callout Specification Dialog” on page 279.

### Marker Defaults

Double-click the **Marker** tool to open the **Marker Defaults** dialog and specify the default appearance of markers.

The **Marker Defaults** dialog looks almost the same as the **Marker Specification** dialog. See “Marker Specification Dialog” on page 282.

### Arrow Defaults

Double-click the **Text Line with Arrow** tool to open the **Arrow Defaults** dialog.

The settings in the **Arrow Defaults** dialog determine the initial settings for arrows drawn using the **Text Line with Arrow** and **Line With Arrow** tools. These settings also determine the initial appearance of arrows when they are added to CAD lines, arcs, and polylines.

The **Arrow Defaults** dialog looks almost the same as the **Arrow panel** of the **Line Specification** dialog. See “Arrow Panel” on page 171.

Avoid typing any text in any text Defaults dialog unless you want it to be present in all text objects you create.

### Preferences

Specify whether pressing the Enter key creates a new line of text or closes the **Rich Text and Text Specification** dialogs in the **Preferences** dialog. See “Text Panel” on page 66.

### Fonts and Alphabets

Home Designer Pro allows you to use any font found in your computer’s Fonts directory.

For best printed results, using true-type or open-type fonts is recommended.

#### Chief Blueprint Font

The Chief Blueprint font is installed in the Windows Fonts directory when Home Designer Pro is installed.

On Mac systems, this font is embedded with the Home Designer Pro installation but not installed on the system. As such, it is available for use in Home Designer Pro but not in other programs.

### International Alphabets

The **Rich Text** tool supports unicode alphabets and characters. In order to use a unicode alphabet or characters, the appropriate language support must be installed on your computer.

Special characters can be added to any **Rich Text** object by:

- Copying and pasting the character from another application;
- Copying and pasting the character from the Windows Character Map;
- Using the Mac Character Viewer;
- Typing the keystroke associated with the character.
The Text Tools

See “Copying and Pasting Text” on page 276.

**Character Size**

**Callouts**, **Markers**, **Plant Schedules**, and dimension numbers can be sized to 1/128” accuracy (0.078125 mn). See “Text Style Panel” on page 284.

These objects use CAD Style Font Sizing, which specifies text size as the measurement from the baseline to the topmost part of the capital letter A, as in most CAD programs.

In legacy files migrated into Version 2021, an additional **Legacy Compatible Size** option will be available for some objects if it was specified in the original program version. When this method is used, text size is based on information stored in the font that is then modified to approximate the specified Character Height.

Rich Text objects have two font sizing methods to choose from: **CAD Style Font Sizing** and a method similar to most word processing applications, where size is based on information stored in the font. See “Options Panel” on page 273.

**Missing Fonts**

If you open a plan or layout file that uses a font that is not installed on the current computer, the program will give you an opportunity to replace it in the Replace Fonts dialog.

The table lists all missing fonts and how they will be replaced.

- Click on a font name in the list to select it. Use the Shift or Ctrl key to select multiple fonts. See “Shift and Ctrl Select” on page 125.
- Select a replacement font from the Replace With drop-down list, or leave “No Change” as the selection to maintain the file’s association with the missing fonts.
- A preview of the selected font displays below the Replace Width list.

If you do not plan to return the file to the computer where it was created, you may want to replace missing fonts with the fonts you normally use. On the other hand, if you do intend to return the file, you may prefer to not replace any missing fonts.

**The Text Tools**

Select CAD> Text to access the Text Tools. These tools are available in plan view, in cross section/elevation views, and in layout files.

The Rich Text tool is used to create text objects.

The Text Line with Arrow tool is used to connect text and another object with an arrow. See “Text Arrows” on page 278.

**Creating Text, Callouts and Markers**

Text, callouts and markers can be created in plan view, in cross section/elevation views, and on layout pages. See “View Windows” on page 93.

Once created, text, callouts and markers can be selected and edited in a variety of ways. See “Editing Text” on page 274.
To create Text

1. Select CAD > Text > Rich Text  


3. Type or paste the desired text into the Text Field.

4. Use the options to change the font, style and size of any portion of the text.

5. When you are finished, simply click outside of the Text Field to close it and the Edit Bar. The Rich Text tool remains active, so you can click and drag to create additional Text objects if you wish.

Note: If you do not type anything in the Text Field, a text object will not be created when you click outside of it.

Displaying Text, Arrows, Callouts and Markers

As with other types of objects, the display of Text objects is controlled in the Layer Display Options dialog. Text objects are located on layers with “Text” at the beginning of the layer name, such as “Text, Callouts”. See “Layer Display Options Dialog” on page 111.

Rich Text Specification Dialog

The Rich Text Specification dialog opens if you select one or more Text objects, then click the Open Object edit button.

This dialog also opens when you select the Rich Text tool and then click once in the drawing area.

When Text objects are group-selected, the text content, zoom factor, and Paragraph Options cannot be changed, but everything else can be.

The Rich Text Specification dialog is similar to the Rich Text Defaults dialog but affects the selected text rather than all subsequently created text objects. See “Text Defaults and Preferences” on page 267.

Text Panel

The settings on the Text panel allow you to type the selected Text object’s content and control many aspects of its appearance, including its font, size, color and style.

You can specify the appearance of the text before typing, and can also select and change the attributes of all or portions of the text content after it is typed. To change text that already exists, simply highlight it using the mouse and/or the Shift + arrow keys and then make any needed changes to its attributes.

Note: If you do not type anything in the text field on this panel when creating a new object, no object will be created when you click OK. On the other hand, if you remove the text from an existing object and click OK, an empty text box will result.
Use the options on the Edit Bar, which displays above the Text Entry field, to change the font, size, and style of the text.

Select the desired options before typing to affect the text as it is typed, or select some or all of the text and then specify which options to apply to it.

- Select a **Font** from the drop-down list.
- Specify the **Text Size** in drawing units.
- Click the **Print Size** button to open the **Printed Size Input** dialog. See “Scaling Text” on page 275.
- Click the **Color** button to specify the color of the selected or subsequently typed text. See “Select Color Dialog” on page 117. If **Layer Color Text** is checked on the APPEARANCE panel, any custom colors specified here are lost.
- Click the **Bold** button to specify the selected text as bold. The Ctrl+B hotkey can also be used.
- Click the **Italic** button to specify the selected text as italic. The Ctrl+I hotkey can also be used.
- Click the **Underline** button to specify the selected text as underlined. The Ctrl + U hotkey can also be used.
- Click the **Strikethrough** button to specify the selected text as stricken-through.
- Click the **Uppercase** button to display the selected text in all capital letters.

- Click the **Align Left**, **Align Center**, or **Align Right** button to specify how the selected text is aligned.
- Click the **Paragraph Options** button to specify the selected paragraph’s alignment, spacing and bullets or numbering in the **Paragraph Options** dialog.
- Specify the **Zoom** factor of the selected text by typing a percentage value in the text field or clicking the up/down arrows. This setting only affects the text as it appears in this dialog.

Note: Some fonts cannot be drawn at certain zoom factors. When this is the case, the appearance of the text will not change.

Type or paste text in the Text Entry field. See “Copy, Cut and Paste” on page 276.

- Depending on the current **Preferences** settings, pressing the Enter key either forces a new line in the text box or closes the dialog. A carriage return can also be added by typing Shift + Enter or Ctrl + Enter. See “Text Panel” on page 66.
- Right-click in the Text Entry field to access a contextual menu from which you can select Undo, Redo, Cut, Copy, Paste and Select All. See “Contextual Menus” on page 30.
- To edit text in the entry field, click and drag to highlight any portion of it and then use the tools on the Edit Bar as needed.
Paragraph Options Dialog

1. Specify the Alignment of the selected paragraph(s). See “Aligning Text” on page 275.

2. Specify the Line Spacing of the selected paragraph(s).

- Click the radio button beside Single, 1.5 Lines, Double or User Specified.
- If you select User Specified Line Height, type the desired height in the text field. For best results, this value should be at least as much as the largest text size used in the selection.

3. Specify the appearance of the selection’s side Margins, as measured in from edges of the text box. Only positive Margin values can be used.

- Specify the Indent, which is measured from the left side margin. A negative value can be used if a left Margin has been specified.

4. Specify the appearance of Bullets and numbering in the selection.

- Select the desired bullet, numbered, or lettered Type from the drop-down list.
- Specify the Number Prefix, which are any characters that you would like to display before the number or letter. Does not affect paragraphs using circle or square bullets.
- Specify the Number Suffix, which are any characters that you would like to display after the number or letter and before its actual text. Does not affect paragraphs using circle or square bullets.

Appearance Panel

Text Lines with Arrows use the same default layer as Rich Text, so they share the same default color, line weight and line style. See “Layers” on page 110.
Check **Border** to display a border around the selected text object and enable the settings that follow.

- Check **Layer Color** to use the line color assigned to the text object’s layer, or click the **Color** bar to select a different color. See “Select Color Dialog” on page 117.
- Check **Use Layer Line Style** to use the line style assigned to the text object’s layer, or choose another style either from the drop-down list.
- Check **Use Layer Weight** to use the line weight assigned to the text object’s layer, or specify a different weight. See “Line Weights” on page 716.

Check **Fill** to display a fill color within selected text object(s) and enable the settings that follow.

- Select **Custom Color** then click the Color bar to use a fill color of your choosing.
- Check **Use Layer Color** to use the color assigned to the text object’s layer as its fill color.
- Check **Use Background Color** to use program’s Background color as the text object’s fill color. See “Colors Panel” on page 64.
- Use the **Transparency** slider bar or text field to control how transparent the fill color is.

Specify the **Top**, **Bottom**, **Left**, and **Right Margins**, which are the distance between the text and the border of the selected text object(s).

**Options Panel**

**Options**

- Check **Add an Arrow** to add a Text Arrow to the selected text object. See “Text Arrows” on page 278.
- Check **Rotate with Plan** to rotate the selected text when **Rotate Plan View** is used. If unchecked, the selected text is unaffected when Rotate Plan View is used. See “Rotate Plan View” on page 94.

**Rotate with Plan** also affects text in views sent to layout if the layout box is rotated. See “CAD and Text in Layout” on page 696.

**Specify the Origin/Angle** of the selected text object.

- Specify the **X Position** and **Y Position** of the selected text relative to the origin. See “3D Drafting” on page 25.
- Specify the **Angle** of the selected text object. The default value is 0°.

**Specify the Size** of the selected text object.

- Specify the **Height** of the selected text object(s) or check **Auto Height** to automatically adjust the text object’s height to match its contents.
- Specify the **Width** to of the selected text object(s) or check **Auto Width** to automatically
adjust the text objects width to match its contents. When Auto Width is used, text extends in a single line rather than wrap.

- **CAD Style Font Sizing** measures text size based on the total height of the capital letter A, as most CAD programs do. Uncheck this to instead size text according to information stored with the font, as most word processing programs do. See “Character Size” on page 269.

### Editing Text

Once created, **Rich Text** objects can be selected individually or as a group and edited using the edit handles, the edit toolbar buttons, and the **Rich Text Specification** dialog. See “Rich Text Specification Dialog” on page 270.

#### Editing Text Attributes

Most text attributes, including the font, size, style, and the content itself, are edited in the **Rich Text Specification** dialog.

In order to edit the attributes of an existing **Rich Text** object, you must select some or all of the text before making changes. See “Text Panel” on page 270.

**To edit Text attributes**

1. Select a **Rich Text** object and click the **Open Object** edit button.
2. On the **TEXT** panel of the **Rich Text Specification** dialog, click and drag to select some or all of the text typed into the Text field.
3. With some or all of the text selected, change any of the attributes available along the top of the panel, including the font, size, color, and style.
4. As changes are made, the selected text updates. Only the selected text is modified.

#### Using the Mouse

A selected **Rich Text** object has the same edit handles as other box-based objects. See “Editing Box-Based Objects” on page 136.

As a text box’s width is made narrower or wider using an edit handle, its height may increase or decrease so that none of the text becomes hidden. The opposite is not true, however: a text box’s height cannot be resized smaller than the height of the rows of text it currently contains, plus its margins.

Depending on the active **Edit Behavior** [ ], the text box and the characters within it may or may not resize together when a corner edit handle is dragged. See “Defaults, Preferences, and Edit Behaviors” on page 119.

- If **Resize** [ ] editing is enabled, both the text object and the font resizes when a corner edit handle is dragged.
- If **Default** [ ] or **Concentric** [ ] editing is enabled, the text box resizes, but not the font size.

Specify the desired **Bumping** behaviors for the selected object(s). See “Bumping/Pushing” on page 142.

- Check **CAD Stops Move** to bump the selected object into other CAD or CAD-based objects as it is moved.
- Check **Wall Stops Move** to stop the selected object when it bumps into a wall.
• If Fillet editing is selecting, the corners become rounded and the font size does not change. See “Behaviors Panel” on page 75.

When text is resized using the edit handles, there is a "sticky point" at the natural size of the text box. Hold down the Ctrl key while resizing to override this behavior.

**Using the Edit Tools**

A selected Rich Text object can be edited in a variety of ways using the buttons on the edit toolbar. See “The Edit Toolbar” on page 29.

**Resizing Text**

Both the border of a text object and the characters it contains can be resized.

The border of a text object can be resized using its edit handles or by specifying the Height and Width in its specification dialog.

The default character height of Rich Text objects can be specified as can the character height for individual objects, in their specification dialogs. See “Text Defaults and Preferences” on page 267.

Character height can be measured in either of two ways. See “Character Size” on page 269.

**Scaling Text**

As with the size of other objects, text size is subject to the current drawing scale specified in the Page Setup dialog. See “Drawing Sheet Setup Dialog” on page 710.

To determine the Height in drawing units that is needed to produce text of a specific size when printed, use the Print Size Calculator dialog.

**To use the Print Size Calculator dialog**

1. Select the text object or Text Style that you wish to scale and click:

2. In the Print Size Calculator dialog:
   • Confirm the desired Printed Scale.
   • Enter the Desired Print Size of the text.
   • The Text Height in View required to produce the Desired Print Size displays here for reference.

3. Click OK to return to the previous dialog. The Character Height value now equals that of the Text Height in View.

Generally, the Printed Scale does not need to be changed in the Print Size Calculator dialog unless you intend to send the current view to layout at a different drawing scale. See “Sending Views to Layout” on page 697.

**Aligning Text**

Text can be aligned in a number of ways.

• The text content of a text object can be aligned to the left, right, center or justified in the Rich Text Specification dialog. See “Text Panel” on page 270.

• The Scale button on the Text panel of a variety of specification dialogs. See “Text Style Panel” on page 284.

• The Scale button in the Text Style Defaults dialog.

• The text content of a text object can be also be aligned by clicking the Align Left, Align Right, Center, or Justify edit button.

• The center points of text objects can be aligned with one another by assigning them the same X and/or Y Position. See “Attributes Panel” on page 280.
Copy, Cut and Paste

Copy, Cut and Paste of text into and out of the text specification dialogs can be accomplished using keyboard hotkeys:

- Press Ctrl + X to Cut the selected text and save it to the system clipboard.
- Press Ctrl + C to Copy the selected text and copy it to the system clipboard.
- Press Ctrl + V to paste your last cut or copied selection in a new text object.

For more, see “Copying and Pasting Objects” on page 104.

Copy, Cut and Paste use the system clipboard, making it possible to transfer text between text objects, between Home Designer Pro files, from a plan or layout into another application, or vice versa.

Copying and Pasting Text

The Copy, Cut and Paste commands use the system clipboard, making it possible to transfer text between text objects, between Home Designer Pro files, from a plan or layout into another application such as a text editor or spreadsheet program, or vice versa. See “Copying and Pasting Objects” on page 104.

All or selected portions of the Materials List can also be copied and pasted into a text object, as well as into a word processing or spreadsheet program. See “Materials Lists” on page 681.

Cut, Copy, and Paste can also be accessed from the Edit menu of many applications, including Home Designer Pro. These menu commands are not available when the text specification dialogs are open, but you can use the associated hotkeys.

To Copy, Cut and Paste text

1. On the TEXT panel of either text specification dialog or in another program altogether, highlight the text you wish to cut, copy or paste.
2. Press Ctrl + X to Cut the selected text out of its original location and save it to the system clipboard.
3. Press Ctrl + C to Copy the selected text to the system clipboard without removing it from its original location.
4. Open the text object or a file in another application and click to place your cursor in the Text field, writing area, or spreadsheet cell.
5. Press Ctrl + V to Paste the copied text at the location of your cursor.

Bear in mind that when text is copied and pasted, its formatting is not always retained. The results depend on the program or type of text object in which the content was created as well as the type of text object into which it is pasted.

Pasting into Rich Text

Text pasted into a Rich Text object from another source will retain most - but not necessarily all - of its custom formatting. If a line of text is sufficiently long, however, it may be wrapped automatically when pasted into Rich Text.

To retain the same character size when text is pasted from a word processing program into the Rich Text Specification dialog, uncheck CAD Style Font Sizing. See “Options Panel” on page 273.

If you want to retain the original color(s) of the text being pasted into a Rich Text object, be sure to uncheck Layer Color Text in the Rich Text Specification dialog. See “Appearance Panel” on page 272.

Text pasted into a RichText object from a spreadsheet program retains basic column and row information. Column width cannot be adjusted as it can in simple Text; however, as you add or remove text from a cell, row height will increase or decrease to accommodate your changes.

Pasting into a View

Text can also be pasted directly into a plan view or cross section/elevation view. When you use the Paste command, a new Rich Text object is created, the text is pasted into that object, and it is selected. In order to see the new object, you may need to Fill Window.
Find/Replace Text

The **Find/Replace Text** tools help you make sure that the text in your files is current and correct.

**Find/Replace Text** locates text in Rich Text Callouts, Markers, plant schedule titles and headings, and custom labels for objects and rooms. It does not locate text in automatic object labels, default room labels, suppressed labels, the Materials List, or in plant schedules, however.

**Find/Replace Text** locates text even when an object’s layer is turned off and/or locked. It can also find text in objects on locked layers. See “Locking Layers” on page 111.

**Find/Replace Text**

Select **Edit > Find/Replace Text** to find a particular word or string of text in your plan or layout file and replace it if you wish.

### Find and Replace -

- **Find** the string of text that you want to find in the text field.
- **Replace With** the string of text that you want the text you find to be replaced with.
- **Search** the object type and scope from the **Searching In** drop-down list. Choose “Current View”, “Current File”, “All Open Files” or “Selected Objects”.

**Search Options** allow you to refine your search.

- **Case Sensitive** to distinguish between capitalized and lowercase letters when searching. When unchecked, capitalization is ignored while searching. The Replace function is always case sensitive.
- **Expand Percent Signs** is checked, the program will ignore strings of one or two % signs in a row, which may be used to mark up imported text with style commands. Uncheck this to find individual % signs in the search results.
- **Show in File** to open a new view window or go to a new layout page and highlight the object associated with the current search result. When unchecked, the current search result will only be highlighted if it is located in the current view window. See “Working in Multiple Views” on page 94.
- **Highlight Color** button to specify the color used to highlight the object associated with the current search result. See “Select Color Dialog” on page 117.

The current search results are shown for reference in the field on the left. The location of the associated object, including file name, view name, and its object type is stated above the results field as well. Click a button to perform the associated action:

- **Find Previous** to find the previous search results.
- **Find Next** to search for additional results.
- **Replace** the current search results with the replacement specified above.
- **Replace All** instances of the current search results found throughout the searching in scope, selected above.

Although the Find options do not locate text in suppressed labels, Replace All will replace that text. See “Displaying Labels” on page 286.
Text Arrows

Text arrows, which are simply CAD lines with arrows drawn on the “Text” layer, can be used to connect text objects to details of interest in your drawing. See “Line Tools” on page 166.

When a selected Text Line with Arrow is snapped to an object on either end, its end edit handle will display the Selected Edge Handle Fill color. See “Colors Panel” on page 64.

Text arrows can be snapped together to form open or closed polylines. If two lines with arrows meet within the bounding box of a text object, however, they will not join. This allows you to attach multiple, separate text arrows to a single text object. See “Editing Line-Based Objects” on page 126.

Lines with arrows can be independent or attached to other objects. If an attached object is moved, the end of the Line with Arrow will move, as well. Arrows attach to closed polyline-based objects along their edges, but can attach to Text or an architectural object anywhere within its bounding box in plan view.

If an arrow is attached to text or another object, deleting either the text or the object will also delete the arrow.

Text with Arrow

The Text with Arrow tool places a text object with an arrow already attached. This arrow can be selected and edited like any other arrow.

Text Line with Arrow

Text Lines with Arrow can be attached to text, CAD and architectural objects by selecting CAD> Text> Text Line with Arrow and then clicking and dragging to draw a line. There is no limit to the number of text lines with arrows that can be attached to an object.

The endpoints of Text Lines with Arrows can be joined to form polylines with corners that can be adjusted using the edit handles. See “Polylines” on page 176.

A Text Line with Arrow behaves like a Line With Arrow with one exception: Text Lines with Arrow are initially placed on the “Text” layer, not the “CAD, Default”. See “Layers” on page 110.

Auto Position Arrows

If either or both ends of a line with arrow are attached to an object, Auto Position Tail and Auto Position Head will be available in the Line Specification dialog. See “Arrow Panel” on page 171.

The Auto Position options are designed to prevent lines with arrows from crossing over the text or other objects that they are snapped to. These options snap the ends of a line with arrow to predefined points on the object(s) it is attached to. If an attached object is moved, the end of the line with arrow will update so that it is snapped to the closest Auto Position location. Similarly, if the line with arrow is moved, rotated, or resized, its end may snap to a new Auto Position location on an attached object.

There are four Auto Position locations on a text object: one at the midpoint of each side. The Auto Position locations on other objects varies by object type.

The following image illustrates the behavior of Auto Positioning. The arrow has the Auto Position Tail option checked, and the tail end of the line is snapped to the text object. When the head of the line with arrow is moved, the tail of the arrow snaps to different Auto Position locations on the text object, maintaining its connection.

In addition:

• If a selected Text Line with Arrow is moved away from an Auto Position location and you check Auto Position Tail, the tail will snap to the nearest Auto Position location.
• The first segment of a polyline arrow attached to text maintains its angle when Auto Position is off and text is moved.
• Auto Position is disabled automatically when an arrow is not attached to one of the auto position locations.
• Arcs and splines with arrows can also be attached to text and other objects.

**Callouts**

Select **CAD > Text > Callout**, then click at the location where you want a callout to be placed in plan view, a cross section/elevation view, or on a layout page. The **Callout Specification** dialog displays. Make any needed changes and click **OK** to place a callout. See “Callout Specification Dialog” on page 279.

**Cross Section Lines**

Check the **Display Cross Section Line** box in the **Callout Specification** dialog to add a cross section line perpendicular to the nearest wall. See “Attributes Panel” on page 280.

Cross section lines can be added to any callout shape. Resize or rotate the cross section line by dragging the triangular edit handle near the end of the cross section line.

**Pointers and Arrows**

To add an arrow or “hat” to a callout, select the callout and drag the diamond-shaped handle away from the center of the callout. An arrow is created, pointing in the direction you dragged. Arrows can also be specified in the **Callout Specification** dialog. See “Attributes Panel” on page 280.

**Double Callouts**

Any callout can be specified as a **Double Callout** in the **Callout Specification** dialog. See “Attributes Panel” on page 280.

To resize the line between the two callout shapes, select the callout and then click and drag the edit handle at the center of either callout shape. The arrows on a double callout are always the same on both callouts.

**Callout Specification Dialog**

To open the **Callout Specification** dialog, select a callout and click the **Open Object** edit button. This dialog also displays when a new callout is created using the **Callout** tool.

The **Callout Specification** dialog is similar to the **Callout Defaults** dialog but affects the selected callouts rather than all subsequently created callouts. See “Text Defaults and Preferences” on page 267.
Callout Panel

1 Specify the text of the selected callout’s Label by typing in the text fields here. The label’s text style can be specified on the TEXT STYLE panel. See “Text Styles” on page 283.

• Type a Callout Label, which displays inside the callout shape. If no Text Below Line is specified, the Callout Label is centered in the callout shape.

• Type the Text Below Line for the bottom row, if desired. If Text Below Line is added, a line will separate this text from the Callout Label in the callout shape.

2 Specify the Callout Shape by clicking the radio button beside one of the options here.

3 Additional Specifications can be set here.

• Uncheck Automatic to enable the Size field and specify a new value. When checked, the callout is sized so that it encompasses the text of its label.

• Specify the Angle of the selected callout. Does not affect Ellipse, Capsule, or Rectangle shaped callouts.

4 A preview of the selected callout displays on the right. See “Dialog Preview Panes” on page 32.

Attributes Panel

1 Specify the attributes of the selected callout’s Cross Section Line.
• Check **Display** to apply a cross section line to the selected callout. When unchecked, no cross section line is used.

• Check **Double Callout** to specify two identical callouts connected by the cross section line. Only available when Display is checked.

• Select the cross section line’s line **Style** from the drop-down list. When **By Layer** is checked, the line style specified in the **Layer Display Options** dialog is used.

• Specify the **Weight** of the cross section line or check **By Layer** to use the line weight specified in the **Layer Display Options** dialog.

Specify the attributes of the **Callout Arrows**.

• Specify whether the arrows are **Small** or **Large**.

• Check **Filled** to specify arrows with a solid fill. When unchecked, arrows are unfilled.

• Check **By Layer** to use the color specified in the **Layer Display Options** dialog or click the **Color** bar to choose an arrow color. See “Select Color Dialog” on page 117.

• Specify the **Number of Arrows**.

A preview of the selected callout displays on the right. See “Dialog Preview Panes” on page 32.

### Line Style Panel

The **Line Style** panel is found in the specification dialogs for many different objects. For more information, see “Line Style Panel” on page 169. Additional attributes for the cross section line and arrows can be specified on the **Attributes panel**.

### Text Style Panel

The settings on the **Text Style** panel control the appearance of the selected object’s text. For more information, see “Text Style Panel” on page 284.

---

### Editing Callouts

Callouts can be edited using the edit handles, the edit toolbar buttons and the **Callout Specification** dialog. See “Callout Specification Dialog” on page 279.

When a callout is selected, it has at least four edit handles. An additional rotate handle displays for each arrow added to the callout.

- The **Move** handle is located at the center of the callout and is used to move it.

- The triangular **Extend/Rotate** handle is used to extend and/or rotate the callout’s cross section line, if one exists. See “Cross Section Lines” on page 279.

- The small, square **Resize** handle is located on the edge of the callout and is used to resize it and its associated text.

- The **Add Arrow** handle is used to add arrows by dragging away from the callout shape.

- The small triangular **Rotate Arrow** handle located at the end of an arrow, if one has been added, is used to rotate that arrow around the callout shape.

### Resizing Callouts

Callout shapes can be resized either in the **Callout Specification** dialog or using the edit handles. See “Callout Panel” on page 280.

Callout text can be resized in the **Callout Specification** dialog. See “Attributes Panel” on page 280.

As long as **Specify Callout Size** box is checked, a callout’s shape and text resize independent of one another. When this box is unchecked, the two are dynamically linked: if you resize the shape, the text adjusts accordingly or vice versa.
Markers

Markers for Level Lines, Test Boring and Point Markers can be placed in plan view, or cross section/elevation views. Framing Reference Markers should only be placed in plan views.

To create a marker, select CAD > Text > Marker and click at the location where you want it to be placed. The Marker Specification dialog opens.

You can also place a framing reference marker using Build > Framing > Framing Reference. See “Framing Reference Markers” on page 479.

Point Markers and Dimensions

There are a number of scenarios in which Markers may be created in conjunction with dimension lines. These Point Markers derive their initial attributes from the Marker Defaults dialog:

• When the Point to Point Dimension tool is used to draw a dimension line and an object is not available to snap to at either the start or end point, a Point Marker will be automatically created and the dimension line will locate it. See “Point to Point Dimensions” on page 258.

• Dimensions drawn in a cross section/elevation view may locate Cross Section Lines that represent objects rather than the objects themselves. When this occurs, Point Markers will also be placed and the dimension lines will locate them. See “Cross Section Lines” on page 574.

• If a dimension line is copied independent of the objects it locates, the pasted dimension line will locate Point Markers. See “Copying and Pasting Dimension Lines” on page 261.

Marker Specification Dialog

To open the Marker Specification dialog, select a marker and click the Open Object edit button.

This dialog also displays when a new marker is created by clicking in plan view using the Marker tool.

The Marker Specification dialog is similar to the Marker Defaults dialog but affects the selected markers rather than all subsequently created markers. See “Text Defaults and Preferences” on page 267.

Marker Panel

1. Choose a marker Type. Note that Framing Reference Markers affect the model, while the other marker types are for annotation only.
Editing Markers

Markers can be edited using the edit handles, edit toolbar and Marker Specification dialog. See “Marker Specification Dialog” on page 282.

When a marker is selected, it has four edit handles.

1. Specify the text and alignment of the selected marker’s Label. The label’s text style can be specified on the TEXT STYLE panel. See “Text Styles” on page 283.

   - Type the Text which displays above the marker’s line.
   - Type the Text Below Line that displays below the marker’s line, if desired. Only available for Level Lines.
   - When a Level Line has text both above and below the line, specify its Alignment. Select Toward Marker to align both lines of text next to the marker; select Centered to center the shorter line of text relative to the longer line; select Away From Marker to align both lines of text with the end of the line.

2. Specify the Size of the selected marker.

3. A preview of the selected marker displays on the right. See “Dialog Preview Panes” on page 32.

4. A preview of the selected marker displays on the right. See “Dialog Preview Panes” on page 32.

Text Styles

In Home Designer Pro, a Text Style is a set of attributes assigned to any object that displays text, such as Callouts, Markers, Dimensions, Plant Schedules, and object labels.

- The Move handle is located at the center of the marker and is used to move it.
- The Resize handle is located on the edge of the marker and is used to resize the marker and associated text.
- The triangular Rotate handle is used to rotate the marker and associated text.
- The Extend handle is used to adjust the distance between the marker and its associated text.

Note: Because of its ability to use multiple attributes in the same object, Rich Text does not use Text Styles. See “Rich Text Specification Dialog” on page 270.
You can create your own or edit existing Text Styles to suit your needs in the **Text Style Defaults** dialog.

### Text Style Defaults

Select **Edit > Default Settings**, click on “Text Styles” and click **Edit** to open the **Text Style Defaults** dialog. The **Saved Text Style Defaults** dialog will open, allowing you to select which Saved Text Style Defaults you would like to edit.

#### Saved Text Style Dialog

- Select the **Name** of a Text Style from the list.
- Click the **Copy** button to create a new Text Style by copying the one currently selected in the Name field.
- Click the **Edit** button to open the defaults dialog for the selected Text Style so that you can edit it.
- Click the **Rename** button to change the name of the selected Text Style.
- Click the **Delete** button to remove the selected Text Style from the current plan or layout file.
- Click **OK** to close the **Saved Text Style Defaults** dialog and save any changes you made in the defaults dialog(s). Any changes made to a given Text Style will be applied to all objects in the current plan that are set to use that Text Style.
- Click **Cancel** to close the **Saved Text Style Defaults** dialog without saving any changes that you may have made in the defaults dialog.

### Text Style Panel

The **TEXT STYLE** panel is found in various specification and defaults dialogs in the program. The settings on this panel are also found in the **Text Style Defaults** dialog, where they affect all objects using that style rather than a single selected object.

1. Specify where the selected object should draw its Text Style from. These options are not available in the **Text Style Defaults** dialog.
• Select **Use Layer for Text Style** to use the Text Style assigned to the layer that the selected text is located on.

• Select **Use Text Style**, then choose a style from the drop-down list to apply that style to the selected object, regardless of what layer it is on. When this is not selected, the name of the selected object’s Text Style displays here for reference.

• Select **Use Custom Text Style** to enable the settings below and customize the selected objects Text Style attributes.

Check **Use Default Text Style** to use the default style for the selected object type, or uncheck this box to enable the settings below and define a custom style.

The settings that follow are only editable when **Use Custom Text Style** is selected. When it is not selected, information about the Text Style that is assigned to the selected object displays for reference.

2 Specify the attributes of the selected Text Style’s **Font**.

• Select a font from the drop-down list.

• The text styles **Bold**, **Underline**, **Italic**, **Strikeout**, and **Uppercase** are available. Check any of the boxes to apply that style.

3 Specify the **Character Height** of text using the selected Text Style.

• Enter the **Character Height** in drawing units. This height is subject to the current drawing scale.

• Click the **Scale** button to open the **Printed Size Input** dialog. See “Scaling Text” on page 275.

• If the selected object was originally created in an older program version and had **Legacy Compatible Size** checked in that version, this check box will be available. If you uncheck the box and click OK, however, the option will be removed. See “Character Size” on page 269.

4 Options -

• Check **Rotate with Plan** to rotate text using the selected Text Style when **Rotate Plan View** is used. If unchecked, the text is unaffected when **Rotate View** is used. See “Rotate Plan View” on page 94.

**Rotate with Plan** also affects text in a view sent to layout if the layout box is rotated. See “CAD and Text in Layout” on page 696.

• Check **Transparent** to make text boxes using the selected Text Style transparent. When unchecked, text boxes have a solid fill the same color as your background color. Not available for objects that have **FILL STYLE** panels in their specification dialogs. See “Colors Panel” on page 64.

5 Specify the selected Text Style’s **Text Color**.

When **Use Custom Text Style** is not selected above, a Text Color does not display here for reference.

• When **By Layer** is checked, text uses the line color assigned to the layer that the object it is assigned to is located on. See “Layer Attributes” on page 110.

• Uncheck **By Layer**, then click the **Color** bar to select a different color. See “Select Color Dialog” on page 117.

6 A preview of the Text Style currently assigned to the selected object displays here.

7 As in many specification dialogs, a preview of the selected object displays on the right. See “Dialog Preview Panes” on page 32.

---

**Object Labels**

Object labels can display in plan view for a variety of different object types.

• Automatic Labels provide basic information about the object, such as its type, size, or name.

• You can create a custom label for an object in its specification dialog using text. See “Label Panel” on page 286.

---

**Automatic Labels**

Most objects that can display labels have an Automatic Label created by the program that states basic information about it. When **Automatic Labels** is selected in the object’s specification dialog, this is usually the label that will be used; however:

• If a user-defined label is specified in the object’s defaults dialog, that label will be used instead of the Automatic Label.
• Fixtures and appliances inserted into cabinets do not have labels of their own.

**Displaying Labels**

The display of object labels can be controlled by layer in the **Layer Display Options** dialog. Label layer names begin with the object type, followed by the word Label: for example, cabinet labels are located on the “Cabinets, Labels” layer. See “Layer Display Options Dialog” on page 111.

You can choose to suppress the label for an individual object on the LABEL panel of its specification dialog.

Object labels use the “Default Label Style” Text Style. See “Text Styles” on page 283.

**Label Panel**

The LABEL panel is found in the specification and defaults dialogs for a variety of different objects.

*Note: If the selected object is a plant and you choose a callout shape in the Plant Schedule Specification dialog, the settings here are overridden and the schedule label is used instead. See “Label Panel” on page 678.*

1. Most objects have a **Suppress Label** option. Check this box to prevent the selected object’s label from displaying in plan view.

Bay, Box and Bow Windows and Mulled Window units have several settings for controlling **Multiple Component** labels. See “Window Labels” on page 314.

• Select **Suppress All Labels** to display no label in plan view. Individual components are counted in the Materials List.

• Select **Show Component Labels** to produce labels for each component in plan view. Individual components are counted in the Materials List.

• Select **Show Single Label for Entire Unit** to produce one label for the unit and suppress component labels. When this option is selected, the settings that follow become enabled.

These settings also affect how Bay, Box and Bow Windows and Mulled Window units are counted in the Materials List. See “Window Labels” on page 314 and “Displaying Mulled Units” on page 311.

2. The **Label Options** control what information is contained in the label. See “Displaying 3D Views” on page 565.

• Select **Automatic Labels** to use the default label for the selected object. See “Automatic Labels” on page 285.

• Select **Specify Label** to replace the selected object’s Automatic Label with whatever you type in the text field below. When Specify Label is chosen, the selected object’s Automatic Label initially populates the text field.

3. In most specification dialogs, a preview of the selected object displays here. Labels can be seen in Plan View only. See “Dialog Preview Panes” on page 32.
Chapter 15: Doors

Home Designer Pro comes with tools for creating a wide variety of interior and exterior doors. In addition, the library offers a large selection of specialty doors and doorways including hinged, sliding, pocket, bifold, and garage doors. Additional name-brand door catalogs are also available for download from our web site, HomeDesignerSoftware.com.

Door Defaults

There are several defaults dialogs for doors. Default Settings are accessed by selecting Edit > Default Settings. Click the arrow next to “Doors” to expand the category. Select a subheading and click the Edit button to open the defaults dialog associated with your selection.

Door Defaults can also be accessed by double-clicking the Door Tools parent button or the Hinged Door or Sliding Door child button. Double-clicking the other Door Tools child buttons will open the defaults dialog for that particular door type.

The Door Defaults dialogs look nearly the same as the Door Specification dialog. See “Door Specification Dialog” on page 296. There are only a couple of differences:

- Since default settings are specified here, “Use Default” is not an option for some settings as it is in the Door Specification dialog.
- The Door Type cannot be changed in the Defaults dialogs.
Because Hinged and Sliding Doors are often used in both interior and exterior applications, they have both Interior and Exterior Door Defaults.

**Interior vs Exterior Doors**

Regardless of its Door Type or the tool used to create it, a door will be:

- An Interior Door if it is placed into a wall that separates two interior rooms;
- An Exterior Door if it is placed into a wall that separates an interior room from either an exterior room or the building’s exterior. See “Room Types” on page 227.

This rule applies to doors copied and pasted from one location to another just as it does to those created using the Door Tools.

**Dynamic Door Defaults**

A variety of door default values are dynamic, including the Add for Rough Opening values, Casing and Lintel Specifications, and Hardware.

When a dynamic default is changed, existing doors using the default value are affected. See “Dynamic Defaults” on page 58.

All Materials listed under “Doorway” on the MATERIALS panel are also dynamic. Materials assigned to doors and hardware items from the library are listed separately and are dynamically linked to the “Interior Door”, “Exterior Door” and “Fixture Trim” and “Hardware” materials set in the Material Defaults dialog rather than the Door Defaults dialogs. See “Material Defaults Dialog” on page 540.

**Door Framing**

The default headers, trimmers, rough opening, and sill for doors can be defined in the Door Defaults dialogs. You can also specify an additional amount to cutout for door openings in concrete garage curbs and foundation walls. See “General Panel” on page 296.

Additional header defaults can also be specified in the Build Framing dialog. See “Framing Defaults” on page 463.

**Door Tools**

To place a door, select the type you want from the Build> Door submenu. Move your mouse pointer over a wall section. When a preview outline can be seen, click to place a door at that location.

The minimum initial size for doors varies by Door Type. For example, If there is room enough along the wall to fit a 12” (300 mm) wide Hinged Door, a preview outline will display and a door can be placed. Garage doors, in contrast, must initially be at least 6’ (1800 mm) wide.

Doors can be placed in both straight and curved walls, as well as span across straight, collinear wall segments.

Doors can also be placed in curved walls. See “Options Panel” on page 298.

A newly created door inherits the settings in the Door Defaults dialog for its door type. Once created, doors can be edited in a variety of ways. See “Door Defaults” on page 287.

Doors cannot be placed in a wall specified as Invisible or if the wall in question is on a locked layer. See “Locking Layers” on page 111. See “Room Dividers and Invisible Walls” on page 191.

Once placed, any door may be changed into any other type of door in the Door Specification dialog. See “General Panel” on page 296.

**Hinged Doors**

Select Build> Door> Hinged Door and click on a wall to place a hinged door at that location. Hinged doors have separate defaults for interior and exterior doors. By default, a hinged door becomes a double door when its width is four feet (1200 mm) or greater.

The initial swing direction of a hinged door depends on the location of the mouse pointer relative to the wall when you click. The door will swing towards the side of the wall that you click nearest.

The initial hinge side of a hinged door can be set by clicking to place the door and then holding the mouse button down rather than releasing it. Move the mouse toward the end of the door that you would like the hinges to be on: as the mouse pointer nears either end, the door preview’s hinge side will move to that end. You can also adjust the door’s swing direction in this manner. When the swing direction and hinge side are correct, release the mouse button.
Doorways

Select Build > Door > Doorway and click on a wall to place a doorway. Doorways are simply openings without a door and can be placed in interior and exterior walls, railings, and fences. You can assign a door from the library to a doorway if you wish.

Sliding Doors

Select Build > Door > Sliding Door and click on a wall to place a sliding door. Sliding doors have separate defaults for interior and exterior doors: interior sliding doors are typically solid while exterior sliding doors are Glass Panel doors.

The initial opening side of a sliding door can be specified by moving the mouse pointer along the wall while the mouse button is still pressed.

Pocket Doors

Select Build > Door > Pocket Door and click on a wall where you want to place a pocket door.

As with sliding doors, the initial opening side of a pocket door can be specified by moving the mouse pointer along the wall while the mouse button is still pressed.

By default, a pocket door becomes a double pocket door if its width is four feet (1200 mm) or greater.

Bifold Doors

Select Build > Door > Bifold Door and click on a wall where you want to place a bifold door.

Like a hinged door, the initial opening side of a bifold door depends on the location of the mouse pointer relative to the wall when you click. The door will open towards the side of the wall that you click nearest.

Similarly, the initial hinge side of a bifold door can be specified by moving the mouse pointer along the wall while the mouse button is still pressed.

By default, a bifold door becomes a double bifold if its width is greater than three feet (900 mm).

Garage Doors

Select Build > Door > Garage Door and click on a wall to place a garage door.

In plan view, dashed lines show the size and location of the garage door when open.

Garage doors will build into a garage stem wall provided the room is designated as a garage before the door is inserted. See “Room Types” on page 227.

Fixed Door

Select Build > Door > Fixed Door and click on a wall to place a fixed door.

Barn Door

Select Build > Door > Barn Door and click on a wall to place a surface mounted sliding door, sometimes referred to as a barn style door.

Shower Door

Select Build > Door > Shower Door and click on a wall to place a hinged glass slab shower door.

Place a Shower Door in a Straight Glass Wall. See “Wall Tools” on page 186.

The Doors & Doorways Library Catalog

The Doors & Doorways library catalog can be accessed by selecting View > Library Browser and browsing to Home Designer Core Catalogs > Architectural > Doors and Doorways. This catalog contains a variety of interior and exterior doors, as well as special entryways and wrapped openings.

Entryways and wrapped openings are examples of Doorways, which are wall openings that do not have doors within them.

To add a door to the Doorway, select a Door Type other than “Doorway” from the drop-down list in the Door Specification dialog. See “General Panel” on page 296.

You can also select a door from the library and place it into a doorway in plan view or any 3D view.
To place a library door in a doorway

1. Go to plan view or any 3D view.
2. Open the Library Browser.
3. Browse or search to find a door style that suits your needs.
4. Select the door in the Library Browser, then click on the doorway to place the selected door within it. If a door already exists, it is replaced.
5. Continue clicking other doorways as needed.

Displaying Doors

- The display of doors, door labels, opening indicators, header lines, and casing is controlled in the **Layer Display Options** dialog. See “Layer Display Options Dialog” on page 111.

Doors can only be placed in walls, so if a wall’s layer is turned off in plan view, any doors placed in that wall will not display, either. Doors can display independent of their containing walls in 3D views, however. See “Displaying Walls” on page 196.

If the “Doors” layer is turned off, doors and their casing do not display but openings in the walls where they are located are visible.

**In Plan Views**

A door’s jamb, casing, and swing are all represented in plan view. If a door is recessed, the affected wall layers will adjust to accommodate the casing.

A threshold line will display across a door opening in plan view when the door:
- Is located in an exterior wall. See “Exterior and Interior Walls” on page 189.
- Opens to an exterior room such as a Garage or Deck. See “Room Types” on page 227.
- Is located between rooms with different floor heights. See “Stepped Floor and Ceiling Platforms” on page 237.

Doorways display dashed lines that represent the wall surface between the doorway and the ceiling. Other types of doors do not display these wall surface lines, however, you can specify that any door display them or not in its specification dialog. See “Options Panel” on page 298.

If an exterior door to a Garage room on Floor 1 extends into a Garage stem wall or curb on Floor 0, its location will be indicated on Floor 0. You can control the display of this concrete cutout in the **Door Specification** dialog. See “Garages” on page 380.

When the “Opening Header Lines” layer is turned on in plan view, headers are represented by dashed lines within each door’s opening. These lines do not correspond to actual framing objects and cannot be selected. In addition, header framing members can be set to display. See “Wall Framing” on page 464.

The vertical casing on the sides of doors will display in plan view when the “Casings, Exterior” and “Casings, Interior” layers are turned on. See “Casing Panel” on page 299.

**In 3D Views**

You can specify whether a selected door is shown open or closed in 3D views by clicking the **Show Door Open in 3D** and **Show Door Closed in 3D** edit buttons as well as in the **Door Specification** dialog. See “Options Panel” on page 298.

If a door is set to display open in 3D, the angle of the open door can be changed using the edit handles in plan view. See “Using the Mouse” on page 291.

You can specify whether an exterior door has a threshold in the **Door Specification** dialog. See “Casing Panel” on page 299.

To display opening indicator arrows in Vector Views, turn on the “Opening Indicators” layer in the **Layer Display Options** dialog. See “Vector View” on page 595.
Editing Doors

Reverse door opening indicators on the Architectural panel of the Preferences dialog. See “Architectural Panel” on page 72.

You can also specify whether window and door glass is opaque or transparent in the Rendering Technique Options dialog. See “Rendering Technique Options” on page 596.

Door Labels

Door labels display in floor plan view, centered on the doors they represent, when the “Doors, Labels” layer is turned on and use the Text Style assigned to their layer. See “Object Labels” on page 285.

Door labels indicate Width and Height. For example:

• In Imperial plans, the automatic label for a 3'-0” wide, 6'-8” high double hung window will read 3068.
• In metric plans, the automatic label for a 900 mm wide, 2100 mm high double hung window will read 900x2100.

Customized labels can also be specified in the Door Specification dialog.

Editing Doors

Before a door can be edited, it must be selected. To select a door, click it when the Select Objects tool or any of the Door Tools are active. Doors and/or windows can also be group selected and edited. See “Selecting Objects” on page 123

Blocked units are made up of individual doors and windows that have been grouped together to act as one object. You can create what is essentially a blocked door unit by assigning a library door to a doorway from the library.

Select a blocked unit by clicking on it in any view. To select a door that is a component of a blocked unit, click at the location of the component in question, then click the Select Next Object edit button. See “Selecting Objects” on page 123.

In the Specification Dialog

The most precise method of editing a door or group of doors is to use the Door Specification dialog. Door type, size, casing, materials, shape, and more can all be specified in this dialog. See “Door Specification Dialog” on page 296.

Using the Mouse

In plan view, click either of the two end handles and drag along the wall to change the width. The label showing the size updates as the handles are dragged. Click and drag the Move handle at the center to move the door along the wall it is placed in. Use the triangular Rotate handle to adjust the door’s swing.

In 3D views, a selected door has five edit handles: the Move handle at the center and a Resize handle on each edge. Click and drag an edge handle to resize the door.

Using the edit handles, doors resize according to the currently active Edit Behavior. See “Defaults, Preferences, and Edit Behaviors” on page 119.

A door or window moved against an intersecting wall temporarily stops when the casing meets the intersecting wall. You can continue to drag and it resumes movement past the intersecting wall.

Using Dimensions

Like various other objects, doors can be moved using dimensions. See “Moving Objects Using Dimensions” on page 263.

You can specify how doors and windows are located by dimensions in the Dimension Defaults dialog. Dimensions can be set to locate the centers, sides, casing, and/or rough openings of doors and windows, or you can choose to not locate them at all. See “Locate Objects Panel” on page 252.
Once a dimension line has been drawn, you can move or add its extension lines to locate non-default locations on a door. See “Editing Extension Lines” on page 261.

Using the Edit Tools

A selected door or doors can be edited in a variety of ways using the buttons on the edit toolbar. See “The Edit Toolbar” on page 29.

- Click the Change Opening/Hinge Side edit button to change the side of the door that its hinges are on. See “Changing Door Swings” on page 293.
- Click the Change Swing Side edit button to change which direction the selected door swings.
- Click the Show Door Open in 3D or Show Door Closed in 3D edit button to control the selected door’s appearance in 3D views. See “In 3D Views” on page 290.
- Click the Gable Over Door/Window to create a gable over the selected door(s) the next time the roof is rebuilt. See “Gable/Roof Lines” on page 451.

Centering Doors

The Center Object edit button allows you to center a selected door along a wall within a room or relative to a cabinet or window. See “Using Center Object” on page 144.

To center a door along a wall

1. Select a door or combination of windows and doors in plan view.
2. Click the Center Object edit button then choose from one of the following options:
   - Click near a wall inside a room to center the door along that wall in that room.
   - Click outside the house (on the exterior room) near an exterior wall to center the door along an exterior wall.

Door Style and Panels

There are a number of Door Styles available for use, including Slab, basic Panel, and Louvered. In addition, a selection of door panel symbols is available in the Library. See “Placing Library Objects” on page 521.

By default, most door types are either single or double, depending on their width. You can specify how many panels a selected door has in the Door Specification dialog. See “Options Panel” on page 298.

Door Sides

Like walls, all doors have two sides: an interior side and an exterior side. This is the case even for doors placed in interior walls. See “Exterior and Interior Walls” on page 189.

By default, the interior side of the door will face the direction that the door swings to open. If you prefer, you can specify that the interior side face the opposite direction in the Door Specification dialog. See “General Panel” on page 296.

You can specify the materials for the two sides separately in the Door Specification dialog. See “Materials Panel” on page 306.

You can also specify different casing for the interior and exterior sides of exterior doors - that is, doors placed in exterior walls or walls defining a Garage or other exterior room type. See “Room Types” on page 227.

Door Casing

Doors typically feature casing, or trim, on both sides of the wall opening. See “Applying Moldings” on page 505.

- By default, interior doors use the same casing profile on both sides. You can specify that both sides be edited separately in the Door Specification dialog. See “General Panel” on page 296.
- Exterior doors can have different casing profiles on their interior and exterior sides.

The default casing for interior and exterior doors is a basic rectangular stock profile. You can specify a door’s casing profiles in the Door Specification dialog, or you can choose to suppress casing altogether. See “Casing Panel” on page 299.

A separate molding profile can be specified for the lintel, or top horizontal molding. See “Lintel Panel” on page 301.

Exterior and interior door casing will display in all views when the “Casings, Exterior” and “Casings, Interior” layers are turned on. In plan view, only the vertical side casing is shown.
Door Hardware

Handles, locks, and hinges can be assigned to a door in the Door Specification dialog. See “Hardware Panel” on page 303.

Changing Door Swings

Door swing direction and hinge side can be changed using the edit handles and the Change Opening/Hinge Side and Change Swing Side edit buttons.

Note: If the door is set to draw closed, the swing as it appears in plan view has no effect on the 3D view. See “Options Panel” on page 298.

The Change Opening/Hinge Side edit button is available for all doors except doors with multiple panels and garage doors.

The Change Swing Side edit button is available for all doors except pocket doors.

Hinged Doors

In addition to using the edit buttons, Hinged Doors and Shower Doors’ hinge side and swing direction can be changed using the triangular Rotate edit handle.

To adjust the angle of swing:

1. In plan view, select the door and grab the triangular handle.
2. Drag to change the amount of swing.
3. Release the mouse.

If you drag near the closed position, the door snaps to a closed position.

To change the swing using edit handles:

1. In plan view, select the door and grab the triangular edit handle.
2. Drag the pointer along the path of the new arc to change the hinge side and/or swing direction.
3. Release the mouse.

In 3D views, handles and locks can also be applied directly from the Library Browser. Select a hardware item in the library, then click on the door to apply it to that side of the door. See “Inserted Objects” on page 522.
Sliding Type Doors

Sliding, Pocket, Bifold, and Barn Doors are types of sliding door.

Similar to hinged doors, the Opening/Hinge and Swing sides of a Sliding, Pocket, Bifold, or Barn Door can be changed by clicking and dragging its diamond-shaped edit handle.

To change the side of a Sliding, Pocket, Bifold or Barn door that opens, select the door and click the Change Opening/Hinge Side edit button.

Note: For a Pocket Door to change Opening Side, there must be enough room for the entire door to fit in the wall on that side.

To flip the fixed and moving sides of the door, click the Change Swing Side edit button.

Garage Doors

To change the side of a garage door that it faces, select it and click the Change Swing Side edit button.

Unlike other door types, the Swing side of a garage door cannot be modified using the edit handles.

Special Doors

A variety of special doors and doorways can be created in Home Designer Pro.

Transoms Above Doors

Transom windows above doors are created the same as other stacked windows. See “Grouped Windows” on page 310.

Wrapped Openings

Wrapped openings of various shapes are available in the Doors & Doorways Library.

You can also create a wrapped opening by unchecking Use Interior Casing and/or Use Exterior Casing in a Doorway’s Door Specification dialog. See “Casing Panel” on page 299. If base molding is present, it will wrap around the opening.

Recessed Doors

A door placed in a brick or stone wall is often recessed into the wall’s exterior. In the illustration below, the door to the right is recessed, so the brick...
wraps the opening. The door on the left is not recessed, so the casing is outside the brick.

You can specify a door as recessed in the Door Specification dialog. See “Options Panel” on page 298.

Openings in Railings

Use the Doorway tool to open a railing for a stairway or other access.

To open a railing across an entire section, resize the doorway’s Width so that it is greater than the length of the railing in the Door Specification dialog. The opening resizes to the maximum width possible for that space. See “General Panel” on page 296.

To add a gate, specify the doorway’s Door Type as a Door, then choose an appropriate gate as the Door Style. A selection of gates is available in the Fences & Railings library folder. See “Placing Library Objects” on page 521.

Creating a Doorway with a Railing

When a railing is specified as No Room Def, it can be positioned within a Doorway.

To create a doorway with railing

1. Place a Doorway at the desired location in your plan.
2. Select Build> Railing and Deck> Straight Railing, then click and drag to draw a railing parallel to the wall with the doorway.
3. Select the railing, then use the Resize edit handles to adjust the length of the railing as needed. See “Using the Edit Handles” on page 126.
4. With the railing selected, click the Open Object edit button.
5. On the General panel of the Railing Specification dialog, check No Room Def and click OK. See “General Panel” on page 212.
6. With the railing still selected, Ctrl + drag it into position within the doorway. See “To move an object freely” on page 142.

Placing a Gable Over a Door

Click the Gable Over Door/Window edit button to produce a gable roof over the selected door(s) the next time automatic roofs are built. See “Gable/Roof Lines” on page 451.

You can manually edit or delete this gable line at any time. Your changes take effect when the automatic roofs are rebuilt. This can also be used with group selected doors.
Door Specification Dialog

To open the Interior or Exterior Door Specification dialog, select a door or group of doors and click the Open Object edit button or double-click on a door using the Select Objects or any Door tool.

Whether a selected door is Interior or Exterior depends on where it is placed. See “Interior vs Exterior Doors” on page 288.

The Lintel panel is also found in the Window Specification dialog. See “Window Specification Dialog” on page 315.

General Panel

1. **General** -

   - **Door Style** - Select Slab, Glass Slab, Panel, Glass Panel, Louvered, or Glass Louver from the drop-down list; select a style from the Library; or choose “Use Default” to use the default door style set in the Door Defaults dialog. See “Door Defaults” on page 287.
   - Specify the **Door Type** as Doorway, Hinged, Sliding, Pocket, Bifold, Garage, Fixed, Barn, or Shower. In the Door Defaults dialogs, the Door Type cannot be changed.
   - Specify the **Swing Angle** of the selected door in plan view, between 0° and 180°. An angle of 0° displays the door as closed and an angle of 180°...
displays it as wide open. The Swing Angle for Bifold doors and double doors that swing from the center can be no more than 90°.

The Swing Angle also affects the door’s appearance in 3D views if Draw Closed is unchecked on the OPTIONS panel.

Specify the Size and Position of the selected door.

- Specify the Width, Height, and Thickness of the door. These values do not include the jamb.
- Select the Elevation Reference from the drop-down list. This determines where the next two settings are measured from and also affects their labels.
- Specify the height to Top, measured from the selected Elevation Reference to the top of the door frame.
- Specify the height to Bottom, measured from the selected Elevation Reference to the bottom of the door frame.

The Sliding Doors settings are available for Slider, Pocket, and Barn Doors.

- Specify the Side and Top Overhang values, which control how much the selected door extends past its wall opening. Only available for Barn Doors.
- Specify the Offset from Wall, which is how far the selected door is offset from its default location. Slider and Pocket Doors are centered in the wall’s Main Layer by default, while Barn Doors are positioned against the wall surface.

Panel Frame Widths - Specify the dimensions of the selected door’s rails and stiles. Only available for Glass, Panel, and Louvered doors.

- Specify the Width of the stiles and top rail. Uncheck Uniform to specify separate values for the Left, Right, and Top of the frame, or leave it checked to use the same value for all three.
- Specify the height of the Bottom rail.

Louver -

- Specify the Size, or vertical height, of the selected door’s louvers. Only available for Louvered and Glass Louvered doors.
- By default, louvers face the direction that the door swings. Check Reverse Direction to reverse the direction that they face.

Options -

- Check Reverse Interior/Exterior to reverse the two sides of the selected door so that they face the opposite direction. Only available when a door symbol from the Library is specified as the Door Style. See “Door Sides” on page 292.
- Check Separate Trim and Materials for Each Side to specify the casing, lintels, and all materials for each side of the selected interior door independently. When unchecked, the two sides of the door use the same trim and materials. Only available when the selected door is placed in an interior wall. See “Exterior and Interior Walls” on page 189.

A preview of the door displays on the right side of the dialog box. A label indicates which side of the door is its Interior and which is its Exterior. See “Dialog Preview Panes” on page 32.
Specify the number of **Door Panels** or sections that the selected door has. See “Door Style and Panels” on page 292.

- Select **Single Door Only** to force the selected hinged, pocket or bifold door to be a single door, regardless of its width.
- Select **Double Door Only** to force the selected hinged, pocket or bifold door to be a double door, regardless of its width.
- Select **Calculate From Width** to use the program defaults. Hinged and pocket doors default to **Single Door** when less than four feet (1200 mm) wide; bifold doors do so when less than three feet (900 mm) wide. If the width is greater than this, **Double Door** is the default.

**Note:** The Calculate From Width defaults are not editable.

- For a selected Garage Door, specify the number of **Vertical Panels**.
- When **All Glass** is unchecked, only the third panel from the bottom the door is a glass panel: the rest are solid panels. Check this box to make all of the panels glass. The number and style of the lites and the Muntin Width can be specified on the **LITES** panel.

The **Plan Display** settings control the display of dashed wall surface lines above the door in plan view. See “In Plan Views” on page 290.

- Select **Automatic** to display wall surface lines only when the selected door is a Doorway.
- Select **Show Top Edge** to display wall surface lines regardless of the door type.
- Select **Hide Top Edge** to not show wall surface lines regardless of door type.

**3D Display** - Specify whether the selected door is shown open or closed in 3D and cross section/elevation views.

If **Show Open** is selected, the Swing Angle set on the General Panel is used.

**Door Swing** - Specify how the selected door swings. Most options here are only available when the selected Hinged or Pocket door is a Double Door. Not available for Bifold, Slider or Garage doors. See “Changing Door Swings” on page 293.

- Check **Both Doors Swing** to allow both sides of a Double Door to swing.
- Check **Left Swing Only** or **Right Swing Only** to allow only the left or right side of a Double Door to swing.
• Check **Swings from Center** to create a Double Door with hinges at the center rather than at the outside edges.

• Check **Swings Both Directions** to allow a door or both sides of a Double Door to swing both directions.

The **Recessed into Wall** options allow you to recess the selected door’s jamb into a wall, away from the exterior surface. This setting also affects the exterior casing and lintel, if used. Only available if the door is placed in a multi-layered wall. See “Wall Type Definitions” on page 208.

5 **Not Recessed**

6 **Recessed to Main Layer**

7 **Recessed to Sheathing Layer**

By default, interior and exterior casing is suppressed for doorways placed into railings: including solid railings and railing pony walls.

8 **Straight**

9 **Curved**

- Check **Recessed** to activate the settings that follow.
- Select **To Main Layer** to recess the door to the wall’s Main Layer.
- Select **To Sheathing Layer** to recess the door to the wall’s sheathing layer.

6 **In Curved Wall** - Specify whether a door placed in a curved wall is **Straight** or **Curved**. Curved is selected for Slider, Pocket, and Barn Doors and cannot be changed. See “Drawing Curved Walls” on page 195.

7 **Plinth Blocks** - Add an **Interior Plinth Block** and/or **Exterior Plinth Block** to the selected door. Plinth blocks do not display in 3D views, but are counted in the Materials List.

A preview of the door displays on the right side of the dialog box. See “Dialog Preview Panes” on page 32.

**Casing Panel**

By default, interior and exterior casing is suppressed for doorways placed into railings: including solid railings and railing pony walls.
Check **Use Interior Casing** to enable the settings that follow, then specify the interior casing for the selected door(s) using those settings. When this box is unchecked, no casing is used.

- **Casing Profile** - Click the Library button to select a molding profile for the casing. A preview of the casing profile displays to the right. See “Select Library Object Dialog” on page 522.
- Click the **Clear** button to remove a selected casing profile from the door.
- Specify the **Width** of the selected casing.
- Define the **Reveal**, which is the distance between the inside edge of the door frame and the inside edge of the casing.

Check **Use Exterior Casing** to enable the settings that follow, then specify the exterior casing for the selected door(s). These settings are the same as those for the Interior Casing, and are not available for doors in interior walls unless **Use Exterior Trim and Materials** is checked on the **GENERAL** panel. See “General Panel” on page 296.

Uncheck **Use Sill/Threshold** to prevent a sill from being generated under the door. See “Displaying Doors” on page 290.

The **Curved Wall Casing** settings are enabled if the selected door is located in a curved wall. See “Drawing Curved Walls” on page 195.

Door and window casing and jamb can be constructed three ways in curved walls:

- **Straight** - Both the door and casing are straight. This can be used where the wall’s curvature is not too sharp and the opening is not too wide. Not available for Sliding, Pocket, or Barn Doors.

- **Radial** - A vertical surface that would be perpendicular to a straight wall has its plane pass through the wall’s center of curvature.

- **Parallel** - A vertical surface that would be perpendicular to a straight wall remains parallel to the line from the wall center through the opening center.
Door Specification Dialog

A preview of the door displays on the right side of the dialog box. If casing is not specified for a Doorway, the Show Wall option will be toggled on automatically. See “Dialog Preview Panes” on page 32.

Lintel Panel

The settings on the LINTEL panel allow you to assign a lintel, or top molding that meets the side casing using a butt joint instead of a mitered joint. These settings are not available if the door has a reflected arch. See “Arch Panel” on page 302.

1. Check Use Interior Lintel to enable the settings that follow, then specify the lintel applied to the interior side of the selected door(s) using these settings. When this box is unchecked, no lintel is used.
   - Lintel Profile - Click the Library button to select a molding profile for the lintel. A preview of the selected profile displays to the right. See “Select Library Object Dialog” on page 522.
   - Click the Clear button to remove a selected lintel profile from the door.
   - Specify the Width of the lintel. This value is independent of the casing’s width; however, the lintel does inherit its depth from the casing.
   - Specify how far to Extend the lintel past the outside edges of the casing on each side.
   - Check Wrap to wrap the lintel profile back toward the wall.

2. Check Use Exterior Lintel to enable the settings that follow, then specify the exterior lintel for the selected door(s) using these settings. These settings are the same as those for the Interior Lintel, and are not available for doors in interior walls unless Use Exterior Trim and Materials is checked on the GENERAL panel. See “General Panel” on page 296.

3. A preview of the door displays on the right side of the dialog box. See “Dialog Preview Panes” on page 32.

Lites Panel

The settings on the LITES panel of the Door Specification dialogs are only available when the selected door is specified as a Glass door on the General Panel. These settings are also found on the
LITES panel of the Window Specification dialog. See “Lites Panel” on page 322.

Jamb Panel

The settings on the JAMB panel are similar to those on the FRAME panel of the Window Specification dialog. See “Frame Panel” on page 321. By default, Has Jamb is unchecked for doorways placed into railings: including solid railings and railing pony walls.

Check Has Jamb to enable the settings that follow, then specify the attributes of the selected door’s jamb using those settings. The jamb is not included in the door’s size, which is set on the General Panel.

• Specify the Sides Width, which is the thickness of the pieces of the door jamb that display in plan view. Changing this value does not affect the door’s size.

• Uncheck Fit Jamb to Wall to specify the Depth and Inset of the selected door’s jamb. When this box is checked, the jamb Depth automatically extends from the Recessed Into Wall layer to the wall’s inside surface with an Inset of 0”. The Recessed Into Wall layer is specified on the Options Panel of this dialog.

• Specify the Depth of the door jamb from front to back.

• Specify the jamb’s Inset, which is measured from the Recessed Into Wall layer and moves the door jamb towards its interior side. If used, the casing and lintel are not affected by this setting.

A preview of the door displays on the right side of the dialog box. See “Dialog Preview Panes” on page 32.

Arch Panel

The settings on the ARCH panel are also found in the Window Specification dialog.

The settings on this panel are not available if the selected door is a Sliding, Bifold or Garage door, or if the selected door has been assigned a lintel. See “Lintel Panel” on page 301.

The ARCH panel is not available for window symbols from the library, and its settings are not available if a selected window has been modified using the SHAPE panel. See “Shape Panel” on page 324.
Define the style and size of the Arch.

- Select a Type of arch from the drop-down list.
- Specify the Height of the arch, as measured from the base of the arch to the top of the door. Not available for Round Top and Octagonal Arches.
- The Radius can also be defined for Tudor and Double Arches.

Options - Define the orientation of the arch.
- Check Reflect to reflect the arch, top to bottom. This is typically used with windows rather than doors. Not available if a lintel is specified for the selected door. See “Lintel Panel” on page 301.
- Select Full Arch to produce an arch with the apex at the door’s center.
- Select Left Arch to produce an arch with the apex on the door’s right side.
- Select Right Arch to produce an arch with the apex on the door’s left side.

A preview of the door displays on the right side of the dialog box. See “Dialog Preview Panes” on page 32.

Hardware Panel

Many of the settings on the HARDWARE panel are Dynamic Defaults: if “Use Default” is selected, the setting in the Door Defaults dialog for the selected door’s Type is used. See “Dynamic Defaults” on page 58.
Specify the **Handles** to be used on the selected door.

- Select an **Interior Handle** and/or **Exterior Handle** from the drop-down lists. Select “Library” or click the Library button to select a handle from the library. See “Select Library Object Dialog” on page 522.
- Specify the location of the door handles **In From Door Edge**.
- Specify the location of the door handles **Up From Bottom**.

Specify the door’s interior and exterior **Locks**.

- Select an **Interior Lock** and/or **Exterior Lock** from the drop-down lists. Select “Library” or click the Library button to select a lock from the library.
- Specify the location of the door locks **Up From Bottom**. The locks use the same In From Door Edge value as the handles.

To use the same handle and lock on both sides of a door, select “Match Interior” as the Exterior option.

Specify the **Hinges** to be used on the selected door.

- Select a style of **Hinges** from the drop-down list. Select “Library” or click the Library button to select a hinges from the library.
- Specify the distance **In From Top/Bottom** of the door to the center of the top and bottom hinges.

Note: For hinges to look right, it is best to have at least a 1/4” (6 mm) reveal for the interior, or hinge side, door casing.

- Specify the **Number of Hinges** on the selected door. Interior hinged doors and bifold doors typically have two hinges while exterior hinged doors have three.

Specify the **Sliding Tracks** to be used on the selected Barn Door.

- Select a **Sliding Track** from the drop-down list. Select “Library” or click the Library button to select a track from the library. See “Select Library Object Dialog” on page 522.
- Specify the track’s **Height Above Door**.
• Select a style of **Hangers** from the drop-down list. Select “Library” or click the **Library** button to select a hanger from the library.

• Specify the distance **In From Sides** of the door to the center of the outermost hangers.

• Specify the number of **Hangers** to be evenly spaced along the door.

5 Check **Hardware on Fixed Section** to include handles, locks, and hinges on the fixed side of a double hinged door. Only available for Double Doors with Left or Right Swing Only selected. See “Options Panel” on page 298.

6 A preview of the door displays on the right side of the dialog box. See “Dialog Preview Panes” on page 32.

### Shutters Panel

The settings on the **SHUTTERS** panel of the **Door Specification** dialogs are also found on the Shutters panel of the **Window Specification** dialog. See “Shutters Panel” on page 305.

### Framing Panel

The settings on the **FRAMING** panel control how the selected door or doors is framed. A similar panel is also found in the **Window Specification** dialog. See “Window Specification Dialog” on page 315.

---

**Home Designer Pro** is dependent upon user input and does not calculate loads or perform structural analysis. Always consult your local building authorities and contact a licensed engineer for structural calculations.

---

1 Specify the characteristics of the selected door’s **Header**.

• Uncheck **Include Header** to prevent a structural header from generating when wall framing is created. When this box is checked, a header as defined below is generated; when it is unchecked, a single, non-structural, horizontal framing member of the same type as the wall studs is created above the door opening.

• Select the header’s framing member **Type** from the drop-down list. See “Structure Types” on page 486.
• When **Automatic** is checked, the program will confirm that the Type selected above agrees with the framing material used by the wall, and will generate a different header Type if it does not. The Type that will be generated is reported in parentheses for reference. When unchecked, the specified Type is used regardless of the wall’s structural material. See “Headers” on page 464.

• Specify the **Thickness** of each header framing member.

• Specify the **Count**, which is the number of the framing members used to create the header. Up to 10 headers can be specified, but only those that fit within the wall’s framing layer will be generated when wall framing is created.

• Specify the vertical **Depth** of the header. This value does not include the top and bottom chords of a Box Header.

• In the **Door** and **Window Defaults** dialogs, an additional **Calculate from Width** check box is available. When checked, the header Depth is automatically calculated based on settings in the **Framing Defaults** dialog and the door’s current width. See “Openings Panel” on page 473.

• Check **Box Header** to add horizontal top and bottom rails above and below the vertical rails. These horizontal boards are not included in the header Depth. See “Headers” on page 464.

  2 Specify the number of **Trimmers** to be generated on each side of the selected door.

  3 **Rough Opening** - Specify the amount to add to **Each Side**, the **Top** and the **Bottom** for the door’s framed rough opening. The rough opening should be large enough to accommodate the door frame and space for shims. Window frames do not need to be included in the rough opening: only shim space. If the Bottom Rough Opening value is greater than the Floor to Bottom value, the difference is added to the top of the rough opening when framing is built.

  4 **Add for Concrete Cutout** - Specify the amount to add to **Each Side** of the door opening when the upper part of the door is in a framed wall and the lower part is located in a concrete or masonry wall, stem wall, or garage curb. See “Wall Type Definitions” on page 208.

• Uncheck **Show in Plan** to suppress the display of the concrete cutout in plan views. A concrete cutout will only display in plan views if it is located in a garage curb. See “In Plan Views” on page 290.

  5 **Sill** - When the bottom of a door is raised sufficiently off the floor, it will require a sill as part of its framing.

• Specify the vertical **Thickness** of the sill.

• Check **Double Sill** to generate two sill members of the specified thickness instead of one.

### Materials Panel

The MATERIALS panel is available for a variety of objects throughout the program. For more information, see “Materials Panel” on page 542.

### Label Panel

Door labels display in plan view when the “Doors, Labels” is turned on and use the Text Style assigned to that layer. See “Door Labels” on page 291.

For information about the settings on this panel, see “Label Panel” on page 286.

### Components Panel

The information on the COMPONENTS panel can be used in the materials list. For more information, see “Components Panel” on page 692.

### Object Information Panel

The information entered on the OBJECT INFORMATION panel can be used in the materials list. For more information, see “Object Information Panel” on page 693.

### Manufacturer Panel

The MANUFACTURER panel provides contact information for the selected door’s manufacturer. Only available for doors from Manufacturer library catalogs. See “Manufacturer Catalogs” on page 514.
Home Designer Pro can model a wide variety of windows. Fixed glass, hung, casement, sliding, awning, hopper, and louver window styles can all be created with the standard Window tool. The shape of a window can be angled or made into a round top or other arch styles. Home Designer Pro can create bay, box, and bow windows with a single click. In addition, the library contains many mulled window combinations.

Chapter Contents

- Window Defaults
- Window Tools
- Special Windows
- Grouped Windows
- Window Levels
- Displaying Windows
- Editing Windows
- Window Specification Dialog
- Bay, Box, and Bow Windows
- Bay, Box, Bow Windows and Roofs
- Bay/Box and Bow Window Specification Dialogs

**Window Defaults**

Default Settings can be accessed by selecting `Edit > Default Settings`. Select Window from the Default Settings dialog and click the Edit button.

You can also double-click the Window Tools parent button to open the Window Defaults dialog.

The settings in the Window Defaults dialog control the attributes of a window when it is initially placed in a plan, so you should define the type of window that will be placed most often in your model. See “Default Settings” on page 57.

The panels in the Window Defaults dialog are similar to those found in the Window Specification dialog, with one exception:

On the General panel of the Window Defaults dialog, you can specify the Minimum Separation between window and/or door units in the plan.

The Minimum Separation value in the Window Defaults dialog specifies how close window and/or door units can be to each other. This setting also determines the width of the shared casing between windows.

For more information, see “Window Specification Dialog” on page 315.

**Dynamic Window Defaults**

A variety of window default values are dynamic, including the Window Type, Add for Rough Opening values, Casing, Lintel and Sill Specifications, Sash and Frame sizes, and Treatments. All Materials are also dynamic. When a dynamic default is changed, existing windows
using the default value are affected. See “Dynamic Defaults” on page 58.

Window Framing

The defaults for window framing can be defined in the Window Defaults dialogs. You can also specify an additional amount to cutout for window openings in concrete walls when the upper part of the window is located in a framed wall. See “Framing Panel” on page 328.

Window Tools

To place a window, select Build> Window and choose the desired Window Tool. Move your mouse pointer over a wall section, then click to place a window in the wall at that location.

- If there is room enough along the wall to fit a 6” (150 mm) wide Standard Window, a preview of the window will display and a window can be placed.
- The Bay, Box, and Bow Window tools do not have preview outlines. If a minimum width of 30” (725 mm) cannot be accommodated at the location where you click, a warning message will display and a window unit will not be created.

Standard Windows can be placed in both straight and curved walls, as well as span across straight, collinear wall segments. In contrast, a Bay, Box, or Bow Window can only be placed in a single, straight wall.

Windows cannot be placed in a wall specified as Invisible or if the wall in question is on a locked layer. See “Locking Layers” on page 111. See “Room Dividers and Invisible Walls” on page 191.

Standard Windows

Select Build> Window> Window, then click on a straight or curved wall to place a Standard Window at that location.

A Standard Window is a single window that is not a bay, box, bow window, a corner window or a blocked unit. These special types are made up of multiple Standard Windows.

A Standard Window that is part of a special window is called a Component Window.

Standard Windows can be specified as any of a variety of window types, such as double hung, casement and awning. See “Window Specification Dialog” on page 315.

Bay Windows

The roof is affected by Bay, Box and Bow Windows. These windows should therefore be placed before the roof is built.

A Bay Window is composed of three wall sections, each with a single component window. The two side walls are at an angle to the main wall. Select Build> Window> Bay Window and click on a straight wall to produce a bay window.

When initially placed, bay windows measure 2’-2” across at the front, 4’-2” across at the back, and are 1’-0” deep. The component windows are specified in the Window Defaults dialog and their sizes adjust to fit the available space.

Box Windows

A Box Window is a bay window with side angles set at 90°. Select Build> Window> Box Window and click on a straight wall to produce a box window.

Box windows initially measure 4’-2” wide with a depth of 1’-6”. The component windows are specified in the Window Defaults dialog and their sizes adjust to fit the available space.

Bow Windows

A Bow Window is a group of identical wall segments that form a segmented curve. Select Build> Window> Bow Window and click on a straight wall to produce a 5-section bow window.
Bow windows can be composed of between two and twenty sections. The number of bow window components can be changed in the **Bow Window Specification** dialog. See “Bay/Box and Bow Window Specification Dialogs” on page 331.

The component windows are specified in the **Window Defaults** dialog. Their sizes adjust to fit the available space.

The 5-section bow below has a 4'-10" radius centered 3'-9" inside the wall, giving an opening 5'-10" across and a depth of 11½".

Note that for a bow with an odd number of sections, the radial dimension is from the center of the arc to an outside corner where two window sections join. The depth (11 ½") is measured to the flat area of the center section, not to a corner. As a result, the radius is a bit greater than the sum of the depth and the distance from the center of the bow’s curve to the exterior of the wall.

### Special Windows

A variety of special windows can be created using multiple standard windows, the edit tools or custom symbols.

#### Creating Manual Bay, Box and Bow Windows

Sometimes it is easier to draw bay, box and bow windows manually than to use the automatic tools. Bays created using walls can have more than one window per section, which is not possible using a bay window unit.

Bear in mind that moving a manually created bay, box or bow window is generally more difficult than moving a unit created with one of the **Window Tools** since it is composed of individual walls.

#### Pass-Throughs

Select **Build> Window> Pass-Through**, then click on a straight or curved wall to place a Pass Through at that location.

A Pass-Through is simply a wall opening without a window unit placed inside. Like a window, it can have casing and a sill. It does not, however, have a sash, frame, or glass. It is one of the window Types available in the **Window Specification** dialog. See “General Panel” on page 316.

#### Wall Niches

Select **Build> Window> Wall Niche**, then click on a straight or curved wall to place a Wall Niche at that location.

A Wall Niche is a wall opening that does not extend through the entire depth of the wall. You can specify the niche’s depth in the **Window Specification** dialog. See “General Panel” on page 316.

#### Windows Library

Select **View> Library Browser**, then browse to Home Designer Core Catalogs-> Architectural-> Windows to access a selection of special window units. Select the desired window, then click on a wall to place the window at that location.

#### Corner Windows

To create a corner window, first create the desired window on each side of the corner. For best results, the heights, casing, and sills of both windows should be the same. For glass that meets at the corner:

- Specify both windows as **Fixed Glass**.
- Use each window’s Move edit handle to position it all the way in the corner. To do this, drag the Move handle past the corner and parallel to the wall that the window is placed in. When the preview outline moves into the middle of the wall corner, release the mouse button.
- You can also position a window in a corner using its end Resize handle.
- Uncheck **Has Corner Post** in the **Window Specification** dialog. See “Frame Panel” on page 321.
Angled top, or shaped windows can be components of corner windows as long as their heights are equal at the corners. Windows with single or two segment tops can be used, but windows with three cannot. If a two segment window is used, the segment nearest the corner must be flat.

When a corner post is required, there are a number of ways to control its size.

- Use dimensions to position the windows relative to the corner. By default, windows will stop when their interior casing bumps into the adjacent wall. See “Editing Windows” on page 314.
- To move a window all the way into a corner, check Ignore Casing for Opening Resize. See “General Plan Defaults Dialog” on page 59.
- To produce a minimal corner post and no siding or casing between the windows, use their Move edit handles. Click and drag each window past the exterior corner until its preview outline moves into the middle of the wall corner.

Special Window Shapes

A selection of special shaped windows is available in the Windows Library, including arched windows and mulled units.

In addition, you can create a wide variety of window shapes in the Window Specification dialog, including:

- Arched windows. See “Arch Panel” on page 325.
- Trapezoidal windows. See “Shape Panel” on page 324.

Recessed Windows

A window or mulled unit placed in a brick or stone wall is often recessed into the wall’s exterior, so the brick wraps the opening.

You can specify a window as recessed in the Window Specification dialog. See “Options Panel” on page 317.

Placing a Gable Over a Window

Click the Gable Over Door/Window edit button to produce a gable roof over the selected window(s) the next time automatic roofs are built. See “Gable/Roof Lines” on page 451.

You can manually edit or delete this gable line at any time. Your changes take effect when the automatic roofs are rebuilt. This tool can also be used with group selected windows.

Stained Glass

A selection of solid stained glass materials is available in the Home Designer Core Catalogs> Materials> Glass library. See “Materials” on page 539.

Vents

A selection of attic, foundation and gable vents are available in the Library Browser. See “The Library” on page 509.

Vents are placed in the same manner as regular windows and can be edited in much the same way, as well.

Grouped Windows

Windows can be grouped together to create a wide variety of custom configurations. Stacked windows are easy to create in 3D views, particularly cross section/elevation views, using their edit handles. See “Editing Windows” on page 314.
Notice how the windows and door in this example are separate, with spaces between them. Doors and/or windows can also be positioned so that there are no spaces between the windows and door units, and the casing between them appears to be shared. To help organize their display in plan view, you can place stacked windows of varying heights on different Window Levels. See “Window Levels” on page 312.

**Automatically Mulled Openings**

To form a mulled group of windows and/or doors, move them close enough together so that their casings touch. Once the casings touch, the windows are mulled together with one casing between the two of them.

The sill of each window in the group must be at the same level for them to share the middle casing. The casing tops do not have to be at the same level. The casings are modeled as if they are one unit but the windows remain separate objects for dimensioning and the Materials List.

Windows can be automatically mulled to doors if the bottom of the window is at the elevation of the floor, equal to the bottom of the door.

The Minimum Separation value in the Window Defaults dialog specifies how close window and door units can be to each other. This setting also controls the width of the shared casing between adjacent windows. See “Window Defaults” on page 307.

**Mulled Units in the Library**

A selection of mulled window units is available in the Windows library. To place one in your plan, select it and click on a wall in any view. See “Placing Library Objects” on page 521.

**Selecting Components of Mulled Units**

To select a component of a mulled unit from the library, click at the location of the component in question, then click the Select Next Object edit button or press the Tab key until that individual component is selected. Only the component clicked on is selectable using this method. If you need to select a different component, click on it and repeat the process.

The selected component may be on any window level in the mulled unit. If there are multiple levels, it is easiest to select the components in a 3D view. When you have selected an individual component, you can change its parameters in the Window Specification dialog. See “Window Specification Dialog” on page 315.

If the selected component is not itself a mulled unit and has no components above it, its Height and Arch parameters can be changed. Changing the Height causes the component top to move. The bottom remains stationary.

**Displaying Mulled Units**

As with other windows, the display of mulled window units is controlled in the Layer Display Options dialog. See “Layer Attributes” on page 110.

Mulled units are placed on the “Windows” layer by default and have a single label, which is on the “Windows, Labels” layer. Mulled units from the library are also included in the windows category of the Materials List. If the component objects of a mulled unit have unique moldings or materials, they will not be noted in the Materials List.

If a mulled unit includes a door, Treat as Door will be checked in the Mulled Unit Specification dialog. When this box is checked, the unit’s default layer is “Doors” and its label is placed on the “Doors, Labels” layer. Units set to Treat as Door are also included in the “Doors” category of the Materials List. See “Options Panel” on page 317.

You can, if you wish, display a mulled unit’s individual component labels instead of a single label for the unit. Labels are placed on the layers they would be on were the unit not mulled. A mulled unit’s label setting also affects how it is listed in the Materials List. See “Object Labels” on page 285.
• When **Suppress All Labels** is selected, individual components are counted in the Materials List.

• When **Show Component Labels** is selected, components are counted in the Materials List.

**Window Levels**

It is often necessary to position more than one window, mulled unit, and/or door at the same location along a wall in plan view: for example, to create an entry with side lites and transom.

To help control and organize the appearance of stacked wall openings in plan view, you can assign windows at various heights to different **Window Levels**.

**Window Levels** do not define the height of a window, just the appearance and behavior of windows and doors in plan view.

- In plan view, windows and doors on the **Default Level** display the line color and style of the layer they are on. See “Layers” on page 110.
- Windows on any other level appear light gray, regardless of the layer they are on.

**The Default Level**

The **Default Level** is the Window Level that Standard Windows are initially placed on when created and affects several things:

- In plan view, windows and doors on the **Default Level** display the line color and style of the layer they are on.
- When you click on stacked doors and windows in plan view, those on the Default Level are selected first. To select an opening on another level, use the **Select Next Object** edit button. See “Select Next Object” on page 124.

Typically, the Default Level is set as 0 (zero).

**Window Level Zero**

**Window Level 0** (zero) is the level that all bay, box and bow windows and doors are always placed on. Typically, it is also the Default Level that standard windows are placed on, as well.

Because doors are always on Level 0 and because Window Levels affect line colors in printouts, it is usually best to keep the Default Level at 0. If you do change the Default Level, remember to change it back before printing.

If you specify the Default Level as a value other than zero and then place a window in your plan, it will not use all Window Defaults settings. Instead:

- The program will position it above any windows that are at the same location but on a lower level rather than use the default Floor to Top height;
- Its Type will be Fixed Glass;
- Its Height will be 12” (300 mm);
- It will have no Sill.

Once the window is created, its parameters can be changed. See “Editing Windows” on page 314.

**Using Window Levels**

The door and windows in the illustration below were created on different Window Levels.

![Illustration of doors and windows on different levels]

**To stack windows using Window Levels**

1. Place the door and side lites on Window Level Zero.
2. Open the **Window Defaults** dialog and change the Default Level to 1.
3. Place the second row of windows above the door and side lites on Level Zero. The program will automatically position fixed glass windows above the door and side lites.
4. Edit these fixed glass windows’ Widths and other attributes as needed.
5. Open the **Window Defaults** dialog and change the Default Level to 2.
6. Place the top window above the others. The program will place a fixed glass window above the windows on Level 1.

7. Edit this window’s Arch and other attributes as needed.

8. When you are finished, open the Window Defaults dialog and change the Default Level back to 0.

Displaying Windows

The display of windows, window labels, openings, casing, and headers in floor plan and 3D views can be controlled in the Layer Display Options dialog. See “Layer Display Options Dialog” on page 111.

Windows can only be placed in walls, so if a wall’s layer is turned off in plan view, any windows placed in that wall will not display, either. Windows can display independent of their containing walls in 3D views, however. See “Displaying Walls” on page 196.

If the “Windows” layer is not set to display, window casing and other components are not visible, but the openings in the walls where they are located can still be seen.

In Plan View

A window’s frame, glass, casing, and sill are all represented in plan view. This makes some window types, notably Sliding and Double and Triple Casement windows, distinguishable.

Double Hung

Left Sliding

Triple Casement

Window types in plan view

Interior and exterior window casings will display in all views when the “Casings, Exterier” and “Casings, Interior” layers are turned on. In plan view, the sills and vertical side casings will be shown, but the horizontal top casing or lintel will not. If a window is recessed, the affected wall layers will adjust to accommodate the casing.

When the “Opening Header Lines” layer is turned on in plan view, headers are represented by dashed lines within each window. These lines do not correspond to actual framing objects and cannot be selected. In addition, header framing members can be set to display. See “Wall Framing” on page 196.

If a window is placed in a Garage room at a height where it extends into the stem wall or curb, a cutout in the concrete will display on the floor below. You can specify the cutout’s size and whether it displays in plan view in the Window Specification dialog. See “General Panel” on page 316.

By default, when a window is located entirely in one part of a pony wall, and that part is not displayed in plan view, the window’s outline is shown but the wall’s layer lines and fill drawn through it. You can instead display windows in the non-displayed parts of pony walls the same as in the displayed parts, or not at all. See “Pony Wall Defaults” on page 185.

Bay, box, and bow windows have dimensions lines associated with them.

- You can suppress their display by turning off the “Manual Dimensions” layer or on a unit by unit basis in the unit’s specification dialog. See “Bay/Box and Bow Window Specification Dialogs” on page 331.

- The arrow style and fill are set in the Dimension Defaults dialog. See “Dimension Defaults Dialog” on page 250.

In 3D Views

To show opening indicator arrows in Vector Views, turn on the “Opening Indicators” layer in the Layer Display Options dialog. See “Vector View” on page 595.
You can change the direction of indicator arrows in the Preferences dialog. See “Architectural Panel” on page 72.

You can also specify whether window and door glass is opaque or transparent in the Rendering Technique Options dialog. See “Rendering Technique Options” on page 596.

When displayed as opaque, window and door glass uses the Material Color set in the Define Material dialog. See “Pattern Panel” on page 550.

Window Labels

Window labels display in floor plan view, centered on the windows they represent, when the “Windows, Labels” layer is turned on and use the Text Style assigned to their layer. See “Object Labels” on page 285.

Window labels indicate Width and Height, followed by Type. For example:

- In Imperial plans, the automatic label for a 3'-0" wide, 4'-0" high double hung window will read 3040 DH.
- In metric plans, the automatic label for a 900 mm wide, 1200 mm high double hung window will read 900x1200 DH.

You can specify whether a Bay, Box or Bow Window displays a single label or displays the labels of its component windows.

- When Suppress All Labels is selected, individual components of Bay, Box and Bow Windows are counted in the Materials List.
- When Show Component Labels is selected, components of Bay, Box and Bow Windows are counted in the Materials List.
- When Show Single Label for Entire Unit is selected, the Bay, Box or Bow Windows has one label in plan view but each component is counted separately in the materials list.

These options are also available for mulled units but affect their display the materials list somewhat differently. See “Displaying Mulled Units” on page 311.

Customized labels can also be specified in the Window Specification dialog.

Wall Niches can also display labels when the “Wall Niches, Labels” layer is on. Unlike other windows, these objects’ Automatic Labels are blank; however, you can specify a custom label in their specification dialog.

Editing Windows

Before a window can be edited, it must be selected. Click on a window when the Select Objects tool or any of the Window Tools are active. Doors and/or windows can also be group-selected and edited. See “Selecting Objects” on page 123.

To select a window that is part of a blocked unit, click the component window, then click the Select Next Object edit button. See “Selecting Components of Mulled Units” on page 311.

Windows can be edited using their edit handles, the edit toolbar buttons, and the Window Specification dialog. See “Window Specification Dialog” on page 315.

When you select a window in plan view, the window size label displays the width followed by the height. For example, a 3036 window is 3'-0" wide by 3'-6" high.

In the Specification Dialog

The most precise method of editing an individual window or group of windows is to use the Window Specification dialog. The window type, size, casing, materials, shape, and more can all be specified in this dialog. See “Window Specification Dialog” on page 315.
Using the Mouse

In plan view, click either of the two end handles and drag along the wall to change the width. The label showing the size updates as the window is resized.

In 3D views, a selected window has five edit handles: the Move handle at the center and a Resize handle on each edge. Click and drag an edge handle to resize the window.

- Using the edit handles, a window resizes according to the currently active Edit Behavior. See “Defaults, Preferences, and Edit Behaviors” on page 119.

A single window or a group of windows can be moved with the center edit handle.

A door or window moved against an intersecting wall temporarily stops when it is the casing distance from the intersecting wall. Enable Ignore Casing for Opening Resize in the Plan Defaults dialog to turn off this behavior. See “General Plan Defaults Dialog” on page 59.

You can continue to drag the selected window and it will resume movement past or onto the intersecting wall.

To create a corner window, drag the Move handle straight out past the wall corner, parallel to the selected window’s wall. See “Corner Windows” on page 309.

Using Dimensions

Like various other objects, windows can be moved using dimensions. See “Moving Objects Using Dimensions” on page 263.

You can specify how windows and doors are located by dimensions in the Dimension Defaults dialog. Dimensions can be set to locate the centers, sides, casing, and/or rough openings of windows and doors, or you can choose to not locate them at all. See “Locate Objects Panel” on page 252.

Window Specification Dialog

To open the Window Specification dialog, select a window or a group of windows and click the Open Object edit button; or double-click the window using the Select Objects or a Window tool.

Once a dimension line has been drawn, you can move or add its extension lines to locate non-default locations on a window. See “Editing Extension Lines” on page 261.

Using the Edit Tools

A selected window or windows can be edited in a variety of ways using the buttons on the edit toolbar. See “The Edit Toolbar” on page 29.

- Click the Gable Over Door/Window edit button to create a gable over the selected window(s) the next time the roof is rebuilt. See “Gable/Roof Lines” on page 451.

- Click the Change Wall Side edit button to move the selected Wall Niche to the opposite side of the wall. See “Wall Niches” on page 309.

Window Casing, Sills, and Millwork

Windows often feature casing, or trim, on both sides of the wall opening as well as a sill on one or both sides. See “Applying Moldings” on page 505.

The default casing for windows is a basic rectangular stock profile. You can specify a window’s casing profiles in the Window Specification dialog, or you can choose to suppress casing altogether. See “Casing Panel” on page 318.

A separate molding profile can be specified for the lintel, or top horizontal molding. A sill profile can be specified, as well. See “Lintel Panel” on page 319.

Additional millwork items can be applied above and below the window’s casing on its exterior side. See “Treatments Panel” on page 325.

Each of these objects can be replaced with a different profile or object directly from the library in 3D views. Select a molding profile or millwork item, then click on the window component you want it to replace. See “Replace From Library” on page 523.

The settings in this dialog are similar to those in the Window Defaults dialog. See “Window Defaults” on page 307.

The settings in this dialog are also similar to those in the Wall Niche, Mulled Unit and Window Symbol Specification dialogs. Although similar, a number of the options cannot be edited when either a window
symbol or a mulled unit is selected, and some panels are not available. See “Grouped Windows” on page 310.

General Panel

In the **Wall Niche Specification** dialog, only the **Size and Position** settings on this panel are available. See “Wall Niches” on page 309.

![Window Specification dialog](image)

1. **Window Type** - Select the type of window from the list. The first entry in the list is the “Use Default”, which is set in the **Window Defaults** dialog.

2. Specify the **Size and Position** of the selected window.
   - Specify the window’s **Width** and **Height**. These values include the window frame.
   - Select the **Elevation Reference** from the drop-down list. This determines where the next two settings are measured from and also affects their setting labels.
   - Specify the height to **Top**, measured from the selected Elevation Reference to the top of the window frame.
   - Specify the height to **Bottom**, measured from the selected Elevation Reference to the bottom of the window frame.
   - Specify the **Depth** of the selected Wall Niche, measured from the wall surface to the back of the niche. Only available for Wall Niches.

3. The **Component Options** affect windows with movable sections and are not available for Pass-Throughs, Fixed glass windows, mulled units, or window symbols.
   - Specify the **Bottom Component Size** for Single Hung, Double Hung, Double Awning, Double Hopper, and Triple Hopper windows; specify the **Top/Bottom Component Size** for Triple Awning windows; or,
   - Specify the **Side Component Size** for Triple Casement and Triple Sliding windows, the **Right Component Size** for Left Sliding windows, or the **Left Component Size** for Right Sliding and Double Casement windows.

   **Note:** When either the Floor to Top or Floor to Bottom setting is modified, the other will adjust in response to prevent the window’s Height from changing.

   A **Component Size** value of 0 creates a window with identically sized components.
• Specify how each Component Opens from the available options. Only available for Casement, Double and Triple Awning, and Double and Triple Hopper windows.

4 The Interior Windows settings are only present when the selected window is a Pass-Through placed in an interior wall. See “Exterior and Interior Walls” on page 189.

• Check Separate Trim and Materials for Each Side to specify the casing, lintels, sills, and all materials for each side of the selected Pass-Through independently. When unchecked, the two sides use the same trim and materials.

5 Options -

• Louver Size - Specify the vertical height of the selected window’s louvers. Only available for Louvered and Glass Louver windows.

6 A preview of the selected window displays here. A label indicates which side of the window is its Interior and which is its Exterior. See “Dialog Preview Panes” on page 32.

Window opening directions can best be seen using the Vector View Rendering Technique.

Options Panel

The OPTIONS panel is not available in the Wall Niche Specification dialog.

The Mulled Units and Mullion Depth settings on the OPTIONS panel are only available in the Mulled Unit Specification dialog. See “Grouped Windows” on page 310.

1 Options -

• Check Interior Corner Block to count interior corner blocks in the materials list. These do not display in 3D views.

• Check Exterior Corner Block to count exterior corner blocks in the materials list. These do not display in 3D views.

• Check Egress to specify the window as an egress window in the Materials List. Not available for Pass-Throughs.

2 The Mulled Units options are only available when a mulled unit is selected.

Consult your local building and fire code authorities for your local egress window requirements.

• Check Reverse Symbol to reverse a window symbol as though it were reflected about a vertical line through its center. Only available in the Window Symbol Specification dialog.
• Check **Treat as Door** to include the unit in the “Doors” category of the Materials List. Only available when the selected unit contains a door. See “Displaying Mulled Units” on page 311.

• Uncheck **Single Wall Hole** to produce individually framed wall openings for each unit in a mulled unit. When this box is checked, a single wall opening with one header for the entire unit is produced.

   3 Specify the **Mullion Depth** for the casing between the components of a mulled unit, measured from wall surface. Positive values move the mullion surface towards the wall center; negative values, away from it. Only available when a mulled unit is selected.

• Specify the **Inside** depth of the mullion on the interior surface of the wall.

• Specify the **Outside** depth of the mullion on the exterior surface of the wall.

The **Recessed into Wall** options allow you to recess the selected window or mulled unit into a wall, away from the exterior surface. Only available if the window or mulled unit is in a multi-layered wall. Check **Recessed** to enable these options.

4 The **Recessed into Wall** options allow you to recess the selected window or mulled unit into a wall, away from the exterior surface. Only available if the window or mulled unit is in a multi-layered wall. Check **Recessed** to enable these options.

5 **Vertical Stacking** - Specify the window **Level** that the selected window is placed on. Not available for mulled units or window symbols. See “Window Levels” on page 312.

6 A preview of the selected window displays here. See “Dialog Preview Panes” on page 32.

### Casing Panel

The **CASING** panel is not available in the **Window Symbol Specification** dialog.
1. Check **Use Interior Casing** to enable the settings that follow, then specify the interior casing for the selected window(s) using those settings. When this box is unchecked, no casing is used.

- **Casing Profile** - Click the **Library** button to select a molding profile for the casing. A preview of the casing profile displays to the right. See “Select Library Object Dialog” on page 522.
- **Clear** button to remove a selected casing profile from the window.
- **Width** of the selected casing.
- Define the **Overlap Frame** value, which is the distance between the outside edge of the window frame and the inside edge of the casing. The default is 0”, which places the inside edge of the casing against the outside edge of the frame.

Type a positive value to overlap the casing over the frame by that amount.

Type a negative value to produce a gap between the casing and the frame.

To produce a reveal of a certain width, subtract the desired reveal from the total width of the frame and type the result here.

2. Check **Use Exterior Casing** to enable the settings that follow, then specify the exterior casing for the selected window(s) using those settings. These settings are the same as those for the Interior Casing. If the selected window is a Pass-Through placed in an interior wall, these settings will be unavailable unless **Separate Trim and Materials on Each Side** is checked on the GENERAL panel. See “General Panel” on page 316.

3. **Curved Wall Casing** - This section is enabled if the window is placed in a curved wall. See “Drawing Curved Walls” on page 195.

Door and window casing and jamb can be constructed three ways in curved walls:

- **Straight** - Both window sash and casing are straight. Straight casing may not fit properly into a wall if the window is too wide or the curvature of the wall, too tight.

![Straight](image)

- **Radial** - The sides of the casing or jambs are inserted in the wall at an angle that passes through the center of the curve.

![Radial](image)

- **Parallel** - The sides of the casing are inserted in the wall at a right angle to the line tangent to the curved wall at the center of the window.

![Parallel](image)

Normally, parallel casing has a straight sash. Radial casing is more like traditional curved windows, and typically has a curved sash.

4. A preview of the selected window displays here. You may need to rotate the preview to see the casing on the side of the door you are editing. If casing is not specified for a Pass-Through, the Show Wall option will be toggled on automatically. See “Dialog Preview Panes” on page 32.

### Lintel Panel

The settings on the LINTEL panel of the **Window and Mulled Unit Specification** dialogs are also found on the panel of the same name in the **Door Specification** dialog. See “Lintel Panel” on page 301.

The **Lintel** panel is not available in the **Window Symbol Specification** dialog.

These settings are not available if the window has a reflected arch. See “Arch Panel” on page 325.

### Sill Panel

The settings on the SILL panel of the **Window and Mulled Unit Specification** dialogs are not available if the window has a reflected arch. See “Arch Panel” on page 325.
The SILL panel is not available in the **Window Symbol Specification** dialog.

1. Check **Use Interior Sill** to enable the settings that follow, then specify the sill applied to the interior side of the selected window(s) using these settings. When this box is unchecked, no interior sill is used.

   - **Sill Profile** - Click the **Library** button to select a molding profile for the sill. A preview of the selected profile displays to the right. See “Select Library Object Dialog” on page 522.
   - Click the **Clear** button to remove the selected sill profile from the window. When no library profile is selected, a basic rectangular profile is used.
   - Specify how far to **Extend** the sill past the outside edges of the casing on each side. If an Apron is specified, it will also be affected by this setting.
   - Specify how far to **Inset** the sill into the window. A value of 0 positions the sill profile against the surface of the wall. Only available when a sill profile from the library is selected.
   - Check **Wrap** to wrap the sill profile back toward the wall.
   - Check **Apron** to include an apron under the sill. When Wrap is checked, the apron will be 1/2” (12 mm) shorter than the sill on each side; when it is unchecked, it will be the same length as the sill.

2. Check **Use Exterior Sill** to enable the settings that follow, then specify the exterior sill for the selected window(s) using these settings. These settings are the same as those for the Interior Sill.

   A preview of the selected window displays here. See “Dialog Preview Panes” on page 32.

### Sash Panel

The settings on the SASH panel control the size and position of the selected window’s sash. Note that increasing the Side, Middle, Top or Bottom Width decreases the area of the glass and vice versa.

The **SASH panel is not available in the Wall Niche, Mulled Unit, and Window Symbol Specification dialogs, and the settings on this panel are not available for Pass-Throughs.**
Specify the width and depth of the selected window’s Sash, which are the pieces of the window that hold the glass; or, uncheck this box to prevent it from having a sash.

- Specify the Side Width of all vertical sash members: those at the window sides as well as the central members of Casement and Sliding windows. This is also the width of the top portion of the window when an arch is specified.
- Specify the Middle width of horizontal components between the top and bottom sash in Double Hung, Double and Triple Awning, and Double and Triple Hopper windows. It does not affect Casement and Sliding windows.
- Specify the Top and Bottom Widths. The Top value is not used if the window has an arch.
- Specify the Depth, or thickness, of the sash stock measured from the exterior to the interior.
- Specify the Inset, the distance between the frame and the outermost sash. If there is no frame, the inset is measured from the outer surface of the wall’s Main Layer.

- **Curved Options** - When the selected window is placed in a curved wall, specify whether it has a curved or straight sash. A curved sash is typically used with Radial casing. See “Casing Panel” on page 318.

A preview of the selected window displays here. See “Dialog Preview Panes” on page 32.

### Frame Panel

The FRAME panel is not available for mulled units or window symbols from the library.

The settings on the FRAME panel are similar to those on the JAMB panel of the Door Specification dialog. See “Jamb Panel” on page 302.
Specify the attributes of the selected window’s Frame. Note that a window’s frame is included in its size, while a door’s jamb is not.

- Check **Has Frame** to include a frame and enable the settings below. When this is unchecked, the selected window has no frame around it.
- Specify the **Side**, **Top**, and **Bottom Widths** of the window’s frame. Changing these values modifies the interior of a window but does not affect its size.
- Uncheck **Fit Frame to Wall** to specify the Depth and Inset of the selected window’s frame. When this box is checked, the frame Depth automatically extends from the Recessed Into Wall layer to the wall’s inside surface with an Inset of 0". The Recessed Into Wall layer is specified on the Options Panel of this dialog.
  - Specify the **Depth** of the window frame from front to back.
  - Specify the frame’s **Inset**, which is measured from the Recessed Into Wall layer and moves the window frame towards its interior side. If used, the casing and lintel are not affected by this setting.
- **Has Corner Post** is only available when the selected Fixed glass window is one of a pair forming a corner window. See “Corner Windows” on page 309.

A preview of the selected window displays here. See “Dialog Preview Panes” on page 32.

### Lites Panel

The LITES panel allows you to add muntins to windows, and is also available for Glass doors. See “Doors” on page 287.

There are four possible styles of muntin bars for regular windows, plus two additional options for arched windows.

A window that has been modified using the SHAPE panel cannot have divided lites or shutters added.

The LITES panel is not available in the Wall Niche, Mulled Unit, and Window Symbol Specification dialogs, and the settings on this panel are not available for Pass-Throughs.
1 Specify the number, position and style of Lites for the selected window.
   • Select a Type, or style, of window lite from the drop-down list.
   - Normal style is the most common, with muntins going horizontally and vertically. Colonial windows are an example of the normal style.
   - Diamond style uses angled muntin bars to divide up the lites. French windows are an example of the diamond style.
   - Prairie style is based on the normal style, but with all the central muntin bars removed, leaving only the two outside muntin bars both horizontally and vertically. Typically, both Lites Across and Lites Vertical should be set between 6 and 8. Federal or Federation windows are an example of the Prairie style.
   - Craftsman style is based on the normal style, but only the topmost horizontal muntin bar is kept with all the portions of the vertical muntin bars above it. Typically, both Lites Across and Lites Vertical should be set between 4 and 8.
   - Enter the number of horizontal Lites Across in each sash.
   - Enter the number of vertical Lites Vertical in each sash.
   - Specify the Muntin Width, which is the width of the bars dividing the panes of glass.
   - Check or uncheck Lites in Top and/or Lites in Bottom - or Lites in Left and/or Lites in Right - to specify either one or both of the sashes to have divided lites.
   - Check Muntin in Corner to add a vertical muntin bar where two corner windows meet. Only available when Has Corner Post is unchecked on the FRAME panel. See “Corner Windows” on page 309.
   - Check Auto Adjust Lites for Component Size to have the program produce lites that are consistent in size across all components. When this is checked, the window’s lites and its specification settings may not agree; when unchecked, lites in the components may not be consistent in size.
   Note: Because the fixed window in a Triple Sliding window is twice the size of the movable windows, the fixed section has a vertical muntin bar. To eliminate this, uncheck Auto Adjust Lites for Component Size.
2 The Arch Options are only available if the window has an Arch specified.
   - Specify a Ray Count of up to 10 radial muntin bars in the portion of the window within the arch. There is one more pane of glass than the number of rays specified. See “Arch Panel” on page 325.
   - Check Concentric to produce muntins radiating from a curved inner muntin that is concentric with the window’s arch. You must have at least three Lites Across for this to be used.
A preview of the selected window displays here. See “Dialog Preview Panes” on page 32.

**Shape Panel**

The settings on the **SHAPE panel** control the position of the selected window’s corners, allowing you to create angled edges and mitered top corners.

If any of these settings are used to create a custom shape, the selected window will be automatically specified as “Fixed Glass” on the **GENERAL panel**. If the selected window has an arch specified on the **ARCH panel**, it will be removed.

The **SHAPE panel** is not available for mull units or window symbols from the library.

---

**Window Width** displays for reference. It can be changed on the **General Panel**.

- **Click Match Roof** to match the angle of the top of the window to the pitch of the roof above by changing its Sides heights, below. If either Top Inside Corner box is checked, it will become unchecked.

  Match Roof does not work for curved roofs, has no effect if the window is not in a gable end wall, and is not available in the Window Defaults dialog.

- **Click Revert All** to restore the window to its original shape, type and arch settings.

---

1. Specify the height of the window’s **Left** and **Right Sides**, as measured from the bottom of the window. By default, these settings match the window’s Height.

2. The **Top Inside Corners** settings allow you to create a second set of top corners with angled edges between them and the outside top corners.

   - **Check Left** to add an additional corner along the top edge.
   - **Specify the Height** of the left inner corner, as seen from the exterior, measured from the bottom of the window.
Window Specification Dialog

- Specify the **Offset** of the left inner corner, as measured from the left side of the window.
- An additional **Right** Inside Corner can be specified in a similar manner.

**The Bottom Corners** settings allow you to raise the heights of the bottom corners, as measured from the bottom of the window specified on the General Panel.
- Check **Left** to raise the height of the bottom left corner.
- Specify the **Height** of the bottom left corner. This value cannot exceed the Height of the Left Side.

The height of the **Bottom Right** corner can be raised in a similar manner.

A preview of the selected window displays here. You may want to rotate the view so the window’s exterior can be seen. See “Dialog Preview Panes” on page 32.

Arch Panel

The settings on the ARCH panel of the Window and Mulled Unit Specification dialogs are also found on the panel of the same name in the Door Specification dialog. See “Arch Panel” on page 302.

The settings on this panel of the Mulled Unit Specification dialog define the overall shape of the blocked unit’s top. If the mulled unit already includes a component window with an arch, these settings cannot be modified.

The ARCH panel is not available for window symbols from the library, and its settings are not available if the selected window has been modified using the SHAPE panel.

Treatments Panel

The settings on the TREATMENTS panel allow you to add embellishments to the interior and exterior of the selected window or mulled unit.

The TREATMENTS panel is not available in the Wall Niche and Window Symbol Specification dialogs.
Specify **Curtains** for the selected window or mulled unit’s interior side.

- Specify a style of **Curtains** by selecting “Use Default”, “None” or “Library” from the drop-down list. If a non-default library item has been selected, its name will display in the list, as well.
- Click the **Library** button or select “Library” from the drop-down list to choose a style of curtain from the library. See “Select Library Object Dialog” on page 522.

- Specify the **Height Off Floor** of the bottom edge of the curtains.
- Specify the **Height Above Casing** of the top of curtains.

The settings on the SHUTTERS panel allow you to specify exterior shutters for the selected window or mulled unit from the library.

**Shutters Panel**

The SHUTTERS panel is not available in the **Wall Niche** and **Window Symbol Specification** dialogs.
Select a **Type** of Shutters from the drop-down list or click the **Library** button to select a style of shutters from the Library Browser. See “Select Library Object Dialog” on page 522.

Specify the **Size** of the selected shutters.
- When **Match Opening Width** is checked, each shutter’s width is exactly half that of the window, excluding casing.
- Uncheck **Match Opening Width** to specify a **Width** in the text field. If the window is later resized, the shutters will not adjust in response.
- When **Match Opening Height** is checked, each shutter’s height equals that of the window, excluding casing.
- Uncheck **Match Opening Height** to specify a **Height** in the text field. If the window is later resized, the shutters will not adjust in response.

Specify the **Position** of the shutters relative to the window.
- Select **On Casing** to position the shutters just outside the window frame, like functional shutters.
- Select **Outside Casing** to position shutters outside the window casing, as decorative shutters often are.

Additional shutter **Options** can be specified here.
- Check **Reverse Direction** to orient the shutters so their exterior sides face outward and their interior sides face the wall. For functional shutters, this should remain unchecked.
- Check **No Arch** for shutters with flat tops that reach the bottom of the curved portion of an arched window. Only available when an Arch is selected. See “Arch Panel” on page 325.

**Shutter Sides** - Specify which sides of the selected window receive shutters.
- Select **Automatic** to assign shutters to both sides of the window as long as there is sufficient room on the wall. If the window is next to a wall intersection or corner, the shutter closest to the intersection will not generate.
- Select **Left Side Only** to assign a shutter to the left side of the window and none on the right.
- Select **Both Sides** to assign shutters to both sides of the window under all circumstances, even if
there isn’t enough room on the wall for one or both of them.

- Select **Right Side Only** to assign a shutter to the right side of the window and none on the left.

A preview of the selected window displays on the right. In order to see the shutters, you may need to rotate the preview to show the Exterior. See “Dialog Preview Panes” on page 32.

**Framing Panel**

The settings on the FRAMING panel are also found on the panel of the same name in the **Door Specification** dialog. See “Framing Panel” on page 305.

**Materials Panel**

The settings on the MATERIALS panel are the same as those found on the same panel in dialogs throughout the program. See “Materials Panel” on page 542.

The settings on the MATERIALS panel of the **Mulled Unit Specification** dialog apply to all components of the blocked unit. Any settings made for individual components of the blocked unit are overridden here.

**Label Panel**

Window labels display in plan view when the “Windows, Labels” layer is turned on and use the Text Style assigned to that layer. See “Window Labels” on page 314.

Similarly, Wall Niche labels display in plan view when the “Wall Niches, Labels” layer is turned on and use the Text Style assigned to that layer. See “Window Labels” on page 314.

For more information about the settings on this panel. See “Label Panel” on page 286.

**Components Panel**

The information on the COMPONENTS panel can be used in the materials list. For more information, see “Components Panel” on page 692.

**Object Information Panel**

The information entered on the OBJECT INFORMATION panel can be used in the materials list. For more information, see “Object Information Panel” on page 693.

**Manufacturer Panel**

The **MANUFACTURER** panel provides contact information for the selected window’s manufacturer. Only available for windows from Manufacturer library catalogs. See “Manufacturer Catalogs” on page 514.

**Bay, Box, and Bow Windows**

Bay, Box and Bow Windows are created much the way regular windows are: select a tool, then click a wall to place that window type.

Home Designer Pro automatically builds a foundation under bay/box/bow windows placed on floor 1 unless they are raised from their original position. That section of the foundation wall is also a bay/box/bow, but without windows. If the foundation was generated before the window is placed, the foundation must be rebuilt or edited manually.

**Editing Bay, Box and Bow Windows**

Bay, box, and bow windows are edited similar to regular windows with one exception: in plan view, a diamond-shaped Depth edit handle displays on the section. Drag this Depth handle outward to increase the depth, or inward to decrease the depth of the unit. See “Editing Windows” on page 314.

Bay, box and bow windows can also be edited in their respective specification dialogs. See “Bay/Box and Bow Window Specification Dialogs” on page 331.

**Displaying Bay, Box and Bow Windows**

The display of bay, box and bow windows is controlled in the **Layer Display Options** dialog. See “Layer Display Options Dialog” on page 111.
Like other windows, bay, box and bow windows can display labels: either a single label for the unit, or one for each component. See “Window Labels” on page 314.

Bay, box and bow window width and radius dimensions, which display in plan view when specified to do so in the window’s specification dialog, are placed on the “Dimensions, Manual” layer. See “Options Panel” on page 332.

Component Windows

A component window within a bay, box or bow window can be resized like any other standard window. To select a component window, click at the location of the component in question, then click the Select Next Object edit button or press the Tab key.

- Only the bay or box window component that was clicked on is selected using this method. If you need to select a different component, click on it and repeat the process.
- In a bow window, all components are identical, so only one component can be selected. Changing this component changes them all.

Resizing Components

An individual component window can be resized using the edit handles, by changing settings in the component’s Window Specification dialog, or by using the Transform/Replicate Object dialog. See “Transform/Replicate Object Dialog” on page 151.

When a bay/box/bow window is first created, there is room for one standard trimmer on each side of each component window. When the bay as a whole is moved and resized, its components automatically resize so that a standard trimmer is still accommodated.

If you increase a component window’s width to the point where there is not enough room for standard trimmers, a thinner trimmer can be used. The size of this thinner trimmer is specified in the Build Framing dialog. See “Openings Panel” on page 473.

If a component window is resized, it retains its size if at all possible when the containing bay/box/bow window is moved or resized. If the bay is resized in such a way that the component is too large to fit even with a thinner trimmer, the component resumes its default behavior, resizing as the containing bay window is resized.

Floors and Ceilings

When originally created, the floor and ceiling within a bay, box, or bow window are the same heights as the floor and ceiling of the room in which it is placed.

Both the top and bottom heights of these window units can be adjusted in its specification dialog or a 3D view using its edit handles to create a lowered ceiling and/or a bench seat or garden window.

When the ceiling is lowered, the top heights of the walls that define the window unit are also lowered. When a roof is built over the unit, its height will be affected, as well.

When the bottom of the window is raised to create a bench seat, the unit’s walls will not reach the ground. As a result, window units with bench seats will have no foundation beneath them when the foundation is built.
Bay, Box, Bow Windows and Roofs

Several different roof styles can be specified for bay, box and bow window units in the Bay/Box and Bow Specification dialogs. See “General Panel” on page 331.

If you change a bay, box, or bow window’s roof specification, you will need to rebuild the roofs to see the changes. See “Rebuilding Roofs” on page 431.

Hip Roofs

By default, a hip roof is built above the unit when roofs are automatically generated. No roof directives need to be selected in the specification dialog to produce this roof.

For this roof style, the ceiling heights of the window unit and the adjacent room must be the same. If you lower the ceiling of the window unit and then build the roof, a lower hip roof over the window is created. See “Floors and Ceilings” on page 329.

If a header is desired over the window unit, first build the roof, then lower the ceiling of the window unit. Once the ceiling is lowered, select Rebuild Walls/Floors/Ceilings. Do not rebuild roof planes.

Rectangular Hip Roofs

To create a rectangular-shaped hip roof above a bay, box, or bow window, select Rectangular Roof Over.

Extend Existing Roof - Rectangular

To extend the main roof down over a window unit to create a rectangular roof over it rather than one that follows its shape, select both Extend Existing Roof over and Rectangular Roof Over.
Gable Roof

A gable roof is not one of the automatic options for the roof above a bay, box or bow window. A gable can be created by manually editing the rectangular hip roofs that are automatically created. See “Roof Planes” on page 436.

To create a gable over a bay window

1. Select the front ridge corner handle of each side hip roof plane and drag the edge forward until the fascia snaps to the edge of the front hip section.
2. Delete the front hip section.
3. Adjust the roof’s overhang as needed.

Bay/Box and Bow Window Specification Dialogs

To open the Bay/Box Window Specification or the Bow Window Specification dialog, select one or more Bay/Box or Bow Windows and click the Open Object edit button.

The options in this dialog can only be set for objects placed in a plan: Bay, Box, and Bow Windows do not have defaults dialogs.

The settings that are available in these dialogs depend on whether the selected object is a Bay, Box, or Bow Window.

General Panel

1. **Sections** - The setting that displays here depends on whether the selected window is a Bay, Box, or Bow Window.
   - Specify the **Bay Angle**, which is the angle of the side components of a Bay or Box Window. Bay Windows have an angle of 45° by default; Box Windows have an angle of 90°.
   - Specify the **Quantity**, which is number of component windows in a Bow Window.
2 Size - Specify the Width and Depth of the selected Bay, Box, or Bow Window.

Specify the Wall Type used by the walls embedded in the selected Bay, Box, or Bow Window. See “Wall Type Definitions” on page 208.

- Select “Use Main Wall Type” from the drop-down list to use the same wall type as that of the wall that the window unit is placed in. If the main wall is a Pony Wall, both wall types are used.
- Select a specific wall type from the drop-down list to use it instead of the Main Wall Type.
- When a specific wall type is selected, click the Define button to modify its definition. See “Wall Type Definitions Dialog” on page 210.

4 Specify the height and structure of the Ceiling within the selected window.

- Check Has Lowered Ceiling to enable the settings that follow. When this is unchecked, the ceiling height and finish material within the window is the same as that for the adjacent room.
- Specify the Height Lowered, which is measured from the ceiling height of the adjacent room.
- Specify the Finish Thickness, which is the thickness of the ceiling’s finish material.
- Specify the Structure Thickness, which is the thickness of the ceiling’s structural layer.

Note: If the Height Lowered is 0”, Has Lowered Ceiling will become unchecked when you click OK.

5 Specify the height and structure of the Floor within the selected window.

- Check Has Raised Floor to enable the settings that follow. When this is unchecked, the floor height and material within the window is the same as that for the adjacent room.
- Specify the Height Raised, which is the measured from the floor height of the adjacent room.
- Specify the Finish Thickness, which is the thickness of the floor’s finish material.
- Specify the Structure Thickness, which is the thickness of the floor’s structural layer.

Note: If the Height Raised is 0”, Has Raised Floor will become unchecked when you click OK.

Options Panel

1 Specify the structure of the automatic Roof over the selected window unit. See “Bay, Box, Bow Windows and Roofs” on page 330.

- Check Use Existing Roof if the existing roof needs no changes to accommodate the bay window.
- Check Extend Existing Roof Over to extend the existing roof plane to cover the bay window below.
- Check Rectangular Roof Over to create a roof over the bay window that is square across the end instead of following the profile of the roof.
Specify the appearance of the selected window unit’s **Dimensions** in plan view.

- Check **Display Standard Dimension** to display the automatically-produced dimensions that show the window’s width and depth.
- Check **Display Dimensions to Center** to display a Bow Window’s radial dimension.

Specify the structure of the selected window unit’s **Components** and the wall sections containing them.

- Uncheck **Has Component Windows** to remove the component windows of the selected Bay, Box, or Bow Window and disable the settings that follow.
- Check **No Framing Between Components** to eliminate the trimmer studs for Bay and Box Window components, allowing the width of each component window to increase. See “Wall Framing” on page 464.
- Check **No Framing Between Components** to remove both studs between the component windows.

Note: If the selected unit is moved or resized, its components automatically resize to use a standard trimmer, regardless of whether either of the two options above are selected.

- Check **Connect Outer Casing** to have exterior casing surround the component windows of a Bow Window as a group rather than individually. Mullions are provided between components. This is how interior casing is always created.
- Check **Components Recessed** to recess the component windows into the wall and enable the settings that follow. Typically used if the window is placed in a brick wall and you want to produce a brick molding.
- Select **To Main Layer** to recess the components to the wall’s Main Layer instead of the exterior wall surface. See “The Main Layer” on page 209.
- Select **To Sheathing Layer** to recess the components to the sheathing layer instead of the exterior wall surface.

### Materials Panel

The settings on the MATERIALS panel are the same as those found on the same panel in dialogs throughout the program. See “Materials Panel” on page 542.

### Label Panel

Bay, Box, and Bow Window labels display in plan view when the “Windows, Labels” layer is turned on and use the Text Style assigned to that layer. See “Window Labels” on page 314.

For more information about the settings on this panel. See “Label Panel” on page 286.

### Components Panel

The information on the COMPONENTS panel can be used in the materials list. See “Components Panel” on page 692.

### Object Information Panel

The information entered on the OBJECT INFORMATION panel can be used the materials list. See “Object Information Panel” on page 693.
With Home Designer Pro’s cabinet tools you can create base, wall, and full height cabinets as well as soffits, shelves, partitions, and custom countertops. These objects are very versatile, allowing for a wide range of customization.

A selection of cabinet door and drawer styles are available in the Library Browser.

Home Designer Pro also has many customized cabinets and cabinet groups available in the library.

Cabinet Defaults

There are several defaults dialogs for cabinets. Access Default Settings by selecting Edit> Default Settings, then clicking the arrow beside “Cabinets”. Select a subheading and click the Edit button to open the defaults dialog associated with your selection.

The Cabinet Defaults dialogs can also be accessed by double-clicking the Cabinet Tools parent button.

Chapter Contents

• Cabinet Defaults
• The Cabinet Tools
• Cabinet Fillers
• Placing Cabinets
• Countertops
• Custom Backsplashes
• Displaying Cabinets
• Cabinet Labels
• Editing Cabinets
• Editing Cabinet Styles
• Special Cabinets
• Cabinet Specification Dialog
• Cabinet Shelf Specification Dialog
• Shelf/Partition Specification Dialog
• Custom Countertop Specification Dialog
• Custom Backsplash Specification Dialog

Double-clicking a Cabinet Tools child button also opens its corresponding defaults dialog, if that object has a defaults dialog.
Each type of cabinet object has default definitions for size, style, materials and much more. In fact, the default dialog for each cabinet type is similar to its corresponding specification dialog. For descriptions of these settings, see “Cabinet Specification Dialog” on page 348, “Shelf/Partition Specification Dialog” on page 358 and “Soffit Specification Dialog” on page 535.

Custom Countertops do not have defaults dialogs. Instead, their initial settings are based on the those of other objects.

• Custom Countertops' initial settings are based on Base Cabinet Default settings but are also influenced by the settings of cabinets beneath them. See “Custom Countertops” on page 337.

Dynamic Cabinet Defaults

When a dynamic default is changed, existing cabinet objects using the default value are affected. See “Dynamic Defaults” on page 58.

The following cabinet default values are dynamic: Separation, Backsplash Height and Thickness, Countertop Overhang and Thickness, Toe Kick Height and Depth, Side and Vertical Overlap, Stiles, and Hardware spacing.

All Materials are also dynamic. In addition, the Cabinet Defaults can be set up to refer dynamically to information in the Material Defaults dialog. This makes it easy to have all cabinet objects in a plan use the same default materials. See “Material Defaults Dialog” on page 540.

To use dynamic cabinet Material Defaults

1. Specify the desired materials for the cabinet categories in the Material Defaults dialog:
   • “Cabinets” can be linked to the default cabinet box, cabinet interior, shelves, and toe kicks as well as to Shelves and Partitions.
   • “Cabinet Door/Drawer” can be linked to the default frames and panels of cabinet doors and drawers.
   • “Countertop” can be linked to the default countertop.
   • “Hardware” can be linked to the default door and drawer pulls and hinges.

2. On the Materials panel of the Base Cabinet Defaults dialog, select the first object component and click the Select Material button.

3. The Select Material dialog opens:
   • On the Library Material panel, check Use default material, or
   • On the Plan Material panel, select “Use Default” at the top of the list.

4. Click OK, then repeat this step for each of the components in the list.

5. Repeat steps 2-4 in each of the Cabinet Defaults dialogs.

General Cabinet Defaults

The General Cabinet Defaults dialog can be accessed only from the Default Settings dialog.

1 Specify the Minimum Cabinet Width. The smallest allowable value is 1/16 of an inch (10 mm).
2 Specify how Cabinet Resizing takes place when the edit handles are used.
3 Select Use Grid Snaps to resize cabinets using Snap Grid increments. See “Grid Snaps” on page 102.
4 Select Use Resize Increment to resize cabinets using the increment specified here.
5 Set the Resize Increment at which cabinets resize. The minimum allowable increment is 1/16 of an inch (10 mm).

Display Options -

Check Show Partial Module Lines to represent module lines as grey lines that do not extend across the cabinets. When this is unchecked, lines between merged cabinet modules display as specified by the “Cabinets, Module Lines” layer. See “Displaying Cabinets” on page 341.

• Check Show Closed Doors/Drawers in Plan Views to display closed cabinet doors and draw-
ers in plan view. When unchecked, closed doors and drawers are not shown. See “Displaying Cabinets” on page 341.

The Cabinet Tools

Select Build> Cabinet to access the Cabinet Tools.

Cabinets are easily created with a single click in plan view or any camera view. See “Click-to-Create” on page 103.

Typically, groups of cabinet objects are positioned closely together and arranged to form work spaces, and there are some special behaviors and techniques to be aware of. See “Placing Cabinets” on page 338.

Once created, cabinets, soffits, shelves, partitions and fillers can be selected and edited much like other box-based objects. See “Editing Cabinets” on page 344.

Base Cabinets

Select Build> Cabinet> Base Cabinet and click in any view. Base cabinets can be placed directly under wall cabinets and generate a countertop and toe kick by default.

Wall Cabinets

To place a wall cabinet, select Build> Cabinet> Wall Cabinet and click in any view. Wall cabinets can be placed directly over base cabinets.

Full Height Cabinets

To place a full height cabinet, select Build> Cabinet> Full Height and click in any view. Full height cabinets generate a toe kick by default and cannot be placed on top of other cabinets.

Soffits

Soffits typically fill the space between cabinet tops and the ceiling, but can also be used to create any object that can be modeled as a 3D box. To place a soffit, select Build> Cabinet> Soffit and click in any view.

By default, soffits use the material assigned to interior walls in the Material Defaults dialog. Like cabinets, soffits can have molding profiles applied to them.

For more information about using soffits for a variety of purposes, see “Other Objects” on page 533.

Shelves

Select Build> Cabinet> Shelf and click in any view to create a shelf.

Create corner shelves by placing one shelf on each wall, then moving or stretching them until they touch.

Once created, shelves can be selected and edited. See “Shelf/Partition Specification Dialog” on page 358.

You can also specify shelves inside of base, wall, and full height cabinet boxes. See “Cabinet Shelf Specification Dialog” on page 357.

Partitions

Select Build> Cabinet> Partition button and click in any view to create a vertical partition.

Like shelves, partitions can be selected and edited after they are placed.

Partitions can be used with shelves to create complex storage systems.

Custom Countertops

Custom Countertops are drawn and edited just like other closed-polyline based objects. Select Build> Cabinet> Custom Countertop, then either click and drag a rectangle or single-click to place a 2’x2’ countertop. See “Countertops” on page 339.

You can also generate a custom countertop over one or more base cabinets using the Generate Custom Countertop edit tool. See “Using the Edit Tools” on page 344.

Custom Backsplashes

Select Build> Cabinet> Custom Backsplash while an elevation or camera view is active, then either click and drag a rectangle or single-click on a wall surface to place a Custom Backsplash Layered Material Polyline on that wall. See “Custom Backsplashes” on page 340.
Cabinet Library Catalog

In the Library Browser, browse to Home Designer Core Catalogs> Architectural> Cabinets to access a selection of specialty cabinets. Select the library object you want, then click in any view to place it in the plan. Once placed, library cabinets can be edited. See “The Library” on page 509.

Cabinet Doors, Drawers, and Panels Catalog

A selection of cabinet door, drawer, and panel styles is available in Home Designer Core Catalogs> Architectural. Select an item, then click on a cabinet in your plan to place the door or drawer onto that cabinet. Doors, drawers, and panels can be assigned to a cabinet in its specification dialog, as well. Cabinet doors, drawers, and panels can also be placed as stand-alone fixtures.

Built-In Sinks and Appliances

A variety of fixtures and appliances such as sinks, cooktops, and dishwashers can be placed into cabinets. See “Inserted Objects” on page 522.

Place fixtures and appliances into cabinets early, so that any resizing can be done while there is adequate free space.

Cabinet Fillers

Home Designer Pro models a continuous countertop and generates fillers automatically when cabinets of the same height are either touching or placed with 3” (75 mm) of one another.

If two cabinets meeting at a corner are separated from each other by 3” (75 mm) or less, the program will automatically generate a filler in the angle between them. A filler is used to separate the front of one of these cabinets from the one it meets so that drawers and doors have room to operate.

Placing Cabinets

Cabinets are easily created with a single click in any view. See “Click-to-Create” on page 103.

When used near a wall corner, the Cabinet Tools will produce corner cabinets and soffits. See “Corner Cabinets” on page 346.

To insert a fixture into a cabinet, select the fixture in the Library Browser, then click on a cabinet. There must be enough space in the cabinet or adjoining cabinets to contain the selected fixture.

If a sink or cooktop is inserted into a cabinet with a top Drawer or Double Drawer, its Item Type will automatically change to a False Drawer or False Double Drawer.

Once placed, an inserted fixture can be selected and edited:

- To select a fixture in a cabinet top, click on it and then click the Select Next Object edit button. See “Select Next Object” on page 124.
- Front fixtures can only be modified or deleted in the Cabinet Specification dialog. See “Front Panel” on page 351.

Electrical Switches and Outlets

Electrical switches and outlets placed within the backsplash area of a base cabinet will display in front of the backsplash in 3D views when the “Electrical” layer is turned. See “The Electrical Tools” on page 364.

Fixtures can be added to both the top and front of the same cabinet. It is up to you to determine which can be effectively and safely combined in the real world.

Two base cabinets and the filler between them
If the ceiling height of the room does not accommodate the height of a cabinet, its **Floor to Bottom** value will be retained and its **Height** will be reduced so that it fits under the ceiling. When this happens, some front items may be removed from the cabinet if there is not enough room for them. See “Front Panel” on page 351.

Because cabinets are typically organized into groups with shared attributes, they have some special behaviors.

**Cabinet Snapping and Aligning**

Cabinets have several special snapping and aligning behaviors which help you create precisely aligned cabinets quickly and easily.

- When Base and/or Full Height cabinets are within 3” of one another’s sides, they will snap together. Wall cabinets snap in a similar manner, but only with other Wall cabinets.
- When Base and/or Full Height cabinets are within 3” of one another’s sides and their front or back surfaces are within 3” of aligning, they will become aligned. Wall cabinets snap in a similar manner with other Wall cabinets as well as Full Height cabinets.
- When a Base and/or Full Height cabinet is placed against the back of another Base or Full Height cabinet, its back surface will automatically face the other cabinet’s back. Wall cabinets snap in a similar manner with other Wall as well as Full Height cabinets.
- When a cabinet or cabinet filler is placed against a wall, its back and/or side will snap to the wall and, if the wall is moved, the cabinet will move with it.

When cabinets are snapped to a wall or to other cabinets, only exposed end cabinets have side counter overhangs.

Cabinet snapping and aligning occurs even when **Object Snaps** are turned off; however, you can override this behavior by moving a cabinet into the desired position using dimensions. See “Moving Objects Using Dimensions” on page 263.

**Countertops**

Countertops are automatically generated on top of base cabinets. These default countertops are
basically components of the cabinets. They can be edited in the Cabinet Specification dialog but cannot be selected and modified separately.

**Custom Countertops**

When automatic countertops do not meet your needs, you can instead use Custom Countertops, which can be selected independent of the cabinets beneath and are drawn and edited just like other closed-polyline based objects. See “Rectangular Polyline” on page 178.

Select Build> Cabinet> Custom Countertop, then either click and drag a rectangle or single-click to place a 2’x2’ countertop. Custom Countertops can be drawn in any view except cross section/elevation views.

You can also generate a custom countertop over one or more selected base cabinets by clicking the Generate Custom Countertop edit button. See “Using the Edit Tools” on page 344.

When a Custom Countertop covers any portion of a base cabinet, it overrides the default countertop.

A custom countertop bases its thickness and height on the base cabinet(s) below.

- If there are multiple cabinets below, it uses the specifications for the cabinet with the greatest overall height.
- If there is no base cabinet below, its height and thickness are based on the base cabinet defaults. See “Cabinet Defaults” on page 335.

**Editing Custom Countertops**

Once created, a custom countertop can be selected in 2D and 3D views and edited like other closed-polyline based objects. See “Editing Closed Polyline-Based Objects” on page 133.

Custom countertops initially use the default countertop material set in the Base Cabinet Defaults dialog. You can specify a different material as well as the height and position in the Custom Countertop Specification dialog. See “Custom Countertop Specification Dialog” on page 359.

You can also specify the edge profile of a custom countertop in the Custom Countertop Specification dialog. See “Moldings Panel” on page 358.

**Waterfall Countertops**

To add a vertical waterfall to the edge of a Custom Countertop, select that edge and click the Add Waterfall to Selected Edge edit button. See “Selected Edge” on page 123.

You can also specify a waterfall edge as well as edit its attributes in the Custom Countertop Specification dialog. See “General Panel” on page 359.

To remove a waterfall from a countertop edge, select that edge and click the Remove Waterfall from Selected Edge edit tool.

**Custom Backsplashes**

The Custom Backsplash tool allows you to create areas on a wall that use a different surface material than the parent wall. To create a Custom Backsplash, select Build> Cabinet> Custom Backsplash.

Custom Backsplashes are closed polyline-based objects that are drawn on the vertical surface of a wall. They can only be drawn, and their shapes edited, in camera and elevation views. See “Polylines” on page 176 and “Editing Closed Polyline-Based Objects” on page 133.

Custom Backsplashes are composed of a layer of backsplash material. The layer material and its thickness can be set in the Custom Backsplash Specification dialog. See “Custom Backsplash Specification Dialog” on page 360.

If any cabinets and/or appliances are present, a Custom Backsplash will:

- Seek to fill the area between any base cabinets or floor appliances against that wall surface and any wall cabinets and/or windows above them.
Displaying Cabinets

If nothing is above any base cabinets, it will fill the area between the cabinets and the ceiling; if nothing is below any wall cabinets, it will fill the area between the cabinets and the floor.

Replace the backsplash associated with any base or wall cabinets.

Displaying Cabinets

The display of the various cabinet object types, labels, module lines, door opening indicators and more is controlled in the Layer Display Options dialog. See “Layer Attributes” on page 110.

In Plan View

Fill Styles and colors can be assigned to cabinet objects in plan view. See “Fill Styles” on page 115.

Like other objects, cabinets are placed in Drawing Groups that affect whether they display in front of or behind other objects in plan view. By default, wall cabinets, soffits and shelves are drawn in front of base and full height cabinets, countertops and partitions. You can modify a selected cabinet’s place in the drawing order by clicking the View Drawing Group Edit Tools edit button. See “Drawing Group Edit Tools” on page 114.

Objects assigned to cabinets, including hardware and moldings, are located on the same layer as their parent object. They display in 3D views, but are not shown in plan view. There are two notable exceptions: countertops and drawers.

- Both automatic and Custom Countertops are drawn on the “Cabinets, Countertops” layer in all views. In plan view, countertops use the line style, color, and weight assigned to this layer; in 3D views, the line attributes of the parent object’s layer is used instead.

- Cabinet doors and drawers are drawn on the “Cabinets, Doors & Drawers” layer in all views, but only display in 3D views by default. See Cabinet Doors and Drawers, below.

Custom Countertops can be assigned an edge profile, and can display the width of this profile if Display Molding Edges is selected in the Custom Countertop Specification dialog. See “General Panel” on page 359.

By default, cabinet module lines display in plan view when cabinet objects of the same type are placed side by side. If you prefer that these lines not display, turn off the “Cabinets, Module Lines” layer. You can also specify whether module lines are full or partial. See “General Cabinet Defaults” on page 336.

You can also display cabinet front indicator arrows in plan view by turning on the “Cabinets, Front Indicators” layer.

Cabinet labels display in plan view when the “Cabinets, Labels” layer is turned on Text Style assigned to their layer. See “Cabinet Labels” on page 342.

In 3D Views

In 3D views, cabinet doors and drawers are drawn on the “Cabinets, Doors & Drawers” layer, and their display can be turned on and off.

To show door opening indicator arrows in cross section/elevation and Orthographic views, turn on the “Opening Indicators” layer. Opening indicators display in Vector Views only. See “Vector View” on page 595.

Cabinet Doors and Drawers

There are several options for controlling the display of cabinet doors and drawers in plan and 3D views.

Cabinet doors and drawers are drawn on the “Cabinets, Doors & Drawers” layer. In plan view, they use the line style, color, and weight assigned to that layer when they are set to display. In 3D Vector Views, they use the line style, color, and weight assigned to their parent cabinet’s layer.

Cabinet doors and drawers can be drawn open or closed in both plan and 3D views.

- To draw a selected cabinet’s doors open in all views, click the Open Cabinet Doors edit button. Any shelves set as Rollout will display in 3D views as well.

- To draw its drawers open in all views, click the Open Cabinet Drawers edit button.
To close the doors and/or drawers, click the Close Cabinet Doors or Close Cabinet Drawers edit button.

Cabinet doors and drawers also can be set to Show Open in the Cabinet Specification dialog. In addition, you can specify how far open each is drawn. See “Front Panel” on page 351.

By default, doors and drawers do not display in plan view when they are closed- even when the “Cabinets, Doors & Drawers” layer is set to display. You can, however, check Show Closed Doors/Drawers in Plan Views in the General Cabinet Defaults dialog. See “General Cabinet Defaults” on page 336.

Rollout Shelves and Storage

Shelves can be specified for Door and Opening cabinet front items and are visible in 3D views. Those inside of Doors will display in 3D views only when Doors and Rollout Shelves are set to Show Open. See “Front Panel” on page 351.

Shelves can be specified as Rollout, each with its own rollout percentage, and will display in 3D views when Doors and Rollout Shelves are set to Show Open. If a Rollout shelf is in a Door item, the door must be set to 100% Percent Open in order for the shelf to draw open. See “Cabinet Shelf Specification Dialog” on page 357.

Cabinet shelves and added storage items do not display in plan view.

In the Materials List

The materials associated with cabinet objects are listed under different Categories in the Materials List:

- **Cabinets** - Lists Cabinets, Shelves, Partitions, Custom Countertops, Custom Backsplashes, storage and organization inserts, and cabinet doors and drawers placed independently from the library.
- **Interior Trim** - Lists Soffits and any moldings assigned to cabinet objects located in Interior room. Note that Soffits are not listed in the Materials List unless a non-default material is applied to them. See “Calculating Materials on Soffits” on page 535.
- **Exterior Trim** - Lists any Soffits and moldings assigned to cabinet objects located in Exterior rooms. See “Room Types” on page 227.
- **Fixtures** - Lists any sinks inserted into base cabinets. See “Inserted Objects” on page 522.
- **Appliance** - Lists any appliance fixtures inserted into cabinets. If a base cabinet has an under-counter appliance inserted into it, that cabinet will not be counted in the Materials List - only the countertop and backsplash materials associated with it will be listed. The cabinet will also display the appliance’s label information instead of its own.

As with other objects, there are a number of ways to control how, or whether, cabinets are included in the Materials List. See “Organizing Materials Lists” on page 684.

You can add and edit information about a cabinet’s accessories in the Cabinet Specification dialog. See “Components Panel” on page 692.

Note that cabinet door and drawer height is described in two different ways:

- In the Cabinet Specification dialog, the Item Height for cabinet doors and drawers describes the height of the opening in the cabinet box rather than that of the door or drawer front. See “Front Panel” on page 351.
- In the Materials List, the full height of cabinet door and drawer front is listed in the Size column.

Cabinet Labels

Labels for cabinets display in plan view when the “Cabinets, Labels” layer is turned on. See “Object Labels” on page 285.

Shelves and Partitions can also display labels when the “Cabinets, Labels” layer is turned on. Unlike cabinets, the Automatic Label for these objects is blank; however, you can specify a custom label in their specification dialogs.

Cabinet labels use the Text Style specified for the “Cabinets, Labels” layer. See “Text Styles” on page 283.

If a base cabinet’s only front item aside from Separations and Blank Areas is an Appliance, the appliance’s label will display instead of the cabinet’s, and will be placed on the “Cabinets, Labels” layer.
The minimum on-screen display size of object labels can be specified in the Preferences dialog. See “Appearance Panel” on page 62.

**Automatic Labels**

The format for automatic cabinet labels has four parts: Key, Code, Size, and Door Swing.

The **Key** provides basic information about the cabinet box and its use. B refers to base cabinets, W refers to wall cabinets and U refers to full height cabinets.

Together with the key, the **Code** provides additional information about the shape of the cabinet box:

<table>
<thead>
<tr>
<th>Code</th>
<th>All Cabinets</th>
</tr>
</thead>
<tbody>
<tr>
<td>LS + Key</td>
<td>Lazy Susan</td>
</tr>
<tr>
<td>LSD + Key</td>
<td>Lazy Susan Diagonal Door</td>
</tr>
<tr>
<td>DC + Key</td>
<td>Diagonal Door</td>
</tr>
<tr>
<td>LC + Key</td>
<td>Left Corner</td>
</tr>
<tr>
<td>BC + Key</td>
<td>Blind Corner</td>
</tr>
<tr>
<td>Key + F</td>
<td>Filler</td>
</tr>
<tr>
<td>E + Key</td>
<td>Right or Left End</td>
</tr>
<tr>
<td>A + Key</td>
<td>Angled Front</td>
</tr>
<tr>
<td>PR + Key</td>
<td>Peninsula Radius</td>
</tr>
<tr>
<td>R + Key</td>
<td>Radius End</td>
</tr>
<tr>
<td>B</td>
<td>Base</td>
</tr>
<tr>
<td>OB</td>
<td>Oven Base</td>
</tr>
<tr>
<td>SB</td>
<td>Sink Base</td>
</tr>
<tr>
<td>RB</td>
<td>Range Base</td>
</tr>
<tr>
<td>#DB</td>
<td>Drawer Bank (# is the number of drawers</td>
</tr>
<tr>
<td>FHB</td>
<td>Full Height Base (1 full height door</td>
</tr>
<tr>
<td>W</td>
<td>Wall</td>
</tr>
<tr>
<td>Code from above + #D</td>
<td>Drawer (# is the number of drawers</td>
</tr>
<tr>
<td>U</td>
<td>Full Height (Utility)</td>
</tr>
<tr>
<td>OTC</td>
<td>Tall Oven</td>
</tr>
<tr>
<td>RTC</td>
<td>Tall Refrigerator</td>
</tr>
</tbody>
</table>

Blind corner cabinets are dependent on the cabinet’s position in the plan. A cabinet can only be a blind corner cabinet when its front is partially hidden by another cabinet. See “Blind Cabinets” on page 348. If a cabinet is moved, therefore, its Code information may change.

The **Size** follows the Code in a cabinet label. Cabinet width is always included in the label; depth and height, on the other hand, may be included depending on the cabinet type and whether they are standard or non-standard.

Base and full height cabinet labels present Size information in this order: width, depth, height. Wall cabinet labels present it in a slightly different order: width, height, depth.

<table>
<thead>
<tr>
<th>Sizes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Base</td>
</tr>
<tr>
<td>Width (W)</td>
</tr>
<tr>
<td>Depth (D)</td>
</tr>
<tr>
<td>Height (H)</td>
</tr>
<tr>
<td>Corner Depth (D)</td>
</tr>
<tr>
<td>Wall</td>
</tr>
<tr>
<td>Width (W)</td>
</tr>
<tr>
<td>Height (H)</td>
</tr>
<tr>
<td>Depth (D)</td>
</tr>
<tr>
<td>Corner Depth (D)</td>
</tr>
<tr>
<td>Full Height</td>
</tr>
<tr>
<td>Width (W)</td>
</tr>
<tr>
<td>Depth (D)</td>
</tr>
<tr>
<td>Height (H)</td>
</tr>
<tr>
<td>Corner Depth (D)</td>
</tr>
</tbody>
</table>

**Door Swing** is included at the end of the label as either L or R, but only if all the doors on a cabinet have the same swing.

Here are a few examples of automatic cabinet labels and their meanings:

- **3DB24**: Base cabinet with 3 drawers, 24” wide. Depth and height are standard.
- **SB24R**: Sink base, 24” wide, with a right door. Depth and height are standard.
- **BCW2436R**: Blind wall cabinet, 24” wide, 36” high, with a right door. Depth is standard (equal to width).
- **DCW2436L**: Diagonal corner wall cabinet, 24” wide, 36” high, with a left door. Depth is standard.
- **OTC362490**: Full height cabinet with oven, 36” wide, 24” deep, 90” high.

The Automatic Labels for Shelves and Partitions are blank, but you can specify custom labels for both. See “Shelf/Partition Specification Dialog” on page 358.
Editing Cabinets

Cabinets can be selected in 2D and 3D views both individually and in groups and edited using the edit handles, the edit toolbar and their specification dialog.

Using the Mouse

Cabinets can be edited like other box-based objects. See “Editing Box-Based Objects” on page 136. The edit handles that a cabinet displays when selected will vary depending on the view.

When a cabinet is selected in plan view or on its top surface in a 3D view, ten edit handles display: the Move handle at the center, the Rotate handle, and a Resize handle on each edge and at each corner.

In 3D views, cabinets can be selected on any surface: front, side, back or top. When the side of a cabinet is selected, five edit handles are available: the Move handle and a Resize handle on each edge.

When cabinet labels are displayed, a label will move as its cabinet is moved or resized. See “Displaying Cabinets” on page 341.

Cabinets cannot be concentrically resized, even when the Concentric edit behavior is enabled. See “Defaults, Preferences, and Edit Behaviors” on page 119.

In the Specification Dialog

A selected cabinet can be customized in a variety of ways in its specification dialog. See “Cabinet Specification Dialog” on page 348.

Multiple Cabinets

When multiple cabinets are selected as a group, any specifications that they share in common can be modified in the Cabinet Specification dialog.

When you group select cabinets of different types, some options are not available in the Cabinet Specification dialog. For example, you cannot modify the crown molding on a full height cabinet if it is selected with a base cabinet that does not have crown molding.

Soffits, shelves, and partitions can be group selected and edited using their corresponding specification dialog. It is important that only soffits, or only shelves, or only partitions be a part of the selection set in order to access the needed specification dialog.

Using the Edit Tools

A cabinet or cabinets can be edited in a variety of ways using the buttons on the edit toolbar. See “The Edit Toolbar” on page 29.

Add to Library

Cabinets can be saved in the Library Browser. Select a base, wall or full height cabinet or cabinet filler and click the Add to Library edit button. See “Add to Library” on page 517.

Using Dimensions

Like various other objects, cabinets can be moved and resized using dimensions. See “Moving Objects Using Dimensions” on page 263.

In order to be edited using dimensions, cabinets must be located by them. In the Dimension Defaults dialog, you specify what components of a cabinet are located by dimensions:

- Cabinet sides, corners, centers, backsplashes, and counter edges can be located in both plan and elevation views.
- Cabinet backsplashes, countertops, toe kicks, and moldings can be located in elevation views; they cannot, however, be edited using dimensions.

See “Locate Objects Panel” on page 252.

Dimensions locate the sides and/or corners of cabinet boxes. If you wish, you can move a dimension’s extension lines to locate the centers or countertop edges in plan view after the dimension line is drawn.
In elevation views, the heights of the toe kick, backsplash, and/or moldings can also be located in this manner. See “Editing Extension Lines” on page 261.

Depending on whether a cabinet box or Custom Countertop is selected, Temporary Dimensions will locate objects near the Selected Edge somewhat differently: See “Temporary Dimensions” on page 258.

• If a cabinet box is selected, Temporary Dimensions will locate the nearest wall surface or another cabinet box, but not automatically generated or Custom Countertops.
• If a Custom Countertop is selected, Temporary Dimensions will locate the nearest wall surface, Custom Countertop, or automatically generated countertop edge.

Moving Walls with Cabinets Attached

When a cabinet is placed or moved against a wall, it will snap to the wall and become attached to it. When a wall is moved, all attached cabinets move with it.

Moving a wall to an unattached cabinet will not attach the cabinet to it: the cabinet must be moved to the wall. A cabinet can also be attached to a wall when Plan Check is used. See “Plan Check” on page 54.

When wall layers are resized or the wall layer definition redefined, the cabinets may become unattached. To reattach, select them, drag them away from the wall, and then drag them back again.

Editing Cabinet Styles

A variety of settings allow you customize the appearance of your cabinets to create styles ranging from traditional to contemporary.

If the desired style is known before cabinets are placed, you can save time by specifying that style in the Cabinet Defaults dialogs before you start drawing. See “Cabinet Defaults” on page 335.

Cabinet Face Items

A variety of different face items can be added to the front of any cabinet, including doors, drawers, cutting boards, and horizontal separations. Face items can be moved, resized, as well as removed and can also be split vertically or horizontally to produce a variety of custom configurations. See “Front Panel” on page 351.

When adding, removing, or resizing face items, it is helpful to keep a few rules in mind:

• Door and drawer Item Height settings reflect the height of the opening rather than that of the front item. When Traditional Overlay is specified, an item’s front height will be equal to its Item Height plus its top and bottom Vertical Overlap.
• When the overall height of a cabinet or the height of a face item is changed, the height of the lowest face item that is not a Separation is adjusted to accommodate the change.
• If you increase the height of the lowest face item, the non-Separation item directly above is adjusted; if you decrease its height, a Blank Area and Separation are created below it.

Note: To ensure that Face Item heights always equal the total cabinet front height, the program automatically adjusts the bottom Face Item as changes are made elsewhere. This means you should start editing Face Items at the top and work down.

Doors, Drawers and Panels

Cabinet doors, drawers, and panels can be applied in either of two ways:

• In the Cabinet Specification dialog. See “Door/Drawer Panel” on page 354.
• Directly from the Library Browser.

Select a style in the Library, then click on a cabinet to apply the selected style to that cabinet. See “Replace From Library” on page 523.

A secondary door or drawer style can also be specified - for example, to create glass doors above solid doors in wall cabinets. See “Front Panel” on page 351.

Cabinet Hardware and Moldings

Cabinet handles, pulls, and hinges can be assigned in the Cabinet Specification dialog. See “Door/Drawer Panel” on page 354.
In 3D views, cabinet hardware can also be applied directly from the Library Browser. Select a cabinet hardware item in the Library, then click on a cabinet door or drawer to assign it to face items of that type. See “Inserted Objects” on page 522.

Multiple molding profiles can also be applied around the perimeter of a cabinet at any height. For example, you may want a wood edge around base cabinet countertops and a crown molding that ties together the tops of the wall cabinets and full height cabinets. See “Applying Moldings” on page 505.

Countertops and Backsplashes

The countertop thickness, overhang, and material for a selected base cabinet can be specified in the Cabinet Specification dialog. See “General Panel” on page 349.

Backsplashes can be applied to base cabinets as well as down from wall cabinets on the General panel of their specification dialogs.

Custom Countertops and Backsplashes can also be created independent of base or wall cabinets. See “The Cabinet Tools” on page 337.

Cabinet Shelves

You can customize the shelves inside of base, wall, and full height cabinet boxes. See “Cabinet Shelf Specification Dialog” on page 357.

Special Cabinets

There are a number of special cabinet shapes that can be specified. Certain requirements must be met before some special cabinet shapes can be specified. If the requirements are not met, a warning message will explain what is needed. See “Cabinet Specification Dialog” on page 348.

Note: Only Standard cabinets can be the default cabinet Type. See “Cabinet Defaults” on page 335.

Standard Cabinets

Select Build > Cabinet > Base Cabinet and click in plan view to place a standard, rectangular base cabinet.

Corner Cabinets

To create a corner cabinet, click as close to an inside wall corner as possible in using either the Base Cabinet, Wall Cabinet, or Full Height cabinet tool. A corner cabinet remains a corner cabinet when it is moved, edited or copied.

You can turn an existing cabinet into a corner cabinet by selecting “Corner” from the Special drop-down list in its specification dialog. See “General Panel” on page 349.

- Before a corner cabinet can be specified in the Cabinet Specification dialog, the cabinet’s Width must be greater than its Depth.
- The Left and the Right Side Widths can be set independently for corner cabinets.

Corner cabinet with sides of equal width

- You can specify a Diagonal Door on corner cabinets to create an angled corner cabinet. See “Front Panel” on page 351.
End Cabinets

To turn a cabinet into an end cabinet, specify its Type as “Left End” or “Right End”.

- End Cabinets have an angled front and side.
- The cabinet width must be no greater than its depth for an end cabinet to be specified.

Radius End Cabinets

To turn a cabinet into a radius end cabinet, specify its Type as “Left Radius End” or “Right Radius End”.

- Radius End cabinets have a 90° arch

As you face the cabinet, a right radius end curves to the right, and a left radius end curves to the left.

Peninsula Radius Cabinets

To turn a cabinet into an end cabinet, specify its Type as “Peninsula Radius”.

Kitchen Islands

To create a kitchen island, simply place several cabinets back-to-back and/or side-to-side. Match the widths so that each cabinet back or side meets the back or side of only one other cabinet. If this is not done, the lines separating the cabinets cannot be suppressed.

A given side of a single cabinet cannot merge with the edges of two different cabinets. The example below shows two instances of cabinets placed back-to-back. Cabinet fronts and joining surfaces are shown.
Blind Cabinets

Often, when two cabinets meet in a corner, one is partially hidden by the other. This partially hidden cabinet is called a “blind” cabinet. Home Designer Pro will resize and offset the front items of the partially hidden cabinet so that they are not located in the hidden portion of the cabinet face.

You can also create a blind cabinet manually by controlling the widths of a cabinet’s left or right stile in its Cabinet Specification dialog. See “Front Panel” on page 351.

Cabinet Specification Dialog

Select one or more cabinet and click the Open Object edit button to open the Cabinet Specification dialog. The options in the Cabinet Specification dialogs are similar to the corresponding Cabinet Defaults dialog. See “Cabinet Defaults” on page 335.
A number of Cabinet Types are available in the drop-down list. Certain requirements must be met before some types can be specified. Not available in the Cabinet Defaults dialogs. See “Special Cabinets” on page 346.

**Size/Position** - The selected cabinet’s dimensions and position relative to the floor can be specified here. Fractional values are supported to 1/16th of an inch (1 mm).

- Specify the **Width** of the cabinet box, as measured across the front of the cabinet box from left to right. This does not include the countertop overhang.
- Specify the **Height (Including Counter)** of the cabinet box, as measured from bottom to top. For base cabinets, this value includes the countertop thickness, but not the height of the backsplash.

Note: Height refers to the height of the entire cabinet, including countertop and toe kick. If you change the Countertop Thickness or Toe Kick Height, the cabinet’s total height is not altered. Instead, the cabinet face height and the heights of face items change in response.

- Specify the **Depth** of the cabinet box, as measured from front to back. It does not include the thickness of overlay doors or the countertop overhang.
- For Corner cabinets, the **Width** and **Depth** fields are instead named **Right Side Width** and **Left Side Width**.
- For Corner cabinets, specify the **Bow Depth**. A positive number creates a bow and a negative number, an inside bow. Not available for Corner
cabinets if Diagonal is unchecked on the Front panel. See “Front Panel” on page 351.

- For Angled Front cabinets, specify the **Left Depth** and **Right Depth** rather than the Depth and Bow Depth.

- Select the **Elevation Reference** from the drop-down list. This determines where the next two settings are measured from and also affects their setting labels.

- Specify the **to Top** distance, measured from the Elevation Reference to the top of the cabinet’s countertop.

- Specify the **to Bottom** distance, measured from the Elevation Reference to the bottom of the cabinet, including the toe kick.

Specify the dimensions and style of the selected cabinet’s **Countertop**, or uncheck this box to prevent it from having a countertop. Only available for base cabinets.

- Specify the countertop **Thickness**. Changing this value does not alter the cabinet height, but it does affect the height of face items. See “Front Panel” on page 351.

- Specify the countertop **Overhang**, **Uniform** to specify separate values for each side in the fields below, or leave it unchecked to use the same value for all sides. Overhangs do not generate on sides that are against a wall or another cabinet. See “Cabinet Snapping and Aligning” on page 339.

- **Corner Treatment** - Specify **Clipped** or **Rounded** countertop corners.

- When Clipped or Rounded is selected, specify the **Corner Width**, which is measured from the original location of the corner to the point where the straight front edge ends.

Check the box beside **Backsplash**, then specify its dimensions and when it should generate, or leave this box unchecked to prevent the selected base or wall cabinet from having a backsplash.

- Specify the backsplash **Height and Thickness**. Height is only available for base cabinets - not wall cabinets.

- Check **Side** to add the backsplash to the side of the cabinet if it is against a wall or a taller cabinet. Not available for Corner cabinets.

- Check **Always Present** to display the backsplash at all times. If unchecked, a backsplash is present only when the cabinet is against a wall.

- Check **Backsplash to Base Below** to extend a backsplash from the selected wall cabinet down to the backsplash or countertop of the base cabinet below. Only available for wall cabinets.

Note that while a base cabinet’s backsplash is measured from the countertop up, a wall cabinet’s backsplash extends downward.

Specify the dimensions and style of the selected cabinet’s **Toe Kick**, or uncheck this box to prevent it from having a toe kick. Only available for base and full height cabinets.

- Specify the toe kick’s **Height and Depth**. Changing the Height does not alter the cabinet height but does affect the heights of the cabinet face and face items.

- **Flat Sides** can be added to base and full height cabinets. Checking Flat Sides eliminates the toe kick area on the exposed end(s) of the cabinet.

- Check **Flat Back** to eliminate the toe kick on a cabinet with an exposed back. This does not eliminate the toe kick on the cabinet front.

- Check **Closed Toe** to extend the cabinet sides to cover the sides of the toe kick. If pilasters that do not extend to the floor are specified, checking this places a support block under them at Exposed Ends.

**Options** -

- Uncheck **Diagonal Door** to create double doors at right angles instead of a single diagonal door. This option is checked by default in the **Cabinet Defaults** dialog and is only available for Corner Cabinets. See “Corner Cabinets” on page 346.

- Check **Lazy Susan** to indicate a lazy Susan in the cabinet’s label and its appearance in plan view. This option does not display in 3D views.

A preview of the selected cabinet displays on the right side of the panel. See “Dialog Preview Panes” on page 32.
Box Construction Panel

1 Define the **Box Construction** of the selected cabinet. Select **Framed** to create a traditional framed cabinet and enable the settings below, or choose **Frameless** for a European style cabinet.
   - Specify the **Separation** value, which is the width of the horizontal face frame piece between doors, drawers, and other face items.

2 Define the **Door/Drawer Overlay** of the selected cabinet.
   - Select **Traditional Overlay**, then specify the **Side** and **Vertical Overlap** values.
   - The **Side Overlap** is the distance that doors and drawers overlap the cabinet’s vertical stiles and is applied to both sides of the doors and drawers.
   - The **Vertical Overlap** is the distance that doors and drawers overlap the horizontal separations between front items and is applied to both the top and bottom of the doors and drawers.
   - Select **Full Overlay**, then specify the **Reveal**, which is the distance between door and drawer front items.
   - Select **Inset** to produce doors and drawers that are flush with the rails and stiles rather than overlapping it.

3 A preview of the selected cabinet displays on the right side of the panel. See “Dialog Preview Panes” on page 32.

**Front Panel**

If you click on a cabinet face item in the preview on the right side of the dialog, the FRONT panel will become active and that face item will be selected and can be edited.
Most of the **Face Items** settings are only active when a door, drawer, or other face item is selected. To select a face item, click on its name in the list or click on it in the preview on the right.

When a face item is selected, it is highlighted in the list as well as in the preview; its attributes can be edited and the list can be navigated using the arrow and number keys. The vertical frame pieces on the sides of the cabinet front are referred to as stiles and cannot be selected in the preview. See “Cabinet Face Items” on page 345.

- A numbered tree list of face items displays here. Item numbers start at the top of the cabinet and go down the face to the bottom of the cabinet. Item 1 is usually the top face frame Separation, or rail. The selected face item is highlighted; if no item is selected, the “Vertical Layout Parent” heading will be highlighted.

- Click **Add New** to add a new face item directly below the currently selected item. When a face item is added, the height of the lowest item on the cabinet front is reduced to make room for the new item. If you click **Add New** with no face item selected, the new item is added to the bottom of the cabinet face.

  - In the **New Cabinet Face Item** dialog, define the **Item Type**, **Item Height**, and click OK. If the Item Type is “Separation”, you can check **Default** to use the default Separation Height.

- Click **Delete** to remove the selected face item. When an Auto Left, Auto Right, Left, Right, or Double Door is deleted, it is replaced by an Opening; when other face item types are deleted, the height of the lowest item is increased to make up the difference. You can also press the Delete key on the keyboard.

The program tries to maintain a single separation between all face items. When you add or delete a face item, separations are usually added or deleted with them.
• Click **Move Up** to move the currently selected item up one position, switching places with the item directly above.

• Click **Move Down** to move the currently selected item down one position, switching places with the item directly below.

• When the selected face item is part of a “Layout - Horizontal”, the **Move Left** and/or **Move Right** buttons will be available instead. Click either to have the selected item switch places with its neighbor.

• Click **Split Vertical** to divide the selected face item into two separate side-by-side items of the same Item Type and Height. A vertical separation is added between them and together the three new items have the same Width as the original item. Not available for Horizontal or Vertical Layouts, Appliances, Separations, or for items 1 1/2” (50 mm) wide or less.

• Click **Split Horizontal** to divide the selected face item into two separate items of the same Item Type and Width, stacked one above the other. A horizontal separation is added between them and together the three new items have the same Height as the original item. Not available for Horizontal or Vertical Layouts, Appliances, Separations, or for items 1 1/2” (51 mm) tall or less.

• Click **Equalize** to make the sizes of a face item’s sub-items equal in size. Only available if the selected item is a Vertical or Horizontal Layout with sub-items.

• Choose the selected face item’s **Item Type** from the drop-down list:

<table>
<thead>
<tr>
<th>Item Type</th>
<th>Special Behaviors</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blank Area</td>
<td>Creates a solid, flat surface.</td>
</tr>
<tr>
<td>Horizontal Layout</td>
<td>Creates a group of identical, side-by-side items separated by vertical separations.</td>
</tr>
<tr>
<td>Vertical Layout</td>
<td>Creates a group of identical, stacked items separated by horizontal separations.</td>
</tr>
<tr>
<td>False Drawer and False Double Drawer</td>
<td>Assumes the appearance of specified the drawer style, including hardware.</td>
</tr>
<tr>
<td>Drawer and Double Drawer</td>
<td>As specified.</td>
</tr>
<tr>
<td>Cutting Board</td>
<td>As specified.</td>
</tr>
<tr>
<td>Auto Right and Auto Left Door</td>
<td>Become double doors when cabinet width is greater than 24” (600 mm).</td>
</tr>
</tbody>
</table>

• Specify the selected face item’s **Item Height**. Fractional values are supported to 1/16th of an inch (1 mm). For doors and drawers, this is the height of the opening rather than the item front height. A door or drawer’s front height is equal to its Height plus its top and bottom Vertical Overlap. For best results, edit face item heights starting at the top of the cabinet and work down. See “Cabinet Face Items” on page 345.

• Specify the selected face item’s **Item Width**. Fractional values are supported to 1/16th of an inch (1 mm). For doors and drawers, this is the width of the opening rather than the item front width. Only available for components of a Horizontal Layout.

• Click **Lock from Auto Resize** to prevent the selected face item from resizing when the cabinet is resized, new face items are added, or when the **Equalize** button is clicked.

• **Shelves** - Click the **Specify** button to open the Cabinet Shelves Specification dialog and specify the shelf configuration for a selected Door or Opening Face Item. See “Cabinet Shelf Specification Dialog” on page 357.

• When an **Appliance/Door/Drawer** or panel is selected, click the **Specify** button to choose an appliance from the Library or to customize the selected door, drawer, or panel’s front style and hardware. The options available depend on the type of face item currently selected. See “Select Library Object Dialog” on page 522 and “Door/Drawer Panel” on page 354.

• Click the **Clear** button to remove the selected appliance from the cabinet or to reset the selected door or drawer so it uses hardware and front style assigned to the cabinet.

• Check **Reverse Appliance** to reverse the selected face item from left to right: for example, to move a dishwasher’s controls from the left side to the...
right. Only available when an “Appliance” item is selected. See “Inserted Objects” on page 522.

- Specify the widths of the Left and Right Stiles, which are the vertical frame pieces to the left and right of all face items.

2 Options -

- Specify the Appliance Front Offset, which is the distance from the front of a top-mounted appliance to the counter edge. Only available for base cabinets with a top-mounted fixture such as a sink or cooktop.

- Specify which types of front items you would like to Show Open in plan, 3D, and cross section/elevation views. See “Cabinet Doors and Drawers” on page 341.

3 A preview of the selected cabinet displays on the right side of the panel. See “Dialog Preview Panes” on page 32.

- Select Cabinet Face Item mode is active by default and allows you to click on a face item like a door, drawer, or separation in the preview to select it for editing. The selected face item is highlighted in grey.

- Mouse-Orbit Camera mode allows you to orbit around the preview of the cabinet. When this is active, you can right-click on a front item to select it.

- The cabinet Label displays below the preview pane. See “Cabinet Labels” on page 342.

Door/Drawer Panel

The settings on the DOOR/DRAWER panel allow you to control the appearance of the selected cabinet’s doors, drawers and hardware.

Similar settings are also found in the Door and Drawer Face Item Specification dialogs, which allow you to customize the door and drawer style and hardware for individual cabinet face items. See “Front Panel” on page 351.
Specify the appearance of the Doors applied to selected cabinet.

Select a door Style from the drop-down list. See “Doors, Drawers and Panels” on page 345.

- Select “Use Default” to apply the door style specified in the defaults dialog for the selected cabinet’s type. See “Cabinet Defaults” on page 335.
- Select “Slab Doors” to apply a flat door front or “Framed Doors” to apply a door with a frame and flat panel front.
- Select “Library” or click the Library button to select a cabinet door from the library. If a library door has been previously selected, its name will display in the list. See “Select Library Object Dialog” on page 522.
- Check Glass Doors to use a glass material for the panel of Framed doors or for the entire door for Slab doors. Not available when “Library” is the selected door Style.
- Check Stile Between Doors to separate double doors and double drawers with a stile. Other face items types are not affected by this setting.

Specify the characteristics of the selected cabinet’s Door Handles.

- Select a door handle Style from the drop-down list or choose one from the Library.
- Specify the position of the handle In From Edge, as measured from the edge of the door opposite the hinges.
- Specify the height of the handle Down From Top, as measured from the top edge of the door. For wall cabinets, this value is measured Up From Bottom.

Specify the characteristics of the cabinet Door Hinges.

- Select a door hinge Style from the drop-down list or choose one from the Library.
- Specify the location of the hinges Up/Down From Edge, as measured from the door edge. If the cabinet door is more than 35 1/4” (880 mm) high, three hinges will be created instead of two.
- Select a Drawer Style from the drop-down list or choose one from the Library. For best results, “Framed” drawers should be at least 6” (150 mm) high.

Specify the characteristics of the selected cabinet’s Drawer Handles.

- Select a drawer Handle Style from the drop-down list or choose one from the Library.
- Specify the Horizontal Position of the drawer handle(s): Choose Use Default to use the default position; One Handle Centered for a single handle centered on the drawer face; or Two Handles In From Edge for two handles set in from the drawer sides by the value specified in the text field.
- Specify the Vertical Position of the drawer handle(s): Choose Use Default to use the default position, Centered for handle(s) centered on the drawer face, or specify the handle’s Distance From Top.

Options -

- Enter a Slab Bevel width to create beveled edges on Slab drawers and doors. The bevel width, as viewed from the front, has a maximum value of 3” (75 mm). Framed and Library doors are not affected by this setting.

A preview of the selected cabinet displays on the right side of the panel. See “Dialog Preview Panes” on page 32.

- The cabinet Label displays below the preview pane. See “Cabinet Labels” on page 342.

Accessories Panel

The ACCESSORIES panel is only available in the Base Cabinet Specification dialog. It is not available for wall or full height cabinets, nor is it found in the Base Cabinet Defaults dialog.
The **Top Appliance/Fixture** settings apply to a fixture inserted into a base cabinet’s countertop. See “Built-In Sinks and Appliances” on page 338.

- Select a fixture **Symbol** from the drop-down list, or choose “None”. If a fixture is inserted into the countertop, its name will be listed. If no top fixture is present, you can select “Library” to select a fixture symbol from the Library.
- Specify the **Front Offset**, which is the distance from the front of the fixture to the front of the cabinet box. A positive value offsets the fixture towards the back of the cabinet while a negative value moves it forward.
- Specify the **Center Side Offset**, which is the distance between the fixture’s center and that of the cabinet. A positive value offsets the fixture to the right while a negative value offsets it to the left.
- Check **Reverse** to reverse the selected fixture from left to right: for example, to move a cooktop’s controls from the left side to the right. See “Inserted Objects” on page 522.

A preview of the selected cabinet displays on the right side of the panel. See “Dialog Preview Panes” on page 32.

**Moldings Panel**

The settings on the MOLDINGS panel allow you to assign one or more horizontal moldings around the selected cabinet. See “Editing Cabinet Styles” on page 345.

For information about the settings here, see “Moldings Panel” on page 506.

**Fill Style Panel**

The settings on the FILL STYLE panel affect the appearance of the selected cabinet in plan view. For more information, see “Fill Style Specification Dialog” on page 115.

**Materials Panel**

The settings on the MATERIALS panel affect the appearance of the selected cabinet in 3D views. For information about these settings, see “Materials Panel” on page 542.

Some material options may be disabled if the selected cabinet is a manufacturer symbol.

**Label Panel**

Cabinet labels display in plan view when the “Cabinets, Labels” layer is turned on and use the Text Style assigned to that layer. See “Cabinet Labels” on page 342.

For more information about the settings on this panel, see “Label Panel” on page 286.

**Components Panel**

The information on the COMPONENTS panel can be used in the materials list. For more information, see “Components Panel” on page 692.

**Object Information Panel**

The information entered on the OBJECT INFORMATION panel can be used in the materials list. For more information, see “Object Information Panel” on page 693.
Cabinet Shelf Specification Dialog

In the Base Cabinet, Wall Cabinet, or Full Height Cabinet Specification dialog, select a door or opening face item and click the Specify Shelves button to open the Cabinet Shelf Specification dialog. See “Front Panel” on page 351.

1 Shelf Management - Specify how shelves in the selected face item are created.
   • By default, cabinet doors and openings receive Automatic cabinet shelves. The number of shelves, shelf type, thickness, spacing, and depth display below.
   • Select the Manual radio button to specify the shelving for the selected door or opening. If the cabinet is resized after shelving has been manually edited, the specifications are maintained, but all shelves may not display in all situations.
   
   The Automatic Settings display here for reference only.

2 The Automatic Settings display here for reference only.

3 The Manual Shelf Specification settings are available when Manual is selected, above.
   • Specify the total Number of Shelves in the selected door or opening front item.
   • Select a Shelf from the drop-down list to customize its settings. To edit all shelves at once, choose “All Shelves”.

   Note: If “All Shelves” is selected after changes are made to an individual shelf, “No Change” may display in the settings that follow.

   • Click the Library button to select a shelf, storage, or organization object from the Library Browser. See “Inserted Objects” on page 522.
   • Click the Clear button to restore the default shelf style.
   • Check Rollout, then specify the amount that the shelf rolls out when set to Show Open. Only available for Standard cabinets. See “Rollout Shelves and Storage” on page 342.
   • Specify the Thickness/Height of the shelves or storage item.
   • Specify the Spacing From Previous, which is the distance from the bottom of the selected shelf to the top of the shelf below it.
   • If the Spacing From Previous value is changed, Equal Spacing will become unchecked. Check this box to produce evenly space the shelves within the selected cabinet front item.
• Specify the selected shelf’s **Depth**: choose **Full**, **Half**, or **Specify** a custom value in inches (mm).

The preview shows shelf numbers and spacing. Shelf thickness and depth are also represented. Press the Tab key to update the preview as changes are made.

### Shelf/Partition Specification Dialog

Select a shelf or partition and click the **Open Object** edit button to open the **Shelf Specification** or **Partition Specification** dialog.

The options in these specification dialogs are similar to the corresponding defaults dialogs. See “Cabinet Defaults” on page 335.

#### General Panel

1. **Size/Position** - Specify the **Height**, **Width**, and **Depth** of the shelf or partition.
2. Select the **Elevation Reference** from the drop-down list. This determines where the next two settings are measured from and also affects their setting labels.
3. Specify the **to Top** distance, measured from the Elevation Reference to the top of the shelf or partition.
4. Specify the **to Bottom** distance, measured from the Elevation Reference to the bottom of the shelf or partition.

A preview of the selected object displays on the right side of the panel. See “Dialog Preview Panes” on page 32.

#### Fill Style Panel

The settings on the **Fill Style** panel affect the appearance of the selected object in plan view. For information about these settings, see “Fill Style Specification Dialog” on page 115.

#### Moldings Panel

The settings on the **Moldings** panel allow you to apply molding to the selected object. For information about these settings, see “Moldings Panel” on page 356.

#### Materials Panel

The settings on the **Materials** panel affect the appearance of the selected object in 3D views. For information about these settings, see “Materials Panel” on page 542.

#### Label Panel

Shelf and Partition labels display in plan view when the “Cabinets, Labels” layer is turned on and use the Text Style assigned to that layer. The Automatic Labels for Shelves and Partitions are blank, but you can specify custom labels. See “Cabinet Labels” on page 342.

For more information about the settings on this panel, see “Label Panel” on page 286.

#### Components Panel

The information on the **Components** panel can be used in the materials list. For more information, see “Components Panel” on page 692.
Object Information Panel

The information entered on the OBJECT INFORMATION panel can be used in the materials list. For more information, see “Object Information Panel” on page 693.

Custom Countertop Specification Dialog

Select a custom countertop and click the Open Object edit button to open the Custom Countertop Specification dialog.

General Panel

Options -

- Check No Molding On Selected Edge to turn off the display of molding on the selected edge. Only has an effect when a molding is specified for the countertop on the MOLDINGS panel of this dialog.
- Check Display Molding Edges to display two edge lines instead of one, indicating the width of any molding applied to the countertop. Only has an effect when a molding is specified for the countertop.

Countertop Thickness -

- Uncheck Set Thickness From Cabinet, then specify the Thickness of the selected Custom Countertop below. When this is checked, the thickness is inherited from the cabinet below or from the Base Cabinet Defaults dialog if no cabinet is present below.

Countertop Height -

- Uncheck Set Height from Cabinet, then specify the height of the selected Custom Countertop using the settings below. When this is checked, Countertop height is determined by the cabinet below or by the default base cabinet counter thickness if no cabinet is present below.
- Select the Elevation Reference from the dropdown list. This determines where the next two settings are measured from and also affects their setting labels.
- Specify the height to Top, which is measured from the selected Elevation Reference to the top of the countertop.
- Specify the height to Bottom, which is measured from the selected Elevation Reference to the bottom of the countertop.
The Waterfall Edge settings control whether the selected countertop edge has a waterfall, as well as its attributes. See “Waterfall Countertops” on page 340.

- Check Add Waterfall to Selected Edge to add a vertical extension to the selected edge of the countertop.
- Uncheck Mitre All Waterfall Edges to create butt joints with seams that may be visible in some views where the waterfall meets the horizontal countertop and any adjacent waterfall edges. When checked, these joints are mitered so the only visible seams are located at the corners.
- When Automatic Height is checked, the waterfall builds down to the floor height countertop’s room, or the default floor height for the current floor if it is not in a room. Uncheck this to specify the waterfall’s vertical height, below.
- Specify the Height from Counter Bottom, measured from the bottom of the horizontal countertop to the bottom of the waterfall.

A preview of the selected cabinet displays on the right side of the panel. See “Dialog Preview Panes” on page 32.

Polyline Panel
The POLYLINE panel states the length of the countertop’s Perimeter, its Area, and its Volume. See “Polyline Panel” on page 177.

Selected Line/Arc Panel
The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. For more information, see “Line Panel” on page 168.

Moldings Panel
The settings on the MOLDINGS panel allow you to apply an edge profile to the selected countertop. For information about these settings, see “Moldings Panel” on page 356.

Line Style Panel
For information about the settings on this panel, see “Line Style Panel” on page 169.

Fill Style Panel
The settings on the FILL STYLE panel affect the appearance of the selected countertop in plan view. For information about these settings, see “Fill Style Specification Dialog” on page 115.

Materials Panel
The settings on the MATERIALS panel affect the appearance of the selected countertop in 3D views. For information about these settings, see “Materials Panel” on page 542.

Components Panel
The information on the COMPONENTS panel can be used in the materials list. For more information, see “Components Panel” on page 692.

Custom Backsplash Specification Dialog
Select a Custom Backsplash and click the Open Object edit button to open the Custom Backsplash Specification dialog.

Structure Panel
• Click the Edit button to open the Backsplash Layers Definition dialog. See “Material Layers Definition Dialogs” on page 538.

• Uncheck Cut Finish Layers of Parent Object to fix the selected Custom Backsplash to the surface of its parent wall. When checked, it cuts into the finish layers of the wall and replaces those layers with its own within its perimeter.

Polyl ine Panel

The POLYLINE panel states the length of the backsplash’s Perimeter, its enclosed Area, and its Volume. See “Polyline Panel” on page 177.

Selected Line/Arc Panel

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. See “Line Panel” on page 168.

The SELECTED ARC panel is available when the selected edge has been converted into an arc. See “Arc Panel” on page 174.

See, too, “Selected Edge” on page 123 and “Change Line/Arc” on page 147.

Line Style Panel

For information about the settings on this panel, see “Line Style Panel” on page 169.

Components Panel

The information on the COMPONENTS panel can be used in the materials list. For more information, see “Components Panel” on page 692.
The electrical plan shows the location of all electrical objects such as lights, switches, outlets, smoke detectors and vent fans. Basic wiring diagrams show which objects share circuits and the locations of the controlling switches.

Electrical objects can be displayed in 2D and 3D views. Some electrical light fixtures also add light sources to 3D views. See “Lighting” on page 585.

Usually, the electrical plan is one of the last additions to a plan since the position of most electrical objects is determined by the location of walls, cabinets and other objects.

**Building requirements vary throughout the country and around the world. It is your responsibility to comply with local codes.**

**Chapter Contents**

- Electrical Defaults Dialog
- The Electrical Tools
- Placing Electrical Objects
- Auto Place Outlets
- Creating Wiring Schematics
- Electrical Library Content
- Displaying Electrical Objects

**Electrical Defaults Dialog**

Default Settings for electrical objects control which symbols are placed in the current plan when the Electrical Tools are used. It can be accessed by selecting Edit> Default Settings or by doubleclicking the Electrical Tools, 110V Outlet, 220V Outlet, Light, or Switch toolbar button. See “Default Settings” on page 57.

Default heights and other attributes of individual objects can be overridden in the Electrical Service Specification dialog. See “Electrical Service Specification Dialog” on page 369.
The Default Library Objects are the objects created using the Electrical Tools. Select an item in the scrollable list to see and edit its settings.

- The name of the object shown in the preview image displays here.
- Select an item in the Default Library Objects list and click the Library button to select a new default object from the library. See “Select Library Object Dialog” on page 522.
- Click the Edit button to open the specification dialog for the selected object. Any changes you make in the specification dialog are saved with the plan as long as the selected object is not replaced. See “Electrical Service Specification Dialog” on page 369.

Default Heights - Specify the heights at which electrical outlets and switches are initially placed when the 110V, 220V, or Switch tools are used.

- Check Use Default Heights to apply the default heights specified here to electrical objects placed in plan view using the Electrical Tools. When this is unchecked, electrical objects use the height saved with their symbol. See “Placing Library Objects” on page 521.
- Outlet - Specify the default height for outlets, and phone, cable and tv jacks.
- Switch - Specify the default height for switches, doorbells and thermostats.
- Above Base Cabinet - Specify the default height for switches and outlets placed above base cabinets in plan view, as measured from the countertop. See “Adjusting Electrical Object Heights” on page 369.
- On Cabinet Side - Specify the default height for switches and outlets placed on the sides of cabinet boxes, measured relative to the side of the cabinet in question. See “Placing Electrical Objects” on page 366.

A preview of the selected object displays here. See “Dialog Preview Panes” on page 32.

---

The Electrical Tools

Select Build> Electrical to access the Electrical Tools.

Most electrical objects are easily created with a single click in plan and camera views. See “Click-to-Create” on page 103.
Some electrical objects are designed to be inserted into walls, floors, ceilings or cabinets, although some can also be free-standing. See “Placing Electrical Objects” on page 366.

The Electrical Tools place objects according to the settings in the **Electrical Defaults** dialog.

Different outlet, switch, and light fixture symbols can be placed in different room types. To take advantage of the program’s capabilities, define room types properly before placing electrical objects. See “Room Types” on page 227.

Once created, outlets, switches, and lights can be selected and edited. See “Editing Electrical Objects” on page 368.

### Outlets

Select **Build> Electrical> 110V Outlet** to place 110 volt duplex outlets on walls, the on floor, and on the sides of cabinets and soffits. Select **Build> Electrical> 220V Outlet** to place 220 volt outlets.

The type and height of an outlet will vary depending on where it is placed. For example:

- In rooms defined as Bath or Master Bath, Ground Fault Circuit Interrupt (GFCI) outlets are placed.
- An outlet placed at the back of a base cabinet in plan view is positioned above the counter.
- An outlet placed at the back of a base cabinet containing a kitchen sink is placed at the standard 11 1/2” (300 mm) above the floor.
- An outlet placed on the side of a cabinet or soffit will be positioned 32” (800 mm) up from that object’s bottom.
- An outlet placed outside the building or in an exterior area such as a deck or porch will be weatherproof.

If standard outlets are placed in a room prior to defining it as a Bath, you should replace them with GFCI outlets.

Switches placed from the Electrical Library do not automatically update by default, but can be specified to do so. See “Electrical Service Specification Dialog” on page 369.

### Switches

Select **Build> Electrical> Switch** to place electrical switches on walls or on the sides of cabinets or soffits. Like outlets, the height of switches is measured from the floor to the center of the object.

- A switch placed on the side of a cabinet or soffit will be positioned 32” (800 mm) up from that object’s bottom.
- Switches placed outside the building or in an exterior area such as a deck or porch will be weatherproof.

If you connect two or more switches in a circuit, they update to 3-way or 4-way switches automatically.

Switches placed from the Electrical Library do not automatically update by default, but can be specified to do so. See “Electrical Service Specification Dialog” on page 369.

### Auto Place Outlets

Select **Build> Electrical> Auto Place Outlets** and click in a room tool to place outlets at regular intervals around the entire room. See “Auto Place Outlets” on page 366.

### Connect Electrical

Select **Build> Electrical> Connect Electrical**, then click and drag to draw splines that snap to electrical switches, outlets, and lights to
illustrate wiring circuits. See “Creating Wiring Schematics” on page 367.

**Lighting and Electrical Library Catalogs**

A selection of free-standing and ceiling-, wall- and cabinet-mounted light fixtures is available in the Library Browser at Home Designer Core Catalogs> Architectural> Lighting.

Special use outlets, switches, jacks and numerous other electrical items can be found at Home Designer Core Catalogs> Mechanical, Electrical, Plumbing> Electrical. See “The Library” on page 509.

---

**Placing Electrical Objects**

Electrical switches, outlets, lights, and other symbols can be created with a single click in any view. They can also be placed from the Library. See “Click-to-Create” on page 103.

When the Outlet, Switch, and Light tools are used, the type and height of the object that is created will vary depending on where it is placed. As you move your mouse pointer around the view, an object preview will display near the pointer whenever it is over a location where an object can be placed. Specific details for each tool are noted in “The Electrical Tools” on page 364.

The electrical objects in the Library are typically designed for a specific use and can only be placed on a wall, on the floor, or on the ceiling. Some are instead free-standing and are designed to be placed on a table or the floor. See “Placing Library Objects” on page 521.

Wall mounted outlets, switches, and Library symbols can also be placed on the sides of cabinets and soffits. They will snap to the outside of the cabinet box or to the outside of Side or Back Panels, but will ignore doors and drawers.

When a light fixture is created using any method, including copying and pasting, it will always be turned On. This is the case even if the default symbol is turned Off. See “Light Data Panel” on page 371.

---

**Electrical Object Heights**

When a wall-mounted electrical object is placed in plan view using one of the Electrical Tools, its initial height off the floor is based on settings in the Electrical Defaults dialog. See “Electrical Defaults Dialog” on page 363.

Wall mounted electrical symbols placed directly from the Library derive their initial heights from specification settings saved with each object. See “Electrical Service Specification Dialog” on page 369.

Similarly, cabinet-mounted electrical objects are placed using height information set in either the Electrical Defaults dialog or the symbol’s specification dialog. If the default height is higher or lower than the cabinet it’s being placed on, the electrical object will be placed along the top or bottom edge of the cabinet box.

In 3D views, an electrical object placed on a wall in a 3D view will snap to its default height provided that the mouse pointer is near that height when you click. If you move the mouse pointer away from the default height, the object will be positioned wherever you click on the wall, regardless of the height at that point.

---

**Auto Place Outlets**

Select Build> Electrical> Auto Place Outlets and click in a room to place 110 volt outlets on the walls around the entire room, spaced so that no wall position is farther than six feet (1800mm) from the nearest outlet. 110 or 220 volt outlets are also placed behind large appliances. In addition, a light is placed above each sink.

Outlets and sink lights are placed based on settings in the Electrical Defaults dialog. See “Electrical Defaults Dialog” on page 363.

It is important that a room’s Type be defined before Auto Place Outlets is used so that outlets are placed appropriately. For example, GFCI (Ground Fault Circuit Interrupter) outlets are placed over
Creating Wiring Schematics

Electrical schematics can be created in two ways. Using the Connect Electrical tool is quick and easy, but if you need detailed schematics, you can create your own wiring diagrams using the CAD tools. See “CAD Objects” on page 161.

Connect Electrical

Select Build > Electrical > Connect Electrical, then click and drag to draw splines that snap to electrical switches, outlets, and lights to illustrate wiring circuits. See “Splines” on page 180.

To create a new circuit or add to an existing circuit, click on a switch, outlet, or light while the Connect Electrical tool is active, drag to the next object and release. You can also draw electrical circuits using the Alternate continuous drawing mode. See “Alternate” on page 120.

When a Connect Electrical spline is first drawn, it looks like an arc but actually consists of two segments that are defined by vertex points. When selected, its edit handles display at each of these vertices. If you click and drag one of these edit handles, the length, angle, and curvature of the spline will change but the other vertices will not move.

To remove a connection from a circuit, simply select and Delete it. If you remove an electrical object from a circuit, any Connect Electrical splines snapped to it will also be deleted. See “Deleting Objects” on page 157.

Three- and Four-Way Switches

Multiples switches can control an object or group of objects.

• Two switches controlling the same objects are referred to as three-way switches.
• Three switches controlling the same objects are called four-way switches.

In plan view, a three- or four-way switch’s “way” number will automatically display in its 2D symbol.
Electrical Library Content

Select View> Library Browser to access a variety of electrical symbols. See “The Library” on page 509.

Browse for electrical objects such as bath vent fans, an electrical panel, fluorescent lights, chandeliers, a smoke detector, thermostat, and more. Select a symbol, then click in your plan to place it on a wall, floor, or ceiling.

You can specify which electrical object in the library is used by each of the Electrical Tools. See “Electrical Defaults Dialog” on page 363.

You can also assign electrical objects from the library to toolbar buttons for easy access and placement to frequently-used library objects. See “Place Library Object Button” on page 523.

Adding Electrical Content

Any electrical symbol placed into a plan can be customized and added to the User Catalog in the Library Browser. See “Add to Library” on page 517.

Displaying Electrical Objects

The display of electrical objects and connections is controlled in the Layer Display Options dialog. See “Layer Attributes” on page 110.

When displayed in 3D views, light fixtures act as sources of light that help illuminate the 3D model. See “Lighting” on page 585.

In Plan View

In plan view, electrical objects are represented by commonly used CAD symbols that represent the type of object rather than its appearance in 3D.

Like other objects, electrical objects are placed in Drawing Groups that affect whether they display in front of or behind other objects in plan view. You can modify a selected object’s place in the drawing order by clicking the View Drawing Group Edit Tools edit button. See “Drawing Group Edit Tools” on page 114.

Electrical symbols are placed on the “Electrical” layer, while Connect Electrical splines are drawn on the “Electrical, Connections” layer.

Electrical Labels

Electrical labels display in plan view when the “Electrical, Labels” layer is turned on and use the Text Style assigned to their layer. See “Object Labels” on page 285.

Customized labels can be specified in the Electrical Service Specification dialog.

Note: Some electrical objects are represented in plan view by a symbol that includes text. This text is not part of the object’s label and does not use the Text Style assigned to the “Electrical, Labels” layer.

In the Materials List

Electrical objects, including outlets, switches, lights, and symbols from the library such as jacks and fans, are listed under the Electrical Category in the Materials List. Connect Electrical splines are 2D objects only, however, and are not calculated. See “Materials Lists” on page 681.

As with other objects, there are a number of ways to control how, or whether, electrical objects are included in the Materials List. See “Organizing Materials Lists” on page 684.

You can add and edit information about an electrical object’s accessories and sub-accessories in specification dialog. See “Components Panel” on page 692.

Editing Electrical Objects

Electrical objects can be selected as a group and individually in 2D and 3D and edited using the edit
handles, the edit toolbar and their specification dialog. See “Electrical Service Specification Dialog” on page 369.

Light fixtures and Added Lights can be group-selected, but their light data cannot be edited unless each has the same number of light sources. See “Lighting” on page 585.

Lights can also be edited using the Adjust Lights dialog. See “Adjust Lights Dialog” on page 588.

Moving Electrical Objects Using Dimensions

Electrical objects can be moved precisely using dimensions. See “Moving Objects Using Dimensions” on page 263.

By default, electrical objects are not located by dimension lines as the lines are drawn. Once created, though, you can edit a dimension line’s extensions to locate the center of any electrical object. See “Editing Extension Lines” on page 261.

In order to locate electrical objects by a dimension line as it is being drawn, first check the box beside Dimensions on the LOCATE OBJECTS panel of the Dimension Defaults dialog. See “Locate Objects Panel” on page 252.

Using the Edit Handles

The edit handles for electrical objects vary depending on the location of the object.

- Wall mounted electrical objects cannot be rotated, so only the Move edit handle displays.
- Electrical objects placed on floors and ceilings can be rotated.
- In 3D views, some ceiling mounted and free-standing light fixtures can be resized.
- Electrical connections are edited like splines. See “Editing Spline-Based Objects” on page 138.

Using the Edit Tools

A selected electrical symbol can be edited in a variety of ways using the buttons on the edit toolbar. See “The Edit Toolbar” on page 29.

In the Specification Dialog

Electrical objects can be edited in the Electrical Service Specification dialog. See “Electrical Service Specification Dialog” on page 369.

Adjusting Electrical Object Heights

When a wall- or cabinet-mounted electrical object is placed, its initial height is based on settings in the Electrical Defaults dialog. See “Placing Electrical Objects” on page 366.

Once placed, a wall-mounted electrical object’s height can be edited in three ways:

- Specify the height in the Electrical Service Specification dialog. See “General Panel” on page 370.
- In 3D views, the position of an electrical object can be adjusted using its edit handles.
- In any view, use the Transform/Replicate Object tool. See “Transform/Replicate Object Dialog” on page 151.

Deleting Electrical Objects

An electrical object can be deleted by selecting it and clicking the Delete edit button or by pressing the Delete key.

All electrical objects in a room, on a floor, or in the entire plan can also be deleted as a group using the Delete Objects dialog. See “Deleting Objects” on page 157.

Electrical Service Specification Dialog

Select one or more electrical objects and click the Open Object edit button to open the Electrical Service Specification dialog. The settings in this dialog vary, depending on the type of object(s) you select. This dialog can also be accessed by clicking the Edit button in the Electrical Defaults dialog. See “Electrical Defaults Dialog” on page 363.

The Electrical Service Specification dialog has six panels:

- General Panel
- Light Data Panel
- Materials Panel
- Label Panel
General Panel

The items on this panel vary, depending on the type of electrical object selected.

1. The **Name** of the selected object as used in the Library Browser and Materials List displays here.

2. Specify the **Position** of the selected electrical object. The options available depend on the type of object selected.
   - Specify the **Offset From Ceiling** of a ceiling outlet or ceiling mounted light. If the light is mounted to a cabinet, this value is the offset from the cabinet.
   - Specify the **Height to Center** of a switch, wall outlet or wall light.
   - Specify the **Offset From Floor** of a floor outlet or floor lamp.
   - Specify the **Distance From Wall** of a wall mounted symbol. A negative value will recess the symbol into the wall and may prevent it from being seen in 3D.

3. Specify the **Size** of the selected electrical symbol.
   - Specify the **Height**, **Width** and **Depth** of the selected symbol.
   - Uncheck **Retain Aspect Ratio** if you would like to modify one of the above values without affecting the others. Doing so may cause the symbol’s shape to become distorted. This check box does not affect editing performed outside of this dialog and is an action rather than a state: the next time you open this dialog, it will be checked.
   - Click the **Reset** button to restore the electrical symbol’s original size.

4. **Options -**
   - Check **Reverse Symbol** to reverse the object’s appearance so that features on its left are located on its right and vice versa. Does not affect symmetrical symbols.
   - Check **Automatically Change Switch Type When Wiring** for a selected switch to become a three- or four-way switch if your wiring plan uses it as such. This setting is not available when the dialog is accessed via the Electrical Defaults dialog. See “Connect Electrical” on page 367.

Switches placed from the toolbar use this option by default; switches placed from the library do not.

5. Any **Copyright** information associated with the selected symbol will be stated here.
A preview of the selected object displays here. See “Dialog Preview Panes” on page 32.

**Light Data Panel**

The LIGHT DATA panel is available when the selected electrical object is a light fixture. The available options vary depending on the type of light selected.

The settings on this panel are similar to those on the same panel of the **Light Specification** dialog. See “Light Specification Dialog” on page 589.

1. Each fixture can have multiple **Light Sources**, listed here. Not available for Added Lights. See “Lighting” on page 585.
   - Select a **Light Source** assigned to the selected light fixture from the drop-down list. The selected light source can be edited using the settings on this panel.
   - Click **Add Light** or **Delete Light** to add or delete light sources from the list. If the selected fixture has only one light source, Delete Light will not be available.

2. Specify the **Light Characteristics** of the currently selected Light Source.
   - Select either **Point Light** or **Spot Light** as the light **Source Type**. The Type determines which options are enabled below. See “Light Types” on page 586.
   - Select an **Intensity** from the drop-down list. The available options are described using lumens and correspond to commonly used light bulb wattages. You can also use the text box or spin controls to make fine adjustments to the Intensity value. When a non-standard value is specified, the Intensity is described as “Custom Lumens”.
   - Click the **Color** bar to define the color of the selected light source. Colored lights alter the appearance of textures and can be used to achieve special effects. See “Select Color Dialog” on page 117.

   ![Diagram of Light Data Panel](image)

   - The default color of light is pure white, which has the least affect on the appearance of material colors and textures.

   - The Angle and Drop Off Rate settings below are only available for Spot Lights.
     - The **Tilt Angle** controls the angle of the illumination with respect to the horizon. A value of -90° points the light straight down and a value of 90° points it straight up. 0° is parallel to the horizon.

3. **Offset**
   - **From Base**: 9°
   - **X Position**: 0°
   - **Y Position**: -6°

4. **Options**
   - **On**
   - **Casta Shadows**
   - **Show Position in Camera View**

5. **Illustration of Light Source**

The default color of light is pure white, which has the least affect on the appearance of material colors and textures.
• The **Direction Angle** defines the direction of the illumination relative to the ground. 0° is measured horizontally pointing to the right. Positive values rotate in a counter-clockwise direction from there. Enter a value up to 360°. If you enter a negative value, the program adds 360° to it when you click OK or press the Tab key.

• The **Cut Off Angle** controls the angle of the cone of illumination for Spot Lights only. A cone angle of 180° creates a spot light that shines in a half sphere on one side of the light source. A small cone angle, for example 10°, creates a very narrow cone of light.

• The **Drop Off Rate** affects how fast a Spot Light’s intensity drops off from the center of the cone to the outside edge.

A value of 0 produces a cone of light with the same intensity from the center to the outside edge and a sharp distinction between lit areas within the cone and unlit areas outside of it. As this value is increased, the light intensity decreases closer to the edge of the cone and the distinction between lit and unlit areas becomes softer. Only available for Spot Lights.

• The **Offset** settings control the location of the selected Light Source relative to the fixture.

• **From Base** controls how far the light source is from the fixture base. The fixture base is determined by the surface that it is attached to (i.e. wall, floor, or ceiling).

• **X Position** and **Y Position** allow you to position the light source relative to the center of the fixture, along the floor/ceiling.

• Additional **Options** that affect how the selected light source behaves are available.

• **Check On** to use the light source in camera views, or uncheck it if you prefer that the light source not be used. See “Lighting” on page 585.

• **Casts Shadows** controls whether or not the light source casts shadows in camera views. See “Shadows” on page 583.

• Check **Show Position in Camera View** to indicate the position of a selected Point or Spot Light source in the preview pane and in 3D views when it is turned On. This tool can be used to determine if your light source is positioned correctly. See “In 3D Views” on page 587.

A preview of the selected object displays here. The selected light source’s Position in Camera View will display in all views except Plan View if the light source is On. See “Dialog Preview Panes” on page 32.

### Materials Panel

The **Materials** panel is found in the specification dialogs for a variety of objects. For more information, see “Materials Panel” on page 542.

### Label Panel

Labels for electrical fixtures display in plan view when the “Electrical, Labels” layer is turned on and use the Text Style assigned to that layer. See “Electrical Labels” on page 368.

For information about the settings on this panel, see “Label Panel” on page 286.

### Components Panel

The information on the **Components** panel can be used in the materials list. For more information, see “Components Panel” on page 692.

### Object Information Panel

The information entered on the **Object Information** panel can be used the materials list. For more information, see “Object Information Panel” on page 693.
Chapter 19: Foundations

There are three foundation types in Home Designer Pro: stem walls with footings, grade beams on piers, and monolithic slab. All three can be generated automatically or manually. The foundation type can be specified in the **Foundation Defaults** dialog when the foundation is built on Floor 0.

There can be only one foundation level in a plan, Floor 0; however, foundation structures can be drawn on any floor using the Foundation and Slab Tools.

---

**Foundation Defaults**

- There are several defaults dialogs that affect the foundation. They can be accessed by selecting **Edit > Default Settings**.

  Select “Foundation” and click the **Edit** button to open the **Foundation Defaults** dialog.

  If a foundation has been built and you are on Floor 0, select “Floor” and click the **Edit** button to open the **Floor 0 Defaults** dialog. The settings here are initially drawn from those in the **Foundation Defaults** dialog. See “Floor Defaults Dialog” on page 387.

  Click the + beside “Walls” to display the subheadings, then select “Foundation Wall” and click the **Edit** button to open the defaults dialog for the Foundation Wall tool. See “Wall, Railing, and Fencing Defaults” on page 184.

**Foundation Defaults Dialog**

The **Foundation Defaults** dialog allows you to specify stem wall height, slab thickness, sill plates, and other characteristics of a foundation. These values determine how a new foundation is generated as well as the sizes for manually drawn foundation walls added to an existing foundation.

The settings in the **Foundation Defaults** dialog are similar to those in the **Build Foundation** dialog.
which opens when **Build > Floor > Build Foundation** is selected. The primary difference is that when you click **OK** in the **Foundation Defaults** dialog, no changes are made to the model. See “Building a Foundation” on page 376.

### Foundation Panel

1. Check **Auto Rebuild Foundation** to automatically rebuild the foundation whenever changes are made to Floor 1 that affect the structure of the foundation. See “Rebuilding Foundations” on page 378.

2. Three different **Foundation Types** can be created in Home Designer Pro. Each type of foundation has different default settings, options, and behaviors. Select the radio button next to the desired type.
   - Select **Walls with Footings** to produce a foundation composed of stem walls with footings that run continuously under the base of the walls.
   - Select **Grade Beams on Piers** to generate a pier and grade beam foundation. The floor framing rests directly on top of the grade beams.
   - Select **Monolithic Slab** to build a slab foundation defined by slab footings. The foundation forms the floor platform for Floor 1. It is visible on Floor 0 and can be selected and edited.

3. **Slab** -
   - Check **Hang 1st Floor Platform Inside Foundation Walls** to produce stem walls that build up to the top of the floor platform of Floor 1. When unchecked, the stem walls build to the bottom of the floor platform, which bears on top of them. Only available when Walls with Footings is selected, above.
   - Check **Show “S” Markers on Step Foundation** to include an “S” symbol in plan view anywhere there is a step in foundation wall height. Not available when Grade Beams on Piers is selected, above. See “Displaying Foundations” on page 377.

4. **Slab Options** -
   - Specify the **Slab Thickness**, which is the thickness of the slab produced above the footing or at the top of the stem wall.
   - Check **Slab at top of Stem Wall** to raise the slab so its top is flush with the top of the stem walls.
Only available when Walls with Footings is the selected Foundation Type.
If Slab at top of Stem Wall is selected, all rooms on the first floor are automatically set to Floor Supplied by the Foundation Room Below in the Room Specification dialog. See “Structure Panel” on page 242.

Stem Walls -
- The name of the Default Foundation Wall Type displays here for reference.
- Click the Edit Default Foundation Wall button to open the Foundation Wall Defaults dialog and change the default settings for foundation walls. See “Foundation Walls” on page 189.
- If Monolithic Slab is the selected Foundation Type, the Edit Garage Curb button will be available. Click it to open the Foundation Wall Defaults dialog and define the walls that form curbs around Garage and Slab rooms.
- Specify the Minimum Height, which is the minimum height for foundation stem walls and grade beams and includes the sill plates.
- The Basement Ceiling Height displays here as a reference. This is the distance from the top of the slab floor to the basement ceiling and is equal to the Minimum Wall Height minus the Slab Thickness.

If the Minimum Wall Height is at least 76” (1900 mm), a Ceiling Finish is added to the foundation room automatically. A slab floor is also generated above the footing. The ceiling height and finish can be changed later. See “Room Specification Dialog” on page 240. To remove this slab, specify the room areas in the basement as “Open Below”. See “Room Types” on page 227.

The Piers options are only available when Grade Beams on Piers is the selected Foundation Type.
- Specify the Width, Depth, and Maximum Separation of the piers.
- Choose either Round or Square piers.

Garage Options -
- Specify the Garage Floor to Stem Wall Top, which is the distance between the slab and the tops of the stem walls in both Garage and Slab rooms. Available for Walls with Footings and Grade Beams on Piers foundation types. See “Foundation Defaults” on page 373.

- Specify the Lower Garage Floor height, which is the distance that Garage and Slab room floors are lowered when a Monolithic Slab foundation is built. This value is also the height of the curbs around these rooms. See “Garages” on page 380.
- Specify the Minimum Garage Stem Wall Height, which is the minimum height that stem walls defining a Garage foundation will be, regardless of the Minimum Stem Wall Height for the rest of the foundation.

Options Panel
The OPTIONS panel allows you to include rebar and other materials related to the foundation in the Materials List. See “Materials Lists” on page 681.

Some options on this panel may be unavailable depending on the foundation type selected on the FOUNDATION panel.
Specify the **Rebar** used in the major foundation components: **Footing**, **Wall Horizontal** courses, **Wall Vertical** courses, **Pier**, and **Slab**. Rebar and mesh are calculated in the Materials List provided that the wall or footing they are associated with is the “Concrete” Structure Type; but, they do not display in any 2D or 3D views of the model. See “The Materials List Tools” on page 681.

- **Bars per Course** - Specify the number of bars of rebar to be used per course for each foundation component.
- **Course Spacing** - Define the spacing for Vertical and Horizontal Wall courses, and for Slabs. If slabs are to have rebar instead of mesh, this spacing value applies to both directions.
- **Rebar size** - Define the rebar size in 1/8th inches. 4 represents 4/8, or ½ inch.
- Specify the **Overlap** where sticks of rebar meet, in terms of the rebar’s **Diameter**. A value of 40.0, for example, equals 40 times the Rebar Size.
- Check **Use Mesh** to reinforce the slab floor with mesh instead of rebar, or uncheck it to use rebar.

**Foundation Options** - Select either **Foam Seal**, **Termite Flashing**, or both. These options are added to the Materials List, but do not display in the model.

---

**Building a Foundation**

Foundations can be generated automatically or drawn manually. A combination of the two methods can also be used.

Three foundation types are available: stem walls with footings, grade beams on piers, and monolithic slabs. The first two options are created using walls; the last creates concrete slabs with footings.

Automatically built foundations are placed on Floor 0 and are based on wall positions and floor heights on Floor 1. Foundation walls or slab footings are generated under:

- All exterior walls on Floor 1 that define a room other than a Deck type room. See “Room Definition” on page 225.
- Any interior walls on Floor 1 defining rooms with different floor heights. See “Floor and Ceiling Heights” on page 235.

At least one room must be defined on Floor 1 for a foundation to be automatically generated. If no rooms are defined on Floor 1, a blank Floor 0 is created.

There can be only one Floor 0 per plan. If your plan requires a foundation on more than one floor, you will need to draw the required foundation walls or slabs yourself.

**To build an automatic foundation**

1. Select **Build > Floor > Build Foundation**.
2. Specify the desired foundation type and other information in the **Build Foundation** dialog. The settings in this dialog are similar to those in the Foundation Defaults dialog. See “Foundation Defaults” on page 373.
3. In the New Floor dialog, select Derive new Foundation plan from the 1st floor plan and click OK to build a foundation based on Floor 1. If you prefer, you can instead select Make new (blank) plan for the Foundation to create an empty foundation level where you can manually draw foundation walls or slabs.

In most cases, it is preferable to base Floor 0 off the first floor plan and then manually edit the foundation as needed. See “Editing Foundations” on page 378.

Mixing Foundation Types

You can also create a foundation that combines stem walls, grade beams and piers, and/or monolithic slabs.

To create a foundation of multiple types

1. Begin by specifying any rooms on Floor 1 that require a slab floor as either a Garage or Slab Room Type. See “Foundations and Rooms” on page 380.

2. Alternatively, or in addition, you can specify any rooms on Floor 1 as having a Monolithic Slab Foundation. See “Structure Panel” on page 242.

3. Build Foundation, as described above.
   - If the foundation will include any grade beams and piers, specify Grade Beams on Piers as the Foundation Type and build the foundation.
   - If the foundation will include a combination of stem walls and slabs, specify Walls with Footings as the Foundation Type.

4. Once the foundation walls have been generated, they can be moved or deleted, and new Foundation Walls and/or Slabs can be drawn. See “Foundation Walls” on page 189 and “The Slab Tools” on page 382.

Openings in Foundation Walls

Any doors placed in walls around a Garage will receive cutouts in the garage stem wall or curb. The width of that cutout can be specified in the Door Specification dialog. See “General Panel” on page 296.
In 3D Views

In 3D views, all objects on Floor 0 will only display when the “Foundation” layer is turned on.

While the display of foundation walls and their footings can be controlled independent of one another in plan view, in 3D views this is not the case. If a foundation wall is set to display, its footing will as well - even if the “Footings” layer is turned off. The reverse is also true - if a foundation wall’s display is turned off, so will its footing’s.

The display of monolithic slab foundations in 3D views is controlled by the “Foundation” layer. Slab footings are located on the “Walls, Foundation” layer; but if this layer is turned off, any slab footings that define a foundation room will continue to display as long as the “Foundation” layer is on.

In the Materials List

The materials that make up foundation walls, footings, and slab floors are listed under the Foundation category in the Materials List, including:

- Concrete for walls, slabs, and footings
- Rebar for walls and footings
- Rebar or mesh for slabs

Other objects relevant to foundations can be found in these categories:

- **Exterior Trim** - Lists slabs drawn with the Slab tools that are located outside of a structure.
- **Interior Trim** - Lists slabs drawn with the Slab tools that are located inside of a structure.

See “Materials Lists” on page 681.

Editing Foundations

Stem wall with footings, wall with piers and monolithic slab foundations are all created using walls which enclose room areas.

- Foundation walls can be selected and edited much like other walls. See “Editing Walls” on page 200.
- Footing size can be changed on a wall by wall basis. See “Footing Width and Height” on page 379.
- Foundation rooms can also be selected and edited like other rooms. See Foundations and Rooms.

Rebuilding Foundations

By default, foundations do not update automatically when changes are made to the structure on Floor 1. For example, if exterior walls are moved or floor platforms are raised or lowered, the foundation must be rebuilt.

You can direct the program to rebuild an automatically generated foundation whenever changes are made on Floor 1 that affect the foundation by checking **Auto Rebuild Foundation** in the **Foundation Defaults** dialog. See “Foundation Panel” on page 374.

You can also rebuild an automatically generated foundation by selecting **Build > Floor > Build Foundation** from the menu.

When **Auto Rebuild Foundation** is enabled, walls cannot be edited, manually drawn or deleted on Floor 0. When the foundation is rebuilt, any manually drawn or edited walls are deleted. Similarly, rooms on Floor 0 cannot be edited while this option is enabled. If you try to draw a wall or edit a room or a wall while **Auto Rebuild Foundation** is turned on, a warning message will display.

Changing Foundation Types

When a foundation is generated, the program creates Floor Defaults settings for Floor 0 based on the information in the Build Foundation dialog. If you specify a Monolithic Slab foundation, the default Floor Structure on Floor 1 will also be changed to a slab rather than a framed platform. See “Floor Defaults Dialog” on page 387.

If you rebuild the foundation using a different Foundation Type, it is advisable to check the floor heights of all rooms on Floor 1 - particularly Garage and Slab rooms, as well as any rooms that do not use the default floor height of 0”.

To avoid unexpected results, it is recommended that you not change the Foundation Type once the foundation is built.
Stem Wall Height

When a foundation is created, all of Floor 0 uses the stem wall height specified in the Foundation Defaults dialog.

This height is measured from the bottom of floor platform of Floor 1 to top of the stem walls’ footings. If Floor 1 has multiple floor platform heights, the foundation stem walls will be stepped.

Once a foundation is created, stem wall heights can be adjusted either on a room-by-room basis or for individual walls.

To change a room’s stem wall height

1. Select a room on Floor 0 and click the Open Object edit button.
2. Specify the desired Stem Wall Height in the Room Specification dialog. See “General Panel” on page 240.
3. If you wish to reduce the Stem Wall Height, you will first need to reduce the Ceiling Height value by the same amount.

If adjacent rooms have stem wall heights that differ by at least 1/16 of an inch, the stem wall separating them uses the larger of these two values.

In 3D views, individual stem walls can be selected and edited. In most cases, this method should only be used for stepping the bottom of the foundation wall. See “Stepped Walls and Footings” on page 207.

Footing Width and Height

Foundation Wall footings derive their Width and Height from in the Foundation Wall Defaults dialog. Once a Foundation Wall is created, its footing can be adjusted in its specification dialog. See “Foundation Panel” on page 217.

Stem wall footing heights can also be edited in 3D views just as the rest of the stem wall can. Slab footing heights, on the other hand, cannot be adjusted in 3D.

You can specify whether stepped stem walls have vertical footings on the Foundation panel of the Foundation Wall Defaults and Specification dialogs.

Interior Footings

Slab foundations often have interior footings: to support posts, for example. Home Designer Pro does not generate interior footings automatically, but you can easily draw them using the Slab tool. See “The Slab Tools” on page 382.

To create an interior footing

1. Select Build> Slab> Slab, then click and drag to draw a slab on Floor 0. This slab will serve as a footing.
2. Select the slab and click the Open Object edit button.
3. In the Slab Specification dialog, specify the desired Height and Thickness. See “General Panel” on page 383.
   • The Height should be set so that it meets the bottom surface of the monolithic slab above.
4. Use the edit handles, dimensions and/or the Reference Display to position the slab at the desired location.

Aligning Foundation Walls

By default, foundation walls and slab footings will align with walls on the floor above along the outside surface of the Main Layer of both wall types. See “Wall Type Definitions” on page 208.

If there is only one layer for both the stem wall and the first floor wall above it, the exterior surfaces of the walls align. The footing is centered on the stem wall.
Deleting Foundations

Select **Build > Floor > Delete Foundation** to delete the entire foundation floor.

You can also select and delete individual foundation walls and slabs by clicking the **Delete** edit button or pressing the Delete key. See “Deleting Objects” on page 157.

Deleting and rebuilding the foundation is often the quickest way to update the model when substantial changes are made to Floor 1 after the foundation is built.

Foundations and Rooms

When a foundation plan is created, rooms included in the Living Area calculation generate a stem wall, grade beam, or slab foundation below them. Garage rooms generate slab foundations, but exterior rooms such as Decks, Courts and Balconies do not generate any foundation. See “Room Types” on page 227.

Interior foundation walls are not generated unless:

- They separate the area under a Slab or Garage room from the rest of the plan;
- They separate the area under a room specified as having a slab foundation from the rest of the plan;
- They define areas under rooms with different floor heights.

**Note:** To remove all or part of the concrete slab in the basement area, select a basement room and define it as Open Below in the Room Specification dialog.

Garages

When a foundation is generated based on the floor plan of Floor 1, a room on the first floor specified as either a Garage or Slab type will receive a stem wall or pier foundation with a slab floor and stem walls. If a monolithic slab foundation is generated, the room will receive a slab floor with curbs.

An opening placed in a wall defining a Garage will receive a cutout in the stem wall or curb that displays in plan view on the floor below provided that the stem wall or curb’s Main Layer has a Concrete or Brick material type.

The width of the concrete cutout can be defined and you can specify whether the cutout displays in the **Door** or **Window Specification** dialog. See “Framing Panel” on page 305.

By default, a room on Floor 1 specified as a Garage or a Slab will be assigned a lower floor height when the foundation is built. The amount that it is lowered depends on the foundation type:

- The floor height will drop the default thickness of the floor platform for Floor 1 plus 12” (300 mm) in a Walls with Footings or Grade Beams on Piers foundation.
- The floor height will drop 3 1/2” (88 mm) in a Monolithic Slab foundation.

These values are set in the **Foundation Defaults** dialog. See “Foundation Panel” on page 374.

**To build a Garage slab with stem walls**

1. Before the foundation is generated, specify the room as a Garage or Slab.
2. Build an automatic Wall with Footings or Grade Beam on Piers foundation.

In the Floor 1 Garage’s **Room Specification** dialog, **Floor Supplied by the Foundation Room Below** will now be checked. See “Structure Panel” on page 242.

By default, the program produces a 4” (100 mm) slab and 24” (600 mm) high stem walls around the garage. These stem walls are drawn on Floor 0, use the Default

**To build a Garage slab with curbs**

1. Before the foundation is generated, specify the room as a Garage or Slab.
2. Build an automatic Monolithic Slab foundation, specifying the required Lower Garage Floor value.

By default, the program produces a 4” (100 mm) slab and 3 1/2” (88 mm) high curb around the garage. The curbs are drawn on Floor 0, use the Default
Foundations and the Terrain

Home Designer Pro automatically raises the structure in a plan a set distance above the terrain. See “Terrain Height vs Floor Height” on page 638.

In a plan with a foundation present, the terrain will be:

- 6” (187 mm) below the top of the stem walls or grade beams in a Walls with Footings or Grade Beams on Piers foundation.
- 8” (200 mm) below the top of the slab in a Mono-lithic Slab foundation.

By default, the program will also create a flattened pad under the building footprint.

Not all foundations have these requirements, of course, so you can customize your foundation and terrain to suit your needs.

Daylight Basements

Daylight basements, also referred to as look-out basements, have walls that are tall enough for basement windows to be positioned above the terrain. They are often found in split level or split entry structures.

To create a daylight basement condition, build a stem wall foundation and modify these settings in the Terrain Specification dialog:

- Uncheck Auto Calculate Elevation.
- Increase the Building Pad Elevation, which is the distance between the default floor height of Floor 1 and the terrain.

Walkout Basements

Walkout basements are a type of daylight basement typically located on sloped terrain. They feature walls that are above ground at the lower end of the slope so that a door can be positioned above the terrain at that end.

To create a walkout basement, build a stem wall foundation and modify these settings in the Terrain Specification dialog:

- Uncheck Flatten Pad.
- Uncheck Auto Calculate Elevation.

You will also need to create sloped terrain and adjust the Building Pad Elevation and/or terrain data so that the terrain is at the appropriate height relative to the structure at both the high and low ends of the slope.
Stepped Foundations

Stepped foundations are usually built on sloping terrain. A stepped foundation will be produced automatically if more than one floor height is present on Floor 1 when the foundation is built.

In plan view, steps in stem wall and monolithic slab foundations are represented using S markers. See “Displaying Foundations” on page 377.

As with a walkout basement, you will need to build a stem wall foundation and modify these settings in the Terrain Specification dialog:

- Uncheck Flatten Pad.
- Uncheck Auto Calculate Elevation.

You will also need to create sloped terrain and adjust the Building Pad Elevation and/or terrain data so that the terrain is at the appropriate height relative to the structure at both the high and low ends of the slope.

You can also create a stepped foundation by editing foundation rooms and walls. See “Stem Wall Height” on page 379.

The Slab Tools

Select Build> Slab to access the Slab Tools.

The Slab Tools are designed for more generic purposes than foundations and should not be substituted for a foundation plan. The settings in the Foundation Defaults dialog do not affect slabs created with the Slab Tools.

Slabs

Select Build> Slab> Slab or Slab With Footing, then either click or click and drag a rectangle to draw a slab. See “Rectangular Polyline” on page 178.

Once created, slabs can be edited like other closed polylines. See “Editing Closed Polyline-Based Objects” on page 133.

A Slab is also created when the Post with Footing tool is used. See “Post with Footing” on page 467.

Piers and Pads

Piers and pads can be manually placed under walls, railings, or beams on any floor. Select Build> Slab> Round Pier or Build> Slab> Square Pad and click in plan view to place a pier or pad.

For information about editing Piers and Pads, see “Editing Piers and Pads” on page 384.

Slabs and the Materials List

If the slab material type is specified as Concrete or Volume, the materials list calculates the total volume of the slab and all footings. See “Define Material Dialog” on page 550.

Editing Slabs

Slabs can be selected in 2D and 3D views both individually and as a group and can be edited using the edit handles, the edit toolbar, and the Slab Specification dialog. See “Slab Specification Dialog” on page 383.

Using the Mouse

Slabs can be edited like other closed-polyline base objects in both 2D and 3D views. See “Editing Closed Polyline-Based Objects” on page 133.

Using the Edit Tools

One or more selected Slabs can be edited in a variety of ways using the buttons on the edit toolbar. As with most objects, Slabs can be copied, replicated, moved, deleted, etc. See “The Edit Toolbar” on page 29.
Slab Specification Dialog

Select a Slab and click the Open Object edit button to open the Slab Specification dialog.

General Panel

1 Specify the characteristics of the selected Slab.
   • Specify the Thickness, which is the measurement from the slab’s top to bottom surfaces.
   • Select the Elevation Reference, from the drop-down list. This determines where the next two settings are measured from and also affects their setting labels.
   • Specify the slab’s height to Top, which is of its top surface measured from the selected Elevation Reference.
   • Specify the slab’s height to Bottom, which is the height of its bottom surface, measured from the Elevation Reference.
   • When the selected slab is a Post Footing or Deck Post Footing, specify whether it is Square or Round. Not available for manually drawn slabs or if the slab’s shape has been modified using the Change Line/Arc edit tool. See “Post with Footing” on page 467.

2 Specify the characteristics of the selected slab’s Footing.
   • Check Has Footing if you would like the slab to have a footing around the inside of its perimeter.
   • Specify the Height and Width for the footing.
   • Specify the Footing Offset, which is the distance that the footing extends out past the edges of the slab. A value of 0 aligns the outside of the footing with the outside of the slab.

3 A preview of the selected slab displays on the right side of the panel. See “Dialog Preview Panes” on page 32.

Polyline Panel

The POLYLINE panel states the length of the selected slab’s Perimeter, its enclosed Area, and its Volume. See “Polyline Panel” on page 177.

Selected Line Panel

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. For information about the settings on this panel, see “Polyline Specification Dialog” on page 177.

Selected Arc Panel

The SELECTED ARC panel is available when the selected edge is an arc as opposed to a line. See “Change Line/Arc” on page 147.
Line Style Panel

For information about the settings on this panel, see “Line Specification Dialog” on page 168.

Fill Style Panel

The settings on the FILL STYLE panel affect the selected slab’s appearance in plan view. For information about these settings, see “Fill Style Specification Dialog” on page 115.

Materials Panel

For information about the settings on this panel, see “Materials Panel” on page 542.

Components Panel

The information on the COMPONENTS panel can be used in the materials list. For more information, see “Components Panel” on page 692.

Editing Piers and Pads

Round Piers and Square Pads can be selected individually and in groups in 2D and 3D views and edited using their edit handles and edit toolbars.

There are several ways to move piers and pads; however, they must always be positioned under a wall. A pier or pad can only be moved away from the wall it is placed beneath if it is moved to another wall.

Using the Mouse

In plan view, piers and pads can be edited like CAD lines. Three edit handles allow the pier or pad to be resized and moved along the wall it is placed beneath. See “Editing Line-Based Objects” on page 126.

In 3D views, piers and pads can be edited like CAD boxes. See “Editing Box-Based Objects” on page 136.

Using Dimensions

In plan view, piers and pads can also be moved using dimensions. See “Moving Objects Using Dimensions” on page 263.

Using the Edit Tools

A selected pier or pad can be edited in a variety of ways using the buttons on the edit toolbar. As with most objects, piers and pads can be replicated, moved, deleted, etc. See “The Edit Toolbar” on page 29.

Library Fireplaces

A variety of fireplace symbols are available in the library. Flush fireplaces are designed to snap to wall surfaces. Some fireplace symbols can be enclosed by walls or positioned to project through a wall. See “Placing Library Objects” on page 521.

If you move a foundation wall or beam, any piers or pads it contains will move with it.

Always check the manufacturer’s product information for the framing and clearance requirements of the fireplace unit you plan to use, and design your plan accordingly.
Chimneys

Chimneys can be created using a variety of methods.

**Masonry Fireplace Chimneys**

*To create a chimney on a masonry fireplace*

1. Select the fireplace in a 3D view.
2. Ctrl + drag the top edge of the chimney upward through all the floors and the roof until it is to the desired height. See “Unrestricted Movement” on page 142.
3. When the chimney is approximately the correct height, select the fireplace, click the Open Object edit button, and type in the exact height.

**Chimney Chases and Caps**

There are two ways to draw a chimney chase:

- Place a closed box Geometric Shape or Soffit over the chimney chase, resize it to match, then increase its height either in its specification dialog or in a 3D view using the same method as extending a masonry fireplace.
- Use walls to define the chimney chase as a room area, making sure these walls are aligned between floors. The chimney chase “room” on the uppermost floor should have a much higher ceiling than the other rooms on that floor and should also have no ceiling or roof. See “Room Specification Dialog” on page 240.

A selection of chimney tops is available in the library. In addition, custom chimney caps can be made using Geometric Shapes and/or Soffits. See “Other Objects” on page 533.
Chapter 20: Multiple Floors

When a new plan file is opened in Home Designer Pro, two floor levels are present: Floor 1 and the Attic Floor. You can add more floors whenever you like: up to 5 total. Once created, floors can also be copied and deleted.

Home Designer Pro also supports special floors for foundations and attics. Only one foundation level and one attic can exist in a plan. Foundations are discussed in their own chapter. See “Foundations” on page 373.

Floor Defaults Dialog

There is a Floor Defaults dialog for each floor in a plan file aside from the Attic floor, which can be accessed by selecting Edit> Default Settings. Click the arrow to the left of “Floors and Rooms” to expand the category, then expand the “Floor Levels” subcategory. Select a floor level one or more floor levels and click the Edit button to open the Floor Defaults dialog for that floor. See “Default Settings vs Preferences” on page 57.

- Floor Defaults can also be accessed by double-clicking the Floor Tools parent button.
- In addition, the Floor Defaults button can be added to a toolbars. See “Toolbar Customization Dialog” on page 89.

The Floor Defaults dialog also opens whenever you add a new floor to the plan. See “Adding Floors” on page 388.

The Floor Defaults dialog does not open when you build a foundation; however, the Floor 0 Default settings are created based on the current Foundation Defaults. See “Foundation Defaults” on page 373.

The Floor Defaults dialog is similar to the Room Specification dialog, but controls the default settings for all rooms on the floor in question. The settings here also control the height of individual walls as they are drawn on that floor. See “Room Specification Dialog” on page 240.
Structure Panel

The settings on the Structure panel are similar to those in the Room Specification dialog. See “Structure Panel” on page 242.

Moldings Panel

The settings on the Moldings panel are similar to those in the Room Specification dialog. See “Moldings Panel” on page 506.

Fill Style Panel

The settings on the Fill Style panel are similar to those in the specification dialogs for many objects throughout the program. See “Fill Style Specification Dialog” on page 115.

Materials Panel

The settings on the Materials panel are similar to those in the specification dialogs for many objects throughout the program. See “Materials Panel” on page 542.

Floor Tools

Select Build> Floor to access the floor tools.

Select Build> Floor> Build New Floor to build a new floor. A new floor can be generated based upon the perimeter of the floor below or a blank floor can be created and drawn from scratch. See “Adding Floors” on page 388.

Select Build> Floor> Insert New Floor to insert a new floor below the Current Floor. See “Adding Floors” on page 388.

Choose Build> Floor> Delete Current Floor to remove the Current Floor from the plan. For more information, see “Deleting Floors” on page 391.

Adding Floors

When a new plan file is opened in Home Designer Pro, two floor levels are present: Floor 1 and the Attic Floor. You can add up to 5 total living floors, as well as create a foundation below Floor 1.

Floors can be added whenever you like; and once created, they can also be copied and deleted.

Build New Floor

New floors can be created in plan view as well as in 3D views, and are always added above the top living floor. To create a new floor, select Build> Floor> Build New Floor.

- Derive new 2nd floor plan from the 1st floor plan creates a new top floor with exterior walls generated directly over the exterior walls of the floor below. Wall types and roof directives associated with the walls on the floor below are dupli-
cated; however, interior walls are not. See “Roof Panel” on page 215.

- Check **Move Highest Floor’s Roof Up** to move any roof planes displaying on the highest floor in the plan up one floor when the new floor is created. Roof planes displaying on floors other than the top floor are unaffected. This option is only available if there are roof planes built on the top floor and is not available when **Auto Rebuild Roofs** is enabled. See “Build Roof Dialog” on page 431.

- Check **Step floor/ceiling elevations to match existing floor** to maintain all ceiling heights on the existing floor by stepping floor heights on the new floor to match. Ceiling heights on the new floor also become stepped accordingly. See “Stepped Floor and Ceiling Platforms” on page 237.

- **Make new (blank) plan for the # floor** creates a new top floor that is blank. This option is typically useful only if none of the exterior walls on the new floor will be directly above the exterior walls on the floor below. If you choose this method, it may be helpful to turn on the Reference Floor when drawing walls on the new floor. See “The Reference Floor” on page 393.

When you click OK, the **Floor Defaults** dialog for the newly created floor opens. Make any necessary changes to the floor structure, moldings, or materials and click OK. See “Floor Defaults Dialog” on page 387.

The new floor becomes the Current Floor in plan view. If, however, the new floor is created in a 3D view, the camera remains on its original floor and does not move.

**Insert New Floor**

A floor level can also be inserted beneath the Current Floor in both plan and 3D views.

Begin by going to the floor level you would like to insert a floor under to make it the Current Floor, then select **Build > Floor > Insert New Floor**. See “The Current Floor” on page 392.

- Select **Derive new # Floor plan from the # Floor plan** to insert a new floor below the Current Floor, with exterior walls based on those of the Current Floor.

- Check **Move Highest Floor’s Roof Up** to move any roof planes displaying on the highest floor in the plan up one floor when the new floor is created. Roof planes displaying on floors other than the top floor are unaffected. This option is only available if there are roof planes built on the top floor and is not available when **Auto Rebuild Roofs** is enabled. See “Build Roof Dialog” on page 431.

- **Select Make new (blank) plan** to insert a blank floor below the Current Floor.

**Adding a Foundation**

To add a foundation, select **Build > Floor > Build Foundation**. See “Building a Foundation” on page 376.
In Plan View

In plan view, only one floor can be active for editing at a time. This is referred to as the Current Floor. See “The Current Floor” on page 392.

In addition to the Current Floor, one other floor can be displayed for reference purposes: the Reference Floor. Objects on the Current Floor can snap to those on the Reference Floor, helping you align objects. See “The Reference Floor” on page 393.

Floor and ceiling platforms do not display in plan view. When floor and/or ceiling framing is present, its display can be turned on; however, other components of floor and ceiling platforms like sheathing, drywall, and finish materials, cannot.

In 3D Views

In most 3D views, all floors in a plan are visible, from the foundation up to the attic. There are three exceptions:

• **Orthographic** and **Perspective Doll House Views**, which show the Current Floor, not including its ceiling, plus any floors beneath it.

• **Wall Elevation** views, which show a wall on a single floor, in a single room.

See “3D View Tools” on page 561.

In the Materials List

The materials that make up floor and ceiling platform assemblies are listed under different Categories in the Materials List:

• **Subfloor** - Lists floor framing and structural sub-flooring materials specified in all Floor Structure Definitions in the current plan. See “Floor and Ceiling Platform Definitions” on page 237.

• **Flooring** - Lists flooring and subflooring materials specified in all Floor Finish Definitions in the current plan.

• **Framing** - Lists ceiling framing and any other materials specified in all Ceiling Structure Definitions in the current plan.

• **Wall Board** - Lists ceiling finish materials specified in all Ceiling Finish Definitions in the current plan.

• **Insulation** - Floor insulation is calculated for all rooms that have a floor, and ceiling insulation is calculated for all rooms that have a ceiling - regardless of the Floor or Ceiling Structure Definition. When a ceiling is not present, insulation is calculated for the roof. See “Structure Panel” on page 242.

• **Foundation** - Lists the concrete and mesh for all Floor Structure Definitions in the current plan with a layer of concrete material. See “Materials and the Materials List” on page 547.

See “Materials Lists” on page 681.

Exchanging Floors

Select **Build> Floor> Exchange With Floor Above** or **Exchange With Floor Below** to swap the Current Floor with the floor above or below.

The floor that was moved becomes the Current Floor at its new location. You can easily move a floor up or down several floors by using either one of these buttons repeatedly.

Copying Floors

The **Edit Area** tools can be used to make copies of entire floors in a plan. See “Edit Area Tools” on page 153. You can use these tools to:

• Make a copy of an existing floor to be pasted onto a new floor.

• Make a copy of all existing floors in a plan to be pasted into a different plan.

You can also copy the information on a floor by pressing Ctrl + A (Select All), then using **Copy** and **Paste Hold Position**. See “Paste Hold Position” on page 106.

Copying Between Plans

While you can copy and paste floors from one plan file to another, this is not always the best approach.
Deleting Floors

To make a copy of the plan for backup or your records, use **Save As** to save the file using a new name. See “Saving, Exporting, and Backing Up Files” on page 43.

- To copy the model into another plan with multiple structures, consider exporting it as a symbol and importing it into the new plan. See “Custom Symbols” on page 183.

Rebuilding Walls, Floors and Ceilings

When you make a change to the walls or to the floor or ceiling platforms in your plan, they may not immediately resize or move in the 3D model. The program does detect such changes, though, and the next time you generate a 3D or section/elevation view, walls, floors and ceilings are rebuilt.

By default, walls, floors and ceilings are also rebuilt when an automatic roof is generated. See “Build Roof Dialog” on page 431.

You can direct the program to rebuild walls, floors, and ceilings at any time by selecting **Build> Floor> Rebuild Walls/Floors/Ceilings**.

If you do not want the program to rebuild walls, floors and ceilings when a 3D view is created, uncheck **Auto Rebuild Floors and Ceilings** in the 3D View Defaults dialog. This may speed up plan view editing for very large plans. When this is unchecked and the structure is not up-to-date, the Rebuild Walls, Floors, Ceilings icon displays near your mouse pointer. See “3D View Defaults Dialog” on page 560.

Split Levels

Both split level floor plans and split level entries can be created by controlling the floor and ceiling heights of individual rooms in a multiple story structure.

For more detailed information about both types of structure, visit HomeDesignerSoftware.com.

**Split Level Floor Plans**

A split level, or tri-level, structure is a building where the floor level in one part of the plan is located approximately half way between the floor and ceiling levels of another part of the plan.

**To create a simple split level plan**

1. Draw a simple rectangular structure divided into two separate halves by an interior wall.
2. Select one of the rooms and click the **Open Object** button. See “Room Specification Dialog” on page 240.

3. Raise the **Floor Height** then press the Tab key.

4. Restore the **Relative Rough Ceiling** to the default value, then click OK.

5. Build a stem wall foundation. See “Foundations” on page 373.
   - The foundation under the room with the lower floor height will have the specified Min Stem Wall Height.
   - The foundation under the room with the raised floor will have taller stem walls.
   - Both can be edited in the **Room Specification** dialog.

6. If you add a Floor 2, note that the **Ceiling Height** in the room on Floor 1 will be reset to the default value.
   - To maintain a stepped condition on multiple floors, return to this room and set the **Relative Rough Ceiling** back to using the default.

**Split Level Entries**

A split level entry, or divided entry, is characterized by an entry door that opens onto a landing positioned half way between the basement floor and first floor levels.

To create a simple split level entry

1. Create a plan file with a full basement at the location of the entry door. See “Basement Rooms” on page 381.

2. Go to Floor 0 and draw a stair **Landing** at the location of the entry. See “Landings” on page 403.


4. Draw stairs upward from the basement floor to the landing.

5. Draw a second stair section from the landing upward.

6. Select the stairs and click the **Auto Stairwell** edit button. See “Creating a Stairwell” on page 412.

Split level entries are often associated with daylight basements. See “Daylight Basements” on page 381.

---

**The Current Floor**

In a given plan view window, only one floor level can be active at any given time. The active floor is referred to as the **Current Floor**, and it is the only floor on which objects can be edited.

If you would like to view two different floor levels side by side, open a second plan view, navigate to the desired floor, and then tile the two views. Although both are visible, only one of these view windows is active. See “Working in Multiple Views” on page 94.

**Floor Up / Floor Down**

If you are working with more than one floor, you can select **Tools> Floor/Reference Display> Up One Floor** or **Down One Floor** to switch from one floor to another.

You can change the Current Floor in floor plan, cross section/elevation and 3D views. The Current Floor displays on the **Change Floor/Reference** button, which can be found between the **Down One Floor** and the **Up One Floor** buttons.

Floors become available once they have been built. The Attic and foundation levels are also accessible using these tools.

**Change Floor / Reference**

If there are multiple floors, select **Tools> Floor/Reference Display> Change Floor/Reference** to open the **Change Floor/Reference** dialog, where you can select both the Current Floor and which floor is used in the Reference Floor, as
well as control the appearance of the Reference Floor.

**The Attic Floor**

Home Designer Pro automatically creates a floor above the top numbered floor level of each plan. This floor is called the Attic floor and has only one purpose: to provide a space for automatically generated Attic walls. See “Attic Walls” on page 207.

In some situations, you may find it necessary to draw one or more walls on the Attic floor; however, even if you enclose an area with walls, rooms cannot be created on this floor level. If you wish to create an attic loft or bonus room in your plan, you must do so on a numbered floor level.

Because the Attic floor is not meant to be a living area, a warning message will display if you try to draw walls or other objects on this floor level.

**The Reference Floor**

When a model has more than one floor level, it is often helpful to see how they relate to each other in plan view. Select Tools> Floor/Reference Display> Reference Display to turn on the display of an additional reference floor along with the Current Floor.

Objects on the Current Floor can snap to objects on the Reference Floor; however, objects on the Reference Floor cannot be selected or edited.

If the Reference Floor Display is turned on when a view is printed, it will be included in the printed output. See “Displaying Objects” on page 709.

If the Reference Floor is on when a plan view is sent to layout, it is always on in that layout view and is not affected if it is turned off in the plan. See “Keeping Layout Views Current” on page 699.

When the Reference Floor Display is turned on, the floor level below the Current Floor is used as the Reference Floor. If there is no floor level below, the floor above is used. By default, the Reference Floor displays in red.

Note: When objects on the Current Floor and the Reference Floor align and lines of two different colors are superimposed upon each other, discoloration may result.

**Change Floor / Reference Dialog**

By default, the floor below the Current Floor is the Reference Floor, but any floor can be referenced using the Change Floor/Reference dialog. To open the dialog, select Tools> Floor/Reference Display> Change Floor/Reference or click the toolbar button that reports the current floor level.

When this dialog is accessed from a camera view, only the Current Floor options will be active.

![Change Floor/Reference Dialog](image)

1. **The Current Floor** is highlighted here. Select another floor from the list to make it the Current Floor instead.

2. **The Reference Display** settings are only available in plan view.

Check **Show Reference Floor** to turn on the display of the Reference Floor.

Choose the current **Reference Floor** from the drop-down list. When “Automatic” is selected, the floor level below the Current Floor is always used; if there is no floor below, the floor above is used instead.

3. Click the **Define** button to open the Layer Display Options dialog and change the settings for the Reference Floor Layer Set. See “Layer Sets” on page 113.
**Swap Floor/Reference**

Click the **Swap Floor/Reference** button to move to the floor level shown in the Reference Floor Display, making it the new Current Floor. At the same time, the original Current Floor becomes the Reference Floor.
Staircases can be composed of one or more straight or curved stair sections, ramps, and landings. Stairs and ramps can be drawn, selected and edited in 2D and 3D views.

Starter treads can be defined, stair sections can be flared, treads can be wrapped, and curved sections can be turned into winders.

Landings can be created automatically or manually and their shape customized. You can edit an existing landing, or create a landing from a closed CAD polyline. Landing heights can be defined or you can let them automatically adjust as needed.

Stairwells can be created automatically or manually and can be seen in 3D views.

Chapter Contents
- Stair and Ramp Defaults
- The Stair Tools
- Anatomy of a Staircase
- Drawing Stairs and Ramps
- L- and U-Shaped Stairs
- Displaying Stairs, Ramps, and Landings
- Editing Stairs and Ramps
- Stair and Ramp Sections and Subsections
- Landings
- Maintaining Tread Depth
- Flared Stairs and Curved Treads
- Starter Treads
- Winders
- Wrapped Stairs
- Other Special Railings and Stairs
- Creating a Stairwell
- Rooms Below Staircases
- Staircase Specification Dialog
- Ramp Specification Dialog
- Stair Landing Specification Dialog

Stair and Ramp Defaults

The purpose of interior stairs is to provide passage from one floor platform to another, so the attributes that influence floor heights - including ceiling heights, floor platform thicknesses, and floor finish materials - also influence the structure of stairs. When considering a staircase’s structure, bear in mind that riser height is directly dependent on the distance from one floor platform to another.

When Automatic Heights are used, stairs are built so that they rest on the top of the floor structure of the floor where they are drawn, and build up to the top of the floor structure on the floor above. Risers are measured to the floor finish surfaces on both floors. See “Floor and Ceiling Platform Definitions” on page 237.
Ramps are built in a similar manner: interior ramps bear on the floor structure, and when Automatic Heights are used, the top surface of both interior and exterior ramps locates floor finish surfaces.

The Stair Tools

Select Build > Stairs to access the Stair Tools.

Draw Stairs

To draw a straight staircase select Build > Stairs > Draw Stairs, then click and drag in floor plan or a 3D view. You can also click once to place a staircase that extends from the current floor up to the next floor. See “Drawing Stairs and Ramps” on page 397.

Straight Stairs

Select Build > Stairs > Straight Stairs, then click to create stairs between the current floor and the floor above. To create stairs between two floor platforms on the current floor, click on the low side, within a few feet of where the floor changes height.

• If you click on the low side of a floor platform defined by a railing, a doorway will be created in the railing, adjacent to the stairs.

• If you click on the low side of a floor platform defined by a wall, stairs will be created but a doorway will not.

• If you click at a location that is not near the edge of a floor platform, a full height staircase will be created.

Curved Stairs

Select Build > Stairs > Curve to Left or Curve to Right and click once in plan view to place a curved staircase. See “Curved Stairs and Ramps” on page 398.

L-Shaped Stairs

Select Build > Stairs > L-Shaped Stairs, then click to create two equal stair sections that form a 90° corner and are connected by a landing. See “L- and U-Shaped Stairs” on page 399.

U-Shaped Stairs

Select Build > Stairs > U-Shaped Stairs, then click to create two stair sections that form a 180° turn and are connected by a landing.

Landing

Select Build > Stairs > Landing to draw a landing, which is a platform connecting two or more stair sections. See “Landings” on page 403.

There are two ways to create a landing using this tool:

• Click once to place a landing measuring 39” (975 mm) on each side.

• Click and drag to draw a rectangular landing sized as needed. See “Polylines” on page 176.

You can also create a landing by converting a CAD polyline. See “Convert Polyline” on page 151.

Ramp

Select Build > Stairs > Ramp to draw a sloped ramp. By default, ramps are drawn at a 1:12 slope to a maximum height of 30” (760 mm). See “Drawing Stairs and Ramps” on page 397.

Spiral Stairs

In the Library Browser, browse to Home Designer Core Catalogs > Architectural > Spiral Stairs to access a selection of spiral staircase fixtures. Select the object that you want, then click in any view to place it in the plan. See “The Library” on page 509.

Because spiral staircase symbols are fixture symbols, they do not have an Auto Stairwell edit tool. An opening in the floor above a spiral staircase must be created manually. See “Creating a Stairwell” on page 412.

Anatomy of a Staircase

Stairs as well as ramps are often described in terms of rise and run. Rise is typically between 6” and 8”, and the run between 10” and 12”. In metric plans, rise is 177 to 190 mm, and the run is about 250 mm.

Whenever possible, Home Designer Pro will automatically apply reasonable rise and run values that meet most building codes to stairs and ramps as they are drawn.
In Home Designer Pro, staircases automatically have a consistent rise and run along their length because this is also a typical requirement of most building codes. When this is not desired, however, stairs and ramps can be divided into multiple sections subsections. See “Stair and Ramp Sections and Subsections” on page 401.

**Staircase Terminology**

**Balusters** - The vertical members that run between the handrail and the treads or bottom rail.

**Bracket** - Decorative L-shaped supports on the exposed side of stairs below each tread.

**Landing** - A platform connecting two or more stair sections.

**Newels** - The end post of a stair railing located at landings and the beginnings and endings of new stair sections.

**Rise** - The height of a riser, measured from tread surface to tread surface, Also referred to as Unit Rise.

**Rise Angle** - The angle of the staircase or stair section, defined by a line drawn through the back surfaces of its treads.

**Riser** - The vertical stair member located between the treads. Risers may be solid or open. When open, the front surfaces of the stringers are considered the risers.

**Run** - The depth of a tread, measured from riser surface to riser surface. Run does not include the Tread Overhang. Also referred to as Unit Run.

**Runner** - The carpet that runs down the center of the staircase.

**Shoe** - The bottom railing, placed on the landing floor, that anchors the balusters at landings.

**Stringer** - The inclined support member of a staircase that supports the treads and risers.

**Tread** - The horizontal member of a stair that the foot is placed on.

**Tread Overhang** - The portion of a tread extending past the front surface of the riser and over the tread below. Also referred to as Nosing or Nosing Extension, it is not included in the Run or Tread Depth measurements.

**Tread Thickness** - The vertical depth of the tread material.

**Winder** - A wedge-shaped stair tread used where curved or angled stairways change direction.

**Stair Structure and the Model**

By default, stairs locate the height of the floor platform that they are drawn on and seek the next level, which may be the floor platform of the floor above or a landing. The stringers locate the subfloor of the floor platforms and maintain consistent riser height. If the stairs are long enough to reach the next level at a reasonable rise angle, their tread depth and number of treads are automatically calculated to create a staircase with consistent tread and riser dimensions along its entire length.

You can modify this behavior or turn it off altogether in the Staircase Specification dialog and specify your own rise and run values. Bear in mind, though, that if you turn it off, you will need to specify the correct **Top** and **Bottom Heights** to make sure that the stairs actually meet both floor platforms correctly. See “General Panel” on page 415.

**Drawing Stairs and Ramps**

Stairs and ramps can be drawn in floor plan and 3D views but not in cross section/elevation views. There are a few things to keep in mind when drawing stairs:

- Before stairs are created, make sure that the heights for both the lower and upper floors are correctly defined.

- Stairs are drawn going **UP**, so they should be drawn from the lower of the two floors they connect.

- By default, stairs adjust their riser and tread dimensions to connect two floor heights if possible. The rise and run are calculated so that the steps are consistent in size.

- Stairs drawn within 1” (25 mm) of a wall will snap to the outer surface of the wall.

- Stairs will snap to the **Reference Display** if you have it turned on. See “The Reference Floor” on page 393.

- Hold down the Ctrl key to suppress these snapping behaviors.
• If a stairwell room has been defined on the floor above, the top of the stairs can be dragged until it stops at the railing or wall defining the stairwell.

• When drawing stairs or a ramp up from the terrain, it is a good idea to make sure the terrain is up to date. See “Building the Terrain” on page 647.

**Straight Stairs and Ramps**

The Draw Stairs tool can be used in two different ways:

• Click and drag in a straight line to draw stairs that are the length that you drag.

• Click once to place stairs that go from the current floor up to the height of the next floor level.

You can also click once using the Straight Stairs tool to create stairs between rooms on the same floor with different floor heights or between exterior rooms and the terrain. When the Straight Stairs tool is active, a preview outline of the stairs will follow the mouse pointer. Hold down the Alt key to reverse the direction of the Up arrow in the preview.

Similarly, Ramps can be created by either clicking and dragging or by clicking. A ramp created with a single click will be 30” (760 mm) high, have a slope of 1:12, and be 360” (9120 mm) long.

An individual stair or ramp section must be between 6” (150 mm) and 100’ (30 m) in length. If a greater length is needed, connect two sections using a landing.

**Curved Stairs and Ramps**

You can make a straight stair or ramp section curved, or vice versa:

• Select the stairs or ramp and click the Change Line/Arc edit button. See “Change Line/Arc” on page 147.

• Select the stairs or ramp, hold down the Alt key (or right-click), and drag an end edit handle. See “Alternate” on page 120.

**Drawing Stairs and Ramps Downward**

Stairs and ramps can be drawn from the current floor level downward; however, drawing stairs or ramps between floors in this manner is not recommended. Drawing downward should only be used to create a staircase or ramp between a porch or deck and the terrain when you require the direction arrow to say “DN” instead of “UP”.

To draw stairs going downward

1. Select Build> Stairs> Draw Stairs.
2. Hold down the Alt key or the right mouse button.
3. Click and drag to create straight stairs.

When drawing stairs or ramps from a floor platform to the terrain, or vice versa, they will locate the height of the terrain as long as it is lower than the floor height. You can also create a landing or “room”
outside the structure and use it to establish the bottom height of the stairs or ramp. Then, draw in an upward direction from the lower platform to the upper platform.

L- and U-Shaped Stairs

The L- and U-Shaped Stairs tools allow you to place staircases composed of two stair sections connected by one or more landings with a single click.

The staircases created with these tools build from the current floor to the floor above. If you need a staircase that builds between platforms on the same floor level, or in a downward direction, you will need to draw it manually. See “Landings” on page 403.

When you select either tool, the New Shaped Staircase dialog opens.

New Shaped Staircase Dialog

The settings in this dialog retained between sessions in the software and are global, affecting all plans.

Check Only Show This Dialog on Double Click to suppress this dialog unless the L-Shaped Stairs or U-Shaped Stairs is double-clicked.

- Specify the Default Direction of the stairs as they build upward: Clockwise, or Counterclockwise.
- Check Make Winders to create multiple landings with angled edges between the two stair sections. When unchecked, a single rectangular landing is produced.

1 Check Only Show This Dialog on Double Click to suppress this dialog unless the L-Shaped Stairs or U-Shaped Stairs is double-clicked.

- Specify the Default Direction of the stairs as they build upward: Clockwise, or Counterclockwise.
- Check Make Winders to create multiple landings with angled edges between the two stair sections. When unchecked, a single rectangular landing is produced.

Displaying Stairs, Ramps, and Landings

The display of stairs, ramps, and landings in all views is controlled in the Layer Display Options dialog. Stairs, ramps, and landings are placed on the “Stairs & Ramps” layer. See “Layer Attributes” on page 110.

In Plan View

In plan view, stairs, ramps, and landings display on the floor they were drawn on and are only visible from the floor above if there is a stairwell. See “Creating a Stairwell” on page 412.
Stairs and ramps have an arrow indicating the direction they run. Interior stairs and ramps have an **UP** arrow on the floor they were created on and a **DN** arrow when viewed from the floor above. See “Drawing Stairs and Ramps” on page 397.

The style and size of the direction arrow can be specified in the **Staircase** or **Ramp Specification** dialog. The Text Style, color, and display are controlled by the “Stairs & Ramps, Up/Down Arrows” layer. See “Arrow Panel” on page 171.

When a staircase is selected in plan view, the numbers associated with each of its sections and subsections display. Stair sections are assigned a single number, while subsection numbers have two parts: a section number and subsection number separated by a hyphen.

**Editing Stairs and Ramps**

Staircases and ramps can be selected and edited in plan view and 3D views. See “Selecting Objects” on page 123.

To select a single section of a staircase, hold down the Shift key before clicking on it. When selected in this manner, a stair section can be edited independent of any other connected stair sections.

**Using the Mouse**

When a staircase or ramp is selected, its edit handles display. These edit handles can be used to customize the object in many ways. See “Editing Objects” on page 119.

- Straight stair sections and ramps are edited like lines. They have additional edit handles for resizing the width of the section. See “Editing Line-Based Objects” on page 126.
- Curved stair sections and ramps are edited like arcs and also include edit handles for resizing the stair’s width. See “Editing Arc-Based Objects” on page 128.
- Ramps can be resized to a maximum top height of 30” (760 mm). If you extend a ramp’s length to greater than 360” (9120 mm), its slope will decrease. For a taller ramp and control over the slope, uncheck **Automatic Heights** in the **Ramp Specification** dialog and specify the values you need. See “General Panel” on page 423.
- When stair sections are merged, the edit handles display differently depending on what subsection is currently selected. See “Merging Stair and Ramp Sections” on page 402.
- When moving merged stair or ramp sections, all merged sections and landings move as one unless **Stair Sections Move Independently** is checked in the **Preferences** dialog. To temporarily enable this behavior, hold down the Alt key on the keyboard. See “Architectural Panel” on page 72 and “Alternate” on page 120.
- Additional edit handles display on the first two treads of a staircase if the **Starter Tread** edit button is clicked. See “Starter Treads” on page 407.
- Several additional edit handles display on a staircase if the **Flare/Curve Stairs** edit button has been clicked. See “Flared Stairs and Curved Treads” on page 405.
In the Specification Dialog


Stair, ramp, and landing railings can also be customized. See “Railing Panel” on page 419, and “Newels/Balusters Panel” on page 421.

Using the Edit Tools

A selected staircase or ramp can be edited in a variety of ways using the buttons on the edit toolbar. See “The Edit Toolbar” on page 29.

Adjusting the Radius of Curved Stairs

The easiest way to match the radius of a stair section to the radius of a curved wall is to draw a staircase near one side of the curved wall using the Draw tool. The stairs snap to the wall, and the radius of the new staircase is defined. See “Curved Stairs and Ramps” on page 398.

Existing curved stairs can be aligned with an existing curved wall by aligning their centers, much the same way that curved stairs on different floors can be aligned. See “Aligning Objects” on page 143.

If there is no curved wall, the radius of a stair section can be aligned to a CAD arc or circle.

To align curved stairs to an object

1. Align the centers of the CAD object and the staircase.
2. Select the curved stairs and move the side nearest to the arc or circle edge using the Resize edit handle.

Finally, restore the stair width by dragging from the other side handle or using the Stair Specification dialog.

Stair and Ramp Sections and Subsections

In Home Designer Pro, staircases and ramps can be composed of multiple sections. In addition, each section can be broken into multiple subsections.

• Both sections and subsections can be curved while their neighbors are straight and can have different tread depths.

• Stair sections can also have different tread widths, can be disconnected from adjacent sections using the edit handles, and are usually separated from other sections by landings.

• Subsections both move and rotate as a single object, while sections move with other sections but rotate separately.

You can identify sections and subsections by clicking on a stair or ramp to select it: sections are identified with labels using whole numbers (1, 2, etc), while subsections are identified using hyphens (1-1, 1-2, etc). In addition, when a a stair or ramp is selected, only the selected section will have edit handles.

Creating Stair and Ramp Subsections

There are several ways to create a stair section with multiple subsections:

• Draw one section, then draw a second section that begins at the first one’s endpoint.

• Draw two separate segments, then snap the start point of one segment to the endpoint of the other using the edit handles.

• Draw one segment and use the Break edit tool to divide it into two subsections. See “Break” on page 146.
Creating Stair and Ramp Sections

There are also three ways to create multiple stair sections:

- Draw two separate stair sections and join them using a landing.
- Use the Complete Break edit tool to divide a section into two sections. See “To create a complete break” on page 147.
- Use the Disconnected Selected Section edit tool to change a subsection into a section.

Merging Stair and Ramp Sections

Any combination of straight and curved stair sections or straight and curved ramps using Automatic Heights can be merged. The resulting staircase or ramp section is made up of subsections and, if there are no landings, functions as a single unit.

Stair and ramp subsections must be drawn in the same direction if they are to be merged:

- The top edge of a stair section or ramp cannot merge with the bottom edge of another section or ramp.
- Combinations of stairs drawn in the UP and DOWN directions cannot be merged.

Stair subsections merge at the center points of their upper and lower edges.

Stair sections and ramps cannot be merged directly. If a combination of stairs and a ramp is required, connect them with a landing. See “Landings” on page 403.

To merge stair or ramp sections

1. Confirm that the stairs or ramps that you wish to merge are using Automatic Heights. See “General Panel” on page 415.
2. Position the sections so they are in the desired relationship to each other.
   - In order to merge stair sections correctly, they must be parallel to one another.
   - To create merged subsections that change direction, make one of the merged sections curved and then specify Winders. See “Winders” on page 408.
3. Select either stair or ramp section so that its edit handles display.
4. Click the Extend handle on the end to be merged and drag it to the point where the two stairs or ramps are to meet.

A staircase consisting of merged subsections resembles a single stair section in plan view. The UP (or DN) arrows join, becoming a single direction arrow.

When a subsection is selected, the entire staircase is selected. Additional edit handles, indicating the presence of multiple subsections and allowing you to reposition the line along which they join. See “Using the Mouse” on page 400.

Lock Tread Depth

If a staircase with Lock Tread Depth selected in the Staircase Specification dialog is resized, its length increases or decreases one full tread at a time. See “General Panel” on page 415.

When Lock Tread Depth is checked, it can be difficult to merge the section with another section or landing. If this is a problem, you can temporarily uncheck Lock Tread Depth. After the stairs are merged, the tread depth can be locked again.

Curved Subsections

Stair subsections attached at both ends by other sections do not have a free end that can be dragged into a curve. In this situation, change the middle subsection to a curve using the Change Line/Arc edit button. See “Change Line/Arc” on page 147.

To curve an enclosed stair subsection

1. Draw three straight stair sections and connect them end to end.
2. Select the middle subsection.
Landings

Stair landings are platforms between stair sections and/or ramps, and can be created in either of five ways:

- Click and drag using the Landing tool.
- Single-click using the Landing tool to create a 3’-3” (975 mm) square landing.
- Click between two stair sections using the Draw Stairs tool.
- Convert a closed CAD polyline into a landing. See “Convert Polyline” on page 151.
- One or more landings are also created when the L-Shaped Stairs or U-Shaped Stairs tool is used.

To create a landing between stair sections

1. Draw two stair sections going UP. They can be at any angle.
2. Click between the two sections using the Draw Stairs tool to create a landing. Notice that only one direction arrow displays after the sections are joined by a landing.

Similarly, a landing can be created between two ramps by clicking between them with the Ramp tool active.

Multiple stair sections and/or ramps can be connected to one landing. For example, two or three stair sections might meet at a landing with a single stair section continuing to the next level.

To be linked by a landing, all sections must be drawn in the same UP direction and the top of one section should be near the bottom of the next.

Stair sections connected with a landing will move together as a single unit unless Stair Sections Move Independently is checked in the Preferences dialog. See “Architectural Panel” on page 72.

A landing formed between two stair sections having less than a 90° angle between them are created with a short edge not less than 6” (150 mm). This is because most building codes require the shortest tread to be at...
least 6” wide. This edge can be manually edited to less than 6” if needed.

Adjacent Landings

Some staircases have more than one landing adjacent to one another. When Auto Adjust Height is used, landings in Home Designer Pro recognize other nearby landings and will automatically adjust their heights and railings when their edges are sufficiently close to one another.

To create adjacent landings, draw two landings and then position them so that their edges are within 1” (25 mm) of one another. The landing that was drawn first will maintain its position while the height of the one drawn later will be the equivalent of one riser higher than the first. The railings on adjacent edges are suppressed, as well.

Adjacent landings can be used to represent winders. See “Winders” on page 408.

Editing Landings

Once created, landings can be selected in 2D and 3D views and edited like other closed-polyline based objects. See “Editing Closed Polyline-Based Objects” on page 133.

Landings derive their initial materials, height, thickness, and railings from the stairs and/or ramps attached to them. You can assign a unique railing or material to a landing in the Stair Landing Specification dialog. See “General Panel” on page 425.

When moving a landing, all stair or ramp sections connected to it move as one unless Stair Sections Move Independently is checked in the Preferences dialog. To temporarily enable this behavior, hold down the Alt key on the keyboard. See “Architectural Panel” on page 72 and “Alternate” on page 120.

Landing Height and Thickness

A landing’s height and thickness can either be dynamically controlled by the program or user-defined and static.

By default, landing top height and thickness are both set to Auto Adjust. This means that if the structure of the attached stairs is edited so that their length or riser height is affected, the landing’s height and thickness will adjust automatically to maintain consistent riser height in all connected stair sections.

If you uncheck either Auto Adjust box in the Stair Landing Specification dialog, the landing will maintain the specified height and/or thickness no matter how the attached stairs or ramps are modified. This can result in stairs that have inconsistent risers. See “General Panel” on page 425.

Landing Railings

By default, landings have railings on all edges, but will automatically suppress the railing along any portion of an edge that connects to a stair or ramp section or has an adjacent landing. You can specify whether this automatic behavior is used, the railing is suppressed, or the railing is always applied in the Stair Landing Specification dialog. See “General Panel” on page 425.

You can also suppress the railing on a selected edge by clicking the Remove Railing from Selected Edge edit button. To always generate the railing on a selected edge, click the Add Railing to Selected Edge edit button. See “Selected Edge” on page 123.

Landings can be edited into a wide variety of shapes. So that the railings of stair sections connect properly to the landing railings, you may find it helpful to use the Break edit tool to create a break in a landing edge if it is longer than the connecting stairs are wide. See “Break” on page 146.

Maintaining Tread Depth

Most building codes require staircases to maintain a consistent tread depth.

Walk Line

By default, Home Designer Pro measures a stair section’s length and tread depth along a Walk Line located 12” (30 cm) from the right edge of the stair section. On curved stairs, it is located 12” (30 cm) from the inside edge of the curve.

The distance of the Walk Line from the staircase edge can be specified in the Staircase Specification dialog. See “Style Panel” on page 417.

Alternatively, you can turn the Walk Line feature off and tread depth will be measured at the tread center.
When a curved stair section has **Automatic Treads** specified in the **Staircase Specification** dialog and the Walk Line is used, the number and/or width of treads in a section or subsection changes when the inner edge is moved. For this reason, it is best to finalize stair section width as early as possible.

There are two ways to keep tread depth even throughout a stair section made of multiple subsections.

**Lock Tread Depth**

The first way to maintain tread depth is to **Lock Tread Depth** to a specified value in the **Staircase Specification** dialog. See “General Panel” on page 415.

Once locked, any changes to the length of the stair section are achieved by keeping the specified tread depth and changing the number of treads.

**Ignore Subsection Boundaries**

Curved stair sections typically have treads that are wider on one side than on the other. When they are connected to other stair sections, as with winders, it is possible to have treads that are too narrow at the Walk Line. See “Winders” on page 408.

Uniform tread depth in a stair section with subsections can be maintained by checking **Ignore Subsection Boundaries** in the **Staircase Specification** dialog. See “General Panel” on page 415.

When **Ignore Subsection Boundaries** is checked, the Tread Depth value may change when the stair section is edited, but will remain consistent throughout all subsections.

Because the boundaries between stair sections are being ignored, the treads where a straight section joins a curved section may shift position or change angle to accommodate the adjustment.

---

**Flared Stairs and Curved Treads**

Any stair section can be flared and/or its treads curved using the **Flare/Curve Stairs** edit button.

Only exposed sides of a stair section can be flared. If one side of a stair section is against a wall or wrapped (see “Wrapped Stairs” on page 409), only the exposed end can be flared.

Flaring, curved treads, and special treads should be the last changes that you make to any stairs.

**Creating a Flared Stair**

Flared stairs grow wider near one end, typically sweeping outward at the bottom. Stairs can also be flared at the top or on both ends.
To create flared stairs

1. Create the stairs and connect them to a landing, floor platform edge, or another stair section.
2. Specify the section width, tread depth, and any other needed information.
3. Select the stairs and click the Flare/Curve Stairs edit button. New Flare edit handles display on all four corners of the stairs.
4. Drag one of the corner handles to flare that corner. As you drag the flare, the Status Bar shows the distance the side handle moves. This allows you to move the opposite handle the same amount.
5. When you are finished editing the flare, click the Main Edit Mode to restore the stairs’ regular edit handles and toolbar buttons.

Symmetrically Flared Stairs

Use the dimension information that displays in the Status Bar as a reference to create symmetric flares on both sides.

Creating symmetrically flared stairs

Adjusting the Flare Radius

After a flared staircase has been created, you may want to soften the radius of the flare.

The four handles at the sides and the four handles at the corners flare the stair section when dragged outward. The two handles in the center of the section move the starting point for flaring along the stair section.

To adjust the flare radius

First, adjust the curvature of the flared section.

1. Select the flared stair and click the Flare/Curve Stairs edit button to access the flare handles again.
2. Select the handle along the flared edge of the stair. Drag this handle outward very slightly. This forms a more gradual flare.

Then, adjust the starting point of the flare:

1. Select the flared stair and click the Flare/Curve Stairs edit button to access the flare handles again.
2. This time, drag the lower of the two central handles upward. The handle above it moves with it. This moves the start point for the bottom flare from the middle of the section toward its top, making the flare even more gradual.

Treads Perpendicular to Flare

Flared stairs often look best when the treads curve to meet the flared side perpendicular to the radius.

To curve the edges of flared treads

1. Select the flared stair and click the Flare/Curve Stairs edit button to access the flare handles again.
2. Drag a corner edit handle upward one tread depth or less.
3. When you are finished editing the curve, click the Main Edit Mode to restore the stairs’ regular edit handles and toolbar buttons.

This type of tread curving works only on flared edges and concentrates the curvature at that edge.

Flared treads can also be curved using the Curve edit handle, which curves the treads more uniformly.

**Curving the Treads**

When treads are curved, all treads in the section show some degree of curvature. Treads close to the curved end have a greater curve than those at the opposite end, but both ends can be curved.

**To curve stair treads**

1. Select the staircase, then click the Flare/Curve Stairs edit button.
2. Drag the edit handle at the center of the bottom edge a small distance to curve the treads.
3. When you are finished editing the curve, click the Main Edit Mode to restore the stairs’ regular edit handles and toolbar buttons.

**Starter Treads**

The first and second treads of a staircase can be turned into starter treads by clicking the Starter Tread edit button. Starter treads extend to the side of the staircase, have rounded edges and are common on traditional staircases.

A starter tread can be added only to open sides of a stair section. If one side of a stair section is against a wall or wrapped (see “Wrapped Stairs” on page 409), only the exposed tread end can become a starter tread.
To create starter treads

1. Click on a staircase to select it.
2. Click the Starter Tread edit button. An edit handle displays on each end of both the first and second treads.
3. Drag either of the handles on the first tread outward from the stair section. If the stair section is against a wall, only one handle displays on the side opposite the wall.
4. As you drag, the ends of the tread become rounded.
5. Two additional edit handles display on each side of the tread, along the back edge.
6. Drag either of the two square handles upward to increase the width of the rounded ends of the tread.
7. Drag the edit handle on the second tread outward from the stair section to create a second starter tread.
8. To make changes to existing starter treads, select the stairs, click the Starter Tread edit button and repeat the above steps as needed.
9. When you are finished editing the starter treads, click the Main Edit Mode to restore the stairs’ regular edit handles and toolbar buttons.

Winders

Winders are steps located where a staircase turns and are narrower on the inside of the turn than they are on the outside. A staircase defined as a winder expands to fill in any gaps between the side of the stairs and nearby walls.

Curved stair sections are typically used to create winders, although straight stairs can also be used. See “Curved Stairs and Ramps” on page 398.

To create winders

1. In an enclosed room area, place and connect the stair sections that you want to be winders. For best results:
   - The stairs should be two straight sections connected by a curved section between them;
   - The curved section should be adjacent to a 90° corner, as illustrated.

    It is often easiest to create the staircase configuration in an open space, away from walls, then move it into position in a wall corner before specifying it as Winders.

2. Select the staircase and click the Open Object edit button to open the Staircase Specification dialog.
3. On the General panel, place a check in the Winders check box and click OK.
4. The steps nearest the wall corner adjust their shapes and extend into the corner after the stair is changed to a winder.

Winders extend to nearby walls

4. The steps nearest the wall corner adjust their shapes and extend into the corner after the stair is changed to a winder.

The winders attribute directs the stair section to expand or contract to meet nearby walls, and can also be used to create a partial railing. See “Partial Railings” on page 411.

Winders sometimes have treads that are too narrow at the inside curve. The Ignore Subsection Boundaries option can address this issue. See “Ignore Subsection Boundaries” on page 405.

In situations where the conditions for stair winders cannot be met, you can use adjacent landings. See “Landings” on page 403.

Wrapped Stairs

Check Allow Wrap on the STYLE panel of the Staircase Specification dialog and the selected stairs can be wrapped around the corner of a deck or landing. Curved stairs and stairs with multiple subsections cannot be wrapped. See “Style Panel” on page 417.

Stair sections that wrap around a corner to meet one another must have identical attributes. As a result, edits made to one wrapped stair section apply to all adjacent, wrapped sections.

To wrap stairs around a deck

1. Begin by drawing a deck. See “Decks” on page 234.

2. Use the Straight Stairs tool to place a stair section on each side of the corner around which you want them to wrap.

3. Move the stair sections toward the corner of the deck. When the two sections are sufficiently close to the corner, they will merge to form wrapped steps.

You can also draw stairs down from a deck by right-clicking to draw them or by pressing the Alt key while you drag. See “To draw stairs going downward” on page 398.

To wrap stairs around a landing

1. Use the Draw Stairs tool to create two perpendicular stair sections with top ends that share a corner.

2. Click between them to create a landing.

3. Rotate one stair section 180°.
Other Special Railings and Stairs

Stairs can be customized to meet a variety of needs.

**Solid Railings**

To create a solid rail along a staircase, position a solid Railing against, but not underneath, the stairs. Specify it as **Solid** and that it **Follow Stairs**. See "Rail Style Panel" on page 222.

The solid railing recognizes the adjacent stairs and climbs alongside them.

If any balusters extend beyond the railing, eliminate them by unchecking **Left Railing** or **Right Railing** in the Staircase Specification dialog. See "Style Panel" on page 417.

4. The stairs wrap around the corner. Notice that the Up arrow displays on the most recently edited stair section.

**Fully Housed Stringers with Balusters**

Fully housed stringers with balusters can also be created by positioning a pony wall next to the stairs.

To create fully housed stringers

1. Create a staircase, then select the stairs and click the Open Object edit button.
2. On the **Style** panel of the Staircase Specification dialog, uncheck **Stringer at Wall** and click OK.
3. Draw an **Interior Wall** or **Half Wall** against, but not underneath, the stairs.
4. Select the wall and click the Open Object edit button.
5. On the **General** panel of the **Wall** or **Railing Specification** dialog, make sure **Railing** is checked.
6. On the **Wall Types** panel:
   - Check **Pony Wall**.
• Specify the **Lower Wall Type** as the same interior wall as the upper wall.

• Specify the **Elevation of Lower Wall Top**. This value should equal the stairs’ riser height plus the height above the treads.

7. On the **RAIL STYLE panel**:  
• Check **Follow Stairs**.
• Specify desired **Railing Height**.
• Click OK.

**Partial Railings**

A staircase can be enclosed on one side by a combination of wall and railing.

Partial railings can be created by specifying the stairs as winders and increasing the **Max Tread Contraction** in the **Staircase Specification** dialog. See “Style Panel” on page 417.

The **Max Tread Contraction** defines the largest distance that any section of the stair system is allowed to move inward when the stairs are turned into winders. If any point on the edge of the stairs would have to move inward more than this defined amount in order to locate the surface of the wall, the stairs do not contract and snap to that wall.

To create a partial stair railing

1. Create a staircase and draw an **Interior Wall** against, but not underneath, the stairs.

2. Select the stairs and click the **Open Object** edit button.

3. On the **GENERAL panel** of the **Staircase Specification** dialog, check **Winders**.

4. On the **STYLE panel**, define the **Max Tread Contraction**. If the interior wall is 4” thick, setting this value to 4” should be sufficient.

5. On the **STYLE panel**, increase the **Stringer Bottom** value to enclose the area under the stairs with railings. The best value depends on your stair design.

6. On the **RAILING panel**, remove the check from either **Right** or **Left Railing at Wall**, depending on the position of the stairs and wall in your plan.

7. Click the **Object Snaps** toggle button to temporarily turn off Object Snaps. See “Object Snaps” on page 101.

8. Select the stairs and use the side edit handle to move the edge of the stairs to approximately the middle of the wall.

9. You may need to **Zoom** in on the stairs and wall to move the stair edge.

**Railing Panels**

You can specify panels, including glass panels or cables, as a stair or ramp’s railing in the **Staircase and Ramp Specification** dialogs. See “Railing Panel” on page 419.

**Inset or Middle Railing**

You can use a **Railing** to create inset stair railings or a middle railing.

To use railing panels with stairs

1. Create a staircase and draw a **Railing** under the stairs.
• Make sure that the railing is located entirely within a single stair section.
• Position it so that it is aligned with the left edge.

2. Select the railing and click the **Open Object** edit button. See “Wall Specification Dialog” on page 212.

3. On the **RAIL STYLE** panel of the **Railing Specification** dialog,
   • Select the **Panels** radio button.
   • Check **Follow Stairs**.

4. On the **NEWELS/BALUSTERS** panel, click the **Browse** button to the right of **Panel Type** and select the railing panel you want to use on the stairs, then click **OK**.

5. Select the staircase and click the **Open Object** edit button.

6. On the **NEWELS/BALUSTERS** panel of the **Railing Specification** dialog, uncheck **Left Railing** to prevent the default stair railing from generating in addition to the railing panel.

7. Repeat these steps if you want railing panels under the right side of the stairs, as well.

---

### Concrete Stairs

![Concrete Stairs]

**To make a solid concrete staircase**

1. On the **STYLE** panel of the **Staircase Specification** dialog:
   • Set the **Tread Overhang** to zero.
   • Set the **Tread Thickness** to zero.
   • Uncheck **Open Risers**.

2. On the **STRINGERS** panel, you can also uncheck **Open Underneath** and check **Large Stringer Base**.

### Masonry Stairs

![Masonry Stairs]

**To make a set of masonry stairs**

1. On the **STYLE** panel of the **Staircase Specification** dialog:
   • Set the **Tread Overhang** to zero.
   • Set the **Tread Thickness** to the thickness of the masonry material.

2. On the **MATERIALS** panel, assign the desired masonry material to the “Tread” component and specify the “Riser/Trim” material as concrete.

### Steel Stringer

![Steel Stringer]

**To make a steel stringer with concrete treads**

1. On the **STYLE** panel of the **Staircase Specification** dialog,
   • Check **Open Underneath**.
   • Set the **Tread Thickness** to 2 inches or more.

2. On the **STRINGERS** panel, select **1 Center Stringer**.

3. On the **MATERIALS** panel, specify the “Tread” material as concrete and the “Riser/Trim” material as steel.

---

### Creating a Stairwell

An interior staircase must be located in a stairwell, an opening to the floor above. A stairwell is an **Open Below** room type on the floor above. See “Room Types” on page 227.

If you create a stairwell away from other walls so the **Open Below** is created in the center of another room, connect a wall of the **Open Below** room to another wall using an invisible wall.
Creating a Stairwell Automatically

To create a stairwell that matches the perimeter of a selected staircase, click the **Auto Stairwell** edit button. This button is only available when a living space exists above the staircase. It will not be available if the space above is Open Below or on the Attic Floor.

**Auto Stairwell** automatically creates a room on the floor above enclosed by railings, defined as Open Below in the **Room Specification** dialog, and given a Stairwell room label. This room can be selected and edited like any other room.

Creating a Stairwell Manually

Stairwells can also be created manually.

**To create a manual stairwell**

1. Draw a two-story building. Create the staircase on the first floor.
2. Make the second floor the **Current Floor** and the first floor the **Reference Floor**. See “The Reference Floor” on page 393.
3. Select **Tools> Floor/Reference Display> Reference Display** to show the Reference Floor, including the stairs.
4. On the upper floor, use the **Railing** tool to create a room around the stairs. Use the edit handles to position the railings as needed.
5. Select the railings one at a time and move them into position.
   - When a railing is selected, its bounding box shows the location of the outer surface of the railing’s drywall layer. For best results, this outer surface (which does not display when the railing is not selected) should meet the top edge of the stairs. See “Wall Types and Railings” on page 188.
   - If you prefer, you can also go **Down One Floor** and adjust the top edge of the staircase to snap it to the surface of the railing on the floor above.
6. When the railings are positioned properly, select **Tools> Floor/Reference Display> Reference Display** to turn off the display of the Reference Floor.
7. Click inside the room using the **Select Objects** tool to select it, then click the **Open Object** edit button.
8. On the **GENERAL** panel of the **Room Specification** dialog, select “Open Below” from the **Room Type** list. Click **OK** to close the dialog.
9. Place a **Doorway** in the railing at the top step for an opening.
10. Select the doorway and define a large width in the **Door Specification** dialog. If the doorway is specified wider than the railing, its width adjusts to fit the available space.

Rooms Below Staircases

Rooms such as closets or storage areas are commonly located beneath staircases.
To create a room below a staircase

1. Draw a staircase, select it, and click the Open Object edit button to open the Staircase Specification dialog.
   - If Winders are specified for this staircase, set Max Tread Contraction to 2" on the STYLE panel to allow walls to be built entirely under the staircase.
   - On the FILL STYLE panel, select “No Pattern” so the walls and other objects under the stairs can be seen.

2. On the same floor as the staircase, draw the Interior Walls under them, following their shape.

3. Reposition the walls as needed, making sure that each is entirely under the stairs.

4. The wall at the foot of the stairs should be placed no closer to the bottom than the second step.

5. Add a door and specify the Room Type.

Staircase Specification Dialog

Staircases can be defined with the greatest accuracy in the Staircase Specification dialog. To open this dialog, select a stair section and click the Open Object edit button or double-click a stair section using the Draw Stairs, Straight Stairs, or Select Objects tool.

If a staircase is composed of multiple stair sections, the section that you clicked on to select the staircase is the Selected Section; however, information about all the sections is available and can be edited in the dialog.

It is recommended that all floor heights, ceiling heights and platform thicknesses be established before using the Staircase Specification dialog.
Staircase Specification Dialog

General Panel

1. **Staircase Information** - Structural information about the selected staircase displays here for reference and updates as changes are made on the General panel.
   - The first comment tells whether or not the staircase reaches the next level, which may be a floor platform or locked landing. It also indicates whether its rise angle is either steeper or more shallow than the Best Fit, described below. If **Automatic Heights** is unchecked, this comment instead says “Start and end heights are set manually”.
   - The second comment, **Best fit riser height of ___ requires ___ total risers to reach ___ to next level**, describes the ideal rise and run for the selected staircase. The program defines the Best Fit Riser Height as the riser height closest to 6 3/4" (168.75 mm) that allows the selected staircase to meet the next level precisely. This comment is only active if **Automatic Heights** is checked, below.
   - The total number of stair **Sections**, **Landings**, and **Risers** associated with the selected staircase also display here.

2. **Staircase Information**

   - **Rise Angle** of the currently active stair section also displays here.
   - Click the **Make Best Fit** button to add or remove risers to the Selected Section. Only available when **Automatic Heights** is checked and the staircase does not currently use the Best Fit Riser Height.

3. Make Best Fit will also extend stairs drawn in a downward direction until they reach the terrain. See “Terrain Perimeter” on page 638.

4. A diagram of a sample staircase’s structure displays here for reference, as well.

   - **Advanced Options** apply to all sections and subsections.
   - Select **Automatic Treads** to have the program define the depth and number of stair treads. If the staircase has multiple sections, each may have different tread depths.
   - Select **Lock Tread Depth** to specify the Tread Depth for each stair section, below, and prevent them from changing. When Lock Tread Depth is selected and the length of the stairs is changed, the number of treads will change.
   - Select **Lock Number of Treads** to specify the number of treads in each stair section and prevent it from changing. When Lock Number of Treads
is selected and the length of the stairs is changed, the tread depths will change.

- If multiple staircases or a staircase with multiple sections is selected, **No Change** may be an option as well. Select this to maintain the multiple sections’ individual settings.

- Uncheck **Automatic Heights** if you would like to specify the bottom and top heights of each stair section, as measured from the default floor height of Floor 1, 0” (mm). When checked, the program automatically defines the top and bottom heights by precisely locating floor platforms and landings.

The **Top Height Reference** values control what point on the staircase the Top Height value, below, describes.

- Select **Floor/Landing** for the Top Height value to describe the height of the top tread plus the stated Riser Height.

- Select **Top Riser** for the Top Height value to describe the height of the top riser.

- Check **Ignore Subsection Boundaries** to maintain tread depth throughout a stair section composed of merged subsections, regardless of whether the subsections have different tread depths assigned to them. See “Ignore Subsection Boundaries” on page 405.

- Select **Lock Bottom** to lock the position of the selected stair section’s bottom end to prevent it from moving. Sections and landings below the selected section do not move when you click OK, while those above do move.

- Select **Lock Top** to lock the position of the selected stair section’s top end to prevent it from moving. Sections and landings above the selected section do not move when you click OK, while those below do move.

**Lock Bottom** and **Lock Top** are actions rather than settings. If you make changes to a staircase that will affect its length, first lock either the bottom or top end of the Selected Section to prevent it from moving. The height of the Selected Section’s locked end is not affected by these settings - only its position on the X/Y axis.

The specifications for each stair section and subsection are listed and can be edited here. Up to ten items total can display.

A change in one value usually affects other values. You may need to reposition the staircase after making changes.

- The **Section Number** column identifies the Selected Section and the number of each section of the selected staircase. If **Ignore Subsection Boundaries** is unchecked, subsection numbers are also identified. The radio button to the left indicates which section or subsection is selected. See “Displaying Stairs, Ramps, and Landings” on page 399.

- Define the **Length**, or run, of each section or subsection measured along the Walk Line. The length is equal to the number of treads multiplied by the tread depth. See “Walk Line” on page 404.

When the length of a section changes, other sections and landings in the staircase unit move in response. You can specify whether the bottom or top edge of the Selected Section moves when you resize it by selecting either the Lock Bottom or Lock Top radio button, above.

- Define the **Width** of each section. Only one width can be defined for a section, so all subsections in the same section have the same width. If a section is connected to a landing, its width should equal the length of the landing edge that it connects to. See “Landings” on page 403.

- Specify the **Tread Depth**, or run, of each stair tread in the selected section. To lock this value, check **Lock Tread Depth**, above.

If a landing is created between two stair sections and one of them has locked tread depth, the resulting staircase also has locked tread depth. Any landings or sections connected to this new staircase adjust to meet it and then have locked tread depth as well.

- Define the number of **Treads** in a stair section or subsection. To lock this value, select Lock Number of Treads, above.

- Define the **Bottom Height**, the height of the stair section’s bottom edge. To lock this value, click the radio button to the left of the section’s number, then click the Lock Bottom radio button, above, and click OK.

- Define the **Top Height**, the height of the stair section’s top edge. To lock this value, click the radio button to the left of the section’s number,
then click the Lock Top radio button, above, and click OK.

- Define the **Riser Height**, the height of the risers in each stair section.

- Check **Winders** to specify the Selected Section, including subsections, as winders. See “Winders” on page 408.

A preview of the selected staircase displays on the right side of the panel. If the staircase includes any landings, only the section that was selected when the dialog was opened will display. See “Dialog Preview Panes” on page 32.

### Style Panel

1. Specify characteristics of the staircase **Treads**. See “Anatomy of a Staircase” on page 396.
   - Specify the **Tread Overhang**, which is the distance that each tread overhangs the riser.
   - Specify the **Tread Thickness**.

2. The **Open Options** control whether the selected stairs have open risers or an open underside.
   - Check **Open Risers** to eliminate the riser face under each tread and expose the stringers.
   - Uncheck **Open Underneath** to add a skirt below the staircase along the two sides. It looks like a wall in 3D, but only has a single face. Base molding does not generate along the bottom of the skirt, and doors cannot be placed in it. In most cases, the recommended way to enclose the area beneath stairs is to use walls. See “Rooms Below Staircases” on page 413.
   - Specify the **Side Inset** of the skirt below the staircase. The default value of 0 aligns the skirt with the outside of the surface of the stringers. Only available when **Open Underneath** is unchecked.

3. Specify the attributes of the staircase’s carpet **Runner**. Only available when **Open Risers** is unchecked, above.
   - Specify the **Runner Width**. The default value of 0 does not create a runner.
   - Uncheck **Runner Tucked** to have the runner drop straight down from the tread front to the riser below. This is checked by default.
Winder - Define the Max Tread Contraction, which is the amount a tread’s width may be reduced when it meets a wall. See “Partial Railings” on page 411. This option only takes effect when the stairs are specified as Winders on the GENERAL panel.

Check Use Walk Line to have the program calculate the tread depth based on a Walk Line. Uncheck the box to disable this function. See “Walk Line” on page 404.

• Specify the distance of the Walk Line from Edge. The default value is 12” (300 mm).
• Check Show Walk Line to show the Walk Line in plan view.

Specify the appearance of the staircase where it meets the Top Landing. These options do not affect the edges of landings.

• Check Nosing at Top Landing to produce tread nosing attached to platform edge at the top of stairs.
• Check Riser Surface at Top Landing to produce a riser surface against the platform edge at the top of the stairs. This allows stair risers to match all the way to the top of the platform.

Options -

• Check Automatic Railing Openings to automatically create a doorway opening when the selected stairs are snapped to a railing drawn on the same floor as the stairs. This is checked by default.
• Check Allow Wrap to wrap the selected stairs around the corner of a deck or landing where another, identical stair section is present. See “Wrapped Stairs” on page 409.

A preview of the selected staircase displays on the right side of the panel. If the staircase includes any landings, only the section that was selected when the dialog was opened will display. See “Dialog Preview Panes” on page 32.

Stringers Panel

The settings on the STRINGERS panel affect all sections of a selected staircase.

Stringer Style -

• Click a radio button to specify the number of stringers assigned to the staircase. Select Custom
**Stringers** to enable the Left, Middle, and Right settings below.

- Specify the **Height Above Tread**, measured straight down from the top outer edge of the tread nosing to the top of the stringer. Only available when 2 Closed Side Stringers is selected, above.

- Specify the **Height Below Tread**, measured straight down from the back bottom edge of the tread to the bottom of the stringer. Not available when Custom Stringers is selected, above.

The **Left**, **Middle**, and **Right** settings are enabled when Custom Stringers is selected. For each of these:

- Specify the **Count** for each stringer location. Multiple Left and Right stringers are butted side to side while multiple Middle stringers are evenly spaced between them.

- Specify the **Thickness**, measured horizontally.

- Specify the **Offset** of each stringer from its default location. A positive value offsets the stringer(s) to the right; a negative value offsets them to the left.

- Specify the **Height Below** the treads, measured straight down from the back bottom edge of the tread to the bottom of the stringer.

- Check **Ext** to specify the stringer(s) as Exterior and allow them to extend up past the top of the stair treads.

- Specify the **Height Above** the stair treads, measured straight down from the top outer edge of the tread nosing to the top of the stringer.

- The vertical **Depth** of the stringers is reported here for reference. This value is affected by the Heights above and below the treads, as well as the stairs Rise Angle.

**Railing Panel**

By default, the settings on the RAILING panel also affect the railings on any landings attached to the selected staircase or ramp. See “Landings” on page 403.

This panel is also found in the Ramp and Landing Specification dialogs.
Specify how the **Railing** is applied to the selected staircase.

- **Stair Rail Height** defines the height from tread surface directly over the riser to railing top.
- **Landing Rail Height** defines the height of the landing rail top from the landing surface.
- **Handrail Width** defines the horizontal width of the handrail used by the selected staircase and any attached landings.
- **Railing On** - Select **Left** and/or **Right** to specify placement of railings on stair sections.
- **Railing at Wall** - Select **Left** and/or **Right** to specify the placement of wall railings. Not available for ramps.

- Check **Railing Transitions** on **Left** and/or **Right** to create “gooseneck” connections between stair and landing railings. This option only has an effect when **Rail Passes Over Newel** is checked. Not available for ramps.

- Check **Smooth Transitions** on **Left** and/or **Right** to specify the placement of smooth connections between stair and landing railings. Not available for ramps.

- Check both **Railing Transitions** and **Smooth Transitions** to produce a handrail like this:
Staircase Specification Dialog

2 Style -
- Select **Balusters** to create regularly spaced balusters between larger newel posts.
- Select **Open** to create with only newels posts.
- Select **Open with Middle Rail** to create railings with newel posts and a middle rail.
- Select **Panels** to create railings composed of panels. The panel style is specified on the NEWELS/BALUSTERS panel. See “Newels/Balusters Panel” on page 421.

3 Top/Bottom Rail -
- Check **Include Top Rail** to produce a top rail on the stair railings that receives the top baluster ends and typically acts as a handrail.
- Check **Include Bottom Rail** to place a low rail on the landing surface that receives the balusters ends.

4 A preview of the selected staircase displays on the right side of the panel. If the staircase includes any landings, only the section that was selected when the dialog was opened will display. See “Dialog Preview Panes” on page 32.

Newels/Balusters Panel

The settings on the NEWELS/BALUSTERS panel will also affect the appearance of railings on any landings attached to the selected staircase. See “Landings” on page 403.

These settings are similar to those found on the same panel of the Ramp and Landing Specification dialogs. See “Ramp Specification Dialog” on page 423.
Newels -

- Uncheck Has Newel Posts, to prevent newels from generating in the selected staircase’s railings. When this box is checked, newels are generated and can be edited using the settings that follow.
- Type - Select Square, Round, or newels from the Library. Selecting Library from the drop-down list is the same as clicking the Library button to the right and allows selection of a newel from the library.
- Specify the Width, which is the width or diameter of each newel. For Library newels, this is the width at its widest point.
- Specify the Height, which is the height from the landing surface to the top of the newel. Only available when Rail Passes Over Newel is unchecked below.
- Specify the Offset, which is the amount each newel is offset from the center of the railing.
- Specify the on-center Spacing of the newel posts.

The first three Balusters settings are similar to the Newels options of the same names, above.

- Cut Baluster Top - Each tread normally has two to three balusters, growing longer toward its back. The default is to use the same baluster and cut it off at the bottom to shorten it toward the tread front. Check this box to cut the balusters at the top instead.

Specify the characteristics of the selected railing’s Panels. These settings are only available when the railing Style specified as “Panels” on the Railing Panel.

- Specify the panel’s Thickness.
- Select “Solid” or “Library” from the Type drop-down list.

A preview of the selected staircase displays on the right side of the panel. If the staircase includes any landings, only the section that was selected when the dialog was opened will display. See “Dialog Preview Panes” on page 32.

Rails Panel

The settings on the RAILS panel are similar to those on the RAILS panel of the Wall Specification dialog as well as the MOLDINGS panel of a variety of other dialogs. See “Moldings Panel” on page 506.

By default, the settings on the RAILS panel will also affect the appearance of railings on any landings attached to the selected staircase. See “Landings” on page 403.

Line Style Panel

The settings on the LINE STYLE panel are available for a variety of other objects in the program. For information about these settings, see “Line Style Panel” on page 169.

Fill Style Panel

The settings on the Fill Style panel affect the appearance of the selected staircase in plan view. For information about these settings, see “Fill Style Specification Dialog” on page 115.

Materials Panel

The settings on the MATERIALS panel affect the appearance of the selected staircase in 3D views and are available for a variety of objects throughout the program. For information about these settings, see “Materials Panel” on page 542.

The settings on this panel will also affect the materials applied to any landings attached to the selected staircase. See “Landings” on page 403.

Arrow Panel

The settings on the ARROW panel control the appearance of the selected staircase’s direction arrow in plan view. See “In Plan View” on page 399.

For information about these settings, see “Arrow Panel” on page 171.

Components Panel

The information on the COMPONENTS panel can be used in the materials list. For more information, see “Components Panel” on page 692.
Ramp Specification Dialog

Ramps can be defined with the greatest accuracy using the **Ramp Specification** dialog. To open this dialog, select one or more ramps and click the **Open Object** edit button or double-click a ramp section using the **Ramp** or **Select Objects** tool.

A diagram of a sample ramp’s structure displays here for reference.

**Size** - Specify the **Ramp Length** and **Width**.

Specify the **Heights** of various key locations on the selected ramp.

- Uncheck **Automatic Heights/Slope** to activate the settings below, then specify the height and slope of the ramp.
- Specify the **Top Height**, which is the height of the ramp at its high end.

- Specify the **Bottom Height**, which is the height of the ramp at its low end.
- Specify the **Base Height**, which is the height of the bottom surface of the ramp.

Specify the ramp’s **Slope** by typing its **Rise** value in the first field, and the **Run** value in the second field. See “Anatomy of a Staircase” on page 396.

**Options** -
• Check **Automatic Railing Openings** to automatically create a doorway opening when the selected ramp is snapped to a railing drawn on the same floor as the ramp. This is checked by default.

• Check **Open Underneath** to remove the skirt around the bottom of the ramp so that it has a uniform, sloped thickness that may not reach the floor or terrain at the high end. This is unchecked by default.

• Specify the **Max Thickness**, which is the ramp’s maximum thickness. At the low end of the ramp where it meets the floor or terrain, its thickness may be less than this value.

6 Specify the structure of the ramp’s **Tread**, which an optional surface layer placed over the top of the ramp.

• Check **Has Tread Surface** to apply a top tread surface to the ramp and enable the settings below.

• Specify the **Tread Overhang**, which is the distance the tread surface extends past the ramp’s edges.

• Specify the **Tread Thickness**, which is the tread surface’s vertical depth.

A preview of the selected ramp displays on the right side of the panel. If the ramp is composed of multiple sections separated by landings, only the section that was selected when the dialog was opened will display. See “Dialog Preview Panes” on page 32.

**Selected Line/Arc Panel**

The **SELECTED LINE** panel is available when the selected edge is a line as opposed to an arc. For more information, see “Line Panel” on page 168.

The **SELECTED ARC** panel is available when the selected edge has been converted to an arc. For more information, see “Arc Panel” on page 174.

See, too, “Selected Edge” on page 123 and “Change Line/Arc” on page 147.

**Railing Panel**

The settings on the **RAILING** panel are similar to those on the same panel in the **Staircase Specification** dialog. For more information about these settings, see “Railing Panel” on page 419.

By default, the settings on this panel will also affect the appearance of railings on any landings attached to the selected ramp. See “Landings” on page 403.

**Newels/Balusters Panel**

The settings on the **NEWELS/BALUSTERS** panel are similar to those on the same panel in the **Staircase Specification** dialog as well as the **MOLDINGS** panel of a variety of other dialogs. See “Moldings Panel” on page 506.

By default, the settings on this panel will also affect the appearance of railings on any landings attached to the selected ramp. See “Landings” on page 403.

**Rails Panel**

The settings on the **RAILS** panel are similar to those on the **RAILS** panel of the **Staircase Specification** dialog for a variety of other objects in the program. For information about these settings, see “Line Style Panel” on page 169.

**Fill Style Panel**

The settings on the **FILL STYLE** panel affect the appearance of the selected ramp in plan view. For information about these settings, see “Fill Style Specification Dialog” on page 115.

**Materials Panel**

The settings on the **MATERIALS** panel affect the appearance of the selected ramp in 3D views and are available for a variety of objects throughout the program. For information about these settings, see “Materials Panel” on page 542.

The settings on this panel will also affect the materials applied to any landings attached to the selected ramp. See “Landings” on page 403.

**Arrow Panel**

The settings on the **ARROW** panel control the appearance of the selected ramp’s direction arrow in plan view. See “In Plan View” on page 399.

For information about these settings, see “Arrow Panel” on page 171.
Components Panel

The information on the COMPONENTS panel can be used in the materials list. For more information, see “Components Panel” on page 692.

Stair Landing Specification Dialog

Select a landing and click the Open Object edit button to open the Stair Landing Specification dialog. See “Landings” on page 403.

General Panel

1. **Landing** -

Uncheck **Auto Adjust Height** to specify the selected landing’s Top Height.

- A free-standing interior landing will have a default Top Height equal to one riser plus the thickness of the default floor finish. A free-standing exterior landing will have a default top height equal to its thickness. When this box is checked, the landing height may adjust as needed to maintain consistent riser height in all connected stair sections, ramp sections, or adjacent landings.

- The **Top Height** field is only active when Auto Adjust Height is unchecked. See “Landing Height and Thickness” on page 404.

Note: A network of adjacent landings can only be created when Auto Adjust Height is checked. See “Adjacent Landings” on page 404.

Uncheck **Auto Adjust Thickness** to specify the selected landing’s **Thickness**.

- A free-standing landing will have a default thickness of 6 3/4" (169 mm). When checked, the thickness is based on the riser height of the stair sections it is attached to, or the thickness of the ramps it is attached to.

- The **Thickness** field is only active when Auto Adjust Thickness is unchecked.

Specify how railings are applied to the landing’s **Selected Edge**. See “Selected Edge” on page 123.

- Select **Automatic** to suppress the railing on any portion of the selected edge that either connects to a stair or ramp section or has an adjacent landing, but to produce a railing where that is not the case. See “Landing Railings” on page 404.

- Select **No Railing** to suppress the railing on the selected edge of this landing.

- Select **Has Railing** to produce a railing along the selected edge, even where it connects to a stair or ramp section or has an adjacent landing.

- Check **Apply to All Edges** to apply your selection to all edges of the landing. This is an action rather than a state - the next time this dialog is opened, this box will be unchecked.
A preview of the selected landing displays on the right side of the panel. See “Dialog Preview Panes” on page 32.

Polyline Panel

The POLYLINE panel states the length of the landing’s Perimeter, its enclosed Area, and its Volume.

The settings on this panel are available for a variety of other objects in the program. See “Polyline Panel” on page 177.

Selected Line/Arc Panel

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. For more information, see “Line Panel” on page 168.

The SELECTED ARC panel is available when the selected edge has been converted to an arc. For more information, see “Arc Panel” on page 174.

See, too, “Selected Edge” on page 123 and “Change Line/Arc” on page 147.

Railing Panel

The settings on the RAILING panel are similar to those on the same panel in the Staircase Specification dialog. For information about these settings, see “Railing Panel” on page 419.

There is one setting that is unique to the Landing Specification dialog:

Uncheck Use Connected Stair or Ramp Railing to enable the settings on this panel and the NEWELS/BALUSTERS panel. When checked, the selected landing derives all railing settings from the connected stairs or ramp.

If the selected landing is not connected to a stair or ramp, this checkbox will be named Use Default Interior or Exterior Stair Railing, depending on where the landing is located.

Newels/Balusters Panel

The settings on the NEWELS/BALUSTERS panel are similar to those on the same panel in the Staircase Specification dialog. For more information, see “Newels/Balusters Panel” on page 421.

By default, the settings on this panel will also affect the appearance of railings on any landings attached to the selected ramp. See “Landings” on page 403.

Line Style Panel

The settings on the LINE STYLE panel are available for a variety of objects throughout the program. See “Line Style Panel” on page 169.

Fill Style Panel

The settings on the FILL STYLE panel affect the appearance of the selected landing in plan view. See “Fill Style Specification Dialog” on page 115.

Materials Panel

When a landing is attached to stairs or a ramp, its initial materials are derived from the stairs or ramp. When the landing is attached to a ramp, its top surface material is defined by the Landing Sides component unless the ramp is using a Tread material.

The settings on this are available for a variety of objects throughout the program. For information about these settings, see “Materials Panel” on page 542.

Components Panel

The information on the COMPONENTS panel can be used in the materials list. For more information, see “Components Panel” on page 692.
Home Designer Pro’s manual and automatic Roof Tools allow you to draw almost any roof style. Proficiency with the Roof Tools can only be attained through practice, but mastering these tools saves you time and effort in plan development. For information about creating specific roof styles, see “Roof Tutorial” on page 48 of the User’s Guide.

Automatic vs. Manual Roofs

Home Designer Pro can create just about any roof style. Most common roof styles such as hips and gables can easily be generated automatically. See “Roof Tutorial” on page 48 of the User’s Guide.

More complex roof styles, including curved roof planes, can be created manually. The manual roof tools allow you to create any roof system that can be represented using roof planes.

Automatically Generated Roofs

The quickest and easiest way to create a roof over a structure is automatically. By default, a roof plane is generated over each exterior wall, creating a hip roof. The program automatically joins the roof planes at ridges, hips, and valleys and tries to create roof planes that join together to form a single, integrated system. See “Automatic Roofs” on page 430.
Any deviations from the default hip roof can be specified on the ROOF panel of the Wall Specification dialog for any exterior wall. Here, you can specify a Full Gable Wall, High/Shed Gable Wall, or other options instead of a default hip roof. You can also specify a different overhang, pitch, an upper pitch, and the elevation where the upper pitch begins for the roof plane that rests on the selected wall. See “Roof Directives in Walls” on page 205.

When you need the roof planes over an area of a plan to be entirely separate from those over the rest of the structure, you can assign those areas to a non-default Roof Group. See “Roof Groups” on page 430.

Roofs can also be automatically generated based on a Roof Baseline Polyline. When a Roof Baseline Polyline is used, information that determines where and how roof planes are generated is contained in the Roof Baseline Specification dialog. See “Roof Baseline Polylines” on page 445.

Bay, bow, and box windows also produce roof planes automatically. For information about these windows and the roof styles that can be used with them, see “Bay, Box, Bow Windows and Roofs” on page 330.

Manually Drawn Roofs

Any roof system that can be created automatically can also be created manually. Each roof plane is drawn and edited individually, offering full control over the process and limiting the possibilities only to your imagination.

Note: You cannot manually draw or edit roof planes when Auto Rebuild Roofs is enabled in the Build Roof dialog. See “Roof Panel” on page 432.

Using Both Techniques

Another useful option is to start with an automatically generated roof and use manual design techniques to finish it. Using both automatic roof generation and the manual roof drawing and editing techniques, you can quickly design highly customized roof systems.

Roof Defaults

Select Edit> Default Settings, to open the Default Settings dialog for a variety of drawing tools, several of which directly affect roof generation.

Roof Defaults Dialog

The Build Roof and Roof Defaults dialogs are nearly identical in appearance and function. The only difference is that the Build Roof dialog has a number of checkboxes that allow you to automatically generate roof planes and related objects. See “Build Roof Dialog” on page 431.

If changes are made to the settings in this dialog after the roof has been built, you will need to rebuild the roof in order for your changes to take effect.

Roof Framing Defaults

Default settings for framing can be specified in either the Build Roof, Framing Defaults, or the Framing Defaults dialog. Framing defaults control the depth of roof planes as well as the depth of floor and ceiling platforms, which influence roof plane heights. See “Framing Defaults” on page 463.

To create roof planes of a particular depth, begin by setting up the desired roof framing defaults, then build the roof. If you later need to change the structure of the roof planes, make the needed change to the Framing Defaults, and then rebuild the roof. You can also edit the structure of individual roof planes.

Floor and Ceiling Heights

The initial heights of floors and ceilings, which influence roof heights, are specified in the Floor Defaults dialog for each floor. See “Floor Defaults Dialog” on page 387.

The floor and ceiling heights in individual rooms also influence roof heights and are specified in the Room Specification dialog. See “Structure Panel” on page 242.

If Auto Rebuild Roofs is checked in the Build Roof dialog and you change floor or ceiling heights, floor or ceiling platform depths, wall positions or roof directives in walls, the roof rebuilds to reflect your changes. See “Rebuilding Roofs” on page 431.

Wall Specification Dialog

By default, when an automatic roof is built, a roof plane is generated over each exterior wall, creating a hip roof.
Any deviations from this default hip roof, such as a gable or a different pitch, can be specified in the **Wall Specification** dialog for any exterior wall. See “Roof Panel” on page 215.

**Dormer Defaults**

The settings in the **Dormer Defaults** dialog determine the initial settings for automatic dormers and are much like those in the **Dormer Specification** dialog. See “Dormer Specification Dialog” on page 458.

The **Dormer Defaults** dialog can be opened from the **Default Settings** dialog or by double-clicking either of the **Auto Dormer** tools.

---

**The Roof Tools**

Select **Build> Roof** to access the Roof Tools.

**Build Roof**

Select **Build> Roof> Build Roof** to open the **Build Roof** dialog, specify the settings for automatically generated and manually drawn roof planes as well as manually drawn ceiling planes, and build or rebuild a roof. See “Build Roof Dialog” on page 431.

When roofs are automatically generated, a roof plane is created over each exterior wall by default, resulting in a hip roof, and the program tries to join them together to form a single, integrated system.

To automatically generate a roof plane using values other than the defaults or to not generate a roof plane bearing on a particular wall (as with a gable or the sides of a shed roof), you can change the settings in the **Wall Specification** dialog. See “Roof Panel” on page 215.

For more information about creating different roof styles, see “Roof Tutorial” on page 48 of the User’s Guide.

**Roof Plane**

Select **Build> Roof> Roof Plane** to draw a roof plane manually. See “Roof Planes” on page 436. You can also double-click the **Roof Plane** button to open the **Build Roof** dialog.

Note: You cannot use the Roof Plane tool when Auto Rebuild Roofs is enabled in the Build Roof dialog. See “Manually Drawn Roofs” on page 428.

**Ceiling Plane**

Select **Build> Roof> Ceiling Plane** to draw a ceiling plane manually. Ceiling planes are drawn and behave much like roof planes. See “Ceiling Planes” on page 448.

**Gable/Roof Line**

Select **Build> Roof> Gable/Roof Line** to draw a gable line that generates a gable along a baseline edge when roofs are automatically generated. See “Gable/Roof Lines” on page 451.

**Skylight**

Select **Build> Roof> Skylight**, then draw a rectangle over an existing roof plane to create a skylight. The skylight, skylight shaft, and ceiling hole (if a ceiling exists) are drawn at the same time. See “Skylights and Roof Holes” on page 453.

**Auto Floating Dormer**

Select **Build> Roof> Auto Floating Dormer** and click within an existing roof plane to place an auto floating dormer. See “Dormers and Crickets” on page 455.

**Auto Dormer**

Select **Build> Roof> Auto Dormer** and click within a roof plane to place a dormer. See “Dormers and Crickets” on page 455.

**Delete Roof Planes**

Select **Build> Roof> Delete Roof Planes** to delete all roof planes in the plan. See “Deleting Roof Planes” on page 442.

**Delete Ceiling Planes**

Select **Build> Roof> Delete Ceiling Planes** to delete all manually drawn ceiling planes in the plan. See “Ceiling Planes” on page 448.

**Fix Roofs**

Select **Build> Roof> Fix Roofs** to remove breaks where a single edge of one roof plane
meets the broken edge of another along a ridge, hip or valley. **Fix Roofs** does not affect eave edges. See “Aligning Roof Edges” on page 439.

**Automatic Roofs**

When roofs are automatically generated, a roof plane is created over each exterior wall by default, resulting in a hip roof, and the program tries to join them together to form a single, integrated system. There are a number of options available to produce variations in this default roof style.

**Roof Directives in Walls**

To automatically generate a roof plane using values other than the defaults or to not generate a roof plane bearing on a particular wall (as with a gable or the sides of a shed roof), you can change the settings in the **Wall Specification** dialog for that wall. See “Roof Panel” on page 215.

For more information about creating different roof styles, see “Roof Tutorial” on page 48 of the User’s Guide.

**Roof Groups**

When an automatic roof is generated, the program tries to create roof planes that join together to form a single, integrated system. Different parts of the structure influence how the roof is generated over the whole.

When you need the roof planes over an area of a plan to be entirely separate from those over the rest of the structure, you can assign those areas to a non-default Roof Group. The program treats different Roof Groups as separate buildings for the purpose of automatic roof generation, preventing their roofs from influencing one another.

Bear in mind that the use of Roof Groups typically involves using a combination of both automatic roof generation and manual roof editing, and that changes to Attic walls may also be necessary. See “Using Both Techniques” on page 428.

Roof Groups are assigned using numbers. The Default Roof Group is always 0, and you can assign rooms to other roof groups in the **Room Specification** dialog. See “General Panel” on page 240.

**Curved Walls and Roofs**

Automatically generated roof planes are placed over curved walls at specified increments. In the **Build Roof** dialog, you can specify the degree increments for the roof over curved walls, from 6° to 90°. The lower the number, the more roof sections are created over the curved wall.

The following illustrations show a roof created at two different curved increments: 30° and 15°.

**Concave Curved Walls and Roofs**

Regular roof plane sections can also generate over concave curved walls. For roof sections to generate over a concave curved wall, the sections’ baselines must be longer than the **Minimum Alcove Size** value on the **Build** panel of the **Build Roof** dialog.

If the baselines are shorter, the automatically gener-
ated roofs are simplified by either:

- Ignoring the curved wall, as if the walls on either side extended to their meeting point.

- Spanning the concave curved wall with a straight Baseline and produce a roof plane for it from that.

Rebuilding Roofs

By default, whenever changes are made to wall placement, floor/ceiling heights, or roof directives in walls, the roof will update in response. If you do not want the roof to rebuild automatically, uncheck Auto

Build Roof Dialog

The Build Roof dialog is used to automatically build or rebuild roof planes and generate Roof Baseline Polylines. The settings in this dialog act as defaults for both manually drawn and automatic roofs. See “Roof Defaults” on page 428.

To open the Build Roof dialog, select Build > Roof > Build Roof. You can also double-click the Roof Tools button or the Roof Plane button to open this dialog.

Roof planes cannot be edited or manually drawn when Auto Rebuild Roofs is turned on. If you try to either edit or draw a roof plane using the Roof Plane tool, a question message will display.

Roof planes and Roof Baseline Polylines are generated based on the positions and roof directive settings for each exterior wall in the plan. If you make changes to any of these walls or to any of the settings in this dialog, you will need to build the roof again for them to take effect. See “Roof Panel” on page 215.

Aside from a number of checkboxes on the ROOF panel that allow you to automatically generate roof planes and related objects, the settings in this dialog

Note: Under some conditions, when the roof is rebuilt new roof planes may be generated in the same location as retained manually drawn or automatic roof planes.
The **Build** options are commands related to building and rebuilding roof planes.

- Check **Build Roof Planes** to build a new roof structure over the entire model. Unless you specify otherwise, the program discards the existing roof planes and produces new ones.

- If you check **Auto Rebuild Roofs**, the program automatically rebuilds the roof whenever you make a change that affects the generation of roofs, such as changes to exterior walls or ceiling heights.

- Check **Make Roof Baseline Polylines** to delete the existing roof and to create Roof Baseline Polylines based on the exterior wall layout and roof information defined in those walls. Not available when **Build Roof Planes** is checked. See “Roof Baseline Polylines” on page 445.

You can also specify how manually drawn or edited roof planes are handled when the roof is rebuilt automatically. These options are only available when **Build Roof Planes** is checked. See “Rebuilding Roofs” on page 431.
• Check **Retain Manually Drawn Roof Planes** to prevent manually drawn roof planes from being deleted when roof planes are rebuilt. Automatic roof planes may be generated in the same location. Also available if **Make Roof Baseline Polylines** is checked.

• Check **Retain Edited Automatic Roof Planes** to prevent automatic roof planes that have been manually edited - including roof planes over exploded dormers - from being deleted when roof planes are rebuilt. Also available if **Make Roof Baseline Polylines** is checked.

If a newly generated roof plane is coplanar with a retained plane, and the area where they overlap is at least half the area of either of them, the new roof plane is deleted and only the retained plane is kept.

Note: Under some conditions, new roof planes may be generated in the same location as manually drawn or automatic roof planes that have been retained.

• Check **Use Existing Roof Baselines** to produce a roof plan based on your Roof Baseline Polyline(s) instead of the exterior wall layout.

The **Specifications** options are basic roof structure settings.

• Enter a value to describe the **Pitch** as a ratio over 12.

• Check **Trusses (no Birdsmouth)** if you wish to frame the roof using trusses rather than rafters. The roof height will be set so that the bottom edge of the truss top chord is flush with the top of the wall. See “Roof Trusses” on page 490.

• If you plan to use both trusses with rafters, leave **Trusses (no Birdsmouth)** unchecked so that the rafters’ depth can be accommodated. See “Mixing Trusses with Stick Framing” on page 493.

**3 Roof Overhang** is measured horizontally from the outside Main Layer of exterior walls to the end of the top of the rafter. It includes fascia but not gutters. See “The Main Layer” on page 209.

• **Eave** is the overhang distance outside of bearing walls for roof planes using the default Pitch. If a particular roof plane has a different Pitch, its overhang will adjust to keep its fascia at the same height. Overhang may be greater for a shallower pitch, lesser for a greater pitch.

• **Gable** is the overhang distance at gable ends or rake walls.

The **Roof Height** options affect the heights of roof planes.

Specify the amount to **Raise/Lower From Ceiling Height**, which controls the height of roof planes relative to the ceiling height specified for the rooms below.

• The default value is 0, which creates roof planes that bear on the wall top plates at the Ceiling Height of the room below.

• Increase this value to raise roof planes so they do not bear directly on the wall top plates. If roofs are raised sufficiently, Attic walls will automatically generate to support them. The exact height depends on the roof pitch.

• Decrease this value to drop roof planes downward and decrease the height of the bearing walls. If roofs are lowered sufficiently, they may extend into rooms, producing areas with angled ceilings.

• Check **Ignore Top Floor** to ignore the top living floor when roof planes are generated. Roof planes are built on the top plates of the walls below the top floor.

Specify how you would like the eaves of roof planes with different pitches to meet. See “Aligning Eaves” on page 441.

• Check **Same Roof Height at Exterior Walls** to keep bearing walls the same height and change horizontal roof overhang distances as needed so that eaves meet correctly. When checked, this option ignores any overhang values you may have entered in the **Wall Specification** dialog. See “Aligning Eaves” on page 441.

Uncheck this option to raise or lower some roof planes relative to the wall’s top plate, allowing all horizontal overhangs to be the same unless a non-default value has been entered in the **Wall Specification** dialog. See “Roof Directives in Walls” on page 205.

• Check **Same Height Eaves** to keep the eave height for all roof planes the same. Roof planes are raised and lowered as needed so that eaves meet correctly.

The eave height used when this box is checked is

4 The overhang values are not sufficient to extend past the outer surface of exterior walls, the walls may not generate correctly in 3D views.
that of a roof plane using the default Pitch and Overhang values. When this box is checked, all roof planes are affected, including those that do not need adjustment in order to align with adjacent planes.

When Same Height Eaves is checked, any non-default overhang values specified in the Wall Specification dialog are used. Roof planes are raised or lowered so that the eave height is the same, regardless of the horizontal overhang.

- Uncheck Allow Low Roof Planes only when an upper floor overhangs roof planes below.

Uncheck Automatic Birdsmouth Cut to enable the settings below. When checked, the birdsmouth is calculated based on the pitch and rafter depth and its values are listed here for reference. See “Birdsmouth Cut” on page 442.

The Raise Off Plate and Birdsmouth settings do not affect the bearing wall heights.

- Enter a positive Raise Off Plate value in this field to produce the trusses with an energy heel to allow for more insulation.

- Enter a negative Birdsmouth Cut value to control the Birdsmouth Depth. For example, for the Birdsmouth Depth of 3”, enter -3”. The location of the Baseline may change if you use the Raise Off Plate setting to specify the birdsmouth depth. See “Birdsmouth Cut” on page 442.

- Specify the Birdsmouth Seat, which is the horizontal depth of the birdsmouth cut. If you change this value, the Raise Off Plate/Birdsmouth Cut value will automatically adjust.

To control the Birdsmouth Cut, you should also check Same Roof Height at Exterior Walls, above.

- The Vertical Structure Depth displays here as a reference. It can be changed on the STRUCTURE panel. See “Structure Panel” on page 436.

### Options -

- Enter the Segment Angle at Curved Wall, which is the angle for roof segments automatically generated to cover a curved wall. A smaller angle produces more roof planes. Note that in some instances, slightly smaller or larger values will be used instead of the specified angle.

- Specify the Minimum Alcove Size, which is the minimum depth and width of an alcove in an otherwise straight exterior wall. Alcoves with both a depth and width less than this value are roofed over, while alcoves that are either wider or deeper than this value do not receive a roof.

*Effects of Minimum Alcove Size of 3’ (36”)*

- **Roof builds around 3’ wide alcove**

- **Roof builds over 2’11” wide alcove**
Options Panel

1. Specify how the roof **Eaves** are configured.
   - Specify how the rafter and truss ends are **Cut** by selecting either **Square Cut** or **Plumb Cut**.
   - Check **Boxed Eave** to produce horizontal boxed eaves or uncheck it for sloping eaves. You can also change this for individual roof planes in the **Roof Plane Specification** dialog. See “Boxed Eaves” on page 460.
   - Check **Flush Eave** to produce box eaves that build flush with the adjacent exterior wall. When unchecked, boxed eaves build to the gable fascia.
   - **Higher Eaves Boxed** - If the selected roof plane contains more than one eave, check this box to box the higher eaves as well as the lower ones.

2. Specify how the **Ceiling** surface on the underside of roof planes is built. See “Vaulted and Cathedral Ceilings” on page 238.
   - When **Use Room Ceiling Finish** is checked, the ceiling finish thickness and material on the underside of roof planes are defined by the room.

With Boxed Eave checked

With Higher Eaves Boxed checked

With Default to Overhang checked
below. Uncheck this box to enable the two settings that follow and define the ceiling finish as part of the roof planes instead. When this is unchecked, you can specify the Ceiling Surface material on the Materials Panel.

• Check Has Ceiling to enable the Ceiling Thickness option. When this box is unchecked, the selected roof plane will have no ceiling surface at all and the “Ceiling Surface” component will not be available on the MATERIALS panel.

• Specify the Ceiling Thickness, which is the thickness of the bottom surface of the ceiling plane.

Specify the material components to Supply for subsequently-built roof planes. When checked, these items are calculated in the Materials List. Only Gutter is available in the Roof Plane Specification dialog.

• Uncheck Gutter to not include gutters on subsequently-built roof planes. This option affects both the Materials List and 3D views.

• Check Edge Flashing to calculate edge flashing in the Materials List when one or more roof planes is against a wall.

• Check Ridge Vent to calculate ridge venting in the Materials List.

• Check Metal Drip Edge at Eave to calculate metal drip edge along the eaves in the Materials List.

• Check Metal Drip Edge at Gable to calculate metal drip edge along any gable eaves in the Materials List.

• Check Valley Flashing to calculate valley flashing in the Materials List when two or more roof planes form a valley.

3 3D Display - When Show All Ridges is checked, a line along each hip between roof planes forming the conical roof above a curved wall displays in Vector Views. Uncheck this box to suppress these lines. See “Rendered and Vector Views” on page 558.

Structure Panel

The settings on the Structure panel of the Build Roof dialog are the same as those on the ROOF panel of the Build Framing dialog. Changes made in one dialog are also applied in the other. See “Roof Panel” on page 476.

Arrow Panel

The settings on this panel allow you to control the appearance of roof plane slope direction arrows. See “Displaying Roofs” on page 438.

For information about these settings, see “Arrow Panel” on page 171.

Materials Panel

The settings on this panel allow you to specify the default materials for the roof’s various components. See “Materials Panel” on page 542.

Roof Styles Panel

The ROOF STYLES panel provides links to tutorial information about creating different roof styles automatically. Click on a roof style to launch the online Help to a page with information about the roof style you selected. See “Roof Tutorial” on page 48 of the User’s Guide.

Components Panel

The information on the COMPONENTS panel can be used in the materials list. For more information, see “Components Panel” on page 692.

Drawing Roof Planes

Roof planes are CAD-based objects that are created and edited like much closed polylines, and also have pitch, elevation and structural properties.
Before drawing roof planes, you should set your roof defaults so that the 3D attributes of your roof planes are correct. See “Roof Defaults” on page 428.

To draw a roof plane

1. Select Build> Roof> Roof Plane.
2. Click and drag a Baseline from point 1 to point 2, as in the following example:

   ![Baseline example]

3. Release the mouse button at point 2 and move your cursor in the upslope direction. As you move the cursor, a preview outline of the roof plane displays.
4. Click at point 3 to build the roof plane. Point 3 is located on the ridge edge of the roof plane.

The Baseline height is determined by the following formula:

\[
\text{Baseline Height} = \text{Elevation of the wall top plate} + \text{Vertical Structure Depth} - \text{Vertical Birdsmouth Depth}
\]

In a cross section, the Baseline is located directly above the outer surface of the main wall layer, at the top surface of the roof framing.

A roof Baseline displays as a separate line within its roof plane when the “Roofs, Baselines” layer is turned on. In 3D views, it can only be seen if the roof plane is selected.

A Baseline has a tick mark at its center point which indicates the direction that the roof plane slopes upward. If the upslope tick is pointing the wrong direction, either rotate the entire roof plane or delete it and draw a new one.

When drawing the Baseline of a roof plane, here are some things to consider:

- A Baseline does not have to be drawn over a wall, although it often is.
- A Baseline drawn along a wall should be drawn over the outer edge of the wall’s main layer. It tries to snap to that layer.
- The elevation of the top plate is defined by the ceiling height in the room. If the roof plane is not drawn over a wall, it’s height is based on the default ceiling height value for the current floor.
- If a Baseline is drawn over the top of any other roof plane, the Baseline height equals the height of the existing roof plane at the point where you started drawing.

The Baseline displays as a separate line within its roof plane when the “Roofs, Baselines” layer is turned on. In 3D views, it can only be seen if the roof plane is selected.
Once drawn, a Baseline can be selected in plan view and edited independent of the roof plane. See “Editing Roof Baselines” on page 441.

**Eave and Gable Overhangs**

Roof overhangs are measured horizontally from the outside Main Layer of exterior walls to the end of the top of the rafter. They include fascia but not gutters. See “The Main Layer” on page 209.

**Displaying Roofs**

Roof planes are drawn on the “Roof Planes” layer.

In plan view, you can also choose to display gutters, gable lines, the overhang area, Roof Baseline Polylines and roof openings. See “Layer Display Options Dialog” on page 111.

If the bottom surface of the roof extends below the ceiling height of a room, Ceiling Break lines will display where the flat ceiling ends and sloped ceiling begins. Ceiling Break lines are drawn on the “Ceiling Break Lines” layer.

If the “Roof Planes” layer is turned off and Auto Rebuild Roofs feature is turned on, changes made to the plan that cause the roof to rebuild will not automatically turn on the display of the roof planes. See “Rebuilding Roofs” on page 431.

**Roof Plane Labels**

Roof plane labels indicating the pitch and slope direction are located on the “Roofs, Labels” layer and can be set to display in floor plan view.

You can specify whether roof plane labels display the pitch in terms of rise and run or in decimal degrees by checking or unchecking Pitch in Degrees in the Roof Plane Specification dialog. See “General Panel” on page 443.

A roof plane’s label can be customized in its specification dialog. See “Object Labels” on page 285.

Manually drawn Ceiling Planes and Skylights can also display labels when the “Roofs, Labels” layer is on. Unlike roof planes, these objects do not include a slope indicator and their Automatic Labels are blank; however, you can specify a custom label using text in their specification dialogs. See “Ceiling Planes” on page 448 and “Skylights and Roof Holes” on page 453.

When a roof plane, ceiling plane or roof hole/skylight is selected in a 3D view, its label will display on a temporary basis if the “Roofs, Labels” layer is turned on.

**Display on Floor Above/Below**

In plan view, roof planes can display on any floor without affecting their height in 3D.

To move the display of a roof plane to a new floor, select it in plan view and click either the Display on Floor Above or Display on Floor Below edit button. The display of group-selected roof planes can also be controlled in this manner.

Any skylights or roof holes placed in a roof plane moved in this manner will move, as well. Other associated objects like Auto Dormers or gutters will not move, however.
In Cross Section Views

When a roof or ceiling plane is viewed in a cross section, the layers that compose it can be seen, including the roof surface, sheathing, and the ceiling surface.

- If roof framing has been built, its display can be turned on, as well. See “Displaying Framing” on page 482.
- If a roof or ceiling plane is located over a room with Flat Ceiling Over this Room checked, the ceiling surface will not generate. See “Vaulted and Cathedral Ceilings” on page 238.

In the Materials List

The materials that make up roof and ceiling plane assemblies are listed under different Categories in the Materials List:

- **Roofing** - Lists most materials associated with roofs, including roofing, sheathing, rafters and trusses, gutters, and skylights.
- **Insulation** - Insulation is calculated for roof and ceiling planes above rooms that do not have Flat Ceiling Over This Room checked. See “Structure Panel” on page 242.
- **Wallboard** - Lists ceiling materials for all rooms, including those that use the underside of the roof as their ceiling.
- **Framing** - Lists ceiling framing for manually drawn ceiling planes.

See “Materials Lists” on page 681.

Editing Roof and Ceiling Planes

A selected roof or ceiling plane can be edited in 2D and 3D using edit handles, edit toolbar buttons, its specification dialog, and the Material Painter. A roof or ceiling plane’s Baseline can also be selected and edited. To select it, first select the roof plane and then click the Select Next Object edit button. See “The Baseline” on page 437.

By default, all roof planes are deleted and replaced whenever the roof is rebuilt using the Build Roof dialog. If you have manually edited roof planes and do not want them to be replaced, be sure to check Retain Edited Roof Planes. See “Roof Panel” on page 432.

An understanding of these two concepts allows you to design almost any kind of roof.

A roof or ceiling plane’s display and appearance can be customized. See “Displaying Roofs” on page 438 and “Roof Plane Specification Dialog” on page 443.

Adding a Step to an Edge

You can make a step, or jog, in the edge of a roof or ceiling plane by selecting it, clicking the Break Line edit button and then clicking on the roof edge. See “Break” on page 146.

2D Shape and 3D Orientation

There are two basic aspects to editing roofs: 2D shape and 3D orientation.

- The 2D shape of a roof or ceiling plane can be edited just like a CAD polyline. As a plane is reshaped in 2D, the program maintains its height and pitch in 3D. See “Editing Closed Polyline-Based Objects” on page 133.
- The 3D orientation of a roof or ceiling plane is defined by its height and pitch and can be edited in its specification dialog. See “General Panel” on page 443.

Aligning Roof Edges

By default, the edges of a roof plane will automatically snap to the outer surface of a nearby parallel wall. You can disable this Special Snapping.
behavior for a selected roof plane in its specification dialog. See “General Panel” on page 443.

After moving a corner edit handle, it may be difficult to make an edge parallel to an eave or a wall. Use the Make Parallel/Perpendicular edit button to align a roof or ceiling plane edge with a wall, another roof plane edge, or another object with a straight edge. See “Using Make Parallel/Perpendicular” on page 144.

Sometimes, what appears to be a single, straight roof plane edge may actually be broken into two or more edges, which can affect your ability to align the edge properly.

A single edge will have three edit handles; if more than three display, more than one edge is present. An extra handle can be removed manually by dragging it into an adjacent handle. You can also use Build> Roof> Fix Roofs. See “Fix Roofs” on page 429.

When Bumping/Pushing is enabled and CAD Stops Move is checked in the Roof Plane Specification dialog, a roof plane will bump against another roof plane, CAD or CAD based object as it is moved. Roof planes cannot push these objects, however. See “Bumping/Pushing” on page 142.

Join Roof Planes

Two roof or ceiling planes can be joined at adjacent edges in both 2D and 3D using the Join Roof Planes edit button. To use this tool, first identify which edges of the roof planes can extend to meet at a ridge, hip, or valley. The program will join the two planes along the line where they intersect whenever possible.

To use Join Roof Planes

1. Select a roof or ceiling plane on the edge to be joined to another plane.
2. Click the Join Roof Planes edit button (or press 2 on the keyboard).
3. Move your pointer to the edge of the second roof or ceiling plane that the first one needs to join to. When your pointer is over the second plane, this plane will highlight.
4. Click on the edge of the second roof or ceiling plane to join it to the first plane.

Note: Join Roof Planes cannot be used to join a roof plane and ceiling plane. Only planes of the same type can be joined using this tool.

If the planes are not close enough, or their shape is not correct, you may need to align their edges, remove extra edges, or move them closer.

When roof or ceiling planes adjust, the program joins them at the proper location and the adjacent edges extend or contract to remain connected. If the joining of the two will completely eliminate or reverse an adjacent edge, the connection cannot be made.

Locating Intersections

When roof planes of differing slopes meet, they create a ridge, hip, or valley. The Join Roof Planes edit tool is the easiest way to move roof plane edges so that they meet correctly; but you can also locate roof plane intersection points where the ridge, hip or valley should be. Once you know where the planes will meet, you can drag edges or corners to those points.

To find roof plane intersection points

1. Make sure that Automatically Place Roof Intersection Points is turned on in the Preferences dialog. See “Architectural Panel” on page 72.
2. Select the roof plane you would like to place intersection points on.
3. Click the edge of another roof plane to place a temporary CAD Point where it would meet the selected roof plane.
4. Repeat steps 1 and 2 for the ridge edge and both fascia edges. You should have three points located on the larger roof plane: these are the intersection points.
5. Once these intersection points are identified, you can snap the corners of the second roof plane to them.

**Aligning Eaves**

It is not uncommon for roof plans to feature more than one pitch. In order for the eaves of roof planes with different pitches to meet correctly at ridges and hips, you must control the roof planes’ heights and their horizontal overhang distances. Two options in the **Build Roof** dialog allow you to control how the eaves of automatically generated roof planes align. See “Roof Panel” on page 432.

- **Same Roof Height at Exterior Walls** maintains the default height of roof planes where they bear on exterior walls. The horizontal overhang distances of any non-default roof planes are adjusted so that they continue to join correctly with default roof planes.

- **Same Eave Heights** maintains the default roof plane height at the eaves as well as any non-default horizontal overhang distances. All roof planes are raised or lowered so that they all have the same height at the eaves as default roof planes.

Roof planes that do not join other roof planes with different pitches at ridges or hips are referred to as **Independent**.

- **Same Roof Height at Exterior Walls** is checked, Independent roof planes are not affected and will maintain any non-default overhang values.

- When both **Same Roof Height at Exterior Walls** and **Same Eave Heights** are checked, the overhangs of Independent roof planes will be adjusted to preserve their heights at both the exterior walls and the eaves.

**Move to be Coplanar**

The **Move to be Coplanar** edit button allows you to move the selected roof plane to be coplanar (in the same plane) with the next selected roof plane. You can use this tool in both 2D and 3D views. The results can be easily seen in a cross section view. The two roof planes must have parallel Baselines for this to work.

**Raising/Lowering Roof Planes**

Roof planes can be raised or lowered in the **Roof Plane Specification** dialog. Begin by locking the **Pitch**, then change the value of the **Baseline Height**. See “General Panel” on page 443.

You can also raise or lower roof planes in the **Transform/Replicate Object** dialog. See “Transform/Replicate Object Dialog” on page 151.

In addition, when a new floor is added to a plan, you can choose to move any roof planes displaying on the top floor up one floor. See “Adding Floors” on page 388.

**Editing Roof Baselines**

The pitch direction and initial height of any roof plane - manual or automatic - is determined by its Baseline. See “The Baseline” on page 437.

In plan view, a Baseline can be selected and edited independent of the roof plane. To select it, click on the roof plane at the location of the Baseline and then click the **Select Next Object** edit button. The Status Bar tells you when the roof plane Baseline is selected. See “Select Next Object” on page 124.

If a roof plane Baseline is moved, its height will not change. Instead, the height of the roof plane will be affected. In most cases, therefore, moving a roof plane’s Baseline independent of the roof plane itself is not recommended.

If the angle of a roof plane’s Baseline is changed, the direction of the roof plane’s pitch will be modified. The Baseline Angle can be modified in either of two ways:

- In the **Roof Plane Specification** dialog. This will change its angle relative to the floor, and will tilt the roof plane along an axis perpendicular to its Baseline. This method is helpful when a specific eave angle is needed. See “General Panel” on page 443.
• Using its Rotate edit handle in plan view. This will change its angle relative to the roof plane’s eave or ridge and will modify the direction of the pitch. This method is best when the pitch direction matters more than the angle of the eave.
• Both of these methods can be used to modify the same roof plane, although the second approach makes it difficult to control both the pitch direction and eave angle, and is not recommended.

The length of a roof plane Baseline can be lengthened or shortened using its edit handles without changing any of the roof plane’s attributes.

**Set Baseline Height Dialog**

If you manually draw a roof plane so that it bears on a wall at its Baseline, and is placed in the same location as an existing roof plane, the *Set Baseline Height* dialog will display. See “The Baseline” on page 437.

• Select **Over Wall Top** to create a roof plane that bears on the wall it is drawn over and has an overhang as specified in the **Build Roof** dialog. This option would be appropriate to produce a full height dormer. See “Manually Drawn Dormers” on page 457.

• Select **Over the Existing Roof Plane** to produce a roof plane with a height based on that of the roof plane below it rather than the wall. The Baseline height equals the top height of the existing roof at the point where you began drawing the new roof plane Baseline, and has no overhang. This option would be appropriate to create a dormer vent or cricket. See “Manually Drawn Crickets” on page 457.

**Editing Roof Plane Structure**

To create roof planes of a particular depth, begin by setting up the desired roof framing defaults, then build the roof. See “Framing Defaults” on page 463.

If you later need to change the structure of the roof planes, make the needed change to the Framing Defaults, and then rebuild the roof. You can also edit roof structure on an individual roof plane basis. See “Roof Plane Specification Dialog” on page 443.

**Birdsmouth Cut**

The birdsmouth is the notch cut into a rafter where it rests on the wall top plate. You can control its vertical depth and the width of the birdsmouth seat in the **Build Roof** dialog. See “Roof Panel” on page 432.

There are two ways to create a roof plane with no birdsmouth:
• Check **Trusses (No Birdsmouth)** in the **Build Roof** dialog before drawing the roof plane.
• Specify a **Raise Off Plate** value of at least 1/16” in the **Build Roof** dialog.

To change the birdsmouth depth after the roof is built, you can move the roof planes up or down, or change the pitch. For example, if you lock the pitch and raise the roof plane by one inch, you decrease the birdsmouth depth by one inch.

**Locking Roof Planes**

When the roof plan is correct, roof planes can be locked to prevent accidental changes. To do this, lock the “Roof Planes” layer. See “Layer Display Options Dialog” on page 111.

Locking roof planes will not prevent roof planes from being deleted if the floor they are on is deleted.

**Deleting Roof Planes**

There are several ways to delete roof planes.

Delete the entire roof quickly by selecting **Build> Roof> Delete Roof Planes**.

You can also delete all roof planes at once in the **Delete Objects** dialog. See “Delete Objects Dialog” on page 157.

In addition, you can select any roof plane or group of roof planes, then press the Delete key or click the **Delete** edit button to delete it from the plan. See “Deleting Objects” on page 157.

Generally speaking, roof planes cannot be deleted if they are locked. An exception to this rule occurs when an entire floor of a plan is deleted. Any roof planes present on a floor will be deleted when the floor is deleted, locked or not. See “Deleting Floors” on page 391.
When a roof plane is deleted, any roof framing associated with it is automatically deleted, as well.

**Roof Plane Specification Dialog**

Select one or more roof planes and click the Open Object edit button to open the Roof Plane Specification dialog.

**General Panel**

There are four values that define the 3D orientation of a roof plane: **Ridge Top Height**, **Baseline Height**, **Fascia Top Height**, and **Pitch**.

Locking any of the **Height** values defines that value as the pivot point for the selected roof plane. Each of these dimensions is measured from the first floor default elevation of 0' - 0".

If you lock the **Pitch** and change a Height value, the roof plane moves vertically, keeping the same slope. It will not pivot.

Changing these values does not affect the 2D representation of the roof plane.

Specify the **Height** and **Pitch** of the selected roof plane(s). Heights are measured from the top surface of the roof plane(s) rafters or trusses. See “Roof Planes” on page 436.
• The **Top of Plate** is defined by the ceiling height of the room below and is reported here for reference. N/A displays if no room is below the roof plane.

• Define the **Ridge Top Height**, or lock this value to make it the roof plane’s pivot point.

• Define the **Baseline Height**, or lock this value to make it the pivot point.

• Define the **Fascia Top Height**, or lock this value to make it the pivot point.

  **Note:** The Fascia Top height will decrease slightly if the fascia edge is aligned with the ridge top of another roof plane.

• Specify the **Pitch** for the selected roof plane, or lock this value to move the roof plane vertically when a Height value is changed.

• Check **Pitch in Degrees** to display the pitch value in this dialog in degrees as well as in roof plane labels. Values between -89° and 89° can be entered. When **Pitch in Degrees** is unchecked, Pitch is described in terms of rise and run: x inches in 12 and in metric plans, x mm in 1000.

The diagram to the right of the Height/Pitch settings shows the location of the Lock point. If a Height/Pitch setting is currently selected for editing, its location will also be indicated using an arrow.

• By default, the selected **Show Diagram for** option is determined by whether Trusses (no Birdsmouth) was checked in the **Build Roof** dialog when the selected roof plane was created.

• Select a radio button to choose whether to **Show Diagram for Rafters** or **Trusses**. The structure of the roof and location of the Top of Plate Lock point vary between these two options.

  **Measurements** - Information about the structure of the selected roof plane(s) displays here for reference.

• Specify the **Structure Thickness** of the selected roof plane(s). The default Structure Thickness is set in the Build Framing dialog. See “Build Framing Dialog” on page 469.

• The **Birdsmouth Depth** is the plumb or vertical depth of the birdsmouth cut. To change it, move the roof plane some way. For example, if you lock the pitch and raise the roof plane by one inch, you will decrease the birdsmouth depth by one inch. See “Birdsmouth Cut” on page 442.

• The **Birdsmouth Seat** is the horizontal width of the birdsmouth cut. This value is dynamically linked to the birdsmouth depth - if one changes, so does the other.

• The **Vertical Structure Depth** is defined by measuring a plumb line across the roof plane structure. The degree of pitch affects the Vertical rafter width. The greater the pitch, the greater the vertical structure depth.

• **Overhang from Baseline** is the horizontal overhang measured from the Baseline to the eave.

• **Mark as Edited** - When an automatically generated roof plane is modified, the program marks it as "edited", giving you the option of retaining it when the roof is rebuilt. Uncheck this box to remove this status from the selected roof plane. See “Rebuilding Roofs” on page 431.

• **Mark as Edited** is only available for automatically generated roof planes. If a manually drawn roof plane is selected, the words **Manual Roof Plane** will display here instead.

• Check **No Special Snapping** to prevent the selected roof plane from snapping to the outer surface of any walls that it may butt against. When this box is unchecked, the roof plane’s edges will automatically snap to the outside of any nearby parallel walls.

  **Specify the angle of the selected roof plane’s Baseline**, relative to the XY axis. See “Editing Roof Baselines” on page 441.

• A positive **Baseline Angle** value causes the Baseline to tilt upward from its default height. A negative value causes it to tilt downward. The top heights of any walls under the selected roof plane will become angled, as well.

• The **Baseline Height** defined above can be maintained at either the **Start** or **End** point. In plan view, the Baseline direction is clockwise around the house.

### Options Panel

The settings on the OPTIONS panel are the same as those on the panel of the same name in the Build Roof dialog, but affect the selected roof plane only. See “Options Panel” on page 435.

### Structure Panel

The settings on the STRUCTURE panel are similar to those on the ROOF panel of the Build Framing dialog.
dialog, but apply to the selected roof plane only. See “Roof Panel” on page 476.

One checkbox is unique to the STRUCTURE panel of the Roof Plane Specification dialog: check Retain Roof Framing to keep the selected roof plane’s framing from being deleted and replaced when roof framing is rebuilt.

Polyline Panel

The POLYLINE panel states the length of the roof plane’s Perimeter and its enclosed Area, calculated using several different methods.

- The Perimeter is the total length of the roof plane’s sides, not including fascia, with its pitch taken into account. It does not equal the perimeter as measured in plan view unless the roof plane has no fascia and the pitch is 0.

- The Framing Area is the area of the roof plane’s framing, not including the fascia, with the pitch taken into account. It is slightly smaller than the Roof Surface Area as roofing typically overhangs the framing by a small amount.

- The Projected Area is the area of the roof plane polyline, including fascia, as seen in plan view. It does not equal the Roof Surface Area unless the pitch is 0.

- The Roof Surface Area is the area of the roof plane’s top surface, which covers the fascia, with the pitch taken into account.

- The Overhang Area is the area of the roof plane’s overhang, including fascia, with its pitch taken into account.

• The Projected Overhang Area is the area of the roof plane’s overhang, including fascia, as seen in plan view.

Selected Line Panel

The SELECTED LINE panel is similar to the Line panel of the Line Specification dialog. See “Line Panel” on page 168.

Line Style Panel

For information about the settings on this panel, see “Line Style” on page 169.

Fill Style Panel

The settings on the FILL STYLE panel control the appearance of the selected roof plane in plan view. For information about these settings, see “Fill Style Specification Dialog” on page 115.

Materials Panel

The settings on the MATERIALS panel allow you to specify materials for the selected roof plane’s various components. For more information, see “Materials Panel” on page 542.

The “Ceiling Surface” component is only available when Use Room Ceiling Finish is unchecked and Has Ceiling, checked, on the OPTIONS panel. See “Options Panel” on page 435.

Label Panel

Roof plane labels display when the “Roofs, Labels” layer is turned on and use the Text Style assigned to that layer. See “Roof Plane Labels” on page 438.

For information about the settings on this panel, see “Label Panel” on page 286.

Components Panel

The information on the COMPONENTS panel can be used in the materials list. See “Components Panel” on page 692.

Roof Baseline Polylines

Typically, the program builds an automatic roof based on the settings in the Build Roof dialog and on the ROOF panel of the Wall Specification dialog, along with the layout of the exterior walls and floor and ceiling heights.

If you want to build a roof that diverges from the footprint of your building as well as the roof directives in the exterior walls, you can use Roof Baseline Polylines.
To create roof baseline polylines

1. Select Build > Roof > Build Roof.
2. On the BUILD panel of the Build Roof dialog, check Make Roof Baseline Polylines.
3. Click OK. A set of roof Baselines is created along the outside edge of the Main Layer of the exterior walls, forming one or more closed polylines.

As with roof planes, the heights of Roof Baseline Polylines are determined by ceiling heights in the plan. If roof planes will be built at more than one height, a separate baseline polyline is created for each height.

Once created, a Roof Baseline Polyline can be edited in a variety of ways, then used as the basis for the roof then next time it is built automatically.

To create a new roof using the directives in your Roof Baseline Polyline(s), check Use Existing Roof Baselines in the Build Roof dialog and click OK. See “Roof Panel” on page 432.

Displaying Roof Baseline Polylines

Roof Baseline Polylines are placed on the “Roofs, Baseline Polylines” layer and use the Text Style assigned to that layer. See “Layer Attributes” on page 110.

Roof directive information displays along each edge of the polyline, including:
- V - vertical (against wall);
- G - gable/shed;
- K - knee wall;
- L - lower (extend slope downward).

If the directive information includes the pitch, the roof plane slopes toward that edge; if it includes the word (vert), it does not.

Editing Roof Baseline Polylines

A Roof Baseline Polyline’s shape can be edited much like a CAD polyline using its edit handles and edit toolbar buttons. See “Editing Closed Polyline-Based Objects” on page 133.

Roof Baseline Specification Dialog

Like walls, each line of a Roof Baseline Polyline contains roof directives that affect automatic roof generation. Select any edge of a Roof Baseline Polyline click the Open Object edit button open the Roof Baseline Specification dialog.

Roof Baseline Polylines always form a closed area with straight sides only. They cannot be severed or curved, but additional joints or corners can be added.

In addition to length and direction, each Roof Baseline Polyline edge has roof directives associated with it, much like the roof directives in individual walls. See “Roof Directives in Walls” on page 205.

An Example

In order for it to reflect any changes that you make to a Roof Baseline Polyline, the roof must be rebuilt. For a simple example of Roof Baseline Polyline editing, consider an L-shaped house, with a rectangular roof. The inner part of the 'L' is a patio that is covered under the same roof.

On the left is the baseline polyline as it was originally produced and the roof plan it creates.

To model the roof plan shown on the right

1. Select the Roof Baseline Polyline along its bottom-most edge.
2. Click the Intersect/Join Two Lines edit button. See “Reshaping Objects” on page 146.
3. Click the left-most edge to remove the two intervening edges.
4. A message box informs you that “The system must delete intervening lines (those on the inside of the L) to join the two selected lines.” Click OK.
5. Open the Build Roof dialog and select the Build Roof Planes and Use Existing Roof Baseline check boxes to model the roof plan shown on the right side of the image above.
Roof Baseline Panel

The settings on the ROOF BASELINE panel control the roof directives associated with the selected edge of the Roof Baseline Polyline. See “Selected Edge” on page 123.

1. Specify the **Baseline Height**, which is the height of the entire Roof Baseline Polyline, not just that of the selected edge. See “The Baseline” on page 437.

2. **Roof Options** -

   - The first six options: **Hip Wall**, **Full Gable Wall**, **Dutch Gable Wall**, **High Shed/Gable Wall**, **Knee Wall**, and **Extend Slope Downward** are the same as those in the Wall Specification dialog. See “Roof Panel” on page 215.
   - Select **Against Wall** if the roof plane rising from this baseline butts against an exterior wall. This is similar to checking High Shed/Gable Wall.

3. The **Pitch Options** are also found in the Wall Specification dialog. See “Roof Panel” on page 215.

   - Unlike the Pitch value elsewhere, this value is not a Dynamic Default here; however, you can click on the Default icon to load the current default Pitch. See “Build Roof Dialog” on page 431.

Polyline Panel

The POLYLINE panel reports general information about the size and shape of the selected Roof Baseline Polyline. See “Polyline Panel” on page 445.

Selected Line Panel

This panel is similar to the LINE panel of the Line Specification dialog. See “Line Panel” on page 168.

Line Style Panel

For information about the settings on this panel, see “Line Style Panel” on page 169.

Fill Style Panel

The settings on the FILL STYLE panel control the appearance of the selected Roof Baseline Polyline in plan view. See “Fill Style Specification Dialog” on page 115.

Roof and Ceiling Framing

Roof framing can be both drawn manually and generated automatically. You can also combine the two techniques. As with other kinds of framing, it is often easiest to begin by generating roof framing automatically and then editing it as needed. See “Manual vs. Automatic Framing” on page 465.
Roof Trusses cannot be generated automatically - they must be drawn manually and then replicated. If you intend to use Roof Trusses, make sure the settings in the Build Roof dialog are properly defined before you build the roof. See “Roof Trusses” on page 490.

When using a combination of Roof Trusses and stick framing, begin by drawing the roof planes and ceiling planes. When they are in place, draw and replicate the Roof Trusses. Finally, automatically generate or manually draw the stick framing and edit it as needed. See “Mixing Rafters and Trusses” on page 466.

Framing for manually drawn Ceiling Planes cannot be drawn manually - it must be automatically generated. The framing for manually drawn Ceiling Planes is generated when roof framing is built and uses the settings in the Build Roof dialog as defaults. Once it has been created, it can be edited. See “Ceiling Plane” on page 429.

Rebuilding Roof Framing

If roof framing defaults are modified after the roof and roof framing are built, neither will update automatically. In order to update the model you need to rebuild the roof, then rebuild the roof framing.

You can also modify the roof framing settings for individual roof planes, and then either build roof framing or click the Build Framing for Selected Object edit button. See “Keeping Framing Current” on page 485.

Ceiling Planes

Ceiling planes are drawn the same way as roof planes and are edited using the same tools. They are useful for creating custom vaulted ceilings. See “Vaulted and Cathedral Ceilings” on page 238.

Ceiling planes are drawn using the same default pitch as roof planes, specified in the Build Roof dialog. See “Build Roof Dialog” on page 431.

There are a few things to remember when drawing ceiling planes.

- Ceiling planes should be created over rooms that have Flat Ceiling Over this Room unchecked in the Room Specification dialog. See “Structure Panel” on page 242.
- The Baseline of a ceiling plane should be drawn along the outer surface of the bearing wall’s Main Layer. This allows the ceiling plane to extend over and be supported by the wall. See “The Main Layer” on page 209.
- The sloping edge at the side of a ceiling plane should butt to the inside of the wall.
- Ceiling planes act independent of the roof planes above.
- Usually, the pitch of a ceiling plane is lower than the pitch of the corresponding roof plane.
- Ceiling planes can be joined together using the Join Roof Planes edit button. See “Join Roof Planes” on page 440.
- Select a ceiling plane and click the Open Object edit button to open the Ceiling Plane Specification dialog. See “Ceiling Plane Specification Dialog” on page 449.

Displaying Ceiling Planes

Ceiling planes are drawn on the “Ceiling Planes” layer.
Manually drawn Ceiling Planes can also display labels when the “Roofs, Labels” layer is on. See “Roof Plane Labels” on page 438.

Editing Ceiling Planes

Ceiling planes can be edited much like roof planes using their edit handles and edit toolbar buttons. See “Editing Roof and Ceiling Planes” on page 439.

Ceiling planes can also be edited in their specification dialog. See “Roof Plane Specification Dialog” on page 443.

As with roof planes, the ceiling planes layer can be locked to prevent them from being selected.

Deleting Ceiling Planes

There are several ways to delete ceiling planes. See “Deleting Objects” on page 157.

Select Build> Roof> Delete Ceiling Planes to delete all ceiling planes in the current plan.

Ceiling planes can also be deleted at once in the Delete Objects dialog. See “Delete Objects Dialog” on page 157.

Select a ceiling plane or group of ceiling planes, then click the Delete edit button or press the Delete key.

Ceiling Plane Specification Dialog

Select a ceiling plane and click the Open Object edit button to open the Ceiling Plane Specification dialog.


General Panel

There are four values that define the 3D orientation of a ceiling plane: Ridge Height, Height Inside Wall, Height Outside Wall, and Pitch.

Locking any of the Height values defines that value as the pivot point for the selected ceiling plane. Each of these dimensions is measured from the first floor default elevation of 0' - 0".

If you lock the Pitch and change a Height value, the ceiling plane moves vertically, keeping the same slope. It will not pivot.

Changing these values does not affect the 2D representation of the ceiling plane.

Specify the Height and Pitch of the selected ceiling plane. Heights are measured to the bottom surface of the ceiling plane’s rafters or
trusses, at the centerpoint of the ceiling plane’s baseline. See “The Baseline” on page 437.
• Select the Elevation Reference, which is where the Height values below are measured from.
• Define the Ridge Height, or lock this value to make it the ceiling plane’s pivot point.
• Define the Height Inside Wall, or lock this value to make it the ceiling plane’s pivot point. If the plane is drawn over a wall, this is located at the inside surface of the wall’s Main Layer.
• Define the Height Outside Wall, or lock this value to make it the ceiling plane’s pivot point. Only available when a ceiling plane is drawn over a wall, this is the height of the lower edge of the ceiling rafters, were they not clipped by the wall below.
• Specify the selected ceiling plane’s Pitch, or lock this value to move the plane vertically when a Height value is changed.
• Check Pitch in Degrees to display the Pitch value in degrees in all dialogs as well as in roof plane labels.

2 Measurements - Information about the structure of the selected ceiling plane(s) displays here for reference.
• Specify the Structure Thickness. The default Structure Thickness is the same as that for roof planes and is set in the Build Framing dialog. See “Build Framing Dialog” on page 469.
• The Vertical Rafter Depth is defined by measuring a plumb line through the ceiling structure. The greater the pitch, the greater the vertical structure depth.
• The Top of Plate value is the top plate height of the bearing wall, and is also the ceiling height of the room.
• Overhang From Wall Inside - Only appearing when a ceiling plane is drawn over a bearing wall, this is the horizontal distance from the Baseline to the inside Main Layer surface of the wall. The Baseline is typically drawn over the outside Main Layer surface, so this value is equal to the wall’s Main Layer thickness.
• Clip End - This is the amount a ceiling rafter’s underside must be clipped at its lower end to rest on the wall top plate, and is zero if the ceiling plane was not drawn over a bearing wall. This value is equal to the ceiling plane’s rise in slope over the distance of the Overhang from Inside Bottom.

The Outside Bottom value plus the Clip end value equals the Top of Plate value.

3 Specify how the Ceiling Finish surface on the underside of the selected ceiling plane is built.
• When Use Room Ceiling Finish is checked, the selected ceiling plane’s ceiling finish thickness and material are defined by the room below and the “Ceiling Surface” component will not be available on the MATERIALS panel. Uncheck this box to define the ceiling finish as part of the ceiling plane and enable the Ceiling Thickness option.
• Specify the Ceiling Thickness, which is the thickness of the bottom surface of the ceiling plane.

Polyline Panel
The POLYLINE panel states the length of the ceiling plane’s Perimeter, its Framing Area, and its Projected Area. See “Polyline Panel” on page 445.

Selected Line Panel
This panel is similar to the LINE panel of the Line Specification dialog. See “Line Panel” on page 168.

Line Style Panel
For information about the settings on this panel, see “Line Style Panel” on page 169.

Fill Style Panel
The settings on the FILL STYLE panel affect the appearance of the selected ceiling plane in plan view. For information about these settings, see “Fill Style Specification Dialog” on page 115.

Materials Panel
The “Ceiling Surface” component is only available when Use Room Ceiling Finish is unchecked and Has Ceiling, checked, on the OPTIONS panel.

Label Panel
Ceiling plane labels display when the “Roofs, Labels” layer is turned on and use the Text Style assigned to that layer. The Automatic Label for
ceiling planes is blank, but you can specify a custom label. See “Roof Plane Labels” on page 438.

For information about the settings on this panel, see “Label Panel” on page 286.

Gable/Roof Lines

The Gable/Roof Line tool can be used to automatically generate a gable above the bearing wall of a hip roof plane. It is best used in situations where roof directives in walls are not possible. For example:

- Where a wall is not present, such as across the front of an alcove;
- Over a Bay, Box, or Bow Window.

See “Roof Directives in Walls” on page 205.

Components Panel

The information on the COMPONENTS panel can be used in the materials list. See “Components Panel” on page 692.

Creating a Gable

To create a gable using a Gable/Roof Line

1. Select Build > Roof > Gable/Roof Line, then click and drag to draw a line outside of the exterior wall that you want to create a gable over.
2. Position the Gable/Roof Line within 10 feet (2260 mm) of the wall’s Main Layer but not touching it. See “The Main Layer” on page 209.
   - Make sure that the Gable/Roof Line is exactly parallel to the exterior wall.
3. Resize the Gable/Roof Line so that it is the length of the desired gable.
   - The length of the Gable/Roof Line determines the gable width at the wall Main Layer, not at the overhang.
   - At the larger roof eave, a gable roof is wider than the gable line by twice the overhang distance.
4. You can specify the pitch of the gable roof planes and their overhang in the Gable Line Specification dialog. See “Gable Line Specification Dialog” on page 453.
5. Select Build > Roof > Build Roof and regenerate the roof. See “Build Roof Dialog” on page 431.

To use the Gable Over Door/Window tool

1. Select one or more doors or windows.
2. Click the Gable Over Door/Window edit button.

Gables produced using Gable Roof Lines
• **Gable Over Door/Window** is not available for openings placed in Full Gable Walls or for Bay, Box or Bow Windows. See “Bay, Box, Bow Windows and Roofs” on page 330.

3. In the **Gable Line Specification** dialog, specify the desired Pitch and Overhang for the gable roof. See “Gable Line Specification Dialog” on page 453.

4. The next time automatic roof planes are built, gables will be created over each of these doors and windows.

• Each gable will extend 12” (300 mm) on either side of its door or window.
• If two of these openings are within 30” (750 mm) of each other on the same wall, a single gable will be created.
• If you move or resize the door or window(s), the associated Gable/Roof Line will not update until the roof is built again.

5. To remove a Gable Over Door/Window, select the door(s) or window(s) and click the **Delete Gable Over Opening** edit button, or select the gable line and click the **Delete** edit button. The next time the roof is built, the gable will be removed.

### Covering an Alcove

A **Gable/Roof Line** can also be used to maintain a roof plane baseline where there is no wall below. For example, you can use it to extend a roof plane across an alcove, rather than wrap into it.

In order for a **Gable/Roof Line** to direct the roof to extend over an alcove or other area where no wall is present, it must be aligned with the exterior walls’ Main Layer.

### Covering a Bay

A **Gable/Roof Line** drawn across a bay causes a gable to be build above the bay when roofs are automatically generated.
In order for the gable to be built, at least one end of the Gable/Roof Line must extend past the side walls of the bay.

If the Gable/Roof Line is drawn along the outer edge of the bay’s outer wall’s Main Layer, the resulting gable will extend only to the eave of the larger roof. Draw the Gable/Roof Line beyond the bay’s outer wall to extend out past the larger roof’s eave.

Gable Line Specification Dialog

Select a gable line and click the Open Object edit button to open the Gable Line Specification dialog. This dialog also opens whenever the Gable Over Door/Window edit button is clicked.

Gable Line Panel

The settings on this panel affect the structure of the two roof planes associated with the selected Gable/Roof Line. The defaults for these settings are set in the Build Roof dialog. See “Roof Panel” on page 432.

- Specify the Pitch of the roof planes that form the gable.
- Specify the Overhang of the roof planes that form the gable.

Line Panel

The settings on the LINE panel are available for a variety of other objects in the program. See “Line Panel” on page 168.

Line Style Panel

The settings on the LINE STYLE panel are available for a variety of other objects in the program. See “Line Style Panel” on page 169.

Arrow Panel

The settings on the ARROW panel are available for a variety of other objects in the program. See “Arrow Panel” on page 171.

Skylights and Roof Holes

A skylight can be created by selecting Build> Roof> Skylight and drawing a rectangular polyline within a single roof plane. You can also simply click once within a roof plane to place a 2’ x 2’ skylight. These measurements describe the skylight’s projected size, as measured in plan view: roof pitch is not taken into account.
The **Skylight** tool places a flat panel skylight into a roof hole, produces a hole in the ceiling platform below, and automatically generates the skylight shaft between these two holes.

To place a skylight in a vaulted ceiling, uncheck **Flat Ceiling Over This Room** in the **Room Specification** dialog, draw the ceiling planes to produce the vault and edit them as needed, and then draw the skylight. See “Structure Panel” on page 242.

Although inserted into roof planes, skylights are able to display in both plan and 3D views when their containing roofs do not.

### Editing Skylights

Skylights can be selected individually or in groups and can be edited using the edit handles, edit toolbar buttons, or the **Roof Hole/Skylight Specification** dialog. See “Roof Hole/Skylight Specification Dialog” on page 454.

Skylights must always be contained by a single roof plane. If the roof plane is deleted, any skylights or holes it contains are also deleted. Aside from this restriction, skylights can be edited much like standard closed polylines. See “Editing Closed Polyline-Based Objects” on page 133.

If you clear the **Skylight** check box in the **Roof Hole/Skylight Specification** dialog, the curb and glass for the skylight is removed but the opening remains.

---

**Note:** If a sloped ceiling plane is present under the skylight, a hole in this ceiling plane is automatically produced. This hole is visible, and may be located directly under the roof hole. It can be moved and edited separately.
Check Skylight to specify this polyline as a skylight. If unchecked, the curb and glass for the skylight are removed but the opening remains.

- Specify the Frame Width and Height of the selected skylight. These values describe the skylight’s projected size, as measured in plan view: roof pitch is not taken into account.

The Inside Hole Rim settings define how the hole for the skylight is framed, as well as the shape of the skylight well where it passes through the roof plane.

- Select Square Sides to cut the framing for the skylight square to the pitch of the roof.
- Select Plumb Sides to produce framing for the skylight that is plumb-cut.
- Select Plumb/Square to produce framing with the bottom edge plumb-cut and the top edge, square-cut.

Polyline Panel

The POLYLINE panel states the roof hole/skylight’s Perimeter, its Framing Area, and its Projected Area. See “Polyline Panel” on page 445.

Selected Line Panel

This panel is similar to the LINE panel of the Line Specification dialog. See “Line Panel” on page 168.

Dormers and Crickets

Dormers can be drawn manually or placed automatically using the Auto Dormer tools.

Automatic Dormers can be placed only under certain conditions:

- Automatic Dormers can only be placed entirely within a single roof plane. They cannot extend past the eaves or ridge of this roof plane.
- Automatic Dormer side walls cannot be positioned above other walls in the plan.
If you click within a roof plane to place an automatic dormer, but click too close to an eave or the ridge, a dormer will not be created; however, its outline will. Move this outline box to a location that meets the dormer’s requirements and it will be created.

Automatic dormers reside by default on their own layer, “Auto Dormers”. Their display cannot be turned off; however, you can lock this layer to prevent unintended editing. See “Layer Display Options Dialog” on page 111.

The initial width, height, roof style and other settings of Auto Dormers are set in the Dormer Defaults dialog. See “Dormer Defaults” on page 429.

**Auto Floating Dormer**

Select Build> Roof> Auto Floating Dormer and click the roof plane where you would like to place the center of the dormer’s front wall.

The bottom edges of all floating dormer walls are cut off by the underlying roof plane. To produce such a dormer manually, check Roof Cuts Wall at Bottom for the dormer walls on the ROOF panel of the Wall Specification dialog.

Usually, no room is defined by the walls of this type of dormer.

The images below show both the outside and inside of a typical floating dormer.

A floating dormer can be placed in plan view on the same floor that its underlying roof plane displays on, or it can be placed on the floor above. Normally, it does not matter what floor the dormer is on; but in some cases, it may need to be on the floor above so that the dormer walls do not interfere with walls or railings in the room below.

Regardless of which floor it is placed on, a dormer must always fit within a single roof plane. When placing a dormer on the floor above, you may find it helpful to turn on the Reference Display. See “The Reference Floor” on page 393.

You may also find it helpful to display the underlying roof plane on the floor above using the Roof Plane Specification dialog. See “Roof Plane Specification Dialog” on page 443.

If the dormer is placed on the same floor as the underlying roof plane and the room below, and if the room has a flat ceiling, then a hole will be produced in the ceiling under the dormer.

**Auto Dormer**

Select Build> Roof> Auto Dormer and click on a roof plane where you want the center of the dormer’s front wall to be.

The walls of an auto dormer go to the floor and meet a knee wall on either side on the back of the dormer. This knee wall must run parallel to the underlying roof plane’s Baseline.

- If you are creating a (non-floating) auto dormer, a knee wall must already exist. The dormer side walls run back to the knee wall and the knee wall is broken where the dormer walls meet it.
- The knee wall does not have to be designated as such in the Wall Specification dialog unless you are generating an automatic roof. See “Knee Walls” on page 207.
- A non-floating dormer must always be created on the same floor as the knee walls.
Editing Auto Dormers

Auto Dormers are a collection of objects that behave as one. When a dormer is selected, it can be edited using its edit handles, edit tools, and specification dialog. See “Dormer Specification Dialog” on page 458.

If you click the Explode Dormer edit button, the dormer’s individual components can be edited.

Using the Mouse

When selected, an auto dormer displays three edit handles. The Move handle displays over the front wall and allows you to relocate the dormer. Two resize handles display on the side walls and allow you to change the width of the dormer.

There are some things to keep in mind when editing auto dormers and auto floating dormers using the mouse.

• Dormers move at 90° angles unless the Ctrl key is pressed before moving them.
• The dormer must be contained within one underlying roof plane.
• Auto dormers cannot be moved beyond the required knee wall.

A variety of resources with information about drawing dormers manually is available at HomeDesignerSoftware.com.

See, too, “Manually Drawn Dormers” on page 61 of the User’s Guide.

There are a few things to keep in mind.

• Walls extend upward until they meet an overlying roof plane.
• A wall can also be cut by underlying roof planes if Roof Cuts Wall at Bottom is checked in the Wall Specification dialog. For this to work properly, the edge of the roof plane must extend completely through the width of the wall. See “Clerestory and Dormer Walls” on page 206.
• Polylines can be converted into a Hole in Roof/Ceiling that allows walls to extend above or below the roof line. See “Convert Polyline” on page 151.

Manually Drawn Crickets

The automatic roof generator will not produce crickets in a roof plan; however, you can manually draw a cricket using the Roof Plane tool. See “Crickets and Dormer Vents” on page 65 of the User’s Guide.
Editing the Window

Dormer windows can be selected, edited, deleted and replaced just like other windows. See “Editing Windows” on page 314. You can place several windows in the front wall.

Unless the dormer’s window has been edited or changed in the Window Specification dialog, when the dormer width is changed, its width changes automatically to fill the front dormer wall. If the window has been edited, its width stays fixed. If a change to the dormer makes its front wall too short to hold the window, the window reverts to auto width.

Exploding Dormers

Click the Explode Auto Dormer edit button to explode a selected auto dormer into its component parts. The dormer walls, roof planes, window, and hole in the roof/ceiling can be edited individually.

The program treats roof planes over an exploded auto dormer as though they were manually drawn, allowing you to protect them from being rebuilt in the Build Roof dialog. See “Roof Panel” on page 432.

Once exploded, it is not possible to block the components into a Dormer object again.

Dormer Specification Dialog

Select a dormer or dormers and click the Open Object edit button to open the Dormer Specification dialog.

The settings in this dialog are also found in the Dormer Defaults dialog, where they apply to all dormers as they are created rather than to a selected dormer.

Roof Panel

Specify the selected dormer’s Roof Style.

- Choose a roof Type from the drop-down list.

You can choose from Hip, Gable, Shed, Gambrel,

Mansard, Barrel, Curved Eave, Hip Curved Eave or Eyebrow.
Describe the **Pitch** of the dormer’s roof planes.

- Specify the **Pitch** of the dormer roof planes. The default dormer pitch applies to all dormer roof types except Shed, which has a default 3 in 12 pitch. For Gambrel and Mansard types, this applies to the lowest, or eave, roof planes.
- Check **Pitch in Degrees** to display the pitch in degrees in all dialogs as well as in roof plane labels; uncheck it to display the pitch in terms of rise and run.

- The **Second Pitch** specifies the upper roof of a Gambrel, Mansard, curved eave, and hip curved eave.
- When a Second Pitch is used, specify the **In from Eave** distance, measured from the lower roof plane eave to where the upper roof plane starts.

### Walls Panel

- Select a **Wall Type** for the dormer walls from the drop-down list.
- Specify the **Height** of the dormer, as measured from where the top of the underlying roof plane meets the dormer front wall exterior to the top plate of the dormer roof’s bearing walls.

This top height is called the dormer ceiling height, even if the ceiling in the dormer is not flat. The top dormer window casing is usually close to this height.

- Check **Set to Existing Ceiling** to assign the ceiling height of the room behind the dormer to the dormer. Not available in the **Dormer Defaults** dialog.
- **Height to Reach Existing** shows the difference between the dormer height where the inside of the wall meets the underside of the roof and the ceiling of the room behind it.
- Specify the dormer’s **Width**, measured from the outside surfaces of the dormer side walls.
- **Form Room Inside Dormer** is used only for floating dormers and creates a flat ceiling in the dormer. If you check this option, you should define the dormer on the floor above the room it is
positioned over. If this room has a flat ceiling, checking this option makes a hole in the ceiling under the dormer. This option should normally be left unchecked.

Only available in the Dormer Defaults dialog, if Set Inside Window Trim Width is checked, the inside casing width for dormer windows defaults to the Inside Window Trim value entered below. Dormer windows can appear too narrow on the outside due to the space required for the inside casing to clear the inside surfaces of the side walls. This value sets the width for the inside casing of the dormer window.

**Line Style Panel**

For information about the settings on this panel, see “Line Style Panel” on page 169.

---

**Roof Returns and Other Details**

Home Designer Pro offers a selection of tools to add architectural details to your roof design.

**Boxed Eaves**

Boxed eaves have a flat, horizontal soffit surface instead of a soffit that follows the underside of the rafter ends. Boxed eaves can either extend out to the gable fascia or build flush with the adjacent exterior wall.

You can specify Boxed Eaves for all roof planes in the Build Roof dialog and for individual roof planes in the Roof Plane Specification dialog. See “Options Panel” on page 435.

The flush eave end uses the wall’s surface material by default; however, you can specify a different material if you wish. See “Materials Panel” on page 436.

**Roof Returns**

A roof return is a small decorative roof plane that connects to the low side of a gable roof overhang and extends below the upper triangular portion of the gable wall. Three styles of roof returns that can be produced automatically.

The first two styles are called Gable and Hip returns since the return ends in a gable or hip.

The third is called a Full return because it extends under the entire gable to connect both sides and is sometimes referred to as a water table. In order for a Full return to be created, the roof planes on each side must have the same Fascia Top Height.

It is not difficult to manually draw roof returns using small roof planes, but it is quicker to produce them automatically.

Roof returns are generated automatically on a wall by wall basis using settings found in the Wall Specification dialog. See “Roof Panel” on page 215.

These roof return settings are also found in the Dormer Specification dialog for gable roof dormers and function similarly. See “Roof Panel” on page 458.
The pitch of an automatically generated roof return is the same as that of the roof plane above it. Its structure is the same as that of the subfascia and eaves of the roof plane above. See “Structure Panel” on page 444.

Fascia

Fascia can be added to both automatic and manually drawn roof planes. They can be generated when the roof planes are drawn when specified in the Build Roof dialog, and can also be added to or removed from individual roof planes in the Roof Plane Specification dialog.

- Fascia and eave fascia can be specified in the Build Framing and Build Roof dialogs. See “Roof Panel” on page 476.
- Fascia is generated whenever the roof is built or rebuilt.
- Fascia can be specified. See “Materials Panel” on page 436.

Fascia display in 3D views and are included in the materials list.

Fascia

The material specified for fascia in the Build Roof dialog displays as part of the roof plane rather than as a separate object. It displays in 3D views but not plan view.

In addition, sub fascia boards are created when roof framing is generated and are placed on the “Framing, Roof Rafters” layer. The fascia material is not applied to these framing members, however.

The width and depth of fascia and eave fascia can be specified in the Build Framing dialog. See “Roof Panel” on page 476.

Soffits

Soffits are the layer of material that covers the rafter ends on the underside of roof eaves and can be constructed in either of two ways:

- By default, soffits follow the underside of the rafter ends and butt against the inside edge of the fascia. The rafter end depth and thus the soffit height is controlled by the Gable Sub Fascia Depth. See “Roof Panel” on page 476.
- Boxed eaves can be specified in the Build Roof and Roof Plane Specification dialogs. Boxed eave height is controlled by the Eave Sub Fascia Depth. See “Options Panel” on page 435.

Gutters

Gutters are added to non-sloping eaves on both automatic and manually drawn roof planes when Gutters is checked in the Build Roof dialog. They can also be added to or removed from individual roof planes in the Roof Plane Specification dialog. See “Options Panel” on page 435.

Gutters are placed on the “Roofs, Gutters” layer. By default, this layer is turned on in 3D views but not in plan view, is included in the materials list, and is locked. See “Layer Display Options Dialog” on page 111.
In Home Designer Pro, framing can be produced both manually and automatically, and can be calculated in the Materials List.

Manual framing members are drawn by clicking and dragging, like drawing a CAD line. Automatic framing for the major components of a 3D model (floors, ceilings, walls and roofs) can be generated using the Build Framing dialog.

Both manually drawn and automatically generated framing members can be selected and edited in 2D and 3D views.

Trusses are covered in their own chapter, “Trusses” on page 489.

Chapter Contents

- Framing Defaults
- Manual vs. Automatic Framing
- The Framing Tools
- Build Framing Dialog
- Framing Reference Markers
- Joist Direction Lines
- Bearing Lines
- Displaying Framing
- Editing Framing
- Keeping Framing Current
- Framing and the Materials List
- Framing Specification Dialog

Framing Defaults

Select Edit> Default Settings to open the Default Settings dialog. Select Framing from the list, then click the Edit button to open the Framing Defaults dialog.

The Post, Floor Beam, and Roof Beam Defaults dialogs can also be accessed by double-clicking the respective drawing tools. The Deck Post and Deck Beam Defaults dialogs are similar, and can be accessed from the Deck Room Defaults dialog. See “Room Type Defaults” on page 226.

Both automatic and manually-drawn framing are generated according to the settings in the Framing Defaults dialog. This dialog is nearly identical to the Build Framing dialog in both appearance and function. The only difference is that the Build Framing dialog has check boxes that allow you to generate different types of framing automatically. See “Build Framing Dialog” on page 469.

Any changes made in the Framing Defaults or Build Framing dialog will affect subsequently drawn or generated framing, but not framing already present in the plan.

The settings in the Framing Defaults dialog directly affect a variety of important structural elements in each plan which determine floor, ceiling and roof heights; so it is best to set your Framing Defaults before building your model. See “Drawing a Plan” on page 34.

Floor and Ceiling Framing

Floor and ceiling platform depths contribute to the overall height of a structure, so their default values
should be set as early as possible. See “Floor Panels” on page 469.

If you plan to draw floor trusses, also see “Trusses Panel” on page 477.

The default floor and ceiling platform settings for a given floor can be overridden on a room by room basis in the Room Specification dialog, or for individual platforms using Joist Direction lines. See “Structure Panel” on page 242.

By default, automatically-generated floor and ceiling joists run in the direction that results in the shortest span between bearing walls and/or beams. Joist Direction lines also allow you to define the direction that joists in a particular floor or ceiling platform. See “Joist Direction Lines” on page 481.

In standard light frame construction, floor and ceiling platforms are built to pass over or bear on the wall framing; however, this is not always desired. You can specify that joists bear on a selected wall, that platforms hang on it, or that the wall build through platforms in the Wall Specification dialog. See “Structure Panel” on page 214.

### Wall Framing

Like other types of framing, wall framing is generated based on settings in the Framing Defaults dialog. See “Wall Panel” on page 472 and “Openings Panel” on page 473.

In addition, wall framing is dependent on settings from other sources:

- The wall type definition settings used by each wall type in the plan - particularly, the Layer Thickness and Layer Material assigned to the Main Layer. See “Wall Type Definitions Dialog” on page 210.
- The Thickness and O.C. Spacing of the framing material assigned to each wall type used in a plan. See “Materials and the Materials List” on page 547.
- The structural specifications for individual walls in the plan. See “General Panel” on page 212.

In order for wall framing to automatically generate, a wall’s framing layer must be set as its Main Layer and its framing material must be a Framing type. See “The Main Layer” on page 209.

### Rough Openings

The rough openings, trimmers, and sills for doors and windows are set in their respective defaults and specification dialogs. See:

- “Door Specification Dialog” on page 296
- “Window Specification Dialog” on page 315

Note: Door and window bucks do not automatically generate in concrete or block walls.

### Headers

Door and window headers can also be set in their respective defaults and specification dialogs.

In addition, a range of header depths for openings of different widths can be specified in the Framing Defaults dialog. Check Calculate from Width in the Door and Window Defaults dialogs to assign header depths to openings based on their width. See “Openings Panel” on page 473.

Like other framing members, headers are assigned a Structure Type such as “Lumber” or “LVL”. By default, the program will try to ensure that an opening’s Header Type agrees with the framing material used by the wall it is inserted into. To do this, it compares the Header Type to the wall’s framing material:

- Wood framing types: Lumber, I-Joist, Glulam, Engineered Lumber, LVL, PSL, and VSL.
- Steel framing types: Steel I, Steel Box, C Channel, and U Channel.

If the Header Type agrees with the wall framing material, it will be unchanged; however, if it does not agree it will change to either “Lumber” in a wood-framed wall or “C-Channel” in a steel-framed wall. To prevent this from occurring and use the specified Header Type regardless of wall material, uncheck Automatic. See “Structure Types” on page 486.

Box headers with top and bottom rails can also specified. See “Framing Panel” on page 305.

### Sill Plates

Sill plates are created when floor framing is generated. They are created over all exterior walls that have either Concrete or Brick material type as their Main Layer material and support a floor platform or a framed wall directly above. See “The Main Layer” on page 209 and “Materials and the Materials List” on page 547.
Sill plate size and number can be specified in the **Wall Specification** dialog of the supporting masonry wall. Only the bottommost plate that comes into contact with masonry is specified as **Treated**. See “Foundation Panel” on page 217.

These sill plates are placed on the “Framing, Sill Plates” layer. See “Displaying Framing” on page 482.

When a monolithic slab foundation is created, the bottom plates of framed walls built on the slab are specified as **Treated** and are placed on the “Framing, Wall” layer.

As with sill plates, multiple bottom plates can be specified in the **Framing Defaults** dialog, but only the bottommost plate is specified as **Treated**. See “Wall Panel” on page 472.

**Roof Framing**

Settings on the **ROOF** and **TRUSSES** panels of the **Framing Defaults** dialog determine the structure of roof planes and manually drawn ceiling planes as well as how they rest on bearing walls, so it is important that their default values be set before building the roof. See “Roof Panel” on page 476 and “Trusses Panel” on page 477.

If changes are made to these defaults that you need to apply to the entire roof plan, you will need to rebuild the entire roof - not just the roof framing. See “Roofs” on page 427.

**Deck Framing**

Deck rooms have special automatically generated framing and are not affected by the settings in the **Framing Defaults** or **Build Framing** dialogs. See “Decks” on page 234.

**Framing Types**

By default, most framing is set to use “Lumber” as the material type. If a You can select from a number of other types, however, such as I-Joist and Glulam. See “Structure Types” on page 486.

**Manual vs. Automatic Framing**

Platform, roof, and wall framing can be produced manually or automatically. In most cases, automatically-generated framing is preferable because it is faster than manually placing, replicating and editing numerous individual framing members.

In many plans, though, framing is drawn using both approaches. For example, a combination of automatically generated rafters and manually drawn trusses can be used to model a roof framing plan. See “Mixing Trusses with Stick Framing” on page 493.

Regardless of how it is created, individual framing members can be selected and edited. See “Editing Framing” on page 484.

**Automatic Framing**

Automatic framing of floor and ceiling platforms, walls and roofs can be generated using the **Build Framing** dialog. The settings in this dialog control the size, spacing, and type of framing drawn in a plan, and related structural information for the major components of the 3D model. See “Build Framing Dialog” on page 469.

Automatic framing of a particular structural component is not generated until the **Build Framing** dialog is opened to the appropriate panel and one of two check boxes selected:

- Select the **Build** check box to build automatic framing once. For example, check **Build Wall Framing** on the WALL panel, then click OK to build wall framing once based on the current state of the model.
- Select the **Automatic** check box, then click OK to build automatic framing every time a change is made to that structural component in the plan. For example, check **Automatic Wall Framing** on the WALL panel to rebuild all wall framing any time a wall is affected by changes to the model.

**Note:** When Automatic framing of a particular type is enabled, framing of that type cannot be manually edited or deleted.

By default, joists automatically generate in the direction that results in the shortest span; however, you can produce different results using interior walls specified as **Bearing Walls**, **Bearing Lines**, **Floor/Ceiling Beams**, and/or **Joist Direction** lines. See “Bearing Lines” on page 482 and “Joist Direction Lines” on page 481.
Manual Framing

Framing objects can also be drawn manually. With the exception of Posts, framing objects are drawn by clicking and dragging in a straight line, the way other line-based objects are. See “Draw Line” on page 166.

The manual framing tools are organized into families: general framing, floor and ceiling framing and roof framing. The family that a drawing tool belongs to determines where it can be used:

• Roof framing objects can only be drawn within the area of one or more roof planes.
• Floor and ceiling framing objects can only be drawn within one or more floor or ceiling platforms.
• General Framing objects and Posts can be drawn anywhere in a model.

Rebuilding and Retaining Framing

It is important to remember that by default, framing does not update automatically when changes are made to the model. For example, if a door is moved or resized, wall framing must be rebuilt. If the footprint is enlarged, the wall framing and any roof or platform framing that is affected must be rebuilt.

You can direct the program to rebuild the automatic framing of floors/ceilings, walls and/or roofs every time a change to the model affects one of these components. To do this, select the Automatic checkbox on the FLOOR, WALL, and/or ROOF panels of the Build Framing dialog.

To learn more, see “Keeping Framing Current” on page 485.

When automatic framing associated with a particular panel in the Build Framing dialog is generated, any existing automatically produced framing of that type is deleted and replaced. You can prevent this from happening to a selected wall or roof plane by checking Retain Wall Framing or Retain Roof Framing in the object’s specification dialog. See “Structure Panel” on page 214 or “Structure Panel” on page 444.

Mixing Manual and Automatic Framing

Floor and ceiling platforms can be framed with a combination of manually-drawn and automatically generated joists. Similarly, roof planes can be framed with a combination of manually drawn and automatic rafters.

If you plan to use this approach, bear in mind that automatically generated joists and rafters will not be created in the same location as an existing, manually drawn joist or rafter; but, they will not necessarily use the same layout. For consistent layout, consider using a Framing Reference Marker. See “Framing Reference Markers” on page 479.

Manually drawn floor, ceiling, and roof framing is unaffected when automatic framing is rebuilt and remains along with the newly produced automatic framing. In contrast, manually drawn wall framing is deleted when automatic framing is rebuilt. You can, however, prevent this from happening by checking Retain Wall Framing in the Wall Specification dialog.

Mixing Rafters and Trusses

Roofs can be framed with rafters, trusses, or a combination of the two. If you plan to combine roof trusses with rafters and/or ceiling joists, you can save time by:

• Check Trusses (No birdsmouth) in the Build Roof dialog before automatically building or manually drawing a roof. See “Build Roof Dialog” on page 431.
• Draw and position all roof trusses before automatically generating framing to produce rafters and ceiling joists. See “Roof Trusses” on page 490.

For more information, see “Mixing Trusses with Stick Framing” on page 493.

Framing with Beams

Floor/Ceiling Beams can be drawn in a plan either before or after automatic framing has been generated. Default settings for beams can be set in the Framing Defaults dialog. See “Beams Panel” on page 474.

If a Floor/Ceiling Beam is present and wall framing is generated, posts will be placed under the beam in any walls that pass under it and studs and top plates will build around the beam as necessary.

If a Floor/Ceiling Beam is created before automatic floor or ceiling framing, you can specify whether joists bear on the beam or hang on its sides.
The Framing Tools

To build joists that bear on a beam

1. Draw a Floor/Ceiling Beam at the desired location in your plan.
2. Select the beam and click the Open Object edit button. On the General panel of the Beam Specification dialog:
   • The Top Height value is equal to the Ceiling Height of the room(s) over which the beam is placed.
   • Bearing Beam is checked.
3. Click OK, then select Build> Framing> Build Framing and build the appropriate floor or ceiling framing. See “Floor Panels” on page 469.

To build joists that butt against a beam

1. Draw a Floor/Ceiling Beam at the desired location in your plan.
2. Select the beam and click the Open Object edit button. On the General panel of the Beam Specification dialog:
   • Specify the desired Depth value and then lock it.
   • Specify the Bottom Height value so that it is equal to the Ceiling Height of the room(s) over which the beam is placed.
   • Uncheck Bearing Beam.
3. If necessary, select Build> Framing> Joist Direction and draw a line perpendicular to the beam and within the floor or ceiling platform.
4. Click OK, then select Build> Framing> Build Framing and build the appropriate floor or ceiling framing. See “Floor Panels” on page 469.

The Framing Tools

Select Build> Framing to access the automatic and manual Framing Tools.

The Framing Tools family has three separate parent buttons: General Framing Tools, Floor/Ceiling Framing Tools, and Roof Framing Tools. The default settings for framing members are derived from their respective panels in the Framing Defaults dialog.

Most types of framing can be created both manually and automatically. Once created, both automatically generated and manually drawn framing members can be selected and edited. See “Editing Framing” on page 484.

Horizontal floor/ceiling platform framing members are referred to as “joists”; vertical wall framing members are referred to as “studs”; and sloped roof framing members are referred to as “rafters”.

Build Framing

Select Build> Framing> Build Framing to open the Build Framing dialog. Here, you can define settings that control how framing is drawn and generate automatic framing. See “Build Framing Dialog” on page 469.

General Framing

General Framing objects are generic, framing members that can be drawn outside of a floor or ceiling platform or roof plane. Select Build> Framing> General Framing, then click and drag in a straight line to create one of these objects. In plan view, a horizontal framing member is created.

Post

Posts can only be placed manually. To do so, select Build> Framing> Post and click in plan view.

Post with Footing

Posts can also be created with footings beneath them. Select Build> Framing> Post and click in plan view to place a post centered over a footing. Post footings are Slab objects and can be selected independent of their posts. See “The Slab Tools” on page 382.

Rafter

Rafters can be drawn both manually and automatically. To draw a rafter manually, select Build> Framing> Rafter in plan view, then click and drag in a straight line within a roof plane.
Rafters are edited like other framing members, except that you cannot set the height. If a rafter is moved, its height and slope are automatically reset to fit under the roof plane at its new position.

**Roof Blocking**

Roof Blocking is automatically generated in the eaves if a soffit is not present; otherwise, blocking is drawn manually. In plan view, select **Build> Framing> Roof Blocking** and click and drag in a straight line within a roof plane. Blocking is typically drawn perpendicular to the rafters, but at the same pitch.

Each run of blocking behaves as a single object but has gaps where it crosses rafters, trusses or other blocking.

Before drawing Roof Blocking:

- Specify whether you want **In Line**, **Stagger** blocking, or **Cross** bridging in the **Framing Defaults** dialog.
- Build the roof framing. See “Roof Panel” on page 476.

In 3D, roof blocking is tilted to follow the pitch of the roof plane in which it is drawn.

**Roof Truss**

Roof trusses can only be drawn manually. To do so, select **Build> Framing> Roof Truss** in plan view and click and drag in a straight line within one or more roof planes. Roof planes and either a default or manually drawn ceiling must be present before a roof truss can be drawn. See “Roof Trusses” on page 490.

**Roof Beam**

Roof beams can only be drawn manually. To do so, select **Build> Framing> Roof Beam** in plan view and click and drag in a straight line. Roof beams are normally be drawn across rafters and placed directly under them.

**Joist**

Floor and ceiling joists can be drawn both manually and automatically. To draw a joist, select **Build> Framing> Joist** in plan view, then click and drag in a straight line within a floor or ceiling platform.

Joists are always drawn as the ceiling framing for the current floor. See “The Current Floor” on page 392. Whether a floor or ceiling joist is drawn is determined by the presence of a floor platform above.

- If there is no floor platform above, a ceiling joist is drawn.
- If there is a floor platform above, a floor joist is drawn.

If you want to draw floor joists for Floor 1, for example, you must do so on Floor 0. See “Foundations” on page 373.

Joists can be automatically generated for multiple floors in the **Build Framing** dialog. See “Floor Panels” on page 469.

**Joist Blocking**

Joist blocking can only be drawn manually in plan view. To do so, select **Build> Framing> Joist Blocking**, then click and drag in a straight line within a floor or ceiling platform.

Before drawing Joist Blocking:

- Specify whether you want **In Line**, **Stagger** blocking, or **Cross** bridging in the **Framing Defaults** dialog.
- Build the floor and/or ceiling platform. See “Floor Panels” on page 469.

Regardless of how many joists or other objects it crosses, each run of blocking behaves as a single object.

**Floor/Ceiling Truss**

Floor and ceiling trusses can only be drawn manually in plan view. Select **Build> Framing> Floor/Ceiling Truss**, then click and drag in a straight line within a floor or ceiling platform. See “Floor and Ceiling Trusses” on page 490.

**Floor/Ceiling Beam**

Floor and ceiling beams can only be drawn manually in plan view. Select **Build> Framing> Floor/Ceiling Beam**, then click and drag in a straight line within a floor or ceiling platform.

Beams can be drawn in two different ways:
• **Under Joists** places the beam underneath the joists so the joists can bear on it.

• **With Joists** places the top of the beam even with the tops of the joists it supports. The joist then butts against it. See “Beams Panel” on page 474.

**Framing Reference Marker**

Framing Reference Markers are manually-placed reference points that specify how automatically-generated framing is laid out. To place one, select **Build> Framing> Framing Reference Marker** in plan view and click to place a Framing Reference Marker.

A Framing Reference Marker can also be created by placing a **Marker** and then specifying its type.

**Build Framing Dialog**

Automatic framing can be generated by selecting **Build> Framing> Build Framing** to open the Build Framing dialog. This dialog can also be accessed by double-clicking the **General Framing** button or any of the **Floor/Ceiling Framing Tools** buttons.

The settings in this dialog are similar to those found in the **Framing Defaults** dialog.

Each major structural component of the model has its own panel or panels in the **Build Roof** dialog. The number of panels in the dialog varies depending on how many floors are in your model. There will be a panel called “1st” for the first floor, “2nd” for the second floor, and so on.

• Floor and ceiling framing settings are found on the Floor panels. See “Floor Panels” on page 469.

• Wall framing settings are located on the **Wall, Openings, and Fireplaces** panels. See “Wall Panel” on page 472, “Openings Panel” on page 473, and “Fireplaces Panel” on page 474.

**Bearing Line**

Bearing Lines direct the program to lap or butt joists and/or rafters where they cross the line instead of spanning from wall to wall, and can only be drawn in plan view. To draw one, select **Build> Framing> Bearing Line** and click and drag in a straight line. See “Bearing Lines” on page 482.

**Joist Direction**

Joist Direction lines define the direction in which joists run in a floor or ceiling platform and can only be drawn in plan view. To draw one, select **Build> Framing> Joist Direction** and click and drag within a floor or ceiling platform. See “Joist Direction Lines” on page 481.

• Floor/Ceiling Beam and Roof Beam settings are found on the **Beams** panel. See “Beams Panel” on page 474.

• Post, floor/ceiling beam and roof beam settings are found on the **Posts** panel. See “Posts Panel” on page 475.

• Roof framing settings are located on the **Roof** and **Trusses** panels. See “Roof Panel” on page 476 and “Trusses Panel” on page 477.

• The settings on the **Roof** panel are the same as those on the **Structure** panel of the **Build Roof** dialog. See “Roof Panel” on page 476.

• You can specify how framing looks in plan view on the **Plan View** panel. See “Materials Panel” on page 479.

• You can set the default materials used for framing on the **Materials** panel. See “Materials Panel” on page 479.

**Floor Panels**

The default floor and ceiling framing for individual floor levels is set here. The defaults for all floor levels, however, is set in the Floor/Ceiling Platform Defaults dialog. See “Floor and Room Defaults” on page 226.

For best results, create roof framing before or at the same time that ceiling joists are generated.
The floor framing for a given floor level is always generated or manually drawn on the floor below. As such, the floor framing settings for a given floor level are found on the FLOOR panel for the floor below it. For example, the floor framing settings for Floor 2 are found on the 1ST panel, while the floor framing settings for Floor 1 are found on the FOUNDATION panel. See “Floor and Ceiling Platforms” on page 236.

In order to create the floor framing for Floor 1, a Floor 0 must be present. If a Floor 0 has not been built, the Build Floor Framing checkbox on the FOUNDATION panel will not be available. See “Foundations” on page 373.

Check Automatic Floor/Ceiling Framing to regenerate floor and ceiling framing whenever changes are made to the model. See “Automatic Framing” on page 465.

- Check Use Framing Reference to build ceiling framing to a Framing Reference Marker. If a reference is present, the center of the first joist is placed at this point and spacing goes from there. If joists are lapped, the surface is placed at this point. When this is unchecked, the program tries to position ceiling joists so that they coincide with rafters. See “Framing Reference Markers” on page 479.

- Specify how the Ceiling Above Floor X is built. These settings are only relevant for rooms that do not have living space above them.

- Check Build Ceiling Framing to generate or regenerate ceiling framing when the OK button is clicked. Only available when there is no living space above at least part of the current floor. Not available in the Framing Defaults dialog.

- The Ceiling Structure depth displays here for reference. Click the Edit button to open the Ceiling Structure Definition dialog and define the layers of materials that form the ceiling platform. See “Material Layers Definition Dialogs” on page 538.

- Check Default to use the Ceiling Structure Definition set in the Floor/Ceiling Platform Defaults dialog. See “Floor and Room Defaults” on page 226.
• Enter a value for the On Center Spacing of ceiling joists above the current floor.

• Specify the Joist Width, which is their horizontal thickness.

• Specify how the ceiling framing members Bear on Beams and bearing walls: they can either Lap side by side or Butt end to end. The lap is 8” (200 mm) and centered over the support.

• Specify what style of Blocking/Bridging is produced for the ceiling when Joist Blocking is manually drawn after joists are in place. See “Joist Blocking” on page 468.

  • In Line produces blocking pieces that align with each other.
  • Stagger produces blocking that alternates on either side of the line you draw.
  • Cross produces cross bridging that looks like in line blocking in plan view, but shows as cross bridging in 3D views and the materials list.

Specify how the Subfloor for Floor X is built. These settings are relevant only for rooms that have living space above them.

• Check Build Floor Framing to generate or regenerate floor framing when the OK button is clicked. Not available in the Framing Defaults dialog or if there is no floor located below the floor in question.

• The Floor Structure depth displays here for reference. Click the Edit button to open the Floor Structure Definition dialog and define the layers of materials that form the floor platform. Only available if there is living space above at least part of the current floor.

• Check Default to use the Floor Structure Definition set in the Floor/Ceiling Platform Defaults dialog.

• Enter a value for the on center Spacing of floor joists above the current floor.

• Specify the Joist Width, which is their horizontal thickness.

• Check Rim Joist to create rim joists across the ends of the floor joists when floor framing is generated. If this is unchecked, line blocking across the ends of the floor joists is usually drawn in later.

• Specify the Rim Joist Width, which is the horizontal thickness.

• Select the Rim Joist Type from the drop-down list.

• Specify how the floor framing members Bear on Beams: they can either Lap or Butt over beams and bearing walls. The lap is 8” (200 mm) and centered over the support.

• Specify what style of Blocking/Bridging is produced for the floor when Joist Blocking is manually drawn after joists are in place. See #2, above.
Wall Panel

Check **Automatic Wall Framing** to regenerate wall framing whenever changes are made to the model. See “Automatic Framing” on page 465.

Specify how **Wall** studs are created.

- Check **Build Wall Framing** to build wall framing for the entire model. Framing is built in walls whose Main Layer material type is “framing”. Not available in the **Framing Defaults** dialog. See “Wall Type Definitions” on page 208.
- Check **Use Wall Framing Material** to use the stud thickness and spacing defined for the framing material used by each wall type. See “Define Material Dialog” on page 550. Uncheck this box to use the thickness and spacing values below for all wall types.
- Specify the **Stud Thickness** for all walls in the plan. Stud depth is equal to the thickness of each wall layer that has a Framing material. Not available when Use Wall Framing Material is checked.

Define how top and bottom **Plates** are generated.

- Specify the **Top Plate Count**, as well as their **Thickness**.
- Specify the **Bottom Plate Count**, as well as their **Thickness**.

Specify where and how **Blocking** is drawn.

- Check **Exterior** to automatically produce blocking on exterior walls when wall framing is built.
- Check **Interior** to automatically produce blocking on internal walls when wall framing is built.
- **In Line** produces blocking pieces that align with each other.
- **Stagger** produces blocking that alternates on either side of a center line along the wall.

**Note:** If the Stud Thickness is equal to the stud depth, only one stud will be created at wall corners.
Wall blocking is generated exactly half-way up each wall’s total height. Once created, it can be selected in a Framing Overview.

5 Mitre Ends of Angle Walls - Specify how wall corners that are not right angles are framed. 90° corners are not affected by these settings.

- Select Mitre Plate Ends to mitre the ends of the top and bottom plates. If unchecked, top and bottom plates will be butted together.

- Select Rotate End Studs to rotate the studs closest to mitre ends to the angle of the mitre. If unchecked, studs will remain perpendicular to the angle of the walls.

- Select Horizontal Frame Thru to frame through the horizontal walls in plan view, butting vertical walls against them. If unchecked, walls that are vertical in plan view will frame through.

Openings Panel

Various defaults for door and window headers as well as the trimmers for bay/box/bow windows can be set here.

The rough openings for doors and windows can be specified in the Door and Window Defaults and Specification dialogs. See “Rough Openings” on page 464.

Specify default Header Sizes, dependent on width of the door or window, including its Rough Opening. These values should be set so that the wider the opening, the deeper the header.

- If the top of an opening’s Rough Opening is closer to the top plate than the Maximum Depth, a solid header is produced to fill the entire space. Short cripple studs between the header and top plate are not produced.

Specify how Bay/Box/Bow Trimmers, are generated.

- Specify the Maximum Number of trimmers that a Bay, Box, or Bow Window with a lowered top height can have on each side of the opening.

- Specify the Component Thickness, which is the thickness of a thinner trimmer for manually resized Bay/Box/Bow Window components if a standard trimmer does not fit. See “Resizing Components” on page 329.

3 Check List Cut Header Lengths in Mixed Reporting to show precut headers in the Materials List. Precut headers are shown only if the walls have been framed and Mixed Reported is selected as the reporting method. See “Structural Member Reporting” on page 683.

If this is unchecked, the Materials List produces a total footage for all headers. When checked, each different length of precut header is listed separately.

4 Specify the number of Bay, Box, or Bow Windows that a Bay, Box, or Bow Window can have on each side of the opening.
4

Plan Views -

Fireplaces Panel

The rough openings for legacy Fireplaces placed in walls can be set on the FIREPLACES panel.

1. Specify the characteristics of fireplace Headers.
   - Specify the Type of material used for fireplace headers.
   - Specify the Thickness of fireplace headers.
   - Specify the Count of boards used to form a fireplace header.

2. Specify when to generate multiple Trimmers on each side of a fireplace. These values include the fireplace’s Rough Opening. See “Rough Openings” on page 464.

3. Specify the characteristics of fireplace Sills. A sill is only generated if a fireplace is raised sufficiently off the floor.
   - Specify the Thickness of fireplace sills.
   - Check Double Sills to specify a double sill for all fireplaces.

Beams Panel

Floor/Ceiling Beams 🌂 and Roof Beams 🌂 are not automatically generated: they can only be drawn manually. See “Manual Framing” on page 466.

- Double Trimmer At - Fireplace openings of this width or greater receive two trimmers on each side when framed.
- Triple Trimmer At - Fireplace openings of this width or greater receive three trimmers on each side when framed.

Note that the total number of headers is affected by the Count value of each door and window.

- Specify the default Header Fill Style for door and window headers by clicking the Fill Style button to open the Wall Header Fill Style dialog. See “Displaying Framing” on page 482.
Click the **Edit Floor Beam Defaults** to open the **Floor/Ceiling Beam Defaults** dialog. This dialog is similar to the **Framing Specification** dialog. See “Framing Specification Dialog” on page 486.

Click the **Edit Roof Beam Defaults** to open the **Roof Beam Defaults** dialog. This dialog is also similar to the **Framing Specification** dialog.

The **Options** settings affect the positioning of **Floor/Ceiling Beams**.

- **Specify the Placement** of Floor/Ceiling Beams relative to the joists. **With Joists** places beams at the same height as the joists so they hang on the beams; **Under Joists** places beams below joists so they bear on the beams. See “Bearing Lines” on page 482.

- **Align Exterior with Outer Layer/Main Layer** - When a Floor/Ceiling Beam is drawn along and over an exterior wall, its exterior surface can snap to either the wall’s outer layer or outer Main Layer, as specified here. See “The Main Layer” on page 209.

### Posts Panel

**Posts** are not automatically generated: they can only be drawn manually. See “Manual Framing” on page 466.

Posts and beams may be created under a Deck room automatically, depending on its size, location, and other variables. Deck Framing defaults are set in the Deck Room Defaults dialog. See “Deck Framing and Planking” on page 234.

---

Click the **Edit Post Defaults** to open the **Post Defaults** dialog. This dialog is similar to the **Framing Specification** dialog for posts. See “Framing Specification Dialog” on page 486.
The **Post Footings** settings control the initial attributes of footings created with the **Post with Footing** tool.

- Specify the **Height Above Floor** value, measured from the top of the subfloor of the room in which the post is placed.
- Specify the top to bottom **Thickness** of the footing.

- **Specify the Width** of the footing. This is the length of each side of a square footing and the diameter of a round footing.

- Select the **Square** or **Round** radio button to specify the initial shape of post footings. Once created, a post footing can be edited like other closed polylines. See “Editing Closed Polyline-Based Objects” on page 133.

### Roof Panel

The settings on the ROOF panel of the **Build Framing** dialog are exactly the same as those on the STRUCTURE panel of the **Build Roof** dialog. See “Build Roof Dialog” on page 431.

These settings are also found on the STRUCTURE panel of the **Roof Plane Specification** dialog. Those settings that apply to ceiling planes are available in the **Ceiling Plane Specification** dialog. See “Roof Plane Specification Dialog” on page 443.

Note: Changes made on the Roof panel will not affect the structure of existing roof planes. To make changes take effect, rebuild the roof.

**Note:** Use Framing Reference is useful when framing a gable roof, but not necessarily a hip roof. See “Framing References and Roof Framing” on page 480.

---

Check **Automatic Roof Framing** to automatically rebuild roof framing if changes are made to the roof plan. See “Automatic Framing” on page 465.

- Check **Use Framing Reference** to use a defined starting point for rafter layout. See “Framing Reference Markers” on page 479.
• Check **Build Roof Framing** to build roof framing for the entire model. Not available in the **Framing Defaults** dialog. See “Roofs” on page 427.

• Uncheck **Angled Dormer Hole** to frame dormers using rafters under the dormer valleys and a double header where the peak of the dormer roof meets the main roof plane. When checked, a five-sided hole is framed with two angled double rafters located under the dormer valleys. If a double header does not fit within the main roof plane, an angled dormer hole is produced regardless of this setting.

![rectangular dormer hole](image)
![Angled Dormer Hole](image)

• Uncheck **Trim Framing To Soffits** to generate full-depth rafters all the way to the subfascia. If checked, rafter depths are trimmed to the top surface of the soffits in the eave area.

• Specify the **Spacing** of automatically generated rafters.

• Specify the **Maximum Lookout Spacing**. Depending on a roof plane’s length, its lookouts may be spaced closer than this value, but not further.

Specify the **Blocking Style**. See “Roof Blocking” on page 468.

• Check **Vertical** to generate blocking that is oriented vertically, or plumb. When unchecked, blocking is perpendicular to the roof framing.

• **In Line** produces blocking pieces that align with each other.

• **Stagger** produces blocking that alternates on either side of the line you draw.

• **Cross/Bridging** produces cross bridging that looks like in line blocking in plan view, but shows as cross bridging in 3D views and the materials list.

**3. Roof Size** - Specify the desired **Width** and **Depth** for **Rafters**, the **Ridge, Lookouts**, **Gable Sub Fascia** (barge rafter), **Eave Sub Fascia**, **Gable Fascia**, **Eave Fascia** and **Blocking**.

Note that the **Gable Sub Fascia** setting controls the height of both gable and eave soffits, and thus the depth of rafter tails when **Trim Framing to Soffits** is checked, above.

Uncheck the boxes beside **Lookout**, **Eave Sub Fascia**, **Gable Fascia** and/or **Eave Fascia** to prevent these framing members from generating when roof framing is built. When these boxes are checked, these items will generate as specified here.

---

**Trusses Panel**

Changes to the settings on this panel do not affect any trusses that are already present in the current plan. See “Trusses” on page 489.

---

*Home Designer Pro does not engineer trusses. Always consult an engineer or truss company to have your trusses professionally designed.*
Specify the **Roof Truss Member Depths**.

- Specify the depth of the **Top Chord**.
- Specify the depth of the **Bottom Chord**.
- Specify the depth of the **Webbing**.

The **Maximum Horizontal Span** settings control the maximum length between junctions of the webbing and the **Top Chord** and **Bottom Chord**. Changing these values can create different truss configurations such as kingpost, queenpost, fink, double fink, fan, howe, or double howe.

These distances are measured horizontally for both roof and floor and ceiling trusses. In some instances, especially in more complex trusses, making these spans equal may result in the webbing appearing more normal or standard. See “Trusses” on page 489.

---

**Plan View Panel**

The settings on the PLAN VIEW panel affect the appearance of Joists, Rafters, Trusses, and General Framing members in plan view. See “Displaying Framing” on page 482.
Specify the Default Fill Style for joists, rafters, and General Framing members by clicking the Fill Style button to open the Default Framing Fill Style dialog. See “Displaying Framing” on page 482.

The Default Fill Style is not a dynamic default setting. Any framing already present in the plan will not be affected if you change it.

Check Use Line for Framing to show joists, rafters, and General Framing members as single lines rather than as closed polylines. See “Displaying Framing” on page 482.

Materials Panel

The default materials that display on General Framing objects and Rafters are specified on the MATERIALS panel. These materials are used in 3D views only and are not used in the Materials List. Materials List information is derived from the structure Type of each framing object. See “Framing and the Materials List” on page 485.

Changes made on the MATERIALS panel of the Build Framing dialog only affect subsequently created framing: both manually drawn and automatically generated.

The settings on this panel of the Build Framing dialog are the same as in many other specification dialogs. See “Materials Panel” on page 542.

Framing Reference Markers

Framing Reference Markers are reference markers that specify the starting point for the layout of automatically-produced framing, including Deck joists. See “Decks” on page 234.

Wall and floor framing always build to the Framing Reference Marker if one is present.

Ceiling and roof framing only build to the Framing Reference Marker when Use Framing Reference is specified for that type of framing.

Typically, a single Framing Reference Marker on Floor 1 is used for the entire model.

When more than one Framing Reference Marker is present, framing layout starts at the one closest to the center of the area to be framed.

If no Framing Reference Marker is found on the floor being framed, the closest Framing Reference Marker on Floor 1 is used.

When Automatic Wall Framing is checked, wall framing automatically rebuilds if a Framing Reference Marker is added or moved. See “Automatic Framing” on page 465.

Automatic Floor/Ceiling Framing and Automatic Roof Framing, on the other hand, do not respond when a Framing Reference Marker is added or moved. These framing types must be rebuilt using
the Build Framing dialog. See “Build Framing Dialog” on page 469.

Using Framing Reference Markers

To place a Framing Reference Marker, select Build> Framing> Framing Reference Marker. Click in plan view to place the Framing Reference Marker.

When Object Snaps are enabled, Framing Reference Marker snap to framing members and other CAD-based objects first, and then to a wall Main Layer surface or corner if possible. See “Object Snaps” on page 101.

Framing Reference Markers can be modified just like other markers. See “Markers” on page 282.

When framing is generated using a Framing Reference Marker, the first framing member of a given type snaps to this point and all other framing members are laid out from there.

• Wall and roof framing snap to the Framing Reference Marker at their centers.
• Floor and ceiling framing snaps to the Framing Reference Marker at their centers when it is set to Butt Over Support in the Build Roof dialog. See “Floor Panels” on page 469.
• Floor and ceiling framing snaps to the Framing Reference Marker along an edge when it is set to Lap over a supporting beam or wall. If Lap is selected, the surfaces where the joists lap are placed at reference spacing, so that joists are placed on either side of the framing reference locations.

Move to Framing Reference

Manually drawn framing and automatic framing that was not generated using a Framing Reference Marker can be moved relative to a Framing Reference Marker using the Move to Framing Ref edit button.

When a framing member using the Move to Framing Ref edit button, the on-center spacing distance set in the Build Framing dialog is used.

The Move to Framing Ref edit button may also reference spacing specific to a particular floor or ceiling platform. See “Joist Direction Lines” on page 481.

A group of selected framing objects that are all parallel to each other can be moved using the Move to Framing Ref edit button. Only one of the objects in the group is compared to the Framing Reference Marker and moved; the remaining objects are simply moved the same amount as the first object. Ideally, therefore, the group should have proper spacing relative to each other before the move.

To move framing objects to a framing reference marker

1. Group select the framing objects.
2. Click the Move to Framing Ref edit button.
3. The framing members are moved to the nearest Framing Reference Marker.

Framing References and Ceiling Framing

For floor joists, the starting point for layout is always the Framing Reference Marker. Ceiling joists, on the other hand, only use a Framing Reference Marker if Use Framing Reference is checked in the Build Roof dialog. See “Floor Panels” on page 469.

If the Use Framing Reference checkbox is cleared, the program will try to position ceiling joists so that they coincide with rafters. Be sure to build the roof framing first if you are doing this.

A Framing Reference Marker is not usually used for both ceiling joists and nearby rafters that run the same way because one is placed on top of the other.

Framing References and Roof Framing

Framing Reference Markers are useful when framing a gable roof, but not necessarily a hip roof. When a Framing Reference is used, common rafters on either side of a hip rafter do not meet in the same place.

If the Framing Reference is not used, the automatic framing utility starts common rafter spacing from each end of the horizontal ridges, which results in common rafters on either side of hip jacks meeting each other.
Joist Direction Lines

By default, automatically-generated floor and ceiling joists will run in the direction that results in the shortest span between bearing walls and/or beams. A Joist Direction line allows you to define the direction that joists in a particular floor or ceiling platform run, regardless of span.

To draw a Joist Direction line, select Build> Framing> Joist Direction, then click and drag as you would draw a CAD line. In order to have any effect, a Joist Direction line must be drawn within the area of a single floor or ceiling platform.

To avoid unexpected results, only one Joist Direction line should be present in a given floor or ceiling platform, and it should not extend outside of the extents of that platform.

Joist Direction lines are located on the “Framing, Bearing Lines” layer and use the Text Style assigned to that layer. See “Text Styles” on page 283.

Multiple Joist Directions

By default, all of the rooms on each living floor share a single floor platform and a single ceiling platform. If you require joists that run in two directions in either of these platforms, begin by dividing the platform in question in two. There are a number of ways to do this:

- Divide the living area into separate rooms with different platform thicknesses and/or heights. See “Floor and Ceiling Platforms” on page 236.

Joist Direction Specification Dialog

A Joist Direction line can control the joist depth and spacing in the floor or ceiling platform in which it is drawn. To change these values, select a Joist Direction line and click the Open Object edit button. The Joist Direction Specification dialog opens.

Any changes made in the Joist Direction Specification dialog will not affect any joists present in its floor or ceiling platform. Only subsequently produced framing in its platform will be affected.

- Specify one or more interior walls as Bearing Walls. See “Structure Panel” on page 214.
- Draw a Floor/Ceiling Beam specified as a Bearing Beam. See “Floor/Ceiling Beam” on page 468.
- Draw a Bearing Line. See “Bearing Lines” on page 482.

Bearing Walls, Floor/Ceiling Beams, and Bearing Lines should be drawn on the same living floor as the joists they will interact with. Floor framing for a living floor is created on the floor below, while ceiling framing for a living floor is created on that floor. See “Floor and Ceiling Framing” on page 463.

Joist Size and Spacing

The text of a Joist Direction line states the platform framing’s Structure Type and size, and the spacing. By default, these values reflect the settings in the Framing Defaults dialog. See “Floor Panels” on page 469.

In plans using US Units, when the Structure Type is “Lumber”, the nominal size will be reported for the joists. For all other Structure Types, fractional inches are used.

It is important to note that if a Joist Direction line is set to use non-default Spacing and Depth values, they will override the settings in both the Framing Defaults and Room Specification dialogs. It will not, however, change the settings in either dialog.

Floor Joist Panel

- Define the Spacing of the joists in the platform associated with the selected Joist Direction line.
- Define the Depth of these joists.

Note: This is not the recommended method for specifying joist depth and spacing in most cases. You should instead use the settings in the Room Specification dialog. See “Room Specification Dialog” on page 240.
Line Style Panel

For information about the settings on this panel, see “Line Style Panel” on page 169.

Arrow Panel

Joist Direction Lines do not use the Attach or Auto Position options for arrows. For information about the settings on this panel, see “Arrow Panel” on page 171.

Bearing Lines

It is not unusual for joists to lap or butt in the middle of a span rather than build across a platform. When they do, they typically bear on a wall or beam at that point. To produce joists that break over a support, specify the wall or beam in question as Bearing in its specification dialog:

• Check Bearing Wall in the Wall Specification dialog. See “Structure Panel” on page 214.
• Check Bearing Beam in the Framing Specification dialog. See “General Panel” on page 487.

Joists lap or butt over the support depending on the option selected in the Build Framing dialog. See “Floor Panels” on page 469.

In either case, the joists’ overlap or butted ends are centered over the support. When an offset from the center is required, do not specify the wall or beam as Bearing and instead draw a Bearing Line.

A Bearing Line directs the program to lap or butt joists where they cross the line instead of framing across to a wall.

Displaying Framing

The display of framing members is controlled in the Layer Display Options dialog. Framing objects are created on one of over twenty layers with names that begin with “Framing,”: Ceiling Beams, for example, are placed on the “Framing, Ceiling Beams” layer. See “Layer Attributes” on page 110.

In Plan View

In plan view, wall studs and posts are represented by box-based CAD objects that look like Cross Boxes. See “Cross Box” on page 179 and “Editing Box-Based Objects” on page 136.

Joists, rafters, trusses, General Framing, and headers are represented in plan view by line-based CAD objects that are look like long, thin rectangles. See “Editing Line-Based Objects” on page 126.

You can specify a default fill style for line-based framing members in the Build Framing dialog. See “Plan View Panel” on page 478, “Openings Panel” on page 473, and “Fill Styles” on page 115.

By default, newly drawn line-based framing members of a given type display in front of older ones. Posts, meanwhile, display in front of beams, but behind joists. You can specify the drawing order of framing members in their specification dialogs. See “Line Style Panel” on page 488.

If you prefer, joists, rafters, trusses, and General Framing can instead be represented by a single line. The Use Line for Framing setting can be set
differently for each floor in a plan. See “Plan View Panel” on page 478.

**In 3D Views**

The easiest way to view framing in 3D is to use either the Orthographic Framing Overview tool or Perspective Framing Overview tool, which display the model using the 3D Framing Set layer set. See “Framing Overview” on page 563.

Framing objects can display in other 3D and cross section/elevation views, although by default they are not set to do so. If you wish to see framing in these views, turn on the framing layers when the view is active.

To reveal framing covered by other objects or wall layers, use the Delete Surface tool. See “Delete 3D Surface” on page 566.

**In Cross Section/Elevation Views**

To display framing in a cross section/elevation view, make sure the framing layers are turned on in that view. See “Layer Display Options Dialog” on page 111.

You can also use the Delete Surface tool to temporarily delete the surfaces of wall layers or other objects that block the view.

In cross section/elevation views, horizontal framing objects that are cut by the cross section plane display as boxes containing an 'X'. Joist Blocking and Roof Blocking cut by the cross section plane displays as a box containing a single diagonal line. See “Cross Section/Elevation Views” on page 564.

**Framing Materials and Types**

The appearance of a framing member in 3D and cross section/elevation views is affected by the material assigned to it and also by its Type.

The material specified for a framing member determines what it looks like in camera views by applying a texture, pattern, or color to its surface. Materials have no effect on how the framing is calculated in the Materials List, however.

The default materials for framing are set:

- In the Floor and Ceiling Structure Definition dialogs for floor and ceiling framing. See “Floor and Ceiling Platform Definitions” on page 237.
- In the Wall Type Definitions dialog for wall framing. See “Wall Type Definitions Dialog” on page 210.
- In the Framing Defaults dialog for General Framing, Posts, and Rafters. See “Materials Panel” on page 479.

Framing Types can also influence how a framing member looks in camera views because some types have special profiles. Framing types are also stated in the Description column in the Materials List. See “Structure Types” on page 486.

**In the Materials List**

When framing is calculated in the materials list, its dimensions and type are noted. Treated lumber is also counted separately form regular lumber. See “Structure Types” on page 486.

Framing lengths can be counted using one of several methods to produce, for example, cut lists and buy lists. See “Structural Member Reporting” on page 683.

If framing is not present in a plan when a Materials List is created, it will not be calculated. See “Framing and the Materials List” on page 485.
Editing Framing

Framing members can be individually selected in all views, and some types can be group selected. To group-select framing in plan view, first select any of the Framing Tools. See “Marquee Select” on page 125.

To select framing objects of a particular type, use the Marquee Select Similar tool’s Restrictive Selection option. See “Marquee Select Similar” on page 125.

Once selected, they can be edited much like other line-based objects can using the edit handles, edit toolbar buttons, or the Framing Specification dialog. See “Framing Specification Dialog” on page 486.

When Start and End Indicators are enabled in the Preferences dialog, a selected framing member will display an S and an E at its start and end points. This makes it easier to choose which end to lock when specifying its Length or Angle. See “Edit Panel” on page 73.

Framing is organized into families which determine where it is generated and where it can be manually drawn. See “Manual vs. Automatic Framing” on page 465. Once framing has been created, however, it can be moved out of its structural component. In order to move roof framing above or below a roof plane, you must first check Manual Rafter Height in the Framing Specification dialog. See “General Panel” on page 487.

Using the Edit Handles

Framing members can be drawn, edited, and moved much the way CAD lines can. See “Editing Line-Based Objects” on page 126.

In Cross Section/Elevation views, joists and rafters cut by the cross section and displaying a cross box can also be edited. See “Editing Box-Based Objects” on page 136. Also, in Cross Section/Elevation views headers can be edited like closed polylines. See “Editing Closed Polyline-Based Objects” on page 133.

In a camera view or overview, the handles that display on a framing member depend on where it is clicked for selection and your current zoom factor.

- Click the top surface to display the same edit handles as in plan view, allowing you to rotate, move, and extend or shorten the length of the member.
- Click a side surface to display the same edit handles as in an elevation view, one at each end and one at the center.
- Zoom in and click on the appropriate edge to display edit handles that control the width and depth of framing members.

Using Dimensions

Framing members can be both moved and resized using dimensions. See “Moving Objects Using Dimensions” on page 263.

Using the Edit Tools

A selected framing member can be edited in a variety of ways using the buttons on the edit toolbar. See “The Edit Toolbar” on page 29.

Mitered and Lapped Joints

Mitered joints can be created using the Join and Mitre Ends edit button. Click on a framing member such as a joist, click the Join and Mitre Ends edit button, then click on another nearby joist to extend and/or trim the two objects as needed so that they join at an angled cut. See “Fillet Lines” on page 148.

You can instead make two framing members meet at a lapped intersection using the Join and Lap Ends edit button. The selected framing member will butt against the second one, which laps the end of the first.

The Join and Mitre Ends and Join and Lap Ends tools not available for Posts, Floor/Ceiling Trusses, or Roof Trusses.

Steel and Concrete

You can set framing defaults to generate steel framing and concrete structural members as well as lumber and other framing types. Individual framing members can also be specified as concrete or steel, as well.

When setting up defaults or modifying an individual object, make sure you specify both the desired framing Type and the material. See “Framing Materials and Types” on page 483.
Roof and Floor Trusses

Roof and floor trusses cannot be edited like regular framing members can and are discussed in their own chapter. See “Editing Truss Envelopes” on page 493.

Deleting Framing

Individual and group-selected framing members can be deleted the way other objects in the program are. See “Deleting Objects” on page 157.

Categories of framing, such as wall framing or floor and ceiling framing, can also be deleted in the Delete Objects dialog. See “Delete Objects Dialog” on page 157.

Automatic Framing

Automatically-generated framing can be rebuilt using either of two checkboxes in the Build Framing dialog:

• Select a Build check box to build automatic framing once. For example, check Build Wall Framing on the WALL panel to build wall framing once based on the current state of the model. If the model is changed later, you may need to do this again.

• Select an Automatic check box to build automatic framing every time a change is made to that structural component in the plan. For example, check Automatic Wall Framing on the WALL panel to rebuild all wall framing any time a wall is affected by changes to the model.

When floor, ceiling or roof framing is regenerated, all automatically produced framing objects and any copies of them are deleted and new framing is calculated. See “Rebuilding and Retaining Framing” on page 466.

Manual Framing

It is vital to remember that manually drawn framing objects and copies of them are not retained when automatic framing is rebuilt.

If a plan is not final, therefore, do not spend a lot of time altering or copying automatically produced framing objects. It is best to wait until your design is final before doing manual framing work.

Framing and the Materials List

Each framing member created in a plan is counted in the Materials List. See “Materials Lists” on page 681.

Framing can be calculated using one of several reporting methods. See “Structural Member Reporting” on page 683.

Depending on what a framing member is used for, it may be listed in the Framing (F), Subfloor (SF), or Roofing (R) category. See “Categories” on page 684.

• Framing includes all wall framing, posts, and General Framing objects.
• Sub Floor lists floor and ceiling framing joists as well as sheathing.
• Roofing includes trusses, rafters, and sheathing.

It is important to note that the floor, ceiling, and roof framing counted in the Materials List may vary considerably depending on whether framing of those types is actually present in the plan:

• If no framing is present in the model, then the required floor, ceiling, and roof framing is estimated. Total lineal footage for various depths of rafters and joists is estimated, rather than a quantity of specific lumber lengths and sizes. Wall framing is not estimated.
• If even one floor, ceiling, or roof framing object exists in the plan, then objects in that category are counted instead of estimated for the Materials List.
Structure Types

A variety of structural member Types is available for use in Home Designer Pro. They fall into four categories:

- Wood framing types: Lumber, I-Joist, Glulam, Engineered Lumber, LVL, PSL, and VSL.
- Steel framing types: Steel I, Steel Box, C Channel, and U Channel.
- Solid Concrete.
- Round (Posts only).

You can select any of these Types as the default for floor and ceiling framing, headers, roof framing, beams, and posts. See “Build Framing Dialog” on page 469.

You can also specify the Type for individual framing members in their specification dialog. See “General Panel” on page 487.

Changing the framing member Type does not affect how framing is placed, but it may change its profile in cross section and 3D views and will affect its description in the Materials List.

The framing member Type does not affect the appearance of the material used by a framing member in 3D views. See “Framing Materials and Types” on page 483.

Structural Member Reporting

You can specify whether framing materials are calculated by lineal foot, as a cut list, or as a buy list. See “Structural Member Reporting” on page 683.

Framing Materials and the Materials Panel

The materials applied to framing objects in 3D views are not used in the Materials List. Materials List information is derived from the structural use of each framing object and its Type - not the material seen on its surfaces in 3D views. See “Materials Panel” on page 479.

Framing Specification Dialog

Select a framing member and click the Open Object edit button to open the Framing Specification dialog for the type of framing member selected.

The settings in this dialog are similar to those in the Post and Beam Specification and Defaults dialogs. See “Framing with Beams” on page 466.
General Panel

The options available in on the GENERAL panel will vary depending on the type of framing member selected.

When **Automatic Height** is checked, the selected Roof Rafter, Roof Beam, or Roof Blocking object generates within the structural layer of the roof plane(s) it is drawn in.

- Uncheck this box to enable the Manual Height settings that follow.
- If the selected object’s height is edited outside of this dialog, Automatic Height will become unchecked automatically.

**Depth and Height** -

- Check the box beside **Raise/Lower**, then enter a positive value to raise or negative value to lower the framing object from its current position. The amount is added to both the Top and Bottom Heights when you click either **Apply** or **OK**, and does not affect the Depth. When Raise/Lower is checked, the other Depth and Height settings are disabled.
- Select the radio button beside one of the height values to **Lock** it, then change a value that remains available.
- Specify the **Top Height** of the post, as measured from the first floor subfloor at 0”. For a rafter, this is the top height at its low end.
- Specify the **Bottom Height** of the post, as measured from the first floor subfloor at 0”. For a rafter, this is the bottom height its low end.
- Specify the **Depth** of the framing object. For a rafter, this is the depth measured perpendicular to the roof plane.
- **Manual Rafter Height** - Normally, the height of each Rafter or Roof Beam end is reset after any move or edit so that it is located just under the roof surface. Check this box to allow the height of the object to be changed. Only available for Rafters and Roof Beams.

**Options** -

- Set the framing member’s **Width**, as seen in plan view.
- Specify a selected wall framing member’s **Thickness**, as seen in plan view. Only available for wall framing.
- Select a structural member **Type** from the drop-down list. The Round Type is unique to Posts. See “Structure Types” on page 486.
- Check **Show Cross** to display the selected Post as a cross box in plan view. Only available for Posts. See “Displaying Framing” on page 482.
Check **Bearing Beam** to specify the selected Floor/Ceiling Beam as a load-bearing beam. When checked, automatically generated joists run perpendicular to the selected beam and either lap or butt over it, as specified in the **Build Framing** dialog. If the beam’s Top Height is at least 1” higher than the joists’ bottom height, the joists will instead butt against the sides of the beam. See “Framing with Beams” on page 466. Only available for Floor/Ceiling Beams.

Check **Treated** to specify that the selected framing member be counted as treated in the Materials List.

The **Rotate** options let you rotate and align a selected wall stud, blocking, or header within the wall’s framing layer. Select **None** for the framing member’s Thickness to span the depth of the framing layer; select **Flat to Outside** to rotate the member 90° and align it with the outside of the framing layer; select **Flat to Inside** to rotate the member 90° and align it with the inside of the framing layer.

**Length and Angle** - Lock the point about which you want like the selected object to resize and/or rotate, then specify its exact length and angle. See “Editing Framing” on page 484.

- Specify the **Length** of the framing object. Rafter length is measured along the top of the rafter, and so is greater than the length measured in plan view. Not available for Posts.

- **Width 1** and **2** - Specify the Post width in each dimension. When a Round Post is specified, Width 1 refers to its diameter and Width 2 is not available.
Chapter 24: Trusses

There are two basic ways to frame a roof. The first is commonly called “stick framing,” or sometimes “handstacking” or “cut-and-stack.” This type of roof incorporates framing such as rafters, ridges, and ceiling joists. See “Framing” on page 463.

The other method is to use prefabricated, engineered roof trusses. Home Designer Pro allows you to design and display a wide variety of trusses.

Disclaimer
Home Designer Pro does not engineer trusses. The trusses displayed by Home Designer Pro are for illustrative purposes only. They can show how trusses are used in your plan, and help you communicate to the licensed engineer who produces your final truss design where you want your trusses and how you would like them to work.

Always have your truss designs approved by a licensed engineer.

Truss Defaults

The default settings for floor, ceiling and roof trusses are set in the Framing Defaults dialog. Select Edit> Default Settings and in the Default Settings dialog, select Framing and click the Edit button.

The default settings for truss chord and webbing depth, maximum span, and kingpost are set in the Framing Defaults dialog. See “Trusses Panel” on page 477.

Chapter Contents

• Truss Defaults
• Floor and Ceiling Trusses
• Roof Trusses
• Drawing Trusses
• Displaying Trusses
• Editing Trusses
• Editing Truss Envelopes
• Truss Labels
• Mixing Trusses with Stick Framing
• Hip Trusses
• Special Roof Trusses
• Roof Truss Specification Dialog
• Floor/Ceiling Truss Specification Dialog

The overall depth of individual Floor/Ceiling Trusses are based on the thicknesses of the platforms in which they are drawn. See “Floor Panels” on page 469.

The structure of Roof Trusses is determined by the position of the roof plane(s) above and the ceiling plane(s) below. See “Roof Planes” on page 436 and “Ceiling Planes” on page 448.
Floor and Ceiling Trusses

Floor and ceiling trusses can be used instead of joists to frame platforms. As with manually-drawn floor and ceiling framing, the presence of a room above determines whether a floor or ceiling truss is drawn. For example, a truss drawn on the first floor of a single story home will be a ceiling truss, while a truss drawn on the first floor of a two-story building will be a floor truss for the 2nd floor.

Floor and ceiling trusses can only be drawn manually. To place a floor or ceiling truss in your plan, select `Build> Framing> Floor/Ceiling Truss`, then click and drag within a floor or ceiling platform in plan view. See “Drawing Trusses” on page 491.

The TRUSSES panel of the Build Framing dialog contains default settings for floor and ceiling trusses. See “Trusses Panel” on page 477. These default settings can be overridden by the settings in the Floor/Ceiling Truss Specification dialog. See “Floor/Ceiling Truss Specification Dialog” on page 499.

Roof Trusses

Roof trusses can be used instead of or in combination with rafters to frame roofs and ceilings. Roof trusses can only be drawn manually, and can only be created where a roof and ceiling are already present. Select `Build> Framing> Roof Truss`, then click and drag in plan view within one or more roof planes to manually draw a roof truss. See “Drawing Trusses” on page 491.

If you intend to use roof trusses, you need first to build your roof planes with this in mind. Before building the roof, select the Trusses (no Birdsmouth) checkbox in the Build Roof dialog. When this is checked, roof plane thickness is based on the default Top Chord Depth set in the Framing Defaults dialog. See “Trusses Panel” on page 477.

If Trusses (no Birdsmouth) is not checked, the roof plane thickness is determined by the rafter Depth setting on the ROOF panel of the Framing Defaults dialog. If you plan to use both trusses and rafters, you should leave this unchecked.

Roof Truss Placement

A roof truss can only exist in a space defined by the roof planes above it and the ceiling or manually drawn Ceiling Plane below it. This is because the shape of a truss is defined by the location of the roof and the ceiling.

If the program either does not find both roof and ceiling planes, or if there is not enough room between them to model a truss, a warning message displays. For example, if you draw a truss in a roof overhang where there is no ceiling, this message displays:

“Roof and ceiling surfaces too close together or cannot be found, so cannot make truss.”

The incorrect truss may still display in plan view with a label of the form “TR-*”. If it does, it should be deleted or moved. See “Editing Trusses” on page 491.

One or both ends of a truss may be truncated if they are drawn across another truss. If this happens, it will end exactly on the surface of the existing truss, producing a girder truss. See “Girder Trusses” on page 496.

Trusses can end on interior walls. You can draw a truss that partially crosses the building by starting and/or ending it within 24” (600mm) of an interior wall. The truss extends over the wall’s Main Layer. Its end lines up with the Main Layer surface on the far side of the wall.

Roof Truss Webbing

The webbing in a newly drawn truss is controlled by the Top Chord and Bottom Chord settings in the Framing Defaults dialog. See “Trusses Panel” on page 477.

Changing these default values may cause different truss configurations such as kingpost, queenpost, fink, double fink, fan, Howe, or double Howe to be represented.
Drawing Trusses

Trusses cannot be generated automatically: they must be manually drawn and then replicated. All trusses are drawn similar to the way CAD lines are and can be drawn in plan view only. See “Draw Line” on page 166.

To draw and replicate trusses

1. Select the either the Floor/Ceiling Truss or Roof Truss tool, then click and drag within either a floor/ceiling platform or one or more roof planes.
   • As they are drawn, roof trusses will snap to any walls that they cross.
   • When a roof truss ends over an exterior wall, it will extend into the roof eave, stopping at the inside edge of the Eave Sub Fascia.
   • Floor/Ceiling trusses will snap to the wall surfaces, the exterior surface of a wall’s Main Layer, as well as to a variety of CAD-based objects, and can be drawn to any length.

2. Reposition the truss:
   • Floor/ceiling trusses are often positioned relative to an exterior wall or Framing Reference Marker. See “Framing Reference Markers” on page 479.
   • Roof trusses are can be positioned over a gable end wall or at the ridge end of a hip.

3. Open the truss’s specification dialog and edit its settings to meet your needs. See “Roof Truss Specification Dialog” on page 497 or “Floor/Ceiling Truss Specification Dialog” on page 499.


The copies of Roof Trusses automatically conform to the structural conditions in their new locations. As a result, replicated Roof Trusses and their labels may be different from the original. See “Truss Labels” on page 493.

Unlike Roof Trusses, Floor/Ceiling Trusses do not conform to new structural conditions when they are either moved or copied. See “Moving Trusses” on page 492.

Displaying Trusses

The display of trusses and their labels is controlled in the Layer Display Options dialog. See “Layer Display Options Dialog” on page 111.

Truss labels display in plan view and are used in the Materials List. See “Truss Labels” on page 493.

In 3D Views

The easiest way to view trusses in 3D is to use either the Orthographic Framing Overview or Perspective Framing Overview tool, which display the model using the 3D Framing Set layer set. See “Framing Overview” on page 563.

Trusses can display in other 3D and cross section/elevation views, although by default they are not set to do so. If you wish to see trusses in these views, turn on the “Framing, Trusses” layer when the view is active.

You can create exposed trusses by placing roof and ceiling planes to produce the desired truss structure, drawing the trusses, and then removing the ceiling. See “Vaulted and Cathedral Ceilings” on page 238.

To reveal trusses covered by other objects, you can use the Delete Surface tool. See “Delete 3D Surface” on page 566.

In the Materials List

All trusses are listed under the Roofing category in the Materials List. Their labels appear in the Size column, along with their length. See “The Materials List Tools” on page 681.

Editing Trusses

Trusses can be selected like other objects in Home Designer Pro. See “Selecting Objects” on page 123.

Once selected, trusses can be edited using dimensions, the edit toolbar buttons, their edit
handles, and their specification dialog. See “Roof Truss Specification Dialog” on page 497.

When **Start and End Indicators** are enabled in the **Preferences** dialog, a truss selected in plan view will display an S and an E at its start and end points. See “Edit Panel” on page 73.

Trusses can be deleted all at once in the **Delete Objects** dialog. See “Delete Objects Dialog” on page 157.

### Using Dimensions

Trusses can be relocated precisely using dimensions. See “Moving Objects Using Dimensions” on page 263.

### Using the Edit Tools

A selected truss can be edited in a variety of ways using the buttons on the edit toolbar. See “The Edit Toolbar” on page 29.

### Using the Edit Handles

When selected in plan view, trusses edit like CAD lines. See “Editing Line-Based Objects” on page 126.

When editing a roof truss’s length, bear in mind that if you position either of its ends at a location that doesn’t correspond to a roof plane edge, interior wall, or another truss, **No Special Snapping** will automatically become checked in its specification dialog.

When selected in a Cross Section/Elevation or 3D view, a truss can be edited like a closed polyline. See “Editing Truss Envelopes” on page 493.

The depth of truss chords can be changed in the truss’s specification dialog, but not using the edit handles.

### Moving Trusses

Trusses can be moved using either their Move edit handle or the **Transform/Replicate Object** edit tool. It’s important to note that Roof and Floor/Ceiling Trusses may behave differently when they are moved:

- When a **Roof Truss** is moved, its shape updates to conform to the structural conditions defined by the roof and ceiling in its new location.

To prevent this from occurring, check **Lock Truss Envelope and Webbing** in the **Roof Truss Specification** dialog before moving the truss. See “Lock Truss Envelope and Webbing” on page 493.

- This is not the case with **Floor/Ceiling Trusses**: when moved to a location with a different platform structure, a Floor/Ceiling Truss will not update to conform to its new surroundings. It is important to draw, position, and copy them within the same floor or ceiling platform structure. If a different Floor/Ceiling Truss depth is needed, a new truss should be drawn.

### Special Truss Snapping

By default, **Roof Trusses** have a number of special snapping behaviors that are used even when **Object Snaps** are toggled off. See “Object Snaps” on page 101.

These special behaviors include:

- As they are drawn, Roof Trusses will snap to any walls that they cross.
- When drawn along an exterior wall, a Roof Truss will snap so that its outer surface is flush with the outer surface of the wall’s Main Layer.
- When drawn along a roof plane edge, a Roof Truss will snap to the roof plane’s edge or corner.
- The center line Roof Trusses will snap to the line along which two roof planes meet.
- When a Roof Truss ends over an exterior wall, it will extend into the roof eave, stopping at the inside edge of the Eave Sub Fascia.

Floor/Ceiling Trusses can be drawn to any length but also have special snapping:

- Floor/Ceiling trusses will snap to the wall surfaces, the exterior surface of a wall’s Main Layer, as well as to a variety of CAD-based objects.

If you edit a truss in such a way that its ends do not correspond to a special snapping location, **No Special Snapping** will automatically become unchecked in its specification dialog. This allows you to easily customize a truss but may make it difficult to snap to commonly used locations.

You can check or uncheck **No Special Snapping** in the **Roof Truss Specification** dialog. See “General Panel” on page 497.
Editing Truss Envelopes

A truss envelope is the shape defined by a truss’s top and bottom chords. When a truss is drawn, the envelope is derived from the floor platform, ceiling platform, or roof that the truss is drawn in.

When a truss is viewed in a 3D view, its envelope can be edited like a closed polyline. See “Editing Closed Polyline-Based Objects” on page 133.

This function can be used to change a roof truss end or overhang as well as the overall truss shape. Changing the truss envelope does not change the structure that it is drawn in, however.

In addition, when a Roof Truss is moved, its shape updates to conform to the structural conditions defined by the roof and ceiling in its new location. As a result, a Roof Truss’s label can change when the truss is moved to a new location.

Floor/Ceiling Trusses do not update when moved to a location with different structural conditions.

Lock Truss Envelope and Webbing

The Lock Truss Envelope and Webbing attribute can be used to prevent a Roof Truss envelope from updating when it is moved or replicated. See “Roof Truss Specification Dialog” on page 497.

Truss Labels

Labels for roof trusses display when the “Framing, Roof Truss Labels” layer is turned on in the current view. Similarly, floor and ceiling trusses display when the “Framing, Floor/Ceiling Truss Labels” is turned on. See “Layer Display Options Dialog” on page 111.

Truss labels are available in two formats: automatic and user-specified. See “Object Labels” on page 285.

Truss labels can display in plan view and are used in the Label column of the Materials List. See “Displaying Trusses” on page 491.

Truss labels use the Text Style specified for their layer in the current view. See “Text Styles” on page 283.

By default, truss labels are centered on the truss that they identify. If the truss is moved or deleted, the label is moved or deleted as well. See “Editing Trusses” on page 491.

Truss labels obey the Minimum Display Size for labels set in the Preferences dialog. See “Appearance Panel” on page 62.

If two or more trusses share the same configuration with identical chords and webbing, they will also share the same truss label.

Automatic Truss Labels

Automatic roof truss labels use the format TR-X, where X is a number indicating the order in which each distinct truss configuration was created. For example, the first truss type created in a plan is labeled TR-1; the second, TR-2; and so on.

Floor and ceiling trusses are labeled FTR-X and use the same numbering convention.

Mixing Trusses with Stick Framing

After the trusses for your roof are in place, additional roof framing can be added. See “Roof Framing” on page 465.

Framing Defaults

Roof planes created using defaults set up for trusses will continue to use those defaults when stick framing is added. If you intend to add rafters, the roof planes should be created while Trusses (no Birdsmouth) is unchecked in the Build Roof dialog. See “Roof Panel” on page 432.

Leaving Trusses (no Birdsmouth) unchecked has a similar effect on roof trusses to that of Raise Off Plate: roof truss bottom chords may be longer than expected and their top chords, higher. This is necessary to create the space needed to accommodate the rafter’s depth.
Automatic Framing

The **Build Framing** dialog can be used to generate roof framing in areas not framed by the trusses, including gable eaves and the ends of hips. Note that rafters will not generate closer than 14” (350mm) to an existing, parallel truss.

Automatically generated roof framing will not extend through an existing roof truss. Instead:

- Automatically produced rafters generate inward from the eave until they butt into a truss.
- Blocking for standard and hip ridges generates as individual rafter objects between trusses.
- Lookouts will pass over **Reduced Gable** trusses and will end at the next truss in. See “**Roof Truss Specification Dialog**” on page 497.
- Hip ridges and common rafters at the end of a hip roof will pass over a **Drop Hip Truss**. See “**Drop Hip or California Hip**” on page 494.

**Manually Drawn Framing**

Unlike automatically generated roof framing, manually drawn rafters will extend through trusses. Rafters can also snap to truss edges as they are being drawn or when they are being edited. See “**Manual Framing**” on page 466.

**Hip Trusses**

A variety of different hip truss configurations can be created, including:

- Step Down Hip trusses
- Drop Hip or California Hip trusses
- Subgirder Hip trusses

**Step Down Hip**

Step Down hip roofs are the quickest style of hip truss framing to produce.

*To create a step down hip truss system*

1. First, draw a **Roof Truss** at the apex of the triangular hip roof plane. When **Object Snaps** are enabled, it will snap into position. See “**Object Snaps**” on page 101.
2. Select the truss; click the **Transform/Replicate Object** edit button; and create enough copies of the truss in the direction of the hip to reach a reasonable minimum height. See “**Transform/Replicate Object Dialog**” on page 151.
3. Using the **Roof Truss** tool, draw hip jacks along the hip ridge from the last truss out into the overhang.
4. Using the **Roof Truss** tool, draw a jack truss from the intersection of the last hip truss and the hip jack to the eave.
5. Select the jack truss; click the **Transform/Replicate Object** edit button; and lay out jack trusses up to the other hip jack.

**Drop Hip or California Hip**

A Drop Hip, or California Hip, system uses trusses with lowered top chords to support stick frame hip ridges and common rafters.

*To create a drop hip truss system*

1. Start a drop hip truss system as you would a step down hip system.
2. When the hip trusses are drawn, group select them, open the **Truss Specification dialog**, and select the **Drop Hip Truss** check box. See “**General Panel**” on page 497.
3. Use the **Build Framing** dialog to produce the common rafters, and the short joists at the hip end. See “**Build Framing Dialog**” on page 469.

The amount that the top chord is lowered is derived from the rafter Depth on the ROOF panel of the **Framing Defaults** dialog. Because both common rafters and hip ridges must pass over this truss, the ridge depth should be set equal to that of the rafter depth.
Special Roof Trusses

Subgirder Hip

Subgirders are the partial trusses that butt into the doubled truss at the end of the main run.

To create a subgirder truss system

1. Draw a Roof Truss where the hip apex meets the ridge.
2. Double it by drawing a second truss on the far side from the hip section.

Special Roof Trusses

A number of special purpose roof trusses can be created in Home Designer Pro.

Energy Heels

To provide more space for ceiling insulation at the exterior walls, roofs are sometimes raised off of the top plate with an energy heel. To create a truss with an energy heel, a vertical member is added over the supporting wall and the bottom chord stops there rather than extending into the overhang.

To create an energy heel

1. In the Build Roof dialog:
   - Check Trusses (no Birdsmouth);
   - Uncheck Automatic Birdsmouth Cut;
   - Specify the desired energy heel height as a positive Raise Off Plate value.
2. Automatically generate or manually draw the roof planes.
3. Draw and position the first truss. See “To draw and replicate trusses” on page 491.
4. Open this truss’s specification dialog and check Energy Heel and Force Truss Rebuild, then click OK. See “Roof Truss Specification Dialog” on page 497.
5. Use the Transform/Replicate Object edit tool to replicate the truss as needed.

Attic Trusses

Attic trusses, a variation of roof trusses, can be drawn if a plan contains an Attic area on both sides and above an upstairs room, such as in a Cape Cod style home. The following is a typical cross section view of a building with attic trusses:

Certain conditions must be met before an attic truss can be built:

- The structure should be sufficiently wide to allow for a loft and attic spaces.
- The loft area must be on a living floor. It cannot be on the Attic floor. See “The Attic Floor” on page 393.
- The loft area must have Attic rooms on both sides. See “Room Types” on page 227.
- The loft area must be separated from the Attic rooms on both sides by Knee Walls. See “Knee Walls” on page 207.
- A flat ceiling in the loft area and a floor below must be present.
- The roof pitch must be steep enough to provide appropriate ceiling height for the loft area.
cal pitches for such a condition are 8 in 12 or greater.

• The roof should bear on the walls of the floor below the loft area and form continuous planes from ridge to baselines.

Once these conditions are met, a roof truss is ready to be designated as an attic truss.

1. Select the roof truss in plan view and click the Open Object edit button to display the GENERAL panel of the Roof Truss Specification dialog.

2. Check the box beside Attic Truss and click OK. See “Roof Truss Specification Dialog” on page 497.

Scissors Trusses

Trusses drawn between roof planes and sloping ceiling planes of a different pitch than the roof are called Scissor trusses. See “Ceiling Planes” on page 448.

The following is an example of a scissors truss drawn beneath an 8 in 12 pitch gable roof and above 4 in 12 pitch ceiling planes.

Girder Trusses

Girder trusses provide support for trusses that are cut short, for example, by a reverse gable or a skylight. They are often doubled- or tripled-up for strength.

Draw a new truss from an existing truss to the roof edge, as you would to draw a hip or end jack truss; or draw a truss between two trusses, forming a girder. This may be necessary for a large opening, such as a skylight.

Trusses cannot be drawn through each other. If a truss is drawn through an existing truss, the program automatically shortens it so that it butts into the existing truss.

Sloping Flat Trusses

A sloping flat truss is a roof truss that builds within the rafter area of the roof plane(s) it is drawn in. In order to create one, the roof plane(s) must have a rafter depth deep enough to accommodate its chords and webbing.

To create a sloping flat truss

1. Select the roof plane in which you would like to draw sloping flat trusses and click the Open Object edit button.

2. On the STRUCTURE panel of the Roof Plane Specification dialog, specify the Rafter depth as the desired depth of the sloping flat truss. See “Structure Panel” on page 444.

3. Select the roof truss and click the Open Object edit button.

4. On the GENERAL panel of the Roof Truss Specification dialog, check the boxes beside Sloping Flat Truss and Force Truss Rebuild, then click OK.
5. Use the **Transform/Replicate Object** edit tool to replicate the truss within the area of the roof plane(s) edited in step 2.

**Roof Truss Specification Dialog**

Select a roof truss or group of roof trusses and click the **Open Object** edit button to open the **Roof Truss Specification** dialog.

The **Roof Truss Specification** dialog allows you to redefine parts of an existing truss or group of trusses. Some settings affect only individual trusses, such as gable trusses, while others affect the whole group.

The shape or volume of a roof truss is controlled by the roof planes above it and the ceiling planes below it. It cannot be changed from this dialog.

---

**General Panel**

The defaults for many of the settings on the **General** panel are set in the **Build Framing** dialog. See “Trusses Panel” on page 477.

1. **Member Sizing** - Specify the sizes of the different members that form the selected truss.
   - Specify the depths of the **Top Chord** and **Bottom Chord**.
   - Specify the depth of the **Webbing**.
   - Specify the **Thickness**, which is the width of the truss in plan view.

2. Specify the **Maximum Span**, which is the maximum horizontal distance between supports along the **Top** and **Bottom Chords**. When these values are equal, the truss webbing often appears more regular.

3. Additional **Options** allow you to create special truss types.
   - Check **Require Kingpost** to require a vertical webbing member from the roof peak to the bottom chord.
If Require Kingpost is unchecked, a kingpost may still be supplied, depending on the truss length and the specified maximum spans.

- Check **End Truss** to replace the webbing with vertical members positioned and spaced the same as the wall studs below.

If an End Truss is in the same position as a gable attic wall, it replaces the framing that would otherwise be produced for that wall.

- Check **Energy Heel** to model remove the bottom chord from the overhang area. For an energy heel to be modeled, the roof should also be raised off the top plates by at least 7”, depending on the roof pitch. See “Energy Heels” on page 495.

- Check **Drop Hip Truss** to lower the flat top of a truss in the hip area of a roof so that common rafters and hip ridges can pass over and be supported by it. See “Drop Hip or California Hip” on page 494.

- Check **Reduced Gable** to lower the top chord of an End Truss so that lookouts can pass over the truss. Reduced trusses do not have overhangs, but you can draw short rafters drawn at the ends of the truss.

- Check **Attic Truss** to specify an attic truss. See “Attic Trusses” on page 495.

- Check **Sloping Flat Truss** to create a truss with a bottom chord that follows the underside of the roof plane(s) it is drawn in. When this is unchecked, the bottom chord follows the ceiling of the room or manually drawn ceiling plane below. See “Sloping Flat Trusses” on page 496.

- Check **Force Truss Rebuild** to rebuild the truss envelope based on the current state of the ceiling and roof when you click **OK**. Not available if Lock Truss Envelope and Webbing is checked.

- Check **Lock Truss Envelope and Webbing** to lock the size and configuration of the selected truss. If a locked truss is moved, it will maintain its original settings and will not fit properly if the new roof and ceiling conditions are different from the original.

- Check **No Special Snapping** to prevent the selected truss from using special truss snapping behavior. This box may become unchecked automatically if you edit a truss using its edit handles. When checked, **Object Snaps** may still occur. See “Special Truss Snapping” on page 492.

**Line Style Panel**

The settings on this panel affect the appearance of the selected truss in plan view only. See “Line Style Panel” on page 169.

**Fill Style Panel**

The settings on this panel affect the appearance of the selected truss in plan view. See “Fill Style Specification Dialog” on page 115.
Materials Panel
The settings on the MATERIALS panel affect the appearance of the selected truss in 3D views. See “Materials Panel” on page 542.

Label Panel
Roof truss labels can display in plan view when the “Framing, Roof Truss Labels” layer is turned on and use the Text Style assigned to that layer. See “Text Styles” on page 283.

For more information about the settings on this panel, see “Label Panel” on page 286.

Floor/Ceiling Truss Specification Dialog
To open the Floor or Ceiling Truss Specification dialog, select one or more floor or ceiling trusses and click the Open Object edit button. See “Floor and Ceiling Trusses” on page 490.

Default values for trusses are set in the Build Framing dialog. See “Trusses Panel” on page 477.

Components Panel
The information on the COMPONENTS panel can be used in the materials list. For more information, see “Components Panel” on page 692.

Object Information Panel
The information entered on the OBJECT INFORMATION panel can be used in schedules and the materials list. For more information, see “Object Information Panel” on page 693.

Floor/Ceiling Truss Specification Dialog

General Panel

1. Specify the Member Depth of the different components of the selected truss.
   - Specify the depth of the Top Chord.
   - Specify the depth of the Bottom Chord.
   - Specify the depth of the Webbing.

2. Specify the Thickness of the truss’s chords and webbing.
   - Specify the Overall Thickness of the selected truss.
   - Specify the thickness of the Webbing.

3. Specify the Maximum Span, which is the maximum horizontal distance between supports along the Top and Bottom Chord.
Options -

- Check **Vertical Supports** to use vertical supports in the selected truss.

- Check **Force Truss Rebuild** to rebuild the truss envelope based on the existing floor or ceiling platform when you click OK. Not available if Lock Truss Envelope and Webbing is checked, below.

- Check **Lock Truss Envelope and Webbing** to lock the size and configuration of the truss. A locked truss which has been relocated will maintain its original settings.

- Check **No Special Snapping** to prevent the selected truss from snapping along its long edge to a wall’s Main Layer or to the corner of a roof plane. If enabled, Object Snaps may still occur. See “Special Truss Snapping” on page 492.

**Line Style Panel**

The settings on this panel affect the appearance of the selected truss in plan view only. See “Line Style Panel” on page 169.

**Fill Style Panel**

The settings on this panel affect the appearance of the selected truss in plan view only. See “Fill Style Specification Dialog” on page 115.

**Materials Panel**

The settings on the MATERIALS panel affect the appearance of the selected truss in 3D views. See “Materials Panel” on page 542.

**Label Panel**

Floor and ceiling truss labels can display in plan view when the “Framing, Floor/Ceiling Truss Labels” layer is turned on and use the Text Style assigned to that layer. See “Text Styles” on page 283. For more information about the settings on this panel, see “Label Panel” on page 286.

**Components Panel**

The information on the COMPONENTS panel can be used in the materials list. For more information, see “Components Panel” on page 692.

**Object Information Panel**

The information entered on the OBJECT INFORMATION panel can be used in schedules and the materials list. For more information, see “Object Information Panel” on page 693.
The Trim Tools allow you to place corner boards and quoins at wall intersections that form corners. You can also assign moldings to a variety of objects, such as rooms and cabinets, in those objects’ specification dialogs. See “Specification Dialogs” on page 32.

Chapter Contents
• Trim and Molding Defaults
• Corner Boards
• Corner Board Specification Dialog
• Quoins
• Quoin Specification Dialog
• Editing Corner Boards and Quoins
• Millwork
• Applying Moldings

Trim and Molding Defaults
Select Edit> Default Settings to open the Default Settings dialog where you can access the defaults for a variety of drawing tools, including a number that affect trim and moldings.
• Click the + beside “Corner Trim” to access the defaults for Corner Boards and Quoins. See “Corner Boards” on page 501 and “Quoins” on page 503.
• Click the + beside “Floors and Rooms”, then beside “Floor Levels”. Select a floor level and click the Edit button to specify the default moldings for rooms on that floor. See “Floor Level Defaults” on page 226.
• Click the + beside “Door” to access the defaults for Interior and Exterior Doors. See “Door Defaults” on page 287.
• Select “Window” and click the Edit button to specify the default casing for windows. See “Window Defaults” on page 307.
• Click the + beside “Cabinet” to access the defaults for the Cabinet Tools, where you can specify default crown and other moldings. See “Cabinet Defaults” on page 335.

Corner Boards
Corner boards are added to a building exterior in any view by selecting Build> Trim> Corner Boards.
Click at a wall corner where you want to add trim. Be sure to click where the outside wall surfaces meet. If you click where the inside surfaces meet, corner trim will be created inside the room.

You can also add Corner Boards to all exterior corners at once by selecting **Build> Trim> Auto Place Corner Boards**.

By default, **Auto Place Corner Boards** adds Corner Boards to outside corners only. If you prefer, you can specify that inside corners receive corner boards in the **Corner Board Defaults** dialog. See “General Panel” on page 502.

Corner boards extend from the top plate down to the bottom of the floor platform of the floor on which it is placed, but do not extend to other floors. You must add corner boards to all floors of the building that you want to have corner boards.

A selected corner board or boards can be moved, but only to another wall corner or corners. In 3D views, corner boards can be lengthened or shortened using the edit handles. Corner boards can be copied, deleted and resized similar to other objects using the edit toolbar or the **Corner Board Specification** dialog.

The default material for corner boards is defined by the **Exterior Trim** entry in the **Material Defaults** dialog. See “Material Defaults” on page 540.

---

**Corner Board Specification Dialog**

Select one or more corner boards and click the **Open Object** edit button to open the **Corner Board Specification** dialog.

The settings in this dialog are similar to those in the **Corner Board Defaults** dialog, but affect the selected corner boards rather than all subsequently created corner boards.

---

**General Panel**

Specify the **Width** and **Thickness** of the selected corner board(s).

Check **Set Top/Set Bottom** to specify the top and bottom heights of the corner board(s).

- If **Set Top** is unchecked, the top of the corner board automatically extends to the top plate.
- If **Set Bottom** is unchecked, the bottom of the corner board automatically extends to the bottom of the floor platform.

In the **Corner Board Defaults** dialog, an additional **Auto Place Option** is available.

- Check **Include Inside Corners** to place Corner Boards on inside corners when the **Auto Place Corner Boards** tool is used. When unchecked, only outside corners receive corner boards.

**Note**: The Auto Place Corner Boards tool does not place corner boards on manually drawn dormers or at intersections with Attic Walls. See “Attic Walls” on page 207.
Materials Panel

The settings on the MATERIALS panel are available for a wide variety of objects in the program. For information about these settings, see “Materials Panel” on page 542.

Components Panel

The information on the COMPONENTS panel can be used in the materials list. For more information, see “Components Panel” on page 692.

Quoins

Select Build> Trim> Quoins in any view and click at a wall corner where you want to place quoins.

You can also add Quoins to all exterior corners at once by selecting Build> Trim> Auto Place Quoins.

By default, Auto Place Quoins adds Quoins to outside corners only. If you prefer, you can specify that inside corners receive quoins in the Quoin Defaults dialog. See “General Panel” on page 502.

Quoin Specification Dialog

Select one or more quoins and click the Open Object edit button to open the Quoin Specification dialog.

The settings in this dialog are the same as those in the Quoin Defaults dialog, but affect the selected quoins rather than all subsequently created quoins.

Note: The Auto Place Quoins tool does not place quoins on manually drawn dormers or at intersections with Attic Walls. See “Attic Walls” on page 207.

A selected quoin or quoins can be moved, but only to another wall corner or corners. In 3D views, quoins can be lengthened or shortened using the edit handles. Quoins can be copied, deleted and resized similar to other objects using the edit toolbar or the Quoin Specification dialog.

The size of quoins in plan view is relative on their size in 3D.

Initially, quoins use the same material as the default material of the wall surface they are placed against. This material is specified in the Wall Type Definitions dialog. See “Wall Specification Dialog” on page 212.
Specify the size and position of the quoins in the selected Quoin object.

- Specify the Width, which is the horizontal dimension of each quoin in the selected Quoin object. The dimension along the other wall is half this value when they are staggered or mirrored.
- Specify the Thickness, which is the amount that the quoin protrudes from the exterior surface of the wall.
- Specify the Quoin Height for individual quoins in the selected Quoin object.
- Specify the Quoin Gap, which is the distance between successive quoins.

Check Set Top/Set Bottom to specify the top and bottom heights of the quoin(s) in the text fields.

- If Set Top is unchecked, the top of the corner board automatically extends to the top plate.

Specify the arrangement of quoins used by the selected Quoin object.

- Uniform - Produce quoins that are of equal length on both sides of the corner.
- Staggered - Produce quoins that have one long side and one short side staggered on opposite sides of the corner.
- Mirrored - Produce quoins that alternate having either two long sides or two short sides.

- When Staggered or Mirrored is selected, check Swap Start Block to switch the starting order for the quoins.

In the Quoin Defaults dialog, an additional Auto Place Option is available.

- Check Include Inside Corners to place Quoins on inside corners when the Auto Place Quoins tool is used. When unchecked, only outside corners receive quoins.
Editing Corner Boards and Quoins

Before a corner board or quoin can be edited, it must be selected. Click on a trim object when the Select Objects tool is active. Corner boards and quoins can also be group selected and edited. See “Selecting Objects” on page 123.

Corner boards and quoins can be edited using their edit handles, the edit toolbar buttons, and their specification dialogs.

Using the Mouse

Depending on the type of view, a corner board or quoin displays a different set of edit handles when selected.

- In plan view, corner boards and quoins display one edit handle and can be moved from one eligible location at a wall corner to another.

- In 3D views, corner boards and quoins can be moved, lengthened, and shortened much the other line-based objects are. See “Editing Line-Based Objects” on page 126.

Deleting Corner Trim

Corner boards and quoins can be selected individually or in groups and deleted using the Delete edit button or the Delete key on the keyboard. They can also be removed using the Delete Objects dialog. See “Deleting Objects” on page 157.

Millwork

A selection of various types of millwork including columns, corbels and finials is available in the Library Browser. See “The Library Browser” on page 509.

Most millwork objects are designed to be placed in a plan as free-standing objects. Some - notably, newels and balusters - can be assigned to objects such as railings and stairs. See “Placing Library Objects” on page 521.

Millwork assigned to an object can be replaced from the library in 3D views. See “Replace From Library” on page 523.

Applying Moldings

Moldings can be applied to a variety of different types of objects in Home Designer Pro, including rooms, doors, windows, and cabinets. Moldings are assigned to their containing object in that object’s specification dialog.

Replacing an Existing Molding

If a molding profile has already been applied to an object, it can be replaced by another directly from the library in a 3D view. Select a molding in the library, then click on a molding assigned to an object in the plan. See “Replace From Library” on page 523.
In a 3D view, select a molding profile from the Library Browser and move your mouse pointer into the view window. When a molding is selected, the pointer displays the Moldings icon. When the mouse pointer is moved over a molding in the view, the Replace From Library icon displays instead. Click on the molding in the view to change its molding profile.

**Moldings Panel**

The specification dialogs for a variety of objects in the program include a MOLDINGS panel. Select an object or group of similar objects and click the Open Object edit button to open the specification dialog for that selection.

1. At the top of the dialog, one or more check boxes may be available.
   - Only available for rooms, uncheck **Use Floor Default** to make the settings that follow active. Check this box to use the defaults set in the Floor Defaults dialog for the current floor. See “Floor Level Defaults” on page 226.
   - If multiple objects with different moldings assigned to them are selected, a No Change check box will be available. Uncheck this box to make the settings that follow active but note that only moldings that all selected objects have in common will be retained.

2. The selected object’s Molding Profiles are listed in a table and can be edited here.
   - Select the name of a molding to edit it or remove it from the object.
   - Click in the Width and/or Height column and type to specify the selected molding’s size.
   - Specify the Vertical Offset of the selected molding, measured relative to the default molding location on the object it is assigned to.
   - A check mark in the To Top column means that the Vertical Offset value is measured from the top of the molding. When unchecked, this value is measured from the bottom of the molding. Click to place or remove a check mark.
   - When Retain Aspect Ratio is checked, if you change either the Height or Width, the other value changes to maintain their original ratio. When this
Applying Moldings

is unchecked, the two values can be edited independently.

The buttons on the right allow you to manage the moldings listed in the table.

- Click the **Add New** button to open the **Select Library Object** dialog and add a new molding profile to the selected object. See “Select Library Object Dialog” on page 522.
- Click the **Make Copy** button to add a copy of the selected molding profile at the bottom of the list.
- Click the **Replace** button to remove the selected profile and replace it with a new profile from the Library.
- Click the **Delete** button to remove the currently selected profile from the table.
- Click the **Move Up** or **Move Down** button to change the order of the line items in the table. This does not change a selected item’s Height, Offset, To Top setting, or Type: only its position in the table.

The **Selected Profile Options** only apply to the molding profile selected above.

- A preview of the molding profile(s) displays here. When multiple moldings of the same Type, To Top setting, or similar Height are specified, they will display together here, even when only one is selected. The selected profile is identified by thicker edge lines than the others. When multiple moldings of different Types, To Top, or Height settings are selected, no preview will display.
- Click the **Rotate Profile** button to rotate the selected profile 90° counterclockwise, or to the left. Not available for stacked moldings or a selected molding symbol.
- In the **Room Specification** dialog, choose the currently selected molding’s **Type** from the drop-down list: Base Molding, Chair Rail, or Crown Molding. See “Room Moldings” on page 240.

**Note:** The Default Base Molding is a basic rectangular stock profile rather than a profile from the library.

Many specification and defaults dialogs have previews of the selected object in which the moldings assigned to it can be seen. See “Dialog Preview Panes” on page 32.
Home Designer Pro’s library offers thousands of symbols, materials, and images that can enhance any plan.

New library catalogs and enhancements are made available by Chief Architect on a continuing basis and are available for download for the current program version.

You can also customize items from the library or import new items from outside the program and then save them in the library for future use.

Chapter Contents

- The Library Browser
- Searching the Library
- Find in Library
- Library Content
- Downloading Library Content
- Importing Library Catalogs
- Adding Library Content
- Organizing the Library
- Filtering the Display of Library Content
- Exporting Library Catalogs
- Placing Library Objects
- Select Library Object Dialog
- Replace From Library
- Displaying Library Objects
- Editing Library Objects
- Symbol Object Specification Dialogs

The Library Browser

The Home Designer Pro Library Browser allows you to manage the contents of the library as well as add library content to your drawings.

To open the Library Browser:

- Select View > Library Browser.
- Click the Library Browser button.
- Press Ctrl + L on your keyboard.

By default, the Library Browser is docked to the right side of the program window, but can be undocked or docked to another side. See “Docking the Library Browser” on page 512.

The Library Browser has four sections:

- The search options at the top.
- The Directory and Search Results Pane.
- The Selection Pane.
- The Preview Pane.

To adjust the height or width of a section, place the pointer over the split bar you want to move. When the double-headed arrow displays, click and drag.
You can work on your drawing with the Library Browser open. To close the Browser, click the Close button or double-click on an object in the Selection Pane.

The library directory is presented in a tree list with five categories: Home Designer Core Catalogs, Home Designer Bonus Catalogs, Manufacturer Catalogs, User Catalog and Trash. See “Library Content” on page 514.

1. Specify what displays in the Directory Pane’s tree list by selecting a filter from the drop-down list. See “Filtering the Display of Library Content” on page 520.
   - When “Not Filtered” is selected, all installed library content will display in the tree list.
   - “Not Filtered” will be the only available option until you create a custom filter.
   - Click the Manage Library Filters button to open the Manage Library Filters dialog. See “Manage Library Filters Dialog” on page 520.

2. Search the library using keywords and optional search filters. See “Searching the Library” on page 512.
   - Begin typing in the text field to search for library items. As you type, search results will display in the Directory Pane.
   - Search a specific catalog or folder by right-clicking on it and selecting Search Folder. Multiple items can be searched in this manner.
   - Right-click on an item in the Search Results list and select Show in Browser to view the item’s location in the Directory list.

3. In the Directory Pane, you can also browse the list using the arrow keys on your keyboard.

   - Click on an item to select it. Preview images display in the Selection and Preview Panes and basic information about it also displays in the program’s Status Bar. See “The Status Bar” on page 33.

   - The Selection Pane shows a thumbnail image of the item selected in the Directory Pane.

   - When an item is selected in the Directory Pane, a basic line-based representation of the item displays in the Selection Pane.
The Library Browser

- If the selected item is a single object, a preview of that object displays in the Preview Pane. You can move your cursor into the drawing area to place the item. See “Placing Library Objects” on page 521.

- If the selected item is a folder, a thumbnail image displays, representing each item inside. Move your pointer over an item in this pane to see a Tool Tip with the item’s name. Click on a folder in the Selection Pane to display its contents here and make it the item selected in the Directory Pane.

- Some folders may have too many items to display useful thumbnails for each; when this is the case, they do not display.

If you have Scrollable List checked in the Preferences dialog, a scroll bar is present at the bottom of the Selection Pane.

Click the Show/Hide Selection Pane button to toggle the Selection Pane on and off.

When an individual item is selected in either the Directory or Selection Pane, an image of it displays in the Preview Pane. If the item is designed to be inserted into another object such as a cabinet, that parent object will also display in the preview.

You can click the Toggle Preview Display button at the bottom of the browser window to switch between preview images in Standard Render and Vector View styles.

If the selected object is a 3D symbol, you can rotate and zoom in or out on the Preview using the mouse.

If you have rotated a view in the Preview Pane, you can restore the default angle either by clicking in the Selection Pane or by right-clicking on the Preview Pane and selecting Reset Preview.

Click the Show/Hide Preview Pane button to toggle the Preview Pane on and off.

The toolbar at the bottom of the browser aids in searching, displaying panes, and managing library content.

Click the Plant Chooser button to open the Plant Chooser dialog. See “Plant Chooser Dialog” on page 670.

Click the Get Additional Online Content button to launch your default web browser to the Home Designer Pro web site, where additional library content is available for download.

Click the Show/Hide Selection Pane button to toggle the Selection Pane on and off.

Click the Show/Hide Preview Pane button to toggle the Preview Pane on and off.

Click the Toggle Preview Display button to switch between Standard Render and Vector View images of a selected library object in the Preview Pane. See “Rendered and Vector Views” on page 558.

A selected material will display on a shape in the Preview Panel. The initial shape is a Sphere, but you can select a Cube, Teapot, or 2D Plane instead if you prefer. The object shape selection is also shared with the Define Material dialog. See “Define Material Dialog” on page 550.

Click the Preferences button at the bottom of the Library Browser to open the Preferences dialog, where display properties for the Library Browser can be controlled. See “Library Browser Panel” on page 66.

Using the Contextual Menus

A number of important library functions can be accessed using the contextual menus. Right-click on an item in the Library Browser to open a contextual menu displaying options related to that item. See Contextual Menus.

The options in the contextual menu vary depending on the item selected, but may include:

- Search Folder
- Cut/Copy/Paste
Expand/Collapse All

When a library category or folder is selected in the Directory Pane, **Expand All** and **Collapse All** are available in the contextual menu, allowing you to expand or contract its contents in the tree view.

Docking the Library Browser

Initially, the Library Browser side window is docked to the right side of the main Home Designer Pro program window. To undock it, click and drag its title bar towards the center of the program window. Once undocked, it can be moved and redocked in the same manner. See “Side Windows” on page 28.

When moved to the top, bottom, or side of the program window, it automatically docks in a vertical or horizontal orientation, depending on its location. You can prevent the Library Browser from docking when dragged:

- In the **Preferences** dialog. See “Appearance Panel” on page 62.
- By holding down the **Ctrl** key while dragging it.

To return the Library Browser to its original position and size, click the **Restore Position/Size** button in the **Preferences** dialog.

Closing the Library Browser

The Library Browser can be closed in either of two ways:

- Click the **Close** button at the top right corner of the browser window.
- Select **View> Library Browser**.

Searching the Library

The Library Browser filtering options let you focus your searches to meet parameters that you define.

**To search the Library Browser**

1. Select **View> Library Browser** and click in the Search field at the top of the Library Browser.
2. Begin typing a keyword to search for. As you type, the search results will populate in the Directory Pane below.
3. You can use quotation marks “” to search for an exact word or phrase, but other operations are not supported.
4. You can click the **Clear** button on the right side of the Search field to remove anything typed in this field.
5. If you move your mouse pointer over the Search field, a Tool Tip will state the number of results of your search.
6. Right-click on an item in the Search Results list and select **Show in Browser** to view the item’s location in the Directory list.
You can also search the contents of one or more specific catalogs and/or folders. Right-click on a catalog or folder level item or group-select multiple catalogs and/or folders and right-click on them, select Search Folder from the contextual menu, and proceed with step 2, above. See “Shift and Ctrl Select” on page 125.

Substrings are not included. For example, searching for “windows” will not produce “window” as a search result. On the other hand, searching for “window” will produce “windows” as a search result.

To search using custom filters

1. Click the Turn on search filtering options button.
   • Check Keyword to match the entered search keyword with an object’s search attributes.
   • Check Entire Word to match the entire keyword or words with the complete name of the object.

2. Click the arrow beside Type, Style, or Manufacturer to expand that category.
   • Check the box beside one or more Type of library item that you want to include in your search.
   • Check the box beside one or more architectural or design Style to include items of that style in your search.
   • Check the box beside one or more Manufacturer to include in your search. Manufacturer catalogs that were imported during the current program session will not be listed here until you exit out of and restart Home Designer Pro.

3. Type a keyword in the Search field. The results will be filtered to match your selected filtering options.

Find in Library

You can find out whether a selected object is saved in the library and if so, where, using the Find Original in Library edit tool.

The Find Original in Library edit tool also allows you to locate any objects inserted into the selected object as well as any materials or moldings assigned to it. See “Inserted Objects” on page 522.

Find in Library Dialog

The Find in Library dialog opens when you select one or more objects and click the Find Original in Library edit button. This dialog lists all of the selected objects as well as all objects assigned to and inserted into them.

Highlighted line items are categories that may have multiple components beneath them.

• Check the box beside a line item to find that object in the library.
• Check the box beside a category heading to select all items in that category.
When you click OK, the dialog will close and one of three things will happen:

- If a single line item was selected in the **Find in Library** dialog was clicked, that item will be selected in the tree list of the Library Browser.
- If the single line item is not found in the library, a message box will inform you of this and give you the option of adding it to the library.
- If multiple line items were selected, the **Show in Library Results** dialog will open, summarizing the status of each.

**Show in Library Results**

If multiple line items are selected in the **Find in Library** dialog, the **Show in Library Results** dialog will report where, or if, they are found in the library.

**Library Content**

The Home Designer Pro library has five categories: Home Designer Core Catalogs, Home Designer Bonus Catalogs, Manufacturer Catalogs, User Catalog and Trash.

**Home Designer Core Catalogs**

The Home Designer Core Catalogs category contains a wide selection of 3D symbols, images, and materials. If you install the program from USB drive, this library content will also be installed; if you download the software, you will be able to download the Core Catalogs separately, after the program is installed.

When you launch the program for the first time, it will ask if you want to download the Core Catalogs. Click Yes to begin the download. If you click No, you can download at any time by selecting **Library > Install Core Content** from the menu.

**Home Designer Bonus Catalogs**

Chief Architect regularly posts new library catalogs available for download. Select **Library > Get Additional Content Online** to access the bonus catalogs and content.

**Manufacturer Catalogs**

A variety of name brand library catalogs is available for download on the Home Designer web site with content ranging from materials to fixtures.

Select **Library > Get Additional Content Online** to access these Manufacturer Catalogs.

As with the Bonus Catalogs, some Manufacturer Catalogs are available free of charge while others can be purchased, and some are available for Support and Software Assurance members only.

Note: Support and Software Assurance is an optional program for holders of Chief Architect Premier and Chief Architect Interiors software licenses and is not available for Home Designer licenses.
The User Catalog

The User Catalog is the location for items that you add to the library either from a drawing or by importing. See “Adding Library Content” on page 517.

You can create and organize custom library folders and imported items such as symbols, images, backdrops, and materials. See “Organizing the Library” on page 518.

Updating Library Catalogs

The Home Designer Core Catalogs, Bonus Catalogs, and Manufacturer Catalogs are updated periodically to include new and improved content. You can update your installed catalogs to include the latest content by selecting Library> Update Library Catalogs at any time.

The program will gather information about the content in each of these three categories, and then download and replace any content that is not up to date, and you may see a progress indicator at the bottom of the Library Browser while it is doing so. See “Download Progress” on page 516.

Library Content Location

All library content aside from your User Catalog is stored in the System Library Database Folder. By default, this folder is created in the directory intended for shared application data in your operating system (C:\ProgramData in Windows; /Library/Application Support in macOS).

The Home Designer User Catalog File, User.Library.calib, is saved in the User Library Folder, which is located in the Home Designer Pro 2021 Data folder by default. See “Home Designer Pro Data” on page 40.

You can specify a different location for both if you wish in the Preferences dialog. If you choose a removable drive or network location, library slowness may result. See “Folders Panel” on page 69.

If you choose to use a different location for your User Catalog, your existing User Library content as well as your Backdrops, Images, Patterns, and Textures folders will be moved there, as well. It is important that you specify a directory on a hard drive with sufficient space to hold these files.

Backing up Custom Content

The best way to back up your custom library content is to export the items in your User Catalog, as this will ensure that the textures used by custom materials or imported symbols are not lost. See “Back Up Your Files” on page 45.

Exported libraries use the .calibz file format: a zipped file type that can include textures and images along with other library data.

To back up your custom library content

1. Launch Home Designer Pro and select View> Library Browser from the menu.
2. Right-click on a folder or item in the User Catalog.
3. Select Export Library from the contextual menu.
4. The Export Library Data dialog is a typical Save dialog. See “Exporting Files” on page 44.
   • Notice that the file type in the Save as type field is “Library File with Textures/Images (*.calibz)”.

Downloading Library Content

The Home Designer Core Catalogs, Home Designer Bonus Catalogs, Manufacturer Catalogs are all available for internet download.

Core Catalogs

When you launch Home Designer Pro for the first time, you will be asked if you want to download the Core Catalogs. Click Yes to begin the download.

Bonus and Manufacturer Catalogs

Bonus and Manufacturer Catalogs can be downloaded from our web site, www.HomeDesignerSoftware.com. Select
Library> Get Additional Content Online to launch your default internet browser to our Content Resources page.

**Download Progress**

When library content is downloading, a green progress bar will display at the bottom of the Library Browser. If you choose to download the Core Catalogs while the library is not open, the Browser will open so the progress indicator can display.

Click on the progress bar to display the name of the current file being downloaded, the total amount of data to be downloaded in KB, and the amount downloaded so far.

**Pausing and Resuming**

Library downloads can only take place while Home Designer Pro is running. If you close the program while a download is in progress, a dialog will confirm whether you wish to stop the download.

- Click **Stop Download and Close Program** to stop the download and close the program.
- Click **Cancel** to leave the program open and continue downloading.

Most catalogs are composed of a single file. If you stop the download midway, none of the downloaded data will be retained.

The Core Catalogs, on the other hand, contain a large volume of data saved in multiple files. If you close the program and stop the Core Catalogs download midway, only data associated with the file currently being downloaded will be lost. You can resume the download beginning with that file at a later time by selecting Library> Install Core Content.

**Download Errors**

If any problems occur during the library download process, a dialog box will notify you at the end of the download. Click **Retry Download** to repeat the download and correct any errors or click **Cancel** to discard the downloaded catalog.

**Importing Library Catalogs**

Home Designer Pro library files have two different file extensions: `.calib` and `.calibz`. Both files can include any combination of Home Designer Pro library items; in addition, `.calibz` files are able to save data associated with textures and images. Both file types can be imported into the Home Designer Pro library.

There are several ways to import a `.calib` or `.calibz` file into the program library:

- Double-click on the file in an operating system window while a plan or layout file is open.
- Drag the file from an operating system window and drop it into the Home Designer Pro program window.
- Select Library> Import Library from the program menu.

Although multiple versions of Home Designer can be installed on a computer, the operating system will only associate `.calib` and `.calibz` library files with one version. If they are not associated with Home Designer Pro 2021, click the Associate Files with this Program button in the Preferences dialog. See “File Management Panel” on page 68.

| Note: Library files cannot be imported if no plan or layout file is open, or when a Materials List window is active. |

**To import library files into the library**

1. Select Library> Import Library to display the Import Library Data dialog.
2. Browse to the `.calib` or `.calibz` file(s) that you want to import and either single or group-select the files so that their names display in the **File Name** field.
   - To select a group of files, click on the first one, hold down the Shift key, then click on another file. The two files plus all files in between are selected.
   - To select multiple files individually, click on one, hold down the Ctrl key, then click on additional files. Only the files you click on are selected.
   - To select all files in the directory, click on one and press Ctrl + A. Only do this if you wish to import all files in the folder.
3. Click the **Open** button.
4. A progress bar will display, telling you the progress of each library data file as it is imported.

5. Once imported, each file will be listed in its corresponding library category and will be selected in the Library Browser tree list. See “Library Content” on page 514.

When a .calibz file is imported into the program, any images or textures saved in it will be copied into the Home Designer Pro 2021 Data\Images and Textures folders for backup purposes. The program will only reference these copies if it cannot locate the files in their original locations. See “Home Designer Pro Data” on page 40.

Library Catalog Migration

If you have library catalogs from Home Designer Pro 2014 through 2020 installed on your computer, the initial startup of Home Designer Pro 2021 will give you the opportunity to migrate that content into the Home Designer Pro 2021 Library. See “Migrating Content and Settings” on page 14.

Legacy Library Conversion

You can import .calib and .calibz files created in Home Designer versions 2012, 10, or 9 for use in version 2021 at any time. See “Exporting Library Catalogs” on page 521.

In addition, legacy .alb files created in Home Designer versions 8.0 and prior can be converted for use in version 2021.

To convert legacy library files

1. Select Library> Convert Legacy (.alb) Library Files.

2. In the Select a Legacy Library File Folder dialog, select one or more .alb files that you want to bring in to Home Designer Pro 2021.

3. The selected files’ names will display in the File name: field.

4. Click the Open button to import these prior version third party .alb files into the User Catalog.

5. Organize the imported content to suit your needs. See “Organizing the Library” on page 518.

Third Party Library Content

There are a variety of third party sources for 3D symbols, textures and other items that may be of use in Home Designer Pro. Some sources even provide this content in .alb file format, which was the library file format used by Home Designer Pro versions 8.0 through X1. These third party libraries can be converted for use in Home Designer Pro 2021 as described above.

Adding Library Content

In addition to downloading Home Designer Pro Content and importing entire catalogs into the library, you can also add a variety of individual objects to the library.

Add to Library

Nearly any object imported into a plan or placed from the Library Browser can be added to the User Catalog in the library.

- Check Add to Library in the Import 3D Symbol dialog. See “Importing 3D Symbols” on page 632.
- Select an object in your plan and click the Add to Library ✪ edit button.

A few objects cannot be added to the library: notably terrain objects, CAD objects, imported pictures, metafiles, and PDF files.

Any object created using a drawing tool in Home Designer Pro will automatically be added to the User Catalog using the name of that tool, whereas a symbol will automatically use the Symbol Name. See “Native Objects vs Symbols” on page 525.

Once added to the library, objects in the User Catalog can be renamed. See “Renaming Library Items” on page 518.

Note: Library content exported from Home Designer Pro 10 will not include catalog names. Any subscribed content from version 10 that has not been downloaded will not be included, either.
Using the Contextual Menu

A variety of new content can be added to the User Catalog by right-clicking on it or on a folder within it and selecting New> from the contextual menu:

- Backdrops - See “3D Backdrops” on page 614.
- Fill Styles - See “Fill Styles” on page 115.
- Images - See “Images” on page 602.
- Plant Image - See “Plant Image Specification Dialog” on page 672.
- 3D Symbols - See “Importing 3D Symbols” on page 632.

See also “Using the Contextual Menus” on page 511 and “Adding New Folders” on page 518.

Creating a Customized Library Item

You can customize an existing library item and save your changes for future use by first copying the item into an unlocked library.

To customize a library object

1. Right-click on a library item and select Copy from the contextual menu.
2. Browse to the User Catalog or a folder within it and right-click on it.
3. Select Paste from the contextual menu to make a copy of the library item in this new location.
4. Right-click on the copied item and select Open Object from the menu.
5. The item’s specification dialog opens, and you can make any changes that you wish to the item.
6. Make any needed changes to the item, then click OK. Your changes will be saved with this item for use in any plan.

Organizing the Library

Library folders and objects can be copied, pasted, moved, and deleted: allowing you to organize your User Catalog to best suit your work style and needs.

Adding New Folders

New folders can be added to the User Catalog or to any folder located within it. To add a new folder, right-click on User Catalog or one of its sub-folders and select New> Folder from the contextual menu.

The new folder is created inside the library item you right-clicked on and is initially named “Untitled”. Type a short, descriptive name and press Enter.

Selecting Library Items

To select a library object, folder, or category, simply click on it. You can also multiple-select library items:

- To select a group of items, click on the first one, hold down the Shift key, then click on another file. The two files plus all files in between are selected.
- To select multiple items individually, click on one, hold down the Ctrl key, then click on additional files. Only the files you click on are selected.

When an item is selected, preview images display in the Selection and Preview Panes and basic information about it also displays in the program’s Status Bar. See “The Status Bar” on page 33.

A selected library item can be modified in a number of ways to help meet your organizational needs. When multiple items are selected, these options may be limited depending on the specific selection set.

Renaming Library Items

Only folders and objects in the User Catalog can be renamed. There are several ways to do this from the tree list:
• Right-click on the item, select **Rename** from the contextual menu, and type a new name.
• Click once on the item, press F2 on your keyboard and type a new name.
• Click once on the item, pause for a moment, then click a second time and type a new name.

Library names are case-sensitive and can contain up to 63 characters. While you can have more than one library item that uses the same name, it is best to use short, descriptive and unique names.

### Moving Library Items

Folders and objects in the User Catalog can be moved to new locations within the User Catalog. Folders and library objects are always organized alphabetically within each hierarchy.

To move one or more items to a different location, select it in the tree list, then click and drag it to the new location in the list. Directories and folders able to accept new content highlight as your mouse pointer moves over them. Release the mouse button to relocate the selected library item in the highlighted location.

You can also cut one or more library items from one location and paste them in another. When an item is cut, it is removed from its current location and saved to the system clipboard. To cut an item:
• Right-click on it and select **Cut** from the contextual menu.
• Click on the library item and press Ctrl + X on your keyboard.

To **Paste** the item, click on a library catalog or folder in the Library Browser tree view and either:
• Right-click on the new location and select **Paste** from the contextual menu.
• Press Ctrl + V on your keyboard.

When a library item is copied and pasted, the new item that results is independent of the original item. If you make changes to it, the original item is unaffected. Similarly, changes to the original item do not affect the copy.

### Library Shortcuts

In addition to copying and pasting to create new, independent library items, you can copy and paste to create Library Shortcuts. Library Shortcuts are not independent items - they are linked to the original item and are affected if changes are made to the original.

Library Shortcuts are advantageous because you can place a given library item in multiple locations to suit your organizational style without increasing the size of the library database and without having to maintain multiple copies of the same item.

To create a Library Shortcut, copy a library item to the system clipboard. Then, right-click on the location where you would like to create a copy and select **Paste Shortcut** from the contextual menu. Library Shortcuts use the same name as their source item but use the Library Shortcut icon.

To locate a Library Shortcut’s source item, right-click on it in the tree list and select **Locate Shortcut Source**.

If you move or delete an item from the library, any shortcuts to it will not be updated or removed. If you try to use a “hanging” shortcut, a message about its status will display in the library preview panes.

### Deleting Library Items

The five installed library categories: Home Designer Core Catalogs, Home Designer Bonus Catalogs, Manufacturer Catalogs, User Catalog, and Trash cannot be deleted.

Catalog level folders in all categories can be deleted; however, individual subfolders and objects can only be deleted out of the User Catalog.
Items in the library that are eligible for deletion can be deleted in either of two ways:

- Right-click on it and choose **Delete** from the contextual menu.
- Select it and press the **Delete** key on your keyboard.

When items from the User Catalog are deleted, they are moved to the Library Browser Trash. Items in the Trash can be retrieved by clicking and dragging them into any location in the User Catalog.

To empty the Trash, right-click on it and select **Empty Trash** from the contextual menu.

Depending on how much content is in the Trash, emptying it can be time consuming. You can click the **Cancel** button to end the process if you wish.

---

**Filtering the Display of Library Content**

Depending on how much library content you have imported or customized, the tree list in the Directory Pane can be very large. You can control what content displays in the list using **Library Filters**.

Library Filters do not remove content from the library database. They do, however, affect the library Search: unless you check **Include Filtered** in the advanced Search options, library content that is not displaying is not included in your searches.

You can also set up filters for your library Search results, but these two types of filters are unrelated. See “To search using custom filters” on page 513.

Library filters can be created, edited, and deleted in the **Manage Library Filters** dialog. Click the

Manage Library Filters button at the top of the Library Browser to open this dialog or select **Library> Manage Library Filters** from the menu.

Any filters that you create will be in the **Active Filter** drop-down list at the top of the Library Browser. Select a filter from the list to display content in the library tree list according to its settings. See “The Library Browser” on page 509.

---

Manage Library Filters Dialog

- A list of available library filters displays here. Click on a name in the list to select it. The
- Selected Filter is highlighted and can be edited using the options to the right.
Exporting Library Catalogs

Exporting library files allows you to:

- Back up your custom library content.
- Transfer library content between computers.
- Share custom library content with colleagues.

Exporting is often preferable to simply copying library files because it allows you to include images and textures in the exported library.

To export content from the library

1. Locate an object, folder, or catalog that you want to export, right click on it, and select Export Library.
2. In the Export Library Data dialog:
   - Choose the appropriate Save in: location for your exported library file.
3. Your exported library file can now be copied to a network location or storage device in an operating system window.

Any Shortcuts present in a catalog will be converted to regular library objects when exported. See “Library Shortcuts” on page 519.

Placing Library Objects

Library objects are subject to placement restrictions based upon typical real-life placement. Most library objects require sufficient free space at the location where they are placed, for example, and some library objects have additional requirements.

Library windows and doors, for example, must be placed in a wall just like standard windows and doors, and some fixtures are designed to be placed in cabinets.

Library symbols have placement restrictions that are determined when the symbol is created but can be changed later. See “Native Objects vs Symbols” on page 525 and “Symbol Specification Dialog” on page 183.

If a warning message displays when placing a library object, it will indicate where the object can be placed.

There are three main categories of items available in the Library Browser:

- Stand-alone objects that can be placed directly into a plan. Examples include cabinet modules, furnishings and images.
- 3D objects designed to be inserted into another 3D object. Examples include cabinet fixtures, windows and doors. Some items, such as cabinet doors and fixtures and fence panels, can be inserted into another object or placed as stand-alone objects.
• Materials and molding profiles, which cannot stand alone and must be assigned or applied to another object.

**Stand-Alone Objects**

Most library categories contain objects that can be selected in the Library Browser and placed directly in a 2D or 3D view.

• Most stand-alone objects are designed to rest on the floor or terrain.
• Some objects will rest on top of a cabinet, shelf, furniture or roof plane object if one is located at the point where they are first placed.
• A few objects, notably some light fixtures, will mount on the bottom of a wall cabinet or on the ceiling.
• In addition, some objects will attach to a wall if one is nearby.

**To place a stand alone library object**

1. Click on an object in the tree view or Selection Pane of the Library Browser to select it for placement. See “The Library Browser” on page 509.
2. Move your mouse pointer into the view area and notice that it displays an icon indicating the type of object selected instead of an arrow.
3. Click to place the selected object at that location.
4. Continue clicking to place as many instances of the selected object as needed. When you are finished, click the **Select Objects** button.

Once a stand-alone object has been placed, it can be edited in a variety of ways. See “Editing Library Objects” on page 525.

**Inserted Objects**

Some objects cannot stand alone and must be placed into other objects in a plan. For example, doors and windows must be inserted into a wall, while some appliances and plumbing fixtures are designed be placed inside a base cabinet. See “Doors” on page 287, “Windows” on page 307 and “Cabinets” on page 335.

With the exceptions of doors, windows, and skylights, an inserted library object can only display in a 2D or 3D view if the object that contains it is set to display. This is the case even if the inserted object’s layer is turned on. See “Displaying Library Objects” on page 524.

**To insert a library object**

1. Click on an item in the tree view or Selection Pane of the Library Browser to select it for placement. See “The Library Browser” on page 509.
2. Move your pointer into the drawing area.
3. Click on the object into which you wish to insert the selected library item. If the selected library item is designed to be inserted into that type of object, it will be placed into it.
4. Continue clicking on other objects to place as many instances of the selected item as needed. When you are finished, click the **Select Objects** button.

When an object has been inserted into another object, it can be replaced directly from the library. See “Replace From Library” on page 523.

If you try to insert an object into another object that is on a locked layer, nothing will be created. See “Object Creation and Layers” on page 104.

**Assigned Items**

Some library items, such as fill styles, moldings and materials, are not objects in themselves but can be applied to objects in a variety of ways.

• Using the specification dialog of the containing object. See “Select Library Object Dialog” on page 522.
• By selecting the item in the library and then clicking on the containing object.
• Materials and fill styles can be assigned to objects directly from the library in 3D views by selecting the library item and then clicking on an object. See “Eyedropper and Painter Tools” on page 155.

**Select Library Object Dialog**

The **Select Library Object** dialog is a modal version of the Library Browser that is accessible from object specification dialogs. See “Specification Dialogs” on page 32.
This dialog also opens when you select the Fill Style Painter tool. See “Painter Tools” on page 156.

The Select Library Object dialog only displays categories of items that are related to the selected object or tool. For example, if this dialog is accessed from the GENERAL panel of the Door Specification dialog, only door symbols will be listed:

The Select Library Object dialog is similar to the LIBRARY MATERIALS panel of the Select Material dialog. See “Select Material Dialog” on page 543.

Place Library Object Button

The Place Library Object button can be added to your toolbar and used for quick access and placement of frequently used library items.

If the Place Library Object button has not yet been assigned a library object, click it once to open the Library Object Button Specification dialog.

Double-click a Place Library Object button that has been assigned a library object to open the Library Object Button Specification dialog.

Replace From Library

There are two different ways to replace an object in a plan with another object from the library.

In 3D views, an inserted object or a molding profile can be replaced by a different item from the library with a single click. See “Inserted Objects” on page 522.

To replace an inserted object

1. Open the Library Browser, and browse to an object of a type similar to the one you wish to replace.
2. Select the object and move the mouse pointer into the 3D view window.
3. The Replace from Library icon will display near the mouse pointer when it passes over an object.
object that can be replaced by the selection from the library.

4. Click once to replace the object in the plan with the selected object from the library.

Some types of inserted objects - notably, doors and cabinet doors and drawers - can also be replaced in this manner in plan view. The Replace from Library icon does not display in plan view, however.

The Replace From Library edit button is available for nearly any stand-alone object that can be added to the library and can be used in 2D and 3D views. Click this button to open the Replace From Library dialog and replace the selected object, and others like it if you choose, with an object of the same type from the library.

1. Select one of the Replacement Options.

• Select Replace Selected Object to replace only the currently selected object.

• Select Replace Identical Objects in Room to replace all objects that are in the same room as, and are identical to, the currently selected object. Not available for doors or windows.

• Select Replace Identical Objects on Floor to replace all objects that are on the same floor as, and are identical to, the currently selected object.

2. Click the Library button to open the Select Library Object dialog and select an object to use as a replacement. The name of the object that is currently selected as a replacement displays above.

Replace From Library cannot be used to replace a selected cabinet with a cabinet of a larger size. In addition, it is not available for backdrops and items assigned to other objects, such as materials.

Displaying Library Objects

The display options available for library objects depend on the type of object in question, as well as the view.

If the display of an object is turned off in a 2D or 3D view, any objects inserted into it will not display in that view, either - even if the inserted object’s layer is turned on. The exception to this rule is doors and windows, which can display in 3D views when their containing wall does not. See “Inserted Objects” on page 522.

In Plan View

All library objects except materials, doors and drawers applied to cabinets, and backdrops can display in plan view. Library objects are represented in plan view by 2D symbols that resemble the size and shape of the object when viewed from above. To learn how to specify the symbol that represents an object, see “Image Specification Dialog” on page 604.

As with other architectural objects, the display of library objects is controlled by layer in the Layer Display Options dialog. Each library category has its own layer. See “Layer Display Options Dialog” on page 111.

Like other objects, each library symbol is placed in a Drawing Group that affects whether it displays in front of or behind other objects. You can modify a selected symbol’s place in the drawing order by clicking the View Drawing Group Edit Tools button.
Editing Library Objects

Library objects can be customized to suit your design needs. There are three approaches to doing so:

- Select an object in the User Catalog, edit it using any of the options in its contextual menu, and your changes will be reflected when you next place this library object in a drawing.
- Place an object in a drawing and then edit it using the various edit tools available for it. This will not affect the original object still saved in the library.
- Place an object in a drawing, edit it using the available edit tools, and then add it back to the library for future use. This will not replace the original object still saved in the library. See “Add to Library” on page 517.

Library objects placed in a drawing can be selected individually or as a group, like other objects in Home Designer Pro. See “Selecting Objects” on page 123.

Once selected, a library object can be edited in a variety of ways using dimensions, the edit handles, the edit toolbar buttons and its specification dialog. See “Symbol Object Specification Dialogs” on page 526.

Native Objects vs Symbols

In Home Designer Pro, objects created using the program’s standard tools, such as the Door Tools and Cabinet Tools, are referred to as native objects.

On the other hand, objects placed from the library, such as fixtures and furnishings, are symbols. Symbols are typically more limited than native objects in how they can be edited.

In addition to the symbols available in the library, you can import additional symbols into the program from 3D .obj, .3ds, .skp, or .dae files. See “Importing 3D Symbols” on page 632.

Any changes made to objects like fixtures and furniture will not be reflected in their Materials List Description, although they may be seen in other columns, such as Size. See “Materials Lists” on page 681.

Using Edit Handles

Most free-standing library symbols are box-based objects and can be edited as such once placed in a drawing. See “Editing Box-Based Objects” on page 136. Depending on the type of view and the surface selected, the edit handles a symbol displays will vary.

When a typical symbol is selected in plan view or on the top surface in a 3D view, up to ten edit handles display. They are the Move handle at the center, the Rotate handle just outside the front indicator (a V) and a Resize handle on each edge and at each corner.
When a symbol is selected on a side in a cross section/elevation or 3D view, it displays six edit handles: the Move handle, a Rotate handle, and a Resize handle on each edge. See “Selected Side” on page 124.

When a free-standing symbol is selected on its side and rotated, you will be prompted to choose whether to update its plan view symbol to reflect its new orientation, as viewed from above. See “In Plan View” on page 524.

Symbols cannot be concentrically resized, even when the Concentric edit behavior is enabled. See “Defaults, Preferences, and Edit Behaviors” on page 119.

Fixtures and furniture placed in a plan are subject to bumping/pushing behavior when moved. See “Bumping/Pushing” on page 142.

In the Specification Dialog

The specification dialog for an individual symbol, Callout, Marker, Elevation Point, image, or plant image in the User Catalog can be edited from the Library Browser Directory Pane. Right-click on the item and select Open Object from the contextual menu. See “Specification Dialogs” on page 32.

Individual or multiple group-selected materials can be edited by right-clicking and selecting Open Object as well. See “Define Material Dialog” on page 550.

Deleting Built-in Fixtures and Appliances

A fixture installed into the front of a cabinet becomes a cabinet face item, like a door or drawer. It can be resized or deleted like other face items in the Cabinet Specification dialog. See “Front Panel” on page 351.

Components

Many architectural objects have a Components panel in their specification dialog that lets you control how that object displays in the Materials List. See “Components Panel” on page 692.

Changes made to the components of an object saved in the library do not affect instances of that object already placed in a plan: they are only applied to instances of the object placed in the future.

Terrain objects, CAD blocks, moldings, images, backdrops, and materials do not display in the Materials List.

Symbol Object Specification Dialogs

The Fixture, Furniture, Geometric Shape, Hardware, Millwork, and Sprinkler Specification dialogs all feature the same options. The actual name of the dialog is determined by the type of object that is currently selected.

For example, selecting a library object placed from the Interiors Core Catalog and clicking the Open Object edit button opens the Furniture Specification dialog.
General Panel

The Name of the selected symbol object displays here.

Size/Position -

- Specify the Width, Height, and Depth of the object.
- Check Retain Aspect Ratio to maintain the ratio between the object’s Height, Width, and Depth when it is resized in the specification dialog. Does not affect the behavior of the object’s edit handles.
- Click Reset Size to reset the symbol’s original, unmodified size. The symbol’s elevation is not affected by this option.
- Select the Elevation Reference from the drop-down list. This determines where the next two settings are measured from and also affects their setting labels.
- Specify the height to Top, measured from the selected Elevation Reference to the top of the object.
- Specify the height to Bottom, measured from the selected Elevation Reference to the bottom of the object.

The Sprinkler Settings are only available if the selected object is a sprinkler. See “Sprinkler Tools” on page 675.

- Specify the Spray Angle, which is the angle within which the sprinkler sprays. An angle of 360° forms a complete circle.
- Specify the Spray Radius, which is the distance from the sprinkler head that the spray reaches.

Options -

Check Reverse Symbol to reverse the object’s appearance, so that features on its left are positioned on its right, and vice versa. This turns a right-hand refrigerator, for example, into a left-hand refrigerator. This option has no effect on objects that are symmetrical.
- Check Flush Mounted to specify that the selected object follow the pitch of either the ceiling or roof. Only available when “From Ceiling” or “From Roof” is selected as the Elevation Reference, above.

If the selected object has a Copyright, information about it displays here.

A preview of the selected library object displays here and updates with changes. If the selected symbol is inserted into another object, such as an appliance in a cabinet, the parent object will also display. See “Dialog Preview Panes” on page 32.
Fill Style Panel
The FILL STYLE panel is available when the selected object is a sprinkler and controls how the area within its spray radius displays in plan view. It is similar to the FILL STYLE panel found in many dialogs. See “Fill Style Specification Dialog” on page 115.

Materials Panel
The settings on the MATERIALS panel affect the appearance of the selected object in 3D views. See “Materials Panel” on page 542.

Label Panel
A variety of library objects can display labels in plan view. Labels use the Text Style assigned to the layer they are on.
For information about the settings on this tab, see “Label Panel” on page 286.

Components Panel
The information on the COMPONENTS panel can be used in the materials list. For more information, see “Components Panel” on page 692.

Object Information Panel
The information entered on the OBJECT INFORMATION panel can be used in the materials list. For more information, see “Object Information Panel” on page 693.

Manufacturer Panel
The MANUFACTURER panel provides contact information for the selected object’s manufacturer. Only available for symbols from Manufacturer library catalogs. See “Manufacturer Catalogs” on page 514.
Chapter 27: Architectural Blocks

An architectural block is a collection of individual 3D objects that are grouped together so that they can be placed and moved as a single object. Although blocked together, these objects retain many of their own attributes, such as materials.

Architectural blocks can also be exploded so that the individual sub-objects become independent of one another.

Chapter Contents

• Creating Architectural Blocks
• Displaying Architectural Blocks
• Editing Architectural Blocks
• Architectural Block Specification Dialog
• Architectural Blocks, Sub-Objects, and Components

Creating Architectural Blocks

To create an architectural block, group-select multiple architectural objects, then click the Make Architectural Block edit button.

Architectural blocks can be created in any view. See “Architectural vs CAD Objects” on page 99.

The following is a list of objects that can be included in architectural blocks:

• Cabinets (Base, Wall, Full Height)
• Custom Countertops
• Soffits, Shelves, Partitions
• Fixture and Furniture symbols

Displaying Architectural Blocks

As with individual objects, the display of architectural blocks is controlled in the Layer Display Options dialog. See “Layer Attributes” on page 110.

• Hardware symbols
• Millwork symbols
• Geometric Shapes
• Electrical objects
• Images
• Slabs and Foundation Slabs
• Roads, Driveways, Sidewalks
• Terrain Features and Terrain Modifiers

Once blocked, the set of blocked objects is contained in a bounding box, indicating that they are now an architectural block.

• If an architectural block is composed of objects that are on the same layer, the block will be placed on that layer, as well.
• If an architectural block is composed of objects on different layers, the block will be placed on the “Architectural Blocks” layer.
In Plan View
You can control the appearance of the bounding box by changing the display properties of the architectural block’s layer or you can turn off its display in the Architectural Block Specification dialog. See “General Panel” on page 531.

Like other objects, an architectural block is placed in a Drawing Group that affects whether it displays in front of or behind other objects. You can modify a selected architectural block’s place in the drawing order by clicking the View Drawing Group Edit Tools edit button. See “Drawing Group Edit Tools” on page 114.

Architectural Block Labels
Architectural blocks can display labels for both the block and any component objects that have labels in plan view. Labels for architectural blocks are placed on the “Architectural Blocks, Labels” layer and use the Text Style assigned to that layer. See “Object Labels” on page 285.

The label for an architectural block can be generated automatically, user-specified, or suppressed. See “Architectural Block Specification Dialog” on page 530.

Editing Architectural Blocks
Architectural blocks can be selected and edited in 2D and 3D views. See “Selecting Objects” on page 123

Once selected, an architectural block can be edited using its edit handles, edit toolbar buttons, and specification dialog. See “Architectural Block Specification Dialog” on page 530.

Using the Edit Handles
A selected architectural block displays a Move handle and a Rotate handle.

Architectural blocks cannot be resized, but the individual objects in the block can be.

In the Specification Dialog
Architectural blocks can be edited in their specification dialog.

Using the Edit Tools
A selected architectural block or blocks can be edited in a variety of ways using the buttons on the edit toolbar. See “The Edit Toolbar” on page 29.

Architectural Block Specification Dialog
The Architectural Block Specification dialog controls the way architectural blocks display in plan view and in materials lists.

Select one or more architectural blocks and click the Open Object edit button to open this dialog.

Explode Architectural Block
You can break an architectural block to make its objects independent. Select the architectural block and click the Explode Architectural Block edit button.

Note: If you open a plan created in another version of Home Designer and an architectural block includes an object that you cannot create in your version of the software, you cannot unblock it or edit its components.

Once exploded, an architectural block cannot be made into a single object again.

Adding Architectural Blocks to the Library
You can create your own architectural blocks and save them in the library. See “Add to Library” on page 517.
General Panel

1. The Display Options control the appearance of the selected architectural block in plan view. See “Displaying Architectural Blocks” on page 529.
   - Check Display Bounding Box to show the bounding box of the objects in the architectural block.
   - Uncheck Display Sub-Objects to suppress the display of the sub-objects and display only the bounding box. If Display Bounding Box is unchecked, it will become checked.

2. Specify the selected architectural block’s Size/Position relative to the floor or terrain. Not available if the selected block includes any objects that do not have these settings in their specification dialogs.
   - Select the Elevation Reference from the drop-down list. This determines where the next two settings are measured from and also affects their setting labels.
   - Specify the height to Top, measured from the selected Elevation Reference to the top of the architectural block.
   - Specify the height to Bottom, measured from the selected Elevation Reference to the bottom of the architectural block.

Label Panel

Labels for Architectural Blocks display in plan view when the “Architectural Blocks, Labels” layer is turned on and use the Text Style assigned to that layer. See “Architectural Block Labels” on page 530.

The LABEL panel is available for a variety of different objects. For more information, see “Label Panel” on page 286.

Components Panel

The information on the COMPONENTS panel can be used in the materials list. For more information, see “Components Panel” on page 692.

Object Information Panel

The information entered on the OBJECT INFORMATION panel can be used in the materials list. For more information, see “Object Information Panel” on page 693.

Architectural Blocks, Sub-Objects, and Components

An architectural block is composed of a group of sub-objects that have been blocked together. For example, a kitchen island architectural block may consist of cabinets, appliances, a custom countertop, and other accessories.

Each of the sub-objects in an architectural block may contain additional parts called components. The cabinets in a kitchen island, for example, may contain handles, hinges, and drawer glide.

Sub-Objects

Certain attributes of an architectural block can be edited at the sub-object level. A sub-object can be edited by accessing its specification dialog in either of two ways:
   - Explore the architectural block, select the sub-object, and click the Open Object edit button.
• Select the sub-object while it is part of the architectural block and click the Open Object edit button. Some attributes may not be editable while the object is part of a block. See “Editing Architectural Blocks” on page 530.

To select a sub-object

1. Click the Select Objects button, then click on the sub-object that you would like to edit.
2. With the architectural block selected, click the Select Next Object edit button or press the Tab key.

The selection switches to the individual object and it can be edited using its edit handles, edit toolbar and specification dialog.

The options for editing a sub-object may be more restricted than if the object were independent. If more extensive editing is required, the architectural block must be exploded.

Components

You can view and modify the components of an architectural block or group of blocks in the Architectural Block Specification dialog. The COMPONENTS panel lists all the sub-objects that comprise an architectural block, as well as the components that make up each sub-object. See “Components Panel” on page 692.
Home Designer Pro has additional objects that can be used to customize your design.

Chapter Contents

- General Shapes
- Soffits
- Special Applications for Soffits
- Soffit Specification Dialog
- Material Layers Definition Dialogs

General Shapes

Items in the Home Designer Core Catalogs> Shapes library catalog allow you to create a variety of custom objects using basic geometric shapes. These shapes can be used individually or combined to create a wide variety of custom objects.

Soffits

Soffits typically fill the space between the tops of wall cabinets and the ceiling, but they are very versatile and can be used to create almost any other object that can be modeled as a 3D box. Select Build> Cabinet> Soffit to activate this tool.

Soffit Defaults

The default settings for soffits are set in the Soffit Defaults dialog. The settings in this dialog are similar to those in the Soffit Specification dialog. See “Soffit Specification Dialog” on page 535.

When a soffit is created, it is placed on the “Cabinets, Soffits” layer. See “Layer Attributes” on page 110.

For best results when placing soffits above wall cabinets:

- The default soffit should be the same width as and 1” (20mm) deeper than the default wall cabinet. See “Cabinet Defaults” on page 335.
- The default soffit Floor to Bottom value should equal the sum of the default wall cabinet’s Floor to Bottom value plus its Height. See “General Panel” on page 536.
- The default soffit Height should be equal to or greater than the space between the ceiling and the top of the wall cabinets.

If the sum of the default soffit’s Floor to Bottom value and Height is larger than the ceiling height of the room in which a soffit is placed, the Floor to Bottom value will be retained and its Height will be adjusted so that it fits under the ceiling.

The maximum soffit width is 250 feet (48m), and the minimum width is 1/16” (1 mm).
Once a soffit is placed in a plan, you can change its size and position to meet a variety of needs.

**Placing Soffits**

Soffits can be created in both 2D and 3D views by simply clicking with the Soffit tool active. See “Click-to-Create” on page 103.

To create a corner soffit, click as close to an inside wall corner as possible. A corner soffit retains its shape when it is moved, edited, or copied.

When positioned against a wall in a room, soffits will automatically display any moldings present in that room that are at the same height as the soffit. Soffits can also have custom molding profiles assigned to them. See “Moldings Panel” on page 247.

When positioned against the ceiling in a room, a soffit will prevent the Ceiling Finish layers directly above it from generating in 3D. See “Lowered Ceilings” on page 238.

**Special Applications for Soffits**

Nearly any object with straight, flat sides can be represented by one or more Soffits. They can be resized to as small as 1/16” (1mm) per side, or as large as 250 feet (48m).

Soffits can have materials applied to them to represent simple mirrors, posts, chimneys and so on. Following are some additional examples.

**Roof Beams and Coffered Ceilings**

Sloped soffits can be used to represent beams or rafters that follow the pitch of the roof in rooms with cathedral ceilings. See “Sloped Soffits” on page 537.

Soffits can also be used to create coffered ceilings. They will display any moldings assigned to the room it is in that are at its height. In addition, you can assign moldings directly to a soffit in its specification dialog. See “Moldings Panel” on page 537.

**Accent Tiles**

A material such as ceramic tile can be assigned to one or more soffits applied to the walls above tubs or in showers.
Masonry Veneer

As an alternative to a pony wall, you can use a soffit to create a brick or stone veneer over part of a wall. Specify a soffit depth equal to the masonry material to be used.

Soffits automatically stop at the floor platform when moved downward or at the ceiling platform when moved upward - even when the soffit is not located in a room. To move or resize a soffit through a floor or ceiling platform, select it and hold the Ctrl key down while dragging its edit handles. See “Unrestricted Movement” on page 142.

Calculating Materials on Soffits

By default, soffit materials are not calculated in the Materials List. In order for a soffit’s material to be counted, it must be edited so that it is not using the default material. See “Material Defaults” on page 540.

The number of bricks, tiles, shingles, shakes or other materials applied to a soffit is calculated using the following rules:

• If the soffit depth is less than the larger of 4 inches (10 mm) or 1 ½ times the material thickness, then only the front area of the soffit is used. Thus if a soffit is 48"x48"x4" thick, and the Dark Red brick material is used (3"x 8" with 3/8" mortar joint) the front of the soffit is 48"x48"=2304 square inches. Including the mortar joint, each brick requires 3 3/8" x 8 3/8" = 28.26 square inches. 2304 sq. in. divided by 28.26 sq. in. per brick gives 81.5 bricks.

• If the soffit depth is greater than both 4 inches (10 mm) and 1 ½ times the material thickness, then the surface areas of the soffit back, sides and top are used in addition to the front, if these surfaces are not attached to a wall or other soffit. However, only those portions of the sides, top and bottom remaining after subtracting twice the material thickness are used. So, for Dark Red brick, which has a depth of 4", the sides, top and bottom surface areas cannot contribute to the brick count unless the soffit depth is greater than 8 inches.

• If surface materials such as brick are applied to a large soffit, the soffit center is assumed to be hollow, with only a single layer of the material applied to each applicable face.

• For shingles and shakes, the overlap amount should be subtracted from the height, as opposed to brick or tile, where the joint width is added to the size.

• For materials in the area category, the soffit area calculation above is used, with the material thickness treated as zero.

• For materials in the volume, concrete or earth categories, the true volume of the soffit is used.

Soffit Specification Dialog

To open the Soffit Specification dialog, select the soffit and click the Open Object edit button or double-click on a soffit using the Soffit tool.

The settings in this dialog are similar to those in the Soffit Defaults dialog, but affect only the selected object(s).
Define the **Size** and **Position** of the selected soffit relative to the floor or terrain.

- Specify the **Width** of the soffit.
- Define the vertical **Height** of the soffit.
- Define the **Depth**, which is the distance between the front and the back of the soffit. When selected in plan view, the front of a soffit has a “V,” and the back of the soffit has a triangular rotation handle.
- If the selected soffit is a corner soffit, the **Width** controls its left side width, and **Depth** controls its right side width.
- Specify the distance from **Floor to Top** of the soffit.
- Specify the distance from **Floor to Bottom** of the soffit.
- When the selected soffit is outside a room, its Floor to Bottom height is measured relative to the terrain. Check **Auto Adjust Height** to maintain the same distance above the terrain if the soffit is moved to a location with different terrain height. Uncheck this to maintain the same absolute height regardless of the terrain below. When **Auto Adjust Height** is checked, the Floor to Bottom value may automatically adjust if the soffit is moved.
- Check **Sloped Soffit** to slope the soffit vertically from the back up towards the front. This may become checked automatically if you check Place Under Ceiling or Place Under Roof, below. When you specify a soffit as sloped, the available options on this panel change. See “Sloped Soffits” on page 537, below.
- The **Height at Back Face** and **Front Face** settings become enabled when Sloped Soffit is checked. See “Sloped Soffits” on page 537.

### Options -

- Check **Place Under Ceiling** to adjust the soffit’s height so its top contacts the ceiling above. If the soffit is below a sloped ceiling plane, Sloped Soffit will become checked and the Height at Back and Front Face will adjust to match the pitch. Not available in the **Soffit Defaults** dialog, or if the soffit is not below a ceiling.
- Check **Place Under Roof** to adjust the soffit’s height so its top contacts the bottom of the roof above. Provided that the roof above does not have a pitch of 0, Sloped Soffit will become checked and the Height at Back and Front Face will adjust to match the pitch. Not available in the **Soffit Defaults** dialog, or if there is no roof above the soffit.
- Check **Ignore Room Moldings** to prevent the selected soffit from displaying moldings assigned to the room that it is placed in. See “Special Applications for Soffits” on page 534.

A preview of the soffit displays on the right side of the dialog box. See “Dialog Preview Panes” on page 32.
Moldings Panel
The settings on the MOLDINGS panel allow you to assign one or more horizontal moldings around the selected soffit.

For information about the settings on this panel, see “Moldings Panel” on page 506.

Fill Style Pane
The settings on the FILL STYLE panel affect the selected soffit’s appearance in plan view. For information about the settings on this panel, see “Fill Style Specification Dialog” on page 115.

Materials Panel
Soffits are not calculated in the Materials List unless a non-default material is specified. See “Calculating Materials on Soffits” on page 535.

For information about the settings on this panel, see “Materials Panel” on page 542.

Sloped Soffits
When a soffit is specified as sloped, the available options on the GENERAL panel of the Soffit Specification dialog change.

- **Width** is measured left to right across the soffit, parallel to the front of the soffit.
- **Thickness** is the top-to-bottom height of the front and back faces of the soffit.
- **Horizontal Length** is measured from back to front in plan view. When a soffit is sloped, this measurement is not the actual length of the soffit’s bottom or top edge. It cannot, for example, be used to determine the length of a sloped beam.

Both the front and back heights of a sloped soffit must be defined. Checking Place Under Ceiling or Place Under Roof will automatically adjust these values to match the slope of the ceiling or roof plane above.
• **Height at Back Face** is measured from the finished floor to the lowest point at the back of the soffit.

• **Height at Front Face** is measured from the finished floor to the underside of the soffit at the upper end.

**Material Layers Definition Dialogs**

The **Material Layers Definition** dialogs allow you to define the layers that make up wall, floor, ceiling, slab, and roof assemblies. The names of these dialogs vary and are determined by the type of object or component being edited. They include:

- Backsplash Layers Definition Dialog
- Ceiling Structure Definition
- Floor Structure Definition

See “Custom Backsplashes” on page 340 and “Floor and Ceiling Platforms” on page 236.

![Material Layers Definition Dialog](image)

1. The selected assembly’s **Layers** are listed here. Layers are numbered and listed from the top of the structure to its bottom. To select a layer for editing, click in its row.

2. Click in the **Pattern** or **Texture** column to open the **Select Material** dialog and choose a material for the selected layer. See “Select Material Dialog” on page 543.

3. Click in the **Thickness** column to type the selected layer’s thickness or depth. Very thin layers can be created, but for best results avoid using a thickness of 0. For very small values, it can be helpful to temporarily change the dialog number format: click the Number Style button.

4. The **Total** thickness of the assembly displays to the right as a reference.

5. Select a **Structure Type** from the drop-down list. Only available when the selected material is a Framing type. See “Framing Materials and Types” on page 483.

6. A preview of the selected assembly displays here. See “Dialog Preview Panes” on page 32.

7. By default, a gap is shown between each of the assembly layers. Click the **Explode Layers** button to remove or restore these gaps.
The objects used in Home Designer Pro have a variety of 3D properties. These objects - walls, windows, doors, cabinets, roof planes, lot perimeters, etc. - can have materials assigned to them so that they look realistic in 3D views. These materials can also be used to generate materials lists that can help with cost estimations.

Designing with objects that look correct in 3D and calculate properly in the Materials List requires that you use realistic material definitions and apply them appropriately to objects in your plan.

Home Designer Pro comes with many materials that are ready for use. From siding, roofing, flooring, masonry, tile, and paneling, to grass, water, and wood materials, Home Designer Pro has materials for every application, inside and out. If you cannot find a material that suits your needs, you can customize the materials provided or create your own.

Learning how to create, manage, apply, and edit materials saves time and adds that professional touch to your designs.

⚠️ Redefining only the visual properties of a material may create unexpected results. For example, changing the image of a brick material to represent siding does not cause the material to be considered as siding during material calculations.
About Materials

The materials that are assigned to objects in Home Designer Pro perform two important roles:

- They determine what the surfaces of objects look like in 3D views.
- They influence how objects are calculated in the Materials List. See “Materials Lists” on page 681.

Materials are stored in the Library Browser and can be applied to objects in either of two ways:

- Using the Material Painter.
- In an object’s specification dialog. See “Materials Panel” on page 542.

Patterns and Textures

In Home Designer Pro, materials have two attributes that determine what they look like in 3D views: Textures and Patterns.

- Textures are created using special image files that tile seamlessly when applied to surfaces and are visible in most Rendering Techniques. See “In Rendered Views” on page 566.
- Patterns are composed of CAD lines and are seen in Technical Illustration and Vector Views. See “Rendering Techniques” on page 595.

Often, the texture and pattern for a given material are both set up to represent the characteristics of the material in the real world and have similar sizing and angles. When customizing such a material, check Keep Pattern/Texture in Sync before making changes to maintain this consistency. See “Define Material Dialog” on page 550.

Materials List Calculation Methods

Every material can be assigned a Calculation method which defines how the material is calculated in the Materials List: for example, by piece, area, volume and so on. See “Materials and the Materials List” on page 547.

Material Defaults

Most objects in the program have defaults dialogs which allow you to set up a variety of attributes, including materials, before the objects are created. These defaults dialogs are accessed by selecting Edit> Default Settings. See “Preferences and Default Settings” on page 57.

The Material Defaults dialog serves two purposes. It allows you to:

- Set the default materials for objects that do not have a defaults dialog: for example, fireplaces and furnishings from the library.
- Set the initial materials that can then populate a variety of defaults dialogs. Door, Window, and Cabinet Defaults are examples of defaults dialogs that can draw their material assignments from the Material Defaults dialog.

Material defaults are dynamic, which means that if you change a particular default material, all objects that are set to use that default will automatically update to use the new material. See “Dynamic Defaults” on page 58.

Because material defaults are dynamic, you can use the Material Defaults dialog to apply a material to multiple objects that share similar components. For example:

- The “Room Moldings” Material Default applies to the base, crown, and chair rail moldings that can be assigned to rooms, as well as to interior door and window casing. If you change this Material Default, all of these objects in the plan can be affected.
- The “Cabinet”, “Cabinet Door/Drawer”, “Countertop”, and “Hardware” Material Defaults can be used in your Cabinet Defaults dialogs to ensure that all cabinets use the same materials. See “Dynamic Cabinet Defaults” on page 336.

Material Defaults Dialog

Select Edit> Default Settings from the menu, select “Materials”, and click the Edit button to open the Material Defaults dialog.
Material Painter Tools

In a 3D view, select 3D > Material Painter to access the Material Painter Tools, which are used to apply materials to object surfaces.

The Material Painter tools are not available in Glass House views. See “Glass House” on page 595.

Material Painter

The Material Painter tool allows you to apply a selected material to other objects in 3D views. It can be activated in several ways:

- Select 3D > Material Painter > Material Painter.
- Select a material in the Library Browser while a 3D view is active.
- The Material Painter also becomes active when the Material Eyedropper is used.

The Material Painter is similar to the other Painter tools but has some additional considerations. See “Painter Tools” on page 156.

To use the Material Painter tool

1. In a 3D view, select 3D > Material Painter > Material Painter.

2. Choose a material from the Select Material dialog. See “Select Material Dialog” on page 543.

3. Select one of the Material Painter Modes from the edit toolbar.

4. If you selected a solid color material, choose whether to use the Blend Colors with Materials option and click the edit button to turn this feature on or off.

5. Note that the name of the material being painted displays on the left side of the Status Bar at the bottom of the program window. See “The Status Bar” on page 33.

- Select a material category from the scrollable list. Select multiple line items using the Shift or Ctrl key. See “Shift and Ctrl Select” on page 125.
- Click the Select Material button or either material preview box to open the Select Material dialog. See “Select Material Dialog” on page 543.

If you use the Material Painter to change a Deck room’s planking or framing will affect its floor structure definition. See “Floor and Ceiling Platform Definitions” on page 237.
rial being painted and the current material on the target surface.

6. Click on a surface to apply the selected material to that surface. The material is applied to surfaces in the model based on the active Material Painter Mode.

7. If either the Component or Object Mode is active, you can continue to click on surfaces to apply the selected material. When you are finished, select a different tool.

**Material Eyedropper**

The Material Eyedropper tool allows you to load the material assigned to an existing object into the Material Painter and apply that material to other objects and is similar to other Eyedropper tools. See “Eyedropper Tools” on page 155.

**Blend Colors With Materials**

The Blend Colors With Materials option allows you to apply a solid color to a surface displaying a texture or pattern and blend the two.

Blend Colors With Materials works in all five Material Painter Modes. See “Blending Materials” on page 546.

**Material Painter Modes**

There are five Material Painter Modes, each specifying how broadly or narrowly the selected material will be applied to surfaces in your plan. They are similar to other Painter Modes in the program, but rather than modify instances of an object type, the Material Painter Modes replace instances of a material based on the selected scope. See “Painter Modes” on page 156.

- **Material Painter Component Mode** is unique to the Material Painter Tools. It is the default mode and applies the selected material to a single component on the target object. For most object types, using this tool is the same as opening an object’s specification dialog and changing the material of one of its components on the MATERIALS panel. See “Materials Panel” on page 542.

- **Material Painter Object Mode** replaces all instances of a material on the target object.

- **Material Painter Room Mode** replaces all instances of a material in the current room.

- **Material Painter Floor Mode** replaces all instances of a material on the current floor.

- **Material Painter Plan Mode** replaces all instances of a material in the entire plan.

**Material Painter and Walls**

Painting walls is an obvious use for the Material Painter; however, it is important to note that the Material Painter Modes affect walls and rooms somewhat differently than they do other objects: particularly if a wall defines multiple rooms on the side that is being painted.

- **Component and Object Modes** only paint the section of the wall that defines the room located where you click to apply a new material. Sections of the same wall that define other rooms are unaffected.

- **Room Mode** applies the material to all walls and solid railings that define the room where you click provided that they have the same original surface material as the one being painted. Any other objects in the room with that original material are also affected, but railings are not unless they are specified as Solid.

- **Floor and Plan Modes** apply the material to all walls, all railings, and any other objects with the same original surface material as the one being painted: either on the current floor, or throughout the plan.

---

**Materials Panel**

The specification dialogs for most objects include a MATERIALS panel. Select an object or a group of similar objects and click the Open Object edit button to open the specification dialog for that selection.
On the MATERIALS panel, you can specify material assignments for the components that make up that object. When a new material is assigned, the appearance of the preview image on the right side of the dialog updates.

If the selected object is using a material that is missing its texture, a Caution symbol will display next to the Materials panel name in the list on the left side of the object’s specification dialog. See “Referenced Files” on page 48.

The table on the left side of the panel lists the components of the selected object that can be assigned unique materials, along with the names of those materials and whether or not the default materials are used. Some objects may have only one component while more complex objects may have many. As changes are made to the selected object, components may be added to or removed from this table.

- Click on a Component in the table to select it. Multiple line items can be added to the selection set by holding down the Shift or Ctrl key. See “Shift and Ctrl Select” on page 125.
- The selected component’s Material is stated in the list, to the right of the component name. If the component is using the default material, the name will be preceded by the word “Default:”. If it is using a Material Default, it will be preceded by the word “Default” followed by the name of an object type. See “Material Defaults” on page 540.

The two boxes to the right of the table display previews of the color, pattern, and texture of the material assigned to the selected component. If “No Texture” displays in the preview window, the material has no texture assigned to it; if a Caution symbol and the words, “Texture Missing” display, the texture file could not be found on the system.

- Click Select Material to open the Select Material dialog. Choose a material and click OK to assign that material to the selected component. See “Select Material Dialog” on page 543.

A preview of the selected object displays on the right side of the panel. To view material textures, select Standard as the View Type; to view material patterns, select Vector View. See “Dialog Preview Panes” on page 32.

Select Material Dialog

The Select Material dialog allows you to select a material to apply to one or more objects and is opened by clicking the Select Material button on the MATERIALS panel of most specification dialogs or by using the Material Painter. See “Materials Panel” on page 542 and “Material Painter Tools” on page 541.

Depending on how it is accessed, the Select Material dialog will have either two or three panels:

Note: If the selected object is a wall or a room modified using the Material Painter, a component’s Material may be described as “No Change”. See “Material Painter and Walls” on page 542.
• The Library Materials Panel allows you to select materials from the Library Browser.
• The Plan Materials Panel lets you to select materials from the Plan Materials dialog.

• The Material Defaults Panel lets you associate an object component with a Material Defaults category rather than a specific material and is only available when the component of a library symbol is selected on the MATERIALS panel of the object’s specification dialog.

Library Materials Panel

The LIBRARY MATERIALS panel is a modal version of the Library Browser that lists only materials. See “The Library Browser” on page 509.

Most of the settings on this panel are also found in the Select Library Object dialog. See “Select Library Object Dialog” on page 522.

The LIBRARY MATERIALS panel has most of the functionality that the Library Browser has, including the search, search filtering options, and preview options.

• To locate a material, either search using keywords or browse the tree list. See “Searching the Library” on page 512.

• To apply a material to an object, either click on the material and click OK or double-click on the item in the Selection Pane.

• Click the Add New Material button to open the Define Material dialog and create a new material saved in the user Catalog. See “Define Material Dialog” on page 550.

• Check Use default material to apply the default material to the selected object, if one exists. See “Material Defaults” on page 540.

• A preview of the selected material displays on the right. See “Dialog Preview Panes” on page 32.

The OK button is only active when a library item is selected. If a library folder or catalog is selected, the OK button cannot be clicked.

Plan Materials Panel

The PLAN MATERIALS panel is similar to the Plan Materials dialog and lets you select from a list of materials already present in the plan as well as manage that list. See “Plan Materials Dialog” on page 549.

Select “Use Default” from the top of the list to apply the default material to the selected object, if applicable.

Material Defaults Panel

The MATERIAL DEFAULTS panel will only be present if the Select Material dialog was accessed via an object specification dialog where a component of an inserted library symbol was selected.

Rather than apply a specific material to the selected component, you can dynamically associate it with a
Material Default category. See “Material Defaults” on page 540.

**Viewing Materials**

Textures display in most Rendering Techniques, while patterns display in Technical Illustration and Vector Views. See “Displaying 3D Views” on page 565.

In Technical Illustration and Vector Views, you can turn the display of material patterns on and off by selecting 3D> **Toggle Patterns**. See “Rendering Techniques” on page 595.

When most other Rendering Techniques are used, you can turn the display of textures on and off by selecting 3D> **Camera View Options> Toggle Textures**.

**Editing Materials**

Much like objects, materials in Home Designer Pro can be edited so that they better suit your design needs. There are two approaches to material editing:

- Select a material in an unlocked library in the Library Browser, edit it, and your changes will be used when you next use the material in any plan. Changes made in this manner do not affect materials already in use in a plan.
- Apply a material to an object in a plan and then edit that applied material using either the **Plan Materials** dialog or **Adjust Material Definition** tool. Changes made in this way will affect any instances of that material in the current plan only.

Editing the material applied to an object is not the same as applying a different material to that object. See “Material Painter Tools” on page 541.

**Library Browser**

Right-click on a material in an unlocked library and select **Open Object** from the contextual menu to open the **Define Material** dialog for that material. See “Define Material Dialog” on page 550.

**Creating Materials**

Home Designer Pro provides a wide variety of materials - including numerous name brand material catalogs - that are ready to download and use. If you cannot find a suitable material, you can edit an existing material or create a new one. See “Editing Materials” on page 545.

**Plan Materials**

Select 3D> **Materials> Plan Materials** to open the **Plan Materials** dialog for the current plan. Select a material and click the **Edit, Copy, or New** button to open the **Define Materials** dialog.

**Adjust Material Definition**

The **Adjust Material Definition** tool is useful for changing plan materials directly from a 3D view.

Select 3D> **Materials> Adjust Material Definition** and then click any surface in a 3D view to modify the material currently assigned to that surface in the **Define Material** dialog. See “Define Material Dialog” on page 550.

Changing a material definition with this tool affects all objects in the current plan that are using that material but does not affect any materials saved in the library or materials used in other plans. See “Adding Library Content” on page 517.

**In the Plan Materials Dialog**

There are two ways to create a new material in the **Plan Materials** dialog. See “Plan Materials Dialog” on page 549.

- Click the **New** button to create a new material for use in the current plan file.
Select a material and click the Copy button to make a new material based on the original, which can then be edited and used in the current plan.

In the Library Browser
Materials can be created in the Library Browser, making them available for use in any plan. See “Adding Library Content” on page 517.

In the directory pane of the Library Browser, right-click on an unlocked folder and select New> Material from the contextual menu. See “Using the Contextual Menus” on page 511.

The Define Material dialog opens, allowing you to specify the new material’s attributes. See “Define Material Dialog” on page 550.

Using Paste Image
A new material can be created by copying an image that will serve as its texture to the system clipboard, then navigating to a Home Designer Pro window and selecting Edit> Paste> Paste from the menu. See “Paste” on page 104.

Blending Materials
In 3D views, you can create a new material by blending a solid color such as a paint color with a textured and/or patterned material. Select 3D> Material Painter> Blend Colors With Materials to toggle this feature on or off. See “Blend Colors With Materials” on page 542.

The result is a new material that is saved in the current plan. It can be found in the Plan Materials dialog, edited as needed, and added to the library if desired. See “Plan Materials Dialog” on page 549.

Materials created using the Blend Colors With Materials tool are given the name of the patterned/textured material with the extension “-PAINTED:” followed by the name of the solid color material.

Texture File Management
In order to display a material’s texture, Home Designer Pro needs to be able to locate the image file associated with it on your computer. See “Referenced Files” on page 48.

If a texture referenced by a newly created material is not located in either the Home Designer Pro 2021 Data folder or the installation folder for the program’s library textures, a copy of the file will be made in Home Designer Pro 2021 Data\Textures\Material Data and the material will reference that copy. See “Home Designer Pro Data” on page 40.

Mapping Patterns and Textures
Materials have two attributes that determine what they look like in 3D views: patterns and textures. See “About Materials” on page 540.

Both patterns and textures have points of origin, which determine where the pattern or texture begins on an X/Y axis. By default, this origin is 0,0; however, you can specify a different origin for each in the Define Material dialog. See “Define Material Dialog” on page 550.

You can also specify whether a material’s pattern and texture origins are set globally or independently for each object. By default, this mapping is per object; check Global Symbol Mapping on either the TEXTURE or PATTERN panel of the Define Material dialog to map all instances of the material throughout the plan from the same origins.

If a material is set to map globally, it may not look right on some surfaces in 3D views. If this is the case and you do not wish to map the material independently on each object, you can create a copy of the material for each surface that requires modification and specify its texture’s origin.

The fill styles of CAD objects are similar to material patterns and can also be mapped on an individual object basis. See “Fill Style Specification Dialog” on page 115.
Determining the Origin

Before a new origin can be specified, the display of coordinates in the Status Bar should be enabled. See “The Status Bar” on page 33.

To determine origin coordinates on the horizontal plane, place your cursor over the origin location in floor plan view. When the pointer is in the position you want to establish as the material origin, take note of the coordinates that display in the Status Bar.

To determine origin coordinates on the vertical plane, place your cursor over the origin location in a cross section/elevation view.

Once you have taken note of the new origin coordinates, enter them on either the PATTERN or TEXTURE panel of the Define Material dialog. See “Define Material Dialog” on page 550.

A texture or pattern origin is a property of the material rather than of the object that the material is assigned to. When an object is moved, the pattern or texture maintains its absolute position and may not look right. It is a good idea to assign pattern or texture origins only after the position of the object has been finalized.

Materials and the Materials List

When applied to structural components like slabs or wall, floor and ceiling, or roof layers, materials perform two important roles. They determine:

- **Stretch to Fit**

  Some special textures, often used for artwork, do not tile. Instead, these textures resize to stretch across any surfaces that they are applied to. Materials that behave this way are specified as **Stretch to Fit** in the Define Material dialog.

  To display an artwork texture, first place a wall or desk frame in your plan. A selection of both are available in the library. See “Placing Library Objects” on page 521.

  Next, simply apply a material specified as **Stretch to Fit** to the center portion of the frame. See “Material Painter Tools” on page 541.

  For more information about creating and using custom materials, see “Materials Tutorial” on page 102 of the User’s Guide.
• How or whether certain features generate in the model.
• How or whether those components are calculated in the materials list.

These considerations are controlled by each material’s Structure Type and its Calculation Method, both of which are specified in the **Define Material** dialog. See “Materials List Panel” on page 555.

### Material Structure Types

The Material Structure Type controls how or whether certain structural features generate in the model.

- The **Air Gap** type is useful in layered material assemblies: for example, to produce an air gap in a masonry wall. Regardless of their pattern or texture specifications, Air Gap materials do not have a 3D presence at all and are not calculated in the Materials List. See “Material Layers Definition Dialogs” on page 538 and “Wall Type Definitions Dialog” on page 210.

- The **Concrete** type must be assigned to a wall type in order to cut a brick ledge into it. This type is also required to produce rebar, steel mesh, and pour number calculations in the Materials List. It is recommended for concrete walls, footings, monolithic slabs, and Slab Footings. See “Foundations” on page 373 and “Brick Ledges” on page 190.

- The **Framing** type is necessary in order to generate framing in wall, floor and ceiling platform, and roof plane assemblies. See “Framing Types” on page 465.

- The **Masonry** type must be assigned to the exterior layer of a wall type in order to generate a brick ledge in the wall below.

- The **Steel Framing** type is necessary in order to generate C-channel wall studs. Both Steel Framing and Framing types produce Lumber type framing in floor and ceiling platforms and roof plane assemblies.

- The **Other** type is useful for other structural applications such as sheathing and siding.

### Calculation Methods

A material’s Calculation method controls how it is counted in the Materials List when it is applied to structural components like wall, floor, or ceiling layers or slabs.

For walls, structural assembly layers, and slabs, Area, Count, and Linear calculations are based on the area of the assembly or the top of the slab. If a material is calculated by Count, its Depth is not used; however, the thickness of the layer or slab is noted in the Size column of the Materials List.

For Soffits, Area, Count and Linear calculations are made for all sides of the object. The Depth of materials calculated by Count is used, but thickness is otherwise not noted.

- Area calculates the total area of a material in structural layers and slabs in square feet (m).
- Count calculates a piece count based the material’s Width, Height, and Depth.
- Linear calculates the total length of strips required to cover the area in feet (m).
- Volume calculates the total volume of a material in structural layers and slabs in cubic yards (m)
- None prevents the material from being calculated in the materials list at all. Provided that the material is not an Air Gap, it may still display in 3D views.

- Framing calculates materials using the selected Structural Member Reporting method. It is only available when the Framing Structural Type is selected. See “Structural Member Reporting” on page 683.

Once a Materials List has been created, the unit of measurement can be changed. See “Changing Count Units” on page 687.

### Representing Overlap

Any material using the Count or Linear Calculation method can be set up to account for material overlap in the **Define Material** dialog. To do this:

- On the **Pattern** panel, set up the material’s pattern so that it accurately represents the size and shape of the exposed portion of an individual piece or strip.
- On the **Texture** panel, set the Scale to represent the appearance of the exposed material in rendered 3D views.
- On the **Materials List** panel, specify the full size of the actual material, including the overlapped portion.

If a material is set up to represent overlapping pieces, it is important that you not click the **Update from Pattern** button. See “Materials List Panel” on page 555.
Managing Plan Materials

The Plan Materials dialog allows you to manage the materials used in the current plan. Select 3D> Materials> Plan Materials to open this dialog. You can also access its settings in the Select Material dialog. See “Select Material Dialog” on page 543.

When a material is applied to an object in a plan, a copy of that material is created and saved with the plan. If you use the Define Materials dialog to modify that material, your changes affect it wherever it is found throughout that plan. All objects in that plan that use that material are affected, but objects placed in other plans are not.

Plan Materials Dialog

A scrollable, alphabetical list of the materials saved in the current plan displays here. Click on the name of a material to select it. Select multiple materials by holding down the Shift or Ctrl key.

- If there is a check mark in the In Use column, the material is used by one or more objects in your plan or is defined as a default material for one or more objects in your plan.
- If the In Use column is empty, the material was used at one time but is no longer assigned to any objects or used as a default.

The buttons on the right allow you to modify the selected material and manage the items in the list.

- Click Edit to open the Define Material dialog for the selected material. See “Define Material Dialog” on page 550.
- Click New to open the Define Material dialog to create a new material.
- Click Copy to create a copy of the selected material and open the Define Material dialog where you can make changes to the copied material.
- Click Purge to remove all unused materials from the plan.
- Click Delete to remove the selected material from the plan. If the material is used in the model, you cannot delete it.

A preview of the material applied to an object displays here. If multiple materials are selected at once, the first one in the list will display. Various options allow you to view different aspects of the material’s attributes:

- Display the material in Standard rendering or Vector View.
- Zoom and orbit the object in the view.
- Toggle Color on or off.
- Click the Restore Original View button to reset the material preview to its original perspective.

All materials that come with Home Designer Pro are stored in the Library Browser. You can create your own materials and save them there, as well. See “Creating Materials” on page 545.
Define Material Dialog

The Define Material dialog allows you to adjust how materials look in 3D views as well as how they are calculated in the Materials List.

This dialog can be accessed in a number of ways:

- Use the Adjust Material Definition tool. See “Adjust Material Definition” on page 545.
- Select a material from the Plan Materials dialog and click Edit, New, or Copy. See “Managing Plan Materials” on page 549.
- Right-click on one or more materials in the Library Browser User Catalog and select Open Object from the contextual menu. When multiple materials are selected, some settings will not be available. See “Using the Contextual Menus” on page 511.

- You can also right-click on the User Catalog and select New> Material.

If you select a manufacturer’s material, some options in the Define Material dialog may not be available and the panels may vary.

If you access the Define Material dialog through a menu or specification dialog, any changes you make will affect that material wherever it is found in the current plan. Other objects in that plan using that material will also be affected, but objects outside the current plan will not.

The Rendering Technique and object shape selections in this dialog’s preview are shared with the Plan Materials dialog and, unlike other dialog previews, are remembered during the current program session. See “Dialog Preview Panes” on page 32.

Pattern Panel

Patterns are used to represent materials in Technical Illustration and Vector Views. See “Patterns and Textures” on page 540.
The **Material Name** displays here. You can type a different name if you wish. Renaming the material does not create a new material: it redefines the existing material. See “Creating Materials” on page 545.

- Check **Keep Pattern/Texture in Sync** to maintain consistent **Scale** and **Offset and Angle** settings for both the selected material’s pattern and its texture if any of these settings are modified.

Specify the **Colors** used to represent the material’s pattern in Vector Views. Click either color box to open the **Select Color** dialog and select a color. See “Select Color Dialog” on page 117.

- The **Material Color** displays in Vector Views and is also used in Rendering Techniques that use textures when **Toggle Textures** is off, or if a material has no texture specified. See “In Vector Views” on page 566.

- The pattern **Line Color** displays in Vector Views only.

- Specify the **Shading Contrast**, which is the amount of contrast between surfaces at different angles to each other in Vector Views. See “Vector View” on page 595.

The following shows a curved wall with three different Shading Contrasts (created in a separate graphics program). Notice how the lowest contrast at the top appears almost flat.
selected as the Pattern Type, the Scale, Offset and Angle settings are disabled.

- Select a **Pattern Type** from the drop-down list. Select “Library” or click the **Library** button to select a pattern from the library. When a pattern is selected from the library, its name will display in the list. See “Select Library Object Dialog” on page 522.

**Scale** -

- Specify the **Width** of the selected pattern. For Concrete and Sand materials, instead adjust the overall pattern **Spacing**.
- Specify the selected pattern’s **Height**. Only available for Brick, Tile, Shingles, and U’s patterns.
- Specify the pattern’s **Scale**. If the pattern appears black in the square preview pane, this value should be increased. Only available for imported patterns and some patterns from the library.

**Offset and Angle** -

- Specify the **Horizontal** and **Vertical Offsets**, if needed, so the pattern displays correctly on surfaces. See “Mapping Patterns and Textures” on page 546.
- Specify the **Angle**, measured counterclockwise, in degrees.
- Check **Global Symbol Mapping** to map the pattern and texture using the same origin on all objects. When unchecked, the origin is defined individually for each object.

- Specify the **Line Weight**, which is the thickness of the pattern lines.

If the selected pattern has a **Copyright**, information about it displays here.

A preview of the material’s pattern displays in the square pane. It updates as you change the pattern’s specifications.

A preview of the material applied to an object displays here and updates as changes are made to the material definition. Various options allow you to view different aspects of the material’s attributes:

- Display the material in Standard rendering or Vector View.
- Zoom and orbit the object in the view.
- Toggle **Color** on or off.
- Click the **Restore Original View** button to reset the material preview to its original perspective.
- Select an object shape: Cube, Sphere, Teapot, or Plane.

The Rendering Technique and object shape selections in this dialog’s preview are shared with the **Plan Materials** dialog. Unlike other dialog previews, these are retained when you close the dialog. The object shape selection is also shared with the Library Browser. See “Plan Materials Dialog” on page 549.

**Texture Panel**

In most Rendering Techniques, materials are represented by textures. See “Rendering Techniques” on page 595.

Transparency information may be contained on the alpha channel of a texture; if so, it is used in rendered views.
The **Material Name** displays here. You can type a different name if you wish. Renaming the material does not create a new material: it redefines the existing material.

- Check **Keep Pattern/Texture in Sync** to maintain consistent **Scale** and **Offset and Angle** settings for both the selected material’s pattern and its texture if any of these settings are modified.

**Texture Source** - Displays the path and file name of the selected texture.

- Click the **Browse** button to browse to a texture file saved on your computer. Supported file formats are `.jpg`, `.bmp`, `.png`, `.gif`, and `.tif`. See “Creating Materials” on page 545.
- You can also type or paste the full path name of a texture in the text field. To remove the file, click the **Remove** button.
- Textures saved in `.zip` files can also be used. See “To use an image saved in a .zip file” on page 554, below.
- If the texture is not located in either the Home Designer Pro 2021 Data folder or the installation folder for the program’s library textures, a copy of the file will be made in Home Designer Pro 2021 Data\Textures\Material Data. See “Home Designer Pro Data” on page 40.

Specify the **Scale** of the selected material’s texture.

- Adjust the **X Scale** and **Y Scale**, or height and width, of the selected texture.

If a rendered surface is larger than the area described by the Scale, the surface has “tiles” of the texture image. If it is smaller, only a portion of the texture is shown.

- Check **Stretch to Fit** to stretch the texture image to cover each surface it is applied to. Stretch to Fit is typically used for artwork or photography in a frame.

Note: Changing the scale or selecting Stretch to Fit can cause textures to appear distorted if applied to a surface with a different aspect ratio than the original texture image.

- Check **Retain Aspect Ratio** to maintain the ratio between the texture image’s height and width and prevent distortion when either its X or Y Scale value is adjusted.

Specify the **Offset and Angle** of the material’s texture. See “Mapping Patterns and Textures” on page 546.

- Specify the **X** and **Y Positions** of the texture’s origin, if needed, to adjust its layout on surfaces.
- Specify the **Angle** of the texture on the surfaces of objects, in degrees.
• Check **Global Symbol Mapping** to map the texture and pattern using the same origin on all objects. When unchecked, the origin is defined individually for each object.

5. Specify the characteristics of the **Material Color**. This can also be set on the **PATTERN** panel.

• Check **Blend with Texture** to apply the Material Color over the material’s texture.

When a new material is created using the **Blend Colors With Materials** tool, the resulting material has this box checked. See “Blend Colors With Materials” on page 542.

• Click the **Color** button to specify the Material Color.

• Click the **Set Material Color Using Texture** button to use the predominant color of the material’s texture. See “Patterns and Textures” on page 540.

6. A preview of the material’s texture displays in the square pane. It updates as you change the material definition.

7. A preview of the material applied to an object displays here and updates as changes are made to the material definition. Various options allow you to view different aspects of the material’s attributes:

• Display the material in Standard rendering or Vector View.

• Zoom and orbit the object in the view.

• Toggle Color on or off.

• Click the **Restore Original View** button to reset the material preview to its original perspective.

• Select an object shape: Cube, Sphere, Teapot, or Plane.

**To use an image saved in a .zip file**

1. Type or copy the full path name of the .zip file in the text field.

2. Directly after the path name, type #zip:, followed immediately by the name of the bump map file including its file extension.

**Properties Panel**

The **PROPERTIES** panel controls how the material appears in most rendered 3D views.

A material’s rendered appearance is also affected by the Render settings in the **Preferences** dialog and the lights that have been placed in the model. See “Light Types” on page 586.

For special lighting effects on an object, use at least one point or spot light.

The **Material Name** displays here. You can type a different name if you wish. Renaming the material does not create a new material: it redefines the existing material.
Options

- **Brightness** controls how bright the material appears. It can be used to get the desired appearance relative to other materials being used.

- **Shininess** controls the sheen of the material when it is rendered with a point or spot light source on it. Shiny materials appear to have a bright white spot on them which simulates reflection of light.

- **Transparency** - Use the slider bar or text field to control the materials transparency. A value of 0 is completely opaque and a value of 100 is completely transparent. Specifying materials with transparency can slow down rendering speed in some situations.

- **Emissive** - Use the slider bar or text field to control how bright a material appears independent of the lighting in the scene. It can be used to simulate surfaces that are glowing with their own light, such as the glass on a light fixture.

A preview of the material applied to an object displays here and updates as changes are made to the material definition. Various options allow you to view different aspects of the material’s attributes:

- Display the material in Standard rendering or Vector View.
- Zoom and orbit the object in the view.
- Toggle Color on or off.
- Click the Restore Original View button to reset the material preview to its original perspective.
- Select an object shape: Cube, Sphere, Teapot, or Plane.

Materials List Panel

The settings on the MATERIALS LIST panel control whether certain structural components are generated in the model as well as how the selected material is counted in the Materials List. See “Materials and the Materials List” on page 547.

1. The **Material Name** displays here. You can type a different name if you wish. Renaming the material does not create a new material: it redefines the existing material.

2. **Specifications** -

   - Select a **Material Structure Type** from the drop-down list. The selected Type defines how - or whether - the material is calculated in the Materials List. See “Material Structure Types” on page 548.
   - Select a **Materials List Calculation** method. When “Air Gap” is the selected Structure Type, the only available Calculation Method will be “None; when “Framing” is the selected Type, only “Framing” will be available. See “Calculation Methods” on page 548.

The settings that are available below depend on which Calculation method is selected.

- Specify the material’s **Width**. This value is available for Count and Linear Calculation methods.
- Specify the material’s **Height**. Only available for the Count Calculation method.
• Click the **Update from Pattern** button to make the Width and Height values here match those set on the **Pattern** panel. Only available when Count or Linear is selected as the Calculation method.

• Specify the material’s **Depth**. Only available for the Count Calculation method, this value is only used for Materials List calculations when the material is applied to a Soffit. This value may also be used if the Material Painter is used to create a floor or ceiling finish. See “Floor and Ceiling Finishes and the Material Painter” on page 237.

The Spacing OC and Thickness settings are only available when “Framing” is the selected Structure Type and only affect wall framing. See “Wall Framing” on page 464.

• Specify the material’s **Spacing OC**.

• Specify the material’s **Thickness**. This value is only used if Use Wall Framing Materials is checked in the Build Framing dialog. See “Wall Panel” on page 472.

**Manufacturer Panel**

If the selected material is from a Manufacturer library catalog, the Define Material dialog will have a fifth panel: the **Manufacturer** panel, which lists contact information. See “Manufacturer Catalogs” on page 514.
Little preparation is needed to create a 3D view of a model: simply click a button to create an overview or click and drag to create a camera or cross section/elevation view.

To improve the quality of the rendering and create a custom look, you can adjust lighting and edit the materials used in the plan. You can create Final views that are even more realistic. See “3D Rendering” on page 583.

Many objects can be placed and edited in 3D views, and any camera view or overview can be saved or even used to record a walkthrough. See “Pictures, Images, and Walkthroughs” on page 601.

### OpenGL and Hardware

Home Designer Pro features an easy to use rendering engine that makes use of OpenGL rendering technology, which has good hardware support on most video cards.

To take full advantage of these rendering capabilities of Home Designer Pro, a graphics card or chipset that supports OpenGL 3.3 on Windows or 4.1 on Mac is required. For more information, visit HomeDesignerSoftware.com.

### Types of 3D Views

There are three categories of 3D views in Home Designer Pro: camera views, overviews and cross section/elevation views. Each of these view types can be generated using a variety of Rendering Techniques. See “Rendering Techniques” on page 595.

Every 3D view is also either orthographic or perspective in nature. Cross section/elevation views...
are always orthographic while camera views are always perspective. You can choose to generate overviews as either orthographic or perspective.

**Perspective and Orthographic Views**

Perspective views have a focal, or vanishing, point. Surface edges and lines that would be parallel in real life appear to converge towards that focal point, and objects closer to the camera appear larger while objects farther from the camera appear smaller.

Orthographic views do not have a focal or vanishing point. Parallel surface edges and pattern lines appear parallel in these views and objects appear to be the same size regardless of their distance from the camera.

Perspective views display 3D objects much the way that they appear to the eye in real life, so they are ideal for presentation views. By default, perspective views are created using the Standard Rendering Technique.

Orthographic views, on the other hand, are useful for technical drawings. By default, orthographic views are created using the Vector View technique.

**Rendered and Vector Views**

3D views can be generated using a variety of different Rendering Techniques. See “Rendering Techniques” on page 595.

Most rendered views represent materials using textures. Surface edge lines are generally not drawn and lighting is often modeled, creating results that range from a photorealistic appearance to artistic painting styles.

Vector Views are non-photorealistic views in which objects are drawn using surface edge lines, or vectors. Limited lighting and shadows can be calculated and materials are represented using pattern lines and solid colors. Vector Views are ideal for layout drawings and high resolution printing. See “Vector View” on page 595.

**Defaults and 3D Preferences**

There are a number of defaults and preference settings that allow you to control the initial characteristics of 3D views.

- Camera positioning, field of view and related initial settings for camera views are specified in the **Camera Defaults** dialogs. See “Camera Defaults Dialogs” on page 558.

- The settings in the **3D View Defaults** dialog control a variety of functions that affect views created by all 3D View tools. See “3D View Defaults Dialog” on page 560.

- The default characteristics of the **Generic Sun** light source can be specified in the **Generic Sun Defaults** dialog. See “Adjust Sunlight Dialog” on page 594.

- Which objects display in a 3D view and which do not is controlled in the **Layer Display Options** dialog. See “Layer Attributes” on page 110.

- 3D views can be generated using any of the **Rendering Techniques**. See “Rendering Techniques” on page 595.

- The initial settings for each Rendering Technique can be set in the **Rendering Techniques Defaults** dialog. See “Rendering Technique Options” on page 596.

- The **RENDER panel** of the **Preferences** dialog has settings that affect 3D views. See “Render Panel” on page 80.

**Camera Defaults Dialogs**

There are several defaults dialogs for cameras, which can be accessed by selecting **Edit> Default Settings** or by double-clicking either the Orthographic or Perspective View Tools parent button. In the **Default Settings** dialog, click the arrow next to “Camera tools”, then select a subheading and click the Edit button to open the defaults dialog associated with your selection.
The defaults dialog for Camera Tools other than Overviews can be accessed by double-clicking the associated toolbar button.

The various Camera Defaults in the list can be multiple-selected and then edited as a group by holding down the Shift or Control keys. Depending on the selection, not all settings may be available. See “Shift and Ctrl Select” on page 125.

The settings in the Camera Defaults dialogs affect how each type of camera captures, clips, and renders views; how they display in plan view; how they are positioned; and how they move.

Once a camera is created, its attributes can be customized. See “Editing 3D Views” on page 571.

Full Camera Defaults

Specify the initial attributes of cameras created using the Full Camera tool. See “Camera Views” on page 561.

The settings in this dialog are the same as those the Full Camera Specification dialog. See “Camera Specification Dialog” on page 575.

Note: The Reflections setting in the Full Camera Defaults is used by walkthroughs created using the Walkthrough Path tool. See “Recording a Walkthrough” on page 618.

Floor Camera Defaults

Specify the initial attributes of cameras created using the legacy Floor Camera tool. This tool is not in the menus or default toolbars but can be added to the toolbars if you wish. See “Toolbars and Hotkeys” on page 85.

The settings in this dialog are the same as those in the Floor Camera Specification dialog.

Perspective Full Overview Defaults

Specify the initial attributes of cameras created using the Perspective Floor Overview tool. See “Full Overview” on page 563.

The settings in this dialog also affect Perspective Framing Overviews.

The settings in this dialog are the same as those in the Perspective Full and Framing Overview Specification dialogs.

Doll House View Defaults

Specify the initial attributes of cameras created using the Doll House View tool. See “Doll House View” on page 563.

The settings in this dialog are the same as those in the Doll House View Specification dialog.

Cross Section/Elevation Defaults

Specify the initial attributes of cameras created using the Cross Section/Elevation tool. See “Cross Section/Elevation Views” on page 562.

The panels in this dialog are also found in the Cross Section/Elevation Specification dialog. See “Cross Section/Elevation Camera Specification Dialog” on page 579.
Backclipped Cross Section Defaults

Specify the initial attributes of cameras created using the Backclipped Cross Section tool. See “Cross Section/Elevation Views” on page 562.

The panels in this dialog are the same as their respective panels in the Cross Section/Elevation Specification dialog. See “Cross Section/Elevation Camera Specification Dialog” on page 579.

Wall Elevation Defaults

Specify the initial attributes of cameras created using the Wall Elevation tool. See “Cross Section/Elevation Views” on page 562.

The panels in this dialog are the same as their respective panels in the Wall Elevation Specification dialog. See “Cross Section/Elevation Camera Specification Dialog” on page 579.

Orthographic Full Overview Defaults

Specify the initial attributes of cameras created using the Orthographic Floor Overview tool. See “Full Overview” on page 563.

The settings in this dialog also affect Orthographic Framing Overviews.

The panels in this dialog are the same as their respective panels in the Orthographic Full and Framing Overview Specification dialogs.

Orthographic Floor Overview Defaults

Specify the initial attributes of cameras created using the Orthographic Dollhouse View tool. See “Overviews” on page 561.

The panels in this dialog are the same as their respective panels in the Orthographic Floor Overview Specification dialogs.

3D View Defaults Dialog

Select 3D> 3D View Defaults or Edit> Default Settings to open the 3D View Defaults dialog.

The settings in this dialog control a variety of functions that affect views created by all 3D View tools.

1 The General Options affect all 3D views.

2 Check Camera Bumps Off Walls to prevent cameras from moving freely through walls. This should be unchecked when using a 3D mouse or
gamepad. See “3Dconnexion® 3D Mice” on page 567.

- Check Auto Rebuild Walls/Floors/Ceilings to automatically rebuild floors and ceilings before a 3D view or elevation is displayed. When this is unchecked and the structure is not up to date, the Rebuild Walls, Floors, Ceilings icon displays near your mouse pointer. See “Rebuilding Walls, Floors and Ceilings” on page 391.

- Check Legacy Compatible Texture Mapping to use global texture mapping settings rather than texture mapping fixed to individual objects.

⚠️ Legacy Compatible Texture Mapping should remain unchecked except in legacy plans with custom rotated textures.

- When Auto Adjust Default Glass Properties is checked, the program automatically adjusts the behavior of window, door, and electrical fixture glass in Standard rendered views in response to interior and exterior lighting conditions. When this box is unchecked, these adjustments are not made.

- Check Always Display Active Cameras to turn on the display of active camera symbols, even when the “Cameras” layer is turned off. When unchecked, active camera symbols obey the layer setting.

- When Display Openings Independent of Walls and Roofs is checked, doors, windows, and skylights display in 3D views when their containing wall or roof plane does not. Uncheck this to prevent these objects from displaying in 3D when their parent objects do not.

### 3D View Tools

Select 3D> Create Orthographic View to display the Orthographic View Tools or 3D> Create Perspective View to display the Perspective View Tools.

#### Camera Views

Camera views are Perspective views. They are not scaled and cannot be annotated but are ideal for creating presentation views.

The Full Camera tool creates multi-floor views of the 3D model. It can be used to create interior and exterior perspectives, and is good for displaying cathedral ceilings, roofs, lofts, stairwell openings, and other variation in floor and ceiling levels.

The Vector View Options only affect views using the Vector View rendering technique. See “Rendered and Vector Views” on page 558.

- Framing Back Clip defines the back clip for framing members in cross section views. Framing must be set to display to see the effects of this value. A zero value does not back clip at all.

The View Types with Color On settings control which 3D view types are generated with Color toggled on when the Vector View Rendering Technique is used. See “3D View Tools” on page 561.

- Select a check box to generate that view type in color or uncheck to generate that view type in grayscale.

- A color view can also be changed to a grayscale and vice versa by choosing View> Color.

Specify how the Surface Edge Lines display for all objects in 3D views.

- Check Use Layer Settings to display surface edge lines for objects using the display settings specified by layer in the Layer Display Options dialog.

If this option is not checked, all edge lines are drawn black and solid with a line weight of 0.

- If Use Layer Settings is checked you can also check Use Object Settings. All objects that have special settings specified on the LINE STYLE panel of their specification dialog display using those settings, overriding the layer settings in the Layer Display Options dialog.

### Camera Views

The Floor Camera tool creates perspective views of the current floor only. Nothing above the ceiling surface is generated, and neither is anything below the floor. This legacy tool is not in the menus or default toolbars but can be added to the toolbars if you wish. See “Toolbars and Hotkeys” on page 85.

#### Overviews

An overview can be either orthographic in nature or perspective, depending on the
tool used to create it. See “Creating Overviews” on page 563.

The Orthographic and Perspective Full Overview tools create views of the entire model including all floors, ceilings, and the roof.

The Orthographic and Perspective Doll House View tools create views of the current floor with the ceiling removed and all floors beneath it visible.

The Orthographic and Perspective Framing Overview tools create views of the framing in the model. Framing must be built in order for it to display in a framing overview. See “Framing Overview” on page 563.

Cross Section/Elevation Views

Cross Section/Elevation views are similar to the traditional, scaled orthographic views often used in drafting. They are scaled and can be fully annotated. See “Cross Section/Elevation Views” on page 564.

A Cross Section/Elevation view displays all floors of the model. If the view is created outside the structure looking toward it, the result is an exterior elevation. If the view is created inside the structure, or passes through any of the structure, a cross section is created.

The Backclipped Cross Section tool includes only the objects between the starting point and stopping point of the cross section line.

The Wall Elevation tool creates an elevation of a wall on a single floor and in a single room. The Wall Elevation tool cannot be used to create exterior views.

Creating Camera Views

All Camera views are created using the same method.

To create a camera view
1. In plan view, select the desired camera tool. The mouse pointer displays the camera icon.
2. Click and drag a line to define the view direction.
   • Where your line begins is the camera’s position.
   • The line that you drag defines the direction the camera is pointed.
   • The end of the line is the focal point of the view, the point the camera rotates around.
   • By default, the field of view is 55°.
3. When you release the mouse button, a view generates in a new window.
4. Return to the plan view. A camera symbol now displays in plan view. See “Working in Multiple Views” on page 94.

In order to create a camera view, you must click and drag at least as far as your current Snap Distance. See “Snap Properties Panel” on page 76.

Camera Height

By default, Cameras are created at a height of 60” (1500 mm). Where this height is measured from depends on the location of the camera:

• If the camera is inside of a room, it is measured from that room’s subfloor.
• If the camera is outside of a room but inside of the Terrain Perimeter, it is measured from the terrain at the location of the camera.
• If the camera is located in neither a room nor within the Terrain Perimeter, it is measured from the default height of the subfloor for the current floor.

Once created, a camera’s height can be modified in its Camera Specification dialog, and the default height value can be set in the Camera Defaults dialog. See “Camera Panel” on page 576.
Creating Overviews

In Home Designer Pro, there are three different overview types: Full, Floor and Framing Overviews.

Each type of overview can be generated as either an orthographic or perspective view. An overview window’s title bar indicates whether it is perspective or orthographic. See “Perspective and Orthographic Views” on page 558.

Overviews generate as soon as you select the tool and are always created at the same angle. The focal point is always located at the center of the model; however, the position of the camera will vary depending on the size of the 3D model. The larger or more spread out the model, the further away the camera will be from the focal point so that the entire model can be seen in the view.

Once generated, an overview window’s title bar indicates whether it is a perspective or orthographic view and a camera symbol representing the overview displays in plan view. The overview ‘camera’ can be edited much like regular camera views can. See “Editing 3D Views” on page 571.

Full Overview

Select 3D> Create Orthographic View> Orthographic Full Overview or 3D> Create Perspective View> Perspective Full Overview to generate an exterior view of the entire model.

Doll House View

Select 3D> Create Orthographic View> Orthographic Doll House View or 3D> Create Perspective View> Perspective Doll House View to create a view of the current floor with the ceiling removed and all floors beneath it visible.

Doll House Views are an effective tool for illustrating traffic flow and the relationships between spaces.

Framing Overview

Select 3D> Create Orthographic View> Orthographic Framing Overview or 3D> Create Perspective View> Perspective Framing Overview to create a view of the entire model, displaying only framing and the foundation.

Select 3D> Create Orthographic View> Orthographic Framing Overview or 3D> Create Perspective View> Perspective Framing Overview to create a view of the entire model, displaying only framing and the foundation.

Framing overviews include all floor, wall, and roof framing as well as foundations. Unlike other overviews, which use the Camera View layer set, Framing Overviews use the 3D Framing Set. See “Layer Sets” on page 113.

Framing must be built before generating this view or the view will be empty.

To see a different floor, select Tools> Floor/Reference Display> Up One Floor or Down One Floor. You can also return to plan view and make another floor current before generating the Doll House View.

If you prefer, you can specify in the Camera Defaults dialog that only the current floor be included in Floor Overviews. See “Camera Defaults Dialogs” on page 558.
Cross Section/Elevation Views

The Cross Section/Elevation, Back-clipped Cross Section, and Wall Elevation tools produce the traditional, orthogonal views often used in drafting. Regardless of their distance from the camera, all lines and dimensions in these views are their true lengths, making it easy to accurately see the spatial relationships of the 3D objects in the model.

Cross section/elevation views can be clipped to limit how much of the model is included in the view. See “Camera Panel” on page 580.

Cross section/elevation views are the only 3D views that can be enhanced with the 2D CAD tools. They can be fully annotated and dimensioned and then printed to scale.

Cross Section/Elevation Camera Tools

Each of the three cross section/elevation camera tools has a specific function.

A Cross Section/Elevation view displays all floors of the model. The cross section begins at the point where the camera arrow is drawn and continues through the entire model.

The Backclipped Cross Section tool includes only the objects or portions of objects between the starting point and stopping point of the camera’s Line of Sight.

The Wall Elevation tool creates an interior elevation of a single wall defining the room that the camera is drawn in. It does not cut through walls or show the ceiling, floor, or roof. It creates a 2D projection of a wall and the objects located between that wall and the camera and is used primarily for kitchen and bath elevations. This tool cannot be used to create exterior views.

Cross Section/Elevation, Backclipped Cross Section, and Wall Elevation views are created in the same way.

To create a cross section/elevation view

1. Select the Cross Section/Elevation, Backclipped Cross Section, or Wall Elevation tool. The pointer changes to a with crosshairs marking the position of the pointer.

2. Click and drag a line in plan view.
   • A Camera symbol displays where you click, along with a Cross Section Line indicating the plane of the camera’s cross section cut line.

3. Drag in the direction of the Line of Sight to draw a camera arrow.
   • Always drag the camera arrow perpendicular to the wall to be viewed.

4. When you release the mouse button, the view generates in a new window.
   • If the view is a Backclipped Cross Section, a second Cross Section Line at the end of the Line of Sight indicates the furthest extent of the backclip.

As with camera views, you must click and drag at least as far as your current Snap Distance in order to create a Cross Section/Elevation view. See “Snap Properties Panel” on page 76.

If the Line of Sight does not cut through a 3D object and the object is within the back clipped distance, such as a window shown in elevation, the object retains its 3D definition and can be selected, moved, stretched, or otherwise modified in the view. The 3D model is updated in all views.

Detailing Cross Section/Elevation Views

CAD objects, including Text and Dimensions, can be created in cross section/elevation views. These objects are superimposed on the view and have no effect on the 3D model itself. If CAD objects have been added to a cross section/elevation view, the program will prompt you to save the view before closing the window. This information is then stored in the view.
In cross section views, some objects, such as walls, may be represented using Cross Section lines. If a dimension line finds an object surface edge represented by a Cross Section line, a Point Marker will be placed at that location, and the dimension will locate it instead of the Cross Section line. See “Markers” on page 282.

Displaying 3D Views

A variety of tools and settings allow you to control the appearance of 3D views. There are also numerous ways to adjust a 3D view’s position, focal point and field of view. See “Editing 3D Views” on page 571.

The name of the current plan file and the type of view displays at the top of each view window in its title bar. If a 3D view is saved, its name also displays.

There is no limit to the number of 3D view windows that you can have open at a given time; bear in mind, though, that each window demands use of your computer’s resources and that you may see poor performance if too many views are open. See “Working in Multiple Views” on page 94.

Layer Display Options

Which objects display in a 3D view is controlled in the Layer Display Options dialog. See “Layer Display Options Dialog” on page 111.

Different view types use different layer sets when they are created. See “Layer Sets” on page 113.

To show framing in a cross section/elevation view, framing must first be built using the Build Framing dialog and the appropriate framing layers must be turned on in the Section View layer set. See “Framing” on page 463.

In Plan View

Cameras are represented in plan view by symbols that indicate the camera’s position, field of view and focal point.

CAD objects will snap to the Snap Grid when Grid Snaps are enabled. Note that the 3D model may obscure the display of the Snap Grid. See “Grid Snaps” on page 102.

Annotated cross section/elevation views can be sent to layout. See “CAD and Text in Layout” on page 696.

2D camera symbols are located on the “Cameras” layer. See “Layers” on page 110.

By default, active camera symbols display regardless of whether the “Cameras” layer is on or off. If you prefer that their display be turned on or off with this layer, uncheck Always Display Active Cameras in the 3D View Defaults dialog. See “3D View Defaults Dialog” on page 560.

Active camera symbols and callouts use the Selection Line color set in the Preferences dialog. All other display attributes are derived from the “Cameras” layer. See “Colors Panel” on page 64.

You can also display camera symbols for saved cameras when the “Cameras” layer is turned on. See “Layers” on page 110.

The symbols for Full Overviews, Cross Section/Elevation, and Backclipped Cross Section views display on all floors, while those for Full Cameras, Floor Overviews, and Wall Elevations display only on the floor where they were created.

You can also move a camera to a different floor by clicking the Up One Floor or Down One Floor button while the camera view is active. Note that this may affect what is seen in the view as well as its display in plan view. See “Floor Up / Floor Down” on page 392.
Both saved and unsaved active cameras can have labels indicating the camera number or its name. Camera labels are located on the “Cameras, Labels” layer. See “Object Labels” on page 285.

- Camera labels are numbered sequentially in each plan in the order they were created unless you rename them.
- Camera labels always use the Camera Name. Saved cameras’ names can be specified in the Camera Specification dialogs. See “Camera Panel” on page 576.

Camera symbols are an on-screen reference: they do not print unless Print Image is used and cannot be sent to layout except as an image. They are, however, included in views exported to .dxf.

### In Rendered Views

There are a number of factors that contribute to the appearance of rendered 3D views:

- Select 3D> Camera View Options> Toggle Textures in a 3D view to turn off the display of material textures. See “About Materials” on page 540. Not available in Glass House, Technical Illustration or Vector Views.
- Select View> Color to toggle between color and grayscale in 3D views. See “Color On/Off” on page 114.
- Select 3D> Lighting> Adjust Lights to open the Adjust Lights dialog and edit the light sources in the current plan. See “Adjust Lights Dialog” on page 588.

Several other factors can contribute to the overall quality of a rendered 3D view. See “Rendering Tips” on page 583.

### In Vector Views

There are also a number of factors that affect the appearance of 3D Vector Views:

- Select 3D> Toggle Patterns in a Technical Illustration or Vector View to turn on or off the display of the “Patterns, 3D Views” layer, which controls the display of material pattern lines. See “Layers” on page 110.
- Select View> Color to toggle between color and black and white to control the display line and fill colors.
- The line style, color, and weight of objects in Vector Views can be specified by layer or, for some objects, individually in their specification dialogs. See “Line Style Panel” on page 169.
- The line weight, color, and style of material patterns are set in the Define Material dialog. See “Define Material Dialog” on page 550.
- Line weights display on screen when Show Line Weights is enabled. See “Line Weights” on page 713.

### 3D Backdrops

A backdrop is an image, usually of an exterior view, that displays in the background of 3D views to help place the model into a realistic setting and add a sense of perspective. If a backdrop is not specified, Home Designer Pro applies a background color. See “3D Backdrops” on page 614.

### Rendering Techniques

Any 3D view can be assigned a Rendering Technique for a range of different purposes: from detail drawings to artistic presentation views. Select 3D> Rendering Techniques to access these tools. See “Rendering Techniques” on page 595.

### Delete 3D Surface

The individual surfaces that make up objects can be temporarily removed from any 3D view by selecting 3D> Delete Surface and then clicking on a surface. When the pointer is over a surface, that surface will become highlighted.

Surfaces removed in one view are removed in all 3D views, but are not permanently removed from the model. Continue clicking surfaces to remove them, then select another tool when you are finished.

Surfaces in 3D views are composed of multiple triangles. Hold the Alt key while clicking to delete one triangular face at a time rather than all triangles forming a surface. See “Edge Smoothing” on page 584.

To restore the most recently deleted surface, select 3D> Delete Surface or click the toolbar button.

There are several ways to restore all deleted surfaces:

- Select Build> Floor> Rebuild Walls/Floors/ Ceilings.
- Exit the 3D view and reopen it.
Repositioning Cameras

Once a 3D view is created, there are many ways to manipulate the camera location and the direction of its line of site using the mouse, the keyboard, and the menus.

The Move Camera with Mouse buttons are included on the toolbars in 3D views by default; but, you can add the other tools your toolbars as well as customize their hotkeys. See “Toolbars and Hotkeys” on page 85.

When the keyboard, toolbar buttons, or menu commands are used to move or rotate a camera, the adjustments occur in regular increments. The size of these increments is specified in the Camera Specification dialog:

- The Incremental Move Distance controls Panning movement and forward and backward Dolly movement.
- The Incremental Rotate Angle controls Orbit movement, Tilt movement, and side to side Dolly movement.

Mouse Scroll Wheel and Trackpad

3D views can be panned and zoomed when any tool is active using the mouse scroll wheel or trackpad gestures. See “Trackpads” on page 27.

The program adjusts the speed of these actions depending on characteristics of the camera:

- Zoom speed depends on how close the camera is to the object located behind the mouse pointer. When the target object is far from the camera, zooming is faster; as the camera gets closer to the target, zooming slows.
- Panning speed depends on the length of the camera’s Line of Sight. In general, it is likely to be faster in an exterior view of a large model, slower in an interior view of a small room. See "Creating Camera Views” on page 562.

By default, panning and zooming adjusts the position and direction of the camera. It does not, however, adjust the distances at which surfaces are clipped. This means that if you zoom in closely on an object, some of its surfaces may be removed from the view. One way to avoid this is to lower the camera’s Clip Surfaces Within value in the Camera Specification dialog. See “Camera Panel” on page 576.

3Dconnexion® 3D Mice

3Dconnexion®’s 3D mice can be used to navigate in all views - including camera views and overviews.

In the Windows version of Home Designer Pro, pre-programmed view direction hotkeys are supported on devices with buttons for that purpose. MacOS™ does not provide mapping support to the view direction commands. See Hotkeys.

In Orthographic views, navigation is centered around the camera’s focal point; for Perspective views, you can specify whether navigation is centered about the

Rebuild 3D

Select 3D> Rebuild 3D to regenerate all 3D data associated with the current plan. All open views will remain open.

See “Camera Specification Dialog” on page 575.

Each time you move the camera, the view is updated. If you are using either the toolbar or keyboard to move the camera, you can hold down the Shift key, suppressing the redraw of the view until the Shift key is released and allowing you to move multiple increments more quickly.

Press Ctrl + Alt + S while in a camera view or overview to spin the view. Press Esc to stop the spinning.

You can also move a camera to a different floor by clicking the Up One Floor button or Down One Floor button while the camera view is active. Note that this may affect what is seen in the view as well as its display in plan view. See “Floor Up / Floor Down” on page 392.
camera or its focal point in the Preferences dialog. See “Render Panel” on page 80.

For best results when using a 3D mouse, uncheck Camera Bumps Off Walls. See “3D View Defaults Dialog” on page 560.

Rolling is not supported in Home Designer Pro, In addition, 3D mice cannot be used to move the mouse pointer. For details about using your 3D Connexion® mouse, refer to its documentation.

Gamepads

In the Windows version of Home Designer Pro, gamepads can be used to navigate in camera views and overviews as well as elevation views. To use a gamepad in Home Designer Pro, check Enable Gamepad in the Gamepad Settings dialog. You can also adjust the sensitivity and other aspects of thumbstick functionality when used in Home Designer Pro. See “Gamepad Settings Dialog” on page 91.

You can specify whether navigation is centered about the location of the camera or its focal point in the Preferences dialog. See “Render Panel” on page 80.

Move Camera with Mouse

An active camera’s position can be edited using the mouse. Select 3D> Move Camera With Mouse to access the Move Camera with Mouse modes. With the exception of Mouse Orbit Camera, which is available in Orthographic Overviews, these tools are not available in Orthographic views.

<table>
<thead>
<tr>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Mouse-Orbit Camera</strong> lets you move the mouse to rotate the camera around its focal point. The camera’s position and direction both change. To continuously rotate the camera around its focal point, click in the 3D view, drag the mouse, and release the mouse button to “throw” the view. Click again in the view to stop it from rotating.</td>
</tr>
<tr>
<td><strong>Mouse-Pan Camera</strong> lets you move the camera up, down, left and right using the mouse. The camera’s position changes, but its direction does not.</td>
</tr>
<tr>
<td><strong>Mouse-Dolly Camera</strong> lets you move the camera forward and backward by moving mouse up and down. Move the mouse left or right to rotate the camera side to side.</td>
</tr>
<tr>
<td><strong>Mouse-Tilt Camera</strong> lets you move the mouse to tilt the camera in any direction while staying in the same location.</td>
</tr>
<tr>
<td><strong>3D Center Camera on Point</strong> lets you focus the camera at a particular point in the scene. This changes the camera’s direction and focal point, but not its position. To use the 3D Center tool, activate the tool and then click on any object in the scene.</td>
</tr>
<tr>
<td><strong>3D Focus on Object</strong> lets you focus the camera on a specific object, changing the camera’s position, direction, focal point, and the length of its line of sight. To use this tool, activate it and then click on an object in the scene. Alternatively, select an object in the view and click the Focus on Selected edit button.</td>
</tr>
</tbody>
</table>
Move Camera with Keyboard

An active camera’s position can be changed using the Arrow keys on your keyboard. Select 3D> Move Camera with Keyboard to access the Move Camera with Keyboard modes. With the exception of Mouse Orbit Camera, which is available in Orthographic Overviews, these modes are not available in Orthographic views.

These modes use the Incremental Move Distance and Incremental Rotate Angle set in the active 3D view’s Camera Specification dialog.

- **Keyboard-Orbit Camera** lets you use the keyboard to rotate the camera around the focal point. The camera’s position and direction both change.

- **Keyboard-Pan Camera** lets you move the camera up, down, right, and left using the keyboard. The camera’s position changes, but its direction does not.

- **Keyboard-Dolly Camera** lets you move the camera forward and back using the Up and Down Arrow keys, and rotate side to side using the Left and Right keys.

- **Keyboard-Tilt Camera** lets you use the Arrow keys to tilt the camera up, down, or side to side to change the focal point. The camera’s direction changes, but its position does not.

Move Camera Tools

Select 3D> Move Camera in a 3D view to access these tools. These tools change the active camera’s position, but not its direction and are not available in Orthographic views.

<table>
<thead>
<tr>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move Camera Forward moves the camera and its focal point forward.</td>
</tr>
<tr>
<td>Move Camera Back moves the camera and the focal point back.</td>
</tr>
<tr>
<td>Move Camera Left moves the camera and the focal point to the left in a line perpendicular to the line of sight.</td>
</tr>
<tr>
<td>Move Camera Right moves the camera and the focal point to the right in a line perpendicular to the line of sight.</td>
</tr>
<tr>
<td>Move Camera Up moves the camera and the focal point up.</td>
</tr>
<tr>
<td>Move Camera Down moves the camera and the focal point down.</td>
</tr>
</tbody>
</table>

Orbit Camera Tools

Select 3D> Orbit Camera in a 3D view to access these tools. Orbiting the camera rotates it about the focal point using the Incremental Rotate Angle set in the active view’s Camera Specification dialog.

These tools are not available in Cross Section/Elevation, Back Clipped Cross Section, or Wall Elevation views.
### Tilt Camera Tools

Select 3D> Tilt Camera to access these tools. Tilt Camera keeps the camera in one place and pivots the camera about its vertical or horizontal axis. This movement uses the Incremental Rotate Angle set in the active view’s Camera Specification dialog and is similar to tilting your head up and down or turning it side-to-side. These tools are not available in Orthographic views.

<table>
<thead>
<tr>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Move Camera In</strong> moves the camera closer to the focal point along the line of sight. The camera cannot move past the focal point using this tool.</td>
</tr>
<tr>
<td><strong>Move Camera Out</strong> moves the camera away from the focal point along the line of sight.</td>
</tr>
<tr>
<td><strong>Orbit Camera Upward</strong> rotates the camera up about the focal point. The camera cannot rotate past a vertical line looking straight down on the focal point.</td>
</tr>
<tr>
<td><strong>Orbit Camera Downward</strong> rotates the camera down about the focal point. The camera cannot rotate past a vertical line looking straight up at the focal point.</td>
</tr>
<tr>
<td><strong>Orbit Camera Left</strong> rotates the camera to the left about the focal point.</td>
</tr>
<tr>
<td><strong>Orbit Camera Right</strong> rotates the camera to the right about the focal point.</td>
</tr>
</tbody>
</table>

### View Direction Tools

The View Direction Tools allow you to view the model from a specific direction in a camera view or overview. While one of these views is active, select 3D> View Direction to access these tools.

<table>
<thead>
<tr>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Tilt Camera Upward</strong> tilts the camera up while keeping it in the same location. The camera cannot tilt beyond the vertical position.</td>
</tr>
<tr>
<td><strong>Tilt Camera Downward</strong> tilts the camera down while keeping it in the same location. The camera cannot tilt beyond the vertical position.</td>
</tr>
<tr>
<td><strong>Turn Camera Left</strong> turns the camera to the left while staying in the same location.</td>
</tr>
<tr>
<td><strong>Turn Camera Right</strong> turns the camera to the right while staying in the same location.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Front View</strong> creates a front view of the model.</td>
</tr>
</tbody>
</table>
In addition to its position and direction, there are other ways to modify a 3D view.

**In the Specification Dialog**

You can make adjustments to a camera in the Camera Specification dialog. This dialog is particularly helpful for making fine adjustments to the camera’s position, appearance, and other attributes. See “Camera Specification Dialog” on page 575.

**Using the Edit Tools**

A camera symbol or symbols selected in plan view can be edited in a variety of ways using the buttons on the edit toolbar. See “The Edit Toolbar” on page 29.

The Copy/Paste edit tool is available for a selected camera or overview. It is not, however, available for cross section/elevation views. See “Copying and Pasting Objects” on page 104.

**Using the Edit Handles**

Return to plan view without closing the 3D view. See “Working in Multiple Views” on page 94.

Using the Select Objects tool, select the camera object. When a camera symbol is selected it displays four edit handles.

- Drag the Line of Sight handle to change the camera angle without moving the focal point.
- Drag the Move handle to relocate the camera while maintaining its relative angle.
- Drag the Focal Point handle to reposition the focal point and change the line of sight without moving the camera.
- Drag the Rotate handle to rotate the camera’s line of sight about its center.

The 3D view corresponding to the camera symbol reflects changes made to the symbol in plan view.

Multiple camera symbols can be selected; however, their editing options are limited to being moved, rotated, and deleted.
Using the Contextual Menu

In a 3D view, right-click in an empty space in which the backdrop or background color displays to access the contextual menu. See “Contextual Menus” on page 30.

- In Vector Views, the options are a selection of commonly used commands from the File, Edit, Tools and Window menus.
- In the other Rendering Techniques, the options are a selection of tools and toggles specific to the current view.

Up One Floor/Down One Floor

You can move a camera to a different floor. While the camera view is active, select Tools> Floor/Reference Display> Up One Floor or Down One Floor. Note that this may affect what is seen in the view as well as its display in plan view. See “In Plan View” on page 565.

The position and movement of a camera is affected by its location within the model. When the camera is outside a building, its height is relative to the terrain and follows the terrain as it is moved. When inside a building, the camera height is relative to the floor of the room it is drawn in.

Which floor an active camera is on determines which floor is affected when any floor-specific actions are done. For example, if a camera is on Floor 2 and changes are made to the Floor Default settings while in that view, Floor 2 will be affected.

If the camera is on an upper floor and you move the camera outside of the building, the camera remains at the same height relative to the floor it was created on.

Zooming

The Zoom Tools are available in all 3D views. See “Zoom Tools” on page 96.

Selecting Window> Zoom In, Zoom Out, or Fill Window does not change the camera’s location or field of view. Instead, the extents of the view are expanded or cropped.

If you wish, you can instead set the Zoom tools to change the Field of View when used in a 3D view. See “Render Panel” on page 80.

Field of View

The Field of View refers to a camera’s field of vision. A wider field of view makes the focal point appear further away, as more of the image is included in the same view window.

In plan view, the angled lines of a camera symbol indicate its field of view.

A camera’s field of view can be adjusted in the Camera Specification dialog. See “Camera Panel” on page 576.

Cross Section Slider

Select 3D> Camera View Options> Cross Section Slider when a camera view or overview is active to open the Cross Section Slider dialog.

Note: The Cross Section Slider is not available when the Vector View Rendering Technique is used. See “Rendering Techniques” on page 595.
To use the Cross Section Slider

1. Check the box beside a cross section cutting plane to select it and make its Position slider and text box active.
2. Move the Position slider to adjust the position of the cutting plane.
   • The cutting plane Position is measured from the edge of the model that is cut first by the selected cutting plane.
3. Repeat steps 1-3 to use additional cutting planes if you wish.
4. Click OK to close the dialog. If the active camera is saved, its Cross Section Slider settings will also be retained. See “Saving 3D Views” on page 575.

Working in 3D

A variety of tools are available in 3D views that allow you to edit your 3D model. You can also use the Dimension, Text, and CAD Tools to add annotation to cross section/elevation views.

Creating Objects in 3D Views

You can place windows, doors, cabinets, electrical objects, corner trim, and most library objects directly into 3D views. To do this, select the appropriate tool and click in the 3D view. You can then edit the object’s size and placement.

When created in 3D, most objects must be placed against a wall, on a floor platform, or within the Terrain Perimeter.

You can also click and drag to draw some CAD-based objects such as custom countertops, roof planes, terrain features and road, in camera views and overviews views.

The Build Framing and Build Roof dialogs are also accessible in 3D views, although the manual Framing Tools and Roof Tools are not.

Selecting and Editing Objects in 3D Views

Most objects can be selected and edited in 3D views. Select Edit> Select Objects and click on the surface of an object to select it. Once selected, objects can be edited using their edit handles, buttons on the edit toolbar, and the object’s specification dialog. See “Editing Objects” on page 119.

When you select an object, edit handles and a handle surface display. The handle surface is a rectangle around the perimeter of the object that indicates the overall height and width of the selected surface. The edit handles that display depend on the type of object selected. Walls, for example, display two resize edit handles when selected while a slab displays ten handles, allowing you to move, resize and reshape it.

Note: If the wall height of the Exterior Room is adjusted in a 3D view, the default Floor or Ceiling Height of the entire floor is changed. See “Floor and Room Defaults” on page 226.
All moving or resizing is in the plane of the handle surface. You cannot move an object directly towards or away from the camera, for example, because that surface plane cannot be seen in the view.

By default, object movement is restricted to one inch or 10 mm increments, but this restriction can be set to custom increments in the **Plan Defaults** dialog and toggled off and on using the **Grid Snaps** button. See “Grid Snaps” on page 102.

Unrestricted positioning can also be enabled by holding down the Ctrl key while moving or resizing an object. See “Unrestricted Movement” on page 142.

Temporary dimension lines display when many objects are selected to help you resize the object and determine its height. These are sometimes easier to see when the color is toggled off. See “Temporary Dimensions” on page 258.

Because cross section/elevation views are orthogonal and display objects at their actual dimensions, they are sometimes more suitable for editing objects than camera views or overviews. See “Cross Section/Elevation Views” on page 564.

When several 3D views are open, changes made in the plan automatically rebuild the model in all views. Because of this, it is typically faster to make changes to your plan with as few windows open as possible.

### Editing Materials in 3D Views

Select **3D> Materials> Adjust Material Definition**, then click on a surface in the 3D view to open the **Define Material** dialog for that material. See “Adjust Material Definition” on page 545.

Select **3D> Material Painter** to apply materials to surfaces in the view using the Material Painter Tools. See “Material Painter Tools” on page 541.

Select **3D> Material Painter> Material Eyedropper** to apply the material on a surface in the view to other surfaces in the view. See “Material Eyedropper” on page 542.

### Rebuild 3D

As changes are made to your plan, a 3D view automatically updates to reflect any changes visible in the view. If you find that a view is not updating as expected, select **3D> Rebuild 3D** to rebuild the entire 3D model.

### Annotating 3D Views

The Dimension Tools, Text Tools, and CAD Tools are available in cross section/elevation views, allowing you to add technical information, call attention to details, and other tasks in these views. See “Detailing Cross Section/Elevation Views” on page 564.

### Cross Section Lines

Cross Section Lines are created in cross section views to represent any objects split by the cross section line of the camera. They are placed on the “Cross Section Lines” layer, which is locked by default, and they get deleted and replaced whenever the view is redrawn.

When a dimension is drawn to locate an object split by a camera’s section line, it actually locates Cross Section Lines. So that dimensions can be retained when Cross Section Lines are regenerated, a **Point Marker** is automatically created where a dimension meets a Cross Section Line and the dimension locates it instead of the Cross Section Line. See “Point Markers and Dimensions” on page 282.

Cross Section Lines will print when their layer is turned on; however, they are not included when the view is sent to layout. The Point Markers created when dimensions locate Cross Section Lines, however, will both print and display in views sent to layout. See “Layout” on page 695.

The “Cross Section Lines” layer can be unlocked, allowing Cross Section Lines to be be selected and edited. Additional CAD objects can also be placed on this layer when it is unlocked, as well; however, when the view is redrawn, all CAD objects on this layer will be deleted and replaced with a fresh set of Cross Section Lines.

### Saving and Printing 3D Views

3D camera views, overviews and cross section/elevation views can be saved with the plan in which they are created, exported and saved as image files, as well as sent to layout and printed.
Saving 3D Views

Select 3D> Save Active Camera to save the current camera in the plan. You can also save a camera view by checking the Saved box in the Camera Specification dialog. See “Camera Specification Dialog” on page 575.

Saved cameras can be closed and re-opened for later use, and retain their Cross Section Slider, Sunlight, Shadows, and Rendering Technique settings. See “Cross Section Slider” on page 572, “Adjust Sunlight Dialog” on page 594, “Shadows” on page 583, and “Rendering Techniques” on page 595.

In addition, if CAD or Text objects are drawn in a cross section/elevation view, you will be prompted to save the view when you close it. Any CAD or Text objects added to a cross section/elevation view are saved with the view as part of the plan file.

Activating Saved Views

There are three ways to open a saved 3D view:

• Select the camera symbol in plan view and click the Open View edit button.
• Double-click the camera symbol using the Select Objects tool.
• Right-click on it and select Open View from the contextual menu.

Unsaved cameras that are open in another view window can also be activated using the Open View edit button.

If you open a saved camera view and then modify its location or direction using any of the tools available in that view, the program will confirm whether you want to re-save the camera using these new settings when you close it. See “Repositioning Cameras” on page 567.

Exporting 3D Views

All 3D views can be exported and saved as .bmp, .jpg, .png, or .tif files. Select File> Export> Picture to save the current screen image as an image file. See “To export a picture” on page 606.

In addition, Vector Views can be exported and saved as .emf files. See “Metafiles” on page 608.

Once saved, a picture can be opened and converted into many other formats using a graphics program. Picture files can be sent to layout or used in word processing, desktop publishing, and web development programs to create advertisements, brochures, etc.

Plan Backup

When transferring a plan to another computer or to another user, it is helpful to include all the Images, Textures, and Backdrops used in the plan so that rendered views are complete. The Backup Entire Plan tool allows you to do so. See “Backup Entire Plan or Project” on page 49.

Printing 3D Views

Since all 3D views other than Vector Views are created using pixels instead of lines, File> Print> Print Image must be used when printing. Print Image is a special Home Designer Pro function that prints the screen in picture format. The entire view prints, including images such as plants and textures.

3D views can also be sent to layout and then printed as part of your construction documents.

Select File> Send to Layout to send the current view to layout. See “Sending Views to Layout” on page 697.

Select a saved, inactive camera symbol in plan view and click the Send Camera’s View to Layout edit button to send the view to layout.

Closing 3D Views

Although you can have any number of 3D views open at a time, to conserve resources on your computer it is a good idea to close views when you no longer need them. There are a number of different ways to do this. See “Closing Views and Files” on page 98.

Camera Specification Dialog

The Camera Specification dialog can be accessed in plan view by selecting one or more camera symbols and clicking the Open Object edit button. See “In Plan View” on page 565.
This dialog can also be accessed while a camera view or overview is active by selecting 3D > Edit Active Camera.

The selected view’s specific type is indicated in the dialog’s title bar: the specification dialog for a Full Camera, for example, is named Full Camera Specification.

The settings in this dialog are also found in the Full Camera, Floor Camera, and all Overview Defaults dialogs. See “Camera Defaults Dialogs” on page 558.

Camera Panel

Some settings only affect some types of views. Depending on the type of camera view selected, not all the settings may be available.

1. **General**
   - Specify the Name that displays in the camera label in plan view.
   - Check Saved to save this view with the plan. As soon as you type anything in the text field, this box becomes checked. If you click OK while this box is checked, it will become checked permanently.
   - Select the selected camera’s Rendering Technique from the drop-down list. See “Rendering Techniques” on page 595.
   - Check Show Shadows to turn on shadows in the selected camera view. When unchecked, shadows are not generated. See “Shadows” on page 583.
   - Check Ray Casted Sun Shadows for higher quality shadows cast by sun light. Ray Casted Sun Shadows take longer to generate than regular
shadows and only refresh when the camera is not moving.

- Check **Reflections** to turn on reflections in the selected camera view. When unchecked, reflections are not generated. See “Reflections” on page 584.

- Light **Bloom** occurs around areas of intense illumination and looks as though the light is ‘bleeding’ beyond the edges of the light source. It adds realism to the view but can take longer to render. Only affects Standard and Watercolor renderings. See “Rendering Techniques” on page 595.

- Check **Edge Smoothing When Idle** to apply high quality edge smoothing to edge and pattern lines when the selected camera is not in motion. See “Edge Smoothing” on page 584.

- Select the amount of **Ambient Occlusion** in the view using the slider bar or text field. Ambient Occlusion allows variation in the strength of the ambient light. It is more realistic than uniform ambient light, but can take longer to render. Only affects Standard, Watercolor, and Physically Based renderings. See “Ambient Lighting and Occlusion” on page 586.

2 The **Lighting** settings control which and how many light sources are used in the current view. See “Lighting Modes” on page 587.

- Select **Automatic**, then specify the **Maximum Number** of lights that can be used in the current camera view.

- Select **Use Light Settings** to use all light sources in the entire plan provided that they are turned **On**.

- Click the **Adjust Lights** button to view a list of the light sources in the plan and modify their settings. See “Adjust Lights Dialog” on page 588.

3 The **Positioning** settings determine the position and orientation of the camera. See “Repositioning Cameras” on page 567.

- The **Height Above Floor** defines the height that the camera is above the floor level for the current floor. See “Camera Height” on page 562.

- The **Tilt Angle** determines the vertical angle that the camera is tilted. The camera maintains its focal point and position in plan view, but if the camera is tilted, the focal point is above or below the current camera height.

- Specify the selected camera’s **Camera Angle**. This is an absolute value: an angle of 0° points the camera toward the left in plan view.

- Specify the **X Position** and **Y Position** for the selected camera. These are absolute coordinates. Specifying zero for both places the camera at the plan’s origin point (0,0).

- The **Incremental Move Distance** controls how far the camera moves each time you Pan in any direction or Dolly forwards or backward using the keyboard, toolbar buttons, or menu. For interior views a small number is good, but for exterior you may want a larger increment.

- The **Incremental Rotate Angle** defines how many degrees the camera rotates each time you Tilt, Orbit, or Dolly side to side using the keyboard, toolbar buttons, or menu. A setting of 90° would make one full rotation in four moves.

- The **Field of View** defines the camera’s field of vision in angular degrees. See “Field of View” on page 572.

4 Options -

- **Clip Surfaces Within** - Objects located within this distance from the camera do not display in the view. Decrease this value to display objects located close to the camera; increase it to improve the appearance of some surfaces in Overview cameras with very large extents.

- Uncheck **Show Lower Floors** to show only the current floor in the selected Floor Overview. When checked, the current floor plus any floors beneath it are included in the view. Only available for Floor Overviews. See “Doll House View” on page 563.

- Check **Hide Camera-Facing Exterior Walls** to suppress the display of any exterior walls that face the camera. Interior walls set as Attic walls are also suppressed. This setting only has an effect when the selected camera’s position is on the exterior of a structure and can also has an associated toggle. See “Hide Camera-Facing Exterior Walls” on page 585.

**Plan Display Panel**

The settings on the PLAN DISPLAY panel control the appearance of the selected camera in plan view. See “In Plan View” on page 565.
The **Plan Display** settings allow you to specify the appearance of the selected camera’s symbol. Uncheck **Default** beside any of these options to modify it. See “Dynamic Defaults” on page 58.

- The **Camera Symbol Size** is measured in plan inches (mm).
- Check **Show Camera Focal Point** to display the camera’s focal point in plan view. When unchecked, the camera’s line of sight and focal point are hidden until the camera is selected.
- Check **Show Field of View Indicators** to display the camera’s field of view indicators in plan view.
- You can also change the **FOV Indicator Length**, which is measured in plan inches (mm).

### Backdrop Panel

The settings on the Backdrop panel allow you to specify a backdrop image or color to display behind your model in the selected 3D view. See “3D Backdrops” on page 614.

1. **Specify Backdrop** - A preview of the selected backdrop image is shown here. A backdrop cannot be selected or removed when Use Generated Sky is checked, below.

   - **Backdrop Name** - The selected backdrop image’s name displays for reference.
   - Click **Select Backdrop** to choose a backdrop image from the library. See “Select Library Object Dialog” on page 522.
• Click **Remove Backdrop** to use a solid color instead of a backdrop image in all 3D views, then specify the color below.

• Click the Color bar to select the **Background Color** that displays when a backdrop image is not being used. See “Select Color Dialog” on page 117.

The Background Color for plan views is set in the Preferences dialog. See “Colors Panel” on page 64.

**Backdrop Options -**

• Check **Use Generated Sky** to simulate a daytime sky backdrop. When checked, Spherical Panoramic Backdrop will also be checked and a preview of the Generated Sky will display above.

• Specify a **Haze Level** of Low, Medium, or High. This determines the degree to which light in the sky backdrop appears to be scattered by particles in the air.

• Specify a **Horizon Level** using the text field or slider bar. The default value of 44% works well in most situations.

• Check **Spherical Panoramic Backdrop** to place the selected backdrop onto a sphere that surrounds your model in camera views and overviews.

• The **Horizontal Angle** and **Vertical Angle** settings are the same as those in the Backdrop Specification dialog. If these values are changed here, the backdrop saved in the library will be unaffected. See “Backdrop Specification Dialog” on page 615.

**Label Panel**

In the Camera Specification dialogs, the settings on the LABEL panel are limited to the **Suppress Label** checkbox and **Position** and **Orientation** settings.

Camera labels always use the Camera Name specified on the CAMERA panel. When callouts are used, the **Callout Label** and **Text Below Line** are specified on the PLAN DISPLAY panel.

For information about this panel, see “Label Panel” on page 286.

---

### Cross Section/Elevation Camera Specification Dialog

The Cross Section/Elevation Camera and Wall Elevation Camera Specification dialogs can be accessed in plan view by selecting one or more cross section/elevation camera symbols and clicking the Open Object edit button. See “In Plan View” on page 565.

This dialog can also be accessed while a cross section/elevation camera view is active by selecting 3D> Edit Active Camera.

The settings in this dialog are also found in the Cross Section/Elevation, Backclipped Cross Section, and Wall Elevation Defaults dialogs. See “Camera Defaults Dialogs” on page 558.
Camera Panel

1. The **Camera Name** displays in plan view. 
   - Check **Saved** to save this view with the plan. As soon as you type anything in the text field, this box becomes checked. If you click OK while this box is checked, it will become checked permanently.
   - Select the **Rendering Technique** used by the selected camera from the drop-down list. See “Rendering Techniques” on page 595.
   - Check **Show Shadows** to turn on shadows in the selected camera view. When unchecked, shadows are not generated. See “Shadows” on page 583.
   - Check **Ray Casted Sun Shadows** for higher quality shadows cast by sun light. Ray Casted Sun Shadows take longer to generate than regular shadows and only refresh when the camera is not moving.
   - Check **Edge Smoothing When Idle** to apply high quality smoothing to edge and pattern lines when the camera is not in motion. See “Edge Smoothing” on page 584.

2. Settings in the **Positioning** section determine the location of the camera in plan view.
   - Specify the **X Position** of the camera in absolute coordinates.
   - Specify the **Y Position** of the camera in absolute coordinates.

3. The **Scene Clipping** settings control the extents of the camera view.
   - **Back Clip After** - Enter the distance in inches (mm) from camera to backclip plane. If zero, no back clipping occurs.
   - Check **Clip To Sides** to limit the selected camera view’s side-to-side extents to the length of its Clip Plane Indicator line(s) in plan view. When unchecked, the full width of the model is included in the view.
   - Check **Back Clip After** - Enter the distance in inches (mm) from camera to backclip plane. If zero, no back clipping occurs.

   The **Clip Plane Indicator Length** can be specified on the PLAN DISPLAY panel when callouts are not used, or using the camera’s edit handles in plan view. See “Editing 3D Views” on page 571.
   - Check **Ignore Railings and Invisible Walls** to ignore the room definition created by these types of walls in a selected **Wall Elevation** view. When this is unchecked, **Wall Elevation** views only recognize room definition created by regular walls. See “Cross Section/Elevation Views” on page 564.

Plan Display Panel

The settings on the PLAN DISPLAY panel control the appearance of the selected camera in plan view. See “In Plan View” on page 565.
The **Plan Display** settings allow you to specify the appearance of the selected camera’s symbol. Uncheck **Default** beside any of these options to modify it. See “Dynamic Defaults” on page 58.

- The **Camera Symbol Size** is measured in plan inches (mm).
- Check **Show Camera Focal Point** to display the camera’s focal point in plan view. When unchecked, the camera’s line of sight, focal point, and clip plane indicators are hidden until the camera is selected.
- Specify the **Clip Plane Indicator Length** in plan inches (mm). See “To create a cross section/elevation view” on page 564.

**Backdrop Panel**

The settings on the **BACKDROP panel** allow you to specify a backdrop image or color to display behind your model in the selected 3D view. See “Backdrop Panel” on page 578.

**Label Panel**

In the **Cross Section/Elevation Camera Specification** dialog, the settings on the **LABEL panel** are limited to the **Suppress Label** checkbox and **Position** and **Orientation** settings.

Camera labels always use the **Camera Name** specified on the **CAMERA panel**. When callouts are used, the **Callout Label** and **Text Below Line** are specified on the **Plan Display panel**.

For information about this panel, see “Label Panel” on page 286.
There are a variety of tools available to create 3D views of a model: simply click a button to create an overview, or click and drag to create a camera or cross section/elevation view. See “3D Views” on page 557.

To improve the quality of the rendering and create a custom look, you can adjust lighting, edit the materials used in the plan, choose from several rendering techniques and fine-tune 3D view quality settings.

Rendering Tips

There are a variety of factors which affect the appearance and quality of rendered 3D views. You can use these tools and settings to achieve renderings that meet your needs.

- Lighting
- Shadows
- Reflections
- Material Definitions
- Images
- Backdrops
- Edge Smoothing
- Hide Camera-Facing Exterior Walls

Lighting

Lighting is extremely important in most 3D renderings. Lighting controls the visibility of objects in a view, affects the appearance of surfaces, and influences the appearances of colors and textures on those surfaces. Even small changes to light intensity, direction and color can have a large impact on image quality. See “Lighting” on page 585.

Shadows

Like lighting, shadows have an important effect on image quality. Shadows can be generated in any type of camera view using any Rendering Technique aside from Glass House. See “Rendering Techniques” on page 595.

When shadows are enabled and the sun is shining directly at a window, its light can shine through the window and into an interior room. These shadows use Ray Casted Sun Shadows by default, but this option can be unchecked if it slows performance in 3D views. See “Generic Sunlight” on page 586.

Shadows are enabled in Full Camera views by default. You can, however, check or uncheck Show Shadows and Ray Casted Sun Shadows in the
defaults dialog for any camera tool or in the specification dialog for any camera view. In addition, you can select 3D> Camera View Options> Toggle Shadows in any camera view. See “Camera Panel” on page 576.

Shadows are affected by the number of light sources in a plan, as well as what Rendering Technique is in use. In order for a light source to cast shadows, it must be On in the current view and have Cast Shadows checked in its specification dialog. See “Light Data Panel” on page 371.

In addition to their appearance in camera views, sun shadows can also display in plan view to represent the shadows created by the sun at a particular date, time, and location. See “Sun Shadows” on page 591.

**Reflections**

Reflections are another aspect of lighting that can increase a 3D view’s realism. When a flat surface is assigned a Mirror material, it can display the reflections of other objects in the scene.

Note that a Mirror surface cannot display the reflection of another mirror. When one mirror can be seen in another, its material is shown rather than a reflection.

Reflections only generate in Perspective 3D views using the Standard Rendering Technique. They can slow down 3D view generation and responsiveness considerably and are turned off by default in the Camera Defaults dialogs. See “Camera Defaults Dialogs” on page 558.

Reflections can be toggled on or off in a camera view by selecting 3D> Camera View Options> Toggle Reflections as well as in the Camera Specification dialog. See “Camera Panel” on page 576.

When the Physically Based Rendering Technique is in use, reflections on non-mirror surfaces are modeled, as well. See “Physically Based” on page 596

**Material Definitions**

Textures are graphic files that represent contoured surfaces of objects such as carpet, bricks, tile, and wood in rendered views. Textures are assigned to materials which in turn are assigned to objects. See “Patterns and Textures” on page 540.

The display of materials in rendered views is controlled by settings on the TEXTURE and PROPERTIES panels of the Define Material dialog. See “Define Material Dialog” on page 550.

For realistic rendered views, it is sometimes helpful to make adjustments to texture properties so that they map to surfaces correctly. See “Mapping Patterns and Textures” on page 546.

Brightness, shininess and transparency control how light sources affect the display of surfaces in rendered views. See “Lighting” on page 585.

If no texture is selected for a material or if the display of textures is turned off, affected surfaces are a solid color instead.

**Images**

Images are very important for the appearance of rendered views. Images are picture files that represent individual objects such as trees, flowers, and vehicles. Images are represented in plan view by 2D symbol and are visible in Vector views. See “Placing Images” on page 602.

**Backdrops**

A backdrop is an image, usually of an exterior view, that displays in the background of 3D views to help place the model into a realistic setting and add a sense of perspective. If a backdrop is not specified, Home Designer Pro applies a background color. See “3D Backdrops” on page 614.

**Edge Smoothing**

Angled surface edges and pattern lines will sometimes display on screen as jagged or stair-stepped. Edge Smoothing softens this effect, producing cleaner lines.

You can specify how much Hardware Edge Smoothing occurs in 3D views in the Preferences dialog. Hardware Edge Smoothing is set to “High” by default; however, if 3D views render slowly on your system, you can try using a lower setting. See “Render Panel” on page 80.

Even higher quality Edge Smoothing can be produced by checking Edge Smoothing When Idle in the Camera Specification dialog. This setting does not affect a camera while its position or orientation are being changed, but applies additional smoothing to edge and pattern lines when the camera is not in motion. See “Camera Panel” on page 576.
This high quality Edge Smoothing option is view-specific and can also be toggled on or off by selecting 3D> Camera View Options> Toggle Edge Smoothing When Idle.

Hide Camera-Facing Exterior Walls
Occasionally, it can be very helpful to view the interior of a structure from an exterior view. To achieve this, create an exterior camera view or overview and select 3D> Camera View Options> Hide Camera-Facing Exterior Walls. This option is view-specific and can also be set in the Camera Specification dialog. See “Camera Panel” on page 576.

Hide Camera-Facing Exterior Walls is also an option for Walkthrough Paths. See “Walkthrough Options Dialog” on page 618.

Lighting
Lighting controls the visibility of objects in 3D views, affects the appearance of surfaces, and influences the appearances of colors and textures on those surfaces.

Each individual light source has a set of properties, such as intensity and color, that can be defined. See “Light Data Panel” on page 371.

By default, a maximum of eight lights can display in a given camera view or overview. If more than eight are present, those with the highest intensity located in the same room as the camera are rendered. Lights in adjacent rooms may also be rendered, with the highest intensity lights rendered first.

You can specify a different Maximum Lights number in the Camera Specification dialog. See “Camera Panel” on page 576.

You can also manually turn on and off individual lights in order to get the desired lighting effects. See “Displaying Lights” on page 587.

When the camera is outside a building, the program normally uses sunlight for lighting calculations and turns off all other light sources. You can turn the sunlight off and use all the other exterior lights to simulate nighttime views.

There are five types of light sources in Standard rendered views:

- Default Interior Light
- Light Fixtures
- Added Lights
- Generic Sunlight
- Ambient Lighting and Occlusion

**Default Interior Light**
If you create a Standard interior camera in a room where no lights have been placed, the program creates a Default Light source within that room. The Default interior light acts like a central point light source but cannot be selected or edited.

Because the Default Light cannot be adjusted, if you want to control the light in an interior rendered view, you must add lights to the rooms in your plan by placing light fixtures and Added Lights.

**Light Fixtures**
An electric symbol that represents a Light Fixture can have one or more light sources associated with it. Properties for each light source such as light type, color and intensity can be modified in the fixture’s specification dialog. See “Electrical Service Specification Dialog” on page 369.

If the light source is a Point or Spot Light, you can also adjust its Offset, or position relative to the fixture. If you choose to Show Position in Camera View, you can see where the light source is located.

Light sources look most realistic when they are offset from a surface.

**Added Lights**
In plan view, select 3D> Lighting> Add Lights to quickly add a light source to a plan. Added Lights and their labels are placed on the “Light Sources” and “Light Sources, Labels” layers.

Added lights only act as light sources in plan files that have at least one room defined. They display 2D symbols in plan view but do not display as objects in 3D views.

While Added Lights do not display as objects in 3D, you can specify that an Added Light’s position be represented by a crosshairs in rendered views that use lighting. See “Light Data Panel” on page 371.
Added lights can be placed into objects that normally do not generate light, such as a TV.

There are two types of added light sources: Point Lights and Spot Lights. See “Light Types” on page 586.

**Generic Sunlight**

When you create a rendered view and no Sun Angle exists, the program creates a **Generic Sun** light source.

The Generic Sun’s default intensity, color, and angle can be set in the **Generic Sun Defaults** dialog, and can be modified in the **Adjust Sunlight** dialog. In addition, you can specify that it follow the camera in 3D views so surfaces are always illuminated. The Generic Sun’s settings are view specific: each 3D view can have its own, unique settings. See “Adjust Sunlight Dialog” on page 594.

When standard shadows are enabled, sunlight can shine through windows into interior rooms. See “Shadows” on page 583.

If you place a **Sun Angle** in plan view, the Generic Sun is no longer used as a light source in rendered views. Instead, sunlight is generated based on specific date, time, latitude, and longitude information. See “Sun Angles and Shadows” on page 590.

You can specify that a particular **Sun Angle** or the Generic Sun be used in any active camera view in the **Adjust Sunlight** dialog. See “Adjust Sunlight Dialog” on page 594.

**Light Types**

There are two types of light source, each of which generates light in a different way and allows you to create a variety of lighting effects:

- **Point Light sources**
- **Spot Light sources**

Any light source except a Sun Angle can be specified as a Point or Spot Light in the **Electrical Service Specification** dialog. See “Light Data Panel” on page 371.

In addition to being assigned to light fixtures, these two types of light sources can be placed in a plan as **Added Lights**, which are light sources that are not associated with a fixture. As with light fixtures, the lighting properties of Added Lights can be specified in their specification dialog. See “Light Specification Dialog” on page 589.

**Ambient Lighting and Occlusion**

Ambient lighting simulates the way light bounces around a scene, producing a basic level of uniform illumination on all surfaces. It is used in camera views and overviews using the Standard, and Watercolor Rendering Techniques.

There are three types of ambient light in Home Designer Pro:

- **Interior Ambient** controls the ambient light in interior views.
- **Daytime Ambient** controls the ambient light in exterior views when **Toggle Sunlight** is on. See “Sun Angles and Shadows” on page 590.
- **Nighttime Ambient** controls the ambient light in exterior rendered views when **Toggle Sunlight** is off.

You can control the brightness of each in the **Rendering Technique Options** dialog. See “Standard Panel” on page 597.

Ambient occlusion adds shading to surfaces near corners which, because of their location, reflect less light compared to other surfaces. Too little ambient occlusion can result in a view having a flat appearance. You can specify the amount of **Ambient Occlusion** to use in Standard, Watercolor, and Physically Based renderings in the **Camera Specification** dialogs. See “Camera Panel” on page 576.
Displaying Lights

The display of light fixtures and Added Lights in floor plan and 3D views is controlled in the Layer Display Options dialog. Light fixtures are placed on the “Electrical” layer, and Added Lights, on the “Light Sources” layer. See “Layer Display Options Dialog” on page 111.

In addition, they can serve as sources of light in rendered 3D views. They can be turned on and off, as well as set to cast shadows.

In Plan View

In plan view, both light fixtures and Added Lights can display labels when the “Electrical, Labels” and/or “Light Sources, Labels” layers are is turned on. See “Object Labels” on page 285.

In 3D Views

Light fixtures and Added Lights can serve as sources of light in rendered views.

To turn a light on or off

There are several ways to turn a light fixture or Added Light on or off:

• Select one or more fixtures or Added Lights and click the Turn Light(s) Off in 3D or Turn Light(s) On in 3D edit button.
• Uncheck On in the object’s specification dialog. See “Light Data Panel” on page 371.
• Clear the On/Off check box in the Adjust Lights dialog. See “Adjust Lights Dialog” on page 588.

Added Lights are not associated with a 3D fixture, but you can specify that any light source’s location be represented in 3D views using a crosshairs. See “Light Data Panel” on page 371.

Light source position indicators will only display when the light is in use in the current 3D view. That is, it must be:

• Turned on.
• In use in the current view.
• Either located in a room or in an exterior view with Sunlight toggled off.

Sunlight will shine through windows into interior rooms when shadows are enabled. See “Shadows” on page 583.

Lighting Modes

By default, cameras use an Automatic Lighting Mode that allows a set number of lights to illuminate the view. This number can be specified in the Camera Specification and Adjust Lights dialogs. See “Camera Panel” on page 576.
If more than the set number of lights are present, lights are prioritized in this order:

- Lights in the same room as the camera before those in different rooms.
- Higher intensity lights before lower intensity lights.
- Lights closer to the camera before those further away.
- Regardless of their intensity or proximity to the camera, lights on floors above the camera are not used in Floor Overviews. See “3D View Tools” on page 561.

The Automatic Lighting Mode is useful because it is an easy way to produce reasonable lighting without taxing your video memory.

An alternative to the Automatic Lighting Mode is the Use Light Settings option. When Use Light Settings is selected, all lights in the current plan that are turned On are used in 3D views. This gives you control over which lights are used as light sources but may require more resources on your system.

**Adjust Lights Dialog**

Light fixtures and Added Lights in the current plan are listed and can be edited in the **Adjust Lights** dialog. Select 3D> Lighting> Adjust Lights to open this dialog in floor plan or any 3D view. You can also open it by clicking the **Adjust Lights** button in the **Camera Specification** dialog. See “Camera Panel” on page 576.

The **Adjust Lights** dialog is an efficient way to control which lights are turned on in 3D views.

When the dialog is opened while a camera view is active, these settings are available:

- The name of the **Current Camera** is stated here for reference.
- Specify the desired **Lighting Mode**. **Automatic** uses the specified **Maximum Lights** while **Use Light Settings** uses the lights as specified below.

In some circumstances, performance in the **Adjust Lights** dialog can be slow when opened from a camera view.

- To avoid this, uncheck **Update Lighting Automatically**.
- When **Update Lighting Automatically** is checked, you can click the **Update** button to update the lights in the camera view.

All lights in the current plan are listed here using the same **Names** as their labels.

- If a line item is a light fixture, it will have an arrow to the left of its name. Click this arrow to show the fixture’s light sources as individual line items.
- Check the box in the **On** column to turn it on or uncheck the box to turn it off. If a fixture has multiple light sources and only some are on, a solid square will display in its check box.
- The **Count** column lists the number of light sources assigned to each light fixture. This column is empty for Added Lights.
- The **Room** column states the location of each light. If a light is not in a room, “Outside” will be reported.
- The **Floor** column states the floor level that each light is on.
- The **Type** column states the type of light source used by each light. See “Light Types” on page 586.
- The **Intensity** column states the strength of each light.
- The **Color** column displays the light’s color. Click the button to choose a different color if you wish.
- Uncheck the box in the **Casts Shadows** column to prevent a light from casting shadows.
- The **In Use** column states whether each light is emitting light in the Current Camera view. If a fixture has multiple light sources and only some are in use, a blue box will display in its row.

To adjust the properties of a light in the list, double-click on its name or select it and click the **Adjust** button. Make changes to the light in its specification dialog and click OK. For more information, see “Light Specification Dialog” on page 589 or “Electrical Service Specification Dialog” on page 369.

Multiple lights can be selected by holding down the Shift key. If multiple lights are selected, clicking the Adjust button opens the **Light Data** dialog, which is similar to the **LIGHT DATA** panel of a single object’s specification dialog.

If you are in a 3D view that displays lighting, the view will regenerate based on the new light settings. The Generic Sun and Sun Angles are not listed in this dialog. See “Generic Sunlight” on page 586.

---

### Light Specification Dialog

Select one or more Parallel, Point or Spot Lights and click the **Open Object** edit button to open the **Light Specification** dialog.

You can also select **3D> Lighting> Adjust Lights** to access a list of the light sources present in the current plan and open the specification dialog for any of them. See “Adjust Lights Dialog” on page 588.

### Location Panel

**Light Display** - Specify where the selected Added Light displays in plan and 3D views.

- Select **All Floors** to display the selected light on all floors in plan view. See “Multiple Floors” on page 387.
- Select **Specify Floor Number** to display the light on one floor only, then choose a floor number from the drop-down list.

Note: The floor or floors that an Added Light displays on in plan view is totally independent of where it displays in 3D.

- Specify the selected light’s **Absolute Elevation**, measured relative to 0, which is the default height of Floor 1.
- Specify the **Display Size**, which is the diameter of the circle representing the Added Light in plan view.
**Light Data Panel**

The settings on this panel are also found on the same panel of the *Electrical Service Specification* dialog. See “Light Data Panel” on page 371.

Depending on the type of light selected, the options available here may vary.

**Sun Angles and Shadows**

In addition to the functional and aesthetic properties of ambient light and light sources in rendered views, the direction and angle of the sun’s light and shadows are an important consideration. Two tools allow you to generate sunlight and sun shadows with accuracy:

- **North Pointers** allow you to specify the direction of true north in a plan.
- **Sun Angles** let you specify an exact location, date, and time for sunlight and sun shadow generation.

**North Pointer**

The **North Pointer** tool is used to define the direction of true north in a plan. The direction of north does not affect the orientation of the Snap and Reference grids, but it does affect the direction of sunlight and sun shadows, how conditioned area totals are calculated, and how bearing information is interpreted by the program.

If a North Pointer is not used, north is assumed to be straight up on screen in plan view.

Select **CAD> Lines> North Pointer** , then click and drag to draw the pointer, starting at the tail and dragging toward the point. Once it is drawn, you can define its exact length and angle in its specification dialog. See “Line Specification Dialog” on page 168.

Multiple North Pointers can be drawn in a given plan file, and will always point in the same direction automatically. If you rotate one of them, the others will automatically rotate to match. Similarly, if you draw a new North Pointer at a different angle, existing North Pointers will rotate to that angle automatically.

**Label Panel**

Labels for Added Lights display in plan view when the “Light Sources, Labels” layer is turned on and use the Text Style assigned to that layer. See “Text Styles” on page 283.

For information about the settings on this panel, see “Label Panel” on page 286.

If you choose to display line angles when a North Pointer exists, be sure to select the appropriate format in the **CAD Defaults** dialog. See “CAD Defaults and Preferences” on page 161.

- If angles are set to **Bearings**, they are relative to the North Pointer.

![The same line's angle is set to show Bearings, which reference the North Pointer.](image)

- If angles are set to show as **Degrees**, the angle relates to 0° (horizontal to the right) even if a North Pointer is present.

![Line angle shown in degrees. This does not reference the North Pointer.](image)

A North Pointer can be selected and edited using its edit handles and edit toolbar buttons. All attributes of the N aside from its size are drawn from the Text Style assigned to the “CAD, Default” layer. For more information, see “Editing Line-Based Objects” on page 126.
Sun Angles and Shadows

Sun Angles

Sun Angles let you establish exactly where your plan’s building site is located, and a precise date and time. This information allows the program to determine the sun’s location in the sky and generate sunlight and sun shadows with accuracy.

When an exterior 3D view is rendered, the program looks for an active Sun Angle. If it finds none, the Generic Sun is used. See “Generic Sunlight” on page 586.

To create a Sun Angle

1. In plan view, go to Floor 1 or Floor 0. Sun Angles can only be created on these floor levels. See “Multiple Floors” on page 387.

2. Select CAD> Lines> Sun Angle and click in the drawing area to place a Sun Angle arrow at that location.

3. In the Sun Angle Specification dialog, specify the Sun Angle’s Earth Data and other information. See “Sun Angle Specification Dialog” on page 592.

4. After it is created, a Sun Angle cannot be rotated; but it can be moved as well as resized using its edit handles. Shadows are not affected. Multiple Sun Angles can be created, each with different specifications; however, only one can be used as a light source in a given 3D view. If more than one Sun Angle is present, specify the one to use in the current view in the Adjust Sunlight dialog. See “Adjust Sunlight Dialog” on page 594.

Sun Angles can display their date and time in plan view and can also produce sun shadow polylines in plan view. Both Sun Angles and their shadows are on the “Sun Angles & Shadows” layer.

Sun Shadows

Sun Shadows allow the program to produce shadows cast by a building that reflect the exact position of the sun in the sky in a particular location and at a specific date and time. This position and time information is specified in the Sun Angle Specification dialog; the date format is derived from your operating system settings. See “Earth Data Panel” on page 592 and “Region and Language Settings” on page 58.

In plan view, sun shadows are represented by polylines filled with a hatch pattern. If a Terrain Perimeter is present, the shape of a sun shadow polyline is affected by changes in terrain height. If no Terrain Perimeter exists, sun shadows fall on an imaginary plane at a height of zero, the default height for Floor 1. Sun shadows rebuild whenever the terrain is rebuilt. See “Build Terrain” on page 639.

No sun shadow generates if the sun is below the horizon or if it is so low on the horizon that the shadow would be extremely long.

Multiple Sun Angles can be placed in the same plan to allow the simultaneous display of shadows cast at different times in plan view. Only one should be turned on in 3D views at any given time, however.

To generate the sun shadows associated with a particular Sun Angle, select it and click the Make Shadow edit button or click the Make Shadow button in the Sun Angle Specification dialog. See “Lighting Data Panel” on page 593.

There are several ways to delete a sun shadow polyline:
- In plan view, select and delete the defining polyline.
- In plan view, select and delete the Sun Angle arrow.

Specify different line colors and/or styles for shadows cast by multiple Sun Angles on the Line Style and Fill Style panels of the Sun Angle Specification dialog.

Note: Sun Angle calculations do not adjust for elevation. They are based on formulas published by the United States Naval Observatory and have limited accuracy as documented by the USNO.
• In plan view, select the Sun Angle arrow and click the Delete Shadow edit button.
• In the Sun Angle Specification dialog, click the Delete Shadow button. See “Earth Data Panel” on page 592.

Sun Angle Specification Dialog

Select CAD > Lines > Sun Angle, then click in plan view to open the Sun Angle Specification dialog and create a new Sun Angle. See “Sun Angles and Shadows” on page 590.

To open the Sun Angle Specification dialog for an existing Sun Angle, select it and click the Open Object edit button. This dialog can also be accessed by clicking the Edit button in Adjust Sunlight dialog. See “Adjust Sunlight Dialog” on page 594.

Earth Data Panel

The settings on the EARTH DATA panel let you establish exactly where your plan’s building site is located, and exactly when the sun’s light should be calculated. This information allows the program to generate sunlight and sun shadows with accuracy.

1 The Solar Angles display for reference and may update as changes are made to the settings on this panel.
• The Solar Altitude is the angle of the sun above the horizontal plane, in degrees.
• The Solar Direction is the angle between true North and the sun’s direction. This is the angle the Sun Angle arrow points in plan view relative to the direction of North. See “North Pointer” on page 590.

2 Specify the Location of the selected Sun Angle. The initial location can be set in the Preferences dialog. See “CAD Panel” on page 73.
• Specify the Latitude, which is measured either North or South of the equator, depending on which radio button you select.
• Specify the Longitude, which is measured either East or West of the Greenwich meridian, depending on which radio button you select.

3 Specify the Date and Time of the selected Sun Angle. The initial time zone can be set in the Preferences dialog.
• Specify a Date for the selected Sun Angle. Select a month from the first drop-down list, a day from the second, and a year from the third.
• Specify a Time for the selected Sun Angle. Select an hour from the first drop-down list; minutes in 15 minute increments can be selected from the second list.
• If you want the Sun Angle to observe Daylight Savings Time, check this box.
• Specify the Time Zone that the building site is located in.

4 Specify the Plan View Display of the selected Sun Angle.
• Specify the Length of Plan Symbol, which is the length of the Sun Angle arrow in plan view.
• Check Show Date on Sun Angle to have the date and time display on the Sun Angle arrow in plan view. This label uses the Text Style assigned to the “Sun Angle & Shadows” layer. See “Text Styles” on page 283.
• Check Auto Rebuild Terrain to rebuild the terrain automatically whenever you create a sun shadow. If this is unchecked and you regenerate sun shadows, the program will prompt you to rebuild the terrain. See “Building the Terrain” on page 647.

When you use the Build Terrain command in plan view, all sun shadows in the plan are automatically updated.
• Click the Make Shadow button to create or regenerate the sun shadow in plan view. See “Sun Shadows” on page 591.
• Click the Delete Shadow button to remove the sun shadow from plan view.
• Check Always Update to have the program update the selected Sun Angle’s shadow whenever any of the defining information is changed. When this is checked, the program may be slower when changes are made in this dialog.
• If Always Update is unchecked and you make changes in this dialog, click the Make Shadow button to generate a new shadow.

Note that the Make Shadow option does not affect 3D views. See “Shadows” on page 583.

Lighting Data Panel
A Sun Angle can be used as a light source in 3D views. The settings on the LIGHTING DATA panel control attributes of the sunlight associated with the selected Sun Angle.

The settings defined on the LIGHTING DATA panel do not affect the sun shadow in plan view: they only affect 3D views in which lighting and shadows can display.

• Check Casts Shadows to have this light source cast shadows. These shadows are similar to the shadow shown in plan view, but may render differently based on the presence of other light sources.
• Use the Intensity slider bar or text field to define the relative strength of the light source. The time of day as set on the EARTH DATA panel does not affect how the Sun Angle renders as a light source, but this does.
• Click the Color bar to select a color for the sunlight associated with the selected Sun Angle. See “Select Color Dialog” on page 117.
Line Style Panel

For information about the LINE STYLE panel, see "Line Style Panel" on page 169.

Fill Style Panel

The settings on the FILL STYLE panel control the appearance of the selected Sun Angle’s shadow in plan view. For information about these settings, see “Fill Style Specification Dialog” on page 115.

Arrow Panel

For information about the settings on the ARROW panel, see "Arrow Panel" on page 171.

Adjust Sunlight Dialog

The Adjust Sunlight dialog allows you to control the intensity, direction and color of the Generic Sun light source in the currently active 3D view or to select a Sun Angle to serve as the source of sunlight in the currently active view. See “Generic Sunlight” on page 586.

The settings in this dialog are view specific. Any changes made to them affect the sun in the currently active 3D view only. Other 3D views can have their own unique settings.

The initial sunlight attributes used in a newly created camera are set in the Sunlight Defaults dialog. See “Defaults and 3D Preferences” on page 558.

There are three ways to open the Adjust Sunlight dialog when a 3D view is active:

• Select 3D> Lighting> Adjust Sunlight.
• Click the Adjust Sunlight button.
• Right-click in an empty space in the background area, then select Adjust Sunlight from the contextual menu.

Select Use Generic Sun to represent the sun in the currently active 3D view using the settings that follow.

- Use the Intensity slider bar or text field to control how bright the Generic Sun light appears.
- Click the Color bar to define the color of the light being modeled. Colored sunlight may be used to achieve special lighting effects, but may alter the appearance of your material colors and textures.
- Check Sun Follows Camera to adjust the position of the Generic Sun so that it is always behind the camera, illuminating surfaces in the view. When this is checked, the Tilt and Direction Angle settings that follow are disabled.

Note: If Use Generated Sky is in use as the backdrop in the current view and Sun Follows Camera is checked, the Generated Sky will not update if the camera is moved.

- Specify the Tilt Angle, which is the angle of the sunlight with respect to the horizon. A value of 90° means that the light points straight up, while a value of -90° means that the light points straight down. 0° is parallel to the horizon.
- Specify the Direction Angle, which is the direction that the sunlight points toward. 0° is measured horizontally on screen, pointing to the right. Positive values rotate in a counter-clockwise direction from there, while negative values rotate clockwise.
- Click the Reset to Defaults button to restore the settings set in the Sunlight Defaults dialog in the current view.
- In the Sunlight Defaults dialog, the Restore Initial Settings button is available instead. Click this to reset the options in that dialog to the originally installed settings.

Select Use Sun Angle to represent the sun using a light source defined by a Sun Angle. See “Sun Angles and Shadows” on page 590.
• Select a Sun Angle from the drop-down list to serve as the source of sunlight in the currently active 3D view. If no Sun Angle is present, the Generic Sun is used.

• Click the Edit button to open the **Sun Angle Specification** dialog for the selected Sun Angle.

**Rendering Techniques**

Any camera view, cross section/elevation view, or overview can be generated using one of several Rendering Techniques to produce views for a range of different purposes: from detail drawings to artistic presentation views. When a 3D view is active, select **3D> Rendering Techniques** to access these tools.

There are two ways to create a view using a particular Rendering Technique:

• Create a 3D view, then select the desired rendering technique from the menu.

• Select the desired rendering technique in the **Camera Defaults** dialog, then create a 3D view. See “Camera Defaults Dialogs” on page 558.

Once a view is created, the effects of the selected rendering technique can be adjusted in the **Rendering Technique Options** dialog. See “Rendering Technique Options” on page 596.

If a camera view is saved, its Rendering Technique settings are saved, as well. See “Saving and Printing 3D Views” on page 574.

---

### Standard Rendering

**Standard** rendering is a photo-realistic technique that represents materials using textures, models lighting, and can also display shadows. Surface edge lines are not drawn and no special colors or effects are applied.

By default, the Generic Sun light color is pure white, which has the least effect on the appearance of material colors and textures. See “Materials” on page 539.

---

The Watercolor technique requires more time to generate than other Rendering Techniques. To save time, adjust the camera's perspective before using one of these techniques. See “Editing 3D Views” on page 571.

---

### Vector View

In Vector Views, surface edge lines are drawn and pattern lines and colors are used to represent materials while textures are not. Shadows are supported, and when in use a single light source is used to produce them. Shading Contrast can be applied to surfaces, but other special colors or effects are not.

---

### Glass House

**Glass House** rendering uses different shades of a single color to display the model with surface edge lines and semi-transparent surfaces. Lighting and shadows are not modeled, and materials are not represented, so neither pattern lines nor textures are used.
In plan view, the camera symbol for a view using the **Glass House** technique displays a G in its center.

### Technical Illustration

**Technical Illustration** rendering draws surface edge and pattern lines, and uses shades of two colors, Warm and Cool. The warm shade is applied to surfaces that face the light source in the view, and the cool shade, to surfaces that face away from it.

Only one light source is used: the light with the highest Intensity found in the room containing the camera. In exterior views, this light is always the Generic Sun. If no lights are on, a fallback light is used. Lighting is modeled as non-photorealistic, stylized highlights and shadows are supported. See “Lighting” on page 585.

In plan view, the camera symbol for a view using the **Technical Illustration** technique displays a T in its center.

### Watercolor

**Watercolor** rendering approximates the effects of watercolor painting such as pigment pooling and flow. It uses textures to represent materials and models lighting and shadows.

In plan view, the camera symbol for a view using the **Watercolor** technique displays a W in its center.

Note: In some plans, the Watercolor techniques may take a considerable amount of time. You can press the Esc key to cancel the rendering.

### Physically Based

**Physically Based** rendering is similar to the photo-realistic Standard technique: it represents materials using textures, does not draw surface edge lines, models lighting, and can display shadows.

Physically Based rendering models material properties and light propagation more accurately than other rendering techniques and is best used when a focus on lighting and finish materials is the goal.

In plan view, the camera symbol for a view using the **Physically Based** technique displays a Ph in its center.

### Rendering Technique Options

The settings in the **Rendering Technique Options** dialog allow you to control the specific effects of each rendering technique on an active 3D view. To access this dialog, create a camera view cross section/elevation view, or overview and select 3D > **Rendering Techniques** > **Technique Options**.

The **Rendering Technique Options** dialog can also be accessed by double-clicking the **Rendering Techniques** parent button.
The settings in the Rendering Technique Defaults dialog are the same as those in this dialog, but control the initial settings of each technique when it is first applied.

In the Rendering Technique Options dialog, select a technique from the list on the left to make its options active on the right. When this dialog is first opened, the technique currently used by the view is selected.

As changes are made in the Rendering Technique Options dialog, the 3D view automatically updates to reflect those changes for all techniques except Watercolor. To update views using these techniques, which take more time to draw than the others, click the Update button in the dialog.

When a 3D view is saved, its Rendering Technique Options settings are saved, as well. See “Saving 3D Views” on page 575.

**Standard Panel**

The active 3D view immediately updates to reflect any changes made to the Rendering Technique Options for Standard renderings.

There are a variety of other tools that affect the appearance of Standard rendered views, as well. See “Displaying 3D Views” on page 565.

Specify the amount of Ambient light to use in different situations in Standard, and Watercolor renderings. See “Ambient Lighting and Occlusion” on page 586.

- **Interior Ambient** affects interior views.
- **Daytime Ambient** affects exterior views.
- **Nighttime Ambient** affects nighttime exterior views.
- Check **Opaque Window Glass** to make the glass in windows and doors opaque. When unchecked, door and window glass is transparent.

- When **Use Backdrop** is checked, the backdrop image specified for this view is used. When unchecked, the specified Backdrop Color is used instead. See “3D Backdrops” on page 614.
- Click **Reset to Defaults** to apply the Standard settings defined in the Rendering Technique Defaults dialog.
- In the Rendering Technique Defaults dialog, the **Restore Initial Settings** button is available instead. Click this to reset the options on this panel to the originally installed settings.

**Vector View Panel**

The active 3D view immediately updates to reflect any changes made to the Rendering Technique Options for Vector Views.

There are a variety of other tools that affect the appearance of Vector Views. See “Displaying 3D Views” on page 565.

Additional settings that affect the appearance of Vector Views can be found in the 3D View Defaults dialog. See “3D View Defaults Dialog” on page 560.
Check Opaque Window Glass to make the glass in windows and doors opaque. When unchecked, door and window glass is transparent.

Check Apply Shading Contrast to use different levels of shading on surfaces oriented at different angles to the camera. When unchecked, unmodified material Colors are shown on all surfaces. Each material’s Shading Contrast can be set individually. See “Pattern Panel” on page 550.

Check Use Backdrop to use the backdrop image specified for this view. When unchecked, the specified Backdrop Color is used instead.

Click Reset to Defaults to apply the Vector View settings defined in the Rendering Technique Defaults dialog.

In the Rendering Technique Defaults dialog, the Restore Initial Settings button is available instead. Click this to reset the options on this panel to the originally installed settings.

Glass House Panel

The active 3D view immediately updates to reflect any changes made to the Rendering Technique Options settings for Glass House renderings.

Click the Color bar to select a color for the semi-transparent surfaces and lines in a Glass House view. See “Select Color Dialog” on page 117.

Specify the Transparency of the surfaces in Glass House view. For example, to create a wireframe line drawing of your structure, turn transparency to full and minimize line thickness.

Specify the Line Thickness of surface lines in Glass House view.

When Use Backdrop is checked, the backdrop image specified for this view is used. When unchecked, the specified Backdrop Color is used instead. See “3D Backdrops” on page 614.

Click Reset to Defaults to apply the Glass House settings defined in the Rendering Technique Defaults dialog.

In the Rendering Technique Defaults dialog, the Restore Initial Settings button is available instead. Click this to reset the options on this panel to the originally installed settings.

Technical Illustration Panel

The active 3D view immediately updates to reflect any changes made to the Rendering Technique Options settings for Technical Illustration renderings.
• Click the **Color** bar to select a **Warm Color** for surfaces that face the light source and a **Cool Color** for surfaces that face away from the light.

• Specify the **Warm Blend**, which is the degree to which the selected Warm Color is blended with original colors on well-lit surfaces in the view.

• Specify the **Cool Blend**, which is the degree to which the selected Cool Color is blended with original colors on shaded surfaces in the view.

• Specify the **Line Thickness** of all surface edge and pattern lines in the view.

• Check **Opaque Window Glass** to make the glass in windows and doors opaque. When unchecked, door and window glass is transparent.

• Check **Use Backdrop** to use the backdrop image specified for this view. When unchecked, the specified Backdrop Color is used.

• Click **Reset to Defaults** to apply the Technical Illustration settings defined in the **Rendering Technique Defaults** dialog.

• In the **Rendering Technique Defaults** dialog, the **Restore Initial Settings** button is available instead. Click this to reset the options on this panel to the originally installed settings.

**Watercolor Panel**

In order for the active 3D view to reflect changes made to the Rendering Technique Options settings for Watercolor renderings,

• Specify the **Smooth Amount**, which is the degree to which details are removed from the original view.

• Specify the **Paint Contrast**, which determines the extent to which variations in pigment color are used.

• Specify the **Turbulence Strength**, which produces “pooling”, or variations in the strength of pigment colors.

• Specify the **Turbulence Scale**, which controls the size of the areas of pooling.
- Specify the **Pigment Settling Strength**, which is creates the appearance of pigment settling into low areas in paper.
- Specify the **Edge Strength**, which is how well-defined surface edge lines are.
- Check **Opaque Window Glass** to make the glass in windows and doors opaque. When unchecked, door and window glass is transparent.
- When **Use Backdrop** is checked, the backdrop image specified for this view is used. When unchecked, the specified Backdrop Color is used instead.
- Click **Reset to Defaults** to apply the Watercolor settings defined in the Rendering Technique Defaults dialog.
- In the **Rendering Technique Defaults** dialog, the **Restore Initial Settings** button is available instead. Click this to reset the options on this panel to the originally installed settings.
- Click **Update View** to apply these settings to the active 3D view.

**Physically Based Panel**

The active 3D view immediately updates to reflect any changes made to the Rendering Technique Options for Physically Based renderings.

There are a variety of other tools that affect the appearance of Physically Based rendered views, as well. See “Rendering Tips” on page 583.

1. Specify the **Camera Exposure**, which is the amount of light in the scene that is captured by the camera. A low value produces a darker view; too high a value can make the scene look washed out.
2. If you find that light and/or color is reflected too strongly onto some surfaces in a view, check **Improve Lighting Quality** to reduce this effect. This setting can result in slowness and should remain unchecked in most circumstances.
3. You can adjust the **Hue**, **Saturation**, and **Brightness** of the view, if needed.
- Check **Use Backdrop** to use the backdrop image specified for this view. When unchecked, the specified Backdrop Color is used instead.
- Click **Reset to Defaults** to apply the Physically Based settings defined in the **Rendering Technique Defaults** dialog.
Chapter 32: Pictures, Images, and Walkthroughs

Home Designer Pro uses picture files in a variety of ways to enhance your drawings.

The Library Browser contains images of real world objects like plants and vehicles that can display in 3D views.

Picture files can also be imported into Home Designer Pro and shown in most views.

You can save any view using a variety of picture file formats. In addition, Home Designer Pro allows you to create virtual tour videos that can be played back later and shared with others.

Chapter Contents

- Picture Files vs Pictures and Image Objects
- Images
- Displaying Images
- Editing Images
- Image Specification Dialog
- Pictures
- Picture File Box Specification Dialog
- Metafiles
- Metafile Box Specification Dialog
- PDF Files
- PDF Box Specification Dialog
- Displaying Pictures, Metafiles, and PDF Boxes
- Editing Pictures, Metafiles, and PDF Boxes
- 3D Backdrops
- Backdrop Specification Dialog
- Walkthrough Paths
- Recording a Walkthrough
- Walkthrough Path Specification Dialog
**Picture Files vs Pictures and Image Objects**

In common computer language, picture files, pictures and images are more or less synonymous. In the Home Designer Pro environment, however, there are some notable differences between these terms.

In Home Designer Pro, a two dimensional image file such as a .bmp, .jpg, .gif, or .png is referred to as a picture file or an image file. Examples of these files are saved on most computers and can be opened in a variety of applications.

A Picture, on the other hand, is a file that has been imported into the program. Pictures can be imported into plan view, cross section/elevation views, and layout pages. They are two-dimensional only and do not display in camera views or overviews.

An Image object is also based on a picture file, but it does display in both 2D and 3D views. Images have 3D width and height data associated with them, as well as a 2D symbol which displays in plan view.

Picture files have additional uses in Home Designer Pro, as well:

- Backdrops are picture files that display behind 3D views. See “3D Backdrops” on page 614.
- Textures are picture files that realistically represent materials in 3D views. See “About Materials” on page 540.

---

**Images**

[Image] Images add realistic detail to 3D views without adding many surfaces to the model. For example, a tree image with a single surface can be used instead of a tree symbol with thousands, dramatically improving realism without compromising drawing time.

There are two types of Images in Home Designer Pro:

- **Images** rotate so that they always face the camera in 3D views.
- **Billboard Images** do not rotate to face the camera. An example of when this may be useful is an image of a trellis, which might look awkward when facing a camera from a side view.

**Placing Images**

A selection of Images are available in the Library Browser. Select one and click in a plan view, camera view or overview to place it. See “Placing Library Objects” on page 521.

**Creating Images**

Custom Images can be added to the User Catalog in the library, as well as created in plan files. Home Designer Pro can use any image with a *.bmp, *.jpg, *.png, *.gif, or *.tif extension. Generally, .png files work best as Images because this format has good compression and allows for the Image to contain transparency information.

To create an Image in plan view

2. On the IMAGE panel:
   - Click the Browse button to select a picture file on your computer or enter the path to a valid picture file in the Image File field. If the file is not located in the Home Designer Pro 2021 Data folder, a copy of the file will be created at Home Designer Pro 2021 Data\Images\My Images and the Image object will reference that copy. See “Home Designer Pro Data” on page 40.
   - Select a 2D Plan Symbol from the drop-down list or click the Library button and select a symbol from the library. The selected symbol represents the image in plan view. See “Image Panel” on page 604.
   - Specify the Size and Position of the image.
3. Specify transparency information on the Transparency panel.
4. Click OK to close the Image Specification dialog.
5. Click to place the new Image in plan view.

To create an image in the Library Browser

1. In the Library Browser, right-click on an unlocked folder.
2. Select New> Image from the contextual menu to open the Image Specification dialog.

3. Browse to the image file you want to add and select your other options. See “Image Specification Dialog” on page 604.

4. Once created, the image is listed in the library folder that you right-clicked on. Size and other data is saved.

**Using Paste Image**

You can also import an image by first copying it to the system clipboard, then navigating to a Home Designer Pro window and selecting Edit> Paste> Paste from the menu. See “Paste Special” on page 106.

---

### Displaying Images

The display of images in floor plan and 3D views is controlled in the **Layer Display Options** dialog. See “Layer Attributes” on page 110.

Images are placed on the “Images” layer.

#### In Plan View

In plan view, most images are represented by an Image symbol. You can specify a different symbol to represent an image if you wish. See “Image Specification Dialog” on page 604.

#### In 3D Views

The actual picture associated with an image object can be seen in 3D views, as can any transparency data associated it. See “Image Specification Dialog” on page 604.

Images can be set to either rotate so that they always face the camera or remain stationary, like billboards. See “Images” on page 602.

#### In Layout Views

Images can be included in all views sent to layout with the exception of those using Plot Lines. See “Plot Line Views” on page 700.

---

### Editing Images

Images can be selected in 2D and 3D views and edited using the edit handles, edit tools and the Image Specification dialog.

#### Using the Mouse

In plan view, a selected image can be rotated, moved, and resized. In 3D views, a selected image only has two edit handles: the circular Resize handle and square Move handle.

When an image is resized using the edit handle, its aspect ratio is retained and 2D symbol resizes proportionally.

#### Using the Edit Toolbar

A selected image or images can be edited in a variety of ways using the buttons on the edit toolbar. See “The Edit Toolbar” on page 29.
Image Specification Dialog

Select an image and click the **Open Object** edit button to open the **Image Specification** dialog.

### Image Panel

**General** information about the selected Image can be specified here.

- The **Image File** associated with the Image can be specified. Click **Browse** to choose a file saved on your computer or type the file’s full pathname in the text field.
- Select a **2D Plan Symbol** from the drop-down list to represent the Image in plan view. See “Displaying Images” on page 603.

**Specify the Size/Elevation of the image as it displays in 3D views.**

- Enter a **Height** for the selected image.
- Enter a **Width** for the selected image.
- Uncheck **Retain Aspect Ratio of X** if you would like to modify the Height or Width without affecting the other value. If you do this, the image may appear distorted. This check box does not affect editing performed outside of this dialog and is an action rather than a state: the next time you open this dialog, it will be checked.
- Click **Reset Original Aspect Ratio of** to reset the image’s original aspect ratio and remove any distortion caused by resizing.
- Select the **Elevation Reference** from the drop-down list. This determines where the next two settings are measured from and also affects their setting labels.
- Specify the height to **Top**, measured from the selected Elevation Reference to the top edge of the image.
- Specify the height to **Bottom**, measured from the selected Elevation Reference to the bottom edge of the image.
- Specify the location of the **X and Y Coordinates** of the selected image’s **Center Point**.
Options -

- Check Reverse Image to reflect the appearance of the image about an imaginary vertical line through its center.
- Check Image Always Faces Camera to prevent the image from rotating to face the camera in 3D views. This box is unchecked for Billboard Images. See “Images” on page 602.

Any Copyright information associated with the selected Image will be stated here.

A preview of the selected Image displays here. The Glass House Rendering Techniques is not available for images. See “Dialog Preview Panes” on page 32.

Transparency Panel

The settings on the TRANSPARENCY panel let you specify portions of the selected image as transparent.

- Click the Use Transparency From The Image File radio button to use any transparency data included in the image file.
- Click the Use Custom Transparency Color radio button to specify a color in the image to represent the transparency and enable the settings below.
- Click the Color bar to select a color in the Select Color dialog. See “Select Color Dialog” on page 117.
- Use the slide bar or enter a value to specify a level of Tolerance to be applied to colors that are almost the same as the specified transparency color.
- Move your pointer over the small preview image below. The pointer changes to an eyedropper and a magnified preview displays to its right. Click to select the color of the pixel your pointer is over as the Transparency color. The selected color displays in the Color bar, below.
- A magnified preview of the area in the preview image above displays here, allowing for accurate pixel selection.

The Transparency Color

If the portion of the image file that you wish to use contains the transparency color, that part of the image also becomes transparent. If this happens, the image may appear partially disintegrated.

You may need to experiment to find the best transparency color and tolerance for the image.

Fill Style Panel

The settings on the FILL STYLE panel affect the appearance of the selected image’s 2D Plan Symbol in plan view, provided that the selected symbol is a
closed shape. For information about these settings, see “Fill Style Specification Dialog” on page 115.

Components Panel

The information on the COMPONENTS panel can be used in the materials list. For more information, see “Components Panel” on page 692.

Pictures

A variety of picture file types can be imported into and exported out of Home Designer Pro.

Metafiles are also types of picture files that can be imported and exported. See “Metafiles” on page 608.

Exporting Pictures

There are several ways to save a picture of a view in Home Designer Pro:

Using the Export Picture tool is similar to creating a screen capture of everything in the current view window. Pictures can be saved in various file formats and used in other applications.

Export Picture is best suited for rendered views. When exporting a line-based view, best results can be achieved by saving it as a Metafile. See “To export a metafile” on page 608.

Use the Print Image tool to either print or save the current view as a PDF file. See “Print Image Dialog” on page 721.

To export a picture

1. Open the view that you would like to export as a picture file.
2. Zoom, pan or otherwise adjust the view so that what you see on screen suits your needs. See “Displaying 3D Views” on page 565.
3. Select File> Export> Export Picture (BMP, JPG, PNG) to open the Export Picture dialog, below, and specify the desired image size and other properties.
4. In the Export Picture File dialog, which opens next, give the file to be exported a name, file type, and location. See “Exporting Files” on page 44.

Export Picture Dialog

Specify the exported file’s Image Size in pixels or inches (mm).

- Check Use Active Window Size to export the picture at the same size as the active view window. The window’s Width and Height are described below. In camera views only, these values can be changed, in which case this box becomes unchecked automatically.
- Select either Pixels or Units as the method by which the picture’s dimensions are measured.
- Specify the Width and Height of the image. The initial values correspond to the view window’s size. In plan view, they display for reference only.
- Specify the Resolution of the image. Select Dots/Inch or Dots/mm from the drop-down list.
- Uncheck Retain Aspect Ratio if you would like to modify the Height or Width without affecting the other value. Leave this box checked to prevent the image from becoming distorted.

Check Transparent Background to produce alpha transparency in the spaces between all objects that can be seen in the current view. Transparency associated with Fill and Text Styles is retained, as well. Note that the .png and .tif file types support transparency, while the .jpg and .bmp file types do not.
**Importing Pictures**

Pictures can be imported into and displayed in plan view, cross section/elevation views, and layout pages. Pictures do not display in camera views or overviews. See “Displaying Pictures, Metafiles, and PDF Boxes” on page 612.

There are several ways to import a Picture into Home Designer Pro:

- Select **File > Import > Import Picture (BMP, JPG, PNG)** to open the Import Picture File dialog, which is a typical open file dialog. See “Importing Files” on page 47.
- Click and drag an image file from an operating system window into the Home Designer Pro window.
- In any application, copy an image to the system clipboard, then select **Edit > Paste > Paste** from the Home Designer Pro menu in an eligible view window. See “Paste Special” on page 106.

An imported picture is placed in the center of the current view. Once imported, pictures can be selected and edited. See “Editing Pictures, Metafiles, and PDF Boxes” on page 613.

---

**Picture File Box Specification Dialog**

Select an imported picture file and click the Open Object edit button to open the **Picture File Box Specification** dialog.

1. Information about the selected **Picture File** can be specified here.

2. The **FileName** of the picture file displays here. Type a new pathname to change the picture assigned to this box.

- Click the **Browse** button to choose a new picture file or to relink to a missing file.
- Check **Save in Plan** to embed the picture in the plan or layout file. If a picture file is embedded, you do not need to include it when sending the plan or layout to a different computer.
- Click the radio button beside either **PNG** or **JPEG** to specify how to save the embedded picture data. Pictures that were originally .jpg files use the JPEG option by default; those that were .gif or .png files use the PNG option by default.
- Specify the picture’s **Quality %** when JPEG is selected. A lower value results in better compression, while a higher value reduces data loss.

Note: PNG is the better option for pictures of line drawings, text, or large areas of a single color. JPEG is the better option for photos.

**Center/Orientation** - Specify the position of the selected Picture’s center point and its angle. See “3D Drafting” on page 25.

- Specify the **X** and **Y Positions** of the picture box’s center point relative to the absolute origin.
- Specify the **Angle** of the picture box relative to a horizontal line pointing towards the right hand side of the screen.

**3** Specify the **Size** of the picture in plan inches (mm).

- Specify the **Width** of the picture box. The original width in pixels displays to the right.
- Specify the **Height** of the picture box. The original height in pixels displays to the right.

- Uncheck **Retain Aspect Ratio of X** if you would like to modify the Height or Width without affecting the other value. If you do this, the picture may appear distorted.

This check box does not affect editing performed outside of this dialog and is an action rather than a state: the next time you open this dialog, it will be checked.

- **Reset Original Aspect Ratio** - If the aspect ratio is changed, you can click this button to return the picture to its original aspect ratio.
- Check **Reset Cropping** to fill the extents of the selected Picture box with the image associated with it. If the box has been resized, the image may appear distorted. See “Editing Pictures, Metafiles, and PDF Boxes” on page 613.

A variety of **Display Options** are available.

- Check **Black and White Dither** to dither the selected picture file. Dithering creates a two tone effect that may produce better results when printed.
- Check **Grayscale** to replace the color in the selected picture with shades of gray.
- Check **Reflect** to reverse the image.
- Enter a degree of **Brightness** from 1 - 100%.
- Enter a degree of **Contrast** from 1 - 100%.

**Line Style Panel**

The settings on this panel are similar to those on the **LINE STYLE** panel in numerous other dialogs, with one exception: check **Show Outline** to turn on the display of the picture’s border polyline. For more information, see “Line Style Panel” on page 169.

### Metafiles

A metafile (.emf, .wmf) is a special picture file format made up of vectors (lines) that allow the image to be rescaled without loss of quality. High resolution pictures of line-based views can be exported as a metafile.

Note: Metafiles are not supported in Mac operating systems and cannot be imported or exported in Mac versions of the software.

### Exporting Metafiles

An enhanced metafile (.emf) can be exported from any line-based view: that is, from plan view and 3D Vector Views.

Only objects that display on screen are included in an exported metafile.

**To export a metafile**

1. Accurately position the view on screen.
2. Select **File > Export > Export Metafile (EMF)**.

3. Drag a marquee from corner to corner, defining the area that will included in the metafile.

4. Release the mouse button to open the **Export Metafile** dialog, which is a typical Save As dialog. See “Saving, Exporting, and Backing Up Files” on page 43.

5. When you click the Save button, the **Metafile Size** dialog opens.

6. Specify the desired **Width** or **Height** of the metafile. When one value is edited, the other changes to maintain its aspect ratio.

   Specify, too, the desired **Dots Per Inch (DPI)** for the metafile. A larger value results in a higher quality metafile, but also a larger file size.

7. When a metafile is exported from a 3D Vector View, you can also specify the printed thickness of lines in the view. To increase the printing line weight, type a larger number in the **Use Line Weight** field. See “Vector View” on page 595.

   Metafiles exported from plan view use the line weights defined in the **Layer Display Options** dialog. See “Layer Display Options Dialog” on page 111.

**Importing Metafiles**

Metafiles can be imported into and displayed in plan view, cross section/elevation views, and layout pages. Metafiles do not display in camera views or overviews. See “Displaying Pictures, Metafiles, and PDF Boxes” on page 612.

There are two ways to import a metafile into Home Designer Pro:

- Select **File > Import > Import Metafile (EMF, WMF)** to open the **Import Metafile** dialog, which is a typical open file dialog. See “Importing Files” on page 47.

- You can also click and drag a metafile file from an operating system window into the Home Designer Pro window to import it.

   An imported metafile is placed in the center of the current view. Once imported, metafiles can be selected and edited. See “Editing Pictures, Metafiles, and PDF Boxes” on page 613.

---

**Metafile Box Specification Dialog**

Select an imported metafile and click the **Open Object** edit button to open the **Metafile Box Specification** dialog.
General Panel

1 Center/Orientation - Specify the position of the selected metafile’s center point and its angle. See “3D Drafting” on page 25.
   - Specify the X and Y Position relative to the absolute origin.
   - Specify the Angle of the metafile box relative to a horizontal line pointing towards the right hand side of the screen.

2 Specify the Size of the metafile in plan inches (mm).
   - Specify the Width of the metafile box.
   - Specify the Height of the metafile box.
   - Uncheck Retain Aspect Ratio of X if you would like to modify the Height or Width without affecting the other value. If you do this, the metafile may appear distorted. This check box does not affect editing performed outside of this dialog and is an action rather than a state: the next time you open this dialog, it will be checked.

   - Reset Original Aspect Ratio - If the aspect ratio is changed, you can click this button to return the picture to its original aspect ratio.
   - Check Reset Cropping to fill the extents of the selected metafile box with the image associated with it. If the box has been resized, the image may appear distorted. See “Editing Pictures, Metafiles, and PDF Boxes” on page 613.

Line Style Panel

The settings on this panel are similar to those on the LINE STYLE panel in numerous other dialogs, with one exception. Check Show Outline to turn on the display of the picture’s border polyline. For more information, see “Line Style Panel” on page 169.

PDF Files

Portable Document Format (.pdf) files are a special type of file that can be viewed on nearly any computer and can include a wide variety of visual information.

Printing and Exporting PDF Files

You can save any view as a 2D .pdf file by selecting File> Export> Export PDF. This will open either the Print View or Print Image dialog, depending on the view type.

You can also save any view as a 2D .pdf file by selecting “Chief Architect Save as PDF” as the Destination printer Name in either of these dialogs. See “Printing to a PDF File” on page 715.

Importing PDF Files

To import a .pdf file, select File> Import> Import PDF.
You can also import a .pdf file by dragging it from an operating system window into the Home Designer Pro window.

You can import .pdf files into Home Designer Pro in plan view, cross section/elevation views, and in layout. Once imported, PDF boxes behave and can be edited similar to imported pictures and metafiles. See “Editing Pictures, Metafiles, and PDF Boxes” on page 613.

Some .pdf files can contain both 2D and 3D information; however, Home Designer Pro can only support 2D data in an imported .pdf file. When a 3D .pdf file is imported, it may display text, a static image of the 3D model, or it may not import at all.

Note: Importing large, or multiple, .pdf files into a plan or layout file can result in program slowness.

PDF Box Specification Dialog

Select an imported PDF box and click the Open Object edit button to open the PDF Box Specification dialog.
General Panel

1. The full Filename of the .pdf file displays here. Type a new name to associate the selected PDF box with a different .pdf file.
   - Click the Browse button to choose a new .pdf file or to relink to a missing file.
   - Specify the Page of the .pdf file that displays in the selected PDF box.
   - Check Save in Plan to embed the .pdf in the plan or layout file. If a .pdf is embedded in a file, you do not need to include it when sending the file to a different computer. If the .pdf file is modified, however, the PDF box in Home Designer Pro will only update automatically if this is unchecked.

2. Center/Orientation - Specify the position of the selected PDF box’s center point and its angle. See “3D Drafting” on page 25.
   - Specify the X and Y Positions of the PDF box’s center point relative to the absolute origin.
   - Specify the Angle of the PDF box relative to an imaginary horizontal line pointing towards the right hand side of the view window.

3. Specify the Size of the PDF box in plan inches (mm).
   - Specify the Width of the PDF box.
   - Specify the Height of the PDF box.
   - Uncheck Retain Aspect Ratio of X if you would like to modify the Height or Width without affecting the other value. If you do this, the PDF box may appear distorted. This check box does not affect editing performed outside of this dialog and is an action rather than a state: the next time you open this dialog, it will be checked.

   - Reset Original Aspect Ratio - If the aspect ratio is changed, you can click this button to return the picture to its original aspect ratio.

   - Check Reset Cropping to fill the extents of the selected PDF box with the image associated with it. If the box has been resized, the image may appear distorted. See “Editing Pictures, Metafiles, and PDF Boxes” on page 613.

Line Style Panel

The settings on this panel are similar to those on the LINE STYLE panel in numerous other dialogs, with one exception: Check the Show Outline box to turn on the display of the PDF box’s border polyline.

Displaying Pictures, Metafiles, and PDF Boxes

The display of Pictures, Metafiles, and PDF Boxes is controlled in the Layer Display Options dialog. See “Layer Attributes” on page 110.
Pictures, Metafiles, and PDF Boxes are placed on the “CAD, Default” layer.

Pictures, Metafiles, and PDF Boxes can be imported into and displayed in plan view, cross section/elevation views, and layout pages. A Picture, Metafile, or PDF Box can only be seen in the view where it was imported and cannot be imported into a camera view or overview.

**Drawing Groups**

Each object in a plan or layout file is included in a Drawing Group, which influences whether it displays in front of or behind other objects. By default, imported pictures and PDF Boxes are placed in the Back Group, and imported metafiles are placed in the same Drawing Group as CAD objects.

Once imported, the drawing order of pictures, metafiles, and PDF Boxes can be customized. See “Drawing Groups” on page 113.

**In Layout**

Pictures, metafiles, and PDF boxes are included when a view is sent to layout, and can also be imported directly onto a layout page. See “Pictures and Metafiles in Layout” on page 697.

---

**Editing Pictures, Metafiles, and PDF Boxes**

Pictures, Metafiles, and PDF Boxes can be selected and edited using the edit handles, the edit toolbar, and their specification dialogs.

**In the Specification Dialog**

Pictures, Metafiles, and PDF Boxes can be customized in their specification dialog. See:
- “Picture File Box Specification Dialog” on page 607
- “Metafile Box Specification Dialog” on page 609
- “PDF Box Specification Dialog” on page 611

**Using the Mouse**

Pictures, Metafiles, and PDF Boxes have edit handles similar to other box-based objects. See “Editing Box-Based Objects” on page 136.

- The corner Resize handles behave do not behave the same for Pictures, Metafiles, and PDF Boxes as they do for CAD boxes, however. If you drag a corner handle of one of these objects while the Default Edit Behavior is active, its contents will resize and height to width ratio will be retained.
- If you drag an Extend handle along a Picture, Metafile, or PDF Box’s edge, the contents of the box will not be resized. If you resize it larger, an empty space will be created between that edge and the contents; if you resize it smaller, the contents will be cropped.

**Using Dimensions**

Pictures, Metafiles, and PDF Boxes can be relocated relative to other objects with precision using dimensions.

To avoid changing the selected object’s aspect ratio, make sure you choose to move the entire object rather than the selected edge. See “Moving Objects Using Dimensions” on page 263.

**Using the Edit Tools**

A selected Picture, Metafile, or PDF Box can be edited in a variety of ways using the buttons on the edit toolbar. See “The Edit Toolbar” on page 29.

**Point to Point Resize**

A selected picture, metafile, or PDF box can be resized in either the X or Y direction with the **Point to Point Resize** edit tool.

**To use the Point to Point Resize tool**

1. Select a picture box, metafile box, or PDF box.
2. Click the **Point to Point Resize** edit button.
3. The mouse pointer displays the Point A icon . Click on the first of two points in the selected object’s box area that have a known distance between them.
4. An extension line extends from Point A to the mouse pointer, which now displays the Point B icon .
5. Click on the second of the two points with a known distance between them.

6. After you click on the second point, the **Point to Point Resize** dialog opens.

7. The current distance between the two points populates the text field. Enter a new dimension that matches the desired distance between the points.

8. When **Retain Aspect Ratio** is checked, the ratio between the selected object’s height and width is maintained when you click OK and the object is resized. When this is unchecked, the object may become distorted-looking.

9. Click **OK** to resize the picture, metafile, or pdf.

### Resize Factor

With a bit of calculation, an imported picture, metafile, or PDF box can be resized to scale using the **Transform/Replicate Object** dialog. Once resized, the information in the object box can be traced using Home Designer Pro’s drawing tools and then deleted.

#### To calculate the Resize Factor

1. Find two items in the imported object that are separated by a known horizontal or vertical distance, such as two walls or plot lines.

2. Draw parallel CAD lines on top of these two items. See “The CAD Drawing Tools” on page 162.

3. Find the distance between the CAD lines. See “The Dimension Tools” on page 257.

4. The Resize Factor for the image is the distance described in the picture divided by the distance between the CAD lines.

For example, if the items are supposed to be 10 feet apart on the picture, but the distance between the two CAD lines drawn on them is only 2 feet, you need to set the Resize Factor for the picture to 5. (10’ divided by 2’ equals 5). When the picture is 5 times the original size, the items on the picture are at the actual scale shown on the picture.

5. Select the picture and click the **Transform/Replicate Object** edit button.

6. In the **Transform/Replicate Object** dialog, select the **Resize Factor** check box.

7. Enter the Resize Factor calculated above, then click **OK**.

---

### 3D Backdrops

A backdrop is an image, typically of an exterior view, that displays in the background of 3D views to help place the model into a realistic setting and add a sense of perspective.

Backdrops automatically adjust to fit each view window, so they look best when they are created with a height to width ratio that is similar to the window you are working in.

#### Specifying a Backdrop Image

Backdrop images are view specific. You can select a backdrop image for a camera view from the library in either of two ways:

- In a 3D view, open the Library Browser. Select a Backdrop image, then move your mouse pointer
into the view window. Click anywhere in the view to apply the selected backdrop.

• Open the Camera Specification dialog, and on the BACKDROP panel, click the Select Backdrop button. See “Backdrop Panel” on page 578.

When a backdrop image is not applied, Home Designer Pro applies a background color instead. This color can be specified on the BACKDROP panel of the Camera Specification dialog, as well.

Spherical Panoramic Backdrops

Spherical Panoramic Backdrops are a special type of backdrop that wraps around the model in 3D views as though it were applied to a sphere surrounding it. It takes an image processing program or special camera to generate spherical panoramic backdrops.

If you have such a file, you can specify it as your Backdrop image, then check Spherical Panoramic Backdrop in the camera’s specification dialog.

The Use Generated Sky option produces a special Spherical Panoramic Backdrop that simulates a daytime sky using the Generic Sun or active Sun Angle data. See “Sun Angles and Shadows” on page 590.

Backdrop Defaults

By default, Home Designer Pro uses backdrop images in Perspective Full Cameras only. You can, however, specify which types of views use backdrops by default, and also select the default backdrop images for each, in the Camera Tools Defaults dialogs. See “Camera Defaults Dialogs” on page 558.

Similarly, backdrop images are only used by default in a few Rendering Techniques: Standard, Watercolor, and Physically Based. You can choose whether a backdrop is used in any technique in the Rendering Technique Options dialog. See “Rendering Technique Options” on page 596.

Adding New Backdrops

A new backdrop image can be created using a variety of graphic file formats and can be imported into Home Designer Pro in several ways:

• Select File> Import> Backdrop to open the Import Backdrop File dialog, which is similar to the Import Picture File dialog. See “Importing Pictures” on page 607.

• Right-click on the User Catalog and select New> Backdrop from the contextual menu.

• Copy and paste an image into Home Designer Pro. See “Copying and Pasting Objects” on page 104.
A preview of the selected image displays here.

Backdrop - Specify backdrop’s Name and the image file associated with it.

- Type a Name for the selected backdrop, to be used in the Library Browser and 3D View Defaults dialog.
- In the Location field, type the full pathname of the image file or click the Browse button and browse to the file on your computer. If the file is not located in the Home Designer Pro 2021 Data folder, a copy of the file will be created at Home Designer Pro 2021 Data\Backdrops\-My Backdrops and the program will reference that copy. See “Home Designer Pro Data” on page 40.

The Spherical Backdrop Options should only be used if the selected backdrop was specially created to serve as a spherical panoramic backdrop.

- Check Spherical Panoramic Backdrop to project the image onto a sphere that surrounds the model in camera views and overviews.

- The Horizontal Angle controls how many times the backdrop appears as you rotate in a full circle around the model. A value of 360° wraps the image around once; a value of 720°, twice; and a value of 180° makes only half the image wrap around the sphere.
- The Vertical Angle determines how much of the backdrop stretches up and down. To have it stretch from the highest point in the sky to the lowest point below the ground, use a value of 180°. To have the backdrop stretch from just below a horizontal render to just above, use a smaller value, such as 100°.

Some experimenting with the Angle values may be necessary to achieve the desired results. You may prefer to do this after adding the backdrop to a plan. See “Backdrop Panel” on page 578.

If the selected image has a Copyright, information about it will display here.

Walkthrough Paths

A 3D Walkthrough is a series of pictures saved as an .mp4, .wmv, or .avi file that can be played like a video by other applications such as Windows Media Player.
Create Walkthrough Path

There are several ways to create a walkthrough along a path, but the Create Walkthrough Path tool is the fastest and most flexible option.

To create a Walkthrough Path

1. Begin by choosing a codec for recording walk-throughs. See “Selecting a Codec” on page 620.
2. In plan view, select 3D> Walkthroughs> Create Walkthrough Path , then click and drag to draw a Walkthrough Path. See “To use the Spline tool” on page 180.
3. Edit the direction and curvature of the spline’s segments, as needed. See “Editing Spline-Based Objects” on page 138.
4. Add Key Frames to the path and modify their specifications.
5. Select the path and click the Record Walkthrough Along Path edit button. See “Record Walkthrough Along Path” on page 618.

Key Frames

Key Frames are points along a Walkthrough Path that allow you to change:

- Camera direction, tilt angle, and height;
- Changes in walkthrough speed;
- The floor that the walkthrough is on.

These changes are applied as the camera moves along the Walkthrough Path from one Key Frame to another.

To add a Key Frame to a Walkthrough Path, select the path and click the Add Key Frame edit button. Then click on the path to add a Key Frame at that location.

In plan view, each Key Frame is represented by a camera symbol centered along the walkthrough path. It displays the frame number, is pointed in the direction of its Camera Angle, and its position along the path corresponds to its Time setting.

Key Frame Time, Angle, and other properties can be edited in the Walkthrough Path Specification dialog. See “General Panel” on page 621.

You can also use the Edit Key Frames edit tool to enable Move and Rotate edit handles for each Key Frame on the selected Walkthrough Path.

To use the Edit Key Frames edit tool

1. Select a Walkthrough Path and click the Edit Key Frames edit tool.
2. Each Key Frame on the selected Walkthrough Path will display a Move and Rotate edit handle.
   - Click and drag the square Move handle to reposition the Key Frame along the path.
   - Click and drag the rectangular Rotate handle to change the Key Frame’s direction angle
3. When you are finished adjusting the Key Frames, click the Main Edit Mode edit tool to restore the Walkthrough Path’s normal edit handles.

Walkthrough Paths and Stairs

If you draw a Walkthrough Path up or down a staircase or ramp, it will follow the height of the stairs or ramp and continue on the next floor.
To create a multiple floor walkthrough

1. Draw a Walkthrough Path so that it extends into a staircase or ramp in the same direction as its Direction Arrow. See “Displaying Stairs, Ramps, and Landings” on page 399.
   • Do not drag the Walkthrough Path across the entire length of the stairs or ramp. If you do, its height will remain relative to the current floor.
2. When you release the mouse button, the program will automatically display a dashed line with an arrow extending past the last Key Frame on the current floor.
   • If it follows stairs or a ramp going upward, the path will also extend to the top end of the staircase or ramp.
3. Go up or down one floor, select the Walkthrough Path, and resize and reshape it as needed. You can use the Create Walkthrough Path tool to draw more segments and additional Key Frames can be added, as well.

Playing a Walkthrough

Once a walkthrough has been recorded, it can be played using a media player.

To play a walkthrough

1. Select 3D> Walkthroughs> Play Walkthrough to open the Select Video File dialog.
2. Browse to the .mp4, .wmv, or .avi file on saved on your computer. Your default video application plays the walkthrough video.

Recording a Walkthrough

There are two approaches to recording a walkthrough of a plan:
• Select a path in plan view, then direct the program to record a walkthrough along that path.
• Create a 3D view, then begin recording and use the Move Camera tools to navigate through the view.

Record Walkthrough Along Path

Once a Walkthrough Path has been drawn, you can use it to record a walkthrough video. See “Create Walkthrough Path” on page 617.

To record a walkthrough along a path

1. In plan view, select a Walkthrough Path or a CAD polyline or spline.
2. Click the Record Walkthrough Along Path edit button.
3. In the Walkthrough Options dialog, specify the desired Quality, Resolution, Rendering Options, and Video Codec, then click OK.
   Note: You can specify your preferred settings, including Frame Rate and Compression, in the Walkthrough Defaults dialog. See “Default Settings” on page 57.
4. In the Save Video As dialog, specify a name and saved location for your walkthrough file. The available file type will vary depending on the Codec you are using. See “Exporting Files” on page 44.
5. When you click Save, a camera view will open, showing the progress of the recording.
   To cancel the recording as it is being created, press the ESC key on your keyboard.

Walkthrough Options Dialog

Most of the settings in this dialog are also found in the Walkthrough Defaults dialog.
The **Quality** settings control the compression and total number of individual frames in the walkthrough.

- Specify a **Compression** percentage between 0 and 100. A value of 0 gives the highest quality images and largest file sizes.
- Specify the desired number of **Frames Per Second**, between 1 and 100. A higher number results in a higher quality recording but also a larger video file.
- Specify a **Duration Along Path**, in seconds.
- The **Total Frames to Record** displays for reference and equals the Frames Per Second times the Duration along Path.

The **Resolution** settings control the size of the walkthrough’s frames.

- Select a size from the drop-down list. “Current Size” is selected by default. If you modify the Width or Height below, “Custom” will become selected.
- The current **Width**, based on the selected Resolution, is stated here. If you change this value, the selected Resolution will become “Custom”. The current **Height**, based on the selected Resolution, is stated here. If you change this value, the selected Resolution will become “Custom”.
- Check **Retain Aspect Ratio** to retain the original ratio between the frame Width and Height. If you modify either value while this is unchecked, the walkthrough may appear distorted.

**Rendering Options -**

- Select the walkthrough’s **Rendering Technique** from the drop-down list. See “Rendering Techniques” on page 595.
- Check **Show Shadows** to turn on shadows in the walkthrough. See “Shadows” on page 583.
- Check **Ray Casted Sun Shadows** for higher quality shadows cast by sun light. Ray Casted Sun Shadows take longer to generate than regular shadows.
- **Bloom** occurs around areas of intense light and looks as though the light is ‘bleeding’ beyond the edges of a light source. It adds realism to the view but takes longer to render. Only available when a Rendering Technique that supports lighting is selected above.
- Check **Hide Camera-Facing Exterior Walls** to suppress the display of any exterior walls that face the camera. Interior walls set as Attic walls are also suppressed. This setting only has an effect when the walkthrough path is on the exterior of a structure.

Note: Reflections will be used in a walkthrough if they are enabled in the Full Camera Defaults dialog when the walkthrough is recorded. See “Full Camera Defaults” on page 559.

Select a **Video Codec** from the drop-down list. This setting is retained between sessions and is also global, affecting all walkthroughs in all plan files. See “Selecting a Codec” on page 620.

When you click OK, the **Save Video As** dialog will open, allowing you to specify the name, location, and file format for the walkthrough file. The available file formats may vary, depending on which codec you selected.

### Frame by Frame Walkthroughs

You can also create a walkthrough by recording it frame by frame. Although time-consuming, creating a walkthrough in this manner lets you see exactly what is being recorded as you record it.

**To record a walkthrough frame by frame**

1. Create a camera view. This view is the first frame of the walkthrough.
2. While the camera view is active, select 3D> Walkthroughs> Record Walkthrough.
3. In the Walkthrough Options dialog:
   • Select a Frame Rate between 1 and 100. The value entered is the number of frames per second.
   • Select a Compression Percent between 0 and 100. A value of 0 gives the highest quality images and the largest file size.
   • Select a Codec from the drop-down list. See “Selecting a Codec” on page 620.
   • Click OK.
4. In the Save Video As dialog, specify the name, location, and file format for the walkthrough file, then click Save. The available file formats will vary, depending on the codec you selected.
5. Use the camera movement tools to navigate the view. Each time the screen redraws, it is recorded as the next frame in sequence. See “Editing 3D Views” on page 571.
6. To move the camera without saving a view, select 3D> Walkthroughs> Pause Recording to temporarily stop recording.
   • You can then select 3D> Walkthroughs> Save Frame button to control what views are saved.
   • You can start recording again by selecting Pause Recording once more.
7. When the walkthrough sequence is complete, select 3D> Walkthroughs> Stop Recording or close the view.

Note: Zooming in and out and using the scroll bars does not change the viewpoint and does not produce a frame for the walkthrough.

If you resize the current view window while recording a walkthrough, the program will stop recording.

Selecting a Codec
A codec is a utility that compresses and decompresses media files, and is used when both recording and viewing videos such as walkthroughs. When you record a walkthrough in Home Designer Pro, you can choose which of the codecs installed on your system you want to use. This selection is universal and is retained between program sessions: when you choose a codec in either Walkthrough Options dialog, it will become selected the next time you open either dialog, even if you do so in another plan.

“Windows Media Video 9” is the default codec in the Windows version and “H.264”, in the Mac version; but any codecs installed on your system will be available to use.

To choose the codec that best suits your needs, it is a good idea to create a test walkthrough using each of the codecs installed on your system to see how well their walkthrough quality and file compression meet your requirements. Note that your choice of codec may affect the file formats in the Save Video As dialog.

For more information about codecs, visit HomeDesignerSoftware.com.

Walkthrough Path Specification Dialog
Select a Walkthrough Path and click the Open Object edit button to open the Walkthrough Path Specification dialog. See “Walkthrough Paths” on page 616.
Walkthrough Path Specification Dialog

General Panel

A list of the selected path’s **Key Frames** displays on the left. Click on a Frame in the list to select and edit it using the settings on the right. When the dialog is opened, the last key frame edited in the current program session will be selected automatically. See “Key Frames” on page 617.

- Specify the **Floor** that the selected Key Frame is located on. See “Multiple Floors” on page 387.
- Specify the **Time** in seconds at which the selected Key Frame is found in the duration of the walkthrough. Frame 1 is always at 0.0 and cannot be moved; similarly, the last frame is always at the end of the walkthrough Duration.
- Specify the **Speed After** (ft/s), which is how fast the camera moves along the walkthrough path from the current Key Frame to the next. Not available if the last Key Frame is selected.
- Specify the **Camera Angle** at the selected Key Frame.
- Specify the **Tilt Angle** of the camera at the selected Key Frame.
- Specify the **Height** of the camera at the selected Key Frame.
- Click the **Delete** button to remove the selected Key Frame from the path.
- Specify the **Key Frame Symbol Size**, which is the size of the symbols representing the selected walkthrough path’s Key Frames in plan view. See “Key Frames” on page 617.

**By default, Key Frames use the Camera Symbol Size set in the Camera Defaults dialog.** See “Camera Defaults Dialogs” on page 558.

**Walkthrough Options** -

- Specify the **Duration**, or total length of the walkthrough video in seconds.

Specify how **Camera Angles** are measured:

- Select **Relative to Path** to measure each camera angle relative to the direction of the walkthrough path at each Key Frame location.
- Select **Absolute** to measure each camera angle relative to the plan’s X, Y, and Z axes. See “3D Drafting” on page 25.

**Note:** When Relative Angles are used, a Camera Angle of 0° points in the direction of the walkthrough path. When Absolute Angles are used, 0° always points in the positive direction along the X axis.

Specify how **Camera Height** is measured:

- Select **Relative to Floor/Terrain** to measure camera height relative to the floor or terrain at each Key Frame location.
- Select **Absolute** to measure camera height relative to the plan’s Z axis.
Polyline Panel
The POLYLNE panel states the length of the path’s **Perimeter**. The **Area** and **Volume** of a walkthrough path will always be described as “Not closed”. See “Polyline Panel” on page 177.

Spline Panel
The Spline panel has a single option and is only available if the selected walkthrough path is a spline. See “Splines” on page 180.

**New Segment Angle** - Specify the angle between line segments that are used to draw the spline. Specifying a smaller angle makes the spline’s curvature smoother.

Line Style Panel
This panel is similar to the LINE STYLE panel in the **Line Specification** dialog. See “Line Style Panel” on page 169.
Chapter 33:
Importing and Exporting

Importing is the process of opening a file that was produced in a different program in Home Designer Pro. Exporting, on the other hand, is the process of saving information in a Home Designer Pro file to a format that can be read by another program.

Home Designer Pro allows you to import and export a variety of information from and to other applications. This chapter focuses on importing and exporting 2D .dwg/.dxf files and a variety of 3D file formats. Other importing and exporting options are described in the chapters in which those objects or settings are discussed.

Chapter Contents
- Chief Architect Account Login
- Export Chief Architect 3D Viewer File
- Import Room Planner File
- DXF vs DWG File Formats
- Importing 2D Drawings
- Import Drawing Assistant
- Exporting 2D DXF/DWG Files
- Additional 2D Export Information
- 3D Data Import Requirements
- Importing 3D Symbols
- Symbol Specification Dialog
- 3D Symbols and Materials
- Exporting a 3D Model
- Export 360 Panorama

Chief Architect Account Login

Your online Chief Architect Account allows you to take advantage of a variety of valuable resources including catalog downloads, license management, and technical support. See “Creating a Chief Architect Account” on page 15.

In order to export a 3D model to a Chief Architect 3D Viewer, export a 360° Panorama image file, or import a drawing from the Room Planner mobile app, you must first log in to your Chief Architect account. See “Export Chief Architect 3D Viewer File” on page 624, “Export 360 Panorama” on page 635, and “Import Room Planner File” on page 625.

If you try to do any of these tasks while you are logged out of your account, the Chief Architect Account Login dialog will open, giving you an opportunity to log in.

You can also log into or out of your online account at any time by selecting Help> Log in to Chief Architect Account or Help> Log out of Chief Architect Account.

Chief Architect Account Login Dialog

When importing a Room Planner file, use the same E-mail Address and Password that you used to save the drawing to the cloud in Room Planner.
When exporting a Chief Architect 3D Viewer or 360° Panorama file, use the **E-mail Address** and **Password** that you use to log in to the account on our website that is associated with your software product key.

### Export Chief Architect 3D Viewer File

The **Chief Architect 3D Viewer** allows a model created in Chief Architect to be viewed in either:

- A web browser on a computer.
- The 3D Viewer app on a mobile device.

In order to export a Chief Architect 3D Viewer file, you must be logged in to your Chief Architect cloud account.

For more information about the Chief Architect 3D Viewer, visit [HomeDesignerSoftware.com](http://HomeDesignerSoftware.com).

To export a file to the cloud for viewing with either option, select **File> Export> Export Chief Architect 3D Viewer File** while a 3D view is active.

Any light sources that are On in the current view, as well as ambient light, will be exported along with the model. See “Lighting” on page 585.

#### 3D Viewer Export Options

- Select **Create New Model** to export a new model without affecting any previously exported files.
- Select **Replace Existing Model** to select a previously-exported model in the list and replace it with the model being exported now.
- To select an existing model to replace, click on its line item in the list.

When you click OK, the **Export 3D Viewer File** dialog opens, where you can specify the exported model’s name, description, and other details.

#### Export 3D Viewer File Dialog

- The **Name** of the current plan file populates this field by default. Specify a different name for the exported 3D Viewer file if you would like.
- Type a brief **Description** of the model.
- Click the **Cameras** button to open the **Select Cameras to Export** dialog and specify which saved cameras to export with the model. See “3D Views” on page 557.
- The **Surface Count** and **Texture Size** display here for reference. Large Surface Count and/or Texture Size values can impact performance in the app.

When you click OK, the 3D model is exported using the layer settings in the camera view that was active when the model was exported.

On the 3D Viewer page, you can also choose to share an exported model with someone so that it can be opened in a 3D Viewer page or in the 3D Viewer mobile app.
Select Cameras to Export Dialog

- The Camera Name of each saved Perspective Camera and Overview in the plan is listed here. The camera that is active when you export the model, if listed, is followed by “(source)”. Doll House Views can be exported; however, they behave like Full Overviews in the 3D Viewer.

- In the Include column, click to add or remove a check mark for each camera that you would like to export. By default, only cameras of the same type, on the same floor, and using the same layer set are Included.

- In the Initial View column, add a check mark for the camera that you would like to be active when the model is opened in 3D Viewer.

- Click the Include All button to export all saved cameras with the model. A large number of saved cameras may slow down the interface of the 3D Viewer app.

- Click the Include None button to export no saved cameras with the model. When the model is opened, an unsaved 3D Overview will be the initial view.

Import Room Planner File

Select File> Import> Import Room Planner File, then select and download a Room Planner file from the cloud. When prompted to log in, use the same credentials you used to save a plan to the cloud in Room Planner.

Files created in Room Planner version 2 and newer can be imported into Home Designer Pro 2021.

Note that the exterior walls in an imported Room Planner drawing will inherit their thickness and other properties from the Exterior Wall Defaults dialog in the current plan, while interior walls will retain the thickness that was set in Room Planner. See “Exterior and Interior Wall Defaults Dialogs” on page 184.

Unless a custom ceiling height has been specified in Room Planner, rooms in an imported file use the Default ceiling height set in the Floor Defaults dialog. See “Floor Level Defaults” on page 226.

By default, window sizes in imported Room Planner drawings are measured from the outside of their frames, just as their Height and Width are in the Window Specification dialog. If you prefer, you can specify that windows are measured from the inside of the frames in the Preferences dialog. See “General Panel” on page 67.

Visit roomplanner.chiefarchitect.com for more information about the Room Planner mobile app.

DXF vs DWG File Formats

.dwg is the native AutoCAD® file format. Originally a proprietary format, it is now widely used with many different products.

.dxf (Drawing eXchange Format) is a standard file format created by Autodesk for the transfer of data between other programs.

Many design programs can read and write .dxf and .dwg files. Both formats interpret data as CAD objects such as lines, polylines, and circles. Both formats can also contain 3D data which can be imported into Home Designer Pro, as well.

Binary .dxf format is another related file format. It is easier for computers to read, is more accurate, and occupies less disk space and regular .dxf files. When exporting, however, bear in mind that not all applications support binary .dxf.

Importing 2D Drawings

2D drawings are imported by reading entities from a .dxf or .dwg file and creating the equivalent CAD objects in Home Designer Pro.

Home Designer Pro 2021 can import 2D .dxf or .dwg files compatible with AutoCAD® through version 2020.
A .dxf or .dwg file can be imported into plan view, a Wall Elevation or Cross Section/Elevation view.

Only drawings created in AutoCAD®’s Model Space can be imported into Home Designer Pro. Entities drawn in Paper Space are not recognized.

External references (xrefs) are not recognized by Home Designer Pro, either.

In general, all Z coordinates are mapped to zero. If an entity in an imported drawing has thickness, Home Designer Pro ignores it.

**Supported Entities**

The following is a list of the entities that are imported and how they are converted. All other entities are ignored:

- **Lines** - Both 2D and 3D lines.
- **Circles** - Fully supported in 2D.
- **Arcs** - Fully supported in 2D.
- **Ellipses** - Fully supported in 2D.
- **Spline entities** - Fully supported as 2D polylines.
- **Polylines and Lightweight Polylines** - Polylines are imported as polylines. Bumps are converted to arcs. Line widths are ignored.
- **Lightweight Polylines** - Fully supported in 2D.
- **Points** - Points are not supported unless the layer they are on is converted to Elevation Data. See “Importing Elevation Data” on page 659.
- **Text and Multi-line Text** - Both are imported as Rich Text and mapped to the Text layer. Multi-line text objects retain their original width. The first font in a multi-line text object is applied to the entire object. If that font is unavailable, Arial is used.
- **Multileaders** - Fully supported in 2D.
- **Unicode** - Fully supported in text objects only.
- **Blocks and Block Inserts** - A block is a named group of CAD entities that have been joined together to behave as a single object. A block insert is a reference to such a block. Blocks are loaded by name. If a duplicate name is found, you can specify whether a block is imported under a new name, replaces an existing block or simply uses the existing block of the same name.

**Note:** Blocks imported into Home Designer Pro cannot be exploded into their individual component objects. See “CAD Blocks” on page 626, below.

- **Hatch entities** - If Import Hatch entities is selected on the SELECT FILE page of the Import Drawing Assistant for a .dwg file, Hatch patterns are imported as a CAD block consisting of solid black filled polylines.
- **2D Solids** (Not ACIS Solids) - Fully supported in 2D.
- **Solids** - A solid is a 3 or 4-sided filled area. These are imported as 2D faces.
- **2D Solids (Not ACIS Solids)**
- **3D Faces/Polyface Meshes** - A 3D face has its Z coordinate mapped to zero, and imports as a polyline.
- **Dimensions** - Rotated, aligned and 3-point angular dimensions are supported. All other dimension types are imported as lines and text rather than functioning dimensions.
- **Attributes** - Attributes are text objects associated with other items, like blocks. These are imported as text objects at the appropriate location but the association with the original object is broken.
- **Line Styles** - Line styles are not imported. Instead, if a style of the same name displays in the Home Designer Pro line styles, that line style is used. Otherwise a solid line style is used.
- **Layers** - You can specify which layers in the imported drawing to import into your Home Designer Pro file. See “Layers” on page 110.

**Import Drawing Assistant**

A 2D .dxf or .dwg file can be imported into any orthographic view: plan view, cross section/elevation views, and layout.

**CAD Blocks**

A block is a group of CAD objects that has been joined together to behave as a single object. Although blocks can be imported into Home Designer Pro, they cannot be exploded and have no specification dialog. They can, however, be selected, moved, and deleted. See “CAD Objects” on page 161.
To import a 2D drawing file, open the view in which you would like to place the drawing and select File > Import > Import Drawing (DWG/DXF) to open the welcome page of the Import Drawing Assistant. Click Next to continue.

You can also launch the Import Drawing Assistant by dragging a .dxf/.dwg file from an operating system window into the Home Designer Pro window.

Select File

1. Click the Browse button to select the file you wish to import. When a file is selected, its full pathname displays to its left. The directory containing the last file selected using the Import Drawing Assistant displays here otherwise. If the pathname is not a valid dxf/.dwg file, this text will display in red.

   Note: If the file you are importing is password protected, you will be prompted to enter the password before continuing.

2. If you want to convert lines with shared end points to polylines and/or boxes, check the appropriate options. Polylines are not affected by these settings, nor are lines that do not share end points.
   - Check Polylines to import lines with shared end points as polylines.

3. Specify how to treat CAD blocks associated with the selected drawing.
   - Select Import all CAD blocks to include all CAD blocks associated with the file being imported whether or not they are in use.
   - Select Only import CAD blocks that are referenced in the drawing to reduce the volume of transferred data.

4. Check Import Hatch entities to import areas of hatching as solid-filled polylines.

Click Next to load the file into memory so that Home Designer Pro can present information about the contents of the file. This can take a while for larger files.

Select Layers

In Home Designer Pro, all drawing file layers are mapped to the “CAD, Default” layer. Original layer attributes are lost, but line color, styles, and weight are preserved on a per-object basis.
A list of the layers found in the imported file and information about each layer displays in this table. See “Layers” on page 110.

- In the Layer column, check the box to the left of each layer name to specify which layers you want to import. Layers with checked boxes are imported; those with unchecked boxes are not.
- Layers that were Visible in the original program are checked by default. You can include a layer that is not visible by checking the box to the left of its name.
- Layers that were Frozen in the original program are not checked by default. You can include a frozen layer by checking the box to its left.
- If a layer is set to Convert To a Terrain Perimeter or Elevation Data, it will be indicated in this column provided that you are importing into plan view.

Click Select All to check the box to the left of all layer names in the table. Click Clear All to clear the checkbox to the left of all layer names in the table.

The Convert To drop-down list allows you to convert the data on any layer into a Terrain Perimeter or Elevation Data. See “Terrain Perimeter” on page 638 and “Importing DWG/DXF Elevation Data” on page 663. Only available when importing into plan view.

To convert a layer to a Terrain Perimeter or Terrain Data, click on its name in the table and then select an option from the Convert To drop-down list. The option you choose will then display in the Convert To column in the table.

Note: If an open polyline is converted into a Terrain Perimeter, the program will draw an additional edge to close the gap.
Exporting 2D DXF/DWG Files

Line-based 2D files can be exported from Home Designer Pro in both .dxf and .dwg file formats. You can specify the version of AutoCAD® to export to. Compatibility with other software may vary.

There are two ways to export a 2D drawing file in Home Designer Pro: Export Current View and Export All Floors.

Drawing Unit

Select a unit of measurement from the drop-down list. Selecting the correct unit helps ensure that your imported drawing is accurately sized.

1. If the file being imported was drawn at a scale other than 1:1, you can compensate for this scaling by creating a custom unit of measurement and specifying it here. See “Unit Conversions Panel” on page 70.

2. Specify how dimensions are imported.
   - Select Import as dimensions where possible to import dimensions as Home Designer Pro-supported dimension lines.
   - Select Import as CAD blocks to import dimensions as CAD entities that are not recognized by Home Designer Pro as dimensions.

3. Check Move drawing to the origin to place the drawing at 0,0. When this is unchecked, it is imported to the same location as it was drawn in the original application. See “3D Drafting” on page 25.

Import Complete

When a .dxf/.dwg file is imported into Home Designer Pro, all of its components are selected as a group. The selection set has Move and Rotate edit handles available for relocating the entire drawing, as well as a variety of edit tools. Once another object or tool is selected, the drawing components are no longer group-selected.

If you do not see your imported drawing, select Window> Fill Window, as it may have been placed at a location not currently visible on screen. When the drawing can be seen, move your mouse pointer over it and note its coordinates in the Status Bar. If any coordinate value has more than six digits, use the Transform/Replicate Object edit button to move it closer to the origin. See “Transform/Replicate Object Dialog” on page 151.

Imported CAD objects can be selected and edited just like objects that were drawn in the program. See “Editing Objects” on page 119.

Export Current View

To export a plan view or 3D view that is currently active, select File> Export> Current View (DWG/DXF).

Bear in mind that Orthographic views are drawn to scale and will produce a 2D drawing that can be
accurately dimensioned. Perspective views, on the other hand, are not scaled and do not produce drawings that can be dimensioned accurately. See “Perspective and Orthographic Views” on page 558.

**Export All Floors**

To export the plan view for all floor plans simultaneously, select File > Export > All Floors (DWG/DXF) from any floor of the plan. The floor plans are exported to a single .dxf or .dwg file.

If you choose to export all floors, the file will contain all floors superimposed on each other. Upon export, each layer in your Home Designer Pro drawing is divided into separate layers: one for each floor. For example: “Electrical-2” contains objects on Floor 2 that were originally on the “Electrical” layer.

**Export Drawing File Dialog**

1. **AutoCAD® File Format Options** - .dxf and .dwg files created by Chief Architect can be compatible with a variety of AutoCAD® versions. Specify which version from the drop-down list.

2. The Layer Options settings allow you to control the layers associated with the file being exported. See “Layers” on page 110.
   - **Split Wall Assemblies Into Layers** - The lines that represent wall layers can be exported onto different layers, allowing them to be displayed separately. See “Wall Type Definitions” on page 208.
   - Select **Export Only Displayed Layers** to export only those layers that are displayed on screen. This is what always occurs when exporting from layout, but is not an available option in layout files.
   - Select **Export all used and named layers** to export all layers that either have something on them or have a layer name specified. Not available in layout files.

3. **Other Options**
   - **Scaling Unit** - Select the unit of measurement to be used. For best results, choose inches or feet for Imperial plan or layout files, or metric units for metric files. See “Dimension Preferences and Defaults” on page 250.
   - Uncheck **Create Associative Dimensions** to export dimensions as simple CAD entities that are not recognized dimensions by other programs. Associative dimensions are recognized by AutoCAD® and many other CAD programs.

   When exporting a layout page, it is often best to uncheck this box.

   - Check **Export Pattern Lines** to export pattern lines. Pattern lines are exported as normal CAD lines.
   - Check **Export Filled Areas** to export filled areas as AutoCAD® 2D solid entities.

   Dimension lines using non-default formatting will lose their changes and will use the default format upon export.

   When you are satisfied with your selections, click the **Export** button to save the exported file as either a .dwg, .dxf, or binary .dxf file.
Additional 2D Export Information

The export process converts high level Home Designer Pro objects (doors, windows, etc) into simple, CAD-based objects (lines, arcs, etc). Home Designer Pro exports all data to AutoCAD®’s Model Space.

Supported Entities

The following entity types are currently supported for 2D export:

**Line** - The simplest entity. In AutoCAD®, lines are 3 dimensional with the Z coordinate set to zero.

**Arc** - Arcs have a start angle, end angle and radius.

**Circle** - Fully Supported.

**Multi Line Text** - If exporting to an AutoCAD® release that supports multi-line text, Home Designer Pro writes the file as multi-line text. If exporting to a version that does not support multi-line text, the file is written as simple text.

**Unicode Text** - Fully supported.

**Polylines** - Polylines are a collection of points with lines or arcs connecting them. Home Designer Pro supports both lines and arcs. Arcs are referred to as bulges in AutoCAD®.

**Block Insert** - A block insert is a reference to a block, which is a named collection of entities. A block can also contain block inserts.

Dimensions

Aligned, rotated, and angular dimensions can all be exported.

Each dimension has an associated block containing a representation of the dimension as it is drawn in Home Designer Pro. It also contains all the data to recreate that information.

- When an exported dimension is modified in AutoCAD® or other CAD program, its appearance changes.

- Home Designer Pro does not support arrowhead styles or fonts.

- Three kinds of dimensions are generated: Aligned, Rotated and 3 Point Angular.

- Please refer to AutoCAD® documentation for more information.

Layers

Layers in other systems are similar to Home Designer Pro layers, but there are some subtle differences. Layer information is mapped as follows:

<table>
<thead>
<tr>
<th>Home Designer Pro</th>
<th>Other Systems</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name</td>
</tr>
<tr>
<td>Color</td>
<td>Nearest AutoCAD® Color. Home Designer Pro uses the default AutoCAD® color table to determine this mapping.</td>
</tr>
<tr>
<td>Display</td>
<td>On</td>
</tr>
<tr>
<td>Size</td>
<td>Line Weight. In AutoCAD®, line weights are determined by a table of mm line widths. Home Designer Pro maps to the closest match in this table based the current view’s Line Weight Scale. See “Drawing Sheet Setup Dialog” on page 710.</td>
</tr>
<tr>
<td>Style</td>
<td>Line type</td>
</tr>
<tr>
<td>Lock</td>
<td>Lock</td>
</tr>
</tbody>
</table>

Line Types

A line type, or line style, is used by layers and entities to determine how lines are drawn. Home Designer Pro line types installed with the program are supported on export.
3D Data Import Requirements

Importing a symbol that can be used by Home Designer Pro is a relatively simple process that begins with previously created 3D data. This 3D data often comes from a program other than Home Designer Pro. If you use another 3D modeling program to create the 3D data, be aware of the following requirements before attempting to create symbols.

There are a number of requirements that must be met before any 3D data can be used to create a symbol in Home Designer Pro:

- The 3D data must be stored in a standard Drawing Exchange File (.dxf), AutoCAD® Drawing (.dwg), object (.obj), 3D Studio® Mesh (.3ds), stereolithography (.stl), COLLADA (.dae), or SketchUp version 2019 and prior (.skp) file format. If you have 3D data in another format, you must convert it into one of these formats first.
- Geometry and material information stored in .3ds files are imported; cameras and lights are not.
- The 3D model must be composed of 3D DWG or 3DSOLID solid entities, or face data. Faces are typically referred to as 3D faces, polygonal faces, or poly meshes. Other types of entities such as lines, curves, circles, polylines, and free form surfaces can exist in the file but are not imported when the symbol is created. This is true for all (.dxf/.dwg/.obj/.3ds/.skp) file types.
- The face data should be assigned to different layers so that you can map them to the correct materials when viewing them in 3D. It is helpful to name your layers using a convention that identifies that materials should be assigned to each sub-component.
- Pay attention to the origin and orientation of the 3D data when designing symbols. Home Designer Pro allows some adjustment when creating the symbol, but it is easier to build the 3D data correctly before importing it into Home Designer Pro. For more information about defining the origin, see “Symbol Origin” on page 191.
- If a symbol with faces that have more than four vertices is imported, the faces are truncated, resulting in an object that appears to have holes. The best remedy is to re-export the model from the original application using only triangular or quadrilateral faces.
- Home Designer Pro does not support grouped objects in symbols imported from .3ds files.

Surface Normals

If you use third party software to create a .dxf/.dwg/.obj/.3ds/.skp file that will be imported as a symbol, you should be familiar with the concept of surface normals.

A surface normal is a vector that is perpendicular to the plane of a surface. This vector points in one direction, determined by the way the face is drawn.

If a face is drawn clockwise, the surface normals are directed outward; if a face is drawn counterclockwise, the surface normals point inward. Home Designer Pro assumes that the face on the positive side of the normal vector is the outside face.

Many objects can be drawn using only one side of each face. A cube is a good example: the inside of a cube is not visible, so it is not necessary to create its inside faces. When inside faces are not calculated, 3D views in Home Designer Pro can generate more quickly.

Importing 3D Symbols

Home Designer Pro supports the import of 3D surface and 3D solid objects saved in .dwg, .dxf, .3ds, .obj, .stl, .dae, and .skp formats.

For most file types, there are three ways to import a 3D symbol into Home Designer Pro:

- By selecting File> Import> Import 3D Symbol tool.
• By selecting **New > 3D Symbol** from the contextual menu in the Library Browser. See “Using the Contextual Menus” on page 511.

• By dragging and dropping the file from an operating system window into plan view.

3D .dx/.dwg files can only be imported by selecting **File > Import > Import 3D Symbol**.

Symbols imported by clicking and dragging are imported for use in the current plan, while those imported using the **Import 3D Symbol** dialog can also be saved in the library. See “The Library” on page 509.

**To drag and drop a 3D symbol file**

1. Open the plan in which you would like to import a 3D symbol and remain in plan view.

2. Open an operating system window in front of the Home Designer Pro program window.

3. Resize and position the window so that the Home Designer Pro program window can be seen behind it.

4. Click on the desired .3ds, .obj, .stl, .dae, or .skp file and drag it into the Home Designer Pro program window.

5. When your cursor changes to a +, click in the drawing area to place as many copies of the symbol as desired. When you are finished, select a different tool.

Symbols imported by clicking and dragging cannot be edited in the **Symbol Specification** dialog. If a symbol needs to be rotated, or its unit of measurement specified, use the **Import 3D Symbol** tool to import it.

**Symbol Specification Dialog**

To import a symbol object, select **File > Import > Import 3D Symbol**.

Home Designer Pro supports the import of 3D surface and 3D solid objects saved to .3ds, .obj, and .skp formats and treats imported symbols as stand-alone fixtures.

The **Import 3D Symbol** dialog, which opens first, is a typical **Open File** dialog in which multiple files can be group-selected for import. See “Importing Files” on page 47.

The **Symbol Specification** dialog opens next.

**3D Panel**

1. **3D Geometry** - Select the **Drawing Unit** that was used to create the symbol. If any units other than inches or mm are selected, the program will convert the data into units appropriate for Home Designer Pro.

2. The **Rotation** settings allow you to rotate the selected symbol about the X, Y, and Z axes.
   - Select the X, Y, or Z **Axis**.

Note: SKP files are always imported using inches, regardless of the default units used in the plan file. See “Creating a New Plan or Layout” on page 41.
• Specify the **Angle** to rotate the symbol in the text field. 90° is set by default.

• Click the **Rotate +** or **Rotate -** button to rotate the object around the selected axis in a clockwise or counterclockwise direction, respectively.

The **Number of Faces** that the symbol has displays here for reference. When multiple symbols are being imported, nothing displays. Although there is no limit to the number of surfaces that a symbol can have, large numbers can increase the rendering time for 3D views significantly.

4 A preview of the symbol’s appearance displays here and updates as changes are made to the settings in this dialog. When multiple symbols are selected, the most recently selected symbol displays.

See “Dialog Preview Panes” on page 32.

### Materials Panel

The **Materials** panel allows you to assign materials to the symbol’s components and is similar to the same panel in many specification dialogs. See “Materials Panel” on page 542.

Bear in mind that .dxf/.dwg files do not include material information, so the components of a symbol imported from this format will not have materials assigned to them. See “3D Symbols and Materials” on page 634.

### 3D Symbols and Materials

When a symbol is imported into Home Designer Pro, material definitions may be included with it. Whether and how material information is included depends on the symbol’s file format. See “About Materials” on page 540.

#### DXF/DWG and STL Files

.dxf/.dwg and .stl files do not include information about material definitions. When imported, default materials for interior fixtures will be assigned.

#### OBJ Files

Material definitions for most .obj files are saved in a separate file with the .mtl file extension. If such a file exists, the materials associated with the .obj file display in the list on the left side of the **Materials** panel of its specification dialog.

If Home Designer Pro does not receive material definition information in an accompanying .mtl file, default material properties are assigned.

Material definitions for .obj files can also include texture information in the form of image files (.jpg, .png, etc).

In order to properly import an .obj file, Home Designer Pro needs the .obj file, the .mtl file, and any referenced texture files. If a texture file is not available, the material it is associated with is created without a texture.

The material definitions associated with an imported .obj symbol are not available for use by other objects in Home Designer Pro until that symbol has been placed into a plan. The associated texture files are then copied to the user’s Textures folder. See “Home Designer Pro Data” on page 40.

#### 3DS and DAE Files

Material definitions for .3ds and .dae files refer to texture information in separate image files.

In order to properly import a .3ds and .dae file, Home Designer Pro needs these referenced image files. If a texture file is not available, the material it is associated with will be created without it. The associated texture files are copied to the user’s Textures folder.

#### SKP Files

The textures associated with a .skp file are saved in the file. After you import a symbol and either place it in a plan or add it to the Library, these textures are saved in the Home Designer Pro Textures folder. Home Designer Pro does not support deformed textures. If a texture associated with a .skp file is deformed, it will be imported without the deformations.

### Texture Filename Conflict

If a texture of the same name already exists in the plan when an .obj, .3ds, or .skp file is imported, the **Texture Filename Conflict** dialog displays.
Exporting a 3D Model

The entire 3D model, or any part that you choose, can be exported from Home Designer Pro into either of two formats:

- DAE Format
- STL Format

To export the 3D model

1. A camera view or overview must be active. See “Types of 3D Views” on page 557.
2. Make sure that everything that you want to export is set to display in the current view, and everything you do not want to export is not set to display. See “Layers” on page 110.
3. Any surfaces removed using the Delete Surfaces tool will not be exported. See “Displaying 3D Views” on page 565.
4. When the model is ready, select File > Export > 3D COLLADA Model to export to this format.

The Export COLLADA Model dialog is a typical File Save dialog.

Any light sources that are On in the current view, as well as ambient light, will be exported to a .dae file along with the model. See “Lighting” on page 585.

Any material textures used in the model are saved as image files in a folder in the same location as the saved .dae file. The folder has the same name as the .dae file, appended with “_textures”.

STL Format

An .stl file can be opened by any program that uses Stereolithography format, and can be printed using a stereolithography machine, or 3D printer. When the model is ready, select File > Export > 3D Model (STL).

The Export STL Model dialog is a typical File Save dialog.

A 3D model exported to an .stl file does not include any material or texture information.

Export 360 Panorama

The Export 360 Panorama tool creates a spherical panoramic image that can be opened in various panorama viewers. Select File > Export > Export 360 Panorama while a 3D view is active to access this tool.

For best results, position the camera as near as you can to the center of the scene before exporting.
Export 360 Panorama File

All of the settings in this dialog are retained during the current program session.

1 Specify the size of the exported image, in pixels.
   - Specify the **Height** and **Width** of the exported image file, in pixels.
   - Check **Limit Dimensions to Powers of Two** to restrict the Width and Height to values that are powers of two. When this is checked and an ineligible value is entered, it will adjust up or down to the nearest power of two. Although not required, this option is recommended for best results in some panoramic image viewers.

2 Check **Save to Disk** to save the exported panoramic image file on the local computer system.
   - Specify the full pathname of the **File** you wish to export, or click the **Browse** button to open the **Export 360 Panorama File** dialog, which is a typical File Save dialog. See “Exporting Files” on page 44.

3 Check **Save to Chief Architect Cloud** to save the exported panoramic image file to your Chief Architect Cloud Account. See “Chief Architect Account Login” on page 623.
   - Type a short, descriptive **Name** for the exported panoramic image file.
   - Type a brief **Description** of the file.

When you click OK, a panoramic image is created and a progress dialog may display. Because spherical panoramas are composed of multiple images stitched together, they may take longer to create than a standard exported picture.

Note: You can also upload a previously saved panoramic image file to the cloud on the 360 Panoramas page of your online account.
Home Designer Pro allows you to model the terrain around a house. Begin by specifying elevation data that creates the surface contours, and then add surface features such as planting areas and water features.

You can import terrain data from a variety of sources and use this data to produce your 3D model.

Once the terrain is modeled, shadows that follow the terrain can be created using the Sun Angle tool. See “Sun Angles and Shadows” on page 590.

Driveways, parking lots and sidewalks as well as plants and sprinklers are among the objects that can be placed in your terrain and are discussed in “Plants and Sprinklers” on page 669 and “Roads, Driveways and Sidewalks” on page 665.

Chapter Contents

• Terrain Toolbar Configuration
• Terrain Perimeter
• Elevation Data Tools
• Terrain Modifier Tools
• Terrain Feature Tools
• Garden Bed Tools
• Water Feature Tools
• Stepping Stone Tools
• Terrain Wall and Curb Tools
• Sun Shadows
• Terrain Objects in the Library
• Displaying Terrain
• Editing Terrain Objects
• Importing Elevation Data
• Converting CAD Objects to Terrain Data

Terrain Toolbar Configuration

The Terrain and Road Tools can be accessed through the Terrain menu. You can also display these tools on your toolbar using the Terrain Configuration. See “Toolbar Configurations” on page 86.

The Terrain Configuration and Terrain menu both display the following Terrain, Road, Plant, and Sprinkler parent tools:

• Elevation Data Tools allow you to add elevation data to your terrain.

• Terrain Modifier Tools model changes in elevation within a defined area.

• Terrain Feature Tools let you add materials over the top of the terrain.

• Garden Bed Tools create Terrain Features with a mulch material.

• Water Feature Tools create Terrain Features with a water material.

• Stepping Stone Tools are used to create paths composed of multiple Terrain Features.

• Terrain Wall and Curb Tools let you draw walls and curbs that follow the terrain.
Road, Driveway and Sidewalk Tools allow you to create paved areas that can form intersections.

- **Plant Tools** allow you to place plant images and 3D plant symbols.
- **Sprinkler Tools** are used to lay out sprinkler symbols and irrigation lines.

**Terrain Perimeter**

The Terrain Perimeter is a closed polyline defining the boundary of the terrain that generates in 3D views and of the contour lines that generate in plan view. Select **Terrain > Create Terrain Perimeter** to create a terrain perimeter.

If you create a terrain perimeter in plan view but do not see it, select **Window > Fill Window**. See “Zoom Tools” on page 96.

When created in a new, blank plan, a new terrain perimeter will be 50’ x 100’. If you create a terrain perimeter after you have drawn all or part of a 3D model, it may increase in size as needed to encompass everything in plan view.

Once created, the terrain perimeter can be resized and edited like other polyline-based objects. See “Editing Closed Polyline-Based Objects” on page 133.

When a terrain perimeter is first created, it is completely flat and is placed at a height of 0’-0”, or sea level.

The terrain perimeter by itself does not have elevation data associated with it. You can use the **Elevation Data** and **Terrain Modifier** tools to create terrain that slopes in a wide variety of ways. If you do not create elevation data within the terrain perimeter, the terrain remains flat at an elevation of 0’-0”. See “Elevation Data Tools” on page 639 and “Terrain Modifier Tools” on page 643.

**Plot Plans**

Using the CAD drawing and editing tools, you can create an accurate plot plan of any building site. For more information, see “Site Plans” on page 433 of the User’s Guide.

**Terrain Height vs Floor Height**

Home Designer Pro always defines the default height of Floor 1 at 0’-0”. This height value is the constant by which the heights of structural elements in the program like walls, floors, and ceilings are measured. The heights of architectural object can be measured relative this absolute height, as well. See “Floor 1 Default Height” on page 226.

The default height of Floor 1 is not, however, the absolute by which terrain elevation is measured. Instead, elevation data is measured relative to sea level. This means that if you want to, you can use real-world elevation data to generate a 3D terrain model without also having to measure floor and ceiling heights from sea level. See “Importing Elevation Data” on page 659.

The program automatically positions Floor 1 a set distance above the terrain. To do this, it first finds the center point of the building footprint. Then, it determines the elevation of the terrain at that point. Finally, it adds the thickness of the floor platform and any sill plates to this value plus either 6” (150 mm) or 8” (200 mm) depending on the foundation type. The resulting value, referred to as the automatic Subfloor Height Above Terrain, is how far the default height of Floor 1 is above sea level in the current plan. See “Foundations and the Terrain” on page 381.

The Subfloor Height Above Terrain distance is stated and can be modified in the **Terrain Specification** dialog. You can specify a custom value to produce a
daylight or walkout basement. See “General Panel” on page 649.

**Build Terrain**

Select Terrain > Build Terrain to generate the terrain surface based on the provided elevation data. Build Terrain also updates the Building Pad Elevation value in the Terrain Specification dialog. See “Building the Terrain” on page 647.

**Auto Rebuild Terrain**

By default, terrain will automatically build any time a 3D view is created, ensuring that the terrain in the view is up-to-date. If your terrain is large and/or highly detailed and has not been modified, and you find that this unnecessarily slows down the generation of 3D views, consider turning this behavior off in the Terrain Specification dialog. See “General Panel” on page 649.

**Clear Terrain**

To remove the generated terrain contours, select Terrain > Clear Terrain. When the terrain is cleared, contours do not display in 3D and contour lines do not display in plan view.

Clear Terrain does not remove the terrain perimeter, elevation data, or terrain features from the model. Rather it deletes all program-generated 2D contour lines and 3D contours.

**Elevation Data Tools**

Select Terrain > Elevation Data to add elevation information to your terrain.

When terrain is generated, this data is used to calculate the surface of your site and is represented by contour lines in plan view and a curved surface in 3D. See “Displaying Terrain” on page 646.

Elevation data can be specified using the Elevation Point, Elevation Line, Elevation Spline, Elevation Region, and Terrain Break tools.

Elevation data can also be imported. See “Importing Elevation Data” on page 659.

The elevation of each Elevation Line, Spline and Region is specified relative to sea level.

The Terrain Perimeter has a variety of editable properties, including many that affect the appearance of the terrain in 2D and 3D views. See “Terrain Specification Dialog” on page 648.

**Terrain Surface Triangles**

Home Designer Pro generates 3D terrain surfaces by dividing them into triangles. The size of the triangles determines how detailed contour lines and terrain surfaces in the 3D model can be. You can specify triangle size in the Terrain Perimeter Specification dialog. See “General Panel” on page 649.

Increasing the triangle count decreases triangle size, yielding more detailed contour lines and a better 3D approximation of the terrain. Smaller triangles demand longer terrain generation time and increased memory requirements. If you select a large number of small triangles for a large site, you may wait a long time for the calculation.

Decreasing the triangle count increases triangle size. Elevation lines are sampled less frequently, speeding up terrain generation. If you specify a small number of triangles for a plan with detailed elevation data, contour lines and 3D surfaces may not generate correctly.

When a large terrain perimeter is used, consider increasing the Triangle Count to help make sure all Elevation Data and Terrain Modifiers generate contours.

To avoid unexpected results, do not draw Elevation Data objects with different elevation information at the same location.

**Elevation Points**

An Elevation Point contains the absolute elevation data for one point in the terrain model. Typically, Elevation Points are imported rather than placed manually.

Home Designer Pro requires many points to make an accurate approximation of your site. Even small sites
may require over a hundred points to generate an accurate model of the terrain if it is sloped. For the sake of illustration, the following example shows only a few elevation points.

To place an elevation point

1. Select **Terrain** > **Elevation Data** > **Elevation Point** and click in plan view at the point where you would like to place elevation data. See “Place Point” on page 163.
3. Click somewhere else in plan view and the **Elevation Point Specification** dialog opens again with the last elevation value entered.
4. Repeat steps 1, 2 and 3 to place additional elevation points with varied elevation values as needed.
5. Select **Terrain** > **Build Terrain**. See “Building the Terrain” on page 647.

Elevation Lines

An **Elevation Line** contains absolute elevation data for many points along a line at a constant elevation. Elevation lines can be connected to create a polyline with many straight sections. For the sake of illustration, the images in the following example show single-section elevation lines.

To draw an elevation line

1. Select **Terrain** > **Elevation Data** > **Elevation Line**, then click and drag a line inside the Terrain Perimeter in plan view.
2. Click on the elevation line to select it, then click the **Open Object** edit button.
3. At first, an elevation line is at elevation 0' - 0". In the **Elevation Line Specification** dialog, specify the desired elevation and click OK. See “Elevation Line/Region Specification Dialog” on page 652.
4. Repeat steps 2 and 3 to draw additional elevation lines as needed.
5. Select **Terrain** > **Build Terrain**. See “Building the Terrain” on page 647.
After it is drawn, an Elevation Line can be edited much the way other line-based objects can. See “Editing Line-Based Objects” on page 126.

Elevation Splines

Elevation Splines can be used to form complex curves and shapes. Like elevation lines, elevation splines contain absolute elevation data for many points along a constant elevation.

To place an elevation spline, select Terrain> Elevation Data> Elevation Spline and click and drag multiple sections in plan view. See “Splines” on page 180.

Elevation splines are initially placed at elevation 0' - 0" and must be opened and assigned an elevation. See “Elevation Line/Region Specification Dialog” on page 652.

After it is drawn, an Elevation Spline can be edited much the way other spline-based objects can. See “Editing Spline-Based Objects” on page 138.

Elevation Regions

An Elevation Region contains absolute elevation data for an enclosed region and is ideal for creating a flat surface in your terrain.

Elevation Regions are similar to Flat Regions in that they produce an area with a flat surface; however, they differ in that an Elevation Region affects the contours of the terrain outside of its perimeter and may also have some sloping within its perimeter. See “Flat Regions” on page 643.

To create an elevation region

1. Select Terrain> Elevation Data> Elevation Region.

2. There are two ways to add a Terrain Modifier to your plan:
   - Click once to place an 8’ (0.6 m) square feature at that location.
   - Click and drag from end-to-end to draw a feature sized as needed. See “Rectangular Polyline” on page 178.

3. Click on the region to select it, then click the Open Object edit button.

4. At first, an elevation line is at elevation 0' - 0". In the Elevation Region Specification dialog, specify the desired elevation and click OK. See “Elevation Line/Region Specification Dialog” on page 652.

After it is drawn, and Elevation Region can be reshaped much the way other closed polyline-based objects can. See “Editing Closed Polyline-Based Objects” on page 133.
An **Elevation Region** can also be created by drawing a closed polyline using **Elevation Lines**.

- If the Terrain Break divides the terrain perimeter into two separate pieces, the terrain data on either side is calculated independently and smoothed separately, resulting in sharp terrain contours.
- If the Terrain Break does not extend completely from one side of the terrain perimeter to the other, the areas near each end of the Terrain Break are blended.

**Terrain Breaks**

A **Terrain Break** creates a division along the terrain surface that affects terrain generation. Elevation data on one side of the terrain break does not affect the terrain generation on the other side, allowing you to create immediate drops in terrain.

To place a Terrain Break, select **Terrain > Elevation Data > Terrain Break** and click and drag a line in plan view.

The **Retaining Wall** tool creates a similar effect by drawing a Terrain Break as well as a retaining wall that rests against the break. By default, the top height of the retaining wall matches the terrain on the high side of the break and the bottom matches the low side. See “Retaining Walls” on page 646.
Terrain Modifier Tools

Select **Terrain> Modifier** to access tools that allow you to modify the existing elevation data by drawing a closed polyline. Their height is relative to the terrain surface generated from the Elevation Data provided in your plan.

The elevation data associated with a Terrain Modifier only affects the terrain within its perimeter. The rest of the terrain is unaffected.

**Raised and Lowered Regions**

The **Raised Region** tool creates a raised area with a top surface that is flattened like a plateau but follows the surface of the terrain. The **Lowered Region** tool creates a depression with a bottom that follows the terrain and is flattened.

**Hills and Valleys**

The **Hill** and **Valley** tools create raised and lowered areas in the terrain that come to a point rather than flattening at their highest or lowest elevations.

**Flat Regions**

The **Flat Region** tool creates an area with a surface that is flattened like a plateau but is level rather than following the contours of the terrain.

There are two ways to add a Terrain Modifier to your plan:

- Click once to place a modifier with endpoints that form a 10’ (4 m) square at that location.
- Click and drag from end-to-end to draw a feature sized as needed. See “Rectangular Polyline” on page 178.

Terrain Modifiers can only be drawn when a Terrain Perimeter is present, and will only display in 3D when they are drawn within the perimeter. See “Displaying Terrain” on page 646.

Once created, Terrain Modifiers can be selected and edited in a variety of ways. See “Editing Spline-Based Objects” on page 138.

Terrain Feature Tools

Select **Terrain> Feature** to access tools for drawing bounded areas that follow the contours of the terrain rather than modifying them.

Terrain Features are useful for creating landscaping features because they have specified heights and materials. You can, for example, create paths and planting beds with gravel or mulch materials that stand out in a grassy Terrain Perimeter. See “Adding Terrain Features” on page 124 of the User’s Guide.

In fact, **Garden Beds** , **Water Features** and **Stepping Stones** are special Terrain Features with material and height attributes already applied to them, saving you time when drawing these objects.

Terrain Features can only be drawn when a Terrain Perimeter is present, and will only display in 3D when they are drawn within the perimeter. See “Displaying Terrain” on page 646.

Terrain Features can be created in either of two ways:
• Click once to place a feature with endpoints that form a 10’ (4 m) square at that location.
• Click and drag from end-to-end to draw a feature sized as needed. See “Rectangular Polyline” on page 178.

Once created, Terrain Features can be edited into nearly any shape you require. See “Editing Closed Polyline-Based Objects” on page 133 and “Editing Spline-Based Objects” on page 138.

**Rectangular Features**

The Rectangular Feature tool can be used to create straight-sided features that can be edited into a wide variety of shapes.

Rectangular Features can also be edited like other closed polyline-based objects. See “Editing Closed Polyline-Based Objects” on page 133.

**Spline Feature**

The Spline Feature tool can be used to create features with rounded edges and smoothly curved corners.

Spline Features can be edited like other closed spline-based objects. See “Editing Spline-Based Objects” on page 138.

**Terrain Holes**

By default, the program automatically cuts a hole in the terrain around any structures located within and on the same floor as the Terrain Perimeter. The shape of these holes follow the exterior surfaces of the walls and will automatically update if any of those walls are moved.

A Terrain Hole is a Terrain Feature that cuts a hole in the terrain. Using this tool is the same as creating a Terrain Feature and checking Make Hole in the Terrain Feature Specification dialog. See “Terrain Feature Specification Dialog” on page 654.

Terrain Holes are useful for manually clipping the terrain around a foundation that does not match the footprint of the first floor.

**Kidney Shaped Features**

The Kidney Shaped Feature tool allows you to quickly create features with curved edges, smooth corners and a right angle bend in its shape.

Kidney Shaped Features can be edited like other closed spline-based objects. See “Editing Spline-Based Objects” on page 138.

Terrain features can also be converted from closed 2D polylines or splines using the Convert Polyline edit tool. See “Convert Polyline” on page 151.

For information about adding height and material information to Terrain Features, see “Terrain Feature Specification Dialog” on page 654.

**Garden Bed Tools**

Select Terrain> Garden Bed to access tools that can be used to place garden bed features in your terrain.

**Polyline Garden Bed**

This tool draws a garden bed with straight sides and four right angles. See “Rectangular Features” on page 644.

**Round Garden Bed**

Use this tool to draw garden beds with rounded edges and smoothly curved corners. See “Spline Feature” on page 644.

**Kidney Shaped Garden Bed**

You can draw a kidney shaped garden bed with this tool. See “Kidney Shaped Features” on page 644.

Garden Beds are basically Terrain Features with material and height attributes typical of planting beds. See “Terrain Feature Tools” on page 643.

You can specify a Garden Bed’s material and height in its Terrain Feature Specification dialog. See “Terrain Feature Specification Dialog” on page 654.

In addition, you can choose to distribute copies of a plant image within a Garden Bed. See “Distributed Plant Panel” on page 655.
Water Feature Tools

Select **Terrain > Water Feature** to access tools for drawing ponds and streams in your terrain.

Ponds are basically **Terrain Features** with material and height attributes typical of bodies of water. See “Terrain Feature Tools” on page 643.

Similarly, Streams are Terrain Curbs with a water material. See “Terrain Wall and Curb Tools” on page 645.

**Round Pond**

Use this tool to draw a pond with rounded edges. See “Spline Feature” on page 644.

**Kidney Shaped Pond**

This tool draws a kidney shaped pond. See “Kidney Shaped Features” on page 644.

Stepping Stone Tools

Select **Terrain > Stepping Stone** to place a walkway made of individual stepping stones.

Stepping Stones are basically **Terrain Features** with material and height attributes typical of walking paths. See “Terrain Feature Tools” on page 643.

There are two ways to draw Stepping Stones:

- Click once to place a stepping stone with end-points that form a 1’ (300 mm) square at that location.
- Click and drag from end-to-end to draw a stepping stone sized as needed. See “Rectangular Polyline” on page 178.

**Polyline Stepping Stone**

The **Polyline Stepping Stone** tool draws rectangular stepping stones. See “Rectangular Features” on page 644.

**Round Stepping Stone**

The **Round Stepping Stone** tool draws stepping stones with rounded edges. See “Spline Feature” on page 644.

Once drawn, Stepping Stones can be selected and edited just like any other Terrain Feature.

By default, Stepping Stones have a concrete material; however, you can specify the material and set the height of Stepping Stones in the **Terrain Feature Specification dialog**. See “Terrain Feature Specification Dialog” on page 654.

Terrain Wall and Curb Tools

Select **Terrain > Terrain Wall and Curb** to draw landscaping walls and curbs that follow the contours of the terrain.

Straight and curved Terrain Walls and Curbs are drawn just as other walls are. See “Creating Walls” on page 193.

**Terrain Walls**

Use the **Straight Terrain Wall** tool to draw a wall that sits on top of and follows the terrain.
Use the **Spline Terrain Wall** to draw a curved terrain wall. This wall is drawn the same way as a CAD Spline. See “Splines” on page 180.

Once drawn, a Terrain Wall can be like other line-based objects. See “Editing Line-Based Objects” on page 126 and “Editing Spline-Based Objects” on page 138.

Terrain walls are 5’ (1500 mm) high and concrete by default, but you can specify the material, height and more in the **Terrain Path Specification**. See “Terrain Path Specification Dialog” on page 658.

### Retaining Walls

The **Retaining Wall** tools function similarly to Terrain Breaks, but include a wall. See “Terrain Breaks” on page 642.

Use the **Straight Retaining Wall** tool draws a straight wall that holds back sloped terrain.

Use the **Curved Retaining Wall** tool to draw a curved retaining wall.

A Retaining Wall’s height is determined by the elevation of the terrain on each side. By default, the height of the wall matches the terrain on the high side of the break and the bottom matches the low side. If you insert a Retaining Wall into flat terrain, it looks like a concrete strip in 3D views.

### Sun Shadows

Sun shadows are generated by the program and represent shadows cast at a particular location on the Earth and at a specific date and time. See “Sun Angles and Shadows” on page 590.

Sun shadows are computed based on the contour of the terrain. If a terrain perimeter exists, the sun shadow adjusts to the terrain.

A sun shadow is automatically rebuilt whenever terrain is rebuilt. If you generate a sun shadow and the terrain is not up-to-date, the terrain automatically rebuilds. You can turn off the automatic rebuild. See “Sun Angle Specification Dialog” on page 592.

### Terrain Curbs

Terrain Curbs are useful for creating curbs around planting beds and along paths.

Use the **Straight Terrain Curb** tool to draw a straight landscaping curb.

Use the **Spline Terrain Curb** tool to draw a curved landscaping curb. This curb is drawn the same way as a CAD Spline. See “Splines” on page 180.

You can specify the height of straight and spline terrain curbs on the **GENERAL** panel of the **Terrain Path Specification**. See “Terrain Path Specification Dialog” on page 658.

**You can also add Fencing to your terrain, complete with gates from the Doors Library. See “Fencing Tools” on page 189.**

### Terrain Objects in the Library

The Library Browser contains a variety of objects that can be placed in a plan’s terrain, including plants, exterior fixtures, accessories and roadway objects. See “The Library Browser” on page 509.

### Displaying Terrain

The display of terrain objects in 2D and 3D views is controlled in the **Layer Display Options** dialog. See “Layer Display Options Dialog” on page 111.

Like other objects, terrain objects are placed in Drawing Groups that affect whether they display in front of or behind other objects. You can modify a selected object’s place in the drawing order by clicking the **View Drawing Group Edit Tools**.
You can customize appearance of Terrain Features, Roads and other terrain objects in plan view by changing their line and fill styles.

Plant images are represented in plan view by 2D CAD symbols. You can select a plant’s symbol in the **Plant Image Specification** dialog. See “Image Panel” on page 673.

**Contour Lines**

When elevation data has been drawn or imported into a plan, contour lines will display in plan views. See “Elevation Data Tools” on page 639.

Home Designer Pro can produce both primary and secondary contours. They are on two different layers so you can control their display separately. Contour line labels use the Text Styles assigned to the “Terrain, Primary Contours” and “Terrain, Secondary Contours” layers.

By default, all contour lines are set to be primary, but you can specify secondary contours, frequency and other attributes of contour lines in the **Terrain Specification** dialog. See “Contours Panel” on page 650.

**In 3D Views**

In order for objects such as Terrain Features and Roads to be visible in 3D views, they must be drawn within the Terrain Perimeter. Any portions of these objects drawn outside of the Terrain Perimeter will not be seen in 3D views. See “Terrain Feature Tools” on page 643.

A variety of tools are available to help you adjust the perspective of your 3D views. See “Editing 3D Views” on page 571.

**Building the Terrain**

When terrain is generated, Home Designer Pro gathers all elevation data that has been added to the model and creates a terrain surface. The program interpolates the data to produce smooth contours.

A terrain perimeter with no additional elevation data drawn within it generates terrain that is flat at the elevation 0' - 0", or sea level.

By default, the terrain is automatically built before a 3D view is generated and when a Sun Shadow is created. This process takes a variable amount of time, depending on the amount of elevation data and number of terrain features in the plan. The **Building Terrain** progress dialog displays as terrain is generated, sometimes only briefly, indicating the progress.

You can turn off **Auto Rebuild Terrain** in the **Terrain Specification** dialog as well as in the **Sun Angle Specification** dialog, and rebuild the terrain manually only when needed by selecting **Terrain > Build Terrain**. When **Auto Rebuild Terrain** is turned off and the terrain is not up to date, the Build Terrain icon displays near your mouse pointer. See “Terrain Specification Dialog” on page 648 and “Earth Data Panel” on page 592.

**Terrain and 3D Drawing Time**

Terrain is typically large with many surface triangles, which often increases the drawing time of 3D views. The time required is affected by the quality of the terrain, the amount of elevation data and number of terrain features present. For information about surface triangles and how they influence terrain quality, see “General Panel” on page 649.

Lights and symbols can be placed outdoors and included in 3D views when the terrain is generated. These objects can also contribute to the time needed to generate 3D views. See “Rendering Tips” on page 583.

**Editing Terrain Objects**

Before a terrain object can be edited, it must be selected. All terrain objects can be selected in plan view. In addition, the Terrain Perimeter and Terrain Features can be selected in 3D views. See “Selecting Objects” on page 123.

A selected terrain object can be edited using its edit handles, edit tools and specification dialog. See “Specification Dialogs” on page 32.

Any time elevation data is changed, the terrain must be rebuilt. This can be done by selecting **Terrain >**
Build Terrain, and occurs automatically when a 3D view is created.

Using the Edit Handles

Terrain objects can be moved, resized, and reshaped using their edit handles. How a selected object can be edited depends on what type of object it is. See “Editing Objects” on page 119.

- The Terrain Perimeter can be moved, resized, and reshaped like a polyline-based objects.
- Elevation Points can be moved in plan view using the Move edit handle.
- Elevation Lines, Elevation Splines and Terrain Breaks are edited like other line- and spline-based objects.
- The shape of a Raised Region, Lowered Region, Hill, Valley, and Flat Region can be edited like a spline.
- Terrain Features are edited like other spline- and polyline-based objects.

Using the Edit Tools

A selected terrain object can be edited in a variety of ways using the buttons on the edit toolbar. The edit tools available for a terrain object depends on the type of object selected. See “The Edit Toolbar” on page 29.

Using Dimensions

Like many other types of objects, terrain objects can be resized and moved using dimensions. For more information see “Moving Objects Using Dimensions” on page 263.

Terrain Specification Dialog

The Terrain Specification dialog controls how your terrain is modeled, as well as its appearance. It can be accessed in any of three ways:

- Select Terrain> Terrain Specification.
- Select the Terrain Perimeter and click the Open Object edit button.
- Double-click the Terrain Perimeter using the Select Objects tool.
General Panel

1. Check Auto Rebuild Terrain to automatically rebuild terrain to reflect recent changes before generating a 3D view or a Sun Shadow. If this option is unchecked and the terrain is not up to date, the Rebuild Terrain icon displays near your mouse pointer. See “Building the Terrain” on page 647.

2. Specify how the Building Pad is generated beneath the structure. See “Foundations and the Terrain” on page 381.
   - To specify the distance between Floor 1 and the terrain at the building footprint center, uncheck Automatic and enter a value in the Subfloor Height Above Terrain field.
   - Check Automatic to have Home Designer Pro automatically lower the terrain relative to the first floor. See “Terrain Height vs Floor Height” on page 638.
   - Check Flatten Pad to flatten the area beneath the building. To create a walkout basement, uncheck this box.

3. Define the thickness of the Skirt added to the terrain. The skirt is only visible in 3D views and gives the viewer a sense of depth when viewing the terrain.
   - Flat specifies that the skirt be flat at its base. Home Designer Pro determines the lowest point in the terrain and then offsets this value by the user specified thickness value. The resulting value is used as a uniform elevation for the base of the skirt.
   - Follow Terrain specifies that the skirt base maintains a consistent distance below the terrain. The distance is equivalent to the specified Thickness value.

4. The Terrain Surface Smoothing settings control the amount of curvature applied to terrain edges.
   - Low produces terrain that has sharp peaks and abrupt changes in slope, while High results in terrain that flows continuously from point to point but may take longer to generate.
   - Select Linear to apply no smoothing to the Terrain. Instead, flat triangular surfaces are created between elevation points. This option is only recommended when large amounts of closely spaced elevation data is present.

5. Triangle Count - Specify the number of surface triangles used to generate the terrain in
3D views. A lower count value will generate more quickly but have reduced quality.

- Specify a **Custom** triangle count value.
- Specify the maximum **Triangle Size** in the terrain surface. Smaller triangles produce better quality results in 3D but take longer to generate.

Home Designer Pro builds 3D terrain surfaces by splitting them into triangles. See “Terrain Surface Triangles” on page 639.

Triangles are computed roughly as follows:

\[
\text{Size of Triangle} = \frac{\text{Area of Terrain Perimeter}}{\text{Number of Triangles}}
\]

The Low (1000), Medium (2000), and High (4000) values work well for a terrain perimeter of approximately 20,000 sq ft (1858 m²). If your terrain perimeter varies greatly from this, consider defining the number of triangles using the **Custom** setting or the **Triangle Size** setting.

**Clipping** - Check **Hide Terrain Intersected by Building** to cut out the portion of the terrain that is intersected by the first floor footprint. Checking this box prevents the generation of contour lines inside the house.

If your foundation footprint differs from your first floor footprint, you may need to use the **Terrain Hole** tool for custom clipping instead. See “Terrain Feature Tools” on page 643.

**Contours Panel**

Home Designer Pro identifies two types of contour lines: Primary and Secondary. They are drawn on different layers, so you can control how they display in plan view. See “Contour Lines” on page 647.

1. Specify the **Frequency** at which contour lines are generated.
   - Define the **Interval** between contour lines, which is the change in elevation between contours. If the interval is set to 12”, a contour line is computed for each elevation change of 12”.
   - Specify the **Offset** value. When the Offset is 0, a contour line will be drawn at zero elevation and additional contours will generate based on the Interval value. If the Offset is changed to 5, a contour line will be drawn 5 units from zero elevation rather than at 0, and additional contours will generate from there.
   - **Primary contour every__contours** - Specify the interval for primary contours. A value of 1 produces only primary contours, while a value of 5 defines every fifth contour line as a primary contour.

2. If contour **Smoothing** is turned on, Home Designer Pro attempts to remove sharp bends and jagged sections from the 2D contour lines.
   - Specify the number of **Passes** to perform when smoothing. The more passes, the smoother the
contour lines become, but contours become less accurate.

3. Control the display of Contour Labels in plan view.

- Check Label Primary Contours to label primary contour lines with their elevation data using the Units specified below.
- Check Label Secondary Contours to label secondary contour lines with their elevation data.
- Check Highlight Negative Elevations to display labels of contour lines with elevations below 0 in red. When unchecked, they use the color set in the Text Style assigned to their layer.

Specify the Label Units used by contour labels. Select either Inches or Decimal Feet (Millimeters or Meters for metric).

4. Polyline Panel

The POLYLINE panel states the length of the Terrain Perimeter’s Perimeter, its enclosed Area, and its Volume.

The settings on this panel are available for a variety of other objects in the program. For information about these settings, see “Polyline Panel” on page 177.

Selected Line/Arc Panel

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. See “Line Panel” on page 168.

The SELECTED ARC panel is available when the selected edge has been converted into an arc. See “Arc Panel” on page 174.

See, too, “Selected Edge” on page 123 and “Change Line/Arc” on page 147.

Line Style Panel

The settings on the LINE STYLE panel are available for a variety of other objects in the program. See “Line Style Panel” on page 169.

Fill Style Panel

The settings on the FILL STYLE panel affect the appearance of the Terrain Perimeter in plan view. See “Fill Style Specification Dialog” on page 115.

Materials Panel

The settings on the MATERIALS panel let you specify the terrain surface and terrain skirt materials used in 3D views. These materials are not calculated in the Materials List. See “Materials Panel” on page 542.

Elevation Point Specification Dialog

To open the Elevation Point Specification dialog, select an elevation point and click the Open Object edit button, or double-click on an Elevation Point using the Select Objects tool.

Use the Elevation Point Specification dialog to define the selected elevation point and control its appearance in plan view.

General Panel
**Location** - Specify the exact location of the elevation point.
- Specify the **Elevation** of the selected Elevation Point.

- **X Position** - Enter the x coordinate of the elevation point.
- **Y Position** - Enter the y coordinate of the elevation point.

**Display** -
- In the **Text** field, type any notes that you would like to display beside the selected Elevation Point in plan view.

**Elevation Line/Region Specification Dialog**

To open the **Elevation Line** or **Elevation Region Specification** dialog, select one or more Elevation Line/Splines, or a polyline composed of elevation Lines/Splines, or an Elevation Region and click the **Open Object** edit button. You can also double-click an Elevation Line/Spline using the **Select Objects** tool.

The **Elevation Line Specification** dialog is used to define the selected Elevation Line/Spline and controls its appearance in plan view.

The settings in this dialog are the same as those in the **Elevation Region Specification** dialog. See “Elevation Regions” on page 641.

**Elevation Panel**

- Specify the **Elevation** of the selected Elevation Line, Spline, or Polyline.
- Check **Interior is Flat** to maintain a flat surface at the specified Elevation. When unchecked, the perimeter of the region maintains the specified Elevation, but the interior elevation may vary depending on other elevation data in the drawing. Only available for closed Elevation Regions.
- Check **Interpolate Tangent to Edge** to flatten the terrain surface as it approaches the edges of the Elevation Region. This option is only available for closed Elevation Regions, and only when Interior is Flat is unchecked.

- Enter the **Marker Radius**, which is the size of the point marker, measured from the center to an edge.

**Line Style Panel**

The settings on the **Line Style** panel are available for a variety of other objects in the program. For information about these settings, see “Line Style Panel” on page 169.

**Text Style Panel**

The settings on the **Text Style** panel control the appearance of the selected Elevation Point’s text. For more information, see “Text Style Panel” on page 284.
Flat Region Specification Dialog

Polyline Panel
The POLYLINE panel states the **Length** of an open polyline or the **Perimeter** of a closed polyline. If multiple Elevation Line/Spline segments form a closed Elevation Region, its **Area** will be calculated. Elevation Lines/Splines do not have a thickness, so they have no **Volume**.

Spline Panel
The SPLINE panel has a single option and is only available when the selected object is an Elevation Spline. See “Splines” on page 180.

**New Segment Angle** - Specify the angle between line segments that are used to draw the spline. Specifying a smaller angle makes the spline smoother. Specify a larger angle to draw the spline faster.

Selected Line/Arc Panel
The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. See “Line Panel” on page 168.

The SELECTED ARC panel is available when the selected edge has been converted into an arc. See “Arc Panel” on page 174.

See, too, “Selected Edge” on page 123 and “Change Line/Arc” on page 147.

Line Style Panel
The settings on the LINE STYLE panel are available for a variety of other objects in the program. See “Line Style Panel” on page 169.

Flat Region Specification Dialog

To open the Flat Region Specification dialog, select a Flat Region and click the Open Object edit button, or double-click a Flat Region using the Select Objects tool. See “Flat Regions” on page 643.

The options in the Flat Region Specification dialog are similar to those in a number of other dialogs in the program.

Polyline Panel
The POLYLINE panel states the length of the region’s **Perimeter** and its enclosed **Area**. Flat Regions do not have a **Volume** measurement. See “Polyline Panel” on page 177.

Spline Panel
The SPLINE panel has a single option. See “Splines” on page 180.

**New Segment Angle** - Specify the angle between line segments that are used to draw the spline. Specifying a smaller angle makes the spline smoother. Specify a larger angle to draw the spline faster.

Hill / Valley Specification Dialog

The Hill/Valley Specification defines the selected Hill or Valley and controls its appearance in plan view.

Fill Style Panel
The settings on the FILL STYLE panel affect the appearance of the selected object in plan view. See “Fill Style Specification Dialog” on page 115.
To open the **Hill/Valley Specification** dialog, select one or more Hill or Valley and click the **Open Object** edit button, or double-click the region(s) using the **Select Objects** tool.

**Hill / Valley Panel**

- **Enter a Height** for the selected Hill or Valley. This height is relative to the terrain surface that is generated from the Elevation Data in your plan. See “Terrain Modifier Tools” on page 643.

**Polyline Panel**

The POLYLINE panel states the length of the hill or valley’s **Perimeter** and its enclosed **Area**. Hills and Valleys do not have a volume measurement.

**Spline Panel**

The SPLINE panel has a single option. See “Splines” on page 180.

**New Segment Angle** - Specify the angle between line segments that are used to draw the spline. Specifying a smaller angle makes the spline smoother. Specify a larger angle to draw the spline faster.

**Line Style Panel**

The settings on the **LINE STYLE** panel are available for a variety of other objects in the program. See “Line Style Panel” on page 169.

**Fill Style Panel**

The settings on the **FILL STYLE** panel affect the appearance of the selected object in plan view. See “Fill Style Specification Dialog” on page 115.

**Raised / Lowered Region Specification Dialog**

To open the **Raised/Lowered Region Specification** dialog, select one or more raised or lowered regions and click the **Open Object** edit button, or double-click the region(s) using the **Select Objects** tool.

The **Raised / Lowered Region Specification** dialog is similar to the **Hill / Valley Specification** dialog. See “Hill / Valley Specification Dialog” on page 653.

**Terrain Feature Specification Dialog**

To open the **Terrain Feature Specification** dialog, select a Terrain Feature or group of Terrain Features and click the **Open Object** edit button, or double-click the Terrain Feature(s) using the **Select Objects** tool.

Most of the panels in this dialog are similar to those for a variety of other objects in the program, including Water Features, Stepping Stones, Driveways, and Parking Lots.

Garden Beds are also a type of Terrain Feature and have an additional Distributed Plant panel in their specification dialog. Garden Beds also have a preview pane on the right side of their specification dialog.
General Panel

- Specify the top **Height** of the Terrain Feature, relative to the terrain surface, using a positive or negative number.
- Specify the feature’s **Thickness**.
  
  If a feature’s height above the terrain is greater than its thickness, the program will fill in the resulting gap.

- Check **Make Hole** to specify the selected Terrain Feature as a Terrain Hole. See “Terrain Holes” on page 644.
- Check **Clip Overlapping Terrain Features** to suppress the 3D display of any part of the selected Terrain Feature intersected by other Terrain Features with a lower Height value. Clipping is useful for creating features that contain other features such as planters or swimming pools.

Distributed Plant Panel

This panel is only available when the selected Terrain Feature is a Garden Bed. See “Garden Bed Tools” on page 644.
Specify the Current Object assigned to the selected garden bed. When an object is assigned, its name and a preview of a single instance of it display here.

- Click the Select button to choose an object from the library. See “Select Library Object Dialog” on page 522.
- Click the Delete button to unassign the Current Object from the selected garden bed.
- Click the Edit button to open the Current Object’s specification dialog. Changes made here affect all objects generated within the garden bed. See “Specification Dialogs” on page 32.

You can replace the plant assigned to a Garden Bed by applying a new one directly from the library. See “Replace From Library” on page 523.

**Display Options** -

- Check Show Objects to display the distributed objects in plan view.

**Object Spacing** - Specify how the objects in the garden bed are spaced.

- Specify the Distance between the objects in the garden bed, as measured from their center points.
- Select Standard Grid to position the objects in rows and columns based on the standard X/Y grid in the program.
- Select Alternate Grid to position the objects in rows and columns based on the shape of the garden bed.

**Object Orientation** - Specify how or if the objects in the garden bed are rotated. These settings do not affect the garden bed itself or its edges.

- Specify the Angle that the distributed objects should be placed at.
- Select Absolute Angle to rotate the objects to the specified Angle as measured from an imaginary horizontal line drawn from the origin towards the right.
- Select Relative Angle to rotate the objects relative to the angle of the region’s first edge or, if that edge is curved, to the angle of its chord. The first edge is typically located at the top of the garden bed when it is first created; however, this can change as the bed is edited.
• Select **Random Angle** to rotate the objects in the region at a variety of random angles.

**Object Positioning** - Specify the positioning of the distributed objects relative to a point of origin within the garden bed.

- Specify the **X Offset**, the horizontal distance in plan view from the garden bed’s specified point of origin.
- Specify the **Y Offset**, the vertical distance in plan view from the garden bed’s specified point of origin.
- Select **From Polyline Center** to measure the offset from the garden bed’s center point.
- Select **Polyline Start** to measure the offset from the garden bed’s start point. This start point is typically located at the top left of the garden bed when it is first created; however, this can change as the garden bed is edited.

A preview of the garden bed displays on the right side of the dialog box. See “Dialog Preview Panes” on page 32.

### Polyline Panel

The POLYLINE panel states the length of the garden bed’s **Perimeter**, its enclosed **Area**, and its **Volume**. See “Polyline Panel” on page 177.

### Spline Panel

The SPLINE panel has a single option and is only available when the selected object is a spline. See “Splines” on page 180.

#### New Segment Angle

- Specify the angle between line segments that are used to draw the spline. Specifying a smaller angle makes the spline smoother. Specify a larger angle to draw the spline faster.

### Selected Line/Arc Panel

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. See “Line Panel” on page 168.

The SELECTED ARC panel is available when the selected edge has been converted into an arc. See “Arc Panel” on page 174.

See, too, “Selected Edge” on page 123 and “Change Line/Arc” on page 147.

### Line Style Panel

The settings on the LINE STYLE panel are available for a variety of other objects in the program. See “Line Style Panel” on page 169.

### Fill Style Panel

The settings on the FILL STYLE panel affect the appearance of the selected object in plan view. See “Fill Style Specification Dialog” on page 115.

### Materials Panel

The settings on the MATERIALS panel affect the appearance of the selected object in 3D views. See “Materials Panel” on page 542.

### Components Panel

The information on the COMPONENTS panel can be used in the materials list. For more information, see “Components Panel” on page 692.

---

**Garden Bed Specification Dialog**

To open the **Garden Bed Specification** dialog, select a Garden Bed or group of Garden Beds and click the **Open Object** edit button or double-click the Garden Bed(s) using the **Select Objects** tool.

**Terrain Break Specification Dialog**

To open the **Terrain Break Specification** dialog, select a Terrain Break or group of Terrain Breaks and click the **Open Object** edit button or double-click the Terrain Break(s) using the **Select Objects** tool. See “Terrain Breaks” on page 642.
General Panel

- Define the Transition Distance, which is the distance from the edge of the terrain break to where the break stops affecting the terrain.

Polyline Panel

The POLYLINE panel states the Length of an open polyline or the Perimeter of a closed polyline. If multiple Terrain Break segments form a closed polyline, its Area will be calculated. Terrain Breaks do not have a thickness, so they have no Volume. See “Polyline Panel” on page 177.

Selected Line/Arc Panel

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. See “Line Panel” on page 168.

The SELECTED ARC panel is available when the selected edge has been converted into an arc. See “Arc Panel” on page 174.

See, too, “Selected Edge” on page 123 and “Change Line/Arc” on page 147.

Line Style Panel

For information about the LINE STYLE panel, see “Line Style Panel” on page 169.

Fill Style Panel

The FILL STYLE panel is only available when multiple Terrain Break segments enclose an area. The settings on this panel affect the appearance of the closed shape in plan view. See “Fill Style Specification Dialog” on page 115.

Terrain Path Specification Dialog

To open the Terrain Path Specification dialog, select one or more Sidewalks, Streams, Terrain Walls or Terrain Curbs and click the Open Object edit button or double-click the terrain path(s) using the Select Objects tool.

Most of the panels in this dialog are similar to those for a variety of other objects in the program.

General Panel

1. **Size** - Enter the **Width** of the object and the **Height** above the terrain. If the Height value is a negative number, the object sinks into the terrain.

2. When one terrain path joins another, you can **Flare** the intersection.

- Check **Start** to create a flare at the starting end of the selected terrain path, then specify the **Radius** of that flare.

- Check **End** to create a flare at that end of the terrain path, then specify the Radius of that flare.
Polyline Panel

The POLYLINE panel states the length of the Terrain Path’s **Perimeter**, its enclosed **Area**, and its **Volume**. See “Polyline Panel” on page 177.

Spline Panel

The SPLINE panel has a single option and is only available when the selected object is a spline path. See “Splines” on page 180.

- **New Segment Angle** - Specify the angle between line segments that are used to draw the spline. Specifying a smaller angle makes the spline smoother. Specify a larger angle to draw the spline faster.

Selected Line/Arc Panel

The SELECTED LINE panel is available when the selected edge is a line as opposed to an arc. See “Line Panel” on page 168.

The SELECTED ARC panel is available when the selected edge has been converted into an arc. See “Arc Panel” on page 174.

See, too, “Selected Edge” on page 123 and “Change Line/Arc” on page 147.

Line Style Panel

The settings on the LINE STYLE panel are available for a variety of other objects in the program. See “Line Style Panel” on page 169.

Fill Style Panel

The settings on the FILL STYLE panel affect the appearance of the selected object in plan view. See “Fill Style Specification Dialog” on page 115.

Materials Panel

The settings on the MATERIALS panel affect the appearance of the selected object in 3D views. See “Materials Panel” on page 542.

Importing Elevation Data

Elevation data can be added to a plan using the tools and techniques described in this chapter or it can be imported from a file.

Home Designer Pro can import elevation data saved in DXF, GPS Exchange (.gpx) and a variety of text file formats (.txt, .csv, .prn, .xyz, .auf and .nez). If your terrain data is not saved in one of these file formats, there are third party programs available that can convert to these formats.

**DXF/DWG Files**

If you have a model of your terrain created on another program that contains contour lines and elevation data, that information can be imported directly as elevation data into Home Designer Pro as a .dxf or a .dwg file. See “Importing DWG/DXF Elevation Data” on page 663.

**Text Files**

Elevation data can be saved in text files as x, y, and z coordinates where x and y define the location of a point on a Cartesian grid, and z defines the elevation for that point. Each data point must be on a separate line in the text file.

Importable text files can come from surveyors, other software programs, or you can create your own using a GPS system.

Elevation data saved in text files can be imported using the **Import Terrain Assistant**.

**GPS Exchange Files**

Elevation data in standard format .gpx files created using a GPS system can also be imported using the **Import GPS Data Assistant**. See “Import GPS Data Assistant” on page 661.
GPS data may include three types of points - Way, Track, and Route. Home Designer Pro can only import a .gpx file if it includes one or more Way Points, and cannot use Route Points at all. If a .gpx file does not include any Way Points, it will not be imported, and if it includes any Route Points, they will be ignored.

Home Designer Pro supports the import of data in standard .gpx files that adhere to the GPX 1.1 Schema. Files that do not follow this standard cannot be imported.

Import Terrain Assistant

The Import Terrain Assistant allows you to import elevation data saved in text (.txt) file format into a plan.

Each data point in this format has information about its X-axis (East to West location), Y-axis (North to South location), and Z-axis (elevation). It might also have a brief description. In order to import elevation data from a text file, you need to know how the data in the file is organized.

To launch the Import Terrain Assistant, select File> Import> Terrain Data . Click Next.

Select File

1. Select a file to import.
   - Click the Browse button to locate a file on your computer. See “Importing Files” on page 47.
   - If a file has been selected, its full pathname displays here for reference; if a file has not been selected, the directory of the last file imported displays. If the pathname is not that of a valid .txt file, this text will display in red.

2. Select the organization of the data.

   Elevation information can be organized in one of six different ways, and can be separated by either a comma (comma delimited) or a space (space delimited).
   - XYZ - Information in this format begins with the X coordinate, followed by the Y coordinate and the Z coordinate.
   - #XYZ - Information in this format begins with a number that belongs to each data point followed by the X coordinate, the Y coordinate, and the Z coordinate.
   - #XYZ Description - Information in this format begins with a number that belongs to each data point followed by the X coordinate, the Y coordinate, and the Z coordinate, and a description.
   - YXZ - Information in this format begins with the Y coordinate followed by the X coordinate and the Z coordinate.
   - #YXZ - Information in this format begins with a number that belongs to each data point followed by the Y coordinate, the X coordinate, and the Z coordinate.
   - #YXZ Description - Information in this format begins with a number that belongs to each data point followed by the Y coordinate, the X coordinate, and the Z coordinate, and a description.

Click Next to continue.
The total number of data points to be imported and the ranges of their coordinates are described here.

Select the **Units** of measurement used for each axis.

Map a data point in the file to the origin in Home Designer Pro to position the terrain data relative to your plan. See “3D Drafting” on page 25.

Change the scale of the terrain.

- Multiply the coordinates of each axis by a specific number to decrease or increase the relative size or relief of your terrain.

**Rotate North Counterclockwise:**

- Specify an amount to rotate the terrain data counterclockwise, or to the left.

Click **Next** to finish.

---

**Import GPS Data Assistant**

The **Import GPS Data Assistant** allows you to import terrain data from the standard .gpx file format. See “GPS Exchange Files” on page 659.

Select **File > Import > GPS Data** to open the **Import GPS Data Assistant**, then click **Next** to continue.

---

Due to the lack of accuracy in some GPS systems, exact distances using the Import GPS Data Assistant are not guaranteed.
1 Select a file to import.

- Click the **Browse** button to locate a `.gpx` file on your computer. See “Importing Files” on page 47.
- If a file has been selected, its full pathname is reported here for reference; if a file has not been selected, the directory of the last file imported displays. If the pathname is not that of a valid `.gpx` file, this text will display in red.

![Import Data As](image)

**Important:** Not all GPS programs use the standard `.gpx` file format; however, only files using the standard format can be imported.

Click **Next** to continue.

Specify which items you want to import by checking the box to the left of the **Name**. Items with unchecked boxes are not imported.

Specify what you would like the selected item to **Import As** from the drop-down list.

- Only Way Points have elevation data associated with them. To import this data, import them as “Elevation Points”.
- Select “Marker” to import either Way Points or Track Points as location markers. Markers have no elevation data associated with them.
- Select “Polyline” to create an open CAD polyline based on the position of Way Points or Track Points. The points themselves are not imported. Polylines have no elevation data associated with them.
- Select “Terrain Perimeter” to create a closed Terrain Perimeter polyline based on the position of either Way Points or Track Points. The points themselves are not imported. A Terrain Perimeter has no elevation data associated with it. See “Terrain Perimeter” on page 638.

![Way Points](image)

Click **Next** to continue.
Converting CAD Objects to Terrain Data

CAD lines, splines, and polylines - either imported or drawn using Home Designer Pro’s CAD Tools - can be selected and converted to terrain data using the Convert Polyline edit tool.

In plan view, select a CAD line, spline, or polyline and click the Convert Polyline edit button to open the Convert Polyline dialog. See “Convert Polyline” on page 151.

If a Terrain Perimeter does not exist in the plan or if a layer in the .dwg/.dxf file is not converted to a Terrain Perimeter, a Terrain Perimeter is created around the extents of the Elevation Data when it is imported.

To avoid unexpected results when importing a drawing, only convert layers with elevation information to Elevation Data.

By default, the Import Drawing Assistant imports entities as regular CAD objects; however, you can specify that any layer in the drawing be converted to either a Terrain Perimeter or Elevation Data. If a layer is converted to Elevation Data, any points and lines on that layer are converted to Elevation Points and Lines, and any elevation data associated with them is preserved.

• If an imported line has vertices with the same Z values, an Elevation Line is created.

By default, the Import Drawing Assistant converts CAD lines, splines, and polylines to elevation data when the Import Drawing Assistant is used.

• If the vertices have differing Z values, an Elevation Point is created for each vertex.

• Imported points are converted to Elevation Points.

• Other imported entities (solids, faces, etc.) are imported normally.

Converting CAD Objects to Terrain Data

Select File> Import> Drawing (DWG/DXF) to open the Import Drawing Assistant, which you can use to import elevation data in .dwg/.dxf format. See “Import Drawing Assistant” on page 626.

Importing DWG/DXF Elevation Data

By default, the Import Drawing Assistant imports entities as regular CAD objects; however, you can specify that any layer in the drawing be converted to either a Terrain Perimeter or Elevation Data. If a layer is converted to Elevation Data, any points and lines on that layer are converted to Elevation Points and Lines, and any elevation data associated with them is preserved.

• If an imported line has vertices with the same Z values, an Elevation Line is created.

1 Lower Elevation Data by:

• Specify the amount that you would like to lower all imported elevation data.

2 Rotate North Counterclockwise:

• Specify an amount to rotate the terrain data counterclockwise, or to the left.

3 Map this point to the origin.

• Specify a point in the imported terrain data, defined by degrees **Latitude** and **Longitude**, that you would like to locate at the origin in the Home Designer Pro plan.

Click Next to finish.

If you do not see the imported terrain, select Window> Fill Window.

To avoid unexpected results when importing a drawing, only convert layers with elevation information to Elevation Data.

Convert Polyline
A Terrain Perimeter must exist before any other types of terrain object can be created. If no Terrain Perimeter is present in the current plan, this will be the only terrain item available in the **Convert Polyline** dialog.

When you click **OK**, the terrain object’s specification dialog opens, allowing you to specify elevation data or other attributes.
Roads and sidewalks are modeled in 3D like other terrain objects in Home Designer Pro. Because they have much in common with terrain objects and rely upon terrain data to be viewed in 3D, it is helpful to be familiar with terrain modeling before using these tools. See “Terrain” on page 637.

Road, Driveway and Sidewalk Tools

Road objects can be drawn in plan view, camera views and overviews, but only when a Terrain Perimeter exists in the plan. See “Terrain Perimeter” on page 638.

Straight and Spline road objects:

- Are typical line- and spline-based objects, and can be edited as such.
- Are flat along their widths, which makes it easy to create roads on sloping terrain.
- Can be joined end-to-end to form intersections and networks.
- Have a consistent width that can be defined in their specification dialogs. See “Road Specification Dialog” on page 667 and “Terrain Path Specification Dialog” on page 658.

Driveways and Parking Lots, on the other hand, are actually Terrain Features which follow the contours of the terrain rather than cut into them. They are drawn as rectangles but can be edited to any shape. See “Terrain Feature Tools” on page 643 and “Editing Closed Polyline-Based Objects” on page 133.

Once road objects have been placed, they can be edited individually or as a group. See “Editing Road Objects” on page 666.

Road Tools

Select Terrain> Road and Sidewalk> Straight Road, then click and drag to draw a line within the Terrain Perimeter to draw a Straight Road.
The ends of multiple road sections can be connected together. Roads are edited along their center line and can be edited much like other line-based objects. See “Editing Line-Based Objects” on page 126.

Select Terrain> Road and Sidewalk> Spline Road, then click and drag to draw a curved road composed of spline segments.

Spline roads are drawn and edited like other spline-based objects. See “Editing Spline-Based Objects” on page 138.

Sidewalk Tools
To create a sidewalk with no curves, select Terrain> Road and Sidewalk> Straight Sidewalk, then click and drag a line within the Terrain Perimeter.

Sidewalks are edited along their center line like line-based objects. See “Editing Line-Based Objects” on page 126.

Select Terrain> Sidewalk> Spline Sidewalk, then click and drag to draw a curved sidewalk composed of spline segments.

Driveway Area
A Driveway Area is a terrain feature with a concrete material assignment. To create a driveway, select Terrain> Road and Sidewalk> Driveway Area, then click and drag from corner to corner to draw a rectangle. See “Polylines” on page 176.

Height, thickness and material information can be specified in a driveway’s specification dialog. See “Terrain Feature Specification Dialog” on page 654.

Driveways can be edited like other closed polylines. See “Editing Closed Polyline-Based Objects” on page 133.

Parking Lot
A Parking Lot is a terrain feature with an asphalt material assignment. To place a parking lot, select Terrain> Road and Sidewalk> Parking Lot, then click and drag from corner to corner to draw a rectangle. See “Polylines” on page 176.

Height, thickness and material information can be specified in a parking lot’s specification dialog. See “Terrain Feature Specification Dialog” on page 654.

Displaying Road Objects
Roads and sidewalks display in floor plan and 3D views based on the settings for their layers in the Layer Display Options dialog. See “Layers” on page 110.

In 3D Views
In order for Road objects to be visible in 3D views, they must be drawn within the Terrain Perimeter.

Any portions of these objects drawn outside of the Terrain Perimeter will not be seen in 3D views.

By default, the terrain rebuilds automatically when road objects are added, removed or edited. If it does not, you can select Terrain> Build Terrain. See “Terrain Perimeter” on page 638.

Editing Road Objects
Road objects can be selected individually and as a group in 2D and 3D views and edited using the edit handles, the edit toolbar and their specification dialogs.

Terrain Walls and Terrain Curbs are also examples of Road objects. See “Terrain Wall and Curb Tools” on page 645.
Using the Mouse

The edit handles available for a selected road object depend on the type of object selected.

- **Straight Roads**, **Terrain Walls**, **Terrain Curbs**, and **Straight Sidewalks** are edited along their centerline like a line or open polyline. See “Editing Line-Based Objects” on page 126.

- **Spline Roads**, **Spline Sidewalks**, **Spline Terrain Walls**, and **Spline Terrain Curbs** are edited along their centerline like CAD splines. See “Splines” on page 180.

- **Driveway Areas** and **Parking Lots** are edited like other closed polyline based objects. See “Editing Closed Polyline-Based Objects” on page 133.

In the Specification Dialog


Using the Edit Tools

A selected road object can be edited in a variety of ways using the buttons on the edit toolbar. See “The Edit Toolbar” on page 29.

Road Specification Dialog

To open the **Road Specification** dialog, select a Straight Road or Spline Road and click the **Open Object** edit button.

Many of the settings in this dialog are similar to those in the **Terrain Path Specification** dialog. See “Terrain Path Specification Dialog” on page 658.

General Panel

1. **Size** - Specify the **Width** and **Height** of the road relative to the terrain.

2. When one road joins another, you can **Flare** the intersection.

- Check **Start** to create a flare at the starting end of the selected road, then specify the **Radius** of that flare.

- Check **End** to create a flare at the end of the selected road, then specify the **Radius** of that flare.

Road flares with 24” Radius
Polyline Panel

The POLYLINE panel states the length of the road’s Perimeter, its Area and its Volume. For more information, see “Polyline Panel” on page 177.

Selected Line/Arc Panel

The SELECTED LINE panel is available when a Straight Road is selected. For more information, see “Line Panel” on page 168.

The SELECTED ARC panel is available when the curved segment of a Straight Road is selected. See “Arc Panel” on page 174.

Spline Panel

The SPLINE panel is available when a Spline Road is selected. Specify the angle between the line segments used to draw the spline. For more information, see “Spline Panel” on page 178.

Line Style Panel

This panel is the same as the LINE STYLE panel in many other specification dialogs. See “Line Style Panel” on page 169.

Fill Style Panel

The settings on the FILL STYLE panel affect the appearance of the selected object in plan view. For information about these settings, see “Fill Style Specification Dialog” on page 115.

Materials Panel

The settings on the MATERIALS panel affect the appearance of the selected object in 3D views. For information about these settings, see “Materials Panel” on page 542.

The material selected here is not calculated in the Materials List. See “Materials Lists” on page 681.
The Plant Tools and sprinklers from the Library Browser allow you to create planting designs and irrigation systems in your terrain.

The Terrain Tools are discussed in their own chapter. See “Terrain” on page 637.

**Chapter Contents**

- Plant Tools
- Plant Chooser Dialog
- Hardiness Zones
- Plant Image Specification Dialog
- Sprinkler Tools
- Sprinkler Specification Dialogs
- Plant Schedules
- Schedule Columns and Numbering
- Plant Schedule Specification Dialog

**Plant Tools**

Select **Terrain> Plant** to add plants to your landscaping plan. Plants can also be placed in a plan directly from the library. See “Placing Library Objects” on page 521.

Plant objects are actually images, which provide realism while avoiding high 3D surface count. Once created, plant images can be selected and edited much like other image objects. See “Editing Images” on page 603.

Select **Terrain> Plant> Plant Chooser** to open the **Plant Chooser** dialog and find plants based on their characteristics and requirements. See “Plant Chooser Dialog” on page 670.

Select **Terrain> Plant> Create Plant Image** to create a plant image. Once a plant image is created, it can be added to the library for future use. See “Creating Images” on page 602.

Select **Terrain> Plant> Grow All Plants** to open the **Grow Plants** dialog.

Click and drag the slider bar and select a growth period from zero to twenty years. This only works for plants that have a mature height and mature age specified in the **Plant Image Specification** dialog. See “Plant Information Panel” on page 674.
Select Terrain> Plant> Show Hardiness Zones to access regional climate zone maps. See “Hardiness Zones” on page 672.

Select Terrain> Plant> Plant Schedule, then click to create a plant schedule. See “Plant Schedules” on page 675.

Garden Beds

Garden Beds are special Terrain Features with material and height attributes typical of planting beds. In addition, you can choose to distribute copies of a plant image within a Garden Bed. See “Garden Bed Tools” on page 644.

Plants Library Catalogs

In the Library Browser, browse to Home Designer Core Catalogs> Plants to access a selection of plant images. Select the library object you want, then click in any view to place it in the plan. See “The Library” on page 509.

A selection of Bonus Catalogs of plants is also available for download. See “Home Designer Bonus Catalogs” on page 514.

In addition, you can add single plants and blocked groups of plants to the library. See “Adding Library Content” on page 517 and “Architectural Blocks” on page 529.

Plant Schedules

The Plant Schedule tool allows you to create customizable plant schedules and plant labels that display schedule numbers. See “Plant Schedules” on page 675.

Plant Chooser Dialog

Select Terrain> Plant> Plant Chooser or click the Plant Chooser button at the bottom of the Library Browser window to open the Plant Chooser.

Use this dialog to search the library for plant images that match your search parameters. You can search using any or all of the options in the Plant Chooser.

The search parameters in this dialog correspond to the settings on the PLANT INFORMATION panel of the Plant Image Specification dialog. See “Plant Information Panel” on page 674.
Type the **Name** of a plant that you would like to find.

- Specify the plant’s **Common Name**, **Scientific Name**, or its **Variety Name**.
- A **Pronunciation** field is also provided. In the Plant Image Specification dialog, it is populated with a phonetic pronunciation guide for the plant’s scientific name.

Check one or more boxes to indicate selected plant **Type** to search for.

Check one or more boxes to specify the selected **Sub-Type** to search for.

Specify the plant **Needs** to search for. These include the **Sun**, **Water**, **Soil pH**, and **Hardiness Zone** range. See “Hardiness Zones” on page 672.

**Flowers and Foliage** -

- Specify the **Flower Color** to search for. Multiple colors can be selected.
- Specify the **Leaf Color** to search for. Multiple colors can be selected
- Specify the **Bloom Time** to search for, which is the season when the plant produces flowers.

Specify the plant **Height** at maturity to search for. This is used with the Grow Plants feature. See “Plant Tools” on page 669.

- An average mature height range can be entered using the **From** and **To** drop-down lists.
- A specific **Height at Maturity** to search for can be entered in the text field.
- A specific **Starting Age**, in months, can be entered in the text field.
- A specific **Age at Maturity**, in months, can be entered in the text field.

Check one or more boxes to search for plants with **Special Characteristics**.
Select which types of plant **Object Type** to search for. 3D Plants are symbol objects, while Plant Images are two dimensional images.

Click the **Search** button at the bottom of the dialog to search for plants that meet your search criteria. The search results display to the right.

Your search results display here.

- The **Number of Items** that match your search criteria is stated.
- Specify whether you want the search results to use the **Common Name** or **Scientific Name**.
- Click on the name of a plant in the list to see its location in the Library Browser.
- Click the **View Item** button to see more information about the selected plant in the **Plant Information** dialog. See “Plant Image Specification Dialog” on page 672.

**Hardiness Zones**

Select **Terrain> Plant> Show Hardiness Zones** to view a selection of regional Hardiness Zone Maps. Click the drop-down list at the top left to select various regions.

**Plant Image Specification Dialog**

Select one or more plant in a plan view or 3D view and click the **Open Object** edit button to open the **Plant Image Specification** dialog.

This dialog can also be accessed by selecting **Terrain> Plant> Create Plant Image**.

The **Plant Information** and **Plant Description** panels are also found in the **Plant Information** dialog, which can be accessed from the **Plant Chooser** dialog. See “Plant Chooser Dialog” on page 670.
Image Panel

1. General -
   - The path and name of the selected plant’s **Image File** displays here.
   - Click **Browse** to specify the saved location on your computer of the image that represents the plant in 3D views.
   - A number of **2D Plant Symbols** are available to represent the image in plan view. Select one from the drop-down list.

2. Specify the **Size/Elevation** of the plant image, as seen in 3D views.
   - Specify the **Height** and **Width** of the image.
   - When **Retain Aspect Ratio** is checked, if you change either the Height or Width, the other value changes to maintain this ratio. If this is unchecked and you resize the plant image, it may become distorted.
   - Click **Reset Original Aspect Ratio** to reset the image’s original aspect ratio and remove any distortion caused by resizing.
   - Select the **Elevation Reference** from the drop-down list. This determines where the next two settings are measured from and also affects their setting labels.

3. Specify the location of the selected plant image’s **Center Point**.
   - Position the selected plant image in reference to the plan coordinates by specifying its **X Coordinate** and **Y Coordinate**.

4. Options -
   - Check **Reverse Image** to reflect the appearance of the image about an imaginary vertical line through its center.
   - Check **Image Always Faces Camera** to prevent the plant image from rotating with the camera.

5. If the selected plant image has been copyrighted, its **Copyright Information** displays here.

Transparency Panel

The settings on the Transparency panel of this dialog are similar to those on the same panel of the Image Specification dialog. For more information, see “Transparency Panel” on page 605.

Plant Information Panel

The settings on the Plant Information panel correspond to the search parameters in the Plant Chooser. See “Plant Chooser Dialog” on page 670.

Plant Description Panel

1 A detailed Description of the plant displays in this text field.
2 Information in the Lighting Comments fields describes the plant’s light requirements.
3 Hardiness Zone Comments are given here. See “Hardiness Zones” on page 672.

Fill Style Panel

The Fill Style panel controls the appearance of the selected plant’s 2D Plant Symbol in plan view. By default, plant images’ fill style is None (Transparent). For information about the settings on this panel, see “Fill Style Specification Dialog” on page 115.

Label Panel

Plant labels display in plan view when the “Plants, Labels” layer is turned on and use the Text Style assigned to that layer. See “Label Panel” on page 286.

Components Panel

The information on the Components panel can be used in the materials list. For more information, see “Components Panel” on page 692.
Object Information Panel
The information entered on the OBJECT INFORMATION panel can be used in Plant Schedules and the materials list. For more information, see “Object Information Panel” on page 693.

Sprinkler Tools

Use the Sprinkler Tools to design a sprinkler system in your plan.

Select Terrain> Sprinkler> Sprinkler Head to open the Select Library Object dialog. Browse to a sprinkler type in the library, click OK, then click in the drawing area to place as many as you need. Once drawn, sprinkler heads can be selected and edited. See “Sprinkler Specification Dialogs” on page 675.

Select Terrain> Sprinkler> Sprinkler Line to draw sprinkler lines in your plan. Sprinkler lines are 2D objects and are drawn and edited much like CAD Lines. See “Line Tools” on page 166.

Select Terrain> Sprinkler> Sprinkler Spline to draw curved sprinkler lines in your plan. Sprinkler splines are 2D objects and are drawn and edited like CAD Splines. See “Splines” on page 180.

Displaying Sprinklers
The display of Sprinkler Heads, Lines and Splines can be controlled in the Layer Display Options dialog. See “Layer Attributes” on page 110.

Sprinkler Specification Dialogs

To open the Sprinkler Specification dialog, select a sprinkler or group of sprinklers and click the Open Object edit button. You can also double-click the sprinkler(s) using the Select Objects tool.

Plant Schedules

A Plant Schedule is a table that lists all of the plants in your plan and can include a variety of information about them, including quantities, common and scientific names, and growing needs. Schedules are dynamically linked to the plants in your plan and update as they are created, deleted, moved, or modified.

In plan view, Sprinkler Head symbols indicate the spray angle.

Sprinkler head display in 3D views; however, Sprinkler Lines and Splines do not.

Sprinkler Heads are counted in the Materials List, as is the total length of Sprinkler Lines and Splines. See “Materials Lists” on page 681.

Editing Sprinklers
Sprinklers can be edited much the way other objects from the library can: using their edit handles, edit tools, and in their specification dialog. See “Editing Library Objects” on page 525.


Sprinkler Lines and Sprinkler Splines also have a specification dialog which is very similar to the Polyline Specification dialog. See “Polyline Specification Dialog” on page 177.

In plan view, select Terrain> Plant> Plant Schedule, then click anywhere in the view to place a schedule at that location. You can continue clicking to place additional copies of the schedule. See “Click-to-Create” on page 103.
Schedules can be edited using the edit handles, the edit toolbar buttons, or the Schedule Specification dialog.

**Using the Edit Handles**

A selected schedule has edit handles similar to those of a CAD box. See “Editing Box-Based Objects” on page 136.

In addition, schedules have edit handles that let you control column widths:

![Resize Column edit handles](image)

*Resize Column* edit handles are located in the Title row, centered on the grid lines that divide the columns, and can be dragged left or right. If a column is resized sufficiently small, the text within will wrap to multiple rows.

**In the Specification Dialog**

The appearance and other attributes of schedules can be modified in the Schedule Specification dialog. See “Plant Schedule Specification Dialog” on page 677.

You can control how plants are listed in a schedule by specifying which Columns to Include in the schedule.

**Using the Edit Tools**

A selected schedule or schedules can be edited in a variety of ways using the buttons on the edit toolbar. See “The Edit Toolbar” on page 29.

- Any objects present in your plan before a schedule is created will be listed first in ascending alphanumeric order, according to their Label information.
- A new, unique objects placed in the plan after the schedule is created will be added to the bottom of the schedule in the order that they are placed, regardless of its Label information.

When an object is edited, its schedule number may or may not change:

- If an object with a Quantity of 1 in the schedule is edited, its position in the schedule will not change.
- If a group of objects listed on the same row in a schedule are edited simultaneously, their position will not change.
- If an object listed on the same row in a schedule with other similar objects is edited so that it is no longer similar enough to share the same row, it will move to the bottom of the schedule. See “Columns and Quantity” on page 676.

**Schedule Columns and Numbering**

Every Plant Schedule has a selection of Columns to Include in its Schedule Specification dialog.

**Columns and Quantity**

It is important to remember that the number of columns you choose to include in a schedule influences the number of separate line items that will be listed in the schedule. For example:

- If you were to uncheck “Common Names” and “Scientific Names” in the Plant Schedule Specification dialog, and then check “Flower Color”, the resulting schedule would list all red flowers in one line item, regardless of their species.
- If you have three paper birch trees in your plan and do not include columns that refer to the trees’ age, such as the Starting Age column, then the three trees will be listed in the same line item - even though one is young, one medium, and one adult.

**Schedule Numbering**

Schedule numbering is dependent on the order in which objects are placed in the plan, as well as the floor they are on.
Plant Schedule Specification Dialog

Plant Schedules can be edited in the **Plant Schedule Specification** dialog. To open this dialog, either select a plant schedule and click the **Open Object** edit button or double-click the schedule using the **Select Objects** tool.

**General Panel**

1. Specify a **Main Title** for the selected schedule. Check **Display** to include the Main Title at the top of the schedule.

2. **Include Options** -
   - **Include Objects from Floor** - By default, only plants located on the floor that the selected schedule was created on will be included in it. You can specify a different floor to include objects from if you wish.
   - To create a schedule of plants on all floors, check **Include Objects from All Floors**.

3. The **Object Preview Options** affect the appearance of previews in the 2D Symbol, 3D Elevation, and 3D Perspective columns.
   - Check **Show Color** to draw 3D Elevation and 3D Perspective plant previews using colored lines. When this is unchecked, lines are black and 3D plant previews are shown in grayscale.
   - Check **Scale Images** to display plant previews at the same relative scale. When unchecked, each preview fills its cell to the extent possible.

4. Check **Use Plan View Scale** to apply the same scale used in plan view to the 2D Symbol column.

Specify which **Columns** are included in the selected schedule. See “Columns and Quantity” on page 676.

- An alphabetical list of all **Available Columns** displays on the left.
- Select one or more names in the list, then click the **Add** button to add them to the Columns to Include list on the right. See “Shift and Ctrl Select” on page 125.
- You can also double-click on an item in the list to add it to the Columns to Include list on the right.
- A list of the **Columns to Include** in the selected schedule displays on the right. The top-to-bottom order in this list corresponds to the columns’ left-to-right order in the schedule. At least one column must be included to create a schedule.
- Select or double-click on an item in the list and click the **Rename** button to specify a new name.
- Click the **Reset** button to restore the default names for all Columns to Include in the current schedule.
• Select one or more items in the list, then click the **Remove** button to remove those items from the list.

• Select one item in the list and click the **Move Up** button to adjust its position upward in the list.

• Select one item in the list and click the **Move Down** button to adjust its position downward in the list.

### Attributes Panel

![Plant Schedule Specification](image)

1. Specify the appearance of the selected schedule’s **Box/Grid**.
2. Check **Display Border** to display lines around the outside of the schedule.
3. Check **Display Grid Lines** to display lines around the rows and columns of schedule, forming boxes around each item, or cell.
4. Specify the **Alignment** of the selected schedule’s text within its columns by choosing an option from the drop-down list.

#### Line Style Panel

The **Line Style** panel is found in the specification dialogs for many different objects. For more information, see “Line Style Panel” on page 169.

#### Fill Style Panel

For information about the settings on this panel, see “Fill Style Specification Dialog” on page 115.

#### Text Style Panel

The settings on this panel control the appearance of the selected schedule’s text. For more information, see “Text Style Panel” on page 284.

### Label Panel

The **Label** panel of the **Plant Schedule Specification** dialog controls the type, size and appearance of the labels that display in plan view.
**General** - Check **Show Labels** to display object labels in plan view. This also turns on the appropriate layer for the objects’ labels in the **Layer Display Options** dialog. See “Layer Display Options Dialog” on page 111.

You can suppress the label for an individual door or window by checking **Suppress Label** in the specification dialog for that object. See “Label Panel” on page 286.

Additional **Label Text** options are available here.

- **Label Prefix** - Specify the leading characters used in callout labels or when Include Schedule # is checked.

When **Use Callout For Label** is checked, the callout shape and size can be specified below. When this option is unchecked, Automatic or user specified labels are used. See “Object Labels” on page 285.

- Select a **Callout Shape**. There are ten shapes to choose from.

When callout labels are used, the schedule numbers are included in the labels. Like other object labels, callout labels use the Text Style assigned to the layer they are on. See “Text Styles” on page 283.

Specify the label **Callout Size**:

- Select **Calculate from Text** for callout labels that are sized to accommodate the text within them.
- Select **Size** and then type the radius in inches (mm). This radius will be used regardless of the size of the label text.
Home Designer Pro can calculate a Materials List in three ways: for All Floors, From Area, or for Room.

Materials Lists can be created, edited, and printed directly from the program. They can also be exported as text, .xml, or .html files for use in other programs.

The Materials List Tools

Select Tools> Materials List to access the Materials List tools.

A Materials List is like a snapshot of the current plan at the time that the list is made. Any changes made to the model after a Materials List is generated are not included in that list. Create a new Materials List if you would like it to include these changes.

It is not necessary to wait until the plan is complete to generate a Materials List. In fact, you can create a series of Materials Lists reflecting costs at various stages of a project.

When you close a Materials List window, the program will ask if you want to save the Materials List. Type a name and click Yes to save the list or click No to close the list without saving it. See “Saving and Managing Materials Lists” on page 688.

Calculate from All Floors

Select Tools> Materials List> Calculate Materials for All Floors to generate a Materials List for the entire model.

Materials lists calculated from all floors can be lengthy, and only a portion of the list may display on your screen at one time. Use the scroll bars to scroll through the complete list. Move the pointer to cells in the list and click to make changes.

Calculate From Area

In plan view only, select Tools> Materials List> Calculate From Area to produce a Materials List for the portion of a plan on a single floor that is included within a temporary rectangular Materials List Polyline.

To use Calculate from Area

1. In plan view, select Tools> Materials List> Calculate from Area.
2. Click and drag to draw a rectangular marquee around the area of the current floor that you would like to produce a Materials List for.
3. When the mouse button is released, a Materials List for the area within the rectangle will display.
Calculate From Area rectangles are temporary and do not display in plan view after the list is created.

**Calculate Materials From Selection**
Select one or more objects and click the Calculate Materials From Selection edit button to create a Materials List that calculates only the selected object(s) and their components.

When the selected object is a room, its moldings and wall, floor, and ceiling finish materials are counted, as is its subflooring; but doors, windows, and structural materials like framing and other structural materials are not.

**Calculate Materials in Room**
To create the Materials List for a room, select the room and then select Tools> Materials List> Calculate Materials for Room.

Calculate Materials in Room is also available on a selected room’s edit toolbar. See “Editing Rooms” on page 230.

A Materials List calculated from a room is created for only the contents of that room: wall materials are not included. An object will be counted in the Materials List if its center point is located inside of the room.

**Calculate Structural Materials for Deck**
The structural materials for a selected deck can be calculated in a Materials List by clicking the Calculate Structural Materials for Deck edit button. See “Decks” on page 234.

**Master List**
Select Tools> Materials List> Master List to open the Master List, a list of previously used materials and any added information such as price or manufacturer. See “The Master List” on page 690.

**Materials List Management**
Select Tools> Materials List> Materials List Management to open a list of saved Materials Lists associated with the current plan. See “Saving and Managing Materials Lists” on page 688.

**Materials List Preferences**
A number of settings that affect the appearance and contents of Materials Lists are found in the Preferences dialog. See “Preferences Dialog” on page 61.

- The Materials List panel lets you specify which Categories are initially included in new Materials Lists.
- The Report Style panel lets you specify which columns are initially included in new Materials Lists, as well as modify the appearance of all Materials Lists.
- The Master List panel lets you specify the current Master List file and the columns used in it.

**Creating an Accurate Materials List**
In order to take full advantage of Home Designer Pro’s Materials List capabilities, there are several things to keep in mind.

- The accuracy of your Materials List is directly related to the accuracy of your model. Floor and ceiling heights, wall lengths, and structural settings all directly affect Materials List calculations.
- It takes more than just making your drawing look right to generate an accurate Materials List. If, for example, you use CAD lines to draw an item on a floor plan, that item will not be included in the Materials List. A better way would be to use a symbol or structural element. See “Architectural vs CAD Objects” on page 99.
- Specify Object Information and Components information before creating a Materials List. Ideally, specify this information in objects’ defaults dialogs or in the Library Browser before placing the objects in the plan.
- If you use custom materials, make sure their material definitions are set up correctly. See “Creating Materials” on page 545 and “Materials and the Materials List” on page 547.
- Bear in mind that using generic objects like geometric shapes from the library to represent objects that aren’t available in Home Designer Pro can result in items being calculated in the Materials List in a manner that you might not expect.
Object Information and Components

Code, Comment, Manufacturer, and Supplier information can be specified for many objects before a Materials List is created. See “Object Information Panel” on page 693.

Price, Extra, Markup, Labor, and Equipment information can also be specified in an object’s specification dialog. See “Components Panel” on page 692.

You can add this information to some objects before they are created in their defaults dialogs. See “Default Settings” on page 57.

You can also add this information to objects placed from the library. See “Editing Library Objects” on page 525.

Material Definitions

The material assigned to structural components like walls, floors and ceilings, roofs, and slabs determines how each component is calculated in the Materials List. See “Calculation Methods” on page 548.

Framing in the Materials List

You can specify whether framing materials are calculated by lineal foot, as a cut list, or as a buy list in the Structural Member Reporting dialog.

For more information about how framing appears in the Materials List, see “Framing and the Materials List” on page 485.

Structural Member Reporting

The Structural Member Reporting dialog allows you to specify the default method used to calculate framing members in the Materials List. There are four options to choose from:

- **Lineal Length** calculates the framing materials of the different structural components of the plan in linear feet.
- **Cut List** calculates the framing materials of the different structural components of the plan by counting the individual pieces present in the model.
- **Buy List** calculates the framing materials of the different structural components of the plan by counting individual pieces and matching them to common board lengths.
- **Mixed Reporting** calculates framing materials using a combination of lineal lengths and piece counts and is recommended for saved Materials Lists in legacy plans.

When a Materials List is active, you can use the Lumber Reporting Method Control drop-down list in the toolbar to choose which method the Materials List uses. This control is not available in the Master List.

Structural Member Reporting Dialog

To open the Structural Member Reporting dialog, select Edit> Default Settings, then select “Structural Member Reporting” from the tree list and click the Edit button. See “Default Settings vs Preferences” on page 57.

You can also open this dialog by selecting Tools> Materials List> Structural Member Reporting or by clicking the Structural Member Reporting button, which can be added to your toolbars. See “To add a button to a toolbar” on page 87.

Choose a Materials List Report Method. The selected method will affect subsequently created Materials Lists, but not any that may already exist.
• Select **Mixed Reporting** to calculate framing materials using a combination of lineal lengths and piece counts.

• Select **Total Lineal Length** to calculate framing materials in linear feet.

• Select **Cut List** to calculate framing materials by counting the individual pieces present in the model.

• Select **Buy List** to calculate framing materials by counting individual pieces and matching them to common board lengths.

• Select the **Length Units** that you want to use from the drop-down list. The selected unit(s) are used in the Materials List when either **Cut List** or **Buy List** is the selected method of reporting. Not available when **Mixed Reporting** or **Total Lineal Length** is selected.

### Organizing Materials Lists

You can control what items are calculated in the Materials List by specifying which categories are used.

In addition, you can control how much information about each item is included by specifying which columns to display.

In addition, you can use the **Lumber Reporting Method Control** drop-down list in the toolbar to choose which method the Materials List uses. See “Structural Member Reporting” on page 683.

There are some parts of a model that cannot be excluded from the Materials List. Floor and ceiling platforms are prime examples. If you need to generate a Materials List for only part of a plan, such as an addition, consider making a copy of the plan file. In the copy, delete the as-built portion of the plan and then generate a Materials List.

---

**Categories**

The line items in the Materials and Master Lists are organized into a set of predefined categories, such as Electrical and Framing, which display in the **ID** column.

You can specify which category each item belongs to in the Materials List and Master List. In addition, many objects can be assigned to a category prior to generating a Materials List in their specification dialog. See “Components Panel” on page 692.

Unlike other categories that calculate materials or objects, the General category lists information about the building’s thermal envelope. See “Conditioned Area Totals” on page 689.
To specify a line item’s category

1. Create a Materials List, open the Master List, or open an object’s specification dialog and go to the Components panel.
2. Click in the cell in the ID column for a line item.
3. Select the desired category from the drop-down list that becomes available.

The categories that are available cannot be altered; however, you can specify which categories are included in the Materials List in either of two ways:
• Globally, in the Preferences dialog. See “Materials List Panel” on page 77.

Subcategories

By default, the Subcategory column of the Materials List is empty for all line items. You can add text to any Subcategory cell by clicking in the cell and typing.

Items can be assigned to a subcategory in the Materials List and, for many items, in their object’s specification dialog in the same manner that they can be assigned to a category. See “Components Panel” on page 692.

Materials List Columns

Each column in the Materials List reports a different category of information about objects in the list. You can specify most of this information for a variety of objects prior to generating a Materials List. See “Object Components” on page 692.

There are two ways to specify which columns are included in the Materials List as well as the order in which they display:
• Globally, in the Preferences dialog. See “Report Style Panel” on page 78.

Materials List Specification Dialog

When a Materials List or the Master List is open, select Tools>Display Options to open the Materials List Specification dialog for the current list.

A table of all of these columns and their capabilities is available in the Materials List chapter of the program’s Help. See “Getting Help” on page 36.

Details Dialog

For information about one or more selected line items in a Materials List, click the Details edit button. The Details dialog displays all Materials List columns for reference, which can be helpful when not all columns are in use in the Materials List. It also lists the Source Object of the selected line item or items.

This dialog will also open when multiple objects located on more than one floor are selected in a Materials List and you click the Find Object in Plan edit button.

When one or more line items located on the same floor are selected, click the Find button at the bottom of the dialog to view their location in a plan view window.

Find Object in Plan

To find out where a line item in the Materials List is located in the model, select its row or any cell in its row and click the Find Object in Plan edit button. A view window opens in which the object or objects associated with that line item are selected.

If a plan view showing the floor that the object is on is open, that view will become active and the object will be selected. If no such view is open, a new unsaved view showing the object’s floor will be created. See “View Windows” on page 93.

If the selected item is a component of a complex object like an Auto Dormer, Mulled Unit, Bay Window, or Architectural Block, the parent object will be selected in the plan instead of the individual component.

Note: The Find Object in Plan tool is not available for wall framing objects.

If the selected row or rows in a Materials List refer to objects on different floors, the Details dialog will open when you click the Find Object in Plan edit button.
The **Master List Specification** dialog is similar to this dialog, but only the **Columns** panel is available. See “The Master List” on page 690.

### Categories Panel

The Categories listed here appear in the ID column of the Materials List in the order they are presented here.

- Check the box beside the name of each category that you want to display in the currently active Materials List.
- Click the **Select All** button to display all categories in the active Materials List.
- Click the **Clear All** button to suppress the display of all categories in the active Materials List.
- Multiple rows can also be selected together using Shift and Ctrl keys. See “Shift and Ctrl Select” on page 125.

Note: The information in a suppressed category is still part of the Materials List. If the Materials List is exported, suppressed categories are exported, as well.

### Columns Panel

- Check the box beside each column you want to include in the Materials List. To suppress a column’s display, remove the check mark next to its name. Columns appear in the Materials List in the order that they display in this list.
- **Move Up** - Click on a column name, then click this button to move that item up one place in the list.
- **Move Down** - Click this button to move the selected column down in the list.

### Options Panel

- Check **Restrict to Floor** to limit the current Materials List to objects on a single floor, then select that floor number from the drop-down list. When unchecked, the Materials List includes all floors.
- If you plan to buy materials from multiple suppliers, you can create a Materials List for each. Check **Restrict to Supplier**, then choose a supplier from the drop-down list. The resulting materials list will include only materials to be purchased from that supplier.
Suppliers can be added to this list in the specification dialog for various objects. See “Components Panel” on page 692.

**Editing Materials Lists**

Materials lists can be edited in a variety of ways. You can adjust the width of a column by clicking and dragging the bar on the right side of the column name.

If a line item has an arrow to the left of its name in the ID column, it represents multiple individual objects. Click the **Expand** edit button to display these individual objects as separate line items; click the **Collapse** edit button to hide them. You can also click the arrow to the left of the name to expand or collapse the line items.

**Adding Information**

You can enter information in the Price, Supplier, Code, Comment and Manufacturer columns for each line item.

Adding price or other information for any item is straightforward. Simply click in the cell and type the desired information. When the information is correct, you can add it to the Master List. See “Adding to the Master List” on page 691.

You can switch between several existing suppliers or manufacturers for a given item by double-clicking on the right side of the cell in an appropriate column. A drop-down arrow displays to the left of the cell. Click it to view a list of suppliers or manufacturers for that item and select one.

When a Materials List is calculated, you can have the program search the Master List for Price, Supplier, and Code information for each item by selecting **Tools> Update From Master**. The information used is marked as “Default” in the Master List.

**Changing Information**

Although the information in some columns cannot be saved to the Master List, you can change the information in any column in an individual Materials List. As with added information, click in a cell to select the existing text, then type in the desired text.

To move an item in a Materials List to a new category, select the cell in the **ID** column and choose a new category from the drop-down list that becomes available. You can also select a subcategory by clicking in the cell in the **Sub Category** column. See “Categories” on page 684.

**Changing Count Units**

The material for a given object component will be counted either by piece; linear feet or meters; square feet or meters; or cubic yards or meters. The same method and unit used in the Count column will be used in the Extra column.

When the Count is linear, area, or volume, you can choose a different unit of measurement:

- Double-click in a cell in the Count column to select and edit it, then choose a unit of measurement from the drop-down list to the right of the selected cell.

- You can also click the **Number Formatting** button when a Count cell is selected to specify the units and accuracy of the value in the selected field. The specified unit is also used in the Extra field for that row. See “Number Formatting Dialog” on page 688, below.

**Tool Tips**

Whenever you mouse over a cell in the Count column, a Tool Tip will display, providing information about the cell’s contents. When the Count is a total length, area, or volume, it may be rounded. The Tool Tip will show the value with greater accuracy.

**Total Cost**

Total Cost for a line item is calculated using the Count, Price, %Markup, Labor and Equipment columns to calculate the cost. The formula used is:

\[
(\text{Count} + \text{Extra}) \times \text{Price} \times (1 + (\% \text{ Markup}/100)) + ((\text{Count} + \text{Extra}) \times \text{Labor}) + ((\text{Count} + \text{Extra}) \times \text{Equipment})
\]

If a column does not appear, 0 is used for the value of that column with the exception of Count and Price, which are always used in the calculation even if they are not shown.
Copying Information

Portions of a Materials List can be copied and then pasted into a Text object or into a word processing program or spreadsheet program using the standard Windows Copy (Ctrl + C), Cut (Ctrl + X), and Paste (Ctrl + V) commands. See “Copying and Pasting Text” on page 276.

Changing the Font

The font used for Materials Lists and the Master List can be specified in the Preferences dialog. See “Font Panel” on page 65.

The size of this font can also be specified in the Preferences dialog. See “Report Style Panel” on page 78.

Number Formatting Dialog

Double-click in a cell in the Count column of the Materials List and click the Number Formatting button to open this dialog and specify the units, formatting, and accuracy of the value in that cell.

The settings in this dialog are also found in the Dimension Defaults dialog. See “Format Panel” on page 251.

Saving and Managing Materials Lists

To save an open Materials List, select Tools> Active View> Save Active Materials List. If the Materials List has not been previously saved, the Save Materials List dialog will open, allowing you to type a short, descriptive name for the list. You will also be prompted to save a Materials List when you close its window.

Once a Materials List has been saved, it is listed in the Materials List Management dialog.

Materials List Management Dialog


Click on the name of a saved Materials List in the list on the left to select it.

- Edit - Open the selected Materials List. You can also double-click an item in the list.
- Rename - Open the Rename Materials List dialog and type a new name for the list.
- Delete - Remove the selected Materials List from the current plan.

Printing and Exporting the Materials List

To print a Materials List, select File> Print while the Materials List window is active. See “Print View Dialog” on page 719.

A Materials List can also be exported into a one of several different file formats that can be opened by various programs. In a Materials List window, or in the Master List, select File> Export Materials List to open the Export Materials List dialog.
Export Materials List Dialog

Specify the **File Type** that you would like to export to.

- Select **Tab Delimited (TXT)** to create a text file with a tab between each field entry in the Materials List, and a carriage return between each row.
- Select **Comma Delimited (CSV)** to create a text file with a comma between each field entry in the Materials List and a carriage return between each row.
- Select **Excel (XML)** to create a file that can be opened by Microsoft Excel.
- Select **HTML** to create an html file that you can view with a web browser.

Additional export options are available here.

- **Uncheck Include Column Headers** to prevent column headings from appearing in the first row of the exported file. Column headers are always included in HTML files.
- **Uncheck Include Hidden Columns** to only export columns currently displayed in the active Materials List. When this is checked, all columns are exported, regardless of whether they are currently displayed.

1 Specify how **Units** of measurement are exported. Currency information is always exported, regardless of the option chosen here.

- Select **Include Units with Amounts** to include units in the same column as the associated value.
- Select **Include Units in a New Column** to report units as text in a new column.
- Select **Do Not Include Units** to not export units at all.

When you click OK, the Write Materials Export File dialog will open. This is a typical File Save dialog. See “Exporting Files” on page 44.

**Estimating Software**

You can export a Materials List to a word processor or spreadsheet program to arrange it in your estimating format. You can also export the Materials List to a number of commercial estimating programs in whose databases you can keep your current pricing, labor costs, and markups and generate reports based on this data.

Before purchasing an estimating software program, be sure that the program supports the direct import of Chief Architect Materials Lists.

Any questions regarding estimating software packages and how they interact with Home Designer Pro should be directed toward the company providing the estimating software. Home Designer Pro is unable to provide any technical support for third party programs.

**Conditioned Area Totals**

Conditioned Area is the space within a building that is heated and/or air conditioned, and a Thermal Envelope is a three dimensional boundary built around the Conditioned Space that separates it from the unconditioned space around it. Thermal Envelopes are composed of floor platforms, ceiling platforms, walls, doors, and windows.

When a Materials List is created, Home Designer Pro calculates the total areas of the components that make up a structure’s Thermal Envelope and lists...
them in the General category of the Materials List. See “Categories” on page 684.

Doors are always categorized as doors rather than as windows. This is the case even when a door is specified as a Glass Door or when it is part of a mulled unit.

Conditioned area totals can be entered into third party programs such as REScheck™ to determine whether the plan meets the energy code in use in your area.

Conditioned Area

With the exception of Unspecified rooms, rooms that are assigned an interior Room Type are included in the Conditioned Area. “Open Below” rooms are also included; however, other hybrid Room Types as well as exterior Room Types are not. See “Room Types” on page 227.

Building Orientation

Walls, doors, and windows are categorized as north-, south-, east-, or west-facing for the purposes of conditioned area totals. These directions are based on the orientation of the plan’s North Pointer. If no North Pointer is used, north is assumed to be straight up on screen in plan view. See “North Pointer” on page 590.

• If a wall is oriented at 45° or less to north in a plan, it will be categorized as a “North” wall. Any doors and windows in this wall will also be categorized as “North”.
• Similarly, walls, doors, and windows oriented within 45° of south, east, or west will be classified as “South”, “East” or “West”, respectively.

The orientation of a curved wall is based on the direction of its chord. See “Drawing Arcs - Arc Creation Modes” on page 171.

The General Category

The General category of the Materials List lists information about the Thermal Envelope of the current plan. The total linear length of each wall type used in the plan is also calculated in the General category. Walls with different heights are each listed separately. See “Wall Type Definitions” on page 208.

The Master List

The Master List saves price, supplier, manufacturer, and other information about items in your Materials Lists and allows you to apply that information to items in future Materials Lists. Select Tools> Materials List> Master List to open the Master List.

Home Designer Pro does not check plans for compliance with building or energy codes.

Home Designer Pro does not check plans for compliance with building or energy codes.

The Master List

The Master List saves price, supplier, manufacturer, and other information about items in your Materials Lists and allows you to apply that information to items in future Materials Lists. Select Tools> Materials List> Master List to open the Master List.

Home Designer Pro allows you to have more than one Master List. Only one can be active, however, and only the active list is updated with new information. You can specify which Master List is active in the Preferences dialog. See “Master List Panel” on page 80.
The Category drop-down list at the top left corner of the window lets you select one particular category for display, or all categories.

As with individual Materials Lists, you can specify which Columns display in the list. See “Materials List Specification Dialog” on page 685.

Use the Find field near the bottom of the window to search for text in the Master List. The search starts from the currently selected cell and moves to the right, then moves down to the next row starting at the left column, and so on, until it finds an instance of the text you entered.

Adding to the Master List

You can edit line items in a Materials List and then add them to the Master List for future use.

To use Update to Master

1. Create a Materials List and change or add information in any editable column of a line item.
2. Select the line item by clicking on its line number on the left side of the list. When selected, then entire line becomes highlighted.
3. Select multiple adjacent rows by holding down the Shift key while clicking.
4. Select Tools> Update to Master. The information in the selected line is saved in the Master List.

Once Master List information exists for a particular item, you do not need to enter it again until you want to update it.

Update from Master

Similarly, items in a Materials List can be updated to include information in the Master List.

To use Update from Master

1. When a Materials List is active, click on a row number to select the row.
2. Select Tools> Update from Master to have the program search the Master List for a record for the selected line item. If an identical record is available, its information is included in the Materials List.
   - Multiple rows can be selected by clicking on one row number, then holding down the Shift key and clicking on additional row numbers.
   - Select all rows by clicking the cell at the top left corner of the Materials List, above the row numbers.

If the Master List contains more than one record for an item, the program references the last one entered. You can override this by defining one specific entry as the default. This is achieved by clicking on the check box in the Def column.

The Master List is almost identical to a Materials List, but has a few additional controls to help with viewing.
Editing the Master List

In the Master List, existing line items can be modified or deleted.

Often, the Master List will include items that you may not want to include in all Materials Lists.

- Check boxes in the **Use** column indicate whether each item is included in the Materials List. If **Use** is unchecked, the item is not included. This is useful in cases where several line items will be purchased as a single unit.
- This **Quantity** column is used to specify how many of an item must be found before information from the Master List is applied to it in a Materials List. If at least this many of the item are found, price, supplier, and other information is used. **Quantity** is useful for applying a quantity discount.
- When more than one line item is available for a specific component or accessory, the **Default** column indicates which item is to be used. Click this column to specify this item as the default. This is useful when a line item has been updated to the Master List more than once with different price, supplier or other information.

To delete a row from the Master List, click on the row number at the far left. The entire row highlights.

Select **Edit** > **Delete**, click the **Delete** button, or press the Delete key on your keyboard.

Object Components

Many architectural objects in the program, from walls to cabinets to images, have components associated with them that are calculated in the Materials List. For example, base cabinets have cabinet box and countertop components.

In addition to their components, some objects also have subcomponents. Cabinet boxes, for example, have doors, drawers and hardware.

Components and subcomponents are specified on the **COMPONENTS** panel of many object specification dialogs.

You can also add and edit information for objects and their accessories in the Materials and Master Lists. See “Editing Materials Lists” on page 687.

Components Panel

Select one or more objects of the same type and click the **Open Object** edit button to open their specification dialog.

The information on the **COMPONENTS** panel can also be edited for objects in the User Catalog of the Library Browser. See “Editing Library Objects” on page 525.

The information on the **COMPONENTS** panel is the same as the Materials List line item(s) for the selected object.
The selected object’s components and their attributes are listed in two tables.

1. The selected object’s components and subcomponents are listed here.
   - Subcomponent names are indented to help distinguish them from main components.
   - Click on a line item to select it and display its Materials List information to the right.

The buttons above the table allow you to manage this list.

   - When a component is selected, click the **Add Line Item** button to add a new component to the list. When a subcomponent is selected, a new subcomponent is created instead.
   - Click the **Remove Line Item** button to remove the selected line item from the list.
   - Click the **Restore Automatic Line Items** to return to the list any previously removed components or subcomponents. Only available when line items have been removed. User-created line items that have been removed are not affected by this option.

2. The left column is a list of column headings found in the Materials List. See “Materials List Columns” on page 685.

3. The Value for each Materials List column can be specified in the right column.

Additional information about how values are calculated may display below the table for some objects: notably, rooms and terrain features.

---

**Object Information Panel**

The **Object Information** panel is found in the specification and defaults dialogs for a variety of different objects. The settings on this panel let you specify information that can then be included in the Materials List and in Plant Schedules. See Materials List Columns in the Home Designer Pro Help.
Specify a **Code**, such as an SKU, for the selected object.

Specify a **Comment** for the selected object.

Specify a **Description** for the selected object.

Specify the selected object’s **Manufacturer**.

Specify the selected object’s **Supplier**.
Chapter 38: Layout

The Home Designer Pro layout facility provides a set of easy to use tools for creating printed construction documents. You can create your own title block and border, then arrange multiple views, notes, and more on a page for printing.

Each layout page can contain multiple views, details, images, CAD objects, or text.

For detailed information about printing in Home Designer Pro, see “Printing and Plotting” on page 707.

Chapter Contents

- Layout Preferences and Defaults
- The Layout Tools
- Creating a Layout File
- CAD and Text in Layout
- Pictures and Metafiles in Layout
- Sending Views to Layout
- Keeping Layout Views Current
- Displaying Layout Views
- Editing Layout Views
- Layout Box Specification Dialog
- Opening Layout Views
- Managing Layout Links
- Printing Layout Files
- Exporting Layout Files

Layout Preferences and Defaults

You can specify the background color of the drawing area in layout files on the COLORS panel of the Preferences dialog. See “Colors Panel” on page 64.

To access the layout defaults for the current layout file, select Edit> Default Settings. The options in the Default Settings dialog are similar to those found in this same dialog in a plan file, although there are fewer choices in the list. See “Default Settings” on page 57.

Drawing Sheet Setup

The settings in the Drawing Sheet Setup dialog are file-specific and are particularly important considerations in layout files. See “Drawing Sheet Setup Dialog” on page 710.

Layout Page Display Options

Select Tools> Layer Settings> Display Options to open the Layout Page Display Options dialog.

This dialog is similar to the Layers Display Options dialog, but controls only the display of objects drawn on the layout page, such as CAD objects, text, dimensions, and imported objects. The display of layout view boxes is also controlled by the Layout Page Display Options - but not the objects within those views.

For information about how to use this dialog, see “Layer Display Options Dialog” on page 111.
For information about controlling the display of objects in views sent to layout, see “Displaying Layout Views” on page 701.

The Layout Tools

There are a variety of tools available to send views to layout and edit them, as well as manage links.

Many of the tools available in layout are described in the Printing chapter. See “The Printing Tools” on page 709.

Select File> Send to Layout to open the Send to Layout dialog and send the current view to the specified layout page. See “Sending Views to Layout” on page 697.

In plan view, select a saved cross section/elevation view symbol and click the Send Camera’s View to Layout edit button. See “Saving and Printing 3D Views” on page 574.

Select a layout view and click the Open View edit button to open the view that was originally sent to layout. This tool is only available for dynamic views. See “Editing Dynamic Views” on page 702.

Select Window> Swap Views to switch between the current view and the view that was current before it. See “Working in Multiple Views” on page 94.

Creating a Layout File

To open an existing layout file, select File> Open Layout. Browse to a directory and select the layout file to open. See “Opening and Importing Files” on page 47.

As with plan view windows, when a layout file is open, it is listed at the bottom of the Window menu as an open view. See “Working in Multiple Views” on page 94.

In order to create a layout file, you must open a new file and then save it.

Choose File> New Layout to create a blank layout file. A layout file is created with the name untitled.layout.

Select File> Save to save the layout file. It is important that you save the layout in the same directory as the plan file from which views will be or have been sent to the layout pages. See “File Management” on page 39.

Although it is possible to use multiple plan files with a layout, it is generally best to associate only one plan file with a layout and to use the same file name for both. If more than one plan file is used, all should be saved in the same directory as the layout file.

When you save your layout, take a moment to also save the plan file associated with it.

When a view is sent to layout, the plan and layout files become linked. If you rename or move either file, this link will be broken and the view will not display. See “Managing Layout Links” on page 704.

CAD and Text in Layout

CAD objects, text objects, as well as dimensions can be incorporated into your layout by both including them in your views sent to layout and by drawing them on the layout page.

On the Layout Page

CAD and text can be drawn directly on the layout page, allowing you to create a title block, border, as well as notes and other annotations.

You can draw dimension lines on the layout page to help position CAD and text objects, as well. Dimensions that locate objects in a view sent to layout, however, should be drawn in the original view. See “Dimensions” on page 249.

CAD, text, and dimensions created in layout can be selected, edited, and deleted just as they can in other views. See “Editing Text” on page 274 and “CAD Objects” on page 161.
In Views Sent to Layout

CAD, text, and dimensions in views sent to layout are scaled just like other objects in the view. If you want text in a layout view to print at a particular size, specify its size based on the scaling you will use when you send the view to layout. See “Character Size” on page 269.

If you rotate a view on the layout page, any text in that view will rotate as well, provided that its Text Style is using the **Rotate with Plan** setting. See “Text Styles” on page 283.

Pictures and Metafiles in Layout

Picture files and metafiles can be included in views sent to layout or imported directly onto a layout page. See “Displaying Pictures, Metafiles, and PDF Boxes” on page 612.

Views can also be sent to layout as pictures embedded in the layout file. See “Static Views” on page 700.

A picture or metafile imported onto the layout page can be selected and edited using its edit handles, edit tools and specification dialog. See “Editing Pictures, Metafiles, and PDF Boxes” on page 613.

Sending Views to Layout

Layout files can contain multiple views sent to it from one or more plan files. To send the active view from a plan file to layout, select **File > Send to Layout**.

You can also send one or more saved, closed cross section/elevation views to layout by selecting the camera symbol and clicking the **Send Camera’s View to Layout** edit button. See “Saving and Printing 3D Views” on page 574.

To send a view to layout

1. Prepare the view so that the desired layer, default, and other settings are in use. See “Dynamic Views” on page 699 for more details.

2. Select **File > Send to Layout**. In the **Send to Layout** dialog, the available options vary depending on the type of view being sent to layout.

3. Click **OK** to send the view to the specified layout page. Depending on the type of view and size of the model, you may see a progress indicator in the Status Bar. See “The Status Bar” on page 33.
Specify the desired **Send Position** for the view. These options are available for all types of views.

- Check **Snap to Active CAD Point** to snap the view you are sending to layout to the active CAD Point. See “Point Tools” on page 163.
- Check **Show Layout Page** to go to the selected layout page when you click OK.

Which **Send Options** are available depends on the type of view being sent to layout.

- Select **Entire Plan/View** to send to layout the extent of the plan that is visible when you click **Fill Window**. This option is available for Vector Views and cross section/elevation views.
- Select **Current Screen** to send only what is shown on screen to layout. This option is available for Vector Views.
- Select **Current Screen As Image** to send only what is shown on screen to layout as an embedded image. See “Picture File Box Specification Dialog” on page 607. This option is available for all views, and is the only option available for rendered views.

The **Camera View Options** are available for cross section/elevation, camera views, and overviews sent to layout - provided that **Current Screen as Image** is not selected, above.

- Select **Live View** to make the view dynamically linked to the plan file.
- Select **Update on Demand** to update the view only when prompted. See “Keeping Layout Views Current” on page 699.
- Select **Always Update** to update the view any time a change is made to the model. This option ensures that the view is always current but may cause program slowness.
- Select **Plot Lines** to send a Vector View to layout that uses automatically generated Plot Lines to represent surface edges and material pattern lines in the model. See “Plot Line Views” on page 700.
- Check **Color Fill** to include colors that correspond to the materials used in the model.
- Check **Use Edge Line Defaults** to use the line weight and color set in the view’s **Layout Box Specification** dialog for all object edge lines. See “Camera View Panel” on page 702. When unchecked, the view uses layer-and/or object-specific settings, per the **Surface Edge Lines** settings in the **3D View Defaults** dialog. See “3D View Defaults Dialog” on page 560.
- Check **Use Pattern Line Defaults** to use the line weight and color set in the view’s **Layout Box**...
4 Select a radio button to specify the method of Scaling for the view sent to layout.

- Select **Fit to Sheet (No Scale)** to send the view to layout at approximately half the size of the layout drawing sheet. Once on the layout page, the view can be resized.
- Specify the **exact scale** for the view in layout. Both Imperial and metric units of measurement are available and can be selected independently.
- When views are sent to layout at different scales, line weights and line styles are subject to the same scaling. See “Line Weights and Scaling” on page 716. In most cases this is not desirable. When **Use Layout Line Scaling** is checked, the lines in views sent to layout appear the same as lines drawn directly on layout. This option is not available for rendered views.

**Keeping Layout Views Current**

It is not uncommon for changes to be made to a plan after views have been sent to layout. In order to make sure that your layout file is up-to-date, it is important to recognize that there are four types of layout views:

- **Dynamic Views**, which update automatically every time changes are made to the original view in the plan.
- **Semi-Dynamic Views**, which fully update when printed or prompted by you.
- **Static Views**, which do not reference the plan and cannot be updated: only replaced.
- **Plot Line Views** have elements that are Dynamic or Semi-Dynamic and others that are Static.

Semi-Dynamic and Plot Line Views can be updated using the **Update Layout View** tools. In addition, a selected view can be updated using the **Update View** edit tool.

**Dynamic Views**

Dynamic views reference the original view in the plan and update automatically whenever changes are made to that view, including:

- Changes to the model.
- Changes to annotations in the view.
- Changes to the layer settings used by the layout view. See “Layout View Layers” on page 701.

In order for a view to be Dynamic, it must be sent to layout using either the **Entire Plan/View** or **Current View Send Option**. In addition, camera views must have **Update Always** specified. See “Send To Layout Dialog” on page 698.

While convenient, Dynamic views require use of your computer’s resources and may slow program performance. Consider sending cameras, overviews, and cross section/elevations to layout as Semi-Dynamic views.

For the most part, plan views sent to layout are Dynamic; however, a number of elements are Static. In order to modify these elements in a view, you need to delete the view and resend it.

- The default **Display in Plan View** and **Display of Openings in Non-Displayed Parts of Walls** settings for pony walls are a permanent part of the layout view. See “Pony Wall Defaults” on page 185.
- The floor level shown in a view sent to layout does not change if you move to a different floor in the plan. See “Multiple Floors” on page 387.
- The **Reference Display** setting in a view sent to layout is unaffected if the Reference Display is turned on or off in the plan. See “The Reference Floor” on page 393.
- The **Color** setting in a view sent to layout is unaffected if Color is toggled on or off in the original view. See “Color On/Off” on page 114.
- The **Rotate Plan View** angle is a permanent part of the layout view. See “Rotate Plan View” on page 94.

For information about controlling the display of dynamic views in layout, see “Displaying Layout Views” on page 701.
**Semi-Dynamic Views**

Camera views, overviews, and cross section/elevation views can all be sent to layout as Semi-Dynamic views. Semi-Dynamic views reference the original view in the plan but no information about the model or the view’s layer settings update unless you prompt the layout view to update.

When a cross section/elevation view has been sent to layout, CAD objects, text, and dimensions in that view are fully Dynamic - even if the view is set to **Update on Demand**. See “Detailing Cross Section/Elevation Views” on page 564.

In order for a view to be Semi-Dynamic, it must be sent using either the **Entire Plan/View** or **Current View** Send Option and have **Update on Demand** specified. See “Send To Layout Dialog” on page 698.

There are several ways to update a Semi-Dynamic view:

- Select it and click the **Update View** button;
- Click the **Update All Views** button; or
- Click the **Update All Live Views** button.

- Update on Demand views also update automatically when you print the layout page that they are on.

Views set to **Update on Demand** may experience a loss in quality as you zoom and pan on the layout page. To restore a view’s resolution, simply update it.

**Static Views**

Static views are like a snapshot of the model taken at a specific time: they do not update when the plan changes. If changes to the plan need to be shown in a Static view, that view must be deleted and resent to layout.

All views sent to layout using the **Current Screen as Image** option are Static. They are treated as imported images embedded in the layout file. See “Picture File Box Specification Dialog” on page 607.

**Plot Line Views**

Camera views, overviews, and cross section/elevation views using the Vector View Rendering Technique can be sent to layout as Plot Lines. See “Rendered and Vector Views” on page 558.

In Plot Line views, the lines in the layout view that represent the 3D model are automatically generated copies of those in the original view, allowing them to maintain the line weights that were specified in the plan. See “Line Weights” on page 716.

- Plot Line views are Semi-Dynamic in that they are linked to the original view and can be updated.
- Plot Line views are Static in that they will not update automatically when printed: they can only be updated manually by you.
- Any CAD objects, text, or dimensions drawn in a cross section/elevation view sent to layout will not be copied and represented by Plot Lines. These objects are fully Dynamic and will update immediately in the layout view if changes are made to them. See “Detailing Cross Section/Elevation Views” on page 564.

- The **Color** setting in a Plot Line view is unaffected if Color is toggled on or off in the original view in the plan. See “Color On/Off” on page 114.

- Image objects are not included in Plot Line views. See “Images” on page 602.

Plot Line views do not automatically update when printed, nor can they be set to update automatically. In order to update a Plot Line view, you must do one of the following:

- Select it and click the **Update View** button;
- Click the **Update All Views** button; or
- Click the **Update All Plot Line Views** button.

In addition, if a camera view sent to layout using the **Plot Lines** option and the camera view is later closed while the layout sheet is open, you will be asked to choose whether to update the view on the layout page.

- If the layout view is up-to-date with the 3D model or if you do not want your changes to be seen in the layout view, select **No**.

- To update the view on the layout page choose **OK**.
Displaying Layout Views

Just as some elements in a view window do not print, they are not included when a view is sent to layout: for example, the Reference Grid and camera symbols in plan view. See “Print Preview” on page 713.

Layout View Layers

When a view is sent to layout, the current layer display settings are used. See “Layer Attributes” on page 110.

The layer settings of a selected Dynamic or Semi-Dynamic layout view can be edited if you click the Open View edit button to open the original view in the plan. Please be aware that if you open the original view in this manner and then Save the plan, the layout view and the original view will share the same layer settings going forward. You should only do this if you want a layout view with layer settings that update whenever changes are made in the plan.

If you would like to change the layer settings of a layout view, consider deleting it and sending a new view to layout with the desired layer settings.

Editing Layout Views

To edit a layout view, first select its layout box using the Select Objects tool. Once selected, the view box can be edited using its edit handles, edit toolbar or specification dialog. See “Layout Box Specification Dialog” on page 702.

Using the Edit Handles

Layout view boxes can be edited like closed polyline-based objects. See “Editing Closed Polyline-Based Objects” on page 133.

Plan views can be rotated. Both the layout box and the view inside it rotate. Cross section/elevation and 3D views sent to layout cannot be rotated.

In the Specification Dialog

Layout view boxes can be customized in their specification dialog. See “Layout Box Specification Dialog” on page 702.

Layout Box Borders and Labels

A border will display around each layout box when the “Layout Box Borders” layer is set to display in the Layout Page Display Options dialog. See “Layout Page Display Options” on page 695.

Layout boxes can also display labels when the “Layout Box Labels” layer is set to display. See “Object Labels” on page 285.

Automatic layout box labels display basic information about the original view in the plan. For example, plan view sent to layout from Floor 1 will have an automatic label that says, “1st Floor”. A camera view sent to layout will have a label that states the camera’s name. Layout box labels can be customized in the Layout Box Specification dialog. See “Label Panel” on page 703.

Missing Layout Views

If a view on the layout page can be selected but cannot be seen, its link to the plan from which it was sent may have been broken. See “Managing Layout Links” on page 704.

Using the Edit Tools

A selected layout view or views can be edited in a variety of ways using the buttons on the edit toolbar. See “The Edit Toolbar” on page 29.

Using Dimensions

Like other CAD based objects, layout views can be moved and resized using dimensions. See “Moving Objects Using Dimensions” on page 263.

Copying Views

Just like many objects, views sent to layout can be copied and pasted into different layout files. As a general rule, though, if multiple copies of a view are needed, it is best to send the view to layout as many times as necessary because each view can then be controlled independently.

Bear in mind, too, that if a layout has views copied from a different layout file and is later moved to a different location on your computer, the link to the original plan file may be broken. See “Keeping Layout Views Current” on page 699.
Editing Dynamic Views

Select a Dynamic or Semi-Dynamic view and click the Open View button to open the original view that was sent to layout. You can also double-click a view of either type in layout to open the original view. See “Opening Layout Views” on page 703.

Resizing Scaled View Boxes

Scaled views retain their scale regardless of how you resize the border. If the border is increased in size, blank spaces may be created; if the border is made smaller, the view may become cropped.

Resizing Non-Scaled View Boxes

If the view was sent to layout using the Fit to Sheet setting, or if a view is set to Fit to Drawing Sheet in the Change Scale dialog, resizing may have one of two results:

- Drag a corner edit handle using the Alternate Edit Behavior to resize both the border and the image proportionally. See “Alternate” on page 120.
- If you use any other Edit Behavior or if you drag a side edit handle, the perimeter of the layout box changes but the view inside it stays the same size. If you make the border smaller, the view may become cropped.

Layout Box Specification Dialog

Select a layout view and click the Open Object edit button to open the Layout Box Specification dialog.

Plan View Panel

The PLAN VIEW panel is only available when the selected view is a plan view. See “Dynamic Views” on page 699.

Specify the Number Height for Dimensions in the selected view. This setting is only available for views sent to layout from plan view. It affects the size of dimension numbers in the layout view but not in the original view in the plan file.

Camera View Panel

The CAMERA VIEW panel is only available when the selected view is a Live View or Plot Lines view. See “Dynamic Views” on page 699.
The Camera View Options are available for Dynamic and Semi-Dynamic cross section/elevation, camera views, and overviews sent to layout. See “Keeping Layout Views Current” on page 699.

- Select Live View to make the view dynamically linked to the plan file.
- Select Update on Demand to update the view only when prompted. See “Keeping Layout Views Current” on page 699.
- Select Always Update to update the view any time a change is made to the model. This option ensures that the view is always current but may cause program slowness.
- Select Plot Lines to use automatically generated Plot Lines to represent surface edges and material pattern lines in the model. See “Plot Line Views” on page 700.
- When Plot Lines is selected, check Color Fill to include colors that correspond to the materials used in the model.

Polyline Panel
The POLYLINE panel states the length of the countertop’s Perimeter, its Area, and its Volume. See “Polyline Panel” on page 177.

Opening Layout Views
Dynamic and Semi-Dynamic views sent to layout refer to an original view in a plan. From the layout page, you can access that original view by selecting a layout box, then clicking the Open View edit button. The original view can also be opened by double-clicking the layout view using the Select Objects tool.

Changes made in this view update in the original layout view when the plan file is saved. Be aware that depending on the changes you make, other views may also be affected.
Layer Sets

Bear in mind, too, that when you open a view to edit it, any changes that you make to your layer settings will be reflected on the layout page. When you are finished making changes to your layout view and wish to resume work on the plan, save your work, close the plan, and then open it again. This will help avoid unintended changes to your layout view.

Managing Layout Links

Careful file management is needed to avoid missing files and disrupted layout links. See “File Management” on page 39.

The following guidelines can help prevent layout links from being broken:

- Save plan files in the same folder as the layout, or in a sub-folder in that folder.
- Custom graphics included in a plan or layout should be embedded in the file or saved in the same folder as the layout.
- Plan files should never be renamed. If a new name is desired, make a copy of the file and rename the copy. Changes made in the copy do not affect views sent to layout from the original plan.
- Avoid sending cross section/elevations to layout more than once. Changes made to the view can affect layout views in unintended ways.
- Layout files should never be moved. If a layout file must be moved, the entire folder it is saved in should be moved or copied and then moved.
- Use File> Backup Entire Plan to create an independent copy of the original layout. Avoid use of “Save As.” See “Backup Entire Plan or Project” on page 49.

Finding Missing Files

When a layout file is opened, the program performs a breadth-first search for dynamically linked views. This means that it:

- Looks first in the same folder as the layout.
- Looks next in the folders located closest to the layout’s folder.
- If a missing file is not found, it expands its search further from the location of the layout file until the files with the linked views are located.
- If a missing file is not found, a second breadth-first search will be performed, searching all zipped files found in the first search.

If a file remains missing after the program performs a search of your system, a Warning message will indicate that the program could not successfully open all of the layout’s associated plan files. When you click OK, the Referenced Plan Files dialog will open, allowing you to relink the layout to its missing associated files.

Referenced Plan Files Dialog

1. The Plan Files Present section lists all files with intact links to the layout.
2. The Plan Files Not Found section lists the names of files with disrupted links to the layout. Any files listed here have been moved,
renamed, or deleted and cannot be found by the program. Intervention is required to find these files and reestablish their links to the layout.

Select a missing file and click the **Browse** button just above the **Plan Files Not Found** field to open the **Browse For Missing File** dialog, which is a typical **Open** dialog. See “Opening and Importing Files” on page 47.

- Locate the missing file in your system’s directory structure. When the missing file is selected, click **Open** to link it to the layout.
- You can also redirect an intact link to from a File Present in Layout to a different file in the same manner.

Be sure to choose **File> Save** in the layout file when the missing files have been located to save their links to the layout file.

### Results of Missing Files

If all missing files are correctly redefined, the layout opens when you click **OK**.

If an error message displays, one or more of the missing files could not be replaced by the redefined file. Click **OK** to continue. The layout opens, but with the following characteristics:

1. Any plan views associated with the missing file(s) are blank. Only the border displays if the “Layout Box Borders” layer is set to display. See “Layout Page Display Options” on page 695.
2. Any elevations or cross sections associated with the missing file(s) show the automatically generated lines, but any added CAD objects are absent.

### Printing Layout Files

Printing layout files is similar to printing a view in a plan file. Select **File> Print> Print** to open the **Print** dialog. See “Print View Dialog” on page 719.

As in plan views, printing options for layouts are set in the **Drawing Sheet Setup** dialog for that layout file. See “Drawing Sheet Setup Dialog” on page 710.

### Printing to Scale

A layout file’s drawing scale is specified in the **Drawing Sheet Setup** dialog. While you can specify any drawing scale that you wish, in nearly all circumstances, you will want the scale to be **1 in = 1 in** or **1 mm = 1 mm** for all layout files.

The views sent to your layout pages have already been assigned a scale, and if you select a scale other than one-to-one for the layout, these views will be scaled a second time when printed.

![Layout views will print at their specified scales only when the drawing scale for the layout file is 1 in = 1 in or 1 mm = 1 mm.]

### Exporting Layout Files

A layout can be exported to a .dxf file much like any other vector-based view.

The main difference is in the scale of the output, which is in scaled paper units rather than model units. If a 50” line in a plan would be scaled to 1” inch when printed, it is exported as a 1” line instead of its length before prior to scaling. See “Exporting 2D DXF/DWG Files” on page 629.
Chapter 39: Printing and Plotting

Home Designer Pro provides a variety of printing options, from printing scaled plan views and 3D perspectives, to a set of templates that can be assembled into a 3D model.

To create working drawings, you can use the program’s Layout facility. Multiple views of the model can be arranged on pages along with a border and title block. For more information, see “Layout” on page 695.

Home Designer Pro also allows you to save your drawings in .pdf file format that can then be sent to a printing service.

Note: Screen captures are provided for illustrative purposes only and are not an endorsement of any products.

### Introduction to Printing

Home Designer Pro offers printing options to suit a variety of needs. It is helpful to be familiar with these options and choose the one that makes the most sense for the project at hand.

**Output Options**

**Printing From Layout** - For professional quality documents with a title block, border, and multiple views of the model, printing from layout provides the best results. For more information, see “Layout” on page 695.

**Printing Directly From a View** - You may prefer to print individual drawings directly from a view. See “Print Tools” on page 709.

**Printing to PDF** - Plans can be printed to a .pdf file and printed remotely. See “Printing to a PDF File” on page 715.

**Export to STL** - Exports an .stl file that can be printed on a stereolithography machine, or 3D printer. See “STL Format” on page 635.
Terminology

**Drawing Sheet Size** - The dimensions of the final printed output. This may or may not be the same as the printer paper size. If the sheet and paper sizes are the same, only one page is required per sheet. See “Drawing Sheet Setup Dialog” on page 710.

**Paper Size** - The dimensions of the paper to be printed on. Specifying a paper size that is smaller than the Sheet Size allows large drawings to be printed across multiple pages.

**Check Plot** - A test printing, typically at a smaller scale, made before final output to large paper format. For more information, see “Check Plots” on page 715.

**Line Weight** - The thickness of a line. A thicker line weight is easier to see, but may not show as much detail. See “Line Weights” on page 716.

Drawing Scale - Drawings are often printed to scale for accuracy. \( \frac{1}{4}'' = 1' \) and \( 1 \text{ m} = 50 \text{ m} \) are examples of common scales. You can specify this scale in the **Drawing Sheet Setup** dialog. See “Drawing Sheet Setup Dialog” on page 710.

When a particular scale is not important, drawings can also be sized to fill a particular area. See “Printing to Scale” on page 714.

Printing Problems

If you encounter difficulties when trying to print, see “Troubleshooting Common Technical Issues” on page 422.

Printers and Plotters

There are many different types of printers and plotters. In general, a printer is smaller, normally outputting 8½ x 11” (Letter or ANSI A size), 8½ x 14” (Legal Size) or sometimes as large as 11 x 17” (Tabloid or ANSI B size).

Plotters are typically used to output larger sheets of paper such as 17 x 22” (ANSI C), or 18” x 24” (ARCH C).

**Printer Drivers**

A printer driver is a program that allows a printer to communicate with the rest of the computer system. Drivers are usually created by the printer manufacturer, are typically updated regularly, and can usually be downloaded free of charge from the manufacturer’s web site.

In addition to interpreting between the printer and the rest of the system, printer drivers save default page size, orientation, margin size, and other information that Home Designer Pro refers to unless you specify otherwise. See “Print View Settings” on page 709.

If you experience printing problems, consider installing updated drivers for your printer. Visit your printer manufacturer’s web site for more information.

Printing to File

If your print service requires you to print to a file that can be read by their plotter, you can install that printer’s drivers on your system and then use the Windows **System Print** dialog to Print to File. See “Print View Dialog” on page 719.

Please note that printing to a file is not an option in the Mac System Print dialog.

Clearing Printer Information

Some information specific to individual printers and plotters, such as available paper sizes, is saved with each plan and layout file. You can select **File > Print > Clear Printer Info** to clear the printer-specific information stored with the plan or layout file.

Printing Defaults

You can print to any printer or plotter that is supported on your operating system and can specify the current printer at any time in either the **Drawing Sheet Setup** or **Print View** dialog.
The Printing Tools

Drawing Sheet Setup

When any orthographic view is active, you can specify its Drawing Sheet size, margins, orientation, printed Drawing Scale, and more in the Drawing Sheet Setup dialog. Select File> Print> Drawing Sheet Setup to open this dialog. See “Drawing Sheet Setup Dialog” on page 710.

The settings in the Drawing Sheet Setup dialog are view-specific. This means that in a plan file, they can be set up one way for plan views and a different way for each cross section/elevation view. When a new view is created, its initial settings are derived from the current plan view settings.

The Drawing Scale set in the Drawing Sheet Setup dialog acts as the default scale for the active view’s Print, Printed Size Input, and Send to Layout dialogs. See “Send To Layout Dialog” on page 698.

Print View Settings

When you are ready to print an orthographic view, select File> Print> Print. The initial settings in the Print View dialog are drawn from the Drawing Sheet Setup for the view. The system’s default printer is selected and if possible, the paper size and orientation are set to match those of the Drawing Sheet.

Once a view has been printed, most of the settings in the Print View dialog are saved and will be applied to all views of the same type, in all Home Designer Pro files. View types with separate Print View settings are:

- Plan view
- Cross Section/Elevation views
- Layout
- Materials Lists

If you prefer that the Print View settings not be retained in this manner, uncheck Remember Print Settings after Printing in the Drawing Sheet Setup dialog.

Displaying Objects

You can control the display of objects when printing directly from a view in the Layer Display Options dialog. See “Layer Display Options Dialog” on page 111.

Objects must be visible in order for them to print; however, not all items that are visible will print. See “Print Preview” on page 713.

To control the display of objects in a camera view sent to layout, turn layers on/off in the view before it is sent to layout.

Print Preview

To get a sense of whether your current settings will meet your needs when printed, you can use the Print Preview toggle to view the printed output on screen before any paper is used. See “Print Preview” on page 713.

The Printing Tools

Select File> Print to view the Print Tools submenu. These tools fall into four categories.

Print Setup Tools

Drawing Sheet Setup - Opens the Drawing Sheet Setup dialog. See “Drawing Sheet Setup Dialog” on page 710.

Scale to Fit - Automatically selects a scale that fits your plan to the drawing sheet. See “Printing to Scale” on page 714.

Center Sheet - Automatically centers the drawing sheet on your drawing. See “Center Sheet” on page 714.

Print Preview - Shows on screen how the current view will appear printed, based on the current scale and other settings. See “Print Preview” on page 713.

Print Tools

Print - Prints the current plan view, Vector View, or layout sheet to a specified scale. See “Print View Dialog” on page 719.

Print Image - Prints the current view including images, textures, and backdrop. Views printed with Print Image are not scaled. See “Print Image Dialog” on page 721.

You can also select File> Export> Export PDF to open the Export PDF dialog. See “Print View Dialog” on page 719.
Display Toggles

A number of toggles allow you to turn various aspects of the display on or off. See “Interface Toggles” on page 26.

- **Color** - Turn the on-screen display of color on or off in all views except perspective views. See “Color” on page 713.

- **Line Weights** - When this is on, line weights appear on screen as they will print. See “Line Weights” on page 713.

- **Drawing Sheet** - Turn this on for a preview of your plan relative to the current Drawing Sheet. See “Drawing Sheet” on page 713.

Reference Grid - The Reference Grid does not print, so you can turn this off to get a better sense of what the view will look like printed. See “Reference Grid” on page 713.

Additional Print Tools

- **Customize Sheet Sizes** - Allows you to create custom sheet sizes. See “Customize Sheet Sizes Dialog” on page 712.

- **Clear Printer Info** - Clears the printer information associated with the current page setup.

Drawing Sheet Setup Dialog

Select File > Print > Drawing Sheet Setup to open the Drawing Sheet Setup dialog.

The **Drawing Sheet Setup** dialog is only available when a plan view, cross section/elevation view, or layout is active.

The settings in this dialog are specific to the current view and are saved with the .plan or .layout file. See “Printing Defaults” on page 708.
Specify the **Orientation** and **Size** of the **Drawing Sheet**, which is the final printed output.

- Click the **Customize** button to open the **Customize Sheet Sizes** dialog. See “Customize Sheet Sizes Dialog” on page 712.

Check **Show Drawing Sheet in View** to turn on the display of the Drawing Sheet in orthographic views. See “Drawing Sheet” on page 713.

Specify the **Drawing Scale** for the active view. This scale is applied only when the view is printed.

The **Drawing Scale** acts as the default scale for the active view’s **Print**, **Print Size Calculator**, and **Send to Layout** dialogs.

Specify the **Printer for View** which is the printer for the active view in the current file. These settings are global, affecting all plan and layout files.

- Uncheck **Remember Print Settings after Printing** to enable the **Choose** button, below. When this is checked, the printer is selected in the **Print View** dialog. See “Printing Defaults” on page 708.

- Click the **Choose** button to select a printer and edit its paper settings in the **Default Printer for View** dialog.

The name of a **Printer** displays to the left of the **Choose** button for reference.

- If the **Remember** box is checked, the last printer used in the current view type is shown; if no printer has been used in the current view, “None” will display.
If the Remember box is unchecked, the system’s default printer will be shown.

If you have questions about your printer’s settings, consult its documentation.

Specify the Drawing Margins which define the extents of the printable area of the active view’s Drawing Sheet.

Click the Populate from Printer button to set the margins based on the selected printer’s default settings. See “Printers and Plotters” on page 708.

Specify the width of the Top, Bottom, Left, and Right margins.

The Advanced Line Weight Options allow you to specify the active view’s line weight scale. A layout file’s line weight scale should always be the same as that of any plan views associated with it. See “Line Weights and Scaling” on page 716.

Check Use 1 for all line weights (Home Designer compatibility) to have the program maintain a consistent line thickness and dash size when the drawing scale is changed. When checked, the Line Weight Scale is based on a 1/4 inch = 1 foot drawing scale and 1 = 1/300 inch line weight scale. This option is not available for layouts and is not normally recommended. See “Line Weights” on page 716.

Select the Line Weight Scale. See “Line Weights and Scaling” on page 716. This setting should always be the same for both a given layout file and any plan views associated with it.

A line weight Preview illustrates how changes to the line weight scale affect the printed size of various line weights at the current Drawing Scale.

Default Printer for View Dialog

To open the Default Printer for View dialog, click the Choose button in the Drawing Sheet Setup dialog.

Select a Printer from the drop-down list.

Choose the Orientation of the paper used by the selected printer.

Select a Paper Size from the drop-down list. The options available will depend on the selected printer.

Select a Paper Source from the drop-down list. The options available will depend on the selected printer.

Customize Sheet Sizes Dialog

To open the Customize Sheet Sizes dialog, select File > Print > Customize Sheet Sizes, or click the Customize button in the Drawing Sheet Setup dialog.

Several options are available:

Click New to create a new sheet size.

Select a sheet size and click Copy to create a duplicate sheet size.

Click Delete to remove the selected sheet size.

Select a sheet size and click Edit to open the Edit Paper Size dialog and change its description, dimensions, and units of measurement.
Print Preview

Print Preview and its related display toggles allow you to get a sense of what the current view will look like when it is printed.

Print Preview

Select File> Print> Print Preview for an on-screen representation of how the current view will appear when printed. Print Preview is only available in views that can be scaled. See “Printing to Scale” on page 714.

When Print Preview is on, the Drawing Sheet and line weights are displayed, and the toggle buttons Drawing Sheet and Line Weights are overridden.

Objects such as camera symbols, CAD points, and the Snap and Reference Grids that do not print do not display in Print Preview. Text and dimension objects appear on-screen as they will on the printed page.

When Print Preview is enabled, color will display depending on whether Print in Color is selected in the Print View dialog. See “Print View Dialog” on page 719.

The Reference Display does print if it is visible. See “The Reference Floor” on page 393.

Color

The Color toggle turns the on-screen display of color on or off in all views. When Color is toggled off, views print in either black and white or greyscale depending on your Preferences setting. See “Colors Panel” on page 64.

• Click OK to close the dialog. Any new sheet sizes created are now available in the Drawing Sheet Setup dialog.

• The data for this dialog is stored in the “sheet-Sizes.sheet” file in the program’s Data folder.

Clearing Printer Information

Select File> Print> Clear Printer Info to clear the printer-specific information stored in the Drawing Sheet Setup dialog.

Reference Grid

The Reference Grid is an on-screen grid composed of regular squares that can be used to convey a sense of scale while drawing. It does not print, and its size can be specified in the General Plan Defaults dialog. See “General Plan Defaults Dialog” on page 59.

Line Weights

Select View> Line Weights for an on-screen representation of line weights and line styles. Turning Line Weights on or off does not affect the final printed output.

When Line Weights is turned on, you can Zoom In to see the location of lines and dashed lines as they will appear on the printed page.

When Line Weights is off, dashed lines look the same, regardless of the zoom factor.

Line Weights can also be turned on or off in the Preferences dialog. See “Appearance Panel” on page 62.

Drawing Sheet

The Drawing Sheet is a representation of the size and orientation of the final printed output. It is different from the printed page size, which means that you can print a large Sheet to multiple smaller pages. Select View> Drawing Sheet to show the Drawing Sheet on screen.

The Drawing Sheet size and orientation are specified in the Drawing Sheet Setup dialog. See “Drawing Sheet Setup Dialog” on page 710.

When the Drawing Sheet is set to display, a blue border representing the margins of the printable area will also display for reference. If the margins have
been set to populate from the selected printer, this border may not display on all edges of the drawing sheet. See “Printer Drivers” on page 708.

When **Drawing Sheet** is on, the drawing sheet behaves as an object.

- When selected at its border the sheet has edit handles, allowing it to be moved. See “Editing Objects” on page 119.
- You can also resize the sheet using its edit handles; however, for best results, it is recommended that you instead select an available sheet size in the **Drawing Sheet Setup** dialog. See “Drawing Sheet Setup Dialog” on page 710.
- Dimension lines can locate the edges of the sheet and can be used to position other objects relative to it. See “Moving Objects Using Dimensions” on page 263.

**Note**: Specifying a sheet size in the Drawing Sheet Setup dialog is preferable to editing the sheet size on-screen.

The drawing sheet cannot be rotated or copied.

**Center Sheet**

Select **File > Print > Center Sheet** to center the drawing sheet on the drawing. This moves the sheet relative to the drawing but does not affect the coordinates of objects in the drawing. The location of the drawing sheet is independent for each floor of the model.

**Printing to Scale**

Several different print scaling options are available. The type of view that you are printing determines which options you may choose from.

**Orthogonal Views**

Plan views, Orthographic 3D views, and layout pages are orthogonal views, which means:

- Your line of sight is at a right angle to all objects in the view.
- Objects do not appear to decrease in size as their distances from the viewer increase.

Orthogonal views can be printed to scale; however, Orthographic 3D views can only be printed to scale when the Vector View Rendering Technique is used.

The scale set in the **Page Setup** dialog is inherited by the **Print** and **Send to Layout** dialogs. This scale can be overridden on an individual basis in either of these dialogs. See “Print View Dialog” on page 719 and “Sending Views to Layout” on page 697.

Select **File > Print > Scale to Fit** in an orthogonal view to select a suitable scale and re-center the drawing sheet so that everything fits on the sheet.

Imperial drawing scales are typically noted in inches per foot. Larger scales, such as 1 inch = 50 feet or 1/200m, are often used for property layouts.

**Perspective Views**

Camera views and Perspective overviews display the model much the way the eye would see it and cannot be scaled.

- Objects in the view may be at any angle relative to your line of sight.
- Objects seem to decrease in size as their distances from the viewer increase.

Perspective views can only be printed using the **Print Image** tool. See “Print Image Dialog” on page 721.

While perspective views cannot be scaled, you can control the printed size of the view. If **Fit to Paper** is selected in the **Print View** dialog, a percent value can be set that defines how much of the printed page to fill. See “Print View Dialog” on page 719. 50% causes the print to be 50% of both the height and width of the paper, including the non-printable border.

For example, if printing to an 8½ x 11 page with a 1" non-printable border in each direction:

- 100% would print an area 8½ x 11. This is not recommended, as part of the output could fall outside the printable area.
- 50% would print an area 4¼ x 5½.
- Each printer may vary slightly.
Check Plots

A check plot is a test print that allows you to print at a reduced scale on smaller, less expensive paper so you can check that the drawing will print as expected. The drawing scale is temporarily adjusted to a specified fraction of its true value. Both drawing scale and line weights are subject to this scale adjustment.

For example, if a layout has a border designed to fit on a Drawing Sheet of 24” x 36”, a check plot at 1/2 scale would allow it to fit on a 12” x 18” page. A view sent to that layout at a Drawing Scale of 1/4” = 1’ would be scaled at 1/8” = 1’ when printed at 1/2 scale.

To create a check plot

1. Select File> Print> Print View. In the Print View dialog:
   • Click the Check Plot at radio button, then choose the desired scale fraction from the drop-down list.
   • The Paper Size will automatically adjust to fit the selected Check Plot Scale.
   • Confirm that the Paper Size is the size you wish to use, then click Print.

2. The next time you print a view, remember to choose To Scale or Fit to Paper again in the Print View dialog.

Printing Text, Dimensions, and Line Styles

As with other objects your drawings, text and dimension numbers are subject to scaling when views are sent to layout or printed. See “Scaling Text” on page 275.

Printed text size is also influenced by the selected font and the method used to specify its size. See “Character Size” on page 269.

Text may not print exactly as it appears on-screen. To get a better idea of how text and dimension characters will print, you may find it helpful to Zoom In on them.

For best printed results, using true-type or open-type fonts is recommended.

Printing Across Multiple Pages

When printing directly from a plan view, cross section/elevation view, or layout it is possible to print at a scale that does not fit the drawing on one page.

When printing to a paper size that is smaller than the sheet size, a 2% overlap is used. Crop marks print where the paper needs to be cut between pages. A solid line is drawn at the drawing sheet boundary on the sides that need to be cut.

To see on-screen what the drawing will look like when printed, select View> Drawing Sheet and then Window> Fill Window. Grey lines across the drawing sheet indicate where the page breaks will occur. See “Drawing Sheet” on page 713.

Printing to a PDF File

Portable Document Format, or .pdf files, are one of the most universally compatible and efficient file formats and can be viewed and printed on most computer platforms.

You can save any view as a .pdf file by selecting “Chief Architect Save as PDF” or any other PDF writer installed on your system as the Destination printer Name in either the Print View or Print Image dialog. See “Print View Dialog” on page 719 and “Print Image Dialog” on page 721.

You can also print to .pdf from any view by selecting File> Export> Export PDF. See “PDF Files” on page 610.

When you print to .pdf, you will be asked to create a file name and choose a destination to save it in the
**Save as PDF File** dialog. See “Saving, Exporting, and Backing Up Files” on page 43.

You can also import .pdf file into Home Designer Pro. See “Importing PDF Files” on page 610.

### Line Weights

The weight of a line refers to its thickness on the printed page and is described in absolute terms as a fraction of a unit, often 1/100th of a millimeter or 1/1000 of an inch. In Home Designer Pro, line weights are assigned to objects, patterns, and layers using whole numbers that correspond to the numerator of this fraction.

You can specify the Line Weight Scale by defining the denominator and the unit used in this fraction in the **Drawing Sheet Setup** dialog. See “Drawing Sheet Setup Dialog” on page 710.

The method for specifying an object’s line weight depends on the object and the type of view.

- Most objects’ line weights can be set by layer. See “Layer Display Options Dialog” on page 111.
- Some objects’ line weights can be set in their specification dialogs. See “Line Style Panel” on page 169.
- The line weights for walls in plan view are defined by wall type in the **Wall Type Definitions** dialog. See “Wall Type Definitions Dialog” on page 210.
- The line weights of material pattern lines, which are visible in Vector Views, can be set in the **Define Material** dialog. See “Define Material Dialog” on page 550.
- The line weight for fill patterns is set for individual objects in their specification dialogs. See “Fill Styles” on page 115.
- The line weight applied to surface edges in Vector Views can be set in the **Print** dialog. See “Print View Dialog” on page 719.
- The end cap length of dashed lines in plan view is set in the **Preferences** dialog. See “CAD Panel” on page 73.
- An assigned line weight of 0 draws a line weight of 1 pixel, the thinnest line weight a printer allows. How thick this is varies from printer to printer. See “Printers and Plotters” on page 708.

#### Line Weights and Scaling

Line weights and line styles are subject to scaling when printed. You can see an on-screen approximation of what lines will look like when a view is printed by toggling on either **Line Weights** or **Print Preview**. See “Print Preview” on page 713.

When a view is sent to layout, line weights and styles may be further affected by the drawing scale selected for the layout view. This occurs when the layout view’s scale is different from the Drawing Scale of the original view.

For example, assume that you have an object in a view with a line weight of 20, and that the view’s Drawing Scale is 1 mm = 50 mm.

- If you send the view to layout at 1 mm = 25 mm scale, twice the original scale, the resulting printed line weight for this object will increase to 40 instead of 20.
- If you send the view to layout at 1 mm = 100 mm scale, half the original scale, the resulting printed line weight for this object will decrease to 10 instead of 20.

Line weight scaling affects both line weights and line styles and can be particularly noticeable with dashed line styles.

You can specify the drawing scale for any orthogonal view by opening the **Drawing Sheet Setup** dialog while in that view. See “Printing to Scale” on page 714.

For any layout view, you can specify whether the original line weight is maintained or not in the **Send to Layout** dialog. See “Send To Layout Dialog” on page 698.

Note that in order to produce exact line weights, a Vector View must be sent to layout using the **Plot Lines** option. See “Plot Line Views” on page 700.

---

**Note:** Under most circumstances, you should select Use Layout Line Scaling when sending views to layout.
or magnified eight times, to show an area of the plan in greater detail.

Because the view on the right was sent to layout at a scale other than that of the original, it is subject to layout line scaling.

The solid lines representing walls, cabinets and doors are rescaled to be eight times thicker than in the original view.

Similarly, the dashed lines representing the door jambs are rescaled so that the dashes and the spaces between them are eight times larger than in the original view.

If **Use Layout Line Scaling** is enabled, line weights are no longer scaled and the dashed lines display at the same size as in the original view.

Because the view in this example is scaled eight times larger in this case, the dashes and line weights look relatively small and fine when **Use Layout Line Scaling** is enabled. Were the view rescaled to be smaller instead, the line weights would look relatively large and thick.

**Printers and Line Weight**

Line weight and print scaling are subject to the limitations of the printer being used. For example, you will not be able to see the difference between a line that is 1/150th of an inch wide and one that is 1/300th of an inch wide when they are printed using a printer that prints 150 dots per inch (DPI).

That is, a CAD line with a line weight of 1 will look the same as a CAD line with a line weight of 4 when the Line Weight Scale is set at 1 = 1/600th of an inch and you print to a printer capable of 150 DPI.

Setting an object’s or group of objects’ line weight to zero causes the lines to print as thinly as possible.

A customizable watermark containing text or the image of your choice can be added to any plan view or layout. To toggle the watermark on or off in the current view, select **View > Watermark**.

In layout files, the watermark will display on all pages; however, in plan files, watermarks are view specific, which means that you can control which views include the watermark and which do not.
Watermarks also are file specific, so you can have a different watermark in each plan and layout file if you wish.

The method for printing a view with a watermark varies depending on the view type:

- For most types of views, check **Show Watermark** in the Print View dialog. See “Print View Dialog” on page 719.
- For perspective cameras and overviews, toggle the watermark on before printing. See “Saving and Printing 3D Views” on page 574.

**Watermark Defaults Dialog**

A watermark can be customized in the **Watermark Defaults** dialog. To open this dialog, select Edit>Default Settings and in the Default Settings dialog, click on “Watermark” and click the Edit button.

You can also open this dialog by clicking the Define button in the Print View dialog. See “Print View Dialog” on page 719.

When the Watermark Defaults dialog is open, the watermark will display in the view window behind the dialog and will update as changes are made to its settings.

1. Select a **Watermark Type** from the drop-down list.
2. The **Text** settings are available when “Text” is the Watermark Type selected above.
   - Type the desired watermark **Text** in the text field.
   - Click the **Color** bar to select a color for the watermark text. See “Select Color Dialog” on page 117.
   - Specify the **Print Size** of the watermark text, as measured from the baseline to top of the capital letter A in the selected Font.
   - Select a **Font** from the drop-down list.
3. The **Image** settings are available when “Image” is the Watermark Type selected above.
   - When an image **File** has been specified, its pathname displays here. You can type a different pathname if you wish.
   - Click the **Browse** button to open the **Watermark Image File** dialog, which is a typical Open dialog. See “Importing Files” on page 47.
   - Specify the **Ratio to Sheet**, which is how far the image extends across the sheet. Not available when “Fit to Sheet” Layout is selected, below.
4. **General** -
   - Specify the **Layout** of the watermark from the drop-down list.
   - Specify the watermark’s **Angle**, measured relative to a horizontal line pointing towards the right hand side of the screen.
   - Use the **Transparency** slider bar or text field to control how transparent the watermark is.

The Marks Per settings are only available when “Tile” or “Border” is selected as the Layout, above.

- Specify the **Marks Per Row**, which is the number of instances of the watermark across the width of the Drawing Sheet.
- Specify the **Marks Per Column**, which is the number of instances of the watermark from top to bottom of the Drawing Sheet.
Specify the watermark **Margins**, measured in from the edges of the Drawing Sheet.

- Check **Use Drawing Sheet Margin** to use the same margins for the watermark that are specified for the Drawing Sheet or uncheck this box to enable the settings that follow. See “Drawing Sheet Setup Dialog” on page 710.
- Specify the width of the **Top**, **Bottom**, **Left**, and **Right** watermark margins.

**Print View Dialog**

To print from plan view, 3D Vector Views, layout, and the Materials List, select **File > Print**. The **Print View**, **Print Layout**, or **Print Materials List** dialog opens. The settings that are available will vary depending on which version of the dialog is open.

Select **File > Export > Export PDF** to open the similar **Export PDF** dialog.

If **Remember Print Settings after Printing** is checked in the **Drawing Sheet Setup** dialog, most settings in this dialog will be saved and applied globally to all views of the same type in all Home Designer Pro files. There are three exceptions: **Sheets** and **Copies** are always reset, and the **Print Source** is determined by whether or not the **Drawing Sheet** is toggled on. See “Print View Settings” on page 709.

**Note:** 3D views that are not Vector Views can be printed using Print Image.
1. Select the **Name** of the **Printer** that you would like to use from the drop-down list. To print to .pdf, select “Chief Architect Save as PDF” from the list, or choose a .pdf writer installed on your system. See “Printing to a PDF File” on page 715.

2. Select the **DPI**, or Dots Per Inch to use when printing, from the drop-down list. The available options may vary depending on the selected printer.

3. Select the **Paper Orientation**, **Size**, and **Source**. The available Size and Source options are controlled by the selected printer’s driver. See “Printer Drivers” on page 708.

4. When possible, the program will automatically set the **Size** and **Orientation** to match those of the Drawing Sheet. See “Drawing Sheet Setup Dialog” on page 710.

5. The **Paper Size** may be automatically adjusted if the **Drawing Scale** option is changed, below.

6. Specify the **Print Source**. Not available in the **Print Materials List** dialog.

7. Select **Drawing Sheet** to print the entire sheet even though you may be zoomed in on a portion of the view. This is selected by default when the Drawing Sheet is set to display in the current view.

8. Select **Current View** to print only that portion of the active view that is currently visible on screen. If you are zoomed out, any blank space outside of the printable objects in the view is ignored. This is selected by default when the Drawing Sheet is not displaying in the current view.

9. Specify the **Drawing Scale** of the printed output. Changes to these options may cause the **Paper Size** to change, above. Not available in the **Print Materials List** dialog or in camera views or overviews. See “Printing to Scale” on page 714.

10. **Fit to Paper** prints the view on one page. The program uses whatever scale is necessary to fit the plan on one page.

11. When **Fit to Paper** is selected, specify the percentage of the paper to be used. The default value is 95%.

Note: The Fit to Paper percentage value is global - affecting all views in all files, and is retained between sessions.

• Select **To Scale** to print at the scale specified in the **Drawing Sheet Setup** dialog. See “Drawing Sheet Setup Dialog” on page 710.

• To print a check plot, select **Check Plot at** and choose a scale adjustment from the drop-down list. See “Check Plots” on page 715.

5 Options -

• Specify the number of **Copies** you would like to print.

• Check **Include Watermark** to include a watermark in the printed output. Click the **Define** button to open the **Watermark Defaults** dialog. See “Watermark Defaults Dialog” on page 718.

• Check **Print in Color** to print in color or clear the check box to print in either grayscale or black and white. In the **Print Materials List** dialog, system default colors are used when this box is unchecked.

• To print in grayscale, check **Obey Color On/Off Setting** in the **Preferences** dialog before printing, then uncheck **Print in Color**. See “Appearance Panel” on page 62.

• To print in black and white, uncheck **Obey Color On/Off Setting** in the **Preferences** dialog before printing, then uncheck **Print in Color**. Lines and fill colors print as either black or white, depending on which is closer to the line or fill’s actual color.

Most black and white printers print a grey scale approximation of the colors if **Print in Color** is selected.

Advanced Options - Click the **Open System Print Dialog** button to close the **Print View** dialog and print using your operating system’s Print dialog instead. Not available when No Printer is selected.

7 Control the appearance of the print job **Preview** on the right side of the dialog.

• Specify the **Page** that displays in the Preview area.

• Click the buttons to **Zoom In**, **Zoom Out**, or **Fit** the selected Page to the extents of the Preview area.

• Uncheck **Update Automatically** to turn off the print job Preview and prevent it from updating as changes are made to the settings in this dialog.
• Click the **Update** button to update the print job Preview to reflect the current settings in this dialog. If Update Automatically is unchecked, clicking Update may force the Preview to be blank.

When **Update Automatically** is checked, a preview of the current print job displays here. The drawing sheet displays as a white rectangle, and if multiple sheets are required, you can scroll through them. If the print job is large, a progress dialog may display briefly as the preview draws or updates.

To help prevent unwanted printed output, information messages regarding page size, resolution, and scale may display here, depending on the settings in this dialog.

---

**Print Image Dialog**

Any view can be printed by selecting File> **Print Image**. This is the only way to print most 3D views. See “3D Rendering” on page 583.

The **Print Image** dialog is similar to the **Print View** dialog; however, the printing process is different. **Print Image** prints individual pixels as opposed to vectors (lines).

---

1. Select the Name of the **Printer** you wish to use from the drop-down list. To print to .pdf, select “Chief Architect Save as PDF” from the list, or choose a .pdf writer installed on your system. See “Printing to a PDF File” on page 715.

2. Select the **DPI**, or Dots Per Inch to use when printing, from the drop-down list. The available options may vary depending on the selected printer.

3. Select the **Paper Orientation**, **Size**, and **Source**. The available Size and Source options are controlled by the selected printer’s driver. See “Printer Drivers” on page 708.

4. Specify the number of **Copies** you would like to print.

5. **Advanced Options** - Click the **Open System Print Dialog** button to close the **Print View** dialog and print using your operating system’s Print dialog instead. Not available when No Printer is selected.

6. Control the appearance of the print job **Preview** on the right side of the dialog.

7. • Specify which **Page** displays in the Preview area.

8. • Click the buttons to **Zoom In**, **Zoom Out**, or **Fit** the selected Page to the extents of the Preview.

9. • Uncheck **Update Automatically** to turn off the print job Preview and prevent it from updating as changes are made to the settings in this dialog.

10. • Click the **Update** button to update the print job Preview to reflect the current settings in this dialog. If Update Automatically is unchecked, clicking Update may force the Preview to be blank.
When Update Automatically is checked, a preview of the current print job displays here. If the print job is large, a progress dialog may display briefly as the preview draws or updates.

To help prevent unwanted printed output, information messages regarding page size and resolution may display here, depending on the settings in this dialog.
Welcome to Home Designer Pro 2021. This appendix has been written to help our upgrading customers make a smooth transition from earlier versions of Home Designer Pro to Home Designer Pro 2021.

Chapter Contents

• Getting Started Checklist
• Considerations for Migrating Legacy Content
• Considerations for Migrating Legacy Settings
• Considerations for Legacy Files
• New and Improved Features by Chapter

Getting Started Checklist

There are many new features in Home Designer Pro 2021, and many existing features have changed. The following checklist suggests steps you should take before migrating your files to Home Designer Pro 2021. More information about each of these steps can be found after the checklist.

☐ 1. Review the List of New and Improved Features by Chapter

There are a number of important reasons why you should familiarize yourself with the new and improved features in Home Designer Pro 2021:

• New and improved features allow you to produce drawings more efficiently, so it is to your advantage to use them.
• Some changes to existing functionality may affect your accustomed drawing style and thus your productivity if you are not aware of them.
• New features may affect your choice of settings in your template files, as well as your preferred Preferences settings.

See “New and Improved Features by Chapter” on page 729.

☐ 2. Review the Considerations for Migrating Legacy Content

Legacy users of Home Designer Pro often have library catalogs and other custom content that they want to continue using. See “Considerations for Migrating Legacy Content” on page 724.
3. Review the Considerations for Migrating Legacy Settings

Before migrating Preferences or Toolbars, bear in mind that legacy settings may not be best suited for using the new program version. See “Considerations for Migrating Legacy Settings” on page 725.

4. Review the Considerations for Legacy Files

Before opening a plan or layout file created in a previous version of Home Designer Pro, be aware of potential changes to the file that could occur in the new program version. See “Considerations for Legacy Files” on page 725.


Once you have learned about the new features in Version 2021 and decided whether to migrate any custom settings from a legacy program version, launch Home Designer Pro 2021. The first time you launch, the Migrate Settings dialog will give you the opportunity to bring legacy settings and content forward into Version 2021. See “Starting Home Designer Pro” on page 13.

### Considerations for Migrating Legacy Content

Legacy users of Home Designer Pro often have a wealth of library catalogs and other custom content that they have built over time and want to continue using.

#### Legacy Library Content

There are several ways that legacy library catalogs can be brought into Home Designer Pro 2021. See “Library Content” on page 514.

If you have Home Designer Pro version 2014 through 2020 installed on your computer, the Migrate Settings dialog will display after you activate the license, allowing you to migrate library content as well as a selection of other settings for use in Home Designer Pro 2021. If multiple legacy versions are present on the system, only the data associated with the most recent will be migrated. See “Migrating Content and Settings” on page 14.

You can import library files from versions 8 through 2014 at any time by selecting **Library > Import Library (.calib, .calibz)** from the program menu.

In addition, library files from versions 7 and prior can be imported by selecting **Library > Convert Legacy (.alb) Library Files** from the program menu. Bear in mind, though, that older content may not be of the same quality as currently offered catalogs and that legacy Manufacturer catalogs may be out of date. See “Importing Library Catalogs” on page 516.

#### Custom Graphics Files

Home Designer Pro can use graphics files regardless of where they are stored on your system; however, it is a good idea to keep your data organized in one location. If you have custom graphics files, including textures, images or backdrops that you used in a previous program version, you can copy them manually using your operating system for use in Home Designer Pro 2021. See “Home Designer Pro Data” on page 40.

- Copy custom texture files to the Home Designer Pro 2021 Textures folder located in the Home Designer Pro 2021 Data folder.
- Copy custom image files to your Home Designer Pro 2021 Images folder located in the Home Designer Pro 2021 Data folder.
- Copy custom backdrop files to your Home Designer Pro 2021 Backdrops folder located in the Home Designer Pro 2021 Data folder.

In Home Designer Pro 2020 through 8, custom graphics were saved in the Home Designer Pro Data folder, as they are in version 2021. In version 7, they were located in the program’s installation directory, in folders that began with “My”. Custom backdrops, for example, were saved in “My Backdrops”.

---


3. Review the Considerations for Migrating Legacy Settings

Before migrating Preferences or Toolbars, bear in mind that legacy settings may not be best suited for using the new program version. See “Considerations for Migrating Legacy Settings” on page 725.

4. Review the Considerations for Legacy Files

Before opening a plan or layout file created in a previous version of Home Designer Pro, be aware of potential changes to the file that could occur in the new program version. See “Considerations for Legacy Files” on page 725.


Once you have learned about the new features in Version 2021 and decided whether to migrate any custom settings from a legacy program version, launch Home Designer Pro 2021. The first time you launch, the Migrate Settings dialog will give you the opportunity to bring legacy settings and content forward into Version 2021. See “Starting Home Designer Pro” on page 13.

### Considerations for Migrating Legacy Content

Legacy users of Home Designer Pro often have a wealth of library catalogs and other custom content that they have built over time and want to continue using.

#### Legacy Library Content

There are several ways that legacy library catalogs can be brought into Home Designer Pro 2021. See “Library Content” on page 514.

If you have Home Designer Pro version 2014 through 2020 installed on your computer, the Migrate Settings dialog will display after you activate the license, allowing you to migrate library content as well as a selection of other settings for use in Home Designer Pro 2021. If multiple legacy versions are present on the system, only the data associated with the most recent will be migrated. See “Migrating Content and Settings” on page 14.

You can import library files from versions 8 through 2014 at any time by selecting **Library > Import Library (.calib, .calibz)** from the program menu.

In addition, library files from versions 7 and prior can be imported by selecting **Library > Convert Legacy (.alb) Library Files** from the program menu. Bear in mind, though, that older content may not be of the same quality as currently offered catalogs and that legacy Manufacturer catalogs may be out of date. See “Importing Library Catalogs” on page 516.

#### Custom Graphics Files

Home Designer Pro can use graphics files regardless of where they are stored on your system; however, it is a good idea to keep your data organized in one location. If you have custom graphics files, including textures, images or backdrops that you used in a previous program version, you can copy them manually using your operating system for use in Home Designer Pro 2021. See “Home Designer Pro Data” on page 40.

- Copy custom texture files to the Home Designer Pro 2021 Textures folder located in the Home Designer Pro 2021 Data folder.
- Copy custom image files to your Home Designer Pro 2021 Images folder located in the Home Designer Pro 2021 Data folder.
- Copy custom backdrop files to your Home Designer Pro 2021 Backdrops folder located in the Home Designer Pro 2021 Data folder.

In Home Designer Pro 2020 through 8, custom graphics were saved in the Home Designer Pro Data folder, as they are in version 2021. In version 7, they were located in the program’s installation directory, in folders that began with “My”. Custom backdrops, for example, were saved in “My Backdrops”.

---

Considerations for Migrating Legacy Settings

The Migrate Settings dialog lets you migrate settings from the most recent legacy installation of Home Designer Pro into Version 2021. If you have extensively customized your Preferences or Toolbars, you may want to continue using those settings. Before doing so, though, it is important to consider that you may make it harder to take advantage of new tools and functionality in Version 2021.

Preferences Settings

Although you can migrate your Preferences settings from Versions 2014 through 2020 into Version 2021, the settings that are available in Version 2021 may differ from previous program versions. You should review all the settings in the Preferences dialog to make sure that they are set to suit your drawing needs. For more information, see “Preferences Dialog” on page 61.

Custom Toolbars

It is possible to migrate toolbars from previous versions to Home Designer Pro 2021; however, it is also possible that your migrated toolbars will be missing new tools available in Version 2021.

We recommend that you set up your custom toolbars the way you would like them in Home Designer Pro 2021. You may find it most effective to customize your toolbars as you get used to working in the new program version, rather than beforehand. See “Toolbar Configurations” on page 86.

Considerations for Legacy Files

As in all software, every new program version introduces changes to its functionality as well as to the user interface. If you choose to bring a project forward, be sure to take a few moments to look it over in the new version and confirm that the new functionality does not require you to make any modifications. Particularly if you have an approaching deadline, you may find it best to finish the current project in the version of the software in which you began it.

Be sure to read this section before opening any plans created in earlier versions of Home Designer Pro.

Home Designer Pro 2021 can open the .plan and .layout files from prior versions. Files with the older .pl and .la file extensions are no longer supported, however, and cannot be opened by Home Designer Pro 2021. Before opening any files created in earlier versions of Home Designer Pro, it is important to be aware of changes made in the newest version and the effect they may have on your legacy plan and layout files.

Please note that files saved in the latest program version cannot be read by older versions of the software. When a legacy file is saved in the version 2021, an unaltered copy of the original file is created in the Home Designer Pro 2021 Data folder, under Archives, which can still be opened in the original version. See “Legacy Archive Files” on page 46.

• “For Files Created in Version 2019 and Prior” on page 726
• “For Files Created in Version 2016 and Prior” on page 727
• “For Files Created in Version 2015 and Prior” on page 727
• “For Files Created in Version 2012 and Prior” on page 727
• “For Files Created in Version 10 and Prior” on page 728
• “For Files Created in Version 9 and Prior” on page 728

For Files Created in Version 2020 and Prior

In addition to the above recommendations, if you wish to open files created in Home Designer Pro Version 2020 or prior, bear in mind the following:

1. Perspective Crop Mode

In Home Designer Pro 2017 through 2020, Perspective Crop Mode allowed older functionality governing zooming in cameras from Version 2016 and prior to be preserved in saved cameras in legacy plans migrated forward. This deprecated tool has been removed from the program’s menu and toolbars in Version 2021, although it can be migrated with legacy toolbars and hotkeys. Saved cameras in legacy plans with this behavior enabled may become distorted if you pan or zoom in the view. To permanently disable this behavior in a camera view and resolve the resulting distortion, select Window> Fill Window or press the F6 key. See “Zooming” on page 572.

For Files Created in Version 2019 and Prior

In addition to the above recommendations, if you wish to open files created in Home Designer Pro Version 2019 or prior, bear in mind the following:

1. Marker and Elevation Point Heights

In Home Designer Pro 2019 and prior, the # sign could be added to the label of a Marker or Elevation Point and the label would report the height of the Marker or the Elevation Point’s elevation. In Version 2021, text macros are used to report this information instead. In legacy plans, any # signs in Marker or Elevation Point labels will be replaced by the %heightf% or %elevationf% macro. See “Elevation Point Specification Dialog” on page 651.

2. Glass Shower Walls

In Home Designer Pro 2019 and prior, the “Glass Shower” wall type was included in installed template files and like other wall types, built to the structural layer of floors and ceilings and to the Main Layer of adjacent walls. In Version 2021, this wall type has the new Partition Wall attribute and instead builds to floor, ceiling, and wall surfaces. When a legacy file is opened in Version 2021, this wall type will be modified to have Partition Wall checked automatically and existing walls will be affected by this change. See “Partition Walls” on page 196.

For Files Created in Version 2018 and Prior

In addition to the above recommendations, if you wish to open files created in Home Designer Pro Version 2018 or prior, bear in mind the following:

1. Parallel Lights

In Home Designer Pro 2018 and prior, Parallel Light sources could be specified for electrical light fixtures and Added Lights. In Version 2021, Parallel Lights are no longer supported. In legacy plans opened in Version 2021, any Parallel Light sources will be converted to Spot Lights. See “Lighting” on page 585.

2. Joist Direction Lines

In Home Designer Pro 2018 and prior, Joist Direction Lines described all platform framing as “joists” and used nominal lumber sizes in whole inches in US Unit plans. In Version 2021, the platform’s framing Structure Type is reported and in US Unit plans, the size is described in fractional inches. When a legacy file is opened in Version 2021, Joist Direction Lines will use the new, more accurate labeling. See “Joist Direction Lines” on page 481.
For Files Created in Version 2016 and Prior

In addition to the above recommendations, if you wish to open files created in Home Designer Pro Version 2016 or prior, bear in mind the following:

1. **Boxed Eaves**

   In Home Designer Pro 2017, improvements to the generation of Boxed Eaves ensure that they extend into exterior rooms with “Use Soffit Surface for Ceiling” specified when located between the roof baseline and an interior room. In some legacy plans opened in Version 2021, the **Length** value for Boxed Eaves may need to be modified in the **Roof Plane Specification** dialog. See “Options Panel” on page 435.

2. **Uppercase Text**

   The Uppercase option was added to Text Styles in Version 2017, whereas in Version 2016 and prior, it was an option for Room Labels only. In legacy plans opened in Version 2017, Room Label Defaults will be assigned a Custom Text Style if any Room Labels are present in the drawing. The Room Labels will be assigned a Custom Text Style, as well. If a given Room Label has been sent to layout more than once and was set to use different Text Styles in each layout view, it is possible that its appearance may be affected in some views. See “Text Styles” on page 283.

For Files Created in Version 2015 and Prior

In addition to the above recommendations, if you wish to open files created in Home Designer Pro Version 2015 or prior, bear in mind the following:

1. **Built-in Appliances**

   In Home Designer Pro 2015 and prior, some appliance symbols designed to be inserted into base cabinets had incorrect sizing data. In legacy plans opened in Version 2021, these appliances will not fit into the cabinet correctly and will need to be replaced. Built-in dishwashers are particularly affected. See “Built-In Sinks and Appliances” on page 338.

2. **Formatting of Bulleted and Numbered Lists**

   In Version X7, various improvements were made to the way lines of Rich Text are spaced. In legacy plans opened in Version X7, Rich Text objects with bulleted and numbered lists may require adjustments. See “Paragraph Options Dialog” on page 272.

3. **Chief Blueprint Font**

   The Chief Blueprint font was improved for Version X6, with decreased top and bottom spacing. The change in spacing may increase the overall height of text objects using this font in X6 files opened in Version 2021. X5 and prior legacy files will not be affected by this change. See “Chief Blueprint Font” on page 268.

For Files Created in Version 2012 and Prior

In addition to the above recommendations, if you wish to open files created in Home Designer Pro Version 2012 or prior, bear in mind the following:

1. **Roof Overhangs and Framing**

   In Home Designer Pro 2012 and prior, roof overhangs were measured to the outside of the subfascia, whereas in Version 2014 and later, they are measured to the outside of the fascia. In legacy plans opened in Version 2021, this will not affect the appearance of roof planes in floor plan view because in 2012 and prior, roof plane polylines represented the projected framing area whereas in Version 2021 they represent the total projected area. But, the position of the fascia and subfascia will shift, as will the length of the rafters. See “Eave and Gable Overhangs” on page 438.
2. Door Swing Direction and Materials

In Home Designer Pro X4 and prior, exterior doors that swing outward display interior material on exterior side of door. This was corrected in Version 2021. Doors modified to work around the old behavior could be affected in legacy plans opened in Version X5. See “Changing Door Swings” on page 293.

3. Door Swing Direction and Louvers

Improvements to door louver direction may affect louvers in all doors with the exception of bifold doors. See “Changing Door Swings” on page 293.

4. Wrapped Door/Window Lintels and Window Sills

In Home Designer Pro 2012 and prior, wrapped lintels and sills extended out further than those that were not wrapped. In legacy plans opened in Version 2021, the extents of wrapped lintels and sills will be adjusted so that they equal their Extend setting. See “Door Casing” on page 292 and “Window Casing, Sills, and Millwork” on page 315.

5. Invisible Beams

The legacy Invisible Beam check box was removed from the Wall Specification dialog. When legacy plans are opened in Version 2021, any Invisible Beam walls will be converted to Invisible Walls. See “General Panel” on page 212.

For Files Created in Version 10 and Prior

In addition to the above recommendations, if you wish to open files created in Home Designer Pro Version 10 or prior, bear in mind the following:

1. Text Styles

The appearance of a number of objects that include text - including object labels, the North Pointer, Sun Angles, Joist Direction Lines, the Up/Down arrows for stairs and ramps - can now be controlled using Text Style. Their appearance may be altered somewhat in legacy plans opened in Home Designer Pro 2021. See “Text Styles” on page 283.

2. Light Sources

The illumination created by light fixtures and Added Lights was improved in Home Designer Pro 2021. Lighting in legacy plans may appear noticeably brighter when viewed in version 2021. See “Light Data Panel” on page 371.

For Files Created in Version 9 and Prior

If you wish to open files created in Home Designer Pro Version 9 or prior, bear in mind the following file management changes and structural enhancements:

1. Legacy file formats

Home Designer Pro 7 files were saved in .pl and .la the file formats. These file formats files are no longer supported and cannot be opened in version 2021. See “Compatibility with Other Programs” on page 39.

2. Material textures, images, and backdrops

Home Designer Pro 9 and prior installed with a catalog of library content, including a selection of material textures, images, and backdrops. This library catalog is no longer installed with the program because it is now available for download on-demand, so it will be possible to open a legacy plan in version 2021 and encounter numerous missing file warnings. To avoid this, we recommend using the Export Entire Plan feature in the original program version to create a folder that includes the plan and all associated textures, images, and backdrops before opening this file in 2021. This tool is renamed Backup Entire Plan in version 2021. See “Backup Entire Plan or Project” on page 49.
3. Floor and ceiling finish thicknesses

In Home Designer Pro 9 and prior, floor and ceiling finish layers were not modeled in 3D, and objects such as railings, stairs, landings, cabinets, fixtures, and furnishings measured their Floor to Bottom height from the subfloor. These objects now measure their Floor to Bottom height from the floor finish surface, so it is possible that you may notice height changes for these objects - particularly in saved, annotated cross section/elevation views. See “Floor and Ceiling Platform Definitions” on page 237.

4. Riser heights and landing thicknesses

The default Best Fit Riser Height for stairs that do not reach the next level has been updated from 9” (225 mm) in version 9 and prior to 6 3/4” (169 mm) in Home Designer Pro 2021. This may affect the riser heights of stairs, as well as the thicknesses of landings attached to those stairs. See “Staircase Specification Dialog” on page 414.

5. Auto Adjust Height

The Follow Terrain option in some specification dialogs was replaced by the Auto Adjust Height check box. If a cabinet, fireplace, fixture, furniture, or other library symbol had Follow Terrain unchecked in version 9 or prior and was located in a room with a floor height other than the default for the current floor, then the object’s Floor to Bottom Height will change to equal that room’s floor height. The object’s position in the model will not change, however. See “Terrain Height vs Floor Height” on page 638 of the Reference Manual.

6. Adjustable Thickness Walls

In Home Designer Pro 9 and prior, generic, single-layer wall types were available for use. When a legacy plan file is opened in version 2021 and these wall types are detected, they are replaced by an updated, non-generic wall type. Framed walls and Railings will also acquire 1/2” (13 mm) thick layers of sheetrock on each side. Railings that define a Deck room with Advanced Deck Framing Built will not acquire sheetrock layers. See “Legacy Wall Types” on page 210.

7. Stairwells defined by railings

Interior railings that used a generic, single-layer wall type drawn in older program versions will acquire layers of sheetrock when the plan is opened in version 2021. This can affect the appearance of staircases where they join to a floor platform. To address this issue, select the railing and move it 1/2” (13 mm) away from the top edge of the staircase. See “Creating a Stairwell Manually” on page 413.

8. Deck rooms

In legacy plans opened in Home Designer Pro 2021, Deck rooms with Advanced Deck Framing built retain the framing but have Automatic Deck Framing turned off by default. Decks with no Advanced Deck Framing built are converted to Balcony rooms. See “Decks” on page 234.

9. Structural Member Reporting

When a plan created in Home Designer Pro 9 or prior is opened in Home Designer Pro 2021, Materials Lists are set to calculate Total Lineal Length. For a combination of lineal length and piece count, select Mixed Reporting in the Structural Member Reporting dialog. See “Structural Member Reporting” on page 683.

10. Fill New Framing Members

In Home Designer Pro 9 and prior, Fill New Framing Members was view-specific; in Home Designer Pro 2021 it applies to the entire plan. As a result, it is turned off by default in legacy plans opened in version 2021. See “CAD Defaults Dialog” on page 161.

New and Improved Features by Chapter

The following is a list of new and improved features in Home Designer Pro Version 2021. Where
possible, cross-references to additional information has been provided.

**Installation**

- City Blueprint and Country Blueprint fonts are no longer installed with Home Designer. See “Chief Blueprint Font” on page 268.

**Program Overview**

- New **Crosshairs** toggle button. See “Crosshairs” on page 27.
- The Status Bar now displays a description of a tool both when the mouse pointer is highlighting it and when it is active. See “The Status Bar” on page 33.

**Preferences and Default Settings**

- The **Reset Side Windows** option now resets the panes in the Library Browser. See “Reset Options Panel” on page 81.
- New **Reset Migration** option allows you to be reprompted to migrate contents and settings from an older program version. See “Reset Options Panel” on page 81.
- New “Force Light” and “Force Dark” options to use Light or Dark Mode in the Mac version of Home Designer Pro regardless of the system settings. See “Colors Panel” on page 64.

**Window and View Tools**

- The Aerial View side window has been removed from the program. See “Window and View Tools” on page 93.

**Creating Objects**

- The Copy and Paste in Place edit tool is now located in the Edit menu, and can be added to the toolbars. See “Copying and Pasting Objects” on page 104.
- New **Paste Hold Position** edit tool. See “Copying and Pasting Objects” on page 104.

**Displaying Objects**

- The background color and transparency for fill patterns can now be specified. See “Fill Styles” on page 115.

**Editing Objects**

- The Break Line edit tool has been renamed **Break**. See “Break” on page 146.
- Improved feedback using the **Point to Point Move** edit tool. See “Using Point to Point Move” on page 143.
- Improved granularity of object categories in the **Delete Objects** dialog. Walls, cameras, Added Lights, Slab Surfaces, and additional framing objects can now be deleted, as well. See “Delete Objects Dialog” on page 157.
- The new **Marquee Mode** for the Fill Style Painter and Object Painter lets you apply attributes to objects by drawing a marquee around them instead of clicking on them. See “Painter Modes” on page 156.
- **Undo** now works in the Materials and Master Lists. See “Undo and Redo” on page 159.

**Walls, Railings, and Fencing**

- Rail profiles can now be specified for railings and fencing. See “Rails Panel” on page 224.
- New **Delete All Unused** option lets you remove all unused wall types from the current plan. See “Wall Type Definitions Dialog” on page 210.
- The Wall Break tool has been removed from the menus in favor of the **Break** edit tool. See “Wall Length” on page 201.
- Enhanced control over the **Start/End Posts** on railings. See “Rail Style Panel” on page 222.
- New **Use Wall Width** check box for railing newels. See “Newels/Balusters Panel” on page 223.

**Rooms**

- New **Calculate Structural Materials for Deck** edit button for Deck rooms. See “Room Moldings” on page 240.
- **COMPONENTS** panels have been added to the **Room Specification** dialog. See “Room Specification Dialog” on page 240.
- Moldings can now be specified in the **Room Type Defaults** dialogs. See “Room Moldings” on page 240.
- Crown moldings are now offset from the ceiling rather than the floor. See “Room Moldings” on page 240.
Text, Callouts, and Markers

- Improved interface in the Find/Replace Text dialog. See “Find/Replace Text” on page 277.
- New “Selected Objects” scope in the Find/Replace Text dialog. See “Find/Replace Text” on page 277.
- Improved ability to search for % character using the Find/Replace Text tool. See “Find/Replace Text” on page 277.
- The deprecated Special Use option for lines with arrows has been removed from the program. See “Text Arrows” on page 278.

Doors and Windows

- New “Match Interior” option for exterior door handles and locks. See “Hardware Panel” on page 303.
- New Box Header option produces horizontal top and bottom header rails. See “Framing Panel” on page 305.
- Panel door top rail and side stiles can now be specified separately to produce offset lites. See “General Panel” on page 296.
- The Automatic behavior governing door and window Header Type is both improved and now optional, allowing you to specify any header type, regardless of the wall’s Main Layer material. See “Framing Panel” on page 305.
- New All Glass option for Glass Panel garage doors. See “Options Panel” on page 298.
- Mulled units with Treat as Door specified are now placed on the “Doors” layer. See “Displaying Mulled Units” on page 311.
- A window’s sash can now be suppressed by unchecking a box. See “Sash Panel” on page 320.
- Windows can now be positioned in a corner using the end Resize handles. See “Corner Windows” on page 309.

Cabinets

- New Add Waterfall to Selected Edge edit tool for Custom Countertops. See “Waterfall Countertops” on page 340.
- The Reverse Appliance option now applies to individual appliances inserted into a cabinet instead of all appliances in that cabinet. See “Accessories Panel” on page 355.
- The interior material for cabinet boxes can now be specified independent of the exterior box material. See “Front Panel” on page 351.
- Countertops, backsplashes, and toe kicks can each be suppressed on an individual cabinet by unchecking a box. See “General Panel” on page 349.

Stairs, Ramps, and Landings

- New Stringer options for Stairs. See “Stringers Panel” on page 418.
- The Break edit tool is now available for stairs and ramps. See “Creating Stair and Ramp Subsections” on page 401.
- The Disconnect Edge edit tool is now available for stairs and ramps. See “Creating Stair and Ramp Sections” on page 402.
- L and U Shaped Stairs can now be created with multiple landings. See “New Shaped Staircase Dialog” on page 399.
- Connected stair sections can now have different widths. See “Stair and Ramp Sections and Subsections” on page 401.
- Merged stair or ramp sections now move along with a selected landing when it is moved. To move landings and/or merged stair sections separately, hold down the Alt key. See “Using the Mouse” on page 400.
- Stairs now bump into landings and other stairs when moved. See “Using the Mouse” on page 400.
- Rail profiles can now be specified for stairs and ramps. See “Stringers Panel” on page 418.

Roofs

- New structural diagram in the Roof Plane Specification dialog illustrates the location of the Height/Pitch Lock point as well as the selected setting. See “General Panel” on page 443.
- The COMPONENTS panel has been added to the Roof Plane, Ceiling Plane, and Roof Hole/Skylight Specification dialogs. See “Roofs” on page 427.
- The Make Roof Baseline Polylines check box is no longer active when Build Roof Planes is checked in the Build Roof dialog. See “Roof Baseline Polylines” on page 445.
• The deprecated Change Roof Pitch or Height dialog has been removed from the program. See “Editing Roof and Ceiling Planes” on page 439.

Framing

• The COMPONENTS and OBJECT INFORMATION panels were added to the Framing Specification dialog. See “Framing Specification Dialog” on page 486.

Trusses

• The COMPONENTS and OBJECT INFORMATION panels were added to the Truss Specification dialogs. See “Trusses” on page 489.

The Library

• New Find Original in Library edit tool lets you select an object in your plan and find it in the library. See “Find in Library” on page 513.
• The Select Library Object dialog now opens to the location of the selected object when the Replace from Library tool is used. See “Replace From Library” on page 523.
• When a custom location for the User Catalog is specified, Referenced Files are now moved there, as well. See “Library Content Location” on page 515.

Materials

• The selected object preview shape in the Define Material dialog is now retained. See “Define Material Dialog” on page 550.

3D Views

• New Display Openings Independent of Walls and Roofs option lets you display doors, windows, and skylights in 3D views when their containing wall or roof is not shown: for example, in Framing Overviews. See “3D View Defaults Dialog” on page 560.
• New Hide Camera-Facing Exterior Walls option allows you to view the interior rooms of a structure while rotating around the exterior. See “Camera Panel” on page 576 and “Walkthrough Options Dialog” on page 618.
• Views can now be navigated using a gamepad. See “Gamepads” on page 568.

• The Camera Bumps Off Walls setting is now off by default in installed template files. See “3D View Defaults Dialog” on page 560.
• The deprecated Perspective Crop Mode has been removed from the program’s menu and toolbars. See “Zooming” on page 572.

Pictures, Images, and Walkthroughs

• The Point to Point Resize edit tool now has a Retain Aspect Ratio option. See “Using Point to Point Resize edit tool” on page 143.
• Improved feedback using the Point to Point Resize edit tool. See “Using Point to Point Move” on page 143.

Importing and Exporting

• Exported COLLADA files now include light sources. See “DAE Format” on page 635.
• Exported 3D Viewer files now include light sources and information about light fixture glass emissive effects. See “Export Chief Architect 3D Viewer File” on page 624.
• Added support for AutoCAD® 2018/2019/2020 file import and export. See “Importing 2D Drawings” on page 625.
• DXF/DWG files can now be imported into layout. See “Import Drawing Assistant” on page 626.

Plants and Sprinklers

• The COMPONENTS panel is now available in the specification dialog for Sprinkler Lines and Sprinkler Splines. See “Sprinkler Specification Dialogs” on page 675.
• The OBJECT INFORMATION panel has been added to the specification dialogs for framing and trusses. See “Object Information Panel” on page 693.
• Undo can now be used in the Materials List. See “Materials Lists” on page 681.

Layout

• The deprecated Merge Generated Lines setting was removed from the Send to Layout dialog. See “Send To Layout Dialog” on page 698.
Printing and Plotting

- Printed page size limitations have been removed from Home Designer. See “Printing and Plotting” on page 707.
Appendix A

Resources and Support

Chief Architect technical support and training resources to help you be successful using our software.

- Learning and Inspiration
- Contacting Technical Support
- Error Messages
- Program Paths Dialog

Learning and Inspiration

Chief Architect offers a variety of resources that help you learn how to use the software, discover new drawing techniques, and connect with other Home Designer users.

**Home Designer Web Site**

The Home Designer web site has an array of resources, including downloadable library content, program updates and more. Select **Help> Visit Home Designer Web Site** from the program menu to launch your default internet browser to [HomeDesignerSoftware.com](http://HomeDesignerSoftware.com).

Reference Manual

The Home Designer Pro Reference Manual is a comprehensive source of information about the entire Home Designer Pro 2021 program interface. This manual is available online in .pdf format by selecting **Help> View Reference Manual**.

User’s Guide

Written for new Home Designer Pro users, but a helpful reference for users of all experience levels as well, the User’s Guide walks you through the process of creating a complete model, from the first wall to the interior design and landscaping.
This guide is available online by selecting Help> View User’s Guide.

**Online Help Videos**

Another resource that illustrates Home Designer Pro’s tools is the collection of tutorial videos available on our web site. To view the online videos, select Help> View Online Help Videos from the program menu or visit www.homedesigner.chiefarchitect.com/videos.

**Online Knowledge Base**

The Home Designer Knowledge Base is a collection of online articles that address common technical issues as well as a range of how-to questions with illustrations and step-by-step instructions. To access these resources, visit HomeDesignerSoftware.com.

**HomeTalk Online Forum**

The HomeTalk User Forum hosts ongoing discussion on a variety of topics related to the use of Home Designer Pro. It is rich with useful tips and available free of charge to all registered Home Designer Pro users.

- Discussions are initiated and carried out by users.
- Experienced users share knowledge with each other and beginners.
- Home Designer Pro Staff members post announcements, advice and technical information.

To visit HomeTalk, select Help> HomeTalk or go to hometalk.chiefarchitect.com.

**Online Samples Gallery**

A collection of plan sets and renderings is available for viewing and download on our web site. Select File> Download Sample Plans to launch your internet browser to HomeDesignerSoftware.com.

**Contacting Technical Support**

Chief Architect’s world class technical support services can be accessed both online and by telephone. Select Help> Technical Support from the program menu to visit HomeDesignerSoftware.com.

Before contacting Technical Support, take a moment to see if the answer to your question is found in the program’s Help, Training Videos, or other online resources. When you contact us, you will be referred to these resources if the answer can be found there.

There are a number of things you can do to ensure a speedy answer to your question when you contact Technical Support.

- Select Help> About Home Designer Pro (PC) or Home Designer Pro> About Home Designer Pro (Mac) and make a note of the first characters of your Product Key and the program’s Build number.
- We periodically release updates to the current program version. Before contacting Technical Support, select Help>
Download Program Updates and make sure you are running the most current update for your program version.

- When you encounter an error message, click the Send Report button if possible and copy the message’s exact wording. See “Error Messages” on page 735.
- When calling Technical Support, have Home Designer Pro running on the computer where the problem occurs. This is necessary in order to troubleshoot the issue and verify that a solution is found.
- Be prepared to reproduce and describe the problem in detail. If we cannot reproduce the problem, there is a reduced chance that we will be able to resolve it.

Telephone Support

Our Technical Support team is committed to answering your questions as quickly as possible and in the order received. We can resolve most issues in just a few minutes and are happy to help you find the best resource to answer your questions. So that we can quickly answer all calls, though, we may ask that you limit your inquiry to one question.

Online Support

If a Support technician needs to see a copy of a plan, layout, or other file, they will ask you submit it to us using the Chief Architect Online Support Center. Questions can also be submitted directly to the Technical Support department using the Online Support Center as well. Be sure to provide a detailed description of the problem you are encountering in your ticket.

Error Messages

Most common error messages have a known cause and simple resolution. When you encounter an error or warning message in Home Designer Pro, you can click the Check Knowledge Base button in the message box to launch your default internet browser to the Home Designer Knowledge Base on our Web site, HomeDesignerSoftware.com.

If the message is discussed in an article it will display, providing information about the message and how best to avoid it.

It is important that abnormal errors be reported to Chief Architect Technical Support so that we can identify and resolve any problems.

The content of an error message is useful in diagnosing its cause. If you encounter an error message, make a note of the error number and the full text of the message. You can also click the Details button and copy the text into a text document or Online Support Center ticket.

If you encounter the error more than once, make a note of your steps prior to receiving the message.

Finally, check to see if there are program updates available. Program updates contain enhancements and other changes that allow
the software to perform at an optimum level. Select **Help > Download Program Updates** from the Home Designer Pro menu and follow the instructions on our Web site, [HomeDesignerSoftware.com](http://HomeDesignerSoftware.com).

### Error Reporting

When an error occurs, you may have the option in the message box to send the report to Chief Architect by clicking the **Send Report** button in the error message box. A report containing technical details about the error, but no personal information, is sent to our Testing team for evaluation.

After clicking the **Send Report** button, please contact [Technical Support](mailto:TechnicalSupport@ChiefArchitect.com) with any additional information that you may have about the circumstances of the error: for example, the type of view that was open and the tool that was active.

---

### Program Paths Dialog

Some technical issues can be caused by problems with support files used by Home Designer Pro. In the event of such an issue, Chief Architect Technical Support may direct you to the **Program Paths** dialog. This dialog displays a list of files utilized by the software along with the pathname of each.

To avoid unintended problems that could prevent you from using the software, it is strongly recommended that you make no changes to any of the files in this list except with the direct assistance of Technical Support.
Index

Numerics

360 Panorama Export .................................. 635
3D
  Backdrops ........................................ 578
  Data Import .................................... 632
  Delete Surface ................................ 566
  Mice .............................................. 27
  Symbols, Importing ................................. 632
3D Roof Designer .................................... 439
3D View Defaults Dialog .............................. 560
3D Views
  Display ........................................... 565
  Doll House ...................................... 563
  Editing .......................................... 573
  Framing Overview ................................ 563
  Full Overview .................................. 563
  Line Weights .................................. 716
  Overviews ....................................... 561
  Save ........................................... 574
  Working in ....................................... 573
3D Wall Designer ...................................... 193

A

Absolute Location
  New point ........................................ 163
Added Lights ....................................... 585
Adding
  Floor Between Existing Floors ................... 389
  to the Library .................................. 517
  Toolbar Buttons ................................. 89
Adjust
  Material Definition ............................... 545
  Wall Angle ....................................... 72
Adjust Lights Dialog ................................ 588
Alcove Roofs ......................................... 452
Align
  Curved Stairs Between Floors ................... 145
  Curved Walls Between Floors .................... 205
  Objects .......................................... 143
  Pony Walls Between Floors ....................... 205
  Roof Edges ...................................... 439
  Stem Walls and Footings ......................... 379
  Text ............................................ 275
  Walls ........................................... 204
Allowed
  Angles Dialog ................................... 154
Alpha Channel ....................................... 552

Alphabets
  International .................................... 268
  Unicode ......................................... 268
Ambient Light
  Daytime .......................................... 586
  Interior ......................................... 586
  Nighttime ....................................... 586
Angle Snaps ......................................... 101
Angled Front Cabinets ................................ 347
Angles
  Entered as bearings ................................ 167
Angular Dimensions ................................ 149, 257, 264
Appearance Preferences ............................. 62
Appliances
  Built into cabinets ................................ 338
Arc
  Creation Modes .................................. 171
  Panel ............................................. 174
  Specification Dialog ............................. 174
  Tools ............................................ 172
  with Arrow ...................................... 173
Architectural Block
  Specification Dialog .............................. 530
Architectural Blocks ................................ 529
  Components ..................................... 532
  Displaying ....................................... 529
  Edit Sub-Objects ................................ 530
  Explode ......................................... 530
  Sub-objects .................................... 531
Architectural Preferences ............................ 72
Archive Files ....................................... 45
Arcs
  Aligning Centers ................................. 145
  Arc About Center ................................ 172
  Arc Creation Modes .............................. 171
  Show Arc Centers ................................ 130
  Start and End Points ............................ 74
Area
  Living Area calculation .......................... 228
  of a Polyline .................................... 177
  of Roof Planes .................................. 445
  of Rooms ........................................ 231
Arrow
  Auto Positioning .................................. 278
  Panel ............................................. 171
  Text Line With ................................... 278
Artwork
  Creating textures .................................. 547
Attic
  Floor ............................................... 393
<table>
<thead>
<tr>
<th>B</th>
<th>Bay/Box Window</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Specification Dialog .................................................................................. 331</td>
</tr>
<tr>
<td></td>
<td>Beams</td>
</tr>
<tr>
<td></td>
<td>Bearing .................................................................................................... 488</td>
</tr>
<tr>
<td></td>
<td>Floor/Ceiling ......................................................................................... 468</td>
</tr>
<tr>
<td></td>
<td>Roof ........................................................................................................ 468</td>
</tr>
<tr>
<td></td>
<td>Roof, exposed ........................................................................................... 534</td>
</tr>
<tr>
<td></td>
<td>Bearing</td>
</tr>
<tr>
<td></td>
<td>Beam ........................................................................................................ 488</td>
</tr>
<tr>
<td></td>
<td>Line ......................................................................................................... 482</td>
</tr>
<tr>
<td></td>
<td>Bearings</td>
</tr>
<tr>
<td></td>
<td>.......................................................................................................... 167</td>
</tr>
<tr>
<td></td>
<td>Behaviors Preferences</td>
</tr>
<tr>
<td></td>
<td>.......................................................................................................... 75</td>
</tr>
<tr>
<td></td>
<td>Birdsmouth</td>
</tr>
<tr>
<td></td>
<td>Cut ........................................................................................................ 442</td>
</tr>
<tr>
<td></td>
<td>Blend Colors with Materials</td>
</tr>
<tr>
<td></td>
<td>.......................................................................................................... 542</td>
</tr>
<tr>
<td></td>
<td>Blind Cabinets</td>
</tr>
<tr>
<td></td>
<td>.......................................................................................................... 348</td>
</tr>
<tr>
<td></td>
<td>Blocking</td>
</tr>
<tr>
<td></td>
<td>Joist .................................................................................................... 468</td>
</tr>
<tr>
<td></td>
<td>Roof ..................................................................................................... 468</td>
</tr>
<tr>
<td></td>
<td>Wall ..................................................................................................... 472</td>
</tr>
<tr>
<td></td>
<td>Blocks</td>
</tr>
<tr>
<td></td>
<td>Architectural ......................................................................................... 529</td>
</tr>
<tr>
<td></td>
<td>Bonus</td>
</tr>
<tr>
<td></td>
<td>Library Catalogs .................................................................................... 514</td>
</tr>
<tr>
<td></td>
<td>Rooms ..................................................................................................... 393</td>
</tr>
<tr>
<td></td>
<td>Bow</td>
</tr>
<tr>
<td></td>
<td>Window Specification ............................................................................... 331</td>
</tr>
<tr>
<td></td>
<td>Bow Windows</td>
</tr>
<tr>
<td></td>
<td>.......................................................................................................... 308</td>
</tr>
<tr>
<td></td>
<td>Box</td>
</tr>
<tr>
<td></td>
<td>Tools ..................................................................................................... 178</td>
</tr>
<tr>
<td></td>
<td>Windows ................................................................................................. 308</td>
</tr>
<tr>
<td></td>
<td>Break</td>
</tr>
<tr>
<td></td>
<td>Line ...................................................................................................... 146</td>
</tr>
<tr>
<td></td>
<td>Line, complete ....................................................................................... 147</td>
</tr>
<tr>
<td></td>
<td>Line, partial ......................................................................................... 146</td>
</tr>
<tr>
<td></td>
<td>Terrain Breaks ....................................................................................... 642</td>
</tr>
<tr>
<td></td>
<td>Brick Ledges</td>
</tr>
<tr>
<td></td>
<td>.......................................................................................................... 190</td>
</tr>
<tr>
<td></td>
<td>Build</td>
</tr>
<tr>
<td></td>
<td>Foundation .............................................................................................. 376, 389</td>
</tr>
<tr>
<td></td>
<td>Framing Dialog ....................................................................................... 469</td>
</tr>
<tr>
<td></td>
<td>House .................................................................................................... 52</td>
</tr>
<tr>
<td></td>
<td>New Floor ............................................................................................... 388</td>
</tr>
<tr>
<td></td>
<td>Roof Dialog ............................................................................................ 431</td>
</tr>
<tr>
<td></td>
<td>Terrain .................................................................................................. 647</td>
</tr>
<tr>
<td></td>
<td>Bumping/Pushing</td>
</tr>
<tr>
<td></td>
<td>.......................................................................................................... 142</td>
</tr>
<tr>
<td>C</td>
<td>Cabinet</td>
</tr>
<tr>
<td></td>
<td>Defaults ................................................................................................. 335</td>
</tr>
<tr>
<td></td>
<td>Designer ................................................................................................. 335</td>
</tr>
<tr>
<td></td>
<td>Modules Library</td>
</tr>
<tr>
<td></td>
<td>.......................................................................................................... 338</td>
</tr>
<tr>
<td></td>
<td>Shelf Specification Dialog .................................................................... 357</td>
</tr>
<tr>
<td></td>
<td>Specification Dialog ............................................................................... 348</td>
</tr>
<tr>
<td></td>
<td>Tools ..................................................................................................... 337</td>
</tr>
<tr>
<td></td>
<td>Cabinets</td>
</tr>
<tr>
<td></td>
<td>.......................................................................................................... 337</td>
</tr>
</tbody>
</table>
Angled front ........................................ 346
Backsplash ........................................ 350
Base ............................................. 337
Bevel .......................................... 355
Blind ........................................... 348
Built-in appliances ......................... 338
Corner ...................................... 346
Countertop, custom ......................... 337, 340
Countertops .................................. 340
Delete face items .............................. 352
Dimension to corners/sides ............... 254
Door/Drawer Overlay ....................... 351
Door/drawer style ............................. 338
Doors, diagonal ................................. 350
Doors, glass ..................................... 355
Editing ......................................... 344
End cabinets .................................... 346
Fillers ........................................... 338
Frameless ....................................... 351
Front Indicators ............................... 341
Front Panel ..................................... 351
Full Height ..................................... 337
General Defaults ............................. 336
Glass doors ..................................... 355
Island ........................................... 347
Labels ............................................ 342
Lazy Susan ..................................... 350
Minimum Width .............................. 336
Module Lines ................................... 341
Module lines, partial ......................... 336
Moving, with Wall .............................. 345
Normal ........................................... 346
Opening Indicators .......................... 341
Peninsula radius ............................... 346
Radius end ..................................... 346
Resize Increment ............................. 336
Reverse Appliance ........................... 353
Separation ..................................... 351
Shaped ......................................... 346
Shelves .......................................... 357
Special shapes ................................. 346, 349
Stile .............................................. 355
Toe kick ......................................... 350
Wall ............................................... 337

CAD

Angle Snaps .................................. 101
Angles in Degrees/Bearings ................. 162
Blocking box .................................. 179
Box .............................................. 179
Circle about center ........................... 175
Circle Tools.................................... 175
Convert to Terrain ............................ 663
Cross box ...................................... 179
Current Point .................................. 164
Delete Current Point .......................... 165
Drawing Tools ................................ 162
Ellipses ......................................... 176
Fillet ............................................ 148
In Layout ...................................... 696
Line Length Format ............................ 162
Lines ............................................ 166
Ovals ........................................... 176
Points, moving .................................. 165
Polylines ....................................... 176
Preferences ..................................... 73
Rectangular Polyline Tool ................. 178
Resize .......................................... 75
Rotate around .................................. 75
Rotate items ................................... 75
Rotate Jump .................................... 75
Stretch .......................................... 155
Temporary Points .............................. 164

CAD Box

Specification Dialog .......................... 179

CAD Defaults .................................. 161

CAD Objects

Converting ...................................... 150
Dimensions to .................................. 254
Displaying ...................................... 181

Calculate

From All Floors ................................. 681
From Room ..................................... 682
Loan .............................................. 54
Materials on soffits ........................... 535

Callout

Arrows ........................................... 279
Defaults ......................................... 268
Size and Shape ................................ 280
Specification Dialog ......................... 279

Callouts ........................................ 279

Camera

Activating ...................................... 575
Change Settings ................................. 575
Clip Surfaces Within ......................... 580
Create Views ................................... 562
Defaults ......................................... 558
Field of View ................................... 572
Move Tools ..................................... 569
Move Up/Down One Floor .................... 572
Orbit Tools ..................................... 569
Plan Display Panel ............................. 577
Specification Dialog ......................... 575
Tilt Tools ....................................... 570

Casing

Door ............................................. 292, 299
Window .......................................... 315

Cathedral Ceilings .............................. 238

Ceiling

Break Lines ..................................... 239
Framing ......................................... 469
Heights .......................................... 235
Plane ............................................ 429, 448
Shelf ............................................. 236
Trusses .......................................... 490

Ceiling Finish Dialog ......................... 244

Ceiling Plane

Specification Dialog ......................... 449

Ceiling Structure Definition ............... 538

Ceilings
| Automatic | 469 |
| Basement | 375 |
| Cathedral | 238 |
| Coffer | 239 |
| Coffer | 239 |
| Dropped | 236 |
| Lowered | 238 |
| Over this room | 243 |
| Special | 238 |
| Trey | 239 |
| Vaulted | 238 |
| Center | |
| Doors | 292 |
| Object edit tool | 144 |
| Sheet | 714 |
| Snapping to | 77 |
| Text | 275 |
| Chamfer | |
| Footings | 218 |
| Two Lines | 148 |
| Change | |
| Door Swings | 293 |
| Floor/Reference | 392–393 |
| Line to arc | 402 |
| Wall Types for Pony Walls | 191 |
| Check | |
| Plots | 708, 715 |
| Chimneys | 385 |
| Circle | |
| Specification Dialog | 176 |
| Tools | 175 |
| Circles | |
| Aligning Centers | 145 |
| Circle about center | 175 |
| Draw using center and radius | 175 |
| Ovals | 176 |
| Clear Terrain | 639 |
| Clear the Terrain | 639 |
| Click Stairs | 396 |
| Close | |
| Plans and Views | 98 |
| Program | 49 |
| Views | 98 |
| Color | |
| Off/On | 114 |
| Color Chooser | |
| Eyedropper | 118 |
| Colors | |
| Selecting | 117 |
| Compatibility | |
| with other programs | 39 |
| Components | 526 |
| Compound Raked Walls | 208 |
| Concentric | |
| Resizing | 121 |
| Configurations Panel | 91 |
| Connect | |
| Electrical | 367 |
| Walls | 195 |
| Contextual Menus | 62 |
| In Render views | 572 |
| Contour Lines | 647 |
| Convert | |
| CAD Lines to Terrain Data | 663 |
| CAD Objects | 150 |
| Polyline | 151 |
| Special Polylines into Polylines | 151 |
| Copy | |
| Floors | 390 |
| Folders and Library Objects | 519 |
| Views | 701 |
| Copy/Paste | |
| Main Edit Mode | 105 |
| Sticky Mode | 105 |
| Corner | |
| Boards | 501 |
| Windows | 309 |
| Corner Board | |
| Specification Dialog | 502 |
| Countertops | |
| Custom | 337, 340 |
| Edge Profiles | 340 |
| Edit Custom | 340 |
| Holes in | 337 |
| Create | |
| New Plan Dialog | 41 |
| Plant Image | 672 |
| Cross Section Lines | |
| Callouts | 280 |
| In Camera Views | 574 |
| Cross Section Slider | 572 |
| Cross Section/Elevation | 564 |
| Cross Section/Elevation Camera | |
| Specification Dialog | 579 |
| Cross Section/Elevation Views | 564 |
| Cross Section/Elevations | |
| Detailing | 564 |
| Sent to Layout | 699 |
| Crosshairs | |
| Aligning with | 143 |
| Crown Molding | |
| Cabinets | 346 |
| Current | |
| CAD Point | 164 |
| Floor | 392 |
| Floor, Delete | 391 |
| Curved | |
| Deck Edge | 187 |
| Deck Railing | 187 |
| Stairs | 396 |
| Walls, Draw | 195 |
| Custom | |
| Backsplash | 340 |
| Counterholes | 337 |
| Countertops | 337 |

Terrain ................................................ 646
Walls, Railings, and Fences .................. 196
Distributed Object Tab ....................... 655
Doll House View .................................. 563
Door
Casing .................................................. 292
Defaults .............................................. 287
Specification Dialog ......................... 296
Swing Angle ........................................ 296
Tools .................................................... 288
Trim ...................................................... 292
Doors
Arched ............................................... 302
Bifold Doors ....................................... 289
Casing ............................................... 299
Center ............................................... 292
Change Opening/Hinge Side ................. 293
Change Swing Side .............................. 293
Doorways ............................................ 289
Double-swing .................................... 299
Frame ................................................. 301
Framing .............................................. 473
Gables Over ........................................ 451
Garage ................................................. 289
Garage, opening direction .................... 294
Garage, panels ................................. 298
Handles ............................................... 303
Hardware .......................................... 303
Hinged Doors ..................................... 288, 293
Hinges ............................................... 303
Ignore Casing when Resizing ............... 60
Labels ............................................... 291
Library .............................................. 289, 296
Lites ................................................... 301
Locks .................................................. 303
Opening Indicators ............................ 290
Openings in railings ......................... 295
Plinth Blocks ..................................... 299
Pocket Doors .................................... 289
Recessed ............................................ 294, 299
Rough opening .................................. 296
Size ..................................................... 296
Sliding Doors .................................... 294
Style .................................................... 296
Swing from Center ............................ 299
Swing, change .................................... 293
Threshold lines .................................. 290
Transoms ............................................ 294
Type .................................................... 296
Wrapped Openings ......................... 294
Doorways
Adding a Door ................................... 290
with Railing ...................................... 295
Dormer
Defaults .............................................. 429
Specification Dialog ......................... 458
Dormers ............................................. 455
Auto Dormer ....................................... 456
Auto Floating ..................................... 456
Explode ............................................. 458
Framing .............................................. 477
Gable Over Door/Window .................... 451
Manually drawn .................................. 457
Windows in ........................................ 458
Double
Trusses .............................................. 495
Draw
Arc About Center ............................. 172
Circle About Center ......................... 175
Curved Railing ................................. 195
Curved wall ....................................... 195
Lines .................................................. 166
Roof Planes ....................................... 437
Drawing Group
Edit Tools .......................................... 114
Move to Back ..................................... 114
Move to Front .................................... 114
Select ............................................... 114
Drawing Groups ................................. 113
Drawing Sheet
Center ............................................... 714
Select ............................................... 713
Show .................................................. 713
Driveway Tools .................................. 665
Driveways ......................................... 666
DWG
File Format ......................................... 625
DXF
File Format ......................................... 625
DXF/DWG
DXF vs. DWG ...................................... 625
Files, Import 2D .................................. 626
Dynamic
Defaults ............................................. 34, 58
Print Preview ..................................... 713
Views ............................................... 699

E

Earth Data Panel ................................. 592
Eaves
Boxed ............................................... 460
Fascia .............................................. 476
Framing ............................................. 476
Plumb Cut ........................................ 435
Square cut ........................................ 435
Edit
Files in Home Designer ...................... 60
Handles ............................................. 27
Paper Size Dialog ......................... 712
Preferences ...................................... 73
Toolbar ............................................. 29
Edit Area
(All Floors) .................................... 153
(All Floors) Visible ......................... 153
Polyline as marquee ......................... 153
Tools ............................................... 153
Version Number.........................37
Hotkeys ................................... 29, 91
Create List ................................ 91
Snap Behaviors .......................... 100
House Wizard
Editing Rooms ............................. 51
Multiple Floors ........................... 52
Placing Rooms ............................. 51
Image
Specification Dialog ....................... 604
Images ...................................... 584
Adding to Library ......................... 602
Creating .................................... 602
Displaying .................................. 603
Editing .......................................... 603
Place .......................................... 602
Printing ........................................ 721
Transparency Color ......................... 605
Import
2D DXF/DWG Files ......................... 626
3D Data ....................................... 632
3D Symbols ................................... 632
Drawing Wizard ............................ 627
DXF/DWG Elevation Data ............... 663
GPS Data ....................................... 661
PDF ............................................. 610
Terrain Assistant .......................... 660
Terrain Data ................................... 659
Input
Arc ............................................. 172
Line ............................................. 166
Point ............................................. 163
Insert
Floor Dialog ................................. 389
Insulation .................................... 179
Interior
Dimension Tool ......................... 257
Dimensions, Auto ......................... 258
Room types ................................... 227
Invisible Walls ............................. 191
Join Roof Planes ........................... 440
Joist
Direction Line .............................. 481
Joist Direction
Specification Dialog ...................... 481
Joists ........................................... 468
Bearing Line .................................. 482
Blocking ....................................... 468
Spacing ......................................... 471
Use Framing Reference ................... 470
see also Framing
K
Key Frames .................................. 617
Keyboard
Commands .................................... 29, 91
Kidney Shaped
Garden Bed ................................... 644
Pond ........................................... 645
Terrain Features ............................ 644
Kingpost ...................................... 497
Kitchen Island ............................. 347
Knee Walls ................................... 207, 216
L
Label Panel ................................... 286
Labels .......................................... 285
Cabinet ........................................ 342
Display size ................................... 63
Displaying ..................................... 286
Door ............................................. 291
Electrical ....................................... 368
Plant ............................................. 674
Roof Plane .................................... 438
Room ............................................ 231
Trusses .......................................... 493
Window ......................................... 314
Landing ......................................... 403
Landings
Height .......................................... 404
Landscape Designer ....................... 637
Layer
Display Options Dialog .................... 111
Layer Sets ..................................... 113
Layers
Colors .......................................... 113
Locking ......................................... 111
Primary and Secondary .................... 110
Layout
CAD ............................................ 696
Create ......................................... 696
Cross Section/Elevations .................. 699
Defaults ........................................ 695
Editing Views .................................. 701
Exporting ...................................... 705
Files, Opening .................................. 47
Floor plan view ................................ 699
Links, Managing ............................. 704
Missing Files ................................... 704
Open View .................................... 696, 702
Page Display Options ...................... 695
Pictures in ...................................... 697
Printing ......................................... 705
Resizing, Non-Scaled Views .............. 702

Edit Mode ........................................... 105
Layer ................................................... 209

Make
Parallel Dialog ................................. 149
Parallel/Perpendicular .............. 144, 149

Manage
Layout Links ................................ 704
Library Filters ............................... 520
Materials Lists ............................. 688

Manual
Dimensions .................................. 257
Roofs ........................................ 427, 436

Manufacturer Libraries ............. 514

Marker
Defaults ........................................ 268
Editing .......................................... 283
Framing Reference .................. 479
Specification Dialog ................. 282
Types ........................................ 282

Marquee Select .......................... 125
Marquee Select Similar ............. 125

Masonry
Stairs ........................................ 412

Master List
Columns to display ....................... 80
File Location .................................. 80
Materials List ............................... 80
Name of file .................................. 80
see also Materials List
Update to Master ..................... 691

Material
Defaults ........................................ 540
Eyedropper .................................. 542

Material Painter
and Walls ..................................... 542
Blending ....................................... 542
Modes .......................................... 542
Using .......................................... 541

Materials
Add to Library ................................ 518
Artwork ........................................ 547
Blending ....................................... 546
Calculating amounts .................. 535
Creating ....................................... 545
Define Material Dialog ............... 550
Editing .......................................... 545
Mapping ....................................... 546
On Soffits ..................................... 535
Panel ........................................... 542
Patterns ....................................... 550
Plan Materials Dialog ................. 549
Render properties ...................... 554
Stained glass ................................ 310
Textures ....................................... 552, 584
Types ........................................... 547
Walls ........................................... 198

Materials List ........................... 681
Calculate from All Floors ........... 681
Calculate from Room ................. 682
Categories .................................... 77
Conditioned Areas ....................... 689
Display Options Dialog ........... 685
Editing ........................................ 687
Estimating software .................... 689
Export ........................................ 688
Font ........................................... 65
Framing ....................................... 485
Grid display on reports ............ 78
Library Objects ............................ 525
Manage ........................................ 688
Master List Preferences ............. 80
Preferences .................................... 77
Report Style Preferences ........... 78
Restrict to Floor ......................... 686
Restrict to Supplier ..................... 686
Save ........................................... 688
Saving .......................................... 681

Max Tread Contraction ............... 411

Menus ........................................... 29

Mesh, in Foundations ............... 376

Message Boxes
Reset ........................................... 33

Metafile Size Dialog ................. 609

Metafiles ..................................... 608

Middle Mouse Button .............. 26, 96

Mitre Ends of Angle Walls .......... 473

Molding
Profiles, changing ..................... 505

Moldings Panel .......................... 506

Mouse
3D ............................................. 27
Pointer Icons ................................ 28

Mouse Buttons
Using .......................................... 26

Move
Along Rails ................................... 201
CAD Points .................................... 165
Camera with Mouse .................. 568
Folders and Library Objects ...... 519
Nudging ....................................... 142
Object Using Dimensions ......... 263
Objects ........................................ 141
Restrictions .................................. 142
to be Coplanar ......................... 441
to Framing Reference .............. 143
Walls with Cabinets Attached ..... 345

Move Point Dialog ..................... 165

Mullioned Unit
Specification Dialog ............... 315

Mulled Units
Framing ....................................... 318
Labels ....................................... 286
Mullion Depth ......................... 318
Treat as Door ......................... 318

Mullions
### Muntins
- Window: 322

### New
- CAD Arc Dialog: 173
- CAD Line Dialog: 167
- CAD Point Dialog: 164
- Plans Preferences: 70
- Polygon Shaped Room: 192

### Newels
- Definition: 396

### Newels/Balusters Panel
- 223

### Niche
- 309

### No Locate Wall
- 214

### North Pointer
- 590

### Nudging
- 142

### Number Style/Angle Style
- Dialog: 82

### Open
- Below: 227
- Layout: 47
- Object: 32
- Plan Files: 47
- Symbol: 526
- View: 575

### OpenGL
- 557

### Openings
- Dimensions to: 254

### Organizing
- your Files: 40

### Orthogonal Views
- 714

### Outlets
- Above cabinet: 365
- Automatic: 366
- Dishwasher: 365
- GFCI: 365
- Manually placed: 365

### Place
- 366
- Sink: 365
- WP: 365

### Oval
- Specification Dialog: 176

### Overall Dimension
- 256

### Overhang
- 437

### Overview
- 23
- Full: 563

### Page Setup Dialog
- 710

### Painting
- Over Materials: 546

### Pan
- Pan Window Tool: 98
- the Display: 97
- Using the Keyboard: 97
- Using the Mouse: 97
- Using the Scroll Bars: 97

### Panorama Export
- 635

### Paragraph Options Dialog
- 272

### Partition Tool
- 337

### Pass-Through
- 309

### Paste
- Hold Position: 106
- Special: 106

### Paste Image
- 104

### Pattern Panel
- 550

### Patterns
- Mapping: 546

### Patterns and Textures
- 546

### PDF
- Importing: 610
- Print to: 715

### Peninsula Radius Cabinets
- 347

### Picture File Box
- Specification Dialog: 607

### Picture Files
- Export: 606
- Import: 607
- Scale: 613

### Piers
- and Pads: 382
- Foundation: 375

### Piers and Pads
- Editing: 384

### Pitch
- Above Wall: 206
- Show as degrees: 60

### Place
- Gable Over Window(s): 310
- Images: 602
- Library Object Button: 523

---

**749**
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Right Button Definition</td>
<td>26</td>
</tr>
<tr>
<td>Rim Joist</td>
<td>469</td>
</tr>
<tr>
<td>Road</td>
<td>665</td>
</tr>
<tr>
<td>Road Specification Dialog</td>
<td>667</td>
</tr>
<tr>
<td>Road Objects</td>
<td>665</td>
</tr>
<tr>
<td>Different Types</td>
<td>665</td>
</tr>
<tr>
<td>Road Tools</td>
<td>665</td>
</tr>
<tr>
<td>Roof</td>
<td>427</td>
</tr>
<tr>
<td>Automatic</td>
<td>215</td>
</tr>
<tr>
<td>Baseline Polyline</td>
<td>445</td>
</tr>
<tr>
<td>Baseline Polyline, Example Using</td>
<td>445</td>
</tr>
<tr>
<td>Baseline, Angled</td>
<td>444</td>
</tr>
<tr>
<td>Baselines</td>
<td>437</td>
</tr>
<tr>
<td>Beams</td>
<td>463</td>
</tr>
<tr>
<td>Birdsmouth Cut</td>
<td>442</td>
</tr>
<tr>
<td>Birdsmouth Depth</td>
<td>444</td>
</tr>
<tr>
<td>Extend Slope Downward</td>
<td>216</td>
</tr>
<tr>
<td>Full Gable Wall</td>
<td>216</td>
</tr>
<tr>
<td>Groups</td>
<td>430</td>
</tr>
<tr>
<td>Over this room</td>
<td>243</td>
</tr>
<tr>
<td>Panel</td>
<td>215</td>
</tr>
<tr>
<td>Second pitch</td>
<td>243</td>
</tr>
<tr>
<td>Styles, Automatic</td>
<td>430</td>
</tr>
<tr>
<td>Tools</td>
<td>429</td>
</tr>
<tr>
<td>Truss</td>
<td>490</td>
</tr>
<tr>
<td>Truss Specification Dialog</td>
<td>497</td>
</tr>
<tr>
<td>Roof Baseline</td>
<td>446</td>
</tr>
<tr>
<td>Specification Dialog</td>
<td>446</td>
</tr>
<tr>
<td>Roof Beams</td>
<td>534</td>
</tr>
<tr>
<td>Roof Designer</td>
<td>429</td>
</tr>
<tr>
<td>Roof Hole/Skylight</td>
<td>455</td>
</tr>
<tr>
<td>Specification Dialog</td>
<td>454</td>
</tr>
<tr>
<td>Roof Plane</td>
<td>443</td>
</tr>
<tr>
<td>Labels</td>
<td>438</td>
</tr>
<tr>
<td>Specification Dialog</td>
<td>443</td>
</tr>
<tr>
<td>Roof Planes</td>
<td>429, 436</td>
</tr>
<tr>
<td>Aligning</td>
<td>439</td>
</tr>
<tr>
<td>Area</td>
<td>445</td>
</tr>
<tr>
<td>Delete</td>
<td>442</td>
</tr>
<tr>
<td>Display</td>
<td>438</td>
</tr>
<tr>
<td>Edit</td>
<td>439</td>
</tr>
<tr>
<td>Intersections, Locate</td>
<td>440</td>
</tr>
<tr>
<td>Join</td>
<td>440</td>
</tr>
<tr>
<td>Low roof planes</td>
<td>434</td>
</tr>
<tr>
<td>Move to be Coplanar</td>
<td>441</td>
</tr>
<tr>
<td>Raising/Lowering</td>
<td>441</td>
</tr>
<tr>
<td>Roof Truss</td>
<td>497</td>
</tr>
<tr>
<td>Specification Dialog</td>
<td>497</td>
</tr>
<tr>
<td>Roofs</td>
<td>427, 431</td>
</tr>
<tr>
<td>Auto Rebuild</td>
<td>431–432</td>
</tr>
<tr>
<td>Auto Roof Return</td>
<td>217</td>
</tr>
<tr>
<td>Automatic vs. Manual</td>
<td>427</td>
</tr>
<tr>
<td>Boxed Eaves</td>
<td>460</td>
</tr>
<tr>
<td>Build Roof Dialog</td>
<td>431</td>
</tr>
<tr>
<td>Crickets</td>
<td>457</td>
</tr>
<tr>
<td>Defaults</td>
<td>428</td>
</tr>
<tr>
<td>Dormers</td>
<td>455</td>
</tr>
<tr>
<td>Eaves, aligning</td>
<td>441</td>
</tr>
<tr>
<td>Energy Heel</td>
<td>495</td>
</tr>
<tr>
<td>Fascia</td>
<td>461</td>
</tr>
<tr>
<td>Fix Roofs Tool</td>
<td>429</td>
</tr>
<tr>
<td>Framing</td>
<td>476</td>
</tr>
<tr>
<td>Gutters</td>
<td>461</td>
</tr>
<tr>
<td>Heights</td>
<td>443</td>
</tr>
<tr>
<td>Hip Trusses</td>
<td>494</td>
</tr>
<tr>
<td>Hole for skylights</td>
<td>453</td>
</tr>
<tr>
<td>Ignore Top Floor</td>
<td>433</td>
</tr>
<tr>
<td>Knee walls</td>
<td>207</td>
</tr>
<tr>
<td>Lock roof planes</td>
<td>434, 442</td>
</tr>
<tr>
<td>Manual</td>
<td>436</td>
</tr>
<tr>
<td>Minimum Alcove Size</td>
<td>434</td>
</tr>
<tr>
<td>Over Alcoves</td>
<td>452</td>
</tr>
<tr>
<td>Over curved walls</td>
<td>430</td>
</tr>
<tr>
<td>Overhang</td>
<td>433, 437</td>
</tr>
<tr>
<td>Pitch</td>
<td>206, 443</td>
</tr>
<tr>
<td>Plumb Cut Eaves</td>
<td>435</td>
</tr>
<tr>
<td>Raise off plate</td>
<td>434</td>
</tr>
<tr>
<td>Retain edits</td>
<td>444</td>
</tr>
<tr>
<td>Returns</td>
<td>460</td>
</tr>
<tr>
<td>Roof Group</td>
<td>241</td>
</tr>
<tr>
<td>Roof Plane</td>
<td>429</td>
</tr>
<tr>
<td>Show pitch as degrees</td>
<td>60, 444</td>
</tr>
<tr>
<td>Skylights</td>
<td>453</td>
</tr>
<tr>
<td>Square Cut Eaves</td>
<td>435</td>
</tr>
<tr>
<td>Step Down Hip</td>
<td>494</td>
</tr>
<tr>
<td>Story-and-a-half</td>
<td>207</td>
</tr>
<tr>
<td>Subgirders</td>
<td>495</td>
</tr>
<tr>
<td>Trusses</td>
<td>433</td>
</tr>
<tr>
<td>Uplift Mark</td>
<td>437</td>
</tr>
<tr>
<td>Vertical Rafter Depth</td>
<td>444</td>
</tr>
<tr>
<td>Room</td>
<td>227</td>
</tr>
<tr>
<td>Defaults</td>
<td>226</td>
</tr>
<tr>
<td>Specification Dialog</td>
<td>240</td>
</tr>
<tr>
<td>Room Labels</td>
<td>231</td>
</tr>
<tr>
<td>Custom</td>
<td>231</td>
</tr>
<tr>
<td>Defaults</td>
<td>227</td>
</tr>
<tr>
<td>Display</td>
<td>231</td>
</tr>
<tr>
<td>Edit</td>
<td>232</td>
</tr>
<tr>
<td>Interior room area</td>
<td>232</td>
</tr>
<tr>
<td>Interior room dimensions</td>
<td>232</td>
</tr>
<tr>
<td>Room area</td>
<td>231</td>
</tr>
<tr>
<td>Standard room area</td>
<td>231</td>
</tr>
<tr>
<td>Room Types</td>
<td>227</td>
</tr>
<tr>
<td>Rooms</td>
<td>231</td>
</tr>
<tr>
<td>Area</td>
<td>231</td>
</tr>
<tr>
<td>Attic</td>
<td>227</td>
</tr>
<tr>
<td>Below Stairs</td>
<td>413</td>
</tr>
<tr>
<td>Editing</td>
<td>230</td>
</tr>
<tr>
<td>Exterior types</td>
<td>227</td>
</tr>
<tr>
<td>Flat Ceiling over</td>
<td>243</td>
</tr>
<tr>
<td>Interior</td>
<td>227</td>
</tr>
<tr>
<td>Interior area</td>
<td>232</td>
</tr>
<tr>
<td>Interior dimensions</td>
<td>232</td>
</tr>
<tr>
<td>Living Area</td>
<td>228</td>
</tr>
<tr>
<td>Name for PlanCheck</td>
<td>54</td>
</tr>
<tr>
<td>Open Below</td>
<td>227</td>
</tr>
</tbody>
</table>
Sample Plans

Same Line Type edit handles .................................... 168

Round

Garden bed ........................................... 644
Pond ........................................... 645

S

Same

Height Eaves ........................................... 433
Roof Height at External Wall ................................... 433

Same Line Type edit handles .................................... 168

Sample Plans

Download ........................................... 734

Save

3D Views ........................................... 574
and Save As ........................................... 43
Layout ........................................... 43
Materials Lists ........................................... 688
Plan ........................................... 43
Thumbnail Image ........................................... 45

Scale

Picture Files ........................................... 613
Printing to ........................................... 714
Terrain Data ........................................... 661
Text Size ........................................... 275
to Fit ........................................... 714

Schedule

Specification Dialog ........................................... 677

Schematics, Wiring ........................................... 367
Scissors Trusses ........................................... 496
Scroll Bars ........................................... 97
Seat

in Bay Window ........................................... 329

Section Views ........................................... 564

Segment Angle at Curved Wall ................................... 434

Select

Backdrop ........................................... 578
Components of Blocked Units ................................... 311
Ctrl+Click ........................................... 125
Library Object Dialog ........................................... 522
Marquee ........................................... 125
Material Dialog ........................................... 543
Multiple Objects ........................................... 125
Next Object ........................................... 124
Objects button ........................................... 123
Objects in 3D Views ........................................... 573
Room ........................................... 229
Selected Edge ........................................... 123
Shift+Click ........................................... 125
Similar Objects ........................................... 123

Select Color Dialog ........................................... 117
Select Drawing Group ........................................... 114
Selection Fill Color ........................................... 64
Send
to Layout Dialog ........................................... 698
Views to layout ........................................... 697

Set Angular Dimension Dialog ................................... 149, 264
Set Baseline Height Dialog ........................................... 442
Set Chamfer Distance ........................................... 148
Set Fillet Radius ........................................... 148

Shadows

Ray Casted ........................................... 583
Sun ........................................... 591

Shelf ........................................... 337
Shelf Ceiling ........................................... 236
Shelf Tool ........................................... 337

Shelf/Partition

Specification Dialog ........................................... 358

Shelves in Cabinets ........................................... 357

Shift Key

Marquee selection ........................................... 125
Select multiple objects ........................................... 125

Shortcut Keys ........................................... 29, 91

Show

Arc Centers ........................................... 130
Line Weights ........................................... 62, 713
Living Area ........................................... 61
Pitch as degrees ........................................... 60
Reference Grid ........................................... 61
Sheet ........................................... 713

Shutters ........................................... 326

Side Windows ........................................... 28

Sidewalk ........................................... 666

Sidewalk Tools ........................................... 665

Sill Plates ........................................... 464

Skylights ........................................... 429, 453

Slab

At top of stem wall ........................................... 374
Foundation ........................................... 374
Monolithic Footings ........................................... 218
Specification Dialog ........................................... 383

Slabs

and the Materials List ........................................... 382
Interior Footings ........................................... 379
Slab Tool ........................................... 382
Tools ........................................... 382

Sliding Doors ........................................... 289

Sloped Soffits ........................................... 537
### Snap Behaviors
- Angle Snaps ........................................ 101
- Extension Snaps .................................. 101
- Grid Snaps ........................................... 61, 102
- Hotkeys ............................................... 100
- Object locations .................................... 101
- Object Snaps ........................................ 101

### Snap Properties
Preferences ....................................... 76

### Soffit
- Defaults ............................................. 533
- Specification Dialog ......................... 535

### Soffit Properties
- Calculating Materials ......................... 535
- Corner .............................................. 534
- Sloped ............................................... 537
- Special applications ............................ 534

### Space Planner
- Toolbar Configuration .......................... 86

### Space Planning
........................................... 51

### Spacing
- Joists .............................................. 471
- Wall Framing ...................................... 472, 556

### Special
- Shaped Cabinets ................................. 346

### Specification Dialogs
- Arc .................................................. 174
- Architectural Block ............................. 530
- Bay/Box Window .................................. 331
- Bow Window ...................................... 331
- Cabinet .......................................... 348
- Cabinet Shelf .................................... 357
- CAD Box .......................................... 179
- CAD Circle ...................................... 176
- CAD Ellipse ...................................... 176
- CAD Oval .......................................... 176
- Callout ............................................ 279
- Camera ............................................ 575
- Ceiling Plane ..................................... 449
- Corner Boards ................................... 502
- Cross Section/Elevation Camera .......... 579
- Custom Backsplash .............................. 360
- Custom Countertop .............................. 359
- Default Sun Light ............................... 594
- Dimension Line .................................. 264
- Door .............................................. 296
- Dormer ............................................ 458
- Electrical Service ................................ 369
- Elevation Line .................................... 652
- Elevation Point .................................. 651
- Elevation Region ................................. 652
- Flat Region ...................................... 653
- Framing ............................................ 486
- Hill / Valley ...................................... 653
- Image ............................................... 604
- Joist Direction .................................... 481
- Layout Box ........................................ 702
- Library Object .................................... 526
- Library Object Button .......................... 523

### Light
.................................................. 589

### Line
.................................................. 168

### Marker
............................................... 282

### Plant Image
.......................................... 672

### Polylne
............................................... 177

### Quoins
............................................... 503

### Raised/Lowered Region
........................................ 654

### Ramp
.................................................. 423

### Rich Text
............................................. 270

### Road
............................................... 667

### Roof Baseline
............................................. 446

### Roof Hole/Skylight
............................................. 454

### Roof Plane
............................................. 443

### Room
............................................... 240

### Schedule
............................................... 677

### Shelf/Partition
............................................. 358

### Slab
.............................................. 383

### Sofit
.............................................. 535

### Sprinkler
............................................. 675

### Stair Landing
............................................. 425

### Staircase
............................................. 414

### Sun Angle
............................................. 592

### Terrain
............................................. 648

### Terrain Break
............................................. 657

### Terrain Feature
............................................. 654

### Terrain Path
............................................. 658

### Text
.............................................. 233

### Wall
.............................................. 212

### Wall Hatch
............................................. 224

### Window
.............................................. 315

### Splines
............................................. 180

### Split
- Level Entries .................................... 392
- Level Floor Plans ............................... 391

### Spot Light
............................................. 587

### Sprinkler
- Designer ............................................. 675
- Specification Dialog ......................... 675
- Tools ............................................... 675

### Stacked Windows
............................................. 310

### Stair
- Landing Specification Dialog ................ 425
- Sections Move Independently ................ 72
- Tools ............................................... 396

### Stair Designer
............................................. 396

### Stair Landing
- Specification Dialog ......................... 425

### Stair Landings
- Height .............................................. 404

### Stair Railing
- Middle Rail ............................................. 411
- Panels .............................................. 411
- Partial .............................................. 411
- Solid .............................................. 410

### Stair Treads
- Automatic ............................................. 415
- Depth .............................................. 416
- Lock Number ....................................... 415
- Lock Tread Depth .................................. 415
Number ........................................ 416
Overhang .................................... 417
Thickness .................................... 417

Staircase
Specification Dialog ....................... 414

Stairs
Align Curved Stairs ......................... 145
Auto Stairwell ................................ 413
Balusters .................................... 421
Change Line/Arc ............................... 402
Click ........................................... 396
Concrete ....................................... 412
Curved ......................................... 396
Curved Treads ................................ 407
Deck to ground ................................ 398
Direction ....................................... 397
Down ........................................... 398
Edit Handles .................................. 400
Editing .......................................... 400
Flare Radius .................................. 406
Flared ........................................... 405
Handrails ...................................... 422
Landings ....................................... 403
Large Stringer Base ......................... 419
Lock Tread Depth .............................. 405
Make Reach .................................... 415
Masonry ........................................ 412
Merge Sections ................................. 402
Newels ......................................... 421
Railings ........................................ 410
Reach Next Floor .............................. 415
Rooms Below ................................. 413
Section Width .................................. 416
Stairwell ....................................... 412
Starter Treads .................................. 407
Straight ......................................... 396
Stringers ....................................... 417
Stringers, steel ............................... 412
Subsections .................................... 405
Symmetrically Flared ....................... 406
Terminology .................................... 396
Tread Depth ................................... 404
Treads ........................................... 415
Walk Line ....................................... 404
Winders ........................................ 408
Wrapped ....................................... 409

Stairwell
Automatic ....................................... 413

Startup Options .............................. 23

Static Views .................................. 699

Status Bar ..................................... 33, 62
Angle style ..................................... 82

Steel
Framing ........................................... 484

Stem Walls .................................... 375
Align ............................................. 379
and Footings, Align ......................... 379

Stepped Foundations ......................... 382
Stepping Stones .............................. 645

Stick Framing
Mixing with Trusses ......................... 493

Sticky Mode .................................... 105

Story-and-a-half .............................. 207

Straight
Deck Edge ....................................... 187
Stairs ........................................... 396

Streams .......................................... 645

Stretch CAD ................................... 155

Structural CAD Reporting .................. 683

Stud
Spacing .......................................... 472
Thickness ...................................... 472

Subgirders ..................................... 495

Sun
Shadows ........................................ 646

Sun Angle ....................................... 590
Create .......................................... 591
Render Data ..................................... 593
Specification Dialog ....................... 592

Sun Shadows .................................... 591

Swap
Views ............................................ 94

Switch
Three way ....................................... 367

Symbol
Surface Normals ............................. 632
vs. Native Objects ......................... 525

T

Tab Key .......................................... 124

Tabs
Columns in Text .............................. 233
Text .............................................. 233

Tape Measure .................................. 259

Technical Support ............................ 723
Contact ......................................... 734
Error Messages ................................ 735
Online .......................................... 735
Online Knowledge Base ..................... 734
Telephone ...................................... 735

Temporary
CAD Points ..................................... 163
Dimensions ..................................... 258
File Directories ............................... 69

Temporary Dimensions ..................... 258

Terrain
and 3D Draw Time ............................ 647
Auto Rebuild .................................. 647
Breaks .......................................... 642
Build ........................................... 647
Clear ............................................ 639
Contour Lines .................................. 647
Contour Smoothing ......................... 650
Texture

Textures .................................................. 584
Mapping .................................................. 546

Thumbnails .................................................. 45
Creating ................................................... 45
Enable ...................................................... 68
Size ......................................................... 68

Tiling Views .................................................. 94

Toolbars ..................................................... 29
Add Tools .................................................. 89
Configurations .......................................... 86
Customize .................................................. 89
Delete Tools .............................................. 87
Drop-Down .................................................. 85
Edit .......................................................... 29
Hide .......................................................... 85
Lock ........................................................ 88
Parent-Child ............................................. 85
Restore ...................................................... 88

Transform/Replicate Object Dialog .................................................. 151

Transom Windows ............................................. 294

Transparencies ................................................ 294
Color ........................................................ 605

Treated ....................................................... 488
Lumber ....................................................... 488
Sill Plates ................................................... 464

Trim .......................................................... 292
Door .......................................................... 292
Window ...................................................... 315

Trimmers ...................................................... 473

Truss ........................................................ 493

Envelope ...................................................... 493

Trusses ....................................................... 433, 477
Attic trusses ................................................. 495
Copy .......................................................... 490
Create ....................................................... 490
Double ....................................................... 495
Drop Hip truss .............................................. 498
Edit ........................................................... 491
End truss ..................................................... 498
Energy Heel .................................................. 495
Floor and Ceiling ......................................... 490
Force Truss Rebuild ...................................... 498
Force truss rebuild ....................................... 500
Girder ....................................................... 496
Hip ............................................................ 496
Hip jack ..................................................... 494
Jack ......................................................... 494
Kingpost ..................................................... 497
Labels ......................................................... 493
Laying out ................................................... 490
Lock Envelope ............................................ 498
Member Depth ............................................. 497, 499
Mixing with Rafters ....................................... 493
Reduced Gable ............................................ 498
Roof ........................................................ 490
Scissors ...................................................... 496
Shape, editing .............................................. 493

Text

Text Aligning ................................................. 275
Arrows ....................................................... 278
Bullets ....................................................... 272
Character Size .............................................. 269
Copy, Cut and Paste ...................................... 276
Creating ..................................................... 269
Displaying ................................................... 270
Editing ....................................................... 274
Layer ........................................................ 270
Layout ....................................................... 696
Line Spacing ............................................... 272
Lists .......................................................... 272
Move ........................................................ 274
Numbering ............................................... 272
Paragraph Options ........................................ 272
Printed Size ............................................... 275
Printing ..................................................... 715
Reshape ..................................................... 274
Resize ....................................................... 275
Rotate ....................................................... 274
Scaling ....................................................... 275
Specification Dialog ..................................... 233
Tab Spacing ................................................ 233

Text Style Defaults Dialog ........................................ 284
Text Styles ................................................... 283

Terrain Break
Specification Dialog ......................................... 657

Terrain Data
Convert CAD Lines to ..................................... 663
Import ......................................................... 659

Terrain Feature
Specification Dialog ......................................... 654

Terrain Features
Clip .......................................................... 654
Height ......................................................... 654

Terrain Modeler
3D Views ..................................................... 647
Clear Terrain ............................................... 639

Terrain Path
Specification Dialog ......................................... 658

Terrain Perimeter ............................................... 638

Contours Panel .............................................. 650
Displaying .................................................. 646
Editing ....................................................... 647
Elevation Data Tools ........................................ 639
Feature Tools ............................................... 643
Flat Region .................................................. 643
Grow All Plants Dialog ................................... 669
Hill ........................................................... 643
Holes .......................................................... 644
Modifier Tools .............................................. 643
Specification Dialog ......................................... 648
Sprintkler Tools .............................................. 675
Sun Shadows ............................................... 646
Toolbar Configuration ...................................... 86, 637
Valley ........................................................ 643
Wall and Curb Tools ......................................... 645

Shape, editing .............................................. 493

Reduced Gable ............................................. 493
Mixing with Rafters ....................................... 493

Footnotes

TEXTR

Footnotes

Footnotes
Same Wall Type handles.................................. 202
Show length when editing.............................. 184
Solid Railings .............................................. 222
Split ..................................................... 190
Stepped .................................................. 207
Thickness .................................................. 201
Wall Coverings .......................................... 219
Widths, Dimensioning .................................. 265

Water Features ............................................ 645
Watermark .................................................. 717
Waterproof Outlets ....................................... 365

Webbing
Thicknes.................................................. 499

Winders .................................................. 408, 417
Definition .................................................. 396

Window
Casing .................................................. 315
Casing, reveal ............................................ 319
Defaults .................................................. 307
Seat ....................................................... 329
Specification Dialog .................................... 315
Trim ....................................................... 315

Windows
Bay and Bow dimensions ............................. 328
Bay, Box, Bow .......................................... 328
Bench Seat .............................................. 329
Component ............................................. 308, 329
Corner ..................................................... 309
Egress ...................................................... 317
Framing .................................................... 473
Gables Over ............................................. 451
Labels ...................................................... 314
Levels ...................................................... 312
Library ..................................................... 309
Match roof ................................................ 324
Minimum Separation .................................. 307
Mulled Units ............................................. 311
Mullions .................................................... 322
Muntins .................................................... 322
Opening Indicators ...................................... 313
Pass-Through ............................................ 309
Recessed .................................................. 310, 318
Shape ...................................................... 324
Shutters .................................................... 326
Special Shapes .......................................... 310
Stacked .................................................... 310
Stained glass material ................................. 310
Standard .................................................. 308
Transom ................................................... 294
Trapezoid ............................................... 324
Treatments ............................................... 325
Types ....................................................... 308
Vents ....................................................... 310

Windows Metafiles ....................................... 608

Wiring Schematics, Creating ......................... 367

Wrapped
Openings .................................................. 294
Stairs ...................................................... 409

Z

Zero
in Dimensions ............................................ 252

Zoom ....................................................... 96
Fill Window .............................................. 97
Mouse Wheel ............................................ 26, 96
Tools ....................................................... 96
Undo Zoom .............................................. 97