Materials
Tutorial

Materials display on the surfaces of objects in 3D views and can make a 3D view appear highly
realistic. When applied to most objects, material quantities will also be calculated in the
Materials List.
This tutorial continues from where the Kitchen and Bath Design Tutorial ended. You may want
to save this tutorial using a new name to archive your previous work. In this tutorial you will
learn about:
•
•
•
•

Setting Materials Defaults
Using the Materials Panel
Using the Material Painter
Blending Colors with Materials

•
•
•

Using the Material Eyedropper
Custom Materials, Images, and Backdrops
Generating a Materials List

Setting Materials Defaults
Material default settings determine the materials used by different objects when they are
initially created. Setting the correct material defaults before beginning a project may help you
save time. For more information, see “Preferences and Default Settings” on page 69 of the
Reference Manual.
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To set material defaults
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1.

Select Edit> Default Settings

to open the Default Settings dialog.

2.

There are a two options. You can do either or both:
• Select an item in the tree list and click the Edit button to open the defaults dialog for
that type of object. The default dialogs for architectural objects such as doors and
windows have a MATERIALS panel that allows you to set the material defaults for
object components. See “Using the Materials Panel” on page 3.
• Select Materials and click the Edit button to open the Material Defaults dialog. Here
you can set the material defaults for many different objects, including some that do not
have default dialogs. See “Material Defaults” on page 740 of the Reference Manual.

Using the Materials Panel

3.

When you are finished, click OK to close the defaults dialog, then click Done to close the
Default Settings dialog.

Once an object has been placed in a plan, the materials applied to it can be changed in a number
of ways.

Using the Materials Panel
Most objects’ materials can be assigned in their specification dialog in both 2D and 3D views.
The materials used by a door, for example, can be edited on the MATERIALS panel of the Door
Specification dialog. For more information, see “Materials Panel” on page 744 of the
Reference Manual.
To change material on an object using the Materials panel
1.

Click the Select Objects
button, then click on the double door leading from the master
bedroom to the deck on Floor 2 to select it.

2.
3.

Click the Open Object
edit button to open the Door Specification dialog.
Select one of the door’s components from the list on the left.

4.

• Click on the name of a material component in the tree list to select it.
• Click the Select Material button to open the Select Material dialog.
Find and select a material and click OK. to apply it to the selected component.
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5.

You can continue to specify component materials. The preview in the dialog updates as
changes are made. When finished, click OK to close the specification dialog.

6.

Create a Full Camera

view of the door to see the results.

The materials used in individual rooms can also be specified. Rooms can be selected in both
floor plan and 3D views:
•

In floor plan view, click in an empty space within a room. When selected, the whole room is
highlighted. If you accidentally select an object other than the room, you can press the Tab
key on the keyboard until the room is selected.

•

In camera views and overviews, click on the floor of the room to select it.

To edit a room using the Materials panel
1.

Select the master bedroom and click the Open Object
Specification dialog.

2.

In the tree list on the MATERIALS panel, select "Molding" under the Crown Molding
component and click the Select Material button.
In the Select Material dialog, select a material and click OK to close the dialog.
Click OK to close the Room Specification dialog.

3.
4.
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to open the Room

Using the Material Painter

5.

The results can be seen in a Full Camera

view.

Using the Material Painter
The Material Painter
3D view.

tool allows you to select a material and then apply it to an object in a

There are five Material Painter Modes which specify how broadly or narrowly the selected
material will be applied to surfaces in your plan. In this tutorial, the Component Mode is used.
For more information, see “The Material Painter” on page 741 of the Reference Manual.
To apply a material using the Material Painter
1.

While still in the 3D view of the door, select 3D> Material Painter
there is a checkmark next to Material Painter Component Mode

2.

and confirm that
.

Click the Material Painter
button to open the Select Material dialog. Browse to
Flooring> Carpeting, select a carpet material, and click OK.
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3.
4.

Move your cursor into the 3D view and notice that it displays a spray can icon
.
Click on the floor of the master bedroom to apply the selected material to that surface,
which is a component of the room.

You can also place an area rug symbol from the library in a room and assign to it
whatever material you wish. See “Placing Library Objects” on page 712.
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Blending Colors with Materials

With the Material Painter
tool you can apply a material to nearly any surface, including
many that can’t be individually selected like the base molding on a wall or the frame of a
or Object
Modes is active, you can continue to
window. When either the Component
apply the selected material to objects until a different tool is selected.
To add artwork to a frame
1.

A variety of frames can be found in the Interiors library category. Place a wall or desk
frame in your plan and create a camera view in which it can be seen.

2.

Select 3D> Material Painter and confirm that there is a checkmark next to Material
Painter Component Mode

3.
4.

.

Click the Material Painter
button to open the Select Material dialog and choose a
painting, photo or print from the Artwork library.
Move your cursor over the middle area of the frame and click to apply the selected
artwork.

The artwork displayed in a frame can also be specified in the frame’s specification dialog. See
“Symbol Object Specification Dialogs” on page 719 of the Reference Manual.

Blending Colors with Materials
Instead of using the Material Painter to replace a material with a new one, you can use it with
feature to blend a color with a textured material such as
the Blend Colors With Materials
the carpet in the master bedroom and create a new material. For more information, see “Blend
Colors With Materials” on page 742 of the Reference Manual.
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To blend a color with a texture
1.

In a 3D view, select 3D> Material Painter> Material Painter

2.

In the Select Material dialog, select a solid color for the carpet from the Generic Colors
library, then click OK.

3.

When you move your cursor into the view, it displays a paint roller icon
• When Blend Colors with Materials

4.

.

is active and a solid color is loaded in the

Material Painter, your cursor displays the paint roller icon
• If you see the spray can icon

.

.

instead, select 3D> Material Painter> Blend

Colors With Materials
or click the Blend Colors With Materials edit button to
turn this feature on.
Click on the carpet to blend the selected color with the carpet texture. The result is a new
material with the textured appearance of the carpet as well as the color you selected.

Using the Material Eyedropper
The Material Eyedropper

tool allows you to load a material that can be seen on a surface

in a 3D view into the Material Painter
tool and then apply it to another surface. For
example, in the master bedroom the wood material assigned to the crown molding is different
than the material assigned to the chair rail and base molding.They can easily be made the same
using the Material Eyedropper
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tool.

Using the Material Eyedropper

1.

Return to the Camera view.

2.

Select 3D> Material Painter> Material Eyedropper
pointer displays an eyedropper icon

and notice that the mouse

.

3.

Click once on the crown molding to load the wood material. Notice that the mouse pointer

4.

changes to a spray can
, indicating that the loaded material is ready to apply to another
object.
Click on the chair rail and base moldings to apply the loaded material.
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Custom Materials, Images, and Backdrops
Home Designer Pro allows you to customize your 3D views by importing your own materials,
image objects, and backdrops that display in 3D views. For more information about images, see
“Pictures, Images, and Walkthroughs” on page 827 of the Reference Manual.
Note: The following steps make use of image files that are not included with the program.
You can use your own image files to create materials, images, and backdrops.

Creating Materials
You can create your own custom materials and save them in the library for use in any plan.
Many materials are represented in 3D views using textures, which are digital images that have
been specially edited to tile seamlessly when applied to a 3D surface. Bear in mind, therefore,
that not all images will necessarily serve as effective material textures.
To add a new material to the library
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1.

Select View> Library Browser

or press Ctrl + L to open the Library Browser.

2.
3.

Right-click on the User Catalog and select New> Material
from the contextual menu.
In the Define Material dialog, give the new material a short, descriptive Name.

Custom Materials, Images, and Backdrops

4.

On the TEXTURE panel, click the Browse button to open the Select Texture File dialog,
where you can choose an image file saved on your computer to be the new material’s
texture.
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5.

Select an image file and click the Open button to return to the Define Material dialog.

6.

Specify the Scale of the texture, which controls how large the image will appear on the
surfaces it is applied to.
On the PROPERTIES panel, specify attributes of the material. A Matte material will most
closely resemble cloth, which is what this material will be used for.
Click OK to add the new material to the User Catalog.

7.
8.

For more information, see “Define Material Dialog” on page 755 of the Reference Manual.

Creating Images
In Home Designer Pro, image objects are more than just 2D pictures. Images have size and
height attributes and can contain transparency information. In floor plan view, they display
only as 2D symbols; but in 3D views, the visual information that images contain can be seen.
To create an image and save it to the library
1.
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Right-click on the User Catalog folder, then select New> Image
from the contextual
menu to open the Image Specification dialog. For more information, see “Image
Specification Dialog” on page 830 of the Reference Manual.

Custom Materials, Images, and Backdrops

2.

On the IMAGE panel, click the Browse button and browse to an image file saved on your
computer. Here, an image of a cat that has transparency data associated with it is used;
however, you can use any image.

3.
4.

Click Open to return to the Image Specification dialog.
On the IMAGE panel, enter the Height or Width, adjusting one will adjust the other,
maintaining the correct proportion. Enter a Height Above Ground value to specify the
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elevation at which the image displays. A value of 24 inches works well in this case as we’ll
be placing the image on a piece of furniture.

5.

6.

Specify the transparency settings on the TRANSPARENCY panel. Since this example is a png
file with transparency already applied, selecting Use Transparency From the Image File
is the best choice.
Click OK to close the Image Specification dialog and add the new image to the My
Images category in the Images library.

Images can be placed in a plan just as plants, furnishings and fixtures are: by selecting the
image and clicking any floor plan view, camera view or overview.

Importing Backdrops
Backdrops are images that display behind 3D views. In Home Designer Pro, you can take a
photo of a site, save it to the library as a backdrop, and display it behind 3D views to create a
realistic rendering of your model and its surrounding view.
To import a backdrop and save it to the library
1.
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Select File> Import> Backdrop

and browse to an image on your computer.

Custom Materials, Images, and Backdrops

2.

Select the image and click Open to add it to the User Catalog.

To apply a backdrop to 3D views
1.

Select 3D> 3D View Defaults

2.

On the BACKDROP panel, click the Select Backdrop button to open the Select Library
Object dialog.
Click the Select Backdrop button and in the Select Library Object dialog, find and select
your new backdrop in the User Catalog and click OK.

3.

4.

to open the 3D View Defaults dialog.

Click OK to close the 3D View Defaults dialog.

You can see your custom material, image, and backdrop by creating a Full Camera

view.
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Generating a Materials List
To conclude this tutorial, we’ll generate a materials list for the house. You can generate a
materials list for a single room, an area of the plan on one floor, or the whole plan. For more
information, see “Materials Lists” on page 939 of the Reference Manual.
Note: The Materials List is only a rough cost estimate. Always compare the Materials List
with a manual take-off before providing a quote or ordering materials for a project.

To generate a materials list for the whole plan
1.

Select Tools> Materials List> Calculate Materials for All Floors
generated for all floors of the house.

2.
3.

Locate the an item, such as one under the Fixtures category.
Click in the “Price” column and type in a value. Notice that the subtotal and Total both
update to reflect the pricing change. You can specify prices for every material in your plan,
allowing you to generate a cost estimate.

4.

If you wish, you can select File> Export Materials List
and save the list as a Tabdelimited .txt file, comma-delimited .csv file, Excel .xml file, or .html file.
Close the materials list by selecting File> Close Window from the menu. A dialog will
give you the opportunity to name and save the Materials List before closing, if you wish.

5.

. A materials list is

You can generate a materials list to estimate the cost of an entire plan or just a portion of a plan.
For more information, see “Materials Lists” on page 939 of the Reference Manual.
To calculate a materials list for an individual room
1.

Click the Select Objects

button, then click in a room to select it.

2.

With the room selected, click the Calculate Materials for Room

edit button or select

Tools> Materials List> Calculate Materials for Room
. The program calculates a list
of the objects and materials contained in the selected room.
To calculate a materials list for just the deck
1.
2.

In floor plan view, select Tools> Materials List> Calculate from Area
.
Click and drag a rectangle surrounding the an area to display a materials list for the area
within the rectangle. The resulting materials list only includes objects and materials
located within the rectangle.

3.

When you have finished, remember to Save

your work.

When you are ready, you can continue working on this plan in the Landscaping Tutorial.
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