Roof Tutorial

The majority of Roof Tutorial describes some common roof styles that can be created using
settings in the Wall Specification dialog and can be completed independent of the other
tutorials. It aso explains how to add gables over doors and windows, how to create dormers
automatically and manually, and how to create skylights.

The Adding a Roof to the Stucco Beach House section continues where the House Design
Tutorial left off and explains how to add a roof to that plan.

For more information about Roof Tools, see “Roofs’ on page 377 of the Reference Manual.
In thistutorial you'll learn about:
¢ Getting Started with Automatic Roof Styles e Cricketsand Dormer Vents

¢ Hip Roofs e Manualy Drawn Dormers

¢ Gable Roofs e Skylights

¢ Shed Roofs e Using the Break Wall Tool to Modify Roofs
e Offset Gable Roofs »  Adding aRoof to the Stucco Beach House
¢ Gambrel Roofs e Troubleshooting Automatic Roof |ssues

e Gull Wing Roofs

e Half Hip Roofs

¢ Mansard Roofs

¢ Finding the Start of an Upper Pitch

¢ Roof Style Quick Reference

* Roof Returns

¢ Adding Gables over Doors and Windows
e Automatic Dormers
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Getting Started with Automatic Roof Styles

Thistutorial uses asimple, rectangular structure to explain how to create common roof styles
using roof style directives assigned to the exterior walls.

To begin a new plan
1. If any plansare open, select File> Close All from the menu.

2. Select File> New Plan [ to open anew plan. In the Create New Plan dialog, select the
Default Style template.

3. Sedlect Build> Wall> Straight Exterior Wall & and draw arectangular floor plan,
measuring about 34 feet by 24 feet (approximately 10.4 m by 7.3 m), in a clockwise
direction. See “Drawing Walls” on page 205 of the Reference Manual.
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4. Select 3D> Create Per spective View> Per spective Full Overview to create a3D
overview of the house.

« If you wish, you can select 3D> Toggle Textures &4 from the menu to turn off the
display of material textures and represent all materials using solid colors.

5. Select Window> Tile Vertically [T] to see both views at the same time.



Getting Started with Automatic Roof Styles

Hip Roof: Floor Plan x x
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Roof Style Directives in Walls

By default, the program will generate aroof plane bearing on each exterior wall that does not
have aroom-defining wall directly above it, and will use the pitch specified in the Build Roof
diaog. Theresult isahip style roof; however, if you need adifferent condition over aparticular
wall to produce another roof style, you can defineit in that wall’s specification dialog.

Individual walls can be selected and edited in both 2D and 3D views. When multiple walls are
to be edited, however, it is usually quicker and easier to work in floor plan view: in part,
because you can hold down the Shift key and group-select walls. See “Editing Walls’ on page
212 of the Reference Manual.

To set a wall’s roof directives

1. Click the Select Objects ' button, then click on awall to select it.

* To select multiple walls, hold down the Shift key on the keyboard and click on
additional walls to add them to the selection set.

2. Click the Open Object ) button to open the Wall Specification diaog.
3. On the ROOF panel:

» The Roof Options control how the roof builds over the selected wall.

 The Pitch Options control how steep the roof that bears on the selected wall is.

» The Over hang setting lets you specify how far the roof above extends past the wall’s
exterior.

» The Auto Roof Return settings let you specify and customize automatic roof returns.

» Lower Wall Typeif Split by Butting Roof lets you create alower wall type that
follows the underside of an adjacent roof plane, if oneis present.

The Roof Styles described in this tutorial use only the Roof and Pitch Options.
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Toreset all roof directives
1. Select Edit> Reset to Defaults.

2. IntheReset to Defaults dialog, set the Reset Scope to All Floors, check Roof Directives
in Walls, and click OK.

Attic Walls

When aroof is generated, attic walls may aso be generated. An Attic wall fills the space
between the walls that define aroom and the roof above. The triangul ar-shaped wall of agable,
for example, is created using an Attic wall.

If you do not want to see attic walls in floor plan view, you can turn off their display.

To turn off the display of attic walls
1. Infloor plan view, select Tools> Display Options [l (or press the ~ key) to open the
Layer Display Options dialog.

2. Find "Walls, Attic" in the Name column, remove the check from the Display column for
thisitem, and click OK. For more information, see “Layer Display Options Dialog” on
page 116 of the Reference Manual.

Deleting Roofs
Whether aroof was drawn manually or automatically generated, deleting roof planesis easy:

 Select anindividual roof plane and Delete X it.
*  Select Build> Roof> Delete Roof Planes &% to delete all roof planesin the plan.

* Select Edit> Delete Objects 5% and in the Delete Objects dialog, select either All Rooms
On ThisFloor or All Floors; place a check beside Roof Planes; and click OK to delete all
roof planes either on the current floor or in the plan.

If awarning message states that roofs cannot be deleted while Auto Rebuild Roof ison, click
the Yes button to turn off Auto Rebuild Roof and delete the roof.

Auto Rebuild Roofs

Auto Rebuild Roofs is a convenient feature in Home Designer Pro that automatically rebuilds
the roof in a plan whenever the exterior walls or floor/ceiling heights are changed. Auto
Rebuild Roofsisturned off by default, and thistutorial is presented with this feature disabled;
however the information presented here also applies when it is enabled.



Hip Roofs

To turn on/off Auto Rebuild Roofs

1. Select Build> Roof> Build Roof |2 from the menu.

2. Onthe Roor panel of the Build Roof dialog, check or uncheck Auto Rebuild Roofs and
click OK.

Hip Roofs

When roofs are automatically generated, aroof planeis built over every exterior wall in the
plan that does not have another wall drawn above it. The result isreferred to as a hip roof.

To create a hip roof

1. Begin with the basic rectangular structure described in “ Getting Started with Automatic
Roof Styles’ on page 2.

2. Select Build> Roof> Build Roof & from the menu to open the Build Roof dialog.
3. Check Build Roof Planes and click OK to generate a hip roof.

Hip Roof: Floor Plan x x
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Gable Roofs

If you would like agable over a particular wall rather than aroof plane bearing on it, you can
specify it asaFull Gable Wall in the Wall Specification dialog. To create basic gable roof,
two walls should be specified as Full Gable Wall.
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To create a gable roof

1

Begin with the basic rectangular structure described in “ Getting Started with Automatic
Roof Styles’ on page 2.

Click the Select Objects %/ tool, select the vertical wall on the left, hold down the Shift
key, and select the vertical wall on the right. The two walls should be group-selected.
Open the Wall Specification dialog and on the Roor panel, check Full Gable Wall and
click OK. See“To set awall’sroof directives’ on page 3.

« Alternatively, you can click the Change to Gable Wall(s) £} edit button.
* To remove the Full Gable Wall attribute from a selected wall, click the Changeto Hip

wall(s) (2 edit button.

Select Build> Roof> Build Roof A to open the Build Roof dialog, check Build Roof
Planes, and click OK.

Gable Roof: Floor Plan X x
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Shed Roofs

To create asingle, sloping roof plane, or shed roof, two walls must be specified as Full Gable
Walls, and one must be aHigh Shed/Gable Wall.

To create a shed roof

1

Begin with the basic rectangular structure described in “ Getting Started with Automatic
Roof Styles’ on page 2.

Asin the Gable Roofs example, specify the left and right vertical walls as Full Gable
Walls.



Offset Gable Roofs

Select the lower horizontal wall and open its Wall Specification dialog. On the ROOF
panel, check High Shed/Gable Wall and click OK. See “To set awall’s roof directives’
on page 3.

Select Build> Roof> Build Roof Y to open the Build Roof dialog, specify aPitch of 2
in 12, check Build Roof Planes, and click OK.

Shed Roof: Floor Plan X ®
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Offset Gable Roofs

An offset gableis atype of gable roof with different pitches on each of the two roof planes and
an ridge that is offset from the building’'s center line. Assign a different pitch to the two roof
planesin the Wall Specification dialog for the wall supporting each one.

To create an offset gable roof

1.

2.

Begin with the basic rectangular structure described in “ Getting Started with Automatic
Roof Styles’ on page 2.

Asin the Gable Roofs example, specify the left and right vertical walls as Full Gable
Walls.

Select the lower horizontal wall and open its Wall Specification dialog. On the ROoOF
panel, leave the Roof Options unchecked and change the Pitch to 12in 12. See“To set a
wall’sroof directives’ on page 3.

Select Build> Roof> Build Roof & to open the Build Roof dialog, check Build Roof
Planes, specify the Pitch as2in 12, and click OK.
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Offset Gable Roof: Floor Plan X x

Gambrel Roofs

A gambrel or barn style roof has two pitches on each side of the ridge. Thefirst (lower) pitch
on either side is stegper than the pitch near the ridge.

To create a gambrel roof

1

Begin with the basic rectangular structure described in “ Getting Started with Automatic
Roof Styles’ on page 2.

Asin the Gable Roofs example, specify the left and right vertical walls as Full Gable
Walls.

Click the Select Objects | k| tool, select the horizontal wall on the top, hold down the Shift
key, and select the horizontal wall on the bottom. The two walls should be group-sel ected.

Open the Wall Specification dialog and on the ROOF panel, change the following settings:

« Make sure that the Pitch value is followed by (D), which means that is set to use the
defaullt.

 Check the box beside Upper Pitch.

« Specify the Upper Pitch as6in 12 and the Start Height as 156".

« To learn more, see “Finding the Start of an Upper Pitch” on page 12.
Click OK to close the Wall Specification dialog. See “To set awall’s roof directives’ on
page 3.
Open the Build Roof dialog, check Build Roof Planes, specify the Pitch as12 in 12, and
click OK.



Gull Wing Roofs

Gambrel Roof: Floor Plan X x
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Experiment with alternate pitches and overhangs. Also, try varying the height at which the
second pitch begins so that you can see the effect it has on the gambrel roof design.

Gull Wing Roofs

A gull wing roof has two pitches on either side of the ridge, as a gambrel does; but the first
pitch of agull wing is shallower than the steeper upper pitch.

To create a gull wing roof

1

Begin with the basic rectangular structure described in “ Getting Started with Automatic
Roof Styles’ on page 2.

Asin the Gable Roofs example, specify the left and right vertical walls as Full Gable
Walls.

Click the Select Objects |/ tool, select one of the horizontal walls, hold down the Shift
key, and select the other horizontal wall. The two walls should be group-selected.

Open the Wall Specification dialog and on the Roor panel, and change the following
settings:

» Make sure that the Pitch value isfollowed by (D), which means that is set to use the

default.

* Place a check in the box beside Upper Pitch.

» Keep the Upper Pitch as 12 in 12 and change the Start Height to 125",

* To learn more, see “Finding the Start of an Upper Pitch” on page 12.
Click OK to close the dialog. See “To set awall’s roof directives’ on page 3.
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6. Click the Build Roof 2 tool, specify a Pitch of 3in 12, check Build Roof Planes, and
click OK intheBuild Roof dialog.

Gull Wing Roof: Floor Plan x x
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Experiment with the height at which the second pitch begins so that you can seethe effect it has
on the gull wing roof design.

Half Hip Roofs

A half hip roof has two gable ends. At the top of each gableisa small hip that extends to the
ridge.

To create a half hip roof

1. Begin with the basic rectangular structure described in “ Getting Started with Automatic
Roof Styles’ on page 2.

2. Asinthe Gable Roofs example, specify the left and right vertical walls as Full Gable
Walls. In addition, change the following Pitch Option settings:

 Check the box beside Upper Pitch.
« Specify the Upper Pitch as3in 12 and set the Sart Height at 170".

3. Click the Build Roof A tool, check Build Roof Planes, and click OK in the Build Roof
dialog.

10



Mansard Roofs

Half Hip Roof: Floor Plan x x
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Mansard Roofs

A mansard roof isahip roof with two pitches on the roof sections above each exterior walls: an
extremely steep lower pitch and a gently sloping upper pitch.

To create a mansard roof

1.

Begin with the basic rectangular structure described in “ Getting Started with Automatic
Roof Styles’ on page 2.

Click the Select Objects || tool, select one of the exterior walls, hold down the Shift key,
and click on the remaining walls to select them as a group.
Open the Wall Specification dialog and on the RoorF panel, and change the following
settings:

* Check the box beside Upper Pitch.

» Specify the Upper Pitch as 1.5in 12 and the Sart Height as 132".

* To learn more, see “Finding the Start of an Upper Pitch” on page 12.
Click OK to closethe dialog. See “To set awall’s roof directives’ on page 3.

Click the Build Roof & tool, specify a Pitch of 24 in 12, check Build Roof Planes, and
click OK inthe Build Roof dialog.

11
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Mansard Roof: Floor Plan X x
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Finding the Start of an Upper Pitch

When creating aroof style with lower and upper pitches, you can determine the exact Starts at
Height or In From Baseline values that you need in an elevation view.

To find the start of an upper pitch

1. Generate the roof using only thefirst, lower pitch. Be sure to define all the roof
information for each wall (gable, hip, first pitch, etc.).

2. Createacross section view that includes the roof plane that will have the second pitch. See
“Cross Section/Elevation Views’ on page 716.

3. Select CAD> Points> Place Point X, click to place atemporary point near the location
where you want the second pitch to start, and then either:

« Using the Point-to-Point Dimension |/ tool, drag adimension line from the floor on
Floor 1 (which has a height of 0 by default) to the temporary point.

« Using the Point-to-Point Dimension |/ tool, drag adimension line from the baseline
to the vertical plane of the temporary point.

12



Finding the Start of an Upper Pitch

4. Enter either of these valuesin the Wall Specification dialog. You can press the Tab key to
update the other value. Click OK to close the dialog.

Pitch Options

Pitch 8" in 12
Upper Pitch
Pitch 4 in 12
Starts atHeight 149 1/2°

In from Baseline 967

5. Open the Build Roof dialog, check Build Roof Planes and click OK to rebuild the roof.

13
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Roof Style Quick Reference

14

The following chart provides a quick reference for building the roof styles described in this
tutorial. The chart shows which wallsto change and what to change on the Roor panel of the
Wall Specification dialog for each wall. These parameters are based on a 34x24-foot model.
For different size plans, adjust these numbers.

Roof Setas S:'t n | L u Start
(0] 0] | ower er ar
Type | WalltoChange | Full Shed | Piteh Pitoh Height
Gable
Gable
Gable Vertical Wall 1
Roof Vertical Wall 2
Horizontal Wall 1 X
Horizontal Wall 2 X
Shed Vertical Wall 1 X
Roof Vertical Wall 2 X
Horizontal Wall 1 X
Horizontal Wall 2
Offset Vertical Wall 1 X
Gable Vertical Wall 2 X
Roof Horizontal Wall 1 12in12
Horizontal Wall 2 3in 12
Gambrel Vertical Wall 1 X
Roof Vertical Wall 2 X
Horizontal Wall 1 12in 12 6in 12 156
Horizontal Wall 2 12in 12 6in12 156
Gull Wing Vertical Wall 1 X
Roof Vertical Wall 2 X
Horizontal Wall 1 3in 12 12 in 12 125
Horizontal Wall 2 3in 12 12in 12 125
Half Hip Vertical Wall 1 X 3in 12 170
Roof Vertical Wall 2 X 3in 12 170
Horizontal Wall 1 6in 12
Horizontal Wall 2 6in 12
Mansard Vertical Wall 1 12 in 12 1.5in 12 132
Roof Vertical Wall 2 12in12 1.5in 12 132
Horizontal Wall 1 12in 12 1.5in 12 132
Horizontal Wall 2 121in 12 1.5in12 132




Roof Returns

Roof Returns

A roof return isasmall decorative roof plane that connectsto the low side of a gable roof
overhang and extends bel ow the upper triangular portion of the gable wall. While you can build
these manually, the following picturesillustrate the three styles of roof returns that can be
produced automatically in Home Designer Pro.

g

Gable Return Hip Return Full Return

Thefirst two are called Gable and Hip returns, since the returns themselves end in either a
gable or ahip. Thethird iscalled a Full return because it extends under the entire gable,
connecting both sides. Full roof returns are sometimes referred to as water tables.

The Auto Roof Return settings are found on the ROOF panel of the Wall Specification dialog.
Roof returns can be specified for any wall, but they will only generate on Full Gable Walls.

Auto Roof Return

Length: 36"

Extend: '

Roof Type: @ Gable () Hip () Full
Slope: (®) Sloping () Flat

Specify the horizontal L ength of the returns in inches; the distance to Extend the returns past

the main roof overhang; the style of roof return; and whether the returns are sloping or flat. As
long as your model has aroof, the specified roof returnswill be generated when you click OK.
For more information, see “Roof Returns’ on page 424 of the Reference Manual.

Adding Gables over Doors and Windows

You can add a gable roof over adoor or window.

15
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To create a gable roof over a door or window

1
2.

3.

Select adoor or window, then click the Gable Over Door/Window € edit button.

Click the Build Roof & tool, check Build Roof Planes, and click OK in the Build Roof
dialog.
A gableis created with an overhang of one foot on each side of the door or window.

To remove a gable roof over a door or window

1
2.

3.

Select the door or window and click the Delete Gable Over Opening 12 edit button.

Click the Build Roof & tool, check Build Roof Planes, and click OK in the Build Roof
dialog.
When you rebuild the roof, the gable will be removed.

To create a gable over several doors and/or windows

1
2.

Select a door, window, or mulled unit.

Hold down the Shift key and click on additional doors and/or windows to add them to your
selection set.

Click the Gable Over Door/Window @/ edit button.

Click the Build Roof & tool, check Build Roof Planes, and click OK in the Build Roof
dialog to create a gable over the selected wall openings.




Automatic Dormers

Automatic Dormers

The Auto Dormer & and the Auto Floating Dormer &/ tools offer aquick and convenient
alternative to drawing dormers manually. With just afew clicks an entire dormer is placed,
complete with roof, roof hole, walls, and window.

Thereisalimit to how low the roof pitch can be set when creating dormers. Generally, 9in 12
isthe lowest pitch that will provide enough elevation to contain a dormer.

Auto Floating Dormer

An Auto Floating Dor mer & canbe placed anywhere within aroof plane, aslong asthereis
enough space to contain it. Floating dormers are sometimes referred to as decorative because
they do not tie in with the structure of the building or require support walls.

Select Build> Roof> Auto Floating Dormer &/ and click within an existing roof planeto
place afloating dormer at that location. Once a dormer is created, it can be moved, resized and
opened for specification. For more information, see “ Editing Auto Dormers’ on page 420 of
the Reference Manual.

i An Auto Floating Dormer cannot initially be placed so that its walls align with an
@ exterior wall. Once it is created, its front wall can often be aligned with an exterior
wall below; however, its side walls must remain inside the exterior walls.

Auto Dormer

The Auto Dormer '€ tool places a standard dormer, which has the same space and structural
requirements as a manually drawn dormer. If you have not drawn dormers manually, you may
benefit from learning how. For information, see “Manually Drawn Dormers’ on page 18.

» Dormers can only be placed in roofs that are large and steep enough to contain them. You
may need to change the pitch and/or size of aroof plane before an automatic dormer can be
placed. If awarning message stating that some walls are outside the roof plane appears
when you try to place an automatic dormer, try decreasing the Height value in the Dormer
Defaults dialog.

* A kneewall must be present for the dormer to connect to. A knee wall will create attic
space and offer structural support. A wall must be present, but it does not necessarily have
to be designated as a Knee Wall in the Wall Specification dialog.

» Dormers cannot be in conflict with the ceiling on the same floor. If you need to create an
open, attic condition, check Ignore Top Floor in the Build Roof dialog and generate roof
planes based on the floor bel ow the dormer. If necessary, you can then use Raise Off Plate

17
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inthe Build Roof dialog to move roof planes up. See “Build Roof Dialog” on page 383 of
the Reference Manual.

Once placed in your model, an automatic dormer can be repositioned and its width adjusted
using its edit handles. Double-click on an automatic dormer to open the Dormer Specification
dialog, which looks just like the Dormer Defaults dialog but only affects the selected dormer.
You can also select the dormer window separately; resize it with its edit handles; and openit for
specification. For more information about dormers, see “Dormers and Crickets’ on page 418 of
the Reference Manual.

Manually Drawn Dormers

18

To create dormers in an upper floor, create a new floor for your plan and modify this floor with
knee walls and windows to form gables. This example starts with a new 40 x 30 foot plan.

Aswith automatic dormers, roof pitches of 9in 12 or greater generally work better than
shallow pitches when creating dormers because they provide enough vertical spaceto build the
dormer within.

To create a new plan
1. Select File> Close All from the menu to close any open plans.

2. Select File> New Plan [ to open anew plan. In the Create New Plan dialog, select the
Default Style template.

3. Sdect File> Save [zl from the menu, save the fileto an easy to find location, such as
Documents, and give the plan a short, descriptive name like Dormer Tutorial.

4. Select Build>Wall> Sraight Exterior Wall & and draw arectangular floor plan, 40
feet by 30 feet, in a clockwise direction.

5. Click the Fill Window Building Only L2 button to zoom in on the house.



Manually Drawn Dormers
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Asin the Gable Roofs example, specify the left and right vertical walls as Full Gable
Walls. See “To set awall’sroof directives’ on page 3.

Select Build> Floor> Build New Floor [z,

Choose the Derive new 2nd floor plan from 1st floor plan option in the New Floor
dialog and click OK. In the Floor 2 Defaults dialog, which opens next, click OK without
making any changes.

Select Build> Roof> Build Roof & to open the Build Roof dialog. On the ROOF panel,
check Build Roof Planes, change the Pitch to 12in 12, and click OK.

To create two knee walls

A knee wall isashort wall on an upper floor that is cut off by aroof plane rather than building
up to full ceiling height. They are often used to separate loft areas from attic space.

1

2.

iy You can create a custom wall type for the knee walls, such as a wall with only a
@ framing layer and one sheetrock layer. See “Wall Type Definitions Dialog” on page
227 of the Reference Manual.

Select Build> Wall> Straight Interior Wall and draw a horizontal interior wall from
left to right. Position this knee wall so that it is 5 feet from the top exterior wall.

Draw another horizontal interior wall and position it 5 feet from the bottom exterior wall.
You can reposition the knee walls using dimensions. For more information, see “Moving
Objects Using Dimensions” on page 787 of the Reference Manual.

19
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5

L s

Group select both interior walls and click the Open Object J edit button. Check the box
beside Knee Wall on the ROOF panel of the Wall Specification dialog and click OK.

Select CAD> Dimensions> Automatic Exterior Dimensions A to create exterior
dimension lines for your plan, which should now look like this:

40

51"
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189 152"
189 152"
30

55 12"
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40

To draw the dormer walls and windows

1. Select Build> Wall> Sraight Exterior Wall & and draw two rectangular boxes on the
outside of the lower knee wall, as shown in the following image.

20



Manually Drawn Dormers
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Position the front walls of each dormer box 2 feet from the bottom exterior wall. The front
dormer walls are those parallel to the bottom wall.

Use dimension lines to position the dormer side walls so that the dormers are 6 feet from
each vertical exterior wallswall and 8 feet wide.

Select Build> Wall> Break Wall %* and click along the lower knee wall to place wall
breaks where it intersects each of the dormer side walls.

L ) [ N
|/ N |/ L

Delete the segments of the knee wall located behind the dormers, as in the following
image:

L |

Select Build> Window> Window = and click on each dormer front wall to place a
window.

« When Midpoint Al Object Snaps are enabled, a"sticky point" will exist at the
midpoint of the dormer front wall when you move your mouse along the front wall.
For more information, see “ Object Snaps’ on page 122 of the Reference Manual.

* You can also use the Center Object ** edit button to center each window along the
wall after it has been placed.See “Using Center Object” on page 169 of the Reference
Manual.
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To build the roof

1

Group select the two dormer front walls with windows and open their Wall Specification
dialog. On the RooF panel, check Full Gable Wall and click OK.

Group select the four dormer side walls and open their Wall Specification dialog. On the
ROOF panel, confirm that Pitch is12in 12, and click OK.

* Earlier, apitch of 12 in 12 was specified in the Build Roof dialog: that pitch will bein
use here by default and will work well for these dormers.

Click the Select Objects || button, then click in the narrow room between the top knee
wall and the top exterior wall to select it.

Click the Open Object J edit button to open the Room Specification dialog. On the
GENERAL panel, select "Attic" asthe Room Type and click OK.

Do the same for the lower attic room.
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Select Build> Roof> Build Roof & from the menu.
In the Build Roof dialog, check Build Roof Planes, and click OK to rebuild the roof.

Select 3D> Create Per spective View> Per spective Full Overview [ to create a 3D
overview of the house and see the results.



Manually Drawn Dormers

Notice that there are small gaps in the dormer side walls. This gap is caused by the
difference between the position of the knee walls and the point at which the ceiling
intersects the roof plane. Thislocation is marked by the black dotted Ceiling Break Linein

floor plan view.

25-5" % 411"

Select each of the knee walls and move them back so that they are in alignment with the
ceiling plane. When Object Snaps are enabled, the wallswill snap into position when they

are close to the Ceiling Break Lines.
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9. Create a 3D view to see how the roof and dormers ook now.

You can move the interior walls closer to or further from the outside walls to change the
dormers’ elevation, or change the pitch for the roof to make the dormerslonger. You can create
dormers in more complex plans the same way, but you may want to experiment with wall
placement and pitch to achieve the desired effect.

24



Crickets and Dormer Vents

Crickets and Dormer Vents

Roof crickets, sometimes called saddles, are raised roof planes built to divert water or snow.
When aroof is generated automatically, cricketswill not be produced, but they can be drawn

manually using the Roof Plane [ tool.

Dormer vents can be created using a similar technique.

To create a manually drawn chimney cricket
1. Create abasic rectangular structure with a hip roof. See “ To create a hip roof” on page 5.

* In this example, the display of Roof Plane Labelsis turned off. See “Roof Plane
Labels’ on page 393 of the Reference Manual.

2. Select Build> Fireplace ml and click on one of the exterior walls to place a masonry
fireplace at that location in the wall.

a8
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« Midpoint Al Object Snaps or the Center Objects ?#/ edit tool can be used to center
the fireplace along the wall, if desired. See“Using Center Object” on page 169 of the
Reference Manual .
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3. Make any required changes to

the fireplace.

« Inthisexample, the default 48" wide fireplaceis used, but its Depth edit handleis used
to offset the fireplace 6" towards the exterior. See “ Chimneys’ on page 374 of the

Reference Manual.

4. Select CAD> Line> DrawLine/anddrawaCADIinealongtheinsidesurfaceofthe

fireplace’s firebox.

* You can also draw the CAD line near the desired location and then move it into place
using dimensions. See “Moving Objects Using Dimensions’ on page 787 of the

Reference Manual.

» Make sure that the CAD line extends past the fireplace in both directions.
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5. Select Build> Roof> Build Roof A from the menu, and in the Build Roof dialog, specify
the Pitch, Framing, and any other attributes that you will need for the cricket.

* In thisexample, aPitch of 12:12 and 1 1/2" x 5 1/2" rafters are specified. See “Build
Roof Dialog” on page 383 of the Reference Manual.

* Do not check Build Roof Planes. Here, the Build Roof dialog is being used to set the
defaults for manually drawn roof planes. See “ Roof Defaults’ on page 379 of the
Reference Manual.

6. Select Build> Roof> Roof Plane ) from the menu, then:

I -+

% |
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* Click on the CAD line near one of its endpoints and drag to draw aroof baseline
perpendicular to the line, towards the structure’sinterior.

* Release the mouse button and move the mouse parallel to the CAD line and in the
direction of the fireplace's center and click once.

* Theroof planethat is created will draw its height from the top of the roof below at the
point where you first clicked to begin drawing.

Note: In this example, the cricket roof plane is assigned an angled fill pattern to
make it easier to see.

7. Usedimensionsto resize the new roof plane so that it measures half the width of the
fireplace from its low edgeto itsridge. In this example, that distance is 24".

8. Use Roof Intersection Points to find the intersection point for the edge of the roof plane
opposite the fireplace. See “Locating Intersections’ on page 396 of the Reference Manual.

K

% |
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« If the program creates an Intersection Point that is not located on the roof plane edge,
move that edge so that it is closer to the fireplace and the roof plane is more narrow
and try again..

9. Usetheroof plane's edit handles to:
« Angle the low edge of the roof plane up to the Intersection Point.

« Drag the short edge of the roof plane outward until it disappears and the roof plane
becomes atriangle.

10. Usethe Copy/Paste " edit tool in combination with the Reflect About Object .0, edit
tool to create a copy of the cricket roof plane. See “ Reflect About Object” on page 178 of
the Reference Manual.

» Copy/reflect the roof plane about the fireplace to produce a roof plane that slopesin
the opposite direction as the original.

28
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11. Usethe Point to Point Move l+" edit tool to move the new roof plane so that its ridge
edge is adjacent to the origina roof plane’s ridge. See “Point to Point Move” on page 167
of the Reference Manual.

12. Center the cricket behind the fireplace:
* Shift+select the two cricket roof planes.

* Click the Center Objects ** edit button.
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* Move the mouse pointer over the fireplace. When a center axis displays over the
fireplace, click once.

13. Create a 3D view to see the results.

iy Remember to restore the settings in the Build Roof dialog if you intend to draw
@ more structural roof planes in your plan.

The cricket created above can easily be converted into a dormer vent. Begin by closing the 3D
view and returning to floor plan view.

To create a dormer vent

1. Select the fireplace positioned in front of the cricket and click the Delete X button.

2. Go Up OneFloor |4 and select Tools> Reference Floors> Reference Floor
Display =)

3. Select Build> Wall> Exterior Wall & and draw awall inside the area of the roof cricket
on the floor below, parallel to its front.



Skylights

« If you draw the wall in the wrong direction and its siding layer facesthe interior, select

it and click the Reverse Layers 't’ edit button.

4. Click onthewall to select it and click the Open Object )| edit button. On the RooF panel
of the Wall Specification dialog, check the box beside Roof Cuts Wall at Bottom and
click OK. See“Roof Panel” on page 235.

5. Withthewall still selected, useits edit handles to move it the desired distance from the
eaves of the roof cricket.

6. Createa3D view to seetheresults.

A selection of attic ventsis available in the Library Browser. See “Vents’ on page 308 of the
Reference Manual .

Skylights

Skylights can easily be added using the Skylight tool. In floor plan view, select Build>

Roof> Skylight then click and drag arectangular shape within an existing roof plane.
When you release the mouse button, a skylight is created and can be repositioned and resized
using its edit handles. For more information, see “ Skylights and Roof Holes’ on page 416 of
the Reference Manual.
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Skylights: Floor Plan x x
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Using the Break Wall Tool to Modify Roofs

Many homes have more than one roof type built above a single exterior wall. One common
exampleisareverse gable roof, created when a house has gable walls that are perpendicular to
one another, asin an L-shaped home.

We can create a reverse gable roof on an L-shaped home using the Break Wall (=5 tool.

To create an L-shaped home
1. Select File> Close All from the menu.

2. Select File> New Plan [ to open anew plan. In the Create New Plan dialog, select the
Default Style template.

3. Draw an L-shaped house with the following dimensions:

« Left wall - 30 feet long

« Upper wall - 45 feet long.

« Right wall 18 feet long.

 Lower wall extending |eft from the right wall - 25 feet long.

« Vertical wall connecting two lower walls - 12 feet long.

 Lower wall extending right from the left wall - 20 feet long.
4. If desired, turn off Auto Rebuild Roof and delete the roof.
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To create areverse gable in this plan, three gable walls are required: two running vertically and
one horizontaly.

To add a gable roof to the plan
1. Check Full Gable Wall on the Roor panel of the Wall Specification dialog for these three
walls:

» The far |eft vertical wall
* Thefar right vertical wall
» The bottom |eft horizontal wall

2. Click the Build Roof A button to open the Build Roof dialog, check Build Roof Planes,
and click OK to build the roof. The roof will look like this:

Reverse Gable Roof: Floor Plan X x
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The gable wall on the left produces roof planes that extend too high and interfere with the roof
over the front extension of the house. To avoid this, use the Break Wall tool to divide the | eft
wall into two different sections. The upper section can then be specified as a Full Gable without
affecting the lower section.

To use the Break Wall tool

1. Select Build> Wall> Break Wall %= and click the far left wall at a point even with the

lower right wall.
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2. Open the lower portion of the wall for specification and on the RooF panel of the Wall
Specification dialog, clear the Full Gable Wall checkbox and click OK.

3. Click the Build Roof ) button, check Build Roof Planes, and click OK to build a roof
based on the new wall specifications.

You now have two full gable roof sections meeting to form your L-shaped roof. Your plan
should look like the following image:



Adding a Roof to the Stucco Beach House
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Notice the step in theridge line. This can be corrected by resizing the lower gable wall. Select
the vertical wall to the right of the bottom gable wall and moveit to the left 2 feet, reducing the
length of the gable wall from 20 to 18 feet. When you are finished, rebuild the roof.
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This completes this Roof Tutorial. You can use any combination of the techniques described
here to create awide variety of roof designs.

Adding a Roof to the Stucco Beach House

With a basic understanding of how automatically generated roofs work, you can return to the

Stucco Beach House plan and add aroof. Select File> Save As [ and give this plan anew
name, such as "Beach House Roof Tutorial" before continuing.
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Individual walls can be selected and edited in both 2D and 3D views; however, when multiple
wallsmust be edited, it isusually quicker and easier to work in floor plan view: in part, because
you can hold down the Shift key and group-select walls. See “Editing Walls’ on page 212 of
the Reference Manual.

To edit the default roof
1. Closeany 3D viewsthat you may have open and work in floor plan view.

2. Starting on Floor 1, use the Select Objects || tool to select the top horizontal exterior
Kitchen wall:
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3. Click the Open Object ¥l edit button and specify thiswall asa Full Gable Wall. See
“Gable Roofs’ on page 5.

4. Click Up OneFloor i to go to the second floor.

5. Using the Select Objects 'k tool, select the Balcony room, then click the Open

Object I edit button. On the STRUCTURE panel of the Room Specification dialog,
uncheck Roof Over This Room, then click OK.



7.

Adding a Roof to the Stucco Beach House

Assign the Full Gable Wall and Extend Slope Downwar d settings to the exterior walls,
as shown in the following image. See “To set awall’s roof directives’ on page 3.
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Once these roof directives have been assigned, the roof can be generated.

To turn on automatic roof generation

5.

Select Build> Roof> Build Roof Y to open the Build Roof dialog.

On the RoOF panel, check Auto Rebuild Roofs and Build Roof Planes. See “Build Roof
Dialog” on page 383 of the Reference Manua for more information.

Set the Pitch to 3in 12.

You can go to the MATERIALS panel to change the material of your roof. Here, an Earth

Roof Tile material.

Click OK to close the dialog and generate a roof.
The additional wallsthat are created are attic walls. See “Attic Walls’ on page 4.
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6. Select 3D> Create Perspective View> Per spective Full Overview [ to create an
exterior view of your plan.

Beach House Roof: Floor Plan X x
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7. Remember to Save [ your plan as you work.
When you are ready, you can continue working on this plan in the Interior Design Tutorial.

Troubleshooting Automatic Roof Issues

38

Creating aroof automatically can require experimentation and practice. Here are some
suggestions for troubleshooting a problematic roof design.

Bear in mind that some complicated roof plans can only be produced by manually drawing and/
or edited roof planes. See “ Automatic vs. Manual Roofs’ on page 378 of the Reference
Manual.

Roof Directives in Walls

As discussed in this chapter and in the Roofs chapter of the Home Designer Pro 2017
Reference Manual, the program will automatically generate aroof plane bearing over each
exterior wall in aplan to produce a hip roof. If you require a different condition over a
particular wall, such as atriangular gable or side wall of a shed roof, you can specify that
condition on the ROOF panel of the Wall Specification dialog. See “Roof Panel” on page 235
of the Reference Manual.

Specifying roof directives that do not reflect what you require directly above a selected wall,
however, can often result in drastic and unwanted changes to your roof. For example, when two
parallel walls are specified as Full Gable Walls, asingle ridge will be created between them.
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If awall that is perpendicular to these wallsis also specified as a Full Gable Wall, the roof
becomes more complex with an additional ridge, two valleys, and two hips.

If you are seeing hips or valleysin your roof where you do not expect them, revisit the ROoF
panel of the walls supporting the affected roof planes.

To review how to restore wall directives back to their default state, see “To reset al roof
directives’ on page 4.

Roof Heights

The heights of all automatically generated roof planes are based on the heights of the wallsthat
they bear on. Wall heights, in turn, are determined by the ceiling heights of the rooms that they
define. See “Floor and Ceiling Heights” on page 258 of the Reference Manual.

For example, the hip roof over asimple rectangular structure with a consistent ceiling heights
(in this case, 109 1/8") has four roof planes.
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Thisroof will become considerably more complex if oneroom insideisgiven alowered ceiling
height (in this case, 97 1/8").
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97 118" || 109 1/8"
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109 178" 109 /8"

If you generate aroof and it seems to be more complicated and has more roof planes than it
should, take alook at the ceiling heights of the rooms in the plan. Often, the correct way to
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create alowered ceiling condition will be to set the ceiling at the default height create a
lowered Ceiling Finish. See “Lowered Ceilings’ on page 262 of the Reference Manual.

Controlling Roof Ridges

A singleroof ridgewill generate for aslong as the bearing walls that support the roofs on either
side of the ridge are the same distance apart. When alcoves or bump outs are introduced along
either bearing wall, theridgeislikely to become broken.

For example, asimple rectangular structure with Full Gable Walls at each end generates a roof
with aridge that runs from Full Gable Wall to Full Gable Wall.
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If abump out is added that affects the length of either Full Gable Wall, or if an alcove is added
anywhere along the length of the structure, the ridge will no longer follow a straight line.

r

There are anumber of ways to maintain asingle ridge line in the presence of alcoves or bump
outs:

« UsetheBreak Wall %* tool to control the length of a Full Gable Wall section. See “Using
the Break Wall Tool to Modify Roofs’ on page 32.
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* Increase the Minimum Alcove Size to specify what size alcoves are roofed. See “ Roof
Panel” on page 385 of the Reference Manual.

e Usethe Extend Slope Downwar d roof directive to allow the roof over a bump out to
extend lower then the ceiling height in that area. See “Roof Directivesin Walls’ on page

220 of the Reference Manual.
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» Specify the areainside of an alcove as an "Open Below" room with aroof but no ceiling,
and Use Soffit Surface for Ceiling specified. See “Room Types’ on page 253 and “ Struc-
ture Panel” on page 267 of the Reference Manual.
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