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Program Overview

Home Designer Interiors is designed to help Chapter Contents
home enthusiasts visualize, develop and . Startup Options
share their design ideas. Home Designer . The Home Designer Interiors Environment
Interiors uses parametric design technology, . Using the Mouse
which means that as you draw, a 3D model is . View and Side Windows
created and is updated as you make changes. . Toolbars and Hotkeys
You can tile a floor plan view next to a 3D . Menus
view and watch one update automatically as . Dialogs
you draw in the other. . The Status Bar
. Message Boxes
. Preferences and Default Settings
. Drawing a Plan
. Viewing Your Plan
. Getting Help
. About Home Designer
. Home Designer Trial Software
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Startup Options

. When Home Designer Interiors opens, The Startup Options dialog can be opened at
the Startup Options dialog displays, any time by selecting File> Startup

alloyving you tg choose how you want to Options = .

begin working in the program or access

useful resources.

™ Welcome to Home Designer *

Chief Architect® Software

Home Designer. Interiors

B New Plan.. (1) Getting Started @ Resources
. Open Plan.. -~ .Trulrnng Videos

New Users Start Here
. Download Cat:

Recent Files @ Announcements @
T\BD Library Catalog

Chief Architect

. Download No.7 Vases catalog to add
modern

W )me of our bonus ¢
a better brows ce. Update your library catalogs

o o Build: 20.1.0.31x64
MY ACCOUNT © Product Key: GOU22

o Select a File command to open a .plan

Choose Open Plan (| to work on an

file. existing plan file. See “Opening and
+ Click New Plan [ to open a new, blank Importing Files” on page 44.
file. See “Creating a New Plan” on page
38.
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9 Recent Files lists the full pathnames of
the most recently opened files. Click on
a name to open the file.

~.- Move your mouse pointer over a name
@ to see the file’s full pathname.

e A selection of useful online Getting
Started options and Resources are
available here. Click on an option to launch
your default internet browser to
HomeDesignerSoftware.com.

* Click Getting Started to visit the Getting
Started page on our web site with links to
a variety of resources to help you begin
using the program.

* Click Training Videos to access a
searchable collection of videos focused
on specific topics.

The Home Designer Interiors Environment

* Click Download Catalogs to visit our 3D
Library of downloadable bonus and man-
ufacturer library catalogs. See “Library
Content” on page 340.

When an internet connection is

available, the Announcements section
displays updated messages and news from
Chief Architect.

6 Click My Account to launch your
default internet browser to the Log In
page on our web site.

Your software version’s Build number
and the first five characters of your
Product Key display here for reference.

To prevent the Startup Options dialog from
displaying when you launch Home Designer
Interiors, uncheck Show Options on
Startup in the Preferences dialog. See
“General Panel” on page 60.

Object-Based Design

Home Designer Interiors’s parametric,
object-based design technology means you
place and edit objects, rather than work with
the many individual lines or surfaces used to
represent them.

You can quickly select and edit the location,
size, shape, style and other properties of
objects as well as change the materials
applied to their surfaces.

Use Home Designer Interiors’s editing
capabilities to make the objects you place in
a plan match the objects they represent in
real life. For example, you can set up your

The Home Designer Interiors Environment

windows and doors to match those available
from your supplier.

3D Drafting

In Home Designer Interiors, the entire
drawing area is laid out on a Cartesian grid, a
three dimensional coordinate system
described using the X, Y, and Z axes. The
current position of your mouse pointer
displays in the Status Bar at the bottom of the
program window.

Architectural objects take up space in all
three dimensions and their height, width and
depth can be specified in Imperial or metric
units. In addition, the location of objects can

19
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be precisely defined using coordinates, again
specified in Imperial or metric units.

CAD objects such as lines and arcs take up
space in two dimensions in the current view.
Their dimensions can also be specified in
Imperial or metric units and their locations
precisely defined using coordinates.

Easy Access to Tools

You can access Home Designer Interiors’s
features in various ways using the mouse and

Menus provide access to most tools.

Convenient toolbar buttons allow fast
access to tools and let you customize the
interface.

Keyboard shortcuts are available for most
tools.

Contextual menus display with a right-
click of the mouse.

The Status Bar at the bottom of the screen
provides tool descriptions and other
information about the current task.
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A number of useful drawing and editing
behaviors, as well as the display of important



elements in the interface, can be easily
enabled and disabled using the menus. For
example:

e Object Snaps, Angle Snaps, and Grid
Snaps can be toggled on or off as needed.
I See “Snap Behaviors” on page 78.

* Display Elements like Print Preview,
Show Line Weights, and the Reference
Display can be turned on when needed
and then toggled off.

When a setting is turned on, its icon in the
menu will display a small checkmark at its

Using the Mouse

lower right corner and have a border around
it in.

Object Shaps is disabled

Ij) Object Snaps

|r’: Angle Snaps F10
™~ Angle Shaps is enabled

Shift+F11

Many of these interface elements are global
Preferences while others are file-specific
default settings. See “Default Settings vs
Preferences” on page 54.

Using the Mouse

Many objects, such as doors and cabinets, are
created by clicking the left mouse button.
Others, such as walls, stairs and dimension
lines, are created by dragging the pointer
from one end of the object to the other.

( The left button is the primary
e button used in Home Designer
. Interiors. Unless specified
otherwise, Home Designer Interiors
documentation refers to the left mouse
button.

Note: If you are left-handed and have re-pro-
grammed your mouse, reverse the instruc-
tions for left and right buttons in this manual.

( The Right button has several uses.
P‘.

N

Right-click to select any object. If, for

example, the Straight Exterior Wall N
tool is active, the left mouse button only
allows you to select walls. You can, however,

select other types of objects such as cabinets
with the right mouse button.

You can also use the right mouse button to
open a context sensitive menu with
additional editing commands. See
“Contextual Menus” on page 25.

( The Middle button can be used to
¢ pan in most view types. To close a
\_, tabbed view window, click on its tab
using the middle mouse button. You
can also program it to work as a double-
click.

If your mouse does not have a middle mouse
button, in the Mac version of Home Designer
Interiors you can use the left button and the
Command key to achieve the same results.

( The Mouse Wheel can be used to
¢ zoom in and out in most view types.
See “Zoom Tools” on page 72.
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3D Mice

3Dconnexion®'s 3D mice can be used to nav-
igate in Home Designer Interiors. For infor-
mation about navigating in camera views and
overviews, see “3Dconnexion® 3D Mice” on
page 387.

Using a Trackpad

In addition to the standard trackpad gestures
on your system, in Home Designer Interiors
you can pinch to zoom.

In macOS ', you can Command + click to
pan. Panning is not supported in the
Windows version of the software, however.

Touch Screens

Standard one-finger touch screen gestures
are supported in both the Windows and Mac
versions of the software. In the Windows
version, touching with a second finger to
cancel an action is also supported, as are
two-finger pan and two-finger pinch to
zoom.

Edit Handles

When you select an object, its edit handles
display.

When you pass the mouse over an edit
handle, information about what the handle
does displays in the Status Bar and the
pointer changes to show how you can use
that handle.

e A two-headed arrow indicates that the
object, corner or edge can be moved in
the direction of the arrows.

» A four-headed arrow indicates that the
selected object or edge may be moved in
multiple directions.

e A circular arrow indicates that the
selected object can be rotated.

Resize handles display along the edges of the
object are used to change the size. See
“Resizing Objects” on page 115.

The Move handle at the object’s center lets
you move the object. Depending on the type
of object(s) selected and how far you are
zoomed in or out, the position of the Move
handle may shift so that it remains on-screen.
See “Moving Objects” on page 112.
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The triangular Rotate handle lets you rotate
the object. See “Rotating Objects” on page
117.
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You can cancel any edit handle operation
before it is completed by pressing the Esc
key on your keyboard or by pressing any two
mouse buttons at the same time.

The edit handles that display depend on the
type of object selected, the current view, and
how far you are zoomed out.

Edit handles do not resize as you zoom in or
out. If you are zoomed out far enough, some



edit handles may be hidden so that they do
not stack over one another. As you zoom in,
these handles become visible again.

Mouse Pointer Icons

The appearance of the mouse pointer in
Home Designer Interiors will vary,

View and Side Windows

depending on which tool is active. For

example, when the Select Objects | tool is
active, it will look like a white arrow, and

when a Cabinet Tool  is active, it will
look like a base cabinet with a small cross.

View and Side Windows

Home Designer Interiors’s main program
window has a number of important features
that let you interact with the program, such
as toolbars and menus. It also features two
different kinds of windows: view windows
and side windows.

View Windows

View windows are sometimes referred to as
“the drawing area” because most of them are
windows in which you can draw or place
architectural and/or CAD objects. There are
a number of different types of view windows
in Home Designer Interiors:

e Plan views
e Camera views and overviews

* Materials Lists

View windows can be navigated by panning
and zooming. You can also enable scroll bars
on their right side and bottom. Select View>
Scrollbars to toggle their display. See
“View Tools” on page 72.

Although only one view window can be
active at any given time, there is no limit to
the number of view windows that can be
open. View windows can be tiled or tabbed,
and you can navigate between them in a
number of different ways. See “Window and

View Tools” on page 69.

You can also tear a view window out of the
main program window. This creates a
second, separate program window complete
with toolbars and menus. Individual view
windows can be torn out and transferred
between program windows.

Side Windows

Side windows provide access to a variety of
tools and content that helps you add detail
your drawings.

Side windows are so-named because they are
typically docked to either the left or right
side of the program window - although, they
can also be docked to the top or bottom, or
undocked entirely. There are several
different types of side window:

* Child Tool Palette
e The Library Browser

Each of these side windows can be opened
via the View menu or by clicking the toolbar
button associated with it. Similarly, each can
be closed by clicking the Close button in its
title bar or tab, via the View menu, or by
clicking its toolbar button. See “View Tools”
on page 72.
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To undock a side window, either drag its title
bar out into the drawing area or click the
Undock button on its title bar. To dock a side
window, drag its title bar to any side of the
program window. You can also double-click
on its title bar to return it to its last docked
location.

Two or more side windows can be docked
together to form a shared side window, and
can be tiled and/or tabbed within that shared
window. To create a shared side window,
begin by docking a side window to a side of
the main program window, then:

» To create tabbed side windows, drag a
second side window over the first. When
the docked window becomes highlighted,
release the mouse button.

» To create tiled side windows, drag a sec-
ond side window over the first. When the
docked window becomes highlighted,
slowly drag the mouse towards one of its
sides. When a highlighted space is cre-
ated along that side, release the mouse
button.

You can choose to disable Side Window
Drag Docking in the Preferences dialog,
and you can also enable Top/Bottom
Docking. See “Appearance Panel” on page
58.

Side windows can also be set to their initial
states in the Preferences dialog. See “Reset
Options Panel” on page 64.

Toolbars and Hotkeys
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Using the toolbar buttons is the fastest,
easiest way to access many program features.
If a tool is active, a small checkmark will
display at the lower left of its button icon.
When you pass the pointer over a toolbar
button, a “tool tip” displays the name of the
tool and a more detailed description displays
in the Status Bar at the bottom of the
program window. When you see one of these
tool tips, press the F1 key to get more
information about that item. See “Getting
Help” on page 33.

Home Designer Interiors’s tools are
organized into families of related tools which
can be accessed using either of two styles of
toolbar interface: the Child Tool Palette or
Drop Down tools. You can select the
interface that you prefer in the Preferences
dialog. See “Appearance Panel” on page 58.

The Edit Toolbar

When you select an object, the edit toolbar
appears. By default, it is located at the
bottom of the program window, just above
the Status Bar. The buttons on the edit
toolbar can be used to edit the selected
object(s). Which buttons display depends on
the type of object selected, the current view,
and how you selected the object.

The edit toolbar buttons are the same as the
options in the contextual menu when you
right-click on an object. See “Contextual
Menus” on page 25.

Hotkeys

Many commands can be invoked from the
keyboard. Press Alt on your keyboard and
press the underlined letter in a menu name to



access that menu, as well as items in the
menus and submenus.

Other keys or key combinations will invoke a
variety of program commands. If a Home

Menus

Designer Interiors menu item has a keyboard
shortcut, or hotkey, associated with it, that
hotkey will display to the right of its name in
the menu.

Menus

Home Designer Interiors uses a standard
Windows menu format. The menus are
located below the title bar in the program
window and can be used to access nearly all
tools in the program. Click on a menu name
to expand it, then click on a menu item to
either activate that tool or access the item’s
submenu. Items with a submenu have an
arrow to the right of the name.

Menu items with an icon to their left have a
toolbar button associated with them.

The menus can be accessed using the
keyboard. Press the Alt key once to enable
this functionality - one letter in each menu
will become underlined. Press the key
associated with one of these underlined
letters to expand its menu - one letter in each
menu item’s name will be underlined. Press
the key associated with one of these letters to
activate that tool or access the item’s
submenu. Press the Esc key to undo your last
selection, or click with the mouse to exit out
of this functionality.

Many tools in Home Designer Interiors also
have hotkeys associated with them. If a menu
item has a hotkey, it will display to the right
of the item’s name. See “Hotkeys” on page
67.

Edit | Build Terrain  Library 3D CAD
7 Undeo Ctrl+Z
Cx Redo Ctrl+Y

Edit menu items with button icons
to the left and hotkeys to the right

In the Home Designer Interiors
documentation, menu paths are written in
this format: Build> Window> Box

Window 71

Contextual Menus

Contextual menus are context-sensitive
menus that display tools relevant to a
selected object or view. To open a contextual
menu, right-click on an object, in an empty
space in a view window, or in a text field in a
dialog box.

The options in an object’s contextual menu
are usually the same as those on an object’s
Edit toolbar. See “The Edit Toolbar” on page
24.

Q Select

[CF Select Next Object Tab

I open Object Ctrl+E
I=0 Copy/Paste Ctrl+Alt+C
‘:"l Copy and Paste in Place

%] Delete Del

i+ Addto Library

4 Center Object Ctrl+G
i. View Draw Order Edit Tools
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Contextual menus can be enabled or disabled
in the Preferences dialog. When contextual
menus are disabled, right-clicks perform

generic object selection, much like when the

Select Objects | tool is active See
“Appearance Panel” on page 58.

Dialogs
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Default and preference settings, object
specifications, display settings, and many
other functions are accessed through dialog
boxes.

Many dialogs have multiple panels, which
are listed in a tree list on the left side of the
dialog. Click on a panel name in the list to
make it active. In Windows, panels can also
be navigated using the keyboard. Press:

+ Ctrl + Tab or Ctrl + F6 to navigate for-
ward,

*  Ctrl + Shift + Tab or Ctrl + Shift + F6 to
navigate backward.

When a panel name is active, you can also
navigate the tree list using the Up and Down
arrow keys.

By default, dialogs always open to the first
panel in the list; if you prefer, you can choose
to Open Dialogs to the Last Panel Visited.
See “General Panel” on page 60,

Dialog panels and settings can be accessed
using the mouse. You can also navigate the
settings on a given dialog panel using the
keyboard. For example:

+ Line items in tree lists can be browsed
using the arrow keys. Up and Down navi-
gate the list, while Left and Right expand
and contract categories.

» Press the Tab key to shift focus from the
tree list to the first setting on the selected
panel.

e Press the Tab key to shift focus from one
setting to the next, or Shift + Tab to go in
the reverse direction.

* A check box can be checked or cleared
by pressing the Spacebar or the + or -
keys, respectively, while it is in focus.

* Columns of radio buttons can be navi-
gated using the Up and Down arrow
keys; rows can be navigated using the
Left and Right arrows. Select a radio but-
ton by pressing the Spacebar while it is in
focus.

e Settings in list boxes can be navigated
using the Up and Down arrow keys.
When a checkbox is in focus, it can be
checked or cleared by pressing the Space-
bar.

*  Drop-down lists can be browsed using
the Up and Down arrow keys. When the
mouse pointer is directly over the drop-
down, the mouse scroll wheel can also be
used; on a Mac, the list must also be
expanded. In Windows only, you can
press Tab to select the highlighted item in
the list and proceed to the next setting.

» Settings with spin control arrows ¥ can
be adjusted by typing in the text field or
using the Up and Down arrow keys.
When the mouse pointer is directly over
the setting, the mouse scroll wheel can
also be used.



+ Slider bars ~J~ can be adjusted by typ-
ing in the text field or using the Left and
Right arrow keys. When the mouse
pointer is directly over the slider bar, the
mouse scroll wheel can also be used.

» Line items in tables can be group selected
using the Ctrl or Shift keys, or by press-
ing Ctrl+A.

» Press Enter on your keyboard to close
most dialogs and apply your changes.

Note: Keyboard navigation in dialogs may
vary somewhat depending on your computer
platform.

In the Mac version of the software, Dictation
is supported in dialogs. Select Edit> Start
Dictation, then open a dialog. Say the word
“Numeral” before a number to enter it as a
numeric value or immediately follow a
number with a unit such as “foot” to enter it
as a measurement.

The units of measurement used in dialogs are
determined by your choice of template files.
See “Creating a New Plan” on page 38.

The number format used in dialogs are set
based on your operating system’s defaults.

Math Operations in Dialogs

Basic addition, subtraction, multiplication,
and division can be performed in the text
boxes where numeric values are entered.

Note that settings for angle, pitch, or bearing
do not support math, nor do those with spin
controls or slider bars.

* To add, type the + character followed by
the amount that you wish to add. Spaces

Dialogs

are ignored and including a unit of mea-
surement is optional.

* To subtract, type the - character followed
by the amount you wish to subtract. As
with adding, spaces are ignored and a
unit of measurement is optional.

* To multiply, type the * character followed
by the amount you wish to multiply by.
Spaces are ignored, and only one of the
values being multiplied can have a unit of
measurement.

» To divide, type the / character followed
by the amount you wish to divide by. To
divide, there must be a space before the /
- if there is not, the input may be treated
as a fraction. The denominator, or value
typed after the /, cannot have a unit of
measurement.

Math expressions support a single operation
only: more than one operation character (+, -,
* /) at a time is not allowed.

Basic math operations can also be used to
move objects using dimensions. See
“Moving Objects Using Dimensions” on
page 192.

Dialog Size and Position

Dialog boxes can be both moved and resized
to suit your needs. By default, the program
will remember both the position and size that
you specify for a dialog and use it the next
time you open it. You can specify whether
the program does this always, per session, or
never in the Preferences dialog. You can
also reset the default sizes and positions. See
“Reset Options Panel” on page 64.

» To move a dialog, position your mouse
pointer within its title bar and then simply
click and drag.
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* To resize a dialog, position your mouse
pointer on any edge or corner and then
click and drag outward or inward. If you
drag an edge, only that edge will move; if
you drag a corner, the two adjacent edges
will move.

When a dialog is resized, some elements
within it may resize in response: for
example, some list boxes and text fields.
Some elements within a dialog box can also
be resized independently. See “Dialog Panel
Splitters” on page 28.

Note that all dialogs have a minimum size
limitation but no maximum size. If a dialog
opens on a monitor with resolution too low to
display its full extents, it will have vertical
and/or horizontal scroll bars.

Note: Some of the dialog box images in the
software documentation have been resized
smaller than their actual minimum size.

Specification Dialogs

I—l Each object in Home Designer
Interiors has a unique specification
dialog where you can enter size, style and
other information specific to the selected
object. To access it, select the object and
click the Open Object edit button. You can
also double-click on an object with the Select

Objects | & tool active to open its
specification dialog. See “Selecting Objects”
on page 94.

Most objects also have a defaults dialog that
lets you specify the initial values in the
specification dialog.

Dialog Preview Panes

Many specification dialogs have a preview
pane that shows how changes affect the
selected object. This preview updates when
you click in a different field or press the Tab
key on your keyboard.

When you click in the preview pane, your
mouse pointer changes to a four-headed
arrow and you can rotate around the object as
well as zoom in and out using the mouse
scroll wheel. Some objects, notably walls,
doors, and windows, have Interior and
Exterior labels to indicate which side is
visible in the preview. Click the Fill

Window [ button above the preview pane
to zoom in or out so that the object fills the
extents of the pane, maintaining the current
rotation.

A selection of Rendering Techniques can be
applied to the preview in most dialogs:
Standard, and Glass House. See “Rendering
Techniques” on page 407.Click the

Color ™ button to turn color in the preview
off or on. Some objects have additional tools
that affect object previews. For example, the
Cabinet Specification dialogs have a Select

Cabinet Face Item 7% button. Object
specific tools like this are discussed in the
documentation for that object type.

Dialog Panel Splitters

Many dialog panels are divided into up to
three sections: a list of panels on the left, an
object preview on the right, and a central
area where settings are located. The vertical
splitters separating these sections each have a
pale, dotted handle.



To resize the panel list or preview, as well as
the area in the middle, move your mouse
pointer over the vertical division line: when

The Status Bar

the splitter cursor 4b can be seen, click and
drag to the left or right.

The Status Bar

The Status Bar at the bottom of the main
program window displays information about
the current state of the program.

This information depends on a variety of
conditions such as the type of object
selected, and the current position of the
pointer. The information may include the
following:

» The type of object currently selected or
the total number of group-selected
objects.

* A description of the edit handle that the
pointer is over.

e A brief description of the toolbar button
or menu item highlighted by the mouse.

¢ The name of the active tool and its hot-
key, if it has one.

» The length and/or angle of an object as it
is being drawn.

* Basic information about a selected library
object, folder, or catalog.

» The current floor.
» The layer that the selected object is on.

e The size of the active window in pixels.

Message Boxes

As you work in Home Designer Interiors, the
program will occasionally prompt you to
examine your settings, alert you if you
command it to do something that could
potentially cause a problem, or notify you if
it encounters a problem that needs your
attention.

™ Information

.'6] Area too constricted, could not position fixture item here,
[] Do not show this message again

Check Knowledge Base

Situations where such message boxes may
display include:

* Closing a file without saving;

* Modifying an object that is set to rebuild
automatically;

* A file referenced outside the program,
such as an image or texture, is missing;

« Creating an object in a space too small to
contain it.

As with dialog boxes, you can access the
options in a message box using the mouse or
navigate them using the keyboard.

A few messages have a Send Report button.
Click this button to send details regarding the
issue that prompted the message to Chief
Architect via the internet.
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Some message boxes include a “Remember
my choice” or a “Do not show this again”
checkbox. Check this box to prevent
messages of this specific type from
displaying in the future. When this box is

checked, some options in the message box
may become inactive.

To allow all message boxes to display again,
click the Reset Message Boxes button in the
Preferences dialog. See “Reset Options
Panel” on page 64.

Preferences and Default Settings
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Preferences and default settings control
many aspects of the user interface and tool
behavior in Home Designer Interiors. You
can use these settings to customize the
program to suit your personal work style.

For more information about defaults and
preferences, see “Preferences and Default
Settings” on page 53.

Preferences

Preference settings let you change program
behavior to suit your workflow. For example,
you can:

* Turn certain display elements on or off.

+ Choose background and editing feedback
colors.

+ Set rendering specifications to maximize
efficiency and quality.

Preference settings are global, affecting all
plan files.

Defaults

Most objects in Home Designer Interiors
derive their intial properties from their
respective default dialogs.

For example, a newly placed Window =
gets its initial values from the Window
Defaults dialog and a newly placed Hinged

Door I\ gets its initial values from the Door
Defaults dialog.

Once an object is placed in a plan, its initial
properties can be overridden, but setting up
your defaults before you begin drawing can
save you considerable time as you build a
model in the program.

Default settings, unlike Preferences, are file
specific.

Dynamic Defaults

Most default settings are static: if you change
one, any objects of that type in the current
file will not be affected. A few defaults,
however, are dynamic: they are tied to
existing objects in the drawing and if you
change the default, those objects may be
affected. See “Dynamic Defaults” on page
55.



Drawing a Plan

Drawing a Plan

When you draw a plan in Home Designer
Interiors, you are placing 3D objects that
represent building components. Home
Designer Interiors comes with predefined
default settings so you can start drawing
plans immediately. You should review these
default settings to be sure they match your
drawing and building methods. See
“Preferences and Default Settings” on page
53.

Set the Defaults
Specify the defaults for walls.

2. Set material defaults for roof, walls, and
rooms.

3. Set style defaults for doors, windows,
cabinets and other objects.

Draw the Floors

1. While the size of the drawing area in
Home Designer Interiors is limited only
by the resources on your computer, it is
best to begin your drawing near the ori-
gin, 0,0,0. See “3D Drafting” on page
19.

2. Draw the exterior walls on Floor 1. See
“Drawing Walls” on page 141.

3. Adjust the perimeter shape and size as
required. See “Using the Edit Handles”
on page 148.

4. Place any first floor bearing walls.

Define types for special rooms such as
garages and decks in the plan. See
“Room Types” on page 165.

6. Place perimeter doors and windows. See
“Doors” on page 209 and “Windows” on
page 225.

7. Build additional floors. See “Adding
Floors” on page 289.

8. Specify the default ceiling height for
each floor as soon as it is created. See
“Floor Defaults Dialog” on page 288.

9. Adjust the perimeter shape of additional
floors as needed. See “Editing Walls” on
page 148.

10. Align edited or moved walls with those
above or below where appropriate. See
“Aligning Walls” on page 151.

Entering Dimensions

When using Imperial units, enter distances as
inches or feet and inches, in fractional or
decimal form. Millimeters are the default
unit for all metric distances. See “Dimen-
sions” on page 183.

» To enter feet, include the (') marker or
the program assumes inches.

* In most cases, the program allows
precision to 1/16th of an inch. Fractions
with denominators 2, 4, 8 and 16 are
allowed.

* The program usually converts decimals
to fractions.

Build the Foundation

1. Derive the foundation plan from the first
floor. See “Building a Foundation” on
page 278.
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2. Adjust the foundation perimeter shape
as needed.

3. Place interior foundation walls as
needed for the first floor bearing walls.

4. Place any other foundation walls
required.

5. Align with Above as needed. See
“Aligning Walls” on page 151.

Viewing Your Plan

You can see your model in a variety of
different 2D and 3D views. You can display
more than one view at a time; and in any
view, you can pan or zoom in or out. See
“Window and View Tools” on page 69.

Floor plan view is a 2D view of the model

most commonly used for drawing and editing.

Each floor displays separately; however, you
have extensive control over which objects
display at any given time, can easily switch
between floors, and can also display items on
a second floor for reference. See “Multiple
Floors” on page 287.

You can create interior and exterior 3D views
of your model from any perspective. As in

floor plan view, you can select and edit many
objects in 3D views and control which objects
are visible. See “3D Views” on page 381.

You can also create Doll House Views that
show only the current floor plus any floors
beneath it. Ceilings on the current floor are
omitted so you can see the interior, visualize
the relationships between spaces, and plan
traffic flow.

All views can be exported as a graphic
image. See “To export a picture” on page
420.



Getting Help

Getting Help

There are many forms of help
= | available in Home Designer Interiors
including: Tool Tips, the Status Bar, and the
online Help menu.

All these forms of help assume you have a
basic working knowledge of your operating
system, including how to use a mouse, open,
close and save files, copy, paste, and right-
click to access contextual menus. Help also
assumes you are familiar with basic
computer terminology.

More information is available in the product
documentation in electronic format and on
Home Designer’s official web site,
HomeDesignerSoftware.com.

See “Additional Resources” on page 457.

Tool Tips

When you move the pointer over a toolbar
button or menu item, a Tool Tip displays,
offering a brief description of the tool. More
information displays in the Status Bar at the
bottom of the window.

Contextual Help

? Online Help is a searchable menu that
= | provides information about all of the
tools in Home Designer Interiors. Select
Help> Launch Help to open the program’s
Help and explore the table of contents,
browse the Index, or Search for keywords.

The Help can also be used to provide instant
information about toolbar buttons, menu
items, and objects in your plan.

*  When you move the cursor over a toolbar
button or menu item, a brief summary of
that tool displays in the Status Bar. Press
the F1 key to open online Help to a page
with more information about the tool.

*  When an object is selected, edit handles
display. Place the cursor over an edit han-
dle and press F1 to open online Help to a
page with information about that handle.

* Press the Help button in any dialog box
to open online Help to a page describing
the options in that dialog.

Chief Architect strives to make our docu-
mentation as helpful as possible for all of our
customers. Please send any suggestions to
documentation@chiefarchitect.com.

About Home Designer

Select Help> About Home Designer
Interiors in Windows® or Home Designer>

About Home Designer in macOS"" to view
information about your software license, the

program’s version number, and its release
date.

Contact information for Chief Architect, Inc.
is available on the MORE INFORMATION
panel.
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Product Upgrade Options

Select Help> Product Upgrade Options to
launch your default web browser to the
Home Designer web page,

www.homedesignersoftware.com, where you
can learn about options for upgrading your
software license.

Home Designer Trial Software

34

Free Trial versions of some Home Designer
programs are available for download at
HomeDesignerSoftware.com.

The Trial software offers the same
functionality as a purchased license with a
few limitations:

* File Saving

* Printing

+ File Exporting

* Recording of Walkthroughs

* Printing or Exporting of Materials Lists

+ Library Browser restrictions

Converting the Trial Version

An installation of the Home Designer
Interiors Trial software can be converted into
a full working version of the program at any
time by purchasing a software license. There
are several ways to begin this process in the
Trial:

* Click the Purchase Full Version Now
button in any Trial Restriction message
box.

» Select Help> Purchase Home Designer
Interiors &
» Select File> Startup Options and

then click the Purchase Full Version
Now button.

Once you have purchased a license, you can
activate it while the Trial software is running.

To activate the full version

1. Select Help> Activate Full Version.

2. In the Product Activation dialog, type
or paste the Product Key associated
with your software license.

3. Click the Activate Full Version button.


http://www.homedesignersoftware.com/discounts/
http://www.homedesignersoftware.com/products/trial.html

Chapter 2:

File Management

Home Designer Interiors saves the complete
3D model of a structure as well as any text
and dimensions associated with the model in
.plan files.

All commands related to opening, saving and
closing plans are located in the File menu.
You can also open plans from the Startup
Options dialog. See “Startup Options” on
page 18.

Just as with files created in other software
applications, you should back up your plan
files externally on a regular basis to avoid
accidental loss of work.

Chapter Contents
Compatibility with Other Programs
Organizing Your Files
Home Designer Interiors Data
Creating a New Plan
Saving, Exporting, and Backing Up Files
Thumbnail Images
Auto Archive
Undo Files
Opening and Importing Files
Referenced Files
Backup Entire Plan
Exiting Home Designer Interiors
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Plans produced in the following programs
can all be read by Home Designer Interiors
2019.

«  Chief Architect® X1 through X10 (lim-
ited editability if enabled)

«  Chief Architect® 10.0 through 11.3 (read
only)

» All Better Homes and Gardens Home

Designer® products, Interior Designer,
and Landscaping and Deck Designer,
Versions 7 and 8.

* All Chief Architect Home Designer®
products, Interior Designer, and Land-

scaping and Deck Designer, Versions 9
through 2018.

Files that have been opened and saved in
Home Designer Interiors 2019 cannot be
read by any of the program versions listed
above. To continue to read files in the
program in which they were created, be sure
to create copies of your files before opening
them in Home Designer Interiors 2019.

Plans produced in the Windows® version of

Home Designer Interiors 2019 can be read in
the Mac® version, and vice versa.

Compatibility with Other Programs

Opening Chief Architect Plans
in Home Designer Programs

Plans created in Chief Architect Versions 10
through X10 and Home Designer Pro
Versions 7 through 2019 can be opened in the
latest Home Designer programs for viewing
and annotating, but not for general editing or
drawing of architectural objects.

Plans created in build 11.4 or later of Chief
Architect X1 or Home Designer Pro 8§, or in
later program versions, can be set to allow
limited editability in other Home Designer
programs. When this permission is enabled, a
Home Designer user can use all of their
program’s drawing tools and can edit objects
in the plan that those tools can create. If an
object cannot be created in the Home
Designer program, however, it will not be
editable.

Please note, too, that if a plan has more floors
than the Home Designer program supports,
the entire plan can be viewed and annotated
only.

In addition, Chief Architect and Home
Designer Pro have the ability to lock layers.
Objects cannot be drawn on locked layers;
objects on locked layers cannot be selected;
and locked layers cannot be unlocked in the
other Home Designer programs. See
“Layers” on page 86.

Organizing Your Files

You should keep your plan files separate
from the support files needed to run Home
Designer Interiors. To keep files organized,

you may find it helpful to create a new folder
for each project.



Home Designer Interiors files may use
imported images, textures and other custom
content saved in their own external data files.
Consider storing copies of all external files in
the same folder as the plan files that use them
so that they are easily found.

Here is one way to organize your files:

e Create a folder in your Documents direc-
tory called “Home Designer Interiors
Plans” or another name you prefer. See
your operating system’s Help to learn
how to create folders.

* Inside this folder, make a new folder for
each project. Save all the files for that

Home Designer Interiors Data

project inside this folder, including plan
files and referenced external files. See
“Saving, Exporting, and Backing Up
Files” on page 39.

Bear in mind, though, that path names
exceeding 260 characters cannot be opened
by Home Designer Interiors. As a result, it is
a good idea to limit the number of embedded
folders you use in your file organization
method.

Once you understand the file management of
Home Designer Interiors, you can decide on
a naming convention that suits your needs.

Home Designer Interiors Data

When Home Designer Interiors 2019 is
installed, the program automatically creates a
folder in the user Documents directory called
Home Designer Interiors 2019 Data. This
folder contains important user-specific
information saved in the following folders
and files and should not be moved, renamed
or deleted:

* Archives - A folder of automatically
archived plan files. See “Auto Archive”
on page 42.

* Backdrops - A folder of custom back-
drop images. See “3D Backdrops” on
page 385.

» Images - A folder of custom images. See
“Adding Materials and Images” on page
345.

* Database Libraries - A folder of user
library data. See “Library Content” on
page 340.

* Scripts - A folder for custom Ruby
scripts associated with Chief Architect
plans.

» Templates - A folder of plan template
files. See “Creating a New Plan” on page
38.

» Textures - A folder where you can save
image files used to create custom material
textures. See “Creating Materials” on
page 375.

» Toolbars - A folder of toolbar files. See
“Toolbar Arrangement” on page 65.

* _MigrateBackup - If you migrated leg-
acy settings into version 2019, additional
folders with names appended with
_MigrateBackup may also be present. See
“Migrating Settings and Content” on page
15.
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If the Home Designer Interiors 2019

Data folder is renamed, moved or
deleted, the program will automatically
replace it using default information from the
Home Designer Interiors installation folder.
When this occurs, customized user settings
and custom user library content will not be
available.

Because the Home Designer Interiors 2019
Data contains custom user data, it is not
deleted when the program is uninstalled. See
“Uninstalling Home Designer Interiors” on
page 18 of the User’s Guide.

Creating a New Plan

D To open the Create New Plan dialog,
select File> New Plan.

You can also choose New Plan in the
Startup Options dialog. See “Startup
Options” on page 18.

Template Plans

D When you select File> New Plan in
Home Designer Interiors, the Create
New Plan dialog opens, letting you select a
template for your new plan. The resulting
new plan uses either metric or U.S. units of
measurement and predefined default settings
for objects like walls, doors, windows, and
cabinets. See “Default Settings” on page 54.

r\ Create Mew Plan

Measurement Units: | U.S. Units (inches)

-

Default Style

American Casual
Arts & Crafts

Colenial

Country Cottage
Mediterranean Influence
Today's Traditional

Urban Chic/Contemporary

you want to create a style of your own.

Default Style New Project—-Taking advantage of our most basic components, the Default settings give
flexibility in concept and design. Use this template when you don't have a spedific style in mind, or when

*

oK Cancel

+ Select either U.S. Units or Metric Units
of measurement. Once a new plan has
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been created, its Measurement Units can-
not be changed.



* Select a style template from the list. If you
are uncertain as to the right style for your
plan, choose Default, as you cannot
change the plan style template once a plan
has been created.

Saving, Exporting, and Backing Up Files

When you click OK, a new floor plan view
window opens, ready for you to begin
drawing.

New, blank plans are called Untitled.plan.
Unless these files are named and saved, they
will be lost when closed.

Saving, exporting, and backing up your files
are three separate tasks that accomplish
different things:

+ Saving a plan file retains your work so
that it can be later opened in Home
Designer Interiors.

» Exporting a file allows you to save certain
kinds of data in a format that can be used
by a program other than Home Designer
Interiors.

* Backing up your files involves taking
steps to make sure that your valuable data
is protected and available when needed.

Whether you are saving, exporting, or
backing up your data, it is important that you
select a location on your computer for the
files you create, and also specify a short,
meaningful name that you will be able to
identify in the future.

To save an untitled plan file

1. Select File> Save [zl to open the Save
File dialog.

2. Specify a location on your computer
where you would like to save the file.

See “Organizing Your Files” on page 36.

3. In the File name text field, type a name
for the file.

Saving, Exporting, and Backing Up Files

4. Home Designer Interiors automatically
assigns the File of type and file exten-
sion .plan.

5. When both the Save in location and File
name are correct, click Save.

iy Although the program warns you if you
@ try to exit without saving, you should get
in the habit of saving plan files before exiting
the program.

Saving Plan Files

IEI IEI When you first save a new,
untitled file, you must select a

location for it on your computer and give it a
name. There are two options for saving plan
files: File> Save and File> Save As.

Both Save [zl and Save As [l can be used
to save your plan files; however, they
accomplish this in two different ways.

- File> Save [l saves the current state of
your plan file without changing its name
and should normally be used for saving
your work.

« File> Save As = opens the Save File
dialog, allowing you to save the plan file
using a different name or location on your
computer.
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Initially, all Open [ and Save As [«
operations go to the “My Documents” folder
of your computer. After that, the location last
visited is remembered and subsequent

Open |_| or Save As =) commands default
to the directory last used for that operation.
This path is saved when the program exits.
The next time Home Designer Interiors is
launched, these defaults are used.

Save File Dialog

The Save File dialog uses the operating
system’s file save dialog format, and is also
used when exporting files. The dialog name

may vary, depending on the type of file being
saved or exported.

A similar Select Folder dialog allows you to
select a folder to which files can be exported.

r\ Save Plan File
- + 1

Organize « MNew folder

£ Riverstone.plan
7 Quick access

[ Desktop
4 Downloads
|| Documents
&=/ Pictures
Riverstone

f@ OneDrive
[ This PC

¥ Metwork

» ThisPC » Documents » Chief Architect Plans » Riverstone ov o)

*

Search Riverstone 2
- @

File name: | Riverstone_revision.plan

(3

Save as type: | Plan Files (*.plan)

» Hide Folders

o -

Cancel

Save

0 Choose a location on your local
computer for the file you are saving.

Any existing folders and/or files in the
current location display here.

)

9 In the File Name field, type a name for
the file. If you select an existing file

from the space above, its name will display
here automatically.

0 When saving a file, the program will

choose the appropriate file type from
the Save as type drop-down list. When
exporting, you may need to choose a specific
file type.



Saving Revision Files

Revisions are a common aspect of any design
project. There are a number of possible
strategies for organizing revision files:

* Prepending the file name;
* Appending the file name;

+ Saving revisions in separate folders.

To avoid confusion and potential mistakes, it
is recommended that you always give files
unique names - including revision files. If
you choose to organize your revisions by
saving them in separate folders, you should
also give each file a unique name that makes
it impossible to confuse it with another file
saved in a different folder.

Exporting Files

Home Designer Interiors has a number of
options for exporting and importing
information out of and your drawings. See
“Pictures, Images, and Walkthroughs” on
page 413.

Often, file export dialogs are simply versions
of the Save File dialog.

Similarly, file import dialogs are often
similar to the Open File dialog. See
“Importing Files” on page 45.

Backup Entire Plan

File> Save As c isa simple way to transfer
a plan to a different location on your
computer. Bear in mind, though, that plan
files often reference external data files such
as imported textures, images, and backdrops.
These external files are not affected when

Save As ol is used.

Saving, Exporting, and Backing Up Files

If you transfer a plan file from one computer
to another, the program will warn you of
missing files if the external data files used by
the plan cannot be found when you open it.

When transferring plans to another computer
that does not have these external files, use

the Backup Entire Plan £ tool. See
“Backup Entire Plan” on page 47.

Backing Up Your Files

It is always a good idea to create backup
copies of all your important files on your
computer.

It is strongly recommended, however, that
you never save directly onto removable
media such as a USB thumb drive, CD, or
DVD. Instead, copy your files to such
locations only after you have saved them on
your computer’s hard drive and exited the
program.

Archive folders are used by Home Designer
Interiors to manage prior versions of your
files. You should not view these files as a
substitute for your own backup routine, and
should never save a file in an archive folder.
See “Auto Archive” on page 42.

When backing up your Home Designer
Interiors files, consider backing up not only
your .plan files, but your custom user data,
as well - including library content, toolbar
configurations, and textures. This custom
data is all located in the Home Designer
Interiors Data folder, so it can be easily
backed up. See “Home Designer Interiors
Data” on page 37.

You can, if you wish, create a folder inside
the Data folder for your .plan files, as well.
See “Organizing Your Files” on page 36.
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Thumbnail Images

A thumbnail is a miniature image that helps
identify a file in the Open Plan File dialog in
Windows. Any view of a plan can be saved
as the thumbnail.

The program automatically creates a
thumbnail image when you first save a new
plan. You can choose to generate small or
large thumbnails.

To create a custom thumbnail image

1. You must save the file and give it a name
before you can save a thumbnail.

2. Create the 2D or 3D view that you want
to use as a thumbnail for the current file.

3. With the desired view active, select

File> Save Thumbnail Image B3

Thumbnail images are saved in the plan file
that they are associated with.

Auto Archive
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The first time a plan is saved, Home
Designer Interiors creates an Archive folder
in the Home Designer Interiors Data folder.
The Archive folder contains Auto Save and
Archive files.

The program does not create Auto Save and
Archive files for untitled plans. In order for
these to be created, a file must have been
previously saved and given a name and save
location on your computer. Further, Archive
files are only updated when you save your
work.

Auto Save and Archive files should not be
viewed as a substitute for regularly saving

your work by selecting File> Save (=) or
pressing Ctrl + S on the keyboard, nor should
they be considered an alternative to your own
file backup routine.

Archive Files

Every time a drawing is saved, Archive files
that keep a historical archive of your plan are
automatically created or updated.

& If you do not save your work regularly,
your archive files will not be updated.

Plan files from previous versions of the
program are automatically moved to the
archive folder when the plan is opened and
saved in Home Designer Interiors.

Archive files are meant to be for emergency
use only. If you must access an archive file,
open it as you would any other file. See

“Creating a New Plan” on page 38. As soon

as the file is open, use Save As = to save
this file to another location.



Legacy Archive Files

Plan files saved in the current program
version are not backwards-compatible: that
is, they cannot be opened in older versions of
the software.

If you open a Home Designer plan file from a
previous program version and immediately

Save | it (not Save As = ), the Auto
Archive utility will create an additional
archive file using the original program
version format. This archive file is a copy of
the original and can still be opened in the
original program version.

Auto Save Files

As you work, Home Designer Interiors
automatically creates Auto Save files at
regular intervals when changes are made to a
file but not saved by selecting File>

Save [

These Auto Save files are appended
_auto_save.plan and are saved in the
Archive folder.

When you close a file normally, its Auto
Save file is retained until the next time the
file is opened - at which time the Auto Save
file is overwritten.

Undo Files

@ JonesResidence_auto_save.plan

Auto Save file after normal shut-down

Auto save files created as a result of an
improper program shutdown are appended
_auto_save_bak.plan.

@ JonesResidence_auto_save_hak. plan
Auto Save file after abnormal shut-down
If your computer shuts down accidentally,

you can recover some of your work by
opening the _auto_save_bak file.

& A file is auto saved only if you have
saved it previously. Auto Save does not
work for unnamed files.

When you reopen a file after a computer shut
down or system crash, the program will
notify you if an Auto Save file newer than
the original file is found and give you the
option to one that file.

Even with Auto Save, you should save your
work manually on a regular basis using any
of the following methods:

« Click the Save =l button.

« Select File> Save [,
* Press Ctrl + S on the keyboard.

Undo Files

Home Designer Interiors stores a set number
of copies of all open plan file changes,
known as undo files. Undo files are
referenced whenever you select Edit>

Undo 2 or Edit> Redo €. See “Undo
and Redo” on page 120.

Undo files are stored in your operating
system’s Temp directory. When Home
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Designer Interiors is closed normally, any
current Undo files are deleted.

Opening and Importing Files
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Opening and importing files are often similar
tasks, but accomplish two very different
things:

Opening a file refers to opening it in the
program in which it was created. Only
plan files can be opened in Home
Designer Interiors. See “Compatibility
with Other Programs” on page 36.

Importing a file brings data that was cre-
ated in a different program into Home
Designer Interiors. A number of different

file types can be imported into Home
Designer Interiors.

[—~_] Select File> Open Plan to open an

existing .plan file located on your
computer. Home Designer Interiors
automatically browses to the directory last
used.

i, Before opening a file located on a
@\ removable storage device, server, or
other computer on a network, copy it to your
local machine’s hard drive first.

Open File Dialog

The Open File dialog uses the operating
system’s file open dialog format, and is also
used when importing files. The dialog name
may vary, depending on your operating

system and the type of file being opened or
imported.

A similar Select Folder dialog allows you to

select an entire folder of files to import.




Opening and Importing Files

™ Open Plan File
« .

Organize « MNew folder

£ Riverstone.plan
7 Quick access

[ Desktop
4 Downloads
= Documents
&=/ Pictures
Riverstone

f@ OneDrive
[ This PC

¥ Metwork

» ThisPC » Documents » Chief Architect Plans » Riverstone ov o)

*
Search Riverstone 2
e v i | 0

File name: |Ri\rer5t0ne.plar1

Plan Files (*.plan) o v

o Choose the location on your local
computer for the file you are opening.

9 Any existing folders and/or files in the
current location display here.

9 In the File Name field, type the file’s

name. If you select the file in the space
above, its name will automatically display
here. When importing some types of files,
multiple files may be selected.

o When opening or importing a file, the
program will usually choose the
appropriate file type from the Save as type
drop-down list. When importing, you may

need to choose a specific file type.

Plan files open to the floor that was active
when the file was last saved and closed.

Importing Files

Home Designer Interiors has a number of
options for exporting and importing
information out of and into your drawings.
Often, file import dialogs are simply versions
of the Open File dialog. See “Pictures,
Images, and Walkthroughs” on page 413.

Similarly, file export dialogs are often similar
to the Save File dialog. See “Exporting
Files” on page 41.

Recently Opened Files

A list of recently opened and saved plan files
can be accessed by selecting File> Open
Recent Files. Select one of these files to
open it without using the Open File dialog.

The names of recent files also display in the
Startup Options dialog. Click on the name
of a file to open it. See “Startup Options” on
page 18.
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Referenced Files
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Home Designer Interiors plan files often
reference a variety of external files for added
detail, including:

* Material Textures
* Images

+ Plant Images

* 3D Backdrops

+ Picture Files

Whenever any view in a plan is opened, the
program checks for referenced files used in
that view and will notify you if any of those
files cannot be found by opening the Missing
Files dialog.

You can also open this dialog at any time by
selecting Tools> Checks> Missing Files.
When accessed this way, all missing files
associated with the current file are listed: not
just those used in the current view.

» PDF Files
Missing Files Dialog
™ Missing Files *
Missing File File Usage Object Name Object Location File Path Replace Image...
backdrop.png  Backdrop  backdrop Ci\Users\A... Replace File
imagepng __Image __limage ___|1stFloor | __|C\Users\A..
pdf file.pdf PDF pdf file 1st Floor Ci\Users\A... Delete Image
picture file.png  Picture picture file 1st Floor Ci\Users\A...
plant image.png Plant Image plantimage  1st Floor ChUsers\A... o
texture.png Texture material Plan Materials  In Use Ch\Users\A...
Add Search Directory...

0 The table lists any Missing Files as well
as useful information about each:

* Missing File reports the name and file
extension of the missing file.

+ File Usage indicates how the missing file
is used in the program.

* Object Name states the name of the
object in Home Designer Interiors that
references the file.

* Object Location indicates where in the
file the object can be found.

e The next column indicates whether a
missing texture is in use in the plan.

¢ File Path states the last known location of
the missing file on your computer system.

Click on a line item in the table to select it
and resolve it using the options on the right.
Multiple line items can be selected; however,
the selections on the right may be limited.
See “Shift and Ctrl Select” on page 96.

g The buttons on the right offer options
for resolving a selected missing file.
The names of these buttons will vary some-



what, depending on the type of file(s)
selected in the list on the left.

* Click the top Replace Object button to
replace any instances of an object or
material referencing the selected missing
file with a different object or material
from the library. Not available for PDF
files or picture files.

* Click the Replace File button to open the
Browse for Missing File dialog and
select a file saved on your system to
replace the missing one. See “Opening
and Importing Files” on page 44.

* Click the Delete Object button to remove
the object or material referencing the

Backup Entire Plan

missing file from the plan. Not available
for material textures that are In Use.

¢ Click the Add Search Directory button to
direct the program to a particular folder to
search for missing files in. The list of
Search folders can be reset in the

Preferences dialog. See “Reset
Options Panel” on page 64.

You can prevent this dialog from opening
automatically by checking Do not display
missing files again during this session at
the bottom of the dialog. This option is not
available when the dialog is opened
manually.

Backup Entire Plan

é Because Home Designer Interiors
plans contain many references to
external files such as material textures and
images, it is a good idea to make copies all
the associated files when a planis moved to a
new location. You can easily do this by
selecting File> Backup Entire Plan.

Backing up an entire plan is important when:

* Migrating legacy files created in older
program versions.

* Transferring files to another computer or
sending them to another user.

e Archiving or backing up your work.

To back up a plan

1. To copy all associated plan files to a new
directory, select File> Backup Entire

Plan =8

2. The Backup Entire Plan dialog opens.

™ Backup Entire Plan *

(® Backup Plan Files and All Referenced Files
(O Backup Plan Files Only
[] send Backup Files to Zip Archive

Cancel Help

* Choose Backup Plan Files and All
Referenced Files to copy the plan file
and all externally referenced files such
as inserted picture files, metafiles, and
texture, image, and backdrop graphics
files.

* Choose Backup Plan Files Only to
copy any externally linked files and
inserted picture files, but no graphics
or texture files. This is best used only
when transferring a file to a computer
that already has the graphics files
installed.
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* Check Send Backup Files to Zip
Archive to save the files in a zipped
folder instead of a regular folder.

* Click OK.

3. The Select the Plan Backup Folder or
Choose Zip Archive to Backup dialog
opens next. This is a typical Save File
dialog. See “Saving, Exporting, and
Backing Up Files” on page 39.

» Navigate to a folder on your system
and select it.

¢ With the destination folder for the
backup selected, click OK.

4. Ifthe destination folder already contains
files, the program will confirm whether
you want to overwrite them.

The resulting folder contains a copy of the
plan or layout file and all referenced files,
and can be moved to a new computer

Exiting Home Designer Interiors
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Select File> Exit to exit the program. If you
have not saved any open files, you will be
reminded to do so. It is better to save your
work before exiting than to save on exit. See
“Closing Views and Files” on page 75.

When you exit from the program using File>
Exit, all Autosave files and Undo files are
automatically deleted.

On a Mac, if you click the program window’s
red Close button, the window will close but
the program itself will continue to run. To
close it down completely, right-click on its
icon on the Dock and select Quit from the
contextual menu.



Space Planning

The Space Planning Tools are a time-saving converts them into a working plan that can be
way to create a preliminary room-by-room edited and detailed to completion.
design of a home without getting caught up
in the details. Once the shape and layout of Chapter Contents
the rooms are finalized, the Build House tool . Space Planning
. Room Box Specification Dialog

Space Planning

7 Select Tools> Space Planning>
Space Planning. The Space
Planning Assistant leads you through a
series of windows that gather information
about the rooms you want to include in your
house. When you click Finish, the selected
room boxes display.

Room boxes can now be arranged into a floor
plan.
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Note: Each Bedroom called for in the Space
Planning Assistant also produces a Closet.

Placing Room Boxes

In addition or as an alternative to the room
boxes created for you by the Space
Planning Assistant, you can create your
own room boxes. To do so, select Tools>

Space Planning [&¥, then choose the desired
room type from the submenu. Click in floor
plan view to place a room box of the selected
type at that location.

Displaying Room Boxes

Room boxes and their labels are located on
the “Space Planning Boxes” layer. Space
Planning Box labels use the Text Style
assigned to that layer, as well. See
“Displaying Objects” on page 86.

Editing Rooms

Once created, room boxes can be edited in a
variety of ways.

Garage

» Select room boxes using the Select

Objects | & tool just like other objects in
Home Designer Interiors. See “Selecting
Objects” on page 94.

*  Room boxes can be resized, rotated, and
rearranged. See “Editing Box-Based
Objects” on page 106.

* Try to line up the rooms so that they are
just touching. Excessive overlaps may
cause your rooms to form incorrectly.
Closets are the exception. You can over-
lap a room with a closet, or place in
inside another room box.

* Rooms can be copied and pasted using
the Copy/Paste " edit button and
deleted using the Delete X edit button.

* Select Tools> Space Planning to
access the room box tools and place addi-
tional room boxes in your plan. Select a

tool and click in the plan to place a room
box of that type.

* Select Tools> Space Planning> Toggle

Room Boxes ) to hide or show the
room boxes.

Build House

When the rooms are in place, select Tools>

Space Planning> Build House % to
convert the rooms into a building model.
Walls and doors are inserted between the
rooms that you arranged.
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When you Build House, the “Space Planning
Boxes” layer is automatically turned off. The
room boxes that you created are not deleted,
however.

Room Box Specification Dialog

Multiple Floors

If you specified a two-story house, follow
these steps:

1.

Edit and arrange the room boxes on
Floor 1 as desired.

Select Tools> Space Planning> Build
House & tool to create the walls on the
first floor.

Go Up One Floor 4% and notice that
the positions of the walls on Floor 1 dis-
play in red as a reference.

Arrange the rooms on Floor 2 as desired,
using the reference display as a guide.

On the second floor, select Tools>

Space Planning> Build House ® to
complete the second floor.

Room Box Specification Dialog

l—l Select a room box and click the Open
Object edit button to open the Room
Box Specification dialog.

General Panel

Most of the settings on the GENERAL panel
are used when the selected room box is

converted to a room using the Build

House & tool.
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™ Room Box Specification

General General
Line Style
Fill Style

Room Name: Kitchen

Function: Kitchen
Size

Width: 156"

Depth: 120"

Fillet Radius:

*

Use Default

Cancel Help

0 Specify the selected room box’s Room
Type and Name.

* Select a Room Type from the drop-down
list. See “Room Types” on page 165.

» Ifyou wish, uncheck Use Room Type,

then specify a custom Room Name for
the selected room box.

e Specify the Size of the selected room
box.

*  Specify the room box’s Width and
Height.

* Specify the Fillet Radius, which is the
radius of the curve on each of the room
box’s corners. Unlike the other settings
on this panel, this value does not affect

52

the shape of the room created using Build

=
House & .

Line Style Panel

The settings on the LINE STYLE panel are
available for a variety of other objects in the
program. For information about these
settings, see “Line Style Panel” on page 126.

Fill Style Panel

For information about the settings on this
panel, see “Fill Style Panel” on page 131.



Chapter 4:

Preferences and
Default Settings

Preferences are global settings that affect the Chapter Contents
functionality and appearance of the Home «  Default Settings vs Preferences
Designer Interiors environment, while «  Dynamic Defaults

default settings control what objects look like e Reset to Defaults

when they are initially created. You can save «  General Plan Defaults Dialog
time by becoming familiar with these «  Preferences Dialog

settings and customizing them before you
begin a new drawing.
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Default and preference settings have
important effects on how the tools in Home
Designer Interiors function. Default settings
are file specific, while Preferences are
global, taking effect regardless of what file is
open.

Defaults and Preferences can be customized
to suit your needs, so it is recommended that
you become familiar with them and learn
how you can use them to your advantage.

Default Settings

@ Default settings determine the initial
characteristics of objects when they

are first drawn. For example, when you place
a base cabinet in a plan, its size, materials,
front items, hardware are determined by
settings in the Base Cabinet Defaults
dialog.

Defaults are file-specific, which means that
any changes that you make to the default
settings in one plan file will have no effect on
other plans.

You can access a complete list of the various
default settings in the current plan file by

selecting Edit> Default Settings @ from
the menu.

™ Default Settings *

Arrow
v Cabinets

iGeneral Cabinet
Base Cabinet
Full Height Cabinet
Wall Cabinet
Soffit
Shelf
Partition

Camera

Dimension
Doors
Floors and Rooms
Foundation
Materials
Plan

Rich Text
Roof

Text Styles
Wall Miche
Walls
Window

Done Help

* Click the + beside a category to expand it
and access the defaults for items related to
that category.

* To open the defaults dialog associated
with an item in the list, double-click on
the line item, or click on the item and then
click the Edit button.

Preferences

Preference settings influence the

overall environment of the program,
such as what the interface looks like and how
the tools are accessed. See “Preferences
Dialog” on page 57.

Unlike default settings, Preferences are
global, which means that any changes that



Dynamic Defaults

you make to them will take effect in all plan To access the Preferences dialog, select

files. Edit> Preferences from the menu.

Dynamic Defaults

Dynamic defaults are values that can be

changed globally throughout a model. Absalute Elevations
« If you change a dynamic default value in Foor fbove (): - ALY pefaut
a defaults dialog, all objects of that type Ceiing ®©): 109 1/8° Defaut
that are set to use the default will update Fioor (©): o Default
automatically to use the new value. Floor Below (): |0 ¥| Defaut
* Any objects of that type that are not using
the default value because of editing will Frame
not be affected if you change the default. Sides Width: | 3/4" (D)

Dynamic defaults are found in the default Top Width: | 34°0)

dialogs of a variety of objects, including Bottom Width: |3/4" (0)

dimension lines, walls, doors, cabinets and To edit a dynamic default, delete the (D) or
Fooms. remove the check from Default box and type
Materials are another example of an attribute the desired value.

that uses Dynamic Defaults. See “Material To reset a value back to the dynamic default,
Defaults™ on page 368. type the letter D in the field or click the

In object specification dialogs, dynamic Default checkbox.

defaults are followed by either a (D) in the
value field or a Default checkbox.

Reset to Defaults

Select Edit> Reset to Defaults to open the

Reset to Defaults dialog. ™ Reset to Defaults X
This dialog allows you to reset critical Reset Scope
structural settings in the current plan to the Olesn
default values. O Al Fioars
Default
[] Floor Heights

[ ceiling Heights
[] roof Directives in Walls

Cancel Help
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o The settings can be cleared for the
current floor or for All Floors.

9 Specify which settings you want to
reset to Default.

* Floor and Ceiling Heights - Floor and
ceiling heights for any room can be
changed in the Room Specification dia-
log. Check to reset the default values as

specified in the Floor Defaults dialog.
See “Floor Defaults Dialog” on page 288.

Roof Directives - You can specify how
the roof builds above an exterior wall in
its Wall Specification dialog. When Roof
Directives are reset, all items on the ROOF
panel are unchecked and any value, such
as the roof pitch, is reset to the default.
See “Roof Directives in Walls” on page
323.

General Plan Defaults Dialog

The settings in the General Plan Defaults
dialog control basic features of the Home
Designer Interiors environment in plan files.
Just as with other default settings, they are
file specific, which means that they can be

set differently in individual plan files. To
open this dialog, select Edit> Default

Settings 7, select Plan, and click the Edit
button.

r\ General Plan Defaults

General Settings

Arrow Key Scroll Distance: |12

[ 1gnore Casing When Resizing Doars and Windows

@
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Snap Grid / Snap Units o
Use Snap Grid/Units
Reference Grid o
Show Reference Grid
Grid Size:
i ol —
[] pisplay as Dots
Living Area o
Living Area To: @ Main Layer
O surface

Show Living Area Label

Cancel Help

o General Settings - Specify the default » (Casing is the trim that surrounds a door or

functionality for a variety of general

behaviors in the program.

window. When you resize a door or win-
dow, its sides are kept away from inter-



secting walls by the width of the casing.
Check Ignore Casing for Opening
Resize to allow wall openings to be posi-
tioned against an intersecting interior
wall. Clear this box retain sufficient space
for the opening’s specified interior trim
width.

* The Arrow Key Scroll Distance setting
determines how far to scroll in floor plan
view when you press an arrow key. The
initial default is 12 inches (300 mm). See
“Using the Arrow Keys” on page 74.

9 The Snap Grid allows you to snap

objects to specific points on-screen as
they are moved or resized. See “Grid Snaps”
on page 79.

* Check Use Snap Grid/Units to enable
Grid Snaps.

* Specify the Snap Unit you wish to use.
The initial default is 1 inch (10 mm).

9 Specify the display of the Reference
Grid.

Preferences Dialog

* Check Show Reference Grid to display
the Reference Grid, the virtual graph
paper used to create a sense of scale in
floor plan view.

e Specify the Reference Grid Size.

* Check Display as Dots to display the
Reference Grid using dots rather than
lines.

0 Specify how the Living Area label is

calculated and whether it displays in
floor plan view. See “Living Area” on page
171.

* Select Main Layer to have the Living
Area calculation measure from the walls’
Main Layer.

» Select Surface to have the Living Area
calculation measure from the walls’ exte-
rior surface.

» Uncheck Show “Living Area” to disable
the display of the Living Area label.

Preferences Dialog

= The settings in the Preferences
dialog are global: they apply to all
plan files and are preserved between
sessions. To access this dialog, select Edit>

Preferences in Windows® or Chief

Architect> Preferences in macOS" . Unlike
most dialogs in the program, it is not
necessary to have a plan file open to access
the Preferences dialog.

The Preferences dialog’s list of panels is
organized in a tree structure with categories
and subcategories. A white arrow next to a

category indicates that it has subcategories.
Click the arrow to make the subcategories
visible or to hide them.

Preferences dialog panels:
*  Appearance Panel
*  Colors Panel
*  Library Browser Panel
*  General Panel
*  Folders Panel
»  Edit Panel
*  Render Panel
*  Video Card Status Panel
*  Reset Options Panel
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Appearance Panel

r\ Preferences

v Appearance Contextual Menus
Colors
Library Browser

v General Dialog Previews
Folders

Edit

~ Render

Video Card Status

Reset Options

Toolbars

Button Size:

Side Window Drag Docking o
TopBottom Docking: Child Tool Palette

[ click Twice to Display

() standard
@ Vector View

@ O 0.

(O child Tool Palette
@ Drop Down
Scale Toolbar Icons for High DPI

EI Pixels (Sizing Will Update on Mext Launch)

[ Library Browser

Cancel Help

Check Contextual Menus to activate

contextual menus that display when
you right-click. See “Contextual Menus” on
page 25.

* Check Click Twice to Display to require
two right-clicks on an object before the
contextual menu displays. This allows the
first right-click to be used for object
selection. See “Selecting Objects” on
page 94.

In 3D views, the two clicks must be on
the same object surface in order for the
contextual menu to display: Clicking on
two different surfaces of the same object
is treated like two single-clicks.
9 Specify how Toolbars present child
tools when a parent button is clicked.
* Choose Parent-Child to display child

tools as buttons at the end of the toolbar
where the parent button resides.

* Choose Drop Down to display child tools
when the drop-down arrow to the right of
the parent button is clicked.

* Uncheck Scale Toolbar Icons for High
DPI to prevent toolbar icons from becom-
ing larger on systems running Windows 7
or 8 and using high DPI resolution. When
checked, toolbar buttons will increase in
size when high DPI is used. Not available
in the Mac version of the software.

e Uncheck Side Window Drag Docking

to prevent undocked side windows
from docking when moved using the mouse.

A side window can still be docked to its last

docked location by double-clicking its title

bar. See “View and Side Windows” on page
23.

* Top/Bottom Docking - Check the box
beside a side window’s name to allow it to
dock on the top and bottom edges of the
program window. Does not affect docking
to the left and right sides.



* Specify the desired toolbar Button Size,
in pixels. Increasing this value will pro-

portionally resize the text in the drop-

Preferences Dialog

down toolbars, as well. See “Toolbar But-
ton Size” on page 67.

Colors Panel

r\ Preferences X
v Appearonce — —
Colors
Library Browser Selection Line: _
v General )
e ponse i —
Edit Selected Edge Handle Fill: _
~ Render
Video Card Status Selection Fill: l:l
Reset Options
Cancel Help

Click a color bar to open the Select Color
dialog. See “Select Color Dialog” on page
90.

* Specify the Background Color for floor
plan view. The background colors for 3D

views can be set in their defaults and
specification dialogs. See .

» Specify the Selection Line color, which is

the color of the lines that represent

object(s) and their edit handles when they

are selected.

* Specify the Handle Fill color, which is
the fill color of the edit handles for
selected objects.

* Specify the Selected Edge Handle Fill
color, which is the fill color of the edit
handle on a selected object’s Selected
Edge. See “Selected Edge” on page 94.

* Specify the Selection Fill color, which is
the fill color for selected objects. Note
that depending on the fill assigned to a
selected object, its Selection Fill color
may vary.

Note: If the Selection Line and Handle Fill
Colors are similar, it may be difficult to distin-
guish between active and inactive CAD

Points.
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Library Browser Panel

The LIBRARY BROWSER panel controls the
appearance of the Library Browser window.
See “The Library Browser” on page 336.

r\ Preferences X
v Appearance View
Colors [ Hide Selection Pane
e G [ Hide Preview Pane
v General
Folders Preview Pane o
Edit
Standard
~ Render ®
Video Card Status O Vector View
Reset Options

Cancel Help

0 View options control the display of the @ Specify whether selected library items
main sections of the Library Browser. in the Preview Pane are displayed

« Check Hide Selection Pane to hide the using the Standard Rendering Technique or

in a line-based Vector View. See “Rendering

pane that displays objects in a selected X
Techniques” on page 407.

library or library folder.

e Check Hide Preview Pane to hide the To restore the original size and position of
pane that shows a preview of a selected the Library Browser and other side windows,
object. click the Restore Side Windows button on

the Reset Options Panel.

General Panel

r\ Preferences X
v Appearance Startup Options o
Colors Show Options on Startup
Library Browser
~ General Save Dialog Size and Position o
Folders ® Always
Edit 0 )
Each Session
~ Render
Video Card Status O Never
Reset Options [] open Dialogs to the Last Panel Visited

Troubleshooting o

|:| Mouse Movement Optimizations

Cancel Help
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o Check Show Options at Startup to

open the Startup Options dialog when
Home Designer Interiors is launched. See
“Startup Options” on page 18.

e Specify when the program should Save

Dialog Size and Position: Always, Per
Session, or Never. See “Dialog Size and
Position” on page 27.

* Check Open Dialogs to the Last Panel
Visited to open panelled dialogs to the
last panel that you accessed during the
current program session. When

Preferences Dialog

unchecked, dialogs always open to the
first panel. See “Dialogs” on page 26.

9 Troubleshooting -

When Mouse Movement Optimizations
is checked, zooming using the mouse
scroll wheel is optimized for Mac sys-
tems. This box is checked by default and
should only be unchecked when trouble-
shooting issues with the mouse scroll
wheel in the Mac version of the software.

Folders Panel

r\ Preferences X
~ Appearance Mote: For Advanced Use Only
Colors Data Folder for Current User:
Library Browser |C: Usersiannes\Documents\Home Designer 2019 Data), | Browse...
v General
Folders All Program Paths:
Edit Show...
~ Render
Video Card Status
Reset Options
Cancel Help

* Important user-specific information is
stored in the Home Designer Interiors
2019 Data folder, which is located in
your Documents directory by default. See
“Home Designer Interiors Data” on page
37.

While you cannot change the name of this
directory, you can change its location. To
avoid unexpected results, it is best to use a
location on your local hard drive.

If you move this folder on your computer
without specifying its location here, the
program will automatically replace it
using default information from the Home
Designer Interiors installation folder. The

same result will occur if you specify a
location on a network or removable
device and this location becomes inacces-
sible. When this occurs, customized user
settings will not be used and custom
library content will not be available.

All library content aside from your User
Catalog is stored in the System Library
Database Folder. By default, this folder
is created in the directory intended for
shared application data in your operating
system (C:\ProgramData in Windows; /
Library/Application Support in macOS).
See “Library Content” on page 340.

61



Home Designer Interiors 2019 Reference Manual

62

& If you choose to use a different folder,
you must specify a directory on a hard
drive with sufficient space to hold these files.

All Program Paths - Click the Show but-
ton to open the Program Paths dialog,
where you can find the location of files
that may be needed for troubleshooting
purposes. See “Program Paths Dialog” on
page 466.

Edit Panel

r\ Preferences %
v Appearance Cross Hair
Colors Enable in Plan and Elevation Views
Library Browser Synchronize with Cursor
v General
Folders Color: _
Edit
ize: Nindow Wi
~ Render Size: |100% of Window Width
Video Card Status
Reset Options
Cancel Help

You can use a cursor with Cross Hairs and
control its appearance.

* Check Enable in Plan to use a cross hair
cursor in floor plan view. This option is
checked by default.

*  When Synchronize with Cursor is
checked, the mouse pointer and cross
hairs always move together on screen. If
you feel that they do not keep up with

your mouse movements, try unchecking
this option.

Click the Color bar to open the Select
Color dialog and specify the color of the
cross hairs.

Cross hair Size is specified as a percent-
age of the view Window Width. Specify
the Size as 100% to extend the cross hairs
across the entire screen.

Render Panel

The settings on the RENDER panel control
how 3D views are generated and navigated.



Preferences Dialog

r\ Preferences

~ Appearance General Options

Colors

Troubleshooting

Hardware Edge Smoothing: Low hd

Codec for Walkthrough Recordings: |TYUV codec hd

Library Browser
v General Codec Options
Folders
Edit
v Rens.edr Card S 3Dconnexion® 30 Mouse
ideo Card Status
Reset Options (®) Rotate about Camera

(O Rotate about Camera Focal Paint

Use Enhanced Lighting
|:| Texture Compression

© © 0 O

Cancel Help

o Hardware Edge Smoothing uses the

video card to reduce the jagged appear-
ance of angled surface edges, producing
cleaner lines. The higher the smoothing
effect, the longer the rendering time. See
“Edge Smoothing” on page 403.

9 Select a Codec for Walkthrough

Recordings from the drop-down list.
By default, “IYUYV codec” in the Windows
version and “H.264” in the Mac version; but
any other codecs that you may have installed
on your system will also display in the list.
See “Walkthroughs™ on page 425.

The 3Dconnexion® settings affect how

3D mice function in Perspective 3D
views. See “3Dconnexion® 3D Mice” on
page 387.

* Select Navigate about Camera to center
mouse movement about the location of
the camera.

* Select Navigate about Camera Focal
Point to center mouse movement about

the location of the camera’s focal point.
See “To create a camera view” on page
383.

0 The Troubleshooting settings can be
used to troubleshoot performance in 3D
views.

¢ Uncheck Use Enhanced Lighting to dis-
able most lighting effects in Rendering
Techniques that support lighting. This box
is checked by default and should only be
unchecked for troubleshooting purposes.
It may become unchecked automatically
if the program detects a problem with
your video card. See “OpenGL and Hard-
ware” on page 382.

*  When Texture Compression is checked,
material textures are compressed so that
less video memory is required when a 3D
view is generated. Texture Compression
takes time, however, so view generation
will typically be slower.
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Video Card Status Panel

The VIDEO CARD STATUS panel displays
information about your video card, including
the vendor and whether the minimum

required OpenGL version is supported. See
“OpenGL and Hardware” on page 382.

This information may be important if you are
having problems generating 3D views.

Reset Options Panel

In order for some of the Reset Options to
take effect, you will need to restart Home
Designer Interiors.

r\ Preferences

v Appearance Preferences
Colors
Library Browser

v General

Reset Message Boxes

Reset Toolbars
Folders
Edit
~ Render
Video Card Status
Reset Options

Reset Search Folders
Reset Dialog Sizes
Reset Side Windows

Reset Preferences

Reset suppressing of message boxes.

Reset toolbars to factory defaults.

Clear the list of directories where the program
searches for missing files.

Reset dialog sizes and positions to factory defaults.

Reset Library Browser and Tool Palette to factory
defaults.

Reset other preferences to factory defaults.

Cancel Help

+ If message boxes have been suppressed,
you can make them display again by
clicking Reset Message Boxes. See
“Message Boxes” on page 29.

+ Click the Reset Toolbars button to reset
all toolbars to their original states. If you
are encountering warning messages
regarding toolbars, this option may
resolve the issue. See “Toolbars and Hot-
keys” on page 65.

* Home Designer Interiors retains a list of
locations where you have located missing
files in the past. If you find that the pro-
gram takes a long time searching before
informing you that files are missing, you
can click the Reset Search Folders but-
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ton to clear this list. See “Referenced
Files” on page 46.

Click the Reset Dialog Sizes button to
restore all dialog boxes to their original
sizes and positions. See “Dialogs” on
page 26.

Click the Reset Side Windows button to

restore all side windows to their original
sizes and positions. Tool Palette Settings

£ are also reset. See “Side Windows” on
page 23.

Click the Reset Preferences button to
restore all preferences to those originally
installed with the program.



Chapter 5:

Toolbars and

Two of the most efficient ways to access
Home Designer Interiors’s tools and settings
are the toolbars and keyboard shortcuts, also
referred to as hotkeys.

Hotkeys

Chapter Contents
. Toolbar Arrangement
. Hotkeys

Toolbar Arrangement

Home Designer Interiors’s toolbars provide
fast access to the program’s most commonly
used tools and settings, and are organized so
that related tools are grouped together and
easy to find.

~iv If a tool or setting is active, a small
@ check mark will display at the lower left
corner of its button icon.

The toolbars that display in a given view
depend on the view type. For example, the
toolbars that are available in floor plan and

3D views are not available in Materials Lists.

Some toolbars are available in more than one
type of view. If a tool cannot be used in that
view, its icon will appear pale grey in color.

Many of Home Designer Interiors’s tools are
organized into families of related tools which
can be accessed using either of two styles of
toolbar interface: the Child Tool Palette or
Drop Down tools. You can select the
interface that you prefer in the Preferences
dialog. See “Appearance Panel” on page 58.

Drop-Down Tools

Click on the arrow to the right of a button to
display a drop-down list of related tools. For
example, click the arrow to the right of the
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Window = button to display a drop-down
list of the other Window Tools.

=l

=1 Window Shift+W
.ﬁ Bay Window
F I BoxWindow
F 1 Bow Window

—1 Pass-Through

The most recently selected tool displays in
the toolbar.

Child Tool Palette

An alternative to Drop-Down toolbars is the
Parent button and Child Tool Palette
interface. Parent toolbar buttons have a blue
triangle in the lower right corner. When you
select a Parent button, its Child tools display
in the Child Tool Palette. If the Child Tool
Palette has been closed, it will open.

By default, the Child Tool Palette is docked
on the left side of the program window; but it
can be undocked and moved, as well as
resized and closed, just like other side
windows. See “Side Windows” on page 23.

As long as it is open, the Child Tool Palette
will also display the members of a selected
tool’s family when the Drop Down interface
is active. If you select a tool that does not
belong to a family, the previously selected
tool’s family will continue to display in the
Tool Palette.

When you click the Window Tools H
Parent button, for example, its Child buttons
display in the Child Tool Palette.

Tool Palette B X

AN ENa =N

e

Click the Settings £ button at the bottom
of the palette to select how the tools within it
are presented:

» Select Fit Palette ®¢ to resize the palette
so that it is one row wide.

«  Seclect Grid View £ to display only the
button icons of the child tools in a grid
that may have multiple rows, depending
on the width of the palette side window.

«  Select List View £= to display child
tools in a vertical list with each tool’s but-
ton icon and name in a row.

You can open the Tool Palette at any time,
even when Drop Down tools are enabled, by
selecting View> Tool Palette. Sce “View
Tools” on page 72.

The Edit Toolbar

When you select an object, its edit toolbar
opens. By default, it is located at the bottom
of the program window, just above the Status
Bar. The buttons on the edit toolbar can be
used to edit the selected object. Which
buttons display depends on the type of object
selected, the current view, and how you
selected the object.



Toolbar Button Size

By default, toolbar buttons are sized at 20
pixels, which works well on most computer
monitors running default system settings. If
you wish, you can increase or decrease this
size in the Preferences dialog. See
“Appearance Panel” on page 58.

Moving Toolbars

You can move any toolbar to a different
location by clicking and dragging its dotted
grab bar. Toolbars can be docked to any side

Hotkeys

of the program window, or they can be
undocked and left floating.

Undocked toolbars can be moved outside of
the program window, and they can be closed
completely. They can also be reshaped;
however, they cannot be resized in such a
manner that any buttons become hidden.

The location of moved toolbars is not saved
between program sessions. The next time
you use Home Designer Interiors, the
toolbars will be back in their original
locations.

Hotkeys

Many Home Designer Interiors tools have a
keyboard shortcut, or hotkey, associated with
them. If such a hotkey exists, it will display
to the right of the tool’s name in the menu.

Edit | Build Terrain  Library 3D CAD
7 Undeo Ctrl+Z
Cx Redo Ctrl+Y

Edit menu items with button icons
to the left and hotkeys to the right

To use a hotkey, simply press the appropriate
key or combination of keys on your keyboard
instead of selecting the menu item or clicking
the toolbar button. For example, press the
Ctrl and Z keys at the same time to perform

an Undo 2.

Note: If a key or key combination is in use as
a system hotkey, it cannot be used as a pro-
gram hotkey.

Create Hotkey List

A list of the hotkeys available to the current
program user can be saved in .html or .xhtml
format.

Select Tools> Create Hotkey List to open
the Save Hotkey List File dialog, a standard
Save dialog, and create a hotkey list that can
then be opened in a web browser window
and printed, if you wish.
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Chapter 6:

Window and View

The View and Window Tools let you control
how views of your drawing are shown on
screen, as well as toggle useful drawing aides
on and off.

There is no limit to the number of plan files
that can be open. The name of the file and the
type of view displays at the top of each view
window in its title bar.

Tools

Chapter Contents
. View Windows
. Working in Multiple Views
. View Tools
. Zoom Tools
. Undo Zoom

. Fill Window
. Panning the Display
. Closing Views and Files

View Windows

In Home Designer Interiors, there are two
different types of views: plan views and 3D
views. Each view displays in a view window
and can show the model from a different
perspective. While multiple views can be
open and display on screen, only one view
window can be active at any given time. See
“3D Views” on page 381 and “Working in
Multiple Views” on page 70.

Plan Views

Plan view is where most drawing and editing
is done, and when you open a new plan file, a
plan view is active. When an existing plan
file is opened, the floor level, view extents,
and Color toggle setting that were in use in
the active plan view the last time the plan
was saved will all be used.
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You can create additional plan views for use
during the current program session: select

Tools> Plan Views> New Plan View (2.
Each plan view that you create can show a
different floor and have different view
extents and Color setting.

Closing View Windows

There are a number of ways to close view
windows. See “Closing Views and Files” on
page 75.

Working in Multiple Views

70

There is no limit to the number of plan files
that can be open, nor is there a limit to the
number of plan view windows that can be
open. The name of the file and the type of
view is stated at the top of each view window
in its title bar as well as in its tab.

By default, Home Designer Interiors uses a
tabbed document interface, which means that
when more than one view window is open in
the program window, each open window will
have a tab that displays in a row above the
currently active view.

e Each tab states the name of file the view
type.

« Each tab features an icon indicating its
type of view.

e Click on a tab to make it the active view.

» If there is not enough room in the pro-
gram window to display all tabs, left and
right arrow buttons allow you to scroll
through the tabs.

» Tabs can be reordered by clicking and
dragging.

There is no limit to the number of 3D view
windows that you can have open at a given
time; bear in mind, though, that each window
demands use of your computer’s resources
and that you may see poor performance if too
many views are open. See “3D Views” on
page 381.

There are several ways to close a view
window. See “Closing Views and Files” on
page 75.

Tiling Views

E D] As an alternative to tabbed views,
windows can instead be tiled.

Tiling allows you to display multiple views

in a single Home Designer Interiors window

so you can see the results of changes in floor
plan view in 3D or vice versa. It can also be
useful for copying objects from one plan to
another.



Floor plan view and a camera view Tiled \ertically

There are several ways to create tiled views:

* Click and drag a view window’s title bar
or tab into the part of the drawing area
that you would like it to be. When a high-
lighted space is created, release the
mouse button.

«  Select Window> Tile Horizontally =
to display views in a horizontal orienta-
tion, one above the other.

«  Select Window> Tile Vertically [ or
press Shift + F6 on the keyboard to dis-
play views in a vertical, side by side, ori-
entation.

Views are tiled left to right or top to bottom
in the order in which they were last active:
the most recent view is on the left or at the
top, while least recent is on the right or on
the bottom.

e To activate a view, click on its title bar or
anywhere in the view window. Note that
any changes you make in the active win-
dow are reflected in other views as well.

Working in Multiple Views

* To end window tiling, select Window>
Tab Windows. You can also end tiling by
double-clicking on the title bar of the pro-
gram window.

Multiple Program Windows

To create a second program window, click
and drag the title bar or tab of a view window
completely out of the current program
window: for example, onto a second monitor.
A second Home Designer Interiors program
window will be created with its own menu
and toolbars.

Swapping Views

There are a number of ways to switch
between open view windows:

¢ Click on a view window’s tab.

¢ Select Window> Select Next Tab or

Window> Select Previous Tab to
cycle through all open views in the order
you prefer.
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+ In Windows, press the Ctrl + Tab (Next
Window) or Ctrl + Shift + Tab (Previous
Window) keys to cycle through all open
views.

* On a Mac, press the Ctrl + } (Next Win-
dow) or Ctrl + Shift + { (Previous Win-
dow) keys to cycle through all open
views.

* A list of all the views currently open is
located at the bottom of the Window
menu. Each view is identified by its name

and what type of view it is. A check mark
is beside the view that is currently active.
Select one to go directly to that view.

If more than eight view windows are open,
More Windows will be the last item in the
Window menu. Select this option to open the
Select Window dialog:

Select the name of a view in the list and click
OK to make it the active view.

View Tools

The View Tools allow you to open and close
the program’s side windows, as well as
toggle a variety of references and drawing
aides. Select the View menu to access these
tools.

Refresh Display redraws the current
—| window to clean up extra lines, show
missing items, and correct random on-screen
effects caused by changes to the model. See
“Refresh Display” on page 90.

:ﬂll'-_ Library Browser opens and closes
U the Library Browser side window. See
“The Library” on page 335.

Tool Palette opens and closes the Tool
Palette, which will display related tools. See
“Child Tool Palette” on page 66.

Scrollbars displays and suppresses
scrollbars on view windows. See
“View Windows” on page 23.

@ Color toggles the display of color in
' the current view. See “Color On/Off”
on page 90.

ﬁ Reference Grid toggles the display of

the Reference Grid in all views in the
current plan file. See “Grid Snaps” on page
79.

Zoom Tools
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Q.l Zoom is used to magnify any given
Al area on the plan or 3D view. Select
Window> Zoom, then click and drag a
marquee around an area on screen. When
you release the mouse, the selected area
expands to fill the screen.

Note that in 3D views, using Zoom A does
not reposition the camera. This can lead to
inconsistencies between a camera’s position
and what is actually shown in the view if
other methods of zooming are used later. See
“Repositioning Cameras” on page 386.



When the zoom is complete, whatever tool

was active prior to selecting the Zoom Q
tool automatically becomes active again. If

another zoom is needed, click the Zoom o
tool again.

Zoom In - Click to zoom in towards
the screen center by a factor of two.

Zoom Out - Click to zoom out from
the screen center by a factor of two.

Undo Zoom - Reverse the last zoom
operation.

Fill Window - Fits all visible items on
screen.

Fill Window Building Only - Fits all
walls and railings on the current floor
on screen.

- B B o @®

Undo Zoom

Zooming With the Mouse Wheel

Use the mouse wheel to zoom in and
\% out in all view windows. Scrolling

the mouse wheel one click up or
down zooms in or out, centering on the
location of your pointer and changing the
zoom by about 10%.

By default, zooming in 3D views changes the
camera’s position. See “Mouse Scroll
Wheel and Trackpad” on page 387.

Note: Depending on the configuration of your
mouse, it may be necessary to hold down the
Ctrl key while turning the mouse wheel. If
zooming in and out are not working correctly,
contact the manufacturer of your mouse and
mouse driver for their assistance.

Undo Zoom

|£| Select Window> Undo Zoom to
reverse the last zoom operation.

| Note: Undo and Redo do not affect zoom.

Zoom A and Undo Zoom & are also
available through the contextual menu. See
“Contextual Menus” on page 25.

Fill Window

IZI In floor plan view, select Window>
Fill Window or press the F6 key to
view nearly everything on screen that is
visible, including the Reference Display.
CAD Points are the only objects that are not
included when Fill Window is used.

If you are zoomed in so that only a portion of
the drawing displays on screen, selecting Fill

Window LI zooms out so that the entire

view fits on the screen. If you are zoomed
out so that the entire drawing is smaller than

the screen, selecting Fill Window K
zooms in until the drawing fills the screen.

When the drawing sheet is shown, Fill

Window I zooms to the sheet borders.

73



Home Designer Interiors 2019 Reference Manual

Fill Window Building Only

Window> Fill Window Building

Only is similar to Fill Window, but
zooms in or out to so that all walls and
railings in the view fill the current window.
Other objects are ignored.

In 3D Views

In 3D views, Fill Window [ J and Fill

Window Building Only adjust the
camera’s Field of View is adjusted so that all
surfaces in the 3D view are included.

Panning the Display
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There are four ways to pan the display
without changing the zoom factor.

Using the Scroll Bars
One method is to use the scroll bars on the

right and bottom edges of the window.

<croll Bars

\

v
>

* Drag the square button in the bar itself in
order to pan a larger distance.

* Click the end arrow keys on the scroll
bars to shift the display in 12" incre-
ments.

e The 12" increment is defined in the Plan
Defaults dialog under Inches Scrolled
by Arrow Key. See “General Plan
Defaults Dialog” on page 56.

Using the Arrow Keys

In floor plan view, the arrow keys on the
keyboard work exactly like clicking the
arrow buttons on the scroll bar. They shift the
display according to the number of inches
defined in the Plan Defaults dialog.

Using the Mouse

If you have a wheel mouse, you can pan the
display by pressing the middle mouse button,
or wheel, and moving the mouse in the
direction you would like to pan. When the
middle mouse button is held down, the

pointer changes to a hand @D icon.

In the Mac version of Home Designer
Interiors, you can pan using the left mouse
button and Command key.

Mouse drivers sometimes have other
functions assigned to the wheel and buttons.
These override the Home Designer Interiors
setting.

Using a Mac Trackpad

In the Mac version of Home Designer

Interiors, you can two finger drag to pan the

display. See “Using a Trackpad” on page 22.
Using the Pan Window Tool

The Pan Window tool works much
=1 like the mouse wheel method.

Select Window> Pan Window 2. The

pointer changes to a hand @D icon. Click and
drag to pan the window. The program reverts



to the previously active tool when you
release the mouse button.

Closing Views and Files

Closing Views and Files

If a view is still needed, you can swap to a
different view without closing it. If, however,
a view is no longer needed, it can be closed.
There are several ways to close a view
window:

« Select File> Close to close the active win-
dow.

* Press Ctrl + W or Ctrl + F4 on the
keyboard to close the active window.

* Click the Close button in the active
view’s title bar or in any view’s tab.

» A tabbed view can be closed by clicking
on its tab using the middle mouse button.

+ Select File> Close All 3D Views 1 to
close all currently open camera view win-
dows instead of just the active window.

« Select File> Close All Views to close all
currently open view windows instead of
just the active window.

If a plan has only one view window open and
you try to close it, the program will prompt
you to save before closing if there are any
unsaved changes. See “Saving, Exporting,
and Backing Up Files” on page 39.

iy Although the program warns you if you
@ try to exit without saving, you should get
in the habit of saving plan files before exiting.

Even if all view windows are closed, the
program can still be open. See “Exiting
Home Designer Interiors” on page 48.
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Chapter 7:

Creating Objects

There are a wide variety of objects in Home
Designer Interiors that you can use to create
3D models and plan drawings. Although
these objects are sometimes very different
from one another, the methods used to create
them are similar.

Once an object is created, it can be selected

and edited to meet the requirements of your

project. The editing characteristics common
to most objects are described elsewhere. See
“Editing Objects” on page 93.

Chapter Contents
Architectural vs CAD Objects
Snap Behaviors
Object Snaps
Angle Snaps
Grid Snaps
Creating Objects
Copying and Pasting Objects
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Architectural vs CAD Objects

There are two broad categories of objects in
Home Designer Interiors: architectural
objects and CAD objects.

Text, text lines with arrows, and dimensions
are 2D CAD objects that can be created and
edited in floor plan view but do not display in

3D camera views and overviews. See
“Dimensions” on page 183 and “Text” on
page 195.

In contrast, architectural objects such as
walls, cabinets, doors, windows, and stairs
display in 2D and 3D views.

Snap Behaviors

There are three categories of snap behavior
in Home Designer Interiors that affect how
objects are created and how they can be
edited:

* Object Snaps I?, which snap objects to
other objects.

* Angle Snaps ‘2, which snap objects at
specific angles.

* Grid Snaps £, which snap objects to
points on a grid.

You can select Edit> Snap Settings to
quickly turn Object, Angle and Grid Snaps
on or off.

To temporarily disable Snap Behaviors and
other move restrictions, press the Ctrl key
while dragging an edit handle. See “Moving
Objects” on page 112.

Object Snaps
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Ij) Object Snaps allow you to position

objects precisely relative to each
other; for example, to position lines so that
their endpoints meet.

Object Snaps can be turned on or off by
selecting Edit> Snap Settings> Object
Snaps.

There are many locations on an object that
other objects can snap to.

* Object endpoints and corners
* The midpoints of object edges

* Object center points

» Intersection points where an object drawn
at an allowed angle meets another object.

In addition, On Object snapping occurs
anywhere on an object’s edges and is most
noticeable when Angle and Grid Snaps are
turned off.

When multiple objects are selected, the
selection set’s only snap point is its midpoint.
Extension Snaps

Extension snaps allow you to snap to a point
that is not actually on an object. Instead,
these snaps locate points that are either



collinear to the end of a wall or orthogonal
(at a 90° angle) to it.

Extension snaps function when you are
drawing or editing walls and create a “sticky

Angle Snaps

point” where the wall being drawn reaches a
point that is either collinear or orthogonal to
another wall’s end point. See “Drawing
Walls” on page 141.

Angle Snaps

|‘_:",:: It is often important that objects be

drawn at exact angles. This can be
accomplished using Angle Snaps. Angle
Snaps allow you to draw walls, lines, and
other objects at angles in 7.5° increments.
Angle Snaps also affect the way objects
rotate, the radius of arcs, and a variety of
other operations.

Angle Snaps can be turned on or off by
selecting Edit> Snap Settings> Angle

Snaps . When Angle Snaps are disabled,

the Angle Snaps | icon will display near

the mouse pointer.

Grid Snaps

EZTF Grid Snaps allow you to snap objects
to points on an on-screen grid. This
grid cannot be seen directly, but as you draw,
move or resize an object, you can sometimes
see it snapping at regular increments. See

“Moving Objects” on page 112 and
“Resizing Objects” on page 115.

It is recommended that you draw and

position the exterior walls of your plan with

Grid Snaps 4 enabled. Once these walls
are in place, you may choose to turn Grid
Snaps off to finish the rest of the drawing.

Grid Snaps are turned on and off by selecting
Edit> Snap Settings>Grid Snaps &t orin
the Plan Defaults dialog.

Reference Grid

In addition to the Snap Grid, the Reference
Grid is provided to give you a visual sense

of scale. The Reference Grid is composed of
12” x 12” squares and is useful for zooming
in and out, or for general layout guidelines,
but is not used for snapping.

The Reference Grid can be toggled on and

off by selecting View> Reference Grid B
See “View Tools” on page 72.

The appearance and size of the Snap and
Reference Grids can be controlled in the
Plan Defaults dialogs. See “General Plan
Defaults Dialog” on page 56.

Grid Snaps and Angle Snaps

Of the three snap behaviors, Grid Snaps have
the lowest priority and are overridden by
Angle Snaps and Object Snaps.

When Grid snaps and Angle Snaps are both
enabled, objects are drawn and edited using
Polar Coordinates. For example, if the grid
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Snap Unit is set to 12" (1 foot), drawing a
new wall at an Allowed Angle snaps the wall
length to 0", 12", 24", and so on.

+~  To draw a line or wall at an Allowed
@ Angle but with unrestricted length, dis-

able Grid Snaps and leave Angle Snaps on.

Creating Objects
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In Home Designer Interiors, there are three
ways to create objects: by clicking to place
an object, by clicking and dragging to draw
an object, or by importing custom symbols,
pictures or metafiles.

If you create an object using any of these
methods and the layer it will go on is turned
off, the program will ask you if you want to
display the layer. See “Object Creation and
Layers” on page 81.

While the size of the drawing area in Home
Designer Interiors is limited only by the
resources on your computer, it is best to
begin your drawing near the origin, 0,0,0.
The current position of your mouse pointer
displays in the Status Bar at the bottom of the
program window. See “3D Drafting” on page
19.

Click-to-Create

Many objects, including doors and windows,
cabinets, library symbols, text, pictures, and
images are created by clicking. Select a
library object or one of the drawing tools
mentioned above, then click in the drawing
area to place the object at that location.

Continue clicking to place the selected object
until another tool is selected.

If you click at a location where there is not
enough room for the object to be placed, one
of two things may happen:

* Some objects, notably cabinets, doors,
and windows, will resize smaller to fit
into the space.

*  Most objects cannot resize in this man-
ner, so the program will present a warn-
ing message indicating that there is not
sufficient space at the current location.

When most drawing tools are active or
library symbols selected for placement, a
preview outline follows your mouse pointer,
indicating the size and shape of the object to
be created. If your pointer is positioned at a
location where the object cannot be placed,
this preview outline will not display.

As you move the mouse pointer, the center
point of the object’s back edge will snap to

active snap points when Grid Snaps &t or
Object Snaps are enabled. See “Snap
Behaviors” on page 78.

Many architectural objects can be created in
floor plan view or any 3D view. In order to
place a stand-alone, click-to-create object in
3D, it is necessary to click near a wall as
walls help orient the new object within the
3D space.

Clicking and Dragging

Other objects, including walls, railings, and
straight stairs are created by clicking and
dragging to define either a path or an
enclosed area. Select a tool, then click and




drag in the drawing area to draw an object
between your start and end points.

Continue drawing the selected object until
another tool is selected.

You can temporarily slow the movement of
the mouse as you drag by holding down the
Shift key on your keyboard.

You can cancel any click-and-drag drawing
operation before it is completed by pressing
the Esc key on your keyboard, or by pressing
any two mouse buttons at the same time.

Importing Objects

Custom symbols, pictures and metafiles can
be imported into the program and placed in
the drawing area with a click. See “Importing

Copying and Pasting Objects

and Exporting” on page 427 and “Pictures,
Images, and Walkthroughs” on page 413.

Object Creation and Layers

When it is created, every object is placed on
a layer which controls whether and how it
displays. See “Layers” on page 86.

If you try to create an object on a layer that is
not set to display in the current view, the
program will ask if you want to turn that
layer on. See “Message Boxes™ on page 29.

» Click Yes to create the object and turn on
its layer in the current view.

e Click No to create the object but leave its
layer turned off in the current view.

* Click Cancel to not create the object and
leave the layer turned off.

Copying and Pasting Objects

New objects can also be created by cutting,
copying, and pasting existing objects, either
individually or in groups. Objects can be
copied from one floor to another, one view
window to another, and one file to another.
Because copying uses your system’s
clipboard, some objects can be pasted into
other applications, as well.

&Objects created in an Imperial plan
should not be pasted into a metric file, or
vice versa. See “Template Plans” on page
38.

Objects cannot be pasted into any views that
they cannot be created in normally. For
example, text cannot be pasted into a 3D
camera view or overview.

A few objects, such as camera symbols,
cannot be copied.

Cut

‘{i’&. Select Edit> Cut or press Ctrl + X to
remove the selected object(s) from the
file and save them in the system clipboard.
To paste the selection in Home Designer
Interiors or another application, select Edit>
Paste or press Ctrl + V while in that
application to enable the Paste function.

Copy

qj Select Edit> Copy or press Ctrl + C

to copy the selected object(s) to the
system clipboard. To paste the selection in
Home Designer Interiors or another
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application, select Edit> Paste or press Ctrl
+ V while in that application to enable the
Paste function.

Paste

Eh Select Edit> Paste or press Ctrl + V

to enable Paste mode, then left- or
right-click in the current view to paste the
selected object(s) previously copied to the
system clipboard at that location. If pasting
from another application, click in the
destination view in Home Designer Interiors
first to make sure it is active.

Once pasted, these object(s) are selected.
Objects pasted in 3D views are selected on
their top surfaces.

If the selection being pasted consists of text,
it is placed in a Text object.

Copy/Paste

Click the Copy/Paste edit button to
copy the selected object(s) to the
system clipboard and immediately enable the

Paste [ function in Home Designer
Interiors.

The Copy/Paste "™ edit button activates
Paste mode in which each available edit tool
and handle makes a copy in addition to its
primary function and two new edit buttons
display on the edit toolbar.

* Click the Sticky Mode X cdit button
remain in the current mode and place
multiple copies of the selected object(s).

«  Click the Main Edit Mode % edit but-
ton or press the Esc key to return to the
selected object’s main edit toolbar.

If you paste a selection in a file other than its
original source file, when you return to the
original, Paste mode is still enabled.

The Copy/Paste ** edit button can be used
with the edit handles in either of two ways:
by clicking or by dragging an edit handle.

To Copy/Paste by clicking
1. Select an object or objects to copy.

2. Click the Copy/Paste " edit button,

select Edit> Copy N from the menu or
press Ctrl + C to copy and then Ctrl +
V to activate the Paste functionality. The
cursor displays the Copy/Paste icon.

3. Ifyou wish to paste the copy in a differ-
ent view or program window, open that
window.

4. Ifyour cursor does not display the Copy/
Paste icon, select Edit> Paste from the
menu or press Ctrl + V.

5. Left- or right-click once to paste a copy
of the object at that location.

To Copy/Paste by dragging
1. Select an object or objects to copy.

2. Click the Copy/Paste " edit button,

select Edit> Copy ™ from the menu or
press Ctrl + C. The cursor displays the
Copy/Paste icon.

3. Drag an edit handle:
* Drag the Move edit handle to position
the copy at a new location.

4. You can position the copy accurately
with respect to the original by watching



the moved distance in the Status Bar at
the bottom of the screen.

Sticky Mode

Normally, after an action is performed

using the edit tools or handles while in
an edit mode such as Paste mode, you return
to the Main Edit Mode. Click the Sticky
Mode edit button to remain in Paste mode
and continue pasting copies of the selected
object(s).

To exit Paste mode and return to the main
edit toolbar for the selected object, click the

Main Edit Mode edit button or press the
Esc key on your keyboard. If you have not
pasted a copy of the selected object and

immediately click Copy/Paste ** after
returning to the Main Edit Mode, Sticky

Mode */ is still enabled.

Copy and Paste in Place

Click the Copy and Paste in Place
& cdit button to create a copy of the
selected object(s) at the same location as the
original. The copy remains selected so you
can perform additional operations.

Because multiple walls, railing and fencing
cannot share the same space, the Copy and

Paste in Place ¥ cdit button is not avail-
able for these objects.

Paste Hold Position

Ijl When copying between different
floors or view windows, you can paste
a copy at the same absolute position as the

original selection using Paste Hold Position.

Copying and Pasting Objects

To use Paste Hold Position
1. Select the object(s) to be copied.

2. Click the Copy/Paste " edit button.

3. Switch to the desired floor or plan file
and select Edit> Paste> Paste Hold

Position [ .

4. A copy is placed at the same X, Y coor-
dinates on the new floor or in the new
plan as the original’s position.

Paste Special

The Paste Special tool allows you to
choose a representation for the

selection to be pasted.

Selections can be pasted as:

¢ Enhanced Windows Metafiles (EMF).
See “Metafiles” on page 421.

* Device Independent Bitmaps (BMP). See
“Importing Pictures” on page 420.

* Unformatted non-unicode text (TXT).

* File Name (a path to a file). Depending
on the file type, it will be either opened or
imported (if supported).

*  Unformatted text (HTML). Pastes as text.

* Model Objects - Home Designer Interiors
format, not compatible with other pro-
grams.

To use Paste Special
1. Select an object, image, text or file on
your computer and copy it.

2. Switch to the desired Home Designer
Interiors view window and select Edit>

Paste> Paste Special [L2].

83



Home Designer Interiors 2019 Reference Manual

3. Inthe Paste Special dialog, select the 4. Click in the drawing area to place the
desired representation for the selection copy at that location.
and click OK.
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Chapter 8:

Displaying Objects

The way that objects display is an important
in all stages of the design process. There are
two primary ways that the display of objects
is controlled: Drawing Groups and Layers.

Chapter Contents
Displaying Objects
Layers
Layer Attributes
Layer Sets
Display Options Dialog
Drawing Groups
Display Toggles
Select Color Dialog
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Displaying Objects

There are two broad categories of objects in
Home Designer Interiors: architectural
objects and CAD objects. See “Architectural
vs CAD Objects” on page 78.

CAD objects are 2D and display only in the
view in which they were drawn.
Architectural objects, on the other hand, are
3D and are represented in 2D and 3D views
in different ways

Layer Settings

By default, CAD and CAD-based objects use
the color assigned to their layer. They can
also be assigned custom line attributes in
their specification dialogs. See “Line Style
Panel” on page 126.

In floor plan view, architectual objects are
represented much like CAD objects, using
the color assigned to their layer.

In addition, layers can be used to turn the
display of objects on and off in different
views.

Fill Styles

Closed CAD objects and can also be
assigned a fill style for their interior areas.
Fill styles may be a solid color or a pattern,
and can be specified as transparent. See “Fill
Style Panel” on page 131.

A few architectural objects such as rooms
and stairs can also be assigned a fill style;
however, it is only used in floor plan view. In
3D views, architectural objects are
represented using surfaces that have
materials assigned to them.

Material Textures

The appearance of architectural objects in 3D
views is determined by the materials applied
to the objects’ surfaces. See “Materials” on
page 367.

In 3D views that use textures, you can turn
on or off the display of textures by selecting
3D> Camera View Options> Toggle

Textures 2% .

Layers
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Layers are used to organize and manage the
display of all objects in all views. A layer can
be thought of as a transparency sheet with
objects placed on it for viewing. Nearly all
views use multiple layers, like a stack of
transparencies put together to show different
types of objects.

You can find out which layer an object is on
by selecting the object and looking at the
Status Bar. And, you can customize how
each layer displays in a particular view in the
Display Options dialog.

Multiple layers are organized into Layer
Sets, which allow you to control which
objects display in different views.



Layer Attributes

Layer Attributes

The display of objects in different views is
controlled by layer sets and layers in the
Display Options dialog. See “Display
Options Dialog” on page 88.

Primary and Secondary Layers

Every object is placed on a layer which
controls whether it displays in a given view.
This layer is referred to as the object’s
primary layer, and you can see its name in
the Status Bar when the object is selected.
See “The Status Bar” on page 29.

In addition, some objects have secondary
layers which may alter the appearance of
objects on the primary layer, but do not
control whether the objects display or not.

For example, the primary layer for base
cabinets is “Cabinets, Base”. In addition,
base cabinets have a number of secondary
layers that control the display of the
countertop, face indicators, door opening
indicators, module lines and labels.

Note: If an object’s primary layer is turned off,
information on its secondary layers will not
display - even if those layers are turned on.

All layers with a check in the “Disp.” column
display when the current layer set is active.

Objects that are not displayed cannot be seen
or selected. If you try to place or draw an
object on a layer that is hidden, the program
asks if you want to turn the layer on.

Name Disp

Architectural Blocks =]

Architectural Blocks, Labels

Audio/Video v
Auto Dormers vy
Cabinets, Base vy

Some objects are designed to be inserted into
another object rather than standing alone. If
the display of an object that contains an
inserted object is turned off, the inserted
object’s display will be turned off, as well
For example, if the display of a wall is turned
off, any doors and windows in that wall will
not display either. See “Inserted Objects” on
page 350.

The Color attribute assigned to a layer
determines how the lines representing
objects on that layer appear in floor plan
view.

Some objects, notably CAD and text, allow
you to override their line color without
changing the layer’s color attribute. A
custom line style can also be assigned to
these objects. See “Line Style Panel” on page
126.

Layer Sets

Layer Sets are used to control the layer
settings for different views in a plan file.

A layer set consists of a complete list of the
layers in the current plan along with the
display settings for each layer as set for a
particular type of view. These display
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settings can be modified, and can be different
for each type of view. See “Display Options
Dialog” on page 88.

Layer sets are file specific, which means that
changes made in one plan file have no effect
on the settings in other files.

Home Designer Interiors uses a different
layer set for the each type of view of your
plan:

* Floor plan view.

+ Camera views and Doll House Views.
See “3D View Tools” on page 383.

¢ Reference Floor. See “The Reference
Floor” on page 293.

While any view is active, select Tools>

Display Options to make changes to the
layer set used for that view type.

Any changes made to settings in the Display
Options dialog for one particular view will
affect all views using that same layer set. For
example, if you make changes for a camera
view, all camera views and overviews in the
current plan will be affected. See “Display
Options Dialog” on page 88.

Display Options Dialog
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The display of objects in all views is
controlled in the Display Options

dialog. To make changes to the display
settings for a particular type of view, open a
view of that type and select Tools> Display
Options.

If the display of a particular layer is turned
off and an object assigned to that layer is
placed in the plan, the program will
automatically ask you if the layer should be
turned on so that the new object will be
visible. After you make your choice, the
object will be created - even if you select
“No.”

Only displayed objects are included when
EMF files are exported, and only displayed
objects print.

™ Display Options O *
Properties for Default Set
MName Disp Color »

‘Architectural Blocks
Architectural Blocks, Labels
Cabinets, Baze

Cabinets, Full

Cabinets, Shelves & Partitions
Cabinets, Soffits

Cabinets, Wall

Cabinets, Countertops
Cabinets, Custorn Backsplashes
Cabinets, Doors & Drawers

Cancel Help

AN LN NN

The Properties for the layer set that is active
in the current view are presented in a table of
layers and their attributes. See “Layer Sets”
on page 87.

* Click on a column header to sort all lay-
ers by that column. Click again to sort in
reverse order.



* Remove the check from the “Disp.” col-
umn to turn off the display of a category
of objects in the current view.

* Click a color bar to open the Select
Color dialog and set the display color for
objects on that layer in floor plan view.
See “Select Color Dialog” on page 90.

Drawing Groups

* Click the size grip at the lower right cor-
ner and drag to resize the dialog box.

Note: Not all objects display in all views. For
instance, invisible walls do not appear in
camera views or materials lists.

Drawing Groups

Each object in a plan file belongs to a
Drawing Group, which influences whether it
displays in front of or behind other objects.
Drawing Groups control the display of
objects in floor plan view but in camera
views and overviews.

Most categories of objects have their own
Drawing Group; however, a few objects are
instead placed in the Front or Back Group.
Imported pictures, which are placed in the
Back Group, are a notable example. A
selected object’s Drawing Group is reported
in the Status Bar. See “The Status Bar” on
page 29.

Within a given Drawing Group, drawing
order is determined by the order in which
objects are placed. By default, an object will
display in front of any objects that were
created before it was. For example, if you
place a chair and then a table, the table will
display in front of the chair; if you instead
place a table and then the chair, the chair will
display in front.

Placed First

/

/

/

Placed Last

Placed Second

Drawing order also affects how objects are
selected. If two objects are positioned so that
they overlap one another, and you click at a
point that they both share, the frontmost
object will become selected first. See “Select
Next Object” on page 95.

Drawing Group Edit Tools

E. Once an object has been placed, its

position in the drawing order can be
modified. To do this, select one or more
objects and click the View Drawing Group
Edit Tools edit button.

Click the Send Backward edit button
to move the selected object(s) to the
back of its current Drawing Group. If it is
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already at the back of its current group, it
will be moved to the next group down in the
drawing order.

Click the Bring Forward edit button

@ :
— | to move the selected object(s) to the

front of its current Drawing Group. If it is
already at the front of its current group, it
will be moved to the next group up in the
drawing order.

Display Toggles

There are a number of toggles and tools that
can be used to affect the appearance of the
on-screen display.

Print Preview

D Print Preview and its related display
toggles allow you to get a sense of
what the current view will look like when it
is printed. See “Print Preview” on page 449.

Refresh Display

Refresh Display redraws the current
window to clean up extra lines, show missing
items, and correct random on-screen effects
caused by changes to a model. Select View>
Refresh Display or press the F5 key to
refresh the on-screen display.

Color On/Off

m The display of color on-screen can be
' toggled on and off in any view by
selecting View> Color.

« If Color ™ is toggled off in any 3D
view, the view will be displayed in gray-
scale.

« IfColor M is toggled off in floor plan
view, the view will be displayed in black
and white.

Delete Surface

In any 3D view, select 3D> Delete

Surface, then click a surface in the
view to temporarily remove the surface from
the current view. See “Delete 3D Surface” on
page 386.

Select Color Dialog

The Select Color dialog can be opened by
clicking on the color bar that can be found in
many dialogs throughout the Windows
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version of the program. In the Mac version,
the standard Colors dialog, or Color Picker,
is used.



Select Color Dialog

[\\ Select Color

o——B_asichors

HLONCOENEN
HLCEOEEEER
EEEEEEEN
HENEEEENN
ANEEEEEN
EEEEECE

o—— Custom colors
(1T [
(T [

Add to Custom Colors
o -

uiﬂ

Hug: |232 e | Red: |l33 e |
D 5ot [3us% (2] green: 190 (7] ——o
wm: [63.9% 2] Bue: 12 5]

Cancel Help

0 The currently selected color displays in

the rectangle at the lower center of the
dialog. There are a number of ways to select
a color in this dialog:

(2]
(3]

e The location of the selected color is iden-
tified by a crosshairs.

Click in any one of the Basic colors
boxes to select it.

Click anywhere in the color spectrum
area to select a color.

* Click anywhere in the vertical bar or drag
the arrow to adjust the selected color’s
Luminosity and RGB values.

0 Define the color by specifying its Hue,

Saturation, and Luminesity (HSL) or
its Red, Green, and Blue (RGB) values.

Click in one of the Custom colors

boxes to either select it or to specify it
as the box for a new custom color to be
defined.

¢ Click the Add to Custom Colors button
to add the selected color to the Custom

Colors group.
0 Click the Color Chooser Eyedropper,
then click anywhere on your monitor to
select the color displaying at that location.

@ You can select a color from any program
“¥" window. Before opening the Color
Chooser dialog, make sure the desired color
can be seen on screen.

Click OK to apply the currently selected
color to the object’s line or fill style, or to the
material’s pattern color.
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Chapter 9:

Editing Objects

Just as the methods used to create different
objects in Home Designer Interiors are
similar, the options for moving, rotating,
resizing, and otherwise editing them are also
alike.

Edit handles allow objects to be resized,
relocated, or rotated using the mouse. Edit
toolbar buttons and the contextual menus
access edit tools relevant to the selected
object(s). Most objects have a specification
dialog that allows you to edit it in ways that
are specific to that type of object.

The editing characteristics common to most
objects are described in this chapter. Unique,
object-specific editing behaviors and the
specification dialogs are covered in their
respective chapters.

Chapter Contents
Selecting Objects
Selecting Multiple Objects
Editing Line Based Objects
Editing Arc Based Objects
Editing Open Polyline Based Objects
Editing Closed-Polyline Based Objects
Editing Box-Based Objects
Editing Spline Based Objects
Editing Circles, Ovals and Ellipses
Moving Objects
Aligning Objects
Resizing Objects
Reshaping Objects
Rotating Objects
Matching Properties
Deleting Objects
Undo and Redo
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Selecting Objects

94

“Select” refers to selecting an object for
editing. An object must be selected before it
can be edited.

In order for an object to be selected, it must
be visible in the current view. See “Layers”
on page 86.

When an object is selected, it displays edit
handles and a grey selection fill color. In 3D
views, a selected object will also display
lines representing the selected edge or
surface. The size of the edit handles does not
change as you zoom in or out. To prevent
them from stacking on one another, some
edit handles may not display as you zoom
away from the selected object.

When an object is selected, its edit toolbar
also displays, typically on the upper left side
of the Home Designer Interiors program

window. See “The Edit Toolbar” on page 24.

Information about the selected object or
objects may also display in the Status Bar.
See “The Status Bar” on page 29.

A selected object remains selected until
another object is selected, a different tool is
activated, the Esc key on the keyboard is
pressed, or any two mouse buttons are
pressed at the same time.

Select Objects

[% Any object created using Home
Designer Interiors can be selected
using the Select Objects tool. Select Edit>
Select Objects, click the toolbar button or

press the Space bar on your keyboard to
activate this tool, then click on an object to
select it.

You can also select objects or open context
sensitive menus using the right mouse button
when any tool is active.

Selecting Similar Objects

If a tool other than Select Objects | is
active, you can only select objects of that
type using the left mouse button. For

example, if the Straight Exterior Wall N
tool is active, you can only select walls using
the left mouse button.

This can be useful for selecting an object
when many objects of a different type
occupy the same space in floor plan view.

Objects can be selected using the right mouse
button, regardless of which tool is active.

Right-Clicking

Regardless of which tool is active, you can
select an eligible object by right-clicking on
it once. When you right-click to select an
object a contextual menu also appears,
displaying the object’s edit tools. See
“Contextual Menus” on page 25.

If a drawing tool is active and you right-click
to select an object, you can unselect it by
left-clicking in an empty space in the
drawing area. Although a drawing tool is
active, it is not used. If you then left-click a
second time, the active tool will be used.

Selected Edge

When you click on a polyline- or box-based
object, the edge that you click nearest
becomes the selected edge and displays an



edit handle larger and of a different color
than those on other edges. The handle on this
edge may also display at the point where you
clicked to select it. You can specify the
Selected Edge Handle Fill color in the
Preferences dialog. See “Colors Panel” on
page 59.

This edge can be edited on the SELECTED
LINE or SELECTED ARC panel of the object’s
specification dialog. See “Moving Objects
Using Dimensions” on page 192, “Selected
Line Panel” on page 318 and “Selected Arc
Panel” on page 319.

Selecting Multiple Objects

Selected Side

Most architectural objects can be selected in
3D views. When selected, the outline of their
bounding box displays, and edit handles are
located on the side where you clicked to
select the object. The edit handles can be
used to move, resize, or rotate the object in
different directions, depending on which side
is selected.

Select Next Object

If there is more than one object in a
next: particular space, it may be difficult to
select the desired object. When a nearby
object is selected, click the Select Next
Object edit button or press the Tab key until
the desired object becomes selected. This
function cannot be applied to groups of
selected objects.

Selecting Multiple Objects

Multiple objects can also be selected and
edited in groups. The options available for
editing them will vary depending on the
types of objects selected.

Marquee Select

Groups of objects can be selected by holding
down either the Shift or Ctrl key when the

Select Objects 5% tool is active and then
dragging a marquee around the objects to be
selected. An object does not need to be
completely enclosed by the marquee to be
selected: it will be selected if the marquee
includes only a small portion of it.

When using the marquee-select method, both
text and architectural objects included in the
marquee are selected. To remove an object
from the selection set, hold down the Shift
key and click it.

The Ctrl key will always marquee-select
objects of all types, regardless of the active
tool. The Shift key, however, can be used to
marquee-select objects of a similar type.

To marquee-select objects by type

1. Select a drawing tool used to create the
type of object you wish to select: for

example, the Hinged Door '\ tool.
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2. Hold down the Shift key, then click and
drag a rectangular selection marquee in
the drawing area.

3. When you release the mouse button,
objects of the selected drawing tool’s
type - here, door objects - located in the
marquee will be selected.

If an object is currently selected and a
selection marquee is drawn around it, that
object becomes de-selected. If an object is
currently selected and a marquee is drawn
around other objects, the original object
remains selected and the other objects are
added to the selection set.

@ To make marquee selection easier, you
~ can turn off the display of objects you
do not want to include in your selection set.
See “Layers” on page 86.

Shift and Ctrl Select

You can select a group of objects by adding
them to the selection set one by one. Select
an object, hold down either the Shift or Ctrl
key, and click additional objects to select
them.

More than one type of object can be selected
using this method, but the ability to edit the

group-selected items is limited to attributes
that all selected objects have in common.

To remove an object from a selection set,
click it once more - again, with either the
Shift or Ctrl key pressed.

The Shift and Ctrl keys can be used to select
multiple items in a variety of contexts, such
as: the Library and Project Browsers, lists in
dialog boxes, and files to be imported.

Edit Area

.| The Edit Area tool allows you to
i | quickly define an area of your plan
and select the objects in that area. Once
selected, they can then be repositioned,
rotated, or deleted. Select Edit> Edit Area,
then click and drag a rectangular marquee
around the area that you would like to move.

Unlike other selection methods, the Edit
Area tool cuts walls and railings where the
selection marquee intersects them, allowing
you to edit only the selected portion of these
objects.

Some objects, such as cabinets, are included
in the selection only if more than half of the
object is contained within the marquee.

Editing Line Based Objects
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Objects are considered line-based when they
can be resized along one axis using the edit
handles.

Straight walls and railings, straight stairs
andtext lines with arrows are examples of
line-based objects.

Most line-based objects can be connected to
other like objects to form polyline-based
objects. See “Editing Open Polyline Based
Objects” on page 101 and “Editing Closed-
Polyline Based Objects” on page 104.

Some objects, notably walls, have line-based
editing behavior only when selected on



certain surfaces. See “Editing Walls” on page
148.

Wall openings such as doors and windows
have line-based editing behavior in floor plan
view only but cannot be rotated, reversed or
converted to an arc. See “Editing Doors” on
page 213 and “Editing Windows” on page
231.
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Other objects, such as stairs, have additional
edit handles that allow you to concentrically
adjust the object’s width.

Using the Edit Handles

When selected, a typical line-based object
displays four edit handles: a Move handle,
two Extend/Change Angle handles, and a

Rotate handle.

Any action performed using the edit handles
can be cancelled by pressing the Esc key or
any two mouse buttons at the same time.

Move

*  Movement may be limited or stopped by
other objects or Snap Behaviors. Move
restrictions can be overridden by holding
down the Ctrl key while dragging. See
“Unrestricted Movement” on page 113.

Rotate

* The Rotate handle is used to rotate the
object about its center. See “Rotating
Objects” on page 117.

Editing Line Based Objects

Extend/Change Angle

» Drag a square end handle parallel to the
selected line to change its length.

* Drag a square end handle at an angle to
the selected line to change its angle.

Adjust Width

Some line-based objects, such as stairs and
roads, have additional handles that allow the
width of the object to be adjusted.

Adjust Width

* Click and drag a small, round Expand
handle to increase or decrease the
object’s width. By default, objects are
resized in 1" increments. This Snap Unit
is defined in the Plan Defaults dialog.
See “General Plan Defaults Dialog” on
page 56.

Using Dimensions

Dimensions can be used to position

line-based objects relative to other
objects. See “Moving Objects Using
Dimensions” on page 192.

Dimensions cannot, however, be used to
adjust the length of line-based objects, or the
width of line-based objects such as stairs.

Using the
Specification Dialog

I—l Line-based objects can be edited using
their specification dialogs. See
“Specification Dialogs” on page 28.
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Using the Edit Toolbar

A selected line-based object can be edited in
a variety of ways using the buttons on the
edit toolbar.

The following toolbar buttons may display
on the edit toolbar for a selected line-based
object:

+  Click the Select Next Object e edit
button to select nearby objects instead of
the selected object. See “Selecting
Objects” on page 94.

* Click the Open Object J1 edit button to
open the specification dialog for the
selected object. See “Specification
Dialogs” on page 28.

* Click the Copy/Paste " edit button to
copy the selected object(s) to the system
clipboard so they can be pasted else-
where. See “Copying and Pasting
Objects” on page 81.

* Click the Copy and Paste in Place i
edit button to create a copy of the
selected object(s) at the same location as
the original. See “Copy and Paste in
Place” on page 83.

«  Click the Delete X edit button to delete
the selected object(s). See “Deleting
Objects” on page 119.

» Click the Center Object **/ edit button
to center an object along a wall within a
room or relative to a cabinet fixture. See
“Using Center Object” on page 114.

* Click the View Drawing Group Edit

Tools TH edit button to modify the
selected object’s place in the drawing
order. See “Drawing Group Edit Tools”
on page 89.

»  Click the Break Line =X edit button to
add a new corner or pivot point to the
selected object. See “Break Line” on
page 116.

* Click the Complete Break = edit
button to break the selected object into
two separate objects. See “Break Line”
on page 116.

* Click the Change Line/Arc | edit but-
ton to change a line-based object to an
arc, or vice versa. See “Change Line/
Arc” on page 117.

Editing Arc Based Objects

Objects are considered arc-based when they
can be resized along a curve using the edit
handles.

Curved walls and railings, curved stairs, and
curved text lines with arrows are examples of
arc-based objects.

Most arc-based objects can be connected to
other like objects to form polyline-based
objects. See “Editing Open Polyline Based
Objects” on page 101 and “Editing Closed-
Polyline Based Objects” on page 104.
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Some objects, notably curved walls, have
arc-based editing behavior only when
selected on certain surfaces. See “Editing
Walls” on page 148.

Other objects, such as curved stairs and
roads, have additional edit handles that allow
you to concentrically adjust the object’s
width.

Using the Edit Handles

When selected, a typical arc-based object
displays seven edit handles.

Any action performed using the edit handles
can be cancelled by pressing the Esc key or
any two mouse buttons at the same time.

Move

* Two Move edit handles allow the arc to
be relocated without changing its shape.
One is located at the center of the chord
and the other, at the arc center.

*  Movement may be limited or stopped by
other objects or Snap Behaviors. Move
restrictions can be overridden by holding
down the Ctrl key while dragging. See
“Unrestricted Movement” on page 113.

Editing Arc Based Objects

' <
Move edit handle

Rotate

* The Rotate handle is used to rotate the
arc about its center. See “Rotating
Objects” on page 117.

Extend

» The end edit handles expand or contract
the arc when moved along the arc radius
or chord.

» If you follow the path of the arc, the end
edit handles allow you to adjust the arc
length.

» The angle formed by the center point of
the arc and its two endpoints is referred to
as the Included Angle. The Included
Angle of the arc can be rotated at
Allowed Angles. See “Angle Snaps” on
page 79.

Resize

Extend edit handles

* Drag the small, round Resize edit handle
to change the radius and included angle
of the arc while maintaining its center.
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Resize edit handle

Reshape

* Drag the small triangular Reshape
handle to change the length and location
of the center without moving the
endpoints.

Reshape edit handle
Adjust Width

Some arc-based objects, such as stairs and
roads, have additional handles that allow the
width of the object to be adjusted.

Adjust Width

* Click and drag a small, round edit handle
to increase or decrease the object’s width.

By default, objects are resized according
to the Snap Unit defined in the Plan
Defaults dialog. See “General Plan
Defaults Dialog” on page 56.

Using Dimensions

Dimensions can be used to position

arc-based objects. Dimension lines
typically locate tangent extension lines and
any extension lines that may be parallel to
those lines rather than the arc itself. See
“Moving Objects Using Dimensions” on
page 192.

Using the
Specification Dialog

I—l Arc-based objects can be edited using
their specification dialogs. See
“Specification Dialogs” on page 28.

Using the Edit Toolbar

A selected arc-based object can be edited in a
variety of ways using the buttons on the edit
toolbar.

The following toolbar buttons may display
on the edit toolbar for a selected arc-based
object:

*  Click the Select Next Object rex edit
button to select nearby objects instead of
the selected object. See “Selecting
Objects” on page 94.

e Click the Open Object J1 edit button to
open the specification dialog for the
selected object. See “Specification
Dialogs” on page 28.

* Click the Copy/Paste ™" edit button to
copy the selected object(s) to the system
clipboard so they can be pasted else-
where. See “Copying and Pasting
Objects” on page 81.



* Click the Copy and Paste in Place i
edit button to create a copy of the
selected object(s) at the same location as
the original. See “Copy and Paste in
Place” on page 83.

«  Click the Delete I edit button to delete
the selected object(s). See “Deleting
Objects” on page 119.

* Click the Center Object ** edit button
to center an object along a wall within a
room or relative to a cabinet fixture. See
“Using Center Object” on page 114.

¢ Click the View Drawing Group Edit

Tools [T edit button to modify the
selected object’s place in the drawing

Editing Open Polyline Based Objects

order. See “Drawing Group Edit Tools”
on page 89.

«  Click the Break Line = edit button to
add a new corner or pivot point to the
selected object. See “Break Line” on
page 116.

* Click the Complete Break = edit
button to break the selected object into
two separate objects. See “Break Line”
on page 116.

«  Click the Change Line/Arc = edit but-
ton to change an arc-based object to a
line, or vice versa. See “Change Line/
Arc” on page 117.

Open polyline-based objects are composed
of individual line- and arc-based objects that
are connected at their end points but do not
form an enclosed area.

Connected walls, stairs, and text lines with
arrows are examples of open polyline-based
objects.

For information about editing closed
polyline-based objects, see “Editing Closed-
Polyline Based Objects” on page 104.

Editing Open Polyline Based Objects

A

Other objects, such as connected stair
segments, have additional edit handles that
allow you to concentrically adjust the width
of all segments of the object.

Using the Edit Handles

A polyline-based object can be composed of
many segments.
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When selected, an open polyline-based
object displays a Move handle, a Rotate
handle, a Reshape handle at the intersection
of each segment, and an Extend handle at
each end.

Each straight, line-based segment also has a
Move edit handle along its length.

Each curved, arc-based segment has its own
Move handle at the center of its chord, a
Resize handle and, if it has an unlocked
center, a Reshape handle. See “Editing Arc
Based Objects” on page 98.

When a polyline is selected, the edge that
you click nearest is called the selected edge,
and certain operations affect only this edge.
The Move handle of the selected edge is
larger than that of other edges. It displays
along the length of a line segment, or at the
center of the chord on an arc segment. See
“Selected Edge” on page 94.

Any action performed using the edit handles
can be cancelled by pressing the Esc key or
any two mouse buttons at the same time.

Move ]
polyline Resize
Reshape arc Reshape
polyline '/ arc
Move line '
segment

& O

d PN Sameline
Exten « Type

Rotate polyline

Move

¢ Click and drag the Move handle to move
the object.

*  Movement may be limited or stopped by
other objects or Snap Behaviors. Move
restrictions can be overridden by holding
down the Ctrl key while dragging. See
“Unrestricted Movement” on page 113.

Rotate

* The Rotate handle is used to rotate the
object about its center. Its position varies
depending on which edge is currently
selected. See “Rotating Objects” on page
117.

Extend

* Click and drag an Extend handle to
lengthen or shorten the unconnected end
of the selected line or arc segment, or to
change the radius of the selected arc. See
“Editing Arc Based Objects” on page 98.

Reshape

¢ Click and drag a Reshape edit handle to
change the angle and/or length of the seg-
ments on either side of it, or the size of
the object.

Move Line Segment

* The Move Line Segment edit handle is
found on straight segments of open poly-
lines and moves the straight section per-
pendicular to itself. Adjacent segments
may extend or contract in their original
directions to maintain their connections.

Move Arc

* Click and drag the Move Arc edit handle
to change the radius and/or chord length
or position. Adjacent segments may



extend, contract, or change angle to
maintain their connections.

Resize Arc

* Click and drag the Resize Arc edit handle
to change the radius, chord length and
chord position of the arc segment. Adja-
cent segments may extend, contract, or
change angle to maintain their connec-
tions.

Reshape Arc

* Click and drag the Reshape Arc edit han-
dle to change the radius of the arc without
moving its end points.

Adjust Width

Some open polyline-based objects, such as
stairs and roads, have additional handles that
allow the width of the object to be adjusted.

Adjust
Width

* Click and drag a small, round edit handle
to increase or decrease the object’s width.
By default, objects are resized in 1"
increments. This Snap Unit is defined in
the Plan Defaults dialog. See “General
Plan Defaults Dialog” on page 56.

Using Dimensions

Dimensions can be used to move or

reshape polyline-based objects. See
“Moving Objects Using Dimensions” on
page 192.

Editing Open Polyline Based Objects

Using the Specification
Dialog

I—l Open polyline-based objects can be

edited using their specification
dialogs. See “Specification Dialogs” on page
28.

Using the Edit Toolbar

A selected open polyline-based object can be
edited in a variety of ways using the buttons
on the edit toolbar.

The following toolbar buttons may display
on the edit toolbar for a selected open
polyline-based object:

«  Click the Select Next Object e edit
button to select nearby objects instead of
the selected object. See “Selecting
Objects” on page 94.

e Click the Open Object b1 edit button to
open the specification dialog for the
selected object. See “Specification
Dialogs” on page 28.

* Click the Copy/Paste " edit button to
copy the selected object(s) to the system
clipboard so they can be pasted else-
where. See “Copying and Pasting
Objects” on page 81.

* Click the Copy and Paste in Place i

edit button to create a copy of the
selected object(s) at the same location as
the original. See “Copy and Paste in
Place” on page 83.

+  Click the Delete ! edit button to delete
the selected object(s). See “Deleting
Objects” on page 119.
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* Click the Center Object ** edit button
to center an object along a wall within a
room or relative to a cabinet fixture. See
“Using Center Object” on page 114.

* Click the View Drawing Group Edit

Tools [T edit button to modify the
selected object’s place in the drawing
order. See “Drawing Group Edit Tools”
on page 89.

«  Click the Break Line = edit button to
add a new corner or pivot point to the

selected object. See “Break Line” on
page 116.

* Click the Complete Break = edit
button to break the selected object into
two separate objects. See “Break Line”
on page 116.

«  Click the Change Line/Arc = edit but-
ton to change a line-based polyline edge
to an arc, or vice versa. See “Change
Line/Arc” on page 117.

Editing Closed-Polyline Based Objects
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Closed polyline-based objects are composed
of individual line- and arc-based objects
joined end-to-end and forming an enclosed
area.

Stair landings are examples of closed
polyline-based objects.

For information about editing open polyline-
based objects, see “Editing Open Polyline
Based Objects” on page 101.
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Using the Edit Handles

A polyline can be composed of many
segments.

When selected, a closed polyline-based
object displays a Move handle, a Rotate

handle, and a Reshape handle at the
intersection of each segment.

Each straight, line-based segment has a
Move edit handle along its length.

Each curved, arc-based segment has its own
Move handle at the center of its chord, a
Resize handle and a Reshape handle. See
“Editing Arc Based Objects” on page 98.

When a polyline is selected, the edge that
you click nearest is called the selected edge,
and certain operations affect only this edge.
The Move handle of the selected edge is
larger than that of other edges. It displays
along the length of a line segment, or at the
center of the chord on an arc segment. See
“Selected Edge” on page 94.

Any action performed using the edit handles
can be cancelled by pressing the Esc key or
any two mouse buttons at the same time.
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* Click and drag the Move handle to move
the object.

*  Movement may be limited or stopped by
other objects or Snap Behaviors. Move
restrictions can be overridden by holding
down the Ctrl key while dragging. See
“Unrestricted Movement” on page 113.

Rotate

* The Rotate handle is used to rotate the
object about its center. Its position varies
depending on which edge is currently
selected. See “Rotating Objects” on page
117.

Reshape

* Click and drag a Reshape edit handle to
change the angle and/or length of the seg-
ments on either side of it.

Move Line Segment

e The Move Line Segment edit handle is
found on straight segments of closed
polylines and moves the straight section
perpendicular to itself. Adjacent seg-
ments may extend or contract in their
original directions to maintain their con-
nections.

Editing Closed-Polyline Based Objects

Move Arc

¢ Click and drag the Move Arc edit handle
to change the radius and/or chord length
or position. Adjacent segments may
extend, contract, or change angle to
maintain their connections.

Resize Arc

* Click and drag the Resize Arc edit handle
to change the radius, chord length and
chord position of the arc segment. Adja-
cent segments may extend, contract, or
change angle to maintain their connec-
tions.

Reshape Arc

¢ Click and drag the Reshape Arc edit han-
dle to change the radius of the arc without
moving its end points.

Using Dimensions

Dimensions can be used to move or

reshape closed polyline-based objects.
See “Moving Objects Using Dimensions™ on
page 192.

Using the
Specification Dialog
I—l Closed polyline-based objects can be
edited using their specification

dialogs. See “Specification Dialogs” on page
28.

Using the Edit Toolbar

A selected closed polyline-based object can
be edited in a variety of ways using the
buttons on the edit toolbar.
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The following toolbar buttons may display
on the edit toolbar for a selected closed
polyline-based object:

+  Click the Select Next Object fex edit
button to select nearby objects instead of
the selected object. See “Selecting
Objects” on page 94.

* Click the Open Object ¥ edit button to
open the specification dialog for the
selected object. See “Specification
Dialogs” on page 28.

* Click the Copy/Paste " edit button to
copy the selected object(s) to the system
clipboard so they can be pasted else-
where. See “Copying and Pasting
Objects” on page 81.

* Click the Copy and Paste in Place i
edit button to create a copy of the
selected object(s) at the same location as
the original. See “Copy and Paste in
Place” on page 83.

«  Click the Delete X edit button to delete
the selected object(s). See “Deleting
Objects” on page 119.

Click the Center Object **/ edit button
to center an object along a wall within a
room or relative to a cabinet fixture. See
“Using Center Object” on page 114.

Click the View Drawing Group Edit

Tools TH edit button to modify the
selected object’s place in the drawing
order. See “Drawing Group Edit Tools”
on page 89.

Click the Break Line = edit button to
add a new corner or pivot point to the
selected object. See “Break Line” on
page 116.

Click the Complete Break = edit
button to break an edge of the selected
object into two separate objects. See
“Break Line” on page 116.

Click the Change Line/Arc | edit but-
ton to change a line-based polyline edge
to an arc, or vice versa. See “Change
Line/Arc” on page 117.

Editing Box-Based Objects
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Box-based objects are similar to closed
polyline-based objects, but must always have
four sides with right-angled corners.

Text objects, many library symbols, pictures
and images are examples of box-based
objects.



Editing Box-Based Objects
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¢ The four Resize handles located at each
corner are used to increase or decrease

FaN
f“: the size of the object.
P o P
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Using the Edit Handles
When selected, a box-based object displays

REF,
ten edit handles.
Any action performed using the edit handles *  The four Extend handles disp.lay along
can be cancelled by pressing the Esc key or each edge. If you select an object on an
any two mouse buttons at the same time. edge, the Extend handle displays at the
point where you clicked; otherwise, it
Extend Move displays at the center of the edge.
a] : Resize o
“REP / =
Rotate = )
T A e The triangular Rotate handle located

near the selected edge of the object is

*  Click and drag the Move handle to move used to rotate it about its center. The

the object. . .
o pointer changes to a circular arrow &
* Movement may be limited or stopped by when moved over this handle. See
other objects or Snap Behaviors. Move “Rotating Objects” on page 117.

restrictions can be overridden by holding
down the Ctrl key while dragging. See
“Unrestricted Movement” on page 113.
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Using Dimensions

Dimensions can be used to move or

reshape box-based objects. See
“Moving Objects Using Dimensions” on
page 192.

Using the
Specification Dialog

I—l Box-based objects can be edited using
their specification dialogs. See
“Specification Dialogs” on page 28.

Using the Edit Toolbar

A selected box-based object can be edited in
a variety of ways using the buttons on the
edit toolbar.

The following toolbar buttons may display
on the edit toolbar for a selected box-based
object:

*  Click the Select Next Object fex edit
button to select nearby objects instead of

the selected object. See “Selecting
Objects” on page 94.

* Click the Open Object J1 edit button to
open the specification dialog for the
selected object. See “Specification
Dialogs” on page 28.

* Click the Copy/Paste ** edit button to
copy the selected object(s) to the system
clipboard so they can be pasted else-
where. See “Copying and Pasting
Objects” on page 81.

* Click the Copy and Paste in Place M
edit button to create a copy of the
selected object(s) at the same location as
the original. See “Copy and Paste in
Place” on page 83.

+  Click the Delete X edit button to delete
the selected object(s). See “Deleting
Objects” on page 119.

* Click the Center Object ** edit button
to center an object along a wall within a
room or relative to a cabinet fixture. See
“Using Center Object” on page 114.

* Click the View Drawing Group Edit

Tools TH edit button to modify the
selected object’s place in the drawing
order. See “Drawing Group Edit Tools”
on page 89.

Editing Spline Based Objects

A Spline is a curve that passes smoothly
through a set of points, or vertices. Splines
are typically used in situations where an
irregular, free-flowing curve is needed.

Objects are considered spline-based when
they can be edited similar to CAD splines
using their edit handles. See “Draw Spline”
on page 125.



Electrical connections drawn with the

Connect Electrical i tool are examples of
spline-based objects. See “Connect Electri-
cal” on page 268.

Electrical connections drawn with the

Connect Electrical i tool are examples of
spline-based objects. See “Connect Electri-
cal” on page 268.

\ertex points

I\

Soline segments
Using the Edit Handles

When a spline is selected, several different
types of handles display.

Any action performed using the edit handles
can be cancelled by pressing the Esc key or
any two mouse buttons at the same time.

\ertex

™~ Move

Py

AN

Rotate

Move

* Click and drag the Move handle to move
the object.

Editing Spline Based Objects

*  Movement may be limited or stopped by
other objects or Snap Behaviors. Move
restrictions can be overridden by holding
down the Ctrl key while dragging. See
“Unrestricted Movement” on page 113.

Rotate

* Click and drag the Rotate edit handle to
rotate the entire spline.

Vertex

» The Vertex edit handles display along the
spline at each vertex. Click and drag a
Vertex edit handle to change the length,
angle and curve of adjacent segments
without affecting other vertices.

Using the
Specification Dialog

l—l Spline-based objects can be edited
using their specification dialogs. See
“Polyline Specification Dialog” on page 130.

Using the Edit Toolbar

A selected spline-based object can be edited
in a variety of ways using the buttons on the
edit toolbar.

The following toolbar buttons may display
on the edit toolbar for a selected spline-based
object:

+  Click the Select Next Object /fex edit
button to select nearby objects instead of
the selected object. See “Selecting
Objects” on page 94.
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* Click the Open Object edit button to
open the specification dialog for the
selected object. See “Polyline
Specification Dialog” on page 130.

* Click the Copy/Paste " edit button to
copy the selected object(s) to the system
clipboard so they can be pasted else-
where. See “Copying and Pasting
Objects” on page 81.

* Click the Copy and Paste in Place i
edit button to create a copy of the
selected object(s) at the same location as
the original. See “Copy and Paste in
Place” on page 83.

+  Click the Delete ™ edit button to delete
the selected object(s). See “Deleting
Objects” on page 119.

* Click the Center Object *¢ edit button
to center an object along a wall within a
room or relative to a cabinet fixture. See
“Using Center Object” on page 114.

* Click the View Drawing Group Edit

Tools TH edit button to modify the
selected object’s place in the drawing
order. See “Drawing Group Edit Tools”
on page 89.

»  Click the Break Line = edit button to
add a new corner or pivot point to the
selected object. See “Break Line” on
page 116.

* Click the Complete Break = edit
button to break an edge of the selected
object into two separate objects. See
“Break Line” on page 116.

Editing Circles, Ovals and Ellipses
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Objects created using the Circle, Oval, and
Ellipse Tools are unusual in that no
architectural objects share their
functionalities.

Using the Edit Handles

When selected, circles, ovals and ellipses
display eleven edit handles.

Unlike Ovals (€ and Ellipses ©, a

Circle O cannot be edited into any other
shapes; it can only be a circle.

Any action performed using the edit handles
can be cancelled by pressing the Esc key or
any two mouse buttons at the same time.

Reshape Y‘ N - N y
ove
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&

Concentric
Resize = =
< o <
Rotate
A
Move

* Click and drag the Move handle to move
the object.

*  Movement may be limited or stopped by
other objects or Snap Behaviors. Move
restrictions can be overridden by holding



down the Ctrl key while dragging. See
“Unrestricted Movement” on page 113.

Rotate

* Click and drag the Rotate handle of an
oval or ellipse to change its orientation.

(7

\_

Reshape

* The eight edit handles beyond the perim-
eter are Reshape edit handles. Move them
in or out to resize and reshape an oval or
ellipse.

"y

» Unlike ovals and ellipses, circles cannot
be reshaped. When a Reshape handle is
dragged on a circle, it is only resized.

PN
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Editing Circles, Ovals and Ellipses

Concentric Resize

* The Concentric Resize edit handle dis-
plays on the perimeter of a circle between
a corner Reshape handle and the center.
Click and drag this handle to resize the
circle without moving its center point.

"y

Using Dimensions

Dimensions can be used to move or

resize circle-based objects. See
“Moving Objects Using Dimensions” on
page 192.

Using the
Specification Dialog

I—l Circles, ovals and ellipses can be
edited using their specification

dialogs. See “Circle/Oval/Ellipse

Specification Dialog” on page 129.

Using the Edit Toolbar

A selected circle, oval or ellipse can be
edited in a variety of ways using the buttons
on the edit toolbar.

The following toolbar buttons may display
on the edit toolbar for a selected circle, oval
or ellipse:

+  Click the Select Next Object rex edit
button to select nearby objects instead of
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the selected object. See “Selecting
Objects” on page 94.

* Click the Open Object J1 edit button to
open the specification dialog for the
selected object. See “Specification
Dialogs” on page 28.

* Click the Copy/Paste " edit button to
copy the selected object(s) to the system
clipboard so they can be pasted else-
where. See “Copying and Pasting
Objects” on page 81.

* Click the Copy and Paste in Place M
edit button to create a copy of the
selected object(s) at the same location as

the original. See “Copy and Paste in
Place” on page 83.

«  Click the Delete X edit button to delete
the selected object(s). See “Deleting
Objects” on page 119.

* Click the Center Object * edit button
to center an object along a wall within a
room or relative to a cabinet fixture. See
“Using Center Object” on page 114.

* Click the View Drawing Group Edit

Tools ‘TM edit button to modify the
selected object’s place in the drawing
order. See “Drawing Group Edit Tools”
on page 89.

Moving Objects
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Objects can be moved using the edit handles
as well as a variety of edit tools. Multiple
selected objects can also be moved as a
group. See “Selecting Objects” on page 94.

Using the Edit Handles

Select an object, then click the Move edit
handle and drag it to a new location. When
your pointer is over the Move handle, it
displays a four-headed arrow.

& 8] <&
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When moved, the selected object moves
orthogonal, or at a right angle to, any of its
edges.

As an object is moved, it jumps at set
increments when Grid Snaps are enabled.
See “Grid Snaps” on page 79.

If an selected object passes over its original
location as it is being moved, it will snap to
that location.

You can temporarily slow the movement of
your mouse as you drag an edit handle by
holding down the Shift key on your
keyboard.

Bumping/Pushing

When an object bumps into another object
while it is being moved, it stops. If you do
not release the mouse button and continue to
drag, however, the selected object resumes
movement and continues past the obstructing
object.



Instead of dragging through and past an one
or more obstructing objects, you can instead
push them. To do this, bump an object into an
obstructing object and release the mouse
button. Then, click and drag the Move edit
handle a second time in the same direction.

Walls, wall openings, cabinets, furnishings
and fixtures are examples of objects that can
bump into as well as push other objects.

Bumping/Pushing does not affect objects
moved using dimensions. See “Moving
Objects Using Dimensions™ on page 192.

Unrestricted Movement

Many objects have restrictions placed on
their movement by their own properties or
specification settings. Architectural objects,
for example, bump into other 3D objects as
they are being moved.

Other move restrictions are activated by the
Snap Settings. See “Snap Behaviors” on
page 78.

These restrictions can be overridden when
necessary by holding down the Ctrl key
while dragging to move an object.

To move an object freely

Select the object.
2. Hold down the Ctrl key.
Click the Move edit handle and drag it to

the new location.

You can also press the Ctrl key while
dragging an object’s Move handle to override
move restrictions.

Moving Objects

Nudging

You can use the arrow keys on your keyboard
to move a selected object or objects by single
Snap Grid increments in 2D and 3D views.
This is referred to as nudging. See “Grid
Snaps” on page 79.

In Floor Plan View

To nudge an object in floor plan view, select
it and press any of the four arrow keys: Up,
Down, Left, or Right.

In 3D Views

In 3D views, nudging is relative to the
selected surface. If, for example, you select
the front of a cabinet in 3D and nudge it to
the left, it will move to the left in floor plan
view. If you instead select the back of a
cabinet in 3D and nudge it to the left, it will
move to the right in floor plan view.

When multiple objects are selected, the
surface that was clicked on last is considered
the selected surface. When nudged, all
selected objects will move relative to that
surface. See “Shift and Ctrl Select” on page
96.

If an object is rotated, the directions that it
can be nudged in 2D are not affected;
however, in 3D, they are. If, for example, a
cabinet is rotated 45°, it will nudge to the left
in floor plan view. When nudged in 3D,
however, it will move at a 45° angle: or
parallel to the selected surface.

Center Object

The Center Object edit button allows

you to move walls, cabinets and other
objects so that they are centered along a wall
within a room or relative to a window or
cabinet.
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Using Dimensions

Objects or the selected edges of some
objects can be moved using

dimensions. See “Moving Objects Using
Dimensions” on page 192.

Aligning Objects

114

It is often important to align objects such as
text boxes or walls, or to align objects on
different floors. There are several methods to
choose from.

Using the Mouse
Cross Hairs

Objects can be aligned by eye using the
mouse cross hairs as a reference. This
method can help you draw, place and edit
objects quickly and with reasonable
accuracy, but is not necessarily as accurate as

some of the other approaches described here.

The mouse cross hairs can be turned on and
off in the Preferences dialog. See “Edit
Panel” on page 62.

Using Snap Settings

With Object Snaps, you can snap the edge
of a selected object to that of another. Select
an edge of an object. Drag it to the edge of
another object, then release the mouse.

Objects drawn at angles other than vertical
and horizontal snap at increments equal to
the Snap unit specified in the Plan Defaults
dialog rather than onto the grid itself. This
does not align objects to the grid unless they
were already snapped to the grid. See “Snap
Behaviors” on page 78.

Using Dimensions

Create a temporary or manual

dimension relative to an object such as
a wall or line, and relocate the objects to the
same dimension. See “Moving Objects
Using Dimensions” on page 192.

+~  Text objects can be aligned using set-
@‘ tings in the Text Specification dialog.
See “Aligning Text” on page 203.

Using Center Object

The Center Object edit button can be

used to center a variety of objects
relative to another object. Center Object can
be used in floor plan and 3D views.

To center an object
1. Select an object.

2. Click the Center Object ** edit button.

Move the mouse pointer over the object
you would like to center the selected
object relative to.
* As the pointer passes over an eligible
object, it becomes highlighted and a
dashed centering axis line displays.

4.  When the desired centering axis dis-
plays, click once to center the selected
object along that axis line.



To center an object in aroom

1. Select an object such a cabinet.

2. Click the Center Object ** edit button.

Move the mouse pointer in the room that
you would like to center the selected
object relative to.

* As you move the pointer, a centering
axis will display along the wall it is
closest to.

* The selected object does not have to be
inside a room in order to be centered
relative to that room.

4.  When a centering axis displays along the
correct wall, click once.

Resizing Objects

5. The object is moved perpendicular to the
centering axis.

If you click outside an exterior wall instead
of clicking inside, the selected object is
centered along the edge of the Exterior
Room. See “The Exterior Room” on page
168.

Aligning Objects on
Different Floors
Objects on different floors can be aligned

with one another using the Reference

Display . See “The Reference Floor” on
page 293.

Resizing Objects

Objects can be resized using the edit handles
and specification dialogs.

Using the Edit Handles

The end, corner and/or side edit handles can
be used to resize a selected object.

To override any movement restrictions
caused by snap settings or the presence of
other objects, press the Ctrl key while
dragging an edit handle.

As an object is resized, any dimensions
indicating its size will update to reflect your
changes. You can use dimensions as
references to help you achieve the correct
size for most objects.

You can temporarily slow the movement of
your mouse as you drag an edit handle by
holding down the Shift key on your
keyboard.

Using the
Specification Dialog

I—l Most objects can be accurately resized
in their specification dialogs. See
“Specification Dialogs” on page 28.

Using Dimensions

Many objects can be resized by

selecting an edge and then moving
that edge using dimensions. See “Moving
Objects Using Dimensions™ on page 192.

Walls can also be resized using dimensions;
however, it is important to understand that
the selected edges of other objects cannot be
resized using dimensions - they can only be
moved. To resize an edge, select an adjacent
edge and move that edge instead.
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Reshaping Objects
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There is a variety of ways to reshape objects
using the edit handles, specification dialogs
and edit toolbar buttons.

Some objects, notably box-based objects,
cannot be reshaped - only resized. See
“Resizing Objects” on page 115.

Using the Edit Handles

Depending on the type of object selected, the
end, corner and/or side edit handles can be
used to reshape a selected object.

To override any movement restrictions
caused by snap settings or the presence of
other objects, press the Ctrl key while
dragging an edit handle.

You can temporarily slow the movement of
your mouse as you drag an edit handle by
holding down the Shift key on your
keyboard.

Using the
Specification Dialog

l—l A variety of objects can be reshaped

by editing values on either the
SELECTED LINE or SELECTED ARC panel of
their specification dialogs. See “Selected
Line Panel” on page 318 and “Selected Arc
Panel” on page 319.

Using Dimensions

Both temporary and manually drawn

dimensions can be used to increase or
decrease the distance between the edge a
line- or polyline-based object and another,
parallel edge or line.

Break Line

_} The Break Line edit tool can be used

to break an individual line- or arc-
based object into two segments. The edges of
a polyline-based object can also be broken.

Note: The Break Line edit button is not avail-
able for box-based objects or some architec-

tural objects such as stairs.

There are two types of breaks: partial and
complete. Partial breaks create a new corner,
or pivot point, while complete breaks
actually sever an edge into two segments.

To create a partial break

1. Click the object, object edge, or object
centerline that you want to break into
two segments.

2. Click the Break Line = edit button
once or press the 3 key.

3. Click the edge to create a new corner
edit handle at that location and two sepa-
rate edges on either side of that handle.

If you click and drag one of the edit handles
on either side of the partial break, the edge
moves at a right angle to itself and another
edge forms, connecting the moved edge with
the one on the other side that does not move.

You can remove an edge from a polyline-
based object by clicking and dragging a
corner handle until it snaps to an adjacent
corner handle.



To create a complete break

1. Click the object, object edge, or object
centerline that you want to break into
two segments.

2. Click the Break Line = edit button.

3. Click the Complete Break = edit
button.

4. Click on an edge to create a complete
break at that location.

The edge that you clicked on will be divided
into two separate sections, one of which will
be selected. You can now move or edit the
selected edge completely independent of the
object or edge on the other side of the break.
Click on the other edge to select it instead.

To remove a break from an edge

1. Make sure that Object Snaps are

enabled. See “Object Snaps” on page 78.

2. Select the object that has a break that
you want to remove.

Rotating Objects

3. Click on the corner edit handle
associated with the break that you want
to remove and drag it to an adjacent
corner handle.

4. Release the mouse button and the handle
that you selected will be removed.

Change Line/Arc

~—| Select an individual line-based or arc-
—/ based object or a segment of a
polyline-based object and click the Change

Line/Arc edit button to convert the selected
segment from a line to an arc or vice versa.
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Rotating Objects

Objects can be rotated using the edit handles
as well as a variety of edit tools. Multiple
selected objects can also be rotated as a
group. See “Selecting Objects” on page 94.

By default, an object or group of objects
rotate about the center point of the selection
set.

Using the Edit Handles

Select an object, then click the triangular
Rotate edit handle and drag it in any

direction. When your pointer is over the
Rotate handle, it displays a curved arrow.

The angles of line-based objects can also be
changed by dragging an end handle in a
direction other than parallel to the object.
The object rotates about the opposite end
point. See “Editing Line Based Objects” on
page 96.

Objects snap to Allowed Angles as they are
rotated. See “Angle Snaps” on page 79.
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To override any movement restrictions
caused by snap settings or the presence of
other objects, press the Ctrl key while
dragging an edit handle.

You can temporarily slow the movement of
your mouse as you drag an edit handle by
holding down the Shift key on your
keyboard.

Using the
Specification Dialog

I—l The exact angle of some objects such
as lines, arcs, walls and the selected
edges of polylines can be specified on either

the GENERAL panel, SELECTED LINE panel,
or SELECTED ARC panel of that object’s
specification dialog. See “Selected Line
Panel” on page 318 and “Selected Arc Panel”
on page 319.

Matching Properties
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2;6 The Object Eyedropper tool allows
EL) you to select attributes from one
object and apply them to other, similar
objects.

To use the Object Eyedropper

1. Begin by selecting the Object Painter
Mode that you want to use. Select
Tools> Object Painter, then:

+ Select Object Painter Object

Mode & to apply attributes to indi-
vidual objects, one at a time.

+ Select Object Painter Room

Mode fEl to apply attributes to an indi-
vidual object as well as all objects in
the same room that are identical to it
with a single click.

« Select Object Painter Floor Mode Ftl
to apply attributes to an individual
object as well as all objects on the same
floor that are identical to it with a sin-
gle click.

« Select Object Painter Plan Mode £l
to apply attributes to an individual

object as well as all objects in the entire
plan that are identical to it with a single
click.

2. Select Tools> Object Painter> Object

Eyedropper @, and notice that your
mouse pointer displays an eyedropper

/ icon.

3. Move your mouse pointer over an object
in the current view. If it becomes high-
lighted and “Object to pick” information
is stated on the left side of the Status
Bar, click once to load the object’s attri-
butes so they can be applied to other,
similar objects.

4. Notice that your mouse pointer now dis-

+ .
plays a spray can "B icon.

5. Move your mouse pointer over an object
that is similar to the one selected in step
1: if it becomes highlighted and “Load
Properties to” information is stated in
the Status Bar, the object is eligible to
receive the loaded attributes.

6. Click on an eligible object to apply
attributes to it as well as any other



identical objects, depending on which
Object Painter Mode is active.

Deleting Objects

7. Continue clicking to apply attributes
until the Esc key is pressed or another
tool is activated.

Deleting Objects

Objects can be deleted in a variety of ways:
* Select an object or group of objects, then
click the Delete | edit button, select

Edit> Delete  from the menu, or press
the either the Delete or Backspace key on
your keyboard.

» Entire categories of objects can be
deleted using the Delete Objects dialog.

* Objects are deleted if the floor they are
placed on is deleted. See “Deleting
Floors” on page 291.

If an object has a line with arrow attached to
it, the arrow is deleted if the object is deleted.
To prevent the arrow from being deleted,
drag the attached end away from the object
before deleting it.

Delete Objects Dialog

% Select Edit> Delete Objects to use
=% the Delete Objects dialog to delete all
objects of one or more specified types in one

room, on the current floor, or on all floors in
the plan.

™ Delete Objects

Delete Scope
() single Room
(® All Rooms On This Floor
[] objects
[] cabinets
[ Architectural Blocks
|:| Fixtures
|:| Furniture
[[] Geometric Shapes/HardwareMillwork
[ Electrical
[] 1mages / Bilboards
[ Plants
[ Fireplaces
[ cap
[ Text
[Jcap

*

[] roof Planes

[ stairs / Landings
[ windows

|:| Doors

[] wall Hatching

[] Manual Dimensions

|:| Automatic Dimensions

Cancel Help
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o Select a Delete Scope:

* Choose Single Room to delete objects
only in rooms on the current floor that
you specify.

* Choose All Rooms on This Floor to
delete objects in all rooms on the current

floor.
e Specify categories of Objects to Delete
by checking the box beside each
category that you wish to delete.

*  Check the box beside any heading to
select all of the categories within it; clear
the box beside a heading to deselect all of
its categories.

To use the Delete Objects dialog

1. Select Edit> Delete Objects 558 to open
the Delete Objects dialog.

2. Specify the Delete Scope as Single
Room or All Rooms On This Floor.

3. Check the box for each category of
objects you want to delete. Click Select
All to check all the boxes or Clear All to
uncheck all boxes.

4.  When the scope is set to Single Room:

* Move your cursor into the drawing area
and click in a room of the plan to delete
objects of the selected type within that
room without closing the dialog.

* Only objects with their center point
located in the room are deleted.

» Continue clicking on rooms or choose a
different Delete Scope.

¢ Click Done when all selections have
been deleted.

5. Ifyouselect All Rooms On This Floor,
you do not need to click in floor plan
view. The Delete button becomes avail-
able, and clicking it closes the dialog
and deletes the specified objects.

Objects such as roofs or Auto Exterior
Dimensions that are set to automatically
rebuild or refresh cannot be deleted while
that behavior is enabled. If objects of this
sort are selected for deletion, the program
will ask whether you want to turn off the
automatic redraw behavior.

Deleting Polyline Edges

To remove an edge from a polyline, drag a
corner handle until it overlaps an adjacent
corner handle to remove the edge between
them and merge them into a single handle.
See “Reshaping Objects” on page 116.

Delete Surface

In any 3D view, select 3D> Delete

Surface, then click a surface in the
view to temporarily remove the surface from
the current view without permanently
affecting the object. See “Delete 3D Surface”
on page 386.

Undo and Redo

120

The Undo and Redo commands
allow you to both undo the last

oS

action performed, as well as redo actions that
were recently Undone.



The 50 most recent actions can be Undone or
Redone. Actions that can be Undone and
Redone include creating, editing, and
deleting objects.

To Undo an action, select Edit> Undo 2,

click the Undo 2 button, or press Ctrl + Z
on your keyboard.

The Redo command is only available after
Undo has been used. To Redo an Undone

action, select Edit> Redo [C¥, click the
Redo © button or press Ctrl + Y on your
keyboard.

It is important to note that Undo 2 and

Redo ' do not affect all actions in the
program, including:

Undo and Redo

Save and Save As. See “Saving, Export-
ing, and Backing Up Files” on page 39.

Changes made in the Library Browser.
See “The Library Browser” on page 336.

Changes made to information in a Mate-
rials List. See “Materials Lists” on page
437.

Changes made in a dialog while the dia-
log box is open. See “Dialogs” on page
26.

Changes made to the display by panning

the display or zooming in or out. See
“Undo Zoom” on page 73.

Changes made to the position of a cam-
era, or its Rendering Technique. See
“Editing 3D Views” on page 391.
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Chapter 10:

CAD Objects

The CAD Tools are used to add information
to 2D views of your model. CAD objects do
not affect 3D objects or display in camera
views or overviews, but they can be used to
add details to floor plan view.

CAD objects are edited much like other
objects in Home Designer Interiors. See
“Editing Objects” on page 93.

Chapter Contents
. The CAD Drawing Tools
. Line Specification Dialog
. Arc Specification Dialog

. Circle/Oval/Ellipse Specification Dialog
. Polylines

. Polyline Specification Dialog

. Box Specification Dialog

. Displaying CAD Objects

The CAD Drawing Tools

The CAD drawing tools can be
accessed by selecting the CAD menu
or by clicking the CAD Tools button.

Draw Lines

/ / Select CAD> Draw Line or
CAD> Draw Line With Arrow
to draw lines with or without arrows.

Todraw alineor line with arrow

1. Select CAD> Draw Line ./~ or Draw
Line With Arrow /.

2. Click and drag in the drawing area to
draw a line.

3. Continue drawing lines as needed, then
select another tool when you are
finished.

Once a line is created, it can be edited. You
can snap the ends of lines together to form
polylines. See “Editing Line Based Objects”
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on page 96 and “Line Specification Dialog”
on page 125.

Draw Arc

Select CAD > Draw Arc to draw an
arc.

e

Todraw an arc

1. Select CAD> Arcs> Draw Are /(%
then click at the arc’s start point.

2. Move the pointer along the desired
curve while dragging to curve the arc.

3. Release the mouse button at the end
point to complete the arc.

Once an arc is created, it can be edited. See
“Editing Arc Based Objects” on page 98 and
“Arc Specification Dialog” on page 127.

You can snap the ends of arcs together with
other arcs or with lines to form polylines. See
“Polylines” on page 129.

Draw Polyline

Select CAD > Draw Polyline to draw
a rectangular polyline in either of two

*]

ways:
+ Click in the drawing area to place a 24” x
24” square polyline at that location.

* Click and drag from corner to corner to
draw a rectangle of any size.

Once drawn, a rectangular polyline can be
edited into any shape. See “Editing Closed-
Polyline Based Objects” on page 104 and

“Polyline Specification Dialog” on page 130.

Draw Box

D Select CAD > Draw Box to draw a
box.

CAD boxes are drawn from corner to corner,
forming a rectangle that can then be edited.
Unlike a polyline, a box always has four 90°
corners. See “Editing Box-Based Objects”
on page 106 and “Box Specification Dialog”
on page 132.

Draw Circle

Select CAD > Draw Circle to draw a
circle.

@,

Draw a Cirele O by dragging across the
diameter, in any direction.

If a small circle is needed, draw a larger
circle and then resize it. See “Editing Circles,
Ovals and Ellipses” on page 110 and “Circle/
Oval/Ellipse Specification Dialog” on page
129.

Draw Oval

Select CAD > Draw Oval to draw an
oval, which is a four-arc
approximation of an ellipse.

Draw an oval, by clicking and dragging at an
angle to define its maximum height and
width.

Once an oval is created, it can be edited. See
“Editing Circles, Ovals and Ellipses” on
page 110 and “Circle/Oval/Ellipse
Specification Dialog” on page 129.

Draw Ellipse

An Ellipse is a set of points with a
constant combined distance from two



points called foci. An ellipse looks like a
stretched circle, or a circular surface viewed
at an angle.

To draw an ellipse, select CAD> Draw

Ellipse © and drag at an angle to define its
maximum height and width.

Once an ellipse is created, it can be edited.
See “Editing Circles, Ovals and Ellipses” on
page 110 and “Circle/Oval/Ellipse
Specification Dialog” on page 129.

Draw Spline

/\/ A Spline is a curve that passes

smoothly through a set of points.
Select CAD> Draw Spline to draw
connected line segments that form a spline.
See “Splines” on page 132.

Line Specification Dialog

Once created, a spline can be selected and
edited. See “Polyline Specification Dialog”
on page 130.

Dimension Tools

Select CAD> Dimensions to access

the Dimension Tools. The Dimension
Tools can be used with CAD and
architectural objects and are discussed in
their own chapter. See “Dimensions” on page
183.

Text Tools

Select CAD> Text to access the Text
Tools. The Text Tools are discussed in
their own chapter. See “Text” on page 195.

Line Specification Dialog

l—l Select a CAD Line, Line With Arrow,

or Text Line With Arrow and click the
Open Object edit button to open the Line
Specification dialog.

The settings on the panels in this dialog are
found in the specification and defaults
dialogs for a variety of different objects in
the program.

Line Panel

The information on the LINE panel of the
Line Specification dialog is similar to that

found on the SELECTED LINE panels of
various specification dialogs in the program.
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™ Line Specification

Line Length/Angle
Line Style Length:
Arrow

Angle:

End Paint

X Position:

¥ Position:

@ O O

Cancel Help

Specify the Length and Angle of the
selected line.

The X and Y Position coordinates of
the selected line’s Start Point display
for reference but cannot be changed here.

The Start Point can be changed using the
line’s edit handles, however. See “Editing
Line Based Objects” on page 96.

9 Specify the X and Y Position of the
selected line’s End Point.

Line Style Panel

The LINE STYLE panel is found in the
specification dialogs for many different
objects. The settings here control the

appearance of the lines and/or arcs that make
up an object. Depending on the type of object
selected, some settings may not be available.

™ Line Specification *
Line Line Options
S cer |
Arrow
Style: hd

Cancel Help

* Click the Line Color box to specify a
new line color. See “Select Color Dialog”
on page 90.

* Click the Line Style drop-down list to
select from a variety of available line
styles.

126

An additional Display Options setting is
available In the Picture File, Metafile, and
PDF File Box Specification dialogs. See
“Pictures, Images, and Walkthroughs” on
page 413.

¢ Check Show Outline to display the
selected object’s border polyline.



Arc Specification Dialog

Arrow Panel

The ARROW panel is available for any line, based object along its edges, but can attach to
arc, open polyline, or spline that can have an an architectural object anywhere within its
arrow: including dimension lines. The 2D symbol in floor plan view. If an arrow is
defaults for arrows are set in the Arrow attached to another object, deleting that
Defaults dialog. See “Dimension Defaults object will also delete the arrow.

Dialog” on page 183.

Closed polylines are examples of objects that

Lines with arrows can be attached to other cannot have arrows.

objects. They attach to a closed polyline-

™ Line Specification *
Line Indude Arrow
Line Style Style: - - Default
Arrow

Fill Color: _ [ Default

[] Arrow On Both Ends

Cancel Help

¢ Check Include Arrow to create an
arrowhead at the end of the selected line,
arc, or open polyline.

e Select an arrowhead Style from the drop- .
down list.

*  Click the Fill Color box to select a color
for the arrowhead to be used if a solid

Style is selected. See “Select Color Dia-
log” on page 90.
Specify the arrowhead’s Size.

Check the box beside Arrow On Both
Ends to create a two-headed arrow.

Place a check in any of the Default boxes
to restore that setting to the default.

Arc Specification Dialog

I—l Select an arc and click the Open The settings on the ARC panel are also found
Object edit button to open the Arc on the SELECTED ARC panels for many
Specification dialog. objects.
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Arc Panel
™ Arc Specification *
e e 1
Line Style Cen
Arrow
t: |-298 5/8
59 11f16"
Start Angle: 156.664275°
End Angle: 23,335725%
Arc Angle: -133.32855%
Arc Length: 138 15/16"
Start Point o
Start X Position: 433 1/15
Start Y Position: |-275
Start Direction:  |66.664275%
End Paint o
End X Position: 542 1116
End Y Position:  |-2757
End Direction: 3.335725
Chord o
Chord Length: 109 5/8"
Conel || reb

0 These settings define the Arc. Some

values are listed for reference only and
cannot be directly changed here. They can,
however, be changed using the edit handles
and edit tools. See “Editing Arc Based
Objects” on page 98.

* The Center X and Center Y Points are
the Y and Y coordinates of the center of
the arc and display for reference. They
may update as changes are made to other
settings in this dialog.

* Radius - Specify the distance between
the center of the arc and the arc surface.

+ Start Angle - The angle of a line drawn
from the arc center to the arc start points.

2]

This displays for reference only but may
update as changes are made to other set-
tings in this dialog.

End Angle - Specify the angle of a line
drawn from the arc center to the arc end.
Arc Angle - Specify the angle between
the center of the arc and each end.

Arc Length - Specify the length of the
arc along its curve.

Start Point - Specify information about
the starting point of the selected arc.

The Start X and Start Y Position coordi-
nates display for reference. They may



update as changes are made to other set-
tings in this dialog.

» Start Direction - Specify the angle of a
tangent line at the start of the arc.

e End Point - Specify information about
the end point of the selected arc.

* End X - Specify the X coordinate for the
end of the arc.

* EndY - Specify the Y coordinate for the
end of the arc.

* End Direction - The the angle of a tan-
gent line at the end of the arc displays for
reference. This displays for reference
only but may update as changes are made
to other settings in this dialog.

Circle/Oval/Ellipse Specification Dialog

Define the selected arc’s Chord, which
is the straight line between its start and
end points.

* Chord Length - The straight line dis-
tance between the two ends of the arc.

* Chord Angle - Specify the angle of the
chord.
Line Style Panel

For information about the LINE STYLE panel,
see “Line Style Panel” on page 126.

Arrow Panel

For information about the ARROW panel, see
“Arrow Panel” on page 127.

I—l Select a circle, oval or ellipse and

click the Open Object edit button to
open the CAD Circle, Oval or Ellipse
Specification dialog.

Circle/Oval/Ellipse Specification Dialog

Line Style Panel

For information about the LINE STYLE panel,
see “Line Style Panel” on page 126.

Fill Style Panel

For information about the FILL STYLE panel,
see “Fill Style Panel” on page 131.

Polylines

A polyline consists of two or more line and/
or arc segments that are attached at their
endpoints. Select CAD>> Rectangular
Polyline, then click and drag from corner to
corner to create a rectangular-shaped, closed
polyline. A closed polyline measuring 2°x 2’
(600 mm x 600 mm) can also be created by
clicking once while the Rectangular
Polyline tool is active.

You can also create a polyline by drawing
lines and/or arcs end-to-end, allowing the
end of each new object to snap to the end of
the previous one.

Line- and arc-based objects will only snap

together to form a polyline if they are on the
same layer and share identical attributes such
as color, line style, and arrow specifications.
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If one end of the polyline is connected to the
other, it becomes a closed polyline.

j@

Closed Polylines

Polylines can be copied, moved, reshaped, or
resized as a single unit.

Once created, polylines can be edited in a
variety of ways. See “Editing Open Polyline

—/
) O

Open Polylines

Based Objects” on page 101 and “Editing
Closed-Polyline Based Objects” on page
104.

Polyline Specification Dialog

130

I—l Select an open polyline, closed

polyline, spline or Electrical
connection and click the Open Object edit
button to open the Polyline Specification
dialog.

Polyline Panel

The POLYLINE panel is found in the
specification dialogs for a variety of objects
throughout the program. It states:

* The Length of an open polyline-based
object;

* The Perimeter of a closed polyline-
based object;

+ The Area of a closed polyline-based
object;

* The Volume of a closed polyline-based
object.

If the polyline is not closed, the Area and
Volume are described as “Not closed”. The
Volume of a 2D polyline will always be 0,
even if it is closed.

Selected Line Panel

The SELECTED LINE panel is available when
the selected edge of the polyline is a line as
opposed to an arc and is not available if the
selected object is a spline. See “Editing Line
Based Objects” on page 96.

Moving the End of a line segment moves the
start of the next connected line, if there is
one.

This panel is similar to the LINE panel of the
Line Specification dialog. See “Line Panel”
on page 125.



Selected Arc Panel

The SELECTED ARC panel is available when
the selected segment of the polyline is an arc
as opposed to a line. It is not available if the
selected object is a spline.

Polyline Specification Dialog

This panel is similar to the ARC panel of the
Arc Specification dialog. See “Arc Panel”
on page 128.

Line Style Panel

This panel is similar to the LINE STYLE panel
in the Line Specification dialog. See “Line
Style Panel” on page 126.

Fill Style Panel

The information on the FILL STYLE panel for

closed polylines is similar to that for many
other objects in the program, including
closed CAD shapes and a variety of
architectural objects.

The FILL STYLE panel is not available for
Electrical Connections as this tool cannot be
used to form closed shapes.

™ Palyline Specification *
Polyline Fill Pattern: Angle Hatch =
Selected Line ) . =
Line Style Spadng: 2 =
Fill Style [] Transparent Pattern Background
ricoer:
Transparency: I
Preview Width: | 12° =
Cancel Help

Specify the characteristics of the selected
object’s fill Pattern. When “None” is the
selected pattern Type, the rest of these

settings are disabled.

* Choose a pattern Type from the drop-

down list.

* Specify the Spacing of the selected fill
pattern. Not available for “Solid” fill.

e Check Transparent Pattern Back-

ground to make the spaces between fill

pattern lines transparent, allowing any
objects behind the fill pattern to be visi-
ble through it. Not available for “Solid”
fill.

Specify the Color of the lines that make
up the fill pattern, or the fill color of
“Solid” fill, by clicking the color bar. The
layer color is used by default. See “Select
Color Dialog” on page 90.

Use the Transparency slider bar or text
field to control how transparent the fill
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pattern lines are. This setting also affects
the transparency of Solid fill colors.

A preview of the selected pattern displays to
the right. As changes are made to the settings
on this panel, the preview will update.

* Choose a Preview Width from the drop-
down list. This value controls how large
an area the preview represents. The
selected value indicates the length of

each side of the preview in actual plan
inches (mm).

Arrow Panel

The ARROW panel is available for most open
polylines and splines and is similar to the
ARROW panel of the Line Specification
dialog. See “Arrow Panel” on page 127.

The ARROW panel is not available for closed
polylines.

Box Specification Dialog

I—l Select a CAD box and click the Open

Object edit button to open the Box
Specification dialog. See “Draw Box” on
page 124.

Line Style Panel

For information about the LINE STYLE panel,
see “Line Panel” on page 125.

Fill Style Panel

For information about the FILL STYLE panel,
see “Fill Style Panel” on page 131.

Splines

132

/\/ A Spline is a curve that passes

smoothly through a set of points.
Splines are typically used in situations where
there is an irregular curve. A contour line is a
typical example. Splines are useful wherever
a free-flowing curve is needed.

Once created, splines can be selected and
edited. See “Polyline Specification Dialog”
on page 130.

To use the Spline tool

1. Select CAD> Spline /..

2. Click and drag to draw the first spline
segment just as you would a line. A sin-
gle spline segment looks identical to a
line, in fact. You may need to turn off

Angle Snaps 2 to draw freely.



3. Draw the second segment from the end
of the first at a different angle. Object

Snaps I'? should be on to assure that
new segments attach correctly to the
ends of previous segments.

¥ Asdrawn e

Result

4. Assoon as two straight spline segments
connect end-to-end, the straight seg-
ments become a curve that passes
through the endpoints defined by the
original segments. Each point is called a
vertex.

5. Draw a few more segments, connecting
each to the free end of a previously
drawn segment.

Result

8 ) / X
T
" As drawn

6. Notice as additional segments are drawn
that the spline changes the curvature of

Displaying CAD Objects

the previous segment to create a contin-
uous curve between the last three points.

7. Form a closed spline by drawing a seg-
ment between its two free ends.

Draw segment to cy‘

8. The result is an irregular curve that
flows smoothly through each vertex.

esult

St

Spline-based objects will only snap together
to form a single spline if they share identical
attributes such as color, line style, and arrow
specifications.

Displaying CAD Objects

As with architectural objects, the display of
CAD objects is controlled in the Display
Options dialog. See “Display Options
Dialog” on page 88.

CAD objects can be drawn in floor plan
view. They are 2D objects only, though, so
they cannot be seen in any view other than
the one they are drawn in and are never
visible in camera views or overviews. See
“Architectural vs CAD Objects” on page 78.
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Drawing Groups

Each object in a plan file is included in a
Drawing Group, which influences whether it
displays in front of or behind other objects.
By default, all CAD objects are placed in the
same Drawing Group. Their drawing order
relative to one another is based on the order
in which they were placed: an object will

display in front of any objects that were
created before it was.

Once created, however, the drawing order of
CAD objects can be customized. See
“Drawing Groups” on page 89.



Chapter 11:

Walls and Railings

Walls are the single most important building
component in Home Designer Interiors. By
creating walls and defining the rooms created
by the walls, you are telling the program how
you want the 3D model built.

There are several ways that walls can be
created in Home Designer Interiors. The
most common is to simply draw them with
the Wall Tools.

In addition, exterior walls can be generated
automatically when a new floor is built by
using another floor as a model. For more, see
“Adding Floors” on page 289.

Another feature that can be used to generate
walls automatically is the Space Planning

Assistant. See “Space Planning” on page 49.

Chapter Contents
Wall Defaults
Wall Tools
Railing Tools
Exterior and Interior Walls
Foundation Walls
Railing Tools
Room Dividers and Invisible Walls
Hatch Wall
Break Wall
Drawing Walls
Connecting Walls
Displaying Walls
Measuring Walls
Editing Walls
Aligning Walls
Roof Directives in Walls
Attic Walls
Wall Type Definitions
Wall Specification Dialog
Railing Specification Dialog
Wall Hatch Specification Dialog
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Wall Defaults

@ Default Settings can be accessed by The settings in the wall defaults dialogs
selecting Edit> Default Settings. determine what wall types are drawn when

Click on “Walls” and click the Edit button to the different wall tools are used. It is a good

open the Wall Defaults dialog. idea to be familiar with these settings and

how they relate to your style of building.

Exterior and Interior Wall Defaults Dialogs

Specify the initial attributes of walls drawn o Select the wall type drawn using the
using the Exterior & and Interior Wall Exterior Wall & tool.
tools in the Exterior and Interior Wall 9 Select the wall type drawn using the
Ill);;aults dialogs. See “Wall Tools” on page Interior Wall tool.
e Uncheck Auto Rebuild Attic Walls to
Exterior/Interior Wall Defaults X prevent Attic walls from automatically
— ° generating when the model changes. When
= 73 checked, Attic Walls are automatically gen-
erated. See “Attic Walls” on page 153.
Interior Wall o
Interior-4 =
Automatic Walls o
Auto Rebuild Attic Walls
Cancel Help
Wall Tools
Select Build> Wall to access the Wall tool is specified in its corresponding defaults
Tools. The type of wall drawn by each wall dialog.
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The Curved Wall tools are similar to their
corresponding Straight Wall Tools. Select
Build> Wall to access these tools as well.

Exterior Walls

E~ |4 The Exterior Wall and Curved

i) Exterior Wall tools draw walls
using the default wall type specified for
exterior walls in the Exterior/Interior Wall
Defaults dialog. See “Exterior and Interior
Walls” on page 138.

Interior Walls

@ The Interior Wall and Curved
£] Interior Wall tools draw walls
using the wall type specified for interior
walls. The interior wall type is defined in the
Exterior/Interior Wall Defaults Defaults
dialog.

Note: Whether a wall is recognized as an
exterior or interior wall by the program is
determined by its position in the model, not
by the tool used to draw it. See “Exterior and
Interior Walls” on page 138.

Half-Walls

The Half-Wall and Curved
Half-Wall tools create solid

Injils)

Railing Tools

railings: walls that are 36” (900 mm) high
topped with a handrail.

Room Dividers

™1 Room Dividers are Invisible walls
kd| with a thickness of 0” (mm) that are
used to define separate room areas in a plan.
They can display in plan view but not in 3D
views. See “Room Dividers and Invisible

Walls” on page 139.

Hatch Wall

f The Hatch Wall tool applies a hatch

pattern to a wall that displays in plan
views. You must click the wall that you want
to apply the hatch pattern to. You can then
select the hatch and resize it if you want to
only hatch a portion of a wall. See “Hatch
Wall” on page 140.

Break Wall

B f' The Break Wall tool applies a break

in a wall. Once a wall is broken, the
two wall segments are separate walls that can
be modified independent of each other. See
“Break Wall” on page 141.

Railing Tools

Select Build> Railing to access the Railing
Tools.

Each of the tools in this family have both
Straight and Curved versions, and are created
and edited just like walls. See “Drawing
Walls” on page 141.

To create a break in a railing for a stairway or

other access, use a Doorway *—* . This keeps
the railing continuous and maintains room
definition. See “Room Definition” on page
163.
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When first drawn, railings are specified as
No Locate, which prevents Auto Exterior

Dimensions A from locating them. This
attribute may also be helpful if you do not
want a railing to divide an area into two
separate rooms. See “General Panel” on page

155.

I]Il]:] I]T'[Il The Railing and Curved Railing
tools create railings that are

primarily used to define interior spaces.

Railings are ideal for a number of tasks:

* Creating changes in floor and/or ceiling
height. See “Floor and Ceiling Heights”
on page 172.

+ Creating stairwells. See “Creating a Stair-
well” on page 308.

—

* Drawing decks. See “Decks” on page
172.

Railing Types

A variety of railing types can be specified in
the Railing Specification dialogs. See “Rail
Style Panel” on page 159. Available types
include:

* Baluster creates railings composed of
newel posts, balusters, a railing, and an
optional bottom rail.

* Solid produces a framed railing wall, or
Half Wall. See “Half-Walls” on page 137.

o If Panels is selected, you can choose a
panel style such as glass or ironwork from
the library. See “Newels/Balusters Panel”
on page 161.

Newels and balusters do not display in plan
view.

Exterior and Interior Walls

138

Eﬂ Most walls are drawn using either
Al the Straight Exterior Wall and

Straight Interior Wall tools.
Exterior and interior walls can

b (|
LA also be drawn using the Curved

Exterior Wall and Curved Interior Wall
tools.

The only difference between the Exterior and
Interior Wall Tools is the wall type used:
Exterior Walls use a wall type set up to
model a wall with siding, while Interior
Walls model interior walls with sheetrock.
You can specify the default wall type for
each tool in the Exterior/Interior Wall
Defaults dialog. See “Exterior and Interior
Wall Defaults Dialogs™ on page 136.



Foundation Walls

To draw a wall using a different wall type, * Any wall or wall segment that is entirely
you can change the default wall type for surrounded by interior room areas is con-
either tool in the Exterior and Interior Wall sidered to be an interior wall.

Defaults dialogs. You can also draw a wall
using the default type and then change the
wall type in the Wall Specification dialog.

* Any wall or wall segment that defines an
exterior room or is exposed to the outside
of the building is considered to be an

Whether a wall is recognized by the program exterior wall. See “Room Types™ on page

as an actual exterior or interior wall is based 165.

on its position in the model, not by which

tool you use to draw the wall.

Foundation Walls

Foundation walls are similar to the interior
and exterior walls but also have a footing.
Foundation walls are created automatically
when a foundation floor is created. See
“Building a Foundation” on page 278.

Room Dividers and Invisible Walls

r—1 The Room Divider tool is used to

k=l define separate room areas in a plan;
typically, by dividing a large room area into

two or more smaller areas. See “Room

" KITCHEN
Definition” on page 163. L

|
Dnlil:ll\}l} ‘ FAMILY g
SV L]

include dividing areas of an open floor plan HALL

into areas with different purposes. Room Dividers separate this dining area
from adjacent rooms

Room Dividers can also be used to define
areas with different floor or ceiling materials
or heights.
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specified as Invisible and have a single layer
of an “Air Gap” material with a thickness of
0” (mm).

separates two rooms with different floor and/
or ceiling heights, its wall type will be
changed to the current plan’s default Interior
Wall so that the platform step created by the
height difference can be enclosed.

Any wall, regardless of its wall type or
thickness, can also be specified as Invisible -
or vie versa - in the Wall Specification
dialog. See “General Panel” on page 155.

Room Dividers are placed on the “Walls,
Invisible” layer by default, as are walls that
are specified as Invisible.

Walls specified as Invisible can display in
plan view but not in 3D views or the

Materials List. See “Displaying Walls” on
page 144.

It is not possible to place doors, windows, or
fireplaces into an Invisible wall; however, if
a wall with openings in it is specified as
Invisible, any openings in it will remain.

Important Notes on
Invisible Walls

* Floor, wall and ceiling areas are calcu-
lated separately for rooms divided by
Invisible walls.

» Cabinets, fixtures and furniture can be
moved freely through Invisible walls.

» Invisible walls can be drawn through a
cabinet to attach to the wall behind.

* Room Dividers are automatically gener-
ated to connect “island” rooms to the
larger structure around them. See “Room
Definition” on page 163.

Hatch Wall
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i The Hatch Wall tool can be used to
fill wall segments with a single hatch
pattern in plan view.

To apply wall hatching, select Build> Wall>

Hatch Wall & | then click on a wall. The
hatch pattern covers the entire length and
width of the wall segment.

Note: The Hatch Wall tool cannot be used to
apply a hatch pattern to Invisible Walls. See
“Room Dividers and Invisible Walls” on page
139.

Hatch Wall & places a hatch pattern across
all layers of the selected wall layers,
covering any fill styles specified for that wall

type.

Once created, wall hatching can be selected,
edited and deleted much like other line-based
objects. See “Editing Line Based Objects” on
page 96.

If you use the Hatch Wall € tool to apply a
hatch pattern to a wall that has been divided
into multiple segments using the Break

Wall & tool, the pattern is only applied to



the segment that you clicked on. See “Break
Wall” on page 141.

Like doors and windows, wall hatching
cannot extend across multiple wall segments.
Unlike these objects, hatching cannot be
located by dimension lines.

Break Wall

The wall hatch pattern can be specified in the
Wall Hatch Specification dialog. See “Wall
Hatch Specification Dialog” on page 162.

When editing or deleting wall hatching,
make sure that it is selected rather than the
wall by noting that ““Wall Hatching” displays
in the Status Bar. See “The Status Bar” on
page 29.

Break Wall

To divide a wall or railing, select Build>
Wall> Break Wall and click on the wall.
The wall is divided into two wall sections at
the point where you click.

-)/- The Break Wall %* tool remains

active, so you can continue to place
breaks in walls. When you are finished,
select a different tool.

If a wall break is placed near the intersection
of two walls, the break is positioned at the
center of the intersection. Note, too, that a
break cannot be placed within 12” of an
existing break or in the same location as a
wall opening.

Once a break is placed, click the Select

Objects | tool and select the original wall.
If edit handles display near the break, the
wall was correctly broken.

Walls separated by a break can be rejoined.
Select one of the segments, then click on the
end edit handle located at the break and drag
it a few plan inches (mm) away from the
break. See “Connecting Walls” on page 143.

The Break Wall %" tool can be used to
create aligned walls on either side of a gap.
See “Creating a Nook™ on page 151.

Drawing Walls

Walls, railings, and fencing are drawn by
clicking and dragging from end to end. Walls
can be drawn in plan view, camera views,
and overviews.

Drawing walls to create a floor plan is simple
if you keep a few things in mind:

* Draw exterior walls first to define the
building’s footprint, then draw the interior
walls after the perimeter is in place.

 Itis easiest to draw walls at the approxi-
mate location and length needed and then
move or resize them precisely using
dimensions later. See “Moving Objects
Using Dimensions” on page 192.

*  When drawing and positioning exterior

walls, make sure Grid Snaps Bt are
enabled. Once these walls are in place,
you may prefer to turn Grid Snaps off to
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draw and position interior walls and other
objects. See “Grid Snaps” on page 79.

* As walls are drawn, “sticky” points iden-
tify points that are either collinear or
orthogonal to the end points of other
walls, making alignment easier. See
“Extension Snaps” on page 78.

*  When walls enclose an area to form a
room, the program will orient all exterior
walls so that the siding material faces out-
ward.

+ To flip the layers of a wall after it is
drawn, select it and click the Reverse
Layers ‘T’ edit button. See “Editing
Walls” on page 148.

+ Initial wall heights are determined by the
default floor and ceiling heights of the
current floor.

Wall Angles

With very few exceptions, walls should be

drawn and edited with Angle Snaps
enabled. Walls that are drawn at irregular
angles can result in wall connection,
alignment, and room definition problems.

If a wall is drawn at an off angle, the Off
Angle Wall I icon will follow the mouse

pointer and a Caution ¥ symbol will
display over the problem wall in plan view.

To correct the wall’s angle, click on the

Caution +¥. symbol that displays over the
wall and select Fix Off Angle Wall from the
contextual menu. In the Fix Off Angle Wall
dialog:

Fix Off Angle Wall *
9

Old Angle:  92.847051%

New Angie:

Lock: @® start () Center (C) End

Cancel Help

* The Old Angle is stated for reference.
* Enter a New Angle in the text field.

Specify whether to Lock the Start, Cen-
ter, or End point of the wall when its
angle is changed.

There are several other ways to fix a selected
wall if it has been drawn at an off angle:

e Click the Open Object ¥ edit button
and specify the correct angle. See “Gen-
eral Panel” on page 155.

* Click and drag an end edit handle until the
wall snaps to an Allowed Angle. See
“Angle Snaps” on page 79.

» If the wall in question should be aligned
with a wall directly above or below it,

click the Align with Wall Above == or

Align with Wall Below ™ edit button.
See “Aligning Walls” on page 151.

You can also suppress the Caution symbol by
specifying the needed angle in the wall’s
specification dialog.

Although not recommended, you can choose
to Ignore Off Angle Wall or Ignore All Off

Angle Walls by clicking on the Caution +*
symbol that displays over an off angle wall.

Wall Positioning

The recommended method of drawing walls
is to draw them at their approximate location



and length, then move them into position
with accuracy using dimensions. To make
this task quick and efficient:

* Notice the temporary wall that displays as
you draw. Its length and angle display in
the Status Bar at the bottom of the win-
dow and adjust as you move the mouse.
Release the mouse button to draw the wall
at the displayed length and angle. See
“The Status Bar” on page 29.

* Use Snaps to help ensure proper wall
alignment and orientation. See “Snap
Behaviors” on page 78.

Once walls are drawn, they can be accurately
dimensioned and moved as needed. See
“Measuring Walls” on page 146.

Wall Openings

To create a door or doorway, do not draw
wall sections with a gap between them. Walls
should be drawn to completely enclose
rooms, and then door and window objects
should be placed in the walls to create
openings later. See “Doors” on page 209 and
“Windows” on page 225.

Masonry fireplaces placed in walls are also
considered to be wall openings. See
“Fireplaces” on page 282.

Connecting Walls

Temporary Dimensions

Temporary dimensions will display along the
length of a wall as it is drawn, helping you
draw walls to the desired length. Although
dimensions display as you are drawing, you
do not need to position walls precisely when
you first draw them: they can be easily
moved into place at any time. See “Editing
Walls” on page 148.

Drawing Curved Walls

To draw a curved wall or railing, select a
curved wall tool, click at the point where you
would like the wall to begin, then drag along
the desired curve. Release the mouse button
to create the wall.

A straight wall can also be converted into a
curved wall and vice versa using the Change
Line/Arc = edit button. See “Change Line/
Arc” on page 117.

@ To create a room in the shape of a cir-
~ cle, you must draw two curved walls.

Space Planning Assistant

The Space Planning Assistant Tools
EiF  allow you to place and arrange room
boxes that can then be converted into a fully
editable house plan, including walls. See

“Space Planning” on page 49.

Connecting Walls

When walls are drawn sufficiently close to
one another, they will snap together to form
an intersection. This snapping occurs when
the walls’ center lines are within a distance
defined by the larger of the two walls’ widths

and will occur even when Object Snaps are
turned off. See “Object Snaps™ on page 78.

If the two walls in question have identical
specifications and are collinear, they will
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merge to become a single wall. See
“Aligning Collinear Walls” on page 151.

When three or more walls connect to form a
completely enclosed area, that area defines a
room. See “Rooms” on page 163.

When walls snap together to form an
intersection and Object Snaps are enabled,
the program joins them at their Main Layers.
See “Aligning Walls” on page 151.

* The wall that is being drawn or edited will
move, lengthen, or shorten slightly to
meet the other wall.

e The other wall will not move; however,
its length may be affected.

Fix Wall Connections

Occasionally, intersecting walls may not
properly connect. When this is the case and
the connection in question is on the current

floor, a Caution %+ symbol will display at
the problem location in plan view and the

Connect Walls "% icon will follow your
mouse pointer.

Click on the Caution % symbol that
displays over the wall to open a contextual
menu:

* Select Delete to delete the wall.

» Select Ignore Unconnected Wall to leave
the wall unchanged and suppress the Cau-
tion symbol.

Removing Wall Breaks

The Break Wall %* tool allows you to break
a wall into two or more separate wall
segments. See “Break Wall” on page 141.

To merge two collinear walls separated by a
break,select one of the segments, then click
on the end edit handle located at the break
and drag it a few plan inches (mm) away
from the break.

If the two walls do not merge, either one or
both walls have been moved and they are no
longer collinear, or one or both has been
edited in some way and they are no longer
identical. Open the Wall Specification
dialog for each wall and determine how they
differ. See “Wall Hatch Specification
Dialog” on page 162.

Displaying Walls
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The display of walls in all views is
| controlled in the Display Options
dialog. See “Layer Attributes” on page 87.

If a “Walls” layer is turned off, any doors and
windows placed in walls on that layer will
not display, either. See “Displaying Doors”
on page 212 and “Displaying Windows” on
page 230.

In Plan View

There are several options for controlling how
walls are displayed in plan view. In the
Display Options dialog, you can specify
whether or not various types of walls display.
Walls are placed on layers with “Walls” at
the beginning of the layer name, such as
“Walls, Normal”.



Note: In plan view, railings not specified as
Solid display their Main Layer regardless of
whether “Walls, Layers” or “Walls, Main Layer
Only” is turned on.

It is sometimes helpful to display the walls
from a floor other than the current floor. To
do this, select and display a reference floor.
See “The Reference Floor” on page 293.

Notification Icons

Occasionally, the program may detect a
problem with one or more walls in a plan.
When this is the case, notification icons will
display on the floor where the problem has
occurred:

» Ifawallis drawn at an off angle, the Off
Angle Wall . icon will follow the

mouse pointer and a Caution +#. symbol
will display over the problem wall in plan
view.

o If'there is a problem with a wall connec-
tion, the Connect Walls % icon will fol-

low the mouse pointer and a Caution +*
symbol will display at the problem loca-
tion.

The recommended response to either
situation is to fix the problem, although you
can choose to ignore it if you prefer. See
“Wall Angles” on page 142 and “Fix Wall
Connections” on page 144.

If an issue has been ignored, notification
icons for it will not display. Select Tools>
Checks> Reset Notification Icons to
display any suppressed notifications so that
any wall angle or connection problems can
be corrected.

Displaying Walls

In 3D Views

As in plan view, the display of walls can be
controlled by layer in the Display Options
dialog.

While most architectural objects in the
program can display in both floor plan and
3D views, a few cannot. Invisible walls and
Wall Hatching are examples of objects that
do not display in 3D.

Wall Materials

There are several ways that materials can be
assigned to walls. See “Rooms” on page 163.

When you draw a wall, it uses the materials
specified in its wall type definition. See
“Wall Type Definitions” on page 154.

You can change the surface material of an
individual wall in the Wall Specification
dialog. If you select “Use Default” as the
material and the wall is used to define a
room, the program refers to the material
specified in the Room Specification dialog.
See “Wall Specification Dialog” on page
154.

You can also change a room’s wall material
in the Room Specification dialog. See
“Materials Panel” on page 372. To restore the
default Wall Type material, select Use
Default in the Select Material dialog. See
“Select Material Dialog” on page 373.

Wall materials can also be changed using the

Material Painter ¥ tool, but bear in mind
that depending on which Material Painter
Mode is in use, only a portion of the wall
may be painted and that the entire room may
be affected rather than the individual wall.
See “Material Painter and Walls” on page
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371.

Note: Wall materials that are specified on the
Materials panel of either the Wall or Room
Specification dialog are not calculated in the
Materials List.

In the Materials List

The materials that make up wall assemblies
are listed under different Categories in the
Materials List:

+ Siding - Lists all materials located outside
of each wall’s Main Layer, such as siding,
sheathing, and housewrap.

* Framing - Lists the Main Layer material
for all walls as well as railings specified
as Solid. Non-framed walls’ Main Layer
materials are also listed here when those
walls are not specified as Foundation.

+ Insulation - Insulation is calculated for
all exterior walls that are not specified as
Railing, regardless of the wall type defini-
tion.

e Wallboard - Lists all materials located
inside of each wall’s Main Layer, such as

drywall. Includes all materials aside from
framing, concrete, and rebar in walls that
do not define rooms.

Does not include Wall Coverings or mate-
rials specified in either the Room or Wall
Specification dialog. See “Materials
Panel” on page 159.

» Interior Trim - Lists base, crown and
chair rail moldings, and Wall Covering
materials specified in the Wall and Room
Specification dialogs. See “Wall Cover-
ing Panel” on page 157.

» Foundation - Lists the concrete for all
walls specified as Foundation as well as
their footings. See “Foundation Walls” on
page 139.

With the exception of wallboard, windows
and doors are taken into account in the
calculation of these totals.

Additional wall-related information is listed
in the General category, including the total
linear feet of each wall type per floor and the
thermal envelope wall area per floor. See
“Conditioned Area” on page 442.

Measuring Walls
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Accurate wall measurements are an essential
aspect of any drawing, and can be achieved
by following two basic rules:

* Be aware of what part of a wall assembly
dimensions are locating;

» Position walls using dimensions rather
than edit handles or edit tools.

These rules can easily be met when you keep
the following recommendations in mind.

For information about changing the value
reported in a dimension line label, see
“Using Dimensions” on page 149.

Use Dimension Defaults

Dimensions can be set to locate walls at their
Dimension Layers or at their surfaces.
Before drawing dimensions - and
particularly, before using them to move your
walls into position - make sure that your



Dimension Defaults are set up to meet your
needs. See “Dimension Defaults Dialog” on
page 183.

If a wall is specified as Invisible, dimensions
will locate it at its centerline regardless of
your Dimension Defaults settings. If the
Invisible wall divides rooms with different
floor heights, dimensions will locate the edge
of the wall facing the room where the floor is
lower.

Edit Dimension Lines

Once a dimension line has been drawn, its
extension lines can be edited to locate a
number of locations on a wall assembly:

* The exterior surface

* The Main Layer’s exterior

* The center line of the wall assembly
* The Main Layer’s center line

e The Main Layer’s interior

¢ The interior surface

See “Editing Extension Lines” on page 191.

Moving Walls Using
Dimensions

By far, the most precise method of
positioning walls is using dimension lines.
To produce accurate measurements,
remember to:

* Be aware of what part of your walls is
being located by dimensions.

* Avoid specifying dimension values with
greater accuracy than your dimensions are
set to display. See “Format Panel” on
page 185.

See “Using Dimensions” on page 149.

Measuring Walls

Use Object, Angle and
Grid Snaps

Object Snaps, Angle Snaps, and Grid Snaps
make it easier to align walls when they are
being drawn as well as when they are edited.
See “Snap Behaviors” on page 78.

Object Snaps help to ensure consistent wall
connections and are particularly helpful
when aligning collinear walls.

When Grid Snaps are enabled, walls are
drawn on a regularly spaced grid, which
helps avoid inaccurate wall placement. This
can become particularly important if you
forego positioning walls using dimensions in
favor of using edit handles to move them.

@ Using Grid Snaps is recommended
~ when you are laying out exterior shell
walls, but may be inconvenient when posi-
tioning interior walls or other objects.

Angle Snaps make it easy to accurately draw
walls at regular angles, ensuring walls that
are truly parallel or perpendicular to one
another and separated by consistent
distances.

No Locate

If a wall is specified as No Locate in the
Wall Specification dialog, it will be ignored

by Auto Exterior Dimensions A in plan
view, as will any doors or windows placed in
it. See “Dimensions” on page 183.

By default, Railings, Deck Railings, and
Room Dividers are specified as No Locate.
See “General Panel” on page 155.

Once a dimension line has been created, it
can be edited so that it locates a No Locate
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wall or railing that is perpendicular to it. See
Editing Dimension Lines.

Editing Walls
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Walls can be selected in all views. When a
wall is selected, it displays edit handles and
an edit toolbar that can be used to modify it
in various ways. When a wall is selected,
temporary dimensions will also display.

The ways in which a wall can be edited
depend on the current view and which edge
is selected. See “Selecting Objects” on page
94.

Selecting Walls

Like other objects, walls can be selected in a
variety of ways. See “Selecting Objects” on
page 94.

In plan view, if wall hatching has been

applied to a wall using the Hatch Wall &
tool, the hatching may be selected first. Click

Select Next Object e to select the wall
itself. See “Hatch Wall” on page 140.

Using the Edit Handles

A selected wall can be modified in a variety
of ways using its edit handles in any view.
The handles that are available will depend on
the current view type.

+ Inplan view, straight and curved walls
can be edited like other line- and arc-
based objects. See “Editing Line Based
Objects” on page 96 and “Editing Arc
Based Objects” on page 98.

e Inacamera view or overview, click on the
top surface of a wall to display the same

edit handles as in plan view, allowing you
to rotate, move, and extend or shorten the
length of the wall.

* Moving a wall in any view will move any
cabinets attached to that wall, as well.

» Ina camera view or overview, click on an
interior or exterior surface to display an
edit handle at the center of each side edge,
allowing you to shorten or lengthen the
wall. Curved walls can be shortened in
this manner, but not lengthened.

*  When a wall is connected to other walls, it
can only be moved perpendicular to itself
or, in the case of curved walls, perpendic-
ular to its chord using the Move edit han-
dle.

In the Specification Dialog

I—l The appearance and structure of walls
can be customized in the Wall

Specification dialog. See “Wall

Specification Dialog” on page 154.

The characteristics of the roof directly above
a selected wall can also be specified in the
Wall Specification dialog. See “Roof Panel”
on page 156.

Using the Edit Tools

A selected wall or walls can be edited in a
variety of ways using the buttons on the edit
toolbar. See “The Edit Toolbar” on page 24.



Using Dimensions

Automatic, manually-drawn, and

temporary dimension lines can be
used to both resize and move walls with
accuracy. Select a wall, then click on a
dimension line that locates it and type in the
value that you need. See “Moving Objects
Using Dimensions” on page 192.

When a wall is resized using dimensions, the
inline text field used to edit the dimension
will have three unique buttons:

e Horizontal walls have Move Left End
7 Move Both Ends “~*, and Move
Right End .

« Vertical walls have Move Top End 'L/,
Move Both Ends **, and Move Bottom
End T

Choose the option that you want to use
before pressing the Enter key.

Move Left End Move Right End

B

Move Both Ends

If both ends of the selected wall intersect
walls that are not parallel to one another, a
fourth option will be available: Move Along

Rails == . When this option is used, the
selected wall both resizes and changes
position so that it remains connected to the
other walls when you press the Enter key.

Editing Walls

|
s, <
v v

Move Along Rails resizes
and moves a selected wall.

Depending on your Dimension Defaults

settings, dimension lines may locate wall

surfaces or Main Layers. See “Dimension
Defaults Dialog” on page 183.

Wall Thickness

The initial thickness of a wall is determined
by its wall type.

You can specify a selected wall’s thickness in
its Wall Specification dialog. See “General
Panel” on page 155.

If a selected wall’s thickness is changed:

* A copy of the wall’s wall type is created
with the same name but appended with a
number equal to the thickness of the
structural layer, and that new type is
assigned to the wall.

» The change in thickness will be applied to
new wall type’s structural layer.

e The structural layer must be at least 1/16”
thick, and the wall’s thickness cannot be
less than the original wall type’s total
thickness minus the thickness of its struc-
tural layer.

If a wall type’s thickness is modified, the
wall will resize about the outside edge of its
structural Layer. In some instances, the wall
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may appear to move as a result of changes
made to the thicknesses of its layers.

Wall Heights

The height of a wall is controlled by the
ceiling height of the room(s) it defines. If the
ceiling or floor height of a room is changed,
the height of the walls that define it also
change.

+ The initial ceiling height for all rooms on
a floor is set in the Floor Defaults dialog
for that floor. See “Current Floor
Defaults” on page 165. Whenever possi-
ble, it is best to set all ceiling heights
using the default.

* The ceiling height of a single room can be
set in its Room Specification dialog. See
“General Panel” on page 177.

Wall Length

Wall length can be modified in several
different ways:

» Using dimensions. See “Measuring
Walls” on page 146.

» In the Wall Specification dialog. See
“General Panel” on page 155.

» By dragging the end edit handles. See
“Editing Line Based Objects” on page 96
and “Editing Arc Based Objects” on page
98.

Bear in mind that if you try to resize a wall
by a small amount using one of its edit
handles and that wall is connected to another
wall at that end, its length will not change
because its end will snap back to the existing
intersection. See “Connecting Walls” on
page 143.

The most accurate way to specify wall length
is using dimensions. By default, wall length
is measured at the outside edge of the Main
Layer. You can instead specify that
dimension lines locate surfaces in the
Dimension Defaults dialog. See “Dimension
Defaults Dialog” on page 183.

Editing Straight/Curved Wall Combinations
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If you move a straight wall connected to a
curved wall with a locked center, the curved
wall extends along its curve and the straight
wall will either lengthen or shorten as needed
to stay connected to the curved wall.

If the connection between the straight and
curved wall cannot be maintained because of
the curved wall’s radius, it will be broken.

— N
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Aligning Walls

Aligning Walls

Wall alignment refers to the way wall
segments line up with one another, either on
the same floor or on the floor above or
below. Walls may need to be aligned in a
variety of situations.

To make alignment easier when drawing or
resizing walls, “sticky” points identify points
that are either collinear or orthogonal to the
end points of other walls. See “Extension
Snaps” on page 78.

Aligning Collinear Walls

Collinear walls are parallel walls connected
end to end and drawn on the same floor.
When collinear walls join end-to-end, the
walls snap together. If these walls have the
same wall type and identical specifications,
and if Object Snaps are enabled, they will
merge to become a single wall segment.

Creating a Nook
Walls can be aligned across an opening such

as a nook, so that they are collinear, using the

Break Wall % tool.
To align walls across a gap

1. Select a wall to build a nook into and
click the Break Wall %* edit button.

2. Click at a point on the wall close to one
side of the nook area. Do not worry
about exact placement right now.

3. Click again near the other side of the
nook. Two short lines at each location
where you clicked indicate Wall Breaks.

Place Wall
Breaks here

Position these
walls as needed

4. Right-click the middle section of the
wall to select the wall section.

5. Click the middle Move handle and drag
the wall outward.

6. Draw side walls to connect the wall back
to the rest of the house.

7. Move these short walls using dimen-
sions to accurately size the nook.

Aligning Walls
Between Floors
Walls can be aligned between floors by
clicking the Align With Wall Above =% and
Align With Wall Below ¥ edit buttons.

i In order for these edit tools to be avail-
@‘ able, the areas of the walls in question
must be partially aligned, or overlapping.

To align walls between floors

1. Select a wall that you want to align with
another wall either above or below it.
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2. Ifthe wall is above or below the other
wall along only part of its length, you
must click on it along that part. Select
Tools> Reference Floors> Reference
Display On = to help make sure you
click on the correct part of the wall.

3. When you have selected the wall at the
desired location, click either the Align

With Wall Above == or Align With
Wall Below ¥ edit button.

Aligning Curved Walls
Between Floors

Curved walls are aligned between floors
using the same technique to align straight
walls. If the centers and radii of the walls are
within a few inches of each other, the Align

With Wall Above == and Align With Wall
Below ™ edit buttons are enabled for the
selected wall. The selected curved wall will
take on the radius and center of the

referenced wall when the walls are aligned.

Roof Directives in Walls

152

To automatically generate a roof plane using
values other than the defaults or to not
generate a roof plane bearing on a particular
wall (as for a gable or the sides of a shed
roof), you can change the settings in the Wall
Specification dialog. See “Roof Panel” on
page 156.

Hip, Gable, and Shed Roofs

By default, the program will produce a roof
plane over each exterior wall to create a hip
roof. You can instead specify a gable or shed
roof above the selected wall.

* Check Full Gable Wall to create a gable
with a ridge centered above the selected
wall(s).

* Check High Shed/Gable Wall for the
side walls or the wall under the high side
of a shed roof.

*  You can also select a wall and click the

Change to Gable Wall(s) (Y edit button,
or change it back by clicking the Change

to Hip Wall(s) ™ edit button.

Pitch

The default pitch for roof planes is set in the
Build Roof dialog. However, any exterior
wall can define the pitch of the roof plane
built above it.

You can also specify a second, upper pitch
above a given wall. Mansard, gambrel, gull
wing and half-hip are examples of roof styles
that use two pitches. See “Roof Tutorial” on
page 57 of the User’s Guide.

Extend Slope Downward

Check Extend Slope Downward to extend
the roof plane downward over a bump out,
instead of creating additional roof planes.
The two connecting walls that create the
bump out must be Full Gable walls.

In the following image, the bearing wall of
the bump out has Extend Slope Downward
checked. The two short side walls are Full
Gable Walls.



Attic Walls

Wall

Full Gable

—

Extend S ope/

Downward

Attic Walls

In Home Designer Interiors, walls are built
between the floor and ceiling platforms of
the current floor. See “Floor and Ceiling
Heights” on page 172. When the program
detects an open space between a wall and the
roof plane above it, it automatically creates
an Attic Wall on the floor above that wall to
fill in the gap.

Attic Walls are typically found above Full
Gable Walls, forming a gable or closing the
top portion of a side wall of a shed roof. Attic
Walls are often found on the Attic floor, but
can be generated on other floors, as well. See
“The Attic Floor” on page 293.

¢ If you do not want to keep a particular
@ Attic Wall in your plan, specify it as
Invisible. See “Room Dividers and Invisible
Walls” on page 139.

Removing Attic Walls

Occasionally, the program will generate an
Attic Wall where one is not wanted. There
are several ways to address this:

* Turn off the display of the “Walls, Attic”
layer.

* Specify the Attic Wall as Invisible. See
“Room Dividers and Invisible Walls” on
page 139.

* Some interior Attic Walls can be sup-
pressed by specifying space they enclose
as a Shelf Ceiling. See “Shelf Ceilings”
on page 173.

« Select the Attic Wall and Delete X/ it.
The program will specify the wall as
Invisible automatically. If you delete this
Invisible wall, a new Attic Wall will be
created.

Knee Walls

Knee Walls are a bit like Attic Walls in that
they are not meant to generate to full ceiling
height. Instead, they build upward until they
encounter a roof plane. Unlike Attic Walls,
however, Knee Walls are used in the interior
of a structure, typically to separate unused
areas from rooms on the upper floor of a
story-and-a-half structure. See “Room
Types” on page 165.

Home Designer Interiors does not specify
walls as Knee Walls automatically. If an
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interior wall is drawn in a location where the
roof is lower than the ceiling height, you
should specify it as a Knee Wall in the Wall
Specification dialog. See “Roof Panel” on
page 156.

For best results, Knee Walls should be drawn
perpendicular to the pitch of the roof and
should intersect with Full Gable Walls on
each end.

Wall Type Definitions

Every wall drawn in a plan is assigned a wall
type, and its Wall Type Definition determines
its structure, its appearance in plan view, and
its default materials.

You can specify the default wall type that is
drawn by the Exterior and Interior Wall tools
and can specify the wall type of any wall
after it is drawn in the Wall Specification
dialog. See “Wall Defaults” on page 136 and
“General Panel” on page 155.

The structural layer of a wall type is its Main
Layer, which controls a number of things:

+ At intersections, walls join at the interior
surfaces of their Main Layers. See “Con-
necting Walls” on page 143.

*  Windows are placed relative to the outer
surface of the Main Layer.

» Exterior walls on different floors are
aligned by the exterior edges of their
Main Layer.

* Roof baselines are placed at the outer
edge of the Main Layer.

*  Walls resize about the exterior surface of
their Main Layer when their thickness or
wall type is changed.

* Object Snaps locate the interior and exte-
rior edges of a wall’s Main Layer. See
“Object Snaps” on page 78.

» By default, dimension lines locate walls at
their Main Layer. See “Dimension
Defaults Dialog” on page 183.

Interior and Exterior Surfaces

Every wall has an interior and exterior
surface - including walls in a plan that are
recognized by the program as being interior
walls. See “Exterior and Interior Walls” on
page 138.

Having separate designations for a wall’s two
surfaces allows you to specify different
materials for each in the Wall Specification
dialog. See “Materials Panel” on page 159.

In plan view, you can identify a selected
wall’s exterior surface by the location of its
edit handles, which display on the exterior of
the Main Layer.

Wall Specification Dialog

I—l To open the Wall Specification
dialog, select a wall and click the
Open Object edit button.

The panels of the Wall Specification dialog
are also found in the Railing Specification



Wall Specification Dialog

dialog. See “Railing Specification Dialog”

on page 159.
General Panel
[\\ Wall Specification «
General General o . |Z|
s
Wall Covering
Materials Wall Length: o
Options o
[ tnwisible
[ Mo Room Definition
[ Mo Locate
Wall Type o
Siding-6 =

Wall exterior is at top of drawing.

Cancel Help

Specify General properties of the
selected wall or railing.

The Thickness of the selected wall dis-
plays and can be changed here. If the wall
is a Post to Overhead Beam railing, this
setting also affects the width of the beam.
See “Wall Thickness” on page 149.

Wall Angle - The current absolute angle
of the wall in plan view is shown. If you
type in a new angle, any walls attached to
it will not move. If the selected wall is
curved, this value describes the angle of
the chord and cannot be modified.

Wall Length - The current length is
shown. If you type a new length, any
walls attached to the selected wall will not

2]

move. If the selected wall is curved, this
value cannot be modified.

Check any of the Options to modify the
selected wall accordingly. In most

cases, multiple options can be selected.

Check Invisible to specify the wall as
invisible. Invisible walls can display in
plan view but not in 3D views or the

invisible by default. See “Room Dividers
and Invisible Walls” on page 139.

Check No Room Def. to display the wall
in floor plan and/or 3D views but not cre-
ate room definition. See “Room Defini-
tion” on page 163.
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* Check No Locate to prevent Auto Exte-

rior Dimensions A from locating the
wall in plan view. See “No Locate” on

page 147.
e Select the Wall Type assigned to the
selected wall from the drop-down list.
A preview diagram of the selected wall

type’s layers, as seen in plan view, displays

below.

0 A preview of the selected wall,
including any doors, windows, and/or

fireplaces inserted into it, displays on the

right. If the selected wall is specified as

Invisible, its plan view will display here by

default. See “Dialog Preview Panes” on page
28.

Roof Panel

Any automatically generated roof style other
than a hip requires roof information to be
defined in the exterior walls. On the ROOF
panel, you can specify how the selected wall

interacts with the roof plan, defining the
portion of the roof plan that bears on it..

The ROOF panel is not available for
Foundation Walls. See “Foundation Walls”
on page 139.

r‘\ Wall Specification

General Roof Options o A A,
Roof ® Hip Wall i lZ‘
"'J:'t'eﬁzl‘;e””g O Full Gable Wl o
(O High Shed/Gable wal
) Knee wall
(O Extend Slope Downward
Pitch Options o
P ni2
[ Upper pitch
Upper Pitch: [ in 12
Start at Height: | 131 15/16
In From Baseline: |41
Overhang o

*

Cancel Help

Roof Options - Specify the shape of
the wall relative to the roof.

Check Full Gable Wall to create a gable
end over the selected wall.

* Check High Shed/Gable Wall to specify
the selected wall as the high end of a shed
roof.

¢ Check Knee Wall to define the selected

interior wall as a knee wall. Only an inte-



rior wall can be defined as a knee wall. A
knee wall’s height is defined by the roof
above, not the ceiling height. See “Knee
Walls” on page 153.

e Check Extend Slope Downward to con-
tinue a roof down over a bump out in an
exterior wall. See “Extend Slope Down-
ward” on page 152.

9 Pitch Options - Specify the pitch or
pitches of the roof plane(s) above the
selected wall.

» Enter a value to define the Pitch of the
roof plane bearing on the selected wall.

* Check Upper Pitch to create a roof with
two pitches or, if the selected wall is a
Full Gable Wall, a half hip condition.

* Enter the Pitch of the second, upper roof.

Wall Specification Dialog

» Specify the Height that the Upper Pitch
Starts at, or define the distance In from
Baseline that the second pitch begins. The
two values are dynamic. Press the Tab key
to update the relative numbers.

9 Specify the Overhang Length, which
is the horizontal distance from the
outside of the wall’s Main Layer to the eave.

See “Wall Type Definitions” on page 154.

0 A preview of the selected wall,

including any doors, windows, and/or
fireplaces inserted into it, displays on the
right. See “Dialog Preview Panes” on page
28.

iy Additional information about using the
@ settings on this panel can be found in

the “Roof Tutorial” on page 57 of the
Reference Manual.

Wall Covering Panel

The WALL COVERING panel is also available
in the Room Specification dialog. See
Room Specification Dialog.
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™ Wall Specification

Position

General Materials

Roof Wall Covering: 1: Tractor Print
Wall Covering

Materials Add New...

Top To Ceiling: |52 1/27

Floor To Bottom: [nter ar
wall Side: Interior
|:| Exterior

Replace... Delete o

Cancel Help

o All wall covering materials applied to
the selected wall are listed here. Select

one from the drop-down list to edit its

position or remove it from the wall.

* Click Add New to apply a new wall cov-
ering to the selected wall. See “Select
Library Object Dialog” on page 350.

+ Click Replace to replace the current wall
covering with a new one from the library.

* Click Delete to remove the current wall
covering from the selected wall.

Preview panes showing the current wall
covering display the row of buttons.

9 Specify the Position of the selected
wall covering.

* Enter the heights of the current wall cov-
ering’s Top To Ceiling and Floor To Bot-
tom. The wall covering’s Height from its
top edge to its bottom edge can also be
specified.

» Check Interior and/or Exterior to apply
the wall covering to the inside and/or out-
side of the selected wall. Interior is
checked by default. Not available for
rooms.

9 Most wall coverings are best previewed

using the Standard Rendering
Technique. See “Dialog Preview Panes” on
page 28.

Rail Style Panel

The RAIL STYLE panel is only available for
Railings and Half Walls. See “Rail Style
Panel” on page 159.

Newels/Balusters Panel

The NEWELS/BALUSTERS panel is only
available for Railings and Half Walls. See
“Newels/Balusters Panel” on page 161.



Materials Panel

All walls - including interior walls, railings -
have an “Exterior Wall Surface” and an
“Interior Wall Surface”. See “Interior and
Exterior Surfaces” on page 154.

The materials specified on the MATERIALS
panel affect the appearance of walls and
Solid Railings in 3D views but are not

Railing Specification Dialog

calculated in the Materials List. See
“Materials Lists” on page 437.

For most railing types, the “Exterior Wall
Surface” component only affects the
appearance of the floor platform under the
railing. and “Interior Wall Surface”
component is not used.

Railing Specification Dialog

I—l To open the Railing Specification
dialog, select a railing and click the
Open Object edit button.

The Railing Specification dialogs is the
same as the Wall Specification dialog, but
has two panels that apply only to Railings
and Half Walls. See “Wall Specification
Dialog” on page 154.

Rail Style Panel

The RAIL STYLE panel is only available for
Railings. See “Railing Tools” on page 137.

™ Railing Specification

General Railing Type
Roof (®) Balusters
Eael\lcviilf%alusters .-
Materials () Open
() Open with Middle Rai
() Panels
MewelsPosts
@ Post to Rail

O Post to Beam
(O Post to Ceiling
O Rail to Post
O Mo Post

Top/Bottom Rail
Indude Top Rail
Indude Bottom Rail

Raise Bottom:

*

L N

Cancel Help
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Railing Type - Select the radio button
for the desired railing type. A preview

of the selected type displays to the left.

12

Select Balusters to create regularly
spaced balusters between larger newel
posts.

Select Solid to create a solid railing or
Half Wall.

Select Open to create a railing with only
newel posts and top and bottom rails.

Select Open with Middle Rail to create a
railing with newel posts and top, bottom,
and middle rails.

Select Panels to create a railing com-
posed of panels.

Specify the properties of the selected
railing’s Newels/Posts.

Select Post to Rail to create newel posts
from the floor to the top rail. This option
is selected by default.

Select Post to Beam to create newel posts
from floor to a beam placed just under the
ceiling height. The beam’s width is based
on the Thickness of the selected railing
wall.

(3]

Select Post to Ceiling to extend the newel
posts to the ceiling.

Select Rail to Post to produce newel
posts of the Height specified on the NEW-
ELS/BALUSTERS panel, with rails that
build to the sides of the newels.

Select No Post to create no newel posts at
all.

The Top/Bottom Rail options control
the placement of the top and bottom

rail, or shoe.

(4]

Uncheck Include Top Rail to eliminate
the top rail.

Uncheck Include Bottom Rail to elimi-
nate the bottom rail and extend the balus-
ters to the floor. Not available for Solid
railings.

Check Raise Bottom, then specify the
Floor to Bottom distance, measured up
from the floor platform to the bottom rail
or panel.

A preview of the selected railing or
fence, including any doorways or gates

inserted into it, displays on the right. See
“Dialog Preview Panes” on page 28.



Railing Specification Dialog

Newels/Balusters Panel

™ Railing Specification

*
General Railing o N
- [
Roof Height:
Rail Style
Mewels/Balusters MewelsPosts o o
Materials width:  [41/2"
Type: Sguare Library...
Balusters o
Width: 11/2°
Type: Sguare Library...
Panels o
Thickness 2
Type: Solid Library...

Cancel Help

o Specify the height of the Railing.

* Specify the Railing Height. For interior
railings, this is measured from the height
of the floor finish.

9 Specify the characteristics of the
selected railing’s Newels/Posts.

* Specify the Width of each newel at its
widest point.

* Specify the Height, which is the height
from the floor or ground to the top of the
newel. Not available if Post to Rail, Post
to Overhead Beam or Post to Ceiling is
selected on the RAIL STYLE panel.

* Specify the on-center Spacing of the
newel posts.

» Type - Select Square, Round, or Library
newels.

Note: Selecting Library from the drop-down
list is the same as clicking the Library button
to the immediate right and allows you to
select a symbol from the library. See “Select

Library Object Dialog” on page 350.

e Specify the characteristics of the

selected railing’s Balusters. These set-
tings are only available when the railing type
is “Balusters”.

e Specify the Width or diameter of each
baluster at its widest point.

* Specify the on-center Spacing of the bal-
usters.

* Type - Select Square, Round, or Library
balusters.

0 Specify the characteristics of the
selected railing’s Panels. These settings
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are only available when the railing type is
specified as Panels on the RAIL STYLE panel.

* Specify the panel’s Thickness.

+ Select “Solid” or “Library” from the
Panel Type drop-down list.

~iv You can also apply newels, balusters,
@ and panels onto a railing directly from
the Library Browser. See “Inserted Objects”
on page 350.

e A preview of the selected railing or
fence, including any doorways or gates

inserted into it, displays on the right. See

“Dialog Preview Panes” on page 28.

Wall Hatch Specification Dialog

I—l To open the Wall Hatch Specification
dialog, select a Wall Hatch and click

the Open Object edit button. See “Hatch
Wall” on page 140.

™ Wall Hatch Specification X
Fill Pattern: Angle2 Hatch hd
Spacing: r e
[ Transparent Pattern Background
ricoe:
Preview Width: | 12° =
Cancel Help

* Choose a Fill Pattern from the drop-
down list. A preview of the selected pat-
tern displays to the right.

The options that follow are disabled until
you select a pattern other than None from
the Fill Pattern drop-down list.

» Define the Spacing for the selected fill
pattern. Hatch spacing set at 12" matches
grid/reference spacing set at 12".

* Check Transparent Pattern Fill to make
the fill pattern transparent. When you

check this option, any objects behind the
fill pattern are visible through it.

» Fill Color - Click the color bar to select a
color for the fill pattern lines or fill color
if a solid fill is specified. This overrides
the layer color. See “Select Color Dialog”
on page 90.

* Choose a Preview Width from the drop-
down list. This value controls how large
an area the preview represents. The
selected value indicates the length of each
side of the preview in plan inches (mm).




When walls or railings create an enclosed
area, a “room” is created. You can select
rooms defined in this manner like other
objects in Home Designer Interiors.

Rooms are assigned a Room Type. Each
Room Type has predefined characteristics.
For example, a room defined as Porch is
assigned certain attributes that are different
than a Kitchen.

Floor and ceiling heights, baseboard, chair-
rail, and crown moldings and materials can
be defined room-by-room or for the entire
floor.

Rooms

Chapter Contents
*  Room Definition
*  Floor and Room Defaults
*  Room Types
» Displaying Rooms
*  Selecting Rooms
«  Editing Rooms
*  Room Types
*  Room Labels
*  Decks
*  Floor and Ceiling Heights
»  Stepped Floor and Ceiling Platforms
*  Special Ceilings
*  Room Specification Dialog

Room Definition

A room is a totally enclosed area defined by
any combination of joined walls or railings,
visible or invisible. To be recognized as a
room by Home Designer Interiors, a room
must have an unbroken perimeter.

Unless otherwise specified, rooms generate
floor and ceiling platforms automatically.
Most rooms are also automatically covered

by the roof when one is built. There are
exceptions to this, such as rooms defined as
Decks. See “Room Types” on page 165.

If a room is drawn within a larger structure
and none of its walls connect to the exterior
walls, either directly or indirectly by
connecting to walls that do, it is referred to as
an “island” room. The program will connect
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such a room to the larger structure with an
Invisible Wall. See “Room Dividers and
Invisible Walls” on page 139.

Room definition disappears if part or all of a
surrounding wall is deleted. It is a good idea
to finalize the position of walls before
specifying Room Types or defining room
attributes such as floor or ceiling height.

Subdividing Rooms

When a room area is first defined, it inherits
its characteristics from the Floor Defaults
dialog for that floor. If the room is then
specified as a particular type, it may inherit
properties from the Room Defaults dialog
associated with its type.

If a new room is created by subdividing a
larger room, it inherits its characteristics
from that larger room - including any non-
default settings.

If two rooms are separated by an Invisible
wall, their interior areas will be measured
from the wall’s centerline and characteristics

like the floor finish materials and moldings
will break along that line.

» If the two rooms have different floor
heights, the break will occur at the wall
edge that faces the room where the floor
is lower.

» If the two rooms have different ceiling
heights, the break will occur at the wall
edge that faces the room where the ceiling
is higher.

Copying and Pasting Rooms

A room can be copied into the same or a
different plan by copying and pasting the
walls that define it. Rooms copied in this
manner retain their size and shape, as well as
any finish materials assigned to the walls.
See “Copying and Pasting Objects” on page
81.

If you want to retain the room’s Type and
other specifications, copy and paste it and the

walls that define it using the Edit Area -
tools. See “Edit Area” on page 96.



Floor and Room Defaults

Floor and Room Defaults

@ Select Edit> Default Settings to open

the Default Settings dialog, then click
the arrow to the left of “Floors and Rooms”
to expand the category. Here, you can access
several defaults dialogs which directly affect
rooms. Select a line item and click the Edit
button to open the defaults dialog associated
with it.

Current Floor Defaults

Many important default values that affect
rooms are specified in the Floor Defaults
dialog for each floor in a plan. This dialog
controls important information that the
program uses to create a 3D model -
particularly floor and ceiling heights and
materials. Moldings can also be specified in
the Floor Defaults dialog.

Only the defaults for the first floor of a
building can be set ahead of time. The
program uses the setting from the first floor
to create subsequent floors. Once a new floor
is created, its floor defaults can be changed.
See “Floor Defaults Dialog” on page 288.

Floor 1 Default Height

Home Designer Interiors always defines the
default height of Floor 1 at 0°-0”. This height

value is measured from the top of the
subfloor and is the constant by which the
heights of structural elements in the program
like walls, floors, and ceilings are measured.
The heights of architectural objects can be
measured relative to this absolute height, as
well. As such, this default cannot be
changed.

Room Type Defaults

™ Room Types *

Available Room Types

iAttic ) Edit...
Balcony
Bath Rename...

Bedroom

Closet

Court

Deck

Dining

Dressing

Entry

Family v

Cancel Help

The settings in the Room Type Defaults
dialogs allow you to specify the floor and
ceiling finish materials for each Room Type.

Room Types

Room Types are used to quickly apply useful
structural, functional, and appearance
properties to different kinds of rooms. For
example, a room assigned the “Garage”
Room Type will receive concrete curbs under

its walls when the Foundation is built, while
a “Kitchen” will get GFCI Outlets when the
Auto Place Outlet tool is used.

When a room is first created by enclosing an
area with walls, it is assigned a generic room
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type of “Unspecified.” Once a room is
created, though, it can be assigned a Room
Type in the Room Specification dialog. See
“General Panel” on page 177.

Available Room Types

There are three broad categories of room
Types: Interior, Exterior and Hybrid.

Interior - Living, Dining, Family, Kitchen,
Nook, Bath, Master Bath, Master Bedrm,
Bedroom, Study, Office, Entry, Hall, Closet,
Dressing, Storage, Laundry, Utility and
Unspecified.

Exterior - Court, Deck, Balcony.

Hybrid - Open Below, Garage, Slab, Porch,
Attic.

Effects of Room Types

Home Designer Interiors applies specific
properties to rooms depending on the
assigned Room Type.

Living and Conditioned Areas

* All interior type rooms are included in
Living Area calculations by default; exte-
rior and hybrid type rooms are not.

* With the exception of Unspecified rooms,
all interior type rooms are included in
Conditioned Area calculations. Open
Below rooms are also included; however,
exterior and other hybrid type rooms are
not. See “Conditioned Area Totals” on
page 442.

Ceilings and Roofs

* Interior rooms have a ceiling and roof
above them.

» Exterior rooms are assumed to be open to
the outside and do not generate a roof
above them.

e Attic rooms do not receive a ceiling and
are ignored by the program’s automatic
roof generator.

* Garage, Slabs, and Porches are treated
like exterior rooms in all cases except that
they generate a ceiling and a roof above
them by default.

Floors and Foundations

e Open Below is a unique type of interior
room. It has no floor platform and can be
used for defining stairwell openings.

* Garages have a foundation under them
with a concrete slab at the top of stem
wall or grade beam.

* The floor in Garage and Slab rooms dis-
play in 3D on Floor 0, not the first floor.
See “Garages” on page 282.

* Aroom’s default floor structure and finish
definitions are determined by its Room
Type. See “Room Type Defaults” on page
165.

* Courts, Decks and Balconies do not gen-
erate foundations.

Doors and Windows

* A window placed in a wall between an
exterior room and an interior room always
faces out toward the exterior.

* Doors placed between interior and exte-
rior type rooms inherit their settings from
the Exterior Defaults for the door tool, if
available; they display threshold lines and
are considered Exterior. See “Interior vs
Exterior Doors” on page 209.



» Doors placed between interior type rooms
do not display thresholds and are consid-
ered Interior.

* Open Below rooms are treated as interior
rooms for window and door placement.

Electrical

* Any outlet manually placed in an exterior
room automatically becomes a waterproof
outlet designed for exterior use.

Displaying Rooms

Trim and Molding

* Moldings are not automatically added to
exterior or hybrid rooms.

» Baseboards and chair rails are not auto-
matically added to Open Below rooms,
but crown molding, if specified in the
Floor Defaults dialog, is.

Displaying Rooms

Unlike most things in Home Designer
Interiors, a room is not an individual object.
Rather, a room is defined by the walls that
enclose it.

In Plan Views

Rooms typically display a transparent fill in

floor plan view. You can, however, specify a
solid color or fill pattern for individual rooms
in the Room Specification dialog. See “Fill

Style Panel” on page 182.

In order for room fill styles to display, the
“Rooms” layer must be turned on. See
“Layer Attributes” on page 87.

Room labels that include the room’s name as
well as its size and other information can be

set to display in floor plan view. See “Room
Labels” on page 170.

In 3D Views

Rooms can be viewed in views created by
any of the 3D view tools. The Dollhouse
View tool can be used to see all rooms on the
current floor without their ceilings. See
“Creating Overviews” on page 384.

In the Materials List

The contents of a room, including
furnishings and floor and ceiling materials
can be calculated using the Calculate From
Room tool. See “To create the Materials List
for a room, select the room and then select
Tools> Calculate Materials for Room.” on
page 438.

Selecting Rooms

Room definition is established when a room
is completely enclosed by walls. You can
confirm that a room has room definition by

using the Select Objects | tool to select it.

When a fully-enclosed room is selected, its
interior space becomes highlighted. See
“Selecting Objects” on page 94.
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BEDROOM
0 A2

Theroom at l€ft is selected
The Exterior Room

Each floor level of a plan has an Exterior
Room, which allows you to control its
exterior wall coverings and materials in the
Exterior Room Specification dialog. See
“Room Specification Dialog” on page 176.

To select the Exterior Room in plan view,
click just outside an exterior wall using the

Select Objects || tool. If a wall or other
object becomes selected instead, click the

Select Next Object e edit button or press
the Tab key until the Exterior Room becomes
selected. The Status Bar indicates which
object is currently selected. See “The Status
Bar” on page 29.

KITCHERM
0 A2

BEDROOM
0 A2

The Exterior Roomis selected

When it is selected, a highlighted band
around the plan’s exterior displays.

In 3D Views
A room can be selected in a 3D view by
clicking on an empty space on its floor or a

wall surface while the Select Objects | =
tool is active.

If you select a wall or other object instead of

the room, click Select Next Object idex edit
button or press the Tab key until the room
becomes selected.

In exterior camera views and overviews, the
Exterior Room for each floor can be selected
by clicking on the exterior surface of an

exterior wall using the Select Objects |
tool and then clicking the Select Next

Object e edit button.

Editing Rooms

A room’s structure and appearance can be
modified using its edit tools and specification

dialog. Rooms can be selected in all views,
and the ways in which they can be edited



depend somewhat on the current view. See
“Selecting Rooms” on page 167.

In 3D Views

The floor and ceiling heights of individual
rooms and entire floor levels can be edited
using edit handles in 3D views. Lowered
ceilings cannot be edited in 3D. See “3D
Views” on page 381.

The default floor and ceiling heights for an
entire floor level can be edited by selecting
the Exterior Room. See “Floor and Room
Defaults” on page 165.

To change default ceiling heightsin 3D

1. Create a 3D view of the exterior of your
plan.

2. Click on the exterior surface of a wall,

then click the Select Next Object ex
edit button.

3. When the Exterior Room is selected in
3D:

 The wall that you clicked on remains
highlighted and an edit handle displays
along its top edge.

* When the wall is on any floor other
than Floor 1, an edit handle also dis-
plays along its bottom edge.

* A bounding box displays around each
wall of the selected floor level.

 The Status Bar says “Exterior Room”.
See “The Status Bar” on page 29.

* A temporary dimension will display,
measuring from the floor’s default
rough floor to default rough ceiling.

Editing Rooms

Click and drag the edit handle on the top
wall edge to adjust the default ceiling
height, or the edit handle on the bottom
edge to adjust the default floor height.

As you drag a handle, notice that the
entire floor level is affected.

Note: Any rooms that do not update when the
default floor or ceiling height is changed are
not using the default values. To use the
default values for a specific room, check
Default for any of the room height values in
its specification dialog. See “General Panel’
on page 177.

See “Temporary Dimensions” on page
188.

To adjust room heightsin 3D

Create a 3D view of your plan.

Click on the surface of a wall that faces
a room to select it, then click the Select

Next Object /e edit button.

When a room is selected in 3D:

* The wall that you clicked on remains
highlighted and an edit handle displays
along its top and bottom edges.

* The Status Bar says “Room”.

* A temporary dimension will display in
elevation views, and measure from the
room’s rough floor to rough ceiling.

Click and drag the edit handle on the top
wall edge to adjust the room ceiling
height, or the handle on the bottom edge
to adjust its floor height. Temporary
dimensions display.

As you drag a handle, notice that all
walls defining that room are affected.

Room materials such as floor, ceiling, and
wall materials can be changed in 3D views
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using the Material Painter "B See “The
Material Painter” on page 369.

Room moldings can be replaced directly
from the library in 3D views, as well. See
“Replace From Library” on page 351.

In the Specification Dialog

I—l Floor and ceiling heights, moldings,

wall coverings, and materials can all
be specified in the Room Specification
dialog. See “Room Specification Dialog” on
page 176.

Using the Edit Tools

A selected room can be edited using the edit
toolbar. See “The Edit Toolbar” on page 24.

» Click the Calculate Materials for

Room edit button to create a materi-
als list of the contents of the selected
room, not including walls. See “To create
the Materials List for a room, select the
room and then select Tools> Calculate
Materials for Room.” on page 438.

« Click the Auto Interior Dimensions |/
edit button to generate interior dimen-
sions that measure each wall defining the
selected room(s). See “Auto Interior
Dimensions” on page 187.

Room Labels
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A label can display in floor plan view for any
area defined as a room. There are two parts
to each room label:

* The Room Name, which is similar to a

Text | T object and can be selected and
edited. See “The Text Tools” on page 197.

* The room area, which is not a standard
text entry and cannot be directly edited.

You can assign a custom Room Name, move
aroom label or even delete it without
affecting the Room Type. See “Room Types”
on page 165.

E Room labels can move or even disap-
pear when room entries are revalidated.

Displaying Room Labels

The display of room labels is controlled in
the Display Options dialog. Room labels are
placed on the “Rooms, Labels” layer and use
the Text Style assigned to that layer. See
“Display Options Dialog” on page 88.

You can specify how the area of rooms is
reported by the program by turning on the
display of one or more of these layers:

* Rooms, Standard Area is measured from
the center of interior walls that define the
room and from either the outside surface
or outside of the Main Layer of exterior
walls, depending on the Living Area to
setting in the General Plan Defaults dia-
log. It is rounded to the nearest square
foot or mm and does not include the area
within bay, box and bow windows. See
“Exterior and Interior Walls” on page 138



and “General Plan Defaults Dialog” on
page 56.

* Rooms, Interior Area is measured from
the inner surfaces of all the room's walls.

* Rooms, Interior Dimensions is also
measured from the inner surfaces of the
room walls.

The display of room labels can also be
controlled on a room by room basis in the
Room Specification dialog. See “General
Panel” on page 177.

Editing Room Labels

Room labels are similar to simple Text | T
objects and can be moved and resized much
like any other text object. You can also
modify a room label’s Text Style and other
attributes in the Room Label Specification
dialog.

The text of a room label cannot be modified
in its specification dialog, however: it must
be specified in the Room Specification
dialog. See “General Panel” on page 177.

If you delete a room label, the Room Type
and Room Name remain unchanged in the
Room Specification dialog. To restore the
label, check the Show Room Label
checkbox on the GENERAL panel of that
dialog.

Room Area

Unlike the rest of a room label, the room area
and dimensions are not standard text entries
and cannot be edited or changed. The room
area moves, resizes and rotates with the rest
of the room label, but you can turn the area
and dimensions on or off separately in the

Room Labels

Display Options dialog. See “Displaying
Rooms” on page 167.

The Interior Area room area calculation
includes the areas within bay, box or bow
windows, while the Standard Area and
Interior Dimensions calculations do not.

Living Area

The Living Area label is an automatically
generated Text object that reports the area of
the current floor specified as living space. By
default, Interior Rooms are defined as part of
the Living Area, while Exterior and Hybrid
Rooms are not. See “Available Room Types”
on page 166.

Regardless of its Room Type, you can
specify whether any room is included in the
Living Area Calculation in the Room
Specification dialog. See “General Panel”
on page 177.

A Living Area label is created as soon as a
room area is defined by walls and/or railings
and is recalculated every time you add,
remove, resize, or redefine a room. If
multiple buildings are created, each will have
its own Living Area label. If none of a
structure’s rooms are included in the Living
Area Calculation, however, no Living Area
label will display for it.

Each Room Area label can be edited in its
specification dialog. If a new floor is added,
however, any existing Living Area labels
will be deleted and replaced. See “Text
Specification Dialog” on page 201.

To turn off the display of all Living Area
labels in a plan, uncheck Show Living Area
Label in the General Plan Defaults dialog
or turn off the “Room Labels” layer in the
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Display Options dialog. See “General Plan
Defaults Dialog” on page 56.

Living Area vs. Footprint

The Living Area should not be mistaken for
the footprint of a house. Only true livable
areas are included in the Living Area
calculation. By default, exterior and hybrid
room types such as Garage, Deck, and Porch
are not included. Neither is any room labeled

Open Below or Attic. See “Available Room
Types” on page 166.

Regardless of its room type, you can specify
whether a room is included in the Living
Area calculation in the RoomSpecification
dialog. See “General Panel” on page 177.

Living Area is measured from either the
outside surface or the outer surface of the
structural layer of exterior walls.

Decks

A Deck room is an exterior-type room that
uses deck planking and framing to create a
floor platform rather than using a single floor
surface that spans the entire room area.

To draw a deck, select Build> Wall> Railing

[T, then click and drag to draw a railing.
Once room definition is established, the area
defined by the railing can be assigned the
“Deck” room type.

You can define a room as a “Deck” in the
Room Specification dialog. See “General
Panel” on page 177.

By default, decks do not have roofs. If you
want a roof over a deck, check Roof Over
This Room in the Room Specification

dialog. See “Structure Panel” on page 178.

To give the roof a visible means of support,
you can select the Post to Beam option in the
Wall Specification dialog. See “Rail Style
Panel” on page 159.

Openings in deck railings can be created

using Doorways "—. See “Openings in
Railings” on page 218.

Deck Framing and Planking

When a Deck room is created, the floor
platform is modeled using joists, beams,
posts, and planking.

Deck framing, planking, posts, and beams
are placed on their own layers with names
that begin with “Framing, Deck”: for exam-
ple, “Framing, Deck Posts”. These layers
cannot be turned on in floor plan view but are
shown in 3D views.

Floor and Ceiling Heights
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Default floor and ceiling heights are defined
in the Floor Defaults dialog for each floor,
including the foundation. Use the Floor

Defaults dialog to change these values on a
floor-by-floor basis. See “Floor and Room
Defaults” on page 165.



Use the Room Specification dialog to set
floor heights on a room-by-room basis. See
“Room Specification Dialog” on page 176.

Different rooms on the same floor can have
unique floor and ceiling heights, allowing
you to create:

* Split levels and bi-levels
* Sunken living rooms and garages

* Cathedral and coffered ceilings.

In 3D views, you can adjust the default floor
and ceiling height for the entire floor or the
floor and ceiling height for an individual
room. See “In 3D Views” on page 169.

In order to raise or lower an area’s floor or
ceiling height, you must give it a room
definition. To create room definition without
enclosing an area with solid walls, use

Railings .

Ceiling and floor heights are interrelated.
Changing the floor height in one room can
affect ceiling heights of the rooms below.

» Ifaroom’s floor is lowered, its ceiling
height is increased while the ceiling
below that room drops.

Floor and Ceiling Heights

» Ifthe floor is raised, the ceiling height
decreases while the ceiling below that
room is raised.

If the rooms above a particular room have
more than one floor height, the room’s
ceiling is stepped.

In a situation like this, a Lowered Ceiling can
be used to cover “steps” made by different
floor heights on the floor above. See
“General Panel” on page 177.

To ensure that steps in floor and ceiling
platforms have solid sides, define their room
areas using Invisible Railings.

Shelf Ceilings

In rooms with high or vaulted ceilings, it is
possible to have a smaller room such as a
closet that has a flat, lower ceiling. By
default, the area above the flat ceiling will be
enclosed by automatically-generated Attic
walls. See “Attic Walls” on page 153.

If you prefer, you can specify that these Attic
walls be suppressed and an open space be
created instead. This condition is referred to
as a Shelf Ceiling, or plant shelf, and can be
specified in the Room Specification dialog
of the room with the lower flat ceiling. See
“Structure Panel” on page 178.
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Split Levels

A split level can be created by raising or
lowering the floor and ceiling heights of
various areas of the plan.

In the following example, the lowest floor
height is 0, the next is 24, and the next is 48
inches. The ceiling height in each room is set
at 109 inches. See “Split Levels” on page
291.

Stepped Floor and Ceiling Platforms

Each floor has default floor and ceiling
heights. You can, however, use the Room
Specification dialog to specify floor and
ceiling heights on a room by room basis to
create stepped floors and ceilings. See
“Structure Panel” on page 178.

If you require a single floor platform with a
uniform height and thickness but different
ceiling heights for the rooms below, specify a
lowered ceiling using the Ceiling Finish
Specification dialog. See “Lowered
Ceilings” on page 174.

Special Ceilings

174

By default, the program builds a flat ceiling
platform on top the wall plates of a room.
More varied and complex ceilings are made

using settings in the Room Specification
dialog.

Lowered Ceilings

You can define a lowered or dropped ceiling
in a room without affecting the top height of
the walls by increasing the thickness of the
Ceiling Finish.

In the following illustration, the default
ceiling height for the entire first floor is 120",
and the room on the right has a ceiling finish
lowered to 96".



Normal ceiling Lowered ceiling

To create a lowered ceiling

1.

Select the room in which you would like
to specify a lowered ceiling.

Special Ceilings

Click the Open Object ¥/ edit button
to open the Room Specification dialog.

On the STRUCTURE panel, increase the
Ceiling Finish value by the amount that
you would like to lower the ceiling.

Notice that the preview diagram repre-
sents the Finished Ceiling height (F).

Cathedral Ceilings

A cathedral ceiling has the same pitch as the
roof and is created using the underside of the
roof above the room.

To create a cathedral ceiling

1.

Build a roof for your plan. See “Roofs”
on page 321.

Select the room and open the Room
Specification dialog. See “Room Speci-
fication Dialog” on page 176.

On the STRUCTURE panel, uncheck Flat
Ceiling Over This Room.

Trey Ceilings

A trey ceiling is an area within a ceiling that
is raised and has either vertical or sloping
sides. A standard trey ceiling can be easily
created by placing Soffits around the

perimeter of the room. An angled trey ceiling

can be created using the underside of roof
planes above.

To create a angled trey ceiling

In the Room Specification dialog, make
sure that Flat Ceiling Over this Room
is checked, then specify the desired
height of the walls as the Ceiling
Height. See “Structure Panel” on page
178.
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2. Make sure that Auto Rebuild Roofs is
unchecked, then build the roof. See
“Build Roof Dialog” on page 323.

3. Change the Ceiling Height of the room
to the desired height of the flat ceiling
surface in its center.

In floor plan view, dashed lines indicate
where the ceiling changes from sloped to
flat. These lines are located on the “Ceiling
Break Lines” layer in the Display Options
dialog. See “Display Options Dialog” on
page 88.

\ NN
T

If the roof is rebuilt after the ceiling height is
adjusted upward, the new roof will be raised
to match the new ceiling height and a trey
ceiling will not be created.

In the following example, a hip roof is built
on 8’ (2400 mm) ceilings. After the roof is
built, the Ceiling Height is raised to 10’
(3000 mm). The resulting ceiling follows the
roof pitch for 2’ (600 mm), then becomes a
flat ceiling.

Hip roof with
cathedral ceiling over.

Hip roof, ceiling over,
ceiling height raised.

Ceiling Break linesin
floor plan view.

Cantilever Undersides

Occasionally, a room will cantilever out past
an exterior wall. You can specify the surface
material of the underside of a cantilever on

the MATERIALS panel of the Room
Specification dialog. See “Room
Specification Dialog” on page 176.

Room Specification Dialog
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I—l The Room Specification dialog

controls the structural characteristics
and appearance of a selected room. To open
the Room Specification dialog, select a
room and click the Open Object edit button.
See “Selecting Rooms” on page 167.

Some of the panels in this dialog are also
found in the Exterior Room Specification
dialog as well as in the Floor and Room
Type Defaults dialogs. See “Floor and Room
Defaults” on page 165.

Some values in this dialog are dynamic. A
value with Default checked references the



Floor Defaults dialog. To return a value to
the default, replace the check mark. See

Room Specification Dialog

The settings in this dialog are similar to those
in the Floor Defaults dialog, but affect only

“Dynamic Defaults” on page 55.

the selected room See “Floor Defaults
Dialog” on page 288.

General Panel

™ Room Specification

General General

Living Area

Structure Room Type: | Unspecified
Moldings
oom Mame= [Unsseahed
Wall Covering Room Name: |Unspedfied
Fill Styl
I t}r N [[] show Room Label
Materials

(O Indude in Total Living Area Calculation
(O Exdude from Total Living Area Calculation
(® Use Default (Induded)

*

Use Default

Cancel Help

The settings here control the Room
Type and the appearance of the Room

Label

Select the Room Type. Changing the
Room Type can affect settings throughout
the dialog. See “Room Types” on page
165.

Click the Define button to open the Room
Types dialog where you can customize
the settings of the selected Room Type.

In the Room Type Defaults dialog only,
the Function of the selected room type
displays for reference. See “Available
Room Types” on page 166.

If you wish to use a custom name in the
room label, uncheck Use Default, then
specify the desired Room Name in the
text field.

Check Show Room Label to display the
room label in floor plan view. See “Room

(2]

Labels” on page 170.

This option is unchecked automatically if
you select “Unspecified” as the Room
Type, and checked automatically if you
select any other Room Type

Specify whether the selected room is
included in the Living Area

calculation. See “Living Area” on page 171.

Select Include in Total Living Area Cal-
culation to include the room in the Living
Area regardless of its Room Type.

Select Exclude from Total Living Area
Calculation exclude the room from the
Living Area regardless of its Room Type.
Select Use Default for Room Type
(Included/Excluded) to base the selected
room’s inclusion in the Living Area on its
Room Type. The default for the selected
Room Type is stated in parentheses.
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Structure Panel

Some settings on the STRUCTURE panel are
also found in the Floor and Room Type
Defaults dialogs.

This panel features a cross section diagram
showing the relationships between its various
heights and platform thicknesses. It is meant
to represent the relationships between
heights and thicknesses rather than provide a
scaled drawing of the model.

Two floors can be included in the diagram:
the floor that the selected room is located on,
and the floor below it, if one exists.

What appears in both the diagram and in the
settings to its left may be affected by the
location where you clicked to select the
room. For example:

» Ifthe selected room is located above two
rooms with different structural settings,
the position of the pointer relative to these
two lower rooms determines which of
them displays as the floor below.

» If the selected room is located below two
rooms with different floor heights, its
absolute and relative ceiling height set-
tings will be disabled.

™ Room Specification

General Absolute Elevations
Structure Floor Above (A):
Moldings -

Wall Covering Ceiling (B):

Fill Style Floor (C):
Materials

Relative Heights

ST T

Stem Wall (I):

SWT = Stem Wal

Ceiling

Ceiling Structure: 5 1/2°

Floor
Floor Finish (K):
Floor Structure (L): 12 5/8"

121 3/4" Default -
109 1/8" Default o

Rough Ceiling (E):  |109 1/8" Default
Finished Ceiling (F): |107 5/8" Default ‘
P Py "

: 3312 Default
37 12" Default
Top

Roof Over This Room

Flat Ceiling Over This Room
[ shelf Ceiling

[ Use Soffit Surface for Ceiling

Ceiling Finish (1): Default

Defal

— 4

Cancel Help




Check the Default box beside any height
value to restore the default setting.

Note: Many of the settings on this panel are
interdependent. For example, if the Ceiling
Finish thickness is modified, the Finished
Ceiling height will change in response.

Absolute Elevations - These height
values are measured from zero, which

is the default top height of the subflooring on
Floor 1. See “Floor and Ceiling Heights” on
page 172.

The Floor Above height displays here for
reference. If multiple rooms with differ-
ing floor heights are present directly
above, “No Change” will display.

Specify the Ceiling height of the selected
room, as measured from zero to the bot-
tom of the ceiling framing. Not available
in the Floor Defaults dialog on Floor 0, or
if multiple floor heights are specified
above the selected room.

Specify the Floor height, as measured
from zero to the top of the subflooring.

Note: The default floor height for Floor 1 is 0.
It can be modified in the Room Specification
dialog, but not in the Floor 1 Defaults dialog.
See “Floor and Room Defaults” on page 165.

If a room is defined directly beneath the
selected room on the floor below, additional
settings may be available.

Specify the Floor Below height, which is
the subfloor height of the room directly

below where you clicked to select the cur-
rently selected room. If there are multiple
rooms with differing floor heights located

(2]

Room Specification Dialog

below, this value may change depending
on where you click.

If the selected room is directly above a
Garage and there is a foundation present,
you can specify the SWT Below height,
which is the top height of the concrete
stem walls around the perimeter of the
garage.

Relative Heights - These height values
are measured from surfaces within the

selected room or the room below.

Specify the Rough Ceiling height, as
measured from the subfloor surface to the
bottom of the ceiling framing. Not avail-
able if multiple floor heights are specified
directly above the selected room.

Specify the Finished Ceiling height, as
measured from the finished floor surface
to the finished ceiling surface. Not avail-
able if multiple floor heights are specified
directly above the selected room.

Specify the distance from the Stem Wall
Top to Ceiling. Only available when
Floor for this Room is Supplied by the
Foundation ‘Room’ from the Floor
Below has been checked.

Specify the Ceiling Below height, which
is the height of the ceiling of the room
below, as measured from that room’s sub-
floor to rough ceiling surfaces. Not avail-
able when Auto Rebuild Foundation is
enabled or if there is no room below the
selected room. See “Rebuilding Founda-
tions” on page 280.

Specify the Stem Wall height, which is
measured from the top of the foundation
wall footing to the top of the treated sill
plate, if one is specified. Only available if
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the selected room or the room below it is
defined by foundation walls.

9 A cross section diagram showing the

relationship between the various height
settings displays here for reference.

o Specify the characteristics of the

room’s Ceiling.

« If Roof Over This Room is checked, a
roof automatically generates over the
room. If unchecked, no roof generates.

+ If Flat Ceiling Over This Room is
checked, the room has a flat ceiling. If

unchecked, the ceiling follows the under-
side of the roof.

* Check Shelf Ceiling to prevent Attic
Walls from generating over the interior
walls that define the selected room. When
unchecked, interior Attic Walls will gen-

erate if surrounding rooms have higher
ceilings than the selected room. See
“Shelf Ceilings” on page 173.

¢ Check Use Soffit Surface for Ceiling to
improve the 3D appearance of the transi-
tion between ceiling and eaves of exterior
rooms with Flat Ceiling Over This Room
unchecked.

* The thickness of the Ceiling Structure
displays here for reference but cannot be
changed.

» Specify the thickness of the Ceiling Fin-
ish layer.

(5]

¢ The thickness of the Floor Structure dis-
plays here for reference but cannot be
changed.

Specify the thickness of the Floor Fin-
ish layer.

Moldings Panel

Chair rail, crown and base moldings can be
assigned to a selected room on the MOLD-
INGS panel. Moldings are placed around the
wall surfaces of a room and continue around
the surface of any soffit that is attached to the
wall at the molding height.

The settings on the MOLDINGS panel are
similar to those found in other specification
dialogs.

The settings on this panel are also similar to
those found in the Floor Defaults dialog, but
affect only the selected room instead of all
rooms on the current floor.

The MOLDINGS panel is also found in the
Cabinet and Soffit Specification dialogs.
See “The Cabinet Tools” on page 248.



Room Specification Dialog

r\ Room Specification
General [] Use Floor Default
Structure
Moldings Molding Profiles
Wall Covering Selected Profile: | 1@ Default Base Molding ~
Fill Style
Materials Add New...
Replace...
Delete
Selected Profile Spedfication
Height: 32"
weth
|:| Retain Aspect Ratio
Type: Base Molding
Selected Profile Offset
O To Top
@ To Bottom
Mumber Style. ..

X
(14
[ 2]

Default Base Molding

Cancel Help

Uncheck Use Room Default to enable

the settings that follow. When checked,
the room uses the default moldings set in the
Floor Defaults dialog. See “Floor Defaults
Dialog” on page 288.

e Specify the Molding Profiles assigned

to the selected room. The Default Base
Molding is a basic rectangular stock profile
rather than a profile from the library.

* The Selected Molding displays at the top
of the drop-down list. Click the arrow to
see all moldings currently applied to the
selected room.

* Click the Add New button to open the
Select Library Object dialog and select a
new molding profile to apply to the room.
See “Select Library Object Dialog” on
page 350.

* Click the Replace button to replace the
currently selected molding with a
different molding profile.

e Click the Delete button to remove the
currently selected molding from the room.

e Selected Molding Specification -
Make changes to the currently selected
molding.

» Specify the Height and Width of the
currently selected molding.

*  When Retain Aspect Ratio is checked, if
you change either the Height or Width,
the other value changes to maintain their
original ratio. When this is unchecked, the
two values can be edited independently.

Select the currently selected molding’s
Type from the drop-down list: Base,
Chair Rail, or Base Molding.
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o Selected Profile Offset - Specify the

distance of the selected molding From
Floor and select whether this distance is
measured To Top or To Bottom of the
molding profile.

Wall Covering Panel

The settings on the WALL COVERING panel
of the Room Specification dialog are the
same as those on the same panel of the Wall
Specification dialog. When a wall covering
is assigned in the Room Specification
dialog, it is applied to all walls in the selected
room only. See “Wall Covering Panel” on
page 157.

~+ Wall coverings can be applied to exte-

@‘ rior rooms as well by selecting the exte-
rior room and opening it for specification. See
“Selecting Rooms” on page 167 for informa-
tion about selecting exterior rooms.

Fill Style Panel

The settings on the FILL STYLE panel affect
the appearance of the room in floor plan
view. This panel is also found in the Floor
Defaults dialog. For more information, see
“Fill Style Panel” on page 131.

Materials Panel

The settings on this panel affect the
appearance of a selected room’s walls, floor,
ceiling, and moldings in 3D views. See
“Materials Panel” on page 372.

Default molding and ceiling and floor
covering materials can be set on this panel in
the Floor Defaults and Room Defaults
dialogs.



Chapter 13:

Dimensions

Home Designer Interiors provides a variety
of dimensioning tools for measuring walls,
doors, windows, and many other objects.

Dimensions can be used to accurately
position objects relative to other objects. In
addition, dimension lines and extensions can
be selected and customized.

Chapter Contents
. Dimension Unit Defaults
. Dimension Defaults Dialog
. The Dimension Tools
. Displaying Dimension Lines
. Editing Dimension Lines
. Editing Extension Lines
. Moving Objects Using Dimensions
. Dimension Line Specification Dialog

Dimension Unit Defaults

All plan files save measurements in either
Imperial or metric units. The type of unit
used is determined when the file is first

created and cannot be changed later. See
“Creating a New Plan” on page 38.

Dimension Defaults Dialog

@ Select Edit> Default Settings, select

“Dimension”, and click the Edit
button to open the Dimension Defaults
dialog.

The settings in this dialog are dynamic
defaults, which means that any changes

made here may affect existing dimension
lines in the drawing that are using default
values. See “Dynamic Defaults” on page 55.
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Setup Panel

|-\ Dimension Defaults

Setup General
Format Auto Refresh Exterior Dimensions
Arrow
Text Style Locate Wall Dimensions At
() surface

(® Main Wall Layer

@ O 0O

Locate Interior Wall Dimensions At
O Center
(® Both Wall Sides

Cancel Help

Uncheck Auto Refresh Exterior

Dimensions to prevent Auto Exterior
Dimensions from being regenerated as
changes are made to the plan. When checked,
Auto Exterior Dimensions will be created
when walls enclose a room area and will
refresh whenever walls, doors, or windows H H
are added or moved. See “Auto Exterior
Dimensions” on page 187. Dimensions locating walls' Main Wall Layers

=49 5/8" ——=

9 Specify how Manual and Auto Exterior
Dimension lines locate both interior 9
and exterior walls.

Specify how Manual and Auto Exterior
Dimension lines locate interior walls.

» Select Centers to have exterior dimen-

*  Select Surfaces to have dimensions sions locate the centers of interior walls.

locate the outer surfaces of walls.

2-4 13186" | 24 13A186"

5|

Dimensions locating an intersecting wall’s center

Dimensions locating wall Surfaces
* Select Both Wall Sides to have dimen-

*  Select Main Wall Layer to have dimen- sions locate both sides of interior walls.
sions locate the structural layer of exte- Either the wall Surfaces or both sides of
rior walls.
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the Main Wall Layers will be located,
depending on your selection above.

2-3 116" 2-3 116"

Dimensions locating an interior wall’s
Main Wall Layer

Dimension Defaults Dialog

You can always change the object or surface
that a dimension locates after it has been cre-
ated. See “Editing Extension Lines” on page
191.

Format Panel

The settings on the FORMAT panel allow you
to specify the units, position, and degree of
accuracy of dimension numbers. The settings

on this panel also control the format of object
length numbers in the Status Bar. See “The
Status Bar” on page 29.

r\ Dimension Defaults

Setup
Format
Arrow

Format

Units: |'-"

Accuracy

Dimension Text Position

Text Style Unit Indicators
[ Leading Zeroes
[ Trailing Zeroes

O Decimal Places: .

® smallest Fraction: 1/

@ Centered on Dimension Line
(O Above Dimension Line

O Below Dimension Line

*

-

Cancel Help

o Specify the numbering Format for
dimension numbers.

¢ Select the Units of measurement to be
used by dimensions from the drop-down
list.

Check Unit Indicators to display the unit
of measurement along with the dimen-
sion number.

Check Leading Zeros to include the zero
before a decimal less than 1 or to display
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0’ or 0” when the ft-in or ’-” unit formats
is used.

* Check Trailing Zeros to display trailing
zeros at the end of decimal values. When
the ft-in or ’-” unit format is used and
fractional inches are specified, 0” will be
included.

(2]

* Select the Decimal Places radio button
for dimension numbers in decimal for-
mat. In the text field, specify the number
of decimal places to use, from 0 to 20. If
0 is used, no decimal places are used.

Specify the degree of Accuracy used
by dimension numbers.

+ Select the Smallest Fraction radio but-
ton for dimension numbers using whole
numbers and fractions. In the text field,
specify the largest denominator to use,
from 1 to 16. If 1 is entered, whole num-

bers are used.
9 Specify the Dimension Text Position,
which is the location of dimension
numbers relative to the dimension line.

* Center primary dimension numbers on
the dimension line. If two formats are
used, the primary format is placed above
the line and the secondary format,
beneath it.

» Position dimension numbers Above
Line.

e Position dimension numbers Below Line.

Arrow Panel

For information about the ARROW panel, see
“Arrow Panel” on page 127.

Text Style Panel

The settings on the TEXT STYLE panel control
the size, font and other attributes of
automatic, manually drawn, and temporary
dimension line labels. See “Dimension
Labels” on page 189.

For information about the settings on this
panel, see “Text Style Panel” on page 206.

Temporary dimension labels always use the
color assigned to their layer - not the color
specified in the Dimension Defaults dialog.

The Dimension Tools
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4% Select CAD> Dimensions to access

the Dimension Tools. Manually drawn
dimensions are created by clicking and
dragging like other line-based objects and
can be drawn in floor plan view.

The zoom factor of the current view affects
whether objects drawn close together are
dimensioned or not. If you try to dimension
an array of objects but the dimension line
locates only the first and last objects along its

path, Zoom A in on the objects and try
again. Similarly, if you want to dimension
between two objects but the dimension
locates unwanted objects between them,

Zoom A out. See “Zoom Tools” on page
72.

Once created, both manually drawn and
automatically generated dimension lines can
be selected and edited. See “Editing
Dimension Lines” on page 189.



Manual Dimensions

To display the distance between two

objects, select CAD> Dimensions>
Manual Dimension and drag a dimension
line near or through the objects.

Manual Dimensions locate walls as specified
in the Dimension Defaults dialog. See
“Dimension Defaults Dialog” on page 183.

End-to-End Dimensions

H Use the End-to-End Dimension tool
to dimension between any two defined
objects in floor plan view.

Select CAD> Dimensions> End-to-End

Dimension 1, then click and drag the
dimension from the first object to the second
object. The dimension line snaps to each
object, ignoring any other objects located
between either end.

Interior Dimensions

K/\ Draw Interior Dimension lines
L parallel to walls in floor plan view to
create interior dimensions.

The Interior Dimension ¢ tool locates
interior wall surfaces only. It does not
dimension between layer surfaces in the
same wall, and it does not locate walls unless
it actually intersects them.

Auto Exterior Dimensions

K The Auto Exterior Dimension tool

generates dimensions around a plan’s
exterior in floor plan view. These dimension
lines locate walls as specified in the
Dimension Defaults dialog. See “Dimension
Defaults Dialog” on page 183.

The Dimension Tools

iy Auto Exterior Dimensions do not gener-
@ ate properly if there is a gap in the exte-
rior walls or if they do not connect properly.

If you edit an Auto Exterior Dimension Val
line, it will be converted to a manual
dimension, so if Auto Exterior Dimensions
are later regenerated, your changes will not
be lost.

There are a maximum of three rows of
automatically generated dimensions per
exterior wall direction. The innermost
dimension line locates exterior walls, interior
walls, and all openings in exterior walls. The
second dimension line locates exterior and
interior walls. The outermost dimension line
is the overall exterior dimension.

Auto Interior Dimensions

IZI The Auto Interior Dimensions tool

creates a set of interior dimensions in
each room that measures each wall on the
current floor. It can be used in floor plan
view in either of two ways:

¢ Select one or more rooms and click the

Auto Interior Dimensions |4 edit tool
to generate interior dimensions that mea-
sure each wall defining the selected
room(s).

¢ Select CAD> Dimensions> Auto Inte-

rior Dimensions |4 to generate a set of
interior dimensions in every room on the
current floor.

Auto Interior Dimensions |/ lines are
generated inside of the rooms they measure
and do not recognize the No Locate setting
for walls. If a wall is specified as No Locate,
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Auto Interior Dimensions will locate it
anyway. See “No Locate” on page 147.

Temporary Dimensions

V Temporary Dimensions display when

an object is selected and show the
distance between the object’s selected edge
and other objects. Select View> Temporary
Dimensions to turn on or off the display of
temporary dimensions. This toggle affects all
views and is saved between launches of
Home Designer Interiors.

As with other dimension lines, Temporary
Dimensions only locate objects that are
parallel or nearly parallel to one another.
They will also locate the endpoints of the
corners of objects located past the end of the

selected edge, within 4 feet (1200 mm) of the
point where you click to select the object.

A temporary dimension will not display
when an object is selected if a dimension line
is already present that shows the same
information.

Tape Measure

© Use the Tape Measure tool to draw a

temporary dimension line between
any two points in the drawing area. The tool
will place temporary markers at the start and
end points of the dimension line. These
points and the line both disappear when you
release the mouse button. If an object is
located by the temporary line, you can snap
to it.

Displaying Dimension Lines

The display of dimension lines is controlled
in the Display Options dialog. See
“Displaying Objects” on page 85.

Dimension lines created by any of the
dimension tools share the same components.

* Dimension Lines run parallel with the
distance being measured.

« Extension Lines are perpendicular to
dimension lines, indicating what they
locate. If a dimension line locates more
than two objects, extension lines divide
the dimension line into segments.

* Arrowheads display at the intersections
of dimension and extension lines.

* Dimension Labels display at the mid-
point of dimension line segments and
indicate the distance that each segment
measures.

Dimension Extension Lines

Labels

Lo
ol
o]

Arrowheads

If a manual dimension line is on a layer that
is turned off and you select an object located
by that dimension line, it will display for
reference using the Selection Line color
specified in the Preferences dialog. See
“Colors Panel” on page 59. This will happen

only if Temporary Dimensions Y are
turned on. See “Temporary Dimensions” on
page 188.



Dimension Labels

Manually drawn, automatic, and temporary
dimension labels use the Text Style specified
in the Dimension Defaults dialog. Unlike
many objects that use Text Styles, by default
dimensions use a Text Style specified in the
defaults dialog rather than the Text Style
assigned to their layer. See “Text Style
Panel” on page 186.

Editing Dimension Lines

Dimension Arrowheads

You can specify the style, color and size of
dimension arrows in the Dimension
Defaults and Dimension Line Specification
dialogs. See .

The arrow at the end of a dimension line will
not display if it is close enough to another
dimension arrow that the two will overlap. A
typical example of this is where two sections
of an Interior Dimension locate two sides of
an interior wall.

Editing Dimension Lines

For information about changing the value
reported in a dimension line label, see
“Moving Objects Using Dimensions” on
page 192.

With the exception of Temporary
Dimensions, dimension lines can be selected
and edited using the mouse and the edit
toolbar buttons.

If an Auto Exterior Dimension line is edited,
it will no longer be considered an automatic
dimension line and will not be deleted and
replaced the next time the Auto Exterior

Dimensions A tool is used.

Using the Mouse

When a dimension line is selected, its edit
handles can be seen. There are four types of
dimension line edit handles. More than one
of some types display, depending on how
many extension lines are present.

Rotate

o

/ Extension Line
|

/ Move

o¢
™~ Add Extension

Line

=

~TTTT——— Extension Line

* The Extension Line handles mark the
location being dimensioned and are used
to move or delete extension lines. See
“Moving Extension Lines” on page 191.

» The Add Extension Line handle displays
to the side of the Move handle and is used
to add extension lines to the dimension
line. Dimension lines do not extend
unless an object can be located. See
“Adding Extension Lines” on page 191.
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* The small, square Move Dimension
Label handle is located at the center of
the selected label. Use this handle to
move the dimension number for each
dimension line section. The pointer

changes to a four-headed arrow «* when
moved over this handle.

* The Move handle is located where you
clicked to select the dimension line and is
used to move the entire dimension line,
including any subsections, perpendicular
to itself. Extension lines are resized as
appropriate. The pointer changes to a

two-headed arrow ++ when moved over
this handle.

* The Rotate handle is located one plan
foot past the end of the dimension line
and is used to rotate the dimension line.

Using the Edit Tools

Dimension lines can be repositioned, copied,
and deleted using the edit toolbar buttons just
like other objects in the program can. See
“The Edit Toolbar” on page 24.

Dimension Number Size

The initial size of dimension numbers is
specified in the Dimension Defaults dialog.
See “Dimension Defaults Dialog” on page
183.

You can specify number height for individual
dimension lines in the Dimension Line
Specification dialog. See “Dimension
Panel” on page 194.

As with text and other objects, dimension
number size is subject to scaling when or
printed.

Copying and Pasting
Dimension Lines

Dimension lines can be copied and pasted
into any view type that supports dimensions.
If a dimension line is copied independent of
the objects it originally locates, the pasted
dimension line will locate point markers.

Deleting Dimension Lines

There are several ways to delete dimension
lines.

You can select any manual or automatic
dimension line or group of dimension lines,
then press the Delete key or click the

Delete X edit button. See “Deleting
Objects” on page 119.

The Delete Objects dialog allows you to
delete all manually drawn and/or automatic
dimension lines at once. See “Delete Objects
Dialog” on page 119.

Individual dimension line segments located
between extension lines can also be deleted.
If a segment is located between two other
segments along the same dimension line, that
dimension will be broken in two.

To delete a portion of a dimension line

1. Select any Dimension Tool aside from
Auto Exterior Dimensions.

2. Manually draw a dimension line over
the segment that you wish to remove,
dragging from extension line to exten-
sion line.



Editing Extension Lines

Editing Extension Lines
Extension lines can be added, edited, and Moving Extension Lines

deleted using the mouse.

To add an extension line

4.

Extension lines can be moved to locate the
centers, sides, or surfaces of most objects. In
this example an extension line is moved from
the windows edge to the center.

Adding Extension Lines

. . To move an extension line
Select the dimension line.

Click the diamond-shaped Add Exten- 1. Select the dimension line it is connected
sion Line edit handle which displays to, not the extension line itself.

near the Move edit handle. The pointer 2. Click the Extension Line edit handle.
changes to a two-headed arrow . The pointer changes to a two-headed
Drag the handle to the object that you arrow +.

want to locate with a new extension han-

dle. This example adds an extension line = 13-9" =

to the window edge.

3. Drag the handle to a new location. The
extension line snaps to possible marks as

the handle is moved.

Release the mouse button to add an 4. Release the mouse button at the new
extension line. location.
13-9" =
6'-9" 136" 3&'0 3-6"—
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@ Not all library symbols can be located
"€ by a dimension line as it is drawn. Once
a dimension is drawn, however, you can
move or add an extension line to locate the
library object.

Deleting Extension Lines

When an extension line is deleted, the
remaining dimensions update. If a dimension
line has only two extension lines, they cannot
be deleted.

To remove an extension line

1. Select the dimension line it is connected
to, not the extension line itself.

2. Click the Extension Line edit handle.

.131_9”

i

21040

I

3. Drag it perpendicular to the direction of
the arrows, away from any dimension-
able object, and release the button when
the extension line disappears.

Moving Objects Using Dimensions

192

Most objects can be moved by changing an
automatic, manual, or temporary dimension
value that locates it. This technique can be
applied in nearly any situation where
dimensions are present. See “Moving
Objects” on page 112.

In addition, some objects can be resized
using dimensions. See “Resizing Objects” on
page 115.

Your pointer indicates which dimensions can
be used to relocate the selected object by
changing to a pointing hand icon.

Another way to tell is to select an object and
drag it in the desired direction. As you drag,
note which dimensions update. These
dimensions are the dimensions that can be
used to move that object.

To move an object using dimensions

1. Select the object and click on a dimen-
sion line that locates it. An inline text
field opens at the location where you
clicked.

* The actual distance displays in the text
field.

* If the dimension is locating two differ-
ent objects and the selected object is
polyline-based, the Move Edge and
Move Entire Object buttons display to
the right of the text field.

Move Edge (selected)

s

Move Entire Object




* If the dimension describes a selected
wall’s length, additional buttons dis-
play to the right. See “Using Dimen-
sions” on page 149.

Move End

J S

Move Both Ends

Move Sart

2. Click the Move button of your choice.

3. Enter a new value in text field.

« To use a different unit, include its indi-
cator after the value.To move the
selected object past a second object, to
its opposite side, enter a negative
value.

* Basic math operations can also be per-
formed in the inline text box, just as
they can in dialogs. See “Math
Operations in Dialogs” on page 27.

4. The selected object moves or resizes
when you press the Enter key or click
outside of the text field.

A variety of polyline- and box-based objects
can also be resized using dimensions.

Dimension Line Specification Dialog

To resize an object using dimensions

1. Select the object along the edge that you
would like to move. See “Selected
Edge” on page 94.

2. Click on a dimension line that indicates
its distance from the object’s opposite
side.

In the inline text field, enter a value.

4. Click Move edge to move the selected
edge only.

5. The selected edge moves, resizing the
object, when you press the Enter key.

iy You can cancel a move or resize opera-
@ tion using dimensions at any time by
pressing the Esc key.

Resizing a House Using
Exterior Dimensions

When resizing a house using dimensions, it
is important to work your way around the
house in one direction. Relocate one wall at a
time in succession so that you do not redefine
the same dimension more than once.

For more information, see “Measuring
Walls” on page 146.

l—l To open the Dimension Line
Specification dialog, double-click a

dimension line using the Select Objects |

or Manual Dimension < tool, or select a

Dimension Line Specification Dialog

dimension line and click the Open Object
edit button.

The settings in this dialog are dynamic
defaults. See “Dimension Defaults Dialog”
on page 183.
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Dimension Panel Specify the Number Height for the selected
dimension. Type “d” in the box to reset the
r‘\ Dimensicn Line Specification * number SiZC to the default'
iirrr'r;?sion Number Height: Arrow Panel

For information about the settings on this
panel, see “Arrow Panel” on page 127.

Cancel Help
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Text is an ideal way to draw attention to
special details of your drawings in floor plan
view.

Text lines with arrow can be attached to text
objects, allowing you to direct attention to
specific plan details.

Text

Chapter Contents
. Text Defaults
. Fonts and Alphabets
. The Text Tools
. Creating Text
. Displaying Text
. Rich Text Specification Dialog
. Text Specification Dialog
. Editing Text
. Copying and Pasting Text
. Text Arrows
. Text Styles

Text Defaults

U.:P Text Defaults can be accessed by

selecting Edit> Default Settings in
any view in which text can be created. See
“Default Settings vs Preferences” on page
54.

The default settings for Rich Text determine
what these objects look like when they are
first created. Text Style Defaults determine
the appearance of text associated with things
like dimensions and object labels.

Text Style Defaults

Select “Text Style” from the list in the
Default Settings dialog and click the Edit
button to open the Saved Text Style
Defaults dialog.

The Text Style Defaults dialog allows you to
specify the attributes of the various Text
Styles in use in the current file. See “Text
Styles” on page 205.
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Rich Text Defaults

The Rich Text Defaults dialog is similar to
the Rich Text Specification dialog. See
“Rich Text Specification Dialog” on page
198.

Text Lines with Arrows ./ use the same
default layer as Rich Text, so by default they
have the same color, line weight and line
style. See “Layers” on page 86.

Arrow Defaults

The settings in the Arrow Defaults dialog
determine the initial settings for arrows

drawn using the Text Line with Arrow s
and Line With Arrow ./ tools.

The Arrow Defaults dialog looks almost the
same as the ARROW panel of the Line
Specification dialog. See “Arrow Panel” on
page 127.

~+v Avoid typing any text in the Rich Text
@ Defaults dialog unless you want it to be
present in all text objects you create.

Fonts and Alphabets

196

Home Designer Interiors allows you to use
any font found in your computer’s Fonts
directory.

Blueprint Fonts

Three architectural fonts: Chief Blueprint,
City Blueprint, and Country Blueprint are
installed in the Windows Fonts directory
when Home Designer Interiors is installed.

Chief Blueprint

City Plueprint
I:"—') —~ [ 3] o

ry LAiueprin

On Mac systems, these fonts are embedded
with the Home Designer Interiors installation
but not installed on the system. As such, they
are available for use in Home Designer
Interiors but not in other programs.

International Alphabets

The Rich Text I tool supports unicode
alphabets and characters. In order to use a
unicode alphabet or characters, the
appropriate language support must be
installed on your computer.

Special characters can be added to any Rich
Text I object by:

* Copying and pasting the character from
another application;

» Copying and pasting the character from
the Windows Character Map;

e Using the Mac Character Viewer;

» Typing the keystroke associated with the
character.

See “Copying and Pasting Text” on page
203.



Missing Fonts

If you open a plan file that uses a font that is
not installed on the current computer, the
program will give you an opportunity to
replace it in the Replace Fonts dialog.

™ Replace Fonts *

The following fonts are not available on this system.
Missing fonts can lead to unpredictable text sizes.

Select one or more fonts in the list. Then choose a
font to replace them with,

Missing Font Replace With

Replace With: | Mo Change V|

Chief Architect Premier X9
3D Home Design Software

Cancel Help

The Text Tools

The table lists all missing fonts and how they
will be replaced.

* Click on a font name in the list to select
it. Use the Shift or Ctrl key to select mul-
tiple fonts. See “Shift and Ctrl Select” on
page 96.

* Select a replacement font from the
Replace With drop-down list, or leave
“No Change” as the selection to maintain
the file’s association with the missing
fonts.

* A preview of the selected font displays
below the Replace Width list.

If you do not plan to return the file to the
computer where it was created, you may
want to replace missing fonts with the fonts
you normally use. On the other hand, if you
do intend to return the file, you may prefer to
not replace any missing fonts.

The Text Tools

Select CAD> Text to access the Text
i Tools. These tools are available in
floor plan view only.

!'jlfa The Rich Text tool is used to create
text objects.

/ The Text Line with Arrow tool is

used to connect text and another
object with an arrow. See “Text Arrows” on
page 204.

f Text with Arrow tool places a Rich
T Text object with an arrow attached.

Creating Text

Text can be created in floor plan view only.

Once created, text can be selected and edited
in a variety of ways. See “Editing Text” on
page 201.

To create Text

1. Select CAD> Text> Rich Text 'If .

2. Type or paste the desired text into the
Text Field.

3. Use the options to change the font, style
and size of any portion of the text.
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Note: If you do not type anything in the Text
Field, a text object will not be created when

you click outside of it.

You can also create lines with arrows
connecting the text that you create to items in
the drawing. See “Text Arrows” on page 204.

Displaying Text

As with other types of objects, the display of
Text objects is controlled in the Display
Options dialog. All Text objects, including
Text Lines with Arrows, are located on the
“Text” layer. See “Display Options Dialog”
on page 88.

Text objects can only be displayed in floor
plan view.

The display attributes of each individual text
object can be controlled independent of the
layer it is placed on. See “Rich Text Specifi-
cation Dialog” on page 198.

Rich Text Specification Dialog

198

The Rich Text Specification dialog

opens if you select the Text T tool
and then click once in the drawing area.

You can also open this dialog by selecting a

Text I object, then clicking the Open
Object edit button.

The Rich Text Specification dialog is
similar to the Rich Text Defaults dialog but
affects the selected text rather than all
subsequently created text objects. See “Text
Defaults” on page 195.

Text Panel

The settings on the TEXT panel allow you to
type the selected Text object’s content and
control many aspects of its appearance,
including its font, size, color and style.

You can specify the appearance of the text
before typing, and can also select and change
the attributes of all or portions of the text
content after it is typed. To change text that
already exists, simply highlight it using the

mouse and/or the Shift + arrow keys and then
make any needed changes to its attributes.

Note: If you do not type anything in the text
field on this panel when creating a new
object, no object will be created when you
click OK. On the other hand, if you remove
the text from an existing object and click OK,
an empty text box will result.




Rich Text Specification Dialog

™ Rich Text Specification

[ Arial v+ | A B [

c
h
g
U]
(]
N

*

B o E@Q)

Type or paste text here....

100%  [5

Cancel Help

o Use the options on the Edit Bar, which
displays above the Text Entry field, to
change the font, size, and style of the text.

Select the desired options before typing to
affect the text as it is typed, or select some or
all of the text and then specify which options
to apply to it.

* Select a Font from the drop-down list.

» Specify the Text Size in drawing units.

«  Click the Color £ button to specify the
color of the selected or subsequently
typed text. See “Select Color Dialog” on
page 90.

+  Click the Bold B button to specify the
selected text as bold.

*  Click the Italic |/ button to specify the
selected text as italic.

+  Click the Underline U button to specify
the selected text as underlined.

+  Click the Strikethrough 'S button to
specify the selected text as stricken-
through.

 Click the Uppercase Aa button to dis-
play the selected text in all capital letters.

+  Click the Align Left =, Align

button to

Center = , or Align Right
specify the how text is aligned.

* Click the Paragraph Options button
to specify the selected paragraph’s align-
ment, spacing and bullets or numbering
in the Paragraph Options dialog.

» Specify the Zoom factor of the selected
text by typing a percentage value in the
text field or clicking the up/down arrows.
This setting only affects the text as it
appears in this dialog.

Note: Some fonts cannot be drawn at certain
zoom factors. When this is the case, the
appearance of the text will not change.

e Type or paste text in the Text Entry
field. See “Copy, Cut and Paste” on
page 203.
* Right-click in the Text Entry field to
access a contextual menu from which you
can select Undo, Redo, Cut, Copy, Paste
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and Select All. See “Contextual Menus”
on page 25.

» To edit text in the entry field, click and
drag to highlight any portion of it and
then use the tools on the Edit Bar as
needed.

Paragraph Options Dialog

™ Paragraph Options *

Alignment o

@ Left
O Center
(O Right
O Justified
Line Spacing o
® single
() 1.5Lines
(O Double
(O User Spedified Line Height:

100.0% '+

Margins o
Indent:

Bullets o
Type: Mone 7
Mumber Prefix:

MNumber Suffix:
Cancel Help

o Specify the Alignment of the selected
paragraph(s). See “Aligning Text” on
page 203.

e Specify the Line Spacing of the
selected paragraph(s).

* Click the radio button beside Single, 1.5
Lines, Double or User Specified.

* Ifyouselect User Specified Line
Height, type the desired height for each
line of text in the selected paragraph(s).
For best results, this value should be at
least as much as the largest character size
used in the selected paragraph(s).

e Specify the appearance of the side
Margins of the selected paragraph(s),

as measured in from edges of the text box.

Only positive Margin values can be used.

* Specify the Indent, which is measured
from the left side margin. A negative
value can be used if a left Margin has
been specified.

0 Specify the appearance of Bullets and
numbering in the selected paragraph(s).

¢ Select the desired bullet, numbered, or
lettered Type from the drop-down list.

* Specify the Number Prefix, which are
any characters that you would like to dis-
play before the selected paragraph’s num-
ber or letter. Does not affect paragraphs
using circle or square bullets.

* Specify the Number Suffix, which are
any characters that you would like to dis-
play after the selected paragraph’s num-
ber or letter and before its actual text.
Does not affect paragraphs using circle or
square bullets.



Text Specification Dialog

Text Specification Dialog

|—| The Text Specification dialog opens
if you select a Room Label or Living
Area Label or a simple Text object in a
legacy plan file created in Version 8 or prior
and click the Open Object edit button. See

“Compatibility with Other Programs” on
page 36.

Settings in the Text Specification dialog can
also be found in other dialogs in the program,
including the Room Label Specification and
the Dimension Defaults dialogs.

Text Panel

The settings on the TEXT panel allow you to
type the selected Text object’s content. Text

cannot be added to a selected Room Label,
however.

™ Text Specification

Text Insert: | >
Text Style

[] add an Arrow

Spell Check... B

Type or paste text here, ..

Type or paste text hers. .

Alignment: |Left

e o

Mumber Style. ..

Cancel Help

o Enter text in the Text Entry field. This

field is not available if the selected
object is a Room Label. See “Room Labels”
on page 170.

9 Select an Alignment option from the
drop-down list to apply to the text.

9 A preview of the selected text object
displays on the right. Not available for

Room Labels. See “Dialog Preview Panes”
on page 28.

Text Style Panel

The TEXT STYLE panel is available for a
variety of objects in the program and control
the appearance of the selected object’s text.
See “Text Style Panel” on page 206.

Editing Text

Once created, Text /I objects can be
selected individually or as a group and edited
using the edit handles and the edit toolbar
buttons Individual text objects can also be

edited in the Rich Text Specification dialog.
See “Rich Text Specification Dialog” on
page 198.
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Editing Text Attributes

Most text attributes, including the font, size,
style, and the content itself, are edited in the
Rich Text Specification dialog.

In order to edit the attributes of an existing

Text ‘I object, you must select some or all
of the text before making changes. See “Text
Panel” on page 198.

To edit Text attributes

1. Select a Text I object and click the
Open Object b1 edit button.

2. On the TEXT panel of the Rich Text
Specification dialog, click and drag to
select some or all of the text typed into
the Text field.

I™ Rich Text Specification

e
Appearance Chief Blueprint E IP ﬁ B ! u
Options

This is eldzelghllof some text.

3. With some or all of the text selected,
change any of the attributes available
along the top of the panel, including the
font, size, color, and style.

I™ Rich Text Specification

[Grefoomr T 1P A

Rich Text
Appearance
Options

B /.U

4. As changes are made, the selected text
updates. Only the selected text is modi-
fied.

™ Rich Text Specification

e
Appearance Chief Blueprint E IP ﬁ B ! u
Options

This is an example of some text.

Using the Mouse

A selected Rich Text I object has the same
edit handles as other box-based objects. See
“Editing Box-Based Objects” on page 106.

Move

Rotate ——— @

As a text box’s width is made narrower or
wider using an edit handle, its height may
increase or decrease so that none of the text
becomes hidden. The opposite is not true,
however: a text box’s height cannot be
resized smaller than the height of the rows of
text it currently contains.

Using the Edit Tools

A selected Rich Text I or Text T object
can be edited in a variety of ways using the
buttons on the edit toolbar. See “The Edit
Toolbar” on page 24.

Resizing Text

The default character height of Rich Text

T objects can be specified as can the
character height for individual objects, in



their specification dialogs. See “Text
Defaults” on page 195.

Scaling Text

As with the size of other objects, text size is
subject to the current drawing scale specified
in the Page Setup dialog. See “Drawing
Sheet Setup Dialog” on page 447.

Aligning Text
Text can be aligned in a couple of ways.

* The text content of a text object can be
aligned to the left, right, center or justi-
fied in the Rich Text Specification dia-
log. See “Text Panel” on page 198.

» The text content of a text object can be
also be aligned by clicking the Align

Left =/, Align Right =, Center =/,

or Justify =/ edit button.

Copying and Pasting Text

Copy, Cut and Paste

Copy, Cut and Paste of text into and out of
the Rich Text Specification dialog can be
accomplished using keyboard hotkeys:

* Press Ctrl + X to Cut the selected text and
save it to the system clipboard.

* Press Ctrl + C to Copy the selected text
and copy it to the system clipboard.

* Press Ctrl + V to paste your last cut or
copied selection in a new text object.

For more, see “Copying and Pasting
Objects” on page 81.

Copy, Cut and Paste use the system
clipboard, making it possible to to transfer
text between text objects, between Home
Designer Interiors files, from a plan into
another application, or vice versa.

Copying and Pasting Text

The Copy, Cut and Paste commands use the
system clipboard, making it possible to
transfer text between text objects, between
Home Designer Interiors files, from a plan
into another application such as a text editor
or spreadsheet program, or vice versa. See
“Copying and Pasting Objects” on page 81.

All or selected portions of the Materials List
can also be copied and pasted into a text
object, as well as into a word processing or
spreadsheet program. See “Materials Lists”
on page 437.

Cut, Copy, and Paste can also be accessed
from the Edit menu of many applications,
including Home Designer Interiors. These

menu commands are not available when the
text specification dialogs are open, but you
can use the associated hotkeys.

To Copy, Cut and Paste text

1. On the TEXT panel of either text specifi-
cation dialog or in another program alto-
gether, highlight the text you wish to cut,
copy or paste.

2. Press Ctrl + X to Cut the selected text
out of its original location and save it to
the system clipboard.

3. Press Ctrl + C to Copy the selected text
to the system clipboard without remov-
ing it from its original location.
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4. Open the text object or a file in another
application and click to place your cur-
sor in the Text field, writing area, or
spreadsheet cell.

5. Press Ctrl + V to Paste the copied text at
the location of your cursor.

Bear in mind that when text is copied and
pasted, its formatting is not always retained.
The results depend on the program or type of
text object in which the content was created
as well as the type of text object into which it
is pasted.

Pasting into Rich Text

!j l:; Text pasted into a Rich Text object
from another source will retain most -
but not necessarily all - of its custom

formatting. If a line of text is sufficiently
long, however, it may be wrapped
automatically when pasted into Rich Text.

Text pasted into a RichText T object from
a spreadsheet program retains basic column
and row information. Column width cannot

be adjusted; however, as you add or remove
text from a cell, row height will increase or

decrease to accommodate your changes.

Pasting into a View

Text can also be pasted directly into a plan
viewelevation view. When you use the Paste
command, a new Rich Text object is created,
the text is pasted into that object, and it is
selected. In order to see the new object, you
may need to Fill Window.

Text Arrows
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Text arrows can be used to connect text
objects to details of interest in your drawing.

Text arrows can be snapped together to form
open or closed polylines. If two lines with
arrows meet within the bounding box of a
text object, however, they will not join. This
allows you to attach multiple, separate text
arrows to a single text object. See “Editing
Line Based Objects” on page 96.

Lines with arrows can be independent or
attached to other objects. If an attached
object is moved, the end of the Line with
Arrow will move, as well. Arrows attach to
closed polyline-based objects along their
edges, but can attach to Text or an
architectural object anywhere within its
bounding box in floor plan view.

If an arrow is attached to text or another
object, deleting either the text or the object
will also delete the arrow.

Text with Arrow

[ f The Text with Arrow tool places a
| text object with an arrow already
attached. This arrow can be selected and
edited like any other arrow.

Text Line with Arrow

/ Text Lines with Arrow can be

attached to text and architectural
objects by selecting CAD> Text> Text Line
with Arrow and then clicking and dragging
to draw a line. There is no limit to the
number of text lines with arrows that can be
attached to an object.



The endpoints of Text Lines with

Arrows /" can be joined to form polylines
with corners that can be adjusted using the
edit handles.

Auto Position Arrows

Auto Positioning helps prevent a Text Line

with Arrow /" from crossing over the text
object it is attached to by snapping the end of
the line to the midpoint of the text box’s
nearest edge. If the text object or the line’s
arrowhead is moved, the location of the tail
end will update as needed so that it snaps to
the nearest edge’s midpoint. This behavior
only occurs when the end of a line with
arrow is snapped an Auto Position location:

Text Styles

if it is snapped to a different point on the text,
the tail end will not move.

The following image illustrates the behavior
of Auto Positioning. When the head of the
arrow is moved, the tail of the arrow snaps to
different Auto Position locations on the text
object, maintaining its connection.

Text—o—no

Text Styles

In Home Designer Interiors, a Text Style is a
set of attributes assigned to any object that
displays text, such as Dimensions and object
labels.

Note: Because of its ability to use multiple
attributes in the same object, Rich Text does
not use Text Styles. See “Rich Text Specifica-
tion Dialog” on page 198.

There are three Text Styles in Home
Designer Interiors. You can edit these Text
Styles to suit your needs in the Text Style
Defaults dialog

e The Default Label Style affects the
appearance of labels for objects such as
doors and windows;

*  The Default Text Style controls the
appearance of legacy Text objects, and
dimension line labels, unless specified
otherwise.

* The Default Room Style controls the
appearance of room labels.

Text Style Defaults

U.:P Select Edit> Default Settings, click

on “Text Styles” and click Edit to
open the Text Style Defaults dialog. The
Saved Text Style Defaults dialog will open,
allowing you to select which Saved Text
Style Defaults you would like to edit.
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Saved Text Style Dialog Click the Edit button to open the defaults
dialog for the selected Text Style so that

M\ Saved Text Styles w you can edit it.

Available Text Styles ¢ Click OK to close the Saved Text Style
172" Text Style Ed... Defaults dialog and save any changes
ey lIeSt)rIe you made in the defaults dialog.

Defaui Tet 2§'|Z +  Click Cancel to close the Saved Text
Schedule Style Style Defaults dialog without saving any

changes that you may have made in the
defaults dialog.
The settings in the Text Style Defaults
e e dialog are similar to those on the TEXT STYLE
«  Select the Name of one of them from the panel of object specification and defaults
drop-down list. This is the currently dialogs in the program but affect all objects
selected Text Style. using that style rather than an individual

selected object.

Text Style Panel

The TEXT STYLE panel is found in various
specification and defaults dialogs in the
program.

r‘\ Dimension Defaults

Setup Use Default Text Style: "Default Text Style™

Format
Font

00

Arrow
Text Style Ch

Character Height o

Text Color o

Preview (Chief Blueprint)

Home Designer 2019
3D Home Design Software

Cancel Help




o Check Use Default Text Style to use
the default style for the selected object

type, or uncheck this box to enable the

settings below and define a custom style.

The settings that follow are only editable
when Use Default Text Style is unchecked.
When it is checked, information about the
Text Style that is assigned to the selected
object displays for reference.

9 Specify the attributes of the selected
Text Style’s Font.

* Select a font from the drop-down list.

* The text styles Bold, Underline, Italic,
Strikeout, and Uppercase are available.
Check any of the boxes to apply that
style.

0 Specify the Character Height of text
using the selected Text Style.

Text Styles

» Enter the Character Height in drawing
units. This height is subject to the current
drawing scale.

0 Specify the selected Text Style’s Text

Color. When Use Custom Text Style is
not selected above, a Text Color does not
display here for reference.

¢ When By Layer is checked, text uses the
line color assigned to the layer that the
object it is assigned to is located on. See
“Layer Attributes” on page 87.

* Uncheck By Layer, then click the Color
bar to select a different color. See “Select
Color Dialog” on page 90.

e A preview of the Text Style currently
assigned to the selected object displays
here.
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Home Designer Interiors comes with tools
for creating a wide variety of interior and
exterior doors. In addition, the library offers
a large selection of specialty doors and
doorways including hinged, sliding, pocket,
bifold, and garage doors. Additional name-
brand door catalogs are also available for
download from our web site, HomeDesign-
erSoftware.com.

Doors

Chapter Contents
. Door Defaults
. The Door Tools
. Displaying Doors
. Editing Doors
. Changing Door Swings
. Special Doors
. Door Specification Dialog

Door Defaults

@ There are several defaults dialogs for

doors. Default Settings are accessed
by selecting Edit> Default Settings. Click
the arrow next to “Doors” to expand the
category. Select a subheading and click the
Edit button to open the defaults dialog
associated with your selection:

The Door Defaults dialogs look nearly the
same as the Door Specification dialog. See
“Door Specification Dialog” on page 219.
There are only a couple of differences:

* Since default settings are specified here,
“Use Default” is not an option for some

settings as it is in the Door Specification
dialog.

* The Door Type cannot be changed in the
Defaults dialogs.

Because Hinged and Sliding Doors are often
used in both interior and exterior
applications, they have both Interior and
Exterior Door Defaults.

Interior vs Exterior Doors

Regardless of its Door Type or the tool used
to create it, a door will be:
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* An Interior Door if it is placed into a wall
that separates two interior rooms;

* An Exterior Door if it is placed into a wall
that separates an interior room from either

an exterior room or the building’s exte-
rior. See “Room Types” on page 165.

This rule applies to doors copied and pasted
from one location to another just as it does to
those created using the Door Tools.

The Door Tools
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m01 | To place a door, select the type you

0. want from the Build> Door submenu.
Move your mouse pointer over a wall
section. When a preview outline can be seen,
click to place a door at that location.

The minimum initial size for doors varies by
Door Type. For example, If there is room
enough along the wall to fit a 12” (300 mm)
wide Hinged Door, a preview outline will
display and a door can be placed. Garage
doors, in contrast, must initially be at least 6
(1800 mm) wide.

Doors can be placed in both straight and
curved walls, as well as span across straight,
collinear wall segments.

A newly created door inherits the settings in
the Door Defaults dialog for its door type.
Once created, doors can be edited in a variety
of ways. See “Door Defaults” on page 209.

Doors cannot be placed in a wall specified as
Invisible. See “Room Dividers and Invisible
Walls” on page 139.

Once placed, any door may be changed into
any other type of door in the Door
Specification dialog. See “General Panel”
on page 219.

Hinged Doors

.I-\]. Select Build> Door> Hinged Door

and click a wall where you want to
place a hinged door. Hinged doors can be
placed on interior or exterior walls, and can
be set up so that different door styles are
placed in each. A hinged door becomes a
double door when its width is four feet or
greater.

The initial swing direction of a hinged door
depends on the location of the mouse pointer
relative to the wall when you click. The door
will swing towards the side of the wall that
you click nearest.

The initial hinge side of a hinged door can be
set by clicking to place the door and then
holding the mouse button down rather than
releasing it. Move the mouse toward the end
of the door that you would like the hinges to
be on: as the mouse pointer nears either end,
the door preview’s hinge side will move to
that end. You can also adjust the door’s
swing direction in this manner. When the
swing direction and hinge side are correct,
release the mouse button.

Doorways

Choose Build> Door> Doorway and
click a wall to place a doorway.
Doorways are simply openings without a



door and can be placed on interior or exterior
walls, or in railings and fences to provide an
opening. You can assign a door from the
library to a doorway if you wish.

Sliding Doors

Select Build> Door> Sliding Door

and click on a wall where you want to
place a sliding door. Sliding doors can be
placed on interior or exterior walls and can
be set up so that different door styles are
placed in each. If placed in an exterior wall,
for example, the door is a Glass Panel; if
placed in an interior wall, it is a solid Slab.

The initial opening side of a sliding door can
be specified by moving the mouse pointer
along the wall while the mouse button is still
pressed.

The default sliding door dimensions are
5’-0” x 6’-8” with a 12” bottom frame and a
6” frame on the sides and top.

Pocket Doors

Select Build> Door> Pocket Door
and click a wall where you want to
place a pocket door.

As with sliding doors, the initial opening side
of a pocket door can be specified by moving
the mouse pointer along the wall while the
mouse button is still pressed.

The default pocket door dimensions are 2°-6”
x 6’-8” high. A pocket door becomes a
double pocket door if its width is four feet or
greater.

The Door Tools

Bifold Doors

Choose Build> Door> Bifold Door
and click a wall where you want to
place a bifold door.

Like a hinged door, the initial opening side of
a bifold door depends on the location of the
mouse pointer relative to the wall when you
click. The door will open towards the side of
the wall that you click nearest.

Similarly, the initial hinge side of a sliding
door can be specified by moving the mouse
pointer along the wall while the mouse
button is still pressed.

The default interior single bifold door is 2’-
6” x 6’-8”. A bifold door becomes a double
bifold if its width is greater than three feet.

Bifold doors always display closed in all 3D
views.

Garage Doors

1| Choose Build> Door> Garage Door
s—a and click a wall to place a garage
door.

The default garage door is 8°-0” x 7°-0” high.
A garage door must be at least two feet wide.

In plan view, dashed lines show the size and
location of the garage door when open.

Garage doors will build into a garage stem
wall provided the room is designated as a
garage before the door is inserted. See
“Room Types” on page 165.

The Doors & Doorways
Library Catalog

tﬂll'a_ The Doors & Doorways library
! catalog can be accessed by selecting

211



Home Designer Interiors 2019 Reference Manual

View> Library Browser and browsing to
Home Designer Core Catalogs>
Architectural> Doors and Doorways. This
catalog contains a variety of interior and
exterior doors, as well as special entryways
and wrapped openings.

Entryways and wrapped openings are
examples of Doorways, which are wall

openings that do not have doors within them.

N

To add a door to the Doorway, select a Door
Type other than “Doorway” from the drop-

down list in the Door Specification dialog.
See “General Panel” on page 219.

You can also select a custom door from the
library and place it into a doorway in plan
view or any 3D view.

To place a library door in a doorway

1. Go to plan view or any 3D view.
2. Open the Library Browser.

Browse or search to find a custom door
style that suits your needs.

4. Select the door in the Library Browser,
then click on the doorway to place the
selected door within it. If a door already
exists, it is replaced.

5. Continue clicking other doorways as
needed.

Displaying Doors

212

The display of doors and door labels is
—U| controlled in the Display Options
dialog. See “Display Options Dialog” on
page 88.

Doors can only be placed in walls, so if a
wall’s layer is turned off, any doors placed in
that wall will not display, either. See
“Displaying Walls” on page 144.

If the “Doors” layer is turned off, doors and
their casing do not display but openings in
the walls where they are located are visible.

In Plan Views

A door’s jamb, and swing are all represented
in plan view. A threshold line will display
across a door opening in plan view when the
door:

» Islocated in an exterior wall. See “Exte-
rior and Interior Walls” on page 138.

* Opens to an exterior room such as a
Garage or Deck. See “Room Types” on
page 165.

* Is located between rooms with different
floor heights. See “Stepped Floor and
Ceiling Platforms” on page 174.
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If an exterior door to a Garage room on Floor
1 extends into a Garage stem wall or curb on
Floor 0, its location will be indicated on
Floor 0. See “Garages” on page 282.

In 3D Views

You can specify whether a selected door is
shown open or closed in 3D views by

clicking the Show Door Open in 3D and
Show Door Closed in 3D il edit buttons as

Editing Doors

well as in the Door Specification dialog.
See“General Panel” on page 219.

If a door is set to display open in 3D, the
angle of the open door can be changed using
the edit handles in plan view. See “Using the
Mouse” on page 214.

You can specify whether an exterior door has
a threshold in the Door Specification dialog.
See “Casing Panel” on page 221.

Door Labels

Door labels display in floor plan view,
centered on the doors they represent, when
the “Doors, Labels” layer is turned on and
use the “Default Label Style” Text Style.
Door labels indicate Width and Height. For
example:

* In Imperial plans, the label for a 3°-0”
wide, 6’-8” high double hung window
will read 3068.

¢ In metric plans, the label for a 900 mm
wide, 2100 mm high double hung window
will read 900x2100.

Editing Doors

Before a door can be edited, it must be
selected. To select a door, click it when the

Select Objects || tool or any of the Door

Tools are active. Doors and/or windows
can also be group selected and edited. See
“Selecting Objects” on page 94

Blocked units are made up of individual
doors and windows that have been grouped
together to act as one object. You can create
what is essentially a blocked door unit by

assigning a library door to a doorway from
the library.

Select a blocked unit by clicking on it in any
view. To select a door that is a component of
a blocked unit, click at the location of the

component in question, then click the Select

Next Object e edit button. See “Selecting
Objects” on page 94.
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In the Specification Dialog

The most precise method of editing a

door is to use the Door Specification
dialog. Door type, size, casing, materials,
and more can all be specified in this dialog.
See “Door Specification Dialog” on page
219.

Using the Mouse

In plan view, click either of the two end
handles and drag along the wall to change the
width. The label showing the size updates as
the handles are dragged. Click and drag the
Move handle at the center to move the door
along the wall it is placed in. Use the
triangular Rotate handle to adjust the door’s
swing.

In 3D views, a selected door has five edit
handles: the Move handle at the center and a
Resize handle on each edge. Click and drag
an edge handle to resize the door.

A door or window moved against an
intersecting wall temporarily stops when the
casing meets the intersecting wall. You can
continue to drag and it resumes movement
past the intersecting wall.

Using Dimensions

Like various other objects, doors can

be moved using dimensions. See
“Moving Objects Using Dimensions” on
page 192.

By default, dimensions locate the sides of
doors. Once a dimension line has been
drawn, you can move or add its extension
lines to locate the center of a door. See
“Editing Extension Lines” on page 191.

Using the Edit Tools

A selected door or doors can be edited in a
variety of ways using the buttons on the edit
toolbar. See “The Edit Toolbar” on page 24.

* Click the Change Opening/Hinge Side

I\ edit button to change the side of the
door that its hinges are on. See “Changing
Door Swings” on page 215.

« @ Click the Show Door Open in 3D

or Show Door Closed in 3D & edit but-
ton to control the selected door’s appear-
ance in 3D views. See “In 3D Views” on
page 213.

Centering Doors

The Center Object edit button allows

you to center a selected door along a
wall within a room or relative to a cabinet or
window. See “Using Center Object” on page
114.

To center a door along a wall

1. Select a door or combination of win-
dows and doors in plan view.

2. Click the Center Object ** edit button
then choose from one of the following
options:

* Click near a wall inside a room to cen-
ter the door along that wall in that
room.

* Click outside the house (on the exterior
room) near an exterior wall to center
the door along an exterior wall.



Door Hardware

Handles, locks, and hinges can be assigned to
a door in the Door Specification dialog. See
“Hardware Panel” on page 222.

Changing Door Swings

Changing Door Swings

ﬁ Door swing direction and hinge
= 7] side can be changed using the
Change Opening/Hinge Side and Change

Swing Side edit buttons.

The Change Opening/Hinge Side LV edit
button is available for all doors except
double doors and garage doors.

The Change Swing Side <X edit button is
available for all doors except pocket doors.

Hinged Doors

In addition to using the edit buttons, hinged
doors’ hinge side and swing direction can be
changed using the triangular Rotate edit
handle.

To adjust the angle of swing:

1. Inplan view, select the door and grab the
triangular handle.

2. Drag to change the amount of swing.

3065

3. Release the mouse.

If you drag near the closed position, the door
snaps to a closed position.
To change the swing using edit handles:

1. Inplan view, select the door and grab the
triangular edit handle.

3065

2. Drag the pointer along the path of the
new arc to change the hinge side and/or
swing direction.

3. Release the mouse.

To change the swing using edit buttons:
1. In plan view, select the door.
2. To change the hinge side, click the

Change Opening/Hinge Side LV edit
button.
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3065

A

3065

3. To change the swing direction, click the

Change Swing Side ¥ edit button.

a

3065

3065

Sliding Doors

To change the side of a sliding door that is
fixed, select the sliding door then click the

Change Opening/Hinge Side LV edit

button.
— = =
5068
= B ey
5068

To flip the fixed and moving sides of the

door, click the Change Swing Side ¥ edit
button.
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As with hinged doors, you can also change
the Opening/Hinge and Swing sides of a
sliding door by clicking and dragging the
triangular edit handle.

Pocket Doors

To change the direction of a pocket door,
select it and click the Change Opening/

Hinge Side [\ edit button.

2668

2668

Note: There must be enough room for the
entire door to fit in the opposite wall or the
door does not change.

As with hinged doors, you can also change
the Opening/Hinge side of a pocket door by
clicking and dragging the triangular edit
handle.

Bifold Doors

To change the side of a bifold door that is
fixed, select it then click the Change

Opening/Hinge Side LV edit button.



p— o

2668, 2

To change the hinged side of the door, click
the Change Swing Side <X edit button.

p— o

] <2668

As with hinged doors, you can also change
the Opening/Hinge and Swing sides of a

Special Doors

bifold door by clicking and dragging the
triangular edit handle.

Garage Doors

To change the side of a garage door that it
faces, select it and click the Change Swing

Side " edit button.

L __|

As with other door types, you can also
change the Swing side of a bifold door by
clicking and dragging the triangular edit
handle.

Special Doors

A variety of special doors and doorways can
be created in Home Designer Interiors.

Transoms Above Doors

Transom windows above doors are created
the same as other stacked windows. See
“Grouped Windows” on page 229.

Wrapped Openings

Wrapped openings of various shapes are
available in the Doors & Doorways
Library.

You can also create a wrapped opening by
unchecking Use Interior Casing and/or Use
Exterior Casing in a Doorway’s Door
Specification dialog. See “Casing Panel” on
page 221. If base molding is present, it will
wrap around the opening.
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Openings in Railings

Use the Doorway *— tool to open a railing

for a stairway or other access.

To open a railing across an entire section,
resize the doorway’s Width so that it is

greater than the length of the railing in the

Door Specification dialog. The opening

resizes to the maximum width possible for
that space. See “General Panel” on page 219.

Creating a Doorway
with a Railing

When a railing is specified as No Room Def,

it can be positioned within a Doorway *.

To create a doorway with railing

1.

Place a Doorway |'E'| at the desired loca-
tion in your plan.

Select Build> Railing and Deck>

Straight Railing @]L then click and
drag to draw a railing parallel to the wall
with the doorway.

Select the railing, then use the Resize
edit handles to adjust the length of the
railing as needed. See “Using the Edit
Handles” on page 97.

With the railing selected, click the Open
Object I edit button.

On the GENERAL panel of the Railing
Specification dialog, check No Room
Def and click OK. See “General Panel”
on page 155.

With the railing still selected, Ctrl + drag
it into position within the doorway. See
“To move an object freely” on page 113.

<

3068

Positioning a railing in a doorway



Door Specification Dialog

Door Specification Dialog

Whether a selected door is Interior or
Exterior depends on where it is placed. See
“Interior vs Exterior Doors” on page 209.

'—l To open the Interior or Exterior Door
Specification dialog, select a door

and click the Open Object edit button or

double-click on a door using the Select

Objects | or any Door il tool.

General Panel

™ Interior Door Specification *
General o
-
Options Door Style: Library...
Casing
Lites Door Type: o
Arch
Hardware Size and Position o
Materials Width:
Height:
Thickness:
Elevation Reference: From Floor = .
Panel Frame Options o
Bottom: g Exte I'FOI‘
Interior Doors o
[] separate Trim and Materials on Each Side
Cancel Help
o General - e Select “Library” from the drop-down list

or click the Library button to choose a
door symbol from the library. Once a
library door is selected, its name is added
to the Door Style list. See “Select Library

* Door Style - Select Slab, Glass Slab,
Panel, Glass Panel, Louvered, or Glass
Louver from the drop-down list; select a

style from the Library; or choose “Use
Default” to use the default door style set
in the Door Defaults dialog. See “Door
Defaults” on page 209.

Object Dialog” on page 350.

Specify the Door Type as Doorway,
Hinged, Slider, Pocket, Bifold, or Garage.
In the Door Defaults dialogs, the Door
Type cannot be changed.
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Specify the Size and Position of the
selected door.

(2]

* Specify the Width, Height, and Thick-
ness of the door.

» Select the Elevation Reference from the
drop-down list. This determines where the
next two settings are measured from and
also affects their labels.

+ Specify the height to Top, measured from
the selected Elevation Reference to the
top of the door frame.

* Specify the height to Bottom, measured
from the selected Elevation Reference to
the bottom of the door frame.

o Panel Frame Options - Specify the

dimensions of the selected door’s rails

and stiles. Only available for Glass, Panel,
and Louvered doors.

» Specify the Width of the stiles and top
rail.

e Specify the height of the Bottom rail.
G The Interior Doors settings are only
available when the selected door is

placed in an interior wall. See “Exterior and
Interior Walls” on page 138.

*  Check Separate Trim and Materials for
Each Side to specify the casing, lintels,
and all materials for each side of the
selected door independently. When
unchecked, the two sides of the door use
the same trim and materials.

e A preview of the door displays on the

right side of the dialog box. A label
indicates which side of the door is its Interior

and which is its Exterior. See “Dialog
Preview Panes” on page 28.

Options Panel

r\ Interior Door Specification

General Door Units

Options

Casing

Lites 3D Display

Arch (®) show Closed
Hardware

Materials

® Calculate from Width (O Single Door Only () Double Door Only

() Show Open

*

QO . -oAan

Exterior

Cancel Help

o Specify the number of Door Units or
panels that the selected door has. Not
available for garage doors.

+ Select Calculate From Width to use the
program defaults. Hinged, Pocket and

Bifold doors default to Single Door when
less than four feet (1200 mm) wide. If the
width is greater than four feet, Double
Door is the default.



* Select Single Door to force the selected
hinged, pocket or bifold door to be a sin-
gle door, regardless of its width.

* Select Double Door to force the selected
hinged, pocket or bifold door to be a dou-
ble door, regardless of its width.

e Ifa Slider door is selected, instead choose
Two, Three, or Four Panel.

Note: The defaults for Calculate From Width
are not editable.

Door Specification Dialog

g 3D Display - Specify whether the
selected door is shown open or closed
in 3D views.

If Show Open is selected, the Swing Angle
set on the General Panel is used.

A preview of the door displays on the right
side of the dialog box. See “Dialog Preview
Panes” on page 28.

Casing Panel

™ Exterior Door Specification

General Use Interior Casing
Options Width: [3 1/4° (D)
Casing
Lites Use Exterior Casing
Arch
Hardware Width: |3 1/2° (D)
Materials

Sill{Threshold

Use Sill/Threshold

*

O .-oam
P} (4]
(3]

Cancel Help

0 Check Use Interior Casing, then
specify the Width of the casing.

9 Check Use Exterior Casing, then

specify the Width of the casing. Not
available for doors in interior walls unless
Use Exterior Trim and Materials is
checked on the GENERAL panel. See
“General Panel” on page 219.

e Uncheck Use Sill/Threshold to prevent
a sill from being generated under the
door. See “Displaying Doors” on page 212.

G A preview of the door displays on the
right side of the dialog box. If casing is
not specified for a Doorway, the Show Wall
option will be toggled on automatically. See
“Dialog Preview Panes” on page 28.

Lites Panel

The settings on the LITES panel of the Door
Specification dialogs are only available

when the selected door is specified as a Glass
door on the General Panel. These settings are
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also found on the LITES panel of the Window
Specification dialog. See “Lites Panel” on
page 235.

Arch Panel

The settings on the ARCH panel are not
available if the selected door is a Sliding,

Bifold or Garage door.
™ Interior Door Specification *
Gen.eral Ar o - lZ‘ I|“|‘E
Options Type: |Broken Arch =
Casing
Arch
Hardware
Materials
Exterior
Cancel Help
0 Define the style and size of the Arch. of the door. Not available for Round Top

Arches.

* Selecta Type of arch from the drop-down e A preview of the door displays on the
list. right side of the dialog box. See

+ Specify the Height of the arch, as mea- “Dialog Preview Panes” on page 28.
sured from the base of the arch to the top

Hardware Panel

Many of the settings on the HARDWARE Defaults dialog for the selected door’s Type
panel are Dynamic Defaults: if “Use is used. See “Dynamic Defaults” on page 55.
Default” is selected, the setting in the Door



Door Specification Dialog

General

r\ Interior Door Specification

Handles

Hinges

Hinges:

Options Interior Handle: Use Default =
Casing
Lites Exterior Handle: Use Default =
Arch In from Door Edge:
Hardware
Materials Up from Bottom: 367 (D)
Locks
Interior Lock: Use Default =
Exterior Lock: Use Default =
Up from Bottom: 427 (D)

Use Default =

AP —

Mumber of Hinges:

X
Q. -oAan
(4]

Exterior

Cancel Help

Specify the Handles to be used on the
selected door.

¢ Select an Interior Handle and/or Exte-
rior Handle from the drop-down lists.

» Specify the location of the door handles
In From Door Edge.

* Specify the location of the door handles

Up From Bottom.
Specify the door’s interior and exterior

9 Locks.

¢ Select an Interior Lock and/or Exterior
Lock from the drop-down lists.

» Specify the location of the door locks Up
From Bottom. The locks use the same In
From Door Edge value as the handles.

(3]

* Select a style of Hinges from the drop-
down list.

Specify the Hinges to be used on the
selected door.

» Specify the distance In From Top/Bot-
tom of the door to the center of the top
and bottom hinges.

Note: For hinges to look right, it is best to
have at least a 1/4" (6 mm) reveal for the inte-

rior, or hinge side, door casing.

e Specify the Number of Hinges on the
selected door. Interior hinged doors and
bifold doors typically have two hinges
while exterior hinged doors have three.

0 A preview of the door displays on the

right side of the dialog box. See

“Dialog Preview Panes” on page 28.

Materials Panel

The MATERIALS panel is available for a
variety of objects throughout the program.
For more information, see “Materials Panel”
on page 372.
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Manufacturer Panel Manufacturer library catalogs. See

. “Manufacturer Catalogs” on page 341.
The MANUFACTURER panel provides contact

information for the selected door’s
manufacturer. Only available for doors from
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Home Designer Interiors can model a wide
variety of windows. Fixed glass, hung,
casement, sliding, awning, hopper, and
louver window styles can all be created with
the standard Window tool. Home Designer
Interiors can create bay, box, and bow
windows with a single click. In addition, the
library contains many mulled window
combinations.

Chapter 16:

Windows

Chapter Contents

Window Defaults
The Window Tools
Special Windows
Grouped Windows
Displaying Windows
Editing Windows
Window Specification Dialog
Bay, Box, and Bow Windows
Bay, Box, Bow Windows and Roofs
Bay/Box and Bow Window

Specification Dialogs
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Window Defaults

@ Default Settings can be accessed by
selecting Edit> Default Settings.
Select Window from the Default Settings

dialog.

The settings in the Window Defaults dialog
control the attributes of a window when it is
initially placed in a plan, so you should
define the type of window that will be placed
most often in your model. See “Default
Settings vs Preferences” on page 54.

The panels in the Window Defaults dialog
are similar to those found in the Window

Specification dialog.For more information,
see “Window Specification Dialog” on page
232.

Dynamic Window Defaults

A variety of window default values are
dynamic, including the Window Type,
Casing Specifications, Sash sizes. All
Materials are also dynamic. When a
dynamic default is changed, existing
windows using the default value are affected.
See “Dynamic Defaults” on page 55.

The Window Tools

226

To place a window, select Build>

Window and choose the desired
Window Tool. Move your mouse pointer
over a wall section, then click to place a
window in the wall at that location.

+ If there is room enough along the wall to
fita 6” (150 mm) wide Standard Window,
a preview of the window will display and
a window can be placed.

» The Bay, Box, and Bow Window tools do
not have preview outlines. If a minimum
width of 30” (725 mm) cannot be accom-
modated at the location where you click,
a warning message will display and a
window unit will not be created.

Standard Windows can be placed in both
straight and curved walls, as well as span
across straight, collinear wall segments. In
contrast, a Bay, Box, or Bow Window can
only be placed in a single, straight wall.

Windows cannot be placed in a wall
specified as Invisible. See “Room Dividers
and Invisible Walls” on page 139.

Standard Windows

Select Build> Window> Window,
then click on a straight or curved wall
to place a Standard Window at that location.

A Standard Window is a single window that
is not a bay, box, or bow window. These
special types are made up of multiple
Standard Windows.

A Standard Window that is part of a special
window is called a Component Window.

Standard Windows can be specified as any of
a variety of window types, such as double
hung, casement and awning. See “Window
Specification Dialog” on page 232.



Bay Windows

The roof is affected by Bay, Box and
Bow Windows. These windows should
therefore be placed before the roof is built.

A Bay Window is composed of three

wall sections, each with a single
component window. The two side walls are
at an angle to the main wall. Select Build>
Window> Bay Window and click on a
straight wall to produce a bay window.

When initially placed, bay windows measure
2°-2” across at the front, 4’-2” across at the
back, and are 1°-0” deep. The component
windows are specified in the Window
Defaults dialog and their sizes adjust to fit
the available space.

e 2-2'
G 42" gy

Box Windows

A Box Window is a bay window with
' Y

side angles set at 90°. Select Build>
Window> Box Window and click on a
straight wall to produce a box window.

Box windows initially measure 4°-2” wide
with a depth of 1°-6”. The component
windows are specified in the Window
Defaults dialog and their sizes adjust to fit
the available space.

16

4om

The Window Tools

Bow Windows

A Bow Window is a group of
identical wall segments that form a
segmented curve. Select Build> Window>
Bow Window and click on a straight wall to
produce a 5-section bow window.

The component windows are specified in the
Window Defaults dialog. Their sizes adjust
to fit the available space.

The 5-section bow below has a 4’-10” radius
centered 3°-9” inside the wall, giving an
opening 5’-10” across and a depth of 11'5”.

Note: Bay, box, and bow window areas are
not included in the living area or in room stan-
dard area calculations. They are included in
room interior area calculations.

Pass-Throughs

Select Build> Window> Pass-

Through, then click on a straight or
curved wall to place a Pass Through at that
location.

A Pass-Through is simply a wall opening
without a window unit placed inside. Like a
window, it can have casing and a sill. It does
not, however, have a sash, frame, or glass. It
is one of the window Types available in the
Window Specification dialog. See “General
Panel” on page 233.
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Wall Niches

Select Build> Window> Wall Niche,
then click on a straight or curved wall
to place a Wall Niche at that location.

A Wall Niche is a wall opening that does not
extend through the entire depth of the wall.
You can specify the niche’s depth in the
Window Specification dialog. See “General
Panel” on page 233.

Windows Library

ﬁﬂul Select View> Library Browser, then
\ browse to Home Designer Core
Catalogs> Architectural> Windows to access
a selection of special window units. Select
the desired window, then click on a wall to
place the window at that location.

Special Windows
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A variety of special windows can be created
using multiple standard windows, the edit
tools or custom symbols.

Creating Manual Bay, Box
and Bow Windows

Sometimes it is easier to draw bay, box and
bow windows manually than to use the
automatic tools. Bays created using walls can
have more than one window per section,
which is not possible using a bay window
unit.

Bear in mind that moving a manually created
bay, box or bow window is generally more
difficult than moving a unit created with one

of the Window Tools H. since it is
composed of individual walls.

Corner Windows

To create a corner window, first create the
desired window on each side of the corner.
For best results, the heights, casing, and sills
of both windows should be the same.

There are a number of ways to control the
size of the corner post.

—

» Use dimensions to position the windows
relative to the corner. By default, win-
dows will stop when their interior casing
bumps into the adjacent wall. See “Edit-
ing Windows” on page 231.

*  To move a window all the way into a cor-
ner, check Ignore Casing for Opening
Resize. See “General Plan Defaults Dia-
log” on page 56.

* To produce a minimal corner post and no
siding or casing between the windows,
use their Move edit handles. Click and
drag each window past the exterior cor-
ner until its preview outline moves into
the middle of the wall corner.



Special Window Shapes

A selection of special shaped windows is
available in the Windows Library, including
arched windows and mulled units.

In addition, you can create a variety of
window shapes in the Window Specification
dialog, including:

¢ Arched windows. See “Arch Panel” on
page 238.

* Trapezoidal windows. See “Shape Panel”
on page 237.

Grouped Windows

Stained Glass

A selection of solid stained glass materials is
available in the Home Designer Core
Catalogs> Materials> Glass library. See
“Materials” on page 367.

Vents

A selection of attic, foundation and gable
vents are available in the Library Browser.
See “The Library” on page 335.

Vents are placed in the same manner as
regular windows and can be edited in much
the same way, as well.

Grouped Windows

Windows can be grouped together to create a
wide variety of custom configurations.
Stacked windows are easy to create in 3D
views using their edit handles. See “Editing
Windows” on page 231.

Notice how the windows and door in this
example are separate, with spaces between
them. Doors and/or windows can also be
positioned so that there are no spaces
between the windows and door units, and the
casing between them appears to be shared.

Automatically Mulled Openings

To form a mulled group of windows and/or
doors, move them close enough together so
that their casings touch. Once the casings
touch, the windows are mulled together with
one casing between the two of them.

The sill of each window in the group must be
at the same level for them to share the middle
casing. The casing tops do not have to be at
the same level. The casings are modeled as if
they are one unit but the windows remain
separate objects for dimensioning and the
Materials List.

Windows can be automatically mulled to
doors if the bottom of the window is at the
elevation of the floor, equal to the bottom of
the door.

Mulled Units in the Library

A selection of mulled window units is
available in the Windows library. To place
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one in your plan, select it and click on a wall
in any view. See “Placing Library Objects”
on page 349.

Selecting Components
of Mulled Units

To select a component of a mulled unit from
the library, click at the location of the com-
ponent in question, then click the Select

Next Object /e edit button or press the Tab
key until that individual component is
selected. Only the component clicked on is
selectable using this method. If you need to
select a different component, click on it and
repeat the process.

If there are multiple levels, it is easiest to
select the components in a 3D view. When
you have selected an individual component,
you can change its parameters in the Window
Specification dialog. See “Window
Specification Dialog” on page 232.

If the selected component is not itself a
mulled unit and has no components above it,
its Height and Arch parameters can be
changed. Changing the Height causes the
component top to move. The bottom remains
stationary.

Displaying Mulled Units

As with other windows, the display of

mulled window units is controlled in
the Display Options dialog. See “Layer
Attributes” on page 87.

Mulled units are placed on the “Windows”
layer by default and have a single label,
which is on the “Windows, Labels” layer.
Mulled units from the library are also
included in the windows category of the
Materials List. If the component objects of a
mulled unit have unique moldings or
materials, they will not be noted in the
Materials List.

Displaying Windows
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The display of windows in floor plan

' and 3D views can be controlled in the
Display Options dialog. See “Display
Options Dialog” on page 88.

Windows can only be placed in walls, so if a
wall’s layer is turned off, any windows
placed in that wall will not display, either.
See “Displaying Walls” on page 144.

If the “Windows” layer is not set to display,
window casing and other components are not

visible, but the openings in the walls where
they are located can still be seen.

In Plan View

A window’s frame, glass, and sill are all
represented in plan view. This makes some
window types, notably Sliding and Double
and Triple Casement windows,
distinguishable.



Double Hung

—=————m= M —e——
Left Sliding

= —— n n ———r——r——r——

— ——

Triple Casement

Window typesin plan view

Bay, box,and bow windows have dimensions
lines associated with them.

* You can suppress their display by turning
off the “Manual Dimensions” layer or on
a unit by unit basis in the unit’s specifica-

Editing Windows

tion dialog. See “Bay/Box and Bow Win-
dow Specification Dialogs” on page 244.

» The arrow style and fill are set in the
Dimension Defaults dialog. See
“Dimension Defaults Dialog” on page
183.

Window Labels

Window labels display in floor plan view,
centered on the windows they represent,
when the “Windows, Labels” layer is turned
on and use the “Default Label Style” Text
Style. Window labels indicate Width and
Height, followed by Type. For example:

* In Imperial plans, the label for a 3°-0”
wide, 4°-0” high double hung window
will read 3040 DH.

* In metric plans, the label for a 900 mm
wide, 1200 mm high double hung win-
dow will read 900x1200 DH.

Editing Windows

Before a window can be edited, it must be
selected. Click on a window when the Select

Objects | tool or any of the Window

Tools H. are active. Doors and/or windows
can also be group-selected and edited. See
“Selecting Objects” on page 94.

To select a window that is part of a blocked
unit, click the component window, then click

the Select Next Object e edit button. See
“Selecting Components of Mulled Units” on
page 230.

Windows can be edited using their edit
handles, the edit toolbar buttons, and the

Window Specification dialog. See “Window
Specification Dialog” on page 232.

When you select a window in plan view, the
window size label displays the width
followed by the height. For example, a 3036
window is 3’-0” wide by 3’-6” high.

In the Specification Dialog

l—l The most precise method of editing a
window is to use the Window
Specification dialog. The window type, size,
casing, materials, and more can all be
specified in this dialog. See “Window
Specification Dialog” on page 232.
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Using the Mouse

In plan view, click either of the two end
handles and drag along the wall to change the
width. The label showing the size updates as
the window is resized.

In 3D views, a selected window has five edit
handles: the Move handle at the center and a
Resize handle on each edge. Click and drag
an edge handle to resize the window.

A single window or a group of windows can
be moved with the center edit handle.

A door or window moved against an
intersecting wall temporarily stops when it is
the casing distance from the intersecting
wall. Enable Ignore Casing for Opening
Resize in the Plan Defaults dialog to turn off
this behavior. See “General Plan Defaults
Dialog” on page 56.

You can continue to drag the selected
window and it will resume movement past
or onto the intersecting wall.

To create a corner window, drag the Move
handle straight out past the wall corner,

parallel to the selected window’s wall. See
“Corner Windows” on page 228.

Using Dimensions

Like various other objects, windows

can be moved using dimensions. See
“Moving Objects Using Dimensions” on
page 192.

By default, dimensions locate the sides of
windows. Once a dimension line has been
drawn, you can move or add its extension
lines to locate the center of a window. See
“Editing Extension Lines” on page 191.

Using the Edit Tools

A selected window or windows can be edited
in a variety of ways using the buttons on the
edit toolbar. See “The Edit Toolbar” on page
24,

* Click the Change Wall Side *# edit but-
ton to move the selected Wall Niche to
the opposite side of the wall. See “Wall
Niches” on page 228.

Window Specification Dialog
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I—l To open the Window Specification
dialog, select a window and click the
Open Object edit button; or double-click the

window using the Select Objects ' or a
Window = tool.

The settings in this dialog are similar to those
in the Window Defaults dialog. See
“Window Defaults” on page 226.

The settings in this dialog are also similar to
those in the Wall Niche, Mulled Unit and
Window Symbol Specification dialogs.
Although similar, a number of the options
cannot be edited when either a window
symbol or a mulled unit from the library is
selected, and some panels are not available.
See “Grouped Windows” on page 229.



Window Specification Dialog

General Panel

In the Wall Niche Specification dialog, only

are available. See “Wall Niches” on page

the Size and Position settings on this panel 228.
™ Window Specification *
General Window Type: Use Default hd o AP i,
Casing lZ‘ Iﬁ!:
Sash Size and Position o
Shape
Arch Heiht:
Treatments Elevation Reference: From Floor =
Shutters

Materials Floor to Top:

Bottom Component Size:

e

® | Exterior

Cancel Help

Window Type - Select the type of
window from the list. The first entry in

the list is the “Use Default”, which is set in
the Window Defaults dialog.

2]

Specify the Size and Position of the
selected window.

Specify the window’s Width and Height.

Select the Elevation Reference from the
drop-down list. This determines where
the next two settings are measured from
and also affects their setting labels.

Specify the height to Top, measured from
the selected Elevation Reference to the
top of the window frame.

Specify the height to Bottom, measured
from the selected Elevation Reference to
the bottom of the window frame.

Specify the Depth of the selected Wall
Niche, measured from the wall surface to

the back of the niche. Only available for
Wall Niches.

to Bottom setting is modified, the other will

Note: When either the Floor to Top or Floor

adjust in response to prevent the window’s
Height from changing.

Specify the Bottom Component Size for
Single Hung, Double Hung, Double
Awning, Double Hopper, and Triple Hop-
per windows; specify the Top/Bottom
Component Size for Triple Awning win-
dows; or,

Specify the Side Component Size for
Triple Casement and Triple Sliding win-
dows, the Right Component Size for
Left Sliding windows, or the Left Com-
ponent Size for Right Sliding and Dou-
ble Casement windows.
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A Component Size value of 0 creates a
window with identically sized components.
9 The Interior Windows settings are
only present when the selected window
is a Pass-Through placed in an interior wall.

See “Exterior and Interior Walls” on page
138.

e Check Separate Trim and Materials for
Each Side to specify the casing and all

materials for each side of the selected
Pass-Through independently. When
unchecked, the two sides use the same

trim and materials.
e A preview of the selected window
displays here. A label indicates which
side of the window is its Interior and which is
its Exterior. See “Dialog Preview Panes” on
page 28.

Casing Panel

The CASING panel is not available in the
Window Symbol Specification dialog.

™ Window Specification

General Use Interior Casing
Casing
Sash Width: (3 1/4" (D)
Lites <ill
Shape
o
Arch RET)
Treatments Use Exterior Casing
Shutters
Materials width: |3 1/2° (D)
sl
Apron

*

O .-oam
(3]

Exterior

Cancel Help

Check Use Interior Casing, then
specify the Width of the casing.

(1]

9 Check Use Exterior Casing, then
specify the Width of the casing.If the

selected window is a Pass-Through placed in

an interior wall, these settings will be

unavailable unless Separate Trim and

Materials on Each Side is checked on the

GENERAL panel. See “General Panel” on

page 233.
e A preview of the selected window
displays here. You may need to rotate
the preview to see the casing you are
editing.If casing is not specified for a Pass-
Through, the Show Wall option will be
toggled on automatically. See “Dialog
Preview Panes” on page 28.



Window Specification Dialog

Sash Panel

The settings on the SASH panel control the
size and position of the selected window’s

sash. Note that increasing the Side, Middle,

Top or Bottom Width decreases the area of
the glass and vice versa.

The SASH panel is not available in the Wall
Niche Specification dialog, and the settings
on this panel are not available for Pass-
Throughs.

™ Window Specification

General Sash

Casing Side Width:
Sash

Lites Middle Width: _1 42" )
Shape Top width:
Arch

Treatments Bottom Width:
Shutters

Materas oep

X
Q. -oAan
(2]

Exterior

Cancel Help

o Specify the width and depth of the

selected window’s Sash, which are the

pieces of the window that hold the glass.
*  Specity the Side Width of all vertical

sash members: those at the window sides
as well as the central members of Case-

ment and Sliding windows. This is also
the width of the top portion of the win-
dow when an arch is specified.

* Specify the Middle width of horizontal

components between the top and bottom
sash in Double Hung, Double and Triple
Awning, and Double and Triple Hopper

windows. It does not affect Casement and
Sliding windows.

*  Specify the Top and Bottom Widths.
The Top value is not used if the window
has an arch.

* Specify the Depth, or thickness, of the
sash stock measured from the exterior to
the interior.

g A preview of the selected window
displays here. See “Dialog Preview
Panes” on page 28.

Lites Panel

The LITES panel allows you to add muntins

to windows, and is also available for Glass
doors. See “Doors” on page 209.

There are four possible styles of muntin bars.

The LITES panel is not available in the Wall
Niche Specification dialog, and the settings
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on this panel are not available for Pass-
Throughs.

™ Window Specification

General Lites

Casing Type: Normal -
Sash

Shope s versc
Arch —

Treatments Lites in Top
Shutters Lites in Bottom
Materials

[] Auto Adjust Lites for Component Size

X
Q. -oAan
(2]

==
=

Exterior

Cancel Help

o Specify the number, position and style
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of Lites for the selected window.

Select a Type, or style, of window lite
from the drop-down list.

Maormal Diamond Frairie Craftsman
Across =3 Across=3 Across =6 Across=4
Vertical=4  Vertical= 3 Vertical = 8 Vertical = 3

Normal style is the most common, with

muntins going horizontally and vertically.
Colonial windows are an example of the

normal style.

Diamond style uses angled muntin bars
to divide up the lites. French windows are
an example of the diamond style.

Prairie style is based on the normal style,
but with all the central muntin bars
removed, leaving only the two outside
muntin bars both horizontally and verti-

cally. Typically, both Lites Across and
Lites Vertical should be set between 6
and 8. Federal or Federation windows are
an example of the Prairie style.

Craftsman style is based on the normal
style, but only the topmost horizontal
muntin bar is kept with all the portions of
the vertical muntin bars above it. Typi-
cally, both Lites Across and Lites Vertical
should be set between 4 and 8.

Enter the number of horizontal Lites
Across in each sash.

Enter the number of vertical Lites Verti-
cal in each sash.

Check or uncheck Lites in Top and/or
Lites in Bottom - or Lites in Left and/or
Lights in Right - to specify either one or
both of the sashes to have divided lites.

Check Auto Adjust Lites for Compo-
nent Size to have the program produce
lites that are consistent in size across all
components. When this is checked, the
window’s lites and its specification set-



tings may not agree; when unchecked,
lites in the components may not be con-
sistent in size.

Note: Because the fixed window in a Triple
Sliding window is twice the size of the mov-
able windows, the fixed section has a vertical
muntin bar. To eliminate this, uncheck Auto
Adjust Lites for Component Size..

Window Specification Dialog

g A preview of the selected window
displays here. See “Dialog Preview
Panes” on page 28.

Shape Panel

The settings on the SHAPE panel control the
position of the selected window’s corners,
allowing you to create angled edges and
mitered top corners.

If any of these settings are used to create a
custom shape, the selected window will be
automatically specified as “Fixed Glass” on
the GENERAL panel. If the selected window

has an arch specified on the ARCH panel, it
will be removed.

The SHAPE panel is not available for mulled
units or window symbols from the library.

Note: The Left and Right settings on this
panel refer to the window’s exterior.

™ Window Specification *
General Window width is: 327 o N =
Casing lZ‘ I|-_|-E
Sash Match Roof Revert Al
Lites ) o
Shape Sides o
Arch Left Right
Treatments Height: |48" | |48"

Shutters
Materials

Exterior

Cancel Help

o Window Width displays for reference.
It can be changed on the  General
Panel.

* Click Match Roof to match the angle of
the top of the window to the pitch of the

roof above by changing its Sides heights,
below. If either Top Inside Corner box is
checked, it will become unchecked.

Match Roof does not work for curved
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roofs, has no effect if the window is not
in a gable end wall, and is not available in
the Window Defaults dialog.

* Click Revert All to restore the window to
its original shape, type and arch settings.

e Specify the height of the window’s Left

and Right Sides, as measured from the
bottom of the window. By default, these
settings match the window’s Height.

e A preview of the selected window

displays here. You may want to rotate
the view so the window’s exterior can be
seen. See “Dialog Preview Panes” on page
28.

Note: The Left and Right settings on this
panel refer to the window’s exterior.

Arch Panel

The ARCH panel is not available for window
symbols from the library, and its settings are

not available if the selected window has been
modified using the Shape Panel.

™ Window Specification

General Arch
Casing Type: |Broken Arch hd

Sash

Lites Heiht:
Shape
Arch
Treatments
Shutters
Materials

X
Q. -oAan
(2]

Exterior

Cancel Help

o Define the style and size of the Arch.

» Select the Type of arch desired from the
drop-down list.

Round Broken Gothic
Top

* Specify the Height of the arch, as mea-
sured from the top of the window to the
base of the arch. The Height can be
defined for all arch types except Round
Top and Octagonal Arches.

e A preview of the selected window

displays here. You may want to rotate
the view so the window’s exterior can be
seen. See “Dialog Preview Panes” on page
28.



Window Specification Dialog

Note: The Left and Right settings on this
panel refer to the window’s exterior.

Treatments Panel

The settings on the TREATMENTS panel allow The TREATMENTS panel is not available in
you to add embellishments to the interior and the Wall Niche and Window Symbol

exterior of the selected window or mulled Specification dialogs.
unit.
™ Window Specification *
Curtai
Gen.eral LEiE o - lZ‘ I|“|‘E
Casing Style: Pendil = Library...
Sash
Lites Height OFF Floor: ©
shape Height Above Casing:
Arch
Treatments Blinds
Shutters o
Materials Style: Use Default hd Library...
Label
Interior
Cancel Help

0 Specify Curtains for the selected »  Specify the Height Off Floor of the bot-
window or mulled unit’s interior side. tom edge of the curtains.

* Specify a style of Curtains by selecting » Specify the Height Above Casing of the
“Use Default”, “None” or “Library” from top of curtains.
the drop-down list. If a non-default
library item has been selected, its name
will display in the list, as well.

+  Click the Library button or select e A preview of the selected window
“Library” from the drop-down list to displays on the right. You may want to

choose a style of curtain from the library rotate the view so the window’s interior or
See “Select Library Object Dialog” on exterior can be seen, as needed. See “Dialog
Preview Panes” on page 28.

e Specify a style of Blinds in the same
manner that Curtains are chosen, above.

page 350.
Shutters Panel
The settings on the SHUTTERS panel allow selected window or mulled unit from the
you to specify exterior shutters for the library.
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The SHUTTERS panel is not available in the
Wall Niche and Window Symbol
Specification dialogs.

(1]
(2]
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™ Window Specification

General Shutters

Casing
Sash
Lites Size
Shape
Arch
Treatments
Shutters
Materials

Type:  Louvered hd

Match Opening Width
Match Opening Height

Position
@ On Casing
(O Outside Casing

Options

|:| Reverse Direction

*

Q. -oAan
2] (5]

Exterior

Cancel Help

Select a Type of Shutters from the
drop-down list.

Specify the Size of the selected
shutters.

When Match Opening Width is
checked, each shutter’s width is exactly

half that of the window, excluding casing.

Uncheck Match Opening Width to
specify a Width in the text field. If the
window is later resized, the shutters will
not adjust in response.

When Match Opening Height is
checked, each shutter’s height equals that
of the window, excluding casing.

Uncheck Match Opening Height to
specify a Height in the text field. If the
window is later resized, the shutters will
not adjust in response.

(3]

Specify the Position of the shutters
relative to the window.

Select On Casing to position the shutters
just outside the window frame, like func-
tional shutters.

Select Outside Casing to position shut-
ters outside the window casing, as deco-
rative shutters often are.

Additional shutter Options can be
specified here.

Check Reverse Direction to orient the
shutters so their exterior sides face out-
ward and their interior sides face the
wall. For functional shutters, this should
remain unchecked.

e A preview of the selected window

displays on the right. In order to see the

shutters, you may need to rotate the preview

to show the Exterior. See “Dialog Preview
Panes” on page 28.



Materials Panel

The settings on the MATERIALS panel are the
same as those found on the same panel in
dialogs throughout the program. See
“Materials Panel” on page 372.

Bay, Box, and Bow Windows

Manufacturer Panel

The MANUFACTURER panel provides contact
information for the selected window’s
manufacturer. Only available for windows
from Manufacturer library catalogs. See
“Manufacturer Catalogs” on page 341.

Bay, Box, and Bow Windows

—.| Bay, Box and Bow Windows
ALRLS are created much the way
regular windows are: select a tool, then click
a wall to place that window type.

Home Designer Interiors automatically
builds a foundation under bay/box/bow
windows placed on floor 1 unless they are
raised from their original position. That
section of the foundation wall is also a bay/
box/bow, but without windows. If the
foundation was generated before the window
is placed, the foundation must be rebuilt or
edited manually.

Editing Bay, Box and
Bow Windows

Bay, box, and bow windows are edited
similar to regular windows with one
exception: in plan view, a diamond-shaped
Depth edit handle displays on the section.
Drag this Depth handle outward to increase
the depth, or inward to decrease the depth of
the unit. See “Editing Windows” on page
231.

B o (i
Ll

Depth edit handle on a bay window

Bay, box and bow windows can also be
edited in their respective specification
dialogs. See “Bay/Box and Bow Window
Specification Dialogs” on page 244.

Displaying Bay, Box
and Bow Windows

The display of bay, box and bow windows is
controlled in the Display Options dialog.
See “Display Options Dialog” on page 88.

Like other windows, bay, box and bow
windows can display labels: either a single
label for the unit, or one for each component.
See “Window Labels” on page 231.

Bay, box and bow window width and radius
dimensions, which display in plan view
when specified to do so in the window’s
specification dialog, are placed on the
“Dimensions, Manual” layer. See “Options
Panel” on page 246.
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Component Windows

A component window within a bay, box or
bow window can be resized like any other
standard window. To select a component
window, click at the location of the
component in question, then click the Select

Next Object ifex edit button or press the Tab
key.

*  Only the bay or box window component
that was clicked on is selected using this
method. If you need to select a different
component, click on it and repeat the pro-
cess.

* In a bow window, all components are
identical, so only one component can be
selected. Changing this component
changes them all.

Resizing Components

An individual component window can be
resized using the edit handles, by changing
settings in the component’s Window
Specification dialog.

When a bay/box/bow window is first created,
there is room for one standard trimmer on
each side of each component window. When
the bay as a whole is moved and resized, its
components automatically resize so that a
standard trimmer is still accommodated.

If a component window is resized, it retains
its size if at all possible when the containing
bay/box/bow window is moved or resized. If
the bay is resized in such a way that the
component is too large to fit even with a
thinner trimmer, the component resumes its
default behavior, resizing as the containing
bay window is resized.

Floors and Ceilings

When originally created, the floor and
ceiling within a bay, box, or bow window are
the same heights as the floor and ceiling of
the room in which it is placed.

Both the top and bottom heights of these
window units can be adjusted in its
specification dialog or a 3D view using its
edit handles to create a lowered ceiling and/
or a bench seat or garden window.

72"

24"

When the ceiling is lowered, the top heights
of the walls that define the window unit are
also lowered. When a roof is built over the
unit, its height will be affected, as well.

When the bottom of the window is raised to
create a bench seat, the unit’s walls will not



reach the ground. As a result, window units
with bench seats will have no foundation
beneath them when the foundation is built.

Bay, Box, Bow Windows and Roofs

Several different roof styles can be specified
for bay, box and bow window units in the
Bay/Box/Bow Specification dialog. See
“Bay/Box and Bow Window

Specification Dialogs” on page 244.

If you change a bay, box, or bow window’s
roof specification, you will need to rebuild
the roofs to see the changes. See “Rebuilding
Roofs” on page 323.

Hip Roofs

By default, a hip roof is built above the unit
when roofs are automatically generated. No
roof directives need to be selected in the
specification dialog to produce this roof.

Use the Existing Roof

To generate a standard roof that ignores a
bay, box, or bow window, check Use
Existing Roof.

Bay, Box, Bow Windows and Roofs

With this option the bay, box, or bow
windows is tucked under the roof eave. You
may find it helpful to increase the width of
the eaves. See “Roof Panel” on page 324.

Extend the Existing Roof

To have the main roof extend down over the
window unit and follow the shape of the unit,
select Extend Existing Roof.

For this roof style, the ceiling heights of the
window unit and the adjacent room must be
the same. If you lower the ceiling of the
window unit and then build the roof, a lower
hip roof over the window is created. See
“Floors and Ceilings” on page 242.
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If a header is desired over the window unit, Extend Existing Roof -
first build the roof, then lower the ceiling of Rectangular

the window unit. Do not rebuild roof planes.
To extend the main roof down over a window

Rectangular Hip Roofs unit to create a rectangular roof over it rather
than one that follows its shape, select both
To create a rectangular-shaped hip roof Extend Existing Roof over and
above a bay, box, or bow window, select Rectangular Roof Over.

Rectangular Roof Over.

Gable Roof

A gable roof is not one of the automatic
options for the roof above a bay, box or bow
window.

Bay/Box and Bow Window Specification Dialogs

l—l To open the Bay/Box Window The options in this dialog can only be set for
Specification or the Bow Window objects placed in a plan: Bay, Box, and Bow

Specification dialog, select a Bay, Box or Windows do not have defaults dialogs.

Bow Window and click the Open Object

edit button.
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Bay/Box and Bow Window Specification Dialogs

General Panel

™ Bow Windaw Specification

Floor

ight Raised:

General Size
Materials
Depth: 115/18"
Ceiling

[] Has Lowered Ceiling

[] Has Raised Floor

Cancel Help

@ © O

Size - Specify the Width and Depth of
the selected Bay, Box, or Bow Window.

9 Specify the height and structure of the
Ceiling within the selected window.

* Check Has Lowered Ceiling to enable
the settings that follow. When this is
unchecked, the ceiling height and finish
material within the window is the same as
that for the adjacent room.

* Specify the Height Lowered, which is
measured from the ceiling height of the

adjacent room.

Note: If the Height Lowered is 0”, Has Low-
ered Ceiling will become unchecked when
you click OK.

e Specify the height and structure of the

Floor within the selected window.

Check Has Raised Floor to enable the
settings that follow. When this is
unchecked, the floor height and material
within the window is the same as that for
the adjacent room.

Specify the Height Raised, which is the
measured from the floor height of the
adjacent room.

Note: If the Height Raised is 0", Has Raised
Floor will become unchecked when you click
OK.
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Options Panel

™ Bow Windaw Specification

Roof
[] Use Existing Roof

General
Options
Materials

Dimensions

[] Extend Existing Roof Over
[] rectangular Roof Over

[] misplay Standard Dimensions
|:| Display Dimensions to Center

*

Cancel Help

o Specify the structure of the Roof over
the selected window unit. See “Bay,
Box, Bow Windows and Roofs” on page 243.

* Check Use Existing Roof if the existing
roof needs no changes to accommodate
the bay window.

* Check Extend Existing Roof Over to
extend the existing roof plane to cover
the bay window below.

* Check Rectangular Roof Over to create
a roof over the bay window that is square
across the end instead of following the
profile of the roof.

2]

view.

Specify the appearance of the selected
window unit’s Dimensions in plan

* Check Display Standard Dimension to
display the automatically-produced
dimensions that show the window’s
width and depth.

* Check Display Dimensions to Center to
display a Bow Window’s radial dimen-
sion.

Materials Panel

The settings on the MATERIALS panel are the
same as those found on the same panel in
dialogs throughout the program. See
“Materials Panel” on page 372.



With Home Designer Interiors’s cabinet tools
you can create base, wall, and full height
cabinets as well as soffits, shelves and
partitions. These objects are very versatile,
allowing for a wide range of customization.

A selection of cabinet door and drawer styles
are available in the Library Browser.

Home Designer Interiors also has many
customized cabinet symbols and cabinet
groups available in the library.

Chapter 17:

Cabinets

Chapter Contents
Cabinet Defaults
The Cabinet Tools
Cabinet Fillers
Placing Cabinets
Displaying Cabinets
Editing Cabinets
Editing Cabinet Styles
Special Cabinets
Cabinet Specification Dialog
Shelf/Partition Specification Dialog
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Cabinet Defaults

@ There are several defaults dialogs for

cabinets. Access Default Settings by
selecting Edit> Default Settings, then
clicking the arrow beside “Cabinets”. Select
a subheading and click the Edit button to
open the defaults dialog associated with your
selection.

Each type of cabinet object has default
definitions for size, style, materials and
more. In fact, the default dialog for each
cabinet type is similar to its corresponding
specification dialog. For descriptions of
these settings, see “Cabinet Specification
Dialog” on page 257, “Shelf/Partition
Specification Dialog” on page 263 and
“Soffit Specification Dialog” on page 364.

General Cabinet Defaults

The General Cabinet Defaults dialog can be
accessed only from the Default Settings
dialog.

r\ General Cabinet Defaults

Minimum Cabinet Width:

Cabinet Resizing
(O Use Grid Snaps

(®) Use Resize Increment:

00

Cancel Help

o Specify the Minimum Cabinet Width.
The minimum allowable width is 1/16
of an inch (10 mm).

Specify how Cabinet Resizing takes
place when the edit handles are used.

(2]

* Select Use Grid Snaps to resize cabinets
using Snap Grid increments. See “Grid
Snaps” on page 79.

» Select Use Resize Increment to resize
cabinets using the increment specified
here.

¢ Set the Resize Increment at which cabi-
nets resize. The minimum allowable
increment is 1/16 of an inch (10 mm).

The Cabinet Tools
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Select Build> Cabinet to access the
Cabinet Tools.

Cabinets are easily created with a single click
in floor plan view or any camera view. See
“Click-to-Create” on page 80.

Typically, groups of cabinet objects are
positioned closely together and arranged to

form work spaces, and there are some special
behaviors and techniques to be aware of. See
“Placing Cabinets” on page 251.

Once created, cabinets, soffits, shelves,
partitions and fillers can be selected and
edited much like other box-based objects.
See “Editing Cabinets” on page 253.



Base Cabinets

@ Select Build> Cabinet> Base

Cabinet and click in any view. Base
cabinets can be placed directly under wall
cabinets and generate a countertop and toe
kick by default.

Wall Cabinets

To place a wall cabinet, select Build>

Cabinet> Wall Cabinet and click in
any view. Wall cabinets can be placed
directly over base cabinets.

Full Height Cabinets

To place a full height cabinet, select
Build> Cabinet> Full Height and
click in any view. Full height cabinets
generate a toe kick by default and cannot be
placed on top of other cabinets.

Soffits

E’a Soffits typically fill the space between
cabinet tops and the ceiling, but can
also be used to create any object that can be
modeled as a 3D box. To place a soffit, select
Build> Cabinet> Soffit and click in any

view.

By default, soffits use the material assigned
to interior walls in the Material Defaults
dialog. Like cabinets, soffits can have
molding profiles applied to them.

For more information about using soffits for
a variety of purposes, see “Other Objects” on
page 361.

The Cabinet Tools

Shelves

== Select Build> Cabinet> Shelf and
click in any view to create a shelf.

Create corner shelves by placing one shelf on
each wall, then moving or stretching them
until they touch.

Once created, shelves can be selected and
edited. See “Shelf/Partition Specification
Dialog” on page 263.

Partitions

E' Select Build> Cabinet> Partition
I button and click in any view to create
a vertical partition.

Like shelves, partitions can be selected and
edited after they are placed.

Partitions can be used with shelves to create
complex storage systems.

Cabinet Library Catalog

:ﬂll'-_ In the Library Browser, browse to

Y Home Designer Core Catalogs>
Architectural> Cabinets to access a selection
of specialty cabinets. Select the library object
you want, then click in any view to place it in
the plan. Once placed, library cabinets can be
edited. See “The Library” on page 335.

Cabinet Doors, Drawers,
and Panels Catalog

:ﬂll'-_. A selection of cabinet door, drawer,

U and panel styles is available in Home
Designer Core Catalogs> Architectural.
Select an item, then click on a cabinet in your
plan to place the door or drawer onto that
cabinet. Doors, drawers, and panels can be
assigned to a cabinet in its specification
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dialog, as well. Cabinet doors, drawers, and
panels can also be placed as stand-alone
fixtures.

Built-In Sinks and Appliances

A variety of fixtures and appliances such as
sinks, cooktops, and dishwashers can be
placed into cabinets. See “Inserted Objects”
on page 350.

@ Place fixtures and appliances into cabi-
"€ nets early, so that any resizing can be
done while there is adequate free space.

To insert a fixture into a cabinet, select the
fixture in the Library Browser, then click on
a cabinet. There must be enough space in the
cabinet or adjoining cabinets to contain the
selected fixture.

If a sink or cooktop is inserted into a cabinet
with a top Drawer or Double Drawer, its Item
Type will automatically change to a False
Drawer or False Double Drawer.

Once placed, an inserted fixture can be
selected and edited:

* To select a fixture in a cabinet top, click
on it and then click the Select Next

Object i edit button. See “Select Next
Object” on page 95.

» Front fixtures can only be modified or
deleted in the Cabinet Specification dia-
log. See “Front Panel” on page 259.

& Fixtures can be added to both the top
and front of the same cabinet. It is up to
you to determine which can be effectively and
safely combined in the real world.

Electrical Switches and Outlets

Electrical switches and outlets placed within
the backsplash area of a base cabinet will
display in front of the backsplash in 3D
views when the “Electrical” layer is turned.
See “The Electrical Tools” on page 266.

Cabinet Fillers

250

Home Designer Interiors models a
continuous countertop and generates fillers
automatically when cabinets of the same
height are either touching or placed with 3”
(75 mm) of one another.

If two cabinets meeting at a corner are
separated from each other by 3” (75 mm) or
less, the program will automatically generate
a filler in the angle between them. A filler is
used to separate the front of one of these

cabinets from the one it meets so that
drawers and doors have room to operate.

| BLBDLAD3S

Two base cabinets and the filler between them



Placing Cabinets

Placing Cabinets

Cabinets are easily created with a single click
in any view. See “Click-to-Create” on page
80.

When used near a wall corner, the Cabinet
Tools will produce corner cabinets and
soffits. See “Corner Cabinets” on page 255.

When created, cabinets are positioned
relative to the floor of the room in which they
are placed. Base and full height cabinets
typically rest on the floor while wall cabinets
are placed a set distance above the floor. See
“Cabinet Defaults” on page 248.

If the ceiling height of the room does not
accommodate the height of a cabinet, its
Floor to Bottom value will be retained and
its Height will be reduced so that it fits under
the ceiling. When this happens, some front
items may be removed from the cabinet if
there is not enough room for them. See
“Front Panel” on page 259.

Because cabinets are typically organized into
groups with shared attributes, they have
some special behaviors.

Cabinet Snapping and Aligning

Cabinets have several special snapping and
aligning behaviors which help you create

precisely aligned cabinets quickly and easily.

*  When Base and/or Full Height cabinets
are within 3” of one another’s sides, they
will snap together. Wall cabinets snap in a
similar manner, but only with other Wall
cabinets.

*  When Base and/or Full Height cabinets
are within 3” of one another’s sides and
their front or back surfaces are within 3”

of aligning, they will become aligned.
Wall cabinets snap in a similar manner
with other Wall cabinets as well as Full
Height cabinets.

*  When a Base and/or Full Height cabinet
is placed against the back of another Base
or Full Height cabinet, its back surface
will automatically face the other cabinet’s
back. Wall cabinets snap in a similar
manner with other Wall as well as Full
Height cabinets.

*  When a cabinet is placed against a wall,
its back and/or side will snap to the wall
and, if the wall is moved, the cabinet will
move with it.

When cabinets are snapped to a wall or to
other cabinets, only exposed end cabinets
have side counter overhangs.

Cabinet snapping and aligning occurs even
when Object Snaps are turned off; however,
you can override this behavior by moving a
cabinet into the desired position using
dimensions. See “Moving Objects Using
Dimensions” on page 192.

Cabinet Merging

When cabinets of the same height and type
are placed side-by-side within 3” (30 mm) of
one another they will automatically merge,
making any shared components such as the
toe kick, countertop, backsplash, and
moldings continuous. Any gap between
merged cabinets will be automatically filled.

The exposed ends of merged cabinets have
side counter overhangs.
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Cabinets placed at different angles will also
merge if they face toward one another and
meet at a front corner. Cabinets that meet at a
back corner will also merge provided that
they face away from one another at an angle
no greater than 87°. In either case, a filler is
created in the angle between the two.

If the side of a cabinet is placed within 3” (30
mm) of a wall, the countertop will extend to
the wall and a filler will be created.

Base and Wall Cabinets

Base and wall cabinets have different default
heights, so they can be placed directly above
or below one another without interference.
You can use Object Snaps to center a wall
cabinet’s back center point above that of a
base cabinet, or vice versa. See “Click-to-
Create” on page 80.

Minimum Cabinet Size

If you try to place a cabinet into a space that
is too narrow for its default size, the program
will place a smaller cabinet with a width that
is a multiple of the default Resize
Increment. For example, if you try to place a
24” wide cabinet in a 20” wide space and
your Resize Increment is 3”, the program
places an 18” cabinet. See “General Cabinet
Defaults” on page 248.

If you try to place a cabinet into a space
narrower than the default Minimum
Cabinet Width, a cabinet will not be placed.
If, for example, you have a space that is 8”
and your Minimum Cabinet Width is 97, no
cabinet is placed.

Displaying Cabinets
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The display of the various cabinet

- object types, labels, module lines,
door opening indicators and more is
controlled in the Display Options dialog.
See “Layer Attributes” on page 87.

Like other objects, cabinets are placed in
Drawing Groups that affect whether they
display in front of or behind other objects in
floor plan view. By default, wall cabinets,
soffits and shelves are drawn in front of base
and full height cabinets and partitions.You
can modify a selected cabinet’s place in the
drawing order by clicking the View Drawing

Group Edit Tools ™ edit button. See
“Drawing Group Edit Tools” on page 89.

Objects assigned to cabinets, including
hardware and moldings, are located on the
same layer as their parent object. They
display in 3D views, but are not shown in
floor plan view. There are two notable
exceptions: countertops and doors/drawers.

» Countertops are drawn on the “Cabinets,
Countertops” layer in all views.

» Cabinet doors and drawers are drawn on
the “Cabinets, Doors & Drawers” layer in
all views, but only display in 3D views.

By default, cabinet module lines display in
floor plan view when cabinet objects of the
same type are placed side by side. If you
prefer that these lines not display, turn off the
“Cabinets, Module Lines” layer. You can



also specify whether module lines are full or
partial.

You can also display cabinet front indicator
arrows in floor plan view by turning on the
“Cabinets, Front Indicators” layer.

Editing Cabinets

Cabinet labels display in floor plan view
when the “Cabinets, Labels™ layer is turned
on and use the “Default Label Style”.

In 3D views, cabinet doors and drawers are

drawn on the “Cabinets, Doors & Drawers”

layer, and their display can be turned on and
off.

Editing Cabinets

Cabinets can be selected in 2D and 3D views
and edited using the edit handles, the edit
toolbar and their specification dialog.

=+~ You can marquee-select cabinets of
@ multiple types when the Full Height
Cabinet tool is active. See “Marquee Select”
on page 95.

Using the Mouse

Cabinets can be edited like other box-based
objects. See “Editing Box-Based Objects” on
page 106. The edit handles that a cabinet
displays when selected will vary depending
on the view.

When a cabinet is selected in floor plan view
or on its top surface in a 3D view, ten edit
handles display: the Move handle at the
center, the Rotate handle, and a Resize
handle on each edge and at each corner.

In 3D views, cabinets can be selected on any
surface: front, side, back or top. When the
side of a cabinet is selected, five edit handles
are available: the Move handle and a Resize
handle on each edge.

_ |

In the Specification Dialog

I—l A selected cabinet can be customized

in a variety of ways in its specification
dialog. See “Cabinet Specification Dialog”
on page 257.

Using the Edit Tools

A cabinet or cabinets can be edited in a
variety of ways using the buttons on the edit
toolbar. See “The Edit Toolbar” on page 24.

Add to Library

Cabinets can be saved in the Library
Browser. Select a base, wall or full height
cabinet or cabinet filler and click the Add to
Library edit button. See “Add to Library”
on page 345.
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Using Dimensions

Like various other objects, cabinets

can be moved and resized using
dimensions. See “Moving Objects Using
Dimensions” on page 192.

Dimensions locate the sides and/or corners of
cabinet boxes. If you wish, you can move a
dimension’s extension lines to locate the
centers or countertop edges in floor plan
view after the dimension line is drawn. See
“Editing Extension Lines” on page 191.

Moving Walls with
Cabinets Attached

When a cabinet is placed or moved against a
wall, it will snap to the wall and become
attached to it. When a wall is moved, all
attached cabinets move with it.

Moving a wall to an unattached cabinet will
not attach the cabinet to it: the cabinet must
be moved to the wall.

Editing Cabinet Styles

254

A variety of settings allow you customize the
appearance of your cabinets to create styles
ranging from traditional to contemporary.

If the desired style is known before cabinets
are placed, you can save time by specifying
that style in the Cabinet Defaults dialogs
before you start drawing. See “Cabinet
Defaults” on page 248.

Cabinet Face Items

A variety of different face items can be
added to the front of any cabinet, including
doors, drawers, cutting boards, and
horizontal separations. Face items can be
moved, resized, as well as removed and can
also be split vertically or horizontally to
produce a variety of custom configurations.
See “Front Panel” on page 259.

When adding, removing, or resizing face
items, it is helpful to keep a few rules in
mind:

*  When the overall height of a cabinet or
the height of a face item is changed, the
height of the lowest face item that is not a

Separation is adjusted to accommodate
the change.

* Ifyou increase the height of the lowest
face item, the non-Separation item
directly above is adjusted; if you decrease
its height, a Blank Area and Separation
are created below it.

Note: To ensure that Face Item heights
always equal the total cabinet front height,
the program automatically adjusts the bottom
Face ltem as changes are made elsewhere.
This means you should start editing Face

Items at the top and work down.

Doors, Drawers and Panels

Cabinet doors, drawers, and panels can be
applied in either of two ways:

» In the Cabinet Specification dialog. See
“Door/Drawer Panel” on page 262.

* Directly from the Library Browser.
Select a style in the Library, then click on a

cabinet to apply the selected style to that
cabinet. See “Replace From Library” on




page 351.

Cabinet Hardware
and Moldings

Cabinet handles, pulls, and hinges can be
assigned in the Cabinet Specification

dialog. See “Door/Drawer Panel” on page
262.

Multiple molding profiles can also be applied

around the perimeter of a cabinet at any
height. For example, you may want a wood
edge around base cabinet countertops and a
crown molding that ties together the tops of
the wall cabinets and full height cabinets.
See “Moldings Panel” on page 180.

Special Cabinets

Wall cabinet with crown molding and light rail

Countertops and Backsplashes

The countertop thickness, overhang, and
material for a selected base cabinet can be
specified in the Cabinet Specification
dialog. See “General Panel” on page 258.

Backsplashes can be applied to base cabinets
as well as down from wall cabinets on the
GENERAL panel of their specification dialogs.

Special Cabinets

There are a number of special cabinet shapes
that can be specified. Certain requirements
must be met before some special cabinet
shapes can be specified. If the requirements
are not met, a warning message will explain
what is needed. See “Cabinet Specification
Dialog” on page 257.

Standard Cabinets
Select Build> Cabinet> Base Cabinet [T

and click in floor plan view to place a
standard, rectangular base cabinet.

Sandard (default) cabinet

Corner Cabinets

To create a corner cabinet, click as close to
an inside wall corner as possible in using
cither the Base Cabinet [T , Wall Cabinet

[, or Full Height cabinet tool. A
corner cabinet remains a corner cabinet when
it is moved, edited or copied.

255



Home Designer Interiors 2019 Reference Manual

256

You can turn an existing cabinet into a corner
cabinet by selecting “Corner” from the
Special drop-down list in its specification
dialog. See “General Panel” on page 258.

+ Before a corner cabinet can be specified
in the Cabinet Specification dialog, the
cabinet’s Width must be greater than its
Depth.

* The Left and the Right Side Widths can
be set independently for corner cabinets.

| CED4EE
B

Corner cabinet with sides of equal width

*  You can specify a Diagonal Door on cor-
ner cabinets to create an angled corner
cabinet. See “Front Panel” on page 259.

Corner cabinet with diagonal door
End Cabinets

Open a cabinet for specification and select
Left or Right End Cabinet from the Special
drop-down list to create an end cabinet.

Left End Cabinet
* End Cabinets have an angled front and
side.

e The cabinet width must be no greater
than its depth for an end cabinet to be
specified.

Radius End Cabinets

Open a cabinet for specification and select
Right or Left Radius End from the Special
drop-down list to create a radius end cabinet.

Radius End cabinets have a 90° arch

As you face the cabinet, a right radius end
curves to the right, and a left radius end
curves to the left.

Peninsula Radius Cabinets

Open a cabinet for specification and select
Peninsula Radius from the Special drop-
down list to create peninsula radius cabinet.



Peninsula Radius Cabinet

Kitchen Islands

To create a kitchen island, simply place
several cabinets back-to-back and/or side-to-
side. Match the widths so that each cabinet
back or side meets the back or side of only
one other cabinet. If this is not done, the lines
separating the cabinets cannot be suppressed.

A given side of a single cabinet cannot merge
with the edges of two different cabinets. The
example below shows two instances of
cabinets placed back-to-back. Cabinet fronts
and joining surfaces are shown.

Cabinet Specification Dialog

Correct - Incorrect -
W dths of front and Solid line here is not
back cabinets match suppressed.

Blind Cabinets

Often, when two cabinets meet in a corner,
one is partially hidden by the other. This
partially hidden cabinet is called a “blind”
cabinet. Home Designer Interiors will resize
and offset the front items of the partially
hidden cabinet so that they are not located in
the hidden portion of the cabinet face.

| 6LenRanas |
|

BLBEDA0EE

Cabinet Specification Dialog

I—l Select a cabinet and click the Open
Object edit button to open the
Cabinet Specification dialog.

The options in the Cabinet Specification
dialogs are similar to the corresponding
Cabinet Defaults dialog. See “Cabinet
Defaults” on page 248.
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General Panel

™ Base Cabinet Specification *
o o ® inme
Door/Drawer
Meoldings Size [Position o o
Materials Height: Induding Countertop
Depth:
Elevation Reference: From Floor =
Floor to Top:
Floor to Bottom: .
Countertop o -
Thickness:
Overhang: Uniform
Front [1"(D) |Back [1"(D) |Left 1"(D) | Right 1"(D)
Backsplash o
Height:
Thickness:
Options: [ side [] Always Present
Options e
Corner: Diagonal Door Lazy Susan
Cancel Help

0 A number of Cabinet Types are

available in the drop-down list. Certain
requirements must be met before some types
can be specified. See “Special Cabinets” on
page 255.

Note: Height refers to the height of the entire
cabinet, including countertop and toe kick. If
you change the Countertop Thickness or Toe
Kick Height, the cabinet’s total height is not
altered. Instead, the cabinet face height and
the heights of face items change in response.

Size/Position - The selected cabinet’s

dimensions and position relative to the
floor can be specified here. Fractional values
are supported to 1/16th of an inch (1 mm).

e Specify the Width of the cabinet box, as
measured across the front of the cabinet
box from left to right. This does not

+ Specify the Height (Including Counter) include the countertop overhang.

of the cabinet box, as measured from bot-
tom to top. For base cabinets, this value
includes the countertop thickness, but not
the height of the backsplash.

*  Specify the Depth of the cabinet box, as
measured from front to back. It does not
include the thickness of overlay doors or
the countertop overhang.



¢ For Corner cabinets, the Width and
Depth fields are instead named Right
Side Width and Left Side Width.

* Select the Elevation Reference from the
drop-down list. This determines where
the next two settings are measured from
and also affects their setting labels.

* Specify the to Top distance, measured
from the Elevation Reference to the top
of the cabinet’s countertop.

*  Specity the to Bottom distance, mea-
sured from the Elevation Reference to the
bottom of the cabinet, including the toe
kick.

9 Specify the dimensions and style of the
Countertop here. Only available for
base cabinets.

* Specify the countertop Thickness.
Changing this value does not alter the
cabinet height, but it does affect the
height of face items. See “Front Panel”
on page 259.

* Specify the countertop Overhang.
Uncheck Uniform to specify separate
values for each side in the fields below, or
leave it checked to use the same value for
all sides. Overhangs do not generate on
sides that are against a wall or another
cabinet. See “Cabinet Snapping and
Aligning” on page 251.

e The dimensions and style of the
Backsplash are specified here. Only
available for base cabinets.

Cabinet Specification Dialog

» Specify the backsplash Height and
Thickness.

e Check Side to add the backsplash to the
side of the cabinet if it is against a wall or
a taller cabinet. Not available for Corner
cabinets.

* Check Always Present to display the
backsplash at all times. If unchecked, a
backsplash is present only when the cabi-
net is against a wall.

* Check Backsplash to Base Below to
extend a backsplash from the selected
wall cabinet down to the backsplash or
countertop of the base cabinet below.
Only available for wall cabinets.

Note that while a base cabinet’s backsplash is
measured from the countertop up, a wall
cabinet’s backsplash extends downward.

e Options -

¢ Uncheck Diagonal Door to create double
doors at right angles instead of a single
diagonal door. This option is checked by
default in the Cabinet Defaults dialog
and is only available for Corner Cabinets.
See “Corner Cabinets” on page 255.

* Check Lazy Susan to indicate a lazy
Susan in the cabinet’s label and its
appearance in floor plan view. This
option does not display in 3D views.

G A preview of the selected cabinet
displays on the right side of the panel.
See “Dialog Preview Panes” on page 28.

FrRONT Panel

If you click on a cabinet face item in the
preview on the right side of the dialog, the

Front panel will become active and that face
item will be selected.
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If the selected cabinet was originally created
in Chief Architect, some settings on this
panel may display for reference only.

™ Base Cabinet Specification

General Face Items

Front [ use Default

Door/Drawer i

Moldings Add MNew... Move Up
Materials

Item Type: | Door - Auto Right hd
Item Height:
Item Width: |22 12
[ Lock from Auto-Resize
Indude Shelves

Options

Reverse Appliance(s)

Move Down Delete o

*

QO L omem

Cancel Help

0 Most of the Face Items settings are
only active when a door, drawer, or
other face item is selected.

* Check Include Shelves to include
shelves in the selected “Door” or “Open-
ing” face item.

To select a face item, click on it in the
preview on the right. When a face item is
selected, Use Default will be unchecked; it is
highlighted in the list as well as in the
preview; its attributes can be edited; and the
list can be navigated using the arrow and
number keys. The vertical frame pieces on
the sides of the cabinet front are referred to
as stiles and cannot be selected in the
preview. See “Cabinet Face Items” on page
254,

* A numbered tree list of face items dis-
plays here. Item numbers start at the top

of the cabinet and go down the face to the
bottom of the cabinet. Item 1 is usually
the top face frame Separation, or rail. The
selected face item is highlighted; if no
item is selected, the “Vertical Layout Par-
ent” heading will be highlighted.

Click Add New to add a new face item
directly below the currently selected
item. When a face item is added, the
height of the lowest item on the cabinet
front is reduced to make room for the
new item. If you click Add New with no
face item selected, the new item is added
to the bottom of the cabinet face.

In the New Cabinet Face Item dialog,
define the Item Type, Item Height, and
click OK. If the Item Type is “Separa-
tion”, you can check Default to use the
default Separation Height.



™ Mew Cabinet Face ltem e

Item Type: | Blank Area hd

Item Height: Default
Mumber Style. .. Cancel Help

* Click Delete to remove the selected face
item. When an Auto Left, Auto Right,
Left, Right, or Double Door is deleted, it
is replaced by an Opening; when other
face item types are deleted, the height of
the lowest item is increased to make up
the difference. You can also press the
Delete key on the keyboard.

Cabinet Specification Dialog

Note: If the Height of an Appliance is
changed, you can enter a “d” to restore its
default height. See “Built-In Sinks and Appli-
ances” on page 250.

iy The program tries to maintain a single
@ separation between all face items.
When you add or delete a face item, separa-
tions are usually added or deleted with them.

* Click Move Up to move the currently
selected item up one position, switching
places with the item directly above.

* Click Move Down to move the currently
selected item down one position, switch-
ing places with the item directly below.

¢ Choose the selected face item’s Item
Type from the drop-down list:

* Specify the selected face item’s Item
Height. Fractional values are supported
to 1/16th of an inch (1 mm). For doors
and drawers, this is the height of the
opening rather than the item front height.
For best results, edit face item heights
starting at the top of the cabinet and work
down. See “Cabinet Face Items” on page
254.

* Check Lock from Auto Resize to pre-
vent the selected face item from resizing
when the cabinet is resized.

¢ The selected item’s Item Width displays
here for reference only. For doors and
drawers, this is the width of the opening
rather than the item front width.

* Check Include Shelves to include
shelves in the selected “Door” or “Open-
ing” face item.

@ Select Reverse Appliance to reverse

any appliances inserted into the
selected cabinet from left to right: for
example, to change a left hand door on a
built-in refrigerator to a right hand door. This
option is only available for cabinets with an
inserted appliance.

e A preview of the selected cabinet
displays on the right side of the panel.
See “Dialog Preview Panes” on page 28.

«  Click the Select Cabinet Face Item [t
button, then click on an item on the front
of the cabinet in the preview to select that
item. The selected face item is high-
lighted in grey.

When the Mouse-Orbit Camera &
mode is active, you can right-click on a
front item to select it.

» The cabinet Label displays below the
preview pane.
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DOOR/DRAWER Panel

The settings on the DOOR/DRAWER panel

selected cabinet’s doors, drawers and

allow you to control the appearance of the hardware.
N Base Cabinet Specification “
Door o -]
General : lZ‘ &
Front Style: Use Default - Library...
Door/Drawer
Moldings Glass Doors o
Materials
Door Handle o
Style: Use Default hd
In From Edge: 138" (D)
Down From Top: 138" (D)
Door Hinges o
Style: Use Default hd .
Up/Down From Edge: | 3" (D) "
Drawer o
Style: Use Default = Library...
Drawer Handle e
Style: Use Default hd
Horizontal Position: (@) Use Default
() One Handle Centered
() Two Handles In From Edge: 0O
Vertical Position: (®) Use Default
(") Centered
() Distance From Top: O
Cancel Help

Specify the appearance of the Doors
applied to selected cabinet.

Select a door Style from the drop-down list.

See “Doors, Drawers and Panels” on page

254.

+ Select “Use Default” to apply the door
style specified in the defaults dialog for

the selected cabinet’s type. See “Cabinet

Defaults” on page 248.

Select “Slab Doors” to apply a flat door
front or “Framed Doors” to apply a door
with a frame and flat panel front.

Select “Library” or click the Library
button to select a cabinet door from the
library. If a library door has been previ-
ously selected, its name will display in
the list. See “Select Library Object Dia-
log” on page 350.

Check Glass Doors to use a glass mate-
rial for the panel of Framed doors or for
the entire door for Slab doors. Not avail-



able when “Library” is the selected door
Style.

9 Specify the characteristics of the
selected cabinet’s Door Handles.

» Select a door handle Style from the drop-
down list.

*  Specify the position of the handle In
From Edge, as measured from the edge
of the door opposite the hinges.

*  Specify the height of the handle Down
From Top, as measured from the top
edge of the door. For wall cabinets, this
value is measured Up From Bottom.

9 Specify the characteristics of the
cabinet Door Hinges.

» Select a door hinge Style from the drop-
down list.

* Specify the location of the hinges Up/
Down From Edge, as measured from the
door edge. If the cabinet door is more
than 35 1/4” (880 mm) high, three hinges
will be created instead of two.

e Select a Drawer Style from the drop-
down list or choose one from the
Library. For best results, “Framed” drawers

should be at least 6” (150 mm) high.

9 Specify the characteristics of the
selected cabinet’s Drawer Handles.

* Select a drawer Handle Style from the
drop-down list.

Shelf/Partition Specification Dialog

» Specify the Horizontal Position of the
drawer handle(s): Choose Use Default to
use the default position; One Handle
Centered for a single handle centered on
the drawer face; or Two Handles In
From Edge for two handles set in from
the drawer sides by the value specified in
the text field.

e Specify the Vertical Position of the
drawer handle(s): Choose Use Default to
use the default position, Centered for
handle(s) centered on the drawer face, or
specify the handle’s Distance From Top.

0 A preview of the selected cabinet
displays on the right side of the panel.
See “Dialog Preview Panes” on page 28.

» The cabinet Label displays below the
preview pane.

Moldings Panel

The settings on the MOLDINGS panel allow
you to assign one or more horizontal
moldings around the selected cabinet. See
“Editing Cabinet Styles” on page 254.

For information about the settings on this
panel, see “Moldings Panel” on page 180.

Materials Panel

The settings on the MATERIALS panel affect
the appearance of the selected cabinet in 3D
views. For information about these settings,
see “Materials Panel” on page 372.

I—l Select a shelf or partition and click the

Open Object edit button to open the

Shelf/Partition Specification Dialog

Shelf Specification or Partition
Specification dialog.
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The options in these specification dialogs are
similar to the corresponding defaults dialogs.
See “Cabinet Defaults” on page 248.

General Panel

™ Shelf Specification X
G | Size [Position o i h
enera - lZ‘
Molangs o
Materials
Depth:
Elevation Reference: From Floor - ~
Floor to Bottom: 69 1/4"
Cancel Help

o Size/Position - Specify the Height,
Width, and Depth of the shelf or
partition.

+ Select the Elevation Reference from the
drop-down list. This determines where
the next two settings are measured from
and also affects their setting labels.

* Specify the to Top distance, measured
from the Elevation Reference to the top
of the shelf or partition.

* Specify the to Bottom distance, mea-
sured from the Elevation Reference to the
bottom of the shelf or partition.

9 A preview of the selected object

displays on the right side of the panel.

See “Dialog Preview Panes” on page 28.

Moldings Panel

The settings on the MOLDINGS panel allow
you to apply molding to the selected object.
For information about these settings, see
“Moldings Panel” on page 263.

Materials Panel

The settings on the MATERIALS panel affect
the appearance of the selected object in 3D
views. For information about these settings,
see “Materials Panel” on page 372.



The electrical plan shows the location of all
electrical objects such as lights, switches,
outlets, smoke detectors and vent fans.

Electrical objects can be displayed in 2D and
3D views. Some electrical light fixtures also
add light sources to 3D views. See
“Lighting” on page 404.

Usually, the electrical plan is one of the last
additions to a plan since the position of most
electrical objects is determined by the
location of walls, cabinets and other objects.

& Building requirements vary throughout
the country and around the world. It is
your responsibility to comply with local codes.

Chapter 18:

Electrical

Chapter Contents
The Electrical Tools
Placing Electrical Objects
Auto Place Outlets
Connect Electrical
Electrical Library Content
Displaying Electrical Objects
Editing Electrical Objects
Electrical Service Specification Dialog
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1] Select Build> Electrical to access the
Electrical Tools.

Most electrical objects are easily created
with a single click in floor plan and camera
views. See “Click-to-Create” on page 80.

Some electrical objects are designed to be
inserted into walls, floors, ceilings or
cabinets, although some can also be free-
standing. See “Placing Electrical Objects” on
page 267.

Once created, outlets, switches, and lights
can be selected and edited. See “Editing
Electrical Objects” on page 270.

Outlets

q:l'\P Select Build> Electrical> 110V
- Outlet to place 110 volt duplex
outlets on walls, the on floor, and on the
sides of cabinets and soffits. Select Build>
Electrical> 220V Outlet to place 220 volt
outlets.

The type and height of an outlet will vary
depending on where it is placed. For
example:

e Inrooms defined as Bath or Master Bath,
Ground Fault Circuit Interrupt (GFCI)
outlets are placed.

& If standard outlets are placed in a room
prior to defining it as a Bath, you should
replace them with GFCI outlets.

* An outlet placed at the back of a base
cabinet in floor plan view is positioned
above the counter.

* An outlet placed at the back of a base
cabinet containing a kitchen sink is
placed at the standard 11 1/2" (300 mm)
above the floor.

* An outlet placed on the side of a cabinet
or soffit will be positioned 32 (800 mm)
up from that object’s bottom.

e An outlet placed outside the building or
in an exterior area such as a deck or porch
will be weatherproof.

To take advantage of the program’s
capabilities, define room types properly
before placing electrical objects. See “Room
Types” on page 165.

Light Fixtures

O Select Build> Electrical> Light to

place light fixtures on walls, the
ceiling, or on soffits. All light fixtures placed
in a plan can also serve as light sources in
3D views. To place a light fixture using the
Light tool:

¢ Click near a wall or the side of a soffit to
place a wall-mounted fixture at that loca-
tion.

* Click away from a wall to place a ceiling
mounted light.

» Click on the center of a soffit to place a
ceiling mounted light on the soffit’s bot-
tom surface.

e Click outside of a room and away from a
wall to place a path light.

*  Some light symbols from the library can
be mounted under wall cabinets, as well.



Switches

$ Select Build> Electrical> Switch to
place electrical switches on walls or
on the sides of cabinets or soffits. Like
outlets, the height of switches is measured
from the floor to the center of the object.

* A switch placed on the side of a cabinet
or soffit will be positioned 32” (800 mm)
up from that object’s bottom.

» Switches placed outside the building or in
an exterior area such as a deck or porch
will be weatherproof.

Auto Place Outlets

Select Build> Electrical> Auto Place

Outlets and click in a room tool to
place outlets at regular intervals around the
entire room. See “Auto Place Outlets” on
page 268.

Placing Electrical Objects

Connect Electrical

- Select Build> Electrical> Connect

i Electrical, then click and drag to draw
splines that snap to electrical switches,
outlets, and lights to illustrate wiring circuits.
See “Connect Electrical” on page 268.

Lighting and Electrical
Library Catalogs

:ﬂll'-_ A selection of free-standing and

! ceiling-, wall- and cabinet-mounted
light fixtures is available in the Library
Browser at Home Designer Core Catalogs>
Architectural> Lighting.

Special use outlets, switches, jacks and
numerous other electrical items can be found
at Home Designer Core
Catalogs>Architectural> Electrical. See
“The Library” on page 335.

Placing Electrical Objects

Electrical switches, outlets, lights, and other
symbols can be created with a single click in
any view. They can also be placed from the
Library. See “Click-to-Create” on page 80.

When the Outlet, Switch, and Light tools are
used, the type and height of the object that is
created will vary depending on where it is
placed. As you move your mouse pointer
around the view, an object preview will
display near the pointer whenever it is over a
location where an object can be placed.
Specific details for each tool are noted in
“The Electrical Tools” on page 266

The electrical objects in the Library are
typically designed for a specific use and can
only be placed on a wall, on the floor, or on

the ceiling. Some are instead free-standing
and are designed to be placed on a table or
the floor. See “Placing Library Objects” on
page 349.

Wall mounted outlets, switches, and Library
symbols can also be placed on the sides of
cabinets and soffits. They will snap to the
outside of the cabinet box but will ignore
doors and drawers.

When a light fixture is created using any
method, including copying and pasting, it
will always be turned On. This is the case
even if the default symbol is turned Off. See
“Light Data Panel” on page 273.

267



Home Designer Interiors 2019 Reference Manual

Electrical Object Heights

When a wall-mounted electrical object is
placed in floor plan view, its initial height off
the floor is based on commonly used
standards.

In 3D views, an electrical object placed on a
wall in a 3D view will snap to the standard
height for its type provided that the mouse
pointer is near that height when you click. If
you move the mouse pointer away from the
standard height, the object will be positioned
wherever you click on the wall, regardless of
the height at that point.

Auto Place Outlets

q:P_ Select Build> Electrical> Auto Place
Y Qutlets and click in a room to place
110 volt outlets on the walls around the
entire room, spaced so that no wall position
is farther than six feet (1800mm) from the
nearest outlet. 110 or 220 volt outlets are also
placed behind large appliances. In addition, a
light is placed above each sink.

It is important that a room’s Type be defined

before Auto Place Outlets P is used so
that outlets are placed appropriately. For
example, GFCI (Ground Fault Circuit
Interrupter) outlets are placed over cabinets
in Kitchen, Bath and Master Bath rooms.
See “Room Types” on page 165.

Auto Place Outlets 4 does not work in
rooms assigned an exterior room type such as

Deck. To place outlets in an exterior room,
place them from the Electrical Library or use

the 110V Outlets P tool.

Railings and invisible walls are ignored by

Auto Place Outlets 7. I it is used in a
room defined by railings or invisible walls,
outlets are automatically placed in any
adjacent rooms on the other side of these
wall types. See “Room Definition” on page
163.

Note: Auto Place Outlets requires that a room
have a door before outlets can be placed.

Once placed, any outlet can be moved,
edited, or deleted. See “Editing Electrical
Objects” on page 270.

Connect Electrical

268

= Select Build> Electrical> Connect

. Electrical, then click and drag to draw
splines that snap to electrical switches,
outlets, and lights to illustrate wiring circuits.

To create a new circuit or add to an existing
circuit, click on a switch, outlet, or light

while the Connect Electrical | tool is
active, drag to the next object and

release.When a Connect Electrical i spline
is first drawn, it looks like an arc but actually
consists of two segments that are defined by
vertex points. When selected, its edit handles




display at each of these vertices. If you click
and drag one of these edit handles, the
length, angle, and curvature of the spline will
change but the other vertices will not move.

\ertex points

- O

R
Foline segments
Connect Electrical | splines cannot be
snapped to one another: they can only snap to
electrical objects. Once drawn, though,
additional vertices can be added and used to

form complex curves. See “Editing Spline
Based Objects” on page 108.

\ertex points

Foline segments

Electrical Library Content

To remove a connection from a circuit,

simply select and Delete 2 it. If you
remove an electrical object from a circuit,
any Connect Electrical splines snapped to it
will also be deleted. See “Deleting Objects”
on page 119.

Three- and Four-Way Switches

Multiple switches can control an object or
group of objects.

* Two switches controlling the same
objects are referred to as three-way
switches.

» Three switches controlling the same
objects are called four-way switches.

In floor plan view, a three- or four-way
switch’s “way” number will automatically
display in its 2D symbol.

Electrical Library Content

;ﬂl';' Select View> Library Browser to
Ul accesses a variety of electrical
symbols. See “The Library” on page 335.

Browse for electrical objects such as bath
vent fans, an electrical panel, fluorescent
lights, chandeliers, a smoke detector,
thermostat, and more. Select a symbol, then
click in your plan to place it on a wall, floor,
or ceiling.

Adding Electrical Content

Any electrical symbol placed into a plan can
be customized and added to the User Catalog
in the Library Browser. Customized settings
are retained. See “Add to Library” on page
345.
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Displaying Electrical Objects

The display of electrical objects is
| controlled in the Display Options
dialog. See “Layer Attributes” on page 87.

When displayed in 3D views, light fixtures
act as sources of light that help illuminate the
3D model. See “Lighting” on page 404.

In floor plan view, electrical objects are
represented by commonly used CAD
symbols that represent the type of object
rather than its appearance in 3D.

Like other objects, electrical objects are
placed in Drawing Groups that affect
whether they display in front of or behind
other objects in floor plan view. You can
modify a selected object’s place in the
drawing order by clicking the View Drawing

Group Edit Tools T edit button. See
“Drawing Group Edit Tools” on page 89.

Electrical symbols are placed on the
“Electrical” layer, while Connect Electrical

splines are drawn on the “Electrical,
Connections” layer.

Electrical labels display in floor plan view
when the “Electrical, Labels” layer is turned
on and use the “Default Label Style” Text
Style.

Note: Some electrical objects are repre-
sented in floor plan view by a symbol that
includes text. This text is not part of the
object’s label and does not use the Default
Label Text Style.

In the Materials List

Electrical objects, including outlets,
switches, lights, and symbols from the
library, are listed under the Electrical
Category in the Materials List. Connect
Electrical splines are 2D objects only,
however, and are not calculated. See
“Materials Lists” on page 437.

Editing Electrical Objects
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Electrical objects can be selected as a group
and individually in 2D and 3D and edited
using the edit handles and the edit
toolbarMoving Electrical Objects
Using Dimensions

Electrical objects can be moved precisely
using dimensions. See “Moving Objects
Using Dimensions” on page 192.

electrical objects are not located by
dimension lines as the lines are drawn. Once
created, though, you can edit a dimension

line’s extensions to locate the center of any
electrical object. See “Editing Extension
Lines” on page 191.

Using the Edit Handles

The edit handles for electrical objects vary
depending on the location of the object.

+  Wall mounted electrical objects cannot be
rotated, so only the Move edit handle dis-

plays.




» Electrical objects placed on floors and
ceilings can be rotated.

* In 3D views, some ceiling mounted and

free-standing light fixtures can be
resized.

Using the Edit Tools

A selected electrical symbol can be edited in
a variety of ways using the buttons on the
edit toolbar. See “The Edit Toolbar” on page
24.

In the Specification Dialog

Electrical objects can be edited in the
Electrical Service Specification dialog. See
“Electrical Service Specification Dialog” on
page 271.

Adjusting Electrical Object
Heights

When a wall- or cabinet-mounted electrical
object is placed, its initial height is based on

Electrical Service Specification Dialog

commonly used standards. See “Placing
Electrical Objects” on page 267.

Once placed, a wall-mounted electrical

object’s height can be edited in either of two

ways:

* Specify the height in the Electrical
Service Specification dialog. See “Gen-
eral Panel” on page 271.

* In 3D views, the position of an electrical
object can be adjusted using its edit han-
dles.

Deleting Electrical Objects

An electrical object can be deleted by

selecting it and clicking the Delete X/ edit
button or by pressing the Delete key.

All electrical objects in a room, on a floor, or
in the entire plan can also be deleted as a
group using the Delete Objects dialog. See
“Deleting Objects” on page 119.

I—l Select an electrical object and click
the Open Object edit button to open
the Electrical Service Specification dialog.

Electrical Service Specification Dialog

The settings in this dialog vary, depending on
the type of object you select.

General Panel

The items on this panel vary, depending on
the type of electrical object selected.

271



Home Designer Interiors 2019 Reference Manual

r‘\ Electrical Service Specification

General Name
Light Data Caged Lantern Sconce
Materials
Position
Height to Center:
Distance From Wall:
Size
Height: 18 5/16"
Depth: 9 1/4"

Retain Aspect Ratio

Reset Size

Options
[ reverse Symbaol

Copyright
Copyright® 2010, Chief Architect, Inc.

Automatically Change Switch Type When Wiring

*

2] 0

o

Cancel Help

G The Name of the selected object as 9 Specify the Size of the selected

used in the Library Browser and
Materials List displays here. .

9 Specify the Position of the selected
electrical object. The options available .
depend on the type of object selected.

* Specify the Offset From Ceiling of a
ceiling outlet or ceiling mounted light. If
the light is mounted to a cabinet, this
value is the offset from the cabinet.

* Specify the Height to Center of a
switch, wall outlet or wall light.

+  Specity the Offset From Floor of a floor
outlet or floor lamp.

* Specify the Distance From Wall of a

electical symbol.

Specify the Height, Width and Depth of
the selected symbol.

Uncheck Retain Aspect Ratio if you
would like to modify one of the above
values without affecting the others.
Doing so may cause the symbol’s shape
to become distorted. This check box does
not affect editing performed outside of
this dialog and is an action rather than a
state: the next time you open this dialog,
it will be checked.

Click the Reset button to restore the elec-
trical symbol’s original size.

wall mounted symbol. A negative value 0 Options -

will recess the symbol into the wall and
may prevent it from being seen in 3D. .
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Check Reverse Symbol to reverse the
object’s appearance so that features on its



left are located on its right and vice versa.
Does not affect symmetrical symbols.

* Check Automatically Change Switch
Type When Wiring for a selected switch
to become a three- or four-way switch if
your wiring plan uses it as such. See
“Connect Electrical” on page 268.

Switches placed from the toolbar use this

Electrical Service Specification Dialog

option by default; switches placed from
the library do not.

(5]

here.

G A preview of the selected object
displays here. See “Dialog Preview

Panes” on page 28.

Any Copyright information associated
with the selected symbol will be stated

Light Data Panel

The LIGHT DATA panel is available when the
selected electrical object is a light fixture.

The available options vary depending on the
type of light selected.

r‘\ Electrical Service Specification X
Light Sources o h
G.eneral - lZ‘
Light Data Light 1 -
Materials
Light Characteristics o o
Source Type:  (®) PointLight () Spot Light
Intensity: 1200 Lumens ¥ | [1200.0 |3
SR —
Tilt Angle: -80.0%
Direction Angle: |0.0®
Cut Off Angle:  |60.0° "
Drop Off Rate: |7.5
Options o
On AT
Casts Shadows
|:| Show Position in Camera View
Cancel Help

0 Each fixture can have multiple Light
Sources, listed here. Not available for
Added Lights. See “Lighting” on page 404.

* Select a Light Source assigned to the
selected light fixture from the drop-down
list. The selected light source can be
edited using the settings on this panel.

9 Specify the Light Characteristics of
the currently selected Light Source.

* Select either Point Light or Spot Light
as the light Source Type. The Type deter-
mines which options are enabled below.
See “Light Types” on page 405.
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* Select an Intensity from the drop-down
list. The available options are described
using lumens and correspond to com-
monly used light bulb wattages. You can
also use the text box or spin controls to
make fine adjustments to the Intensity
value. When a non-standard value is
specified, the Intensity is described as
“Custom Lumens”.

* Click the Color bar to define the color of
the selected light source. Colored lights
alter the appearance of textures and can
be used to achieve special effects. See
“Select Color Dialog” on page 90.

iy The default color of light is pure white,
@ which has the least affect on the

appearance of material colors and textures.

The Angle and Drop Off Rate settings below
are only available for Spot Lights.

* The Tilt Angle controls the angle of the
illumination with respect to the horizon.
A value of -90° points the light straight
down and a value of 90° points it straight
up. 0° is parallel to the horizon.

* The Direction Angle defines the
direction of the illumination relative to
the ground. 0° is measured horizontally
pointing to the right. Positive values
rotate in a counter-clockwise direction
from there. Enter a value up to 360°. If
you enter a negative value, the program
adds 360° to it when you click OK or
press the Tab key.

+ The Cut Off Angle controls the angle of
the cone of illumination for Spot Lights
only. A cone angle of 180° creates a spot
light that shines in a half sphere on one
side of the light source. A small cone

angle, for example 10°, creates a very
narrow cone of light.

¢ The Drop Off Rate affects how fast a
Spot Light’s intensity drops off from the
center of the cone to the outside edge.

A value of 0 produces a cone of light with
the same intensity from the center to the
outside edge and a sharp distinction
between lit areas within the cone and
unlit areas outside of it. As this value is
increased, the light intensity decreases
closer to the edge of the cone and the
distinction between lit and unlit areas
becomes softer. Only available for Spot
Lights.

Additional Options that affect how the
selected light source behaves are available.

¢ Check On to use the light source in
camera views, or uncheck it if you prefer
that the light source not be used. See
“Lighting” on page 404.

» Casts Shadows controls whether or not
the light source casts shadows in camera
views. See “Shadows” on page 402.

* Check Show Position in Camera View
to indicate the position of a selected Point
or Spot Light source in the preview pane
and in 3D views when it is turned On.
This tool can be used to determine if your
light source is positioned correctly. See
“In 3D Views” on page 405.

o A preview of the selected object

displays here. The selected light
source’s Position in Camera View will
display in the Standard Rendering Technique

if the light source is On. See “Dialog
Preview Panes” on page 28.



Electrical Service Specification Dialog

Materials Panel For more information, see “Materials Panel”

. . on page 372.
The MATERIALS panel is found in the

specification dialogs for a variety of objects.
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Chapter 19:

Foundations

There are two foundation types in Home Chapter Contents
Designer Interiors: stem walls with footings . Foundation Defaults
and monolithic slab. The foundation type can . Building a Foundation
be specified in the Foundation Defaults . Displaying Foundations
dialog when the foundation is built on Floor . Editing Foundations
0. . Deleting Foundations
. Foundations and Rooms
& Always consult registered geotechnical : F¥replaces . . .
and civil engineers for information : Fireplace Specification Dialog

regarding the proper foundation for your site. . Library Fireplaces
. Chimneys
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Foundation Defaults

@ Foundation Defaults can be accessed
by selecting Edit> Default Settings.

Select “Foundation” and click the Edit
button to open the Foundation Defaults
dialog.

The settings in the Foundation Defaults
dialog are similar to those in the Build
Foundation dialog, which opens when

Build> Floor> Build Foundation ™" is
selected. The primary difference is that when
you click OK in the Foundation Defaults
dialog, no changes are made to the model.
See “Building a Foundation” on page 278.

|-\ Foundation Defaults X

Automatically Rebuild Foundation o

Foundation Type o

(® Walls with Footings
(O Monolithic Slab

Wall Options o

Wall Height: 37
Cancel Help

Check Auto Rebuild Foundation to

automatically rebuild the foundation
whenever changes are made to Floor 1 that
affect the structure of the foundation. See
“Rebuilding Foundations™ on page 280.

Click the radio button beside either
Monolithic Slab or Walls with
Footings to specify which foundation type

the program should build.

(3]

»  Wall Thickness - Specify the desired
thickness of the foundation walls. See
“Wall Thickness” on page 149.

* Wall Height - Specify the desired height
of the foundation walls.

Wall Options - Specify characteristics
of the foundation walls.

If the wall height is at least 6 feet (1800 mm),
a slab floor is generated above the footings
and inside the foundation walls. The Wall
Height includes the thickness of this slab.

If you do not want this slab, specify the
“rooms” on Floor 0 as Open Below in the
Room Specification dialog. See “Available
Room Types” on page 166.

Building a Foundation
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Two foundation types are available:
stem walls with footings and
monolithic slabs. The first option is created
using walls; the second creates concrete slabs
with footings.

Automatically built foundations are placed
on Floor 0 and are based on wall positions

and floor heights on Floor 1. Foundation
walls or slab footings are generated under:

» All exterior walls on Floor 1 that define a
room other than a Court, Deck or Bal-
cony room type. See “Room Definition”
on page 163.

* Any interior walls on Floor 1 defining
rooms with different floor heights. See



“Floor and Ceiling Heights” on page 172.

At least one room must be defined on Floor 1
for a foundation to be automatically
generated. If no rooms are defined on Floor
1, a blank Floor 0 is created.

To build an automatic foundation

1. Select Build> Floor> Build Founda-

. [E]
tion - .

2. Specify the desired foundation type and
other information in the Build
Foundation dialog. The settings in this
dialog are similar to those in the Foun-
dation Defaults dialog. See “Foundation
Defaults” on page 278.

3. Inthe New Floor dialog, sclect Derive
new Foundation plan from the 1st
floor plan and click OK to build a foun-
dation based on Floor 1.

Displaying Foundations

If you prefer, you can instead select Make
new (blank) plan for the Foundation to
create an empty foundation level where you
can manually draw foundation walls or slabs.

In most cases, it is preferable to base Floor 0
off the first floor plan and then manually edit
the foundation as needed. See “Editing
Foundations” on page 280.

Mixing Foundation Types

You can also create a foundation that
combines stem walls and/or monolithic
slabs.

To create a foundation of multiple types

1. Begin by specifying any rooms on Floor
1 that require a slab floor as either a
Garage or Slab Room Type. See “Foun-
dations and Rooms” on page 281.

2. Build Foundation , as described

above.

Displaying Foundations

The display of foundation walls, slabs,

curbs and footings is controlled in the
Display Options dialog. See “Display
Options Dialog” on page 88.

» Foundation Walls, including slab footings
and Garage curbs, are placed on the
“Walls, Foundation” layer.

» Footings under slab footings and Founda-
tion Walls are placed on the “Footings”
layer.

* Deck post footings are placed on the
“Footings, Deck Post” layer.

» The “Foundations” layer controls the dis-
play of all objects on Floor 0 in 3D views
but does not affect floor plan view.

In floor plan view, foundation walls are
drawn with solid lines and footings, with
dashed lines.

If a door on Floor 1 extends into a stem wall
or curb defining a Garage room, its location
will be indicated on Floor 0.

In 3D views, all objects on Floor 0 will only
display when the “Foundation” layer is
turned on.
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While the display of foundation walls and
their footings can be controlled independent
of one another in floor plan view, in 3D
views this is not the case. If a foundation
wall is set to display, its footing will as well -
even if the “Footings” layer is turned off. The
reverse is also true - if a foundation wall’s
display is turned off, so will its footing’s.

The display of monolithic slab foundations in
3D views is controlled by the “Foundation”
layer. Slab footings are located on the
“Walls, Foundation” layer; but if this layer is
turned off, any slab footings that define a
foundation room will continue to display as
long as the “Foundation” layer is on.

Editing Foundations
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Stem wall with footings and monolithic slab
foundations are both created using walls
which enclose room areas.

* Foundation walls can be selected and
edited much like other walls. See “Edit-
ing Walls” on page 148.

« Foundation rooms can also be selected
and edited like other rooms. See  Foun-
dations and Rooms.

Rebuilding Foundations

By default, foundations update automatically
when changes are made to the structure on
Floor 1. For example, if exterior walls are
moved or floor platforms are raised or
lowered, the foundation will be rebuilt.

If you prefer that the foundation not rebuild
automatically, you can uncheck Auto
Rebuild Foundation in the Foundation
Defaults dialog. See “Foundation Defaults”
on page 278.

You can also rebuild an automatically
generated foundation by selecting Build>

Floor> Build Foundation from the

menu.

When Auto Rebuild Foundation is enabled,
walls cannot be edited, manually drawn or

deleted on Floor 0. When the foundation is
rebuilt, any manually drawn or edited walls
are deleted. Similarly, rooms on Floor 0
cannot be edited while this option is enabled.
If you try to draw a wall or edit a room or a
wall while Auto Rebuild Foundation is
turned on, a warning message will display.

Changing Foundation Types

When a foundation is generated, the program
creates Floor Defaults settings for Floor 0
based on the information in the Build
Foundation dialog. If you specify a
Monolithic Slab foundation, the default
Floor Structure on Floor 1 will also be
changed to a slab rather than a framed
platform. See “Floor Defaults Dialog” on
page 288.

If you rebuild the foundation using a
different Foundation Type, it is advisable to
check the floor heights of all rooms on Floor
1 - particularly Garage and Slab rooms, as
well as any rooms that do not use the default
floor height of 0”.

& To avoid unexpected results, it is rec-
ommended that you not change the
Foundation Type once the foundation is built.




Stem Wall Height

When a foundation is created, all of Floor 0
uses the stem wall height specified in the
Foundation Defaults dialog,

This height is measured from the bottom of
floor platform of Floor 1 to top of the stem
walls’ footings. If Floor 1 has multiple floor
platform heights, the foundation stem walls
will be stepped.

Once a foundation is created, stem wall
heights can be adjusted either on a room-by-
room basis or for individual walls.

Deleting Foundations

To change a room'’s stem wall height

1. Select a room on Floor 0 and click the
Open Object b1 edit button.

2. Specify the desired Stem Wall Height
in the Room Specification dialog. See
“General Panel” on page 177.

3. If you wish to reduce the Stem Wall
Height, you will first need to reduce the
Ceiling Height value by the same
amount.

If adjacent rooms have stem wall heights that
differ by at least 1/16 of an inch, the stem
wall separating them uses the larger of these
two values.

Deleting Foundations

& Select Build> Floor> Delete Foun-
dation to delete the entire foundation
floor.

You can also select and delete individual
foundation walls and slabs by clicking the

Delete I edit button or pressing the Delete
key. See “Deleting Objects” on page 119.

Deleting and rebuilding the foundation is
often the quickest way to update the model
when substantial changes are made to Floor 1
after the foundation is built.

Foundations and Rooms

When a foundation plan is created, rooms
included in the Living Area calculation
generate a stem wall or slab foundation
below them. Garage rooms generate slab
foundations, but exterior rooms such as
Decks, Courts and Balconies do not generate
any foundation. See “Room Types” on page
165.

Interior foundation walls are not generated
unless:

* They separate the area under a Slab or
Garage room from the rest of the plan;

» They define areas under rooms with dif-
ferent floor heights.

Note: To remove all or part of the concrete
slab in the basement area, select a basement
room and define it as Open Below in the
Room Specification dialog.
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Garages

When a foundation is generated based on the
floor plan of Floor 1, a room on the first floor
specified as either a Garage or Slab type will
receive a foundation with a slab floor and
stem walls. If a monolithic slab foundation is
generated, the room will receive a slab floor
with curbs.

By default, a room on Floor 1 specified as a
Garage or a Slab will be assigned a lower
floor height when the foundation is built. The
amount that it is lowered depends on the
foundation type:

* The floor height will drop the default
thickness of the floor platform for Floor 1
plus 12 (300 mm) - a total of 24 5/8”
(618 mm) - in a Walls with Footings
foundation.

* The floor height will drop 3 1/2” (88 mm)
in a Monolithic Slab foundation.

To build a Garage slab with stem walls

1. Before the foundation is generated,
specify the room as a Garage or Slab.

2. Build a Wall with Footings foundation.
To build a Garage slab with curbs

1. Before the foundation is generated,
specify the room as a Garage or Slab.

2. Build a Monolithic Slab foundation,
specifying the required Lower Garage
Floor value.

Basement Rooms

When a foundation’s type is Walls with
Footings and it is assigned a Minimum Wall
Height of 76” (1900 mm) or greater, the
resulting basement is automatically created
with a 4” (100 mm) concrete slab floor. and a
default Floor Finish like that on Floor 1.

Similarly, if a foundation is set up to have a
Basement Ceiling Height of 72 (1800 mm)
or greater when built, it is automatically
given a painted drywall Ceiling Finish.

Regardless of its ceiling height, however,
you can specify a ceiling finish for any room
in the Room Specification dialog. See
“Structure Panel” on page 178.

The resulting basement can be divided into

separate rooms using Interior Walls or
any wall type you wish.

Stepped Foundations

A stepped foundation will be produced
automatically if more than one floor height is
present on Floor 1 when the foundation is
built.

You can also create a stepped foundation by
editing foundation rooms. See “Stem Wall
Height” on page 281.

Fireplaces

—=| A masonry fireplace can be placed in
or away from a wall by selecting

Build> Fireplace and then clicking in the
drawing area.



e Ifcreated in a wall, it is considered a wall
opening and can be moved or resized like
a window or door.

o Ifcreated away from a wall, it moves and
resizes similar to a cabinet.

A selection of prefabricated metal fireplaces
is also available from the Architectural Core
Catalog. These can be framed in with
standard walls. See “The Library” on page
335.

The display of fireplaces is controlled in the
Display Options dialog. See “Display
Options Dialog” on page 88.

Fireplaces are edited, moved, resized, and
deleted similar other objects. See “Editing
Objects” on page 93.

Built into a Wall

To place a masonry fireplace in a wall, select

Build> Fireplace ™ and click on a wall. A
fireplace is created with the outside of the
fireplace flush with the outside of the wall.

Fireplaces cannot be placed in a wall
specified as Invisible. See “Room Dividers
and Invisible Walls” on page 139.

oL 0]

Select the fireplace to display four edit
handles located along the wall.

oL 0]

Fireplaces

Click the diamond-shaped Depth handle and
drag toward the outside of the wall. The
fireplace will stop when the firebox front is
flush with the inside edge of the wall.

In 3D views, fireplaces placed in walls
display five edit handles: a Resize handle
along each edge and a Move handle at the
center.

Fireplaces always face the interior when
placed on an exterior wall. When placing a
fireplace in an interior wall, click on the edge
of the wall that you want the fireplace to
face. The fireplace is created with the firebox
on the same side as the wall edge you clicked
on to create it.

Freestanding

To place a free-standing masonry fireplace,

select Build> Fireplace | and click in an
open area away from a wall.

Unlike fireplaces placed in walls, free-
standing fireplace have ten edit handles when
selected and may be rotated, resized, or
moved in any direction, similar to the way
CAD boxes can. See “Editing Box-Based
Objects” on page 106.
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Free-standing fireplaces can be selected and
replaced with a symbol from the library by

clicking the Replace From Library = edit
button. See “Replace From Library” on page
351.

Fireplace Foundations

When a Walls with Footings foundation is
built, a fireplace foundation will be

generated under any Fireplaces ® present
on Floor 1. See “Building a Foundation” on
page 278.

Fireplace foundations are the same material
type as the original fireplace, but do not have
a firebox or a hearth. Fireplace foundations
can be edited or deleted as needed. A firebox
and hearth can be added in the Fireplace
Specification dialog.

Fireplace Specification Dialog
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I—l Select a masonry fireplace and click
the Open Object edit button to
display the Fireplace Specification dialog.

Dimensions in this dialog here must be
entered in whole inches. Fractions and
decimals are not accepted.

General Panel

™ Fireplace Specification

General Size and Position

Floor to Top:

Floor to Bottom:

Plan Display

Materials
Depth:
Elevation Reference: From Floor =

1%
c
=]
g
m
2
2
=]
3
m
3
0,
[=}
a
2

*

s

Cancel Help

Specify the Size and Position of the
selected fireplace and its hearth.

+ Specify the Height, Width, and Depth of

the fireplace.

* Specify the Hearth Depth. This is mea-
sured from the front of the fireplace out

into the room. To eliminate the hearth
altogether, enter a zero for this value.

* Specify the Hearth Height, relative to
the floor in the room that the fireplace
faces.



* Select the Elevation Reference from the
drop-down list. This determines where
the next two settings are measured from
and also affects their setting labels.

*  Specify the height to Top, measured from
the selected Elevation Reference.

* Specify the height to Bottom, measured
from the selected Elevation Reference.

Library Fireplaces

g Plan Display - Check Suppress
Dimensions to turn off the display of

the selected fireplace’s width and firebox

width dimensions in floor plan view.

The preview of the fireplace updates as
changes are made. See “Dialog Preview
Panes” on page 28.

Firebox Panel

™ Fireplace Specification
General Size
Materials
width:
Offset
O Left
(® Right

s

Cancel Help

Define the Size of the selected
fireplace’s firebox.

» Specify the firebox’s Height and Width.

*  Specify the Depth of the firebox.
Define the firebox Offset, measured
from the center of the fireplace.

« Enter the offset Distance, which is how
far the firebox is offset from the fireplace
center. A value of 0 centers the firebox in
the fireplace.

« Offset to Left/Right - Choose to offset
the firebox to the left or to the right.

The preview of the fireplace updates as
changes are made. See “Dialog Preview
Panes” on page 28.

Materials Panel

For information about the settings on this
panel, see “Materials Panel” on page 372.

Library Fireplaces

A variety of fireplace symbols are available
in the library. Flush fireplaces are designed
to snap to wall surfaces. Some fireplace

symbols can be enclosed by walls or
positioned to project through a wall.See
“Placing Library Objects” on page 349.
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O

Open Front fireplace projecting through a wall

& Always check the manufacturer’s prod-
uct information for the framing and
clearance requirements of the fireplace unit
you plan to use, and design your plan
accordingly

Chimneys
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Chimneys can be created using a variety of
methods.

Masonry Fireplace Chimneys
To create a chimney on a masonry fireplace

Select the fireplace in a 3D view.

2. Ctrl + drag the top edge of the chimney
upward through all the floors and the
roof until it is to the desired height. See
“Unrestricted Movement” on page 113.

3. When the chimney is approximately the
correct height, select the fireplace, click

the Open Object b1 edit button, and
type in the exact height.

Chimney Chases and Caps

There are two ways to draw a chimney chase:

* Place a closed box Geometric Shape or
Soffit over the chimney chase, resize it to
match, then increase its height either in
its specification dialog or in a 3D view
using the same method as extending a
masonry fireplace.

» Use walls to define the chimney chase as
a room area, making sure these walls are
aligned between floors. The chimney
chase “room” on the uppermost floor
should have a much higher ceiling than
the other rooms on that floor and should
also have no ceiling or roof. See “Room
Specification Dialog” on page 176.

A selection of chimney tops is available in
the library. In addition, custom chimney caps
can be made using Geometric Shapes and/or
Soffits. See “Other Objects” on page 361.



Chapter 20:

Multiple Floors

When a new plan file is opened in Home
Designer Interiors, two floor levels are
present: Floor 1 and the Attic Floor. You can
add more floors whenever you like: up to 3
total. Once created, floors can also be copied
and deleted.

Home Designer Interiors also supports
special floors for foundations and attics.
Only one foundation level and one attic can
exist in a plan. Foundations are discussed in
their own chapter. See “Foundations” on
page 277.

Chapter Contents
Floor Defaults Dialog
Floor Tools
Adding Floors
Displaying Floors
Exchanging Floors
Deleting Floors
Split Levels
The Current Floor
The Attic Floor
The Reference Floor
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Floor Defaults Dialog

@ There is a Floor Defaults dialog for

each floor in a plan file. The defaults
for the current floor can be accessed by
selecting Edit> Default Settings. Click the
arrow to the left of “Floors and Rooms” to
expand the category, then select “Current
Floor” and click the Edit button to open the
Floor Defaults dialog for the currently active
floor. See “Default Settings vs Preferences”
on page 54.

The Floor Defaults dialog also opens
whenever you add a new floor to the plan.
See “Adding Floors” on page 289.

The Floor Defaults dialog does not open
when you build a foundation; however, the
Floor 0 Default settings are created based on
the current Foundation Defaults. See
“Building a Foundation” on page 278.

The Floor Defaults dialog is similar to the
Room Specification dialog, but controls the
default settings for all rooms on the current
floor. The settings here also control the
height of individual walls as they are drawn
on the floor in question. See “Room
Specification Dialog” on page 176.

Note: The default floor height for Floor 1 is 0.
It can be modified in the Room Specification
dialog, but not in the Floor 1 Defaults dialog.
See “Floor and Room Defaults” on page 165.

Structure Panel

The settings on the STRUCTURE panel are
similar to those in the Room Specification
dialog. See “Structure Panel” on page 178.

Moldings Panel

The settings on the MOLDINGS panel are
similar to those in the Room Specification
dialog. See “Moldings Panel” on page 180.

Fill Style Panel

The settings on the FILL STYLE panel are
similar to those in the specification dialogs
for many objects throughout the program.
See “Fill Style Panel” on page 131.

Materials Panel

The settings on the MATERIALS panel are
similar to those in the specification dialogs
for many objects throughout the program.
See “Materials Panel” on page 372.

Floor Tools

Select Build> Floor to access the
floor tools.

55/ Select Build> Floor> Build New
Floor to build a new floor. A new
floor can be generated based upon the

perimeter of the floor below or a blank floor
can be created and drawn from scratch. See
“Adding Floors” on page 289.

<] Choose Build> Floor> Delete
LE] Current Floor to remove the current



floor from the plan. For more information,
see “Deleting Floors” on page 291.

Choose Build> Floor> Build
------ Foundation to open the Foundation

Adding Floors

Defaults dialog and build a foundation floor.
See “Building a Foundation” on page 278.

q&a] Select Build> Floor> Delete

Foundation to remove the foundation
from the plan. See “Deleting Foundations”
on page 281.

Adding Floors

When a new plan file is opened in Home
Designer Interiors, two floor levels are
present: Floor 1 and the Attic Floor. You can
add up to 3 total living floors, as well as
create a foundation below Floor 1.

Floors can be added whenever you like; and
once created, they can also be copied and
deleted.

Note: Home Designer Interiors allows only
one floor, the foundation/basement, below
the first floor. Keep this in mind when you
begin an as-built or plan for a multi-story
building. See “Foundations” on page 277.

Build New Floor

%51 New floors can be created in floor
plan view as well as in 3D views, and
are always added above the top living floor.
To create a new floor, select Build> Floor>
Build New Floor.

™ MNew Floor e

(® Derive new 2nd floor plan from the 1st floor plan

[] Move the roof over the highest floor up

[ step fioorjceiling elevations to match existing floor
(O Make new blank plan for the 2nd floor

Cancel Help

¢ Derive new 2nd floor plan from the 1st
floor plan creates a new top floor with
exterior walls generated directly over the
exterior walls of the floor below. Wall
types and roof directives associated with
the walls on the floor below are dupli-
cated; however, interior walls are not. See
“Roof Panel” on page 156.

* Check Move Highest Floor’s Roof Up to
move any roof planes displaying on the
highest floor in the plan up one floor
when the new floor is created. Roof
planes displaying on floors other than the
top floor are unaffected. This option is
only available if there are roof planes
built on the top floor and is not available
when Auto Rebuild Roofs is enabled.
See “Build Roof Dialog” on page 323.

* Check Step floor/ceiling elevations to
match existing floor to maintain all ceil-
ing heights on the existing floor by step-
ping floor heights on the new floor to
match. Ceiling heights on the new floor
also become stepped accordingly. See
“Stepped Floor and Ceiling Platforms™ on
page 174.

e Make new (blank) plan for the 2nd
floor creates a new top floor that is blank.
This option is typically selected only if
none of the exterior walls on the new
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floor will be directly above the exterior
walls on the floor below. If you choose
this method, it may be helpful to turn on
the Reference Floor when drawing walls
on the new floor. See “The Reference
Floor” on page 293.

When you click OK, the Room Defaults
dialog for the newly created floor opens.
Make any necessary changes to the floor
structure, moldings, or materials and click
OK. See “Floor Defaults Dialog” on page
288.

The new floor becomes the current floor in
floor plan view. If, however, the new floor is
created in a 3D view, the camera remains on
its original floor and does not move.

Adding a Foundation

To add a foundation, select Build> Floor>

Build Foundation ™. See “Building a
Foundation” on page 278.

Displaying Floors

Home Designer Interiors allows you to view
the floors in your plan in a variety of ways.

In Floor Plan View

In floor plan view, only one floor can be
active for editing at a time. This is referred to
as the Current Floor. See “The Current
Floor” on page 292.

In addition to the Current Floor, one other
floor can be displayed for reference
purposes: the Reference Floor. Objects on
the Current Floor can snap to those on the
Reference Floor, helping you align objects.
See “The Reference Floor” on page 293.

In 3D Views

In most 3D views, all floors in a plan are
visible, from the foundation up to the attic.
There are two exceptions:

* Floor Camera (18 views, which show
the Current Floor only.

» Doll House Views @2 which show the
Current Floor, not including its ceiling,
plus any floors beneath it.

See “3D View Tools” on page 383.

Exchanging Floors

290

Select Build> Floor> Exchange
With Floor Above or Exchange
With Floor Below to swap the current floor
with the floor above or below.

Nl

The floor that was moved becomes the
current floor at its new location. You can
easily move a floor up or down several floors
by using either one of these buttons
repeatedly.



Deleting Floors

Deleting Floors

5= Select Build> Floor> Delete Current
L5 Floor to remove the current floor
from the plan. If there is a floor above, it
becomes the current floor; if there is no floor
below, the floor beneath becomes the current

floor.

&) To delete Floor 0, select Build>
Floor> Delete Foundation. You can

delete the foundation without actually being
on Floor 0. Floor 0 cannot be deleted while
Auto Rebuild Foundation is turned on. See
“Deleting Foundations™ on page 281.

When a floor is deleted, all objects on
that floor are deleted with it.

Split Levels

Both split level floor plans and split level
entries can be created by controlling the floor
and ceiling heights of individual rooms in a
multiple story structure.

Split Level Floor Plans

A split level, or tri-level, structure is a
building where the floor level in one part of
the plan is located approximately half way
between the floor and ceiling levels of
another part of the plan.

Flit Level Home

To create a simple split level plan

1. Draw a simple rectangular structure
divided into two separate halves by an
interior wall.

2. Select one of the rooms and click the

Open Object J1 edit button. See
“Room Specification Dialog” on page
176.

3. Raise the Floor Height then press the
Tab key.

4. Restore the Relative Rough Ceiling to
the default value, then click OK.

5. Build a stem wall foundation. See
“Foundations” on page 277.

¢ The foundation under the room with
the lower floor height will have the
specified Min Stem Wall Height.

¢ The foundation under the room with
the raised floor will have taller stem
walls.

* Both can be edited in the Room
Specification dialog.

6. Ifyou add a Floor 2, note that the Ceil-
ing Height in the room on Floor 1 will
be reset to the default value.

» To maintain a stepped condition on
multiple floors, return to this room and
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set the Relative Rough Ceiling back to
using the default.

Split Level Entries

A split level entry, or divided entry, is
characterized by an entry door that opens
onto a landing positioned half way between
the basement floor and first floor levels.

Solit Level Entry

To create a simple split level entry

1. Create a plan file with a full basement at
the location of the entry door. See
“Basement Rooms” on page 282.

2. Go to Floor 0 and draw a stair
Landing \Z at the location of the entry.
See “Landings” on page 303.

3. Draw stairs upward from the basement
floor to the landing.
* The number of treads and risers in the
stair section will determine the landing
height.

4. Draw a second stair section from the
landing upward.

5. Select the stairs and click the Auto

Stairwell BT edit button. See “Creating
a Stairwell” on page 308.

For more detailed instructions, visit
HomeDesignerSoftware.com.

The Current Floor

292

Only one floor can be active at any given
time. The active floor is referred to as the
Current Floor, and it is the only floor on
which objects can be edited.

If you want to edit two different floors at the
same time, you can open the plan again. This
opens a second window on the current open
plan that has the same editing abilities as the
first. Only one of these windows can be
active at any given time.

Floor Up / Floor Down

If you are working with
more than one floor, you

W1 AN

can select Tools> Reference Floors> Up
One Floor or Down One Floor to switch
from one floor to another.

You can change the current floor in floor plan
and 3D views. The current floor displays on

the Change Floor/Reference | button,
which can be found between the Down One
Floor and the Up One Floor buttons.

Floors become available once they have been
built. The Attic and foundation levels are
also accessible using these tools.


http://www.homedesignersoftware.com/support/displayfaq.php?faqNumber=269&subject=floors

Change Floor / Reference

If there are multiple floors, select
1 Tools> Reference Floors> Change
Floor/Reference to open the Change Floor/

The Attic Floor

Reference dialog, where you can select both
the current floor and which floor is used in
the Reference Floor, as well as control the
appearance of the Reference Floor.

The Attic Floor

Home Designer Interiors
A automatically creates a floor above
the top numbered floor level of each plan.
This floor is called the Attic floor and has
only one purpose: to provide a space for
automatically generated Attic walls. See
“Attic Walls” on page 153.

Because the Attic floor is not meant to be a
living area, a warning message will display if

you try to draw walls or other objects on this
floor.

In some situations, you may find it necessary
to draw one or more walls on this floor;
however, even if you enclose an area with
walls, rooms cannot be created on the Attic
floor.

If you wish to create an attic loft, bonus
room, or storage area in your plan, you will
need do so on a numbered floor level.

The Reference Floor

When there is more than one floor in a
model, it is often helpful to see how they
relate to each other. Any floor can be shown
as the Reference Floor along with the
current floor.

When the Reference Floor Display is turned
on, the floor that you were last on prior to the
current floor is used as the Reference Floor
and is shown in red. Objects on the

Reference Floor cannot be selected or edited.

Reference Floor Display

~— To turn on the Reference Floor, select
Tools> Reference Floors> Reference
Floor Display or press F9 on your keyboard.

i

If the Reference Floor is turned on when a
view is printed, it will be included in the

printed output. See “Displaying Objects” on
page 447.

Note: If objects on the current floor and the
Reference Floor have edges that line up, the
Reference Floor may be difficult to see on
screen. When lines of two different colors are
superimposed upon each other, discoloration
may result.

Reference Floor Display
Options

g The display of objects in the
Reference Floor is controlled by
selecting Tools> Reference Floors>
Reference Floor Display Options. See
“Display Options Dialog” on page 88.
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Change Floor / Reference Dialog

By default, the floor below the
1 Current Floor is the Reference Floor,
but any floor can be referenced using the
Change Floor/Reference dialog. To open

the dialog, select Tools> Reference Floors>
Change Floor/Reference button.

When this dialog is accessed from a camera
view, only the Current Floor settings will be
active.

r\ Change Floor/Reference e
Current Floor: Reference Floor:

Foundation o Foundation o

1st Floor 2nd Floor

2nd Floor 3rd Floor

3rd Floor Attic

Attic

Cancel Help

0 The Current Floor is highlighted here.
You can select another floor to make it

the current floor.

9 The Reference Floor currently used for
reference is highlighted here. You can

select another floor to display it instead.

Swap Floor/Reference

CE If one floor is defined as the current

floor and another floor is defined as
the reference floor, select Tools> Reference
Floors> Swap Floor/Reference to switch
the status of the two floors.



Staircases can be composed of one or more
straight or curved stair sections and landings.
Stairs can be drawn, selected and edited in
2D and 3D views.

Stairwells can be created automatically or
manually and can be seen in 3D views.

& Local building and fire authorities must
be consulted for specific stair construc-
tion codes and access requirements.

Chapter Contents
. Stair Defaults
. The Stair Tools

Stairs and Landings

Anatomy of a Staircase

Drawing Stairs

L- and U-Shaped Stairs
Displaying Stairs and Landings
Editing Stairs

Merging Stair Sections

Landings

Maintaining Tread Depth

Starter Treads

Wrapped Stairs

Other Special Railings and Stairs
Creating a Stairwell

Rooms Below Staircases
Staircase Specification Dialog
Stair Landing Specification Dialog

Stair Defaults

The purpose of interior stairs is to provide
passage from one floor platform to another,
so the attributes that influence floor heights -
including ceiling heights - also influence the
structure of stairs. When considering a
staircase’s structure, bear in mind that riser
height is directly dependent on the distance
from one floor platform to another.
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The Stair Tools

296

w- Select Build> Stairs to access the
% Stair Tools.

Draw Stairs

%.| To draw a straight staircase select
Build> Stairs> Draw Stairs, then
click and drag in floor plan or a 3D view.
You can also click once to place a staircase
that extends from the current floor up to the
next floor. See “Drawing Stairs” on page
298.

Straight Stairs

= Select Build> Stairs> Straight
Stairs, then click to create stairs
between the current floor and the floor
above. To create stairs between two floor
platforms on the current floor, click on the
low side, within a few feet of where the floor
changes height.

» Ifyou click on the low side of a floor
platform defined by a railing, a doorway
will be created in the railing, adjacent to
the stairs.

+ Ifyou click on the low side of a floor
platform defined by a wall, stairs will be
created but a doorway will not.

+ Ifyou click at a location that is not near
the edge of a floor platform, a full height
staircase will be created.

Curved Stairs

", ﬁ‘“ Select Build> Stairs> Curve to
== | Left or Curve to Right and click

once in floor plan view to place a curved

staircase. See “Curved Stairs” on page 298.

L-Shaped Stairs

Wil Select Build> Stairs> L-Shaped

= | Stairs, then click to create two equal
stair sections that form a 90° corner and are
connected by a landing. See “L- and U-
Shaped Stairs” on page 299.

U-Shaped Stairs

mmm Seclect Build> Stairs> U-Shaped
EllE  Stairs, then click to create two stair
sections that form a 180° turn and are
connected by a landing.

Landing

\2 Select Build> Stairs> Landing to

draw a landing, which is a platform
connecting two or more stair sections. See
“Landings” on page 303.

There are two ways to create a landing using
this tool:

» Click once to place a landing measuring
39” (975 mm) on each side.

* Click and drag to draw a rectangular
landing sized as needed.

Spiral Stairs

:ﬂll'-_ In the Library Browser, browse to
U Home Designer Core Catalogs>
Architectural> Spiral Stairs to access a
selection of spiral staircase fixtures. Select
the object that you want, then click in any
view to place it in the plan. See “The
Library” on page 335.

Because spiral staircase symbols are fixture
symbols, they do not have an Auto Stairwell



edit tool. An opening in the floor above a
spiral staircase must be created manually.
See “Creating a Stairwell” on page 308.

Anatomy of a Staircase

Anatomy of a Staircase

Stairs are often described in terms of rise and
run. Rise is typically between 6" and 8", and
the run between 10" and 12". In metric plans,
rise i1s 177 to 190 mm, and the run is about
250 mm.

Staircase Terminology

Balusters - The vertical members that run
between the handrail and the treads or
bottom rail.

Bracket - Decorative L-shaped supports on
the exposed side of stairs below each tread.

Landing - A platform connecting two or
more stair sections.

Newels - The end post of a stair railing
located at landings and the beginnings and
endings of new stair sections.

Rise - The height of a riser, measured from
tread surface to tread surface, Also referred
to as Unit Rise.

Rise Angle - The angle of the staircase or
stair section, defined by a line drawn through
the back surfaces of its treads.

Riser - The vertical stair member located
between the treads. Risers may be solid or
open. When open, the front surfaces of the
stringers are considered the risers.

Run - The depth of a tread, measured from
riser surface to riser surface. Run does not
include the Tread Overhang. Also referred to
as Unit Run.

Runner - The carpet that runs down the
center of the staircase.

Shoe - The bottom railing, placed on the
landing floor, that anchors the balusters at
landings.

Stringer - The inclined support member of a
staircase that supports the treads and risers.

Tread - The horizontal member of a stair that
the foot is placed on.

Tread Overhang - The portion of a tread
extending past the front surface of the riser
and over the tread below. Also referred to as
Nosing or Nosing Extension, it is not
included in the Run or Tread Depth
measurements.

Tread Thickness - The vertical depth of the
tread material.

Stair Structure and the Model

Stairs locate the height of the floor platform
that they are drawn on and seek the next
level, which may be the floor platform of the
floor above or a landing. The stringers locate
the subfloor of the floor platforms and
maintain consistent riser height. If the stairs
are long enough to reach the next level at a
reasonable rise angle, their tread depth and
number of treads are automatically
calculated to create a staircase with
consistent tread and riser dimensions along
its entire length.
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Stair Sections and Subsections

In Home Designer Interiors, staircases can be
composed of multiple sections and
subsections. See “Merging Stair Sections” on
page 301.

 Stair sections are separated by landings.

* Subsections are considered part of the
same section because they are connected
to one another directly rather than sepa-
rated by a landing.

Drawing Stairs

Stairs can be drawn in floor plan and 3D
views. In 3D views, these objects can only be
drawn in the presence of a floor platform.
See “Working in 3D” on page 394.

There are a few things to keep in mind when
drawing stairs:

« Before stairs are created, make sure that
the heights for both the lower and upper
floors are correctly defined.

 Stairs are drawn going UP, so they should
be drawn from the lower of the two floors
they connect.

* By default, stairs adjust their riser and
tread dimensions to connect two floor
heights if possible. The rise and run are
calculated so that the steps are consistent
in size.

» Stairs drawn within 1” (25 mm) of a wall
will snap to the outer surface of the wall.

 Stairs will snap to the Reference Display
=, if you have it turned on.

* Hold down the Ctrl key to suppress these
snapping behaviors.

+ Ifastairwell room has been defined on
the floor above, the top of the stairs can
be dragged until it stops at the railing or
wall defining the stairwell.

Straight Stairs

The Draw Stairs 5 tool can be used in two
different ways:

» Click and drag in a straight line to draw
stairs that are the length that you drag.

» Click once to place stairs that go from the
current floor up to the height of the next
floor level.

You can also click once using the Straight

Stairs 3 tool to create stairs between rooms
on the same floor with different floor heights.
When the Straight Stairs tool is active, a
preview outline of the stairs will follow the
mouse pointer. Hold down the Alt key to
reverse the direction of the Up arrow in the
preview.

An individual stair section must be between
6” (150 mm) and 100’ (30 m) in length. If a
greater length is needed, connect two
sections using a landing.

Curved Stairs

* You can make a straight stair section
curved, or vice versa by selecting the
stairs and clicking the Change Line/Arc
= edit button. See “Change Line/Arc”
on page 117.



You can also curve straight stairs by drawing
them against a curved wall.

Sraight stairs drawn along a curved wall

L- and U-Shaped Stairs

e, | a0 Curved Stairs can also be

el . .

== | created in floor plan view by
selecting Build> Stairs> Curve to Left or
Curve to Right. Click to place a 90° curved
stair section that can then be edited. You can
continue clicking to place additional curved
staircases until another tool is selected.

L- and U-Shaped Stairs

|| == The L-Shaped Stairs and U-

= ElE Shaped Stairs tools allow you to
place staircases composed of two stair
sections connected by a landing with a single
click.

The staircases created with these tools build
from the current floor to the floor above. If
you need a staircase that builds between
platforms on the same floor level, or in a
downward direction, you will need to draw it
manually. See “Landings” on page 303.

When you select either tool, the New
Shaped Staircase dialog opens.

New Shaped Staircase Dialog

The settings in this dialog retained between
sessions in the software and are global,
affecting all plans.

™ New Shaped Staircase

*
Default Direction: (®) Clockwise o
(O Counterdockwise
U-Shaped Stairs

Cancel Help

o Specify the Default Direction of the
stairs as they build upward: Clockwise,
or Counterclockwise.

e U Shaped Stairs - Specify the width of
the Gap between the two stair sections.

When you click OK, a preview outline will
follow the mouse pointer.

You can control the staircase’s orientation
and direction by moving the mouse pointer
towards a wall.

* In the case of a U-Shaped S staircase,
the landing will snap to the wall first.

» As you move the mouse pointer closer to
the wall, the preview will rotate so that
the upper stair section snaps to the wall.
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+ Ifyou continue to move the mouse closer,
the lower stair section will snap to the
wall instead.

* Ifyou move the mouse pointer into a wall
corner, the preview will rotate so that the
bottom stair section snaps to the wall that
is nearest to the mouse pointer.

| . .
*  When a U-Shaped ZlE staircase preview
is in a wall corner, move the mouse

pointer within the landing area to control
which wall the back of the landing snaps
to. With the landing in place, move the
mouse pointer over the two stair sections
to control which is the bottom section.

e Press the Alt key to reverse these snap-
ping behaviors and the stairs’ direction.

* Hold down the Ctrl key to prevent the
stairs from rotating or snapping to walls.

Displaying Stairs and Landings

The display of stairs and landings in
. all views is controlled in the Display

Options dialog. Stairs and landings are
placed on the “Stairs & Ramps” layer. See
“Layer Attributes” on page 87.

In Floor Plan View

In floor plan view, stairs and landings display
on the floor they were drawn on and are only
visible from the floor above if there is a
stairwell. See “Creating a Stairwell” on page
308.

Stairs have an arrow indicating the direction
they run. Interior stairs have an UP arrow on
the floor they were created on and a DN
arrow when viewed from the floor above.
See “Drawing Stairs” on page 298.

When a staircase is selected in floor plan
view, the numbers associated with each of its
sections and subsections display. Stair

sections are assigned a single number, while
subsection numbers have two parts: a section
number and subsection number separated by
a hyphen.

o d ol |||l
1 2-1 2-2
& L\l I

Stair subsection
numbers

In 3D Views

Although stairs span between two floors,
they can only belong to one floor. As a result,
only multi-floor views show the upper floor
with the platform opening and the lower
floor with the staircase simultaneously. In
Floor Cameras and Doll House Views,
stairwells may appear as an empty spaces.
See “3D View Tools” on page 383.

Stair section
number

Editing Stairs

Staircases can be selected and edited in floor
plan view and 3D views. See “Selecting

Objects” on page 94.



Using the Mouse

When a staircase is selected, its edit handles
display. These edit handles can be used to
customize the object in many ways. See
“Editing Objects” on page 93.

» Straight stair sections are edited like
lines. They have additional edit handles
for resizing the width of the section. See
“Editing Line Based Objects” on page
96.

» Curved stair sections are edited like arcs
and also include edit handles for resizing
the stair’s width. See “Editing Arc Based
Objects” on page 98.

*  When stair sections are merged, the edit
handles display differently depending on
what subsection is currently selected. See
“Merging Stair Sections” on page 301.

Merging Stair Sections

*  When moving merged stair sections, all
merged sections move as one.

» Additional edit handles display on the
first two treads of a staircase if the

Starter Tread & edit button is clicked.
See “Starter Treads” on page 306.

In the Specification Dialog

|—| Stairs can be customized in the

Staircase Specification dialog. See
“Staircase Specification Dialog” on page
311.

Using the Edit Tools

A selected staircase can be edited in a variety
of ways using the buttons on the edit toolbar.
See “The Edit Toolbar” on page 24.

Merging Stair Sections

Any combination of straight and curved stair
sections using Automatic Heights can be
merged. The resulting staircase section is
made up of subsections and, if there are no
landings, functions as a single unit.

Stair subsections must be drawn in the same
direction if they are to be merged:

* The top edge of a stair section cannot
merge with the bottom edge of another
section.

* Combinations of stairs drawn in the UP
and DOWN directions cannot be merged.

Stair subsections merge at the center points
of their upper and lower edges.

To merge stair sections

1. Confirm that the stairs that you wish to
merge are using Automatic Heights.
See “General Panel” on page 311.

2. Position the sections so they are in the
desired relationship to each other.

* In order to merge stair sections cor-
rectly, they must be parallel to one
another.

» To create merged subsections that
change direction, make one of the
merged sections curved.

3. Select either stair section so that its edit
handles display.
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4. Click the Extend handle on the end to be
merged and drag it to the point where the
two stairs are to meet.

+
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Merging parallel stair sections

A staircase consisting of merged subsections
resembles a single stair section in floor plan
view. The UP (or DN) arrows join, becoming
a single direction arrow.

When a subsection is selected, the entire
staircase is selected. Additional edit handles,
indicating the presence of multiple
subsections and allowing you to reposition
the line along which they join. See “Using
the Mouse” on page 301.

Curved Subsections

Stair subsections attached at both ends by
other sections do not have a free end that can
be dragged into a curve. In this situation,
change the middle sub-section to a curve
using the Change Line/Arc 2 edit button.
See “Change Line/Arc” on page 117.

To curve an enclosed stair subsection

1. Draw three straight stair sections and
connect them end to end.

2. Select the middle subsection.

LY

|
)
9 __up
o
The middle stair subsection is selected
3. Click the Change Line/Arc — edit
button. The center section turns into a
curved stair section.

After using Change Line/Arc

4. Use the triangular Change Curve edit
handle to adjust the curvature of the
middle section as needed.



Landings

Landings

Stair landings are platforms between stair

sections and can be created in either of three

ways:

* Using the Landing " tool.

* By clicking between two stair sections
using the Draw Stairs < tool.

* A landing is also created when the L-
Shaped Stairs 2 or U-Shaped

|
=ll=

Stairs tool is used.

To create a landing between stair sections:

1. Draw two stair sections going UP. They
can be at any angle.

2. Click between the two sections using the

Draw Stairs S5 tool to create a landing.
Notice that only one direction arrow dis-
plays after the sections are joined by a
landing.

4 HH-s tH | @

Creating a stair landing

Multiple stair sections can be connected to
one landing. For example, two or three stair
sections might meet at a landing with a single
stair section continuing to the next level.

To be linked by a landing, all sections must
be drawn in the same UP direction and the

top of one section should be near the bottom
of the next.

Stair sections connected with a landing will
move together as a single unit.

A landing formed between two stair sections
having less than a 90° angle between them
are created with a short edge not less than 6”
(150 mm). This is because most building
codes require the shortest tread to be at least
6” wide. This edge can be manually edited to
less than 6” if needed.

Editing Landings

Landings can be selected in 2D and 3D
views, both individually and in groups, and
edited using the edit handles, the edit toolbar,
and the Landing Specification dialog. See
“Stair Landing Specification Dialog” on
page 317.

Landings derive their initial materials and
railing characteristics from the stairs attached
to them. You can assign a unique railing or
material to a landing in its specification
dialog.

By default, landings have railings on all
edges. You can suppress the railing on a
selected edge by clicking the Remove

Railing from Selected Edge S edit button.
To restore a selected railing, click the Add

Railing to Selected Edge €5 edit button.
See “Selected Edge” on page 94.

Custom Shaped Landings

Landings can be edited like other closed
polyline-based objects. You can add or
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remove edges, convert an edge from straight
to curved, or vice versa. A curved landing
creates curved railings. See “Editing Closed-
Polyline Based Objects” on page 104.

You can edit the shape of a landing into a
wide variety of shapes. So that the railings of
stair sections connect properly to the landing
railings, make sure that each stair section end
is snapped to a landing edge with the same
length as the stair’s width. If necessary, use

the Break Line —X tool to create a break in a
landing edge if it is longer than the
connecting stairs are wide. See “Break Line”
on page 116.

Landing Height

A landing’s height is controlled by the
program and will adjust automatically as the
stairs attached to it are modified so that the
stairs maintain a consistent rise angle.

Unlocked Landings

By default, new landings are unlocked,
which means that their height is determined
by the stair or ramp sections attached to it.
An unlocked landing will automatically
adjust its height as necessary to maintain the
same riser height and rise angle for all
attached sections.

In this example, two stair sections with eight
treads each are connected by a landing.

Because the sections have the same number
of treads, the landing height is one half of the
distance between the two connected floors.

Unlocked landings maintain
consistent riser height

5I

If a change is made to either stair section, the
program will maintain the stairs’ connection
to the floors above and below, and will
instead modify the height of the landing and
the other stair section so that a consistent
riser height is maintained.

As long as a stair or ramp system consists of
a landing connecting only two stair sections,
the program can easily set landing heights
and produce consistent a rise angle. If more
than two stair sections meet at a landing, the
relationship between them becomes more
complex. In this situation, you may want to
define the exact height of the landing instead
of letting the program define it for you.

Locked Landings

A locked landing has a specifically defined
height that does not adjust automatically
when there are changes in the attached stairs.
Instead, the stairs adjust to the landing.

For example, start with the same staircase
used to illustrate unlocked landings, with one



change: the landing height is now defined at
78 inches (1980 mm).

Locked landings produce
independent stair sections

3I_6II _:_1

6I_6II

Since the landing height is now closer to the
upper floor than to the lower floor, the upper
stair section has a very shallow riser height
and the lower section has a tall riser height.

Stair and ramp sections attached to a locked
landing no longer relate to one another:

* Changes to one section do not affect the
other.

» The Staircase Specification dialogs
show only the selected section and those
connected to it by unlocked landings,
rather than the entire system.

Maintaining Tread Depth

* Locked landings do not move when
attached stair or ramp sections are
moved. Only unlocked landings and the
sections attached to them will move.

Locked landing can be used to break up a
complex network of stairs and landings into
smaller pieces with known bottom and top
heights.

To lock alanding

1. Select the landing and click the Open

Object b1 edit button to open the Stair
Landing Specification dialog. See
“General Panel” on page 318.

2. On the GENERAL panel, uncheck Auto
Adjust Height When Connected to
Stairs.

3. Specify the desired Top Height and
click OK.

4. The landing moves to the specified
height and all stairs that connect to that
landing are redefined.

To unlock a landing, open its specification
dialog, check Auto Adjust Height When
Connected to Stairs, and click OK. The Top
Height will automatically adjust to any stair
or ramp sections attached to it and will try to
produce a staircase with a single riser height.

Maintaining Tread Depth

Most building codes require staircases to
maintain a consistent tread depth.

Home Designer Interiors measures a stair
section’s length and tread depth along a Walk
Line located 12" (30 cm) from the right edge

of the stair section. On curved stairs, it is
located 12” (30 cm) from the inside edge of
the curve.

When a curved stair section has Automatic
Treads specified in the Staircase
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Specification dialog and the Walk Line is
used, the number and/or width of treads in a
section or subsection changes when the inner

edge is moved. For this reason, it is best to
finalize stair section width as early as

possible.

Starter Treads

306

E The first and second treads of a

staircase can be turned into starter
treads by clicking the Starter Tread edit
button. Starter treads extend to the side of the
staircase, have rounded edges and are
common on traditional staircases.

A starter tread can be added only to open
sides of a stair section. If one side of a stair
section is against a wall or wrapped (see
“Wrapped Stairs” on page 307), only the
exposed tread end can become a starter tread.

To create starter treads
1. Click on a staircase to select it.

2. Click the Starter Tread & edit button.
An edit handle displays on each end of
both the first and second treads.

o
=l

3. Drag either of the handles on the first
tread outward from the stair section. If
the stair section is against a wall, only
one handle displays on the side opposite
the wall.

4. Asyou drag, the ends of the tread
become rounded.

5. Two additional edit handles display on
each side of the tread, along the back
edge.

6. Drag either of the two square handles
upward to increase the width of the
rounded ends of the tread.

——

7. Drag the edit handle on the second tread
outward from the stair section to create a
second starter tread.




Wrapped Stairs

| Tread |E\ edit button and repeat the
| above steps as needed.

When you are finished editing the starter

treads, click the Main Edit Mode |E| to
restore the stairs’ regular edit handles
and toolbar buttons.

=

8. To make changes to existing starter
treads, select the stairs, click the Starter

T
v
W

\O

Wrapped Stairs

Stairs can be wrapped around the corner of a
deck or landing. Curved stairs and stairs with
multiple subsections cannot be wrapped. See
“Style Panel” on page 313.

To wrap stairs around a deck

1. Begin by drawing a deck. See “Decks”
on page 172.

2. Use the Straight Stairs |§| tool to place
a stair section on each side of the corner
around which you want them to wrap.

3. Move the stair sections toward the cor-
ner of the deck. When the two sections
are sufficiently close to the corner, they
will merge to form wrapped steps.

iy You can draw stairs down from a deck
@ by right-clicking to draw them or by
pressing the Alt key while you drag.

To wrap stairsaround a landing

1. Use the Draw Stairs |§| tool to create
two perpendicular stair sections with top
ends that share a corner.

2. Click between them to create a landing.

Rotate one stair section 180°.
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4. The stairs wrap around the corner.

=t Notice that the Up arrow displays on the
7 most recently edited stair section.
/ :
[ ] =P
S,
i)
UP

Other Special Railings and Stairs
Stairs can be customized to meet a variety of
needs.

Solid Railings
To create a solid rail along a staircase,

position a solid Railing or Half Wall |
against, but not underneath, the stairs.

< up
If any balusters extend beyond the railing,
eliminate them by unchecking Left Railing
Solid Railing or Right Railing in the Staircase

Specification dialog. See “Style Panel” on

The solid railing recognizes the adjacent p:ge 313 & Y

stairs and climbs alongside them. '

Creating a Stairwell
An interior staircase must be located in a stairwell is an Open Below room type on the
stairwell, an opening to the floor above. A floor above. See “Room Types” on page 165.
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If you create a stairwell away from other
walls so the Open Below is created in the
center of another room, connect a wall of the
Open Below room to another wall using an
invisible wall.

Creating a Stairwell
Automatically

E To create a stairwell that matches the

perimeter of a selected staircase, click
the Auto Stairwell edit button. This button is
only available when a living space exists
above the staircase. It will not be available if
the space above is Open Below or on the
Attic Floor.

Auto Stairwell BT automatically creates a
room on the floor above enclosed by railings,
defined as Open Below in the Room
Specification dialog, and given a Stairwell
room label. This room can be selected and
edited like any other room.

Creating a Stairwell Manually
Stairwells can also be created manually.

To create a manual stairwell

1. Draw a two-story building. Create the
staircase on the first floor.

2. Make the second floor the Current
Floor and the first floor the Reference
Floor. See “The Reference Floor” on
page 293.

3. Select Tools> Reference Floors>

Reference Display & to show the Ref-
erence Floor, including the stairs.

Creating a Stairwell

4. On the upper floor, use the Railing [
tool to create a room around the stairs.
Use the edit handles to position the rail-
ings as needed.

5. Select the railings one at a time and
move them into position.

* When arailing is selected, its bounding
box shows the location of the outer sur-
face of the railing’s drywall layer. For
best results, this outer surface (which
does not display when the railing is not
selected) should meet the top edge of
the stairs.

* If you prefer, you can also go Down

One Floor 7| and adjust the top edge
of the staircase to snap it to the surface
of the railing on the floor above.

6. When the railings are positioned prop-
erly, select Tools> Reference Floors>

Reference Display “ to turn off the
display of the Reference Floor.

7. Click inside the room using the Select
Objects | & tool to select it, then click
the Open Object ¥/ edit button.

8. On the GENERAL panel of the Room
Specification dialog, select “Open
Below” from the Room Type list. Click
OK to close the dialog.
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If the doorway is specified wider than
the railing, its width maximizes to fit the
space available.

OPE N BELOWY
giifesp|

9. Place a Doorway "= in the railing at the
top step for an opening.

10. Select the doorway and define a large
width in the Door Specification dialog.

Rooms Below Staircases

Rooms such as closets or storage areas are 2. On the same floor as the staircase, draw
commonly located beneath staircases. the Interior Walls under them, fol-

. lowing their shape.
To create a room below a staircase . )
3. Reposition the walls as needed, making

1. Draw a staircase, select it, and click the sure that each is entirely under the stairs.
Open Object ¥/ edit button to open the 4. The wall at the foot of the stairs should
Staircase Specification dialog. be placed no closer to the bottom than

* On the FILL STYLE panel, select None the second step.

(Transparent) so the walls and other 5. Add a door and specify the Room Type.
objects under the stairs can be seen.

v ST Z-Im
e s o s s s o —
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Staircase Specification Dialog

Staircase Specification Dialog

Ji

Staircases can be defined with the
greatest accuracy in the Staircase

Specification dialog. To open this dialog,
select a stair section and click the Open
Object edit button or double-click a stair

section using the Draw Stairs S, Straight
Stairs S3, or Select Objects % tool.

If a staircase is composed of multiple stair
sections, the section that you clicked on to

select the staircase is the Selected Section;
however, information about all the sections is
available and can be edited in the dialog.

& It is recommended that all floor heights,

ceiling heights and platform thicknesses
be established before using the Staircase
Specification dialog.

General Panel

General

Style

Railing
MNewels/Balusters
Line Style

Fill Style
Materials

r\ Interior Staircase Specification

Staircase Information

Staircase reaches next level,

Best fit riser height of & 7/8" requires 16 total

risers to reach 109 3/4" to next level,
Mo. Sections: 3

Mo. Landings: 2

Mo. Risers: 16

Rise Angle:  29.08

Make Best Fit

Advanced Options
(® Automatic Treads
(O Lock Tread Depth
(O Lock Number of Treads

Section #: Length Width

@1 [ iES |1

Oz [sor | |35 | 1113718
O3 [e0" iES | |1

*

L N

Riser
Height

b Lengin

# Treads Riser Height

wm

wm
=}

Cancel Help

Staircase Information - Structural

information about the selected staircase
displays here for reference and updates as
changes are made on the GENERAL panel.

¢ The first comment tells whether or not

the staircase reaches the next level. It also
indicates whether its rise angle is either
steeper or more shallow than the Best Fit,
described below. If Automatic Heights
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is unchecked, this comment instead says
“Start and end heights are set manually”.

The second comment, Best fit riser
height of ___ requires ___ total risers
to reach ___ to next level, describes the
ideal rise and run for the selected
staircase. The program defines the Best
Fit Riser Height as the riser height closest
to 6 3/4” (168.75 mm) that allows the
selected staircase to meet the next level
precisely. This comment is only active if
Automatic Heights is checked, below.

The total number of stair Sections,
Landings, and Risers associated with the
selected staircase also display here.

The Rise Angle of the currently active
stair section also displays here.

Click the Make Best Fit button to add or
remove risers to the Selected Section.
Only available when Automatic Heights
is checked and the staircase does not cur-
rently use the Best Fit Riser Height.

A diagram of a sample staircase’s structure
displays here for reference, as well.

(2]

The Advanced Options apply to all
sections and subsections.

Select Automatic Treads to have the
program define the depth and number of
stair treads. If the staircase has multiple
sections, each may have different tread
depths.

Select Lock Tread Depth to specify the
Tread Depth for each stair section, below,
and prevent them from changing. When
Lock Tread Depth is selected and the
length of the stairs is changed, the num-
ber of treads will change.

(3]

Select Lock Number of Treads to spec-
ify the number of treads in each stair sec-
tion and prevent it from changing. When
Lock Number of Treads is selected and
the length of the stairs is changed, the
tread depths will change.

If a staircase with multiple sections is
selected, No Change may be an option as
well. Select this to maintain the multiple
sections’ individual settings.

The specifications for each stair section
and subsection are listed and can be

edited here. Up to ten items total can display.

A change in one value usually affects other
values. You may need to reposition the
staircase after making changes.

The Section Number column identifies
the Selected Section and the number of
each section of the selected staircase. The
radio button to the left indicates which
section or subsection is selected. See
“Displaying Stairs and Landings” on
page 300.

Define the Length, or run, of each sec-
tion.

When the length of a section changes,
other sections and landings in the stair-
case unit move in response. You can
specify whether the bottom or top edge of
the Selected Section moves when you
resize it by selecting either the Lock Bot-
tom or Lock Top radio button, above.

Define the Width of each section. If a
section is connected to a landing, its
width should equal the length of the land-
ing edge that it connects to. See “Land-
ings” on page 303.



Specify the Tread Depth, or run, of each
stair tread in the selected section.

Define the number of Treads in a stair
section or subsection.

Define the Riser Height, the height of
the risers in each stair section.

Staircase Specification Dialog

0 A preview of the selected staircase

displays on the right side of the panel.
If the staircase includes any landings, only
the section that was selected when the dialog
was opened will display. See “Dialog
Preview Panes” on page 28.

Style Panel

r\ Interior Staircase Specification

[] Closed Stringer

Open Options

|:| Open Risers

Runner
Runner Width:
Runner Tucked

Tread

Large Stringer Base
[] Extend Stringer Top

General Stringer

Railing )

MNewels/Balusters TTEEr FTiE
Line Style Stringer at Wall
Fill Styl

I\-;atet:aels [] single Stringer

Open Underneath

Tread Overhang:
Tread Thdoes:

*

L N

Cancel Help

o Specify the attributes of the selected

staircase’s Stringers, which are the

angled support members that support the
treads. See “Anatomy of a Staircase” on page
297.

Specify the height of the Stringer Top
when Stringer at Wall or Closed
Stringer is selected. This is measured
from the top front corner of a tread.

Specify the height of the Stringer Bot-
tom, as measured from the bottom back
corner of a tread.

e Check Stringer at Wall to produce a
raised stringer top baseboard at the sides
of the stair sections against walls. This
baseboard follows the slope of the stair.

» Check Single Stringer to form a single 5-
inch (125 mm) thick stringer in the center
of the staircase. Checking Single
Stringer automatically checks Open Ris-
ers and unchecks Stringer at Wall and
Closed Stringer.

* Check Closed Stringer to raise the tops
of the exposed stringers to cover the sides
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of the treads. If this is checked, no central
stringer is applied to open riser stairs.
This setting only affects those stringers
that are not against a wall.

e Check Large Stringer Base to widen the
stringers at the foot of the staircase. This
is helpful when walls are created below
the stairs.

>

Large Sringer Base shown at right

-

+ Extend Stringer Top is checked by
default and extends a triangular portion
of the stringer under the landing or plat-
form at the top of the stairs.

Q The Open Options control whether the

selected stairs have open risers or an

open underside. They are not available when
Single Stringer is checked, above.

*  Uncheck Open Underneath to add a
skirt below the staircase along the two
sides. It looks like a wall in 3D, but only
has a single face. Base molding does not
generate along the bottom of the skirt,
and doors cannot be placed in it. In most
cases, the recommended way to enclose

the area beneath stairs is to use walls. See
“Rooms Below Staircases” on page 310.

¢ Check Open Risers to eliminate the riser
face under each tread and expose the
stringers. If Closed Sides is also selected,
no central stringer is supplied.
0 Specify the attributes of the staircase’s
carpet Runner. Only available when
Open Risers is unchecked, above.

* Specify the Runner Width. The default
value of 0 does not create a runner.

»  Uncheck Runner Tucked to have the
runner drop straight down from the tread
front to the riser below. This is checked

by default.
0 Specify the characteristics of the
staircase Treads. See “Anatomy of a
Staircase” on page 297.

e Specify the Tread Overhang, which is
the distance that each tread overhangs the
riser.

* Specify the Tread Thickness.

A preview of the selected staircase

displays on the right side of the panel.
If the staircase includes any landings, only
the section that was selected when the dialog
was opened will display. See “Dialog
Preview Panes” on page 28.



Staircase Specification Dialog

Railing Panel

r\ Interior Staircase Specification X

General Railing o n,
o 0]

Style Stair Rail Height:
Railing
Mewels/Balusters Landing Rail Height: o
Line Style Handrail Width:
Fill Style
Materiale Railing On: Left Right

Railing at Wall: Left Right

Style
(® Balusters
O Open
() Open with Middle Rail
O Panels
Top/Bottom Rail
Indude Top Rail
[ indude Bottom Rail

|:| Raise Bottom: 4

Cancel Help

o Specify how the Railing is applied to
the selected staircase.

Stair Rail Height defines the height from

tread surface directly over the riser to

railing top.

Landing Rail Height defines the height

of the landing rail top from the landing

surface.

Railing On - Select Left and/or Right to

specify placement of railings on stair sec-

tions.

Railing at Wall - Select Left and/or

Right to specify the placement of wall
railings. Not available for ramps.

9 Style -

Select Balusters to create regularly
spaced balusters between larger newel
posts.

Select Open to create with only newels
posts.

Select Open with Middle Rail to create
railings with newel posts and a middle
rail.

Select Panels to create railings composed
of panels. The panel style is specified on
the NEWELS/BALUSTERS panel. See
“Newels/Balusters Panel” on page 316.

e Top/Bottom Rail -

Check Include Top Rail to produce a top
rail on the stair railings that receives the
top baluster ends and typically acts as a
handrail.

Check Include Bottom Rail to place a
low rail on the landing surface that
receives the balusters ends.
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* Check Raise Bottom, then specify the
distance to raise the bottom rail or panel
from the stair tread.

0 A preview of the selected staircase
displays on the right side of the panel.
If the staircase includes any landings, only
the section that was selected when the dialog
was opened will display. See “Dialog
Preview Panes” on page 28.

Newels/Balusters Panel

The settings on the NEWELS/BALUSTERS selected staircase. See “Landings” on page
panel will also affect the appearance of 303.
railings on any landings attached to the

r\ Interior Staircase Specification X
S;T:ral MNewels o v lZ‘
Railing Has Mewel Posts
Newels/Balusters Type: |Square v | | Lbrary...

Line Style
Fill Style ol
Materials Height: |4
Rail Passes Over Newel
Balusters o
Type: | Square 7 Library...
[ cut Baluster Top
Cancel Help
0 Newels - clicking the Library button to the right
and allows selection of a newel from the
*  Uncheck Has Newel Posts, to prevent library.

newels from generating in the selected » Specify the Width, which is the width or

staircase’s railings. When this box is diameter of each newel. For Library new-

checked, newels are generated and can be els, this is the width at its widest point.
edited using the settings that follow. «  Specify the Height, which is the height

* Type - Select Square, Round, or newels from the landing surface to the top of the
from the Library. Selecting Library newel. Only available when Rail Passes
from the drop-down list is the same as Over Newel is unchecked below.
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* Specify the on-center Spacing of the
newel posts.

9 The first three Balusters settings are
similar to the Newels options of the
same names, above.

e Cut Baluster Top - Each tread normally
has two to three balusters, growing lon-
ger toward its back. The default is to use
the same baluster and cut it off at the bot-
tom to shorten it toward the tread front.
Check this box to cut the balusters at the
top instead.

e Specify the characteristics of the
selected railing’s Panels. These settings

are only available when the railing Style

specified as “Panels” on the Railing Panel.

» Specify the panel’s Thickness.

» Select “Solid” or “Library” from the Type
drop-down list.

~iy You can also apply newels, balusters,
@ and panels onto stair or ramp railing
directly from the Library Browser. See
“Inserted Objects” on page 350.

0 A preview of the selected staircase
displays on the right side of the panel.
If the staircase includes any landings, only

Stair Landing Specification Dialog

the section that was selected when the dialog
was opened will display. See “Dialog
Preview Panes” on page 28.

Line Style Panel

The settings on the LINE STYLE panel are
available for a variety of other objects in the
program. For information about these
settings, see “Line Style Panel” on page 126.

Fill Style Panel

The settings on the FILL STYLE panel affect
the appearance of the selected staircase in

floor plan view. For information about these
settings, see “Fill Style Panel” on page 131.

Materials Panel

The settings on the MATERIALS panel affect
the appearance of the selected staircase in 3D
views and are available for a variety of
objects throughout the program. For
information about these settings, see
“Materials Panel” on page 372.

The settings on this panel will also affect the
materials applied to any landings attached to
the selected staircase. See “Landings” on
page 303.

I—l Select a landing and click the Open

Object edit button to open the Stair
Landing Specification dialog. See
“Landings” on page 303.

Stair Landing Specification Dialog

Many of the panels in this dialog are found in
the specification dialogs for a variety of
different objects in the program.
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General Panel

™ Stair Landing Specification

General Landing

Polyline

Selected Line
Railing
MNewels/Balusters
Line Style v
Fill Style
Materials

Top Height: |27 7/8

CKness: 734

[] Mo Rail on Selected Edge

Mumber Style. ..

Auto Adjust Height When Connected to Stairs

Auto Adjust Thickness When Connected to Stairs

L N

Cancel Help

0 Landing -

Uncheck Auto Adjust Height When
Connected to Stairs to specify the selected
landing’s Top Height.

* A free-standing interior landing will have
a default Top Height of 6 3/4” (169 mm)
plus the thickness of the default floor fin-
ish. A free-standing exterior landing will
have a default top height equal to its
thickness. When this box is checked, the
landing height may adjust as needed to
maintain consistent riser height in all
connected stair sections.

» The Top Height field is only active when
Auto Adjust Height When Connected to
Stairs is unchecked. See “Locked Land-
ings” on page 304.

Uncheck Auto Adjust Thickness When
Connected to Stairs to specify the selected
landing’s Thickness.

* A free-standing landing will have a
default thickness of 6 3/4” (169 mm).
When checked, the thickness is based on
the riser height of the stair sections it is

attached to, or the thickness of the ramps
it is attached to.

» The Thickness ficld is only active when
Auto Adjust Thickness When Connected
to Stairs is unchecked.

Check No Rail on Selected Edge to suppress
the railing on the selected edge of this
landing. See “Selected Edge” on page 94.
e A preview of the selected landing
displays on the right side of the panel.
See “Dialog Preview Panes” on page 28.

Polyline Panel

The POLYLINE panel states the length of the
landing’s Perimeter, its enclosed Area, and
its Volume.

The settings on the this panel are available
for a variety of other objects in the program.
See “Polyline Panel” on page 130.

Selected Line Panel

The SELECTED LINE panel is available when
the selected edge is a line as opposed to an
arc. See “Selected Edge” on page 94.



The settings on this panel are available for a
variety of other objects in the program. See
“Line Panel” on page 125

Moving the End of a line segment moves the
start of the next connected line.
Selected Arc Panel

The SELECTED ARC panel is available only
when the selected edge has been converted to
an arc. See “Change Line/Arc” on page 117.

The settings on this panel are available for a
variety of other objects in the program. See
“Arc Panel” on page 128

Line Style Panel

The settings on the LINE STYLE panel are
available for a variety of objects throughout

Stair Landing Specification Dialog

the program. See “Line Style Panel” on page
126

Fill Style Panel

The settings on the FILL STYLE panel affect
the appearance of the selected landing in
floor plan view. See “Fill Style Panel” on
page 131

Materials Panel

When a landing is attached to stairs, its initial
materials are derived from the stairs.

The settings on this are available for a variety
of objects throughout the program. For
information about these settings, see
“Materials Panel” on page 372.
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Home Designer Interiors’s automatic Roof
Tools allow you to draw almost any roof
style.

Proficiency with the Roof Tools can only be
attained through practice, but mastering
these tools saves you time and effort in plan
development. For information about creating
specific roof styles, see “Roof Tutorial” on
page 57 of the User’s Guide.

Chapter 22:

Roofs

Chapter Contents
Roof Defaults
The Roof Tools
Automatic Roofs
Build Roof Dialog
Editing Roofs
Skylights
Skylight Specification Dialog
Roof Pitches in Degrees
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Roof Defaults

@ Select Edit> Default Settings, to

open the Default Settings dialog for a
variety of drawing tools, several of which
directly affect roof generation.

Roof Defaults Dialog

The Build Roof and Roof Defaults dialogs
are nearly identical in appearance and
function. The only difference is that the
Build Roof dialog has a checkbox that
allows you to automatically generate roof
planes. See “Build Roof Dialog” on page
323.

Floor and Ceiling Heights

The initial heights of floors and ceilings,
which influence roof heights, are specified in
the Floor Defaults dialog for each floor. See
“Floor Defaults Dialog” on page 288.

The floor and ceiling heights in individual
rooms also influence roof heights and are
specified in the Room Specification dialog.
See “Structure Panel” on page 178.

~+  If Auto Rebuild Roofs is checked in the
@ Build Roof dialog and you change floor
or ceiling heights, wall positions or roof direc-
tives in walls, the roof rebuilds to reflect your
changes. See “Rebuilding Roofs” on page
323.

Wall Specification Dialog

By default, when a roof is built, a roof plane
is generated over each exterior wall, creating
a hip roof.

Any deviations from this default hip roof,
such as a gable or a different pitch, can be
specified in the Wall Specification dialog for
any exterior wall. See “Roof Panel” on page
156.

The Roof Tools
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Select Build> Roof to access the Roof
Tools.

Build Roof

Select Build> Roof> Build Roof to

open the Build Roof dialog, specify
the settings for automatically generated roof
planes, and build or rebuild a roof. See
“Build Roof Dialog” on page 323.

When roofs are automatically generated, a
roof plane is created over each exterior wall
by default, resulting in a hip roof.

To automatically generate a roof plane using
values other than the defaults or to not
generate a roof plane bearing on a particular
wall (as with a gable or the sides of a shed
roof), you can change the settings in the Wall
Specification dialog. See “Roof Panel” on
page 156.

For more information about creating
different roof styles, see “Roof Tutorial” on
page 57 of the User’s Guide.



Skylight

& Select Build> Roof> Skylight, then
Bl draw a rectangle over an existing roof
plane to create a skylight. The skylight, sky-
light shaft, and ceiling hole (if a ceiling
exists) are drawn at the same time. See
“Skylights” on page 326.

Automatic Roofs

Delete Roof

% Select Build> Roof> Delete Roof to
delete all roof planes in the plan. See
“Deleting Roof Planes” on page 325.

Automatic Roofs

When roofs are automatically generated, a
roof plane is created over each exterior wall
by default, resulting in a hip roof.

Roof Directives in Walls

To automatically generate a roof plane using
values other than the defaults or to not
generate a roof plane bearing on a particular
wall (as with a gable or the sides of a shed
roof), you can change the settings in the Wall
Specification dialog for that wall. See “Roof
Panel” on page 156.

For more information about creating
different roof styles, see “Roof Tutorial” on
page 57 of the User’s Guide.

Rebuilding Roofs

By default, whenever changes are made to
wall placement, floor/ceiling heights, or roof
directives in walls, the roof will update in
response. If you do not want the roof to
rebuild automatically, uncheck Auto
Rebuild Roofs in the Build Roof dialog. See
“Roof Panel” on page 324.

You can also rebuild the roof at any time to
reflect the current state of the model by
opening the Build Roof dialog and clicking
OK.

Build Roof Dialog

The Build Roof dialog is used to
automatically build or rebuild roof
planes. To open the Build Roof dialog, select

Build> Roof> Build Roof .

Roof planes are generated based on the
positions and roof directive settings for each
exterior wall in the plan. If you make
changes to any of these walls, you will need

to build the roof again for them to take effect.
See “Roof Panel” on page 156.

Aside from a checkbox on the ROOF panel
that allows you to automatically generate
roof planes, the settings in this dialog are
also found in the Roof Defaults dialog. See
“Roof Defaults” on page 322.

There are three panels in the Build Roof
dialog:
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. Roof Panel

. Roof Styles Panel

. Materials Panel
Roof Panel
™ Build Roof X
Roof Build
Materials Auto Rebuild Roofs
Roof Styles

Specifications

[ 1gnore Top (1st) Floor

Pitch (in 12)
Minimum Alcove Size:
Eave Overhang:
Gable Overhang:

| ok

Cancel Help

o The Build options are commands
related to building and rebuilding roofs.

» Ifyou check Auto Rebuild Roofs, the
program automatically rebuilds the roof if
you make a change that affects the roof,
such as to exterior wall positions or ceil-
ing heights.

* Check Ignore Top Floor to build the roof
so that it bears on the walls of the floor
below the top living floor in the plan.
When unchecked, the roof builds so that it
bears on the walls on the top floor of the
plan.

2]

+ Enter a value to describe the Pitch. In
plans using U.S. units of measurement,
pitch is described as a ratio over 12; in
metric plans, it is measured in degrees.
For a conversion to degrees, see “Roof
Pitches in Degrees” on page 328.

The Specifications settings affect basic
roof structure.

* Minimum Alcove Size - Specify the min-
imum width of an alcove (depression into
an otherwise straight exterior wall). Any
alcove less than the specified width is
treated as though the exterior wall contin-
ues straight across. Alcoves that measure
wider than this value are not roofed over;
they cause a change in roof planes.

Following is an example showing this
difference. If Min Alcove is 36", a 36" wide
alcove requires a change in the roof line.
Each wall of the alcove has an eave. On the
right, the alcove is less than the 36"
minimum, so the roof passes right over it.

e e
Y s s
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s
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The Roof Overhang is measured
horizontally from the exterior surface of the
wall’s framing layer to the end of the top of
the rafter. It does not include gutters,
sheathing or siding.

* Normal is the overhang at the eaves and
is always the overhang for a roof plane
having the default Pitch specified above.
If the pitch for a particular roof plane is
set differently, its overhang may try to
maintain its fascia at the same height.
Overhang can be greater for a shallower
pitch, lesser for a greater pitch.

* Gable is the overhang dimension at gable
ends or rake walls.

& If the roof overhang values are not suffi-
cient to extend past the outer layer of
exterior walls, the walls may not generate
correctly in 3D views.

Editing Roofs

Materials Panel

The settings on this panel allow you to
specify materials for the roof’s various
components. See “Materials Panel” on page
372.

Roof Styles Panel

The ROOF STYLES panel provides links to
tutorial information about creating different
roof styles automatically. Click on a roof
style to launch the online Help to a page with
information about the roof style you selected.
See “Roof Tutorial” on page 57 of the User’s
Guide.

Editing Roofs

Unlike most other objects in Home Designer
Interiors, roof planes cannot be selected and
edited. To make changes to the roof, you
must edit the edit roof directives in walls
and/or settings in the Build Roof dialog, and
then rebuild. See “Rebuilding Roofs” on
page 323.

An exception to this rule is the Material

Painter "8 tool, which you can use to
change the materials used by individual roof
planes without rebuilding the roof. Bear in
mind, though, that any changes made using

the Material Painter £ will not be retained
if the roof is later rebuilt. See “The Material
Painter” on page 369.

Deleting Roof Planes
There are several ways to delete roof planes.

% Delete the entire roof quickly by
selecting Build> Roof> Delete Roof.

% You can also delete all roof planes at
=% once in the Delete Objects dialog.
See “Delete Objects Dialog” on page 119.
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Skylights

& A skylight can be created by selecting
[nel Build> Roof> Skylight and drawing a T Z
rectangular polyline within a single roof : :
plane. You can also simply click once within | |
a roof plane to place a 2’ x 2’ skylight. -] ||
| |

| |

| |

o ;

The Skylight (o8l tool places a flat panel
skylight into a roof hole, produces a hole in
the ceiling platform below, and automatically
generates the skylight shaft between these
two holes.

To place a skylight in a vaulted ceiling,
uncheck Flat Ceiling Over This Room in
the Room Specification dialog, draw the
ceiling planes to produce the vault and edit
them as needed, and then draw the skylight.
See “Structure Panel” on page 178.

Editing Skylights

Skylights can be edited using the edit
handles, edit toolbar buttons, or the Skylight
Specification dialog. See “Skylight
Specification Dialog” on page 326.

Skylights must always be contained by a
single roof plane. If the roof plane is deleted,
any skylights it contains are also deleted.
Aside from this restriction, skylights can be
edited much like standard closed polylines.
See “Editing Closed-Polyline Based
Objects” on page 104.

Skylight Specification Dialog

I—l Select a skylight and click the Open Skylight Specification dialog. See
Object edit button to open the “Skylights” on page 326.
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Skylight Specification Dialog

General Panel

™ skylight Specification

Materials
Angle for Inside Hole Rim

General Skylight o
Line Style

(® Square Sides
() Plumb Sides
(O Plumb/Square

*

Cancel Help

o Specify the Frame Width and Height
of the selected skylight.

0 Angle for Inside Hole Rim - Defines
the shape of the skylight well where it
passes through the roof plane.

* Square Sides - The framing for the sky-
light is cut square to the pitch of the roof.

e Plumb Sides - The framing for the sky-
light is plumb-cut.

* Plumb/Square - The bottom edge is
plumb-cut, the top edge square-cut.

Polyline Panel

The POLYLINE panel states the skylight’s
Perimeter, its Framing Area, and its
Projected Area.

* The Perimeter is the length of the sky-
light’s perimeter with the pitch taken into
account. It does not equal the perimeter as
measured in floor plan view.

* The Framing Area is the area of the sky-

light with the pitch taken into account.

* The Projected Area is the area of the
skylight as seen in floor plan view.

Line Style Panel

For information about the settings on this
panel, see “Line Style Panel” on page 126.

Fill Style Panel

The settings on the FILL STYLE panel control
the appearance of the selected skylight in
floor plan view. For information about these
settings, see “Fill Style Panel” on page 131.

Materials Panel

For information about the MATERIALS panel,
see “Materials Panel” on page 372.
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Roof Pitches in Degrees

4,757 9.46” 14 18.44°
T ///|
12 12 12 12
1 2 3 4
22,57 ‘ 26.57° 30.26° 33.69°
12 12 12 12
5 [} T ]
36.87° 39.81° 42,51 45°
12 12 12 12
9 10 1" 12
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Trim

Chapter Contents
Trim and Molding Defaults
Corner Boards
Corner Board Specification Dialog
Quoins
Quoin Specification Dialog
Editing Corner Boards and Quoins
Millwork
Moldings
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Trim and Molding Defaults

@ Select Edit> Default Settings to open

the Default Settings dialog where
you can access the defaults for a variety of
drawing tools, including a number that affect
trim and moldings.

e Select “Floor” and click the Edit button
to specify the default moldings for rooms
on the current floor. See “Current Floor
Defaults” on page 165.

¢ Click the + beside “Door” to access the
defaults for Interior and Exterior Doors.
See “Door Defaults” on page 209.

* Select “Window” and click the Edit but-
ton to specify the default casing for win-

dows. See “Window Defaults” on page
226.

e Click the + beside “Cabinet” to access the
defaults for the Cabinet Tools, where you
can specify default crown and other mold-
ings. See “Cabinet Defaults” on page 248.

Corner Boards

330

| Corner boards are added to a building
L1 exterior in any view by selecting

Build> Trim> Corner Boards.

Click at a wall corner where you want to add
trim. Be sure to click where the outside wall
surfaces meet. If you click where the inside
surfaces meet, corner trim will be created
inside the room.

Corner boards extend from the top plate
down to the bottom of the floor platform of
the floor on which it is placed, but do not
extend to other floors. You must add corner
boards to all floors of the building that you
want to have corner boards.

A selected corner board or boards can be
moved, but only to another wall corner or
corners. In 3D views, corner boards can be
lengthened or shortened using the edit
handles. Corner boards can be copied,
deleted and resized similar to other objects
using the edit toolbar or the Corner Board
Specification dialog.

The default material for corner boards is
defined by the Exterior Trim entry in the
Material Defaults dialog. See “Material
Defaults” on page 368.



Corner Board Specification Dialog

Corner Board Specification Dialog

'—l Select corner board and click the
Open Object edit button to open the
Corner Board Specification dialog.

General Panel

Materials Panel program. For information about these

) settings, see “Materials Panel” on page 372.
The settings on the MATERIALS panel are

available for a wide variety of objects in the

Quoins
| Select Build> Trim> Quoins in any A selected quoin or quoins can be moved,
== view and click at a wall corner where but only to another wall corner or corners. In
you want to place quoins. 3D views, quoins can be lengthened or

shortened using the edit handles. Quoins can
be copied, deleted and resized similar to
other objects using the edit toolbar or the
Quoin Specification dialog.

The size of quoins in plan view is relative on
their size in 3D.

Initially, quoins use the same material as the
default material of the wall surface they are
placed against.

Quoin Specification Dialog

l—l Select quoin and click the Open
Object edit button to open the Quoin
Specification dialog.

General Panel

o Specify the Size of the quoins in the *  Specify the Width, which is the horizon-
selected Quoin object. tal dimension of each quoin in the
selected Quoin object. The dimension
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along the other wall is half this value
when they are staggered or mirrored.

+ Specify the Quoin Height for individual
quoins in the selected Quoin object.

(2]

+ Uniform - Produce quoins that are of
equal length on both sides of the corner.

Specify the arrangement of quoins used
by the selected Quoin object.

» Staggered - Produce quoins that have one
long side and one short side staggered on
opposite sides of the corner.

Materials Panel

The settings on the MATERIALS panel are
available for a wide variety of objects in the
program. For information about these
settings, see “Materials Panel” on page 372.

Editing Corner Boards and Quoins

Before a corner board or quoin can be edited,
it must be selected. Click on a trim object

when the Select Objects < tool is active.
Corner boards and quoins can also be group
selected and edited. See “Selecting Objects”
on page 94

Corner boards and quoins can be edited using
their edit handles, the edit toolbar buttons,
and their specification dialogs.

Using the Mouse

Depending on the type of view, a corner
board or quoin displays a different set of edit
handles when selected.

+ In plan view, corner boards and quoins
display one edit handle and can be moved
from one eligible location at a wall corner
to another.

* In 3D views, corner boards and quoins
can be moved, lengthened, and shorted
much the other line-based objects are. See
“Editing Line Based Objects” on page 96.

Using the Edit Buttons

A selected corner board or quoin can be
edited in a variety of ways using the buttons
on the edit toolbar. See “The Edit Toolbar”
on page 24.

Deleting Corner Trim

Corner boards and quoins can be selected
individually or in groups and deleted using

the Delete X edit button or the Delete key
on the keyboard. They can also be removed
using the Delete Objects dialog. See
“Deleting Objects” on page 119.

Millwork

332

A selection of various types of millwork
including columns, corbels and finials is
available in the Library Browser. See “The
Library Browser” on page 336.

Most millwork objects are designed to be
placed in a plan as free-standing objects.
Some - notably, newels and balusters - can
be assigned to objects such as railings and



stairs. See “Placing Library Objects” on page
349.

Moldings

Millwork assigned to an object can be
replaced from the library in 3D views. See
“Replace From Library” on page 351.

Moldings

Crown, base, and chair rail moldings can be
assigned to rooms in the Room
Specification dialog. See Moldings Panel on
page 310.

In some plan style templates, Wall and Full
Height Cabinets also have crown moldings.
These cabinets can be placed in any plan

from the library. See Template FilesPlans on
page 22.

Wall and Full Height Cabinets with crown
moldings are also available in the library at
Home Designer Core Catalogs> Cabinets>
Style Template Cabinets. See The Library
Browser on page 774.
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Home Designer Interiors’s library offers
thousands of symbols, materials, and images
that can enhance any plan.

New library catalogs and enhancements are
made available by Chief Architect on a
continuing basis and are available for
download for the current program version.

You can also customize items from the
library or import new items from outside the
program and then save them in the library for
future use.

The Library

Chapter Contents
. The Library Browser
. Searching the Library
. Library Content
. Downloading Library Content
. Importing Library Catalogs
. Adding Library Content
. Organizing the Library
. Exporting Library Catalogs
. Placing Library Objects
. Select Library Object Dialog
. Replace From Library
. Displaying Library Objects
. Editing Library Objects
. Symbol Object Specification Dialogs
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The Library Browser

336

uﬂlla. The Home Designer Interiors Library
4 Browser allows you to manage the
contents of the library as well as add library
content to your drawings.

To open the Library Browser:

+ Select View> Library Browser G

«  Click the Library Browser button .
e Press Ctrl + L on your keyboard.

By default, the Library Browser is docked to
the right side of the program window, but can
be undocked or docked to another side. See

“Docking the Library Browser” on page 339.

The Library Browser has four sections:

* The search options at the top.

* The Directory and Search Results Pane.
* The Selection Pane.

* The Preview Pane.

To adjust the height or width of a section,
place the pointer over the split bar you want
to move. When the double-headed arrow +*
displays, click and drag.

-~ You can control the configuration of the
@ Library Browser panes in the Prefer-
ences dialog. See “Library Browser Panel” on
page 60.

You can work on your drawing with the
Library Browser open. To close the Browser,
click the Close x| button or double-click on
an object in the Selection Pane.

The library directory is presented in a tree list
with five categories: Home Designer Core

Catalogs, Home Designer Bonus Catalogs,
Manufacturer Catalogs, User Catalog and
Trash. See “Library Content” on page 340.

Library Browser n

4 Home Designer Core Catalogs ~
4 Architectural
4 Appliances
4 Cooktops & Rangetops
4[] Large

Electric Cooktop
Extra Large Gas Cooktop
Gas 5 Burner Rangetop
Large Electric Rangetop

. n .

Large Electric Ran Large Gas Ranget Large Induction C

O b (@ m-
Search the library using keywords and

0 optional search filters. See “Searching
the Library” on page 339.

* Begin typing in the text field to search for
library items. As you type, search results
will display in the Directory Pane.

» Search a specific catalog or folder by
right-clicking on it and selecting Search



Folder. Multiple items can be searched in
this manner.

» Right-click on an item in the Search
Results list and select Show in Browser
to view the item’s location in the Direc-
tory list.

«  Click the Browse (% button to stop
searching and restore the Directory list.

«  Click the Search A button to display
the search results for your search entry.

* Click the Search Filtering Options
button to customize your search parame-
ters. If the Library Browser is resized so
that it is narrow, this button will be
replaced by two arrows.

9 The library Directory and Search
Results display here. The basic
structure of the directory tree is:

F Library Categary
o I'Fl Library Catalog 1
o I'['T| Library Folder 1
B Library Object

Library items are always placed in
alphabetical order within their heirarchy.

The Library Browser includes a Trash bin,
where deleted items are moved until you
choose to Empty Trash. See “Deleting
Library Items” on page 348.

Navigate the Directory Pane using the
mouse. Click the gray Expand arrow

beside a catalog or folder to display its
contents. Once expanded, you can click the
black Collapse arrow 4 to close it again.
You can also browse the list using the arrow
keys on your keyboard.

The Library Browser

Click on an item to select it. Preview images
display in the Selection and Preview Panes
and basic information about it also displays
in the program’s Status Bar. See “The Status
Bar” on page 29.

The Selection Pane shows a thumbnail
image of the item selected in the
Directory Pane.

When an item is selected in the Directory
Pane, a basic line-based representation of the
item displays in the Selection Pane.

« If'the selected item is a single object, a
preview of that object displays in the Pre-
view Pane. You can move your cursor
into the drawing area to place the item.
See “Placing Library Objects” on page
349.

¢ Ifthe selected item is a folder, a thumb-
nail image displays, representing each
item inside. Move your pointer over an
item in this pane to see a Tool Tip with
the item’s name. Click on a folder in the
Selection Pane to display its contents
here and make it the item selected in the
Directory Pane.

* Some folders may have too many items
to display useful thumbnails for each;
when this is the case, they do not display.

Click the Show/Hide Selection Pane [T
button to toggle the Selection Pane on and
off.

When an individual item is selected in

either the Directory or Selection Pane,
an image of it displays in the Preview Pane.
If the item is designed to be inserted into
another object such as a cabinet, that parent
object will also display in the preview.
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You can click the Toggle Preview Display

(@ button at the bottom of the browser
window to switch between preview images
in high and low detail.

If the selected object is a 3D symbol, you can
rotate and zoom in or out on the Preview
using the mouse.

If you have rotated a view in the Preview
Pane, you can restore the default angle either
by clicking in the Selection Pane or by right-
clicking on the Preview Pane and selecting
Reset Preview.

Click the Show/Hide Preview Pane [
button to toggle the Preview Pane on and off.

The toolbar at the bottom of the
browser aids in searching, displaying
panes, and managing library content.

H Click the Get Additional Online
HE?' Content button to launch your default
web browser to the Home Designer Interiors
web site, where additional library content is

available for download.
E Click the Show/Hide Selection Pane
button to toggle the Selection Pane on

and off.
EE Click the Show/Hide Preview Pane
button to toggle the Preview Pane on

and off.

ﬁ Click the Toggle Preview Display

¥ button to switch between high and
low detail images of a selected library object

in the Preview Pane.

@ A selected material will display on a
shape in the Preview Panel. The initial

shape is a Sphere, but you can select a Cube,

Teapot, or 2D Plane instead if you prefer.

Click the Prefe.rences button at the

bottom of the Library Browser to open
the Preferences dialog, where display
properties for the Library Browser can be
controlled. See “Library Browser Panel” on
page 60.

Using the Contextual Menus

A number of important library functions can
be accessed using the contextual menus.
Right-click on an item in the Library
Browser to open a contextual menu
displaying options related to that item. See
Contextual Menus.

Library Browser n

e e Q&

> Home Designer Core Catalogs
Home Designer Bonus Catalogs
Manufacturer Catalogs

4 [ User Catalog

mages :
L] Images :
[ Trash Cut Ctrl-X
Copy Ctrl-C
MNew D Folder
Delete
Backdrop...
Rename F2
Image...
Export Library. W Material...

¥ 30 symbol.

The options in the contextual menu vary
depending on the item selected, but may
include:

¢ Search Folder
* Cut/Copy/Paste
¢ Paste Shortcut

» Locate Shortcut Source

¢ New
¢ Rename
*  Delete



* Export Library

e Open Object

* Reset Preview

* Expand All/Collapse All

¢ Show in Browser

Keyboard Commands

The Library Browser can be navigated using
the arrow keys on your keyboard.

* The right and left arrow keys expand and
collapse folders.

* The up and down keys change which
library object is currently selected.

* Select an item and press F2 to rename it.

» Select an item and press the Delete key to
delete it.

Expand/Collapse All

When a library category or folder is selected
in the Directory Pane, Expand All and
Collapse All are available in the contextual
menu, allowing you to expand or contract its
contents in the tree view.

Searching the Library

Docking the Library Browser

Initially, the Library Browser side window is
docked to the right side of the main Home
Designer Interiors program window. To
undock it, click and drag its title bar towards
the center of the program window. Once
undocked, it can be moved and redocked in
the same manner. See “Side Windows” on
page 23.

When moved to the top, bottom, or side of
the program window, it automatically docks
in a vertical or horizontal orientation,
depending on its location. You can prevent
the Library Browser from docking by hold-
ing down the Ctrl key while dragging it.

To return the Library Browser to its original
position and size, click the Restore Position/
Size button in the Preferences dialog. See
“Reset Options Panel” on page 64.

Closing the Library Browser

The Library Browser can be closed in either
of two ways:

«  Click the Close I button at the top right
corner of the browser window.

* Select View> Library Browser il

Searching the Library

The Library Browser filtering options let you
focus your searches to meet parameters that
you define.

To search the Library Browser

1. Select View> Library Browser W\ and
click in the Search field at the top of the
Library Browser.

2. Begin typing a keyword to search for. As
you type, the search results will populate
in the Directory Pane below.
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3. You can use quotation marks “”’ to
search for an exact word or phrase, but
other operations are not supported.

4. You can click the Clear & button on
the right side of the Search field to
remove anything typed in this field.

5. Ifyou move your mouse pointer over the
Search field, a Tool Tip will state the
number of results of your search.

6. Right-click on an item in the Search
Results list and select Show in Browser
to view the item’s location in the Direc-
tory list.

You can also search the contents of one or
more specific catalogs and/or folders. Right-
click on a catalog or folder level item or
group-select multiple catalogs and/or folders
and right-click on them, select Search
Folder from the contextual menu, and
proceed with step 2, above. See “Shift and
Ctrl Select” on page 96.

Substrings are not included. For example,
searching for “windows” will not produce
“window” as a search result. On the other
hand, searching for “window” will produce
“windows” as a search result.

To search using custom filters

1. Click the Turn on search filtering
options =] button.

* Check Keyword to match the entered
search keyword with an object’s search
attributes.

* Check Entire Word to match the
entire keyword or words with the com-
plete name of the object.

* Check Folders to include library fold-
ers in your search.

2. Click the arrow beside Type, Style, or
Manufacturer to expand that category.
* Check the box beside one or more
Type of library item that you want to
include in your search.
* Check the box beside one or more
architectural or design Style to include
items of that style in your search.

* Check the box beside one or more
Manufacturer to include in your
search. Manufacturer catalogs that
were imported during the current pro-
gram session will not be listed here
until you exit out of and restart Home
Designer Interiors.

~+ To save time, check the box beside
@ Type, Style, or Manufacturer to select
all of the options in that category at once;
uncheck the box to deselect all of the options.

3. Type a keyword in the Search field. The
results will be filtered to match your
selected filtering options.

Library Content

The Home Designer Interiors library has five
categories: Home Designer Core Catalogs,
Home Designer Bonus Catalogs,

Manufacturer Catalogs, User Catalog and
Trash.



Home Designer Core Catalogs

The Home Designer Core Catalogs category
contains a wide selection of 3D symbols,
images, and materials. When you install the
program from DVD, this library content will
also be installed; if you download the
software, you will be able to download the
Core Catalogs separately, after the program
is installed.

When you launch the program for the first
time, it will ask if you want to download the
Core Catalogs. Click Yes to begin the
download. If you click No, you can
download at any time by selecting Library>
Install Core Content from the menu.

Home Designer
Bonus Catalogs

Chief Architect regularly posts new library
catalogs available for download. Select
Library> Get Additional Content

Online % from the menu to access the
bonus catalogs and content.

Most Bonus Catalogs can be purchased for a
nominal fee, while others are available free
of charge. In addition, some Bonus Catalogs
are only available to Chief Architect Support
and Software Assurance program members.

Manufacturer Catalogs

A variety of name brand library catalogs is
available for download on the Home
Designer web site with content ranging from
materials to fixtures.

Select Library> Get Additional Content

Online i to access these Manufacturer
Catalogs.

Library Content

As with the Bonus Catalogs, some
Manufacturer Catalogs are available free of
charge while others can be purchased, and
some are available for Support and Software
Assurance members only.

Note: Support and Software Assurance is an
optional program for holders of Chief Archi-
tect Premier and Chief Architect Interiors soft-
ware licenses and is not available for Home
Designer licenses.

The User Catalog

The User Catalog is the location for items
that you add to the library either from a
drawing or by importing. See “Adding
Library Content” on page 345.

You can create and organize custom library
folders and imported images, backdrops, and
materials. See “Organizing the Library” on
page 346.

Updating Library Catalogs

The Home Designer Core Catalogs, Bonus
Catalogs, and Manufacturer Catalogs are
updated periodically to include new and
improved content. You can update your
installed catalogs to include the latest content
by selecting Library> Update Library
Catalogs at any time.

The program will gather information about
the content in each of these three categories,
and then download and replace any content
that is not up to date, and you may see a
progress indicator at the bottom of the
Library Browser while it is doing so. See
“Download Progress” on page 343.
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Library Content Location

The Home Designer Interiors User Catalog
File, User Library.calib, is located in the
Home Designer Interiors 2019 Data folder.
See “Home Designer Interiors Data” on page
37.

All library content aside from your User
Catalog is stored in the System Library
Database Folder. By default, this folder is
created in the directory intended for shared
application data in your operating system
(C:\ProgramData in Windows; /Library/
Application Support in macOS).

You can specify a different location if you
wish in the Preferences dialog. If you
choose a removeable drive or network
location, library slowness may result. See
“Folders Panel” on page 61.

& If you choose to use a different folder,
you must specify a directory on a hard
drive with sufficient space to hold these files.

Backing up Custom Content

The best way to back up your custom library
content is to export the items in your User
Catalog, as this will ensure that the textures
used by custom materials are not lost. See
“Backing Up Your Files” on page 41.

Exported libraries use the .calibz file format:
a zipped file type that can include textures
and images along with other library data.

To back up your custom library content

1. Launch Home Designer Interiors and

select View> Library Browser il
from the menu.

2. Right-click on a folder or item in the
User Catalog.

3. Select Export Library from the contex-
tual menu.

4. The Export Library Data dialog is a typ-
ical Save dialog. See “Exporting Files”
on page 41.
* Notice that the file type in the Save as
type field is “Library File with Tex-
tures/Images (*.calibz)”.

Downloading Library Content

The Home Designer Core Catalogs, Home
Designer Bonus Catalogs, Manufacturer
Catalogs are all available for internet
download.

Core Catalogs

When you launch Home Designer Interiors
for the first time, you will be asked if you
want to download the Core Catalogs. Click
Yes to begin the download.

If you click No, you can download at any
time by selecting Library> Install Core
Content from the menu.

Bonus and Manufacturer
Catalogs
Bonus and Manufacturer Catalogs can be

downloaded from our web site,
www.HomeDesignerSoftware.com. Select




Library> Get Additional Content

Online & to launch your default internet
browser to our Content Resources page.

Download Progress

When library content is downloading, a
green progress bar will display at the bottom
of the Library Browser. If you choose to
download the Core Catalogs while the library
is not open, the Browser will open so the
progress indicator can display.

Click on the progress bar to display the name
of the current file being downloaded, the
total amount of data to be downloaded in
KB, and the amount downloaded so far.

Downloading: CoreCatalogFiles. zip 17,155 of 227,472 KB

| b EIEEE

Pausing and Resuming

Library downloads can only take place while
Home Designer Interiors is running. If you
close the program while a download is in
progress, a dialog will confirm whether you
wish to stop the download.

Importing Library Catalogs

* Click Stop Download and Close Pro-
gram to stop the download and close the
program.

e Click Cancel to leave the program open
and continue downloading.

Most catalogs are composed of a single file.
If you stop the download midway, none of
the downloaded data will be retained.

The Core Catalogs, on the other hand,
contain a large volume of data saved in
multiple files. If you close the program and
stop the Core Catalogs download midway,
only data associated with the file currently
being downloaded will be lost. You can
resume the download beginning with that file
at a later time by selecting Library> Install
Core Content.

Download Errors

If any problems occur during the library
download process, a dialog box will notify
you at the end of the download. Click Retry
Download to repeat the download and
correct any errors or click Cancel to discard
the downloaded catalog.

Importing Library Catalogs

Home Designer Interiors library files have
two different file extensions: .calib and
.calibz. Both files can include any
combination of Home Designer Interiors
library items; in addition, .calibz files are
able to save data associated with textures and
images. Both file types can be imported into
the Home Designer Interiors library.

There are several ways to import a .calib or
.calibz file into the program library:

* Double-click on the file in an operating
system window while a plan file is open.

* Drag the file from an operating system
window and drop it into the Home
Designer Interiors program window.
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+ Select Library> Import Library from
the program menu.

Note: Library files cannot be imported if no
plan file is open, or when a Materials List win-
dow is active.

To import library filesinto the library

1. Select Library> Import Library to dis-
play the Import Library Data dialog.

2. Browse to the .calib or .calibz file that
you want to import and select the files so
that its name displays in the File Name
field.

Click the Open button.

4. A progress bar will display, telling you
the progress of each library data file as it
is imported. Once imported, each file
will be located in the User Catalog.

When a .calib or .calibz file is imported into
the program, its contents are automatically
placed in the User Catalog. Any images or
textures saved in a .calibz file will be copied
into the Home Designer Interiors 2019 Data\
Images and Textures folders for backup
purposes. The program will only reference
these copies if it cannot locate the files in
their original locations. See “Home Designer
Interiors Data” on page 37.

Library Catalog Migration

If you have library catalogs from Home
Designer Interiors 2014 through 2018
installed on your computer, the initial startup
of Home Designer Interiors 2019 will give
you the opportunity to migrate that content

into the Home Designer Interiors 2019
Library. See “Migrating Settings and
Content” on page 15.

Legacy Library Conversion

You can import .calib and .calibz files
created in Home Designer versions 2012, 10,
or 9 for use in version 2019 at any time. See
“Exporting Library Catalogs” on page 348.

Note: Library content exported from Home
Designer Interiors 10 will not include catalog
names. Any subscribed content from version
10 that has not been downloaded will not be

included, either.

In addition, legacy .alb files created in Home
Designer versions 8.0 and prior can be
converted for use in version 2019.

To convert legacy library files

1. Select Library> Convert Legacy (.alb)
Library Files.

2. Inthe Select a Legacy Library File
Folder dialog, select an .alb file that
you want to bring in to Home Designer
Interiors 2019.

3. The selected file’s name will display in
the File name: field.

4. Click the Open button to import the
prior version third party .alb file into the
User Catalog.

5. Organize the imported content to suit
your needs. See “Organizing the
Library” on page 346.




Adding Library Content

Adding Library Content

In addition to downloading Home Designer
Interiors Content and importing entire
catalogs into the library, you can also add a
variety of individual objects to the library.

Add to Library

Nearly any object placed from the Library
Browser can be added to the User Catalog in
the library. Select an object in your plan and

click the Add to Library W edit button.

A few objects cannot be added to the library:
notably imported pictures, metafiles, and
PDF files.

Any object created using a drawing tool in
Home Designer Interiors will automatically
be added to the User Catalog using the name
of that tool, whereas a symbol will automati-
cally use the Symbol Name. See “Native
Objects vs Symbols” on page 353.

Once added to the library, objects in the User
Catalog can be renamed. See “Renaming
Library Items” on page 346.

Adding Materials and Images

New materials, images, and plant images can
be created in the User Catalog. Right-click
on the User Catalog or a folder within it,
select New> from the contextual menu, then
select the type of item you wish to create
from the submenu.

Home Designer Interiors can use materials
and images in a variety of file formats and
provides several means of adding new
material and image files to the library. For
more information, see “Creating Materials”

on page 375 and “To create an image in the
Library Browser” on page 415.

Adding New Backdrops

A backdrop is an image, typically of an
exterior view, that displays in the background
of 3D views to help place the model into a
realistic setting and add a sense of
perspective. See “3D Backdrops” on page
423.

A new backdrop image can be created using
a variety of graphic file formats and can be
imported into Home Designer Interiors in
several ways:

» Select File> Import> Backdrop B4 to
open the Import Backdrop File dialog,
which is similar to the Import Picture
File dialog. See “Importing Pictures” on
page 420.

* Right-click on the User Catalog and
select New> Backdrop from the contex-
tual menu.

» Copy and paste an image into Home
Designer Interiors. See “Copying and
Pasting Objects” on page 81.

Creating a Customized
Library Item

You can customize an existing library object
and save your changes for future use by first
copying the item into an unlocked library.
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To customize a library object

1. Right-click on a library item and select
Copy ™" from the contextual menu.

2. Browse to the User Catalog or a folder
within it and right-click on it.

3. Select Paste from the contextual menu
to make a copy of the library item in this
new location.

4. Right-click on the copied item and select
Open )1 from the menu.

5. The item’s specification dialog opens,
and you can make any changes that you
wish to the item.

6. Make any needed changes to the item,
then click OK. Your changes will be
saved with this item for use in any plan.

Organizing the Library

Library folders and objects can be copied,
pasted, moved, and deleted: allowing you to
organize your User Catalog to best suit your
work style and needs.

Adding New Folders

New folders can be added to the User
Catalog or to any folder located within it. To
add a new folder, right-click on User Catalog
or one of its sub-folders and select New>
Folder from the contextual menu.

The new folder is created inside the library
item you right-clicked on and is initially
named “Untitled”. Type a short, descriptive
name and press Enter.

Library Browser n

Type to start searching... Q @

> Home Designer Core Catalogs

Home Designer Bonus Catalogs
Manufacturer Catalogs
4 [ User Catalog
["] 3D Symbols
M Backdrops
M Images
[—| Materials

—
[ Trash L5

Selecting Library Iltems

To select a library object, folder, or category,
simply click on it.

When an item is selected, preview images
display in the Selection and Preview Panes
and basic information about it also displays
in the program’s Status Bar. See “The Status
Bar” on page 29.

A selected library item can be modified in a
number of ways to help meet your
organizational needs.

Renaming Library Items

Only folders and objects in the User Catalog
can be renamed. There are several ways to do
this from the tree list:

* Right-click on the item, select Rename
from the contextual menu, and type a
new name.

» Click once on the item, press F2 on your
keyboard and type a new name.

* Click once on the item, pause for a
moment, then click a second time and
type a new name.



Library names are case-sensitive and can
contain up to 63 characters. While you can
have more than one library item that uses the
same name, it is best to use short, descriptive
and unique names.

Moving Library Items

Folders and objects in the User Catalog can
be moved to new locations within the User
Catalog. Folders and library objects are
always organized alphabetically within each
hierarchy.

To move an item to a different location,
select it in the tree list, then click and drag it
to the new location in the list. Directories and
folders able to accept new content highlight
as your mouse pointer moves over them.
Release the mouse button to relocate the
selected library item in the highlighted
location.

You can also cut a library item from one
location and paste it in another. When an
item is cut, it is removed from its current
location and saved to the system clipboard.
To cut an item:

* Right-click on it and select Cut from the
contextual menu.

e Click on the library item and press
Ctrl + X on your keyboard.

To Paste the item, click on a library catalog
or folder in the Library Browser tree view
and either:

* Right-click on the new location and
select Paste from the contextual menu.

* Press Ctrl + V on your keyboard.

Organizing the Library

Copying Library Items

All library folders and library objects can be
copied and pasted to new locations in the
User Catalog.

There are two ways to copy a library item to
the system clipboard:

* Right-click on it and select Copy from
the contextual menu.

¢ Click on the library item and press
Ctrl + C on your keyboard.

To Paste the item, click on a library catalog
or folder in the Library Browser tree view
and either:

* Right-click on the new location and
select Paste from the contextual menu.

* Press Ctrl + V on your keyboard.

When a library item is copied and pasted, the
new item that results is independent of the
original item. If you make changes to it, the
original item is unaffected. Similarly,
changes to the original item do not affect the

copy.

Library Shortcuts

In addition to copying and pasting to create
new, independent library items, you can copy
and paste to create Library Shortcuts. Library
Shortcuts are not independent items - they
are linked to the original item and are
affected if changes are made to the original.

Library Shortcuts are advantageous because
you can place a given library item in multiple
locations to suit your organizational style
without increasing the size of the library
database and without having to maintain
multiple copies of the same item.
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To create a Library Shortcut, copy a library
item to the system clipboard. Then, right-
click on the location where you would like to
create a copy and select Paste Shortcut from
the contextual menu. Library Shortcuts use
the same name as their source item but use

the Library Shortcut &~ icon.

To locate a Library Shortcut’s source item,
right-click on it in the tree list and select
Locate Shortcut Source.

If you move or delete an item from the
library, any shortcuts to it will not be updated
or removed. If you try to use a “hanging”
shortcut, a message about its status will
display in the library preview panes.

Deleting Library Items

The five installed library categories: Home
Designer Core Catalogs, Home Designer
Bonus Catalogs, Manufacturer Catalogs,
User Catalog, and Trash cannot be deleted.

Catalog level folders in all categories can be
deleted; however, individual subfolders and
objects can only be deleted out of the User
Catalog.

Items in the library that are eligible for
deletion can be deleted in either of two ways:

» Right-click on it and choose Delete from
the contextual menu.

» Select it and press the Delete key on your
keyboard.

When items from the User Catalog are
deleted, they are moved to the Library

Browser Trash 'Iﬂ' Items in the Trash can be
retrieved by clicking and dragging them into
any location in the User Catalog.

To empty the Trash ﬁ, right-click on it and
select Empty Trash from the contextual
menu.

Depending on how much content is in the
Trash, emptying it can be time consuming.
You can click the Cancel button to end the
process if you wish.

& The Empty Trash command is both
immediate and permanent. It cannot be
undone, so use care when using it. You
should back up all your library files regularly.
See “Backing up Custom Content” on page
342.

Exporting Library Catalogs
Exporting library files allows you to:

« Back up your custom library content.

+ Transfer library content between comput-

€rS.

Exporting is often preferable to simply
copying library files because it allows you to
include images and textures in the exported
library.
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To export content from the library

1. Locate an object, folder, or catalog that
you want to export, right click on it, and
select Export Library.

2. In the Export Library Data dialog.

* Choose the appropriate Save in: loca-
tion for your exported library file.



* Type a short, descriptive name for your
library file in the File Name field.

* Click the Save as type: drop down list
and select whether or not you want the
library to include Textures/Images.

-+ If any of the items being exported are
@ images or use textures, be sure to
select the .calibz file type.

Placing Library Objects

* Click Save.

3. Your exported library file can now be
copied to a network location or storage
device in an operating system window.

Any Shortcuts i';:' present in a catalog will
be converted to regular library objects when
exported. See “Library Shortcuts” on page
347.

Placing Library Objects

Library objects are subject to placement
restrictions based upon typical real-life
placement. Most library objects require
sufficient free space at the location where
they are placed, for example, and some
library objects have additional requirements.

Library windows and doors, for example,

must be placed in a wall just like standard
windows and doors, and some fixtures are
designed to be placed in cabinets.

If a warning message displays when placing
a library object, it will indicate where the
object can be placed.

There are three main categories of items
available in the Library Browser:

« Stand-alone objects that can be placed
directly into a plan. Examples include
cabinet modules, furnishings and images.

* 3D objects designed to be inserted into
another 3D object. Examples include
cabinet fixtures, windows and doors.
Some items, such as cabinet doors and
fixtures, can be inserted into another
object or placed as stand-alone objects.

e Materials, which cannot stand alone and
must be assigned or applied to another
object.

Stand-Alone Objects

Most library categories contain objects that
can be selected in the Library Browser and
placed directly in a 2D or 3D view.

*  Most stand-alone objects are designed to
rest on the floor.

* Some objects will rest on top of a cabinet,
shelf, furniture or roof plane object if one
is located at the point where they are first
placed.

* A few objects, notably some light fix-
tures, will mount on the bottom of a wall
cabinet or on the ceiling.

¢ In addition, some objects will attach to a
wall if one is nearby.

To place a stand alone library object

1. Click on an object in the tree view or
Selection Pane of the Library Browser to
select it for placement. See “The Library
Browser” on page 336.
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2. Move your mouse pointer into the view
area and notice that it displays an icon
indicating the type of object selected
instead of an arrow.

3. Click to place the selected object at that
location.

4. Continue clicking to place as many
instances of the selected object as
needed. When you are finished, click the

Select Objects || button.

Once a stand-alone object has been placed, it
can be edited in a variety of ways. See
“Editing Library Objects” on page 353.

Inserted Objects

Some objects cannot stand alone and must be
placed into other objects in a plan. For
example, doors and windows must be
inserted into a wall, while some appliances
and plumbing fixtures are designed be placed
inside a base cabinet. See “Doors” on page
209, “Windows” on page 225 and “Cabinets”
on page 247.

An inserted object can only display in a 2D
or 3D view if the object that contains it is set
to display. This is the case even if the
inserted object’s layer is turned on. See
“Displaying Library Objects” on page 352.

Toinsert a library object

1. Click on an item in the tree view or
Selection Pane of the Library Browser to

select it for placement. See “The Library
Browser” on page 336.

2. Move your pointer into the drawing
area.

3. Click on the object into which you wish
to insert the selected library item. If the
selected library item is designed to be
inserted into that type of object, it will
be placed into it.

4. Continue clicking on other objects to
place as many instances of the selected
item as needed. When you are finished,

click the Select Objects || button.

When an object has been inserted into
another object, it can be replaced directly
from the library. See “Replace From Library”
on page 351.

Assigned Items

Some library items, such as materials, are not
objects in themselves but can be applied to
objects in a variety of ways.

» Using the specification dialog of the con-
taining object. See “Select Library Object
Dialog” on page 350.

* By selecting the item in the library and
then clicking on the containing object.

*  Materials can be assigned to objects
directly from the library in 3D views or
by selecting the material and then
clicking on an object’s surface. See “The
Material Painter” on page 369.

Select Library Object Dialog
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The Select Library Object dialog is a modal
version of the Library Browser that is

accessible from object specification dialogs.
See “Specification Dialogs” on page 28.



The Select Library Object dialog only
displays categories of items that are related
to the selected object. For example, if the
dialog is accessed from the GENERAL panel
of the Door Specification dialog, only door
symbols will be listed:

Replace From Library

The Select Library Object dialog is similar
to the LIBRARY MATERIALS panel of the
Select Material dialog. See “Select Material
Dialog” on page 373.

Replace From Library

There are two different ways to replace an
object in a plan with another object from the
library.

In 3D views, an inserted object can be
replaced by a different item from the library
with a single click. See “Inserted Objects” on
page 350.

To replace an inserted object

1. Open the Library Browser, and browse
to an object of a type similar to the one
you wish to replace.

2. Select the object and move the mouse
pointer into the 3D view window.

3. The Replace from Library 3& icon will
display near the mouse pointer when it
passes over an object that can be
replaced by the selection from the
library.

4. Click once to replace the object in the
plan with the selected object from the
library.

Some types of inserted objects - notably,
doors and cabinet doors and drawers - can
also be replaced in this manner in floor plan

view. The Replace from Library g icon
does not display in floor plan view, however.

~iv You can override the Replace from
@ Library functionality by holding down
the Alt key while clicking. A free-standing
object will be created if there is space for it
instead of an inserted object being replaced.

= | The Replace From Library edit

== button is available for nearly any
stand-alone object that can be added to the
library and can be used in 2D and 3D views.
Click this button to open the Replace From
Library dialog and replace the selected
object, and others like it if you choose, with
an object of the same type from the library.

™ Replace From Library *
Replacement Options o
(® Replace selected object
(O Replace identical objects in room
(O Replace identical objects on floor

Replace with o

Pedestal Sink 01

OK Cancel Help

o Select one of the Replacement
Options.

» Select Replace Selected Object to
replace only the currently selected object.

» Select Replace Identical Objects in
Room to replace all objects that are in the
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same room as, and are identical to, the
currently selected object. Not available
for doors or windows.

* Select Replace Identical Objects on
Floor to replace all objects that are on the
same floor as, and are identical to, the
currently selected object.

e Click the Library button to open the

Select Library Object dialog and select
an object to use as a replacement. The name

of the object that is currently selected as a
replacement displays above.

Replace From Library = cannot be used
to replace a selected cabinet with a cabinet of
a larger size. In addition, it is not available
for backdrops and items assigned to other
objects, such as materials.

& If the Replace from Library edit tool is
used to replace an electrical object, any
Connect Electrical splines attached to it will
be deleted. See “Connect Electrical” on page
268.

Displaying Library Objects

352

The display options available for library
objects depend on the type of object in
question, as well as the view.

If the display of an object is turned off in a
2D or 3D view, any objects inserted into it
will not display in that view, either - even if
the inserted object’s layer is turned on. See
“Inserted Objects” on page 350.

In Floor Plan View

All library objects except materials, doors
and drawers applied to cabinets, and
backdrops can display in floor plan view.
Library objects are represented in floor plan
view by 2D symbols that resemble the size
and shape of the object when viewed from
above.

As with other architectural objects, the
display of library objects is controlled by
layer in the Display Options dialog. Each
library category has its own layer. See
“Display Options Dialog” on page 88.

Like other objects, each library symbol is
placed in a Drawing Group that affects
whether it displays in front of or behind other
objects. You can modify a selected symbol’s
place in the drawing order by clicking the

View Drawing Group Edit Tools T8 edit
button. See “Drawing Group Edit Tools” on
page 89.

Object Labels

Fixtures, Furnishings, Geometric Shapes,
Hardware, Millwork and Plants can display
labels in floor plan view when the
appropriate layer is set to display in the
Display Options dialog. For example,
fixture labels are placed on the “Fixtures,
Labels” layer.

In 3D Views

All library objects can display in 3D views.

By default, images rotate to face the camera
in 3D views. For information about turning
off image rotation, see “Image Specification



Dialog” on page 416.

Editing Library Objects

Editing Library Objects

Like native Home Designer Interiors objects,
library objects can be customized to suit your
design needs. There are three approaches to
editing library objects:

» Select an object in the User Catalog, edit
it using any of the options in its contex-
tual menu, and your changes will be
reflected when you next place this library
object in a drawing.

* Place an object in a drawing and then edit
it using the various edit tools available
for it. This will not affect the original
object still saved in the library.

* Place an object in a drawing, edit it using
the available edit tools, and then add it
back to the library for future use. This
will not replace the original object still
saved in the library. See “Add to Library”
on page 345.

Library objects placed in a drawing can be
selected individually or as a group, like other
objects in Home Designer Interiors. See
“Selecting Objects” on page 94.

Once selected, library objects can be edited
in a variety of ways using dimensions, the
edit handles, the edit toolbar buttons and the
specification dialog. See “Symbol Object
Specification Dialogs” on page 354.

Native Objects vs Symbols
In Home Designer Interiors, objects created

using the program’s standard tools, such as

the Door Tools and Cabinet Tools @,
are referred to as native objects.

On the other hand, objects placed from the
library, such as fixtures and furnishings, are
symbols. Symbols are typically more limited
than native objects in how they can be edited.

Any changes made to objects like fixtures
and furniture will not be reflected in their
Materials List Description, although they
may be seen in other columns, such as Size.
See “Materials Lists” on page 437.

Using Edit Handles

Most library symbols are box-based objects
and can be edited as such once placed in a
drawing. See “Editing Box-Based Objects”
on page 106. Depending on the type of view
and the surface selected, the edit handles a
symbol displays will vary.

When a furnishing or fixture symbol is
selected in floor plan view or on the top
surface in a 3D view, up to ten edit handles
display. They are the Move handle at the
center, the Rotate handle just outside the
front indicator (a V) and a Resize handle on
each edge and at each corner.

When a symbol is selected on a side in a 3D
view, it displays six edit handles: the Move
handle, a Rotate handle, and a Resize handle
on each edge. See “Selected Side” on page
95.

Fixtures and furniture placed in a plan are
subject to bumping/pushing behavior when
moved. See “Bumping/Pushing” on page
112.
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Symbol Object Specification Dialogs

|—| The Fixture, Furniture, Geometric For example, selecting a library object
Shape and Millwork Specification placed from the Interiors Core Catalog and

dialogs all feature th.e same options: The clicking the Open Object 1 edit button

actual name of the dialog is determined by opens the Furniture Specification dialog.

the type of object that is currently selected.

General Panel

r\l Furniture Specification *
:El::iaalls N.ame. .S.Iat Back Chair o - lZ‘
Size [Position o
Depth:
|:| Retain Aspect Ratio
Reset Size
Elevation Reference: From Floor =
Floor to Top:
Floor to Bottom:
Options o
[ reverse Symbaol
Flush Mounted
Copyright o
Copyright® 2010, Chief Architect, Inc.
Cancel Help

0 The Name of the selected symbol ¢ Click Reset Size to reset the symbol’s
object displays here. original, unmodified size. The symbol’s

e Size/Position - elevation is not affected by this option.
* Select the Elevation Reference from the

. Specify the Height, Width, and Depth of drop-down list. Thls determines where
the object. the next two settlngs are measured from

and also affects their setting labels.

* Check Retain Aspect Ratio to maintain
the ratio between the object’s Height,
Width, and Depth when it is resized in the
specification dialog. Does not affect the
behavior of the object’s edit handles.

*  Specify the height to Top, measured from
the selected Elevation Reference to the
top of the object.
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*  Specify the height to Bottom, measured
from the selected Elevation Reference to
the bottom of the object.

9 Options -

Check Reverse Symbol to reverse the
object’s appearance, so that features on its
left are positioned on its right, and vice versa.
This turns a right-hand refrigerator, for
example, into a left-hand refrigerator. This
option has no effect on objects that are
symmetrical.

e Check Flush Mounted to specify that the
selected object follow the pitch of either
the ceiling or roof. Only available when
“From Ceiling” or “From Roof” is
selected as the Elevation Reference,
above.

o If the selected object has a Copyright,
information about it displays here.

Symbol Object Specification Dialogs

6 A preview of the selected library object

displays here and updates with changes.
If the selected symbol is inserted into another
object, such as an appliance in a cabinet, the
parent object will also display. See “Dialog
Preview Panes” on page 28.

Materials Panel
For information about the settings on this
tab, see “Materials Panel” on page 372.

Manufacturer Panel

The MANUFACTURER panel provides contact
information for the selected object’s
manufacturer. Only available for symbols
from Manufacturer library catalogs. See
“Manufacturer Catalogs” on page 341.
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Chapter 25:

Architectural

A selection of pre-arranged rooms library
catalogs is available for download. These
pre-arranged rooms are a collection of
fixtures, furnishings and accessories that are
grouped together so that they can be placed
and moved as a single object. See
“Downloading Library Content” on page
342.

3D objects that are grouped together like this
are referred to as Architectural Blocks.
Although blocked together, these objects
retain many of their own attributes, such as
materials.

Architectural blocks can also be exploded so
that the individual sub-objects become
independent of one another.

Blocks

Chapter Contents
. Displaying Architectural Blocks
. Editing Architectural Blocks

. Architectural Blocks and Sub-Objects
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Displaying Architectural Blocks

As with individual objects, the display
of architectural blocks is controlled in

the Display Options dialog. See “Layer

Attributes” on page 87.

+ If an architectural block is composed of

objects that are on the same layer, the
block will be placed on that layer, as well.

» If an architectural block is composed of
objects on different layers, the block will
be placed on the “Architectural Blocks”
layer.

Editing Architectural Blocks

Architectural blocks can be selected and
edited in 2D and 3D views. See “Selecting
Objects” on page 94.

Once selected, an architectural block can be
edited using its edit handles and edit toolbar
buttons.

Using the Edit Handles

A selected architectural block displays a
Move handle and a Rotate handle.

Architectural blocks cannot be resized, but
the individual objects in the block can be.

Using the Edit Tools

A selected architectural block or blocks can
be edited in a variety of ways using the
buttons on the edit toolbar. See “The Edit
Toolbar” on page 24.

Editing Sub-Objects

The individual objects included in an
architectural block can also be selected and
edited. See “To select a sub-object” on page
359.

Explode Architectural Block

-’ You can break an architectural block
to make its objects independent.
Select the architectural block and click the
Explode Architectural Block edit button.

Note: If you open a plan created in another
version of Home Designer and an architec-
tural block includes an object that you cannot
create in your version of the software, you
cannot unblock it or edit its components.

Once exploded, an architectural block cannot
be made into a single object again.

An architectural block is composed of a
group of sub-objects that have been blocked
together. For example, a kitchen island

Architectural Blocks and Sub-Objects

architectural block may consist of cabinets,
appliances, and other accessories.



Each of the sub-objects in an architectural
block may contain additional parts called
components. The cabinets in a kitchen island,
for example, may contain handles, hinges,
and drawer glide.

Sub-Objects

Certain attributes of an architectural block
can be edited at the sub-object level. A sub-
object can be edited by accessing its
specification dialog in either of two ways:

* Explode the architectural block, select
the sub-object, and click the Open

Object J1 edit button.

* Select the sub-object while it is part of
the architectural block and click the

Open Object b1 edit button. Some attri-
butes may not be editable while the
object is part of a block. See “Editing
Architectural Blocks” on page 358.

To select a sub-object

1. Click the Select Objects | & button,
then click on the sub-object that you
would like to edit.

2. With the architectural block selected,

click the Select Next Object rex edit
button or press the Tab key.

The selection switches to the individual
object and it can be edited using its edit
handles, edit toolbar and specification
dialog.

The options for editing a sub-object may be
more restricted than if the object were
independent. If more extensive editing is
required, the architectural block must be
exploded.

Architectural Blocks and Sub-Objects
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Chapter 26:

Other Objects

Home Designer Interiors has additional
objects that can be used to customize your
design.

Chapter Contents
. General Shapes
. Soffits

. Special Applications for Soffits
. Soffit Specification Dialog

General Shapes

wr- Items in the Home Designer Core

U Catalogs> Shapes library catalog
allow you to create a variety of custom
objects using basic geometric shapes. These
shapes can can be used individually or

combined to create a wide variety of custom
objects.

General Shape objects are placed and edited
much like other library objects. See “Editing
Box-Based Objects” on page 106.

Soffits

@ Soffits typically fill the space between
the tops of wall cabinets and the
ceiling, but they are very versatile and can be
used to create almost any other object that
can be modeled as a 3D box. Select Build>
Cabinet> Soffit to activate this tool.

Soffit Defaults

The default settings for soffits are set in the
Soffit Defaults dialog. The settings in this
dialog are similar to those in the Soffit
Specification dialog. See “Soffit
Specification Dialog” on page 364.
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For best results when placing soffits above
wall cabinets:

e The default soffit should be the same
width as and 1" (20mm) deeper than the
default wall cabinet. See “Cabinet
Defaults” on page 248.

* The default soffit Floor to Bottom value
should equal the sum of the default wall
cabinet’s Floor to Bottom value plus its
Height. See “General Panel” on page
364.

* The default soffit Height should be equal
to or greater than the space between the
ceiling and the top of the wall cabinets.

If the sum of the default soffit’s Floor to
Bottom value and Height is larger than the
ceiling height of the room in which a soffit is
placed, the Floor to Bottom value will be
retained and its Height will be adjusted so
that it fits under the ceiling.

The maximum soffit width is 250 feet (48m),
and the minimum width is 1/16" (1 mm).

Once a soffit is placed in a plan, you can
change its size and position to meet a variety
of needs.

Placing Soffits

Soffits can be created in both 2D and 3D

views by simply clicking with the Soffit =
tool active. See “Click-to-Create” on page
80.

They can be assigned materials that are
calculated in the Materials List, but by
default they use the material assigned to the
default wall. See “Wall Defaults” on page
136.

When positioned against a wall in a room,
soffits will display any moldings present in
that room that are at the same height as the
soffit. See “Moldings Panel” on page 180.

To create a corner soffit, click as close to an
inside wall corner as possible. A corner soffit
retains its shape when it is moved, edited, or
copied.

When a soffit is created, it is placed on the
“Cabinets, Soffits” layer. See “Layer
Attributes” on page 87.

Special Applications for Soffits

362

Nearly any object with straight, flat sides can
be represented by one or more Soffits. They

can be resized to as small as 1/16" (1mm) per
side, or as large as 250 feet (48m).

Soffits can have materials applied to them to
represent simple mirrors, posts, chimneys
and so on. Following are some additional
examples.

Coffered Ceilings

Soffits can be used to create coffered
ceilings. They will display any moldings
assigned to the room it is in that are at its
height. In addition, you can assign moldings
directly to a soffit in its specification dialog.
See “Moldings Panel” on page 365.



Accent Tiles

A material such as ceramic tile can be

assigned to one or more soffits applied to the

walls above tubs or in showers.

Calculating Materials on Soffits

By default, soffit materials are not calculated

in the Materials List. In order for a soffit’s
material to be counted, it must be edited so
that it is not using the default material. See

Special Applications for Soffits

“Material Defaults” on page 368.

The number of bricks, tiles, shingles, shakes
or other materials applied to a soffit is
calculated using the following rules:

If the soffit depth is less than the larger of
4 inches (10 mm) or 1 % times the mate-
rial thickness, then only the front area of
the soffit is used. Thus if a soffit is
48"x48”x4” thick, and the Dark Red
brick material is used (3"x 8" with 3/8”
mortar joint) the front of the soffit is
48"x487=2304 square inches. Including
the mortar joint, each brick requires 3 3/
8” x 8 3/8” = 28.26 square inches. 2304
sq. in. divided by 28.26 sq. in. per brick
gives 81.5 bricks.

If the soffit depth is greater than both 4
inches (10 mm) and 1 % times the mate-
rial thickness, then the surface areas of
the soffit back, sides and top are used in
addition to the front, if these surfaces are
not attached to a wall or other soffit.
However, only those portions of the
sides, top and bottom remaining after
subtracting twice the material thickness
are used. So, for Dark Red brick, which
has a depth of 4", the sides, top and bot-
tom surface areas cannot contribute to the
brick count unless the soffit depth is
greater than 8 inches.

If surface materials such as brick are
applied to a large soffit, the soffit center
is assumed to be hollow, with only a sin-
gle layer of the material applied to each
applicable face.

For shingles and shakes, the overlap
amount should be subtracted from the
height, as opposed to brick or tile, where
the joint width is added to the size.
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* For materials in the area category, the
soffit area calculation above is used, with
the material thickness treated as zero.

For materials in the volume, concrete or
earth categories, the true volume of the
soffit is used.

Soffit Specification Dialog

I—l To open the Soffit Specification
dialog, select the soffit and click the
Open Object edit button or double-click on

a soffit using the Soffit A tool.

The settings in this dialog are similar to those
in the Soffit Defaults dialog, but affect only
the selected object(s).

General Panel

r\ Soffit Specification

General Size [Position
Materials

Height: 17 5/8"

Floor to Top: 107 5/8"

Options
[] 1gnore Room Moldings

Mumber Style...

Auto Adjust Height

L N

—

Cancel Help

Define the Size and Position of the
selected soffit relative to the floor.

*  Specity the Width of the soffit.
* Define the vertical Height of the soffit.

* Define the Depth, which is the distance
between the front and the back of the sof-
fit. When selected in floor plan view, the
front of a soffit has a “V,” and the back of
the soffit has a triangular rotation handle.

e If'the selected soffit is a corner soffit, the
Width controls its left side width, and
Depth controls its right side width.

364

Floor to Bottom - Specify the distance
from the bottom of the soffit to the floor.
This is sometimes more easily done by
positioning the soffit in a 3D view.

When the selected soffit is outside a
room, its Floor to Bottom height is mea-
sured relative to the terrain. Check Auto
Adjust Height to maintain the same dis-
tance above the terrain if the soffit is
moved to a location with different terrain
height. Uncheck this to maintain the
same absolute height regardless of the
terrain below. When Auto Adjust Height



is checked, the Floor to Bottom value
may automatically adjust if the soffit is
moved.

9 Options - Check Ignore Room Mold-

ings to prevent the selected soffit from
displaying moldings assigned to the room
that it is placed in. See “Special Applications
for Soffits” on page 362.

9 A preview of the soffit displays on the
right side of the dialog box. See
“Dialog Preview Panes” on page 28.

Soffit Specification Dialog

Moldings Panel
For information about the settings on this
panel, see “Moldings Panel” on page 263.
Materials Panel

Soffits are not calculated in the Materials
List unless a non-default material is
specified. See “Calculating Materials on
Soffits” on page 363.

For information about the settings on this
panel, see “Materials Panel” on page 372.

365



Home Designer Interiors 2019 Reference Manual

366



The objects used in Home Designer Interiors
have a variety of 3D properties. These
objects - walls, windows, doors, cabinets,
etc. - can have materials assigned to them so
that they look realistic in 3D views. These
materials can also be used to generate
materials lists that can help with cost
estimations.

Designing with objects that look correct in
3D and calculate properly in the Materials

List requires that you use realistic material
definitions and apply them appropriately to
objects in your plan.

Home Designer Interiors comes with many
materials that are ready for use. From paint,
tile, countertops and wood finishes to
carpeting, wall coverings and fabric, Home
Designer Interiors has materials for every
application. If you cannot find a material that

Materials

suits your needs, you can customize the
materials provided or create your own.

& Redefining only the visual properties of a
material may create unexpected results.
For example, changing the image of a brick
material to represent siding does not cause
the material to be considered as siding during

material calculations.

Chapter Contents
e About Materials
*  Material Defaults
*  The Material Painter
*  Materials Panel
*  Select Material Dialog
«  Editing Materials
*  Creating Materials
*  Define Material Dialog

About Materials

The materials that are assigned to objects in
Home Designer Interiors perform two
important roles:

* They determine what the surfaces of
objects look like in 3D views.
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* They influence how objects are calculated
in the Materials List. See “Materials
Lists” on page 437.

Materials are stored in the Materials catalog
in the Library Browser and can be applied to
objects in either of two ways:

« Using the Material Painter "F .

» In an object’s specification dialog. See
“Materials Panel” on page 372.

Textures

In Home Designer Interiors, materials have
textures associated with them that determine
how they look in 3D views.

Textures are created using special image files
that tile seamlessly when applied to surfaces.

In 3D views, you can turn the display of
textures on and off by selecting 3D> Render

View Options> Toggle Textures % . When
textures are turned off, as well as in
Technical Illustration renderings, materials
are represented using solid colors. See
“Rendering Techniques” on page 407.

Material Defaults

368

@ Most objects in the program have

defaults dialogs which allow you to
set up a variety of attributes, including
materials, before the objects are created.
These defaults dialogs are accessed by
selecting Edit> Default Settings. See
“Preferences and Default Settings” on page
53.

The Material Defaults dialog serves two
purposes. It allows you to:

+ Set the default materials for objects that
do not have a defaults dialog. Fireplaces
and furnishings from the library are
examples of objects that do not have a
defaults dialog.

+ Set the initial materials that can then pop-
ulate a variety of defaults dialogs for
objects that do have them. Door, Window,
and Cabinet Defaults are examples of
defaults dialogs that can draw their mate-
rial assignments from the Material
Defaults dialog.

Material defaults are dynamic, which means
that if you change a particular material in a
defaults dialog, all objects of that type that
are set to use that default will automatically
update to use the new material. See
“Dynamic Defaults” on page 55.

Because material defaults are Dynamic
Defaults, you can use the Material Defaults
dialog to apply a material to multiple objects
that share similar components. For example:

* The “Room Moldings” Material Default
applies to the base, crown, and chair rail
moldings that can be assigned to rooms,
as well as to interior door and window
casing. If you change this Material
Default, all of these objects in the plan
can be affected.

e The “Cabinet”, “Cabinet Door/Drawer”,
“Countertop”, and “Hardware” Material
Defaults can be used in your Cabinet
Defaults dialogs to ensure that all cabi-
nets use the same materials.



Material Defaults Dialog

Select Edit> Default Settings 9/ from the
menu, select “Materials”, and click the Edit
button to open the Material Defaults dialog.

™ Material Defaults e

Drywall

Hardware ~
Railings

Ridge Cap

Reoad Marking

Room Moldings

Stair Tread
Terrain/Property Line
Wall Covering

iWalls (Interior)/Soffits
Water

Window Sash

Select Material...

Cancel Help

The Material Painter

Select a category from the scrollable list.

Click the Select Material button or mate-
rial preview box to open the Select
Material dialog. See “Select Material Dia-
log” on page 373.

The Material Painter

pﬂ Select 3D> Material Painter to

access the Material Painter Tools,
which are used to apply materials to object
surfaces in 3D views. The Material Painter
tool can also be activated by selecting a
material in the library while a 3D view is
active. The Material Painter tools are not
available in Glass House views. See “Glass
House” on page 408.

Material Painter Modes

There are five Material Painter Modes. Each
mode specifies how broadly or narrowly the
selected material will be applied to surfaces
in your plan.

* The Material Painter Component Mode

¢H is the default mode and applies the
selected material to an object component.

For most types of objects, using this tool

is the same as opening an object’s specifi-
cation dialog and changing the material of
one of its components on the MATERIALS
panel. See “Materials Panel” on page 372.

The Material Painter Object Mode Ok
applies a material to all components of an
object that share the same material assign-
ment.

The Material Painter Room Mode #f]
applies a material to all the objects in the
room that currently have the same mate-
rial. For example, if you apply a material
to a dining room chair, this mode applies
the material to all other objects in the
room with the same original material,
such as other chairs and the dining table.
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+ The Material Painter Floor Mode FF)

applies the selected material to all sur-
faces on the floor that currently have the
same material. For example, if you apply
a material to the kitchen countertops
using this mode, the bathroom counter-

tops on the same floor also have the mate-

rial applied.

The Material Painter Plan Mode /7l
applies the selected material to all sur-
faces in the entire plan that currently have
the same material. For example, if you
have the same carpet on all floors in a
plan, applying a selected material while
this mode is active will change all carpet
on all floors.

When the Material Painter "8 tool is
active, the Material Painter Mode toolbar
buttons display in the edit toolbar, allowing
you to quickly change modes.

Cil ok RE FR 5 B

Blend Colors With Materials

In addition to the Material Painter
Modes, the Blend Colors With
Materials option allows you to apply a solid
color to a surface displaying a pattern and

blend the two.

Blend Colors With Materials ‘T works in
all five Material Painter Modes. See
“Blending Materials” on page 376.

To use the Material Painter tool

Create a 3D view in which the patterned
material is visible.

2. Select 3D> Material Painter> Mate-
rial Painter ¥l .

3. Select a solid color material from the
Select Library Object dialog. See
“Select Library Object Dialog” on page
350.

* Check Use Default Material at the
bottom left of the dialog to apply the
default material to any object that has a

You can also specify the active mode by
selecting 3D> Material Painter. A check
displays next to the active mode in the
submenu.

'ﬁ Material Painter...
f Material Eyedropper

Material Painter Component Mode
g Material Painter Object Mode

ﬁ' Material Painter Room Mode

F' Material Painter Floor Mode

p Material Painter Plan Mode

Blend Colors With Materials

defaults dialog. See “Material
Defaults” on page 368.

Select a Material Painter Mode from the
edit toolbar, which displays on the left
side of the program window when the
Material Painter is enabled.

Click the Blend Colors With Textures

“T’| edit button to turn this feature on or
off depending on your needs.

Note that the name of the material being
painted displays on the left side of the
Status Bar at the bottom of the program
window. See “The Status Bar” on page
29.



* Move your pointer over a surface in the
3D view. The Status Bar now states
both the material being painted and the
current material on the target surface.

7. Click on the surface to apply the
selected material to that surface. The
material is applied to surfaces in the
model based on the active Material
Painter Mode.

« When both the Material Painter ¥
and Blend Colors With Textures are
active, the cursor displays a paint roller

+
icon 7.
+ When the Material Painter “Fl is
active and Blend Colors With

Textures 'f is not, the cursor displays
+
a spray can icon "B .

8. If either the Component ¢k or Object

Mode 6F is active, you can continue to
click on surfaces to apply the selected
material. When you are finished, select a
different tool.

Material Painter and Walls

Painting walls is an obvious use for the

Material Painter "8 ; however, it is
important to note that the Material Painter
Modes affect walls and rooms somewhat
differently than they do other objects:
particularly if a wall defines multiple rooms
on the side that is being painted.

« Component ctl and Object Modes Of
only paint the section of the wall that
defines the room located where you click
to apply a new material. Sections of the

The Material Painter

same wall that define other rooms are
unaffected.

« Room Mode #f] applies the material to
all walls and solid railings that define the
room where you click provided that they
have the same original surface material as
the one being painted. Any other objects
in the room with that original material are
also affected, but railings are not unless
they are specified as Solid.

« Floor fil and Plan Modes £l apply the
material to all walls, all railings, and any
other objects with the same original sur-
face material as the one being painted:
either on the current floor, or throughout
the plan.

Note: Wall materials applied using the Mate-
rial Painter tool are not calculated in the
Materials List.

Material Eyedropper

‘}Q The Material Eyedropper tool

allows you to load the material
assigned to an existing object and apply that
material to other objects.

In a 3D view, select 3D> Material Painter>

Material Eyedropper «* and then move
your mouse pointer over a surface in the
view. The name of the material on that
surface is stated on the left side of the Status
Bar. Click on the surface to load its material
assignment. The pointer then changes to
indicate that the material is ready to be
applied to another object using the Material

Painter "H tool. Depending on the currently
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active Material Painter Mode, you can
continue to apply the material to the surfaces
of other objects.

Materials Panel

372

The specification dialogs for most objects
include a MATERIALS panel. Select an object

and click the Open Object J1 edit button to
open the specification dialog for that
selection.

On the MATERIALS panel, you can specify
material assignments for the components that
make up that object. When a new material is

assigned, the appearance of the preview
image on the right side of the dialog updates.

If the selected object is using a material that

is missing its texture, a Caution +#. symbol
will display next to the Materials panel name
in the list on the left side of the object’s
specification dialog. See “Referenced Files”
on page 46.

r\ Base Cabinet Specification

General Component Material

Front ~ [ Base cabinet

X
(1) m 1@ & &

Door/Drawer

“_" Backsplash ‘Default: White Tile

Moldings

r A
Materials W' Cabinet

W' Countertop Default: SoapStone

Default: Color - Snow White

W' Drawers/Panels Default: Color - Snow White
W' Hardware Default: Aluminum Brushed

W' Shelves Default: Color - Snow White
W' Toe Kick Default: Color - Snow White
~ & Framed Panel
W' Frame Default Cabinet Door/Drawer: Color -
%' Panel Default Cabinet Door/Drawer: Color -

Select Material...

Cancel Help

o The table on the left side of the panel
lists the components of the selected
object that can be assigned unique materials,
along with the names of those materials and
whether or not the default materials are used.
Some objects may have only one component
while more complex objects may have many.
As changes are made to the selected object,

components may be added to or removed
from this table.

* Click on a Component in the table to
select it. Multiple line items can be added
to the selection set by holding down the
Shift or Ctrl key. See “Shift and Ctrl
Select” on page 96.




* The selected component’s Material is
stated in the list, to the right of the com-
ponent name. If the component is using
the default material, the name will be pre-
ceded by the word “Default:”. If it is
using a Material Default, it will be pre-
ceded by the word “Default” followed by
the name of an object type. See “Material
Defaults” on page 368.

Note: If the selected object is a wall or a room
modified using the Material Painter, a compo-
nent's Material may be described as “No
Change”. See “Material Painter and Walls” on
page 371.

9 The box to the right of the table
displays a preview of the material

Select Material Dialog

assigned to the selected component. If “No
Texture” displays in the preview window, the
material has no texture assigned to it; if a

Caution ¥ symbol and the words, “Texture
Missing” display, the texture file could not
be found on the system.

» Click Select Material to open the Select
Material dialog. Choose a material and
click OK to assign that material to the
selected component. See “Select Material
Dialog” on page 373.

9 A preview of the selected object

displays on the right side of the panel.
To view material textures, select Standard
as the View Type. See “Dialog Preview
Panes” on page 28.

Select Material Dialog

The Select Material dialog allows you to
select a material to apply to one or more
objects and is opened by clicking the Select
Material button on the MATERIALS panel of
most specification dialogs or by using the

Material Painter ¥ . See “Materials Panel”

on page 372 and “The Material Painter” on
page 369.

Most of the time, the Select Material dialog
has a single panel; however, if a component
of a library symbol is selected in an object
specification dialog, two panels will be
present.

Library Materials Panel

The LIBRARY MATERIALS panel is a modal
version of the Library Browser that lists only
materials. See “The Library Browser” on
page 336.

The settings on this panel are also found in
the Select Library Object dialog. See
“Select Library Object Dialog” on page 350.
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r‘\ Select Material

|T'-r'pe to start searching. ..

v Home Designer Core Catalogs
A El Materials
El Artwork
[ Ceiling Tiles
v [ Colors
A El Color Palettes
El Balance
[ Breezy
El Contrasts
El Divine
El Glamour
El Lavish
[] Organic
fln ae

Color - Butte

Color - Marin Color - Maya Color - Moss

Color - Plum

[ (= (2 v

[ use default material

Cancel Help

The LIBRARY MATERIALS panel has most of
the functionality that the Library Browser
has: including the search, the toggleable,
resizable Preview and Selection Panes, and

the Toggle Preview Display (@ button.

* To locate a material, either search using
keywords or browse the tree list. See
“Searching the Library” on page 339.

» To apply a material to an object, either
click on the material and click OK or
double-click on the item in the Selection
Pane.

+ Click the Add New Material ** button
to open the Define Material dialog and
create a new material saved in the user
Catalog. See “Define Material Dialog” on
page 376.

* Check Use default material to apply the
default material to the selected object, if
one exists. See “Material Defaults” on
page 368.

The OK button is only active when a library
item is selected. If a library folder or catalog
is selected, the OK button cannot be clicked.

Material Defaults Panel

The MATERIAL DEFAULTS panel will only be
present if the Select Material dialog was
accessed via an object specification dialog
where a component of a library symbol was
selected.

Rather than apply a specific material to the
selected component, you can dynamically
associate it with a Material Default category.
See “Material Defaults” on page 368.



Editing Materials

Editing Materials

Much like objects, materials in Home
Designer Interiors can be edited so that they
better suit your design needs. There are two
approaches to material editing:

» Select a material in an unlocked library in
the Library Browser, edit it, and your
changes will be used when you next use
the material in any plan. Changes made in
this manner do not affect materials
already in use in a plan.

e Apply a material to an object in a plan and
then edit that applied material using the

Adjust Material Definition 4 tool.
Changes made in this way will affect any
instances of that material in the current
plan only.

Editing the material applied to an object is
not the same as applying a different material
to that object. See “The Material Painter” on
page 369.

Library Browser

Right-click on a material in an unlocked
library and select Open from the contextual
menu to open the Define Material dialog for
that material. See “Define Material Dialog”
on page 376.

Adjust Material Definition

y The Adjust Material Definition tool
7 is useful for changing plan materials
directly from a 3D view.

Select 3D> Materials> Adjust Material

Definition 4 and then click any surface in
a 3D view to modify the material currently
assigned to that surface in the Define
Material dialog. See “Define Material
Dialog” on page 376.

Changing a material definition with this tool
affects all objects in the current plan that are
using that material but does not affect any
materials saved in the library or materials
used in other plans. See “Adding Library
Content” on page 345.

Creating Materials

Home Designer Interiors provides a wide
variety of materials - including numerous
name brand material catalogs - that are ready
to download and use. If you cannot find a
suitable material, you can edit an existing
material or create a new one. See “Editing
Materials” on page 375.

Note: Adding a material to a plan is not the
same as adding it to the library. If you want a
new material to be available for use in other
plans, create it in the Library Browser.

In the Library Browser

Materials can be created in the Library
Browser, making them available for use in
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any plan. See “Adding Library Content” on
page 345.

In the directory pane of the Library Browser,
right-click on an unlocked folder and select

New> Material ¥ from the contextual
menu. See “Using the Contextual Menus” on
page 338.

The Define Material dialog opens, allowing
you to specify the new material’s attributes.
See “Define Material Dialog” on page 376.

Blending Materials

G_-i-:, In 3D views, you can create a new

material by blending a solid color
such as a paint color with a textured material.
Select 3D> Material Painter> Blend
Colors With Materials to toggle this feature
on or off. See “Blend Colors With Materials”
on page 370.

The result is a new material that is saved in
the current plan.

Materials created using the Blend Colors

With Materials T tool are given the name
of the patterned/textured material with the

extension “--PAINTED:” followed by the
name of the solid color material.

Component Material
v M Base cabinet
W' Backsplash

W' Cabinet

Default: White Tile
Rustic Hickory--PAINTED: Color - Chocolate

Stretch to Fit

Some special textures, often used for
artwork, stretch across any surfaces that they
are applied to. Materials that behave this way
are specified as Stretch to Fit in the Define
Material dialog.

To display an artwork texture, first place a
wall or desk frame in your plan. A selection
of both are available in the library. See
“Placing Library Objects” on page 349.

Next, simply apply a material specified as
Stretch to Fit to the center portion of the
frame. See “The Material Painter” on page
369.

For more information about creating and
using custom materials, see “Materials
Tutorial” on page 115 of the User’s Guide.

Define Material Dialog
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The Define Material dialog allows you to
adjust how materials look in 3D views and
can be accessed in a number of ways:

+ Use the Adjust Material Definition V4
tool. See “Adjust Material Definition” on
page 375.

+ Right-click on material in the Library
Browser User Catalog and select Open
Object from the contextual menu. See

“Using the Contextual Menus” on page
338.

*  You can also right-click on an unlocked
library and select New> Material.

Manufacturer Panel

If the selected material was copied from the
Manufacturer library category, the MANU-
FACTURER panel lists contact information.



See “Manufacturer Catalogs” on page 341.

Define Material Dialog

[\\ Define Material
Material o
MName: |Whihe Tile —|
(O solid Color Select...
© Tesure
Texture o
[ Blend Color And Texture  Select Calar...
sl
vl
[ stretch to Fit
Retain Aspect Ratio
Options o
Brightness: @® Bright () Medium () Dark
Shininess: O shiny () Matte () Dull
Emissive: '
1 1 1 1 1 1 1 1 1 1
Copyright o
Copyright® 2007-2010, Chief Architect, Inc.
| ok

| ot | [ e |

0 The Material Name displays here. In
this field, you can type a new name if
you wish. Renaming the material does not
create a new material: it redefines the
existing material in the current plan.

 Click the Solid Color radio button to
specify the material as a solid color, then
click the Select button to open the Select
Color dialog and select a new color. See
“Select Color Dialog” on page 90.

* Click the Texture radio button to specify
a texture for the material instead of a solid
color, then click the Select button to open
the Select Texture File dialog, a standard
Open File dialog, and specify an image

saved on your computer to serve as the

texture.
9 The Texture Options are only enabled
when Texture is selected, above.

¢ Check Blend Color and Texture to blend
the selected texture with a solid color,
then click the Select Color button to
specify the color you would like to blend
it with. When a new material is created
using the Blends Color With Materials

|?\ tool, the resulting material has this
box checked. See “Blend Colors With
Materials” on page 370.

* Specify the X and Y Scale for the chosen
texture in inches (mm). If you specify x
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and y values of 307, the pattern repeats
every 30 inches in both directions along a
surface.

* Check Stretch to Fit to stretch the texture
image over the entirety of each surface it
is applied to. This is useful when you
wish to create a painting or photo material
to display in a frame. See “Stretch to Fit”
on page 376.

Note: Changing the scale or selecting Stretch
to Fit can cause textures to appear distorted if
they are mapped to a surface using a different
aspect ratio than they were originally created

with.

* Check Retain Aspect Ratio to maintain
the ratio between the texture image’s
height and width and prevent distortion
when either its X or Y Scale value is
adjusted.

* Rotate Angle - Specify how the texture is
rotated on the surface it is applied to.

e General Options -

* Brightness controls how bright the mate-
rial appears relative to other materials.

+ Shininess controls the sheen of the mate-
rial when it is rendered with a point or
spot light source on it. Shiny materials

such as metal will reflect light when
viewed at the right angle.

* Transparency controls the opacity of the
material. A transparency value of 0 results
in a completely opaque material, while a
value of 100 creates a material that is
completely invisible.

* Use the Emissive slider bar or text field to
control how bright a material appears
independent of the lighting in the scene. It
can be used to simulate surfaces that are
glowing with their own light, such as the
glass on a light fixture.

(4]

(5

0 A preview of the material applied to an
object displays here and updates as

changes are made to the material definition.

Various options allow you to view different

aspects of the material’s attributes:

Any Copyright information about the
material displays here.

A preview of the selected texture or
color displays in the square pane.

* Zoom and orbit the object in the view.
¢ Toggle Color on or off.

* Select an object shape: Cube, Sphere, or
Teapot.



Define Material Dialog
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Little preparation is needed to create a 3D
view of a model: simply click a button to
create an overview or click and drag to create
acamera view.

To improve the quality of the rendering and
create a custom look, you can adjust lighting
and edit the materials used in the plan. You
can create Final views that are even more
realistic. See “3D Rendering” on page 401.

Many objects can be placed and edited in 3D
views, and any camera view or overview can
be saved or even used to record a
walkthrough. See “Pictures, Images, and
Walkthroughs” on page 413.

Chapter 28:

3D Views

Chapter Contents
OpenGL and Hardware
Camera Defaults Dialogs
3D View Tools
Creating Camera Views
Creating Overviews
Displaying 3D Views
Repositioning Cameras
Editing 3D Views
Cross Section Slider
Working in 3D
Saving and Printing 3D Views
Camera Specification Dialog

381



Home Designer Interiors 2019 Reference Manual

OpenGL and Hardware

Home Designer Interiors features an easy to
use rendering engine that makes use of
OpenGL rendering technology, which has
good hardware support on most video cards.

To take full advantage of thes rendering
capabilities of Home Designer Interiors, a
graphics card or chipset that supports
OpenGL 3.3 on Windows or 4.1 on Mac is
required.

Camera Defaults Dialogs

@ There are several defaults dialogs for

cameras, which can be accessed by
selecting Edit> Default Settings. In the
Default Settings dialog, click the arrow next
to “Camera tools”, then select a subheading
and click the Edit button to open the defaults
dialog associated with your selection.

The settings in the Camera Defaults dialogs
control the initial use of effects that improve
the appearance of 3D views.

The settings in these defaults dialogs are also
found in the Camera Specification dialog.
See “Camera Specification Dialog” on page
396.

Once a camera is created, its attributes can be
customized. See “Editing 3D Views” on page
391.

Full Camera Defaults

Specify the initial attributes of cameras

created using the Full Camera 8 tool. See
“Camera Views” on page 383.

The settings in this dialog also affect Glass
House Cameras 13,

The settings in this dialog are the same as
those the Full Camera Specification dialog.

Floor Camera Defaults

Specify the initial attributes of cameras

created using the Floor Camera 1@ tool.

The settings in this dialog are the same as
those in the Floor Camera Specification
dialog.

Doll House View Defaults

Specify the initial attributes of cameras

created using the Doll House View @ tool.
See “Overviews” on page 383.

382

The settings in this dialog are the same as
those in the Doll House View Specification
dialog.



3D View Tools

3D View Tools

Select 3D> Create Camera View to display
the Camera View Tools.

Camera Views

I_E] The Full Camera tool creates multi-

floor views of the 3D model. It can be
used to create interior and exterior
perspectives, and is good for displaying
cathedral ceilings, roofs, lofts, stairwell
openings, and other variation in floor and
ceiling levels.

E| The Floor Camera tool creates
[m perspective views of the current floor

only. Nothing above the ceiling surface is
generated, and neither is anything below the
floor.

e The Glass House Camera tool

J creates full camera view of the 3D
model using the Glass House Rendering
Technique. See “Glass House” on page 408.

Overviews

B The Doll House View tool creates

views of the current floor with the
ceiling removed and all floors beneath it
visible.

Creating Camera Views

All Camera views are created using the same
method.

To create a camera view

1. In floor plan view, select the desired
camera tool. The mouse pointer displays

o
the camera B3 icon.

2. Click and drag a line to define the view
direction.

* Where your line begins is the camera’s
position.

* The line that you drag defines the
direction the camera is pointed.

* The end of the line is the focal point of
the view, the point the camera rotates
around.

* By default, the field of view is 45°,
which is similar to what the human eye
sees or a 5S0mm camera lens.

1. Camera
(click)

2.Lineof Sght
(drag)

3. Focal Paint
(release)

Field of \AV
Indicator

3. When you release the mouse button, a

view generates in a new window.

4. Return to the floor plan view. A camera

symbol now displays in floor plan view.
See “Working in Multiple Views” on
page 70.
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Camera Height

By default, Cameras are created at a height
of 60” (1500 mm). Where this height is
measured from depends on the location of
the camera:

e If the camera is inside of a room, it is
measured from that room’s subfloor.

e If the camera is located outside of a
room, it is measured from the default
height of the subfloor for the current
floor.

Once created, a camera’s height can be
modified in its Camera Specification dialog
See “Camera Specification Dialog” on page
396.

Creating Overviews

—— Select 3D> Create Doll House View
o to create a drawing of the current floor
with the ceiling removed.

Doll House Views generate as soon as you
select the tool and are always created at the
same angle. The focal point is always located
at the center of the model; however, the
position of the camera will vary depending
on the size of the 3D model. The larger or
more spread out the model, the further away
the camera will be from the focal point so
that the entire model can be seen in the view.

Once generated, an overview window’s title
bar indicates its view type and a camera
symbol representing the Doll House View
displays in floor plan view, The overview
‘camera’ can be edited much like regular
camera views can. See “Editing 3D Views’
on page 391.

]

== Doll House Views are an effective tool
for illustrating traffic flow and the
relationships between spaces.

To see a different floor, select Tools>

Reference Floors> Up One Floor 4 or

Down One Floor 7. You can also return to
floor plan view and make another floor
current before generating the Doll House
View.

Displaying 3D Views

A variety of tools and settings allow you to
control the appearance of your 3D views.
There are also numerous ways to adjust the
position, focal point and field of view of a
3D view. See “Editing 3D Views” on page
391.

The name of the current plan file and the type
of view displays at the top of each view
window in its title bar.

There is no limit to the number of 3D view
windows that you can have open at a given



time; bear in mind, though, that each window
demands use of your computer’s resources
and that you may see poor performance if too
many views are open. See “Working in
Multiple Views” on page 70.

Display Options

Which objects display in a 3D view is
controlled in the Display Options

dialog. See “Display Options Dialog” on

page 88.

Different view types use different layer sets

when they are created. See “Layer Sets” on

page 87.

In Floor Plan View

Cameras are represented in floor plan view
by symbols that indicate the camera’s posi-
tion, field of view and focal point.

FY

Carrera 1

|
Fay
The symbols forFull and Floor Cameras and
Doll House Views display only on the floor

where the view was created. See “Creating
Camera Views” on page 383.

You can move a camera to a different floor
by clicking the Up One Floor 2 or Down

One Floor 7| button while the camera view

Displaying 3D Views

is active. Note that this may affect what is
seen in the view as well as its display in floor
plan view. See “Floor Up / Floor Down” on
page 292.

Active cameras can have labels indicating
the camera number. Camera labels are
located on the “Cameras, Labels” layer. They
are numbered sequentially in each plan in the
order they were created.

Camera symbols are an on-screen reference:
they do not print unless Print Image is used.

In Rendered Views

There are a number of factors that contribute
to the appearance of rendered 3D views:

* Select 3D> Toggle Textures % ina3D
view to turn off the display of material
textures. See “About Materials” on page
367. Not available in Glass House Views.

+  Select View> Color ™ to toggle
between color and grayscale in 3D views.
See “Color On/Off” on page 90.

Several other factors can contribute to the
overall quality of a rendered 3D view. See
“Rendering Tips” on page 402.

3D Backdrops

A backdrop is an image, usually of an
exterior view, that displays in the background
of 3D views to help place the model into a
realistic setting and add a sense of
perspective. If a backdrop is not specified,
Home Designer Interiors applies a
background color. See “3D Backdrops” on
page 423.
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Delete 3D Surface

% The individual surfaces that make up

objects can be temporarily removed
from any 3D view by selecting 3D> Delete
Surface and then clicking on a surface.
When the pointer is over a surface, that
surface will become highlighted.

Surfaces removed in one view are removed
in all 3D views, but are not permanently
removed from the model. Continue clicking
surfaces to remove them, then select another
tool when you are finished.

Surfaces in 3D views are composed of
multiple triangles. Hold the Alt key while
clicking to delete one triangular face at a
time rather than all triangles forming a
surface.

To restore the most recently deleted surface,
select 3D> Delete Surface or click the
toolbar button.

There are several ways to restore all deleted
surfaces:

» Select Build> Floor> Rebuild Walls/
Floors/Ceilings,

» Exit the 3D view and reopen it.

* QGenerate a new 3D view.

Rebuild 3D

[]ﬁl Select 3D> Rebuild 3D to regenerate
all 3D data associated with the current
plan. All open views will remain open.

Repositioning Cameras

386

Once a 3D view is created, there are many
ways to manipulate the camera location and
the direction of its line of site using the
mouse, the keyboard, and the menus.

When the keyboard, toolbar buttons, or menu
commands are used to move or rotate a
camera, the adjustments occur in regular
increments. The size of these increments is
specified in the Camera Specification
dialog:
e The Incremental Move Distance con-
trols Panning movement and forward and
backward Dolly movement.

* The Incremental Rotate Angle controls
Orbit movement, Tilt movement, and side
to side Dolly movement.

See “Camera Specification Dialog” on page
396.

Each time you move the camera, the view is
updated. If you are using either the toolbar or
keyboard to move the camera, you can hold
down the Shift key, suppressing the redraw
of the view until the Shift key is released and
allowing you to move multiple increments
more quickly.

You can also move a camera to a different
floor by clicking the Up One Floor & or

Down One Floor %7/ button while the
camera view is active. Note that this may
affect what is seen in the view as well as its
display in floor plan view. See “Floor Up /
Floor Down” on page 292.



Repositioning Cameras

Mouse Scroll Wheel and Trackpad

3D views can be panned and zoomed when
any tool is active using the mouse scroll
wheel or trackpad gestures. See “Using a
Trackpad” on page 22.

The program adjusts the speed of these
actions depending on characteristics of the
camera:

* Zoom speed depends on how close the
camera is to the object located behind the
mouse pointer. When the target object is
far from the camera, zooming is faster; as
the camera gets closer to the target,
zooming slows.

* Panning speed depends on the length of
the camera’s Line of Sight. In general, it
is likely to be faster in an exterior view of
a large model, slower in an interior view
of a small room. See “Creating Camera
Views” on page 383.

By default, panning and zooming adjusts the
position and direction of the camera. It does
not, however, adjust the distances at which
surfaces are clipped. This means that if you
zoom in closely on an object, some of its
surfaces may be removed from the view. One
way to avoid this is to lower the camera’s
Clip Surfaces Within value in the Camera
Specification dialog. See “Camera
Specification Dialog” on page 396.

Another way to avoid this is using

Perspective Crop Mode .

When Perspective Crop Mode 1 is active,
panning and zooming do not adjust the
position of the camera. As such, using it can
result in inconsistencies between a camera’s
position and what is actually shown in the
view. For this reason, it should only be used
to zoom in closely on small objects or
details.

To use Perspective Crop Mode

1.  Zoom in on an object that you would
like to examine closely.

2. Ifany of its surfaces disappear, zoom out
until they are restored.

3. Select 3D> Camera View Options>
Perspective Crop Mode 9.

4. Zoom in on the object, but try to limit
any panning or other changes to the
camera’s perspective.

& Once Perspective Crop Mode has
been enabled in a camera view, it
should remain toggled on and navigation in
that view should be limited.

3Dconnexion® 3D Mice

3Dconnexion®'s 3D mice can be used to
navigate in all views - including camera
views and overviews.

In the Windows version of Chief Architect,
pre-programmed view direction hotkeys are

supported on devices with buttons for that

purpose. MacOS" does not provide mapping
support to the view direction commands;
however, you can create custom hotkeys for
the commands in Chief Architect and then
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program your 3D mouse to use those Note that rolling is not supported in Chief
hotkeys. See Hotkeys. Architect and that 3D mice cannot be used to
move the mouse pointer. For details about

You can specify whether navigation is ©

centered about the camera or its focal point : )
in the Preferences dialog. See “Render its documentation.
Panel” on page 62.

using your 3D Connexion™ mouse, refer to

Move Camera with Mouse

h'i An active camera’s position can be Move Camera With Mouse to access the
W cdited using the mouse. Select 3D> Move Camera with Mouse modes.
Hotkey Description

&; Alt+ O | Mouse-Orbit Camera lets you move the mouse to rotate the camera
around its focal point. The camera’s position and direction both
change.

To continuously rotate the camera around its focal point, click in the
3D view, drag the mouse, and release the mouse button to “throw” the
view. Click again in the view to stop it from rotating.

Alt+ To temporarily activate Mouse-Orbit Camera, hold down the Alt key
middle | and then click and drag using the middle mouse button. When the Alt
mouse | key and middle mouse button are released, whatever tool was
button | previously in use will still be active.

Alt+P | Mouse-Pan Camera lets you move the camera up, down, left and right
using the mouse. The camera’s position changes, but its direction does
not.

Alt+D | Mouse-Dolly Camera lets you move the camera forward and
backward by moving mouse up and down. Move the mouse left or right
to rotate the camera side to side.

Alt+T | Mouse-Tilt Camera lets you move the mouse to tilt the camera in any
direction while staying in the same location.

A 2 &

3D Center Camera on Point lets you focus the camera at a particular
point in the scene. This changes the camera’s direction and focal point,
but not its position. To use the 3D Center tool, activate the tool and
then click on any object in the scene.

el




Repositioning Cameras

Hotkey Description

3D Focus on Object lets you focus the camera on a specific object.
This changes the camera’s position, direction, focal point, and the
length of its line of sight. To use the 3D Center tool, activate the tool
and then click on any object in the scene.

Move Camera with Keyboard

An active camera’s position can be changed .
using the Arrow keys on your keyboard.

Select 3D> Move Camera with Keyboard

to access the Move Camera with Keyboard
modes.

These modes use the Incremental Move
Distance and Incremental Rotate Angle set

in the active 3D view’s Camera

Specification dialog. .

* Keyboard-Orbit Camera lets you use
the keyboard to rotate the camera around
the focal point. The camera’s position

Keyboard-Pan Camera lets you move
the camera up, down, right, and left using
the keyboard. The camera’s position
changes, but its direction does not.

Keyboard-Dolly Camera lets you move
the camera forward and back using the
Up and Down Arrow keys, and rotate
side to side using the Left and Right keys.

Keyboard-Tilt Camera lets you use the
Arrow keys to tilt the camera up, down,
or side to side to change the focal point.
The camera’s direction changes, but its

and direction both change. position does not.

Move Camera Tools

Select 3D> Move Camera in a 3D
¥ . view to access these tools. These tools
change the active camera’s position, but not
its direction.

These tools use the Incremental Move
Distance set in the active 3D view’s Camera
Specification dialog.

Hotkey Description
ﬁ F Move Camera Forward moves the camera and its focal point forward.
@ B Move Camera Back moves the camera and the focal point back.
<:I L Move Camera Left moves the camera and the focal point to the left in
a line perpendicular to the line of sight.
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Hotkey

Description

ED R

Move Camera Right moves the camera and the focal point to the right
in a line perpendicular to the line of sight.

T U

Move Camera Up moves the camera and the focal point up.

l D

Move Camera Down moves the camera and the focal point down.

Orbit Camera Tools

Ay Select 3D> Orbit Camera in a 3D using the Incremental Rotate Angle set in
4 view to access these tools. Orbiting the active view’s Camera Specification
the camera rotates it about the focal point dialog.
Hotkey Description

ﬁ I

Move Camera In moves the camera closer to the focal point along the
line of sight. The camera cannot move past the focal point using this
tool.

Move Camera Out moves the camera away from the focal point along
the line of sight.

Orbit Camera Upward rotates the camera up about the focal point.
The camera cannot rotate past a vertical line looking straight down on
the focal point.

b=

Orbit Camera Downward rotates the camera down about the focal
point. The camera cannot rotate past a vertical line looking straight up
at the focal point.

B

Orbit Camera Left rotates the camera to the left about the focal point.

Orbit Camera Right rotates the camera to the right about the focal
point.
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Tilt Camera Tools

&) Select 3D> Tilt Camera to access
4 these tools. Tilting keeps the camera

in one place and pivots the camera about its

vertical or horizontal axis. This movement

uses the Incremental Rotate Angle set in
the active view’s Camera Specification
dialog and is similar to tilting your head up
and down or turning it side-to-side.

Hotkey

Description

Tilt Camera Upward tilts the camera up while keeping it in the same
location. The camera cannot tilt beyond the vertical position.

Tilt Camera Downward tilts the camera down while keeping it in the
same location. The camera cannot tilt beyond the vertical position.

same location.

Turn Camera Left turns the camera to the left while staying in the

M NS

same location.

Turn Camera Right turns the camera to the right while staying in the

Editing 3D Views

In addition to its position and direction, there
are other ways to modify a 3D view.

In the Specification Dialog

I—l You can make adjustments to a
camera in the Camera Specification
dialog. This dialog is particularly helpful for

making fine adjustments to the camera’s
position, appearance, and other attributes.
See “Camera Specification Dialog” on page
396.

@ Tile a 3D view and the floor plan view
~ and use the camera movement tools to
see how they affect the camera. See “Tiling
Views” on page 70.

Using the Edit Tools

A camera symbol or symbols selected in
floor plan view can be edited in a variety of
ways using the buttons on the edit toolbar.
See “The Edit Toolbar” on page 24.

Using the Edit Handles

Return to floor plan view without closing the
3D view. See “Working in Multiple Views”
on page 70.

Using the Select Objects | tool, select the

camera object. When a camera symbol is
selected it displays four edit handles.
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S g—— Lineof Sight
|

é; Move

o -€——Focal Point

s -@——  Rotate

* Drag the Line of Sight handle to change
the camera angle without moving the
focal point.

* Drag the Move handle to relocate the
camera while maintaining its relative
angle.

+ Drag the Focal Point handle to reposition
the focal point and change the line of
sight without moving the camera.

* Drag the Rotate handle to rotate the cam-
era’s line of sight about its center.

The 3D view corresponding to the camera
symbol reflects changes made to the symbol
in floor plan view.

Multiple camera symbols can be selected;
however, their editing options are limited to
being moved, rotated, and deleted.

Using the Contextual Menu

In a 3D view, right-click in an empty space in
which the backdrop or background color

displays to access the contextual menu. See
“Contextual Menus” on page 25.

Refresh Display Fs
i Adjust Sunlight...

@ Glass House

Technique Options...
[ﬁ] Cross Section Slider...

These options are a selection of tools and
toggles specific to the current view.

Up One Floor/Down One Floor

You can move a camera to a different floor.
While the camera view is active, select
Tools> Reference Floors> Up One

Floor 4> or Down One Floor *7|. Note that
this may affect what is seen in the view as
well as its display in floor plan view. See “In
Floor Plan View” on page 385.

The position and movement of a camera is
affected by its location within the model.
When inside a building, the camera height is
relative to the floor of the room it is drawn
in.

If the camera is on an upper floor and you
move the camera outside of the building, the
camera remains at the same height relative to
the floor it was created on.

Zooming

The Zoom Tools are available in all
3D views. See “Zoom Tools” on page
72.

Selecting Window> Zoom In ®, Zoom

Out 4 or Fill Window [ I does not change
the camera’s location or field of view.



Instead, the extents of the view are expanded
or cropped.

Field of View

The Field of View refers to a camera’s field
of vision. A wider field of view makes the
focal point appear further away, as more of
the image is included in the same view
window.

In floor plan view, the angled lines of a
camera symbol indicate its field of view.

Cross Section Slider

FOV Indicators

4

Can:era 1
5]
|

A camera’s field of view can be adjusted in
the Camera Specification dialog. See
“Camera Specification Dialog” on page 396.

Cross Section Slider

[El_ﬂ Select 3D> Cross Section Slider
when a camera view or overview is

N Cross Section Slider *
0 ‘@ 43 1/4

43 1/4

339 1/2°

339 1/2°

I 130"
130"
Cancel Help

To use the Cross Section Slider

1. Check the box beside a cross section
cutting plane to select it and make its
Position slider and text box active.

active to open the Cross Section Slider
dialog.

2.  Move the Position slider to adjust the
position of the cutting plane.

* The cutting plane Position is measured
from the edge of the model that is cut
first by the selected cutting plane.
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* Position the Cutting Plane with accu-
racy using the text field to the right of
the slider.

3. Repeat steps 1-3 to use additional cut-
ting planes if you wish.

4. Click OK to close the dialog. If the
active camera is saved, its Cross Section
Slider settings will also be retained. See
“Saving 3D Views” on page 395.

Working in 3D

394

A variety of tools are available in 3D views
that allow you to edit your 3D model.

Creating Objects in 3D Views

You can place windows, doors, and most
library objects directly into 3D views. To do
this, select the appropriate tool and click in
the 3D view. You can then edit the object’s
size and placement.

When created in 3D, most objects must be
placed against a wall or on a floor platform.

Selecting and Editing
Objects in 3D Views

Most objects can be selected and edited in

3D views. Select Edit> Select Objects | &
and click on the surface of an object to select
it. Once selected, objects can be edited using
their edit handles, buttons on the edit toolbar,
and the object’s specification dialog. See
“Editing Objects” on page 93.

When you select an object, edit handles and a
handle surface display. The handle surface is
a rectangle around the perimeter of the object
that indicates the overall height and width of
the selected surface. The edit handles that
display depend on the type of object selected.
Walls, for example, display two resize edit

handles when selected while the top of a
cabinet displays ten handles, allowing you to
move, resize and reshape it.

Note: If the wall height of the Exterior Room
is adjusted in a 3D view, the default Floor or
Ceiling Height of the entire floor is changed.

See “Floor and Room Defaults” on page 165.

All moving or resizing is in the plane of the
handle surface. You cannot move an object
directly towards or away from the camera,
for example, because that surface plane
cannot be seen in the view.

By default, object movement is restricted to
one inch or 10 mm increments. See “Grid
Snaps” on page 79.

Unrestricted positioning can also be enabled
by holding down the Ctrl key while moving
or resizing an object. See “Unrestricted
Movement” on page 113.

Temporary dimension lines display when
many objects are selected to help you resize
the object and determine its height.

When several 3D views are open, changes
made in the plan automatically rebuild the
model in all views. Because of this, it is
typically faster to make changes to your plan
with as few windows open as possible.




Editing Materials in 3D Views
Select 3D> Materials> Adjust
/’? Material Definition, then click on a
surface in the 3D view to open the Define

Material dialog for that material. See “Adjust
Material Definition” on page 375.

pﬂ Select 3D> Material Painter to apply

materials to surfaces in the view using
the Material Painter Tools. See “The Material
Painter” on page 369.

[f Select 3D> Material Painter>
Material Eyedropper to apply the

Saving and Printing 3D Views

material on a surface in the view to other
surfaces in the view. See “Material
Eyedropper” on page 371.

Rebuild 3D

[]ﬁl As changes are made to your plan, a

3D view automatically updates to
reflect any changes visible in the view. If you
find that a view is not updating as expected,
select 3D> Rebuild 3D to rebuild the entire
3D model.

Saving and Printing 3D Views

3D camera views and overviews can be
saved with the plan in which they are
created, exported and saved as image files, as
well as printed.

Saving 3D Views

% Select 3D> Save Active Camera to
save the current camera in the plan.
You can also save a camera view by checking
the Saved box in the Camera Specification
dialog. See “Camera Specification Dialog”

on page 396.

Saved cameras can be closed and re-opened
for later use, and retain their Cross Section
Slider Shadows, and Rendering Technique
settings. See “Cross Section Slider” on page
393, “Shadows” on page 402, and
“Rendering Techniques” on page 407.

Activating Saved Views

There are three ways to open a saved 3D
view:

» Select the camera symbol in floor plan

view and click the Open View 3 edit
button.

* Double-click the camera symbol using
the Select Objects | %/ tool.

» Right-click on it and select Open View
from the contextual menu.

Unsaved cameras that are open in another

view window can also be activated using the

Open View H edit button.

If you open a saved camera view and then

modify its location or direction using any of

the tools available in that view, the program

will confirm whether you want to re-save the

camera using these new settings when you

close it. See “Repositioning Cameras” on
page 386.

Exporting 3D Views

I_Et-l All 3D views can be exported and
saved as .bmp, .jpg, .png, or .tif files.
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Select File> Export> Picture to save the
current screen image as an image file. See
“To export a picture” on page 420.

Once saved, a picture can be opened and
converted into many other formats using a
graphics program.

Printing 3D Views

| Since 3D views are created using
pixels instead of lines, File> Print>
Print Image must be used when printing.
Print Image is a special Home Designer
Interiors function that prints the screen in
picture format. The entire view prints,
including images such as plants and textures.

The quality of your print image is affected by
your current window size and screen
resolution. To maximize the quality of your
printed image, generate it in full screen size
and use the maximum screen resolution.

Closing 3D Views

Although you can have any number of 3D
views open at a time, to conserve resources
on your computer it is a good idea to close
views when you no longer need them. There
are a number of different ways to do this. See
“Closing Views and Files” on page 75.

Camera Specification Dialog

396

I—l The Camera Specification dialog can

be accessed in floor plan view by
selecting a camera symbol and clicking the
Open Object edit button. See “In Floor Plan
View” on page 385.

This dialog can also be accessed while a
camera view or overview is active by

selecting 3D> Edit Active Camera =h

The selected view’s specific type is indicated
in the dialog’s title bar: the specification

dialog for a Full Camera 8, for example,
is named Full Camera Specification.

The settings in this dialog are also found in
the Full Camera, Floor Camera, and all
Overview and Doll House View Defaults
dialogs. See “Camera Defaults Dialogs” on
page 382.



Camera Specification Dialog

Camera Panel

™ Full Camera Specification

Camera General

3D Backdrop Mame:

Ambient Ocdusion:
Lighting

@ Automatic:

(O Use Light Settings
Positioning

Height Above Floor:

Tilt Angle:

Field of View:

Scene Clipping

Clip Surfaces Within:

Incremental Move Distance:

Incremental Rotate Angle:

1@ x

|Camera 1

[] show Shadows

Ray Casted Sun Shadows
[ reflections
Bloom
[] Edge Smoothing when Idle

rra—

12 Default
10.0° Default
55.0° Default
24 Default

Cancel Help

0 General -

Specify the Name that displays in the
camera label in floor plan view.

Check Show Shadows to turn on shad-
ows in the selected camera view. When
unchecked, shadows are not generated.
See “Shadows” on page 402.

Check Ray Casted Sun Shadows for
higher quality shadows cast by sun light.
Ray Casted Sun Shadows take longer to
generate than regular shadows and only
refresh when the camera is not moving.

Check Reflections to turn on reflections
in the selected camera view. When

unchecked, reflections are not generated.
See “Reflections” on page 402.

* Bloom, or light bloom, occurs around

areas of intense illumination and looks as
though the light is ‘bleeding’ beyond the
edges of the light source. It adds realism
to the view but takes longer to render.
Only affects Standard and Watercolor
renderings. See “Rendering Techniques”
on page 407.

Check Edge Smoothing When Idle to
apply high quality edge smoothing to
edge lines when the selected camera is
not in motion. See “Edge Smoothing” on
page 403.
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+ Select the amount of Ambient Occlusion
to use using the slider bar or text field.
Ambient Occlusion allows variation in
the strength of the ambient light. It is
more realistic than uniform ambient light,
but takes longer to render. Only affects
Standard and Watercolor renderings. See
“Ambient Lighting and Occlusion” on
page 404.

9 The Lighting settings control how

many and which light sources are used
in the current view. See “Lighting Modes™ on
page 406.

* Select Automatic, then specify the Max-
imum Number of lights that can be used
in the current camera view.

+ Select Use Light Settings to use all light
sources in the entire plan provided that

they are turned On o

9 The Positioning settings determine the
position and orientation of the camera.
See “Repositioning Cameras” on page 386.

+ The Height Above Floor defines the
height that the camera is above the floor
level for the current floor. See “Camera
Height” on page 384.

* The Tilt Angle determines the vertical
angle that the camera is tilted. The cam-
era maintains its focal point and position
in floor plan view, but if the camera is

tilted, the focal point is above or below
the current camera height.

To change a setting below, first uncheck
Default.

¢ The Incremental Move Distance con-
trols how far the camera moves each time
you Pan in any direction or Dolly for-
wards or backward using the keyboard,
toolbar buttons, or menu. For interior
views a small number is good, but for
exterior you may want a larger increment.

e The Incremental Rotate Angle defines
how many degrees the camera rotates
each time you Tilt, Orbit, or Dolly side to
side using the keyboard, toolbar buttons,
or menu. A setting of 90° would make
one full rotation in four moves.

» The Field of View defines the camera’s
field of vision in angular degrees. See
“Field of View” on page 393.

0 Options -

e Clip Surfaces Within - Objects located
within this distance from the camera do
not display in the view. Decrease this
value to display objects located very
close to the camera; increase it to
improve the appearance of some surfaces
in Overview cameras with very large
extents.

3D Backdrop Panel

The settings on the 3D Backdrop panel allow
you to specify a backdrop image or color to

display behind your model in the selected 3D
view. See “3D Backdrops” on page 423.



Camera Specification Dialog

™ Full Camera Specification

Specify Backdrop
Backdrop Name:

Camera
3D Backdrop

Rolling Hills

*

Backdrop Options
[] Use Generated Sky

Haze Level:

Horizon Level:

0 Specify Backdrop -A preview of the
selected backdrop image is shown here.

A backdrop cannot be selected or removed

when Use Generated Sky is checked, below.

* Backdrop Name - The selected back-
drop image’s name displays for reference.

e Click Select Backdrop to choose a back-
drop image from the library. See “Select
Library Object Dialog” on page 350.

* Click Remove Backdrop to use a solid
color instead of a backdrop image in all
3D views, then specify the color below.

* Click the Color bar to select the Back-
ground Color that displays when a back-
drop image is not being used. See “Select
Color Dialog” on page 90.

Background Color: l:l

Low

Medium

High

Select Backdrop...

Remove Backdrop

Only used when
backdrop is not used

4%

Cancel Help

The Background Color for plan views is set
in the Preferences dialog. See “Colors
Panel” on page 59.

g Backdrop Options -

* Check Use Generated SKky to simulate a
daytime sky backdrop. When checked,
Spherical Panoramic Backdrop will also
be checked and a preview of the Gener-
ated Sky will display above.

* Specify a Haze Level of Low, Medium,
or High. This determines the degree to
which light in the sky backdrop appears
to be scattered by particles in the air.

* Specify a Horizon Level using the text
field or slider bar. The default value of
44% works well in most situations.
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Chapter 29:

3D Rendering

There are a variety of tools available to
create 3D views of a model: simply click a
button to create an overview, or click and
drag to create a camera view. See “3D
Views” on page 381.

To improve the quality of the rendering and
create a custom look, you can adjust lighting,
edit the materials used in the plan, choose
from several rendering techniques and fine-
tune 3D view quality settings.

Chapter Contents

Rendering Tips

Lighting

Light Types

Displaying Lights

Lighting Modes

Adjust Sunlight Dialog
Rendering Techniques
Rendering Technique Options
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Rendering Tips

402

There are a variety of factors which affect the
appearance and quality of rendered 3D
views. You can use these tools and settings to
achieve renderings that meet your needs.

+ Lighting

+ Shadows

+ Reflections

* Material Definitions
* Images

+ Backdrops

+ Edge Smoothing

Lighting

Lighting is extremely important in most 3D
renderings. Lighting controls the visibility of
objects in a view, affects the appearance of
surfaces, and influences the appearances of
colors and textures on those surfaces. Even
small changes to light intensity, direction and
color can have a large impact on image
quality. See “Lighting” on page 404.

Shadows

’ h Like lighting, shadows have an

important effect on image quality.
Shadows can be generated in any type of
camera view using any Rendering Technique
aside from Glass House. See “Rendering
Techniques” on page 407.

When shadows are enabled and the sun is
shining directly at a window, its light can
shine through the window and into an
interior room. These shadows use Ray
Casted Sun Shadows by default, but this

option can be unchecked if it slows
performance in 3D views.

Shadows are enabled in Full and Floor
camera views by default. You can, however,
check or uncheck Show Shadows and Ray
Casted Sun Shadows in the defaults dialog
for any camera tool or in the Camera
Specification dialog. In addition, you can
select 3D> Camera View Options> Toggle

Shadows B in any camera view. See
“Camera Panel” on page 397.

Shadows are affected by the number of light
sources in a plan, as well as what Rendering
Technique is in use. In order for a light
source to cast shadows, it must be On in the
current view and have Cast Shadows
checked in its specification dialog. See
“Light Data Panel” on page 273.

Reflections

@ Reflections are another aspect of
T | lighting that can increase a 3D view’s
realism. When a flat surface is assigned a
Mirror material, it can display the reflections
of other objects in the scene.

Note that a Mirror surface cannot display the
reflection of another mirror. When one
mirror can be seen in another, its material is
shown rather than a reflection.

Reflections only generate in Perspective 3D
views using the Standard Rendering
Technique. They can slow down 3D view
generation and responsiveness considerably.

Reflections can be toggled on or off in a
camera view by selecting 3D> Camera



View Options> Toggle Reflections @ as
well as in the Camera Specification dialog.
See “Camera Specification Dialog” on page
396.

Material Definitions

Textures are graphic files that represent
contoured surfaces of objects such as carpet,
bricks, tile, and wood in 3D views. Textures
are assigned to materials which in turn are
assigned to objects. See “Textures” on page
368.

The display of materials in 3D views is
controlled by settings in the Define Material
dialog. See “Define Material Dialog” on
page 376.

Brightness, shininess and transparency
control how light sources affect the display
of surfaces in 3D views. See “Lighting” on
page 404.

If no texture is selected for a material or if
the display of textures is turned off, affected
surfaces are a solid color instead.

Images

Images are very important for the appearance
of 3D views. Images are picture files that
represent individual objects such as trees,
flowers, and vehicles. See “Placing Images”
on page 414.

Backdrops

A backdrop is an image, usually of an
exterior view, that displays in the background

Rendering Tips

of 3D views to help place the model into a
realistic setting and add a sense of
perspective. If a backdrop is not specified,
Home Designer Interiors applies a
background color. See “3D Backdrops” on
page 423.

Edge Smoothing

Angled surface edges will sometimes display
on screen as jagged or stair-stepped. Edge
Smoothing softens this effect, producing
cleaner lines.

You can specify how much Hardware Edge
Smoothing occurs in 3D views in the
Preferences dialog. Hardware Edge
Smoothing is set to “High” by default;
however, if 3D views render slowly on your
system, you can try using a lower setting. See
“Render Panel” on page 62.

Even higher quality Edge Smoothing can be
produced by checking Edge Smoothing
When Idle in the Camera Specification
dialog. This setting does not affect a camera
while its position or orientation are being
changed, but applies additional smoothing to
edge lines when the camera is not in motion.
See “Camera Specification Dialog” on page
396.

This high quality Edge Smoothing option is
view-specific and can also be toggled on or
off by selecting 3D> Camera View
Options> Toggle Edge Smoothing When

Idle @ .
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Lighting

Lighting controls the visibility of objects in
3D views, affects the appearance of surfaces,
and influences the appearances of colors and
textures on those surfaces.

Each individual light source has a set of
properties, such as intensity and color, that
can be defined. See “Light Data Panel” on
page 273.

By default, a maximum of eight lights can
display in a given camera view or overview.
If more than eight are present, those with the
highest intensity located in the same room as
the camera are rendered. Lights in adjacent
rooms may also be rendered, with the highest
intensity lights rendered first.

You can specify a different Maximum Lights
number in the Camera Specification dialog.
See “Camera Panel” on page 397.

You can also manually turn on and off
individual lights in order to get the desired
lighting effects. See “Displaying Lights” on
page 405.

When the camera is outside a building, the
program normally uses sunlight for lighting
calculations and turns off all other light
sources.

Default Lights

If you create a Standard interior in a room
where no lights have been placed, the
program creates a Default Light source
within that room. The Default interior light
acts like a central point light source but
cannot be selected or edited.

Because the Default Light cannot be
adjusted, if you want to control the light in an
interior 3D view, you must add lights to the
rooms in your plan by placing light fixtures
and Added Lights

If you create an exterior 3D view, the
program creates a Generic Sun. Like the
Default Light, the Generic Sun cannot be
adjusted in any way.

Light Fixtures

An electric symbol that represents a Light
Fixture has a light source associated with it.
When a light is placed in a room, it will be
used as a light source in 3D views instead of
the Default Light. In large rooms, more than
one light fixture may be needed for sufficient
light.

Generic Sunlight

When you create a 3D view, the program
creates a Generic Sun light source. The
Generic Sun’s intensity, color, and angle can
be modified in the Adjust Sunlight dialog.
See “Adjust Sunlight Dialog” on page 406.

Ambient Lighting and
Occlusion

Ambient lighting simulates the way light
bounces around a scene, producing a basic
level of uniform illumination on all surfaces.
It is used in camera views and overviews
using the Standard Rendering Technique. .

Ambient occlusion adds shading to surfaces
near corners which, because of their location,
reflect less light compared to other surfaces.



Too little ambient occlusion can result in a
view having a flat appearance. You can
specify the amount of Ambient Occlusion to
use in the Camera Specification dialogs.

Light Types

See “Camera Defaults Dialogs” on page 382
and “Camera Specification Dialog” on page
396.

Light Types

There are two types of light source, each of
which generates light in a different way and
allows you to create a variety of lighting
effects:

* Point Light sources

* Spot Light sources

Any light source can be specified as a Point
or Spot Light in the Electrical Service
Specification dialog. See “Light Data Panel”
on page 273.

Point Lights

Like a bare light bulb, a Point Light radiates
light equally in all directions from its origin.

Point lights are a realistic representation of
non-directional electric lighting.

If no user defined light exists, Home
Designer Interiors creates a Point Light
source to represent a light within a room.

Spot Lights

A Spot Light focuses the light in a specified
direction. The Tilt and Direction Angles can
be specified in the light fixture’s
specification dialog.

Displaying Lights

The display of light fixtures in floor
plan and 3D views is controlled in the

Display Options dialog. Light fixtures are
placed on the “Electrical” layer. See
“Display Options Dialog” on page 88.

In addition, they can serve as sources of light
in rendered 3D views. They can be turned on
and off, as well as set to cast shadows.

In Floor Plan View

In floor plan view, light fixtures can display
labels when the “Electrical, Labels”layer is
turned on.

In 3D Views

Light fixtures can serve as sources of light in
rendered views.

Toturn alight on or off

There are two ways to turn a light fixture on
or off:

» Select one or more fixtures and click the
Turn Light(s) Off in 3D @ or Turn
Light(s) On in 3D/&¥ edit button.
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*  Uncheck On in the object’s specification
dialog. See “Light Data Panel” on page
273.

You can specify that any light source’s
location be represented in 3D views using a
cross hairs. See “Light Data Panel” on page
273.

Light source position indicators will only
display when the light is in use in the current
3D view. That is, it must be:

*  Turned on.
¢ In use in the current view.

¢ Either located in a room or in an exterior
view with Sunlight toggled off.

Sunlight will shine through windows into
interior rooms when shadows are enabled.
See “Shadows” on page 402.

Lighting Modes

By default, cameras use an Automatic
Lighting Mode that allows a set number of
lights to illuminate the view. This number
can be specified in the Camera
Specification dialog. See “Camera Panel”
on page 397.

If more than the set number of lights are
present, lights are prioritized in this order:

* Lights in the same room as the camera
before those in different rooms.

* Higher intensity lights before lower
intensity lights.

» Lights closer to the camera before those
further away.

* Regardless of their intensity or proximity
to the camera, lights on floors above the
camera are not used in Floor Cameras
and Overviews. See “3D View Tools” on
page 383.

The Automatic Lighting Mode is useful
because it is an easy way to produce
reasonable lighting without taxing your
video memory.

An alternative to the Automatic Lighting
Mode is the Use Light Settings option.
When Use Light Settings is selected, all
lights in the current plan that are turned On
are used in 3D views. This gives you control
over which lights are used as light sources
but may require more resources on your
system.

Adjust Sunlight Dialog

.| The Adjust Sunlight dialog allows
you to control the intensity, direction
and color of the Generic Sun light source in

the currently active 3D view. See “Generic
Sunlight” on page 404.

To open this dialog, select 3D> Adjust

Sunlight =/ while a 3D view is active.



™ Adjust Sunlight X
Light Settings
Intensity: 100,000 Lux (Mid day) hd
Color: l:l
Tilt Angle: '
Direction Angle: '

Restore Initial Settings

Cancel Help

* Use the Intensity slider bar or text field
to control how bright the Generic Sun
light appears.

*  Click the Color bar to define the color of
the light being modeled. Colored sunlight
may be used to achieve special lighting
effects, but may alter the appearance of
your material colors and textures.

Rendering Techniques

*  Specify the Tilt Angle, which is the angle
of the sunlight with respect to the hori-
zon. A value of 90° means that the light
points straight up, while a value of -90°
means that the light points straight down.
0° is parallel to the horizon.

e Specify the Direction Angle, which is
the direction that the sunlight points
toward. 0° is measured horizontally on
screen, pointing to the right. Positive val-
ues rotate in a counter-clockwise direc-
tion from there, while negative values
rotate clockwise.

* Click the Restore Initial Settings button
to restore the original Generic Sun set-
tings.

By default, the Generic Sun light color is
pure white, which has the least effect on the
appearance of material colors and textures.
See “Materials” on page 367.

Rendering Techniques

Any camera view or overview can be
] = generated using one of several
Rendering Techniques to produce views for a
range of different purposes. When a 3D view
is active, select 3D> Rendering Techniques
to access these tools.

Once a view is created, the effects of the
selected rendering technique can be adjusted
in the Rendering Technique Options
dialog. See “Rendering Technique Options”
on page 408.

Standard Rendering

Standard rendering is a photo-
realistic technique that represents
materials using textures, models lighting, and

can also display shadows. Surface edge lines
are not drawn and no special colors or effects
are applied.

" In floor plan view, the camera

I — - symbol for a view using the
~-._ Standard technique displays an S
in its center. See “Displaying 3D
Views” on page 384.
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Glass House

Glass House rendering uses different shades
of a single color to display the model with
surface edge lines and semi-transparent
surfaces. Lighting and shadows are not
modeled, and materials are not represented,
so textures are not used.

_~~In floor plan view, the camera
I — - symbol for a view using the Glass
~._ House technique displays a G in
its center.

Technical lllustration

ﬁ Technical Illustration rendering
draws surface edge and pattern lines,
and uses shades of two colors, Warm and
Cool. The warm shade is applied to surfaces
that face the light source in the view, and the

cool shade,to surfaces that face away from it.

Only one light source is used: the light with
the highest Intensity found in the room
containing the camera. In exterior views, this
light is always the Generic Sun. If no lights
are on, a fallback light is used. Lighting is
modeled as non-photorealistic, stylized

highlights and shadows are supported. See
“Lighting” on page 404.

_~In floor plan view, the camera
I — - symbol for a view using the
~._ Technical Illustration technique
displays a T in its center.

Watercolor

ﬁ Watercolor rendering approximates

the effects of watercolor painting such
as pigment pooling and flow. It uses textures
to represent materials and models lighting
and shadows.

" In floor plan view, the camera
I — - symbol for a view using the
~._ Watercolor technique displays a
W in its center.

Rendering Technique Options

~_| The settings in the Rendering
[E=] Technique Options dialog allow you

to control the specific effects of each
rendering technique on an active 3D view. To



access this dialog, create a camera view or
overview and select 3D> Rendering
Techniques> Technique Options.

In the Rendering Technique Options
dialog, select a technique from the list on the
left to make its options active on the right.
When this dialog is first opened, the
technique currently used by the view is
selected.

Rendering Technique Options

As changes are made in the Rendering
Technique Options dialog, the 3D view
automatically updates to reflect those
changes for all techniques except Watercolor.
To update views using these techniques,
which take more time to draw than the
others, click the Update button in the dialog.

When a 3D view is saved, its Rendering
Technique Options settings are saved, as
well. See “Saving 3D Views” on page 395.

Standard Panel

The active 3D view immediately

updates to reflect any changes made to
the Rendering Technique Options for
Standard renderings.

There are a variety of other tools that affect
the appearance of Standard rendered views,
as well. See “Displaying 3D Views” on page
384.

™ Rendering Technique Options

Standard Interior Ambient:
Glass House
Technical lllustration

Watercolor

Use Backdrop

Daytime Ambient:
Mighttime Ambient:

Reset to Defaults

*
|
| | 3%
|
Cancel Help

Specify the amount of Ambient light in
different situations. See “Ambient Lighting
and Occlusion” on page 404.

« Interior Ambient affects interior views.
* Daytime Ambient affects exterior views.

* Nighttime Ambient affects nighttime
exterior views.

*  When Use Backdrop is checked, the
backdrop image specified for this view is
used. When unchecked, the specified
Backdrop Color is used instead. See “3D
Backdrops” on page 423.

» Click Reset to Defaults to restore the
default settings used when the Standard
technique was first enabled.

Glass House Panel

The active 3D view immediately
updates to reflect any changes made to

=

the Rendering Technique Options settings for
Glass House renderings.
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™ Rendering Technique Options

*
Standar cio: |
Glass House
Technical lllustration Transparency: I
Watercolor
e s ]
[] Use Backdrop

Reset to Defaults

Cancel Help

* Click the Color bar to select a color for
the semi-transparent surfaces and lines in
a Glass House view. See “Select Color
Dialog” on page 90.

+ Specify the Transparency of the surfaces
in Glass House view. For example, to cre-
ate a wireframe line drawing of your
structure, turn transparency to full and
minimize line thickness.

Specify the Line Thickness of surface
lines in Glass House view.

When Use Backdrop is checked, the
backdrop image specified for this view is
used. When unchecked, the specified
Backdrop Color is used instead. See “3D
Backdrops” on page 423.

Click Reset to Defaults to restore the
default settings used when the Glass
House technique was first enabled.

Technical lllustration Panel

ﬁ The active 3D view immediately
updates to reflect any changes made to

the Rendering Technique Options settings for
Technical Illustration renderings.

™ Rendering Technique Options

*
s wamcos [
Glass House
Technical lllustration Cool Color: _
Watercolor
Viarm Blend: i
Cool Blend: i
e s ]
[] Use Backdrop

Reset to Defaults

Cancel Help

* Click the Color bar to select a Warm
Color for surfaces that face the light
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source and a Cool Color for surfaces that
face away from the light.



Specify the Warm Blend, which is the
degree to which the selected Warm Color
is blended with original colors on well-lit
surfaces in the view.

Specify the Cool Blend, which is the
degree to which the selected Cool Color
is blended with original colors on shaded
surfaces in the view.

Rendering Technique Options

Specify the Line Thickness of all surface
edge and pattern lines in the view.

Check Use Backdrop to use the back-
drop image specified for this view. When
unchecked, the specified Backdrop Color
is used.

Click Reset to Defaults to restore the
default settings used when the Technical
[llustration technique was first enabled.

Watercolor Panel

In order for the active 3D view to
reflect changes made to the Rendering

o

Technique Options settings for Watercolor
renderings,

™ Rendering Technique Options

Standard

Glass House
Technical lllustration
Watercolor

Smooth Amount:

Paint Contrast:

Edge Strength:

Turbulence Strength:

Turbulence Scale:

Use Backdrop

Pigment Settling Strength: I o

i
I 00
| 7
i

I &

Reset to Defaults

Cmml.u —_
g IR
g |2 [F]|=]]|3
A
=
m
H
*

Cancel Help

Specify the Smooth Amount, which is
the degree to which details are removed
from the original view.

Specify the Paint Contrast, which deter-
mines the extent to which variations in
pigment color are used.

Specify the Turbulence Strength, which
produces “pooling”, or variations in the
strength of pigment colors.

Specify the Turbulence Scale, which
controls the size of the areas of pooling.

Specify the Pigment Settling Strength,
which is creates the appearance of pig-
ment settling into low areas in paper.

Specify the Edge Strength, which is how
well-defined surface edge lines are.

When Use Backdrop is checked, the
backdrop image specified for this view is
used. When unchecked, the specified
Backdrop Color is used instead.

Click Reset to Defaults to restore the
default settings used when the Watercolor
technique was first enabled in this view.
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* Click Update View to apply these set-
tings to the active 3D view.
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Chapter 30:

Pictures, Images,
and Walkthroughs

Home Designer Interiors uses picture files in
a variety of ways to enhance your drawings.

The Library Browser contains images of real
world objects like plants and vehicles that
can display in 3D views.

Picture files can also be imported into Home
Designer Interiors and shown in most views.

You can save any view using a variety of
picture file formats. In addition, Home
Designer Interiors allows you to create
virtual tours that can be saved as .avi files,
shared with others, and played back later.

Chapter Contents
Picture Files vs Pictures and Image Objects
Images
Displaying Images
Editing Images
Image Specification Dialog
Pictures
Picture File Box Specification Dialog
Metafiles
Metafile Box Specification Dialog
Displaying Pictures and Metafiles
Editing Pictures and Metafiles
3D Backdrops
Backdrop Specification Dialog
Walkthroughs
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Picture Files vs Pictures and Image Objects

In common computer language, picture files,
pictures and images are more or less
synonymous. In the Home Designer Interiors
environment, however, there are some
notable differences between these terms.

In Home Designer Interiors, a two
dimensional image file such as a .bmp, .jpg,
.gif, or .png is referred to as a picture file or
an image file. Examples of these files are
saved on most computers and can be opened
in a variety of applications.

A Picture, on the other hand, is a file that has
been imported into the program. Pictures can
be imported into floor plan view. They are

two-dimensional only and do not display in
camera Views Or OVerviews.

An Image object is also based on a picture
file, but it does display in both 2D and 3D
views. Images have 3D width and height data
associated with them, as well as a 2D symbol
which displays in floor plan view.

Picture files have additional uses in Home
Designer Interiors, as well:

» Backdrops are picture files that display

behind 3D views. See “3D Backdrops”
on page 423.

» Textures are picture files that realistically
represent materials in 3D views. See
“About Materials” on page 367.

Images

414

Images add realistic detail to 3D views
without adding many surfaces to the model.
For example, a tree image with a single
surface can be used instead of a tree symbol
with thousands, dramatically improving

realism without compromising drawing time.

There are two types of Images in Home
Designer Interiors:

* Images @ rotate so that they always
face the camera in 3D views.

* Billboard Images [l do not rotate to
face the camera. An example of when
this may be useful is an image of a trellis,
which might look awkward when facing
a camera from a side view.

Placing Images

:ﬂl_'-_ A selection of Images are available in

the Library Browser. Select one and
click in a floor plan view, camera view or
overview to place it. See “Placing Library
Objects” on page 349.

Creating Images

@ Custom Images can be added to the

Ll Library Browser, as well as created in
plan files. Home Designer Interiors can use
any image with a *.bmp, *.jpg, *.png, *.gif,
or *.tif extension.

Generally, .png files work best as Images
because this format has good compression
and allows for the Image to contain
transparency information.



To create an Image in floor plan view

1. In floor plan view, select Build>
Image> Create Image @ or Billboard

Image [ to open the Image
Specification dialog. See “Image Speci-
fication Dialog” on page 416.

2. On the IMAGE panel:

Click the Browse button to select a pic-
ture file on your computer or enter the
path to a valid picture file in the Image
File field.

Select a 2D Plan Symbol from the drop-
down list or click the Library button
and select a symbol from the library. The
selected symbol represents the image in
floor plan view. See “Image Panel” on
page 417.

Specify the Size and Position of the
image.

3. Specify transparency information on the
TRANSPARENCY panel.

4. Click OK to close the Image
Specification dialog.

Displaying Images

5. Click to place the new Image in floor
plan view.

To create an image in the Library Browser

1. Inthe Library Browser, right-click on an
unlocked folder.

2. Select New> Image from the contextual
menu to open the Image Specification
dialog.

3. Browse to the image file you want to
add and select your other options. See
“Image Specification Dialog” on page
416.

4. Once created, the image is listed in the
library folder that you right-clicked on.
Size and other data is saved.

Using Paste Image

Eh You can also import an image by first

copying it to the system clipboard,
then navigating to a Home Designer Interiors
window and selecting Edit> Paste> Paste
from the menu. See “Paste Special” on page
83.

Displaying Images

The display of images in floor plan

and 3D views is controlled in the
Display Options dialog. See “Layer
Attributes” on page 87.

Images are placed on the”Images” layer.

In Floor Plan View
In floor plan view, most images are

represented by an Image @ symbol. You
can specify a different symbol to represent an

image if you wish. See “Image Specification
Dialog” on page 416.

In 3D Views

The actual picture associated with an image
object can be seen in 3D views, as can any
transparency data associated it. See “Image
Specification Dialog” on page 416.

Images can be set to either rotate so that they
always face the camera or remain stationary,
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like billboards. See “Images” on page 414.

Editing Images

Images can be selected in 2D and 3D views
and edited using the edit handles, edit tools
and the Image Specification dialog.

Using the Mouse

In floor plan view, a selected image can be
rotated, moved, and resized. In 3D views, a
selected image only has two edit handles: the
circular Resize handle and square Move
handle.

| 54 916" |

o

?2"

When an image is resized using the edit
handle, its aspect ratio is retained and 2D
symbol resizes proportionally.

Using the Edit Toolbar

A selected image or images can be edited in a
variety of ways using the buttons on the edit
toolbar. See “The Edit Toolbar” on page 24.

Image Specification Dialog

416

I—l Select an image and click the Open
Object edit button to open the Image
Specification dialog.



Image Specification Dialog

Image Panel

™ Image Specification *
| General o - h
mage £
Transparency Image File: |‘|ced Files'\BonusImages. zip#zip:Flag(h 144).png | Browse...
Fill Style
2D Plan Symbol: Other hd o
Size Elevation o .
Height:
Retain Aspect Ratio of 0.64
Reset Original Aspect Ratio
Elevation Reference: From Floor =
Floor to Top:
Center Point o
X Position: 501"
¥ Position: 218"
Options o
|:| Reverse Image
Image Always Faces Camera
Copyright o
Copyright® 2010, Chief Architect, Inc.
Cancel Help
General information about the selected * Enter a Width for the selected image.

Image can be specified here.

* The Image File associated with the

Image can be specified. Click Browse to
choose a file saved on your computer or

type the file’s full pathname in the text
field.

* Select a 2D Plan Symbol from the drop-
down list to represent the Image in floor

plan view. See “Displaying Images” on
page 415.

2]

* Enter a Height for the selected image.

Specify the Size/Elevation of the
image as it displays in 3D views.

Uncheck Retain Aspect Ratio of X if
you would like to modify the Height or
Width without affecting the other value.
If you do this, the image may appear dis-
torted.

This check box does not affect editing
performed outside of this dialog and is an
action rather than a state: the next time
you open this dialog, it will be checked.

Click Reset Original Aspect Ratio of to
reset the image’s original aspect ratio and
remove any distortion caused by resizing.

Select the Elevation Reference from the
drop-down list. This determines where
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the next two settings are measured from
and also affects their setting labels.

+ Specify the height to Top, measured from
the selected Elevation Reference to the
top edge of the image.

+ Specify the height to Bottom, measured
from the selected Elevation Reference to
the bottom edge of the image.

0 Specify the location of the X and Y
Coordinates of the selected image’s
Center Point.

9 Options -

* Check Reverse Image to reflect the
appearance of the image about an imagi-
nary vertical line through its center.

¢ Check Image Always Faces Camera to
prevent the image from rotating to face
the camera in 3D views. This box is
unchecked for Billboard Images. See
“Images” on page 414.

e Any Copyright information associated
with the selected Image will be stated
here.

0 A preview of the selected Image

displays here. The Glass House
Rendering Techniques is not available for
images. See “Dialog Preview Panes” on page
28.

Transparency Panel

The settings on the TRANSPARENCY panel let
you specify portions of the selected image as
transparent.

™ Image Specification

Image (O) Use Transparency From the Image File
Transparency @ Use Custom Transparency Color
Fill Style
coor:
Tolerance: I

Click on the image below to select a new color.

Cancel Help




* Click the Use Transparency From The
Image File radio button to use any trans-
parency data included in the image file.

¢ Click the Use Custom Transparency
Color radio button to specify a color in
the image to represent the transparency
and enable the settings below.

¢ Click the Color bar to select a color in the
Select Color dialog. See “Select Color
Dialog” on page 90.

» Use the slide bar or enter a value to spec-
ify a level of Tolerance to be applied to
colors that are almost the same as the
specified transparency color.

* Move your pointer over the small pre-
view image below. The pointer changes
to an eyedropper and a magnified pre-
view displays to its right. Click to select
the color of the pixel your pointer is over
as the Transparency color. The selected
color displays in the Color bar, below.

* A magnified preview of the area in the
preview image above displays here,
allowing for accurate pixel selection.

Pictures

Note: The image preview will display its origi-
nal orientation, even if Reverse Image is
checked on the Image panel.

The Transparency Color

If the portion of the image file that you wish
to use contains the transparency color, that
part of the image also becomes transparent.
If this happens, the image may appear
partially disintegrated.

You may need to experiment to find the best
transparency color and tolerance for the
image.

Fill Style Panel

The settings on the FILL STYLE panel affect
the appearance of the selected image’s 2D
Plan Symbol in floor plan view, provided
that the selected symbol is a closed shape.
For information about these settings, see
“Fill Style Panel” on page 131.

Pictures

A variety of picture file types can be
imported into and exported out of Home
Designer Interiors.

Metafiles are also types of picture files that
can be imported and exported. See
“Metafiles” on page 421.

Exporting Pictures

There are several ways to save a picture of a
view in Home Designer Interiors:

I_Et—l Using the Export Picture tool is

similar to creating a screen capture of
everything in the current view window.
Pictures can be saved in various file formats
and used in other applications.

Export Picture [ is best suited for 3D
views. When exporting a line-based view,
best results can be achieved by saving it as a
Metafile. See “To export a metafile” on page
421.
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— | Use the Print Image tool to either
= print or save the current view as a
PDF file. See “Print Image Dialog” on page

454.

To export a picture

1. Open the view that you would like to

export as a picture file.

2. Zoom, pan or otherwise adjust the view
so that what you see on screen suits your
needs. See “Displaying 3D Views” on

page 384.

3. Select File> Export> Export Picture

(BMP, JPG, PNG) [# to open the

Export Picture File dialog and give the
file to be exported a name, file type, and
location. See “Exporting Files” on page

41.

Importing Pictures

rx;—l Pictures can be imported into and
— displayed only in floor plan view.

Pictures do not display in camera views or
overviews. See “Displaying Pictures and

Metafiles” on page 422.

There are several ways to import a Picture
into Home Designer Interiors:

* Select File> Import> Import Picture

(BMP, JPG, PNG) ¥ to open the
Import Picture File dialog, which is a
typical open file dialog. See “Importing
Files” on page 45.

* Click and drag an image file from an
operating system window into the Home
Designer Interiors window.

» Inany application, copy an image to the
system clipboard, then select Edit>

Paste> Paste [1) from the Home
Designer Interiors menu in an eligible
view window. See “Paste Special” on
page 83.

Note: Importing large, or multiple, Pictures
into a plan file can result in program slow-
ness.

An imported picture is placed in the center of
the current view. Once imported, pictures can
be selected and edited. See “Editing Pictures
and Metafiles” on page 422.

Picture File Box Specification Dialog

I—l Select an imported picture file and
click the Open Object edit button to
open the Picture File Box Specification

dialog.

420

The settings in this dialog are similar to those
on the LINE STYLE panel in numerous other
dialogs, with one exception: check Show
Outline to turn on the display of the picture’s
border polyline. For more information, see
“Line Style Panel” on page 126.



Metafiles

Metafiles
A metafile (.emf, .wmf) is a special picture
file format made up of vectors (lines) that ™ Metafile Size X
allow the image to be r§sca1§d without .loss Enter desred width of your picture:
of quahty. ngh resolution plCtuI'eS of line- (measured in target document)
based views can be exported as a metafile. Width:
Height: 41/8"
Note: Metafiles are not supported in Mac pPL

operating systems and cannot be imported or Cancel Help
exported in Mac versions of the software.

6. Specify the desired Width or Height of

Exporting Metafiles the metafile. When one value is edited,
the other changes to maintain its aspect
+ | An enhanced metafile (.emf) can be ratio
EMF] - exported from floor plan view. ’
Only objects that display on screen are Specify, too, the desired Dots Per Inch
included in an exported metafile. (DPI) for the metafile. A larger value
results in a higher quality metafile, but
To export a metafile also a larger file size.
1. Accurately position the view on screen. Importing Metafiles

ile> >
2. Select File> Export> Export Metafile WiE| Metafiles can be imported into and

(EMF) G . ¥ ¥ displayed only in floor plan view.
Metafiles do not display in camera views or
overviews. See “Displaying Pictures and
Metafiles” on page 422.

.

3. Dragamarquee from corner to cor-
ner, defining the area that will included
in the metafile.

There are two ways to import a metafile into

4. Release the mouse button to open the . .
Home Designer Interiors:

Export Metafile dialog, which is a typi-

cal Save As dialog. See “Saving, * Select File> Import> Import Metafile
Exporting, and Backing Up Files” on (EME,WMF) 0 o open the Import
page 39. Metafile dialog, which is a typical open

5. When you click the Save button, the file dialog. See “Importing Files” on page
Metafile Size dialog opens. 45.

*  You can also click and drag a metafile file
from an operating system window into
the Home Designer Interiors window to
import it.
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An imported metafile is placed in the center

of the current view. Once imported, metafiles

can be selected and edited. See “Editing
Pictures and Metafiles” on page 422.

Metafile Box Specification Dialog

I—l Select an imported metafile and click
the Open Object edit button to open
the Metafile Box Specification dialog.

The settings in this dialog are similar to those

on the LINE STYLE panel in numerous other

dialogs, with one exception. Check Show
Outline to turn on the display of the picture’s
border polyline. For more information, see
“Line Style Panel” on page 126.

Displaying Pictures and Metafiles

The display of Pictures and Metafiles
#is controlled in the Display Options
dialog. See “Layer Attributes” on page 87.

Pictures and Metafiles are placed on the
“CAD, Default” layer.

Pictures and Metafiles can be imported into
and displayed only in floor plan view. A
Picture or Metafile can only be seen in the
view where it was imported and cannot be
imported into a camera view or overview.

Drawing Groups

Each object in a plan file is included in a
Drawing Group, which influences whether it
displays in front of or behind other objects.
By default, imported pictures are placed in
the Back Group, and imported metafiles are
placed in the same Drawing Group as CAD
objects.

Once imported, the drawing order of pictures
and metafiles can be customized. See
“Drawing Groups” on page 89.

Editing Pictures and Metafiles

422

Pictures and Metafiles can be selected and
edited using the edit handles, the edit toolbar,
and their specification dialogs.

In the Specification Dialog

Pictures and Metafiles can be customized in
their specification dialog. See:

+ “Picture File Box Specification Dialog”
on page 420

» “Metafile Box Specification Dialog” on
page 422

Using the Mouse

Pictures and Metafiles have edit handles
similar to other box-based objects. See
“Editing Box-Based Objects” on page 106.

* The corner Resize handles behave do not
behave the same for Pictures and
Metafiles as they do for CAD boxes,



however. If you drag a corner handle of
one of these objects while the Default
Edit Behavior is active, its contents will
resize and height to width ratio will be
retained.

» If you drag an Extend handle along a
Picture or Metafile edge, the contents of
the box will not be resized. If you resize
it larger, an empty space will be created
between that edge and the contents; if
you resize it smaller, the contents will be
cropped.

3D Backdrops

Using Dimensions

Pictures and Metafiles can be relocated
relative to other objects with precision using
dimensions.

To avoid changing the selected object’s
aspect ratio, make sure you choose to move
the entire object rather than the selected
edge. See “Moving Objects Using
Dimensions” on page 192.

Using the Edit Tools

A selected Picture or Metafile can be edited
in a variety of ways using the buttons on the
edit toolbar. See “The Edit Toolbar” on page
24.

3D Backdrops

A backdrop is an image, typically of an
exterior view, that displays in the background
of 3D views to help place the model into a
realistic setting and add a sense of
perspective.

A selection of backdrop images is available
in the Library Browser. You can also create
your own backdrop images and import them
into the library. See “Adding New
Backdrops” on page 345.

Backdrops automatically adjust to fit each
view window, so they look best when they
are created with a height to width ratio that is
similar to the window you are working in.

@ You can create digital photos of a build-
~ ing site for use as a backdrop.

Specifying a Backdrop Image

Backdrop images are view specific. You can
select a backdrop image for a camera view
from the library in either of two ways:

* Ina3D view, open the Library Browser.
Select a Backdrop image, then move your
mouse pointer £z into the view window.
Click anywhere in the view to apply the
selected backdrop.

* Open the Camera Specification dialog,
and on the BACKDROP panel, click the
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Select Backdrop button. See “3D Back-
drop Panel” on page 398.

When a backdrop image is not applied,
Home Designer Interiors applies a
background color instead. This color can be
specified on the BACKDROP panel of the
Camera Specification dialog, as well.

The Use Generated Sky option produces a
special Spherical Panoramic Backdrop that
simulates a daytime sky using the Generic
Sun.

Backdrop Defaults

By default, Home Designer Interiors uses
backdrop images in Full Cameras and Floor
Cameras only. You can, however, specify
which types of views use backdrops by

default, and also select the default backdrop
images for each, in the Camera Tools
Defaults dialogs. See “Camera Defaults
Dialogs” on page 382.

Similarly, backdrop images are only used by
default in a few Rendering Techniques:
Standard, Watercolor, and Physically Based.
You can choose whether a backdrop is used
in any technique in the Rendering
Technique Options dialog. See “Rendering
Technique Options” on page 408.

Similarly, backdrop images are only used by
default in the Standard and Watercolor
Rendering Techniques. You can choose
whether a backdrop is used in any technique
in the Rendering Technique Options
dialog. See “Rendering Technique Options”
on page 408.

Backdrop Specification Dialog

424

E To open the Backdrop Specification
dialog, select File> Import> Import
Backdrop or right-click on the User Catalog
in the Library Browser and select New>
Backdrop from the contextual menu. See
“Adding New Backdrops” on page 345.

You can also open this dialog by right-
clicking on a backdrop image in the User
Catalog in the Library Browser and selecting

Open b1 from the contextual menu.



Walkthroughs

™ Backdrop Specification

(2]
Z

Backdrop

MName: |Ranch

Location: }iles\,CoreCaialogFiles.zip #zip:Ranch. PG Browse. ..
Copyright o

Copyright® 2010, Chief Architect, Inc.

Cancel Help

0 A preview of the selected image
displays here.

9 Backdrop - Specify backdrop’s Name
and the image file associated with it.

* Type a Name for the selected backdrop,
to be used in the Library Browser and 3D
View Defaults dialog.

* In the Location field, type the full path-
name of the image file or click the
Browse button and browse to the file on
your computer.

If the selected image has a Copyright,
information about it will display here.

Walkthroughs

A 3D Walkthrough is a series of
® u/ pictures saved as an .avi file that can
be played like a video by other applications
such as Windows Media Player.

To record a walkthrough

1. Begin by selecting the codec for record-
ing walkthroughs. See “Selecting a
Codec” on page 426.

2. Create a camera view. This view is the
first frame of the walkthrough.
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From the view, select 3D> Walk-
throughs> Record Walkthrough (@ .

Specify a location and name for the
walkthrough in the Save Video As dia-
log and click Save.

In the Walkthrough Options dialog:

™ Walkthrough Options *

Frame Rate:
Compression: %

Cancel Help

Select a Frame Rate between 1 and
100. The value entered is the number of
frames per second.

Select a Compression Percent between
0 and 100. A value of 0 gives the highest
quality images and the largest file size.

Click OK.

Use the camera movement tools to cre-
ate additional views. Each time the
screen redraws, that view is recorded as
the next frame in sequence. See “Editing
3D Views” on page 391.

When the walkthrough sequence is com-
plete, select 3D> Walkthroughs> Stop

Recording B or close the view.

Note: Zooming in and out and using the scroll
bars does not change the viewpoint and does
not produce a frame for the walkthrough.

If you resize the current view window while
recording a walkthrough, the program will
stop recording.

To play a walkthrough

1. Select 3D> Walkthroughs> Play

Walkthrough P to open the Select
Video File dialog.

2. Browse to an .avi file on saved on your
computer. Your default video application
plays the walkthrough video.

Selecting a Codec

A codec is a a utility that compresses and
decompresses media files, and is used when
both recording and viewing .avi files such as
walkthrough videos.

You can specify which codec to use when
recording walkthroughs in the Preferences
dialog. See “Render Panel” on page 62.

To choose the codec that best suits your
needs, it is a good idea to create a test
walkthrough using each of the codecs
installed on your system to see how well
their walkthrough quality and file
compression meet your requirements.

For more information about codecs, visit
HomeDesignerSoftware.com.


https://www.homedesignersoftware.com/support/article/KB-00076/specifying-what-video-codecs-to-use-for-walkthroughs.html
https://www.homedesignersoftware.com/support/article/KB-00076/specifying-what-video-codecs-to-use-for-walkthroughs.html

Chapter 31:

Importing and

Importing is the process of opening a file that
was produced in a different program in
Home Designer Interiors. Exporting, on the
other hand, is the process of saving
information in a Home Designer Interiors file
to a format that can be read by another
program.

Home Designer Interiors allows you to
import and export a variety of information
from and to other applications. This chapter
focuses on importing a variety of 3D file
formats. Other importing and exporting
options are described in the chapters in
which those objects or settings are discussed.

Exporting

Chapter Contents
Chief Architect Account Login
Export Chief Architect 3D Viewer File
Import Room Planner File
3D Data Import Requirements
Importing 3D Symbols
Symbol Specification Dialog
3D Symbols and Materials
Export 360 Panorama
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Chief Architect Account Login

Your online Chief Architect Account allows
you to take advantage of a variety of valuable
resources including catalog downloads,
license management, and technical support.
See “Creating a Chief Architect Account” on
page 17.

In order to export a 3D model to a Chief
Architect 3D Viewer, export a 360°
Panorama image file, or import a drawing
from the Room Planner mobile app, you
must first log in your Chief Architect
account. See “Export Chief Architect 3D Viewer
File” on page 428, “Export 360 Panorama” on
page 435, and “Import Room Planner File” on
page 430.

If you try to do any of these tasks while you
are logged out of your account, the Chief
Architect Account Login dialog will open,
giving you an opportunity to log in.

You can also log into or out of your online
account at any time by selecting Help> Log

in to Chief Architect Account or Help>
Log out of Chief Architect Account.

Chief Architect Account Login
Dialog

™ Chief Architect Account Login *

Cancel Help

Password:

When importing a Room Planner file, use the
same E-mail Address and Password that
you used to save the drawing to the cloud in
Room Planner.

When exporting a Chief Architect 3D
Viewer or 360° Panorama file, use the E-
mail Address and Password that you use to
log in to the account on our website that is
associated with your software product key.

T The Chief Architect 3D Viewer
allows a model created in Chief
Architect to be viewed in either:

* A web browser on a computer.

+ The 3D Viewer app on a mobile device.

In order to export a Chief Architect 3D
Viewer file, you must be logged in to your
Chief Architect cloud account and have
active Support and Software Assurance.

Export Chief Architect 3D Viewer File

To export a file to the cloud for viewing with
either option, select File> Export> Export

Chief Architect 3D Viewer File
3D view is active.

while a

For more information about the Chief
Architect 3D Viewer, visit
HomeDesignerSoftware.com.



http://www.chiefarchitect.com/products/3d-viewer/

Export 3D Viewer File Dialog

™ Export 3D Viewer File b
MName: Albertson |
Description:

Surface Count: 251311
Texture Size:  34.71MB

Check knowledge Base Cancel Help

Cameras...

Export Chief Architect 3D Viewer File

Select Cameras to Export

Dialog
™ Select Cameras to Export *
Camera Name Include  Initial View Include All
Exterior Overview \/
Include N
Kitchen (source) | v | nieiae Tone
Master Bath \/

* The Name of the current plan file popu-
lates this field by default. Specify a differ-
ent name for the exported 3D Viewer file
if you would like.

* Type a brief Description of the model.

* Click the Cameras button to open the
Select Cameras to Export dialog and
specify which saved cameras to export
with the model.

* The Surface Count and Texture Size dis-
play here for reference. Large Surface
Count and/or Texture Size values can
impact performance in the mobile app.

Check knowledge Base Cancel Help

~+~ To reduce Surface Count and Texture
@ Size, consider turning off unnecessary
layers in the current 3D view before export-
ing. See “Layers” on page 86.

When you click OK, the 3D model is
exported using the layer settings in the
camera view that was active when the model
was exported.

On the 3D Viewer page, you can also choose
to share an exported model with someone so
that it can be opened in a 3D Viewer page or
in the 3D Viewer mobile app.

The Camera Name of each saved Per-
spective Camera and Overview in the
plan is listed here. The camera that is
active when you export the model, if
listed, is followed by “(source)”. Floor
Cameras and Overviews can be exported;
however, they behave like Full Cameras
and Overviews in the 3D Viewer.

In the Include column, click to add a
check mark for each camera that you
would like to export. By default, only
cameras of the same type, on the same
floor, and using the same layer set are
Included.

In the Initial View column, add a check
mark for the camera that you would like
to be active when the model is opened in
3D Viewer.

Click the Include All button to export all
saved cameras with the model. A large
number of saved cameras may slow down
the interface of the 3D Viewer app.

Click the Include None button to export
no saved cameras with the model. When
the model is opened, an unsaved 3D
Overview will be the initial view.
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Import Room Planner File

¥ Select File> Import> Import Room
.| Planner File, then select and
download a Room Planner file from the
cloud. When prompted to log in, use the
same credentials you used to save a plan to
the cloud in Room Planner.

Files created in Room Planner versions 2 -
4.1 can be imported into Home Designer
Interiors 2019.

Note that the exterior walls in an imported
Room Planner drawing will inherit their
thickness and other properties from the
Exterior Wall Defaults dialog in the current

plan, while interior walls will retain the
thickness that was set in Room Planner. See
“Exterior and Interior Wall Defaults
Dialogs” on page 136.

Unless a custom ceiling height has been
specified in Room Planner, rooms in an
imported file use the Default ceiling height
set in the Floor Defaults dialog. See
“Current Floor Defaults” on page 165.

Visit roomplanner.chiefarchitect.com for
more information about the Room Planner
mobile app.

3D Data Import Requirements
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Importing a symbol that can be used by
Home Designer Interiors is a relatively
simple process that begins with previously
created 3D data. This 3D data often comes
from a program other than Home Designer
Interiors. If you use another 3D modeling
program to create the 3D data, be aware of
the following requirements before attempting
to create symbols.

Home Designer Interiors is not able to
provide support for any third party soft-

/N

ware.

There are a number of requirements that
must be met before any 3D data can be used
to create a symbol in Home Designer
Interiors:

* The 3D data must be stored in an, object
(.obj), 3D Studio® Mesh (.3ds),

COLLADA (.dae), or SketchUp version
2018 and prior (.skp) file format. If you
have 3D data in another format, you must
convert it into one these formats

first. Geometry and material information
stored in .3ds files are imported; cameras
and lights are not.

* The 3D model must be composed of
3DSOLID solid entities, or face data.
Faces are typically referred to as 3D
faces, polygonal faces, or poly meshes.
Other types of entities such as lines,
curves, circles, polylines, and free form
surfaces can exist in the file but are not
imported when the symbol is created.
This is true for all (.obj/.3ds/.skp) file
types.

» The face data should be assigned to dif-
ferent layers so that you can map them to
the correct materials when viewing them
in 3D. It is helpful to name your layers


http://roomplanner.chiefarchitect.com/

using a convention that identifies that
materials should be assigned to each sub-
component.

» Pay attention to the origin and orientation
of the 3D data when designing symbols.
Home Designer Interiors allows some
adjustment when creating the symbol, but
it is easier to build the 3D data correctly
before importing it into Home Designer
Interiors. For more information about
defining the origin, see “Symbol Origin”
on page 1201.

+ If a symbol with faces that have more
than four vertices is imported, the faces
are truncated, resulting in an object that
appears to have holes. The best remedy is
to re-export the model from the original
application using only triangular or quad-
rilateral faces.

* Home Designer Interiors does not support
grouped objects in symbols imported
from .3ds files.

Surface Normals

If you use third party software to create an
.0bj/.3ds./skp file that will be imported as a

Importing 3D Symbols

symbol, you should be familiar with the
concept of surface normals.

i

A surface normal is a vector that is
perpendicular to the plane of a surface. This
vector points in one direction, determined by
the way the face is drawn.

If a face is drawn clockwise, the surface
normals are directed outward; if a face is
drawn counter-clockwise, the surface
normals point inward. Home Designer
Interiors assumes that the face on the positive
side of the normal vector is the outside face.

Many objects can be drawn using only one
side of each face. A cube is a good example:
the inside of a cube is not visible, so it is not
necessary to create its inside faces. When
inside faces are not calculated, 3D views in
Home Designer Interiors can generate more
quickly.

Importing 3D Symbols

} Home Designer Interiors supports the

"H import of 3D surface and 3D solid
objects saved in .3ds, .obj, .dae, and .skp
formats.

There are three ways to import a 3D symbol
into Home Designer Interiors:

* By selecting File> Import> Import 3D
Symbol | f tool.

« By selecting New> 3D Symbol |'# from
the contextual menu in the Library
Browser. See “Using the Contextual
Menus” on page 338.

* By dragging and dropping the file from an
operating system window into floor plan
view.
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Symbols imported by clicking and dragging
are imported for use in the current plan,
while those imported using the Import 3D
Symbol dialog are also saved in the library.
See “The Library” on page 335.

To drag and drop a 3D symbol file

1. Open the plan in which you would like
to import a 3D symbol and remain in
floor plan view.

2. Open an operating system window in
front of the Home Designer Interiors
program window.

3. Resize and position the window so that
the Home Designer Interiors program
window can be seen behind it.

4. Click on the desired .3ds, .obj .dae, or
.skp file and drag it into the Home
Designer Interiors program window.

5. When your cursor changes to a +, click
in the drawing area to place as many
copies of the symbol as desired. When
you are finished, select a different tool.

Symbols imported by clicking and dragging
cannot be edited in the Symbol
Specification dialog. If a symbol needs to be
rotated, or its unit of measurement specified,

use the Import 3D Symbol |# tool to
import it.

Symbol Specification Dialog
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Il To import a symbol object, select
r‘ﬂ File> Import> Import 3D Symbol.

Home Designer Interiors supports the import
of 3D surface and 3D solid objects saved to
.3ds, .obj, and .skp formats and treats
imported symbols as stand alone fixtures.

The Import 3D Symbol File dialog, which
opens first, is a typical Open File dialog in
which multiple files can be group-selected
for import. See “Importing Files” on page 45.

The Symbol Specification dialog opens
next.



Symbol Specification Dialog

3D Panel
™ Symbol Specification *
D S
- 3D Geometry o T lZ‘
Materials
Drawing Unit: in 7
Rotation o
Axis: Ox Oy ®z
Angle: Rotate + Rotate -
Faces o
Mumber Of Faces: 9164
P
=
Mumber Style. .. Cancel Help

0 3D Geometry - Select the Drawing

Unit that was used to create the
symbol. If any units other than inches or mm
are selected, the program will convert the
data into units appropriate for Home
Designer Interiors.

Note: SKP files are always imported using
inches, regardless of the default units used in
the plan file. See “Creating a New Plan” on

page 38.
g The Rotation settings allow you to
rotate the selected symbol about the X,
Y, and Z axes.

¢ Select the X, Y, or Z Axis.

* Specify the Angle to rotate the symbol in
the text field. 90° is set by default.

* Click the Rotate + or Rotate - button to
rotate the object around the selected axis
in a clockwise or counterclockwise direc-
tion, respectively.

e The Number of Faces that the symbol
has displays here for reference. When
multiple symbols are being imported,
nothing displays. Although there is no limit
to the number of surfaces that a symbol can
have, large numbers can increase the
rendering time for 3D views significantly.
0 A preview of the symbol’s appearance
displays here and updates as changes
are made to the settings in this dialog. When
multiple symbols are selected, the most

recently selected symbol displays. See
“Dialog Preview Panes” on page 28.

Materials Panel

The MATERIALS panel allows you to assign
materials to the symbol’s components and is
similar to the same panel in many
specification dialogs. See “Materials Panel”
on page 372.
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3D Symbols and Materials

When a symbol is imported into Home
Designer Interiors, material definitions may
be included with it. How material
information is included depends on the
symbol’s file format. See “About Materials”
on page 367.

OBJ Files

Material definitions for most .obj files are
saved in a separate file with the .mtl file
extension. If such a file exists, the materials
associated with the .obj file display in the list
on the left side of the MATERIALS panel of its
specification dialog.

If Home Designer Interiors does not receive
material definition information in an
accompanying .mtl file, default material
properties are assigned.

Material definitions for .obj files can also
include texture information in the form of
image files (.jpg, .png, etc).

In order to properly import an .obj file,
Home Designer Interiors needs the .obj file,
the .mtl file, and any referenced texture files.
If a texture file is not available, the material
it is associated with is created without a
texture.

The material definitions associated with an
imported .obj symbol are not available for

use by other objects in Home Designer
Interiors until that symbol has been placed
into a plan. The associated texture files are
then copied to the user’s Textures folder. See
“Home Designer Interiors Data” on page 37.

3DS and DAE Files

Material definitions for .3ds and .dae files
refer to texture information in separate image
files.

In order to properly import a .3ds and .dae
file, Home Designer Interiors needs these
referenced image files. If a texture file is not
available, the material it is associated with
will be created without it. The associated
texture files are copied to the user’s Textures
folder.

SKP Files

The textures associated with a .skp file are
saved in the file. After you import a symbol
and either place it in a plan or add it to the
Library, these textures are saved in the Home
Designer Interiors Textures folder.

Home Designer Interiors does not support
deformed textures. If a texture associated
with a .skp file is deformed, it will be
imported without the deformations.

Texture Filename Conflict

If a texture of the same name already exists
in the plan when an .obj, .3ds, or .skp file is

imported, the Texture Filename Conflict
dialog displays.



™ Texture Filename Conflict e
The file 'SOAPST~1.PNG' already exists in the textures folder.
What would you like to do?

Action
(® Rename the imported texture,

|.|res\+‘ly Textures\SOAPST~11.PNG Browse...

(O) Use the existing texture instead of the imported texture,
(O Replace the existing texture with the imported texture.

Do this for all remaining texture conflicts in this impart.

Cancel Help

e Select Rename the imported texture,
then click the Browse button to create a

Export 360 Panorama

copy of the texture’s image file with a
new name that you specify.

Select Use the existing texture instead
of the imported texture to keep the
existing texture.

Select Replace the existing texture with
the imported texture to replace the tex-
ture already present in the plan with the
new, imported one.

Check Do this for all remaining textures
in this object to use the same selection
for all textures with filename conflicts
associated with this symbol.

Export 360 Panorama

4= The Export 360 Panorama tool
[;] creates a spherical panoramic image
that can be opened in various panorama
viewers. Select File> Export> Export 360
Panorama while a 3D view is active to
access this tool.

For best results, position the camera as near
as you can to the center of the scene before
exporting.

Export 360 Panorama File

All of the settings in this dialog are retained
during the current program session.

™ Export 360 Panorama File *
s mes Q)
Heiht: Pixes

Limit Dimensions to Powers of Two
Retain Aspect Ratio

Save to Disk o
File: Please Enter a Valid Path Browse...

[ save to Chief Architect Cloud o
Descriptio

OK Cancel Help

0 Specify the size of the exported image,

in pixels.
Specify the Height and Width of the
exported image file, in pixels.

Check Limit Dimensions to Powers of
Two to restrict the Width and Height to
values that are powers of two. When this
is checked and an ineligible value is
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entered, it will adjust up or down to the
nearest power of two. Although not
required, this option is recommended for
best results in some panoramic image
viewers.

* The Retain Aspect Ratio check box dis-

plays for reference and cannot be
changed. The ratio between Width and
Height is 2 to 1 when Limit Dimensions
to Powers of Two is unchecked, above.

Check Save to Disk to save the
exported panoramic image file on the
local computer system.

+ Specify the full pathname of the File you
wish to export, or click the Browse button
to open the Export 360 Panorama File
dialog, which is a typical File Save dia-
log. See “Exporting Files” on page 41.

Note: You can also upload a panoramic
image file to the cloud on the 360 Panoramas
page of your online account.

Check Save to Chief Architect Cloud

to save the exported panoramic image
file to your Chief Architect Cloud Account.
See “Chief Architect Account Login” on
page 428.

» Type a short, descriptive Name for the
exported panoramic image file.

* Type a brief Description of the file.

When you click OK, a panoramic image is
created and a progress dialog may display.
Because spherical panoramas are composed
of multiple images stitched together, they
may take longer to create than a standard
exported picture.




Chapter 32:

Materials Lists

Materials Lists can be created for individual
rooms in your plan, edited, and printed
directly from the program. They can also be
exported as text files for use in other
programs.

& The Materials List is based on certain

assumptions that may not match your
building style. Home Designer Interiors makes
no representation as to the accuracy or reliabil-
ity of the Materials List generated by Home
Designer Interiors. Always compare the Materi-
als List with a manual take-off before providing
a quote or ordering materials for a job.

Chapter Contents
The Materials List
Creating an Accurate Materials List
Organizing Materials Lists
Materials List Display Options Dialog
Editing Materials Lists
Printing and Exporting the Materials List
Conditioned Area Totals
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The Materials List

A Materials List is like a snapshot of the
current plan at the time that the list is made.
Any changes made to the model after a
Materials List is generated are not included
in that list. Create a new Materials List if you
would like it to include these changes.

It is not necessary to wait until the plan is
complete to generate a Materials List. In fact,
you can create a series of Materials Lists
reflecting costs at various stages of a project.

~+ For comparison, generate Materials Lists
@‘ with and without a proposed plan modifi-
cation.

To create the Materials List for a
room, select the room and then select
Tools> Calculate Materials for Room.

Calculate Materials for Room is also
available on a selected room’s edit toolbar.
See “Editing Rooms” on page 168.

A Materials List calculated from a room is
created for only the contents of that room:
wall materials are not included.

Creating an Accurate Materials List

In order to take full advantage of Home
Designer Interiors’s Materials List
capabilities, bear in mind that using generic
objects like geometric shapes from the

library to represent objects that aren’t avail-
able in Home Designer Interiors can result in
items being calculated in the Materials List
in a manner that you might not expect.

Organizing Materials Lists
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You can control what items are calculated in
the Materials List by specifying which
categories are used.

There are some parts of a model that cannot
be excluded from the Materials List. Floor
and ceiling platforms are prime examples. If

you need to generate a Materials List for only
part of a plan, such as an addition, consider
making a copy of the plan file. In the copy,
delete the as-built portion of the plan and
then generate a Materials List.



Organizing Materials Lists

™ Home Designer 2019 - (m] x
File Edit Toocls View Window Help
h] — BR?
8 X [Euntited 1: 1stFloor X B Untitied 1: Materials List - Untitled 1 X
Untitied 1: Materials List - Untitled 1 x
Columns — D Floor Sze Description Count Bxtra  Unit Price  Total Cost Comment Label ~
1 General
2,/ 6N 1 109 1/8 high 99 - $0.00
GN2 1 thermal envelope - wall area - North 264 48 sqft $0.00
4 GN3 1 thermal envelope - wall area - East  173.17 sqft $0.00
5 G4 1 thermal envelope - wall area - South 264 10 sqft $0.00
Categories 6 GN5 1 thermal envelope - wall area - West  172.79 sqft $0.00
7 GN6 1 thermal envelope - ceiling area 551.00 sq ft $0.00
8 GNT 1 thermal envelope - floor area 551.00 sqft $0.00
\ Subtotal $0.00
10 Subfloor
1" SF1 1 &xBx34 05B-Hez 19 $0.00
12 Subtotal: $0.00
13 Framing
14 1 12°x6" ceiling joists - lumber 420 ft $0.00
15 F2 12°x6" fir plate 295 ft $0.00
1% >F3 12°x6" fir stud 541 t $0.00 -
& | »
Edit | S@E®
Toolbar 3 Entries
Categories 3. Select the desired category from the

The line items in the Materials List are
organized into a set of predefined categories,
such as Electrical and Framing, which
display in the ID column.

Unlike other categories that calculate
materials or objects, the General category
lists information about the building’s thermal
envelope. See “Conditioned Area Totals” on
page 442.

To specify alineitem’s category

1.
2.

Create a Materials List.

Click in the cell in the ID column for a

line item.

drop-down list that becomes available.

The categories that are available cannot be
altered; however, you can specify which
categories are included for individual lists in
the Materials List Display Options dialog.

Details Dialog

1 .| For information about one or more
selected line items in a Materials List,
click the Details edit button. The Details
dialog displays all Materials List columns for
reference, which can be helpful when not all
columns are in use in the Materials List. It
also lists the Source Object of the selected
line item or items.
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This dialog will also open when multiple
objects located on more than one floor are
selected in a Materials List and you click the

Find Object in Plan "4 edit button.

When one or more line items located on the
same floor are selected, click the Find button
at the bottom of the dialog to view their
location in a plan view window.

Find Object in Plan

Eo To find out where a line item in the

~~%| Materials List is located in the model,
select its row or any cell in its row and click
the Find Object in Plan edit button. This
tool opens a view window and selects the
object or objects associated with that line
item.

If a plan view showing the floor that the
object is on is open, that view will become

active and the object will be selected. If no
such view is open, a new unsaved view
showing the object’s floor will be created.
See “View Windows” on page 69.

If the selected item is a component of a
complex object like an Auto Dormer, Mulled
Unit, Bay Window, or Architectural Block,
the parent object will be selected in the plan
instead of the individual component.

Note: The Find Object in Plan tool is not avail-
able for objects that cannot be selected: for
example, wall framing objects and roofs.

If the selected row or rows in a Materials List
refer to objects on different floors, the
Details dialog will open when you click the

Find Object in Plan 3 edit button.

Materials List Display Options Dialog
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When a Materials List is open, select
—" Tools> Display Options to open the
Materials List Display Options dialog for
the current list.

™ Materials List Display Options *

Indude These Categories

Categories &
Decks-Walks (DW)

Doors (D)

Electrical (E)

Exterior Trim (EX)

Fixtures (FX)

Flooring (FL)

Foundation (FO)

Framing (F)

Furniture (FU)

% Genealah)

Cancel Help




The Categories listed here appear in the ID
column of the Materials List in the order they
are presented here.

* Check the box beside the name of each
category that you want to display in the
currently active Materials List.

Editing Materials Lists

» Multiple rows can be selected together
using Shift and Ctrl keys. See “Shift and
Ctrl Select” on page 96.

Note: The information in a suppressed category
is still part of the Materials List. If the Materials
List is exported, suppressed categories are
exported, as well.

Editing Materials Lists

Materials lists can be edited in a variety of
ways. You can adjust the width of a column
by clicking and dragging the bar on the right
side of the column name.

Adding Information

You can enter information in the Price and
Comment column for each line item.

Adding price or other information for any
item is straightforward. Simply click in the
cell and type the desired information.

Changing Information

You can change the information in any
column in an individual Materials List. As
with added information, click in a cell to
select the existing text, then type in the
desired text.

To move an item in a Materials List to a new
category, select the cell in the ID column and
choose a new category from the drop-down
list that becomes available. See “Categories”
on page 439.

Tool Tips

Whenever you mouse over a cell in the
Count column, a Tool Tip will display,

providing information about the cell’s
contents. When the Count is a total length,
area, or volume, it may be rounded. The Tool
Tip will show the value with greater
accuracy.

Total Cost

Total Cost for a line item is calculated using
the Count, Unit, Price, %Markup, Labor and
Equipment columns to calculate the cost.
The formula used is:

(Count + Extra) * Price * (1 + (%
Markup/100)) + ((Count + Extra) * Labor)
+ ((Count + Extra) * Equipment)

If a column does not appear, 0 is used for the
value of that column with the exception of
Count and Price, which are always used in
the calculation even if they are not shown.

Copying Information

Portions of a Materials List can be copied

and then pasted into a Text I object or into
a word processing program or spreadsheet
program using the standard Windows Copy
(Ctrl + C), Cut (Ctrl + X), and Paste

(Ctrl + V) commands. See “Copying and
Pasting Text” on page 203.
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Printing and Exporting the Materials List

Eil To print a Materials List, select File>
= Print while the Materials List window
is active. See “Print View Dialog” on page

451.

+ | A Materials List can also be exported
MAT! into a tab delimited text (.txt) file that
can be opened directly by most spreadsheet
programs. In a Materials List window, select
File> Export Materials List.

The Write Materials Export File dialog will
open. This is a typical File Save dialog. See
“Exporting Files” on page 41.

Estimating Software

You can export a Materials List to a word
processor or spreadsheet program to arrange

it in your estimating format. You can also
export the Materials List to a number of
commercial estimating programs in whose
databases you can keep your current pricing
and generate reports based on this data.

Before purchasing an estimating software
program, be sure that the program supports
the direct import of Chief Architect Materials
Lists.

Any questions regarding estimating software
packages and how they interact with Home
Designer Interiors should be directed toward
the company providing the estimating
software. Home Designer Interiors is unable
to provide any technical support for third
party programs.

Conditioned Area Totals
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Conditioned Area is the space within a
building that is heated and/or air conditioned,
and a Thermal Envelope is a three
dimensional boundary built around the
Conditioned Space that separates it from the
unconditioned space around it. Thermal
Envelopes are composed of floor platforms,
ceiling platforms, walls, doors, and windows.

‘When a Materials List is created, Home
Designer Interiors calculates the total areas
of the components that make up a structure’s
Thermal Envelope and lists them in the
General category of the Materials List. See
“Categories” on page 439.

Doors are always categorized as doors rather
than as windows. This is the case even when

a door is specified as a Glass Door or when it
is part of a mulled unit.

Conditioned area totals can be entered into

third party programs such as REScheck to
determine whether the plan meets the energy
code in use in your area.

Home Designer Interiors does not check
plans for compliance with building or
energy codes.

/N

Conditioned Area

With the exception of Unspecified rooms,
rooms that are assigned an interior Room
Type are included in the Conditioned Area.
“Open Below” rooms are also included;



however, other hybrid Room Types as well
as exterior Room Types are not. See “Room
Types” on page 165.

Building Orientation

Walls, doors, and windows are categorized as
north-, south-, east-, or west-facing for the
purposes of conditioned area totals. The
definition of North in a plan is straight up on
screen in floor plan view.

« Ifawall is oriented at 45° or less to north
in a plan, it will be categorized as a
“North” wall. Any doors and windows in
this wall will also be categorized as
“North”.

* Similarly, walls, doors, and windows ori-
ented within 45° of south, east, or west

Conditioned Area Totals

will be classified as “South”, “East” or
“West”, respectively.

The orientation of a curved wall is based on
the direction of its chord.

The General Category

The General category of the Materials List
lists information about the Thermal Envelope
of the current plan. The total linear length of
each wall type used in the plan is also
calculated in the General category. Walls
with different heights are each listed
separately. See “Wall Type Definitions” on
page 154.
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Home Designer Interiors provides a variety
of printing options.

Home Designer Interiors also allows you to
save your drawings in .pdf file format that
can then be sent to a printing service.

Note: Screen captures are provided for
illustrative purposes only and are not an
endorsement of any products.

Chapter 33:

Printing

Chapter Contents
Introduction to Printing
The Printing Tools
Drawing Sheet Setup Dialog
Print Preview
Printing to Scale
Printing Across Multiple Pages
Printing to a PDF File
Print View Dialog
Print Image Dialog
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Home Designer Interiors offers printing
options to suit a variety of needs. It is helpful
to be familiar with these options and choose
the one that makes the most sense for the
project at hand.

Output Options

Printing a View - Floor plan view can be
printed to scale. See “The Printing Tools” on
page 447.

Printing an Image - Any view of your plan
can be printed as an unscaled image. See
“Print Image Dialog” on page 454.

Printing to PDF - Plans can be printed to a
.pdf file and printed remotely. See “Printing
to a PDF File” on page 451.

Terminology

Paper Size - The dimensions of the paper to
be printed on. Specifying a paper size that is
smaller than the scaled drawing allows large

drawings to be printed across multiple pages.

Drawing Scale - Drawings are often printed
to scale for accuracy. /4" =1"and | m=50m
are examples of common scales. You can
specify this scale in the Drawing Sheet
Setup dialog. See “Drawing Sheet Setup
Dialog” on page 447.

When a particular scale is not important,
drawings can also be sized to fill a particular
area. See “Printing to Scale” on page 450.

Printing Problems

If you encounter difficulties when trying to
print, see “Troubleshooting Common
Technical Issues” on page 462.

Printer Drivers

A printer driver is a program that allows a
printer to communicate with the rest of the
computer system. Drivers are usually created
by the printer manufacturer, are typically
updated regularly, and can usually be
downloaded free of charge from the
manufacturer’s web site.

In addition to interpreting between the
printer and the rest of the system, printer
drivers save default page size, orientation,
margin size, and other information that
Home Designer Interiors refers to unless you
specify otherwise. See “Print View Dialog”
on page 451.

If you experience printing problems,
consider installing updated drivers for your
printer. Visit your printer manufacturer’s web
site for more information.

& Options available with one driver may
not be available with another. Printers
supported in one operating system may not
be supported by the manufacturer in another.

Clearing Printer Information

Some information specific to individual
printers, such as available paper sizes, is
saved with each plan file. You can select
File> Print> Clear Printer Info to clear the
printer-specific information stored with the



Displaying Objects

You can control the display of objects
when printing directly from a view in

The Printing Tools

the Display Options dialog. See “Display
Options Dialog” on page 88.

Objects must be visible in order for them to
print; however, not all items that are visible
will print. See “Print Preview” on page 449.

The Printing Tools

Ii;il Select File> Print to view the Print
LT.  Tools submenu. These tools fall into
two categories.

Print Setup Tools

Drawing Sheet Setup - Opens the
Drawing Sheet Setup dialog. See
“Drawing Sheet Setup Dialog” on page 447.

Scale to Fit - Automatically selects a
scale that fits your plan to the printer
page. See “Printing to Scale” on page 450.

Center Sheet - Automatically centers
the drawing sheet on your drawing.
See “Center Sheet” on page 449.

D Print Preview - Shows on screen how
the current view will appear printed,

based on the current scale and other settings.
See “Print Preview” on page 449.

Print Tools

1| Print - Prints the current floor plan to
=1 aspecified scale. See “Print View Dia-
log” on page 451.

—7 | Print Image - Prints the current view
including images, textures, and
backdrop. Views printed with Print Image
are not scaled. See “Print Image Dialog” on
page 454.

Clear Printer Info - Clears the printer
information associated with the current page
setup.

Drawing Sheet Setup Dialog

Select File> Print> Drawing Sheet
Setup to open the Drawing Sheet
Setup dialog.

The Drawing Sheet Setup dialog is only
available when floor plan view is active.
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When a perspective view is active, Drawing
Sheet Setup is not available.
The settings in this dialog are specific to the

current view and are saved with the .plan
file..

Drawing Sheet Setu
g p

Drawing Sheet

Size: ARCHC (18" x 247

Drawing Scale

14

Printer:

Drawing Margins

Qrientation: O Portrait @ Landscape

[] show Drawing Sheet in View

Remember Print Settings after Printing
Last Printer Used: None

Top: 318"
Left: 318"
Right: 318"
Bottom: 318"
Cancel Help

*

0 Specify the Orientation and Size of the
Drawing Sheet, which is the final
printed output.

Check Show Drawing Sheet in View to turn
on the display of the Drawing Sheet in
orthographic views. See “Drawing Sheet” on

page 449.

6 Specify the Drawing Scale for the
active view. This scale is applied only

when the view is printed.

The scale is specified in two parts, which by
default are Y4 inch =1 ft or I m = 50 m. Both
imperial and metric units of measurement are
available and can be selected independently.

* Uncheck Remember Print Settings
after Printing to use the default settings
every time a Print dialog is opened.
When checked, the program remembers
your settings for each type of view. This
setting is global, affecting all plan files.

e Specify the Drawing Margins. which

define the extents of the printable area
of the active view’s Drawing Sheet.

» Specify the width of the Top, Bottom,
Left, and Right margins.

Clearing Printer Information

Select File> Print> Clear Printer Info to
clear the printer-specific information stored
in the Drawing Sheet Setup dialog.



Print Preview

Print Preview

D Print Preview and its related display
toggles allow you to get a sense of
what the current view will look like when it

is printed.

Print Preview

D Select File> Print> Print Preview for
an on-screen representation of how
the current view will appear when printed.
Print Preview is only available in floor plan
view. See “Printing to Scale” on page 450.

The printer page displays as a solid white
rectangle, and blue lines along the edges of
the printer page indicate the edges of the
printable area, as defined by the currently
selected printer. See “Drawing Sheet Setup
Dialog” on page 447.

Objects such as camera symbols, and the
Reference Grid that do not print do not

display in Print Preview [l . Text and
dimension objects appear on-screen as they
will on the printed page.

When Print Preview [ is enabled, color
will display depending on whether Print in
Color is selected in the Print View dialog.
See “Print View Dialog” on page 451.

The Reference Display does print if it is
visible. See “Reference Floor Display” on
page 293.

Color

The Color toggle turns the on-screen display
of color on or off in all views.

Reference Grid

The Reference Grid is an on-screen grid
composed of regular squares that can be used
to convey a sense of scale while drawing. It
does not print, and its size can be specified in
the General Plan Defaults dialog. See
“General Plan Defaults Dialog” on page 56.

Drawing Sheet

The Drawing Sheet is a representation of the
size and orientation of the final printed
output. It is different from the printed page
size, which means that you can print a large
Sheet to multiple smaller pages.

The Drawing Sheet size and orientation are
specified in the Drawing Sheet Setup
dialog. See “Drawing Sheet Setup Dialog”
on page 447.

When the Drawing Sheet is set to display, a
blue border representing the margins of the
printable area will also display for reference.

Center Sheet

Select File> Print> Center Sheet to

center the printer page on the drawing.
This moves the printer page relative to the
drawing but does not affect the coordinates
of objects in the drawing. The location of the
printer page is independent for each floor of
the model.
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Printing to Scale

Several different print scaling options are
available. The type of view that you are
printing determines which options you may
choose from.

Floor plan views can be printed to scale.

The scale set in the Page Setup dialog is
inherited by the Print dialog. This scale can
be overridden on an individual basis in the
Print dialog. See “Print View Dialog” on
page 451.

Select File> Print> Scale to Fit =1 to select
a suitable scale and re-center the printer page
so that everything fits on the page.

Imperial drawing scales are typically noted
in inches per foot. Larger scales, such as 1

inch = 50 feet or 1:200m, are often used for
property layouts.

Perspective Views

Camera views and overviews display the
model much the way the eye would see it and
cannot be scaled.

* Objects in the view may be at any angle
relative to your line of sight.

* Objects seem to decrease in size as their
distances from the viewer increase.

Perspective views can only be printed using

the Print Image %= tool. See “Print Image
Dialog” on page 454.

Printing Across Multiple Pages

450

When printing directly from a floor plan
view it is possible to print at a scale that does
not fit the drawing on one page.

To see on-screen what the drawing will look
like when printed, select File> Print> Print

Preview [ and then Window> Fill

Window [ 3. Grey lines across the drawing
sheet indicate where the page breaks will
occur. See “Print Preview” on page 449.

To print across multiple pages

1. Select File> Print> Print Preview [
to display the white rectangle represent-
ing the printer paper. See “Print Pre-
view” on page 449.

2. Click the Select Objects 1% button,
then click near an edge of the printer
paper rectangle to select it.

When selected, the printer paper is
highlighted in pale grey and a square
Move edit handle displays at its center.

3. Click and drag the Move edit handle to
position the printer paper so that the por-
tion of your drawing that you would like
to print on your first page is located
within the printable area of the page.

4. Select File> Print> Print & . In the
Print dialog, make sure To Scale is
selected, then click OK. See “Print View
Dialog” on page 451.



5. Select the printer paper rectangle and
move it so that the desired contents of
your second printed page are within the
printable area and print To Scale.

6. Continue moving the printer paper and
printing as needed.

Printing to a PDF File

When printing multiple pages, it is generally
a good idea to leave some overlap on the
edges of each page to make sure that
information near those edges is not left off
the printed pages by mistake.

Printing to a PDF File

Portable Document Format, or .pdf files, are
one of the most universally compatible and
efficient file formats and can be viewed and
printed on most computer platforms.

You can save any view as a .pdf file by
selecting “Chief Architect Save as PDF” as
the Destination printer Name in either the
Print View or Print Image dialog. See “Print
View Dialog” on page 451 and “Print Image
Dialog” on page 454.

If you have a .pdf writer installed on your
system, you can use it to create a .pdf file
instead. To print to .pdf, simply select it as
the Destination printer Name in the Print
View or Print Image dialog.

When you print to .pdf, you will be asked to
create a file name and choose a destination to
save it in the Save as PDF File dialog. For
more information, see “Saving, Exporting,
and Backing Up Files” on page 39.

» Specify the width of the Top, Bottom,
Left, and Right watermark margins.

Print View Dialog

1| To print from floor plan view and the

LT/ Materials List, select File> Print>
Print. The Print View or or Print Materials

List dialog opens. The settings that are
available will vary depending on which
version of the dialog is open.
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Note: 3D views can be printed using Print
Image.

™ Print View

Destination o
Name: | Chief Architect Save ASPDF |
-

- 2}

Orientation: (_) Portrait (@) Landscape

Size: |aRCHB (12" x 187 -

Source: | Ny |

Print Source o

(® Drawing Sheet: ARCHE (12" x 187

O Current View

@ Fitto Paper

(O To Scale: 1/8in=1ft

Options o
o
[ print in Colar
Advanced Options o
Open System Print Dialog. ..
Preview o
= o1
Zoom: [ m || ouw || A |

[ Update Automatically Update

Drawing Scale o

ﬁ Drawing Scale is Fit to Paper. Printout may not be to salg

[aveaspoF..] | cancel || Heb |

Select the Name of the Printer that you
would like to use from the drop-down

list. To print to .pdf, select “Chief Architect
Save as PDF” from the list, or choose a .pdf
writer installed on your system. See
“Printing to a PDF File” on page 451.

Select the DPI, or Dots Per Inch to use
when printing, from the drop-down list.

The available options may vary depend-
ing on the selected printer.

e Select the Paper Orientation, Size,

and Source. The available Size and
Source options are controlled by the selected
printer’s driver.



*  When possible, the program will auto-
matically set the Size and Orientation to
match those of the Drawing Sheet.

* The Paper Size may be automatically
adjusted if the Drawing Scale option is
changed, below.

o Specify the Print Source. Not available
in the Print Materials List dialog.

* Select Drawing Sheet to print the entire
sheet even though you may be zoomed in
on a portion of the view.

* Select Current View to print only that
portion of the active view that is currently
visible on screen. If you are zoomed out,
any blank space outside of the printable
objects in the view is ignored.

o Specify the Drawing Scale of the
printed output. Changes to these
options may cause the Paper Size to change,
above. Not available in the Print Materials
List dialog or in camera views or overviews.

» Fit to Paper prints the view on one page.
The program uses whatever scale is nec-
essary to fit the plan on one page.

*  When Fit to Paper is selected, specify
the percentage of the paper to be used.
The default value is 95%.

Note: The Fit to Paper percentage value is
global - affecting all views in all files, and is
retained between sessions.

* Select To Scale to print at the scale speci-
fied in the Drawing Sheet Setup dialog.
See “Drawing Sheet Setup Dialog” on
page 447.

Print View Dialog

6 Options - Specify the number of Cop-
ies you would like to print.

6 Advanced Options - Click the Open
System Print Dialog button to close
the Print View dialog and print using your
operating system’s Print dialog instead. Not
available when No Printer is selected.

0 Control the appearance of the print job
Preview on the right side of the dialog.

» Specify the Page that displays in the Pre-
view area.

* Click the buttons to Zoom In, Zoom
Out, or Fit the selected Page to the
extents of the Preview area.

* Uncheck Update Automatically to turn
off the print job Preview and prevent it
from updating as changes are made to the
settings in this dialog.

* Click the Update button to update the
print job Preview to reflect the current
settings in this dialog. If Update Auto-
matically is unchecked, clicking Update
may force the Preview to be blank.

e When Update Automatically is

checked, a preview of the current print
job displays here. The drawing sheet displays
as a white rectangle, and if multiple sheets
are required, you can scroll through them. If
the print job is large, a progress dialog may
display briefly as the preview draws or
updates.

e To help prevent unwanted printed
output, information messages regarding

page size, resolution, and scale may display

here, depending on the settings in this dialog.
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Print Image Dialog
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~| Any view can be printed by selecting
= File> Print Image. This is the only
way to print 3D views. See “3D Rendering’
on page 401.

)

The Print Image dialog is similar to the Print
View dialog; however, the printing process is
different. Print Image prints individual
pixels as opposed to vectors (lines).

™ Print Image

Destination
MName: Chief Architect Save As PDF

DFI: 600 =

Paper
Qrientation: @ Portrait O Landscape
Letter (812" x 117)

Size:

Source:

Options

Copies:
Advanced Options

Open System Print Dialog...

Preview

Page - of 1

Zoom: In Cut

Update Automatically

-

Update

O X

o
@) Printer 0PI value is low: 72 DPL.

Save As POF...

Cancel Help

0 Select the Name of the Printer you
wish to use from the drop-down list. To
print to .pdf, select “Chief Architect Save as
PDF” from the list, or choose a .pdf writer
installed on your system. See “Printing to a

PDF File” on page 451.

9 Select the Paper Orientation, Size,
and Source. The available Size and

Source options are controlled by the selected

printer’s driver. See “Printer Drivers” on
page 446.

(3]

Specify the number of Copies you
would like to print.

0 Advanced Options - Click the Open
System Print Dialog button to close
the Print View dialog and print using your
operating system’s Print dialog instead. Not
available when No Printer is selected.

(5]

» Specify the Page that displays in the Pre-
view area.

Control the appearance of the print job
Preview on the right side of the dialog.

¢ Click the buttons to Zoom In, Zoom
Out, or Fit the selected Page to the
extents of the Preview area.



Uncheck Update Automatically to turn
off the print job Preview and prevent it
from updating as changes are made to the
settings in this dialog.

Click the Update button to update the
print job Preview to reflect the current
settings in this dialog. If Update Auto-
matically is unchecked, clicking Update
may force the Preview to be blank.

Print Image Dialog

0 When Update Automatically is

checked, a preview of the current print
job displays here. If the print job is large, a
progress dialog may display briefly as the
preview draws or updates.

0 To help prevent unwanted printed
output, information messages regarding

page size and resolution may display here,

depending on the settings in this dialog.
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Appendix A

Additional
Resources

Home Designer Interiors offers a variety of
resources to help you become familiar with
the many features it offers.

. Reference Manual
. User’s Guide

. Online Help Videos

. Home Designer Web Site

. Online Home Designer Samples Gallery
. HomeTalk Online User Forum

. Technical Support

Reference Manual

The Home Designer Interiors Reference
Manual is a comprehensive source of
information for Home Designer Interiors
2019. Chapters are organized by subject,
beginning with the fundamental concepts and
progressing to the more advanced features.

The Reference Manual is presented in .pdf
file format and includes a Table of Contents
and Index. This manual is available online by
selecting Help> View Reference

Manual i from the program menu.

User’s Guide

Written for new Home Designer Interiors
users, but a helpful reference for users of all
experience levels as well, the User’s Guide
features a series of tutorials designed to
introduce the basics of using the program.

The Home Designer Interiors User’s Guide is
organized by topic and walks you through
the process of creating a complete model,
from the first wall to the interior design and
landscaping.
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This guide is available online by selecting
Help> View User’s Guide from the program
menu.

Online Help Videos

Another resource designed to illustrate Home
Designer Interiors’s tools is the set of tutorial
videos available on our web site.

To view the online videos, select Help>
View Online Help Videos from the program
menu or visit
www.homedesigner.chiefarchitect.com/vid-
€0s.

Home Designer Web Site

If you have questions that the online Help
feature ha not answered, feel free to turn to
the our web site.

A database of common technical support
questions and answers related to Home

Designer Interiors is available through a
searchable interface.

Select Help> Visit Home Designer Web

Site @ from the menu to launch your
default internet browser to
HomeDesignerSoftware.com.

Online Home Designer Samples Gallery

% A collection of plan sets and
renderings is available for viewing
and download on our web site.

Select File> Download Sample Plans B8 to
launch your internet browser to
HomeDesignerSoftware.com

HomeTalk Online User Forum

The HomeTalk Bulletin Board offers several
ongoing discussions about a variety of topics
related to the use of Home Designer
Interiors. It's rich with useful tips and
available free of charge to all registered
Home Designer Interiors users.

« Discussions are initiated and carried out
by users.
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» Experienced users share knowledge with
each other and beginners.

*  Home Designer Interiors Staff members
post announcements, advice and techni-
cal information.

To visit the HomeTalk forum, select Help>
HomeTalk or go to


http://www.homedesignersoftware.com/videos/
http://www.homedesignersoftware.com/videos/
http://www.homedesignersoftware.com/
http://www.homedesignersoftware.com/samples.html

hometalk.chiefarchitect.com.

Technical Support

Technical Support

Chief Architect takes pride in offering world
class technical support services that can be
accessed by telephone or on our web site.
Select Help> Technical Support from the
program menu to visit
HomeDesignerSoftware.com.

Before contacting Technical Support, take a
moment to see if the answer to your question
is found in the Help resources, tutorial
videos, or in our online Knowledge Base at:
HomeDesignerSoftware.com.

When you contact us, Technical Support will
refer you to these resources if the answer can
be found there.

So that our Technical Support specialists can
assist you as efficiently as possible, please
refer to “Technical Support Services” on
page 461 for additional trouble-shooting
suggestions and information that will be
needed before placing your call.
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Appendix B

Technical Support

Chief Architect is committed to providing
world-class technical support to complement
our products.

The primary function of technical support is
to make sure our software is functioning

Services

correctly and to help you quickly resolve
problems that prevent its normal use. Our
technical support professionals are eager to
work with you to make certain our software
is functioning as designed.

Chief Architect offers a variety of reference
options in addition to the resources that come
standard with the program.

Online Knowledge Base

The Home Designer online Knowledge Base
contains a variety of articles describing how
to resolve common technical problems and
achieve specific design goals.

The Knowledge Base is found in the
Technical Support section of the Web site
and can be referred to again and again at your
convenience at

Reference and Training Resources

HomeDesignerSoftware.com .

Online Help Videos

Chief Architect has developed a collection of
training videos that contain in-depth training
on a wide range of topics. These videos are
available on our Web site,
HomeDesignerSoftware.com.

User Forum

Our HomeTalk User Forum is a great place
to discuss and exchange ideas with other
Home Designer Interiors users. Here you can
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post questions, read discussions from other
users, and post suggestions to improve our
product. In addition to our regular users,
from time to time our support and

engineering teams monitor the forum and
provide input and discussion on current
topics. This resource is available free of
charge at hometalk.chiefarchitect.com.

Chief Architect strives to make certain our
software works correctly; however, from
time to time issues arise that prevent its
normal operation.

Installation Issues

The following are common reasons for
installation failure of Home Designer
Interiors and other software:

* Anti-virus software is enabled and inter-
fering with installation. Anti-virus soft-
ware is the most common cause of
installation failures for any type of soft-
ware. Refer to your anti-virus software’s
documentation for details on how to dis-
able the software and re-enable it once
installation is complete.

¢ The recommended minimum system
requirements are not met. See “System
Requirements” on page 7.

* The computer has a CD drive but not a
DVD drive. A standard CD drive will not
read DVD discs.

Troubleshooting Common Technical Issues

» The DVD has fingerprints, scratches, or
other defects. Sometimes a small finger-
print can prevent the program from
installing. Clean the disk with soft cotton
cloth. Be sure to use soft cotton rather
than paper products on disks to avoid
scratching.

If you see visible cracking on a CD or

DVD, do not insert it in your CD/DVD
drive. Cracked disks can fly apart and cause
damage to your drive.

* You do not have sufficient rights to install
the software. Verify that you have admin-
istrative rights and the administrative
password during the installation process.
If you are on a corporate network, consult
your network administrator for assis-
tance.

Refer to the online Knowledge Base for
solutions to common installation problems.
If the answer to your question is not found
there, contact our Technical Support
department for assistance.

Printing problems fall into two main
categories: those that prevent the printer
from working in any program and problems

Troubleshooting Printing Problems

printing from Home Designer Interiors. To
determine if the problem is specific to Home
Designer Interiors, try the following:


http://hometalk.chiefarchitect.com/

1. Begin by clicking on the Windows Start
button, and select Printers.

2. Right-click the printer that is not func-
tioning properly in the Printers folder.

3. Click Properties from the menu that
appears.

4. On the General tab, click the Print Test
Page button.

If the printer does not produce a test page,

the problem is not one that Chief Architect
Technical Support can solve. Follow these

suggestions:

¢ Check the connection between the com-
puter and the printer.

*  Check your printer documentation for
troubleshooting printer problems.

* Contact your printer's manufacturer or
check their Web site for support informa-
tion.

Your printer manufacturer is the best
resource for solving problems of this type.
Chief Architect Technical Support is not able
to help diagnose and solve problems that
prevent printing from any program.

@ It is a good idea to keep the Owner’s
“€" Manual for your printer close at hand.
Write inside the Owner’s Manual the various
phone numbers for technical support for that
printer — for the original manufacturer and for
your local dealer.

Printers vary widely in how they function.
Sometimes a faulty cable can be a problem.
Often, solving a printing problem is as
simple as downloading and installing an
updated printer driver. See “Printer Drivers”
on page 446.

Troubleshooting Printing Problems

If you can print from Home Designer
Interiors but are not satisfied with the output,
refer to “Printing” on page 445 for
information on how to set up and use the
printing functions in the program. Legacy
users should bear in mind that each release
has new features and enhancements, so
techniques that were used in prior versions
may not work in the current version.

Make sure that you use Print Preview [
before printing. Print Preview displays the
printed paper, or drawing sheet, as a white
rectangle on screen, and shows how the sheet
is scaled and positioned relative to your
drawing. If the drawing is not on the drawing
sheet on-screen, it will not be on the sheet
when you print. See “Print Preview” on page
449.

Make sure that your scaling is correct for the
paper size. If the plan is much smaller or
much larger than the drawing sheet, you may
need to change your Scale. See “Printing to
Scale” on page 450.

64 Bit Windows

Some printers may not function correctly on
64 bit Windows operating systems. If you are
experiencing a printing problem while using
a 64 bit version of Windows, please contact

the printer’s manufacturer to verify that you
have the correct driver installed.

Clearing Printer Information

Some information specific to individual
printers, such as available printer paper sizes,
is saved with each plan file.

If you are encountering problems when
printing, or unexpected options in the Page
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Setup dialog, sclect File> Print> Clear
Printer Info to clear the printer-specific
information stored with the plan file.

After using Clear Printer Info, select File>

Print> Page Setup [L/|. Make sure the
settings in the Page Setup dialog are correct,

and then click OK and Save [ the file.

Online Knowledge Base

For answers to frequently asked questions
regarding printing and other topics, select
Help> Visit Home Designer Interiors Web

Site @ and browse the Technical Support
section of our Web site,
HomeDesignerSoftware.com.

Our Technical Support specialists post new
articles periodically to help resolve problems
that you may encounter.

Error Messages
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Most common error messages have a known
cause and simple resolution. When you
encounter an error or warning message in
Home Designer Interiors, you can click the
Check Knowledge Base button in the
message box to launch your default internet
browser to the Home Designer Knowledge
Base on our Web site,

HomeDesignerSoftware.com.

If an article discussing the message is
available it will display, providing
information about the message and how best
to avoid it.

It is important that abnormal errors be
reported to Chief Architect Technical
Support so that we can identify and resolve
any problems.

The content of an error message is useful in
diagnosing its cause. If you encounter an
error message, read it carefully and write
down the error number and the exact text of
the error message.

iy Press the Print Screen key on your key-
@ board to capture a picture of the error
message. Open a new word processing doc-
ument or e-mail message and choose Edit>
Paste to paste a copy of the error message
into the document for later reference.

If you encounter the error more than once,
make a note of your steps prior to receiving
the message.

Before you report an error, check the
Knowledge Base to see if the error is already
documented by typing the error message or
part of the error message into the search
form.

Finally, check to see if there are program
updates available. These updates are
provided free for the current version of
Home Designer Interiors and contain
enhancements and other changes that allow
the program to perform at an optimum level.
Select Help> Download Program Updates
from the Home Designer Interiors menu and
follow the instructions on our Web site,
HomeDesignerSoftware.com.
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Error Reporting

When an error occurs, you may have the
option in the message box to send the report
to Chief Architect.

Contacting Technical Support

No personal information is sent. When you
click Send, your default internet browser
launches and a Web page appears on screen
This message confirms that the report was
sent successfully and may give you further
instructions on how to proceed.

Contacting Technical Support

Before contacting Technical Support, take a
moment to see if the answer to your question
is found in the Reference Manual, Help
index, or in our online Knowledge Base.
When you contact us, Technical Support will
refer you to these resources if the answer can
be found there.

Chief Architect's technical support can be
reached at (208) 292-3375 or via our Web
site,

HomeDesignerSoftware.com.

There are several things you can do to ensure
a speedy answer to your question when you
contact Technical Support.

» Before contacting Technical Support,
select Help> About Home Designer
Interiors and make a note of the first
characters of your Product Key and the
exact version of Home Designer Interiors
you are using. Technical support is avail-
able to the owners of software licenses.
When you contact Technical Support, be
prepared to verify that you are the owner
of the software license.

* Before contacting Technical Support,
check to see if there are program updates
available for download. Our engineering
team periodically creates updates to the
program to resolve functionality or pro-
gram issues that were unknown at the

time of release. These updates are pro-
vided free of charge for the current
released version and can be accessed by
selecting Help> Download Program
Updates from the menu.

*  When you first encounter a problem or
error message, copy the exact wording of
the message or a detailed description of
the problem. This helps us isolate the
problem and provide you with a solution
as quickly as possible.

»  When placing a call to Technical Support,
be at the computer or work station that is
experiencing the problem and have Home
Designer Interiors running. If you do not
have access to the problem computer at
the time of the call, the technician may be
unable to reproduce the issue and/or sug-
gest a remedy that can be implemented
and verified immediately.

* Be prepared to reproduce the problem
when you contact us. If the problem can-
not be reproduced, there is a reduced
chance that we will be able to resolve the
problem on your first phone call.

Online Information

Home Designer Interiors has a variety of
support resources available on our Web site.
These include our Technical Support
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Knowledge Base, the How do I...?
Solution Finder, downloadable program
updates, and ways to contact our Technical
Support department. To access these
resources, Vvisit:
HomeDesignerSoftware.com .

Our support team is happy to assist you in
finding the best resource to answer your
questions, and can resolve most issues in just
a few minutes. In order to allow us to quickly
answer your calls, we ask that you limit
yourself to one question per support call.

Online Support

Questions can be answered online by the
Technical Support department. To submit a
technical inquiry online, visit the Technical

Support section of our Web site and use the _
Online Support Center .

This route ensures that your question is
delivered to the first available support
professional. Requesting assistance of an
individual specialist is not recommended,
since that person may not be available to
answer your question in a timely manner.

Telephone Support

Our Technical Support team is committed to
answering your questions as quickly as
possible and in the order received. Your call
is important to us; however, there are times
when we get more calls than expected and
you may have to wait a few minutes before
speaking to a technician.

Program Paths Dialog

466

Some technical issues can be caused by
problems with support files used by Home
Designer Interiors. In the event of such an
issue, Chief Architect Technical Support may
direct you to the Program Paths dialog. This
dialog displays a list of files utilized by the
software along with the pathname of each.

To avoid unintended problems that could
prevent you from using the software, it is
strongly recommended that you make no
changes to any of the files in this list except
with the direct assistance of Technical
Support.
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