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Chapter 1:

Program Overview

Home Designer Essentials is designed to 
help home enthusiasts visualize, develop and 
share their design ideas. Home Designer 
Essentials uses parametric design 
technology, which means that as you draw, a 
3D model is created and is updated as you 
make changes. You can tile a floor plan view 
next to a 3D view and watch one update 
automatically as you draw in the other.

Chapter Contents
•      Startup Options
•      The Home Designer Essentials 

Environment
•      Toolbars
•      Menus
•      Dialogs
•      The Status Bar
•      Message Boxes
•      Default Settings
•      Drawing a Plan
•      Viewing Your Plan
•      Getting Help
•      About Home Designer Essentials
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Startup Options
When Home Designer Essentials 
opens, the Startup Options dialog 

displays, allowing you to choose how you 
want to begin working in the program or 
access useful resources. 

The Startup Options dialog can be opened at 
any time by selecting File> Startup 

Options .

Getting Started- Click to launch your 
default internet browser to the Getting 

Started page on our web site,
 www.HomeDesignerSoftware.com. There, 
you will find links to a variety of online 
resources to help you begin using the 
program.

Select a File command to open a .plan 
file.

• Click New Plan  to open a new, blank 
plan. See “Creating a New Plan” on page 
31.

• Choose Open Plan to work on an 
existing plan file. See “Opening a Plan 
File” on page 35.

2

3 

4 

1

5 

1

2

http://www.homedesignersoftware.com/
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Recent Files lists the names of the most 
recently opened files. Click on a name 

to open the file.

Remove the check from Show Options 
on Startup if you do not want this 

dialog to display when you launch Home 
Designer Essentials. Instead, a new blank 
plan the Create New Plan dialog opens. 

To have the Startup Options dialog display 
at startup again, select File> Startup 

Options  and place a check mark at Show 
Options on Startup. 

The Build number of the program 
version you are using and the first five 

characters of your software license Product 
Key display here. 

The Home Designer Essentials Environment

Object-Based Design
Home Designer Essentials’s parametric, 
object-based design technology means you 
place and edit objects, rather than work with 
the many individual lines or surfaces used to 
represent them. 

You can quickly select and edit the location, 
size, shape, style and other properties of 
objects as well as change the materials 
applied to their surfaces. 

Use Home Designer Essentials’s editing 
capabilities to make the objects you place in 
a plan match the objects they represent in 
real life. For example, you can set up your 
windows and doors to match those available 
from your supplier. 

3D Drafting
In Home Designer Essentials, the entire 
drawing area is laid out on a Cartesian grid, a 
three dimensional coordinate system 
described using the X, Y and Z axes. The 
current position of your mouse pointer 
displays in the Status Bar at the bottom of the 
program window.

Architectural objects take up space in all 
three dimensions and their height, width and 
depth can be specified in Imperial or metric 
units. In addition, the location of objects can 
be precisely defined using coordinates, again 
specified in Imperial or metric units.

CAD objects such as lines and arcs take up 
space in two dimensions in the current view. 
Their dimensions can also be specified in 
Imperial or metric units and their locations 
precisely defined using coordinates.

Easy Access to Tools
You can access Home Designer Essentials’s 
features in various ways using the mouse and 
keyboard. 
• Menus provide access to most tools.
• Convenient toolbar buttons allow fast 

access to tools and let you customize the 
interface.

• Keyboard shortcuts are available for most 
tools.

• Contextual menus display with a right-
click of the mouse.

3

3 4 
3 5 
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• The Status Bar at the bottom of the screen 
provides tool descriptions and other 
information about the current task. 

Using the Mouse
Many objects, such as doors and cabinets, are 
created by clicking the left mouse button. 
Others, such as walls, stairs and dimension 
lines, are created by dragging the pointer 
from one end of the object to the other.

The left button is the primary 
button used in Home Designer 
Essentials. Unless specified 
otherwise, Home Designer 

Essentials documentation refers to the left 
mouse button.

The Right button has several uses. 
Right-click to select any object.

If, for example, the Straight Exterior 

Wall  tool is active, the left mouse button 
allows you to select only walls. You can 
select other object types such as cabinets 
with the right mouse button.

You can also use the right mouse button to 
open a context sensitive menu with 
additional editing commands.

The Middle button can be used to 
pan in floor plan view

You can also program it to work as a 
double-click.

Status Bar

Parent 
Tools

Menus

Library 
Browser

Edit  
Toolbar

Pointer Crosshair 
Lines

Selected 
Object

Temporary 
Dimension

Library 
Preview 
Panes

Title 
Bar

Note: If you are left-handed and have re-pro-
grammed your mouse, reverse the instruc-
tions for left and right buttons in this manual. 
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The Mouse Wheel can be used to 
zoom in and out in most views.

Using the Edit Handles
When you select an object, its edit handles 
display. 

When you pass the mouse over the edit 
handles, the pointer changes to show how 
you can use that handle. 
• A two-headed arrow indicates that the 

object, corner or edge can be moved in 
the direction of the arrows.  

• A four-headed arrow indicates that the 
selected object or edge may be moved in 
multiple directions. 

• A circular arrow indicates that the 
selected object can be rotated.

Resize handles display along the edges of the 
object are used to change the size. See 
“Resizing Objects” on page 80.

The Move handle at the object’s center lets 
you move the object. See “Moving Objects” 
on page 77.

The triangular Rotate handle lets you rotate 
the object. See “Rotating Objects” on page 
81.

You can cancel any edit handle operation 
before it is completed by pressing the Esc 
key on your keyboard or by pressing any two 
mouse buttons at the same time. 

The edit handles that display depend on the 
type of object selected, the current view, and 
how far you are zoomed out. 

Edit handles do not resize as you zoom in or 
out. If you are zoomed out far enough, some 
edit handles may be hidden so that they do 
not stack over one another.  As you zoom in, 
these handles become visible again.

Toolbars
Using the toolbar buttons is the fastest, 
easiest way to access many program features. 

The toolbars that display in a given view 
depend on the view type. For example, 
toolbars that control camera position display 
in 3D views but not in floor plan view.

When you pass the pointer over a toolbar 
button, a “tool tip” displays the name of the 

tool. When you see one of these tool tips, 
press F1 to get more information about that 
item. A more detailed description displays in 
the Status Bar at the bottom of the window.

You can use either of two styles of toolbar 
interface: drop-down tools or parent-child 
buttons.
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Drop-Down Tools
Click on the arrow to the right of a button to 
display a drop-down list of related tools. For 
example, click the arrow to the right of the 

Window  button to display a drop-down 
list of the other Window Tools.

The most recently selected tool displays in 
the toolbar.

Parent and Child Tools
An alternative to the Drop-Down toolbar 
interface are Parent and Child tools. Parent 
toolbar buttons have a blue triangle in the 
lower right corner. When you select a parent 
button, child tools display on the right side of 
the toolbar. 

When you click the Window Tools  
parent button, for example, its child buttons 
display to the right.

You can select either Parent - Child or Drop-
Down tools by selecting Tools> Toolbars> 
from the menu.

The Edit Toolbar
When you select an object, the edit toolbar 
appears. By default, it is located at the  of the 
program window. The toolbar buttons that 
display can be used to edit the selected 
object(s). Which buttons display depends on 
the type of object selected, the current view, 
and how you selected the object.

The edit toolbar buttons are the same as the 
options in the contextual menu when you 
right-click on an object.

Hotkeys
Many commands can be invoked from the 
keyboard.  Press Alt on your keyboard and 
press the underlined letter in a menu name to 
access that menu, as well as items in the 
menus and submenus. 

Other keys or key combinations will invoke a 
variety of program commands. If a Home 
Designer Essentials menu item has a 
keyboard shortcut, or hotkey, associated with 
it, that hotkey will display to the right of its 
name in the menu.

Menus
Home Designer Essentials uses a standard 
Windows menu format. The menus are 
located below the title bar in the program 
window and can be used to access nearly all 

tools in the program. Click on a menu name 
to expand it, then click on a menu item to 
either activate that tool or access the item’s 
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submenu. Items with a submenu have an 
arrow to the right of the name.

Menu items with an icon to their left have a 
toolbar button associated with them.

The menus can be accessed using the 
keyboard. Press the Alt key once to enable 
this functionality - one letter in each menu 
will become underlined. Press the key 
associated with one of these underlined 
letters to expand its menu - one letter in each 
menu item’s name will be underlined. Press 
the key associated with one of these letters to 
activate that tool or access the item’s 
submenu. Press the Esc key to undo your last 
selection, or click with the mouse to exit out 
of this functionality. 

Many tools in Home Designer Essentials also 
have hotkeys associated with them. If a menu 
item has a hotkey, it will display to the right 
of the item’s name. See “Hotkeys” on page 
46.

In the Home Designer Essentials 
documentation, menu paths are written in 
this format: Build> Window> Box 

Window . An icon image after the menu 
path indicates that a toolbar button is also 
available. 

Contextual Menus
Contextual menus are context sensitive 
menus that display tools relevant to a 
selected object or view.

To access contextual menus, right-click on an 
object, in an empty space in a view window 
or in a text field in any dialog box. 

Dialogs
Default settings, object specifications, 
display settings, and many other functions 
are accessed through dialog boxes. 

Dialog tabs and settings can be accessed 
using the mouse. You can also navigate the 
settings on a given dialog tab using the 
keyboard:
• Press the Tab key proceed from one set-

ting to the next, or Shift + Tab to go in the 
reverse direction. 

• Line items in tree lists can be browsed 
using the arrow keys. Up and Down navi-
gate the list, while Left and Right expand 
and contract categories.

• Settings with spin control arrows  can 
be adjusted by typing in the text field, 
using the up and down arrow keys, or the 
mouse scroll wheel.

• Settings with slider bars  can be 
adjusted by typing in the text field, using 
the left and right arrow keys, or the 
mouse scroll wheel.

• Press Enter on your keyboard to close 
any dialog and apply your changes.

Many dialogs have a preview that shows how 
the changes affect the object. This preview 

Edit menu items with button icons 
to the left and hotkeys to the right



24

Home Designer Essentials 2012 Reference Manual

updates when you click in a different field or 
press the Tab key on your keyboard. 

Some dialog boxes are resizable. Resizable 
dialogs have a size grip at the lower right 
corner of the box which you can click and 
drag. 

Specification Dialogs
Each object in Home Designer 
Essentials has a unique specification 

dialog where you can enter size, style and 
other information specific to the selected 
object. To access it, select the object and 
click the Open Object edit button. You can 
also double-click on an object with the Select 

Objects  tool active to open its 
specification dialog. See “Selecting Objects” 
on page 60.

The Status Bar
The Status Bar at the bottom of the main 
program window displays information about 
the current state of the program. 

This information depends on a variety of 
conditions such as the type of object 
selected, and the current position of the 
pointer. The information may include the 
following:
• A brief description of the toolbar button 

or menu item highlighted by the mouse.

• A description of the selected object.
• The total number of objects currently 

group-selected.
• Basic information about a selected library 

object, folder, or catalog.
• The current floor.
• The screen redraw time.
• The length and/or angle of an object as it 

is being drawn.

Message Boxes
As you work in Home Designer Essentials, 
the program will alert you if you command it 
to do something that could potentially cause 
a problem, or if the program encounters a 
problem that needs your attention. 

Situations where such message boxes may 
display include: 
• Closing a file without saving;
• A file referenced outside the program, 

such as an image or texture, is missing;
• Creating an object in a space too small to 

contain it.

You can access the settings in a message box 
using the mouse, or navigate them using the 
keyboard: 
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• Press the Tab key proceed from one set-
ting to the next, or Shift + Tab to go in the 
reverse direction. 

• When a checkbox is the active setting, 
press the Spacebar to check or to clear it.

• Buttons have hotkeys associated with 
them. Press the Alt key on the keyboard 
to underline the hotkeys in the current 
message box.

• Press Enter on your keyboard to close the 
message box and perform the action asso-
ciated with the highlighted button.

Some message boxes include a “Remember 
my choice” or a “Do not show this again” 
checkbox. Check this box to prevent 
messages of this specific type from 
displaying in the future.

To allow all message boxes to display again, 
select Help> Reset Message Boxes. 

Default Settings
Default settings control many aspects of the 
user interface and tool behavior in Home 
Designer Essentials. You can use these 
settings to customize the program to suit 
your personal work style.

For more information about defaults, see 
“Default Settings” on page 41.

Defaults
Most objects in Home Designer Essentials 
derive their intial properties from their 
respective default dialogs. 

For example, a newly placed Window  
gets its initial values from the Window 
Defaults dialog and a newly placed Hinged 

Door  gets its initial values from the Door 
Defaults dialog. 

Once an object is placed in a plan, its initial 
properties can be overridden, but setting up 

your defaults before you begin drawing can 
save you considerable time as you build a 
model in the program.

Dynamic Defaults
Dynamic defaults are values that affect 
existing objects in a plan. 

In specification dialogs, dynamic default 
values have a Default checkbox beside them 
or a [D] in their text fields. As long as this 
checkbox is checked or the [D] is present, 
changes made to the default affect the object. 

To edit an individual object, you must delete 
the [D] or uncheck the box in the 
specification dialog. Objects you edit in this 
way do not update if you change the default.

To restore a value to the default, click to 
place a check in the Default checkbox or 
type a “d” into an edit box.
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Drawing a Plan
When you draw a plan in Home Designer 
Essentials, you are placing 3D objects that 
represent building components. Home 
Designer Essentials comes with predefined 
default settings so you can start drawing 
plans immediately. You should review these 
default settings to be sure they match your 
drawing and building methods. See “Default 
Settings” on page 41.

Set the Defaults
Set material defaults for roof, walls, and 
rooms.

Set style defaults for doors, windows, mold-
ing, cabinets and other objects.

Draw the Floors

1. While the size of the drawing area in 
Home Designer Essentials is limited 
only by the resources on  your computer, 
it is best to begin your drawing near the 
origin, 0,0,0. See “3D Drafting” on page 
19.

2. Draw the exterior walls on Floor 1. See 
“Drawing Walls” on page 92.

3. Adjust the perimeter shape and size as 
required. See “Using the Edit Handles” 
on page 96.

4. Place any first floor bearing walls. 
5. Define types for special rooms such as 

garages and decks in the plan. See 
“Room Types” on page 113. 

6. Place perimeter doors and windows. See 
“Doors” on page 127 and “Windows” on 
page 143.

7. Build additional floors. See “Adding 
Floors” on page 161.

8. Specify the default ceiling height for 
each floor as soon as it is created. See 
“Floor Defaults Dialog” on page 160.

9. Adjust the perimeter shape of additional 
floors as needed. See “Editing Walls” on 
page 96.

10. Align edited or moved walls with those 
above or below where appropriate. See 
“Aligning Walls” on page 98.

Entering Dimensions
When using Imperial units, enter distances as 
inches or feet and inches, in fractional or 
decimal form. Millimeters are the default 
unit for all metric distances. See “Dimen-
sions” on page 323.
• To enter feet, include the ( ' ) marker or 

the program assumes inches.
• In most cases, the program allows 

precision to 1/16th of an inch. Fractions 
with denominators 2, 4, 8 and 16 are 
allowed.

• The program usually converts decimals 
to fractions.

Build the Foundation

1. Derive the foundation plan from the first 
floor. See “Building a Foundation” on 
page 168.

2. Adjust the foundation perimeter shape 
as needed.

3. Place interior foundation walls as 
needed for the first floor bearing walls.
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4. Place any other foundation walls 
required.

5. Align with Above as needed. See 
“Aligning Walls” on page 98.

Add Structure and Details

1. Build non-structural interior walls. 
Begin on floor one and work up in mul-
tiple story structures. 

2. Add walls where needed to create fea-
tures such as chimney chases, plumbing 
walls, or Open Below areas.

3. Finish the relevant interior structure 
including interior doors, doorways, cabi-
nets, fixtures, and fireplaces.

4. Build the terrain and landscaping. See 
“Terrain” on page 237.

Viewing Your Plan
You can see your model in a variety of 
different 2D and 3D views. You can display 
more than one view at a time and in any 
view, you can pan or zoom in or out. See 
“Zoom & View Tools” on page 291. 
Floor plan view is a 2D view of the model and 
is most commonly used for drawing and 
editing. In floor plan view, each floor displays 
separately and you can only edit one floor at a 
time; however, you have extensive control 
over which objects display at any given time, 
can easily switch between floors, and can also 
display items on a second floor for reference. 
You can create interior and exterior 3D views 
of your model from any perspective. As in 
floor plan view, you can select and edit many 

objects in 3D views and can control which 
objects are visible. See “3D Views” on page 
299.
You can also create Doll House Views that 
show only the current floor. Ceilings are 
omitted so you can see the interior, visualize 
the relationships between spaces, and plan 
traffic flow.
Framing Overviews display framing in 3D. 
You can customize 3D views to serve special 
purposes such as this.

All views can be exported as a graphic 
image. See “To export a picture” on page 
356.

Getting Help
There are many forms of help 
available in Home Designer Essentials 

including: Tool Tips, the Status Bar, and the 
online Help menu. 

All these forms of help assume you have a 
basic working knowledge of the Windows 
operating system, including how to use a 

mouse, open, close and save files, copy, 
paste, and right-click to access contextual 
menus. Help also assumes you are familiar 
with Windows terms.

More information is available in the product 
documentation in electronic format and on 
Home Designer’s official web site,  
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www.HomeDesignerSoftware.com. See 
“Additional Resources” on page 379.

Tool Tips
When you move the pointer over a toolbar 
button or menu item, a Tool Tipdisplays, 
offering a brief description of the tool. More 
information displays in the Status Bar at the 
bottom of the window.

Online Help Menu
Online Help is a searchable menu that 
provides information about all of the tools in 
Home Designer Essentials. Select Help> 

Contents & Index  to open the online 
Help and explore the table of contents, 
browse the Index, or search for keywords.

Current Mode Help
Online Help can also be used to provide 
instant information about toolbar buttons, 
menu items, and objects in your plan.
• When you move the cursor over a toolbar 

button or menu item, a brief summary of 
that tool displays in the Status Bar.  Press 
the F1 key to open online Help to a page 
with more information about the tool.

• When an object is selected, edit handles 
display. Place the cursor over an edit han-
dle and press F1 to open online Help to a 
page with information about that handle. 

• Press the Help button in any dialog box 
to open online Help to a page describing 
the options in that dialog. 

About Home Designer Essentials
Select Help> About Home Designer 
Essentials to view information about your 
software license, the program’s version 
number, and its release date.

Contact information for Chief Architect, Inc. 
is available on the More Information tab.

Upgrade to Chief Architect
Select Help> Upgrade to Chief Architect to 
launch your default web browser to the Chief 
Architect web page, www.chiefarchi-
tect.com, where you can learn about this 
powerful home design software for building 
professionals.

Chief Architect can open plans originally 
created in Home Designer, and offers an 
extensive set of drawing, editing and 
rendering tools that allows you to produce 
complete, professional working drawings.

Chief Architect strives to make our docu-
mentation as helpful as possible for all of
our customers. Please send any questions,
comments, or feedback to 
documentation@chiefarchitect.com.

http://www.homedesignersoftware.com/
http://www.chiefarchitect.com/
http://www.chiefarchitect.com/
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Chapter 2:

File Management

Home Designer Essentials saves the 
complete 3D model of a structure and 
surrounding terrain as well as text in .plan 
files.

All commands related to opening, saving and 
closing plans are located in the File menu. 
You can also open plans from the Startup 
Options dialog. See “Startup Options” on 
page 18.

Just as with files created in other software 
applications, you should back up your plan 
files externally on a regular basis to avoid 
accidental loss of work.

Chapter Contents
•      Compatibility with Other Programs
•      Organizing Your Files
•      Home Designer Essentials Data
•      Creating a New Plan
•      Saving a Plan File
•      Auto Archive
•      Undo Files
•      Opening a Plan File
•      Searching for Plans
•      Closing Views and Files
•      Exiting Home Designer Essentials



30

Home Designer Essentials 2012 Reference Manual

Compatibility with Other Programs
Plans produced in the following programs 
can all be read by Home Designer Essentials 
2012. 

• Chief Architect® 5.0 through 10.08 (read 
only)

• Chief Architect® X1, X2 and X3 (limited 
editability if enabled)

• 3D Home Architect® 3.0 and 4.0

• Chief Architect® Home Edition 5.0
• All Better Homes and Gardens Home 

Designer® products, Interior Designer, 
and Landscaping and Deck Designer, Ver-
sions 6 through 8.

• All Chief Architect Home Designer® 
products, Interior Designer, and Land-
scaping and Deck Designer, Version 9.

• Trading Spaces® Design Companion™

Files that have been opened and saved in 
Home Designer Essentials 2012 cannot be 
read by the programs listed above. To 
continue to read files in the program in which 
they were created, be sure to create copies of 
your files before opening them in Home 
Designer Essentials 2012. 

Plans created in Chief Architect, build 11.4 
and later, can be opened in Home Designer 
programs for viewing and annotating only. 
Limited editability in Home Designer 
programs is an option that can be enabled 
when the file is opened in Chief Architect.

Organizing Your Files
You should keep your plan files separate 
from the support files needed to run Home 
Designer Essentials. To keep files organized, 
you may find it helpful to create a new folder 
for each project.

Home Designer Essentials files may use 
imported images, textures and other custom 
content saved in their own external data files. 
Consider storing copies of all external files in 
the same folder as the plan files that use them 
so that they are easily found. 

Here is one way to organize your files:

• Create a folder in  your Documents direc-
tory  (“My Documents” in Windows XP) 
called  “Home Designer Essentials Plans” 
or another name you prefer. See Microsoft 
Windows Help to learn how to create 
folders.

• Inside this folder, make a new folder for 
each project. Save all the files for that 
project inside this folder, including plan 
files and referenced external files. See 
“Saving a Plan File” on page 32.

Bear in mind, though, that path names 
exceeding 260 characters cannot be opened 
by Home Designer Essentials. As a result, it 

Note: 3D Home Architect 5.0 was not devel-
oped by Chief Architect, Inc. Plans written
using 3D Home Architect 5.0 or later cannot
be read by Home Designer Essentials.
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is a good idea to limit the number of 
embedded folders you use in your file 
organization method.

Once you understand the file management of 
Home Designer Essentials, you can decide 
on a naming convention that suits your 
needs. 

Home Designer Essentials Data
When Home Designer Essentials 2012 is 
installed, the program automatically creates a 
folder in the user Documents directory called 
Home Designer Essentials 2012 Data. This 
folder contains important user-specific 
information saved in the following folders 
and files and should not be moved, renamed 
or deleted: 
• Archives - A folder of automatically 

archived plan files. See “Auto Archive” 
on page 34. 

• Backdrops - A folder of custom back-
drop images. See “3D Backdrops” on 
page 306.

• Images - A folder of custom images. See 
“Adding Materials and Images” on page 
271.

• Database Libraries - A folder of user 
library data. See “Library Content” on 
page 270.

• Scripts - A folder for custom Ruby 
scripts associated with Chief Architect 
plans.

• Templates - A folder of plan template 
files. See “Creating a New Plan” on page 
31.

• Textures - A folder of texture files, 
including textures referenced by installed 
template files, that can be used to create 
custom materials. See “Creating Materi-
als” on page 286. 

• Toolbars - A folder of toolbar files. See 
“Toolbar Arrangement” on page 46. 

Because the Home Designer Essentials 2012 
Data contains custom user data, it is not 
deleted when the program is uninstalled. See 
“Uninstalling Home Designer Essentials” on 
page 20 of the User’s Guide.

Creating a New Plan
To open the Create New Plan dialog, 
select File> New Plan. 

You can also choose New Plan in the 
Startup Options dialog. See “Startup 
Options” on page 18.

If the Home Designer Essentials 2012
Data folder is renamed, moved or

deleted, the program will automatically
replace it using default information from the
Home Designer Essentials installation
folder.  When this occurs, customized user
settings and custom user library content will
not be available.
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Template Plans
When you select File> New Plan in 
Home Designer Essentials, the Create 

New Plan dialog opens, letting you select a 
template for your new plan. The resulting 

new plan uses either metric or Imperial units 
of measurement and predefined default 
settings, layer settings, wall definitions, and 
page setup information. 

Home Designer Essentials includes a 
selection of plan templates, each with 
different default settings that allow you to 
begin working in a particular plan style 
quickly. See “Default Settings” on page 42.

Select a style template from the scrollable 
list. If you are uncertain as to the right style 
for your plan, choose Default, as you cannot 

change the plan style template once a plan 
has been created.

Select either U.S. Units or Metric Units of 
measurement, and click OK. The floor plan 
view window opens, ready for you to begin 
drawing.

New, blank plans are called  Untitled.plan. 
Unless these files are named and saved, they 
will be lost when closed. 

Saving a Plan File
When you first save a new, 
untitled file, you must select a 
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location for it on your computer and give it a 
name. There are two options for saving plan 
files: File> Save and File> Save As.

Both Save  and Save As  can be used 
to save your plan files; however, they 
accomplish this in two different ways.

• File> Save  saves the current state of 
your plan file without changing its name 
and should normally be used for saving 
your work.

• File> Save As  opens the Save Plan 
File dialog, allowing you to save the plan 
file using a different name or location on 
your computer. 

To save an untitled plan file

1. Select File> Save  to open the Save 
Plan File dialog.

2. In the Save in drop-down, browse to the 
location on your computer where you 
would like to save the file. See “Orga-
nizing Your Files” on page 30.

3. In the File name text field, type a name 
for the file. 

4. Home Designer Essentials automatically 
assigns the File of type and file exten-
sion .plan.

5. When both the Save in location and File 
name are correct, click Save. 

Initially, all Open  and Save As  
operations go to the “My Documents” folder 
of your computer. After that, the location last 
visited is remembered and subsequent 

Open  or Save As  commands default 
to the directory last used for that operation. 
This path is saved when the program exits. 
The next time Home Designer Essentials is 
launched, these defaults are used.

Exporting Files
Home Designer Essentials has a number of 
options for exporting and importing 
information out of and your drawings. Often, 
file export dialogs are nearly identical to the 
Save Plan File dialog. See “Pictures, 
Images, & Walkthroughs” on page 351. 

Similarly, file import dialogs are often 
similar to the Open Plan File dialog. See 
“Importing Files” on page 36. 

Backing Up Your Files
It is always a good idea to create backup 
copies of all your important files on your 
computer.

It is strongly recommended, however, that 
you never save directly onto removable 
media such as a USB thumb drive, CD, or 
DVD. Instead, copy your files to such 
locations in Windows Explorer only after 

Although the program warns you if you
try to exit without saving, you should get

in the habit of saving plan files before exiting
the program.
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you have saved them on your computer’s 
hard drive and exited the program.

Archive folders are used by Home Designer 
Essentials to manage prior versions of your 
files. You should not view these files as a 
substitute for your own backup routine, and 
should never save a file in an archive folder. 
See “Auto Archive” on page 34.

When backing up your Home Designer 
Essentials files, consider backing up not only 

your .plan files, but your custom user data, 
as well - including library content, toolbar 
configurations, and textures. This custom 
data is all located in the Home Designer 
Essentials Data folder, so it can be easily 
backed up. See “Home Designer Essentials 
Data” on page 31.

You can, if you wish, create a folder inside 
the Data folder for your .plan files, as well. 
See “Organizing Your Files” on page 30.

Auto Archive
The first time a plan is saved, Home 
Designer Essentials creates an Archive folder 
in the Home Designer Essentials Data folder. 
The Archive folder contains Auto Save and 
Archive files. 

The program does not create Auto Save and 
Archive files for untitled plans. In order for 
these to be created, a file must have been 
previously saved and given a name and save 
location on your computer.

Auto Save and Archive files should not be 
viewed as a substitute for regularly saving 

your work by selecting File> Save  or 
pressing Ctrl + S on the keyboard, nor should 
they be considered an alternative to your own 
file backup routine.

Archive Files
Every time a drawing is saved, Archive files 
that keep a historical archive of your plan are 
automatically created. 

Plan files from previous versions of the 
program are automatically moved to the 

archive folder when the plan is opened and 
saved in Home Designer Essentials.

Archive files are meant to be for emergency 
use only. If you must access an archive file, 
open it as you would any other file. See 
“Creating a New Plan” on page 31. As soon 

as the file is open, use Save As  to save 
this file to another location.

Auto Save Files
As you work, Home Designer Essentials 
automatically creates Auto Save files at 
regular intervals when changes are made to a 
file but not saved by selecting File> 

Save . 

These Auto Save files are appended 
_auto_save.plan and are saved in the 
Archive folder. 

When you close a file normally, its Auto 
Save file is retained until the next time the 
file is opened - at which time the Auto Save 
file is overwritten.
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Auto save files created as a result of an 
improper program shutdown are appended 
_auto_save_bak.plan.

If your computer shuts down accidentally, 
you can recover some of your work by 
opening the _auto_save_bak file.

When you reopen a file after a computer shut 
down or system crash, the following dialog 
displays if an Auto Save file newer than the 
original file is found. 

Even with Auto Save, you should save your 
work manually on a regular basis using any 
of the following methods: 

• Click the Save  button.

• Select File> Save .
• Press Ctrl + S on the keyboard.

Undo Files
Home Designer Essentials stores a set 
number of copies of all open plan file 
changes, known as undo files. Undo files are 
referenced whenever you select Edit> 

Undo  or Edit> Redo . See “Undo 
and Redo” on page 83.

Undo files are stored in the Windows 
Temporary Directory.  When you use 
Windows system cleanup features, these files 
can be deleted.  Because of this, you should 
only use these type of utilities when Home 
Designer Essentials is not running.

When Home Designer Essentials is closed 
normally, any current Undo files are deleted.

Opening a Plan File
Select File> Open Plan to open an 
existing .plan file located on your 

computer. Home Designer Essentials 
automatically browses to the directory last 
used.

A file is auto saved only if you have
saved it previously. Auto Save does not

work for unnamed files. 

Auto Save file after normal shut-down

Auto Save file after abnormal shut-down

Never open a file located on a server or
other computer on a network, or on a

removable storage device. Copy such files to
your local machine’s hard drive first, and then
open the copy.
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The Open Plan File dialog can be resized by 
clicking and dragging the lower right corner. 

• In the Look in drop-down, browse to the 
location on your computer where the file 
you wish to open is saved. 

• Any folders and .plan files in the current 
location display in the field below. The 
file type that displays depends on the 
Files of Type selection.

• Click on the file you wish to open. Its 
name will display in the File name text 
field. 

• The only file type available in the Files of 
type list is .plan. 

• When the desired file is selected, click 
Open. 

Plan files open to the floor that was active 
when the file was last saved and closed.  

Importing Files
Home Designer Essentials has a number of 
options for exporting and importing 
information out of and into your drawings. 
Often, file import dialogs are nearly identical 
to the Open Plan File dialog. See “Pictures, 
Images, & Walkthroughs” on page 351. 

Similarly, file export dialogs are often similar 
to the Save Plan File dialog. See “Exporting 
Files” on page 33. 

Recently Opened Files
The names of the plan files you most recently 
opened or saved display at the bottom of the 
File menu. Click on a recent file to open that 
file without using the Open Plan File dialog. 

The names of recently open files also display 
in the Startup Options dialog. Click on the 
name of a file to open it. See “Startup 
Options” on page 18.
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Searching for Plans
Select Tools> Plan Database> 
Search for Plans to locate an 

existing, fully-editable sample plan or search 
a selection of non-editable plans by popular 

home designers. This command opens the 
Find Plan Wizard, which helps you search 
for plans based on parameters that you 
define. 

Find Plan Wizard
The Find Plan Wizard can be used to search 
for plans using stored information about each 

plan, such as the square footage and the 
number of bedrooms and other room types. 

Begin by selecting either a database of 
editable sample plans or a collection of house 

plan drawings by popular home plan 
companies, then click Next to continue. 
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House Style

At the bottom of each page, the number of 
plans that match your current search 
parameters displays. As you modify the 
parameters, this number increases or 
decreases as matching plans are found.

On any page, click the Back button to 
modify any  previously selected parameters. 

Select the number of floors in the house and 
the number of bedrooms, then click Next to 
continue. 
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House Size

Select the number of bathrooms and square 
footage of the house, then click Next to 
continue. 
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Plan Details

Click on the name of a plan in the list to see a 
preview of the plan 

Click Next, then click the Finish button to 
open the selected plan. 

Closing Views and Files
Choose File> Close to close the active 
window. If it is the last open view for a plan 
and you have not saved it, the program  
prompts you to save before closing. 

Select File> Close All to close all currently 
open windows.

Exiting Home Designer Essentials
Select File> Exit to exit the program. If you 
have not saved any open plans, you are 
reminded to do so. It is better to save your 
work before exiting than to save on exit. 

When you exit from the program using File> 
Exit, all Autosave files and Undo files are 
automatically deleted. 

Although the program warns you if you
try to exit without saving, you should get

in the habit of saving plan files before exiting. 
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Chapter 3:

Default Settings

In Home Designer Essentials, default 
settings determine what objects look like 
when they are initially created.  You can save 
time by becoming familiar with the defaults 
in the program and setting them up before 
you start drawing in a new plan.

Chapter Contents
•      Default Settings
•      Dynamic Defaults
•      General Plan Defaults Dialog
•      Set Background Color
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Default Settings
Default settings determine the initial 
characteristics of objects when they 

are first drawn. For example, when you place 
a base cabinet in a plan, its size, materials, 
front items, hardware are determined by 
settings in the Base Cabinet Defaults 
dialog.

Defaults are file-specific, which means that 
any changes that you make to the default 
settings in one plan file will have no effect on 
other plans 

You can access a complete list of the various 
default settings by selecting Edit> Default 

Settings  from the menu while floor plan 
view is active.

• Default settings is also available in other 
view windows; however, the items in the 
list may not include tools that cannot be 
used in the current view. 

• Click the + beside a category to expand it 
and access the defaults for items related to 
that category.

• To open the defaults dialog associated 
with an item in the list, double-click on 
the line item, or click on the item and then 
click the Edit button.

Dynamic Defaults
Dynamic defaults are values that can be 
changed globally throughout a model. 
• If you change a dynamic default value in 

a defaults dialog, all objects of that type 

that are set to use the default will update 
automatically to use the new value.

• Any objects of that type that are not using 
the default value because of editing will 
not be affected if you change the default. 
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Dynamic defaults are found in the default 
dialogs of a variety of objects, including 
dimension lines, walls, doors, cabinets and 
rooms.

Materials are another example of an attribute 
that uses Dynamic Defaults. See “Material 
Defaults” on page 289.

In object specification dialogs, dynamic 
defaults are followed by either a (D) in the 
value field or a Default check box.

To edit a dynamic default, delete the (D) or 
remove the check from Default box and type 
the desired value. 

To reset a value back to the dynamic default, 
type the letter D in the field or click the 
Default checkbox.

General Plan Defaults Dialog
The settings in the General Plan Defaults 
dialog control basic features of the Home 
Designer Essentials environment. To open 
this dialog, select Edit> Default Settings 

, select Plan, and click the Edit button.

• Check Fixtures and Furniture May be 
Resized to display side edit handles on 
selected fixtures and furniture so you can 

resize them. Clear this option to display 
only Move and Rotate edit handles. See 
“Editing Box-Based Objects” on page 72.

Changes made to fixture/furniture sizes 
are not reflected in the Materials List 
because the Materials List refers to 
objects by their labels, not by their physi-
cal dimensions. If you resize a fixture or 
furniture object, the correlation between 
its label and its actual physical dimen-
sions is no longer accurate. 

• Casing is the trim that surrounds a door or 
window. When you resize a door or win-
dow, its sides are kept away from inter-
secting walls by the width of the casing. 
Check Window/Door Casing Ignored 
When Resizing to ignore the casing so 
that doors and windows can be moved or 
resized flush against an intersecting wall.
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• Inches Scrolled by Hotkeys determines 
how far your plan will scroll when you 
press an arrow key. The initial default is 
12 inches (300 mm).

• Check Use Snap Grid/Units to enable 
Grid Snaps, which snaps objects to a grid 

as you draw or edit them. See “Grid 
Snaps” on page 53.

• Specify the Snap Unit: the increments at 
which you want snapping to occur. The 
initial default is 1 inch (10 mm).

Set Background Color
Select Tools> Display Settings> Set 
Background Color to open the Set 
Background Color dialog.

Click the color bar to open the Color 
Chooser dialog and select a color to use as 
the background color in floor plan and Cross 
Section/Elevation views for the current plan. 
See “Color Chooser Dialog” on page 290.
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Chapter 4:

Toolbars &
Hotkeys

Two of the most efficient ways to access 
Home Designer Essentials’s tools are the 
toolbars and keyboard shortcuts, also 
referred to as hotkeys.

Toolbars are organized into configurations, 
which are basically collections of multiple 
toolbars arranged for use during specific 
drawing tasks.  Within a given toolbar 
configuration, buttons are arranged so that 
similar tools are located near one another. 

Chapter Contents
•      Toolbar Arrangement
•      Hotkeys
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Toolbar Arrangement
Toolbars can be viewed in Drop - Down or 
Parent - Child arrangement. Drop - Down 
toolbar buttons have an arrow to the right of 
the button that accesses additional, related 
tools. 

Alternatively, you can use Home Designer 
Essentials’s Parent - Child toolbar 
arrangement. In this arrangement, you select 
a “parent” button to display its “child” 
buttons to the right. 

To switch between these two toolbar 
arrangements, select Tools> Toolbars and 
click on either option in the submenu. 

Moving Toolbars
You can, if you wish, move any toolbar to a 
different location.  Toolbars can be docked to 
any side of the program window, or they can 
be undocked and left floating.  Undocked 
toolbars can also be moved outside of the 
program window. 

The location of moved toolbars is not saved 
between program sessions. The next time 
you use Home Designer Essentials, the 
toolbars will be back in their original 
locations.

Hotkeys
Many Home Designer Essentials tools have a 
keyboard shortcut, or hotkey, associated with 
them. If such a hotkey exists, it will display 
to the right of the tool’s name in the menu.

To use a hotkey, simply press the appropriate 
key or combination of keys on your keyboard 
instead of selecting the menu item or clicking 
the toolbar button. For example, press the 
Ctrl and Z keys at the same time to perform 

an Undo .

Edit menu items with button icons 
to the left and hotkeys to the right
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Chapter 5:

Layers

Layers are used to organize and manage the 
display of all objects in all views . A layer 
can be thought of as a transparency sheet 
with objects placed on it for viewing. Nearly 
all views use multiple layers, like a stack of 
transparencies put together to show different 
types of objects. 

You can customize how each layer displays 
in a particular view in the Display Options 
dialog. 

Multiple layers are organized into Layer 
Sets, which allow you to control which 
objects display in different views.

Chapter Contents
•      Displaying Objects
•      Layer Sets
•      Display Options Dialog
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Displaying Objects
The display of objects in different views is 
controlled by layer sets and layers in the 
Display Options dialog. See “Display 
Options Dialog” on page 49.

Primary and Secondary Layers
Every object is placed on a layer which 
controls whether it displays in a given view. 
This layer is referred to as the object’s 
primary layer. 

In addition, some objects have secondary 
layers which may alter the appearance of 
objects on the primary layer, but do not 
control whether the objects display or not. 

For example, the primary layer for base 
cabinets is “Cabinets, Base”. In addition, 
base cabinets have a number of secondary 
layers that control the display of the 
countertop, face indicators, door opening 
indicators, module lines and labels.

All layers with a check in the “Disp.” column 
display when the current layer set is active. 
Objects that are not displayed cannot be seen 

or selected. If you try to place or draw an 
object on a layer that is hidden, the program 
asks if you want to turn the layer on.

Some objects cannot stand alone in a 
drawing: they can only be inserted into 
another object. If the display of an object that 
contains an inserted object is turned off, the 
display of the inserted object will be turned 
off, as well  For example, if the display of a 
wall is turned off, any doors and windows in 
that wall will not display either. See 
“Inserted Objects” on page 275.

The Color attribute assigned to a layer 
determines how the lines representing 
objects on that layer appear in floor plan and 
Cross Section/Elevation views. 

Many objects, including terrain and text 
objects, allow you to override the line color 
without changing the layer’s color attribute.

Layer Sets
Layer Sets are used to control the layer 
settings for different views in a plan file. 

A layer set consists of a complete list of the 
layers in the current plan along with the 

display settings for each layer as set for a 
particular type of view. These display 
settings can be modified, and can be different 
for each type of view. See “Display Options 
Dialog” on page 49.

Note: If an object’s primary layer is turned off,
information on its secondary layers will not
display - even if those layers are turned on.
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Layer sets are file specific, which means that 
changes made in one plan file have no effect 
on the settings in other files. 

Home Designer Essentials uses a different 
layer set for the each type of view of your 
plan:
• Floor plan view.
• Camera views and Overviews. See “3D 

View Tools” on page 302.
• Cross Section/Elevations. See “Cross 

Section/Elevation Views” on page 304.
• Framing Overviews. See “Framing Over-

view” on page 304.
• Reference Display. See “The Reference 

Floor” on page 165.

• Print Model. See “Print Model” on page 
369.

While any view is active, select Tools> 

Display Settings> Display Options  to 
make changes to the layer set used for that 
view type. 

Any changes made to settings in the Display 
Options dialog for one particular view will 
affect all views using that same layer set. For 
example, if you make changes for a camera 
view, all camera views and overviews in the 
current plan will be affected. See “Display 
Options Dialog” on page 49. 

Unlike other layer sets, the Print Model layer 
set cannot be modified.

Display Options Dialog
The display of objects in all views is 
controlled in the Display Options 

dialog. To make changes to the display 
settings for a particular type of view, open a 
view of that type and select Tools> Display 
Settings> Display Options.

If the display of a particular layer is turned 
off and an object assigned to that layer is 
placed in the plan, the program will 

automatically ask you if the layer should be 
turned on so that the new object will be 
visible. After you make your choice, the 
object will be created - even if you select 
“No.”

Only displayed objects are included when 
EMF files are exported, and only displayed 
objects print.
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• Remove the check from the “Disp.” col-
umn to turn off the display of a category 
of objects in the current view. 

• Click a color bar to open the Color 
Chooser dialog and set the display color 
for objects on that layer in floor plan and 
Cross Section/Elevation views. See 
“Color Chooser Dialog” on page 290. 

• Click on a column header to sort all lay-
ers by that column. Click again to sort in 
reverse order.

• Click the size grip at the lower right cor-
ner and drag to resize the dialog box.

Note: Not all objects display in all views. For
instance, door labels do not appear in 3D
views.
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Chapter 6:

Creating Objects

There are a wide variety of objects in Home 
Designer Essentials that you can use to create 
3D models and plan drawings. Although 
these objects are sometimes very different 
from one another, the methods used to create 
them are similar. 

Once an object is created, it can be selected 
and edited to meet the requirements of your 
project. The editing characteristics common 
to most objects are described elsewhere. See 
“Editing Objects” on page 59. 

Chapter Contents
•      Architectural vs CAD Objects
•      Snap Behaviors
•      Angle Snaps
•      Grid Snaps
•      Creating Objects
•      Copying and Pasting Objects
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Architectural vs CAD Objects
There are two broad categories of objects in 
Home Designer Essentials: architectural 
objects and CAD objects. 

Text, text lines with arrows, and dimensions 
are 2D CAD objects that can be created and 
edited in floor plan view but do not display in 
3D camera views and overviews. See 
“Dimensions” on page 323 and “Text” on 
page 335. 

In contrast, architectural objects such as 
walls, cabinets, doors, windows, and stairs 
display in 2D and 3D views.

Some architectural objects, such as terrain 
features, have some behaviors in common 
with CAD objects and are referred to as 
CAD-based.

Snap Behaviors
There are three categories of snap behavior 
in Home Designer Essentials that affect how 
objects are created and how they can be 
edited: 
•      Object Snaps, which snap objects to 

other objects. 
•      Angle Snaps, which snap objects at 

specific angles. 

•      Grid Snaps , which snap objects to 
points on a grid.

You can select Edit> Snap Settings  to 
quickly turn Object, Angle and Grid Snaps 
on or off. 

To temporarily disable Snap Behaviors and 
other move restrictions, press the Ctrl key 
while dragging an edit handle. See “Moving 
Objects” on page 77.

Object Snaps
Object Snaps allow you to position objects 
precisly relative to each other; for example, 
to position lines so that their endpoints meet.

Object Snaps can be turned on or off by 
selecting Edit> Snap Settings> Object 
Snaps.

There are many locations on an object that 
other objects can snap to.
• Object endpoints and corners
• The midpoints of object edges

• Object center points
• Intersection points where an object drawn 

at an allowed angle meets another object.

In addition, On Object snapping occurs 
anywhere on an object’s edges and is most 
noticeable when Angle and Grid Snaps are 
turned off.

When multiple objects are selected the 
selection set’s only snap point is its midpoint.
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Extension Snaps
Extension snaps allow you to snap to a point 
that is not actually on an object. Instead, 
these snaps locate points that are either 
colinear to the end of a wall or orthogonal (at 
a 90° angle) to it. 

Extension snaps function when you are 
drawing or editing walls and create a “sticky 
point” where the wall being drawn reaches a 
point that is either colinear or orthogonal to 
another wall’s end point. See “Drawing 
Walls” on page 92. 

Angle Snaps
It is often important that objects be drawn at 
exact angles.

Angle Snaps allow you to draw walls, and 
other objects at angles in 7.5° increments. 

Angle Snaps also affect the way objects 
rotate, the radius of arcs, and a variety of 
other operations.

Grid Snaps
Grid Snaps allow you to snap objects to 
points on a grid. This grid cannot be seen 
directly, but as you draw, move or resize an 
object, you can can often see the snap points. 
The size of this Snap Grid can be controlled 
in the Plan Defaults dialog. See “General 
Plan Defaults Dialog” on page 43.

Grid Snaps and Angle Snaps
Of the three snap behaviors, Grid Snaps have 
the lowest priority and are overridden by 
Angle Snaps and Object Snaps. 

When Grid snaps and Angle Snaps are both 
enabled, objects are drawn and edited using 
Polar Coordinates. For example, if the grid 
Snap Unit is set to 12" (1 foot), drawing a 
new wall at an Allowed Angle snaps the wall 
length to 0", 12", 24", and so on.

Creating Objects
In Home Designer Essentials, there are three 
ways to create objects: by clicking to place 
an object, by clicking and dragging to draw 
an object, or by importing custom pictures or 
metafiles.

While the size of the drawing area in Home 
Designer Essentials is limited only by the 

resources on your computer, it is best to 
begin your drawing near the origin, 0,0,0. 
The current position of your mouse pointer 
displays in the Status Bar at the bottom of the 
program window. See “3D Drafting” on page 
19. 
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Click-to-Create
Many objects, including doors and windows, 
cabinets, library symbols, terrain objects, 
text, pictures and images  are created by 
clicking. Select a or library object, then click 
in the drawing area to place the object at that 
location. 

Continue clicking to place the selected object 
until another tool is selected.

If you click at a location where there is not 
enough room for the object to be placed, one 
of two things may happen:
• Some objects, notably cabinets, doors, 

and windows, will resize smaller to fit 
into the space. 

• Most objects cannot resize in this man-
ner, so the program will present a warn-
ing message indicating that there is not 
sufficient space at the current location.

When most drawing tools are active or 
library symbols selected for placement, a 
preview outline follows your mouse pointer, 
indicating the size and shape of the object to 
be created. If your pointer is positioned at a 
location where the object cannot be placed, 
this preview outline will not display.

As you move the mouse pointer, the center 
point of the object’s back edge will snap to 
active snap points when Grid Snaps or 
Object Snaps are enabled. See “Snap 
Behaviors” on page 52.

Many architectural objects can be created in 
floor plan view or any 3D view. In order to 
place a stand-alone, click-to-create object in 
3D, it is necessary to click near a wall or 
within the Terrain Perimeter as these objects 

help orient the new object within the 3D 
space. 

Clicking and Dragging
Other objects, including walls and railings, 
straight stairs, and terrain features are created 
by clicking and dragging to define either a 
path or an enclosed area. Select a tool, then 
click and drag in the drawing area to draw an 
object between your start and end points.

Continue drawing the selected object until 
another tool is selected.

You can cancel any click-and-drag drawing 
operation before it is completed by pressing 
the Esc key on your keyboard, or by pressing 
any two mouse buttons at the same time. 

Importing Objects
Pictures and metafiles can be imported into 
the program and placed in the drawing area 
with a click. See “Pictures, Images, & 
Walkthroughs” on page 351. 

Object Creation and Layers
When it is created, every object is placed on 
a layer, which controls whether and how the 
object displays. See “Displaying Objects” on 
page 48. 

If you try to create an object on a layer that is 
not set to display in the current view, the 
program will ask if you want to turn that 
layer on. See “Message Boxes” on page 24. 

Note: If you choose to leave the layer off, the
object will be created but you will not be able
to see it until its layer is turned on. 
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Copying and Pasting Objects
New objects can also be created by cutting, 
copying, and pasting existing objects, either 
individually or in groups. Objects can be 
copied from one floor to another, one view 
window to another, and one file to another. 
Because copying uses the Windows 
Clipboard, some objects can be pasted into 
other applications, as well.

Objects cannot be pasted into any views that 
they cannot be created in normally. For 
example, text cannot be pasted into a 3D 
camera view or overview. 

A few objects, such as Terrain Perimeters 
and camera symbols, cannot be copied. 

Cut
Select Edit> Cut to remove the 
selected object(s) from the file and 

save them in the Windows Clipboard. To 
paste the selection in Home Designer 
Essentials or another application, select 
Edit> Paste or press Ctrl + V while in that 
application to enable the Paste function.

Copy
Select Edit> Copy to copy the 
selected object(s) to the Windows 

Clipboard. To paste the selection in Home 
Designer Essentials or another application, 
select Edit> Paste or press Ctrl + V while in 
that application to enable the Paste function. 

Paste
Select Edit> Paste to enable Paste 
mode, then left- or right-click in the 

current view to paste the selected object(s) 

previously copied to the Windows Clipboard 
at that location. 

Once pasted, these object(s) are selected. 
Objects pasted in 3D views are selected on 
their top surfaces.

If the selection being pasted consists of text, 
it is placed in a Text object.

Copy/Paste
Click the Copy/Paste edit button to 
copy the selected object(s) to the 

Windows Clipboard and immediately enable 

the Paste  function in Home Designer 
Essentials. 

The Copy/Paste  edit button activates 
Paste mode in which each available edit tool 
and handle makes a copy in addition to its 
primary function and four new edit buttons 
display on the edit toolbar.

• Click the Sticky Mode  edit button 
remain in the current mode and place 
multiple copies of the selected object(s). 

• Click the Main Edit Mode  edit but-
ton or press the Esc key to return to the 
selected objects’s main edit toolbar.

If you paste a selection in a file other than its 
original source file, when you return to the 
original, Paste mode is still enabled. 

The Copy/Paste  edit button can be used 
with the edit handles in either of two ways: 
by clicking or by dragging an edit handle.
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To Copy/Paste by clicking

1. Select an object or objects to copy.

2. Click the Copy/Paste  edit button, 

select Edit> Copy  from the menu or 
press Ctrl + C to copy and then Ctrl + 
V to activate the Paste functionality. The 
cursor displays the Copy/Paste icon.

3. If you wish to paste the copy in a differ-
ent view or program window, open that 
window. 

4. If your cursor does not display the Copy/
Paste icon, select Edit> Paste from the 
menu or press Ctrl + V.

5. Left- or right-click once to paste a copy 
of the object at that location.

To Copy/Paste by dragging

1. Select an object or objects to copy.

2. Click the Copy/Paste  edit button, 

select Edit> Copy  from the menu or 
press Ctrl + C. The cursor displays the 
Copy/Paste icon.

3. Drag an edit handle:
•  Drag the Move edit handle to position 

the copy at a new location. 
4. You can position the copy accurately 

with respect to the original by watching 
the moved distance in the Status Bar at 
the bottom of the screen.

Sticky Mode
Normally, after an action is performed 
using the edit tools or handles while in 

an edit mode such as Paste mode, you  return 
to the Main Edit Mode. Click the Sticky 

Mode edit button to remain in Paste mode 
and continue pasting copies of the selected 
object(s). 

To exit Paste mode and return to the main 
edit toolbar for the selected object, click the 

Main Edit Mode  edit button or press the 
Esc key on your keyboard. If you have not 
pasted a copy of the selected object and 

immediately click Copy/Paste  after 
returning to the Main Edit Mode, Sticky 

Mode  is still enabled. 

Copy and Paste in Place
Click the Copy and Paste in Place 
edit button to create a copy of the 

selected object(s) at the same location as the 
original. The copy remains selected so you 
can perform additional operations.

Because multiple walls, railing and fencing 
cannot share the same space, the Copy and 

Paste in Place  edit button is not avail-
able for these objects.

Paste Hold Position
When copying between different 
floors or view windows, you can paste 

a copy at the same absolute position as the 
original selection using Paste Hold Position.

To use Paste Hold Position

1. Select the object(s) to be copied.

2. Click the Copy/Paste  edit button.
3. Switch to the desired floor or plan file 

and select Edit> Paste> Paste Hold 

Position .
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4. A copy is placed at the same X, Y coor-
dinates on the new floor or in the new 
plan as the original’s position.

Paste Special
The Paste Special tool allows you to 
choose a representation for the 

selection to be pasted. 

Selections can be pasted as:
• Enhanced Windows Metafiles (EMF). 

See “Metafiles” on page 357. 
• Device Independent Bitmaps (BMP). See 

“Importing Pictures” on page 356.
• Unformatted non-unicode text (TXT).
• File Name (a path to a file). Depending 

on the file type, it will be either opened or 
imported (if supported). 

• Unformatted text (HTML). Pastes as text.
• Model Objects - Home Designer 

Essentials format, not compatible with 
other programs.

To use Paste Special

1. Select an object, image, text or file on 
your computer and copy it.

2. Switch to the desired Home Designer 
Essentials view window and select 

Edit> Paste> Paste Special .
3. In the Paste Special dialog, select the 

desired representation for the selection 
and click OK.

4. Click in the drawing area to place the 
copy at that location.

Copy Region as Picture
The Copy Region as Picture tool 
allows you to copy any portion of the 

screen and save it as a picture.  See “Copy 
Region as Picture” on page 359. 
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Chapter 7:

Editing Objects

Just as the methods used to create different 
objects in Home Designer Essentials are 
similar, the options for moving, rotating, 
resizing, and otherwise editing them are also 
alike. 

Edit handles allow objects to be resized, 
relocated, or rotated using the mouse. Edit 
toolbar buttons and the contextual menus 
access edit tools relevant to the selected 
object(s). Most objects have a specification 
dialog that allows you to edit it in ways that 
are specific to that type of object. 

The editing characteristics common to most 
objects are described in this chapter. Unique, 
object-specific editing behaviors and the 
specification dialogs are covered in their 
respective chapters. 

Chapter Contents
•      Selecting Objects
•      Editing Line Based Objects
•      Editing Arc Based Objects
•      Editing Open Polyline Based Objects
•      Editing Closed-Polyline Based Objects
•      Editing Box-Based Objects
•      Editing Spline Based Objects
•      Displaying Objects
•      Moving Objects
•      Aligning Objects
•      Resizing Objects
•      Reshaping Objects
•      Rotating Objects
•      Deleting Objects
•      Undo and Redo



60

Home Designer Essentials 2012 Reference Manual

Selecting Objects
“Select” refers to selecting an object for 
editing. An object must be selected before it 
can be edited. 

In order for an object to be selected, it must 
be visible in the current view. See “Layers” 
on page 47. 

When an object is selected, it displays edit 
handles and a grey selection fill color. In 3D 
views, a selected object will also display 
lines representing the selected edge or 
surface. The size of the edit handles does not 
change as you zoom in or out. To prevent 
them from stacking on one another, some 
edit handles may not display as you zoom 
away from the selected object. 

When an object is selected, its edit toolbar 
also displays, typically on the upper left side 
of the Home Designer Essentials program 
window.  See “The Edit Toolbar” on page 22.

Information about the selected object or 
objects may also display in the Status Bar. 
See “The Status Bar” on page 24.

A selected object remains selected until 
another object is selected, a different tool is 
activated, the Esc key on the keyboard is 
pressed, or any two mouse buttons are 
pressed at the same time. 

Select Objects
Any object created using Home 
Designer Essentials can be selected 

using the Select Objects tool. Select Edit> 
Select Objects, click the toolbar button or 
press the Space bar on your keyboard to 
activate this tool, then click on an object to 
select it.

You can also select objects or open context 
sensitive menus using the right mouse button 
when any tool is active.

 Selecting Similar Objects

If a tool other than Select Objects  is 
active, you can only select objects of that 
type using the left mouse button. For 

example, if the Straight Exterior Wall  
tool is active, you can only select walls using 
the left mouse button. 

This can be useful for selecting an object 
when many objects of a different type 
occupy the same space in floor plan view. 

Objects can be selected using the right mouse 
button, regardless of which tool is active. 

Right-Clicking
Regardless of which tool is active, you can 
select an eligible object by right-clicking on 
it once. When you right-click to select an 
object a contextual menu also appears, 
displaying the object’s edit tools. See 
“Contextual Menus” on page 23.

If a drawing tool is active and you right-click 
to select an object, you can unselect it by 
left-clicking in an empty space in the 
drawing area. Although a drawing tool is 
active, it is not used. If you then left-click a 
second time, the active tool will be used. 

Selected Edge
When you click on a polyline- or box-based 
object, the edge that you click nearest 
becomes the selected edge and displays an 
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edit handle larger than those on other edges. 
The handle on this edge may also display at 
the point where you clicked to select it.  

This edge can be edited on the Selected Line 
or Selected Arc tab of the object’s 
specification dialog. See “Moving Objects 
Using Dimensions” on page 331, “Selected 
Line Tab” on page 203 and “Selected Arc 
Tab” on page 203.

Select Next Object
If there is more than one object in a 
particular space, it may be difficult to 

select the desired object. When a nearby 
object is selected, click the Select Next 
Object edit button or press the Tab key until 
the desired object becomes selected. This 
function cannot be applied to groups of 
selected objects.

Marquee Select
Groups of objects can be selected by holding 
down either the Shift or Ctrl key when the 

Select Objects  tool is active and then 
dragging a marquee around the objects to be 
selected. An object does not need to be 
completely enclosed by the marquee to be 
selected: it will be selected if the marquee 
includes only a small portion of it. 

If an object is currently selected and a 
selection marquee is drawn around it, that 
object becomes de-selected.  If an object is 
currently selected and a marquee is drawn 
around other objects, the original object  
remains selected and the other objects are 
added to the selection set.

When using the marquee-select method, both 
text and architectural objects included in the 
marquee are selected. To remove an object 
from the selection set, hold down the Shift 
key and click it.

The marquee-select method can also be used 
to group-select similar object types. For 

example, click the Hinged Door  child 
button, hold down either the Shift key, drag a 
marquee, release the mouse button, and only 
door objects within the marquee are selected.

Shift Select
You can select a group of objects by adding 
them to the selection set one by one. Select 
an object, hold down either the Shift or Ctrl 
key, and click additional objects to select 
them. 

More than one type of object can be selected 
using this method, but the ability to edit the 
group-selected items is limited to attributes 
that all selected objects have in common.

To remove an object from a selection set, 
click it once more - again, with either the 
Shift or Ctrl key pressed.

To make marquee selection easier, you
can turn off the display of objects you

do not want to include in your selection set.
See “Displaying Objects” on page 48.
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Edit Area
The Edit Area tool allows you to 
quickly define an area of your plan 

and select the objects in that area. Once 
selected, they can then be repositioned, 
rotated, or deleted. Select Edit> Edit Area, 
then click and drag a rectangular marquee 
around the area that you would like to move.

Unlike other selection methods, the Edit 
Area tool cuts walls, railings and fencing 
where the selection marquee intersects them, 
allowing you to edit only the selected portion 
of these objects. 

Some objects, such as cabinets, are included 
in the selection only if more than half of the 
object is contained within the marquee. 

Editing Line Based Objects
Objects are considered line-based when they 
can be resized along one axis using the edit 
handles.

 Straight walls and railings, straight stairs and 
straight roads are examples of line-based 
objects. 

Most line-based objects can be connected to 
other like objects to form polyline-based 
objects provided that they are on the same 
layer. Line-based objects will only form a 
polyline with other objects if they share 
identical arrow specifications, as well. See 
“Editing Open Polyline Based Objects” on 
page 67 and “Editing Closed-Polyline Based 
Objects” on page 69.

Some objects, notably walls, have line-based 
editing behavior only when selected on 
certain surfaces. See “Editing Walls” on page 
96.

Wall openings such as doors and windows 
have line-based editing behavior in floor plan 
view only but cannot be rotated, reversed or 
converted to an arc. See “Editing Doors” on 
page 131 and “Editing Windows” on page 
149.

Other objects, such as stairs and roads, have 
additional edit handles that allow you to 
concentrically adjust the object’s width. 

Using the Edit Handles
When selected, a typical line-based object 
displays four edit handles.  

Any action performed using the edit handles 
can be cancelled by pressing the Esc key or 
any two mouse buttons at the same time.

Move
• Movement may be limited or stopped by 

other objects or Snap Behaviors. Move 
restrictions can be overridden by holding 
down the Ctrl key while dragging. See 
“Unrestricted Movement” on page 78.

Rotate
• The Rotate handle is used to rotate the 

object about its center. See “Rotating 
Objects” on page 81.
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Extend/Change Angle 
• Drag an end handle parallel to the 

selected line to change its length. 
• Drag an end handle at an angle to the 

selected line to change its angle. 

Adjust Width

Some line-based objects, such as stairs and 
roads, have additional handles that allow the 
width of the object to be adjusted.

• Click and drag a small, round Expand 
handle to increase or decrease the 
object’s width. By default, objects are 
resized in 1" increments. This Snap Unit 
is defined in the Plan Defaults dialog. 
See “General Plan Defaults Dialog” on 
page 43.

Using Dimensions
Dimensions can be used to position 
line-based objects relative to other 

objects. See “Moving Objects Using 
Dimensions” on page 331.

Dimensions cannot, however, be used to 
adjust the length of line-based objects, or the 
width of line-based objects such as stairs.

Using the 
Specification Dialog

Line-based objects can be edited using 
their specification dialogs. See 

“Specification Dialogs” on page 24.

Using the Edit Toolbar
A selected line-based object can be edited in 
a variety of ways using the buttons on the 
edit toolbar. 

The following toolbar buttons may display 
on the edit toolbar for a selected line-based 
object: 

• Click the Select Next Object  edit 
button to select nearby objects instead of 
the selected object. See “Selecting 
Objects” on page 60.

• Click the Open Object  edit button to 
open the specification dialog for the 
selected object(s). See “Specification 
Dialogs” on page 24.

• Click the Copy/Paste  edit button to 
copy the selected object(s) to the Win-
dows Clipboard so they can be pasted 
elsewhere. See “Copying and Pasting 
Objects” on page 55.

• Click the Copy and Paste in Place  
edit button to create a copy of the 
selected object(s) at the same location as 
the original. See “Copy and Paste in 
Place” on page 56.

• Click the Delete  edit button to delete 
the selected object(s). See “Deleting 
Objects” on page 82.

Adjust Width
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• Click the Accurate Move  edit button 
to slow down the mouse speed when 
using the edit handles. See “Accurate 
Move” on page 78.

• Click the Center Object  edit button 
to center an object along along a wall 
within a room or relative to a cabinet 
fixture. See “Using Center Object” on 
page 79.

• Click the Move to Front of Group  
edit button to display the selected object 

in front of other objects in the same 
drawing group. See “Move to Front of 
Group” on page 76.

• Click the Break Line  edit button to 
add a new corner or pivot point to the 
selected object. See “Break Line” on 
page 81.

• Click the Change Line/Arc  edit but-
ton to change a line-based object to an 
arc, or vice versa. See “Change Line/
Arc” on page 81.

Editing Arc Based Objects
Objects are considered arc-based when they 
can be resized along a curve using the edit 
handles.

Curved walls and railings, curved stairs, and 
curved roads are examples of arc-based 
objects.  

Most arc-based objects can be connected to 
other like objects to form polyline-based 
objects provided that they are on the same 
layer. Arc-based objects will only form a 
polyline with other objects if they share 
identical arrow specifications, as well. See 
“Editing Open Polyline Based Objects” on 
page 67 and “Editing Closed-Polyline Based 
Objects” on page 69.

Some objects, notably curved walls, have 
arc-based editing behavior only when 

selected on certain surfaces. See “Editing 
Walls” on page 96.

Other objects, such as curved stairs and 
roads, have additional edit handles that allow 
you to concentrically adjust the object’s 
width. 

Using the Edit Handles
When selected, a typical arc-based object 
displays seven edit handles. 

Any action performed using the edit handles 
can be cancelled by pressing the Esc key or 
any two mouse buttons at the same time.

Move
• Two Move edit handles allow the arc to 

be relocated without changing its shape. 
One is located at the center of the chord 
and the other, at the arc center. 

• Movement may be limited or stopped by 
other objects or Snap Behaviors. Move 
restrictions can be overridden by holding 
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down the Ctrl key while dragging. See 
“Unrestricted Movement” on page 78.

Rotate
• The Rotate handle is used to rotate the 

arc about its center. See “Rotating 
Objects” on page 81.

Extend
• The end edit handles expand or contract 

the arc when moved along the arc radius 
or chord. 

• If you follow the path of the arc, the end 
edit handles allow you to adjust the arc 
length.

• The angle formed by the center point of 
the arc and its two endpoints is referred to 
as the Included Angle. The Included 
Angle of the arc can be rotated at 
Allowed Angles. See “Angle Snaps” on 
page 53.

Resize
• Drag the small, round Resize edit handle 

to change the radius and included angle 
of the arc while maintaining its center. 

Reshape
• Drag the small triangular Reshape 

handle to change the length and location 
of the center without moving the 
endpoints.

Adjust Width

Some arc-based objects, such as stairs, have 
additional handles that allow the width of the 
object to be adjusted. 

• Click and drag a small, round edit handle 
to increase or decrease the object’s width. 

Move edit handle

Extend edit handles

Resize edit handle

Reshape edit handle

Adjust Width
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By default, objects are resized according 
to the Snap Unit defined in the Plan 
Defaults dialog. See “General Plan 
Defaults Dialog” on page 43.

Using Dimensions
Dimensions can be used to position 
arc-based objects. Dimension lines 

typically locate tangent extension lines and 
any extension lines that may be parallel to 
those lines rather than the arc itself. See 
“Moving Objects Using Dimensions” on 
page 331.

Using the 
Specification Dialog

Arc-based objects can be edited using 
their specification dialogs. See 

“Specification Dialogs” on page 24.

Using the Edit Toolbar
A selected arc-based object can be edited in a 
variety of ways using the buttons on the edit 
toolbar. 

The following toolbar buttons may display 
on the edit toolbar for a selected arc-based 
object:

• Click the Select Next Object  edit 
button to select nearby objects instead of 
the selected object. See “Selecting 
Objects” on page 60.

• Click the Open Object  edit button to 
open the specification dialog for the 
selected object(s). See “Specification 
Dialogs” on page 24.

• Click the Copy/Paste  edit button to 
copy the selected object(s) to the Win-
dows Clipboard so they can be pasted 
elsewhere. See “Copying and Pasting 
Objects” on page 55.

• Click the Copy and Paste in Place  
edit button to create a copy of the 
selected object(s) at the same location as 
the original. See “Copy and Paste in 
Place” on page 56.

• Click the Delete  edit button to delete 
the selected object(s). See “Deleting 
Objects” on page 82.

• Click the Accurate Move  edit button 
to slow down the mouse speed when 
using the edit handles. See “Accurate 
Move” on page 78.

• Click the Center Object  edit button 
to center an object along along a wall 
within a room or relative to a cabinet 
fixture. See “Using Center Object” on 
page 79.

• Click the Move to Front of Group  
edit button to display the selected object 
in front of other objects in the same 
drawing group. See “Move to Front of 
Group” on page 76.

• Click the Break Line  edit button to 
add a new corner or pivot point to the 
selected object. See “Break Line” on 
page 81.

• Click the Change Line/Arc  edit but-
ton to change an arc-based object to a 
line, or vice versa. See “Change Line/
Arc” on page 81.
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Editing Open Polyline Based Objects
Open polyline-based objects are composed 
of individual line- and arc-based objects that 
are connected at their end points but do not 
form an enclosed area. 

Connected walls, stairs, and roads are 
examples of open polyline-based objects. 

Other objects, such as connected stair and 
road segments, have additional edit handles 
that allow you to concentrically adjust the 
width of all segments of the object. 

Using the Edit Handles
A polyline-based object can be composed of 
many segments.  

When selected, an open polyline-based 
object displays a Move handle, a Rotate 
handle, a Reshape handle at the intersection 
of each segment, and an Extend handle at 
each end. 

Each straight, line-based segment also has a 
Move edit handle along its length. 

Each curved, arc-based segment has its own 
Move handle at the center of its chord, a 
Resize handle and, if it has an unlocked 

center, a Reshape handle. See “Editing Arc 
Based Objects” on page 64.

When a polyline is selected, the edge that 
you click nearest is called the selected edge, 
and certain operations affect only this edge. 
The Move handle of the selected edge is 
larger than that of other edges. It displays 
along the length of a line segment, or at the 
center of the chord on an arc segment. See 
“Selected Edge” on page 60.

Any action performed using the edit handles 
can be cancelled by pressing the Esc key or 
any two mouse buttons at the same time.

Move
• Click and drag the Move handle to move 

the object. 
• Movement may be limited or stopped by 

other objects or Snap Behaviors. Move 
restrictions can be overridden by holding 
down the Ctrl key while dragging. See 
“Unrestricted Movement” on page 78.

Rotate
• The Rotate handle is used to rotate the 

object about its center. Its position varies 
depending on which edge is currently 
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selected. See “Rotating Objects” on page 
81.

Extend
• Click and drag an Extend handle to 

lengthen or shorten the unconnected end 
of the selected line or arc segment, or to 
change the radius of the selected arc. See 
“Editing Arc Based Objects” on page 64.

Reshape 
• Click and drag a Reshape edit handle to 

change the angle and/or length of the seg-
ments on either side of it, or the size of 
the object. 

Move Line Segment
• The Move Line Segment edit handle is 

found on straight segments of open 
polylines and moves the straight section-
perpendicular to itself. Adjacent seg-
ments may extend or contract in their 
original directions to maintain their con-
nections. 

Move Arc
• Click and drag the Move Arc edit handle 

to change the radius and/or chord length 
or position. Adjacent segments may 
extend, contract, or change angle to 
maintain their connections. 

Resize Arc
• Click and drag the Resize Arc edit handle 

to change the radius, chord length and 
chord position of the arc segment. Adja-
cent segments may extend, contract, or 
change angle to maintain their connec-
tions. 

Reshape Arc
• Click and drag the Reshape Arc edit han-

dle to change the radius of the arc without 
moving its end points. 

Adjust Width

Some arc-based objects, such as stairs and 
roads, have additional handles that allow the 
width of the object to be adjusted. 

• Click and drag a small, round edit handle 
to increase or decrease the object’s width. 
By default, objects are resized in 1" 
increments. This Snap Unit is defined in 
the Plan Defaults dialog. See “General 
Plan Defaults Dialog” on page 43.

Using Dimensions
Dimensions can be used to move or 
reshape polyline-based objects. See 

“Moving Objects Using Dimensions” on 
page 331.

Using the Specification 
Dialog

Open polyline-based objects can be 
edited using their specification 

dialogs. See “Specification Dialogs” on page 
24.

Adjust 
Width
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Using the Edit Toolbar
A selected open polyline-based object can be 
edited in a variety of ways using the buttons 
on the edit toolbar. 

The following toolbar buttons may display 
on the edit toolbar for a selected open 
polyline-based object:

• Click the Select Next Object  edit 
button to select nearby objects instead of 
the selected object. See “Selecting 
Objects” on page 60.

• Click the Open Object  edit button to 
open the specification dialog for the 
selected object(s). See “Specification 
Dialogs” on page 24.

• Click the Copy/Paste  edit button to 
copy the selected object(s) to the Win-
dows Clipboard so they can be pasted 
elsewhere. See “Copying and Pasting 
Objects” on page 55.

• Click the Copy and Paste in Place  
edit button to create a copy of the 
selected object(s) at the same location as 
the original. See “Copy and Paste in 
Place” on page 56.

• Click the Delete  edit button to delete 
the selected object(s). See “Deleting 
Objects” on page 82.

• Click the Accurate Move  edit button 
to slow down the mouse speed when 
using the edit handles. See “Accurate 
Move” on page 78.

• Click the Center Object  edit button 
to center an object along along a wall 
within a room or relative to a cabinet 
fixture. See “Using Center Object” on 
page 79.

• Click the Move to Front of Group  
edit button to display the selected object 
in front of other objects in the same 
drawing group. See “Move to Front of 
Group” on page 76.

• Click the Break Line  edit button to 
add a new corner or pivot point to the 
selected object. See “Break Line” on 
page 81.

• Click the Change Line/Arc  edit but-
ton to change a line-based polyline edge 
to an arc, or vice versa. See “Change 
Line/Arc” on page 81.

Editing Closed-Polyline Based Objects
Closed polyline-based objects are composed 
of individual line- and arc-based objects 
joined end-to-end and forming an enclosed 
area.

Terrain features and stair landings are 
examples of closed polyline-based objects. 
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Using the Edit Handles
A polyline can be composed of many 
segments.  

When selected, a closed polyline-based 
object displays a Move handle, a Rotate 
handle, and a Reshape handle at the 
intersection of each segment. 

Each straight, line-based segment has a 
Move edit handle along its length. 

Each curved, arc-based segment has its own 
Move handle at the center of its chord, a 
Resize handle and a Reshape handle. See 
“Editing Arc Based Objects” on page 64.

When a polyline is selected, the edge that 
you click nearest is called the selected edge, 
and certain operations affect only this edge. 
The Move handle of the selected edge is 
larger than that of other edges. It displays 
along the length of a line segment, or at the 
center of the chord on an arc segment. See 
“Selected Edge” on page 60.

Any action performed using the edit handles 
can be cancelled by pressing the Esc key or 
any two mouse buttons at the same time.

Move
• Click and drag the Move handle to move 

the object. 

• Movement may be limited or stopped by 
other objects or Snap Behaviors. Move 
restrictions can be overridden by holding 
down the Ctrl key while dragging. See 
“Unrestricted Movement” on page 78.

Rotate
• The Rotate handle is used to rotate the 

object about its center. Its position varies 
depending on which edge is currently 
selected. See “Rotating Objects” on page 
81.

Reshape 
• Click and drag a Reshape edit handle to 

change the angle and/or length of the seg-
ments on either side of it, or the size of 
the object. 

Move Line Segment
• The Move Line Segment edit handle is 

found on straight segments of closed 
polylines and moves the straight section-
perpendicular to itself. Adjacent seg-
ments may extend or contract in their 
original directions to maintain their con-
nections. 

Move Arc
• Click and drag the Move Arc edit handle 

to change the radius and/or chord length 
or position. Adjacent segments may 
extend, contract, or change angle to 
maintain their connections. 

Resize Arc
• Click and drag the Resize Arc edit handle 

to change the radius, chord length and 
chord position of the arc segment. Adja-
cent segments may extend, contract, or 
change angle to maintain their connec-
tions. 
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Reshape Arc
• Click and drag the Reshape Arc edit han-

dle to change the radius of the arc without 
moving its end points. 

Using Dimensions
Dimensions can be used to move or 
reshape closed polyline-based objects. 

See “Moving Objects Using Dimensions” on 
page 331.

Using the 
Specification Dialog

Closed polyline-based objects can be 
edited using their specification 

dialogs. See “Specification Dialogs” on page 
24.

Using the Edit Toolbar
A selected closed polyline-based object can 
be edited in a variety of ways using the 
buttons on the edit toolbar. 

The following toolbar buttons may display 
on the edit toolbar for a selected closed 
polyline-based object:

• Click the Select Next Object  edit 
button to select nearby objects instead of 
the selected object. See “Selecting 
Objects” on page 60.

• Click the Open Object  edit button to 
open the specification dialog for the 
selected object(s). See “Specification 
Dialogs” on page 24.

• Click the Copy/Paste  edit button to 
copy the selected object(s) to the Win-
dows Clipboard so they can be pasted 

elsewhere. See “Copying and Pasting 
Objects” on page 55.

• Click the Copy and Paste in Place  
edit button to create a copy of the 
selected object(s) at the same location as 
the original. See “Copy and Paste in 
Place” on page 56.

• Click the Delete  edit button to delete 
the selected object(s). See “Deleting 
Objects” on page 82.

• Click the Accurate Move  edit button 
to slow down the mouse speed when 
using the edit handles. See “Accurate 
Move” on page 78.

• Click the Center Object  edit button 
to center an object along along a wall 
within a room or relative to a cabinet 
fixture. See “Using Center Object” on 
page 79.

• Click the Move to Front of Group  
edit button to display the selected object 
in front of other objects in the same 
drawing group. See “Move to Front of 
Group” on page 76.

• Click the Break Line  edit button to 
add a new corner or pivot point to the 
selected object. See “Break Line” on 
page 81.

• Click the Change Line/Arc  edit but-
ton to change a line-based polyline edge 
to an arc, or vice versa. See “Change 
Line/Arc” on page 81.
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Editing Box-Based Objects
Box-based objects are similar to closed 
polyline-based objects, but must always have 
four sides with right-angled corners. 

Text objects, many library symbols, pictures 
and images are examples of box-based 
objects.

Using the Edit Handles
When selected, a box-based object displays 
ten edit handles. 

Any action performed using the edit handles 
can be cancelled by pressing the Esc key or 
any two mouse buttons at the same time.

• Click and drag the Move handle to move 
the object. 

• Movement may be limited or stopped by 
other objects or Snap Behaviors. Move 
restrictions can be overridden by holding 
down the Ctrl key while dragging. See 
“Unrestricted Movement” on page 78.

• The four Resize handles located at each 
corner are used to increase or decrease 
the size of the object. 

• The four Extend handles display along 
each edge. If you select an object on an 
edge, the Extend handle displays at the 
point where you clicked; otherwise, it 
displays at the center of the edge.

• The triangular Rotate handle located 
near the selected edge of the object is 
used to rotate it about its center. The 
pointer changes to a circular arrow  

Move

Rotate

Resize

Extend



Editing Box-Based Objects

 73

when moved over this handle. See 
“Rotating Objects” on page 81.

Using Dimensions
Dimensions can be used to move or 
reshape box-based objects. See 

“Moving Objects Using Dimensions” on 
page 331.

Using the 
Specification Dialog

Box-based objects can be edited using 
their specification dialogs. See 

“Specification Dialogs” on page 24.

Using the Edit Toolbar
A selected closed polyline-based object can 
be edited in a variety of ways using the 
buttons on the edit toolbar.  

The following toolbar buttons may display 
on the edit toolbar for a selected closed 
polyline-based object:

• Click the Select Next Object  edit 
button to select nearby objects instead of 
the selected object. See “Selecting 
Objects” on page 60.

• Click the Open Object  edit button to 
open the specification dialog for the 
selected object(s). See “Specification 
Dialogs” on page 24. 

• Click the Copy/Paste  edit button to 
copy the selected object(s) to the Win-
dows Clipboard so they can be pasted 
elsewhere. See “Copying and Pasting 
Objects” on page 55.

• Click the Copy and Paste in Place  
edit button to create a copy of the 
selected object(s) at the same location as 
the original. See “Copy and Paste in 
Place” on page 56.

• Click the Delete  edit button to delete 
the selected object(s). See “Deleting 
Objects” on page 82.

• Click the Accurate Move  edit button 
to slow down the mouse speed when 
using the edit handles. See “Accurate 
Move” on page 78.

• Click the Center Object  edit button 
to center an object along along a wall 
within a room or relative to a cabinet 
fixture. See “Using Center Object” on 
page 79.

• Click the Move to Front of Group  
edit button to display the selected object 
in front of other objects in the same 
drawing group. See “Move to Front of 
Group” on page 76.
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Editing Spline Based Objects
Objects are considered spline-based when 
they can be edited similar to CAD splines 
using their edit handles. 

A Spline is a curve that passes smoothly 
through a set of points. Splines are typically 
used in situations where there is an irregular 
curve. Splines are useful wherever a free-
flowing curve is needed.

Round and kidney-shaped terrain features are 
spline-based objects. See “Terrain” on page 
237.

Using the Edit Handles
When a spline is selected, several different 
types of handles display. 

Any action performed using the edit handles 
can be cancelled by pressing the Esc key or 
any two mouse buttons at the same time.

Move
• Click and drag the Move handle to move 

the object. 
• Movement may be limited or stopped by 

other objects or Snap Behaviors. Move 
restrictions can be overridden by holding 
down the Ctrl key while dragging. See 
“Unrestricted Movement” on page 78.

Rotate
• Click and drag the Rotate edit handle to 

rotate the entire spline. 

Reshape
• The Reshape edit handles display along 

the spline at each vertex. Click and drag a 
Reshape edit handle to change the length, 
angle and curve of adjacent segments 
without affecting other reshape handles. 

Resize
• The Resize edit handles display along the 

spline, between each vertex. Click and 
drag a Resize edit handle to move the 
adjacent vertices and lengthen or shorten 
adjacent segments.
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Using the 
Specification Dialog

Spline-based objects can be edited 
using their specification dialogs. See 

“Specification Dialogs” on page 24.

Using the Edit Toolbar
A selected spline-based object can be edited 
in a variety of ways using the buttons on the 
edit toolbar.  

The following toolbar buttons may display 
on the edit toolbar for a selected spline-based 
object:

• Click the Select Next Object  edit 
button to select nearby objects instead of 
the selected object. See “Selecting 
Objects” on page 60.

• Click the Open Object  edit button to 
open the specification dialog for the 
selected object(s). See “Specification 
Dialogs” on page 24.

• Click the Copy/Paste  edit button to 
copy the selected object(s) to the Win-
dows Clipboard so they can be pasted 

elsewhere. See “Copying and Pasting 
Objects” on page 55.

• Click the Copy and Paste in Place  
edit button to create a copy of the 
selected object(s) at the same location as 
the original. See “Copy and Paste in 
Place” on page 56.

• Click the Delete  edit button to delete 
the selected object(s). See “Deleting 
Objects” on page 82.

• Click the Accurate Move  edit button 
to slow down the mouse speed when 
using the edit handles. See “Accurate 
Move” on page 78.

• Click the Center Object  edit button 
to center an object along along a wall 
within a room or relative to a cabinet 
fixture. See “Using Center Object” on 
page 79.

• Click the Move to Front of Group  
edit button to display the selected object 
in front of other objects in the same 
drawing group. See “Move to Front of 
Group” on page 76.

• Click the Break Line  edit button to 
add a new corner or pivot point to the 
selected object. See “Break Line” on 
page 81.

• Click the Move to Front of Group  
edit button to display the selected object 
in front of other objects in the same 
drawing group. See “Move to Front of 
Group” on page 76.
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Displaying Objects
The display of objects in 2D and 3D views 
can be controlled by layer. See “Displaying 
Objects” on page 48.

Line and Fill Styles
Line style and color can be controlled by 
layer or overridden in the specification 
dialogs for many objects. See “Line Style 
Tab” on page 205. 

In addition, some objects have a fill style that 
can be specified in the objects’ specification 
dialogs. See “Fill Style Tab” on page 205.

Color On/Off
The display of color on-screen can be 
toggled on and off in 3D by selecting 

Tools> Display Settings> Color On/Off. 

The display of colors may or may not make a 
view easier to understand. Experiment to see 
what works for you.

 You can also print in color or gray scale. See 
“Print Dialog” on page 368.

Drawing Groups
Each object in a plan file belongs to one of 
three drawing groups, which influences 
whether it displays in front of or behind other 
objects. 
• The Default Group is where most 

objects are placed when first created. 
• Objects on the Back Group display 

behind those in the other two drawing 
groups.

• Objects on the Front Group display in 
front of those in the other two drawing 
groups.

With the exception of imported pictures, 
when an object is first created, it is placed in 
the Default Group. Objects in this group 
display in front of or behind one another 
according to program-defined rules that 
cannot be modified.

Once a CAD or CAD-based object is created, 
though, you can control how it displays 
relative to other objects using its 
specification dialog. See “Line Style Tab” on 
page 205.

You can  check Move to Front of Group to 
display the object in front of other objects in 
its drawing group, but not necessarily in 
front of objects in other groups.  

Move to Front of Group
Click the Move to Front of Group 
edit button to move the selected 

object(s) so that it displays in front of other 
objects in the same drawing group. Move to 
Front of Group functions like the checkbox 
of the same name in the object’s specification 
dialog.
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Textures
The appearance of architectural objects in 3D 
views is affected by the materials applied to 
the objects’ surfaces. See “Materials” on 
page 281. 

In  views, you can turn on or off the display 
of textures by selecting 3D> Toggle 

Textures . 

Delete Surface
In any 3D view, select 3D> Delete 
Surface, then click a surface in the 

view to temporarily remove the surface from 
the current view. See “Delete 3D Surface” on 
page 306.

Refresh Display
Refresh Display redraws the current 
window to clean up extra lines, show missing 
items, and correct random on-screen effects 
caused by changes to a model. Select Tools> 
Display Settings> Refresh Display or press 
the F5 key to refresh the on-screen display. 

Moving Objects
Objects can be moved individually and in 
groups using the edit handles, as well as a 
variety of edit tools.

Using the Edit Handles
Select an object, then click the Move edit 
handle and drag it to a new location. When 
your pointer is over the Move handle, it 
displays a four-headed arrow. 

When moved, the selected object moves 
orthogonal, or at a right angle to, any of its 
edges.

As an object is moved, it jumps at set 
increments when Grid Snaps  are enabled. 
See “Grid Snaps” on page 53.

If an selected object passes over its original 
location as it is being moved, it will snap to 
that location.

Bumping/Pushing
When an object bumps into another similar 
object while it is being moved, it stops. 
Continue dragging and the selected item  
resumes movement through the obstructing 
object.  

Walls, wall openings, cabinets, furnishings 
and fixtures are examples of objects that can 
push other objects of these same types once 
they have bumped into them. Instead of 
dragging through the obstructing object(s), 
release the mouse button and then click and 
drag the Move edit handle a second time in 
the same direction to push. 
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Unrestricted Movement
Many objects have restrictions placed on 
their movement by their own properties or 
specification settings. Architectural objects, 
for example, bump into other 3D objects as 
they are being moved. 

Other move restrictions are activated by the 
Snap Settings. See “Snap Behaviors” on 
page 52.

These restrictions can be overridden when 
necessary by holding down the Ctrl key 
while dragging to move an object.

To move an object freely 

1. Select the object. 
2. Hold down the Ctrl key.
3. Click  the Move edit handle and drag it 

to the new location.

You can also press the Ctrl key while 
dragging an object’s Move handle to override 
move restrictions. 

Accurate Move
Click the Accurate Move edit button, 
then move the selected object(s) at a 

slower speed than normal for greater 
precision. Accurate Move can also be used 
to resize, reshape or rotate objects.

Accurate Move  is not a toggle button: it 
only affects the speed of the mouse during 
the next edit. The next time you want to use 
this edit tool, you need to click it again.

You can also slow down the movement speed 
of a selection after you have started moving 
it by pressing the Shift key. Release the Shift 
key to resume movement at normal speed. 

Center Object
The Center Object edit button allows 
you to move walls, cabinets and other 

objects so that they are centered along a wall 
within a room or relative to a window or 
cabinet. 

Using Dimensions
Objects or the selected edges of some 
objects can be moved using 

dimensions. See “Moving Objects Using 
Dimensions” on page 331.

Aligning Objects
It is often important to align objects such as 
text boxes or walls, or to align objects on 
different floors. There are several methods to 
choose from. 

Using the Mouse 
Crosshairs

Objects can be aligned by eye using the 
mouse crosshairs as a reference. This method 
can help you draw, place and edit objects 
quickly and with reasonable accuracy, but is 
not necessarily as accurate as some of the 
other approaches described here.
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The mouse crosshairs can be turned on and 
off by selecting Tools> Display Settings> 
Show Crosshairs.

Using Snap Settings
With Object Snaps, you can snap the edge 
of a selected object to that of another. Select 
an edge of an object. Drag it to the edge of 
another object, then release the mouse.

With Grid Snaps  on, objects snap at 
increments equal to the Snap unit specified 
in the Plan Defaults dialog rather than onto 
the grid itself. This does not align objects to 
the grid unless they were already snapped to 
the grid. See “Snap Behaviors” on page 52. 

Using Dimensions
Create a temporary or manual 
dimension relative to an object such as 

a wall or line, and relocate the objects to the 
same dimension. See “Moving Objects 
Using Dimensions” on page 331. 

Using Center Object
The Center Object edit button can be 
used to center a variety of objects 

relative to another object. 

To center an object 

1. Select an object.

2. Click the Center Object  edit button.

3. Move the mouse pointer over the object 
you would like to center the selected 
object relative to.

•  As the pointer passes over an eligible 
object, it becomes highlighted and a 
dashed centering axis line displays.

4. When the desired centering axis dis-
plays, click once to center the selected 
object along that axis line.

To center an object in a room

1. Select an object such a cabinet.

2. Click the Center Object  edit button.
3. Move the mouse pointer in the room that 

you would like to center the selected 
object relative to.

•  As you move the pointer, a centering 
axis will display along the wall it is 
closest to.

•  The selected object does not have to be 
inside a room in order to be centered 
relative to that room.

4. When a centering axis displays along the 
correct wall, click once. 

5. The object is moved perpendicular to the 
centering axis. 

If you click outside an exterior wall instead 
of clicking inside, the selected object is 
centered along the edge of the Exterior 
Room. See “The Exterior Room” on page 
111. 

Aligning Objects on 
Different Floors

Objects on different floors can be aligned 
with one another using the Reference 

Text objects can be aligned using set-
tings in the Text Specification dialog.

See “Aligning Text” on page 342.
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Display . See “The Reference Floor” on 
page 165.

Resizing Objects
Objects can be resized using the edit handles 
and specification dialogs. 

Using the Edit Handles
The end, corner and/or side edit handles can 
be used to resize a selected object. 

To override any movement restrictions 
caused by snap settings or the presence of 
other objects, press the Ctrl key while 
dragging an edit handle.

As an object is resized, any dimensions 
indicating its size will update to reflect yoru 
changes. You can use dimensions as 
references to help you achieve the correct 
size for most objects. 

Using the 
Specification Dialog

Most objects can be accurately resized 
in their specification dialogs. See 

“Specification Dialogs” on page 24. 

Using Dimensions
Many objects can be resized by 
selecting an edge and then moving 

that edge using dimensions. See “Moving 
Objects Using Dimensions” on page 331.

Walls can also be resized using dimensions; 
however, it is important to understand that 
the selected edges of other objects cannot be 
resized using dimensions - they can only be 
moved. To resize an edge, select an adjacent 
edge and move that edge instead.

Reshaping Objects
There is a variety of ways to reshape objects 
using the edit handles, specification dialogs 
and edit toolbar buttons.

Some objects, notably box-based objects, 
cannot be reshaped - only resized. See 
“Resizing Objects” on page 80.

Using the Edit Handles
Depending on the type of object selected, the 
end, corner and/or side edit handles can be 
used to reshape a selected object. 

To override any movement restrictions 
caused by snap settings or the presence of 
other objects, press the Ctrl key while 
dragging an edit handle.

Using the 
Specification Dialog

A variety of terrain objects can be 
reshaped by editing values on either 

the Selected Line or Selected Arc tab of their 
specification dialogs. See “Selected Line 
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Tab” on page 203 and “Selected Arc Tab” on 
page 203.

Using Dimensions
Both temporary and manually drawn 
dimensions can be used to increase or 

decrease the distance between the edge a 
line- or polyline-based object and another, 
parallel edge or line. 

Break Line
The Break Line edit button can be 
used to break an individual line-, arc-, 

or spline-based object into two segments. 
The edges of a polyline-based object can also 
be broken.

The Break Line  edit tool can be used to 
create two types of breaks: partial breaks and 
complete breaks.

When a partial break is created, a new corner 
edit handle is placed at the location of the 
break. Partial breaks are also referred to as 
joints, nodes or pivot points.

• Click the Break Line  edit button to 
add a new corner or pivot point to the 
selected object. 

To create a partial break

1. Click the object or edge that you want to 
break into two segments.

2. Click the Break Line  edit button 
once or press the 3 key. 

3. Click the edge to create a new corner 
edit handle at that location and two sepa-
rate edges on either side of that handle. 

If you click and drag one of the edit handles 
on either side of the partial break, the edge 
moves at a right angle to itself and another 
edge forms, connecting the moved edge with 
the one on the other side that does not move.

You can remove an edge from a polyline-
based object by clicking and dragging a 
corner handle until it snaps to an adjacent 
corner handle.

Change Line/Arc
Select an individual line-based or arc-
based object or a segment of a 

polyline-based object and click the Change 
Line/Arc edit button to convert the selected 
segement from a line to an arc or vice versa.

Rotating Objects
Objects can be rotated individually and in 
groups using a variety of methods.

Note: The Break Line edit button is not avail-
able for box-based objects or some architec-
tural objects such as stairs.
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By default, an object or group of objects  
rotate about the center point of the selection 
set. 

Using the Edit Handles
Select an object, then click the triangular 
Rotate edit handle and drag it in any 
direction. When your pointer is over the 
Rotate handle, it displays a curved arrow.

The angles of line-based objects can also be 
changed by dragging an end handle in a 
direction other than parallel to the object. 
The object rotates about the opposite end 
point. See “Editing Line Based Objects” on 
page 62.

Objects snap to Allowed Angles as they are 
rotated. See “Angle Snaps” on page 53. 

To override any movement restrictions 
caused by snap settings or the presence of 
other objects, press the Ctrl key while 
dragging an edit handle.

Using the 
Specification Dialog

The exact angle of some objects such 
as lines, arcs, walls and the selected 

edges of polylines can be specified on either 
the General tab, Selected Line tab, or 
Selected Arc tab of that object’s specification 
dialog. See “Selected Line Tab” on page 203 
and “Selected Arc Tab” on page 203.

Reverse Plan
The Reverse Plan tool is a quick way 
to mirror a plan so that everything on 

all floors of the entire plan is swapped left to 
right rather than rotated. 

Select Tools> Reverse Plan  to reflect an 
entire plan right to left, as though it were 
reflected about a vertical line. 

Deleting Objects
Objects can be deleted in a variety of ways: 
• Select an object or group of objects, then 

click the Delete  edit button, select 

Edit> Delete  from the menu, or press 
the either the Delete or Backspace key on 
your keyboard. 

• Entire categories of objects can be 
deleted using the Delete Objects dialog.

• Objects are deleted if the floor they are 
placed on is deleted. See “Deleting 
Floors” on page 162.

If an object has a line with arrow attached to 
it, the arrow is deleted if the object is deleted. 
To prevent the arrow from being deleted, 
drag the attached end away from the object 
before deleting it. 

Delete Objects Dialog
Use the Delete Objects dialog to 
delete all objects of one or more 

specified types in one room, on the current 
floor, or in the entire plan. 



Undo and Redo

 83

To use the Delete Objects dialog

1. Select Edit> Delete Objects  to open 
the Delete Objects dialog.

2. Specify the Delete Scope as Single 
Room or All Rooms On This Floor. 

3. In the Delete section, check the box for 
each category of objects you want to 
delete. Click Select All to check all the 
boxes or Clear All to uncheck all boxes.

4. When the scope is set to Single Room:

•  Move your cursor into the drawing area 
and click in a room of the plan to delete 
objects of the selected type within that 
room without closing the dialog. 

•  Continue clicking on rooms or choose a 
different Delete Scope.

•  Click Done when all selections have 
been deleted.

5. If you select All Rooms On This Floor, 
you do not need to click in floor plan 
view. The OK button becomes available, 
and clicking it closes the dialog and 
delete the specified objects. 

Deleting Polyline Edges
To remove an edge from a polyline, drag a 
corner handle until it overlaps an adjacent 
corner handle to remove the edge between 
them and merge them into a single handle. 
See “Reshaping Objects” on page 80.

Delete Surface
In any 3D view, select 3D> Delete 
Surface, then click a surface in the 

view to temporarily remove the surface from 
the current view without permanently 
affecting the object. See “Delete 3D Surface” 
on page 306.

Undo and Redo
The Undo and Redo commands 
allow you to both undo the last 

action performed, as well as redo actions that 
were recently Undone. 

The ten most recent actions can be Undone 
or Redone. Actions that can be Undone and 

Redone include creating, editing, and 
deleting objects. 

To Undo an action, select Edit> Undo , 

click the Undo  button, or press Ctrl + Z 
on your keyboard.
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The Redo command is only available 
immediately after Undo has been used. To 
Redo an Undone action, select Edit> 

Redo , click the Redo  button or press 
Ctrl + Y on your keyboard. 

It is important to note that Undo  and 

Redo  do not affect all actions in the 
program. Commands that are not affected 
include:

• Save and Save As. See “Saving a Plan 
File” on page 32. 

• Changes made in the Library Browser. 
See “The Library Browser” on page 266. 

• Changes made in a dialog while the dia-
log box is open. See “Dialogs” on page 
23.

• Changes made to the display by panning 
the display or zooming in or out. See 
“Undo Zoom” on page 292.
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Chapter 8:

Walls, Railings &
Fencing

Walls are the single most important building 
component in Home Designer Essentials. By 
creating walls and defining the rooms created 
by the walls, you are telling the program how 
you want the 3D model built.

There are several ways that walls can be 
created in Home Designer Essentials. The 
most common  is to simply draw them with 
the Wall Tools. 

In addition, exterior walls can be generated 
automatically when a new floor is built by 
using another floor as a model. For more, see 
“Adding Floors” on page 161.

Another feature that can be used to generate 
walls automatically is the House Wizard. 
See “House Wizard” on page 347.

Chapter Contents
•      Wall Defaults
•      The Wall Tools
•      The Deck Tools
•      The Fencing Tools
•      Exterior and Interior Walls
•      Foundation Walls
•      Railings
•      Invisible Walls
•      Hatch Wall
•      Break Wall
•      Drawing Walls
•      Connecting Walls
•      Displaying Walls
•      Measuring Walls
•      Editing Walls
•      Aligning Walls
•      Roof Directives in Walls
•      Attic Walls
•      Wall Type Definitions
•      Wall Specification Dialog
•      Wall Hatch Specification Dialog
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Wall Defaults
Default Settings can be accessed by 
selecting Edit> Default Settings. 

Click on “Walls” and click the Edit button to 
open the Wall Defaults dialog. 

The settings in the wall defaults dialogs 
determine what wall types are drawn when 
the different wall tools are used. It is a good 
idea to be familiar with these settings and 
how they relate to your style of building.

Exterior/Interior Wall Defaults Dialog
Specify which wall types are drawn using the 

Exterior  and Interior Wall  tools in 
the Exterior/Interior Wall Defaults dialog.

Exterior Wall Tool - From the drop-
down list, select the wall type drawn 

with the Exterior Wall  tool.  

Interior Wall Tool - From the drop-
down list, select the wall type drawn by 

the Interior Wall  tool. 

The Wall Tools
Select Build> Wall  to access the Wall Tools. 
The type of wall drawn by each wall tool is 

specified in its corresponding defaults 
dialog. 

1 

2

1 2
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The Curved Wall tools are similar to their 
corresponding Straight Wall Tools. Select 
Build> Curved Wall  to access these tools. 

Exterior Walls
The Exterior Wall and Curved 
Exterior Wall tools draw walls 

using the default wall type specified for 
exterior walls in the Exterior/Interior Wall 
Defaults dialog. See “Exterior and Interior 
Walls” on page 88.

Interior Walls
The Interior Wall and Curved 
Interior Wall tools draw walls 

using the wall type specified for interior 
walls. The interior wall type is defined in the 
Exterior/Interior Wall Defaults Defaults 
dialog. 

Railings
The Railing and Curved Railing 
tools create railings. See 

“Railings” on page 89.

Invisible Wall
Invisible Walls are walls used to 
define separate room areas in a plan. 

They can display in floor plan view but not in 
3D views. You can also convert a normal 
wall into an invisible wall and vice versa in 
the Wall Specification dialog. See “Invisible 
Walls” on page 90. 

Hatch Wall
The Hatch Wall tool applies a hatch 
pattern to a wall that displays in floor 

plan views. You must click the wall that you 
want to apply the hatch pattern to. You can 
then select the hatch and resize it if you want 
to only hatch a portion of a wall. See “Hatch 
Wall” on page 91.

Break Wall
The Break Wall tool applies a break 
in a wall. Once a wall is broken, the 

two wall segments are separate walls that can 
be modified independent of each other. See 
“Break Wall” on page 91.

The Deck Tools
Select Build> Deck to access the 
Deck Tools. When a room is defined 

using deck railing, its Room Type is 
automatically set to “Deck”. See “Decks” on 
page 116.

Note: Whether a wall is recognized as an
exterior or interior wall by the program is
determined by its position in the model, not
by the tool used to draw it. See “Exterior and
Interior Walls” on page 88.
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Deck Railing
The Straight Deck Railing and 
Curved Deck Railing tools draw 

decks, complete with framing and bounded 
by a railing. If a foundation level exists, 
supports for the deck are also created. See 
“Railings” on page 89.

Deck Edges
The Straight Deck Edge and 
Curved Deck Edge draw decks 

complete with framing, but without a railing. 
No deck supports are created. 

The Fencing Tools
Select Build> Fencing or click the 
Fencing Tools to access the fencing 

tools. 

The Fencing and Curved 
Fencing tools are used to draw 

fences, which are similar to railings but by 
default do not define room areas. Fencing is 
created and edited much like walls and 
railings, and normally used outside of a 
building.  

You can specify a fence panel style in the 
Fencing Specification dialog. See “Fence 
Style Tab” on page 106.

Exterior and Interior Walls
Most walls are drawn using either the 

Exterior Wall  or Interior Wall  tool. 
The only difference between these two tools 
is the wall type used. You can specify the 
default wall type for each tool in the Wall 
Defaults dialog. 

To draw a wall using a different wall type, 
you can change the default wall type for 

either tool in the Wall Defaults dialog. You 
can also draw a wall using the default type 
and then change the wall type in the Wall 
Specification dialog.

Whether a wall is recognized by the program 
as an actual exterior or interior wall is based 
on the model, not by which tool you use to 
draw the wall. Any wall that is entirely 
surrounded by interior room areas is 
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considered an interior wall. Any wall 
exposed to the outside of the building is 
considered an exterior wall.

Foundation Walls
Foundation walls are similar to the interior 
and exterior walls but also have a footing. 
Foundation walls created automatically when 
a foundation floor is created. See “Building a 
Foundation” on page 168. 

Railings
Railings are created and edited 
just like walls. See “Drawing 

Walls” on page 92.

Railings are ideal for a number of tasks:
• Creating changes in floor and/or ceiling 

height. See “Floor & Ceiling Heights” on 
page 117.

• Creating stairwells. See “Creating a Stair-
well” on page 196.

• Drawing decks. See “Decks” on page 116.
To produce a break in a railing for a stairway 

or other access, use a Doorway  . This 
keeps the railing continuous and maintains 
room definition. See “Room Definition” on 
page 110. 

When first drawn, railings are specified as 
No Locate, which prevents Auto Exterior 

Dimensions  from locating them. The No 
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Room Def attribute may also be helpful if 
you do not want a railing to divide an area 
into two separate rooms. See “General Tab” 
on page 102.

Newels and balusters do not display in floor 
plan view.

Railing Types
A variety of railing types can be specified in 
the Railing and Deck Railing Specification 

dialogs. See “Railing Tab” on page 104. 
Available types include:
• Baluster creates railings composed of 

newel posts, balusters, a railing, and an 
optional shoe. 

• Solid produces a framed railing wall, or 
Half Wall. 

• If Panels is selected, you can choose a 
Panel Type.

Invisible Walls
Invisible walls can display in floor 
plan view but not in 3D views. They 

are used to create or modify room definition, 
most often by defining smaller areas within 
larger rooms. See “Room Definition” on 
page 110. 

Invisible walls can also be used to define 
areas with different floor or ceiling materials 
or heights. 

Common uses for invisible walls include 
dividing areas of an open floor plan into 
areas with different purposes. 

An invisible wall can be turned into a normal 
wall, or vice versa, by clicking the Invisible 
check box in its Wall Specification dialog. 
See “General Tab” on page 102.

Invisible walls are are placed on the “Walls, 
Invisible” layer by default. A wall placed on 
a non-default layer and then specified as 
Invisible, however, will not move to the 
“Walls, Invisible” layer.  

Important Notes on 
Invisible Walls

• Floor, wall and ceiling areas are calcu-
lated separately for rooms divided by 
invisible and normal walls.

• Invisible walls are ignored by the Auto 

Place Outlets  tool; it functions as 
though they were not present. 

• Cabinets, fixtures and furniture can be 
moved freely through Invisible walls. 

• Invisible walls can be drawn through a 
cabinet to attach to the wall behind.

Invisible walls separate this dining area 
from adjacent rooms 
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Hatch Wall
The Hatch Wall tool can be used to 
fill wall segments with a single hatch 

pattern in floor plan view.  

To apply wall hatching, select Build> Wall> 

Hatch Wall , then click on a wall. The 
hatch pattern covers the entire length and 
width of the wall segment.

Hatch Wall  places a hatch pattern across 
all layers of the selected wall, covering any 
fill styles specified for that wall type.

Once created, wall hatching can be selected, 
edited and deleted much like other line-based 
objects. See “Editing Line Based Objects” on 
page 62.

If you use the Hatch Wall  tool to apply a 
hatch pattern to a wall that has been divided 
into multiple segments using the Break 

Wall  tool, the pattern is only applied to 
the segment that you clicked on . See “Break 
Wall” on page 91.

Like doors and windows, wall hatching 
cannot extend across multiple wall segments. 
Unlike these objects, hatching cannot be 
located by dimension lines.

The wall hatch pattern can be specified in the 
Wall Hatch Specification dialog. See “Wall 
Hatch Specification Dialog” on page 107. 

When editing or deleting wall hatching, 
make sure that it is selected rather than the 
wall by noting that “Wall Hatching” displays 
in the Status Bar. See “The Status Bar” on 
page 24. 

Break Wall
To divide a wall or railing, select  
Build> Wall> Break Wall and click 

on the wall. The wall is divided into two wall 
sections at the point where you click. 

The Break Wall  tool remains active, so 
you can continue to place breaks in walls. 
When you are finished, select a different 
tool.

If a wall break is placed near the intersection 
of two walls, the break is positioned at the 
center of the intersection. 

Once a break is placed, click the Select 

Objects  tool and select the original wall. 
If edit handles display near the break, the 
wall was correctly broken.

Walls separated by a break can be rejoined. 
Select one of the segments, then click on the 
end edit handle located at the break and drag 
it a few plan inches (mm) away from the 
break. See “Connecting Walls” on page 93.

The Break Wall  tool can be used to 
create aligned walls on either side of a gap. 
See “Creating a Nook” on page 99.

Note: The Hatch Wall tool cannot be used to
apply a hatch pattern to Invisible Walls. See
“Invisible Walls” on page 90.
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Drawing Walls
Walls are drawn by clicking and dragging 
from end to end and can be drawn in floor 
plan view, camera views, and overviews. 

Drawing walls to create a floor plan is simple 
if you keep a few things in mind: 
• Draw exterior walls first to define the 

building’s footprint, then draw the interior 
walls after the perimeter is in place. 

• It is easiest to draw walls at the approxi-
mate location and length needed and then 
move or resize them precisely using 
dimensions later. See “Moving Objects 
Using Dimensions” on page 331. 

• As walls are drawn, “sticky” points iden-
tify points that are either collinear or 
orthogonal to the end points of other 
walls, making alignment easier. See 
“Extension Snaps” on page 53. 

• When walls enclose an area to form a 
room, the program will orient all exterior 
walls so that the siding material faces out-
ward. 

• To flip the layers of a wall after it is 
drawn, select it and click the Reverse 

Layers  edit button. See “Editing 
Walls” on page 96.

• Initial wall heights are determined by the 
default floor and ceiling heights of the 
current floor.

Wall Positioning
The recommended method of drawing walls 
is to draw them at their approximate location 
and length, then move them into position 

with accuracy using dimensions. To make 
this task quick and efficient: 
• Notice the temporary wall that displays as 

you draw. Its length and angle display in 
the Status Bar at the bottom of the win-
dow and adjust as you move the mouse. 
Release the mouse button to draw the wall 
at the displayed length and angle. See 
“The Status Bar” on page 24. 

• Use Snaps to help ensure proper wall 
alignment and orientation. See “Snap 
Behaviors” on page 52. 

Once walls are drawn, they can be accurately 
dimensioned and moved as needed. See 
“Measuring Walls” on page 95. 

Wall Openings
To create a door or doorway, do not draw 
wall sections with a gap between them. Walls 
should be drawn to completely enclose 
rooms, and then door and window objects 
should be placed in the walls to create 
openings later. See “Doors” on page 127 and 
“Windows” on page 143. 

Masonry fireplaces placed in walls are also 
considered to be wall openings. See 
“Fireplaces” on page 259.

Temporary Dimensions
Temporary dimensions will display along the 
length of a wall as it is drawn, helping you 
draw walls to the desired length. Although 
dimensions display as you are drawing, you 
do not need to position walls precisely when 
you first draw them: they can be easily 
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moved into place at any time. See “Editing 
Walls” on page 96. 

 Drawing Curved Walls
To draw a curved wall or railing, select a 
curved wall tool, click at the point where you 
would like the wall to begin, then drag along 
the desired curve. Release the mouse button 
to create the wall.

A straight wall can also be converted into a 
curved wall and vice versa using the Change 

Line/Arc  edit button. See “Change Line/
Arc” on page 81.

House Wizard
The House Wizard allows you to place 
and arrange room “objects” that can 

then be converted into a fully editable house 
plan, including walls. See “House Wizard” 
on page 347.

Connecting Walls
When walls are drawn sufficiently close to 
one another, they will snap together to form 
an intersection. This snapping occurs when 
the walls’ center lines are within a distance 
defined by the larger of the two walls’ widths 
and will occur even when Object Snaps are 
turned off. See “Object Snaps” on page 52.

If the two walls in question have the same 
wall type and identical specifications, and 
are collinear, they will merge to become a 
single wall. See “Aligning Collinear Walls” 
on page 98.  

When three or more walls connect to form a 
completely enclosed area, that area defines a 
room. See “Rooms” on page 109.

When walls snap together to form an 
intersection and Object Snaps are enabled, 
the program joins them at theirMain Layers. 
See “Aligning Walls” on page 98. 
• The wall that is being drawn or edited will 

move, lengthen, or shorten slightly to 
meet the other wall. 

• The other wall will not move; however, 
its length may be affected. 

Removing Wall Breaks

The Break Wall  tool allows you to break 
a wall into two or more separate wall 
segments. See “Break Wall” on page 91.

To merge two collinear walls separated by a 
break,select one of the segments, then click 
on the end edit handle located at the break 
and drag it a few plan inches (mm) away 
from the break. 

If the two walls do not merge, either one or 
both walls have been moved and they are no 
longer collinear, or one or both has been 
edited in some way and they are no longer 
identical. Open the Wall Specification 
dialog for each wall and determine how they 
differ. See “Wall Hatch Specification 
Dialog” on page 107.

To create a room in the shape of a cir-
cle, you must draw two curved walls.
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Displaying Walls
The display of walls in all views is 
controlled in the Display Options 

dialog. See “Displaying Objects” on page 48.

If a “Walls” layer is turned off, any doors and 
windows placed in walls on that layer will 
not display, either. See “Displaying Doors” 
on page 130 and “Displaying Windows” on 
page 148.

In Floor Plan View
There are several options for controlling how 
walls are displayed in floor plan view. In the 
Display Options dialog, you can specify 
whether or not various types of walls display. 
Walls are placed on layers with “Walls” at 
the beginning of the layer name, such as 
“Walls, Normal”. 

It is sometimes helpful to display the walls 
from a floor other than the current floor. To 
do this, select and display a reference floor. 
See “The Reference Floor” on page 165. 

In 3D Views
As in floor plan view, the display of walls 
can be controlled by layer in the Display 
Options dialog. 

While most architectural objects in the 
program can display in both floor plan and 
3D views, a few cannot. Invisible walls and 
wall hatching are examples of objects that do 
not display in 3D.

Wall Materials
There are several ways that materials can be 
assigned to walls. See “Rooms” on page 109. 

When you draw a wall, it uses the. 

You can change the surface material of an 
individual wall in the Wall Specification 
dialog. If you select “Use Default” as the 
material and the wall is used to define a 
room, the program refers to the material 
specified in the Room Specification dialog. 
See “Wall Specification Dialog” on page 
102.

You can also change a room’s wall material 
in the Room Specification dialog. See 
“Materials Tab” on page 284. To restore the 
default Wall Type material, select Use 
Default in the Select Library Object dialog. 
See “Select Library Object Dialog” on page 
276. 

Note: In floor plan view, railings not specified
as Solid display their Main Layer regardless
of whether “Walls, Layers” or “Walls, Main
Layer Only” is turned on.  

Note: Wall materials that are specified on the
Materials tab of either the Wall or Room
Specification dialog are not calculated in the
Materials List.
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Measuring Walls
Accurate wall measurements are an essential 
aspect of any drawing, and can be achieved 
by following two basic rules:
• Be aware of what part of a wall assembly 

dimensions are locating;
• Position walls using dimensions rather 

than edit handles or edit tools.

These rules can easily be met when you keep 
the following recommendations in mind.

Use Dimension Defaults
Dimensions can be set to locate walls at their 
Main Layers or at surfaces. Before drawing 
dimensions - and particularly, before using 
them to move your walls into position - make 
sure that your Dimension Defaults are set up 
to meet your needs. See “Dimension 
Defaults Dialog” on page 323.

Edit Dimension Lines
Once a dimension line has been drawn, its 
extension lines can be edited to locate a 
number of locations on a wall assembly:
• The exterior surface
• The Main Layer’s exterior
• The center line of the wall assembly
• The Main Layer’s center line
• The Main Layer’s interior
• The interior surface

See “Editing Extension Lines” on page 330. 

Move Walls Using Dimensions
By far, the most precise method of 
positioning walls is using dimension lines. 
To produce accurate measurements, 
remember to:
• Be aware of what part of your walls is 

being located by dimensions.
• Avoid specifying dimension values with 

greater accuracy than your dimensions are 
set to display. See “Format Tab” on page 
325. 

See “Using Dimensions” on page 97.

Use Object, Angle and 
Grid Snaps

Object Snaps, Angle Snaps, and Grid Snaps 
make it easier to align walls when they are 
being drawn as well as when they are edited. 
See “Snap Behaviors” on page 52. 

Object Snaps help to ensure consistent wall 
connections and are particularly helpful 
when aligning collinear walls. 

When Grid Snaps are enabled, walls are 
drawn on a regularly spaced grid, which 
helps avoid inaccurate wall placement. This 
can become particularly important if you 
forego positioning walls using dimensions in 
favor of using edit handles to move them. 

Angle Snaps make it easy to accurately draw 
walls at regular angles, ensuring walls that 
are truly parallel or perpendicular to one 
another and separated by consistent 
distances.
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Editing Walls
Walls can be selected individually and as a 
group in all views. When a wall is selected, it 
displays edit handles and an edit toolbar that 
can be used to edit it in various ways. When 
a wall is selected, temporary dimensions will 
also display.

The ways in which a wall can be edited 
depends on the current view and which edge 
is selected. See “Selecting Objects” on page 
60. 

Selecting Walls
• When you try to select a wall in a Cross 

Section/Elevation or 3D view, the interior 
or exterior room that it defines may be 
selected first. Click the Select Next 

Object  edit button or press the Tab 
key on your keyboard to select the wall 
itself. 

• In floor plan view, if wall hatching has 
been applied to a wall using the Hatch 

Wall  tool, the hatching may be 
selected first. Click Select Next 

Object  to select the wall itself. See 
“Hatch Wall” on page 91.

Using the Edit Handles
Depending on the type of view, a wall 
displays a different set of edit handles when 
selected. 
• In floor plan view, straight and curved 

walls can be edited like other line- and 
arc-based objects. See “Editing Line 

Based Objects” on page 62 and “Editing 
Arc Based Objects” on page 64.

• In a camera view or overview, click on the 
top surface of a wall to display the same 
edit handles as in floor plan view, allow-
ing you to rotate, move, and extend or 
shorten the length of the wall. 

• Moving a wall in any view will move any 
cabinets attached to that wall, as well.

• In a cross section/elevation view, the side 
edges of straight walls can be moved to 
shorten or lengthen the segment. Curved 
walls can be shortened in this manner, but 
not lengthened.

• In a camera view or overview, click on an 
interior or exterior surface to display an 
edit handle at the center of each side edge, 
allowing you to shorten or lengthen the 
wall. Curved walls can be shortened in 
this manner, but not lengthened.

• When a wall is connected to other walls  it 
can only be moved perpendicular to itself 
or, in the case of curved walls, perpendic-
ular to its chord using the Move edit han-
dle. 

In the Specification Dialog
The appearance and structure of walls 
can be customized in the Wall 

Specification dialog. See “Wall 
Specification Dialog” on page 102.

The characteristics of the roof directly above 
a selected wall can also be specified in the 
Wall Specification dialog. See “Roof Tab” 
on page 103.
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Using the Edit Tools
A selected wall or walls can be edited in a 
variety of ways using the buttons on the edit 
toolbar. See “The Edit Toolbar” on page 22.

The characteristics of the roof directly above 
a selected wall can also be specified in the 
Wall Specification dialog. See “Roof Tab” 
on page 103.

Using Dimensions
Automatic, manually-drawn, and 
temporary dimension lines can be 

used to both resize and move walls with 
accuracy. Select a wall, then click on a 
dimension line that locates it. See “Moving 
Objects Using Dimensions” on page 331.

When a wall is resized using dimensions, the 
inline text field used to edit the dimension 
will have three unique buttons: Move Start, 
Move End and Move Both Ends. 

Depending on your Dimension Defaults 
settings, dimension lines may locate wall 
surfaces or Main Layers. See “Dimension 
Defaults Dialog” on page 323.

Wall Thickness
The initial thickness of a wall is determined 
by its wall type. 

You can specify a selected wall’s thickness in 
its Wall Specification dialog. See “General 
Tab” on page 102. 

If a selected wall’s thickness is changed: 
• A copy of the wall’s wall type is created 

with the same name but appended with a 
number equal to the thickness of the 
structural layer, and that new type is 
assigned to the wall.

• The change in thickness will be applied to 
new wall type’s structural layer. 

• The structural layer must be at least 1/16” 
thick, and the wall’s thickness cannot be 
less than the original wall type’s total 
thickness minus the thickness of its struc-
tural layer.  

If a wall type’s thickness is modified, the 
wall will resize about the outside edge of its 
Main Layer. In some instances, the wall may 
appear to move as a result of changes made 
to the thicknesses of its layers.

Wall Heights
The height of a wall is controlled by the 
ceiling height of the room(s) it defines. If the 
ceiling or floor height of a room is changed, 
the height of the walls that define it also 
change. 
• The ceiling heights for all rooms on a 

floor are controlled in the Room Defaults 
dialog for that floor. See “Floor and Room 
Defaults” on page 110. Whenever possi-
ble, it is best to set all ceiling heights 
using the defaults.

• The ceiling height of a single room can be 
set in its Room Specification dialog. See 
“General Tab” on page 120.

Wall Length
Wall length can be modified in several 
different ways: 

Move Both Ends

Move Start       Move End
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• Using dimensions. See “Measuring 
Walls” on page 95.

• In the Wall Specification dialog. See 
“General Tab” on page 102.

• By dragging the end edit handles. See 
“Editing Line Based Objects” on page 62 
and “Editing Arc Based Objects” on page 
64. 

Bear in mind that if you try to resize a wall 
by a small amount using one of its edit 
handles and that wall is connected to another 

wall at that end, its length will not change 
because its end will snap back to the existing 
intersection. See “Connecting Walls” on 
page 93. 

The most accurate way to specify wall length 
is using dimensions. By default, wall length 
is measured at the outside edge of the Main 
Layer. You can instead specify that 
dimension lines locate surfaces in the 
Dimension Defaults dialog. See “Dimension 
Defaults Dialog” on page 323.

Editing Straight/Curved Wall Combinations
If you move a straight wall connected to a 
curved wall with a locked center, the curved 
wall extends along its curve and the straight 
wall will either lengthen or shorten as needed 
to stay connected to the curved wall. 

If the connection between the straight and 
curved wall cannot be maintained because of 
the curved wall’s radius, it will be broken.

Aligning Walls
Wall alignment refers to the way wall 
segments line up with one another, either on 
the same floor or on the floor above or 
below.  Walls may need to be aligned in a 
variety of situations.

To make alignment easier when drawing or 
resizing walls, “sticky” points identify points 
that are either collinear or orthogonal to the 
end points of other walls. See “Extension 
Snaps” on page 53. 

Aligning Collinear Walls
Collinear walls are parallel walls connected 
end to end and drawn on the same floor. 
When collinear walls join end-to-end, the 
walls snap together. If these walls have the 
same wall type and identical specifications, 
and if Object Snaps are enabled, they will 
merge to become a single wall segment.
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Creating a Nook
Walls can be aligned across an opening such 
as a nook, so that they are collinear, using the 

Break Wall  tool. 

To align walls across  a gap

1. Select a wall to build a nook into and 

click the Break Wall  edit button. 
2. Click at a point on the wall close to one 

side of the nook area. Do not worry 
about exact placement right now. 

3. Click again near the other side of the 
nook. Two short lines at each location 
where you clicked indicate Wall Breaks. 

4. Right-click the middle section of the 
wall to select the wall section. 

5. Click the middle Move handle and drag 
the wall outward. 

6. Draw side walls to connect the wall back 
to the rest of the house. 

7. Move these short walls using dimen-
sions to accurately size the nook. 

Aligning Walls 
Between Floors

Walls can be aligned between floors by 

clicking the Align With Wall Above  and 

Align With Wall Below  edit buttons.

To align walls between floors

1. Select a wall that you want to align with 
another wall either above or below it.

2. If the wall is above or below the other 
wall along only part of its length, you 
must click on it along that part. Select 
Tools> Reference Floors> Reference 

Display On  to help make sure you 
click on the correct part of the wall.

3. When you have selected the wall at the 
desired location, click either the Align 

With Wall Above  or Align With 

Wall Below  edit button.

Aligning Curved Walls 
Between Floors

Curved walls are aligned between floors 
using the same technique to align straight 
walls. If the centers and radii of the walls are 
within a few inches of each other, the Align 

With Wall Above  and Align With Wall 

Below  edit buttons are enabled for the 
selected wall. The selected curved wall will 
take on the radius and center of the 
referenced wall when the walls are aligned.

Place Wall 
Breaks here

Position these 
walls as needed

In order for these edit tools to be avail-
able, the areas of the walls in question

must be partially aligned, or overlapping.
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Roof Directives in Walls
To automatically generate a roof plane using 
values other than the defaults or to not 
generate a roof plane bearing on a particular 
wall (as for a gable or the sides of a shed 
roof), you can change the settings in the Wall 
Specification dialog. See “Roof Tab” on 
page 103. 

Hip, Gable, and Shed Roofs
By default, the program will produce a roof 
plane over each exterior wall to create a hip 
roof. You can instead specify a gable or shed 
roof above the selected wall. 
• Check Full Gable Wall to create a gable 

with a ridge centered above the selected 
wall(s).

• Check High Shed/Gable Wall for the 
side walls or the wall under the high side 
of a shed roof.  

• You can also select a  wall and click the 

Change to Gable Wall(s)  edit button, 
or change it back by clicking the Change 

to Hip Wall(s)  edit button. 

Pitch
The default pitch for roof planes is set in the 
Build Roof dialog. However, any exterior 
wall can define the pitch of the roof plane 
built above it.

You can also specify a second, upper pitch 
above a given wall. Mansard, gambrel, gull 
wing and half-hip are examples of roof styles 
that use two pitches. See “Roof Tutorial” on 
page 61 of the User’s Guide.

Extend Slope Downward
Check Extend Slope Downward to extend 
the roof plane downward over a bumpout, 
instead of creating additional roof planes. 
The two connecting walls that create the 
bumpout must be Full Gable walls.

In the following image, the bearing wall of 
the bumpout has Extend Slope Downward 
checked. The two short side walls are Full 
Gable Walls. 

Before

After

Full Gable 
Wall

Extend Slope 
Downward
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Attic Walls
In Home Designer Essentials, walls are built 
between the floor and ceiling platforms of 
the current floor.  See “Floor & Ceiling 
Heights” on page 117. When the program 
detects an open space between a wall and the 
roof plane above it, it automatically creates 
an Attic Wall on the floor above that wall to 
fill in the gap. 

Attic Walls are typically found above Full 
Gable Walls, forming a gable or closing the 
top portion of a side wall beneath a shed 
roof. They are also generated above all 
exterior walls when the Raise Off Plate 
value in the Build Roof dialog is 3” (175 
mm) or greater. See “Build Roof Dialog” on 
page 177. 

Attic walls are often found on the Attic floor, 
but can be generated on other floors, as well. 
See “The Attic Floor” on page 165. 

Knee Walls
Knee Walls are a bit like Attic Walls in that 
they are not meant to generate to full ceiling 
height. Instead, they build upward until they 
encounter a roof plane. Unlike Attic Walls, 
however, Knee Walls are used in the interior 
of a structure, typically to separate unused 
areas from rooms on the upper floor of a 
story-and-a-half structure. See “Room 
Types” on page 113.

Home Designer Essentials does not specify 
walls as Knee Walls automatically. If an 
interior wall is drawn in a location where the 
roof is lower than the ceiling height, you 
should specify it as a Knee Wall in the Wall 
Specification dialog. See “Roof Tab” on 
page 103.

Wall Type Definitions
Every wall drawn in a plan is assigned a wall 
type, and its Wall Type Definition determines 
its structure, its appearance in floor plan 
view, and its default materials. 

You can specify the default wall types used 
when walls are first created, and can specify 
the wall type of any wall after it is drawn in 
the Wall Specification dialog. See “Wall 
Defaults” on page 86 and “General Tab” on 
page 102.

The structural layer of a wall type is its Main 
Layer, which controls a number of things:

• At intersections, walls join at the interior 
surfaces of their Main Layers. See “Con-
necting Walls” on page 93. 

• Exterior walls on different floors are 
aligned by the exterior edges of their 
Main Layers. 

• Roof baselines are placed at the outer 
edge of the Main Layer.

If you do not want to keep a particular
Attic Wall in your plan, specify it as

Invisible. See “Invisible Walls” on page 90.
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• Walls resize about the exterior surface of 
their Main Layer when their wall type is 
changed.

• Object Snaps locate the exterior surface 
of a wall’s Main Layer. See “Object 
Snaps” on page 52. 

• By default, dimension lines locate walls at 
their Main Layer. See “Dimension 
Defaults Dialog” on page 323. 

Interior and Exterior Surfaces
Every wall has an interior and exterior 
surface - including walls in a plan that are 

recognized by the program as being interior 
walls. See “Exterior and Interior Walls” on 
page 88.

Having separate designations for a wall’s two 
surfaces allows you to specify different 
materials for each in the Wall Specification 
dialog. See “Materials Tab” on page 106.

In floor plan view, you can identify a 
selected wall’s exterior surface by the 
location of its edit handles, which display on 
the exterior of the Main Layer.

Wall Specification Dialog
To open the Wall Specification 
dialog, select a wall or group of walls 

and click the Open Object edit button. 

The tabs of the Wall Specification dialog are 
also found in the Railing, Deck Railing, and 
Fencing Specification dialogs. 

General Tab

1

3

4

5
2
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Some items on the General tab are available 
only when they apply to the selected wall or 
railing.

The Thickness of the selected wall 
displays and can be changed here. If the 

wall is a Post to Overhead Beam railing, this 
setting also affects the width of the beam. 
See “Wall Thickness” on page 97. 

Specify the Wall Angle and Wall 
Length of a straight wall. These 

options are not available for curved walls.
• Wall Angle - The current absolute angle 

of the wall in a floor plan view is shown. 
Type in a new angle to rotate the wall 
about its locked point.

• Wall Length - The current length is 
shown. Type in a new length. The part of 
the wall that extends or contracts is deter-
mined by where it is locked.

Check any of the Options to modify the 
selected wall accordingly. In most 

cases, multiple options can be selected. Not 
available for fencing. 
•  Select No Room Def. to display the wall 

in floor plan and/or 3D views but not cre-
ate room definition. See “Room Defini-
tion” on page 110.

• Select No Locate to prevent Auto Exte-
rior Dimensions from locating a wall. 
Railings have No Locate selected by 
default. See “Auto Exterior Dimensions” 
on page 327.

• Select Beam to have the wall display as 
two lines in floor plan view and a beam in 
3D views. 

The Wall Type drop-down allows you 
to change the type of the wall currently 

selected to any of the available options.  Its 
graphic representation in the upper right 
corner will update to reflect the wall type that 
is currently selected. Not available for 
fencing. 

A preview diagram of the selected wall 
type displays here.

Roof Tab
Any automatically generated roof style other 
than a hip requires roof information to be 
defined in the exterior walls. On the Roof 
tab, you can specify how the selected wall 
interacts with the roof plan, defining the 
portion of the roof plan that bears on it..

The Roof tab is not available for Foundation 
Walls or Fencing. See “Foundation Walls” on 
page 89 and “The Fencing Tools” on page 
88. 

1

2

3

4

5
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Roof Options - Specify the shape of 
the wall relative to the roof.

• Check Full Gable Wall to create a gable 
end over the selected wall. 

• Check High Shed/Gable Wall to specify 
the selected wall as the high end of a shed 
roof. 

• Check Knee Wall to define the selected 
interior wall as a knee wall. Only an inte-
rior wall can be defined as a knee wall. A 
knee wall’s height is defined by the roof 
above, not the ceiling height. See “Knee 
Walls” on page 101.

• Check Extend Slope Downward to con-
tinue a roof down over a bumpout in an 

exterior wall. See “Extend Slope Down-
ward” on page 100.

Pitch Options - Specify the pitch or 
pitches of the roof plane(s) above the 

selected wall.
• Enter a value to define the Pitch of the 

roof plane bearing on the selected wall. 
• Check Upper Pitch to create a roof with 

two pitches or, if the selected wall is a 
Full Gable Wall, a half hip condition.

• Enter the Pitch of the second, upper roof.
• Specify the Height that the Upper Pitch 

Starts at, or define the distance in from 
Baseline that the second pitch begins. The 
two values are dynamic. Press the Tab key 
to update the relative numbers.

Railing Tab
The Railing tab is only available for Railings 
and Deck Railings. See “Railings” on page 
89 and “The Deck Tools” on page 87.

1

2

1

2



Wall Specification Dialog

 105

Railing Type - Select the radio button 
for the desired railing type. A preview 

of the selected type displays to the left.
• Balusters - Create balusters. 
• Solid - Create a solid, wall style railing. 

The wall is the type defined by the current 
wall layer definition. 

• Open - Create a railing with only a top 
rail.

• Middle Rail - Create a railing with a top 
and a middle rail.

• No Rail - Eliminate rails, leaving only 
posts (and overhead beam, if selected). 

• Panels - Create a solid panel.

Post Type - Select the check box for 
the desired post type.

• Post to Rail - Create newel posts from 
floor to rail height. This option is selected 
by default.

• Post to Overhead Beam - Create newel 
posts from floor to an overhead beam 
placed just under the ceiling height. The 
beam’s width is based on the Thickness of 
the selected railing wall. 

• Post to Ceiling - Extend the newel posts 
to the ceiling.

Shoe Options - Select the check box for the 
desired placement of the bottom rail, or shoe. 
If neither box is checked, the shoe is placed 
at floor platform level.
• Raise Shoe - Raise the shoe 3½” (87 mm) 

off the floor platform.
• No Shoe - Eliminate the shoe altogether. 

Balusters go right to the floor.

Railing Height - Specify the height of 
the railing in inches. Not available if 

Post to Rail, Post to Overhead Beam, or Post 
to Ceiling is selected.

Baluster Spacing - Specify the 
distance between balusters in inches.

1 2

3
4

5

6
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Newel Height and Newel Spacing - 
Specify the height and distance 

between newels.

A preview of the railing displays here 
and updates as options are changed.

Fence Style Tab
The Fence Style Tab is only available when a 
Fence object is selected. See “The Fencing 
Tools” on page 88.

Specify the size of the fencing 
components.

• Specify the overall Fence Height, from 
the ground to the top.

• Specify the Post Height, which can be 
greater than, less than, or the same as the 
overall Fence Height.

• Specify the Post Spacing, which is the 
distance from the center of one post to the 
next.  

Click the Fencing Library button to 
specify a style of fence panel from the 

library. See “Select Library Object Dialog” 
on page 276.

Check Large Posts/Pillars for the 
selected fencing to have posts that are 

50% wider than the selected fencing’s 
Thickness value. When unchecked, the posts 
are the same width as the Thickness.  

Materials Tab
All walls have an “Exterior Wall Surface” 
and an “Interior Wall Surface”, including 
interior walls. See “Interior and Exterior 
Surfaces” on page 102. 

5 6
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The materials specified on the Materials tab 
affect the appearance of walls in 3D views 
but are not calculated in the Materials List. 
See “Materials Lists” on page 373. 

The Materials tab is available for a variety of 
objects. See “Materials Tab” on page 284.

Wall Hatch Specification Dialog 
To open the Wall Hatch Specification 
dialog, select a Wall Hatch and click 

the Open Object edit button. See “Hatch 
Wall” on page 91.

• Choose a Fill Pattern from the drop-
down list.  A preview of the selected pat-
tern displays to the right.

The options that follow are disabled until 

you select a pattern other than None from 
the Fill Pattern drop-down list.

• Define the Spacing for the selected fill 
pattern. Hatch spacing set at 12" matches 
grid/reference spacing set at 12".

• Check Transparent Pattern Fill to make 
the fill pattern transparent. When you 
check this option, any objects behind the 
fill pattern are visible through it. 

•  Fill Color - Click the color bar to select a 
color for the fill pattern lines or fill color 
if a solid fill is specified. This overrides 
the layer color. See “Color Chooser Dia-
log” on page 290.

•  Choose a Preview Width from the drop-
down list. This value controls how large 
an area the preview represents. The 
selected value indicates the length of each 
side of the preview in plan inches (mm).
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Chapter 9:

Rooms

When walls or railings create an enclosed 
area, a “room” is created. You can select 
rooms defined in this manner like other 
objects in Home Designer Essentials.

Rooms are assigned a Room Type. Each 
Room Type has predefined characteristics. 
For example, a room defined as Porch is 
assigned certain attributes that are different 
than a Kitchen. 

Floor and ceiling heights, baseboard, chair-
rail, and crown moldings and materials can 
be defined room-by-room or for the entire 
floor.

Chapter Contents
•      Floor and Room Defaults
•      Room Definition
•      Selecting Rooms
•      Displaying Rooms
•      Editing Rooms
•      Room Types
•      Room Labels
•      Decks
•      Floor & Ceiling Heights
•      Special Ceilings
•      Room Specification Dialog
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Floor and Room Defaults
Select Edit> Default Settings to open 
the Default Settings dialog where 

you can access several defaults dialogs 
which directly affect rooms. 

Floor Defaults
Default values for rooms are specified in the 
Floor Defaults dialog for the current floor. 
This dialog also controls important 
information that the program uses to create 
3D models - particularly floor and ceiling 
heights and materials. Moldings can also be 
specified in the Floor Defaults dialog. 

Only the defaults for the first floor of a 
building can be set ahead of time. The 
program uses the setting from the first floor 
to create subsequent floors. Once a new floor 
is built, its floor defaults can be changed. See 
“Floor Defaults Dialog” on page 160.

Room Defaults
Additional defaults for several categories of 
rooms can also be specified:
• Normal Rooms
• Kitchens/Baths/Utility Rooms
• Decks
• Garage/Porches/Slabs

These Room Defaults dialogs are accessed 
by expanding the “Rooms” category in the 
Default Settings dialog. Select a room type 
and click the Edit button to open the defaults 
dialog for that room type. The settings in 
these dialogs are limited to material 
assignments and apply to all rooms assigned 
a particular room type.

If a room is assigned one of these room 
types, it uses the defaults associated with that 
type. 

If a room type has not been assigned, the 
room uses the materials specified in the 
Floor Defaults dialog. 

Room Definition
A room is a totally enclosed area defined by 
any combination of joined walls or railings, 
visible or invisible. To be recognized as a 
room by Home Designer Essentials, a room 
must have an unbroken perimeter.

Unless otherwise specified, rooms generate 
floor and ceiling platforms automatically. 
Most rooms are also automatically covered 
by the roof when one is built. There are 

exceptions to this, such as rooms defined as 
Decks. See “Room Types” on page 113.

If a room is drawn within a larger structure 
and none of its walls connect to the exterior 
walls, either directly or indirectly by 
connecting to walls that do, the program will 
connect such a room to the larger structure 
with an Invisible Wall. See “Invisible Walls” 
on page 90.
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Room definition disappears if part or all of a 
surrounding wall is deleted. It is a good idea 
to finalize the position of walls before 
defining rooms with names and attributes 
such as floor height and ceiling height.

Subdividing Rooms
When a room area is first defined, it inherits 
its characteristics from the Floor Defaults 

dialog for that floor. If the room is then 
specified as a particular type, it may inherit 
material settings from the appropriate Room 
Defaults dialog. 

If a new room is created by subdividing a 
larger room, it inherits its characteristics 
from that larger room - including any non-
default settings.  

Selecting Rooms
Room definition is established when a room 
is completely enclosed by walls. You can 
confirm that a room has room definition by 

using the Select Objects  tool to select it. 
When a fully-enclosed room is selected, the 
room highlights. 

The Exterior Room
You can also select the exterior of a model. 
This allows you to control the building’s 
exterior wall coverings and materials using 
the Room Specification dialog. 

Click just outside an exterior wall using the 

Select Objects  tool to select the Exterior 
Room. When it is selected, a highlighted 

band around the plan’s exterior displays. 
This band represents the selection area for 
the Exterior Room.

In camera views and overviews, the Exterior 
Room can be selected by clicking on the 
exterior surface of an exterior wall using the 

Select Objects  tool.

In 3D Views
Click on the floor of a room or on a wall 
surface inside the room in a 3D or cross 

section view using the Select Objects  
tool. If you select another object instead of 

The room at left is selected

The Exterior Room is selected
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the room, click Select Next Object  edit 
button or press the Tab key until the room is 
selected. The Status Bar indicates which 
object is currently selected.

In camera views and overviews, the Exterior 
Room can be selected by clicking once on 

the exterior surface of an exterior wall using 

the Select Objects  tool. 

Displaying Rooms
Unlike most things in Home Designer 
Essentials, a room is not an individual object. 
Rather, a room is defined by the walls that 
enclose it.

In Floor Plan View
Rooms typically display a transparent fill in 
floor plan view. You can, however, specify a 
solid color or fill pattern for individual rooms 
in the Room Specification dialog. See “Fill 
Style Tab” on page 124.

In order for room fill styles to display, the 
“Rooms” layer must be turned on. See 
“Displaying Objects” on page 48. 

Room labels that include the room’s name as 
well as its size and other information can be 
set to display in floor plan view. See “Room 
Labels” on page 115. 

In 3D Views
Rooms can be viewed in 3D views created by 
any of the 3D view tools. The Dollhouse 
View tool can be used to see all rooms on the 
current floor without their ceilings. See 
“Creating Overviews” on page 303.

Editing Rooms
Once a room is defined by walls or railings, 
its structure and appearance can be edited 
using the edit buttons or the Room 
Specification dialog. 

In 3D Views
The floor and ceiling heights for floors and 
rooms can be edited using edit handles in 3D 
views. Lowered ceilings cannot be edited in 
3D. See “3D Views” on page 299. 

The default floor and ceiling heights for an 
entire model can be edited by selecting the 
Exterior Room. See “The Exterior Room” on 
page 111.

To change default ceiling heights in 3D

1. Create a 3D or Cross Section/Elevation 
view of the exterior of your plan. 

2. Click on the exterior surface of a wall to 
select the Exterior Room. The Status Bar 

Note: If the wall height of the Exterior Room
is adjusted in a 3D view, the default Floor or
Ceiling Height of the entire floor is changed.
See “Floor and Room Defaults” on page 110.
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indicates when the exterior room is 
selected. See “The Exterior Room” on 
page 111.

3. Click and drag the edit handle on the top 
wall edge to adjust the default ceiling 
height, or the edit handle on the bottom 
edge to adjust the default floor height. 
Temporary dimensions display.

To adjust room heights in 3D

1. Create a 3D or Cross Section/Elevation 
view of your plan.

2. Click on the surface of a wall that faces 
the room to select it. When the room is 
selected in 3D:

•  The room highlights. 

•  The Status Bar says “Room”. See “The 
Status Bar” on page 24.

•  Two edit handles display on the top and 
bottom edges of the highlighted wall.

3. Click and drag the edit handle on the top 
wall edge to adjust the room ceiling 
height, or the handle on the bottom edge 
to adjust its floor height. Temporary 
dimensions display.

4. As you drag a handle, notice that all 
walls defining that room are affected.

Room materials such as floor, ceiling, and 
wall materials can be changed in 3D views 

using the Material Painter . See “The 
Material Painter” on page 282.

In the Specification Dialog
Floor and ceiling heights, floor 
platform structure, moldings, and 

materials can all be specified in the Room 
Specification dialog. See “Room 
Specification Dialog” on page 120.

Room Types
When a room is first created by enclosing an 
area with walls, it is assigned a generic room 
type of “Unspecified.” 

Once your floor plan is laid out, each room 
should be assigned a Room Type in the 
Room Specification dialog. See “General 
Tab” on page 120. The Room Type applies 
appropriate structural and display properties 
to the room. 

When you assign a Room Type, a label 
showing the room’s Type displays in floor 
plan view.

You can edit the text of a room label in floor 
plan view, but the type of room originally 
assigned remains until it is changed in the 
Room Specification dialog. See “Editing 
Room Labels” on page 115.

Available Room Types
There are three categories of room types: 
Interior, Exterior and Hybrid.

Interior - Living, Dining, Family, Kitchen, 
Nook, Bath, Master Bath, Master Bedrm, 
Bedroom, Study, Office, Entry, Hall, Closet, 

Note: Any rooms that do not update when the
default floor or ceiling height is changed are
not using the default values. To use the
default values for a specific room, check
Default for any of the room height values in
its specification dialog. See “General Tab” on
page 120.
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Dressing, Storage, Laundry, Utility and 
Unspecified.

Exterior - Court, Deck, Balcony.

Hybrid - Open Below, Garage, Slab, Porch, 
Attic.

Effects of Room Types
The program applies specific structural and 
display properties to rooms depending on the 
assigned Room Type.

Living Area
• All interior type rooms are included in 

Living Area calculations; exterior and 
hybrid rooms are not. 

Ceilings and Roofs
• Interior rooms have a ceiling and roof 

above them unless specified otherwise.
• Exterior rooms are assumed to be open to 

the outside and do not generate a roof 
above them, or room moldings.

• Attic rooms are ignored by the program’s 
automatic roof generator.

• Garage, Slabs, and Porches are treated 
like exterior rooms in all cases except that 
they generate a ceiling and a roof above 
them.

Floors and Foundations
• Open Below is a unique type of interior 

room. It has no floor platform and can be 
used for defining stairwell openings. 

• Walls that define the garage have a foun-
dation under them  with a concrete slab at 
the top of stem wall or grade beam.

• The floor in Garage and Slab rooms dis-
play in 3D on Floor 0, not the first floor. 
See “Garages” on page 172.

•
• Courts, decks and balconies do not gener-

ate foundations.

Doors and Windows
• A window placed in a wall between an 

exterior room and an interior room always 
faces out toward the exterior. 

• Windows placed between interior rooms 
generate a warning message. 

• Door placed between interior and exterior 
type rooms display threshold lines.

• Interior doors do not display thresholds.
• Open Below rooms are treated as interior 

rooms for window and door placement.

Electrical

• The Auto Place Outlets  tool adds 
outlets automatically to all interior rooms 
except bathrooms. Only one outlet over 
each sink is added for a bathroom.

• The Auto Place Outlets  tool places 
fewer outlets in hybrid rooms. 

• The Auto Place Outlets  tool does not 
place outlets in exterior type rooms, 
Porches or Open Below rooms.

• Any outlet manually placed in an exterior 
room automatically becomes a waterproof 
outlet designed for exterior use. 

Trim and Molding
• Moldings are not automatically drawn in 

exterior or hybrid rooms.
• Baseboards and chair rails are not initially 

drawn in Open Below rooms, but crown 
molding, if present, is. 
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Plan Check

• Plan Check  uses the room type and 
its characteristics for basic plan checking. 

For example, a closet does not need a 
smoke detector but a bedroom does. See 
“Plan Check” on page 349. 

Room Labels
A label can display in floor plan view for any 
area defined as a room. There are two parts 
to each room label: 
• The Room Name, which is similar to a 

Text  object and can be selected and 
edited. See “The Text Tools” on page 336. 

• The room area, which is not a standard 
text entry and cannot be directly edited. 

You can assign a custom Room Name, move 
a room label or even delete it without 
affecting the Room Type. See “Room Types” 
on page 113.

Displaying Room Labels
The display of room labels is controlled in 
the Display Options dialog. Room labels are 
placed on the “Rooms, Labels” layer and use 
the Text Style assigned to that layer. See 
“Display Options Dialog” on page 49. 

You can specify how the area of rooms is 
calculated by the program by turning on the 
display of one or more of these layers: 
• Rooms, Standard Area is measured from 

the center of interior walls to the exterior 
wall framing. It is rounded to the nearest 
square foot or mm and does not include 
the area within bay, box and bow win-
dows. 

• Rooms, Interior Area is measured from 
the inner surfaces of all the room's walls. 

• Rooms, Interior Dimensions is also 
measured from the inner surfaces of the 
room walls. 

Editing Room Labels

Room labels are similar to simple Text  
objects and can be changed, moved and 
resized much like any other text object. You 
can also modify a room label’s Text Style 
and other attributes in the Room Label 
Specification dialog.

The text of a room label cannot be modified 
in its specification dialog, however: it must 
be specified in the Room Specification 
dialog. See “General Tab” on page 120.

If you delete a room label, the Room Type 
remains in the Room Specification dialog. 
To restore the label, check the Show Room 
Label check box on the General tab of that 
dialog.

Room Area
Unlike the rest of a room label, the room area 
and dimensions are not standard text entries 
and cannot be edited or changed. The room 
area moves, resizes and rotates with the rest 
of the room label, but you can turn the area 
and dimensions on or off separately in the 
Display Options dialog. 

Room labels can move or even disap-
pear when room entries are revalidated.
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The Interior Area room area calculation 
includes the areas within bay, box or bow 
windows, while the Standard Area and 
Interior Dimensions calculations do not.

Living Area
The Living Area label displays the area of 
the floor platform for living areas in a plan. It 
is found near the bottom center of the plan as 
soon as a room area is defined by walls and/
or railing.

The Living Area displays for an individual 
building if half or more of that building's area 
is living area. For example, a living area 
label would not display for a detached garage 
that contains a bathroom or small shop.

You can choose not to display this label by 
turning off the display of the Room Labels 
layer in the Display Options dialog.

The Living Area label can be moved or 
deleted. To restore a deleted Living Area 

label, select Tools> Plan Check . You 
can click the Done button immediately, 
without actually completing Plan Check. See 
“Plan Check” on page 349.

Living Area vs. Footprint
The Living Area should not be mistaken for 
the footprint of the house. Only true livable 
areas are included in the Living Area 
calculation. Exterior and hybrid room types 
such as Garage, Deck, and Porch are not 
included. Neither is any room labeled Open 
Below or Attic. See “Available Room Types” 
on page 113. 

Living Area is measured from the outer 
surface of the structural layer of exterior 
walls. When walls separate the living area 
from exterior or hybrid room types, it is 
measured to the wall center line.

Decks
A Deck room is an exterior-type room that 
uses deck planking and framing to create a 
floor platform rather than using a single floor 
surface that spans the entire room area.

To draw a deck, select Build> Deck> Deck 

Railing , then click and drag to draw a 
railing. 
• To create a deck without a railing, use one 

of the Deck Edge tools. See “The Deck 
Tools” on page 87.

A room does not have to be defined by Deck 
Railing to be specified as a “Deck.” See 
“Room Types” on page 113. You can also 
define a room as a “Deck” in the Room 

Specification dialog. See “General Tab” on 
page 120.

By default, decks do not have roofs. If you 
want a roof over a deck, check Roof Over 
This Room in the Room Specification 
dialog. See “Structure Tab” on page 121.

To give the roof a visible means of support, 
you can select the Post to Beam option in the 
Wall Specification dialog. See “Railing Tab” 
on page 104.

Openings in deck railings can be created 

using Doorways . See “Openings in 
Railings” on page 135. 
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Floor & Ceiling Heights
Use the Room Specification dialog to set 
floor heights on a room-by-room basis. See 
“Room Specification Dialog” on page 120. 

Different rooms on the same floor can have 
unique floor and ceiling heights, allowing 
you to create:
• Split levels and bi-levels
• Sunken living rooms and garages
• Cathedral and coffered ceilings.

In 3D views, you can adjust the default floor 
and ceiling height for the entire floor or the 
floor and ceiling height for an individual 
room. See “In 3D Views” on page 112.

All floor and ceiling heights are measured 
relative to zero, which is the default floor 
height for Floor 1. Unlike other default floor 
and ceiling heights, the default floor height 
for Floor 1 cannot be changed, but the floor 
heights of rooms on Floor 1 can be edited 
individually. 

In order to raise or lower an area’s floor or 
ceiling height, you must give it a room 
definition. To create room definition without 

enclosing an area with solid walls, use 

Railings . 

Ceiling and floor heights are interrelated. 
Changing the floor height in one room can 
affect ceiling heights of the rooms below. 
• If a room’s floor is lowered, its ceiling 

height is increased while the ceiling 
below that room drops. 

• If the floor is raised, the ceiling height 
decreases while the ceiling below that 
room is raised. 

If the rooms above a particular room have 
more than one floor height, the room’s 
ceiling is stepped.

In a situation like this, a Lowered Ceiling can 
be used to cover “steps” made by different 
floor heights on the floor above. See 
“General Tab” on page 120.

To ensure that steps in floor and ceiling 
platforms have solid sides, define their room 
areas using Invisible Railings. 
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Split Levels
A split level can be created by raising or 
lowering the floor and ceiling heights of 
various areas of the plan.

In the following example, the lowest floor 
height is 0, the next is 24, and the next is 48 
inches. The ceiling height in each room is set 
at 109 inches. See “Split Levels” on page 
163.

 

Special Ceilings
By default, the program builds a flat ceiling 
platform on top the wall plates of a room. 
More varied and complex ceilings are made 

using settings in the Room Specification 
dialog.

Lowered Ceilings
You can define a lowered or dropped ceiling 
in a room without affecting the top plate 
height of the walls by increasing the 
thickness of the Ceiling Finish.

In the following illustration, the default 
ceiling height for the entire first floor is 120", 
and the room on the right has a ceiling finish 
lowered to 96".  

To create a lowered ceiling

1. Select the room in which you would like 
to specify a lowered ceiling.

Normal ceiling Lowered ceiling
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2. Click the Open Object  edit button 
to open the Room Specification dialog.

3. On the Structure tab, increase the Ceil-
ing Finish value by the amount that you 
would like to lower the ceiling.

4. Notice that the preview diagram repre-
sents the Finished Ceiling height (F).

Cathedral Ceilings
A cathedral ceiling has the same pitch as the 
roof and is created using the underside of the 
roof above the room. 

To create a cathedral ceiling

1. Build a roof for your plan. See “Roofs” 
on page 175. 

2. Select the room and open the Room 
Specification dialog. See “Room Speci-
fication Dialog” on page 120.

3. On the Structure tab, clear the check box 
for Ceiling Over This Room.

Tray Ceilings
A tray ceiling is flat in the center and sloped 
around the perimeter. You can easily create a 
tray ceiling using the underside of roof 
planes above.

The roof must be built before adjusting the 
ceiling height for a tray ceiling with a sloping 
perimeter. If the roof is rebuilt after adjusting 
the ceiling height, the new roof will be raised 
to match the new ceiling height.

To create a tray ceiling

1. In the Room Specification dialog, make 
sure that Ceiling Over this Room is 
checked, then specify the desired height 
of the walls as the Ceiling Height. See 
“Structure Tab” on page 121.

2. Change the Ceiling Height of the room 
to the desired height of the flat ceiling 
surface in its center. 

In floor plan view, dashed lines indicate 
where the ceiling changes from sloped to 
flat. These lines are located on the “Ceiling 
Break Lines” layer in the Display Options 
dialog. See “Display Options Dialog” on 
page 49.

In this example, a hip roof is based on 8’ 
ceilings. After the roof is built, the Ceiling 
Height is raised to 10’. The resulting ceiling 
follows the roof pitch for 2’, then becomes a 
flat ceiling. 
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Cantilever Undersides
Occasionally, a room will cantilever out past 
an exterior wall. You can specify the surface 
material of the underside of a cantilever on 

the Materials tab of the Room Specification 
dialog. See “Room Specification Dialog” on 
page 120.

Room Specification Dialog
The Room Specification dialog 
controls the structural characteristics 

and appearance of a selected room. To open 
the Room Specification dialog, select a 
room and click the Open Object edit button. 
See “Selecting Rooms” on page 111. 

Several of the tabs in the Room 
Specification dialog are also found in the 
Floor and Room Defaults dialogs. See 
“Floor and Room Defaults” on page 110.

Some values in this dialog are dynamic. A 
value with Default checked is referenced 
from the Floor Defaults dialog. To return a 
value to the default, replace the check mark. 
See “Dynamic Defaults” on page 42.

The settings in this dialog are similar to those 
in the Floor Defaults dialog, but affect only 
the selected room See “Floor Defaults 
Dialog” on page 160.

General Tab
Only the settings on the General tab are 
enabled in the Floor Defaults dialog.

Hip roof with cathedral 
ceiling over.

Hip roof, ceiling over, ceiling 
height raised and ceilings 
rebuilt.

Tray ceiling from floor plan 
view. Note dashed lines for 
changed ceiling direction.
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The settings here control the Room 
Type and the appearance of the Room 

Label.
• Select the Room Type. This affects some 

of the room’s characteristics. See “Room 
Types” on page 113.

• Check Show Room Label to display the 
room label in floor plan view. This option 
is unchecked automatically if you select 
“Unspecified” as the room type. See 
“Room Labels” on page 115.

• If you wish to use a custom name in the 
room label, uncheck Use Room Type, 
then specify the desired Room Name in 
the text field.

Specify whether the selected room is 
included in the Living Area 

calculation. See “Living Area” on page 116. 
• Select Include in Total Living Area Cal-

culation to include the room in the Living 
Area regardless of its Room Type. 

• Select Exclude from Total Living Area 
Calculation exclude the room in the Liv-
ing Area regardless of its Room Type. 

• Select Use Default for Room Type 
(Included/Excluded) to base the selected 
room’s inclusion in the Living Area on its 
Room Type. 

Structure Tab
The Structure tab  features a cross section 
diagram that shows the relationships between 
the various heights and platform thicknesses. 
It is meant to represent the relationships 
between heights and thicknesses rather than 
provide a scaled drawing of the model.

Two floors can be included in the diagram: 
the floor that the selected room is located on, 
and the floor below it, if one exists. 

What appears in the diagram may be affected 
by the location where you clicked to select 
the room. For example, if the selected room 
is located over two rooms on the floor below 
with different structural information, the 
position of the pointer relative to these lower 
rooms determines which of them displays as 
the floor below. 

1

2

1 2
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Check the Default box beside any height 
value to restore the default setting. 

Absolute Elevations - Specify these 
height values as measured from the 

default first floor height of zero.  See “Floor 
& Ceiling Heights” on page 117.
• The Floor Above height displays as a ref-

erence and cannot be changed here.
• Specify the Ceiling height of the selected 

room. Not available in the Floor Defaults 
dialog on Floor 0, or if more than one 
room is defined above the selected room. 

• Specify the Floor height. 

If a room is defined directly beneath the 
selected room on the floor below, additional 
settings may be available. 
• Specify the Floor Below height, which is 

the floor height of the room directly 
below where you clicked to select the cur-
rently selected room. 

• If the selected room is directly above a 
Garage and there is a foundation present, 
you can specify the SWT Below height, 
which is the top height of the concrete 
stem walls around the perimeter of the 
garage. 

Relative Heights - Specify these height 
values as measured from surfaces 

within the selected room or the room below. 
• Specify the Rough Ceiling height, as 

measured to the bottom surface of the 
ceiling framing to the subfloor surface. 
Not available if there is a room over all or 
part of this room.

1

2

3

5

4

Note: The default floor height for Floor 1 is 0.
It can be modified in the Room Specification
dialog, but not in the Floor 1 Defaults dialog.
See “Floor and Room Defaults” on page 110.

1

2
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• Specify the Finished Ceiling height, as 
measured from the finished floor surface 
to the surface of the finished ceiling. Not 
available if there is a room over all or part 
of this room.

• Specify the distance from the Stem Wall 
Top to Ceiling. Only available when 
Floor for this Room is Supplied by the 
Foundation ‘Room’ from the Floor 
Below has been checked.

• Specify the Ceiling Below height, which 
is the height of the ceiling of the room 
below, as measured from that room’s sub-
floor to rough ceiling surfaces. Not avail-
able when Auto Rebuild Foundation is 
enabled or if there is no room below the 
selected room. See “Rebuilding Founda-
tions” on page 170.

• Specify the Stem Wall height, which is 
measured from the bottom of the room’s 
floor framing to the top of the foundation 
wall footing and including a treated sill 
plate, if one is specified. Only available if 
the selected room or the room below it is 
defined by foundation walls.

Specify the characteristics of the 
room’s Ceiling. 

• If Roof Over This Room is checked, a 
roof automatically generates over the 
room. If unchecked, no roof generates.

• If Ceiling Over This Room is checked, 
the room has a flat ceiling. If unchecked, 
the ceiling follows the underside of the 
roof.

• Check Use Soffit Surface for Ceiling to 
improve the 3D appearance of the transi-
tion between ceiling and eaves of exterior 
rooms with Ceiling Over This Room 
unchecked. 

• The thickness of the Ceiling Structure 
displays here for reference but cannot be 
changed. 

• Specify the thickness of the Ceiling Fin-
ish layer. 

Specify the thickness of the Floor Fin-
ish layer. 

• The thickness of the Floor Structure dis-
plays here for reference but cannot be 
changed. 

A cross section diagram showing the 
relationship between the various height 

settings displays here for reference. 

Moldings Tab
Chair rail, crown and base moldings can be 
assigned to a selected room on the Moldings 
tab. Moldings are placed around the wall 
surfaces of a room and continue around the 
surface of any soffit that is attached to the 
wall at the molding height.

The settings on this tab are also similar to 
those found in the Floor Defaults dialog, but 
affect only the selected room instead of all 
rooms on the current floor. 

3

4

5
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Uncheck Default to enable the settings 
that follow. When checked, the room 

uses the default moldings set in the Floor 
Defaults dialog. See “Floor Defaults Dialog” 
on page 160. 

The Molding drop-down list includes 
all moldings currently applied to the 

selected room(s). Select one from the list to 
edit, replace, or delete it. 

Make changes to the moldings assigned 
to the selected room(s).

• Click the Add New button to open the 
Select Library Object dialog and select a 
new molding profile to apply to the room. 
See “Select Library Object Dialog” on 
page 276.

• Click the Select button to replace the 
currently selected molding with a 
different molding profile. 

• Click the Delete button to remove the 
currently selected molding from the room. 

Molding Specification - Make changes 
to the currently selected molding. 

• Specify the Height and Width of the 
currently selected molding. 

• Specify the distance of the selected mold-
ing From Floor and select whether this 
distance is measured To Top or To 
Bottom of the molding profile.

• Select the currently selected molding’s 
Type from the drop-down list: crown, 
chair rail, or base molding.

Fill Style Tab
The settings on the Fill Style tab affect the 
appearance of the room in floor plan view. 
This tab is also found in the Floor Defaults 
dialog. For more information, see “Fill Style 
Tab” on page 205.

1
2

3
4

1

2

3

4



Room Specification Dialog

 125

Materials Tab
The settings on the Materials tab affect the 
appearance of the selected room’s walls, 
floor, ceiling and moldings in 3D views. 

Default molding and ceiling and floor 
covering materials can be set in the Floor or 
Room Defaults dialogs. 

For more information, see “Materials Tab” 
on page 284. 
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Chapter 10:

Doors

Home Designer Essentials comes with tools 
for creating a wide variety of interior and 
exterior doors. In addition, the library offers 
a large selection of specialty doors and 
doorways including hinged, sliding, pocket, 
bifold, and garage doors.

Chapter Contents
•      Door Defaults
•      The Door Tools
•      Displaying Doors
•      Editing Doors
•      Changing Door Swings
•      Special Doors
•      Door Specification Dialog

Door Defaults
Default Settings are accessed by 
selecting Edit> Default Settings. 

Click the “+” next to Doors to show the door 
sub-headings. Select a subheading and click 
the Edit button to open the defaults dialog 
associated with your selection: 

The values in the Door Defaults dialog are 
initial values for interior or exterior doors. 
Individual doors can be edited after they are 
created. 

The Door Defaults dialogs look nearly the 
same as the Door Specification dialog. See 

“Door Specification Dialog” on page 136. 
There are only a couple of differences: 
• Since default settings are specified here, 

“Use Default” is not an option for some 
settings as it is in the Door Specification 
dialog.

• The Door Type cannot be changed in the 
Defaults dialogs.
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The Door Tools
To place a door, select the type you 
want from the Build> Door submenu. 

With a Door Tool active, move your mouse 
pointer over a wall section. If there is room 
enough along the wall to fit a 12” (300 mm) 
wide door, a preview of the door will display. 
When a preview can be seen, click on a wall 
to place a door in the wall at that location.

Hinged and Sliding Doors have both Interior 
and Exterior Door Defaults. If the wall is an 
exterior wall or one that separates an interior 
from an exterior room, the program places an 
exterior door based on the default settings for 
exterior doors. If the wall is an interior wall, 
the program places an interior door based on 
the default settings for interior doors. This 
rule applies to doors copied and pasted from 
one location to another just as it does to 
newly placed doors. See “Door Defaults” on 
page 127.

Once placed, any door may be changed into 
any other type of door using the Door 
Specification dialog. See “Door 
Specification Dialog” on page 136.

Hinged Doors
Select Build> Door> Hinged Door 
and click a wall where you want to 

place a hinged door. Hinged doors can be 
placed on interior or exterior walls. A hinged 
door becomes a double door when its width 
is four feet or greater. 

The initial swing direction of a hinged door 
depends on the location of the mouse pointer 
relative to the wall when you click. The door 

will swing towards the side of the wall that 
you click nearest. 

The initial hinge side of a hinged door can be 
set by clicking to place the door and then 
holding the mouse button down rather than 
releasing it. Move the mouse toward the end 
of the door that you would like the hinges to 
be on: as the mouse pointer nears either end, 
the door preview’s hinge side will move to 
that end. You can also adjust the door’s 
swing direction in this manner. When the 
swing direction and hinge side are correct, 
release the mouse button.

Doorways
Choose Build> Door>  Doorway and 
click a wall to place a doorway (an 

opening without a door). Doorways can be 
placed on interior or exterior walls, or in 
railings and fences to provide an opening. 
You can assign a door from the library to a 
doorway.

Sliding Doors
Select Build> Door> Sliding Door 
and click a wall where you want to 

place a sliding door. Sliding doors can be 
placed on interior or exterior walls. If placed 
in an exterior wall, the door is glass; if placed 
in an interior wall, it is a solid slab.

The initial opening side of a sliding door can 
be specified by moving the mouse pointer 
along the wall while the mouse button is still 
pressed.  
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The default sliding door dimensions are 
5’-0” x 6’-8” with a 12” bottom frame and a 
6” frame on the sides and top. 

Pocket Doors
Select Build> Door> Pocket Door  
and click a wall where you want to 

place a pocket door.

As with sliding doors, the initial opening side 
of a pocket door can be specified by moving 
the mouse pointer along the wall while the 
mouse button is still pressed.  

The default pocket door dimensions are 2’-6” 
x 6’-8” high. A pocket door becomes a 
double pocket door if its width is four feet or 
greater. 

Bifold Doors
Choose Build> Door> Bifold Door 
and click a wall where you want to 

place a bifold door.

Like a hinged door, the initial opening side of 
a bifold door depends on the location of the 
mouse pointer relative to the wall when you 
click. The door will open towards the side of 
the wall that you click nearest. 

Similarly, the initial hinge side of a sliding 
door can be specified by moving the mouse 
pointer along the wall while the mouse 
button is still pressed.  

The default interior single bifold door is 2’-
6” x 6’-8”. A bifold door becomes a double 
bifold if its width is greater than three feet.

Bifold doors always display closed in all 3D 
views.

Garage Doors
Choose Build> Door> Garage Door 
and click a wall to place a garage 

door.

The default garage door is 8’-0” x 7’-0” high. 
A garage door must be at least two feet wide.

In floor plan view, dashed lines show the size 
and location of the garage door when open.

Garage doors will build into a garage stem 
wall provided the room is designated as a 
garage before the door is inserted. See 
“Room Types” on page 113.

The Doors & Doorways 
Library

The Doors & Doorways library can be 
accessed by selecting Library> 

Library Browser and browsing to Home 
Designer Essentials Content> Architectural. 
This library folder contains a variety of 
interior and exterior doors, as well as special 
entryways and wrapped openings. 

Entryways and wrapped openings are 
examples of Doorways, which are wall 
openings that do not have doors within them.

To add a door to the Doorway, select a Door 
Type other than “Doorway” from the drop-
down list in the Door Specification dialog. 
See “General Tab” on page 137. 
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You can also select a custom door from the 
library and place it into a doorway in floor 
plan view or any 3D view.

To place a library door in a doorway

1. Go to floor plan view or any 3D view. 
2. Open the Library Browser. 

3. Navigate through the Doors library cate-
gory until you find the custom door style 
desired. 

4. Select the door in the Library Browser, 
then click on the doorway to place the 
selected door within it. If a door already 
exists, it is replaced. 

5. Continue clicking other doorways until 
all changes have been made.

Displaying Doors
The display of doors, door sizes, 
opening indicators and headers is 

controlled in the Display Options dialog. 
See “Display Options Dialog” on page 49.

Doors can only be placed in walls, so if a 
wall’s layer is turned off, any doors placed in 
that wall will not display, either. See 
“Displaying Walls” on page 94. 

If the “Doors” layer is turned off, doors and 
their casing do not display but openings in 
the walls where they are located are visible.

In Floor Plan View
When the “Doors” layer is turned on in floor 
plan view, door symbols represent the width 
of the opening and indicate its swing. If a 
door is recessed, the affected wall layers will 
adjust to accomodate the casing.

Doors in exterior walls and doors that open 
to exterior type rooms such as a Garage, 
Porch, or Deck have a threshold line across 
the opening in floor plan view. See “Room 
Types” on page 113.

If an exterior door to a Garage room on Floor 
1 extends into a Garage stem wall or curb on 
Floor 0, its location will be indicated on 
Floor 0. See “Garages” on page 172. 

Door Labels
Door labels display in floor plan view, 
centered on the doors they represent, when 
the “Doors, Labels” layer is turned on. Door 
labels indicate Width and Height. For 
example: 
• In Imperial plans, the label for a 3’-0” 

wide, 6’-8” high double hung window 
will read 3068.

• In metric plans, the label for a 900 mm 
wide, 2100 mm high double hung win-
dow will read 900x2100.

Threshold
Line
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In 3D Views
You can specify whether a selected door is 
shown open or closed in 3D views by 

clicking the Show Door Open in 3D  and 

Show Door Closed in 3D  edit buttons as 

well as in the Door Specification dialog. 
See“General Tab” on page 137.

If a door is set to display open in 3D, the 
angle of the open door can be changed using 
the edit handles. See “Using the Mouse” on 
page 131.

Editing Doors
Before a door can be edited, it must be 
selected. To select a door, click it when the 

Select Objects  tool or any of the Door 

Tools  are active. Doors and/or windows 
can also be group selected and edited. See 
“Selecting Objects” on page 60. 

When you select a door in floor plan view, 
the door size label indicates the width 
followed by the height. For example, a 3068 
door is 3’-0” wide by 6’-8” high. 

Blocked units are made up of individual 
doors and windows that have been grouped 
together to act as one object. You can create 
what is essentially a blocked door unit by 
assigning a library door to a doorway from 
the library

Select a blocked unit by clicking on it in any 
view. To select a door that is a component of 
a blocked unit, click at the location of the 
component in question, then click the Select 

Next Object  edit button. See “Selecting 
Objects” on page 60.

In the Specification Dialog
The most precise method of editing a 
door is to use the Door Specification 

dialog. Door type, size, casing, materials, 
and more can all be specified in this dialog. 

See “Door Specification Dialog” on page 
136. 

Using the Mouse
In floor plan view, click either of the two end 
handles and drag along the wall to change the 
width. The label showing the size updates as 
the handles are dragged. Click and drag the 
Move handle at the center to move the door 
along the wall it is placed in. Use the 
triangular Rotate handle to adjust the door’s 
swing.  If the door’s label displays, an 
additional handle is available to move the 
label.

In 3D views, a selected door has five edit 
handles: the Move handle at the center and a 
Resize handle on each edge.  Click and drag 
an edge handle to resize the door.  

A door or window moved against an 
intersecting wall temporarily stops when the 
casing meets the intersecting wall. You can 
continue to drag and it resumes movement 
past the intersecting wall. 

Using the Edit Tools
A selected door or doors can be edited in a 
variety of ways using the buttons on the edit 
toolbar. See “The Edit Toolbar” on page 22.
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Centering Doors
The Center Object edit button allows 
you to center a selected door along a 

wall within a room or relative to a cabinet or 
window. See “Using Center Object” on page 
79.

To center a door along a wall 

1. Select a door or combination of win-
dows and doors in floor plan view. 

2. Click the Center Object  edit button 
then choose from one of the following 
options: 

•  Click near a wall inside a room to cen-
ter the door along that wall in that 
room.

•  Click outside the house (on the exterior 
room) near an exterior wall to center 
the door along an exterior wall.

Changing Door Swings
Door swing direction and hinge 
side can be changed using the 

Change Opening/Hinge Side and Change 
Swing Side edit buttons.

The Change Opening/Hinge Side  edit 
button is available for all doors except 
double doors and garage doors.

The Change Swing Side  edit button is 
available for all doors except pocket doors. 

Hinged Doors
In addition to using the edit buttons, hinged 
doors’ hinge side and swing direction can be 
changed using the triangular Rotate edit 
handle.

To adjust the angle of swing:

1. In floor plan view, select the door and 
grab the triangular handle.

2. Drag to change the amount of swing. 

3. Release the mouse. 

If you drag near the closed position, the door 
snaps to a closed position.

To change the swing using edit handles:

1. In floor plan view, select the door and 
grab the triangular edit handle.
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2. Drag the pointer along the path of the 
new arc to change the hinge side and/or 
swing direction.

3. Release the mouse.

To change the swing using edit buttons:

1. In floor plan view, select the door.
2. To change the hinge side, click the 

Change Opening/Hinge Side  edit 
button.

3. To change the swing direction, click the 

Change Swing Side  edit button.

Sliding Doors
To change the side of a sliding door that is 
fixed, select the sliding door then click the 

Change Opening/Hinge Side  edit 
button.

To flip the fixed and moving sides of the 

door, click the Change Swing Side  edit 
button.

As with hinged doors, you can also change 
the Opening/Hinge and Swing sides of a 
sliding door by clicking and dragging the 
triangular edit handle.
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Pocket Doors
To change the direction of a pocket door, 
select it and click the Change Opening/

Hinge Side  edit button.

As with hinged doors, you can also change 
the Opening/Hinge side of a pocket door by 
clicking and dragging the triangular edit 
handle.

Bifold Doors
To change the side of a bifold door that is 
fixed, select it then click the Change 

Opening/Hinge Side  edit button.

To change the hinged side of the door, click 

the Change Swing Side  edit button.

As with hinged doors, you can also change 
the Opening/Hinge and Swing sides of a 
bifold door by clicking and dragging the 
triangular edit handle.

Garage Doors
To change the side of a garage door that it 
faces, select it and click the Change Swing 

Side  edit button.

As with other door types, you can also 
change the Swing side of a bifold door by 
clicking and dragging the triangular edit 
handle. 

Special Doors
A variety of special doors and doorways can be created in Home Designer Essentials.

Note: There must be enough room for the
entire door to fit in the opposite wall or the
door does not change.
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Wrapped Openings
You can create a wrapped opening by placing 
a doorway in the wall and checking 
Suppress Casing in the Door Specification 
dialog. See “Casing Tab” on page 138. If 
base molding is present, it will wrap around 
the opening. 

Openings in Railings

Use the Doorway  tool to open a railing 
for a stairway or other access. 

To open a railing across an entire section, 
resize the doorway’s Width so that it is 
greater than the length of the railing in the 
Door Specification dialog. The opening 
resizes to the maximum width possible for 
that space. See “General Tab” on page 137.

To add a gate, specify the doorway’s Door 
Type as a Door, then choose an appropriate 
gate as the Door Style. A selection of gates is 
available in the Fences & Railings library 
folder. See “Placing Library Objects” on 
page 274. 

Transoms Above Doors
Transom windows above doors are created 
the same as other stacked windows. See 
“Grouped Windows” on page 146.

Creating a Doorway 
with a Railing

When a railing is specified as No Room Def, 

it can be positioned within a Doorway .

To create a doorway with railing

1. Place a Doorway  at the desired loca-
tion in your plan.

2. Select Build> Wall> Straight 

Railing , then click and drag to draw 
a railing  parallel to the wall with the 
doorway. 

3. Click on the railing, then use the Resize 
edit handles to adjust the length of the 
railing as needed. See “Using the Edit 
Handles” on page 62.

4. With the railing selected, click the Open 

Object  edit button.
5. On the General tab of the Railing 

Specification dialog, check No Room 
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Def and click OK. See “General Tab” on 
page 102.

6. With the railing still selected, Ctrl + drag 
it into position within the doorway. See 
“To move an object freely” on page 78.

Placing a Gable Over a Door
Click the Gable Over Door/Window 
edit button to produce a gable roof 

over the selected door(s) the next time 
automatic roofs are built. See “Gable Over 
Door/Window” on page 181.

You can manually edit or delete this gable 
line at any time. Your changes take effect 
when the automatic roofs are rebuilt. This 
can also be used with group selected doors.

Door Specification Dialog
To open the Door Specification 
dialog, select a door and click the 

Open Object edit button or double-click on 

a door using the Select Objects  or a 

Door  tool.

Positioning a railing in a doorway
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General Tab

Door Style - Define the door as slab, 
glass, panel, or louvered, or select a 

door style from the library. Select”Use 
Default” to use the default door style set in 
the Door Defaults dialog. See “Door 
Defaults” on page 127.
• Select “Library” from the list or click the 

Library button to choose a door symbol 
from the library. Once a library door is 
selected, that door is added to the Door 
Style list. See “Select Library Object Dia-
log” on page 276.

Door Type - Specify doorway, hinged, 
slider, pocket, bifold, or garage door.

Slider, pocket, bifold and garage are not 
allowed as exterior door defaults. 

Specify the Size and Position of the 
selected door. 

• Specify the Width, Height, and Thick-
ness of the door. 

• Floor to Bottom - Specify the height of 
the bottom of the door frame as measured 
from the subfloor. 

3D Display Options - Specify whether 
the selected door is drawn closed or 

open in 3D and cross section/elevation 
views. 

A preview of the door displays on the 
right side of the dialog box.

Select Interior or Exterior to specify 
which side of the door displays in the 

preview.

1
2
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Casing Tab
Changes made on the Casing tab can only be 
seen in 3D views. 

Specify the casing for the selected door. 

• Select the Interior or Exterior radio but-
ton to define the casing for that door side 
and display it in the preview image. This 
choice is not available for interior doors, 
which use the same values for both sides.

• Define the Width of the selected casing.
• Check Suppress Casing to have a 

wrapped opening instead of casing.
• Check Suppress Sill to prevent a sill 

from being generated under the door.
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Frame & Lites Tab

Frame - Specify the dimensions of the 
door’s rails and stiles. Only available 

for Glass, Panel, and Louvered Doors. See      
General Tab.
• Specify the Width of the stiles and top 

rail. 
• Specify the height of the Bottom rail.

Specify the number of Lites, or panes 
of glass, as well as their configuration. 

Only available for Glass doors. 
• Specify the number of horizontal Lites 

Across. 
• Specify the number of Lites Vertical. 
• Choose a Type, or style, from the drop-

down list. 

• Normal style is the most common, with 
vertical and horizontal muntin bars.

• Diamond style uses angled muntins to 
divide the lites.

• Prairie style is based on the normal style, 
but with all the central muntins removed, 
leaving only the two outside muntins, 
both horizontally and vertically. Lites 
Across and Vertical are typically set 
between 6 and 8.

• Craftsman style is based on the normal 
style, but only the topmost horizontal 
muntin is kept with all the portions of the 
vertical muntins above it. Lites Across 
and Vertical are typically set between 4 
and 8.

1

2

1

2
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Hardware Tab
Many of the settings on the Hardware tab are 
Dynamic Defaults: if “Use Default” is 
selected, the setting in the Door Defaults 

dialog is used. See “Dynamic Defaults” on 
page 42.

Specify the Handles to be used on the 
selected door. 

• Select an Interior Handle and/or Exte-
rior Handle from the drop-down lists. 

• Specify the location of the door handles  
In From Door Edge.

• Specify the location of the door handles 
Up From Bottom.

Specify the door’s interior and exterior 
Locks. 

• Select an Interior Lock and/or Exterior 
Lock from the drop-down lists.  

Normal Diamond Prairie Craftsman

1

2

3

1

2
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• Specify the location of the door locks Up 
From Bottom. The locks use the same In 
From Door Edge value as the handles.

Specify the Hinges to be used on the 
door. Two hinges are placed for interior 

doors, and three for exterior doors.
• Select a style of Hinges from the drop-

down list.  
• Specify the distance In From Top/Bot-

tom of the door to the center of the top 
and bottom hinges. 

Materials Tab
The Materials tab is available for numerous 
objects. For more information, see 
“Materials Tab” on page 284.

3

Note: For hinges to look right, it is best to
have at least a 1/4" (6 mm) reveal for the inte-
rior, or hinge side, door casing. 
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Chapter 11:

Windows

Home Designer Essentials can model a wide 
variety of windows. Fixed glass, hung, 
casement, sliding, awning, hopper, and 
louver window styles can all be created with 
the standard Window tool, and even set as 
the default. Home Designer Essentials can 
create bay, box, and bow windows at the 
click of a button. In addition, the library 
contains many mulled window 
combinations. 

Chapter Contents
•      Window Defaults
•      The Window Tools
•      Special Windows
•      Grouped Windows
•      Displaying Windows
•      Editing Windows
•      Bay, Box, and Bow Windows
•      Bay, Box, Bow Windows & Roofs
•      Window Specification Dialog
•      Bay/Box/Bow Window 

Specification Dialog



144

Home Designer Essentials  2012 Reference Manual

Window Defaults
Default Settings can be accessed by 
selecting Edit> Default Settings. 

Select Window from the Default Settings 
dialog.

The settings in the Window Defaults dialog 
control the attributes of a window when it is 
initially placed in a plan, so you should 
define the type of window that will be placed 
most often in your model. See “Default 
Settings” on page 42.

The tabs in the Window Defaults dialog are 
similar to those found in the Window 

Specification dialog. For more information, 
see “Window Specification Dialog” on page 
153.

Dynamic Window Defaults
A variety of window default values are 
dynamic, including the Window Type, 
Casing Specifications, and Sash sizes. All 
Materials are also dynamic. When a 
dynamic default is changed, existing 
windows using the default value are affected. 
See “Dynamic Defaults” on page 42. 

The Window Tools
To place a window, select Build> 
Window and choose the desired 

window type. Click on a wall to place a 
window of the selected type at that location. 
Bay, box and bow windows can only be 
placed in straight walls, while standard 
windows can be placed in both straight and 
curved walls. 

Standard Windows
Select Build> Window> Window, 
then click on a straight or curved wall 

to place a standard window at that location.

A standard window is a single window that is 
not a bay, box, or bow window. These 
special types are made up of multiple 
standard windows. 

A standard window that is part of a special 
window is called a component window.

Standard windows can be specified as any of 
a variety of window types, such as double 
hung, casement and awning. See “Window 
Specification Dialog” on page 153.

Bay Windows

A Bay Window is composed of three 
wall sections, each with a single 

component window. The two side walls are 
at an angle to the main wall. Select Build> 
Window> Bay Window and click on a 
straight wall to produce a bay window. 

When initially placed, bay windows measure  
2’-2” across at the front, 4’-2” across at the 
back, and are 1’-0” deep. The component 
windows are specified in the Window 

The roof is affected by Bay, Box and
Bow Windows. These windows should

therefore be placed before the roof is built.
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Defaults dialog and their sizes adjust to fit 
the available space. 

Box Windows
A Box Window is a bay window with 
side angles set at 90°. Select Build> 

Window> Box Window and click on a 
straight wall to produce a box window. 

Box windows initially measure 4’-2” wide 
with a depth of 1’-6”. The component 
windows are specified in the Window 
Defaults dialog and their sizes adjust to fit 
the available space. 

Bow Windows
A Bow Window is a group of 
identical wall segments that form a 

segmented curve. Select Build> Window> 

Bow Window and click on a straight wall to 
produce a 5-section bow window. 

The component windows are specified in the 
Window Defaults dialog. Their sizes adjust 
to fit the available space.

The 5-section bow below has a 4’-10” radius 
centered 3’-9” inside the wall, giving an 
opening 5’-10” across and a depth of 11½”.

Windows Library
Select Library> Library Browser, 
then browse to Home Designer 

Essentials Core Catalogs> Architectural to 
access a selection of special windows. Select 
the desired window, then click on a wall to 
place the window at that location. 

Special Windows
A variety of special windows can be created 
using multiple standard windows, the edit 
tools or custom symbols.

Creating Manual Bay, Box 
and Bow Windows

Sometimes it is easier to draw bay, 
box and bow windows manually than 

to use the automatic tools. Bays created 
using walls can have more than one window 
per section, which is not possible using a bay 
window unit.

Bear in mind that moving a manually created 
bay, box or bow window is generally more 
difficult than moving a unit created with one 

Note: Bay, box, and bow window areas are
not included in the living area or in room stan-
dard area calculations. They are included in
room interior area calculations.
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of the Window Tools  since it is 
composed of individual walls.

Corner Windows
Corner windows are produced when each  
window has one edge at or past the interior 
side of the adjacent wall.

To create a corner window, first create the 
desired window on each side of the corner. 
The header height and the sill height of both 
windows must be the same. 

Once the corner window is formed, its 
components and corner post size can be 

adjusted. Blocked units can also meet at a 
corner this way.

Special Window Shapes
A selection of special shaped windows is 
available in the Windows Library, including 
arched windows and mulled units. 

Placing a Gable 
Over a Window

Click the Gable Over Door/Window 
edit button to produce a gable roof 

over the selected window(s) the next time 
automatic roofs are built. See “Gable Over 
Door/Window” on page 181.

You can manually edit or delete this gable 
line at any time. Your changes take effect 
when the automatic roofs are rebuilt. This 
can also be used with group selected 
windows.

Vents
A selection of attic, foundation and gable 
vents are available in the Library Browser. 
See “The Library” on page 265.

Vents are placed in the same manner as 
regular windows and can be edited in much 
the same way, as well. 

Grouped Windows
Windows can be grouped together to create a 
wide variety of custom configurations. 
Stacked windows are easy to create in 3D 

views, particular Cross Section/Elevation 
views, using their edit handles. See “Editing 
Windows” on page 149.

To move a window all the way into a
corner, check Ignore Casing for Open-

ing Resize in the Plan Defaults dialog. See
“General Plan Defaults Dialog” on page 43.
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Notice how the windows and door in this 
example are separate, with a sections of wall 
showing between them. Doors and/or 
windows can also be organized into a unit in 
which the casing connects the windows and 
door and no wall surface shows between 
them. 

Automatically Mulled Openings
To form a mulled group of windows and/or 
doors, move them close enough together so 
that their casings touch. Once the casings 
touch, the windows are mulled together with 
one casing between the two of them. 

The sill of each window in the group must be 
at the same level for them to share the middle 
casing. The casing tops do not have to be at 
the same level. The casings are modeled as if 
they are one unit but the windows  remain 
separate objects for dimensioning and the 
Materials List.

Windows can be automatically mulled to 
doors if the bottom of the window is at the 
elevation of the floor, equal to the bottom of 
the door. 

Mulled Units in the Library
A selection of mulled window units is 
available in the Windows library. To place 
one in your plan, select it and click on a wall 
in any view. See “Placing Library Objects” 
on page 274.

Selecting Components 
of Mulled Units

To select a component of a mulled unit from 
the library, click at the location of the com-
ponent in question, then click the Select 

Next Object  edit button or press the Tab 
key until that individual component is 
selected. Only the component clicked on is 
selectable using this method. If you need to 
select a different component, click on it and 
repeat the process.

If there are multiple levels, it is easiest to 
select the components in a 3D view. When 
you have selected an individual component, 
you can change its parameters in the Window 
Specification dialog. See “Window 
Specification Dialog” on page 153.

If the selected component is not itself a 
mulled unit and has no components above it, 
its Height and Arch parameters can be 
changed. Changing the Height causes the 
component top to move. The bottom remains 
stationary.

Displaying Mulled Units
As with other windows, the display of 
mulled window units is controlled in 

the Display Options dialog. See “Displaying 
Objects” on page 48.

Mulled units are placed on the “Windows” 
layer by default and have a single label, 
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which is on the “Windows, Labels” layer. 
Mulled units from the library are also 
included in the windows category of the 
Materials List. If the component objects of a 

mulled unit have unique moldings or 
materials, they will not be noted in the 
Materials List.

Displaying Windows
The display of windows in floor plan 
and 3D views can be controlled in the 

Display Options dialog. See “Display 
Options Dialog” on page 49.

Windows can only be placed in walls, so if a 
wall’s layer is turned off, any windows 
placed in that wall will not display, either. 
See “Displaying Walls” on page 94. 

If the “Windows” layer is not set to display, 
window casing and other components are not 
visible, but the openings in the walls where 
they are located can still be seen.

In Floor Plan View
Some window types, notably Sliding and 
Double and Triple Casement windows, are 
distinguishable in floor plan view.

Bay, box,and bow windows have dimensions 
lines associated with them. 
• You can suppress their display by turning 

off the “Manual Dimensions” layer or on 
a unit by unit basis in the unit’s specifica-
tion dialog. See “Bay/Box/Bow Window 
Specification Dialog” on page 158. 

• The arrow style and fill are set in the 
Dimension Defaults dialog. See 
“Dimension Defaults Dialog” on page 
323.

Window Labels
Window labels display in floor plan view, 
centered on the windows they represent, 
when the “Windows, Labels” layer is turned 
on. Window labels indicate Width and 
Height, followed by Type. For example: 
• In Imperial plans, the label for a 3’-0” 

wide, 4’-0” high double hung window 
will read 3040 DH.

• In metric plans, the label for a 900 mm 
wide, 1200 mm high double hung win-
dow will read 900x1200 DH.

Double Hung

Left Sliding

Triple Casement

Window types in floor plan view
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Editing Windows
Before a window can be edited, it must be 
selected. Click on a window when the Select 

Objects  tool or any of the Window 

Tools  are active. Doors and/or windows 
can also be group-selected and edited. See 
“Selecting Objects” on page 60.

To select a window that is part of a blocked 
unit, click the component window, then click 

the Select Next Object  edit button. See 
“Selecting Components of Mulled Units” on 
page 147.

Windows can be edited using their edit 
handles, the edit toolbar buttons, and the 
Window Specification dialog. See “Window 
Specification Dialog” on page 153.

When you select a window in floor plan 
view, the window size label displays the 
width followed by the height. For example, a 
3036 window is 3’-0” wide by 3’-6” high. 

Using the Mouse
• In floor plan view, click either of the two 

end handles and drag along the wall to 
change the width. The label showing the 
size updates as the window is resized. 

• In 3D views, a selected window has five 
edit handles: the Move handle at the cen-
ter and a Resize handle on each edge. 

Click and drag an edge handle to resize 
the window.

• A single window or a group of windows 
can be moved with the center edit handle.

• A door or window moved against an 
intersecting wall temporarily stops when 
it is the casing distance from the inter-
secting wall. You can continue to drag 
and it resumes movement past or onto the 
intersecting wall. Enable Ignore Casing 
for Opening Resize in the Plan Defaults 
dialog to turn off this behavior. See “Gen-
eral Plan Defaults Dialog” on page 43.

In the Specification Dialog
The most precise method of editing a 
window is to use the Window 

Specification dialog. The window type, size, 
casing, materials, and more can all be 
specified in this dialog. See “Window 
Specification Dialog” on page 153.

Using the Edit Tools
A selected window or windows can be edited 
in a variety of ways using the buttons on the 
edit toolbar. See “The Edit Toolbar” on page 
22.

Bay, Box, and Bow Windows
Bay, Box and Bow Windows 
are created much the way 

regular windows are: select a tool, then click 
a wall to place that window type. 

Note: Using the edit handles is the only way
to resize bay, box and bow window systems.
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Home Designer Essentials automatically 
builds a foundation under bay/box/bow 
windows placed on floor 1 unless they are 
raised from their original position. That 
section of the foundation wall is also a bay/
box/bow, but without windows. If the 
foundation was generated before the window 
is placed, the foundation must be rebuilt or 
edited manually.

Editing Bay, Box and 
Bow Windows

Bay, box and bow windows are edited 
similar to regular windows, with one 
exception: in floor plan view, a diamond-
shaped Depth edit handle displays on the 
section. Drag this Depth handle outward to 
increase the depth, or inward to decrease the 
depth of the unit. See “Editing Windows” on 
page 149.

Bay, box and bow windows can also be 
edited in their respective specification 
dialogs. See “Bay/Box/Bow Window 
Specification Dialog” on page 158.

Displaying Bay, Box 
and Bow Windows

The display of bay, box and bow windows is 
controlled in the Display Options dialog. 
See “Display Options Dialog” on page 49. 

Like other windows, bay, box and bow 
windows can display labels. See “Window 
Labels” on page 148. 

Bay, box and bow window width and radius 
dimensions, which display in floor plan view, 
are placed on the “Dimensions, Manual” 
layer. See “Displaying Objects” on page 48.

Component Windows
A component window within a bay, box or 
bow window can be resized like any other 
standard window. To select a component 
window, click at the location of the 
component in question, then click the Select 

Next Object  edit button or press the Tab 
key. 
• Only the bay or box window component 

that was clicked on is selected using this 
method. If you need to select a different 
component, click on it and repeat the pro-
cess.

• In a bow window, all components are 
identical, so only one component can be 
selected. Changing this component 
changes them all.

Resizing Components
An individual component window can be 
resized using the edit handles, by changing 
settings in the component’s Window 
Specification dialog. 

When a bay/box/bow window is first created, 
there is room for one standard trimmer on 
each side of each component window. When 
the bay as a whole is moved and resized, its 
components automatically resize so that a 
standard trimmer is still accomodated. 

Depth edit handle on a bay window
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If a component window is resized, it retains 
its size if at all possible when the containing 
bay/box/bow window is moved or resized. If 
the bay is resized in such a way that the 
component is too large to fit even with a 
thinner trimmer, the component resumes its 
default behavior, resizing as the containing 
bay window is resized.

Floors and Ceilings
When originally created, the floor and 
ceiling within a bay, box, or bow window are 
the same heights as the floor and ceiling of 
the room in which it is placed. 

Both the top and bottom heights of these 
window units can be adjusted in a 3D view 
using the window’s edit handles to create a 
lowered ceiling and/or a bench seat or garden 
window.

When the ceiling is lowered, the top heights 
of the walls that define the window unit are 
also lowered. When a roof is built over the 
unit, its height will be affected, as well.

When the bottom of the window is raised to 
create a bench seat, the unit’s walls will not 
reach the ground. As a result, window units 
with bench seats will have no foundation 
beneath them when the foundation is built.

Bay, Box, Bow Windows & Roofs
Several different roof styles are available for 
bay, box and bow window units.  

Hip Roofs
Unless a different option is selected, a hip 
roof is built above the unit when roofs are 
automatically generated.
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If a different style of roof is desired, the 
window’s specification dialog can be used to 
change the style of roof that is be generated 
over a bay, box or bow window.

See “Bay/Box/Bow Window 
Specification Dialog” on page 158.

Place Under Roof Slope
To have the main roof plane extend down 
over the window unit while following the 
shape of the unit, select Extend Existing 
Roof. Rebuild the roofs to see the changes.
 

For this roof style to work successfully, the 
ceiling heights of the window unit and the 
room containing it must be the same. This 
does not work if you have lowered the 
ceiling for the window unit.

If a header is desired over the bay, box or 
bow window, first build the roof correctly, 
then lower the ceiling of the bay, box or bow 
window in 3D. This fills in the area between 
the header and the roof. Do not rebuild roof 
planes, if you do, a lower hip roof over the 
window unit is created.

Use Existing Roof
To generate a standard roof with no 
allowances made for bay, box, or bow 

windows below, check Use Existing Roof. 
With this option the bay, box, or bow 
windows is tucked under the roof eave.

Place Under Roof - Rectangular
To extend the roof plane down over a bay, 
box or bow window with a rectangular roof, 
ignoring the shape of the unit, select both 
Extend existing roof over and Rectangular 
roof over in the specification dialog. The 
Rectangular roof over option does not work 
in combination with Use existing roof since 
the existing roof does not cover the window 
unit.

See the previous section for directions on 
extending the roof down over bay, box or 
bow windows. 

Rectangular Hip Roof
To create a rectangular hip roof, select only 
Rectangular roof over, then rebuild the 
roof.
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Gable Roof
A gable roof is not one of the automatic 
options for the roof above a bay, box or bow 
window.

Window Specification Dialog
To open the Window Specification 
dialog, select a window and click the 

Open Object edit button or double-click the 

window using the Select Objects  or a 

Window  tool. 

The settings in this dialog are similar to those 
in the Window Defaults dialog. See 
“Window Defaults” on page 144.

General Tab

To create a gable roof over a normal
window, use the Gable Over Door/

Window edit button. See “Gable Over Door/
Window” on page 181.

1
2

3
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Window Type - Select the type of 
window from the list. The first entry in 

the list is the Default type set in the Window 
Defaults dialog. 

Specify the Size and Position of the 
selected window. 

• Specify the Width and Height of the 
window. 

• Floor to Top - Specify the height of the 
top of the window frame as measured 
from the subfloor. 

• Movable Size - Specify the dimension of 
the movable portion of the window. A 
value of 0 defaults the movable size to 

whatever is normal for that type of win-
dow. Not available for Fixed Glass, Sin-
gle or Double Casement, Single Awning 
or Hopper, Louvered, Pass-Thru or 
mulled units. 

• Louver Size - Specify the vertical height 
of the selected window’s louvers. Only 
available for Louvered windows. 

A preview of the selected window 
displays here. 

• Select Interior or Exterior to specify 
which side of the window displays in the 
preview.

Casing Tab
Changes made on the Casing tab can only be 
seen in 3D views.  

Specify the casing for the selected window or 
mulled unit. 
• Select the Interior or Exterior radio but-

ton to define the casing for that window 
side and display it in the preview image. 

• Define the Width of the selected casing.

• Check Suppress Casing to have a 
wrapped opening instead of casing on the 
selected side of the window.

• Check Sill to have a sill on the selected 
side of the window.

• Check Apron to include an apron under 
the sill. 

1

2

3
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Sash & Frame Tab

Specify the size and position of the 
Sash. Increasing the Side, Middle, Top 

or Bottom decreases the area of the glass.
• Specify the Side width of all vertical sash 

members: those at the window sides as 
well as the central members of casement 
and sliding windows. This is also the 
width of the top portion of the window 
when an arch is specified.

• Specify the Middle width of horizontal 
components between the top and bottom 

sash in double hung, double and triple 
awning, and double and triple hopper 
windows. It does not affect casement and 
sliding windows.

• Specify the Top and Bottom sash widths. 
The Top value is not used if the window 
has an arch.

Specify the Depth, or thickness, of the 
sash stock measured from the exterior 

to the interior.

Lites Tab
The Lites tab allows you to add muntins to 
various window styles. There are four 
possible styles of muntin bars.

1

2
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Specify the number, position and style 
of Lites for the selected window.

• Enter the number of horizontal Lites 
Across in each sash. 

• Enter the number of vertical Lites Verti-
cal in each sash.

• Check or uncheck Lites in Fixed and 
Lites in Moveable to specify either one 
or both of the sashes to have divided lites.

Select a Type, or style, of window lite 
from the drop-down list. 

• Normal style is the most common, with 
muntins going horizontally and vertically. 
Colonial windows are an example of the 
normal style.

• Diamond style uses angled muntin bars 
to divide up the lites. French windows are 
an example of the diamond style.

• Prairie style is based on the normal style, 
but with all the central muntin bars 
removed, leaving only the two outside 
muntin bars both horizontally and verti-
cally. Typically, both Lites Across and 
Lites Vertical should be set between 6 
and 8. Federal or Federation windows are 
an example of the Prairie style.

• Craftsman style is based on the normal 
style, but only the topmost horizontal 
muntin bar is kept with all the portions of 
the vertical muntin bars above it. Typi-

cally, both Lites Across and Lites Vertical should be set between 4 and 8.

1

2

Note: Because the fixed window in a Triple
Sliding window is twice the size of the mov-
able windows, the fixed section has a vertical
muntin bar. To eliminate this, clear the Lites in
fixed check box.

1

Lites in Fixed Lites in Movable

2
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Shutters Tab
The settings on the Shutters tab allow you to 
specify exterior shutters for the selected 
window. 

Check Use Shutters to apply shutters 
to the selected window’s exterior and 

enable the settings below. 

Specify the Shutter Width for the 
selected window.

• Unheck Set Width by Window to type a 
width in the Specify Width field. If the 
window is later resized, the shutters 
width will not adjust in response.

• When Set Width by Window is checked, 
a shutter width exactly half that of the 
window, excluding casing, is used.

Additional Shutter Options can be 
specified here.

• Check Outside Casing to position shut-
ters outside the window casing, as deco-
rative shutters often are. Uncheck this to 

position the shutters just outside the win-
dow frame, like functional shutters.

• Check Louver for louvered shutters. 
Uncheck this for solid shutters. If Outside 
Casing is checked, the louvers face out-
ward, away from the wall; if checked, 
louvers face toward the wall.

A preview of the selected window displays 
on the right.
• Select Interior or Exterior to specify 

which side of the window displays in the 
preview. In order to see exterior shutters 
in the preview, Exterior must be selected. 

Materials Tab
The settings on the Materials tab are the 
same as those found on the same tab in 
dialogs throughout the program. See 
“Materials Tab” on page 284.

1
2

3

1

2
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Bay/Box/Bow Window Specification Dialog
To open the Bay/Box Window 
Specification dialog, select a bay, box 

or bow window and click the Open Object 
edit button.

The options in this dialog can only be set for 
objects placed in a plan: bay, box, and bow 
windows do not have defaults dialogs.  

Specify the structure of the Roof over the 
selected window unit. See “Bay, Box, Bow 
Windows & Roofs” on page 151. 
• Check Use Existing Roof if the existing 

roof needs no changes to accomodate the 
bay window.

• Check Extend Existing Roof to extend 
the existing roof plane to cover the bay 
window below.

• Check Rectangular Roof to create a roof 
over the bay window that is square across 
the end instead of following the profile of 
the roof.

• Check Suppress Dimension to suppress 
the automatically-produced dimensions 
that show the size of the window unit in 
floor plan view. 
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Chapter 12:

Multiple Floors

When a new plan file is opened in Home 
Designer Essentials, two floor levels are 
present: Floor 1 and the Attic Floor. You can 
add more floors whenever you like: up to 3 
total. Once created, floors can also be copied 
and deleted. 

Home Designer Essentials also supports 
special floors for foundations and attics. 
Only one foundation level and one attic can 
exist in a plan. Foundations are discussed in 
their own chapter. See “Foundations” on 
page 167.

Chapter Contents
•      Floor Defaults Dialog
•      Floor Tools
•      Adding Floors
•      Displaying Floors
•      Deleting Floors
•      Split Levels
•      The Current Floor
•      The Attic Floor
•      The Reference Floor
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Floor Defaults Dialog
There is a Floor Defaults dialog for 
each floor in a plan file. The defaults 

for the current floor can be accessed by 
selecting Edit> Default Settings. Select 
“Floor” from the category tree and click the 
Edit button to open the Floor Defaults 
dialog for the currently active floor. See 
“Default Settings” on page 42.

The Floor Defaults dialog also opens 
whenever you add a new floor to the plan. 
See “Adding Floors” on page 161. 

The Floor Defaults dialog does not open 
when you build a foundation; however, the 
Floor 0 Default settings are created based on 

the current Foundation Defaults. See 
“Building a Foundation” on page 168. 

The Floor Defaults dialog is similar to the 
Room Specification dialog, but controls the 
default settings for all rooms on the current 
floor. The settings here also control the 
height of individual walls as they are drawn 
on the floor in question. See “Room 
Specification Dialog” on page 120.

General Tab
Only one setting on the General tab is unique 
to the Floor Defaults dialog.

On Floor 1 only, define the wall layer that 
you would like to calculate the Living Area 
To. See “Living Area” on page 116.

Structure Tab
The settings on the Structure tab are similar 
to those in the Room Specification dialog. 
See “Structure Tab” on page 121. 

Moldings Tab
The settings on the Moldings tab are similar 
to those in the Room Specification dialog. 
See “Moldings Tab” on page 123. 

Fill Style Tab
The settings on the Fill Style tab are similar 
to those in the specification dialogs for many 
objects throughout the program. See “Fill 
Style Tab” on page 205. 

Note: The default floor height for Floor 1 is 0.
It can be modified in the Room Specification
dialog, but not in the Floor 1 Defaults dialog.
See “Floor and Room Defaults” on page 110.
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Materials Tab
The settings on the Materials tab are similar 
to those in the specification dialogs for many 

objects throughout the program. See 
“Materials Tab” on page 284. 

Floor Tools
Select Build> Floor to access the 
floor tools.

Select Build> Floor> Build New 
Floor to build a new floor. A new 

floor can be generated based upon the 
perimeter of the floor below or a blank floor 
can be created and drawn from scratch. See 
“Adding Floors” on page 161.

Choose Build> Floor> Build 
Foundation to open the Foundation 

Defaults dialog and build a foundation floor. 
See “Building a Foundation” on page 168.

Select Build> Floor> Delete 
Foundation to remove the foundation 

from the plan. See “Deleting Foundations” 
on page 171.

Adding Floors
New floors can be added in floor plan view 
and 3D views. 

To create a new floor

1. Select Build> Floor> Build New 

Floor  to open the New Floor dialog. 

2. Select the options that you need and 
click OK.

•  Derive new 2nd floor plan from the 
1st floor plan creates a new top floor 
with exterior walls generated directly 
over the exterior walls of the floor 

below. Wall types and roof directives 
associated with the walls on the floor 
below are duplicated; however, interior 
walls are not. See “Roof Tab” on page 
103.

•  Check Move Highest Floor’s Roof Up 
to move any roof planes displaying on 
the highest floor in the plan up one 
floor when the new floor is created. 
Roof planes displaying on floors other 
than the top floor are unaffected. This 
option is only available if there are roof 
planes built on the top floor and is not 
available when Auto Rebuild Roofs is 
enabled. See “Build Roof Dialog” on 
page 177.

•  Make new (blank) plan for the 2nd 
floor creates a new top floor that is 
blank. This option is typically selected 
only if none of the exterior walls on the 
new floor will be directly above the 
exterior walls on the floor below. If 
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you choose this method, it may be 
helpful to turn on the Reference Dis-
play when drawing walls on the new 
floor. See “The Reference Floor” on 
page 165.

3. The Room Defaults dialog for the 
newly created floor opens next. Make 
any necessary changes to the floor struc-
ture, moldings, or materials and click 
OK. See “Floor Defaults Dialog” on 
page 160.

4. The new floor becomes the current floor 
in floor plan view. If, however, the new 
floor is created in a 3D view, the camera 

remains on its original floor and does 
not move. 

Adding a Foundation
To add a foundation, select Build> Floor> 

Build Foundation . See “Building a 
Foundation” on page 168.

Displaying Floors
Home Designer Essentials allows you to 
view the floors in your plan in a variety of 
ways.

In Floor Plan View
In floor plan view, only one floor can be 
active for editing at a time. This is referred to 
as the Current Floor. See “The Current 
Floor” on page 164. 

In addition to the Current Floor, one other 
floor can be displayed for reference 
purposes: the Reference Floor. Objects on 
the Current Floor can snap to those on the 
Reference Floor, helping you align objects. 
See “The Reference Floor” on page 165.

In 3D Views
In most 3D views, all floors in a plan are 
visible, from the foundation up to the attic. 
There are two exceptions: 

• Doll House View . 

• Interior Cross Section/Elevation  
views.

 Doll House Views show the Current Floor 
only, not including its ceiling, while interior 
Cross Section/Elevation views show a wall 
on a single floor in a single room. See “3D 
View Tools” on page 302. 

Deleting Floors
Select Build> Floor> Delete Current 
Floor to remove the current floor 

from the plan. If there is a floor above, it 

becomes the current floor; if there is no floor 
below, the floor beneath becomes the current 
floor. 

Note: Home Designer Essentials allows only
one floor, the foundation/basement, below
the first floor. Keep this in mind when you
begin an as-built or plan for a multi-story
building.
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To delete Floor 0, select Build> 
Floor> Delete Foundation. You can 

delete the foundation without actually being 
on Floor 0. Floor 0 cannot be deleted while 

Auto Rebuild Foundation is turned on. See 
“Deleting Foundations” on page 171.

Stepped Floor & Ceiling Platforms
Each floor has default floor and ceiling 
heights. You can, however, use the Room 
Specification dialog to specify floor and 
ceiling heights on a room by room basis to 
create stepped floors and ceilings. See 
“Structure Tab” on page 121. 

If you require a single floor platform with a 
uniform height and thickness but different 
ceiling heights for the rooms below, specify a 
lowered ceiling using the Ceiling Finish 
Specification dialog. See “Lowered 
Ceilings” on page 118.

Split Levels
Both split level floor plans and split level 
entries can be created by controlling the floor 
and ceiling heights of individual rooms in a 
multiple story structure. 

Split Level Floor Plans
A split level, or tri-level, structure is a 
building where the floor level in one part of 
the plan is located approximately half way 
between the floor and ceiling levels of 
another part of the plan. 

To create a simple split level plan

1. Draw a simple rectangular structure 
divided into two separate halves by an 
interior wall.

2. Select one of the rooms and click the 

Open Object  edit button. See 
“Room Specification Dialog” on page 
120.

3. Raise the Floor Height then press the 
Tab key.

4. Restore the Relative Rough Ceiling to 
the default value, then click OK.

5. Build a stem wall foundation. See 
“Foundations” on page 167.

•  The foundation under the room with 
the lower floor height will have the 
specified Min Stem Wall Height. 

When a floor is deleted, all objects on
that floor are deleted with it.

Split Level Home
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•  The foundation under the room with 
the raised floor will have taller stem 
walls. 

•  Both can be edited in the Room 
Specification dialog.

6. If you add a Floor 2, note that the Ceil-
ing Height in the room on Floor 1 will 
be reset to the default value. 

•  To maintain a stepped condition on 
multiple floors, return to this room and 
set the Relative Rough Ceiling back to 
using the default.

Split Level Entries
A split level entry, or divided entry, is 
characterized by an entry door that opens 
onto a landing positioned half way between 
the basement floor and first floor levels. 

To create a simple split level entry

1. Create a plan file with a full basement at 
the location of the entry door. See 
“Basement Rooms” on page 172.

2. Go to Floor 0 and draw a stair Landing 

 at the location of the entry. See 
“Landings” on page 192.

3. Draw stairs upward from the basement 
floor to the landing.

•  The number of treads and risers in the 
stair section will determine the landing 
height.

4. Draw a second stair section from the 
landing upward. 

5. Select the stairs and click the Auto 

Stairwell  edit button. See “Creating 
a Stairwell” on page 196. 

Split level entries are often associated with 
daylight basements. See “Daylight 
Basements” on page 173. 

For more detailed instructions, visit  
www.HomeDesignerSoftware.com.

The Current Floor
Only one floor can be active at any given 
time. The active floor is referred to as the 
Current Floor, and it is the only floor on 
which objects can be edited.

If you want to edit two different floors at the 
same time, you can open the plan again. This 
opens a second window on the current open 
plan that has the same editing abilities as the 

first. Only one of these windows can be 
active at any given time.

Floor Up / Floor Down
If you are working with 
more than one floor, you 

can select Tools> Reference Floors> Up 

Split Level Entry

http://www.homedesignersoftware.com/support/displayfaq.php?faqNumber=269&subject=floors
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One Floor or Down One Floor to switch 
from one floor to another. 

You can change the current floor in floor plan 
and 3D views. The current floor displays on 

the Change Floor/Reference  button, 
which can be found between the Down One 
Floor and the Up One Floor buttons. 

Floors become available once they have been 
built. The Attic and foundation levels are 
also accessible using these tools. 

Change Floor / Reference
If there are multiple floors, select 
Tools> Reference Floors> Change 

Floor/Reference to open the Change Floor/
Reference dialog, where you can select both 
the current floor and which floor is used in 
the Reference Display, as well as control the 
appearance of the Reference Display. 

The Attic Floor
Home Designer Essentials 
automatically creates a floor above 

the top numbered floor level of each plan. 
This floor is called the Attic floor and has 
only one purpose: to provide a space for 
automatically generated Attic walls. See 
“Attic Walls” on page 101.

Because the Attic floor is not meant to be a 
living area, a warning message will display if 

you try to draw walls or other objects on this 
floor.

In some situations, you may find it necessary 
to draw one or more walls on this floor; 
however, even if you enclose an area with 
walls, rooms cannot be created on the Attic 
floor.

If you wish to create an attic loft, bonus 
room, or storage area in your plan, you will 
need do so on a numbered floor level. 

The Reference Floor
When there is more than one floor in a 
model, it is often helpful to see how different 
floors relate to each other. Any floor can be 
shown as the Reference Floor along with the 
current floor. 

When the Reference Display is turned on, the 
floor that you were last on prior to the current 
floor is used as the Reference Floor. Objects 
on the Reference Floor cannot be selected or 
edited.

Reference Display
To display the Reference Floor, select 
Tools> Reference Floors> Reference 

Display or press F9 on your keyboard.  

If the Reference Display is turned on when a 
view is printed, it will be included in the 
printed output. See “Display Options and 
Printing” on page 364. 
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Reference Display Options
The display of objects in the 
Reference Display is controlled by 

selecting Tools> Reference Floors> 
Reference Display Options. See “Display 
Options Dialog” on page 49.

Change Floor / Reference
By default, the floor below the current 
floor is the Reference Floor, but any 

floor can be referenced using the Change 
Floor/Reference dialog. To open the dialog, 
select Tools> Reference Floors> Change 
Floor/Reference button. 

The Reference Floor currently used for 
reference is highlighted here. You can 

select another floor. 

The Current Floor is highlighted here. 
You can select another floor to make it 

the current floor.

Swap Floor/Reference
If one floor is defined as the current 
floor and another floor is defined as 

the reference floor, select Tools> Reference 
Floors> Swap Floor/Reference to switch 
the status of the two floors.

Note: If objects on the current floor and the
Reference Floor have edges that line up, the
Reference Floor may be difficult to see on
screen. When lines of two different colors are
superimposed upon each other, discoloration
may result.

1
2

1

2
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Chapter 13:

Foundations

There are two foundation types in Home 
Designer Essentials: stem walls with footings 
and monolithic slab. The foundation type can 
be specified in the Foundation Defaults 
dialog when the foundation is built.

There can be only one foundation level in 
your plan, Level 0. Foundation walls can be 
drawn on upper floors using the Wall tool.

Chapter Contents
•      Foundation Defaults
•      Building a Foundation
•      Displaying Foundations
•      Editing Foundations
•      Deleting Foundations
•      Foundations and Rooms
•      Foundations and the Terrain

Always consult registered geotechnical
and civil engineers for information

regarding the proper foundation for your site. 
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Foundation Defaults
Foundation Defaults can be accessed 
by selecting Edit> Default Settings. 

Select “Foundation” and click the Edit 
button to open the Foundation Defaults 
dialog. 

The settings in the Foundation Defaults 
dialog are similar to those in the Build 

Foundation dialog, which opens when 

Build> Floor> Build Foundation  is 
selected. The primary difference is that when 
you click OK in the Foundation Defaults 
dialog, no changes are made to the model. 
See “Building a Foundation” on page 168.

Click the radio button beside either 
Monolithic Slab or Walls with Footings to 
specify which foundation type the program 
should build.

Wall Thickness - Specify the desired 
thickness of the foundation wall. See “Wall 
Thickness” on page 97.

Wall Height - Specify the desired height of 
the foundation walls. 

If the wall height is at least 6 feet (1800 mm), 
a slab floor is generated above the footings 
and inside the foundation walls. The Wall 
Height includes the thickness of this slab.

If you do not want this slab, specify the 
“rooms” on Floor 0 as Open Below in the 
Room Specification dialog. See “Available 
Room Types” on page 113.

Building a Foundation
Two foundation types are available: 
stem walls with footings and 

monolithic slabs. The first option is created 

using walls; the second creates concrete slabs 
with footings.
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Automatically built foundations are placed 
on Floor 0 and are based on wall positions 
and floor heights on Floor 1. Foundation 
walls or slab footings are generated under:
• All exterior walls on Floor 1 that define a 

room other than a Court, Deck or Bal-
cony room type. See “Room Definition” 
on page 110.

• Any interior walls on Floor 1 defining 
rooms with different floor heights. See 
“Floor & Ceiling Heights” on page 117. 

At least one room must be defined on Floor 1 
for a foundation to be automatically 
generated. If no rooms are defined on Floor 
1, a blank Floor 0 is created. 

Once a foundation is generated, you can add 
interior walls to customize it.

To build an automatic foundation

1. Select Build> Floor> Build Founda-

tion . 

2. Specify the desired foundation type and 
other information in the Build 
Foundation dialog. The settings in this 
dialog are similar to those in the Foun-
dation Defaults dialog. See “Foundation 
Defaults” on page 168.

3. In the New Floor dialog, select Derive 
new Foundation plan from the 1st 
floor plan and click OK to build a foun-
dation based on Floor 1.

If you prefer, you can instead select Make 
new (blank) plan for the Foundation to 
create an empty foundation level where you 
can manually draw foundation walls or slabs.

In most cases, it is preferable to base Floor 0 
off the first floor plan and then manually edit 
the foundation as needed. See “Editing 
Foundations” on page 170.

Displaying Foundations
The display of foundation walls, slabs, 
curbs and footings is controlled in the 

Display Options dialog. See “Display 
Options Dialog” on page 49. 
• Foundation Walls, including slab footings 

and Garage curbs, are placed on the 
“Walls, Foundation” layer.

• Footings under Foundation Walls and 
slab footings are placed on the “Foot-
ings” layer. 

In floor plan view, foundation walls are 
drawn with solid lines and footings, with 
dashed lines. 

If a door on Floor 1 extends into a stem wall 
or curb defining a Garage room, its location 
will be indicated on Floor 0.

In 3D views, all objects on Floor 0 will only 
display when the “Foundation” layer is 
turned on. 

While the display of foundation walls and 
their footings can be controlled independent 
of one another in floor plan view, in 3D 
views this is not the case. If a foundation 
wall is set to display, its footing will as well - 
even if the “Footings” layer is turned off. The 
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reverse is also true - if a foundation wall’s 
display is turned off, so will its footing’s.

The display of monolithic slab foundations in 
3D views is controlled by the “Foundation” 
layer. Slab footings are located on the 

“Walls, Foundation” layer; but if this layer is 
turned off, any slab footings that define a 
foundation room will continue to display as 
long as the “Foundation” layer is on. 

Editing Foundations
Stem wall with footings and monolithic slab 
foundations are all created using walls which 
enclose room areas.
• Foundation walls can be selected and 

edited much like other walls. See “Edit-
ing Walls” on page 96.

• Foundation rooms can also be selected 
and edited like other rooms. See      Foun-
dations and Rooms.

Rebuilding Foundations
By default, foundations do not update 
automatically when changes are made to the 
structure on Floor 1. For example, if exterior 
walls are moved or floor platforms are raised 
or lowered, the foundation must will be 
rebuilt.

If you prefer that the foundation not rebuild 
automatically, you can uncheck Auto 
Rebuild Foundation in the Foundation 
Defaults dialog. See “Foundation Defaults” 
on page 168.

You can rebuild an automatically generated 
foundation by selecting Build> Floor> 

Build Foundation  from the menu. 

Changing Foundation Types

When a foundation is generated, the program 
creates Floor Defaults settings for Floor 0 
based on the information in the Build 
Foundation dialog. If you specify a 
Monolithic Slab foundation, the default 
Floor Structure on Floor 1 will also be 
changed to a slab rather than a framed 
platform. See “Floor Defaults Dialog” on 
page 160.

If you rebuild the foundation using a 
different Foundation Type, these Floor 
Defaults settings will not change, so you 
should expect to adjust the structural settings 
for Floor 1 and Floor 0 Defaults, particularly 
the floor heights. 

Once your Floor Defaults settings are 
adjusted as needed, it is advisable to check 
the floor heights of all rooms on Floor 1 - 
particularly Garage and Slab rooms, as well 
as any rooms that do not use the default floor 
height of 0”.

To avoid unexpected results, it is rec-
ommended that you not change the

Foundation Type once the foundation is built.
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Stem Wall Height
When a foundation is created, all of Floor 0 
uses the stem wall height specified in the 
Foundation Defaults dialog, 

This height is measured from the bottom of 
floor platform of Floor 1 to top of the stem 
walls’ footings. If Floor 1 has multiple floor 
platform heights, the foundation stem walls 
will be stepped.

Once a foundation is created, stem wall 
heights can be adjusted either on a room-by-
room basis or for individual walls.

To change a room’s stem wall height

1. Select a room on Floor 0 and click the 

Open Object  edit button. 
2. Specify the desired Stem Wall Height 

in the Room Specification dialog. See 
“General Tab” on page 120.

3. If you wish to reduce the Stem Wall 
Height, you will first need to reduce the 
Ceiling Height value by the same 
amount.

If adjacent rooms have stem wall heights that 
differ by at least 1/16 of an inch, the stem 
wall separating them uses the larger of these 
two values.

Deleting Foundations
Select Build> Floor> Delete Foun-
dation to delete the entire foundation 

floor. 

You can also select and delete individual 
foundation walls and slabs by clicking the 

Delete  edit button or pressing the Delete 
key. See “Deleting Objects” on page 82.

Deleting and rebuilding the foundation is 
often the quickest way to update the model 
when substantial changes are made to Floor 1 
after the foundation is built.

Foundations and Rooms
When a foundation plan is created, rooms 
included in the Living Area calculation 
generate a stem wall or slab foundation 
below them. Garage rooms generate slab 
foundations, but exterior rooms such as 
Decks, Courts and Balconies do not generate 
any foundation. 

Interior foundation walls are not generated 
unless:

• They separate the area under a Slab or 
Garage room from the rest of the plan;

• They define areas under rooms with dif-
ferent floor heights.

Note: To remove all or part of the concrete
slab in the basement area, select a basement
room and define it as Open Below in the
Room Specification dialog.
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Garages
When a foundation is generated based on the 
floor plan of Floor 1, a room on the first floor 
specified as either a Garage or Slab type will 
receive a foundation with a slab floor and 
stem walls. If a monolithic slab foundation is 
generated, the room will receive a slab floor 
with curbs.

By default, a room on Floor 1 specified as a 
Garage or a Slab will be assigned a lower 
floor height when the foundation is built. The 
amount that it is lowered depends on the 
foundation type:
• The floor height will drop the default 

thickness of the floor platform for Floor 1 
plus 12” (300 mm) - a total of 24 5/8” 
(618 mm) - in a Walls with Footings 
foundation.

• The floor height will drop 3 1/2” (88 mm) 
in a Monolithic Slab foundation. 

To build a Garage slab with stem walls

1. Before the foundation is generated, 
specify the room as a Garage or Slab. 

2. Build a Wall with Footings foundation.

To build a Garage slab with curbs

1. Before the foundation is generated, 
specify the room as a Garage or Slab. 

2. Build a Monolithic Slab foundation, 
specifying the required Lower Garage 
Floor value.

Basement Rooms
When a foundation’s type is Walls with 
Footings and it is assigned a Minimum Wall 
Height of 76” (1900 mm) or greater, the 
resulting basement is automatically created 
with a 4” (100 mm) concrete slab floor. 

Similarly, if a foundation is set up to have a 
Basement Ceiling Height of 72” (1800 mm) 
or greater when built, it is automatically 
given a painted drywall Ceiling Finish. 

Regardless of its ceiling height, however, 
you can specify a ceiling finish for any room 
in the Room Specification dialog. See 
“Structure Tab” on page 121.

The resulting basement can be divided into 

separate rooms using Interior Walls  or 
any wall type you wish.

Foundations and the Terrain
Home Designer Essentials automatically 
positions the terrain a set distance below 
Floor 1. See “Terrain Height vs Floor 
Height” on page 238. 

In a plan with a foundation present, this 
distance will be: 

• 6” (187 mm) below the top of the stem 
walls in a Walls with Footings founda-
tion. 

• 8” (200 mm) below the top of the slab in 
a Monolithic Slab foundation. 
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Not all foundations have these requirements, 
of course, so you can customize your 
foundation and terrain to suit your needs.

Daylight Basements
Daylight basements, also referred to as look-
out basements, have walls that are tall 
enough for basement windows to be 

positioned above the terrain. They are often 
found in split level or split entry structures.

To create a daylight basement condition,  
build a stem wall foundation and modify 
these settings in the Terrain Specification 
dialog: 
• Uncheck Auto Calculate Elevation.
• Increase the Building Pad Elevation, 

which is the distance between the default 
floor height of Floor 1 and the terrain. 

Stepped Foundations
A stepped foundation will be produced 
automatically if more than one floor height is 
present on Floor 1 when the foundation is 
built. 

You can also create a stepped foundation by 
editing foundation rooms. See “Stem Wall 
Height” on page 171.

Floor platform

Stem Wall Top

Terrain
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Chapter 14:

Roofs

Home Designer Essentials’s automatic Roof 
Tools allow you to draw almost any roof 
style. 

Proficiency with the Roof Tools can only be 
attained through practice, but mastering 
these tools saves you time and effort in plan 
development. For information about creating 
specific roof styles, see “Roof Tutorial” on 
page 61 of the User’s Guide.

Chapter Contents
•      Roof Defaults
•      The Roof Tools
•      Automatic Roofs
•      Build Roof Dialog
•      Editing Roofs
•      Skylights
•      Roof Hole/Skylight Specification Dialog
•      Gable Over Door/Window
•      Roof Pitches in Degrees
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Roof Defaults
Select Edit> Default Settings, to 
open the Default Settings dialog for a 

variety of drawing tools, several of which 
directly affect roof generation. 

Build Roof Dialog
While not listed in the Default Settings 
dialog, the Build Roof dialog functions as 
the defaults dialog for roofs. Many, but not 
all, initial default values for automatically 
generated roofs are set in this dialog. See 
“Build Roof Dialog” on page 177.

Floor and Ceiling Heights
The initial heights of floors and ceilings, 
which influence roof heights, are specified in 

the Floor Defaults dialog for each floor. See 
“Floor Defaults Dialog” on page 160.

The floor and ceiling heights in individual 
rooms also influence roof heights and are 
specified in the Room Specification dialog. 
See “Structure Tab” on page 121.

Wall Specification Dialog
By default, when a roof is built, a roof plane 
is generated over each exterior wall, creating 
a hip roof. 

Any deviations from this default hip roof, 
such as a gable or a different pitch, can be 
specified in the Wall Specification dialog for 
any exterior wall. See “Roof Tab” on page 
103. 

The Roof Tools
Select Build> Roof to access the Roof 
Tools. 

Build Roof
Select Build> Roof> Build Roof to 
open the Build Roof dialog, specify 

the settings for automatically generated roof 
planes, and build or rebuild a roof. See 
“Build Roof Dialog” on page 177.

When roofs are automatically generated, a 
roof plane is created over each exterior wall 
by default, resulting in a hip roof.

To automatically generate a roof plane using 
values other than the defaults or to not 
generate a roof plane bearing on a particular 

wall (as with a gable or the sides of a shed 
roof), you can change the settings in the Wall 
Specification dialog. See “Roof Tab” on 
page 103.

For more information about creating 
different roof styles, see “Roof Tutorial” on 
page 61 of the User’s Guide. 

Skylight
Select Build> Roof> Skylight, then 
draw a rectangle over an existing roof 

plane to create a skylight. The skylight, sky-
light shaft, and ceiling hole (if a ceiling 
exists) are drawn at the same time. See 
“Skylights” on page 179.
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Delete Roof
Select Build> Roof> Delete Roof to 
delete all roof planes in the plan. See 

“Deleting Roof Planes” on page 179.

Automatic Roofs
When roofs are automatically generated, a 
roof plane is created over each exterior wall 
by default, resulting in a hip roof.

Roof Directives in Walls
To automatically generate a roof plane using 
values other than the defaults or to not 
generate a roof plane bearing on a particular 
wall (as with a gable or the sides of a shed 
roof), you can change the settings in the Wall 
Specification dialog for that wall. See “Roof 
Tab” on page 103.

For more information about creating 
different roof styles, see “Roof Tutorial” on 
page 61 of the User’s Guide. 

Rebuilding Roofs
When changes are made to the model, the 
roof does not update to reflect these changes.

You can rebuild the roof at any time to reflect 
the current state of the model by opening the 
Build Roof dialog and clicking OK.

Build Roof Dialog
The Build Roof dialog is used to 
automatically build or rebuild roof 

planes.To open the Build Roof dialog, select 

Build> Roof> Build Roof .

Roof planes are generated based on the 
positions and roof directive settings for each 
exterior wall in the plan. If you make 
changes to any of these walls, you will need 
to build the roof again for them to take effect. 
See “Roof Tab” on page 103. 

There are three tabs in the Build Roof dialog: 
•      Roof Tab
•      Materials Tab
•      Roof Styles Tab
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Roof Tab

Check Ignore Top Floor to build the 
roof so that it bears on the walls of the 

floor below the top living floor in the plan. 
When unchecked, the roof builds so that it 
bears on the walls on the top floor of the 
plan.

The options in the Specifications 
section are basic roof structure settings. 

• Enter a value to describe the Pitch as a 
ratio over 12. For a conversion to degrees, 
see “Roof Pitches in Degrees” on page 
183.

• Min. Alcove - Specify the minimum 
width of an alcove (depression into an 
otherwise straight exterior wall). Any 
alcove less than the specified width is 
treated as though the exterior wall contin-
ues straight across. Alcoves that measure 
wider than this value are not roofed over; 
they cause a change in roof planes. 

Following is an example showing this 
difference. If Min Alcove is 36", a 36" wide 
alcove requires a change in the roof line. 
Each wall of the alcove has an eave. On the 

right, the alcove is less than the 36" 
minimum, so the roof passes right over it.

The Roof Overhang is measured 
horizontally from the exterior surface 

of the wall’s framing layer to the end of the 
top of the rafter. It does not include gutters, 
sheathing or siding. 
• Normal is the overhang at the eaves and 

is always the overhang for a roof plane 
having the default Pitch specified above. 
If the pitch for a particular roof plane is 
set differently, its overhang may try to 
maintain its fascia at the same height. 
Overhang can be greater for a shallower 
pitch, lesser for a greater pitch.

• Gable is the overhang dimension at gable 
ends or rake walls. 

1
2

3

1

2

3
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Materials Tab
The settings on the Materials tab allow you 
to specify materials for the roof’s various 
components. For information about using the 

Materials tab, see “Materials Tab” on page 
284.

Roof Styles Tab
The Roof Styles tab provides links to tutorial 
information about creating different roof 
styles automatically. Click on a roof style to 
launch the online Help to a page with 
information about the roof style you selected. 
See “Roof Tutorial” on page 61 of the User’s 
Guide. 

Editing Roofs
Unlike most other objects in Home Designer 
Essentials, roof planes cannot be selected 
and edited. To make changes to the roof, you 
must edit the edit roof directives in walls 
and/or settings in the Build Roof dialog, and 
then rebuild. See “Rebuilding Roofs” on 
page 177.

An exception to this rule is the Material 

Painter  tool, which you can use to 
change the materials used by  individual roof 
planes without rebuilding the roof. Bear in 
mind, though, that any changes made using 

the Material Painter  will not be retained 
if the roof is later rebuilt. See “The Material 
Painter” on page 282.

Deleting Roof Planes
There are several ways to delete roof planes.

Delete the entire roof quickly by 
selecting Build> Roof> Delete Roof. 

You can also delete all roof planes at 
once in the Delete Objects dialog. 

See “Delete Objects Dialog” on page 82.

Skylights
A skylight can be created by selecting 
Build> Roof> Skylight and drawing a 

rectangular polyline within a single roof 
plane. You can also simply click once within 
a roof plane to place a 2’ x 2’ skylight.

The Skylight  tool places a flat panel 
skylight into a roof hole, produces a hole in 
the ceiling platform below, and automatically 

generates the skylight shaft between these 
two holes.

To place a skylight in a vaulted ceiling, 
uncheck Ceiling Over This Room in the 
Room Specification dialog, draw the ceiling 
planes to produce the vault and edit them as 
needed, and then draw the skylight. See 
“Structure Tab” on page 121.

If the roof overhang values are not suffi-
cient to extend past the outer layer of

exterior walls, the walls may  not generate
correctly in 3D views..
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Editing Skylights
Once selected, skylights can be edited using 
the edit handles, edit toolbar buttons, or the 
Roof Hole/Skylight Specification dialog. 
See “Roof Hole/Skylight Specification 
Dialog” on page 180.

Skylights must always be contained by a 
single roof plane. If the roof plane is deleted, 
any skylights or holes it contains are also 
deleted. Aside from this restriction, skylights 
can be edited much like standard closed 
polylines. See “Editing Closed-Polyline 
Based Objects” on page 69. 

Roof Hole/Skylight Specification Dialog
Select a skylight and click the Open 
Object edit button to open the Roof 

Hole/Skylight Specification dialog. See 
“Skylights” on page 179.
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General Tab

Skylight Frame Width and Height - 
Define the width and height of the 

frame or curb of the skylight.

Angle for Inside Hole Rim - Defines 
the shape of the skylight well where it 

passes through the roof plane.
• Square Sides - The framing for the sky-

light is cut square to the pitch of the roof.
• Plumb Sides - The framing for the sky-

light is plumb-cut.
• Plumb/Square - The bottom edge is 

plumb-cut, the top edge square-cut.

Line Style Tab
For information about the settings on this 
tab, see “Line Style Tab” on page 205.

Fill Style Tab
The settings on the Fill Style tab control the 
appearance of the selected skylight in floor 
plan view. For information about these 
settings, see “Fill Style Tab” on page 205.

Materials Tab
For information about the Materials tab, see 
“Materials Tab” on page 284.

Gable Over Door/Window 

Click the Gable Over Door/Window 
edit button to add a small gable 

dormer over one or more selected doors or 
windows the next time automatic roof planes 
are built.

The Gable Line displays in floor plan view 
when the Roofs, Gable Lines layer is set to 
display. 

1

2

1

2
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The Gable Over Door/Window  edit 
button is not available for doors or windows 
placed in Full Gable Walls or if a bay, box or 
bow window is selected. See “Bay, Box, 
Bow Windows & Roofs” on page 151.

If you move or resize the door or window(s), 
the associated Gable Line does not update 
until the roof is built again.  

To remove a Gable Over Door/Window, 
select the door or window(s) and click the 

Delete Gable Over Opening  edit button. 
The next time the roof is built, the gable will 
be removed. 
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Roof Pitches in Degrees
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Chapter 15:

Stairs &
Landings

Staircases can be composed of one or more 
straight or curved stair sections and landings. 
Stairs can be drawn, selected and edited in 
2D and 3D views.

Stairwells can be created automatically or 
manually and can be seen in 3D views. 

Chapter Contents
•      Stair Defaults
•      The Stair Tools
•      Anatomy of a Staircase
•      Drawing Stairs
•      Displaying Stairs and Landings
•      Editing Stairs
•      Merging Stair Sections
•      Landings
•      Maintaining Tread Depth
•      Starter Treads
•      Wrapped Stairs
•      Other Special Railings & Stairs
•      Creating a Stairwell
•      Rooms Below Staircases
•      Staircase Specification Dialog
•      Stair Landing Specification Dialog

Local building and fire authorities must
be consulted for specific stair construc-

tion codes and access requirements.
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Stair Defaults
The purpose of interior stairs is to provide 
passage from one floor platform to another, 
so the attributes that influence floor heights - 
including ceiling heights - also influence the 

structure of stairs. When considering a 
staircase’s structure, bear in mind that riser 
height is directly dependent on the distance 
from one floor platform to another. 

The Stair Tools
Select Build> Stairs to access the 
Stair Tools.

Straight Stairs
To draw a straight staircase select 
Build> Stairs> Straight Stairs, then 

click and drag in floor plan or a 3D view. 
You can also click once to place a staircase 
that extends from the current floor up to the 
next floor. See “Drawing Stairs” on page 
188.

Click Stairs
 Select Build> Stairs> Click Stairs to 
create stairs between levels on the 

same floor with a single click of the mouse. 
Click the low side, within a few feet of where 
the floor changes height. 
• If you click on the low side of a floor 

platform defined by a railing, a doorway 
will be created in the railing, adjacent to 
the stairs. 

• If you click on the low side of a floor 
platform defined by a wall, stairs will be 
created but a doorway will not.

• If you click at a location that is not near 
the edge of a floor platform, a full height 
staircase will be created.

Curved Stairs
Select Build> Stairs> Curve to 
Left or Curve to Right and click 

once in floor plan view to place a curved 
staircase. See “Curved Stairs” on page 188.

Landing
Select Build> Stairs> Landing to 
draw a landing, which is a platform 

connecting two or more stair sections. See 
“Landings” on page 192.

There are two ways to create a landing using 
this tool:
• Click once to place a landing measuring 

39” (975 mm) on each side.
• Click and drag from end to end to draw a 

rectangular landing sized as needed. See 
“Polylines” on page 745.  
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Anatomy of a Staircase
Stairs are often described in terms of rise and 
run. Rise is typically between 6" and 8", and 
the run between 10" and 12". In metric plans,  
rise is 177 to 190 mm, and the run is about 
250 mm.

Staircase Terminology
Balusters - The vertical members that run 
between the handrail and the treads or shoe. 

Bracket - Decorative L-shaped supports on 
the exposed side of stairs below each tread.

Landing - A platform connecting two or 
more stair sections.

Newels - The end post of a stair railing 
located at landings and the beginnings and 
endings of new stair sections.

Rise - The height of a riser, measured from 
tread surface to tread surface, Also referred 
to as Unit Rise. 

Rise Angle - The angle of the staircase or 
stair section, defined by a line drawn through 
the back surfaces of its treads.

Riser - The vertical stair member located 
between the treads. Risers may be solid or 
open. When open, the front surfaces of the 
stringers are considered the risers. 

Run - The depth of a tread, measured from 
riser surface to riser surface. Run does not 
include the Tread Overhang. Also referred to 
as Unit Run. 

Runner - The carpet that runs down the 
center of the staircase.

Shoe - The bottom railing, placed on the 
landing floor, that anchors the balusters at 
landings.

Stringer - The inclined support member of a 
staircase that supports the treads and risers.

Tread - The horizontal member of a stair that 
the foot is placed on. 

Tread Overhang - The portion of a tread 
extending past the front surface of the riser 
and over the tread below. Also referred to as 
Nosing or Nosing Extension, it is not 
included in the Run or Tread Depth 
measurements.

Thread Thickness - The vertical depth of 
the tread material.

Stair Structure and the Model
Stairs locate the height of the floor platform 
that they are drawn on, and seek the next 
level, which may be the floor platform of the 
floor above or a landing. The stringers locate 
the subfloor of the floor platforms and 
maintain consistent riser height. If the stairs 
are long enough to reach the next level at a 
reasonable rise angle, their tread depth and 
number of treads are automatically 
calculated to create a staircase with 
consistent tread and riser dimensions along 
its entire length. 

Stair Sections and 
Subsections

In Home Designer Essentials, staircases can 
be composed of multiple sections and 
subsections. See “Merging Stair Sections” on 
page 190. 
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• Stair sections are separated by landings.
• Subsections are considered part of the 

same section because they are connected 

to one another directly rather than sepa-
rated by a landing.  

Drawing Stairs
Stairs can be drawn in floor plan and 3D 
views but not in cross section/elevation 
views. In 3D views, these objects can only be 
drawn in the presence of a floor platform or 
terrain perimeter. See “Working in 3D” on 
page 312.

There are a few things to keep in mind when 
drawing stairs.
• Before stairs are created, make sure that 

the heights for both the lower and upper 
floors are correctly defined. 

• Stairs are drawn going UP, so they should 
be drawn from the lower of the two floors 
they connect. 

• By default, stairs adjust their riser and 
tread dimensions to connect two floor 
heights if possible. The rise and run are 
calculated so that the steps are consistent 
in size. 

• If you have the Reference Display  
turned on, stairs snap to the reference dis-
play. 

• If a stairwell room has been defined on 
the floor above, the top of the stairs can 
be dragged until it stops at the railing or 
wall defining the stairwell.

Straight Stairs

Straight Stairs  can be created in three 
different ways:

• Click and drag in a straight line to draw 
stairs that are the length that you drag.

• Click once to place stairs that go from the 
current floor up to the height of the next 
floor level.

• Click once using the Click Stairs  
tool to create stairs between rooms on the 
same floor with different floor heights or 
between exterior rooms and the terrain.

An individual stair section must be between 
6” (150 mm) and 100’ (30,000 mm) in 
length. If a greater length is needed, connect 
two sections using a landing.

Curved Stairs
Curved Stairs can be created in 
floor plan view by selecting 

Build> Stairs> Curve to Left or Curve to 
Right. Click to place a 90º curved stair 
section that can then be edited. You can 
continue clicking to place additional curved 
staircases until another tool is selected.
• In addition, you can change a straight 

stair section into curved stairs, or vice 
versa by selecting the stairs and clicking 

the Change Line/Arc  edit button. 
See “Change Line/Arc” on page 81.

Drawing Stairs Downward
Stairs can be drawn from the current floor 
level downward; however, drawing stairs 
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between floors in this manner is not 
recommended. Drawing downward should 
only be used to create a staircase between a 
porch or deck and the terrain when you 
require the direction arrow to say “DN” 
instead of “UP”. 

To draw stairs going downward

1. Select Build> Stairs> Straight 

Stairs .

2. Hold down the Alt key or the right 
mouse button.

3. Click and drag to create straight stairs.

When drawing stairs from a floor platform to 
the terrain, or vice versa, they will locate the 
height of the terrain as long as it is lower than 
the floor height. You can also create “room” 
outside the structure and use it to establish 
the bottom height of the stairs. Then, draw in 
an upward direction from the lower platform 
to the upper platform. 

Displaying Stairs and Landings
The display of stairs and landings in 
all views is controlled in the Display 

Options dialog. Stairs and landings are 
placed on the Stairs & Ramps” layer. See 
“Displaying Objects” on page 48.

In Floor Plan View
In floor plan view, stairs and landings display 
on the floor they were drawn on and are only 
visible from the floor above if there is a 
stairwell. 

Stairs have an arrow indicating the direction 
they run. Interior stairs have an UP arrow on 
the floor they were created on and a DN 
arrow when viewed from the floor above. 
See “Drawing Stairs” on page 188. 

The style and size of a direction arrow can be 
specified in the Staircase or Ramp 
Specification dialog. The color and display 
are controlled by the “Stairs & Ramps, Up/
Down Arrows” layer. 

When a staircase is selected in floor plan 
view, the numbers associated with each of its 
sections and subsections display. Stair 

sections are assigned a single-digit number. 
Subsection numbers have two parts: a section 
number and subsection number, separated by 
a hyphen.

In 3D Views
Although stairs span between two floors, 
they can only belong to one floor. As a result, 
only multi-floor views show the upper floor 
with the platform opening and the lower 
floor with the staircase simultaneously. In  
Doll House Views, stairwells may appear as 
an empty spaces. See “3D View Tools” on 
page 302.

Stair section 
number

Stair subsection 
numbers
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Editing Stairs
Staircases can be selected and edited in floor 
plan view and 3D views. See “Selecting 
Objects” on page 60. 

Using the Mouse
When a staircase is selected, its edit handles 
display. These edit handles can be used to 
customize the object in many ways. See 
“Editing Objects” on page 59.
• Straight stair sections are edited like 

lines. They have additional edit handles 
for resizing the width of the section. See 
“Editing Line Based Objects” on page 
62.

• Curved stair sections are edited like arcs 
and also include edit handles for resizing 
the stair’s width. See “Editing Arc Based 
Objects” on page 64.

• When stair sections are merged, the edit 
handles display differently depending on 

what subsection is currently selected. See 
“Merging Stair Sections” on page 190.

• When moving merged stair sections, all 
merged sections move as one.

• Additional edit handles display on the 
first two treads of a staircase if the 

Starter Tread  edit button is clicked. 
See “Starter Treads” on page 194. 

In the Specification Dialog
Stairs can be customized in the 
Staircase Specification dialog. See 

“Staircase Specification Dialog” on page 
199.

Using the Edit Tools
A selected staircase can be edited in a variety 
of ways using the buttons on the edit toolbar. 
See “The Edit Toolbar” on page 22.

Merging Stair Sections
Any combination of straight and curved stair 
sections using Automatic Heights can be 
merged. The resulting staircase section is 
made up of subsections and, if there are no 
landings, functions as a single unit. 

Stair subsections must be drawn in the same 
direction if they are to be merged: 
• The top edge of a stair section cannot 

merge with the bottom edge of another 
section.

• Combinations of stairs drawn in the UP 
and DOWN directions cannot be merged. 

Stair subsections merge at the center points 
of their upper and lower edges. 

To merge stair sections 

1. Confirm that the stairs that you wish to 
merge are using Automatic Heights. 
See “General Tab” on page 199.

2. Position the sections so they are in the 
desired relationship to each other. 

•  In order to merge stair sections cor-
rectly, they must be parallel to one 
another.  
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•  To create merged subsections that 
change direction, make one of the 
merged sections curved.

3. Select either stair section so that its edit 
handles display.

4. Click the Extend handle on the end to be 
merged and drag it to the point where the 
two stairs are to meet. 

A staircase consisting of merged subsections 
resembles a single stair section in floor plan 
view. The UP (or DN) arrows join, becoming 
a single direction arrow. 

When a subsection is selected, the entire 
staircase is selected. Additional edit handles, 
indicating the presence of multiple 
subsections and allowing you to reposition 
the line along which they join.  See “Using 
the Mouse” on page 190.

Curved Subsections
Stair subsections attached at both ends by 
other sections do not have a free end that can 
be dragged into a curve. In this situation, 
change the middle sub-section to a curve 

using the Change Line/Arc  edit button. 
See “Change Line/Arc” on page 81.

To curve an enclosed stair subsection

1. Draw three straight stair sections and 
connect them end to end.

2. Select the middle subsection.

3. Click the Change Line/Arc  edit 
button. The center section turns into a 
curved stair section.

Merging parallel stair sections
Select the middle stair subsection
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4. Use the triangular Change Curve edit 
handle to adjust the curvature of the 
middle section as needed.

Landings
Stair landings are platforms between stair 
sections and can be created in either of two 
ways:

• Using the Landing  tool. 
• By clicking between two stair sections 

using the Straight Stairs  tool.

To create a landing between stair sections:

1. Draw two stair sections going UP. They 
can be at any angle.

2. Click between the two sections using the 

Straight Stairs  tool to create a land-
ing. Notice that only one direction arrow 
displays after the sections are joined by 
a landing.

Multiple stair sections can be connected to 
one landing. For example, two or three stair 
sections might meet at a landing with a single 
stair section continuing to the next level.

To be linked by a landing, all sections must 
be drawn in the same UP direction and the 
top of one section should be near the bottom 
of the next.

Stair sections connected with a landing will 
move together as a single unit.

A landing formed between two stair sections 
having less than a 90º angle between them 

After using Change Line/Arc

Creating a stair landing
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are created with a short edge not less than 6” 
(150 mm). This is because most building 
codes require the shortest tread to be at least 
6” wide. This edge can be manually edited to 
less than 6” if needed.

Editing Landings
Landings can be selected in 2D and 3D 
views, both individually and in groups, and 
edited using the edit handles, the edit toolbar, 
and the Landing Specification dialog. See 
“Stair Landing Specification Dialog” on 
page 202. 

Landings derive their initial materials and 
railing characteristics from the stairs attached 
to them. You can assign a unique material to 
a landing in its specification dialog or using 

the Material Painter ; however, the 
railing style is always defined by the attached 
stairs. 

Custom Shaped Landings
Landings can be edited like other closed 
polyline-based objects. You can add or 
remove edges, convert an edge from straight 
to curved, or vice versa. A curved landing 
creates curved railings. See “Editing Closed-
Polyline Based Objects” on page 69.

You can edit the shape of a landing into a 
wide variety of shapes. So that the railings of 
stair sections connect properly to the landing 
railings, make sure that each stair section end 
is snapped to a landing edge with the same 
length as the stair’s width. If necessary, use 

the Break Line  tool to create a break in a 
landing edge if it is longer than the 
connecting stairs are wide. See “Break Line” 
on page 81.

Landing Height
Landing height is controlled by the program 
and will adjust automatically as the stairs 
attached to it are modified.

Maintaining Tread Depth
Most building codes require staircases to 
maintain a consistent tread depth. 

Walk Line
By default, Home Designer Essentials 
measures the length and tread depth of a stair 
section along a walk line. The walk line is 
typically located 12" (30 cm) from the edge 
of the stair section. On curved stairs, it is 
measured from the inside edge of the curve. 

When the walk line is used on a curved stair 
section, the number and/or width of treads in 

a section or subsection changes when the 
inner edge is moved because the walk line is 
measured from this inner edge. You should 
set the stair section width to its final value as 
early as possible.
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Starter Treads
The first and second treads of a 
staircase can be turned into starter 

treads by clicking the Starter Tread edit 
button. Starter treads extend to the side of the 
staircase, have rounded edges and are 
common on traditional staircases. 

A starter tread can be added only to open 
sides of a stair section. If one side of a stair 
section is against a wall or wrapped (see 
“Wrapped Stairs” on page 195), only the 
exposed tread end can become a starter tread. 

To create starter treads

1. Click on a staircase to select it.

2. Click the Starter Tread  edit button. 
An edit handle displays on each end of 
both the first and second treads.

3. Drag either of the handles on the first 
tread outward from the stair section. If 
the stair section is against a wall, only 
one handle displays on the side opposite 
the wall.

4. As you drag, the ends of the tread 
become rounded.

5. Two additional edit handles display on 
each side of the tread, along the back 
edge. 

6. Drag either of the two square handles 
upward to increase the width of the 
rounded ends of the tread. 

7. Drag the edit handle on the second tread 
outward from the stair section to create a 
second starter tread. 
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8. To make changes to existing starter 
treads, select the stairs, click the Starter 

Tread  edit button and repeat the 
above steps as needed. 

9. When you are finished editing the starter 

treads, click the Main Edit Mode  to 
restore the stairs’ regular edit handles 
and toolbar buttons. 

Wrapped Stairs
Stairs can be wrapped around the corner of a 
deck or landing. Curved stairs and stairs with 
multiple subsections cannot be wrapped. See 
“Style Tab” on page 201.

To wrap stairs around a deck

1. Draw a deck if you have not already 
done so. See “Decks” on page 116. 

2. Use the Click Stairs  tool to draw a 
stair section on each side of the corner 
around which you want them to wrap.

3. Draw a second set of stairs on the other 
edge of the deck the same way.

4. If necessary, move the stair sections 
toward the corner of the deck. The two 
sections merge to form wrapped steps.

To wrap stairs around a landing

1. Draw two perpendicular Straight 

Stair  sections.
2. Click between them to create a landing.
3. Rotate one stair section 180°. 

You can also draw stairs down from a
deck by right-clicking to draw them or by

pressing the Alt key while you drag. See “To
draw stairs going downward” on page 189.
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4. The stairs wrap around the corner. 
Notice that the Up arrow displays on the 
most recently edited stair section.

Other Special Railings & Stairs
Stairs can be customized to meet a variety of 
needs.

Solid Railings
To create a solid rail along a staircase, create 
the Railing against, but not underneath, the 
stairs and specify it as Solid. See “Railing 
Tab” on page 104.

The solid railing recognizes the adjacent 
stairs and climbs alongside them. 

If any balusters show beyond the railing, 
eliminate them by unchecking Left railing 
or Right railing in the Staircase 
Specification dialog. See “Style Tab” on 
page 201.

Creating a Stairwell
An interior staircase must be located in a 
stairwell, an opening to the floor above. A 

stairwell is an Open Below room type on the 
floor above. See “Room Types” on page 113.

Solid Railing
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If you create a stairwell away from other 
walls so the Open Below is created in the 
center of another room, connect a wall of the 
Open Below room to another wall using an 
invisible wall. 

Creating a Stairwell 
Automatically

To create a stairwell that matches the 
perimeter of a selected staircase, click 

the Auto Stairwell edit button. This button is 
only available when a living space exists 
above the staircase. It will not be available if 
the space above is Open Below or on the 
Attic Floor.

Auto Stairwell  automatically creates a 
room on the floor above enclosed by railings, 
defined as Open Below in the Room 
Specification dialog, and given a Stairwell 
room label. This room can be selected and 
edited like any other room.

Creating a Stairwell Manually
Stairwells can also be created manually. 

To create a manual stairwell

1. Draw a two-story building. Create the 
staircase on the first floor.

2. Make the second floor the Current 
Floor and the first floor the Reference 
Floor. See “The Reference Floor” on 
page 165.

3. Select Tools> Reference Floors> 

Reference Display  to show the Ref-
erence Floor, including the stairs. 

4. On the upper floor, use the Railing  
tool to create a room around the stairs. 

Use the edit handles to position the rail-
ings as needed. 

5. Select the railings one at a time and 
move them into position. 

•  When a railing is selected, its bounding 
box shows the location of the outer sur-
face of the railing’s drywall layer. For 
best results, this outer surface (which 
does not display when the railing is not 
selected) should meet the top edge of 
the stairs.

•  If you prefer, you can also go Down 

One Floor  and adjust the top edge 
of the staircase to snap it to the surface 
of the railing on the floor above.

6. When the railings are positioned prop-
erly, select Tools> Reference Floors> 

Reference Display  to turn off the 
display of the Reference Floor.

7. Click inside the room using the Select 

Objects  tool to select it, then click 

the Open Object  edit button.
8. On the General tab of the Room 

Specification dialog, select “Open 
Below” from the Room Type list. Click 
OK to close the dialog.
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9. Place a Doorway  in the railing at the 
top step for an opening. 

10. Select the doorway and define a large 
width in the Door Specification dialog. 

If the doorway is specified wider than 
the railing, its width maximizes to fit the 
space available.

 

Rooms Below Staircases
Rooms such as closets or storage areas are 
commonly located beneath staircases.

To create a room below a staircase

1. Draw a staircase, select it, and click the 

Open Object  edit button to open the 
Staircase Specification dialog.

•  On the Fill Style tab, select None 
(Transparent) so the walls and other 
objects under the stairs can be seen.

2. On the same floor as the staircase, draw 

the Interior Walls  under them, fol-
lowing their shape. 

3. Reposition the walls as needed, making 
sure that each is entirely under the stairs.

4. The wall at the foot of the stairs should 
be placed no closer to the bottom than 
the second step.

5. Add a door and specify the Room Type.



Staircase Specification Dialog

 199

Staircase Specification Dialog
Staircases can be defined with the 
greatest accuracy using the Staircase 

Specification dialog. To open the Staircase 
Specification dialog, select a stair section 
and click the Open Object edit button or 
double-click a stair section using the 

Straight Stairs   or Select Objects  
tool. 

If a staircase is composed of multiple stair 
sections, the section that you clicked on to 
select the staircase is the Selected Section; 
however, information about all the sections is 
available and can be edited in this dialog. 

General Tab

Staircase Information - Structural 
information about the selected staircase 

displays here. This information cannot be 
edited directly, but updates as changes are 
made in the dialog. If you modify a value 
elsewhere, press the Tab key to update this 
information. 
• The first comment tells whether or not 

the staircase reaches the next level. It also 
indicates whether its rise angle is either 
steeper or more shallow than the Best Fit, 

described below. If Automatic Heights 
is unchecked, this comment instead says 
“Start and end heights are set manually”. 

• The second comment, Best fit riser 
height of ___ requires ___ total risers 
to reach ___ to next level, describes the 
ideal rise and run for the selected 
staircase. The program defines the Best 
Fit Riser Height as the riser height closest 
to 6 3/4” (168.75 mm) that allows the 
selected staircase to meet the next level 

It is recommended that all floor heights,
ceiling heights and platform thicknesses

be established before using the Staircase
Specification dialog.

1

2

4

3

1
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precisely.  This comment is only active if 
Automatic Heights is checked, below.

• The total number of stair Sections, 
Landings, and Risers associated with the 
selected staircase also display here. 

• The Rise Angle of the currently active 
stair section also displays here.

• Click the Make Best Fit button to add or 
remove risers to the Selected Section. 
Only available when Automatic Heights 
is checked and the staircase does not cur-
rently use the Best Fit Riser Height. 

Make Best Fit will also extend stairs drawn 
in a downward direction until they reach the 
terrain. See “Terrain Perimeter” on page 237. 

The Advanced Options apply to all 
sections and subsections.

Automatic Treads, Lock Tread Depth, and 
Lock Number of Treads affect how treads are 
calculated. Only one of these options can be 
selected at a time. 
• Select Automatic Treads to have the 

program define the depth and number of 
stair treads. If the staircase has multiple 
sections, each may have different tread 
depths. 

• Select Lock Tread Depth to specify the 
Tread Depth for each stair section, below, 
and prevent them from changing. When 
Lock Tread Depth is selected and the 
length of the stairs is changed, the num-
ber of treads will change.

• Select Lock Number of Treads to spec-
ify the number of treads in each stair sec-
tion and prevent it from changing. When 
Lock Number of Treads is selected and 
the length of the stairs is changed, the 
tread depths will change.

• Uncheck Automatic Heights if you 
would like to specify the bottom and top 
heights of each stair section, as measured 
from the default floor height of Floor 1, 
0” (mm). When checked, the program 
automatically defines the top and bottom 
heights by precisely locating floor plat-
forms and landings.

Lock Bottom and Lock Top are actions rather 
than settings. If you make changes to the 
staircase that will affect its length, first lock 
either the bottom or top end of the Selected 
Section to prevent it from moving. The 
height of the Selected Section’s locked end is 
not affected by these settings - only its 
position on the X/Y axis.
• Select Lock Bottom to lock the position 

of the selected stair section’s bottom end 
to prevent it from moving. Sections and 
landings below the selected section do 
not move when you click OK, while 
those above do move.

• Select Lock Top to lock the position of 
the selected stair section’s top end to pre-
vent it from moving. Sections and land-
ings above the selected section do not 
move when you click OK, while those 
below do move.

The specifications for each stair section 
and subsection display and can be edited 

here. A maximum of ten items can display. 

A change in one value usually affects other 
values. You may need to reposition the 
staircase after making changes.

2

If you select a staircase by clicking near
its bottom end, Lock Top will be

selected; if you select it near its top end, Lock
Bottom will be selected. 

3
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• The Section # column identifies the 
Selected Section and the number of each 
section of the selected staircase. The 
radio button to the left indicates which 
section or subsection is selected. See 
“Displaying Stairs and Landings” on 
page 189.

• Define the Length, or run, of each sec-
tion measured along the Walk Line. The 
length is equal to the number of treads 
multiplied by the tread depth. See “Walk 
Line” on page 193.

When the length of a section changes, 
other sections and landings in the stair-
case unit move in response. You can 
specify whether the bottom or top edge of 
the Selected Section moves when you 
resize it by selecting either the Lock Bot-
tom or Lock Top radio button, above. 

• Define the Width of each section.  If a 
section is connected to a landing, its 
width should equal the length of the land-

ing edge that it connects to. See “Land-
ings” on page 192. 

• Specify the Tread Depth, or run, of each 
stair tread in the selected section. 

• Define the number of Treads in a stair 
section or subsection.

• Define the Bottom Height, the height of 
the stair section’s bottom edge. To lock 
this value, click the radio button to the 
left of the section’s number, then click the 
Lock Bottom radio button, above, and 
click OK.

• Define the Top Height, the height of the 
stair section’s top edge. To lock this 
value, click the radio button to the left of 
the section’s number, then click the Lock 
Top radio button, above, and click OK. 

• Define the Riser Height, the height of 
the risers in each stair section. 

A diagram of a sample staircase’s  
structure displays here for reference. 

Style Tab
The settings on the Style tab affect all stair 
sections and subsections. 

• Uncheck Open Underneath to add a 
skirt below the staircase along the two 
sides. It looks like a wall in 3D, but it has 

only a single face. Base molding does not 
generate along the bottom of the skirt, 
and doors cannot be placed in it.

4
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In most cases, the recommended way to 
enclose the area beneath stairs is to use walls. 
See “Rooms Below Staircases” on page 198.
• Check Open Risers to eliminate the riser 

face under each tread and expose the 
stringers. If Closed Sides is also selected, 
no central stringer is supplied.

• Check Large Stringer Base to widen the 
stringers at the foot of the staircase. This 
is helpful when walls are created below 
the stairs.

• Uncheck Left Railing and/or Right Rail-
ing to suppress the hand rail on that side 
of the staircase. Both boxes are checked 
by default. 

• Specify the Railing Width, which is the 
width of the hand rail. 

• Specify the Runner Width. The default 
value of 0 does not create a runner. Only 

available when Open Risers is 
unchecked, above.

Line Style Tab
The settings on the Line Style tab are 
available for a variety of other objects in the 
program. For information about these 
settings, see “Line Style Tab” on page 205.

Fill Style Tab
The settings on the Fill Style tab affect the 
appearance of the selected staircase in floor 
plan view. For information about these 
settings, see “Fill Style Tab” on page 205.

Materials Tab
The settings on the Materials tab affect the 
appearance of the selected staircase in 3D 
views and are available for a variety of 
objects throughout the program. For 
information about these settings, see 
“Materials Tab” on page 284.

The settings on this tab will also affect the 
materials applied to any landings attached to 
the selected staircase. See “Landings” on 
page 192.

Stair Landing Specification Dialog
Select a landing and click the Open 
Object edit button to open the Stair 

Landing Specification dialog. See 
“Landings” on page 192.

Polyline Tab
The Polyline tab indicates the length of the 
landing’s Perimeter, its enclosed Area, and 
its Volume. 

The settings on the this tab are available for a 
variety of other objects in the program.

Large Stringer Base shown at right
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Selected Line Tab
The Selected Line tab is available when the 
selected edge is a line as opposed to an arc. 
See “Selected Edge” on page 60.

The settings on this tab are available for a 
variety of other objects in the program.

Specify the Length and Angle of the 
selected line.

The X and Y coordinates for the Start 
point of the line display here.

Specify the X and Y coordinate for the 
End of the line here.

Moving the End of a line segment moves the 
start of the next connected line.

Selected Arc Tab
The Selected Arc tab is available only when 
the selected edge has been converted to an 
arc. See “Change Line/Arc” on page 81.

The settings on this tab are available for a 
variety of other objects in the program.

1 2

3

1

2

3



204

Home Designer Essentials 2012 Reference Manual

Arc - These settings define the arc. 

• Center X - The x coordinate for the cen-
ter of the arc displays here for reference.

• Center Y - The y coordinate for the cen-
ter of the arc displays here for reference.

• Radius - Specify the distance between 
the center of the arc and the arc surface.

• Start Angle - The angle of a line drawn 
from the arc center to the arc start dis-
plays here for reference.

• End Angle - Specify the angle of a line 
drawn from the arc center to the arc end.

• Arc Angle - Specify the angle between 
the center of the arc and each end.

• Arc Length - Specify the length of the 
arc along the curve.

Start  - Information about the starting 
point of the selected arc displays here.

• Start X - The X coordinate of the arc’s 
starting point displays here.

• Start Y - The Y coordinate of the arc’s 
starting point displays here.

• Start Direction - Specify the angle of a 
tangent line at the start of the arc.

End - Information about the end point 
of the selected arc displays here.

• End X - Specify the X coordinate for the 
end of the arc.

• End Y - Specify the Y coordinate for the 
end of the arc.

• End Direction - The angle of a tangent 
line at the end of the arc displays here.

1 2
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Chord - Define the selected arc’s 
chord, which is the line drawn between 

its start and end points.

• Chord Length - The straight line dis-
tance between the two ends of the arc.

• Chord Angle - Specify the angle of the 
chord.

Line Style Tab
The settings on the Line Style tab are 
available for a variety of objects throughout 
the program. 

Click the color bar and specify the Line 
Color used to represent the selected 

object. See “Color Chooser Dialog” on page 
290.

Select a Line Style to represent the 
selected object from the drop-down list. 

Fill Style Tab
The settings on the Fill Style tab affect the 
appearance of the selected landing in floor 
plan view.

Choose a Fill Pattern from the drop-
down list. 

4
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The options that follow are disabled until you 
select a pattern other than None from the Fill 
Pattern drop-down list.

Define the Spacing for the selected fill 
pattern. 

Check Transparent Pattern Fill to 
make the fill pattern transparent. When 

you check this option, any objects behind the 
fill pattern are visible through it. 

 Fill Pattern Color - Select a line color 
or fill color if a solid fill is specified. 

This overrides the layer color. See “Color 
Chooser Dialog” on page 290.

 A preview of the selected pattern 
displays here. As changes are made to 

the settings on this tab, the preview will 
update.

 Choose a Preview Width from the 
drop-down list. This value controls how 

large an area the preview represents. The 
selected value indicates the length of each 
side of the preview in actual plan inches 
(mm). 

Materials Tab
When a landing is attached to stairs, its initial 
materials are derived from the stairs.  

The settings on this are available for a variety 
of objects throughout the program. For 
information about these settings, see 
“Materials Tab” on page 284.

2

3

4

5

6



 207

Chapter 16:

Electrical

The electrical plan shows the location of all 
electrical objects such as lights, switches, 
outlets, smoke detectors and vent fans. Basic 
wiring diagrams show which objects share 
circuits and the locations of the controlling 
switches.

Electrical objects can be displayed in 2D and 
3D views. Some electrical light fixtures also 
add light sources to 3D views. See 
“Lighting” on page 318.

Usually, the electrical plan is one of the last 
additions to a plan since the position of most 
electrical objects is determined by the 
location of walls, cabinets and other objects.

Chapter Contents
•      The Electrical Tools
•      Creating Wiring Schematics
•      Auto Place Outlets
•      Electrical Library
•      Displaying Electrical Objects
•      Editing Electrical Objects
•      Electrical Service Specification Dialog

Building requirements vary throughout
the country and around the world. It is

your responsibility to comply with local codes.
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The Electrical Tools
Select Build> Electrical to access the 
Electrical Tools. 

Click in floor plan view to place an electrical 
object. Some can only be placed against 
walls, some only on the ceiling or floor, and 
some automatically change as needed. If you 
click within 12" of the wall, the selected 
object is placed on the wall. 

Once an electrical object has been placed, it 
can be edited in the Electrical Service 
Specification dialog. See “Electrical Service 
Specification Dialog” on page 211.

Outlets
Select Build> Electrical> 110V 
Outlet to place 110 volt duplex 

outlets in walls or on the floor. Select Build> 
Electrical> 220V Outlet to place 220 volt 
outlets. 

Certain room types and situations cause 
various types of outlets to be placed. For 
example:
• In rooms defined as Kitchen, Bath or 

Master Bath, Ground Fault Circuit Inter-
rupt (GFCI) outlets are placed. 

• Outlets placed on the wall behind a base 
cabinet containing a dishwasher or sink 
are placed at the normal 12" (300 mm) 
above the floor. If an outlet is placed 

above a cabinet, the default Above Cabi-
net Default Height is used instead. 

• Outlets placed outside the building or in 
an exterior area such as a deck or porch 
are labeled WP, or Water Proof.

To take advantage of the program’s 
capabilities, define room types properly 
before placing electrical objects. See “Room 
Types” on page 113.

Light Fixtures
Select Build> Electrical> Light to 
place light fixtures. All light fixtures 

placed in a plan can also serve as light 
sources in  3D views. To place a light fixture 
using the Light tool
• Click near a wall to place a wall-mounted 

fixture at that location. 
• Click away from a wall to place a ceiling 

mounted light. 
• Some light symbols from the library can 

be mounted under wall cabinets, as well. 

Switches
Select Build> Electrical> Switch to 
place electrical switches as specified 

in the Electrical Defaults dialog. Like 
outlets, the height of switches is measured 
from the floor to the center of the object.

An electrical switch can be placed on either a 
wall or a cabinet, depending on the type of 
switch. A selection of each type is available 
in the Library Browser. See “Placing Library 
Objects” on page 274.

If standard outlets are placed in a room
prior to defining it as a Kitchen or Bath,

you should replace them with GFCI outlets.
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Lighting and Electrical 
Libraries

A selection of free-standing and 
ceiling-, wall- and cabinet-mounted 

light fixtures is available in the Library 
Browser at Home Designer Essentials Core 
Catalogs> Architectural> Lighting. 

Special use outlets, switches, jacks and 
numerous other electrical items can be found 
at Home Designer Essentials Core 
Catalogs>Architectural> Electrical. See 
“The Library” on page 265. 

Creating Wiring Schematics

Connect Electrical
Select Build> Electrical> Connect 
Electrical to illustrate circuits. Using 

this tool, you can show which lights and 
outlets are attached to any given switch. 

To create a new circuit or to add to an 
existing circuit, click one electrical object 

while using Connect Electrical  tool, 
drag to the next object and release.

Remove an electrical object from a circuit by 

selecting it and clicking the Delete  edit 
button. See “Deleting Objects” on page 82.

More than one switch can control an object 
or group of objects. Two switches controlling 
the same objects are referred to as three-way 
switches. Three switches controlling the 
same objects are called four-way switches. 
The number of “ways” is one more than the 
number of switches in the same circuit. This 
number displays with the switch symbol in 
floor plan view.

Auto Place Outlets
Select Build> Electrical> Auto Place 
Outlets and click in a room tool to 

place outlets, usually 110 volt, around the 
entire room at intervals not greater than 
twelve feet so that no wall position is farther 
than six feet (1800mm) from the nearest 
outlet. 

It is important that the room type be defined 

before using Auto Place Outlets  so that 
outlets are placed appropriately in each room 

type. For example, GFCI (Ground Fault 
Circuit Interrupter) outlets are placed over 
cabinets in Kitchen, Bath and Master Bath 
rooms 

Stand-alone or built-in appliances such as 
ranges, washers, and dryers each have their 
required 110 volt or 220 volt outlets placed 
automatically. Lights are always placed 
above sinks.

If you connect two or more switches in a
circuit, they update to 3-way or 4-way

switches automatically.
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Auto Place Outlets  requires a room to 
have a door before outlets are automatically 
placed and does not work in any room 
defined as an exterior room. Exterior rooms 
require that the outlets be placed individually 

using the 110V Outlets  tool or from the 
Electrical Library. See “Room Types” on 
page 113.

Railings and invisible walls do not separate 

rooms for Auto Place Outlets : If Auto 

Place Outlets  is used in a room defined 
by railings or invisible walls, outlets are 
automatically placed in all adjacent rooms 
that share these wall types with that room.

Any outlet can be moved, deleted, or merged 
with other outlets or switches. See 
“Switches” on page 208.

Electrical Library
Select Library> Library Browser to 
accesses a variety of electrical 

symbols. See “The Library” on page 265.

Browse for electrical objects such as bath 
vent fans, an electrical panel, fluorescent 

lights, chandeliers, a smoke detector, 
thermostat, and more. Select a symbol, then 
click in your plan to place it on a wall, floor, 
or ceiling.

Displaying Electrical Objects
The display of electrical objects and 
connections is controlled in the 

Display Options dialog. See “Displaying 
Objects” on page 48.

When displayed in 3D views, light fixtures 
act as sources of light that help illuminate the 
3D model. See “Lighting” on page 318.

Electrical labels display in floor plan view 
when the “Electrical, Labels” layer is turned 
on.

Editing Electrical Objects
Electrical objects can be selected as a group 
and individually in 2D and 3D and edited 
using the edit handles and the edit toolbar . 

Using the Edit Handles
The edit handles for electrical objects vary 
depending on the location of the object. Wall 
mounted electrical objects cannot be rotated, 
so only the Move edit handle displays.
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Electrical objects placed on floors and 
ceilings can be rotated.

Electrical connections edit like splines. See 
“Editing Spline Based Objects” on page 74.

Using the Edit Buttons
A selected electrical symbol can be edited in 
a variety of ways using the buttons on the 
edit toolbar. See “The Edit Toolbar” on page 
22.

Adjusting the Height 
of Electrical Objects

In floor plan view, an outlet placed where a 
base cabinet meets a wall is placed above the 
counter unless the cabinet contains a fixture 
or appliance other than a bathroom sink. If 
the fixture requires electricity, the outlet 

remains behind the cabinet at normal wall 
height, where it can supply power to the 
fixture or appliance.

Kitchen sinks are assumed to require 
electricity since they often contain a garbage 
disposal. Dishwashers are not considered to 
require electricity since they are usually 
plugged in under a nearby sink. If an outlet is 
needed above a cabinet containing a kitchen 
sink, place the outlet before adding the sink, 
or move the outlet up.

To change the height of an electrical object in 
floor plan view, open the object for 
specification and type the desired height in 
the Electrical Service Specification dialog. 
See “Electrical Service Specification Dialog” 
on page 211.

Electrical objects placed in 3D views are 
placed wherever you click a wall, regardless 
of the height. In 3D views, the position of an 
electrical object can be adjusted using its edit 
handles.

Deleting Electrical Objects
An electrical object can be deleted by 

selecting it and clicking the Delete  edit 
button or by pressing the Delete key.

All electrical objects in a room, on a floor, or 
in the entire plan can be deleted as a group 
using the Delete Objects dialog. See 
“Deleting Objects” on page 82.

Electrical Service Specification Dialog
Select an electrical object and click 
the Open Object edit button to open 

the Electrical Service Specification dialog. 

The settings in this dialog vary, depending on 
the type of object(s) you select.

Wall-mounted outlet in 2D and 3D views



212

Home Designer Essentials 2012 Reference Manual

General Tab
The items on this tab vary, depending on the 
type of electrical object selected.

The Name of the selected object as 
used in the Library Browser and 

Materials List displays here.

Specify the Position of the selected 
electical symbol. The options available 

depend on the type of electrical symbol 
selected.
• Specify the Offset From Ceiling of a 

ceiling outlet or ceiling mounted light. If 
the light is mounted to a cabinet, this 
value is the offset from the cabinet.

• Specify the Height to Center of a 
switch, wall outlet or wall light. 

• Specify the Offset From Floor of a floor 
outlet or floor lamp. 

• Specify the Distance From Wall of a 
wall mounted symbol. A negative value 

will recess the symbol into the wall and 
may prevent it from being seen in 3D. 

Specify the Size of the selected 
electical symbol. 

• Specify the Height, Width and Depth of 
the selected symbol. 

• Click the Reset button to restore the elec-
trical symbol’s original size 

Check Automatically Change Switch 
Type When Wiring for a selected 

switch to become a three- or four-way switch 
if your wiring plan later uses it as such. See 
“Connect Electrical” on page 209. Switches 
placed from the toolbar use this option by 
default; switches placed from the library do 
not. Only available for switches. 

1
2

3
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Materials Tab
The Materials tab is found in the 
specification dialogs for a variety of objects. 

For more information, see “Materials Tab” 
on page 284.
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Chapter 17:

Trim Tools

The Trim Tools allow you to place corner 
boards and quoins at wall intersections that 
form corners. 

You can also assign moldings to a variety of 
objects, such as rooms and cabinets, in those 
objects’ specification dialogs. See 
“Specification Dialogs” on page 24.

Chapter Contents
•      Trim and Molding Defaults
•      Corner Boards
•      Corner Board Specification Dialog
•      Quoins
•      Quoin Specification Dialog
•      Editing Corner Boards and Quoins
•      Millwork
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Trim and Molding Defaults
Select Edit> Default Settings to open 
the Default Settings dialog where 

you can access the defaults for a variety of 
drawing tools, including a number that affect 
trim and moldings. 
• Select “Floor” and click the Edit button 

to specify the default moldings for rooms 
on the current floor. See “Floor and 
Room Defaults” on page 110. 

• Click the + beside “Door” ” to access the 
defaults for Interior and Exterior Doors. 
See “Door Defaults” on page 127. 

• Select “Window” and click the Edit but-
ton to specify the default casing for win-
dows. See “Window Defaults” on page 
144.

Corner Boards
Corner boards are added to a building 
exterior in any view by selecting 

Build> Trim> Corner Boards.

Click at a wall corner where you want to add 
trim. Be sure to click where the outside wall 
surfaces meet. If you click where the inside 
surfaces meet, corner trim will be created 
inside the room.

Corner boards extend from the top plate 
down to the bottom of the floor platform of 
the floor on which it is placed, but do not 
extend to other floors. You must add corner 
boards to all floors of the building that you 
want to have corner boards. 

A selected corner board or boards can be 
moved, but only to another wall corner or 
corners.  In 3D views, corner boards can be 
lengthened or shortened using the edit 
handles. Corner boards can be copied, 
deleted and resized similar to other objects 
using the edit toolbar or  the Corner Board 
Specification dialog. 

The default material for corner boards is 
defined by the Exterior Trim entry in the 
Material Defaults dialog. See “Material 
Defaults” on page 289.

Corner Board Specification Dialog
Select a corner board and click the 
Open Object edit button to open the 

Corner Board Specification dialog.
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General Tab

Specify the Width of the selected corner 
board(s).

Materials Tab
The settings on the Materials tab are 
available for a wide variety of objects in the 
program. For information about these 
settings, see “Materials Tab” on page 284.

Quoins
Select Build> Trim> Quoins in any 
view and click at a wall corner where 

you want to place quoins. 

A selected quoin or quoins can be moved, 
but only to another wall corner or corners. In 
3D views, quoins can be lengthened or 
shortened using the edit handles. Quoins can 
be copied, deleted and resized similar to 
other objects using the edit toolbar or  the 
Quoin Specification dialog. 

The size of quoins in floor plan view is 
relative on their size in 3D.

Initially, quoins use the same material as the 
default material of the wall surface they are 
placed against. 

Quoin Specification Dialog
Select a quoin and click the Open 
Object edit button to open the Quoin 

Specification dialog.
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General Tab

Specify the dimensions of the quoins in 
the selected Quoin object. 

• Specify the Width, which is the long 
dimension of each quoin in the selected 
Quoin object. The dimension along the 
other wall is half this value when they are 
staggered or mirrored.

• Specify the Quoin Height for individual 
quoins in the selected Quoin object.

Specify the arrangement of quoins used 
by the selected Quoin object(s). 

• Uniform - Produce quoins that are of 
equal length on both sides of the corner.

• Staggered - Produce quoins that have 
one long side and one short side stag-
gered on opposite sides of the corner.

Materials Tab
The settings on the Materials tab are 
available for a wide variety of objects in the 
program. For information about these 
settings, see “Materials Tab” on page 284.

Editing Corner Boards and Quoins
Before a corner board or quoin can be edited, 
it must be selected. Click on a trim object 

when the Select Objects  tool is active. 
Corner boards and quoins can also be group 
selected and edited. See “Selecting Objects” 
on page 60.

Corner boards and quoins can be edited using 
their edit handles, the edit toolbar buttons, 
and their specification dialogs. 

Using the Mouse
Depending on the type of view, a corner 
board or quoin displays a different set of edit 
handles when selected. 
• In floor plan view, corner boards and 

quoins display one edit handle and can be 
moved from one eligible location at a 
wall corner to another.

• In 3D views, corner boards and quoins 
can be moved, lengthened, and shorted 
much the other line-based objects are. 

1

2

1

2
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See “Editing Line Based Objects” on 
page 62. 

Using the Edit Buttons
A selected corner board or quoin can be 
edited in a variety of ways using the buttons 
on the edit toolbar. See “The Edit Toolbar” 
on page 22.

Millwork
A selection of various types of millwork 
including columns, corbels and finials is 
available in the Library Browser. See “The 
Library Browser” on page 266. 

Most millwork items can be placed in a plan 
as free-standing objects.  Some items - 

notably, newels and balusters - can be 
assigned to objects such as railings, stairs 
and ramps. See “Placing Library Objects” on 
page 274. 
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Chapter 18:

Cabinets

With Home Designer Essentials’s cabinet 
tools you can create base, wall, and full 
height cabinets as well as soffits, shelves and 
partitions. These objects are very versatile, 
allowing for a wide range of customization. 

A selection of cabinet door and drawer styles 
are available in the Library Browser.

Home Designer Essentials also has many 
customized cabinet symbols and cabinet 
groups available in the library.

Chapter Contents
•      Cabinet Defaults
•      The Cabinet Tools
•      Cabinet Fillers
•      Placing Cabinets
•      Displaying Cabinets
•      Editing Cabinets
•      Editing Cabinet Styles
•      Special Cabinets
•      Cabinet Specification Dialog
•      Shelf/Partition Specification Dialog

Cabinet Defaults
Access default settings for each 
cabinet tool by selecting Edit> 

Default Settings, then clicking the + beside 
Cabinets. Select a subheading and click the 
Edit button to open the defaults dialog 
associated with your selection: 

Each type of cabinet object has default 
definitions for size, style, materials and 
more. In fact, the default dialog for each 
cabinet type is similar to its corresponding 
specification dialog. For descriptions of 

these settings, see “Cabinet Specification 
Dialog” on page 230, “Shelf/Partition 
Specification Dialog” on page 234 and 
“Soffit Specification Dialog” on page 258.
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General Cabinet Defaults
The General Cabinet Defaults dialog can be 
accessed only from the Default Settings 
dialog.

Specify the Minimum Cabinet Width. The 
minimum allowable width is 1/16 of an inch 
(10 mm). 

Specify how Cabinet Resizing takes place 
when the edit handles are used.
• Select Use Grid Snaps to resize cabinets 

using Snap Grid increments. See “Grid 
Snaps” on page 53.

• Select Use Resize Increment to resize 
cabinets using the increment specified 
here. 

• Set the Resize Increment at which cabi-
nets resize. The minimum allowable 
increment is 1/16 of an inch (10 mm).

The Cabinet Tools
Select Build> Cabinet to access the 
Cabinet Tools.

Cabinets are easily created with a single click 
in any view. See “Click-to-Create” on page 
54.

Typically, groups of cabinet objects are 
positioned closely together and arranged to 
form work spaces, and there are some special 
behaviors and techniques to be aware of. See 
“Placing Cabinets” on page 224.

Once created, cabinets, soffits, shelves, 
partitions and fillers can be selected and 
edited much like other box-based objects. 
See “Editing Box-Based Objects” on page 
72.

Base Cabinets
Select Build> Cabinet> Base 
Cabinet and click in any view. Base 

cabinets can be placed directly under wall 
cabinets and generate a countertop and toe 
kick by default.

Wall Cabinets
To place a wall cabinet, select Build> 
Cabinet> Wall Cabinet and click in 

any view. Wall cabinets can be placed 
directly over base cabinets. 

Full Height Cabinets
To place a full height cabinet, select 
Build> Cabinet> Full Height and 

click in any view. Full height cabinets 
generate a toe kick by default and cannot be 
placed on top of other cabinets.
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Soffits
Soffits typically fill the space between 
cabinet tops and the ceiling, but can 

also be used to create any object that can be 
modeled as a 3D box. To place a soffit, select 
Build> Cabinet> Soffit and click in any 
view.

Soffits can display in both floor plan and 3D 
views. They can be assigned materials that 
are calculated in the Materials List; by 
default, they use the material assigned to 
interior walls in the Material Defaults dialog. 
Like cabinets, soffits can have molding 
profiles applied to them.

For more information about using soffits for 
a variety of purposes, see “Other Objects” on 
page 255.

Shelves
Select Build> Cabinet>  Shelf and 
click in any view to create a shelf. 

Create corner shelves by placing one shelf on 
each wall, then moving or stretching them 
until they touch.

Once created, shelves can be selected and 
edited. See “Shelf/Partition Specification 
Dialog” on page 234.

Partitions
Select Build> Cabinet> Partition 
button and click in any view to create 

a vertical partition. 

Like shelves, partitions can be selected and 
edited after they are placed.  

Partitions can be used with shelves to create 
complex storage systems.

Cabinets Library
In the Library Browser, browse to 
Home Designer Essentials Core 

Catalogs> Architectural> Cabinets to access 
a selection of specialty cabinets. Select the 
library object you want, then click in any 
view to place it in the plan. Once placed, 
library cabinets can be edited. See “The 
Library” on page 265.

Cabinet Doors, Drawers, 
& Panels Library

A selection of special cabinet doors, 
drawers and panels is available in  

Home Designer Essentials Core Catalogs> 
Architectural.  Select an item, then click on a 
cabinet in your plan to place the door or 
drawer onto that cabinet. Doors, drawers and 
panels can be assigned to a cabinet in its 
specification dialog, as well. Cabinet doors, 
drawers and panels can also be placed as 
stand-alone fixtures. 

Built-In Appliances
A variety of fixtures and appliances such as 
sinks, cooktops, and dishwashers can be 
placed into cabinets. See “Inserted Objects” 
on page 275. 

To install an appliance into a cabinet, select 
the appliance for placement in the selection 
pane of the Library Browser and click on a 
cabinet. There must be enough space in the 
cabinet or adjoining cabinets to contain the 
selected appliance. 

Place range tops and sinks into cabi-
nets early, so that any resizing can be

done before too many cabinets are placed.
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Fixtures can be added to both the top and 
front of the same cabinet. The fixture on top 
can be selected by clicking the cabinet and 
pressing the Tab key or clicking the Select 

Next Object  edit button. The fixture on 
the face can be deleted on the Front tab of the 
Cabinet Specification dialog. 

Electrical Switches & Outlets
Electrical switches and outlets placed. See 
“The Electrical Tools” on page 208.

Cabinet Fillers
By default, Home Designer Essentials 
models a continuous countertop and 
generates fillers automatically  when 
cabinets of the same height are either 
touching or placed with 3” (30 mm) of one 
another. 

If two cabinets meeting at a corner are 
separated from each other by 3”(30 mm) or 
less, the program will automatically generate 
a filler in the angle between them. A filler is 
used to separate the front of one of these 

cabinets from the one it meets so that 
drawers and doors have room to operate.

Placing Cabinets
Cabinets are easily created with a single click 
in any view. See “Click-to-Create” on page 
54. 

 When used near a wall corner, the Cabinet 
Tools will produce corner cabinets and 
soffits. See “Corner Cabinets” on page 228.

When created, cabinets are positioned 
relative to the floor of the room in which they 
are placed. Base and full height cabinets 
typically rest on the floor while wall cabinets 
are placed a set distance above the floor. See 
“Cabinet Defaults” on page 221.

If the ceiling height of the room does not 
accomodate the height of a cabinet, its Floor 
to Bottom value will be retained and its 
Height will be reduced so that it fits under 
the ceiling. When this happens, some front 
items may be removed from the cabinet if 
there is not enough room for them. See 
“Front Tab” on page 231.

Because cabinets are typically organized into 
groups with shared attributes, they have 
some special behaviors. 

In the real world, some appliances can
share a cabinet, while others cannot. It

is up to you to determine which appliances
can be effectively and safely combined. 

Two base cabinets and the filler between them
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Cabinet Snapping and Aligning
Cabinets have several special snapping and 
aligning behaviors which help you create 
precisly aligned cabinets quickly and easily.
• When Base and/or Full Height cabinets 

are within 3” of one another’s sides, they 
will snap together. Wall cabinets snap in a 
similar manner, but only with other Wall 
cabinets.

• When Base and/or Full Height cabinets 
are within 3” of one another’s sides and 
their front or back surfaces are within 3” 
of aligning, they will become aligned. 
Wall cabinets snap in a similar manner 
with other Wall cabinets as well as Full 
Height cabinets.

• When a Base and/or Full Height cabinet 
is placed against the back of another Base 
or Full Height cabinet, its back surface 
will automatically face the other cabinet’s 
back. Wall cabinets snap in a similar 
manner with other Wall as well as Full 
Height cabinets.

• When a cabinet is placed against a wall, 
its back and/or side will snap to the wall 
and, if the wall is moved, the cabinet will 
move with it.

When cabinets are snapped to a wall or to 
other cabinets, only exposed end cabinets 
have side counter overhangs.

Cabinet snapping and aligning occurs even 
when when Object Snaps are turned off; 
however, you can override this behavior by 
moving a cabinet into the desired position 
using dimensions. See “Moving Objects 
Using Dimensions” on page 331.

Cabinet Merging
When cabinets of the same height and type 
are placed side-by-side within 3” (30 mm) of 
one another they will automatically merge, 
making any shared components such as the 
toe kick, countertop, backsplash and 
moldings continuous. Any gap between 
merged cabinets will be automatically filled.

The exposed ends of merged cabinets have 
side counter overhangs.

Cabinets placed at different angles will also 
merge if they face toward one another and 
meet at a front corner. Cabinets that meet at a 
back corner will also merge provided that 
they face away from one another at an angle 
no greater than 87°. In either case, a filler is 
created in the angle between the two. 

If the side of a cabinet is placed within 3” (30 
mm) of a wall, the countertop will extend to 
the wall and a filler will be created. 

Base and Wall Cabinets
Base and wall cabinets have different default 
heights, so they can be placed directly above 
or below one another without interference. 
You can use Object Snaps to center a wall 
cabinet’s back center point above that of a 
base cabinet, or vice versa. See “Click-to-
Create” on page 54.

Minimum Cabinet Size
If you try to place a cabinet into a space that 
is too narrow for its default size, the program 
will place a smaller cabinet with a width that 
is a multiple of the default Resize 
Increment. For example, if you try to place a 
24” wide cabinet in a 20” wide space and 
your Resize Increment is 3”, the program 
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places an 18” cabinet. See “General Cabinet 
Defaults” on page 222.

If you try to place a cabinet into a space 
narrower than the default Minimum 

Cabinet Width, a cabinet will not be placed. 
If, for example, you have a space that is 8” 
and your Minimum Cabinet Width is 9”, no 
cabinet is placed. 

Displaying Cabinets
The display of the various cabinet 
object types, labels, module lines, 

door opening indicators and more is 
controlled in the Display Options dialog. 
See “Displaying Objects” on page 48.

Cabinets are drawn so that wall cabinets, 
soffits and shelves are always in front of base 
and full height cabinets and partitions. 

Countertops display if the “Cabinets, 
Countertops” layer is turned on. 

By default, cabinet module lines do not 
display when cabinet modules are merged. 
To show lines between individual cabinets in 
floor plan view, set the “Cabinets, Module 
Lines” layer to display. You can specify 
whether module lines are full or partial. 

You can also display cabinet front indicator 
arrows in floor plan view by turning on the 
“Cabinets, Front Indicators” layer.

Editing Cabinets
Cabinets and cabinet fillers can be selected in 
2D and 3D views and edited using the edit 
handles, the edit toolbar and their 
specification dialog. See “Cabinet 
Specification Dialog” on page 230.

Using the Mouse
Cabinets can be edited like other box-based 
objects. See “Editing Box-Based Objects” on 
page 72. Depending on the view, the edit 
handles a cabinet displays when selected  
will vary. 

When a cabinet is selected in floor plan view 
or on its top surface in a 3D view, ten edit 
handles display. They are the Move handle at 
the center, the Rotate handle, and a Resize 
handle on each edge and at each corner. 

When a cabinet is selected on a side in a 
cross section/elevation or 3D view, it has five 
edit handles: the Move handle and a Resize 
handle on each edge. In 3D views, cabinets 
can be selected on any surface: front, side, 
back or top. 
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In the Specification Dialog
A selected cabinet can be customized 
in a variety of ways in its specification 

dialog. See “Cabinet Specification Dialog” 
on page 230.

Using the Edit Tools
A cabinet or cabinets can be edited in a 
variety of ways using the buttons on the edit 
toolbar. See “The Edit Toolbar” on page 22.

Moving Walls with 
Cabinets Attached

When a cabinet is placed or moved against a 
wall, it will snap to the wall and become 
attached to it. When a wall is moved, all 
attached cabinets move with it. 

Moving a wall to an unattached cabinet will 
not attach the cabinet to it: the cabinet must 
be moved to the wall. A cabinet can also be 

attached to a wall when Plan Check  is 
used. See “Plan Check” on page 349. 

Editing Cabinet Styles
A variety of settings allow you customize the 
appearance of your cabinets to create styles 
ranging from traditional to contemporary.

If the desired style is known before cabinets 
are placed, you can save time by specifing 
that style in the Cabinet Defaults dialogs 
before you start drawing. See “Cabinet 
Defaults” on page 221.

Doors, Drawers & Panels
Cabinet doors can be applied in either of two 
ways:  
• In the Cabinet Specification dialog. See 

“Door/Drawer Tab” on page 233.
• Directly from the Library  Browser.

Select a style in the library, then click on a 
cabinet to apply the selected style to that 
cabinet. In 3D views, click on a face item to 
apply the selected object to that item. See 
“Placing Library Objects” on page 274.

Cabinet Hardware
Cabinet handles, pulls, and hinges can be 
assigned in the Cabinet Specification 
dialog. See “Door/Drawer Tab” on page 233.

In 3D views, pulls and handles can also be 
applied directly from the Library Browser. 
Select a hardware item, then click on the 
cabinet face item to apply it to that face item.

Countertops & Backsplashes
Countertop thickness, and material for a 
selected base cabinet can be specified in the 
Base Cabinet Specification dialog. See 
“Front Tab” on page 231. 

Backsplashes can also be applied to base 
cabinets, also on the Front tab of their 
specification dialog.
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Special Cabinets
There are a number of special cabinet shapes 
that can be specified. Certain requirements 
must be met before some special cabinet 
shapes can be specified. If the requirements 
are not met, a warning message will explain 
what is needed. See “Cabinet Specification 
Dialog” on page 230.

Standard Cabinets

Select Build> Cabinet> Base Cabinet  
and click in floor plan view to place a 
standard, rectangular base cabinet.

Corner Cabinets
To create a corner cabinet, click as close to 
an inside wall corner as possible in using 

either the Base Cabinet , Wall Cabinet 

, or Full Height  cabinet tool. A 
corner cabinet remains a corner cabinet when 
it is moved, edited or copied.

Turn an existing cabinet  into a corner 
cabinet by selecting Corner Cabinet from the 
Special drop-down list in its specification 
dialog. See “General Tab” on page 230.
• Before a corner cabinet can be specified 

in the Cabinet Specification dialog, the 

cabinet’s Width must be greater than its 
Depth.

• The Left and the Right Side Widths can 
be set independently for corner cabinets. 

• You can specify a Diagonal Door on cor-
ner cabinets to create an angled corner 
cabinet. See “Front Tab” on page 231.

End Cabinets
Open a cabinet for specification and select 
Left or Right End Cabinet from the Special 
drop-down list to create an end cabinet.

Standard (default) cabinet

Corner cabinet with sides of equal width

Corner cabinet with diagonal door

Left End Cabinet
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• End Cabinets have an angled front and 
side.

• The cabinet width must be no greater 
than its depth for an end cabinet to be 
specified.

Radius End Cabinets
Open a cabinet for specification and select 
Right or Left Radius End from the Special 
drop-down list to create a radius end cabinet.

As you face the cabinet, a right radius end 
curves to the right, and a left radius end 
curves to the left.

Peninsula Radius Cabinets
Open a cabinet for specification and select 
Pen. Radius from the Special drop-down list 
to create peninsula radius cabinet.

Kitchen Islands
To create a kitchen island, simply place 
several cabinets back-to-back and/or side-to-
side. Match the widths so that each cabinet 
back or side meets the back or side of only 
one other cabinet. If this is not done, the lines 
separating the cabinets cannot be suppressed. 

Two cabinets cannot merge with the same 
side of another cabinet. The picture shows 
two instances when cabinets are placed back-
to-back. Cabinet fronts and joining surfaces 
are shown.

Blind Cabinets
Often, when two cabinets meet in a corner, 
one is partially hidden by the other. This 
partially hidden cabinet is called a “blind” 
cabinet. Home Designer Essentials will 
resize and offset the front items of the 
partially hidden cabinet so that they are not 
located in the hidden portion of the cabinet 
face.

Radius End cabinets have a 90° arch

Peninsula Radius Cabinet

Correct - 
Widths of front and 

back cabinets match

Incorrect - 
Solid line here is not 

suppressed.
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Cabinet Specification Dialog
Select a cabinet and click the Open 
Object edit button to open the 

Cabinet Specification dialog.

The options in the Cabinet Specification 
dialogs are similar to the corresponding 
Cabinet Defaults dialog. See “Cabinet 
Defaults” on page 221.

General Tab

A number of Special cabinet types are 
available in the drop-down list. Certain 

requirements must be met before some 
special cabinet shapes can be specified.  See 
“Special Cabinets” on page 228. 

Size/Position - The selected cabinet’s 
dimensions and position relative to the 

floor can be specified here. Fractional values 
are supported to 1/16th of an inch (1 mm).
• Specify the Height of the cabinet box, as 

measured from bottom to top. For base 
cabinets, this value includes the counter-
top thickness, but not the height of the 
backsplash. 

1
2

3
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• Specify the Width of the cabinet box, as 
measured across the front of the cabinet 
box from left to right. This does not 
include the countertop overhang.

• Specify the Depth of the cabinet box, as 
measured from front to back. It does not 
include the thickness of overlay doors or 
the countertop overhang. 

• For corner cabinets, the Width and 
Depth fields become Right Side Width 
and Left Side Width.

• Specify the Floor to Bottom distance. 
For base and full height cabinets, this is 
usually 0.  

The preview of the cabinet updates as 
the cabinet changes.

The Cabinet Label displays below the 
preview diagram.

Front Tab

Click on a face item in the preview 
diagram to select it. The selected item 

is highlighted, and the Face Items settings 
below become active, allowing you to edit 
the selected item.

Define the Face Items on the front of 
the selected cabinet. For best results, 

edit face items starting at the top of the 
cabinet and work down.

Click the Item Type drop-down list to apply 
a type to the selected Face Item, such a door, 
drawers or panel.
• Cabinet fronts may be composed of any 

combination of face items, but there is a 
limit to the number of items that can rea-
sonably fit on a given cabinet’s front. 

• Auto Right and Auto Left Doors become 
double doors automatically when the cab-

3
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inet width is greater than 24” (600 mm). 
Left, Right and Double Doors are as 
specified regardless of the cabinet width.

• False Drawers assume the appearance of 
the drawer style and hardware assigned to 
the cabinet.

• Door Panels assume the appearance of 
the cabinet’s door style but not the door 
hardware.

• Appliances cannot be added from the 
Item Type list, but are included once 
they have been added from the library. 
See “Built-In Appliances” on page 223.

• The backsplash can be selected but its 
type cannot be changed. 

Item Height - Define a value for the selected 
item in the cabinet front. Fractional heights 
are supported to 1/16th of an inch (1 mm). 
• When the height of a cabinet is changed, 

or the height of a face item is changed, 
the height of the lowest face item is 
altered to make up the difference. 

• If you modify the lowest item, the item 
directly above is adjusted. Set the coun-
tertop height and the toe kick height first, 
and then work from the top to the bottom 
when adjusting face items.

• If the height of an appliance has been 
altered, entering “d” restores its default 
height. 

Check Include Shelves to include shelves in 
the selected “Door” or “Opening” face item. 

Click Add New to add a new face item 
directly below the currently selected item.
• When you click Add New, the New 

Cabinet Face Item dialog displays. 
Define the Item Type, Item Height and 
click OK. 

• If you click Add New with no face item 
selected, the program adds the new item 
at the bottom of the cabinet face. 

• When a face item is added to the cabinet 
front, the program attempts to reduce the 
height of the lowest item on the cabinet 
front to make room for the new item. 

Click Delete to remove the currently selected 
item. 
• When a face item is deleted, the height of 

the lowest item is usually increased to 
make up the difference.

• When an Auto Left, Auto Right, Left, 
Right, or Double Door is deleted, it is 
replaced by an Opening.

Click Move Up to move the currently 
selected item up one position, switching 
places with the item directly above.

Click Move Down to move the currently 
selected item down one position, switching 
places with the item directly below.

Note: The program makes sure that the
heights of the front items equal the total cabi-
net face height. When necessary, a blank
area is inserted at the bottom or the lowest
face item is deleted when there is not enough
room. This means you should start editing
face items at the top and work down.
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Options - 

• Uncheck Diagonal Door to create double 
doors at right angles instead of a single 
diagonal door. This option is only avail-

able for Corner Cabinets and is checked 
by default in the Cabinet Defaults dia-
log.

• Select Reverse Appliance to reverse the 
fixture from left to right: for example, to 
change a left hand door on a built-in 
refrigerator to a right hand door.This 
option is only available for cabinets with 
an inserted appliance. 

Door/Drawer Tab
The settings on the Door/Drawer tab allow 
you to control the appearance of the selected 
cabinet’s doors and hardware. 

Note: The program tries to maintain a single
separation between all face items. When you
add or delete a face item, separations are
usually added or deleted with them.

3
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Specify the style and hardware for any 
Doors applied to selected cabinet(s). 

Select a door Style from the drop-down list. 
See “Doors, Drawers & Panels” on page 227.
• Select “Plain Doors” to apply a flat door 

front or “Framed Doors” to apply a door 
with a frame and flat panel front.

• Select “Library” or click the Library 
button to select a cabinet door from the 
library. If a library door has been previ-
ously selected, its name will display in 
the list. See “Select Library Object Dia-
log” on page 276.

Specify the characteristics of the cabinet’s 
door Handles. 
• Select a door handle Style from the drop-

down list or choose one from the library. 
• Specify the position of the handle In 

From Edge,as  measured from the edge 
of the door opposite the hinges.

• Specify the height of the handle Down 
From Top, as measured from the top 
edge of the door. For wall cabinets, this 
value is measured Up From Bottom.

Specify the characteristics of the cabinet 
door Hinges. 
• Select a door hinge Style from the drop-

down list or choose one from the library. 

• Specify the location of the hinges Up/
Down From Edge, as measured from the 
door edge. If the cabinet door is more 
than 35 1/4” (880 mm) high, three hinges 
will be created instead of two. 

Glass Doors is available for cabinets with 
Plain or Framed doors. Framed door panels 
are created using a glass material. The entire 
door is glass on Plain doors. 

Specify the style and hardware for any 
Drawers applied to the cabinet(s). 

Select a from the drop-down list or choose 
one from the library. For best results, Framed 
drawers should be at least  6” (150 mm) high.

Select a drawer from the drop-down list or 
choose one from the library. 
• The In From Drawer Edge setting cre-

ates two handles the specified distance 
from the left and right drawer edges. A 
value of 0 creates a single handle cen-
tered horizontally on the drawer.

• Specify the location of the handle Down 
From Top. A value of 0 centers the han-
dle vertically on the drawer.

Materials Tab
The settings on the Materials tab affect the 
appearance of the selected cabinet in 3D 
views. For information about these settings, 
see “Materials Tab” on page 284.

Shelf/Partition Specification Dialog
Select a shelf or partition and click the 
Open Object edit button to open the 

Shelf Specification or Partition 
Specification dialog.

The options in these specification dialogs are 
similar to the corresponding defaults dialogs. 
See “Cabinet Defaults” on page 221.

1

2
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General Tab

Specify the Height, Width, Depth, and the 
distance from the Floor to Bottom of the 
shelf or partition. 

Uncheck Auto Adjust Height if you do not 
want the shelf or partition to follow the 
terrain.

Materials Tab
The settings on the Materials tab affect the 
appearance of the selected object in 3D 
views. For information about these settings, 
see “Materials Tab” on page 284.
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Chapter 19:

Terrain

Home Designer Essentials allows you to 
model surface features such as planting 
areas, water features and plants in level 
terrain around your house plan.

Driveways, parking lots and sidewalks are 
among the objects that can be placed in your 
terrain and are discussed in “Sidewalks, 
Driveways & Parking Lots” on page 251.

Chapter Contents
•      Terrain Perimeter
•      Terrain Feature Tools
•      Garden Bed Tools
•      Water Feature Tools
•      Terrain Objects in the Library
•      Displaying Terrain
•      Editing Terrain Objects
•      Terrain Object Specification Dialogs
•      Plants
•      Plant Image Specification Dialog

Terrain Perimeter
The Terrain Perimeter is a closed 
polyline defining the boundary of the 

terrain that generates in 3D views. A Terrain 
Perimeter should be present in your plan 
already, but if one is not, select Terrain> 
Create Terrain Perimeter to create one.
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If you create a terrain perimeter in floor plan 
view but do not see it, select Window> Fill 

Window . See “Zoom Tools” on page 
292. 

Once created, the terrain perimeter can be 
resized and edited like other polyline-based 
objects. See “Editing Closed-Polyline Based 
Objects” on page 69. 

Terrain Height vs Floor Height
Home Designer Essentials always defines the 
default height of Floor 1 at 0’-0”. This height 
value is the constant by which the heights of 

architectural objects and structural elements 
in the program, including walls, floors, and 
ceilings, are measured. 

The default height of Floor 1 is not, however, 
the absolute by which terrain elevation is 
measured. The program automatically 
positions Floor 1 a set distance above the 
terrain. This Elevation distance is 6” (150 
mm) plus the thickness of the floor platform 
when a foundation is present. 

Once terrain has been built, the Elevation 
distance is stated in the Terrain 
Specification dialog. You can specify a 
custom Elevation value to produce a daylight 
or walkout basement. See “General Tab” on 
page 243. 

Build Terrain
Select Terrain> Build Terrain to 
generate the terrain surface with any 

terrain features and roads you have drawn. 
Build Terrain also updates the Building Pad 
Elevation value in the Terrain Specification 
dialog. See “Building the Terrain” on page 
241.

The Terrain Perimeter has a variety of  
editable properties that affect the appearance 
of the terrain in 2D and 3D views.  See 
“Terrain Specification Dialog” on page 242.

Terrain Feature Tools
Select Terrain> Feature to access 
tools for drawing bounded areas that 

follow the contours of the terrain rather than 
modifying them. 

Terrain Perimeter

           Terrain perimeter in a 3D view

Note: When no foundation has been built, the
distance from Floor 1 to the terrain is 12” (320
mm). 
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Terrain Features are useful for creating 
landscaping features because they have 
specified heights and materials. You can, for 
example, create paths and planting beds with 
gravel or mulch materials that stand out in a 
grassy Terrain Perimeter. See “Adding 
Terrain Features” on page 145 of the User’s 
Guide. 

In fact, Driveways , Garden Beds  

and Water Features  are special Terrain 
Features with material and height attributes 
already applied to them, saving you time 
when drawing these objects.

Terrain Features can only be drawn when a 
Terrain Perimeter is present, and will only 
display in 3D when they are drawn within the 
perimeter. See “Displaying Terrain” on page 
241.

Terrain Features can be created in either of 
two ways: 
• Click once to place a feature with end-

points that form a 10’ (4 m) square at that 
location. 

• Click and drag from end to end to draw a 
feature sized as needed. 

Once created, Terrain Features can be edited 
into nearly any shape you require. See “Edit-
ing Closed-Polyline Based Objects” on page 
69 and “Editing Spline Based Objects” on 
page 74.

Rectangular Features
The Rectangular Feature tool can be 
used to create straight-sided features 

that can be edited into a wide variety of 
shapes. 

Rectangular Features can also be edited like 
other closed polyline-based objects. See 
“Editing Closed-Polyline Based Objects” on 
page 69.

Round Feature
The Round Feature tool can be used 
to create features with rounded edges 

and smoothly curved corners. 

Round Features can be edited like other 
closed spline-based objects. See “Editing 
Spline Based Objects” on page 74.

Kidney Shaped Features
The Kidney Shaped Feature tool 
allows you to quickly create features 

with curved edges, smooth corners and a 
right angle bend in its shape.

Kidney Shaped Features can be edited like 
other closed spline-based objects. See “Edit-
ing Spline Based Objects” on page 74.

For information about adding height and 
material information to Terrain Features, see 
“Terrain Feature Specification Dialog” on 
page 244.

Terrain Features can be drawn in 2D
and 3D views. 



240

Home Designer Essentials 2012 Reference Manual

Garden Bed Tools
Select Terrain> Garden Bed to 
access tools that can be used to place 

garden bed features in your terrain. 

Garden Beds are basically Terrain Features 
with material and height attributes typical of 
planting beds. See “Terrain Feature Tools” 
on page 238.

In addition, you can choose to distribute 
copies of a plant image within a Garden Bed. 
See “Distributed Plant Tab” on page 245.

Polyline Garden Bed
This tool draws a garden bed with 
straight sides and four right angles. 

See “Rectangular Features” on page 239.

Round Garden Bed
Use this tool to draw garden beds with 
rounded edges and smoothly curved 

corners. See “Round Feature” on page 239. 

Kidney Shaped Garden Bed
You can draw a kidney shaped garden 
bed with this tool. See “Kidney 

Shaped Features” on page 239.

Once drawn, Garden Beds can be selected 
and edited just like other Terrain Features. 

Specify the material and set the height of 
Garden Beds in the Terrain Feature 
Specification dialog.  See “Terrain Feature 
Specification Dialog” on page 244.  

Water Feature Tools
Select Terrain> Water Feature to 
access tools for drawing ponds in your 

terrain.

Ponds are basically Terrain Features with 
material and height attributes typical of 
bodies of water. See “Terrain Feature Tools” 
on page 238.

Round Pond
Use this tool to draw a pond with 
rounded edges. See “Round Feature” 

on page 239. 

Kidney Shaped Pond
This tool draws a kidney shaped pond. 
See “Kidney Shaped Features” on 

page 239.

Terrain Objects in the Library
The Library Browser contains a 
variety of objects that can be placed in 

a plan’s terrain, including plants, exterior 

fixtures, accessories and roadway objects. 
See “The Library Browser” on page 266. 
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You can also create your own objects and 
save them in the library. Select any 
combination of elevation points, elevation 
lines, terrain features, roads, sidewalks, road 
markings, or even the terrain perimeter itself 
and send them to the library as one unit. This 

library object can then be placed into any 
plan. Once placed into a plan, each object is 
independent and is no longer part of the 
group. See “Adding Library Content” on 
page 271. 

Displaying Terrain
The display of terrain objects in 2D 
and 3D views is controlled in the 

Display Options dialog. See “Display 
Options Dialog” on page 49.

You can customize appearance of Terrain 
Features, Sidewalks and other terrain objects 
in floor plan view by changing their line and 
fill styles. See “Terrain Object Specification 
Dialogs” on page 242. 

Plant images are represented in floor plan 
view by 2D symbols. You can select a plant’s 
symbol in the Plant Image Specification 
dialog. See “Image Tab” on page 249. 

In 3D Views
In order for objects such as Terrain Features 
and Sidewalks to be visible in 3D views, the 
Terrain Perimeter layer must also display. In 
addition, only the portions of these objects 
that are drawn within the Terrain Perimeter 
will be seen in 3D views. See “Terrain 
Feature Tools” on page 238.

A variety of tools are available to help you 
adjust the perspective of your 3D views. See 
“Editing 3D Views” on page 307.

Building the Terrain
Terrain is generated based on settings 
in the Terrain Specification dialog 

and the presence of any terrain features and 
roads in the plan. See “Terrain Specification 
Dialog” on page 242.

The terrain is automatically built before a 3D 
view is generated. This process takes a 
variable amount of time, depending on the 
number of terrain features in the plan. The 
Building Terrain progress dialog displays as 
terrain is generated, sometimes only briefly, 
indicating the progress.

You can rebuild the terrain at any time by 

selecting Terrain> Build Terrain .

Terrain & 3D Drawing Time
Terrain is typically large with many surfaces, 
which often increases the drawing time of 3D 
views. The time required is affected by the 
number of terrain features present.  

Lights and symbols can be placed outdoors 
and included in 3D views when the terrain is 
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generated. These objects can also contribute 
to the time needed to generate 3D views. See 
“Rendering Tips” on page 317.

Editing Terrain Objects
Before a terrain object can be edited, it must 
be selected. All terrain objects can be 
selected in floor plan and 3D views. See 
“Selecting Objects” on page 60. 

A selected terrain object can be edited using 
its edit handles, edit tools and specification 
dialog. See “Specification Dialogs” on page 
24.

Using the Edit Handles
• The shape of the Terrain Perimeter can be 

edited like other polyline-based objects. 
See “Editing Closed-Polyline Based 
Objects” on page 69. 

• Terrain Features are edited like other 
spline- and polyline-based objects. See 

“Editing Closed-Polyline Based Objects” 
on page 69 and “Editing Spline Based 
Objects” on page 74.

Using the Edit Tools
A selected terrain object can be edited in a 
variety of ways using the buttons on the edit 
toolbar. The edit tools available for a terrain 
object depends on the type of terrain object 
selected. See “The Edit Toolbar” on page 22.

Terrain Object Specification Dialogs
Just as there are a number of different 
types of terrain objects, there are a 

number of different specification dialogs for 
them.

Terrain Specification Dialog
The Terrain Specification dialog 
controls the appearance of your 

terrain.

The Terrain Specification dialog can be 
accessed in any of two ways:

• Select the Terrain Perimeter and click the 

Open Object  edit button.
• Double-click the Terrain Perimeter using 

the Select Objects  tool. 

Note: If you copy terrain objects from one
plan to another, you cannot view the pasted
objects in 3D unless a Terrain Perimeter
exists. 
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General Tab

Check Auto Calculate Elevation to 
automatically calculate the building pad 

elevation value during terrain rebuild. Home 
Designer Essentials takes the center of the 
building footprint and finds the terrain 
elevation at this point. This elevation is 
added to 8, 12, or 18 inches to calculate the 
building pad elevation. 8 inches is used for a 
slab foundation, 18 is used if a foundation 
floor is present, and 12 is used otherwise.

Building Pad Elevation - Enter the 
value of the elevation of the floor 

height of the first floor in your plan. This 
option is only available when Auto Calculate 
Elevation is unchecked. 

For example, if a structure is placed in the 
middle of a terrain sloping evenly from a 
height of 100.00’ to a height of 112.00’, 
entering a value of 106.00’ for the building 
pad elevation will display the structure at the 
correct height in 3D views.

Check Hide Terrain Intersected by 
Building to cut out the portion of the 

terrain that is intersected by the first floor 
footprint. 

Polyline Tab
The Polyline tab indicates the polyline’s 
Length/Perimeter, its enclosed Area, and 
its Volume. 

The settings on the this tab are available for a 
variety of other objects in the program. For 
information about these settings, see 
“Polyline Tab” on page 202.

Selected Line Tab
The Selected Line tab is available when the 
selected edge of the Terrain Perimeter is a 
line as opposed to an arc. See “Selected 
Edge” on page 60.

The settings on this tab are available for a 
variety of other objects in the program. For 
information about these settings, see 
“Selected Line Tab” on page 203.

Selected Arc Tab
The Selected Arc tab is available when the 
selected segment of the polyline is an arc as 
opposed to a line. See “Change Line/Arc” on 
page 81.

The settings on this tab are available for a 
variety of other objects in the program. For 
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information about these settings, see 
“Selected Arc Tab” on page 203.

Line Style Tab
The settings on the Line Style tab are 
available for a variety of other objects in the 
program. For information about these 
settings, see “Line Style Tab” on page 205.

Fill Style Tab
The settings on the Fill Style tab affect the 
appearance of the Terrain Perimeter in floor 

plan view. For information about these 
settings, see “Fill Style Tab” on page 205.

Materials Tab
The settings on the Materials tab let you 
specify the terrain surface and terrain skirt 
materials used in 3D views. These materials 
are not calculated in the Materials List. See 
“Materials Tab” on page 284.

Terrain Feature Specification Dialog
To open the Terrain Feature 
Specification dialog, select a Terrain 

Feature and click the Open Object edit 
button or double-click the Terrain Feature 

using the Select Objects  tool.

The settings in this dialog control the 
appearance, size, and shape of the selected 
Terrain Feature.

Most of the tabs in this dialog are similar to 
those for a variety of other objects in the 
program.

General Tab

Specify the Height and Thickness of 
the terrain feature relative to the terrain 

surface. 

• Specify the top Height of the feature 
using a positive or negative number. 

• Specify the feature’s Thickness.

1

2
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If a feature’s height above the terrain is 
greater than its thickness, the program will 
fill in the resulting gap.

Clipping - Check Clip Overlapping 
Terrain Features to suppress the 3D 

display of any part of the selected Terrain 
Feature intersected by other Terrain Features 
with a lower Height value. Clipping is useful 
for creating features that contain other 
features such as planters or swimming pools.

Distributed Plant Tab
This tab is only available when the selected 
terrain feature is a Garden Bed. See “Garden 
Bed Tools” on page 240.

Current Object - Specify the object 
assigned to the selected region. 

• Click the Select button to choose an 
object from the library. See “Select 
Library Object Dialog” on page 276.

• A preview of the Current Object along 
with its name display to the left. 

• Click the Delete button to unassign the 
Current Object from the selected region.

2
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• Click the Edit button to open the Current 
Object’s specification dialog. Changes 
made here affect all objects generated 
within the region. See “Specification Dia-
logs” on page 24.

• Check Show Objects to display the dis-
tributed objects in floor plan view.

• Check Show Region to display the edges 
of the distribution region in floor plan 
view.

Object Spacing - Specify how the 
objects in the region are spaced. 

• Specify the Distance between the objects 
in the region, as measured from their cen-
ter points. 

• Select Standard Grid to position the 
objects in rows and columns based on the 
standard X/Y grid in the program. 

• Select Alternate Grid to position the 
objects in rows and columns based on the 
shape of the region. 

Object Orientation - Specify how or if 
the objects in the region are rotated. 

These settings do not affect the region itself 
or its edges.
• Specify the Angle that the distributed 

objects should be placed at. 
• Select Absolute Angle to rotate the 

objects to the specified Angle as mea-
sured from an imaginary horizontal line 
drawn from the origin towards the right. 

• Select Relative Angle to rotate the 
objects relative to the angle of the 
region’s first edge or, if that edge is 
curved, to the angle of its chord. The first 
edge is typically located at the top of the 

region when it is first created; however, 
this can change as the region is edited.

• Select Random Angle to rotate the 
objects in the region at a variety of ran-
dom angles. 

Object Positioning - Specify the 
positioning of the distributed objects 

relative to a point of origin within the region. 
• Specify the X Offset, the horizontal dis-

tance in floor plan view from the region’s 
specified point of origin. 

• Specify the Y Offset, the vertical distance 
in floor plan view from the region’s speci-
fied point of origin. 

• Select From Polyline Center to measure 
the offset from the region’s center point. 

• Select Polyline Start to measure the off-
set from the region’s start point. This start 
point is typically located at the top left of 
the region when it is first created; how-
ever, this can change as the region is 
edited. 

Polyline Tab
The Polyline tab indicates the polyline’s 
Length/Perimeter, its enclosed Area, and 
the Volume of a closed polyline. 

Selected Line Tab
The Selected Line tab is available when the 
selected edge of the Terrain Perimeter is a 
line as opposed to an arc. See “Selected 
Edge” on page 60.

The settings on this tab are available for a 
variety of other objects in the program. For 
information about these settings, see 
“Selected Line Tab” on page 203.

2

3

4



Garden Bed Specification Dialog

 247

Selected Arc Tab
The Selected Arc tab is available when the 
selected segment of the polyline is an arc as 
opposed to a line. See “Change Line/Arc” on 
page 81.

The settings on this tab are available for a 
variety of other objects in the program. For 
information about these settings, see 
“Selected Arc Tab” on page 203.

Line Style Tab
The settings on the Line Style tab are 
available for a variety of other objects in the 

program. For information about these 
settings, see “Line Style Tab” on page 205.

Fill Style Tab
The settings on the Fill Style tab affect the 
appearance of the selected object in floor 
plan view. For information about these 
settings, see “Fill Style Tab” on page 205.

Materials Tab
The settings on the Materials tab affect the 
appearance of the selected object in 3D 
views. See “Materials Tab” on page 284.

Garden Bed Specification Dialog
To open the Garden Bed 
Specification dialog, select a Garden 

Bed and click the Open Object edit button 
or double-click the Garden Bed using the 

Select Objects  tool.

Because a Garden Bed is a type of terrain 
feature, the settings in this dialog are 
essentially the same as those in the Terrain 
Feature Specification dialog. See “Terrain 
Feature Specification Dialog” on page 244.

Terrain Path Specification Dialog
To open the Terrain Path 
Specification dialog, select a 

Sidewalk and click the Open Object edit 
button or double-click the Sidewalk using the 

Select Objects  tool.

Most of the tabs in this dialog are similar to 
those for a variety of other objects in the 
program.

General Tab

Enter the Width of the object and the 
Height. If you enter a negative number for 
the height, the object sinks into the terrain. 
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Polyline Tab
The Polyline tab indicates the Terrain Path 
polyline’s Length/Perimeter, its enclosed 
Area, and the Volume of a closed polyline. 

Selected Line Tab
The Selected Line tab is available when the 
selected edge of the Terrain Perimeter is a 
line as opposed to an arc. See “Selected 
Edge” on page 60.

The settings on this tab are available for a 
variety of other objects in the program. For 
information about these settings, see 
“Selected Line Tab” on page 203.

Selected Arc Tab
The Selected Arc tab is available when the 
selected segment of the polyline is an arc as 
opposed to a line. See “Break Line” on page 
81.

The settings on this tab are available for a 
variety of other objects in the program. For 

information about these settings, see 
“Selected Arc Tab” on page 203.

Line Style Tab
The settings on the Line Style tab are 
available for a variety of other objects in the 
program. For information about these 
settings, see “Line Style Tab” on page 205.

Fill Style Tab
The settings on the Fill Style tab affect the 
appearance of the selected object in floor 
plan view. For information about these 
settings, see “Fill Style Tab” on page 205.

Materials Tab
The settings on the Materials tab affect the 
appearance of the selected object in 3D 
views. See “Materials Tab” on page 284.

Plants
Home Designer Essentials’s Library 
Browser features a Plants category 

with a selection of plant, shrub and tree 
images which you can place in your plan. 
See “The Library” on page 265. 

Once placed in your plan, these plant images 
can be selected, moved, copied and resized to 
produce a wide variety of unique landscaping 
designs. See “Editing Images” on page 354. 

Plant Image Specification Dialog
Select a plant in a floor plan or 3D 
view and click the Open Object edit 

button to open the Plant Image 
Specification dialog. 
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Image Tab

Image File - The path and name of the 
selected image file displays here. Click 

Browse to specify the saved location on your 
computer of the image that represents the 
plant in 3D views.

2D Plant Symbol - A number of 2D 
symbols are available to mark the 

location of the image in floor plan view. 
Select one from the drop-down list.

Options 

• Check Reverse Image to reflect the 
appearance of the image about an imagi-
nary vertical line through its center. 

• Check Do not rotate in 3D view to pre-
vent the plant image from rotating with 
the camera.

Specify the Size of the plant image, as 
seen in 3D views. 

• Enter a Height for the image. 
• Enter a Width for the image. 
• When Retain Aspect Ratio of is checked, 

if you change either the Height or Width, 
the other value changes to maintain this 
ratio. If this is unchecked and you resize 
the plant image, it may become distorted.

• Click Reset Original Aspect Ratio of to 
reset the image’s original aspect ratio and 
remove any distortion caused by resizing.

Specify the Location of the selected 
plant image.

• Precisely position the selected plant 
image in reference to the plan coordinates 
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by specifying its X Coordinate and Y 
Coordinate.

• Specify the selected plant image’s Height 
Above Ground.

Fill Style Tab
The Fill Style tab controls the appearance of 
the selected plant’s 2D Plant Symbol in floor 
plan view.  By default, plant images’ fill style 

is None (Transparent). For information about 
the settings on this tab, see “Fill Style Tab” 
on page 747.

If the plant’s 2D Plan Symbol does not form 
a closed shape, the settings on the Fill Style 
tab will have no effect on the appearance of 
the plant in floor plan view. 
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Chapter 20:

Sidewalks, Drive-
ways & Parking

Lots

Sidewalks, driveways and parking lots are 
modeled in 3D like other terrain objects in 
Home Designer Essentials. Because they 
have much in common with terrain objects 
and rely upon terrain data to be viewed in 
3D, it is helpful to be familiar with terrain 
modeling before using these tools. See 
“Terrain” on page 237.

Chapter Contents
•      Road Tools
•      Displaying Road Objects
•      Editing Road Objects
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Road Tools
Sidewalks, driveways and parking lots can 
be drawn in floor plan view, camera views 
and overviews, but only when a Terrain 
Perimeter exists in the plan. See “Terrain 
Perimeter” on page 237. 

Sidewalks have a consistent width that can 
be defined in their specification dialog. See 
“Terrain Feature Specification Dialog” on 
page 244 and “Terrain Path Specification 
Dialog” on page 247.  

Driveways and Parking Lots are actually 
Terrain Features.  See “Terrain Feature 
Tools” on page 238. They are drawn as 
rectangles but can be edited to any shape. 
See “Editing Closed-Polyline Based 
Objects” on page 69.

Once road objects have been placed, they can 
be edited individually or as a group. See 
“Editing Road Objects” on page 253.

Straight Sidewalk
To create a sidewalk, select Terrain> 
Road and Sidewalk> Straight 

Sidewalk, then click and drag from end to 
end to draw a line. The ends of multiple 
sidewalk sections can be connected together.

Sidewalks are edited along their center line 
like line- and polyline- based objects. See 
“Editing Line Based Objects” on page 62. 

Sidewalks can be edited in their specification 
dialog. See “Terrain Path Specification 
Dialog” on page 247.

Driveway Area
A Driveway Area is a terrain feature 
with a concrete material assignment. 

To create a driveway, select Terrain> Road 
and Sidewalk> Driveway Area, then click 
and drag from corner to corner to draw a 
rectangle. 

Height, thickness and material information 
can be specified in a driveway’s specification 
dialog. See “Terrain Feature Specification 
Dialog” on page 244.

Driveways can be edited like other closed 
polylines. See “Editing Closed-Polyline 
Based Objects” on page 69. 

Parking Lot
A Parking Lot is a terrain feature 
with an asphalt material assignment. 

To place a parking lot, select Terrain> Road 
and Sidewalk> Parking Lot , then click and 
drag from corner to corner to draw a 
rectangle. 

Height, thickness and material information 
can be specified in a parking lot’s 
specification dialog. See “Terrain Feature 
Specification Dialog” on page 244.

Displaying Road Objects
Sidewalks, driveways and parking lots 
display in floor plan and 3D views 

based on the settings in the Display Options 
dialog. See “Layers” on page 47.
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In 3D Views
Road objects display in 3D views within the 
Terrain Perimeter. If the display of the 
Terrain Perimeter is turned off in 3D views, 
sidewalks, driveways and parking lots will 
not display, either: even if their layers are 
turned on.

By default, terrain rebuilds automatically 
when road objects are added, removed or 
edited. If it does not, you can select Terrain> 

Build Terrain . See “Terrain Perimeter” 
on page 237.

Editing Road Objects
Road objects can be selected in 2D and 3D 
views and edited using the edit handles, the 
edit toolbar and their specification dialogs.  

Using the Mouse
The edit handles available for a selected road 
object depend on the type of object selected. 

• Sidewalks  are edited along their cen-
terline like a line or open polyline. See 
“Editing Line Based Objects” on page 
62. 

• Driveway Areas  and Parking 

Lots  are edited like other closed 
polyline based objects. See “Editing 
Closed-Polyline Based Objects” on page 
69.

In the Specification Dialog
Road objects can be customized in 
their specification dialogs. See 

“Terrain Feature Specification Dialog” on 
page 244 and “Terrain Path Specification 
Dialog” on page 247.

Using the Edit Tools
A selected road object can be edited in a 
variety of ways using the buttons on the edit 
toolbar. See “The Edit Toolbar” on page 22.
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Chapter 21:

Other Objects

Home Designer Essentials has additional 
objects that can be used to customize your 
design.

Chapter Contents
•      General Shapes
•      Soffits
•      Special Applications for Soffits
•      Calculating Materials on Soffits
•      Soffit Specification Dialog
•      Fireplaces
•      Fireplace Specification Dialog
•      Library Fireplaces
•      Chimneys

General Shapes
Items in the Home Designer Essentials 
Content> Shapes library allow you to create 
a variety of custom objects using basic 
geometric shapes. These shapes can can be 

used individually or combined to create a 
wide variety of custom objects. 

General Shape objects are placed and edited 
much like other library objects. See “Editing 
Box-Based Objects” on page 72.

Soffits
Soffits typically fill the space between 
the tops of wall cabinets and the 

ceiling, but they are very versatile and can be 

used to create almost any other object that 
can be modeled as a 3D box. Select Build> 
Cabinet> Soffit to activate this tool.
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Soffit Defaults
The default settings for soffits are set in the 
Soffit Defaults dialog. The settings in this 
dialog are similar to those in the Soffit 
Specification dialog. See “Soffit 
Specification Dialog” on page 258.

For best results when placing soffits above 
wall cabinets:
• The default soffit should be the same 

width as and 1" (20mm) deeper than the 
default wall cabinet. See “Cabinet 
Defaults” on page 221. 

• The default soffit Floor to Bottom value 
should equal the sum of the default wall 
cabinet’s Floor to Bottom value plus its 
Height. See “General Tab” on page 258.

• The default soffit Height should be equal 
to or greater than the space between the 
ceiling and the top of the wall cabinets. 

If the sum of the default soffit’s Floor to 
Bottom value and Height is larger than the 
ceiling height of the room in which a soffit is 
placed, the Floor to Bottom value will be 
retained and its Height will be adjusted so 
that it fits under the ceiling. 

The maximum soffit width is 170 feet (52m), 
and the minimum width is 1/16" (1 mm).

Once a soffit is placed in a plan, you can 
change its size and position to meet a variety 
of needs. 

Placing Soffits
Soffits can be created in both 2D and 3D 

views by simply clicking with the Soffit  
tool active. See “Click-to-Create” on page 
54. 

They can be assigned materials that are 
calculated in the Materials List, but by 
default they use the material assigned to the 
default wall. See “Wall Defaults” on page 86.

When positioned against a wall in a room, 
soffits will display any moldings present in 
that room that are at the same height as the 
soffit. See “Moldings Tab” on page 123.

To create a corner soffit, click as close to an 
inside wall corner as possible. A corner soffit 
retains its shape when it is moved, edited, or 
copied. 

When a soffit is created, it is placed on the 
“Cabinets, Soffits” layer. See “Displaying 
Objects” on page 48. 

Special Applications for Soffits
Anything that can be represented by a three 
dimensional box of any size or angle can be 
represented by a soffit. They can be resized 
to as small as 1/16" x 1/16" x 1/16" (1mm x 
1mm x 1mm) or as large as 135 feet (32m).

Soffits can have materials applied to them to 
represent simple mirrors, posts, chimneys 
and so on.

Following are some additional examples.

Accent Tile Surrounds
A material such as ceramic tile can be 
assigned to one or more soffits applied to the 
walls above tubs or in showers.



Calculating Materials on Soffits

 257

Masonry Veneer
Create a brick or stone veneer that extends 
halfway up a wall using soffits placed around 
the base of the house. Specify a depth for the 
soffits equal to the masonry material to be 
used.

Soffits automatically stop at the floor 
platform when moved downward. To place a 
soffit for a brick ledge, create a Cross 

Section/Elevation  view looking straight 
at the brick ledge. Select the brick soffit, hold 
the Ctrl key down, grab the soffit by its 
middle handle, and drag it down past the 
floor so that it covers the floor platform edge 
as well. See “Unrestricted Movement” on 
page 78.

Calculating Materials on Soffits
The number of bricks, tiles, shingles, shakes 
or other materials applied to a soffit is 
calculated using the following rules:
• If the soffit depth is less than the larger of 

4 inches (10 mm) or 1 ½ times the mate-
rial thickness, then only the front area of 
the soffit is used. Thus if a soffit is 
48"x48”x4” thick, and the Dark Red 
brick material is used (3"x 8" with 3/8” 
mortar joint) the front of the soffit is 
48"x48”=2304 square inches. Including 
the mortar joint, each brick requires 3 3/
8” x 8 3/8” = 28.26 square inches. 2304 

sq. in. divided by 28.26 sq. in. per brick 
gives 81.5 bricks.

• If the soffit depth is greater than both 4 
inches (10 mm) and 1 ½ times the mate-
rial thickness, then the surface areas of 
the soffit back, sides and top are used in 
addition to the front, if these surfaces are 
not attached to a wall or other soffit. 
However, only those portions of the 
sides, top and bottom remaining after 
subtracting twice the material thickness 
are used. So, for Dark Red brick, which 
has a depth of 4", the sides, top and bot-
tom surface areas cannot contribute to the 
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brick count unless the soffit depth is 
greater than 8 inches.

• If surface materials such as brick are 
applied to a large soffit, the soffit center 
is assumed to be hollow, with only a sin-
gle layer of the material applied to each 
applicable face.

• For shingles and shakes, the overlap 
amount should be subtracted from the 

height, as opposed to brick or tile, where 
the joint width is added to the size.

• For materials in the area category, the 
soffit area calculation above is used, with 
the material thickness treated as zero.

• For materials in the volume, concrete or 
earth categories, the true volume of the 
soffit is used.

Soffit Specification Dialog
To customize a soffit using the Soffit 
Specification dialog, double-click on 

the soffit using the Soffit  tool or select 
the soffit and click the Open Object edit 
button.

The settings in this dialog are similar to those 
in the Soffit Defaults dialog, but affect only 
the selected object(s). 

General Tab

Define the Size and Position of the selected soffit relative to the floor or terrain. 

2

1

1
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• Specify the Width of the soffit. 
• Define the vertical Height of the soffit. 
• Depth - Define the distance between the 

front and the back of the soffit. When 
selected in floor plan view, the front of a 
soffit has a “V,” and the back of the soffit 
has a triangular rotation handle.

• If the selected soffit is a corner soffit, the 
Width controls its left side width, and 
Depth controls its right side width. 

• Floor to Bottom - Specify the distance 
from the bottom of the soffit to the floor. 
This is sometimes more easily done by 
positioning the soffit in a 3D view.

• Auto Adjust Height - If the soffit is out-
side a room, check this box to place it rel-
ative to the terrain height. When 
unchecked, the soffit’s Height is mea-
sured from the default floor height of 
Floor 1. See “Terrain Height vs Floor 
Height” on page 238 of the Reference 
Manual.

A preview of the soffit displays on the 
right side of the dialog box.

Materials Tab
For information about the settings on this 
tab, see “Materials Tab” on page 284.

Fireplaces
A masonry fireplace can be placed in 
or away from a wall by selecting 

Build> Fireplace and then clicking in the 
drawing area. 
• If created in a wall, it is considered a wall 

opening and can be moved or resized like 
a window or door. 

• If created away from a wall, it moves and 
resizes similar to a cabinet.

A selection of prefabricated metal fireplaces 
is also available from the Fixtures (Interior) 
library category. These can be framed in with 
standard walls. See “The Library” on page 
265.

The display of fireplaces is controlled in the 
Display Options dialog. See “Display 
Options Dialog” on page 49.

Fireplaces are edited, moved, resized, and 
deleted similar other objects. See “Editing 
Objects” on page 59.

Built into a Wall
To place a masonry fireplace in a wall, select 

Build> Fireplace  and click on a wall. A 
fireplace is created with the outside of the 
fireplace flush with the outside of the wall.

Select the fireplace to display four edit 
handles located along the wall.

Click the diamond-shaped Depth handle and 
drag toward the outside of the wall. The 

2
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fireplace will stop when the firebox front is 
flush with the inside edge of the wall.

In 3D views, fireplaces placed in walls 
display five edit handles: a Resize handle 
along each edge and a Move handle at the 
center. 

Fireplaces always face the interior when 
placed on an exterior wall. When placing a 
fireplace in an interior wall, click on the edge 
of the wall that you want the fireplace to 
face. The fireplace is created with the firebox 
on the same side as the wall edge you clicked 
on to create it. 

Freestanding
To place a free-standing masonry fireplace, 

select Build> Fireplace  and click in an 
open area away from a wall.

Unlike fireplaces placed in walls, free-
standing fireplace have ten edit handles when 
selected and may be rotated, resized, or 
moved in any direction, similar to the way 
CAD boxes can. See “Editing Box-Based 
Objects” on page 72.

Fireplace Foundations
If a fireplace is added on the first floor before 
building the foundation plan, a foundation 
will be generated under the fireplace when 
the foundation is built. 

The fireplace foundation is the same material 
type as the original fireplace, but will not 
have a firebox or a hearth. This fireplace 
foundation may be edited or deleted as 
desired. A firebox and hearth can be added in 
the Fireplace Specification dialog. 

Fireplace Specification Dialog
Select a masonry fireplace and click 
the Open Object edit button to 

display the Fireplace Specification dialog. 

Dimensions in this dialog here must be 
entered in whole inches. Fractions and 
decimals are not accepted.
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General Tab

Specify the Size and Position of the 
selected fireplace and its hearth. 

• Specify the Height of the fireplace.
• Specify the Width of the fireplace.
• Specify the Depth of the fireplace.
• Specify the Hearth Depth. This is mea-

sured from the front of the fireplace out 
into the room. To eliminate the hearth 
altogether, enter a zero for this value.

• Specify the Hearth Height, relative to 
the floor in that room.

• Enter the Floor to Bottom distance from 
the floor to the bottom of the hearth.

• Check Auto Adjust Height to make a 
free-standing fireplace outside a building 
adjust its height to that of the terrain. 
Only available when the selected fire-
place is free-standing.

Check Suppress Dimensions to turn 
off the display of the selected 

fireplace’s width and firebox width 
dimensions in floor plan view. 

The preview image of the fireplace 
updates as changes are made. Press the 

Tab key to update to the most recent change.

1
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Firebox Tab

Define the Size of the selected 
fireplace’s firebox.

• Specify the firebox’s Height and Width.
• Specify the Depth of the firebox.
• The defaults are 25, 24, and 18 inches 

respectively.

Define the firebox Offset, measured 
from the center of the fireplace. 

• Enter offset Distance, which is how far 
the firebox is offset from the fireplace 
center. A value of 0 centers the fire box in 
the fireplace. 

• Offset to Left/Right - Choose to offset 
the firebox to the left or to the right. 

Materials Tab
For information about the settings on this 
tab, see “Materials Tab” on page 284.

Library Fireplaces
A variety of different fireplace symbols are 
available in library. See “The Library” on 
page 265. The fireplaces in the Library 
behave just like other Library objects.

1

2

1

2

Always check the manufacturer’s prod-
uct information for the framing and

clearance requirements of the fireplace unit
you plan to use, and design your plan
accordingly
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Placing a Library Fireplace
A variety of fireplace symbols are available 
in the library. See “Placing Library Objects” 
on page 274.

Flush fireplaces are designed to snap to wall 
surfaces. 

Some fireplace symbols can be enclosed by 
walls or positioned to project through a wall.

Chimneys

Masonry Fireplace Chimneys

To create a chimney on a masonry fireplace

1. Select the fireplace in a 3D view. 
2. Ctrl + drag the top edge of the chimney 

upward through all the floors and the 
roof until it is to the desired height. See 
“Unrestricted Movement” on page 78.

3. When the chimney is approximately the 
correct height, select the fireplace, click 

the Open Object  edit button, and 
type in the exact height.

Chimney Chases & Caps
There are two ways to draw a chimney chase. 
• Place a closed box geometric shape or 

soffit in position over the chimney chase, 

resize it to match, then increase its height 
either in its specification dialog or in a 
3D view using the same method as 
extending a masonry fireplace. 

• Define the chimney chase as a room area 
using walls, making sure these walls are 
aligned between floors. The chimney 
chase “room” on the uppermost floor 
should have a much higher ceiling than 
the other rooms on that floor and should 
also have no ceiling or roof. See “Room 
Specification Dialog” on page 120.

A selection of chimney tops is available in 
the library.  In addition, custom chimney 
caps can be made using  Geometric Shapes 
and/or soffits. See “General Shapes” on page 
255 and “Soffits” on page 255.

Open Front Library fireplace 
projecting through a 4" wall
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Chapter 22:

The Library

Home Designer Essentials’s library offers 
thousands of symbols, materials, and images 
that can enhance any plan. 

Chapter Contents
•      The Library Browser
•      Searching the Library
•      Library Content
•      Downloading Library Content
•      Adding Library Content
•      Organizing the Library
•      Placing Library Objects
•      Select Library Object Dialog
•      Displaying Library Objects
•      Editing Library Objects
•      Symbol Object Specification Dialogs
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The Library Browser
The Home Designer Essentials 
Library Browser allows you to 

manage the contents of the library as well as 
add library content to your drawings. 

To open the Library Browser:

• Select Library> Library Browser .

• Click the Library Browser button .
• Press Ctrl + L on your keyboard.

By default, the Library Browser is docked to 
the right side of the program window, but can 
be undocked or docked to another side. See 
“Docking the Library Browser” on page 268.

The Library Browser has four sections: 
• The search options at the top. 
• The Directory and Search Results Pane. 
• The Selection Pane. 
• The Preview Pane. 

To adjust the height or width of a section, 
place the pointer over the split bar you want 
to move. When the double-headed arrow  
displays, click and drag. 

You can work on your drawing with the 
Library Browser open. To close the Browser, 
click the Close  button or double-click on 
an object in the Selection Pane. 

The library has three categories: Home 
Designer Essentials Core Catalogs, User 
Catalog and Trash. See “Library Content” on 
page 270. 

Search the library using keywords and 
optional search filters. See “Searching 

the Library” on page 269.
• Begin typing in the text field to search for 

library items. As you type, search results 
will display in the Directory Pane. 

• Right-click on an item in the Search 
Results list and select Show in Browser 
to view the item’s location in the Direc-
tory list.

• Click the Browse  button to stop 
searching and restore the Directory list.

1
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• Click the Search  button to display the 
search results for your search entry.

• Click the Turn On Search Filtering  
button to display the search filtering 
options and customize your search 
parameters. 

• Click the Turn Off Search Filtering  
button to display the search filtering 
options and customize your search 
parameters. 

The library Directory and Search 
Results display here. The basic 

structure of the directory tree is: 

•  Library Category

•       Library Catalog 1

•           Library Folder 1

•                Library Object

•            Library Folder 2

•       Library Catalog 2       and so on.

Library items are always placed in 
alphabetical order within their heirarchy.

The Library Browser includes a Trash bin, 
where deleted items are moved until you 
choose to Empty Trash. See “Deleting 
Library Items” on page 274.

Navigate the Directory Pane using the 
mouse. Click the  beside a catalog or 
folder to display its contents. Once 
expanded, you can click the  beside it to 
close it again. You can also scroll the list 
using the arrow keys on your keyboard. 

Click on an item to select it. Preview images 
display in the Selection and Preview Panes 
and basic information about it also displays 

in the program’s Status Bar. See “The Status 
Bar” on page 24.

The Selection Pane shows a thumbnail 
image of the item selected in the 

Directory Pane.  

When an item is selected in the Directory 
Pane, a basic line-based representation of the 
item displays in the Selection Pane.
• If the selected item is a single object, a 

preview of that object displays in the Pre-
view Pane. You can move your cursor 
into the drawing area to place the item. 
See “Placing Library Objects” on page 
274. 

• If the selected item is a folder, a thumb-
nail image displays, representing each 
item inside. Move your pointer over an 
item in this pane to see a Tool Tip with 
the item’s name. Click on a folder in the 
Selection Pane to display its contents 
here and make it the item selected in the 
Directory Pane.

• Some folders may have too many items 
to display useful thumbnails for each; 
when this is the case, they do not display.

Click the Show/Hide Selection Pane  button 
to toggle the Selection Pane on and off.

When an individual object is selected in 
either the Directory or Selection Pane, 

an image of it displays in the Preview Pane. 

You can click the Toggle Display  button at 
the bottom of the browser window to switch 
between preview images in high and low 
detail. 

If the selected object is a 3D symbol, you can  
rotate and zoom in or out on the Preview 
using the mouse.

2

3

4
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If you have rotated a view in the Preview 
Pane, you can restore the default angle either 
by clicking in the Selection Pane or by right-
clicking on the Preview Pane and selecting 
Reset Preview.  

Click the Show/Hide Preview Pane  button 
to toggle the Preview Pane on and off.

The toolbar at the bottom of the 
browser aids in searching, displaying 

panes, and managing library content. 

Click the Show/Hide Selection Pane 
button to toggle the Selection Pane on 

and off.

Click the Show/Hide Preview Pane 
button to toggle the Preview Pane on 

and off.

Click the Toggle Display button to 
switch between  high and low detail 

images of a selected library object in the 
Preview Pane. 

Using the Contextual Menus
A number of important library functions can 
be accessed using the contextual menus. 
Right-click on an item in the Library 
Browser to open a contextual menu 
displaying options related to that item. See      
Contextual Menus.

The options in the contextual menu vary 
depending on the item selected, but may 
include: 
• Cut/Copy/Paste
• Paste Shortcut
• Rename
• Delete
• Open
• Reset Preview
• Expand All/Collapse All
• Show in Browser

Keyboard Commands
The Library Browser can be navigated using 
the arrow keys on your keyboard. 
• The right and left arrow keys expand and 

collapse folders.
• The up and down keys change which 

library object is currently selected.
• Select an item and press F2 to rename it.
• Select an item and press the Delete key to 

delete it. 

Expand/Collapse All
When a library category or folder is selected 
in the Directory Pane, Expand All and 
Collapse All are available in the contextual 
menu, allowing you to expand or contract its 
contents in the tree view.

Docking the Library 
Browser

Initially, the Library Browser is docked to 
the right side of the Home Designer 
Essentials program window.

5
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To undock the browser window, double-click 
the striped grab bar. You can also undock it 
by clicking on the grab bar and dragging it 
into the center of the program window.

Once undocked, the Library Browser can be 
moved by clicking and dragging the title bar.

When moved to the top, bottom, or side of 
your screen, it automatically docks in a 
vertical or horizontal orientation, depending 
on its location.
• Holding down the Ctrl key prevents the 

Library Browser from docking while 
moving.

• If you close the program with the Library 
Browser docked, it displays in the same 

position the next time the program is 
opened. 

To return the browser window to its original 
position and size, select Library> Restore 
Position/Size Defaults. 

Closing the Library 
Browser

The Library Browser can be closed in either 
of two ways: 

• Click the Close  button at the top right 
corner of the browser window.

• Select Library> Close Library 
Browser .

Searching the Library
The Library Browser filtering options let you 
focus your searches to meet parameters that 
you define. 

To search the Library Browser

1. Select Library> Library Browser  
and click in the Search field at the top of 
the Library Browser.

2. Begin typing a keyword to search for.
3. As you type, the search results will pop-

ulate in the Directory Pane below.
4. If you move your mouse pointer over the 

Search field, a Tool Tip will state the 
number of results of your search.

5. Right-click on an item in the Search 
Results list and select Show in Browser 
to view the item’s location in the Direc-
tory list.

Substrings are not included. For example, 
searching for “windows” will not produce 
“window” as a search result. On the other 
hand, searching for “window” will produce 
“windows” as a search result.

To search using custom filters

1. Click the Turn on search filtering 
optons  button. 

•  Check Match Keyword to match the 
entered search keyword with an 
object’s search attributes. 

•  Check Match Entire Word to match 
the entire keyword or words with the 
complete name of the object. 

•  Check Match Folders to include 
library folders in your search.

2. Check Filter by to enable additional fil-
tering options, which display below.
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3. Select a filtering option from the drop-
down list on the left, then choose what to 
include in the filter from the drop-down 
list on the right:

•  Select Type, then select a category of 
library item to include in your search.

•  Select Style, then choose a design style 
to restrict the search results to objects 
of that style.

•  Select Manufacturer, then choose the 
name of a manufacturer to include in 
your search.

4. Multiple filters can be created and used 
at the same time:

•  Click the Add  button to the right of 
a filter to make copy of that filter.

•  Specify a new Type, Style, and/or 
Manufacturer for the new filter. 

•  Click the Delete  button to the right 
of a filter to remove that filter.

Library Content
The Home Designer Essentials library has 
three categories: Home Designer Essentials 
Core Catalogs, User Catalog and Trash. See 
Getting Started Guide, “Deleting Library 
Items” on page 274.

Home Designer Core Catalogs
The Home Designer Essentials Core 
Catalogs category contains a wide selection 
of 3D symbols, images, and materials. 

When you launch the program for the first 
time, you will be asked if you want to 
download the Core Catalogs. Click Yes to 
begin the download. If you click No, you can 
download at any time by selecting Library> 
Download Core Content from the menu. 

The User Catalog
The User Catalog is the location for items 
that you add to the library. See “Adding 
Library Content” on page 271. 

You can create and organize custom library 
folders and imported images, backdrops, and 
materials. See “Organizing the Library” on 
page 272.

Backing up Library Content
The Home Designer Essentials User Catalog 
File, User_Library.calib, is located in the 
Home Designer Essentials 2012 Data folder. 
See “Home Designer Essentials Data” on 
page 31. 

Downloading Library Content
When you launch Home Designer Essentials 
for the first time, you will be asked if you 

want to download the Core Catalogs. Click 
Yes to begin the download. 

Note: Your custom search settings are not
retained when you end the current program
session.
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If you click No, you can download at any 
time by selecting Library> Install Core 
Content from the menu. 

Download Progress
When library content is downloading, a 
green progress bar will display at the bottom 
of the Library Browser. If you choose to 
download the Core Catalogs while the library 
is not open, the Browser will open so the 
progress indicator can display. 

Click on the progress bar to display the name 
of the current file being downloaded, the 
total amount of data to be downloaded in 
KB, and the amount downloaded so far.

Pausing and Resuming
The library download can only take place 
while Home Designer Essentials is running. 
If you close the program while the download 

is in progress, a dialog will confirm whether 
you wish to stop the download.
• Click Stop Download and Close Pro-

gram to stop the download and close the 
program. 

• Click Cancel to leave the program open 
and continue downloading. 

The Core Catalogs contain a large volume of 
data saved in multiple files. If you close the 
program and stop the Core Catalogs 
download midway, only data associated with 
the file currently being downloaded will be 
lost. You can resume the download 
beginning with that file at a later time by 
selecting Library> Download Core 
Content.

Download Errors
If any problems occur during the library 
download process, a dialog box will notify 
you at the end of the download. Click Retry 
Download to repeat the download and 
correct any errors or click Cancel to discard 
the downloaded catalog. 

Adding Library Content
In addition to downloading Home Designer 
Essentials Content  into the library, you can 
also add a variety of individual objects to the 
library. 

Adding Materials and Images
Home Designer Essentials can use materials 
and images in a variety of file formats and 
provides several means of adding new 
material and image files to the library. For 

more information, see “Creating Materials” 
on page 286 and “Adding Images to the 
Library” on page 353. 

Adding New Backdrops
Backdrops are images that display behind the 
model in 3D views. See “3D Backdrops” on 
page 306.
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To add a backdrop to the library

1. Select File> Import> Backdrop  to 
open the Import Backdrop File dialog, 
which is similar to the Import Picture 
File dialog. See “Importing Pictures” on 
page 356.

2. Browse to an image file on your com-
puter, select it, and click Open. This 
backdrop can now be found in the My 
Backdrops library.

You can also create a new backdrop by 
copying and pasting an image into Home 
Designer Essentials. See “Copying and 
Pasting Objects” on page 55. 

New materials and images can be created in 
the User Catalog or any folder within it. 
Right-click on the User Catalog or a folder 
within it, select New> from the contextual 
menu, then select the type of item you wish 
to create from the submenu. 

Organizing the Library
Library folders and objects can be copied, 
pasted, moved, and deleted: allowing you to 
organize your User Catalog to best suit your 
work style and needs.  

Adding New Folders
New folders can be added to User Catalog or 
to any folder located within the User 
Catalog. To add a new folder, right-click on 
User Catalog or one of its sub-folders and 
select New> Folder from the contextual 
menu. The new folder is created inside the 
library item you right-clicked on and is 
initially named “Untitled”. Type a short, 
descriptive name and press Enter. 

Selecting Library Items
To select a library object, folder, or category, 
simply click on it.
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When an item is selected, preview images 
display in the Selection and Preview Panes 
and basic information about it also displays 
in the program’s Status Bar. See “The Status 
Bar” on page 24. 

A selected library item can be modified in a 
number of ways to help meet your 
organizational needs. 

Renaming Library Items
Only folders and objects in the User Catalog 
can be renamed. There are several ways to do 
this from the tree list: 
• Right-click on the item, select Rename 

from the contextual menu, and type a 
new name. 

• Click once on the item, press F2 on your 
keyboard and type a new name.

• Click once on the item, pause for a 
moment, then click a second time and 
type a new name.

Library names are case-sensitive and can 
contain up to 63 characters. While you can 
have more than one library item that uses the 
same name, it is best to use short, descriptive 
and unique names.

Moving Library Items
Folders and objects in the User Catalog can 
be moved to new locations within the User 
Catalog. Folders and library objects are 
always organized alphabetically within each 
hierarchy.

To move an item to a different location, 
select it in the tree list, then click and drag it 
to the new location in the list. Directories and 
folders able to accept new content highlight 
as your ouse pointer moves over them. 

Release the mouse button to relocate the 
selected library item in the highlighted 
location.

Copying Library Items
All library folders and library objects can be 
copied and pasted to new locations in the 
User Catalog. 

There are two ways to copy a library item to 
the Windows Clipboard: 
• Right-click on it and select Copy from 

the contextual menu. 
• Click on the library item and press 

Ctrl + C on your keyboard.

To Paste the item, click on a library catalog 
or folder in the Library Browser tree view 
and either:
• Right-click on the new location and 

select Paste from the contextual menu.
• Press Ctrl + V on your keyboard. 

When a library item is copied and pasted, the 
new item that results is independent of the 
original item. If you make changes to it, the 
original item is unaffected. Similarly, 
changes to the original item do not affect the 
copy.

Library Shortcuts
In addition to copying and pasting to create 
new, independent library items, you can copy 
and paste to create Library Shortcuts. Library 
Shortcuts are not independent items - they 
are linked to the original item and are 
affected if changes are made to the original.

Library Shortcuts are advantageous because 
you can place a given library item in multiple 
locations to suit your organizational style 
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without increasing the size of the library 
database and without having to maintain 
multiple copies of the same item.

To create a Library Shortcut, copy a library 
item to the Windows Clipboard. Then, right-
click on the location where you would like to 
create a copy and select Paste Shortcut from 
the contextual menu. Library Shortcuts use 
the same name as their source item but use 

the Library Shortcut  icon.

To locate a Library Shortcut’s source item, 
right-click on it in the tree list and select 
Locate Shortcut Source 

If you move or delete an item from the 
library, any shortcuts to it will not be updated 
or removed. If you try to use a “hanging” 
shortcut, a message about its status will 
display in the library preview panes.

Deleting Library Items
The three installed library categories: Home 
Designer Essentials Core Catalogs, User 
Catalog, and Trash cannot be deleted. 

Individual subfolders and objects can be 
deleted out of the User Catalog in either of 
two ways: 
• Right-click on it and choose Delete from 

the contextual menu.
• Select it and press the Delete key on your 

keyboard.

When items from the User Catalog are 
deleted, they are moved to the Library 

Browser Trash . Items in the Trash can be 
retrieved by clicking and dragging them into 
any location in the User Catalog.

To empty the Trash , right-click on it and 
select Empty Trash from the contextual 
menu. 

Depending on how much content is in the 
Trash, emptying it can be time consuming. 
You can click the Cancel button to end the 
process if you wish. 

Placing Library Objects
Library objects are subject to placement 
restrictions based upon typical real-life 
placement. Most library objects require 
sufficient free space at the location where 
they are placed, for example, and some 
library objects have additional requirements.

Library windows and doors, for example, 
must be placed in a wall just like standard 

windows and doors, and some fixtures are 
designed to be placed in cabinets.

If a warning message displays when placing 
a library object, it will indicate where the 
object can be placed. 

There are three main categories of items 
available in the Library Browser:

The Empty Trash command is both
immediate and permanent. It cannot be

undone, so use care when using it. You
should back up all your library files regularly.
See “Backing up Library Content” on page
270. 
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• Stand-alone objects that can be placed 
directly into a plan. Examples include 
cabinet modules, furnishings and images.

• 3D objects designed to be inserted into 
another 3D object. Examples include 
cabinet fixtures, windows and doors. 
Some items, such as cabinet doors and 
fixtures and fence panels, can be inserted 
into another object or placed as stand-
alone objects. 

• Materials, which cannot stand alone and 
must be assigned or applied to another 
object.

Stand-Alone Objects
Most library categories contain objects that 
can be selected in the Library Browser and 
placed directly in a 2D or 3D view. 
• Most stand-alone objects are designed to 

rest on the floor or terrain.
• Some objects will rest on top of a cabinet, 

shelf, furniture or roof plane object if one 
is located at the point where they are first 
placed.

• A few objects, notably some light fix-
tures, will mount on the bottom of a wall 
cabinet or on the ceiling.

• In addition, some objects will attach to a 
wall if one is nearby.

To place a stand alone library object

1. Click on an object in the tree view or 
Selection Pane of the Library Browser to 
select it for placement. See “The Library 
Browser” on page 266. 

2. Move your cursor into the view area and 
notice that it displays an icon indicating 

the type of object selected instead of an 
arrow icon.

3. Click to place the selected object at that 
location. 

4. Continue clicking to place as many 
instances of the selected object as 
needed. When you are finished, click the 

Select Objects  button. 

Once a stand-alone object has been placed, it 
can be edited in a variety of ways. See 
“Editing Library Objects” on page 277.

Inserted Objects
Some objects cannot stand alone and must be 
placed into other objects in a plan. For 
example, doors and windows must be 
inserted into a wall, while some appliances 
and plumbing fixtures must be placed inside 
a base cabinet. See “Doors” on page 127, 
“Windows” on page 143 and “Cabinets” on 
page 221.

An inserted object can only display in a 2D 
or 3D view if the object that contains it is set 
to display. This is the case even if the 
inserted object’s layer is turned on. See 
“Displaying Library Objects” on page 277. 

To insert a library object

1. Click on an object in the tree view or 
Selection Pane of the Library Browser to 
select it for placement. See “The Library 
Browser” on page 266. 

2. Move your cursor into the drawing area.
3. Click on the object into which you wish 

to insert the selected library item. The 
library item is inserted into the object.
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4. Continue clicking to place as many 
instances of the selected item as needed. 
When you are finished, click the Select 

Objects  button.

Assigned Items
Some library items, such as materials, are not 
objects in themselves but can be applied to 
objects in a variety of ways.

• Using the specification dialog of the con-
taining object. See “Select Library Object 
Dialog” on page 276.

• By selecting the item in the library and 
then clicking on the containing object in 
floor plan view.

• Materials can be assigned to objects 
directly from the library in 3D views by 
by selecting the material and then 
clicking on an object’s surface. See “The 
Material Painter” on page 282.

Select Library Object Dialog
The Select Library Object dialog is a modal 
version of the Library Browser that is 
accessible from object specification dialogs 
that display the  button. Click this 
button to select and apply items from the 
library to the object currently opened for 
specification. See “Specification Dialogs” on 
page 24. 

The Select Library Object dialog only 
displays categories that are related to the 
opened object. For example, this is how the 
dialog looks when accessed from the General 
tab of the Door Specification dialog:

If the Select Library Object dialog is opened 
by clicking the Select Material button on the 
Materials tab of any specification dialog  or 

using the Material Painter , two 
additional options are available: 
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• Click the Add New Material  button 
to open the Define Material dialog and 
create a new material.

• Check Use default material to apply the 
default material for the selected object, if 
one exists. See “Material Defaults” on 
page 289.

See “Materials Tab” on page 284 or “The 
Material Painter” on page 282.

To make your selection, highlight the desired 
object and click OK, or simply double-click 
on the object in the Selection Pane to close 
the Select Library Object dialog. 

The Select Library Object dialog and its 
individual panes can be resized , display 
the Preview and Selection Panes, and can 
includes the search and search filtering 
options.  

Displaying Library Objects
The display options available for library 
objects depend on the type of object in 
question, as well as the view.

If the display of an object is turned off in a 
2D or 3D view, any objects inserted into it 
will not display in that view, either - even if 
the inserted object’s layer is turned on. See 
“Inserted Objects” on page 275. 

In Floor Plan View
All library objects except materials, doors 
and drawers applied to cabinets, and 
backdrops can display in floor plan view. 
Library objects are represented in floor plan 
view by 2D symbols that resemble the size 
and shape of the object when viewed from 
above.

As with other architectural objects, the 
display of library objects is controlled by 
layer in the Display Options dialog. Each 

library category has its own layer.  See 
“Display Options Dialog” on page 49.

Object Labels
Fixtures, Furnishings, Geometric Shapes, 
Hardware, Millwork and Plants can display 
labels in floor plan view when the 
appropriate layer is set to display in the 
Display Options dialog. For example, 
fixture labels are placed on the “Fixtures, 
Labels” layer.

In 3D Views
All library objects can display in 3D views. 

By default, images rotate to face the camera 
in 3D views. For information about turning 
off image rotation, see “Image Specification 
Dialog” on page 355.

Editing Library Objects
Library objects placed in a drawing can be 
selected individually or as a group, like other 

objects in Home Designer Essentials. See 
“Selecting Objects” on page 60. 
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Once selected, library objects can be edited 
in a variety of ways using the edit handles, 
the edit toolbar buttons and the specification 
dialog. See “Symbol Object Specification 
Dialogs” on page 278. 

In Home Designer Essentials, objects created 
using the program’s standard tools, such as 

the Door Tools  and Cabinet Tools , 
are referred to as native objects. 

On the other hand, objects placed from the 
library, such as fixtures and furnishings, are 
symbols. Symbols are typically more limited 
than native objects in how they can be edited.

Using Edit Handles
Most library symbols are box-based objects 
and can be edited as such once placed in a 
drawing. See “Editing Box-Based Objects” 
on page 72. Depending on the type of view 
and the surface selected, the edit handles a 
symbol displays will vary. 

To resize Fixtures and Furniture, you must 
check Fixture/Furniture Resize Enabled in 
the Plan Defaults dialog. When this option is 
checked, these library objects have edit 
handles when selected and can be resized 

like other objects. See “General Plan 
Defaults Dialog” on page 43. 

When a furnishing or fixture symbol is 
selected in floor plan view or on the top 
surface in a 3D view, up to ten edit handles 
display. They are the Move handle at the 
center, the Rotate handle just outside the 
front indicator (a V) and a Resize handle on 
each edge and at each corner. 

When a symbol is selected on a side in a 
cross section/elevation or 3D view, it 
displays five edit handles: the Move handle 
and a Resize handle on each edge. 

Fixtures and furniture placed in a plan are 
subject to bumping/pushing behavior when 
moved. See “Bumping/Pushing” on page 77.

In the Specification Dialog
The specification dialog for any image, 
material, or plant image in the library can be 
edited from the Library Browser Directory 
Pane. See “Specification Dialogs” on page 
24. 

Specification dialogs are not available for 
native objects saved in the library. 

Symbol Object Specification Dialogs
The Fixture, Furniture, Geometric 
Shape and Millwork Specification 

dialogs all feature the same options. The 
actual name of the dialog is determined by 
the type of object that is currently selected. 

For example, selecting a library object from 
the Interiors folder and clicking the Open 

Object  edit button opens the Furniture 
Specification dialog. 
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General Tab

The Name of the selected object 
displays here.

Specification - Define the size and 
height above the floor of the object. 

• Specify the Height, Width, and Depth of 
the object.

• Floor to Bottom - Enter the distance 
from the floor to the bottom of the object. 
A value of zero makes the object rest on 
the floor. 

• If the selected symbol is ceiling mounted, 
Height Above Ceiling will be available 
instead of Floor to Bottom. Specify the 
selected object’s height above the ceiling. 
Enter a negative value to offset the sym-
bol below the ceiling, or uncheck Follow 
Ceiling if you prefer to specify the 
object’s Floor to Bottom height instead. 

• Click Reset to reset the symbol’s origi-
nal, unmodified size. The Floor to Bot-
tom value is not affected by this button.

• Check Auto Adjust Height if you want 
the object to follow the surface of the ter-
rain when it is placed outside a building.

Check Reverse Symbol to reverse the 
object’s appearance, so that features on 

its left are positioned on its right, and vice 
versa. This turns a right-hand refrigerator, for 
example, into a left-hand refrigerator. This 
option has no effect on objects that are 
symmetrical.

A preview of the library object displays 
here and updates with changes.

Materials Tab
For information about the settings on this 
tab, see “Materials Tab” on page 284.

1
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Chapter 23:

Materials

The objects used in Home Designer 
Essentials have a variety of 3D properties. 
These objects - walls, windows, doors, 
cabinets, roof planes, lot perimeters, etc. - 
can have materials assigned to them so that 
they look realistic in 3D views. These 
materials can also be used to generate 
materials lists that can help with cost 
estimations.

Designing with objects that look correct in 
3D and calculate properly in the Materials 
List requires that you use realistic material 
definitions and apply them appropriately to 
objects in your plan.

Home Designer Essentials comes with many 
materials that are ready for use. From siding, 
roofing, flooring, masonry, tile, and paneling, 
to grass, water, and wood materials, Home 
Designer Essentials has materials for every 
application, inside and out. If you cannot find 

a material that suits your needs, you can 
customize the materials provided or create 
your own.

Chapter Contents
•      About Materials
•      The Material Painter
•      Materials Tab
•      Editing Materials
•      Creating Materials
•      Define Material Dialog
•      Material Defaults
•      Color Chooser Dialog

About Materials
The materials that are assigned to objects in 
Home Designer Essentials perform two 

important roles:

Redefining only the visual properties of a
material may create unexpected results.

For example, changing the image of a brick
material to represent siding does not cause
the material to be considered as siding during
material calculations.
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• They determine what the surfaces of 
objects look like in 3D views. 

• They influence how objects are calculated 
in the Materials List. See “Materials 
Lists” on page 373.

Materials are stored in the Materials library 
in the Library Browser and can be applied to 
objects in either of two ways:

• Using the Material Painter . 
• In an object’s specification dialog. See 

“Materials Tab” on page 284.

Textures
In Home Designer Essentials, materials have 
textures associated with them that determine 
how they look in 3D views.

Textures are created using special image files 
that tile seamlessly when applied to surfaces.

In 3D views, you can turn the display of 
textures on and off by selecting 3D> Render 

View Options> Toggle Textures .

 The Material Painter
Select 3D> Materials> Material 
Painter to access the Material Painter 

Tools, which are used to apply materials to 
object surfaces in 3D views. 

The Material Painter  tool can also be 
activated by selecting a material in the 
library while a 3D view is active. 

Material Painter Modes
There are five Material Painter Modes. Each 
mode specifies how broadly or narrowly the 
selected material will be applied to surfaces 
in your plan. 
• The Material Painter Component Mode 

 is the default mode. This applies the 
selected material to an object component. 
Using this tool is the same as opening an 
object for specification and changing the 
material for one of its components on the 
Materials tab. See “Materials Tab” on 
page 284.

• The Material Painter Object Mode  
applies a material to all components of an 
object that share the same material assign-
ment. 

• The Material Painter Room Mode  
applies a material to all the objects in the 
room that currently have the same mate-
rial. For example, if you apply a material 
to a dining room chair, this mode applies 
the material to all other objects in the 
room with the same original material, 
such as other chairs and the dining table.

• The Material Painter Floor Mode  
applies the selected material to all sur-
faces on the floor that currently have the 
same material. For example, if you apply 
a material to the kitchen countertops 
using this mode, the bathroom counter-
tops on the same floor also have the mate-
rial applied.

• The Material Painter Plan Mode  
applies the selected material to all sur-
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faces in the entire plan that currently have 
the same material. For example, if you 
have the same carpet on all floors in a 
plan, applying a selected material while 
this mode is active will change all carpet 
on all floors. 

When the Material Painter  tool is 
active, the Material Painter Mode toolbar 
buttons display in the edit toolbar, allowing 
you to quickly change modes.

You can also specify the active mode in the 

3D> Materials> Material Painter  
menu. A check displays next to the active 
mode in the submenu.

Blend Colors With Materials
In addition to the Material Painter 
Modes, the Blend Colors With 

Materials option allows you to apply a solid 
color to a surface displaying a pattern and 
blend the two. 

Blend Colors With Materials  works in 
all five Material Painter Modes. See 
“Blending Materials” on page 286.

To use the Material Painter tool

1. Create a 3D view in which the patterned 
material is visible.

2. Select 3D> Materials> Material 

Painter> Material Painter . 
3. Select a solid color material from the 

Select Library Object dialog. See 
“Select Library Object Dialog” on page 
276.

•  Check Use Default Material at the 
bottom left of the dialog to apply the 
default material to any object that has a 
defaults dialog. See “Material 
Defaults” on page 289.

4. Select a Material Painter Mode from the 
edit toolbar, which displays on the left 
side of the program window when the 
Material Painter is enabled.

5. Click the Blend Colors With Textures 

 edit button to turn this feature on or 
off depending on your needs.

6. Note that the name of the material being 
painted displays on the left side of the 
Status Bar at the bottom of the program 
window. See “The Status Bar” on page 
24. 

•  Move your pointer over a surface in the 
3D view. The Status Bar now states 
both the material being painted and the 
current material on the target surface.

7. Click on the surface to apply the 
selected material to that surface. The 
material is applied to surfaces in the 
model based on the active Material 
Painter Mode. 

•  When both the Material Painter  
and Blend Colors With Textures  are 
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active, the cursor displays a paint roller 

icon .

•  When the Material Painter  is 
active and Blend Colors With 

Textures  is not, the cursor displays 

a spray can icon . 

8. If either the Component  or Object 

Mode   is active, you can continue to 
click on surfaces to apply the selected 
material. When you are finished, select a 
different tool. 

Material Painter & Walls

As a general rule, the Material Painter  
cannot be used to apply a material to an 
individual wall. Rather, it applies the 
material to an entire room, to all the rooms 
on the floor, or to all the rooms in the entire 
plan, depending on which Material Painter 
Mode is active.

There are a couple of exceptions to this rule 
that apply when the wall surface being 
painted faces an exterior room such a porch 
and/or the Exterior Room. See “Room 
Types” on page 113.

• If the Material Painter Room Mode  
is active, the selected material is applied 
to the entire exterior room. If any walls 
defining this room also define other exte-
rior rooms, their entire lengths are also 
affected. 

• If the Material Painter Component 

Mode  is active, the entire length of 
the individual wall is painted. Other walls 
defining the exterior room(s) are unaf-
fected. 

Material Eyedropper
The Material Eyedropper tool 
allows you to load the material 

assigned to an existing object and apply that 
material to other objects.

In a 3D view, select 3D> Materials> Mate-

rial Eyedropper  and then move your 
mouse pointer over a surface in the view. The 
name of the material on that surface is stated 
on the left side of the Status Bar. Click on the 
surface to load its material assignment. The 
pointer then changes to indicate that the 
material is ready to be applied to another 

object using the Material Painter  tool. 
Depending on the currently active Material 
Painter Mode, you can continue to apply the 
material to the surfaces of other objects.

Materials Tab
The specification dialogs for most objects 
include a Materials tab. Select an object or a 
group of similar objects and click the Open 

Object  edit button to open the 
specification dialog for that selection. 

On the Materials tab, you can specify 
material assignments for the components that 
make up that object. When a new material is 
assigned, the appearance of the preview 
image on the right side of the dialog updates. 
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The tree list on the left side of the tab lists the 
components of the selected object that can be 
assigned materials. Some objects may only 
have a single component while more 
complex objects may have many. 

Some components contain additional sub-
components, which display separately in the 
components tree list. 

Select a component in the tree list to 
assign a new material to it. 

The box to the right of the tree list 
displays a preview of the texture of the 

material assigned to the selected component. 
If “No Texture” displays in the preview 
window, either the material has no texture 
assigned or the texture file could not be 
found on the system.

Click Select Material to open the 
Select Library Object dialog. Select a 

material and click OK to assign that material 
to the selected component. See “Select 
Library Object Dialog” on page 276. 

Select OK to close the dialog and return to 
the active view. 

Editing Materials
Much like objects, materials in Home 
Designer Essentials can be edited so that they 
better suits your design needs. There are two 
approaches to material editing:

• Select a material in an unlocked library in 
the Library Browser, edit it, and your 
changes will be used when you next use 
the material in any plan. Changes made in 
this manner do not affect materials 
already in use in a plan. 

1
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• Apply a material to an object in a plan and 
then edit that applied material using the 

Adjust Material Definition  tool. 
Changes made in this way will affect any 
instances of that material in the current 
plan only. 

Editing the material applied to an object is 
not the same as applying a different material 
to that object. See “The Material Painter” on 
page 282.

Library Browser
Right-click on a material in an unlocked 
library and select Open from the contextual 
menu to open the Define Material dialog for 
that material. See “Define Material Dialog” 
on page 287.

Adjust Material Definition
The Adjust Material Definition tool 
is useful for changing plan materials 

directly from a 3D view. 

Select 3D> Materials> Adjust Material 

Definition  and then click any surface in 
a 3D view to modify the material currently 
assigned to that surface in the Define 
Material dialog. See “Define Material Dia-
log” on page 287.

Changing a material definition with this tool 
affects all objects in the current plan that are 
using that material but does not affect any 
materials saved in the library or materials 
used in other plans. See “Adding Library 
Content” on page 271.

Creating Materials
Home Designer Essentials provides a wide 
variety of materials - including numerous 
name brand material catalogs - that are ready 
to download and use. If you cannot find a 
suitable material, you can edit an existing 
material or create a new one. See “Editing 
Materials” on page 285.

In the Library Browser
Materials can be created in the Library 
Browser, making them available for use in 
any plan. See “Adding Library Content” on 
page 271. 

In the directory pane of the Library Browser, 
right-click on an unlocked folder and select 
New> Material from the contextual menu. 
See “Using the Contextual Menus” on page 
268.

In the Define Material dialog, you can create 
a new material in the selected unlocked 
folder. See “Define Material Dialog” on page 
287. 

Blending Materials
In 3D views, you can create a new 
material by blending a solid color 

such as a paint color with a textured material. 
Select 3D> Materials> Material Painter> 
Blend Colors With Materials to toggle this 
feature on or off. See “Blend Colors With 
Materials” on page 283.

Note: Adding a material to a plan is not the
same as adding it to the library. If you want a
new material to be available for use in other
plans, create it in the Library Browser.



Define Material Dialog

 287

The result is a new material that is saved in 
the current plan. 

Materials created using the Blend Colors 

With Materials  tool are given the name 
of the patterned/textured material with the 
extension “--PAINTED:” followed by the 
name of the solid color material. 

Stretch to Fit
Some special textures, often used for 
artwork, stretch across any surfaces that they 

are applied to. Materials that behave this way 
are specified as Stretch to Fit in the Define 
Material dialog. 

To display an artwork texture, first place a 
wall or desk frame in your plan. A selection 
of both are available in the library at 
Furnishings (Interior)> Interior Accessories> 
Mirrors & Frames. See “Placing Library 
Objects” on page 274.

Next, simply apply a material specified as 
Stretch to Fit to the center portion of the 
frame. See “The Material Painter” on page 
282. 

Define Material Dialog
The Define Material dialog allows you to 
adjust how materials look in 3D views and 
can be accessed in a number of ways:
• Select a material from the Plan Materials 

dialog and click Edit, New, or Copy. 
• You can also right-click on an unlocked 

library and select New> Material.

If you select a manufacturer’s material, the 
options in the Define Material dialog may 
change. Some options are not available and 
the tabs may vary.

If you access the Define Material dialog 
through a menu or specification dialog, your 
edits affect that material wherever it is found 
in the current plan. Other objects in that plan 
that use that material are also affected, but 
objects outside the current plan are not. 
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The Name of the material displays 
here. In this field, you can type a new 

name if you wish. Renaming the material 
does not create a new material: it redefines 
the existing material. 

Solid Color - Click this radio button to 
specify the material as a solid color, 

then click the Select button to open the 
Windows Color Chooser dialog and select a 
new color. See “Color Chooser Dialog” on 
page 290.

Texture - Click this radio button to 
specify a texture for the material 

instead of a solid color, then click the Select 
button to open the Select Texture File 
dialog, a standard Open File dialog, and 
specify an image saved on your computer to 
serve as the texture.

Check Blend Color and Texture to 
blend the selected texture with a solid 

color, then click the Select Color button to 
specify the color you would like to blend it 
with.

When a new material is created using the 

Blends Color With Materials  tool, the 
resulting material has this box checked. See 
“Blend Colors With Materials” on page 283.

Specify the Scale for the chosen texture 
in inches (mm). If you specify x and y 

values of 30”, the pattern repeats every 30 
inches in both directions along a surface. 

Check Stretch to Fit to stretch the texture 
image over the entirety of each surface it is 
applied to. This is useful when you wish to 
create a painting or photo material to display 
in a frame. See “Stretch to Fit” on page 287.
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Rotate Angle - Specify how the texture 
is rotated on the surface.

A preview of the current material 
displays here.

Brightness - Controls how bright the 
material appears relative to other 

materials.

Shininess controls the sheen of the 
material when it is rendered with a 

point or spot light source on it. Shiny 
materials such as metal will reflect light 
when viewed at the right angle.

Transparency controls the opacity of 
the material. A transparency value of 0 

results in a completely opaque material, 
while a value of 100 creates a material that is 
completely invisible. 

Emissive - Use the slider bar or text 
field to control how bright a material 

appears independent of the lighting in the 
scene. It can be used to simulate surfaces that 
are glowing with their own light, such as the 
glass on a light fixture. 

Material Defaults
Most objects in the program have 
defaults dialogs which allow you to 

set up a variety of attributes, including 
materials, before the objects are created. 
Default Settings are accessed by selecting 
Edit> Default Settings. See “Default 
Settings” on page 41.

Not all objects, however, have default 
settings that can be accessed prior to being 
placed. Garage doors, for example, do not 
have a defaults dialog. Instead, you can 
specify the materials for them in the Material 
Defaults dialog. Once a garage door is 
created, you can change its materials. 

Select Edit> Default Settings  from the 
menu, select “Materials”, and click the Edit 
button to open the Material Defaults dialog. 

Material Defaults Dialog
The settings here are similar to those on the 
Materials tab found in object specification 
dialogs throughout the program. See “Mate-
rials Tab” on page 284.
• Select a category from the scrollable list. 
• Click the Select Material button or pre-

view box to open the Select Library 
Object dialog. See “Select Library Object 
Dialog” on page 276.

Note: Changing the scale or selecting Stretch
to Fit can cause textures to appear distorted if
they are mapped to a surface using a different
aspect ratio than they were originally created
with.
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Color Chooser Dialog
The Color Chooser dialog is opened by 
clicking on the color bar that can be found in 
many dialogs throughout the program.

Click in any one of the Base colors 
boxes to select it as the new color.

Click in one of the Custom colors 
boxes to either select it as the new color 

or to specify it as the box for a new custom 
color to be defined.

Click anywhere in the color palette area 
to dynamically choose a color. The 

location of a selected color is identified by a 
black crosshairs.

Click anywhere in the vertical bar to 
adjust the selected color’s darkness.

Drag the Color Chooser Eyedropper 
anywhere on your monitor and release 

the mouse button to select the color 
displaying at that location.

Click Add to Custom Colors to add 
the color to selected Custom Colors 

box.
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You can select a color from any program
window. Before opening the Color

Chooser dialog, make sure the desired color
can be seen onscreen by tiling Home Designer
Essentials and the other program window.
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Chapter 24:

Zoom & View Tools

Use the Zoom tools to position the current 
view. To work on a specific area, you may 
need to zoom in so that the entire screen is 
filled by only a single room. At other times 
you may need to view the entire plan.

There is no limit to the number of plan files 
that can be open. The name of the file and the 
type of view displays at the top of each view 
window in its title bar. 

There are a number of ways to pan across the 
screen, shifting the visible part of the plan 
slightly while still maintaining the same 
zoom factor. 

Multiple views of one or more open files also 
can be arranged and managed using the View 
tools.

Chapter Contents
•      Zoom Tools
•      Undo Zoom
•      Fill Window
•      Panning the Display
•      Swapping Views
•      Window Menu Tools
•      Cascade
•      Tiling Views
•      Arrange Icons
•      Closing Views
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Zoom Tools
Zoom is used to magnify any given 
area on the plan or 3D view. Select 

Window> Zoom, then click and drag a 
marquee around an area on screen. When 
you release the mouse, the selected area 
expands to fill the screen. 

When the zoom is complete, whatever tool 

was active prior to selecting the  Zoom  
tool automatically becomes active again. If 

another zoom is needed, click the  Zoom  
tool again.

Zoom In - Click to zoom in towards 
the screen center by a factor of two.

Zoom Out - Click to zoom out from 
the screen center by a factor of two.

Undo Zoom - Reverse the last zoom 
operation. See .

Fill Window - Fits all visible items on 
screen. See .

Fill Window Building Only - Fits all 
walls and railings on the current floor 

on screen. 

Pan Window - Move the display 
without changing the zoom factor. See 

.

Zooming With 
the Mouse Wheel

Use the mouse wheel to zoom in and 
out in plan and 3D views. Scrolling 
the mouse wheel one click up or 

down zooms in or out, centering on the 
location of your pointer and changing the 
zoom by about 10%.

Zooming in 3D Views
Zooming in 3D views does not change the 
camera’s location or field of view. Instead, 
the extents of the view are expanded or 
cropped. 

Undo Zoom
Select Window> Undo Zoom to 
reverse the last zoom operation. 

Zoom  and Undo Zoom  are also 
available through the contextual menu. See 
“Contextual Menus” on page 23. 

Note: Depending on the configuration of your
mouse, it may be necessary to hold down the
Ctrl key while turning the mouse wheel. If
zooming in and out are not working correctly,
contact the manufacturer of your mouse and
mouse driver for their assistance. 

Note: Undo and Redo do not affect zoom.
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Fill Window
In floor plan view or a cross section/
elevation view, select Window> Fill 

Window or press the F6 key to view nearly 
everything on screen that is visible, including 
the Reference Display. CAD Points are the 
only objects that are not included when Fill 
Window is used. 

If you are zoomed in so that only a portion of 
the drawing displays on screen, selecting Fill 

Window  zooms out so that the entire 
view fits on the screen. If you are zoomed 
out so that the entire drawing is smaller than 

the screen, selecting  Fill Window  
zooms in until the drawing fills the screen.

When the drawing sheet is shown, Fill 

Window  zooms to the sheet borders.

Fill Window Building Only
Window> Fill Window Building 
Only is similar to Fill Window, but 

zooms in or out to so that all walls and 
railings in the view fill the current window. 
Other objects are ignored.

In 3D Views

In 3D views, Fill Window  and Fill 

Window Building Only  adjust the 
camera’s Field of View is adjusted so that all 
surfaces in the 3D view are included.  

Panning the Display
There are four ways to pan the display 
without changing the zoom factor.

Using the Scroll Bars
One method is to use the scroll bars on the 
right and bottom edges of the window.

• Drag the square button in the bar itself in 
order to pan a larger distance. 

• Click the end arrow keys on the scroll 
bars to shift the display in 12" incre-
ments. 

• The 12" increment is defined in the Plan 
Defaults dialog under Inches Scrolled 
by Arrow Key. See “General Plan 
Defaults Dialog” on page 43.

Using the Arrow Keys
In floor plan view, the arrow keys on the 
keyboard work exactly like clicking the 
arrow buttons on the scroll bar. They shift the 
display according to the number of inches 
defined in the Plan Defaults dialog.
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Using the Mouse
If you have a wheel mouse, you can pan the 
display by pressing the middle mouse button, 
or wheel, and moving the mouse in the 
direction you would like to pan. When the 
middle mouse button is held down, the 

pointer changes to a hand  icon. 

Mouse drivers sometimes have other 
functions assigned to the wheel and buttons. 
These override the Home Designer 
Essentials setting.

Using the Pan Window Tool
The Pan Window tool works much 
like the mouse wheel method.

Select Window> Pan Window . The 

pointer changes to a hand  icon. Click and 
drag in floor plan view to pan the window. 
The command is invoked once and the pro-
gram reverts to the previously active tool 
when you release the mouse button.

Swapping Views
There are several ways to switch between 
open view windows.

• Select Window> Next Window  or 

Window> Previous Window  to 
cycle through all open views in the order 
you prefer. 

• Press the Ctrl + Tab (Next Window) or 
Ctrl + Shift + Tab (Previous Window) 
keys to cycle through all open views. 

• A list of all the views currently open is 
located at the bottom of the Window 
menu. Each view is identified by its name 
and what type of view it is. Select one to 
go directly to that view.

Window Menu Tools
Select Window from the menu to access the 
Window Menu tools, which help you display 
multiple view windows of your model at the 
same time.

Select Window> Cascade to cascade 
all open views. See “Cascade” on 

page 295.

Select Window> Tile 
Horizontally or Tile Vertically 

to tile all open views. See “Tiling Views” on 
page 297.

Select Window> Arrange Icons to 
arrange all open views that are 

currently minimized. See “Arrange Icons” on 
page 298. 

Select Window> Next Window to 
switch to the next open view. See 

“Swapping Views” on page 294.

Select Window> Previous Window 
to switch to the previous open view. 

See “Swapping Views” on page 294.
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Open View Windows
There is no limit to the number of plan files 
that can be open. The name of the file and the 
type of view displays at the top of each view 
window in its title bar. 

There is no limit to the number of 3D view 
windows that you can have open at a given 
time; bear in mind, though, that each window 
demands use of your computer’s resources 
and that you may see poor performance if too 
many views are open. See “3D Views” on 
page 299.

A list of all view windows currently open 
displays at the bottom of the Window menu. 
Each view is identified by its name and what 
type of view it is. A checkmark is beside the 
view that is currently active. Select one to go 
directly to that view. 

The names of up to eight views can display 
here. If more than eight view windows are 
open, More Windows is the last item in the 
menu. Select this option to open the Select 
Window dialog. 

Select the name of a view from the list and 
click OK to make it the active view.

Cascade
Select Window> Cascade to cascade 
all open views. Cascade is a Windows 

function which allows you to organize open 
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windows in a cascading pattern. Click on any 
visible edge to activate that window.



Tiling Views

 297

Tiling Views
The window tiling options allow 
you to display multiple views side 

by side in the Home Designer Essentials 
window.

Select Window> Tile Horizontally  to 
display both views in a horizontal 
orientation.

Select Window> Tile Vertically  or press 
Shift + F6 on the keyboard to display both 
views in a vertical orientation. 

To activate a view, click on its title bar or 
anywhere in the view window. Note that any 
changes you make are reflected in other 
views as well.

To end window tiling, click the 

Maximize  button in the upper right 
corner of any open view.

Tiling allows you to see the results of 
changes in floor plan view in 3D or vice 

versa, and can also be useful for copying 
objects from one plan to another.
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Arrange Icons
Arrange Icons is a Windows function 
used when several active windows 

have been minimized. Select Window> 
Arrange Icons to align the minimized title 

bars in a row at the bottom of the working 
desktop. You can then click the minimized 
title bars to reactivate them or use them for 
swapping and closing views.

Closing Views
Select File> Close or click the   at the top 
right corner of a window to close it. If the 

view is still needed, swap to a different view 
without closing the current views.
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Chapter 25:

3D Views

Little preparation is needed to create a 3D 
view of a model: simply click a button to 
create an overview or click and drag to create 
a camera or cross section/elevation view. 

To improve the quality of the rendering and 
create a custom look, you can adjust lighting 
and edit the materials used in the plan. You 
can create Final views that are even more 
realistic. See “3D Rendering” on page 317.

Many objects can be placed and edited in 3D 
views, and any camera view or overview can 
be saved or even used to record a 
walkthrough. See “Pictures, Images, & 
Walkthroughs” on page 351.

Chapter Contents
•      OpenGL and Hardware
•      3D Backdrop Dialog
•      Render Quality
•      3D View Tools
•      Creating Camera Views
•      Creating Overviews
•      Cross Section/Elevation Views
•      Displaying 3D Views
•      Editing 3D Views
•      Cross Section Slider
•      Working in 3D
•      Printing 3D Views
•      Camera Specification Dialog
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OpenGL and Hardware
Home Designer Essentials features a built in, 
easy to use rendering engine that makes use 
of OpenGL rendering technology, which has 
good hardware support on most video cards. 

To take full advantage of the rendering 
capabilities of Home Designer Essentials, a 
graphics card that supports OpenGL 

hardware acceleration and has at least 256 
MB of dedicated video memory is highly 
recommended. For complex models, an 
accelerated card generates quality renderings 
in seconds that might otherwise take minutes 
or even hours with a non-accelerated card or 
chipset.

3D Backdrop Dialog
Select 3D> 3D Backdrop from the 
menu to open the 3D Backdrop 

dialog. This dialog allows you to specify a 

solid color or picture file of your choice to 
use as a background for 3D views. See “3D 
Backdrops” on page 306. 

A preview of the selected backdrop 
displays. See “3D Backdrops” on page 

306.

Click Select Backdrop to open the 
Select Library Object dialog. Browse 

the Backdrops library, select a backdrop, 
and click OK.
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Click Remove Backdrop to change the 
backdrop to a solid color. The color 

used is defined in the Background Color 
section of this dialog. 

Show Backdrop in - Specify where the 
selected backdrop image displays.

• Specify which View Types you would 
like to use the selected backdrop in. By 
default, only Perspective Camera Views 
use a backdrop.

• Specify which Rendering Techniques 
you would like to use the selected back-
drop in. By default only Standard uses a 
backdrop. See “Glass House View” on 
page 320.

Click the color bar to select the 
Background Color that displays when 

a backdrop image is not being used. See 
“Color Chooser Dialog” on page 290. 

Render Quality
Select Edit> Default Settings to open 
the Default Settings dialog. Select 

Render Quality from the list and click the 
Edit button to open the Render Quality 
dialog. 

• Move the slider bar to increase or 
decrease the render quality of 3D views. 
The description below the slider bar 
updates as you move it, indicating the 
effects of the selected quality setting.

This setting controls the quality of cam-
era views, but does not affect 

Final Views  or Final Views with 

Shadows .
• When Synchronize Crosshair with 

Cursor is checked, the mouse pointer 
and crosshair always move together on 
screen. If you feel that they do not keep 
up with your mouse movements, try 
unchecking this option.

• When Use Enhanced Lighting is 
checked, Standard rendered views gener-
ate lighting effects that require a video 
card supporting OpenGL 2.0. Uncheck-
ing this box may speed up Standard ren-
dering times somewhat; however, the 
quality of lighting effects will be reduced. 
Not available if your video card does not 
support OpenGL 2.0. See “OpenGL and 
Hardware” on page 300.
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3D View Tools
Select 3D> Create Camera View to display 
the Camera View Tools.

Camera Views
The Full Camera tool creates multi-
floor views of the 3D model. It can be 

used to create interior and exterior 
perspectives, and is good for displaying 
cathedral ceilings, roofs, lofts, stairwell 
openings, and other variation in floor and 
ceiling levels.

The Glass House Camera tool 
creates full camera view of the 3D 

model using  the Glass House Rendering 
Technique. See “Glass House View” on page 
320.

Overviews
The Full Overview tool creates views 
of the entire model including all 

floors, ceilings, and the roof. 

The Doll House View tool creates 
views of the current floor without a 

roof or ceiling. 

TheFraming Overview tool creates 
views of the framing in the model. See 

“Framing Overview” on page 304. 

Cross Section/Elevation Views
Cross Section/Elevation views are similar 
to the traditional, orthographic views often 
used in drafting. See “Cross Section/
Elevation Views” on page 304.

A Cross Section/Elevation view 
displays all floors of the model except 

floor 0. If the view is created outside the 
structure looking toward it, the result is an 
exterior elevation. If the view is created 
inside the structure, or passes through any of 
the structure, a cross section is created. 

Creating Camera Views

To create a camera view

1. In floor plan view, select the desired 
camera tool. The mouse pointer displays 

the camera   icon. 
2. Click and drag a line to define the view 

direction. 
•  Where your line begins is the camera’s 

position. 

•  The line that you drag defines the 
direction the camera is pointed. 

•  The end of the line is the focal point of 
the view, the point the camera rotates 
around.

•  By default, the field of view is 45°, 
which is similar to what the human eye 
sees or a 50mm camera lens.



Creating Overviews

 303

3. When you release the mouse button, a 
view generates in a new window.

4. Return to the floor plan view. A camera 
symbol now displays in floor plan view. 
See “Swapping Views” on page 294.

Creating Overviews
Overviews generate as soon as you select the 
tool and are always created at the same 
angle. The focal point is always located at 
the center of the model; however, the 
position of the camera will vary depending 
on the size of the 3D model. The larger or 
more spread out the model, the further away 
the camera will be from the focal point so 
that the entire model can be seen in the view. 

Once generated, an overview window’s title 
bar indicates its view type and a camera 
symbol representing the overview displays in 
floor plan view, The overview ‘camera’ can 
be edited much like regular camera views 
can. See “Editing 3D Views” on page 307.

Full Overview
Select 3D> Create Camera View> 
Full Overview to generate an exterior 

view of the entire model.

Doll House View
Select 3D> Create Camera View> 
Doll House View to create a drawing 

of the current floor with the ceiling removed.

Doll House Views are an effective tool for 
illustrating traffic flow and the relationships 
between spaces. They are also helpful for 
trouble-shooting, since they isolate a single 
floor for review. 

FOV Indicators

Camera 
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To see a different floor, select Tools> 

Reference Floors> Up One Floor  or 

Down One Floor . You can also return to 
floor plan view and make another floor 
current before generating the Doll House 
View.

Framing Overview
Select 3D> Create Camera View> 
Framing Overview to create a view 

of the entire model, displaying only framing 
and the foundation. 

Framing overviews include all floor, wall, 
and roof framing as well as foundations.  

Cross Section/Elevation Views
The Cross Section/Elevation tool produces 
the traditional, orthogonal views often used 
in drafting. Regardless of their distance from 
the camera, all lines and dimensions in these 
views are their true lengths, making it easy to 
accurately see the spatial relationships of the 
3D objects in the model.

To create a Cross Section/Elevation view

1. Select the Cross Section/Elevation  
tool. The pointer changes to a  with 

crosshairs marking the position of the 
pointer.

•  Click in floor plan view and drag a line. 
•  A Camera symbol displays where you 

click, along with a Cross Section Line 
indicating the plane of a cross section’s 
cut line.

2. Drag in the direction of the Line of Sight 
to draw a camera arrow.

•  Always drag the camera arrow perpen-
dicular to the wall to be viewed. 
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3. When you release the mouse button, the 
view generates in a new window.

If the Line of Sight does not cut through a 3D 
object, such as a window shown in elevation, 
the object retains its 3D definition. 3D 

objects can be selected, moved, stretched, or 
otherwise modified in a cross section/
elevation view. The 3D model is updated in 
all views.

Displaying 3D Views
The name of the current plan file and the type 
of view displays at the top of each view 
window in its title bar. 

There is no limit to the number of 3D view 
windows that you can have open at a given 
time; bear in mind, though, that each window 
demands use of your computer’s resources 
and that you may see poor performance if too 
many views are open. See “Open View 
Windows” on page 295.

A variety of tools and settings allow you to 
control the appearance of your 3D views. 
There are also numerous ways to adjust the 
position, focal point and field of view of a 
3D view. See “Editing 3D Views” on page 
307.

In Floor Plan View
Active 3D cameras are represented in floor 
plan view using symbols that indicate the 
camera’s position, field of view and focal 
point. 

Active cameras can have labels indicating 
the camera number. Camera labels are 
located on the “Cameras, Labels” layer. The 

Camera 
(click)

Focal 
Point 
(release)

Line of 
Sight 
(drag)

1.

2.

3.

Clip Plane Indicators
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camera labels are numbered sequentially in 
the order they were created.

Camera symbols are an on-screen reference: 
they do not print unless Print Image is used. 

Display Options
Which objects display in a 3D view is 
controlled in the Display Options 

dialog. See “Display Options Dialog” on 
page 49. 

Different view types use different layer sets 
when they are created. See “Layer Sets” on 
page 48.

3D Backdrops
Backdrop images can be used to add realism 
and a sense of perspective to 3D views. You 
can select a backdrop image for a plan file 
from the library in either of two ways: 
• In any view, select 3D> 3D 

Backdrop  to open the 3D Backdrop 
dialog. See “3D Backdrop Dialog” on 
page 300. 

• In a 3D view, open the Library Browser. 
Browse to and select a Backdrop image, 
then move your cursor into the view win-
dow. Click anywhere in the view to apply 
the selected backdrop. 

Regardless of how it is selected, only one 
backdrop can be used in a plan at any given 
time. You can specify which views use the 
selected backdrop in the 3D Backdrop dia-
log.

Textures
Select 3D> Toggle Textures in a 3D 
view to turn off the display of material 

textures. See “About Materials” on page 281. 
Not available in Glass House Views. 

Delete 3D Surface
The individual surface of an object 
can be temporarily removed from any 

3D view by selecting 3D> Delete Surface 
and then clicking on a surface. When the 
pointer is over a surface, that surface will 
become highlighted.

Surfaces removed in one view are removed 
in all 3D views, but are not permanently 
removed from the model. Continue clicking 
surfaces to remove them, then select another 
tool when you are finished.

Surfaces in 3D views are composed of 
multiple triangles. Hold the Alt key while 
clicking to delete one triangular face at a 
time rather than all triangles forming a  
surface. 

Select 3D> Delete Surface  or click the 
toolbar button to restore the most recently 
deleted surface. All surfaces can be restored 
by selecting Build> Floor> Rebuild Walls/
Floors/Ceilings or by exiting the 3D view 
and reopening it.

Lighting
Select 3D> Lighting> Adjust Sun-
light to open the Default Sun Light 

Specification dialog. See “Default Sun Light 
Specification Dialog” on page 320.

Select 3D> Lighting> Toggle Sun-
light  to turn on and off the light 

source that represents the sun. This feature 
can be used to simulate day vs. night exterior 
views. User defined exterior lights are turned 
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off in day views and turned on in night 
views. See “Default Sun Light” on page 319.

Final Views
Select 3D> Final View or Final 
View with Shadows to 

regenerate the 3D view with improved 

quality and/or shadows. See “Preview vs 
Final View” on page 318.

Rebuild 3D
Select 3D> Rebuild 3D to regenerate 
all 3D data asociated with the current 

plan. All open views will remain open.

Editing 3D Views
Once a 3D view is created, there are many 
ways to manipulate the camera location, 
focal point, and line of site to adjust the view 
on-screen.

The camera movement tools provide the 
ability to pivot the camera in any direction, 
move it perpendicular to the line of sight and 
rotate the camera around its focal point.

Cameras can be moved in incremental steps 
using either the toolbar or the keyboard.  

Each time you move the camera, the view is 
updated. If you are using either the toolbar or 
keyboard to move the camera,  you can hold 
down the Shift key, suppressing the redraw 
of the view until the Shift key is released and 
allowing you to move multiple increments 
more quickly. 

In the Specification Dialog
You can  make adjustments to a 
camera in the Camera Specification 

dialog. This dialog is particularly helpful for 
making fine adjustments to the camera’s 
position and other attributes. See “Camera 
Specification Dialog” on page 314.

Using the Contextual Menu
In a 3D view, right-click in an empty space in 
which the backdrop or background color 
displays to access the contextual menu. See 
“Contextual Menus” on page 23. 
• These options are a selection of tools and 

toggles specific to 3D views.

Up One Floor/Down One Floor
You can move a camera to a different floor. 
While the camera view is active, select 
Tools> Reference Floors> Up One 

Floor  or Down One Floor . 

The position and movement of a camera is 
affected by its location within the model. 

Tile a 3D view and the floor plan view
and use the camera movement tools to

see how they affect the camera. See “Tiling
Views” on page 297.
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When the camera is outside a building, its 
height is relative to the terrain and follows 
the terrain as it is moved. When inside a 
building, the camera height is relative to the 
floor of the room it is drawn in.

If the camera is on an upper floor and you 
move the camera outside of the building, the 
camera remains at the same height relative to 
the floor it was created on.

Move Camera with Mouse
A camera’s position can also be edited while 
the view is active. These tools are not 
available in Cross Section/Elevation views.

Select 3D> Move Camera With 
Mouse to access the Move Camera 

with Mouse modes.

Click Mouse-Orbit Camera (or use 
the hot key Alt + O) then move the 

mouse to rotate the camera around the 
current camera focal point. You can also 
click in the 3D view, move the mouse, and 
release the mouse button to “throw” the 
view. Click again in the view to stop the it 
from rotating. 

Click Mouse-Pan Camera (or use the 
hot key Alt + P) then move the mouse 

to move the camera up, down, left and right. 

Click Mouse-Dolly Camera (or use 
the hot key Alt + D) then move the 

mouse to move the camera forward and 
backward by moving the mouse up and 
down. It also allows you to turn the camera 
left and right in the same way. 

Click Mouse-Tilt Camera (or use the 
hot key Alt + T) then move the mouse 

to tilt the camera in any direction while 
staying in the same location. 

3D Center Camera on Point - 
Allows you to focus the camera at a 

particular point in the scene. This also sets 
the camera center so that future use of the 
Mouse-Orbit tool rotates around that 
particular point. To use the 3D Center tool, 
activate the tool and then click any object in 
the scene. 

Move Camera with Arrow Keys
You can use the arrow keys on your keyboard 
to move the camera. The camera direction 
and field of view do not change: only its 
position.

Select 3D> Move Camera with Arrow 
Keys to access these tools. These tools are 
not available in Cross Section/Elevation 
views.

Select 3D> Move Camera with Arrow 
Keys> Arrow-Orbit Camera to rotate the 
camera around the current focal point. Use 
the arrow keys on your keyboard to move the 
camera. 

Select 3D> Move Camera with Arrow 
Keys> Arrow-Pan Camera to move the 
camera up, down, right, and left using the 
arrow keys. 

Select 3D> Move Camera with Arrow 
Keys> Arrow-Dolly Camera to move the 
camera forward and back using the up and 
down arrow keys, and side to side using the 
left and right arrow keys. 

Select 3D> Move Camera with Arrow 
Keys> Arrow-Tilt Camera to use the arrow 
keys to tilt the camera any direction at the 
same location.
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Move Camera Tools
Select 3D> Move Camera to access 
these tools. These tools reposition the 

camera, while keeping the direction of the 
field of view in the same place. These tools 
are not available in Cross Section/Elevation 
views.

Move Camera Forward - Moves the 
camera and the focal point forward. 

You can also use the hot key F.

Move Camera Back - Moves the 
camera and the focal point back. You 

can also use the hot key B.

Move Camera Left - Moves the 
camera and the focal point to the left 

in a line perpendicular to the line of sight. 
You can also use the hot key L.

Move Camera Right - Moves the 
camera and the focal point to the right 

in a line perpendicular to the line of 
sight.You can also use the hot key R.

Move Camera Up - Moves the 
camera and the focal point up.You can 

also use the hot key U.

Move Camera Down - Moves the 
camera and the focal point down. You 

can also use the hot key D.

Orbit Camera Tools
Select 3D> Orbit Camera to access 
these tools. Orbiting the camera 

rotates the camera about the focal point. 
These tools are not available in Cross 
Section/Elevation views.

Move Camera In - Move the position 
of the camera closer to the focal point 

along the line of sight. The camera does not 

rotate past the focal point using this tool. You 
can also use the hot key I.

Move Camera Out - Move the 
position of the camera away from the 

focal point along the line of sight. You can 
also use the hot key O.

Orbit Camera Upward - Rotate the 
camera up about the focal point. The 

camera does not rotate past the vertical line 
going up from the focal point.

Orbit Camera Downward - Rotate 
the camera down about the focal 

point. The camera does not rotate below the 
vertical line going down from the focal point.

Orbit Camera Left - Rotate the 
camera to the left about the focal 

point.

Orbit Camera Right - Rotate the 
camera to the right about the focal 

point.

Tilt Camera Tools
Select 3D> Tilt Camera to access 
these tools. Tilting keeps the camera 

in one place and pivots the camera about its 
vertical or horizontal axis. This movement is 
similar to tilting your head up and down or 
turning it side-to-side. These tools are not 
available in Cross Section/Elevation views.

Tilt Camera Upward - Tilts the 
camera up while keeping it in the 

same location. The camera does not tilt 
beyond the vertical position.

Tilt Camera Downward - Tilts the 
camera down while keeping it in the 

same location. The camera does not tilt 
beyond the vertical position.
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Turn Camera Left - Turns the 
camera to the left while staying in the 

same location.

Turn Camera Right - Turns the 
camera to the right while staying in 

the same location.

Keyboard Camera Movements
Camera movement in 3D views can be 
controlled using the keyboard. These hotkeys 
are not available in Cross Section/Elevation 
views.

F - Move forward.

B - Move backward.

U - Move up.

D - Move down.

L - Move left.

R - Move right.

I - Move inward along the line of sight. 

O - Move outward along the line of sight. 

W - Increase camera Field of View.

N - Decrease camera Field of View.

Left or Right Arrow - The program 
remembers the mode you selected under 3D> 
Move Camera with Arrow Keys. If you are 
in a view that does not support the mode you 
selected, the arrow keys move the screen 
right or left. 

Up or Down Arrow - The program 
remembers the mode you selected under 3D> 
Move Camera with Arrow Keys. If you are 
in a view that does not support the mode you 
selected, the arrow keys move the screen up 
or down.

Zooming
The Zoom Tools are available in all 
3D views. See “Zoom Tools” on page 

292. 

Selecting Window> Zoom In , Zoom 

Out  or Fill Window  does not change 
the camera’s location or field of view. 
Instead, the extents of the view are expanded 
or cropped. 

Field of View
The Field of View refers to a camera’s field 
of vision. A wider field of view makes the 
focal point appear further away, as more of 
the image is included in the same view 
window. 

In floor plan view, the angled lines of a 
camera symbol indicate its field of view.

A camera’s field of view can be adjusted in 
the Camera Specification dialog. See 
“Camera Specification Dialog” on page 314.

The field of view can also be adjusted while 
in a camera view by pressing the W key to 
increase the field of view or the N key to 
decrease the field of view.

FOV Indicators
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Using the Edit Handles
Return to floor plan view without closing the 
3D view. See “Swapping Views” on page 
294.

Using the Select Objects  tool, select the 
camera object. When a camera symbol is 
selected it displays four edit handles.

• Drag the Line of Sight handle to change 
the camera angle without moving the 
focal point.

• Drag the Move handle to relocate the 
camera while maintaining its relative 
angle.

• Drag the Focal Point handle to reposition 
the camera, the focal point, and line of 
sight.

• Drag the Rotate handle to rotate the cam-
era’s line of sight about its center.

• Drag the smaller Move Label handle to 
move the label.

The 3D view corresponding to the camera 
symbol reflects changes made to the symbol 
in floor plan view.

Multiple camera symbols can also be 
selected; however, their editing options are 
limited to being moved, rotated, and deleted. 

Cross Section Slider
Select 3D> Cross Section Slider 
when a camera view or overview is 

active to open the Cross Section Slider 
dialog. 

Choose one of the cross section angles and 
move the Position slider to adjust the 
position of the cutting plane. Select the 
option at top right to turn off the cutting 
plane.

Rotate

Focal Point

Move

Line of Sight

Move



312

Home Designer Essentials 2012 Reference Manual

Working in 3D 
A variety of tools are available in 3D views 
that allow you to edit your 3D model.

Creating Objects in 3D Views
You can place windows, doors, and most 
library objects directly into 3D views. To do 
this, select the appropriate tool and click in 
the 3D view. You can then edit the object’s 
size and placement. 

When created in 3D, most objects must be 
placed against a wall, on a floor platform, or 
within the Terrain Perimeter.  

You can also click and drag to draw some 
objects such as terrain features and road, in 
camera views and overviews views. 

Selecting and Editing 
Objects in 3D Views

Most objects can be selected and edited in 

3D views. Select Edit> Select Objects  
and click on the surface of an object to select 
it. Once selected, objects can be edited using 
their edit handles, buttons on the edit toolbar, 
and the object’s specification dialog. See 
“Editing Objects” on page 59.

When you select an object, edit handles and a 
handle surface display. The handle surface is 
a rectangle around the perimeter of the object 
that indicates the overall height and width of 
the selected surface. The edit handles that 
display depend on the type of object selected. 
Walls, for example, display two resize edit 
handles when selected while a slab displays 
ten handles, allowing you to move, resize 
and reshape it.
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All moving or resizing is in the plane of the 
handle surface. You cannot  move an object 
directly towards or away from the camera, 
for example, because that surface plane 
cannot be seen in the view. 

By default, object movement is restricted to 
one inch or 10 mm increments. See “Grid 
Snaps” on page 53.

Unrestricted positioning can also be enabled 
by holding down the Ctrl key while moving 
or resizing an object. See “Unrestricted 
Movement” on page 78. 

When Fixtures and Furniture May Be 
Resized is unchecked in the Plan Defaults 
dialog, only a single handle displays for 
furniture and stand-alone fixtures and 
appliances. In this case, the object can only 
be moved. See “General Plan Defaults 
Dialog” on page 43. 

Temporary dimension lines display when 
many objects are selected to help you resize 
the object and determine its height.

Because cross section/elevation views are 
orthogonal and display objects at their actual 
dimensions, they are sometimes more 
suitable for editing objects than camera 

views or overviews. See “Cross Section/
Elevation Views” on page 304.

When several 3D views are open, changes 
made in the plan automatically rebuild the 
model in all views.  Because of this, it is 
typically faster to make changes to your plan 
with as few windows open as possible.

Editing Materials in 3D Views
Select 3D> Materials> Adjust 
Material Definition, then click on a 

surface in the 3D view to open the Define 
Material dialog for that material. See “Adjust 
Material Definition” on page 286.

Select 3D> Materials> Material 
Painter to apply materials to surfaces 

in the view using the Material Painter Tools. 
See “The Material Painter” on page 282.

Select 3D> Materials> Material 
Eyedropper to apply the material on 

a surface in the view to other surfaces in the 
view. See “Material Eyedropper” on page 
284. 

Rebuild 3D
As changes are made to your plan, a 
3D view automatically updates to 

reflect any changes visible in the view. If you 
find that a view is not updating as expected, 
select 3D> Rebuild 3D to rebuild the entire 
3D model.

Printing 3D Views
3D camera views and overviews can be 
exported and saved outside of Home 
Designer Essentials, as well as printed. 

Exporting 3D Views
All 3D views can be exported and 
saved as .bmp, .jpg, .png, or .tif files. 

Note: If the wall height of the Exterior Room
is adjusted in a 3D view, the default Floor or
Ceiling Height of the entire floor is changed.
See “Floor and Room Defaults” on page 110.
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Select File> Export> Picture to save the 
current screen image as an image file. See 
“To export a picture” on page 356.

Once saved, a picture can be opened and 
converted into many other formats using a 
graphics program.

When a picture is exported, it is assigned the 
same size as it displays on screen. You can 
change the size of the view window to create 
a smaller or bigger picture.

Printing 3D Views
Since 3D views are created using 
pixels instead of lines, File> Print> 

Print Image must be used when printing. 
Print Image is a special Home Designer 
Essentials function that prints the screen in 
picture format. The entire view prints, 
including images such as plants and textures. 

The quality of your print image is affected by 
your current window size and screen 
resolution. To maximize the quality of your 
printed image, generate it in full screen size 
and use the maximum screen resolution.

Camera Specification Dialog
The Camera Specification dialog can 
be accessed in floor plan view by 

selecting a camera symbol and clicking the 
Open Object edit button. See “In Floor Plan 
View” on page 305.

This dialog can also be accessed while a 
camera view or overview is active by 

selecting 3D> Edit Active Camera . 

The selected view’s specific type is indicated 
in the dialog’s title bar: the specification 

dialog for a Full Camera , for example, 
is named Full Camera Specification.

Some settings only affect some types of 
views. Depending on the type of camera 
view selected, not all the settings may be 
editable. 

To change a setting, first uncheck Default, 
then type a new value in the text field.
• The Incremental Move Distance con-

trols how many inches the camera moves 
each time you direct it to move right, left, 
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forwards or backwards. For interior 
views a small number is good, but for 
exterior you may want a larger increment.

• The Incremental Rotate Angle defines 
how many degrees the camera rotates 
each time you direct it to. A setting of 90° 
would make one full rotation in four 
moves.

• The Height Above Floor defines the 
height that the camera is above the floor 
level for the current floor.

• The Field of View defines the camera’s 
field of vision in angular degrees. See 
“Field of View” on page 310.

• The Tilt Angle determines the angle the 
camera is tilted. The camera maintains its 
focal point and position in floor plan 
view, but if the camera is tilted, the focal 
point is above or below the current cam-
era height. 

You can increase a camera’s Field of
View when the view is active by press-

ing the W key, or decrease the Field of View
by pressing the N key. 



316

Home Designer Essentials 2012 Reference Manual



 317

Chapter 26:

3D Rendering

There are a variety of tools available to 
create 3D views of a model: simply click a 
button to create an overview, or click and 
drag to create a camera or cross section/
elevation view. See “3D Views” on page 299.

To improve the quality of the rendering and 
create a custom look, you can adjust lighting, 
edit the materials used in the plan, choose 
from several rendering techniques and fine-
tune 3D view quality settings. From most 3D 

views, you can create Final views of even 
higher quality.

Chapter Contents
•      Rendering Tips
•      Lighting
•      Displaying Lights
•      Default Sun Light Specification Dialog
•      Glass House View
•      Speeding up 3D View Generation

Rendering Tips
There are a variety of factors which affect the 
appearance and quality of rendered 3D 
views. You can use these tools and settings to 
achieve renderings that meet your needs. 

Lighting
Lighting is extremely important in most 3D 
renderings. Lighting controls the visibility of 
objects in a view, affects the appearance of 
surfaces, and influences the appearances of 
colors and textures on those surfaces. Even 

small changes to light intensity, direction and 
color can have a large impact on image 
quality. See “Lighting” on page 318.

Material Textures
Textures are graphic files that represent 
irregular surfaces of objects such as carpet, 
bricks, tile, and wood in 3D views. Textures 
are assigned to materials which in turn are 
assigned to objects. See “Textures” on page 
282. 



318

Home Designer Essentials 2012 Reference Manual

The display of materials in 3D views is 
controlled by settings in the Define Material 
dialog. See “Define Material Dialog” on 
page 287.

Brightness, shininess and transparency 
control how light sources affect the display 
of surfaces in 3D views. See “Lighting” on 
page 318.

If no texture is selected for a material or if 
the display of textures is turned off, affected 
surfaces are a solid color instead.

Images
Images are very important for the appearance 
of 3D views. Images are picture files that 
represent individual objects such as trees, 
flowers, cars,  and people. See “Placing 
Images” on page 352.

Backdrops
Backdrops are images that display in the 
background of 3D views. Only one backdrop 
can be used at a time. If a backdrop is not 
applied, Home Designer Essentials applies a 
background color. 

Backdrops and background colors are 
selected in the 3D Backdrop dialog. See “3D 
Backdrop Dialog” on page 300.

You can drag and drop a backdrop directly 
into a 3D view from the Library Browser. 
Select a backdrop from the upper pane of the 
Library Browser, notice that the pointer 

changes in the 3D view ( ) to indicate that 
a backdrop is loaded for placement, and then 
click in the view to apply the selected 
backdrop. 

Preview vs Final View

When a rendered 3D view is first created, it 
uses quality settings that allow the view to 
generate quickly but with reasonable quality.

Final Views produce much higher quality 
images that are more suitable for printing or 
saving as graphics files. Final Views often 
take significantly longer to generate than 
Previews, so the 3D view reverts back to the 
Preview settings as soon as anything is 
changed within the view.

When you have finished making adjustments 

in the 3D view, select 3D> Final View  or 

Final View with Shadows . 

Lighting
In 3D views, lighting is calculated on a 
room-by-room basis; only the light sources 
in the room containing the camera are used. 

When the camera is outside a building, the 
program normally uses sunlight for lighting 
calculations and turns off all other light 
sources. You can turn the sunlight off and use 

all the other exterior lights to simulate night 
time views.

The maximum number of light sources that 
can be turned on in a view at the same time is 
determined by your video card. If your video 
card’s maximum number of lights is eight, 
the program only uses the eight light sources 
closest to the camera’s position. 
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There are three ways to create light sources 
for 3Dviews:
• Default Lights
• Light Fixtures
• Sunlight

Default Lights
If you create an interior 3D view of a room 
and no lights have been placed there, the 
program creates a Default Light source 
within that room. The Default interior light 
acts like a central point light source. 

The Default Light cannot be adjusted in any 
way. If you want to control the light in an 
interior 3D view, you must add a light to the 
room that you are rendering by placing a 
lighting fixture. 

Light Fixtures
An electric symbol that represents a Light 
Fixture has a light source associated with it. 
When a light is placed in a room, it will be 
used as a light source in 3D views instead of 
the Default Light. In large rooms, more than 
one light fixture may be needed for sufficient 
light.

Default Sun Light
If you create an exterior 3D view, the 
program creates a Default Sun light source. 

The Default Sun can be opened for 
specification in a 3D view by selecting 3D> 

Lighting> Adjust Sunlight . See 
“Default Sun Light Specification Dialog” on 
page 320.

Select 3D> Lighting> Toggle Sunlight  
turn the Default Sun on or off to simulate 
either daytime or nighttime exterior lighting.

Displaying Lights
The display of light fixtures in floor 
plan and 3D views is controlled in the 

Display Options dialog. See “Display 
Options Dialog” on page 49.

In addition, they can serve as sources of light 
in rendered 3D views. They can be turned on 
and off, as well.

Light fixtures are placed on the “Electrical” 
layer. See “Displaying Objects” on page 48. 

In floor plan view, light fixtures can display 
labels when the “Electrical, Labels”layer is 
turned on. 

To turn a light on or off

There are several ways to turn a light 
fixtureon or off: 
• Select one or more fixtures and click the 

Turn Light(s) Off in 3D  or Turn 

Light(s) On in 3D  edit button. 



320

Home Designer Essentials 2012 Reference Manual

Default Sun Light Specification Dialog
The Default Sun Light Specification dialog 
allows you to control the intensity, direction 
and color of the Default Sun light source. 

While in a 3D view, select 3D> Lighting> 

Adjust Sunlight . See “Default Sun 
Light” on page 319.

• Intensity - Use the slider bar or text field 
to control how bright the default sun light 
appears in 3D views. 

An intensity of 0% is the same as turning 

the sun light off. An intensity of 100% is 
the maximum brightness allowed. 

• Click the Color bar to define the color of 
the light being modeled. Colored sun 
light may be used to achieve special 
lighting effects, but may alter the appear-
ance of your material colors and textures. 

• Specify the Tilt Angle, which is the angle 
of the sun light with respect to the hori-
zon. A value of 90° means that the light 
points straight up, while a value of -90° 
means that the light points straight down. 
0° is parallel to the horizon.

• Specify the Direction Angle, which is 
the direction that the sun light points 
toward. Zero degrees is measured hori-
zontally on screen, pointing to the right. 
Positive values rotate in a counter-clock-
wise direction from there, while negative 
values rotate clockwise. 

The Default Sun light color is pure white, 
which has the least effect on the material 
colors and textures.

Glass House View
Glass House View can be used to 
display the 3D model using semi-

transparent surfaces. Different shades of blue 
are used to represent surfaces and surface 
edge lines. Lighting is not modeled, and 
materials are not represented, so neither 
pattern lines nor textures are used.

Glass House View is an excellent way to 
illustrate the spatial relationships between 
different areas in the plan. 

You can display a current camera view or 
overview as a Glass House View by selecting 
3D> Rendering Techniques> Glass 

House . To switch back, select 3D> 

Rendering Techniques> Standard .

Glass House Options
You can modify the appearance of 
Glass House Views by selecting 3D> 
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Rendering Techniques> Glass House 
Options. 

• Click the Color bar to select a color for 
the semi-transparent surfaces and lines in 
a Glass House view. See “Color Chooser 
Dialog” on page 290. 

• Specify the Transparency of the surfaces 
in Glass House view. For example, to cre-
ate a wireframe line drawing of your 
structure, turn transparency to full and 
minimize line thickness.

• Specify the Line Thickness of surface 
lines in Glass House view. 

• Click Reset to Defaults to restore the 
default settings used when the Glass 
House view was first created. 

Speeding up 3D View Generation
Depending on the speed of your processor, 
how many cores your processor has, and 
your computer’s video memory, a 3D view 
may generate in a few seconds or less. 

When you have a large, complex model with 
a lot of detail, it may take a few minutes to 
generate a 3D view of everything in the 
model. During this process, progress 
information may display in the Status Bar 
and in a message window. 

There are several ways to speed up the 
generation time of views.

Turn Off Layers
The display of objects in 3D views 
can be turned on or off by layer in the 

Display Options dialog. Turning off the 

display of unneeded objects in 3D views can 
speed up 3D view generation time. See 
“Display Options Dialog” on page 49. 

Halt Generation with Esc Key
Using the Esc key, you can interrupt the 
modeling process at any point and display 
the incomplete model “as is.” This is 
particularly helpful when you just need to 
reorient a model on the screen for a specific 
angle or view.

The Esc option allows you to place the view 
quickly, then press the F5 function key to 
refresh the display with all 3D faces intact. 
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Chapter 27:

Dimensions

Home Designer Essentials provides a variety 
of dimensioning tools for measuring walls, 
doors, windows, and many other objects. 

Dimensions can be used to accurately 
position objects relative to other objects. In 
addition, dimension lines and extensions can 
be selected and customized. 

Chapter Contents
•      Dimension Unit Defaults
•      Dimension Defaults Dialog
•      The Dimension Tools
•      Displaying Dimension Lines
•      Editing Dimension Lines
•      Editing Extension Lines
•      Moving Objects Using Dimensions
•      Dimension Line Specification Dialog

Dimension Unit Defaults
All plan files save measurements in either 
Imperial or metric units. The type of unit 
used is determined when the file is first 

created and cannot be changed later. See 
“Creating a New Plan” on page 31.

Dimension Defaults Dialog
In floor plan view or a cross section/
elevation view, select Edit> Default 

Settings, select “Dimension”, and click the 
Edit button to access the Dimension 
Defaults dialog. 

The settings in this dialog are dynamic 
defaults, which means that any changes 
made here may affect existing dimension 
lines in the drawing that are using default 
values. See “Dynamic Defaults” on page 42. 
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Setup Tab

Specify how Manual and Auto Exterior 
Dimension lines locate both interior 

and exterior walls. 
• Select Surfaces to have dimensions 

locate the outer surfaces of walls. 

• Select Main Wall Layer to have dimen-
sions locate the structural layer of exte-
rior walls.

Specify how Manual and Auto Exterior 
Dimension lines locate interior walls.

• Select Centers to have exterior dimen-
sions locate the centers of interior walls. 

• Select Both Wall Sides to have dimen-
sions locate both sides of interior walls. 
Either the wall Surfaces or both sides of 
the Main Wall Layers will be located, 
depending on your selection above. 

You can always change the object or surface 
that a dimension locates after it has been cre-
ated. See “Editing Extension Lines” on page 
330.

1

2

1

Dimensions locating wall Surfaces

Dimensions locating walls’ Main Wall Layers

2

Dimensions locating an intersecting wall’s center

Dimensions locating an interior wall’s 
                  Main Wall Layer
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Format Tab
The settings on the Format tab allow you to 
specify the units, degree of accuracy and 
position of dimension numbers. 

The settings on this tab also control the 
format of numbers indicating object length in 

the Status Bar. See “The Status Bar” on page 
24. 

Specify the numbering Format for 
dimension numbers. 

• Select the Units of measurement to be 
used by dimensions from the drop-down 
list.

• Check Unit Indicators to display the unit 
of measurement along with the dimen-
sion number.

• Check Leading Zeros to include the zero 
before a decimal less than 1 or to display  
0’ or 0” when the ft-in or ’-” unit formats 
are used. 

• Check Trailing Zeros to display trailing 
zeros at the end of decimal values. 

Specify the Location of dimension 
numbers relative to the dimension line. 

• Center primary dimension numbers on 
the dimension line. If two formats are 
used, the primary format is placed above 
the line and the secondary format, 
beneath it. 

• Position dimension numbers Above 
Line. 

• Position dimension numbers Below Line. 

Specify the degree of Accuracy used 
by dimension numbers. 

• Select the Decimal Places radio button 
for dimension numbers in decimal for-

1

2

3

1 2

3
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mat.  In the text field, specify the number 
of decimal places to use, from 0 to 20. If 
0 is used, no decimal places are used.

• Select the Smallest Fraction radio but-
ton for dimension numbers using whole 
numbers and fractions.  In the text field, 
specify the largest denominator to use, 
from 1 to 128. If 1 is entered, whole num-
bers are used. 

Arrow Tab
For information about the Arrow tab, see 
“Arrow Tab” on page 345.

Text StyleTab
The settings on the Text Style tab control the 
size, font and other attributes of automatic, 
manually drawn, and temporary dimension 
line labels. See “Dimension Labels” on page 
328. 

For information about the settings on this 
tab, see “Text Style Tab” on page 340.

Temporary dimension labels always use the 
color assigned to their layer - not the color 
specified in the Dimension Defaults dialog. 

The Dimension Tools
Select CAD>Dimension to access the 
Dimension Tools. Dimensions are 

drawn by clicking and dragging like other 
line-based objects and can be drawn in floor 
plan view. 

The zoom factor of the current view affects 
whether objects drawn close together are 
dimensioned or not. If you try to dimension 
an array of objects but the dimension line 
locates only the first and last objects along its 

path, Zoom  in on the objects and try 
again. Similarly, if you want to dimension 
between two objects but the dimension 
locates unwanted objects between them, 

Zoom  out. See “Zoom Tools” on page 
292.

Once created, both manually drawn and 
automatically generated dimension lines can 
be selected and edited.  See “Editing 
Dimension Lines” on page 328. 

Manual Dimensions
To display the distance between two 
objects, select CAD>Dimension> 

Manual Dimension and drag a dimension 
line near or through the objects. 

Manual Dimensions locate walls as specified 
in the Dimension Defaults dialog. See 
“Dimension Defaults Dialog” on page 323.

End-to-End Dimensions
Use the End-to-End Dimension tool 
to dimension between any two defined 

objects in floor plan view. 

Select CAD> Dimension> End-to-End 

Dimension , then drag the dimension 
from the first object to the second object. The 
dimension line snaps to each object, ignoring 
any other objects located between either end.
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Auto Exterior Dimensions
The Auto Exterior Dimension tool 
generates dimensions around a plan’s 

exterior in floor plan view. 

Auto Exterior Dimension  locate walls 
as specified in theDimension Defaults 
dialog. See “Dimension Defaults Dialog” on 
page 323.

If you edit an Auto Exterior Dimension   
line, it will be converted to a manual 
dimension, so if Auto Exterior Dimensions 
are later regenerated, your changes will not 
be lost. 

There are a maximum of three rows of 
automatically generated dimensions per 
exterior wall direction. The innermost 
dimension line locates exterior walls, interior 
walls, and all openings in exterior walls. The 
second dimension line locates exterior and 
interior walls. The outermost dimension line 
is the overall exterior dimension.

Temporary Dimensions
Temporary Dimensions display when an 
object is selected and show the distance 

between the object’s selected edge and other 
objects. 

As with other dimension lines, Temporary 
Dimensions only locate objects that are 
parallel or nearly parallel to one another. 
They will also locate the endpoints of the 
corners of objects located past the end of the 
selected edge, within 4 feet (1200 mm) of the 
point where you click to select the object.

A temporary dimension will not display 
when an object is selected if a manually 
drawn dimension line is already present that 
shows the same information. 

Tape Measure
Use the Tape Measure tool to draw a 
temporary dimension line between 

any two points in the drawing area. The tool 
will place temporary markers at the start and 
end points of the dimension line. These 
points and the line both disappear when you 
release the mouse button. If an object is 
located by the temporary line, you can snap 
to it.

The Tape Measure  tool can be used in 
cross section/elevation views as well as in 
floor plan view. See “Cross Section/
Elevation Views” on page 304. 

Displaying Dimension Lines
The display of dimension lines is controlled 
in the Display Options dialog. See 
“Displaying Objects” on page 48. 

Dimension lines created by any of the 
dimension tools share the same components.

Auto Exterior Dimensions do not gener-
ate properly if there is a gap in the exte-

rior walls. For example, sometimes angled
walls may not connect properly. 
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• Dimension Lines run parallel with the 
distance being measured.

• Extension Lines are perpendicular to 
dimension lines, indicating what they 
locate. If a dimension line locates more 
than two objects, extension lines divide 
the dimension line into segments. 

• Arrowheads display at the intersections 
of dimension and extension lines.

• Dimension Labels display at the mid-
point of dimension line segments and 
indicate the distance that each segment 
measures.

If a manual dimension line is on a layer that 
is turned off and you select an object located 
by that dimension line, it will display for 
reference in grey.

Dimension Labels
Manually drawn, automatic and temporary 
dimension labels use the Text Style specified 
in the Dimension Defaults dialog. 

Dimension Arrowheads
You can specify the style, color and size of  
dimension arrows in the Manual Dimension 
Defaults and Dimension Line Specification 
dialogs. See . 

The arrow at the end of a dimension line will 
not display if it is close enough to to another 
dimension arrow that the two will overlap. A 
typical example of this is where two sections 
of a dimension locate two sides of an interior 
wall. 

Editing Dimension Lines
With the exception of Temporary 
Dimensions, dimension lines can be selected 
and edited using the mouse and the edit 
toolbar buttons.

If an Auto Exterior Dimension line is edited, 
it will no longer be considered an automatic 
dimension line and will not be deleted and 
replaced the next time the Auto Exterior 

Dimensions   tool is used.

Dimension line numbers and extension lines 
can be individually selected, moved and 

deleted, and new extension lines can be 
added. See “Editing Extension Lines” on 
page 330.

Using the Mouse
When a dimension line is selected, its edit 
handles can be seen. There are four types of 
dimension line edit handles. More than one 
of some types display, depending on how 
many extension lines are present.

Dimension 
Labels

Extension Lines

Arrowheads
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• The Extension Line handles mark the 
location being dimensioned and are used 
to move or delete extension lines. See 
“Moving Extension Lines” on page 330.

• The Add Extension Line handle displays 
to the side of the Move handle and is used 
to add extension lines to the dimension 
line. Dimension lines do not extend 
unless an object can be located. See 
“Adding Extension Lines” on page 330.

• The small, square Move Dimension 
Label handle is located at the center of 
the selected label. Use this handle to 
move the dimension number for each 
dimension line section. The pointer 
changes to a  four-headed arrow  when 
moved over this handle.

• The Move handle is located where you 
clicked to select the dimension line and is 
used to move the entire dimension line, 
including any subsections, perpendicular 
to itself. Extension lines are resized as 
appropriate. The pointer changes to a 
two-headed arrow  when moved over 
this handle.

• The Rotate handle is located one plan 
foot past the end of the dimension line 
and is used to rotate the dimension line. 

Using the Edit Tools
Dimension lines can be repositioned, copied, 
and deleted using the edit toolbar buttons just 
like other objects in the program can. See 
“The Edit Toolbar” on page 22. 

Dimension Number Size
The initial size of dimension numbers is 
specified in the Dimension Defaults dialog. 
See “Dimension Defaults Dialog” on page 
323. 

You can specify number height for individual 
dimension lines in the Dimension Line 
Specification dialog. See “Dimension Tab” 
on page 333.

As with text and other objects, dimension 
number size is subject to scaling when or 
printed.  

Copying and Pasting 
Dimension Lines

Dimension lines can be copied and pasted 
into any view type that supports dimensions. 
If a dimension line is copied independent of 
the objects it originally locates, the pasted 
dimension line will locate point markers.

Deleting Dimension Lines
There are several ways to delete dimension 
lines. 

You can select any manual or automatic 
dimension line or group of dimension lines, 
then press the Delete key or click the 

Rotate

Extension Line

Extension Line

Move

Add Extension 
Line
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Delete  edit button to delete it. See 
“Deleting Objects” on page 82.

The Delete Objects dialog allows you to 
delete all dimension lines at once. See 
“Delete Objects Dialog” on page 82.

Individual dimension line segments located 
between extension lines can also be deleted. 
If a segment is located between two other 
segments along the same dimension line, that 
dimension will be broken in two.

To delete a portion of a dimension line

1. Select any Dimension Tool aside from 
Auto Exterior Dimensions.

2. Click and drag a manual dimension line 
over the segment that you wish to 
remove, dragging from extension line to 
extension line.

Editing Extension Lines
Extension lines can be added, edited, and 
deleted using the mouse. 

Adding Extension Lines

To add an extension line

1. Select the dimension line.
2. Click the diamond-shaped Add Exten-

sion Line edit handle which displays 
near the Move edit handle. The pointer 
changes to a two-headed arrow .

3. Drag the handle to the object that you 
want to locate with a new extension han-
dle. This example adds an extension line 
to the window edge. 

4. Release the mouse button to add an 
extension line.

Moving Extension Lines
Extension lines can be moved to locate the 
centers, sides, or surfaces of most objects. In 
this example an extension line is moved from 
the windows edge to the center.

To move an extension line

1. Select the dimension line it is connected 
to, not the extension line itself.

2. Click the Extension Line edit handle. 
The pointer changes to a two-headed 
arrow .
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3. Drag the handle to a new location. The 
extension line snaps to possible marks as 
the handle is moved.

4. Release the mouse button at the new 
location.

Deleting Extension Lines
When an extension line is deleted, the 
remaining dimensions update. If a dimension 
line hasonly two extension lines, they cannot 
be deleted.

To remove an extension line

1. Select the dimension line it is connected 
to, not the extension line itself.

2. Click the Extension Line edit handle. 

3. Drag it perpendicular to the direction of 
the arrows, away from any dimension-
able object, and release the button when 
the extension line disappears.

Moving Objects Using Dimensions
Most objects can be moved by changing an 
automatic, manual or temporary dimension 
value that locates it. This technique can be 
applied in nearly any situation where 
dimensions are present. See “Moving 
Objects” on page 77.

In addition, some objects can be resized 
using dimensions. See “Resizing Objects” on 
page 80.

Your pointer indicates which dimensions can 
be used to relocate the selected object by 
changing to a pointing hand icon. 

Another way to tell is to select an object and 
drag it in the desired direction. As you drag, 

Not all library symbols can be located
by a dimension line as it is drawn. Once

a dimension is drawn, however, you can
move or add an extension line to locate the
library object.
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note which dimensions update. These 
dimensions are the dimensions that can be 
used to move that object. 

To move an object using dimensions

1. Select the object and click on a dimen-
sion line that locates it. An inline text 
field opens at the location where you 
clicked. 

•  The actual distance displays in the text 
field. 

•  If the dimension is locating two differ-
ent objects, the Move Edge and Move 
Entire Object buttons display to the 
right of the text field. 

•  If the dimension describes a selected 
wall’s length, the Move Start, Move 
End and Move Both Ends buttons dis-
play to the right instead. 

2. Click the Move button of your choice. 
3. Enter a new value in text field. 

•  To use a different unit, include its indi-
cator after the value.To move the 

selected object past a second object, to 
its opposite side, enter a negative 
value. 

4. The selected object moves or resizes 
when you press the Enter key or click 
outside of the text field. 

To resize an object using dimensions

1. Select the object along the edge that you 
would like to move. See “Selected 
Edge” on page 60.

2. Click on a dimension line that indicates 
its distance from the object’s opposite 
side. 

3. In the inline text field, enter a value. 
4. Click Move edge to move the selected 

edge only. 
5. The selected edge moves, resizing the 

object, when you press the Enter key. 

Resizing a House Using 
Exterior Dimensions

When resizing a house using dimensions, it 
is important to work your way around the 
house in one direction. Relocate one wall at a 
time in succession so that you do not redefine 
the same dimension more than once. 

For more information, see “Adjusting Wall 
Positions” on page 31 of the User’s Guide. 

Move Entire Object

Move Edge (selected)

Move Both Ends

Move Start       Move End

You can cancel a move or resize opera-
tion using dimensions at any time by
pressing the Esc key.
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Dimension Line Specification Dialog
To open the Dimension Line 
Specification dialog, double-click a 

dimension line using the Select Objects  

or Manual Dimension  tool, or select a 

dimension line and click the Open Object 
edit button.

The settings in this dialog are dynamic 
defaults. See “Dimension Defaults Dialog” 
on page 323. 

Dimension Tab

Specify the Number Height for the selected 
dimension. Type “d” in the box to reset the 
number size to the default.

Arrow Tab
For information about the settings on this 
tab, see “Arrow Tab” on page 345.
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Chapter 28:

Text

Text is an ideal way to draw attention to 
special details in plans. Text can be added in 
floor plan and cross section/elevation view.

Text lines with arrow can be attached to text 
objects, allowing you to direct attention to 
specific plan details.

Chapter Contents
•      Fonts and Alphabets
•      The Text Tools
•      Creating Text
•      Displaying Text
•      Rich Text Specification Dialog
•      Text Specification Dialog
•      Editing Text
•      Copying & Pasting Text
•      Text Arrows
•      Line/Polyline Specification Dialog

Fonts and Alphabets
Home Designer Essentials allows you to use 
any font found in your Windows Fonts 
directory. 

International Alphabets

The Rich Text  tool supports unicode 
alphabets and characters. In order to use a 
unicode alphabet or characters, the 
appropriate language support must be 
installed on your computer. 

Special characters can be added to any Rich 

Text  object by: 
• Copying and pasting the character from 

another application;
• Copying and pasting the character from 

the Windows Character Map;
• Typing the keystroke associated with the 

character.

See “Copying & Pasting Text” on page 342.
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The Text Tools
Select CAD> Text to display the Text 
Tools. Text objects can be created in 

floor plan view and cross/section elevation 
views.

The Rich Text tool is used to create 
text objects.

The Text Line with Arrow tool is 
used to connect text and another 

object with an arrow. See “Text Arrows” on 
page 343.

Text with Arrow tool places a Rich 
Text object with an arrow attached.

Creating Text
Text can be created in floor plan view and . 

Once created, text can be selected and edited 
in a variety of ways. See “Editing Text” on 
page 341. 

To create Rich Text

1. Select CAD> Text> Rich Text . 
2. Type or paste the desired text into the 

Text Field.

3. Use the options  to change the font, style 
and size of any portion of the text. 

You can also create lines with arrows 
connecting the text that you create to items in 
the drawing. See “Text Arrows” on page 343. 

Displaying Text
The Text Tools can be used in floor plan 
view. The display of text objects in these 
views is controlled in the Display Options 
dialog.  See “Display Options Dialog” on 
page 49. 

All Text objects, including Text Lines with 
Arrows, are located on the “Text” layer. 

The display attributes of each individual text 
object can be controlled independent of the 
layer it is placed on. See “Rich Text Specifi-
cation Dialog” on page 336. 

Rich Text Specification Dialog
The Rich Text Specification dialog 

opens if you select the Rich Text  
tool and then click once in the drawing area.

You can also open this dialog by selecting a 

Rich Text  object, then clicking the Open 
Object edit button. 

Note: If you do not type anything in the Text
Field, a text object will not be created when
you click outside of it.
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Text Tab
The settings on the Text tab allow you to type 
the selected Rich Text object’s content and 
control many aspects of its appearance, 
including its font, size, color and style.

You can specify the appearance of the text 
before typing, and can also select and change 

the attributes of all or portions of the text 
content after it is typed. To change text that 
already exists, simply highlight it using the 
mouse and/or the Shift + arrow keys and then 
make any needed changes to its attributes. 

Use the options on the Edit Bar, which 
displays above the Text Entry field, to 

change the font, style and size of the text.

Select the desired options before typing to 
affect the text as it is typed, or select some or 
all of the text and then specify which options 
to apply to it.
• Specify the text size in drawing units. 

When imperial Inches or Feet and Inches 
are used, accuracy to 1/128” is possible.

• Select a font from the drop-down list.
• Click the Color button to specify the 

color of the selected or subsequently 

typed text. See “Color Chooser Dialog” 
on page 290. 

• Click the Bold button to specify the 
selected or subsequently typed  text as 
bold.

• Click the Italic button to specify the 
selected or subsequently typed text as 
italic.

• Click the Underline button to specify the 
selected or subsequently typed text as 
underlined.

• Click the Strikethrough button to 
selected or specify the subsequently 
typed text as stricken-through.

1

2

1
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• Click the Align Left, Align Center or 
Align Right button to specify the how 
the selected or subsequently typed text is 
aligned.

• Click the Paragraph Options button to 
specify the selected paragraph’s align-
ment, spacing and bullets or numbering 
in the Paragraph Options dialog. 

• Specify the Zoom factor of the selected 
text by typing a percentage value in the 
text field or clicking the up/down arrows. 
This setting only affects the text as it 
appears in this dialog.

Type or paste text in the Text Entry 
field. See “Copy, Cut and Paste” on 

page 342.

Right-click in the Text Entry field to access a 
contextual menu from which you can select 
Cut, Copy, Paste and Select All. See 
“Contextual Menus” on page 23. 

To edit text in the entry field, click and drag 
to highlight any portion of it and then use the 
tools on the Edit Bar as needed.

Paragraph Options Dialog

Specify the Alignment of the selected 
paragraph(s). See “Aligning Text” on 

page 342.

Specify the Line Spacing of the 
selected paragraph(s). 

• Click the radio button beside Single, 1.5 
Lines, Double or User Specified.

• If you select User Specified Line 
Height, type the desired height for each 
line of text in the selected paragraph(s). 
For best results, this value should be at 
least as much as the largest character size 
used in the selected paragraph(s). 

Specify the appearance of Bullets and 
numbering in the selected paragraph(s). 

• Select the desired bullet, numbered or let-
tered Type from the drop-down list.

Note: Some fonts cannot be drawn at certain
zoom factors. When this is the case, the
appearance of the text will not change.

2

1

2

3

1

2

3
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• Select the desired punctuation Style for 
the selected numbered or lettered Type. 
Only available when a numbered or let-
tered Type is selected. 

• Numbering Start At - Specify the num-
ber assigned to the first numbered or let-
tered paragraph in the selected text 
object. Value must be 1 or greater. 

To adjust the size of bullets
1. Click at the end of a bulleted paragraph 

to position your cursor there.
2. Hold down the Shift key and press the 

right arrow key once to highlight the end 
of the paragraph.

3. Specify the desired bullet size in the text 
size field at the top of the Text tab. 

Text Specification Dialog
The Text Specification dialog opens 
if you select a Room Label or a simple 

Text object in a legacy plan file created in 
Version 8 or prior and click the Open Object 
edit button. See “Compatibility with Other 
Programs” on page 30.

Settings in the Text Specification dialog can 
also be found in other dialogs in the program, 
including the Room Label Specification and 
the Dimension Defaults dialogs. 

Text Tab

Enter text in the Text Entry field. This 
field is not available if the selected 

object is a Room Label. See “Room Labels” 
on page 115. 

1

2

1
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Select an Alignment option from the 
drop-down list to apply to the text.

Text Style Tab
The Text Style is also available in a number 
of other dialogs in the program.

Uncheck Use Default Text Style to 
enable the settings that follow. When it 

is checked, information about the Text Style 
that is assigned to the selected object 
displays for reference.

Specify the attributes of the selected 
Text Style’s Font. 

• Select a font from the drop-down list.
• The text styles Bold, Underline, Italic, 

and Strikeout are available. Check any 
of the boxes to apply that style.

Specify the Size of text using the 
selected Text Style. 

• Enter the Character Height in drawing 
units. This height is subject to the current 
drawing scale. When imperial Inches or 
Feet and Inches are used, accuracy to 
1/128” is possible. 

Specify the selected Text Style’s Text 
Color. When Use Custom Text Style is 

not selected above, a Text Color does not 
display here for reference. 
• When  By Layer is checked, text uses the 

line color assigned to the layer it is 
located on. See “Layers” on page 47.  
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• Uncheck By Layer, then click the Color 
bar to select a different color. See “Color 
Chooser Dialog” on page 290.

A preview of the Text Style currently 
assigned to the selected object displays 

here. 

Editing Text 

Once created, Rich Text  objects can be 
selected individually or as a group and edited 
using the edit handles and the edit toolbar 
buttons Individual text objects can also be 
edited in the Rich Text Specification dialog. 
See “Rich Text Specification Dialog” on 
page 336.

Editing Text Attributes
Most text attributes, including the font, size, 
style, and the content itself, are edited in the 
Rich Text Specification dialog.

In order to edit the attributes of an existing 

Rich Text  object, you must select some 
or all of the text before making changes. See 
“Text Tab” on page 337. 

To edit Rich Text attributes

1. Select a Rich Text  object and click 

the Open Object  edit button.
2. On the Text tab of the Rich Text 

Specification dialog, click and drag to 
select some or all of the text typed into 
the Text field. 

3. With some or all of the text selected, 
change any of the attributes available 

along the top of the tab, including the 
font, size, color, and style.

4. As changes are made, the selected text 
updates. Only the selected text is modi-
fied.

Using the Mouse

A selected Rich Text   object has the 
same edit handles as other box-based objects. 
See “Editing Box-Based Objects” on page 
72.

As a Rich Text  box is made smaller 
using an edit handle, not all of the text may 
be visible.

5

Resize

Extend/
Contract

Rotate

Move
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Using the Edit Tools

A selected Rich Text  or Text  object 
can be edited in a variety of ways using the 
buttons on the edit toolbar. See “The Edit 
Toolbar” on page 22.

Resizing Text

The character height of Rich Text  
objects can be specified in their specification 
dialogs. 

Scaling Text
As with the size of other objects, text size is 
subject to the current drawing scale specified 
in the Page Setup dialog. See “Page Setup 
Dialog” on page 367. 

Aligning Text
Text can be aligned in a couple of ways. 
• The text content of a text object can be 

aligned to the left, right, center or justi-
fied in the Rich Text Specification dia-
log. See “Text Tab” on page 337.

• The text content of a text object can be 
also be aligned by clicking the Align 

Left , Align Right , Center , 

or Justify  edit button.  

Copy, Cut and Paste
Copy, Cut and Paste of text into and out of 
the Rich Text Specification dialog can be 
accomplished using keyboard hotkeys:
• Press Ctrl + X to Cut the selected text and 

save it to the Windows clipboard.
• Press Ctrl + C to Copy the selected text 

and copy it to the Windows clipboard.
• Press Ctrl + V to paste your last cut or 

copied selection in a new text object.

For more, see “Copying and Pasting 
Objects” on page 55.

Copy, Cut and Paste use the Windows 
clipboard, making it possible to to transfer 
text between text objects, between Home 
Designer Essentials files, from a plan into 
another application, or vice versa. 

Copying & Pasting Text
The Copy, Cut and Paste commands use the 
Windows clipboard, making it possible to 
transfer text between text objects, between 
Home Designer Essentials files, from a plan 
into another application such as a text editor 
or spreadsheet program, or vice versa. See 
“Copying and Pasting Objects” on page 55.

All or selected portions of the Materials List 
can also be copied and pasted into a text 

object, as well as into a word processing or 
spreadsheet program. See “Materials Lists” 
on page 373.

Cut, Copy, and Paste can also be accessed 
from the Edit menu of many applications, 
including Home Designer Essentials. These 
menu commands are not available when the 
text specification dialogs are open, but you 
can use the associated hotkeys. 
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To Copy, Cut and Paste text
1. On the Text tab of either text specifica-

tion dialog or in another program alto-
gether, highlight the text you wish to cut, 
copy or paste.

2. Press Ctrl + X to Cut the selected text 
out of its original location and save it to 
the Windows clipboard.

3. Press Ctrl + C to Copy the selected text 
to the Windows clipboard without 
removing it from its original location.

4. Open the text object or a file in another 
application and click to place your cur-
sor in the Text field, writing area, or 
spreadsheet cell.

5. Press Ctrl + V to Paste the copied text at 
the location of your cursor.

Bear in mind that when text is copied and 
pasted, its formatting is not always retained. 
The results depend on the program or type of 

text object in which the content was created 
as well as the type of text object into which it 
is pasted. 

Pasting into Rich Text
Text pasted into a Rich Text object 
from another source will retain most 

of its custom formatting. 

Text pasted into a Rich Text  object from 
a spreadsheet program retains basic column 
and row information. Column width cannot 
be adjusted; however, as you add or remove 
text froma cell, row height will increase or 
decrease to accomodate your changes.

The background colors of two or more cells 
copied from a spreadsheet application will be 

retained if pasted in to Rich Text ; 
however, once pasted background color 
cannot be edited. 

Text Arrows
Text arrows can be used to connect text 
objects to details of interest in your drawing.  

Text arrows can be snapped together to form 
open or closed polylines. If two lines with 
arrows meet within the bounding box of a 
text object, however, they will not join. This 
allows you to attach multiple, separate text 
arrows to a single text object. See “Editing 
Line Based Objects” on page 62.

Lines with arrows can be independent or 
attached to other objects. Arrows attach to 
closed polyline-based objects along their 
edges, but can attach to an architectural 
object anywhere within its 2D symbol in 
floor plan view. If an arrow is attached to text 

or another object, deleting either the text or 
the object will also delete the arrow. 

Text with Arrow
The Text with Arrow tool places a 
text object with an arrow already 

attached. This arrow can be selected and 
edited like any other arrow.

Text Line with Arrow
Text Lines with Arrow can be 
attached to text and architectural 

objects by selecting CAD> Text> Text Line 

with Arrow  and then clicking and 
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dragging to draw a line. There is no limit to 
the number of text lines with arrows that can 
be attached to an object.

The endpoints of Text Lines with 

Arrows  can be joined to form polylines 
with corners that can be adjusted using the 
edit handles.  

Auto Positioning Arrows
There are four auto position locations on a 
text object: one at the midpoint of each side.

The following image illustrates the behavior 
of auto positioning. When the head of the 

line with arrow is moved, the tail of the 
arrow snaps to different auto position 
locations on the text object, maintaining its 
connection.

Line/Polyline Specification Dialog
Select a Text Line with Arrow and 
click the Open Object edit button to 

open the Line Specification dialog, Arc 
Specification dialog (if the line has been 
curved) or the Polyline Specification dialog 
(if the object is composed of multiple line 
and/or arc segments). 

The settings in these dialogs are similar to 
those available for a variety of other objects 
in the program.

Polyline Tab
The Polyline tab is available when the 
selected object is composed or more than one 
line or arc segment and displays the Length/
Perimeter, Area, and Volume of the selected 
polyline. The Area and Volume of open 
polylines are described as “Not closed”. 

Selected Line Tab
The Selected Line tab is available when the 
selected edge of the polyline is a line as 
opposed to an arc. See “Selected Edge” on 
page 60.

The settings on the Selected Line tab are 
available for a variety of other objects in the 
program. For information about these 
settings, see “Selected Line Tab” on page 
203.

Selected Arc Tab
The Selected Arc tab is available when the 
selected edge of the polyline is a line as 
opposed to a line. See “Change Line/Arc” on 
page 81.

The settings on the Selected Line tab are 
available for a variety of other objects in the 
program. For information about these 
settings, see “Selected Arc Tab” on page 203.
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 Line Style Tab
The settings on the Line Style tab are 
available for a variety of other objects in the 

program. For information about these 
settings, see “Line Style Tab” on page 205.

Arrow Tab
The Arrow tab is available for open 
polylines, but not for closed polylines.

Select an arrowhead Type from the 
drop-down list. 

Check Default to reset the arrow type.

Select the Fill Color used to fill the 
arrowheads.  See “Color Chooser 

Dialog” on page 290.

Check Default to reset the fill color.

Define a Size for the arrow(s).

Check Default to reset the size.

Check Arrow on Both Ends to place a 
head on both ends of the selected 

arrow(s).

Fill Style Tab
The Fill Style tab is available for closed 
polylines, but not for open polylines.

The settings on the Fill Style tab are 
available for a variety of other objects in the 
program. For information about these 
settings, see “Fill Style Tab” on page 205

1
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Chapter 29:

Project Planning

The tools described in this chapter let you 
draw plans with ease and flexibility and run 
checks on plans so you can be more 
confident that they are free of common 
drawing errors.

Chapter Contents
•      House Wizard
•      Plan Check

House Wizard
The House Wizard is a time-saving 
feature used to create a preliminary 

room-by-room design of a home without 
getting caught up in the details. Once the 
shape and layout of the rooms are finalized, 
the House Wizard converts them into a 
working plan that can be edited and detailed 
to completion.

Start House Wizard
Select Tools> House Wizard> Start 
House Wizard. The House Wizard 

leads you through a series of windows that 
gather information about the rooms you want 
to include in your house. When you click 
Finish and close the House Wizard, the 
selected room boxes display.

Room boxes can now be arranged into a floor 
plan. 
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Placing Room Boxes
In addition or as an alternative to the room 
boxes created for you by the House Wizard, 
you can create your own room boxes. To do 

so, select Tools> House Wizard , then 
choose the desired room type from the 
submenu. Click in floor plan view to place a 
room box of the selected type at that 
location. 

Displaying Room Boxes
Room boxes and their labels are located on 
the “House Wizard Room Boxes” layer. 
Room box labels use the Text Style assigned 
to that layer, as well. See “Displaying 
Objects” on page 48. 

Editing Rooms
Once created, room boxes can be edited in a 
variety of ways.

• Select room boxes using the Select 

Objects  tool just like other objects in 
Home Designer Essentials. See “Select-
ing Objects” on page 60.

• Room boxes can be resized, rotated, and 
rearranged. See “Editing Box-Based 
Objects” on page 72.

• Try to line up the rooms so that they are 
just touching. Excessive overlaps may 
cause your rooms to form incorrectly. 
Closets are the exception. You can over-
lap a room with a closet, or place in 
inside another room box.

• Rooms can be copied and pasted using 

the Copy/Paste  edit button and 

deleted using the Delete  edit button.

• Select Tools> House Wizard  to 
access the room box tools and place addi-
tional room boxes in your plan. Select a 
tool and click in the plan to place a room 
box of that type. 

• Select Tools> House Wizard> Hide 

Room Boxes  to hide or show the 
room boxes.

Build House
When the rooms are in place, select Tools> 

House Wizard> Build House  to convert 
the rooms into a building model. Walls and 
doors are inserted between the rooms that 
you arranged. 
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When you Build House, the “House Wizard 
Room Boxes” layer is automatically turned 
off. The room boxes that you created are not 
deleted, however. 

Multiple Floors
If you specified a two-story house, follow 
these steps:

1. Edit and arrange the room boxes on 
Floor 1 as desired.

2. Select Tools> House Wizard> Build 

House  tool to create the walls on the 
first floor.

3. Go Up One Floor  and notice that 
the positions of the walls on Floor 1 dis-
play in red as a reference.

4. Arrange the rooms on Floor 2 as desired, 
using the reference display as a guide.

5. On the second floor, select Tools> 

House Wizard> Build House  to 
complete the second floor.

Plan Check
Plan Check checks the floor of your 
plan currently shown on screen for 

anything that appears to violate common 
building practices. Plan Check may not find 
all the problems in a plan, but does it point 
out areas that may need improvement. 

As your plan evolves, a number of things that 
may become incorrect can be fixed using 
Plan Check. For example, doors that change 
from exterior to interior as you add new 
rooms are redrawn without the threshold line 
that marks an exterior door. A cabinet, 
fixture or furniture item that is against a wall 
because the wall was moved into it, as 

opposed to the item moving, are attached to 
the wall.

To run Plan Check, select Tools> Plan 

Check .

Disclaimer: The Plan Check feature in
Home Designer Essentials compares

your plan with common building practices.
Plan Check does not claim to detect all build-
ing code and design requirements. Always
have your plans checked by a licensed pro-
fessional before beginning actual construc-
tion.
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Plan Check Dialog

The current error number, along with 
the total number of errors found.

A description of the current error 
displays here.

Options for navigating Plan Check are 
found on the right side.

• Click Next to ignore the current error and 
proceed to the next.

• Click Previous to return to the previous 
error.

• Click Hold to suspend Plan Check so you 
can fix the current error. Select Tools> 
Checks> Plan Check again and the 
check starts where it left off.

• Click Done to terminate Plan Check.

Potential plan errors found are usually 
highlighted in floor plan view. To ensure the 
highlighted item is on-screen, make sure the 
entire plan is shown in the window before 

you run Plan Check .
If this dialog obscures the floor plan view, 
drag its title bar to move it. It remembers its 
new position and displays there the next time 

Plan Check  is run.

Room Types

Plan Check  can do a much better job of 
checking for problems if it knows what the 
rooms in your plan are to be used for, so you 
should assign a Room Type to each room in 
your plan. See “Room Types” on page 113.

The first time Plan Check  runs in a plan, 
it automatically assigns a room type to as 
many undesignated rooms as it can. Some 
rooms are determined by their size and 
shape, and others by their contents. For 
example, a shelf in a small room indicates a 
closet; a stove or refrigerator indicates a 
kitchen; or a bed, a bedroom. If the program 

cannot assign a room type, Plan Check  
highlights it and suggests that you do so 
manually. 
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Chapter 30:

Pictures, Images, &
Walkthroughs

Home Designer Essentials uses picture files 
in a variety of ways to enhance your 
drawings. 

The Library Browser contains images of real 
world objects like plants, vehicles, and 
people that can display in 3D views.

Picture files can also be imported into Home 
Designer Essentials and shown in most 
views. 

You can save any view using a variety of 
picture file formats. In addition, Home 
Designer Essentials allows you to create 
virtual tours that can be saved as .avi files, 
shared with others, and played back later.

Chapter Contents
•      Picture Files vs Pictures and Image Objects
•      Images
•      Displaying Images
•      Editing Images
•      Image Specification Dialog
•      Pictures
•      Editing Pictures
•      Picture File Box Specification Dialog
•      Metafiles
•      Editing Metafiles
•      Metafile Specification Dialog
•      Copy Region as Picture
•      Walkthroughs
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Picture Files vs Pictures and Image Objects
In common computer language, picture files, 
pictures and images are more or less 
synonymous. In the Home Designer 
Essentials environment, however, there are 
some notable differences between these 
terms.

In Home Designer Essentials, a two 
dimensional image file such as a .bmp, .jpg, 
.gif, or .png is referred to as a picture file or 
an image file. Examples of these files are 
saved on most computers and can be opened 
in a variety of applications. 

A picture, on the other hand, is a file that has 
been imported into the program. Pictures can 
be imported into floor plan view and cross 
section/elevation views. They are two-

dimensional only and do not display in 
camera views or overviews. 

An image object is also based on a picture 
file, but it does display in both 2D and 3D 
views. Images have 3D width and height data 
associated with them, as well as a 2D symbol 
which displays in floor plan view. 

Picture files have additional uses in Home 
Designer Essentials, as well:
• Backdrops are picture files that display 

behind 3D views. See “3D Backdrops” 
on page 306.

• Textures are picture files that realistically 
represent materials in 3D views. See 
“About Materials” on page 281.

Images
Images add realistic detail to 3D views 
without adding many surfaces to the model. 
For example, a tree image with a single 
surface can be used instead of a tree symbol 
with thousands, dramatically improving 
realism without compromising drawing time.

There are two types of images in Home 
Designer Essentials: 

• Images  rotate so that they always 
face the camera in 3D views.

• Billboard Images  do not rotate to 
face the camera. An example of when 
this may be useful is an image of a trellis, 
which might look awkward when facing 
a camera from a side view. 

Placing Images
A selection of images are available in 
the Library Browser. Select one and 

click in a floor plan view, camera view or 
overview to place it. See “Placing Library 
Objects” on page 274.

Creating Images
Select Build> Image to view the 
Image Tools, which allow you to add 

images to the current plan. 

To create an image in floor plan view 

1. In floor plan view, select Build> 

Image> Create Image  or Billboard 
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Image  to open the Image 
Specification dialog. See “Image Speci-
fication Dialog” on page 355.

2. On the Image tab:
•  Click the Browse button to select a pic-

ture file on your computer or enter the 
path to a valid picture file in the Image 
File field.

•  Select or 2D plan symbol to represent 
the image in floor plan view. Choose a 
2D Plan Symbol from the list or click 
the Library button and select a symbol 
from the library. See “Image Tab” on 
page 355.

•  Enter Height and/or Width and Loca-
tion information. 

3. Enter transparency information and 
layer information on the Transparency 
tab. 

4. Click OK to close the Image 
Specification dialog.

5. Click to place the new image in floor 
plan view. 

Adding Images to the Library
Home Designer Essentials can use any image 
with a *.bmp, *.jpg, *.png, *.gif, *.tif, 
*.pcx, or *.tga extension.

Generally, .png files work best as images 
because this format has good compression 
and allows for the image to contain 
transparency information.

Right-click on an unlocked folder in the 
Library Browser. Select New> Image from 
the contextual menu. The Image 
Specification dialog opens. 
Browse to the image you want to add and 
select your other options. For more 
information in these options, see “Image 
Specification Dialog” on page 355.  

To create an image in the Library Browser 

1. In the Library Browser, right-click on an 
unlocked folder.

2. Select New> Image from the contextual 
menu to open the Image Specification 
dialog. 

3. Once created, the image is listed in the 
library folder that you right-clicked on. 
Size and other data is saved. 

Using Paste Image
You can also import an image by first 
copying it to the Windows Clipboard, 

then navigating to a Home Designer 
Essentials window and selecting Edit> 
Paste> Paste from the menu. See “Paste 
Special” on page 57. 

The display of images in floor plan 
and 3D views is controlled in the 

Display Options dialog. See “Displaying 
Objects” on page 48.

Displaying Images
The display of images in floor plan 
and 3D views is controlled in the 

Layer Display Options dialog. See 
“Displaying Objects” on page 48.
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Images are placed on the”Images” layer by 
default but they can be moved to other 
layers. See “Image Specification Dialog” on 
page 355.

In Floor Plan View
In floor plan view, most images are typically 

represented by an Image  symbol. You 
can specify a different symbol to represent an 
image if you wish. See “Image Specification 
Dialog” on page 355. 

In 3D Views
The actual picture associated with an image 
object can be seen in 3D views. It is sized 
according to its Width and Height 
specifications. Any transparency data 
associated with the image is also applied. See 
“Image Specification Dialog” on page 355.

Images can be set to either rotate so that they 
always face the camera or to remain 
stationary, like billboards. See “Images” on 
page 352. 

Editing Images
Images can be selected in 2D and 3D views 
and edited using the edit handles, edit tools 
and the Image Specification dialog. 

Using the Mouse
Images can be resized in floor plan view by 
dragging the circular Resize handle at the top 
of the 2D symbol. 

Images can also be resized in 3D views by 
dragging the circular Resize edit handle at 
the top. 

When an image is resized, the aspect ratio of 
the image and its 2D symbol are retained, so 
the image resizes proportionally.

Using the Edit Tools
A selected image or images can be edited in a 
variety of ways using the buttons on the edit 
toolbar. As with most objects, images can be 
copied, replicated, moved, deleted, etc. See 
“The Edit Toolbar” on page 22.
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Image Specification Dialog
Select an image and click the Open 
Object edit button to open the Image 

Specification dialog. 

Image Tab

Image File - The path and name of the 
selected image. You can click Browse 

to replace the current image with a different 
one saved on your computer.

2D Plan Symbol - Select a 2D symbol 
from the drop-down list to mark the 

location of the image in floor plan view. See 
“Displaying Images” on page 353.

Options

• Check Reverse Image to reflect the 
appearance of the image about an imagi-
nary vertical line through its center. 

• Check Do Not Rotate in Camera Views 
to prevent the image from rotating to face 
the camera in 3D views. This box is 
checked for Billboard Images. See 
“Images” on page 352. 

Specify the Size of the image as it 
displays in 3D views.

• Enter a Height for the selected image. 
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• Enter a Width for the selected image. 
• When Retain Aspect Ratio of is 

checked, if you change either the Height 
or Width, the other value changes to 
maintain this ratio. If this is unchecked 
and you resize the image, it may become 
distorted.

• Click Reset Original Aspect Ratio of to 
reset the image’s original aspect ratio and 
remove any distortion caused by resizing.

Specify the Location of the selected 
image.

• Position the selected image precisely by 
specifying its X and Y Coordinates.

• Specify the image’s Height Above 
Ground.

Pictures
A variety of picture file types can be 
imported into and exported out of Home 
Designer Essentials. 

Metafiles are also types of picture files that 
can be imported and exported. See 
“Metafiles” on page 357.

Exporting Pictures
Using the Export Picture tool is 
similar to creating a screen capture of 

everything  in the current Home Designer 
Essentials window. Pictures can be saved in 
various file formats and used in other 
applications. 

Export Picture  is best suited for 3D 
views. When exporting a line-based view, 
best results can be achieved by saving it as a 
Metafile. See “To export a metafile” on page 
358.

To export a picture

1. Open the view that you would like to 
export to a picture file. 

2. Zoom, pan or otherwise adjust the view 
so that what you see on screen suits your 

needs. See “Displaying 3D Views” on 
page 305.

3. Select File> Export> Picture (BMP, 

JPG, PNG)  in any view to open the 
Export Picture File dialog, which is a 
typical Save File dialog. See “Exporting 
Files” on page 33. 

Importing Pictures
There are several ways to import a picture 
into Home Designer Essentials.

Picture files can be imported into and 
displayed in floor plan view and cross 
section/elevation views. Picture files do not 
display in camera views or overviews. 

Using Import Picture
Select File> Import> Picture (BMP, 
JPG, PNG) to insert a picture file into 

a plan file. The Import Picture File dialog 
opens.

Click Open to finish importing the picture. 
The picture is placed in the center of the 
current view, and can be selected and edited. 

5
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Clicking and Dragging

You can import a picture directly into floor 
plan view by dragging an image file from a 
Windows Explorer window into the Home 
Designer Essentials window

Using Paste Image

You can import a picture by first 
copying it to the Windows Clipboard, 

then navigating to a Home Designer 
Essentials window and selecting Edit> 
Paste> Paste from the menu, or by using the 
Screen Capture tools. See “Paste Special” on 
page 57.

Editing Pictures
Pictures can be selected individually and as a 
group in 2D and 3D views and edited using 
the edit handles, the edit toolbar and their 
specification dialog. See “Picture File Box 
Specification Dialog” on page 357.

Using the Mouse
Pictures can be edited like CAD boxes. See 
“Editing Box-Based Objects” on page 72. 

Using the Edit Tools
A selected picture or pictures can be edited in 
a variety of ways using the buttons on the 
edit toolbar. See “The Edit Toolbar” on page 
22.

Picture File Box Specification Dialog
Select an imported picture file and 
click the Open Object edit button to 

open the Picture File Box Specification 
dialog.

The settings in this dialog are similar to those 
on the Line Style tab in numerous other 
dialogs, with one exception. 

Uncheck the Show Outline box to turn off 
the display of the picture’s border polyline.

For more information, see “Line Style Tab” 
on page 205.

Metafiles
A metafile (.emf, .wmf) is a special picture 
file format made up of vectors (lines) that 
allow the image to be rescaled without loss 
of quality. 

High resolution pictures  of line-based views 
can be exported as a metafile.
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Exporting Metafiles
An enhanced metafile (.emf) can be 
exported from floor plan view. 

Only objects that display on screen are 
included in an exported metafile.

To export a metafile

1. Accurately position the view on screen.
2. Select File> Export> Metafile 

(EMF) . 

3. Drag a marquee  from corner to cor-
ner, defining the area that will included 
in the metafile.

4. Release the mouse to open the Metafile 
Size dialog.

5. Specify the desired Width or Height of 
the metafile. When one value is edited, 
the other changes to maintain its aspect 
ratio. 

Specify, too, the desired Dots Per Inch 
(DPI) for the metafile. A larger value 
results in a higher quality metafile, but 
also a larger file size.

6. Click OK to open the Export Metafile 
dialog, which is a typical Save As dia-
log. See “Saving a Plan File” on page 
32. 

7. Enter a name and location on your com-
puter for the metafile, then click Save. 

Importing Metafiles
Select File> Import> Metafile 
(EMF,WMF) from floor plan view to 

open the Import Metafile dialog, which is a 
typical open file dialog. See “Opening a Plan 
File” on page 35. 

Editing Metafiles
Once imported into a plan, a metafile can be 
selected and edited like other objects. See 
“Selecting Objects” on page 60.

Using Dimensions
Metafiles can be relocated relative to other 
objects with precision using dimensions. See 
“Moving Objects Using Dimensions” on 
page 331.

Using Edit Handles
Metafiles can be edited using their edit 
handles much the way CAD boxes can. See 
“Editing Box-Based Objects” on page 72.

Using the Edit Tools
A selected metfile or metafiles can be edited 
in a variety of ways using the buttons on the 
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edit toolbar. See “The Edit Toolbar” on page 
22.

Metafile Specification Dialog
Select an imported metafile and click 
the Open Object edit button to open 

the Metafile Specification dialog.

The settings in this dialog are similar to those 
on the Line Style tab in numerous other 
dialogs, with one exception. 

Uncheck the Show Outline box to turn off 
the display of the picture’s border polyline.

For more information, see “Line Style Tab” 
on page 205.

Copy Region as Picture
You can copy any portion of the 
screen and save it as a picture using 

the Copy Region as Picture tool.

To use Copy Region as Picture

1. Open the view that you would like to 
copy all or part of as a picture.

2. Select Edit> Copy Region as 

Picture . Your pointer displays a 

marquee  icon.
3. Click and drag a rectangular selection 

marquee around the desired region.

4. The selection is copied to the Windows 
clipboard.

•  If the current view is vector-based, the 
Metafile Size dialog displays because 
the program uses this file format to 
produce vector-based pictures. See 
“Metafiles” on page 357.

•  If the current view is a 3D view, the 
region is sent directly to the Windows 
clipboard.

5. From there, the picture can be pasted 
into another view or another program.

Walkthroughs
A 3D Walkthrough is a series of 
picture files saved in .avi format that 

can be played like a movie by other 
applications such as Windows Media Player.

If you resize the current view window while 
recording a walkthrough, the program will 
stop recording. 
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To record a walkthrough

1. Create a camera view. This view is the 
first frame of the walkthrough.

2. From the view, select 3D> Walk-

throughs> Record Walkthrough . 
3. Specify a location and name for the 

walkthrough in the Write Movie File 
dialog and click Save. 

4. In the Walkthrough Options dialog: 

•  Select a Frame Rate between 1 and 
100. The value entered is the number 
of frames per second. 

•  Select a Compression Percent 
between 0 and 100. A value of 0 gives 
the highest quality images and the larg-
est file size.

•  Click OK.
5. Use the camera movement tools to cre-

ate additional views. Each time the 
screen redraws, that view is recorded as 

the next frame in sequence. See “Editing 
3D Views” on page 307.

6. To move the camera without saving a 
view, select 3D> Walkthroughs> Pause 
Recording  to temporarily stop record-
ing. 

•  You can then select 3D> Walk-
throughs> Save Frame  button to con-
trol what views are saved.

•  You can start recording again by select-
ing Pause Recording  once more.

7. When the walkthrough sequence is com-
plete, select 3D>Walkthroughs> Stop 

Recording  or close the view.

To play a walkthrough

1. Select 3D> Walkthroughs> Play 

Walkthrough  to open the Open 
Movie File dialog. 

2. Browse to an .avi file on saved on your 
computer. Your default video application 
plays the walkthrough.

Note: Zooming in and out and using the scroll
bars does not change the viewpoint and does
not produce a frame for the walkthrough.
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Chapter 31:

Printing

Home Designer Essentials provides a variety 
of printing options, from printing plan and 
3D views to a set of templates that can be 
assembled into a 3D model.

Home Designer Essentials also allows you to 
save your drawings in pdf file format that can 
then be sent to a printing service.

Chapter Contents
•      Introduction to Printing
•      Printers
•      The Printing Tools
•      Display Options and Printing
•      Printing Directly from a View
•      Printing to Scale
•      Printing Across Multiple Pages
•      Printing to a PDF File
•      Page Setup Dialog
•      Print Dialog
•      Print Image Dialog
•      Print Model

Screen captures are provided for
illustrative purposes only and are not an

endorsement of any products.
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Introduction to Printing

Home Designer Essentials offers printing 
options to suit a variety of needs. You will 
benefit from understanding the output 
options clearly and choosing the one that 
makes the most sense for the project at hand.

Output Options
Printing a View - You can print any view of 
your plan. Home Designer Essentials can 
print to almost any printer that supports 
printing graphics from Windows programs. 
See “The Printing Tools” on page 363.

Printing to a Remote Printer - Plans can be 
printed to a .pdf file and printed remotely. 
See “Printing to a PDF File” on page 366.

Print Model - If your final printed output 
will be used to create a 3D model of your 
design, the Print Model feature works best. 
See “Print Model” on page 369.

Terminology
There are a couple of terms that you should 
familiarize yourself with.

Paper Size - The dimensions of the paper to 
be printed on. Specifying a paper size that is 
smaller than the scaled drawing allows large 
drawings to be printed across multiple pages.

Printing Scale - Drawings are often printed 
to scale for accuracy. ¼" = 1' and 1 m = 50 m 
are examples of common scales. Home 
Designer Essentials prints to a scale of 1/16” 
= 1’ by default, although this scale can be 
changed in the Page Setup dialog. See 
“Page Setup Dialog” on page 367. 

When a particular scale is not important, 
drawings can also be sized to fill a particular 
area. See “Printing to Scale” on page 365.

Printing Problems
Home Designer Essentials can print to 
almost any printer that supports printing 
graphics from Windows programs. If you 
encounter difficulties when trying to print, 
see “Troubleshooting Common Technical 
Issues” on page 384.

Printers

Printer Drivers
Printer drivers are programs that interpret 
between software programs and the printer. 
The drivers are usually created by the 
manufacturer of the printer and are typically 

updated regularly. Different drivers are used 
for different versions of Windows. 

It is useful to keep track of the drivers for 
each printer you use and update them 
whenever the Windows operating system is 
updated or replaced.

Always familiarize yourself with your
printer or plotter before a deadline. It

takes a little time to configure the machine
properly when you first start. 
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To find the version of your printer driver,  
select Start> Control Panel> Printers and 
Faxes to view the Printers information for 
Windows. Select the printer in question, then 
choose File> Properties.

In most Printer Properties dialogs is an 
About button which you can click to find the 
version and creation date of the driver 
currently in use. If you experience printing 
problems and yours is not the latest driver, 
consider replacing it with an updated driver. 
Visit your printer manufacturer’s Web site 
for more information.

Windows provides information about 
installing printer drivers. To access Windows 
Help, select Start> Help. If you have 
problems installing a driver, refer to your 
printer documentation for technical support.

Clearing Printer Information
Some information specific to individual 
printers, such as available paper sizes, is 
saved with each plan file. You can select 
File> Print> Clear Printer Info to clear the 
printer-specific information stored with the 
plan file.

The Printing Tools
Select File> Print to view the Print 
Tools submenu. 

Page Setup - Opens the Page Setup 
dialog, where printing options are set. 

See “Page Setup Dialog” on page 367.

Scale to Fit - Automatically selects a 
scale that fits your plan to the printer 

page. See “Printing to Scale” on page 365.

Center Sheet - Automatically centers 
your drawing on the sheet. See “Cen-

ter Sheet” on page 364.

Print Preview - Shows how the 
current view will appear when printed. 

See “Print Preview” on page 364.

Print - Prints the current floor plan. 
See “Print Dialog” on page 368.

Print Image - Prints a screen view 
including images, textures and 

backdrops. See “Print Image Dialog” on 
page 369.

Print Model - Opens the Print Model 
dialog, allowing you to print templates 

for making a physical model of your plan. 
See “Print Model” on page 369.

Clear Printer Info - Clears the printer 
information associated with the current page 
setup.  

Note: You should only update your printer
driver if you are having problems printing.

Options available with one driver may
not be available with another. Printers

supported in one version of Windows may not
be supported by the manufacturer in another.
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Display Options and Printing
The display of objects in views can be used 
to affect the printed output. Some display 
options allow you to preview the printed 
output on screen before any paper is used.

Objects must be visible in order for them to 
print; but not all items that are visible print. 
• Camera symbols in floor plan view, for 

example, do not print. 
• The Reference Display does print if it is 

visible. See “Reference Display” on page 
165. 

Displaying Objects
You can control the display of objects 
when printing directly from a view in 

the Display Options dialog. See “Display 
Options Dialog” on page 49.

Print Preview
Select File> Print> Print Preview for 
an on-screen representation of how 

the current view will appear when printed. 
Print Preview is only available in floor plan 
view. See “Printing to Scale” on page 365.

The printer page displays as a solid white 
rectangle, and blue lines along the edges of 
the printer page indicate the edges of the 
printable area, as defined by the currently 
selected printer. See “Printers” on page 362.

Objects such as camera symbols that do not 

print do not display in Print Preview . 
Text and dimension objects appear on-screen 
as they will on the printed page.

Center Sheet
Select File> Print> Center Sheet to 
center the printer page on the drawing. 

This moves the printer page relative to the 
drawing but does not affect the coordinates 
of objects in the drawing. The location of the 
printer page is independent for each floor of 
the model.

Printing Directly from a View
To print directly from any floor plan 
view, choose File> Print> Print. See 

“Print Dialog” on page 368. 

To set up print formatting before printing, 

select File> Print> Page Setup . See 
“Page Setup Dialog” on page 367.

To see how your printed output will
appear on paper, select File> Print>

Print Preview.
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3D views can be printed using File> Print> 

Print Image . See “Print Image Dialog” 
on page 369.

Printing to Scale
Several different print scaling options are 
available. The type of view that you are 
printing determines which options you may 
choose from.

Orthogonal Views
Floor plan  views are orthogonal views, 
which means: 
• Your line of sight is at a right angle to all 

objects in the view. 
• Objects do not appear to decrease in size 

as their distances from the viewer 
increase.

Orthogonal views can be printed to scale.

The scale set in the Page Setup dialog is 
inherited by the Print dialog. This scale can 
be overridden on an individual basis in the 
Print dialog. See “Print Dialog” on page 368. 

Select File> Print> Scale to Fit  in an 
orthogonal view to select a suitable scale and 

re-center the printer page so that everything 
fits on the page.

Imperial drawing scales are typically noted 
in inches per foot. Larger scales, such as 1 
inch = 50 feet or 1:200m, are often used for 
property layouts.

Perspective Views
Camera views and overviews display the 
model much the way the eye would see it and 
cannot be scaled.
• Objects in the view may be at any angle 

relative to your line of sight. 
• Objects seem to decrease in size as their 

distances from the viewer increase.

Perspective views can only be printed using 

the Print Image  tool. See “Print Image 
Dialog” on page 369.

Printing Across Multiple Pages
When printing directly from a floor plan 
view it is possible to print at a scale that does 
not fit the drawing on one page.

To see on-screen what the drawing will look 
like when printed, select File> Print> Print 

Preview  and then Window> Fill 

Window . Grey lines across the drawing 
sheet  indicate where the page breaks will 
occur. See “Print Preview” on page 364.
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To print across multiple pages

1. Select File> Print> Print Preview  
to display the white rectangle represent-
ing the printer paper. See “Print Pre-
view” on page 364.

2. Click the Select Objects  button, 
then click near an edge of the printer 
paper rectangle to select it. 
When selected, the printer paper is 
highlighted in pale grey and a square 
Move edit handle displays at its center.

3. Click and drag the Move edit handle to 
position the printer paper so that the por-
tion of your drawing that you would like 
to print on your first page is located 
within the printable area of the page. 

4. Select File> Print> Print . In the 
Print dialog, make sure To Scale is 
selected, then click OK. See “Print Dia-
log” on page 368.

5. Select the printer paper rectangle and 
move it so that the desired contents of 
your second printed page are within the 
printable area and print To Scale.

6. Continue moving the printer paper and 
printing as needed.

When printing multiple pages, it is generally 
a good idea to leave some overlap on the 
edges of each page to make sure that 
information near those edges is not left off 
the printed pages by mistake. 

Printing to a PDF File
The .pdf, or Portable Document Format, 
creates viewable and printable documents 
and is one of the most universally compatible 
and efficient file formats.  

Creating a .pdf document requires that a .pdf 
printer driver be installed on your computer. 
This is not a physical print device, but a 
software program that is recognized as a 
printer by all other programs and creates a 
.pdf file that can be read and printed using 
Adobe® Reader®. 

When you print to a .pdf print driver, you 
will be asked for a file name and destination 
automatically. 

To print to .pdf 

1. Select your .pdf printer driver as you 
would select any other printer in the 
Page Setup dialog. See “Page Setup 
Dialog” on page 367. 

2. Select File> Print> Print  to open 
the Print dialog. Your .pdf printer driver 
is listed as the selected printer.

3. Select the needed options in the Print 
dialog, then click OK. 

4. In the Save As dialog, select a File 
name and Save in location for your .pdf 
file. For information about the settings 
in the Save As dialog, see “Saving a 
Plan File” on page 32.
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Page Setup Dialog
Select File> Print> Page Setup to 
open the Page Setup dialog. 

The Page Setup dialog is only available 
when an orthogonal view is active. When a 

perspective view is active, Page Setup  is 
not available. 

The settings in this dialog, including the 
selected printer, are specific to the current 
orthogonal view file, and are saved with the 
.plan file. 

Specify the printer paper Size and 
Source. The options available in these 

drop-down lists are controlled by the 
currently selected printer’s driver. See 
“Printer Drivers” on page 362.

Select Portrait or Landscape paper 
orientation.

Specify a print Scale. 1/16 inch = 1 ft 
(1m = 50 mm) is the default.

Click the Printer button to select a 
printer.

A preview of the printer paper displays 
on the right side of the dialog.

Click OK to close the dialog and apply any 
changes.

Clearing Printer Information
Select File> Print> Clear Printer Info to 
clear the printer-specific information stored 
in the Page Setup dialog.
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Print Dialog
To print directly from floor plan view 
and the Materials  List, select File> 

Print> Print. The Print dialog opens.

Specify Printer parameters.

• Choose a printer from the Name drop-
down list. 

• Click Properties to verify that the 
printer’s paper size, orientation and other 
settings are configured correctly. 

Specify the Print Range.

• Current Screen prints only the portion 
of the entire View showing on screen.

• Entire Sheet prints the entire sheet even 
though you may be zoomed in on a por-
tion of the view.

Select from the available Scaling 
options.

• Fit to Paper prints the plan on one page. 
The program will use whatever scale is 
necessary to fit the plan on one page. If a 
percentage less than 100 is specified, 
only that portion of the printable area is 
used.

• Select To Scale to print at the scale speci-
fied by settings in the current plan.

Note: 3D views can be printed using Print
Image. See “Print Image Dialog” on page
369. 

2

3 4

1

1
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Note: If you are zoomed out, and Current
Screen is selected, any white space around
the plan is calculated for printing.

3
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Select from the available Options. 

• Specify the number of Copies to print. 

• Check the Print in Color box to print in 
color or clear the check box to print in 
grey scale. 

Most black and white printers will print a 
grey scale approximation of the colors if 
Print in Color is selected.

Print Image Dialog
Any view can be printed by selecting 
File> Print Image. This is the only 

way to print 3D views. See “3D Rendering” 
on page 317.

The Print Image dialog is similar to the Print 
dialog; however, the printing process is 
different. Print Image prints individual 
pixels as opposed to vectors (lines).

Specify the Printer parameters.

• Choose a printer from the Name drop-
down list.

• Click Properties to verify that the 
printer’s paper size, orientation and other 
settings are configured correctly. 

Specify the Print Range. 

Specify the number of Copies.

Print Model
The Model Maker allows you to create 
a template of your plan that can be 

printed to scale and assembled into an actual 
3D model. Three groups of templates are 

4
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used in the process. Walls and roofs are 
printed separately. These can then be placed 
onto a floor plan view, which is printed as a 
layout for the entire model.

Since different people build house models in 
different ways, the Model Maker focuses on 
providing the most necessary tools. It may 
not necessarily give you everything you 
might want in order to build house models 
your way. For example, you may want to 
affix tabs to certain wall or roof edges to help 
attach them to their neighbors. While you 
can draw some of these things onto printed 
sheets, the system does not provide them 

automatically. What it does provide is 
accurate templates for wall and roof sections. 
Combining these with your own skills helps 
you create professional quality models.

Printing the Model
The best way to understand how the various 
options affect the final product is to make a 
very simple two story plan and try them out.

To print the model templates, choose File> 

Print> Print Model . The Print Model 
dialog opens.

Print Model Dialog

Select a Printer from the drop-down 
list and set its Properties. 

• Landscape is usually the best mode for 
printing models. If it is not your default 
printing mode, it can be selected via the 
Properties button.

• Information about your printer and its 
current setup displays here. 

Specify the Scale for your model. The 
default is 1/16 inch = 1 foot (1 m = 

50 m).

Specify the Floor Thickness, which is 
the thickness of the material that you 

will use for the floor platform of the model.

Check Print in Color to print in color 
rather than black and white.

1
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Assembling the Model
Once the templates have been printed, they 
are ready to be assembled. You need scissors 
and an adhesive and a rigid material that can 
be easily cut and glued, such as thin 
cardboard or styrofoam, to provide support 
for the 3D model.

Floor Plan View Template

Begin by laying out the floor plan view, 
which is used as a layout for the entire 3D 
model. If your floor plan view template 
printed on a number of sheets, they should be 
combined into one. Exterior and interior wall 
surfaces should match throughout.

Adhere your complete floor plan view 
template to a sturdy and dedicated surface to 
provide support for your walls.

Walls

Walls should be cut and fixed to a rigid 
backing so that they can stand on their own 
and support the weight of the roof or floors 
above them. How they are cut and assembled 
varies depending on the desired final 

appearance of the model and how they were 
printed. 

It may be helpful to take the thickness of the 
rigid material being used into consideration 
and override the scale thickness of the walls 
so that it agrees with your material thickness.

If your walls were resized in the Print Model 
dialog, you may see unwanted lines between 
floors that should merge together seamlessly. 
This is usually due to walls whose exterior 
surfaces match but overall thickness does 
not. You can prevent this by checking Use 
Scale Wall Thickness, which prevents walls 
from resizing. This is best if you do not want 
to print the interior wall surfaces, or are 
using a modeling material that closely 
matches the scale thickness of your walls.

Roofs

Roof planes are joined together when 
possible before printing. For each roof 
surface, the fascia and soffit surfaces are 
attached at the eave, so that the least amount 
of taping produces the roof and adjoining 
surfaces. 
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Chapter 32:

Materials Lists

Materials Lists can be created, edited, and 
printed directly from the program. They can 
also be exported as text files for use in other 
programs.

Chapter Contents
•      The Materials List
•      Creating an Accurate Materials List
•      Organizing Materials Lists
•      Materials List Display Options Dialog
•      Editing Materials Lists
•      Exporting the Materials List
•      Conditioned Area Totals

The Materials List is based on certain 
assumptions that may not match your 

building style. Home Designer Essentials 
makes no representation as to the accuracy or 
reliability of the Materials List generated by 
Home Designer Essentials. Always compare 
the Materials List with a manual take-off before 
providing a quote or ordering materials for a 
job. 



374

Home Designer Essentials 2012 Reference Manual

The Materials List
A Materials List is like a snapshot of the 
current plan at the time that the list is made. 
Any changes made to the model after a 
Materials List is generated are not included 
in that list. Create a new Materials List if you 
would like it to include these changes. 

It is not necessary to wait until the plan is 
complete to generate a Materials List. In fact, 
you can create a series of Materials Lists 
reflecting costs at various stages of a project.

Select Tools> Materials List> 
Calculate From All Floors to 

generate a Materials List for the entire 
model.

Materials lists can be lengthy, and only a 
portion of the list may display on your screen 
at one time. Use the scroll bars to scroll 
through the complete list. Move the pointer 
to cells in the list and click to make changes. 

A Materials List is like a snapshot of the 
current plan at the time that the list is made. 
Any changes made to the model after a 
Materials List is generated are not included 
in that list. Create a new Materials List if you 
would like it to include these changes.

It is not necessary to wait until the plan is 
complete to generate a Materials List. In fact, 
you can create a series of Materials Lists 
reflecting costs at various stages of a project.

Creating an Accurate Materials List
In order to take full advantage of Home 
Designer Essentials’s Materials List 
capabilities, bear in mind that using generic 
objects like geometric shapes from the 

library to represent objects that aren’t avail-
able in Home Designer Essentials can result 
in items being calculated in the Materials 
List in a manner that you might not expect.

Organizing Materials Lists
You can control what items are calculated in 
the Materials List by specifying which 
categories are used.

There are some parts of a model that cannot 
be excluded from the Materials List. Floor 
and ceiling platforms are prime examples. If 

you need to generate a Materials List for only 
part of a plan, such as an addition, consider 
making a copy of the plan file. In the copy, 
delete the as-built portion of the plan and 
then generate a Materials List.

For comparison, generate Materials Lists 
with and without a proposed plan modifi-

cation.

For comparison, generate Materials Lists 
with and without a proposed plan modifi-

cation.
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Categories
The line items in the Materials List are 
organized into a set of predefined categories, 
such as Electrical and Framing, which 
display in the ID column.

To specify a line item’s category

1. Create a Materials List.

2. Click in the cell in the ID column for a 
line item.

3. Select the desired category from the 
drop-down list that becomes available.

The categories that are available cannot be 
altered; however, you can specify which 
categories are included for individual lists in 
the Materials List Display Options dialog. 

Materials List Display Options Dialog
When a Materials List is open, select 
Tools> Display Options to open the 

Materials List Display Options dialog for 
the currently open list.

Categories

Columns



376

Home Designer Essentials 2012 Reference Manual

Check the box beside the name of each 
category that you want to include in the 
active Materials List. 

These categories appear in the ID column in 
the order they are presented here. 

The Materials List changes automatically to 
reflect any changes you make as soon as the 
OK button is clicked.

Editing Materials Lists
Materials lists can be edited in a variety of 
ways. You can adjust the width of a column 
by clicking and dragging the bar on the right 
side of the column name. 

Adding Information
You can enter information in the Price and 
Comment columns for each item. 

Adding price or other information for any 
item is straightforward. Simply click in the 
cell and type the desired information.

Changing Information
You can change the information in any 
column in an individual Materials List. As 
with added information, click in a cell to 
select the existing text, then type in the 
desired text. 

To move an item in a Materials List to a new 
category, select the cell in the ID column and 
choose a new category from the drop-down 
list that becomes available. See “Categories” 
on page 375.

Note: The information in a suppressed category 
is still part of the Materials List. If the Materials 
List is exported, suppressed categories are 
exported, as well.
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Total Cost
Total Cost is calculated using the Count, 
Unit, Price, %Markup, Labor and Equipment 
columns to calculate the cost. The formula 
used is: 

(Count + Extra) * Price * (1 + (%    
Markup/100)) + ((Count + Extra) * Labor) 
+ ((Count + Extra) * Equipment)

If a column does not appear, 0 is used for the 
value of that column with the exception of 

Count and Price, which are always used in 
the calculation even if they are not shown.

Copying Information
Portions of a Materials List can be copied 

and then pasted into a Text  object or into 
a word processing program or spreadsheet 
program using the standard Windows Copy 
(Ctrl + C), Cut (Ctrl + X), and Paste 
(Ctrl + V) commands. See “Copying & 
Pasting Text” on page 342.

Exporting the Materials List
Any Materials List can be exported 
into a text (.txt) file that can be 

opened directly by most spreadsheet 
programs. In a Materials List window, select 
File> Export Materials List.

The Write Materials Export File dialog will 
open. This is a typical File Save dialog. See 
“Exporting Files” on page 33. 

Estimating Software
You can export a Materials List to a word 
processor or spreadsheet program to arrange 
it in your estimating format. You can also 
export the Materials List to a number of 

commercial estimating programs in whose 
databases you can keep your current pricing 
and generate reports based on this data. 

Before purchasing an estimating software 
program, be sure that the program supports 
the direct import of Home Designer 
Essentials Materials Lists. 

Any questions regarding estimating software 
packages and how they interact with Home 
Designer Essentials should be directed 
toward the company providing the estimating 
software. Home Designer Essentials is 
unable to provide any technical support for 
third party programs.

Conditioned Area Totals
The Materials List calculates the total areas 
of walls, floors, ceilings, doors and windows 
that separate the conditioned space in a plan 
from unconditioned space. This information 
is listed in the General category of the 

Materials List. See “Categories” on page 
375.

Conditioned area totals can be entered into 
third party programs such as REScheck to 
determine whether the plan meets the energy 
code in use in your area. 
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Walls, doors and windows are categorized as 
north, south, east, or west facing for the 
purposes of conditioned area totals.  

If a wall is oriented at 45º or less to north in a 
plan, it will be categorized as a “North” wall. 
Any doors and windows in this wall will also 
be categorized as “North”.

Similarly, south-facing walls, doors and 
windows are categorized as “South” if they 
are oriented at 45º or less of south in the plan.

Walls, doors and windows oriented within 
45º of either east or west will be classified as 
“East” or “West”, respectively.

The orientation of a curved wall is based on 
the direction of its chord.  

Doors are always categorized as doors rather 
than as glass (windows). This is the case 
even when a door is specified as a Glass 
Door or when it is part of a mulled unit.

Home Designer Essentials does not 
check plans for compliance with building 
or energy codes.
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Appendix A

Additional
Resources

Home Designer Essentials offers a variety of 
resources to help you become familiar with 
the many features it offers.

•      Reference Manual

•      User’s Guide
•      Home Designer Web Site
•      Home Talk Online User Forum
•      Technical Support

Reference Manual
The Home Designer Essentials Reference 
Manual is a comprehensive source of 
information for Home Designer Essentials 
2012. Chapters are organized by subject, 
beginning with the fundamental concepts and 
progressing to the more advanced features. 

The Reference Manual is presented in .pdf 
file format and includes a Table of Contents 
and Index. This manual is available online by 
selecting Help> View Reference Manual 

 from the program menu.

User’s Guide
Written for new Home Designer Essentials 
users, but a helpful reference for users of all 
experience levels as well, the User’s Guide 
features a series of tutorials designed to 
introduce the basics of using the program.

The Home Designer Essentials User’s Guide 
is organized by topic and walks you through 

the process of creating a complete model, 
from the first wall to the interior design and 
landscaping.  

This guide is available online by selecting 
Help> View User’s Guide from the program 
menu.



380

Home Designer Essentials 2012 Reference Manual

Online Help Videos
Another resource designed to illustrate Home 
Designer Essentials’s powerful tools is the 
set of tutorial videos available on our web 
site. 

To view the online videos, select Help> 
View Online Help Videos from the program 
menu or visit 
video.homedesigner.chiefarchitect.com/vid-
eos.

Home Designer Web Site
If you have questions that the online Help 
feature ha not answered, feel free to turn to 
the our web site. 

A database of common technical support 
questions and answers related to Home 

Designer Essentials is available through a 
searchable interface. 

Select Help> Visit Home Designer Web 

Site  from the menu to launch your 
default internet browser to 
 www.HomeDesignerSoftware.com.

Home Talk Online User Forum
The Home Talk Bulletin Board offers several 
ongoing discussions about a variety of topics 
related to the use of Home Designer 
Essentials. It's rich with useful tips and 
available free of charge to all registered 
Home Designer Essentials users. 
• Discussions are initiated and carried out 

by users. 

• Experienced users share knowledge with 
each other and beginners. 

• Home Designer Essentials Staff members 
post announcements, advice and techni-
cal information. 

To visit the Home Talk forum, select Help> 
Home Talk or go to:  HomeTalk.HomeDe-
signerSoftware.com.

Technical Support
Chief Architect takes pride in offering world 
class technical support services that can be 
accessed by telephone or on our web site at 
 www.HomeDesignerSoftware.com or by 
selecting Help> Technical Support from the 
program menu.

Before contacting Technical Support, take a 
moment to see if the answer to your question 
is found in the Help resources, tutorial 
videos, or in our on-line Help Database at 
 www.HomeDesignerSoftware.com. 

http://video.homedesigner.chiefarchitect.com/videos
http://video.homedesigner.chiefarchitect.com/videos
http://www.homedesignersoftware.com/
http://hometalk.homedesignersoftware.com/
http://hometalk.homedesignersoftware.com/
http://www.homedesignersoftware.com/support/
http://www.homedesignersoftware.com/
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When you contact us, Technical Support will 
refer you to these resources if the answer can 
be found there.

So that our Technical Support specialists can 
assist you as efficiently as possible, please 

refer to “Technical Support Services” on 
page 383 for additional trouble-shooting 
suggestions and information that will be 
needed before placing your call.

Upgrade to Chief Architect
Chief Architect is a premium, professional 
residential drafting and 3D design program 
that allows builders, architects and other 
professionals in the building and interior 
design trades to produce construction 
documents and high quality 3D renderings of 
their plans. 

Chief Architect can open and edit plans 
created in Home Designer Essentials. In 

addition, Home Designer Essentials can open 
plans created in Chief Architect for viewing, 
as well.

To learn more, select Help> Upgrade to 
Chief Architect. to launch your default web 
browser to www.chiefarchitect.com.

http://www.chiefarchitect.com/
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Appendix B

Technical Support
Services

Chief Architect is committed to providing 
world-class technical support to complement 
our products. 

The primary function of technical support is 
to make sure our software is functioning 

correctly and to help you quickly resolve 
problems that prevent its normal use. Our 
technical support professionals are eager to 
work with you to make certain our software 
is functioning as designed. 

Reference and Training Resources
Chief Architect offers a variety of reference 
options in addition to the resources that come 
standard with the program. 

Help Database
The Home Designer online Help Database 
contains a variety of articles describing how 
to resolve common technical problems and 
achieve specific design goals. 

The Help Database is found in the Technical 
Support section of the Web site and can be 
referred to again and again at your 

convenience at 
 www.HomeDesignerSoftware.com .

Online Help Videos
Chief Architect has developed a collection of 
training videos that contain in-depth training 
on a wide range of topics. These videos are 
available on our Web site,  
 www.HomeDesignerSoftware.com .

User Forum
Our Home Talk User Forum is a great place 
to discuss and exchange ideas with other 

http://www.homedesignersoftware.com/support/database.html
http://video.homedesigner.chiefarchitect.com/videos
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Home Designer Essentials users. Here you 
can post questions, read discussions from 
other users, and post suggestions to improve 
our product. In addition to our regular users, 
from time to time our support and 

engineering teams monitor the forum and 
provide input and discussion on current 
topics. This resource is available free of 
charge at   
HomeTalk.HomeDesignerSoftware.com. 

Troubleshooting Common Technical Issues
Chief Architect strives to make certain our 
software works correctly; however, from 
time to time issues arise that prevent its 
normal operation. 

Installation Issues
The following are common reasons for 
installation failure of Home Designer 
Essentials and other software:
• Anti-virus software is enabled and inter-

fering with installation. Anti-virus soft-
ware is the most common cause of 
installation failures for any type of soft-
ware. Refer to your anti-virus software’s 
documentation for details on how to dis-
able the software and re-enable it once 
installation is complete.

• The recommended minimum system 
requirements are not met. See “System 
Requirements” on page 7.

• The computer has a CD drive but not a  
DVD drive. A standard CD drive will not 
read DVD discs. 

• The DVD has fingerprints, scratches, or 
other defects. Sometimes a small finger-
print can prevent the program from 
installing. Clean the disk with soft cotton 
cloth. Be sure to use soft cotton rather 
than paper products on disks to avoid 
scratching.

• You do not have sufficient rights to install 
the software. Verify that you have admin-
istrative rights and the administrative 
password during the installation process. 
If you are on a corporate network, consult 
your network administrator for assis-
tance.

Refer to the on-line Help Database for 
solutions to common installation problems. 
If the answer to your question is not found 
there, contact our Technical Support 
department for assistance.

Troubleshooting Printing Problems
Printing problems fall into two main 
categories: those that prevent the printer 
from working in any program and problems 

printing from Home Designer Essentials. To 
determine if the problem is specific to Home 
Designer Essentials, try the following:

If you see visible cracking on a CD or
DVD, do not insert it in your CD/DVD

drive. Cracked disks can fly apart and cause
damage to your drive.

http://hometalk.homedesignersoftware.com/
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1. Begin by clicking on the Windows Start 
button, and select Printers. 

2. Right-click the printer that is not func-
tioning properly in the Printers folder. 

3. Click Properties from the menu that 
appears.

4. On the General tab, click the Print Test 
Page button. 

If the printer does not produce a test page, 
the problem is not one that Chief Architect 
Technical Support can solve. Follow these 
suggestions:
• Check the connection between the com-

puter and the printer.
• Check your printer documentation for 

troubleshooting printer problems.
• Contact your printer's manufacturer or 

check their Web site for support informa-
tion. 

Your printer manufacturer is the best 
resource for solving problems of this type. 
Chief Architect Technical Support is not able 
to help diagnose and solve problems that 
prevent printing from any program. 

Printers vary widely in how they function. 
Sometimes a faulty cable can be a problem. 
Often, solving a printing problem is as 
simple as downloading and installing an 
updated printer driver. See “Printer Drivers” 
on page 362.

If you can print from Home Designer 
Essentials but are not satisfied with the 
output, refer to “Printing” on page 361 for 
information on how to set up and use the 
printing functions in the program. Legacy 
users should bear in mind that each release 
has new features and enhancements, so 
techniques that were used in prior versions 
may not work in the current version. 

Make sure that you use Print Preview  
before printing. Print Preview displays the 
printed paper, or drawing sheet, as a white 
rectangle on screen, and shows how the sheet 
is scaled and positioned relative to your 
drawing. If the drawing is not on the drawing 
sheet on-screen, it will not be on the sheet 
when you print. See “Print Preview” on page 
364.

Make sure that your scaling is correct for the 
paper size. If the plan is much smaller or 
much larger than the drawing sheet, you may 
need to change your Scale. See “Printing to 
Scale” on page 365.

64 Bit Versions of Windows
Some printers may not function correctly on 
64 bit Windows operating systems. If you are 
experiencing a printing problem while using 
a 64 bit version of Windows, please contact 
the printer’s manufacturer to verify that you 
have the correct driver installed.

Printing to a legacy parallel printer port on a 
Windows 64 bit machine may not work 
correctly when using a hardware lock. USB 
printers should not be affected. 

It is a good idea to keep the Owner’s
Manual for your printer close at hand.

Write inside the Owner’s Manual the various
phone numbers for technical support for that
printer – for the original manufacturer and for
your local dealer.
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Clearing Printer Information
Some information specific to individual 
printers, such as available printer paper sizes, 
is saved with each plan file. 

If you are encountering problems when 
printing, or unexpected options in the Page 
Setup dialog, select File> Print> Clear 
Printer Info to clear the printer-specific 
information stored with the plan file. 

After using Clear Printer Info, select File> 

Print> Page Setup . Make sure the 

settings in the Page Setup dialog are correct, 

and then click OK and Save  the file.

Help Database
For answers to frequently asked questions 
regarding printing and other topics, select 
Help> Visit Home Designer Essentials 

Web Site  and browse the Technical 
Support section of our Web site, 
 www.HomeDesignerSoftware.com. Our 
Technical Support specialists post new 
articles periodically to help resolve problems 
you may encounter. 

Error Messages
Most common error messages have a known 
cause and simple resolution. When you 
encounter an error or warning message in 
Home Designer Essentials, you can click the 
Check Help Database button in the message 
box to launch your default internet browser 
to the Home Designer Help Database on our 
Web site,
 www.HomeDesignerSoftware.com. If an 
article discussing the message is available it 
will display, providing information about the 
message and how best to avoid it. 

It is important that abnormal errors be 
reported to Chief Architect Technical 
Support so that we can identify and resolve 
any problems. 

The content of an error message is useful in 
diagnosing its cause. If you encounter an 
error message, read it carefully and write 
down the error number and the exact text of 
the error message. 

If you encounter the error more than once, 
make a note of your steps prior to receiving 
the message.

Before you report an error, check the Help 
Database to see if the error is already 
documented by typing the error message or 
part of the error message into the search 
form. 

Finally, check to see if there are program 
updates available. These updates are 
provided free for the current version of 
Home Designer Essentials and contain 
enhancements and other changes that allow 
the program to perform at an optimum level. 
Select Help> Download Program Updates 

Press the Print Screen key on your key-
board to capture a picture of the error

message. Open a new word processing doc-
ument or e-mail message and choose Edit>
Paste to paste a copy of the error message
into the document for later reference.

http://www.homedesignersoftware.com/support/
http://www.homedesignersoftware.com/support/database.html
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from the Home Designer Essentials menu to 
visit our Web site,
 www.HomeDesignerSoftware.com, and 
follow the instructions.

Error Reporting
When and error occurs, you may have the 
option in the message box to send the report 
to Chief Architect. 

No personal information is sent. When you 
click Send, your default internet browser 
launches and a Web page appears on screen 
This message confirms that the report was 
sent successfully and may give you further 
instructions on how to proceed.

Contacting Technical Support
Before contacting Technical Support, take a 
moment to see if the answer to your question 
is found in the Reference Manual, Help 
index, or in our on-line Help Database. When 
you contact us, Technical Support will refer 
you to these resources if the answer can be 
found there.

Chief Architect's world-class technical 
support is available Monday through Friday 
from 6 AM to 5 PM Pacific Standard Time 
and can be reached at (208) 292-3375 or via 
our Web site, 
 www.HomeDesignerSoftware.com.

There are several things you can do to ensure 
a speedy answer to your question when you 
contact Technical Support.
• Before contacting Technical Support, 

select Help> About Home Designer 
Essentials and make a note of the first 
characters of your Product Key and the 
exact version of Home Designer 
Essentials you are using. Technical sup-
port is available to the owners of software 
licenses. When you contact Technical 
Support, be prepared to verify that you 
are the owner of the software license.

• Before contacting Technical Support, 
check to see if there are program updates 
available for download. Our engineering 
team periodically creates updates to the 
program to resolve functionality or pro-
gram issues that were unknown at the 
time of release. These updates are pro-
vided free of charge for the current 
released version and can be accessed by 
selecting Help> Download Program 
Updates from the menu. 

• When you first encounter a problem or 
error message, copy the exact wording of 
the message or a detailed description of 
the problem. This helps us isolate the 
problem and provide you with a solution 
as quickly as possible. 

• When placing a call to Technical Support, 
be at the computer or work station that is 
experiencing the problem and have Home 
Designer Essentials running. If you do 
not have access to the problem computer 
at the time of the call, the technician may 
be unable to reproduce the issue and/or 
suggest a remedy that can be imple-
mented and verified immediately.

http://www.homedesignersoftware.com/support/updates.html
http://www.homedesignersoftware.com/
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• Be prepared to reproduce the problem 
when you contact us. If the problem can-
not be reproduced, there is a reduced 
chance that we will be able to resolve the 
problem on your first phone call.

Online Information
Home Designer Essentials has a variety of 
support resources available on our Web site. 
These include our Technical Support Help 
Database, the How do I…? Solution 
Finder, downloadable program updates, and 
ways to contact our Technical Support 
department. To access these resources, visit:  
www.HomeDesignerSoftware.com .

Our support team is happy to assist you in 
finding the best resource to answer your 
questions, and can resolve most issues in just 
a few minutes. In order to allow us to quickly 
answer your calls, we ask that you limit 
yourself to one question per support call. 

Online Support
Questions can be answered online by the 
Technical Support department. To submit a 
technical inquiry online, visit the Technical 
Support section of our Web site and use the   
Online Support Center . 

This route ensures that your question is 
delivered to the first available support 
professional. Requesting assistance of an 
individual specialist is not recommended, 
since that person may not be available to 
answer your question in a timely manner.

Telephone Support
Our Technical Support team is committed to 
answering your questions as quickly as 
possible and in the order received. Your call 
is important to us; however, there are times 
when we get more calls than expected and 
you may have to wait a few minutes before 
speaking to a technician. 

http://www.homedesignersoftware.com/
http://support.homedesignersoftware.com/
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Balusters ........................................... 105
Definition .......................................... 187
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Break Lines ....................................... 119
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Ceilings
Cathedral........................................... 119
Lowered ............................................ 118
Over this room ................................... 123
Special .............................................. 118
Tray .................................................. 119

Center
Doors ................................................ 132
Object edit tool.................................... 79
Sheet ................................................ 364

Change
Door Swings ...................................... 132
Floor/Reference ......................... 165–166
Line to arc ......................................... 191

Chimneys............................................ 263
Click Stairs ......................................... 186
Close

Plans and Views ................................. 40
Program ............................................. 40
Views ................................................ 298

Color
Off/On ................................................ 76

Color Chooser .............................50, 290
Dialog................................................ 290
Eyedropper ........................................ 290

Compatibility
with other programs ............................ 30

Connect
Electrical ........................................... 209
Walls .................................................. 93

Contextual Menus
In Render views ................................. 307

Copy
Folders and Library Objects ................ 273
Region as Picture............................... 359

Copy/Paste
Main Edit Mode ................................... 56
Sticky Mode ........................................ 56

Corner
Boards .............................................. 216
Windows............................................ 146

Corner Board

Specification Dialog ........................... 216
Create

New Plan Dialog.................................. 31
Cross Section Slider ........................ 311
Cross Section/Elevations ................ 302

Create .............................................. 304
Crosshairs

Mouse ................................................ 78
Synchronize with Cursor .................... 301
Toggle On/Off ..................................... 78

Current
Floor ................................................. 164
Floor, Delete ............................. 162–163

Curved
Deck Edge .......................................... 88
Deck Railing........................................ 88
Stairs ................................................ 186
Walls, Draw ........................................ 93

D
Deck

Designer ............................................. 88
Edges ................................................. 88
Railing ................................................ 88

Decks ........................................... 88, 116
Default

Lights ............................................... 319
Default Sun Light

Specification Dialog ........................... 320
Defaults

Cabinet ............................................. 221
Dimension......................................... 323
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Material ............................................ 287
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Fixtures
Lights ............................................... 208
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Opening .............................................. 35
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Select

Components of Blocked Units ............ 147
Library Object Dialog ......................... 276
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Similar Objects .................................... 60
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Raise for railing ................................. 105

Shortcut Keys ............................... 22, 46
Shutters ............................................. 157
Sidewalk ............................................ 252
Skylights .................................... 176, 179
Sliding Doors .................................... 128
Snap Behaviors................................... 52

Angle Snaps ....................................... 53
Extension Snaps ................................. 53
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Undo Zoom ....................................... 292
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