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Roof Tutorial

The majority of Roof Tutorial describes some common roof styles that can be created using settings in the Wall 
Specification dialog and can be completed independent of the other tutorials. It also explains how to add 
gables over doors and windows, how to create dormers automatically and manually, and how to create 
skylights. 

The Adding a Roof to the Stucco Beach House section continues where the House Design Tutorial left off and 
explains how to add a roof to that plan.

For more information about Roof Tools, see “Roofs” on page 289 of the Reference Manual.

In this tutorial you’ll learn about:
•      Getting Started with Automatic Roof Styles
•      Hip Roofs
•      Gable Roofs
•      Dutch Gable Roofs
•      Shed Roofs
•      Offset Gable Roofs
•      Gambrel Roofs
•      Gull Wing Roofs
•      Half Hip Roofs
•      Mansard Roofs

•      Roof Style Quick Reference
•      Roof Returns
•      Adding Gables over Doors and Windows
•      Automatic Dormers
•      Manually Drawn Dormers
•      Skylights
•      Using the Break Edit Tool to Modify Roofs
•      Adding a Roof to the Stucco Beach House
•      Troubleshooting Roof Issues

Getting Started with Automatic Roof Styles
This tutorial uses a simple, rectangular structure to explain how to create common roof styles using roof style 
directives assigned to the exterior walls.

To begin a new plan
1. If any plans are open, select File> Close All from the menu.

2. Select File> New Plan  to open a new plan. In the Create New Plan dialog, select the Default Style 
template. 



2

Home Designer Architectural 2021 Tutorial Guide

3. Select Build> Wall> Straight Exterior Wall  and draw a rectangular floor plan, measuring about 34 
feet by 24 feet (approximately 10.4 m by 7.3 m), in a clockwise direction. See “Creating Walls” on page 
128 of the Reference Manual.

4. Select 3D> Create Camera View> Perspective Full Overview  to create a 3D overview of the house. 

• If you wish, you can select 3D> Toggle Textures  from the menu to turn off the display of material 
textures and represent all materials using solid colors.

5. Select Window> Tile Vertically  to see both views at the same time.

Roof Style Directives in Walls
By default, the program will generate a roof plane bearing on each exterior wall that does not have a room-
defining wall directly above it, and will use the pitch specified in the Build Roof dialog. The result is a hip style 
roof; however, if you need a different condition over a particular wall to produce another roof style, you can 
define it in that wall’s specification dialog.

Individual walls can be selected and edited in both 2D and 3D views. When multiple walls are to be edited, 
however, it is usually quicker and easier to work in plan view. See “Editing Walls” on page 133 of the 
Reference Manual.

To set a wall’s roof directives

1. Click the Select Objects  button, then click on a wall to select it.
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2. Click the Open Object  button to open the Wall Specification dialog.
3. On the ROOF panel:

• The Roof Options control how the roof builds over the selected wall.
• The Pitch Options control how steep the roof that bears on the selected wall is.

To reset all roof directives
1. Select Edit> Reset to Defaults.
2. In the Reset to Defaults dialog, set the Reset Scope to All Floors, check Roof Directives in Walls, and 

click OK.

Attic Walls
When a roof is generated, attic walls may also be generated. An Attic wall fills the space between the walls that 
define a room and the roof above. The triangular-shaped wall of a gable, for example, is created using an Attic 
wall.

If you do not want to see attic walls in plan view, you can turn off their display.

To turn off the display of attic walls

1. In plan view, select Tools> Display Options  (or press the ~ key) to open the Display Options dialog. 
2. Find "Walls, Attic" in the Name column, remove the check from the Display column for this item, and 

click OK. For more information, see “Display Options Dialog” on page 81 of the Reference Manual.

Deleting Roofs
Roof planes can be easily deleted in either of two ways:

• Select Build> Roof> Delete Roof .

• Select Edit> Delete Objects  and in the Delete Objects dialog, select either All Rooms On This Floor 
or All Floors; place a check beside Roof; and click OK to delete all roof planes either on the current floor 
or in the plan.

If a warning message states that roofs cannot be deleted while Auto Rebuild Roof is on, click the Yes button to 
turn off Auto Rebuild Roof and delete the roof.

Auto Rebuild Roofs
Auto Rebuild Roofs is a convenient feature in Home Designer Architectural that automatically rebuilds the 
roof in a plan whenever the exterior walls or floor/ceiling heights are changed. Auto Rebuild Roofs is turned on 
by default, but this tutorial is presented with this feature disabled; however the information presented here also 
applies when it is enabled.

To turn on/off Auto Rebuild Roofs

1. Select Build> Roof> Build Roof  from the menu.
2. In the Build Roof dialog, check or uncheck Auto Rebuild Roofs and click OK.

Hip Roofs
When roofs are automatically generated, a roof plane is built over every exterior wall in the plan that does not 
have another wall drawn above it. The result is referred to as a hip roof.
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To create a hip roof
1. Begin with the basic rectangular structure described in “Getting Started with Automatic Roof Styles” on 

page 1.

2. Select Build> Roof> Build Roof  from the menu to open the Build Roof dialog.
3. Click OK to generate a hip roof.

Gable Roofs
If you would like a gable over a particular wall rather than a roof plane bearing on it, you can specify it as a 
Full Gable Wall in the Wall Specification dialog. To create basic gable roof, two walls should be specified as 
Full Gable Wall.

To create a gable roof
1. Begin with the basic rectangular structure described in “Getting Started with Automatic Roof Styles” on 

page 1.

2. Use the Select Objects  tool to select one of the walls drawn vertically on screen. 
3. Open the Wall Specification dialog and on the ROOF panel, check Full Gable Wall and click OK. See “To 

set a wall’s roof directives” on page 2.

• Alternatively, you can click the Change to Gable Wall(s)  edit button.

• To remove the Full Gable Wall attribute from a selected wall, click the Change to Hip Wall(s)  
edit button.

4. Make the same changes to the other vertically-drawn wall. 

5. Select Build> Roof> Build Roof  to open the Build Roof dialog and click OK.
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Dutch Gable Roofs
A Dutch gable, sometimes called a Dutch hip, is a combination of hip and gable roof styles in which a gable is 
located at the end of the ridge, at the top of a hip roof plane.

To create a Dutch gable roof
1. Begin with the basic rectangular structure described in “To begin a new plan” on page 1.

2. Use the Select Objects  tool to select one of the walls drawn vertically on screen. 
3. Open the Wall Specification dialog and on the ROOF panel, change the following settings: 

• Check the box beside Dutch Gable Roof.
• Specify the Starts at Height as 180".

4. Click OK to close the Wall Specification dialog. See “To set a wall’s roof directives” on page 2.
5. Make the same changes to the other vertically-drawn wall. 

6. Select Build> Roof> Build Roof  to open the Build Roof dialog and click OK.

Shed Roofs
To create a single, sloping roof plane, or shed roof, two walls must be specified as Full Gable Walls, and one 
must be a High Shed/Gable Wall.



6

Home Designer Architectural 2021 Tutorial Guide

To create a shed roof
1. Begin with the basic rectangular structure described in “Getting Started with Automatic Roof Styles” on 

page 1.
2. As in the Gable Roofs example, specify the left and right vertical walls as Full Gable Walls.
3. Select the lower horizontal wall and open its Wall Specification dialog. On the ROOF panel, check High 

Shed/Gable Wall and click OK. See “To set a wall’s roof directives” on page 2.

4. Select Build> Roof> Build Roof  to open the Build Roof dialog, specify a Pitch of 2 in 12, and click 
OK.

Offset Gable Roofs
An offset gable is a type of gable roof with different pitches on each of the two roof planes and a ridge that is 
offset from the building’s center line. Assign a different pitch to the two roof planes in the Wall Specification 
dialog for the wall supporting each one.

To create an offset gable roof
1. Begin with the basic rectangular structure described in “To begin a new plan” on page 1.
2. As in the Gable Roofs example, specify the left and right vertical walls as Full Gable Walls.
3. Select the lower horizontal wall and open its Wall Specification dialog. On the ROOF panel, leave the 

Roof Options unchecked and change the Pitch to 12 in 12. See “To set a wall’s roof directives” on page 2.

4. Select Build> Roof> Build Roof  to open the Build Roof dialog, specify the Pitch as 2 in 12, and click 
OK.
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Gambrel Roofs
A gambrel or barn style roof has two pitches on each side of the ridge. The first (lower) pitch on either side is 
steeper than the pitch near the ridge.

To create a gambrel roof
1. Begin with the basic rectangular structure described in “Getting Started with Automatic Roof Styles” on 

page 1.
2. As in the Gable Roofs example, specify the left and right vertical walls as Full Gable Walls.

3. Use the Select Objects  tool to select one of the walls drawn horizontally on screen.
4. Open the Wall Specification dialog and on the ROOF panel, change the following settings: 

• Make sure that the Pitch value is followed by (D), which means that is set to use the default. 
• Check the box beside Upper Pitch.
• Specify the Upper Pitch as 6 in 12 and the Start Height as 156".

5. Click OK to close the Wall Specification dialog. See “To set a wall’s roof directives” on page 2.
6. Make the same changes to the other horizontally-drawn wall. 
7. Open the Build Roof dialog, specify the Pitch as 12 in 12, and click OK.

Experiment with alternate pitches and overhangs. Also, try varying the height at which the second pitch begins 
so that you can see the effect it has on the gambrel roof design.

Gull Wing Roofs
A gull wing roof has two pitches on either side of the ridge, as a gambrel does; but the first pitch of a gull wing 
is shallower than the steeper upper pitch.

To create a gull wing roof
1. Begin with the basic rectangular structure described in “Getting Started with Automatic Roof Styles” on 

page 1.
2. As in the Gable Roofs example, specify the left and right vertical walls as Full Gable Walls.

3. Use the Select Objects  tool to select one of the walls drawn horizontally on screen. 
4. Open the Wall Specification dialog and on the ROOF panel, and change the following settings:

• Make sure that the Pitch value is followed by (D), which means that is set to use the default. 
• Place a check in the box beside Upper Pitch.
• Keep the Upper Pitch as 12 in 12 and change the Start Height to 125".
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5. Click OK to close the dialog. See “To set a wall’s roof directives” on page 2.
6. Make the same changes to the other horizontally-drawn wall. 

7. Click the Build Roof  tool, specify a Pitch of 3 in 12, and click OK in the Build Roof dialog.

Experiment with the height at which the second pitch begins so that you can see the effect it has on the gull 
wing roof design.

Half Hip Roofs
A half hip roof has two gable ends. At the top of each gable is a small hip that extends to the ridge.

To create a half hip roof
1. Begin with the basic rectangular structure described in “Getting Started with Automatic Roof Styles” on 

page 1.
2. As in the Gable Roofs example, specify the left and right vertical walls as Full Gable Walls. In addition, 

change the following Pitch Option settings: 
• Check the box beside Upper Pitch.
• Specify the Upper Pitch as 3 in 12 and set the Start Height at 170". 

3. Click the Build Roof  tool and click OK in the Build Roof dialog.
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Mansard Roofs
A mansard roof is a hip roof with two pitches on the roof sections above each exterior walls: an extremely steep 
lower pitch and a gently sloping upper pitch. 

To create a mansard roof
1. Begin with the basic rectangular structure described in “Getting Started with Automatic Roof Styles” on 

page 1.

2. Use the Select Objects  tool to select one of the walls. 
3. Open the Wall Specification dialog and on the ROOF panel, and change the following settings:

• Check the box beside Upper Pitch.
• Specify the Upper Pitch as 1.5 in 12 and the Start Height as 132". 

4. Click OK to close the dialog. See “To set a wall’s roof directives” on page 2.
5. Make the same changes to each of the exterior walls. 

6. Click the Build Roof  tool, specify a Pitch of 24 in 12, and click OK in the Build Roof dialog.
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Roof Style Quick Reference
The following chart provides a quick reference for building the roof styles described in this tutorial. The chart 
shows which walls to change and what to change on the ROOF panel of the Wall Specification dialog for each 
wall. These parameters are based on a 34x24-foot model. For different size plans, adjust these numbers.

Roof Returns
A roof return is a small decorative roof plane that connects to the low side of a gable roof overhang and extends 
below the upper triangular portion of the gable wall. While you can build these manually, the following 
pictures illustrate the three styles of roof returns that can be produced automatically in Home Designer 
Architectural.

Roof 
Type Wall to Change

Set as 
Full 

Gable

Set as 
High 
Shed 
Gable

Lower 
Pitch

Upper 
Pitch

Start 
Height

Gable
Roof

Vertical Wall 1
Vertical Wall 2
Horizontal Wall 1 X
Horizontal Wall 2 X

Shed
Roof

Vertical Wall 1 X
Vertical Wall 2 X
Horizontal Wall 1 X
Horizontal Wall 2

Offset
Gable
Roof

Vertical Wall 1 X
Vertical Wall 2 X
Horizontal Wall 1 12 in 12
Horizontal Wall 2 3 in 12

Gambrel
Roof

Vertical Wall 1 X
Vertical Wall 2 X
Horizontal Wall 1 12 in 12 6 in 12 156
Horizontal Wall 2 12 in 12 6 in 12 156

Gull Wing
Roof

Vertical Wall 1 X
Vertical Wall 2 X
Horizontal Wall 1 3 in 12 12 in 12 125
Horizontal Wall 2 3 in 12 12 in 12 125

Half Hip
Roof

Vertical Wall 1 X 3 in 12 170
Vertical Wall 2 X 3 in 12 170
Horizontal Wall 1 6 in 12
Horizontal Wall 2 6 in 12

Mansard
Roof

Vertical Wall 1 12 in 12 1.5 in 12 132
Vertical Wall 2 12 in 12 1.5 in 12 132
Horizontal Wall 1 12 in 12 1.5 in 12 132
Horizontal Wall 2 12 in 12 1.5 in 12 132
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The first two are called Gable and Hip returns, since the returns themselves end in either a gable or a hip. The 
third is called a Full return because it extends under the entire gable, connecting both sides. Full roof returns 
are sometimes referred to as water tables. 

The Auto Roof Return settings are found on the ROOF panel of the Wall Specification dialog. Roof returns can 
be specified for any wall, but they will only generate on Full Gable Walls. 

Specify the horizontal Length of the returns in inches; the distance to Extend the returns past the main roof 
overhang; the style of roof return; and whether the returns are sloping or flat. As long as your model has a roof, 
the specified roof returns will be generated when you click OK. For more information, see “Roof Returns” on 
page 300 of the Reference Manual.

Adding Gables over Doors and Windows
You can add a gable roof over a door or window.

To create a gable roof over a door or window

1. Select a door or window, then click the Gable Over Door/Window  edit button.

2. Click the Build Roof  tool and click OK in the Build Roof dialog.
3. A gable is created with an overhang of one foot on each side of the door or window.

To remove a gable roof over a door or window

1. Select the door or window and click the Delete Gable Over Opening  edit button.

2. Click the Build Roof  tool and click OK in the Build Roof dialog.
3. When you rebuild the roof, the gable will be removed.

To create a gable over several doors and/or windows
1. Select a door, window, or mulled unit.
2. Hold down the Shift key and click on additional doors and/or windows to add them to your selection set.

3. Click the Gable Over Door/Window  edit button.

4. Click the Build Roof  tool and click OK in the Build Roof dialog to create a gable over the selected 
wall openings.

Gable Return Hip Return Full Return
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Automatic Dormers
The Dormer  tool offers a quick and convenient alternative to drawing dormers manually. With just a few 
clicks an entire dormer is placed, complete with roof, roof hole, walls, and window. 

There is a limit to how low the roof pitch can be set when creating dormers. Generally, 9 in 12 is the lowest 
pitch that will provide enough elevation to contain a dormer. 

A Dormer  can be placed anywhere within a roof plane, as long as there is enough space to contain it. 

Select Build> Roof> Dormer  and click within an existing roof plane to place a floating dormer at that 
location. Once a dormer is created, it can be moved, resized and opened for specification. For more 
information, see “Editing Auto Dormers” on page 298 of the Reference Manual.

Manually Drawn Dormers
To create dormers in an upper floor, create a new floor for your plan and modify this floor with knee walls and 
windows to form gables. This example starts with a new 40 x 30 foot plan.

As with automatic dormers, roof pitches of 9 in 12 or greater generally work better than shallow pitches when 
creating dormers because they provide enough vertical space to build the dormer within.

To create a new plan
1. Select File> Close All from the menu to close any open plans.

2. Select File> New Plan  to open a new plan. In the Create New Plan dialog, select the Default Style 
template. 

3. Select File> Save  from the menu, save the file to an easy to find location, such as Documents, and give 
the plan a short, descriptive name like Dormer Tutorial.

4. Select Build> Wall> Straight Exterior Wall  and draw a rectangular floor plan, 40 feet by 30 feet, in 
a clockwise direction.

5. Click the Fill Window Building Only  button to zoom in on the house.

A Dormer cannot initially be placed so that its walls align with an exterior wall. Once
it is created, its front wall can often be aligned with an exterior wall below; however,

its side walls must remain inside the exterior walls.
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6. As in the Gable Roofs example, specify the left and right vertical walls as Full Gable Walls. See “To set a 
wall’s roof directives” on page 2.

7. Select Build> Floor> Build New Floor .
8. Choose the Derive new 2nd floor plan from 1st floor plan option in the New Floor dialog and click OK. 

In the Floor 2 Defaults dialog, which opens next, click OK without making any changes.

9. Select Build> Roof> Build Roof  to open the Build Roof dialog. On the ROOF panel, change the Pitch 
to 12 in 12, and click OK.

To create two knee walls

A knee wall is a short wall on an upper floor that is cut off by a roof plane rather than building up to full ceiling 
height. They are often used to separate loft areas from attic space.

1. Select Build> Wall> Straight Interior Wall   and draw a horizontal interior wall from left to right. 
Position this knee wall so that it is 5 feet from the top exterior wall.

2. Draw another horizontal interior wall and position it 5 feet from the bottom exterior wall. You can 
reposition the knee walls using dimensions. For more information, see “Moving Objects Using 
Dimensions” on page 176 of the Reference Manual.

You can create a custom wall type for the knee walls, such as a wall with only a
framing layer and one sheetrock layer. See “Wall Type Definitions Dialog” on page

139 of the Reference Manual.
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3. Select each of the interior walls one at a time and click the Open Object  edit button. Check the box 
beside Knee Wall on the ROOF panel of the Wall Specification dialog and click OK.

4. Select CAD> Dimensions> Automatic Exterior Dimensions  to create exterior dimension lines for 
your plan, which should now look like this:

To draw the dormer walls and windows

1. Select Build> Wall> Straight Exterior Wall  and draw two rectangular boxes on the outside of the 
lower knee wall, as shown in the following image.

2. Position the front walls of each dormer box 2 feet from the bottom exterior wall. The front dormer walls 
are those parallel to the bottom wall.

3. Use dimension lines to position the dormer side walls so that the dormers are 6 feet from each vertical 
exterior walls wall and 8 feet wide.

4. Click on the lower knee wall to select it, then: 

• Click the Break  edit button.

• Click the Sticky Mode  edit button.
• Click on the lower knee wall at the point where it intersects each of the dormer side walls to divide the 

wall into separate segments at those points. 

5. Click the Select Objects  button, then select and delete the segments of the knee wall located behind 
the dormers, as in the following image:

6. Select Build> Window> Window  and click on each dormer front wall to place a window. 
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• When Object Snaps are enabled, a "sticky point" will exist at the midpoint of the dormer front wall 
when you move your mouse along the front wall. For more information, see “Object Snaps” on page 
74 of the Reference Manual. 

• You can also use the Center Object  edit button to center each window along the wall after it has 
been placed. See “Using Center Object” on page 103 of the Reference Manual.

To build the roof
1. Select the two dormer front walls with windows and open their Wall Specification dialog. On the ROOF 

panel, check Full Gable Wall and click OK.
2. Select the four dormer side walls and open their Wall Specification dialog. On the ROOF panel, confirm 

that Pitch is 12 in 12, and click OK.
• Earlier, a pitch of 12 in 12 was specified in the Build Roof dialog: that pitch will be in use here by 

default and will work well for these dormers.

1. Click the Select Objects  button, then click in the narrow room between the top knee wall and the top 
exterior wall to select it.

2. Click the Open Object  edit button to open the Room Specification dialog. On the GENERAL panel, 
select "Attic" as the Room Type and click OK.

3. Do the same for the lower attic room.

4. Select Build> Roof> Build Roof  from the menu.
5. In the Build Roof dialog, click OK to rebuild the roof.

6. Select 3D> Create Camera View> Perspective Full Overview  to create a 3D overview of the house 
and see the results.
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7. Notice that there are small gaps in the dormer side walls. This gap is caused by the difference between the 
position of the knee walls and the point at which the ceiling intersects the roof plane. This location is 
marked by the black dotted Ceiling Break Line in plan view.

8. Select each of the knee walls and move them back so that they are in alignment with the ceiling plane. 
When Object Snaps are enabled, the walls will snap into position when they are close to the Ceiling Break 
Lines.

9. Create a 3D view to see how the roof and dormers look now.
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You can move the interior walls closer to or further from the outside walls to change the dormers’ elevation, or 
change the pitch for the roof to make the dormers longer. You can create dormers in more complex plans the 
same way, but you may want to experiment with wall placement and pitch to achieve the desired effect.

Skylights
Skylights can easily be added using the Skylight  tool. In plan view, select Build> Roof> Skylight  then 
click and drag a rectangular shape within an existing roof plane. When you release the mouse button, a skylight 
is created and can be repositioned and resized using its edit handles. For more information, see “Skylights” on 
page 295 of the Reference Manual.

Using the Break Edit Tool to Modify Roofs
Many homes have more than one roof type built above a single exterior wall. One common example is a 
reverse gable roof, created when a house has gable walls that are perpendicular to one another, as in an L-
shaped home. 

We can create a reverse gable roof on an L-shaped home using the Break  edit tool.

To create an L-shaped home
1. Select File> Close All from the menu.
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2. Select File> New Plan  to open a new plan. In the Create New Plan dialog, select the Default Style 
template. 

3. Draw an L-shaped house with the following dimensions:
• Left wall - 30 feet long
• Upper wall - 45 feet long.
• Right wall 18 feet long.
• Lower wall extending left from the right wall - 25 feet long.
• Vertical wall connecting two lower walls - 12 feet long.
• Lower wall extending right from the left wall - 20 feet long.

4.  If desired, turn off Auto Rebuild Roof and delete the roof.

To create a reverse gable in this plan, three gable walls are required: two running vertically and one 
horizontally.

To add a gable roof to the plan
1. Check Full Gable Wall on the ROOF panel of the Wall Specification dialog for these three walls:

• The far left vertical wall
• The far right vertical wall
• The bottom left horizontal wall

2. Click the Build Roof  button to open the Build Roof dialog and click OK to build the roof. The roof 
will look like this:

The gable wall on the left produces roof planes that extend too high and interfere with the roof over the front 
extension of the house. To avoid this, use the Break edit tool to divide the left wall into two different sections. 
The upper section can then be specified as a Full Gable without affecting the lower section. 
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To use the Break edit tool

1. Select the vertical wall on the left side of the building, then click the Break  edit button and click on 
this wall at a point even with the lower right wall. 

• An easy way to do this is to temporarily stretch the lower right wall across to the left wall; 
• Place a wall break where the walls meet;
• Then return the lower right wall to its correct position.

2. Open the lower portion of the wall for specification and on the ROOF panel of the Wall Specification 
dialog, clear the Full Gable Wall checkbox and click OK. 

3. Click the Build Roof  button and click OK to build a roof based on the new wall specifications.

You now have two full gable roof sections meeting to form your L-shaped roof. Your plan should look like the 
following image:

Notice the step in the ridge line. This can be corrected by resizing the lower gable wall. Select the vertical wall 
to the right of the bottom gable wall and move it to the left 2 feet, reducing the length of the gable wall from 20 
to 18 feet. When you are finished, rebuild the roof.
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This completes this Roof Tutorial. You can use any combination of the techniques described here to create a 
wide variety of roof designs.

Adding a Roof to the Stucco Beach House
With a basic understanding of how automatically generated roofs work, you can return to the Stucco Beach 

House plan and add a roof. Select File> Save As  and give this plan a new name, such as "Beach House 
Roof Tutorial" before continuing.

Individual walls can be selected and edited in both 2D and 3D views; however, when multiple walls must be 
edited, it is usually quicker and easier to work in plan view. See “Editing Walls” on page 133 of the Reference 
Manual.

To edit the default roof
1. Close any 3D views that you may have open and work in plan view.

2. Starting on Floor 1, use the Select Objects  tool to select the top horizontal exterior Kitchen wall:

3. Click the Open Object  edit button and specify this wall as a Full Gable Wall. See “Gable Roofs” on 
page 4.

4. Click Up One Floor  to go to the second floor.

5. Using the Select Objects  tool, select the Balcony room, then click the Open Object  edit button. 
On the STRUCTURE panel of the Room Specification dialog, uncheck Roof Over This Room, then click 
OK.
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6. Assign the Full Gable Wall and Extend Slope Downward settings to the exterior walls, as shown in the 
following image. See “To set a wall’s roof directives” on page 2.

7. Once these roof directives have been assigned, the roof can be generated.

To turn on automatic roof generation

1. Select Build> Roof> Build Roof  to open the Build Roof dialog.
2. On the ROOF panel, check Auto Rebuild Roofs. See “Build Roof Dialog” on page 291 of the Reference 

Manual for more information.
3. Set the Pitch to 3 in 12.
4. You can go to the MATERIALS panel to change the material of your roof. Here, an Earth Roof Tile material.
5. Click OK to close the dialog and generate a roof.

The additional walls that are created are attic walls. See “Attic Walls” on page 3.

6. Select 3D> Create Camera View> Perspective Full Overview  to create an exterior view of your 
plan.

7. Remember to Save  your plan as you work.

Full Gable Wall

Full Gable 
Wall

Full Gable Wall

Full 
Gable 
Wall

Extend 
Slope 
Downward

Extend 
Slope 
Downward

Full Gable 
Wall

Full Gable 
Wall
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When you are ready, you can continue working on this plan in the Interior Design Tutorial.

Troubleshooting Roof Issues
Creating a roof can require experimentation and practice. Here are some suggestions for troubleshooting a 
problematic roof design.

Roof Directives in Walls
As discussed in this chapter and in the Roofs chapter of the Home Designer Architectural 2021 Reference 
Manual, the program will automatically generate a roof plane bearing over each exterior wall in a plan to 
produce a hip roof. If you require a different condition over a particular wall, such as a triangular gable or side 
wall of a shed roof, you can specify that condition on the ROOF panel of the Wall Specification dialog. See 
“Roof Panel” on page 142 of the Reference Manual. 

Specifying roof directives that do not reflect what you require directly above a selected wall, however, can 
often result in drastic and unwanted changes to your roof. For example, when two parallel walls are specified 
as Full Gable Walls, a single ridge will be created between them.

If a wall that is perpendicular to these walls is also specified as a Full Gable Wall, the roof becomes more 
complex with an additional ridge, two valleys, and two hips. 

If you are seeing hips or valleys in your roof where you do not expect them, revisit the ROOF panel of the walls 
supporting the affected roof planes.

To review how to restore wall directives back to their default state, see “To reset all roof directives” on page 3.

Roof Heights
The heights of all roof planes are based on the heights of the walls that they bear on. Wall heights, in turn, are 
determined by the ceiling heights of the rooms that they define. See “Floor and Ceiling Heights” on page 159 
of the Reference Manual.
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For example, the hip roof over a simple rectangular structure with a consistent ceiling heights (in this case, 109 
1/8") has four roof planes.

This roof will become considerably more complex if one room inside is given a lowered ceiling height (in this 
case, 97 1/8").

If you generate a roof and it seems to be more complicated and has more roof planes than it should, take a look 
at the ceiling heights of the rooms in the plan. Often, the correct way to create a lowered ceiling condition will 
be to set the ceiling at the default height create a lowered Ceiling Finish. See “Lowered Ceilings” on page 160 
of the Reference Manual. 

Controlling Roof Ridges
A single roof ridge will generate for as long as the bearing walls that support the roofs on either side of the 
ridge are the same distance apart. When alcoves or bump outs are introduced along either bearing wall, the 
ridge is likely to become broken.

For example, a simple rectangular structure with Full Gable Walls at each end generates a roof with a ridge that 
runs from Full Gable Wall to Full Gable Wall.
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If a bump out is added that affects the length of either Full Gable Wall, or if an alcove is added anywhere along 
the length of the structure, the ridge will no longer follow a straight line. 

There are a number of ways to maintain a single ridge line in the presence of alcoves or bump outs:

• Use the Break  edit tool to control the length of a Full Gable Wall section. See “Using the Break Edit 
Tool to Modify Roofs” on page 17. 

• Increase the Minimum Alcove Size to specify what size alcoves are roofed. See “Roof Panel” on page 291 
of the Reference Manual.

• Use the Extend Slope Downward roof directive to allow the roof over a bump out to extend lower then the 
ceiling height in that area. See “Roof Directives in Walls” on page 137 of the Reference Manual. 



Troubleshooting Roof Issues

 25

• Specify the area inside of an alcove as an "Open Below" room with a roof but no ceiling, and Use Soffit 
Surface for Ceiling specified. See “Room Types” on page 153 and “Structure Panel” on page 164 of the 
Reference Manual. 
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